AT32F413 Firmwary Library: Introduction

AT32F413 Firmwary Library 2.1.0
AT32F413 Peripherals Driver Library
Introduction

The AT32F413 Firmware Library is a firmware package which contains the device drivers for all of the peripherals for AT32F413.

This library provides a set of examples for each peripheral and some application such as the IAP and sLib utilities.

The mamual is structured as follows:

  • AT32F413_periph_driver : device drivers
  • AT32F413_periph_examples : examples for AT32F413
  • AT32F413_periph_template : AT32F413 project template for Keil and IAR IDE tools
  • AT32F413_board : AT-START-F413 board setting functions
  • AT32F413_middlewares_i2c_application_library : middlewares for I2C application
  • AT32F413_middlewares_usbd_class : middlewares for different USB device class
  • AT32F413_middlewares_usbd_drivers : middlewares for USB device core driver
  • UTILITIES_examples : some applications such as FreeRTOS, sLib and IAP.
Generated by doxygen 1.9.2


AT32F413 Firmwary Library: Modules

Modules
Here is a list of all modules:
[detail level 1234]
► CMSIS |
► AT32F413 |
Library_configuration_section |
Configuration_section_for_CMSIS |
Exported_types |
Exported_macro |
Peripheral_memory_map |
► AT32F413_system |
AT32F413_system_clock_stable_definition |
AT32F413_system_exported_variables |
AT32F413_system_exported_functions |
AT32F413_system_private_defines |
AT32F413_system_private_variables |
AT32F413_system_private_functions |
► AT32F413_periph_driver |
► ACC | ACC driver modules
ACC_exported_constants |
ACC_exported_types |
ACC_exported_functions |
ACC_private_functions |
► ADC | ADC driver modules
ADC_interrupts_definition | Adc interrupt
ADC_flags_definition | Adc flag
ADC_exported_types |
ADC_exported_functions |
ADC_private_functions |
► BPR | BPR driver modules
BPR_flags_definition | Bpr flag
BPR_exported_types |
BPR_exported_functions |
BPR_private_functions |
► CAN | CAN driver modules
CAN_timeout_count |
CAN_flags_definition | Can flag
CAN_interrupts_definition | Can interrupt
CAN_exported_types |
CAN_exported_functions |
CAN_private_functions |
► CRC | CRC driver modules
CRC_exported_types |
CRC_exported_functions |
CRC_private_functions |
► CRM | CRM driver modules
CRM_flags_definition | Crm flag
CRM_interrupts_definition | Crm interrupt
CRM_exported_types |
CRM_exported_functions |
CRM_private_functions |
► DEBUG | DEBUG driver modules
DEBUG_mode_definition |
DEBUG_exported_types |
DEBUG_exported_functions |
DEBUG_private_functions |
► DMA | DMA driver modules
DMA_interrupts_definition | Dma interrupt
DMA_flexible_channel |
DMA_flags_definition | Dma flag
DMA_exported_types |
DMA_exported_functions |
DMA_private_functions |
► EXINT | EXINT driver modules
EXINT_lines |
EXINT_exported_types |
EXINT_exported_functions |
EXINT_private_functions |
► FLASH | FLASH driver modules
FLASH_unlock_keys | Flash unlock keys
FLASH_spim_address | Flash spim address
FLASH_flags | Flash flag
FLASH_interrupts | Flash interrupts
FLASH_slib_mask | Flash slib mask
FLASH_user_system_data | Flash user system data
FLASH_timeout_definition | Flash timeout definition
FLASH_exported_types |
FLASH_exported_functions |
FLASH_private_functions |
► GPIO | GPIO driver modules
GPIO_pins_number_definition |
IOMUX_map_definition | Iomux map definitions
IOMUX_map2_definition | Iomux map2 definitions
IOMUX_map3_definition | Iomux map3 definitions
IOMUX_map4_definition | Iomux map4 definitions
IOMUX_map5_definition | Iomux map5 definitions
IOMUX_map6_definition | Iomux map6 definitions
IOMUX_map7_definition | Iomux map7 definitions
GPIO_exported_types |
GPIO_exported_functions |
GPIO_private_functions |
► I2C | I2C driver modules
I2C_sts1_flags_definition | I2c sts1 flag
I2C_sts2_flags_definition | I2c sts2 flag
I2C_interrupts_definition | I2c interrupt
I2C_exported_types |
I2C_exported_functions |
I2C_private_functions |
► MISC | MISC driver modules
MISC_vector_table_base_address |
MISC_exported_types |
MISC_exported_functions |
MISC_private_functions |
► PWC | PWC driver modules
PWC_flags_definition | Pwc flag
PWC_exported_types |
PWC_exported_functions |
PWC_private_functions |
► RTC | RTC driver modules
RTC_interrupts_definition | Rtc interrupt
RTC_flags_definition | Rtc flag
RTC_exported_types |
RTC_exported_functions |
RTC_private_functions |
► SDIO | SDIO driver modules
SDIO_interrupts_definition | Sdio interrupt
SDIO_flags_definition | Sdio flag
SDIO_exported_types |
SDIO_exported_functions |
SDIO_private_functions |
► SPI | SPI driver modules
SPI_I2S_flags_definition | Spi i2s flag
SPI_I2S_interrupts_definition | Spi i2s interrupt
SPI_exported_types |
SPI_exported_functions |
SPI_private_functions |
► TMR | TMR driver modules
TMR_flags_definition | Tmr flag
TMR_interrupt_select_type_definition | Tmr interrupt select type
TMR_exported_types |
TMR_exported_functions |
TMR_private_functions |
► USART | USART driver modules
USART_flags_definition | Usart flag
USART_interrupts_definition | Usart interrupt
USART_exported_types |
USART_exported_functions |
USART_private_functions |
► USB | USB driver modules
USB_interrupts_definition | Usb interrupt mask
USB_interrupt_flags_definition | Usb interrupt flag
USB_endpoint_register_bit_definition | Usb endpoint register bit define
USB_endpoint_tx_and_rx_status_definition | Usb endpoint tx and rx status
USB_device_endpoint_register_type_definition | Usb device endpoint register type define
USB_buffer_table_default_offset_address_definition | Usb buffer table default offset address
USB_packet_buffer_start_address_definition | Usb packet buffer start address
USB_exported_enum_types |
USB_macro_definition |
USB_exported_types |
USB_exported_functions |
USB_private_functions |
► WDT | WDT driver modules
WDT_flags_definition | Wdt flag
WDT_exported_types |
WDT_exported_functions |
WDT_private_functions |
► WWDT | WWDT driver modules
WWDT_enable_bit_definition | Wwdt enable bit
WWDT_exported_types |
WWDT_exported_functions |
WWDT_private_functions |
► AT32F413_middlewares_i2c_application_library |
I2C_library_event_check_flag |
I2C_library_memory_address_width_mode |
I2C_library_transmission_mode |
I2C_library_status_code |
I2C_library_handler |
I2C_library_exported_functions |
► AT32F413_middlewares_usbd_class |
► USB_audio_class | Usb device class audio demo
USB_audio_class_private_functions |
USB_audio_class_definition |
USB_device_audio_config_definition |
► USB_audio_desc | Usb device audio descriptor
USB_audio_desc_private_functions |
USB_audio_desc_definition |
► USB_audio_hid_class | Usb device class audio hid demo
USB_device_audio_hid_config_definition |
USB_audio_hid_class_private_functions |
USB_audio_hid_class_definition |
► USB_audio_hid_desc | Usb device audio hid descriptor
USB_audio_hid_desc_private_functions |
USB_audio_hid_desc_definition |
► USB_cdc_class | Usb device class cdc demo
USB_cdc_class_private_functions |
USB_cdc_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
USB_cdc_class_exported_functions |
► USB_cdc_desc | Usb device cdc descriptor
USB_cdc_desc_private_functions |
USB_cdc_desc_definition |
► USB_cdc_keyboard_class | Usb device class composite cdc and keyboard
USB_cdc_keyboard_class_private_functions |
USB_cdc_keyboard_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
USB_cdc_keyboar_class_exported_functions |
► USB_cdc_keyboard_desc | Usb device cdc keyboard descriptor
USB_cdc_keyboard_desc_private_functions |
USB_cdc_keyboard_desc_definition |
► USB_cdc_msc_class | Usb device class cdc msc demo
USB_cdc_msc_class_private_functions |
USB_cdc_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
► USB_cdc_msc_desc | Usb device cdc msc descriptor
USB_cdc_msc_desc_private_functions |
USB_cdc_desc_definition |
► USB_msc_bot_scsi | Usb device class mass storage demo
USB_msc_bot_functions |
USB_msc_bot_scsi_definition |
► USB_custom_hid_class | Usb device custom hid demo
USB_custom_hid_class_private_functions |
USB_custom_hid_class_endpoint_definition |
USB_custom_hid_class_request_code_definition |
USB_custom_hid_class_exported_functions |
► USB_custom_hid_desc | Usb device custom_hid descriptor
USB_custom_hid_desc_private_functions |
USB_custom_hid_desc_definition |
► USB_hid_iap_class | Usb device class hid iap demo
USB_hid_iap_class_private_functions |
USB_hid_iap_class_definition |
► USB_hid_iap_desc | Usb device hid_iap descriptor
USB_hid_iap_desc_private_functions |
USB_hid_iap_desc_definition |
► USB_keyboard_class | Usb device keyboard demo
USB_keyboard_class_private_functions |
USB_keyboard_class_endpoint_definition |
USB_hid_class_exported_functions |
► USB_keyboard_desc | Usb device keyboard descriptor
USB_keyboard_desc_private_functions |
USB_keyboard_desc_definition |
► USB_mouse_class | Usb device mouse demo
USB_mouse_class_private_functions |
USB_mouse_class_endpoint_definition |
USB_mouse_class_request_code_definition |
USB_hid_class_exported_functions |
► USB_mouse_desc | Usb device mouse descriptor
USB_mouse_desc_private_functions |
USB_mouse_desc_definition |
► USB_msc_class | Usb device class msc demo
USB_msc_class_private_functions |
USB_msc_class_definition |
► USB_msc_desc | Usb device msc descriptor
USB_msc_desc_private_functions |
USB_msc_desc_definition |
► USB_printer_class | Usb device class printer demo
USB_printer_class_private_functions |
USB_printer_class_definition |
► USB_printer_desc | Usb device printer descriptor
USB_printer_desc_private_functions |
USB_printer_desc_definition |
► AT32F413_middlewares_usbd_drivers |
► USBD_drivers_core | Usb device drivers core
USBD_core_exported_types |
USBD_core_exported_functions |
USBD_core_private_functions |
► USBD_drivers_interrupt | Usb device interrupt
USBD_int_exported_functions |
USBD_int_private_functions |
► USBD_drivers_standard_request | Usb device standard_request
USBD_sdr_exported_functions |
USBD_sdr_private_functions |
► USB_standard |
USB_standard_define |
USB_standard_exported_types |
► AT32F413_board |
► BOARD | Onboard periph driver
BOARD_pins_definition |
BOARD_exported_functions |
► AT32F413_periph_examples |
ACC_calibration |
ADC_combine_mode_ordinary_simult |
ADC_current_vref_value_check |
ADC_exint_trigger_partitioned |
ADC_internal_temperature_sensor |
ADC_repeat_conversion_loop_transfer |
ADC_software_trigger_repeat |
ADC_tmr_trigger_automatic_preempted |
ADC_voltage_monitoring |
BPR_data |
BPR_tamper |
CAN_communication_mode |
CAN_filter |
CAN_loopback_mode |
CORTEX_m4_bit_band |
CORTEX_m4_cmsis_dsp |
► CORTEX_m4_fpu |
JULIA_fpu_functions |
CORTEX_m4_systick_interrupt |
CRC_calculation |
CRM_clock_failure_detection |
CRM_sysclk_switch |
DEBUG_tmr |
DMA_data_to_gpio_flexible |
DMA_flash_to_sram |
EXINT_config |
EXINT_software_trigger |
FLASH_fap_enable |
► FLASH_write_read |
FLASH_write_read_functions |
► FLASH_operate_spim |
FLASH_operate_spim_functions |
FLASH_run_in_spim |
GPIO_io_toggle |
GPIO_led_toggle |
GPIO_swjtag_remap |
I2C_communication_dma |
I2C_communication_int |
I2C_communication_poll |
I2C_eeprom |
I2S_halfduplex_dma |
I2S_halfduplex_interrupt |
I2S_spii2s_switch_halfduplex_polling |
PWC_deepsleep_rtc |
PWC_power_voltage_monitor |
PWC_sleep_tmr2 |
PWC_sleep_usart1 |
PWC_standby_rtc |
PWC_standby_wakeup_pin |
► RTC_calendar |
RTC_calendar_type |
RTC_calendar_exported_functions |
RTC_lick_calibration |
► SDIO_sd_mmc_card |
SDIO_sd_mmc_card_instance_definition |
SDIO_sd_mmc_card_exported_types |
SDIO_sd_mmc_card_command_index_definition |
SDIO_sd_mmc_card_paremeters_definition |
SDIO_sd_mmc_card_response_definition |
SDIO_sd_mmc_card_command_class_definition |
SDIO_sd_mmc_card_cmd8_definition |
SDIO_sd_mmc_card_mmc_extend_definition |
SDIO_sd_mmc_card_interrupt_flags_definition |
SDIO_sd_mmc_card_exported_functions |
► SDIO_sdio_fatfs |
SDIO_sdio_fatfs_instance_definition |
SDIO_sdio_fatfs_exported_types |
SDIO_sdio_fatfs_command_index_definition |
SDIO_sdio_fatfs_paremeters_definition |
SDIO_sdio_fatfs_response_definition |
SDIO_sdio_fatfs_command_class_definition |
SDIO_sdio_fatfs_cmd8_definition |
SDIO_sdio_fatfs_mmc_extend_definition |
SDIO_sdio_fatfs_interrupt_flags_definition |
SDIO_sdio_fatfs_exported_functions |
SPI_crc_transfer_polling |
SPI_fullduplex_polling |
SPI_halfduplex_interrupt |
SPI_halfduplex_transceiver_switch |
SPI_only_receive_mode_polling |
SPI_use_jtagpin_hardwarecs_dma |
► SPI_w25q_flash |
SPI_flash_cs_pin_definition |
SPI_flash_id_definition |
SPI_flash_operation_definition |
SPI_flash_exported_functions |
SRAM_extend_sram |
TMR_6_steps |
TMR_7_pwm_output |
TMR_cascade_synchro |
TMR_complementary_signals |
TMR_dma |
TMR_dma_burst |
TMR_encoder_tmr2 |
TMR_external_clock |
TMR_hall_xor_tmr2 |
TMR_hang_mode |
TMR_input_capture |
TMR_oc_high |
TMR_oc_low |
TMR_oc_toggle_tmr3 |
TMR_oc_toggle_tmr9 |
TMR_one_cycle |
TMR_parallel_synchro |
TMR_pwm_input |
TMR_pwm_input_dma |
TMR_pwm_output_simulate |
TMR_pwm_output_tmr10 |
TMR_pwm_output_tmr3 |
TMR_timer_base |
TMR_tmr1_synchro |
TMR_tmr2_32bit |
USART_half_duplex |
USART_hw_flow_control |
USART_idle_detection |
USART_interrupt |
USART_irda |
USART_polling |
USART_printf |
USART_receiver_mute |
F413_USART_rs485 |
USART_smartcard |
USART_synchronous |
USART_transfer_by_dma_interrupt |
USART_transfer_by_dma_polling |
► USB_device_audio |
USB_device_audio_codec_reg_definition |
USB_device_audio_codec_pin_definition |
USB_device_audio_codec_exported_functions |
► USB_device_audio_hid |
USB_device_audio_hid_codec_reg_definition |
USB_device_audio_hid_codec_pin_definition |
USB_device_audio_hid_codec_exported_functions |
USB_device_composite_vcp_keyboard |
USB_device_msc |
USB_device_composite_vcp_msc |
USB_device_custom_hid |
USB_device_keyboard |
USB_device_mouse |
USB_device_printer |
USB_device_vcp_loopback |
► USB_device_virtual_msc_iap |
USB_device_virtual_msc_iap_definition |
WDT_reset |
WDT_standby |
WWDT_reset |
► AT32F413_periph_template |
Library_configuration |
System_clock_configuration |
LED_toggle |
► UTILITIES_examples |
FreeRTOS_demo |
► GEN_random_number_demo |
RTC_asseed_definition |
GEN_random_number_demo_exported_functions |
SLIB_project_l0 |
SLIB_project_l1 |
► USART_iap_app_led3_toggle |
App_led3_definition |
App_led3_exported_functions |
► USART_iap_app_led4_toggle |
App_led4_definition |
App_led4_exported_functions |
► USART_iap_bootloader |
Bootloader_definition |
Bootloader_exported_functions |
Bootloader_exported_types |
► USB_iap_app_led3_toggle |
App_led3_toggle_definition |
App_led3_toggle_exported_functions |
► USB_iap_app_led4_toggle |
App_led4_toggle_definition |
App_led4_toggle_exported_functions |
► USB_iap_bootloader |
Bootloader_definition |
Bootloader_exported_functions |


AT32F413 Firmwary Library: CMSIS

Modules
CMSIS

Modules

AT32F413
AT32F413_system

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: AT32F413

Modules
AT32F413
CMSIS

Modules

Library_configuration_section
Configuration_section_for_CMSIS
Exported_types
Exported_macro
Peripheral_memory_map

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: Library_configuration_section

Macros
Library_configuration_section
CMSIS » AT32F413

Macros

#define | __AT32F413_LIBRARY_VERSION_MAJOR (0x02)
at32f413 standard peripheral library version number More...
#define | __AT32F413_LIBRARY_VERSION_MIDDLE (0x01)
#define | __AT32F413_LIBRARY_VERSION_MINOR (0x00)
#define | __AT32F413_LIBRARY_VERSION_RC (0x00)
#define | __AT32F413_LIBRARY_VERSION

Detailed Description

Macro Definition Documentation

◆ __AT32F413_LIBRARY_VERSION

#define __AT32F413_LIBRARY_VERSION
Value:
((__AT32F413_LIBRARY_VERSION_MAJOR << 24) | \
(__AT32F413_LIBRARY_VERSION_MIDDLE << 16) | \
(__AT32F413_LIBRARY_VERSION_MINOR << 8) | \
(__AT32F413_LIBRARY_VERSION_RC))
__AT32F413_LIBRARY_VERSION_MIDDLE
#define __AT32F413_LIBRARY_VERSION_MIDDLE
Definition: at32f413.h:126
__AT32F413_LIBRARY_VERSION_RC
#define __AT32F413_LIBRARY_VERSION_RC
Definition: at32f413.h:128
__AT32F413_LIBRARY_VERSION_MAJOR
#define __AT32F413_LIBRARY_VERSION_MAJOR
at32f413 standard peripheral library version number
Definition: at32f413.h:125
__AT32F413_LIBRARY_VERSION_MINOR
#define __AT32F413_LIBRARY_VERSION_MINOR
Definition: at32f413.h:127

Definition at line 129 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_MAJOR

#define __AT32F413_LIBRARY_VERSION_MAJOR (0x02)

at32f413 standard peripheral library version number

tip: to avoid modifying this file each time you need to switch between these devices, you can define the device in your toolchain compiler preprocessor. define with package define with memory density [31:24] major version

Definition at line 125 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_MIDDLE

#define __AT32F413_LIBRARY_VERSION_MIDDLE (0x01)

[23:16] middle version

Definition at line 126 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_MINOR

#define __AT32F413_LIBRARY_VERSION_MINOR (0x00)

[15:8] minor version

Definition at line 127 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_RC

#define __AT32F413_LIBRARY_VERSION_RC (0x00)

[7:0] release candidate

Definition at line 128 of file at32f413.h.


AT32F413 Firmwary Library: Configuration_section_for_CMSIS

Macros | Typedefs | Enumerations
Configuration_section_for_CMSIS
CMSIS » AT32F413

Macros

#define | __CM4_REV 0x0001U
configuration of the cortex-m4 processor and core peripherals More...
#define | __MPU_PRESENT 1
#define | __NVIC_PRIO_BITS 4
#define | __Vendor_SysTickConfig 0
#define | __FPU_PRESENT 1U

Typedefs

typedef enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...

Enumerations

enum IRQn {
Reset_IRQn = -15 , NonMaskableInt_IRQn = -14 , HardFault_IRQn = -13 , MemoryManagement_IRQn = -12 ,
BusFault_IRQn = -11 , UsageFault_IRQn = -10 , SVCall_IRQn = -5 , DebugMonitor_IRQn = -4 ,
PendSV_IRQn = -2 , SysTick_IRQn = -1 , WWDT_IRQn = 0 , PVM_IRQn = 1 ,
TAMPER_IRQn = 2 , RTC_IRQn = 3 , FLASH_IRQn = 4 , CRM_IRQn = 5 ,
EXINT0_IRQn = 6 , EXINT1_IRQn = 7 , EXINT2_IRQn = 8 , EXINT3_IRQn = 9 ,
EXINT4_IRQn = 10 , DMA1_Channel1_IRQn = 11 , DMA1_Channel2_IRQn = 12 , DMA1_Channel3_IRQn = 13 ,
DMA1_Channel4_IRQn = 14 , DMA1_Channel5_IRQn = 15 , DMA1_Channel6_IRQn = 16 , DMA1_Channel7_IRQn = 17 ,
ADC1_2_IRQn = 18 , USBFS_H_CAN1_TX_IRQn = 19 , USBFS_L_CAN1_RX0_IRQn = 20 , CAN1_RX1_IRQn = 21 ,
CAN1_SE_IRQn = 22 , EXINT9_5_IRQn = 23 , TMR1_BRK_TMR9_IRQn = 24 , TMR1_OVF_TMR10_IRQn = 25 ,
TMR1_TRG_HALL_TMR11_IRQn = 26 , TMR1_CH_IRQn = 27 , TMR2_GLOBAL_IRQn = 28 , TMR3_GLOBAL_IRQn = 29 ,
TMR4_GLOBAL_IRQn = 30 , I2C1_EVT_IRQn = 31 , I2C1_ERR_IRQn = 32 , I2C2_EVT_IRQn = 33 ,
I2C2_ERR_IRQn = 34 , SPI1_IRQn = 35 , SPI2_IRQn = 36 , USART1_IRQn = 37 ,
USART2_IRQn = 38 , USART3_IRQn = 39 , EXINT15_10_IRQn = 40 , RTCAlarm_IRQn = 41 ,
USBFSWakeUp_IRQn = 42 , TMR8_BRK_IRQn = 43 , TMR8_OVF_IRQn = 44 , TMR8_TRG_HALL_IRQn = 45 ,
TMR8_CH_IRQn = 46 , SDIO1_IRQn = 49 , TMR5_GLOBAL_IRQn = 50 , UART4_IRQn = 52 ,
UART5_IRQn = 53 , DMA2_Channel1_IRQn = 56 , DMA2_Channel2_IRQn = 57 , DMA2_Channel3_IRQn = 58 ,
DMA2_Channel4_5_IRQn = 59 , CAN2_TX_IRQn = 68 , CAN2_RX0_IRQn = 69 , CAN2_RX1_IRQn = 70 ,
CAN2_SE_IRQn = 71 , ACC_IRQn = 72 , USBFS_MAPH_IRQn = 73 , USBFS_MAPL_IRQn = 74 ,
DMA2_Channel6_7_IRQn = 75
}
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...

Detailed Description

Macro Definition Documentation

◆ __CM4_REV

#define __CM4_REV 0x0001U

configuration of the cortex-m4 processor and core peripherals

core revision r0p1

Definition at line 145 of file at32f413.h.

◆ __FPU_PRESENT

#define __FPU_PRESENT 1U

fpu present

Definition at line 149 of file at32f413.h.

◆ __MPU_PRESENT

#define __MPU_PRESENT 1

mpu present

Definition at line 146 of file at32f413.h.

◆ __NVIC_PRIO_BITS

#define __NVIC_PRIO_BITS 4

at32 uses 4 bits for the priority levels

Definition at line 147 of file at32f413.h.

◆ __Vendor_SysTickConfig

#define __Vendor_SysTickConfig 0

set to 1 if different systick config is used

Definition at line 148 of file at32f413.h.

Typedef Documentation

◆ IRQn_Type

typedef enum IRQn IRQn_Type

at32f413 interrupt number definition, according to the selected device in Library_configuration_section

Enumeration Type Documentation

◆ IRQn

enum IRQn

at32f413 interrupt number definition, according to the selected device in Library_configuration_section

Enumerator
Reset_IRQn | 1 reset vector, invoked on power up and warm reset
NonMaskableInt_IRQn | 2 non maskable interrupt
HardFault_IRQn | 3 hard fault, all classes of fault
MemoryManagement_IRQn | 4 cortex-m4 memory management interrupt
BusFault_IRQn | 5 cortex-m4 bus fault interrupt
UsageFault_IRQn | 6 cortex-m4 usage fault interrupt
SVCall_IRQn | 11 cortex-m4 sv call interrupt
DebugMonitor_IRQn | 12 cortex-m4 debug monitor interrupt
PendSV_IRQn | 14 cortex-m4 pend sv interrupt
SysTick_IRQn | 15 cortex-m4 system tick interrupt
WWDT_IRQn | window watchdog timer interrupt
PVM_IRQn | pvm through exint line detection interrupt
TAMPER_IRQn | tamper interrupt
RTC_IRQn | rtc global interrupt
FLASH_IRQn | flash global interrupt
CRM_IRQn | crm global interrupt
EXINT0_IRQn | external line0 interrupt
EXINT1_IRQn | external line1 interrupt
EXINT2_IRQn | external line2 interrupt
EXINT3_IRQn | external line3 interrupt
EXINT4_IRQn | external line4 interrupt
DMA1_Channel1_IRQn | dma1 channel 1 global interrupt
DMA1_Channel2_IRQn | dma1 channel 2 global interrupt
DMA1_Channel3_IRQn | dma1 channel 3 global interrupt
DMA1_Channel4_IRQn | dma1 channel 4 global interrupt
DMA1_Channel5_IRQn | dma1 channel 5 global interrupt
DMA1_Channel6_IRQn | dma1 channel 6 global interrupt
DMA1_Channel7_IRQn | dma1 channel 7 global interrupt
ADC1_2_IRQn | adc1 and adc2 global interrupt
USBFS_H_CAN1_TX_IRQn | usb device high priority or can1 tx interrupts
USBFS_L_CAN1_RX0_IRQn | usb device low priority or can1 rx0 interrupts
CAN1_RX1_IRQn | can1 rx1 interrupt
CAN1_SE_IRQn | can1 se interrupt
EXINT9_5_IRQn | external line[9:5] interrupts
TMR1_BRK_TMR9_IRQn | tmr1 brake interrupt
TMR1_OVF_TMR10_IRQn | tmr1 overflow interrupt
TMR1_TRG_HALL_TMR11_IRQn | tmr1 trigger and hall interrupt
TMR1_CH_IRQn | tmr1 channel interrupt
TMR2_GLOBAL_IRQn | tmr2 global interrupt
TMR3_GLOBAL_IRQn | tmr3 global interrupt
TMR4_GLOBAL_IRQn | tmr4 global interrupt
I2C1_EVT_IRQn | i2c1 event interrupt
I2C1_ERR_IRQn | i2c1 error interrupt
I2C2_EVT_IRQn | i2c2 event interrupt
I2C2_ERR_IRQn | i2c2 error interrupt
SPI1_IRQn | spi1 global interrupt
SPI2_IRQn | spi2 global interrupt
USART1_IRQn | usart1 global interrupt
USART2_IRQn | usart2 global interrupt
USART3_IRQn | usart3 global interrupt
EXINT15_10_IRQn | external line[15:10] interrupts
RTCAlarm_IRQn | rtc alarm through exint line interrupt
USBFSWakeUp_IRQn | usb device wakeup from suspend through exint line interrupt
TMR8_BRK_IRQn | tmr8 brake interrupt
TMR8_OVF_IRQn | tmr8 overflow interrupt
TMR8_TRG_HALL_IRQn | tmr8 trigger and hall interrupt
TMR8_CH_IRQn | tmr8 channel interrupt
SDIO1_IRQn | sdio1 global interrupt
TMR5_GLOBAL_IRQn | tmr5 global interrupt
UART4_IRQn | uart4 global interrupt
UART5_IRQn | uart5 global interrupt
DMA2_Channel1_IRQn | dma2 channel 1 global interrupt
DMA2_Channel2_IRQn | dma2 channel 2 global interrupt
DMA2_Channel3_IRQn | dma2 channel 3 global interrupt
DMA2_Channel4_5_IRQn | dma2 channel 4 and channel 5 global interrupt
CAN2_TX_IRQn | can2 tx interrupt
CAN2_RX0_IRQn | can2 rx0 interrupt
CAN2_RX1_IRQn | can2 rx1 interrupt
CAN2_SE_IRQn | can2 se interrupt
ACC_IRQn | acc interrupt
USBFS_MAPH_IRQn | usb map hp interrupt
USBFS_MAPL_IRQn | usb map lp interrupt
DMA2_Channel6_7_IRQn | dma2 channel 6 and channel 7 global interrupt

Definition at line 155 of file at32f413.h.


AT32F413 Firmwary Library: Exported_types

Typedefs | Enumerations
Exported_types
CMSIS » AT32F413

Typedefs

typedef int32_t | INT32
typedef int16_t | INT16
typedef int8_t | INT8
typedef uint32_t | UINT32
typedef uint16_t | UINT16
typedef uint8_t | UINT8
typedef int32_t | s32
typedef int16_t | s16
typedef int8_t | s8
typedef const int32_t | sc32
typedef const int16_t | sc16
typedef const int8_t | sc8
typedef __IO int32_t | vs32
typedef __IO int16_t | vs16
typedef __IO int8_t | vs8
typedef __I int32_t | vsc32
typedef __I int16_t | vsc16
typedef __I int8_t | vsc8
typedef uint32_t | u32
typedef uint16_t | u16
typedef uint8_t | u8
typedef const uint32_t | uc32
typedef const uint16_t | uc16
typedef const uint8_t | uc8
typedef __IO uint32_t | vu32
typedef __IO uint16_t | vu16
typedef __IO uint8_t | vu8
typedef __I uint32_t | vuc32
typedef __I uint16_t | vuc16
typedef __I uint8_t | vuc8

Enumerations

enum | flag_status { RESET = 0 , SET = !RESET }
flag status More...
enum | confirm_state { FALSE = 0 , TRUE = !FALSE }
confirm state More...
enum | error_status { ERROR = 0 , SUCCESS = !ERROR }
error status More...

Detailed Description

Typedef Documentation

◆ INT16

typedef int16_t INT16

Definition at line 250 of file at32f413.h.

◆ INT32

typedef int32_t INT32

Definition at line 249 of file at32f413.h.

◆ INT8

typedef int8_t INT8

Definition at line 251 of file at32f413.h.

◆ s16

typedef int16_t s16

Definition at line 257 of file at32f413.h.

◆ s32

typedef int32_t s32

Definition at line 256 of file at32f413.h.

◆ s8

typedef int8_t s8

Definition at line 258 of file at32f413.h.

◆ sc16

typedef const int16_t sc16

read only

Definition at line 261 of file at32f413.h.

◆ sc32

typedef const int32_t sc32

read only

Definition at line 260 of file at32f413.h.

◆ sc8

typedef const int8_t sc8

read only

Definition at line 262 of file at32f413.h.

◆ u16

typedef uint16_t u16

Definition at line 273 of file at32f413.h.

◆ u32

typedef uint32_t u32

Definition at line 272 of file at32f413.h.

◆ u8

typedef uint8_t u8

Definition at line 274 of file at32f413.h.

◆ uc16

typedef const uint16_t uc16

read only

Definition at line 277 of file at32f413.h.

◆ uc32

typedef const uint32_t uc32

read only

Definition at line 276 of file at32f413.h.

◆ uc8

typedef const uint8_t uc8

read only

Definition at line 278 of file at32f413.h.

◆ UINT16

typedef uint16_t UINT16

Definition at line 253 of file at32f413.h.

◆ UINT32

typedef uint32_t UINT32

Definition at line 252 of file at32f413.h.

◆ UINT8

typedef uint8_t UINT8

Definition at line 254 of file at32f413.h.

◆ vs16

typedef __IO int16_t vs16

Definition at line 265 of file at32f413.h.

◆ vs32

typedef __IO int32_t vs32

Definition at line 264 of file at32f413.h.

◆ vs8

typedef __IO int8_t vs8

Definition at line 266 of file at32f413.h.

◆ vsc16

typedef __I int16_t vsc16

read only

Definition at line 269 of file at32f413.h.

◆ vsc32

typedef __I int32_t vsc32

read only

Definition at line 268 of file at32f413.h.

◆ vsc8

typedef __I int8_t vsc8

read only

Definition at line 270 of file at32f413.h.

◆ vu16

typedef __IO uint16_t vu16

Definition at line 281 of file at32f413.h.

◆ vu32

typedef __IO uint32_t vu32

Definition at line 280 of file at32f413.h.

◆ vu8

typedef __IO uint8_t vu8

Definition at line 282 of file at32f413.h.

◆ vuc16

typedef __I uint16_t vuc16

read only

Definition at line 285 of file at32f413.h.

◆ vuc32

typedef __I uint32_t vuc32

read only

Definition at line 284 of file at32f413.h.

◆ vuc8

typedef __I uint8_t vuc8

read only

Definition at line 286 of file at32f413.h.

Enumeration Type Documentation

◆ confirm_state

enum confirm_state

confirm state

Enumerator
FALSE
TRUE

Definition at line 296 of file at32f413.h.

◆ error_status

enum error_status

error status

Enumerator
ERROR
SUCCESS

Definition at line 301 of file at32f413.h.

◆ flag_status

enum flag_status

flag status

Enumerator
RESET
SET

Definition at line 291 of file at32f413.h.


AT32F413 Firmwary Library: Exported_macro

Macros
Exported_macro
CMSIS » AT32F413

Macros

#define | REG8(addr) *(volatile uint8_t *)(addr)
#define | REG16(addr) *(volatile uint16_t *)(addr)
#define | REG32(addr) *(volatile uint32_t *)(addr)
#define | MAKE_VALUE(reg_offset, bit_num) (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))
#define | PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
#define | PERIPH_REG_BIT(value) (0x1U << (value & 0x1F))

Detailed Description

Macro Definition Documentation

◆ MAKE_VALUE

#define MAKE_VALUE | ( | reg_offset,
 |  | bit_num
 | ) | (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))

Definition at line 315 of file at32f413.h.

◆ PERIPH_REG

#define PERIPH_REG | ( | periph_base,
 |  | value
 | ) | REG32((periph_base + (value >> 16)))

Definition at line 317 of file at32f413.h.

◆ PERIPH_REG_BIT

#define PERIPH_REG_BIT ( value ) (0x1U << (value & 0x1F))

Definition at line 318 of file at32f413.h.

◆ REG16

#define REG16 ( addr ) *(volatile uint16_t *)(addr)

Definition at line 312 of file at32f413.h.

◆ REG32

#define REG32 ( addr ) *(volatile uint32_t *)(addr)

Definition at line 313 of file at32f413.h.

◆ REG8

#define REG8 ( addr ) *(volatile uint8_t *)(addr)

Definition at line 311 of file at32f413.h.


AT32F413 Firmwary Library: Peripheral_memory_map

Macros
Peripheral_memory_map
CMSIS » AT32F413

Macros

#define | FLASH_BASE ((uint32_t)0x08000000)
#define | SPIM_FLASH_BASE ((uint32_t)0x08400000)
#define | USD_BASE ((uint32_t)0x1FFFF800)
#define | SRAM_BASE ((uint32_t)0x20000000)
#define | PERIPH_BASE ((uint32_t)0x40000000)
#define | XMC_REG_BASE ((uint32_t)0xA0000000)
#define | DEBUG_BASE ((uint32_t)0xE0042000)
#define | APB1PERIPH_BASE (PERIPH_BASE + 0x00000)
#define | APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
#define | AHBPERIPH_BASE (PERIPH_BASE + 0x20000)
#define | TMR2_BASE (APB1PERIPH_BASE + 0x0000)
#define | TMR3_BASE (APB1PERIPH_BASE + 0x0400)
#define | TMR4_BASE (APB1PERIPH_BASE + 0x0800)
#define | TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
#define | RTC_BASE (APB1PERIPH_BASE + 0x2800)
#define | WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
#define | WDT_BASE (APB1PERIPH_BASE + 0x3000)
#define | SPI2_BASE (APB1PERIPH_BASE + 0x3800)
#define | USART2_BASE (APB1PERIPH_BASE + 0x4400)
#define | USART3_BASE (APB1PERIPH_BASE + 0x4800)
#define | UART4_BASE (APB1PERIPH_BASE + 0x4C00)
#define | UART5_BASE (APB1PERIPH_BASE + 0x5000)
#define | I2C1_BASE (APB1PERIPH_BASE + 0x5400)
#define | I2C2_BASE (APB1PERIPH_BASE + 0x5800)
#define | USBFS_BASE (APB1PERIPH_BASE + 0x5C00)
#define | CAN1_BASE (APB1PERIPH_BASE + 0x6400)
#define | CAN2_BASE (APB1PERIPH_BASE + 0x6800)
#define | BPR_BASE (APB1PERIPH_BASE + 0x6C00)
#define | PWC_BASE (APB1PERIPH_BASE + 0x7000)
#define | IOMUX_BASE (APB2PERIPH_BASE + 0x0000)
#define | EXINT_BASE (APB2PERIPH_BASE + 0x0400)
#define | GPIOA_BASE (APB2PERIPH_BASE + 0x0800)
#define | GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)
#define | GPIOC_BASE (APB2PERIPH_BASE + 0x1000)
#define | GPIOD_BASE (APB2PERIPH_BASE + 0x1400)
#define | GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)
#define | ADC1_BASE (APB2PERIPH_BASE + 0x2400)
#define | ADC2_BASE (APB2PERIPH_BASE + 0x2800)
#define | TMR1_BASE (APB2PERIPH_BASE + 0x2C00)
#define | SPI1_BASE (APB2PERIPH_BASE + 0x3000)
#define | TMR8_BASE (APB2PERIPH_BASE + 0x3400)
#define | USART1_BASE (APB2PERIPH_BASE + 0x3800)
#define | TMR9_BASE (APB2PERIPH_BASE + 0x4C00)
#define | TMR10_BASE (APB2PERIPH_BASE + 0x5000)
#define | TMR11_BASE (APB2PERIPH_BASE + 0x5400)
#define | ACC_BASE (APB2PERIPH_BASE + 0x5800)
#define | SDIO1_BASE (APB2PERIPH_BASE + 0x8000)
#define | DMA1_BASE (AHBPERIPH_BASE + 0x0000)
#define | DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)
#define | DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)
#define | DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)
#define | DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)
#define | DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)
#define | DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)
#define | DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)
#define | DMA2_BASE (AHBPERIPH_BASE + 0x0400)
#define | DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)
#define | DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)
#define | DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)
#define | DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)
#define | DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)
#define | DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)
#define | DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)
#define | CRM_BASE (AHBPERIPH_BASE + 0x1000)
#define | FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)
#define | CRC_BASE (AHBPERIPH_BASE + 0x3000)

Detailed Description

Macro Definition Documentation

◆ ACC_BASE

#define ACC_BASE (APB2PERIPH_BASE + 0x5800)

Definition at line 377 of file at32f413.h.

◆ ADC1_BASE

#define ADC1_BASE (APB2PERIPH_BASE + 0x2400)

Definition at line 368 of file at32f413.h.

◆ ADC2_BASE

#define ADC2_BASE (APB2PERIPH_BASE + 0x2800)

Definition at line 369 of file at32f413.h.

◆ AHBPERIPH_BASE

#define AHBPERIPH_BASE (PERIPH_BASE + 0x20000)

Definition at line 338 of file at32f413.h.

◆ APB1PERIPH_BASE

#define APB1PERIPH_BASE (PERIPH_BASE + 0x00000)

Definition at line 336 of file at32f413.h.

◆ APB2PERIPH_BASE

#define APB2PERIPH_BASE (PERIPH_BASE + 0x10000)

Definition at line 337 of file at32f413.h.

◆ BPR_BASE

#define BPR_BASE (APB1PERIPH_BASE + 0x6C00)

Definition at line 358 of file at32f413.h.

◆ CAN1_BASE

#define CAN1_BASE (APB1PERIPH_BASE + 0x6400)

Definition at line 356 of file at32f413.h.

◆ CAN2_BASE

#define CAN2_BASE (APB1PERIPH_BASE + 0x6800)

Definition at line 357 of file at32f413.h.

◆ CRC_BASE

#define CRC_BASE (AHBPERIPH_BASE + 0x3000)

Definition at line 398 of file at32f413.h.

◆ CRM_BASE

#define CRM_BASE (AHBPERIPH_BASE + 0x1000)

Definition at line 396 of file at32f413.h.

◆ DEBUG_BASE

#define DEBUG_BASE ((uint32_t)0xE0042000)

Definition at line 334 of file at32f413.h.

◆ DMA1_BASE

#define DMA1_BASE (AHBPERIPH_BASE + 0x0000)

Definition at line 380 of file at32f413.h.

◆ DMA1_CHANNEL1_BASE

#define DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)

Definition at line 381 of file at32f413.h.

◆ DMA1_CHANNEL2_BASE

#define DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)

Definition at line 382 of file at32f413.h.

◆ DMA1_CHANNEL3_BASE

#define DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)

Definition at line 383 of file at32f413.h.

◆ DMA1_CHANNEL4_BASE

#define DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)

Definition at line 384 of file at32f413.h.

◆ DMA1_CHANNEL5_BASE

#define DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)

Definition at line 385 of file at32f413.h.

◆ DMA1_CHANNEL6_BASE

#define DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)

Definition at line 386 of file at32f413.h.

◆ DMA1_CHANNEL7_BASE

#define DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)

Definition at line 387 of file at32f413.h.

◆ DMA2_BASE

#define DMA2_BASE (AHBPERIPH_BASE + 0x0400)

Definition at line 388 of file at32f413.h.

◆ DMA2_CHANNEL1_BASE

#define DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)

Definition at line 389 of file at32f413.h.

◆ DMA2_CHANNEL2_BASE

#define DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)

Definition at line 390 of file at32f413.h.

◆ DMA2_CHANNEL3_BASE

#define DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)

Definition at line 391 of file at32f413.h.

◆ DMA2_CHANNEL4_BASE

#define DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)

Definition at line 392 of file at32f413.h.

◆ DMA2_CHANNEL5_BASE

#define DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)

Definition at line 393 of file at32f413.h.

◆ DMA2_CHANNEL6_BASE

#define DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)

Definition at line 394 of file at32f413.h.

◆ DMA2_CHANNEL7_BASE

#define DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)

Definition at line 395 of file at32f413.h.

◆ EXINT_BASE

#define EXINT_BASE (APB2PERIPH_BASE + 0x0400)

Definition at line 362 of file at32f413.h.

◆ FLASH_BASE

#define FLASH_BASE ((uint32_t)0x08000000)

Definition at line 328 of file at32f413.h.

◆ FLASH_REG_BASE

#define FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)

Definition at line 397 of file at32f413.h.

◆ GPIOA_BASE

#define GPIOA_BASE (APB2PERIPH_BASE + 0x0800)

Definition at line 363 of file at32f413.h.

◆ GPIOB_BASE

#define GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)

Definition at line 364 of file at32f413.h.

◆ GPIOC_BASE

#define GPIOC_BASE (APB2PERIPH_BASE + 0x1000)

Definition at line 365 of file at32f413.h.

◆ GPIOD_BASE

#define GPIOD_BASE (APB2PERIPH_BASE + 0x1400)

Definition at line 366 of file at32f413.h.

◆ GPIOF_BASE

#define GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)

Definition at line 367 of file at32f413.h.

◆ I2C1_BASE

#define I2C1_BASE (APB1PERIPH_BASE + 0x5400)

Definition at line 353 of file at32f413.h.

◆ I2C2_BASE

#define I2C2_BASE (APB1PERIPH_BASE + 0x5800)

Definition at line 354 of file at32f413.h.

◆ IOMUX_BASE

#define IOMUX_BASE (APB2PERIPH_BASE + 0x0000)

Definition at line 361 of file at32f413.h.

◆ PERIPH_BASE

#define PERIPH_BASE ((uint32_t)0x40000000)

Definition at line 332 of file at32f413.h.

◆ PWC_BASE

#define PWC_BASE (APB1PERIPH_BASE + 0x7000)

Definition at line 359 of file at32f413.h.

◆ RTC_BASE

#define RTC_BASE (APB1PERIPH_BASE + 0x2800)

Definition at line 345 of file at32f413.h.

◆ SDIO1_BASE

#define SDIO1_BASE (APB2PERIPH_BASE + 0x8000)

Definition at line 378 of file at32f413.h.

◆ SPI1_BASE

#define SPI1_BASE (APB2PERIPH_BASE + 0x3000)

Definition at line 371 of file at32f413.h.

◆ SPI2_BASE

#define SPI2_BASE (APB1PERIPH_BASE + 0x3800)

Definition at line 348 of file at32f413.h.

◆ SPIM_FLASH_BASE

#define SPIM_FLASH_BASE ((uint32_t)0x08400000)

Definition at line 329 of file at32f413.h.

◆ SRAM_BASE

#define SRAM_BASE ((uint32_t)0x20000000)

Definition at line 331 of file at32f413.h.

◆ TMR10_BASE

#define TMR10_BASE (APB2PERIPH_BASE + 0x5000)

Definition at line 375 of file at32f413.h.

◆ TMR11_BASE

#define TMR11_BASE (APB2PERIPH_BASE + 0x5400)

Definition at line 376 of file at32f413.h.

◆ TMR1_BASE

#define TMR1_BASE (APB2PERIPH_BASE + 0x2C00)

Definition at line 370 of file at32f413.h.

◆ TMR2_BASE

#define TMR2_BASE (APB1PERIPH_BASE + 0x0000)

Definition at line 341 of file at32f413.h.

◆ TMR3_BASE

#define TMR3_BASE (APB1PERIPH_BASE + 0x0400)

Definition at line 342 of file at32f413.h.

◆ TMR4_BASE

#define TMR4_BASE (APB1PERIPH_BASE + 0x0800)

Definition at line 343 of file at32f413.h.

◆ TMR5_BASE

#define TMR5_BASE (APB1PERIPH_BASE + 0x0C00)

Definition at line 344 of file at32f413.h.

◆ TMR8_BASE

#define TMR8_BASE (APB2PERIPH_BASE + 0x3400)

Definition at line 372 of file at32f413.h.

◆ TMR9_BASE

#define TMR9_BASE (APB2PERIPH_BASE + 0x4C00)

Definition at line 374 of file at32f413.h.

◆ UART4_BASE

#define UART4_BASE (APB1PERIPH_BASE + 0x4C00)

Definition at line 351 of file at32f413.h.

◆ UART5_BASE

#define UART5_BASE (APB1PERIPH_BASE + 0x5000)

Definition at line 352 of file at32f413.h.

◆ USART1_BASE

#define USART1_BASE (APB2PERIPH_BASE + 0x3800)

Definition at line 373 of file at32f413.h.

◆ USART2_BASE

#define USART2_BASE (APB1PERIPH_BASE + 0x4400)

Definition at line 349 of file at32f413.h.

◆ USART3_BASE

#define USART3_BASE (APB1PERIPH_BASE + 0x4800)

Definition at line 350 of file at32f413.h.

◆ USBFS_BASE

#define USBFS_BASE (APB1PERIPH_BASE + 0x5C00)

Definition at line 355 of file at32f413.h.

◆ USD_BASE

#define USD_BASE ((uint32_t)0x1FFFF800)

Definition at line 330 of file at32f413.h.

◆ WDT_BASE

#define WDT_BASE (APB1PERIPH_BASE + 0x3000)

Definition at line 347 of file at32f413.h.

◆ WWDT_BASE

#define WWDT_BASE (APB1PERIPH_BASE + 0x2C00)

Definition at line 346 of file at32f413.h.

◆ XMC_REG_BASE

#define XMC_REG_BASE ((uint32_t)0xA0000000)

Definition at line 333 of file at32f413.h.


AT32F413 Firmwary Library: AT32F413_system

Modules
AT32F413_system
CMSIS

Modules

AT32F413_system_clock_stable_definition
AT32F413_system_exported_variables
AT32F413_system_exported_functions
AT32F413_system_private_defines
AT32F413_system_private_variables
AT32F413_system_private_functions

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: AT32F413_system_clock_stable_definition

Macros
AT32F413_system_clock_stable_definition
CMSIS » AT32F413_system

Macros

#define | HEXT_STABLE_DELAY (5000u)
#define | PLL_STABLE_DELAY (500u)
#define | SystemCoreClock system_core_clock

Detailed Description

Macro Definition Documentation

◆ HEXT_STABLE_DELAY

#define HEXT_STABLE_DELAY (5000u)

Definition at line 44 of file system_at32f413.h.

◆ PLL_STABLE_DELAY

#define PLL_STABLE_DELAY (500u)

Definition at line 45 of file system_at32f413.h.

◆ SystemCoreClock

#define SystemCoreClock system_core_clock

Definition at line 46 of file system_at32f413.h.


AT32F413 Firmwary Library: AT32F413_system_exported_variables

Variables
AT32F413_system_exported_variables
CMSIS » AT32F413_system

Variables

unsigned int system_core_clock

Detailed Description

Variable Documentation

◆ system_core_clock

unsigned int system_core_clock
extern

system clock frequency (core clock)

value of the high speed internal clock in hz system clock frequency (core clock)

Definition at line 46 of file system_at32f413.c.

Referenced by delay_init(), DMA1_Channel2_IRQHandler(), main(), mclk_tmr1_init(), sd_init(), sd_power_on(), system_core_clock_update(), tmr1_config(), TMR3_GLOBAL_IRQHandler(), and usb_clock48m_select().


AT32F413 Firmwary Library: AT32F413_system_exported_functions

Functions
AT32F413_system_exported_functions
CMSIS » AT32F413_system

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Detailed Description

Function Documentation

◆ system_core_clock_update()

void system_core_clock_update ( void )

update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters.

Parameters
none
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 110 of file system_at32f413.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ SystemInit()

void SystemInit ( void )

setup the microcontroller system initialize the flash interface.

Note
this function should be used only after reset.
Parameters
none
Return values
none

< vector table base offset field. this value must be a multiple of 0x200.

Definition at line 62 of file system_at32f413.c.


AT32F413 Firmwary Library: AT32F413_system_private_defines

Macros
AT32F413_system_private_defines
CMSIS » AT32F413_system

Macros

#define VECT_TAB_OFFSET 0x0

Detailed Description

Macro Definition Documentation

◆ VECT_TAB_OFFSET

#define VECT_TAB_OFFSET 0x0

vector table base offset field. this value must be a multiple of 0x200.

Definition at line 38 of file system_at32f413.c.


AT32F413 Firmwary Library: AT32F413_system_private_variables

Variables
AT32F413_system_private_variables
CMSIS » AT32F413_system

Variables

unsigned int system_core_clock = ((uint32_t)8000000)

Detailed Description

Variable Documentation

◆ system_core_clock

unsigned int system_core_clock = ((uint32_t)8000000)

value of the high speed internal clock in hz system clock frequency (core clock)

Definition at line 46 of file system_at32f413.c.

Referenced by delay_init(), DMA1_Channel2_IRQHandler(), main(), mclk_tmr1_init(), sd_init(), sd_power_on(), system_core_clock_update(), tmr1_config(), TMR3_GLOBAL_IRQHandler(), and usb_clock48m_select().


AT32F413 Firmwary Library: AT32F413_system_private_functions

Functions
AT32F413_system_private_functions
CMSIS » AT32F413_system

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Detailed Description

Function Documentation

◆ system_core_clock_update()

void system_core_clock_update ( void )

update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters.

Parameters
none
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 110 of file system_at32f413.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ SystemInit()

void SystemInit ( void )

setup the microcontroller system initialize the flash interface.

Note
this function should be used only after reset.
Parameters
none
Return values
none

< vector table base offset field. this value must be a multiple of 0x200.

Definition at line 62 of file system_at32f413.c.


AT32F413 Firmwary Library: AT32F413_periph_driver

Modules
AT32F413_periph_driver

Modules

ACC
ACC driver modules.
ADC
ADC driver modules.
BPR
BPR driver modules.
CAN
CAN driver modules.
CRC
CRC driver modules.
CRM
CRM driver modules.
DEBUG
DEBUG driver modules.
DMA
DMA driver modules.
EXINT
EXINT driver modules.
FLASH
FLASH driver modules.
GPIO
GPIO driver modules.
I2C
I2C driver modules.
MISC
MISC driver modules.
PWC
PWC driver modules.
RTC
RTC driver modules.
SDIO
SDIO driver modules.
SPI
SPI driver modules.
TMR
TMR driver modules.
USART
USART driver modules.
USB
USB driver modules.
WDT
WDT driver modules.
WWDT
WWDT driver modules.

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: ACC

Modules | Macros
ACC
AT32F413_periph_driver

ACC driver modules. More...

Modules

ACC_exported_constants
ACC_exported_types
ACC_exported_functions
ACC_private_functions

Macros

#define ACC ((acc_type *) ACC_BASE)

Detailed Description

ACC driver modules.

Macro Definition Documentation

◆ ACC

#define ACC ((acc_type *) ACC_BASE)

Definition at line 164 of file at32f413_acc.h.


AT32F413 Firmwary Library: ACC_exported_constants

Macros
ACC_exported_constants
AT32F413_periph_driver » ACC

Macros

#define | ACC_CAL_HICKCAL ((uint16_t)0x0000)
#define | ACC_CAL_HICKTRIM ((uint16_t)0x0002)
#define | ACC_RSLOST_FLAG ((uint16_t)0x0002)
#define | ACC_CALRDY_FLAG ((uint16_t)0x0001)
#define | ACC_CALRDYIEN_INT ((uint16_t)0x0020)
#define | ACC_EIEN_INT ((uint16_t)0x0010)

Detailed Description

Macro Definition Documentation

◆ ACC_CAL_HICKCAL

#define ACC_CAL_HICKCAL ((uint16_t)0x0000)

acc hick calibration

Definition at line 50 of file at32f413_acc.h.

◆ ACC_CAL_HICKTRIM

#define ACC_CAL_HICKTRIM ((uint16_t)0x0002)

acc hick trim

Definition at line 51 of file at32f413_acc.h.

◆ ACC_CALRDY_FLAG

#define ACC_CALRDY_FLAG ((uint16_t)0x0001)

acc internal high-speed clock calibration ready error flag

Definition at line 54 of file at32f413_acc.h.

◆ ACC_CALRDYIEN_INT

#define ACC_CALRDYIEN_INT ((uint16_t)0x0020)

acc internal high-speed clock calibration ready interrupt enable

Definition at line 56 of file at32f413_acc.h.

◆ ACC_EIEN_INT

#define ACC_EIEN_INT ((uint16_t)0x0010)

acc reference signal lost interrupt enable

Definition at line 57 of file at32f413_acc.h.

◆ ACC_RSLOST_FLAG

#define ACC_RSLOST_FLAG ((uint16_t)0x0002)

acc reference signal lost error flag

Definition at line 53 of file at32f413_acc.h.


AT32F413 Firmwary Library: ACC_exported_types

Data Structures
ACC_exported_types
AT32F413_periph_driver » ACC

Data Structures

struct acc_type
type define acc register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: acc_type Struct Reference

Data Fields
acc_type Struct Reference
AT32F413_periph_driver » ACC » ACC_exported_types

type define acc register all More...

#include <at32f413_acc.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t calrdy: 1
__IO uint32_t rslost: 1
__IO uint32_t reserved1: 30
} sts_bit
};
acc sts register, offset:0x00 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t calon: 1
__IO uint32_t entrim: 1
__IO uint32_t reserved1: 2
__IO uint32_t eien: 1
__IO uint32_t calrdyien: 1
__IO uint32_t reserved2: 2
__IO uint32_t step: 4
__IO uint32_t reserved3: 20
} ctrl1_bit
};
acc ctrl1 register, offset:0x04 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t hickcal: 8
__IO uint32_t hicktrim: 6
__IO uint32_t reserved1: 18
} ctrl2_bit
};
acc ctrl2 register, offset:0x08 More...
union {
__IO uint32_t c1
struct {
__IO uint32_t c1: 16
__IO uint32_t reserved1: 16
} c1_bit
};
acc acc_c1 register, offset:0x0C More...
union {
__IO uint32_t c2
struct {
__IO uint32_t c2: 16
__IO uint32_t reserved1: 16
} c2_bit
};
acc acc_c2 register, offset:0x10 More...
union {
__IO uint32_t c3
struct {
__IO uint32_t c3: 16
__IO uint32_t reserved1: 16
} c3_bit
};
acc acc_c3 register, offset:0x14 More...

Detailed Description

type define acc register all

Definition at line 70 of file at32f413_acc.h.

Field Documentation

◆

union { ... } acc_type::@1

acc sts register, offset:0x00

◆

union { ... } acc_type::@11

acc acc_c3 register, offset:0x14

◆

union { ... } acc_type::@3

acc ctrl1 register, offset:0x04

◆

union { ... } acc_type::@5

acc ctrl2 register, offset:0x08

◆

union { ... } acc_type::@7

acc acc_c1 register, offset:0x0C

◆

union { ... } acc_type::@9

acc acc_c2 register, offset:0x10

◆ c1

__IO uint32_t acc_type::c1

Definition at line 125 of file at32f413_acc.h.

◆

struct { ... } acc_type::c1_bit

◆ c2

__IO uint32_t acc_type::c2

Definition at line 138 of file at32f413_acc.h.

◆

struct { ... } acc_type::c2_bit

◆ c3

__IO uint32_t acc_type::c3

Definition at line 151 of file at32f413_acc.h.

◆

struct { ... } acc_type::c3_bit

◆ calon

__IO uint32_t acc_type::calon

Definition at line 95 of file at32f413_acc.h.

◆ calrdy

__IO uint32_t acc_type::calrdy

Definition at line 81 of file at32f413_acc.h.

◆ calrdyien

__IO uint32_t acc_type::calrdyien

Definition at line 99 of file at32f413_acc.h.

◆ ctrl1

__IO uint32_t acc_type::ctrl1

Definition at line 92 of file at32f413_acc.h.

◆

struct { ... } acc_type::ctrl1_bit

◆ ctrl2

__IO uint32_t acc_type::ctrl2

Definition at line 111 of file at32f413_acc.h.

◆

struct { ... } acc_type::ctrl2_bit

◆ eien

__IO uint32_t acc_type::eien

Definition at line 98 of file at32f413_acc.h.

◆ entrim

__IO uint32_t acc_type::entrim

Definition at line 96 of file at32f413_acc.h.

◆ hickcal

__IO uint32_t acc_type::hickcal

Definition at line 114 of file at32f413_acc.h.

◆ hicktrim

__IO uint32_t acc_type::hicktrim

Definition at line 115 of file at32f413_acc.h.

◆ reserved1

__IO uint32_t acc_type::reserved1

Definition at line 83 of file at32f413_acc.h.

◆ reserved2

__IO uint32_t acc_type::reserved2

Definition at line 100 of file at32f413_acc.h.

◆ reserved3

__IO uint32_t acc_type::reserved3

Definition at line 102 of file at32f413_acc.h.

◆ rslost

__IO uint32_t acc_type::rslost

Definition at line 82 of file at32f413_acc.h.

◆ step

__IO uint32_t acc_type::step

Definition at line 101 of file at32f413_acc.h.

◆ sts

__IO uint32_t acc_type::sts

Definition at line 78 of file at32f413_acc.h.

◆

struct { ... } acc_type::sts_bit
The documentation for this struct was generated from the following file:
  • at32f413_acc.h


AT32F413 Firmwary Library: ACC_exported_functions

Functions
ACC_exported_functions
AT32F413_periph_driver » ACC

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

Function Documentation

◆ acc_calibration_mode_enable()

void acc_calibration_mode_enable | ( | uint16_t | acc_trim,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the acc calibration mode.

Parameters
acc_trim specifies the acc calibration type. this parameter can be one of the following values:
  • ACC_CAL_HICKCAL
  • ACC_CAL_HICKTRIM
new_state specifies the acc calibration to be enabled or disabled.(TRUE or FALSE)
Return values
none

< acc hick calibration

Definition at line 51 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_flag_clear()

void acc_flag_clear ( uint16_t acc_flag )

clear the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
none

Definition at line 199 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_flag_get()

flag_status acc_flag_get ( uint16_t acc_flag )

check whether the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be one of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
flag_status (SET or RESET)

< acc internal high-speed clock calibration ready error flag

Definition at line 183 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_hickcal_get()

uint8_t acc_hickcal_get ( void )

return the current acc hickcal value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 110 of file at32f413_acc.c.

◆ acc_hicktrim_get()

uint8_t acc_hicktrim_get ( void )

return the current acc hicktrim value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 100 of file at32f413_acc.c.

◆ acc_interrupt_enable()

void acc_interrupt_enable | ( | uint16_t | acc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified acc interrupts.

Parameters
acc_int specifies the acc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ACC_CALRDYIEN_INT
  • ACC_EIEN_INT
new_state (TRUE or FALSE)
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

Definition at line 83 of file at32f413_acc.c.

Referenced by main().

◆ acc_read_c1()

uint16_t acc_read_c1 ( void )

return the current acc c1 value.

Parameters
none
Return values
16-bit c1 value.

Definition at line 150 of file at32f413_acc.c.

◆ acc_read_c2()

uint16_t acc_read_c2 ( void )

return the current acc c2 value.

Parameters
none
Return values
16-bit c2 value.

Definition at line 160 of file at32f413_acc.c.

◆ acc_read_c3()

uint16_t acc_read_c3 ( void )

return the current acc c3 value.

Parameters
none
Return values
16-bit c3 value.

Definition at line 170 of file at32f413_acc.c.

◆ acc_step_set()

void acc_step_set ( uint8_t step_value )

store calibration step data in acc's ctrl1 register.

Parameters
step_value value to be stored in the acc's ctrl1 register
Return values
none

Definition at line 69 of file at32f413_acc.c.

◆ acc_write_c1()

void acc_write_c1 ( uint16_t acc_c1_value )

wtire the value to acc c1 register.

Parameters
acc_c1_value
Return values
none.

Definition at line 120 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c2()

void acc_write_c2 ( uint16_t acc_c2_value )

wtire the value to acc c2 register.

Parameters
acc_c2_value
Return values
none.

Definition at line 130 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c3()

void acc_write_c3 ( uint16_t acc_c3_value )

wtire the value to acc c3 register.

Parameters
acc_c3_value
Return values
none.

Definition at line 140 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().


AT32F413 Firmwary Library: ACC_private_functions

Functions
ACC_private_functions
AT32F413_periph_driver » ACC

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

Function Documentation

◆ acc_calibration_mode_enable()

void acc_calibration_mode_enable | ( | uint16_t | acc_trim,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the acc calibration mode.

Parameters
acc_trim specifies the acc calibration type. this parameter can be one of the following values:
  • ACC_CAL_HICKCAL
  • ACC_CAL_HICKTRIM
new_state specifies the acc calibration to be enabled or disabled.(TRUE or FALSE)
Return values
none

< acc hick calibration

Definition at line 51 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_flag_clear()

void acc_flag_clear ( uint16_t acc_flag )

clear the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
none

Definition at line 199 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_flag_get()

flag_status acc_flag_get ( uint16_t acc_flag )

check whether the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be one of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
flag_status (SET or RESET)

< acc internal high-speed clock calibration ready error flag

Definition at line 183 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_hickcal_get()

uint8_t acc_hickcal_get ( void )

return the current acc hickcal value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 110 of file at32f413_acc.c.

◆ acc_hicktrim_get()

uint8_t acc_hicktrim_get ( void )

return the current acc hicktrim value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 100 of file at32f413_acc.c.

◆ acc_interrupt_enable()

void acc_interrupt_enable | ( | uint16_t | acc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified acc interrupts.

Parameters
acc_int specifies the acc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ACC_CALRDYIEN_INT
  • ACC_EIEN_INT
new_state (TRUE or FALSE)
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

Definition at line 83 of file at32f413_acc.c.

Referenced by main().

◆ acc_read_c1()

uint16_t acc_read_c1 ( void )

return the current acc c1 value.

Parameters
none
Return values
16-bit c1 value.

Definition at line 150 of file at32f413_acc.c.

◆ acc_read_c2()

uint16_t acc_read_c2 ( void )

return the current acc c2 value.

Parameters
none
Return values
16-bit c2 value.

Definition at line 160 of file at32f413_acc.c.

◆ acc_read_c3()

uint16_t acc_read_c3 ( void )

return the current acc c3 value.

Parameters
none
Return values
16-bit c3 value.

Definition at line 170 of file at32f413_acc.c.

◆ acc_step_set()

void acc_step_set ( uint8_t step_value )

store calibration step data in acc's ctrl1 register.

Parameters
step_value value to be stored in the acc's ctrl1 register
Return values
none

Definition at line 69 of file at32f413_acc.c.

◆ acc_write_c1()

void acc_write_c1 ( uint16_t acc_c1_value )

wtire the value to acc c1 register.

Parameters
acc_c1_value
Return values
none.

Definition at line 120 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c2()

void acc_write_c2 ( uint16_t acc_c2_value )

wtire the value to acc c2 register.

Parameters
acc_c2_value
Return values
none.

Definition at line 130 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c3()

void acc_write_c3 ( uint16_t acc_c3_value )

wtire the value to acc c3 register.

Parameters
acc_c3_value
Return values
none.

Definition at line 140 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().


AT32F413 Firmwary Library: ADC

Modules | Macros
ADC
AT32F413_periph_driver

ADC driver modules. More...

Modules

ADC_interrupts_definition
adc interrupt
ADC_flags_definition
adc flag
ADC_exported_types
ADC_exported_functions
ADC_private_functions

Macros

#define | ADC1 ((adc_type *) ADC1_BASE)
#define | ADC2 ((adc_type *) ADC2_BASE)

Detailed Description

ADC driver modules.

Macro Definition Documentation

◆ ADC1

#define ADC1 ((adc_type *) ADC1_BASE)

Definition at line 557 of file at32f413_adc.h.

◆ ADC2

#define ADC2 ((adc_type *) ADC2_BASE)

Definition at line 558 of file at32f413_adc.h.


AT32F413 Firmwary Library: ADC_interrupts_definition

Macros
ADC_interrupts_definition
AT32F413_periph_driver » ADC

adc interrupt More...

Macros

#define | ADC_CCE_INT ((uint32_t)0x00000020)
#define | ADC_VMOR_INT ((uint32_t)0x00000040)
#define | ADC_PCCE_INT ((uint32_t)0x00000080)

Detailed Description

adc interrupt

Macro Definition Documentation

◆ ADC_CCE_INT

#define ADC_CCE_INT ((uint32_t)0x00000020)

channels conversion end interrupt

Definition at line 50 of file at32f413_adc.h.

◆ ADC_PCCE_INT

#define ADC_PCCE_INT ((uint32_t)0x00000080)

preempt channels conversion end interrupt

Definition at line 52 of file at32f413_adc.h.

◆ ADC_VMOR_INT

#define ADC_VMOR_INT ((uint32_t)0x00000040)

voltage monitoring out of range interrupt

Definition at line 51 of file at32f413_adc.h.


AT32F413 Firmwary Library: ADC_flags_definition

Macros
ADC_flags_definition
AT32F413_periph_driver » ADC

adc flag More...

Macros

#define | ADC_VMOR_FLAG ((uint8_t)0x01)
#define | ADC_CCE_FLAG ((uint8_t)0x02)
#define | ADC_PCCE_FLAG ((uint8_t)0x04)
#define | ADC_PCCS_FLAG ((uint8_t)0x08)
#define | ADC_OCCS_FLAG ((uint8_t)0x10)

Detailed Description

adc flag

Macro Definition Documentation

◆ ADC_CCE_FLAG

#define ADC_CCE_FLAG ((uint8_t)0x02)

channels conversion end flag

Definition at line 64 of file at32f413_adc.h.

◆ ADC_OCCS_FLAG

#define ADC_OCCS_FLAG ((uint8_t)0x10)

ordinary channel conversion start flag

Definition at line 67 of file at32f413_adc.h.

◆ ADC_PCCE_FLAG

#define ADC_PCCE_FLAG ((uint8_t)0x04)

preempt channels conversion end flag

Definition at line 65 of file at32f413_adc.h.

◆ ADC_PCCS_FLAG

#define ADC_PCCS_FLAG ((uint8_t)0x08)

preempt channel conversion start flag

Definition at line 66 of file at32f413_adc.h.

◆ ADC_VMOR_FLAG

#define ADC_VMOR_FLAG ((uint8_t)0x01)

voltage monitoring out of range flag

Definition at line 63 of file at32f413_adc.h.


AT32F413 Firmwary Library: ADC_exported_types

Data Structures | Enumerations
ADC_exported_types
AT32F413_periph_driver » ADC

Data Structures

struct | adc_base_config_type
adc base config type More...
struct | adc_type
type define adc register all More...

Enumerations

enum adc_combine_mode_type {
ADC_INDEPENDENT_MODE = 0x00 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE = 0x01 , ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE = 0x02 , ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE = 0x03 ,
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE = 0x04 , ADC_PREEMPT_SMLT_ONLY_MODE = 0x05 , ADC_ORDINARY_SMLT_ONLY_MODE = 0x06 , ADC_ORDINARY_SHORTSHIFT_ONLY_MODE = 0x07 ,
ADC_ORDINARY_LONGSHIFT_ONLY_MODE = 0x08 , ADC_PREEMPT_INTERLTRIG_ONLY_MODE = 0x09
}
adc combine mode type(these options are reserved in adc2) More...
enum | adc_data_align_type { ADC_RIGHT_ALIGNMENT = 0x00 , ADC_LEFT_ALIGNMENT = 0x01 }
adc data align type More...
enum adc_channel_select_type {
ADC_CHANNEL_0 = 0x00 , ADC_CHANNEL_1 = 0x01 , ADC_CHANNEL_2 = 0x02 , ADC_CHANNEL_3 = 0x03 ,
ADC_CHANNEL_4 = 0x04 , ADC_CHANNEL_5 = 0x05 , ADC_CHANNEL_6 = 0x06 , ADC_CHANNEL_7 = 0x07 ,
ADC_CHANNEL_8 = 0x08 , ADC_CHANNEL_9 = 0x09 , ADC_CHANNEL_10 = 0x0A , ADC_CHANNEL_11 = 0x0B ,
ADC_CHANNEL_12 = 0x0C , ADC_CHANNEL_13 = 0x0D , ADC_CHANNEL_14 = 0x0E , ADC_CHANNEL_15 = 0x0F ,
ADC_CHANNEL_16 = 0x10 , ADC_CHANNEL_17 = 0x11
}
adc channel select type More...
enum adc_sampletime_select_type {
ADC_SAMPLETIME_1_5 = 0x00 , ADC_SAMPLETIME_7_5 = 0x01 , ADC_SAMPLETIME_13_5 = 0x02 , ADC_SAMPLETIME_28_5 = 0x03 ,
ADC_SAMPLETIME_41_5 = 0x04 , ADC_SAMPLETIME_55_5 = 0x05 , ADC_SAMPLETIME_71_5 = 0x06 , ADC_SAMPLETIME_239_5 = 0x07
}
adc sampletime select type More...
enum adc_ordinary_trig_select_type {
ADC12_ORDINARY_TRIG_TMR1CH1 = 0x00 , ADC12_ORDINARY_TRIG_TMR1CH2 = 0x01 , ADC12_ORDINARY_TRIG_TMR1CH3 = 0x02 , ADC12_ORDINARY_TRIG_TMR2CH2 = 0x03 ,
ADC12_ORDINARY_TRIG_TMR3TRGOUT = 0x04 , ADC12_ORDINARY_TRIG_TMR4CH4 = 0x05 , ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT = 0x06 , ADC12_ORDINARY_TRIG_SOFTWARE = 0x07 ,
ADC12_ORDINARY_TRIG_TMR1TRGOUT = 0x0D , ADC12_ORDINARY_TRIG_TMR8CH1 = 0x0E , ADC12_ORDINARY_TRIG_TMR8CH2 = 0x0F
}
adc ordinary group trigger event select type More...
enum adc_preempt_trig_select_type {
ADC12_PREEMPT_TRIG_TMR1TRGOUT = 0x00 , ADC12_PREEMPT_TRIG_TMR1CH4 = 0x01 , ADC12_PREEMPT_TRIG_TMR2TRGOUT = 0x02 , ADC12_PREEMPT_TRIG_TMR2CH1 = 0x03 ,
ADC12_PREEMPT_TRIG_TMR3CH4 = 0x04 , ADC12_PREEMPT_TRIG_TMR4TRGOUT = 0x05 , ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 = 0x06 , ADC12_PREEMPT_TRIG_SOFTWARE = 0x07 ,
ADC12_PREEMPT_TRIG_TMR1CH1 = 0x0D , ADC12_PREEMPT_TRIG_TMR8CH1 = 0x0E , ADC12_PREEMPT_TRIG_TMR8TRGOUT = 0x0F
}
adc preempt group trigger event select type More...
enum | adc_preempt_channel_type { ADC_PREEMPT_CHANNEL_1 = 0x00 , ADC_PREEMPT_CHANNEL_2 = 0x01 , ADC_PREEMPT_CHANNEL_3 = 0x02 , ADC_PREEMPT_CHANNEL_4 = 0x03 }
adc preempt channel type More...
enum adc_voltage_monitoring_type {
ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200 , ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200 , ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200 , ADC_VMONITOR_ALL_ORDINARY = 0x00800000 ,
ADC_VMONITOR_ALL_PREEMPT = 0x00400000 , ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000 , ADC_VMONITOR_NONE = 0x00000000
}
adc voltage_monitoring type More...

Detailed Description

Enumeration Type Documentation

◆ adc_channel_select_type

enum adc_channel_select_type

adc channel select type

Enumerator
ADC_CHANNEL_0 | adc channel 0
ADC_CHANNEL_1 | adc channel 1
ADC_CHANNEL_2 | adc channel 2
ADC_CHANNEL_3 | adc channel 3
ADC_CHANNEL_4 | adc channel 4
ADC_CHANNEL_5 | adc channel 5
ADC_CHANNEL_6 | adc channel 6
ADC_CHANNEL_7 | adc channel 7
ADC_CHANNEL_8 | adc channel 8
ADC_CHANNEL_9 | adc channel 9
ADC_CHANNEL_10 | adc channel 10
ADC_CHANNEL_11 | adc channel 11
ADC_CHANNEL_12 | adc channel 12
ADC_CHANNEL_13 | adc channel 13
ADC_CHANNEL_14 | adc channel 14
ADC_CHANNEL_15 | adc channel 15
ADC_CHANNEL_16 | adc channel 16
ADC_CHANNEL_17 | adc channel 17

Definition at line 106 of file at32f413_adc.h.

◆ adc_combine_mode_type

enum adc_combine_mode_type

adc combine mode type(these options are reserved in adc2)

Enumerator
ADC_INDEPENDENT_MODE | independent mode
ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE | combined ordinary simultaneous + preempt simultaneous mode
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE | combined ordinary simultaneous + preempt interleaved trigger mode
ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE | combined ordinary short shifting + preempt simultaneous mode
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE | combined ordinary long shifting + preempt simultaneous mode
ADC_PREEMPT_SMLT_ONLY_MODE | preempt simultaneous mode only
ADC_ORDINARY_SMLT_ONLY_MODE | ordinary simultaneous mode only
ADC_ORDINARY_SHORTSHIFT_ONLY_MODE | ordinary short shifting mode only
ADC_ORDINARY_LONGSHIFT_ONLY_MODE | slow interleaved mode only
ADC_PREEMPT_INTERLTRIG_ONLY_MODE | alternate trigger mode only

Definition at line 80 of file at32f413_adc.h.

◆ adc_data_align_type

enum adc_data_align_type

adc data align type

Enumerator
ADC_RIGHT_ALIGNMENT | data right alignment
ADC_LEFT_ALIGNMENT | data left alignment

Definition at line 97 of file at32f413_adc.h.

◆ adc_ordinary_trig_select_type

enum adc_ordinary_trig_select_type

adc ordinary group trigger event select type

Enumerator
ADC12_ORDINARY_TRIG_TMR1CH1 | timer1 ch1 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR1CH2 | timer1 ch2 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR1CH3 | timer1 ch3 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR2CH2 | timer2 ch2 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR3TRGOUT | timer3 trgout event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR4CH4 | timer4 ch4 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT | exint line11/timer8 trgout event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_SOFTWARE | software(OCSWTRG) control bit as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR1TRGOUT | timer1 trgout event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR8CH1 | timer8 ch1 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR8CH2 | timer8 ch2 event as trigger source of adc1/adc2 ordinary sequence

Definition at line 146 of file at32f413_adc.h.

◆ adc_preempt_channel_type

enum adc_preempt_channel_type

adc preempt channel type

Enumerator
ADC_PREEMPT_CHANNEL_1 | adc preempt channel 1
ADC_PREEMPT_CHANNEL_2 | adc preempt channel 2
ADC_PREEMPT_CHANNEL_3 | adc preempt channel 3
ADC_PREEMPT_CHANNEL_4 | adc preempt channel 4

Definition at line 184 of file at32f413_adc.h.

◆ adc_preempt_trig_select_type

enum adc_preempt_trig_select_type

adc preempt group trigger event select type

Enumerator
ADC12_PREEMPT_TRIG_TMR1TRGOUT | timer1 trgout event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR1CH4 | timer1 ch4 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR2TRGOUT | timer2 trgout event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR2CH1 | timer2 ch1 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR3CH4 | timer3 ch4 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR4TRGOUT | timer4 trgout event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 | exint line15/timer8 ch4 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_SOFTWARE | software(PCSWTRG) control bit as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR1CH1 | timer1 ch1 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR8CH1 | timer8 ch1 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR8TRGOUT | timer8 trgout event as trigger source of adc1/adc2 preempt sequence

Definition at line 165 of file at32f413_adc.h.

◆ adc_sampletime_select_type

enum adc_sampletime_select_type

adc sampletime select type

Enumerator
ADC_SAMPLETIME_1_5 | adc sample time 1.5 cycle
ADC_SAMPLETIME_7_5 | adc sample time 7.5 cycle
ADC_SAMPLETIME_13_5 | adc sample time 13.5 cycle
ADC_SAMPLETIME_28_5 | adc sample time 28.5 cycle
ADC_SAMPLETIME_41_5 | adc sample time 41.5 cycle
ADC_SAMPLETIME_55_5 | adc sample time 55.5 cycle
ADC_SAMPLETIME_71_5 | adc sample time 71.5 cycle
ADC_SAMPLETIME_239_5 | adc sample time 239.5 cycle

Definition at line 131 of file at32f413_adc.h.

◆ adc_voltage_monitoring_type

enum adc_voltage_monitoring_type

adc voltage_monitoring type

Enumerator
ADC_VMONITOR_SINGLE_ORDINARY | voltage_monitoring on a single ordinary channel
ADC_VMONITOR_SINGLE_PREEMPT | voltage_monitoring on a single preempt channel
ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT | voltage_monitoring on a single ordinary or preempt channel
ADC_VMONITOR_ALL_ORDINARY | voltage_monitoring on all ordinary channel
ADC_VMONITOR_ALL_PREEMPT | voltage_monitoring on all preempt channel
ADC_VMONITOR_ALL_ORDINARY_PREEMPT | voltage_monitoring on all ordinary and preempt channel
ADC_VMONITOR_NONE | no channel guarded by the voltage_monitoring

Definition at line 195 of file at32f413_adc.h.


AT32F413 Firmwary Library: adc_base_config_type Struct Reference

Data Fields
adc_base_config_type Struct Reference
AT32F413_periph_driver » ADC » ADC_exported_types

adc base config type More...

#include <at32f413_adc.h>

Data Fields

confirm_state sequence_mode
confirm_state repeat_mode
adc_data_align_type data_align
uint8_t ordinary_channel_length

Detailed Description

adc base config type

Definition at line 209 of file at32f413_adc.h.

Field Documentation

◆ data_align

adc_data_align_type adc_base_config_type::data_align

adc data alignment

Definition at line 213 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

◆ ordinary_channel_length

uint8_t adc_base_config_type::ordinary_channel_length

adc ordinary channel sequence length

Definition at line 214 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

◆ repeat_mode

confirm_state adc_base_config_type::repeat_mode

adc repeat mode

Definition at line 212 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

◆ sequence_mode

confirm_state adc_base_config_type::sequence_mode

adc sequence mode

Definition at line 211 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

The documentation for this struct was generated from the following file:
  • at32f413_adc.h


AT32F413 Firmwary Library: adc_type Struct Reference

Data Fields
adc_type Struct Reference
AT32F413_periph_driver » ADC » ADC_exported_types

type define adc register all More...

#include <at32f413_adc.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t vmor: 1
__IO uint32_t cce: 1
__IO uint32_t pcce: 1
__IO uint32_t pccs: 1
__IO uint32_t occs: 1
__IO uint32_t reserved1: 27
} sts_bit
};
adc sts register, offset:0x00 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t vmcsel: 5
__IO uint32_t cceien: 1
__IO uint32_t vmorien: 1
__IO uint32_t pcceien: 1
__IO uint32_t sqen: 1
__IO uint32_t vmsgen: 1
__IO uint32_t pcautoen: 1
__IO uint32_t ocpen: 1
__IO uint32_t pcpen: 1
__IO uint32_t ocpcnt: 3
__IO uint32_t mssel: 4
__IO uint32_t reserved1: 2
__IO uint32_t pcvmen: 1
__IO uint32_t ocvmen: 1
__IO uint32_t reserved2: 8
} ctrl1_bit
};
adc ctrl1 register, offset:0x04 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t adcen: 1
__IO uint32_t rpen: 1
__IO uint32_t adcal: 1
__IO uint32_t adcalinit: 1
__IO uint32_t reserved1: 4
__IO uint32_t ocdmaen: 1
__IO uint32_t reserved2: 2
__IO uint32_t dtalign: 1
__IO uint32_t pctesel_l: 3
__IO uint32_t pcten: 1
__IO uint32_t reserved3: 1
__IO uint32_t octesel_l: 3
__IO uint32_t octen: 1
__IO uint32_t pcswtrg: 1
__IO uint32_t ocswtrg: 1
__IO uint32_t itsrven: 1
__IO uint32_t pctesel_h: 1
__IO uint32_t octesel_h: 1
__IO uint32_t reserved4: 6
} ctrl2_bit
};
adc ctrl2 register, offset:0x08 More...
union {
__IO uint32_t spt1
struct {
__IO uint32_t cspt10: 3
__IO uint32_t cspt11: 3
__IO uint32_t cspt12: 3
__IO uint32_t cspt13: 3
__IO uint32_t cspt14: 3
__IO uint32_t cspt15: 3
__IO uint32_t cspt16: 3
__IO uint32_t cspt17: 3
__IO uint32_t reserved1: 8
} spt1_bit
};
adc spt1 register, offset:0x0C More...
union {
__IO uint32_t spt2
struct {
__IO uint32_t cspt0: 3
__IO uint32_t cspt1: 3
__IO uint32_t cspt2: 3
__IO uint32_t cspt3: 3
__IO uint32_t cspt4: 3
__IO uint32_t cspt5: 3
__IO uint32_t cspt6: 3
__IO uint32_t cspt7: 3
__IO uint32_t cspt8: 3
__IO uint32_t cspt9: 3
__IO uint32_t reserved1: 2
} spt2_bit
};
adc spt2 register, offset:0x10 More...
union {
__IO uint32_t pcdto1
struct {
__IO uint32_t pcdto1: 12
__IO uint32_t reserved1: 20
} pcdto1_bit
};
adc pcdto1 register, offset:0x14 More...
union {
__IO uint32_t pcdto2
struct {
__IO uint32_t pcdto2: 12
__IO uint32_t reserved1: 20
} pcdto2_bit
};
adc pcdto2 register, offset:0x18 More...
union {
__IO uint32_t pcdto3
struct {
__IO uint32_t pcdto3: 12
__IO uint32_t reserved1: 20
} pcdto3_bit
};
adc pcdto3 register, offset:0x1C More...
union {
__IO uint32_t pcdto4
struct {
__IO uint32_t pcdto4: 12
__IO uint32_t reserved1: 20
} pcdto4_bit
};
adc pcdto4 register, offset:0x20 More...
union {
__IO uint32_t vmhb
struct {
__IO uint32_t vmhb: 12
__IO uint32_t reserved1: 20
} vmhb_bit
};
adc vmhb register, offset:0x24 More...
union {
__IO uint32_t vmlb
struct {
__IO uint32_t vmlb: 12
__IO uint32_t reserved1: 20
} vmlb_bit
};
adc vmlb register, offset:0x28 More...
union {
__IO uint32_t osq1
struct {
__IO uint32_t osn13: 5
__IO uint32_t osn14: 5
__IO uint32_t osn15: 5
__IO uint32_t osn16: 5
__IO uint32_t oclen: 4
__IO uint32_t reserved1: 8
} osq1_bit
};
adc osq1 register, offset:0x2C More...
union {
__IO uint32_t osq2
struct {
__IO uint32_t osn7: 5
__IO uint32_t osn8: 5
__IO uint32_t osn9: 5
__IO uint32_t osn10: 5
__IO uint32_t osn11: 5
__IO uint32_t osn12: 5
__IO uint32_t reserved1: 2
} osq2_bit
};
adc osq2 register, offset:0x30 More...
union {
__IO uint32_t osq3
struct {
__IO uint32_t osn1: 5
__IO uint32_t osn2: 5
__IO uint32_t osn3: 5
__IO uint32_t osn4: 5
__IO uint32_t osn5: 5
__IO uint32_t osn6: 5
__IO uint32_t reserved1: 2
} osq3_bit
};
adc osq3 register, offset:0x34 More...
union {
__IO uint32_t psq
struct {
__IO uint32_t psn1: 5
__IO uint32_t psn2: 5
__IO uint32_t psn3: 5
__IO uint32_t psn4: 5
__IO uint32_t pclen: 2
__IO uint32_t reserved1: 10
} psq_bit
};
adc psq register, offset:0x38 More...
union {
__IO uint32_t pdt1
struct {
__IO uint32_t pdt1: 16
__IO uint32_t reserved1: 16
} pdt1_bit
};
adc pdt1 register, offset:0x3C More...
union {
__IO uint32_t pdt2
struct {
__IO uint32_t pdt2: 16
__IO uint32_t reserved1: 16
} pdt2_bit
};
adc pdt2 register, offset:0x40 More...
union {
__IO uint32_t pdt3
struct {
__IO uint32_t pdt3: 16
__IO uint32_t reserved1: 16
} pdt3_bit
};
adc pdt3 register, offset:0x44 More...
union {
__IO uint32_t pdt4
struct {
__IO uint32_t pdt4: 16
__IO uint32_t reserved1: 16
} pdt4_bit
};
adc pdt4 register, offset:0x48 More...
union {
__IO uint32_t odt
struct {
__IO uint32_t odt: 16
__IO uint32_t adc2odt: 16
} odt_bit
};
adc odt register, offset:0x4C More...

Detailed Description

type define adc register all

Definition at line 220 of file at32f413_adc.h.

Field Documentation

◆

union { ... } adc_type::@19

adc sts register, offset:0x00

◆

union { ... } adc_type::@21

adc ctrl1 register, offset:0x04

◆

union { ... } adc_type::@23

adc ctrl2 register, offset:0x08

◆

union { ... } adc_type::@25

adc spt1 register, offset:0x0C

◆

union { ... } adc_type::@27

adc spt2 register, offset:0x10

◆

union { ... } adc_type::@29

adc pcdto1 register, offset:0x14

◆

union { ... } adc_type::@31

adc pcdto2 register, offset:0x18

◆

union { ... } adc_type::@33

adc pcdto3 register, offset:0x1C

◆

union { ... } adc_type::@35

adc pcdto4 register, offset:0x20

◆

union { ... } adc_type::@37

adc vmhb register, offset:0x24

◆

union { ... } adc_type::@39

adc vmlb register, offset:0x28

◆

union { ... } adc_type::@41

adc osq1 register, offset:0x2C

◆

union { ... } adc_type::@43

adc osq2 register, offset:0x30

◆

union { ... } adc_type::@45

adc osq3 register, offset:0x34

◆

union { ... } adc_type::@47

adc psq register, offset:0x38

◆

union { ... } adc_type::@49

adc pdt1 register, offset:0x3C

◆

union { ... } adc_type::@51

adc pdt2 register, offset:0x40

◆

union { ... } adc_type::@53

adc pdt3 register, offset:0x44

◆

union { ... } adc_type::@55

adc pdt4 register, offset:0x48

◆

union { ... } adc_type::@57

adc odt register, offset:0x4C

◆ adc2odt

__IO uint32_t adc_type::adc2odt

Definition at line 547 of file at32f413_adc.h.

◆ adcal

__IO uint32_t adc_type::adcal

Definition at line 276 of file at32f413_adc.h.

Referenced by adc_calibration_start(), and adc_calibration_status_get().

◆ adcalinit

__IO uint32_t adc_type::adcalinit

Definition at line 277 of file at32f413_adc.h.

Referenced by adc_calibration_init(), and adc_calibration_init_status_get().

◆ adcen

__IO uint32_t adc_type::adcen

Definition at line 274 of file at32f413_adc.h.

Referenced by adc_enable().

◆ cce

__IO uint32_t adc_type::cce

Definition at line 232 of file at32f413_adc.h.

◆ cceien

__IO uint32_t adc_type::cceien

Definition at line 249 of file at32f413_adc.h.

◆ cspt0

__IO uint32_t adc_type::cspt0

Definition at line 324 of file at32f413_adc.h.

◆ cspt1

__IO uint32_t adc_type::cspt1

Definition at line 325 of file at32f413_adc.h.

◆ cspt10

__IO uint32_t adc_type::cspt10

Definition at line 304 of file at32f413_adc.h.

◆ cspt11

__IO uint32_t adc_type::cspt11

Definition at line 305 of file at32f413_adc.h.

◆ cspt12

__IO uint32_t adc_type::cspt12

Definition at line 306 of file at32f413_adc.h.

◆ cspt13

__IO uint32_t adc_type::cspt13

Definition at line 307 of file at32f413_adc.h.

◆ cspt14

__IO uint32_t adc_type::cspt14

Definition at line 308 of file at32f413_adc.h.

◆ cspt15

__IO uint32_t adc_type::cspt15

Definition at line 309 of file at32f413_adc.h.

◆ cspt16

__IO uint32_t adc_type::cspt16

Definition at line 310 of file at32f413_adc.h.

◆ cspt17

__IO uint32_t adc_type::cspt17

Definition at line 311 of file at32f413_adc.h.

◆ cspt2

__IO uint32_t adc_type::cspt2

Definition at line 326 of file at32f413_adc.h.

◆ cspt3

__IO uint32_t adc_type::cspt3

Definition at line 327 of file at32f413_adc.h.

◆ cspt4

__IO uint32_t adc_type::cspt4

Definition at line 328 of file at32f413_adc.h.

◆ cspt5

__IO uint32_t adc_type::cspt5

Definition at line 329 of file at32f413_adc.h.

◆ cspt6

__IO uint32_t adc_type::cspt6

Definition at line 330 of file at32f413_adc.h.

◆ cspt7

__IO uint32_t adc_type::cspt7

Definition at line 331 of file at32f413_adc.h.

◆ cspt8

__IO uint32_t adc_type::cspt8

Definition at line 332 of file at32f413_adc.h.

◆ cspt9

__IO uint32_t adc_type::cspt9

Definition at line 333 of file at32f413_adc.h.

◆ ctrl1

__IO uint32_t adc_type::ctrl1

Definition at line 245 of file at32f413_adc.h.

Referenced by adc_interrupt_enable(), and adc_voltage_monitor_enable().

◆

struct { ... } adc_type::ctrl1_bit

Referenced by adc_base_config(), adc_ordinary_part_count_set(), adc_ordinary_part_mode_enable(), adc_preempt_auto_mode_enable(), adc_preempt_part_mode_enable(), adc_voltage_monitor_enable(), and adc_voltage_monitor_single_channel_select().

◆ ctrl2

__IO uint32_t adc_type::ctrl2

Definition at line 271 of file at32f413_adc.h.

◆

struct { ... } adc_type::ctrl2_bit

Referenced by adc_base_config(), adc_calibration_init(), adc_calibration_init_status_get(), adc_calibration_start(), adc_calibration_status_get(), adc_dma_mode_enable(), adc_enable(), adc_ordinary_conversion_trigger_set(), adc_ordinary_software_trigger_enable(), adc_ordinary_software_trigger_status_get(), adc_preempt_conversion_trigger_set(), adc_preempt_software_trigger_enable(), and adc_preempt_software_trigger_status_get().

◆ dtalign

__IO uint32_t adc_type::dtalign

Definition at line 281 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ itsrven

__IO uint32_t adc_type::itsrven

Definition at line 289 of file at32f413_adc.h.

◆ mssel

__IO uint32_t adc_type::mssel

Definition at line 258 of file at32f413_adc.h.

◆ occs

__IO uint32_t adc_type::occs

Definition at line 235 of file at32f413_adc.h.

◆ ocdmaen

__IO uint32_t adc_type::ocdmaen

Definition at line 279 of file at32f413_adc.h.

Referenced by adc_dma_mode_enable().

◆ oclen

__IO uint32_t adc_type::oclen

Definition at line 428 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ ocpcnt

__IO uint32_t adc_type::ocpcnt

Definition at line 257 of file at32f413_adc.h.

Referenced by adc_ordinary_part_count_set().

◆ ocpen

__IO uint32_t adc_type::ocpen

Definition at line 255 of file at32f413_adc.h.

Referenced by adc_ordinary_part_mode_enable().

◆ ocswtrg

__IO uint32_t adc_type::ocswtrg

Definition at line 288 of file at32f413_adc.h.

Referenced by adc_ordinary_software_trigger_enable(), and adc_ordinary_software_trigger_status_get().

◆ octen

__IO uint32_t adc_type::octen

Definition at line 286 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ octesel_h

__IO uint32_t adc_type::octesel_h

Definition at line 291 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ octesel_l

__IO uint32_t adc_type::octesel_l

Definition at line 285 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ ocvmen

__IO uint32_t adc_type::ocvmen

Definition at line 261 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_enable().

◆ odt

__IO uint32_t adc_type::odt

Definition at line 543 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_data_get().

◆

struct { ... } adc_type::odt_bit

Referenced by adc_ordinary_conversion_data_get().

◆ osn1

__IO uint32_t adc_type::osn1

Definition at line 459 of file at32f413_adc.h.

◆ osn10

__IO uint32_t adc_type::osn10

Definition at line 444 of file at32f413_adc.h.

◆ osn11

__IO uint32_t adc_type::osn11

Definition at line 445 of file at32f413_adc.h.

◆ osn12

__IO uint32_t adc_type::osn12

Definition at line 446 of file at32f413_adc.h.

◆ osn13

__IO uint32_t adc_type::osn13

Definition at line 424 of file at32f413_adc.h.

◆ osn14

__IO uint32_t adc_type::osn14

Definition at line 425 of file at32f413_adc.h.

◆ osn15

__IO uint32_t adc_type::osn15

Definition at line 426 of file at32f413_adc.h.

◆ osn16

__IO uint32_t adc_type::osn16

Definition at line 427 of file at32f413_adc.h.

◆ osn2

__IO uint32_t adc_type::osn2

Definition at line 460 of file at32f413_adc.h.

◆ osn3

__IO uint32_t adc_type::osn3

Definition at line 461 of file at32f413_adc.h.

◆ osn4

__IO uint32_t adc_type::osn4

Definition at line 462 of file at32f413_adc.h.

◆ osn5

__IO uint32_t adc_type::osn5

Definition at line 463 of file at32f413_adc.h.

◆ osn6

__IO uint32_t adc_type::osn6

Definition at line 464 of file at32f413_adc.h.

◆ osn7

__IO uint32_t adc_type::osn7

Definition at line 441 of file at32f413_adc.h.

◆ osn8

__IO uint32_t adc_type::osn8

Definition at line 442 of file at32f413_adc.h.

◆ osn9

__IO uint32_t adc_type::osn9

Definition at line 443 of file at32f413_adc.h.

◆ osq1

__IO uint32_t adc_type::osq1

Definition at line 421 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆

struct { ... } adc_type::osq1_bit

Referenced by adc_base_config().

◆ osq2

__IO uint32_t adc_type::osq2

Definition at line 438 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆

struct { ... } adc_type::osq2_bit

◆ osq3

__IO uint32_t adc_type::osq3

Definition at line 456 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆

struct { ... } adc_type::osq3_bit

◆ pcautoen

__IO uint32_t adc_type::pcautoen

Definition at line 254 of file at32f413_adc.h.

Referenced by adc_preempt_auto_mode_enable().

◆ pcce

__IO uint32_t adc_type::pcce

Definition at line 233 of file at32f413_adc.h.

◆ pcceien

__IO uint32_t adc_type::pcceien

Definition at line 251 of file at32f413_adc.h.

◆ pccs

__IO uint32_t adc_type::pccs

Definition at line 234 of file at32f413_adc.h.

◆ pcdto1

__IO uint32_t adc_type::pcdto1

Definition at line 343 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto1_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto2

__IO uint32_t adc_type::pcdto2

Definition at line 356 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto2_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto3

__IO uint32_t adc_type::pcdto3

Definition at line 369 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto3_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto4

__IO uint32_t adc_type::pcdto4

Definition at line 382 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto4_bit

Referenced by adc_preempt_offset_value_set().

◆ pclen

__IO uint32_t adc_type::pclen

Definition at line 481 of file at32f413_adc.h.

Referenced by adc_preempt_channel_length_set(), and adc_preempt_channel_set().

◆ pcpen

__IO uint32_t adc_type::pcpen

Definition at line 256 of file at32f413_adc.h.

Referenced by adc_preempt_part_mode_enable().

◆ pcswtrg

__IO uint32_t adc_type::pcswtrg

Definition at line 287 of file at32f413_adc.h.

Referenced by adc_preempt_software_trigger_enable(), and adc_preempt_software_trigger_status_get().

◆ pcten

__IO uint32_t adc_type::pcten

Definition at line 283 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pctesel_h

__IO uint32_t adc_type::pctesel_h

Definition at line 290 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pctesel_l

__IO uint32_t adc_type::pctesel_l

Definition at line 282 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pcvmen

__IO uint32_t adc_type::pcvmen

Definition at line 260 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_enable().

◆ pdt1

__IO uint32_t adc_type::pdt1

Definition at line 491 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt1_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt2

__IO uint32_t adc_type::pdt2

Definition at line 504 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt2_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt3

__IO uint32_t adc_type::pdt3

Definition at line 517 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt3_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt4

__IO uint32_t adc_type::pdt4

Definition at line 530 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt4_bit

Referenced by adc_preempt_conversion_data_get().

◆ psn1

__IO uint32_t adc_type::psn1

Definition at line 477 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn2

__IO uint32_t adc_type::psn2

Definition at line 478 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn3

__IO uint32_t adc_type::psn3

Definition at line 479 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn4

__IO uint32_t adc_type::psn4

Definition at line 480 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psq

__IO uint32_t adc_type::psq

Definition at line 474 of file at32f413_adc.h.

◆

struct { ... } adc_type::psq_bit

Referenced by adc_preempt_channel_length_set(), and adc_preempt_channel_set().

◆ reserved1

__IO uint32_t adc_type::reserved1

Definition at line 236 of file at32f413_adc.h.

◆ reserved2

__IO uint32_t adc_type::reserved2

Definition at line 262 of file at32f413_adc.h.

◆ reserved3

__IO uint32_t adc_type::reserved3

Definition at line 284 of file at32f413_adc.h.

◆ reserved4

__IO uint32_t adc_type::reserved4

Definition at line 292 of file at32f413_adc.h.

◆ rpen

__IO uint32_t adc_type::rpen

Definition at line 275 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ spt1

__IO uint32_t adc_type::spt1

Definition at line 301 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆

struct { ... } adc_type::spt1_bit

◆ spt2

__IO uint32_t adc_type::spt2

Definition at line 321 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆

struct { ... } adc_type::spt2_bit

◆ sqen

__IO uint32_t adc_type::sqen

Definition at line 252 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ sts

__IO uint32_t adc_type::sts

Definition at line 228 of file at32f413_adc.h.

Referenced by adc_flag_clear(), and adc_flag_get().

◆

struct { ... } adc_type::sts_bit

◆ vmcsel

__IO uint32_t adc_type::vmcsel

Definition at line 248 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_single_channel_select().

◆ vmhb

__IO uint32_t adc_type::vmhb

Definition at line 395 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_threshold_value_set().

◆

struct { ... } adc_type::vmhb_bit

Referenced by adc_voltage_monitor_threshold_value_set().

◆ vmlb

__IO uint32_t adc_type::vmlb

Definition at line 408 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_threshold_value_set().

◆

struct { ... } adc_type::vmlb_bit

Referenced by adc_voltage_monitor_threshold_value_set().

◆ vmor

__IO uint32_t adc_type::vmor

Definition at line 231 of file at32f413_adc.h.

◆ vmorien

__IO uint32_t adc_type::vmorien

Definition at line 250 of file at32f413_adc.h.

◆ vmsgen

__IO uint32_t adc_type::vmsgen

Definition at line 253 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_enable().

The documentation for this struct was generated from the following file:
  • at32f413_adc.h


AT32F413 Firmwary Library: ADC_exported_functions

Functions
ADC_exported_functions
AT32F413_periph_driver » ADC

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

Function Documentation

◆ adc_base_config()

void adc_base_config | ( | adc_type * | adc_x,
 |  | adc_base_config_type * | adc_base_struct
 | ) |  |

initialize the adc peripheral according to the specified parameters.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0x10)
Return values
none

Definition at line 141 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_base_default_para_init()

void adc_base_default_para_init ( adc_base_config_type * adc_base_struct )

adc base default para init.

Parameters
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0x10)
Return values
none

Definition at line 115 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init()

void adc_calibration_init ( adc_type * adc_x )

initialize calibration register of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 197 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init_status_get()

flag_status adc_calibration_init_status_get ( adc_type * adc_x )

get calibration register's initialize status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of reset calibration register status(SET or RESET).

Definition at line 209 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_start()

void adc_calibration_start ( adc_type * adc_x )

start calibration process of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 228 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_status_get()

flag_status adc_calibration_status_get ( adc_type * adc_x )

get calibration status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of calibration status(SET or RESET).

Definition at line 240 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_mode_select()

void adc_combine_mode_select ( adc_combine_mode_type combine_mode )

select combine mode of the specified adc peripheral.

Parameters
combine_mode select the adc combine mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
  • ADC_PREEMPT_SMLT_ONLY_MODE
  • ADC_ORDINARY_SMLT_ONLY_MODE
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE note:these bits are reserved in adc2
Return values
none

Definition at line 95 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_ordinary_conversion_data_get()

uint32_t adc_combine_ordinary_conversion_data_get ( void )

return the last conversion data for ordinary channel of combine adc(adc1 and adc2).

Return values
the last conversion data for ordinary channel.

Definition at line 715 of file at32f413_adc.c.

◆ adc_dma_mode_enable()

void adc_dma_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma transfer.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1. note:this bit is reserved in adc2
new_state | new state of the adc dma transfer. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 159 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_enable()

void adc_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of a/d converter. this parameter can be: TRUE or FALSE. note:after adc ready,user set adcen bit will cause ordinary conversion
Return values
none

Definition at line 73 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_flag_clear()

void adc_flag_clear | ( | adc_type * | adc_x,
 |  | uint32_t | adc_flag
 | ) |  |

clear flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be any combination of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG(also can clear by reading the adc_x->odt)
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG
  • ADC_OCCS_FLAG
Return values
none

Definition at line 799 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_flag_get()

flag_status adc_flag_get | ( | adc_type * | adc_x,
 |  | uint8_t | adc_flag
 | ) |  |

get flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be one of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG(no interrupt associated)
  • ADC_OCCS_FLAG(no interrupt associated)
Return values
the new state of adc flag status(SET or RESET).

Definition at line 770 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_interrupt_enable()

void adc_interrupt_enable | ( | adc_type * | adc_x,
 |  | uint32_t | adc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc interrupts.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_int specifies the adc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ADC_VMOR_INT
  • ADC_CCE_INT
  • ADC_PCCE_INT
new_state | new state of the specified adc interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 178 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_channel_set()

void adc_ordinary_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the ordinary group sequencer. this parameter must be:
  • between 1 to 16
adc_sampletime set the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 341 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_conversion_data_get()

uint16_t adc_ordinary_conversion_data_get ( adc_type * adc_x )

return the last conversion data for ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the last conversion data for ordinary channel.

Definition at line 706 of file at32f413_adc.c.

◆ adc_ordinary_conversion_trigger_set()

void adc_ordinary_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_trig_select_type | adc_ordinary_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_ordinary_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_ORDINARY_TRIG_TMR1CH1 - ADC12_ORDINARY_TRIG_TMR1CH2 - ADC12_ORDINARY_TRIG_TMR1CH3 - ADC12_ORDINARY_TRIG_TMR2CH2
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT - ADC12_ORDINARY_TRIG_TMR4CH4 - ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT - ADC12_ORDINARY_TRIG_SOFTWARE
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT - ADC12_ORDINARY_TRIG_TMR8CH1 - ADC12_ORDINARY_TRIG_TMR8CH2
new_state | new state of ordinary channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 479 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_count_set()

void adc_ordinary_part_count_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_count
 | ) |  |

set partitioned mode channel count of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_count configure the adc partitioned mode channel count. this parameter can be:
  • (0x1~0x8)
Return values
none

Definition at line 573 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_mode_enable()

void adc_ordinary_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 588 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_software_trigger_enable()

void adc_ordinary_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ordinary software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 642 of file at32f413_adc.c.

Referenced by main().

◆ adc_ordinary_software_trigger_status_get()

flag_status adc_ordinary_software_trigger_status_get ( adc_type * adc_x )

get ordinary software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of ordinary software start conversion status(SET or RESET).

Definition at line 654 of file at32f413_adc.c.

◆ adc_preempt_auto_mode_enable()

void adc_preempt_auto_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable automatic preempt group conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of automatic preempt group conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 616 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_length_set()

void adc_preempt_channel_length_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_lenght
 | ) |  |

set preempt channel lenghth of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_lenght set the adc preempt channel lenghth. this parameter can be:
  • (0x1~0x4)
Return values
none

Definition at line 392 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_set()

void adc_preempt_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the preempt group sequencer. this parameter must be:
  • between 1 to 4
adc_sampletime config the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 424 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_conversion_data_get()

uint16_t adc_preempt_conversion_data_get | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel
 | ) |  |

return the conversion data for selection preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPTED_CHANNEL_1
  • ADC_PREEMPTED_CHANNEL_2
  • ADC_PREEMPTED_CHANNEL_3
  • ADC_PREEMPTED_CHANNEL_4
Return values
the conversion data for selection preempt channel.

Definition at line 733 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_preempt_conversion_trigger_set()

void adc_preempt_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_preempt_trig_select_type | adc_preempt_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT - ADC12_PREEMPT_TRIG_TMR1CH4 - ADC12_PREEMPT_TRIG_TMR2TRGOUT - ADC12_PREEMPT_TRIG_TMR2CH1
  • ADC12_PREEMPT_TRIG_TMR3CH4 - ADC12_PREEMPT_TRIG_TMR4TRGOUT - ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 - ADC12_PREEMPT_TRIG_SOFTWARE
  • ADC12_PREEMPT_TRIG_TMR1CH1 - ADC12_PREEMPT_TRIG_TMR8CH1 - ADC12_PREEMPT_TRIG_TMR8TRGOUT
new_state | new state of preempt channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 510 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_offset_value_set()

void adc_preempt_offset_value_set | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel,
 |  | uint16_t | adc_offset_value
 | ) |  |

set preempt channel's conversion value offset of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
adc_offset_value set the adc preempt channel's conversion value offset. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 542 of file at32f413_adc.c.

◆ adc_preempt_part_mode_enable()

void adc_preempt_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on preempt channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 602 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_enable()

void adc_preempt_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable preempt software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 675 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_status_get()

flag_status adc_preempt_software_trigger_status_get ( adc_type * adc_x )

get preempt software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of preempt software start conversion status(SET or RESET).

Definition at line 687 of file at32f413_adc.c.

◆ adc_reset()

void adc_reset ( adc_type * adc_x )

deinitialize the adc peripheral registers to their default reset values.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 49 of file at32f413_adc.c.

◆ adc_tempersensor_vintrv_enable()

void adc_tempersensor_vintrv_enable ( confirm_state new_state )

enable or disable the temperature sensor and vintrv channel.

Parameters
new_state new state of Internal temperature sensor and vintrv. this parameter can be: TRUE or FALSE. note:this bit is present only in adc1
Return values
none

Definition at line 628 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_enable()

void adc_voltage_monitor_enable | ( | adc_type * | adc_x,
 |  | adc_voltage_monitoring_type | adc_voltage_monitoring
 | ) |  |

enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_voltage_monitoring choose the adc_voltage_monitoring config. this parameter can be one of the following values:
  • ADC_VMONITOR_SINGLE_ORDINARY
  • ADC_VMONITOR_SINGLE_PREEMPT
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY
  • ADC_VMONITOR_ALL_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT
  • ADC_VMONITOR_NONE
Return values
none

Definition at line 268 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_single_channel_select()

void adc_voltage_monitor_single_channel_select | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel
 | ) |  |

select the voltage monitoring's channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
Return values
none

Definition at line 309 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_threshold_value_set()

void adc_voltage_monitor_threshold_value_set | ( | adc_type * | adc_x,
 |  | uint16_t | adc_high_threshold,
 |  | uint16_t | adc_low_threshold
 | ) |  |

set voltage monitoring's high and low thresholds value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_high_threshold voltage monitoring's high thresholds value. this parameter can be:
  • (0x000~0xFFF)
adc_low_threshold voltage monitoring's low thresholds value. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 289 of file at32f413_adc.c.

Referenced by adc_config().


AT32F413 Firmwary Library: ADC_private_functions

Functions
ADC_private_functions
AT32F413_periph_driver » ADC

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

Function Documentation

◆ adc_base_config()

void adc_base_config | ( | adc_type * | adc_x,
 |  | adc_base_config_type * | adc_base_struct
 | ) |  |

initialize the adc peripheral according to the specified parameters.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0x10)
Return values
none

Definition at line 141 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_base_default_para_init()

void adc_base_default_para_init ( adc_base_config_type * adc_base_struct )

adc base default para init.

Parameters
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0x10)
Return values
none

Definition at line 115 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init()

void adc_calibration_init ( adc_type * adc_x )

initialize calibration register of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 197 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init_status_get()

flag_status adc_calibration_init_status_get ( adc_type * adc_x )

get calibration register's initialize status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of reset calibration register status(SET or RESET).

Definition at line 209 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_start()

void adc_calibration_start ( adc_type * adc_x )

start calibration process of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 228 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_status_get()

flag_status adc_calibration_status_get ( adc_type * adc_x )

get calibration status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of calibration status(SET or RESET).

Definition at line 240 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_mode_select()

void adc_combine_mode_select ( adc_combine_mode_type combine_mode )

select combine mode of the specified adc peripheral.

Parameters
combine_mode select the adc combine mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
  • ADC_PREEMPT_SMLT_ONLY_MODE
  • ADC_ORDINARY_SMLT_ONLY_MODE
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE note:these bits are reserved in adc2
Return values
none

Definition at line 95 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_ordinary_conversion_data_get()

uint32_t adc_combine_ordinary_conversion_data_get ( void )

return the last conversion data for ordinary channel of combine adc(adc1 and adc2).

Return values
the last conversion data for ordinary channel.

Definition at line 715 of file at32f413_adc.c.

◆ adc_dma_mode_enable()

void adc_dma_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma transfer.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1. note:this bit is reserved in adc2
new_state | new state of the adc dma transfer. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 159 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_enable()

void adc_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of a/d converter. this parameter can be: TRUE or FALSE. note:after adc ready,user set adcen bit will cause ordinary conversion
Return values
none

Definition at line 73 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_flag_clear()

void adc_flag_clear | ( | adc_type * | adc_x,
 |  | uint32_t | adc_flag
 | ) |  |

clear flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be any combination of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG(also can clear by reading the adc_x->odt)
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG
  • ADC_OCCS_FLAG
Return values
none

Definition at line 799 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_flag_get()

flag_status adc_flag_get | ( | adc_type * | adc_x,
 |  | uint8_t | adc_flag
 | ) |  |

get flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be one of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG(no interrupt associated)
  • ADC_OCCS_FLAG(no interrupt associated)
Return values
the new state of adc flag status(SET or RESET).

Definition at line 770 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_interrupt_enable()

void adc_interrupt_enable | ( | adc_type * | adc_x,
 |  | uint32_t | adc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc interrupts.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_int specifies the adc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ADC_VMOR_INT
  • ADC_CCE_INT
  • ADC_PCCE_INT
new_state | new state of the specified adc interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 178 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_channel_set()

void adc_ordinary_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the ordinary group sequencer. this parameter must be:
  • between 1 to 16
adc_sampletime set the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 341 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_conversion_data_get()

uint16_t adc_ordinary_conversion_data_get ( adc_type * adc_x )

return the last conversion data for ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the last conversion data for ordinary channel.

Definition at line 706 of file at32f413_adc.c.

◆ adc_ordinary_conversion_trigger_set()

void adc_ordinary_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_trig_select_type | adc_ordinary_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_ordinary_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_ORDINARY_TRIG_TMR1CH1 - ADC12_ORDINARY_TRIG_TMR1CH2 - ADC12_ORDINARY_TRIG_TMR1CH3 - ADC12_ORDINARY_TRIG_TMR2CH2
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT - ADC12_ORDINARY_TRIG_TMR4CH4 - ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT - ADC12_ORDINARY_TRIG_SOFTWARE
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT - ADC12_ORDINARY_TRIG_TMR8CH1 - ADC12_ORDINARY_TRIG_TMR8CH2
new_state | new state of ordinary channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 479 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_count_set()

void adc_ordinary_part_count_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_count
 | ) |  |

set partitioned mode channel count of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_count configure the adc partitioned mode channel count. this parameter can be:
  • (0x1~0x8)
Return values
none

Definition at line 573 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_mode_enable()

void adc_ordinary_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 588 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_software_trigger_enable()

void adc_ordinary_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ordinary software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 642 of file at32f413_adc.c.

Referenced by main().

◆ adc_ordinary_software_trigger_status_get()

flag_status adc_ordinary_software_trigger_status_get ( adc_type * adc_x )

get ordinary software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of ordinary software start conversion status(SET or RESET).

Definition at line 654 of file at32f413_adc.c.

◆ adc_preempt_auto_mode_enable()

void adc_preempt_auto_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable automatic preempt group conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of automatic preempt group conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 616 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_length_set()

void adc_preempt_channel_length_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_lenght
 | ) |  |

set preempt channel lenghth of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_lenght set the adc preempt channel lenghth. this parameter can be:
  • (0x1~0x4)
Return values
none

Definition at line 392 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_set()

void adc_preempt_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the preempt group sequencer. this parameter must be:
  • between 1 to 4
adc_sampletime config the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 424 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_conversion_data_get()

uint16_t adc_preempt_conversion_data_get | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel
 | ) |  |

return the conversion data for selection preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPTED_CHANNEL_1
  • ADC_PREEMPTED_CHANNEL_2
  • ADC_PREEMPTED_CHANNEL_3
  • ADC_PREEMPTED_CHANNEL_4
Return values
the conversion data for selection preempt channel.

Definition at line 733 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_preempt_conversion_trigger_set()

void adc_preempt_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_preempt_trig_select_type | adc_preempt_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT - ADC12_PREEMPT_TRIG_TMR1CH4 - ADC12_PREEMPT_TRIG_TMR2TRGOUT - ADC12_PREEMPT_TRIG_TMR2CH1
  • ADC12_PREEMPT_TRIG_TMR3CH4 - ADC12_PREEMPT_TRIG_TMR4TRGOUT - ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 - ADC12_PREEMPT_TRIG_SOFTWARE
  • ADC12_PREEMPT_TRIG_TMR1CH1 - ADC12_PREEMPT_TRIG_TMR8CH1 - ADC12_PREEMPT_TRIG_TMR8TRGOUT
new_state | new state of preempt channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 510 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_offset_value_set()

void adc_preempt_offset_value_set | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel,
 |  | uint16_t | adc_offset_value
 | ) |  |

set preempt channel's conversion value offset of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
adc_offset_value set the adc preempt channel's conversion value offset. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 542 of file at32f413_adc.c.

◆ adc_preempt_part_mode_enable()

void adc_preempt_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on preempt channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 602 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_enable()

void adc_preempt_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable preempt software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 675 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_status_get()

flag_status adc_preempt_software_trigger_status_get ( adc_type * adc_x )

get preempt software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of preempt software start conversion status(SET or RESET).

Definition at line 687 of file at32f413_adc.c.

◆ adc_reset()

void adc_reset ( adc_type * adc_x )

deinitialize the adc peripheral registers to their default reset values.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 49 of file at32f413_adc.c.

◆ adc_tempersensor_vintrv_enable()

void adc_tempersensor_vintrv_enable ( confirm_state new_state )

enable or disable the temperature sensor and vintrv channel.

Parameters
new_state new state of Internal temperature sensor and vintrv. this parameter can be: TRUE or FALSE. note:this bit is present only in adc1
Return values
none

Definition at line 628 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_enable()

void adc_voltage_monitor_enable | ( | adc_type * | adc_x,
 |  | adc_voltage_monitoring_type | adc_voltage_monitoring
 | ) |  |

enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_voltage_monitoring choose the adc_voltage_monitoring config. this parameter can be one of the following values:
  • ADC_VMONITOR_SINGLE_ORDINARY
  • ADC_VMONITOR_SINGLE_PREEMPT
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY
  • ADC_VMONITOR_ALL_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT
  • ADC_VMONITOR_NONE
Return values
none

Definition at line 268 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_single_channel_select()

void adc_voltage_monitor_single_channel_select | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel
 | ) |  |

select the voltage monitoring's channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
Return values
none

Definition at line 309 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_threshold_value_set()

void adc_voltage_monitor_threshold_value_set | ( | adc_type * | adc_x,
 |  | uint16_t | adc_high_threshold,
 |  | uint16_t | adc_low_threshold
 | ) |  |

set voltage monitoring's high and low thresholds value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_high_threshold voltage monitoring's high thresholds value. this parameter can be:
  • (0x000~0xFFF)
adc_low_threshold voltage monitoring's low thresholds value. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 289 of file at32f413_adc.c.

Referenced by adc_config().


AT32F413 Firmwary Library: BPR

Modules | Macros
BPR
AT32F413_periph_driver

BPR driver modules. More...

Modules

BPR_flags_definition
bpr flag
BPR_exported_types
BPR_exported_functions
BPR_private_functions

Macros

#define BPR ((bpr_type *) BPR_BASE)

Detailed Description

BPR driver modules.

Macro Definition Documentation

◆ BPR

#define BPR ((bpr_type *) BPR_BASE)

Definition at line 754 of file at32f413_bpr.h.


AT32F413 Firmwary Library: BPR_flags_definition

Macros
BPR_flags_definition
AT32F413_periph_driver » BPR

bpr flag More...

Macros

#define | BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)
#define | BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)

Detailed Description

bpr flag

Macro Definition Documentation

◆ BPR_TAMPER_EVENT_FLAG

#define BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)

bpr tamper event flag

Definition at line 51 of file at32f413_bpr.h.

◆ BPR_TAMPER_INTERRUPT_FLAG

#define BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)

bpr tamper interrupt flag

Definition at line 50 of file at32f413_bpr.h.


AT32F413 Firmwary Library: BPR_exported_types

Data Structures | Enumerations
BPR_exported_types
AT32F413_periph_driver » BPR

Data Structures

struct bpr_type
type define bpr register all More...

Enumerations

enum bpr_data_type {
BPR_DATA1 = 0x04 , BPR_DATA2 = 0x08 , BPR_DATA3 = 0x0C , BPR_DATA4 = 0x10 ,
BPR_DATA5 = 0x14 , BPR_DATA6 = 0x18 , BPR_DATA7 = 0x1C , BPR_DATA8 = 0x20 ,
BPR_DATA9 = 0x24 , BPR_DATA10 = 0x28 , BPR_DATA11 = 0x40 , BPR_DATA12 = 0x44 ,
BPR_DATA13 = 0x48 , BPR_DATA14 = 0x4C , BPR_DATA15 = 0x50 , BPR_DATA16 = 0x54 ,
BPR_DATA17 = 0x58 , BPR_DATA18 = 0x5C , BPR_DATA19 = 0x60 , BPR_DATA20 = 0x64 ,
BPR_DATA21 = 0x68 , BPR_DATA22 = 0x6C , BPR_DATA23 = 0x70 , BPR_DATA24 = 0x74 ,
BPR_DATA25 = 0x78 , BPR_DATA26 = 0x7C , BPR_DATA27 = 0x80 , BPR_DATA28 = 0x84 ,
BPR_DATA29 = 0x88 , BPR_DATA30 = 0x8C , BPR_DATA31 = 0x90 , BPR_DATA32 = 0x94 ,
BPR_DATA33 = 0x98 , BPR_DATA34 = 0x9C , BPR_DATA35 = 0xA0 , BPR_DATA36 = 0xA4 ,
BPR_DATA37 = 0xA8 , BPR_DATA38 = 0xAC , BPR_DATA39 = 0xB0 , BPR_DATA40 = 0xB4 ,
BPR_DATA41 = 0xB8 , BPR_DATA42 = 0xBC
}
battery powered register data type More...
enum bpr_rtc_output_type {
BPR_RTC_OUTPUT_NONE = 0x000 , BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE = 0x080 , BPR_RTC_OUTPUT_ALARM = 0x100 , BPR_RTC_OUTPUT_SECOND = 0x300 ,
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER = 0x480 , BPR_RTC_OUTPUT_ALARM_TOGGLE = 0x900 , BPR_RTC_OUTPUT_SECOND_TOGGLE = 0xB00
}
bpr rtc output type More...
enum bpr_tamper_pin_active_level_type { BPR_TAMPER_PIN_ACTIVE_HIGH = 0x00 , BPR_TAMPER_PIN_ACTIVE_LOW = 0x01 }
tamper pin active level type More...

Detailed Description

Enumeration Type Documentation

◆ bpr_data_type

enum bpr_data_type

battery powered register data type

Enumerator
BPR_DATA1 | bpr data register 1
BPR_DATA2 | bpr data register 2
BPR_DATA3 | bpr data register 3
BPR_DATA4 | bpr data register 4
BPR_DATA5 | bpr data register 5
BPR_DATA6 | bpr data register 6
BPR_DATA7 | bpr data register 7
BPR_DATA8 | bpr data register 8
BPR_DATA9 | bpr data register 9
BPR_DATA10 | bpr data register 10
BPR_DATA11 | bpr data register 11
BPR_DATA12 | bpr data register 12
BPR_DATA13 | bpr data register 13
BPR_DATA14 | bpr data register 14
BPR_DATA15 | bpr data register 15
BPR_DATA16 | bpr data register 16
BPR_DATA17 | bpr data register 17
BPR_DATA18 | bpr data register 18
BPR_DATA19 | bpr data register 19
BPR_DATA20 | bpr data register 20
BPR_DATA21 | bpr data register 21
BPR_DATA22 | bpr data register 22
BPR_DATA23 | bpr data register 23
BPR_DATA24 | bpr data register 24
BPR_DATA25 | bpr data register 25
BPR_DATA26 | bpr data register 26
BPR_DATA27 | bpr data register 27
BPR_DATA28 | bpr data register 28
BPR_DATA29 | bpr data register 29
BPR_DATA30 | bpr data register 30
BPR_DATA31 | bpr data register 31
BPR_DATA32 | bpr data register 32
BPR_DATA33 | bpr data register 33
BPR_DATA34 | bpr data register 34
BPR_DATA35 | bpr data register 35
BPR_DATA36 | bpr data register 36
BPR_DATA37 | bpr data register 37
BPR_DATA38 | bpr data register 38
BPR_DATA39 | bpr data register 39
BPR_DATA40 | bpr data register 40
BPR_DATA41 | bpr data register 41
BPR_DATA42 | bpr data register 42

Definition at line 64 of file at32f413_bpr.h.

◆ bpr_rtc_output_type

enum bpr_rtc_output_type

bpr rtc output type

Enumerator
BPR_RTC_OUTPUT_NONE | output disable
BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE | output clock before calibration
BPR_RTC_OUTPUT_ALARM | output alarm event with pluse mode
BPR_RTC_OUTPUT_SECOND | output second event with pluse mode
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER | output clock after calibration
BPR_RTC_OUTPUT_ALARM_TOGGLE | output alarm event with toggle mode
BPR_RTC_OUTPUT_SECOND_TOGGLE | output second event with toggle mode

Definition at line 113 of file at32f413_bpr.h.

◆ bpr_tamper_pin_active_level_type

enum bpr_tamper_pin_active_level_type

tamper pin active level type

Enumerator
BPR_TAMPER_PIN_ACTIVE_HIGH | tamper pin input active level is high
BPR_TAMPER_PIN_ACTIVE_LOW | tamper pin input active level is low

Definition at line 127 of file at32f413_bpr.h.


AT32F413 Firmwary Library: bpr_type Struct Reference

Data Fields
bpr_type Struct Reference
AT32F413_periph_driver » BPR » BPR_exported_types

type define bpr register all More...

#include <at32f413_bpr.h>

Data Fields

__IO uint32_t | reserved1
reserved, offset:0x00 More...
union {
__IO uint32_t dt1
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt1_bit
};
bpr dt1 register, offset:0x04 More...
union {
__IO uint32_t dt2
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt2_bit
};
bpr dt2 register, offset:0x08 More...
union {
__IO uint32_t dt3
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt3_bit
};
bpr dt3 register, offset:0x0C More...
union {
__IO uint32_t dt4
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt4_bit
};
bpr dt4 register, offset:0x10 More...
union {
__IO uint32_t dt5
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt5_bit
};
bpr dt5 register, offset:0x14 More...
union {
__IO uint32_t dt6
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt6_bit
};
bpr dt6 register, offset:0x18 More...
union {
__IO uint32_t dt7
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt7_bit
};
bpr dt7 register, offset:0x1C More...
union {
__IO uint32_t dt8
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt8_bit
};
bpr dt8 register, offset:0x20 More...
union {
__IO uint32_t dt9
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt9_bit
};
bpr dt9 register, offset:0x24 More...
union {
__IO uint32_t dt10
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt10_bit
};
bpr dt10 register, offset:0x28 More...
union {
__IO uint32_t rtccal
struct {
__IO uint32_t calval: 7
__IO uint32_t calout: 1
__IO uint32_t outen: 1
__IO uint32_t outsel: 1
__IO uint32_t ccos: 1
__IO uint32_t outm: 1
__IO uint32_t reserved1: 20
} rtccal_bit
};
bpr rtccal register, offset:0x2C More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t tpen: 1
__IO uint32_t tpp: 1
__IO uint32_t reserved1: 30
} ctrl_bit
};
bpr ctrl register, offset:0x30 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t tpefclr: 1
__IO uint32_t tpifclr: 1
__IO uint32_t tpien: 1
__IO uint32_t reserved1: 5
__IO uint32_t tpef: 1
__IO uint32_t tpif: 1
__IO uint32_t reserved2: 22
} ctrlsts_bit
};
bpr ctrlsts register, offset:0x34 More...
__IO uint32_t | reserved3
reserved, offset:0x3C More...
union {
__IO uint32_t dt11
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt11_bit
};
bpr dt11 register, offset:0x40 More...
union {
__IO uint32_t dt12
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt12_bit
};
bpr dt12 register, offset:0x44 More...
union {
__IO uint32_t dt13
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt13_bit
};
bpr dt13 register, offset:0x48 More...
union {
__IO uint32_t dt14
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt14_bit
};
bpr dt14 register, offset:0x4C More...
union {
__IO uint32_t dt15
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt15_bit
};
bpr dt15 register, offset:0x50 More...
union {
__IO uint32_t dt16
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt16_bit
};
bpr dt16 register, offset:0x54 More...
union {
__IO uint32_t dt17
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt17_bit
};
bpr dt17 register, offset:0x58 More...
union {
__IO uint32_t dt18
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt18_bit
};
bpr dt18 register, offset:0x5C More...
union {
__IO uint32_t dt19
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt19_bit
};
bpr dt19 register, offset:0x60 More...
union {
__IO uint32_t dt20
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt20_bit
};
bpr dt20 register, offset:0x64 More...
union {
__IO uint32_t dt21
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt21_bit
};
bpr dt21 register, offset:0x68 More...
union {
__IO uint32_t dt22
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt22_bit
};
bpr dt22 register, offset:6C More...
union {
__IO uint32_t dt23
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt23_bit
};
bpr dt23 register, offset:0x70 More...
union {
__IO uint32_t dt24
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt24_bit
};
bpr dt24 register, offset:0x74 More...
union {
__IO uint32_t dt25
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt25_bit
};
bpr dt25 register, offset:0x78 More...
union {
__IO uint32_t dt26
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt26_bit
};
bpr dt26 register, offset:0x7C More...
union {
__IO uint32_t dt27
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt27_bit
};
bpr dt27 register, offset:0x80 More...
union {
__IO uint32_t dt28
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt28_bit
};
bpr dt28 register, offset:0x84 More...
union {
__IO uint32_t dt29
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt29_bit
};
bpr dt29 register, offset:0x88 More...
union {
__IO uint32_t dt30
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt30_bit
};
bpr dt30 register, offset:0x8C More...
union {
__IO uint32_t dt31
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt31_bit
};
bpr dt31 register, offset:0x90 More...
union {
__IO uint32_t dt32
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt32_bit
};
bpr dt32 register, offset:0x94 More...
union {
__IO uint32_t dt33
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt33_bit
};
bpr dt33 register, offset:0x98 More...
union {
__IO uint32_t dt34
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt34_bit
};
bpr dt34 register, offset:0x9C More...
union {
__IO uint32_t dt35
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt35_bit
};
bpr dt35 register, offset:0xA0 More...
union {
__IO uint32_t dt36
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt36_bit
};
bpr dt36 register, offset:0xA4 More...
union {
__IO uint32_t dt37
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt37_bit
};
bpr dt37 register, offset:0xA8 More...
union {
__IO uint32_t dt38
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt38_bit
};
bpr dt38 register, offset:0xAC More...
union {
__IO uint32_t dt39
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt39_bit
};
bpr dt39 register, offset:0xB0 More...
union {
__IO uint32_t dt40
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt40_bit
};
bpr dt40 register, offset:0xB4 More...
union {
__IO uint32_t dt41
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt41_bit
};
bpr dt41 register, offset:0xB8 More...
union {
__IO uint32_t dt42
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt42_bit
};
bpr dt42 register, offset:0xBC More...

Detailed Description

type define bpr register all

Definition at line 136 of file at32f413_bpr.h.

Field Documentation

◆

union { ... } bpr_type::@101

bpr ctrl register, offset:0x30

◆

union { ... } bpr_type::@103

bpr ctrlsts register, offset:0x34

◆

union { ... } bpr_type::@105

bpr dt11 register, offset:0x40

◆

union { ... } bpr_type::@107

bpr dt12 register, offset:0x44

◆

union { ... } bpr_type::@109

bpr dt13 register, offset:0x48

◆

union { ... } bpr_type::@111

bpr dt14 register, offset:0x4C

◆

union { ... } bpr_type::@113

bpr dt15 register, offset:0x50

◆

union { ... } bpr_type::@115

bpr dt16 register, offset:0x54

◆

union { ... } bpr_type::@117

bpr dt17 register, offset:0x58

◆

union { ... } bpr_type::@119

bpr dt18 register, offset:0x5C

◆

union { ... } bpr_type::@121

bpr dt19 register, offset:0x60

◆

union { ... } bpr_type::@123

bpr dt20 register, offset:0x64

◆

union { ... } bpr_type::@125

bpr dt21 register, offset:0x68

◆

union { ... } bpr_type::@127

bpr dt22 register, offset:6C

◆

union { ... } bpr_type::@129

bpr dt23 register, offset:0x70

◆

union { ... } bpr_type::@131

bpr dt24 register, offset:0x74

◆

union { ... } bpr_type::@133

bpr dt25 register, offset:0x78

◆

union { ... } bpr_type::@135

bpr dt26 register, offset:0x7C

◆

union { ... } bpr_type::@137

bpr dt27 register, offset:0x80

◆

union { ... } bpr_type::@139

bpr dt28 register, offset:0x84

◆

union { ... } bpr_type::@141

bpr dt29 register, offset:0x88

◆

union { ... } bpr_type::@143

bpr dt30 register, offset:0x8C

◆

union { ... } bpr_type::@145

bpr dt31 register, offset:0x90

◆

union { ... } bpr_type::@147

bpr dt32 register, offset:0x94

◆

union { ... } bpr_type::@149

bpr dt33 register, offset:0x98

◆

union { ... } bpr_type::@151

bpr dt34 register, offset:0x9C

◆

union { ... } bpr_type::@153

bpr dt35 register, offset:0xA0

◆

union { ... } bpr_type::@155

bpr dt36 register, offset:0xA4

◆

union { ... } bpr_type::@157

bpr dt37 register, offset:0xA8

◆

union { ... } bpr_type::@159

bpr dt38 register, offset:0xAC

◆

union { ... } bpr_type::@161

bpr dt39 register, offset:0xB0

◆

union { ... } bpr_type::@163

bpr dt40 register, offset:0xB4

◆

union { ... } bpr_type::@165

bpr dt41 register, offset:0xB8

◆

union { ... } bpr_type::@167

bpr dt42 register, offset:0xBC

◆

union { ... } bpr_type::@79

bpr dt1 register, offset:0x04

◆

union { ... } bpr_type::@81

bpr dt2 register, offset:0x08

◆

union { ... } bpr_type::@83

bpr dt3 register, offset:0x0C

◆

union { ... } bpr_type::@85

bpr dt4 register, offset:0x10

◆

union { ... } bpr_type::@87

bpr dt5 register, offset:0x14

◆

union { ... } bpr_type::@89

bpr dt6 register, offset:0x18

◆

union { ... } bpr_type::@91

bpr dt7 register, offset:0x1C

◆

union { ... } bpr_type::@93

bpr dt8 register, offset:0x20

◆

union { ... } bpr_type::@95

bpr dt9 register, offset:0x24

◆

union { ... } bpr_type::@97

bpr dt10 register, offset:0x28

◆

union { ... } bpr_type::@99

bpr rtccal register, offset:0x2C

◆ calout

__IO uint32_t bpr_type::calout

Definition at line 282 of file at32f413_bpr.h.

◆ calval

__IO uint32_t bpr_type::calval

Definition at line 281 of file at32f413_bpr.h.

◆ ccos

__IO uint32_t bpr_type::ccos

Definition at line 285 of file at32f413_bpr.h.

◆ ctrl

__IO uint32_t bpr_type::ctrl

Definition at line 296 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::ctrl_bit

◆ ctrlsts

__IO uint32_t bpr_type::ctrlsts

Definition at line 310 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::ctrlsts_bit

◆ dt

__IO uint32_t bpr_type::dt

Definition at line 151 of file at32f413_bpr.h.

◆ dt1

__IO uint32_t bpr_type::dt1

Definition at line 148 of file at32f413_bpr.h.

◆ dt10

__IO uint32_t bpr_type::dt10

Definition at line 265 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt10_bit

◆ dt11

__IO uint32_t bpr_type::dt11

Definition at line 338 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt11_bit

◆ dt12

__IO uint32_t bpr_type::dt12

Definition at line 351 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt12_bit

◆ dt13

__IO uint32_t bpr_type::dt13

Definition at line 364 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt13_bit

◆ dt14

__IO uint32_t bpr_type::dt14

Definition at line 377 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt14_bit

◆ dt15

__IO uint32_t bpr_type::dt15

Definition at line 390 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt15_bit

◆ dt16

__IO uint32_t bpr_type::dt16

Definition at line 403 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt16_bit

◆ dt17

__IO uint32_t bpr_type::dt17

Definition at line 416 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt17_bit

◆ dt18

__IO uint32_t bpr_type::dt18

Definition at line 429 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt18_bit

◆ dt19

__IO uint32_t bpr_type::dt19

Definition at line 442 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt19_bit

◆

struct { ... } bpr_type::dt1_bit

◆ dt2

__IO uint32_t bpr_type::dt2

Definition at line 161 of file at32f413_bpr.h.

◆ dt20

__IO uint32_t bpr_type::dt20

Definition at line 455 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt20_bit

◆ dt21

__IO uint32_t bpr_type::dt21

Definition at line 468 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt21_bit

◆ dt22

__IO uint32_t bpr_type::dt22

Definition at line 481 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt22_bit

◆ dt23

__IO uint32_t bpr_type::dt23

Definition at line 494 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt23_bit

◆ dt24

__IO uint32_t bpr_type::dt24

Definition at line 507 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt24_bit

◆ dt25

__IO uint32_t bpr_type::dt25

Definition at line 520 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt25_bit

◆ dt26

__IO uint32_t bpr_type::dt26

Definition at line 533 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt26_bit

◆ dt27

__IO uint32_t bpr_type::dt27

Definition at line 546 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt27_bit

◆ dt28

__IO uint32_t bpr_type::dt28

Definition at line 559 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt28_bit

◆ dt29

__IO uint32_t bpr_type::dt29

Definition at line 572 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt29_bit

◆

struct { ... } bpr_type::dt2_bit

◆ dt3

__IO uint32_t bpr_type::dt3

Definition at line 174 of file at32f413_bpr.h.

◆ dt30

__IO uint32_t bpr_type::dt30

Definition at line 585 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt30_bit

◆ dt31

__IO uint32_t bpr_type::dt31

Definition at line 598 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt31_bit

◆ dt32

__IO uint32_t bpr_type::dt32

Definition at line 611 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt32_bit

◆ dt33

__IO uint32_t bpr_type::dt33

Definition at line 624 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt33_bit

◆ dt34

__IO uint32_t bpr_type::dt34

Definition at line 637 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt34_bit

◆ dt35

__IO uint32_t bpr_type::dt35

Definition at line 650 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt35_bit

◆ dt36

__IO uint32_t bpr_type::dt36

Definition at line 663 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt36_bit

◆ dt37

__IO uint32_t bpr_type::dt37

Definition at line 676 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt37_bit

◆ dt38

__IO uint32_t bpr_type::dt38

Definition at line 689 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt38_bit

◆ dt39

__IO uint32_t bpr_type::dt39

Definition at line 702 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt39_bit

◆

struct { ... } bpr_type::dt3_bit

◆ dt4

__IO uint32_t bpr_type::dt4

Definition at line 187 of file at32f413_bpr.h.

◆ dt40

__IO uint32_t bpr_type::dt40

Definition at line 715 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt40_bit

◆ dt41

__IO uint32_t bpr_type::dt41

Definition at line 728 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt41_bit

◆ dt42

__IO uint32_t bpr_type::dt42

Definition at line 741 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt42_bit

◆

struct { ... } bpr_type::dt4_bit

◆ dt5

__IO uint32_t bpr_type::dt5

Definition at line 200 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt5_bit

◆ dt6

__IO uint32_t bpr_type::dt6

Definition at line 213 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt6_bit

◆ dt7

__IO uint32_t bpr_type::dt7

Definition at line 226 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt7_bit

◆ dt8

__IO uint32_t bpr_type::dt8

Definition at line 239 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt8_bit

◆ dt9

__IO uint32_t bpr_type::dt9

Definition at line 252 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt9_bit

◆ outen

__IO uint32_t bpr_type::outen

Definition at line 283 of file at32f413_bpr.h.

◆ outm

__IO uint32_t bpr_type::outm

Definition at line 286 of file at32f413_bpr.h.

◆ outsel

__IO uint32_t bpr_type::outsel

Definition at line 284 of file at32f413_bpr.h.

◆ reserved1

__IO uint32_t bpr_type::reserved1

reserved, offset:0x00

Definition at line 141 of file at32f413_bpr.h.

◆ reserved2

__IO uint32_t bpr_type::reserved2

reserved, offset:0x38

Definition at line 319 of file at32f413_bpr.h.

◆ reserved3

__IO uint32_t bpr_type::reserved3

reserved, offset:0x3C

Definition at line 331 of file at32f413_bpr.h.

◆ rtccal

__IO uint32_t bpr_type::rtccal

Definition at line 278 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::rtccal_bit

◆ tpef

__IO uint32_t bpr_type::tpef

Definition at line 317 of file at32f413_bpr.h.

◆ tpefclr

__IO uint32_t bpr_type::tpefclr

Definition at line 313 of file at32f413_bpr.h.

◆ tpen

__IO uint32_t bpr_type::tpen

Definition at line 299 of file at32f413_bpr.h.

◆ tpien

__IO uint32_t bpr_type::tpien

Definition at line 315 of file at32f413_bpr.h.

◆ tpif

__IO uint32_t bpr_type::tpif

Definition at line 318 of file at32f413_bpr.h.

◆ tpifclr

__IO uint32_t bpr_type::tpifclr

Definition at line 314 of file at32f413_bpr.h.

◆ tpp

__IO uint32_t bpr_type::tpp

Definition at line 300 of file at32f413_bpr.h.

The documentation for this struct was generated from the following file:
  • at32f413_bpr.h


AT32F413 Firmwary Library: BPR_exported_functions

Functions
BPR_exported_functions
AT32F413_periph_driver » BPR

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

Function Documentation

◆ bpr_data_read()

uint16_t bpr_data_read ( bpr_data_type bpr_data )

read bpr bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
Return values
none

Definition at line 114 of file at32f413_bpr.c.

Referenced by bpr_reg_check(), bpr_reg_judge(), and rtc_init().

◆ bpr_data_write()

void bpr_data_write | ( | bpr_data_type | bpr_data,
 |  | uint16_t | data_value
 | ) |  |

write bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
data_value (0x0000~0xFFFF)
Return values
none

Definition at line 131 of file at32f413_bpr.c.

Referenced by bpr_reg_write(), and rtc_init().

◆ bpr_flag_clear()

void bpr_flag_clear ( uint32_t flag )

clear bpr tamper flag

Parameters
flag specifies the flag to clear. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
none

< bpr tamper interrupt flag

Definition at line 81 of file at32f413_bpr.c.

Referenced by main(), and TAMPER_IRQHandler().

◆ bpr_flag_get()

flag_status bpr_flag_get ( uint32_t flag )

bpr event flag get, for tamper event flag

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
state of tamper event flag

< bpr tamper interrupt flag

Definition at line 61 of file at32f413_bpr.c.

Referenced by TAMPER_IRQHandler().

◆ bpr_interrupt_enable()

void bpr_interrupt_enable ( confirm_state new_state )

enable or disable bpr tamper interrupt

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 98 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_reset()

void bpr_reset ( void )

bpr reset by crm reset register

Parameters
none
Return values
none

Definition at line 47 of file at32f413_bpr.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ bpr_rtc_clock_calibration_value_set()

void bpr_rtc_clock_calibration_value_set ( uint8_t calibration_value )

set rtc clock calibration value

Parameters
calibration_value (0x00~0x7f)
Return values
none

Definition at line 163 of file at32f413_bpr.c.

◆ bpr_rtc_output_select()

void bpr_rtc_output_select ( bpr_rtc_output_type output_source )

select bpr rtc output

Parameters
output_source this parameter can be one of the following values:
  • BPR_RTC_OUTPUT_NONE: output disable.
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE: output clock before calibration.
  • BPR_RTC_OUTPUT_ALARM: output alarm event with pluse mode.
  • BPR_RTC_OUTPUT_SECOND: output second event with pluse mode.
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER: output clock after calibration.
  • BPR_RTC_OUTPUT_ALARM_TOGGLE: output alarm event with toggle mode.
  • BPR_RTC_OUTPUT_SECOND_TOGGLE: output second event with toggle mode.
Return values
none

Definition at line 149 of file at32f413_bpr.c.

Referenced by rtc_configuration().

◆ bpr_tamper_pin_active_level_set()

void bpr_tamper_pin_active_level_set ( bpr_tamper_pin_active_level_type active_level )

set bpr tamper pin active level

Parameters
active_level this parameter can be one of the following values:
  • BPR_TAMPER_PIN_ACTIVE_HIGH: tamper pin input active level is high.
  • BPR_TAMPER_PIN_ACTIVE_LOW: tamper pin input active level is low.
Return values
none

Definition at line 187 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_tamper_pin_enable()

void bpr_tamper_pin_enable ( confirm_state new_state )

enable or disable bpr tamper pin

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 174 of file at32f413_bpr.c.

Referenced by main(), rtc_configuration(), and TAMPER_IRQHandler().


AT32F413 Firmwary Library: BPR_private_functions

Functions
BPR_private_functions
AT32F413_periph_driver » BPR

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

Function Documentation

◆ bpr_data_read()

uint16_t bpr_data_read ( bpr_data_type bpr_data )

read bpr bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
Return values
none

Definition at line 114 of file at32f413_bpr.c.

Referenced by bpr_reg_check(), bpr_reg_judge(), and rtc_init().

◆ bpr_data_write()

void bpr_data_write | ( | bpr_data_type | bpr_data,
 |  | uint16_t | data_value
 | ) |  |

write bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
data_value (0x0000~0xFFFF)
Return values
none

Definition at line 131 of file at32f413_bpr.c.

Referenced by bpr_reg_write(), and rtc_init().

◆ bpr_flag_clear()

void bpr_flag_clear ( uint32_t flag )

clear bpr tamper flag

Parameters
flag specifies the flag to clear. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
none

< bpr tamper interrupt flag

Definition at line 81 of file at32f413_bpr.c.

Referenced by main(), and TAMPER_IRQHandler().

◆ bpr_flag_get()

flag_status bpr_flag_get ( uint32_t flag )

bpr event flag get, for tamper event flag

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
state of tamper event flag

< bpr tamper interrupt flag

Definition at line 61 of file at32f413_bpr.c.

Referenced by TAMPER_IRQHandler().

◆ bpr_interrupt_enable()

void bpr_interrupt_enable ( confirm_state new_state )

enable or disable bpr tamper interrupt

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 98 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_reset()

void bpr_reset ( void )

bpr reset by crm reset register

Parameters
none
Return values
none

Definition at line 47 of file at32f413_bpr.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ bpr_rtc_clock_calibration_value_set()

void bpr_rtc_clock_calibration_value_set ( uint8_t calibration_value )

set rtc clock calibration value

Parameters
calibration_value (0x00~0x7f)
Return values
none

Definition at line 163 of file at32f413_bpr.c.

◆ bpr_rtc_output_select()

void bpr_rtc_output_select ( bpr_rtc_output_type output_source )

select bpr rtc output

Parameters
output_source this parameter can be one of the following values:
  • BPR_RTC_OUTPUT_NONE: output disable.
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE: output clock before calibration.
  • BPR_RTC_OUTPUT_ALARM: output alarm event with pluse mode.
  • BPR_RTC_OUTPUT_SECOND: output second event with pluse mode.
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER: output clock after calibration.
  • BPR_RTC_OUTPUT_ALARM_TOGGLE: output alarm event with toggle mode.
  • BPR_RTC_OUTPUT_SECOND_TOGGLE: output second event with toggle mode.
Return values
none

Definition at line 149 of file at32f413_bpr.c.

Referenced by rtc_configuration().

◆ bpr_tamper_pin_active_level_set()

void bpr_tamper_pin_active_level_set ( bpr_tamper_pin_active_level_type active_level )

set bpr tamper pin active level

Parameters
active_level this parameter can be one of the following values:
  • BPR_TAMPER_PIN_ACTIVE_HIGH: tamper pin input active level is high.
  • BPR_TAMPER_PIN_ACTIVE_LOW: tamper pin input active level is low.
Return values
none

Definition at line 187 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_tamper_pin_enable()

void bpr_tamper_pin_enable ( confirm_state new_state )

enable or disable bpr tamper pin

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 174 of file at32f413_bpr.c.

Referenced by main(), rtc_configuration(), and TAMPER_IRQHandler().


AT32F413 Firmwary Library: CAN

Modules | Macros
CAN
AT32F413_periph_driver

CAN driver modules. More...

Modules

CAN_timeout_count
CAN_flags_definition
can flag
CAN_interrupts_definition
can interrupt
CAN_exported_types
CAN_exported_functions
CAN_private_functions

Macros

#define | CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
can flag clear operation macro definition val More...
#define | CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
#define | CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
#define | CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
#define | CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
#define | CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
#define | CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
#define | CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
#define | CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
#define | CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
#define | CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
#define | CAN1 ((can_type *) CAN1_BASE)

Detailed Description

CAN driver modules.

Macro Definition Documentation

◆ CAN1

#define CAN1 ((can_type *) CAN1_BASE)

Definition at line 936 of file at32f413_can.h.

◆ CAN_MSTS_EDZIF_VAL

#define CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)

edzif bit value, it clear by writing 1

Definition at line 113 of file at32f413_can.h.

◆ CAN_MSTS_EOIF_VAL

#define CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)

can flag clear operation macro definition val

eoif bit value, it clear by writing 1

Definition at line 111 of file at32f413_can.h.

◆ CAN_MSTS_QDZIF_VAL

#define CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)

qdzif bit value, it clear by writing 1

Definition at line 112 of file at32f413_can.h.

◆ CAN_RF0_RF0FF_VAL

#define CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)

rf0ff bit value, it clear by writing 1

Definition at line 120 of file at32f413_can.h.

◆ CAN_RF0_RF0OF_VAL

#define CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)

rf0of bit value, it clear by writing 1

Definition at line 121 of file at32f413_can.h.

◆ CAN_RF0_RF0R_VAL

#define CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)

rf0r bit value, it clear by writing 1

Definition at line 122 of file at32f413_can.h.

◆ CAN_RF1_RF1FF_VAL

#define CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)

rf1ff bit value, it clear by writing 1

Definition at line 123 of file at32f413_can.h.

◆ CAN_RF1_RF1OF_VAL

#define CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)

rf1of bit value, it clear by writing 1

Definition at line 124 of file at32f413_can.h.

◆ CAN_RF1_RF1R_VAL

#define CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)

rf1r bit value, it clear by writing 1

Definition at line 125 of file at32f413_can.h.

◆ CAN_TSTS_TM0CT_VAL

#define CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)

tm0ct bit value, it clear by writing 1

Definition at line 117 of file at32f413_can.h.

◆ CAN_TSTS_TM0TCF_VAL

#define CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)

tm0tcf bit value, it clear by writing 1

Definition at line 114 of file at32f413_can.h.

◆ CAN_TSTS_TM1CT_VAL

#define CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)

tm1ct bit value, it clear by writing 1

Definition at line 118 of file at32f413_can.h.

◆ CAN_TSTS_TM1TCF_VAL

#define CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)

tm1tcf bit value, it clear by writing 1

Definition at line 115 of file at32f413_can.h.

◆ CAN_TSTS_TM2CT_VAL

#define CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)

tm2ct bit value, it clear by writing 1

Definition at line 119 of file at32f413_can.h.

◆ CAN_TSTS_TM2TCF_VAL

#define CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)

tm2tcf bit value, it clear by writing 1

Definition at line 116 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_timeout_count

Macros
CAN_timeout_count
AT32F413_periph_driver » CAN

Macros

#define | FZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | DZC_TIMEOUT ((uint32_t)0x0000FFFF)

Detailed Description

Macro Definition Documentation

◆ DZC_TIMEOUT

#define DZC_TIMEOUT ((uint32_t)0x0000FFFF)

time out for dzc bit

Definition at line 51 of file at32f413_can.h.

◆ FZC_TIMEOUT

#define FZC_TIMEOUT ((uint32_t)0x0000FFFF)

time out for fzc bit

Definition at line 50 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_flags_definition

Macros
CAN_flags_definition
AT32F413_periph_driver » CAN

can flag More...

Macros

#define | CAN_EAF_FLAG ((uint32_t)0x01)
#define | CAN_EPF_FLAG ((uint32_t)0x02)
#define | CAN_BOF_FLAG ((uint32_t)0x03)
#define | CAN_ETR_FLAG ((uint32_t)0x04)
#define | CAN_EOIF_FLAG ((uint32_t)0x05)
#define | CAN_TM0TCF_FLAG ((uint32_t)0x06)
#define | CAN_TM1TCF_FLAG ((uint32_t)0x07)
#define | CAN_TM2TCF_FLAG ((uint32_t)0x08)
#define | CAN_RF0MN_FLAG ((uint32_t)0x09)
#define | CAN_RF0FF_FLAG ((uint32_t)0x0A)
#define | CAN_RF0OF_FLAG ((uint32_t)0x0B)
#define | CAN_RF1MN_FLAG ((uint32_t)0x0C)
#define | CAN_RF1FF_FLAG ((uint32_t)0x0D)
#define | CAN_RF1OF_FLAG ((uint32_t)0x0E)
#define | CAN_QDZIF_FLAG ((uint32_t)0x0F)
#define | CAN_EDZC_FLAG ((uint32_t)0x10)
#define | CAN_TMEF_FLAG ((uint32_t)0x11)

Detailed Description

can flag

Macro Definition Documentation

◆ CAN_BOF_FLAG

#define CAN_BOF_FLAG ((uint32_t)0x03)

bus-off flag

Definition at line 64 of file at32f413_can.h.

◆ CAN_EAF_FLAG

#define CAN_EAF_FLAG ((uint32_t)0x01)

error active flag

Definition at line 62 of file at32f413_can.h.

◆ CAN_EDZC_FLAG

#define CAN_EDZC_FLAG ((uint32_t)0x10)

enter doze mode confirm flag

Definition at line 77 of file at32f413_can.h.

◆ CAN_EOIF_FLAG

#define CAN_EOIF_FLAG ((uint32_t)0x05)

error occur interrupt flag

Definition at line 66 of file at32f413_can.h.

◆ CAN_EPF_FLAG

#define CAN_EPF_FLAG ((uint32_t)0x02)

error passive flag

Definition at line 63 of file at32f413_can.h.

◆ CAN_ETR_FLAG

#define CAN_ETR_FLAG ((uint32_t)0x04)

error type record flag

Definition at line 65 of file at32f413_can.h.

◆ CAN_QDZIF_FLAG

#define CAN_QDZIF_FLAG ((uint32_t)0x0F)

quit doze mode interrupt flag

Definition at line 76 of file at32f413_can.h.

◆ CAN_RF0FF_FLAG

#define CAN_RF0FF_FLAG ((uint32_t)0x0A)

receive fifo 0 full flag

Definition at line 71 of file at32f413_can.h.

◆ CAN_RF0MN_FLAG

#define CAN_RF0MN_FLAG ((uint32_t)0x09)

receive fifo 0 message num flag

Definition at line 70 of file at32f413_can.h.

◆ CAN_RF0OF_FLAG

#define CAN_RF0OF_FLAG ((uint32_t)0x0B)

receive fifo 0 overflow flag

Definition at line 72 of file at32f413_can.h.

◆ CAN_RF1FF_FLAG

#define CAN_RF1FF_FLAG ((uint32_t)0x0D)

receive fifo 1 full flag

Definition at line 74 of file at32f413_can.h.

◆ CAN_RF1MN_FLAG

#define CAN_RF1MN_FLAG ((uint32_t)0x0C)

receive fifo 1 message num flag

Definition at line 73 of file at32f413_can.h.

◆ CAN_RF1OF_FLAG

#define CAN_RF1OF_FLAG ((uint32_t)0x0E)

receive fifo 1 overflow flag

Definition at line 75 of file at32f413_can.h.

◆ CAN_TM0TCF_FLAG

#define CAN_TM0TCF_FLAG ((uint32_t)0x06)

transmit mailbox 0 transmission completed flag

Definition at line 67 of file at32f413_can.h.

◆ CAN_TM1TCF_FLAG

#define CAN_TM1TCF_FLAG ((uint32_t)0x07)

transmit mailbox 1 transmission completed flag

Definition at line 68 of file at32f413_can.h.

◆ CAN_TM2TCF_FLAG

#define CAN_TM2TCF_FLAG ((uint32_t)0x08)

transmit mailbox 2 transmission completed flag

Definition at line 69 of file at32f413_can.h.

◆ CAN_TMEF_FLAG

#define CAN_TMEF_FLAG ((uint32_t)0x11)

transmit mailbox empty flag

Definition at line 78 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_interrupts_definition

Macros
CAN_interrupts_definition
AT32F413_periph_driver » CAN

can interrupt More...

Macros

#define | CAN_TCIEN_INT ((uint32_t)0x00000001)
#define | CAN_RF0MIEN_INT ((uint32_t)0x00000002)
#define | CAN_RF0FIEN_INT ((uint32_t)0x00000004)
#define | CAN_RF0OIEN_INT ((uint32_t)0x00000008)
#define | CAN_RF1MIEN_INT ((uint32_t)0x00000010)
#define | CAN_RF1FIEN_INT ((uint32_t)0x00000020)
#define | CAN_RF1OIEN_INT ((uint32_t)0x00000040)
#define | CAN_EAIEN_INT ((uint32_t)0x00000100)
#define | CAN_EPIEN_INT ((uint32_t)0x00000200)
#define | CAN_BOIEN_INT ((uint32_t)0x00000400)
#define | CAN_ETRIEN_INT ((uint32_t)0x00000800)
#define | CAN_EOIEN_INT ((uint32_t)0x00008000)
#define | CAN_QDZIEN_INT ((uint32_t)0x00010000)
#define | CAN_EDZIEN_INT ((uint32_t)0x00020000)

Detailed Description

can interrupt

Macro Definition Documentation

◆ CAN_BOIEN_INT

#define CAN_BOIEN_INT ((uint32_t)0x00000400)

bus-off interrupt

Definition at line 98 of file at32f413_can.h.

◆ CAN_EAIEN_INT

#define CAN_EAIEN_INT ((uint32_t)0x00000100)

error active interrupt

Definition at line 96 of file at32f413_can.h.

◆ CAN_EDZIEN_INT

#define CAN_EDZIEN_INT ((uint32_t)0x00020000)

enter doze mode confirm interrupt

Definition at line 102 of file at32f413_can.h.

◆ CAN_EOIEN_INT

#define CAN_EOIEN_INT ((uint32_t)0x00008000)

error occur interrupt

Definition at line 100 of file at32f413_can.h.

◆ CAN_EPIEN_INT

#define CAN_EPIEN_INT ((uint32_t)0x00000200)

error passive interrupt

Definition at line 97 of file at32f413_can.h.

◆ CAN_ETRIEN_INT

#define CAN_ETRIEN_INT ((uint32_t)0x00000800)

error type record interrupt

Definition at line 99 of file at32f413_can.h.

◆ CAN_QDZIEN_INT

#define CAN_QDZIEN_INT ((uint32_t)0x00010000)

quit doze mode interrupt

Definition at line 101 of file at32f413_can.h.

◆ CAN_RF0FIEN_INT

#define CAN_RF0FIEN_INT ((uint32_t)0x00000004)

receive fifo 0 full interrupt

Definition at line 91 of file at32f413_can.h.

◆ CAN_RF0MIEN_INT

#define CAN_RF0MIEN_INT ((uint32_t)0x00000002)

receive fifo 0 message interrupt

Definition at line 90 of file at32f413_can.h.

◆ CAN_RF0OIEN_INT

#define CAN_RF0OIEN_INT ((uint32_t)0x00000008)

receive fifo 0 overflow interrupt

Definition at line 92 of file at32f413_can.h.

◆ CAN_RF1FIEN_INT

#define CAN_RF1FIEN_INT ((uint32_t)0x00000020)

receive fifo 1 full interrupt

Definition at line 94 of file at32f413_can.h.

◆ CAN_RF1MIEN_INT

#define CAN_RF1MIEN_INT ((uint32_t)0x00000010)

receive fifo 1 message interrupt

Definition at line 93 of file at32f413_can.h.

◆ CAN_RF1OIEN_INT

#define CAN_RF1OIEN_INT ((uint32_t)0x00000040)

receive fifo 1 overflow interrupt

Definition at line 95 of file at32f413_can.h.

◆ CAN_TCIEN_INT

#define CAN_TCIEN_INT ((uint32_t)0x00000001)

transmission complete interrupt

Definition at line 89 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_exported_types

Data Structures | Enumerations
CAN_exported_types
AT32F413_periph_driver » CAN

Data Structures

struct | can_base_type
can init structure definition More...
struct | can_baudrate_type
can baudrate structure definition More...
struct | can_filter_init_type
can filter init structure definition More...
struct | can_tx_message_type
can tx message structure definition More...
struct | can_rx_message_type
can rx message structure definition More...
struct | can_tx_mailbox_type
can controller area network tx mailbox More...
struct | can_fifo_mailbox_type
can controller area network fifo mailbox More...
struct | can_filter_register_type
can controller area network filter bit register More...
struct | can_type
type define can register all More...

Enumerations

enum | can_filter_fifo_type { CAN_FILTER_FIFO0 = 0x00 , CAN_FILTER_FIFO1 = 0x01 }
can filter fifo More...
enum | can_filter_mode_type { CAN_FILTER_MODE_ID_MASK = 0x00 , CAN_FILTER_MODE_ID_LIST = 0x01 }
can filter mode More...
enum | can_filter_bit_width_type { CAN_FILTER_16BIT = 0x00 , CAN_FILTER_32BIT = 0x01 }
can filter bit width select More...
enum | can_mode_type { CAN_MODE_COMMUNICATE = 0x00 , CAN_MODE_LOOPBACK = 0x01 , CAN_MODE_LISTENONLY = 0x02 , CAN_MODE_LISTENONLY_LOOPBACK = 0x03 }
can mode More...
enum | can_operating_mode_type { CAN_OPERATINGMODE_FREEZE = 0x00 , CAN_OPERATINGMODE_DOZE = 0x01 , CAN_OPERATINGMODE_COMMUNICATE = 0x02 }
can operating mode More...
enum | can_rsaw_type { CAN_RSAW_1TQ = 0x00 , CAN_RSAW_2TQ = 0x01 , CAN_RSAW_3TQ = 0x02 , CAN_RSAW_4TQ = 0x03 }
can resynchronization adjust width More...
enum can_bts1_type {
CAN_BTS1_1TQ = 0x00 , CAN_BTS1_2TQ = 0x01 , CAN_BTS1_3TQ = 0x02 , CAN_BTS1_4TQ = 0x03 ,
CAN_BTS1_5TQ = 0x04 , CAN_BTS1_6TQ = 0x05 , CAN_BTS1_7TQ = 0x06 , CAN_BTS1_8TQ = 0x07 ,
CAN_BTS1_9TQ = 0x08 , CAN_BTS1_10TQ = 0x09 , CAN_BTS1_11TQ = 0x0A , CAN_BTS1_12TQ = 0x0B ,
CAN_BTS1_13TQ = 0x0C , CAN_BTS1_14TQ = 0x0D , CAN_BTS1_15TQ = 0x0E , CAN_BTS1_16TQ = 0x0F
}
can bit time segment 1 More...
enum can_bts2_type {
CAN_BTS2_1TQ = 0x00 , CAN_BTS2_2TQ = 0x01 , CAN_BTS2_3TQ = 0x02 , CAN_BTS2_4TQ = 0x03 ,
CAN_BTS2_5TQ = 0x04 , CAN_BTS2_6TQ = 0x05 , CAN_BTS2_7TQ = 0x06 , CAN_BTS2_8TQ = 0x07
}
can bit time segment 2 More...
enum | can_identifier_type { CAN_ID_STANDARD = 0x00 , CAN_ID_EXTENDED = 0x01 }
can identifier type More...
enum | can_trans_frame_type { CAN_TFT_DATA = 0x00 , CAN_TFT_REMOTE = 0x01 }
can transmission frame type More...
enum | can_tx_mailbox_num_type { CAN_TX_MAILBOX0 = 0x00 , CAN_TX_MAILBOX1 = 0x01 , CAN_TX_MAILBOX2 = 0x02 }
can tx mailboxes More...
enum | can_rx_fifo_num_type { CAN_RX_FIFO0 = 0x00 , CAN_RX_FIFO1 = 0x01 }
can receive fifo More...
enum | can_transmit_status_type { CAN_TX_STATUS_FAILED = 0x00 , CAN_TX_STATUS_SUCCESSFUL = 0x01 , CAN_TX_STATUS_PENDING = 0x02 , CAN_TX_STATUS_NO_EMPTY = 0x04 }
can transmit status More...
enum | can_enter_doze_status_type { CAN_ENTER_DOZE_FAILED = 0x00 , CAN_ENTER_DOZE_SUCCESSFUL = 0x01 }
can enter doze mode status More...
enum | can_quit_doze_status_type { CAN_QUIT_DOZE_FAILED = 0x00 , CAN_QUIT_DOZE_SUCCESSFUL = 0x01 }
can quit doze mode status More...
enum | can_msg_discarding_rule_type { CAN_DISCARDING_FIRST_RECEIVED = 0x00 , CAN_DISCARDING_LAST_RECEIVED = 0x01 }
can message discarding rule select when overflow More...
enum | can_msg_sending_rule_type { CAN_SENDING_BY_ID = 0x00 , CAN_SENDING_BY_REQUEST = 0x01 }
can multiple message sending sequence rule More...
enum can_error_record_type {
CAN_ERRORRECORD_NOERR = 0x00 , CAN_ERRORRECORD_STUFFERR = 0x01 , CAN_ERRORRECORD_FORMERR = 0x02 , CAN_ERRORRECORD_ACKERR = 0x03 ,
CAN_ERRORRECORD_BITRECESSIVEERR = 0x04 , CAN_ERRORRECORD_BITDOMINANTERR = 0x05 , CAN_ERRORRECORD_CRCERR = 0x06 , CAN_ERRORRECORD_SOFTWARESETERR = 0x07
}
can error type record More...

Detailed Description

Enumeration Type Documentation

◆ can_bts1_type

enum can_bts1_type

can bit time segment 1

Enumerator
CAN_BTS1_1TQ | 1 time quantum
CAN_BTS1_2TQ | 2 time quantum
CAN_BTS1_3TQ | 3 time quantum
CAN_BTS1_4TQ | 4 time quantum
CAN_BTS1_5TQ | 5 time quantum
CAN_BTS1_6TQ | 6 time quantum
CAN_BTS1_7TQ | 7 time quantum
CAN_BTS1_8TQ | 8 time quantum
CAN_BTS1_9TQ | 9 time quantum
CAN_BTS1_10TQ | 10 time quantum
CAN_BTS1_11TQ | 11 time quantum
CAN_BTS1_12TQ | 12 time quantum
CAN_BTS1_13TQ | 13 time quantum
CAN_BTS1_14TQ | 14 time quantum
CAN_BTS1_15TQ | 15 time quantum
CAN_BTS1_16TQ | 16 time quantum

Definition at line 193 of file at32f413_can.h.

◆ can_bts2_type

enum can_bts2_type

can bit time segment 2

Enumerator
CAN_BTS2_1TQ | 1 time quantum
CAN_BTS2_2TQ | 2 time quantum
CAN_BTS2_3TQ | 3 time quantum
CAN_BTS2_4TQ | 4 time quantum
CAN_BTS2_5TQ | 5 time quantum
CAN_BTS2_6TQ | 6 time quantum
CAN_BTS2_7TQ | 7 time quantum
CAN_BTS2_8TQ | 8 time quantum

Definition at line 216 of file at32f413_can.h.

◆ can_enter_doze_status_type

enum can_enter_doze_status_type

can enter doze mode status

Enumerator
CAN_ENTER_DOZE_FAILED | can enter the doze mode failed
CAN_ENTER_DOZE_SUCCESSFUL | can enter the doze mode successful

Definition at line 279 of file at32f413_can.h.

◆ can_error_record_type

enum can_error_record_type

can error type record

Enumerator
CAN_ERRORRECORD_NOERR | no error
CAN_ERRORRECORD_STUFFERR | stuff error
CAN_ERRORRECORD_FORMERR | form error
CAN_ERRORRECORD_ACKERR | acknowledgment error
CAN_ERRORRECORD_BITRECESSIVEERR | bit recessive error
CAN_ERRORRECORD_BITDOMINANTERR | bit dominant error
CAN_ERRORRECORD_CRCERR | crc error
CAN_ERRORRECORD_SOFTWARESETERR | software set error

Definition at line 315 of file at32f413_can.h.

◆ can_filter_bit_width_type

enum can_filter_bit_width_type

can filter bit width select

Enumerator
CAN_FILTER_16BIT | two 16-bit filters
CAN_FILTER_32BIT | one 32-bit filter

Definition at line 152 of file at32f413_can.h.

◆ can_filter_fifo_type

enum can_filter_fifo_type

can filter fifo

Enumerator
CAN_FILTER_FIFO0 | filter fifo 0 assignment for filter x
CAN_FILTER_FIFO1 | filter fifo 1 assignment for filter x

Definition at line 134 of file at32f413_can.h.

◆ can_filter_mode_type

enum can_filter_mode_type

can filter mode

Enumerator
CAN_FILTER_MODE_ID_MASK | identifier mask mode
CAN_FILTER_MODE_ID_LIST | identifier list mode

Definition at line 143 of file at32f413_can.h.

◆ can_identifier_type

enum can_identifier_type

can identifier type

Enumerator
CAN_ID_STANDARD | standard Id
CAN_ID_EXTENDED | extended Id

Definition at line 231 of file at32f413_can.h.

◆ can_mode_type

enum can_mode_type

can mode

Enumerator
CAN_MODE_COMMUNICATE | communication mode
CAN_MODE_LOOPBACK | loopback mode
CAN_MODE_LISTENONLY | listen-only mode
CAN_MODE_LISTENONLY_LOOPBACK | loopback combined with listen-only mode

Definition at line 161 of file at32f413_can.h.

◆ can_msg_discarding_rule_type

enum can_msg_discarding_rule_type

can message discarding rule select when overflow

Enumerator
CAN_DISCARDING_FIRST_RECEIVED | can discarding the first received message
CAN_DISCARDING_LAST_RECEIVED | can discarding the last received message

Definition at line 297 of file at32f413_can.h.

◆ can_msg_sending_rule_type

enum can_msg_sending_rule_type

can multiple message sending sequence rule

Enumerator
CAN_SENDING_BY_ID | can sending the minimum id message first
CAN_SENDING_BY_REQUEST | can sending the first request message first

Definition at line 306 of file at32f413_can.h.

◆ can_operating_mode_type

enum can_operating_mode_type

can operating mode

Enumerator
CAN_OPERATINGMODE_FREEZE | freeze mode
CAN_OPERATINGMODE_DOZE | doze mode
CAN_OPERATINGMODE_COMMUNICATE | communication mode

Definition at line 172 of file at32f413_can.h.

◆ can_quit_doze_status_type

enum can_quit_doze_status_type

can quit doze mode status

Enumerator
CAN_QUIT_DOZE_FAILED | can quit doze mode failed
CAN_QUIT_DOZE_SUCCESSFUL | can quit doze mode successful

Definition at line 288 of file at32f413_can.h.

◆ can_rsaw_type

enum can_rsaw_type

can resynchronization adjust width

Enumerator
CAN_RSAW_1TQ | 1 time quantum
CAN_RSAW_2TQ | 2 time quantum
CAN_RSAW_3TQ | 3 time quantum
CAN_RSAW_4TQ | 4 time quantum

Definition at line 182 of file at32f413_can.h.

◆ can_rx_fifo_num_type

enum can_rx_fifo_num_type

can receive fifo

Enumerator
CAN_RX_FIFO0 | can fifo 0 used to receive
CAN_RX_FIFO1 | can fifo 1 used to receive

Definition at line 259 of file at32f413_can.h.

◆ can_trans_frame_type

enum can_trans_frame_type

can transmission frame type

Enumerator
CAN_TFT_DATA | data frame
CAN_TFT_REMOTE | remote frame

Definition at line 240 of file at32f413_can.h.

◆ can_transmit_status_type

enum can_transmit_status_type

can transmit status

Enumerator
CAN_TX_STATUS_FAILED | can transmission failed
CAN_TX_STATUS_SUCCESSFUL | can transmission successful
CAN_TX_STATUS_PENDING | can transmission pending
CAN_TX_STATUS_NO_EMPTY | can transmission no empty mailbox

Definition at line 268 of file at32f413_can.h.

◆ can_tx_mailbox_num_type

enum can_tx_mailbox_num_type

can tx mailboxes

Enumerator
CAN_TX_MAILBOX0 | can tx mailbox 0
CAN_TX_MAILBOX1 | can tx mailbox 1
CAN_TX_MAILBOX2 | can tx mailbox 2

Definition at line 249 of file at32f413_can.h.


AT32F413 Firmwary Library: can_base_type Struct Reference

Data Fields
can_base_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can init structure definition More...

#include <at32f413_can.h>

Data Fields

can_mode_type mode_selection
confirm_state ttc_enable
confirm_state aebo_enable
confirm_state aed_enable
confirm_state prsf_enable
can_msg_discarding_rule_type mdrsel_selection
can_msg_sending_rule_type mmssr_selection

Detailed Description

can init structure definition

Definition at line 330 of file at32f413_can.h.

Field Documentation

◆ aebo_enable

confirm_state can_base_type::aebo_enable

automatic exit bus-off enable

Definition at line 336 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ aed_enable

confirm_state can_base_type::aed_enable

automatic exit doze mode enable

Definition at line 338 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mdrsel_selection

can_msg_discarding_rule_type can_base_type::mdrsel_selection

message discarding rule select when overflow

Definition at line 342 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mmssr_selection

can_msg_sending_rule_type can_base_type::mmssr_selection

multiple message sending sequence rule

Definition at line 344 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mode_selection

can_mode_type can_base_type::mode_selection

specifies the can mode.

Definition at line 332 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ prsf_enable

confirm_state can_base_type::prsf_enable

prohibit retransmission when sending fails enable

Definition at line 340 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ ttc_enable

confirm_state can_base_type::ttc_enable

time triggered communication mode enable

Definition at line 334 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_baudrate_type Struct Reference

Data Fields
can_baudrate_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can baudrate structure definition More...

#include <at32f413_can.h>

Data Fields

uint16_t baudrate_div
can_rsaw_type rsaw_size
can_bts1_type bts1_size
can_bts2_type bts2_size

Detailed Description

can baudrate structure definition

Definition at line 351 of file at32f413_can.h.

Field Documentation

◆ baudrate_div

uint16_t can_baudrate_type::baudrate_div

baudrate division,this parameter can be 0x001~0x1000.

Definition at line 353 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ bts1_size

can_bts1_type can_baudrate_type::bts1_size

bit time segment 1

Definition at line 357 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ bts2_size

can_bts2_type can_baudrate_type::bts2_size

bit time segment 2

Definition at line 359 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ rsaw_size

can_rsaw_type can_baudrate_type::rsaw_size

resynchronization adjust width

Definition at line 355 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_filter_init_type Struct Reference

Data Fields
can_filter_init_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can filter init structure definition More...

#include <at32f413_can.h>

Data Fields

confirm_state filter_activate_enable
can_filter_mode_type filter_mode
can_filter_fifo_type filter_fifo
uint8_t | filter_number
can_filter_bit_width_type filter_bit
uint16_t | filter_id_high
uint16_t | filter_id_low
uint16_t | filter_mask_high
uint16_t | filter_mask_low

Detailed Description

can filter init structure definition

Definition at line 366 of file at32f413_can.h.

Field Documentation

◆ filter_activate_enable

confirm_state can_filter_init_type::filter_activate_enable

enable or disable the filter activate.

Definition at line 368 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_bit

can_filter_bit_width_type can_filter_init_type::filter_bit

config the filter bit width 16bit or 32bit.

Definition at line 376 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_fifo

can_filter_fifo_type can_filter_init_type::filter_fifo

config the fifo which will be assigned to the filter.

Definition at line 372 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_id_high

uint16_t can_filter_init_type::filter_id_high

config the filter identification, for 32-bit configuration it's high 16 bits, for 16-bit configuration it's first.

Definition at line 378 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_id_low

uint16_t can_filter_init_type::filter_id_low

config the filter identification, for 32-bit configuration it's low 16 bits, for 16-bit configuration it's second.

Definition at line 381 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mask_high

uint16_t can_filter_init_type::filter_mask_high

config the filter mask or identification, according to the filtering mode, for 32-bit configuration it's high 16 bits, for 16-bit configuration it's first.

Definition at line 384 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mask_low

uint16_t can_filter_init_type::filter_mask_low

config the filter mask or identification, according to the filtering mode, for 32-bit configuration it's low 16 bits, for 16-bit configuration it's second.

Definition at line 387 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mode

can_filter_mode_type can_filter_init_type::filter_mode

config the filter mode mask or list.

Definition at line 370 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_number

uint8_t can_filter_init_type::filter_number

config the filter number, parameter ranges from 0 to 13.

Definition at line 374 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_tx_message_type Struct Reference

Data Fields
can_tx_message_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can tx message structure definition More...

#include <at32f413_can.h>

Data Fields

uint32_t | standard_id
uint32_t | extended_id
can_identifier_type id_type
can_trans_frame_type frame_type
uint8_t | dlc
uint8_t | data [8]

Detailed Description

can tx message structure definition

Definition at line 394 of file at32f413_can.h.

Field Documentation

◆ data

uint8_t can_tx_message_type::data[8]

contains the transmit data. it ranges from 0 to 0xFF.

Definition at line 409 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ dlc

uint8_t can_tx_message_type::dlc

specifies frame data length that will be transmitted. this parameter can be a value between 0 to 8

Definition at line 406 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ extended_id

uint32_t can_tx_message_type::extended_id

specifies the 29 bits extended identifier. this parameter can be a value between 0 to 0x1FFFFFFF.

Definition at line 399 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ frame_type

can_trans_frame_type can_tx_message_type::frame_type

specifies frame type for the transmit message.

Definition at line 404 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ id_type

can_identifier_type can_tx_message_type::id_type

specifies identifier type for the transmit message.

Definition at line 402 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ standard_id

uint32_t can_tx_message_type::standard_id

specifies the 11 bits standard identifier. this parameter can be a value between 0 to 0x7FF.

Definition at line 396 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_rx_message_type Struct Reference

Data Fields
can_rx_message_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can rx message structure definition More...

#include <at32f413_can.h>

Data Fields

uint32_t | standard_id
uint32_t | extended_id
can_identifier_type id_type
can_trans_frame_type frame_type
uint8_t | dlc
uint8_t | data [8]
uint8_t | filter_index

Detailed Description

can rx message structure definition

Definition at line 416 of file at32f413_can.h.

Field Documentation

◆ data

uint8_t can_rx_message_type::data[8]

contains the receive data. it ranges from 0 to 0xFF.

Definition at line 431 of file at32f413_can.h.

Referenced by can_message_receive().

◆ dlc

uint8_t can_rx_message_type::dlc

specifies the frame data length that will be received. this parameter can be a value between 0 to 8

Definition at line 428 of file at32f413_can.h.

Referenced by can_message_receive().

◆ extended_id

uint32_t can_rx_message_type::extended_id

specifies the 29 bits extended identifier. this parameter can be a value between 0 to 0x1FFFFFFF.

Definition at line 421 of file at32f413_can.h.

Referenced by can_message_receive(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ filter_index

uint8_t can_rx_message_type::filter_index

specifies the message stored in which filter this parameter can be a value between 0 to 0xFF

Definition at line 433 of file at32f413_can.h.

Referenced by can_message_receive().

◆ frame_type

can_trans_frame_type can_rx_message_type::frame_type

specifies frame type for the receive message.

Definition at line 426 of file at32f413_can.h.

Referenced by can_message_receive().

◆ id_type

can_identifier_type can_rx_message_type::id_type

specifies identifier type for the receive message.

Definition at line 424 of file at32f413_can.h.

Referenced by can_message_receive(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ standard_id

uint32_t can_rx_message_type::standard_id

specifies the 11 bits standard identifier this parameter can be a value between 0 to 0x7FF.

Definition at line 418 of file at32f413_can.h.

Referenced by can_message_receive(), and USBFS_L_CAN1_RX0_IRQHandler().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_tx_mailbox_type Struct Reference

Data Fields
can_tx_mailbox_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can controller area network tx mailbox More...

#include <at32f413_can.h>

Data Fields

union {
__IO uint32_t tmi
struct {
__IO uint32_t tmsr: 1
__IO uint32_t tmfrsel: 1
__IO uint32_t tmidsel: 1
__IO uint32_t tmeid: 18
__IO uint32_t tmsid: 11
} tmi_bit
};
can tmi register More...
union {
__IO uint32_t tmc
struct {
__IO uint32_t tmdtbl: 4
__IO uint32_t reserved1: 4
__IO uint32_t tmtsten: 1
__IO uint32_t reserved2: 7
__IO uint32_t tmts: 16
} tmc_bit
};
can tmc register More...
union {
__IO uint32_t tmdtl
struct {
__IO uint32_t tmdt0: 8
__IO uint32_t tmdt1: 8
__IO uint32_t tmdt2: 8
__IO uint32_t tmdt3: 8
} tmdtl_bit
};
can tmdtl register More...
union {
__IO uint32_t tmdth
struct {
__IO uint32_t tmdt4: 8
__IO uint32_t tmdt5: 8
__IO uint32_t tmdt6: 8
__IO uint32_t tmdt7: 8
} tmdth_bit
};
can tmdth register More...

Detailed Description

can controller area network tx mailbox

Definition at line 440 of file at32f413_can.h.

Field Documentation

◆

union { ... } can_tx_mailbox_type::@214

can tmi register

◆

union { ... } can_tx_mailbox_type::@216

can tmc register

◆

union { ... } can_tx_mailbox_type::@218

can tmdtl register

◆

union { ... } can_tx_mailbox_type::@220

can tmdth register

◆ reserved1

__IO uint32_t can_tx_mailbox_type::reserved1

Definition at line 467 of file at32f413_can.h.

◆ reserved2

__IO uint32_t can_tx_mailbox_type::reserved2

Definition at line 469 of file at32f413_can.h.

◆ tmc

__IO uint32_t can_tx_mailbox_type::tmc

Definition at line 463 of file at32f413_can.h.

◆

struct { ... } can_tx_mailbox_type::tmc_bit

Referenced by can_message_transmit(), and can_ttc_mode_enable().

◆ tmdt0

__IO uint32_t can_tx_mailbox_type::tmdt0

Definition at line 482 of file at32f413_can.h.

◆ tmdt1

__IO uint32_t can_tx_mailbox_type::tmdt1

Definition at line 483 of file at32f413_can.h.

◆ tmdt2

__IO uint32_t can_tx_mailbox_type::tmdt2

Definition at line 484 of file at32f413_can.h.

◆ tmdt3

__IO uint32_t can_tx_mailbox_type::tmdt3

Definition at line 485 of file at32f413_can.h.

◆ tmdt4

__IO uint32_t can_tx_mailbox_type::tmdt4

Definition at line 497 of file at32f413_can.h.

◆ tmdt5

__IO uint32_t can_tx_mailbox_type::tmdt5

Definition at line 498 of file at32f413_can.h.

◆ tmdt6

__IO uint32_t can_tx_mailbox_type::tmdt6

Definition at line 499 of file at32f413_can.h.

◆ tmdt7

__IO uint32_t can_tx_mailbox_type::tmdt7

Definition at line 500 of file at32f413_can.h.

◆ tmdtbl

__IO uint32_t can_tx_mailbox_type::tmdtbl

Definition at line 466 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmdth

__IO uint32_t can_tx_mailbox_type::tmdth

Definition at line 494 of file at32f413_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmdth_bit

◆ tmdtl

__IO uint32_t can_tx_mailbox_type::tmdtl

Definition at line 479 of file at32f413_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmdtl_bit

◆ tmeid

__IO uint32_t can_tx_mailbox_type::tmeid

Definition at line 453 of file at32f413_can.h.

◆ tmfrsel

__IO uint32_t can_tx_mailbox_type::tmfrsel

Definition at line 451 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmi

__IO uint32_t can_tx_mailbox_type::tmi

Definition at line 447 of file at32f413_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmi_bit

Referenced by can_message_transmit().

◆ tmidsel

__IO uint32_t can_tx_mailbox_type::tmidsel

Definition at line 452 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmsid

__IO uint32_t can_tx_mailbox_type::tmsid

Definition at line 454 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmsr

__IO uint32_t can_tx_mailbox_type::tmsr

Definition at line 450 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmts

__IO uint32_t can_tx_mailbox_type::tmts

Definition at line 470 of file at32f413_can.h.

◆ tmtsten

__IO uint32_t can_tx_mailbox_type::tmtsten

Definition at line 468 of file at32f413_can.h.

Referenced by can_ttc_mode_enable().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_fifo_mailbox_type Struct Reference

Data Fields
can_fifo_mailbox_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can controller area network fifo mailbox More...

#include <at32f413_can.h>

Data Fields

union {
__IO uint32_t rfi
struct {
__IO uint32_t reserved1: 1
__IO uint32_t rffri: 1
__IO uint32_t rfidi: 1
__IO uint32_t rfeid: 18
__IO uint32_t rfsid: 11
} rfi_bit
};
can rfi register More...
union {
__IO uint32_t rfc
struct {
__IO uint32_t rfdtl: 4
__IO uint32_t reserved1: 4
__IO uint32_t rffmn: 8
__IO uint32_t rfts: 16
} rfc_bit
};
can rfc register More...
union {
__IO uint32_t rfdtl
struct {
__IO uint32_t rfdt0: 8
__IO uint32_t rfdt1: 8
__IO uint32_t rfdt2: 8
__IO uint32_t rfdt3: 8
} rfdtl_bit
};
can rfdtl register More...
union {
__IO uint32_t rfdth
struct {
__IO uint32_t rfdt4: 8
__IO uint32_t rfdt5: 8
__IO uint32_t rfdt6: 8
__IO uint32_t rfdt7: 8
} rfdth_bit
};
can rfdth register More...

Detailed Description

can controller area network fifo mailbox

Definition at line 508 of file at32f413_can.h.

Field Documentation

◆

union { ... } can_fifo_mailbox_type::@226

can rfi register

◆

union { ... } can_fifo_mailbox_type::@228

can rfc register

◆

union { ... } can_fifo_mailbox_type::@230

can rfdtl register

◆

union { ... } can_fifo_mailbox_type::@232

can rfdth register

◆ reserved1

__IO uint32_t can_fifo_mailbox_type::reserved1

Definition at line 518 of file at32f413_can.h.

◆ rfc

__IO uint32_t can_fifo_mailbox_type::rfc

Definition at line 531 of file at32f413_can.h.

◆

struct { ... } can_fifo_mailbox_type::rfc_bit

Referenced by can_message_receive().

◆ rfdt0

__IO uint32_t can_fifo_mailbox_type::rfdt0

Definition at line 549 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt1

__IO uint32_t can_fifo_mailbox_type::rfdt1

Definition at line 550 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt2

__IO uint32_t can_fifo_mailbox_type::rfdt2

Definition at line 551 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt3

__IO uint32_t can_fifo_mailbox_type::rfdt3

Definition at line 552 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt4

__IO uint32_t can_fifo_mailbox_type::rfdt4

Definition at line 564 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt5

__IO uint32_t can_fifo_mailbox_type::rfdt5

Definition at line 565 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt6

__IO uint32_t can_fifo_mailbox_type::rfdt6

Definition at line 566 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt7

__IO uint32_t can_fifo_mailbox_type::rfdt7

Definition at line 567 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdth

__IO uint32_t can_fifo_mailbox_type::rfdth

Definition at line 561 of file at32f413_can.h.

◆

struct { ... } can_fifo_mailbox_type::rfdth_bit

Referenced by can_message_receive().

◆ rfdtl

__IO uint32_t can_fifo_mailbox_type::rfdtl

Definition at line 534 of file at32f413_can.h.

Referenced by can_message_receive().

◆

struct { ... } can_fifo_mailbox_type::rfdtl_bit

Referenced by can_message_receive().

◆ rfeid

__IO uint32_t can_fifo_mailbox_type::rfeid

Definition at line 521 of file at32f413_can.h.

◆ rffmn

__IO uint32_t can_fifo_mailbox_type::rffmn

Definition at line 536 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rffri

__IO uint32_t can_fifo_mailbox_type::rffri

Definition at line 519 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfi

__IO uint32_t can_fifo_mailbox_type::rfi

Definition at line 515 of file at32f413_can.h.

Referenced by can_message_receive().

◆

struct { ... } can_fifo_mailbox_type::rfi_bit

Referenced by can_message_receive().

◆ rfidi

__IO uint32_t can_fifo_mailbox_type::rfidi

Definition at line 520 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfsid

__IO uint32_t can_fifo_mailbox_type::rfsid

Definition at line 522 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfts

__IO uint32_t can_fifo_mailbox_type::rfts

Definition at line 537 of file at32f413_can.h.

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_filter_register_type Struct Reference

Data Fields
can_filter_register_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can controller area network filter bit register More...

#include <at32f413_can.h>

Data Fields

__IO uint32_t | ffdb1
__IO uint32_t | ffdb2

Detailed Description

can controller area network filter bit register

Definition at line 575 of file at32f413_can.h.

Field Documentation

◆ ffdb1

__IO uint32_t can_filter_register_type::ffdb1

Definition at line 577 of file at32f413_can.h.

Referenced by can_filter_init().

◆ ffdb2

__IO uint32_t can_filter_register_type::ffdb2

Definition at line 578 of file at32f413_can.h.

Referenced by can_filter_init().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_type Struct Reference

Data Fields
can_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

type define can register all More...

#include <at32f413_can.h>

Data Fields

union {
__IO uint32_t mctrl
struct {
__IO uint32_t fzen: 1
__IO uint32_t dzen: 1
__IO uint32_t mmssr: 1
__IO uint32_t mdrsel: 1
__IO uint32_t prsfen: 1
__IO uint32_t aeden: 1
__IO uint32_t aeboen: 1
__IO uint32_t ttcen: 1
__IO uint32_t reserved1: 7
__IO uint32_t sprst: 1
__IO uint32_t ptd: 1
__IO uint32_t reserved2: 15
} mctrl_bit
};
can mctrl register, offset:0x00 More...
union {
__IO uint32_t msts
struct {
__IO uint32_t fzc: 1
__IO uint32_t dzc: 1
__IO uint32_t eoif: 1
__IO uint32_t qdzif: 1
__IO uint32_t edzif: 1
__IO uint32_t reserved1: 3
__IO uint32_t cuss: 1
__IO uint32_t curs: 1
__IO uint32_t lsamprx: 1
__IO uint32_t realrx: 1
__IO uint32_t reserved2: 20
} msts_bit
};
can msts register, offset:0x04 More...
union {
__IO uint32_t tsts
struct {
__IO uint32_t tm0tcf: 1
__IO uint32_t tm0tsf: 1
__IO uint32_t tm0alf: 1
__IO uint32_t tm0tef: 1
__IO uint32_t reserved1: 3
__IO uint32_t tm0ct: 1
__IO uint32_t tm1tcf: 1
__IO uint32_t tm1tsf: 1
__IO uint32_t tm1alf: 1
__IO uint32_t tm1tef: 1
__IO uint32_t reserved2: 3
__IO uint32_t tm1ct: 1
__IO uint32_t tm2tcf: 1
__IO uint32_t tm2tsf: 1
__IO uint32_t tm2alf: 1
__IO uint32_t tm2tef: 1
__IO uint32_t reserved3: 3
__IO uint32_t tm2ct: 1
__IO uint32_t tmnr: 2
__IO uint32_t tm0ef: 1
__IO uint32_t tm1ef: 1
__IO uint32_t tm2ef: 1
__IO uint32_t tm0lpf: 1
__IO uint32_t tm1lpf: 1
__IO uint32_t tm2lpf: 1
} tsts_bit
};
can tsts register, offset:0x08 More...
union {
__IO uint32_t rf0
struct {
__IO uint32_t rf0mn: 2
__IO uint32_t reserved1: 1
__IO uint32_t rf0ff: 1
__IO uint32_t rf0of: 1
__IO uint32_t rf0r: 1
__IO uint32_t reserved2: 26
} rf0_bit
};
can rf0 register, offset:0x0C More...
union {
__IO uint32_t rf1
struct {
__IO uint32_t rf1mn: 2
__IO uint32_t reserved1: 1
__IO uint32_t rf1ff: 1
__IO uint32_t rf1of: 1
__IO uint32_t rf1r: 1
__IO uint32_t reserved2: 26
} rf1_bit
};
can rf1 register, offset:0x10 More...
union {
__IO uint32_t inten
struct {
__IO uint32_t tcien: 1
__IO uint32_t rf0mien: 1
__IO uint32_t rf0fien: 1
__IO uint32_t rf0oien: 1
__IO uint32_t rf1mien: 1
__IO uint32_t rf1fien: 1
__IO uint32_t rf1oien: 1
__IO uint32_t reserved1: 1
__IO uint32_t eaien: 1
__IO uint32_t epien: 1
__IO uint32_t boien: 1
__IO uint32_t etrien: 1
__IO uint32_t reserved2: 3
__IO uint32_t eoien: 1
__IO uint32_t qdzien: 1
__IO uint32_t edzien: 1
__IO uint32_t reserved3: 14
} inten_bit
};
can inten register, offset:0x14 More...
union {
__IO uint32_t ests
struct {
__IO uint32_t eaf: 1
__IO uint32_t epf: 1
__IO uint32_t bof: 1
__IO uint32_t reserved1: 1
__IO uint32_t etr: 3
__IO uint32_t reserved2: 9
__IO uint32_t tec: 8
__IO uint32_t rec: 8
} ests_bit
};
can ests register, offset:0x18 More...
union {
__IO uint32_t btmg
struct {
__IO uint32_t brdiv: 12
__IO uint32_t reserved1: 4
__IO uint32_t bts1: 4
__IO uint32_t bts2: 3
__IO uint32_t reserved2: 1
__IO uint32_t rsaw: 2
__IO uint32_t reserved3: 4
__IO uint32_t lben: 1
__IO uint32_t loen: 1
} btmg_bit
};
can btmg register, offset:0x1C More...
can_tx_mailbox_type | tx_mailbox [3]
can controller area network tx mailbox register, offset:0x180~0x1AC More...
can_fifo_mailbox_type | fifo_mailbox [2]
can controller area network fifo mailbox register, offset:0x1B0~0x1CC More...
union {
__IO uint32_t fctrl
struct {
__IO uint32_t fcs: 1
__IO uint32_t reserved1: 31
} fctrl_bit
};
can fctrl register, offset:0x200 More...
union {
__IO uint32_t fmcfg
struct {
__IO uint32_t fmsel0: 1
__IO uint32_t fmsel1: 1
__IO uint32_t fmsel2: 1
__IO uint32_t fmsel3: 1
__IO uint32_t fmsel4: 1
__IO uint32_t fmsel5: 1
__IO uint32_t fmsel6: 1
__IO uint32_t fmsel7: 1
__IO uint32_t fmsel8: 1
__IO uint32_t fmsel9: 1
__IO uint32_t fmsel10: 1
__IO uint32_t fmsel11: 1
__IO uint32_t fmsel12: 1
__IO uint32_t fmsel13: 1
__IO uint32_t reserved1: 18
} fmcfg_bit
};
can fmcfg register, offset:0x204 More...
union {
__IO uint32_t fbwcfg
struct {
__IO uint32_t fbwsel0: 1
__IO uint32_t fbwsel1: 1
__IO uint32_t fbwsel2: 1
__IO uint32_t fbwsel3: 1
__IO uint32_t fbwsel4: 1
__IO uint32_t fbwsel5: 1
__IO uint32_t fbwsel6: 1
__IO uint32_t fbwsel7: 1
__IO uint32_t fbwsel8: 1
__IO uint32_t fbwsel9: 1
__IO uint32_t fbwsel10: 1
__IO uint32_t fbwsel11: 1
__IO uint32_t fbwsel12: 1
__IO uint32_t fbwsel13: 1
__IO uint32_t reserved1: 18
} fbwcfg_bit
};
can fbwcfg register, offset:0x20C More...
__IO uint32_t | reserved4
can reserved register, offset:0x210 More...
union {
__IO uint32_t frf
struct {
__IO uint32_t frfsel0: 1
__IO uint32_t frfsel1: 1
__IO uint32_t frfsel2: 1
__IO uint32_t frfsel3: 1
__IO uint32_t frfsel4: 1
__IO uint32_t frfsel5: 1
__IO uint32_t frfsel6: 1
__IO uint32_t frfsel7: 1
__IO uint32_t frfsel8: 1
__IO uint32_t frfsel9: 1
__IO uint32_t frfsel10: 1
__IO uint32_t frfsel11: 1
__IO uint32_t frfsel12: 1
__IO uint32_t frfsel13: 1
__IO uint32_t reserved1: 18
} frf_bit
};
can frf register, offset:0x214 More...
__IO uint32_t | reserved5
can reserved register, offset:0x218 More...
union {
__IO uint32_t facfg
struct {
__IO uint32_t faen0: 1
__IO uint32_t faen1: 1
__IO uint32_t faen2: 1
__IO uint32_t faen3: 1
__IO uint32_t faen4: 1
__IO uint32_t faen5: 1
__IO uint32_t faen6: 1
__IO uint32_t faen7: 1
__IO uint32_t faen8: 1
__IO uint32_t faen9: 1
__IO uint32_t faen10: 1
__IO uint32_t faen11: 1
__IO uint32_t faen12: 1
__IO uint32_t faen13: 1
__IO uint32_t reserved1: 18
} facfg_bit
};
can facfg register, offset:0x21C More...
__IO uint32_t | reserved6 [8]
can reserved register, offset:0x220~0x23C More...
can_filter_register_type | ffb [14]
can ffb register, offset:0x240~0x2AC More...

Detailed Description

type define can register all

Definition at line 584 of file at32f413_can.h.

Field Documentation

◆

union { ... } can_type::@238

can mctrl register, offset:0x00

◆

union { ... } can_type::@240

can msts register, offset:0x04

◆

union { ... } can_type::@242

can tsts register, offset:0x08

◆

union { ... } can_type::@244

can rf0 register, offset:0x0C

◆

union { ... } can_type::@246

can rf1 register, offset:0x10

◆

union { ... } can_type::@248

can inten register, offset:0x14

◆

union { ... } can_type::@250

can ests register, offset:0x18

◆

union { ... } can_type::@252

can btmg register, offset:0x1C

◆

union { ... } can_type::@254

can fctrl register, offset:0x200

◆

union { ... } can_type::@256

can fmcfg register, offset:0x204

◆

union { ... } can_type::@258

can fbwcfg register, offset:0x20C

◆

union { ... } can_type::@260

can frf register, offset:0x214

◆

union { ... } can_type::@262

can facfg register, offset:0x21C

◆ aeboen

__IO uint32_t can_type::aeboen

Definition at line 601 of file at32f413_can.h.

Referenced by can_base_init().

◆ aeden

__IO uint32_t can_type::aeden

Definition at line 600 of file at32f413_can.h.

Referenced by can_base_init().

◆ bof

__IO uint32_t can_type::bof

Definition at line 740 of file at32f413_can.h.

Referenced by can_flag_get().

◆ boien

__IO uint32_t can_type::boien

Definition at line 720 of file at32f413_can.h.

◆ brdiv

__IO uint32_t can_type::brdiv

Definition at line 757 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ btmg

__IO uint32_t can_type::btmg

Definition at line 754 of file at32f413_can.h.

◆

struct { ... } can_type::btmg_bit

Referenced by can_base_init(), and can_baudrate_set().

◆ bts1

__IO uint32_t can_type::bts1

Definition at line 759 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ bts2

__IO uint32_t can_type::bts2

Definition at line 760 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ curs

__IO uint32_t can_type::curs

Definition at line 625 of file at32f413_can.h.

◆ cuss

__IO uint32_t can_type::cuss

Definition at line 624 of file at32f413_can.h.

◆ dzc

__IO uint32_t can_type::dzc

Definition at line 619 of file at32f413_can.h.

Referenced by can_doze_mode_enter(), can_doze_mode_exit(), can_flag_get(), and can_operating_mode_set().

◆ dzen

__IO uint32_t can_type::dzen

Definition at line 596 of file at32f413_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), can_doze_mode_exit(), and can_operating_mode_set().

◆ eaf

__IO uint32_t can_type::eaf

Definition at line 738 of file at32f413_can.h.

Referenced by can_flag_get().

◆ eaien

__IO uint32_t can_type::eaien

Definition at line 718 of file at32f413_can.h.

◆ edzien

__IO uint32_t can_type::edzien

Definition at line 725 of file at32f413_can.h.

◆ edzif

__IO uint32_t can_type::edzif

Definition at line 622 of file at32f413_can.h.

Referenced by can_flag_get().

◆ eoien

__IO uint32_t can_type::eoien

Definition at line 723 of file at32f413_can.h.

◆ eoif

__IO uint32_t can_type::eoif

Definition at line 620 of file at32f413_can.h.

Referenced by can_flag_get().

◆ epf

__IO uint32_t can_type::epf

Definition at line 739 of file at32f413_can.h.

Referenced by can_flag_get().

◆ epien

__IO uint32_t can_type::epien

Definition at line 719 of file at32f413_can.h.

◆ ests

__IO uint32_t can_type::ests

Definition at line 735 of file at32f413_can.h.

Referenced by can_flag_clear().

◆

struct { ... } can_type::ests_bit

Referenced by can_error_type_record_get(), can_flag_get(), can_receive_error_counter_get(), and can_transmit_error_counter_get().

◆ etr

__IO uint32_t can_type::etr

Definition at line 742 of file at32f413_can.h.

Referenced by can_error_type_record_get(), and can_flag_get().

◆ etrien

__IO uint32_t can_type::etrien

Definition at line 721 of file at32f413_can.h.

◆ facfg

__IO uint32_t can_type::facfg

Definition at line 900 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::facfg_bit

◆ faen0

__IO uint32_t can_type::faen0

Definition at line 903 of file at32f413_can.h.

◆ faen1

__IO uint32_t can_type::faen1

Definition at line 904 of file at32f413_can.h.

◆ faen10

__IO uint32_t can_type::faen10

Definition at line 913 of file at32f413_can.h.

◆ faen11

__IO uint32_t can_type::faen11

Definition at line 914 of file at32f413_can.h.

◆ faen12

__IO uint32_t can_type::faen12

Definition at line 915 of file at32f413_can.h.

◆ faen13

__IO uint32_t can_type::faen13

Definition at line 916 of file at32f413_can.h.

◆ faen2

__IO uint32_t can_type::faen2

Definition at line 905 of file at32f413_can.h.

◆ faen3

__IO uint32_t can_type::faen3

Definition at line 906 of file at32f413_can.h.

◆ faen4

__IO uint32_t can_type::faen4

Definition at line 907 of file at32f413_can.h.

◆ faen5

__IO uint32_t can_type::faen5

Definition at line 908 of file at32f413_can.h.

◆ faen6

__IO uint32_t can_type::faen6

Definition at line 909 of file at32f413_can.h.

◆ faen7

__IO uint32_t can_type::faen7

Definition at line 910 of file at32f413_can.h.

◆ faen8

__IO uint32_t can_type::faen8

Definition at line 911 of file at32f413_can.h.

◆ faen9

__IO uint32_t can_type::faen9

Definition at line 912 of file at32f413_can.h.

◆ fbwcfg

__IO uint32_t can_type::fbwcfg

Definition at line 838 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::fbwcfg_bit

◆ fbwsel0

__IO uint32_t can_type::fbwsel0

Definition at line 841 of file at32f413_can.h.

◆ fbwsel1

__IO uint32_t can_type::fbwsel1

Definition at line 842 of file at32f413_can.h.

◆ fbwsel10

__IO uint32_t can_type::fbwsel10

Definition at line 851 of file at32f413_can.h.

◆ fbwsel11

__IO uint32_t can_type::fbwsel11

Definition at line 852 of file at32f413_can.h.

◆ fbwsel12

__IO uint32_t can_type::fbwsel12

Definition at line 853 of file at32f413_can.h.

◆ fbwsel13

__IO uint32_t can_type::fbwsel13

Definition at line 854 of file at32f413_can.h.

◆ fbwsel2

__IO uint32_t can_type::fbwsel2

Definition at line 843 of file at32f413_can.h.

◆ fbwsel3

__IO uint32_t can_type::fbwsel3

Definition at line 844 of file at32f413_can.h.

◆ fbwsel4

__IO uint32_t can_type::fbwsel4

Definition at line 845 of file at32f413_can.h.

◆ fbwsel5

__IO uint32_t can_type::fbwsel5

Definition at line 846 of file at32f413_can.h.

◆ fbwsel6

__IO uint32_t can_type::fbwsel6

Definition at line 847 of file at32f413_can.h.

◆ fbwsel7

__IO uint32_t can_type::fbwsel7

Definition at line 848 of file at32f413_can.h.

◆ fbwsel8

__IO uint32_t can_type::fbwsel8

Definition at line 849 of file at32f413_can.h.

◆ fbwsel9

__IO uint32_t can_type::fbwsel9

Definition at line 850 of file at32f413_can.h.

◆ fcs

__IO uint32_t can_type::fcs

Definition at line 797 of file at32f413_can.h.

Referenced by can_filter_init().

◆ fctrl

__IO uint32_t can_type::fctrl

Definition at line 794 of file at32f413_can.h.

◆

struct { ... } can_type::fctrl_bit

Referenced by can_filter_init().

◆ ffb

can_filter_register_type can_type::ffb[14]

can ffb register, offset:0x240~0x2AC

Definition at line 929 of file at32f413_can.h.

Referenced by can_filter_init().

◆ fifo_mailbox

can_fifo_mailbox_type can_type::fifo_mailbox[2]

can controller area network fifo mailbox register, offset:0x1B0~0x1CC

Definition at line 782 of file at32f413_can.h.

Referenced by can_message_receive().

◆ fmcfg

__IO uint32_t can_type::fmcfg

Definition at line 807 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::fmcfg_bit

◆ fmsel0

__IO uint32_t can_type::fmsel0

Definition at line 810 of file at32f413_can.h.

◆ fmsel1

__IO uint32_t can_type::fmsel1

Definition at line 811 of file at32f413_can.h.

◆ fmsel10

__IO uint32_t can_type::fmsel10

Definition at line 820 of file at32f413_can.h.

◆ fmsel11

__IO uint32_t can_type::fmsel11

Definition at line 821 of file at32f413_can.h.

◆ fmsel12

__IO uint32_t can_type::fmsel12

Definition at line 822 of file at32f413_can.h.

◆ fmsel13

__IO uint32_t can_type::fmsel13

Definition at line 823 of file at32f413_can.h.

◆ fmsel2

__IO uint32_t can_type::fmsel2

Definition at line 812 of file at32f413_can.h.

◆ fmsel3

__IO uint32_t can_type::fmsel3

Definition at line 813 of file at32f413_can.h.

◆ fmsel4

__IO uint32_t can_type::fmsel4

Definition at line 814 of file at32f413_can.h.

◆ fmsel5

__IO uint32_t can_type::fmsel5

Definition at line 815 of file at32f413_can.h.

◆ fmsel6

__IO uint32_t can_type::fmsel6

Definition at line 816 of file at32f413_can.h.

◆ fmsel7

__IO uint32_t can_type::fmsel7

Definition at line 817 of file at32f413_can.h.

◆ fmsel8

__IO uint32_t can_type::fmsel8

Definition at line 818 of file at32f413_can.h.

◆ fmsel9

__IO uint32_t can_type::fmsel9

Definition at line 819 of file at32f413_can.h.

◆ frf

__IO uint32_t can_type::frf

Definition at line 869 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::frf_bit

◆ frfsel0

__IO uint32_t can_type::frfsel0

Definition at line 872 of file at32f413_can.h.

◆ frfsel1

__IO uint32_t can_type::frfsel1

Definition at line 873 of file at32f413_can.h.

◆ frfsel10

__IO uint32_t can_type::frfsel10

Definition at line 882 of file at32f413_can.h.

◆ frfsel11

__IO uint32_t can_type::frfsel11

Definition at line 883 of file at32f413_can.h.

◆ frfsel12

__IO uint32_t can_type::frfsel12

Definition at line 884 of file at32f413_can.h.

◆ frfsel13

__IO uint32_t can_type::frfsel13

Definition at line 885 of file at32f413_can.h.

◆ frfsel2

__IO uint32_t can_type::frfsel2

Definition at line 874 of file at32f413_can.h.

◆ frfsel3

__IO uint32_t can_type::frfsel3

Definition at line 875 of file at32f413_can.h.

◆ frfsel4

__IO uint32_t can_type::frfsel4

Definition at line 876 of file at32f413_can.h.

◆ frfsel5

__IO uint32_t can_type::frfsel5

Definition at line 877 of file at32f413_can.h.

◆ frfsel6

__IO uint32_t can_type::frfsel6

Definition at line 878 of file at32f413_can.h.

◆ frfsel7

__IO uint32_t can_type::frfsel7

Definition at line 879 of file at32f413_can.h.

◆ frfsel8

__IO uint32_t can_type::frfsel8

Definition at line 880 of file at32f413_can.h.

◆ frfsel9

__IO uint32_t can_type::frfsel9

Definition at line 881 of file at32f413_can.h.

◆ fzc

__IO uint32_t can_type::fzc

Definition at line 618 of file at32f413_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), and can_operating_mode_set().

◆ fzen

__IO uint32_t can_type::fzen

Definition at line 595 of file at32f413_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), and can_operating_mode_set().

◆ inten

__IO uint32_t can_type::inten

Definition at line 707 of file at32f413_can.h.

Referenced by can_interrupt_enable().

◆

struct { ... } can_type::inten_bit

◆ lben

__IO uint32_t can_type::lben

Definition at line 764 of file at32f413_can.h.

Referenced by can_base_init().

◆ loen

__IO uint32_t can_type::loen

Definition at line 765 of file at32f413_can.h.

Referenced by can_base_init().

◆ lsamprx

__IO uint32_t can_type::lsamprx

Definition at line 626 of file at32f413_can.h.

◆ mctrl

__IO uint32_t can_type::mctrl

Definition at line 592 of file at32f413_can.h.

◆

struct { ... } can_type::mctrl_bit

Referenced by can_base_init(), can_baudrate_set(), can_debug_transmission_prohibit(), can_doze_mode_enter(), can_doze_mode_exit(), can_operating_mode_set(), and can_ttc_mode_enable().

◆ mdrsel

__IO uint32_t can_type::mdrsel

Definition at line 598 of file at32f413_can.h.

Referenced by can_base_init().

◆ mmssr

__IO uint32_t can_type::mmssr

Definition at line 597 of file at32f413_can.h.

Referenced by can_base_init().

◆ msts

__IO uint32_t can_type::msts

Definition at line 615 of file at32f413_can.h.

Referenced by can_flag_clear().

◆

struct { ... } can_type::msts_bit

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), can_doze_mode_exit(), can_flag_get(), and can_operating_mode_set().

◆ prsfen

__IO uint32_t can_type::prsfen

Definition at line 599 of file at32f413_can.h.

Referenced by can_base_init().

◆ ptd

__IO uint32_t can_type::ptd

Definition at line 605 of file at32f413_can.h.

Referenced by can_debug_transmission_prohibit().

◆ qdzien

__IO uint32_t can_type::qdzien

Definition at line 724 of file at32f413_can.h.

◆ qdzif

__IO uint32_t can_type::qdzif

Definition at line 621 of file at32f413_can.h.

Referenced by can_flag_get().

◆ realrx

__IO uint32_t can_type::realrx

Definition at line 627 of file at32f413_can.h.

◆ rec

__IO uint32_t can_type::rec

Definition at line 745 of file at32f413_can.h.

Referenced by can_receive_error_counter_get().

◆ reserved1

__IO uint32_t can_type::reserved1

can reserved register, offset:0x20~0x17C

Definition at line 603 of file at32f413_can.h.

◆ reserved2

__IO uint32_t can_type::reserved2

can reserved register, offset:0x1D0~0x1FC

Definition at line 606 of file at32f413_can.h.

◆ reserved3

__IO uint32_t can_type::reserved3

can reserved register, offset:0x208

Definition at line 656 of file at32f413_can.h.

◆ reserved4

__IO uint32_t can_type::reserved4

can reserved register, offset:0x210

Definition at line 862 of file at32f413_can.h.

◆ reserved5

__IO uint32_t can_type::reserved5

can reserved register, offset:0x218

Definition at line 893 of file at32f413_can.h.

◆ reserved6

__IO uint32_t can_type::reserved6[8]

can reserved register, offset:0x220~0x23C

Definition at line 924 of file at32f413_can.h.

◆ rf0

__IO uint32_t can_type::rf0

Definition at line 673 of file at32f413_can.h.

Referenced by can_flag_clear(), and can_receive_fifo_release().

◆

struct { ... } can_type::rf0_bit

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf0ff

__IO uint32_t can_type::rf0ff

Definition at line 678 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf0fien

__IO uint32_t can_type::rf0fien

Definition at line 712 of file at32f413_can.h.

◆ rf0mien

__IO uint32_t can_type::rf0mien

Definition at line 711 of file at32f413_can.h.

◆ rf0mn

__IO uint32_t can_type::rf0mn

Definition at line 676 of file at32f413_can.h.

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf0of

__IO uint32_t can_type::rf0of

Definition at line 679 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf0oien

__IO uint32_t can_type::rf0oien

Definition at line 713 of file at32f413_can.h.

◆ rf0r

__IO uint32_t can_type::rf0r

Definition at line 680 of file at32f413_can.h.

◆ rf1

__IO uint32_t can_type::rf1

Definition at line 690 of file at32f413_can.h.

Referenced by can_flag_clear(), and can_receive_fifo_release().

◆

struct { ... } can_type::rf1_bit

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf1ff

__IO uint32_t can_type::rf1ff

Definition at line 695 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf1fien

__IO uint32_t can_type::rf1fien

Definition at line 715 of file at32f413_can.h.

◆ rf1mien

__IO uint32_t can_type::rf1mien

Definition at line 714 of file at32f413_can.h.

◆ rf1mn

__IO uint32_t can_type::rf1mn

Definition at line 693 of file at32f413_can.h.

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf1of

__IO uint32_t can_type::rf1of

Definition at line 696 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf1oien

__IO uint32_t can_type::rf1oien

Definition at line 716 of file at32f413_can.h.

◆ rf1r

__IO uint32_t can_type::rf1r

Definition at line 697 of file at32f413_can.h.

◆ rsaw

__IO uint32_t can_type::rsaw

Definition at line 762 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ sprst

__IO uint32_t can_type::sprst

Definition at line 604 of file at32f413_can.h.

◆ tcien

__IO uint32_t can_type::tcien

Definition at line 710 of file at32f413_can.h.

◆ tec

__IO uint32_t can_type::tec

Definition at line 744 of file at32f413_can.h.

Referenced by can_transmit_error_counter_get().

◆ tm0alf

__IO uint32_t can_type::tm0alf

Definition at line 642 of file at32f413_can.h.

◆ tm0ct

__IO uint32_t can_type::tm0ct

Definition at line 645 of file at32f413_can.h.

◆ tm0ef

__IO uint32_t can_type::tm0ef

Definition at line 659 of file at32f413_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm0lpf

__IO uint32_t can_type::tm0lpf

Definition at line 662 of file at32f413_can.h.

◆ tm0tcf

__IO uint32_t can_type::tm0tcf

Definition at line 640 of file at32f413_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm0tef

__IO uint32_t can_type::tm0tef

Definition at line 643 of file at32f413_can.h.

◆ tm0tsf

__IO uint32_t can_type::tm0tsf

Definition at line 641 of file at32f413_can.h.

Referenced by can_transmit_status_get().

◆ tm1alf

__IO uint32_t can_type::tm1alf

Definition at line 648 of file at32f413_can.h.

◆ tm1ct

__IO uint32_t can_type::tm1ct

Definition at line 651 of file at32f413_can.h.

◆ tm1ef

__IO uint32_t can_type::tm1ef

Definition at line 660 of file at32f413_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm1lpf

__IO uint32_t can_type::tm1lpf

Definition at line 663 of file at32f413_can.h.

◆ tm1tcf

__IO uint32_t can_type::tm1tcf

Definition at line 646 of file at32f413_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm1tef

__IO uint32_t can_type::tm1tef

Definition at line 649 of file at32f413_can.h.

◆ tm1tsf

__IO uint32_t can_type::tm1tsf

Definition at line 647 of file at32f413_can.h.

Referenced by can_transmit_status_get().

◆ tm2alf

__IO uint32_t can_type::tm2alf

Definition at line 654 of file at32f413_can.h.

◆ tm2ct

__IO uint32_t can_type::tm2ct

Definition at line 657 of file at32f413_can.h.

◆ tm2ef

__IO uint32_t can_type::tm2ef

Definition at line 661 of file at32f413_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm2lpf

__IO uint32_t can_type::tm2lpf

Definition at line 664 of file at32f413_can.h.

◆ tm2tcf

__IO uint32_t can_type::tm2tcf

Definition at line 652 of file at32f413_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm2tef

__IO uint32_t can_type::tm2tef

Definition at line 655 of file at32f413_can.h.

◆ tm2tsf

__IO uint32_t can_type::tm2tsf

Definition at line 653 of file at32f413_can.h.

Referenced by can_transmit_status_get().

◆ tmnr

__IO uint32_t can_type::tmnr

Definition at line 658 of file at32f413_can.h.

◆ tsts

__IO uint32_t can_type::tsts

Definition at line 637 of file at32f413_can.h.

Referenced by can_flag_clear(), and can_transmit_cancel().

◆

struct { ... } can_type::tsts_bit

Referenced by can_flag_get(), can_message_transmit(), and can_transmit_status_get().

◆ ttcen

__IO uint32_t can_type::ttcen

Definition at line 602 of file at32f413_can.h.

Referenced by can_base_init(), and can_ttc_mode_enable().

◆ tx_mailbox

can_tx_mailbox_type can_type::tx_mailbox[3]

can controller area network tx mailbox register, offset:0x180~0x1AC

Definition at line 777 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_ttc_mode_enable().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: CAN_exported_functions

Functions
CAN_exported_functions
AT32F413_periph_driver » CAN

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

Function Documentation

◆ can_base_init()

error_status can_base_init | ( | can_type * | can_x,
 |  | can_base_type * | can_base_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_base_struct | pointer to a can_base_struct structure that contains the configuration information for the can peripheral.
Return values
the status of initialization this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 195 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_baudrate_default_para_init()

void can_baudrate_default_para_init ( can_baudrate_type * can_baudrate_struct )

fill each can_baudrate_struct member with its default value.

Parameters
can_baudrate_struct pointer to a can_baudrate_type structure which will be initialized.
Return values
none.

Definition at line 71 of file at32f413_can.c.

◆ can_baudrate_set()

error_status can_baudrate_set | ( | can_type * | can_x,
 |  | can_baudrate_type * | can_baudrate_struct
 | ) |  |

set the baudrate of the can peripheral

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_baudrate_struct | pointer to a can_baudrate_type structure which will be set.
Note
baudrate calculate method is: baudrate = fpclk/(baudrate_div *(3 + bts1_size + bts2_size))
Return values
the result of baudrate set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 100 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_debug_transmission_prohibit()

void can_debug_transmission_prohibit | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the debug transmission prohibit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
new_state | new state of debug transmission prohibit. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 396 of file at32f413_can.c.

◆ can_default_para_init()

void can_default_para_init ( can_base_type * can_base_struct )

fill each can_init_struct member with its default value.

Parameters
can_base_struct pointer to a can_base_type structure which will be initialized.
Return values
none.

Definition at line 158 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_doze_mode_enter()

can_enter_doze_status_type can_doze_mode_enter ( can_type * can_x )

enter the low power mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_ENTER_DOZE_SUCCESSFUL <it meaning enter the doze mode succeed>
  • CAN_ENTER_DOZE_FAILED <it meaning enter the doze mode failed>

< time out for fzc bit

Definition at line 802 of file at32f413_can.c.

◆ can_doze_mode_exit()

can_quit_doze_status_type can_doze_mode_exit ( can_type * can_x )

exit the doze mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_QUIT_DOZE_SUCCESSFUL <it meaning exit the doze mode succeed>
  • CAN_QUIT_DOZE_FAILED <it meaning exit the doze mode failed>

< time out for dzc bit

Definition at line 832 of file at32f413_can.c.

◆ can_error_type_record_get()

can_error_record_type can_error_type_record_get ( can_type * can_x )

return the error type record (etr) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of the error code the return can be one of the follow values:
  • CAN_ERRORRECORD_NOERR
  • CAN_ERRORRECORD_STUFFERR,
  • CAN_ERRORRECORD_FORMERR,
  • CAN_ERRORRECORD_ACKERR,
  • CAN_ERRORRECORD_BITRECESSIVEERR,
  • CAN_ERRORRECORD_BITDOMINANTERR,
  • CAN_ERRORRECORD_CRCERR,
  • CAN_ERRORRECORD_SOFTWARESETERR

Definition at line 864 of file at32f413_can.c.

◆ can_filter_default_para_init()

void can_filter_default_para_init ( can_filter_init_type * can_filter_init_struct )

fill each can_filter_init_struct member with its default value.

Parameters
can_filter_init_struct pointer to a can_filter_init_type structure which will be initialized.
Return values
none.

Definition at line 270 of file at32f413_can.c.

◆ can_filter_init()

void can_filter_init | ( | can_type * | can_x,
 |  | can_filter_init_type * | can_filter_init_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_filter_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_filter_init_struct | pointer to a can_filter_init_type structure that contains the configuration information.
Return values
none.

Definition at line 305 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_flag_clear()

void can_flag_clear | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

clear flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG
  • CAN_ETR_SOFTWARE_FLAG note:CAN_RF0MN_FLAG and CAN_RF1MN_FLAG can not clear by this function
Return values
none.

< error active flag

< error passive flag

< bus-off flag

< error occur interrupt flag

< eoif bit value, it clear by writing 1

< error type record flag

< eoif bit value, it clear by writing 1

< transmit mailbox 0 transmission completed flag

< tm0tcf bit value, it clear by writing 1

< transmit mailbox 1 transmission completed flag

< tm1tcf bit value, it clear by writing 1

< transmit mailbox 2 transmission completed flag

< tm2tcf bit value, it clear by writing 1

< receive fifo 0 full flag

< rf0ff bit value, it clear by writing 1

< receive fifo 0 overflow flag

< rf0of bit value, it clear by writing 1

< receive fifo 1 full flag

< rf1ff bit value, it clear by writing 1

< receive fifo 1 overflow flag

< rf1of bit value, it clear by writing 1

< quit doze mode interrupt flag

< qdzif bit value, it clear by writing 1

< enter doze mode confirm flag

< edzif bit value, it clear by writing 1

< transmit mailbox empty flag

< tm0tcf bit value, it clear by writing 1

< tm1tcf bit value, it clear by writing 1

< tm2tcf bit value, it clear by writing 1

Definition at line 1089 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler().

◆ can_flag_get()

flag_status can_flag_get | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

get flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0MN_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1MN_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:the state of CAN_EDZC_FLAG need to check dzc and edzif bit note:the state of CAN_TMEF_FLAG need to check rqc0,rqc1 and rqc2 bit
Return values
status of can_flag, the returned value can be:SET or RESET.

< error active flag

< error passive flag

< bus-off flag

< error type record flag

< error occur interrupt flag

< transmit mailbox 0 transmission completed flag

< transmit mailbox 1 transmission completed flag

< transmit mailbox 2 transmission completed flag

< receive fifo 0 message num flag

< receive fifo 0 full flag

< receive fifo 0 overflow flag

< receive fifo 1 message num flag

< receive fifo 1 full flag

< receive fifo 1 overflow flag

< quit doze mode interrupt flag

< enter doze mode confirm flag

< transmit mailbox empty flag

Definition at line 965 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ can_interrupt_enable()

void can_interrupt_enable | ( | can_type * | can_x,
 |  | uint32_t | can_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the interrupt of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_int specifies the can interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • CAN_TCIEN_INT
  • CAN_RF0MIEN_INT
  • CAN_RF0FIEN_INT
  • CAN_RF0OIEN_INT
  • CAN_RF1MIEN_INT
  • CAN_RF1FIEN_INT
  • CAN_RF1OIEN_INT
  • CAN_EAIEN_INT
  • CAN_EPIEN_INT
  • CAN_BOIEN_INT
  • CAN_ETRIEN_INT
  • CAN_EOIEN_INT
  • CAN_QDZIEN_INT
  • CAN_EDZIEN_INT
new_state | new state of the can interrupts. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 925 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_message_receive()

void can_message_receive | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number,
 |  | can_rx_message_type * | rx_message_struct
 | ) |  |

receive message of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
rx_message_struct | pointer to a structure which store the receive message.
Return values
none.

Definition at line 620 of file at32f413_can.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ can_message_transmit()

uint8_t can_message_transmit | ( | can_type * | can_x,
 |  | can_tx_message_type * | tx_message_struct
 | ) |  |

fill the transmission message and transmit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
tx_message_struct | pointer to a structure which contains the message to be trans.
Return values
the number of the mailbox that is used for transmission: this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
  • CAN_TX_STATUS_NO_EMPTY <meanings there is no empty mailbox, message cannot be filled>

Definition at line 441 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_operating_mode_set()

error_status can_operating_mode_set | ( | can_type * | can_x,
 |  | can_operating_mode_type | can_operating_mode
 | ) |  |

set the operation mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_operating_mode can operating mode. this parameter can be one of the following values:
  • CAN_OPERATINGMODE_FREEZE
  • CAN_OPERATINGMODE_DOZE
  • CAN_OPERATINGMODE_COMMUNICATE
Return values
status of operation mode set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

Definition at line 724 of file at32f413_can.c.

◆ can_receive_error_counter_get()

uint8_t can_receive_error_counter_get ( can_type * can_x )

return the receive error counter (rec) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of receive error counter.

Definition at line 879 of file at32f413_can.c.

◆ can_receive_fifo_release()

void can_receive_fifo_release | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

release the specified fifo of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number fifo to be release. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
none.

< rf0r bit value, it clear by writing 1

< rf1r bit value, it clear by writing 1

Definition at line 667 of file at32f413_can.c.

Referenced by can_message_receive().

◆ can_receive_message_pending_get()

uint8_t can_receive_message_pending_get | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

return the number of pending messages of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
the number of message pending in the receive fifo.

Definition at line 693 of file at32f413_can.c.

◆ can_reset()

void can_reset ( can_type * can_x )

deinitialize the can peripheral registers to their default reset values.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
none.

Definition at line 49 of file at32f413_can.c.

◆ can_transmit_cancel()

void can_transmit_cancel | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

cancel a transmit request of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
mailbox mailbox number. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
none.

< tm0ct bit value, it clear by writing 1

< tm1ct bit value, it clear by writing 1

< tm2ct bit value, it clear by writing 1

Definition at line 590 of file at32f413_can.c.

◆ can_transmit_error_counter_get()

uint8_t can_transmit_error_counter_get ( can_type * can_x )

return the transmit error counter of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of transmit error counter.

Definition at line 893 of file at32f413_can.c.

◆ can_transmit_status_get()

can_transmit_status_type can_transmit_status_get | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

check the transmission state of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
transmit_mailbox the number of the mailbox that is used for transmission. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
can transmit status this parameter can be one of the following values:
  • CAN_TX_STATUS_SUCCESSFUL
  • CAN_TX_STATUS_FAILED
  • CAN_TX_STATUS_PENDING

Definition at line 515 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_ttc_mode_enable()

void can_ttc_mode_enable | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable time trigger operation communication mode of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
new_state | : new state of time trigger operation communication mode. this parameter can be: TRUE or FALSE.
Note
note1: when enabled, transmit mailbox time stamp(tmts[15:0]) value is sent in the last two data bytes of the 8-byte message: tmts[7:0] in data byte 6 and tmts[15:8] in data byte 7
note2: tmdtbl must be programmed as 8 in order time stamp (2 bytes) to be sent over the can bus.
Return values
none

Definition at line 417 of file at32f413_can.c.


AT32F413 Firmwary Library: CAN_private_functions

Functions
CAN_private_functions
AT32F413_periph_driver » CAN

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

Function Documentation

◆ can_base_init()

error_status can_base_init | ( | can_type * | can_x,
 |  | can_base_type * | can_base_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_base_struct | pointer to a can_base_struct structure that contains the configuration information for the can peripheral.
Return values
the status of initialization this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 195 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_baudrate_default_para_init()

void can_baudrate_default_para_init ( can_baudrate_type * can_baudrate_struct )

fill each can_baudrate_struct member with its default value.

Parameters
can_baudrate_struct pointer to a can_baudrate_type structure which will be initialized.
Return values
none.

Definition at line 71 of file at32f413_can.c.

◆ can_baudrate_set()

error_status can_baudrate_set | ( | can_type * | can_x,
 |  | can_baudrate_type * | can_baudrate_struct
 | ) |  |

set the baudrate of the can peripheral

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_baudrate_struct | pointer to a can_baudrate_type structure which will be set.
Note
baudrate calculate method is: baudrate = fpclk/(baudrate_div *(3 + bts1_size + bts2_size))
Return values
the result of baudrate set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 100 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_debug_transmission_prohibit()

void can_debug_transmission_prohibit | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the debug transmission prohibit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
new_state | new state of debug transmission prohibit. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 396 of file at32f413_can.c.

◆ can_default_para_init()

void can_default_para_init ( can_base_type * can_base_struct )

fill each can_init_struct member with its default value.

Parameters
can_base_struct pointer to a can_base_type structure which will be initialized.
Return values
none.

Definition at line 158 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_doze_mode_enter()

can_enter_doze_status_type can_doze_mode_enter ( can_type * can_x )

enter the low power mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_ENTER_DOZE_SUCCESSFUL <it meaning enter the doze mode succeed>
  • CAN_ENTER_DOZE_FAILED <it meaning enter the doze mode failed>

< time out for fzc bit

Definition at line 802 of file at32f413_can.c.

◆ can_doze_mode_exit()

can_quit_doze_status_type can_doze_mode_exit ( can_type * can_x )

exit the doze mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_QUIT_DOZE_SUCCESSFUL <it meaning exit the doze mode succeed>
  • CAN_QUIT_DOZE_FAILED <it meaning exit the doze mode failed>

< time out for dzc bit

Definition at line 832 of file at32f413_can.c.

◆ can_error_type_record_get()

can_error_record_type can_error_type_record_get ( can_type * can_x )

return the error type record (etr) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of the error code the return can be one of the follow values:
  • CAN_ERRORRECORD_NOERR
  • CAN_ERRORRECORD_STUFFERR,
  • CAN_ERRORRECORD_FORMERR,
  • CAN_ERRORRECORD_ACKERR,
  • CAN_ERRORRECORD_BITRECESSIVEERR,
  • CAN_ERRORRECORD_BITDOMINANTERR,
  • CAN_ERRORRECORD_CRCERR,
  • CAN_ERRORRECORD_SOFTWARESETERR

Definition at line 864 of file at32f413_can.c.

◆ can_filter_default_para_init()

void can_filter_default_para_init ( can_filter_init_type * can_filter_init_struct )

fill each can_filter_init_struct member with its default value.

Parameters
can_filter_init_struct pointer to a can_filter_init_type structure which will be initialized.
Return values
none.

Definition at line 270 of file at32f413_can.c.

◆ can_filter_init()

void can_filter_init | ( | can_type * | can_x,
 |  | can_filter_init_type * | can_filter_init_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_filter_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_filter_init_struct | pointer to a can_filter_init_type structure that contains the configuration information.
Return values
none.

Definition at line 305 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_flag_clear()

void can_flag_clear | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

clear flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG
  • CAN_ETR_SOFTWARE_FLAG note:CAN_RF0MN_FLAG and CAN_RF1MN_FLAG can not clear by this function
Return values
none.

< error active flag

< error passive flag

< bus-off flag

< error occur interrupt flag

< eoif bit value, it clear by writing 1

< error type record flag

< eoif bit value, it clear by writing 1

< transmit mailbox 0 transmission completed flag

< tm0tcf bit value, it clear by writing 1

< transmit mailbox 1 transmission completed flag

< tm1tcf bit value, it clear by writing 1

< transmit mailbox 2 transmission completed flag

< tm2tcf bit value, it clear by writing 1

< receive fifo 0 full flag

< rf0ff bit value, it clear by writing 1

< receive fifo 0 overflow flag

< rf0of bit value, it clear by writing 1

< receive fifo 1 full flag

< rf1ff bit value, it clear by writing 1

< receive fifo 1 overflow flag

< rf1of bit value, it clear by writing 1

< quit doze mode interrupt flag

< qdzif bit value, it clear by writing 1

< enter doze mode confirm flag

< edzif bit value, it clear by writing 1

< transmit mailbox empty flag

< tm0tcf bit value, it clear by writing 1

< tm1tcf bit value, it clear by writing 1

< tm2tcf bit value, it clear by writing 1

Definition at line 1089 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler().

◆ can_flag_get()

flag_status can_flag_get | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

get flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0MN_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1MN_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:the state of CAN_EDZC_FLAG need to check dzc and edzif bit note:the state of CAN_TMEF_FLAG need to check rqc0,rqc1 and rqc2 bit
Return values
status of can_flag, the returned value can be:SET or RESET.

< error active flag

< error passive flag

< bus-off flag

< error type record flag

< error occur interrupt flag

< transmit mailbox 0 transmission completed flag

< transmit mailbox 1 transmission completed flag

< transmit mailbox 2 transmission completed flag

< receive fifo 0 message num flag

< receive fifo 0 full flag

< receive fifo 0 overflow flag

< receive fifo 1 message num flag

< receive fifo 1 full flag

< receive fifo 1 overflow flag

< quit doze mode interrupt flag

< enter doze mode confirm flag

< transmit mailbox empty flag

Definition at line 965 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ can_interrupt_enable()

void can_interrupt_enable | ( | can_type * | can_x,
 |  | uint32_t | can_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the interrupt of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_int specifies the can interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • CAN_TCIEN_INT
  • CAN_RF0MIEN_INT
  • CAN_RF0FIEN_INT
  • CAN_RF0OIEN_INT
  • CAN_RF1MIEN_INT
  • CAN_RF1FIEN_INT
  • CAN_RF1OIEN_INT
  • CAN_EAIEN_INT
  • CAN_EPIEN_INT
  • CAN_BOIEN_INT
  • CAN_ETRIEN_INT
  • CAN_EOIEN_INT
  • CAN_QDZIEN_INT
  • CAN_EDZIEN_INT
new_state | new state of the can interrupts. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 925 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_message_receive()

void can_message_receive | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number,
 |  | can_rx_message_type * | rx_message_struct
 | ) |  |

receive message of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
rx_message_struct | pointer to a structure which store the receive message.
Return values
none.

Definition at line 620 of file at32f413_can.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ can_message_transmit()

uint8_t can_message_transmit | ( | can_type * | can_x,
 |  | can_tx_message_type * | tx_message_struct
 | ) |  |

fill the transmission message and transmit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
tx_message_struct | pointer to a structure which contains the message to be trans.
Return values
the number of the mailbox that is used for transmission: this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
  • CAN_TX_STATUS_NO_EMPTY <meanings there is no empty mailbox, message cannot be filled>

Definition at line 441 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_operating_mode_set()

error_status can_operating_mode_set | ( | can_type * | can_x,
 |  | can_operating_mode_type | can_operating_mode
 | ) |  |

set the operation mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_operating_mode can operating mode. this parameter can be one of the following values:
  • CAN_OPERATINGMODE_FREEZE
  • CAN_OPERATINGMODE_DOZE
  • CAN_OPERATINGMODE_COMMUNICATE
Return values
status of operation mode set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

Definition at line 724 of file at32f413_can.c.

◆ can_receive_error_counter_get()

uint8_t can_receive_error_counter_get ( can_type * can_x )

return the receive error counter (rec) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of receive error counter.

Definition at line 879 of file at32f413_can.c.

◆ can_receive_fifo_release()

void can_receive_fifo_release | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

release the specified fifo of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number fifo to be release. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
none.

< rf0r bit value, it clear by writing 1

< rf1r bit value, it clear by writing 1

Definition at line 667 of file at32f413_can.c.

Referenced by can_message_receive().

◆ can_receive_message_pending_get()

uint8_t can_receive_message_pending_get | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

return the number of pending messages of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
the number of message pending in the receive fifo.

Definition at line 693 of file at32f413_can.c.

◆ can_reset()

void can_reset ( can_type * can_x )

deinitialize the can peripheral registers to their default reset values.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
none.

Definition at line 49 of file at32f413_can.c.

◆ can_transmit_cancel()

void can_transmit_cancel | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

cancel a transmit request of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
mailbox mailbox number. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
none.

< tm0ct bit value, it clear by writing 1

< tm1ct bit value, it clear by writing 1

< tm2ct bit value, it clear by writing 1

Definition at line 590 of file at32f413_can.c.

◆ can_transmit_error_counter_get()

uint8_t can_transmit_error_counter_get ( can_type * can_x )

return the transmit error counter of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of transmit error counter.

Definition at line 893 of file at32f413_can.c.

◆ can_transmit_status_get()

can_transmit_status_type can_transmit_status_get | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

check the transmission state of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
transmit_mailbox the number of the mailbox that is used for transmission. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
can transmit status this parameter can be one of the following values:
  • CAN_TX_STATUS_SUCCESSFUL
  • CAN_TX_STATUS_FAILED
  • CAN_TX_STATUS_PENDING

Definition at line 515 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_ttc_mode_enable()

void can_ttc_mode_enable | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable time trigger operation communication mode of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
new_state | : new state of time trigger operation communication mode. this parameter can be: TRUE or FALSE.
Note
note1: when enabled, transmit mailbox time stamp(tmts[15:0]) value is sent in the last two data bytes of the 8-byte message: tmts[7:0] in data byte 6 and tmts[15:8] in data byte 7
note2: tmdtbl must be programmed as 8 in order time stamp (2 bytes) to be sent over the can bus.
Return values
none

Definition at line 417 of file at32f413_can.c.


AT32F413 Firmwary Library: CRC

Modules | Macros
CRC
AT32F413_periph_driver

CRC driver modules. More...

Modules

CRC_exported_types
CRC_exported_functions
CRC_private_functions

Macros

#define CRC ((crc_type *) CRC_BASE)

Detailed Description

CRC driver modules.

Macro Definition Documentation

◆ CRC

#define CRC ((crc_type *) CRC_BASE)

Definition at line 162 of file at32f413_crc.h.


AT32F413 Firmwary Library: CRC_exported_types

Data Structures | Enumerations
CRC_exported_types
AT32F413_periph_driver » CRC

Data Structures

struct crc_type
type define crc register all More...

Enumerations

enum | crc_reverse_input_type { CRC_REVERSE_INPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_INPUT_BY_BYTE = 0x01 , CRC_REVERSE_INPUT_BY_HALFWORD = 0x02 , CRC_REVERSE_INPUT_BY_WORD = 0x03 }
crc reverse input data More...
enum | crc_reverse_output_type { CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_OUTPUT_DATA = 0x01 }
crc reverse output data More...
enum | crc_poly_size_type { CRC_POLY_SIZE_32B = 0x00 , CRC_POLY_SIZE_16B = 0x01 , CRC_POLY_SIZE_8B = 0x02 , CRC_POLY_SIZE_7B = 0x03 }
crc polynomial size More...

Detailed Description

Enumeration Type Documentation

◆ crc_poly_size_type

enum crc_poly_size_type

crc polynomial size

Enumerator
CRC_POLY_SIZE_32B | polynomial size 32 bits
CRC_POLY_SIZE_16B | polynomial size 16 bits
CRC_POLY_SIZE_8B | polynomial size 8 bits
CRC_POLY_SIZE_7B | polynomial size 7 bits

Definition at line 72 of file at32f413_crc.h.

◆ crc_reverse_input_type

enum crc_reverse_input_type

crc reverse input data

Enumerator
CRC_REVERSE_INPUT_NO_AFFECTE | input data no reverse
CRC_REVERSE_INPUT_BY_BYTE | input data reverse by byte
CRC_REVERSE_INPUT_BY_HALFWORD | input data reverse by half word
CRC_REVERSE_INPUT_BY_WORD | input data reverse by word

Definition at line 52 of file at32f413_crc.h.

◆ crc_reverse_output_type

enum crc_reverse_output_type

crc reverse output data

Enumerator
CRC_REVERSE_OUTPUT_NO_AFFECTE | output data no reverse
CRC_REVERSE_OUTPUT_DATA | output data reverse by word

Definition at line 63 of file at32f413_crc.h.


AT32F413 Firmwary Library: crc_type Struct Reference

Data Fields
crc_type Struct Reference
AT32F413_periph_driver » CRC » CRC_exported_types

type define crc register all More...

#include <at32f413_crc.h>

Data Fields

union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 32
} dt_bit
};
crc dt register, offset:0x00 More...
union {
__IO uint32_t cdt
struct {
__IO uint32_t cdt: 8
__IO uint32_t reserved1: 24
} cdt_bit
};
crc cdt register, offset:0x04 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t rst: 1
__IO uint32_t reserved1: 2
__IO uint32_t poly_size: 2
__IO uint32_t revid: 2
__IO uint32_t revod: 1
__IO uint32_t reserved2: 24
} ctrl_bit
};
crc ctrl register, offset:0x08 More...
union {
__IO uint32_t idt
struct {
__IO uint32_t idt: 32
} idt_bit
};
crc idt register, offset:0x10 More...
union {
__IO uint32_t poly
struct {
__IO uint32_t poly: 32
} poly_bit
};
crc polynomial register, offset:0x14 More...

Detailed Description

type define crc register all

Definition at line 83 of file at32f413_crc.h.

Field Documentation

◆

union { ... } crc_type::@277

crc dt register, offset:0x00

◆

union { ... } crc_type::@279

crc cdt register, offset:0x04

◆

union { ... } crc_type::@281

crc ctrl register, offset:0x08

◆

union { ... } crc_type::@283

crc idt register, offset:0x10

◆

union { ... } crc_type::@285

crc polynomial register, offset:0x14

◆ cdt

__IO uint32_t crc_type::cdt

Definition at line 102 of file at32f413_crc.h.

◆

struct { ... } crc_type::cdt_bit

◆ ctrl

__IO uint32_t crc_type::ctrl

Definition at line 115 of file at32f413_crc.h.

◆

struct { ... } crc_type::ctrl_bit

◆ dt

__IO uint32_t crc_type::dt

Definition at line 90 of file at32f413_crc.h.

◆

struct { ... } crc_type::dt_bit

◆ idt

__IO uint32_t crc_type::idt

Definition at line 137 of file at32f413_crc.h.

◆

struct { ... } crc_type::idt_bit

◆ poly

__IO uint32_t crc_type::poly

Definition at line 149 of file at32f413_crc.h.

◆

struct { ... } crc_type::poly_bit

◆ poly_size

__IO uint32_t crc_type::poly_size

Definition at line 120 of file at32f413_crc.h.

◆ reserved1

__IO uint32_t crc_type::reserved1

crm reserved1 register, offset:0x0C

Definition at line 106 of file at32f413_crc.h.

◆ reserved2

__IO uint32_t crc_type::reserved2

Definition at line 123 of file at32f413_crc.h.

◆ revid

__IO uint32_t crc_type::revid

Definition at line 121 of file at32f413_crc.h.

◆ revod

__IO uint32_t crc_type::revod

Definition at line 122 of file at32f413_crc.h.

◆ rst

__IO uint32_t crc_type::rst

Definition at line 118 of file at32f413_crc.h.

The documentation for this struct was generated from the following file:
  • at32f413_crc.h


AT32F413 Firmwary Library: CRC_exported_functions

Functions
CRC_exported_functions
AT32F413_periph_driver » CRC

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_data_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...
void | crc_poly_value_set (uint32_t value)
config crc polynomial value More...
uint32_t | crc_poly_value_get (void)
return crc polynomial value More...
void | crc_poly_size_set (crc_poly_size_type size)
config crc polynomial data size More...
crc_poly_size_type | crc_poly_size_get (void)
return crc polynomial data size More...

Detailed Description

Function Documentation

◆ crc_block_calculate()

uint32_t crc_block_calculate | ( | uint32_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

compute the 32-bit crc of a given buffer of data word(32-bit).

Parameters
pbuffer | pointer to the buffer containing the data to be computed
length | length of the buffer to be computed
Return values
32-bit crc

Definition at line 70 of file at32f413_crc.c.

Referenced by main().

◆ crc_common_data_get()

uint8_t crc_common_data_get ( void )

return the 8-bit data stored in the common data register

Parameters
none
Return values
8-bit value of the common data register

Definition at line 107 of file at32f413_crc.c.

◆ crc_common_data_set()

void crc_common_data_set ( uint8_t cdt_value )

store a 8-bit data in the common data register.

Parameters
cdt_value 8-bit value to be stored in the common data register
Return values
none

Definition at line 97 of file at32f413_crc.c.

◆ crc_data_get()

uint32_t crc_data_get ( void )

return the current crc value.

Parameters
none
Return values
32-bit crc

Definition at line 87 of file at32f413_crc.c.

Referenced by crc_cal().

◆ crc_data_reset()

void crc_data_reset ( void )

reset the crc data register.

Parameters
none
Return values
none

Definition at line 47 of file at32f413_crc.c.

Referenced by crc_cal(), flash_crc_check(), and main().

◆ crc_init_data_set()

void crc_init_data_set ( uint32_t value )

set the 32-bit initial data of crc

Parameters
value initial data
Return values
none

Definition at line 117 of file at32f413_crc.c.

◆ crc_one_word_calculate()

uint32_t crc_one_word_calculate ( uint32_t data )

compute the 32-bit crc of a given data word(32-bit).

Parameters
data data word(32-bit) to compute its crc
Return values
32-bit crc

Definition at line 58 of file at32f413_crc.c.

Referenced by crc_cal(), and flash_crc_check().

◆ crc_poly_size_get()

crc_poly_size_type crc_poly_size_get ( void )

return crc polynomial data size

Parameters
none
Return values
polynomial data size.

Definition at line 191 of file at32f413_crc.c.

◆ crc_poly_size_set()

void crc_poly_size_set ( crc_poly_size_type size )

config crc polynomial data size

Parameters
size this parameter can be one of the following values:
  • CRC_POLY_SIZE_32B
  • CRC_POLY_SIZE_16B
  • CRC_POLY_SIZE_8B
  • CRC_POLY_SIZE_7B
Return values
none.

Definition at line 181 of file at32f413_crc.c.

◆ crc_poly_value_get()

uint32_t crc_poly_value_get ( void )

return crc polynomial value

Parameters
none
Return values
32-bit value of the polynomial value.

Definition at line 166 of file at32f413_crc.c.

◆ crc_poly_value_set()

void crc_poly_value_set ( uint32_t value )

config crc polynomial value

Parameters
value 32-bit new data of crc poly value
Return values
none.

Definition at line 156 of file at32f413_crc.c.

◆ crc_reverse_input_data_set()

void crc_reverse_input_data_set ( crc_reverse_input_type value )

control the reversal of the bit order in the input data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_INPUT_NO_AFFECTE
  • CRC_REVERSE_INPUT_BY_BYTE
  • CRC_REVERSE_INPUT_BY_HALFWORD
  • CRC_REVERSE_INPUT_BY_WORD
Return values
none.

Definition at line 132 of file at32f413_crc.c.

◆ crc_reverse_output_data_set()

void crc_reverse_output_data_set ( crc_reverse_output_type value )

control the reversal of the bit order in the output data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_OUTPUT_NO_AFFECTE
  • CRC_REVERSE_OUTPUT_DATA
Return values
none.

Definition at line 145 of file at32f413_crc.c.


AT32F413 Firmwary Library: CRC_private_functions

Functions
CRC_private_functions
AT32F413_periph_driver » CRC

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_data_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...
void | crc_poly_value_set (uint32_t value)
config crc polynomial value More...
uint32_t | crc_poly_value_get (void)
return crc polynomial value More...
void | crc_poly_size_set (crc_poly_size_type size)
config crc polynomial data size More...
crc_poly_size_type | crc_poly_size_get (void)
return crc polynomial data size More...

Detailed Description

Function Documentation

◆ crc_block_calculate()

uint32_t crc_block_calculate | ( | uint32_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

compute the 32-bit crc of a given buffer of data word(32-bit).

Parameters
pbuffer | pointer to the buffer containing the data to be computed
length | length of the buffer to be computed
Return values
32-bit crc

Definition at line 70 of file at32f413_crc.c.

Referenced by main().

◆ crc_common_data_get()

uint8_t crc_common_data_get ( void )

return the 8-bit data stored in the common data register

Parameters
none
Return values
8-bit value of the common data register

Definition at line 107 of file at32f413_crc.c.

◆ crc_common_data_set()

void crc_common_data_set ( uint8_t cdt_value )

store a 8-bit data in the common data register.

Parameters
cdt_value 8-bit value to be stored in the common data register
Return values
none

Definition at line 97 of file at32f413_crc.c.

◆ crc_data_get()

uint32_t crc_data_get ( void )

return the current crc value.

Parameters
none
Return values
32-bit crc

Definition at line 87 of file at32f413_crc.c.

Referenced by crc_cal().

◆ crc_data_reset()

void crc_data_reset ( void )

reset the crc data register.

Parameters
none
Return values
none

Definition at line 47 of file at32f413_crc.c.

Referenced by crc_cal(), flash_crc_check(), and main().

◆ crc_init_data_set()

void crc_init_data_set ( uint32_t value )

set the 32-bit initial data of crc

Parameters
value initial data
Return values
none

Definition at line 117 of file at32f413_crc.c.

◆ crc_one_word_calculate()

uint32_t crc_one_word_calculate ( uint32_t data )

compute the 32-bit crc of a given data word(32-bit).

Parameters
data data word(32-bit) to compute its crc
Return values
32-bit crc

Definition at line 58 of file at32f413_crc.c.

Referenced by crc_cal(), and flash_crc_check().

◆ crc_poly_size_get()

crc_poly_size_type crc_poly_size_get ( void )

return crc polynomial data size

Parameters
none
Return values
polynomial data size.

Definition at line 191 of file at32f413_crc.c.

◆ crc_poly_size_set()

void crc_poly_size_set ( crc_poly_size_type size )

config crc polynomial data size

Parameters
size this parameter can be one of the following values:
  • CRC_POLY_SIZE_32B
  • CRC_POLY_SIZE_16B
  • CRC_POLY_SIZE_8B
  • CRC_POLY_SIZE_7B
Return values
none.

Definition at line 181 of file at32f413_crc.c.

◆ crc_poly_value_get()

uint32_t crc_poly_value_get ( void )

return crc polynomial value

Parameters
none
Return values
32-bit value of the polynomial value.

Definition at line 166 of file at32f413_crc.c.

◆ crc_poly_value_set()

void crc_poly_value_set ( uint32_t value )

config crc polynomial value

Parameters
value 32-bit new data of crc poly value
Return values
none.

Definition at line 156 of file at32f413_crc.c.

◆ crc_reverse_input_data_set()

void crc_reverse_input_data_set ( crc_reverse_input_type value )

control the reversal of the bit order in the input data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_INPUT_NO_AFFECTE
  • CRC_REVERSE_INPUT_BY_BYTE
  • CRC_REVERSE_INPUT_BY_HALFWORD
  • CRC_REVERSE_INPUT_BY_WORD
Return values
none.

Definition at line 132 of file at32f413_crc.c.

◆ crc_reverse_output_data_set()

void crc_reverse_output_data_set ( crc_reverse_output_type value )

control the reversal of the bit order in the output data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_OUTPUT_NO_AFFECTE
  • CRC_REVERSE_OUTPUT_DATA
Return values
none.

Definition at line 145 of file at32f413_crc.c.


AT32F413 Firmwary Library: CRM

Modules | Macros
CRM
AT32F413_periph_driver

CRM driver modules. More...

Modules

CRM_flags_definition
crm flag
CRM_interrupts_definition
crm interrupt
CRM_exported_types
CRM_exported_functions
CRM_private_functions

Macros

#define | CRM_REG(value) PERIPH_REG(CRM_BASE, value)
#define | CRM_REG_BIT(value) PERIPH_REG_BIT(value)
#define | CRM ((crm_type *) CRM_BASE)

Detailed Description

CRM driver modules.

Macro Definition Documentation

◆ CRM

#define CRM ((crm_type *) CRM_BASE)

Definition at line 842 of file at32f413_crm.h.

◆ CRM_REG

#define CRM_REG ( value ) PERIPH_REG(CRM_BASE, value)

Definition at line 45 of file at32f413_crm.h.

◆ CRM_REG_BIT

#define CRM_REG_BIT ( value ) PERIPH_REG_BIT(value)

Definition at line 46 of file at32f413_crm.h.


AT32F413 Firmwary Library: CRM_flags_definition

Macros
CRM_flags_definition
AT32F413_periph_driver » CRM

crm flag More...

Macros

#define | CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
#define | CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
#define | CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
#define | CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)
#define | CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)
#define | CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)
#define | CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)
#define | CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)
#define | CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)
#define | CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)
#define | CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)
#define | CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)
#define | CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)
#define | CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)
#define | CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)
#define | CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)
#define | CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)
#define | CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)

Detailed Description

crm flag

Macro Definition Documentation

◆ CRM_ALL_RESET_FLAG

#define CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)

all reset flag

Definition at line 58 of file at32f413_crm.h.

◆ CRM_CLOCK_FAILURE_INT_FLAG

#define CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)

clock failure interrupt ready flag

Definition at line 70 of file at32f413_crm.h.

◆ CRM_HEXT_READY_INT_FLAG

#define CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)

high speed external crystal stable interrupt ready flag

Definition at line 68 of file at32f413_crm.h.

◆ CRM_HEXT_STABLE_FLAG

#define CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)

high speed external crystal stable flag

Definition at line 54 of file at32f413_crm.h.

◆ CRM_HICK_READY_INT_FLAG

#define CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)

high speed internal clock stable interrupt ready flag

Definition at line 67 of file at32f413_crm.h.

◆ CRM_HICK_STABLE_FLAG

#define CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)

high speed internal clock stable flag

Definition at line 53 of file at32f413_crm.h.

◆ CRM_LEXT_READY_INT_FLAG

#define CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)

low speed external crystal stable interrupt ready flag

Definition at line 66 of file at32f413_crm.h.

◆ CRM_LEXT_STABLE_FLAG

#define CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)

low speed external crystal stable flag

Definition at line 56 of file at32f413_crm.h.

◆ CRM_LICK_READY_INT_FLAG

#define CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)

low speed internal clock stable interrupt ready flag

Definition at line 65 of file at32f413_crm.h.

◆ CRM_LICK_STABLE_FLAG

#define CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)

low speed internal clock stable flag

Definition at line 57 of file at32f413_crm.h.

◆ CRM_LOWPOWER_RESET_FLAG

#define CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)

low-power reset flag

Definition at line 64 of file at32f413_crm.h.

◆ CRM_NRST_RESET_FLAG

#define CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)

nrst pin reset flag

Definition at line 59 of file at32f413_crm.h.

◆ CRM_PLL_READY_INT_FLAG

#define CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)

phase locking loop stable interrupt ready flag

Definition at line 69 of file at32f413_crm.h.

◆ CRM_PLL_STABLE_FLAG

#define CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)

phase locking loop stable flag

Definition at line 55 of file at32f413_crm.h.

◆ CRM_POR_RESET_FLAG

#define CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)

power on reset flag

Definition at line 60 of file at32f413_crm.h.

◆ CRM_SW_RESET_FLAG

#define CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)

software reset flag

Definition at line 61 of file at32f413_crm.h.

◆ CRM_WDT_RESET_FLAG

#define CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)

watchdog timer reset flag

Definition at line 62 of file at32f413_crm.h.

◆ CRM_WWDT_RESET_FLAG

#define CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)

window watchdog timer reset flag

Definition at line 63 of file at32f413_crm.h.


AT32F413 Firmwary Library: CRM_interrupts_definition

Macros
CRM_interrupts_definition
AT32F413_periph_driver » CRM

crm interrupt More...

Macros

#define | CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
#define | CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
#define | CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
#define | CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
#define | CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
#define | CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)

Detailed Description

crm interrupt

Macro Definition Documentation

◆ CRM_CLOCK_FAILURE_INT

#define CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)

clock failure interrupt

Definition at line 86 of file at32f413_crm.h.

◆ CRM_HEXT_STABLE_INT

#define CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)

high speed external crystal stable interrupt

Definition at line 84 of file at32f413_crm.h.

◆ CRM_HICK_STABLE_INT

#define CRM_HICK_STABLE_INT ((uint32_t)0x00000400)

high speed internal clock stable interrupt

Definition at line 83 of file at32f413_crm.h.

◆ CRM_LEXT_STABLE_INT

#define CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)

low speed external crystal stable interrupt

Definition at line 82 of file at32f413_crm.h.

◆ CRM_LICK_STABLE_INT

#define CRM_LICK_STABLE_INT ((uint32_t)0x00000100)

low speed internal clock stable interrupt

Definition at line 81 of file at32f413_crm.h.

◆ CRM_PLL_STABLE_INT

#define CRM_PLL_STABLE_INT ((uint32_t)0x00001000)

phase locking loop stable interrupt

Definition at line 85 of file at32f413_crm.h.


AT32F413 Firmwary Library: CRM_exported_types

Data Structures | Enumerations
CRM_exported_types
AT32F413_periph_driver » CRM

Data Structures

struct | crm_clocks_freq_type
crm clocks freqency structure More...
struct | crm_type
type define crm register all More...

Enumerations

enum crm_periph_clock_type {
CRM_DMA1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 0 & 0x1F)) , CRM_DMA2_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 1 & 0x1F)) , CRM_CRC_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 6 & 0x1F)) , CRM_SDIO1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 10 & 0x1F)) ,
CRM_IOMUX_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 0 & 0x1F)) , CRM_GPIOA_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 3 & 0x1F)) , CRM_GPIOC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 4 & 0x1F)) ,
CRM_GPIOD_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 9 & 0x1F)) , CRM_ADC2_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 10 & 0x1F)) ,
CRM_TMR1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 13 & 0x1F)) , CRM_USART1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 14 & 0x1F)) ,
CRM_TMR9_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 21 & 0x1F)) , CRM_ACC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 22 & 0x1F)) ,
CRM_TMR2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 2 & 0x1F)) , CRM_TMR5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 3 & 0x1F)) ,
CRM_WWDT_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 17 & 0x1F)) , CRM_USART3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 18 & 0x1F)) ,
CRM_UART4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 21 & 0x1F)) , CRM_I2C2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 22 & 0x1F)) ,
CRM_USB_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 27 & 0x1F)) , CRM_PWC_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 28 & 0x1F)) ,
CRM_CAN2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 31 & 0x1F))
}
crm periph clock More...
enum crm_periph_reset_type {
CRM_IOMUX_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 0 & 0x1F)) , CRM_EXINT_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 1 & 0x1F)) , CRM_GPIOA_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 3 & 0x1F)) ,
CRM_GPIOC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 4 & 0x1F)) , CRM_GPIOD_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 9 & 0x1F)) ,
CRM_ADC2_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 10 & 0x1F)) , CRM_TMR1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 13 & 0x1F)) ,
CRM_USART1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 14 & 0x1F)) , CRM_TMR9_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 21 & 0x1F)) ,
CRM_ACC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 22 & 0x1F)) , CRM_TMR2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 2 & 0x1F)) ,
CRM_TMR5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 3 & 0x1F)) , CRM_WWDT_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 17 & 0x1F)) ,
CRM_USART3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 18 & 0x1F)) , CRM_UART4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 21 & 0x1F)) ,
CRM_I2C2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 22 & 0x1F)) , CRM_USB_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 27 & 0x1F)) ,
CRM_PWC_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 28 & 0x1F)) , CRM_CAN2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 31 & 0x1F))
}
crm periph reset More...
enum | crm_periph_clock_sleepmd_type { CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 2 & 0x1F)) , CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 4 & 0x1F)) }
crm periph clock in sleep mode More...
enum crm_pll_mult_type {
CRM_PLL_MULT_2 = 0 , CRM_PLL_MULT_3 = 1 , CRM_PLL_MULT_4 = 2 , CRM_PLL_MULT_5 = 3 ,
CRM_PLL_MULT_6 = 4 , CRM_PLL_MULT_7 = 5 , CRM_PLL_MULT_8 = 6 , CRM_PLL_MULT_9 = 7 ,
CRM_PLL_MULT_10 = 8 , CRM_PLL_MULT_11 = 9 , CRM_PLL_MULT_12 = 10 , CRM_PLL_MULT_13 = 11 ,
CRM_PLL_MULT_14 = 12 , CRM_PLL_MULT_15 = 13 , CRM_PLL_MULT_16 = 15 , CRM_PLL_MULT_17 = 16 ,
CRM_PLL_MULT_18 = 17 , CRM_PLL_MULT_19 = 18 , CRM_PLL_MULT_20 = 19 , CRM_PLL_MULT_21 = 20 ,
CRM_PLL_MULT_22 = 21 , CRM_PLL_MULT_23 = 22 , CRM_PLL_MULT_24 = 23 , CRM_PLL_MULT_25 = 24 ,
CRM_PLL_MULT_26 = 25 , CRM_PLL_MULT_27 = 26 , CRM_PLL_MULT_28 = 27 , CRM_PLL_MULT_29 = 28 ,
CRM_PLL_MULT_30 = 29 , CRM_PLL_MULT_31 = 30 , CRM_PLL_MULT_32 = 31 , CRM_PLL_MULT_33 = 32 ,
CRM_PLL_MULT_34 = 33 , CRM_PLL_MULT_35 = 34 , CRM_PLL_MULT_36 = 35 , CRM_PLL_MULT_37 = 36 ,
CRM_PLL_MULT_38 = 37 , CRM_PLL_MULT_39 = 38 , CRM_PLL_MULT_40 = 39 , CRM_PLL_MULT_41 = 40 ,
CRM_PLL_MULT_42 = 41 , CRM_PLL_MULT_43 = 42 , CRM_PLL_MULT_44 = 43 , CRM_PLL_MULT_45 = 44 ,
CRM_PLL_MULT_46 = 45 , CRM_PLL_MULT_47 = 46 , CRM_PLL_MULT_48 = 47 , CRM_PLL_MULT_49 = 48 ,
CRM_PLL_MULT_50 = 49 , CRM_PLL_MULT_51 = 50 , CRM_PLL_MULT_52 = 51 , CRM_PLL_MULT_53 = 52 ,
CRM_PLL_MULT_54 = 53 , CRM_PLL_MULT_55 = 54 , CRM_PLL_MULT_56 = 55 , CRM_PLL_MULT_57 = 56 ,
CRM_PLL_MULT_58 = 57 , CRM_PLL_MULT_59 = 58 , CRM_PLL_MULT_60 = 59 , CRM_PLL_MULT_61 = 60 ,
CRM_PLL_MULT_62 = 61 , CRM_PLL_MULT_63 = 62 , CRM_PLL_MULT_64 = 63
}
crm pll mult_x More...
enum | crm_pll_clock_source_type { CRM_PLL_SOURCE_HICK = 0x00 , CRM_PLL_SOURCE_HEXT = 0x01 , CRM_PLL_SOURCE_HEXT_DIV = 0x02 }
crm pll clock source More...
enum | crm_pll_output_range_type { CRM_PLL_OUTPUT_RANGE_LE72MHZ = 0x00 , CRM_PLL_OUTPUT_RANGE_GT72MHZ = 0x01 }
crm pll clock output range More...
enum crm_clock_source_type {
CRM_CLOCK_SOURCE_HICK = 0x00 , CRM_CLOCK_SOURCE_HEXT = 0x01 , CRM_CLOCK_SOURCE_PLL = 0x02 , CRM_CLOCK_SOURCE_LEXT = 0x03 ,
CRM_CLOCK_SOURCE_LICK = 0x04
}
crm clock source More...
enum crm_ahb_div_type {
CRM_AHB_DIV_1 = 0x00 , CRM_AHB_DIV_2 = 0x08 , CRM_AHB_DIV_4 = 0x09 , CRM_AHB_DIV_8 = 0x0A ,
CRM_AHB_DIV_16 = 0x0B , CRM_AHB_DIV_64 = 0x0C , CRM_AHB_DIV_128 = 0x0D , CRM_AHB_DIV_256 = 0x0E ,
CRM_AHB_DIV_512 = 0x0F
}
crm ahb division More...
enum crm_apb1_div_type {
CRM_APB1_DIV_1 = 0x00 , CRM_APB1_DIV_2 = 0x04 , CRM_APB1_DIV_4 = 0x05 , CRM_APB1_DIV_8 = 0x06 ,
CRM_APB1_DIV_16 = 0x07
}
crm apb1 division More...
enum crm_apb2_div_type {
CRM_APB2_DIV_1 = 0x00 , CRM_APB2_DIV_2 = 0x04 , CRM_APB2_DIV_4 = 0x05 , CRM_APB2_DIV_8 = 0x06 ,
CRM_APB2_DIV_16 = 0x07
}
crm apb2 division More...
enum crm_adc_div_type {
CRM_ADC_DIV_2 = 0x00 , CRM_ADC_DIV_4 = 0x01 , CRM_ADC_DIV_6 = 0x02 , CRM_ADC_DIV_8 = 0x03 ,
CRM_ADC_DIV_12 = 0x05 , CRM_ADC_DIV_16 = 0x07
}
crm adc division More...
enum crm_usb_div_type {
CRM_USB_DIV_1_5 = 0x00 , CRM_USB_DIV_1 = 0x01 , CRM_USB_DIV_2_5 = 0x02 , CRM_USB_DIV_2 = 0x03 ,
CRM_USB_DIV_3_5 = 0x04 , CRM_USB_DIV_3 = 0x05 , CRM_USB_DIV_4 = 0x06
}
crm usb division More...
enum | crm_rtc_clock_type { CRM_RTC_CLOCK_NOCLK = 0x00 , CRM_RTC_CLOCK_LEXT = 0x01 , CRM_RTC_CLOCK_LICK = 0x02 , CRM_RTC_CLOCK_HEXT_DIV = 0x03 }
crm rtc clock More...
enum | crm_hick_div_6_type { CRM_HICK48_DIV6 = 0x00 , CRM_HICK48_NODIV = 0x01 }
crm hick 48mhz division More...
enum | crm_sclk_type { CRM_SCLK_HICK = 0x00 , CRM_SCLK_HEXT = 0x01 , CRM_SCLK_PLL = 0x02 }
crm sclk select More...
enum crm_clkout_select_type {
CRM_CLKOUT_NOCLK = 0x00 , CRM_CLKOUT_LICK = 0x02 , CRM_CLKOUT_LEXT = 0x03 , CRM_CLKOUT_SCLK = 0x04 ,
CRM_CLKOUT_HICK = 0x05 , CRM_CLKOUT_HEXT = 0x06 , CRM_CLKOUT_PLL_DIV_2 = 0x07 , CRM_CLKOUT_PLL_DIV_4 = 0x0C ,
CRM_CLKOUT_USB = 0x0D , CRM_CLKOUT_ADC = 0x0E
}
crm clkout select More...
enum crm_clkout_div_type {
CRM_CLKOUT_DIV_1 = 0x00 , CRM_CLKOUT_DIV_2 = 0x08 , CRM_CLKOUT_DIV_4 = 0x09 , CRM_CLKOUT_DIV_8 = 0x0A ,
CRM_CLKOUT_DIV_16 = 0x0B , CRM_CLKOUT_DIV_64 = 0x0C , CRM_CLKOUT_DIV_128 = 0x0D , CRM_CLKOUT_DIV_256 = 0x0E ,
CRM_CLKOUT_DIV_512 = 0x0F
}
crm clkout division More...
enum | crm_auto_step_mode_type { CRM_AUTO_STEP_MODE_DISABLE = 0x00 , CRM_AUTO_STEP_MODE_ENABLE = 0x03 }
crm auto step mode More...
enum | crm_usb_int_map_type { CRM_USB_INT19_INT20 = 0x00 , CRM_USB_INT73_INT74 = 0x01 }
crm usbdev interrupt remap More...
enum | crm_usb_clock_source_type { CRM_USB_CLOCK_SOURCE_PLL = 0x00 , CRM_USB_CLOCK_SOURCE_HICK = 0x01 }
crm usb 48 mhz clock source select More...
enum | crm_hick_sclk_frequency_type { CRM_HICK_SCLK_8MHZ = 0x00 , CRM_HICK_SCLK_48MHZ = 0x01 }
crm hick as system clock frequency select More...

Detailed Description

Enumeration Type Documentation

◆ crm_adc_div_type

enum crm_adc_div_type

crm adc division

Enumerator
CRM_ADC_DIV_2 | apb2clk div2 to adcclk
CRM_ADC_DIV_4 | apb2clk div4 to adcclk
CRM_ADC_DIV_6 | apb2clk div6 to adcclk
CRM_ADC_DIV_8 | apb2clk div8 to adcclk
CRM_ADC_DIV_12 | apb2clk div12 to adcclk
CRM_ADC_DIV_16 | apb2clk div16 to adcclk

Definition at line 342 of file at32f413_crm.h.

◆ crm_ahb_div_type

enum crm_ahb_div_type

crm ahb division

Enumerator
CRM_AHB_DIV_1 | sclk div1 to ahbclk
CRM_AHB_DIV_2 | sclk div2 to ahbclk
CRM_AHB_DIV_4 | sclk div4 to ahbclk
CRM_AHB_DIV_8 | sclk div8 to ahbclk
CRM_AHB_DIV_16 | sclk div16 to ahbclk
CRM_AHB_DIV_64 | sclk div64 to ahbclk
CRM_AHB_DIV_128 | sclk div128 to ahbclk
CRM_AHB_DIV_256 | sclk div256 to ahbclk
CRM_AHB_DIV_512 | sclk div512 to ahbclk

Definition at line 302 of file at32f413_crm.h.

◆ crm_apb1_div_type

enum crm_apb1_div_type

crm apb1 division

Enumerator
CRM_APB1_DIV_1 | ahbclk div1 to apb1clk
CRM_APB1_DIV_2 | ahbclk div2 to apb1clk
CRM_APB1_DIV_4 | ahbclk div4 to apb1clk
CRM_APB1_DIV_8 | ahbclk div8 to apb1clk
CRM_APB1_DIV_16 | ahbclk div16 to apb1clk

Definition at line 318 of file at32f413_crm.h.

◆ crm_apb2_div_type

enum crm_apb2_div_type

crm apb2 division

Enumerator
CRM_APB2_DIV_1 | ahbclk div1 to apb2clk
CRM_APB2_DIV_2 | ahbclk div2 to apb2clk
CRM_APB2_DIV_4 | ahbclk div4 to apb2clk
CRM_APB2_DIV_8 | ahbclk div8 to apb2clk
CRM_APB2_DIV_16 | ahbclk div16 to apb2clk

Definition at line 330 of file at32f413_crm.h.

◆ crm_auto_step_mode_type

enum crm_auto_step_mode_type

crm auto step mode

Enumerator
CRM_AUTO_STEP_MODE_DISABLE | disable auto step mode
CRM_AUTO_STEP_MODE_ENABLE | enable auto step mode

Definition at line 432 of file at32f413_crm.h.

◆ crm_clkout_div_type

enum crm_clkout_div_type

crm clkout division

Enumerator
CRM_CLKOUT_DIV_1 | clkout div1
CRM_CLKOUT_DIV_2 | clkout div2
CRM_CLKOUT_DIV_4 | clkout div4
CRM_CLKOUT_DIV_8 | clkout div8
CRM_CLKOUT_DIV_16 | clkout div16
CRM_CLKOUT_DIV_64 | clkout div64
CRM_CLKOUT_DIV_128 | clkout div128
CRM_CLKOUT_DIV_256 | clkout div256
CRM_CLKOUT_DIV_512 | clkout div512

Definition at line 416 of file at32f413_crm.h.

◆ crm_clkout_select_type

enum crm_clkout_select_type

crm clkout select

Enumerator
CRM_CLKOUT_NOCLK | output no clock to clkout pin
CRM_CLKOUT_LICK | output low speed internal clock to clkout pin
CRM_CLKOUT_LEXT | output low speed external crystal to clkout pin
CRM_CLKOUT_SCLK | output system clock to clkout pin
CRM_CLKOUT_HICK | output high speed internal clock to clkout pin
CRM_CLKOUT_HEXT | output high speed external crystal to clkout pin
CRM_CLKOUT_PLL_DIV_2 | output phase locking loop clock div2 to clkout pin
CRM_CLKOUT_PLL_DIV_4 | output phase locking loop clock div4 to clkout pin
CRM_CLKOUT_USB | output usbclk to clkout pin
CRM_CLKOUT_ADC | output adcclk to clkout pin

Definition at line 399 of file at32f413_crm.h.

◆ crm_clock_source_type

enum crm_clock_source_type

crm clock source

Enumerator
CRM_CLOCK_SOURCE_HICK | high speed internal clock
CRM_CLOCK_SOURCE_HEXT | high speed external crystal
CRM_CLOCK_SOURCE_PLL | phase locking loop
CRM_CLOCK_SOURCE_LEXT | low speed external crystal
CRM_CLOCK_SOURCE_LICK | low speed internal clock

Definition at line 290 of file at32f413_crm.h.

◆ crm_hick_div_6_type

enum crm_hick_div_6_type

crm hick 48mhz division

Enumerator
CRM_HICK48_DIV6 | high speed internal clock (48 mhz) div6
CRM_HICK48_NODIV | high speed internal clock (48 mhz) no div

Definition at line 380 of file at32f413_crm.h.

◆ crm_hick_sclk_frequency_type

enum crm_hick_sclk_frequency_type

crm hick as system clock frequency select

Enumerator
CRM_HICK_SCLK_8MHZ | fixed 8 mhz when hick is selected as sclk
CRM_HICK_SCLK_48MHZ | 8 mhz or 48 mhz depend on hickdiv when hick is selected as sclk

Definition at line 459 of file at32f413_crm.h.

◆ crm_periph_clock_sleepmd_type

enum crm_periph_clock_sleepmd_type

crm periph clock in sleep mode

Enumerator
CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE | sram sleep mode periph clock
CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE | flash sleep mode periph clock

Definition at line 191 of file at32f413_crm.h.

◆ crm_periph_clock_type

enum crm_periph_clock_type

crm periph clock

Enumerator
CRM_DMA1_PERIPH_CLOCK | dma1 periph clock
CRM_DMA2_PERIPH_CLOCK | dma2 periph clock
CRM_CRC_PERIPH_CLOCK | crc periph clock
CRM_SDIO1_PERIPH_CLOCK | sdio1 periph clock
CRM_IOMUX_PERIPH_CLOCK | iomux periph clock
CRM_GPIOA_PERIPH_CLOCK | gpioa periph clock
CRM_GPIOB_PERIPH_CLOCK | gpiob periph clock
CRM_GPIOC_PERIPH_CLOCK | gpioc periph clock
CRM_GPIOD_PERIPH_CLOCK | gpiod periph clock
CRM_GPIOF_PERIPH_CLOCK | gpiof periph clock
CRM_ADC1_PERIPH_CLOCK | adc1 periph clock
CRM_ADC2_PERIPH_CLOCK | adc2 periph clock
CRM_TMR1_PERIPH_CLOCK | tmr1 periph clock
CRM_SPI1_PERIPH_CLOCK | spi1 periph clock
CRM_TMR8_PERIPH_CLOCK | tmr8 periph clock
CRM_USART1_PERIPH_CLOCK | usart1 periph clock
CRM_TMR9_PERIPH_CLOCK | tmr9 periph clock
CRM_TMR10_PERIPH_CLOCK | tmr10 periph clock
CRM_TMR11_PERIPH_CLOCK | tmr11 periph clock
CRM_ACC_PERIPH_CLOCK | acc periph clock
CRM_TMR2_PERIPH_CLOCK | tmr2 periph clock
CRM_TMR3_PERIPH_CLOCK | tmr3 periph clock
CRM_TMR4_PERIPH_CLOCK | tmr4 periph clock
CRM_TMR5_PERIPH_CLOCK | tmr5 periph clock
CRM_WWDT_PERIPH_CLOCK | wwdt periph clock
CRM_SPI2_PERIPH_CLOCK | spi2 periph clock
CRM_USART2_PERIPH_CLOCK | usart2 periph clock
CRM_USART3_PERIPH_CLOCK | usart3 periph clock
CRM_UART4_PERIPH_CLOCK | uart4 periph clock
CRM_UART5_PERIPH_CLOCK | uart5 periph clock
CRM_I2C1_PERIPH_CLOCK | i2c1 periph clock
CRM_I2C2_PERIPH_CLOCK | i2c2 periph clock
CRM_USB_PERIPH_CLOCK | usb periph clock
CRM_CAN1_PERIPH_CLOCK | can1 periph clock
CRM_BPR_PERIPH_CLOCK | bpr periph clock
CRM_PWC_PERIPH_CLOCK | pwc periph clock
CRM_CAN2_PERIPH_CLOCK | can2 periph clock

Definition at line 99 of file at32f413_crm.h.

◆ crm_periph_reset_type

enum crm_periph_reset_type

crm periph reset

Enumerator
CRM_IOMUX_PERIPH_RESET | iomux periph reset
CRM_EXINT_PERIPH_RESET | exint periph reset
CRM_GPIOA_PERIPH_RESET | gpioa periph reset
CRM_GPIOB_PERIPH_RESET | gpiob periph reset
CRM_GPIOC_PERIPH_RESET | gpioc periph reset
CRM_GPIOD_PERIPH_RESET | gpiod periph reset
CRM_GPIOF_PERIPH_RESET | gpiof periph reset
CRM_ADC1_PERIPH_RESET | adc1 periph reset
CRM_ADC2_PERIPH_RESET | adc2 periph reset
CRM_TMR1_PERIPH_RESET | tmr1 periph reset
CRM_SPI1_PERIPH_RESET | spi2 periph reset
CRM_TMR8_PERIPH_RESET | tmr8 periph reset
CRM_USART1_PERIPH_RESET | usart1 periph reset
CRM_TMR9_PERIPH_RESET | tmr9 periph reset
CRM_TMR10_PERIPH_RESET | tmr10 periph reset
CRM_TMR11_PERIPH_RESET | tmr11 periph reset
CRM_ACC_PERIPH_RESET | acc periph reset
CRM_TMR2_PERIPH_RESET | tmr2 periph reset
CRM_TMR3_PERIPH_RESET | tmr3 periph reset
CRM_TMR4_PERIPH_RESET | tmr4 periph reset
CRM_TMR5_PERIPH_RESET | tmr5 periph reset
CRM_WWDT_PERIPH_RESET | wwdt periph reset
CRM_SPI2_PERIPH_RESET | spi2 periph reset
CRM_USART2_PERIPH_RESET | usart2 periph reset
CRM_USART3_PERIPH_RESET | usart3 periph reset
CRM_UART4_PERIPH_RESET | uart4 periph reset
CRM_UART5_PERIPH_RESET | uart5 periph reset
CRM_I2C1_PERIPH_RESET | i2c1 periph reset
CRM_I2C2_PERIPH_RESET | i2c2 periph reset
CRM_USB_PERIPH_RESET | usb periph reset
CRM_CAN1_PERIPH_RESET | can1 periph reset
CRM_BPR_PERIPH_RESET | bpr periph reset
CRM_PWC_PERIPH_RESET | pwc periph reset
CRM_CAN2_PERIPH_RESET | can2 periph reset

Definition at line 147 of file at32f413_crm.h.

◆ crm_pll_clock_source_type

enum crm_pll_clock_source_type

crm pll clock source

Enumerator
CRM_PLL_SOURCE_HICK | high speed internal clock as pll reference clock source
CRM_PLL_SOURCE_HEXT | high speed external crystal as pll reference clock source
CRM_PLL_SOURCE_HEXT_DIV | high speed external crystal div as pll reference clock source

Definition at line 271 of file at32f413_crm.h.

◆ crm_pll_mult_type

enum crm_pll_mult_type

crm pll mult_x

Enumerator
CRM_PLL_MULT_2 | pll multiplication factor 2
CRM_PLL_MULT_3 | pll multiplication factor 3
CRM_PLL_MULT_4 | pll multiplication factor 4
CRM_PLL_MULT_5 | pll multiplication factor 5
CRM_PLL_MULT_6 | pll multiplication factor 6
CRM_PLL_MULT_7 | pll multiplication factor 7
CRM_PLL_MULT_8 | pll multiplication factor 8
CRM_PLL_MULT_9 | pll multiplication factor 9
CRM_PLL_MULT_10 | pll multiplication factor 10
CRM_PLL_MULT_11 | pll multiplication factor 11
CRM_PLL_MULT_12 | pll multiplication factor 12
CRM_PLL_MULT_13 | pll multiplication factor 13
CRM_PLL_MULT_14 | pll multiplication factor 14
CRM_PLL_MULT_15 | pll multiplication factor 15
CRM_PLL_MULT_16 | pll multiplication factor 16
CRM_PLL_MULT_17 | pll multiplication factor 17
CRM_PLL_MULT_18 | pll multiplication factor 18
CRM_PLL_MULT_19 | pll multiplication factor 19
CRM_PLL_MULT_20 | pll multiplication factor 20
CRM_PLL_MULT_21 | pll multiplication factor 21
CRM_PLL_MULT_22 | pll multiplication factor 22
CRM_PLL_MULT_23 | pll multiplication factor 23
CRM_PLL_MULT_24 | pll multiplication factor 24
CRM_PLL_MULT_25 | pll multiplication factor 25
CRM_PLL_MULT_26 | pll multiplication factor 26
CRM_PLL_MULT_27 | pll multiplication factor 27
CRM_PLL_MULT_28 | pll multiplication factor 28
CRM_PLL_MULT_29 | pll multiplication factor 29
CRM_PLL_MULT_30 | pll multiplication factor 30
CRM_PLL_MULT_31 | pll multiplication factor 31
CRM_PLL_MULT_32 | pll multiplication factor 32
CRM_PLL_MULT_33 | pll multiplication factor 33
CRM_PLL_MULT_34 | pll multiplication factor 34
CRM_PLL_MULT_35 | pll multiplication factor 35
CRM_PLL_MULT_36 | pll multiplication factor 36
CRM_PLL_MULT_37 | pll multiplication factor 37
CRM_PLL_MULT_38 | pll multiplication factor 38
CRM_PLL_MULT_39 | pll multiplication factor 39
CRM_PLL_MULT_40 | pll multiplication factor 40
CRM_PLL_MULT_41 | pll multiplication factor 41
CRM_PLL_MULT_42 | pll multiplication factor 42
CRM_PLL_MULT_43 | pll multiplication factor 43
CRM_PLL_MULT_44 | pll multiplication factor 44
CRM_PLL_MULT_45 | pll multiplication factor 45
CRM_PLL_MULT_46 | pll multiplication factor 46
CRM_PLL_MULT_47 | pll multiplication factor 47
CRM_PLL_MULT_48 | pll multiplication factor 48
CRM_PLL_MULT_49 | pll multiplication factor 49
CRM_PLL_MULT_50 | pll multiplication factor 50
CRM_PLL_MULT_51 | pll multiplication factor 51
CRM_PLL_MULT_52 | pll multiplication factor 52
CRM_PLL_MULT_53 | pll multiplication factor 53
CRM_PLL_MULT_54 | pll multiplication factor 54
CRM_PLL_MULT_55 | pll multiplication factor 55
CRM_PLL_MULT_56 | pll multiplication factor 56
CRM_PLL_MULT_57 | pll multiplication factor 57
CRM_PLL_MULT_58 | pll multiplication factor 58
CRM_PLL_MULT_59 | pll multiplication factor 59
CRM_PLL_MULT_60 | pll multiplication factor 60
CRM_PLL_MULT_61 | pll multiplication factor 61
CRM_PLL_MULT_62 | pll multiplication factor 62
CRM_PLL_MULT_63 | pll multiplication factor 63
CRM_PLL_MULT_64 | pll multiplication factor 64

Definition at line 201 of file at32f413_crm.h.

◆ crm_pll_output_range_type

enum crm_pll_output_range_type

crm pll clock output range

Enumerator
CRM_PLL_OUTPUT_RANGE_LE72MHZ | pll clock output range less than or equal to 72mhz
CRM_PLL_OUTPUT_RANGE_GT72MHZ | pll clock output range greater than 72mhz

Definition at line 281 of file at32f413_crm.h.

◆ crm_rtc_clock_type

enum crm_rtc_clock_type

crm rtc clock

Enumerator
CRM_RTC_CLOCK_NOCLK | no clock as rtc clock source
CRM_RTC_CLOCK_LEXT | low speed external crystal as rtc clock source
CRM_RTC_CLOCK_LICK | low speed internal clock as rtc clock source
CRM_RTC_CLOCK_HEXT_DIV | high speed external crystal div as rtc clock source

Definition at line 369 of file at32f413_crm.h.

◆ crm_sclk_type

enum crm_sclk_type

crm sclk select

Enumerator
CRM_SCLK_HICK | select high speed internal clock as sclk
CRM_SCLK_HEXT | select high speed external crystal as sclk
CRM_SCLK_PLL | select phase locking loop clock as sclk

Definition at line 389 of file at32f413_crm.h.

◆ crm_usb_clock_source_type

enum crm_usb_clock_source_type

crm usb 48 mhz clock source select

Enumerator
CRM_USB_CLOCK_SOURCE_PLL | select phase locking loop clock as usb clock source
CRM_USB_CLOCK_SOURCE_HICK | select high speed internal clock as usb clock source

Definition at line 450 of file at32f413_crm.h.

◆ crm_usb_div_type

enum crm_usb_div_type

crm usb division

Enumerator
CRM_USB_DIV_1_5 | pllclk div1.5 to usbclk
CRM_USB_DIV_1 | pllclk div1 to usbclk
CRM_USB_DIV_2_5 | pllclk div2.5 to usbclk
CRM_USB_DIV_2 | pllclk div2 to usbclk
CRM_USB_DIV_3_5 | pllclk div3.5 to usbclk
CRM_USB_DIV_3 | pllclk div3 to usbclk
CRM_USB_DIV_4 | pllclk div4 to usbclk

Definition at line 355 of file at32f413_crm.h.

◆ crm_usb_int_map_type

enum crm_usb_int_map_type

crm usbdev interrupt remap

Enumerator
CRM_USB_INT19_INT20 | usb high and low priority irq numer use 19 and 20
CRM_USB_INT73_INT74 | usb high and low priority irq numer use 73 and 74

Definition at line 441 of file at32f413_crm.h.


AT32F413 Firmwary Library: crm_clocks_freq_type Struct Reference

Data Fields
crm_clocks_freq_type Struct Reference
AT32F413_periph_driver » CRM » CRM_exported_types

crm clocks freqency structure More...

#include <at32f413_crm.h>

Data Fields

uint32_t | sclk_freq
uint32_t | ahb_freq
uint32_t | apb2_freq
uint32_t | apb1_freq
uint32_t | adc_freq

Detailed Description

crm clocks freqency structure

Definition at line 468 of file at32f413_crm.h.

Field Documentation

◆ adc_freq

uint32_t crm_clocks_freq_type::adc_freq

adc clock frequency

Definition at line 474 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get().

◆ ahb_freq

uint32_t crm_clocks_freq_type::ahb_freq

ahb bus clock frequency

Definition at line 471 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), main(), and tmr_init().

◆ apb1_freq

uint32_t crm_clocks_freq_type::apb1_freq

apb1 bus clock frequency

Definition at line 473 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), i2c_init(), main(), usart_configuration(), and usart_init().

◆ apb2_freq

uint32_t crm_clocks_freq_type::apb2_freq

apb2 bus clock frequency

Definition at line 472 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), and usart_init().

◆ sclk_freq

uint32_t crm_clocks_freq_type::sclk_freq

system clock frequency

Definition at line 470 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), i2s_init(), main(), systick_configuration(), tmr1_config(), tmr2_config(), and TMR3_GLOBAL_IRQHandler().

The documentation for this struct was generated from the following file:
  • at32f413_crm.h


AT32F413 Firmwary Library: crm_type Struct Reference

Data Fields
crm_type Struct Reference
AT32F413_periph_driver » CRM » CRM_exported_types

type define crm register all More...

#include <at32f413_crm.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t hicken: 1
__IO uint32_t hickstbl: 1
__IO uint32_t hicktrim: 6
__IO uint32_t hickcal: 8
__IO uint32_t hexten: 1
__IO uint32_t hextstbl: 1
__IO uint32_t hextbyps: 1
__IO uint32_t cfden: 1
__IO uint32_t reserved1: 4
__IO uint32_t pllen: 1
__IO uint32_t pllstbl: 1
__IO uint32_t reserved2: 6
} ctrl_bit
};
crm ctrl register, offset:0x00 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t sclksel: 2
__IO uint32_t sclksts: 2
__IO uint32_t ahbdiv: 4
__IO uint32_t apb1div: 3
__IO uint32_t apb2div: 3
__IO uint32_t adcdiv_l: 2
__IO uint32_t pllrcs: 1
__IO uint32_t pllhextdiv: 1
__IO uint32_t pllmult_l: 4
__IO uint32_t usbdiv_l: 2
__IO uint32_t clkout_sel: 3
__IO uint32_t usbdiv_h: 1
__IO uint32_t adcdiv_h: 1
__IO uint32_t pllmult_h: 2
__IO uint32_t pllrange: 1
} cfg_bit
};
crm cfg register, offset:0x04 More...
union {
__IO uint32_t clkint
struct {
__IO uint32_t lickstblf: 1
__IO uint32_t lextstblf: 1
__IO uint32_t hickstblf: 1
__IO uint32_t hextstblf: 1
__IO uint32_t pllstblf: 1
__IO uint32_t reserved1: 2
__IO uint32_t cfdf: 1
__IO uint32_t lickstblien: 1
__IO uint32_t lextstblien: 1
__IO uint32_t hickstblien: 1
__IO uint32_t hextstblien: 1
__IO uint32_t pllstblien: 1
__IO uint32_t reserved2: 3
__IO uint32_t lickstblfc: 1
__IO uint32_t lextstblfc: 1
__IO uint32_t hickstblfc: 1
__IO uint32_t hextstblfc: 1
__IO uint32_t pllstblfc: 1
__IO uint32_t reserved3: 2
__IO uint32_t cfdfc: 1
__IO uint32_t reserved4: 8
} clkint_bit
};
crm clkint register, offset:0x08 More...
union {
__IO uint32_t apb2rst
struct {
__IO uint32_t iomuxrst: 1
__IO uint32_t exintrst: 1
__IO uint32_t gpioarst: 1
__IO uint32_t gpiobrst: 1
__IO uint32_t gpiocrst: 1
__IO uint32_t gpiodrst: 1
__IO uint32_t reserved1: 1
__IO uint32_t gpioerst: 1
__IO uint32_t reserved2: 1
__IO uint32_t adc1rst: 1
__IO uint32_t adc2rst: 1
__IO uint32_t tmr1rst: 1
__IO uint32_t spi1rst: 1
__IO uint32_t tmr8rst: 1
__IO uint32_t usart1rst: 1
__IO uint32_t reserved3: 4
__IO uint32_t tmr9rst: 1
__IO uint32_t tmr10rst: 1
__IO uint32_t tmr11rst: 1
__IO uint32_t accrst: 1
__IO uint32_t reserved4: 9
} apb2rst_bit
};
crm apb2rst register, offset:0x0C More...
union {
__IO uint32_t apb1rst
struct {
__IO uint32_t tmr2rst: 1
__IO uint32_t tmr3rst: 1
__IO uint32_t tmr4rst: 1
__IO uint32_t tmr5rst: 1
__IO uint32_t reserved1: 7
__IO uint32_t wwdtrst: 1
__IO uint32_t reserved2: 2
__IO uint32_t spi2rst: 1
__IO uint32_t reserved3: 2
__IO uint32_t usart2rst: 1
__IO uint32_t usart3rst: 1
__IO uint32_t uart4rst: 1
__IO uint32_t uart5rst: 1
__IO uint32_t i2c1rst: 1
__IO uint32_t i2c2rst: 1
__IO uint32_t usbrst: 1
__IO uint32_t reserved4: 1
__IO uint32_t can1rst: 1
__IO uint32_t reserved5: 1
__IO uint32_t bprrst: 1
__IO uint32_t pwcrst: 1
__IO uint32_t reserved6: 2
__IO uint32_t can2rst: 1
} apb1rst_bit
};
crm apb1rst register, offset:0x10 More...
union {
__IO uint32_t ahben
struct {
__IO uint32_t dma1en: 1
__IO uint32_t dma2en: 1
__IO uint32_t sramen: 1
__IO uint32_t reserved1: 1
__IO uint32_t flashen: 1
__IO uint32_t reserved2: 1
__IO uint32_t crcen: 1
__IO uint32_t reserved3: 3
__IO uint32_t sdio1en: 1
__IO uint32_t reserved5: 21
} ahben_bit
};
crm ahben register, offset:0x14 More...
union {
__IO uint32_t apb2en
struct {
__IO uint32_t iomuxen: 1
__IO uint32_t reserved1: 1
__IO uint32_t gpioaen: 1
__IO uint32_t gpioben: 1
__IO uint32_t gpiocen: 1
__IO uint32_t gpioden: 1
__IO uint32_t reserved2: 1
__IO uint32_t gpiofen: 1
__IO uint32_t reserved3: 1
__IO uint32_t adc1en: 1
__IO uint32_t adc2en: 1
__IO uint32_t tmr1en: 1
__IO uint32_t spi1en: 1
__IO uint32_t tmr8en: 1
__IO uint32_t usart1en: 1
__IO uint32_t reserved4: 4
__IO uint32_t tmr9en: 1
__IO uint32_t tmr10en: 1
__IO uint32_t tmr11en: 1
__IO uint32_t accen: 1
__IO uint32_t reserved5: 9
} apb2en_bit
};
crm apb2en register, offset:0x18 More...
union {
__IO uint32_t apb1en
struct {
__IO uint32_t tmr2en: 1
__IO uint32_t tmr3en: 1
__IO uint32_t tmr4en: 1
__IO uint32_t tmr5en: 1
__IO uint32_t reserved1: 7
__IO uint32_t wwdten: 1
__IO uint32_t reserved2: 2
__IO uint32_t spi2en: 1
__IO uint32_t reserved3: 2
__IO uint32_t usart2en: 1
__IO uint32_t usart3en: 1
__IO uint32_t uart4en: 1
__IO uint32_t uart5en: 1
__IO uint32_t i2c1en: 1
__IO uint32_t i2c2en: 1
__IO uint32_t usben: 1
__IO uint32_t reserved4: 1
__IO uint32_t can1en: 1
__IO uint32_t reserved5: 1
__IO uint32_t bpren: 1
__IO uint32_t pwcen: 1
__IO uint32_t reserved6: 2
__IO uint32_t can2en: 1
} apb1en_bit
};
crm apb1en register, offset:0x1C More...
union {
__IO uint32_t bpdc
struct {
__IO uint32_t lexten: 1
__IO uint32_t lextstbl: 1
__IO uint32_t lextbyps: 1
__IO uint32_t reserved1: 5
__IO uint32_t rtcsel: 2
__IO uint32_t reserved2: 5
__IO uint32_t rtcen: 1
__IO uint32_t bpdrst: 1
__IO uint32_t reserved3: 15
} bpdc_bit
};
crm bpdc register, offset:0x20 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t licken: 1
__IO uint32_t lickstbl: 1
__IO uint32_t reserved1: 22
__IO uint32_t rstfc: 1
__IO uint32_t reserved2: 1
__IO uint32_t nrstf: 1
__IO uint32_t porrstf: 1
__IO uint32_t swrstf: 1
__IO uint32_t wdtrstf: 1
__IO uint32_t wwdtrstf: 1
__IO uint32_t lprstf: 1
} ctrlsts_bit
};
crm ctrlsts register, offset:0x24 More...
union {
__IO uint32_t misc1
struct {
__IO uint32_t hickcal_key: 8
__IO uint32_t reserved1: 8
__IO uint32_t clkout_sel: 1
__IO uint32_t reserved2: 7
__IO uint32_t usbbufs: 1
__IO uint32_t hickdiv: 1
__IO uint32_t reserved3: 2
__IO uint32_t clkoutdiv: 4
} misc1_bit
};
crm misc1 register, offset:0x30 More...
union {
__IO uint32_t misc2
struct {
__IO uint32_t reserved1: 16
__IO uint32_t clk_to_tmr: 1
__IO uint32_t reserved2: 15
} misc2_bit
};
crm misc2 register, offset:0x50 More...
union {
__IO uint32_t misc3
struct {
__IO uint32_t reserved1: 4
__IO uint32_t auto_step_en: 2
__IO uint32_t reserved2: 2
__IO uint32_t hick_to_usb: 1
__IO uint32_t hick_to_sclk: 1
__IO uint32_t reserved3: 22
} misc3_bit
};
crm misc3 register, offset:0x54 More...
union {
__IO uint32_t intmap
struct {
__IO uint32_t usbintmap: 1
__IO uint32_t reserved1: 31
} intmap_bit
};
crm intmap register, offset:0x5C More...

Detailed Description

type define crm register all

Definition at line 480 of file at32f413_crm.h.

Field Documentation

◆

union { ... } crm_type::@292

crm ctrl register, offset:0x00

◆

union { ... } crm_type::@294

crm cfg register, offset:0x04

◆

union { ... } crm_type::@296

crm clkint register, offset:0x08

◆

union { ... } crm_type::@298

crm apb2rst register, offset:0x0C

◆

union { ... } crm_type::@300

crm apb1rst register, offset:0x10

◆

union { ... } crm_type::@302

crm ahben register, offset:0x14

◆

union { ... } crm_type::@304

crm apb2en register, offset:0x18

◆

union { ... } crm_type::@306

crm apb1en register, offset:0x1C

◆

union { ... } crm_type::@308

crm bpdc register, offset:0x20

◆

union { ... } crm_type::@310

crm ctrlsts register, offset:0x24

◆

union { ... } crm_type::@312

crm misc1 register, offset:0x30

◆

union { ... } crm_type::@314

crm misc2 register, offset:0x50

◆

union { ... } crm_type::@316

crm misc3 register, offset:0x54

◆

union { ... } crm_type::@318

crm intmap register, offset:0x5C

◆ accen

__IO uint32_t crm_type::accen

Definition at line 677 of file at32f413_crm.h.

◆ accrst

__IO uint32_t crm_type::accrst

Definition at line 590 of file at32f413_crm.h.

◆ adc1en

__IO uint32_t crm_type::adc1en

Definition at line 667 of file at32f413_crm.h.

◆ adc1rst

__IO uint32_t crm_type::adc1rst

Definition at line 580 of file at32f413_crm.h.

◆ adc2en

__IO uint32_t crm_type::adc2en

Definition at line 668 of file at32f413_crm.h.

◆ adc2rst

__IO uint32_t crm_type::adc2rst

Definition at line 581 of file at32f413_crm.h.

◆ adcdiv_h

__IO uint32_t crm_type::adcdiv_h

Definition at line 525 of file at32f413_crm.h.

◆ adcdiv_l

__IO uint32_t crm_type::adcdiv_l

Definition at line 518 of file at32f413_crm.h.

◆ ahbdiv

__IO uint32_t crm_type::ahbdiv

Definition at line 515 of file at32f413_crm.h.

◆ ahben

__IO uint32_t crm_type::ahben

Definition at line 634 of file at32f413_crm.h.

◆

struct { ... } crm_type::ahben_bit

◆ apb1div

__IO uint32_t crm_type::apb1div

Definition at line 516 of file at32f413_crm.h.

◆ apb1en

__IO uint32_t crm_type::apb1en

Definition at line 687 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb1en_bit

◆ apb1rst

__IO uint32_t crm_type::apb1rst

Definition at line 600 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb1rst_bit

◆ apb2div

__IO uint32_t crm_type::apb2div

Definition at line 517 of file at32f413_crm.h.

◆ apb2en

__IO uint32_t crm_type::apb2en

Definition at line 655 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb2en_bit

◆ apb2rst

__IO uint32_t crm_type::apb2rst

Definition at line 568 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb2rst_bit

◆ auto_step_en

__IO uint32_t crm_type::auto_step_en

Definition at line 810 of file at32f413_crm.h.

◆ bpdc

__IO uint32_t crm_type::bpdc

Definition at line 721 of file at32f413_crm.h.

◆

struct { ... } crm_type::bpdc_bit

◆ bpdrst

__IO uint32_t crm_type::bpdrst

Definition at line 731 of file at32f413_crm.h.

◆ bpren

__IO uint32_t crm_type::bpren

Definition at line 709 of file at32f413_crm.h.

◆ bprrst

__IO uint32_t crm_type::bprrst

Definition at line 622 of file at32f413_crm.h.

◆ can1en

__IO uint32_t crm_type::can1en

Definition at line 707 of file at32f413_crm.h.

◆ can1rst

__IO uint32_t crm_type::can1rst

Definition at line 620 of file at32f413_crm.h.

◆ can2en

__IO uint32_t crm_type::can2en

Definition at line 712 of file at32f413_crm.h.

◆ can2rst

__IO uint32_t crm_type::can2rst

Definition at line 625 of file at32f413_crm.h.

◆ cfden

__IO uint32_t crm_type::cfden

Definition at line 497 of file at32f413_crm.h.

◆ cfdf

__IO uint32_t crm_type::cfdf

Definition at line 545 of file at32f413_crm.h.

◆ cfdfc

__IO uint32_t crm_type::cfdfc

Definition at line 558 of file at32f413_crm.h.

◆ cfg

__IO uint32_t crm_type::cfg

Definition at line 510 of file at32f413_crm.h.

◆

struct { ... } crm_type::cfg_bit

◆ clk_to_tmr

__IO uint32_t crm_type::clk_to_tmr

Definition at line 796 of file at32f413_crm.h.

◆ clkint

__IO uint32_t crm_type::clkint

Definition at line 536 of file at32f413_crm.h.

◆

struct { ... } crm_type::clkint_bit

◆ clkout_sel

__IO uint32_t crm_type::clkout_sel

Definition at line 523 of file at32f413_crm.h.

◆ clkoutdiv

__IO uint32_t crm_type::clkoutdiv

Definition at line 778 of file at32f413_crm.h.

◆ crcen

__IO uint32_t crm_type::crcen

Definition at line 643 of file at32f413_crm.h.

◆ ctrl

__IO uint32_t crm_type::ctrl

Definition at line 487 of file at32f413_crm.h.

◆

struct { ... } crm_type::ctrl_bit

◆ ctrlsts

__IO uint32_t crm_type::ctrlsts

Definition at line 741 of file at32f413_crm.h.

◆

struct { ... } crm_type::ctrlsts_bit

◆ dma1en

__IO uint32_t crm_type::dma1en

Definition at line 637 of file at32f413_crm.h.

◆ dma2en

__IO uint32_t crm_type::dma2en

Definition at line 638 of file at32f413_crm.h.

◆ exintrst

__IO uint32_t crm_type::exintrst

Definition at line 572 of file at32f413_crm.h.

◆ flashen

__IO uint32_t crm_type::flashen

Definition at line 641 of file at32f413_crm.h.

◆ gpioaen

__IO uint32_t crm_type::gpioaen

Definition at line 660 of file at32f413_crm.h.

◆ gpioarst

__IO uint32_t crm_type::gpioarst

Definition at line 573 of file at32f413_crm.h.

◆ gpioben

__IO uint32_t crm_type::gpioben

Definition at line 661 of file at32f413_crm.h.

◆ gpiobrst

__IO uint32_t crm_type::gpiobrst

Definition at line 574 of file at32f413_crm.h.

◆ gpiocen

__IO uint32_t crm_type::gpiocen

Definition at line 662 of file at32f413_crm.h.

◆ gpiocrst

__IO uint32_t crm_type::gpiocrst

Definition at line 575 of file at32f413_crm.h.

◆ gpioden

__IO uint32_t crm_type::gpioden

Definition at line 663 of file at32f413_crm.h.

◆ gpiodrst

__IO uint32_t crm_type::gpiodrst

Definition at line 576 of file at32f413_crm.h.

◆ gpioerst

__IO uint32_t crm_type::gpioerst

Definition at line 578 of file at32f413_crm.h.

◆ gpiofen

__IO uint32_t crm_type::gpiofen

Definition at line 665 of file at32f413_crm.h.

◆ hextbyps

__IO uint32_t crm_type::hextbyps

Definition at line 496 of file at32f413_crm.h.

◆ hexten

__IO uint32_t crm_type::hexten

Definition at line 494 of file at32f413_crm.h.

◆ hextstbl

__IO uint32_t crm_type::hextstbl

Definition at line 495 of file at32f413_crm.h.

◆ hextstblf

__IO uint32_t crm_type::hextstblf

Definition at line 542 of file at32f413_crm.h.

◆ hextstblfc

__IO uint32_t crm_type::hextstblfc

Definition at line 555 of file at32f413_crm.h.

◆ hextstblien

__IO uint32_t crm_type::hextstblien

Definition at line 549 of file at32f413_crm.h.

◆ hick_to_sclk

__IO uint32_t crm_type::hick_to_sclk

Definition at line 813 of file at32f413_crm.h.

◆ hick_to_usb

__IO uint32_t crm_type::hick_to_usb

Definition at line 812 of file at32f413_crm.h.

◆ hickcal

__IO uint32_t crm_type::hickcal

Definition at line 493 of file at32f413_crm.h.

◆ hickcal_key

__IO uint32_t crm_type::hickcal_key

Definition at line 771 of file at32f413_crm.h.

◆ hickdiv

__IO uint32_t crm_type::hickdiv

Definition at line 776 of file at32f413_crm.h.

◆ hicken

__IO uint32_t crm_type::hicken

Definition at line 490 of file at32f413_crm.h.

◆ hickstbl

__IO uint32_t crm_type::hickstbl

Definition at line 491 of file at32f413_crm.h.

◆ hickstblf

__IO uint32_t crm_type::hickstblf

Definition at line 541 of file at32f413_crm.h.

◆ hickstblfc

__IO uint32_t crm_type::hickstblfc

Definition at line 554 of file at32f413_crm.h.

◆ hickstblien

__IO uint32_t crm_type::hickstblien

Definition at line 548 of file at32f413_crm.h.

◆ hicktrim

__IO uint32_t crm_type::hicktrim

Definition at line 492 of file at32f413_crm.h.

◆ i2c1en

__IO uint32_t crm_type::i2c1en

Definition at line 703 of file at32f413_crm.h.

◆ i2c1rst

__IO uint32_t crm_type::i2c1rst

Definition at line 616 of file at32f413_crm.h.

◆ i2c2en

__IO uint32_t crm_type::i2c2en

Definition at line 704 of file at32f413_crm.h.

◆ i2c2rst

__IO uint32_t crm_type::i2c2rst

Definition at line 617 of file at32f413_crm.h.

◆ intmap

__IO uint32_t crm_type::intmap

Definition at line 828 of file at32f413_crm.h.

◆

struct { ... } crm_type::intmap_bit

◆ iomuxen

__IO uint32_t crm_type::iomuxen

Definition at line 658 of file at32f413_crm.h.

◆ iomuxrst

__IO uint32_t crm_type::iomuxrst

Definition at line 571 of file at32f413_crm.h.

◆ lextbyps

__IO uint32_t crm_type::lextbyps

Definition at line 726 of file at32f413_crm.h.

◆ lexten

__IO uint32_t crm_type::lexten

Definition at line 724 of file at32f413_crm.h.

◆ lextstbl

__IO uint32_t crm_type::lextstbl

Definition at line 725 of file at32f413_crm.h.

◆ lextstblf

__IO uint32_t crm_type::lextstblf

Definition at line 540 of file at32f413_crm.h.

◆ lextstblfc

__IO uint32_t crm_type::lextstblfc

Definition at line 553 of file at32f413_crm.h.

◆ lextstblien

__IO uint32_t crm_type::lextstblien

Definition at line 547 of file at32f413_crm.h.

◆ licken

__IO uint32_t crm_type::licken

Definition at line 744 of file at32f413_crm.h.

◆ lickstbl

__IO uint32_t crm_type::lickstbl

Definition at line 745 of file at32f413_crm.h.

◆ lickstblf

__IO uint32_t crm_type::lickstblf

Definition at line 539 of file at32f413_crm.h.

◆ lickstblfc

__IO uint32_t crm_type::lickstblfc

Definition at line 552 of file at32f413_crm.h.

◆ lickstblien

__IO uint32_t crm_type::lickstblien

Definition at line 546 of file at32f413_crm.h.

◆ lprstf

__IO uint32_t crm_type::lprstf

Definition at line 754 of file at32f413_crm.h.

◆ misc1

__IO uint32_t crm_type::misc1

Definition at line 768 of file at32f413_crm.h.

◆

struct { ... } crm_type::misc1_bit

◆ misc2

__IO uint32_t crm_type::misc2

Definition at line 792 of file at32f413_crm.h.

◆

struct { ... } crm_type::misc2_bit

◆ misc3

__IO uint32_t crm_type::misc3

Definition at line 806 of file at32f413_crm.h.

◆

struct { ... } crm_type::misc3_bit

◆ nrstf

__IO uint32_t crm_type::nrstf

Definition at line 749 of file at32f413_crm.h.

◆ pllen

__IO uint32_t crm_type::pllen

Definition at line 499 of file at32f413_crm.h.

◆ pllhextdiv

__IO uint32_t crm_type::pllhextdiv

Definition at line 520 of file at32f413_crm.h.

◆ pllmult_h

__IO uint32_t crm_type::pllmult_h

Definition at line 526 of file at32f413_crm.h.

◆ pllmult_l

__IO uint32_t crm_type::pllmult_l

Definition at line 521 of file at32f413_crm.h.

◆ pllrange

__IO uint32_t crm_type::pllrange

Definition at line 527 of file at32f413_crm.h.

◆ pllrcs

__IO uint32_t crm_type::pllrcs

Definition at line 519 of file at32f413_crm.h.

◆ pllstbl

__IO uint32_t crm_type::pllstbl

Definition at line 500 of file at32f413_crm.h.

◆ pllstblf

__IO uint32_t crm_type::pllstblf

Definition at line 543 of file at32f413_crm.h.

◆ pllstblfc

__IO uint32_t crm_type::pllstblfc

Definition at line 556 of file at32f413_crm.h.

◆ pllstblien

__IO uint32_t crm_type::pllstblien

Definition at line 550 of file at32f413_crm.h.

◆ porrstf

__IO uint32_t crm_type::porrstf

Definition at line 750 of file at32f413_crm.h.

◆ pwcen

__IO uint32_t crm_type::pwcen

Definition at line 710 of file at32f413_crm.h.

◆ pwcrst

__IO uint32_t crm_type::pwcrst

Definition at line 623 of file at32f413_crm.h.

◆ reserved1

__IO uint32_t crm_type::reserved1

crm reserved1 register, offset:0x28~0x2C

Definition at line 498 of file at32f413_crm.h.

◆ reserved2

__IO uint32_t crm_type::reserved2

crm reserved2 register, offset:0x4C~0x34

Definition at line 501 of file at32f413_crm.h.

◆ reserved3

__IO uint32_t crm_type::reserved3

crm reserved3 register, offset:0x58

Definition at line 557 of file at32f413_crm.h.

◆ reserved4

__IO uint32_t crm_type::reserved4

Definition at line 559 of file at32f413_crm.h.

◆ reserved5

__IO uint32_t crm_type::reserved5

Definition at line 621 of file at32f413_crm.h.

◆ reserved6

__IO uint32_t crm_type::reserved6

Definition at line 624 of file at32f413_crm.h.

◆ rstfc

__IO uint32_t crm_type::rstfc

Definition at line 747 of file at32f413_crm.h.

◆ rtcen

__IO uint32_t crm_type::rtcen

Definition at line 730 of file at32f413_crm.h.

◆ rtcsel

__IO uint32_t crm_type::rtcsel

Definition at line 728 of file at32f413_crm.h.

◆ sclksel

__IO uint32_t crm_type::sclksel

Definition at line 513 of file at32f413_crm.h.

◆ sclksts

__IO uint32_t crm_type::sclksts

Definition at line 514 of file at32f413_crm.h.

◆ sdio1en

__IO uint32_t crm_type::sdio1en

Definition at line 645 of file at32f413_crm.h.

◆ spi1en

__IO uint32_t crm_type::spi1en

Definition at line 670 of file at32f413_crm.h.

◆ spi1rst

__IO uint32_t crm_type::spi1rst

Definition at line 583 of file at32f413_crm.h.

◆ spi2en

__IO uint32_t crm_type::spi2en

Definition at line 697 of file at32f413_crm.h.

◆ spi2rst

__IO uint32_t crm_type::spi2rst

Definition at line 610 of file at32f413_crm.h.

◆ sramen

__IO uint32_t crm_type::sramen

Definition at line 639 of file at32f413_crm.h.

◆ swrstf

__IO uint32_t crm_type::swrstf

Definition at line 751 of file at32f413_crm.h.

◆ tmr10en

__IO uint32_t crm_type::tmr10en

Definition at line 675 of file at32f413_crm.h.

◆ tmr10rst

__IO uint32_t crm_type::tmr10rst

Definition at line 588 of file at32f413_crm.h.

◆ tmr11en

__IO uint32_t crm_type::tmr11en

Definition at line 676 of file at32f413_crm.h.

◆ tmr11rst

__IO uint32_t crm_type::tmr11rst

Definition at line 589 of file at32f413_crm.h.

◆ tmr1en

__IO uint32_t crm_type::tmr1en

Definition at line 669 of file at32f413_crm.h.

◆ tmr1rst

__IO uint32_t crm_type::tmr1rst

Definition at line 582 of file at32f413_crm.h.

◆ tmr2en

__IO uint32_t crm_type::tmr2en

Definition at line 690 of file at32f413_crm.h.

◆ tmr2rst

__IO uint32_t crm_type::tmr2rst

Definition at line 603 of file at32f413_crm.h.

◆ tmr3en

__IO uint32_t crm_type::tmr3en

Definition at line 691 of file at32f413_crm.h.

◆ tmr3rst

__IO uint32_t crm_type::tmr3rst

Definition at line 604 of file at32f413_crm.h.

◆ tmr4en

__IO uint32_t crm_type::tmr4en

Definition at line 692 of file at32f413_crm.h.

◆ tmr4rst

__IO uint32_t crm_type::tmr4rst

Definition at line 605 of file at32f413_crm.h.

◆ tmr5en

__IO uint32_t crm_type::tmr5en

Definition at line 693 of file at32f413_crm.h.

◆ tmr5rst

__IO uint32_t crm_type::tmr5rst

Definition at line 606 of file at32f413_crm.h.

◆ tmr8en

__IO uint32_t crm_type::tmr8en

Definition at line 671 of file at32f413_crm.h.

◆ tmr8rst

__IO uint32_t crm_type::tmr8rst

Definition at line 584 of file at32f413_crm.h.

◆ tmr9en

__IO uint32_t crm_type::tmr9en

Definition at line 674 of file at32f413_crm.h.

◆ tmr9rst

__IO uint32_t crm_type::tmr9rst

Definition at line 587 of file at32f413_crm.h.

◆ uart4en

__IO uint32_t crm_type::uart4en

Definition at line 701 of file at32f413_crm.h.

◆ uart4rst

__IO uint32_t crm_type::uart4rst

Definition at line 614 of file at32f413_crm.h.

◆ uart5en

__IO uint32_t crm_type::uart5en

Definition at line 702 of file at32f413_crm.h.

◆ uart5rst

__IO uint32_t crm_type::uart5rst

Definition at line 615 of file at32f413_crm.h.

◆ usart1en

__IO uint32_t crm_type::usart1en

Definition at line 672 of file at32f413_crm.h.

◆ usart1rst

__IO uint32_t crm_type::usart1rst

Definition at line 585 of file at32f413_crm.h.

◆ usart2en

__IO uint32_t crm_type::usart2en

Definition at line 699 of file at32f413_crm.h.

◆ usart2rst

__IO uint32_t crm_type::usart2rst

Definition at line 612 of file at32f413_crm.h.

◆ usart3en

__IO uint32_t crm_type::usart3en

Definition at line 700 of file at32f413_crm.h.

◆ usart3rst

__IO uint32_t crm_type::usart3rst

Definition at line 613 of file at32f413_crm.h.

◆ usbbufs

__IO uint32_t crm_type::usbbufs

Definition at line 775 of file at32f413_crm.h.

◆ usbdiv_h

__IO uint32_t crm_type::usbdiv_h

Definition at line 524 of file at32f413_crm.h.

◆ usbdiv_l

__IO uint32_t crm_type::usbdiv_l

Definition at line 522 of file at32f413_crm.h.

◆ usben

__IO uint32_t crm_type::usben

Definition at line 705 of file at32f413_crm.h.

◆ usbintmap

__IO uint32_t crm_type::usbintmap

Definition at line 831 of file at32f413_crm.h.

◆ usbrst

__IO uint32_t crm_type::usbrst

Definition at line 618 of file at32f413_crm.h.

◆ wdtrstf

__IO uint32_t crm_type::wdtrstf

Definition at line 752 of file at32f413_crm.h.

◆ wwdten

__IO uint32_t crm_type::wwdten

Definition at line 695 of file at32f413_crm.h.

◆ wwdtrst

__IO uint32_t crm_type::wwdtrst

Definition at line 608 of file at32f413_crm.h.

◆ wwdtrstf

__IO uint32_t crm_type::wwdtrstf

Definition at line 753 of file at32f413_crm.h.

The documentation for this struct was generated from the following file:
  • at32f413_crm.h


AT32F413 Firmwary Library: CRM_exported_functions

Functions
CRM_exported_functions
AT32F413_periph_driver » CRM

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

Function Documentation

◆ crm_adc_clock_div_set()

void crm_adc_clock_div_set ( crm_adc_div_type div_value )

set crm adc division

Parameters
value this parameter can be one of the following values:
  • CRM_ADC_DIV_2
  • CRM_ADC_DIV_4
  • CRM_ADC_DIV_6
  • CRM_ADC_DIV_8
  • CRM_ADC_DIV_12
  • CRM_ADC_DIV_16
Return values
none

Definition at line 455 of file at32f413_crm.c.

Referenced by adc_config().

◆ crm_ahb_div_set()

void crm_ahb_div_set ( crm_ahb_div_type value )

set crm ahb division

Parameters
value this parameter can be one of the following values:
  • CRM_AHB_DIV_1
  • CRM_AHB_DIV_2
  • CRM_AHB_DIV_4
  • CRM_AHB_DIV_8
  • CRM_AHB_DIV_16
  • CRM_AHB_DIV_64
  • CRM_AHB_DIV_128
  • CRM_AHB_DIV_256
  • CRM_AHB_DIV_512
Return values
none

Definition at line 404 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb1_div_set()

void crm_apb1_div_set ( crm_apb1_div_type value )

set crm apb1 division

Note
the maximum frequency of APB1/APB2 clock is 100 MHz
Parameters
value this parameter can be one of the following values:
  • CRM_APB1_DIV_1
  • CRM_APB1_DIV_2
  • CRM_APB1_DIV_4
  • CRM_APB1_DIV_8
  • CRM_APB1_DIV_16
Return values
none

Definition at line 421 of file at32f413_crm.c.

Referenced by main(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb2_div_set()

void crm_apb2_div_set ( crm_apb2_div_type value )

set crm apb2 division

Note
the maximum frequency of APB1/APB2 clock is 100 MHz
Parameters
value this parameter can be one of the following values:
  • CRM_APB2_DIV_1
  • CRM_APB2_DIV_2
  • CRM_APB2_DIV_4
  • CRM_APB2_DIV_8
  • CRM_APB2_DIV_16
Return values
none

Definition at line 438 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_auto_step_mode_enable()

void crm_auto_step_mode_enable ( confirm_state new_state )

auto step clock switch enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 715 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_battery_powered_domain_reset()

void crm_battery_powered_domain_reset ( confirm_state new_state )

battery powered domain software reset

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 495 of file at32f413_crm.c.

Referenced by bpr_reset().

◆ crm_clkout_div_set()

void crm_clkout_div_set ( crm_clkout_div_type clkout_div )

set crm clkout division

Parameters
clkout_div this parameter can be one of the following values:
  • CRM_CLKOUT_DIV_1
  • CRM_CLKOUT_DIV_2
  • CRM_CLKOUT_DIV_4
  • CRM_CLKOUT_DIV_8
  • CRM_CLKOUT_DIV_16
  • CRM_CLKOUT_DIV_64
  • CRM_CLKOUT_DIV_128
  • CRM_CLKOUT_DIV_256
  • CRM_CLKOUT_DIV_512
Return values
none

Definition at line 805 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clkout_to_tmr10_enable()

void crm_clkout_to_tmr10_enable ( confirm_state new_state )

enable or disable clkout direct to tmr10 channel 1

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 785 of file at32f413_crm.c.

◆ crm_clock_failure_detection_enable()

void crm_clock_failure_detection_enable ( confirm_state new_state )

enable or disable clock failure detection

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 485 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_clock_out_set()

void crm_clock_out_set ( crm_clkout_select_type clkout )

set crm clkout

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT_NOCLK
  • CRM_CLKOUT_LICK
  • CRM_CLKOUT_LEXT
  • CRM_CLKOUT_SCLK
  • CRM_CLKOUT_HICK
  • CRM_CLKOUT_HEXT
  • CRM_CLKOUT_PLL_DIV_2
  • CRM_CLKOUT_PLL_DIV_4
  • CRM_CLKOUT_USB
  • CRM_CLKOUT_ADC
Return values
none

Definition at line 684 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clock_source_enable()

void crm_clock_source_enable | ( | crm_clock_source_type | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the crm clock source

Parameters
source this parameter can be one of the following values:
  • CRM_CLOCK_SOURCE_HICK
  • CRM_CLOCK_SOURCE_HEXT
  • CRM_CLOCK_SOURCE_PLL
  • CRM_CLOCK_SOURCE_LEXT
  • CRM_CLOCK_SOURCE_LICK
new_state (TRUE or FALSE)
Return values
none

Definition at line 283 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_clocks_freq_get()

void crm_clocks_freq_get ( crm_clocks_freq_type * clocks_struct )

get crm clocks freqency

Parameters
clocks
  • pointer to the crm_clocks_freq structure
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 577 of file at32f413_crm.c.

Referenced by i2c_init(), i2s_init(), main(), tmr1_config(), tmr2_config(), tmr_init(), usart_configuration(), and usart_init().

◆ crm_flag_clear()

void crm_flag_clear ( uint32_t flag )

clear the crm reset flags

Parameters
flag this parameter can be one of the following values: reset flag:
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG
  • CRM_ALL_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
none

< nrst pin reset flag

< power on reset flag

< software reset flag

< watchdog timer reset flag

< window watchdog timer reset flag

< low-power reset flag

< all reset flag

< low speed internal clock stable interrupt ready flag

< low speed external crystal stable interrupt ready flag

< high speed internal clock stable interrupt ready flag

< high speed external crystal stable interrupt ready flag

< phase locking loop stable interrupt ready flag

< clock failure interrupt ready flag

Definition at line 328 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_flag_get()

flag_status crm_flag_get ( uint32_t flag )

get crm flag status

Parameters
flag this parameter can be one of the following values:
  • CRM_HICK_STABLE_FLAG
  • CRM_HEXT_STABLE_FLAG
  • CRM_PLL_STABLE_FLAG
  • CRM_LEXT_STABLE_FLAG
  • CRM_LICK_STABLE_FLAG
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 120 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), crm_hext_stable_wait(), main(), rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_hext_bypass()

void crm_hext_bypass ( confirm_state new_state )

enable or disable crm high speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 91 of file at32f413_crm.c.

◆ crm_hext_stable_wait()

error_status crm_hext_stable_wait ( void )

wait for hext stable

Parameters
none
Return values
error_status (ERROR or SUCCESS)

< high speed external crystal stable flag

< time out for hext start up

< high speed external crystal stable flag

Definition at line 139 of file at32f413_crm.c.

Referenced by sclk_96m_hext_config(), system_clock_config(), and system_clock_recover().

◆ crm_hick_clock_calibration_set()

void crm_hick_clock_calibration_set ( uint8_t cali_value )

set the crm calibration value

Parameters
cali_value (0x00~0xFF)
Return values
none

Definition at line 176 of file at32f413_crm.c.

◆ crm_hick_clock_trimming_set()

void crm_hick_clock_trimming_set ( uint8_t trim_value )

set the hick trimming value

Parameters
trim_value (0x00~0x3F)
Return values
none

Definition at line 166 of file at32f413_crm.c.

◆ crm_hick_divider_select()

void crm_hick_divider_select ( crm_hick_div_6_type value )

config hick divider select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK48_DIV6
  • CRM_HICK48_NODIV
Return values
none

Definition at line 744 of file at32f413_crm.c.

Referenced by crm_hick_sclk_frequency_select().

◆ crm_hick_sclk_frequency_select()

void crm_hick_sclk_frequency_select ( crm_hick_sclk_frequency_type value )

hick as system clock frequency select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK_SCLK_8MHZ
  • CRM_HICK_SCLK_48MHZ
Return values
none

Definition at line 757 of file at32f413_crm.c.

Referenced by crm_usb_clock_source_select().

◆ crm_interrupt_enable()

void crm_interrupt_enable | ( | uint32_t | crm_int,
 |  | confirm_state | new_state
 | ) |  |

config crm interrupt

Parameters
int this parameter can be any combination of the following values:
  • CRM_LICK_STABLE_INT
  • CRM_LEXT_STABLE_INT
  • CRM_HICK_STABLE_INT
  • CRM_HEXT_STABLE_INT
  • CRM_PLL_STABLE_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 702 of file at32f413_crm.c.

◆ crm_lext_bypass()

void crm_lext_bypass ( confirm_state new_state )

enable or disable crm low speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 81 of file at32f413_crm.c.

◆ crm_periph_clock_enable()

void crm_periph_clock_enable | ( | crm_periph_clock_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock

Parameters
value this parameter can be one of the following values:
  • CRM_DMA1_PERIPH_CLOCK - CRM_DMA2_PERIPH_CLOCK - CRM_CRC_PERIPH_CLOCK - CRM_SDIO1_PERIPH_CLOCK
  • CRM_IOMUX_PERIPH_CLOCK - CRM_GPIOA_PERIPH_CLOCK - CRM_GPIOB_PERIPH_CLOCK - CRM_GPIOC_PERIPH_CLOCK
  • CRM_GPIOD_PERIPH_CLOCK - CRM_GPIOF_PERIPH_CLOCK - CRM_ADC1_PERIPH_CLOCK - CRM_ADC2_PERIPH_CLOCK
  • CRM_TMR1_PERIPH_CLOCK - CRM_SPI1_PERIPH_CLOCK - CRM_TMR8_PERIPH_CLOCK - CRM_USART1_PERIPH_CLOCK
  • CRM_TMR9_PERIPH_CLOCK - CRM_TMR10_PERIPH_CLOCK - CRM_TMR11_PERIPH_CLOCK - CRM_ACC_PERIPH_CLOCK
  • CRM_TMR3_PERIPH_CLOCK - CRM_TMR4_PERIPH_CLOCK - CRM_TMR5_PERIPH_CLOCK - CRM_WWDT_PERIPH_CLOCK
  • CRM_SPI2_PERIPH_CLOCK - CRM_USART2_PERIPH_CLOCK - CRM_USART3_PERIPH_CLOCK - CRM_UART4_PERIPH_CLOCK
  • CRM_UART5_PERIPH_CLOCK - CRM_I2C1_PERIPH_CLOCK - CRM_I2C2_PERIPH_CLOCK - CRM_USB_PERIPH_CLOCK
  • CRM_CAN1_PERIPH_CLOCK - CRM_BPR_PERIPH_CLOCK - CRM_PWC_PERIPH_CLOCK - CRM_CAN2_PERIPH_CLOCK
new_state (TRUE or FALSE)
Return values
none

Definition at line 204 of file at32f413_crm.c.

Referenced by adc_config(), app_load(), at32_button_init(), at32_led_init(), button_exint_init(), can_configuration(), can_gpio_config(), clkout_config(), codec_i2s_init(), crc_cal(), crm_configuration(), dma_config(), dma_configuration(), exint_config(), exint_line0_config(), exint_line4_config(), flash_crc_check(), gpio_config(), i2c_lowlevel_init(), i2s_config(), jump_to_app(), main(), mclk_tmr1_init(), rs485_config(), rtc_alarm_clock_set(), rtc_configuration(), rtc_init(), rtc_time_set(), sd_dma_config(), sd_init(), spi_config(), spiflash_init(), spim_init(), tmr1_config(), tmr2_config(), TMR3_GLOBAL_IRQHandler(), tmr_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_clock48m_select(), and usb_usart_config().

◆ crm_periph_reset()

void crm_periph_reset | ( | crm_periph_reset_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral reset

Parameters
value this parameter can be one of the following values:
  • CRM_IOMUX_PERIPH_RESET - CRM_EXINT_PERIPH_RESET - CRM_GPIOA_PERIPH_RESET - CRM_GPIOB_PERIPH_RESET
  • CRM_GPIOC_PERIPH_RESET - CRM_GPIOD_PERIPH_RESET - CRM_GPIOF_PERIPH_RESET - CRM_ADC1_PERIPH_RESET
  • CRM_ADC2_PERIPH_RESET - CRM_TMR1_PERIPH_RESET - CRM_SPI1_PERIPH_RESET - CRM_TMR8_PERIPH_RESET
  • CRM_USART1_PERIPH_RESET - CRM_TMR9_PERIPH_RESET - CRM_TMR10_PERIPH_RESET - CRM_TMR11_PERIPH_RESET
  • CRM_ACC_PERIPH_RESET - CRM_TMR2_PERIPH_RESET - CRM_TMR3_PERIPH_RESET - CRM_TMR4_PERIPH_RESET
  • CRM_TMR5_PERIPH_RESET - CRM_WWDT_PERIPH_RESET - CRM_SPI2_PERIPH_RESET - CRM_USART2_PERIPH_RESET
  • CRM_USART3_PERIPH_RESET - CRM_UART4_PERIPH_RESET - CRM_UART5_PERIPH_RESET - CRM_I2C1_PERIPH_RESET
  • CRM_I2C2_PERIPH_RESET - CRM_USB_PERIPH_RESET - CRM_CAN1_PERIPH_RESET - CRM_BPR_PERIPH_RESET
  • CRM_PWC_PERIPH_RESET - CRM_CAN2_PERIPH_RESET
new_state (TRUE or FALSE)
Return values
none

Definition at line 234 of file at32f413_crm.c.

Referenced by adc_reset(), can_reset(), gpio_iomux_reset(), gpio_reset(), i2c_reset(), jump_to_app(), pwc_reset(), spi_i2s_reset(), tmr_reset(), usart_reset(), and wwdt_reset().

◆ crm_periph_sleep_mode_clock_enable()

void crm_periph_sleep_mode_clock_enable | ( | crm_periph_clock_sleepmd_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock in sleep mode

Parameters
value this parameter can be one of the following values:
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
new_state (TRUE or FALSE)
Return values
none

Definition at line 257 of file at32f413_crm.c.

◆ crm_pll_config()

void crm_pll_config | ( | crm_pll_clock_source_type | clock_source,
 |  | crm_pll_mult_type | mult_value,
 |  | crm_pll_output_range_type | pll_range
 | ) |  |

config crm pll

Parameters
clock_source this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
  • CRM_PLL_SOURCE_HEXT_DIV
mult_value (CRM_PLL_MULT_2~64)
pll_range this parameter can be one of the following values:
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ
Return values
none

Definition at line 514 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_reset()

void crm_reset ( void )

reset the crm register

Parameters
none
Return values
none

Definition at line 47 of file at32f413_crm.c.

Referenced by app_update_handle(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_rtc_clock_enable()

void crm_rtc_clock_enable ( confirm_state new_state )

enable or disable rtc

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 384 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_rtc_clock_select()

void crm_rtc_clock_select ( crm_rtc_clock_type value )

select rtc clock

Parameters
value this parameter can be one of the following values:
  • CRM_RTC_CLOCK_LEXT
  • CRM_RTC_CLOCK_LICK
  • CRM_RTC_CLOCK_HEXT_DIV
Return values
none

Definition at line 374 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_sysclk_switch()

void crm_sysclk_switch ( crm_sclk_type value )

select system clock source

Parameters
value this parameter can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL
Return values
none

Definition at line 552 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_sysclk_switch_status_get()

crm_sclk_type crm_sysclk_switch_status_get ( void )

indicate which clock source is used as system clock

Parameters
none
Return values
crm_sclk this return can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL

Definition at line 566 of file at32f413_crm.c.

Referenced by crm_clocks_freq_get(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), system_clock_recover(), and system_core_clock_update().

◆ crm_usb_clock_div_set()

void crm_usb_clock_div_set ( crm_usb_div_type div_value )

set crm usb division

Parameters
value this parameter can be one of the following values:
  • CRM_USB_DIV_1_5
  • CRM_USB_DIV_1
  • CRM_USB_DIV_2_5
  • CRM_USB_DIV_2
  • CRM_USB_DIV_3_5
  • CRM_USB_DIV_3
  • CRM_USB_DIV_4
Return values
none

Definition at line 474 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_clock_source_select()

void crm_usb_clock_source_select ( crm_usb_clock_source_type value )

usb 48 mhz clock source select

Parameters
value this parameter can be one of the following values:
  • CRM_USB_CLOCK_SOURCE_PLL
  • CRM_USB_CLOCK_SOURCE_HICK
Return values
none

Definition at line 771 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_interrupt_remapping_set()

void crm_usb_interrupt_remapping_set ( crm_usb_int_map_type int_remap )

usbdev interrupt remapping control

Parameters
int_remap this parameter can be one of the following values:
  • CRM_USB_INT19_INT20
  • CRM_USB_INT73_INT74
Return values
none

Definition at line 731 of file at32f413_crm.c.


AT32F413 Firmwary Library: CRM_private_functions

Functions
CRM_private_functions
AT32F413_periph_driver » CRM

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

Function Documentation

◆ crm_adc_clock_div_set()

void crm_adc_clock_div_set ( crm_adc_div_type div_value )

set crm adc division

Parameters
value this parameter can be one of the following values:
  • CRM_ADC_DIV_2
  • CRM_ADC_DIV_4
  • CRM_ADC_DIV_6
  • CRM_ADC_DIV_8
  • CRM_ADC_DIV_12
  • CRM_ADC_DIV_16
Return values
none

Definition at line 455 of file at32f413_crm.c.

Referenced by adc_config().

◆ crm_ahb_div_set()

void crm_ahb_div_set ( crm_ahb_div_type value )

set crm ahb division

Parameters
value this parameter can be one of the following values:
  • CRM_AHB_DIV_1
  • CRM_AHB_DIV_2
  • CRM_AHB_DIV_4
  • CRM_AHB_DIV_8
  • CRM_AHB_DIV_16
  • CRM_AHB_DIV_64
  • CRM_AHB_DIV_128
  • CRM_AHB_DIV_256
  • CRM_AHB_DIV_512
Return values
none

Definition at line 404 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb1_div_set()

void crm_apb1_div_set ( crm_apb1_div_type value )

set crm apb1 division

Note
the maximum frequency of APB1/APB2 clock is 100 MHz
Parameters
value this parameter can be one of the following values:
  • CRM_APB1_DIV_1
  • CRM_APB1_DIV_2
  • CRM_APB1_DIV_4
  • CRM_APB1_DIV_8
  • CRM_APB1_DIV_16
Return values
none

Definition at line 421 of file at32f413_crm.c.

Referenced by main(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb2_div_set()

void crm_apb2_div_set ( crm_apb2_div_type value )

set crm apb2 division

Note
the maximum frequency of APB1/APB2 clock is 100 MHz
Parameters
value this parameter can be one of the following values:
  • CRM_APB2_DIV_1
  • CRM_APB2_DIV_2
  • CRM_APB2_DIV_4
  • CRM_APB2_DIV_8
  • CRM_APB2_DIV_16
Return values
none

Definition at line 438 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_auto_step_mode_enable()

void crm_auto_step_mode_enable ( confirm_state new_state )

auto step clock switch enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 715 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_battery_powered_domain_reset()

void crm_battery_powered_domain_reset ( confirm_state new_state )

battery powered domain software reset

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 495 of file at32f413_crm.c.

Referenced by bpr_reset().

◆ crm_clkout_div_set()

void crm_clkout_div_set ( crm_clkout_div_type clkout_div )

set crm clkout division

Parameters
clkout_div this parameter can be one of the following values:
  • CRM_CLKOUT_DIV_1
  • CRM_CLKOUT_DIV_2
  • CRM_CLKOUT_DIV_4
  • CRM_CLKOUT_DIV_8
  • CRM_CLKOUT_DIV_16
  • CRM_CLKOUT_DIV_64
  • CRM_CLKOUT_DIV_128
  • CRM_CLKOUT_DIV_256
  • CRM_CLKOUT_DIV_512
Return values
none

Definition at line 805 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clkout_to_tmr10_enable()

void crm_clkout_to_tmr10_enable ( confirm_state new_state )

enable or disable clkout direct to tmr10 channel 1

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 785 of file at32f413_crm.c.

◆ crm_clock_failure_detection_enable()

void crm_clock_failure_detection_enable ( confirm_state new_state )

enable or disable clock failure detection

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 485 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_clock_out_set()

void crm_clock_out_set ( crm_clkout_select_type clkout )

set crm clkout

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT_NOCLK
  • CRM_CLKOUT_LICK
  • CRM_CLKOUT_LEXT
  • CRM_CLKOUT_SCLK
  • CRM_CLKOUT_HICK
  • CRM_CLKOUT_HEXT
  • CRM_CLKOUT_PLL_DIV_2
  • CRM_CLKOUT_PLL_DIV_4
  • CRM_CLKOUT_USB
  • CRM_CLKOUT_ADC
Return values
none

Definition at line 684 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clock_source_enable()

void crm_clock_source_enable | ( | crm_clock_source_type | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the crm clock source

Parameters
source this parameter can be one of the following values:
  • CRM_CLOCK_SOURCE_HICK
  • CRM_CLOCK_SOURCE_HEXT
  • CRM_CLOCK_SOURCE_PLL
  • CRM_CLOCK_SOURCE_LEXT
  • CRM_CLOCK_SOURCE_LICK
new_state (TRUE or FALSE)
Return values
none

Definition at line 283 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_clocks_freq_get()

void crm_clocks_freq_get ( crm_clocks_freq_type * clocks_struct )

get crm clocks freqency

Parameters
clocks
  • pointer to the crm_clocks_freq structure
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 577 of file at32f413_crm.c.

Referenced by i2c_init(), i2s_init(), main(), tmr1_config(), tmr2_config(), tmr_init(), usart_configuration(), and usart_init().

◆ crm_flag_clear()

void crm_flag_clear ( uint32_t flag )

clear the crm reset flags

Parameters
flag this parameter can be one of the following values: reset flag:
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG
  • CRM_ALL_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
none

< nrst pin reset flag

< power on reset flag

< software reset flag

< watchdog timer reset flag

< window watchdog timer reset flag

< low-power reset flag

< all reset flag

< low speed internal clock stable interrupt ready flag

< low speed external crystal stable interrupt ready flag

< high speed internal clock stable interrupt ready flag

< high speed external crystal stable interrupt ready flag

< phase locking loop stable interrupt ready flag

< clock failure interrupt ready flag

Definition at line 328 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_flag_get()

flag_status crm_flag_get ( uint32_t flag )

get crm flag status

Parameters
flag this parameter can be one of the following values:
  • CRM_HICK_STABLE_FLAG
  • CRM_HEXT_STABLE_FLAG
  • CRM_PLL_STABLE_FLAG
  • CRM_LEXT_STABLE_FLAG
  • CRM_LICK_STABLE_FLAG
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 120 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), crm_hext_stable_wait(), main(), rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_hext_bypass()

void crm_hext_bypass ( confirm_state new_state )

enable or disable crm high speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 91 of file at32f413_crm.c.

◆ crm_hext_stable_wait()

error_status crm_hext_stable_wait ( void )

wait for hext stable

Parameters
none
Return values
error_status (ERROR or SUCCESS)

< high speed external crystal stable flag

< time out for hext start up

< high speed external crystal stable flag

Definition at line 139 of file at32f413_crm.c.

Referenced by sclk_96m_hext_config(), system_clock_config(), and system_clock_recover().

◆ crm_hick_clock_calibration_set()

void crm_hick_clock_calibration_set ( uint8_t cali_value )

set the crm calibration value

Parameters
cali_value (0x00~0xFF)
Return values
none

Definition at line 176 of file at32f413_crm.c.

◆ crm_hick_clock_trimming_set()

void crm_hick_clock_trimming_set ( uint8_t trim_value )

set the hick trimming value

Parameters
trim_value (0x00~0x3F)
Return values
none

Definition at line 166 of file at32f413_crm.c.

◆ crm_hick_divider_select()

void crm_hick_divider_select ( crm_hick_div_6_type value )

config hick divider select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK48_DIV6
  • CRM_HICK48_NODIV
Return values
none

Definition at line 744 of file at32f413_crm.c.

Referenced by crm_hick_sclk_frequency_select().

◆ crm_hick_sclk_frequency_select()

void crm_hick_sclk_frequency_select ( crm_hick_sclk_frequency_type value )

hick as system clock frequency select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK_SCLK_8MHZ
  • CRM_HICK_SCLK_48MHZ
Return values
none

Definition at line 757 of file at32f413_crm.c.

Referenced by crm_usb_clock_source_select().

◆ crm_interrupt_enable()

void crm_interrupt_enable | ( | uint32_t | crm_int,
 |  | confirm_state | new_state
 | ) |  |

config crm interrupt

Parameters
int this parameter can be any combination of the following values:
  • CRM_LICK_STABLE_INT
  • CRM_LEXT_STABLE_INT
  • CRM_HICK_STABLE_INT
  • CRM_HEXT_STABLE_INT
  • CRM_PLL_STABLE_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 702 of file at32f413_crm.c.

◆ crm_lext_bypass()

void crm_lext_bypass ( confirm_state new_state )

enable or disable crm low speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 81 of file at32f413_crm.c.

◆ crm_periph_clock_enable()

void crm_periph_clock_enable | ( | crm_periph_clock_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock

Parameters
value this parameter can be one of the following values:
  • CRM_DMA1_PERIPH_CLOCK - CRM_DMA2_PERIPH_CLOCK - CRM_CRC_PERIPH_CLOCK - CRM_SDIO1_PERIPH_CLOCK
  • CRM_IOMUX_PERIPH_CLOCK - CRM_GPIOA_PERIPH_CLOCK - CRM_GPIOB_PERIPH_CLOCK - CRM_GPIOC_PERIPH_CLOCK
  • CRM_GPIOD_PERIPH_CLOCK - CRM_GPIOF_PERIPH_CLOCK - CRM_ADC1_PERIPH_CLOCK - CRM_ADC2_PERIPH_CLOCK
  • CRM_TMR1_PERIPH_CLOCK - CRM_SPI1_PERIPH_CLOCK - CRM_TMR8_PERIPH_CLOCK - CRM_USART1_PERIPH_CLOCK
  • CRM_TMR9_PERIPH_CLOCK - CRM_TMR10_PERIPH_CLOCK - CRM_TMR11_PERIPH_CLOCK - CRM_ACC_PERIPH_CLOCK
  • CRM_TMR3_PERIPH_CLOCK - CRM_TMR4_PERIPH_CLOCK - CRM_TMR5_PERIPH_CLOCK - CRM_WWDT_PERIPH_CLOCK
  • CRM_SPI2_PERIPH_CLOCK - CRM_USART2_PERIPH_CLOCK - CRM_USART3_PERIPH_CLOCK - CRM_UART4_PERIPH_CLOCK
  • CRM_UART5_PERIPH_CLOCK - CRM_I2C1_PERIPH_CLOCK - CRM_I2C2_PERIPH_CLOCK - CRM_USB_PERIPH_CLOCK
  • CRM_CAN1_PERIPH_CLOCK - CRM_BPR_PERIPH_CLOCK - CRM_PWC_PERIPH_CLOCK - CRM_CAN2_PERIPH_CLOCK
new_state (TRUE or FALSE)
Return values
none

Definition at line 204 of file at32f413_crm.c.

Referenced by adc_config(), app_load(), at32_button_init(), at32_led_init(), button_exint_init(), can_configuration(), can_gpio_config(), clkout_config(), codec_i2s_init(), crc_cal(), crm_configuration(), dma_config(), dma_configuration(), exint_config(), exint_line0_config(), exint_line4_config(), flash_crc_check(), gpio_config(), i2c_lowlevel_init(), i2s_config(), jump_to_app(), main(), mclk_tmr1_init(), rs485_config(), rtc_alarm_clock_set(), rtc_configuration(), rtc_init(), rtc_time_set(), sd_dma_config(), sd_init(), spi_config(), spiflash_init(), spim_init(), tmr1_config(), tmr2_config(), TMR3_GLOBAL_IRQHandler(), tmr_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_clock48m_select(), and usb_usart_config().

◆ crm_periph_reset()

void crm_periph_reset | ( | crm_periph_reset_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral reset

Parameters
value this parameter can be one of the following values:
  • CRM_IOMUX_PERIPH_RESET - CRM_EXINT_PERIPH_RESET - CRM_GPIOA_PERIPH_RESET - CRM_GPIOB_PERIPH_RESET
  • CRM_GPIOC_PERIPH_RESET - CRM_GPIOD_PERIPH_RESET - CRM_GPIOF_PERIPH_RESET - CRM_ADC1_PERIPH_RESET
  • CRM_ADC2_PERIPH_RESET - CRM_TMR1_PERIPH_RESET - CRM_SPI1_PERIPH_RESET - CRM_TMR8_PERIPH_RESET
  • CRM_USART1_PERIPH_RESET - CRM_TMR9_PERIPH_RESET - CRM_TMR10_PERIPH_RESET - CRM_TMR11_PERIPH_RESET
  • CRM_ACC_PERIPH_RESET - CRM_TMR2_PERIPH_RESET - CRM_TMR3_PERIPH_RESET - CRM_TMR4_PERIPH_RESET
  • CRM_TMR5_PERIPH_RESET - CRM_WWDT_PERIPH_RESET - CRM_SPI2_PERIPH_RESET - CRM_USART2_PERIPH_RESET
  • CRM_USART3_PERIPH_RESET - CRM_UART4_PERIPH_RESET - CRM_UART5_PERIPH_RESET - CRM_I2C1_PERIPH_RESET
  • CRM_I2C2_PERIPH_RESET - CRM_USB_PERIPH_RESET - CRM_CAN1_PERIPH_RESET - CRM_BPR_PERIPH_RESET
  • CRM_PWC_PERIPH_RESET - CRM_CAN2_PERIPH_RESET
new_state (TRUE or FALSE)
Return values
none

Definition at line 234 of file at32f413_crm.c.

Referenced by adc_reset(), can_reset(), gpio_iomux_reset(), gpio_reset(), i2c_reset(), jump_to_app(), pwc_reset(), spi_i2s_reset(), tmr_reset(), usart_reset(), and wwdt_reset().

◆ crm_periph_sleep_mode_clock_enable()

void crm_periph_sleep_mode_clock_enable | ( | crm_periph_clock_sleepmd_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock in sleep mode

Parameters
value this parameter can be one of the following values:
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
new_state (TRUE or FALSE)
Return values
none

Definition at line 257 of file at32f413_crm.c.

◆ crm_pll_config()

void crm_pll_config | ( | crm_pll_clock_source_type | clock_source,
 |  | crm_pll_mult_type | mult_value,
 |  | crm_pll_output_range_type | pll_range
 | ) |  |

config crm pll

Parameters
clock_source this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
  • CRM_PLL_SOURCE_HEXT_DIV
mult_value (CRM_PLL_MULT_2~64)
pll_range this parameter can be one of the following values:
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ
Return values
none

Definition at line 514 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_reset()

void crm_reset ( void )

reset the crm register

Parameters
none
Return values
none

Definition at line 47 of file at32f413_crm.c.

Referenced by app_update_handle(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_rtc_clock_enable()

void crm_rtc_clock_enable ( confirm_state new_state )

enable or disable rtc

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 384 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_rtc_clock_select()

void crm_rtc_clock_select ( crm_rtc_clock_type value )

select rtc clock

Parameters
value this parameter can be one of the following values:
  • CRM_RTC_CLOCK_LEXT
  • CRM_RTC_CLOCK_LICK
  • CRM_RTC_CLOCK_HEXT_DIV
Return values
none

Definition at line 374 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_sysclk_switch()

void crm_sysclk_switch ( crm_sclk_type value )

select system clock source

Parameters
value this parameter can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL
Return values
none

Definition at line 552 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_sysclk_switch_status_get()

crm_sclk_type crm_sysclk_switch_status_get ( void )

indicate which clock source is used as system clock

Parameters
none
Return values
crm_sclk this return can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL

Definition at line 566 of file at32f413_crm.c.

Referenced by crm_clocks_freq_get(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), system_clock_recover(), and system_core_clock_update().

◆ crm_usb_clock_div_set()

void crm_usb_clock_div_set ( crm_usb_div_type div_value )

set crm usb division

Parameters
value this parameter can be one of the following values:
  • CRM_USB_DIV_1_5
  • CRM_USB_DIV_1
  • CRM_USB_DIV_2_5
  • CRM_USB_DIV_2
  • CRM_USB_DIV_3_5
  • CRM_USB_DIV_3
  • CRM_USB_DIV_4
Return values
none

Definition at line 474 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_clock_source_select()

void crm_usb_clock_source_select ( crm_usb_clock_source_type value )

usb 48 mhz clock source select

Parameters
value this parameter can be one of the following values:
  • CRM_USB_CLOCK_SOURCE_PLL
  • CRM_USB_CLOCK_SOURCE_HICK
Return values
none

Definition at line 771 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_interrupt_remapping_set()

void crm_usb_interrupt_remapping_set ( crm_usb_int_map_type int_remap )

usbdev interrupt remapping control

Parameters
int_remap this parameter can be one of the following values:
  • CRM_USB_INT19_INT20
  • CRM_USB_INT73_INT74
Return values
none

Definition at line 731 of file at32f413_crm.c.


AT32F413 Firmwary Library: DEBUG

Modules | Macros
DEBUG
AT32F413_periph_driver

DEBUG driver modules. More...

Modules

DEBUG_mode_definition
DEBUG_exported_types
DEBUG_exported_functions
DEBUG_private_functions

Macros

#define DEBUGMCU ((debug_type *) DEBUG_BASE)

Detailed Description

DEBUG driver modules.

Macro Definition Documentation

◆ DEBUGMCU

#define DEBUGMCU ((debug_type *) DEBUG_BASE)

Definition at line 134 of file at32f413_debug.h.


AT32F413 Firmwary Library: DEBUG_mode_definition

Macros
DEBUG_mode_definition
AT32F413_periph_driver » DEBUG

Macros

#define | DEBUG_SLEEP 0x00000001
#define | DEBUG_DEEPSLEEP 0x00000002
#define | DEBUG_STANDBY 0x00000004
#define | DEBUG_WDT_PAUSE 0x00000100
#define | DEBUG_WWDT_PAUSE 0x00000200
#define | DEBUG_TMR1_PAUSE 0x00000400
#define | DEBUG_TMR2_PAUSE 0x00000800
#define | DEBUG_TMR3_PAUSE 0x00001000
#define | DEBUG_TMR4_PAUSE 0x00002000
#define | DEBUG_CAN1_PAUSE 0x00004000
#define | DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000
#define | DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000
#define | DEBUG_TMR8_PAUSE 0x00020000
#define | DEBUG_TMR5_PAUSE 0x00040000
#define | DEBUG_CAN2_PAUSE 0x00200000
#define | DEBUG_TMR9_PAUSE 0x10000000
#define | DEBUG_TMR10_PAUSE 0x20000000
#define | DEBUG_TMR11_PAUSE 0x40000000

Detailed Description

Macro Definition Documentation

◆ DEBUG_CAN1_PAUSE

#define DEBUG_CAN1_PAUSE 0x00004000

debug can1 pause

Definition at line 58 of file at32f413_debug.h.

◆ DEBUG_CAN2_PAUSE

#define DEBUG_CAN2_PAUSE 0x00200000

debug can2 pause

Definition at line 63 of file at32f413_debug.h.

◆ DEBUG_DEEPSLEEP

#define DEBUG_DEEPSLEEP 0x00000002

debug deepsleep mode

Definition at line 50 of file at32f413_debug.h.

◆ DEBUG_I2C1_SMBUS_TIMEOUT

#define DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000

debug i2c1 smbus timeout

Definition at line 59 of file at32f413_debug.h.

◆ DEBUG_I2C2_SMBUS_TIMEOUT

#define DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000

debug i2c2 smbus timeout

Definition at line 60 of file at32f413_debug.h.

◆ DEBUG_SLEEP

#define DEBUG_SLEEP 0x00000001

debug sleep mode

Definition at line 49 of file at32f413_debug.h.

◆ DEBUG_STANDBY

#define DEBUG_STANDBY 0x00000004

debug standby mode

Definition at line 51 of file at32f413_debug.h.

◆ DEBUG_TMR10_PAUSE

#define DEBUG_TMR10_PAUSE 0x20000000

debug timer10 pause

Definition at line 65 of file at32f413_debug.h.

◆ DEBUG_TMR11_PAUSE

#define DEBUG_TMR11_PAUSE 0x40000000

debug timer11 pause

Definition at line 66 of file at32f413_debug.h.

◆ DEBUG_TMR1_PAUSE

#define DEBUG_TMR1_PAUSE 0x00000400

debug timer1 pause

Definition at line 54 of file at32f413_debug.h.

◆ DEBUG_TMR2_PAUSE

#define DEBUG_TMR2_PAUSE 0x00000800

debug timer2 pause

Definition at line 55 of file at32f413_debug.h.

◆ DEBUG_TMR3_PAUSE

#define DEBUG_TMR3_PAUSE 0x00001000

debug timer3 pause

Definition at line 56 of file at32f413_debug.h.

◆ DEBUG_TMR4_PAUSE

#define DEBUG_TMR4_PAUSE 0x00002000

debug timer4 pause

Definition at line 57 of file at32f413_debug.h.

◆ DEBUG_TMR5_PAUSE

#define DEBUG_TMR5_PAUSE 0x00040000

debug timer5 pause

Definition at line 62 of file at32f413_debug.h.

◆ DEBUG_TMR8_PAUSE

#define DEBUG_TMR8_PAUSE 0x00020000

debug timer8 pause

Definition at line 61 of file at32f413_debug.h.

◆ DEBUG_TMR9_PAUSE

#define DEBUG_TMR9_PAUSE 0x10000000

debug timer9 pause

Definition at line 64 of file at32f413_debug.h.

◆ DEBUG_WDT_PAUSE

#define DEBUG_WDT_PAUSE 0x00000100

debug watchdog timer pause

Definition at line 52 of file at32f413_debug.h.

◆ DEBUG_WWDT_PAUSE

#define DEBUG_WWDT_PAUSE 0x00000200

debug window watchdog timer pause

Definition at line 53 of file at32f413_debug.h.


AT32F413 Firmwary Library: DEBUG_exported_types

Data Structures
DEBUG_exported_types
AT32F413_periph_driver » DEBUG

Data Structures

struct debug_type
type define debug register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: debug_type Struct Reference

Data Fields
debug_type Struct Reference
AT32F413_periph_driver » DEBUG » DEBUG_exported_types

type define debug register all More...

#include <at32f413_debug.h>

Data Fields

union {
__IO uint32_t pid
struct {
__IO uint32_t pid: 32
} idcode_bit
};
debug idcode register, offset:0x00 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t sleep_debug: 1
__IO uint32_t deepsleep_debug: 1
__IO uint32_t standby_debug: 1
__IO uint32_t reserved1: 2
__IO uint32_t trace_ioen: 1
__IO uint32_t trace_mode: 2
__IO uint32_t wdt_pause: 1
__IO uint32_t wwdt_pause: 1
__IO uint32_t tmr1_pause: 1
__IO uint32_t tmr2_pause: 1
__IO uint32_t tmr3_pause: 1
__IO uint32_t tmr4_pause: 1
__IO uint32_t can1_pause: 1
__IO uint32_t i2c1_smbus_timeout: 1
__IO uint32_t i2c2_smbus_timeout: 1
__IO uint32_t tmr8_pause: 1
__IO uint32_t tmr5_pause: 1
__IO uint32_t reserved2: 2
__IO uint32_t can2_pause: 1
__IO uint32_t reserved3: 6
__IO uint32_t tmr9_pause: 1
__IO uint32_t tmr10_pause: 1
__IO uint32_t tmr11_pause: 1
__IO uint32_t reserved4: 1
} ctrl_bit
};
debug ctrl register, offset:0x04 More...

Detailed Description

type define debug register all

Definition at line 79 of file at32f413_debug.h.

Field Documentation

◆

union { ... } debug_type::@334

debug idcode register, offset:0x00

◆

union { ... } debug_type::@336

debug ctrl register, offset:0x04

◆ can1_pause

__IO uint32_t debug_type::can1_pause

Definition at line 113 of file at32f413_debug.h.

◆ can2_pause

__IO uint32_t debug_type::can2_pause

Definition at line 119 of file at32f413_debug.h.

◆ ctrl

__IO uint32_t debug_type::ctrl

Definition at line 98 of file at32f413_debug.h.

◆

struct { ... } debug_type::ctrl_bit

◆ deepsleep_debug

__IO uint32_t debug_type::deepsleep_debug

Definition at line 102 of file at32f413_debug.h.

◆ i2c1_smbus_timeout

__IO uint32_t debug_type::i2c1_smbus_timeout

Definition at line 114 of file at32f413_debug.h.

◆ i2c2_smbus_timeout

__IO uint32_t debug_type::i2c2_smbus_timeout

Definition at line 115 of file at32f413_debug.h.

◆

struct { ... } debug_type::idcode_bit

◆ pid

__IO uint32_t debug_type::pid

Definition at line 86 of file at32f413_debug.h.

◆ reserved1

__IO uint32_t debug_type::reserved1

Definition at line 104 of file at32f413_debug.h.

◆ reserved2

__IO uint32_t debug_type::reserved2

Definition at line 118 of file at32f413_debug.h.

◆ reserved3

__IO uint32_t debug_type::reserved3

Definition at line 120 of file at32f413_debug.h.

◆ reserved4

__IO uint32_t debug_type::reserved4

Definition at line 124 of file at32f413_debug.h.

◆ sleep_debug

__IO uint32_t debug_type::sleep_debug

Definition at line 101 of file at32f413_debug.h.

◆ standby_debug

__IO uint32_t debug_type::standby_debug

Definition at line 103 of file at32f413_debug.h.

◆ tmr10_pause

__IO uint32_t debug_type::tmr10_pause

Definition at line 122 of file at32f413_debug.h.

◆ tmr11_pause

__IO uint32_t debug_type::tmr11_pause

Definition at line 123 of file at32f413_debug.h.

◆ tmr1_pause

__IO uint32_t debug_type::tmr1_pause

Definition at line 109 of file at32f413_debug.h.

◆ tmr2_pause

__IO uint32_t debug_type::tmr2_pause

Definition at line 110 of file at32f413_debug.h.

◆ tmr3_pause

__IO uint32_t debug_type::tmr3_pause

Definition at line 111 of file at32f413_debug.h.

◆ tmr4_pause

__IO uint32_t debug_type::tmr4_pause

Definition at line 112 of file at32f413_debug.h.

◆ tmr5_pause

__IO uint32_t debug_type::tmr5_pause

Definition at line 117 of file at32f413_debug.h.

◆ tmr8_pause

__IO uint32_t debug_type::tmr8_pause

Definition at line 116 of file at32f413_debug.h.

◆ tmr9_pause

__IO uint32_t debug_type::tmr9_pause

Definition at line 121 of file at32f413_debug.h.

◆ trace_ioen

__IO uint32_t debug_type::trace_ioen

Definition at line 105 of file at32f413_debug.h.

◆ trace_mode

__IO uint32_t debug_type::trace_mode

Definition at line 106 of file at32f413_debug.h.

◆ wdt_pause

__IO uint32_t debug_type::wdt_pause

Definition at line 107 of file at32f413_debug.h.

◆ wwdt_pause

__IO uint32_t debug_type::wwdt_pause

Definition at line 108 of file at32f413_debug.h.

The documentation for this struct was generated from the following file:
  • at32f413_debug.h


AT32F413 Firmwary Library: DEBUG_exported_functions

Functions
DEBUG_exported_functions
AT32F413_periph_driver » DEBUG

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

Function Documentation

◆ debug_device_id_get()

uint32_t debug_device_id_get ( void )

get debug device id

Parameters
none
Return values
the debug device id

Definition at line 47 of file at32f413_debug.c.

◆ debug_periph_mode_set()

void debug_periph_mode_set | ( | uint32_t | periph_debug_mode,
 |  | confirm_state | new_state
 | ) |  |

set periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_SLEEP
  • DEBUG_DEEPSLEEP
  • DEBUG_STANDBY
  • DEBUG_WDT_PAUSE
  • DEBUG_WWDT_PAUSE
  • DEBUG_TMR1_PAUSE
  • DEBUG_TMR2_PAUSE
  • DEBUG_TMR3_PAUSE
  • DEBUG_TMR4_PAUSE
  • DEBUG_CAN1_PAUSE
  • DEBUG_I2C1_SMBUS_TIMEOUT
  • DEBUG_I2C2_SMBUS_TIMEOUT
  • DEBUG_TMR8_PAUSE
  • DEBUG_TMR5_PAUSE
  • DEBUG_CAN2_PAUSE
  • DEBUG_TMR9_PAUSE
  • DEBUG_TMR10_PAUSE
  • DEBUG_TMR11_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 77 of file at32f413_debug.c.

Referenced by main().


AT32F413 Firmwary Library: DEBUG_private_functions

Functions
DEBUG_private_functions
AT32F413_periph_driver » DEBUG

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

Function Documentation

◆ debug_device_id_get()

uint32_t debug_device_id_get ( void )

get debug device id

Parameters
none
Return values
the debug device id

Definition at line 47 of file at32f413_debug.c.

◆ debug_periph_mode_set()

void debug_periph_mode_set | ( | uint32_t | periph_debug_mode,
 |  | confirm_state | new_state
 | ) |  |

set periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_SLEEP
  • DEBUG_DEEPSLEEP
  • DEBUG_STANDBY
  • DEBUG_WDT_PAUSE
  • DEBUG_WWDT_PAUSE
  • DEBUG_TMR1_PAUSE
  • DEBUG_TMR2_PAUSE
  • DEBUG_TMR3_PAUSE
  • DEBUG_TMR4_PAUSE
  • DEBUG_CAN1_PAUSE
  • DEBUG_I2C1_SMBUS_TIMEOUT
  • DEBUG_I2C2_SMBUS_TIMEOUT
  • DEBUG_TMR8_PAUSE
  • DEBUG_TMR5_PAUSE
  • DEBUG_CAN2_PAUSE
  • DEBUG_TMR9_PAUSE
  • DEBUG_TMR10_PAUSE
  • DEBUG_TMR11_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 77 of file at32f413_debug.c.

Referenced by main().


AT32F413 Firmwary Library: DMA

Modules | Macros
DMA
AT32F413_periph_driver

DMA driver modules. More...

Modules

DMA_interrupts_definition
dma interrupt
DMA_flexible_channel
DMA_flags_definition
dma flag
DMA_exported_types
DMA_exported_functions
DMA_private_functions

Macros

#define | DMA1 ((dma_type *) DMA1_BASE)
#define | DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
#define | DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
#define | DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
#define | DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
#define | DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
#define | DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
#define | DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
#define | DMA2 ((dma_type *) DMA2_BASE)
#define | DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
#define | DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
#define | DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
#define | DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
#define | DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
#define | DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
#define | DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)

Detailed Description

DMA driver modules.

Macro Definition Documentation

◆ DMA1

#define DMA1 ((dma_type *) DMA1_BASE)

Definition at line 477 of file at32f413_dma.h.

◆ DMA1_CHANNEL1

#define DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)

Definition at line 478 of file at32f413_dma.h.

◆ DMA1_CHANNEL2

#define DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)

Definition at line 479 of file at32f413_dma.h.

◆ DMA1_CHANNEL3

#define DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)

Definition at line 480 of file at32f413_dma.h.

◆ DMA1_CHANNEL4

#define DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)

Definition at line 481 of file at32f413_dma.h.

◆ DMA1_CHANNEL5

#define DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)

Definition at line 482 of file at32f413_dma.h.

◆ DMA1_CHANNEL6

#define DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)

Definition at line 483 of file at32f413_dma.h.

◆ DMA1_CHANNEL7

#define DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)

Definition at line 484 of file at32f413_dma.h.

◆ DMA2

#define DMA2 ((dma_type *) DMA2_BASE)

Definition at line 486 of file at32f413_dma.h.

◆ DMA2_CHANNEL1

#define DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)

Definition at line 487 of file at32f413_dma.h.

◆ DMA2_CHANNEL2

#define DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)

Definition at line 488 of file at32f413_dma.h.

◆ DMA2_CHANNEL3

#define DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)

Definition at line 489 of file at32f413_dma.h.

◆ DMA2_CHANNEL4

#define DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)

Definition at line 490 of file at32f413_dma.h.

◆ DMA2_CHANNEL5

#define DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)

Definition at line 491 of file at32f413_dma.h.

◆ DMA2_CHANNEL6

#define DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)

Definition at line 492 of file at32f413_dma.h.

◆ DMA2_CHANNEL7

#define DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)

Definition at line 493 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_interrupts_definition

Macros
DMA_interrupts_definition
AT32F413_periph_driver » DMA

dma interrupt More...

Macros

#define | DMA_FDT_INT ((uint32_t)0x00000002)
#define | DMA_HDT_INT ((uint32_t)0x00000004)
#define | DMA_DTERR_INT ((uint32_t)0x00000008)

Detailed Description

dma interrupt

Macro Definition Documentation

◆ DMA_DTERR_INT

#define DMA_DTERR_INT ((uint32_t)0x00000008)

dma errorr interrupt

Definition at line 52 of file at32f413_dma.h.

◆ DMA_FDT_INT

#define DMA_FDT_INT ((uint32_t)0x00000002)

dma full data transfer interrupt

Definition at line 50 of file at32f413_dma.h.

◆ DMA_HDT_INT

#define DMA_HDT_INT ((uint32_t)0x00000004)

dma half data transfer interrupt

Definition at line 51 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_flexible_channel

Macros
DMA_flexible_channel
AT32F413_periph_driver » DMA

Macros

#define | FLEX_CHANNEL1 ((uint8_t)0x01)
#define | FLEX_CHANNEL2 ((uint8_t)0x02)
#define | FLEX_CHANNEL3 ((uint8_t)0x03)
#define | FLEX_CHANNEL4 ((uint8_t)0x04)
#define | FLEX_CHANNEL5 ((uint8_t)0x05)
#define | FLEX_CHANNEL6 ((uint8_t)0x06)
#define | FLEX_CHANNEL7 ((uint8_t)0x07)

Detailed Description

Macro Definition Documentation

◆ FLEX_CHANNEL1

#define FLEX_CHANNEL1 ((uint8_t)0x01)

dma flexible channel1

Definition at line 62 of file at32f413_dma.h.

◆ FLEX_CHANNEL2

#define FLEX_CHANNEL2 ((uint8_t)0x02)

dma flexible channel2

Definition at line 63 of file at32f413_dma.h.

◆ FLEX_CHANNEL3

#define FLEX_CHANNEL3 ((uint8_t)0x03)

dma flexible channel3

Definition at line 64 of file at32f413_dma.h.

◆ FLEX_CHANNEL4

#define FLEX_CHANNEL4 ((uint8_t)0x04)

dma flexible channel4

Definition at line 65 of file at32f413_dma.h.

◆ FLEX_CHANNEL5

#define FLEX_CHANNEL5 ((uint8_t)0x05)

dma flexible channel5

Definition at line 66 of file at32f413_dma.h.

◆ FLEX_CHANNEL6

#define FLEX_CHANNEL6 ((uint8_t)0x06)

dma flexible channel6

Definition at line 67 of file at32f413_dma.h.

◆ FLEX_CHANNEL7

#define FLEX_CHANNEL7 ((uint8_t)0x07)

dma flexible channel7

Definition at line 68 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_flags_definition

Macros
DMA_flags_definition
AT32F413_periph_driver » DMA

dma flag More...

Macros

#define | DMA1_GL1_FLAG ((uint32_t)0x00000001)
#define | DMA1_FDT1_FLAG ((uint32_t)0x00000002)
#define | DMA1_HDT1_FLAG ((uint32_t)0x00000004)
#define | DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
#define | DMA1_GL2_FLAG ((uint32_t)0x00000010)
#define | DMA1_FDT2_FLAG ((uint32_t)0x00000020)
#define | DMA1_HDT2_FLAG ((uint32_t)0x00000040)
#define | DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
#define | DMA1_GL3_FLAG ((uint32_t)0x00000100)
#define | DMA1_FDT3_FLAG ((uint32_t)0x00000200)
#define | DMA1_HDT3_FLAG ((uint32_t)0x00000400)
#define | DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
#define | DMA1_GL4_FLAG ((uint32_t)0x00001000)
#define | DMA1_FDT4_FLAG ((uint32_t)0x00002000)
#define | DMA1_HDT4_FLAG ((uint32_t)0x00004000)
#define | DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
#define | DMA1_GL5_FLAG ((uint32_t)0x00010000)
#define | DMA1_FDT5_FLAG ((uint32_t)0x00020000)
#define | DMA1_HDT5_FLAG ((uint32_t)0x00040000)
#define | DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
#define | DMA1_GL6_FLAG ((uint32_t)0x00100000)
#define | DMA1_FDT6_FLAG ((uint32_t)0x00200000)
#define | DMA1_HDT6_FLAG ((uint32_t)0x00400000)
#define | DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
#define | DMA1_GL7_FLAG ((uint32_t)0x01000000)
#define | DMA1_FDT7_FLAG ((uint32_t)0x02000000)
#define | DMA1_HDT7_FLAG ((uint32_t)0x04000000)
#define | DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
#define | DMA2_GL1_FLAG ((uint32_t)0x10000001)
#define | DMA2_FDT1_FLAG ((uint32_t)0x10000002)
#define | DMA2_HDT1_FLAG ((uint32_t)0x10000004)
#define | DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
#define | DMA2_GL2_FLAG ((uint32_t)0x10000010)
#define | DMA2_FDT2_FLAG ((uint32_t)0x10000020)
#define | DMA2_HDT2_FLAG ((uint32_t)0x10000040)
#define | DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
#define | DMA2_GL3_FLAG ((uint32_t)0x10000100)
#define | DMA2_FDT3_FLAG ((uint32_t)0x10000200)
#define | DMA2_HDT3_FLAG ((uint32_t)0x10000400)
#define | DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
#define | DMA2_GL4_FLAG ((uint32_t)0x10001000)
#define | DMA2_FDT4_FLAG ((uint32_t)0x10002000)
#define | DMA2_HDT4_FLAG ((uint32_t)0x10004000)
#define | DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
#define | DMA2_GL5_FLAG ((uint32_t)0x10010000)
#define | DMA2_FDT5_FLAG ((uint32_t)0x10020000)
#define | DMA2_HDT5_FLAG ((uint32_t)0x10040000)
#define | DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
#define | DMA2_GL6_FLAG ((uint32_t)0x10100000)
#define | DMA2_FDT6_FLAG ((uint32_t)0x10200000)
#define | DMA2_HDT6_FLAG ((uint32_t)0x10400000)
#define | DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
#define | DMA2_GL7_FLAG ((uint32_t)0x11000000)
#define | DMA2_FDT7_FLAG ((uint32_t)0x12000000)
#define | DMA2_HDT7_FLAG ((uint32_t)0x14000000)
#define | DMA2_DTERR7_FLAG ((uint32_t)0x18000000)

Detailed Description

dma flag

Macro Definition Documentation

◆ DMA1_DTERR1_FLAG

#define DMA1_DTERR1_FLAG ((uint32_t)0x00000008)

dma1 channel1 error flag

Definition at line 82 of file at32f413_dma.h.

◆ DMA1_DTERR2_FLAG

#define DMA1_DTERR2_FLAG ((uint32_t)0x00000080)

dma1 channel2 error flag

Definition at line 86 of file at32f413_dma.h.

◆ DMA1_DTERR3_FLAG

#define DMA1_DTERR3_FLAG ((uint32_t)0x00000800)

dma1 channel3 error flag

Definition at line 90 of file at32f413_dma.h.

◆ DMA1_DTERR4_FLAG

#define DMA1_DTERR4_FLAG ((uint32_t)0x00008000)

dma1 channel4 error flag

Definition at line 94 of file at32f413_dma.h.

◆ DMA1_DTERR5_FLAG

#define DMA1_DTERR5_FLAG ((uint32_t)0x00080000)

dma1 channel5 error flag

Definition at line 98 of file at32f413_dma.h.

◆ DMA1_DTERR6_FLAG

#define DMA1_DTERR6_FLAG ((uint32_t)0x00800000)

dma1 channel6 error flag

Definition at line 102 of file at32f413_dma.h.

◆ DMA1_DTERR7_FLAG

#define DMA1_DTERR7_FLAG ((uint32_t)0x08000000)

dma1 channel7 error flag

Definition at line 106 of file at32f413_dma.h.

◆ DMA1_FDT1_FLAG

#define DMA1_FDT1_FLAG ((uint32_t)0x00000002)

dma1 channel1 full data transfer flag

Definition at line 80 of file at32f413_dma.h.

◆ DMA1_FDT2_FLAG

#define DMA1_FDT2_FLAG ((uint32_t)0x00000020)

dma1 channel2 full data transfer flag

Definition at line 84 of file at32f413_dma.h.

◆ DMA1_FDT3_FLAG

#define DMA1_FDT3_FLAG ((uint32_t)0x00000200)

dma1 channel3 full data transfer flag

Definition at line 88 of file at32f413_dma.h.

◆ DMA1_FDT4_FLAG

#define DMA1_FDT4_FLAG ((uint32_t)0x00002000)

dma1 channel4 full data transfer flag

Definition at line 92 of file at32f413_dma.h.

◆ DMA1_FDT5_FLAG

#define DMA1_FDT5_FLAG ((uint32_t)0x00020000)

dma1 channel5 full data transfer flag

Definition at line 96 of file at32f413_dma.h.

◆ DMA1_FDT6_FLAG

#define DMA1_FDT6_FLAG ((uint32_t)0x00200000)

dma1 channel6 full data transfer flag

Definition at line 100 of file at32f413_dma.h.

◆ DMA1_FDT7_FLAG

#define DMA1_FDT7_FLAG ((uint32_t)0x02000000)

dma1 channel7 full data transfer flag

Definition at line 104 of file at32f413_dma.h.

◆ DMA1_GL1_FLAG

#define DMA1_GL1_FLAG ((uint32_t)0x00000001)

dma1 channel1 global flag

Definition at line 79 of file at32f413_dma.h.

◆ DMA1_GL2_FLAG

#define DMA1_GL2_FLAG ((uint32_t)0x00000010)

dma1 channel2 global flag

Definition at line 83 of file at32f413_dma.h.

◆ DMA1_GL3_FLAG

#define DMA1_GL3_FLAG ((uint32_t)0x00000100)

dma1 channel3 global flag

Definition at line 87 of file at32f413_dma.h.

◆ DMA1_GL4_FLAG

#define DMA1_GL4_FLAG ((uint32_t)0x00001000)

dma1 channel4 global flag

Definition at line 91 of file at32f413_dma.h.

◆ DMA1_GL5_FLAG

#define DMA1_GL5_FLAG ((uint32_t)0x00010000)

dma1 channel5 global flag

Definition at line 95 of file at32f413_dma.h.

◆ DMA1_GL6_FLAG

#define DMA1_GL6_FLAG ((uint32_t)0x00100000)

dma1 channel6 global flag

Definition at line 99 of file at32f413_dma.h.

◆ DMA1_GL7_FLAG

#define DMA1_GL7_FLAG ((uint32_t)0x01000000)

dma1 channel7 global flag

Definition at line 103 of file at32f413_dma.h.

◆ DMA1_HDT1_FLAG

#define DMA1_HDT1_FLAG ((uint32_t)0x00000004)

dma1 channel1 half data transfer flag

Definition at line 81 of file at32f413_dma.h.

◆ DMA1_HDT2_FLAG

#define DMA1_HDT2_FLAG ((uint32_t)0x00000040)

dma1 channel2 half data transfer flag

Definition at line 85 of file at32f413_dma.h.

◆ DMA1_HDT3_FLAG

#define DMA1_HDT3_FLAG ((uint32_t)0x00000400)

dma1 channel3 half data transfer flag

Definition at line 89 of file at32f413_dma.h.

◆ DMA1_HDT4_FLAG

#define DMA1_HDT4_FLAG ((uint32_t)0x00004000)

dma1 channel4 half data transfer flag

Definition at line 93 of file at32f413_dma.h.

◆ DMA1_HDT5_FLAG

#define DMA1_HDT5_FLAG ((uint32_t)0x00040000)

dma1 channel5 half data transfer flag

Definition at line 97 of file at32f413_dma.h.

◆ DMA1_HDT6_FLAG

#define DMA1_HDT6_FLAG ((uint32_t)0x00400000)

dma1 channel6 half data transfer flag

Definition at line 101 of file at32f413_dma.h.

◆ DMA1_HDT7_FLAG

#define DMA1_HDT7_FLAG ((uint32_t)0x04000000)

dma1 channel7 half data transfer flag

Definition at line 105 of file at32f413_dma.h.

◆ DMA2_DTERR1_FLAG

#define DMA2_DTERR1_FLAG ((uint32_t)0x10000008)

dma2 channel1 error flag

Definition at line 111 of file at32f413_dma.h.

◆ DMA2_DTERR2_FLAG

#define DMA2_DTERR2_FLAG ((uint32_t)0x10000080)

dma2 channel2 error flag

Definition at line 115 of file at32f413_dma.h.

◆ DMA2_DTERR3_FLAG

#define DMA2_DTERR3_FLAG ((uint32_t)0x10000800)

dma2 channel3 error flag

Definition at line 119 of file at32f413_dma.h.

◆ DMA2_DTERR4_FLAG

#define DMA2_DTERR4_FLAG ((uint32_t)0x10008000)

dma2 channel4 error flag

Definition at line 123 of file at32f413_dma.h.

◆ DMA2_DTERR5_FLAG

#define DMA2_DTERR5_FLAG ((uint32_t)0x10080000)

dma2 channel5 error flag

Definition at line 127 of file at32f413_dma.h.

◆ DMA2_DTERR6_FLAG

#define DMA2_DTERR6_FLAG ((uint32_t)0x10800000)

dma2 channel6 error flag

Definition at line 131 of file at32f413_dma.h.

◆ DMA2_DTERR7_FLAG

#define DMA2_DTERR7_FLAG ((uint32_t)0x18000000)

dma2 channel7 error flag

Definition at line 135 of file at32f413_dma.h.

◆ DMA2_FDT1_FLAG

#define DMA2_FDT1_FLAG ((uint32_t)0x10000002)

dma2 channel1 full data transfer flag

Definition at line 109 of file at32f413_dma.h.

◆ DMA2_FDT2_FLAG

#define DMA2_FDT2_FLAG ((uint32_t)0x10000020)

dma2 channel2 full data transfer flag

Definition at line 113 of file at32f413_dma.h.

◆ DMA2_FDT3_FLAG

#define DMA2_FDT3_FLAG ((uint32_t)0x10000200)

dma2 channel3 full data transfer flag

Definition at line 117 of file at32f413_dma.h.

◆ DMA2_FDT4_FLAG

#define DMA2_FDT4_FLAG ((uint32_t)0x10002000)

dma2 channel4 full data transfer flag

Definition at line 121 of file at32f413_dma.h.

◆ DMA2_FDT5_FLAG

#define DMA2_FDT5_FLAG ((uint32_t)0x10020000)

dma2 channel5 full data transfer flag

Definition at line 125 of file at32f413_dma.h.

◆ DMA2_FDT6_FLAG

#define DMA2_FDT6_FLAG ((uint32_t)0x10200000)

dma2 channel6 full data transfer flag

Definition at line 129 of file at32f413_dma.h.

◆ DMA2_FDT7_FLAG

#define DMA2_FDT7_FLAG ((uint32_t)0x12000000)

dma2 channel7 full data transfer flag

Definition at line 133 of file at32f413_dma.h.

◆ DMA2_GL1_FLAG

#define DMA2_GL1_FLAG ((uint32_t)0x10000001)

dma2 channel1 global flag

Definition at line 108 of file at32f413_dma.h.

◆ DMA2_GL2_FLAG

#define DMA2_GL2_FLAG ((uint32_t)0x10000010)

dma2 channel2 global flag

Definition at line 112 of file at32f413_dma.h.

◆ DMA2_GL3_FLAG

#define DMA2_GL3_FLAG ((uint32_t)0x10000100)

dma2 channel3 global flag

Definition at line 116 of file at32f413_dma.h.

◆ DMA2_GL4_FLAG

#define DMA2_GL4_FLAG ((uint32_t)0x10001000)

dma2 channel4 global flag

Definition at line 120 of file at32f413_dma.h.

◆ DMA2_GL5_FLAG

#define DMA2_GL5_FLAG ((uint32_t)0x10010000)

dma2 channel5 global flag

Definition at line 124 of file at32f413_dma.h.

◆ DMA2_GL6_FLAG

#define DMA2_GL6_FLAG ((uint32_t)0x10100000)

dma2 channel6 global flag

Definition at line 128 of file at32f413_dma.h.

◆ DMA2_GL7_FLAG

#define DMA2_GL7_FLAG ((uint32_t)0x11000000)

dma2 channel7 global flag

Definition at line 132 of file at32f413_dma.h.

◆ DMA2_HDT1_FLAG

#define DMA2_HDT1_FLAG ((uint32_t)0x10000004)

dma2 channel1 half data transfer flag

Definition at line 110 of file at32f413_dma.h.

◆ DMA2_HDT2_FLAG

#define DMA2_HDT2_FLAG ((uint32_t)0x10000040)

dma2 channel2 half data transfer flag

Definition at line 114 of file at32f413_dma.h.

◆ DMA2_HDT3_FLAG

#define DMA2_HDT3_FLAG ((uint32_t)0x10000400)

dma2 channel3 half data transfer flag

Definition at line 118 of file at32f413_dma.h.

◆ DMA2_HDT4_FLAG

#define DMA2_HDT4_FLAG ((uint32_t)0x10004000)

dma2 channel4 half data transfer flag

Definition at line 122 of file at32f413_dma.h.

◆ DMA2_HDT5_FLAG

#define DMA2_HDT5_FLAG ((uint32_t)0x10040000)

dma2 channel5 half data transfer flag

Definition at line 126 of file at32f413_dma.h.

◆ DMA2_HDT6_FLAG

#define DMA2_HDT6_FLAG ((uint32_t)0x10400000)

dma2 channel6 half data transfer flag

Definition at line 130 of file at32f413_dma.h.

◆ DMA2_HDT7_FLAG

#define DMA2_HDT7_FLAG ((uint32_t)0x14000000)

dma2 channel7 half data transfer flag

Definition at line 134 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_exported_types

Data Structures | Enumerations
DMA_exported_types
AT32F413_periph_driver » DMA

Data Structures

struct | dma_init_type
dma init type More...
struct | dma_type
type define dma register More...
struct | dma_channel_type
type define dma channel register all More...

Enumerations

enum dma_flexible_request_type {
DMA_FLEXIBLE_ADC1 = 0x01 , DMA_FLEXIBLE_SPI1_RX = 0x09 , DMA_FLEXIBLE_SPI1_TX = 0x0A , DMA_FLEXIBLE_SPI2_RX = 0x0B ,
DMA_FLEXIBLE_SPI2_TX = 0x0C , DMA_FLEXIBLE_UART1_RX = 0x19 , DMA_FLEXIBLE_UART1_TX = 0x1A , DMA_FLEXIBLE_UART2_RX = 0x1B ,
DMA_FLEXIBLE_UART2_TX = 0x1C , DMA_FLEXIBLE_UART3_RX = 0x1D , DMA_FLEXIBLE_UART3_TX = 0x1E , DMA_FLEXIBLE_UART4_RX = 0x1F ,
DMA_FLEXIBLE_UART4_TX = 0x20 , DMA_FLEXIBLE_UART5_RX = 0x21 , DMA_FLEXIBLE_UART5_TX = 0x22 , DMA_FLEXIBLE_I2C1_RX = 0x29 ,
DMA_FLEXIBLE_I2C1_TX = 0x2A , DMA_FLEXIBLE_I2C2_RX = 0x2B , DMA_FLEXIBLE_I2C2_TX = 0x2C , DMA_FLEXIBLE_SDIO1 = 0x31 ,
DMA_FLEXIBLE_TMR1_TRIG = 0x35 , DMA_FLEXIBLE_TMR1_HALL = 0x36 , DMA_FLEXIBLE_TMR1_OVERFLOW = 0x37 , DMA_FLEXIBLE_TMR1_CH1 = 0x38 ,
DMA_FLEXIBLE_TMR1_CH2 = 0x39 , DMA_FLEXIBLE_TMR1_CH3 = 0x3A , DMA_FLEXIBLE_TMR1_CH4 = 0x3B , DMA_FLEXIBLE_TMR2_TRIG = 0x3D ,
DMA_FLEXIBLE_TMR2_OVERFLOW = 0x3F , DMA_FLEXIBLE_TMR2_CH1 = 0x40 , DMA_FLEXIBLE_TMR2_CH2 = 0x41 , DMA_FLEXIBLE_TMR2_CH3 = 0x42 ,
DMA_FLEXIBLE_TMR2_CH4 = 0x43 , DMA_FLEXIBLE_TMR3_TRIG = 0x45 , DMA_FLEXIBLE_TMR3_OVERFLOW = 0x47 , DMA_FLEXIBLE_TMR3_CH1 = 0x48 ,
DMA_FLEXIBLE_TMR3_CH2 = 0x49 , DMA_FLEXIBLE_TMR3_CH3 = 0x4A , DMA_FLEXIBLE_TMR3_CH4 = 0x4B , DMA_FLEXIBLE_TMR4_TRIG = 0x4D ,
DMA_FLEXIBLE_TMR4_OVERFLOW = 0x4F , DMA_FLEXIBLE_TMR4_CH1 = 0x50 , DMA_FLEXIBLE_TMR4_CH2 = 0x51 , DMA_FLEXIBLE_TMR4_CH3 = 0x52 ,
DMA_FLEXIBLE_TMR4_CH4 = 0x53 , DMA_FLEXIBLE_TMR5_TRIG = 0x55 , DMA_FLEXIBLE_TMR5_OVERFLOW = 0x57 , DMA_FLEXIBLE_TMR5_CH1 = 0x58 ,
DMA_FLEXIBLE_TMR5_CH2 = 0x59 , DMA_FLEXIBLE_TMR5_CH3 = 0x5A , DMA_FLEXIBLE_TMR5_CH4 = 0x5B , DMA_FLEXIBLE_TMR8_TRIG = 0x6D ,
DMA_FLEXIBLE_TMR8_HALL = 0x6E , DMA_FLEXIBLE_TMR8_OVERFLOW = 0x6F , DMA_FLEXIBLE_TMR8_CH1 = 0x70 , DMA_FLEXIBLE_TMR8_CH2 = 0x71 ,
DMA_FLEXIBLE_TMR8_CH3 = 0x72 , DMA_FLEXIBLE_TMR8_CH4 = 0x73
}
dma flexible request type More...
enum | dma_dir_type { DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000 , DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010 , DMA_DIR_MEMORY_TO_MEMORY = 0x4000 }
dma direction type More...
enum | dma_peripheral_inc_type { DMA_PERIPHERAL_INC_DISABLE = 0x00 , DMA_PERIPHERAL_INC_ENABLE = 0x01 }
dma peripheral incremented type More...
enum | dma_memory_inc_type { DMA_MEMORY_INC_DISABLE = 0x00 , DMA_MEMORY_INC_ENABLE = 0x01 }
dma memory incremented type More...
enum | dma_peripheral_data_size_type { DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
dma peripheral data size type More...
enum | dma_memory_data_size_type { DMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , DMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
dma memory data size type More...
enum | dma_priority_level_type { DMA_PRIORITY_LOW = 0x00 , DMA_PRIORITY_MEDIUM = 0x01 , DMA_PRIORITY_HIGH = 0x02 , DMA_PRIORITY_VERY_HIGH = 0x03 }
dma priority level type More...

Detailed Description

Enumeration Type Documentation

◆ dma_dir_type

enum dma_dir_type

dma direction type

Enumerator
DMA_DIR_PERIPHERAL_TO_MEMORY | dma data transfer direction:peripheral to memory
DMA_DIR_MEMORY_TO_PERIPHERAL | dma data transfer direction:memory to peripheral
DMA_DIR_MEMORY_TO_MEMORY | dma data transfer direction:memory to memory

Definition at line 213 of file at32f413_dma.h.

◆ dma_flexible_request_type

enum dma_flexible_request_type

dma flexible request type

Enumerator
DMA_FLEXIBLE_ADC1 | adc1 flexible request id
DMA_FLEXIBLE_SPI1_RX | spi1_rx flexible request id
DMA_FLEXIBLE_SPI1_TX | spi1_tx flexible request id
DMA_FLEXIBLE_SPI2_RX | spi2_rx flexible request id
DMA_FLEXIBLE_SPI2_TX | spi2_tx flexible request id
DMA_FLEXIBLE_UART1_RX | uart1_rx flexible request id
DMA_FLEXIBLE_UART1_TX | uart1_tx flexible request id
DMA_FLEXIBLE_UART2_RX | uart2_rx flexible request id
DMA_FLEXIBLE_UART2_TX | uart2_tx flexible request id
DMA_FLEXIBLE_UART3_RX | uart3_rx flexible request id
DMA_FLEXIBLE_UART3_TX | uart3_tx flexible request id
DMA_FLEXIBLE_UART4_RX | uart4_rx flexible request id
DMA_FLEXIBLE_UART4_TX | uart4_tx flexible request id
DMA_FLEXIBLE_UART5_RX | uart5_rx flexible request id
DMA_FLEXIBLE_UART5_TX | uart5_tx flexible request id
DMA_FLEXIBLE_I2C1_RX | i2c1_rx flexible request id
DMA_FLEXIBLE_I2C1_TX | i2c1_tx flexible request id
DMA_FLEXIBLE_I2C2_RX | i2c2_rx flexible request id
DMA_FLEXIBLE_I2C2_TX | i2c2_tx flexible request id
DMA_FLEXIBLE_SDIO1 | sdio1 flexible request id
DMA_FLEXIBLE_TMR1_TRIG | tmr1_trig flexible request id
DMA_FLEXIBLE_TMR1_HALL | tmr1_hall flexible request id
DMA_FLEXIBLE_TMR1_OVERFLOW | tmr1_overflow flexible request id
DMA_FLEXIBLE_TMR1_CH1 | tmr1_ch1 flexible request id
DMA_FLEXIBLE_TMR1_CH2 | tmr1_ch2 flexible request id
DMA_FLEXIBLE_TMR1_CH3 | tmr1_ch3 flexible request id
DMA_FLEXIBLE_TMR1_CH4 | tmr1_ch4 flexible request id
DMA_FLEXIBLE_TMR2_TRIG | tmr2_trig flexible request id
DMA_FLEXIBLE_TMR2_OVERFLOW | tmr2_overflow flexible request id
DMA_FLEXIBLE_TMR2_CH1 | tmr2_ch1 flexible request id
DMA_FLEXIBLE_TMR2_CH2 | tmr2_ch2 flexible request id
DMA_FLEXIBLE_TMR2_CH3 | tmr2_ch3 flexible request id
DMA_FLEXIBLE_TMR2_CH4 | tmr2_ch4 flexible request id
DMA_FLEXIBLE_TMR3_TRIG | tmr3_trig flexible request id
DMA_FLEXIBLE_TMR3_OVERFLOW | tmr3_overflow flexible request id
DMA_FLEXIBLE_TMR3_CH1 | tmr3_ch1 flexible request id
DMA_FLEXIBLE_TMR3_CH2 | tmr3_ch2 flexible request id
DMA_FLEXIBLE_TMR3_CH3 | tmr3_ch3 flexible request id
DMA_FLEXIBLE_TMR3_CH4 | tmr3_ch4 flexible request id
DMA_FLEXIBLE_TMR4_TRIG | tmr4_trig flexible request id
DMA_FLEXIBLE_TMR4_OVERFLOW | tmr4_overflow flexible request id
DMA_FLEXIBLE_TMR4_CH1 | tmr4_ch1 flexible request id
DMA_FLEXIBLE_TMR4_CH2 | tmr4_ch2 flexible request id
DMA_FLEXIBLE_TMR4_CH3 | tmr4_ch3 flexible request id
DMA_FLEXIBLE_TMR4_CH4 | tmr4_ch4 flexible request id
DMA_FLEXIBLE_TMR5_TRIG | tmr5_trig flexible request id
DMA_FLEXIBLE_TMR5_OVERFLOW | tmr5_overflow flexible request id
DMA_FLEXIBLE_TMR5_CH1 | tmr5_ch1 flexible request id
DMA_FLEXIBLE_TMR5_CH2 | tmr5_ch2 flexible request id
DMA_FLEXIBLE_TMR5_CH3 | tmr5_ch3 flexible request id
DMA_FLEXIBLE_TMR5_CH4 | tmr5_ch4 flexible request id
DMA_FLEXIBLE_TMR8_TRIG | tmr8_trig flexible request id
DMA_FLEXIBLE_TMR8_HALL | tmr8_hall flexible request id
DMA_FLEXIBLE_TMR8_OVERFLOW | tmr8_overflow flexible request id
DMA_FLEXIBLE_TMR8_CH1 | tmr8_ch1 flexible request id
DMA_FLEXIBLE_TMR8_CH2 | tmr8_ch2 flexible request id
DMA_FLEXIBLE_TMR8_CH3 | tmr8_ch3 flexible request id
DMA_FLEXIBLE_TMR8_CH4 | tmr8_ch4 flexible request id

Definition at line 148 of file at32f413_dma.h.

◆ dma_memory_data_size_type

enum dma_memory_data_size_type

dma memory data size type

Enumerator
DMA_MEMORY_DATA_WIDTH_BYTE | dma memory databus width 8bit
DMA_MEMORY_DATA_WIDTH_HALFWORD | dma memory databus width 16bit
DMA_MEMORY_DATA_WIDTH_WORD | dma memory databus width 32bit

Definition at line 251 of file at32f413_dma.h.

◆ dma_memory_inc_type

enum dma_memory_inc_type

dma memory incremented type

Enumerator
DMA_MEMORY_INC_DISABLE | dma memory increment mode disable
DMA_MEMORY_INC_ENABLE | dma memory increment mode enable

Definition at line 232 of file at32f413_dma.h.

◆ dma_peripheral_data_size_type

enum dma_peripheral_data_size_type

dma peripheral data size type

Enumerator
DMA_PERIPHERAL_DATA_WIDTH_BYTE | dma peripheral databus width 8bit
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD | dma peripheral databus width 16bit
DMA_PERIPHERAL_DATA_WIDTH_WORD | dma peripheral databus width 32bit

Definition at line 241 of file at32f413_dma.h.

◆ dma_peripheral_inc_type

enum dma_peripheral_inc_type

dma peripheral incremented type

Enumerator
DMA_PERIPHERAL_INC_DISABLE | dma peripheral increment mode disable
DMA_PERIPHERAL_INC_ENABLE | dma peripheral increment mode enable

Definition at line 223 of file at32f413_dma.h.

◆ dma_priority_level_type

enum dma_priority_level_type

dma priority level type

Enumerator
DMA_PRIORITY_LOW | dma channel priority: low
DMA_PRIORITY_MEDIUM | dma channel priority: mediue
DMA_PRIORITY_HIGH | dma channel priority: high
DMA_PRIORITY_VERY_HIGH | dma channel priority: very high

Definition at line 261 of file at32f413_dma.h.


AT32F413 Firmwary Library: dma_init_type Struct Reference

Data Fields
dma_init_type Struct Reference
AT32F413_periph_driver » DMA » DMA_exported_types

dma init type More...

#include <at32f413_dma.h>

Data Fields

uint32_t | peripheral_base_addr
uint32_t | memory_base_addr
dma_dir_type direction
uint16_t | buffer_size
confirm_state peripheral_inc_enable
confirm_state memory_inc_enable
dma_peripheral_data_size_type peripheral_data_width
dma_memory_data_size_type memory_data_width
confirm_state loop_mode_enable
dma_priority_level_type priority

Detailed Description

dma init type

Definition at line 272 of file at32f413_dma.h.

Field Documentation

◆ buffer_size

uint16_t dma_init_type::buffer_size

counter to transfer

Definition at line 277 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ direction

dma_dir_type dma_init_type::direction

dma transmit direction, peripheral as source or as destnation

Definition at line 276 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ loop_mode_enable

confirm_state dma_init_type::loop_mode_enable

when circular mode enable, buffer size will reload if count to 0

Definition at line 282 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ memory_base_addr

uint32_t dma_init_type::memory_base_addr

base addrress for memory

Definition at line 275 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ memory_data_width

dma_memory_data_size_type dma_init_type::memory_data_width

memory data width for transmit

Definition at line 281 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ memory_inc_enable

confirm_state dma_init_type::memory_inc_enable

memory address increment after one transmit

Definition at line 279 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ peripheral_base_addr

uint32_t dma_init_type::peripheral_base_addr

base addrress for peripheral

Definition at line 274 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ peripheral_data_width

dma_peripheral_data_size_type dma_init_type::peripheral_data_width

peripheral data width for transmit

Definition at line 280 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ peripheral_inc_enable

confirm_state dma_init_type::peripheral_inc_enable

periphera address increment after one transmit

Definition at line 278 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ priority

dma_priority_level_type dma_init_type::priority

dma priority can choose from very high, high, dedium or low

Definition at line 283 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

The documentation for this struct was generated from the following file:
  • at32f413_dma.h


AT32F413 Firmwary Library: dma_type Struct Reference

Data Fields
dma_type Struct Reference
AT32F413_periph_driver » DMA » DMA_exported_types

type define dma register More...

#include <at32f413_dma.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t gf1: 1
__IO uint32_t fdtf1: 1
__IO uint32_t hdtf1: 1
__IO uint32_t dterrf1: 1
__IO uint32_t gf2: 1
__IO uint32_t fdtf2: 1
__IO uint32_t hdtf2: 1
__IO uint32_t dterrf2: 1
__IO uint32_t gf3: 1
__IO uint32_t fdtf3: 1
__IO uint32_t hdtf3: 1
__IO uint32_t dterrf3: 1
__IO uint32_t gf4: 1
__IO uint32_t fdtf4: 1
__IO uint32_t hdtf4: 1
__IO uint32_t dterrf4: 1
__IO uint32_t gf5: 1
__IO uint32_t fdtf5: 1
__IO uint32_t hdtf5: 1
__IO uint32_t dterrf5: 1
__IO uint32_t gf6: 1
__IO uint32_t fdtf6: 1
__IO uint32_t hdtf6: 1
__IO uint32_t dterrf6: 1
__IO uint32_t gf7: 1
__IO uint32_t fdtf7: 1
__IO uint32_t hdtf7: 1
__IO uint32_t dterrf7: 1
__IO uint32_t reserved1: 4
} sts_bit
};
dma sts register, offset:0x00 More...
union {
__IO uint32_t clr
struct {
__IO uint32_t gfc1: 1
__IO uint32_t fdtfc1: 1
__IO uint32_t hdtfc1: 1
__IO uint32_t dterrfc1: 1
__IO uint32_t gfc2: 1
__IO uint32_t fdtfc2: 1
__IO uint32_t hdtfc2: 1
__IO uint32_t dterrfc2: 1
__IO uint32_t gfc3: 1
__IO uint32_t fdtfc3: 1
__IO uint32_t hdtfc3: 1
__IO uint32_t dterrfc3: 1
__IO uint32_t gfc4: 1
__IO uint32_t fdtfc4: 1
__IO uint32_t hdtfc4: 1
__IO uint32_t dterrfc4: 1
__IO uint32_t gfc5: 1
__IO uint32_t fdtfc5: 1
__IO uint32_t hdtfc5: 1
__IO uint32_t dterrfc5: 1
__IO uint32_t gfc6: 1
__IO uint32_t fdtfc6: 1
__IO uint32_t hdtfc6: 1
__IO uint32_t dterrfc6: 1
__IO uint32_t gfc7: 1
__IO uint32_t fdtfc7: 1
__IO uint32_t hdtfc7: 1
__IO uint32_t dterrfc7: 1
__IO uint32_t reserved1: 4
} clr_bit
};
dma clr register, offset:0x04 More...
union {
__IO uint32_t src_sel0
struct {
__IO uint32_t ch1_src: 8
__IO uint32_t ch2_src: 8
__IO uint32_t ch3_src: 8
__IO uint32_t ch4_src: 8
} src_sel0_bit
};
dma src_sel0 register, offset:0xA0 More...
union {
__IO uint32_t src_sel1
struct {
__IO uint32_t ch5_src: 8
__IO uint32_t ch6_src: 8
__IO uint32_t ch7_src: 8
__IO uint32_t dma_flex_en: 1
__IO uint32_t reserved1: 7
} src_sel1_bit
};
dma src_sel1 register, offset:0xA4 More...

Detailed Description

type define dma register

Definition at line 289 of file at32f413_dma.h.

Field Documentation

◆

union { ... } dma_type::@340

dma sts register, offset:0x00

◆

union { ... } dma_type::@342

dma clr register, offset:0x04

◆

union { ... } dma_type::@344

dma src_sel0 register, offset:0xA0

◆

union { ... } dma_type::@346

dma src_sel1 register, offset:0xA4

◆ ch1_src

__IO uint32_t dma_type::ch1_src

Definition at line 382 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch2_src

__IO uint32_t dma_type::ch2_src

Definition at line 383 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch3_src

__IO uint32_t dma_type::ch3_src

Definition at line 384 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch4_src

__IO uint32_t dma_type::ch4_src

Definition at line 385 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch5_src

__IO uint32_t dma_type::ch5_src

Definition at line 397 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch6_src

__IO uint32_t dma_type::ch6_src

Definition at line 398 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch7_src

__IO uint32_t dma_type::ch7_src

Definition at line 399 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ clr

__IO uint32_t dma_type::clr

Definition at line 336 of file at32f413_dma.h.

◆

struct { ... } dma_type::clr_bit

◆ dma_flex_en

__IO uint32_t dma_type::dma_flex_en

Definition at line 400 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ dterrf1

__IO uint32_t dma_type::dterrf1

Definition at line 302 of file at32f413_dma.h.

◆ dterrf2

__IO uint32_t dma_type::dterrf2

Definition at line 306 of file at32f413_dma.h.

◆ dterrf3

__IO uint32_t dma_type::dterrf3

Definition at line 310 of file at32f413_dma.h.

◆ dterrf4

__IO uint32_t dma_type::dterrf4

Definition at line 314 of file at32f413_dma.h.

◆ dterrf5

__IO uint32_t dma_type::dterrf5

Definition at line 318 of file at32f413_dma.h.

◆ dterrf6

__IO uint32_t dma_type::dterrf6

Definition at line 322 of file at32f413_dma.h.

◆ dterrf7

__IO uint32_t dma_type::dterrf7

Definition at line 326 of file at32f413_dma.h.

◆ dterrfc1

__IO uint32_t dma_type::dterrfc1

Definition at line 342 of file at32f413_dma.h.

◆ dterrfc2

__IO uint32_t dma_type::dterrfc2

Definition at line 346 of file at32f413_dma.h.

◆ dterrfc3

__IO uint32_t dma_type::dterrfc3

Definition at line 350 of file at32f413_dma.h.

◆ dterrfc4

__IO uint32_t dma_type::dterrfc4

Definition at line 354 of file at32f413_dma.h.

◆ dterrfc5

__IO uint32_t dma_type::dterrfc5

Definition at line 358 of file at32f413_dma.h.

◆ dterrfc6

__IO uint32_t dma_type::dterrfc6

Definition at line 362 of file at32f413_dma.h.

◆ dterrfc7

__IO uint32_t dma_type::dterrfc7

Definition at line 366 of file at32f413_dma.h.

◆ fdtf1

__IO uint32_t dma_type::fdtf1

Definition at line 300 of file at32f413_dma.h.

◆ fdtf2

__IO uint32_t dma_type::fdtf2

Definition at line 304 of file at32f413_dma.h.

◆ fdtf3

__IO uint32_t dma_type::fdtf3

Definition at line 308 of file at32f413_dma.h.

◆ fdtf4

__IO uint32_t dma_type::fdtf4

Definition at line 312 of file at32f413_dma.h.

◆ fdtf5

__IO uint32_t dma_type::fdtf5

Definition at line 316 of file at32f413_dma.h.

◆ fdtf6

__IO uint32_t dma_type::fdtf6

Definition at line 320 of file at32f413_dma.h.

◆ fdtf7

__IO uint32_t dma_type::fdtf7

Definition at line 324 of file at32f413_dma.h.

◆ fdtfc1

__IO uint32_t dma_type::fdtfc1

Definition at line 340 of file at32f413_dma.h.

◆ fdtfc2

__IO uint32_t dma_type::fdtfc2

Definition at line 344 of file at32f413_dma.h.

◆ fdtfc3

__IO uint32_t dma_type::fdtfc3

Definition at line 348 of file at32f413_dma.h.

◆ fdtfc4

__IO uint32_t dma_type::fdtfc4

Definition at line 352 of file at32f413_dma.h.

◆ fdtfc5

__IO uint32_t dma_type::fdtfc5

Definition at line 356 of file at32f413_dma.h.

◆ fdtfc6

__IO uint32_t dma_type::fdtfc6

Definition at line 360 of file at32f413_dma.h.

◆ fdtfc7

__IO uint32_t dma_type::fdtfc7

Definition at line 364 of file at32f413_dma.h.

◆ gf1

__IO uint32_t dma_type::gf1

Definition at line 299 of file at32f413_dma.h.

◆ gf2

__IO uint32_t dma_type::gf2

Definition at line 303 of file at32f413_dma.h.

◆ gf3

__IO uint32_t dma_type::gf3

Definition at line 307 of file at32f413_dma.h.

◆ gf4

__IO uint32_t dma_type::gf4

Definition at line 311 of file at32f413_dma.h.

◆ gf5

__IO uint32_t dma_type::gf5

Definition at line 315 of file at32f413_dma.h.

◆ gf6

__IO uint32_t dma_type::gf6

Definition at line 319 of file at32f413_dma.h.

◆ gf7

__IO uint32_t dma_type::gf7

Definition at line 323 of file at32f413_dma.h.

◆ gfc1

__IO uint32_t dma_type::gfc1

Definition at line 339 of file at32f413_dma.h.

◆ gfc2

__IO uint32_t dma_type::gfc2

Definition at line 343 of file at32f413_dma.h.

◆ gfc3

__IO uint32_t dma_type::gfc3

Definition at line 347 of file at32f413_dma.h.

◆ gfc4

__IO uint32_t dma_type::gfc4

Definition at line 351 of file at32f413_dma.h.

◆ gfc5

__IO uint32_t dma_type::gfc5

Definition at line 355 of file at32f413_dma.h.

◆ gfc6

__IO uint32_t dma_type::gfc6

Definition at line 359 of file at32f413_dma.h.

◆ gfc7

__IO uint32_t dma_type::gfc7

Definition at line 363 of file at32f413_dma.h.

◆ hdtf1

__IO uint32_t dma_type::hdtf1

Definition at line 301 of file at32f413_dma.h.

◆ hdtf2

__IO uint32_t dma_type::hdtf2

Definition at line 305 of file at32f413_dma.h.

◆ hdtf3

__IO uint32_t dma_type::hdtf3

Definition at line 309 of file at32f413_dma.h.

◆ hdtf4

__IO uint32_t dma_type::hdtf4

Definition at line 313 of file at32f413_dma.h.

◆ hdtf5

__IO uint32_t dma_type::hdtf5

Definition at line 317 of file at32f413_dma.h.

◆ hdtf6

__IO uint32_t dma_type::hdtf6

Definition at line 321 of file at32f413_dma.h.

◆ hdtf7

__IO uint32_t dma_type::hdtf7

Definition at line 325 of file at32f413_dma.h.

◆ hdtfc1

__IO uint32_t dma_type::hdtfc1

Definition at line 341 of file at32f413_dma.h.

◆ hdtfc2

__IO uint32_t dma_type::hdtfc2

Definition at line 345 of file at32f413_dma.h.

◆ hdtfc3

__IO uint32_t dma_type::hdtfc3

Definition at line 349 of file at32f413_dma.h.

◆ hdtfc4

__IO uint32_t dma_type::hdtfc4

Definition at line 353 of file at32f413_dma.h.

◆ hdtfc5

__IO uint32_t dma_type::hdtfc5

Definition at line 357 of file at32f413_dma.h.

◆ hdtfc6

__IO uint32_t dma_type::hdtfc6

Definition at line 361 of file at32f413_dma.h.

◆ hdtfc7

__IO uint32_t dma_type::hdtfc7

Definition at line 365 of file at32f413_dma.h.

◆ reserved1

__IO uint32_t dma_type::reserved1

reserved, offset:0x08~0x9C

Definition at line 327 of file at32f413_dma.h.

◆ src_sel0

__IO uint32_t dma_type::src_sel0

Definition at line 379 of file at32f413_dma.h.

◆

struct { ... } dma_type::src_sel0_bit

Referenced by dma_flexible_config().

◆ src_sel1

__IO uint32_t dma_type::src_sel1

Definition at line 394 of file at32f413_dma.h.

◆

struct { ... } dma_type::src_sel1_bit

Referenced by dma_flexible_config().

◆ sts

__IO uint32_t dma_type::sts

Definition at line 296 of file at32f413_dma.h.

◆

struct { ... } dma_type::sts_bit
The documentation for this struct was generated from the following file:
  • at32f413_dma.h


AT32F413 Firmwary Library: dma_channel_type Struct Reference

Data Fields
dma_channel_type Struct Reference
AT32F413_periph_driver » DMA » DMA_exported_types

type define dma channel register all More...

#include <at32f413_dma.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t chen: 1
__IO uint32_t fdtien: 1
__IO uint32_t hdtien: 1
__IO uint32_t dterrien: 1
__IO uint32_t dtd: 1
__IO uint32_t lm: 1
__IO uint32_t pincm: 1
__IO uint32_t mincm: 1
__IO uint32_t pwidth: 2
__IO uint32_t mwidth: 2
__IO uint32_t chpl: 2
__IO uint32_t m2m: 1
__IO uint32_t reserved1: 17
} ctrl_bit
};
dma ctrl register, offset:0x08+20*(x-1) x=1...7 More...
union {
__IO uint32_t dtcnt
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} dtcnt_bit
};
dma dtcnt register, offset:0x0C+20*(x-1) x=1...7 More...
union {
__IO uint32_t paddr
struct {
__IO uint32_t paddr: 32
} paddr_bit
};
dma cpba register, offset:0x10+20*(x-1) x=1...7 More...
union {
__IO uint32_t maddr
struct {
__IO uint32_t maddr: 32
} maddr_bit
};
dma cmba register, offset:0x14+20*(x-1) x=1...7 More...

Detailed Description

type define dma channel register all

Definition at line 409 of file at32f413_dma.h.

Field Documentation

◆

union { ... } dma_channel_type::@352

dma ctrl register, offset:0x08+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@354

dma dtcnt register, offset:0x0C+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@356

dma cpba register, offset:0x10+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@358

dma cmba register, offset:0x14+20*(x-1) x=1...7

◆ chen

__IO uint32_t dma_channel_type::chen

Definition at line 419 of file at32f413_dma.h.

Referenced by dma_channel_enable(), and dma_reset().

◆ chpl

__IO uint32_t dma_channel_type::chpl

Definition at line 429 of file at32f413_dma.h.

Referenced by dma_init().

◆ cnt

__IO uint32_t dma_channel_type::cnt

Definition at line 443 of file at32f413_dma.h.

◆ ctrl

__IO uint32_t dma_channel_type::ctrl

Definition at line 416 of file at32f413_dma.h.

Referenced by dma_init(), dma_interrupt_enable(), and dma_reset().

◆

struct { ... } dma_channel_type::ctrl_bit

Referenced by dma_channel_enable(), dma_init(), and dma_reset().

◆ dtcnt

__IO uint32_t dma_channel_type::dtcnt

Definition at line 440 of file at32f413_dma.h.

Referenced by dma_data_number_get(), dma_data_number_set(), dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::dtcnt_bit

◆ dtd

__IO uint32_t dma_channel_type::dtd

Definition at line 423 of file at32f413_dma.h.

◆ dterrien

__IO uint32_t dma_channel_type::dterrien

Definition at line 422 of file at32f413_dma.h.

◆ fdtien

__IO uint32_t dma_channel_type::fdtien

Definition at line 420 of file at32f413_dma.h.

◆ hdtien

__IO uint32_t dma_channel_type::hdtien

Definition at line 421 of file at32f413_dma.h.

◆ lm

__IO uint32_t dma_channel_type::lm

Definition at line 424 of file at32f413_dma.h.

Referenced by dma_init().

◆ m2m

__IO uint32_t dma_channel_type::m2m

Definition at line 430 of file at32f413_dma.h.

◆ maddr

__IO uint32_t dma_channel_type::maddr

Definition at line 465 of file at32f413_dma.h.

Referenced by dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::maddr_bit

◆ mincm

__IO uint32_t dma_channel_type::mincm

Definition at line 426 of file at32f413_dma.h.

Referenced by dma_init().

◆ mwidth

__IO uint32_t dma_channel_type::mwidth

Definition at line 428 of file at32f413_dma.h.

Referenced by dma_init().

◆ paddr

__IO uint32_t dma_channel_type::paddr

Definition at line 453 of file at32f413_dma.h.

Referenced by dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::paddr_bit

◆ pincm

__IO uint32_t dma_channel_type::pincm

Definition at line 425 of file at32f413_dma.h.

Referenced by dma_init().

◆ pwidth

__IO uint32_t dma_channel_type::pwidth

Definition at line 427 of file at32f413_dma.h.

Referenced by dma_init().

◆ reserved1

__IO uint32_t dma_channel_type::reserved1

Definition at line 431 of file at32f413_dma.h.

The documentation for this struct was generated from the following file:
  • at32f413_dma.h


AT32F413 Firmwary Library: DMA_exported_functions

Functions
DMA_exported_functions
AT32F413_periph_driver » DMA

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...

Detailed Description

Function Documentation

◆ dma_channel_enable()

void dma_channel_enable | ( | dma_channel_type * | dmax_channely,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma channely

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
new_state (TRUE or FALSE)
Return values
None

Definition at line 196 of file at32f413_dma.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), dma_config(), dma_configuration(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), and spi_bytes_write().

◆ dma_data_number_get()

uint16_t dma_data_number_get ( dma_channel_type * dmax_channely )

get number of data from dtcnt register

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
the number of data.

Definition at line 132 of file at32f413_dma.c.

◆ dma_data_number_set()

void dma_data_number_set | ( | dma_channel_type * | dmax_channely,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
data_number the number of data to be transferred(0x0000~0xFFFF) transfer.
Return values
none.

Definition at line 107 of file at32f413_dma.c.

◆ dma_default_para_init()

void dma_default_para_init ( dma_init_type * dma_init_struct )

dma init config with its default value.

Parameters
dma_init_struct : pointer to a dma_init_type structure which will be initialized.
Return values
none

Definition at line 360 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_flag_clear()

void dma_flag_clear ( uint32_t dmax_flag )

clear dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
none

Definition at line 342 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flag_get()

flag_status dma_flag_get ( uint32_t dmax_flag )

get dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
state of dma flag

Definition at line 296 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flexible_config()

void dma_flexible_config | ( | dma_type * | dma_x,
 |  | uint8_t | flex_channelx,
 |  | dma_flexible_request_type | flexible_request
 | ) |  |

initialize the dma_x flexible function according to the specified parameters.

Parameters
dma_x this parameter can be one of the following values:
  • DMA1
  • DMA2
flex_channelx this parameter can be one of the following values:
  • FLEX_CHANNEL1
  • FLEX_CHANNEL2
  • FLEX_CHANNEL3
  • FLEX_CHANNEL4
  • FLEX_CHANNEL5
  • FLEX_CHANNEL6
  • FLEX_CHANNEL7
flexible_request every peripheral have specified hardware_id. this parameter can be one of the following values:
  • DMA_FLEXIBLE_ADC1 - DMA_FLEXIBLE_SPI1_RX - DMA_FLEXIBLE_SPI1_TX - DMA_FLEXIBLE_SPI2_RX
  • DMA_FLEXIBLE_SPI2_TX - DMA_FLEXIBLE_UART1_RX - DMA_FLEXIBLE_UART1_TX - DMA_FLEXIBLE_UART2_RX
  • DMA_FLEXIBLE_UART2_TX - DMA_FLEXIBLE_UART3_RX - DMA_FLEXIBLE_UART3_TX - DMA_FLEXIBLE_UART4_RX
  • DMA_FLEXIBLE_UART4_TX - DMA_FLEXIBLE_UART5_RX - DMA_FLEXIBLE_UART5_TX - DMA_FLEXIBLE_I2C1_RX
  • DMA_FLEXIBLE_I2C1_TX - DMA_FLEXIBLE_I2C2_RX - DMA_FLEXIBLE_I2C2_TX - DMA_FLEXIBLE_SDIO1
  • DMA_FLEXIBLE_TMR1_TRIG - DMA_FLEXIBLE_TMR1_HALL - DMA_FLEXIBLE_TMR1_OVERFLOW- DMA_FLEXIBLE_TMR1_CH1
  • DMA_FLEXIBLE_TMR1_CH2 - DMA_FLEXIBLE_TMR1_CH3 - DMA_FLEXIBLE_TMR1_CH4 - DMA_FLEXIBLE_TMR2_TRIG
  • DMA_FLEXIBLE_TMR2_OVERFLOW- DMA_FLEXIBLE_TMR2_CH1 - DMA_FLEXIBLE_TMR2_CH2 - DMA_FLEXIBLE_TMR2_CH3
  • DMA_FLEXIBLE_TMR2_CH4 - DMA_FLEXIBLE_TMR3_TRIG - DMA_FLEXIBLE_TMR3_OVERFLOW- DMA_FLEXIBLE_TMR3_CH1
  • DMA_FLEXIBLE_TMR3_CH2 - DMA_FLEXIBLE_TMR3_CH3 - DMA_FLEXIBLE_TMR3_CH4 - DMA_FLEXIBLE_TMR4_TRIG
  • DMA_FLEXIBLE_TMR4_OVERFLOW- DMA_FLEXIBLE_TMR4_CH1 - DMA_FLEXIBLE_TMR4_CH2 - DMA_FLEXIBLE_TMR4_CH3
  • DMA_FLEXIBLE_TMR4_CH4 - DMA_FLEXIBLE_TMR5_TRIG - DMA_FLEXIBLE_TMR5_OVERFLOW- DMA_FLEXIBLE_TMR5_CH1
  • DMA_FLEXIBLE_TMR5_CH2 - DMA_FLEXIBLE_TMR5_CH3 - DMA_FLEXIBLE_TMR5_CH4 - DMA_FLEXIBLE_TMR8_TRIG
  • DMA_FLEXIBLE_TMR8_HALL - DMA_FLEXIBLE_TMR8_OVERFLOW- DMA_FLEXIBLE_TMR8_CH1 - DMA_FLEXIBLE_TMR8_CH2
  • DMA_FLEXIBLE_TMR8_CH3 - DMA_FLEXIBLE_TMR8_CH4
Return values
none

< dma flexible channel1

< dma flexible channel2

< dma flexible channel3

< dma flexible channel4

< dma flexible channel5

< dma flexible channel6

< dma flexible channel7

Definition at line 236 of file at32f413_dma.c.

Referenced by dma_configuration(), and main().

◆ dma_init()

void dma_init | ( | dma_channel_type * | dmax_channely,
 |  | dma_init_type * | dma_init_struct
 | ) |  |

dma init

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_initstruct : pointer to a dma_init_type structure.
Return values
none

Definition at line 395 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_interrupt_enable()

void dma_interrupt_enable | ( | dma_channel_type * | dmax_channely,
 |  | uint32_t | dma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma interrupt

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_int this parameter can be any combination of the following values:
  • DMA_FDT_INT
  • DMA_HDT_INT
  • DMA_DTERR_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 163 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), and main().

◆ dma_reset()

void dma_reset ( dma_channel_type * dmax_channely )

reset the dmax channely registers.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
none

Definition at line 62 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().


AT32F413 Firmwary Library: DMA_private_functions

Functions
DMA_private_functions
AT32F413_periph_driver » DMA

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...

Detailed Description

Function Documentation

◆ dma_channel_enable()

void dma_channel_enable | ( | dma_channel_type * | dmax_channely,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma channely

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
new_state (TRUE or FALSE)
Return values
None

Definition at line 196 of file at32f413_dma.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), dma_config(), dma_configuration(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), and spi_bytes_write().

◆ dma_data_number_get()

uint16_t dma_data_number_get ( dma_channel_type * dmax_channely )

get number of data from dtcnt register

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
the number of data.

Definition at line 132 of file at32f413_dma.c.

◆ dma_data_number_set()

void dma_data_number_set | ( | dma_channel_type * | dmax_channely,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
data_number the number of data to be transferred(0x0000~0xFFFF) transfer.
Return values
none.

Definition at line 107 of file at32f413_dma.c.

◆ dma_default_para_init()

void dma_default_para_init ( dma_init_type * dma_init_struct )

dma init config with its default value.

Parameters
dma_init_struct : pointer to a dma_init_type structure which will be initialized.
Return values
none

Definition at line 360 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_flag_clear()

void dma_flag_clear ( uint32_t dmax_flag )

clear dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
none

Definition at line 342 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flag_get()

flag_status dma_flag_get ( uint32_t dmax_flag )

get dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
state of dma flag

Definition at line 296 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flexible_config()

void dma_flexible_config | ( | dma_type * | dma_x,
 |  | uint8_t | flex_channelx,
 |  | dma_flexible_request_type | flexible_request
 | ) |  |

initialize the dma_x flexible function according to the specified parameters.

Parameters
dma_x this parameter can be one of the following values:
  • DMA1
  • DMA2
flex_channelx this parameter can be one of the following values:
  • FLEX_CHANNEL1
  • FLEX_CHANNEL2
  • FLEX_CHANNEL3
  • FLEX_CHANNEL4
  • FLEX_CHANNEL5
  • FLEX_CHANNEL6
  • FLEX_CHANNEL7
flexible_request every peripheral have specified hardware_id. this parameter can be one of the following values:
  • DMA_FLEXIBLE_ADC1 - DMA_FLEXIBLE_SPI1_RX - DMA_FLEXIBLE_SPI1_TX - DMA_FLEXIBLE_SPI2_RX
  • DMA_FLEXIBLE_SPI2_TX - DMA_FLEXIBLE_UART1_RX - DMA_FLEXIBLE_UART1_TX - DMA_FLEXIBLE_UART2_RX
  • DMA_FLEXIBLE_UART2_TX - DMA_FLEXIBLE_UART3_RX - DMA_FLEXIBLE_UART3_TX - DMA_FLEXIBLE_UART4_RX
  • DMA_FLEXIBLE_UART4_TX - DMA_FLEXIBLE_UART5_RX - DMA_FLEXIBLE_UART5_TX - DMA_FLEXIBLE_I2C1_RX
  • DMA_FLEXIBLE_I2C1_TX - DMA_FLEXIBLE_I2C2_RX - DMA_FLEXIBLE_I2C2_TX - DMA_FLEXIBLE_SDIO1
  • DMA_FLEXIBLE_TMR1_TRIG - DMA_FLEXIBLE_TMR1_HALL - DMA_FLEXIBLE_TMR1_OVERFLOW- DMA_FLEXIBLE_TMR1_CH1
  • DMA_FLEXIBLE_TMR1_CH2 - DMA_FLEXIBLE_TMR1_CH3 - DMA_FLEXIBLE_TMR1_CH4 - DMA_FLEXIBLE_TMR2_TRIG
  • DMA_FLEXIBLE_TMR2_OVERFLOW- DMA_FLEXIBLE_TMR2_CH1 - DMA_FLEXIBLE_TMR2_CH2 - DMA_FLEXIBLE_TMR2_CH3
  • DMA_FLEXIBLE_TMR2_CH4 - DMA_FLEXIBLE_TMR3_TRIG - DMA_FLEXIBLE_TMR3_OVERFLOW- DMA_FLEXIBLE_TMR3_CH1
  • DMA_FLEXIBLE_TMR3_CH2 - DMA_FLEXIBLE_TMR3_CH3 - DMA_FLEXIBLE_TMR3_CH4 - DMA_FLEXIBLE_TMR4_TRIG
  • DMA_FLEXIBLE_TMR4_OVERFLOW- DMA_FLEXIBLE_TMR4_CH1 - DMA_FLEXIBLE_TMR4_CH2 - DMA_FLEXIBLE_TMR4_CH3
  • DMA_FLEXIBLE_TMR4_CH4 - DMA_FLEXIBLE_TMR5_TRIG - DMA_FLEXIBLE_TMR5_OVERFLOW- DMA_FLEXIBLE_TMR5_CH1
  • DMA_FLEXIBLE_TMR5_CH2 - DMA_FLEXIBLE_TMR5_CH3 - DMA_FLEXIBLE_TMR5_CH4 - DMA_FLEXIBLE_TMR8_TRIG
  • DMA_FLEXIBLE_TMR8_HALL - DMA_FLEXIBLE_TMR8_OVERFLOW- DMA_FLEXIBLE_TMR8_CH1 - DMA_FLEXIBLE_TMR8_CH2
  • DMA_FLEXIBLE_TMR8_CH3 - DMA_FLEXIBLE_TMR8_CH4
Return values
none

< dma flexible channel1

< dma flexible channel2

< dma flexible channel3

< dma flexible channel4

< dma flexible channel5

< dma flexible channel6

< dma flexible channel7

Definition at line 236 of file at32f413_dma.c.

Referenced by dma_configuration(), and main().

◆ dma_init()

void dma_init | ( | dma_channel_type * | dmax_channely,
 |  | dma_init_type * | dma_init_struct
 | ) |  |

dma init

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_initstruct : pointer to a dma_init_type structure.
Return values
none

Definition at line 395 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_interrupt_enable()

void dma_interrupt_enable | ( | dma_channel_type * | dmax_channely,
 |  | uint32_t | dma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma interrupt

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_int this parameter can be any combination of the following values:
  • DMA_FDT_INT
  • DMA_HDT_INT
  • DMA_DTERR_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 163 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), and main().

◆ dma_reset()

void dma_reset ( dma_channel_type * dmax_channely )

reset the dmax channely registers.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
none

Definition at line 62 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().


AT32F413 Firmwary Library: EXINT

Modules | Macros
EXINT
AT32F413_periph_driver

EXINT driver modules. More...

Modules

EXINT_lines
EXINT_exported_types
EXINT_exported_functions
EXINT_private_functions

Macros

#define EXINT ((exint_type *) EXINT_BASE)

Detailed Description

EXINT driver modules.

Macro Definition Documentation

◆ EXINT

#define EXINT ((exint_type *) EXINT_BASE)

Definition at line 196 of file at32f413_exint.h.


AT32F413 Firmwary Library: EXINT_lines

Macros
EXINT_lines
AT32F413_periph_driver » EXINT

Macros

#define | EXINT_LINE_NONE ((uint32_t)0x000000)
#define | EXINT_LINE_0 ((uint32_t)0x000001)
#define | EXINT_LINE_1 ((uint32_t)0x000002)
#define | EXINT_LINE_2 ((uint32_t)0x000004)
#define | EXINT_LINE_3 ((uint32_t)0x000008)
#define | EXINT_LINE_4 ((uint32_t)0x000010)
#define | EXINT_LINE_5 ((uint32_t)0x000020)
#define | EXINT_LINE_6 ((uint32_t)0x000040)
#define | EXINT_LINE_7 ((uint32_t)0x000080)
#define | EXINT_LINE_8 ((uint32_t)0x000100)
#define | EXINT_LINE_9 ((uint32_t)0x000200)
#define | EXINT_LINE_10 ((uint32_t)0x000400)
#define | EXINT_LINE_11 ((uint32_t)0x000800)
#define | EXINT_LINE_12 ((uint32_t)0x001000)
#define | EXINT_LINE_13 ((uint32_t)0x002000)
#define | EXINT_LINE_14 ((uint32_t)0x004000)
#define | EXINT_LINE_15 ((uint32_t)0x008000)
#define | EXINT_LINE_16 ((uint32_t)0x010000)
#define | EXINT_LINE_17 ((uint32_t)0x020000)
#define | EXINT_LINE_18 ((uint32_t)0x040000)

Detailed Description

Macro Definition Documentation

◆ EXINT_LINE_0

#define EXINT_LINE_0 ((uint32_t)0x000001)

external interrupt line 0

Definition at line 50 of file at32f413_exint.h.

◆ EXINT_LINE_1

#define EXINT_LINE_1 ((uint32_t)0x000002)

external interrupt line 1

Definition at line 51 of file at32f413_exint.h.

◆ EXINT_LINE_10

#define EXINT_LINE_10 ((uint32_t)0x000400)

external interrupt line 10

Definition at line 60 of file at32f413_exint.h.

◆ EXINT_LINE_11

#define EXINT_LINE_11 ((uint32_t)0x000800)

external interrupt line 11

Definition at line 61 of file at32f413_exint.h.

◆ EXINT_LINE_12

#define EXINT_LINE_12 ((uint32_t)0x001000)

external interrupt line 12

Definition at line 62 of file at32f413_exint.h.

◆ EXINT_LINE_13

#define EXINT_LINE_13 ((uint32_t)0x002000)

external interrupt line 13

Definition at line 63 of file at32f413_exint.h.

◆ EXINT_LINE_14

#define EXINT_LINE_14 ((uint32_t)0x004000)

external interrupt line 14

Definition at line 64 of file at32f413_exint.h.

◆ EXINT_LINE_15

#define EXINT_LINE_15 ((uint32_t)0x008000)

external interrupt line 15

Definition at line 65 of file at32f413_exint.h.

◆ EXINT_LINE_16

#define EXINT_LINE_16 ((uint32_t)0x010000)

external interrupt line 16 connected to the pvm output

Definition at line 66 of file at32f413_exint.h.

◆ EXINT_LINE_17

#define EXINT_LINE_17 ((uint32_t)0x020000)

external interrupt line 17 connected to the rtc alarm event

Definition at line 67 of file at32f413_exint.h.

◆ EXINT_LINE_18

#define EXINT_LINE_18 ((uint32_t)0x040000)

external interrupt line 18 connected to the usb fs wakeup from suspend event

Definition at line 68 of file at32f413_exint.h.

◆ EXINT_LINE_2

#define EXINT_LINE_2 ((uint32_t)0x000004)

external interrupt line 2

Definition at line 52 of file at32f413_exint.h.

◆ EXINT_LINE_3

#define EXINT_LINE_3 ((uint32_t)0x000008)

external interrupt line 3

Definition at line 53 of file at32f413_exint.h.

◆ EXINT_LINE_4

#define EXINT_LINE_4 ((uint32_t)0x000010)

external interrupt line 4

Definition at line 54 of file at32f413_exint.h.

◆ EXINT_LINE_5

#define EXINT_LINE_5 ((uint32_t)0x000020)

external interrupt line 5

Definition at line 55 of file at32f413_exint.h.

◆ EXINT_LINE_6

#define EXINT_LINE_6 ((uint32_t)0x000040)

external interrupt line 6

Definition at line 56 of file at32f413_exint.h.

◆ EXINT_LINE_7

#define EXINT_LINE_7 ((uint32_t)0x000080)

external interrupt line 7

Definition at line 57 of file at32f413_exint.h.

◆ EXINT_LINE_8

#define EXINT_LINE_8 ((uint32_t)0x000100)

external interrupt line 8

Definition at line 58 of file at32f413_exint.h.

◆ EXINT_LINE_9

#define EXINT_LINE_9 ((uint32_t)0x000200)

external interrupt line 9

Definition at line 59 of file at32f413_exint.h.

◆ EXINT_LINE_NONE

#define EXINT_LINE_NONE ((uint32_t)0x000000)

Definition at line 49 of file at32f413_exint.h.


AT32F413 Firmwary Library: EXINT_exported_types

Data Structures | Enumerations
EXINT_exported_types
AT32F413_periph_driver » EXINT

Data Structures

struct | exint_init_type
exint init type More...
struct | exint_type
type define exint register all More...

Enumerations

enum | exint_line_mode_type { EXINT_LINE_INTERRUPUT = 0x00 , EXINT_LINE_EVENT = 0x01 }
exint line mode type More...
enum | exint_polarity_config_type { EXINT_TRIGGER_RISING_EDGE = 0x00 , EXINT_TRIGGER_FALLING_EDGE = 0x01 , EXINT_TRIGGER_BOTH_EDGE = 0x02 }
exint polarity configuration type More...

Detailed Description

Enumeration Type Documentation

◆ exint_line_mode_type

enum exint_line_mode_type

exint line mode type

Enumerator
EXINT_LINE_INTERRUPUT | external interrupt line interrupt mode
EXINT_LINE_EVENT | external interrupt line event mode

Definition at line 80 of file at32f413_exint.h.

◆ exint_polarity_config_type

enum exint_polarity_config_type

exint polarity configuration type

Enumerator
EXINT_TRIGGER_RISING_EDGE | external interrupt line rising trigger mode
EXINT_TRIGGER_FALLING_EDGE | external interrupt line falling trigger mode
EXINT_TRIGGER_BOTH_EDGE | external interrupt line both rising and falling trigger mode

Definition at line 89 of file at32f413_exint.h.


AT32F413 Firmwary Library: exint_init_type Struct Reference

Data Fields
exint_init_type Struct Reference
AT32F413_periph_driver » EXINT » EXINT_exported_types

exint init type More...

#include <at32f413_exint.h>

Data Fields

exint_line_mode_type line_mode
uint32_t line_select
exint_polarity_config_type line_polarity
confirm_state line_enable

Detailed Description

exint init type

Definition at line 99 of file at32f413_exint.h.

Field Documentation

◆ line_enable

confirm_state exint_init_type::line_enable

enable or disable exint

Definition at line 104 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ line_mode

exint_line_mode_type exint_init_type::line_mode

choose mode event or interrupt mode

Definition at line 101 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ line_polarity

exint_polarity_config_type exint_init_type::line_polarity

select the tregger polarity, with rising edge, falling edge or both edge

Definition at line 103 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ line_select

uint32_t exint_init_type::line_select

select the exint line, availiable for single line or multiple lines

Definition at line 102 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_exint.h


AT32F413 Firmwary Library: exint_type Struct Reference

Data Fields
exint_type Struct Reference
AT32F413_periph_driver » EXINT » EXINT_exported_types

type define exint register all More...

#include <at32f413_exint.h>

Data Fields

union {
__IO uint32_t inten
struct {
__IO uint32_t intenx: 23
__IO uint32_t reserved1: 9
} inten_bit
};
exint inten register, offset:0x00 More...
union {
__IO uint32_t evten
struct {
__IO uint32_t evtenx: 23
__IO uint32_t reserved1: 9
} evten_bit
};
exint evten register, offset:0x04 More...
union {
__IO uint32_t polcfg1
struct {
__IO uint32_t rpx: 23
__IO uint32_t reserved1: 9
} polcfg1_bit
};
exint polcfg1 register, offset:0x08 More...
union {
__IO uint32_t polcfg2
struct {
__IO uint32_t fpx: 23
__IO uint32_t reserved1: 9
} polcfg2_bit
};
exint polcfg2 register, offset:0x0C More...
union {
__IO uint32_t swtrg
struct {
__IO uint32_t swtx: 23
__IO uint32_t reserved1: 9
} swtrg_bit
};
exint swtrg register, offset:0x10 More...
union {
__IO uint32_t intsts
struct {
__IO uint32_t linex: 23
__IO uint32_t reserved1: 9
} intsts_bit
};
exint intsts register, offset:0x14 More...

Detailed Description

type define exint register all

Definition at line 110 of file at32f413_exint.h.

Field Documentation

◆

union { ... } exint_type::@364

exint inten register, offset:0x00

◆

union { ... } exint_type::@366

exint evten register, offset:0x04

◆

union { ... } exint_type::@368

exint polcfg1 register, offset:0x08

◆

union { ... } exint_type::@370

exint polcfg2 register, offset:0x0C

◆

union { ... } exint_type::@372

exint swtrg register, offset:0x10

◆

union { ... } exint_type::@374

exint intsts register, offset:0x14

◆ evten

__IO uint32_t exint_type::evten

Definition at line 131 of file at32f413_exint.h.

◆

struct { ... } exint_type::evten_bit

◆ evtenx

__IO uint32_t exint_type::evtenx

Definition at line 134 of file at32f413_exint.h.

◆ fpx

__IO uint32_t exint_type::fpx

Definition at line 160 of file at32f413_exint.h.

◆ inten

__IO uint32_t exint_type::inten

Definition at line 118 of file at32f413_exint.h.

◆

struct { ... } exint_type::inten_bit

◆ intenx

__IO uint32_t exint_type::intenx

Definition at line 121 of file at32f413_exint.h.

◆ intsts

__IO uint32_t exint_type::intsts

Definition at line 183 of file at32f413_exint.h.

◆

struct { ... } exint_type::intsts_bit

◆ linex

__IO uint32_t exint_type::linex

Definition at line 186 of file at32f413_exint.h.

◆ polcfg1

__IO uint32_t exint_type::polcfg1

Definition at line 144 of file at32f413_exint.h.

◆

struct { ... } exint_type::polcfg1_bit

◆ polcfg2

__IO uint32_t exint_type::polcfg2

Definition at line 157 of file at32f413_exint.h.

◆

struct { ... } exint_type::polcfg2_bit

◆ reserved1

__IO uint32_t exint_type::reserved1

Definition at line 122 of file at32f413_exint.h.

◆ rpx

__IO uint32_t exint_type::rpx

Definition at line 147 of file at32f413_exint.h.

◆ swtrg

__IO uint32_t exint_type::swtrg

Definition at line 170 of file at32f413_exint.h.

◆

struct { ... } exint_type::swtrg_bit

◆ swtx

__IO uint32_t exint_type::swtx

Definition at line 173 of file at32f413_exint.h.

The documentation for this struct was generated from the following file:
  • at32f413_exint.h


AT32F413 Firmwary Library: EXINT_exported_functions

Functions
EXINT_exported_functions
AT32F413_periph_driver » EXINT

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

Function Documentation

◆ exint_default_para_init()

void exint_default_para_init ( exint_init_type * exint_struct )

exint default para init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 62 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), and usart_configuration().

◆ exint_event_enable()

void exint_event_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint event

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint event. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 210 of file at32f413_exint.c.

◆ exint_flag_clear()

void exint_flag_clear ( uint32_t exint_line )

clear exint flag

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 124 of file at32f413_exint.c.

Referenced by button_isr(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), EXINT9_5_IRQHandler(), main(), PVM_IRQHandler(), RTCAlarm_IRQHandler(), and usart_configuration().

◆ exint_flag_get()

flag_status exint_flag_get ( uint32_t exint_line )

get exint flag

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
the new state of exint flag(SET or RESET).

Definition at line 140 of file at32f413_exint.c.

Referenced by EXINT0_IRQHandler(), EXINT4_IRQHandler(), main(), and PVM_IRQHandler().

◆ exint_init()

void exint_init ( exint_init_type * exint_struct )

exint init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 76 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ exint_interrupt_enable()

void exint_interrupt_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint interrupt

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint interrupt. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 185 of file at32f413_exint.c.

◆ exint_reset()

void exint_reset ( void )

exint reset

Parameters
none
Return values
none

Definition at line 47 of file at32f413_exint.c.

◆ exint_software_interrupt_event_generate()

void exint_software_interrupt_event_generate ( uint32_t exint_line )

generate exint software interrupt event

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 167 of file at32f413_exint.c.

Referenced by TMR1_OVF_TMR10_IRQHandler().


AT32F413 Firmwary Library: EXINT_private_functions

Functions
EXINT_private_functions
AT32F413_periph_driver » EXINT

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

Function Documentation

◆ exint_default_para_init()

void exint_default_para_init ( exint_init_type * exint_struct )

exint default para init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 62 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), and usart_configuration().

◆ exint_event_enable()

void exint_event_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint event

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint event. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 210 of file at32f413_exint.c.

◆ exint_flag_clear()

void exint_flag_clear ( uint32_t exint_line )

clear exint flag

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 124 of file at32f413_exint.c.

Referenced by button_isr(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), EXINT9_5_IRQHandler(), main(), PVM_IRQHandler(), RTCAlarm_IRQHandler(), and usart_configuration().

◆ exint_flag_get()

flag_status exint_flag_get ( uint32_t exint_line )

get exint flag

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
the new state of exint flag(SET or RESET).

Definition at line 140 of file at32f413_exint.c.

Referenced by EXINT0_IRQHandler(), EXINT4_IRQHandler(), main(), and PVM_IRQHandler().

◆ exint_init()

void exint_init ( exint_init_type * exint_struct )

exint init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 76 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ exint_interrupt_enable()

void exint_interrupt_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint interrupt

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint interrupt. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 185 of file at32f413_exint.c.

◆ exint_reset()

void exint_reset ( void )

exint reset

Parameters
none
Return values
none

Definition at line 47 of file at32f413_exint.c.

◆ exint_software_interrupt_event_generate()

void exint_software_interrupt_event_generate ( uint32_t exint_line )

generate exint software interrupt event

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 167 of file at32f413_exint.c.

Referenced by TMR1_OVF_TMR10_IRQHandler().


AT32F413 Firmwary Library: FLASH

Modules | Macros
FLASH
AT32F413_periph_driver

FLASH driver modules. More...

Modules

FLASH_unlock_keys
flash unlock keys
FLASH_spim_address
flash spim address
FLASH_flags
flash flag
FLASH_interrupts
flash interrupts
FLASH_slib_mask
flash slib mask
FLASH_user_system_data
flash user system data
FLASH_timeout_definition
flash timeout definition
FLASH_exported_types
FLASH_exported_functions
FLASH_private_functions

Macros

#define | FLASH ((flash_type *) FLASH_REG_BASE)
#define | USD ((usd_type *) USD_BASE)

Detailed Description

FLASH driver modules.

Macro Definition Documentation

◆ FLASH

#define FLASH ((flash_type *) FLASH_REG_BASE)

Definition at line 562 of file at32f413_flash.h.

◆ USD

#define USD ((usd_type *) USD_BASE)

Definition at line 563 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_unlock_keys

Macros
FLASH_unlock_keys
AT32F413_periph_driver » FLASH

flash unlock keys More...

Macros

#define | FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
#define | FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
#define | FAP_RELIEVE_KEY ((uint16_t)0x00A5)
#define | SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)

Detailed Description

flash unlock keys

Macro Definition Documentation

◆ FAP_RELIEVE_KEY

#define FAP_RELIEVE_KEY ((uint16_t)0x00A5)

flash fap relieve key val

Definition at line 53 of file at32f413_flash.h.

◆ FLASH_UNLOCK_KEY1

#define FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)

flash operation unlock order key1

Definition at line 51 of file at32f413_flash.h.

◆ FLASH_UNLOCK_KEY2

#define FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)

flash operation unlock order key2

Definition at line 52 of file at32f413_flash.h.

◆ SLIB_UNLOCK_KEY

#define SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)

flash slib operation unlock order key

Definition at line 54 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_spim_address

Macros
FLASH_spim_address
AT32F413_periph_driver » FLASH

flash spim address More...

Macros

#define FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)

Detailed Description

flash spim address

Macro Definition Documentation

◆ FLASH_SPIM_START_ADDR

#define FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)

flash start address of spim

Definition at line 64 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_flags

Macros
FLASH_flags
AT32F413_periph_driver » FLASH

flash flag More...

Macros

#define | FLASH_OBF_FLAG ((uint32_t)0x00000001)
#define | FLASH_ODF_FLAG ((uint32_t)0x00000020)
#define | FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)
#define | FLASH_EPPERR_FLAG ((uint32_t)0x00000010)
#define | FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)
#define | FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)
#define | FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)
#define | FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)
#define | FLASH_USDERR_FLAG ((uint32_t)0x40000001)

Detailed Description

flash flag

Macro Definition Documentation

◆ FLASH_EPPERR_FLAG

#define FLASH_EPPERR_FLAG ((uint32_t)0x00000010)

flash bank1 erase/program protection error flag

Definition at line 78 of file at32f413_flash.h.

◆ FLASH_OBF_FLAG

#define FLASH_OBF_FLAG ((uint32_t)0x00000001)

flash bank1 operate busy flag

Definition at line 75 of file at32f413_flash.h.

◆ FLASH_ODF_FLAG

#define FLASH_ODF_FLAG ((uint32_t)0x00000020)

flash bank1 operate done flag

Definition at line 76 of file at32f413_flash.h.

◆ FLASH_PRGMERR_FLAG

#define FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)

flash bank1 program error flag

Definition at line 77 of file at32f413_flash.h.

◆ FLASH_SPIM_EPPERR_FLAG

#define FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)

flash spim erase/program protection error flag

Definition at line 82 of file at32f413_flash.h.

◆ FLASH_SPIM_OBF_FLAG

#define FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)

flash spim operate busy flag

Definition at line 79 of file at32f413_flash.h.

◆ FLASH_SPIM_ODF_FLAG

#define FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)

flash spim operate done flag

Definition at line 80 of file at32f413_flash.h.

◆ FLASH_SPIM_PRGMERR_FLAG

#define FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)

flash spim program error flag

Definition at line 81 of file at32f413_flash.h.

◆ FLASH_USDERR_FLAG

#define FLASH_USDERR_FLAG ((uint32_t)0x40000001)

flash user system data error flag

Definition at line 83 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_interrupts

Macros
FLASH_interrupts
AT32F413_periph_driver » FLASH

flash interrupts More...

Macros

#define | FLASH_ERR_INT ((uint32_t)0x00000001)
#define | FLASH_ODF_INT ((uint32_t)0x00000002)
#define | FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)
#define | FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)

Detailed Description

flash interrupts

Macro Definition Documentation

◆ FLASH_ERR_INT

#define FLASH_ERR_INT ((uint32_t)0x00000001)

flash bank1 error interrupt

Definition at line 94 of file at32f413_flash.h.

◆ FLASH_ODF_INT

#define FLASH_ODF_INT ((uint32_t)0x00000002)

flash bank1 operate done interrupt

Definition at line 95 of file at32f413_flash.h.

◆ FLASH_SPIM_ERR_INT

#define FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)

flash spim error interrupt

Definition at line 96 of file at32f413_flash.h.

◆ FLASH_SPIM_ODF_INT

#define FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)

flash spim operate done interrupt

Definition at line 97 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_slib_mask

Macros
FLASH_slib_mask
AT32F413_periph_driver » FLASH

flash slib mask More...

Macros

#define | FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)
#define | FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)
#define | FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)

Detailed Description

flash slib mask

Macro Definition Documentation

◆ FLASH_SLIB_DATA_START_SECTOR

#define FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)

flash slib d-bus area start sector

Definition at line 109 of file at32f413_flash.h.

◆ FLASH_SLIB_END_SECTOR

#define FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)

flash slib end sector

Definition at line 110 of file at32f413_flash.h.

◆ FLASH_SLIB_START_SECTOR

#define FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)

flash slib start sector

Definition at line 108 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_user_system_data

Macros
FLASH_user_system_data
AT32F413_periph_driver » FLASH

flash user system data More...

Macros

#define | USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
#define | USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
#define | USD_DEPSLP_NO_RST ((uint16_t)0x0002)
#define | USD_DEPSLP_RST ((uint16_t)0x0000)
#define | USD_STDBY_NO_RST ((uint16_t)0x0004)
#define | USD_STDBY_RST ((uint16_t)0x0000)

Detailed Description

flash user system data

Macro Definition Documentation

◆ USD_DEPSLP_NO_RST

#define USD_DEPSLP_NO_RST ((uint16_t)0x0002)

no reset generated when entering in deepsleep

Definition at line 124 of file at32f413_flash.h.

◆ USD_DEPSLP_RST

#define USD_DEPSLP_RST ((uint16_t)0x0000)

reset generated when entering in deepsleep

Definition at line 125 of file at32f413_flash.h.

◆ USD_STDBY_NO_RST

#define USD_STDBY_NO_RST ((uint16_t)0x0004)

no reset generated when entering in standby

Definition at line 127 of file at32f413_flash.h.

◆ USD_STDBY_RST

#define USD_STDBY_RST ((uint16_t)0x0000)

reset generated when entering in standby

Definition at line 128 of file at32f413_flash.h.

◆ USD_WDT_ATO_DISABLE

#define USD_WDT_ATO_DISABLE ((uint16_t)0x0001)

wdt auto start disabled

Definition at line 121 of file at32f413_flash.h.

◆ USD_WDT_ATO_ENABLE

#define USD_WDT_ATO_ENABLE ((uint16_t)0x0000)

wdt auto start enabled

Definition at line 122 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_timeout_definition

Macros
FLASH_timeout_definition
AT32F413_periph_driver » FLASH

flash timeout definition More...

Macros

#define | ERASE_TIMEOUT ((uint32_t)0x40000000)
#define | PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | OPERATION_TIMEOUT ((uint32_t)0x10000000)

Detailed Description

flash timeout definition

Macro Definition Documentation

◆ ERASE_TIMEOUT

#define ERASE_TIMEOUT ((uint32_t)0x40000000)

internal flash erase operation timeout

Definition at line 139 of file at32f413_flash.h.

◆ OPERATION_TIMEOUT

#define OPERATION_TIMEOUT ((uint32_t)0x10000000)

flash common operation timeout

Definition at line 143 of file at32f413_flash.h.

◆ PROGRAMMING_TIMEOUT

#define PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)

internal flash program operation timeout

Definition at line 140 of file at32f413_flash.h.

◆ SPIM_ERASE_TIMEOUT

#define SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)

spim erase operation timeout

Definition at line 141 of file at32f413_flash.h.

◆ SPIM_PROGRAMMING_TIMEOUT

#define SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)

spim program operation timeout

Definition at line 142 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_exported_types

Data Structures | Enumerations
FLASH_exported_types
AT32F413_periph_driver » FLASH

Data Structures

struct | flash_type
type define flash register all More...
struct | usd_type
user system data More...

Enumerations

enum flash_status_type {
FLASH_OPERATE_BUSY = 0x00 , FLASH_PROGRAM_ERROR = 0x01 , FLASH_EPP_ERROR = 0x02 , FLASH_OPERATE_DONE = 0x03 ,
FLASH_OPERATE_TIMEOUT = 0x04
}
flash status type More...
enum flash_spim_model_type { FLASH_SPIM_MODEL1 = 0x01 , FLASH_SPIM_MODEL2 = 0x02 }
flash spim model type More...

Detailed Description

Enumeration Type Documentation

◆ flash_spim_model_type

enum flash_spim_model_type

flash spim model type

Enumerator
FLASH_SPIM_MODEL1 | spim model 1
FLASH_SPIM_MODEL2 | spim model 2

Definition at line 168 of file at32f413_flash.h.

◆ flash_status_type

enum flash_status_type

flash status type

Enumerator
FLASH_OPERATE_BUSY | flash status is operate busy
FLASH_PROGRAM_ERROR | flash status is program error
FLASH_EPP_ERROR | flash status is epp error
FLASH_OPERATE_DONE | flash status is operate done
FLASH_OPERATE_TIMEOUT | flash status is operate timeout

Definition at line 156 of file at32f413_flash.h.


AT32F413 Firmwary Library: flash_type Struct Reference

Data Fields
flash_type Struct Reference
AT32F413_periph_driver » FLASH » FLASH_exported_types

type define flash register all More...

#include <at32f413_flash.h>

Data Fields

union {
__IO uint32_t psr
struct {
__IO uint32_t reserved1: 32
} psr_bit
};
flash psr register, offset:0x00 More...
union {
__IO uint32_t unlock
struct {
__IO uint32_t ukval: 32
} unlock_bit
};
flash unlock register, offset:0x04 More...
union {
__IO uint32_t usd_unlock
struct {
__IO uint32_t usd_ukval: 32
} usd_unlock_bit
};
flash usd unlock register, offset:0x08 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t obf: 1
__IO uint32_t reserved1: 1
__IO uint32_t prgmerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t epperr: 1
__IO uint32_t odf: 1
__IO uint32_t reserved3: 26
} sts_bit
};
flash sts register, offset:0x0C More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t fprgm: 1
__IO uint32_t secers: 1
__IO uint32_t bankers: 1
__IO uint32_t reserved1: 1
__IO uint32_t usdprgm: 1
__IO uint32_t usders: 1
__IO uint32_t erstr: 1
__IO uint32_t oplk: 1
__IO uint32_t reserved2: 1
__IO uint32_t usdulks: 1
__IO uint32_t errie: 1
__IO uint32_t reserved3: 1
__IO uint32_t odfie: 1
__IO uint32_t reserved4: 19
} ctrl_bit
};
flash ctrl register, offset:0x10 More...
union {
__IO uint32_t addr
struct {
__IO uint32_t fa: 32
} addr_bit
};
flash addr register, offset:0x14 More...
union {
__IO uint32_t usd
struct {
__IO uint32_t usderr: 1
__IO uint32_t fap: 1
__IO uint32_t wdt_ato_en: 1
__IO uint32_t depslp_rst: 1
__IO uint32_t stdby_rst: 1
__IO uint32_t reserved1: 5
__IO uint32_t user_d0: 8
__IO uint32_t user_d1: 8
__IO uint32_t reserved2: 6
} usd_bit
};
flash usd register, offset:0x1C More...
union {
__IO uint32_t epps
struct {
__IO uint32_t epps: 32
} epps_bit
};
flash epps register, offset:0x20 More...
union {
__IO uint32_t unlock3
struct {
__IO uint32_t ukval: 32
} unlock3_bit
};
flash unlock3 register, offset:0x84 More...
union {
__IO uint32_t select
struct {
__IO uint32_t select: 32
} select_bit
};
flash select register, offset:0x88 More...
union {
__IO uint32_t sts3
struct {
__IO uint32_t obf: 1
__IO uint32_t reserved1: 1
__IO uint32_t prgmerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t epperr: 1
__IO uint32_t odf: 1
__IO uint32_t reserved3: 26
} sts3_bit
};
flash sts3 register, offset:0x8C More...
union {
__IO uint32_t ctrl3
struct {
__IO uint32_t fprgm: 1
__IO uint32_t secers: 1
__IO uint32_t chpers: 1
__IO uint32_t reserved1: 3
__IO uint32_t erstr: 1
__IO uint32_t oplk: 1
__IO uint32_t reserved2: 2
__IO uint32_t errie: 1
__IO uint32_t reserved3: 1
__IO uint32_t odfie: 1
__IO uint32_t reserved4: 19
} ctrl3_bit
};
flash ctrl3 register, offset:0x90 More...
union {
__IO uint32_t addr3
struct {
__IO uint32_t fa: 32
} addr3_bit
};
flash addr3 register, offset:0x94 More...
union {
__IO uint32_t da
struct {
__IO uint32_t fda: 32
} da_bit
};
flash da register, offset:0x98 More...
__IO uint32_t | reserved5 [12]
flash reserved5 register, offset:0xC8~0x9C More...
union {
__IO uint32_t slib_sts0
struct {
__IO uint32_t reserved1: 3
__IO uint32_t slib_enf: 1
__IO uint32_t reserved2: 28
} slib_sts0_bit
};
flash slib_sts0 register, offset:0xCC More...
union {
__IO uint32_t slib_sts1
struct {
__IO uint32_t slib_ss: 11
__IO uint32_t slib_dat_ss: 11
__IO uint32_t slib_es: 10
} slib_sts1_bit
};
flash slib_sts1 register, offset:0xD0 More...
union {
__IO uint32_t slib_pwd_clr
struct {
__IO uint32_t slib_pclr_val: 32
} slib_pwd_clr_bit
};
flash slib_pwd_clr register, offset:0xD4 More...
union {
__IO uint32_t slib_misc_sts
struct {
__IO uint32_t slib_pwd_err: 1
__IO uint32_t slib_pwd_ok: 1
__IO uint32_t slib_ulkf: 1
__IO uint32_t reserved1: 13
__IO uint32_t slib_rcnt: 9
__IO uint32_t reserved2: 7
} slib_misc_sts_bit
};
flash slib_misc_sts register, offset:0xD8 More...
union {
__IO uint32_t slib_set_pwd
struct {
__IO uint32_t slib_pset_val: 32
} slib_set_pwd_bit
};
flash slib_set_pwd register, offset:0xDC More...
union {
__IO uint32_t slib_set_range
struct {
__IO uint32_t slib_ss_set: 11
__IO uint32_t slib_dss_set: 11
__IO uint32_t slib_es_set: 10
} slib_set_range_bit
};
flash slib_set_range register, offset:0xE0 More...
__IO uint32_t | reserved6 [3]
flash reserved6 register, offset:0xEC~0xE4 More...
union {
__IO uint32_t slib_unlock
struct {
__IO uint32_t slib_ukval: 32
} slib_unlock_bit
};
flash slib_unlock register, offset:0xF0 More...
union {
__IO uint32_t crc_ctrl
struct {
__IO uint32_t crc_ss: 12
__IO uint32_t crc_sn: 12
__IO uint32_t reserved1: 7
__IO uint32_t crc_strt: 1
} crc_ctrl_bit
};
flash crc_ctrl register, offset:0xF4 More...
union {
__IO uint32_t crc_chkr
struct {
__IO uint32_t crc_chkr: 32
} crc_chkr_bit
};
flash crc_chkr register, offset:0xF8 More...

Detailed Description

type define flash register all

Definition at line 177 of file at32f413_flash.h.

Field Documentation

◆

union { ... } flash_type::@382

flash psr register, offset:0x00

◆

union { ... } flash_type::@384

flash unlock register, offset:0x04

◆

union { ... } flash_type::@386

flash usd unlock register, offset:0x08

◆

union { ... } flash_type::@388

flash sts register, offset:0x0C

◆

union { ... } flash_type::@390

flash ctrl register, offset:0x10

◆

union { ... } flash_type::@392

flash addr register, offset:0x14

◆

union { ... } flash_type::@394

flash usd register, offset:0x1C

◆

union { ... } flash_type::@396

flash epps register, offset:0x20

◆

union { ... } flash_type::@398

flash unlock3 register, offset:0x84

◆

union { ... } flash_type::@400

flash select register, offset:0x88

◆

union { ... } flash_type::@402

flash sts3 register, offset:0x8C

◆

union { ... } flash_type::@404

flash ctrl3 register, offset:0x90

◆

union { ... } flash_type::@406

flash addr3 register, offset:0x94

◆

union { ... } flash_type::@408

flash da register, offset:0x98

◆

union { ... } flash_type::@410

flash slib_sts0 register, offset:0xCC

◆

union { ... } flash_type::@412

flash slib_sts1 register, offset:0xD0

◆

union { ... } flash_type::@414

flash slib_pwd_clr register, offset:0xD4

◆

union { ... } flash_type::@416

flash slib_misc_sts register, offset:0xD8

◆

union { ... } flash_type::@418

flash slib_set_pwd register, offset:0xDC

◆

union { ... } flash_type::@420

flash slib_set_range register, offset:0xE0

◆

union { ... } flash_type::@422

flash slib_unlock register, offset:0xF0

◆

union { ... } flash_type::@424

flash crc_ctrl register, offset:0xF4

◆

union { ... } flash_type::@426

flash crc_chkr register, offset:0xF8

◆ addr

__IO uint32_t flash_type::addr

Definition at line 263 of file at32f413_flash.h.

◆ addr3

__IO uint32_t flash_type::addr3

Definition at line 381 of file at32f413_flash.h.

◆

struct { ... } flash_type::addr3_bit

◆

struct { ... } flash_type::addr_bit

◆ bankers

__IO uint32_t flash_type::bankers

Definition at line 243 of file at32f413_flash.h.

◆ chpers

__IO uint32_t flash_type::chpers

Definition at line 364 of file at32f413_flash.h.

◆ crc_chkr

__IO uint32_t flash_type::crc_chkr

Definition at line 525 of file at32f413_flash.h.

◆

struct { ... } flash_type::crc_chkr_bit

◆ crc_ctrl

__IO uint32_t flash_type::crc_ctrl

Definition at line 510 of file at32f413_flash.h.

◆

struct { ... } flash_type::crc_ctrl_bit

◆ crc_sn

__IO uint32_t flash_type::crc_sn

Definition at line 514 of file at32f413_flash.h.

◆ crc_ss

__IO uint32_t flash_type::crc_ss

Definition at line 513 of file at32f413_flash.h.

◆ crc_strt

__IO uint32_t flash_type::crc_strt

Definition at line 516 of file at32f413_flash.h.

◆ ctrl

__IO uint32_t flash_type::ctrl

Definition at line 238 of file at32f413_flash.h.

◆ ctrl3

__IO uint32_t flash_type::ctrl3

Definition at line 359 of file at32f413_flash.h.

◆

struct { ... } flash_type::ctrl3_bit

◆

struct { ... } flash_type::ctrl_bit

◆ da

__IO uint32_t flash_type::da

Definition at line 393 of file at32f413_flash.h.

◆

struct { ... } flash_type::da_bit

◆ depslp_rst

__IO uint32_t flash_type::depslp_rst

Definition at line 286 of file at32f413_flash.h.

◆ epperr

__IO uint32_t flash_type::epperr

Definition at line 227 of file at32f413_flash.h.

◆ epps

__IO uint32_t flash_type::epps

Definition at line 300 of file at32f413_flash.h.

◆

struct { ... } flash_type::epps_bit

◆ errie

__IO uint32_t flash_type::errie

Definition at line 251 of file at32f413_flash.h.

◆ erstr

__IO uint32_t flash_type::erstr

Definition at line 247 of file at32f413_flash.h.

◆ fa

__IO uint32_t flash_type::fa

Definition at line 266 of file at32f413_flash.h.

◆ fap

__IO uint32_t flash_type::fap

Definition at line 284 of file at32f413_flash.h.

◆ fda

__IO uint32_t flash_type::fda

Definition at line 396 of file at32f413_flash.h.

◆ fprgm

__IO uint32_t flash_type::fprgm

Definition at line 241 of file at32f413_flash.h.

◆ obf

__IO uint32_t flash_type::obf

Definition at line 223 of file at32f413_flash.h.

◆ odf

__IO uint32_t flash_type::odf

Definition at line 228 of file at32f413_flash.h.

◆ odfie

__IO uint32_t flash_type::odfie

Definition at line 253 of file at32f413_flash.h.

◆ oplk

__IO uint32_t flash_type::oplk

Definition at line 248 of file at32f413_flash.h.

◆ prgmerr

__IO uint32_t flash_type::prgmerr

Definition at line 225 of file at32f413_flash.h.

◆ psr

__IO uint32_t flash_type::psr

Definition at line 184 of file at32f413_flash.h.

◆

struct { ... } flash_type::psr_bit

◆ reserved1

__IO uint32_t flash_type::reserved1

flash reserved1 register, offset:0x18

Definition at line 187 of file at32f413_flash.h.

◆ reserved2

__IO uint32_t flash_type::reserved2

flash reserved2 register, offset:0x80~0x24

Definition at line 226 of file at32f413_flash.h.

◆ reserved3

__IO uint32_t flash_type::reserved3

Definition at line 229 of file at32f413_flash.h.

◆ reserved4

__IO uint32_t flash_type::reserved4

Definition at line 254 of file at32f413_flash.h.

◆ reserved5

__IO uint32_t flash_type::reserved5[12]

flash reserved5 register, offset:0xC8~0x9C

Definition at line 403 of file at32f413_flash.h.

◆ reserved6

__IO uint32_t flash_type::reserved6[3]

flash reserved6 register, offset:0xEC~0xE4

Definition at line 491 of file at32f413_flash.h.

◆ secers

__IO uint32_t flash_type::secers

Definition at line 242 of file at32f413_flash.h.

◆ select

__IO uint32_t flash_type::select

Definition at line 329 of file at32f413_flash.h.

◆

struct { ... } flash_type::select_bit

◆ slib_dat_ss

__IO uint32_t flash_type::slib_dat_ss

Definition at line 428 of file at32f413_flash.h.

◆ slib_dss_set

__IO uint32_t flash_type::slib_dss_set

Definition at line 483 of file at32f413_flash.h.

◆ slib_enf

__IO uint32_t flash_type::slib_enf

Definition at line 414 of file at32f413_flash.h.

◆ slib_es

__IO uint32_t flash_type::slib_es

Definition at line 429 of file at32f413_flash.h.

◆ slib_es_set

__IO uint32_t flash_type::slib_es_set

Definition at line 484 of file at32f413_flash.h.

◆ slib_misc_sts

__IO uint32_t flash_type::slib_misc_sts

Definition at line 450 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_misc_sts_bit

◆ slib_pclr_val

__IO uint32_t flash_type::slib_pclr_val

Definition at line 441 of file at32f413_flash.h.

◆ slib_pset_val

__IO uint32_t flash_type::slib_pset_val

Definition at line 470 of file at32f413_flash.h.

◆ slib_pwd_clr

__IO uint32_t flash_type::slib_pwd_clr

Definition at line 438 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_pwd_clr_bit

◆ slib_pwd_err

__IO uint32_t flash_type::slib_pwd_err

Definition at line 453 of file at32f413_flash.h.

◆ slib_pwd_ok

__IO uint32_t flash_type::slib_pwd_ok

Definition at line 454 of file at32f413_flash.h.

◆ slib_rcnt

__IO uint32_t flash_type::slib_rcnt

Definition at line 457 of file at32f413_flash.h.

◆ slib_set_pwd

__IO uint32_t flash_type::slib_set_pwd

Definition at line 467 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_set_pwd_bit

◆ slib_set_range

__IO uint32_t flash_type::slib_set_range

Definition at line 479 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_set_range_bit

◆ slib_ss

__IO uint32_t flash_type::slib_ss

Definition at line 427 of file at32f413_flash.h.

◆ slib_ss_set

__IO uint32_t flash_type::slib_ss_set

Definition at line 482 of file at32f413_flash.h.

◆ slib_sts0

__IO uint32_t flash_type::slib_sts0

Definition at line 410 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_sts0_bit

◆ slib_sts1

__IO uint32_t flash_type::slib_sts1

Definition at line 424 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_sts1_bit

◆ slib_ukval

__IO uint32_t flash_type::slib_ukval

Definition at line 501 of file at32f413_flash.h.

◆ slib_ulkf

__IO uint32_t flash_type::slib_ulkf

Definition at line 455 of file at32f413_flash.h.

◆ slib_unlock

__IO uint32_t flash_type::slib_unlock

Definition at line 498 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_unlock_bit

◆ stdby_rst

__IO uint32_t flash_type::stdby_rst

Definition at line 287 of file at32f413_flash.h.

◆ sts

__IO uint32_t flash_type::sts

Definition at line 220 of file at32f413_flash.h.

◆ sts3

__IO uint32_t flash_type::sts3

Definition at line 341 of file at32f413_flash.h.

◆

struct { ... } flash_type::sts3_bit

◆

struct { ... } flash_type::sts_bit

◆ ukval

__IO uint32_t flash_type::ukval

Definition at line 199 of file at32f413_flash.h.

◆ unlock

__IO uint32_t flash_type::unlock

Definition at line 196 of file at32f413_flash.h.

◆ unlock3

__IO uint32_t flash_type::unlock3

Definition at line 317 of file at32f413_flash.h.

◆

struct { ... } flash_type::unlock3_bit

◆

struct { ... } flash_type::unlock_bit

◆ usd

__IO uint32_t flash_type::usd

Definition at line 280 of file at32f413_flash.h.

◆

struct { ... } flash_type::usd_bit

◆ usd_ukval

__IO uint32_t flash_type::usd_ukval

Definition at line 211 of file at32f413_flash.h.

◆ usd_unlock

__IO uint32_t flash_type::usd_unlock

Definition at line 208 of file at32f413_flash.h.

◆

struct { ... } flash_type::usd_unlock_bit

◆ usderr

__IO uint32_t flash_type::usderr

Definition at line 283 of file at32f413_flash.h.

◆ usders

__IO uint32_t flash_type::usders

Definition at line 246 of file at32f413_flash.h.

◆ usdprgm

__IO uint32_t flash_type::usdprgm

Definition at line 245 of file at32f413_flash.h.

◆ usdulks

__IO uint32_t flash_type::usdulks

Definition at line 250 of file at32f413_flash.h.

◆ user_d0

__IO uint32_t flash_type::user_d0

Definition at line 289 of file at32f413_flash.h.

◆ user_d1

__IO uint32_t flash_type::user_d1

Definition at line 290 of file at32f413_flash.h.

◆ wdt_ato_en

__IO uint32_t flash_type::wdt_ato_en

Definition at line 285 of file at32f413_flash.h.

The documentation for this struct was generated from the following file:
  • at32f413_flash.h


AT32F413 Firmwary Library: usd_type Struct Reference

Data Fields
usd_type Struct Reference
AT32F413_periph_driver » FLASH » FLASH_exported_types

user system data More...

#include <at32f413_flash.h>

Data Fields

__IO uint16_t | fap
__IO uint16_t | ssb
__IO uint16_t | data0
__IO uint16_t | data1
__IO uint16_t | epp0
__IO uint16_t | epp1
__IO uint16_t | epp2
__IO uint16_t | epp3
__IO uint16_t | eopb0
__IO uint16_t | reserved
__IO uint16_t | data2
__IO uint16_t | data3
__IO uint16_t | data4
__IO uint16_t | data5
__IO uint16_t | data6
__IO uint16_t | data7
__IO uint16_t | ext_flash_key [8]

Detailed Description

user system data

Definition at line 537 of file at32f413_flash.h.

Field Documentation

◆ data0

__IO uint16_t usd_type::data0

Definition at line 541 of file at32f413_flash.h.

◆ data1

__IO uint16_t usd_type::data1

Definition at line 542 of file at32f413_flash.h.

◆ data2

__IO uint16_t usd_type::data2

Definition at line 549 of file at32f413_flash.h.

◆ data3

__IO uint16_t usd_type::data3

Definition at line 550 of file at32f413_flash.h.

◆ data4

__IO uint16_t usd_type::data4

Definition at line 551 of file at32f413_flash.h.

◆ data5

__IO uint16_t usd_type::data5

Definition at line 552 of file at32f413_flash.h.

◆ data6

__IO uint16_t usd_type::data6

Definition at line 553 of file at32f413_flash.h.

◆ data7

__IO uint16_t usd_type::data7

Definition at line 554 of file at32f413_flash.h.

◆ eopb0

__IO uint16_t usd_type::eopb0

Definition at line 547 of file at32f413_flash.h.

◆ epp0

__IO uint16_t usd_type::epp0

Definition at line 543 of file at32f413_flash.h.

◆ epp1

__IO uint16_t usd_type::epp1

Definition at line 544 of file at32f413_flash.h.

◆ epp2

__IO uint16_t usd_type::epp2

Definition at line 545 of file at32f413_flash.h.

◆ epp3

__IO uint16_t usd_type::epp3

Definition at line 546 of file at32f413_flash.h.

◆ ext_flash_key

__IO uint16_t usd_type::ext_flash_key[8]

Definition at line 555 of file at32f413_flash.h.

◆ fap

__IO uint16_t usd_type::fap

Definition at line 539 of file at32f413_flash.h.

◆ reserved

__IO uint16_t usd_type::reserved

Definition at line 548 of file at32f413_flash.h.

◆ ssb

__IO uint16_t usd_type::ssb

Definition at line 540 of file at32f413_flash.h.

The documentation for this struct was generated from the following file:
  • at32f413_flash.h


AT32F413 Firmwary Library: FLASH_exported_functions

Functions
FLASH_exported_functions
AT32F413_periph_driver » FLASH

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
void | flash_spim_dummy_read (void)
operate the flash spim dummy read. More...
flash_status_type | flash_spim_mass_program (uint32_t address, uint8_t *buf, uint32_t cnt)
mass program for flash spim. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datastart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

Function Documentation

◆ flash_byte_program()

flash_status_type flash_byte_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a byte at a specified address.

Note
this function cannot be used to program spim.
Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

Definition at line 489 of file at32f413_flash.c.

Referenced by flash_write_data(), and msc_disk_write().

◆ flash_crc_calibrate()

uint32_t flash_crc_calibrate | ( | uint32_t | start_sector,
 |  | uint32_t | sector_cnt
 | ) |  |

flash crc calibration in main block.

Parameters
start_sector crc calibration start sector number sector_cnt: crc calibration sector count
Return values
uint32 crc calibration result

< flash common operation timeout

Definition at line 940 of file at32f413_flash.c.

◆ flash_epp_set()

flash_status_type flash_epp_set ( uint32_t * sector_bits )

config erase/program protection for the desired sectors.

Parameters
sector_bits the pointer of the address of the sectors to be erase/program protected. general every bit is used to protect the 4KB bytes, and the last one bit is used to protect the rest.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 550 of file at32f413_flash.c.

◆ flash_epp_status_get()

void flash_epp_status_get ( uint32_t * sector_bits )

return the flash erase/program protection status.

Parameters
sector_bits pointer to get the epps register.
Return values
none

Definition at line 600 of file at32f413_flash.c.

◆ flash_fap_enable()

flash_status_type flash_fap_enable ( confirm_state new_state )

enable or disable the flash access protection.

Note
if the user has already programmed the other user system data before calling this function, must re-program them since this function erase all user system data.
Parameters
new_state new state of the flash access protection. this parameter can be: TRUE or FALSE.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash erase operation timeout

Definition at line 615 of file at32f413_flash.c.

Referenced by main().

◆ flash_fap_status_get()

flag_status flash_fap_status_get ( void )

check the flash access protection status.

Parameters
none
Return values
flash access protection status(SET or RESET)

Definition at line 657 of file at32f413_flash.c.

Referenced by flash_user_system_data_erase(), and main().

◆ flash_flag_clear()

void flash_flag_clear ( uint32_t flash_flag )

clear the flash flag.

Parameters
flash_flag specifies the flash flags to clear. this parameter can be any combination of the following values:
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
Return values
none

Definition at line 96 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler(), flash_write(), main(), and spim_operate().

◆ flash_flag_get()

flag_status flash_flag_get ( uint32_t flash_flag )

check whether the specified flash flag is set or not.

Parameters
flash_flag specifies the flash flag to check. this parameter can be one of flash flag status:
  • FLASH_OBF_FLAG
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_OBF_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
  • FLASH_USDERR_FLAG
Return values
the new state of flash_flag (SET or RESET).

Definition at line 57 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler(), and spim_init().

◆ flash_halfword_program()

flash_status_type flash_halfword_program | ( | uint32_t | address,
 |  | uint16_t | data
 | ) |  |

program a halfword at a specified address.

Parameters
address | specifies the address to be programmed, halfword alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< internal flash program operation timeout

Definition at line 450 of file at32f413_flash.c.

Referenced by flash_2kb_write(), and flash_write_nocheck().

◆ flash_internal_all_erase()

flash_status_type flash_internal_all_erase ( void )

erase flash all internal sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

Definition at line 311 of file at32f413_flash.c.

◆ flash_interrupt_enable()

void flash_interrupt_enable | ( | uint32_t | flash_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified flash interrupts.

Parameters
flash_int specifies the flash interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • FLASH_ERR_INT
  • FLASH_ODF_INT
  • FLASH_SPIM_ERR_INT
  • FLASH_SPIM_ODF_INT
new_state new state of the specified flash interrupts. this parameter can be: TRUE or FALSE.
Return values
none

< flash bank1 error interrupt

< flash bank1 operate done interrupt

< flash spim error interrupt

< flash spim operate done interrupt

Definition at line 727 of file at32f413_flash.c.

Referenced by config_flash_interrupt().

◆ flash_lock()

void flash_lock ( void )

lock the flash controller.

Parameters
none
Return values
none

Definition at line 249 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), and msc_disk_write().

◆ flash_operation_status_get()

flash_status_type flash_operation_status_get ( void )

return the flash operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 120 of file at32f413_flash.c.

Referenced by flash_operation_wait_for().

◆ flash_operation_wait_for()

flash_status_type flash_operation_wait_for ( uint32_t time_out )

wait for flash operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 178 of file at32f413_flash.c.

Referenced by flash_byte_program(), flash_crc_calibrate(), flash_epp_set(), flash_fap_enable(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), flash_slib_disable(), flash_slib_enable(), flash_ssb_set(), flash_user_system_data_erase(), flash_user_system_data_program(), flash_word_program(), flash_write(), main(), and spim_operate().

◆ flash_sector_erase()

flash_status_type flash_sector_erase ( uint32_t sector_address )

erase a specified flash sector.

Parameters
sector_address the sector address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim erase operation timeout

< internal flash erase operation timeout

Definition at line 270 of file at32f413_flash.c.

Referenced by flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_erase_sector(), iap_init(), msc_disk_write(), slib_enable(), and spim_operate().

◆ flash_slib_datastart_sector_get()

uint16_t flash_slib_datastart_sector_get ( void )

get the data start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 919 of file at32f413_flash.c.

◆ flash_slib_disable()

error_status flash_slib_disable ( uint32_t pwd )

disable slib when slib enabled.

Parameters
pwd slib password
Return values
success or error

< internal flash erase operation timeout

Definition at line 864 of file at32f413_flash.c.

◆ flash_slib_enable()

flash_status_type flash_slib_enable | ( | uint32_t | pwd,
 |  | uint16_t | start_sector,
 |  | uint16_t | data_start_sector,
 |  | uint16_t | end_sector
 | ) |  |

enable security library function.

Parameters
pwd slib password start_sector: security library start sector data_start_sector: security library d-bus area start sector end_sector: security library end sector
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash slib operation unlock order key

< flash slib d-bus area start sector

< flash slib end sector

< flash slib start sector

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 829 of file at32f413_flash.c.

Referenced by slib_enable().

◆ flash_slib_end_sector_get()

uint16_t flash_slib_end_sector_get ( void )

get the end sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 929 of file at32f413_flash.c.

◆ flash_slib_remaining_count_get()

uint32_t flash_slib_remaining_count_get ( void )

get remaining count of slib(range: 256~0).

Parameters
none
Return values
uint32_t

Definition at line 886 of file at32f413_flash.c.

◆ flash_slib_start_sector_get()

uint16_t flash_slib_start_sector_get ( void )

get the start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 909 of file at32f413_flash.c.

◆ flash_slib_state_get()

flag_status flash_slib_state_get ( void )

get the slib state.

Parameters
none
Return values
SET or RESET

Definition at line 896 of file at32f413_flash.c.

Referenced by main().

◆ flash_spim_all_erase()

flash_status_type flash_spim_all_erase ( void )

erase flash spim sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< spim erase operation timeout

Definition at line 334 of file at32f413_flash.c.

◆ flash_spim_dummy_read()

void flash_spim_dummy_read ( void )

operate the flash spim dummy read.

Parameters
none
Return values
none

< flash start address of spim

< flash start address of spim

< flash start address of spim

Definition at line 769 of file at32f413_flash.c.

Referenced by flash_halfword_program(), flash_sector_erase(), flash_spim_all_erase(), flash_spim_mass_program(), flash_spim_model_select(), and flash_word_program().

◆ flash_spim_encryption_range_set()

void flash_spim_encryption_range_set ( uint32_t decode_address )

set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption.

Parameters
decode_address the end address of encrypted data in spim
Return values
none

Definition at line 759 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_lock()

void flash_spim_lock ( void )

lock the flash spim controller.

Parameters
none
Return values
none

Definition at line 259 of file at32f413_flash.c.

◆ flash_spim_mass_program()

flash_status_type flash_spim_mass_program | ( | uint32_t | address,
 |  | uint8_t * | buf,
 |  | uint32_t | cnt
 | ) |  |

mass program for flash spim.

Parameters
address | specifies the start address to be programmed, word or halfword alignment is recommended.
buf | specifies the pointer of data to be programmed.
cnt | specifies the data counter to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< spim program operation timeout

Definition at line 784 of file at32f413_flash.c.

◆ flash_spim_model_select()

void flash_spim_model_select ( flash_spim_model_type mode )

select spim supports extended spi flash chip model.

Parameters
mode the extended spi flash model
Return values
none

Definition at line 744 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_operation_status_get()

flash_status_type flash_spim_operation_status_get ( void )

return the flash spim operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 149 of file at32f413_flash.c.

Referenced by flash_spim_operation_wait_for().

◆ flash_spim_operation_wait_for()

flash_status_type flash_spim_operation_wait_for ( uint32_t time_out )

wait for flash spim operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 203 of file at32f413_flash.c.

Referenced by flash_halfword_program(), flash_sector_erase(), flash_spim_all_erase(), flash_spim_mass_program(), and flash_word_program().

◆ flash_spim_unlock()

void flash_spim_unlock ( void )

unlock the flash spim controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 238 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_ssb_set()

flash_status_type flash_ssb_set ( uint8_t usd_ssb )

program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.

Parameters
usd_ssb the system setting byte
Note
this parameter usd_ssb must contain a combination of all the following 3 types of data type 1: wdt_ato_en, select the wdt auto start this data can be one of the following values:
  • USD_WDT_ATO_DISABLE: disable wdt auto start
  • USD_WDT_ATO_ENABLE: enable wdt auto start type 2: depslp_rst, reset event when entering deepsleep mode. this data can be one of the following values:
  • USD_DEPSLP_NO_RST: no reset generated when entering in deepsleep
  • USD_DEPSLP_RST: reset generated when entering in deepsleep type 3: stdby_rst, reset event when entering standby mode. this data can be one of the following values:
  • USD_STDBY_NO_RST: no reset generated when entering in standby
  • USD_STDBY_RST: reset generated when entering in standby
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 681 of file at32f413_flash.c.

◆ flash_ssb_status_get()

uint8_t flash_ssb_status_get ( void )

return the flash system setting byte status.

Parameters
none
Return values
values from flash_usd register: wdt_ato_en(bit0), depslp_rst(bit1) and stdby_rst(bit2).

Definition at line 709 of file at32f413_flash.c.

◆ flash_unlock()

void flash_unlock ( void )

unlock the flash controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 227 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), extend_sram(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), main(), msc_disk_write(), and slib_enable().

◆ flash_user_system_data_erase()

flash_status_type flash_user_system_data_erase ( void )

erase the flash user system data.

Note
this functions erases all user system data except the fap byte.
Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash fap relieve key val

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash program operation timeout

Definition at line 361 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_user_system_data_program()

flash_status_type flash_user_system_data_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a halfword at a specified user system data address.

Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 512 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_word_program()

flash_status_type flash_word_program | ( | uint32_t | address,
 |  | uint32_t | data
 | ) |  |

program a word at a specified address.

Parameters
address | specifies the address to be programmed, word alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< internal flash program operation timeout

Definition at line 412 of file at32f413_flash.c.

Referenced by flash_fat16_set_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_set_upgrade_flag(), slib_enable(), and spim_operate().


AT32F413 Firmwary Library: FLASH_private_functions

Functions
FLASH_private_functions
AT32F413_periph_driver » FLASH

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
void | flash_spim_dummy_read (void)
operate the flash spim dummy read. More...
flash_status_type | flash_spim_mass_program (uint32_t address, uint8_t *buf, uint32_t cnt)
mass program for flash spim. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datastart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

Function Documentation

◆ flash_byte_program()

flash_status_type flash_byte_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a byte at a specified address.

Note
this function cannot be used to program spim.
Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

Definition at line 489 of file at32f413_flash.c.

Referenced by flash_write_data(), and msc_disk_write().

◆ flash_crc_calibrate()

uint32_t flash_crc_calibrate | ( | uint32_t | start_sector,
 |  | uint32_t | sector_cnt
 | ) |  |

flash crc calibration in main block.

Parameters
start_sector crc calibration start sector number sector_cnt: crc calibration sector count
Return values
uint32 crc calibration result

< flash common operation timeout

Definition at line 940 of file at32f413_flash.c.

◆ flash_epp_set()

flash_status_type flash_epp_set ( uint32_t * sector_bits )

config erase/program protection for the desired sectors.

Parameters
sector_bits the pointer of the address of the sectors to be erase/program protected. general every bit is used to protect the 4KB bytes, and the last one bit is used to protect the rest.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 550 of file at32f413_flash.c.

◆ flash_epp_status_get()

void flash_epp_status_get ( uint32_t * sector_bits )

return the flash erase/program protection status.

Parameters
sector_bits pointer to get the epps register.
Return values
none

Definition at line 600 of file at32f413_flash.c.

◆ flash_fap_enable()

flash_status_type flash_fap_enable ( confirm_state new_state )

enable or disable the flash access protection.

Note
if the user has already programmed the other user system data before calling this function, must re-program them since this function erase all user system data.
Parameters
new_state new state of the flash access protection. this parameter can be: TRUE or FALSE.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash erase operation timeout

Definition at line 615 of file at32f413_flash.c.

Referenced by main().

◆ flash_fap_status_get()

flag_status flash_fap_status_get ( void )

check the flash access protection status.

Parameters
none
Return values
flash access protection status(SET or RESET)

Definition at line 657 of file at32f413_flash.c.

Referenced by flash_user_system_data_erase(), and main().

◆ flash_flag_clear()

void flash_flag_clear ( uint32_t flash_flag )

clear the flash flag.

Parameters
flash_flag specifies the flash flags to clear. this parameter can be any combination of the following values:
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
Return values
none

Definition at line 96 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler(), flash_write(), main(), and spim_operate().

◆ flash_flag_get()

flag_status flash_flag_get ( uint32_t flash_flag )

check whether the specified flash flag is set or not.

Parameters
flash_flag specifies the flash flag to check. this parameter can be one of flash flag status:
  • FLASH_OBF_FLAG
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_OBF_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
  • FLASH_USDERR_FLAG
Return values
the new state of flash_flag (SET or RESET).

Definition at line 57 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler(), and spim_init().

◆ flash_halfword_program()

flash_status_type flash_halfword_program | ( | uint32_t | address,
 |  | uint16_t | data
 | ) |  |

program a halfword at a specified address.

Parameters
address | specifies the address to be programmed, halfword alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< internal flash program operation timeout

Definition at line 450 of file at32f413_flash.c.

Referenced by flash_2kb_write(), and flash_write_nocheck().

◆ flash_internal_all_erase()

flash_status_type flash_internal_all_erase ( void )

erase flash all internal sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

Definition at line 311 of file at32f413_flash.c.

◆ flash_interrupt_enable()

void flash_interrupt_enable | ( | uint32_t | flash_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified flash interrupts.

Parameters
flash_int specifies the flash interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • FLASH_ERR_INT
  • FLASH_ODF_INT
  • FLASH_SPIM_ERR_INT
  • FLASH_SPIM_ODF_INT
new_state new state of the specified flash interrupts. this parameter can be: TRUE or FALSE.
Return values
none

< flash bank1 error interrupt

< flash bank1 operate done interrupt

< flash spim error interrupt

< flash spim operate done interrupt

Definition at line 727 of file at32f413_flash.c.

Referenced by config_flash_interrupt().

◆ flash_lock()

void flash_lock ( void )

lock the flash controller.

Parameters
none
Return values
none

Definition at line 249 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), and msc_disk_write().

◆ flash_operation_status_get()

flash_status_type flash_operation_status_get ( void )

return the flash operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 120 of file at32f413_flash.c.

Referenced by flash_operation_wait_for().

◆ flash_operation_wait_for()

flash_status_type flash_operation_wait_for ( uint32_t time_out )

wait for flash operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 178 of file at32f413_flash.c.

Referenced by flash_byte_program(), flash_crc_calibrate(), flash_epp_set(), flash_fap_enable(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), flash_slib_disable(), flash_slib_enable(), flash_ssb_set(), flash_user_system_data_erase(), flash_user_system_data_program(), flash_word_program(), flash_write(), main(), and spim_operate().

◆ flash_sector_erase()

flash_status_type flash_sector_erase ( uint32_t sector_address )

erase a specified flash sector.

Parameters
sector_address the sector address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim erase operation timeout

< internal flash erase operation timeout

Definition at line 270 of file at32f413_flash.c.

Referenced by flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_erase_sector(), iap_init(), msc_disk_write(), slib_enable(), and spim_operate().

◆ flash_slib_datastart_sector_get()

uint16_t flash_slib_datastart_sector_get ( void )

get the data start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 919 of file at32f413_flash.c.

◆ flash_slib_disable()

error_status flash_slib_disable ( uint32_t pwd )

disable slib when slib enabled.

Parameters
pwd slib password
Return values
success or error

< internal flash erase operation timeout

Definition at line 864 of file at32f413_flash.c.

◆ flash_slib_enable()

flash_status_type flash_slib_enable | ( | uint32_t | pwd,
 |  | uint16_t | start_sector,
 |  | uint16_t | data_start_sector,
 |  | uint16_t | end_sector
 | ) |  |

enable security library function.

Parameters
pwd slib password start_sector: security library start sector data_start_sector: security library d-bus area start sector end_sector: security library end sector
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash slib operation unlock order key

< flash slib d-bus area start sector

< flash slib end sector

< flash slib start sector

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 829 of file at32f413_flash.c.

Referenced by slib_enable().

◆ flash_slib_end_sector_get()

uint16_t flash_slib_end_sector_get ( void )

get the end sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 929 of file at32f413_flash.c.

◆ flash_slib_remaining_count_get()

uint32_t flash_slib_remaining_count_get ( void )

get remaining count of slib(range: 256~0).

Parameters
none
Return values
uint32_t

Definition at line 886 of file at32f413_flash.c.

◆ flash_slib_start_sector_get()

uint16_t flash_slib_start_sector_get ( void )

get the start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 909 of file at32f413_flash.c.

◆ flash_slib_state_get()

flag_status flash_slib_state_get ( void )

get the slib state.

Parameters
none
Return values
SET or RESET

Definition at line 896 of file at32f413_flash.c.

Referenced by main().

◆ flash_spim_all_erase()

flash_status_type flash_spim_all_erase ( void )

erase flash spim sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< spim erase operation timeout

Definition at line 334 of file at32f413_flash.c.

◆ flash_spim_dummy_read()

void flash_spim_dummy_read ( void )

operate the flash spim dummy read.

Parameters
none
Return values
none

< flash start address of spim

< flash start address of spim

< flash start address of spim

Definition at line 769 of file at32f413_flash.c.

Referenced by flash_halfword_program(), flash_sector_erase(), flash_spim_all_erase(), flash_spim_mass_program(), flash_spim_model_select(), and flash_word_program().

◆ flash_spim_encryption_range_set()

void flash_spim_encryption_range_set ( uint32_t decode_address )

set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption.

Parameters
decode_address the end address of encrypted data in spim
Return values
none

Definition at line 759 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_lock()

void flash_spim_lock ( void )

lock the flash spim controller.

Parameters
none
Return values
none

Definition at line 259 of file at32f413_flash.c.

◆ flash_spim_mass_program()

flash_status_type flash_spim_mass_program | ( | uint32_t | address,
 |  | uint8_t * | buf,
 |  | uint32_t | cnt
 | ) |  |

mass program for flash spim.

Parameters
address | specifies the start address to be programmed, word or halfword alignment is recommended.
buf | specifies the pointer of data to be programmed.
cnt | specifies the data counter to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< spim program operation timeout

Definition at line 784 of file at32f413_flash.c.

◆ flash_spim_model_select()

void flash_spim_model_select ( flash_spim_model_type mode )

select spim supports extended spi flash chip model.

Parameters
mode the extended spi flash model
Return values
none

Definition at line 744 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_operation_status_get()

flash_status_type flash_spim_operation_status_get ( void )

return the flash spim operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 149 of file at32f413_flash.c.

Referenced by flash_spim_operation_wait_for().

◆ flash_spim_operation_wait_for()

flash_status_type flash_spim_operation_wait_for ( uint32_t time_out )

wait for flash spim operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 203 of file at32f413_flash.c.

Referenced by flash_halfword_program(), flash_sector_erase(), flash_spim_all_erase(), flash_spim_mass_program(), and flash_word_program().

◆ flash_spim_unlock()

void flash_spim_unlock ( void )

unlock the flash spim controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 238 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_ssb_set()

flash_status_type flash_ssb_set ( uint8_t usd_ssb )

program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.

Parameters
usd_ssb the system setting byte
Note
this parameter usd_ssb must contain a combination of all the following 3 types of data type 1: wdt_ato_en, select the wdt auto start this data can be one of the following values:
  • USD_WDT_ATO_DISABLE: disable wdt auto start
  • USD_WDT_ATO_ENABLE: enable wdt auto start type 2: depslp_rst, reset event when entering deepsleep mode. this data can be one of the following values:
  • USD_DEPSLP_NO_RST: no reset generated when entering in deepsleep
  • USD_DEPSLP_RST: reset generated when entering in deepsleep type 3: stdby_rst, reset event when entering standby mode. this data can be one of the following values:
  • USD_STDBY_NO_RST: no reset generated when entering in standby
  • USD_STDBY_RST: reset generated when entering in standby
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 681 of file at32f413_flash.c.

◆ flash_ssb_status_get()

uint8_t flash_ssb_status_get ( void )

return the flash system setting byte status.

Parameters
none
Return values
values from flash_usd register: wdt_ato_en(bit0), depslp_rst(bit1) and stdby_rst(bit2).

Definition at line 709 of file at32f413_flash.c.

◆ flash_unlock()

void flash_unlock ( void )

unlock the flash controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 227 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), extend_sram(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), main(), msc_disk_write(), and slib_enable().

◆ flash_user_system_data_erase()

flash_status_type flash_user_system_data_erase ( void )

erase the flash user system data.

Note
this functions erases all user system data except the fap byte.
Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash fap relieve key val

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash program operation timeout

Definition at line 361 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_user_system_data_program()

flash_status_type flash_user_system_data_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a halfword at a specified user system data address.

Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 512 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_word_program()

flash_status_type flash_word_program | ( | uint32_t | address,
 |  | uint32_t | data
 | ) |  |

program a word at a specified address.

Parameters
address | specifies the address to be programmed, word alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< internal flash program operation timeout

Definition at line 412 of file at32f413_flash.c.

Referenced by flash_fat16_set_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_set_upgrade_flag(), slib_enable(), and spim_operate().


AT32F413 Firmwary Library: GPIO

Modules | Macros
GPIO
AT32F413_periph_driver

GPIO driver modules. More...

Modules

GPIO_pins_number_definition
IOMUX_map_definition
iomux map definitions
IOMUX_map2_definition
iomux map2 definitions
IOMUX_map3_definition
iomux map3 definitions
IOMUX_map4_definition
iomux map4 definitions
IOMUX_map5_definition
iomux map5 definitions
IOMUX_map6_definition
iomux map6 definitions
IOMUX_map7_definition
iomux map7 definitions
GPIO_exported_types
GPIO_exported_functions
GPIO_private_functions

Macros

#define | IOMUX_MAKE_VALUE(reg_offset, bit_addr, bit_num, bit_val) (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))
#define | GPIOA ((gpio_type *) GPIOA_BASE)
#define | GPIOB ((gpio_type *) GPIOB_BASE)
#define | GPIOC ((gpio_type *) GPIOC_BASE)
#define | GPIOD ((gpio_type *) GPIOD_BASE)
#define | GPIOF ((gpio_type *) GPIOF_BASE)
#define | IOMUX ((iomux_type *) IOMUX_BASE)

Detailed Description

GPIO driver modules.

Macro Definition Documentation

◆ GPIOA

#define GPIOA ((gpio_type *) GPIOA_BASE)

Definition at line 746 of file at32f413_gpio.h.

◆ GPIOB

#define GPIOB ((gpio_type *) GPIOB_BASE)

Definition at line 747 of file at32f413_gpio.h.

◆ GPIOC

#define GPIOC ((gpio_type *) GPIOC_BASE)

Definition at line 748 of file at32f413_gpio.h.

◆ GPIOD

#define GPIOD ((gpio_type *) GPIOD_BASE)

Definition at line 749 of file at32f413_gpio.h.

◆ GPIOF

#define GPIOF ((gpio_type *) GPIOF_BASE)

Definition at line 750 of file at32f413_gpio.h.

◆ IOMUX

#define IOMUX ((iomux_type *) IOMUX_BASE)

Definition at line 751 of file at32f413_gpio.h.

◆ IOMUX_MAKE_VALUE

#define IOMUX_MAKE_VALUE | ( | reg_offset,
 |  | bit_addr,
 |  | bit_num,
 |  | bit_val
 | ) | (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))

Definition at line 71 of file at32f413_gpio.h.


AT32F413 Firmwary Library: GPIO_pins_number_definition

Macros
GPIO_pins_number_definition
AT32F413_periph_driver » GPIO

Macros

#define | GPIO_PINS_0 0x0001
#define | GPIO_PINS_1 0x0002
#define | GPIO_PINS_2 0x0004
#define | GPIO_PINS_3 0x0008
#define | GPIO_PINS_4 0x0010
#define | GPIO_PINS_5 0x0020
#define | GPIO_PINS_6 0x0040
#define | GPIO_PINS_7 0x0080
#define | GPIO_PINS_8 0x0100
#define | GPIO_PINS_9 0x0200
#define | GPIO_PINS_10 0x0400
#define | GPIO_PINS_11 0x0800
#define | GPIO_PINS_12 0x1000
#define | GPIO_PINS_13 0x2000
#define | GPIO_PINS_14 0x4000
#define | GPIO_PINS_15 0x8000
#define | GPIO_PINS_ALL 0xFFFF

Detailed Description

Macro Definition Documentation

◆ GPIO_PINS_0

#define GPIO_PINS_0 0x0001

gpio pins number 0

Definition at line 49 of file at32f413_gpio.h.

◆ GPIO_PINS_1

#define GPIO_PINS_1 0x0002

gpio pins number 1

Definition at line 50 of file at32f413_gpio.h.

◆ GPIO_PINS_10

#define GPIO_PINS_10 0x0400

gpio pins number 10

Definition at line 59 of file at32f413_gpio.h.

◆ GPIO_PINS_11

#define GPIO_PINS_11 0x0800

gpio pins number 11

Definition at line 60 of file at32f413_gpio.h.

◆ GPIO_PINS_12

#define GPIO_PINS_12 0x1000

gpio pins number 12

Definition at line 61 of file at32f413_gpio.h.

◆ GPIO_PINS_13

#define GPIO_PINS_13 0x2000

gpio pins number 13

Definition at line 62 of file at32f413_gpio.h.

◆ GPIO_PINS_14

#define GPIO_PINS_14 0x4000

gpio pins number 14

Definition at line 63 of file at32f413_gpio.h.

◆ GPIO_PINS_15

#define GPIO_PINS_15 0x8000

gpio pins number 15

Definition at line 64 of file at32f413_gpio.h.

◆ GPIO_PINS_2

#define GPIO_PINS_2 0x0004

gpio pins number 2

Definition at line 51 of file at32f413_gpio.h.

◆ GPIO_PINS_3

#define GPIO_PINS_3 0x0008

gpio pins number 3

Definition at line 52 of file at32f413_gpio.h.

◆ GPIO_PINS_4

#define GPIO_PINS_4 0x0010

gpio pins number 4

Definition at line 53 of file at32f413_gpio.h.

◆ GPIO_PINS_5

#define GPIO_PINS_5 0x0020

gpio pins number 5

Definition at line 54 of file at32f413_gpio.h.

◆ GPIO_PINS_6

#define GPIO_PINS_6 0x0040

gpio pins number 6

Definition at line 55 of file at32f413_gpio.h.

◆ GPIO_PINS_7

#define GPIO_PINS_7 0x0080

gpio pins number 7

Definition at line 56 of file at32f413_gpio.h.

◆ GPIO_PINS_8

#define GPIO_PINS_8 0x0100

gpio pins number 8

Definition at line 57 of file at32f413_gpio.h.

◆ GPIO_PINS_9

#define GPIO_PINS_9 0x0200

gpio pins number 9

Definition at line 58 of file at32f413_gpio.h.

◆ GPIO_PINS_ALL

#define GPIO_PINS_ALL 0xFFFF

gpio all pins

Definition at line 65 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map_definition

Macros
IOMUX_map_definition
AT32F413_periph_driver » GPIO

iomux map definitions More...

Macros

#define | SPI1_MUX_01 SPI1_GMUX_0001
#define | I2C1_MUX I2C1_GMUX_0001
#define | USART1_MUX USART1_GMUX_0001
#define | USART3_MUX_01 USART3_GMUX_0001
#define | TMR1_MUX_01 TMR1_GMUX_0001
#define | TMR2_MUX_01 TMR2_GMUX_001
#define | TMR2_MUX_10 TMR2_GMUX_010
#define | TMR2_MUX_11 TMR2_GMUX_011
#define | TMR3_MUX_10 TMR3_GMUX_0010
#define | TMR3_MUX_11 TMR3_GMUX_0011
#define | CAN_MUX_10 CAN1_GMUX_0010
#define | PD01_MUX PD01_GMUX
#define | TMR5CH4_MUX TMR5CH4_GMUX
#define | ADC1_ETP_MUX ADC1_ETP_GMUX
#define | ADC1_ETO_MUX ADC1_ETO_GMUX
#define | ADC2_ETP_MUX ADC2_ETP_GMUX
#define | ADC2_ETO_MUX ADC2_ETO_GMUX
#define | SWJTAG_CONF_001 SWJTAG_GMUX_001
#define | SWJTAG_CONF_010 SWJTAG_GMUX_010
#define | SWJTAG_CONF_100 SWJTAG_GMUX_100

Detailed Description

iomux map definitions

Macro Definition Documentation

◆ ADC1_ETO_MUX

#define ADC1_ETO_MUX ADC1_ETO_GMUX

adc1 external trigger ordinary conversion muxing

Definition at line 93 of file at32f413_gpio.h.

◆ ADC1_ETP_MUX

#define ADC1_ETP_MUX ADC1_ETP_GMUX

adc1 external trigger preempted conversion muxing

Definition at line 92 of file at32f413_gpio.h.

◆ ADC2_ETO_MUX

#define ADC2_ETO_MUX ADC2_ETO_GMUX

adc2 external trigger ordinary conversion muxing

Definition at line 95 of file at32f413_gpio.h.

◆ ADC2_ETP_MUX

#define ADC2_ETP_MUX ADC2_ETP_GMUX

adc2 external trigger preempted conversion muxing

Definition at line 94 of file at32f413_gpio.h.

◆ CAN_MUX_10

#define CAN_MUX_10 CAN1_GMUX_0010

can_rx(pb8), can_tx(pb9)

Definition at line 89 of file at32f413_gpio.h.

◆ I2C1_MUX

#define I2C1_MUX I2C1_GMUX_0001

i2c1_scl(pb8), i2c1_sda(pb9)

Definition at line 80 of file at32f413_gpio.h.

◆ PD01_MUX

#define PD01_MUX PD01_GMUX

pd0/pd1 mapping on osc_in/osc_out

Definition at line 90 of file at32f413_gpio.h.

◆ SPI1_MUX_01

#define SPI1_MUX_01 SPI1_GMUX_0001

spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb0)

Definition at line 79 of file at32f413_gpio.h.

◆ SWJTAG_CONF_001

#define SWJTAG_CONF_001 SWJTAG_GMUX_001

full swj enabled (jtag-dp + sw-dp) but without jtrst

Definition at line 96 of file at32f413_gpio.h.

◆ SWJTAG_CONF_010

#define SWJTAG_CONF_010 SWJTAG_GMUX_010

jtag-dp disabled and sw-dp enabled

Definition at line 97 of file at32f413_gpio.h.

◆ SWJTAG_CONF_100

#define SWJTAG_CONF_100 SWJTAG_GMUX_100

full swj disabled (jtag-dp + sw-dp)

Definition at line 98 of file at32f413_gpio.h.

◆ TMR1_MUX_01

#define TMR1_MUX_01 TMR1_GMUX_0001

tmr1_ext(pa12), tmr1_ch1(pa8), tmr1_ch2(pa9), tmr1_ch3(pa10), tmr1_ch4(pa11), tmr1_brkin(pa6), tmr1_ch1c(pa7), tmr1_ch2c(pb0), tmr1_ch3c(pb1)

Definition at line 83 of file at32f413_gpio.h.

◆ TMR2_MUX_01

#define TMR2_MUX_01 TMR2_GMUX_001

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pa2), tmr2_ch4(pa3)

Definition at line 84 of file at32f413_gpio.h.

◆ TMR2_MUX_10

#define TMR2_MUX_10 TMR2_GMUX_010

tmr2_ch1_ext(pa0), tmr2_ch2(pa1), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 85 of file at32f413_gpio.h.

◆ TMR2_MUX_11

#define TMR2_MUX_11 TMR2_GMUX_011

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 86 of file at32f413_gpio.h.

◆ TMR3_MUX_10

#define TMR3_MUX_10 TMR3_GMUX_0010

tmr3_ch1(pb4), tmr3_ch2(pb5), tmr3_ch3(pb0), tmr3_ch4(pb1)

Definition at line 87 of file at32f413_gpio.h.

◆ TMR3_MUX_11

#define TMR3_MUX_11 TMR3_GMUX_0011

tmr3_ch1(pc6), tmr3_ch2(pc7), tmr3_ch3(pc8), tmr3_ch4(pc9)

Definition at line 88 of file at32f413_gpio.h.

◆ TMR5CH4_MUX

#define TMR5CH4_MUX TMR5CH4_GMUX

lick connected to tmr5_ch4 input capture for calibration

Definition at line 91 of file at32f413_gpio.h.

◆ USART1_MUX

#define USART1_MUX USART1_GMUX_0001

usart1_tx(pb6), usart1_rx(pb7)

Definition at line 81 of file at32f413_gpio.h.

◆ USART3_MUX_01

#define USART3_MUX_01 USART3_GMUX_0001

usart3_tx(pc10), usart3_rx(pc11), usart3_ck(pc12), usart3_cts(pb13), usart3_rts(pb14)

Definition at line 82 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map2_definition

Macros
IOMUX_map2_definition
AT32F413_periph_driver » GPIO

iomux map2 definitions More...

Macros

#define EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000

Detailed Description

iomux map2 definitions

Macro Definition Documentation

◆ EXT_SPIM_EN_MUX

#define EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000

enable external spi-flash interface

Definition at line 109 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map3_definition

Macros
IOMUX_map3_definition
AT32F413_periph_driver » GPIO

iomux map3 definitions More...

Macros

#define | TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)
#define | TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)
#define | TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)

Detailed Description

iomux map3 definitions

Macro Definition Documentation

◆ TMR10_GMUX

#define TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)

tmr10_ch1(pa6)

Definition at line 121 of file at32f413_gpio.h.

◆ TMR11_GMUX

#define TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)

tmr11_ch1(pa7)

Definition at line 122 of file at32f413_gpio.h.

◆ TMR9_GMUX

#define TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)

tmr9_ch1(pb14), tmr9_ch2(pb15)

Definition at line 120 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map4_definition

Macros
IOMUX_map4_definition
AT32F413_periph_driver » GPIO

iomux map4 definitions More...

Macros

#define | TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)
#define | TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)
#define | TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)
#define | TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)
#define | TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)
#define | TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)
#define | TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)
#define | TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)
#define | TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)

Detailed Description

iomux map4 definitions

Macro Definition Documentation

◆ TMR1_GMUX_0001

#define TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)

tmr1_ext(pa12), tmr1_ch1(pa8), tmr1_ch2(pa9), tmr1_ch3(pa10), tmr1_ch4(pa11), tmr1_brkin(pa6), tmr1_ch1c(pa7), tmr1_ch2c(pb0), tmr1_ch3c(pb1)

Definition at line 133 of file at32f413_gpio.h.

◆ TMR2_GMUX_001

#define TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pa2), tmr2_ch4(pa3)

Definition at line 134 of file at32f413_gpio.h.

◆ TMR2_GMUX_010

#define TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)

tmr2_ch1_ext(pa0), tmr2_ch2(pa1), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 135 of file at32f413_gpio.h.

◆ TMR2_GMUX_011

#define TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 136 of file at32f413_gpio.h.

◆ TMR2ITR1_GMUX

#define TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)

usbdev sof as input to tmr2_int.1

Definition at line 137 of file at32f413_gpio.h.

◆ TMR3_GMUX_0010

#define TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)

tmr3_ch1(pb4), tmr3_ch2(pb5), tmr3_ch3(pb0), tmr3_ch4(pb1)

Definition at line 138 of file at32f413_gpio.h.

◆ TMR3_GMUX_0011

#define TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)

tmr3_ch1(pc6), tmr3_ch2(pc7), tmr3_ch3(pc8), tmr3_ch4(pc9)

Definition at line 139 of file at32f413_gpio.h.

◆ TMR5_GMUX_001

#define TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)

tmr5_ch1(pf4), tmr5_ch2(pf5)

Definition at line 140 of file at32f413_gpio.h.

◆ TMR5CH4_GMUX

#define TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)

lick connected to tmr5_ch4 input capture for calibration

Definition at line 141 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map5_definition

Macros
IOMUX_map5_definition
AT32F413_periph_driver » GPIO

iomux map5 definitions More...

Macros

#define | I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)
#define | I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)
#define | I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)
#define | SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)

Detailed Description

iomux map5 definitions

Macro Definition Documentation

◆ I2C1_GMUX_0001

#define I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)

i2c1_scl(pb8), i2c1_sda(pb9)

Definition at line 152 of file at32f413_gpio.h.

◆ I2C1_GMUX_0011

#define I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)

i2c1_scl(pf6), i2c1_sda(pf7)

Definition at line 153 of file at32f413_gpio.h.

◆ I2C2_GMUX_0001

#define I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)

i2c2_scl(pf6), i2c2_sda(pf7)

Definition at line 154 of file at32f413_gpio.h.

◆ I2C2_GMUX_0010

#define I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)

i2c2_scl(pa8), i2c2_sda(pc9)

Definition at line 155 of file at32f413_gpio.h.

◆ I2C2_GMUX_0011

#define I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)

i2c2_scl(pa8), i2c2_sda(pb4)

Definition at line 156 of file at32f413_gpio.h.

◆ SPI1_GMUX_0001

#define SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)

spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb6)

Definition at line 157 of file at32f413_gpio.h.

◆ SPI2_GMUX_0001

#define SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)

spi2_cs/i2s2_ws(pa15), spi2_sck/i2s2_ck(pb3), spi2_miso(pb4), spi2_mosi/i2s2_sd(pb5), i2s2_mck(pc7)

Definition at line 158 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map6_definition

Macros
IOMUX_map6_definition
AT32F413_periph_driver » GPIO

iomux map6 definitions More...

Macros

#define | CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)
#define | CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)
#define | SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)
#define | SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)
#define | SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)
#define | SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)
#define | USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)
#define | USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)
#define | UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)

Detailed Description

iomux map6 definitions

Macro Definition Documentation

◆ CAN1_GMUX_0010

#define CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)

can_rx(pb8), can_tx(pb9)

Definition at line 169 of file at32f413_gpio.h.

◆ CAN2_GMUX_0001

#define CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)

can2_rx(pb5), can2_tx(pb6)

Definition at line 170 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0100

#define SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)

sdio1_ck(pc4), sdio1_cmd(pc5), sdio1_d0(pc0), sdio1_d1(pc1), sdio1_d2(pc2), sdio1_d3(pc3), sdio1_d4(pa4), sdio1_d5(pa5), sdio1_d6(pa6), sdio1_d7(pa7)

Definition at line 171 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0101

#define SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)

sdio1_ck(pc4), sdio1_cmd(pc5), sdio1_d0(pa4), sdio1_d1(pa5), sdio1_d2(pa6), sdio1_d3(pa7)

Definition at line 172 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0110

#define SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)

sdio1_ck(pa2), sdio1_cmd(pa3), sdio1_d0(pc0), sdio1_d1(pc1), sdio1_d2(pc2), sdio1_d3(pc3), sdio1_d4(pa4), sdio1_d5(pa5), sdio1_d6(pa6), sdio1_d7(pa7)

Definition at line 173 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0111

#define SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)

sdio1_ck(pa2), sdio1_cmd(pa3), sdio1_d0(pa4), sdio1_d1(pa5), sdio1_d2(pa6), sdio1_d3(pa7)

Definition at line 174 of file at32f413_gpio.h.

◆ UART4_GMUX_0001

#define UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)

uart4_tx(pf4), uart4_rx(pf5)

Definition at line 177 of file at32f413_gpio.h.

◆ USART1_GMUX_0001

#define USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)

usart1_tx(pb6), usart1_rx(pb7)

Definition at line 175 of file at32f413_gpio.h.

◆ USART3_GMUX_0001

#define USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)

usart3_tx(pc10), usart3_rx(pc11), usart3_ck(pc12), usart3_cts(pb13), usart3_rts(pb14)

Definition at line 176 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map7_definition

Macros
IOMUX_map7_definition
AT32F413_periph_driver » GPIO

iomux map7 definitions More...

Macros

#define | EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)
#define | EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)
#define | ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)
#define | ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)
#define | ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)
#define | ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)
#define | SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)
#define | SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)
#define | SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)
#define | PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)

Detailed Description

iomux map7 definitions

Macro Definition Documentation

◆ ADC1_ETO_GMUX

#define ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)

adc1 external trigger ordinary conversion muxing

Definition at line 191 of file at32f413_gpio.h.

◆ ADC1_ETP_GMUX

#define ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)

adc1 external trigger preempted conversion muxing

Definition at line 190 of file at32f413_gpio.h.

◆ ADC2_ETO_GMUX

#define ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)

adc2 external trigger ordinary conversion muxing

Definition at line 193 of file at32f413_gpio.h.

◆ ADC2_ETP_GMUX

#define ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)

adc2 external trigger preempted conversion muxing

Definition at line 192 of file at32f413_gpio.h.

◆ EXT_SPIM_GMUX_1000

#define EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)

spim_sck(pb1), spim_cs(pa8), spim_io0(pa11), spim_io1(pa12), spim_io2(pb7), spim_sio3(pb6)

Definition at line 188 of file at32f413_gpio.h.

◆ EXT_SPIM_GMUX_1001

#define EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)

spim_sck(pb1), spim_cs(pa8), spim_io0(pb10), spim_io1(pb11), spim_io2(pb7), spim_sio3(pb6)

Definition at line 189 of file at32f413_gpio.h.

◆ PD01_GMUX

#define PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)

pd0/pd1 mapping on osc_in/osc_out

Definition at line 197 of file at32f413_gpio.h.

◆ SWJTAG_GMUX_001

#define SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)

full swj enabled (jtag-dp + sw-dp) but without jtrst

Definition at line 194 of file at32f413_gpio.h.

◆ SWJTAG_GMUX_010

#define SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)

jtag-dp disabled and sw-dp enabled

Definition at line 195 of file at32f413_gpio.h.

◆ SWJTAG_GMUX_100

#define SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)

full swj disabled (jtag-dp + sw-dp)

Definition at line 196 of file at32f413_gpio.h.


AT32F413 Firmwary Library: GPIO_exported_types

Data Structures | Enumerations
GPIO_exported_types
AT32F413_periph_driver » GPIO

Data Structures

struct | gpio_init_type
gpio init type More...
struct | gpio_type
type define gpio register all More...
struct | iomux_type
type define iomux register all More...

Enumerations

enum | gpio_mode_type { GPIO_MODE_INPUT = 0x00 , GPIO_MODE_OUTPUT = 0x10 , GPIO_MODE_MUX = 0x08 , GPIO_MODE_ANALOG = 0x03 }
gpio mode select More...
enum | gpio_drive_type { GPIO_DRIVE_STRENGTH_STRONGER = 0x01 , GPIO_DRIVE_STRENGTH_MODERATE = 0x02 , GPIO_DRIVE_STRENGTH_MAXIMUM = 0x03 }
gpio output drive strength select More...
enum | gpio_output_type { GPIO_OUTPUT_PUSH_PULL = 0x00 , GPIO_OUTPUT_OPEN_DRAIN = 0x04 }
gpio output type More...
enum | gpio_pull_type { GPIO_PULL_NONE = 0x0004 , GPIO_PULL_UP = 0x0018 , GPIO_PULL_DOWN = 0x0028 }
gpio pull type More...
enum gpio_pins_source_type {
GPIO_PINS_SOURCE0 = 0x00 , GPIO_PINS_SOURCE1 = 0x01 , GPIO_PINS_SOURCE2 = 0x02 , GPIO_PINS_SOURCE3 = 0x03 ,
GPIO_PINS_SOURCE4 = 0x04 , GPIO_PINS_SOURCE5 = 0x05 , GPIO_PINS_SOURCE6 = 0x06 , GPIO_PINS_SOURCE7 = 0x07 ,
GPIO_PINS_SOURCE8 = 0x08 , GPIO_PINS_SOURCE9 = 0x09 , GPIO_PINS_SOURCE10 = 0x0A , GPIO_PINS_SOURCE11 = 0x0B ,
GPIO_PINS_SOURCE12 = 0x0C , GPIO_PINS_SOURCE13 = 0x0D , GPIO_PINS_SOURCE14 = 0x0E , GPIO_PINS_SOURCE15 = 0x0F
}
gpio pins source type More...
enum gpio_port_source_type {
GPIO_PORT_SOURCE_GPIOA = 0x00 , GPIO_PORT_SOURCE_GPIOB = 0x01 , GPIO_PORT_SOURCE_GPIOC = 0x02 , GPIO_PORT_SOURCE_GPIOD = 0x03 ,
GPIO_PORT_SOURCE_GPIOF = 0x05
}
gpio port source type More...

Detailed Description

Enumeration Type Documentation

◆ gpio_drive_type

enum gpio_drive_type

gpio output drive strength select

Enumerator
GPIO_DRIVE_STRENGTH_STRONGER | stronger sourcing/sinking strength
GPIO_DRIVE_STRENGTH_MODERATE | moderate sourcing/sinking strength
GPIO_DRIVE_STRENGTH_MAXIMUM | maximum sourcing/sinking strength

Definition at line 221 of file at32f413_gpio.h.

◆ gpio_mode_type

enum gpio_mode_type

gpio mode select

Enumerator
GPIO_MODE_INPUT | gpio input mode
GPIO_MODE_OUTPUT | gpio output mode
GPIO_MODE_MUX | gpio mux function mode
GPIO_MODE_ANALOG | gpio analog in/out mode

Definition at line 210 of file at32f413_gpio.h.

◆ gpio_output_type

enum gpio_output_type

gpio output type

Enumerator
GPIO_OUTPUT_PUSH_PULL | output push-pull
GPIO_OUTPUT_OPEN_DRAIN | output open-drain

Definition at line 231 of file at32f413_gpio.h.

◆ gpio_pins_source_type

enum gpio_pins_source_type

gpio pins source type

Enumerator
GPIO_PINS_SOURCE0 | gpio pins source number 0
GPIO_PINS_SOURCE1 | gpio pins source number 1
GPIO_PINS_SOURCE2 | gpio pins source number 2
GPIO_PINS_SOURCE3 | gpio pins source number 3
GPIO_PINS_SOURCE4 | gpio pins source number 4
GPIO_PINS_SOURCE5 | gpio pins source number 5
GPIO_PINS_SOURCE6 | gpio pins source number 6
GPIO_PINS_SOURCE7 | gpio pins source number 7
GPIO_PINS_SOURCE8 | gpio pins source number 8
GPIO_PINS_SOURCE9 | gpio pins source number 9
GPIO_PINS_SOURCE10 | gpio pins source number 10
GPIO_PINS_SOURCE11 | gpio pins source number 11
GPIO_PINS_SOURCE12 | gpio pins source number 12
GPIO_PINS_SOURCE13 | gpio pins source number 13
GPIO_PINS_SOURCE14 | gpio pins source number 14
GPIO_PINS_SOURCE15 | gpio pins source number 15

Definition at line 250 of file at32f413_gpio.h.

◆ gpio_port_source_type

enum gpio_port_source_type

gpio port source type

Enumerator
GPIO_PORT_SOURCE_GPIOA | gpio port source gpioa
GPIO_PORT_SOURCE_GPIOB | gpio port source gpiob
GPIO_PORT_SOURCE_GPIOC | gpio port source gpioc
GPIO_PORT_SOURCE_GPIOD | gpio port source gpiod
GPIO_PORT_SOURCE_GPIOF | gpio port source gpiof

Definition at line 273 of file at32f413_gpio.h.

◆ gpio_pull_type

enum gpio_pull_type

gpio pull type

Enumerator
GPIO_PULL_NONE | floating for input, no pull for output
GPIO_PULL_UP | pull-up
GPIO_PULL_DOWN | pull-down

Definition at line 240 of file at32f413_gpio.h.


AT32F413 Firmwary Library: gpio_init_type Struct Reference

Data Fields
gpio_init_type Struct Reference
AT32F413_periph_driver » GPIO » GPIO_exported_types

gpio init type More...

#include <at32f413_gpio.h>

Data Fields

uint32_t gpio_pins
gpio_output_type gpio_out_type
gpio_pull_type gpio_pull
gpio_mode_type gpio_mode
gpio_drive_type gpio_drive_strength

Detailed Description

gpio init type

Definition at line 285 of file at32f413_gpio.h.

Field Documentation

◆ gpio_drive_strength

gpio_drive_type gpio_init_type::gpio_drive_strength

drive strength selection

Definition at line 291 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_mode

gpio_mode_type gpio_init_type::gpio_mode

mode selection

Definition at line 290 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_out_type

gpio_output_type gpio_init_type::gpio_out_type

output type selection

Definition at line 288 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_pins

uint32_t gpio_init_type::gpio_pins

pins number selection

Definition at line 287 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_pull

gpio_pull_type gpio_init_type::gpio_pull

pull type selection

Definition at line 289 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_gpio.h


AT32F413 Firmwary Library: gpio_type Struct Reference

Data Fields
gpio_type Struct Reference
AT32F413_periph_driver » GPIO » GPIO_exported_types

type define gpio register all More...

#include <at32f413_gpio.h>

Data Fields

union {
__IO uint32_t cfglr
struct {
__IO uint32_t iomc0: 2
__IO uint32_t iofc0: 2
__IO uint32_t iomc1: 2
__IO uint32_t iofc1: 2
__IO uint32_t iomc2: 2
__IO uint32_t iofc2: 2
__IO uint32_t iomc3: 2
__IO uint32_t iofc3: 2
__IO uint32_t iomc4: 2
__IO uint32_t iofc4: 2
__IO uint32_t iomc5: 2
__IO uint32_t iofc5: 2
__IO uint32_t iomc6: 2
__IO uint32_t iofc6: 2
__IO uint32_t iomc7: 2
__IO uint32_t iofc7: 2
} cfglr_bit
};
gpio cfglr register, offset:0x00 More...
union {
__IO uint32_t cfghr
struct {
__IO uint32_t iomc8: 2
__IO uint32_t iofc8: 2
__IO uint32_t iomc9: 2
__IO uint32_t iofc9: 2
__IO uint32_t iomc10: 2
__IO uint32_t iofc10: 2
__IO uint32_t iomc11: 2
__IO uint32_t iofc11: 2
__IO uint32_t iomc12: 2
__IO uint32_t iofc12: 2
__IO uint32_t iomc13: 2
__IO uint32_t iofc13: 2
__IO uint32_t iomc14: 2
__IO uint32_t iofc14: 2
__IO uint32_t iomc15: 2
__IO uint32_t iofc15: 2
} cfghr_bit
};
gpio cfghr register, offset:0x04 More...
union {
__IO uint32_t idt
struct {
__IO uint32_t idt0: 1
__IO uint32_t idt1: 1
__IO uint32_t idt2: 1
__IO uint32_t idt3: 1
__IO uint32_t idt4: 1
__IO uint32_t idt5: 1
__IO uint32_t idt6: 1
__IO uint32_t idt7: 1
__IO uint32_t idt8: 1
__IO uint32_t idt9: 1
__IO uint32_t idt10: 1
__IO uint32_t idt11: 1
__IO uint32_t idt12: 1
__IO uint32_t idt13: 1
__IO uint32_t idt14: 1
__IO uint32_t idt15: 1
__IO uint32_t reserved1: 16
} idt_bit
};
gpio idt register, offset:0x08 More...
union {
__IO uint32_t odt
struct {
__IO uint32_t odt0: 1
__IO uint32_t odt1: 1
__IO uint32_t odt2: 1
__IO uint32_t odt3: 1
__IO uint32_t odt4: 1
__IO uint32_t odt5: 1
__IO uint32_t odt6: 1
__IO uint32_t odt7: 1
__IO uint32_t odt8: 1
__IO uint32_t odt9: 1
__IO uint32_t odt10: 1
__IO uint32_t odt11: 1
__IO uint32_t odt12: 1
__IO uint32_t odt13: 1
__IO uint32_t odt14: 1
__IO uint32_t odt15: 1
__IO uint32_t reserved1: 16
} odt_bit
};
gpio odt register, offset:0x0C More...
union {
__IO uint32_t scr
struct {
__IO uint32_t iosb0: 1
__IO uint32_t iosb1: 1
__IO uint32_t iosb2: 1
__IO uint32_t iosb3: 1
__IO uint32_t iosb4: 1
__IO uint32_t iosb5: 1
__IO uint32_t iosb6: 1
__IO uint32_t iosb7: 1
__IO uint32_t iosb8: 1
__IO uint32_t iosb9: 1
__IO uint32_t iosb10: 1
__IO uint32_t iosb11: 1
__IO uint32_t iosb12: 1
__IO uint32_t iosb13: 1
__IO uint32_t iosb14: 1
__IO uint32_t iosb15: 1
__IO uint32_t iocb0: 1
__IO uint32_t iocb1: 1
__IO uint32_t iocb2: 1
__IO uint32_t iocb3: 1
__IO uint32_t iocb4: 1
__IO uint32_t iocb5: 1
__IO uint32_t iocb6: 1
__IO uint32_t iocb7: 1
__IO uint32_t iocb8: 1
__IO uint32_t iocb9: 1
__IO uint32_t iocb10: 1
__IO uint32_t iocb11: 1
__IO uint32_t iocb12: 1
__IO uint32_t iocb13: 1
__IO uint32_t iocb14: 1
__IO uint32_t iocb15: 1
} scr_bit
};
gpio scr register, offset:0x10 More...
union {
__IO uint32_t clr
struct {
__IO uint32_t iocb0: 1
__IO uint32_t iocb1: 1
__IO uint32_t iocb2: 1
__IO uint32_t iocb3: 1
__IO uint32_t iocb4: 1
__IO uint32_t iocb5: 1
__IO uint32_t iocb6: 1
__IO uint32_t iocb7: 1
__IO uint32_t iocb8: 1
__IO uint32_t iocb9: 1
__IO uint32_t iocb10: 1
__IO uint32_t iocb11: 1
__IO uint32_t iocb12: 1
__IO uint32_t iocb13: 1
__IO uint32_t iocb14: 1
__IO uint32_t iocb15: 1
__IO uint32_t reserved1: 16
} clr_bit
};
gpio clr register, offset:0x14 More...
union {
__IO uint32_t wpr
struct {
__IO uint32_t wpen0: 1
__IO uint32_t wpen1: 1
__IO uint32_t wpen2: 1
__IO uint32_t wpen3: 1
__IO uint32_t wpen4: 1
__IO uint32_t wpen5: 1
__IO uint32_t wpen6: 1
__IO uint32_t wpen7: 1
__IO uint32_t wpen8: 1
__IO uint32_t wpen9: 1
__IO uint32_t wpen10: 1
__IO uint32_t wpen11: 1
__IO uint32_t wpen12: 1
__IO uint32_t wpen13: 1
__IO uint32_t wpen14: 1
__IO uint32_t wpen15: 1
__IO uint32_t wpseq: 1
__IO uint32_t reserved1: 15
} wpr_bit
};
gpio wpr register, offset:0x18 More...

Detailed Description

type define gpio register all

Definition at line 297 of file at32f413_gpio.h.

Field Documentation

◆

union { ... } gpio_type::@451

gpio cfglr register, offset:0x00

◆

union { ... } gpio_type::@453

gpio cfghr register, offset:0x04

◆

union { ... } gpio_type::@455

gpio idt register, offset:0x08

◆

union { ... } gpio_type::@457

gpio odt register, offset:0x0C

◆

union { ... } gpio_type::@459

gpio scr register, offset:0x10

◆

union { ... } gpio_type::@461

gpio clr register, offset:0x14

◆

union { ... } gpio_type::@463

gpio wpr register, offset:0x18

◆ cfghr

__IO uint32_t gpio_type::cfghr

Definition at line 331 of file at32f413_gpio.h.

Referenced by gpio_init().

◆

struct { ... } gpio_type::cfghr_bit

◆ cfglr

__IO uint32_t gpio_type::cfglr

Definition at line 304 of file at32f413_gpio.h.

Referenced by gpio_init().

◆

struct { ... } gpio_type::cfglr_bit

◆ clr

__IO uint32_t gpio_type::clr

Definition at line 457 of file at32f413_gpio.h.

Referenced by at32_led_on(), gpio_bits_reset(), gpio_bits_write(), and gpio_init().

◆

struct { ... } gpio_type::clr_bit

◆ idt

__IO uint32_t gpio_type::idt

Definition at line 358 of file at32f413_gpio.h.

Referenced by gpio_input_data_bit_read(), and gpio_input_data_read().

◆ idt0

__IO uint32_t gpio_type::idt0

Definition at line 361 of file at32f413_gpio.h.

◆ idt1

__IO uint32_t gpio_type::idt1

Definition at line 362 of file at32f413_gpio.h.

◆ idt10

__IO uint32_t gpio_type::idt10

Definition at line 371 of file at32f413_gpio.h.

◆ idt11

__IO uint32_t gpio_type::idt11

Definition at line 372 of file at32f413_gpio.h.

◆ idt12

__IO uint32_t gpio_type::idt12

Definition at line 373 of file at32f413_gpio.h.

◆ idt13

__IO uint32_t gpio_type::idt13

Definition at line 374 of file at32f413_gpio.h.

◆ idt14

__IO uint32_t gpio_type::idt14

Definition at line 375 of file at32f413_gpio.h.

◆ idt15

__IO uint32_t gpio_type::idt15

Definition at line 376 of file at32f413_gpio.h.

◆ idt2

__IO uint32_t gpio_type::idt2

Definition at line 363 of file at32f413_gpio.h.

◆ idt3

__IO uint32_t gpio_type::idt3

Definition at line 364 of file at32f413_gpio.h.

◆ idt4

__IO uint32_t gpio_type::idt4

Definition at line 365 of file at32f413_gpio.h.

◆ idt5

__IO uint32_t gpio_type::idt5

Definition at line 366 of file at32f413_gpio.h.

◆ idt6

__IO uint32_t gpio_type::idt6

Definition at line 367 of file at32f413_gpio.h.

◆ idt7

__IO uint32_t gpio_type::idt7

Definition at line 368 of file at32f413_gpio.h.

◆ idt8

__IO uint32_t gpio_type::idt8

Definition at line 369 of file at32f413_gpio.h.

◆ idt9

__IO uint32_t gpio_type::idt9

Definition at line 370 of file at32f413_gpio.h.

◆

struct { ... } gpio_type::idt_bit

◆ iocb0

__IO uint32_t gpio_type::iocb0

Definition at line 433 of file at32f413_gpio.h.

◆ iocb1

__IO uint32_t gpio_type::iocb1

Definition at line 434 of file at32f413_gpio.h.

◆ iocb10

__IO uint32_t gpio_type::iocb10

Definition at line 443 of file at32f413_gpio.h.

◆ iocb11

__IO uint32_t gpio_type::iocb11

Definition at line 444 of file at32f413_gpio.h.

◆ iocb12

__IO uint32_t gpio_type::iocb12

Definition at line 445 of file at32f413_gpio.h.

◆ iocb13

__IO uint32_t gpio_type::iocb13

Definition at line 446 of file at32f413_gpio.h.

◆ iocb14

__IO uint32_t gpio_type::iocb14

Definition at line 447 of file at32f413_gpio.h.

◆ iocb15

__IO uint32_t gpio_type::iocb15

Definition at line 448 of file at32f413_gpio.h.

◆ iocb2

__IO uint32_t gpio_type::iocb2

Definition at line 435 of file at32f413_gpio.h.

◆ iocb3

__IO uint32_t gpio_type::iocb3

Definition at line 436 of file at32f413_gpio.h.

◆ iocb4

__IO uint32_t gpio_type::iocb4

Definition at line 437 of file at32f413_gpio.h.

◆ iocb5

__IO uint32_t gpio_type::iocb5

Definition at line 438 of file at32f413_gpio.h.

◆ iocb6

__IO uint32_t gpio_type::iocb6

Definition at line 439 of file at32f413_gpio.h.

◆ iocb7

__IO uint32_t gpio_type::iocb7

Definition at line 440 of file at32f413_gpio.h.

◆ iocb8

__IO uint32_t gpio_type::iocb8

Definition at line 441 of file at32f413_gpio.h.

◆ iocb9

__IO uint32_t gpio_type::iocb9

Definition at line 442 of file at32f413_gpio.h.

◆ iofc0

__IO uint32_t gpio_type::iofc0

Definition at line 308 of file at32f413_gpio.h.

◆ iofc1

__IO uint32_t gpio_type::iofc1

Definition at line 310 of file at32f413_gpio.h.

◆ iofc10

__IO uint32_t gpio_type::iofc10

Definition at line 339 of file at32f413_gpio.h.

◆ iofc11

__IO uint32_t gpio_type::iofc11

Definition at line 341 of file at32f413_gpio.h.

◆ iofc12

__IO uint32_t gpio_type::iofc12

Definition at line 343 of file at32f413_gpio.h.

◆ iofc13

__IO uint32_t gpio_type::iofc13

Definition at line 345 of file at32f413_gpio.h.

◆ iofc14

__IO uint32_t gpio_type::iofc14

Definition at line 347 of file at32f413_gpio.h.

◆ iofc15

__IO uint32_t gpio_type::iofc15

Definition at line 349 of file at32f413_gpio.h.

◆ iofc2

__IO uint32_t gpio_type::iofc2

Definition at line 312 of file at32f413_gpio.h.

◆ iofc3

__IO uint32_t gpio_type::iofc3

Definition at line 314 of file at32f413_gpio.h.

◆ iofc4

__IO uint32_t gpio_type::iofc4

Definition at line 316 of file at32f413_gpio.h.

◆ iofc5

__IO uint32_t gpio_type::iofc5

Definition at line 318 of file at32f413_gpio.h.

◆ iofc6

__IO uint32_t gpio_type::iofc6

Definition at line 320 of file at32f413_gpio.h.

◆ iofc7

__IO uint32_t gpio_type::iofc7

Definition at line 322 of file at32f413_gpio.h.

◆ iofc8

__IO uint32_t gpio_type::iofc8

Definition at line 335 of file at32f413_gpio.h.

◆ iofc9

__IO uint32_t gpio_type::iofc9

Definition at line 337 of file at32f413_gpio.h.

◆ iomc0

__IO uint32_t gpio_type::iomc0

Definition at line 307 of file at32f413_gpio.h.

◆ iomc1

__IO uint32_t gpio_type::iomc1

Definition at line 309 of file at32f413_gpio.h.

◆ iomc10

__IO uint32_t gpio_type::iomc10

Definition at line 338 of file at32f413_gpio.h.

◆ iomc11

__IO uint32_t gpio_type::iomc11

Definition at line 340 of file at32f413_gpio.h.

◆ iomc12

__IO uint32_t gpio_type::iomc12

Definition at line 342 of file at32f413_gpio.h.

◆ iomc13

__IO uint32_t gpio_type::iomc13

Definition at line 344 of file at32f413_gpio.h.

◆ iomc14

__IO uint32_t gpio_type::iomc14

Definition at line 346 of file at32f413_gpio.h.

◆ iomc15

__IO uint32_t gpio_type::iomc15

Definition at line 348 of file at32f413_gpio.h.

◆ iomc2

__IO uint32_t gpio_type::iomc2

Definition at line 311 of file at32f413_gpio.h.

◆ iomc3

__IO uint32_t gpio_type::iomc3

Definition at line 313 of file at32f413_gpio.h.

◆ iomc4

__IO uint32_t gpio_type::iomc4

Definition at line 315 of file at32f413_gpio.h.

◆ iomc5

__IO uint32_t gpio_type::iomc5

Definition at line 317 of file at32f413_gpio.h.

◆ iomc6

__IO uint32_t gpio_type::iomc6

Definition at line 319 of file at32f413_gpio.h.

◆ iomc7

__IO uint32_t gpio_type::iomc7

Definition at line 321 of file at32f413_gpio.h.

◆ iomc8

__IO uint32_t gpio_type::iomc8

Definition at line 334 of file at32f413_gpio.h.

◆ iomc9

__IO uint32_t gpio_type::iomc9

Definition at line 336 of file at32f413_gpio.h.

◆ iosb0

__IO uint32_t gpio_type::iosb0

Definition at line 417 of file at32f413_gpio.h.

◆ iosb1

__IO uint32_t gpio_type::iosb1

Definition at line 418 of file at32f413_gpio.h.

◆ iosb10

__IO uint32_t gpio_type::iosb10

Definition at line 427 of file at32f413_gpio.h.

◆ iosb11

__IO uint32_t gpio_type::iosb11

Definition at line 428 of file at32f413_gpio.h.

◆ iosb12

__IO uint32_t gpio_type::iosb12

Definition at line 429 of file at32f413_gpio.h.

◆ iosb13

__IO uint32_t gpio_type::iosb13

Definition at line 430 of file at32f413_gpio.h.

◆ iosb14

__IO uint32_t gpio_type::iosb14

Definition at line 431 of file at32f413_gpio.h.

◆ iosb15

__IO uint32_t gpio_type::iosb15

Definition at line 432 of file at32f413_gpio.h.

◆ iosb2

__IO uint32_t gpio_type::iosb2

Definition at line 419 of file at32f413_gpio.h.

◆ iosb3

__IO uint32_t gpio_type::iosb3

Definition at line 420 of file at32f413_gpio.h.

◆ iosb4

__IO uint32_t gpio_type::iosb4

Definition at line 421 of file at32f413_gpio.h.

◆ iosb5

__IO uint32_t gpio_type::iosb5

Definition at line 422 of file at32f413_gpio.h.

◆ iosb6

__IO uint32_t gpio_type::iosb6

Definition at line 423 of file at32f413_gpio.h.

◆ iosb7

__IO uint32_t gpio_type::iosb7

Definition at line 424 of file at32f413_gpio.h.

◆ iosb8

__IO uint32_t gpio_type::iosb8

Definition at line 425 of file at32f413_gpio.h.

◆ iosb9

__IO uint32_t gpio_type::iosb9

Definition at line 426 of file at32f413_gpio.h.

◆ odt

__IO uint32_t gpio_type::odt

Definition at line 386 of file at32f413_gpio.h.

Referenced by at32_led_toggle(), gpio_output_data_bit_read(), gpio_output_data_read(), gpio_pins_toggle(), and gpio_port_write().

◆ odt0

__IO uint32_t gpio_type::odt0

Definition at line 389 of file at32f413_gpio.h.

◆ odt1

__IO uint32_t gpio_type::odt1

Definition at line 390 of file at32f413_gpio.h.

◆ odt10

__IO uint32_t gpio_type::odt10

Definition at line 399 of file at32f413_gpio.h.

◆ odt11

__IO uint32_t gpio_type::odt11

Definition at line 400 of file at32f413_gpio.h.

◆ odt12

__IO uint32_t gpio_type::odt12

Definition at line 401 of file at32f413_gpio.h.

◆ odt13

__IO uint32_t gpio_type::odt13

Definition at line 402 of file at32f413_gpio.h.

◆ odt14

__IO uint32_t gpio_type::odt14

Definition at line 403 of file at32f413_gpio.h.

◆ odt15

__IO uint32_t gpio_type::odt15

Definition at line 404 of file at32f413_gpio.h.

◆ odt2

__IO uint32_t gpio_type::odt2

Definition at line 391 of file at32f413_gpio.h.

◆ odt3

__IO uint32_t gpio_type::odt3

Definition at line 392 of file at32f413_gpio.h.

◆ odt4

__IO uint32_t gpio_type::odt4

Definition at line 393 of file at32f413_gpio.h.

◆ odt5

__IO uint32_t gpio_type::odt5

Definition at line 394 of file at32f413_gpio.h.

◆ odt6

__IO uint32_t gpio_type::odt6

Definition at line 395 of file at32f413_gpio.h.

◆ odt7

__IO uint32_t gpio_type::odt7

Definition at line 396 of file at32f413_gpio.h.

◆ odt8

__IO uint32_t gpio_type::odt8

Definition at line 397 of file at32f413_gpio.h.

◆ odt9

__IO uint32_t gpio_type::odt9

Definition at line 398 of file at32f413_gpio.h.

◆

struct { ... } gpio_type::odt_bit

◆ reserved1

__IO uint32_t gpio_type::reserved1

Definition at line 377 of file at32f413_gpio.h.

◆ scr

__IO uint32_t gpio_type::scr

Definition at line 414 of file at32f413_gpio.h.

Referenced by at32_led_off(), gpio_bits_set(), gpio_bits_write(), and gpio_init().

◆

struct { ... } gpio_type::scr_bit

◆ wpen0

__IO uint32_t gpio_type::wpen0

Definition at line 488 of file at32f413_gpio.h.

◆ wpen1

__IO uint32_t gpio_type::wpen1

Definition at line 489 of file at32f413_gpio.h.

◆ wpen10

__IO uint32_t gpio_type::wpen10

Definition at line 498 of file at32f413_gpio.h.

◆ wpen11

__IO uint32_t gpio_type::wpen11

Definition at line 499 of file at32f413_gpio.h.

◆ wpen12

__IO uint32_t gpio_type::wpen12

Definition at line 500 of file at32f413_gpio.h.

◆ wpen13

__IO uint32_t gpio_type::wpen13

Definition at line 501 of file at32f413_gpio.h.

◆ wpen14

__IO uint32_t gpio_type::wpen14

Definition at line 502 of file at32f413_gpio.h.

◆ wpen15

__IO uint32_t gpio_type::wpen15

Definition at line 503 of file at32f413_gpio.h.

◆ wpen2

__IO uint32_t gpio_type::wpen2

Definition at line 490 of file at32f413_gpio.h.

◆ wpen3

__IO uint32_t gpio_type::wpen3

Definition at line 491 of file at32f413_gpio.h.

◆ wpen4

__IO uint32_t gpio_type::wpen4

Definition at line 492 of file at32f413_gpio.h.

◆ wpen5

__IO uint32_t gpio_type::wpen5

Definition at line 493 of file at32f413_gpio.h.

◆ wpen6

__IO uint32_t gpio_type::wpen6

Definition at line 494 of file at32f413_gpio.h.

◆ wpen7

__IO uint32_t gpio_type::wpen7

Definition at line 495 of file at32f413_gpio.h.

◆ wpen8

__IO uint32_t gpio_type::wpen8

Definition at line 496 of file at32f413_gpio.h.

◆ wpen9

__IO uint32_t gpio_type::wpen9

Definition at line 497 of file at32f413_gpio.h.

◆ wpr

__IO uint32_t gpio_type::wpr

Definition at line 485 of file at32f413_gpio.h.

Referenced by gpio_pin_wp_config().

◆

struct { ... } gpio_type::wpr_bit

◆ wpseq

__IO uint32_t gpio_type::wpseq

Definition at line 504 of file at32f413_gpio.h.

The documentation for this struct was generated from the following file:
  • at32f413_gpio.h


AT32F413 Firmwary Library: iomux_type Struct Reference

Data Fields
iomux_type Struct Reference
AT32F413_periph_driver » GPIO » GPIO_exported_types

type define iomux register all More...

#include <at32f413_gpio.h>

Data Fields

union {
__IO uint32_t evtout
struct {
__IO uint32_t selpin: 4
__IO uint32_t selport: 3
__IO uint32_t evoen: 1
__IO uint32_t reserved1: 24
} evtout_bit
};
mux event control register, offset:0x00 More...
union {
__IO uint32_t remap
struct {
__IO uint32_t spi1_mux_l: 1
__IO uint32_t i2c1_mux: 1
__IO uint32_t usart1_mux: 1
__IO uint32_t reserved1: 1
__IO uint32_t usart3_mux: 2
__IO uint32_t tmr1_mux: 2
__IO uint32_t tmr2_mux: 2
__IO uint32_t tmr3_mux: 2
__IO uint32_t reserved2: 1
__IO uint32_t can_mux: 2
__IO uint32_t pd01_mux: 1
__IO uint32_t tmr5ch4_mux: 1
__IO uint32_t adc1_extrgpre_mux: 1
__IO uint32_t adc1_extrgord_mux: 1
__IO uint32_t adc2_extrgpre_mux: 1
__IO uint32_t adc2_extrgord_mux: 1
__IO uint32_t reserved3: 3
__IO uint32_t swjtag_conf: 3
__IO uint32_t reserved4: 4
__IO uint32_t spi1_mux_h: 1
} remap_bit
};
iomux remap register, offset:0x04 More...
union {
__IO uint32_t exintc1
struct {
__IO uint32_t exint0: 4
__IO uint32_t exint1: 4
__IO uint32_t exint2: 4
__IO uint32_t exint3: 4
__IO uint32_t reserved1: 16
} exintc1_bit
};
mux external interrupt configuration register 1, offset:0x08 More...
union {
__IO uint32_t exintc2
struct {
__IO uint32_t exint4: 4
__IO uint32_t exint5: 4
__IO uint32_t exint6: 4
__IO uint32_t exint7: 4
__IO uint32_t reserved1: 16
} exintc2_bit
};
mux external interrupt configuration register 2, offset:0x0c More...
union {
__IO uint32_t exintc3
struct {
__IO uint32_t exint8: 4
__IO uint32_t exint9: 4
__IO uint32_t exint10: 4
__IO uint32_t exint11: 4
__IO uint32_t reserved1: 16
} exintc3_bit
};
mux external interrupt configuration register 3, offset:0x10 More...
union {
__IO uint32_t exintc4
struct {
__IO uint32_t exint12: 4
__IO uint32_t exint13: 4
__IO uint32_t exint14: 4
__IO uint32_t exint15: 4
__IO uint32_t reserved1: 16
} exintc4_bit
};
mux external interrupt configuration register 4, offset:0x14 More...
union {
__IO uint32_t remap2
struct {
__IO uint32_t reserved1: 21
__IO uint32_t ext_spim_en_mux: 1
__IO uint32_t reserved2: 10
} remap2_bit
};
iomux remap register 2, offset:0x1C More...
union {
__IO uint32_t remap3
struct {
__IO uint32_t tmr9_gmux: 4
__IO uint32_t tmr10_gmux: 4
__IO uint32_t tmr11_gmux: 4
__IO uint32_t reserved1: 20
} remap3_bit
};
iomux remap register 3, offset:0x20 More...
union {
__IO uint32_t remap4
struct {
__IO uint32_t tmr1_gmux: 4
__IO uint32_t tmr2_gmux: 3
__IO uint32_t tmr2itr1_gmux: 1
__IO uint32_t tmr3_gmux: 4
__IO uint32_t reserved1: 4
__IO uint32_t tmr5_gmux: 3
__IO uint32_t tmr5ch4_gmux: 1
__IO uint32_t reserved2: 12
} remap4_bit
};
iomux remap register 4, offset:0x24 More...
union {
__IO uint32_t remap5
struct {
__IO uint32_t reserved1: 4
__IO uint32_t i2c1_gmux: 4
__IO uint32_t i2c2_gmux: 4
__IO uint32_t reserved2: 4
__IO uint32_t spi1_gmux: 4
__IO uint32_t spi2_gmux: 4
__IO uint32_t reserved3: 8
} remap5_bit
};
iomux remap register 5, offset:0x28 More...
union {
__IO uint32_t remap6
struct {
__IO uint32_t can1_gmux: 4
__IO uint32_t can2_gmux: 4
__IO uint32_t sdio1_gmux: 4
__IO uint32_t reserved1: 4
__IO uint32_t usart1_gmux: 4
__IO uint32_t reserved2: 4
__IO uint32_t usart3_gmux: 4
__IO uint32_t uart4_gmux: 4
} remap6_bit
};
iomux remap register 6, offset:0x2C More...
union {
__IO uint32_t remap7
struct {
__IO uint32_t ext_spim_gmux: 3
__IO uint32_t ext_spim_gen: 1
__IO uint32_t adc1_etp_gmux: 1
__IO uint32_t adc1_eto_gmux: 1
__IO uint32_t reserved1: 2
__IO uint32_t adc2_etp_gmux: 1
__IO uint32_t adc2_eto_gmux: 1
__IO uint32_t reserved2: 6
__IO uint32_t swjtag_gmux: 3
__IO uint32_t reserved3: 1
__IO uint32_t pd01_gmux: 1
__IO uint32_t reserved4: 11
} remap7_bit
};
iomux remap register 7, offset:0x30 More...

Detailed Description

type define iomux register all

Definition at line 514 of file at32f413_gpio.h.

Field Documentation

◆

union { ... } iomux_type::@472

mux event control register, offset:0x00

◆

union { ... } iomux_type::@474

iomux remap register, offset:0x04

◆

union { ... } iomux_type::@476

mux external interrupt configuration register 1, offset:0x08

◆

union { ... } iomux_type::@478

mux external interrupt configuration register 2, offset:0x0c

◆

union { ... } iomux_type::@480

mux external interrupt configuration register 3, offset:0x10

◆

union { ... } iomux_type::@482

mux external interrupt configuration register 4, offset:0x14

◆

union { ... } iomux_type::@484

iomux remap register 2, offset:0x1C

◆

union { ... } iomux_type::@486

iomux remap register 3, offset:0x20

◆

union { ... } iomux_type::@488

iomux remap register 4, offset:0x24

◆

union { ... } iomux_type::@490

iomux remap register 5, offset:0x28

◆

union { ... } iomux_type::@492

iomux remap register 6, offset:0x2C

◆

union { ... } iomux_type::@494

iomux remap register 7, offset:0x30

◆ adc1_eto_gmux

__IO uint32_t iomux_type::adc1_eto_gmux

Definition at line 727 of file at32f413_gpio.h.

◆ adc1_etp_gmux

__IO uint32_t iomux_type::adc1_etp_gmux

Definition at line 726 of file at32f413_gpio.h.

◆ adc1_extrgord_mux

__IO uint32_t iomux_type::adc1_extrgord_mux

Definition at line 552 of file at32f413_gpio.h.

◆ adc1_extrgpre_mux

__IO uint32_t iomux_type::adc1_extrgpre_mux

Definition at line 551 of file at32f413_gpio.h.

◆ adc2_eto_gmux

__IO uint32_t iomux_type::adc2_eto_gmux

Definition at line 730 of file at32f413_gpio.h.

◆ adc2_etp_gmux

__IO uint32_t iomux_type::adc2_etp_gmux

Definition at line 729 of file at32f413_gpio.h.

◆ adc2_extrgord_mux

__IO uint32_t iomux_type::adc2_extrgord_mux

Definition at line 554 of file at32f413_gpio.h.

◆ adc2_extrgpre_mux

__IO uint32_t iomux_type::adc2_extrgpre_mux

Definition at line 553 of file at32f413_gpio.h.

◆ can1_gmux

__IO uint32_t iomux_type::can1_gmux

Definition at line 705 of file at32f413_gpio.h.

◆ can2_gmux

__IO uint32_t iomux_type::can2_gmux

Definition at line 706 of file at32f413_gpio.h.

◆ can_mux

__IO uint32_t iomux_type::can_mux

Definition at line 548 of file at32f413_gpio.h.

◆ evoen

__IO uint32_t iomux_type::evoen

Definition at line 526 of file at32f413_gpio.h.

◆ evtout

__IO uint32_t iomux_type::evtout

Definition at line 521 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::evtout_bit

◆ exint0

__IO uint32_t iomux_type::exint0

Definition at line 570 of file at32f413_gpio.h.

◆ exint1

__IO uint32_t iomux_type::exint1

Definition at line 571 of file at32f413_gpio.h.

◆ exint10

__IO uint32_t iomux_type::exint10

Definition at line 604 of file at32f413_gpio.h.

◆ exint11

__IO uint32_t iomux_type::exint11

Definition at line 605 of file at32f413_gpio.h.

◆ exint12

__IO uint32_t iomux_type::exint12

Definition at line 618 of file at32f413_gpio.h.

◆ exint13

__IO uint32_t iomux_type::exint13

Definition at line 619 of file at32f413_gpio.h.

◆ exint14

__IO uint32_t iomux_type::exint14

Definition at line 620 of file at32f413_gpio.h.

◆ exint15

__IO uint32_t iomux_type::exint15

Definition at line 621 of file at32f413_gpio.h.

◆ exint2

__IO uint32_t iomux_type::exint2

Definition at line 572 of file at32f413_gpio.h.

◆ exint3

__IO uint32_t iomux_type::exint3

Definition at line 573 of file at32f413_gpio.h.

◆ exint4

__IO uint32_t iomux_type::exint4

Definition at line 586 of file at32f413_gpio.h.

◆ exint5

__IO uint32_t iomux_type::exint5

Definition at line 587 of file at32f413_gpio.h.

◆ exint6

__IO uint32_t iomux_type::exint6

Definition at line 588 of file at32f413_gpio.h.

◆ exint7

__IO uint32_t iomux_type::exint7

Definition at line 589 of file at32f413_gpio.h.

◆ exint8

__IO uint32_t iomux_type::exint8

Definition at line 602 of file at32f413_gpio.h.

◆ exint9

__IO uint32_t iomux_type::exint9

Definition at line 603 of file at32f413_gpio.h.

◆ exintc1

__IO uint32_t iomux_type::exintc1

Definition at line 567 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc1_bit

◆ exintc2

__IO uint32_t iomux_type::exintc2

Definition at line 583 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc2_bit

◆ exintc3

__IO uint32_t iomux_type::exintc3

Definition at line 599 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc3_bit

◆ exintc4

__IO uint32_t iomux_type::exintc4

Definition at line 615 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc4_bit

◆ ext_spim_en_mux

__IO uint32_t iomux_type::ext_spim_en_mux

Definition at line 640 of file at32f413_gpio.h.

◆ ext_spim_gen

__IO uint32_t iomux_type::ext_spim_gen

Definition at line 725 of file at32f413_gpio.h.

◆ ext_spim_gmux

__IO uint32_t iomux_type::ext_spim_gmux

Definition at line 724 of file at32f413_gpio.h.

◆ i2c1_gmux

__IO uint32_t iomux_type::i2c1_gmux

Definition at line 688 of file at32f413_gpio.h.

◆ i2c1_mux

__IO uint32_t iomux_type::i2c1_mux

Definition at line 540 of file at32f413_gpio.h.

◆ i2c2_gmux

__IO uint32_t iomux_type::i2c2_gmux

Definition at line 689 of file at32f413_gpio.h.

◆ pd01_gmux

__IO uint32_t iomux_type::pd01_gmux

Definition at line 734 of file at32f413_gpio.h.

◆ pd01_mux

__IO uint32_t iomux_type::pd01_mux

Definition at line 549 of file at32f413_gpio.h.

◆ remap

__IO uint32_t iomux_type::remap

Definition at line 536 of file at32f413_gpio.h.

◆ remap2

__IO uint32_t iomux_type::remap2

Definition at line 636 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap2_bit

◆ remap3

__IO uint32_t iomux_type::remap3

Definition at line 650 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap3_bit

◆ remap4

__IO uint32_t iomux_type::remap4

Definition at line 665 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap4_bit

◆ remap5

__IO uint32_t iomux_type::remap5

Definition at line 684 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap5_bit

◆ remap6

__IO uint32_t iomux_type::remap6

Definition at line 702 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap6_bit

◆ remap7

__IO uint32_t iomux_type::remap7

Definition at line 721 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap7_bit

◆

struct { ... } iomux_type::remap_bit

◆ reserved1

__IO uint32_t iomux_type::reserved1

iomux reserved1 register, offset:0x18

Definition at line 527 of file at32f413_gpio.h.

◆ reserved2

__IO uint32_t iomux_type::reserved2

Definition at line 547 of file at32f413_gpio.h.

◆ reserved3

__IO uint32_t iomux_type::reserved3

Definition at line 555 of file at32f413_gpio.h.

◆ reserved4

__IO uint32_t iomux_type::reserved4

Definition at line 557 of file at32f413_gpio.h.

◆ sdio1_gmux

__IO uint32_t iomux_type::sdio1_gmux

Definition at line 707 of file at32f413_gpio.h.

◆ selpin

__IO uint32_t iomux_type::selpin

Definition at line 524 of file at32f413_gpio.h.

◆ selport

__IO uint32_t iomux_type::selport

Definition at line 525 of file at32f413_gpio.h.

◆ spi1_gmux

__IO uint32_t iomux_type::spi1_gmux

Definition at line 691 of file at32f413_gpio.h.

◆ spi1_mux_h

__IO uint32_t iomux_type::spi1_mux_h

Definition at line 558 of file at32f413_gpio.h.

◆ spi1_mux_l

__IO uint32_t iomux_type::spi1_mux_l

Definition at line 539 of file at32f413_gpio.h.

◆ spi2_gmux

__IO uint32_t iomux_type::spi2_gmux

Definition at line 692 of file at32f413_gpio.h.

◆ swjtag_conf

__IO uint32_t iomux_type::swjtag_conf

Definition at line 556 of file at32f413_gpio.h.

◆ swjtag_gmux

__IO uint32_t iomux_type::swjtag_gmux

Definition at line 732 of file at32f413_gpio.h.

◆ tmr10_gmux

__IO uint32_t iomux_type::tmr10_gmux

Definition at line 654 of file at32f413_gpio.h.

◆ tmr11_gmux

__IO uint32_t iomux_type::tmr11_gmux

Definition at line 655 of file at32f413_gpio.h.

◆ tmr1_gmux

__IO uint32_t iomux_type::tmr1_gmux

Definition at line 668 of file at32f413_gpio.h.

◆ tmr1_mux

__IO uint32_t iomux_type::tmr1_mux

Definition at line 544 of file at32f413_gpio.h.

◆ tmr2_gmux

__IO uint32_t iomux_type::tmr2_gmux

Definition at line 669 of file at32f413_gpio.h.

◆ tmr2_mux

__IO uint32_t iomux_type::tmr2_mux

Definition at line 545 of file at32f413_gpio.h.

◆ tmr2itr1_gmux

__IO uint32_t iomux_type::tmr2itr1_gmux

Definition at line 670 of file at32f413_gpio.h.

◆ tmr3_gmux

__IO uint32_t iomux_type::tmr3_gmux

Definition at line 671 of file at32f413_gpio.h.

◆ tmr3_mux

__IO uint32_t iomux_type::tmr3_mux

Definition at line 546 of file at32f413_gpio.h.

◆ tmr5_gmux

__IO uint32_t iomux_type::tmr5_gmux

Definition at line 673 of file at32f413_gpio.h.

◆ tmr5ch4_gmux

__IO uint32_t iomux_type::tmr5ch4_gmux

Definition at line 674 of file at32f413_gpio.h.

◆ tmr5ch4_mux

__IO uint32_t iomux_type::tmr5ch4_mux

Definition at line 550 of file at32f413_gpio.h.

◆ tmr9_gmux

__IO uint32_t iomux_type::tmr9_gmux

Definition at line 653 of file at32f413_gpio.h.

◆ uart4_gmux

__IO uint32_t iomux_type::uart4_gmux

Definition at line 712 of file at32f413_gpio.h.

◆ usart1_gmux

__IO uint32_t iomux_type::usart1_gmux

Definition at line 709 of file at32f413_gpio.h.

◆ usart1_mux

__IO uint32_t iomux_type::usart1_mux

Definition at line 541 of file at32f413_gpio.h.

◆ usart3_gmux

__IO uint32_t iomux_type::usart3_gmux

Definition at line 711 of file at32f413_gpio.h.

◆ usart3_mux

__IO uint32_t iomux_type::usart3_mux

Definition at line 543 of file at32f413_gpio.h.

The documentation for this struct was generated from the following file:
  • at32f413_gpio.h


AT32F413 Firmwary Library: GPIO_exported_functions

Functions
GPIO_exported_functions
AT32F413_periph_driver » GPIO

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

Function Documentation

◆ gpio_bits_reset()

void gpio_bits_reset | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

clear the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 339 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_config(), rs485_send_data(), and TMR2_GLOBAL_IRQHandler().

◆ gpio_bits_set()

void gpio_bits_set | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

set the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 308 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_send_data(), and usart_configuration().

◆ gpio_bits_write()

void gpio_bits_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | bit_state
 | ) |  |

set or clear the selected data port bit.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
bit_state | specifies the value to be written to the selected bit (TRUE or FALSE).
Return values
none

Definition at line 371 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_default_para_init()

void gpio_default_para_init ( gpio_init_type * gpio_init_struct )

fill each gpio_init_type member with its default value.

Parameters
gpio_init_struct : pointer to a gpio_init_type structure which will be initialized.
Return values
none

< gpio all pins

Definition at line 166 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), mclk_tmr1_init(), rs485_config(), spim_init(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), and usart_spi_configuration().

◆ gpio_event_output_config()

void gpio_event_output_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as event output.

Parameters
gpio_port_source select the gpio port to be used as source for event output. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 469 of file at32f413_gpio.c.

◆ gpio_event_output_enable()

void gpio_event_output_enable ( confirm_state new_state )

enable or disable the event output.

Parameters
confirm_state new state of the event output. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 488 of file at32f413_gpio.c.

◆ gpio_exint_line_config()

void gpio_exint_line_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as exint line.

Parameters
gpio_port_source select the gpio port to be used as source for exint. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 571 of file at32f413_gpio.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), and usart_configuration().

◆ gpio_init()

void gpio_init | ( | gpio_type * | gpio_x,
 |  | gpio_init_type * | gpio_init_struct
 | ) |  |

initialize the gpio peripheral.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
gpio_init_struct | pointer to gpio init structure.
Return values
none

Definition at line 98 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_input_data_bit_read()

flag_status gpio_input_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified input port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 201 of file at32f413_gpio.c.

Referenced by at32_button_state(), button_isr(), and gpio_config().

◆ gpio_input_data_read()

uint16_t gpio_input_data_read ( gpio_type * gpio_x )

read the specified gpio input data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 224 of file at32f413_gpio.c.

◆ gpio_iomux_reset()

void gpio_iomux_reset ( void )

reset the mux functions (remap, event control and exint configuration) registers to their default values.

Parameters
none
Return values
none

Definition at line 84 of file at32f413_gpio.c.

◆ gpio_output_data_bit_read()

flag_status gpio_output_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified output port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 254 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_output_data_read()

uint16_t gpio_output_data_read ( gpio_type * gpio_x )

read the specified gpio ouput data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 277 of file at32f413_gpio.c.

◆ gpio_pin_remap_config()

void gpio_pin_remap_config | ( | uint32_t | gpio_remap,
 |  | confirm_state | new_state
 | ) |  |

iomux remap and debug i/o configuration.

Parameters
gpio_remap select the pin to remap. this parameter can be one of the following values:
  • SPI1_MUX_01 - I2C1_MUX - USART1_MUX - USART3_MUX_01
  • TMR1_MUX_01 - TMR2_MUX_01 - TMR2_MUX_10 - TMR2_MUX_11
  • TMR3_MUX_10 - TMR3_MUX_11 - CAN_MUX_10 - PD01_MUX
  • TMR5CH4_MUX - ADC1_EXTRGPRE_MUX - ADC1_EXTRGORD_MUX - ADC2_EXTRGPRE_MUX
  • ADC2_EXTRGORD_MUX - SWJTAG_CONF_001 - SWJTAG_CONF_010 - SWJTAG_CONF_100
  • EXT_SPIM_EN_MUX - TMR9_GMUX - TMR10_GMUX - TMR11_GMUX
  • TMR1_GMUX_0001 - TMR2_GMUX_001 - TMR2_GMUX_010 - TMR2_GMUX_011
  • TMR2ITR1_GMUX - TMR3_GMUX_0010 - TMR3_GMUX_0011 - TMR5_GMUX_001
  • TMR5CH4_GMUX - I2C1_GMUX_0001 - I2C1_GMUX_0011 - I2C2_GMUX_0001
  • I2C2_GMUX_0010 - I2C2_GMUX_0011 - SPI1_GMUX_0001 - SPI2_GMUX_0001
  • CAN1_GMUX_0010 - CAN2_GMUX_0001 - SDIO1_GMUX_0100 - SDIO1_GMUX_0101
  • SDIO1_GMUX_0110 - SDIO1_GMUX_0111 - USART1_GMUX_0001 - USART3_GMUX_0001
  • UART4_GMUX_0001 - EXT_SPIM_GMUX_1000 - EXT_SPIM_GMUX_1001 - ADC1_ETP_GMUX
  • ADC1_ETO_GMUX - ADC2_ETP_GMUX - ADC2_ETO_GMUX - SWJTAG_GMUX_001
  • SWJTAG_GMUX_010 - SWJTAG_GMUX_100 - PD01_GMUX
new_state (TRUE or FALSE)
Return values
none

Definition at line 515 of file at32f413_gpio.c.

Referenced by can_gpio_config(), gpio_config(), i2c_lowlevel_init(), main(), and spim_init().

◆ gpio_pin_wp_config()

void gpio_pin_wp_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

write protect gpio pins configuration registers.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be any combination of the following:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 422 of file at32f413_gpio.c.

◆ gpio_port_write()

void gpio_port_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | port_value
 | ) |  |

write data to the specified gpio data port.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
port_value | specifies the value to be written to the port output data register.
Return values
none

Definition at line 391 of file at32f413_gpio.c.

◆ gpio_reset()

void gpio_reset ( gpio_type * gpio_x )

reset the gpio register

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
none

Definition at line 49 of file at32f413_gpio.c.


AT32F413 Firmwary Library: GPIO_private_functions

Functions
GPIO_private_functions
AT32F413_periph_driver » GPIO

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

Function Documentation

◆ gpio_bits_reset()

void gpio_bits_reset | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

clear the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 339 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_config(), rs485_send_data(), and TMR2_GLOBAL_IRQHandler().

◆ gpio_bits_set()

void gpio_bits_set | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

set the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 308 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_send_data(), and usart_configuration().

◆ gpio_bits_write()

void gpio_bits_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | bit_state
 | ) |  |

set or clear the selected data port bit.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
bit_state | specifies the value to be written to the selected bit (TRUE or FALSE).
Return values
none

Definition at line 371 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_default_para_init()

void gpio_default_para_init ( gpio_init_type * gpio_init_struct )

fill each gpio_init_type member with its default value.

Parameters
gpio_init_struct : pointer to a gpio_init_type structure which will be initialized.
Return values
none

< gpio all pins

Definition at line 166 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), mclk_tmr1_init(), rs485_config(), spim_init(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), and usart_spi_configuration().

◆ gpio_event_output_config()

void gpio_event_output_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as event output.

Parameters
gpio_port_source select the gpio port to be used as source for event output. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 469 of file at32f413_gpio.c.

◆ gpio_event_output_enable()

void gpio_event_output_enable ( confirm_state new_state )

enable or disable the event output.

Parameters
confirm_state new state of the event output. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 488 of file at32f413_gpio.c.

◆ gpio_exint_line_config()

void gpio_exint_line_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as exint line.

Parameters
gpio_port_source select the gpio port to be used as source for exint. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 571 of file at32f413_gpio.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), and usart_configuration().

◆ gpio_init()

void gpio_init | ( | gpio_type * | gpio_x,
 |  | gpio_init_type * | gpio_init_struct
 | ) |  |

initialize the gpio peripheral.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
gpio_init_struct | pointer to gpio init structure.
Return values
none

Definition at line 98 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_input_data_bit_read()

flag_status gpio_input_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified input port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 201 of file at32f413_gpio.c.

Referenced by at32_button_state(), button_isr(), and gpio_config().

◆ gpio_input_data_read()

uint16_t gpio_input_data_read ( gpio_type * gpio_x )

read the specified gpio input data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 224 of file at32f413_gpio.c.

◆ gpio_iomux_reset()

void gpio_iomux_reset ( void )

reset the mux functions (remap, event control and exint configuration) registers to their default values.

Parameters
none
Return values
none

Definition at line 84 of file at32f413_gpio.c.

◆ gpio_output_data_bit_read()

flag_status gpio_output_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified output port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 254 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_output_data_read()

uint16_t gpio_output_data_read ( gpio_type * gpio_x )

read the specified gpio ouput data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 277 of file at32f413_gpio.c.

◆ gpio_pin_remap_config()

void gpio_pin_remap_config | ( | uint32_t | gpio_remap,
 |  | confirm_state | new_state
 | ) |  |

iomux remap and debug i/o configuration.

Parameters
gpio_remap select the pin to remap. this parameter can be one of the following values:
  • SPI1_MUX_01 - I2C1_MUX - USART1_MUX - USART3_MUX_01
  • TMR1_MUX_01 - TMR2_MUX_01 - TMR2_MUX_10 - TMR2_MUX_11
  • TMR3_MUX_10 - TMR3_MUX_11 - CAN_MUX_10 - PD01_MUX
  • TMR5CH4_MUX - ADC1_EXTRGPRE_MUX - ADC1_EXTRGORD_MUX - ADC2_EXTRGPRE_MUX
  • ADC2_EXTRGORD_MUX - SWJTAG_CONF_001 - SWJTAG_CONF_010 - SWJTAG_CONF_100
  • EXT_SPIM_EN_MUX - TMR9_GMUX - TMR10_GMUX - TMR11_GMUX
  • TMR1_GMUX_0001 - TMR2_GMUX_001 - TMR2_GMUX_010 - TMR2_GMUX_011
  • TMR2ITR1_GMUX - TMR3_GMUX_0010 - TMR3_GMUX_0011 - TMR5_GMUX_001
  • TMR5CH4_GMUX - I2C1_GMUX_0001 - I2C1_GMUX_0011 - I2C2_GMUX_0001
  • I2C2_GMUX_0010 - I2C2_GMUX_0011 - SPI1_GMUX_0001 - SPI2_GMUX_0001
  • CAN1_GMUX_0010 - CAN2_GMUX_0001 - SDIO1_GMUX_0100 - SDIO1_GMUX_0101
  • SDIO1_GMUX_0110 - SDIO1_GMUX_0111 - USART1_GMUX_0001 - USART3_GMUX_0001
  • UART4_GMUX_0001 - EXT_SPIM_GMUX_1000 - EXT_SPIM_GMUX_1001 - ADC1_ETP_GMUX
  • ADC1_ETO_GMUX - ADC2_ETP_GMUX - ADC2_ETO_GMUX - SWJTAG_GMUX_001
  • SWJTAG_GMUX_010 - SWJTAG_GMUX_100 - PD01_GMUX
new_state (TRUE or FALSE)
Return values
none

Definition at line 515 of file at32f413_gpio.c.

Referenced by can_gpio_config(), gpio_config(), i2c_lowlevel_init(), main(), and spim_init().

◆ gpio_pin_wp_config()

void gpio_pin_wp_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

write protect gpio pins configuration registers.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be any combination of the following:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 422 of file at32f413_gpio.c.

◆ gpio_port_write()

void gpio_port_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | port_value
 | ) |  |

write data to the specified gpio data port.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
port_value | specifies the value to be written to the port output data register.
Return values
none

Definition at line 391 of file at32f413_gpio.c.

◆ gpio_reset()

void gpio_reset ( gpio_type * gpio_x )

reset the gpio register

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
none

Definition at line 49 of file at32f413_gpio.c.


AT32F413 Firmwary Library: I2C

Modules | Macros
I2C
AT32F413_periph_driver

I2C driver modules. More...

Modules

I2C_sts1_flags_definition
i2c sts1 flag
I2C_sts2_flags_definition
i2c sts2 flag
I2C_interrupts_definition
i2c interrupt
I2C_exported_types
I2C_exported_functions
I2C_private_functions

Macros

#define | I2C1 ((i2c_type *) I2C1_BASE)
#define | I2C2 ((i2c_type *) I2C2_BASE)

Detailed Description

I2C driver modules.

Macro Definition Documentation

◆ I2C1

#define I2C1 ((i2c_type *) I2C1_BASE)

Definition at line 345 of file at32f413_i2c.h.

◆ I2C2

#define I2C2 ((i2c_type *) I2C2_BASE)

Definition at line 346 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_sts1_flags_definition

Macros
I2C_sts1_flags_definition
AT32F413_periph_driver » I2C

i2c sts1 flag More...

Macros

#define | I2C_STARTF_FLAG ((uint32_t)0x00000001)
#define | I2C_ADDR7F_FLAG ((uint32_t)0x00000002)
#define | I2C_TDC_FLAG ((uint32_t)0x00000004)
#define | I2C_ADDRHF_FLAG ((uint32_t)0x00000008)
#define | I2C_STOPF_FLAG ((uint32_t)0x00000010)
#define | I2C_RDBF_FLAG ((uint32_t)0x00000040)
#define | I2C_TDBE_FLAG ((uint32_t)0x00000080)
#define | I2C_BUSERR_FLAG ((uint32_t)0x00000100)
#define | I2C_ARLOST_FLAG ((uint32_t)0x00000200)
#define | I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)
#define | I2C_OUF_FLAG ((uint32_t)0x00000800)
#define | I2C_PECERR_FLAG ((uint32_t)0x00001000)
#define | I2C_TMOUT_FLAG ((uint32_t)0x00004000)
#define | I2C_ALERTF_FLAG ((uint32_t)0x00008000)

Detailed Description

i2c sts1 flag

Macro Definition Documentation

◆ I2C_ACKFAIL_FLAG

#define I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)

i2c acknowledge failure flag

Definition at line 59 of file at32f413_i2c.h.

◆ I2C_ADDR7F_FLAG

#define I2C_ADDR7F_FLAG ((uint32_t)0x00000002)

i2c 0~7 bit address match flag

Definition at line 51 of file at32f413_i2c.h.

◆ I2C_ADDRHF_FLAG

#define I2C_ADDRHF_FLAG ((uint32_t)0x00000008)

i2c master 9~8 bit address header match flag

Definition at line 53 of file at32f413_i2c.h.

◆ I2C_ALERTF_FLAG

#define I2C_ALERTF_FLAG ((uint32_t)0x00008000)

i2c smbus alert flag

Definition at line 63 of file at32f413_i2c.h.

◆ I2C_ARLOST_FLAG

#define I2C_ARLOST_FLAG ((uint32_t)0x00000200)

i2c arbitration lost flag

Definition at line 58 of file at32f413_i2c.h.

◆ I2C_BUSERR_FLAG

#define I2C_BUSERR_FLAG ((uint32_t)0x00000100)

i2c bus error flag

Definition at line 57 of file at32f413_i2c.h.

◆ I2C_OUF_FLAG

#define I2C_OUF_FLAG ((uint32_t)0x00000800)

i2c overflow or underflow flag

Definition at line 60 of file at32f413_i2c.h.

◆ I2C_PECERR_FLAG

#define I2C_PECERR_FLAG ((uint32_t)0x00001000)

i2c pec receive error flag

Definition at line 61 of file at32f413_i2c.h.

◆ I2C_RDBF_FLAG

#define I2C_RDBF_FLAG ((uint32_t)0x00000040)

i2c receive data buffer full flag

Definition at line 55 of file at32f413_i2c.h.

◆ I2C_STARTF_FLAG

#define I2C_STARTF_FLAG ((uint32_t)0x00000001)

i2c start condition generation complete flag

Definition at line 50 of file at32f413_i2c.h.

◆ I2C_STOPF_FLAG

#define I2C_STOPF_FLAG ((uint32_t)0x00000010)

i2c stop condition generation complete flag

Definition at line 54 of file at32f413_i2c.h.

◆ I2C_TDBE_FLAG

#define I2C_TDBE_FLAG ((uint32_t)0x00000080)

i2c transmit data buffer empty flag

Definition at line 56 of file at32f413_i2c.h.

◆ I2C_TDC_FLAG

#define I2C_TDC_FLAG ((uint32_t)0x00000004)

i2c transmit data complete flag

Definition at line 52 of file at32f413_i2c.h.

◆ I2C_TMOUT_FLAG

#define I2C_TMOUT_FLAG ((uint32_t)0x00004000)

i2c smbus timeout flag

Definition at line 62 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_sts2_flags_definition

Macros
I2C_sts2_flags_definition
AT32F413_periph_driver » I2C

i2c sts2 flag More...

Macros

#define | I2C_TRMODE_FLAG ((uint32_t)0x10010000)
#define | I2C_BUSYF_FLAG ((uint32_t)0x10020000)
#define | I2C_DIRF_FLAG ((uint32_t)0x10040000)
#define | I2C_GCADDRF_FLAG ((uint32_t)0x10100000)
#define | I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)
#define | I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)
#define | I2C_ADDR2_FLAG ((uint32_t)0x10800000)

Detailed Description

i2c sts2 flag

Macro Definition Documentation

◆ I2C_ADDR2_FLAG

#define I2C_ADDR2_FLAG ((uint32_t)0x10800000)

i2c own address 2 received flag

Definition at line 80 of file at32f413_i2c.h.

◆ I2C_BUSYF_FLAG

#define I2C_BUSYF_FLAG ((uint32_t)0x10020000)

i2c bus busy flag transmission mode

Definition at line 75 of file at32f413_i2c.h.

◆ I2C_DEVADDRF_FLAG

#define I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)

i2c smbus device address received flag

Definition at line 78 of file at32f413_i2c.h.

◆ I2C_DIRF_FLAG

#define I2C_DIRF_FLAG ((uint32_t)0x10040000)

i2c transmission direction flag

Definition at line 76 of file at32f413_i2c.h.

◆ I2C_GCADDRF_FLAG

#define I2C_GCADDRF_FLAG ((uint32_t)0x10100000)

i2c general call address received flag

Definition at line 77 of file at32f413_i2c.h.

◆ I2C_HOSTADDRF_FLAG

#define I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)

i2c smbus host address received flag

Definition at line 79 of file at32f413_i2c.h.

◆ I2C_TRMODE_FLAG

#define I2C_TRMODE_FLAG ((uint32_t)0x10010000)

i2c transmission mode

Definition at line 74 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_interrupts_definition

Macros
I2C_interrupts_definition
AT32F413_periph_driver » I2C

i2c interrupt More...

Macros

#define | I2C_DATA_INT ((uint16_t)0x0400)
#define | I2C_EVT_INT ((uint16_t)0x0200)
#define | I2C_ERR_INT ((uint16_t)0x0100)

Detailed Description

i2c interrupt

Macro Definition Documentation

◆ I2C_DATA_INT

#define I2C_DATA_INT ((uint16_t)0x0400)

i2c data transmission interrupt

Definition at line 91 of file at32f413_i2c.h.

◆ I2C_ERR_INT

#define I2C_ERR_INT ((uint16_t)0x0100)

i2c error interrupt

Definition at line 93 of file at32f413_i2c.h.

◆ I2C_EVT_INT

#define I2C_EVT_INT ((uint16_t)0x0200)

i2c event interrupt

Definition at line 92 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_exported_types

Data Structures | Enumerations
I2C_exported_types
AT32F413_periph_driver » I2C

Data Structures

struct i2c_type
type define i2c register all More...

Enumerations

enum | i2c_master_ack_type { I2C_MASTER_ACK_CURRENT = 0x00 , I2C_MASTER_ACK_NEXT = 0x01 }
i2c master receiving mode acknowledge control More...
enum | i2c_pec_position_type { I2C_PEC_POSITION_CURRENT = 0x00 , I2C_PEC_POSITION_NEXT = 0x01 }
i2c pec position set More...
enum | i2c_smbus_alert_set_type { I2C_SMBUS_ALERT_HIGH = 0x00 , I2C_SMBUS_ALERT_LOW = 0x01 }
i2c smbus alert pin set More...
enum | i2c_smbus_mode_set_type { I2C_SMBUS_MODE_DEVICE = 0x00 , I2C_SMBUS_MODE_HOST = 0x01 }
i2c smbus mode set More...
enum | i2c_fsmode_duty_cycle_type { I2C_FSMODE_DUTY_2_1 = 0x00 , I2C_FSMODE_DUTY_16_9 = 0x01 }
i2c fast mode duty cycle More...
enum | i2c_address_mode_type { I2C_ADDRESS_MODE_7BIT = 0x00 , I2C_ADDRESS_MODE_10BIT = 0x01 }
i2c address mode More...
enum | i2c_direction_type { I2C_DIRECTION_TRANSMIT = 0x00 , I2C_DIRECTION_RECEIVE = 0x01 }
i2c address direction More...

Detailed Description

Enumeration Type Documentation

◆ i2c_address_mode_type

enum i2c_address_mode_type

i2c address mode

Enumerator
I2C_ADDRESS_MODE_7BIT | 7bit address mode
I2C_ADDRESS_MODE_10BIT | 10bit address mode

Definition at line 153 of file at32f413_i2c.h.

◆ i2c_direction_type

enum i2c_direction_type

i2c address direction

Enumerator
I2C_DIRECTION_TRANSMIT | transmit mode
I2C_DIRECTION_RECEIVE | receive mode

Definition at line 162 of file at32f413_i2c.h.

◆ i2c_fsmode_duty_cycle_type

enum i2c_fsmode_duty_cycle_type

i2c fast mode duty cycle

Enumerator
I2C_FSMODE_DUTY_2_1 | duty cycle is 2:1 in fast mode
I2C_FSMODE_DUTY_16_9 | duty cycle is 16:9 in fast mode

Definition at line 144 of file at32f413_i2c.h.

◆ i2c_master_ack_type

enum i2c_master_ack_type

i2c master receiving mode acknowledge control

Enumerator
I2C_MASTER_ACK_CURRENT | acken bit acts on the current byte
I2C_MASTER_ACK_NEXT | acken bit acts on the next byte

Definition at line 106 of file at32f413_i2c.h.

◆ i2c_pec_position_type

enum i2c_pec_position_type

i2c pec position set

Enumerator
I2C_PEC_POSITION_CURRENT | the current byte is pec
I2C_PEC_POSITION_NEXT | the next byte is pec

Definition at line 115 of file at32f413_i2c.h.

◆ i2c_smbus_alert_set_type

enum i2c_smbus_alert_set_type

i2c smbus alert pin set

Enumerator
I2C_SMBUS_ALERT_HIGH | smbus alert pin set high
I2C_SMBUS_ALERT_LOW | smbus alert pin set low

Definition at line 125 of file at32f413_i2c.h.

◆ i2c_smbus_mode_set_type

enum i2c_smbus_mode_set_type

i2c smbus mode set

Enumerator
I2C_SMBUS_MODE_DEVICE | smbus device mode
I2C_SMBUS_MODE_HOST | smbus host mode

Definition at line 134 of file at32f413_i2c.h.


AT32F413 Firmwary Library: i2c_type Struct Reference

Data Fields
i2c_type Struct Reference
AT32F413_periph_driver » I2C » I2C_exported_types

type define i2c register all More...

#include <at32f413_i2c.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t i2cen: 1
__IO uint32_t permode: 1
__IO uint32_t reserved1: 1
__IO uint32_t smbmode: 1
__IO uint32_t arpen: 1
__IO uint32_t pecen: 1
__IO uint32_t gcaen: 1
__IO uint32_t stretch: 1
__IO uint32_t genstart: 1
__IO uint32_t genstop: 1
__IO uint32_t acken: 1
__IO uint32_t mackctrl: 1
__IO uint32_t pecten: 1
__IO uint32_t smbalert: 1
__IO uint32_t reserved2: 1
__IO uint32_t reset: 1
__IO uint32_t reserved3: 16
} ctrl1_bit
};
i2c ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t clkfreq: 8
__IO uint32_t errien: 1
__IO uint32_t evtien: 1
__IO uint32_t dataien: 1
__IO uint32_t dmaen: 1
__IO uint32_t dmaend: 1
__IO uint32_t reserved1: 19
} ctrl2_bit
};
i2c ctrl2 register, offset:0x04 More...
union {
__IO uint32_t oaddr1
struct {
__IO uint32_t addr1: 10
__IO uint32_t reserved1: 5
__IO uint32_t addr1mode: 1
__IO uint32_t reserved2: 16
} oaddr1_bit
};
i2c oaddr1 register, offset:0x08 More...
union {
__IO uint32_t oaddr2
struct {
__IO uint32_t addr2en: 1
__IO uint32_t addr2: 7
__IO uint32_t reserved1: 24
} oaddr2_bit
};
i2c oaddr2 register, offset:0x0C More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 8
__IO uint32_t reserved1: 24
} dt_bit
};
i2c dt register, offset:0x10 More...
union {
__IO uint32_t sts1
struct {
__IO uint32_t startf: 1
__IO uint32_t addr7f: 1
__IO uint32_t tdc: 1
__IO uint32_t addrhf: 1
__IO uint32_t stopf: 1
__IO uint32_t reserved1: 1
__IO uint32_t rdbf: 1
__IO uint32_t tdbe: 1
__IO uint32_t buserr: 1
__IO uint32_t arlost: 1
__IO uint32_t ackfail: 1
__IO uint32_t ouf: 1
__IO uint32_t pecerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t tmout: 1
__IO uint32_t alertf: 1
__IO uint32_t reserved3: 16
} sts1_bit
};
i2c sts1 register, offset:0x14 More...
union {
__IO uint32_t sts2
struct {
__IO uint32_t trmode: 1
__IO uint32_t busyf: 1
__IO uint32_t dirf: 1
__IO uint32_t reserved1: 1
__IO uint32_t gcaddrf: 1
__IO uint32_t devaddrf: 1
__IO uint32_t hostaddrf: 1
__IO uint32_t addr2: 1
__IO uint32_t pecval: 8
__IO uint32_t reserved2: 16
} sts2_bit
};
i2c sts2 register, offset:0x18 More...
union {
__IO uint32_t clkctrl
struct {
__IO uint32_t speed: 12
__IO uint32_t reserved1: 2
__IO uint32_t dutymode: 1
__IO uint32_t speedmode: 1
__IO uint32_t reserved2: 16
} clkctrl_bit
};
i2c clkctrl register, offset:0x1C More...
union {
__IO uint32_t tmrise
struct {
__IO uint32_t risetime: 6
__IO uint32_t reserved1: 26
} tmrise_bit
};
i2c tmrise register, offset:0x20 More...

Detailed Description

type define i2c register all

Definition at line 171 of file at32f413_i2c.h.

Field Documentation

◆

union { ... } i2c_type::@508

i2c ctrl1 register, offset:0x00

◆

union { ... } i2c_type::@510

i2c ctrl2 register, offset:0x04

◆

union { ... } i2c_type::@512

i2c oaddr1 register, offset:0x08

◆

union { ... } i2c_type::@514

i2c oaddr2 register, offset:0x0C

◆

union { ... } i2c_type::@516

i2c dt register, offset:0x10

◆

union { ... } i2c_type::@518

i2c sts1 register, offset:0x14

◆

union { ... } i2c_type::@520

i2c sts2 register, offset:0x18

◆

union { ... } i2c_type::@522

i2c clkctrl register, offset:0x1C

◆

union { ... } i2c_type::@524

i2c tmrise register, offset:0x20

◆ acken

__IO uint32_t i2c_type::acken

Definition at line 191 of file at32f413_i2c.h.

Referenced by i2c_ack_enable().

◆ ackfail

__IO uint32_t i2c_type::ackfail

Definition at line 279 of file at32f413_i2c.h.

◆ addr1

__IO uint32_t i2c_type::addr1

Definition at line 227 of file at32f413_i2c.h.

Referenced by i2c_own_address1_set().

◆ addr1mode

__IO uint32_t i2c_type::addr1mode

Definition at line 229 of file at32f413_i2c.h.

Referenced by i2c_master_read_addr(), i2c_master_write_addr(), i2c_own_address1_set(), and i2c_slave_transmit().

◆ addr2

__IO uint32_t i2c_type::addr2

Definition at line 243 of file at32f413_i2c.h.

Referenced by i2c_own_address2_set().

◆ addr2en

__IO uint32_t i2c_type::addr2en

Definition at line 242 of file at32f413_i2c.h.

Referenced by i2c_own_address2_enable().

◆ addr7f

__IO uint32_t i2c_type::addr7f

Definition at line 270 of file at32f413_i2c.h.

◆ addrhf

__IO uint32_t i2c_type::addrhf

Definition at line 272 of file at32f413_i2c.h.

◆ alertf

__IO uint32_t i2c_type::alertf

Definition at line 284 of file at32f413_i2c.h.

◆ arlost

__IO uint32_t i2c_type::arlost

Definition at line 278 of file at32f413_i2c.h.

◆ arpen

__IO uint32_t i2c_type::arpen

Definition at line 185 of file at32f413_i2c.h.

Referenced by i2c_arp_mode_enable().

◆ buserr

__IO uint32_t i2c_type::buserr

Definition at line 277 of file at32f413_i2c.h.

◆ busyf

__IO uint32_t i2c_type::busyf

Definition at line 298 of file at32f413_i2c.h.

◆ clkctrl

__IO uint32_t i2c_type::clkctrl

Definition at line 315 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::clkctrl_bit

Referenced by i2c_fast_mode_duty_set(), and i2c_init().

◆ clkfreq

__IO uint32_t i2c_type::clkfreq

Definition at line 209 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ ctrl1

__IO uint32_t i2c_type::ctrl1

Definition at line 178 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::ctrl1_bit

Referenced by i2c_ack_enable(), i2c_arp_mode_enable(), i2c_clock_stretch_enable(), i2c_enable(), i2c_flag_clear(), i2c_general_call_enable(), i2c_init(), i2c_master_receive_ack_set(), i2c_pec_calculate_enable(), i2c_pec_position_set(), i2c_pec_transmit_enable(), i2c_smbus_alert_set(), i2c_smbus_enable(), i2c_smbus_mode_set(), i2c_software_reset(), i2c_start_generate(), and i2c_stop_generate().

◆ ctrl2

__IO uint32_t i2c_type::ctrl2

Definition at line 206 of file at32f413_i2c.h.

Referenced by i2c_interrupt_enable().

◆

struct { ... } i2c_type::ctrl2_bit

Referenced by i2c_dma_enable(), i2c_dma_end_transfer_set(), and i2c_init().

◆ dataien

__IO uint32_t i2c_type::dataien

Definition at line 212 of file at32f413_i2c.h.

◆ devaddrf

__IO uint32_t i2c_type::devaddrf

Definition at line 302 of file at32f413_i2c.h.

◆ dirf

__IO uint32_t i2c_type::dirf

Definition at line 299 of file at32f413_i2c.h.

◆ dmaen

__IO uint32_t i2c_type::dmaen

Definition at line 213 of file at32f413_i2c.h.

Referenced by i2c_dma_enable().

◆ dmaend

__IO uint32_t i2c_type::dmaend

Definition at line 214 of file at32f413_i2c.h.

Referenced by i2c_dma_end_transfer_set().

◆ dt

__IO uint32_t i2c_type::dt

Definition at line 253 of file at32f413_i2c.h.

Referenced by i2c_7bit_address_send(), i2c_data_receive(), i2c_data_send(), and i2c_dma_config().

◆

struct { ... } i2c_type::dt_bit

◆ dutymode

__IO uint32_t i2c_type::dutymode

Definition at line 320 of file at32f413_i2c.h.

Referenced by i2c_fast_mode_duty_set(), and i2c_init().

◆ errien

__IO uint32_t i2c_type::errien

Definition at line 210 of file at32f413_i2c.h.

◆ evtien

__IO uint32_t i2c_type::evtien

Definition at line 211 of file at32f413_i2c.h.

◆ gcaddrf

__IO uint32_t i2c_type::gcaddrf

Definition at line 301 of file at32f413_i2c.h.

◆ gcaen

__IO uint32_t i2c_type::gcaen

Definition at line 187 of file at32f413_i2c.h.

Referenced by i2c_general_call_enable().

◆ genstart

__IO uint32_t i2c_type::genstart

Definition at line 189 of file at32f413_i2c.h.

Referenced by i2c_start_generate().

◆ genstop

__IO uint32_t i2c_type::genstop

Definition at line 190 of file at32f413_i2c.h.

Referenced by i2c_stop_generate().

◆ hostaddrf

__IO uint32_t i2c_type::hostaddrf

Definition at line 303 of file at32f413_i2c.h.

◆ i2cen

__IO uint32_t i2c_type::i2cen

Definition at line 181 of file at32f413_i2c.h.

Referenced by i2c_enable(), i2c_flag_clear(), and i2c_init().

◆ mackctrl

__IO uint32_t i2c_type::mackctrl

Definition at line 192 of file at32f413_i2c.h.

Referenced by i2c_master_receive_ack_set(), and i2c_pec_position_set().

◆ oaddr1

__IO uint32_t i2c_type::oaddr1

Definition at line 224 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::oaddr1_bit

Referenced by i2c_master_read_addr(), i2c_master_write_addr(), i2c_own_address1_set(), and i2c_slave_transmit().

◆ oaddr2

__IO uint32_t i2c_type::oaddr2

Definition at line 239 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::oaddr2_bit

Referenced by i2c_own_address2_enable(), and i2c_own_address2_set().

◆ ouf

__IO uint32_t i2c_type::ouf

Definition at line 280 of file at32f413_i2c.h.

◆ pecen

__IO uint32_t i2c_type::pecen

Definition at line 186 of file at32f413_i2c.h.

Referenced by i2c_pec_calculate_enable().

◆ pecerr

__IO uint32_t i2c_type::pecerr

Definition at line 281 of file at32f413_i2c.h.

◆ pecten

__IO uint32_t i2c_type::pecten

Definition at line 193 of file at32f413_i2c.h.

Referenced by i2c_pec_transmit_enable().

◆ pecval

__IO uint32_t i2c_type::pecval

Definition at line 305 of file at32f413_i2c.h.

Referenced by i2c_pec_value_get().

◆ permode

__IO uint32_t i2c_type::permode

Definition at line 182 of file at32f413_i2c.h.

Referenced by i2c_smbus_enable().

◆ rdbf

__IO uint32_t i2c_type::rdbf

Definition at line 275 of file at32f413_i2c.h.

◆ reserved1

__IO uint32_t i2c_type::reserved1

Definition at line 183 of file at32f413_i2c.h.

◆ reserved2

__IO uint32_t i2c_type::reserved2

Definition at line 195 of file at32f413_i2c.h.

◆ reserved3

__IO uint32_t i2c_type::reserved3

Definition at line 197 of file at32f413_i2c.h.

◆ reset

__IO uint32_t i2c_type::reset

Definition at line 196 of file at32f413_i2c.h.

Referenced by i2c_software_reset().

◆ risetime

__IO uint32_t i2c_type::risetime

Definition at line 334 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ smbalert

__IO uint32_t i2c_type::smbalert

Definition at line 194 of file at32f413_i2c.h.

Referenced by i2c_smbus_alert_set().

◆ smbmode

__IO uint32_t i2c_type::smbmode

Definition at line 184 of file at32f413_i2c.h.

Referenced by i2c_smbus_mode_set().

◆ speed

__IO uint32_t i2c_type::speed

Definition at line 318 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ speedmode

__IO uint32_t i2c_type::speedmode

Definition at line 321 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ startf

__IO uint32_t i2c_type::startf

Definition at line 269 of file at32f413_i2c.h.

◆ stopf

__IO uint32_t i2c_type::stopf

Definition at line 273 of file at32f413_i2c.h.

◆ stretch

__IO uint32_t i2c_type::stretch

Definition at line 188 of file at32f413_i2c.h.

Referenced by i2c_clock_stretch_enable().

◆ sts1

__IO uint32_t i2c_type::sts1

Definition at line 266 of file at32f413_i2c.h.

Referenced by i2c_flag_clear(), and i2c_flag_get().

◆

struct { ... } i2c_type::sts1_bit

◆ sts2

__IO uint32_t i2c_type::sts2

Definition at line 294 of file at32f413_i2c.h.

Referenced by i2c_flag_clear(), and i2c_flag_get().

◆

struct { ... } i2c_type::sts2_bit

Referenced by i2c_pec_value_get().

◆ tdbe

__IO uint32_t i2c_type::tdbe

Definition at line 276 of file at32f413_i2c.h.

◆ tdc

__IO uint32_t i2c_type::tdc

Definition at line 271 of file at32f413_i2c.h.

◆ tmout

__IO uint32_t i2c_type::tmout

Definition at line 283 of file at32f413_i2c.h.

◆ tmrise

__IO uint32_t i2c_type::tmrise

Definition at line 331 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::tmrise_bit

Referenced by i2c_init().

◆ trmode

__IO uint32_t i2c_type::trmode

Definition at line 297 of file at32f413_i2c.h.

The documentation for this struct was generated from the following file:
  • at32f413_i2c.h


AT32F413 Firmwary Library: I2C_exported_functions

Functions
I2C_exported_functions
AT32F413_periph_driver » I2C

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

Function Documentation

◆ i2c_7bit_address_send()

void i2c_7bit_address_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | address,
 |  | i2c_direction_type | direction
 | ) |  |

transmit the slave address.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the slave address which will be transmitted
direction this parameter can be one of the following values:
  • I2C_DIRECTION_TRANSMIT: transmit mode.
  • I2C_DIRECTION_RECEIVE: receive mode.
Return values
none.

Definition at line 501 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_ack_enable()

void i2c_ack_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable acknowledge.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none.

Definition at line 281 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_rx_isr_dma().

◆ i2c_arp_mode_enable()

void i2c_arp_mode_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable arp mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 339 of file at32f413_i2c.c.

◆ i2c_clock_stretch_enable()

void i2c_clock_stretch_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock stretch.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 268 of file at32f413_i2c.c.

◆ i2c_data_receive()

uint8_t i2c_data_receive ( i2c_type * i2c_x )

receive a byte through the i2c periph.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t received byte

Definition at line 533 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_slave_receive(), and i2c_slave_rx_isr_int().

◆ i2c_data_send()

void i2c_data_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | data
 | ) |  |

send a byte through the i2c periph.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
data | byte to be transmitted.
Return values
none

Definition at line 521 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), i2c_master_transmit(), i2c_master_tx_isr_int(), i2c_master_write_addr(), i2c_memory_address_send(), i2c_memory_write(), i2c_slave_transmit(), and i2c_slave_tx_isr_int().

◆ i2c_dma_enable()

void i2c_dma_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma requests.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 435 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_dma_end_transfer_set()

void i2c_dma_end_transfer_set | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable if the next dma transfer will be the last one.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 422 of file at32f413_i2c.c.

Referenced by i2c_master_receive_dma(), and i2c_memory_read_dma().

◆ i2c_enable()

void i2c_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2c periph

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 239 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_fast_mode_duty_set()

void i2c_fast_mode_duty_set | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty
 | ) |  |

config fast mode duty cycle

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
Return values
none

Definition at line 255 of file at32f413_i2c.c.

◆ i2c_flag_clear()

void i2c_flag_clear | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

clear flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
flag this parameter can be any combination of the following values:
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_ADDR7F_FLAG: i2c 0~7 bit address match flag.
Return values
none

< i2c 0~7 bit address match flag

< i2c stop condition generation complete flag

Definition at line 615 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_err_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_tx_isr_int(), i2c_slave_tx_rx_isr_dma(), and i2c_wait_flag().

◆ i2c_flag_get()

flag_status i2c_flag_get | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

get flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
flag this parameter can be one of the following values:
  • I2C_STARTF_FLAG: start condition generation complete flag.
  • I2C_ADDR7F_FLAG: 0~7 bit address match flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_ADDRHF_FLAG: master 9~8 bit address header match flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_TRMODE_FLAG: transmission mode.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_DIRF_FLAG: transmission direction flag.
  • I2C_GCADDRF_FLAG: general call address received flag.
  • I2C_DEVADDRF_FLAG: smbus device address received flag.
  • I2C_HOSTADDRF_FLAG: smbus host address received flag.
  • I2C_ADDR2_FLAG: own address 2 received flag.
Return values
flag_status (SET or RESET)

Definition at line 568 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_rx_isr_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_slave_rx_isr_int(), i2c_slave_tx_isr_int(), i2c_slave_tx_rx_isr_dma(), and i2c_wait_flag().

◆ i2c_general_call_enable()

void i2c_general_call_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable general call.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 326 of file at32f413_i2c.c.

◆ i2c_init()

void i2c_init | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty,
 |  | uint32_t | speed
 | ) |  |

init i2c speed and duty cycle.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
speed | i2c scl clock speed, such as 100000
Return values
none

Definition at line 88 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_interrupt_enable()

void i2c_interrupt_enable | ( | i2c_type * | i2c_x,
 |  | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupt

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
source this parameter can be one of the following values:
  • I2C_DATA_INT: data interrupt.
  • I2C_EV_INT: event interrupt.
  • I2C_ERR_INT: error interrupt.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 453 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_err_irq_handler(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_memory_read_int(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_slave_tx_isr_int(), and i2c_slave_tx_rx_isr_dma().

◆ i2c_master_receive_ack_set()

void i2c_master_receive_ack_set | ( | i2c_type * | i2c_x,
 |  | i2c_master_ack_type | pos
 | ) |  |

master receiving mode acknowledge control.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_MASTER_ACK_CURRENT: acken bit acts on the current byte
  • I2C_MASTER_ACK_NEXT: acken bit acts on the next byte
Return values
none

Definition at line 297 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_own_address1_set()

void i2c_own_address1_set | ( | i2c_type * | i2c_x,
 |  | i2c_address_mode_type | mode,
 |  | uint16_t | address
 | ) |  |

config own address1.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
mode this parameter can be one of the following values:
  • I2C_ADDRESS_MODE_7BIT: 7bit address.
  • I2C_ADDRESS_MODE_10BIT: 10bit address.
address | own address1, such as 0xb0.
Return values
none

Definition at line 183 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_own_address2_enable()

void i2c_own_address2_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 213 of file at32f413_i2c.c.

◆ i2c_own_address2_set()

void i2c_own_address2_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | address
 | ) |  |

config own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the 7bit i2c own address2, such as 0xa0.
Return values
none.

Definition at line 200 of file at32f413_i2c.c.

◆ i2c_pec_calculate_enable()

void i2c_pec_calculate_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec calcultetion.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 397 of file at32f413_i2c.c.

◆ i2c_pec_position_set()

void i2c_pec_position_set | ( | i2c_type * | i2c_x,
 |  | i2c_pec_position_type | pos
 | ) |  |

pec position set.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_PEC_POSITION_CURRENT: the current byte is pec
  • I2C_PEC_POSITION_NEXT: the next byte is pec
Return values
none

Definition at line 313 of file at32f413_i2c.c.

◆ i2c_pec_transmit_enable()

void i2c_pec_transmit_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 384 of file at32f413_i2c.c.

◆ i2c_pec_value_get()

uint8_t i2c_pec_value_get ( i2c_type * i2c_x )

get pec value.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t pec value.

Definition at line 409 of file at32f413_i2c.c.

◆ i2c_reset()

void i2c_reset ( i2c_type * i2c_x )

reset the i2c register

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none

Definition at line 49 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_smbus_alert_set()

void i2c_smbus_alert_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_alert_set_type | level
 | ) |  |

drive the smbus alert pin high or low.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_ALERT_LOW: smbus alert pin set low.
  • I2C_SMBUS_ALERT_HIGH: smbus alert pin set high.
Return values
none

Definition at line 371 of file at32f413_i2c.c.

◆ i2c_smbus_enable()

void i2c_smbus_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the smbus mode

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 226 of file at32f413_i2c.c.

◆ i2c_smbus_mode_set()

void i2c_smbus_mode_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_mode_set_type | mode
 | ) |  |

config smbus host or device.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_MODE_DEVICE: smbus device.
  • I2C_SMBUS_MODE_HOST: smbus host.
Return values
none

Definition at line 355 of file at32f413_i2c.c.

◆ i2c_software_reset()

void i2c_software_reset | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

software reset.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 71 of file at32f413_i2c.c.

◆ i2c_start_generate()

void i2c_start_generate ( i2c_type * i2c_x )

generate start condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 472 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_stop_generate()

void i2c_stop_generate ( i2c_type * i2c_x )

generate stop condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 484 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_memory_address_send(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), and i2c_wait_flag().


AT32F413 Firmwary Library: I2C_private_functions

Functions
I2C_private_functions
AT32F413_periph_driver » I2C

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

Function Documentation

◆ i2c_7bit_address_send()

void i2c_7bit_address_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | address,
 |  | i2c_direction_type | direction
 | ) |  |

transmit the slave address.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the slave address which will be transmitted
direction this parameter can be one of the following values:
  • I2C_DIRECTION_TRANSMIT: transmit mode.
  • I2C_DIRECTION_RECEIVE: receive mode.
Return values
none.

Definition at line 501 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_ack_enable()

void i2c_ack_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable acknowledge.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none.

Definition at line 281 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_rx_isr_dma().

◆ i2c_arp_mode_enable()

void i2c_arp_mode_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable arp mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 339 of file at32f413_i2c.c.

◆ i2c_clock_stretch_enable()

void i2c_clock_stretch_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock stretch.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 268 of file at32f413_i2c.c.

◆ i2c_data_receive()

uint8_t i2c_data_receive ( i2c_type * i2c_x )

receive a byte through the i2c periph.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t received byte

Definition at line 533 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_slave_receive(), and i2c_slave_rx_isr_int().

◆ i2c_data_send()

void i2c_data_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | data
 | ) |  |

send a byte through the i2c periph.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
data | byte to be transmitted.
Return values
none

Definition at line 521 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), i2c_master_transmit(), i2c_master_tx_isr_int(), i2c_master_write_addr(), i2c_memory_address_send(), i2c_memory_write(), i2c_slave_transmit(), and i2c_slave_tx_isr_int().

◆ i2c_dma_enable()

void i2c_dma_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma requests.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 435 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_dma_end_transfer_set()

void i2c_dma_end_transfer_set | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable if the next dma transfer will be the last one.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 422 of file at32f413_i2c.c.

Referenced by i2c_master_receive_dma(), and i2c_memory_read_dma().

◆ i2c_enable()

void i2c_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2c periph

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 239 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_fast_mode_duty_set()

void i2c_fast_mode_duty_set | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty
 | ) |  |

config fast mode duty cycle

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
Return values
none

Definition at line 255 of file at32f413_i2c.c.

◆ i2c_flag_clear()

void i2c_flag_clear | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

clear flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
flag this parameter can be any combination of the following values:
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_ADDR7F_FLAG: i2c 0~7 bit address match flag.
Return values
none

< i2c 0~7 bit address match flag

< i2c stop condition generation complete flag

Definition at line 615 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_err_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_tx_isr_int(), i2c_slave_tx_rx_isr_dma(), and i2c_wait_flag().

◆ i2c_flag_get()

flag_status i2c_flag_get | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

get flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
flag this parameter can be one of the following values:
  • I2C_STARTF_FLAG: start condition generation complete flag.
  • I2C_ADDR7F_FLAG: 0~7 bit address match flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_ADDRHF_FLAG: master 9~8 bit address header match flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_TRMODE_FLAG: transmission mode.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_DIRF_FLAG: transmission direction flag.
  • I2C_GCADDRF_FLAG: general call address received flag.
  • I2C_DEVADDRF_FLAG: smbus device address received flag.
  • I2C_HOSTADDRF_FLAG: smbus host address received flag.
  • I2C_ADDR2_FLAG: own address 2 received flag.
Return values
flag_status (SET or RESET)

Definition at line 568 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_rx_isr_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_slave_rx_isr_int(), i2c_slave_tx_isr_int(), i2c_slave_tx_rx_isr_dma(), and i2c_wait_flag().

◆ i2c_general_call_enable()

void i2c_general_call_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable general call.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 326 of file at32f413_i2c.c.

◆ i2c_init()

void i2c_init | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty,
 |  | uint32_t | speed
 | ) |  |

init i2c speed and duty cycle.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
speed | i2c scl clock speed, such as 100000
Return values
none

Definition at line 88 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_interrupt_enable()

void i2c_interrupt_enable | ( | i2c_type * | i2c_x,
 |  | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupt

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
source this parameter can be one of the following values:
  • I2C_DATA_INT: data interrupt.
  • I2C_EV_INT: event interrupt.
  • I2C_ERR_INT: error interrupt.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 453 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_err_irq_handler(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_memory_read_int(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_slave_tx_isr_int(), and i2c_slave_tx_rx_isr_dma().

◆ i2c_master_receive_ack_set()

void i2c_master_receive_ack_set | ( | i2c_type * | i2c_x,
 |  | i2c_master_ack_type | pos
 | ) |  |

master receiving mode acknowledge control.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_MASTER_ACK_CURRENT: acken bit acts on the current byte
  • I2C_MASTER_ACK_NEXT: acken bit acts on the next byte
Return values
none

Definition at line 297 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_own_address1_set()

void i2c_own_address1_set | ( | i2c_type * | i2c_x,
 |  | i2c_address_mode_type | mode,
 |  | uint16_t | address
 | ) |  |

config own address1.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
mode this parameter can be one of the following values:
  • I2C_ADDRESS_MODE_7BIT: 7bit address.
  • I2C_ADDRESS_MODE_10BIT: 10bit address.
address | own address1, such as 0xb0.
Return values
none

Definition at line 183 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_own_address2_enable()

void i2c_own_address2_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 213 of file at32f413_i2c.c.

◆ i2c_own_address2_set()

void i2c_own_address2_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | address
 | ) |  |

config own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the 7bit i2c own address2, such as 0xa0.
Return values
none.

Definition at line 200 of file at32f413_i2c.c.

◆ i2c_pec_calculate_enable()

void i2c_pec_calculate_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec calcultetion.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 397 of file at32f413_i2c.c.

◆ i2c_pec_position_set()

void i2c_pec_position_set | ( | i2c_type * | i2c_x,
 |  | i2c_pec_position_type | pos
 | ) |  |

pec position set.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_PEC_POSITION_CURRENT: the current byte is pec
  • I2C_PEC_POSITION_NEXT: the next byte is pec
Return values
none

Definition at line 313 of file at32f413_i2c.c.

◆ i2c_pec_transmit_enable()

void i2c_pec_transmit_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 384 of file at32f413_i2c.c.

◆ i2c_pec_value_get()

uint8_t i2c_pec_value_get ( i2c_type * i2c_x )

get pec value.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t pec value.

Definition at line 409 of file at32f413_i2c.c.

◆ i2c_reset()

void i2c_reset ( i2c_type * i2c_x )

reset the i2c register

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none

Definition at line 49 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_smbus_alert_set()

void i2c_smbus_alert_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_alert_set_type | level
 | ) |  |

drive the smbus alert pin high or low.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_ALERT_LOW: smbus alert pin set low.
  • I2C_SMBUS_ALERT_HIGH: smbus alert pin set high.
Return values
none

Definition at line 371 of file at32f413_i2c.c.

◆ i2c_smbus_enable()

void i2c_smbus_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the smbus mode

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 226 of file at32f413_i2c.c.

◆ i2c_smbus_mode_set()

void i2c_smbus_mode_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_mode_set_type | mode
 | ) |  |

config smbus host or device.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_MODE_DEVICE: smbus device.
  • I2C_SMBUS_MODE_HOST: smbus host.
Return values
none

Definition at line 355 of file at32f413_i2c.c.

◆ i2c_software_reset()

void i2c_software_reset | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

software reset.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 71 of file at32f413_i2c.c.

◆ i2c_start_generate()

void i2c_start_generate ( i2c_type * i2c_x )

generate start condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 472 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_stop_generate()

void i2c_stop_generate ( i2c_type * i2c_x )

generate stop condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 484 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_memory_address_send(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), and i2c_wait_flag().


AT32F413 Firmwary Library: MISC

Modules
MISC
AT32F413_periph_driver

MISC driver modules. More...

Modules

MISC_vector_table_base_address
MISC_exported_types
MISC_exported_functions
MISC_private_functions

Detailed Description

MISC driver modules.


AT32F413 Firmwary Library: MISC_vector_table_base_address

Macros
MISC_vector_table_base_address
AT32F413_periph_driver » MISC

Macros

#define | NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
#define | NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

Detailed Description

Macro Definition Documentation

◆ NVIC_VECTTAB_FLASH

#define NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

nvic vector table based flash address

Definition at line 50 of file at32f413_misc.h.

◆ NVIC_VECTTAB_RAM

#define NVIC_VECTTAB_RAM ((uint32_t)0x20000000)

nvic vector table based ram address

Definition at line 49 of file at32f413_misc.h.


AT32F413 Firmwary Library: MISC_exported_types

Enumerations
MISC_exported_types
AT32F413_periph_driver » MISC

Enumerations

enum nvic_priority_group_type {
NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7) , NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6) , NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5) , NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4) ,
NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
}
nvic interrupt priority group More...
enum | nvic_lowpower_mode_type { NVIC_LP_SLEEPONEXIT = 0x02 , NVIC_LP_SLEEPDEEP = 0x04 , NVIC_LP_SEVONPEND = 0x10 }
nvic low power mode More...
enum | systick_clock_source_type { SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000) , SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004) }
systick clock source More...

Detailed Description

Enumeration Type Documentation

◆ nvic_lowpower_mode_type

enum nvic_lowpower_mode_type

nvic low power mode

Enumerator
NVIC_LP_SLEEPONEXIT | enable sleep-on-exit feature
NVIC_LP_SLEEPDEEP | enable sleep-deep output signal when entering sleep mode
NVIC_LP_SEVONPEND | send event on pending

Definition at line 75 of file at32f413_misc.h.

◆ nvic_priority_group_type

enum nvic_priority_group_type

nvic interrupt priority group

Enumerator
NVIC_PRIORITY_GROUP_0 | 0 bits for preemption priority, 4 bits for subpriority
NVIC_PRIORITY_GROUP_1 | 1 bits for preemption priority, 3 bits for subpriority
NVIC_PRIORITY_GROUP_2 | 2 bits for preemption priority, 2 bits for subpriority
NVIC_PRIORITY_GROUP_3 | 3 bits for preemption priority, 1 bits for subpriority
NVIC_PRIORITY_GROUP_4 | 4 bits for preemption priority, 0 bits for subpriority

Definition at line 63 of file at32f413_misc.h.

◆ systick_clock_source_type

enum systick_clock_source_type

systick clock source

Enumerator
SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 | systick clock source from core clock div8
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV | systick clock source from core clock

Definition at line 85 of file at32f413_misc.h.


AT32F413 Firmwary Library: MISC_exported_functions

Functions
MISC_exported_functions
AT32F413_periph_driver » MISC

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

Function Documentation

◆ nvic_irq_disable()

void nvic_irq_disable ( IRQn_Type irqn )

disable nvic irq number

Parameters
irqn (IRQn_Type number)
Return values
none

Definition at line 79 of file at32f413_misc.c.

Referenced by app_load(), and jump_to_app().

◆ nvic_irq_enable()

void nvic_irq_enable | ( | IRQn_Type | irqn,
 |  | uint32_t | preempt_priority,
 |  | uint32_t | sub_priority
 | ) |  |

enable nvic irq

Parameters
irqn | (IRQn_Type number)
preempt_priority | preemptive priority value (starting from 0)
sub_priority | subpriority value (starting from 0)
Return values
none

Definition at line 62 of file at32f413_misc.c.

Referenced by adc_config(), alarm_init(), button_exint_init(), can_configuration(), codec_i2s_init(), config_flash_interrupt(), dma_config(), dma_configuration(), exint_line0_config(), exint_line4_config(), i2c_lowlevel_init(), i2s_config(), main(), nvic_configuration(), rs485_config(), rtc_config(), spi_config(), tmr1_config(), tmr2_config(), tmr_init(), uart_init(), usart1_config(), usart_configuration(), and usb_usart_config().

◆ nvic_lowpower_mode_config()

void nvic_lowpower_mode_config | ( | nvic_lowpower_mode_type | lp_mode,
 |  | confirm_state | new_state
 | ) |  |

config nvic lowpower mode

Parameters
lp_mode this parameter can be one of the following values:
  • NVIC_LP_SEVONPEND
  • NVIC_LP_SLEEPDEEP
  • NVIC_LP_SLEEPONEXIT
new_state (new state of lp condition. ENABLE or DISABLE)
Return values
none

Definition at line 125 of file at32f413_misc.c.

◆ nvic_priority_group_config()

void nvic_priority_group_config ( nvic_priority_group_type priority_group )

config nvic priority group

Parameters
priority_group this parameter can be one of the following values:
  • NVIC_PRIORITY_GROUP_0
  • NVIC_PRIORITY_GROUP_1
  • NVIC_PRIORITY_GROUP_2
  • NVIC_PRIORITY_GROUP_3
  • NVIC_PRIORITY_GROUP_4
Return values
none

Definition at line 95 of file at32f413_misc.c.

Referenced by button_exint_init(), config_flash_interrupt(), exint_line0_config(), main(), nvic_configuration(), and usart_configuration().

◆ nvic_system_reset()

void nvic_system_reset ( void )

system reset

Parameters
none
Return values
none

Definition at line 50 of file at32f413_misc.c.

Referenced by app_loop(), extend_sram(), iap_command_handle(), and main().

◆ nvic_vector_table_set()

void nvic_vector_table_set | ( | uint32_t | base,
 |  | uint32_t | offset
 | ) |  |

set the vector table location and offset.

Parameters
base this parameter can be one of the following values:
  • NVIC_VECTTAB_RAM
  • NVIC_VECTTAB_FLASH
offset (vector table base offset field. this value must be a multiple of 0x200)
Return values
none

Definition at line 110 of file at32f413_misc.c.

Referenced by main().

◆ systick_clock_source_config()

void systick_clock_source_config ( systick_clock_source_type source )

config systick clock source

Parameters
source this parameter can be one of the following values:
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Return values
none

Definition at line 145 of file at32f413_misc.c.

Referenced by delay_init(), and main().


AT32F413 Firmwary Library: MISC_private_functions

Macros | Functions
MISC_private_functions
AT32F413_periph_driver » MISC

Macros

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

Macro Definition Documentation

◆ AIRCR_VECTKEY_MASK

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Definition at line 43 of file at32f413_misc.c.

Function Documentation

◆ nvic_irq_disable()

void nvic_irq_disable ( IRQn_Type irqn )

disable nvic irq number

Parameters
irqn (IRQn_Type number)
Return values
none

Definition at line 79 of file at32f413_misc.c.

Referenced by app_load(), and jump_to_app().

◆ nvic_irq_enable()

void nvic_irq_enable | ( | IRQn_Type | irqn,
 |  | uint32_t | preempt_priority,
 |  | uint32_t | sub_priority
 | ) |  |

enable nvic irq

Parameters
irqn | (IRQn_Type number)
preempt_priority | preemptive priority value (starting from 0)
sub_priority | subpriority value (starting from 0)
Return values
none

Definition at line 62 of file at32f413_misc.c.

Referenced by adc_config(), alarm_init(), button_exint_init(), can_configuration(), codec_i2s_init(), config_flash_interrupt(), dma_config(), dma_configuration(), exint_line0_config(), exint_line4_config(), i2c_lowlevel_init(), i2s_config(), main(), nvic_configuration(), rs485_config(), rtc_config(), spi_config(), tmr1_config(), tmr2_config(), tmr_init(), uart_init(), usart1_config(), usart_configuration(), and usb_usart_config().

◆ nvic_lowpower_mode_config()

void nvic_lowpower_mode_config | ( | nvic_lowpower_mode_type | lp_mode,
 |  | confirm_state | new_state
 | ) |  |

config nvic lowpower mode

Parameters
lp_mode this parameter can be one of the following values:
  • NVIC_LP_SEVONPEND
  • NVIC_LP_SLEEPDEEP
  • NVIC_LP_SLEEPONEXIT
new_state (new state of lp condition. ENABLE or DISABLE)
Return values
none

Definition at line 125 of file at32f413_misc.c.

◆ nvic_priority_group_config()

void nvic_priority_group_config ( nvic_priority_group_type priority_group )

config nvic priority group

Parameters
priority_group this parameter can be one of the following values:
  • NVIC_PRIORITY_GROUP_0
  • NVIC_PRIORITY_GROUP_1
  • NVIC_PRIORITY_GROUP_2
  • NVIC_PRIORITY_GROUP_3
  • NVIC_PRIORITY_GROUP_4
Return values
none

Definition at line 95 of file at32f413_misc.c.

Referenced by button_exint_init(), config_flash_interrupt(), exint_line0_config(), main(), nvic_configuration(), and usart_configuration().

◆ nvic_system_reset()

void nvic_system_reset ( void )

system reset

Parameters
none
Return values
none

Definition at line 50 of file at32f413_misc.c.

Referenced by app_loop(), extend_sram(), iap_command_handle(), and main().

◆ nvic_vector_table_set()

void nvic_vector_table_set | ( | uint32_t | base,
 |  | uint32_t | offset
 | ) |  |

set the vector table location and offset.

Parameters
base this parameter can be one of the following values:
  • NVIC_VECTTAB_RAM
  • NVIC_VECTTAB_FLASH
offset (vector table base offset field. this value must be a multiple of 0x200)
Return values
none

Definition at line 110 of file at32f413_misc.c.

Referenced by main().

◆ systick_clock_source_config()

void systick_clock_source_config ( systick_clock_source_type source )

config systick clock source

Parameters
source this parameter can be one of the following values:
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Return values
none

Definition at line 145 of file at32f413_misc.c.

Referenced by delay_init(), and main().


AT32F413 Firmwary Library: PWC

Modules | Macros
PWC
AT32F413_periph_driver

PWC driver modules. More...

Modules

PWC_flags_definition
pwc flag
PWC_exported_types
PWC_exported_functions
PWC_private_functions

Macros

#define | PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
pwc wakeup pin num definition More...
#define | PWC ((pwc_type *) PWC_BASE)

Detailed Description

PWC driver modules.

Macro Definition Documentation

◆ PWC

#define PWC ((pwc_type *) PWC_BASE)

Definition at line 146 of file at32f413_pwc.h.

◆ PWC_WAKEUP_PIN_1

#define PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)

pwc wakeup pin num definition

standby wake-up pin1

Definition at line 61 of file at32f413_pwc.h.


AT32F413 Firmwary Library: PWC_flags_definition

Macros
PWC_flags_definition
AT32F413_periph_driver » PWC

pwc flag More...

Macros

#define | PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
#define | PWC_STANDBY_FLAG ((uint32_t)0x00000002)
#define | PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)

Detailed Description

pwc flag

Macro Definition Documentation

◆ PWC_PVM_OUTPUT_FLAG

#define PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)

pvm output flag

Definition at line 52 of file at32f413_pwc.h.

◆ PWC_STANDBY_FLAG

#define PWC_STANDBY_FLAG ((uint32_t)0x00000002)

standby flag

Definition at line 51 of file at32f413_pwc.h.

◆ PWC_WAKEUP_FLAG

#define PWC_WAKEUP_FLAG ((uint32_t)0x00000001)

wakeup flag

Definition at line 50 of file at32f413_pwc.h.


AT32F413 Firmwary Library: PWC_exported_types

Data Structures | Enumerations
PWC_exported_types
AT32F413_periph_driver » PWC

Data Structures

struct pwc_type
type define pwc register all More...

Enumerations

enum pwc_pvm_voltage_type {
PWC_PVM_VOLTAGE_2V3 = 0x01 , PWC_PVM_VOLTAGE_2V4 = 0x02 , PWC_PVM_VOLTAGE_2V5 = 0x03 , PWC_PVM_VOLTAGE_2V6 = 0x04 ,
PWC_PVM_VOLTAGE_2V7 = 0x05 , PWC_PVM_VOLTAGE_2V8 = 0x06 , PWC_PVM_VOLTAGE_2V9 = 0x07
}
pwc pvm voltage type More...
enum | pwc_sleep_enter_type { PWC_SLEEP_ENTER_WFI = 0x00 , PWC_SLEEP_ENTER_WFE = 0x01 }
pwc sleep enter type More...
enum | pwc_deep_sleep_enter_type { PWC_DEEP_SLEEP_ENTER_WFI = 0x00 , PWC_DEEP_SLEEP_ENTER_WFE = 0x01 }
pwc deep sleep enter type More...

Detailed Description

Enumeration Type Documentation

◆ pwc_deep_sleep_enter_type

enum pwc_deep_sleep_enter_type

pwc deep sleep enter type

Enumerator
PWC_DEEP_SLEEP_ENTER_WFI | use wfi enter deepsleep mode
PWC_DEEP_SLEEP_ENTER_WFE | use wfe enter deepsleep mode

Definition at line 93 of file at32f413_pwc.h.

◆ pwc_pvm_voltage_type

enum pwc_pvm_voltage_type

pwc pvm voltage type

Enumerator
PWC_PVM_VOLTAGE_2V3 | power voltage monitoring boundary 2.3v
PWC_PVM_VOLTAGE_2V4 | power voltage monitoring boundary 2.4v
PWC_PVM_VOLTAGE_2V5 | power voltage monitoring boundary 2.5v
PWC_PVM_VOLTAGE_2V6 | power voltage monitoring boundary 2.6v
PWC_PVM_VOLTAGE_2V7 | power voltage monitoring boundary 2.7v
PWC_PVM_VOLTAGE_2V8 | power voltage monitoring boundary 2.8v
PWC_PVM_VOLTAGE_2V9 | power voltage monitoring boundary 2.9v

Definition at line 70 of file at32f413_pwc.h.

◆ pwc_sleep_enter_type

enum pwc_sleep_enter_type

pwc sleep enter type

Enumerator
PWC_SLEEP_ENTER_WFI | use wfi enter sleep mode
PWC_SLEEP_ENTER_WFE | use wfe enter sleep mode

Definition at line 84 of file at32f413_pwc.h.


AT32F413 Firmwary Library: pwc_type Struct Reference

Data Fields
pwc_type Struct Reference
AT32F413_periph_driver » PWC » PWC_exported_types

type define pwc register all More...

#include <at32f413_pwc.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t reserved1: 1
__IO uint32_t lpsel: 1
__IO uint32_t clswef: 1
__IO uint32_t clsef: 1
__IO uint32_t pvmen: 1
__IO uint32_t pvmsel: 3
__IO uint32_t bpwen: 1
__IO uint32_t reserved2: 23
} ctrl_bit
};
pwc ctrl register, offset:0x00 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t swef: 1
__IO uint32_t sef: 1
__IO uint32_t pvmof: 1
__IO uint32_t reserved1: 5
__IO uint32_t swpen: 1
__IO uint32_t reserved2: 23
} ctrlsts_bit
};
pwc ctrlsts register, offset:0x04 More...

Detailed Description

type define pwc register all

Definition at line 102 of file at32f413_pwc.h.

Field Documentation

◆

union { ... } pwc_type::@535

pwc ctrl register, offset:0x00

◆

union { ... } pwc_type::@537

pwc ctrlsts register, offset:0x04

◆ bpwen

__IO uint32_t pwc_type::bpwen

Definition at line 118 of file at32f413_pwc.h.

◆ clsef

__IO uint32_t pwc_type::clsef

Definition at line 115 of file at32f413_pwc.h.

◆ clswef

__IO uint32_t pwc_type::clswef

Definition at line 114 of file at32f413_pwc.h.

◆ ctrl

__IO uint32_t pwc_type::ctrl

Definition at line 109 of file at32f413_pwc.h.

◆

struct { ... } pwc_type::ctrl_bit

◆ ctrlsts

__IO uint32_t pwc_type::ctrlsts

Definition at line 128 of file at32f413_pwc.h.

◆

struct { ... } pwc_type::ctrlsts_bit

◆ lpsel

__IO uint32_t pwc_type::lpsel

Definition at line 113 of file at32f413_pwc.h.

◆ pvmen

__IO uint32_t pwc_type::pvmen

Definition at line 116 of file at32f413_pwc.h.

◆ pvmof

__IO uint32_t pwc_type::pvmof

Definition at line 133 of file at32f413_pwc.h.

◆ pvmsel

__IO uint32_t pwc_type::pvmsel

Definition at line 117 of file at32f413_pwc.h.

◆ reserved1

__IO uint32_t pwc_type::reserved1

Definition at line 112 of file at32f413_pwc.h.

◆ reserved2

__IO uint32_t pwc_type::reserved2

Definition at line 119 of file at32f413_pwc.h.

◆ sef

__IO uint32_t pwc_type::sef

Definition at line 132 of file at32f413_pwc.h.

◆ swef

__IO uint32_t pwc_type::swef

Definition at line 131 of file at32f413_pwc.h.

◆ swpen

__IO uint32_t pwc_type::swpen

Definition at line 135 of file at32f413_pwc.h.

The documentation for this struct was generated from the following file:
  • at32f413_pwc.h


AT32F413 Firmwary Library: PWC_exported_functions

Functions
PWC_exported_functions
AT32F413_periph_driver » PWC

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

Function Documentation

◆ pwc_battery_powered_domain_access()

void pwc_battery_powered_domain_access ( confirm_state new_state )

enable or disable access to the battery powered domain.

Parameters
new_state new state of battery powered domain access. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 59 of file at32f413_pwc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_config(), rtc_configuration(), rtc_init(), and rtc_time_set().

◆ pwc_deep_sleep_mode_enter()

void pwc_deep_sleep_mode_enter ( pwc_deep_sleep_enter_type pwc_deep_sleep_enter )

enter pwc deep-sleep mode

Parameters
pwc_deep_sleep_enter choose the instruction to enter deep sleep mode. this parameter can be one of the following values:
  • PWC_DEEP_SLEEP_ENTER_WFI
  • PWC_DEEP_SLEEP_ENTER_WFE
Return values
none

Definition at line 187 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_clear()

void pwc_flag_clear ( uint32_t pwc_flag )

clear flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be any combination of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • note:"PWC_PVM_OUTPUT_FLAG" cannot be choose!this bit is readonly bit,it means the voltage monitoring output state
Return values
none

< standby flag

< wakeup flag

Definition at line 125 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_get()

flag_status pwc_flag_get ( uint32_t pwc_flag )

get flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be one of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • PWC_PVM_OUTPUT_FLAG
Return values
state of select flag(SET or RESET).

Definition at line 142 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_power_voltage_monitor_enable()

void pwc_power_voltage_monitor_enable ( confirm_state new_state )

enable or disable pwc power voltage monitor (pvm)

Parameters
new_state new state of pvm. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 88 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_pvm_level_select()

void pwc_pvm_level_select ( pwc_pvm_voltage_type pvm_voltage )

select the voltage threshold detected by the power voltage detector.

Parameters
pvm_voltage select pwc pvm voltage this parameter can be one of the following values:
  • PWC_PVM_VOLTAGE_2V3
  • PWC_PVM_VOLTAGE_2V4
  • PWC_PVM_VOLTAGE_2V5
  • PWC_PVM_VOLTAGE_2V6
  • PWC_PVM_VOLTAGE_2V7
  • PWC_PVM_VOLTAGE_2V8
  • PWC_PVM_VOLTAGE_2V9
Return values
none

Definition at line 77 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_reset()

void pwc_reset ( void )

deinitialize the pwc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 47 of file at32f413_pwc.c.

◆ pwc_sleep_mode_enter()

void pwc_sleep_mode_enter ( pwc_sleep_enter_type pwc_sleep_enter )

enter pwc sleep mode

Parameters
sleep_mode_enter choose the instruction to enter sleep mode. this parameter can be one of the following values:
  • PWC_SLEEP_ENTER_WFI
  • PWC_SLEEP_ENTER_WFE
Return values
none

Definition at line 164 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_standby_mode_enter()

void pwc_standby_mode_enter ( void )

enter pwc standby mode

Parameters
none
Return values
none

Definition at line 208 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_wakeup_pin_enable()

void pwc_wakeup_pin_enable | ( | uint32_t | pin_num,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pwc standby wakeup pin

Parameters
pin_num choose the wakeup pin. this parameter can be be any combination of the following values:
  • PWC_WAKEUP_PIN_1
new_state new state of the standby wakeup pin. this parameter can be one of the following values:
  • TRUE <wakeup pin is used for wake up cpu from standby mode>
  • FALSE <wakeup pin is used for general purpose I/O>
Return values
none

Definition at line 104 of file at32f413_pwc.c.

Referenced by main().


AT32F413 Firmwary Library: PWC_private_functions

Functions
PWC_private_functions
AT32F413_periph_driver » PWC

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

Function Documentation

◆ pwc_battery_powered_domain_access()

void pwc_battery_powered_domain_access ( confirm_state new_state )

enable or disable access to the battery powered domain.

Parameters
new_state new state of battery powered domain access. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 59 of file at32f413_pwc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_config(), rtc_configuration(), rtc_init(), and rtc_time_set().

◆ pwc_deep_sleep_mode_enter()

void pwc_deep_sleep_mode_enter ( pwc_deep_sleep_enter_type pwc_deep_sleep_enter )

enter pwc deep-sleep mode

Parameters
pwc_deep_sleep_enter choose the instruction to enter deep sleep mode. this parameter can be one of the following values:
  • PWC_DEEP_SLEEP_ENTER_WFI
  • PWC_DEEP_SLEEP_ENTER_WFE
Return values
none

Definition at line 187 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_clear()

void pwc_flag_clear ( uint32_t pwc_flag )

clear flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be any combination of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • note:"PWC_PVM_OUTPUT_FLAG" cannot be choose!this bit is readonly bit,it means the voltage monitoring output state
Return values
none

< standby flag

< wakeup flag

Definition at line 125 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_get()

flag_status pwc_flag_get ( uint32_t pwc_flag )

get flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be one of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • PWC_PVM_OUTPUT_FLAG
Return values
state of select flag(SET or RESET).

Definition at line 142 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_power_voltage_monitor_enable()

void pwc_power_voltage_monitor_enable ( confirm_state new_state )

enable or disable pwc power voltage monitor (pvm)

Parameters
new_state new state of pvm. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 88 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_pvm_level_select()

void pwc_pvm_level_select ( pwc_pvm_voltage_type pvm_voltage )

select the voltage threshold detected by the power voltage detector.

Parameters
pvm_voltage select pwc pvm voltage this parameter can be one of the following values:
  • PWC_PVM_VOLTAGE_2V3
  • PWC_PVM_VOLTAGE_2V4
  • PWC_PVM_VOLTAGE_2V5
  • PWC_PVM_VOLTAGE_2V6
  • PWC_PVM_VOLTAGE_2V7
  • PWC_PVM_VOLTAGE_2V8
  • PWC_PVM_VOLTAGE_2V9
Return values
none

Definition at line 77 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_reset()

void pwc_reset ( void )

deinitialize the pwc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 47 of file at32f413_pwc.c.

◆ pwc_sleep_mode_enter()

void pwc_sleep_mode_enter ( pwc_sleep_enter_type pwc_sleep_enter )

enter pwc sleep mode

Parameters
sleep_mode_enter choose the instruction to enter sleep mode. this parameter can be one of the following values:
  • PWC_SLEEP_ENTER_WFI
  • PWC_SLEEP_ENTER_WFE
Return values
none

Definition at line 164 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_standby_mode_enter()

void pwc_standby_mode_enter ( void )

enter pwc standby mode

Parameters
none
Return values
none

Definition at line 208 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_wakeup_pin_enable()

void pwc_wakeup_pin_enable | ( | uint32_t | pin_num,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pwc standby wakeup pin

Parameters
pin_num choose the wakeup pin. this parameter can be be any combination of the following values:
  • PWC_WAKEUP_PIN_1
new_state new state of the standby wakeup pin. this parameter can be one of the following values:
  • TRUE <wakeup pin is used for wake up cpu from standby mode>
  • FALSE <wakeup pin is used for general purpose I/O>
Return values
none

Definition at line 104 of file at32f413_pwc.c.

Referenced by main().


AT32F413 Firmwary Library: RTC

Modules | Macros
RTC
AT32F413_periph_driver

RTC driver modules. More...

Modules

RTC_interrupts_definition
rtc interrupt
RTC_flags_definition
rtc flag
RTC_exported_types
RTC_exported_functions
RTC_private_functions

Macros

#define RTC ((rtc_type *) RTC_BASE)

Detailed Description

RTC driver modules.

Macro Definition Documentation

◆ RTC

#define RTC ((rtc_type *) RTC_BASE)

Definition at line 226 of file at32f413_rtc.h.


AT32F413 Firmwary Library: RTC_interrupts_definition

Macros
RTC_interrupts_definition
AT32F413_periph_driver » RTC

rtc interrupt More...

Macros

#define | RTC_TS_INT ((uint16_t)0x0001)
#define | RTC_TA_INT ((uint16_t)0x0002)
#define | RTC_OVF_INT ((uint16_t)0x0004)

Detailed Description

rtc interrupt

Macro Definition Documentation

◆ RTC_OVF_INT

#define RTC_OVF_INT ((uint16_t)0x0004)

rtc overflow interrupt

Definition at line 52 of file at32f413_rtc.h.

◆ RTC_TA_INT

#define RTC_TA_INT ((uint16_t)0x0002)

rtc time alarm interrupt

Definition at line 51 of file at32f413_rtc.h.

◆ RTC_TS_INT

#define RTC_TS_INT ((uint16_t)0x0001)

rtc time second interrupt

Definition at line 50 of file at32f413_rtc.h.


AT32F413 Firmwary Library: RTC_flags_definition

Macros
RTC_flags_definition
AT32F413_periph_driver » RTC

rtc flag More...

Macros

#define | RTC_TS_FLAG ((uint16_t)0x0001)
#define | RTC_TA_FLAG ((uint16_t)0x0002)
#define | RTC_OVF_FLAG ((uint16_t)0x0004)
#define | RTC_UPDF_FLAG ((uint16_t)0x0008)
#define | RTC_CFGF_FLAG ((uint16_t)0x0020)

Detailed Description

rtc flag

Macro Definition Documentation

◆ RTC_CFGF_FLAG

#define RTC_CFGF_FLAG ((uint16_t)0x0020)

rtc configuration finish flag

Definition at line 67 of file at32f413_rtc.h.

◆ RTC_OVF_FLAG

#define RTC_OVF_FLAG ((uint16_t)0x0004)

rtc overflow flag

Definition at line 65 of file at32f413_rtc.h.

◆ RTC_TA_FLAG

#define RTC_TA_FLAG ((uint16_t)0x0002)

rtc time alarm flag

Definition at line 64 of file at32f413_rtc.h.

◆ RTC_TS_FLAG

#define RTC_TS_FLAG ((uint16_t)0x0001)

rtc time second flag

Definition at line 63 of file at32f413_rtc.h.

◆ RTC_UPDF_FLAG

#define RTC_UPDF_FLAG ((uint16_t)0x0008)

rtc update finish flag

Definition at line 66 of file at32f413_rtc.h.


AT32F413 Firmwary Library: RTC_exported_types

Data Structures
RTC_exported_types
AT32F413_periph_driver » RTC

Data Structures

struct rtc_type
type define rtc register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: rtc_type Struct Reference

Data Fields
rtc_type Struct Reference
AT32F413_periph_driver » RTC » RTC_exported_types

type define rtc register all More...

#include <at32f413_rtc.h>

Data Fields

union {
__IO uint32_t ctrlh
struct {
__IO uint32_t tsien: 1
__IO uint32_t taien: 1
__IO uint32_t ovfien: 1
__IO uint32_t reserved1: 29
} ctrlh_bit
};
rtc ctrlh register, offset:0x00 More...
union {
__IO uint32_t ctrll
struct {
__IO uint32_t tsf: 1
__IO uint32_t taf: 1
__IO uint32_t ovff: 1
__IO uint32_t updf: 1
__IO uint32_t cfgen: 1
__IO uint32_t cfgf: 1
__IO uint32_t reserved1: 26
} ctrll_bit
};
rtc ctrll register, offset:0x04 More...
union {
__IO uint32_t divh
struct {
__IO uint32_t div: 4
__IO uint32_t reserved1: 28
} divh_bit
};
rtc divh register, offset:0x08 More...
union {
__IO uint32_t divl
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} divl_bit
};
rtc divl register, offset:0x0C More...
union {
__IO uint32_t divcnth
struct {
__IO uint32_t divcnt: 4
__IO uint32_t reserved1: 28
} divcnth_bit
};
rtc divcnth register, offset:0x10 More...
union {
__IO uint32_t divcntl
struct {
__IO uint32_t divcnt: 16
__IO uint32_t reserved1: 16
} divcntl_bit
};
rtc divcntl register, offset:0x14 More...
union {
__IO uint32_t cnth
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} cnth_bit
};
rtc cnth register, offset:0x18 More...
union {
__IO uint32_t cntl
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} cntl_bit
};
rtc cntl register, offset:0x1C More...
union {
__IO uint32_t tah
struct {
__IO uint32_t ta: 16
__IO uint32_t reserved1: 16
} tah_bit
};
rtc tah register, offset:0x20 More...
union {
__IO uint32_t tal
struct {
__IO uint32_t ta: 16
__IO uint32_t reserved1: 16
} tal_bit
};
rtc tal register, offset:0x24 More...

Detailed Description

type define rtc register all

Definition at line 80 of file at32f413_rtc.h.

Field Documentation

◆

union { ... } rtc_type::@541

rtc ctrlh register, offset:0x00

◆

union { ... } rtc_type::@543

rtc ctrll register, offset:0x04

◆

union { ... } rtc_type::@545

rtc divh register, offset:0x08

◆

union { ... } rtc_type::@547

rtc divl register, offset:0x0C

◆

union { ... } rtc_type::@549

rtc divcnth register, offset:0x10

◆

union { ... } rtc_type::@551

rtc divcntl register, offset:0x14

◆

union { ... } rtc_type::@553

rtc cnth register, offset:0x18

◆

union { ... } rtc_type::@555

rtc cntl register, offset:0x1C

◆

union { ... } rtc_type::@557

rtc tah register, offset:0x20

◆

union { ... } rtc_type::@559

rtc tal register, offset:0x24

◆ cfgen

__IO uint32_t rtc_type::cfgen

Definition at line 110 of file at32f413_rtc.h.

◆ cfgf

__IO uint32_t rtc_type::cfgf

Definition at line 111 of file at32f413_rtc.h.

◆ cnt

__IO uint32_t rtc_type::cnt

Definition at line 176 of file at32f413_rtc.h.

◆ cnth

__IO uint32_t rtc_type::cnth

Definition at line 173 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::cnth_bit

◆ cntl

__IO uint32_t rtc_type::cntl

Definition at line 186 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::cntl_bit

◆ ctrlh

__IO uint32_t rtc_type::ctrlh

Definition at line 88 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::ctrlh_bit

◆ ctrll

__IO uint32_t rtc_type::ctrll

Definition at line 103 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::ctrll_bit

◆ div

__IO uint32_t rtc_type::div

Definition at line 124 of file at32f413_rtc.h.

◆ divcnt

__IO uint32_t rtc_type::divcnt

Definition at line 150 of file at32f413_rtc.h.

◆ divcnth

__IO uint32_t rtc_type::divcnth

Definition at line 147 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divcnth_bit

◆ divcntl

__IO uint32_t rtc_type::divcntl

Definition at line 160 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divcntl_bit

◆ divh

__IO uint32_t rtc_type::divh

Definition at line 121 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divh_bit

◆ divl

__IO uint32_t rtc_type::divl

Definition at line 134 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divl_bit

◆ ovff

__IO uint32_t rtc_type::ovff

Definition at line 108 of file at32f413_rtc.h.

◆ ovfien

__IO uint32_t rtc_type::ovfien

Definition at line 93 of file at32f413_rtc.h.

◆ reserved1

__IO uint32_t rtc_type::reserved1

Definition at line 94 of file at32f413_rtc.h.

◆ ta

__IO uint32_t rtc_type::ta

Definition at line 202 of file at32f413_rtc.h.

◆ taf

__IO uint32_t rtc_type::taf

Definition at line 107 of file at32f413_rtc.h.

◆ tah

__IO uint32_t rtc_type::tah

Definition at line 199 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::tah_bit

◆ taien

__IO uint32_t rtc_type::taien

Definition at line 92 of file at32f413_rtc.h.

◆ tal

__IO uint32_t rtc_type::tal

Definition at line 212 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::tal_bit

◆ tsf

__IO uint32_t rtc_type::tsf

Definition at line 106 of file at32f413_rtc.h.

◆ tsien

__IO uint32_t rtc_type::tsien

Definition at line 91 of file at32f413_rtc.h.

◆ updf

__IO uint32_t rtc_type::updf

Definition at line 109 of file at32f413_rtc.h.

The documentation for this struct was generated from the following file:
  • at32f413_rtc.h


AT32F413 Firmwary Library: RTC_exported_functions

Functions
RTC_exported_functions
AT32F413_periph_driver » RTC

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

Function Documentation

◆ rtc_alarm_set()

void rtc_alarm_set ( uint32_t alarm_value )

rtc alarm value set

Parameters
alarm_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 113 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_clock_set(), and rtc_alarm_config().

◆ rtc_counter_get()

uint32_t rtc_counter_get ( void )

rtc counter get

Parameters
none
Return values
rtc counter

Definition at line 65 of file at32f413_rtc.c.

Referenced by main(), randnum_test(), rtc_alarm_config(), RTC_IRQHandler(), and rtc_time_get().

◆ rtc_counter_set()

void rtc_counter_set ( uint32_t counter_value )

rtc counter set

Parameters
counter_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 47 of file at32f413_rtc.c.

Referenced by rtc_time_set().

◆ rtc_divider_get()

uint32_t rtc_divider_get ( void )

rtc divider get

Parameters
none
Return values
rtc counter

Definition at line 98 of file at32f413_rtc.c.

◆ rtc_divider_set()

void rtc_divider_set ( uint32_t div_value )

rtc divider set

Parameters
div_value (0x0000_0000 ~ 0x000F_FFFF)
Return values
none

Definition at line 80 of file at32f413_rtc.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ rtc_flag_clear()

void rtc_flag_clear ( uint16_t flag )

rtc flag clear

Parameters
interrupt_flag this parameter can be any combination of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_UPDF_FLAG: rtc update finish flag.
Return values
none

Definition at line 185 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_flag_get()

flag_status rtc_flag_get ( uint16_t flag )

rtc flag get

Parameters
flag this parameter can be one of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_UPDF_FLAG: rtc update finish flag.
  • RTC_CFGF_FLAG: rtc configuration finish flag.
Return values
state of rtc flag

Definition at line 159 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_interrupt_enable()

void rtc_interrupt_enable | ( | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

rtc interrupt enable

Parameters
source this parameter can be any combination of the following values:
  • RTC_TS_INT: time second interrupt.
  • RTC_TA_INT: time alarm interrupt.
  • RTC_OVF_INT: overflow interrupt.
new_state (TRUE or FALSE)
Return values
none

Definition at line 136 of file at32f413_rtc.c.

Referenced by alarm_init(), rtc_config(), and rtc_configuration().

◆ rtc_wait_config_finish()

void rtc_wait_config_finish ( void )

rtc wait configuration finish

Parameters
none
Return values
none

Definition at line 195 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_alarm_config(), rtc_config(), rtc_configuration(), rtc_init(), rtc_time_set(), and RTCAlarm_IRQHandler().

◆ rtc_wait_update_finish()

void rtc_wait_update_finish ( void )

rtc wait update finish

Parameters
none
Return values
none

Definition at line 205 of file at32f413_rtc.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().


AT32F413 Firmwary Library: RTC_private_functions

Functions
RTC_private_functions
AT32F413_periph_driver » RTC

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

Function Documentation

◆ rtc_alarm_set()

void rtc_alarm_set ( uint32_t alarm_value )

rtc alarm value set

Parameters
alarm_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 113 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_clock_set(), and rtc_alarm_config().

◆ rtc_counter_get()

uint32_t rtc_counter_get ( void )

rtc counter get

Parameters
none
Return values
rtc counter

Definition at line 65 of file at32f413_rtc.c.

Referenced by main(), randnum_test(), rtc_alarm_config(), RTC_IRQHandler(), and rtc_time_get().

◆ rtc_counter_set()

void rtc_counter_set ( uint32_t counter_value )

rtc counter set

Parameters
counter_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 47 of file at32f413_rtc.c.

Referenced by rtc_time_set().

◆ rtc_divider_get()

uint32_t rtc_divider_get ( void )

rtc divider get

Parameters
none
Return values
rtc counter

Definition at line 98 of file at32f413_rtc.c.

◆ rtc_divider_set()

void rtc_divider_set ( uint32_t div_value )

rtc divider set

Parameters
div_value (0x0000_0000 ~ 0x000F_FFFF)
Return values
none

Definition at line 80 of file at32f413_rtc.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ rtc_flag_clear()

void rtc_flag_clear ( uint16_t flag )

rtc flag clear

Parameters
interrupt_flag this parameter can be any combination of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_UPDF_FLAG: rtc update finish flag.
Return values
none

Definition at line 185 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_flag_get()

flag_status rtc_flag_get ( uint16_t flag )

rtc flag get

Parameters
flag this parameter can be one of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_UPDF_FLAG: rtc update finish flag.
  • RTC_CFGF_FLAG: rtc configuration finish flag.
Return values
state of rtc flag

Definition at line 159 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_interrupt_enable()

void rtc_interrupt_enable | ( | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

rtc interrupt enable

Parameters
source this parameter can be any combination of the following values:
  • RTC_TS_INT: time second interrupt.
  • RTC_TA_INT: time alarm interrupt.
  • RTC_OVF_INT: overflow interrupt.
new_state (TRUE or FALSE)
Return values
none

Definition at line 136 of file at32f413_rtc.c.

Referenced by alarm_init(), rtc_config(), and rtc_configuration().

◆ rtc_wait_config_finish()

void rtc_wait_config_finish ( void )

rtc wait configuration finish

Parameters
none
Return values
none

Definition at line 195 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_alarm_config(), rtc_config(), rtc_configuration(), rtc_init(), rtc_time_set(), and RTCAlarm_IRQHandler().

◆ rtc_wait_update_finish()

void rtc_wait_update_finish ( void )

rtc wait update finish

Parameters
none
Return values
none

Definition at line 205 of file at32f413_rtc.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().


AT32F413 Firmwary Library: SDIO

Modules
SDIO
AT32F413_periph_driver

SDIO driver modules. More...

Modules

SDIO_interrupts_definition
sdio interrupt
SDIO_flags_definition
sdio flag
SDIO_exported_types
SDIO_exported_functions
SDIO_private_functions

Detailed Description

SDIO driver modules.


AT32F413 Firmwary Library: SDIO_interrupts_definition

Macros
SDIO_interrupts_definition
AT32F413_periph_driver » SDIO

sdio interrupt More...

Macros

#define | SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_INT ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
#define | SDIO_TXERRU_INT ((uint32_t)0x00000010)
#define | SDIO_RXERRO_INT ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
#define | SDIO_DTCMP_INT ((uint32_t)0x00000100)
#define | SDIO_SBITERR_INT ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
#define | SDIO_DOCMD_INT ((uint32_t)0x00000800)
#define | SDIO_DOTX_INT ((uint32_t)0x00001000)
#define | SDIO_DORX_INT ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_INT ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_INT ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_INT ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_INT ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_INT ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_INT ((uint32_t)0x00080000)
#define | SDIO_TXBUF_INT ((uint32_t)0x00100000)
#define | SDIO_RXBUF_INT ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_INT ((uint32_t)0x00400000)

Detailed Description

sdio interrupt

Macro Definition Documentation

◆ SDIO_CMDCMPL_INT

#define SDIO_CMDCMPL_INT ((uint32_t)0x00000080)

command sent interrupt

Definition at line 57 of file at32f413_sdio.h.

◆ SDIO_CMDFAIL_INT

#define SDIO_CMDFAIL_INT ((uint32_t)0x00000001)

command response received check failed interrupt

Definition at line 50 of file at32f413_sdio.h.

◆ SDIO_CMDRSPCMPL_INT

#define SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)

command response received interrupt

Definition at line 56 of file at32f413_sdio.h.

◆ SDIO_CMDTIMEOUT_INT

#define SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)

command response timerout interrupt

Definition at line 52 of file at32f413_sdio.h.

◆ SDIO_DOCMD_INT

#define SDIO_DOCMD_INT ((uint32_t)0x00000800)

command transfer in progress interrupt

Definition at line 61 of file at32f413_sdio.h.

◆ SDIO_DORX_INT

#define SDIO_DORX_INT ((uint32_t)0x00002000)

data receive in progress interrupt

Definition at line 63 of file at32f413_sdio.h.

◆ SDIO_DOTX_INT

#define SDIO_DOTX_INT ((uint32_t)0x00001000)

data transmit in progress interrupt

Definition at line 62 of file at32f413_sdio.h.

◆ SDIO_DTBLKCMPL_INT

#define SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)

data block sent/received interrupt

Definition at line 60 of file at32f413_sdio.h.

◆ SDIO_DTCMP_INT

#define SDIO_DTCMP_INT ((uint32_t)0x00000100)

data sent interrupt

Definition at line 58 of file at32f413_sdio.h.

◆ SDIO_DTFAIL_INT

#define SDIO_DTFAIL_INT ((uint32_t)0x00000002)

data block sent/received check failed interrupt

Definition at line 51 of file at32f413_sdio.h.

◆ SDIO_DTTIMEOUT_INT

#define SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)

data timeout interrupt

Definition at line 53 of file at32f413_sdio.h.

◆ SDIO_RXBUF_INT

#define SDIO_RXBUF_INT ((uint32_t)0x00200000)

data available in receive interrupt

Definition at line 71 of file at32f413_sdio.h.

◆ SDIO_RXBUFE_INT

#define SDIO_RXBUFE_INT ((uint32_t)0x00080000)

receive buf empty interrupt

Definition at line 69 of file at32f413_sdio.h.

◆ SDIO_RXBUFF_INT

#define SDIO_RXBUFF_INT ((uint32_t)0x00020000)

receive buf full interrupt

Definition at line 67 of file at32f413_sdio.h.

◆ SDIO_RXBUFH_INT

#define SDIO_RXBUFH_INT ((uint32_t)0x00008000)

receive buf half full interrupt

Definition at line 65 of file at32f413_sdio.h.

◆ SDIO_RXERRO_INT

#define SDIO_RXERRO_INT ((uint32_t)0x00000020)

received overrun error interrupt

Definition at line 55 of file at32f413_sdio.h.

◆ SDIO_SBITERR_INT

#define SDIO_SBITERR_INT ((uint32_t)0x00000200)

start bit not detected on data bus interrupt

Definition at line 59 of file at32f413_sdio.h.

◆ SDIO_SDIOIF_INT

#define SDIO_SDIOIF_INT ((uint32_t)0x00400000)

sdio interface received interrupt

Definition at line 72 of file at32f413_sdio.h.

◆ SDIO_TXBUF_INT

#define SDIO_TXBUF_INT ((uint32_t)0x00100000)

data available in transmit interrupt

Definition at line 70 of file at32f413_sdio.h.

◆ SDIO_TXBUFE_INT

#define SDIO_TXBUFE_INT ((uint32_t)0x00040000)

transmit buf empty interrupt

Definition at line 68 of file at32f413_sdio.h.

◆ SDIO_TXBUFF_INT

#define SDIO_TXBUFF_INT ((uint32_t)0x00010000)

transmit buf full interrupt

Definition at line 66 of file at32f413_sdio.h.

◆ SDIO_TXBUFH_INT

#define SDIO_TXBUFH_INT ((uint32_t)0x00004000)

transmit buf half empty interrupt

Definition at line 64 of file at32f413_sdio.h.

◆ SDIO_TXERRU_INT

#define SDIO_TXERRU_INT ((uint32_t)0x00000010)

transmit underrun error interrupt

Definition at line 54 of file at32f413_sdio.h.


AT32F413 Firmwary Library: SDIO_flags_definition

Macros
SDIO_flags_definition
AT32F413_periph_driver » SDIO

sdio flag More...

Macros

#define | SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
#define | SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
#define | SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
#define | SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
#define | SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
#define | SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
#define | SDIO_DOTX_FLAG ((uint32_t)0x00001000)
#define | SDIO_DORX_FLAG ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
#define | SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
#define | SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)

Detailed Description

sdio flag

Macro Definition Documentation

◆ SDIO_CMDCMPL_FLAG

#define SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)

command sent flag

Definition at line 90 of file at32f413_sdio.h.

◆ SDIO_CMDFAIL_FLAG

#define SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)

command response received check failed flag

Definition at line 83 of file at32f413_sdio.h.

◆ SDIO_CMDRSPCMPL_FLAG

#define SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)

command response received flag

Definition at line 89 of file at32f413_sdio.h.

◆ SDIO_CMDTIMEOUT_FLAG

#define SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)

command response timerout flag

Definition at line 85 of file at32f413_sdio.h.

◆ SDIO_DOCMD_FLAG

#define SDIO_DOCMD_FLAG ((uint32_t)0x00000800)

command transfer in progress flag

Definition at line 94 of file at32f413_sdio.h.

◆ SDIO_DORX_FLAG

#define SDIO_DORX_FLAG ((uint32_t)0x00002000)

data receive in progress flag

Definition at line 96 of file at32f413_sdio.h.

◆ SDIO_DOTX_FLAG

#define SDIO_DOTX_FLAG ((uint32_t)0x00001000)

data transmit in progress flag

Definition at line 95 of file at32f413_sdio.h.

◆ SDIO_DTBLKCMPL_FLAG

#define SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)

data block sent/received flag

Definition at line 93 of file at32f413_sdio.h.

◆ SDIO_DTCMPL_FLAG

#define SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)

data sent flag

Definition at line 91 of file at32f413_sdio.h.

◆ SDIO_DTFAIL_FLAG

#define SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)

data block sent/received check failed flag

Definition at line 84 of file at32f413_sdio.h.

◆ SDIO_DTTIMEOUT_FLAG

#define SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)

data timeout flag

Definition at line 86 of file at32f413_sdio.h.

◆ SDIO_RXBUF_FLAG

#define SDIO_RXBUF_FLAG ((uint32_t)0x00200000)

data available in receive flag

Definition at line 104 of file at32f413_sdio.h.

◆ SDIO_RXBUFE_FLAG

#define SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)

receive buf empty flag

Definition at line 102 of file at32f413_sdio.h.

◆ SDIO_RXBUFF_FLAG

#define SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)

receive buf full flag

Definition at line 100 of file at32f413_sdio.h.

◆ SDIO_RXBUFH_FLAG

#define SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)

receive buf half full flag

Definition at line 98 of file at32f413_sdio.h.

◆ SDIO_RXERRO_FLAG

#define SDIO_RXERRO_FLAG ((uint32_t)0x00000020)

received overrun error flag

Definition at line 88 of file at32f413_sdio.h.

◆ SDIO_SBITERR_FLAG

#define SDIO_SBITERR_FLAG ((uint32_t)0x00000200)

start bit not detected on data bus flag

Definition at line 92 of file at32f413_sdio.h.

◆ SDIO_SDIOIF_FLAG

#define SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)

sdio interface received flag

Definition at line 105 of file at32f413_sdio.h.

◆ SDIO_TXBUF_FLAG

#define SDIO_TXBUF_FLAG ((uint32_t)0x00100000)

data available in transmit flag

Definition at line 103 of file at32f413_sdio.h.

◆ SDIO_TXBUFE_FLAG

#define SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)

transmit buf empty flag

Definition at line 101 of file at32f413_sdio.h.

◆ SDIO_TXBUFF_FLAG

#define SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)

transmit buf full flag

Definition at line 99 of file at32f413_sdio.h.

◆ SDIO_TXBUFH_FLAG

#define SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)

transmit buf half empty flag

Definition at line 97 of file at32f413_sdio.h.

◆ SDIO_TXERRU_FLAG

#define SDIO_TXERRU_FLAG ((uint32_t)0x00000010)

transmit underrun error flag

Definition at line 87 of file at32f413_sdio.h.


AT32F413 Firmwary Library: SDIO_exported_types

Data Structures | Enumerations
SDIO_exported_types
AT32F413_periph_driver » SDIO

Data Structures

struct | sdio_command_struct_type
sdio command structure More...
struct | sdio_data_struct_type
sdio data structure More...
struct | sdio_type
type define sdio register all More...

Enumerations

enum | sdio_power_state_type { SDIO_POWER_OFF = 0x00 , SDIO_POWER_ON = 0x03 }
sdio power state More...
enum | sdio_edge_phase_type { SDIO_CLOCK_EDGE_RISING = 0x00 , SDIO_CLOCK_EDGE_FALLING = 0x01 }
sdio edge phase More...
enum | sdio_bus_width_type { SDIO_BUS_WIDTH_D1 = 0x00 , SDIO_BUS_WIDTH_D4 = 0x01 , SDIO_BUS_WIDTH_D8 = 0x02 }
sdio bus width More...
enum | sdio_reponse_type { SDIO_RESPONSE_NO = 0x00 , SDIO_RESPONSE_SHORT = 0x01 , SDIO_RESPONSE_LONG = 0x03 }
sdio response type More...
enum | sdio_wait_type { SDIO_WAIT_FOR_NO = 0x00 , SDIO_WAIT_FOR_INT = 0x01 , SDIO_WAIT_FOR_PEND = 0x02 }
sdio wait type More...
enum | sdio_rsp_index_type { SDIO_RSP1_INDEX = 0x00 , SDIO_RSP2_INDEX = 0x01 , SDIO_RSP3_INDEX = 0x02 , SDIO_RSP4_INDEX = 0x03 }
sdio response register index More...
enum sdio_block_size_type {
SDIO_DATA_BLOCK_SIZE_1B = 0x00 , SDIO_DATA_BLOCK_SIZE_2B = 0x01 , SDIO_DATA_BLOCK_SIZE_4B = 0x02 , SDIO_DATA_BLOCK_SIZE_8B = 0x03 ,
SDIO_DATA_BLOCK_SIZE_16B = 0x04 , SDIO_DATA_BLOCK_SIZE_32B = 0x05 , SDIO_DATA_BLOCK_SIZE_64B = 0x06 , SDIO_DATA_BLOCK_SIZE_128B = 0x07 ,
SDIO_DATA_BLOCK_SIZE_256B = 0x08 , SDIO_DATA_BLOCK_SIZE_512B = 0x09 , SDIO_DATA_BLOCK_SIZE_1024B = 0x0A , SDIO_DATA_BLOCK_SIZE_2048B = 0x0B ,
SDIO_DATA_BLOCK_SIZE_4096B = 0x0C , SDIO_DATA_BLOCK_SIZE_8192B = 0x0D , SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
}
sdio data block size More...
enum | sdio_transfer_mode_type { SDIO_DATA_BLOCK_TRANSFER = 0x00 , SDIO_DATA_STREAM_TRANSFER = 0x01 }
sdio data transfer mode More...
enum | sdio_transfer_direction_type { SDIO_DATA_TRANSFER_TO_CARD = 0x00 , SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01 }
sdio data transfer direction More...
enum | sdio_read_wait_mode_type { SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00 , SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01 }
sdio read wait mode More...

Detailed Description

Enumeration Type Documentation

◆ sdio_block_size_type

enum sdio_block_size_type

sdio data block size

Enumerator
SDIO_DATA_BLOCK_SIZE_1B | data block size 1 byte
SDIO_DATA_BLOCK_SIZE_2B | data block size 2 bytes
SDIO_DATA_BLOCK_SIZE_4B | data block size 4 bytes
SDIO_DATA_BLOCK_SIZE_8B | data block size 8 bytes
SDIO_DATA_BLOCK_SIZE_16B | data block size 16 bytes
SDIO_DATA_BLOCK_SIZE_32B | data block size 32 bytes
SDIO_DATA_BLOCK_SIZE_64B | data block size 64 bytes
SDIO_DATA_BLOCK_SIZE_128B | data block size 128 bytes
SDIO_DATA_BLOCK_SIZE_256B | data block size 256 bytes
SDIO_DATA_BLOCK_SIZE_512B | data block size 512 bytes
SDIO_DATA_BLOCK_SIZE_1024B | data block size 1024 bytes
SDIO_DATA_BLOCK_SIZE_2048B | data block size 2048 bytes
SDIO_DATA_BLOCK_SIZE_4096B | data block size 4096 bytes
SDIO_DATA_BLOCK_SIZE_8192B | data block size 8192 bytes
SDIO_DATA_BLOCK_SIZE_16384B | data block size 16384 bytes

Definition at line 177 of file at32f413_sdio.h.

◆ sdio_bus_width_type

enum sdio_bus_width_type

sdio bus width

Enumerator
SDIO_BUS_WIDTH_D1 | sdio wide bus select 1-bit
SDIO_BUS_WIDTH_D4 | sdio wide bus select 4-bit
SDIO_BUS_WIDTH_D8 | sdio wide bus select 8-bit

Definition at line 136 of file at32f413_sdio.h.

◆ sdio_edge_phase_type

enum sdio_edge_phase_type

sdio edge phase

Enumerator
SDIO_CLOCK_EDGE_RISING | sdio bus clock generated on the rising edge of the master clock
SDIO_CLOCK_EDGE_FALLING | sdio bus clock generated on the falling edge of the master clock

Definition at line 127 of file at32f413_sdio.h.

◆ sdio_power_state_type

enum sdio_power_state_type

sdio power state

Enumerator
SDIO_POWER_OFF | power-off, clock to card is stopped
SDIO_POWER_ON | power-on, the card is clocked

Definition at line 118 of file at32f413_sdio.h.

◆ sdio_read_wait_mode_type

enum sdio_read_wait_mode_type

sdio read wait mode

Enumerator
SDIO_READ_WAIT_CONTROLLED_BY_D2 | the sdio read wait on data2 line
SDIO_READ_WAIT_CONTROLLED_BY_CK | the sdio read wait on clock line

Definition at line 217 of file at32f413_sdio.h.

◆ sdio_reponse_type

enum sdio_reponse_type

sdio response type

Enumerator
SDIO_RESPONSE_NO | no response
SDIO_RESPONSE_SHORT | short response
SDIO_RESPONSE_LONG | long response

Definition at line 146 of file at32f413_sdio.h.

◆ sdio_rsp_index_type

enum sdio_rsp_index_type

sdio response register index

Enumerator
SDIO_RSP1_INDEX | response index 1, corresponding to sdio_rsp register 1
SDIO_RSP2_INDEX | response index 2, corresponding to sdio_rsp register 2
SDIO_RSP3_INDEX | response index 3, corresponding to sdio_rsp register 3
SDIO_RSP4_INDEX | response index 4, corresponding to sdio_rsp register 4

Definition at line 166 of file at32f413_sdio.h.

◆ sdio_transfer_direction_type

enum sdio_transfer_direction_type

sdio data transfer direction

Enumerator
SDIO_DATA_TRANSFER_TO_CARD | the sdio controller write
SDIO_DATA_TRANSFER_TO_CONTROLLER | the sdio controller read

Definition at line 208 of file at32f413_sdio.h.

◆ sdio_transfer_mode_type

enum sdio_transfer_mode_type

sdio data transfer mode

Enumerator
SDIO_DATA_BLOCK_TRANSFER | the sdio block transfer mode
SDIO_DATA_STREAM_TRANSFER | the sdio stream transfer mode

Definition at line 199 of file at32f413_sdio.h.

◆ sdio_wait_type

enum sdio_wait_type

sdio wait type

Enumerator
SDIO_WAIT_FOR_NO | no wait
SDIO_WAIT_FOR_INT | wait interrupt request
SDIO_WAIT_FOR_PEND | wait end of transfer

Definition at line 156 of file at32f413_sdio.h.


AT32F413 Firmwary Library: sdio_command_struct_type Struct Reference

Data Fields
sdio_command_struct_type Struct Reference
AT32F413_periph_driver » SDIO » SDIO_exported_types

sdio command structure More...

#include <at32f413_sdio.h>

Data Fields

uint32_t | argument
uint8_t | cmd_index
sdio_reponse_type rsp_type
sdio_wait_type wait_type

Detailed Description

sdio command structure

Definition at line 226 of file at32f413_sdio.h.

Field Documentation

◆ argument

uint32_t sdio_command_struct_type::argument

the sdio command argument is sent to a card as part of command message

Definition at line 228 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ cmd_index

uint8_t sdio_command_struct_type::cmd_index

the sdio command index

Definition at line 229 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ rsp_type

sdio_reponse_type sdio_command_struct_type::rsp_type

the sdio response type

Definition at line 230 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ wait_type

sdio_wait_type sdio_command_struct_type::wait_type

the sdio wait for interrupt request is enabled or disable

Definition at line 231 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

The documentation for this struct was generated from the following file:
  • at32f413_sdio.h


AT32F413 Firmwary Library: sdio_data_struct_type Struct Reference

Data Fields
sdio_data_struct_type Struct Reference
AT32F413_periph_driver » SDIO » SDIO_exported_types

sdio data structure More...

#include <at32f413_sdio.h>

Data Fields

uint32_t | timeout
uint32_t | data_length
sdio_block_size_type block_size
sdio_transfer_mode_type transfer_mode
sdio_transfer_direction_type transfer_direction

Detailed Description

sdio data structure

Definition at line 237 of file at32f413_sdio.h.

Field Documentation

◆ block_size

sdio_block_size_type sdio_data_struct_type::block_size

the sdio data block size of block transfer mode

Definition at line 241 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

◆ data_length

uint32_t sdio_data_struct_type::data_length

the sdio data length

Definition at line 240 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), sdio_command_data_send(), and sdio_data_config().

◆ timeout

uint32_t sdio_data_struct_type::timeout

the sdio data timeout period in car bus clock periods

Definition at line 239 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

◆ transfer_direction

sdio_transfer_direction_type sdio_data_struct_type::transfer_direction

the sdio data transfer direction

Definition at line 243 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), sdio_command_data_send(), and sdio_data_config().

◆ transfer_mode

sdio_transfer_mode_type sdio_data_struct_type::transfer_mode

the sdio transfer mode, block or stream

Definition at line 242 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

The documentation for this struct was generated from the following file:
  • at32f413_sdio.h


AT32F413 Firmwary Library: sdio_type Struct Reference

Data Fields
sdio_type Struct Reference
AT32F413_periph_driver » SDIO » SDIO_exported_types

type define sdio register all More...

#include <at32f413_sdio.h>

Data Fields

union {
__IO uint32_t pwrctrl
struct {
__IO uint32_t ps: 2
__IO uint32_t reserved1: 30
} pwrctrl_bit
};
sdio pwrctrl register, offset:0x00 More...
union {
__IO uint32_t clkctrl
struct {
__IO uint32_t clkdiv_l: 8
__IO uint32_t clkoen: 1
__IO uint32_t pwrsven: 1
__IO uint32_t bypsen: 1
__IO uint32_t busws: 2
__IO uint32_t clkegs: 1
__IO uint32_t hfcen: 1
__IO uint32_t clkdiv_h: 2
__IO uint32_t reserved1: 15
} clkctrl_bit
};
sdio clkctrl register, offset:0x04 More...
union {
__IO uint32_t argu
struct {
__IO uint32_t argu: 32
} argu_bit
};
sdio argu register, offset:0x08 More...
union {
__IO uint32_t cmdctrl
struct {
__IO uint32_t cmdidx: 6
__IO uint32_t rspwt: 2
__IO uint32_t intwt: 1
__IO uint32_t pndwt: 1
__IO uint32_t ccsmen: 1
__IO uint32_t iosusp: 1
__IO uint32_t reserved1: 20
} cmdctrl_bit
};
sdio cmdctrl register, offset:0x0C More...
union {
__IO uint32_t rspcmd
struct {
__IO uint32_t rspcmd: 6
__IO uint32_t reserved1: 26
} rspcmd_bit
};
sdio rspcmd register, offset:0x10 More...
union {
__IO uint32_t rsp1
struct {
__IO uint32_t cardsts1: 32
} rsp1_bit
};
sdio rsp1 register, offset:0x14 More...
union {
__IO uint32_t rsp2
struct {
__IO uint32_t cardsts2: 32
} rsp2_bit
};
sdio rsp2 register, offset:0x18 More...
union {
__IO uint32_t rsp3
struct {
__IO uint32_t cardsts3: 32
} rsp3_bit
};
sdio rsp3 register, offset:0x1C More...
union {
__IO uint32_t rsp4
struct {
__IO uint32_t cardsts4: 32
} rsp4_bit
};
sdio rsp4 register, offset:0x20 More...
union {
__IO uint32_t dttmr
struct {
__IO uint32_t timeout: 32
} dttmr_bit
};
sdio dttmr register, offset:0x24 More...
union {
__IO uint32_t dtlen
struct {
__IO uint32_t dtlen: 25
__IO uint32_t reserved1: 7
} dtlen_bit
};
sdio dtlen register, offset:0x28 More...
union {
__IO uint32_t dtctrl
struct {
__IO uint32_t tfren: 1
__IO uint32_t tfrdir: 1
__IO uint32_t tfrmode: 1
__IO uint32_t dmaen: 1
__IO uint32_t blksize: 4
__IO uint32_t rdwtstart: 1
__IO uint32_t rdwtstop: 1
__IO uint32_t rdwtmode: 1
__IO uint32_t ioen: 1
__IO uint32_t reserved1: 20
} dtctrl_bit
};
sdio dtctrl register, offset:0x2C More...
union {
__IO uint32_t dtcnt
struct {
__IO uint32_t cnt: 25
__IO uint32_t reserved1: 7
} dtcnt_bit
};
sdio dtcnt register, offset:0x30 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t cmdfail: 1
__IO uint32_t dtfail: 1
__IO uint32_t cmdtimeout: 1
__IO uint32_t dttimeout: 1
__IO uint32_t txerru: 1
__IO uint32_t rxerro: 1
__IO uint32_t cmdrspcmpl: 1
__IO uint32_t cmdcmpl: 1
__IO uint32_t dtcmpl: 1
__IO uint32_t sbiterr: 1
__IO uint32_t dtblkcmpl: 1
__IO uint32_t docmd: 1
__IO uint32_t dotx: 1
__IO uint32_t dorx: 1
__IO uint32_t txbufh: 1
__IO uint32_t rxbufh: 1
__IO uint32_t txbuff: 1
__IO uint32_t rxbuff: 1
__IO uint32_t txbufe: 1
__IO uint32_t rxbufe: 1
__IO uint32_t txbuf: 1
__IO uint32_t rxbuf: 1
__IO uint32_t ioif: 1
__IO uint32_t reserved1: 9
} sts_bit
};
sdio sts register, offset:0x34 More...
union {
__IO uint32_t intclr
struct {
__IO uint32_t cmdfail: 1
__IO uint32_t dtfail: 1
__IO uint32_t cmdtimeout: 1
__IO uint32_t dttimeout: 1
__IO uint32_t txerru: 1
__IO uint32_t rxerro: 1
__IO uint32_t cmdrspcmpl: 1
__IO uint32_t cmdcmpl: 1
__IO uint32_t dtcmpl: 1
__IO uint32_t sbiterr: 1
__IO uint32_t dtblkcmpl: 1
__IO uint32_t reserved1: 11
__IO uint32_t ioif: 1
__IO uint32_t reserved2: 9
} intclr_bit
};
sdio intclr register, offset:0x38 More...
union {
__IO uint32_t inten
struct {
__IO uint32_t cmdfailien: 1
__IO uint32_t dtfailien: 1
__IO uint32_t cmdtimeoutien: 1
__IO uint32_t dttimeoutien: 1
__IO uint32_t txerruien: 1
__IO uint32_t rxerroien: 1
__IO uint32_t cmdrspcmplien: 1
__IO uint32_t cmdcmplien: 1
__IO uint32_t dtcmplien: 1
__IO uint32_t sbiterrien: 1
__IO uint32_t dtblkcmplien: 1
__IO uint32_t docmdien: 1
__IO uint32_t dotxien: 1
__IO uint32_t dorxien: 1
__IO uint32_t txbufhien: 1
__IO uint32_t rxbufhien: 1
__IO uint32_t txbuffien: 1
__IO uint32_t rxbuffien: 1
__IO uint32_t txbufeien: 1
__IO uint32_t rxbufeien: 1
__IO uint32_t txbufien: 1
__IO uint32_t rxbufien: 1
__IO uint32_t ioifien: 1
__IO uint32_t reserved1: 9
} inten_bit
};
sdio inten register, offset:0x3C More...
union {
__IO uint32_t bufcnt
struct {
__IO uint32_t cnt: 24
__IO uint32_t reserved1: 8
} bufcnt_bit
};
sdio bufcnt register, offset:0x48 More...
union {
__IO uint32_t buf
struct {
__IO uint32_t dt: 32
} buf_bit
};
sdio buf register, offset:0x80 More...

Detailed Description

type define sdio register all

Definition at line 249 of file at32f413_sdio.h.

Field Documentation

◆

union { ... } sdio_type::@571

sdio pwrctrl register, offset:0x00

◆

union { ... } sdio_type::@573

sdio clkctrl register, offset:0x04

◆

union { ... } sdio_type::@575

sdio argu register, offset:0x08

◆

union { ... } sdio_type::@577

sdio cmdctrl register, offset:0x0C

◆

union { ... } sdio_type::@579

sdio rspcmd register, offset:0x10

◆

union { ... } sdio_type::@581

sdio rsp1 register, offset:0x14

◆

union { ... } sdio_type::@583

sdio rsp2 register, offset:0x18

◆

union { ... } sdio_type::@585

sdio rsp3 register, offset:0x1C

◆

union { ... } sdio_type::@587

sdio rsp4 register, offset:0x20

◆

union { ... } sdio_type::@589

sdio dttmr register, offset:0x24

◆

union { ... } sdio_type::@591

sdio dtlen register, offset:0x28

◆

union { ... } sdio_type::@593

sdio dtctrl register, offset:0x2C

◆

union { ... } sdio_type::@595

sdio dtcnt register, offset:0x30

◆

union { ... } sdio_type::@597

sdio sts register, offset:0x34

◆

union { ... } sdio_type::@599

sdio intclr register, offset:0x38

◆

union { ... } sdio_type::@601

sdio inten register, offset:0x3C

◆

union { ... } sdio_type::@603

sdio bufcnt register, offset:0x48

◆

union { ... } sdio_type::@605

sdio buf register, offset:0x80

◆ argu

__IO uint32_t sdio_type::argu

Definition at line 289 of file at32f413_sdio.h.

Referenced by sdio_command_config(), and sdio_reset().

◆

struct { ... } sdio_type::argu_bit

◆ blksize

__IO uint32_t sdio_type::blksize

Definition at line 412 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ buf

__IO uint32_t sdio_type::buf

Definition at line 557 of file at32f413_sdio.h.

Referenced by sdio_data_read(), and sdio_data_write().

◆

struct { ... } sdio_type::buf_bit

◆ bufcnt

__IO uint32_t sdio_type::bufcnt

Definition at line 539 of file at32f413_sdio.h.

Referenced by sdio_buffer_counter_get().

◆

struct { ... } sdio_type::bufcnt_bit

◆ busws

__IO uint32_t sdio_type::busws

Definition at line 276 of file at32f413_sdio.h.

Referenced by sdio_bus_width_config().

◆ bypsen

__IO uint32_t sdio_type::bypsen

Definition at line 275 of file at32f413_sdio.h.

Referenced by sdio_clock_bypass().

◆ cardsts1

__IO uint32_t sdio_type::cardsts1

Definition at line 335 of file at32f413_sdio.h.

◆ cardsts2

__IO uint32_t sdio_type::cardsts2

Definition at line 347 of file at32f413_sdio.h.

◆ cardsts3

__IO uint32_t sdio_type::cardsts3

Definition at line 359 of file at32f413_sdio.h.

◆ cardsts4

__IO uint32_t sdio_type::cardsts4

Definition at line 371 of file at32f413_sdio.h.

◆ ccsmen

__IO uint32_t sdio_type::ccsmen

Definition at line 308 of file at32f413_sdio.h.

Referenced by sdio_command_config(), and sdio_command_state_machine_enable().

◆ clkctrl

__IO uint32_t sdio_type::clkctrl

Definition at line 269 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::clkctrl_bit

Referenced by sdio_bus_width_config(), sdio_clock_bypass(), sdio_clock_config(), sdio_clock_enable(), sdio_flow_control_enable(), and sdio_power_saving_mode_enable().

◆ clkdiv_h

__IO uint32_t sdio_type::clkdiv_h

Definition at line 279 of file at32f413_sdio.h.

Referenced by sdio_clock_config().

◆ clkdiv_l

__IO uint32_t sdio_type::clkdiv_l

Definition at line 272 of file at32f413_sdio.h.

Referenced by sdio_clock_config().

◆ clkegs

__IO uint32_t sdio_type::clkegs

Definition at line 277 of file at32f413_sdio.h.

Referenced by sdio_clock_config().

◆ clkoen

__IO uint32_t sdio_type::clkoen

Definition at line 273 of file at32f413_sdio.h.

Referenced by sdio_clock_enable().

◆ cmdcmpl

__IO uint32_t sdio_type::cmdcmpl

Definition at line 449 of file at32f413_sdio.h.

◆ cmdcmplien

__IO uint32_t sdio_type::cmdcmplien

Definition at line 509 of file at32f413_sdio.h.

◆ cmdctrl

__IO uint32_t sdio_type::cmdctrl

Definition at line 301 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::cmdctrl_bit

Referenced by sdio_command_config(), sdio_command_state_machine_enable(), and sdio_io_suspend_command_set().

◆ cmdfail

__IO uint32_t sdio_type::cmdfail

Definition at line 442 of file at32f413_sdio.h.

◆ cmdfailien

__IO uint32_t sdio_type::cmdfailien

Definition at line 502 of file at32f413_sdio.h.

◆ cmdidx

__IO uint32_t sdio_type::cmdidx

Definition at line 304 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ cmdrspcmpl

__IO uint32_t sdio_type::cmdrspcmpl

Definition at line 448 of file at32f413_sdio.h.

◆ cmdrspcmplien

__IO uint32_t sdio_type::cmdrspcmplien

Definition at line 508 of file at32f413_sdio.h.

◆ cmdtimeout

__IO uint32_t sdio_type::cmdtimeout

Definition at line 444 of file at32f413_sdio.h.

◆ cmdtimeoutien

__IO uint32_t sdio_type::cmdtimeoutien

Definition at line 504 of file at32f413_sdio.h.

◆ cnt

__IO uint32_t sdio_type::cnt

Definition at line 429 of file at32f413_sdio.h.

◆ dmaen

__IO uint32_t sdio_type::dmaen

Definition at line 411 of file at32f413_sdio.h.

Referenced by sdio_dma_enable().

◆ docmd

__IO uint32_t sdio_type::docmd

Definition at line 453 of file at32f413_sdio.h.

◆ docmdien

__IO uint32_t sdio_type::docmdien

Definition at line 513 of file at32f413_sdio.h.

◆ dorx

__IO uint32_t sdio_type::dorx

Definition at line 455 of file at32f413_sdio.h.

◆ dorxien

__IO uint32_t sdio_type::dorxien

Definition at line 515 of file at32f413_sdio.h.

◆ dotx

__IO uint32_t sdio_type::dotx

Definition at line 454 of file at32f413_sdio.h.

◆ dotxien

__IO uint32_t sdio_type::dotxien

Definition at line 514 of file at32f413_sdio.h.

◆ dt

__IO uint32_t sdio_type::dt

Definition at line 560 of file at32f413_sdio.h.

◆ dtblkcmpl

__IO uint32_t sdio_type::dtblkcmpl

Definition at line 452 of file at32f413_sdio.h.

◆ dtblkcmplien

__IO uint32_t sdio_type::dtblkcmplien

Definition at line 512 of file at32f413_sdio.h.

◆ dtcmpl

__IO uint32_t sdio_type::dtcmpl

Definition at line 450 of file at32f413_sdio.h.

◆ dtcmplien

__IO uint32_t sdio_type::dtcmplien

Definition at line 510 of file at32f413_sdio.h.

◆ dtcnt

__IO uint32_t sdio_type::dtcnt

Definition at line 426 of file at32f413_sdio.h.

Referenced by sdio_data_counter_get().

◆

struct { ... } sdio_type::dtcnt_bit

◆ dtctrl

__IO uint32_t sdio_type::dtctrl

Definition at line 405 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::dtctrl_bit

Referenced by sdio_data_config(), sdio_data_state_machine_enable(), sdio_dma_enable(), sdio_io_function_enable(), sdio_read_wait_mode_set(), sdio_read_wait_start(), and sdio_read_wait_stop().

◆ dtfail

__IO uint32_t sdio_type::dtfail

Definition at line 443 of file at32f413_sdio.h.

◆ dtfailien

__IO uint32_t sdio_type::dtfailien

Definition at line 503 of file at32f413_sdio.h.

◆ dtlen

__IO uint32_t sdio_type::dtlen

Definition at line 392 of file at32f413_sdio.h.

Referenced by sdio_data_config(), and sdio_reset().

◆

struct { ... } sdio_type::dtlen_bit

Referenced by sdio_data_config().

◆ dttimeout

__IO uint32_t sdio_type::dttimeout

Definition at line 445 of file at32f413_sdio.h.

◆ dttimeoutien

__IO uint32_t sdio_type::dttimeoutien

Definition at line 505 of file at32f413_sdio.h.

◆ dttmr

__IO uint32_t sdio_type::dttmr

Definition at line 380 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::dttmr_bit

Referenced by sdio_data_config().

◆ hfcen

__IO uint32_t sdio_type::hfcen

Definition at line 278 of file at32f413_sdio.h.

Referenced by sdio_flow_control_enable().

◆ intclr

__IO uint32_t sdio_type::intclr

Definition at line 474 of file at32f413_sdio.h.

Referenced by sdio_flag_clear(), and sdio_reset().

◆

struct { ... } sdio_type::intclr_bit

◆ inten

__IO uint32_t sdio_type::inten

Definition at line 499 of file at32f413_sdio.h.

Referenced by sdio_interrupt_enable(), and sdio_reset().

◆

struct { ... } sdio_type::inten_bit

◆ intwt

__IO uint32_t sdio_type::intwt

Definition at line 306 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ ioen

__IO uint32_t sdio_type::ioen

Definition at line 416 of file at32f413_sdio.h.

Referenced by sdio_io_function_enable().

◆ ioif

__IO uint32_t sdio_type::ioif

Definition at line 464 of file at32f413_sdio.h.

◆ ioifien

__IO uint32_t sdio_type::ioifien

Definition at line 524 of file at32f413_sdio.h.

◆ iosusp

__IO uint32_t sdio_type::iosusp

Definition at line 309 of file at32f413_sdio.h.

Referenced by sdio_io_suspend_command_set().

◆ pndwt

__IO uint32_t sdio_type::pndwt

Definition at line 307 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ ps

__IO uint32_t sdio_type::ps

Definition at line 259 of file at32f413_sdio.h.

Referenced by sdio_power_set(), and sdio_power_status_get().

◆ pwrctrl

__IO uint32_t sdio_type::pwrctrl

Definition at line 256 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::pwrctrl_bit

Referenced by sdio_power_set(), and sdio_power_status_get().

◆ pwrsven

__IO uint32_t sdio_type::pwrsven

Definition at line 274 of file at32f413_sdio.h.

Referenced by sdio_power_saving_mode_enable().

◆ rdwtmode

__IO uint32_t sdio_type::rdwtmode

Definition at line 415 of file at32f413_sdio.h.

Referenced by sdio_read_wait_mode_set().

◆ rdwtstart

__IO uint32_t sdio_type::rdwtstart

Definition at line 413 of file at32f413_sdio.h.

Referenced by sdio_read_wait_start().

◆ rdwtstop

__IO uint32_t sdio_type::rdwtstop

Definition at line 414 of file at32f413_sdio.h.

Referenced by sdio_read_wait_stop().

◆ reserved1

__IO uint32_t sdio_type::reserved1

sdio reserved1 register, offset:0x40~0x44

Definition at line 260 of file at32f413_sdio.h.

◆ reserved2

__IO uint32_t sdio_type::reserved2

sdio reserved2 register, offset:0x4C~0x7C

Definition at line 490 of file at32f413_sdio.h.

◆ rsp1

__IO uint32_t sdio_type::rsp1

Definition at line 332 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp1_bit

◆ rsp2

__IO uint32_t sdio_type::rsp2

Definition at line 344 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp2_bit

◆ rsp3

__IO uint32_t sdio_type::rsp3

Definition at line 356 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp3_bit

◆ rsp4

__IO uint32_t sdio_type::rsp4

Definition at line 368 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp4_bit

◆ rspcmd

__IO uint32_t sdio_type::rspcmd

Definition at line 319 of file at32f413_sdio.h.

Referenced by sdio_command_response_get().

◆

struct { ... } sdio_type::rspcmd_bit

Referenced by sdio_command_response_get().

◆ rspwt

__IO uint32_t sdio_type::rspwt

Definition at line 305 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ rxbuf

__IO uint32_t sdio_type::rxbuf

Definition at line 463 of file at32f413_sdio.h.

◆ rxbufe

__IO uint32_t sdio_type::rxbufe

Definition at line 461 of file at32f413_sdio.h.

◆ rxbufeien

__IO uint32_t sdio_type::rxbufeien

Definition at line 521 of file at32f413_sdio.h.

◆ rxbuff

__IO uint32_t sdio_type::rxbuff

Definition at line 459 of file at32f413_sdio.h.

◆ rxbuffien

__IO uint32_t sdio_type::rxbuffien

Definition at line 519 of file at32f413_sdio.h.

◆ rxbufh

__IO uint32_t sdio_type::rxbufh

Definition at line 457 of file at32f413_sdio.h.

◆ rxbufhien

__IO uint32_t sdio_type::rxbufhien

Definition at line 517 of file at32f413_sdio.h.

◆ rxbufien

__IO uint32_t sdio_type::rxbufien

Definition at line 523 of file at32f413_sdio.h.

◆ rxerro

__IO uint32_t sdio_type::rxerro

Definition at line 447 of file at32f413_sdio.h.

◆ rxerroien

__IO uint32_t sdio_type::rxerroien

Definition at line 507 of file at32f413_sdio.h.

◆ sbiterr

__IO uint32_t sdio_type::sbiterr

Definition at line 451 of file at32f413_sdio.h.

◆ sbiterrien

__IO uint32_t sdio_type::sbiterrien

Definition at line 511 of file at32f413_sdio.h.

◆ sts

__IO uint32_t sdio_type::sts

Definition at line 439 of file at32f413_sdio.h.

Referenced by sdio_flag_get().

◆

struct { ... } sdio_type::sts_bit

◆ tfrdir

__IO uint32_t sdio_type::tfrdir

Definition at line 409 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ tfren

__IO uint32_t sdio_type::tfren

Definition at line 408 of file at32f413_sdio.h.

Referenced by sdio_data_config(), and sdio_data_state_machine_enable().

◆ tfrmode

__IO uint32_t sdio_type::tfrmode

Definition at line 410 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ timeout

__IO uint32_t sdio_type::timeout

Definition at line 383 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ txbuf

__IO uint32_t sdio_type::txbuf

Definition at line 462 of file at32f413_sdio.h.

◆ txbufe

__IO uint32_t sdio_type::txbufe

Definition at line 460 of file at32f413_sdio.h.

◆ txbufeien

__IO uint32_t sdio_type::txbufeien

Definition at line 520 of file at32f413_sdio.h.

◆ txbuff

__IO uint32_t sdio_type::txbuff

Definition at line 458 of file at32f413_sdio.h.

◆ txbuffien

__IO uint32_t sdio_type::txbuffien

Definition at line 518 of file at32f413_sdio.h.

◆ txbufh

__IO uint32_t sdio_type::txbufh

Definition at line 456 of file at32f413_sdio.h.

◆ txbufhien

__IO uint32_t sdio_type::txbufhien

Definition at line 516 of file at32f413_sdio.h.

◆ txbufien

__IO uint32_t sdio_type::txbufien

Definition at line 522 of file at32f413_sdio.h.

◆ txerru

__IO uint32_t sdio_type::txerru

Definition at line 446 of file at32f413_sdio.h.

◆ txerruien

__IO uint32_t sdio_type::txerruien

Definition at line 506 of file at32f413_sdio.h.

The documentation for this struct was generated from the following file:
  • at32f413_sdio.h


AT32F413 Firmwary Library: SDIO_exported_functions

Functions
SDIO_exported_functions
AT32F413_periph_driver » SDIO

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

Function Documentation

◆ sdio_buffer_counter_get()

uint32_t sdio_buffer_counter_get ( sdio_type * sdio_x )

get the number of words left to be written to or read from fifo..

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of words

Definition at line 475 of file at32f413_sdio.c.

◆ sdio_bus_width_config()

void sdio_bus_width_config | ( | sdio_type * | sdio_x,
 |  | sdio_bus_width_type | width
 | ) |  |

config sdio bus width

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
width this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D1
  • SDIO_BUS_WIDTH_D4
  • SDIO_BUS_WIDTH_D8
Return values
none

Definition at line 126 of file at32f413_sdio.c.

Referenced by sd_power_on(), and sd_wide_bus_operation_config().

◆ sdio_clock_bypass()

void sdio_clock_bypass | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock divider bypss

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 139 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_config()

void sdio_clock_config | ( | sdio_type * | sdio_x,
 |  | uint16_t | clk_div,
 |  | sdio_edge_phase_type | clk_edg
 | ) |  |

config sdio clock

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
clk_div | sdio clock divide factor(frequency = sdio_clk / [clk_psc + 2]).
clk_edg this parameter can be one of the following values:
  • SDIO_CLOCK_EDGE_RISING
  • SDIO_CLOCK_EDGE_FALLING
Return values
none

Definition at line 102 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_enable()

void sdio_clock_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sdio_ck output.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 179 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_command_config()

void sdio_command_config | ( | sdio_type * | sdio_x,
 |  | sdio_command_struct_type * | command_struct
 | ) |  |

config sdio command.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
command_struct | : pointer to a sdio_command_struct_type structure that contains the configuration information for the sdio command.
Return values
none

Definition at line 327 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_command_response_get()

uint8_t sdio_command_response_get ( sdio_type * sdio_x )

get command index of last command for which response received.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
uint8_t command index

Definition at line 363 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp4_error(), command_rsp5_error(), and command_rsp6_error().

◆ sdio_command_state_machine_enable()

void sdio_command_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable command path state machine(CPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 350 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_data_config()

void sdio_data_config | ( | sdio_type * | sdio_x,
 |  | sdio_data_struct_type * | data_struct
 | ) |  |

config sdio data.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data_struct | : pointer to a sdio_data_struct_type structure that contains the configuration information for the sdio data.
Return values
none

Definition at line 414 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_counter_get()

uint32_t sdio_data_counter_get ( sdio_type * sdio_x )

get the number of remaining data bytes to be transferred.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of bytes

Definition at line 451 of file at32f413_sdio.c.

◆ sdio_data_read()

uint32_t sdio_data_read ( sdio_type * sdio_x )

read a word data from sdio fifo.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t data received

Definition at line 463 of file at32f413_sdio.c.

Referenced by scr_find(), and sdio_command_data_send().

◆ sdio_data_state_machine_enable()

void sdio_data_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable data path state machine(DPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 439 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_write()

void sdio_data_write | ( | sdio_type * | sdio_x,
 |  | uint32_t | data
 | ) |  |

write one word data to fifo.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data | data to be transferred.
Return values
none

Definition at line 488 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_dma_enable()

void sdio_dma_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 192 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_flag_clear()

void sdio_flag_clear | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

clear sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be any combination of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_SDIOIF_FLAG
Return values
none

Definition at line 313 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), command_rsp7_error(), mmc_stream_write(), scr_find(), sd_block_write(), sd_irq_service(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_flag_get()

flag_status sdio_flag_get | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

get sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
flag this parameter can be one of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_DOCMD_FLAG
  • SDIO_DOTX_FLAG
  • SDIO_DORX_FLAG
  • SDIO_TXBUFH_FLAG
  • SDIO_RXBUFH_FLAG
  • SDIO_TXBUFF_FLAG
  • SDIO_RXBUFF_FLAG
  • SDIO_TXBUFE_FLAG
  • SDIO_RXBUFE_FLAG
  • SDIO_TXBUF_FLAG
  • SDIO_RXBUF_FLAG
  • SDIO_SDIOIF_FLAG
Return values
flag_status (SET or RESET)

Definition at line 276 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), scr_find(), sd_irq_service(), and sdio_command_data_send().

◆ sdio_flow_control_enable()

void sdio_flow_control_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable hardware flow control.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 166 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_interrupt_enable()

void sdio_interrupt_enable | ( | sdio_type * | sdio_x,
 |  | uint32_t | int_opt,
 |  | confirm_state | new_state
 | ) |  |

config corresponding interrupt.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be one of the following values:
  • SDIO_CMDFAIL_INT
  • SDIO_DTFAIL_INT
  • SDIO_CMDTIMEOUT_INT
  • SDIO_DTTIMEOUT_INT
  • SDIO_TXERRU_INT
  • SDIO_RXERRO_INT
  • SDIO_CMDRSPCMPL_INT
  • SDIO_CMDCMPL_INT
  • SDIO_DTCMP_INT
  • SDIO_SBITERR_INT
  • SDIO_DTBLKCMPL_INT
  • SDIO_DOCMD_INT
  • SDIO_DOTX_INT
  • SDIO_DORX_INT
  • SDIO_TXBUFH_INT
  • SDIO_RXBUFH_INT
  • SDIO_TXBUFF_INT
  • SDIO_RXBUFF_INT
  • SDIO_TXBUFE_INT
  • SDIO_RXBUFE_INT
  • SDIO_TXBUF_INT
  • SDIO_RXBUF_INT
  • SDIO_SDIOIF_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 230 of file at32f413_sdio.c.

Referenced by sd_irq_service().

◆ sdio_io_function_enable()

void sdio_io_function_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the sd i/o function.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 543 of file at32f413_sdio.c.

◆ sdio_io_suspend_command_set()

void sdio_io_suspend_command_set | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sd i/o suspend command sending.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 556 of file at32f413_sdio.c.

◆ sdio_power_saving_mode_enable()

void sdio_power_saving_mode_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable power saving mode, config sdio_ck clock output when the bus is idle.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 153 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_power_set()

void sdio_power_set | ( | sdio_type * | sdio_x,
 |  | sdio_power_state_type | power_state
 | ) |  |

set the power status of the controller

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
power_state this parameter can be one of the following values:
  • SDIO_POWER_OFF
  • SDIO_POWER_ON
Return values
none

Definition at line 73 of file at32f413_sdio.c.

Referenced by sd_power_off(), and sd_power_on().

◆ sdio_power_status_get()

sdio_power_state_type sdio_power_status_get ( sdio_type * sdio_x )

get power status.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
sdio_power_state_type (SDIO_POWER_ON or SDIO_POWER_OFF)

Definition at line 85 of file at32f413_sdio.c.

Referenced by sd_card_init().

◆ sdio_read_wait_mode_set()

void sdio_read_wait_mode_set | ( | sdio_type * | sdio_x,
 |  | sdio_read_wait_mode_type | mode
 | ) |  |

set the read wait mode.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
mode this parameter can be one of the following values:
  • SDIO_READ_WAIT_CONTROLLED_BY_D2
  • SDIO_READ_WAIT_CONTROLLED_BY_CK
Return values
none

Definition at line 504 of file at32f413_sdio.c.

◆ sdio_read_wait_start()

void sdio_read_wait_start | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to start sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 517 of file at32f413_sdio.c.

◆ sdio_read_wait_stop()

void sdio_read_wait_stop | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to stop sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 530 of file at32f413_sdio.c.

◆ sdio_reset()

void sdio_reset ( sdio_type * sdio_x )

reset the sdio register

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
none

Definition at line 49 of file at32f413_sdio.c.

Referenced by sd_init().

◆ sdio_response_get()

uint32_t sdio_response_get | ( | sdio_type * | sdio_x,
 |  | sdio_rsp_index_type | reg_index
 | ) |  |

get response received from the card for the last command.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
reg_index this parameter can be one of the following values:
  • SDIO_RSP1_INDEX
  • SDIO_RSP2_INDEX
  • SDIO_RSP3_INDEX
  • SDIO_RSP4_INDEX
Return values
uint32_t response register value

Definition at line 381 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp5_error(), command_rsp6_error(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_status_send().


AT32F413 Firmwary Library: SDIO_private_functions

Functions
SDIO_private_functions
AT32F413_periph_driver » SDIO

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

Function Documentation

◆ sdio_buffer_counter_get()

uint32_t sdio_buffer_counter_get ( sdio_type * sdio_x )

get the number of words left to be written to or read from fifo..

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of words

Definition at line 475 of file at32f413_sdio.c.

◆ sdio_bus_width_config()

void sdio_bus_width_config | ( | sdio_type * | sdio_x,
 |  | sdio_bus_width_type | width
 | ) |  |

config sdio bus width

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
width this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D1
  • SDIO_BUS_WIDTH_D4
  • SDIO_BUS_WIDTH_D8
Return values
none

Definition at line 126 of file at32f413_sdio.c.

Referenced by sd_power_on(), and sd_wide_bus_operation_config().

◆ sdio_clock_bypass()

void sdio_clock_bypass | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock divider bypss

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 139 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_config()

void sdio_clock_config | ( | sdio_type * | sdio_x,
 |  | uint16_t | clk_div,
 |  | sdio_edge_phase_type | clk_edg
 | ) |  |

config sdio clock

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
clk_div | sdio clock divide factor(frequency = sdio_clk / [clk_psc + 2]).
clk_edg this parameter can be one of the following values:
  • SDIO_CLOCK_EDGE_RISING
  • SDIO_CLOCK_EDGE_FALLING
Return values
none

Definition at line 102 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_enable()

void sdio_clock_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sdio_ck output.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 179 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_command_config()

void sdio_command_config | ( | sdio_type * | sdio_x,
 |  | sdio_command_struct_type * | command_struct
 | ) |  |

config sdio command.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
command_struct | : pointer to a sdio_command_struct_type structure that contains the configuration information for the sdio command.
Return values
none

Definition at line 327 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_command_response_get()

uint8_t sdio_command_response_get ( sdio_type * sdio_x )

get command index of last command for which response received.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
uint8_t command index

Definition at line 363 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp4_error(), command_rsp5_error(), and command_rsp6_error().

◆ sdio_command_state_machine_enable()

void sdio_command_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable command path state machine(CPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 350 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_data_config()

void sdio_data_config | ( | sdio_type * | sdio_x,
 |  | sdio_data_struct_type * | data_struct
 | ) |  |

config sdio data.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data_struct | : pointer to a sdio_data_struct_type structure that contains the configuration information for the sdio data.
Return values
none

Definition at line 414 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_counter_get()

uint32_t sdio_data_counter_get ( sdio_type * sdio_x )

get the number of remaining data bytes to be transferred.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of bytes

Definition at line 451 of file at32f413_sdio.c.

◆ sdio_data_read()

uint32_t sdio_data_read ( sdio_type * sdio_x )

read a word data from sdio fifo.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t data received

Definition at line 463 of file at32f413_sdio.c.

Referenced by scr_find(), and sdio_command_data_send().

◆ sdio_data_state_machine_enable()

void sdio_data_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable data path state machine(DPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 439 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_write()

void sdio_data_write | ( | sdio_type * | sdio_x,
 |  | uint32_t | data
 | ) |  |

write one word data to fifo.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data | data to be transferred.
Return values
none

Definition at line 488 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_dma_enable()

void sdio_dma_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 192 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_flag_clear()

void sdio_flag_clear | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

clear sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be any combination of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_SDIOIF_FLAG
Return values
none

Definition at line 313 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), command_rsp7_error(), mmc_stream_write(), scr_find(), sd_block_write(), sd_irq_service(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_flag_get()

flag_status sdio_flag_get | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

get sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
flag this parameter can be one of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_DOCMD_FLAG
  • SDIO_DOTX_FLAG
  • SDIO_DORX_FLAG
  • SDIO_TXBUFH_FLAG
  • SDIO_RXBUFH_FLAG
  • SDIO_TXBUFF_FLAG
  • SDIO_RXBUFF_FLAG
  • SDIO_TXBUFE_FLAG
  • SDIO_RXBUFE_FLAG
  • SDIO_TXBUF_FLAG
  • SDIO_RXBUF_FLAG
  • SDIO_SDIOIF_FLAG
Return values
flag_status (SET or RESET)

Definition at line 276 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), scr_find(), sd_irq_service(), and sdio_command_data_send().

◆ sdio_flow_control_enable()

void sdio_flow_control_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable hardware flow control.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 166 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_interrupt_enable()

void sdio_interrupt_enable | ( | sdio_type * | sdio_x,
 |  | uint32_t | int_opt,
 |  | confirm_state | new_state
 | ) |  |

config corresponding interrupt.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be one of the following values:
  • SDIO_CMDFAIL_INT
  • SDIO_DTFAIL_INT
  • SDIO_CMDTIMEOUT_INT
  • SDIO_DTTIMEOUT_INT
  • SDIO_TXERRU_INT
  • SDIO_RXERRO_INT
  • SDIO_CMDRSPCMPL_INT
  • SDIO_CMDCMPL_INT
  • SDIO_DTCMP_INT
  • SDIO_SBITERR_INT
  • SDIO_DTBLKCMPL_INT
  • SDIO_DOCMD_INT
  • SDIO_DOTX_INT
  • SDIO_DORX_INT
  • SDIO_TXBUFH_INT
  • SDIO_RXBUFH_INT
  • SDIO_TXBUFF_INT
  • SDIO_RXBUFF_INT
  • SDIO_TXBUFE_INT
  • SDIO_RXBUFE_INT
  • SDIO_TXBUF_INT
  • SDIO_RXBUF_INT
  • SDIO_SDIOIF_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 230 of file at32f413_sdio.c.

Referenced by sd_irq_service().

◆ sdio_io_function_enable()

void sdio_io_function_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the sd i/o function.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 543 of file at32f413_sdio.c.

◆ sdio_io_suspend_command_set()

void sdio_io_suspend_command_set | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sd i/o suspend command sending.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 556 of file at32f413_sdio.c.

◆ sdio_power_saving_mode_enable()

void sdio_power_saving_mode_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable power saving mode, config sdio_ck clock output when the bus is idle.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 153 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_power_set()

void sdio_power_set | ( | sdio_type * | sdio_x,
 |  | sdio_power_state_type | power_state
 | ) |  |

set the power status of the controller

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
power_state this parameter can be one of the following values:
  • SDIO_POWER_OFF
  • SDIO_POWER_ON
Return values
none

Definition at line 73 of file at32f413_sdio.c.

Referenced by sd_power_off(), and sd_power_on().

◆ sdio_power_status_get()

sdio_power_state_type sdio_power_status_get ( sdio_type * sdio_x )

get power status.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
sdio_power_state_type (SDIO_POWER_ON or SDIO_POWER_OFF)

Definition at line 85 of file at32f413_sdio.c.

Referenced by sd_card_init().

◆ sdio_read_wait_mode_set()

void sdio_read_wait_mode_set | ( | sdio_type * | sdio_x,
 |  | sdio_read_wait_mode_type | mode
 | ) |  |

set the read wait mode.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
mode this parameter can be one of the following values:
  • SDIO_READ_WAIT_CONTROLLED_BY_D2
  • SDIO_READ_WAIT_CONTROLLED_BY_CK
Return values
none

Definition at line 504 of file at32f413_sdio.c.

◆ sdio_read_wait_start()

void sdio_read_wait_start | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to start sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 517 of file at32f413_sdio.c.

◆ sdio_read_wait_stop()

void sdio_read_wait_stop | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to stop sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 530 of file at32f413_sdio.c.

◆ sdio_reset()

void sdio_reset ( sdio_type * sdio_x )

reset the sdio register

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
none

Definition at line 49 of file at32f413_sdio.c.

Referenced by sd_init().

◆ sdio_response_get()

uint32_t sdio_response_get | ( | sdio_type * | sdio_x,
 |  | sdio_rsp_index_type | reg_index
 | ) |  |

get response received from the card for the last command.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
reg_index this parameter can be one of the following values:
  • SDIO_RSP1_INDEX
  • SDIO_RSP2_INDEX
  • SDIO_RSP3_INDEX
  • SDIO_RSP4_INDEX
Return values
uint32_t response register value

Definition at line 381 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp5_error(), command_rsp6_error(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_status_send().


AT32F413 Firmwary Library: SPI

Modules | Macros
SPI
AT32F413_periph_driver

SPI driver modules. More...

Modules

SPI_I2S_flags_definition
spi i2s flag
SPI_I2S_interrupts_definition
spi i2s interrupt
SPI_exported_types
SPI_exported_functions
SPI_private_functions

Macros

#define | SPI1 ((spi_type *) SPI1_BASE)
#define | SPI2 ((spi_type *) SPI2_BASE)

Detailed Description

SPI driver modules.

Macro Definition Documentation

◆ SPI1

#define SPI1 ((spi_type *) SPI1_BASE)

Definition at line 446 of file at32f413_spi.h.

◆ SPI2

#define SPI2 ((spi_type *) SPI2_BASE)

Definition at line 447 of file at32f413_spi.h.


AT32F413 Firmwary Library: SPI_I2S_flags_definition

Macros
SPI_I2S_flags_definition
AT32F413_periph_driver » SPI

spi i2s flag More...

Macros

#define | SPI_I2S_RDBF_FLAG 0x0001
#define | SPI_I2S_TDBE_FLAG 0x0002
#define | I2S_ACS_FLAG 0x0004
#define | I2S_TUERR_FLAG 0x0008
#define | SPI_CCERR_FLAG 0x0010
#define | SPI_MMERR_FLAG 0x0020
#define | SPI_I2S_ROERR_FLAG 0x0040
#define | SPI_I2S_BF_FLAG 0x0080

Detailed Description

spi i2s flag

Macro Definition Documentation

◆ I2S_ACS_FLAG

#define I2S_ACS_FLAG 0x0004

i2s audio channel state flag

Definition at line 53 of file at32f413_spi.h.

◆ I2S_TUERR_FLAG

#define I2S_TUERR_FLAG 0x0008

i2s transmitter underload error flag

Definition at line 54 of file at32f413_spi.h.

◆ SPI_CCERR_FLAG

#define SPI_CCERR_FLAG 0x0010

spi crc calculation error flag

Definition at line 55 of file at32f413_spi.h.

◆ SPI_I2S_BF_FLAG

#define SPI_I2S_BF_FLAG 0x0080

spi or i2s busy flag

Definition at line 58 of file at32f413_spi.h.

◆ SPI_I2S_RDBF_FLAG

#define SPI_I2S_RDBF_FLAG 0x0001

spi or i2s receive data buffer full flag

Definition at line 51 of file at32f413_spi.h.

◆ SPI_I2S_ROERR_FLAG

#define SPI_I2S_ROERR_FLAG 0x0040

spi or i2s receiver overflow error flag

Definition at line 57 of file at32f413_spi.h.

◆ SPI_I2S_TDBE_FLAG

#define SPI_I2S_TDBE_FLAG 0x0002

spi or i2s transmit data buffer empty flag

Definition at line 52 of file at32f413_spi.h.

◆ SPI_MMERR_FLAG

#define SPI_MMERR_FLAG 0x0020

spi master mode error flag

Definition at line 56 of file at32f413_spi.h.


AT32F413 Firmwary Library: SPI_I2S_interrupts_definition

Macros
SPI_I2S_interrupts_definition
AT32F413_periph_driver » SPI

spi i2s interrupt More...

Macros

#define | SPI_I2S_ERROR_INT 0x0020
#define | SPI_I2S_RDBF_INT 0x0040
#define | SPI_I2S_TDBE_INT 0x0080

Detailed Description

spi i2s interrupt

Macro Definition Documentation

◆ SPI_I2S_ERROR_INT

#define SPI_I2S_ERROR_INT 0x0020

error interrupt

Definition at line 70 of file at32f413_spi.h.

◆ SPI_I2S_RDBF_INT

#define SPI_I2S_RDBF_INT 0x0040

receive data buffer full interrupt

Definition at line 71 of file at32f413_spi.h.

◆ SPI_I2S_TDBE_INT

#define SPI_I2S_TDBE_INT 0x0080

transmit data buffer empty interrupt

Definition at line 72 of file at32f413_spi.h.


AT32F413 Firmwary Library: SPI_exported_types

Data Structures | Enumerations
SPI_exported_types
AT32F413_periph_driver » SPI

Data Structures

struct | spi_init_type
spi init type More...
struct | i2s_init_type
i2s init type More...
struct | spi_type
type define spi register all More...

Enumerations

enum | spi_frame_bit_num_type { SPI_FRAME_8BIT = 0x00 , SPI_FRAME_16BIT = 0x01 }
spi frame bit num type More...
enum | spi_master_slave_mode_type { SPI_MODE_SLAVE = 0x00 , SPI_MODE_MASTER = 0x01 }
spi master/slave mode type More...
enum | spi_clock_polarity_type { SPI_CLOCK_POLARITY_LOW = 0x00 , SPI_CLOCK_POLARITY_HIGH = 0x01 }
spi clock polarity (clkpol) type More...
enum | spi_clock_phase_type { SPI_CLOCK_PHASE_1EDGE = 0x00 , SPI_CLOCK_PHASE_2EDGE = 0x01 }
spi clock phase (clkpha) type More...
enum | spi_cs_mode_type { SPI_CS_HARDWARE_MODE = 0x00 , SPI_CS_SOFTWARE_MODE = 0x01 }
spi cs mode type More...
enum spi_mclk_freq_div_type {
SPI_MCLK_DIV_2 = 0x00 , SPI_MCLK_DIV_4 = 0x01 , SPI_MCLK_DIV_8 = 0x02 , SPI_MCLK_DIV_16 = 0x03 ,
SPI_MCLK_DIV_32 = 0x04 , SPI_MCLK_DIV_64 = 0x05 , SPI_MCLK_DIV_128 = 0x06 , SPI_MCLK_DIV_256 = 0x07 ,
SPI_MCLK_DIV_512 = 0x08 , SPI_MCLK_DIV_1024 = 0x09
}
spi master clock frequency division type More...
enum | spi_first_bit_type { SPI_FIRST_BIT_MSB = 0x00 , SPI_FIRST_BIT_LSB = 0x01 }
spi transmit first bit (lsb/msb) type More...
enum | spi_transmission_mode_type { SPI_TRANSMIT_FULL_DUPLEX = 0x00 , SPI_TRANSMIT_SIMPLEX_RX = 0x01 , SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02 , SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03 }
spi transmission mode type More...
enum | spi_crc_direction_type { SPI_CRC_RX = 0x0014 , SPI_CRC_TX = 0x0018 }
spi crc direction type More...
enum | spi_half_duplex_direction_type { SPI_HALF_DUPLEX_DIRECTION_RX = 0x00 , SPI_HALF_DUPLEX_DIRECTION_TX = 0x01 }
spi single line bidirectional direction type More...
enum | spi_software_cs_level_type { SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00 , SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01 }
spi software cs internal level type More...
enum i2s_audio_protocol_type {
I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00 , I2S_AUDIO_PROTOCOL_MSB = 0x01 , I2S_AUDIO_PROTOCOL_LSB = 0x02 , I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03 ,
I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
}
i2s audio protocol type More...
enum i2s_audio_sampling_freq_type {
I2S_AUDIO_FREQUENCY_DEFAULT = 2 , I2S_AUDIO_FREQUENCY_8K = 8000 , I2S_AUDIO_FREQUENCY_11_025K = 11025 , I2S_AUDIO_FREQUENCY_16K = 16000 ,
I2S_AUDIO_FREQUENCY_22_05K = 22050 , I2S_AUDIO_FREQUENCY_32K = 32000 , I2S_AUDIO_FREQUENCY_44_1K = 44100 , I2S_AUDIO_FREQUENCY_48K = 48000 ,
I2S_AUDIO_FREQUENCY_96K = 96000 , I2S_AUDIO_FREQUENCY_192K = 192000
}
i2s audio frequency type More...
enum | i2s_data_channel_format_type { I2S_DATA_16BIT_CHANNEL_16BIT = 0x01 , I2S_DATA_16BIT_CHANNEL_32BIT = 0x02 , I2S_DATA_24BIT_CHANNEL_32BIT = 0x03 , I2S_DATA_32BIT_CHANNEL_32BIT = 0x04 }
i2s data bit num and channel bit num type More...
enum | i2s_operation_mode_type { I2S_MODE_SLAVE_TX = 0x00 , I2S_MODE_SLAVE_RX = 0x01 , I2S_MODE_MASTER_TX = 0x02 , I2S_MODE_MASTER_RX = 0x03 }
i2s operation mode type More...
enum | i2s_clock_polarity_type { I2S_CLOCK_POLARITY_LOW = 0x00 , I2S_CLOCK_POLARITY_HIGH = 0x01 }
i2s clock polarity type More...

Detailed Description

Enumeration Type Documentation

◆ i2s_audio_protocol_type

enum i2s_audio_protocol_type

i2s audio protocol type

Enumerator
I2S_AUDIO_PROTOCOL_PHILLIPS | i2s philip standard
I2S_AUDIO_PROTOCOL_MSB | msb-justified standard
I2S_AUDIO_PROTOCOL_LSB | lsb-justified standard
I2S_AUDIO_PROTOCOL_PCM_SHORT | pcm standard-short frame
I2S_AUDIO_PROTOCOL_PCM_LONG | pcm standard-long frame

Definition at line 194 of file at32f413_spi.h.

◆ i2s_audio_sampling_freq_type

enum i2s_audio_sampling_freq_type

i2s audio frequency type

Enumerator
I2S_AUDIO_FREQUENCY_DEFAULT | i2s audio sampling frequency default
I2S_AUDIO_FREQUENCY_8K | i2s audio sampling frequency 8k
I2S_AUDIO_FREQUENCY_11_025K | i2s audio sampling frequency 11.025k
I2S_AUDIO_FREQUENCY_16K | i2s audio sampling frequency 16k
I2S_AUDIO_FREQUENCY_22_05K | i2s audio sampling frequency 22.05k
I2S_AUDIO_FREQUENCY_32K | i2s audio sampling frequency 32k
I2S_AUDIO_FREQUENCY_44_1K | i2s audio sampling frequency 44.1k
I2S_AUDIO_FREQUENCY_48K | i2s audio sampling frequency 48k
I2S_AUDIO_FREQUENCY_96K | i2s audio sampling frequency 96k
I2S_AUDIO_FREQUENCY_192K | i2s audio sampling frequency 192k

Definition at line 206 of file at32f413_spi.h.

◆ i2s_clock_polarity_type

enum i2s_clock_polarity_type

i2s clock polarity type

Enumerator
I2S_CLOCK_POLARITY_LOW | i2s clock steady state is low level
I2S_CLOCK_POLARITY_HIGH | i2s clock steady state is high level

Definition at line 245 of file at32f413_spi.h.

◆ i2s_data_channel_format_type

enum i2s_data_channel_format_type

i2s data bit num and channel bit num type

Enumerator
I2S_DATA_16BIT_CHANNEL_16BIT | 16-bit data packed in 16-bit channel frame
I2S_DATA_16BIT_CHANNEL_32BIT | 16-bit data packed in 32-bit channel frame
I2S_DATA_24BIT_CHANNEL_32BIT | 24-bit data packed in 32-bit channel frame
I2S_DATA_32BIT_CHANNEL_32BIT | 32-bit data packed in 32-bit channel frame

Definition at line 223 of file at32f413_spi.h.

◆ i2s_operation_mode_type

enum i2s_operation_mode_type

i2s operation mode type

Enumerator
I2S_MODE_SLAVE_TX | slave transmission mode
I2S_MODE_SLAVE_RX | slave reception mode
I2S_MODE_MASTER_TX | master transmission mode
I2S_MODE_MASTER_RX | master reception mode

Definition at line 234 of file at32f413_spi.h.

◆ spi_clock_phase_type

enum spi_clock_phase_type

spi clock phase (clkpha) type

Enumerator
SPI_CLOCK_PHASE_1EDGE | data capture start from the first clock edge
SPI_CLOCK_PHASE_2EDGE | data capture start from the second clock edge

Definition at line 112 of file at32f413_spi.h.

◆ spi_clock_polarity_type

enum spi_clock_polarity_type

spi clock polarity (clkpol) type

Enumerator
SPI_CLOCK_POLARITY_LOW | sck keeps low at idle state
SPI_CLOCK_POLARITY_HIGH | sck keeps high at idle state

Definition at line 103 of file at32f413_spi.h.

◆ spi_crc_direction_type

enum spi_crc_direction_type

spi crc direction type

Enumerator
SPI_CRC_RX | crc direction is rx
SPI_CRC_TX | crc direction is tx

Definition at line 167 of file at32f413_spi.h.

◆ spi_cs_mode_type

enum spi_cs_mode_type

spi cs mode type

Enumerator
SPI_CS_HARDWARE_MODE | cs is hardware mode
SPI_CS_SOFTWARE_MODE | cs is software mode

Definition at line 121 of file at32f413_spi.h.

◆ spi_first_bit_type

enum spi_first_bit_type

spi transmit first bit (lsb/msb) type

Enumerator
SPI_FIRST_BIT_MSB | the frame format is msb first
SPI_FIRST_BIT_LSB | the frame format is lsb first

Definition at line 147 of file at32f413_spi.h.

◆ spi_frame_bit_num_type

enum spi_frame_bit_num_type

spi frame bit num type

Enumerator
SPI_FRAME_8BIT | 8-bit data frame format
SPI_FRAME_16BIT | 16-bit data frame format

Definition at line 85 of file at32f413_spi.h.

◆ spi_half_duplex_direction_type

enum spi_half_duplex_direction_type

spi single line bidirectional direction type

Enumerator
SPI_HALF_DUPLEX_DIRECTION_RX | single line bidirectional half duplex mode direction: receive(slbtd = 0)
SPI_HALF_DUPLEX_DIRECTION_TX | single line bidirectional half duplex mode direction: transmit(slbtd = 1)

Definition at line 176 of file at32f413_spi.h.

◆ spi_master_slave_mode_type

enum spi_master_slave_mode_type

spi master/slave mode type

Enumerator
SPI_MODE_SLAVE | select as slave mode
SPI_MODE_MASTER | select as master mode

Definition at line 94 of file at32f413_spi.h.

◆ spi_mclk_freq_div_type

enum spi_mclk_freq_div_type

spi master clock frequency division type

Enumerator
SPI_MCLK_DIV_2 | master clock frequency division 2
SPI_MCLK_DIV_4 | master clock frequency division 4
SPI_MCLK_DIV_8 | master clock frequency division 8
SPI_MCLK_DIV_16 | master clock frequency division 16
SPI_MCLK_DIV_32 | master clock frequency division 32
SPI_MCLK_DIV_64 | master clock frequency division 64
SPI_MCLK_DIV_128 | master clock frequency division 128
SPI_MCLK_DIV_256 | master clock frequency division 256
SPI_MCLK_DIV_512 | master clock frequency division 512
SPI_MCLK_DIV_1024 | master clock frequency division 1024

Definition at line 130 of file at32f413_spi.h.

◆ spi_software_cs_level_type

enum spi_software_cs_level_type

spi software cs internal level type

Enumerator
SPI_SWCS_INTERNAL_LEVEL_LOW | internal level low
SPI_SWCS_INTERNAL_LEVEL_HIGHT | internal level high

Definition at line 185 of file at32f413_spi.h.

◆ spi_transmission_mode_type

enum spi_transmission_mode_type

spi transmission mode type

Enumerator
SPI_TRANSMIT_FULL_DUPLEX | dual line unidirectional full-duplex mode(slben = 0 and ora = 0)
SPI_TRANSMIT_SIMPLEX_RX | dual line unidirectional simplex receive-only mode(slben = 0 and ora = 1)
SPI_TRANSMIT_HALF_DUPLEX_RX | single line bidirectional half duplex mode-receiving(slben = 1 and slbtd = 0)
SPI_TRANSMIT_HALF_DUPLEX_TX | single line bidirectional half duplex mode-transmitting(slben = 1 and slbtd = 1)

Definition at line 156 of file at32f413_spi.h.


AT32F413 Firmwary Library: spi_init_type Struct Reference

Data Fields
spi_init_type Struct Reference
AT32F413_periph_driver » SPI » SPI_exported_types

spi init type More...

#include <at32f413_spi.h>

Data Fields

spi_transmission_mode_type transmission_mode
spi_master_slave_mode_type master_slave_mode
spi_mclk_freq_div_type mclk_freq_division
spi_first_bit_type first_bit_transmission
spi_frame_bit_num_type frame_bit_num
spi_clock_polarity_type clock_polarity
spi_clock_phase_type clock_phase
spi_cs_mode_type cs_mode_selection

Detailed Description

spi init type

Definition at line 254 of file at32f413_spi.h.

Field Documentation

◆ clock_phase

spi_clock_phase_type spi_init_type::clock_phase

clock phase selection

Definition at line 262 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ clock_polarity

spi_clock_polarity_type spi_init_type::clock_polarity

clock polarity selection

Definition at line 261 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ cs_mode_selection

spi_cs_mode_type spi_init_type::cs_mode_selection

hardware or software cs mode selection

Definition at line 263 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ first_bit_transmission

spi_first_bit_type spi_init_type::first_bit_transmission

transmit lsb or msb selection

Definition at line 259 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ frame_bit_num

spi_frame_bit_num_type spi_init_type::frame_bit_num

frame bit num 8 or 16 bit selection

Definition at line 260 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ master_slave_mode

spi_master_slave_mode_type spi_init_type::master_slave_mode

master or slave mode selection

Definition at line 257 of file at32f413_spi.h.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ mclk_freq_division

spi_mclk_freq_div_type spi_init_type::mclk_freq_division

master clock frequency division selection

Definition at line 258 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), and spiflash_init().

◆ transmission_mode

spi_transmission_mode_type spi_init_type::transmission_mode

transmission mode selection

Definition at line 256 of file at32f413_spi.h.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_spi.h


AT32F413 Firmwary Library: i2s_init_type Struct Reference

Data Fields
i2s_init_type Struct Reference
AT32F413_periph_driver » SPI » SPI_exported_types

i2s init type More...

#include <at32f413_spi.h>

Data Fields

i2s_operation_mode_type operation_mode
i2s_audio_protocol_type audio_protocol
i2s_audio_sampling_freq_type audio_sampling_freq
i2s_data_channel_format_type data_channel_format
i2s_clock_polarity_type clock_polarity
confirm_state mclk_output_enable

Detailed Description

i2s init type

Definition at line 269 of file at32f413_spi.h.

Field Documentation

◆ audio_protocol

i2s_audio_protocol_type i2s_init_type::audio_protocol

audio protocol selection

Definition at line 272 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ audio_sampling_freq

i2s_audio_sampling_freq_type i2s_init_type::audio_sampling_freq

audio frequency selection

Definition at line 273 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ clock_polarity

i2s_clock_polarity_type i2s_init_type::clock_polarity

clock polarity selection

Definition at line 275 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ data_channel_format

i2s_data_channel_format_type i2s_init_type::data_channel_format

data bit num and channel bit num selection

Definition at line 274 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ mclk_output_enable

confirm_state i2s_init_type::mclk_output_enable

mclk_output selection

Definition at line 276 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ operation_mode

i2s_operation_mode_type i2s_init_type::operation_mode

operation mode selection

Definition at line 271 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

The documentation for this struct was generated from the following file:
  • at32f413_spi.h


AT32F413 Firmwary Library: spi_type Struct Reference

Data Fields
spi_type Struct Reference
AT32F413_periph_driver » SPI » SPI_exported_types

type define spi register all More...

#include <at32f413_spi.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t clkpha: 1
__IO uint32_t clkpol: 1
__IO uint32_t msten: 1
__IO uint32_t mdiv_l: 3
__IO uint32_t spien: 1
__IO uint32_t ltf: 1
__IO uint32_t swcsil: 1
__IO uint32_t swcsen: 1
__IO uint32_t ora: 1
__IO uint32_t fbn: 1
__IO uint32_t ntc: 1
__IO uint32_t ccen: 1
__IO uint32_t slbtd: 1
__IO uint32_t slben: 1
__IO uint32_t reserved1: 16
} ctrl1_bit
};
spi ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t dmaren: 1
__IO uint32_t dmaten: 1
__IO uint32_t hwcsoe: 1
__IO uint32_t reserved1: 2
__IO uint32_t errie: 1
__IO uint32_t rdbfie: 1
__IO uint32_t tdbeie: 1
__IO uint32_t mdiv_h: 1
__IO uint32_t reserved2: 23
} ctrl2_bit
};
spi ctrl2 register, offset:0x04 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t rdbf: 1
__IO uint32_t tdbe: 1
__IO uint32_t acs: 1
__IO uint32_t tuerr: 1
__IO uint32_t ccerr: 1
__IO uint32_t mmerr: 1
__IO uint32_t roerr: 1
__IO uint32_t bf: 1
__IO uint32_t reserved1: 24
} sts_bit
};
spi sts register, offset:0x08 More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt_bit
};
spi dt register, offset:0x0C More...
union {
__IO uint32_t cpoly
struct {
__IO uint32_t cpoly: 16
__IO uint32_t reserved1: 16
} cpoly_bit
};
spi cpoly register, offset:0x10 More...
union {
__IO uint32_t rcrc
struct {
__IO uint32_t rcrc: 16
__IO uint32_t reserved1: 16
} rcrc_bit
};
spi rcrc register, offset:0x14 More...
union {
__IO uint32_t tcrc
struct {
__IO uint32_t tcrc: 16
__IO uint32_t reserved1: 16
} tcrc_bit
};
spi tcrc register, offset:0x18 More...
union {
__IO uint32_t i2sctrl
struct {
__IO uint32_t i2scbn: 1
__IO uint32_t i2sdbn: 2
__IO uint32_t i2sclkpol: 1
__IO uint32_t stdsel: 2
__IO uint32_t reserved1: 1
__IO uint32_t pcmfssel: 1
__IO uint32_t opersel: 2
__IO uint32_t i2sen: 1
__IO uint32_t i2smsel: 1
__IO uint32_t reserved2: 20
} i2sctrl_bit
};
spi i2sctrl register, offset:0x1C More...
union {
__IO uint32_t i2sclk
struct {
__IO uint32_t i2sdiv_l: 8
__IO uint32_t i2sodd: 1
__IO uint32_t i2smclkoe: 1
__IO uint32_t i2sdiv_h: 2
__IO uint32_t reserved1: 20
} i2sclk_bit
};
spi i2sclk register, offset:0x20 More...

Detailed Description

type define spi register all

Definition at line 282 of file at32f413_spi.h.

Field Documentation

◆

union { ... } spi_type::@625

spi ctrl1 register, offset:0x00

◆

union { ... } spi_type::@627

spi ctrl2 register, offset:0x04

◆

union { ... } spi_type::@629

spi sts register, offset:0x08

◆

union { ... } spi_type::@631

spi dt register, offset:0x0C

◆

union { ... } spi_type::@633

spi cpoly register, offset:0x10

◆

union { ... } spi_type::@635

spi rcrc register, offset:0x14

◆

union { ... } spi_type::@637

spi tcrc register, offset:0x18

◆

union { ... } spi_type::@639

spi i2sctrl register, offset:0x1C

◆

union { ... } spi_type::@641

spi i2sclk register, offset:0x20

◆ acs

__IO uint32_t spi_type::acs

Definition at line 341 of file at32f413_spi.h.

◆ bf

__IO uint32_t spi_type::bf

Definition at line 346 of file at32f413_spi.h.

◆ ccen

__IO uint32_t spi_type::ccen

Definition at line 304 of file at32f413_spi.h.

Referenced by spi_crc_enable().

◆ ccerr

__IO uint32_t spi_type::ccerr

Definition at line 343 of file at32f413_spi.h.

◆ clkpha

__IO uint32_t spi_type::clkpha

Definition at line 293 of file at32f413_spi.h.

Referenced by spi_init().

◆ clkpol

__IO uint32_t spi_type::clkpol

Definition at line 294 of file at32f413_spi.h.

Referenced by spi_init().

◆ cpoly

__IO uint32_t spi_type::cpoly

Definition at line 369 of file at32f413_spi.h.

Referenced by spi_crc_polynomial_get(), and spi_crc_polynomial_set().

◆

struct { ... } spi_type::cpoly_bit

Referenced by spi_crc_polynomial_get(), and spi_crc_polynomial_set().

◆ ctrl1

__IO uint32_t spi_type::ctrl1

Definition at line 290 of file at32f413_spi.h.

Referenced by spi_i2s_flag_clear().

◆

struct { ... } spi_type::ctrl1_bit

Referenced by spi_crc_enable(), spi_crc_next_transmit(), spi_enable(), spi_frame_bit_num_set(), spi_half_duplex_direction_set(), spi_init(), and spi_software_cs_internal_level_set().

◆ ctrl2

__IO uint32_t spi_type::ctrl2

Definition at line 316 of file at32f413_spi.h.

Referenced by spi_i2s_interrupt_enable().

◆

struct { ... } spi_type::ctrl2_bit

Referenced by spi_hardware_cs_output_enable(), spi_i2s_dma_receiver_enable(), spi_i2s_dma_transmitter_enable(), and spi_init().

◆ dmaren

__IO uint32_t spi_type::dmaren

Definition at line 319 of file at32f413_spi.h.

Referenced by spi_i2s_dma_receiver_enable().

◆ dmaten

__IO uint32_t spi_type::dmaten

Definition at line 320 of file at32f413_spi.h.

Referenced by spi_i2s_dma_transmitter_enable().

◆ dt

__IO uint32_t spi_type::dt

Definition at line 356 of file at32f413_spi.h.

Referenced by spi_i2s_data_receive(), spi_i2s_data_transmit(), and spi_i2s_flag_clear().

◆

struct { ... } spi_type::dt_bit

◆ errie

__IO uint32_t spi_type::errie

Definition at line 323 of file at32f413_spi.h.

◆ fbn

__IO uint32_t spi_type::fbn

Definition at line 302 of file at32f413_spi.h.

Referenced by spi_frame_bit_num_set(), and spi_init().

◆ hwcsoe

__IO uint32_t spi_type::hwcsoe

Definition at line 321 of file at32f413_spi.h.

Referenced by spi_hardware_cs_output_enable().

◆ i2scbn

__IO uint32_t spi_type::i2scbn

Definition at line 411 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sclk

__IO uint32_t spi_type::i2sclk

Definition at line 429 of file at32f413_spi.h.

◆

struct { ... } spi_type::i2sclk_bit

Referenced by i2s_init().

◆ i2sclkpol

__IO uint32_t spi_type::i2sclkpol

Definition at line 413 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sctrl

__IO uint32_t spi_type::i2sctrl

Definition at line 408 of file at32f413_spi.h.

◆

struct { ... } spi_type::i2sctrl_bit

Referenced by i2s_enable(), i2s_init(), and spi_init().

◆ i2sdbn

__IO uint32_t spi_type::i2sdbn

Definition at line 412 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sdiv_h

__IO uint32_t spi_type::i2sdiv_h

Definition at line 435 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sdiv_l

__IO uint32_t spi_type::i2sdiv_l

Definition at line 432 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sen

__IO uint32_t spi_type::i2sen

Definition at line 418 of file at32f413_spi.h.

Referenced by i2s_enable().

◆ i2smclkoe

__IO uint32_t spi_type::i2smclkoe

Definition at line 434 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2smsel

__IO uint32_t spi_type::i2smsel

Definition at line 419 of file at32f413_spi.h.

Referenced by i2s_init(), and spi_init().

◆ i2sodd

__IO uint32_t spi_type::i2sodd

Definition at line 433 of file at32f413_spi.h.

Referenced by i2s_init().

◆ ltf

__IO uint32_t spi_type::ltf

Definition at line 298 of file at32f413_spi.h.

Referenced by spi_init().

◆ mdiv_h

__IO uint32_t spi_type::mdiv_h

Definition at line 326 of file at32f413_spi.h.

Referenced by spi_init().

◆ mdiv_l

__IO uint32_t spi_type::mdiv_l

Definition at line 296 of file at32f413_spi.h.

Referenced by spi_init().

◆ mmerr

__IO uint32_t spi_type::mmerr

Definition at line 344 of file at32f413_spi.h.

◆ msten

__IO uint32_t spi_type::msten

Definition at line 295 of file at32f413_spi.h.

Referenced by spi_init().

◆ ntc

__IO uint32_t spi_type::ntc

Definition at line 303 of file at32f413_spi.h.

Referenced by spi_crc_next_transmit().

◆ opersel

__IO uint32_t spi_type::opersel

Definition at line 417 of file at32f413_spi.h.

Referenced by i2s_init().

◆ ora

__IO uint32_t spi_type::ora

Definition at line 301 of file at32f413_spi.h.

Referenced by spi_init().

◆ pcmfssel

__IO uint32_t spi_type::pcmfssel

Definition at line 416 of file at32f413_spi.h.

Referenced by i2s_init().

◆ rcrc

__IO uint32_t spi_type::rcrc

Definition at line 382 of file at32f413_spi.h.

Referenced by spi_crc_value_get().

◆

struct { ... } spi_type::rcrc_bit

Referenced by spi_crc_value_get().

◆ rdbf

__IO uint32_t spi_type::rdbf

Definition at line 339 of file at32f413_spi.h.

◆ rdbfie

__IO uint32_t spi_type::rdbfie

Definition at line 324 of file at32f413_spi.h.

◆ reserved1

__IO uint32_t spi_type::reserved1

Definition at line 307 of file at32f413_spi.h.

◆ reserved2

__IO uint32_t spi_type::reserved2

Definition at line 327 of file at32f413_spi.h.

◆ roerr

__IO uint32_t spi_type::roerr

Definition at line 345 of file at32f413_spi.h.

◆ slben

__IO uint32_t spi_type::slben

Definition at line 306 of file at32f413_spi.h.

Referenced by spi_init().

◆ slbtd

__IO uint32_t spi_type::slbtd

Definition at line 305 of file at32f413_spi.h.

Referenced by spi_half_duplex_direction_set(), and spi_init().

◆ spien

__IO uint32_t spi_type::spien

Definition at line 297 of file at32f413_spi.h.

Referenced by spi_enable().

◆ stdsel

__IO uint32_t spi_type::stdsel

Definition at line 414 of file at32f413_spi.h.

Referenced by i2s_init().

◆ sts

__IO uint32_t spi_type::sts

Definition at line 336 of file at32f413_spi.h.

Referenced by spi_i2s_flag_clear(), and spi_i2s_flag_get().

◆

struct { ... } spi_type::sts_bit

◆ swcsen

__IO uint32_t spi_type::swcsen

Definition at line 300 of file at32f413_spi.h.

Referenced by spi_init().

◆ swcsil

__IO uint32_t spi_type::swcsil

Definition at line 299 of file at32f413_spi.h.

Referenced by spi_init(), and spi_software_cs_internal_level_set().

◆ tcrc

__IO uint32_t spi_type::tcrc

Definition at line 395 of file at32f413_spi.h.

Referenced by spi_crc_value_get().

◆

struct { ... } spi_type::tcrc_bit

Referenced by spi_crc_value_get().

◆ tdbe

__IO uint32_t spi_type::tdbe

Definition at line 340 of file at32f413_spi.h.

◆ tdbeie

__IO uint32_t spi_type::tdbeie

Definition at line 325 of file at32f413_spi.h.

◆ tuerr

__IO uint32_t spi_type::tuerr

Definition at line 342 of file at32f413_spi.h.

The documentation for this struct was generated from the following file:
  • at32f413_spi.h


AT32F413 Firmwary Library: SPI_exported_functions

Functions
SPI_exported_functions
AT32F413_periph_driver » SPI

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

Function Documentation

◆ i2s_default_para_init()

void i2s_default_para_init ( i2s_init_type * i2s_init_struct )

i2s init config with its default value.

Parameters
i2s_init_struct : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 296 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ i2s_enable()

void i2s_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2s.

Parameters
spi_x | select the i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of i2s. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 443 of file at32f413_spi.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), i2s_config(), and main().

◆ i2s_init()

void i2s_init | ( | spi_type * | spi_x,
 |  | i2s_init_type * | i2s_init_struct
 | ) |  |

i2s init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
i2s_init_struct | : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 314 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ spi_crc_enable()

void spi_crc_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware crc calculation for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of crc calculation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 189 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_next_transmit()

void spi_crc_next_transmit ( spi_type * spi_x )

spi next transmit crc for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 150 of file at32f413_spi.c.

Referenced by main().

◆ spi_crc_polynomial_get()

uint16_t spi_crc_polynomial_get ( spi_type * spi_x )

return the crc polynomial register value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the select crc polynomial register value

Definition at line 175 of file at32f413_spi.c.

◆ spi_crc_polynomial_set()

void spi_crc_polynomial_set | ( | spi_type * | spi_x,
 |  | uint16_t | crc_poly
 | ) |  |

set the crc polynomial value for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_poly | crc polynomial value.
Return values
none

Definition at line 163 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_value_get()

uint16_t spi_crc_value_get | ( | spi_type * | spi_x,
 |  | spi_crc_direction_type | crc_direction
 | ) |  |

return the transmit or the receive crc value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_direction select transmit or receive crc value to be read
  • SPI_CRC_RX
  • SPI_CRC_TX
Return values
the select crc register value

Definition at line 204 of file at32f413_spi.c.

◆ spi_default_para_init()

void spi_default_para_init ( spi_init_type * spi_init_struct )

spi init config with its default value.

Parameters
spi_init_struct : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 69 of file at32f413_spi.c.

Referenced by spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_enable()

void spi_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable spi.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 285 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_frame_bit_num_set()

void spi_frame_bit_num_set | ( | spi_type * | spi_x,
 |  | spi_frame_bit_num_type | bit_num
 | ) |  |

set the data frame bit num for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
bit_num set the data frame size
  • SPI_FRAME_8BIT
  • SPI_FRAME_16BIT
Return values
none

Definition at line 255 of file at32f413_spi.c.

◆ spi_half_duplex_direction_set()

void spi_half_duplex_direction_set | ( | spi_type * | spi_x,
 |  | spi_half_duplex_direction_type | direction
 | ) |  |

set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
direction data transfer direction this parameter can be one of the following values:
  • SPI_HALF_DUPLEX_DIRECTION_RX
  • SPI_HALF_DUPLEX_DIRECTION_TX
Return values
none

Definition at line 271 of file at32f413_spi.c.

◆ spi_hardware_cs_output_enable()

void spi_hardware_cs_output_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware cs output for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi master cs output. this parameter can be: TRUE or FALSE. note:the bit only use in spi master mode
Return values
none

Definition at line 222 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_i2s_data_receive()

uint16_t spi_i2s_data_receive ( spi_type * spi_x )

spi/i2s data receive

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the received data value

Definition at line 524 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_data_transmit()

void spi_i2s_data_transmit | ( | spi_type * | spi_x,
 |  | uint16_t | tx_data
 | ) |  |

spi/i2s data transmit

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
tx_data the data to be transmit. this parameter can be:
  • (0x0000~0xFFFF)
Return values
none

Definition at line 512 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_dma_receiver_enable()

void spi_i2s_dma_receiver_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma receiver mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 497 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_dma_transmitter_enable()

void spi_i2s_dma_transmitter_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma transmitter mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 483 of file at32f413_spi.c.

Referenced by codec_i2s_init(), main(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_flag_clear()

void spi_i2s_flag_clear | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

clear flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_CCERR_FLAG
  • SPI_I2S_RDBF_FLAG
  • I2S_TUERR_FLAG
  • SPI_MMERR_FLAG
  • SPI_I2S_ROERR_FLAG
Note
SPI_I2S_TDBE_FLAG this flag is cleared when the tx buffer already contain data to be transmit. I2S_ACS_FLAG this flag cann't cleared by software,the flag indicate the channel side(not use in pcm standard mode). SPI_I2S_BF_FLAG this flag cann't cleared by software, it's set and cleared by hardware.
Return values
none

< spi crc calculation error flag

< spi crc calculation error flag

< spi or i2s receive data buffer full flag

< i2s transmitter underload error flag

< spi master mode error flag

< spi or i2s receiver overflow error flag

Definition at line 578 of file at32f413_spi.c.

Referenced by main().

◆ spi_i2s_flag_get()

flag_status spi_i2s_flag_get | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

get flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_I2S_RDBF_FLAG
  • SPI_I2S_TDBE_FLAG
  • I2S_ACS_FLAG (this flag only use in i2s mode)
  • I2S_TUERR_FLAG (this flag only use in i2s mode)
  • SPI_CCERR_FLAG (this flag only use in spi mode)
  • SPI_MMERR_FLAG (this flag only use in spi mode)
  • SPI_I2S_ROERR_FLAG
  • SPI_I2S_BF_FLAG
Return values
the new state of spi/i2s flag

Definition at line 546 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_interrupt_enable()

void spi_i2s_interrupt_enable | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified spi/i2s interrupts.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_int specifies the spi/i2s interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • SPI_I2S_ERROR_INT
  • SPI_I2S_RDBF_INT
  • SPI_I2S_TDBE_INT
new_state | new state of the specified spi/i2s interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 462 of file at32f413_spi.c.

Referenced by i2s_config(), main(), SPI1_IRQHandler(), SPI2_IRQHandler(), and spi_config().

◆ spi_i2s_reset()

void spi_i2s_reset ( spi_type * spi_x )

spi reset by crm reset register

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 49 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), and spi_config().

◆ spi_init()

void spi_init | ( | spi_type * | spi_x,
 |  | spi_init_type * | spi_init_struct
 | ) |  |

spi init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_init_struct | : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 89 of file at32f413_spi.c.

Referenced by main(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_software_cs_internal_level_set()

void spi_software_cs_internal_level_set | ( | spi_type * | spi_x,
 |  | spi_software_cs_level_type | level
 | ) |  |

set the software cs internal level for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
level set the state of spi cs level. this parameter can be one of the following values:
  • SPI_SWCS_INTERNAL_LEVEL_LOW
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT note:the bit only use when swcsen bit is set. note:when use this bit,io operation on the cs pin are invalid.
Return values
none

Definition at line 240 of file at32f413_spi.c.


AT32F413 Firmwary Library: SPI_private_functions

Functions
SPI_private_functions
AT32F413_periph_driver » SPI

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

Function Documentation

◆ i2s_default_para_init()

void i2s_default_para_init ( i2s_init_type * i2s_init_struct )

i2s init config with its default value.

Parameters
i2s_init_struct : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 296 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ i2s_enable()

void i2s_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2s.

Parameters
spi_x | select the i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of i2s. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 443 of file at32f413_spi.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), i2s_config(), and main().

◆ i2s_init()

void i2s_init | ( | spi_type * | spi_x,
 |  | i2s_init_type * | i2s_init_struct
 | ) |  |

i2s init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
i2s_init_struct | : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 314 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ spi_crc_enable()

void spi_crc_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware crc calculation for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of crc calculation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 189 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_next_transmit()

void spi_crc_next_transmit ( spi_type * spi_x )

spi next transmit crc for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 150 of file at32f413_spi.c.

Referenced by main().

◆ spi_crc_polynomial_get()

uint16_t spi_crc_polynomial_get ( spi_type * spi_x )

return the crc polynomial register value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the select crc polynomial register value

Definition at line 175 of file at32f413_spi.c.

◆ spi_crc_polynomial_set()

void spi_crc_polynomial_set | ( | spi_type * | spi_x,
 |  | uint16_t | crc_poly
 | ) |  |

set the crc polynomial value for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_poly | crc polynomial value.
Return values
none

Definition at line 163 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_value_get()

uint16_t spi_crc_value_get | ( | spi_type * | spi_x,
 |  | spi_crc_direction_type | crc_direction
 | ) |  |

return the transmit or the receive crc value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_direction select transmit or receive crc value to be read
  • SPI_CRC_RX
  • SPI_CRC_TX
Return values
the select crc register value

Definition at line 204 of file at32f413_spi.c.

◆ spi_default_para_init()

void spi_default_para_init ( spi_init_type * spi_init_struct )

spi init config with its default value.

Parameters
spi_init_struct : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 69 of file at32f413_spi.c.

Referenced by spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_enable()

void spi_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable spi.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 285 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_frame_bit_num_set()

void spi_frame_bit_num_set | ( | spi_type * | spi_x,
 |  | spi_frame_bit_num_type | bit_num
 | ) |  |

set the data frame bit num for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
bit_num set the data frame size
  • SPI_FRAME_8BIT
  • SPI_FRAME_16BIT
Return values
none

Definition at line 255 of file at32f413_spi.c.

◆ spi_half_duplex_direction_set()

void spi_half_duplex_direction_set | ( | spi_type * | spi_x,
 |  | spi_half_duplex_direction_type | direction
 | ) |  |

set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
direction data transfer direction this parameter can be one of the following values:
  • SPI_HALF_DUPLEX_DIRECTION_RX
  • SPI_HALF_DUPLEX_DIRECTION_TX
Return values
none

Definition at line 271 of file at32f413_spi.c.

◆ spi_hardware_cs_output_enable()

void spi_hardware_cs_output_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware cs output for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi master cs output. this parameter can be: TRUE or FALSE. note:the bit only use in spi master mode
Return values
none

Definition at line 222 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_i2s_data_receive()

uint16_t spi_i2s_data_receive ( spi_type * spi_x )

spi/i2s data receive

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the received data value

Definition at line 524 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_data_transmit()

void spi_i2s_data_transmit | ( | spi_type * | spi_x,
 |  | uint16_t | tx_data
 | ) |  |

spi/i2s data transmit

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
tx_data the data to be transmit. this parameter can be:
  • (0x0000~0xFFFF)
Return values
none

Definition at line 512 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_dma_receiver_enable()

void spi_i2s_dma_receiver_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma receiver mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 497 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_dma_transmitter_enable()

void spi_i2s_dma_transmitter_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma transmitter mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 483 of file at32f413_spi.c.

Referenced by codec_i2s_init(), main(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_flag_clear()

void spi_i2s_flag_clear | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

clear flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_CCERR_FLAG
  • SPI_I2S_RDBF_FLAG
  • I2S_TUERR_FLAG
  • SPI_MMERR_FLAG
  • SPI_I2S_ROERR_FLAG
Note
SPI_I2S_TDBE_FLAG this flag is cleared when the tx buffer already contain data to be transmit. I2S_ACS_FLAG this flag cann't cleared by software,the flag indicate the channel side(not use in pcm standard mode). SPI_I2S_BF_FLAG this flag cann't cleared by software, it's set and cleared by hardware.
Return values
none

< spi crc calculation error flag

< spi crc calculation error flag

< spi or i2s receive data buffer full flag

< i2s transmitter underload error flag

< spi master mode error flag

< spi or i2s receiver overflow error flag

Definition at line 578 of file at32f413_spi.c.

Referenced by main().

◆ spi_i2s_flag_get()

flag_status spi_i2s_flag_get | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

get flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_I2S_RDBF_FLAG
  • SPI_I2S_TDBE_FLAG
  • I2S_ACS_FLAG (this flag only use in i2s mode)
  • I2S_TUERR_FLAG (this flag only use in i2s mode)
  • SPI_CCERR_FLAG (this flag only use in spi mode)
  • SPI_MMERR_FLAG (this flag only use in spi mode)
  • SPI_I2S_ROERR_FLAG
  • SPI_I2S_BF_FLAG
Return values
the new state of spi/i2s flag

Definition at line 546 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_interrupt_enable()

void spi_i2s_interrupt_enable | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified spi/i2s interrupts.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_int specifies the spi/i2s interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • SPI_I2S_ERROR_INT
  • SPI_I2S_RDBF_INT
  • SPI_I2S_TDBE_INT
new_state | new state of the specified spi/i2s interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 462 of file at32f413_spi.c.

Referenced by i2s_config(), main(), SPI1_IRQHandler(), SPI2_IRQHandler(), and spi_config().

◆ spi_i2s_reset()

void spi_i2s_reset ( spi_type * spi_x )

spi reset by crm reset register

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 49 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), and spi_config().

◆ spi_init()

void spi_init | ( | spi_type * | spi_x,
 |  | spi_init_type * | spi_init_struct
 | ) |  |

spi init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_init_struct | : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 89 of file at32f413_spi.c.

Referenced by main(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_software_cs_internal_level_set()

void spi_software_cs_internal_level_set | ( | spi_type * | spi_x,
 |  | spi_software_cs_level_type | level
 | ) |  |

set the software cs internal level for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
level set the state of spi cs level. this parameter can be one of the following values:
  • SPI_SWCS_INTERNAL_LEVEL_LOW
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT note:the bit only use when swcsen bit is set. note:when use this bit,io operation on the cs pin are invalid.
Return values
none

Definition at line 240 of file at32f413_spi.c.


AT32F413 Firmwary Library: TMR

Modules | Macros
TMR
AT32F413_periph_driver

TMR driver modules. More...

Modules

TMR_flags_definition
tmr flag
TMR_interrupt_select_type_definition
tmr interrupt select type
TMR_exported_types
TMR_exported_functions
TMR_private_functions

Macros

#define | TMR1 ((tmr_type *) TMR1_BASE)
#define | TMR2 ((tmr_type *) TMR2_BASE)
#define | TMR3 ((tmr_type *) TMR3_BASE)
#define | TMR4 ((tmr_type *) TMR4_BASE)

Detailed Description

TMR driver modules.

Macro Definition Documentation

◆ TMR1

#define TMR1 ((tmr_type *) TMR1_BASE)

Definition at line 830 of file at32f413_tmr.h.

◆ TMR2

#define TMR2 ((tmr_type *) TMR2_BASE)

Definition at line 831 of file at32f413_tmr.h.

◆ TMR3

#define TMR3 ((tmr_type *) TMR3_BASE)

Definition at line 832 of file at32f413_tmr.h.

◆ TMR4

#define TMR4 ((tmr_type *) TMR4_BASE)

Definition at line 833 of file at32f413_tmr.h.


AT32F413 Firmwary Library: TMR_flags_definition

Macros
TMR_flags_definition
AT32F413_periph_driver » TMR

tmr flag More...

Macros

#define | TMR_OVF_FLAG ((uint32_t)0x000001)
#define | TMR_C1_FLAG ((uint32_t)0x000002)
#define | TMR_C2_FLAG ((uint32_t)0x000004)
#define | TMR_C3_FLAG ((uint32_t)0x000008)
#define | TMR_C4_FLAG ((uint32_t)0x000010)
#define | TMR_HALL_FLAG ((uint32_t)0x000020)
#define | TMR_TRIGGER_FLAG ((uint32_t)0x000040)
#define | TMR_BRK_FLAG ((uint32_t)0x000080)
#define | TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
#define | TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
#define | TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
#define | TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)

Detailed Description

tmr flag

Macro Definition Documentation

◆ TMR_BRK_FLAG

#define TMR_BRK_FLAG ((uint32_t)0x000080)

tmr flag brake

Definition at line 57 of file at32f413_tmr.h.

◆ TMR_C1_FLAG

#define TMR_C1_FLAG ((uint32_t)0x000002)

tmr flag channel 1

Definition at line 51 of file at32f413_tmr.h.

◆ TMR_C1_RECAPTURE_FLAG

#define TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)

tmr flag channel 1 recapture

Definition at line 58 of file at32f413_tmr.h.

◆ TMR_C2_FLAG

#define TMR_C2_FLAG ((uint32_t)0x000004)

tmr flag channel 2

Definition at line 52 of file at32f413_tmr.h.

◆ TMR_C2_RECAPTURE_FLAG

#define TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)

tmr flag channel 2 recapture

Definition at line 59 of file at32f413_tmr.h.

◆ TMR_C3_FLAG

#define TMR_C3_FLAG ((uint32_t)0x000008)

tmr flag channel 3

Definition at line 53 of file at32f413_tmr.h.

◆ TMR_C3_RECAPTURE_FLAG

#define TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)

tmr flag channel 3 recapture

Definition at line 60 of file at32f413_tmr.h.

◆ TMR_C4_FLAG

#define TMR_C4_FLAG ((uint32_t)0x000010)

tmr flag channel 4

Definition at line 54 of file at32f413_tmr.h.

◆ TMR_C4_RECAPTURE_FLAG

#define TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)

tmr flag channel 4 recapture

Definition at line 61 of file at32f413_tmr.h.

◆ TMR_HALL_FLAG

#define TMR_HALL_FLAG ((uint32_t)0x000020)

tmr flag hall

Definition at line 55 of file at32f413_tmr.h.

◆ TMR_OVF_FLAG

#define TMR_OVF_FLAG ((uint32_t)0x000001)

tmr flag overflow

Definition at line 50 of file at32f413_tmr.h.

◆ TMR_TRIGGER_FLAG

#define TMR_TRIGGER_FLAG ((uint32_t)0x000040)

tmr flag trigger

Definition at line 56 of file at32f413_tmr.h.


AT32F413 Firmwary Library: TMR_interrupt_select_type_definition

Macros
TMR_interrupt_select_type_definition
AT32F413_periph_driver » TMR

tmr interrupt select type More...

Macros

#define | TMR_OVF_INT ((uint32_t)0x000001)
#define | TMR_C1_INT ((uint32_t)0x000002)
#define | TMR_C2_INT ((uint32_t)0x000004)
#define | TMR_C3_INT ((uint32_t)0x000008)
#define | TMR_C4_INT ((uint32_t)0x000010)
#define | TMR_HALL_INT ((uint32_t)0x000020)
#define | TMR_TRIGGER_INT ((uint32_t)0x000040)
#define | TMR_BRK_INT ((uint32_t)0x000080)

Detailed Description

tmr interrupt select type

Macro Definition Documentation

◆ TMR_BRK_INT

#define TMR_BRK_INT ((uint32_t)0x000080)

tmr interrupt brake

Definition at line 79 of file at32f413_tmr.h.

◆ TMR_C1_INT

#define TMR_C1_INT ((uint32_t)0x000002)

tmr interrupt channel 1

Definition at line 73 of file at32f413_tmr.h.

◆ TMR_C2_INT

#define TMR_C2_INT ((uint32_t)0x000004)

tmr interrupt channel 2

Definition at line 74 of file at32f413_tmr.h.

◆ TMR_C3_INT

#define TMR_C3_INT ((uint32_t)0x000008)

tmr interrupt channel 3

Definition at line 75 of file at32f413_tmr.h.

◆ TMR_C4_INT

#define TMR_C4_INT ((uint32_t)0x000010)

tmr interrupt channel 4

Definition at line 76 of file at32f413_tmr.h.

◆ TMR_HALL_INT

#define TMR_HALL_INT ((uint32_t)0x000020)

tmr interrupt hall

Definition at line 77 of file at32f413_tmr.h.

◆ TMR_OVF_INT

#define TMR_OVF_INT ((uint32_t)0x000001)

tmr interrupt overflow

Definition at line 72 of file at32f413_tmr.h.

◆ TMR_TRIGGER_INT

#define TMR_TRIGGER_INT ((uint32_t)0x000040)

tmr interrupt trigger

Definition at line 78 of file at32f413_tmr.h.


AT32F413 Firmwary Library: TMR_exported_types

Data Structures | Enumerations
TMR_exported_types
AT32F413_periph_driver » TMR

Data Structures

struct | tmr_output_config_type
tmr output config type More...
struct | tmr_input_config_type
tmr input capture config type More...
struct | tmr_brkdt_config_type
tmr brkdt config type More...
struct | tmr_type
type define tmr register all More...

Enumerations

enum | tmr_clock_division_type { TMR_CLOCK_DIV1 = 0x00 , TMR_CLOCK_DIV2 = 0x01 , TMR_CLOCK_DIV4 = 0x02 }
tmr clock division type More...
enum tmr_count_mode_type {
TMR_COUNT_UP = 0x00 , TMR_COUNT_DOWN = 0x01 , TMR_COUNT_TWO_WAY_1 = 0x02 , TMR_COUNT_TWO_WAY_2 = 0x04 ,
TMR_COUNT_TWO_WAY_3 = 0x06
}
tmr counter mode type More...
enum tmr_primary_select_type {
TMR_PRIMARY_SEL_RESET = 0x00 , TMR_PRIMARY_SEL_ENABLE = 0x01 , TMR_PRIMARY_SEL_OVERFLOW = 0x02 , TMR_PRIMARY_SEL_COMPARE = 0x03 ,
TMR_PRIMARY_SEL_C1ORAW = 0x04 , TMR_PRIMARY_SEL_C2ORAW = 0x05 , TMR_PRIMARY_SEL_C3ORAW = 0x06 , TMR_PRIMARY_SEL_C4ORAW = 0x07
}
tmr primary mode select type More...
enum sub_tmr_input_sel_type {
TMR_SUB_INPUT_SEL_IS0 = 0x00 , TMR_SUB_INPUT_SEL_IS1 = 0x01 , TMR_SUB_INPUT_SEL_IS2 = 0x02 , TMR_SUB_INPUT_SEL_IS3 = 0x03 ,
TMR_SUB_INPUT_SEL_C1INC = 0x04 , TMR_SUB_INPUT_SEL_C1DF1 = 0x05 , TMR_SUB_INPUT_SEL_C2DF2 = 0x06 , TMR_SUB_INPUT_SEL_EXTIN = 0x07
}
tmr subordinate mode input select type More...
enum tmr_sub_mode_select_type {
TMR_SUB_MODE_DIABLE = 0x00 , TMR_SUB_ENCODER_MODE_A = 0x01 , TMR_SUB_ENCODER_MODE_B = 0x02 , TMR_SUB_ENCODER_MODE_C = 0x03 ,
TMR_SUB_RESET_MODE = 0x04 , TMR_SUB_HANG_MODE = 0x05 , TMR_SUB_TRIGGER_MODE = 0x06 , TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
}
tmr subordinate mode select type More...
enum | tmr_encoder_mode_type { TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A , TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B , TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C }
tmr encoder mode type More...
enum tmr_output_control_mode_type {
TMR_OUTPUT_CONTROL_OFF = 0x00 , TMR_OUTPUT_CONTROL_HIGH = 0x01 , TMR_OUTPUT_CONTROL_LOW = 0x02 , TMR_OUTPUT_CONTROL_SWITCH = 0x03 ,
TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04 , TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05 , TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06 , TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
}
tmr output control mode type More...
enum | tmr_force_output_type { TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH , TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW }
tmr force output type More...
enum | tmr_output_polarity_type { TMR_OUTPUT_ACTIVE_HIGH = 0x00 , TMR_OUTPUT_ACTIVE_LOW = 0x01 }
tmr output channel polarity type More...
enum | tmr_input_polarity_type { TMR_INPUT_RISING_EDGE = 0x00 , TMR_INPUT_FALLING_EDGE = 0x01 , TMR_INPUT_BOTH_EDGE = 0x03 }
tmr input channel polarity type More...
enum tmr_channel_select_type {
TMR_SELECT_CHANNEL_1 = 0x00 , TMR_SELECT_CHANNEL_1C = 0x01 , TMR_SELECT_CHANNEL_2 = 0x02 , TMR_SELECT_CHANNEL_2C = 0x03 ,
TMR_SELECT_CHANNEL_3 = 0x04 , TMR_SELECT_CHANNEL_3C = 0x05 , TMR_SELECT_CHANNEL_4 = 0x06
}
tmr channel select type More...
enum | tmr_channel1_input_connected_type { TMR_CHANEL1_CONNECTED_C1IRAW = 0x00 , TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01 }
tmr channel1 input connected type More...
enum | tmr_input_direction_mapped_type { TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01 , TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02 , TMR_CC_CHANNEL_MAPPED_STI = 0x03 }
tmr input channel mapped type channel direction More...
enum | tmr_channel_input_divider_type { TMR_CHANNEL_INPUT_DIV_1 = 0x00 , TMR_CHANNEL_INPUT_DIV_2 = 0x01 , TMR_CHANNEL_INPUT_DIV_4 = 0x02 , TMR_CHANNEL_INPUT_DIV_8 = 0x03 }
tmr input divider type More...
enum | tmr_dma_request_source_type { TMR_DMA_REQUEST_BY_CHANNEL = 0x00 , TMR_DMA_REQUEST_BY_OVERFLOW = 0x01 }
tmr dma request source select type More...
enum tmr_dma_request_type {
TMR_OVERFLOW_DMA_REQUEST = 0x00000100 , TMR_C1_DMA_REQUEST = 0x00000200 , TMR_C2_DMA_REQUEST = 0x00000400 , TMR_C3_DMA_REQUEST = 0x00000800 ,
TMR_C4_DMA_REQUEST = 0x00001000 , TMR_HALL_DMA_REQUEST = 0x00002000 , TMR_TRIGGER_DMA_REQUEST = 0x00004000
}
tmr dma request type More...
enum tmr_event_trigger_type {
TMR_OVERFLOW_SWTRIG = 0x00000001 , TMR_C1_SWTRIG = 0x00000002 , TMR_C2_SWTRIG = 0x00000004 , TMR_C3_SWTRIG = 0x00000008 ,
TMR_C4_SWTRIG = 0x00000010 , TMR_HALL_SWTRIG = 0x00000020 , TMR_TRIGGER_SWTRIG = 0x00000040 , TMR_BRK_SWTRIG = 0x00000080
}
tmr event triggered by software type More...
enum | tmr_polarity_active_type { TMR_POLARITY_ACTIVE_HIGH = 0x00 , TMR_POLARITY_ACTIVE_LOW = 0x01 , TMR_POLARITY_ACTIVE_BOTH = 0x02 }
tmr polarity active type More...
enum | tmr_external_signal_divider_type { TMR_ES_FREQUENCY_DIV_1 = 0x00 , TMR_ES_FREQUENCY_DIV_2 = 0x01 , TMR_ES_FREQUENCY_DIV_4 = 0x02 , TMR_ES_FREQUENCY_DIV_8 = 0x03 }
tmr external signal divider type More...
enum | tmr_external_signal_polarity_type { TMR_ES_POLARITY_NON_INVERTED = 0x00 , TMR_ES_POLARITY_INVERTED = 0x01 }
tmr external signal polarity type More...
enum tmr_dma_transfer_length_type {
TMR_DMA_TRANSFER_1BYTE = 0x00 , TMR_DMA_TRANSFER_2BYTES = 0x01 , TMR_DMA_TRANSFER_3BYTES = 0x02 , TMR_DMA_TRANSFER_4BYTES = 0x03 ,
TMR_DMA_TRANSFER_5BYTES = 0x04 , TMR_DMA_TRANSFER_6BYTES = 0x05 , TMR_DMA_TRANSFER_7BYTES = 0x06 , TMR_DMA_TRANSFER_8BYTES = 0x07 ,
TMR_DMA_TRANSFER_9BYTES = 0x08 , TMR_DMA_TRANSFER_10BYTES = 0x09 , TMR_DMA_TRANSFER_11BYTES = 0x0A , TMR_DMA_TRANSFER_12BYTES = 0x0B ,
TMR_DMA_TRANSFER_13BYTES = 0x0C , TMR_DMA_TRANSFER_14BYTES = 0x0D , TMR_DMA_TRANSFER_15BYTES = 0x0E , TMR_DMA_TRANSFER_16BYTES = 0x0F ,
TMR_DMA_TRANSFER_17BYTES = 0x10 , TMR_DMA_TRANSFER_18BYTES = 0x11
}
tmr dma transfer length type More...
enum tmr_dma_address_type {
TMR_CTRL1_ADDRESS = 0x0000 , TMR_CTRL2_ADDRESS = 0x0001 , TMR_STCTRL_ADDRESS = 0x0002 , TMR_IDEN_ADDRESS = 0x0003 ,
TMR_ISTS_ADDRESS = 0x0004 , TMR_SWEVT_ADDRESS = 0x0005 , TMR_CM1_ADDRESS = 0x0006 , TMR_CM2_ADDRESS = 0x0007 ,
TMR_CCTRL_ADDRESS = 0x0008 , TMR_CVAL_ADDRESS = 0x0009 , TMR_DIV_ADDRESS = 0x000A , TMR_PR_ADDRESS = 0x000B ,
TMR_RPR_ADDRESS = 0x000C , TMR_C1DT_ADDRESS = 0x000D , TMR_C2DT_ADDRESS = 0x000E , TMR_C3DT_ADDRESS = 0x000F ,
TMR_C4DT_ADDRESS = 0x0010 , TMR_BRK_ADDRESS = 0x0011 , TMR_DMACTRL_ADDRESS = 0x0012
}
tmr dma base address type More...
enum | tmr_brk_polarity_type { TMR_BRK_INPUT_ACTIVE_LOW = 0x00 , TMR_BRK_INPUT_ACTIVE_HIGH = 0x01 }
tmr brk polarity type More...
enum | tmr_wp_level_type { TMR_WP_OFF = 0x00 , TMR_WP_LEVEL_3 = 0x01 , TMR_WP_LEVEL_2 = 0x02 , TMR_WP_LEVEL_1 = 0x03 }
tmr write protect level type More...

Detailed Description

Enumeration Type Documentation

◆ sub_tmr_input_sel_type

enum sub_tmr_input_sel_type

tmr subordinate mode input select type

Enumerator
TMR_SUB_INPUT_SEL_IS0 | subordinate mode input select is0
TMR_SUB_INPUT_SEL_IS1 | subordinate mode input select is1
TMR_SUB_INPUT_SEL_IS2 | subordinate mode input select is2
TMR_SUB_INPUT_SEL_IS3 | subordinate mode input select is3
TMR_SUB_INPUT_SEL_C1INC | subordinate mode input select c1inc
TMR_SUB_INPUT_SEL_C1DF1 | subordinate mode input select c1df1
TMR_SUB_INPUT_SEL_C2DF2 | subordinate mode input select c2df2
TMR_SUB_INPUT_SEL_EXTIN | subordinate mode input select extin

Definition at line 129 of file at32f413_tmr.h.

◆ tmr_brk_polarity_type

enum tmr_brk_polarity_type

tmr brk polarity type

Enumerator
TMR_BRK_INPUT_ACTIVE_LOW | tmr brk input channel active low
TMR_BRK_INPUT_ACTIVE_HIGH | tmr brk input channel active high

Definition at line 375 of file at32f413_tmr.h.

◆ tmr_channel1_input_connected_type

enum tmr_channel1_input_connected_type

tmr channel1 input connected type

Enumerator
TMR_CHANEL1_CONNECTED_C1IRAW | channel1 pins is only connected to C1IRAW input
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR | channel1/2/3 pins are connected to C1IRAW input after xored

Definition at line 226 of file at32f413_tmr.h.

◆ tmr_channel_input_divider_type

enum tmr_channel_input_divider_type

tmr input divider type

Enumerator
TMR_CHANNEL_INPUT_DIV_1 | tmr channel input divider 1
TMR_CHANNEL_INPUT_DIV_2 | tmr channel input divider 2
TMR_CHANNEL_INPUT_DIV_4 | tmr channel input divider 4
TMR_CHANNEL_INPUT_DIV_8 | tmr channel input divider 8

Definition at line 245 of file at32f413_tmr.h.

◆ tmr_channel_select_type

enum tmr_channel_select_type

tmr channel select type

Enumerator
TMR_SELECT_CHANNEL_1 | tmr channel select channel 1
TMR_SELECT_CHANNEL_1C | tmr channel select channel 1 complementary
TMR_SELECT_CHANNEL_2 | tmr channel select channel 2
TMR_SELECT_CHANNEL_2C | tmr channel select channel 2 complementary
TMR_SELECT_CHANNEL_3 | tmr channel select channel 3
TMR_SELECT_CHANNEL_3C | tmr channel select channel 3 complementary
TMR_SELECT_CHANNEL_4 | tmr channel select channel 4

Definition at line 212 of file at32f413_tmr.h.

◆ tmr_clock_division_type

enum tmr_clock_division_type

tmr clock division type

Enumerator
TMR_CLOCK_DIV1 | tmr clock division 1
TMR_CLOCK_DIV2 | tmr clock division 2
TMR_CLOCK_DIV4 | tmr clock division 4

Definition at line 92 of file at32f413_tmr.h.

◆ tmr_count_mode_type

enum tmr_count_mode_type

tmr counter mode type

Enumerator
TMR_COUNT_UP | tmr counter mode up
TMR_COUNT_DOWN | tmr counter mode down
TMR_COUNT_TWO_WAY_1 | tmr counter mode two way 1
TMR_COUNT_TWO_WAY_2 | tmr counter mode two way 2
TMR_COUNT_TWO_WAY_3 | tmr counter mode two way 3

Definition at line 102 of file at32f413_tmr.h.

◆ tmr_dma_address_type

enum tmr_dma_address_type

tmr dma base address type

Enumerator
TMR_CTRL1_ADDRESS | tmr dma base address ctrl1
TMR_CTRL2_ADDRESS | tmr dma base address ctrl2
TMR_STCTRL_ADDRESS | tmr dma base address stctrl
TMR_IDEN_ADDRESS | tmr dma base address iden
TMR_ISTS_ADDRESS | tmr dma base address ists
TMR_SWEVT_ADDRESS | tmr dma base address swevt
TMR_CM1_ADDRESS | tmr dma base address cm1
TMR_CM2_ADDRESS | tmr dma base address cm2
TMR_CCTRL_ADDRESS | tmr dma base address cctrl
TMR_CVAL_ADDRESS | tmr dma base address cval
TMR_DIV_ADDRESS | tmr dma base address div
TMR_PR_ADDRESS | tmr dma base address pr
TMR_RPR_ADDRESS | tmr dma base address rpr
TMR_C1DT_ADDRESS | tmr dma base address c1dt
TMR_C2DT_ADDRESS | tmr dma base address c2dt
TMR_C3DT_ADDRESS | tmr dma base address c3dt
TMR_C4DT_ADDRESS | tmr dma base address c4dt
TMR_BRK_ADDRESS | tmr dma base address brake
TMR_DMACTRL_ADDRESS | tmr dma base address dmactrl

Definition at line 349 of file at32f413_tmr.h.

◆ tmr_dma_request_source_type

enum tmr_dma_request_source_type

tmr dma request source select type

Enumerator
TMR_DMA_REQUEST_BY_CHANNEL | tmr dma request source select channel
TMR_DMA_REQUEST_BY_OVERFLOW | tmr dma request source select overflow

Definition at line 256 of file at32f413_tmr.h.

◆ tmr_dma_request_type

enum tmr_dma_request_type

tmr dma request type

Enumerator
TMR_OVERFLOW_DMA_REQUEST | tmr dma request select overflow
TMR_C1_DMA_REQUEST | tmr dma request select channel 1
TMR_C2_DMA_REQUEST | tmr dma request select channel 2
TMR_C3_DMA_REQUEST | tmr dma request select channel 3
TMR_C4_DMA_REQUEST | tmr dma request select channel 4
TMR_HALL_DMA_REQUEST | tmr dma request select hall
TMR_TRIGGER_DMA_REQUEST | tmr dma request select trigger

Definition at line 265 of file at32f413_tmr.h.

◆ tmr_dma_transfer_length_type

enum tmr_dma_transfer_length_type

tmr dma transfer length type

Enumerator
TMR_DMA_TRANSFER_1BYTE | tmr dma transfer length 1 byte
TMR_DMA_TRANSFER_2BYTES | tmr dma transfer length 2 bytes
TMR_DMA_TRANSFER_3BYTES | tmr dma transfer length 3 bytes
TMR_DMA_TRANSFER_4BYTES | tmr dma transfer length 4 bytes
TMR_DMA_TRANSFER_5BYTES | tmr dma transfer length 5 bytes
TMR_DMA_TRANSFER_6BYTES | tmr dma transfer length 6 bytes
TMR_DMA_TRANSFER_7BYTES | tmr dma transfer length 7 bytes
TMR_DMA_TRANSFER_8BYTES | tmr dma transfer length 8 bytes
TMR_DMA_TRANSFER_9BYTES | tmr dma transfer length 9 bytes
TMR_DMA_TRANSFER_10BYTES | tmr dma transfer length 10 bytes
TMR_DMA_TRANSFER_11BYTES | tmr dma transfer length 11 bytes
TMR_DMA_TRANSFER_12BYTES | tmr dma transfer length 12 bytes
TMR_DMA_TRANSFER_13BYTES | tmr dma transfer length 13 bytes
TMR_DMA_TRANSFER_14BYTES | tmr dma transfer length 14 bytes
TMR_DMA_TRANSFER_15BYTES | tmr dma transfer length 15 bytes
TMR_DMA_TRANSFER_16BYTES | tmr dma transfer length 16 bytes
TMR_DMA_TRANSFER_17BYTES | tmr dma transfer length 17 bytes
TMR_DMA_TRANSFER_18BYTES | tmr dma transfer length 18 bytes

Definition at line 324 of file at32f413_tmr.h.

◆ tmr_encoder_mode_type

enum tmr_encoder_mode_type

tmr encoder mode type

Enumerator
TMR_ENCODER_MODE_A | tmr encoder mode a
TMR_ENCODER_MODE_B | tmr encoder mode b
TMR_ENCODER_MODE_C | tmr encoder mode c

Definition at line 159 of file at32f413_tmr.h.

◆ tmr_event_trigger_type

enum tmr_event_trigger_type

tmr event triggered by software type

Enumerator
TMR_OVERFLOW_SWTRIG | tmr event triggered by software of overflow
TMR_C1_SWTRIG | tmr event triggered by software of channel 1
TMR_C2_SWTRIG | tmr event triggered by software of channel 2
TMR_C3_SWTRIG | tmr event triggered by software of channel 3
TMR_C4_SWTRIG | tmr event triggered by software of channel 4
TMR_HALL_SWTRIG | tmr event triggered by software of hall
TMR_TRIGGER_SWTRIG | tmr event triggered by software of trigger
TMR_BRK_SWTRIG | tmr event triggered by software of brake

Definition at line 279 of file at32f413_tmr.h.

◆ tmr_external_signal_divider_type

enum tmr_external_signal_divider_type

tmr external signal divider type

Enumerator
TMR_ES_FREQUENCY_DIV_1 | tmr external signal frequency divider 1
TMR_ES_FREQUENCY_DIV_2 | tmr external signal frequency divider 2
TMR_ES_FREQUENCY_DIV_4 | tmr external signal frequency divider 4
TMR_ES_FREQUENCY_DIV_8 | tmr external signal frequency divider 8

Definition at line 304 of file at32f413_tmr.h.

◆ tmr_external_signal_polarity_type

enum tmr_external_signal_polarity_type

tmr external signal polarity type

Enumerator
TMR_ES_POLARITY_NON_INVERTED | tmr external signal polarity non-inerted
TMR_ES_POLARITY_INVERTED | tmr external signal polarity inerted

Definition at line 315 of file at32f413_tmr.h.

◆ tmr_force_output_type

enum tmr_force_output_type

tmr force output type

Enumerator
TMR_FORCE_OUTPUT_HIGH | tmr force output high
TMR_FORCE_OUTPUT_LOW | tmr force output low

Definition at line 184 of file at32f413_tmr.h.

◆ tmr_input_direction_mapped_type

enum tmr_input_direction_mapped_type

tmr input channel mapped type channel direction

Enumerator
TMR_CC_CHANNEL_MAPPED_DIRECT | channel is configured as input, mapped direct
TMR_CC_CHANNEL_MAPPED_INDIRECT | channel is configured as input, mapped indirect
TMR_CC_CHANNEL_MAPPED_STI | channel is configured as input, mapped sti

Definition at line 235 of file at32f413_tmr.h.

◆ tmr_input_polarity_type

enum tmr_input_polarity_type

tmr input channel polarity type

Enumerator
TMR_INPUT_RISING_EDGE | tmr input channel polarity rising
TMR_INPUT_FALLING_EDGE | tmr input channel polarity falling
TMR_INPUT_BOTH_EDGE | tmr input channel polarity both edge

Definition at line 202 of file at32f413_tmr.h.

◆ tmr_output_control_mode_type

enum tmr_output_control_mode_type

tmr output control mode type

Enumerator
TMR_OUTPUT_CONTROL_OFF | tmr output control mode off
TMR_OUTPUT_CONTROL_HIGH | tmr output control mode high
TMR_OUTPUT_CONTROL_LOW | tmr output control mode low
TMR_OUTPUT_CONTROL_SWITCH | tmr output control mode switch
TMR_OUTPUT_CONTROL_FORCE_LOW | tmr output control mode force low
TMR_OUTPUT_CONTROL_FORCE_HIGH | tmr output control mode force high
TMR_OUTPUT_CONTROL_PWM_MODE_A | tmr output control mode pwm a
TMR_OUTPUT_CONTROL_PWM_MODE_B | tmr output control mode pwm b

Definition at line 169 of file at32f413_tmr.h.

◆ tmr_output_polarity_type

enum tmr_output_polarity_type

tmr output channel polarity type

Enumerator
TMR_OUTPUT_ACTIVE_HIGH | tmr output channel polarity high
TMR_OUTPUT_ACTIVE_LOW | tmr output channel polarity low

Definition at line 193 of file at32f413_tmr.h.

◆ tmr_polarity_active_type

enum tmr_polarity_active_type

tmr polarity active type

Enumerator
TMR_POLARITY_ACTIVE_HIGH | tmr polarity active high
TMR_POLARITY_ACTIVE_LOW | tmr polarity active low
TMR_POLARITY_ACTIVE_BOTH | tmr polarity active both high ande low

Definition at line 294 of file at32f413_tmr.h.

◆ tmr_primary_select_type

enum tmr_primary_select_type

tmr primary mode select type

Enumerator
TMR_PRIMARY_SEL_RESET | tmr primary mode select reset
TMR_PRIMARY_SEL_ENABLE | tmr primary mode select enable
TMR_PRIMARY_SEL_OVERFLOW | tmr primary mode select overflow
TMR_PRIMARY_SEL_COMPARE | tmr primary mode select compare
TMR_PRIMARY_SEL_C1ORAW | tmr primary mode select c1oraw
TMR_PRIMARY_SEL_C2ORAW | tmr primary mode select c2oraw
TMR_PRIMARY_SEL_C3ORAW | tmr primary mode select c3oraw
TMR_PRIMARY_SEL_C4ORAW | tmr primary mode select c4oraw

Definition at line 114 of file at32f413_tmr.h.

◆ tmr_sub_mode_select_type

enum tmr_sub_mode_select_type

tmr subordinate mode select type

Enumerator
TMR_SUB_MODE_DIABLE | subordinate mode disable
TMR_SUB_ENCODER_MODE_A | subordinate mode select encoder mode a
TMR_SUB_ENCODER_MODE_B | subordinate mode select encoder mode b
TMR_SUB_ENCODER_MODE_C | subordinate mode select encoder mode c
TMR_SUB_RESET_MODE | subordinate mode select reset
TMR_SUB_HANG_MODE | subordinate mode select hang
TMR_SUB_TRIGGER_MODE | subordinate mode select trigger
TMR_SUB_EXTERNAL_CLOCK_MODE_A | subordinate mode external clock mode a

Definition at line 144 of file at32f413_tmr.h.

◆ tmr_wp_level_type

enum tmr_wp_level_type

tmr write protect level type

Enumerator
TMR_WP_OFF | tmr write protect off
TMR_WP_LEVEL_3 | tmr write protect level 3
TMR_WP_LEVEL_2 | tmr write protect level 2
TMR_WP_LEVEL_1 | tmr write protect level 1

Definition at line 384 of file at32f413_tmr.h.


AT32F413 Firmwary Library: tmr_output_config_type Struct Reference

Data Fields
tmr_output_config_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

tmr output config type More...

#include <at32f413_tmr.h>

Data Fields

tmr_output_control_mode_type oc_mode
confirm_state oc_idle_state
confirm_state occ_idle_state
tmr_output_polarity_type oc_polarity
tmr_output_polarity_type occ_polarity
confirm_state oc_output_state
confirm_state occ_output_state

Detailed Description

tmr output config type

Definition at line 395 of file at32f413_tmr.h.

Field Documentation

◆ oc_idle_state

confirm_state tmr_output_config_type::oc_idle_state

output channel idle state

Definition at line 398 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_mode

tmr_output_control_mode_type tmr_output_config_type::oc_mode

output channel mode

Definition at line 397 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_output_state

confirm_state tmr_output_config_type::oc_output_state

output channel enable

Definition at line 402 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_polarity

tmr_output_polarity_type tmr_output_config_type::oc_polarity

output channel polarity

Definition at line 400 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_idle_state

confirm_state tmr_output_config_type::occ_idle_state

output channel complementary idle state

Definition at line 399 of file at32f413_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_output_state

confirm_state tmr_output_config_type::occ_output_state

output channel complementary enable

Definition at line 403 of file at32f413_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_polarity

tmr_output_polarity_type tmr_output_config_type::occ_polarity

output channel complementary polarity

Definition at line 401 of file at32f413_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: tmr_input_config_type Struct Reference

Data Fields
tmr_input_config_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

tmr input capture config type More...

#include <at32f413_tmr.h>

Data Fields

tmr_channel_select_type input_channel_select
tmr_input_polarity_type input_polarity_select
tmr_input_direction_mapped_type input_mapped_select
uint8_t input_filter_value

Detailed Description

tmr input capture config type

Definition at line 409 of file at32f413_tmr.h.

Field Documentation

◆ input_channel_select

tmr_channel_select_type tmr_input_config_type::input_channel_select

tmr input channel select

Definition at line 411 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_filter_value

uint8_t tmr_input_config_type::input_filter_value

tmr channel filter value

Definition at line 414 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_mapped_select

tmr_input_direction_mapped_type tmr_input_config_type::input_mapped_select

tmr channel mapped direct or indirect

Definition at line 413 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_polarity_select

tmr_input_polarity_type tmr_input_config_type::input_polarity_select

tmr input polarity select

Definition at line 412 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: tmr_brkdt_config_type Struct Reference

Data Fields
tmr_brkdt_config_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

tmr brkdt config type More...

#include <at32f413_tmr.h>

Data Fields

uint8_t deadtime
tmr_brk_polarity_type brk_polarity
tmr_wp_level_type wp_level
confirm_state auto_output_enable
confirm_state fcsoen_state
confirm_state fcsodis_state
confirm_state brk_enable

Detailed Description

tmr brkdt config type

Definition at line 420 of file at32f413_tmr.h.

Field Documentation

◆ auto_output_enable

confirm_state tmr_brkdt_config_type::auto_output_enable

automatic output enable

Definition at line 425 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ brk_enable

confirm_state tmr_brkdt_config_type::brk_enable

tmr brk enale

Definition at line 428 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ brk_polarity

tmr_brk_polarity_type tmr_brkdt_config_type::brk_polarity

tmr brake polarity

Definition at line 423 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ deadtime

uint8_t tmr_brkdt_config_type::deadtime

dead-time generator setup

Definition at line 422 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ fcsodis_state

confirm_state tmr_brkdt_config_type::fcsodis_state

frozen channel status when output disable

Definition at line 427 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ fcsoen_state

confirm_state tmr_brkdt_config_type::fcsoen_state

frozen channel status when output enable

Definition at line 426 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ wp_level

tmr_wp_level_type tmr_brkdt_config_type::wp_level

write protect configuration

Definition at line 424 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: tmr_type Struct Reference

Data Fields
tmr_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

type define tmr register all More...

#include <at32f413_tmr.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t tmren: 1
__IO uint32_t ovfen: 1
__IO uint32_t ovfs: 1
__IO uint32_t ocmen: 1
__IO uint32_t cnt_dir: 3
__IO uint32_t prben: 1
__IO uint32_t clkdiv: 2
__IO uint32_t pmen: 1
__IO uint32_t reserved1: 21
} ctrl1_bit
};
tmr ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t cbctrl: 1
__IO uint32_t reserved1: 1
__IO uint32_t ccfs: 1
__IO uint32_t drs: 1
__IO uint32_t ptos: 3
__IO uint32_t c1insel: 1
__IO uint32_t c1ios: 1
__IO uint32_t c1cios: 1
__IO uint32_t c2ios: 1
__IO uint32_t c2cios: 1
__IO uint32_t c3ios: 1
__IO uint32_t c3cios: 1
__IO uint32_t c4ios: 1
__IO uint32_t reserved2: 17
} ctrl2_bit
};
tmr ctrl2 register, offset:0x04 More...
union {
__IO uint32_t stctrl
struct {
__IO uint32_t smsel: 3
__IO uint32_t reserved1: 1
__IO uint32_t stis: 3
__IO uint32_t sts: 1
__IO uint32_t esf: 4
__IO uint32_t esdiv: 2
__IO uint32_t ecmben: 1
__IO uint32_t esp: 1
__IO uint32_t reserved2: 16
} stctrl_bit
};
tmr smc register, offset:0x08 More...
union {
__IO uint32_t iden
struct {
__IO uint32_t ovfien: 1
__IO uint32_t c1ien: 1
__IO uint32_t c2ien: 1
__IO uint32_t c3ien: 1
__IO uint32_t c4ien: 1
__IO uint32_t hallien: 1
__IO uint32_t tien: 1
__IO uint32_t brkie: 1
__IO uint32_t ovfden: 1
__IO uint32_t c1den: 1
__IO uint32_t c2den: 1
__IO uint32_t c3den: 1
__IO uint32_t c4den: 1
__IO uint32_t hallde: 1
__IO uint32_t tden: 1
__IO uint32_t reserved1: 17
} iden_bit
};
tmr die register, offset:0x0C More...
union {
__IO uint32_t ists
struct {
__IO uint32_t ovfif: 1
__IO uint32_t c1if: 1
__IO uint32_t c2if: 1
__IO uint32_t c3if: 1
__IO uint32_t c4if: 1
__IO uint32_t hallif: 1
__IO uint32_t trgif: 1
__IO uint32_t brkif: 1
__IO uint32_t reserved1: 1
__IO uint32_t c1rf: 1
__IO uint32_t c2rf: 1
__IO uint32_t c3rf: 1
__IO uint32_t c4rf: 1
__IO uint32_t reserved2: 19
} ists_bit
};
tmr ists register, offset:0x10 More...
union {
__IO uint32_t swevt
struct {
__IO uint32_t ovfswtr: 1
__IO uint32_t c1swtr: 1
__IO uint32_t c2swtr: 1
__IO uint32_t c3swtr: 1
__IO uint32_t c4swtr: 1
__IO uint32_t hallswtr: 1
__IO uint32_t trgswtr: 1
__IO uint32_t brkswtr: 1
__IO uint32_t reserved: 24
} swevt_bit
};
tmr eveg register, offset:0x14 More...
union {
__IO uint32_t cm1
struct {
__IO uint32_t c1c: 2
__IO uint32_t c1oien: 1
__IO uint32_t c1oben: 1
__IO uint32_t c1octrl: 3
__IO uint32_t c1osen: 1
__IO uint32_t c2c: 2
__IO uint32_t c2oien: 1
__IO uint32_t c2oben: 1
__IO uint32_t c2octrl: 3
__IO uint32_t c2osen: 1
__IO uint32_t reserved1: 16
} cm1_output_bit
channel mode More...
struct {
__IO uint32_t c1c: 2
__IO uint32_t c1idiv: 2
__IO uint32_t c1df: 4
__IO uint32_t c2c: 2
__IO uint32_t c2idiv: 2
__IO uint32_t c2df: 4
__IO uint32_t reserved1: 16
} cm1_input_bit
input capture mode More...
};
tmr ccm1 register, offset:0x18 More...
union {
__IO uint32_t cm2
struct {
__IO uint32_t c3c: 2
__IO uint32_t c3oien: 1
__IO uint32_t c3oben: 1
__IO uint32_t c3octrl: 3
__IO uint32_t c3osen: 1
__IO uint32_t c4c: 2
__IO uint32_t c4oien: 1
__IO uint32_t c4oben: 1
__IO uint32_t c4octrl: 3
__IO uint32_t c4osen: 1
__IO uint32_t reserved1: 16
} cm2_output_bit
channel mode More...
struct {
__IO uint32_t c3c: 2
__IO uint32_t c3idiv: 2
__IO uint32_t c3df: 4
__IO uint32_t c4c: 2
__IO uint32_t c4idiv: 2
__IO uint32_t c4df: 4
__IO uint32_t reserved1: 16
} cm2_input_bit
input capture mode More...
};
tmr ccm2 register, offset:0x1C More...
union {
uint32_t cctrl
struct {
__IO uint32_t c1en: 1
__IO uint32_t c1p: 1
__IO uint32_t c1cen: 1
__IO uint32_t c1cp: 1
__IO uint32_t c2en: 1
__IO uint32_t c2p: 1
__IO uint32_t c2cen: 1
__IO uint32_t c2cp: 1
__IO uint32_t c3en: 1
__IO uint32_t c3p: 1
__IO uint32_t c3cen: 1
__IO uint32_t c3cp: 1
__IO uint32_t c4en: 1
__IO uint32_t c4p: 1
__IO uint32_t reserved1: 18
} cctrl_bit
};
tmr cce register, offset:0x20 More...
union {
__IO uint32_t cval
struct {
__IO uint32_t cval: 32
} cval_bit
};
tmr cnt register, offset:0x24 More...
union {
__IO uint32_t div
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} div_bit
};
tmr div, offset:0x28 More...
union {
__IO uint32_t pr
struct {
__IO uint32_t pr: 32
} pr_bit
};
tmr pr register, offset:0x2C More...
union {
__IO uint32_t rpr
struct {
__IO uint32_t rpr: 8
__IO uint32_t reserved1: 24
} rpr_bit
};
tmr rpr register, offset:0x30 More...
union {
uint32_t c1dt
struct {
__IO uint32_t c1dt: 32
} c1dt_bit
};
tmr c1dt register, offset:0x34 More...
union {
uint32_t c2dt
struct {
__IO uint32_t c2dt: 32
} c2dt_bit
};
tmr c2dt register, offset:0x38 More...
union {
__IO uint32_t c3dt
struct {
__IO uint32_t c3dt: 32
} c3dt_bit
};
tmr c3dt register, offset:0x3C More...
union {
__IO uint32_t c4dt
struct {
__IO uint32_t c4dt: 32
} c4dt_bit
};
tmr c4dt register, offset:0x40 More...
union {
__IO uint32_t brk
struct {
__IO uint32_t dtc: 8
__IO uint32_t wpc: 2
__IO uint32_t fcsodis: 1
__IO uint32_t fcsoen: 1
__IO uint32_t brken: 1
__IO uint32_t brkv: 1
__IO uint32_t aoen: 1
__IO uint32_t oen: 1
__IO uint32_t reserved1: 16
} brk_bit
};
tmr brk register, offset:0x44 More...
union {
__IO uint32_t dmactrl
struct {
__IO uint32_t addr: 5
__IO uint32_t reserved1: 3
__IO uint32_t dtb: 5
__IO uint32_t reserved2: 19
} dmactrl_bit
};
tmr dmactrl register, offset:0x48 More...
union {
__IO uint32_t dmadt
struct {
__IO uint32_t dmadt: 16
__IO uint32_t reserved1: 16
} dmadt_bit
};
tmr dmadt register, offset:0x4C More...

Detailed Description

type define tmr register all

Definition at line 434 of file at32f413_tmr.h.

Field Documentation

◆

union { ... } tmr_type::@652

tmr ctrl1 register, offset:0x00

◆

union { ... } tmr_type::@654

tmr ctrl2 register, offset:0x04

◆

union { ... } tmr_type::@656

tmr smc register, offset:0x08

◆

union { ... } tmr_type::@658

tmr die register, offset:0x0C

◆

union { ... } tmr_type::@660

tmr ists register, offset:0x10

◆

union { ... } tmr_type::@662

tmr eveg register, offset:0x14

◆

union { ... } tmr_type::@664

tmr ccm1 register, offset:0x18

◆

union { ... } tmr_type::@666

tmr ccm2 register, offset:0x1C

◆

union { ... } tmr_type::@668

tmr cce register, offset:0x20

◆

union { ... } tmr_type::@670

tmr cnt register, offset:0x24

◆

union { ... } tmr_type::@672

tmr div, offset:0x28

◆

union { ... } tmr_type::@674

tmr pr register, offset:0x2C

◆

union { ... } tmr_type::@676

tmr rpr register, offset:0x30

◆

union { ... } tmr_type::@678

tmr c1dt register, offset:0x34

◆

union { ... } tmr_type::@680

tmr c2dt register, offset:0x38

◆

union { ... } tmr_type::@682

tmr c3dt register, offset:0x3C

◆

union { ... } tmr_type::@684

tmr c4dt register, offset:0x40

◆

union { ... } tmr_type::@686

tmr brk register, offset:0x44

◆

union { ... } tmr_type::@688

tmr dmactrl register, offset:0x48

◆

union { ... } tmr_type::@690

tmr dmadt register, offset:0x4C

◆ addr

__IO uint32_t tmr_type::addr

Definition at line 804 of file at32f413_tmr.h.

Referenced by tmr_dma_control_config().

◆ aoen

__IO uint32_t tmr_type::aoen

Definition at line 791 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ brk

__IO uint32_t tmr_type::brk

Definition at line 782 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::brk_bit

Referenced by tmr_brkdt_config(), and tmr_output_enable().

◆ brken

__IO uint32_t tmr_type::brken

Definition at line 789 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ brkie

__IO uint32_t tmr_type::brkie

Definition at line 516 of file at32f413_tmr.h.

◆ brkif

__IO uint32_t tmr_type::brkif

Definition at line 543 of file at32f413_tmr.h.

◆ brkswtr

__IO uint32_t tmr_type::brkswtr

Definition at line 568 of file at32f413_tmr.h.

◆ brkv

__IO uint32_t tmr_type::brkv

Definition at line 790 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ c1c

__IO uint32_t tmr_type::c1c

Definition at line 585 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1cen

__IO uint32_t tmr_type::c1cen

Definition at line 663 of file at32f413_tmr.h.

Referenced by tmr_channel_enable().

◆ c1cios

__IO uint32_t tmr_type::c1cios

Definition at line 471 of file at32f413_tmr.h.

◆ c1cp

__IO uint32_t tmr_type::c1cp

Definition at line 664 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c1den

__IO uint32_t tmr_type::c1den

Definition at line 518 of file at32f413_tmr.h.

◆ c1df

__IO uint32_t tmr_type::c1df

Definition at line 605 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1dt [1/2]

uint32_t tmr_type::c1dt

Definition at line 734 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆ c1dt [2/2]

__IO uint32_t tmr_type::c1dt

Definition at line 737 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::c1dt_bit

◆ c1en

__IO uint32_t tmr_type::c1en

Definition at line 661 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1idiv

__IO uint32_t tmr_type::c1idiv

Definition at line 604 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1ien

__IO uint32_t tmr_type::c1ien

Definition at line 510 of file at32f413_tmr.h.

◆ c1if

__IO uint32_t tmr_type::c1if

Definition at line 537 of file at32f413_tmr.h.

◆ c1insel

__IO uint32_t tmr_type::c1insel

Definition at line 469 of file at32f413_tmr.h.

Referenced by tmr_channel1_input_select().

◆ c1ios

__IO uint32_t tmr_type::c1ios

Definition at line 470 of file at32f413_tmr.h.

◆ c1oben

__IO uint32_t tmr_type::c1oben

Definition at line 587 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c1octrl

__IO uint32_t tmr_type::c1octrl

Definition at line 588 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c1oien

__IO uint32_t tmr_type::c1oien

Definition at line 586 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c1osen

__IO uint32_t tmr_type::c1osen

Definition at line 589 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c1p

__IO uint32_t tmr_type::c1p

Definition at line 662 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ c1rf

__IO uint32_t tmr_type::c1rf

Definition at line 545 of file at32f413_tmr.h.

◆ c1swtr

__IO uint32_t tmr_type::c1swtr

Definition at line 562 of file at32f413_tmr.h.

◆ c2c

__IO uint32_t tmr_type::c2c

Definition at line 590 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2cen

__IO uint32_t tmr_type::c2cen

Definition at line 667 of file at32f413_tmr.h.

Referenced by tmr_channel_enable().

◆ c2cios

__IO uint32_t tmr_type::c2cios

Definition at line 473 of file at32f413_tmr.h.

◆ c2cp

__IO uint32_t tmr_type::c2cp

Definition at line 668 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c2den

__IO uint32_t tmr_type::c2den

Definition at line 519 of file at32f413_tmr.h.

◆ c2df

__IO uint32_t tmr_type::c2df

Definition at line 608 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2dt [1/2]

uint32_t tmr_type::c2dt

Definition at line 746 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆ c2dt [2/2]

__IO uint32_t tmr_type::c2dt

Definition at line 749 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::c2dt_bit

◆ c2en

__IO uint32_t tmr_type::c2en

Definition at line 665 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2idiv

__IO uint32_t tmr_type::c2idiv

Definition at line 607 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2ien

__IO uint32_t tmr_type::c2ien

Definition at line 511 of file at32f413_tmr.h.

◆ c2if

__IO uint32_t tmr_type::c2if

Definition at line 538 of file at32f413_tmr.h.

◆ c2ios

__IO uint32_t tmr_type::c2ios

Definition at line 472 of file at32f413_tmr.h.

◆ c2oben

__IO uint32_t tmr_type::c2oben

Definition at line 592 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c2octrl

__IO uint32_t tmr_type::c2octrl

Definition at line 593 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c2oien

__IO uint32_t tmr_type::c2oien

Definition at line 591 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c2osen

__IO uint32_t tmr_type::c2osen

Definition at line 594 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c2p

__IO uint32_t tmr_type::c2p

Definition at line 666 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ c2rf

__IO uint32_t tmr_type::c2rf

Definition at line 546 of file at32f413_tmr.h.

◆ c2swtr

__IO uint32_t tmr_type::c2swtr

Definition at line 563 of file at32f413_tmr.h.

◆ c3c

__IO uint32_t tmr_type::c3c

Definition at line 625 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init().

◆ c3cen

__IO uint32_t tmr_type::c3cen

Definition at line 671 of file at32f413_tmr.h.

Referenced by tmr_channel_enable().

◆ c3cios

__IO uint32_t tmr_type::c3cios

Definition at line 475 of file at32f413_tmr.h.

◆ c3cp

__IO uint32_t tmr_type::c3cp

Definition at line 672 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c3den

__IO uint32_t tmr_type::c3den

Definition at line 520 of file at32f413_tmr.h.

◆ c3df

__IO uint32_t tmr_type::c3df

Definition at line 645 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆ c3dt

__IO uint32_t tmr_type::c3dt

Definition at line 758 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆

struct { ... } tmr_type::c3dt_bit

◆ c3en

__IO uint32_t tmr_type::c3en

Definition at line 669 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), and tmr_input_channel_init().

◆ c3idiv

__IO uint32_t tmr_type::c3idiv

Definition at line 644 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), and tmr_input_channel_init().

◆ c3ien

__IO uint32_t tmr_type::c3ien

Definition at line 512 of file at32f413_tmr.h.

◆ c3if

__IO uint32_t tmr_type::c3if

Definition at line 539 of file at32f413_tmr.h.

◆ c3ios

__IO uint32_t tmr_type::c3ios

Definition at line 474 of file at32f413_tmr.h.

◆ c3oben

__IO uint32_t tmr_type::c3oben

Definition at line 627 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c3octrl

__IO uint32_t tmr_type::c3octrl

Definition at line 628 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c3oien

__IO uint32_t tmr_type::c3oien

Definition at line 626 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c3osen

__IO uint32_t tmr_type::c3osen

Definition at line 629 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c3p

__IO uint32_t tmr_type::c3p

Definition at line 670 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c3rf

__IO uint32_t tmr_type::c3rf

Definition at line 547 of file at32f413_tmr.h.

◆ c3swtr

__IO uint32_t tmr_type::c3swtr

Definition at line 564 of file at32f413_tmr.h.

◆ c4c

__IO uint32_t tmr_type::c4c

Definition at line 630 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init().

◆ c4den

__IO uint32_t tmr_type::c4den

Definition at line 521 of file at32f413_tmr.h.

◆ c4df

__IO uint32_t tmr_type::c4df

Definition at line 648 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆ c4dt

__IO uint32_t tmr_type::c4dt

Definition at line 770 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆

struct { ... } tmr_type::c4dt_bit

◆ c4en

__IO uint32_t tmr_type::c4en

Definition at line 673 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), and tmr_input_channel_init().

◆ c4idiv

__IO uint32_t tmr_type::c4idiv

Definition at line 647 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), and tmr_input_channel_init().

◆ c4ien

__IO uint32_t tmr_type::c4ien

Definition at line 513 of file at32f413_tmr.h.

◆ c4if

__IO uint32_t tmr_type::c4if

Definition at line 540 of file at32f413_tmr.h.

◆ c4ios

__IO uint32_t tmr_type::c4ios

Definition at line 476 of file at32f413_tmr.h.

◆ c4oben

__IO uint32_t tmr_type::c4oben

Definition at line 632 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c4octrl

__IO uint32_t tmr_type::c4octrl

Definition at line 633 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c4oien

__IO uint32_t tmr_type::c4oien

Definition at line 631 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c4osen

__IO uint32_t tmr_type::c4osen

Definition at line 634 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c4p

__IO uint32_t tmr_type::c4p

Definition at line 674 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c4rf

__IO uint32_t tmr_type::c4rf

Definition at line 548 of file at32f413_tmr.h.

◆ c4swtr

__IO uint32_t tmr_type::c4swtr

Definition at line 565 of file at32f413_tmr.h.

◆ cbctrl

__IO uint32_t tmr_type::cbctrl

Definition at line 464 of file at32f413_tmr.h.

Referenced by tmr_channel_buffer_enable().

◆ ccfs

__IO uint32_t tmr_type::ccfs

Definition at line 466 of file at32f413_tmr.h.

Referenced by tmr_hall_select().

◆ cctrl

uint32_t tmr_type::cctrl

Definition at line 658 of file at32f413_tmr.h.

Referenced by tmr_output_channel_config().

◆

struct { ... } tmr_type::cctrl_bit

Referenced by tmr_channel_enable(), tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ clkdiv

__IO uint32_t tmr_type::clkdiv

Definition at line 450 of file at32f413_tmr.h.

Referenced by tmr_clock_source_div_set().

◆ cm1

__IO uint32_t tmr_type::cm1

Definition at line 578 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::cm1_input_bit

input capture mode

Referenced by tmr_encoder_mode_config(), tmr_input_channel_divider_set(), tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆

struct { ... } tmr_type::cm1_output_bit

channel mode

Referenced by tmr_force_output_set(), tmr_output_channel_buffer_enable(), tmr_output_channel_config(), tmr_output_channel_immediately_set(), tmr_output_channel_mode_select(), and tmr_output_channel_switch_set().

◆ cm2

__IO uint32_t tmr_type::cm2

Definition at line 618 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::cm2_input_bit

input capture mode

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆

struct { ... } tmr_type::cm2_output_bit

channel mode

Referenced by tmr_force_output_set(), tmr_output_channel_buffer_enable(), tmr_output_channel_config(), tmr_output_channel_immediately_set(), tmr_output_channel_mode_select(), and tmr_output_channel_switch_set().

◆ cnt_dir

__IO uint32_t tmr_type::cnt_dir

Definition at line 448 of file at32f413_tmr.h.

Referenced by tmr_cnt_dir_set().

◆ ctrl1

__IO uint32_t tmr_type::ctrl1

Definition at line 441 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::ctrl1_bit

Referenced by tmr_32_bit_function_enable(), tmr_clock_source_div_set(), tmr_cnt_dir_set(), tmr_counter_enable(), tmr_one_cycle_mode_enable(), tmr_overflow_event_disable(), tmr_overflow_request_source_set(), and tmr_period_buffer_enable().

◆ ctrl2

__IO uint32_t tmr_type::ctrl2

Definition at line 461 of file at32f413_tmr.h.

Referenced by tmr_output_channel_config().

◆

struct { ... } tmr_type::ctrl2_bit

Referenced by tmr_channel1_input_select(), tmr_channel_buffer_enable(), tmr_channel_dma_select(), tmr_hall_select(), and tmr_primary_mode_select().

◆ cval

__IO uint32_t tmr_type::cval

Definition at line 684 of file at32f413_tmr.h.

Referenced by tmr_counter_value_get(), and tmr_counter_value_set().

◆

struct { ... } tmr_type::cval_bit

◆ div

__IO uint32_t tmr_type::div

Definition at line 696 of file at32f413_tmr.h.

Referenced by tmr_base_init(), tmr_div_value_get(), and tmr_div_value_set().

◆

struct { ... } tmr_type::div_bit

◆ dmactrl

__IO uint32_t tmr_type::dmactrl

Definition at line 801 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::dmactrl_bit

Referenced by tmr_dma_control_config().

◆ dmadt

__IO uint32_t tmr_type::dmadt

Definition at line 816 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::dmadt_bit

◆ drs

__IO uint32_t tmr_type::drs

Definition at line 467 of file at32f413_tmr.h.

Referenced by tmr_channel_dma_select().

◆ dtb

__IO uint32_t tmr_type::dtb

Definition at line 806 of file at32f413_tmr.h.

Referenced by tmr_dma_control_config().

◆ dtc

__IO uint32_t tmr_type::dtc

Definition at line 785 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ ecmben

__IO uint32_t tmr_type::ecmben

Definition at line 495 of file at32f413_tmr.h.

Referenced by tmr_external_clock_mode2_config().

◆ esdiv

__IO uint32_t tmr_type::esdiv

Definition at line 494 of file at32f413_tmr.h.

Referenced by tmr_external_clock_config().

◆ esf

__IO uint32_t tmr_type::esf

Definition at line 493 of file at32f413_tmr.h.

Referenced by tmr_external_clock_config().

◆ esp

__IO uint32_t tmr_type::esp

Definition at line 496 of file at32f413_tmr.h.

Referenced by tmr_external_clock_config().

◆ fcsodis

__IO uint32_t tmr_type::fcsodis

Definition at line 787 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ fcsoen

__IO uint32_t tmr_type::fcsoen

Definition at line 788 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ hallde

__IO uint32_t tmr_type::hallde

Definition at line 522 of file at32f413_tmr.h.

◆ hallien

__IO uint32_t tmr_type::hallien

Definition at line 514 of file at32f413_tmr.h.

◆ hallif

__IO uint32_t tmr_type::hallif

Definition at line 541 of file at32f413_tmr.h.

◆ hallswtr

__IO uint32_t tmr_type::hallswtr

Definition at line 566 of file at32f413_tmr.h.

◆ iden

__IO uint32_t tmr_type::iden

Definition at line 506 of file at32f413_tmr.h.

Referenced by tmr_dma_request_enable(), and tmr_interrupt_enable().

◆

struct { ... } tmr_type::iden_bit

◆ ists

__IO uint32_t tmr_type::ists

Definition at line 533 of file at32f413_tmr.h.

Referenced by tmr_flag_clear(), and tmr_flag_get().

◆

struct { ... } tmr_type::ists_bit

◆ ocmen

__IO uint32_t tmr_type::ocmen

Definition at line 447 of file at32f413_tmr.h.

Referenced by tmr_one_cycle_mode_enable().

◆ oen

__IO uint32_t tmr_type::oen

Definition at line 792 of file at32f413_tmr.h.

Referenced by tmr_output_enable().

◆ ovfden

__IO uint32_t tmr_type::ovfden

Definition at line 517 of file at32f413_tmr.h.

◆ ovfen

__IO uint32_t tmr_type::ovfen

Definition at line 445 of file at32f413_tmr.h.

Referenced by tmr_overflow_event_disable().

◆ ovfien

__IO uint32_t tmr_type::ovfien

Definition at line 509 of file at32f413_tmr.h.

◆ ovfif

__IO uint32_t tmr_type::ovfif

Definition at line 536 of file at32f413_tmr.h.

◆ ovfs

__IO uint32_t tmr_type::ovfs

Definition at line 446 of file at32f413_tmr.h.

Referenced by tmr_overflow_request_source_set().

◆ ovfswtr

__IO uint32_t tmr_type::ovfswtr

Definition at line 561 of file at32f413_tmr.h.

Referenced by tmr_base_init().

◆ pmen

__IO uint32_t tmr_type::pmen

Definition at line 451 of file at32f413_tmr.h.

Referenced by tmr_32_bit_function_enable().

◆ pr

__IO uint32_t tmr_type::pr

Definition at line 709 of file at32f413_tmr.h.

Referenced by tmr_base_init(), tmr_period_value_get(), and tmr_period_value_set().

◆

struct { ... } tmr_type::pr_bit

◆ prben

__IO uint32_t tmr_type::prben

Definition at line 449 of file at32f413_tmr.h.

Referenced by tmr_period_buffer_enable().

◆ ptos

__IO uint32_t tmr_type::ptos

Definition at line 468 of file at32f413_tmr.h.

Referenced by tmr_primary_mode_select().

◆ reserved

__IO uint32_t tmr_type::reserved

Definition at line 569 of file at32f413_tmr.h.

◆ reserved1

__IO uint32_t tmr_type::reserved1

Definition at line 452 of file at32f413_tmr.h.

◆ reserved2

__IO uint32_t tmr_type::reserved2

Definition at line 477 of file at32f413_tmr.h.

◆ rpr

__IO uint32_t tmr_type::rpr

Definition at line 721 of file at32f413_tmr.h.

Referenced by tmr_repetition_counter_set().

◆

struct { ... } tmr_type::rpr_bit

Referenced by tmr_repetition_counter_set().

◆ smsel

__IO uint32_t tmr_type::smsel

Definition at line 489 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_external_clock_mode1_config(), tmr_internal_clock_set(), and tmr_sub_mode_select().

◆ stctrl

__IO uint32_t tmr_type::stctrl

Definition at line 486 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::stctrl_bit

Referenced by tmr_encoder_mode_config(), tmr_external_clock_config(), tmr_external_clock_mode1_config(), tmr_external_clock_mode2_config(), tmr_internal_clock_set(), tmr_sub_mode_select(), tmr_sub_sync_mode_set(), and tmr_trigger_input_select().

◆ stis

__IO uint32_t tmr_type::stis

Definition at line 491 of file at32f413_tmr.h.

Referenced by tmr_external_clock_mode1_config(), and tmr_trigger_input_select().

◆ sts

__IO uint32_t tmr_type::sts

Definition at line 492 of file at32f413_tmr.h.

Referenced by tmr_sub_sync_mode_set().

◆ swevt

__IO uint32_t tmr_type::swevt

Definition at line 558 of file at32f413_tmr.h.

Referenced by tmr_event_sw_trigger().

◆

struct { ... } tmr_type::swevt_bit

Referenced by tmr_base_init().

◆ tden

__IO uint32_t tmr_type::tden

Definition at line 523 of file at32f413_tmr.h.

◆ tien

__IO uint32_t tmr_type::tien

Definition at line 515 of file at32f413_tmr.h.

◆ tmren

__IO uint32_t tmr_type::tmren

Definition at line 444 of file at32f413_tmr.h.

Referenced by tmr_counter_enable().

◆ trgif

__IO uint32_t tmr_type::trgif

Definition at line 542 of file at32f413_tmr.h.

◆ trgswtr

__IO uint32_t tmr_type::trgswtr

Definition at line 567 of file at32f413_tmr.h.

◆ wpc

__IO uint32_t tmr_type::wpc

Definition at line 786 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: TMR_exported_functions

Functions
TMR_exported_functions
AT32F413_periph_driver » TMR

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time More...

Detailed Description

Function Documentation

◆ tmr_32_bit_function_enable()

void tmr_32_bit_function_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr 32 bit function(plus mode)

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 752 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_base_init()

void tmr_base_init | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr,
 |  | uint32_t | tmr_div
 | ) |  |

init tmr base

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
tmr_div | (timer div value:0x0000~0xFFFF)
Return values
none

Definition at line 178 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_brkdt_config()

void tmr_brkdt_config | ( | tmr_type * | tmr_x,
 |  | tmr_brkdt_config_type * | brkdt_struct
 | ) |  |

config tmr brake mode and dead-time

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 1722 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_brkdt_default_para_init()

void tmr_brkdt_default_para_init ( tmr_brkdt_config_type * tmr_brkdt_struct )

init tmr brkdt default para

Parameters
tmr_brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 156 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel1_input_select()

void tmr_channel1_input_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel1_input_connected_type | ch1_connect
 | ) |  |

select tmr channel1 input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
ch1_connect this parameter can be one of the following values:
  • TMR_CHANEL1_CONNECTED_C1IRAW
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Return values
none

Definition at line 1092 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_buffer_enable()

void tmr_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1228 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_dma_select()

void tmr_channel_dma_select | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_source_type | cc_dma_select
 | ) |  |

select tmr channel dma

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
cc_dma_select this parameter can be one of the following values:
  • TMR_DMA_REQUEST_BY_CHANNEL
  • TMR_DMA_REQUEST_BY_OVERFLOW
Return values
none

Definition at line 1202 of file at32f413_tmr.c.

◆ tmr_channel_enable()

void tmr_channel_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

tmr channel enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_3C
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 882 of file at32f413_tmr.c.

Referenced by main(), and TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_channel_value_get()

uint32_t tmr_channel_value_get | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel
 | ) |  |

get tmr channel value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
Return values
tmr channel value

Definition at line 545 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_channel_value_set()

void tmr_channel_value_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint32_t | tmr_channel_value
 | ) |  |

set tmr channel value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_channel_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 500 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), TMR1_BRK_TMR9_IRQHandler(), tmr1_config(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_clock_source_div_set()

void tmr_clock_source_div_set | ( | tmr_type * | tmr_x,
 |  | tmr_clock_division_type | tmr_clock_div
 | ) |  |

set tmr clock source division

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_clock_div this parameter can be one of the following values:
  • TMR_CLOCK_DIV1
  • TMR_CLOCK_DIV2
  • TMR_CLOCK_DIV4
Return values
none

Definition at line 203 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), and tmr2_config().

◆ tmr_cnt_dir_set()

void tmr_cnt_dir_set | ( | tmr_type * | tmr_x,
 |  | tmr_count_mode_type | tmr_cnt_dir
 | ) |  |

set tmr counter count direction

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_dir this parameter can be one of the following values:
  • TMR_COUNT_UP
  • TMR_COUNT_DOWN
  • TMR_COUNT_TWO_WAY_1
  • TMR_COUNT_TWO_WAY_2
  • TMR_COUNT_TWO_WAY_3
Return values
none

Definition at line 224 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_counter_enable()

void tmr_counter_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr counter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 113 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_counter_value_get()

uint32_t tmr_counter_value_get ( tmr_type * tmr_x )

get tmr counter value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr counter value

Definition at line 268 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_counter_value_set()

void tmr_counter_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_cnt_value
 | ) |  |

set tmr counter value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 254 of file at32f413_tmr.c.

◆ tmr_div_value_get()

uint32_t tmr_div_value_get ( tmr_type * tmr_x )

get tmr div value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr div value

Definition at line 296 of file at32f413_tmr.c.

◆ tmr_div_value_set()

void tmr_div_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_div_value
 | ) |  |

set tmr div value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_div_value | (0x0000~0xFFFF)
Return values
none

Definition at line 282 of file at32f413_tmr.c.

◆ tmr_dma_control_config()

void tmr_dma_control_config | ( | tmr_type * | tmr_x,
 |  | tmr_dma_transfer_length_type | dma_length,
 |  | tmr_dma_address_type | dma_base_address
 | ) |  |

config tmr dma control

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
dma_length this parameter can be one of the following values:
  • TMR_DMA_TRANSFER_1BYTE
  • TMR_DMA_TRANSFER_2BYTES
  • TMR_DMA_TRANSFER_3BYTES ...
  • TMR_DMA_TRANSFER_17BYTES
  • TMR_DMA_TRANSFER_18BYTES
dma_base_address this parameter can be one of the following values:
  • TMR_CTRL1_ADDRESS
  • TMR_CTRL2_ADDRESS
  • TMR_STCTRL_ADDRESS
  • TMR_IDEN_ADDRESS
  • TMR_ISTS_ADDRESS
  • TMR_SWEVT_ADDRESS
  • TMR_CM1_ADDRESS
  • TMR_CM2_ADDRESS
  • TMR_CCTRL_ADDRESS
  • TMR_CVAL_ADDRESS
  • TMR_DIV_ADDRESS
  • TMR_PR_ADDRESS
  • TMR_RPR_ADDRESS
  • TMR_C1DT_ADDRESS
  • TMR_C2DT_ADDRESS
  • TMR_C3DT_ADDRESS
  • TMR_C4DT_ADDRESS
  • TMR_BRK_ADDRESS
  • TMR_DMACTRL_ADDRESS
Return values
none

Definition at line 1706 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_dma_request_enable()

void tmr_dma_request_enable | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_type | dma_request,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr dma request

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
dma_request this parameter can be one of the following values:
  • TMR_OVERFLOW_DMA_REQUEST
  • TMR_C1_DMA_REQUEST
  • TMR_C2_DMA_REQUEST
  • TMR_C3_DMA_REQUEST
  • TMR_C4_DMA_REQUEST
  • TMR_HALL_DMA_REQUEST
  • TMR_TRIGGER_DMA_REQUEST
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1286 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_encoder_mode_config()

void tmr_encoder_mode_config | ( | tmr_type * | tmr_x,
 |  | tmr_encoder_mode_type | encoder_mode,
 |  | tmr_input_polarity_type | ic1_polarity,
 |  | tmr_input_polarity_type | ic2_polarity
 | ) |  |

config tmr encoder mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
encoder_mode this parameter can be one of the following values:
  • TMR_ENCODER_MODE_A
  • TMR_ENCODER_MODE_B
  • TMR_ENCODER_MODE_C
ic1_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
ic2_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
Return values
none

Definition at line 1604 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_event_sw_trigger()

void tmr_event_sw_trigger | ( | tmr_type * | tmr_x,
 |  | tmr_event_trigger_type | tmr_event
 | ) |  |

generate tmr event

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_event this parameter can be one of the following values:
  • TMR_OVERFLOW_SWTRIG
  • TMR_C1_SWTRIG
  • TMR_C2_SWTRIG
  • TMR_C3_SWTRIG
  • TMR_C4_SWTRIG
  • TMR_HALL_SWTRIG
  • TMR_TRIGGER_SWTRIG
  • TMR_BRK_SWTRIG
Return values
none

Definition at line 1412 of file at32f413_tmr.c.

Referenced by SysTick_Handler().

◆ tmr_external_clock_config()

void tmr_external_clock_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1523 of file at32f413_tmr.c.

Referenced by tmr_external_clock_mode1_config(), and tmr_external_clock_mode2_config().

◆ tmr_external_clock_mode1_config()

void tmr_external_clock_mode1_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode1

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1549 of file at32f413_tmr.c.

◆ tmr_external_clock_mode2_config()

void tmr_external_clock_mode2_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1575 of file at32f413_tmr.c.

◆ tmr_flag_clear()

void tmr_flag_clear | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

clear tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be any combination of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
none

Definition at line 1389 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR1_TRG_HALL_TMR11_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_flag_get()

flag_status tmr_flag_get | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

get tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be one of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
state of tmr flag

Definition at line 1351 of file at32f413_tmr.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and TMR5_GLOBAL_IRQHandler().

◆ tmr_force_output_set()

void tmr_force_output_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_force_output_type | force_output
 | ) |  |

set tmr force output

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
force_output this parameter can be one of the following values:
  • TMR_FORCE_OUTPUT_HIGH
  • TMR_FORCE_OUTPUT_LOW
Return values
none

Definition at line 1640 of file at32f413_tmr.c.

◆ tmr_hall_select()

void tmr_hall_select | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr hall

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1215 of file at32f413_tmr.c.

◆ tmr_input_channel_divider_set()

void tmr_input_channel_divider_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

set tmr input channel divider

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1117 of file at32f413_tmr.c.

◆ tmr_input_channel_filter_set()

void tmr_input_channel_filter_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint16_t | filter_value
 | ) |  |

set tmr input channel filter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
filter_value | (0x0~0xf)
Return values
none

Definition at line 938 of file at32f413_tmr.c.

◆ tmr_input_channel_init()

void tmr_input_channel_init | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

init tmr input channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 810 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_input_default_para_init()

void tmr_input_default_para_init ( tmr_input_config_type * tmr_input_struct )

init tmr input default para

Parameters
tmr_input_struct
  • to the structure of tmr_input_config_type
Return values
none

Definition at line 142 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_internal_clock_set()

void tmr_internal_clock_set ( tmr_type * tmr_x )

set tmr select internal clock

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
Return values
none

Definition at line 1437 of file at32f413_tmr.c.

◆ tmr_interrupt_enable()

void tmr_interrupt_enable | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_interrupt,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr interrupt

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_interrupt this parameter can be one of the following values:
  • TMR_OVF_INT
  • TMR_C1_INT
  • TMR_C2_INT
  • TMR_C3_INT
  • TMR_C4_INT
  • TMR_HALL_INT
  • TMR_TRIGGER_INT
  • TMR_BRK_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1317 of file at32f413_tmr.c.

Referenced by main(), tmr1_config(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_one_cycle_mode_enable()

void tmr_one_cycle_mode_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr one cycle mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 738 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_output_channel_buffer_enable()

void tmr_output_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

enable tmr output channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 607 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_output_channel_config()

void tmr_output_channel_config | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_config_type * | tmr_output_struct
 | ) |  |

config tmr output channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 317 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_channel_immediately_set()

void tmr_output_channel_immediately_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel immediately

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 653 of file at32f413_tmr.c.

◆ tmr_output_channel_mode_select()

void tmr_output_channel_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_control_mode_type | oc_mode
 | ) |  |

select tmr output channel mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
oc_mode this parameter can be one of the following values:
  • TMR_OUTPUT_CONTROL_OFF
  • TMR_OUTPUT_CONTROL_HIGH
  • TMR_OUTPUT_CONTROL_LOW
  • TMR_OUTPUT_CONTROL_SWITCH
  • TMR_OUTPUT_CONTROL_FORCE_HIGH
  • TMR_OUTPUT_CONTROL_FORCE_LOW
  • TMR_OUTPUT_CONTROL_PWM_MODE_A
  • TMR_OUTPUT_CONTROL_PWM_MODE_B
Return values
none

Definition at line 423 of file at32f413_tmr.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_output_channel_polarity_set()

void tmr_output_channel_polarity_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_polarity_active_type | oc_polarity
 | ) |  |

set tmr output channel polarity

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3C
oc_polarity this parameter can be one of the following values:
  • TMR_POLARITY_ACTIVE_HIGH
  • TMR_POLARITY_ACTIVE_LOW
Return values
none

Definition at line 1463 of file at32f413_tmr.c.

◆ tmr_output_channel_switch_set()

void tmr_output_channel_switch_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel switch

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 699 of file at32f413_tmr.c.

◆ tmr_output_default_para_init()

void tmr_output_default_para_init ( tmr_output_config_type * tmr_output_struct )

init tmr output default para

Parameters
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 125 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_enable()

void tmr_output_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

tmr output enable(oen),this function is important for advtm output enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1425 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_overflow_event_disable()

void tmr_overflow_event_disable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr overflow event generation

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 789 of file at32f413_tmr.c.

◆ tmr_overflow_request_source_set()

void tmr_overflow_request_source_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr the overflow event sources

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 775 of file at32f413_tmr.c.

◆ tmr_period_buffer_enable()

void tmr_period_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr period buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 586 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_period_value_get()

uint32_t tmr_period_value_get ( tmr_type * tmr_x )

get tmr period value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)

Definition at line 479 of file at32f413_tmr.c.

◆ tmr_period_value_set()

void tmr_period_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr_value
 | ) |  |

set tmr period value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr_value | timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 463 of file at32f413_tmr.c.

◆ tmr_primary_mode_select()

void tmr_primary_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_primary_select_type | primary_mode
 | ) |  |

select tmr primary mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
primary_mode this parameter can be one of the following values:
  • TMR_PRIMARY_SEL_RESET
  • TMR_PRIMARY_SEL_ENABLE
  • TMR_PRIMARY_SEL_OVERFLOW
  • TMR_PRIMARY_SEL_COMPARE
  • TMR_PRIMARY_SEL_C1ORAW
  • TMR_PRIMARY_SEL_C2ORAW
  • TMR_PRIMARY_SEL_C3ORAW
  • TMR_PRIMARY_SEL_C4ORAW
Return values
none

Definition at line 1164 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_pwm_input_config()

void tmr_pwm_input_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

config tmr pwm input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 984 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_repetition_counter_set()

void tmr_repetition_counter_set | ( | tmr_type * | tmr_x,
 |  | uint8_t | tmr_rpr_value
 | ) |  |

set the repetition counter register(rpr) value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
tmr_rpr_value | (0x00~0xFF)
Return values
none

Definition at line 238 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_reset()

void tmr_reset ( tmr_type * tmr_x )

tmr reset by crm reset register

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
none

Definition at line 50 of file at32f413_tmr.c.

◆ tmr_sub_mode_select()

void tmr_sub_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_sub_mode_select_type | sub_mode
 | ) |  |

select tmr subordinate mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
sub_mode this parameter can be one of the following values:
  • TMR_SUB_MODE_DIABLE
  • TMR_SUB_ENCODER_MODE_A
  • TMR_SUB_ENCODER_MODE_B
  • TMR_SUB_ENCODER_MODE_C
  • TMR_SUB_RESET_MODE
  • TMR_SUB_HANG_MODE
  • TMR_SUB_TRIGGER_MODE
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A
Return values
none

Definition at line 1186 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_sub_sync_mode_set()

void tmr_sub_sync_mode_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr subordinate synchronization mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1263 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_trigger_input_select()

void tmr_trigger_input_select | ( | tmr_type * | tmr_x,
 |  | sub_tmr_input_sel_type | trigger_select
 | ) |  |

select tmr sub-trigger

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
trigger_select this parameter can be one of the following values:
  • TMR_SUB_INPUT_SEL_IS0
  • TMR_SUB_INPUT_SEL_IS1
  • TMR_SUB_INPUT_SEL_IS2
  • TMR_SUB_INPUT_SEL_IS3
  • TMR_SUB_INPUT_SEL_C1INC
  • TMR_SUB_INPUT_SEL_C1DF1
  • TMR_SUB_INPUT_SEL_C2DF2
  • TMR_SUB_INPUT_SEL_EXTIN
Return values
none

Definition at line 1250 of file at32f413_tmr.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_private_functions

Functions
TMR_private_functions
AT32F413_periph_driver » TMR

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time More...

Detailed Description

Function Documentation

◆ tmr_32_bit_function_enable()

void tmr_32_bit_function_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr 32 bit function(plus mode)

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 752 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_base_init()

void tmr_base_init | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr,
 |  | uint32_t | tmr_div
 | ) |  |

init tmr base

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
tmr_div | (timer div value:0x0000~0xFFFF)
Return values
none

Definition at line 178 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_brkdt_config()

void tmr_brkdt_config | ( | tmr_type * | tmr_x,
 |  | tmr_brkdt_config_type * | brkdt_struct
 | ) |  |

config tmr brake mode and dead-time

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 1722 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_brkdt_default_para_init()

void tmr_brkdt_default_para_init ( tmr_brkdt_config_type * tmr_brkdt_struct )

init tmr brkdt default para

Parameters
tmr_brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 156 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel1_input_select()

void tmr_channel1_input_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel1_input_connected_type | ch1_connect
 | ) |  |

select tmr channel1 input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
ch1_connect this parameter can be one of the following values:
  • TMR_CHANEL1_CONNECTED_C1IRAW
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Return values
none

Definition at line 1092 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_buffer_enable()

void tmr_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1228 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_dma_select()

void tmr_channel_dma_select | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_source_type | cc_dma_select
 | ) |  |

select tmr channel dma

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
cc_dma_select this parameter can be one of the following values:
  • TMR_DMA_REQUEST_BY_CHANNEL
  • TMR_DMA_REQUEST_BY_OVERFLOW
Return values
none

Definition at line 1202 of file at32f413_tmr.c.

◆ tmr_channel_enable()

void tmr_channel_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

tmr channel enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_3C
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 882 of file at32f413_tmr.c.

Referenced by main(), and TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_channel_value_get()

uint32_t tmr_channel_value_get | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel
 | ) |  |

get tmr channel value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
Return values
tmr channel value

Definition at line 545 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_channel_value_set()

void tmr_channel_value_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint32_t | tmr_channel_value
 | ) |  |

set tmr channel value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_channel_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 500 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), TMR1_BRK_TMR9_IRQHandler(), tmr1_config(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_clock_source_div_set()

void tmr_clock_source_div_set | ( | tmr_type * | tmr_x,
 |  | tmr_clock_division_type | tmr_clock_div
 | ) |  |

set tmr clock source division

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_clock_div this parameter can be one of the following values:
  • TMR_CLOCK_DIV1
  • TMR_CLOCK_DIV2
  • TMR_CLOCK_DIV4
Return values
none

Definition at line 203 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), and tmr2_config().

◆ tmr_cnt_dir_set()

void tmr_cnt_dir_set | ( | tmr_type * | tmr_x,
 |  | tmr_count_mode_type | tmr_cnt_dir
 | ) |  |

set tmr counter count direction

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_dir this parameter can be one of the following values:
  • TMR_COUNT_UP
  • TMR_COUNT_DOWN
  • TMR_COUNT_TWO_WAY_1
  • TMR_COUNT_TWO_WAY_2
  • TMR_COUNT_TWO_WAY_3
Return values
none

Definition at line 224 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_counter_enable()

void tmr_counter_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr counter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 113 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_counter_value_get()

uint32_t tmr_counter_value_get ( tmr_type * tmr_x )

get tmr counter value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr counter value

Definition at line 268 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_counter_value_set()

void tmr_counter_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_cnt_value
 | ) |  |

set tmr counter value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 254 of file at32f413_tmr.c.

◆ tmr_div_value_get()

uint32_t tmr_div_value_get ( tmr_type * tmr_x )

get tmr div value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr div value

Definition at line 296 of file at32f413_tmr.c.

◆ tmr_div_value_set()

void tmr_div_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_div_value
 | ) |  |

set tmr div value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_div_value | (0x0000~0xFFFF)
Return values
none

Definition at line 282 of file at32f413_tmr.c.

◆ tmr_dma_control_config()

void tmr_dma_control_config | ( | tmr_type * | tmr_x,
 |  | tmr_dma_transfer_length_type | dma_length,
 |  | tmr_dma_address_type | dma_base_address
 | ) |  |

config tmr dma control

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
dma_length this parameter can be one of the following values:
  • TMR_DMA_TRANSFER_1BYTE
  • TMR_DMA_TRANSFER_2BYTES
  • TMR_DMA_TRANSFER_3BYTES ...
  • TMR_DMA_TRANSFER_17BYTES
  • TMR_DMA_TRANSFER_18BYTES
dma_base_address this parameter can be one of the following values:
  • TMR_CTRL1_ADDRESS
  • TMR_CTRL2_ADDRESS
  • TMR_STCTRL_ADDRESS
  • TMR_IDEN_ADDRESS
  • TMR_ISTS_ADDRESS
  • TMR_SWEVT_ADDRESS
  • TMR_CM1_ADDRESS
  • TMR_CM2_ADDRESS
  • TMR_CCTRL_ADDRESS
  • TMR_CVAL_ADDRESS
  • TMR_DIV_ADDRESS
  • TMR_PR_ADDRESS
  • TMR_RPR_ADDRESS
  • TMR_C1DT_ADDRESS
  • TMR_C2DT_ADDRESS
  • TMR_C3DT_ADDRESS
  • TMR_C4DT_ADDRESS
  • TMR_BRK_ADDRESS
  • TMR_DMACTRL_ADDRESS
Return values
none

Definition at line 1706 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_dma_request_enable()

void tmr_dma_request_enable | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_type | dma_request,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr dma request

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
dma_request this parameter can be one of the following values:
  • TMR_OVERFLOW_DMA_REQUEST
  • TMR_C1_DMA_REQUEST
  • TMR_C2_DMA_REQUEST
  • TMR_C3_DMA_REQUEST
  • TMR_C4_DMA_REQUEST
  • TMR_HALL_DMA_REQUEST
  • TMR_TRIGGER_DMA_REQUEST
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1286 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_encoder_mode_config()

void tmr_encoder_mode_config | ( | tmr_type * | tmr_x,
 |  | tmr_encoder_mode_type | encoder_mode,
 |  | tmr_input_polarity_type | ic1_polarity,
 |  | tmr_input_polarity_type | ic2_polarity
 | ) |  |

config tmr encoder mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
encoder_mode this parameter can be one of the following values:
  • TMR_ENCODER_MODE_A
  • TMR_ENCODER_MODE_B
  • TMR_ENCODER_MODE_C
ic1_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
ic2_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
Return values
none

Definition at line 1604 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_event_sw_trigger()

void tmr_event_sw_trigger | ( | tmr_type * | tmr_x,
 |  | tmr_event_trigger_type | tmr_event
 | ) |  |

generate tmr event

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_event this parameter can be one of the following values:
  • TMR_OVERFLOW_SWTRIG
  • TMR_C1_SWTRIG
  • TMR_C2_SWTRIG
  • TMR_C3_SWTRIG
  • TMR_C4_SWTRIG
  • TMR_HALL_SWTRIG
  • TMR_TRIGGER_SWTRIG
  • TMR_BRK_SWTRIG
Return values
none

Definition at line 1412 of file at32f413_tmr.c.

Referenced by SysTick_Handler().

◆ tmr_external_clock_config()

void tmr_external_clock_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1523 of file at32f413_tmr.c.

Referenced by tmr_external_clock_mode1_config(), and tmr_external_clock_mode2_config().

◆ tmr_external_clock_mode1_config()

void tmr_external_clock_mode1_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode1

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1549 of file at32f413_tmr.c.

◆ tmr_external_clock_mode2_config()

void tmr_external_clock_mode2_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1575 of file at32f413_tmr.c.

◆ tmr_flag_clear()

void tmr_flag_clear | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

clear tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be any combination of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
none

Definition at line 1389 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR1_TRG_HALL_TMR11_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_flag_get()

flag_status tmr_flag_get | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

get tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be one of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
state of tmr flag

Definition at line 1351 of file at32f413_tmr.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and TMR5_GLOBAL_IRQHandler().

◆ tmr_force_output_set()

void tmr_force_output_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_force_output_type | force_output
 | ) |  |

set tmr force output

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
force_output this parameter can be one of the following values:
  • TMR_FORCE_OUTPUT_HIGH
  • TMR_FORCE_OUTPUT_LOW
Return values
none

Definition at line 1640 of file at32f413_tmr.c.

◆ tmr_hall_select()

void tmr_hall_select | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr hall

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1215 of file at32f413_tmr.c.

◆ tmr_input_channel_divider_set()

void tmr_input_channel_divider_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

set tmr input channel divider

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1117 of file at32f413_tmr.c.

◆ tmr_input_channel_filter_set()

void tmr_input_channel_filter_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint16_t | filter_value
 | ) |  |

set tmr input channel filter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
filter_value | (0x0~0xf)
Return values
none

Definition at line 938 of file at32f413_tmr.c.

◆ tmr_input_channel_init()

void tmr_input_channel_init | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

init tmr input channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 810 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_input_default_para_init()

void tmr_input_default_para_init ( tmr_input_config_type * tmr_input_struct )

init tmr input default para

Parameters
tmr_input_struct
  • to the structure of tmr_input_config_type
Return values
none

Definition at line 142 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_internal_clock_set()

void tmr_internal_clock_set ( tmr_type * tmr_x )

set tmr select internal clock

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
Return values
none

Definition at line 1437 of file at32f413_tmr.c.

◆ tmr_interrupt_enable()

void tmr_interrupt_enable | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_interrupt,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr interrupt

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_interrupt this parameter can be one of the following values:
  • TMR_OVF_INT
  • TMR_C1_INT
  • TMR_C2_INT
  • TMR_C3_INT
  • TMR_C4_INT
  • TMR_HALL_INT
  • TMR_TRIGGER_INT
  • TMR_BRK_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1317 of file at32f413_tmr.c.

Referenced by main(), tmr1_config(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_one_cycle_mode_enable()

void tmr_one_cycle_mode_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr one cycle mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 738 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_output_channel_buffer_enable()

void tmr_output_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

enable tmr output channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 607 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_output_channel_config()

void tmr_output_channel_config | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_config_type * | tmr_output_struct
 | ) |  |

config tmr output channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 317 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_channel_immediately_set()

void tmr_output_channel_immediately_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel immediately

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 653 of file at32f413_tmr.c.

◆ tmr_output_channel_mode_select()

void tmr_output_channel_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_control_mode_type | oc_mode
 | ) |  |

select tmr output channel mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
oc_mode this parameter can be one of the following values:
  • TMR_OUTPUT_CONTROL_OFF
  • TMR_OUTPUT_CONTROL_HIGH
  • TMR_OUTPUT_CONTROL_LOW
  • TMR_OUTPUT_CONTROL_SWITCH
  • TMR_OUTPUT_CONTROL_FORCE_HIGH
  • TMR_OUTPUT_CONTROL_FORCE_LOW
  • TMR_OUTPUT_CONTROL_PWM_MODE_A
  • TMR_OUTPUT_CONTROL_PWM_MODE_B
Return values
none

Definition at line 423 of file at32f413_tmr.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_output_channel_polarity_set()

void tmr_output_channel_polarity_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_polarity_active_type | oc_polarity
 | ) |  |

set tmr output channel polarity

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3C
oc_polarity this parameter can be one of the following values:
  • TMR_POLARITY_ACTIVE_HIGH
  • TMR_POLARITY_ACTIVE_LOW
Return values
none

Definition at line 1463 of file at32f413_tmr.c.

◆ tmr_output_channel_switch_set()

void tmr_output_channel_switch_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel switch

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 699 of file at32f413_tmr.c.

◆ tmr_output_default_para_init()

void tmr_output_default_para_init ( tmr_output_config_type * tmr_output_struct )

init tmr output default para

Parameters
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 125 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_enable()

void tmr_output_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

tmr output enable(oen),this function is important for advtm output enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1425 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_overflow_event_disable()

void tmr_overflow_event_disable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr overflow event generation

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 789 of file at32f413_tmr.c.

◆ tmr_overflow_request_source_set()

void tmr_overflow_request_source_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr the overflow event sources

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 775 of file at32f413_tmr.c.

◆ tmr_period_buffer_enable()

void tmr_period_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr period buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 586 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_period_value_get()

uint32_t tmr_period_value_get ( tmr_type * tmr_x )

get tmr period value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)

Definition at line 479 of file at32f413_tmr.c.

◆ tmr_period_value_set()

void tmr_period_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr_value
 | ) |  |

set tmr period value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr_value | timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 463 of file at32f413_tmr.c.

◆ tmr_primary_mode_select()

void tmr_primary_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_primary_select_type | primary_mode
 | ) |  |

select tmr primary mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
primary_mode this parameter can be one of the following values:
  • TMR_PRIMARY_SEL_RESET
  • TMR_PRIMARY_SEL_ENABLE
  • TMR_PRIMARY_SEL_OVERFLOW
  • TMR_PRIMARY_SEL_COMPARE
  • TMR_PRIMARY_SEL_C1ORAW
  • TMR_PRIMARY_SEL_C2ORAW
  • TMR_PRIMARY_SEL_C3ORAW
  • TMR_PRIMARY_SEL_C4ORAW
Return values
none

Definition at line 1164 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_pwm_input_config()

void tmr_pwm_input_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

config tmr pwm input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 984 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_repetition_counter_set()

void tmr_repetition_counter_set | ( | tmr_type * | tmr_x,
 |  | uint8_t | tmr_rpr_value
 | ) |  |

set the repetition counter register(rpr) value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
tmr_rpr_value | (0x00~0xFF)
Return values
none

Definition at line 238 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_reset()

void tmr_reset ( tmr_type * tmr_x )

tmr reset by crm reset register

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
none

Definition at line 50 of file at32f413_tmr.c.

◆ tmr_sub_mode_select()

void tmr_sub_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_sub_mode_select_type | sub_mode
 | ) |  |

select tmr subordinate mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
sub_mode this parameter can be one of the following values:
  • TMR_SUB_MODE_DIABLE
  • TMR_SUB_ENCODER_MODE_A
  • TMR_SUB_ENCODER_MODE_B
  • TMR_SUB_ENCODER_MODE_C
  • TMR_SUB_RESET_MODE
  • TMR_SUB_HANG_MODE
  • TMR_SUB_TRIGGER_MODE
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A
Return values
none

Definition at line 1186 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_sub_sync_mode_set()

void tmr_sub_sync_mode_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr subordinate synchronization mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1263 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_trigger_input_select()

void tmr_trigger_input_select | ( | tmr_type * | tmr_x,
 |  | sub_tmr_input_sel_type | trigger_select
 | ) |  |

select tmr sub-trigger

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
trigger_select this parameter can be one of the following values:
  • TMR_SUB_INPUT_SEL_IS0
  • TMR_SUB_INPUT_SEL_IS1
  • TMR_SUB_INPUT_SEL_IS2
  • TMR_SUB_INPUT_SEL_IS3
  • TMR_SUB_INPUT_SEL_C1INC
  • TMR_SUB_INPUT_SEL_C1DF1
  • TMR_SUB_INPUT_SEL_C2DF2
  • TMR_SUB_INPUT_SEL_EXTIN
Return values
none

Definition at line 1250 of file at32f413_tmr.c.

Referenced by main().


AT32F413 Firmwary Library: USART

Modules | Macros
USART
AT32F413_periph_driver

USART driver modules. More...

Modules

USART_flags_definition
usart flag
USART_interrupts_definition
usart interrupt
USART_exported_types
USART_exported_functions
USART_private_functions

Macros

#define | USART1 ((usart_type *) USART1_BASE)
#define | USART2 ((usart_type *) USART2_BASE)

Detailed Description

USART driver modules.

Macro Definition Documentation

◆ USART1

#define USART1 ((usart_type *) USART1_BASE)

Definition at line 317 of file at32f413_usart.h.

◆ USART2

#define USART2 ((usart_type *) USART2_BASE)

Definition at line 318 of file at32f413_usart.h.


AT32F413 Firmwary Library: USART_flags_definition

Macros
USART_flags_definition
AT32F413_periph_driver » USART

usart flag More...

Macros

#define | USART_PERR_FLAG ((uint32_t)0x00000001)
#define | USART_FERR_FLAG ((uint32_t)0x00000002)
#define | USART_NERR_FLAG ((uint32_t)0x00000004)
#define | USART_ROERR_FLAG ((uint32_t)0x00000008)
#define | USART_IDLEF_FLAG ((uint32_t)0x00000010)
#define | USART_RDBF_FLAG ((uint32_t)0x00000020)
#define | USART_TDC_FLAG ((uint32_t)0x00000040)
#define | USART_TDBE_FLAG ((uint32_t)0x00000080)
#define | USART_BFF_FLAG ((uint32_t)0x00000100)
#define | USART_CTSCF_FLAG ((uint32_t)0x00000200)

Detailed Description

usart flag

Macro Definition Documentation

◆ USART_BFF_FLAG

#define USART_BFF_FLAG ((uint32_t)0x00000100)

usart break frame flag

Definition at line 58 of file at32f413_usart.h.

◆ USART_CTSCF_FLAG

#define USART_CTSCF_FLAG ((uint32_t)0x00000200)

usart cts change flag

Definition at line 59 of file at32f413_usart.h.

◆ USART_FERR_FLAG

#define USART_FERR_FLAG ((uint32_t)0x00000002)

usart framing error flag

Definition at line 51 of file at32f413_usart.h.

◆ USART_IDLEF_FLAG

#define USART_IDLEF_FLAG ((uint32_t)0x00000010)

usart idle flag

Definition at line 54 of file at32f413_usart.h.

◆ USART_NERR_FLAG

#define USART_NERR_FLAG ((uint32_t)0x00000004)

usart noise error flag

Definition at line 52 of file at32f413_usart.h.

◆ USART_PERR_FLAG

#define USART_PERR_FLAG ((uint32_t)0x00000001)

usart parity error flag

Definition at line 50 of file at32f413_usart.h.

◆ USART_RDBF_FLAG

#define USART_RDBF_FLAG ((uint32_t)0x00000020)

usart receive data buffer full flag

Definition at line 55 of file at32f413_usart.h.

◆ USART_ROERR_FLAG

#define USART_ROERR_FLAG ((uint32_t)0x00000008)

usart receiver overflow error flag

Definition at line 53 of file at32f413_usart.h.

◆ USART_TDBE_FLAG

#define USART_TDBE_FLAG ((uint32_t)0x00000080)

usart transmit data buffer empty flag

Definition at line 57 of file at32f413_usart.h.

◆ USART_TDC_FLAG

#define USART_TDC_FLAG ((uint32_t)0x00000040)

usart transmit data complete flag

Definition at line 56 of file at32f413_usart.h.


AT32F413 Firmwary Library: USART_interrupts_definition

Macros
USART_interrupts_definition
AT32F413_periph_driver » USART

usart interrupt More...

Macros

#define | USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
#define | USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
#define | USART_TDC_INT MAKE_VALUE(0x0C,0x06)
#define | USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
#define | USART_PERR_INT MAKE_VALUE(0x0C,0x08)
#define | USART_BF_INT MAKE_VALUE(0x10,0x06)
#define | USART_ERR_INT MAKE_VALUE(0x14,0x00)
#define | USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)

Detailed Description

usart interrupt

Macro Definition Documentation

◆ USART_BF_INT

#define USART_BF_INT MAKE_VALUE(0x10,0x06)

usart break frame interrupt

Definition at line 75 of file at32f413_usart.h.

◆ USART_CTSCF_INT

#define USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)

usart cts change interrupt

Definition at line 77 of file at32f413_usart.h.

◆ USART_ERR_INT

#define USART_ERR_INT MAKE_VALUE(0x14,0x00)

usart error interrupt

Definition at line 76 of file at32f413_usart.h.

◆ USART_IDLE_INT

#define USART_IDLE_INT MAKE_VALUE(0x0C,0x04)

usart idle interrupt

Definition at line 70 of file at32f413_usart.h.

◆ USART_PERR_INT

#define USART_PERR_INT MAKE_VALUE(0x0C,0x08)

usart parity error interrupt

Definition at line 74 of file at32f413_usart.h.

◆ USART_RDBF_INT

#define USART_RDBF_INT MAKE_VALUE(0x0C,0x05)

usart receive data buffer full interrupt

Definition at line 71 of file at32f413_usart.h.

◆ USART_TDBE_INT

#define USART_TDBE_INT MAKE_VALUE(0x0C,0x07)

usart transmit data buffer empty interrupt

Definition at line 73 of file at32f413_usart.h.

◆ USART_TDC_INT

#define USART_TDC_INT MAKE_VALUE(0x0C,0x06)

usart transmit data complete interrupt

Definition at line 72 of file at32f413_usart.h.


AT32F413 Firmwary Library: USART_exported_types

Data Structures | Enumerations
USART_exported_types
AT32F413_periph_driver » USART

Data Structures

struct usart_type
type define usart register all More...

Enumerations

enum | usart_parity_selection_type { USART_PARITY_NONE = 0x00 , USART_PARITY_EVEN = 0x01 , USART_PARITY_ODD = 0x02 }
usart parity selection type More...
enum | usart_wakeup_mode_type { USART_WAKEUP_BY_IDLE_FRAME = 0x00 , USART_WAKEUP_BY_MATCHING_ID = 0x01 }
usart wakeup mode type More...
enum | usart_data_bit_num_type { USART_DATA_8BITS = 0x00 , USART_DATA_9BITS = 0x01 }
usart data bit num type More...
enum | usart_break_bit_num_type { USART_BREAK_10BITS = 0x00 , USART_BREAK_11BITS = 0x01 }
usart break frame bit num type More...
enum | usart_clock_phase_type { USART_CLOCK_PHASE_1EDGE = 0x00 , USART_CLOCK_PHASE_2EDGE = 0x01 }
usart phase of the clock type More...
enum | usart_clock_polarity_type { USART_CLOCK_POLARITY_LOW = 0x00 , USART_CLOCK_POLARITY_HIGH = 0x01 }
usart polarity of the clock type More...
enum | usart_lbcp_type { USART_CLOCK_LAST_BIT_NONE = 0x00 , USART_CLOCK_LAST_BIT_OUTPUT = 0x01 }
usart last bit clock pulse type More...
enum | usart_stop_bit_num_type { USART_STOP_1_BIT = 0x00 , USART_STOP_0_5_BIT = 0x01 , USART_STOP_2_BIT = 0x02 , USART_STOP_1_5_BIT = 0x03 }
usart stop bit num type More...
enum | usart_hardware_flow_control_type { USART_HARDWARE_FLOW_NONE = 0x00 , USART_HARDWARE_FLOW_RTS = 0x01 , USART_HARDWARE_FLOW_CTS = 0x02 , USART_HARDWARE_FLOW_RTS_CTS = 0x03 }
usart hardware flow control type More...

Detailed Description

Enumeration Type Documentation

◆ usart_break_bit_num_type

enum usart_break_bit_num_type

usart break frame bit num type

Enumerator
USART_BREAK_10BITS | usart lin mode berak frame detection 10 bits
USART_BREAK_11BITS | usart lin mode berak frame detection 11 bits

Definition at line 118 of file at32f413_usart.h.

◆ usart_clock_phase_type

enum usart_clock_phase_type

usart phase of the clock type

Enumerator
USART_CLOCK_PHASE_1EDGE | usart data capture is done on the clock leading edge
USART_CLOCK_PHASE_2EDGE | usart data capture is done on the clock trailing edge

Definition at line 127 of file at32f413_usart.h.

◆ usart_clock_polarity_type

enum usart_clock_polarity_type

usart polarity of the clock type

Enumerator
USART_CLOCK_POLARITY_LOW | usart clock stay low level outside transmission window
USART_CLOCK_POLARITY_HIGH | usart clock stay high level outside transmission window

Definition at line 136 of file at32f413_usart.h.

◆ usart_data_bit_num_type

enum usart_data_bit_num_type

usart data bit num type

Enumerator
USART_DATA_8BITS | usart data size is 8 bits
USART_DATA_9BITS | usart data size is 9 bits

Definition at line 109 of file at32f413_usart.h.

◆ usart_hardware_flow_control_type

enum usart_hardware_flow_control_type

usart hardware flow control type

Enumerator
USART_HARDWARE_FLOW_NONE | usart without hardware flow
USART_HARDWARE_FLOW_RTS | usart hardware flow only rts
USART_HARDWARE_FLOW_CTS | usart hardware flow only cts
USART_HARDWARE_FLOW_RTS_CTS | usart hardware flow both rts and cts

Definition at line 165 of file at32f413_usart.h.

◆ usart_lbcp_type

enum usart_lbcp_type

usart last bit clock pulse type

Enumerator
USART_CLOCK_LAST_BIT_NONE | usart clock pulse of the last data bit is not outputted
USART_CLOCK_LAST_BIT_OUTPUT | usart clock pulse of the last data bit is outputted

Definition at line 145 of file at32f413_usart.h.

◆ usart_parity_selection_type

enum usart_parity_selection_type

usart parity selection type

Enumerator
USART_PARITY_NONE | usart no parity
USART_PARITY_EVEN | usart even parity
USART_PARITY_ODD | usart odd parity

Definition at line 90 of file at32f413_usart.h.

◆ usart_stop_bit_num_type

enum usart_stop_bit_num_type

usart stop bit num type

Enumerator
USART_STOP_1_BIT | usart stop bits num is 1
USART_STOP_0_5_BIT | usart stop bits num is 0.5
USART_STOP_2_BIT | usart stop bits num is 2
USART_STOP_1_5_BIT | usart stop bits num is 1.5

Definition at line 154 of file at32f413_usart.h.

◆ usart_wakeup_mode_type

enum usart_wakeup_mode_type

usart wakeup mode type

Enumerator
USART_WAKEUP_BY_IDLE_FRAME | usart wakeup by idle frame
USART_WAKEUP_BY_MATCHING_ID | usart wakeup by matching id

Definition at line 100 of file at32f413_usart.h.


AT32F413 Firmwary Library: usart_type Struct Reference

Data Fields
usart_type Struct Reference
AT32F413_periph_driver » USART » USART_exported_types

type define usart register all More...

#include <at32f413_usart.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t perr: 1
__IO uint32_t ferr: 1
__IO uint32_t nerr: 1
__IO uint32_t roerr: 1
__IO uint32_t idlef: 1
__IO uint32_t rdbf: 1
__IO uint32_t tdc: 1
__IO uint32_t tdbe: 1
__IO uint32_t bff: 1
__IO uint32_t ctscf: 1
__IO uint32_t reserved1: 22
} sts_bit
};
usart sts register, offset:0x00 More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 9
__IO uint32_t reserved1: 23
} dt_bit
};
usart dt register, offset:0x04 More...
union {
__IO uint32_t baudr
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} baudr_bit
};
usart baudr register, offset:0x08 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t sbf: 1
__IO uint32_t rm: 1
__IO uint32_t ren: 1
__IO uint32_t ten: 1
__IO uint32_t idleien: 1
__IO uint32_t rdbfien: 1
__IO uint32_t tdcien: 1
__IO uint32_t tdbeien: 1
__IO uint32_t perrien: 1
__IO uint32_t psel: 1
__IO uint32_t pen: 1
__IO uint32_t wum: 1
__IO uint32_t dbn: 1
__IO uint32_t uen: 1
__IO uint32_t reserved1: 18
} ctrl1_bit
};
usart ctrl1 register, offset:0x0C More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t id: 4
__IO uint32_t reserved1: 1
__IO uint32_t bfbn: 1
__IO uint32_t bfien: 1
__IO uint32_t reserved2: 1
__IO uint32_t lbcp: 1
__IO uint32_t clkpha: 1
__IO uint32_t clkpol: 1
__IO uint32_t clken: 1
__IO uint32_t stopbn: 2
__IO uint32_t linen: 1
__IO uint32_t reserved3: 17
} ctrl2_bit
};
usart ctrl2 register, offset:0x10 More...
union {
__IO uint32_t ctrl3
struct {
__IO uint32_t errien: 1
__IO uint32_t irdaen: 1
__IO uint32_t irdalp: 1
__IO uint32_t slben: 1
__IO uint32_t scnacken: 1
__IO uint32_t scmen: 1
__IO uint32_t dmaren: 1
__IO uint32_t dmaten: 1
__IO uint32_t rtsen: 1
__IO uint32_t ctsen: 1
__IO uint32_t ctscfien: 1
__IO uint32_t reserved1: 21
} ctrl3_bit
};
usart ctrl3 register, offset:0x14 More...
union {
__IO uint32_t gdiv
struct {
__IO uint32_t isdiv: 8
__IO uint32_t scgt: 8
__IO uint32_t reserved1: 16
} gdiv_bit
};
usart gdiv register, offset:0x18 More...

Detailed Description

type define usart register all

Definition at line 176 of file at32f413_usart.h.

Field Documentation

◆

union { ... } usart_type::@714

usart sts register, offset:0x00

◆

union { ... } usart_type::@716

usart dt register, offset:0x04

◆

union { ... } usart_type::@718

usart baudr register, offset:0x08

◆

union { ... } usart_type::@720

usart ctrl1 register, offset:0x0C

◆

union { ... } usart_type::@722

usart ctrl2 register, offset:0x10

◆

union { ... } usart_type::@724

usart ctrl3 register, offset:0x14

◆

union { ... } usart_type::@726

usart gdiv register, offset:0x18

◆ baudr

__IO uint32_t usart_type::baudr

Definition at line 218 of file at32f413_usart.h.

◆

struct { ... } usart_type::baudr_bit

Referenced by usart_init().

◆ bfbn

__IO uint32_t usart_type::bfbn

Definition at line 262 of file at32f413_usart.h.

Referenced by usart_break_bit_num_set().

◆ bff

__IO uint32_t usart_type::bff

Definition at line 194 of file at32f413_usart.h.

◆ bfien

__IO uint32_t usart_type::bfien

Definition at line 263 of file at32f413_usart.h.

◆ clken

__IO uint32_t usart_type::clken

Definition at line 268 of file at32f413_usart.h.

Referenced by usart_clock_enable().

◆ clkpha

__IO uint32_t usart_type::clkpha

Definition at line 266 of file at32f413_usart.h.

Referenced by usart_clock_config().

◆ clkpol

__IO uint32_t usart_type::clkpol

Definition at line 267 of file at32f413_usart.h.

Referenced by usart_clock_config().

◆ ctrl1

__IO uint32_t usart_type::ctrl1

Definition at line 231 of file at32f413_usart.h.

◆

struct { ... } usart_type::ctrl1_bit

Referenced by usart_break_send(), usart_enable(), usart_init(), usart_parity_selection_config(), usart_receiver_enable(), usart_receiver_mute_enable(), usart_transmitter_enable(), and usart_wakeup_mode_set().

◆ ctrl2

__IO uint32_t usart_type::ctrl2

Definition at line 257 of file at32f413_usart.h.

◆

struct { ... } usart_type::ctrl2_bit

Referenced by usart_break_bit_num_set(), usart_clock_config(), usart_clock_enable(), usart_init(), usart_lin_mode_enable(), and usart_wakeup_id_set().

◆ ctrl3

__IO uint32_t usart_type::ctrl3

Definition at line 280 of file at32f413_usart.h.

◆

struct { ... } usart_type::ctrl3_bit

Referenced by usart_dma_receiver_enable(), usart_dma_transmitter_enable(), usart_hardware_flow_control_set(), usart_irda_low_power_enable(), usart_irda_mode_enable(), usart_single_line_halfduplex_select(), usart_smartcard_mode_enable(), and usart_smartcard_nack_set().

◆ ctscf

__IO uint32_t usart_type::ctscf

Definition at line 195 of file at32f413_usart.h.

◆ ctscfien

__IO uint32_t usart_type::ctscfien

Definition at line 293 of file at32f413_usart.h.

◆ ctsen

__IO uint32_t usart_type::ctsen

Definition at line 292 of file at32f413_usart.h.

Referenced by usart_hardware_flow_control_set().

◆ dbn

__IO uint32_t usart_type::dbn

Definition at line 246 of file at32f413_usart.h.

Referenced by usart_init().

◆ div

__IO uint32_t usart_type::div

Definition at line 221 of file at32f413_usart.h.

Referenced by usart_init().

◆ dmaren

__IO uint32_t usart_type::dmaren

Definition at line 289 of file at32f413_usart.h.

Referenced by usart_dma_receiver_enable().

◆ dmaten

__IO uint32_t usart_type::dmaten

Definition at line 290 of file at32f413_usart.h.

Referenced by usart_dma_transmitter_enable().

◆ dt

__IO uint32_t usart_type::dt

Definition at line 205 of file at32f413_usart.h.

Referenced by usart_data_receive(), usart_data_transmit(), and usart_flag_clear().

◆

struct { ... } usart_type::dt_bit

◆ errien

__IO uint32_t usart_type::errien

Definition at line 283 of file at32f413_usart.h.

◆ ferr

__IO uint32_t usart_type::ferr

Definition at line 187 of file at32f413_usart.h.

◆ gdiv

__IO uint32_t usart_type::gdiv

Definition at line 303 of file at32f413_usart.h.

◆

struct { ... } usart_type::gdiv_bit

Referenced by usart_irda_smartcard_division_set(), and usart_smartcard_guard_time_set().

◆ id

__IO uint32_t usart_type::id

Definition at line 260 of file at32f413_usart.h.

Referenced by usart_wakeup_id_set().

◆ idlef

__IO uint32_t usart_type::idlef

Definition at line 190 of file at32f413_usart.h.

◆ idleien

__IO uint32_t usart_type::idleien

Definition at line 238 of file at32f413_usart.h.

◆ irdaen

__IO uint32_t usart_type::irdaen

Definition at line 284 of file at32f413_usart.h.

Referenced by usart_irda_mode_enable().

◆ irdalp

__IO uint32_t usart_type::irdalp

Definition at line 285 of file at32f413_usart.h.

Referenced by usart_irda_low_power_enable().

◆ isdiv

__IO uint32_t usart_type::isdiv

Definition at line 306 of file at32f413_usart.h.

Referenced by usart_irda_smartcard_division_set().

◆ lbcp

__IO uint32_t usart_type::lbcp

Definition at line 265 of file at32f413_usart.h.

Referenced by usart_clock_config().

◆ linen

__IO uint32_t usart_type::linen

Definition at line 270 of file at32f413_usart.h.

Referenced by usart_lin_mode_enable().

◆ nerr

__IO uint32_t usart_type::nerr

Definition at line 188 of file at32f413_usart.h.

◆ pen

__IO uint32_t usart_type::pen

Definition at line 244 of file at32f413_usart.h.

Referenced by usart_parity_selection_config().

◆ perr

__IO uint32_t usart_type::perr

Definition at line 186 of file at32f413_usart.h.

◆ perrien

__IO uint32_t usart_type::perrien

Definition at line 242 of file at32f413_usart.h.

◆ psel

__IO uint32_t usart_type::psel

Definition at line 243 of file at32f413_usart.h.

Referenced by usart_parity_selection_config().

◆ rdbf

__IO uint32_t usart_type::rdbf

Definition at line 191 of file at32f413_usart.h.

◆ rdbfien

__IO uint32_t usart_type::rdbfien

Definition at line 239 of file at32f413_usart.h.

◆ ren

__IO uint32_t usart_type::ren

Definition at line 236 of file at32f413_usart.h.

Referenced by usart_receiver_enable().

◆ reserved1

__IO uint32_t usart_type::reserved1

Definition at line 196 of file at32f413_usart.h.

◆ reserved2

__IO uint32_t usart_type::reserved2

Definition at line 264 of file at32f413_usart.h.

◆ reserved3

__IO uint32_t usart_type::reserved3

Definition at line 271 of file at32f413_usart.h.

◆ rm

__IO uint32_t usart_type::rm

Definition at line 235 of file at32f413_usart.h.

Referenced by usart_receiver_mute_enable().

◆ roerr

__IO uint32_t usart_type::roerr

Definition at line 189 of file at32f413_usart.h.

◆ rtsen

__IO uint32_t usart_type::rtsen

Definition at line 291 of file at32f413_usart.h.

Referenced by usart_hardware_flow_control_set().

◆ sbf

__IO uint32_t usart_type::sbf

Definition at line 234 of file at32f413_usart.h.

Referenced by usart_break_send().

◆ scgt

__IO uint32_t usart_type::scgt

Definition at line 307 of file at32f413_usart.h.

Referenced by usart_smartcard_guard_time_set().

◆ scmen

__IO uint32_t usart_type::scmen

Definition at line 288 of file at32f413_usart.h.

Referenced by usart_smartcard_mode_enable().

◆ scnacken

__IO uint32_t usart_type::scnacken

Definition at line 287 of file at32f413_usart.h.

Referenced by usart_smartcard_nack_set().

◆ slben

__IO uint32_t usart_type::slben

Definition at line 286 of file at32f413_usart.h.

Referenced by usart_single_line_halfduplex_select().

◆ stopbn

__IO uint32_t usart_type::stopbn

Definition at line 269 of file at32f413_usart.h.

Referenced by usart_init().

◆ sts

__IO uint32_t usart_type::sts

Definition at line 183 of file at32f413_usart.h.

Referenced by usart_flag_clear(), and usart_flag_get().

◆

struct { ... } usart_type::sts_bit

◆ tdbe

__IO uint32_t usart_type::tdbe

Definition at line 193 of file at32f413_usart.h.

◆ tdbeien

__IO uint32_t usart_type::tdbeien

Definition at line 241 of file at32f413_usart.h.

◆ tdc

__IO uint32_t usart_type::tdc

Definition at line 192 of file at32f413_usart.h.

◆ tdcien

__IO uint32_t usart_type::tdcien

Definition at line 240 of file at32f413_usart.h.

◆ ten

__IO uint32_t usart_type::ten

Definition at line 237 of file at32f413_usart.h.

Referenced by usart_transmitter_enable().

◆ uen

__IO uint32_t usart_type::uen

Definition at line 247 of file at32f413_usart.h.

Referenced by usart_enable().

◆ wum

__IO uint32_t usart_type::wum

Definition at line 245 of file at32f413_usart.h.

Referenced by usart_wakeup_mode_set().

The documentation for this struct was generated from the following file:
  • at32f413_usart.h


AT32F413 Firmwary Library: USART_exported_functions

Functions
USART_exported_functions
AT32F413_periph_driver » USART

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

Function Documentation

◆ usart_break_bit_num_set()

void usart_break_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_break_bit_num_type | break_bit
 | ) |  |

set the usart break frame bit num.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
break_bit specifies the break bit num. this parameter can be one of the following values:
  • USART_BREAK_10BITS
  • USART_BREAK_11BITS
Return values
none

Definition at line 352 of file at32f413_usart.c.

◆ usart_break_send()

void usart_break_send ( usart_type * usart_x )

transmit break characters.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 403 of file at32f413_usart.c.

◆ usart_clock_config()

void usart_clock_config | ( | usart_type * | usart_x,
 |  | usart_clock_polarity_type | clk_pol,
 |  | usart_clock_phase_type | clk_pha,
 |  | usart_lbcp_type | clk_lb
 | ) |  |

usart clock config.

Note
clock config are not available for UART4 and UART5.
Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
clk_pol polarity of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_POLARITY_LOW
  • USART_CLOCK_POLARITY_HIGH
clk_pha phase of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_PHASE_1EDGE
  • USART_CLOCK_PHASE_2EDGE
clk_lb whether the clock pulse of the last data bit transmitted (MSB) is outputted on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_LAST_BIT_NONE
  • USART_CLOCK_LAST_BIT_OUTPUT
Return values
none

Definition at line 222 of file at32f413_usart.c.

Referenced by usart_spi_configuration().

◆ usart_clock_enable()

void usart_clock_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart enable the ck pin.

Note
clock enable are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | TRUE or FALSE
Return values
none

Definition at line 238 of file at32f413_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_data_receive()

uint16_t usart_data_receive ( usart_type * usart_x )

return the most recent received data by the usart peripheral.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
the received data.

Definition at line 391 of file at32f413_usart.c.

Referenced by main(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart_data_transmit()

void usart_data_transmit | ( | usart_type * | usart_x,
 |  | uint16_t | data
 | ) |  |

transmit single data through the usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
data | the data to transmit.
Return values
none

Definition at line 379 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_dma_receiver_enable()

void usart_dma_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma receiver interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 293 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_dma_transmitter_enable()

void usart_dma_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma transmitter interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 279 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_enable()

void usart_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 171 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_flag_clear()

void usart_flag_clear | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

clear the usart's pending flags.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • USART_CTSCF_FLAG: (not available for UART4 and UART5).
  • USART_BFF_FLAG:
  • USART_TDC_FLAG:
  • USART_RDBF_FLAG:
  • USART_PERR_FLAG:
  • USART_FERR_FLAG:
  • USART_NERR_FLAG:
  • USART_ROERR_FLAG:
  • USART_IDLEF_FLAG:
Note
  • USART_PERR_FLAG, USART_FERR_FLAG, USART_NERR_FLAG, USART_ROERR_FLAG and USART_IDLEF_FLAG are cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a read operation to usart dt register (usart_data_receive()).
  • USART_RDBF_FLAG can be also cleared by a read to the usart dt register(usart_data_receive()).
  • USART_TDC_FLAG can be also cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a write operation to usart dt register (usart_data_transmit()).
  • USART_TDBE_FLAG is cleared only by a write to the usart dt register(usart_data_transmit()).
Return values
none

< usart parity error flag

< usart framing error flag

< usart noise error flag

< usart receiver overflow error flag

< usart idle flag

Definition at line 602 of file at32f413_usart.c.

Referenced by rs485_config().

◆ usart_flag_get()

flag_status usart_flag_get | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

check whether the specified usart flag is set or not.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to check. this parameter can be one of the following values:
  • USART_CTSCF_FLAG: cts change flag (not available for UART4,UART5,USART6,UART7 and UART8)
  • USART_BFF_FLAG: break frame flag
  • USART_TDBE_FLAG: transmit data buffer empty flag
  • USART_TDC_FLAG: transmit data complete flag
  • USART_RDBF_FLAG: receive data buffer full flag
  • USART_IDLEF_FLAG: idle flag
  • USART_ROERR_FLAG: receiver overflow error flag
  • USART_NERR_FLAG: noise error flag
  • USART_FERR_FLAG: framing error flag
  • USART_PERR_FLAG: parity error flag
Return values
the new state of usart_flag (SET or RESET).

Definition at line 564 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_hardware_flow_control_set()

void usart_hardware_flow_control_set | ( | usart_type * | usart_x,
 |  | usart_hardware_flow_control_type | flow_state
 | ) |  |

configure the usart's hardware flow control.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3
flow_state specifies the hardware flow control. this parameter can be one of the following values:
  • USART_HARDWARE_FLOW_NONE
  • USART_HARDWARE_FLOW_RTS,
  • USART_HARDWARE_FLOW_CTS,
  • USART_HARDWARE_FLOW_RTS_CTS
Return values
none

Definition at line 521 of file at32f413_usart.c.

Referenced by usart1_config(), and usart_configuration().

◆ usart_init()

void usart_init | ( | usart_type * | usart_x,
 |  | uint32_t | baud_rate,
 |  | usart_data_bit_num_type | data_bit,
 |  | usart_stop_bit_num_type | stop_bit
 | ) |  |

initialize the usart peripheral according to the specified parameters.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
baud_rate | configure the usart communication baud rate.
data_bit data bits transmitted or received in a frame this parameter can be one of the following values:
  • USART_DATA_8BITS
  • USART_DATA_9BITS. note：
  • when parity check is disabled, the data bit width is the actual data bit number.
  • when parity check is enabled, the data bit width is the actual data bit number minus 1, and the MSB bit is replaced with the parity bit.
stop_bit stop bits transmitted this parameter can be one of the following values:
  • USART_STOP_1_BIT
  • USART_STOP_0_5_BIT.
  • USART_STOP_2_BIT
  • USART_STOP_1_5_BIT.
Return values
none

Definition at line 104 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_interrupt_enable()

void usart_interrupt_enable | ( | usart_type * | usart_x,
 |  | uint32_t | usart_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart interrupts.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_int specifies the USART interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • USART_IDLE_INT: idle interrupt
  • USART_RDBF_INT: rdbf interrupt
  • USART_TDC_INT: tdc interrupt
  • USART_TDBE_INT: tdbe interrupt
  • USART_PERR_INT: perr interrupt
  • USART_BF_INT: break frame interrupt
  • USART_ERR_INT: err interrupt
  • USART_CTSCF_INT: ctscf interrupt
new_state | new state of the specified usart interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 262 of file at32f413_usart.c.

Referenced by data_take(), main(), rs485_config(), SC_USART_IRQHandler(), uart_init(), usart1_config(), USART2_IRQHandler(), USART3_IRQHandler(), usart_configuration(), and usb_usart_config().

◆ usart_irda_low_power_enable()

void usart_irda_low_power_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

configure the usart's irda low power.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 503 of file at32f413_usart.c.

◆ usart_irda_mode_enable()

void usart_irda_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's irda interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 489 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_irda_smartcard_division_set()

void usart_irda_smartcard_division_set | ( | usart_type * | usart_x,
 |  | uint8_t | div_val
 | ) |  |

config the irda/smartcard division.

Note
the division are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
div_val | specifies the division.
Return values
none

Definition at line 431 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_lin_mode_enable()

void usart_lin_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart lin mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart lin mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 366 of file at32f413_usart.c.

◆ usart_parity_selection_config()

void usart_parity_selection_config | ( | usart_type * | usart_x,
 |  | usart_parity_selection_type | parity
 | ) |  |

usart parity selection config.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
parity select the none, odd or even parity. this parameter can be one of the following values:
  • USART_PARITY_NONE
  • USART_PARITY_EVEN.
  • USART_PARITY_ODD
Return values
none

Definition at line 143 of file at32f413_usart.c.

Referenced by usart1_config(), usart_configuration(), and usb_usart_config().

◆ usart_receiver_enable()

void usart_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart receiver enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 197 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_receiver_mute_enable()

void usart_receiver_mute_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

config the usart in mute mode in multi-processor communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart mute mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 336 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_reset()

void usart_reset ( usart_type * usart_x )

deinitialize the usart peripheral registers to their default reset values.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 50 of file at32f413_usart.c.

◆ usart_single_line_halfduplex_select()

void usart_single_line_halfduplex_select | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart single line bidirectional half-duplex communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the single line half-duplex select. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 475 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_guard_time_set()

void usart_smartcard_guard_time_set | ( | usart_type * | usart_x,
 |  | uint8_t | guard_time_val
 | ) |  |

config the specified usart smartcard guard time.

Note
The guard time bits are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
guard_time_val | specifies the guard time (0x00~0xFF).
Return values
none

Definition at line 417 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_mode_enable()

void usart_smartcard_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart smart card mode.

Note
the smart card mode are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the smart card mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 446 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_nack_set()

void usart_smartcard_nack_set | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable nack transmission in smartcard mode.

Note
the smart card nack are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the nack transmission. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 461 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_transmitter_enable()

void usart_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart transmitter enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 184 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_wakeup_id_set()

void usart_wakeup_id_set | ( | usart_type * | usart_x,
 |  | uint8_t | usart_id
 | ) |  |

set the wakeup id of the usart.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_id | the matching id(0x0~0xF).
Return values
none

Definition at line 306 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_wakeup_mode_set()

void usart_wakeup_mode_set | ( | usart_type * | usart_x,
 |  | usart_wakeup_mode_type | wakeup_mode
 | ) |  |

select the usart wakeup method in multi-processor communication.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
wakeup_mode determines the way to wake up usart method. this parameter can be one of the following values:
  • USART_WAKEUP_BY_IDLE_FRAME
  • USART_WAKEUP_BY_MATCHING_ID
Return values
none

Definition at line 322 of file at32f413_usart.c.

Referenced by usart_configuration().


AT32F413 Firmwary Library: USART_private_functions

Functions
USART_private_functions
AT32F413_periph_driver » USART

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

Function Documentation

◆ usart_break_bit_num_set()

void usart_break_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_break_bit_num_type | break_bit
 | ) |  |

set the usart break frame bit num.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
break_bit specifies the break bit num. this parameter can be one of the following values:
  • USART_BREAK_10BITS
  • USART_BREAK_11BITS
Return values
none

Definition at line 352 of file at32f413_usart.c.

◆ usart_break_send()

void usart_break_send ( usart_type * usart_x )

transmit break characters.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 403 of file at32f413_usart.c.

◆ usart_clock_config()

void usart_clock_config | ( | usart_type * | usart_x,
 |  | usart_clock_polarity_type | clk_pol,
 |  | usart_clock_phase_type | clk_pha,
 |  | usart_lbcp_type | clk_lb
 | ) |  |

usart clock config.

Note
clock config are not available for UART4 and UART5.
Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
clk_pol polarity of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_POLARITY_LOW
  • USART_CLOCK_POLARITY_HIGH
clk_pha phase of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_PHASE_1EDGE
  • USART_CLOCK_PHASE_2EDGE
clk_lb whether the clock pulse of the last data bit transmitted (MSB) is outputted on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_LAST_BIT_NONE
  • USART_CLOCK_LAST_BIT_OUTPUT
Return values
none

Definition at line 222 of file at32f413_usart.c.

Referenced by usart_spi_configuration().

◆ usart_clock_enable()

void usart_clock_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart enable the ck pin.

Note
clock enable are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | TRUE or FALSE
Return values
none

Definition at line 238 of file at32f413_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_data_receive()

uint16_t usart_data_receive ( usart_type * usart_x )

return the most recent received data by the usart peripheral.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
the received data.

Definition at line 391 of file at32f413_usart.c.

Referenced by main(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart_data_transmit()

void usart_data_transmit | ( | usart_type * | usart_x,
 |  | uint16_t | data
 | ) |  |

transmit single data through the usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
data | the data to transmit.
Return values
none

Definition at line 379 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_dma_receiver_enable()

void usart_dma_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma receiver interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 293 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_dma_transmitter_enable()

void usart_dma_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma transmitter interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 279 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_enable()

void usart_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 171 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_flag_clear()

void usart_flag_clear | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

clear the usart's pending flags.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • USART_CTSCF_FLAG: (not available for UART4 and UART5).
  • USART_BFF_FLAG:
  • USART_TDC_FLAG:
  • USART_RDBF_FLAG:
  • USART_PERR_FLAG:
  • USART_FERR_FLAG:
  • USART_NERR_FLAG:
  • USART_ROERR_FLAG:
  • USART_IDLEF_FLAG:
Note
  • USART_PERR_FLAG, USART_FERR_FLAG, USART_NERR_FLAG, USART_ROERR_FLAG and USART_IDLEF_FLAG are cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a read operation to usart dt register (usart_data_receive()).
  • USART_RDBF_FLAG can be also cleared by a read to the usart dt register(usart_data_receive()).
  • USART_TDC_FLAG can be also cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a write operation to usart dt register (usart_data_transmit()).
  • USART_TDBE_FLAG is cleared only by a write to the usart dt register(usart_data_transmit()).
Return values
none

< usart parity error flag

< usart framing error flag

< usart noise error flag

< usart receiver overflow error flag

< usart idle flag

Definition at line 602 of file at32f413_usart.c.

Referenced by rs485_config().

◆ usart_flag_get()

flag_status usart_flag_get | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

check whether the specified usart flag is set or not.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to check. this parameter can be one of the following values:
  • USART_CTSCF_FLAG: cts change flag (not available for UART4,UART5,USART6,UART7 and UART8)
  • USART_BFF_FLAG: break frame flag
  • USART_TDBE_FLAG: transmit data buffer empty flag
  • USART_TDC_FLAG: transmit data complete flag
  • USART_RDBF_FLAG: receive data buffer full flag
  • USART_IDLEF_FLAG: idle flag
  • USART_ROERR_FLAG: receiver overflow error flag
  • USART_NERR_FLAG: noise error flag
  • USART_FERR_FLAG: framing error flag
  • USART_PERR_FLAG: parity error flag
Return values
the new state of usart_flag (SET or RESET).

Definition at line 564 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_hardware_flow_control_set()

void usart_hardware_flow_control_set | ( | usart_type * | usart_x,
 |  | usart_hardware_flow_control_type | flow_state
 | ) |  |

configure the usart's hardware flow control.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3
flow_state specifies the hardware flow control. this parameter can be one of the following values:
  • USART_HARDWARE_FLOW_NONE
  • USART_HARDWARE_FLOW_RTS,
  • USART_HARDWARE_FLOW_CTS,
  • USART_HARDWARE_FLOW_RTS_CTS
Return values
none

Definition at line 521 of file at32f413_usart.c.

Referenced by usart1_config(), and usart_configuration().

◆ usart_init()

void usart_init | ( | usart_type * | usart_x,
 |  | uint32_t | baud_rate,
 |  | usart_data_bit_num_type | data_bit,
 |  | usart_stop_bit_num_type | stop_bit
 | ) |  |

initialize the usart peripheral according to the specified parameters.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
baud_rate | configure the usart communication baud rate.
data_bit data bits transmitted or received in a frame this parameter can be one of the following values:
  • USART_DATA_8BITS
  • USART_DATA_9BITS. note：
  • when parity check is disabled, the data bit width is the actual data bit number.
  • when parity check is enabled, the data bit width is the actual data bit number minus 1, and the MSB bit is replaced with the parity bit.
stop_bit stop bits transmitted this parameter can be one of the following values:
  • USART_STOP_1_BIT
  • USART_STOP_0_5_BIT.
  • USART_STOP_2_BIT
  • USART_STOP_1_5_BIT.
Return values
none

Definition at line 104 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_interrupt_enable()

void usart_interrupt_enable | ( | usart_type * | usart_x,
 |  | uint32_t | usart_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart interrupts.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_int specifies the USART interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • USART_IDLE_INT: idle interrupt
  • USART_RDBF_INT: rdbf interrupt
  • USART_TDC_INT: tdc interrupt
  • USART_TDBE_INT: tdbe interrupt
  • USART_PERR_INT: perr interrupt
  • USART_BF_INT: break frame interrupt
  • USART_ERR_INT: err interrupt
  • USART_CTSCF_INT: ctscf interrupt
new_state | new state of the specified usart interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 262 of file at32f413_usart.c.

Referenced by data_take(), main(), rs485_config(), SC_USART_IRQHandler(), uart_init(), usart1_config(), USART2_IRQHandler(), USART3_IRQHandler(), usart_configuration(), and usb_usart_config().

◆ usart_irda_low_power_enable()

void usart_irda_low_power_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

configure the usart's irda low power.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 503 of file at32f413_usart.c.

◆ usart_irda_mode_enable()

void usart_irda_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's irda interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 489 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_irda_smartcard_division_set()

void usart_irda_smartcard_division_set | ( | usart_type * | usart_x,
 |  | uint8_t | div_val
 | ) |  |

config the irda/smartcard division.

Note
the division are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
div_val | specifies the division.
Return values
none

Definition at line 431 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_lin_mode_enable()

void usart_lin_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart lin mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart lin mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 366 of file at32f413_usart.c.

◆ usart_parity_selection_config()

void usart_parity_selection_config | ( | usart_type * | usart_x,
 |  | usart_parity_selection_type | parity
 | ) |  |

usart parity selection config.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
parity select the none, odd or even parity. this parameter can be one of the following values:
  • USART_PARITY_NONE
  • USART_PARITY_EVEN.
  • USART_PARITY_ODD
Return values
none

Definition at line 143 of file at32f413_usart.c.

Referenced by usart1_config(), usart_configuration(), and usb_usart_config().

◆ usart_receiver_enable()

void usart_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart receiver enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 197 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_receiver_mute_enable()

void usart_receiver_mute_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

config the usart in mute mode in multi-processor communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart mute mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 336 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_reset()

void usart_reset ( usart_type * usart_x )

deinitialize the usart peripheral registers to their default reset values.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 50 of file at32f413_usart.c.

◆ usart_single_line_halfduplex_select()

void usart_single_line_halfduplex_select | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart single line bidirectional half-duplex communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the single line half-duplex select. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 475 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_guard_time_set()

void usart_smartcard_guard_time_set | ( | usart_type * | usart_x,
 |  | uint8_t | guard_time_val
 | ) |  |

config the specified usart smartcard guard time.

Note
The guard time bits are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
guard_time_val | specifies the guard time (0x00~0xFF).
Return values
none

Definition at line 417 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_mode_enable()

void usart_smartcard_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart smart card mode.

Note
the smart card mode are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the smart card mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 446 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_nack_set()

void usart_smartcard_nack_set | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable nack transmission in smartcard mode.

Note
the smart card nack are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the nack transmission. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 461 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_transmitter_enable()

void usart_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart transmitter enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 184 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_wakeup_id_set()

void usart_wakeup_id_set | ( | usart_type * | usart_x,
 |  | uint8_t | usart_id
 | ) |  |

set the wakeup id of the usart.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_id | the matching id(0x0~0xF).
Return values
none

Definition at line 306 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_wakeup_mode_set()

void usart_wakeup_mode_set | ( | usart_type * | usart_x,
 |  | usart_wakeup_mode_type | wakeup_mode
 | ) |  |

select the usart wakeup method in multi-processor communication.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
wakeup_mode determines the way to wake up usart method. this parameter can be one of the following values:
  • USART_WAKEUP_BY_IDLE_FRAME
  • USART_WAKEUP_BY_MATCHING_ID
Return values
none

Definition at line 322 of file at32f413_usart.c.

Referenced by usart_configuration().


AT32F413 Firmwary Library: USB

Modules | Macros | Typedefs | Variables
USB
AT32F413_periph_driver

USB driver modules. More...

Modules

USB_interrupts_definition
usb interrupt mask
USB_interrupt_flags_definition
usb interrupt flag
USB_endpoint_register_bit_definition
usb endpoint register bit define
USB_endpoint_tx_and_rx_status_definition
usb endpoint tx and rx status
USB_device_endpoint_register_type_definition
usb device endpoint register type define
USB_buffer_table_default_offset_address_definition
usb buffer table default offset address
USB_packet_buffer_start_address_definition
usb packet buffer start address
USB_exported_enum_types
USB_macro_definition
USB_exported_types
USB_exported_functions
USB_private_functions

Macros

#define USB ((usbd_type *) USBFS_BASE)

Typedefs

typedef usbd_type usb_reg_type

Variables

uint32_t g_usb_packet_address

Detailed Description

USB driver modules.

Macro Definition Documentation

◆ USB

#define USB ((usbd_type *) USBFS_BASE)

Definition at line 664 of file at32f413_usb.h.

Typedef Documentation

◆ usb_reg_type

typedef usbd_type usb_reg_type

Definition at line 666 of file at32f413_usb.h.

Variable Documentation

◆ g_usb_packet_address

uint32_t g_usb_packet_address
extern

usb buffer address

Definition at line 47 of file at32f413_usb.c.

Referenced by usb_read_packet(), usb_usbbufs_enable(), and usb_write_packet().


AT32F413 Firmwary Library: USB_interrupts_definition

Macros
USB_interrupts_definition
AT32F413_periph_driver » USB

usb interrupt mask More...

Macros

#define | USB_LSOF_INT ((uint32_t)0x00000100)
#define | USB_SOF_INT ((uint32_t)0x00000200)
#define | USB_RST_INT ((uint32_t)0x00000400)
#define | USB_SP_INT ((uint32_t)0x00000800)
#define | USB_WK_INT ((uint32_t)0x00001000)
#define | USB_BE_INT ((uint32_t)0x00002000)
#define | USB_UCFOR_INT ((uint32_t)0x00004000)
#define | USB_TC_INT ((uint32_t)0x00008000)

Detailed Description

usb interrupt mask

Macro Definition Documentation

◆ USB_BE_INT

#define USB_BE_INT ((uint32_t)0x00002000)

usb bus error interrupt

Definition at line 57 of file at32f413_usb.h.

◆ USB_LSOF_INT

#define USB_LSOF_INT ((uint32_t)0x00000100)

usb lost sof interrupt

Definition at line 52 of file at32f413_usb.h.

◆ USB_RST_INT

#define USB_RST_INT ((uint32_t)0x00000400)

usb reset interrupt

Definition at line 54 of file at32f413_usb.h.

◆ USB_SOF_INT

#define USB_SOF_INT ((uint32_t)0x00000200)

usb sof interrupt

Definition at line 53 of file at32f413_usb.h.

◆ USB_SP_INT

#define USB_SP_INT ((uint32_t)0x00000800)

usb suspend interrupt

Definition at line 55 of file at32f413_usb.h.

◆ USB_TC_INT

#define USB_TC_INT ((uint32_t)0x00008000)

usb transmission completed interrupt

Definition at line 59 of file at32f413_usb.h.

◆ USB_UCFOR_INT

#define USB_UCFOR_INT ((uint32_t)0x00004000)

usb core fifo overrun interrupt

Definition at line 58 of file at32f413_usb.h.

◆ USB_WK_INT

#define USB_WK_INT ((uint32_t)0x00001000)

usb wakeup interrupt

Definition at line 56 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_interrupt_flags_definition

Macros
USB_interrupt_flags_definition
AT32F413_periph_driver » USB

usb interrupt flag More...

Macros

#define | USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)
#define | USB_INOUT_FLAG ((uint32_t)0x00000010)
#define | USB_LSOF_FLAG ((uint32_t)0x00000100)
#define | USB_SOF_FLAG ((uint32_t)0x00000200)
#define | USB_RST_FLAG ((uint32_t)0x00000400)
#define | USB_SP_FLAG ((uint32_t)0x00000800)
#define | USB_WK_FLAG ((uint32_t)0x00001000)
#define | USB_BE_FLAG ((uint32_t)0x00002000)
#define | USB_UCFOR_FLAG ((uint32_t)0x00004000)
#define | USB_TC_FLAG ((uint32_t)0x00008000)

Detailed Description

usb interrupt flag

Macro Definition Documentation

◆ USB_BE_FLAG

#define USB_BE_FLAG ((uint32_t)0x00002000)

usb bus error flag

Definition at line 77 of file at32f413_usb.h.

◆ USB_EPT_NUM_FLAG

#define USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)

usb endpoint number

Definition at line 70 of file at32f413_usb.h.

◆ USB_INOUT_FLAG

#define USB_INOUT_FLAG ((uint32_t)0x00000010)

usb in/out transcation flag

Definition at line 71 of file at32f413_usb.h.

◆ USB_LSOF_FLAG

#define USB_LSOF_FLAG ((uint32_t)0x00000100)

usb lost sof flag

Definition at line 72 of file at32f413_usb.h.

◆ USB_RST_FLAG

#define USB_RST_FLAG ((uint32_t)0x00000400)

usb reset flag

Definition at line 74 of file at32f413_usb.h.

◆ USB_SOF_FLAG

#define USB_SOF_FLAG ((uint32_t)0x00000200)

usb sof flag

Definition at line 73 of file at32f413_usb.h.

◆ USB_SP_FLAG

#define USB_SP_FLAG ((uint32_t)0x00000800)

usb suspend flag

Definition at line 75 of file at32f413_usb.h.

◆ USB_TC_FLAG

#define USB_TC_FLAG ((uint32_t)0x00008000)

usb transmission completed flag

Definition at line 79 of file at32f413_usb.h.

◆ USB_UCFOR_FLAG

#define USB_UCFOR_FLAG ((uint32_t)0x00004000)

usb core fifo overrun flag

Definition at line 78 of file at32f413_usb.h.

◆ USB_WK_FLAG

#define USB_WK_FLAG ((uint32_t)0x00001000)

usb wakeup flag

Definition at line 76 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_endpoint_register_bit_definition

Macros
USB_endpoint_register_bit_definition
AT32F413_periph_driver » USB

usb endpoint register bit define More...

Macros

#define | USB_EPTADDR ((uint32_t)0x0000000F)
#define | USB_TXSTS ((uint32_t)0x00000030)
#define | USB_TXDTS ((uint32_t)0x00000040)
#define | USB_TXTC ((uint32_t)0x00000080)
#define | USB_EXF ((uint32_t)0x00000100)
#define | USB_TRANS_TYPE ((uint32_t)0x00000600)
#define | USB_SETUPTC ((uint32_t)0x00000800)
#define | USB_RXSTS ((uint32_t)0x00003000)
#define | USB_RXDTS ((uint32_t)0x00004000)
#define | USB_RXTC ((uint32_t)0x00008000)
#define | USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)
#define | USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)
#define | USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)

Detailed Description

usb endpoint register bit define

Macro Definition Documentation

◆ USB_EPT_BIT_MASK

#define USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)

usb bit mask

Definition at line 101 of file at32f413_usb.h.

◆ USB_EPTADDR

#define USB_EPTADDR ((uint32_t)0x0000000F)

usb endpoint address

Definition at line 90 of file at32f413_usb.h.

◆ USB_EXF

#define USB_EXF ((uint32_t)0x00000100)

usb endpoint extend funtion

Definition at line 94 of file at32f413_usb.h.

◆ USB_RX_MASK

#define USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)

usb rx mask

Definition at line 103 of file at32f413_usb.h.

◆ USB_RXDTS

#define USB_RXDTS ((uint32_t)0x00004000)

usb rx data toggle synchronization

Definition at line 98 of file at32f413_usb.h.

◆ USB_RXSTS

#define USB_RXSTS ((uint32_t)0x00003000)

usb rx status

Definition at line 97 of file at32f413_usb.h.

◆ USB_RXTC

#define USB_RXTC ((uint32_t)0x00008000)

usb rx transcation completed

Definition at line 99 of file at32f413_usb.h.

◆ USB_SETUPTC

#define USB_SETUPTC ((uint32_t)0x00000800)

usb setup transcation completed

Definition at line 96 of file at32f413_usb.h.

◆ USB_TRANS_TYPE

#define USB_TRANS_TYPE ((uint32_t)0x00000600)

usb transfer type

Definition at line 95 of file at32f413_usb.h.

◆ USB_TX_MASK

#define USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)

usb tx mask

Definition at line 102 of file at32f413_usb.h.

◆ USB_TXDTS

#define USB_TXDTS ((uint32_t)0x00000040)

usb tx data toggle synchronization

Definition at line 92 of file at32f413_usb.h.

◆ USB_TXSTS

#define USB_TXSTS ((uint32_t)0x00000030)

usb tx status

Definition at line 91 of file at32f413_usb.h.

◆ USB_TXTC

#define USB_TXTC ((uint32_t)0x00000080)

usb tx transcation completed

Definition at line 93 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_endpoint_tx_and_rx_status_definition

Macros
USB_endpoint_tx_and_rx_status_definition
AT32F413_periph_driver » USB

usb endpoint tx and rx status More...

Macros

#define | USB_TX_DISABLE ((uint32_t)0x00000000)
#define | USB_TX_STALL ((uint32_t)0x00000010)
#define | USB_TX_NAK ((uint32_t)0x00000020)
#define | USB_TX_VALID ((uint32_t)0x00000030)
#define | USB_TXDTS0 ((uint32_t)0x00000010)
#define | USB_TXDTS1 ((uint32_t)0x00000020)
#define | USB_RX_DISABLE ((uint32_t)0x00000000)
#define | USB_RX_STALL ((uint32_t)0x00001000)
#define | USB_RX_NAK ((uint32_t)0x00002000)
#define | USB_RX_VALID ((uint32_t)0x00003000)
#define | USB_RXDTS0 ((uint32_t)0x00001000)
#define | USB_RXDTS1 ((uint32_t)0x00002000)

Detailed Description

usb endpoint tx and rx status

Macro Definition Documentation

◆ USB_RX_DISABLE

#define USB_RX_DISABLE ((uint32_t)0x00000000)

usb rx status disable

Definition at line 122 of file at32f413_usb.h.

◆ USB_RX_NAK

#define USB_RX_NAK ((uint32_t)0x00002000)

usb rx status nak

Definition at line 124 of file at32f413_usb.h.

◆ USB_RX_STALL

#define USB_RX_STALL ((uint32_t)0x00001000)

usb rx status stall

Definition at line 123 of file at32f413_usb.h.

◆ USB_RX_VALID

#define USB_RX_VALID ((uint32_t)0x00003000)

usb rx status valid

Definition at line 125 of file at32f413_usb.h.

◆ USB_RXDTS0

#define USB_RXDTS0 ((uint32_t)0x00001000)

usb rx data toggle bit 0

Definition at line 127 of file at32f413_usb.h.

◆ USB_RXDTS1

#define USB_RXDTS1 ((uint32_t)0x00002000)

usb rx data toggle bit 1

Definition at line 128 of file at32f413_usb.h.

◆ USB_TX_DISABLE

#define USB_TX_DISABLE ((uint32_t)0x00000000)

usb tx status disable

Definition at line 114 of file at32f413_usb.h.

◆ USB_TX_NAK

#define USB_TX_NAK ((uint32_t)0x00000020)

usb tx status nak

Definition at line 116 of file at32f413_usb.h.

◆ USB_TX_STALL

#define USB_TX_STALL ((uint32_t)0x00000010)

usb tx status stall

Definition at line 115 of file at32f413_usb.h.

◆ USB_TX_VALID

#define USB_TX_VALID ((uint32_t)0x00000030)

usb tx status valid

Definition at line 117 of file at32f413_usb.h.

◆ USB_TXDTS0

#define USB_TXDTS0 ((uint32_t)0x00000010)

usb tx data toggle bit 0

Definition at line 119 of file at32f413_usb.h.

◆ USB_TXDTS1

#define USB_TXDTS1 ((uint32_t)0x00000020)

usb tx data toggle bit 1

Definition at line 120 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_device_endpoint_register_type_definition

Macros
USB_device_endpoint_register_type_definition
AT32F413_periph_driver » USB

usb device endpoint register type define More...

Macros

#define | USB_EPT_CONTROL ((uint32_t)0x00000200)
#define | USB_EPT_BULK ((uint32_t)0x00000000)
#define | USB_EPT_INT ((uint32_t)0x00000600)
#define | USB_EPT_ISO ((uint32_t)0x00000400)

Detailed Description

usb device endpoint register type define

Macro Definition Documentation

◆ USB_EPT_BULK

#define USB_EPT_BULK ((uint32_t)0x00000000)

usb endpoint transfer type bulk

Definition at line 140 of file at32f413_usb.h.

◆ USB_EPT_CONTROL

#define USB_EPT_CONTROL ((uint32_t)0x00000200)

usb endpoint transfer type control

Definition at line 139 of file at32f413_usb.h.

◆ USB_EPT_INT

#define USB_EPT_INT ((uint32_t)0x00000600)

usb endpoint transfer type interrupt

Definition at line 141 of file at32f413_usb.h.

◆ USB_EPT_ISO

#define USB_EPT_ISO ((uint32_t)0x00000400)

usb endpoint transfer type iso

Definition at line 142 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_buffer_table_default_offset_address_definition

Macros
USB_buffer_table_default_offset_address_definition
AT32F413_periph_driver » USB

usb buffer table default offset address More...

Macros

#define USB_BUFFER_TABLE_ADDRESS 0x0000

Detailed Description

usb buffer table default offset address

Macro Definition Documentation

◆ USB_BUFFER_TABLE_ADDRESS

#define USB_BUFFER_TABLE_ADDRESS 0x0000

usb buffer table address

Definition at line 153 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_packet_buffer_start_address_definition

Macros
USB_packet_buffer_start_address_definition
AT32F413_periph_driver » USB

usb packet buffer start address More...

Macros

#define | USB_PACKET_BUFFER_ADDRESS 0x40006000
#define | USB_PACKET_BUFFER_ADDRESS_EX 0x40007800

Detailed Description

usb packet buffer start address

Macro Definition Documentation

◆ USB_PACKET_BUFFER_ADDRESS

#define USB_PACKET_BUFFER_ADDRESS 0x40006000

usb buffer address

Definition at line 164 of file at32f413_usb.h.

◆ USB_PACKET_BUFFER_ADDRESS_EX

#define USB_PACKET_BUFFER_ADDRESS_EX 0x40007800

usb buffer extend address

Definition at line 165 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_exported_enum_types

Enumerations
USB_exported_enum_types
AT32F413_periph_driver » USB

Enumerations

enum usb_ept_number_type {
USB_EPT0 = 0x00 , USB_EPT1 = 0x01 , USB_EPT2 = 0x02 , USB_EPT3 = 0x03 ,
USB_EPT4 = 0x04 , USB_EPT5 = 0x05 , USB_EPT6 = 0x06 , USB_EPT7 = 0x07
}
usb endpoint number define More...
enum | ept_trans_type { EPT_CONTROL_TYPE = 0x00 , EPT_ISO_TYPE = 0x01 , EPT_BULK_TYPE = 0x02 , EPT_INT_TYPE = 0x03 }
usb endpoint max num define More...
enum | ept_inout_type { EPT_IN = 0x00 , EPT_OUT = 0x01 }
endpoint endpoint direction define More...
enum | data_trans_dir { DATA_TRANS_OUT = 0x00 , DATA_TRANS_IN = 0x01 }
data transfer direction More...
enum | usb_clk48_s { USB_CLK_HICK , USB_CLK_HEXT }
usb clock select More...

Detailed Description

Enumeration Type Documentation

◆ data_trans_dir

enum data_trans_dir

data transfer direction

Enumerator
DATA_TRANS_OUT | usb data transfer direction out
DATA_TRANS_IN | usb data transfer direction in

Definition at line 219 of file at32f413_usb.h.

◆ ept_inout_type

enum ept_inout_type

endpoint endpoint direction define

Enumerator
EPT_IN | usb endpoint direction in
EPT_OUT | usb endpoint direction out

Definition at line 210 of file at32f413_usb.h.

◆ ept_trans_type

enum ept_trans_type

usb endpoint max num define

endpoint transfer type define

Enumerator
EPT_CONTROL_TYPE | usb transfer type control
EPT_ISO_TYPE | usb transfer type iso
EPT_BULK_TYPE | usb transfer type bulk
EPT_INT_TYPE | usb transfer type interrupt

Definition at line 199 of file at32f413_usb.h.

◆ usb_clk48_s

enum usb_clk48_s

usb clock select

Enumerator
USB_CLK_HICK
USB_CLK_HEXT

Definition at line 228 of file at32f413_usb.h.

◆ usb_ept_number_type

enum usb_ept_number_type

usb endpoint number define

Enumerator
USB_EPT0 | usb endpoint 0
USB_EPT1 | usb endpoint 1
USB_EPT2 | usb endpoint 2
USB_EPT3 | usb endpoint 3
USB_EPT4 | usb endpoint 4
USB_EPT5 | usb endpoint 5
USB_EPT6 | usb endpoint 6
USB_EPT7 | usb endpoint 7

Definition at line 178 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_macro_definition

Macros
USB_macro_definition
AT32F413_periph_driver » USB

Macros

#define | USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status More...
#define | USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status More...
#define | GET_TX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)
get usb endpoint tx/rx length address More...
#define | GET_RX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)
#define | USB_GET_TX_LEN(eptn) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)
get usb endpoint tx/rx data length More...
#define | USB_GET_RX_LEN(eptn) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)
#define | USB_DBUF0_GET_LEN(eptn) USB_GET_TX_LEN(eptn)
double buffer mode get endpoint buf0/buf1 data length More...
#define | USB_DBUF1_GET_LEN(eptn) USB_GET_RX_LEN(eptn)
#define | BLK32(reg, len, blks)
set usb length of rx buffer More...
#define | BLK2(reg, len, blks)
#define | USB_SET_RXLEN_REG(reg, len)
#define | USB_SET_TXLEN(eptn, len) (*(GET_TX_LEN_ADDR(eptn)) = (len))
set endpoint tx/rx transfer length More...
#define | USB_SET_RXLEN(eptn, len)
#define | USB_OUT_EPT_DOUBLE_BUF0(eptn, len)
double buffer mode set endpoint rx buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length More...
#define | USB_SET_TX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)
set usb endpoint tx/rx fifo address More...
#define | USB_SET_RX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)
#define | USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address) (USB_SET_TX_ADDRESS(eptn, address))
set double buffer mode usb endpoint buf0/buf1 fifo address More...
#define | USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address) (USB_SET_RX_ADDRESS(eptn, address))
#define | USB_TOGGLE_TXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))
set usb tx/rx toggle More...
#define | USB_TOGGLE_RXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))
#define | USB_CLEAR_TXDTS(eptn)
clear usb tx/rx toggle More...
#define | USB_CLEAR_RXDTS(eptn)
#define | USB_SET_TRANS_TYPE(eptn, type) (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)
set usb endpoint type More...
#define | USB_SET_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))
set/clear usb extend function More...
#define | USB_CLEAR_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))
#define | USB_SET_EPT_ADDRESS(eptn, address) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))
set usb device address More...
#define | USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application More...
#define | USB_CLEAR_TXTC(eptn) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)
clear tx/rx transfer completed flag More...
#define | USB_CLEAR_RXTC(eptn) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)
#define | USB_SET_EPT_DOUBLE_BUFFER(eptn) USB_SET_EXF(eptn)
set/clear endpoint double buffer mode More...
#define | USB_CLEAR_EPT_DOUBLE_BUFFER(eptn) USB_CLEAR_EXF(eptn)

Detailed Description

Macro Definition Documentation

◆ BLK2

#define BLK2 | ( | reg,
 |  | len,
 |  | blks
 | ) |
Value:
{ \
blks = (len) >> 1; \
if(((len) & 0x1) == 0) \
blks ++; \
*reg = (uint16_t)((blks) << 10); \
}

Definition at line 308 of file at32f413_usb.h.

◆ BLK32

#define BLK32 | ( | reg,
 |  | len,
 |  | blks
 | ) |
Value:
{ \
blks = (len) >> 5; \
if(((len) & 0x1F) == 0) \
blks --; \
*reg = ((uint16_t)((blks) << 10) | 0x8000); \
}

set usb length of rx buffer

Parameters
reg | usb rx length register
len | rx max length
blks | number of blocks

Definition at line 301 of file at32f413_usb.h.

◆ GET_RX_LEN_ADDR

#define GET_RX_LEN_ADDR ( eptn ) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)

Definition at line 277 of file at32f413_usb.h.

◆ GET_TX_LEN_ADDR

#define GET_TX_LEN_ADDR ( eptn ) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)

get usb endpoint tx/rx length address

Parameters
eptn endpoint number
Return values
the length address of tx/rx

Definition at line 276 of file at32f413_usb.h.

◆ USB_CLEAR_EPT_DOUBLE_BUFFER

#define USB_CLEAR_EPT_DOUBLE_BUFFER ( eptn ) USB_CLEAR_EXF(eptn)

Definition at line 485 of file at32f413_usb.h.

◆ USB_CLEAR_EXF

#define USB_CLEAR_EXF ( eptn ) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))

Definition at line 444 of file at32f413_usb.h.

◆ USB_CLEAR_RXDTS

#define USB_CLEAR_RXDTS ( eptn )
Value:
{ \
if(USB->ept_bit[eptn].rxdts != 0) \
USB_TOGGLE_RXDTS(eptn); \
}
USB
#define USB
Definition: at32f413_usb.h:664

Definition at line 421 of file at32f413_usb.h.

◆ USB_CLEAR_RXTC

#define USB_CLEAR_RXTC ( eptn ) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)

Definition at line 477 of file at32f413_usb.h.

◆ USB_CLEAR_TXDTS

#define USB_CLEAR_TXDTS ( eptn )
Value:
{ \
if(USB->ept_bit[eptn].txdts != 0) \
USB_TOGGLE_TXDTS(eptn); \
}

clear usb tx/rx toggle

Parameters
eptn endpoint number
Return values
none

Definition at line 417 of file at32f413_usb.h.

◆ USB_CLEAR_TXTC

#define USB_CLEAR_TXTC ( eptn ) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)

clear tx/rx transfer completed flag

Parameters
eptn endpoint number
Return values
none

Definition at line 476 of file at32f413_usb.h.

◆ USB_DBUF0_GET_LEN

#define USB_DBUF0_GET_LEN ( eptn ) USB_GET_TX_LEN(eptn)

double buffer mode get endpoint buf0/buf1 data length

Parameters
eptn endpoint number
Return values
the length of buf0/buf1

Definition at line 292 of file at32f413_usb.h.

◆ USB_DBUF1_GET_LEN

#define USB_DBUF1_GET_LEN ( eptn ) USB_GET_RX_LEN(eptn)

Definition at line 293 of file at32f413_usb.h.

◆ USB_FREE_DB_USER_BUFFER

#define USB_FREE_DB_USER_BUFFER | ( | eptn,
 |  | inout
 | ) |
Value:
{ \
if(inout == DATA_TRANS_IN) \
{ \
USB_TOGGLE_RXDTS(eptn); \
} \
else \
{ \
USB_TOGGLE_TXDTS(eptn); \
} \
}
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:222

free buffer used by application

Parameters
eptn | endpoint number
inout | transfer direction
Return values
none

Definition at line 460 of file at32f413_usb.h.

◆ USB_GET_RX_LEN

#define USB_GET_RX_LEN ( eptn ) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)

Definition at line 285 of file at32f413_usb.h.

◆ USB_GET_TX_LEN

#define USB_GET_TX_LEN ( eptn ) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)

get usb endpoint tx/rx data length

Parameters
eptn endpoint number
Return values
the length of tx/rx

Definition at line 284 of file at32f413_usb.h.

◆ USB_OUT_EPT_DOUBLE_BUF0

#define USB_OUT_EPT_DOUBLE_BUF0 | ( | eptn,
 |  | len
 | ) |
Value:
{ \
uint32_t *rx_reg = GET_TX_LEN_ADDR(eptn); \
USB_SET_RXLEN_REG(rx_reg, (len)); \
}
GET_TX_LEN_ADDR
#define GET_TX_LEN_ADDR(eptn)
get usb endpoint tx/rx length address
Definition: at32f413_usb.h:276

double buffer mode set endpoint rx buf0 length

Parameters
eptn | endpoint number
len | transfer length
Return values
none

Definition at line 345 of file at32f413_usb.h.

◆ USB_SET_DOUBLE_BUFF0_ADDRESS

#define USB_SET_DOUBLE_BUFF0_ADDRESS | ( | eptn,
 |  | address
 | ) | (USB_SET_TX_ADDRESS(eptn, address))

set double buffer mode usb endpoint buf0/buf1 fifo address

Parameters
eptn | endpoint number
address | offset of the fifo address
Return values
none

Definition at line 401 of file at32f413_usb.h.

◆ USB_SET_DOUBLE_BUFF1_ADDRESS

#define USB_SET_DOUBLE_BUFF1_ADDRESS | ( | eptn,
 |  | address
 | ) | (USB_SET_RX_ADDRESS(eptn, address))

Definition at line 402 of file at32f413_usb.h.

◆ USB_SET_EPT_ADDRESS

#define USB_SET_EPT_ADDRESS | ( | eptn,
 |  | address
 | ) | (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))

set usb device address

Parameters
eptn | endpoint number
address | device address
Return values
none

Definition at line 452 of file at32f413_usb.h.

◆ USB_SET_EPT_DOUBLE_BUF0_LEN

#define USB_SET_EPT_DOUBLE_BUF0_LEN | ( | eptn,
 |  | len,
 |  | dir
 | ) |
Value:
{ \
if(dir == DATA_TRANS_OUT) \
{ \
USB_OUT_EPT_DOUBLE_BUF0(eptn, len); \
} \
else \
{ \
*(GET_TX_LEN_ADDR(eptn)) = (len); \
} \
}
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:221

double buffer mode set endpoint buf0 length

Parameters
eptn | endpoint number
len | transfer length
dir | transfer direction(in/out)
Return values
none

Definition at line 357 of file at32f413_usb.h.

◆ USB_SET_EPT_DOUBLE_BUF1_LEN

#define USB_SET_EPT_DOUBLE_BUF1_LEN | ( | eptn,
 |  | len,
 |  | dir
 | ) |
Value:
{ \
if(dir == DATA_TRANS_OUT) \
{ \
USB_SET_RXLEN(eptn, len); \
} \
else \
{ \
*(GET_RX_LEN_ADDR(eptn)) = (len); \
} \
}
GET_RX_LEN_ADDR
#define GET_RX_LEN_ADDR(eptn)
Definition: at32f413_usb.h:277

double buffer mode set endpoint buf1 length

Parameters
eptn | endpoint number
len | transfer length
dir | transfer direction(in/out)
Return values
none

Definition at line 375 of file at32f413_usb.h.

◆ USB_SET_EPT_DOUBLE_BUFFER

#define USB_SET_EPT_DOUBLE_BUFFER ( eptn ) USB_SET_EXF(eptn)

set/clear endpoint double buffer mode

Parameters
eptn endpoint number
Return values
none

Definition at line 484 of file at32f413_usb.h.

◆ USB_SET_EXF

#define USB_SET_EXF ( eptn ) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))

set/clear usb extend function

Parameters
eptn endpoint number
Return values
none

Definition at line 443 of file at32f413_usb.h.

◆ USB_SET_RX_ADDRESS

#define USB_SET_RX_ADDRESS | ( | eptn,
 |  | address
 | ) | (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)

Definition at line 393 of file at32f413_usb.h.

◆ USB_SET_RXLEN

#define USB_SET_RXLEN | ( | eptn,
 |  | len
 | ) |
Value:
{ \
uint32_t *rx_reg = GET_RX_LEN_ADDR(eptn); \
USB_SET_RXLEN_REG(rx_reg, (len)); \
}

Definition at line 334 of file at32f413_usb.h.

◆ USB_SET_RXLEN_REG

#define USB_SET_RXLEN_REG | ( | reg,
 |  | len
 | ) |
Value:
{ \
uint16_t blks; \
if(len > 62) \
{ \
BLK32(reg, len, blks); \
} \
else \
{ \
BLK2(reg, len, blks); \
} \
}

Definition at line 315 of file at32f413_usb.h.

◆ USB_SET_RXSTS

#define USB_SET_RXSTS | ( | ept_num,
 |  | new_sts
 | ) |
Value:
{ \
register uint16_t epsts = (USB->ept[ept_num]) & USB_RX_MASK; \
if((new_sts & USB_RXDTS0) != 0) \
epsts ^= USB_RXDTS0; \
if((new_sts & USB_RXDTS1) != 0) \
epsts ^= USB_RXDTS1; \
USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
}
USB_RXTC
#define USB_RXTC
Definition: at32f413_usb.h:99
USB_TXTC
#define USB_TXTC
Definition: at32f413_usb.h:93
USB_RX_MASK
#define USB_RX_MASK
Definition: at32f413_usb.h:103
USB_RXDTS0
#define USB_RXDTS0
Definition: at32f413_usb.h:127
USB_RXDTS1
#define USB_RXDTS1
Definition: at32f413_usb.h:128

set usb endpoint rx status

Parameters
ept_num | endpoint number
new_sts | the new rx status of this endpoint number
Return values
none

Definition at line 262 of file at32f413_usb.h.

◆ USB_SET_TRANS_TYPE

#define USB_SET_TRANS_TYPE | ( | eptn,
 |  | type
 | ) | (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)

set usb endpoint type

set usb transfer type

Parameters
eptn | endpoint number
type | transfer type
Return values
none

Definition at line 436 of file at32f413_usb.h.

◆ USB_SET_TX_ADDRESS

#define USB_SET_TX_ADDRESS | ( | eptn,
 |  | address
 | ) | (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)

set usb endpoint tx/rx fifo address

Parameters
eptn | endpoint number
address | offset of the fifo address
Return values
none

Definition at line 392 of file at32f413_usb.h.

◆ USB_SET_TXLEN

#define USB_SET_TXLEN | ( | eptn,
 |  | len
 | ) | (*(GET_TX_LEN_ADDR(eptn)) = (len))

set endpoint tx/rx transfer length

Parameters
eptn | endpoint number
len | transfer length
Return values
none

Definition at line 333 of file at32f413_usb.h.

◆ USB_SET_TXSTS

#define USB_SET_TXSTS | ( | ept_num,
 |  | new_sts
 | ) |
Value:
{ \
register uint16_t epsts = (USB->ept[ept_num]) & USB_TX_MASK; \
if((new_sts & USB_TXDTS0) != 0) \
epsts ^= USB_TXDTS0; \
if((new_sts & USB_TXDTS1) != 0) \
epsts ^= USB_TXDTS1; \
USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
}
USB_TX_MASK
#define USB_TX_MASK
Definition: at32f413_usb.h:102
USB_TXDTS1
#define USB_TXDTS1
Definition: at32f413_usb.h:120
USB_TXDTS0
#define USB_TXDTS0
Definition: at32f413_usb.h:119

set usb endpoint tx status

Parameters
ept_num | endpoint number
new_sts | the new tx status of this endpoint number
Return values
none

Definition at line 247 of file at32f413_usb.h.

◆ USB_TOGGLE_RXDTS

#define USB_TOGGLE_RXDTS ( eptn ) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))

Definition at line 410 of file at32f413_usb.h.

◆ USB_TOGGLE_TXDTS

#define USB_TOGGLE_TXDTS ( eptn ) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))

set usb tx/rx toggle

Parameters
eptn endpoint number
Return values
none

Definition at line 409 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_exported_types

Data Structures
USB_exported_types
AT32F413_periph_driver » USB

Data Structures

struct | usb_ept_info
usb endpoint infomation structure definition More...
struct | usbd_type
type define usb register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: usb_ept_info Struct Reference

Data Fields
usb_ept_info Struct Reference
AT32F413_periph_driver » USB » USB_exported_types

usb endpoint infomation structure definition More...

#include <at32f413_usb.h>

Data Fields

uint8_t | eptn
uint8_t | ept_address
uint8_t | inout
uint8_t | trans_type
uint16_t | tx_addr
uint16_t | rx_addr
uint16_t | maxpacket
uint8_t | is_double_buffer
uint8_t | stall
uint16_t | status
uint16_t | total_len
uint16_t | trans_len
uint8_t * | trans_buf
uint16_t | last_len
uint16_t | rem0_len
uint16_t | ept0_slen

Detailed Description

usb endpoint infomation structure definition

Definition at line 498 of file at32f413_usb.h.

Field Documentation

◆ ept0_slen

uint16_t usb_ept_info::ept0_slen

endpoint 0 transfer sum length

Definition at line 519 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), usbd_ctrl_recv(), and usbd_ctrl_send().

◆ ept_address

uint8_t usb_ept_info::ept_address

endpoint address

Definition at line 501 of file at32f413_usb.h.

Referenced by usb_ept_open(), and usbd_ept_defaut_init().

◆ eptn

uint8_t usb_ept_info::eptn

endpoint register number (0~7)

Definition at line 500 of file at32f413_usb.h.

Referenced by usb_ept_close(), usb_ept_open(), usb_ept_stall(), usbd_clear_stall(), usbd_ept_defaut_init(), and usbd_set_stall().

◆ inout

uint8_t usb_ept_info::inout

endpoint dir DATA_TRANS_IN or DATA_TRANS_OUT

Definition at line 502 of file at32f413_usb.h.

Referenced by usb_ept_close(), usb_ept_open(), usb_ept_stall(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_defaut_init(), and usbd_ept_open().

◆ is_double_buffer

uint8_t usb_ept_info::is_double_buffer

endpoint double buffer flag

Definition at line 508 of file at32f413_usb.h.

Referenced by usb_ept_close(), usb_ept_open(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_dbuffer_enable(), usbd_ept_send(), and usbd_eptn_handler().

◆ last_len

uint16_t usb_ept_info::last_len

last transfer length

Definition at line 517 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), and usbd_ept_send().

◆ maxpacket

uint16_t usb_ept_info::maxpacket

endpoint max packet

Definition at line 507 of file at32f413_usb.h.

Referenced by usb_ept_open(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ept_buf_auto_define(), usbd_ept_defaut_init(), usbd_ept_open(), usbd_ept_recv(), and usbd_ept_send().

◆ rem0_len

uint16_t usb_ept_info::rem0_len

rem transfer length

Definition at line 518 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), and usbd_ctrl_send().

◆ rx_addr

uint16_t usb_ept_info::rx_addr

endpoint rx buffer offset address

Definition at line 506 of file at32f413_usb.h.

Referenced by usb_ept_open(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_defaut_init(), usbd_ept_send(), and usbd_eptn_handler().

◆ stall

uint8_t usb_ept_info::stall

endpoint is stall state

Definition at line 509 of file at32f413_usb.h.

Referenced by usbd_clear_stall(), usbd_endpoint_request(), and usbd_set_stall().

◆ status

uint16_t usb_ept_info::status

endpoint status

Definition at line 510 of file at32f413_usb.h.

Referenced by usbd_endpoint_request().

◆ total_len

uint16_t usb_ept_info::total_len

endpoint transmission total length

Definition at line 513 of file at32f413_usb.h.

Referenced by usbd_ept_defaut_init(), usbd_ept_recv(), usbd_ept_send(), and usbd_eptn_handler().

◆ trans_buf

uint8_t* usb_ept_info::trans_buf

endpoint transmission buffer

Definition at line 515 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), usbd_core_out_handler(), usbd_ept_defaut_init(), usbd_ept_recv(), usbd_ept_send(), and usbd_eptn_handler().

◆ trans_len

uint16_t usb_ept_info::trans_len

endpoint transmission length

Definition at line 514 of file at32f413_usb.h.

Referenced by usbd_ept_recv(), usbd_ept_send(), usbd_eptn_handler(), and usbd_get_recv_len().

◆ trans_type

uint8_t usb_ept_info::trans_type

endpoint type: EPT_CONTROL_TYPE, EPT_BULK_TYPE, EPT_INT_TYPE, EPT_ISO_TYPE

Definition at line 503 of file at32f413_usb.h.

Referenced by usb_ept_open(), and usbd_ept_open().

◆ tx_addr

uint16_t usb_ept_info::tx_addr

endpoint tx buffer offset address

Definition at line 505 of file at32f413_usb.h.

Referenced by usb_ept_open(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_defaut_init(), usbd_ept_send(), and usbd_eptn_handler().

The documentation for this struct was generated from the following file:
  • at32f413_usb.h


AT32F413 Firmwary Library: usbd_type Struct Reference

Data Fields
usbd_type Struct Reference
AT32F413_periph_driver » USB » USB_exported_types

type define usb register all More...

#include <at32f413_usb.h>

Data Fields

union {
__IO uint32_t ept [8]
struct {
__IO uint32_t eptaddr: 4
__IO uint32_t txsts: 2
__IO uint32_t txdts: 1
__IO uint32_t txtc: 1
__IO uint32_t exf: 1
__IO uint32_t trans_type: 2
__IO uint32_t setuptc: 1
__IO uint32_t rxsts: 2
__IO uint32_t rxdts: 1
__IO uint32_t rxtc: 1
__IO uint32_t reserved1: 16
} ept_bit [8]
};
usb endpoint register, offset:0x00 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t csrst: 1
__IO uint32_t disusb: 1
__IO uint32_t lpm: 1
__IO uint32_t ssp: 1
__IO uint32_t gresume: 1
__IO uint32_t reserved1: 3
__IO uint32_t lsofien: 1
__IO uint32_t sofien: 1
__IO uint32_t rstien: 1
__IO uint32_t spien: 1
__IO uint32_t wkien: 1
__IO uint32_t beien: 1
__IO uint32_t ucforien: 1
__IO uint32_t tcien: 1
__IO uint32_t reserved2: 16
} ctrl_bit
};
usb control register, offset:0x40 More...
union {
__IO uint32_t intsts
struct {
__IO uint32_t ept_num: 4
__IO uint32_t inout: 1
__IO uint32_t reserved1: 3
__IO uint32_t lsof: 1
__IO uint32_t sof: 1
__IO uint32_t rst: 1
__IO uint32_t sp: 1
__IO uint32_t wk: 1
__IO uint32_t be: 1
__IO uint32_t ucfor: 1
__IO uint32_t tc: 1
__IO uint32_t reserved2: 16
} intsts_bit
};
usb interrupt status register, offset:0x44 More...
union {
__IO uint32_t sofrnum
struct {
__IO uint32_t sofnum: 11
__IO uint32_t lsofnum: 2
__IO uint32_t clck: 1
__IO uint32_t dmsts: 1
__IO uint32_t dpsts: 1
__IO uint32_t reserved1: 16
} sofrnum_bit
};
usb frame number register, offset:0x48 More...
union {
__IO uint32_t devaddr
struct {
__IO uint32_t addr: 7
__IO uint32_t cen: 1
__IO uint32_t reserved1: 24
} devaddr_bit
};
usb device address register, offset:0x4c More...
union {
__IO uint32_t buftbl
struct {
__IO uint32_t reserved1: 3
__IO uint32_t btaddr: 13
__IO uint32_t reserved2: 16
} buftbl_bit
};
usb buffer address register, offset:0x50 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t sofouten: 1
__IO uint32_t reserved1: 31
} cfg_bit
};
usb cfg control register, offset:0x60 More...

Detailed Description

type define usb register all

Definition at line 525 of file at32f413_usb.h.

Field Documentation

◆

union { ... } usbd_type::@735

usb endpoint register, offset:0x00

◆

union { ... } usbd_type::@737

usb control register, offset:0x40

◆

union { ... } usbd_type::@739

usb interrupt status register, offset:0x44

◆

union { ... } usbd_type::@741

usb frame number register, offset:0x48

◆

union { ... } usbd_type::@743

usb device address register, offset:0x4c

◆

union { ... } usbd_type::@745

usb buffer address register, offset:0x50

◆

union { ... } usbd_type::@747

usb cfg control register, offset:0x60

◆ addr

__IO uint32_t usbd_type::addr

Definition at line 625 of file at32f413_usb.h.

Referenced by usb_set_address().

◆ be

__IO uint32_t usbd_type::be

Definition at line 593 of file at32f413_usb.h.

◆ beien

__IO uint32_t usbd_type::beien

Definition at line 570 of file at32f413_usb.h.

◆ btaddr

__IO uint32_t usbd_type::btaddr

Definition at line 640 of file at32f413_usb.h.

◆ buftbl

__IO uint32_t usbd_type::buftbl

Definition at line 636 of file at32f413_usb.h.

Referenced by usb_dev_init().

◆

struct { ... } usbd_type::buftbl_bit

◆ cen

__IO uint32_t usbd_type::cen

Definition at line 626 of file at32f413_usb.h.

Referenced by usb_set_address().

◆ cfg

__IO uint32_t usbd_type::cfg

Definition at line 650 of file at32f413_usb.h.

◆

struct { ... } usbd_type::cfg_bit

◆ clck

__IO uint32_t usbd_type::clck

Definition at line 610 of file at32f413_usb.h.

◆ csrst

__IO uint32_t usbd_type::csrst

Definition at line 559 of file at32f413_usb.h.

Referenced by usb_dev_init().

◆ ctrl

__IO uint32_t usbd_type::ctrl

Definition at line 556 of file at32f413_usb.h.

Referenced by usb_interrupt_enable(), and usbd_irq_handler().

◆

struct { ... } usbd_type::ctrl_bit

Referenced by usb_connect(), usb_dev_init(), usb_disconnect(), usb_enter_suspend(), usb_exit_suspend(), usb_remote_wkup_clear(), and usb_remote_wkup_set().

◆ devaddr

__IO uint32_t usbd_type::devaddr

Definition at line 622 of file at32f413_usb.h.

Referenced by usb_dev_init().

◆

struct { ... } usbd_type::devaddr_bit

Referenced by usb_set_address().

◆ disusb

__IO uint32_t usbd_type::disusb

Definition at line 560 of file at32f413_usb.h.

Referenced by usb_connect(), and usb_disconnect().

◆ dmsts

__IO uint32_t usbd_type::dmsts

Definition at line 611 of file at32f413_usb.h.

◆ dpsts

__IO uint32_t usbd_type::dpsts

Definition at line 612 of file at32f413_usb.h.

◆ ept

__IO uint32_t usbd_type::ept[8]

Definition at line 532 of file at32f413_usb.h.

Referenced by usbd_eptn_handler().

◆

struct { ... } usbd_type::ept_bit[8]

Referenced by usbd_ept_send().

◆ ept_num

__IO uint32_t usbd_type::ept_num

Definition at line 585 of file at32f413_usb.h.

◆ eptaddr

__IO uint32_t usbd_type::eptaddr

Definition at line 535 of file at32f413_usb.h.

◆ exf

__IO uint32_t usbd_type::exf

Definition at line 539 of file at32f413_usb.h.

◆ gresume

__IO uint32_t usbd_type::gresume

Definition at line 563 of file at32f413_usb.h.

Referenced by usb_remote_wkup_clear(), and usb_remote_wkup_set().

◆ inout

__IO uint32_t usbd_type::inout

Definition at line 586 of file at32f413_usb.h.

◆ intsts

__IO uint32_t usbd_type::intsts

Definition at line 582 of file at32f413_usb.h.

Referenced by usb_dev_init(), usb_flag_clear(), usb_flag_get(), usbd_ept_loop_handler(), and usbd_irq_handler().

◆

struct { ... } usbd_type::intsts_bit

◆ lpm

__IO uint32_t usbd_type::lpm

Definition at line 561 of file at32f413_usb.h.

Referenced by usb_enter_suspend(), and usb_exit_suspend().

◆ lsof

__IO uint32_t usbd_type::lsof

Definition at line 588 of file at32f413_usb.h.

◆ lsofien

__IO uint32_t usbd_type::lsofien

Definition at line 565 of file at32f413_usb.h.

◆ lsofnum

__IO uint32_t usbd_type::lsofnum

Definition at line 609 of file at32f413_usb.h.

◆ reserved1

__IO uint32_t usbd_type::reserved1

Definition at line 545 of file at32f413_usb.h.

◆ reserved2

__IO uint32_t usbd_type::reserved2

Definition at line 573 of file at32f413_usb.h.

◆ rst

__IO uint32_t usbd_type::rst

Definition at line 590 of file at32f413_usb.h.

◆ rstien

__IO uint32_t usbd_type::rstien

Definition at line 567 of file at32f413_usb.h.

◆ rxdts

__IO uint32_t usbd_type::rxdts

Definition at line 543 of file at32f413_usb.h.

◆ rxsts

__IO uint32_t usbd_type::rxsts

Definition at line 542 of file at32f413_usb.h.

◆ rxtc

__IO uint32_t usbd_type::rxtc

Definition at line 544 of file at32f413_usb.h.

◆ setuptc

__IO uint32_t usbd_type::setuptc

Definition at line 541 of file at32f413_usb.h.

◆ sof

__IO uint32_t usbd_type::sof

Definition at line 589 of file at32f413_usb.h.

◆ sofien

__IO uint32_t usbd_type::sofien

Definition at line 566 of file at32f413_usb.h.

◆ sofnum

__IO uint32_t usbd_type::sofnum

Definition at line 608 of file at32f413_usb.h.

◆ sofouten

__IO uint32_t usbd_type::sofouten

Definition at line 653 of file at32f413_usb.h.

◆ sofrnum

__IO uint32_t usbd_type::sofrnum

Definition at line 605 of file at32f413_usb.h.

◆

struct { ... } usbd_type::sofrnum_bit

◆ sp

__IO uint32_t usbd_type::sp

Definition at line 591 of file at32f413_usb.h.

◆ spien

__IO uint32_t usbd_type::spien

Definition at line 568 of file at32f413_usb.h.

◆ ssp

__IO uint32_t usbd_type::ssp

Definition at line 562 of file at32f413_usb.h.

Referenced by usb_enter_suspend(), and usb_exit_suspend().

◆ tc

__IO uint32_t usbd_type::tc

Definition at line 595 of file at32f413_usb.h.

◆ tcien

__IO uint32_t usbd_type::tcien

Definition at line 572 of file at32f413_usb.h.

◆ trans_type

__IO uint32_t usbd_type::trans_type

Definition at line 540 of file at32f413_usb.h.

◆ txdts

__IO uint32_t usbd_type::txdts

Definition at line 537 of file at32f413_usb.h.

Referenced by usbd_ept_send().

◆ txsts

__IO uint32_t usbd_type::txsts

Definition at line 536 of file at32f413_usb.h.

◆ txtc

__IO uint32_t usbd_type::txtc

Definition at line 538 of file at32f413_usb.h.

◆ ucfor

__IO uint32_t usbd_type::ucfor

Definition at line 594 of file at32f413_usb.h.

◆ ucforien

__IO uint32_t usbd_type::ucforien

Definition at line 571 of file at32f413_usb.h.

◆ wk

__IO uint32_t usbd_type::wk

Definition at line 592 of file at32f413_usb.h.

◆ wkien

__IO uint32_t usbd_type::wkien

Definition at line 569 of file at32f413_usb.h.

The documentation for this struct was generated from the following file:
  • at32f413_usb.h


AT32F413 Firmwary Library: USB_exported_functions

Functions
USB_exported_functions
AT32F413_periph_driver » USB

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Detailed Description

Function Documentation

◆ usb_buffer_free()

void usb_buffer_free ( void )

free usb endpoint buffer

Parameters
none
Return values
none

Definition at line 484 of file at32f413_usb.c.

Referenced by usbd_reset_handler().

◆ usb_buffer_malloc()

uint16_t usb_buffer_malloc ( uint16_t maxpacket )

usb auto malloc endpoint buffer

Parameters
mapacket endpoint support max packet size
Return values
none

Definition at line 472 of file at32f413_usb.c.

Referenced by usbd_ept_buf_auto_define().

◆ usb_connect()

void usb_connect ( usbd_type * usbx )

connect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 79 of file at32f413_usb.c.

Referenced by usbd_connect().

◆ usb_dev_init()

void usb_dev_init ( usbd_type * usbx )

initialize usb peripheral controller register

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer table address

< usb sof interrupt

< usb reset interrupt

< usb suspend interrupt

< usb wakeup interrupt

< usb transmission completed interrupt

Definition at line 56 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_disconnect()

void usb_disconnect ( usbd_type * usbx )

disconnect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 91 of file at32f413_usb.c.

Referenced by usbd_disconnect().

◆ usb_enter_suspend()

void usb_enter_suspend ( usbd_type * usbx )

usb device enter suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 427 of file at32f413_usb.c.

Referenced by usbd_enter_suspend().

◆ usb_ept_close()

void usb_ept_close | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

close usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 256 of file at32f413_usb.c.

Referenced by usbd_ept_close().

◆ usb_ept_open()

void usb_ept_open | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

open usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb endpoint address

< usb endpoint transfer type control

< usb endpoint transfer type bulk

< usb endpoint transfer type interrupt

< usb endpoint transfer type iso

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb transfer type

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 137 of file at32f413_usb.c.

Referenced by usbd_ept_open().

◆ usb_ept_stall()

void usb_ept_stall | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

set endpoint tx or rx status to stall

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status stall

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status stall

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status stall

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status stall

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 409 of file at32f413_usb.c.

◆ usb_exit_suspend()

void usb_exit_suspend ( usbd_type * usbx )

usb device exit suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 439 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup(), and usbd_wakeup_handler().

◆ usb_flag_clear()

void usb_flag_clear | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

clear flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 536 of file at32f413_usb.c.

Referenced by usbd_irq_handler().

◆ usb_flag_get()

flag_status usb_flag_get | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

get flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 505 of file at32f413_usb.c.

◆ usb_interrupt_enable()

void usb_interrupt_enable | ( | usbd_type * | usbx,
 |  | uint16_t | interrupt,
 |  | confirm_state | new_state
 | ) |  |

usb interrupt enable

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
interrupt this parameter can be any combination of the following values:
  • USB_LSOF_INT
  • USB_SOF_INT
  • USB_RST_INT
  • USB_SP_INT
  • USB_WK_INT
  • USB_BE_INT
  • USB_UCFOR_INT
  • USB_TC_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 377 of file at32f413_usb.c.

Referenced by usb_dev_init().

◆ usb_read_packet()

void usb_read_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

read data from usb buffer to user buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint rx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 341 of file at32f413_usb.c.

Referenced by usbd_eptn_handler().

◆ usb_remote_wkup_clear()

void usb_remote_wkup_clear ( usbd_type * usbx )

usb remote wakeup clear

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 462 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_remote_wkup_set()

void usb_remote_wkup_set ( usbd_type * usbx )

usb remote wakeup set

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 451 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_set_address()

void usb_set_address | ( | usbd_type * | usbx,
 |  | uint8_t | address
 | ) |  |

set the host assignment address

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
address | host assignment address
Return values
none

Definition at line 396 of file at32f413_usb.c.

Referenced by usbd_eptn_handler(), usbd_reset_handler(), and usbd_set_device_addr().

◆ usb_usbbufs_enable()

void usb_usbbufs_enable | ( | usbd_type * | usbx,
 |  | confirm_state | state
 | ) |  |

mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes.

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer extend address

< usb buffer address

Definition at line 114 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_write_packet()

void usb_write_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

write data from user memory to usb buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint tx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 314 of file at32f413_usb.c.

Referenced by usbd_ept_send().


AT32F413 Firmwary Library: USB_private_functions

Macros | Functions | Variables
USB_private_functions
AT32F413_periph_driver » USB

Macros

#define USB_ENDP_DESC_TABLE_OFFSET 0x40
usb packet buffer start address More...

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Variables

uint32_t | g_usb_packet_address = 0x40006000
static uint16_t | g_usb_offset_addr = 0x40

Detailed Description

Macro Definition Documentation

◆ USB_ENDP_DESC_TABLE_OFFSET

#define USB_ENDP_DESC_TABLE_OFFSET 0x40

usb packet buffer start address

Definition at line 46 of file at32f413_usb.c.

Function Documentation

◆ usb_buffer_free()

void usb_buffer_free ( void )

free usb endpoint buffer

Parameters
none
Return values
none

Definition at line 484 of file at32f413_usb.c.

Referenced by usbd_reset_handler().

◆ usb_buffer_malloc()

uint16_t usb_buffer_malloc ( uint16_t maxpacket )

usb auto malloc endpoint buffer

Parameters
mapacket endpoint support max packet size
Return values
none

Definition at line 472 of file at32f413_usb.c.

Referenced by usbd_ept_buf_auto_define().

◆ usb_connect()

void usb_connect ( usbd_type * usbx )

connect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 79 of file at32f413_usb.c.

Referenced by usbd_connect().

◆ usb_dev_init()

void usb_dev_init ( usbd_type * usbx )

initialize usb peripheral controller register

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer table address

< usb sof interrupt

< usb reset interrupt

< usb suspend interrupt

< usb wakeup interrupt

< usb transmission completed interrupt

Definition at line 56 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_disconnect()

void usb_disconnect ( usbd_type * usbx )

disconnect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 91 of file at32f413_usb.c.

Referenced by usbd_disconnect().

◆ usb_enter_suspend()

void usb_enter_suspend ( usbd_type * usbx )

usb device enter suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 427 of file at32f413_usb.c.

Referenced by usbd_enter_suspend().

◆ usb_ept_close()

void usb_ept_close | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

close usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 256 of file at32f413_usb.c.

Referenced by usbd_ept_close().

◆ usb_ept_open()

void usb_ept_open | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

open usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb endpoint address

< usb endpoint transfer type control

< usb endpoint transfer type bulk

< usb endpoint transfer type interrupt

< usb endpoint transfer type iso

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb transfer type

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 137 of file at32f413_usb.c.

Referenced by usbd_ept_open().

◆ usb_ept_stall()

void usb_ept_stall | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

set endpoint tx or rx status to stall

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status stall

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status stall

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status stall

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status stall

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 409 of file at32f413_usb.c.

◆ usb_exit_suspend()

void usb_exit_suspend ( usbd_type * usbx )

usb device exit suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 439 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup(), and usbd_wakeup_handler().

◆ usb_flag_clear()

void usb_flag_clear | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

clear flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 536 of file at32f413_usb.c.

Referenced by usbd_irq_handler().

◆ usb_flag_get()

flag_status usb_flag_get | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

get flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 505 of file at32f413_usb.c.

◆ usb_interrupt_enable()

void usb_interrupt_enable | ( | usbd_type * | usbx,
 |  | uint16_t | interrupt,
 |  | confirm_state | new_state
 | ) |  |

usb interrupt enable

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
interrupt this parameter can be any combination of the following values:
  • USB_LSOF_INT
  • USB_SOF_INT
  • USB_RST_INT
  • USB_SP_INT
  • USB_WK_INT
  • USB_BE_INT
  • USB_UCFOR_INT
  • USB_TC_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 377 of file at32f413_usb.c.

Referenced by usb_dev_init().

◆ usb_read_packet()

void usb_read_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

read data from usb buffer to user buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint rx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 341 of file at32f413_usb.c.

Referenced by usbd_eptn_handler().

◆ usb_remote_wkup_clear()

void usb_remote_wkup_clear ( usbd_type * usbx )

usb remote wakeup clear

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 462 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_remote_wkup_set()

void usb_remote_wkup_set ( usbd_type * usbx )

usb remote wakeup set

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 451 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_set_address()

void usb_set_address | ( | usbd_type * | usbx,
 |  | uint8_t | address
 | ) |  |

set the host assignment address

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
address | host assignment address
Return values
none

Definition at line 396 of file at32f413_usb.c.

Referenced by usbd_eptn_handler(), usbd_reset_handler(), and usbd_set_device_addr().

◆ usb_usbbufs_enable()

void usb_usbbufs_enable | ( | usbd_type * | usbx,
 |  | confirm_state | state
 | ) |  |

mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes.

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer extend address

< usb buffer address

Definition at line 114 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_write_packet()

void usb_write_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

write data from user memory to usb buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint tx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 314 of file at32f413_usb.c.

Referenced by usbd_ept_send().

Variable Documentation

◆ g_usb_offset_addr

uint16_t g_usb_offset_addr = 0x40
static

Definition at line 48 of file at32f413_usb.c.

Referenced by usb_buffer_free(), and usb_buffer_malloc().

◆ g_usb_packet_address

uint32_t g_usb_packet_address = 0x40006000

usb buffer address

Definition at line 47 of file at32f413_usb.c.

Referenced by usb_read_packet(), usb_usbbufs_enable(), and usb_write_packet().


AT32F413 Firmwary Library: WDT

Modules | Macros
WDT
AT32F413_periph_driver

WDT driver modules. More...

Modules

WDT_flags_definition
wdt flag
WDT_exported_types
WDT_exported_functions
WDT_private_functions

Macros

#define WDT ((wdt_type *) WDT_BASE)

Detailed Description

WDT driver modules.

Macro Definition Documentation

◆ WDT

#define WDT ((wdt_type *) WDT_BASE)

Definition at line 152 of file at32f413_wdt.h.


AT32F413 Firmwary Library: WDT_flags_definition

Macros
WDT_flags_definition
AT32F413_periph_driver » WDT

wdt flag More...

Macros

#define | WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
#define | WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)

Detailed Description

wdt flag

Macro Definition Documentation

◆ WDT_DIVF_UPDATE_FLAG

#define WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)

wdt division value update complete flag

Definition at line 51 of file at32f413_wdt.h.

◆ WDT_RLDF_UPDATE_FLAG

#define WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)

wdt reload value update complete flag

Definition at line 52 of file at32f413_wdt.h.


AT32F413 Firmwary Library: WDT_exported_types

Data Structures | Enumerations
WDT_exported_types
AT32F413_periph_driver » WDT

Data Structures

struct wdt_type
type define wdt register all More...

Enumerations

enum wdt_division_type {
WDT_CLK_DIV_4 = 0x00 , WDT_CLK_DIV_8 = 0x01 , WDT_CLK_DIV_16 = 0x02 , WDT_CLK_DIV_32 = 0x03 ,
WDT_CLK_DIV_64 = 0x04 , WDT_CLK_DIV_128 = 0x05 , WDT_CLK_DIV_256 = 0x06
}
wdt division value type More...
enum wdt_cmd_value_type { WDT_CMD_LOCK = 0x0000 , WDT_CMD_UNLOCK = 0x5555 , WDT_CMD_ENABLE = 0xCCCC , WDT_CMD_RELOAD = 0xAAAA }
wdt cmd value type More...

Detailed Description

Enumeration Type Documentation

◆ wdt_cmd_value_type

enum wdt_cmd_value_type

wdt cmd value type

Enumerator
WDT_CMD_LOCK | disable write protection command
WDT_CMD_UNLOCK | enable write protection command
WDT_CMD_ENABLE | enable wdt command
WDT_CMD_RELOAD | reload command

Definition at line 79 of file at32f413_wdt.h.

◆ wdt_division_type

enum wdt_division_type

wdt division value type

Enumerator
WDT_CLK_DIV_4 | wdt clock divider value is 4
WDT_CLK_DIV_8 | wdt clock divider value is 8
WDT_CLK_DIV_16 | wdt clock divider value is 16
WDT_CLK_DIV_32 | wdt clock divider value is 32
WDT_CLK_DIV_64 | wdt clock divider value is 64
WDT_CLK_DIV_128 | wdt clock divider value is 128
WDT_CLK_DIV_256 | wdt clock divider value is 256

Definition at line 65 of file at32f413_wdt.h.


AT32F413 Firmwary Library: wdt_type Struct Reference

Data Fields
wdt_type Struct Reference
AT32F413_periph_driver » WDT » WDT_exported_types

type define wdt register all More...

#include <at32f413_wdt.h>

Data Fields

union {
__IO uint32_t cmd
struct {
__IO uint32_t cmd: 16
__IO uint32_t reserved1: 16
} cmd_bit
};
wdt cmd register, offset:0x00 More...
union {
__IO uint32_t div
struct {
__IO uint32_t div: 3
__IO uint32_t reserved1: 29
} div_bit
};
wdt div register, offset:0x04 More...
union {
__IO uint32_t rld
struct {
__IO uint32_t rld: 12
__IO uint32_t reserved1: 20
} rld_bit
};
wdt rld register, offset:0x08 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t divf: 1
__IO uint32_t rldf: 1
__IO uint32_t reserved1: 30
} sts_bit
};
wdt sts register, offset:0x0C More...

Detailed Description

type define wdt register all

Definition at line 90 of file at32f413_wdt.h.

Field Documentation

◆

union { ... } wdt_type::@756

wdt cmd register, offset:0x00

◆

union { ... } wdt_type::@758

wdt div register, offset:0x04

◆

union { ... } wdt_type::@760

wdt rld register, offset:0x08

◆

union { ... } wdt_type::@762

wdt sts register, offset:0x0C

◆ cmd

__IO uint32_t wdt_type::cmd

Definition at line 98 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::cmd_bit

◆ div

__IO uint32_t wdt_type::div

Definition at line 111 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::div_bit

◆ divf

__IO uint32_t wdt_type::divf

Definition at line 140 of file at32f413_wdt.h.

◆ reserved1

__IO uint32_t wdt_type::reserved1

Definition at line 102 of file at32f413_wdt.h.

◆ rld

__IO uint32_t wdt_type::rld

Definition at line 124 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::rld_bit

◆ rldf

__IO uint32_t wdt_type::rldf

Definition at line 141 of file at32f413_wdt.h.

◆ sts

__IO uint32_t wdt_type::sts

Definition at line 137 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::sts_bit
The documentation for this struct was generated from the following file:
  • at32f413_wdt.h


AT32F413 Firmwary Library: WDT_exported_functions

Functions
WDT_exported_functions
AT32F413_periph_driver » WDT

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

Function Documentation

◆ wdt_counter_reload()

void wdt_counter_reload ( void )

reload wdt counter

Parameters
none
Return values
none

Definition at line 57 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_divider_set()

void wdt_divider_set ( wdt_division_type division )

set wdt division divider

Parameters
division this parameter can be one of the following values:
  • WDT_CLK_DIV_4
  • WDT_CLK_DIV_8
  • WDT_CLK_DIV_16
  • WDT_CLK_DIV_32
  • WDT_CLK_DIV_64
  • WDT_CLK_DIV_128
  • WDT_CLK_DIV_256
Return values
none

Definition at line 85 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_enable()

void wdt_enable ( void )

wdt enable ,the reload value will be sent to the counter

Parameters
none
Return values
none

Definition at line 47 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_flag_get()

flag_status wdt_flag_get ( uint16_t wdt_flag )

get wdt flag

Parameters
wdt_flag this parameter can be one of the following values:
  • WDT_DIVF_UPDATE_FLAG: division value update complete flag.
  • WDT_RLDF_UPDATE_FLAG: reload value update complete flag.
Return values
state of wdt flag

Definition at line 115 of file at32f413_wdt.c.

◆ wdt_register_write_enable()

void wdt_register_write_enable ( confirm_state new_state )

enable or disable wdt cmd register write

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 95 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_reload_value_set()

void wdt_reload_value_set ( uint16_t reload_value )

set wdt counter reload value

Parameters
reload_value (0x0000~0x0FFF)
Return values
none

Definition at line 67 of file at32f413_wdt.c.

Referenced by main().


AT32F413 Firmwary Library: WDT_private_functions

Functions
WDT_private_functions
AT32F413_periph_driver » WDT

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

Function Documentation

◆ wdt_counter_reload()

void wdt_counter_reload ( void )

reload wdt counter

Parameters
none
Return values
none

Definition at line 57 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_divider_set()

void wdt_divider_set ( wdt_division_type division )

set wdt division divider

Parameters
division this parameter can be one of the following values:
  • WDT_CLK_DIV_4
  • WDT_CLK_DIV_8
  • WDT_CLK_DIV_16
  • WDT_CLK_DIV_32
  • WDT_CLK_DIV_64
  • WDT_CLK_DIV_128
  • WDT_CLK_DIV_256
Return values
none

Definition at line 85 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_enable()

void wdt_enable ( void )

wdt enable ,the reload value will be sent to the counter

Parameters
none
Return values
none

Definition at line 47 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_flag_get()

flag_status wdt_flag_get ( uint16_t wdt_flag )

get wdt flag

Parameters
wdt_flag this parameter can be one of the following values:
  • WDT_DIVF_UPDATE_FLAG: division value update complete flag.
  • WDT_RLDF_UPDATE_FLAG: reload value update complete flag.
Return values
state of wdt flag

Definition at line 115 of file at32f413_wdt.c.

◆ wdt_register_write_enable()

void wdt_register_write_enable ( confirm_state new_state )

enable or disable wdt cmd register write

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 95 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_reload_value_set()

void wdt_reload_value_set ( uint16_t reload_value )

set wdt counter reload value

Parameters
reload_value (0x0000~0x0FFF)
Return values
none

Definition at line 67 of file at32f413_wdt.c.

Referenced by main().


AT32F413 Firmwary Library: WWDT

Modules | Macros
WWDT
AT32F413_periph_driver

WWDT driver modules. More...

Modules

WWDT_enable_bit_definition
wwdt enable bit
WWDT_exported_types
WWDT_exported_functions
WWDT_private_functions

Macros

#define WWDT ((wwdt_type *) WWDT_BASE)

Detailed Description

WWDT driver modules.

Macro Definition Documentation

◆ WWDT

#define WWDT ((wwdt_type *) WWDT_BASE)

Definition at line 125 of file at32f413_wwdt.h.


AT32F413 Firmwary Library: WWDT_enable_bit_definition

Macros
WWDT_enable_bit_definition
AT32F413_periph_driver » WWDT

wwdt enable bit More...

Macros

#define WWDT_EN_BIT ((uint32_t)0x00000080)

Detailed Description

wwdt enable bit

Macro Definition Documentation

◆ WWDT_EN_BIT

#define WWDT_EN_BIT ((uint32_t)0x00000080)

wwdt enable bit

Definition at line 50 of file at32f413_wwdt.h.


AT32F413 Firmwary Library: WWDT_exported_types

Data Structures | Enumerations
WWDT_exported_types
AT32F413_periph_driver » WWDT

Data Structures

struct wwdt_type
type define wwdt register all More...

Enumerations

enum wwdt_division_type { WWDT_PCLK1_DIV_4096 = 0x00 , WWDT_PCLK1_DIV_8192 = 0x01 , WWDT_PCLK1_DIV_16384 = 0x02 , WWDT_PCLK1_DIV_32768 = 0x03 }
wwdt division type More...

Detailed Description

Enumeration Type Documentation

◆ wwdt_division_type

enum wwdt_division_type

wwdt division type

Enumerator
WWDT_PCLK1_DIV_4096 | wwdt counter clock = (pclk1/4096)/1)
WWDT_PCLK1_DIV_8192 | wwdt counter clock = (pclk1/4096)/2)
WWDT_PCLK1_DIV_16384 | wwdt counter clock = (pclk1/4096)/4)
WWDT_PCLK1_DIV_32768 | wwdt counter clock = (pclk1/4096)/8)

Definition at line 63 of file at32f413_wwdt.h.


AT32F413 Firmwary Library: wwdt_type Struct Reference

Data Fields
wwdt_type Struct Reference
AT32F413_periph_driver » WWDT » WWDT_exported_types

type define wwdt register all More...

#include <at32f413_wwdt.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t cnt: 7
__IO uint32_t wwdten: 1
__IO uint32_t reserved1: 24
} ctrl_bit
};
wwdt ctrl register, offset:0x00 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t win: 7
__IO uint32_t div: 2
__IO uint32_t rldien: 1
__IO uint32_t reserved1: 22
} cfg_bit
};
wwdt cfg register, offset:0x04 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t rldf: 1
__IO uint32_t reserved1: 31
} sts_bit
};
wwdt cfg register, offset:0x08 More...

Detailed Description

type define wwdt register all

Definition at line 74 of file at32f413_wwdt.h.

Field Documentation

◆

union { ... } wwdt_type::@768

wwdt ctrl register, offset:0x00

◆

union { ... } wwdt_type::@770

wwdt cfg register, offset:0x04

◆

union { ... } wwdt_type::@772

wwdt cfg register, offset:0x08

◆ cfg

__IO uint32_t wwdt_type::cfg

Definition at line 96 of file at32f413_wwdt.h.

◆

struct { ... } wwdt_type::cfg_bit

◆ cnt

__IO uint32_t wwdt_type::cnt

Definition at line 85 of file at32f413_wwdt.h.

◆ ctrl

__IO uint32_t wwdt_type::ctrl

Definition at line 82 of file at32f413_wwdt.h.

◆

struct { ... } wwdt_type::ctrl_bit

◆ div

__IO uint32_t wwdt_type::div

Definition at line 100 of file at32f413_wwdt.h.

◆ reserved1

__IO uint32_t wwdt_type::reserved1

Definition at line 87 of file at32f413_wwdt.h.

◆ rldf

__IO uint32_t wwdt_type::rldf

Definition at line 114 of file at32f413_wwdt.h.

◆ rldien

__IO uint32_t wwdt_type::rldien

Definition at line 101 of file at32f413_wwdt.h.

◆ sts

__IO uint32_t wwdt_type::sts

Definition at line 111 of file at32f413_wwdt.h.

◆

struct { ... } wwdt_type::sts_bit

◆ win

__IO uint32_t wwdt_type::win

Definition at line 99 of file at32f413_wwdt.h.

◆ wwdten

__IO uint32_t wwdt_type::wwdten

Definition at line 86 of file at32f413_wwdt.h.

The documentation for this struct was generated from the following file:
  • at32f413_wwdt.h


AT32F413 Firmwary Library: WWDT_exported_functions

Functions
WWDT_exported_functions
AT32F413_periph_driver » WWDT

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

Function Documentation

◆ wwdt_counter_set()

void wwdt_counter_set ( uint8_t wwdt_cnt )

wwdt counter value set

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

Definition at line 112 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_divider_set()

void wwdt_divider_set ( wwdt_division_type division )

wwdt division set

Parameters
division this parameter can be one of the following values:
  • WWDT_PCLK1_DIV_4096 (wwdt counter clock = (pclk1/4096)/1)
  • WWDT_PCLK1_DIV_8192 (wwdt counter clock = (pclk1/4096)/2)
  • WWDT_PCLK1_DIV_16384 (wwdt counter clock = (pclk1/4096)/4)
  • WWDT_PCLK1_DIV_32768 (wwdt counter clock = (pclk1/4096)/8)
Return values
none

Definition at line 62 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_enable()

void wwdt_enable ( uint8_t wwdt_cnt )

wwdt enable and the counter value load

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

< wwdt enable bit

Definition at line 82 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_flag_clear()

void wwdt_flag_clear ( void )

wwdt reload counter interrupt flag clear

Parameters
none
Return values
none

Definition at line 72 of file at32f413_wwdt.c.

◆ wwdt_flag_get()

flag_status wwdt_flag_get ( void )

wwdt reload counter interrupt flag get

Parameters
none
Return values
state of reload counter interrupt flag

Definition at line 102 of file at32f413_wwdt.c.

◆ wwdt_interrupt_enable()

void wwdt_interrupt_enable ( void )

wwdt reload counter interrupt enable

Parameters
none
Return values
none

Definition at line 92 of file at32f413_wwdt.c.

◆ wwdt_reset()

void wwdt_reset ( void )

wwdt reset by crm reset register

Return values
none

Definition at line 46 of file at32f413_wwdt.c.

◆ wwdt_window_counter_set()

void wwdt_window_counter_set ( uint8_t window_cnt )

wwdt window counter value set

Parameters
window_cnt (0x40~0x7f)
Return values
none

Definition at line 122 of file at32f413_wwdt.c.

Referenced by main().


AT32F413 Firmwary Library: WWDT_private_functions

Functions
WWDT_private_functions
AT32F413_periph_driver » WWDT

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

Function Documentation

◆ wwdt_counter_set()

void wwdt_counter_set ( uint8_t wwdt_cnt )

wwdt counter value set

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

Definition at line 112 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_divider_set()

void wwdt_divider_set ( wwdt_division_type division )

wwdt division set

Parameters
division this parameter can be one of the following values:
  • WWDT_PCLK1_DIV_4096 (wwdt counter clock = (pclk1/4096)/1)
  • WWDT_PCLK1_DIV_8192 (wwdt counter clock = (pclk1/4096)/2)
  • WWDT_PCLK1_DIV_16384 (wwdt counter clock = (pclk1/4096)/4)
  • WWDT_PCLK1_DIV_32768 (wwdt counter clock = (pclk1/4096)/8)
Return values
none

Definition at line 62 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_enable()

void wwdt_enable ( uint8_t wwdt_cnt )

wwdt enable and the counter value load

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

< wwdt enable bit

Definition at line 82 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_flag_clear()

void wwdt_flag_clear ( void )

wwdt reload counter interrupt flag clear

Parameters
none
Return values
none

Definition at line 72 of file at32f413_wwdt.c.

◆ wwdt_flag_get()

flag_status wwdt_flag_get ( void )

wwdt reload counter interrupt flag get

Parameters
none
Return values
state of reload counter interrupt flag

Definition at line 102 of file at32f413_wwdt.c.

◆ wwdt_interrupt_enable()

void wwdt_interrupt_enable ( void )

wwdt reload counter interrupt enable

Parameters
none
Return values
none

Definition at line 92 of file at32f413_wwdt.c.

◆ wwdt_reset()

void wwdt_reset ( void )

wwdt reset by crm reset register

Return values
none

Definition at line 46 of file at32f413_wwdt.c.

◆ wwdt_window_counter_set()

void wwdt_window_counter_set ( uint8_t window_cnt )

wwdt window counter value set

Parameters
window_cnt (0x40~0x7f)
Return values
none

Definition at line 122 of file at32f413_wwdt.c.

Referenced by main().


AT32F413 Firmwary Library: AT32F413_middlewares_i2c_application_library

Modules | Macros | Functions
AT32F413_middlewares_i2c_application_library

Modules

I2C_library_event_check_flag
I2C_library_memory_address_width_mode
I2C_library_transmission_mode
I2C_library_status_code
I2C_library_handler
I2C_library_exported_functions

Macros

#define | DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel More...
#define | DMA_GET_HT_FLAG(DMA_CHANNEL)
get the dma half transfer flag through the channel More...
#define | DMA_GET_TERR_FLAG(DMA_CHANNEL)
get the dma transfer error flag through the channel More...
#define | I2C_START 0
i2c transmission status More...
#define | I2C_END 1

Functions

__WEAK void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set More...
void | i2c_dma_config (i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint8_t *pdata, uint16_t size)
dma transfer cofiguration. More...
i2c_status_type | i2c_master_write_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master transmits mode. More...
i2c_status_type | i2c_master_read_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master receive mode. More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_memory_address_send (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t mem_address, int32_t timeout)
send memory address. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_master_tx_isr_int (i2c_handle_type *hi2c)
master transfer mode interrupt procession function More...
void | i2c_master_rx_isr_int (i2c_handle_type *hi2c)
master receive mode interrupt procession function More...
void | i2c_slave_tx_isr_int (i2c_handle_type *hi2c)
slave transfer mode interrupt procession function More...
void | i2c_slave_rx_isr_int (i2c_handle_type *hi2c)
slave receive mode interrupt procession function More...
void | i2c_master_tx_isr_dma (i2c_handle_type *hi2c)
master interrupt processing function in dma mode. More...
void | i2c_slave_tx_rx_isr_dma (i2c_handle_type *hi2c)
slave interrupt processing function in dma mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...

Detailed Description

< define to prevent recursive inclusion ----------------------------------—

Macro Definition Documentation

◆ DMA_GET_HT_FLAG

#define DMA_GET_HT_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_HDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_HDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_HDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_HDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_HDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_HDT6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_HDT7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_HDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_HDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_HDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_HDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_HDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_HDT6_FLAG : \
DMA2_HDT7_FLAG)
DMA1_HDT5_FLAG
#define DMA1_HDT5_FLAG
Definition: at32f413_dma.h:97
DMA2_HDT6_FLAG
#define DMA2_HDT6_FLAG
Definition: at32f413_dma.h:130
DMA1_HDT7_FLAG
#define DMA1_HDT7_FLAG
Definition: at32f413_dma.h:105
DMA2_HDT3_FLAG
#define DMA2_HDT3_FLAG
Definition: at32f413_dma.h:118
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f413_dma.h:93
DMA2_HDT5_FLAG
#define DMA2_HDT5_FLAG
Definition: at32f413_dma.h:126
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f413_dma.h:89
DMA2_HDT1_FLAG
#define DMA2_HDT1_FLAG
Definition: at32f413_dma.h:110
DMA2_HDT2_FLAG
#define DMA2_HDT2_FLAG
Definition: at32f413_dma.h:114
DMA1_HDT1_FLAG
#define DMA1_HDT1_FLAG
Definition: at32f413_dma.h:81
DMA2_HDT4_FLAG
#define DMA2_HDT4_FLAG
Definition: at32f413_dma.h:122
DMA2_HDT7_FLAG
#define DMA2_HDT7_FLAG
Definition: at32f413_dma.h:134
DMA1_HDT2_FLAG
#define DMA1_HDT2_FLAG
Definition: at32f413_dma.h:85
DMA1_HDT6_FLAG
#define DMA1_HDT6_FLAG
Definition: at32f413_dma.h:101
DMA2_CHANNEL5
#define DMA2_CHANNEL5
Definition: at32f413_dma.h:491
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:482
DMA2_CHANNEL2
#define DMA2_CHANNEL2
Definition: at32f413_dma.h:488
DMA2_CHANNEL3
#define DMA2_CHANNEL3
Definition: at32f413_dma.h:489
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
DMA2_CHANNEL6
#define DMA2_CHANNEL6
Definition: at32f413_dma.h:492
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:479
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f413_dma.h:490
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f413_dma.h:487
DMA1_CHANNEL6
#define DMA1_CHANNEL6
Definition: at32f413_dma.h:483
DMA1_CHANNEL7
#define DMA1_CHANNEL7
Definition: at32f413_dma.h:484

get the dma half transfer flag through the channel

Definition at line 54 of file i2c_application.c.

◆ DMA_GET_TC_FLAG

#define DMA_GET_TC_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_FDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_FDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_FDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_FDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_FDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_FDT6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_FDT7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_FDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_FDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_FDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_FDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_FDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_FDT6_FLAG : \
DMA2_FDT7_FLAG)
DMA1_FDT7_FLAG
#define DMA1_FDT7_FLAG
Definition: at32f413_dma.h:104
DMA2_FDT7_FLAG
#define DMA2_FDT7_FLAG
Definition: at32f413_dma.h:133
DMA2_FDT4_FLAG
#define DMA2_FDT4_FLAG
Definition: at32f413_dma.h:121
DMA2_FDT6_FLAG
#define DMA2_FDT6_FLAG
Definition: at32f413_dma.h:129
DMA2_FDT2_FLAG
#define DMA2_FDT2_FLAG
Definition: at32f413_dma.h:113
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
DMA1_FDT6_FLAG
#define DMA1_FDT6_FLAG
Definition: at32f413_dma.h:100
DMA2_FDT5_FLAG
#define DMA2_FDT5_FLAG
Definition: at32f413_dma.h:125
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f413_dma.h:109
DMA2_FDT3_FLAG
#define DMA2_FDT3_FLAG
Definition: at32f413_dma.h:117
DMA1_FDT5_FLAG
#define DMA1_FDT5_FLAG
Definition: at32f413_dma.h:96
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:84
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:88

get the dma transfer complete flag through the channel

Definition at line 35 of file i2c_application.c.

◆ DMA_GET_TERR_FLAG

#define DMA_GET_TERR_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_DTERR1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_DTERR2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_DTERR3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_DTERR4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_DTERR5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_DTERR6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_DTERR7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_DTERR1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_DTERR2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_DTERR3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_DTERR4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_DTERR5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_DTERR6_FLAG : \
DMA2_DTERR7_FLAG)
DMA1_DTERR7_FLAG
#define DMA1_DTERR7_FLAG
Definition: at32f413_dma.h:106
DMA1_DTERR3_FLAG
#define DMA1_DTERR3_FLAG
Definition: at32f413_dma.h:90
DMA2_DTERR4_FLAG
#define DMA2_DTERR4_FLAG
Definition: at32f413_dma.h:123
DMA2_DTERR7_FLAG
#define DMA2_DTERR7_FLAG
Definition: at32f413_dma.h:135
DMA1_DTERR1_FLAG
#define DMA1_DTERR1_FLAG
Definition: at32f413_dma.h:82
DMA1_DTERR4_FLAG
#define DMA1_DTERR4_FLAG
Definition: at32f413_dma.h:94
DMA2_DTERR6_FLAG
#define DMA2_DTERR6_FLAG
Definition: at32f413_dma.h:131
DMA1_DTERR6_FLAG
#define DMA1_DTERR6_FLAG
Definition: at32f413_dma.h:102
DMA1_DTERR5_FLAG
#define DMA1_DTERR5_FLAG
Definition: at32f413_dma.h:98
DMA1_DTERR2_FLAG
#define DMA1_DTERR2_FLAG
Definition: at32f413_dma.h:86
DMA2_DTERR3_FLAG
#define DMA2_DTERR3_FLAG
Definition: at32f413_dma.h:119
DMA2_DTERR5_FLAG
#define DMA2_DTERR5_FLAG
Definition: at32f413_dma.h:127
DMA2_DTERR1_FLAG
#define DMA2_DTERR1_FLAG
Definition: at32f413_dma.h:111
DMA2_DTERR2_FLAG
#define DMA2_DTERR2_FLAG
Definition: at32f413_dma.h:115

get the dma transfer error flag through the channel

Definition at line 73 of file i2c_application.c.

◆ I2C_END

#define I2C_END 1

Definition at line 93 of file i2c_application.c.

◆ I2C_START

#define I2C_START 0

i2c transmission status

Definition at line 92 of file i2c_application.c.

Function Documentation

◆ i2c_config()

void i2c_config ( i2c_handle_type * hi2c )

i2c peripheral initialization.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 110 of file i2c_application.c.

Referenced by audio_codec_init(), and main().

◆ i2c_dma_config()

void i2c_dma_config | ( | i2c_handle_type * | hi2c,
 |  | dma_channel_type * | dma_channelx,
 |  | uint8_t * | pdata,
 |  | uint16_t | size
 | ) |  |

dma transfer cofiguration.

Parameters
hi2c | the handle points to the operation information.
dma_channelx | dma channel to be cofigured.
pdata | data buffer.
size | data size.
Return values
none.

< dma full data transfer interrupt

< dma full data transfer interrupt

Definition at line 255 of file i2c_application.c.

Referenced by i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_dma_rx_irq_handler()

void i2c_dma_rx_irq_handler ( i2c_handle_type * hi2c )

dma reveive complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c acknowledge failure flag

< i2c event interrupt

Definition at line 2292 of file i2c_application.c.

Referenced by DMA1_Channel5_IRQHandler(), and DMA1_Channel7_IRQHandler().

◆ i2c_dma_tx_irq_handler()

void i2c_dma_tx_irq_handler ( i2c_handle_type * hi2c )

dma transmission complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c event interrupt

< i2c error interrupt

Definition at line 2255 of file i2c_application.c.

Referenced by DMA1_Channel4_IRQHandler(), and DMA1_Channel6_IRQHandler().

◆ i2c_err_irq_handler()

void i2c_err_irq_handler ( i2c_handle_type * hi2c )

i2c error interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c bus error flag

< i2c bus error flag

< i2c arbitration lost flag

< i2c arbitration lost flag

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c event interrupt

< i2c overflow or underflow flag

< i2c overflow or underflow flag

< i2c pec receive error flag

< i2c pec receive error flag

< i2c smbus timeout flag

< i2c smbus timeout flag

< i2c smbus alert flag

< i2c smbus alert flag

< i2c error interrupt

Definition at line 2338 of file i2c_application.c.

Referenced by I2C1_ERR_IRQHandler(), and I2C2_ERR_IRQHandler().

◆ i2c_evt_irq_handler()

void i2c_evt_irq_handler ( i2c_handle_type * hi2c )

interrupt procession function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 2222 of file i2c_application.c.

Referenced by I2C1_EVT_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 100 of file i2c_application.c.

Referenced by i2c_config().

◆ i2c_master_read_addr()

i2c_status_type i2c_master_read_addr | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint32_t | timeout
 | ) |  |

send address in master receive mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
timeout | maximum waiting time.
Return values
i2c status.

< i2c start condition generation complete flag

< check flag none

< i2c master 9~8 bit address header match flag

< check flag ackfail

< i2c 0~7 bit address match flag

< check flag ackfail

< i2c 0~7 bit address match flag

< i2c start condition generation complete flag

< check flag none

< i2c 0~7 bit address match flag

< check flag ackfail

Definition at line 337 of file i2c_application.c.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_memory_read(), i2c_memory_read_dma(), and i2c_memory_read_int().

◆ i2c_master_receive()

i2c_status_type i2c_master_receive | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 563 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_dma()

i2c_status_type i2c_master_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

Definition at line 1125 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_int()

i2c_status_type i2c_master_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 907 of file i2c_application.c.

Referenced by main().

◆ i2c_master_rx_isr_int()

void i2c_master_rx_isr_int ( i2c_handle_type * hi2c )

master receive mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c transmit data complete flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

< i2c receive data buffer full flag

< i2c data transmission interrupt

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 2016 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_master_transmit()

i2c_status_type i2c_master_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 420 of file i2c_application.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), and main().

◆ i2c_master_transmit_dma()

i2c_status_type i2c_master_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

Definition at line 1024 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit_int()

i2c_status_type i2c_master_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 821 of file i2c_application.c.

Referenced by main().

◆ i2c_master_tx_isr_dma()

void i2c_master_tx_isr_dma ( i2c_handle_type * hi2c )

master interrupt processing function in dma mode.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c transmit data complete flag

< i2c event interrupt

Definition at line 2170 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_master_tx_isr_int()

void i2c_master_tx_isr_int ( i2c_handle_type * hi2c )

master transfer mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c transmit data buffer empty flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1986 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_master_write_addr()

i2c_status_type i2c_master_write_addr | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint32_t | timeout
 | ) |  |

send address in master transmits mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
timeout | maximum waiting time.
Return values
i2c status.

< i2c start condition generation complete flag

< check flag none

< i2c master 9~8 bit address header match flag

< check flag ackfail

< i2c 0~7 bit address match flag

< check flag ackfail

Definition at line 284 of file i2c_application.c.

Referenced by i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), and i2c_memory_write_int().

◆ i2c_memory_address_send()

i2c_status_type i2c_memory_address_send | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | mem_address,
 |  | int32_t | timeout
 | ) |  |

send memory address.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
timeout | maximum waiting time.
Return values
i2c status.

< i2c transmit data buffer empty flag

< check flag ackfail

Definition at line 1252 of file i2c_application.c.

Referenced by i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), and i2c_memory_write_int().

◆ i2c_memory_read()

i2c_status_type i2c_memory_read | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 1387 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_dma()

i2c_status_type i2c_memory_read_dma | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

Definition at line 1877 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_int()

i2c_status_type i2c_memory_read_int | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1677 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write()

i2c_status_type i2c_memory_write | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 1298 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_dma()

i2c_status_type i2c_memory_write_dma | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through dma mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

Definition at line 1794 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_int()

i2c_status_type i2c_memory_write_int | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1600 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive()

i2c_status_type i2c_slave_receive | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag stop

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 488 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_dma()

i2c_status_type i2c_slave_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

Definition at line 1077 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_int()

i2c_status_type i2c_slave_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 868 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_rx_isr_int()

void i2c_slave_rx_isr_int ( i2c_handle_type * hi2c )

slave receive mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 2130 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_slave_transmit()

i2c_status_type i2c_slave_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 734 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_dma()

i2c_status_type i2c_slave_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

Definition at line 1201 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_int()

i2c_status_type i2c_slave_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 985 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_tx_isr_int()

void i2c_slave_tx_isr_int ( i2c_handle_type * hi2c )

slave transfer mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< i2c data transmission interrupt

< i2c event interrupt

< i2c error interrupt

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 2089 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_slave_tx_rx_isr_dma()

void i2c_slave_tx_rx_isr_dma ( i2c_handle_type * hi2c )

slave interrupt processing function in dma mode.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

< i2c event interrupt

Definition at line 2191 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_wait_end()

i2c_status_type i2c_wait_end | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | timeout
 | ) |  |

wait for the transfer to end.

Parameters
hi2c | the handle points to the operation information.
timeout | maximum waiting time.
Return values
i2c status.

Definition at line 128 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_flag()

i2c_status_type i2c_wait_flag | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | flag,
 |  | uint32_t | event_check,
 |  | uint32_t | timeout
 | ) |  |

wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set

Parameters
hi2c | the handle points to the operation information.
flag specifies the flag to check. this parameter can be one of the following values:
  • I2C_STARTF_FLAG: start condition generation complete flag.
  • I2C_ADDR7F_FLAG: 0~7 bit address match flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_ADDRHF_FLAG: master 9~8 bit address header match flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_TRMODE_FLAG: transmission mode.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_DIRF_FLAG: transmission direction flag.
  • I2C_GCADDRF_FLAG: general call address received flag.
  • I2C_DEVADDRF_FLAG: smbus device address received flag.
  • I2C_HOSTADDRF_FLAG: smbus host address received flag.
  • I2C_ADDR2_FLAG: own address 2 received flag.
event_check check other error flags while waiting for the flag. parameter as following values:
  • I2C_EVENT_CHECK_NONE
  • I2C_EVENT_CHECK_ACKFAIL
  • I2C_EVENT_CHECK_STOP
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag ackfail

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< check flag stop

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

Definition at line 184 of file i2c_application.c.

Referenced by i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_write_addr(), i2c_memory_address_send(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().


AT32F413 Firmwary Library: I2C_library_event_check_flag

Macros
I2C_library_event_check_flag
AT32F413_middlewares_i2c_application_library

Macros

#define | I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
#define | I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
#define | I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

Detailed Description

Macro Definition Documentation

◆ I2C_EVENT_CHECK_ACKFAIL

#define I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)

check flag ackfail

Definition at line 46 of file i2c_application.h.

◆ I2C_EVENT_CHECK_NONE

#define I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)

check flag none

Definition at line 45 of file i2c_application.h.

◆ I2C_EVENT_CHECK_STOP

#define I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

check flag stop

Definition at line 47 of file i2c_application.h.


AT32F413 Firmwary Library: I2C_library_memory_address_width_mode

Enumerations
I2C_library_memory_address_width_mode
AT32F413_middlewares_i2c_application_library

Enumerations

enum i2c_mem_address_width_type { I2C_MEM_ADDR_WIDIH_8 = 0x01 , I2C_MEM_ADDR_WIDIH_16 = 0x02 }

Detailed Description

Enumeration Type Documentation

◆ i2c_mem_address_width_type

enum i2c_mem_address_width_type
Enumerator
I2C_MEM_ADDR_WIDIH_8 | memory address is 8 bit
I2C_MEM_ADDR_WIDIH_16 | memory address is 16 bit

Definition at line 57 of file i2c_application.h.


AT32F413 Firmwary Library: I2C_library_transmission_mode

Enumerations
I2C_library_transmission_mode
AT32F413_middlewares_i2c_application_library

Enumerations

enum i2c_mode_type {
I2C_INT_MA_TX = 0 , I2C_INT_MA_RX , I2C_INT_SLA_TX , I2C_INT_SLA_RX ,
I2C_DMA_MA_TX , I2C_DMA_MA_RX , I2C_DMA_SLA_TX , I2C_DMA_SLA_RX
}

Detailed Description

Enumeration Type Documentation

◆ i2c_mode_type

enum i2c_mode_type
Enumerator
I2C_INT_MA_TX
I2C_INT_MA_RX
I2C_INT_SLA_TX
I2C_INT_SLA_RX
I2C_DMA_MA_TX
I2C_DMA_MA_RX
I2C_DMA_SLA_TX
I2C_DMA_SLA_RX

Definition at line 71 of file i2c_application.h.


AT32F413 Firmwary Library: I2C_library_status_code

Enumerations
I2C_library_status_code
AT32F413_middlewares_i2c_application_library

Enumerations

enum i2c_status_type {
I2C_OK = 0 , I2C_ERR_STEP_1 , I2C_ERR_STEP_2 , I2C_ERR_STEP_3 ,
I2C_ERR_STEP_4 , I2C_ERR_STEP_5 , I2C_ERR_STEP_6 , I2C_ERR_STEP_7 ,
I2C_ERR_STEP_8 , I2C_ERR_STEP_9 , I2C_ERR_STEP_10 , I2C_ERR_STEP_11 ,
I2C_ERR_STEP_12 , I2C_ERR_START , I2C_ERR_ADDR10 , I2C_ERR_ADDR ,
I2C_ERR_STOP , I2C_ERR_ACKFAIL , I2C_ERR_TIMEOUT , I2C_ERR_INTERRUPT
}

Detailed Description

Enumeration Type Documentation

◆ i2c_status_type

enum i2c_status_type
Enumerator
I2C_OK | no error
I2C_ERR_STEP_1 | step 1 error
I2C_ERR_STEP_2 | step 2 error
I2C_ERR_STEP_3 | step 3 error
I2C_ERR_STEP_4 | step 4 error
I2C_ERR_STEP_5 | step 5 error
I2C_ERR_STEP_6 | step 6 error
I2C_ERR_STEP_7 | step 7 error
I2C_ERR_STEP_8 | step 8 error
I2C_ERR_STEP_9 | step 9 error
I2C_ERR_STEP_10 | step 10 error
I2C_ERR_STEP_11 | step 11 error
I2C_ERR_STEP_12 | step 12 error
I2C_ERR_START | start error
I2C_ERR_ADDR10 | addr10 error
I2C_ERR_ADDR | addr error
I2C_ERR_STOP | stop error
I2C_ERR_ACKFAIL | ackfail error
I2C_ERR_TIMEOUT | timeout error
I2C_ERR_INTERRUPT | interrupt error

Definition at line 92 of file i2c_application.h.


AT32F413 Firmwary Library: I2C_library_handler

Data Structures
I2C_library_handler
AT32F413_middlewares_i2c_application_library

Data Structures

struct i2c_handle_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: i2c_handle_type Struct Reference

Data Fields
i2c_handle_type Struct Reference
AT32F413_middlewares_i2c_application_library » I2C_library_handler

#include <i2c_application.h>

Data Fields

i2c_type * i2cx
uint8_t * | pbuff
__IO uint16_t | pcount
__IO uint32_t | mode
__IO uint32_t | timeout
__IO uint32_t | status
__IO i2c_status_type | error_code
dma_channel_type * dma_tx_channel
dma_channel_type * dma_rx_channel
dma_init_type dma_init_struct

Detailed Description

Definition at line 125 of file i2c_application.h.

Field Documentation

◆ dma_init_struct

dma_init_type i2c_handle_type::dma_init_struct

dma init parameters

Definition at line 136 of file i2c_application.h.

Referenced by i2c_dma_config(), and i2c_lowlevel_init().

◆ dma_rx_channel

dma_channel_type* i2c_handle_type::dma_rx_channel

dma receive channel

Definition at line 135 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_lowlevel_init(), i2c_master_receive_dma(), i2c_memory_read_dma(), and i2c_slave_receive_dma().

◆ dma_tx_channel

dma_channel_type* i2c_handle_type::dma_tx_channel

dma transmit channel

Definition at line 134 of file i2c_application.h.

Referenced by i2c_dma_config(), i2c_dma_tx_irq_handler(), i2c_lowlevel_init(), i2c_master_transmit_dma(), i2c_memory_write_dma(), and i2c_slave_transmit_dma().

◆ error_code

__IO i2c_status_type i2c_handle_type::error_code

i2c error code

Definition at line 133 of file i2c_application.h.

Referenced by i2c_err_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_write_addr(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_wait_end(), and i2c_wait_flag().

◆ i2cx

i2c_type* i2c_handle_type::i2cx

i2c registers base address

Definition at line 127 of file i2c_application.h.

Referenced by audio_codec_init(), i2c_config(), i2c_dma_config(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_err_irq_handler(), i2c_lowlevel_init(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_master_write_addr(), i2c_memory_address_send(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_slave_tx_isr_int(), i2c_slave_tx_rx_isr_dma(), i2c_wait_flag(), and main().

◆ mode

__IO uint32_t i2c_handle_type::mode

i2c communication mode

Definition at line 130 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_err_irq_handler(), i2c_evt_irq_handler(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ pbuff

uint8_t* i2c_handle_type::pbuff

pointer to i2c transfer buffer

Definition at line 128 of file i2c_application.h.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

◆ pcount

__IO uint16_t i2c_handle_type::pcount

i2c transfer counter

Definition at line 129 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

◆ status

__IO uint32_t i2c_handle_type::status

i2c communication status

Definition at line 132 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_err_irq_handler(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_dma(), i2c_master_tx_isr_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_slave_tx_isr_int(), i2c_slave_tx_rx_isr_dma(), and i2c_wait_end().

◆ timeout

__IO uint32_t i2c_handle_type::timeout

i2c wait time

Definition at line 131 of file i2c_application.h.

Referenced by i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

The documentation for this struct was generated from the following file:
  • i2c_application.h


AT32F413 Firmwary Library: I2C_library_exported_functions

Functions
I2C_library_exported_functions
AT32F413_middlewares_i2c_application_library

Functions

void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...

Detailed Description

Function Documentation

◆ i2c_config()

void i2c_config ( i2c_handle_type * hi2c )

i2c peripheral initialization.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 110 of file i2c_application.c.

Referenced by audio_codec_init(), and main().

◆ i2c_dma_rx_irq_handler()

void i2c_dma_rx_irq_handler ( i2c_handle_type * hi2c )

dma reveive complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c acknowledge failure flag

< i2c event interrupt

Definition at line 2292 of file i2c_application.c.

Referenced by DMA1_Channel5_IRQHandler(), and DMA1_Channel7_IRQHandler().

◆ i2c_dma_tx_irq_handler()

void i2c_dma_tx_irq_handler ( i2c_handle_type * hi2c )

dma transmission complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c event interrupt

< i2c error interrupt

Definition at line 2255 of file i2c_application.c.

Referenced by DMA1_Channel4_IRQHandler(), and DMA1_Channel6_IRQHandler().

◆ i2c_err_irq_handler()

void i2c_err_irq_handler ( i2c_handle_type * hi2c )

i2c error interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c bus error flag

< i2c bus error flag

< i2c arbitration lost flag

< i2c arbitration lost flag

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c event interrupt

< i2c overflow or underflow flag

< i2c overflow or underflow flag

< i2c pec receive error flag

< i2c pec receive error flag

< i2c smbus timeout flag

< i2c smbus timeout flag

< i2c smbus alert flag

< i2c smbus alert flag

< i2c error interrupt

Definition at line 2338 of file i2c_application.c.

Referenced by I2C1_ERR_IRQHandler(), and I2C2_ERR_IRQHandler().

◆ i2c_evt_irq_handler()

void i2c_evt_irq_handler ( i2c_handle_type * hi2c )

interrupt procession function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 2222 of file i2c_application.c.

Referenced by I2C1_EVT_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

Definition at line 100 of file i2c_application.c.

Referenced by i2c_config().

◆ i2c_master_receive()

i2c_status_type i2c_master_receive | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 563 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_dma()

i2c_status_type i2c_master_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

Definition at line 1125 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_int()

i2c_status_type i2c_master_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 907 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit()

i2c_status_type i2c_master_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 420 of file i2c_application.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), and main().

◆ i2c_master_transmit_dma()

i2c_status_type i2c_master_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

Definition at line 1024 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit_int()

i2c_status_type i2c_master_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 821 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read()

i2c_status_type i2c_memory_read | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 1387 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_dma()

i2c_status_type i2c_memory_read_dma | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

Definition at line 1877 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_int()

i2c_status_type i2c_memory_read_int | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1677 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write()

i2c_status_type i2c_memory_write | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 1298 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_dma()

i2c_status_type i2c_memory_write_dma | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through dma mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

Definition at line 1794 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_int()

i2c_status_type i2c_memory_write_int | ( | i2c_handle_type * | hi2c,
 |  | i2c_mem_address_width_type | mem_address_width,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
mem_address_width memory address width. this parameter can be one of the following values:
  • I2C_MEM_ADDR_WIDIH_8: memory address is 8 bit
  • I2C_MEM_ADDR_WIDIH_16: memory address is 16 bit
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1600 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive()

i2c_status_type i2c_slave_receive | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag stop

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 488 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_dma()

i2c_status_type i2c_slave_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

Definition at line 1077 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_int()

i2c_status_type i2c_slave_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 868 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit()

i2c_status_type i2c_slave_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 734 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_dma()

i2c_status_type i2c_slave_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

Definition at line 1201 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_int()

i2c_status_type i2c_slave_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 985 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_end()

i2c_status_type i2c_wait_end | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | timeout
 | ) |  |

wait for the transfer to end.

Parameters
hi2c | the handle points to the operation information.
timeout | maximum waiting time.
Return values
i2c status.

Definition at line 128 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_flag()

i2c_status_type i2c_wait_flag | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | flag,
 |  | uint32_t | event_check,
 |  | uint32_t | timeout
 | ) |  |

wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set

Parameters
hi2c | the handle points to the operation information.
flag specifies the flag to check. this parameter can be one of the following values:
  • I2C_STARTF_FLAG: start condition generation complete flag.
  • I2C_ADDR7F_FLAG: 0~7 bit address match flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_ADDRHF_FLAG: master 9~8 bit address header match flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_TRMODE_FLAG: transmission mode.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_DIRF_FLAG: transmission direction flag.
  • I2C_GCADDRF_FLAG: general call address received flag.
  • I2C_DEVADDRF_FLAG: smbus device address received flag.
  • I2C_HOSTADDRF_FLAG: smbus host address received flag.
  • I2C_ADDR2_FLAG: own address 2 received flag.
event_check check other error flags while waiting for the flag. parameter as following values:
  • I2C_EVENT_CHECK_NONE
  • I2C_EVENT_CHECK_ACKFAIL
  • I2C_EVENT_CHECK_STOP
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag ackfail

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< check flag stop

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

Definition at line 184 of file i2c_application.c.

Referenced by i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_write_addr(), i2c_memory_address_send(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().


AT32F413 Firmwary Library: AT32F413_middlewares_usbd_class

Modules | Variables
AT32F413_middlewares_usbd_class

Modules

USB_audio_class
usb device class audio demo
USB_audio_desc
usb device audio descriptor
USB_audio_hid_class
usb device class audio hid demo
USB_audio_hid_desc
usb device audio hid descriptor
USB_cdc_class
usb device class cdc demo
USB_cdc_desc
usb device cdc descriptor
USB_cdc_keyboard_class
usb device class composite cdc and keyboard
USB_cdc_keyboard_desc
usb device cdc keyboard descriptor
USB_cdc_msc_class
usb device class cdc msc demo
USB_cdc_msc_desc
usb device cdc msc descriptor
USB_msc_bot_scsi
usb device class mass storage demo
USB_custom_hid_class
usb device custom hid demo
USB_custom_hid_desc
usb device custom_hid descriptor
USB_hid_iap_class
usb device class hid iap demo
USB_hid_iap_desc
usb device hid_iap descriptor
USB_keyboard_class
usb device keyboard demo
USB_keyboard_desc
usb device keyboard descriptor
USB_mouse_class
usb device mouse demo
USB_mouse_desc
usb device mouse descriptor
USB_msc_class
usb device class msc demo
USB_msc_desc
usb device msc descriptor
USB_printer_class
usb device class printer demo
USB_printer_desc
usb device printer descriptor

Variables

uint8_t | cbd_typical_type::opcode
uint8_t | cbd_typical_type::lun
uint32_t | cbd_typical_type::address
uint8_t | cbd_typical_type::reserved1
uint32_t | cbd_typical_type::alloc_length
uint16_t | cbd_typical_type::reserved2
uint8_t | cbd_extended_type::opcode
uint8_t | cbd_extended_type::lun
uint32_t | cbd_extended_type::address
uint8_t | cbd_extended_type::reserved1
uint32_t | cbd_extended_type::alloc_length
uint16_t | cbd_extended_type::reserved2
uint32_t | cbw_type::dCBWSignature
uint32_t | cbw_type::dCBWTage
uint32_t | cbw_type::dCBWDataTransferLength
uint8_t | cbw_type::bmCBWFlags
uint8_t | cbw_type::bCBWLUN
uint8_t | cbw_type::bCBWCBLength
uint8_t | cbw_type::CBWCB [16]
uint32_t | csw_type::dCSWSignature
uint32_t | csw_type::dCSWTag
uint32_t | csw_type::dCSWDataResidue
uint32_t | csw_type::bCSWStatus
uint8_t | sense_type::err_code
uint8_t | sense_type::reserved1
uint8_t | sense_type::sense_key
uint32_t | sense_type::information
uint8_t | sense_type::as_length
uint32_t | sense_type::reserved2
uint8_t | sense_type::asc
uint8_t | sense_type::ascq
uint32_t | sense_type::reserved3
uint8_t | msc_type::msc_state
uint8_t | msc_type::bot_status
uint32_t | msc_type::max_lun
uint32_t | msc_type::blk_nbr [1]
uint32_t | msc_type::blk_size [1]
uint32_t | msc_type::blk_addr
uint32_t | msc_type::blk_len
uint32_t | msc_type::data_len
uint8_t | msc_type::data [4096]
uint32_t | msc_type::alt_setting
cbw_type msc_type::cbw_struct
csw_type msc_type::csw_struct
uint32_t | cdc_msc_struct_type::alt_setting
uint8_t | cdc_msc_struct_type::g_rx_buff [0x40]
uint8_t | cdc_msc_struct_type::g_cmd [0x08]
uint8_t | cdc_msc_struct_type::g_req
uint16_t | cdc_msc_struct_type::g_len
uint16_t | cdc_msc_struct_type::g_rxlen
__IO uint8_t | cdc_msc_struct_type::g_tx_completed
__IO uint8_t | cdc_msc_struct_type::g_rx_completed
linecoding_type cdc_msc_struct_type::linecoding
uint8_t | cdc_msc_struct_type::msc_state
uint8_t | cdc_msc_struct_type::bot_status
uint32_t | cdc_msc_struct_type::max_lun
uint32_t | cdc_msc_struct_type::blk_nbr [1]
uint32_t | cdc_msc_struct_type::blk_size [1]
uint64_t | cdc_msc_struct_type::blk_addr
uint32_t | cdc_msc_struct_type::blk_len
uint32_t | cdc_msc_struct_type::data_len
uint8_t | cdc_msc_struct_type::data [4096]
cbw_type cdc_msc_struct_type::cbw_struct
csw_type cdc_msc_struct_type::csw_struct

Detailed Description

Variable Documentation

◆ address [1/2]

uint32_t cbd_typical_type::address

Definition at line 164 of file cdc_msc_class.h.

◆ address [2/2]

uint32_t cbd_extended_type::address

Definition at line 177 of file cdc_msc_class.h.

◆ alloc_length [1/2]

uint32_t cbd_typical_type::alloc_length

Definition at line 166 of file cdc_msc_class.h.

◆ alloc_length [2/2]

uint32_t cbd_extended_type::alloc_length

Definition at line 179 of file cdc_msc_class.h.

◆ alt_setting [1/2]

uint32_t msc_type::alt_setting

Definition at line 240 of file cdc_msc_class.h.

Referenced by class_setup_handler().

◆ alt_setting [2/2]

uint32_t cdc_msc_struct_type::alt_setting

Definition at line 253 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), cdc_struct_init(), and msc_class_setup_handler().

◆ as_length

uint8_t sense_type::as_length

Definition at line 217 of file cdc_msc_class.h.

◆ asc

uint8_t sense_type::asc

Definition at line 219 of file cdc_msc_class.h.

◆ ascq

uint8_t sense_type::ascq

Definition at line 220 of file cdc_msc_class.h.

◆ bCBWCBLength

uint8_t cbw_type::bCBWCBLength

Definition at line 193 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ bCBWLUN

uint8_t cbw_type::bCBWLUN

Definition at line 192 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), and bot_scsi_cmd_process().

◆ bCSWStatus

uint32_t csw_type::bCSWStatus

Definition at line 205 of file cdc_msc_class.h.

Referenced by bot_scsi_send_csw(), and bot_scsi_send_data().

◆ blk_addr [1/2]

uint32_t msc_type::blk_addr

Definition at line 234 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_addr [2/2]

uint64_t cdc_msc_struct_type::blk_addr

Definition at line 269 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_len [1/2]

uint32_t msc_type::blk_len

Definition at line 235 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_len [2/2]

uint32_t cdc_msc_struct_type::blk_len

Definition at line 270 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_nbr [1/2]

uint32_t msc_type::blk_nbr

Definition at line 231 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_check_address(), and bot_scsi_format_capacity().

◆ blk_nbr [2/2]

uint32_t cdc_msc_struct_type::blk_nbr[1]

Definition at line 266 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_check_address(), and bot_scsi_format_capacity().

◆ blk_size [1/2]

uint32_t msc_type::blk_size

Definition at line 232 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_read10(), and bot_scsi_write10().

◆ blk_size [2/2]

uint32_t cdc_msc_struct_type::blk_size[1]

Definition at line 267 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_read10(), and bot_scsi_write10().

◆ bmCBWFlags

uint8_t cbw_type::bmCBWFlags

Definition at line 191 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_stall(), and bot_scsi_write10().

◆ bot_status [1/2]

uint8_t msc_type::bot_status

Definition at line 228 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_init(), bot_scsi_reset(), and bot_scsi_stall().

◆ bot_status [2/2]

uint8_t cdc_msc_struct_type::bot_status

Definition at line 263 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_init(), bot_scsi_reset(), and bot_scsi_stall().

◆ cbw_struct [1/2]

cbw_type msc_type::cbw_struct

Definition at line 242 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_cmd_process(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ cbw_struct [2/2]

cbw_type cdc_msc_struct_type::cbw_struct

Definition at line 275 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_cmd_process(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ CBWCB

uint8_t cbw_type::CBWCB

Definition at line 194 of file cdc_msc_class.h.

Referenced by bot_scsi_cmd_process(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ csw_struct [1/2]

csw_type msc_type::csw_struct

Definition at line 243 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ csw_struct [2/2]

csw_type cdc_msc_struct_type::csw_struct

Definition at line 276 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ data [1/2]

uint8_t msc_type::data

Definition at line 238 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), and bot_scsi_write10().

◆ data [2/2]

uint8_t cdc_msc_struct_type::data[4096]

Definition at line 273 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), and bot_scsi_write10().

◆ data_len [1/2]

uint32_t msc_type::data_len

Definition at line 237 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_start_stop(), bot_scsi_test_unit(), and bot_scsi_verify().

◆ data_len [2/2]

uint32_t cdc_msc_struct_type::data_len

Definition at line 272 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_start_stop(), bot_scsi_test_unit(), and bot_scsi_verify().

◆ dCBWDataTransferLength

uint32_t cbw_type::dCBWDataTransferLength

Definition at line 190 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), and bot_scsi_write10().

◆ dCBWSignature

uint32_t cbw_type::dCBWSignature

Definition at line 188 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ dCBWTage

uint32_t cbw_type::dCBWTage

Definition at line 189 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ dCSWDataResidue

uint32_t csw_type::dCSWDataResidue

Definition at line 204 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_data(), and bot_scsi_write10().

◆ dCSWSignature

uint32_t csw_type::dCSWSignature

Definition at line 202 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), and bot_scsi_send_csw().

◆ dCSWTag

uint32_t csw_type::dCSWTag

Definition at line 203 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), and bot_scsi_init().

◆ err_code

uint8_t sense_type::err_code

Definition at line 213 of file cdc_msc_class.h.

◆ g_cmd

uint8_t cdc_msc_struct_type::g_cmd[0x08]

Definition at line 255 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_len

uint16_t cdc_msc_struct_type::g_len

Definition at line 257 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler().

◆ g_req

uint8_t cdc_msc_struct_type::g_req

Definition at line 256 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_rx_buff

uint8_t cdc_msc_struct_type::g_rx_buff[0x40]

Definition at line 254 of file cdc_msc_class.h.

Referenced by class_init_handler(), and usb_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t cdc_msc_struct_type::g_rx_completed

Definition at line 258 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), class_out_handler(), and usb_vcp_get_rxdata().

◆ g_rxlen

uint16_t cdc_msc_struct_type::g_rxlen

Definition at line 257 of file cdc_msc_class.h.

Referenced by class_out_handler(), and usb_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t cdc_msc_struct_type::g_tx_completed

Definition at line 258 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), class_in_handler(), and usb_vcp_send_data().

◆ information

uint32_t sense_type::information

Definition at line 216 of file cdc_msc_class.h.

◆ linecoding

linecoding_type cdc_msc_struct_type::linecoding

Definition at line 259 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), and usb_vcp_cmd_process().

◆ lun [1/2]

uint8_t cbd_typical_type::lun

Definition at line 163 of file cdc_msc_class.h.

◆ lun [2/2]

uint8_t cbd_extended_type::lun

Definition at line 176 of file cdc_msc_class.h.

◆ max_lun [1/2]

uint32_t msc_type::max_lun

Definition at line 229 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), bot_scsi_reset(), and class_setup_handler().

◆ max_lun [2/2]

uint32_t cdc_msc_struct_type::max_lun

Definition at line 264 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), bot_scsi_reset(), and msc_class_setup_handler().

◆ msc_state [1/2]

uint8_t msc_type::msc_state

Definition at line 227 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ msc_state [2/2]

uint8_t cdc_msc_struct_type::msc_state

Definition at line 262 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ opcode [1/2]

uint8_t cbd_typical_type::opcode

Definition at line 162 of file cdc_msc_class.h.

◆ opcode [2/2]

uint8_t cbd_extended_type::opcode

Definition at line 175 of file cdc_msc_class.h.

◆ reserved1 [1/3]

uint8_t cbd_typical_type::reserved1

Definition at line 165 of file cdc_msc_class.h.

◆ reserved1 [2/3]

uint8_t cbd_extended_type::reserved1

Definition at line 178 of file cdc_msc_class.h.

◆ reserved1 [3/3]

uint8_t sense_type::reserved1

Definition at line 214 of file cdc_msc_class.h.

◆ reserved2 [1/3]

uint16_t cbd_typical_type::reserved2

Definition at line 167 of file cdc_msc_class.h.

◆ reserved2 [2/3]

uint16_t cbd_extended_type::reserved2

Definition at line 180 of file cdc_msc_class.h.

◆ reserved2 [3/3]

uint32_t sense_type::reserved2

Definition at line 218 of file cdc_msc_class.h.

◆ reserved3

uint32_t sense_type::reserved3

Definition at line 221 of file cdc_msc_class.h.

◆ sense_key

uint8_t sense_type::sense_key

Definition at line 215 of file cdc_msc_class.h.


AT32F413 Firmwary Library: USB_audio_class

Modules
USB_audio_class
AT32F413_middlewares_usbd_class

usb device class audio demo More...

Modules

USB_audio_class_private_functions
USB_audio_class_definition
USB_device_audio_config_definition

Detailed Description

usb device class audio demo


AT32F413 Firmwary Library: USB_audio_class_private_functions

Functions | Variables
USB_audio_class_private_functions
AT32F413_middlewares_usbd_class » USB_audio_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...

Variables

usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_class_handler

Detailed Description

Function Documentation

◆ audio_get_interface()

static void audio_get_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio get interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 598 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_cur()

static void audio_req_get_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 416 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_max()

static void audio_req_get_max | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get max

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 517 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_min()

static void audio_req_get_min | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get min

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 495 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_res()

static void audio_req_get_res | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get res

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 539 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_set_cur()

static void audio_req_set_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request set cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 455 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_set_interface()

static void audio_set_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio set interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 561 of file audio_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 116 of file audio_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 236 of file audio_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 222 of file audio_class.c.

◆ class_event_handler()

usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | usb device core handler type
event | usb device event
Return values
status of usb_sts_type

Definition at line 380 of file audio_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 307 of file audio_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 82 of file audio_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 338 of file audio_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 139 of file audio_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 365 of file audio_class.c.

Variable Documentation

◆ audio_class_handler

usbd_class_handler audio_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&audio_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_class.c:365
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_class.c:307
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_class.c:116
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_class.c:139
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_class.c:222
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_class.c:380
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_class.c:236
audio_struct
usb_audio_type audio_struct
Definition: audio_class.c:60
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_class.c:82
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_class.c:338

Definition at line 63 of file audio_class.c.

Referenced by main().

◆ audio_struct

usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}

Definition at line 60 of file audio_class.c.


AT32F413 Firmwary Library: USB_audio_class_definition

Data Structures | Macros | Variables
USB_audio_class_definition
AT32F413_middlewares_usbd_class » USB_audio_class

Data Structures

struct usb_audio_type
usb audio control struct More...

Macros

#define | USBD_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUDIO_FEEDBACK_EPT 0x83
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Variables

usbd_class_handler audio_class_handler

Detailed Description

Macro Definition Documentation

◆ AUDIO_DESCRIPTOR_SIZE

#define AUDIO_DESCRIPTOR_SIZE 0x09

Definition at line 82 of file audio_class.h.

◆ AUDIO_DESCRIPTOR_TYPE

#define AUDIO_DESCRIPTOR_TYPE 0x21

audio descriptor type

Definition at line 81 of file audio_class.h.

◆ AUDIO_FEEDBACK_MAXPACKET_SIZE

#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3

Definition at line 62 of file audio_class.h.

◆ AUDIO_FREQ_SET_CONTROL

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 76 of file audio_class.h.

◆ AUDIO_MIC_IN_MAXPACKET_SIZE

#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 60 of file audio_class.h.

◆ AUDIO_MUTE_CONTROL

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

Definition at line 74 of file audio_class.h.

◆ AUDIO_REMAIN_SIZE

#define AUDIO_REMAIN_SIZE 40

endpoint support max size

Definition at line 59 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_ENDPOINT

#define AUDIO_REQ_CONTROL_ENDPOINT 0x02

Definition at line 68 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_INTERFACE

#define AUDIO_REQ_CONTROL_INTERFACE 0x01

request type define

Definition at line 67 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_MASK

#define AUDIO_REQ_CONTROL_MASK 0x03

Definition at line 69 of file audio_class.h.

◆ AUDIO_SPK_OUT_MAXPACKET_SIZE

#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 61 of file audio_class.h.

◆ AUDIO_VOLUME_CONTROL

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 75 of file audio_class.h.

◆ FEEDBACK_REFRESH_TIME

#define FEEDBACK_REFRESH_TIME 0x8

Definition at line 63 of file audio_class.h.

◆ USBD_AUDIO_FEEDBACK_EPT

#define USBD_AUDIO_FEEDBACK_EPT 0x83

Definition at line 54 of file audio_class.h.

◆ USBD_AUDIO_MIC_IN_EPT

#define USBD_AUDIO_MIC_IN_EPT 0x81

endpoint define

Definition at line 52 of file audio_class.h.

◆ USBD_AUDIO_SPK_OUT_EPT

#define USBD_AUDIO_SPK_OUT_EPT 0x02

Definition at line 53 of file audio_class.h.

Variable Documentation

◆ audio_class_handler

usbd_class_handler audio_class_handler
extern

Definition at line 63 of file audio_class.c.

Referenced by main().


AT32F413 Firmwary Library: usb_audio_type Struct Reference

Data Fields
usb_audio_type Struct Reference
AT32F413_middlewares_usbd_class » USB_audio_class » USB_audio_class_definition

usb audio control struct More...

#include <audio_class.h>

Data Fields

uint8_t | enpd
uint8_t | interface
uint8_t | request_no
uint8_t | spk_mute
uint8_t | mic_mute
uint16_t | spk_volume
uint16_t | mic_volume
uint32_t | spk_freq
uint32_t | mic_freq
uint16_t | spk_volume_limits [3]
uint16_t | mic_volume_limits [3]
uint8_t | audio_cmd
uint32_t | audio_cmd_len
uint32_t | spk_alt_setting
uint32_t | mic_alt_setting
uint8_t | g_audio_cur [64]
uint8_t | audio_spk_data [(48 *2 *(16/8)+40)]
uint8_t | audio_mic_data [(48 *2 *(16/8)+40)]
uint8_t | audio_feed_back [0x3+1]

Detailed Description

usb audio control struct

Definition at line 87 of file audio_class.h.

Field Documentation

◆ audio_cmd

uint8_t usb_audio_type::audio_cmd

Definition at line 101 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ audio_cmd_len

uint32_t usb_audio_type::audio_cmd_len

Definition at line 102 of file audio_class.h.

Referenced by audio_req_set_cur().

◆ audio_feed_back

uint8_t usb_audio_type::audio_feed_back[0x3+1]

Definition at line 108 of file audio_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_mic_data

uint8_t usb_audio_type::audio_mic_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 107 of file audio_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_spk_data

uint8_t usb_audio_type::audio_spk_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 106 of file audio_class.h.

Referenced by audio_set_interface(), class_init_handler(), and class_out_handler().

◆ enpd

uint8_t usb_audio_type::enpd

Definition at line 89 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_audio_cur

uint8_t usb_audio_type::g_audio_cur[64]

Definition at line 105 of file audio_class.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), and class_ept0_rx_handler().

◆ interface

uint8_t usb_audio_type::interface

Definition at line 90 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ mic_alt_setting

uint32_t usb_audio_type::mic_alt_setting

Definition at line 104 of file audio_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ mic_freq

uint32_t usb_audio_type::mic_freq

Definition at line 97 of file audio_class.h.

Referenced by class_ept0_rx_handler().

◆ mic_mute

uint8_t usb_audio_type::mic_mute

Definition at line 93 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume

uint16_t usb_audio_type::mic_volume

Definition at line 95 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume_limits

uint16_t usb_audio_type::mic_volume_limits[3]

Definition at line 99 of file audio_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

◆ request_no

uint8_t usb_audio_type::request_no

Definition at line 91 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ spk_alt_setting

uint32_t usb_audio_type::spk_alt_setting

Definition at line 103 of file audio_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ spk_freq

uint32_t usb_audio_type::spk_freq

Definition at line 96 of file audio_class.h.

Referenced by class_ept0_rx_handler().

◆ spk_mute

uint8_t usb_audio_type::spk_mute

Definition at line 92 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume

uint16_t usb_audio_type::spk_volume

Definition at line 94 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume_limits

uint16_t usb_audio_type::spk_volume_limits[3]

Definition at line 98 of file audio_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

The documentation for this struct was generated from the following file:
  • audio_class.h


AT32F413 Firmwary Library: USB_device_audio_config_definition

Macros
USB_device_audio_config_definition
AT32F413_middlewares_usbd_class » USB_audio_class

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 1
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

Macro Definition Documentation

◆ AUDIO_BITW_16

#define AUDIO_BITW_16 16

Definition at line 59 of file audio/audio_conf.h.

◆ AUDIO_DEFAULT_BITW

#define AUDIO_DEFAULT_BITW AUDIO_BITW_16

Definition at line 70 of file audio/audio_conf.h.

◆ AUDIO_DEFAULT_FREQ

#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K

Definition at line 69 of file audio/audio_conf.h.

◆ AUDIO_FREQ_16K

#define AUDIO_FREQ_16K 16000

Definition at line 57 of file audio/audio_conf.h.

◆ AUDIO_FREQ_48K

#define AUDIO_FREQ_48K 48000

Definition at line 58 of file audio/audio_conf.h.

◆ AUDIO_MIC_CHANEL_NUM

#define AUDIO_MIC_CHANEL_NUM 2

Definition at line 61 of file audio/audio_conf.h.

◆ AUDIO_MIC_DEFAULT_BITW

#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16

Definition at line 62 of file audio/audio_conf.h.

◆ AUDIO_SPK_CHANEL_NUM

#define AUDIO_SPK_CHANEL_NUM 2

Definition at line 64 of file audio/audio_conf.h.

◆ AUDIO_SPK_DEFAULT_BITW

#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16

Definition at line 65 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FEEDBACK

#define AUDIO_SUPPORT_FEEDBACK 1

Definition at line 47 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ

#define AUDIO_SUPPORT_FREQ
Value:
(AUDIO_SUPPORT_FREQ_16K + \
AUDIO_SUPPORT_FREQ_48K \
)
AUDIO_SUPPORT_FREQ_16K
#define AUDIO_SUPPORT_FREQ_16K
Definition: audio/audio_conf.h:49

Definition at line 53 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_16K

#define AUDIO_SUPPORT_FREQ_16K 1

Definition at line 49 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_48K

#define AUDIO_SUPPORT_FREQ_48K 1

Definition at line 50 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_MAX_FREQ

#define AUDIO_SUPPORT_MAX_FREQ 48

Definition at line 68 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_MIC

#define AUDIO_SUPPORT_MIC 1

Definition at line 46 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_SPK

#define AUDIO_SUPPORT_SPK 1

Definition at line 45 of file audio/audio_conf.h.


AT32F413 Firmwary Library: USB_audio_desc

Modules
USB_audio_desc
AT32F413_middlewares_usbd_class

usb device audio descriptor More...

Modules

USB_audio_desc_private_functions
USB_audio_desc_definition

Detailed Description

usb device audio descriptor


AT32F413 Firmwary Library: USB_audio_desc_private_functions

Functions | Variables
USB_audio_desc_private_functions
AT32F413_middlewares_usbd_class » USB_audio_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler audio_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 623 of file audio_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 545 of file audio_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 525 of file audio_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 611 of file audio_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 565 of file audio_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 576 of file audio_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 555 of file audio_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 588 of file audio_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 535 of file audio_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 600 of file audio_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 503 of file audio_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 477 of file audio_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 451 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5730 ),
HBYTE( 0x5730 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
0x01
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 58 of file audio_desc.c.

◆ audio_desc_handler

usbd_desc_handler audio_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_desc.c:545
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_desc.c:525
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_desc.c:576
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_desc.c:535
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_desc.c:611
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_desc.c:555
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_desc.c:588
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_desc.c:623
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_desc.c:565
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_desc.c:600

device descriptor handler structure

Definition at line 63 of file audio_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
( 0x12 + ((0x08 + ( 1 + 1 ) ) + ( 1 + 1 ) * 0x22) + + (0x31 + ( ( 1 + 1 ) ) * 3) + (0x31 + ( ( 1 + 1 ) ) * 3) + (9 * 1 ) ) ,
g_usbd_configuration
}

Definition at line 423 of file audio_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 416 of file audio_desc.c.

Referenced by get_device_descriptor().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 430 of file audio_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 437 of file audio_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 443 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_audio_desc_definition

Macros | Variables
USB_audio_desc_definition
AT32F413_middlewares_usbd_class » USB_audio_desc

Macros

#define | AUDIO_BCD_NUM 0x0100
#define | USBD_AUDIO_VENDOR_ID 0x2E3C
#define | USBD_AUDIO_PRODUCT_ID 0x5730
#define | USBD_AUDIO_SIZ_STRING_LANGID 4
#define | USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x0D
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUDIO_BINTERVAL_TIME 0x01
#define | USBD_AUDIO_CONFIG_DESC_SIZE
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler audio_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ AT32_AUDIO_FREQ_16K

#define AT32_AUDIO_FREQ_16K 16000

audio support freq

Definition at line 186 of file audio_desc.h.

◆ AT32_AUDIO_FREQ_48K

#define AT32_AUDIO_FREQ_48K 48000

Definition at line 187 of file audio_desc.h.

◆ AUDIO_AC_DESCRIPTOR_UNDEFINED

#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00

audio class-specific ac interface descriptor subtypes

Definition at line 88 of file audio_desc.h.

◆ AUDIO_AC_EXTENSION_UNIT

#define AUDIO_AC_EXTENSION_UNIT 0x08

Definition at line 96 of file audio_desc.h.

◆ AUDIO_AC_FEATURE_UNIT

#define AUDIO_AC_FEATURE_UNIT 0x06

Definition at line 94 of file audio_desc.h.

◆ AUDIO_AC_HEADER

#define AUDIO_AC_HEADER 0x01

Definition at line 89 of file audio_desc.h.

◆ AUDIO_AC_INPUT_TERMINAL

#define AUDIO_AC_INPUT_TERMINAL 0x02

Definition at line 90 of file audio_desc.h.

◆ AUDIO_AC_MIXER_UNIT

#define AUDIO_AC_MIXER_UNIT 0x04

Definition at line 92 of file audio_desc.h.

◆ AUDIO_AC_OUTPUT_TERMINAL

#define AUDIO_AC_OUTPUT_TERMINAL 0x03

Definition at line 91 of file audio_desc.h.

◆ AUDIO_AC_PROCESSING_UNIT

#define AUDIO_AC_PROCESSING_UNIT 0x07

Definition at line 95 of file audio_desc.h.

◆ AUDIO_AC_SELECTOR_UNIT

#define AUDIO_AC_SELECTOR_UNIT 0x05

Definition at line 93 of file audio_desc.h.

◆ AUDIO_AS_DESCRIPTOR_UNDEFINED

#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00

audio class-specific as interface descriptor subtypes

Definition at line 101 of file audio_desc.h.

◆ AUDIO_AS_FORMAT_SPECIFIC

#define AUDIO_AS_FORMAT_SPECIFIC 0x03

Definition at line 104 of file audio_desc.h.

◆ AUDIO_AS_FORMAT_TYPE

#define AUDIO_AS_FORMAT_TYPE 0x02

Definition at line 103 of file audio_desc.h.

◆ AUDIO_AS_GENERAL

#define AUDIO_AS_GENERAL 0x01

Definition at line 102 of file audio_desc.h.

◆ AUDIO_BCD_NUM

#define AUDIO_BCD_NUM 0x0100

Definition at line 49 of file audio_desc.h.

◆ AUDIO_BINTERVAL_TIME

#define AUDIO_BINTERVAL_TIME 0x01

Definition at line 203 of file audio_desc.h.

◆ AUDIO_CS_CONFIGURATION

#define AUDIO_CS_CONFIGURATION 0x22

Definition at line 76 of file audio_desc.h.

◆ AUDIO_CS_DEVICE

#define AUDIO_CS_DEVICE 0x21

Definition at line 77 of file audio_desc.h.

◆ AUDIO_CS_ENDPOINT

#define AUDIO_CS_ENDPOINT 0x25

Definition at line 74 of file audio_desc.h.

◆ AUDIO_CS_INTERFACE

#define AUDIO_CS_INTERFACE 0x24

audio class-specific descriptor types

Definition at line 73 of file audio_desc.h.

◆ AUDIO_CS_STRING

#define AUDIO_CS_STRING 0x23

Definition at line 75 of file audio_desc.h.

◆ AUDIO_CS_UNDEFINED

#define AUDIO_CS_UNDEFINED 0x20

Definition at line 78 of file audio_desc.h.

◆ AUDIO_FEATURE_UNIT_SIZE

#define AUDIO_FEATURE_UNIT_SIZE 0x0D

Definition at line 161 of file audio_desc.h.

◆ AUDIO_FORMAT_TYPE_I

#define AUDIO_FORMAT_TYPE_I 0x01

audio format type 1

Definition at line 146 of file audio_desc.h.

◆ AUDIO_FU_BASS_CONTROL

#define AUDIO_FU_BASS_CONTROL 0x03

Definition at line 128 of file audio_desc.h.

◆ AUDIO_FU_CONTROL_UNDEFINED

#define AUDIO_FU_CONTROL_UNDEFINED 0x00

audio feature unit control selectors

Definition at line 125 of file audio_desc.h.

◆ AUDIO_FU_MID_CONTROL

#define AUDIO_FU_MID_CONTROL 0x04

Definition at line 129 of file audio_desc.h.

◆ AUDIO_FU_MUTE_CONTROL

#define AUDIO_FU_MUTE_CONTROL 0x01

Definition at line 126 of file audio_desc.h.

◆ AUDIO_FU_TREBLE_CONTROL

#define AUDIO_FU_TREBLE_CONTROL 0x05

Definition at line 130 of file audio_desc.h.

◆ AUDIO_FU_VOLUME_CONTROL

#define AUDIO_FU_VOLUME_CONTROL 0x02

Definition at line 127 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_MICROPHONE

#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201

Definition at line 139 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_SIZE

#define AUDIO_INPUT_TERMINAL_SIZE 0x0C

audio interface descriptor size define

Definition at line 159 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_UNDEFINED

#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200

Definition at line 138 of file audio_desc.h.

◆ AUDIO_INTERFACE_LEN

#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)

Definition at line 152 of file audio_desc.h.

◆ AUDIO_INTERFACE_NUM

#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)

audio interface config

Definition at line 151 of file audio_desc.h.

◆ AUDIO_MIC_BITW

#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)

Definition at line 194 of file audio_desc.h.

◆ AUDIO_MIC_CHR

#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM

Definition at line 193 of file audio_desc.h.

◆ AUDIO_MIC_FEATURE_UNIT_ID

#define AUDIO_MIC_FEATURE_UNIT_ID 0x02

Definition at line 167 of file audio_desc.h.

◆ AUDIO_MIC_FREQ_SIZE

#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio microphone freq and channel config

Definition at line 192 of file audio_desc.h.

◆ AUDIO_MIC_INPUT_TERMINAL_ID

#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01

audio terminal id define

Definition at line 166 of file audio_desc.h.

◆ AUDIO_MIC_INTERFACE

#define AUDIO_MIC_INTERFACE 0x01

Definition at line 153 of file audio_desc.h.

◆ AUDIO_MIC_INTERFACE_NUMBER

#define AUDIO_MIC_INTERFACE_NUMBER 0x01

audio interface number

Definition at line 176 of file audio_desc.h.

◆ AUDIO_MIC_OUTPUT_TERMINAL_ID

#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03

Definition at line 168 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SIZE

#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09

Definition at line 160 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SPEAKER

#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301

Definition at line 141 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_UNDEFINED

#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300

Definition at line 140 of file audio_desc.h.

◆ AUDIO_PROTOCOL_UNDEFINED

#define AUDIO_PROTOCOL_UNDEFINED 0x00

audio interface protocol codes

Definition at line 83 of file audio_desc.h.

◆ AUDIO_REQ_GET_CUR

#define AUDIO_REQ_GET_CUR 0x81

Definition at line 111 of file audio_desc.h.

◆ AUDIO_REQ_GET_MAX

#define AUDIO_REQ_GET_MAX 0x83

Definition at line 115 of file audio_desc.h.

◆ AUDIO_REQ_GET_MEM

#define AUDIO_REQ_GET_MEM 0x85

Definition at line 119 of file audio_desc.h.

◆ AUDIO_REQ_GET_MIN

#define AUDIO_REQ_GET_MIN 0x82

Definition at line 113 of file audio_desc.h.

◆ AUDIO_REQ_GET_RES

#define AUDIO_REQ_GET_RES 0x84

Definition at line 117 of file audio_desc.h.

◆ AUDIO_REQ_GET_STAT

#define AUDIO_REQ_GET_STAT 0xFF

Definition at line 120 of file audio_desc.h.

◆ AUDIO_REQ_SET_CUR

#define AUDIO_REQ_SET_CUR 0x01

Definition at line 110 of file audio_desc.h.

◆ AUDIO_REQ_SET_MAX

#define AUDIO_REQ_SET_MAX 0x03

Definition at line 114 of file audio_desc.h.

◆ AUDIO_REQ_SET_MEM

#define AUDIO_REQ_SET_MEM 0x05

Definition at line 118 of file audio_desc.h.

◆ AUDIO_REQ_SET_MIN

#define AUDIO_REQ_SET_MIN 0x02

Definition at line 112 of file audio_desc.h.

◆ AUDIO_REQ_SET_RES

#define AUDIO_REQ_SET_RES 0x04

Definition at line 116 of file audio_desc.h.

◆ AUDIO_REQUEST_CODE_UNDEFINED

#define AUDIO_REQUEST_CODE_UNDEFINED 0x00

audio class-specific request codes

Definition at line 109 of file audio_desc.h.

◆ AUDIO_SPK_BITW

#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)

Definition at line 201 of file audio_desc.h.

◆ AUDIO_SPK_CHR

#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM

Definition at line 200 of file audio_desc.h.

◆ AUDIO_SPK_FEATURE_UNIT_ID

#define AUDIO_SPK_FEATURE_UNIT_ID 0x05

Definition at line 170 of file audio_desc.h.

◆ AUDIO_SPK_FREQ_SIZE

#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio speaker freq and channel config

Definition at line 199 of file audio_desc.h.

◆ AUDIO_SPK_INPUT_TERMINAL_ID

#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04

Definition at line 169 of file audio_desc.h.

◆ AUDIO_SPK_INTERFACE

#define AUDIO_SPK_INTERFACE 0x02

Definition at line 154 of file audio_desc.h.

◆ AUDIO_SPK_INTERFACE_NUMBER

#define AUDIO_SPK_INTERFACE_NUMBER 0x02

Definition at line 178 of file audio_desc.h.

◆ AUDIO_SPK_OUTPUT_TERMINAL_ID

#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06

Definition at line 171 of file audio_desc.h.

◆ AUDIO_SUBCLASS_AUDIOCONTROL

#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01

Definition at line 66 of file audio_desc.h.

◆ AUDIO_SUBCLASS_AUDIOSTREAMING

#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02

Definition at line 67 of file audio_desc.h.

◆ AUDIO_SUBCLASS_MIDISTREMING

#define AUDIO_SUBCLASS_MIDISTREMING 0x03

Definition at line 68 of file audio_desc.h.

◆ AUDIO_SUBCLASS_UNDEFINED

#define AUDIO_SUBCLASS_UNDEFINED 0x00

audio interface subclass codes

Definition at line 65 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_STREAMING

#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101

Definition at line 136 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_UNDEFINED

#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100

audio terminal type

Definition at line 135 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_VENDOR

#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF

Definition at line 137 of file audio_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 213 of file audio_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 214 of file audio_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 215 of file audio_desc.h.

◆ SAMPLE_FREQ

#define SAMPLE_FREQ ( frq ) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))

Definition at line 211 of file audio_desc.h.

◆ USBD_AUDIO_CONFIG_DESC_SIZE

#define USBD_AUDIO_CONFIG_DESC_SIZE
Value:
( 0x12 + AUDIO_INTERFACE_LEN + \
+ (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
+ (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
+ (9 * AUDIO_SUPPORT_FEEDBACK) \
)
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:192
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:199
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:152
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:47

Definition at line 206 of file audio_desc.h.

◆ USBD_AUDIO_DESC_CONFIGURATION_STRING

#define USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"

Definition at line 59 of file audio_desc.h.

◆ USBD_AUDIO_DESC_INTERFACE_STRING

#define USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"

Definition at line 60 of file audio_desc.h.

◆ USBD_AUDIO_DESC_MANUFACTURER_STRING

#define USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"

Definition at line 57 of file audio_desc.h.

◆ USBD_AUDIO_DESC_PRODUCT_STRING

#define USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"

Definition at line 58 of file audio_desc.h.

◆ USBD_AUDIO_PRODUCT_ID

#define USBD_AUDIO_PRODUCT_ID 0x5730

Definition at line 52 of file audio_desc.h.

◆ USBD_AUDIO_SIZ_STRING_LANGID

#define USBD_AUDIO_SIZ_STRING_LANGID 4

Definition at line 54 of file audio_desc.h.

◆ USBD_AUDIO_SIZ_STRING_SERIAL

#define USBD_AUDIO_SIZ_STRING_SERIAL 0x1A

Definition at line 55 of file audio_desc.h.

◆ USBD_AUDIO_VENDOR_ID

#define USBD_AUDIO_VENDOR_ID 0x2E3C

Definition at line 51 of file audio_desc.h.

Variable Documentation

◆ audio_desc_handler

usbd_desc_handler audio_desc_handler
extern

device descriptor handler structure

Definition at line 63 of file audio_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_audio_hid_class

Modules
USB_audio_hid_class
AT32F413_middlewares_usbd_class

usb device class audio hid demo More...

Modules

USB_device_audio_hid_config_definition
USB_audio_hid_class_private_functions
USB_audio_hid_class_definition

Detailed Description

usb device class audio hid demo


AT32F413 Firmwary Library: USB_device_audio_hid_config_definition

Macros
USB_device_audio_hid_config_definition
AT32F413_middlewares_usbd_class » USB_audio_hid_class

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

Macro Definition Documentation

◆ AUDIO_BITW_16

#define AUDIO_BITW_16 16

Definition at line 59 of file audio_hid/audio_conf.h.

◆ AUDIO_DEFAULT_BITW

#define AUDIO_DEFAULT_BITW AUDIO_BITW_16

Definition at line 70 of file audio_hid/audio_conf.h.

◆ AUDIO_DEFAULT_FREQ

#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K

Definition at line 69 of file audio_hid/audio_conf.h.

◆ AUDIO_FREQ_16K

#define AUDIO_FREQ_16K 16000

Definition at line 57 of file audio_hid/audio_conf.h.

◆ AUDIO_FREQ_48K

#define AUDIO_FREQ_48K 48000

Definition at line 58 of file audio_hid/audio_conf.h.

◆ AUDIO_MIC_CHANEL_NUM

#define AUDIO_MIC_CHANEL_NUM 2

Definition at line 61 of file audio_hid/audio_conf.h.

◆ AUDIO_MIC_DEFAULT_BITW

#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16

Definition at line 62 of file audio_hid/audio_conf.h.

◆ AUDIO_SPK_CHANEL_NUM

#define AUDIO_SPK_CHANEL_NUM 2

Definition at line 64 of file audio_hid/audio_conf.h.

◆ AUDIO_SPK_DEFAULT_BITW

#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16

Definition at line 65 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FEEDBACK

#define AUDIO_SUPPORT_FEEDBACK 1

Definition at line 47 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ

#define AUDIO_SUPPORT_FREQ
Value:
(AUDIO_SUPPORT_FREQ_16K + \
AUDIO_SUPPORT_FREQ_48K \
)
AUDIO_SUPPORT_FREQ_16K
#define AUDIO_SUPPORT_FREQ_16K
Definition: audio_hid/audio_conf.h:49

Definition at line 53 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_16K

#define AUDIO_SUPPORT_FREQ_16K 0

Definition at line 49 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_48K

#define AUDIO_SUPPORT_FREQ_48K 1

Definition at line 50 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_MAX_FREQ

#define AUDIO_SUPPORT_MAX_FREQ 48

Definition at line 68 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_MIC

#define AUDIO_SUPPORT_MIC 1

Definition at line 46 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_SPK

#define AUDIO_SUPPORT_SPK 1

Definition at line 45 of file audio_hid/audio_conf.h.


AT32F413 Firmwary Library: USB_audio_hid_class_private_functions

Functions | Variables
USB_audio_hid_class_private_functions
AT32F413_middlewares_usbd_class » USB_audio_hid_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
usb_sts_type | class_audio_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | class_hid_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_hid_class_handler

Detailed Description

Function Documentation

◆ audio_get_interface()

static void audio_get_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio get interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 756 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_hid_class_send_report()

usb_sts_type audio_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 778 of file audio_hid_class.c.

Referenced by main().

◆ audio_req_get_cur()

static void audio_req_get_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 574 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_max()

static void audio_req_get_max | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get max

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 675 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_min()

static void audio_req_get_min | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get min

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 653 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_res()

static void audio_req_get_res | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get res

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 697 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_set_cur()

static void audio_req_set_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request set cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 613 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_set_interface()

static void audio_set_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio set interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 719 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ class_audio_setup_handler()

usb_sts_type class_audio_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 157 of file audio_hid_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 126 of file audio_hid_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 367 of file audio_hid_class.c.

◆ class_ept0_tx_handler()

usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 353 of file audio_hid_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | usb device core handler type
event | usb device event
Return values
status of usb_sts_type

Definition at line 538 of file audio_hid_class.c.

◆ class_hid_setup_handler()

usb_sts_type class_hid_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 243 of file audio_hid_class.c.

Referenced by class_setup_handler().

◆ class_in_handler()

usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 453 of file audio_hid_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 81 of file audio_hid_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 489 of file audio_hid_class.c.

◆ class_setup_handler()

usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 322 of file audio_hid_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 523 of file audio_hid_class.c.

◆ usb_hid_buf_process()

static void usb_hid_buf_process | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |
static

usb device report function

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
none

Definition at line 797 of file audio_hid_class.c.

Referenced by class_ept0_rx_handler(), and class_out_handler().

Variable Documentation

◆ audio_hid_class_handler

usbd_class_handler audio_hid_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&audio_hid_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_hid_class.c:523
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_hid_class.c:126
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_hid_class.c:367
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_hid_class.c:538
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:322
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_hid_class.c:81
audio_hid_struct
usb_audio_hid_type audio_hid_struct
Definition: audio_hid_class.c:60
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_hid_class.c:353
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_hid_class.c:489
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_hid_class.c:453

Definition at line 62 of file audio_hid_class.c.

Referenced by main().

◆ audio_hid_struct

usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}

Definition at line 60 of file audio_hid_class.c.


AT32F413 Firmwary Library: USB_audio_hid_class_definition

Data Structures | Macros | Functions | Variables
USB_audio_hid_class_definition
AT32F413_middlewares_usbd_class » USB_audio_hid_class

Data Structures

struct usb_audio_hid_type
usb audio control struct More...

Macros

#define | USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
#define | USBD_AUHID_HID_IN_EPT 0x84
usb custom hid use endpoint define More...
#define | USBD_AUHID_HID_OUT_EPT 0x05
#define | USBD_AUHID_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Functions

usb_sts_type audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler audio_hid_class_handler

Detailed Description

Macro Definition Documentation

◆ AUDIO_DESCRIPTOR_SIZE

#define AUDIO_DESCRIPTOR_SIZE 0x09

Definition at line 105 of file audio_hid_class.h.

◆ AUDIO_DESCRIPTOR_TYPE

#define AUDIO_DESCRIPTOR_TYPE 0x21

audio descriptor type

Definition at line 104 of file audio_hid_class.h.

◆ AUDIO_FEEDBACK_MAXPACKET_SIZE

#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3

Definition at line 74 of file audio_hid_class.h.

◆ AUDIO_FREQ_SET_CONTROL [1/2]

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 99 of file audio_hid_class.h.

◆ AUDIO_FREQ_SET_CONTROL [2/2]

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 99 of file audio_hid_class.h.

◆ AUDIO_MIC_IN_MAXPACKET_SIZE

#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 72 of file audio_hid_class.h.

◆ AUDIO_MUTE_CONTROL [1/2]

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

audio descriptor type

audio set cur type define

Definition at line 97 of file audio_hid_class.h.

◆ AUDIO_MUTE_CONTROL [2/2]

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

audio descriptor type

audio set cur type define

Definition at line 97 of file audio_hid_class.h.

◆ AUDIO_REMAIN_SIZE

#define AUDIO_REMAIN_SIZE 40

endpoint support max size

Definition at line 71 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_ENDPOINT

#define AUDIO_REQ_CONTROL_ENDPOINT 0x02

Definition at line 80 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_INTERFACE

#define AUDIO_REQ_CONTROL_INTERFACE 0x01

request type define

Definition at line 79 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_MASK

#define AUDIO_REQ_CONTROL_MASK 0x03

Definition at line 81 of file audio_hid_class.h.

◆ AUDIO_SPK_OUT_MAXPACKET_SIZE

#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 73 of file audio_hid_class.h.

◆ AUDIO_VOLUME_CONTROL [1/2]

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 98 of file audio_hid_class.h.

◆ AUDIO_VOLUME_CONTROL [2/2]

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 98 of file audio_hid_class.h.

◆ FEEDBACK_REFRESH_TIME

#define FEEDBACK_REFRESH_TIME 0x8

Definition at line 75 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_FEEDBACK_EPT

#define USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83

Definition at line 54 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_MIC_IN_EPT

#define USBD_AUHID_AUDIO_MIC_IN_EPT 0x81

endpoint define

Definition at line 52 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_SPK_OUT_EPT

#define USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02

Definition at line 53 of file audio_hid_class.h.

◆ USBD_AUHID_HID_IN_EPT

#define USBD_AUHID_HID_IN_EPT 0x84

usb custom hid use endpoint define

Definition at line 59 of file audio_hid_class.h.

◆ USBD_AUHID_HID_OUT_EPT

#define USBD_AUHID_HID_OUT_EPT 0x05

Definition at line 60 of file audio_hid_class.h.

◆ USBD_AUHID_IN_MAXPACKET_SIZE

#define USBD_AUHID_IN_MAXPACKET_SIZE 0x40

usb custom hid in and out max packet size define

Definition at line 65 of file audio_hid_class.h.

◆ USBD_AUHID_OUT_MAXPACKET_SIZE

#define USBD_AUHID_OUT_MAXPACKET_SIZE 0x40

Definition at line 66 of file audio_hid_class.h.

Function Documentation

◆ audio_hid_class_send_report()

usb_sts_type audio_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 778 of file audio_hid_class.c.

Referenced by main().

Variable Documentation

◆ audio_hid_class_handler

usbd_class_handler audio_hid_class_handler
extern

Definition at line 62 of file audio_hid_class.c.

Referenced by main().


AT32F413 Firmwary Library: usb_audio_hid_type Struct Reference

Data Fields
usb_audio_hid_type Struct Reference
AT32F413_middlewares_usbd_class » USB_audio_hid_class » USB_audio_hid_class_definition

usb audio control struct More...

#include <audio_hid_class.h>

Data Fields

uint8_t | enpd
uint8_t | interface
uint8_t | request_no
uint8_t | spk_mute
uint8_t | mic_mute
uint16_t | spk_volume
uint16_t | mic_volume
uint32_t | spk_freq
uint32_t | mic_freq
uint16_t | spk_volume_limits [3]
uint16_t | mic_volume_limits [3]
uint8_t | audio_cmd
uint32_t | audio_cmd_len
uint32_t | spk_alt_setting
uint32_t | mic_alt_setting
uint8_t | g_audio_cur [64]
uint8_t | audio_spk_data [(48 *2 *(16/8)+40)]
uint8_t | audio_mic_data [(48 *2 *(16/8)+40)]
uint8_t | audio_feed_back [0x3+1]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | g_rxhid_buff [0x40]
uint8_t | g_txhid_buff [0x40]
uint8_t | hid_state

Detailed Description

usb audio control struct

Definition at line 110 of file audio_hid_class.h.

Field Documentation

◆ alt_setting

uint32_t usb_audio_hid_type::alt_setting

Definition at line 137 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ audio_cmd

uint8_t usb_audio_hid_type::audio_cmd

Definition at line 124 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ audio_cmd_len

uint32_t usb_audio_hid_type::audio_cmd_len

Definition at line 125 of file audio_hid_class.h.

Referenced by audio_req_set_cur().

◆ audio_feed_back

uint8_t usb_audio_hid_type::audio_feed_back[0x3+1]

Definition at line 131 of file audio_hid_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_mic_data

uint8_t usb_audio_hid_type::audio_mic_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 130 of file audio_hid_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_spk_data

uint8_t usb_audio_hid_type::audio_spk_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 129 of file audio_hid_class.h.

Referenced by audio_set_interface(), class_init_handler(), and class_out_handler().

◆ enpd

uint8_t usb_audio_hid_type::enpd

Definition at line 112 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_audio_cur

uint8_t usb_audio_hid_type::g_audio_cur[64]

Definition at line 128 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_rxhid_buff

uint8_t usb_audio_hid_type::g_rxhid_buff[0x40]

Definition at line 139 of file audio_hid_class.h.

Referenced by class_init_handler(), class_out_handler(), and usb_hid_buf_process().

◆ g_txhid_buff

uint8_t usb_audio_hid_type::g_txhid_buff[0x40]

Definition at line 140 of file audio_hid_class.h.

Referenced by usb_hid_buf_process().

◆ hid_protocol

uint32_t usb_audio_hid_type::hid_protocol

Definition at line 135 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ hid_set_idle

uint32_t usb_audio_hid_type::hid_set_idle

Definition at line 136 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ hid_set_report

uint8_t usb_audio_hid_type::hid_set_report[64]

Definition at line 138 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_hid_setup_handler().

◆ hid_state

uint8_t usb_audio_hid_type::hid_state

Definition at line 141 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_hid_setup_handler().

◆ interface

uint8_t usb_audio_hid_type::interface

Definition at line 113 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ mic_alt_setting

uint32_t usb_audio_hid_type::mic_alt_setting

Definition at line 127 of file audio_hid_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ mic_freq

uint32_t usb_audio_hid_type::mic_freq

Definition at line 120 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler().

◆ mic_mute

uint8_t usb_audio_hid_type::mic_mute

Definition at line 116 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume

uint16_t usb_audio_hid_type::mic_volume

Definition at line 118 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume_limits

uint16_t usb_audio_hid_type::mic_volume_limits[3]

Definition at line 122 of file audio_hid_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

◆ request_no

uint8_t usb_audio_hid_type::request_no

Definition at line 114 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ spk_alt_setting

uint32_t usb_audio_hid_type::spk_alt_setting

Definition at line 126 of file audio_hid_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ spk_freq

uint32_t usb_audio_hid_type::spk_freq

Definition at line 119 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler().

◆ spk_mute

uint8_t usb_audio_hid_type::spk_mute

Definition at line 115 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume

uint16_t usb_audio_hid_type::spk_volume

Definition at line 117 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume_limits

uint16_t usb_audio_hid_type::spk_volume_limits[3]

Definition at line 121 of file audio_hid_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

The documentation for this struct was generated from the following file:
  • audio_hid_class.h


AT32F413 Firmwary Library: USB_audio_hid_desc

Modules
USB_audio_hid_desc
AT32F413_middlewares_usbd_class

usb device audio hid descriptor More...

Modules

USB_audio_hid_desc_private_functions
USB_audio_hid_desc_definition

Detailed Description

usb device audio hid descriptor


AT32F413 Firmwary Library: USB_audio_hid_desc_private_functions

Functions | Variables
USB_audio_hid_desc_private_functions
AT32F413_middlewares_usbd_class » USB_audio_hid_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 778 of file audio_hid_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 700 of file audio_hid_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 680 of file audio_hid_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 766 of file audio_hid_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 720 of file audio_hid_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 731 of file audio_hid_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 710 of file audio_hid_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 743 of file audio_hid_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 690 of file audio_hid_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 755 of file audio_hid_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 658 of file audio_hid_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 632 of file audio_hid_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 606 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5555 ),
HBYTE( 0x5555 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
0x01
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 60 of file audio_hid_desc.c.

◆ audio_hid_desc_handler

usbd_desc_handler audio_hid_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_hid_desc.c:700
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_hid_desc.c:680
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_hid_desc.c:731
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_hid_desc.c:690
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_hid_desc.c:766
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_hid_desc.c:710
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_hid_desc.c:743
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_hid_desc.c:778
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_hid_desc.c:720
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_hid_desc.c:755

device descriptor handler structure

Definition at line 65 of file audio_hid_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
( 0x12 + ((0x08 + ( 1 + 1 ) ) + ( 1 + 1 ) * 0x22) + + (0x31 + ( ( 0 + 1 ) ) * 3) + (0x31 + ( ( 0 + 1 ) ) * 3) + (9 * 1 ) + 32 ) ,
g_usbd_configuration
}

Definition at line 578 of file audio_hid_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 571 of file audio_hid_desc.c.

Referenced by get_device_descriptor().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 585 of file audio_hid_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 592 of file audio_hid_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 598 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_audio_hid_desc_definition

Macros | Variables
USB_audio_hid_desc_definition
AT32F413_middlewares_usbd_class » USB_audio_hid_desc

Macros

#define | AUHID_BCD_NUM 0x0100
#define | USBD_AUHID_VENDOR_ID 0x2E3C
#define | USBD_AUHID_PRODUCT_ID 0x5555
#define | USBD_AUHID_SIZ_STRING_LANGID 4
#define | USBD_AUHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x0D
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | HID_INTERFACE_NUMBER 0x03
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUHID_HID_BINTERVAL_TIME 0x01
#define | AUHID_HID_BCD_NUM 0x0110
usb bcd number define More...
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | USBD_AUHID_HID_SIZ_REPORT_DESC 126
#define | USBD_AUHID_HID_DESC_SIZE 32
#define | USBD_AUHID_CONFIG_DESC_SIZE

Variables

uint8_t | g_usbd_audio_hid_report [126]
usb hid report descriptor More...
uint8_t | g_audio_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ AT32_AUDIO_FREQ_16K

#define AT32_AUDIO_FREQ_16K 16000

audio support freq

Definition at line 186 of file audio_hid_desc.h.

◆ AT32_AUDIO_FREQ_48K

#define AT32_AUDIO_FREQ_48K 48000

Definition at line 187 of file audio_hid_desc.h.

◆ AUDIO_AC_DESCRIPTOR_UNDEFINED

#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00

audio class-specific ac interface descriptor subtypes

Definition at line 87 of file audio_hid_desc.h.

◆ AUDIO_AC_EXTENSION_UNIT

#define AUDIO_AC_EXTENSION_UNIT 0x08

Definition at line 95 of file audio_hid_desc.h.

◆ AUDIO_AC_FEATURE_UNIT

#define AUDIO_AC_FEATURE_UNIT 0x06

Definition at line 93 of file audio_hid_desc.h.

◆ AUDIO_AC_HEADER

#define AUDIO_AC_HEADER 0x01

Definition at line 88 of file audio_hid_desc.h.

◆ AUDIO_AC_INPUT_TERMINAL

#define AUDIO_AC_INPUT_TERMINAL 0x02

Definition at line 89 of file audio_hid_desc.h.

◆ AUDIO_AC_MIXER_UNIT

#define AUDIO_AC_MIXER_UNIT 0x04

Definition at line 91 of file audio_hid_desc.h.

◆ AUDIO_AC_OUTPUT_TERMINAL

#define AUDIO_AC_OUTPUT_TERMINAL 0x03

Definition at line 90 of file audio_hid_desc.h.

◆ AUDIO_AC_PROCESSING_UNIT

#define AUDIO_AC_PROCESSING_UNIT 0x07

Definition at line 94 of file audio_hid_desc.h.

◆ AUDIO_AC_SELECTOR_UNIT

#define AUDIO_AC_SELECTOR_UNIT 0x05

Definition at line 92 of file audio_hid_desc.h.

◆ AUDIO_AS_DESCRIPTOR_UNDEFINED

#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00

audio class-specific as interface descriptor subtypes

Definition at line 100 of file audio_hid_desc.h.

◆ AUDIO_AS_FORMAT_SPECIFIC

#define AUDIO_AS_FORMAT_SPECIFIC 0x03

Definition at line 103 of file audio_hid_desc.h.

◆ AUDIO_AS_FORMAT_TYPE

#define AUDIO_AS_FORMAT_TYPE 0x02

Definition at line 102 of file audio_hid_desc.h.

◆ AUDIO_AS_GENERAL

#define AUDIO_AS_GENERAL 0x01

Definition at line 101 of file audio_hid_desc.h.

◆ AUDIO_CS_CONFIGURATION

#define AUDIO_CS_CONFIGURATION 0x22

Definition at line 75 of file audio_hid_desc.h.

◆ AUDIO_CS_DEVICE

#define AUDIO_CS_DEVICE 0x21

Definition at line 76 of file audio_hid_desc.h.

◆ AUDIO_CS_ENDPOINT

#define AUDIO_CS_ENDPOINT 0x25

Definition at line 73 of file audio_hid_desc.h.

◆ AUDIO_CS_INTERFACE

#define AUDIO_CS_INTERFACE 0x24

audio class-specific descriptor types

Definition at line 72 of file audio_hid_desc.h.

◆ AUDIO_CS_STRING

#define AUDIO_CS_STRING 0x23

Definition at line 74 of file audio_hid_desc.h.

◆ AUDIO_CS_UNDEFINED

#define AUDIO_CS_UNDEFINED 0x20

Definition at line 77 of file audio_hid_desc.h.

◆ AUDIO_FEATURE_UNIT_SIZE

#define AUDIO_FEATURE_UNIT_SIZE 0x0D

Definition at line 160 of file audio_hid_desc.h.

◆ AUDIO_FORMAT_TYPE_I

#define AUDIO_FORMAT_TYPE_I 0x01

audio format type 1

Definition at line 145 of file audio_hid_desc.h.

◆ AUDIO_FU_BASS_CONTROL

#define AUDIO_FU_BASS_CONTROL 0x03

Definition at line 127 of file audio_hid_desc.h.

◆ AUDIO_FU_CONTROL_UNDEFINED

#define AUDIO_FU_CONTROL_UNDEFINED 0x00

audio feature unit control selectors

Definition at line 124 of file audio_hid_desc.h.

◆ AUDIO_FU_MID_CONTROL

#define AUDIO_FU_MID_CONTROL 0x04

Definition at line 128 of file audio_hid_desc.h.

◆ AUDIO_FU_MUTE_CONTROL

#define AUDIO_FU_MUTE_CONTROL 0x01

Definition at line 125 of file audio_hid_desc.h.

◆ AUDIO_FU_TREBLE_CONTROL

#define AUDIO_FU_TREBLE_CONTROL 0x05

Definition at line 129 of file audio_hid_desc.h.

◆ AUDIO_FU_VOLUME_CONTROL

#define AUDIO_FU_VOLUME_CONTROL 0x02

Definition at line 126 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_MICROPHONE

#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201

Definition at line 138 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_SIZE

#define AUDIO_INPUT_TERMINAL_SIZE 0x0C

audio interface descriptor size define

Definition at line 158 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_UNDEFINED

#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200

Definition at line 137 of file audio_hid_desc.h.

◆ AUDIO_INTERFACE_LEN

#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)

Definition at line 151 of file audio_hid_desc.h.

◆ AUDIO_INTERFACE_NUM

#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)

audio interface config

Definition at line 150 of file audio_hid_desc.h.

◆ AUDIO_MIC_BITW

#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)

Definition at line 194 of file audio_hid_desc.h.

◆ AUDIO_MIC_CHR

#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM

Definition at line 193 of file audio_hid_desc.h.

◆ AUDIO_MIC_FEATURE_UNIT_ID

#define AUDIO_MIC_FEATURE_UNIT_ID 0x02

Definition at line 166 of file audio_hid_desc.h.

◆ AUDIO_MIC_FREQ_SIZE

#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio microphone freq and channel config

Definition at line 192 of file audio_hid_desc.h.

◆ AUDIO_MIC_INPUT_TERMINAL_ID

#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01

audio terminal id define

Definition at line 165 of file audio_hid_desc.h.

◆ AUDIO_MIC_INTERFACE

#define AUDIO_MIC_INTERFACE 0x01

Definition at line 152 of file audio_hid_desc.h.

◆ AUDIO_MIC_INTERFACE_NUMBER

#define AUDIO_MIC_INTERFACE_NUMBER 0x01

audio interface number

Definition at line 175 of file audio_hid_desc.h.

◆ AUDIO_MIC_OUTPUT_TERMINAL_ID

#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03

Definition at line 167 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SIZE

#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09

Definition at line 159 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SPEAKER

#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301

Definition at line 140 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_UNDEFINED

#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300

Definition at line 139 of file audio_hid_desc.h.

◆ AUDIO_PROTOCOL_UNDEFINED

#define AUDIO_PROTOCOL_UNDEFINED 0x00

audio interface protocol codes

Definition at line 82 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_CUR

#define AUDIO_REQ_GET_CUR 0x81

Definition at line 110 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MAX

#define AUDIO_REQ_GET_MAX 0x83

Definition at line 114 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MEM

#define AUDIO_REQ_GET_MEM 0x85

Definition at line 118 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MIN

#define AUDIO_REQ_GET_MIN 0x82

Definition at line 112 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_RES

#define AUDIO_REQ_GET_RES 0x84

Definition at line 116 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_STAT

#define AUDIO_REQ_GET_STAT 0xFF

Definition at line 119 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_CUR

#define AUDIO_REQ_SET_CUR 0x01

Definition at line 109 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MAX

#define AUDIO_REQ_SET_MAX 0x03

Definition at line 113 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MEM

#define AUDIO_REQ_SET_MEM 0x05

Definition at line 117 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MIN

#define AUDIO_REQ_SET_MIN 0x02

Definition at line 111 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_RES

#define AUDIO_REQ_SET_RES 0x04

Definition at line 115 of file audio_hid_desc.h.

◆ AUDIO_REQUEST_CODE_UNDEFINED

#define AUDIO_REQUEST_CODE_UNDEFINED 0x00

audio class-specific request codes

Definition at line 108 of file audio_hid_desc.h.

◆ AUDIO_SPK_BITW

#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)

Definition at line 201 of file audio_hid_desc.h.

◆ AUDIO_SPK_CHR

#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM

Definition at line 200 of file audio_hid_desc.h.

◆ AUDIO_SPK_FEATURE_UNIT_ID

#define AUDIO_SPK_FEATURE_UNIT_ID 0x05

Definition at line 169 of file audio_hid_desc.h.

◆ AUDIO_SPK_FREQ_SIZE

#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio speaker freq and channel config

Definition at line 199 of file audio_hid_desc.h.

◆ AUDIO_SPK_INPUT_TERMINAL_ID

#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04

Definition at line 168 of file audio_hid_desc.h.

◆ AUDIO_SPK_INTERFACE

#define AUDIO_SPK_INTERFACE 0x02

Definition at line 153 of file audio_hid_desc.h.

◆ AUDIO_SPK_INTERFACE_NUMBER

#define AUDIO_SPK_INTERFACE_NUMBER 0x02

Definition at line 177 of file audio_hid_desc.h.

◆ AUDIO_SPK_OUTPUT_TERMINAL_ID

#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06

Definition at line 170 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_AUDIOCONTROL

#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01

Definition at line 65 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_AUDIOSTREAMING

#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02

Definition at line 66 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_MIDISTREMING

#define AUDIO_SUBCLASS_MIDISTREMING 0x03

Definition at line 67 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_UNDEFINED

#define AUDIO_SUBCLASS_UNDEFINED 0x00

audio interface subclass codes

Definition at line 64 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_STREAMING

#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101

Definition at line 135 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_UNDEFINED

#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100

audio terminal type

Definition at line 134 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_VENDOR

#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF

Definition at line 136 of file audio_hid_desc.h.

◆ AUHID_BCD_NUM

#define AUHID_BCD_NUM 0x0100

Definition at line 49 of file audio_hid_desc.h.

◆ AUHID_HID_BCD_NUM

#define AUHID_HID_BCD_NUM 0x0110

usb bcd number define

Definition at line 208 of file audio_hid_desc.h.

◆ AUHID_HID_BINTERVAL_TIME

#define AUHID_HID_BINTERVAL_TIME 0x01

Definition at line 203 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_HID

#define HID_CLASS_DESC_HID 0x21

usb hid class descriptor define

Definition at line 213 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_PHYSICAL

#define HID_CLASS_DESC_PHYSICAL 0x23

Definition at line 215 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_REPORT

#define HID_CLASS_DESC_REPORT 0x22

Definition at line 214 of file audio_hid_desc.h.

◆ HID_INTERFACE_NUMBER

#define HID_INTERFACE_NUMBER 0x03

Definition at line 181 of file audio_hid_desc.h.

◆ HID_REPORT_ID_1

#define HID_REPORT_ID_1 0x01

usb hid report id define

Definition at line 220 of file audio_hid_desc.h.

◆ HID_REPORT_ID_2

#define HID_REPORT_ID_2 0x02

Definition at line 221 of file audio_hid_desc.h.

◆ HID_REPORT_ID_3

#define HID_REPORT_ID_3 0x03

Definition at line 222 of file audio_hid_desc.h.

◆ HID_REPORT_ID_4

#define HID_REPORT_ID_4 0x04

Definition at line 223 of file audio_hid_desc.h.

◆ HID_REPORT_ID_5

#define HID_REPORT_ID_5 0x05

Definition at line 224 of file audio_hid_desc.h.

◆ HID_REPORT_ID_6

#define HID_REPORT_ID_6 0xF0

Definition at line 225 of file audio_hid_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 227 of file audio_hid_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 228 of file audio_hid_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 229 of file audio_hid_desc.h.

◆ SAMPLE_FREQ

#define SAMPLE_FREQ ( frq ) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))

Definition at line 232 of file audio_hid_desc.h.

◆ USBD_AUHID_CONFIG_DESC_SIZE

#define USBD_AUHID_CONFIG_DESC_SIZE
Value:
( 0x12 + AUDIO_INTERFACE_LEN + \
+ (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
+ (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
+ (9 * AUDIO_SUPPORT_FEEDBACK) \
+ USBD_AUHID_HID_DESC_SIZE)
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_hid_desc.h:192
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_hid_desc.h:199
USBD_AUHID_HID_DESC_SIZE
#define USBD_AUHID_HID_DESC_SIZE
Definition: audio_hid_desc.h:235
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_hid_desc.h:151
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:47

Definition at line 236 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_CONFIGURATION_STRING

#define USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"

Definition at line 59 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_INTERFACE_STRING

#define USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"

Definition at line 60 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_MANUFACTURER_STRING

#define USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"

Definition at line 57 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_PRODUCT_STRING

#define USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"

Definition at line 58 of file audio_hid_desc.h.

◆ USBD_AUHID_HID_DESC_SIZE

#define USBD_AUHID_HID_DESC_SIZE 32

Definition at line 235 of file audio_hid_desc.h.

◆ USBD_AUHID_HID_SIZ_REPORT_DESC

#define USBD_AUHID_HID_SIZ_REPORT_DESC 126

Definition at line 234 of file audio_hid_desc.h.

◆ USBD_AUHID_PRODUCT_ID

#define USBD_AUHID_PRODUCT_ID 0x5555

Definition at line 52 of file audio_hid_desc.h.

◆ USBD_AUHID_SIZ_STRING_LANGID

#define USBD_AUHID_SIZ_STRING_LANGID 4

Definition at line 54 of file audio_hid_desc.h.

◆ USBD_AUHID_SIZ_STRING_SERIAL

#define USBD_AUHID_SIZ_STRING_SERIAL 0x1A

Definition at line 55 of file audio_hid_desc.h.

◆ USBD_AUHID_VENDOR_ID

#define USBD_AUHID_VENDOR_ID 0x2E3C

Definition at line 51 of file audio_hid_desc.h.

Variable Documentation

◆ audio_hid_desc_handler

usbd_desc_handler audio_hid_desc_handler
extern

device descriptor handler structure

Definition at line 65 of file audio_hid_desc.c.

Referenced by main().

◆ g_audio_hid_usb_desc

ALIGNED_HEAD uint8_t g_audio_hid_usb_desc
extern
Initial value:
=
{
0x09,
0x21 ,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
0x22 ,
LBYTE(sizeof(g_usbd_audio_hid_report)),
HBYTE(sizeof(g_usbd_audio_hid_report)),
}
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:432
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263

usb hid descriptor

Definition at line 530 of file audio_hid_desc.c.

Referenced by class_hid_setup_handler().

◆ g_usbd_audio_hid_report

ALIGNED_HEAD uint8_t g_usbd_audio_hid_report
extern

usb hid report descriptor

Definition at line 432 of file audio_hid_desc.c.

Referenced by class_hid_setup_handler().


AT32F413 Firmwary Library: USB_cdc_class

Modules
USB_cdc_class
AT32F413_middlewares_usbd_class

usb device class cdc demo More...

Modules

USB_cdc_class_private_functions
USB_cdc_class_definition
USB_cdc_class_exported_types
USB_cdc_class_exported_functions

Detailed Description

usb device class cdc demo


AT32F413 Firmwary Library: USB_cdc_class_private_functions

Functions | Variables
USB_cdc_class_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_struct_init (cdc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_struct_type cdc_struct
usbd_class_handler cdc_class_handler

Detailed Description

Function Documentation

◆ cdc_struct_init()

static usb_sts_type cdc_struct_init ( cdc_struct_type * pcdc )
static

usb device cdc init

Parameters
pcdc to the structure of cdc_struct
Return values
status of usb_sts_type

Definition at line 325 of file cdc_class.c.

Referenced by class_init_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 121 of file cdc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 218 of file cdc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 204 of file cdc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 295 of file cdc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 240 of file cdc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 86 of file cdc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 260 of file cdc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 144 of file cdc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 280 of file cdc_class.c.

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

Definition at line 297 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usb_vcp_cmd_process().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device class request function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 399 of file cdc_class.c.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 343 of file cdc_class.c.

Referenced by main().

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 373 of file cdc_class.c.

Referenced by main().

Variable Documentation

◆ cdc_class_handler

usbd_class_handler cdc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&cdc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_class.c:280
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_class.c:240
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_class.c:121
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_class.c:144
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_class.c:204
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_class.c:218
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_class.c:295
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_class.c:86
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_class.c:260
cdc_struct
cdc_struct_type cdc_struct
Definition: cdc_class.c:64

Definition at line 67 of file cdc_class.c.

Referenced by main().

◆ cdc_struct

cdc_struct_type cdc_struct

Definition at line 64 of file cdc_class.c.

◆ linecoding

linecoding_type linecoding
Initial value:
=
{
115200,
0,
0,
8
}

Definition at line 55 of file cdc_class.c.

Referenced by cdc_struct_init().


AT32F413 Firmwary Library: USB_cdc_class_definition

Macros
USB_cdc_class_definition
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x81
#define | USBD_CDC_BULK_OUT_EPT 0x01
#define | USBD_CDC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08
#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x83
#define | USBD_CDC_BULK_OUT_EPT 0x02
#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Detailed Description

Macro Definition Documentation

◆ USBD_CDC_BULK_IN_EPT [1/2]

#define USBD_CDC_BULK_IN_EPT 0x81

Definition at line 52 of file cdc_class.h.

◆ USBD_CDC_BULK_IN_EPT [2/2]

#define USBD_CDC_BULK_IN_EPT 0x83

Definition at line 52 of file cdc_msc_class.h.

◆ USBD_CDC_BULK_OUT_EPT [1/2]

#define USBD_CDC_BULK_OUT_EPT 0x01

Definition at line 53 of file cdc_class.h.

◆ USBD_CDC_BULK_OUT_EPT [2/2]

#define USBD_CDC_BULK_OUT_EPT 0x02

Definition at line 53 of file cdc_msc_class.h.

◆ USBD_CDC_CMD_MAXPACKET_SIZE [1/2]

#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Definition at line 60 of file cdc_class.h.

◆ USBD_CDC_CMD_MAXPACKET_SIZE [2/2]

#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Definition at line 64 of file cdc_msc_class.h.

◆ USBD_CDC_IN_MAXPACKET_SIZE

#define USBD_CDC_IN_MAXPACKET_SIZE 0x40

usb cdc in and out max packet size define

Definition at line 58 of file cdc_class.h.

◆ USBD_CDC_INT_EPT [1/2]

#define USBD_CDC_INT_EPT 0x82

usb cdc use endpoint define

Definition at line 51 of file cdc_class.h.

◆ USBD_CDC_INT_EPT [2/2]

#define USBD_CDC_INT_EPT 0x82

usb cdc use endpoint define

Definition at line 51 of file cdc_msc_class.h.

◆ USBD_CDC_MSC_IN_MAXPACKET_SIZE

#define USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40

usb cdc in and out max packet size define

Definition at line 61 of file cdc_msc_class.h.

◆ USBD_CDC_MSC_OUT_MAXPACKET_SIZE

#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40

Definition at line 63 of file cdc_msc_class.h.

◆ USBD_CDC_OUT_MAXPACKET_SIZE

#define USBD_CDC_OUT_MAXPACKET_SIZE 0x40

Definition at line 59 of file cdc_class.h.

◆ USBD_MSC_BULK_IN_EPT

#define USBD_MSC_BULK_IN_EPT 0x81

Definition at line 55 of file cdc_msc_class.h.

◆ USBD_MSC_BULK_OUT_EPT

#define USBD_MSC_BULK_OUT_EPT 0x01

Definition at line 56 of file cdc_msc_class.h.


AT32F413 Firmwary Library: USB_cdc_class_exported_types

Modules | Data Structures
USB_cdc_class_exported_types
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class

Modules

USB_msc_bot_scsi_definition
USB_cdc_msc_class_exported_functions

Data Structures

struct | cdc_struct_type
usb cdc class struct More...
struct | vcp_keyboard_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: USB_msc_bot_scsi_definition

Data Structures | Macros | Functions
USB_msc_bot_scsi_definition
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type
struct | cdc_msc_struct_type
usb cdc class struct More...

Macros

#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36
#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Detailed Description

Macro Definition Documentation

◆ ADDRESS_OUT_OF_RANGE [1/2]

#define ADDRESS_OUT_OF_RANGE 0x21

Definition at line 151 of file cdc_msc_class.h.

◆ ADDRESS_OUT_OF_RANGE [2/2]

#define ADDRESS_OUT_OF_RANGE 0x21

Definition at line 117 of file msc_bot_scsi.h.

◆ CBW_BMCBWFLAGS_DIR_IN [1/2]

#define CBW_BMCBWFLAGS_DIR_IN 0x80

Definition at line 110 of file cdc_msc_class.h.

◆ CBW_BMCBWFLAGS_DIR_IN [2/2]

#define CBW_BMCBWFLAGS_DIR_IN 0x80

Definition at line 76 of file msc_bot_scsi.h.

◆ CBW_BMCBWFLAGS_DIR_OUT [1/2]

#define CBW_BMCBWFLAGS_DIR_OUT 0x00

Definition at line 109 of file cdc_msc_class.h.

◆ CBW_BMCBWFLAGS_DIR_OUT [2/2]

#define CBW_BMCBWFLAGS_DIR_OUT 0x00

Definition at line 75 of file msc_bot_scsi.h.

◆ CBW_CMD_LENGTH [1/2]

#define CBW_CMD_LENGTH 31

Definition at line 107 of file cdc_msc_class.h.

◆ CBW_CMD_LENGTH [2/2]

#define CBW_CMD_LENGTH 31

Definition at line 73 of file msc_bot_scsi.h.

◆ CBW_DCBWSIGNATURE [1/2]

#define CBW_DCBWSIGNATURE 0x43425355

Definition at line 108 of file cdc_msc_class.h.

◆ CBW_DCBWSIGNATURE [2/2]

#define CBW_DCBWSIGNATURE 0x43425355

Definition at line 74 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_FAILED [1/2]

#define CSW_BCSWSTATUS_FAILED 0x01

Definition at line 115 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_FAILED [2/2]

#define CSW_BCSWSTATUS_FAILED 0x01

Definition at line 81 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_PASS [1/2]

#define CSW_BCSWSTATUS_PASS 0x00

Definition at line 114 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_PASS [2/2]

#define CSW_BCSWSTATUS_PASS 0x00

Definition at line 80 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_PHASE_ERR [1/2]

#define CSW_BCSWSTATUS_PHASE_ERR 0x02

Definition at line 116 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_PHASE_ERR [2/2]

#define CSW_BCSWSTATUS_PHASE_ERR 0x02

Definition at line 82 of file msc_bot_scsi.h.

◆ CSW_CMD_LENGTH [1/2]

#define CSW_CMD_LENGTH 13

Definition at line 112 of file cdc_msc_class.h.

◆ CSW_CMD_LENGTH [2/2]

#define CSW_CMD_LENGTH 13

Definition at line 78 of file msc_bot_scsi.h.

◆ CSW_DCSWSIGNATURE [1/2]

#define CSW_DCSWSIGNATURE 0x53425355

Definition at line 113 of file cdc_msc_class.h.

◆ CSW_DCSWSIGNATURE [2/2]

#define CSW_DCSWSIGNATURE 0x53425355

Definition at line 79 of file msc_bot_scsi.h.

◆ GET_LINE_CODING [1/2]

#define GET_LINE_CODING 0x21

Definition at line 105 of file cdc_msc_class.h.

◆ GET_LINE_CODING [2/2]

#define GET_LINE_CODING 0x21

Definition at line 71 of file msc_bot_scsi.h.

◆ INVALID_COMMAND [1/2]

#define INVALID_COMMAND 0x20

Definition at line 147 of file cdc_msc_class.h.

◆ INVALID_COMMAND [2/2]

#define INVALID_COMMAND 0x20

Definition at line 113 of file msc_bot_scsi.h.

◆ INVALID_FIELD_IN_PARAMETER_LIST [1/2]

#define INVALID_FIELD_IN_PARAMETER_LIST 0x26

Definition at line 150 of file cdc_msc_class.h.

◆ INVALID_FIELD_IN_PARAMETER_LIST [2/2]

#define INVALID_FIELD_IN_PARAMETER_LIST 0x26

Definition at line 116 of file msc_bot_scsi.h.

◆ INVALID_FIELED_IN_COMMAND [1/2]

#define INVALID_FIELED_IN_COMMAND 0x24

Definition at line 148 of file cdc_msc_class.h.

◆ INVALID_FIELED_IN_COMMAND [2/2]

#define INVALID_FIELED_IN_COMMAND 0x24

Definition at line 114 of file msc_bot_scsi.h.

◆ MEDIUM_HAVE_CHANGED [1/2]

#define MEDIUM_HAVE_CHANGED 0x28

Definition at line 153 of file cdc_msc_class.h.

◆ MEDIUM_HAVE_CHANGED [2/2]

#define MEDIUM_HAVE_CHANGED 0x28

Definition at line 119 of file msc_bot_scsi.h.

◆ MEDIUM_NOT_PRESENT [1/2]

#define MEDIUM_NOT_PRESENT 0x3A

Definition at line 152 of file cdc_msc_class.h.

◆ MEDIUM_NOT_PRESENT [2/2]

#define MEDIUM_NOT_PRESENT 0x3A

Definition at line 118 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_ERROR [1/2]

#define MSC_BOT_STATE_ERROR 0x02

Definition at line 129 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_ERROR [2/2]

#define MSC_BOT_STATE_ERROR 0x02

Definition at line 95 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_IDLE [1/2]

#define MSC_BOT_STATE_IDLE 0x00

Definition at line 127 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_IDLE [2/2]

#define MSC_BOT_STATE_IDLE 0x00

Definition at line 93 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_RECOVERY [1/2]

#define MSC_BOT_STATE_RECOVERY 0x01

Definition at line 128 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_RECOVERY [2/2]

#define MSC_BOT_STATE_RECOVERY 0x01

Definition at line 94 of file msc_bot_scsi.h.

◆ MSC_CMD_ALLOW_MEDIUM_REMOVAL [1/2]

#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E

Definition at line 89 of file cdc_msc_class.h.

◆ MSC_CMD_ALLOW_MEDIUM_REMOVAL [2/2]

#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E

Definition at line 55 of file msc_bot_scsi.h.

◆ MSC_CMD_FORMAT_UNIT [1/2]

#define MSC_CMD_FORMAT_UNIT 0x04

Definition at line 84 of file cdc_msc_class.h.

◆ MSC_CMD_FORMAT_UNIT [2/2]

#define MSC_CMD_FORMAT_UNIT 0x04

Definition at line 50 of file msc_bot_scsi.h.

◆ MSC_CMD_INQUIRY [1/2]

#define MSC_CMD_INQUIRY 0x12

Definition at line 85 of file cdc_msc_class.h.

◆ MSC_CMD_INQUIRY [2/2]

#define MSC_CMD_INQUIRY 0x12

Definition at line 51 of file msc_bot_scsi.h.

◆ MSC_CMD_MODE_SENSE10 [1/2]

#define MSC_CMD_MODE_SENSE10 0x5A

Definition at line 88 of file cdc_msc_class.h.

◆ MSC_CMD_MODE_SENSE10 [2/2]

#define MSC_CMD_MODE_SENSE10 0x5A

Definition at line 54 of file msc_bot_scsi.h.

◆ MSC_CMD_MODE_SENSE6 [1/2]

#define MSC_CMD_MODE_SENSE6 0x1A

Definition at line 87 of file cdc_msc_class.h.

◆ MSC_CMD_MODE_SENSE6 [2/2]

#define MSC_CMD_MODE_SENSE6 0x1A

Definition at line 53 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_10 [1/2]

#define MSC_CMD_READ_10 0x28

Definition at line 90 of file cdc_msc_class.h.

◆ MSC_CMD_READ_10 [2/2]

#define MSC_CMD_READ_10 0x28

Definition at line 56 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_12 [1/2]

#define MSC_CMD_READ_12 0xA8

Definition at line 91 of file cdc_msc_class.h.

◆ MSC_CMD_READ_12 [2/2]

#define MSC_CMD_READ_12 0xA8

Definition at line 57 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_CAPACITY [1/2]

#define MSC_CMD_READ_CAPACITY 0x25

Definition at line 92 of file cdc_msc_class.h.

◆ MSC_CMD_READ_CAPACITY [2/2]

#define MSC_CMD_READ_CAPACITY 0x25

Definition at line 58 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_FORMAT_CAPACITY [1/2]

#define MSC_CMD_READ_FORMAT_CAPACITY 0x23

Definition at line 93 of file cdc_msc_class.h.

◆ MSC_CMD_READ_FORMAT_CAPACITY [2/2]

#define MSC_CMD_READ_FORMAT_CAPACITY 0x23

Definition at line 59 of file msc_bot_scsi.h.

◆ MSC_CMD_REQUEST_SENSE [1/2]

#define MSC_CMD_REQUEST_SENSE 0x03

Definition at line 94 of file cdc_msc_class.h.

◆ MSC_CMD_REQUEST_SENSE [2/2]

#define MSC_CMD_REQUEST_SENSE 0x03

Definition at line 60 of file msc_bot_scsi.h.

◆ MSC_CMD_START_STOP [1/2]

#define MSC_CMD_START_STOP 0x1B

Definition at line 86 of file cdc_msc_class.h.

◆ MSC_CMD_START_STOP [2/2]

#define MSC_CMD_START_STOP 0x1B

Definition at line 52 of file msc_bot_scsi.h.

◆ MSC_CMD_TEST_UNIT [1/2]

#define MSC_CMD_TEST_UNIT 0x00

Definition at line 95 of file cdc_msc_class.h.

◆ MSC_CMD_TEST_UNIT [2/2]

#define MSC_CMD_TEST_UNIT 0x00

Definition at line 61 of file msc_bot_scsi.h.

◆ MSC_CMD_VERIFY [1/2]

#define MSC_CMD_VERIFY 0x2F

Definition at line 96 of file cdc_msc_class.h.

◆ MSC_CMD_VERIFY [2/2]

#define MSC_CMD_VERIFY 0x2F

Definition at line 62 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_10 [1/2]

#define MSC_CMD_WRITE_10 0x2A

Definition at line 97 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_10 [2/2]

#define MSC_CMD_WRITE_10 0x2A

Definition at line 63 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_12 [1/2]

#define MSC_CMD_WRITE_12 0xAA

Definition at line 98 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_12 [2/2]

#define MSC_CMD_WRITE_12 0xAA

Definition at line 64 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_VERIFY [1/2]

#define MSC_CMD_WRITE_VERIFY 0x2E

Definition at line 99 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_VERIFY [2/2]

#define MSC_CMD_WRITE_VERIFY 0x2E

Definition at line 65 of file msc_bot_scsi.h.

◆ MSC_MAX_DATA_BUF_LEN [1/2]

#define MSC_MAX_DATA_BUF_LEN 4096

Definition at line 82 of file cdc_msc_class.h.

◆ MSC_MAX_DATA_BUF_LEN [2/2]

#define MSC_MAX_DATA_BUF_LEN 4096

Definition at line 48 of file msc_bot_scsi.h.

◆ MSC_REQ_BO_RESET [1/2]

#define MSC_REQ_BO_RESET 0xFF

bulk only mass storage reset

Definition at line 102 of file cdc_msc_class.h.

◆ MSC_REQ_BO_RESET [2/2]

#define MSC_REQ_BO_RESET 0xFF

bulk only mass storage reset

Definition at line 68 of file msc_bot_scsi.h.

◆ MSC_REQ_GET_MAX_LUN [1/2]

#define MSC_REQ_GET_MAX_LUN 0xFE

get max lun

Definition at line 101 of file cdc_msc_class.h.

◆ MSC_REQ_GET_MAX_LUN [2/2]

#define MSC_REQ_GET_MAX_LUN 0xFE

get max lun

Definition at line 67 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_CMD [1/2]

#define MSC_STATE_MACHINE_CMD 0x00

Definition at line 118 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_CMD [2/2]

#define MSC_STATE_MACHINE_CMD 0x00

Definition at line 84 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_DATA_IN [1/2]

#define MSC_STATE_MACHINE_DATA_IN 0x01

Definition at line 119 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_DATA_IN [2/2]

#define MSC_STATE_MACHINE_DATA_IN 0x01

Definition at line 85 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_DATA_OUT [1/2]

#define MSC_STATE_MACHINE_DATA_OUT 0x02

Definition at line 120 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_DATA_OUT [2/2]

#define MSC_STATE_MACHINE_DATA_OUT 0x02

Definition at line 86 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_FAILED [1/2]

#define MSC_STATE_MACHINE_FAILED 0x06

Definition at line 124 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_FAILED [2/2]

#define MSC_STATE_MACHINE_FAILED 0x06

Definition at line 90 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_IDLE [1/2]

#define MSC_STATE_MACHINE_IDLE 0x07

Definition at line 125 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_IDLE [2/2]

#define MSC_STATE_MACHINE_IDLE 0x07

Definition at line 91 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_LAST_DATA [1/2]

#define MSC_STATE_MACHINE_LAST_DATA 0x04

Definition at line 122 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_LAST_DATA [2/2]

#define MSC_STATE_MACHINE_LAST_DATA 0x04

Definition at line 88 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_SEND_DATA [1/2]

#define MSC_STATE_MACHINE_SEND_DATA 0x03

Definition at line 121 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_SEND_DATA [2/2]

#define MSC_STATE_MACHINE_SEND_DATA 0x03

Definition at line 87 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_STATUS [1/2]

#define MSC_STATE_MACHINE_STATUS 0x05

Definition at line 123 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_STATUS [2/2]

#define MSC_STATE_MACHINE_STATUS 0x05

Definition at line 89 of file msc_bot_scsi.h.

◆ MSC_SUPPORT_MAX_LUN [1/2]

#define MSC_SUPPORT_MAX_LUN 1

Definition at line 81 of file cdc_msc_class.h.

◆ MSC_SUPPORT_MAX_LUN [2/2]

#define MSC_SUPPORT_MAX_LUN 1

Definition at line 47 of file msc_bot_scsi.h.

◆ PARAMETER_LIST_LENGTH_ERROR [1/2]

#define PARAMETER_LIST_LENGTH_ERROR 0x1A

Definition at line 149 of file cdc_msc_class.h.

◆ PARAMETER_LIST_LENGTH_ERROR [2/2]

#define PARAMETER_LIST_LENGTH_ERROR 0x1A

Definition at line 115 of file msc_bot_scsi.h.

◆ REQ_SENSE_STANDARD_DATA_LEN [1/2]

#define REQ_SENSE_STANDARD_DATA_LEN 0x12

Definition at line 131 of file cdc_msc_class.h.

◆ REQ_SENSE_STANDARD_DATA_LEN [2/2]

#define REQ_SENSE_STANDARD_DATA_LEN 0x12

Definition at line 97 of file msc_bot_scsi.h.

◆ SCSI_INQUIRY_DATA_LENGTH [1/2]

#define SCSI_INQUIRY_DATA_LENGTH 36

Definition at line 155 of file cdc_msc_class.h.

◆ SCSI_INQUIRY_DATA_LENGTH [2/2]

#define SCSI_INQUIRY_DATA_LENGTH 36

Definition at line 121 of file msc_bot_scsi.h.

◆ SENSE_KEY_ABORTED_COMMAND [1/2]

#define SENSE_KEY_ABORTED_COMMAND 0x0B

Definition at line 142 of file cdc_msc_class.h.

◆ SENSE_KEY_ABORTED_COMMAND [2/2]

#define SENSE_KEY_ABORTED_COMMAND 0x0B

Definition at line 108 of file msc_bot_scsi.h.

◆ SENSE_KEY_BLANK_CHECK [1/2]

#define SENSE_KEY_BLANK_CHECK 0x08

Definition at line 140 of file cdc_msc_class.h.

◆ SENSE_KEY_BLANK_CHECK [2/2]

#define SENSE_KEY_BLANK_CHECK 0x08

Definition at line 106 of file msc_bot_scsi.h.

◆ SENSE_KEY_DATA_PROTECT [1/2]

#define SENSE_KEY_DATA_PROTECT 0x07

Definition at line 139 of file cdc_msc_class.h.

◆ SENSE_KEY_DATA_PROTECT [2/2]

#define SENSE_KEY_DATA_PROTECT 0x07

Definition at line 105 of file msc_bot_scsi.h.

◆ SENSE_KEY_HARDWARE_ERROR [1/2]

#define SENSE_KEY_HARDWARE_ERROR 0x04

Definition at line 136 of file cdc_msc_class.h.

◆ SENSE_KEY_HARDWARE_ERROR [2/2]

#define SENSE_KEY_HARDWARE_ERROR 0x04

Definition at line 102 of file msc_bot_scsi.h.

◆ SENSE_KEY_ILLEGAL_REQUEST [1/2]

#define SENSE_KEY_ILLEGAL_REQUEST 0x05

Definition at line 137 of file cdc_msc_class.h.

◆ SENSE_KEY_ILLEGAL_REQUEST [2/2]

#define SENSE_KEY_ILLEGAL_REQUEST 0x05

Definition at line 103 of file msc_bot_scsi.h.

◆ SENSE_KEY_MEDIUM_ERROR [1/2]

#define SENSE_KEY_MEDIUM_ERROR 0x03

Definition at line 135 of file cdc_msc_class.h.

◆ SENSE_KEY_MEDIUM_ERROR [2/2]

#define SENSE_KEY_MEDIUM_ERROR 0x03

Definition at line 101 of file msc_bot_scsi.h.

◆ SENSE_KEY_MISCOMPARE [1/2]

#define SENSE_KEY_MISCOMPARE 0x0E

Definition at line 144 of file cdc_msc_class.h.

◆ SENSE_KEY_MISCOMPARE [2/2]

#define SENSE_KEY_MISCOMPARE 0x0E

Definition at line 110 of file msc_bot_scsi.h.

◆ SENSE_KEY_NO_SENSE [1/2]

#define SENSE_KEY_NO_SENSE 0x00

Definition at line 132 of file cdc_msc_class.h.

◆ SENSE_KEY_NO_SENSE [2/2]

#define SENSE_KEY_NO_SENSE 0x00

Definition at line 98 of file msc_bot_scsi.h.

◆ SENSE_KEY_NOT_READY [1/2]

#define SENSE_KEY_NOT_READY 0x02

Definition at line 134 of file cdc_msc_class.h.

◆ SENSE_KEY_NOT_READY [2/2]

#define SENSE_KEY_NOT_READY 0x02

Definition at line 100 of file msc_bot_scsi.h.

◆ SENSE_KEY_RECOVERED_ERROR [1/2]

#define SENSE_KEY_RECOVERED_ERROR 0x01

Definition at line 133 of file cdc_msc_class.h.

◆ SENSE_KEY_RECOVERED_ERROR [2/2]

#define SENSE_KEY_RECOVERED_ERROR 0x01

Definition at line 99 of file msc_bot_scsi.h.

◆ SENSE_KEY_UNIT_ATTENTION [1/2]

#define SENSE_KEY_UNIT_ATTENTION 0x06

Definition at line 138 of file cdc_msc_class.h.

◆ SENSE_KEY_UNIT_ATTENTION [2/2]

#define SENSE_KEY_UNIT_ATTENTION 0x06

Definition at line 104 of file msc_bot_scsi.h.

◆ SENSE_KEY_VENDERO_SPECIFIC [1/2]

#define SENSE_KEY_VENDERO_SPECIFIC 0x09

Definition at line 141 of file cdc_msc_class.h.

◆ SENSE_KEY_VENDERO_SPECIFIC [2/2]

#define SENSE_KEY_VENDERO_SPECIFIC 0x09

Definition at line 107 of file msc_bot_scsi.h.

◆ SENSE_KEY_VOLUME_OVERFLOW [1/2]

#define SENSE_KEY_VOLUME_OVERFLOW 0x0D

Definition at line 143 of file cdc_msc_class.h.

◆ SENSE_KEY_VOLUME_OVERFLOW [2/2]

#define SENSE_KEY_VOLUME_OVERFLOW 0x0D

Definition at line 109 of file msc_bot_scsi.h.

◆ SET_LINE_CODING [1/2]

#define SET_LINE_CODING 0x20

Definition at line 104 of file cdc_msc_class.h.

◆ SET_LINE_CODING [2/2]

#define SET_LINE_CODING 0x20

Definition at line 70 of file msc_bot_scsi.h.

Function Documentation

◆ bot_cbw_decode()

void bot_cbw_decode ( void * udev )

bulk-only cbw decode

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 195 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_dataout_handler().

◆ bot_scsi_allow_medium_removal()

usb_sts_type bot_scsi_allow_medium_removal | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command meidum removal

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 422 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_capacity()

usb_sts_type bot_scsi_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 476 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_check_address()

usb_sts_type bot_scsi_check_address | ( | void * | udev,
 |  | uint8_t | lun,
 |  | uint32_t | blk_offset,
 |  | uint32_t | blk_count
 | ) |  |

check address

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type

Definition at line 302 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_clear_feature()

void bot_scsi_clear_feature | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

clear feature

Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type

Definition at line 728 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_cmd_process()

usb_sts_type bot_scsi_cmd_process ( void * udev )

bulk-only transport scsi command process

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type
Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 748 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), and bot_scsi_dataout_handler().

◆ bot_scsi_datain_handler()

void bot_scsi_datain_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data in handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 142 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_dataout_handler()

void bot_scsi_dataout_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data out handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 171 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_format_capacity()

usb_sts_type bot_scsi_format_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command format capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 503 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_init()

void bot_scsi_init ( void * udev )

initialize bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 102 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_inquiry()

usb_sts_type bot_scsi_inquiry | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command inquiry

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 367 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense10()

usb_sts_type bot_scsi_mode_sense10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 456 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense6()

usb_sts_type bot_scsi_mode_sense6 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense6

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 436 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_read10()

usb_sts_type bot_scsi_read10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command read10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 597 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_request_sense()

usb_sts_type bot_scsi_request_sense | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command request sense

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 538 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_reset()

void bot_scsi_reset ( void * udev )

reset bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 124 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_send_csw()

void bot_scsi_send_csw | ( | void * | udev,
 |  | uint8_t | status
 | ) |  |

send command status

Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none
Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none

Definition at line 263 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), and bot_scsi_write10().

◆ bot_scsi_send_data()

void bot_scsi_send_data | ( | void * | udev,
 |  | uint8_t * | buffer,
 |  | uint32_t | len
 | ) |  |

send bot data

Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none
Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none

Definition at line 242 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_sense_code()

void bot_scsi_sense_code | ( | void * | udev,
 |  | uint8_t | sense_key,
 |  | uint8_t | asc
 | ) |  |

send scsi sense code

Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none
Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none

Definition at line 287 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_check_address(), bot_scsi_cmd_process(), bot_scsi_read10(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_stall()

void bot_scsi_stall ( void * udev )

bot endpoint stall

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 319 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_start_stop()

usb_sts_type bot_scsi_start_stop | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command start stop

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 408 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_test_unit()

usb_sts_type bot_scsi_test_unit | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command test unit

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 345 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_verify()

usb_sts_type bot_scsi_verify | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command verify

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 569 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_write10()

usb_sts_type bot_scsi_write10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command write10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 658 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().


AT32F413 Firmwary Library: cbd_typical_type Struct Reference

Data Fields
cbd_typical_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

typical command block description More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | opcode
uint8_t | lun
uint32_t | address
uint8_t | reserved1
uint32_t | alloc_length
uint16_t | reserved2

Detailed Description

typical command block description

Definition at line 160 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: cbd_extended_type Struct Reference

Data Fields
cbd_extended_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

extended command block description More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | opcode
uint8_t | lun
uint32_t | address
uint8_t | reserved1
uint32_t | alloc_length
uint16_t | reserved2

Detailed Description

extended command block description

Definition at line 173 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: cbw_type Struct Reference

Data Fields
cbw_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

command block wrapper More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | dCBWSignature
uint32_t | dCBWTage
uint32_t | dCBWDataTransferLength
uint8_t | bmCBWFlags
uint8_t | bCBWLUN
uint8_t | bCBWCBLength
uint8_t | CBWCB [16]

Detailed Description

command block wrapper

Definition at line 186 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: csw_type Struct Reference

Data Fields
csw_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

command block wrapper More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | dCSWSignature
uint32_t | dCSWTag
uint32_t | dCSWDataResidue
uint32_t | bCSWStatus

Detailed Description

command block wrapper

Definition at line 200 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: sense_type Struct Reference

Data Fields
sense_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

request sense standard data More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | err_code
uint8_t | reserved1
uint8_t | sense_key
uint32_t | information
uint8_t | as_length
uint32_t | reserved2
uint8_t | asc
uint8_t | ascq
uint32_t | reserved3

Detailed Description

request sense standard data

Definition at line 211 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: msc_type Struct Reference

Data Fields
msc_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

#include <cdc_msc_class.h>

Data Fields

uint8_t | msc_state
uint8_t | bot_status
uint32_t | max_lun
uint32_t | blk_nbr [1]
uint32_t | blk_size [1]
uint32_t | blk_addr
uint32_t | blk_len
uint32_t | data_len
uint8_t | data [4096]
uint32_t | alt_setting
cbw_type cbw_struct
csw_type csw_struct
uint64_t | blk_addr

Detailed Description

Definition at line 225 of file cdc_msc_class.h.

Field Documentation

◆ blk_addr

uint64_t msc_type::blk_addr

Definition at line 200 of file msc_bot_scsi.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: cdc_msc_struct_type Struct Reference

Data Fields
cdc_msc_struct_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

usb cdc class struct More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | alt_setting
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
linecoding_type linecoding
uint8_t | msc_state
uint8_t | bot_status
uint32_t | max_lun
uint32_t | blk_nbr [1]
uint32_t | blk_size [1]
uint64_t | blk_addr
uint32_t | blk_len
uint32_t | data_len
uint8_t | data [4096]
cbw_type cbw_struct
csw_type csw_struct

Detailed Description

usb cdc class struct

Definition at line 250 of file cdc_msc_class.h.

The documentation for this struct was generated from the following file:
  • cdc_msc_class.h


AT32F413 Firmwary Library: USB_cdc_msc_class_exported_functions

Functions | Variables
USB_cdc_msc_class_exported_functions
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_msc_class_handler

Detailed Description

Function Documentation

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len
Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 343 of file cdc_class.c.

Referenced by main().

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status
Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 373 of file cdc_class.c.

Referenced by main().

Variable Documentation

◆ cdc_msc_class_handler

usbd_class_handler cdc_msc_class_handler
extern

Definition at line 70 of file cdc_msc_class.c.

Referenced by main().


AT32F413 Firmwary Library: cdc_struct_type Struct Reference

Data Fields
cdc_struct_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

usb cdc class struct More...

#include <cdc_class.h>

Data Fields

uint32_t | alt_setting
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
linecoding_type linecoding

Detailed Description

usb cdc class struct

Definition at line 73 of file cdc_class.h.

Field Documentation

◆ alt_setting

uint32_t cdc_struct_type::alt_setting

Definition at line 75 of file cdc_class.h.

Referenced by cdc_struct_init(), and class_setup_handler().

◆ g_cmd

uint8_t cdc_struct_type::g_cmd[0x08]

Definition at line 77 of file cdc_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ g_len

uint16_t cdc_struct_type::g_len

Definition at line 79 of file cdc_class.h.

Referenced by class_setup_handler().

◆ g_req

uint8_t cdc_struct_type::g_req

Definition at line 78 of file cdc_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ g_rx_buff

uint8_t cdc_struct_type::g_rx_buff[0x40]

Definition at line 76 of file cdc_class.h.

Referenced by class_init_handler(), and usb_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t cdc_struct_type::g_rx_completed

Definition at line 80 of file cdc_class.h.

Referenced by cdc_struct_init(), class_out_handler(), and usb_vcp_get_rxdata().

◆ g_rxlen

uint16_t cdc_struct_type::g_rxlen

Definition at line 79 of file cdc_class.h.

Referenced by class_out_handler(), and usb_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t cdc_struct_type::g_tx_completed

Definition at line 80 of file cdc_class.h.

Referenced by cdc_struct_init(), class_in_handler(), and usb_vcp_send_data().

◆ linecoding

linecoding_type cdc_struct_type::linecoding

Definition at line 81 of file cdc_class.h.

Referenced by cdc_struct_init(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • cdc_class.h


AT32F413 Firmwary Library: vcp_keyboard_type Struct Reference

Data Fields
vcp_keyboard_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

#include <cdc_keyboard_class.h>

Data Fields

uint32_t | alt_setting
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint8_t | hid_set_report [64]
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint8_t | hid_state
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
__IO uint8_t | g_keyboard_tx_completed
linecoding_type linecoding

Detailed Description

Definition at line 72 of file cdc_keyboard_class.h.

Field Documentation

◆ alt_setting

uint32_t vcp_keyboard_type::alt_setting

Definition at line 74 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and keyboard_class_setup_handler().

◆ g_cmd

uint8_t vcp_keyboard_type::g_cmd[0x08]

Definition at line 80 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_keyboard_tx_completed

__IO uint8_t vcp_keyboard_type::g_keyboard_tx_completed

Definition at line 86 of file cdc_keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and keyboard_send_string().

◆ g_len

uint16_t vcp_keyboard_type::g_len

Definition at line 83 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler().

◆ g_req

uint8_t vcp_keyboard_type::g_req

Definition at line 81 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_rx_buff

uint8_t vcp_keyboard_type::g_rx_buff[0x40]

Definition at line 79 of file cdc_keyboard_class.h.

Referenced by class_init_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t vcp_keyboard_type::g_rx_completed

Definition at line 85 of file cdc_keyboard_class.h.

Referenced by class_out_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_rxlen

uint16_t vcp_keyboard_type::g_rxlen

Definition at line 83 of file cdc_keyboard_class.h.

Referenced by class_out_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t vcp_keyboard_type::g_tx_completed

Definition at line 84 of file cdc_keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and usb_vcpkybrd_vcp_send_data().

◆ hid_protocol

uint32_t vcp_keyboard_type::hid_protocol

Definition at line 75 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_set_idle

uint32_t vcp_keyboard_type::hid_set_idle

Definition at line 76 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_set_report

uint8_t vcp_keyboard_type::hid_set_report[64]

Definition at line 78 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_state

uint8_t vcp_keyboard_type::hid_state

Definition at line 82 of file cdc_keyboard_class.h.

Referenced by class_ept0_rx_handler(), and keyboard_class_setup_handler().

◆ linecoding

linecoding_type vcp_keyboard_type::linecoding

Definition at line 88 of file cdc_keyboard_class.h.

Referenced by class_init_handler(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • cdc_keyboard_class.h


AT32F413 Firmwary Library: USB_cdc_class_exported_functions

Functions | Variables
USB_cdc_class_exported_functions
AT32F413_middlewares_usbd_class » USB_cdc_class

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_class_handler

Detailed Description

Function Documentation

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len
Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 343 of file cdc_class.c.

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status
Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 373 of file cdc_class.c.

Variable Documentation

◆ cdc_class_handler

usbd_class_handler cdc_class_handler
extern

Definition at line 67 of file cdc_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_desc

Modules | Variables
USB_cdc_desc
AT32F413_middlewares_usbd_class

usb device cdc descriptor More...

Modules

USB_cdc_desc_private_functions
USB_cdc_desc_definition

Variables

usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc descriptor

Variable Documentation

◆ cdc_desc_handler

usbd_desc_handler cdc_desc_handler
extern

device descriptor handler structure

Definition at line 64 of file cdc_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_desc_private_functions

Functions | Variables
USB_cdc_desc_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 429 of file cdc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 351 of file cdc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 331 of file cdc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 417 of file cdc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 371 of file cdc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 382 of file cdc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 361 of file cdc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 394 of file cdc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 341 of file cdc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 406 of file cdc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 309 of file cdc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 283 of file cdc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 257 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x02,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5740 ),
HBYTE( 0x5740 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 59 of file cdc_desc.c.

◆ cdc_desc_handler

usbd_desc_handler cdc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_desc.c:351
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_desc.c:331
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_desc.c:382
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_desc.c:341
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_desc.c:417
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_desc.c:361
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_desc.c:394
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_desc.c:429
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_desc.c:371
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_desc.c:406

device descriptor handler structure

Definition at line 64 of file cdc_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
67 ,
g_usbd_configuration
}

Definition at line 229 of file cdc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 222 of file cdc_desc.c.

Referenced by get_device_descriptor().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 236 of file cdc_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 243 of file cdc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 249 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_cdc_desc_definition

Macros
USB_cdc_desc_definition
AT32F413_middlewares_usbd_class » USB_cdc_desc | AT32F413_middlewares_usbd_class » USB_cdc_msc_desc

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_PRODUCT_ID 0x5740
#define | USBD_CDC_CONFIG_DESC_SIZE 67
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_MSC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_MSC_PRODUCT_ID 0x5760
#define | USBD_CDC_MSC_CONFIG_DESC_SIZE 106
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | VCPMSC_MSC_INTERFACE 0x00
usb interface define More...
#define | VCPMSC_CDC_INTERFACE 0x01
#define | VCPMSC_CDC_DATA_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ CDC_BCD_NUM [1/2]

#define CDC_BCD_NUM 0x0110

usb bcd number define

Definition at line 50 of file cdc_desc.h.

◆ CDC_BCD_NUM [2/2]

#define CDC_BCD_NUM 0x0110

usb bcd number define

Definition at line 50 of file cdc_msc_desc.h.

◆ CDC_HID_BINTERVAL_TIME [1/2]

#define CDC_HID_BINTERVAL_TIME 0xFF

usb endpoint interval define

Definition at line 76 of file cdc_desc.h.

◆ CDC_HID_BINTERVAL_TIME [2/2]

#define CDC_HID_BINTERVAL_TIME 0xFF

usb endpoint interval define

Definition at line 77 of file cdc_msc_desc.h.

◆ MCU_ID1 [1/2]

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 81 of file cdc_desc.h.

◆ MCU_ID1 [2/2]

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 90 of file cdc_msc_desc.h.

◆ MCU_ID2 [1/2]

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 82 of file cdc_desc.h.

◆ MCU_ID2 [2/2]

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 91 of file cdc_msc_desc.h.

◆ MCU_ID3 [1/2]

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 83 of file cdc_desc.h.

◆ MCU_ID3 [2/2]

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 92 of file cdc_msc_desc.h.

◆ USBD_CDC_CONFIG_DESC_SIZE

#define USBD_CDC_CONFIG_DESC_SIZE 67

usb descriptor size define

Definition at line 61 of file cdc_desc.h.

◆ USBD_CDC_DESC_CONFIGURATION_STRING [1/2]

#define USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"

Definition at line 70 of file cdc_desc.h.

◆ USBD_CDC_DESC_CONFIGURATION_STRING [2/2]

#define USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"

Definition at line 71 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_INTERFACE_STRING [1/2]

#define USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"

Definition at line 71 of file cdc_desc.h.

◆ USBD_CDC_DESC_INTERFACE_STRING [2/2]

#define USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"

Definition at line 72 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_MANUFACTURER_STRING [1/2]

#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 68 of file cdc_desc.h.

◆ USBD_CDC_DESC_MANUFACTURER_STRING [2/2]

#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 69 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_PRODUCT_STRING [1/2]

#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "

Definition at line 69 of file cdc_desc.h.

◆ USBD_CDC_DESC_PRODUCT_STRING [2/2]

#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "

Definition at line 70 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_CONFIG_DESC_SIZE

#define USBD_CDC_MSC_CONFIG_DESC_SIZE 106

usb descriptor size define

Definition at line 62 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_PRODUCT_ID

#define USBD_CDC_MSC_PRODUCT_ID 0x5760

Definition at line 56 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_VENDOR_ID

#define USBD_CDC_MSC_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 55 of file cdc_msc_desc.h.

◆ USBD_CDC_PRODUCT_ID

#define USBD_CDC_PRODUCT_ID 0x5740

Definition at line 56 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_LANGID [1/2]

#define USBD_CDC_SIZ_STRING_LANGID 4

Definition at line 62 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_LANGID [2/2]

#define USBD_CDC_SIZ_STRING_LANGID 4

Definition at line 63 of file cdc_msc_desc.h.

◆ USBD_CDC_SIZ_STRING_SERIAL [1/2]

#define USBD_CDC_SIZ_STRING_SERIAL 0x1A

Definition at line 63 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_SERIAL [2/2]

#define USBD_CDC_SIZ_STRING_SERIAL 0x1A

Definition at line 64 of file cdc_msc_desc.h.

◆ USBD_CDC_VENDOR_ID

#define USBD_CDC_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 55 of file cdc_desc.h.

◆ VCPMSC_CDC_DATA_INTERFACE

#define VCPMSC_CDC_DATA_INTERFACE 0x02

Definition at line 84 of file cdc_msc_desc.h.

◆ VCPMSC_CDC_INTERFACE

#define VCPMSC_CDC_INTERFACE 0x01

Definition at line 83 of file cdc_msc_desc.h.

◆ VCPMSC_MSC_INTERFACE

#define VCPMSC_MSC_INTERFACE 0x00

usb interface define

Definition at line 82 of file cdc_msc_desc.h.


AT32F413 Firmwary Library: USB_cdc_keyboard_class

Modules
USB_cdc_keyboard_class
AT32F413_middlewares_usbd_class

usb device class composite cdc and keyboard More...

Modules

USB_cdc_keyboard_class_private_functions
USB_cdc_keyboard_class_definition
USB_cdc_class_exported_types
USB_cdc_keyboar_class_exported_functions

Detailed Description

usb device class composite cdc and keyboard


AT32F413 Firmwary Library: USB_cdc_keyboard_class_private_functions

Macros | Functions | Variables
USB_cdc_keyboard_class_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | keyboard_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

vcp_keyboard_type vcp_keyboard_struct
static const unsigned char _asciimap [128]
linecoding_type linecoding_vcpkybrd
usbd_class_handler cdc_keyboard_class_handler

Detailed Description

Macro Definition Documentation

◆ SHIFT

#define SHIFT 0x80

Definition at line 57 of file cdc_keyboard_class.c.

Function Documentation

◆ cdc_class_setup_handler()

static usb_sts_type cdc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 320 of file cdc_keyboard_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 265 of file cdc_keyboard_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 474 of file cdc_keyboard_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 460 of file cdc_keyboard_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 564 of file cdc_keyboard_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 501 of file cdc_keyboard_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 222 of file cdc_keyboard_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 529 of file cdc_keyboard_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 291 of file cdc_keyboard_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 549 of file cdc_keyboard_class.c.

◆ keyboard_class_setup_handler()

static usb_sts_type keyboard_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 381 of file cdc_keyboard_class.c.

Referenced by class_setup_handler().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device class request function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 652 of file cdc_keyboard_class.c.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ usb_vcpkybrd_class_send_report()

usb_sts_type usb_vcpkybrd_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 687 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ usb_vcpkybrd_keyboard_send_char()

void usb_vcpkybrd_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb keyoard send char

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 705 of file cdc_keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_vcpkybrd_vcp_get_rxdata()

uint16_t usb_vcpkybrd_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 595 of file cdc_keyboard_class.c.

Referenced by main().

◆ usb_vcpkybrd_vcp_send_data()

error_status usb_vcpkybrd_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 626 of file cdc_keyboard_class.c.

Referenced by main().

Variable Documentation

◆ _asciimap

const unsigned char _asciimap[128]
static

Definition at line 58 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ cdc_keyboard_class_handler

usbd_class_handler cdc_keyboard_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&vcp_keyboard_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_keyboard_class.c:549
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_keyboard_class.c:501
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_keyboard_class.c:265
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:291
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_keyboard_class.c:460
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_keyboard_class.c:474
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_keyboard_class.c:564
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_keyboard_class.c:222
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_keyboard_class.c:529
vcp_keyboard_struct
vcp_keyboard_type vcp_keyboard_struct
Definition: cdc_keyboard_class.c:55

Definition at line 203 of file cdc_keyboard_class.c.

Referenced by main().

◆ linecoding_vcpkybrd

linecoding_type linecoding_vcpkybrd
Initial value:
=
{
115200,
0x00,
0x00,
0x08
}

Definition at line 191 of file cdc_keyboard_class.c.

Referenced by class_init_handler().

◆ vcp_keyboard_struct

vcp_keyboard_type vcp_keyboard_struct

Definition at line 55 of file cdc_keyboard_class.c.


AT32F413 Firmwary Library: USB_cdc_keyboard_class_definition

Macros
USB_cdc_keyboard_class_definition
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class

Macros

#define | USBD_VCPKYBRD_CDC_INT_EPT 0x82
usb use endpoint define More...
#define | USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
#define | USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
#define | USBD_VCPKYBRD_HID_IN_EPT 0x83
#define | USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
usb in and out max packet size define More...
#define | USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
#define | USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Detailed Description

Macro Definition Documentation

◆ USBD_VCPKYBRD_CDC_BULK_IN_EPT

#define USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81

Definition at line 52 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CDC_BULK_OUT_EPT

#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01

Definition at line 53 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CDC_INT_EPT

#define USBD_VCPKYBRD_CDC_INT_EPT 0x82

usb use endpoint define

Definition at line 51 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CMD_MAXPACKET_SIZE

#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Definition at line 61 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_HID_IN_EPT

#define USBD_VCPKYBRD_HID_IN_EPT 0x83

Definition at line 54 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_IN_MAXPACKET_SIZE

#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40

usb in and out max packet size define

Definition at line 59 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_OUT_MAXPACKET_SIZE

#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40

Definition at line 60 of file cdc_keyboard_class.h.


AT32F413 Firmwary Library: USB_cdc_keyboar_class_exported_functions

Functions | Variables
USB_cdc_keyboar_class_exported_functions
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class

Functions

uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

usbd_class_handler cdc_keyboard_class_handler

Detailed Description

Function Documentation

◆ usb_vcpkybrd_class_send_report()

usb_sts_type usb_vcpkybrd_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 687 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ usb_vcpkybrd_keyboard_send_char()

void usb_vcpkybrd_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb keyoard send char

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 705 of file cdc_keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_vcpkybrd_vcp_get_rxdata()

uint16_t usb_vcpkybrd_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 595 of file cdc_keyboard_class.c.

Referenced by main().

◆ usb_vcpkybrd_vcp_send_data()

error_status usb_vcpkybrd_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 626 of file cdc_keyboard_class.c.

Referenced by main().

Variable Documentation

◆ cdc_keyboard_class_handler

usbd_class_handler cdc_keyboard_class_handler
extern

Definition at line 203 of file cdc_keyboard_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_keyboard_desc

Modules | Variables
USB_cdc_keyboard_desc
AT32F413_middlewares_usbd_class

usb device cdc keyboard descriptor More...

Modules

USB_cdc_keyboard_desc_private_functions
USB_cdc_keyboard_desc_definition

Variables

usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc keyboard descriptor

Variable Documentation

◆ cdc_keyboard_desc_handler

usbd_desc_handler cdc_keyboard_desc_handler
extern

device descriptor handler structure

Definition at line 63 of file cdc_keyboard_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_keyboard_desc_private_functions

Functions | Variables
USB_cdc_keyboard_desc_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_vcpkybrd_hid_usb_desc [9]
usb hid descriptor More...
uint8_t | g_usbd_vcpkybrd_hid_report [63]
usb hid keyboard report descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 534 of file cdc_keyboard_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 456 of file cdc_keyboard_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 436 of file cdc_keyboard_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 522 of file cdc_keyboard_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 476 of file cdc_keyboard_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 487 of file cdc_keyboard_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 466 of file cdc_keyboard_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 499 of file cdc_keyboard_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 446 of file cdc_keyboard_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 511 of file cdc_keyboard_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 414 of file cdc_keyboard_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 388 of file cdc_keyboard_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 362 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0xEF,
0x02,
0x01,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5750 ),
HBYTE( 0x5750 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb hid keyboard report descriptor

usb hid descriptor

usb configuration standard descriptor

Definition at line 58 of file cdc_keyboard_desc.c.

◆ cdc_keyboard_desc_handler

usbd_desc_handler cdc_keyboard_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_keyboard_desc.c:456
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_keyboard_desc.c:436
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_keyboard_desc.c:487
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_keyboard_desc.c:446
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_keyboard_desc.c:522
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_keyboard_desc.c:466
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_keyboard_desc.c:499
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_keyboard_desc.c:534
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_keyboard_desc.c:476
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_keyboard_desc.c:511

device descriptor handler structure

Definition at line 63 of file cdc_keyboard_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
108 ,
g_usbd_configuration
}

Definition at line 334 of file cdc_keyboard_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 327 of file cdc_keyboard_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_vcpkybrd_hid_report

ALIGNED_HEAD uint8_t g_usbd_vcpkybrd_hid_report
extern

usb hid keyboard report descriptor

Definition at line 264 of file cdc_keyboard_desc.c.

Referenced by keyboard_class_setup_handler().

◆ g_vcpkybrd_hid_usb_desc

ALIGNED_HEAD uint8_t g_vcpkybrd_hid_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:264

usb hid descriptor

Definition at line 245 of file cdc_keyboard_desc.c.

Referenced by keyboard_class_setup_handler().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 341 of file cdc_keyboard_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 348 of file cdc_keyboard_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 354 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_cdc_keyboard_desc_definition

Macros
USB_cdc_keyboard_desc_definition
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_desc

Macros

#define | VCPKYBRD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_VCPKYBRD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_VCPKYBRD_PRODUCT_ID 0x5750
#define | USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
usb descriptor size define More...
#define | USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
#define | USBD_VCPKYBRD_SIZ_STRING_LANGID 4
#define | USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
#define | USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
#define | USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
#define | USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
#define | VCPKYBRD_HID_BINTERVAL_TIME 0x0A
usb endpoint interval define More...
#define | VCPKYBRD_CDC_INTERFACE 0x00
usb interface define More...
#define | VCPKYBRD_CDC_DATA_INTERFACE 0x01
#define | VCPKYBRD_KEYBOARD_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 91 of file cdc_keyboard_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 92 of file cdc_keyboard_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 93 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_CONFIG_DESC_SIZE

#define USBD_VCPKYBRD_CONFIG_DESC_SIZE 108

usb descriptor size define

Definition at line 63 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_CONFIGURATION_STRING

#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"

Definition at line 73 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_INTERFACE_STRING

#define USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"

Definition at line 74 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_MANUFACTURER_STRING

#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 71 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_PRODUCT_STRING

#define USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"

Definition at line 72 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_HID_SIZ_REPORT_DESC

#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63

Definition at line 64 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_PRODUCT_ID

#define USBD_VCPKYBRD_PRODUCT_ID 0x5750

Definition at line 57 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_SIZ_STRING_LANGID

#define USBD_VCPKYBRD_SIZ_STRING_LANGID 4

Definition at line 65 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_SIZ_STRING_SERIAL

#define USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A

Definition at line 66 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_VENDOR_ID

#define USBD_VCPKYBRD_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 56 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_BCD_NUM

#define VCPKYBRD_BCD_NUM 0x0110

usb bcd number define

Definition at line 51 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_CDC_DATA_INTERFACE

#define VCPKYBRD_CDC_DATA_INTERFACE 0x01

Definition at line 85 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_CDC_INTERFACE

#define VCPKYBRD_CDC_INTERFACE 0x00

usb interface define

Definition at line 84 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_HID_BINTERVAL_TIME

#define VCPKYBRD_HID_BINTERVAL_TIME 0x0A

usb endpoint interval define

Definition at line 79 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_KEYBOARD_INTERFACE

#define VCPKYBRD_KEYBOARD_INTERFACE 0x02

Definition at line 86 of file cdc_keyboard_desc.h.


AT32F413 Firmwary Library: USB_cdc_msc_class

Modules
USB_cdc_msc_class
AT32F413_middlewares_usbd_class

usb device class cdc msc demo More...

Modules

USB_cdc_msc_class_private_functions
USB_cdc_class_definition
USB_cdc_class_exported_types

Detailed Description

usb device class cdc msc demo


AT32F413 Firmwary Library: USB_cdc_msc_class_private_functions

Functions | Variables
USB_cdc_msc_class_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_msc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static usb_sts_type | cdc_struct_init (cdc_msc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | msc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_msc_struct_type cdc_msc_struct
usbd_class_handler cdc_msc_class_handler

Detailed Description

Function Documentation

◆ cdc_class_setup_handler()

static usb_sts_type cdc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 191 of file cdc_msc_class.c.

Referenced by class_setup_handler().

◆ cdc_struct_init()

static usb_sts_type cdc_struct_init ( cdc_msc_struct_type * pcdc )
static

usb device cdc init

Parameters
pcdc to the structure of cdc_struct
Return values
status of usb_sts_type

Definition at line 461 of file cdc_msc_class.c.

Referenced by class_init_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 125 of file cdc_msc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 337 of file cdc_msc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 323 of file cdc_msc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 431 of file cdc_msc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 359 of file cdc_msc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 88 of file cdc_msc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 387 of file cdc_msc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 154 of file cdc_msc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 416 of file cdc_msc_class.c.

◆ msc_class_setup_handler()

static usb_sts_type msc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

< get max lun

< bulk only mass storage reset

Definition at line 252 of file cdc_msc_class.c.

Referenced by class_setup_handler().

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

Definition at line 297 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usb_vcp_cmd_process().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 534 of file cdc_msc_class.c.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 479 of file cdc_msc_class.c.

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 509 of file cdc_msc_class.c.

Variable Documentation

◆ cdc_msc_class_handler

usbd_class_handler cdc_msc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&cdc_msc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_msc_class.c:416
cdc_msc_struct
cdc_msc_struct_type cdc_msc_struct
Definition: cdc_msc_class.c:67
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_msc_class.c:359
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_msc_class.c:125
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:154
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_msc_class.c:323
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_msc_class.c:337
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_msc_class.c:431
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_msc_class.c:88
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_msc_class.c:387

Definition at line 70 of file cdc_msc_class.c.

Referenced by main().

◆ cdc_msc_struct

cdc_msc_struct_type cdc_msc_struct

Definition at line 67 of file cdc_msc_class.c.

Referenced by msc_class_setup_handler().

◆ linecoding

linecoding_type linecoding
Initial value:
=
{
115200,
0,
0,
8
}

Definition at line 58 of file cdc_msc_class.c.

Referenced by cdc_struct_init(), and usb_usart_config().


AT32F413 Firmwary Library: USB_cdc_msc_desc

Modules | Variables
USB_cdc_msc_desc
AT32F413_middlewares_usbd_class

usb device cdc msc descriptor More...

Modules

USB_cdc_msc_desc_private_functions
USB_cdc_desc_definition

Variables

usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc msc descriptor

Variable Documentation

◆ cdc_msc_desc_handler

usbd_desc_handler cdc_msc_desc_handler
extern

device descriptor handler structure

Definition at line 67 of file cdc_msc_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_msc_desc_private_functions

Macros | Functions | Variables
USB_cdc_msc_desc_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_msc_desc

Macros

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Macro Definition Documentation

◆ USB_INTERFACE_ASSOCIATION_TYPE

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Definition at line 43 of file cdc_msc_desc.c.

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 482 of file cdc_msc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 404 of file cdc_msc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 384 of file cdc_msc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 470 of file cdc_msc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 424 of file cdc_msc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 435 of file cdc_msc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 414 of file cdc_msc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 447 of file cdc_msc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 394 of file cdc_msc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 459 of file cdc_msc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 362 of file cdc_msc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 336 of file cdc_msc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 310 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0xEF,
0x02,
0x01,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5760 ),
HBYTE( 0x5760 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 62 of file cdc_msc_desc.c.

◆ cdc_msc_desc_handler

usbd_desc_handler cdc_msc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_msc_desc.c:404
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_msc_desc.c:384
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_msc_desc.c:435
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_msc_desc.c:394
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_msc_desc.c:470
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_msc_desc.c:414
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_msc_desc.c:447
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_msc_desc.c:482
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_msc_desc.c:424
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_msc_desc.c:459

device descriptor handler structure

Definition at line 67 of file cdc_msc_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
106 ,
g_usbd_configuration
}

Definition at line 282 of file cdc_msc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 275 of file cdc_msc_desc.c.

Referenced by get_device_descriptor().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 289 of file cdc_msc_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 296 of file cdc_msc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 302 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_msc_bot_scsi

Modules
USB_msc_bot_scsi
AT32F413_middlewares_usbd_class

usb device class mass storage demo More...

Modules

USB_msc_bot_functions
USB_msc_bot_scsi_definition

Detailed Description

usb device class mass storage demo


AT32F413 Firmwary Library: USB_msc_bot_functions

Functions | Variables
USB_msc_bot_functions
AT32F413_middlewares_usbd_class » USB_msc_bot_scsi

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] | ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] | ALIGNED_TAIL

Detailed Description

Function Documentation

◆ bot_cbw_decode()

void bot_cbw_decode ( void * udev )

bulk-only cbw decode

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 195 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_dataout_handler().

◆ bot_scsi_allow_medium_removal()

usb_sts_type bot_scsi_allow_medium_removal | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command meidum removal

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 422 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_capacity()

usb_sts_type bot_scsi_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 476 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_check_address()

usb_sts_type bot_scsi_check_address | ( | void * | udev,
 |  | uint8_t | lun,
 |  | uint32_t | blk_offset,
 |  | uint32_t | blk_count
 | ) |  |

check address

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type

Definition at line 302 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_clear_feature()

void bot_scsi_clear_feature | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

clear feature

Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type

Definition at line 728 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_setup_handler(), and msc_class_setup_handler().

◆ bot_scsi_cmd_process()

usb_sts_type bot_scsi_cmd_process ( void * udev )

bulk-only transport scsi command process

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type
Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 748 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), and bot_scsi_dataout_handler().

◆ bot_scsi_datain_handler()

void bot_scsi_datain_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data in handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 142 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_in_handler().

◆ bot_scsi_dataout_handler()

void bot_scsi_dataout_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data out handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 171 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_out_handler().

◆ bot_scsi_format_capacity()

usb_sts_type bot_scsi_format_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command format capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 503 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_init()

void bot_scsi_init ( void * udev )

initialize bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 102 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_init_handler().

◆ bot_scsi_inquiry()

usb_sts_type bot_scsi_inquiry | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command inquiry

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 367 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense10()

usb_sts_type bot_scsi_mode_sense10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 456 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense6()

usb_sts_type bot_scsi_mode_sense6 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense6

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 436 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_read10()

usb_sts_type bot_scsi_read10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command read10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 597 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_request_sense()

usb_sts_type bot_scsi_request_sense | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command request sense

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 538 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_reset()

void bot_scsi_reset ( void * udev )

reset bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 124 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_setup_handler(), and msc_class_setup_handler().

◆ bot_scsi_send_csw()

void bot_scsi_send_csw | ( | void * | udev,
 |  | uint8_t | status
 | ) |  |

send command status

Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none
Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none

Definition at line 263 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), and bot_scsi_write10().

◆ bot_scsi_send_data()

void bot_scsi_send_data | ( | void * | udev,
 |  | uint8_t * | buffer,
 |  | uint32_t | len
 | ) |  |

send bot data

Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none
Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none

Definition at line 242 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_sense_code()

void bot_scsi_sense_code | ( | void * | udev,
 |  | uint8_t | sense_key,
 |  | uint8_t | asc
 | ) |  |

send scsi sense code

Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none
Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none

Definition at line 287 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_check_address(), bot_scsi_cmd_process(), bot_scsi_read10(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_stall()

void bot_scsi_stall ( void * udev )

bot endpoint stall

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 319 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_start_stop()

usb_sts_type bot_scsi_start_stop | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command start stop

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 408 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_test_unit()

usb_sts_type bot_scsi_test_unit | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command test unit

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 345 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_verify()

usb_sts_type bot_scsi_verify | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command verify

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 569 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_write10()

usb_sts_type bot_scsi_write10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command write10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 658 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

Variable Documentation

◆ ALIGNED_TAIL [1/2]

ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL
Initial value:
= {
0x00,
0x00,
0x00,
0x00,
0x00,
}

Definition at line 44 of file composite_cdc_msc/msc_bot_scsi.c.

◆ ALIGNED_TAIL [2/2]

ALIGNED_HEAD uint8_t mode_sense10_data [8] ALIGNED_TAIL
Initial value:
= {
0x00,
0x00,
0x00,
0x00,
0x00,
}

Definition at line 44 of file msc/msc_bot_scsi.c.


AT32F413 Firmwary Library: USB_custom_hid_class

Modules
USB_custom_hid_class
AT32F413_middlewares_usbd_class

usb device custom hid demo More...

Modules

USB_custom_hid_class_private_functions
USB_custom_hid_class_endpoint_definition
USB_custom_hid_class_request_code_definition
USB_custom_hid_class_exported_functions

Detailed Description

usb device custom hid demo


AT32F413 Firmwary Library: USB_custom_hid_class_private_functions

Functions | Variables
USB_custom_hid_class_private_functions
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device class report function More...
usb_sts_type | custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

custom_hid_type custom_hid_struct
usbd_class_handler custom_hid_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 102 of file custom_hid_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 218 of file custom_hid_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 204 of file custom_hid_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 296 of file custom_hid_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 241 of file custom_hid_class.c.

◆ class_init_handler()

usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 74 of file custom_hid_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 258 of file custom_hid_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 122 of file custom_hid_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 281 of file custom_hid_class.c.

◆ custom_hid_class_send_report()

usb_sts_type custom_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 328 of file custom_hid_class.c.

Referenced by main().

◆ usb_hid_buf_process()

static void usb_hid_buf_process | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |
static

usb device class report function

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
none

Definition at line 346 of file custom_hid_class.c.

Referenced by class_ept0_rx_handler(), and class_out_handler().

Variable Documentation

◆ custom_hid_class_handler

usbd_class_handler custom_hid_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&custom_hid_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: custom_hid_class.c:281
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: custom_hid_class.c:241
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: custom_hid_class.c:102
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: custom_hid_class.c:122
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: custom_hid_class.c:204
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: custom_hid_class.c:218
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: custom_hid_class.c:296
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: custom_hid_class.c:258
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: custom_hid_class.c:74
custom_hid_struct
custom_hid_type custom_hid_struct
Definition: custom_hid_class.c:52

Definition at line 55 of file custom_hid_class.c.

Referenced by main().

◆ custom_hid_struct

custom_hid_type custom_hid_struct

Definition at line 52 of file custom_hid_class.c.


AT32F413 Firmwary Library: USB_custom_hid_class_endpoint_definition

Macros
USB_custom_hid_class_endpoint_definition
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Macros

#define | USBD_CUSTOM_HID_IN_EPT 0x81
usb custom hid use endpoint define More...
#define | USBD_CUSTOM_HID_OUT_EPT 0x01
#define | USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Detailed Description

Macro Definition Documentation

◆ USBD_CUSTOM_HID_IN_EPT

#define USBD_CUSTOM_HID_IN_EPT 0x81

usb custom hid use endpoint define

Definition at line 51 of file custom_hid_class.h.

◆ USBD_CUSTOM_HID_OUT_EPT

#define USBD_CUSTOM_HID_OUT_EPT 0x01

Definition at line 52 of file custom_hid_class.h.

◆ USBD_CUSTOM_IN_MAXPACKET_SIZE

#define USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40

usb custom hid in and out max packet size define

Definition at line 57 of file custom_hid_class.h.

◆ USBD_CUSTOM_OUT_MAXPACKET_SIZE

#define USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Definition at line 58 of file custom_hid_class.h.


AT32F413 Firmwary Library: USB_custom_hid_class_request_code_definition

Data Structures
USB_custom_hid_class_request_code_definition
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Data Structures

struct custom_hid_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: custom_hid_type Struct Reference

Data Fields
custom_hid_type Struct Reference
AT32F413_middlewares_usbd_class » USB_custom_hid_class » USB_custom_hid_class_request_code_definition

#include <custom_hid_class.h>

Data Fields

uint8_t | g_rxhid_buff [0x40]
uint8_t | g_txhid_buff [0x40]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | hid_get_report [64]
uint8_t | hid_state

Detailed Description

Definition at line 68 of file custom_hid_class.h.

Field Documentation

◆ alt_setting

uint32_t custom_hid_type::alt_setting

Definition at line 75 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ g_rxhid_buff

uint8_t custom_hid_type::g_rxhid_buff[0x40]

Definition at line 70 of file custom_hid_class.h.

Referenced by class_init_handler(), class_out_handler(), and usb_hid_buf_process().

◆ g_txhid_buff

uint8_t custom_hid_type::g_txhid_buff[0x40]

Definition at line 71 of file custom_hid_class.h.

Referenced by usb_hid_buf_process().

◆ hid_get_report

uint8_t custom_hid_type::hid_get_report[64]

Definition at line 78 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ hid_protocol

uint32_t custom_hid_type::hid_protocol

Definition at line 73 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t custom_hid_type::hid_set_idle

Definition at line 74 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t custom_hid_type::hid_set_report[64]

Definition at line 77 of file custom_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_state

uint8_t custom_hid_type::hid_state

Definition at line 79 of file custom_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

The documentation for this struct was generated from the following file:
  • custom_hid_class.h


AT32F413 Firmwary Library: USB_custom_hid_class_exported_functions

Functions | Variables
USB_custom_hid_class_exported_functions
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Functions

usb_sts_type custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler custom_hid_class_handler

Detailed Description

Function Documentation

◆ custom_hid_class_send_report()

usb_sts_type custom_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 328 of file custom_hid_class.c.

Referenced by main().

Variable Documentation

◆ custom_hid_class_handler

usbd_class_handler custom_hid_class_handler
extern

Definition at line 55 of file custom_hid_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_custom_hid_desc

Modules | Variables
USB_custom_hid_desc
AT32F413_middlewares_usbd_class

usb device custom_hid descriptor More...

Modules

USB_custom_hid_desc_private_functions
USB_custom_hid_desc_definition

Variables

usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...

Detailed Description

usb device custom_hid descriptor

Variable Documentation

◆ custom_hid_desc_handler

usbd_desc_handler custom_hid_desc_handler
extern

custom hid device descriptor handler structure

Definition at line 63 of file custom_hid_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_custom_hid_desc_private_functions

Functions | Variables
USB_custom_hid_desc_private_functions
AT32F413_middlewares_usbd_class » USB_custom_hid_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_custom_hid_report [126]
usb hid report descriptor More...
uint8_t | g_custom_hid_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 514 of file custom_hid_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 436 of file custom_hid_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 416 of file custom_hid_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 502 of file custom_hid_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 456 of file custom_hid_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 467 of file custom_hid_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 446 of file custom_hid_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 479 of file custom_hid_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 426 of file custom_hid_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 491 of file custom_hid_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 394 of file custom_hid_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 368 of file custom_hid_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 342 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5745 ),
HBYTE( 0x5745 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 58 of file custom_hid_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
41 ,
g_usbd_configuration
}

Definition at line 314 of file custom_hid_desc.c.

Referenced by get_device_configuration().

◆ custom_hid_desc_handler

usbd_desc_handler custom_hid_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: custom_hid_desc.c:436
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: custom_hid_desc.c:416
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: custom_hid_desc.c:467
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: custom_hid_desc.c:426
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: custom_hid_desc.c:502
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: custom_hid_desc.c:446
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: custom_hid_desc.c:479
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: custom_hid_desc.c:514
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: custom_hid_desc.c:456
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: custom_hid_desc.c:491

custom hid device descriptor handler structure

Definition at line 63 of file custom_hid_desc.c.

Referenced by main().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 307 of file custom_hid_desc.c.

Referenced by get_device_descriptor().

◆ g_custom_hid_usb_desc

ALIGNED_HEAD uint8_t g_custom_hid_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_custom_hid_report)),
HBYTE(sizeof(g_usbd_custom_hid_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:167

usb hid descriptor

Definition at line 265 of file custom_hid_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_custom_hid_report

ALIGNED_HEAD uint8_t g_usbd_custom_hid_report
extern

usb hid report descriptor

Definition at line 167 of file custom_hid_desc.c.

Referenced by class_setup_handler().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 321 of file custom_hid_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 328 of file custom_hid_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 334 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_custom_hid_desc_definition

Macros
USB_custom_hid_desc_definition
AT32F413_middlewares_usbd_class » USB_custom_hid_desc

Macros

#define | CUSHID_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CUSHID_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CUSHID_PRODUCT_ID 0x5745
#define | USBD_CUSHID_CONFIG_DESC_SIZE 41
usb descriptor size define More...
#define | USBD_CUSHID_SIZ_REPORT_DESC 126
#define | USBD_CUSHID_SIZ_STRING_LANGID 4
#define | USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
#define | USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
#define | USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
#define | CUSHID_BINTERVAL_TIME 0x0A
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ CUSHID_BCD_NUM

#define CUSHID_BCD_NUM 0x0110

usb bcd number define

Definition at line 52 of file custom_hid_desc.h.

◆ CUSHID_BINTERVAL_TIME

#define CUSHID_BINTERVAL_TIME 0x0A

Definition at line 76 of file custom_hid_desc.h.

◆ HID_REPORT_ID_1

#define HID_REPORT_ID_1 0x01

usb hid report id define

usb hid report id define

Definition at line 84 of file custom_hid_desc.h.

◆ HID_REPORT_ID_2

#define HID_REPORT_ID_2 0x02

Definition at line 85 of file custom_hid_desc.h.

◆ HID_REPORT_ID_3

#define HID_REPORT_ID_3 0x03

Definition at line 86 of file custom_hid_desc.h.

◆ HID_REPORT_ID_4

#define HID_REPORT_ID_4 0x04

Definition at line 87 of file custom_hid_desc.h.

◆ HID_REPORT_ID_5

#define HID_REPORT_ID_5 0x05

Definition at line 88 of file custom_hid_desc.h.

◆ HID_REPORT_ID_6

#define HID_REPORT_ID_6 0xF0

Definition at line 89 of file custom_hid_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 94 of file custom_hid_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 95 of file custom_hid_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 96 of file custom_hid_desc.h.

◆ USBD_CUSHID_CONFIG_DESC_SIZE

#define USBD_CUSHID_CONFIG_DESC_SIZE 41

usb descriptor size define

Definition at line 63 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_CONFIGURATION_STRING

#define USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"

Definition at line 73 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_INTERFACE_STRING

#define USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"

Definition at line 74 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_MANUFACTURER_STRING

#define USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 71 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_PRODUCT_STRING

#define USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"

Definition at line 72 of file custom_hid_desc.h.

◆ USBD_CUSHID_PRODUCT_ID

#define USBD_CUSHID_PRODUCT_ID 0x5745

Definition at line 58 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_REPORT_DESC

#define USBD_CUSHID_SIZ_REPORT_DESC 126

Definition at line 64 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_STRING_LANGID

#define USBD_CUSHID_SIZ_STRING_LANGID 4

Definition at line 65 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_STRING_SERIAL

#define USBD_CUSHID_SIZ_STRING_SERIAL 0x1A

Definition at line 66 of file custom_hid_desc.h.

◆ USBD_CUSHID_VENDOR_ID

#define USBD_CUSHID_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 57 of file custom_hid_desc.h.


AT32F413 Firmwary Library: USB_hid_iap_class

Modules
USB_hid_iap_class
AT32F413_middlewares_usbd_class

usb device class hid iap demo More...

Modules

USB_hid_iap_class_private_functions
USB_hid_iap_class_definition

Detailed Description

usb device class hid iap demo


AT32F413 Firmwary Library: USB_hid_iap_class_private_functions

Functions | Variables
USB_hid_iap_class_private_functions
AT32F413_middlewares_usbd_class » USB_hid_iap_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

iap_info_type iap_info
usbd_class_handler hid_iap_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 96 of file hid_iap_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 209 of file hid_iap_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 195 of file hid_iap_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 287 of file hid_iap_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 231 of file hid_iap_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 74 of file hid_iap_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 249 of file hid_iap_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 116 of file hid_iap_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 272 of file hid_iap_class.c.

◆ usb_iap_class_send_report()

usb_sts_type usb_iap_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 319 of file hid_iap_class.c.

Referenced by usbd_hid_iap_process().

Variable Documentation

◆ hid_iap_class_handler

usbd_class_handler hid_iap_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&iap_info
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: hid_iap_class.c:272
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:52
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: hid_iap_class.c:231
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: hid_iap_class.c:96
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: hid_iap_class.c:116
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: hid_iap_class.c:195
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: hid_iap_class.c:209
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: hid_iap_class.c:287
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: hid_iap_class.c:74
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: hid_iap_class.c:249

Definition at line 55 of file hid_iap_class.c.

Referenced by main().

◆ iap_info

iap_info_type iap_info

Definition at line 52 of file hid_iap_class.c.

Referenced by app_loop(), iap_address(), iap_clear_upgrade_flag(), iap_crc(), iap_data_write(), iap_erase_sector(), iap_finish(), iap_get(), iap_get_upgrade_flag(), iap_idle(), iap_init(), iap_jump(), iap_loop(), iap_respond(), iap_set_upgrade_flag(), iap_start(), usbd_hid_iap_in_complete(), and usbd_hid_iap_process().


AT32F413 Firmwary Library: USB_hid_iap_class_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_hid_iap_class_definition
AT32F413_middlewares_usbd_class » USB_hid_iap_class

Data Structures

struct iap_info_type

Macros

#define | USBD_HIDIAP_IN_EPT 0x81
#define | USBD_HIDIAP_OUT_EPT 0x01
#define | USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
#define | USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
#define | FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
#define | KB_TO_B(kb) ((kb) << 10)
#define | SECTOR_SIZE_1K 0x400
#define | SECTOR_SIZE_2K 0x800
#define | SECTOR_SIZE_4K 0x1000
#define | IAP_CMD_IDLE 0x5AA0
iap command More...
#define | IAP_CMD_START 0x5AA1
#define | IAP_CMD_ADDR 0x5AA2
#define | IAP_CMD_DATA 0x5AA3
#define | IAP_CMD_FINISH 0x5AA4
#define | IAP_CMD_CRC 0x5AA5
#define | IAP_CMD_JMP 0x5AA6
#define | IAP_CMD_GET 0x5AA7
#define | HID_IAP_BUFFER_LEN 1024
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | CONVERT_ENDIAN(dwValue)
#define | IAP_ACK 0xFF00
#define | IAP_NACK 0x00FF

Enumerations

enum iap_result_type { IAP_SUCCESS , IAP_WAIT , IAP_FAILED }
enum iap_machine_state_type {
IAP_STS_IDLE , IAP_STS_START , IAP_STS_ADDR , IAP_STS_DATA ,
IAP_STS_FINISH , IAP_STS_CRC , IAP_STS_JMP_WAIT , IAP_STS_JMP
}

Functions

usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *report, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...

Variables

usbd_class_handler hid_iap_class_handler
iap_info_type iap_info

Detailed Description

Macro Definition Documentation

◆ CONVERT_ENDIAN

#define CONVERT_ENDIAN ( dwValue )
Value:
((dwValue >> 24) | ((dwValue >> 8) & 0xFF00) | \
((dwValue << 8) & 0xFF0000) | (dwValue << 24) )

Definition at line 77 of file hid_iap_class.h.

◆ FLASH_SIZE_REG

#define FLASH_SIZE_REG ( ) ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/

Definition at line 56 of file hid_iap_class.h.

◆ HID_IAP_BUFFER_LEN

#define HID_IAP_BUFFER_LEN 1024

Definition at line 75 of file hid_iap_class.h.

◆ IAP_ACK

#define IAP_ACK 0xFF00

Definition at line 80 of file hid_iap_class.h.

◆ IAP_CMD_ADDR

#define IAP_CMD_ADDR 0x5AA2

Definition at line 68 of file hid_iap_class.h.

◆ IAP_CMD_CRC

#define IAP_CMD_CRC 0x5AA5

Definition at line 71 of file hid_iap_class.h.

◆ IAP_CMD_DATA

#define IAP_CMD_DATA 0x5AA3

Definition at line 69 of file hid_iap_class.h.

◆ IAP_CMD_FINISH

#define IAP_CMD_FINISH 0x5AA4

Definition at line 70 of file hid_iap_class.h.

◆ IAP_CMD_GET

#define IAP_CMD_GET 0x5AA7

Definition at line 73 of file hid_iap_class.h.

◆ IAP_CMD_IDLE

#define IAP_CMD_IDLE 0x5AA0

iap command

Definition at line 66 of file hid_iap_class.h.

◆ IAP_CMD_JMP

#define IAP_CMD_JMP 0x5AA6

Definition at line 72 of file hid_iap_class.h.

◆ IAP_CMD_START

#define IAP_CMD_START 0x5AA1

Definition at line 67 of file hid_iap_class.h.

◆ IAP_NACK

#define IAP_NACK 0x00FF

Definition at line 81 of file hid_iap_class.h.

◆ IAP_UPGRADE_COMPLETE_FLAG

#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38

Definition at line 76 of file hid_iap_class.h.

◆ KB_TO_B

#define KB_TO_B ( kb ) ((kb) << 10)

Definition at line 57 of file hid_iap_class.h.

◆ SECTOR_SIZE_1K

#define SECTOR_SIZE_1K 0x400

Definition at line 59 of file hid_iap_class.h.

◆ SECTOR_SIZE_2K

#define SECTOR_SIZE_2K 0x800

Definition at line 60 of file hid_iap_class.h.

◆ SECTOR_SIZE_4K

#define SECTOR_SIZE_4K 0x1000

Definition at line 61 of file hid_iap_class.h.

◆ USBD_HIDIAP_IN_EPT

#define USBD_HIDIAP_IN_EPT 0x81

Definition at line 50 of file hid_iap_class.h.

◆ USBD_HIDIAP_IN_MAXPACKET_SIZE

#define USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40

Definition at line 53 of file hid_iap_class.h.

◆ USBD_HIDIAP_OUT_EPT

#define USBD_HIDIAP_OUT_EPT 0x01

Definition at line 51 of file hid_iap_class.h.

◆ USBD_HIDIAP_OUT_MAXPACKET_SIZE

#define USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40

Definition at line 54 of file hid_iap_class.h.

Enumeration Type Documentation

◆ iap_machine_state_type

enum iap_machine_state_type
Enumerator
IAP_STS_IDLE
IAP_STS_START
IAP_STS_ADDR
IAP_STS_DATA
IAP_STS_FINISH
IAP_STS_CRC
IAP_STS_JMP_WAIT
IAP_STS_JMP

Definition at line 90 of file hid_iap_class.h.

◆ iap_result_type

enum iap_result_type
Enumerator
IAP_SUCCESS
IAP_WAIT
IAP_FAILED

Definition at line 83 of file hid_iap_class.h.

Function Documentation

◆ usb_iap_class_send_report()

usb_sts_type usb_iap_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 319 of file hid_iap_class.c.

Referenced by usbd_hid_iap_process().

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 238 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by class_in_handler().

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 192 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by class_out_handler().

Variable Documentation

◆ hid_iap_class_handler

usbd_class_handler hid_iap_class_handler
extern

Definition at line 55 of file hid_iap_class.c.

Referenced by main().

◆ iap_info

iap_info_type iap_info
extern

Definition at line 52 of file hid_iap_class.c.

Referenced by app_loop(), iap_address(), iap_clear_upgrade_flag(), iap_crc(), iap_data_write(), iap_erase_sector(), iap_finish(), iap_get(), iap_get_upgrade_flag(), iap_idle(), iap_init(), iap_jump(), iap_loop(), iap_respond(), iap_set_upgrade_flag(), iap_start(), usbd_hid_iap_in_complete(), and usbd_hid_iap_process().


AT32F413 Firmwary Library: iap_info_type Struct Reference

Data Fields
iap_info_type Struct Reference
AT32F413_middlewares_usbd_class » USB_hid_iap_class » USB_hid_iap_class_definition

#include <hid_iap_class.h>

Data Fields

uint8_t | iap_fifo [1024]
uint8_t | iap_rx [0x40]
uint8_t | iap_tx [0x40]
uint32_t | fifo_length
uint32_t | tx_length
uint32_t | app_address
uint32_t | iap_address
uint32_t | flag_address
uint32_t | flash_start_address
uint32_t | flash_end_address
uint32_t | sector_size
uint32_t | flash_size
uint32_t | respond_flag
uint8_t | g_rxhid_buff [0x40]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint32_t | hid_state
uint8_t | hid_set_report [64]
iap_machine_state_type state

Detailed Description

Definition at line 102 of file hid_iap_class.h.

Field Documentation

◆ alt_setting

uint32_t iap_info_type::alt_setting

Definition at line 127 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ app_address

uint32_t iap_info_type::app_address

Definition at line 112 of file hid_iap_class.h.

Referenced by iap_get(), iap_init(), and iap_loop().

◆ fifo_length

uint32_t iap_info_type::fifo_length

Definition at line 109 of file hid_iap_class.h.

Referenced by iap_data_write(), and iap_init().

◆ flag_address

uint32_t iap_info_type::flag_address

Definition at line 114 of file hid_iap_class.h.

Referenced by iap_clear_upgrade_flag(), iap_get_upgrade_flag(), iap_init(), and iap_set_upgrade_flag().

◆ flash_end_address

uint32_t iap_info_type::flash_end_address

Definition at line 117 of file hid_iap_class.h.

Referenced by iap_address(), and iap_init().

◆ flash_size

uint32_t iap_info_type::flash_size

Definition at line 120 of file hid_iap_class.h.

Referenced by iap_init().

◆ flash_start_address

uint32_t iap_info_type::flash_start_address

Definition at line 116 of file hid_iap_class.h.

Referenced by iap_init().

◆ g_rxhid_buff

uint8_t iap_info_type::g_rxhid_buff[0x40]

Definition at line 124 of file hid_iap_class.h.

Referenced by class_init_handler(), and class_out_handler().

◆ hid_protocol

uint32_t iap_info_type::hid_protocol

Definition at line 125 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t iap_info_type::hid_set_idle

Definition at line 126 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t iap_info_type::hid_set_report[64]

Definition at line 129 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint32_t iap_info_type::hid_state

Definition at line 128 of file hid_iap_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ iap_address

uint32_t iap_info_type::iap_address

Definition at line 113 of file hid_iap_class.h.

Referenced by iap_address(), iap_data_write(), and iap_init().

◆ iap_fifo

uint8_t iap_info_type::iap_fifo[1024]

Definition at line 105 of file hid_iap_class.h.

Referenced by iap_data_write().

◆ iap_rx

uint8_t iap_info_type::iap_rx[0x40]

Definition at line 106 of file hid_iap_class.h.

◆ iap_tx

uint8_t iap_info_type::iap_tx[0x40]

Definition at line 107 of file hid_iap_class.h.

Referenced by iap_address(), iap_crc(), iap_data_write(), iap_finish(), iap_get(), iap_idle(), iap_jump(), iap_start(), and usbd_hid_iap_process().

◆ respond_flag

uint32_t iap_info_type::respond_flag

Definition at line 122 of file hid_iap_class.h.

Referenced by iap_respond(), and usbd_hid_iap_process().

◆ sector_size

uint32_t iap_info_type::sector_size

Definition at line 119 of file hid_iap_class.h.

Referenced by iap_erase_sector(), and iap_init().

◆ state

iap_machine_state_type iap_info_type::state

Definition at line 131 of file hid_iap_class.h.

Referenced by app_loop(), iap_address(), iap_data_write(), iap_finish(), iap_idle(), iap_jump(), iap_loop(), iap_start(), and usbd_hid_iap_in_complete().

◆ tx_length

uint32_t iap_info_type::tx_length

Definition at line 110 of file hid_iap_class.h.

The documentation for this struct was generated from the following file:
  • hid_iap_class.h


AT32F413 Firmwary Library: USB_hid_iap_desc

Modules
USB_hid_iap_desc
AT32F413_middlewares_usbd_class

usb device hid_iap descriptor More...

Modules

USB_hid_iap_desc_private_functions
USB_hid_iap_desc_definition

Detailed Description

usb device hid_iap descriptor


AT32F413 Firmwary Library: USB_hid_iap_desc_private_functions

Functions | Variables
USB_hid_iap_desc_private_functions
AT32F413_middlewares_usbd_class » USB_hid_iap_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 450 of file hid_iap_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 372 of file hid_iap_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 352 of file hid_iap_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 438 of file hid_iap_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 392 of file hid_iap_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 403 of file hid_iap_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 382 of file hid_iap_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 415 of file hid_iap_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 362 of file hid_iap_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 427 of file hid_iap_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 330 of file hid_iap_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 304 of file hid_iap_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 278 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0xAF01 ),
HBYTE( 0xAF01 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 61 of file hid_iap_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
41 ,
g_usbd_configuration
}

Definition at line 250 of file hid_iap_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 243 of file hid_iap_desc.c.

Referenced by get_device_descriptor().

◆ hid_iap_desc_handler

usbd_desc_handler hid_iap_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: hid_iap_desc.c:372
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: hid_iap_desc.c:352
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: hid_iap_desc.c:403
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: hid_iap_desc.c:362
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: hid_iap_desc.c:438
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: hid_iap_desc.c:382
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: hid_iap_desc.c:415
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: hid_iap_desc.c:450
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: hid_iap_desc.c:392
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: hid_iap_desc.c:427

hid device descriptor handler structure

Definition at line 66 of file hid_iap_desc.c.

Referenced by main().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 257 of file hid_iap_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 264 of file hid_iap_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 270 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_hid_iap_desc_definition

Macros | Variables
USB_hid_iap_desc_definition
AT32F413_middlewares_usbd_class » USB_hid_iap_desc

Macros

#define | HIDIAP_BCD_NUM 0x0110
#define | USBD_HIDIAP_VENDOR_ID 0x2E3C
#define | USBD_HIDIAP_PRODUCT_ID 0xAF01
#define | USBD_HIDIAP_CONFIG_DESC_SIZE 41
#define | USBD_HIDIAP_SIZ_REPORT_DESC 32
#define | USBD_HIDIAP_SIZ_STRING_LANGID 4
#define | USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
#define | USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
#define | USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
#define | USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
#define | HIDIAP_BINTERVAL_TIME 0x01
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_hidiap_report [32]
usb hid report descriptor More...
uint8_t | g_hidiap_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ HIDIAP_BCD_NUM

#define HIDIAP_BCD_NUM 0x0110

Definition at line 49 of file hid_iap_desc.h.

◆ HIDIAP_BINTERVAL_TIME

#define HIDIAP_BINTERVAL_TIME 0x01

Definition at line 64 of file hid_iap_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 66 of file hid_iap_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 67 of file hid_iap_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 68 of file hid_iap_desc.h.

◆ USBD_HIDIAP_CONFIG_DESC_SIZE

#define USBD_HIDIAP_CONFIG_DESC_SIZE 41

Definition at line 54 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_CONFIGURATION_STRING

#define USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"

Definition at line 61 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_INTERFACE_STRING

#define USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"

Definition at line 62 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_MANUFACTURER_STRING

#define USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_PRODUCT_STRING

#define USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"

Definition at line 60 of file hid_iap_desc.h.

◆ USBD_HIDIAP_PRODUCT_ID

#define USBD_HIDIAP_PRODUCT_ID 0xAF01

Definition at line 52 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_REPORT_DESC

#define USBD_HIDIAP_SIZ_REPORT_DESC 32

Definition at line 55 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_STRING_LANGID

#define USBD_HIDIAP_SIZ_STRING_LANGID 4

Definition at line 56 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_STRING_SERIAL

#define USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file hid_iap_desc.h.

◆ USBD_HIDIAP_VENDOR_ID

#define USBD_HIDIAP_VENDOR_ID 0x2E3C

Definition at line 51 of file hid_iap_desc.h.

Variable Documentation

◆ g_hidiap_usb_desc

ALIGNED_HEAD uint8_t g_hidiap_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_hidiap_report)),
HBYTE(sizeof(g_usbd_hidiap_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:170
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263

usb hid descriptor

Definition at line 201 of file hid_iap_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_hidiap_report

ALIGNED_HEAD uint8_t g_usbd_hidiap_report
extern
Initial value:
=
{
0x06, 0xFF, 0x00,
0x09, 0x01,
0xa1, 0x01,
0x15, 0x00,
0x25, 0xFF,
0x75, 0x08,
0x95, 0x40,
0x09, 0x01,
0x81, 0x02,
0x95, 0x40,
0x09, 0x01,
0x91, 0x02,
0x95, 0x01,
0x09, 0x01,
0xB1, 0x02,
0xC0
}

usb hid report descriptor

Definition at line 170 of file hid_iap_desc.c.

Referenced by class_setup_handler().

◆ hid_iap_desc_handler

usbd_desc_handler hid_iap_desc_handler
extern

hid device descriptor handler structure

Definition at line 66 of file hid_iap_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_keyboard_class

Modules | Data Structures
USB_keyboard_class
AT32F413_middlewares_usbd_class

usb device keyboard demo More...

Modules

USB_keyboard_class_private_functions
USB_keyboard_class_endpoint_definition
USB_hid_class_exported_functions

Data Structures

struct keyboard_type

Detailed Description

usb device keyboard demo


AT32F413 Firmwary Library: USB_keyboard_class_private_functions

Macros | Functions | Variables
USB_keyboard_class_private_functions
AT32F413_middlewares_usbd_class » USB_keyboard_class

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

keyboard_type keyboard_struct
static const unsigned char _asciimap [128]
usbd_class_handler keyboard_class_handler

Detailed Description

Macro Definition Documentation

◆ SHIFT

#define SHIFT 0x80

Definition at line 52 of file keyboard_class.c.

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 229 of file keyboard_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 339 of file keyboard_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 325 of file keyboard_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 408 of file keyboard_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 361 of file keyboard_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 206 of file keyboard_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 381 of file keyboard_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 246 of file keyboard_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 393 of file keyboard_class.c.

◆ usb_hid_keyboard_send_char()

void usb_hid_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 460 of file keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_keyboard_class_send_report()

usb_sts_type usb_keyboard_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 442 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

Variable Documentation

◆ _asciimap

const unsigned char _asciimap[128]
static

Definition at line 53 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

◆ keyboard_class_handler

usbd_class_handler keyboard_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&keyboard_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: keyboard_class.c:393
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: keyboard_class.c:361
keyboard_struct
keyboard_type keyboard_struct
Definition: keyboard_class.c:51
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: keyboard_class.c:229
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: keyboard_class.c:246
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: keyboard_class.c:325
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: keyboard_class.c:339
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: keyboard_class.c:408
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: keyboard_class.c:206
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: keyboard_class.c:381

Definition at line 187 of file keyboard_class.c.

Referenced by main().

◆ keyboard_struct

keyboard_type keyboard_struct

Definition at line 51 of file keyboard_class.c.


AT32F413 Firmwary Library: USB_keyboard_class_endpoint_definition

Macros
USB_keyboard_class_endpoint_definition
AT32F413_middlewares_usbd_class » USB_keyboard_class

Macros

#define | USBD_KEYBOARD_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Detailed Description

Macro Definition Documentation

◆ USBD_KEYBOARD_IN_EPT

#define USBD_KEYBOARD_IN_EPT 0x81

usb hid use endpoint define

Definition at line 51 of file keyboard_class.h.

◆ USBD_KEYBOARD_IN_MAXPACKET_SIZE

#define USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40

usb hid in and out max packet size define

Definition at line 56 of file keyboard_class.h.

◆ USBD_KEYBOARD_OUT_MAXPACKET_SIZE

#define USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Definition at line 57 of file keyboard_class.h.


AT32F413 Firmwary Library: USB_hid_class_exported_functions

Functions | Variables
USB_hid_class_exported_functions
AT32F413_middlewares_usbd_class » USB_keyboard_class | AT32F413_middlewares_usbd_class » USB_mouse_class

Functions

usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

usbd_class_handler keyboard_class_handler
usbd_class_handler mouse_class_handler

Detailed Description

Function Documentation

◆ usb_hid_keyboard_send_char()

void usb_hid_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 460 of file keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_hid_mouse_send()

void usb_hid_mouse_send | ( | void * | udev,
 |  | uint8_t | op
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 321 of file mouse_class.c.

Referenced by main().

◆ usb_keyboard_class_send_report()

usb_sts_type usb_keyboard_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 442 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

◆ usb_mouse_class_send_report()

usb_sts_type usb_mouse_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 304 of file mouse_class.c.

Referenced by usb_hid_mouse_send().

Variable Documentation

◆ keyboard_class_handler

usbd_class_handler keyboard_class_handler
extern

Definition at line 187 of file keyboard_class.c.

Referenced by main().

◆ mouse_class_handler

usbd_class_handler mouse_class_handler
extern

Definition at line 54 of file mouse_class.c.

Referenced by main().


AT32F413 Firmwary Library: keyboard_type Struct Reference

Data Fields
keyboard_type Struct Reference
AT32F413_middlewares_usbd_class » USB_keyboard_class

#include <keyboard_class.h>

Data Fields

uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | keyboard_buf [8]
__IO uint8_t | hid_suspend_flag
__IO uint8_t | g_u8tx_completed
uint8_t | hid_state
uint8_t | temp

Detailed Description

Definition at line 64 of file keyboard_class.h.

Field Documentation

◆ alt_setting

uint32_t keyboard_type::alt_setting

Definition at line 68 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ g_u8tx_completed

__IO uint8_t keyboard_type::g_u8tx_completed

Definition at line 73 of file keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and keyboard_send_string().

◆ hid_protocol

uint32_t keyboard_type::hid_protocol

Definition at line 66 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t keyboard_type::hid_set_idle

Definition at line 67 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t keyboard_type::hid_set_report[64]

Definition at line 69 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint8_t keyboard_type::hid_state

Definition at line 74 of file keyboard_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_suspend_flag

__IO uint8_t keyboard_type::hid_suspend_flag

Definition at line 72 of file keyboard_class.h.

Referenced by class_event_handler().

◆ keyboard_buf

uint8_t keyboard_type::keyboard_buf[8]

Definition at line 70 of file keyboard_class.h.

Referenced by usb_hid_keyboard_send_char().

◆ temp

uint8_t keyboard_type::temp

Definition at line 75 of file keyboard_class.h.

Referenced by usb_hid_keyboard_send_char().

The documentation for this struct was generated from the following file:
  • keyboard_class.h


AT32F413 Firmwary Library: USB_keyboard_desc

Modules | Variables
USB_keyboard_desc
AT32F413_middlewares_usbd_class

usb device keyboard descriptor More...

Modules

USB_keyboard_desc_private_functions
USB_keyboard_desc_definition

Variables

usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...

Detailed Description

usb device keyboard descriptor

Variable Documentation

◆ keyboard_desc_handler

usbd_desc_handler keyboard_desc_handler
extern

keyboard device descriptor handler structure

Definition at line 64 of file keyboard_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_keyboard_desc_private_functions

Functions | Variables
USB_keyboard_desc_private_functions
AT32F413_middlewares_usbd_class » USB_keyboard_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_keyboard_report [63]
usb mouse report descriptor More...
uint8_t | g_keyboard_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 451 of file keyboard_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 373 of file keyboard_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 353 of file keyboard_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 439 of file keyboard_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 393 of file keyboard_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 404 of file keyboard_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 383 of file keyboard_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 416 of file keyboard_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 363 of file keyboard_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 428 of file keyboard_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 331 of file keyboard_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 305 of file keyboard_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 279 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x6040 ),
HBYTE( 0x6040 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb mouse report descriptor

usb configuration standard descriptor

Definition at line 59 of file keyboard_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
34 ,
g_usbd_configuration
}

Definition at line 251 of file keyboard_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 244 of file keyboard_desc.c.

Referenced by get_device_descriptor().

◆ g_keyboard_usb_desc

ALIGNED_HEAD uint8_t g_keyboard_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_keyboard_report)),
HBYTE(sizeof(g_usbd_keyboard_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:160

usb hid descriptor

Definition at line 202 of file keyboard_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_keyboard_report

ALIGNED_HEAD uint8_t g_usbd_keyboard_report
extern

usb mouse report descriptor

Definition at line 160 of file keyboard_desc.c.

Referenced by class_setup_handler().

◆ keyboard_desc_handler

usbd_desc_handler keyboard_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: keyboard_desc.c:373
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: keyboard_desc.c:353
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: keyboard_desc.c:404
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: keyboard_desc.c:363
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: keyboard_desc.c:439
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: keyboard_desc.c:383
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: keyboard_desc.c:416
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: keyboard_desc.c:451
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: keyboard_desc.c:393
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: keyboard_desc.c:428

keyboard device descriptor handler structure

Definition at line 64 of file keyboard_desc.c.

Referenced by main().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 258 of file keyboard_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 265 of file keyboard_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 271 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_keyboard_desc_definition

Macros
USB_keyboard_desc_definition
AT32F413_middlewares_usbd_class » USB_keyboard_desc

Macros

#define | KEYBOARD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_KEYBOARD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_KEYBOARD_PRODUCT_ID 0x6040
#define | USBD_KEYBOARD_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_KEYBOARD_SIZ_REPORT_DESC 63
#define | USBD_KEYBOARD_SIZ_STRING_LANGID 4
#define | USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
#define | USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
#define | USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
#define | USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
#define | KEYBOARD_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ KEYBOARD_BCD_NUM

#define KEYBOARD_BCD_NUM 0x0110

usb bcd number define

Definition at line 51 of file keyboard_desc.h.

◆ KEYBOARD_BINTERVAL_TIME

#define KEYBOARD_BINTERVAL_TIME 0x0A

usb hid endpoint interval define

Definition at line 78 of file keyboard_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 83 of file keyboard_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 84 of file keyboard_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 85 of file keyboard_desc.h.

◆ USBD_KEYBOARD_CONFIG_DESC_SIZE

#define USBD_KEYBOARD_CONFIG_DESC_SIZE 34

usb descriptor size define

Definition at line 62 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_CONFIGURATION_STRING

#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"

Definition at line 72 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_INTERFACE_STRING

#define USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"

Definition at line 73 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_MANUFACTURER_STRING

#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 70 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_PRODUCT_STRING

#define USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"

Definition at line 71 of file keyboard_desc.h.

◆ USBD_KEYBOARD_PRODUCT_ID

#define USBD_KEYBOARD_PRODUCT_ID 0x6040

Definition at line 57 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_REPORT_DESC

#define USBD_KEYBOARD_SIZ_REPORT_DESC 63

Definition at line 63 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_STRING_LANGID

#define USBD_KEYBOARD_SIZ_STRING_LANGID 4

Definition at line 64 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_STRING_SERIAL

#define USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A

Definition at line 65 of file keyboard_desc.h.

◆ USBD_KEYBOARD_VENDOR_ID

#define USBD_KEYBOARD_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 56 of file keyboard_desc.h.


AT32F413 Firmwary Library: USB_mouse_class

Modules
USB_mouse_class
AT32F413_middlewares_usbd_class

usb device mouse demo More...

Modules

USB_mouse_class_private_functions
USB_mouse_class_endpoint_definition
USB_mouse_class_request_code_definition
USB_hid_class_exported_functions

Detailed Description

usb device mouse demo


AT32F413 Firmwary Library: USB_mouse_class_private_functions

Functions | Variables
USB_mouse_class_private_functions
AT32F413_middlewares_usbd_class » USB_mouse_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

mouse_type mouse_struct
usbd_class_handler mouse_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 94 of file mouse_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 204 of file mouse_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 190 of file mouse_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 270 of file mouse_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 226 of file mouse_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 73 of file mouse_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 243 of file mouse_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 111 of file mouse_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 255 of file mouse_class.c.

◆ usb_hid_mouse_send()

void usb_hid_mouse_send | ( | void * | udev,
 |  | uint8_t | op
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 321 of file mouse_class.c.

Referenced by main().

◆ usb_mouse_class_send_report()

usb_sts_type usb_mouse_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 304 of file mouse_class.c.

Referenced by usb_hid_mouse_send().

Variable Documentation

◆ mouse_class_handler

usbd_class_handler mouse_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&mouse_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: mouse_class.c:255
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: mouse_class.c:226
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: mouse_class.c:94
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: mouse_class.c:111
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: mouse_class.c:190
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: mouse_class.c:204
mouse_struct
mouse_type mouse_struct
Definition: mouse_class.c:51
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: mouse_class.c:270
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: mouse_class.c:73
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: mouse_class.c:243

Definition at line 54 of file mouse_class.c.

Referenced by main().

◆ mouse_struct

mouse_type mouse_struct

Definition at line 51 of file mouse_class.c.


AT32F413 Firmwary Library: USB_mouse_class_endpoint_definition

Macros
USB_mouse_class_endpoint_definition
AT32F413_middlewares_usbd_class » USB_mouse_class

Macros

#define | USBD_MOUSE_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...

Detailed Description

Macro Definition Documentation

◆ USBD_MOUSE_IN_EPT

#define USBD_MOUSE_IN_EPT 0x81

usb hid use endpoint define

Definition at line 51 of file mouse_class.h.

◆ USBD_MOUSE_IN_MAXPACKET_SIZE

#define USBD_MOUSE_IN_MAXPACKET_SIZE 0x40

usb hid in and out max packet size define

Definition at line 56 of file mouse_class.h.


AT32F413 Firmwary Library: USB_mouse_class_request_code_definition

Data Structures | Macros
USB_mouse_class_request_code_definition
AT32F413_middlewares_usbd_class » USB_mouse_class

Data Structures

struct mouse_type

Macros

#define | MOVE_STEP 20
usb hid mouse operation More...
#define | BUTTON_RELEASE 0
#define | LEFT_BUTTON 1
#define | RIGHT_BUTTON 2
#define | LEFT_MOVE 3
#define | RIGHT_MOVE 4
#define | UP_MOVE 5
#define | DOWN_MOVE 6

Detailed Description

Macro Definition Documentation

◆ BUTTON_RELEASE

#define BUTTON_RELEASE 0

Definition at line 72 of file mouse_class.h.

◆ DOWN_MOVE

#define DOWN_MOVE 6

Definition at line 78 of file mouse_class.h.

◆ LEFT_BUTTON

#define LEFT_BUTTON 1

Definition at line 73 of file mouse_class.h.

◆ LEFT_MOVE

#define LEFT_MOVE 3

Definition at line 75 of file mouse_class.h.

◆ MOVE_STEP

#define MOVE_STEP 20

usb hid mouse operation

Definition at line 70 of file mouse_class.h.

◆ RIGHT_BUTTON

#define RIGHT_BUTTON 2

Definition at line 74 of file mouse_class.h.

◆ RIGHT_MOVE

#define RIGHT_MOVE 4

Definition at line 76 of file mouse_class.h.

◆ UP_MOVE

#define UP_MOVE 5

Definition at line 77 of file mouse_class.h.


AT32F413 Firmwary Library: mouse_type Struct Reference

Data Fields
mouse_type Struct Reference
AT32F413_middlewares_usbd_class » USB_mouse_class » USB_mouse_class_request_code_definition

#include <mouse_class.h>

Data Fields

uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | mouse_buffer [4]
uint8_t | hid_state
__IO uint8_t | hid_suspend_flag

Detailed Description

Definition at line 80 of file mouse_class.h.

Field Documentation

◆ alt_setting

uint32_t mouse_type::alt_setting

Definition at line 84 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_protocol

uint32_t mouse_type::hid_protocol

Definition at line 82 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t mouse_type::hid_set_idle

Definition at line 83 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t mouse_type::hid_set_report[64]

Definition at line 86 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint8_t mouse_type::hid_state

Definition at line 88 of file mouse_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_suspend_flag

__IO uint8_t mouse_type::hid_suspend_flag

Definition at line 89 of file mouse_class.h.

Referenced by class_event_handler().

◆ mouse_buffer

uint8_t mouse_type::mouse_buffer[4]

Definition at line 87 of file mouse_class.h.

Referenced by usb_hid_mouse_send().

The documentation for this struct was generated from the following file:
  • mouse_class.h


AT32F413 Firmwary Library: USB_mouse_desc

Modules | Variables
USB_mouse_desc
AT32F413_middlewares_usbd_class

usb device mouse descriptor More...

Modules

USB_mouse_desc_private_functions
USB_mouse_desc_definition

Variables

usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...

Detailed Description

usb device mouse descriptor

Variable Documentation

◆ mouse_desc_handler

usbd_desc_handler mouse_desc_handler
extern

mouse device descriptor handler structure

Definition at line 64 of file mouse_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_mouse_desc_private_functions

Functions | Variables
USB_mouse_desc_private_functions
AT32F413_middlewares_usbd_class » USB_mouse_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_mouse_report [74]
usb mouse report descriptor More...
uint8_t | g_mouse_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 465 of file mouse_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 387 of file mouse_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 367 of file mouse_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 453 of file mouse_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 407 of file mouse_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 418 of file mouse_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 397 of file mouse_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 430 of file mouse_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 377 of file mouse_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 442 of file mouse_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 345 of file mouse_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 319 of file mouse_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 293 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5710 ),
HBYTE( 0x5710 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb mouse report descriptor

usb configuration standard descriptor

Definition at line 59 of file mouse_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
34 ,
g_usbd_configuration
}

Definition at line 265 of file mouse_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 258 of file mouse_desc.c.

Referenced by get_device_descriptor().

◆ g_mouse_usb_desc

ALIGNED_HEAD uint8_t g_mouse_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_mouse_report)),
HBYTE(sizeof(g_usbd_mouse_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:160

usb hid descriptor

Definition at line 216 of file mouse_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_mouse_report

ALIGNED_HEAD uint8_t g_usbd_mouse_report
extern

usb mouse report descriptor

Definition at line 160 of file mouse_desc.c.

Referenced by class_setup_handler().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 272 of file mouse_desc.c.

Referenced by get_device_lang_id().

◆ mouse_desc_handler

usbd_desc_handler mouse_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: mouse_desc.c:387
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: mouse_desc.c:367
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: mouse_desc.c:418
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: mouse_desc.c:377
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: mouse_desc.c:453
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: mouse_desc.c:397
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: mouse_desc.c:430
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: mouse_desc.c:465
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: mouse_desc.c:407
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: mouse_desc.c:442

mouse device descriptor handler structure

Definition at line 64 of file mouse_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 279 of file mouse_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 285 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_mouse_desc_definition

Macros
USB_mouse_desc_definition
AT32F413_middlewares_usbd_class » USB_mouse_desc

Macros

#define | MOUSE_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_MOUSE_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_MOUSE_PRODUCT_ID 0x5710
#define | USBD_MOUSE_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_MOUSE_SIZ_REPORT_DESC 74
#define | USBD_MOUSE_SIZ_STRING_LANGID 4
#define | USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
#define | USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
#define | USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
#define | USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
#define | MOUSE_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 83 of file mouse_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 84 of file mouse_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 85 of file mouse_desc.h.

◆ MOUSE_BCD_NUM

#define MOUSE_BCD_NUM 0x0110

usb bcd number define

Definition at line 51 of file mouse_desc.h.

◆ MOUSE_BINTERVAL_TIME

#define MOUSE_BINTERVAL_TIME 0x0A

usb hid endpoint interval define

Definition at line 78 of file mouse_desc.h.

◆ USBD_MOUSE_CONFIG_DESC_SIZE

#define USBD_MOUSE_CONFIG_DESC_SIZE 34

usb descriptor size define

Definition at line 62 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_CONFIGURATION_STRING

#define USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"

Definition at line 72 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_INTERFACE_STRING

#define USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"

Definition at line 73 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_MANUFACTURER_STRING

#define USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 70 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_PRODUCT_STRING

#define USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"

Definition at line 71 of file mouse_desc.h.

◆ USBD_MOUSE_PRODUCT_ID

#define USBD_MOUSE_PRODUCT_ID 0x5710

Definition at line 57 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_REPORT_DESC

#define USBD_MOUSE_SIZ_REPORT_DESC 74

Definition at line 63 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_STRING_LANGID

#define USBD_MOUSE_SIZ_STRING_LANGID 4

Definition at line 64 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_STRING_SERIAL

#define USBD_MOUSE_SIZ_STRING_SERIAL 0x1A

Definition at line 65 of file mouse_desc.h.

◆ USBD_MOUSE_VENDOR_ID

#define USBD_MOUSE_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 56 of file mouse_desc.h.


AT32F413 Firmwary Library: USB_msc_class

Modules
USB_msc_class
AT32F413_middlewares_usbd_class

usb device class msc demo More...

Modules

USB_msc_class_private_functions
USB_msc_class_definition

Detailed Description

usb device class msc demo


AT32F413 Firmwary Library: USB_msc_class_private_functions

Functions | Variables
USB_msc_class_private_functions
AT32F413_middlewares_usbd_class » USB_msc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...

Variables

msc_type msc_struct
usbd_class_handler msc_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 95 of file msc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 200 of file msc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 186 of file msc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 256 of file msc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 215 of file msc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 74 of file msc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 229 of file msc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

< get max lun

< bulk only mass storage reset

Definition at line 115 of file msc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 241 of file msc_class.c.

Variable Documentation

◆ msc_class_handler

usbd_class_handler msc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&msc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: msc_class.c:241
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: msc_class.c:215
msc_struct
msc_type msc_struct
Definition: msc_class.c:52
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: msc_class.c:95
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: msc_class.c:115
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: msc_class.c:186
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: msc_class.c:200
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: msc_class.c:256
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: msc_class.c:74
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: msc_class.c:229

Definition at line 55 of file msc_class.c.

Referenced by main().

◆ msc_struct

msc_type msc_struct

Definition at line 52 of file msc_class.c.


AT32F413 Firmwary Library: USB_msc_class_definition

Macros | Variables
USB_msc_class_definition
AT32F413_middlewares_usbd_class » USB_msc_class

Macros

#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_IN_MAXPACKET_SIZE 0x40
#define | USBD_OUT_MAXPACKET_SIZE 0x40

Variables

usbd_class_handler msc_class_handler

Detailed Description

Macro Definition Documentation

◆ USBD_IN_MAXPACKET_SIZE

#define USBD_IN_MAXPACKET_SIZE 0x40

Definition at line 50 of file msc_class.h.

◆ USBD_MSC_BULK_IN_EPT

#define USBD_MSC_BULK_IN_EPT 0x81

Definition at line 47 of file msc_class.h.

◆ USBD_MSC_BULK_OUT_EPT

#define USBD_MSC_BULK_OUT_EPT 0x01

Definition at line 48 of file msc_class.h.

◆ USBD_OUT_MAXPACKET_SIZE

#define USBD_OUT_MAXPACKET_SIZE 0x40

Definition at line 51 of file msc_class.h.

Variable Documentation

◆ msc_class_handler

usbd_class_handler msc_class_handler
extern

Definition at line 55 of file msc_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_msc_desc

Modules
USB_msc_desc
AT32F413_middlewares_usbd_class

usb device msc descriptor More...

Modules

USB_msc_desc_private_functions
USB_msc_desc_definition

Detailed Description

usb device msc descriptor


AT32F413 Firmwary Library: USB_msc_desc_private_functions

Functions | Variables
USB_msc_desc_private_functions
AT32F413_middlewares_usbd_class » USB_msc_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler msc_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 388 of file msc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 310 of file msc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 290 of file msc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 376 of file msc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 330 of file msc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 341 of file msc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 320 of file msc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 353 of file msc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 300 of file msc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 365 of file msc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 268 of file msc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 242 of file msc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 216 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5720 ),
HBYTE( 0x5720 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 60 of file msc_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
32 ,
g_usbd_configuration
}

Definition at line 188 of file msc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 181 of file msc_desc.c.

Referenced by get_device_descriptor().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 195 of file msc_desc.c.

Referenced by get_device_lang_id().

◆ msc_desc_handler

usbd_desc_handler msc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: msc_desc.c:310
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: msc_desc.c:290
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: msc_desc.c:341
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: msc_desc.c:300
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: msc_desc.c:376
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: msc_desc.c:320
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: msc_desc.c:353
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: msc_desc.c:388
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: msc_desc.c:330
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: msc_desc.c:365

device descriptor handler structure

Definition at line 65 of file msc_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 202 of file msc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 208 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_msc_desc_definition

Macros | Variables
USB_msc_desc_definition
AT32F413_middlewares_usbd_class » USB_msc_desc

Macros

#define | MSC_BCD_NUM 0x0110
#define | USBD_MSC_VENDOR_ID 0x2E3C
#define | USBD_MSC_PRODUCT_ID 0x5720
#define | USBD_MSC_CONFIG_DESC_SIZE 32
#define | USBD_MSC_SIZ_STRING_LANGID 4
#define | USBD_MSC_SIZ_STRING_SERIAL 0x1A
#define | USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
#define | USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
#define | USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler msc_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 62 of file msc_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 63 of file msc_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 64 of file msc_desc.h.

◆ MSC_BCD_NUM

#define MSC_BCD_NUM 0x0110

Definition at line 48 of file msc_desc.h.

◆ USBD_MSC_CONFIG_DESC_SIZE

#define USBD_MSC_CONFIG_DESC_SIZE 32

Definition at line 53 of file msc_desc.h.

◆ USBD_MSC_DESC_CONFIGURATION_STRING

#define USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"

Definition at line 59 of file msc_desc.h.

◆ USBD_MSC_DESC_INTERFACE_STRING

#define USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"

Definition at line 60 of file msc_desc.h.

◆ USBD_MSC_DESC_MANUFACTURER_STRING

#define USBD_MSC_DESC_MANUFACTURER_STRING "Artery"

Definition at line 57 of file msc_desc.h.

◆ USBD_MSC_DESC_PRODUCT_STRING

#define USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"

Definition at line 58 of file msc_desc.h.

◆ USBD_MSC_PRODUCT_ID

#define USBD_MSC_PRODUCT_ID 0x5720

Definition at line 51 of file msc_desc.h.

◆ USBD_MSC_SIZ_STRING_LANGID

#define USBD_MSC_SIZ_STRING_LANGID 4

Definition at line 54 of file msc_desc.h.

◆ USBD_MSC_SIZ_STRING_SERIAL

#define USBD_MSC_SIZ_STRING_SERIAL 0x1A

Definition at line 55 of file msc_desc.h.

◆ USBD_MSC_VENDOR_ID

#define USBD_MSC_VENDOR_ID 0x2E3C

Definition at line 50 of file msc_desc.h.

Variable Documentation

◆ msc_desc_handler

usbd_desc_handler msc_desc_handler
extern

device descriptor handler structure

Definition at line 65 of file msc_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_printer_class

Modules
USB_printer_class
AT32F413_middlewares_usbd_class

usb device class printer demo More...

Modules

USB_printer_class_private_functions
USB_printer_class_definition

Detailed Description

usb device class printer demo


AT32F413 Firmwary Library: USB_printer_class_private_functions

Functions | Variables
USB_printer_class_private_functions
AT32F413_middlewares_usbd_class » USB_printer_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

static ALIGNED_HEAD uint8_t printer_device_id[24] ALIGNED_TAIL
printer_type printer_struct
usbd_class_handler printer_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 107 of file printer_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 201 of file printer_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 187 of file printer_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 270 of file printer_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 216 of file printer_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 81 of file printer_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 236 of file printer_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 127 of file printer_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 255 of file printer_class.c.

◆ usb_printer_get_rxdata()

uint16_t usb_printer_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 302 of file printer_class.c.

Referenced by main().

◆ usb_printer_send_data()

error_status usb_printer_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 332 of file printer_class.c.

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t printer_device_id [ 24 ] ALIGNED_TAIL
static
Initial value:
=
{
0x00, 0x16,
'M', 'F', 'G',':','A','r','t','e', 'r', 'y' ,' ',
'C','M', 'D', ':', 'E', 'S', 'C', 'P', 'O', 'S',' ',
}

Definition at line 51 of file printer_class.c.

◆ printer_class_handler

usbd_class_handler printer_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&printer_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: printer_class.c:255
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: printer_class.c:216
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: printer_class.c:107
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: printer_class.c:127
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: printer_class.c:187
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: printer_class.c:201
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: printer_class.c:270
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: printer_class.c:81
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: printer_class.c:236
printer_struct
printer_type printer_struct
Definition: printer_class.c:59

Definition at line 62 of file printer_class.c.

Referenced by main().

◆ printer_struct

printer_type printer_struct

Definition at line 59 of file printer_class.c.


AT32F413 Firmwary Library: USB_printer_class_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_printer_class_definition
AT32F413_middlewares_usbd_class » USB_printer_class

Data Structures

struct printer_type

Macros

#define | USBD_PRINTER_BULK_IN_EPT 0x81
#define | USBD_PRINTER_BULK_OUT_EPT 0x01
#define | USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
#define | USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
#define | PRINTER_DEVICE_ID_LEN 24

Enumerations

enum printer_req_type { PRINTER_REQ_GET_DEVICE_ID = 0x00 , PRINTER_REQ_GET_PORT_STATUS = 0x01 , PRINTER_REQ_GET_SOFT_RESET = 0x02 }

Functions

uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler printer_class_handler

Detailed Description

Macro Definition Documentation

◆ PRINTER_DEVICE_ID_LEN

#define PRINTER_DEVICE_ID_LEN 24

Definition at line 55 of file printer_class.h.

◆ USBD_PRINTER_BULK_IN_EPT

#define USBD_PRINTER_BULK_IN_EPT 0x81

Definition at line 48 of file printer_class.h.

◆ USBD_PRINTER_BULK_OUT_EPT

#define USBD_PRINTER_BULK_OUT_EPT 0x01

Definition at line 49 of file printer_class.h.

◆ USBD_PRINTER_IN_MAXPACKET_SIZE

#define USBD_PRINTER_IN_MAXPACKET_SIZE 0x40

Definition at line 52 of file printer_class.h.

◆ USBD_PRINTER_OUT_MAXPACKET_SIZE

#define USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40

Definition at line 53 of file printer_class.h.

Enumeration Type Documentation

◆ printer_req_type

enum printer_req_type
Enumerator
PRINTER_REQ_GET_DEVICE_ID
PRINTER_REQ_GET_PORT_STATUS
PRINTER_REQ_GET_SOFT_RESET

Definition at line 57 of file printer_class.h.

Function Documentation

◆ usb_printer_get_rxdata()

uint16_t usb_printer_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 302 of file printer_class.c.

Referenced by main().

◆ usb_printer_send_data()

error_status usb_printer_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 332 of file printer_class.c.

Variable Documentation

◆ printer_class_handler

usbd_class_handler printer_class_handler
extern

Definition at line 62 of file printer_class.c.

Referenced by main().


AT32F413 Firmwary Library: printer_type Struct Reference

Data Fields
printer_type Struct Reference
AT32F413_middlewares_usbd_class » USB_printer_class » USB_printer_class_definition

#include <printer_class.h>

Data Fields

uint32_t | alt_setting
uint32_t | g_printer_port_status
uint8_t | g_rx_buff [0x40]
uint8_t | g_printer_data [0x40]
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
uint32_t | g_rxlen

Detailed Description

Definition at line 65 of file printer_class.h.

Field Documentation

◆ alt_setting

uint32_t printer_type::alt_setting

Definition at line 67 of file printer_class.h.

Referenced by class_setup_handler().

◆ g_printer_data

uint8_t printer_type::g_printer_data[0x40]

Definition at line 70 of file printer_class.h.

Referenced by class_setup_handler().

◆ g_printer_port_status

uint32_t printer_type::g_printer_port_status

Definition at line 68 of file printer_class.h.

Referenced by class_init_handler(), and class_setup_handler().

◆ g_rx_buff

uint8_t printer_type::g_rx_buff[0x40]

Definition at line 69 of file printer_class.h.

Referenced by class_init_handler(), and usb_printer_get_rxdata().

◆ g_rx_completed

__IO uint8_t printer_type::g_rx_completed

Definition at line 72 of file printer_class.h.

Referenced by class_out_handler(), and usb_printer_get_rxdata().

◆ g_rxlen

uint32_t printer_type::g_rxlen

Definition at line 73 of file printer_class.h.

Referenced by class_out_handler(), and usb_printer_get_rxdata().

◆ g_tx_completed

__IO uint8_t printer_type::g_tx_completed

Definition at line 71 of file printer_class.h.

Referenced by class_in_handler(), class_init_handler(), and usb_printer_send_data().

The documentation for this struct was generated from the following file:
  • printer_class.h


AT32F413 Firmwary Library: USB_printer_desc

Modules
USB_printer_desc
AT32F413_middlewares_usbd_class

usb device printer descriptor More...

Modules

USB_printer_desc_private_functions
USB_printer_desc_definition

Detailed Description

usb device printer descriptor


AT32F413 Firmwary Library: USB_printer_desc_private_functions

Functions | Variables
USB_printer_desc_private_functions
AT32F413_middlewares_usbd_class » USB_printer_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler printer_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 388 of file printer_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 310 of file printer_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 290 of file printer_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 376 of file printer_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 330 of file printer_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 341 of file printer_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 320 of file printer_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 353 of file printer_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 300 of file printer_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 365 of file printer_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 268 of file printer_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 242 of file printer_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 216 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x57FF ),
HBYTE( 0x57FF ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 60 of file printer_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
32 ,
g_usbd_configuration
}

Definition at line 188 of file printer_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 181 of file printer_desc.c.

Referenced by get_device_descriptor().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 195 of file printer_desc.c.

Referenced by get_device_lang_id().

◆ printer_desc_handler

usbd_desc_handler printer_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: printer_desc.c:310
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: printer_desc.c:290
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: printer_desc.c:341
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: printer_desc.c:300
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: printer_desc.c:376
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: printer_desc.c:320
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: printer_desc.c:353
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: printer_desc.c:388
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: printer_desc.c:330
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: printer_desc.c:365

device descriptor handler structure

Definition at line 65 of file printer_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 202 of file printer_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 208 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_printer_desc_definition

Macros | Variables
USB_printer_desc_definition
AT32F413_middlewares_usbd_class » USB_printer_desc

Macros

#define | PRINTER_BCD_NUM 0x0110
#define | USBD_PRINTER_VENDOR_ID 0x2E3C
#define | USBD_PRINTER_PRODUCT_ID 0x57FF
#define | USBD_PRINTER_CONFIG_DESC_SIZE 32
#define | USBD_PRINTER_SIZ_STRING_LANGID 4
#define | USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
#define | USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
#define | USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
#define | USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
#define | PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
#define | PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
#define | PRINTER_PROTOCOL_1284_4 0x03
#define | PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler printer_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 68 of file printer_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 69 of file printer_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 70 of file printer_desc.h.

◆ PRINTER_BCD_NUM

#define PRINTER_BCD_NUM 0x0110

Definition at line 48 of file printer_desc.h.

◆ PRINTER_PROTOCOL_1284_4

#define PRINTER_PROTOCOL_1284_4 0x03

Definition at line 64 of file printer_desc.h.

◆ PRINTER_PROTOCOL_BI_DIRECTIONAL

#define PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02

Definition at line 63 of file printer_desc.h.

◆ PRINTER_PROTOCOL_UNIDIRECTIONAL

#define PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01

Definition at line 62 of file printer_desc.h.

◆ PRINTER_PROTOCOL_VENDOR_SPECIFIC

#define PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF

Definition at line 65 of file printer_desc.h.

◆ USBD_PRINTER_CONFIG_DESC_SIZE

#define USBD_PRINTER_CONFIG_DESC_SIZE 32

Definition at line 53 of file printer_desc.h.

◆ USBD_PRINTER_DESC_CONFIGURATION_STRING

#define USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"

Definition at line 59 of file printer_desc.h.

◆ USBD_PRINTER_DESC_INTERFACE_STRING

#define USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"

Definition at line 60 of file printer_desc.h.

◆ USBD_PRINTER_DESC_MANUFACTURER_STRING

#define USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"

Definition at line 57 of file printer_desc.h.

◆ USBD_PRINTER_DESC_PRODUCT_STRING

#define USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"

Definition at line 58 of file printer_desc.h.

◆ USBD_PRINTER_PRODUCT_ID

#define USBD_PRINTER_PRODUCT_ID 0x57FF

Definition at line 51 of file printer_desc.h.

◆ USBD_PRINTER_SIZ_STRING_LANGID

#define USBD_PRINTER_SIZ_STRING_LANGID 4

Definition at line 54 of file printer_desc.h.

◆ USBD_PRINTER_SIZ_STRING_SERIAL

#define USBD_PRINTER_SIZ_STRING_SERIAL 0x1A

Definition at line 55 of file printer_desc.h.

◆ USBD_PRINTER_VENDOR_ID

#define USBD_PRINTER_VENDOR_ID 0x2E3C

Definition at line 50 of file printer_desc.h.

Variable Documentation

◆ printer_desc_handler

usbd_desc_handler printer_desc_handler
extern

device descriptor handler structure

Definition at line 65 of file printer_desc.c.

Referenced by main().


AT32F413 Firmwary Library: AT32F413_middlewares_usbd_drivers

Modules
AT32F413_middlewares_usbd_drivers

Modules

USBD_drivers_core
usb device drivers core
USBD_drivers_interrupt
usb device interrupt
USBD_drivers_standard_request
usb device standard_request
USB_standard

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: USBD_drivers_core

Modules
USBD_drivers_core
AT32F413_middlewares_usbd_drivers

usb device drivers core More...

Modules

USBD_core_exported_types
USBD_core_exported_functions
USBD_core_private_functions

Detailed Description

usb device drivers core


AT32F413 Firmwary Library: USBD_core_exported_types

Data Structures | Enumerations
USBD_core_exported_types
AT32F413_middlewares_usbd_drivers » USBD_drivers_core

Data Structures

struct | usbd_desc_t
usb device descriptor struct More...
struct | usbd_desc_handler
usb device descriptor handler More...
struct | usbd_class_handler
usb device class handler More...
struct | usbd_core_type
usb device core struct type More...

Enumerations

enum usbd_event_type {
USBD_NOP_EVENT , USBD_RESET_EVENT , USBD_SUSPEND_EVENT , USBD_WAKEUP_EVENT ,
USBD_ERR_EVENT
}
usb device event More...

Detailed Description

Enumeration Type Documentation

◆ usbd_event_type

enum usbd_event_type

usb device event

Enumerator
USBD_NOP_EVENT | usb device event nop
USBD_RESET_EVENT | usb device event reset
USBD_SUSPEND_EVENT | usb device event suspend
USBD_WAKEUP_EVENT | usb device event wakeup
USBD_ERR_EVENT | usb device event error

Definition at line 52 of file usbd_core.h.


AT32F413 Firmwary Library: usbd_desc_t Struct Reference

Data Fields
usbd_desc_t Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device descriptor struct More...

#include <usbd_core.h>

Data Fields

uint16_t | length
uint8_t * | descriptor

Detailed Description

usb device descriptor struct

Definition at line 64 of file usbd_core.h.

Field Documentation

◆ descriptor

uint8_t* usbd_desc_t::descriptor

descriptor string

Definition at line 67 of file usbd_core.h.

Referenced by class_audio_setup_handler(), class_setup_handler(), get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), get_device_product_string(), and usbd_get_descriptor().

◆ length

uint16_t usbd_desc_t::length

descriptor length

Definition at line 66 of file usbd_core.h.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), get_device_product_string(), and usbd_get_descriptor().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: usbd_desc_handler Struct Reference

Data Fields
usbd_desc_handler Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device descriptor handler More...

#include <usbd_core.h>

Data Fields

usbd_desc_t *(* | get_device_descriptor )(void)
usbd_desc_t *(* | get_device_qualifier )(void)
usbd_desc_t *(* | get_device_configuration )(void)
usbd_desc_t *(* | get_device_other_speed )(void)
usbd_desc_t *(* | get_device_lang_id )(void)
usbd_desc_t *(* | get_device_manufacturer_string )(void)
usbd_desc_t *(* | get_device_product_string )(void)
usbd_desc_t *(* | get_device_serial_string )(void)
usbd_desc_t *(* | get_device_interface_string )(void)
usbd_desc_t *(* | get_device_config_string )(void)

Detailed Description

usb device descriptor handler

Definition at line 73 of file usbd_core.h.

Field Documentation

◆ get_device_config_string

usbd_desc_t *(* usbd_desc_handler::get_device_config_string) (void)

get device device config callback

Definition at line 84 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_configuration

usbd_desc_t *(* usbd_desc_handler::get_device_configuration) (void)

get device configuration callback

Definition at line 77 of file usbd_core.h.

Referenced by class_audio_setup_handler(), class_setup_handler(), and usbd_get_descriptor().

◆ get_device_descriptor

usbd_desc_t *(* usbd_desc_handler::get_device_descriptor) (void)

get device descriptor callback

Definition at line 75 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_interface_string

usbd_desc_t *(* usbd_desc_handler::get_device_interface_string) (void)

get device interface string callback

Definition at line 83 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_lang_id

usbd_desc_t *(* usbd_desc_handler::get_device_lang_id) (void)

get device lang id callback

Definition at line 79 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_manufacturer_string

usbd_desc_t *(* usbd_desc_handler::get_device_manufacturer_string) (void)

get device manufacturer callback

Definition at line 80 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_other_speed

usbd_desc_t *(* usbd_desc_handler::get_device_other_speed) (void)

get device other speed callback

Definition at line 78 of file usbd_core.h.

◆ get_device_product_string

usbd_desc_t *(* usbd_desc_handler::get_device_product_string) (void)

get device product callback

Definition at line 81 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_qualifier

usbd_desc_t *(* usbd_desc_handler::get_device_qualifier) (void)

get device qualifier callback

Definition at line 76 of file usbd_core.h.

◆ get_device_serial_string

usbd_desc_t *(* usbd_desc_handler::get_device_serial_string) (void)

get device serial callback

Definition at line 82 of file usbd_core.h.

Referenced by usbd_get_descriptor().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: usbd_class_handler Struct Reference

Data Fields
usbd_class_handler Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device class handler More...

#include <usbd_core.h>

Data Fields

usb_sts_type(* | init_handler )(void *udev)
usb_sts_type(* | clear_handler )(void *udev)
usb_sts_type(* | setup_handler )(void *udev, usb_setup_type *setup)
usb_sts_type(* | ept0_tx_handler )(void *udev)
usb_sts_type(* | ept0_rx_handler )(void *udev)
usb_sts_type(* | in_handler )(void *udev, uint8_t ept_num)
usb_sts_type(* | out_handler )(void *udev, uint8_t ept_num)
usb_sts_type(* | sof_handler )(void *udev)
usb_sts_type(* | event_handler )(void *udev, usbd_event_type event)
void * | pdata

Detailed Description

usb device class handler

Definition at line 90 of file usbd_core.h.

Field Documentation

◆ clear_handler

usb_sts_type(* usbd_class_handler::clear_handler) (void *udev)

usb class clear handler

Definition at line 93 of file usbd_core.h.

Referenced by usbd_set_configuration().

◆ ept0_rx_handler

usb_sts_type(* usbd_class_handler::ept0_rx_handler) (void *udev)

usb class endpoint 0 rx complete handler

Definition at line 96 of file usbd_core.h.

Referenced by usbd_core_out_handler().

◆ ept0_tx_handler

usb_sts_type(* usbd_class_handler::ept0_tx_handler) (void *udev)

usb class endpoint 0 tx complete handler

Definition at line 95 of file usbd_core.h.

Referenced by usbd_core_in_handler().

◆ event_handler

usb_sts_type(* usbd_class_handler::event_handler) (void *udev, usbd_event_type event)

usb class event handler

Definition at line 100 of file usbd_core.h.

Referenced by usbd_reset_handler(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ in_handler

usb_sts_type(* usbd_class_handler::in_handler) (void *udev, uint8_t ept_num)

usb class in transfer complete handler

Definition at line 97 of file usbd_core.h.

Referenced by usbd_core_in_handler().

◆ init_handler

usb_sts_type(* usbd_class_handler::init_handler) (void *udev)

usb class init handler

Definition at line 92 of file usbd_core.h.

Referenced by usbd_set_configuration().

◆ out_handler

usb_sts_type(* usbd_class_handler::out_handler) (void *udev, uint8_t ept_num)

usb class out transfer complete handler

Definition at line 98 of file usbd_core.h.

Referenced by usbd_core_out_handler().

◆ pdata

void* usbd_class_handler::pdata

usb class data pointer

Definition at line 101 of file usbd_core.h.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), audio_set_interface(), bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_check_address(), bot_scsi_clear_feature(), bot_scsi_cmd_process(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_format_capacity(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_start_stop(), bot_scsi_test_unit(), bot_scsi_verify(), bot_scsi_write10(), cdc_class_setup_handler(), class_ept0_rx_handler(), class_event_handler(), class_hid_setup_handler(), class_in_handler(), class_init_handler(), class_out_handler(), class_setup_handler(), keyboard_class_setup_handler(), keyboard_send_string(), main(), msc_class_setup_handler(), usb_hid_buf_process(), usb_hid_keyboard_send_char(), usb_hid_mouse_send(), usb_printer_get_rxdata(), usb_printer_send_data(), usb_vcp_cmd_process(), usb_vcp_get_rxdata(), usb_vcp_send_data(), usb_vcpkybrd_vcp_get_rxdata(), and usb_vcpkybrd_vcp_send_data().

◆ setup_handler

usb_sts_type(* usbd_class_handler::setup_handler) (void *udev, usb_setup_type *setup)

usb class setup handler

Definition at line 94 of file usbd_core.h.

Referenced by usbd_clear_feature(), usbd_device_request(), usbd_endpoint_request(), usbd_get_descriptor(), usbd_interface_request(), and usbd_set_feature().

◆ sof_handler

usb_sts_type(* usbd_class_handler::sof_handler) (void *udev)

usb class sof handler

Definition at line 99 of file usbd_core.h.

Referenced by usbd_sof_handler().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: usbd_core_type Struct Reference

Data Fields
usbd_core_type Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device core struct type More...

#include <usbd_core.h>

Data Fields

usb_reg_type * usb_reg
usbd_class_handler * class_handler
usbd_desc_handler * desc_handler
usb_ept_info | ept_in [USB_EPT_MAX_NUM]
usb_ept_info | ept_out [USB_EPT_MAX_NUM]
usb_setup_type setup
uint8_t | setup_buffer [12]
uint8_t | ept0_sts
uint8_t | speed
uint16_t | ept0_wlength
usbd_conn_state conn_state
usbd_conn_state old_conn_state
uint8_t | device_addr
uint8_t | remote_wakup
uint8_t | default_config
uint8_t | dev_config
uint16_t | config_status

Detailed Description

usb device core struct type

Definition at line 107 of file usbd_core.h.

Field Documentation

◆ class_handler

usbd_class_handler* usbd_core_type::class_handler

usb device class handler pointer

Definition at line 111 of file usbd_core.h.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), audio_set_interface(), bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_check_address(), bot_scsi_clear_feature(), bot_scsi_cmd_process(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_format_capacity(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_start_stop(), bot_scsi_test_unit(), bot_scsi_verify(), bot_scsi_write10(), cdc_class_setup_handler(), class_ept0_rx_handler(), class_event_handler(), class_hid_setup_handler(), class_in_handler(), class_init_handler(), class_out_handler(), class_setup_handler(), keyboard_class_setup_handler(), keyboard_send_string(), main(), msc_class_setup_handler(), usb_hid_buf_process(), usb_hid_keyboard_send_char(), usb_hid_mouse_send(), usb_printer_get_rxdata(), usb_printer_send_data(), usb_vcp_cmd_process(), usb_vcp_get_rxdata(), usb_vcp_send_data(), usb_vcpkybrd_vcp_get_rxdata(), usb_vcpkybrd_vcp_send_data(), usbd_clear_feature(), usbd_core_in_handler(), usbd_core_init(), usbd_core_out_handler(), usbd_device_request(), usbd_endpoint_request(), usbd_get_descriptor(), usbd_interface_request(), usbd_reset_handler(), usbd_set_configuration(), usbd_set_feature(), usbd_sof_handler(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ config_status

uint16_t usbd_core_type::config_status

usb configure status

Definition at line 131 of file usbd_core.h.

Referenced by usbd_clear_feature(), and usbd_get_status().

◆ conn_state

usbd_conn_state usbd_core_type::conn_state

usb current connect state

Definition at line 124 of file usbd_core.h.

Referenced by usbd_clear_feature(), usbd_connect_state_get(), usbd_core_in_handler(), usbd_core_init(), usbd_core_out_handler(), usbd_endpoint_request(), usbd_eptn_handler(), usbd_get_configuration(), usbd_get_status(), usbd_interface_request(), usbd_remote_wakeup(), usbd_reset_handler(), usbd_set_address(), usbd_set_configuration(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ default_config

uint8_t usbd_core_type::default_config

usb default config state

Definition at line 129 of file usbd_core.h.

Referenced by usbd_get_configuration().

◆ desc_handler

usbd_desc_handler* usbd_core_type::desc_handler

usb device descriptor handler pointer

Definition at line 112 of file usbd_core.h.

Referenced by class_audio_setup_handler(), class_setup_handler(), usbd_core_init(), and usbd_get_descriptor().

◆ dev_config

uint8_t usbd_core_type::dev_config

usb device config state

Definition at line 130 of file usbd_core.h.

Referenced by usbd_get_configuration(), and usbd_set_configuration().

◆ device_addr

uint8_t usbd_core_type::device_addr

device address

Definition at line 127 of file usbd_core.h.

Referenced by usbd_eptn_handler(), and usbd_set_address().

◆ ept0_sts

uint8_t usbd_core_type::ept0_sts

usb control endpoint 0 state

Definition at line 120 of file usbd_core.h.

Referenced by usbd_core_in_handler(), usbd_core_out_handler(), usbd_core_setup_handler(), usbd_ctrl_recv(), usbd_ctrl_recv_status(), usbd_ctrl_send(), and usbd_ctrl_send_status().

◆ ept0_wlength

uint16_t usbd_core_type::ept0_wlength

usb endpoint 0 transfer length

Definition at line 122 of file usbd_core.h.

Referenced by usbd_core_in_handler(), and usbd_core_setup_handler().

◆ ept_in

usb_ept_info usbd_core_type::ept_in[USB_EPT_MAX_NUM]

usb in endpoint infomation struct

Definition at line 114 of file usbd_core.h.

Referenced by usbd_clear_stall(), usbd_core_in_handler(), usbd_ctrl_send(), usbd_endpoint_request(), usbd_ept_buf_custom_define(), usbd_ept_close(), usbd_ept_dbuffer_enable(), usbd_ept_defaut_init(), usbd_ept_open(), usbd_ept_send(), usbd_eptn_handler(), and usbd_set_stall().

◆ ept_out

usb_ept_info usbd_core_type::ept_out[USB_EPT_MAX_NUM]

usb out endpoint infomation struct

Definition at line 115 of file usbd_core.h.

Referenced by usbd_clear_stall(), usbd_core_out_handler(), usbd_ctrl_recv(), usbd_endpoint_request(), usbd_ept_buf_custom_define(), usbd_ept_close(), usbd_ept_dbuffer_enable(), usbd_ept_defaut_init(), usbd_ept_open(), usbd_ept_recv(), usbd_eptn_handler(), usbd_get_recv_len(), and usbd_set_stall().

◆ old_conn_state

usbd_conn_state usbd_core_type::old_conn_state

usb save the previous connect state

Definition at line 125 of file usbd_core.h.

Referenced by usbd_remote_wakeup(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ remote_wakup

uint8_t usbd_core_type::remote_wakup

remote wakeup state

Definition at line 128 of file usbd_core.h.

Referenced by main(), usbd_clear_feature(), usbd_get_status(), and usbd_set_feature().

◆ setup

usb_setup_type usbd_core_type::setup

usb setup type struct

Definition at line 117 of file usbd_core.h.

Referenced by class_ept0_rx_handler(), usbd_clear_feature(), usbd_core_setup_handler(), usbd_device_request(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_set_feature().

◆ setup_buffer

uint8_t usbd_core_type::setup_buffer[12]

usb setup request buffer

Definition at line 118 of file usbd_core.h.

Referenced by usbd_core_setup_handler(), and usbd_eptn_handler().

◆ speed

uint8_t usbd_core_type::speed

usb speed

Definition at line 121 of file usbd_core.h.

◆ usb_reg

usb_reg_type* usbd_core_type::usb_reg

usb register pointer

Definition at line 109 of file usbd_core.h.

Referenced by usbd_connect(), usbd_core_init(), usbd_disconnect(), usbd_enter_suspend(), usbd_ept_close(), usbd_ept_loop_handler(), usbd_ept_open(), usbd_ept_send(), usbd_eptn_handler(), usbd_irq_handler(), usbd_remote_wakeup(), usbd_reset_handler(), usbd_set_device_addr(), and usbd_wakeup_handler().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: USBD_core_exported_functions

Functions
USBD_core_exported_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_core

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

Function Documentation

◆ usbd_clear_stall()

void usbd_clear_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

clear endpoint stall

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 234 of file usbd_core.c.

Referenced by usbd_endpoint_request().

◆ usbd_connect()

void usbd_connect ( usbd_core_type * udev )

usb device connect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 559 of file usbd_core.c.

Referenced by main(), and usb_reset().

◆ usbd_connect_state_get()

usbd_conn_state usbd_connect_state_get ( usbd_core_type * udev )

get usb connect state

Parameters
udev to the structure of usbd_core_type
Return values
usb connect state

Definition at line 590 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), custom_hid_class_send_report(), main(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), and usb_vcpkybrd_class_send_report().

◆ usbd_core_in_handler()

void usbd_core_in_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core in transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 46 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_init()

void usbd_core_init | ( | usbd_core_type * | udev,
 |  | usb_reg_type * | usb_reg,
 |  | usbd_class_handler * | class_handler,
 |  | usbd_desc_handler * | desc_handler,
 |  | uint8_t | core_id
 | ) |  |

initializes the usb core

Parameters
udev | to the structure of usbd_core_type
usb_reg | usb register pointer (USB)
class_handler | usb class handler
desc_handler | device config handler
core_id | usb core id number
Return values
none

Definition at line 670 of file usbd_core.c.

Referenced by main().

◆ usbd_core_out_handler()

void usbd_core_out_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core out transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 98 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_setup_handler()

void usbd_core_setup_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_num
 | ) |  |

usb core setup transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 138 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_ctrl_recv()

void usbd_ctrl_recv | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | recv data buffer
len | recv data length
Return values
none

Definition at line 193 of file usbd_core.c.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_hid_setup_handler(), class_setup_handler(), and keyboard_class_setup_handler().

◆ usbd_ctrl_recv_status()

void usbd_ctrl_recv_status ( usbd_core_type * udev )

usb control endpoint send out status

Parameters
udev usb device core handler type
Return values
none

Definition at line 221 of file usbd_core.c.

Referenced by usbd_core_in_handler().

◆ usbd_ctrl_send()

void usbd_ctrl_send | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 174 of file usbd_core.c.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), and usbd_get_status().

◆ usbd_ctrl_send_status()

void usbd_ctrl_send_status ( usbd_core_type * udev )

usb control endpoint send in status

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 209 of file usbd_core.c.

Referenced by class_audio_setup_handler(), class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_core_out_handler(), usbd_endpoint_request(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_set_feature().

◆ usbd_ctrl_unsupport()

void usbd_ctrl_unsupport ( usbd_core_type * udev )

un-support device request

Parameters
udev usb device core handler type
Return values
none

Definition at line 284 of file usbd_core.c.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_device_request(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), usbd_get_status(), usbd_interface_request(), usbd_set_address(), and usbd_set_configuration().

◆ usbd_disconnect()

void usbd_disconnect ( usbd_core_type * udev )

usb device disconnect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 569 of file usbd_core.c.

Referenced by usb_reset().

◆ usbd_enter_suspend()

void usbd_enter_suspend ( usbd_core_type * udev )

usb device enter suspend mode

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 620 of file usbd_core.c.

Referenced by usbd_suspend_handler().

◆ usbd_ept_buf_auto_define()

void usbd_ept_buf_auto_define ( usb_ept_info * ept_info )

usb auto define endpoint buffer

Parameters
usb_ept_info endpoint information
Return values
none

Definition at line 425 of file usbd_core.c.

Referenced by usbd_ept_open().

◆ usbd_ept_buf_custom_define()

void usbd_ept_buf_custom_define | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint32_t | addr
 | ) |  |

usb custom define endpoint buffer

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
addr | usb fifo offset address
Return values
none

Definition at line 459 of file usbd_core.c.

Referenced by class_init_handler(), and usbd_reset_handler().

◆ usbd_ept_close()

void usbd_ept_close | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb close endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 536 of file usbd_core.c.

Referenced by class_clear_handler(), class_setup_handler(), and msc_class_setup_handler().

◆ usbd_ept_dbuffer_enable()

void usbd_ept_dbuffer_enable | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

enable endpoint double buffer.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 404 of file usbd_core.c.

Referenced by class_init_handler().

◆ usbd_ept_defaut_init()

void usbd_ept_defaut_init ( usbd_core_type * udev )

usb endpoint structure initialization

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 630 of file usbd_core.c.

Referenced by usbd_core_init(), and usbd_reset_handler().

◆ usbd_ept_open()

void usbd_ept_open | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t | ept_type,
 |  | uint16_t | maxpacket
 | ) |  |

usb open endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
ept_type | endpoint type
maxpacket | endpoint support max buffer size
Return values
none

Definition at line 501 of file usbd_core.c.

Referenced by class_init_handler(), class_setup_handler(), msc_class_setup_handler(), and usbd_reset_handler().

◆ usbd_ept_recv()

void usbd_ept_recv | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | receive data buffer
len | receive data length
Return values
none

Definition at line 359 of file usbd_core.c.

Referenced by audio_set_interface(), bot_scsi_init(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_stall(), bot_scsi_write10(), class_init_handler(), class_out_handler(), usb_printer_get_rxdata(), usb_vcp_get_rxdata(), usb_vcpkybrd_vcp_get_rxdata(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), usbd_ctrl_recv_status(), and usbd_eptn_handler().

◆ usbd_ept_send()

void usbd_ept_send | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 299 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), audio_set_interface(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), class_in_handler(), custom_hid_class_send_report(), usb_hid_buf_process(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), usb_printer_send_data(), usb_vcp_send_data(), usb_vcpkybrd_class_send_report(), usb_vcpkybrd_vcp_send_data(), usbd_core_in_handler(), usbd_ctrl_send(), usbd_ctrl_send_status(), and usbd_eptn_handler().

◆ usbd_get_recv_len()

uint32_t usbd_get_recv_len | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb endpoint get receive data length

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 392 of file usbd_core.c.

Referenced by bot_cbw_decode(), class_ept0_rx_handler(), and class_out_handler().

◆ usbd_remote_wakeup()

void usbd_remote_wakeup ( usbd_core_type * udev )

usb device remote wakeup

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 600 of file usbd_core.c.

Referenced by main().

◆ usbd_set_device_addr()

void usbd_set_device_addr | ( | usbd_core_type * | udev,
 |  | uint8_t | address
 | ) |  |

usb device set device address.

Parameters
udev | to the structure of usbd_core_type
address | host assignment address
Return values
none

Definition at line 580 of file usbd_core.c.

◆ usbd_set_stall()

void usbd_set_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb set endpoint to stall.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 259 of file usbd_core.c.

Referenced by bot_scsi_clear_feature(), bot_scsi_stall(), usbd_ctrl_unsupport(), and usbd_endpoint_request().


AT32F413 Firmwary Library: USBD_core_private_functions

Functions
USBD_core_private_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_core

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

Function Documentation

◆ usbd_clear_stall()

void usbd_clear_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

clear endpoint stall

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 234 of file usbd_core.c.

Referenced by usbd_endpoint_request().

◆ usbd_connect()

void usbd_connect ( usbd_core_type * udev )

usb device connect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 559 of file usbd_core.c.

Referenced by main(), and usb_reset().

◆ usbd_connect_state_get()

usbd_conn_state usbd_connect_state_get ( usbd_core_type * udev )

get usb connect state

Parameters
udev to the structure of usbd_core_type
Return values
usb connect state

Definition at line 590 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), custom_hid_class_send_report(), main(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), and usb_vcpkybrd_class_send_report().

◆ usbd_core_in_handler()

void usbd_core_in_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core in transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 46 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_init()

void usbd_core_init | ( | usbd_core_type * | udev,
 |  | usb_reg_type * | usb_reg,
 |  | usbd_class_handler * | class_handler,
 |  | usbd_desc_handler * | desc_handler,
 |  | uint8_t | core_id
 | ) |  |

initializes the usb core

Parameters
udev | to the structure of usbd_core_type
usb_reg | usb register pointer (USB)
class_handler | usb class handler
desc_handler | device config handler
core_id | usb core id number
Return values
none

Definition at line 670 of file usbd_core.c.

Referenced by main().

◆ usbd_core_out_handler()

void usbd_core_out_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core out transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 98 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_setup_handler()

void usbd_core_setup_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_num
 | ) |  |

usb core setup transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 138 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_ctrl_recv()

void usbd_ctrl_recv | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | recv data buffer
len | recv data length
Return values
none

Definition at line 193 of file usbd_core.c.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_hid_setup_handler(), class_setup_handler(), and keyboard_class_setup_handler().

◆ usbd_ctrl_recv_status()

void usbd_ctrl_recv_status ( usbd_core_type * udev )

usb control endpoint send out status

Parameters
udev usb device core handler type
Return values
none

Definition at line 221 of file usbd_core.c.

Referenced by usbd_core_in_handler().

◆ usbd_ctrl_send()

void usbd_ctrl_send | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 174 of file usbd_core.c.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), and usbd_get_status().

◆ usbd_ctrl_send_status()

void usbd_ctrl_send_status ( usbd_core_type * udev )

usb control endpoint send in status

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 209 of file usbd_core.c.

Referenced by class_audio_setup_handler(), class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_core_out_handler(), usbd_endpoint_request(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_set_feature().

◆ usbd_ctrl_unsupport()

void usbd_ctrl_unsupport ( usbd_core_type * udev )

un-support device request

Parameters
udev usb device core handler type
Return values
none

Definition at line 284 of file usbd_core.c.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_device_request(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), usbd_get_status(), usbd_interface_request(), usbd_set_address(), and usbd_set_configuration().

◆ usbd_disconnect()

void usbd_disconnect ( usbd_core_type * udev )

usb device disconnect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 569 of file usbd_core.c.

Referenced by usb_reset().

◆ usbd_enter_suspend()

void usbd_enter_suspend ( usbd_core_type * udev )

usb device enter suspend mode

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 620 of file usbd_core.c.

Referenced by usbd_suspend_handler().

◆ usbd_ept_buf_auto_define()

void usbd_ept_buf_auto_define ( usb_ept_info * ept_info )

usb auto define endpoint buffer

Parameters
usb_ept_info endpoint information
Return values
none

Definition at line 425 of file usbd_core.c.

Referenced by usbd_ept_open().

◆ usbd_ept_buf_custom_define()

void usbd_ept_buf_custom_define | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint32_t | addr
 | ) |  |

usb custom define endpoint buffer

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
addr | usb fifo offset address
Return values
none

Definition at line 459 of file usbd_core.c.

Referenced by class_init_handler(), and usbd_reset_handler().

◆ usbd_ept_close()

void usbd_ept_close | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb close endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 536 of file usbd_core.c.

Referenced by class_clear_handler(), class_setup_handler(), and msc_class_setup_handler().

◆ usbd_ept_dbuffer_enable()

void usbd_ept_dbuffer_enable | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

enable endpoint double buffer.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 404 of file usbd_core.c.

Referenced by class_init_handler().

◆ usbd_ept_defaut_init()

void usbd_ept_defaut_init ( usbd_core_type * udev )

usb endpoint structure initialization

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 630 of file usbd_core.c.

Referenced by usbd_core_init(), and usbd_reset_handler().

◆ usbd_ept_open()

void usbd_ept_open | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t | ept_type,
 |  | uint16_t | maxpacket
 | ) |  |

usb open endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
ept_type | endpoint type
maxpacket | endpoint support max buffer size
Return values
none

Definition at line 501 of file usbd_core.c.

Referenced by class_init_handler(), class_setup_handler(), msc_class_setup_handler(), and usbd_reset_handler().

◆ usbd_ept_recv()

void usbd_ept_recv | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | receive data buffer
len | receive data length
Return values
none

Definition at line 359 of file usbd_core.c.

Referenced by audio_set_interface(), bot_scsi_init(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_stall(), bot_scsi_write10(), class_init_handler(), class_out_handler(), usb_printer_get_rxdata(), usb_vcp_get_rxdata(), usb_vcpkybrd_vcp_get_rxdata(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), usbd_ctrl_recv_status(), and usbd_eptn_handler().

◆ usbd_ept_send()

void usbd_ept_send | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 299 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), audio_set_interface(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), class_in_handler(), custom_hid_class_send_report(), usb_hid_buf_process(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), usb_printer_send_data(), usb_vcp_send_data(), usb_vcpkybrd_class_send_report(), usb_vcpkybrd_vcp_send_data(), usbd_core_in_handler(), usbd_ctrl_send(), usbd_ctrl_send_status(), and usbd_eptn_handler().

◆ usbd_get_recv_len()

uint32_t usbd_get_recv_len | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb endpoint get receive data length

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 392 of file usbd_core.c.

Referenced by bot_cbw_decode(), class_ept0_rx_handler(), and class_out_handler().

◆ usbd_remote_wakeup()

void usbd_remote_wakeup ( usbd_core_type * udev )

usb device remote wakeup

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 600 of file usbd_core.c.

Referenced by main().

◆ usbd_set_device_addr()

void usbd_set_device_addr | ( | usbd_core_type * | udev,
 |  | uint8_t | address
 | ) |  |

usb device set device address.

Parameters
udev | to the structure of usbd_core_type
address | host assignment address
Return values
none

Definition at line 580 of file usbd_core.c.

◆ usbd_set_stall()

void usbd_set_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb set endpoint to stall.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 259 of file usbd_core.c.

Referenced by bot_scsi_clear_feature(), bot_scsi_stall(), usbd_ctrl_unsupport(), and usbd_endpoint_request().


AT32F413 Firmwary Library: USBD_drivers_interrupt

Modules
USBD_drivers_interrupt
AT32F413_middlewares_usbd_drivers

usb device interrupt More...

Modules

USBD_int_exported_functions
USBD_int_private_functions

Detailed Description

usb device interrupt


AT32F413 Firmwary Library: USBD_int_exported_functions

Functions
USBD_int_exported_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_interrupt

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

Function Documentation

◆ usbd_ept_loop_handler()

void usbd_ept_loop_handler ( usbd_core_type * udev )

usb device endpoint loop handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 222 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_eptn_handler()

void usbd_eptn_handler | ( | usbd_core_type * | udev,
 |  | usb_ept_number_type | ept_num
 | ) |  |

usb device endpoint request handler.

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 109 of file usbd_int.c.

Referenced by usbd_ept_loop_handler().

◆ usbd_irq_handler()

void usbd_irq_handler ( usbd_core_type * udev )

usb device interrput request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 44 of file usbd_int.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ usbd_reset_handler()

void usbd_reset_handler ( usbd_core_type * udev )

usb device reset interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 242 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_sof_handler()

void usbd_sof_handler ( usbd_core_type * udev )

usb device sof interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 275 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_suspend_handler()

void usbd_suspend_handler ( usbd_core_type * udev )

usb device suspend interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 287 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_wakeup_handler()

void usbd_wakeup_handler ( usbd_core_type * udev )

usb device wakup interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 308 of file usbd_int.c.

Referenced by usbd_irq_handler().


AT32F413 Firmwary Library: USBD_int_private_functions

Functions
USBD_int_private_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_interrupt

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

Function Documentation

◆ usbd_ept_loop_handler()

void usbd_ept_loop_handler ( usbd_core_type * udev )

usb device endpoint loop handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 222 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_eptn_handler()

void usbd_eptn_handler | ( | usbd_core_type * | udev,
 |  | usb_ept_number_type | ept_num
 | ) |  |

usb device endpoint request handler.

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 109 of file usbd_int.c.

Referenced by usbd_ept_loop_handler().

◆ usbd_irq_handler()

void usbd_irq_handler ( usbd_core_type * udev )

usb device interrput request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 44 of file usbd_int.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ usbd_reset_handler()

void usbd_reset_handler ( usbd_core_type * udev )

usb device reset interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 242 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_sof_handler()

void usbd_sof_handler ( usbd_core_type * udev )

usb device sof interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 275 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_suspend_handler()

void usbd_suspend_handler ( usbd_core_type * udev )

usb device suspend interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 287 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_wakeup_handler()

void usbd_wakeup_handler ( usbd_core_type * udev )

usb device wakup interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 308 of file usbd_int.c.

Referenced by usbd_irq_handler().


AT32F413 Firmwary Library: USBD_drivers_standard_request

Modules
USBD_drivers_standard_request
AT32F413_middlewares_usbd_drivers

usb device standard_request More...

Modules

USBD_sdr_exported_functions
USBD_sdr_private_functions

Detailed Description

usb device standard_request


AT32F413 Firmwary Library: USBD_sdr_exported_functions

Functions
USBD_sdr_exported_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_standard_request

Functions

void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

Function Documentation

◆ usbd_device_request()

usb_sts_type usbd_device_request ( usbd_core_type * udev )

standard usb device requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 348 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_endpoint_request()

usb_sts_type usbd_endpoint_request ( usbd_core_type * udev )

standard usb endpoint requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 419 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_interface_request()

usb_sts_type usbd_interface_request ( usbd_core_type * udev )

standard usb interface requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 392 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_setup_request_parse()

void usbd_setup_request_parse | ( | usb_setup_type * | setup,
 |  | uint8_t * | buf
 | ) |  |

usb parse standard setup request

Parameters
setup | setup structure
buf | setup buffer
Return values
none

Definition at line 53 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().


AT32F413 Firmwary Library: USBD_sdr_private_functions

Functions
USBD_sdr_private_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_standard_request

Functions

static usb_sts_type | usbd_get_descriptor (usbd_core_type *udev)
get usb standard device description request More...
static usb_sts_type | usbd_set_address (usbd_core_type *udev)
this request sets the device address More...
static usb_sts_type | usbd_get_status (usbd_core_type *udev)
get usb status request More...
static usb_sts_type | usbd_clear_feature (usbd_core_type *udev)
clear usb feature request More...
static usb_sts_type | usbd_set_feature (usbd_core_type *udev)
set usb feature request More...
static usb_sts_type | usbd_get_configuration (usbd_core_type *udev)
get usb configuration request More...
static usb_sts_type | usbd_set_configuration (usbd_core_type *udev)
sets the usb device configuration request More...
void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

Function Documentation

◆ usbd_clear_feature()

static usb_sts_type usbd_clear_feature ( usbd_core_type * udev )
static

clear usb feature request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 208 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_device_request()

usb_sts_type usbd_device_request ( usbd_core_type * udev )

standard usb device requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 348 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_endpoint_request()

usb_sts_type usbd_endpoint_request ( usbd_core_type * udev )

standard usb endpoint requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 419 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_get_configuration()

static usb_sts_type usbd_get_configuration ( usbd_core_type * udev )
static

get usb configuration request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 254 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_get_descriptor()

static usb_sts_type usbd_get_descriptor ( usbd_core_type * udev )
static

get usb standard device description request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 67 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_get_status()

static usb_sts_type usbd_get_status ( usbd_core_type * udev )
static

get usb status request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 183 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_interface_request()

usb_sts_type usbd_interface_request ( usbd_core_type * udev )

standard usb interface requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 392 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_set_address()

static usb_sts_type usbd_set_address ( usbd_core_type * udev )
static

this request sets the device address

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 137 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_set_configuration()

static usb_sts_type usbd_set_configuration ( usbd_core_type * udev )
static

sets the usb device configuration request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 286 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_set_feature()

static usb_sts_type usbd_set_feature ( usbd_core_type * udev )
static

set usb feature request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 236 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_setup_request_parse()

void usbd_setup_request_parse | ( | usb_setup_type * | setup,
 |  | uint8_t * | buf
 | ) |  |

usb parse standard setup request

Parameters
setup | setup structure
buf | setup buffer
Return values
none

Definition at line 53 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().


AT32F413 Firmwary Library: USB_standard

Modules
USB_standard
AT32F413_middlewares_usbd_drivers

Modules

USB_standard_define
USB_standard_exported_types

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: USB_standard_define

Data Structures | Macros | Enumerations
USB_standard_define
AT32F413_middlewares_usbd_drivers » USB_standard

Data Structures

struct linecoding_type
usb cdc class set line coding struct More...

Macros

#define | USB_REQ_RECIPIENT_DEVICE 0x00
usb request recipient More...
#define | USB_REQ_RECIPIENT_INTERFACE 0x01
#define | USB_REQ_RECIPIENT_ENDPOINT 0x02
#define | USB_REQ_RECIPIENT_OTHER 0x03
#define | USB_REQ_RECIPIENT_MASK 0x1F
#define | USB_REQ_TYPE_STANDARD 0x00
usb request type More...
#define | USB_REQ_TYPE_CLASS 0x20
#define | USB_REQ_TYPE_VENDOR 0x40
#define | USB_REQ_TYPE_RESERVED 0x60
#define | USB_REQ_DIR_HTD 0x00
usb request data transfer direction More...
#define | USB_REQ_DIR_DTH 0x80
#define | USB_STD_REQ_GET_STATUS 0
usb standard device requests codes More...
#define | USB_STD_REQ_CLEAR_FEATURE 1
#define | USB_STD_REQ_SET_FEATURE 3
#define | USB_STD_REQ_SET_ADDRESS 5
#define | USB_STD_REQ_GET_DESCRIPTOR 6
#define | USB_STD_REQ_SET_DESCRIPTOR 7
#define | USB_STD_REQ_GET_CONFIGURATION 8
#define | USB_STD_REQ_SET_CONFIGURATION 9
#define | USB_STD_REQ_GET_INTERFACE 10
#define | USB_STD_REQ_SET_INTERFACE 11
#define | USB_STD_REQ_SYNCH_FRAME 12
#define | USB_DESCIPTOR_TYPE_DEVICE 1
usb standard device type More...
#define | USB_DESCIPTOR_TYPE_CONFIGURATION 2
#define | USB_DESCIPTOR_TYPE_STRING 3
#define | USB_DESCIPTOR_TYPE_INTERFACE 4
#define | USB_DESCIPTOR_TYPE_ENDPOINT 5
#define | USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
#define | USB_DESCIPTOR_TYPE_OTHER_SPEED 7
#define | USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
#define | USB_LANGID_STRING 0
usb standard string type More...
#define | USB_MFC_STRING 1
#define | USB_PRODUCT_STRING 2
#define | USB_SERIAL_STRING 3
#define | USB_CONFIG_STRING 4
#define | USB_INTERFACE_STRING 5
#define | USB_CONF_REMOTE_WAKEUP 2
usb configuration attributes More...
#define | USB_CONF_SELF_POWERED 1
#define | USB_FEATURE_EPT_HALT 0
usb standard feature selectors More...
#define | USB_FEATURE_REMOTE_WAKEUP 1
#define | USB_FEATURE_TEST_MODE 2
#define | USB_EPT0_IDLE 0
endpoint 0 state More...
#define | USB_EPT0_SETUP 1
#define | USB_EPT0_DATA_IN 2
#define | USB_EPT0_DATA_OUT 3
#define | USB_EPT0_STATUS_IN 4
#define | USB_EPT0_STATUS_OUT 5
#define | USB_EPT0_STALL 6
#define | USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
usb descriptor length More...
#define | USB_DEVICE_DESC_LEN 0x12
#define | USB_DEVICE_CFG_DESC_LEN 0x09
#define | USB_DEVICE_IF_DESC_LEN 0x09
#define | USB_DEVICE_EPT_LEN 0x07
#define | USB_DEVICE_OTG_DESC_LEN 0x03
#define | USB_DEVICE_LANGID_STR_DESC_LEN 0x04
#define | USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
#define | USB_CLASS_CODE_AUDIO 0x01
usb class code More...
#define | USB_CLASS_CODE_CDC 0x02
#define | USB_CLASS_CODE_HID 0x03
#define | USB_CLASS_CODE_PRINTER 0x07
#define | USB_CLASS_CODE_MSC 0x08
#define | USB_CLASS_CODE_HUB 0x09
#define | USB_CLASS_CODE_CDCDATA 0x0A
#define | USB_CLASS_CODE_CCID 0x0B
#define | USB_CLASS_CODE_VIDEO 0x0E
#define | USB_CLASS_CODE_VENDOR 0xFF
#define | USB_EPT_DESC_CONTROL 0x00
usb endpoint type More...
#define | USB_EPT_DESC_ISO 0x01
#define | USB_EPT_DESC_BULK 0x02
#define | USB_EPT_DESC_INTERRUPT 0x03
#define | USB_EPT_DESC_NSYNC 0x00
#define | USB_ETP_DESC_ASYNC 0x04
#define | USB_ETP_DESC_ADAPTIVE 0x08
#define | USB_ETP_DESC_SYNC 0x0C
#define | USB_EPT_DESC_DATA_EPT 0x00
#define | USB_EPT_DESC_FD_EPT 0x10
#define | USB_EPT_DESC_FDDATA_EPT 0x20
#define | USBD_CDC_CS_INTERFACE 0x24
usb cdc class descriptor define More...
#define | USBD_CDC_CS_ENDPOINT 0x25
#define | USBD_CDC_SUBTYPE_HEADER 0x00
usb cdc class sub-type define More...
#define | USBD_CDC_SUBTYPE_CMF 0x01
#define | USBD_CDC_SUBTYPE_ACM 0x02
#define | USBD_CDC_SUBTYPE_UFD 0x06
#define | SET_LINE_CODING 0x20
usb cdc class request code define More...
#define | GET_LINE_CODING 0x21
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REQ_SET_PROTOCOL 0x0B
usb hid class request code define More...
#define | HID_REQ_GET_PROTOCOL 0x03
#define | HID_REQ_SET_IDLE 0x0A
#define | HID_REQ_GET_IDLE 0x02
#define | HID_REQ_SET_REPORT 0x09
#define | HID_REQ_GET_REPORT 0x01
#define | HID_DESCRIPTOR_TYPE 0x21
#define | HID_REPORT_DESC 0x22
#define | USB_MAX_EP0_SIZE 64
endpoint 0 max size More...
#define | SWAPBYTE(addr)
usb swap address More...
#define | MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
min and max define More...
#define | MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
#define | LBYTE(x) ((uint8_t)(x & 0x00FF))
low byte and high byte define More...
#define | HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))

Enumerations

enum usbd_conn_state { USB_CONN_STATE_DEFAULT =1 , USB_CONN_STATE_ADDRESSED , USB_CONN_STATE_CONFIGURED , USB_CONN_STATE_SUSPENDED }
usb device connect state More...

Detailed Description

Macro Definition Documentation

◆ GET_LINE_CODING

#define GET_LINE_CODING 0x21

Definition at line 205 of file usb_std.h.

◆ HBYTE

#define HBYTE ( x ) ((uint8_t)((x & 0xFF00) >>8))

high byte define

Definition at line 264 of file usb_std.h.

◆ HID_CLASS_DESC_HID

#define HID_CLASS_DESC_HID 0x21

usb hid class descriptor define

Definition at line 221 of file usb_std.h.

◆ HID_CLASS_DESC_PHYSICAL

#define HID_CLASS_DESC_PHYSICAL 0x23

Definition at line 223 of file usb_std.h.

◆ HID_CLASS_DESC_REPORT

#define HID_CLASS_DESC_REPORT 0x22

Definition at line 222 of file usb_std.h.

◆ HID_DESCRIPTOR_TYPE

#define HID_DESCRIPTOR_TYPE 0x21

Definition at line 234 of file usb_std.h.

◆ HID_REPORT_DESC

#define HID_REPORT_DESC 0x22

Definition at line 235 of file usb_std.h.

◆ HID_REQ_GET_IDLE

#define HID_REQ_GET_IDLE 0x02

Definition at line 231 of file usb_std.h.

◆ HID_REQ_GET_PROTOCOL

#define HID_REQ_GET_PROTOCOL 0x03

Definition at line 229 of file usb_std.h.

◆ HID_REQ_GET_REPORT

#define HID_REQ_GET_REPORT 0x01

Definition at line 233 of file usb_std.h.

◆ HID_REQ_SET_IDLE

#define HID_REQ_SET_IDLE 0x0A

Definition at line 230 of file usb_std.h.

◆ HID_REQ_SET_PROTOCOL

#define HID_REQ_SET_PROTOCOL 0x0B

usb hid class request code define

Definition at line 228 of file usb_std.h.

◆ HID_REQ_SET_REPORT

#define HID_REQ_SET_REPORT 0x09

Definition at line 232 of file usb_std.h.

◆ LBYTE

#define LBYTE ( x ) ((uint8_t)(x & 0x00FF))

low byte and high byte define

low byte define

Definition at line 263 of file usb_std.h.

◆ MAX

#define MAX | ( | a,
 |  | b
 | ) | (uint16_t)(((a) > (b)) ? (a) : (b))

max define

Definition at line 257 of file usb_std.h.

◆ MIN

#define MIN | ( | a,
 |  | b
 | ) | (uint16_t)(((a) < (b)) ? (a) : (b))

min and max define

min define

Definition at line 253 of file usb_std.h.

◆ SET_LINE_CODING

#define SET_LINE_CODING 0x20

usb cdc class request code define

Definition at line 204 of file usb_std.h.

◆ SWAPBYTE

#define SWAPBYTE ( addr )
Value:
(uint16_t)(((uint16_t)(*((uint8_t *)(addr)))) + \
(((uint16_t)(*(((uint8_t *)(addr)) + 1))) << 8))

usb swap address

swap address

Definition at line 247 of file usb_std.h.

◆ USB_CLASS_CODE_AUDIO

#define USB_CLASS_CODE_AUDIO 0x01

usb class code

usb class code audio

Definition at line 159 of file usb_std.h.

◆ USB_CLASS_CODE_CCID

#define USB_CLASS_CODE_CCID 0x0B

usb class code ccid

Definition at line 166 of file usb_std.h.

◆ USB_CLASS_CODE_CDC

#define USB_CLASS_CODE_CDC 0x02

usb class code cdc

Definition at line 160 of file usb_std.h.

◆ USB_CLASS_CODE_CDCDATA

#define USB_CLASS_CODE_CDCDATA 0x0A

usb class code cdc data

Definition at line 165 of file usb_std.h.

◆ USB_CLASS_CODE_HID

#define USB_CLASS_CODE_HID 0x03

usb class code hid

Definition at line 161 of file usb_std.h.

◆ USB_CLASS_CODE_HUB

#define USB_CLASS_CODE_HUB 0x09

usb class code hub

Definition at line 164 of file usb_std.h.

◆ USB_CLASS_CODE_MSC

#define USB_CLASS_CODE_MSC 0x08

usb class code msc

Definition at line 163 of file usb_std.h.

◆ USB_CLASS_CODE_PRINTER

#define USB_CLASS_CODE_PRINTER 0x07

usb class code printer

Definition at line 162 of file usb_std.h.

◆ USB_CLASS_CODE_VENDOR

#define USB_CLASS_CODE_VENDOR 0xFF

usb class code vendor

Definition at line 168 of file usb_std.h.

◆ USB_CLASS_CODE_VIDEO

#define USB_CLASS_CODE_VIDEO 0x0E

usb class code video

Definition at line 167 of file usb_std.h.

◆ USB_CONF_REMOTE_WAKEUP

#define USB_CONF_REMOTE_WAKEUP 2

usb configuration attributes

usb configuration attributes remote wakeup

Definition at line 112 of file usb_std.h.

◆ USB_CONF_SELF_POWERED

#define USB_CONF_SELF_POWERED 1

usb configuration attributes self powered

Definition at line 113 of file usb_std.h.

◆ USB_CONFIG_STRING

#define USB_CONFIG_STRING 4

usb standard string type config

Definition at line 106 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_CONFIGURATION

#define USB_DESCIPTOR_TYPE_CONFIGURATION 2

usb standard device type configuration

Definition at line 91 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_DEVICE

#define USB_DESCIPTOR_TYPE_DEVICE 1

usb standard device type

usb standard device type device

Definition at line 90 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER

#define USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6

usb standard device type qualifier

Definition at line 95 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_ENDPOINT

#define USB_DESCIPTOR_TYPE_ENDPOINT 5

usb standard device type endpoint

Definition at line 94 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_INTERFACE

#define USB_DESCIPTOR_TYPE_INTERFACE 4

usb standard device type interface

Definition at line 93 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_INTERFACE_POWER

#define USB_DESCIPTOR_TYPE_INTERFACE_POWER 8

usb standard device type interface power

Definition at line 97 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_OTHER_SPEED

#define USB_DESCIPTOR_TYPE_OTHER_SPEED 7

usb standard device type other speed

Definition at line 96 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_STRING

#define USB_DESCIPTOR_TYPE_STRING 3

usb standard device type string

Definition at line 92 of file usb_std.h.

◆ USB_DEVICE_CFG_DESC_LEN

#define USB_DEVICE_CFG_DESC_LEN 0x09

usb configuration descriptor length

Definition at line 149 of file usb_std.h.

◆ USB_DEVICE_DESC_LEN

#define USB_DEVICE_DESC_LEN 0x12

usb device descriptor length

Definition at line 148 of file usb_std.h.

◆ USB_DEVICE_EPT_LEN

#define USB_DEVICE_EPT_LEN 0x07

usb endpoint descriptor length

Definition at line 151 of file usb_std.h.

◆ USB_DEVICE_IF_DESC_LEN

#define USB_DEVICE_IF_DESC_LEN 0x09

usb interface descriptor length

Definition at line 150 of file usb_std.h.

◆ USB_DEVICE_LANGID_STR_DESC_LEN

#define USB_DEVICE_LANGID_STR_DESC_LEN 0x04

usb lang id string descriptor length

Definition at line 153 of file usb_std.h.

◆ USB_DEVICE_OTG_DESC_LEN

#define USB_DEVICE_OTG_DESC_LEN 0x03

usb otg descriptor length

Definition at line 152 of file usb_std.h.

◆ USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN

#define USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09

usb other speed descriptor length

Definition at line 154 of file usb_std.h.

◆ USB_DEVICE_QUALIFIER_DESC_LEN

#define USB_DEVICE_QUALIFIER_DESC_LEN 0x0A

usb descriptor length

usb qualifier descriptor length

Definition at line 147 of file usb_std.h.

◆ USB_EPT0_DATA_IN

#define USB_EPT0_DATA_IN 2

usb endpoint state data in

Definition at line 138 of file usb_std.h.

◆ USB_EPT0_DATA_OUT

#define USB_EPT0_DATA_OUT 3

usb endpoint state data out

Definition at line 139 of file usb_std.h.

◆ USB_EPT0_IDLE

#define USB_EPT0_IDLE 0

endpoint 0 state

usb endpoint state idle

Definition at line 136 of file usb_std.h.

◆ USB_EPT0_SETUP

#define USB_EPT0_SETUP 1

usb endpoint state setup

Definition at line 137 of file usb_std.h.

◆ USB_EPT0_STALL

#define USB_EPT0_STALL 6

usb endpoint state stall

Definition at line 142 of file usb_std.h.

◆ USB_EPT0_STATUS_IN

#define USB_EPT0_STATUS_IN 4

usb endpoint state status in

Definition at line 140 of file usb_std.h.

◆ USB_EPT0_STATUS_OUT

#define USB_EPT0_STATUS_OUT 5

usb endpoint state status out

Definition at line 141 of file usb_std.h.

◆ USB_EPT_DESC_BULK

#define USB_EPT_DESC_BULK 0x02

usb endpoint description type bulk

Definition at line 175 of file usb_std.h.

◆ USB_EPT_DESC_CONTROL

#define USB_EPT_DESC_CONTROL 0x00

usb endpoint type

usb endpoint description type control

Definition at line 173 of file usb_std.h.

◆ USB_EPT_DESC_DATA_EPT

#define USB_EPT_DESC_DATA_EPT 0x00

usb endpoint description data

Definition at line 183 of file usb_std.h.

◆ USB_EPT_DESC_FD_EPT

#define USB_EPT_DESC_FD_EPT 0x10

usb endpoint description fd

Definition at line 184 of file usb_std.h.

◆ USB_EPT_DESC_FDDATA_EPT

#define USB_EPT_DESC_FDDATA_EPT 0x20

usb endpoint description fddata

Definition at line 185 of file usb_std.h.

◆ USB_EPT_DESC_INTERRUPT

#define USB_EPT_DESC_INTERRUPT 0x03

usb endpoint description type interrupt

Definition at line 176 of file usb_std.h.

◆ USB_EPT_DESC_ISO

#define USB_EPT_DESC_ISO 0x01

usb endpoint description type iso

Definition at line 174 of file usb_std.h.

◆ USB_EPT_DESC_NSYNC

#define USB_EPT_DESC_NSYNC 0x00

usb endpoint description nsync

Definition at line 178 of file usb_std.h.

◆ USB_ETP_DESC_ADAPTIVE

#define USB_ETP_DESC_ADAPTIVE 0x08

usb endpoint description adaptive

Definition at line 180 of file usb_std.h.

◆ USB_ETP_DESC_ASYNC

#define USB_ETP_DESC_ASYNC 0x04

usb endpoint description async

Definition at line 179 of file usb_std.h.

◆ USB_ETP_DESC_SYNC

#define USB_ETP_DESC_SYNC 0x0C

usb endpoint description sync

Definition at line 181 of file usb_std.h.

◆ USB_FEATURE_EPT_HALT

#define USB_FEATURE_EPT_HALT 0

usb standard feature selectors

usb standard feature selectors endpoint halt

Definition at line 118 of file usb_std.h.

◆ USB_FEATURE_REMOTE_WAKEUP

#define USB_FEATURE_REMOTE_WAKEUP 1

usb standard feature selectors remote wakeup

Definition at line 119 of file usb_std.h.

◆ USB_FEATURE_TEST_MODE

#define USB_FEATURE_TEST_MODE 2

usb standard feature selectors test mode

Definition at line 120 of file usb_std.h.

◆ USB_INTERFACE_STRING

#define USB_INTERFACE_STRING 5

usb standard string type interface

Definition at line 107 of file usb_std.h.

◆ USB_LANGID_STRING

#define USB_LANGID_STRING 0

usb standard string type

usb standard string type lang id

Definition at line 102 of file usb_std.h.

◆ USB_MAX_EP0_SIZE

#define USB_MAX_EP0_SIZE 64

endpoint 0 max size

usb endpoint 0 max size

Definition at line 240 of file usb_std.h.

◆ USB_MFC_STRING

#define USB_MFC_STRING 1

usb standard string type mfc

Definition at line 103 of file usb_std.h.

◆ USB_PRODUCT_STRING

#define USB_PRODUCT_STRING 2

usb standard string type product

Definition at line 104 of file usb_std.h.

◆ USB_REQ_DIR_DTH

#define USB_REQ_DIR_DTH 0x80

usb request data transfer direction device to host

Definition at line 70 of file usb_std.h.

◆ USB_REQ_DIR_HTD

#define USB_REQ_DIR_HTD 0x00

usb request data transfer direction

usb request data transfer direction host to device

Definition at line 69 of file usb_std.h.

◆ USB_REQ_RECIPIENT_DEVICE

#define USB_REQ_RECIPIENT_DEVICE 0x00

usb request recipient

usb request recipient device

Definition at line 52 of file usb_std.h.

◆ USB_REQ_RECIPIENT_ENDPOINT

#define USB_REQ_RECIPIENT_ENDPOINT 0x02

usb request recipient endpoint

Definition at line 54 of file usb_std.h.

◆ USB_REQ_RECIPIENT_INTERFACE

#define USB_REQ_RECIPIENT_INTERFACE 0x01

usb request recipient interface

Definition at line 53 of file usb_std.h.

◆ USB_REQ_RECIPIENT_MASK

#define USB_REQ_RECIPIENT_MASK 0x1F

usb request recipient mask

Definition at line 56 of file usb_std.h.

◆ USB_REQ_RECIPIENT_OTHER

#define USB_REQ_RECIPIENT_OTHER 0x03

usb request recipient other

Definition at line 55 of file usb_std.h.

◆ USB_REQ_TYPE_CLASS

#define USB_REQ_TYPE_CLASS 0x20

usb request type class

Definition at line 62 of file usb_std.h.

◆ USB_REQ_TYPE_RESERVED

#define USB_REQ_TYPE_RESERVED 0x60

usb request type reserved

Definition at line 64 of file usb_std.h.

◆ USB_REQ_TYPE_STANDARD

#define USB_REQ_TYPE_STANDARD 0x00

usb request type

usb request type standard

Definition at line 61 of file usb_std.h.

◆ USB_REQ_TYPE_VENDOR

#define USB_REQ_TYPE_VENDOR 0x40

usb request type vendor

Definition at line 63 of file usb_std.h.

◆ USB_SERIAL_STRING

#define USB_SERIAL_STRING 3

usb standard string type serial

Definition at line 105 of file usb_std.h.

◆ USB_STD_REQ_CLEAR_FEATURE

#define USB_STD_REQ_CLEAR_FEATURE 1

usb request code clear feature

Definition at line 76 of file usb_std.h.

◆ USB_STD_REQ_GET_CONFIGURATION

#define USB_STD_REQ_GET_CONFIGURATION 8

usb request code get configuration

Definition at line 81 of file usb_std.h.

◆ USB_STD_REQ_GET_DESCRIPTOR

#define USB_STD_REQ_GET_DESCRIPTOR 6

usb request code get descriptor

Definition at line 79 of file usb_std.h.

◆ USB_STD_REQ_GET_INTERFACE

#define USB_STD_REQ_GET_INTERFACE 10

usb request code get interface

Definition at line 83 of file usb_std.h.

◆ USB_STD_REQ_GET_STATUS

#define USB_STD_REQ_GET_STATUS 0

usb standard device requests codes

usb request code status

Definition at line 75 of file usb_std.h.

◆ USB_STD_REQ_SET_ADDRESS

#define USB_STD_REQ_SET_ADDRESS 5

usb request code address

Definition at line 78 of file usb_std.h.

◆ USB_STD_REQ_SET_CONFIGURATION

#define USB_STD_REQ_SET_CONFIGURATION 9

usb request code set configuration

Definition at line 82 of file usb_std.h.

◆ USB_STD_REQ_SET_DESCRIPTOR

#define USB_STD_REQ_SET_DESCRIPTOR 7

usb request code set descriptor

Definition at line 80 of file usb_std.h.

◆ USB_STD_REQ_SET_FEATURE

#define USB_STD_REQ_SET_FEATURE 3

usb request code feature

Definition at line 77 of file usb_std.h.

◆ USB_STD_REQ_SET_INTERFACE

#define USB_STD_REQ_SET_INTERFACE 11

usb request code set interface

Definition at line 84 of file usb_std.h.

◆ USB_STD_REQ_SYNCH_FRAME

#define USB_STD_REQ_SYNCH_FRAME 12

usb request code synch frame

Definition at line 85 of file usb_std.h.

◆ USBD_CDC_CS_ENDPOINT

#define USBD_CDC_CS_ENDPOINT 0x25

Definition at line 191 of file usb_std.h.

◆ USBD_CDC_CS_INTERFACE

#define USBD_CDC_CS_INTERFACE 0x24

usb cdc class descriptor define

Definition at line 190 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_ACM

#define USBD_CDC_SUBTYPE_ACM 0x02

Definition at line 198 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_CMF

#define USBD_CDC_SUBTYPE_CMF 0x01

Definition at line 197 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_HEADER

#define USBD_CDC_SUBTYPE_HEADER 0x00

usb cdc class sub-type define

Definition at line 196 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_UFD

#define USBD_CDC_SUBTYPE_UFD 0x06

Definition at line 199 of file usb_std.h.

Enumeration Type Documentation

◆ usbd_conn_state

enum usbd_conn_state

usb device connect state

Enumerator
USB_CONN_STATE_DEFAULT | usb device connect state default
USB_CONN_STATE_ADDRESSED | usb device connect state address
USB_CONN_STATE_CONFIGURED | usb device connect state configured
USB_CONN_STATE_SUSPENDED | usb device connect state suspend

Definition at line 125 of file usb_std.h.


AT32F413 Firmwary Library: linecoding_type Struct Reference

Data Fields
linecoding_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_define

usb cdc class set line coding struct More...

#include <usb_std.h>

Data Fields

uint32_t | bitrate
uint8_t | format
uint8_t | parity
uint8_t | data

Detailed Description

usb cdc class set line coding struct

Definition at line 210 of file usb_std.h.

Field Documentation

◆ bitrate

uint32_t linecoding_type::bitrate

Definition at line 212 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ data

uint8_t linecoding_type::data

Definition at line 215 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ format

uint8_t linecoding_type::format

Definition at line 213 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ parity

uint8_t linecoding_type::parity

Definition at line 214 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: USB_standard_exported_types

Data Structures | Enumerations
USB_standard_exported_types
AT32F413_middlewares_usbd_drivers » USB_standard

Data Structures

struct | usb_setup_type
format of usb setup data More...
struct | usb_device_desc_type
format of standard device descriptor More...
struct | usb_configuration_desc_type
format of standard configuration descriptor More...
struct | usb_interface_desc_type
format of standard interface descriptor More...
struct | usb_endpoint_desc_type
format of standard endpoint descriptor More...
struct | usb_header_desc_type
format of header More...

Enumerations

enum usb_sts_type {
USB_OK , USB_FAIL , USB_WAIT , USB_NOT_SUPPORT ,
USB_ERROR
}
usb return status More...

Detailed Description

Enumeration Type Documentation

◆ usb_sts_type

enum usb_sts_type

usb return status

Enumerator
USB_OK | usb status ok
USB_FAIL | usb status fail
USB_WAIT | usb status wait
USB_NOT_SUPPORT | usb status not support
USB_ERROR | usb status error

Definition at line 277 of file usb_std.h.


AT32F413 Firmwary Library: usb_setup_type Struct Reference

Data Fields
usb_setup_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of usb setup data More...

#include <usb_std.h>

Data Fields

uint8_t | bmRequestType
uint8_t | bRequest
uint16_t | wValue
uint16_t | wIndex
uint16_t | wLength

Detailed Description

format of usb setup data

Definition at line 289 of file usb_std.h.

Field Documentation

◆ bmRequestType

uint8_t usb_setup_type::bmRequestType

characteristics of request

Definition at line 291 of file usb_std.h.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_core_setup_handler(), usbd_device_request(), usbd_endpoint_request(), and usbd_setup_request_parse().

◆ bRequest

uint8_t usb_setup_type::bRequest

specific request

Definition at line 292 of file usb_std.h.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_device_request(), usbd_endpoint_request(), and usbd_setup_request_parse().

◆ wIndex

uint16_t usb_setup_type::wIndex

word-sized field that varies according to request typically used to pass an index or offset

Definition at line 294 of file usb_std.h.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), audio_set_interface(), class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_set_address(), usbd_set_configuration(), and usbd_setup_request_parse().

◆ wLength

uint16_t usb_setup_type::wLength

number of bytes to transfer if there is a data stage

Definition at line 296 of file usb_std.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), usbd_core_setup_handler(), usbd_get_configuration(), usbd_get_descriptor(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_setup_request_parse().

◆ wValue

uint16_t usb_setup_type::wValue

word-sized field that varies according to request

Definition at line 293 of file usb_std.h.

Referenced by audio_req_get_cur(), audio_req_set_cur(), audio_set_interface(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_endpoint_request(), usbd_get_descriptor(), usbd_set_address(), usbd_set_configuration(), usbd_set_feature(), and usbd_setup_request_parse().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_device_desc_type Struct Reference

Data Fields
usb_device_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard device descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint16_t | bcdUSB
uint8_t | bDeviceClass
uint8_t | bDeviceSubClass
uint8_t | bDeviceProtocol
uint8_t | bMaxPacketSize0
uint16_t | idVendor
uint16_t | idProduct
uint16_t | bcdDevice
uint8_t | iManufacturer
uint8_t | iProduct
uint8_t | iSerialNumber
uint8_t | bNumConfigurations

Detailed Description

format of standard device descriptor

Definition at line 302 of file usb_std.h.

Field Documentation

◆ bcdDevice

uint16_t usb_device_desc_type::bcdDevice

device release number in binary-coded decimal

Definition at line 313 of file usb_std.h.

◆ bcdUSB

uint16_t usb_device_desc_type::bcdUSB

usb specification release number

Definition at line 306 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_device_desc_type::bDescriptorType

device descriptor type

Definition at line 305 of file usb_std.h.

◆ bDeviceClass

uint8_t usb_device_desc_type::bDeviceClass

class code (assigned by the usb-if)

Definition at line 307 of file usb_std.h.

◆ bDeviceProtocol

uint8_t usb_device_desc_type::bDeviceProtocol

protocol code ((assigned by the usb-if))

Definition at line 309 of file usb_std.h.

◆ bDeviceSubClass

uint8_t usb_device_desc_type::bDeviceSubClass

subclass code (assigned by the usb-if)

Definition at line 308 of file usb_std.h.

◆ bLength

uint8_t usb_device_desc_type::bLength

size of this descriptor in bytes

Definition at line 304 of file usb_std.h.

◆ bMaxPacketSize0

uint8_t usb_device_desc_type::bMaxPacketSize0

maximum packet size for endpoint zero

Definition at line 310 of file usb_std.h.

◆ bNumConfigurations

uint8_t usb_device_desc_type::bNumConfigurations

number of possible configurations

Definition at line 317 of file usb_std.h.

◆ idProduct

uint16_t usb_device_desc_type::idProduct

product id ((assigned by the usb-if))

Definition at line 312 of file usb_std.h.

◆ idVendor

uint16_t usb_device_desc_type::idVendor

verndor id ((assigned by the usb-if))

Definition at line 311 of file usb_std.h.

◆ iManufacturer

uint8_t usb_device_desc_type::iManufacturer

index of string descriptor describing manufacturer

Definition at line 314 of file usb_std.h.

◆ iProduct

uint8_t usb_device_desc_type::iProduct

index of string descriptor describing product

Definition at line 315 of file usb_std.h.

◆ iSerialNumber

uint8_t usb_device_desc_type::iSerialNumber

index of string descriptor describing serial number

Definition at line 316 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_configuration_desc_type Struct Reference

Data Fields
usb_configuration_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard configuration descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint16_t | wTotalLength
uint8_t | bNumInterfaces
uint8_t | bConfigurationValue
uint8_t | iConfiguration
uint8_t | bmAttributes
uint8_t | bMaxPower

Detailed Description

format of standard configuration descriptor

Definition at line 323 of file usb_std.h.

Field Documentation

◆ bConfigurationValue

uint8_t usb_configuration_desc_type::bConfigurationValue

value to use as an argument to the SetConfiguration() request

Definition at line 329 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_configuration_desc_type::bDescriptorType

configuration descriptor type

Definition at line 326 of file usb_std.h.

◆ bLength

uint8_t usb_configuration_desc_type::bLength

size of this descriptor in bytes

Definition at line 325 of file usb_std.h.

◆ bmAttributes

uint8_t usb_configuration_desc_type::bmAttributes

configuration characteristics D7 reserved D6 self-powered D5 remote wakeup D4~D0 reserved

Definition at line 331 of file usb_std.h.

◆ bMaxPower

uint8_t usb_configuration_desc_type::bMaxPower

maximum power consumption of the usb device from the bus

Definition at line 336 of file usb_std.h.

◆ bNumInterfaces

uint8_t usb_configuration_desc_type::bNumInterfaces

number of interfaces supported by this configuration

Definition at line 328 of file usb_std.h.

◆ iConfiguration

uint8_t usb_configuration_desc_type::iConfiguration

index of string descriptor describing this configuration

Definition at line 330 of file usb_std.h.

◆ wTotalLength

uint16_t usb_configuration_desc_type::wTotalLength

total length of data returned for this configuration

Definition at line 327 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_interface_desc_type Struct Reference

Data Fields
usb_interface_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard interface descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint8_t | bInterfaceNumber
uint8_t | bAlternateSetting
uint8_t | bNumEndpoints
uint8_t | bInterfaceClass
uint8_t | bInterfaceSubClass
uint8_t | bInterfaceProtocol
uint8_t | iInterface

Detailed Description

format of standard interface descriptor

Definition at line 344 of file usb_std.h.

Field Documentation

◆ bAlternateSetting

uint8_t usb_interface_desc_type::bAlternateSetting

value used to select this alternate setting for the interface

Definition at line 349 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_interface_desc_type::bDescriptorType

interface descriptor type

Definition at line 347 of file usb_std.h.

◆ bInterfaceClass

uint8_t usb_interface_desc_type::bInterfaceClass

class code (assigned by the usb-if)

Definition at line 351 of file usb_std.h.

◆ bInterfaceNumber

uint8_t usb_interface_desc_type::bInterfaceNumber

number of this interface

Definition at line 348 of file usb_std.h.

◆ bInterfaceProtocol

uint8_t usb_interface_desc_type::bInterfaceProtocol

protocol code (assigned by the usb-if)

Definition at line 353 of file usb_std.h.

◆ bInterfaceSubClass

uint8_t usb_interface_desc_type::bInterfaceSubClass

subclass code (assigned by the usb-if)

Definition at line 352 of file usb_std.h.

◆ bLength

uint8_t usb_interface_desc_type::bLength

size of this descriptor in bytes

Definition at line 346 of file usb_std.h.

◆ bNumEndpoints

uint8_t usb_interface_desc_type::bNumEndpoints

number of endpoints used by this interface

Definition at line 350 of file usb_std.h.

◆ iInterface

uint8_t usb_interface_desc_type::iInterface

index of string descriptor describing this interface

Definition at line 354 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_endpoint_desc_type Struct Reference

Data Fields
usb_endpoint_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard endpoint descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint8_t | bEndpointAddress
uint8_t | bmAttributes
uint16_t | wMaxPacketSize
uint8_t | bInterval

Detailed Description

format of standard endpoint descriptor

Definition at line 360 of file usb_std.h.

Field Documentation

◆ bDescriptorType

uint8_t usb_endpoint_desc_type::bDescriptorType

endpoint descriptor type

Definition at line 363 of file usb_std.h.

◆ bEndpointAddress

uint8_t usb_endpoint_desc_type::bEndpointAddress

the address of the endpoint on the usb device described by this descriptor

Definition at line 364 of file usb_std.h.

◆ bInterval

uint8_t usb_endpoint_desc_type::bInterval

interval for polling endpoint for data transfers

Definition at line 367 of file usb_std.h.

◆ bLength

uint8_t usb_endpoint_desc_type::bLength

size of this descriptor in bytes

Definition at line 362 of file usb_std.h.

◆ bmAttributes

uint8_t usb_endpoint_desc_type::bmAttributes

describes the endpoints attributes when it is configured using bConfiguration value

Definition at line 365 of file usb_std.h.

◆ wMaxPacketSize

uint16_t usb_endpoint_desc_type::wMaxPacketSize

maximum packet size this endpoint

Definition at line 366 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_header_desc_type Struct Reference

Data Fields
usb_header_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of header More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType

Detailed Description

format of header

Definition at line 373 of file usb_std.h.

Field Documentation

◆ bDescriptorType

uint8_t usb_header_desc_type::bDescriptorType

descriptor type

Definition at line 376 of file usb_std.h.

◆ bLength

uint8_t usb_header_desc_type::bLength

size of this descriptor in bytes

Definition at line 375 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: AT32F413_board

Modules
AT32F413_board

Modules

BOARD
onboard periph driver

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: BOARD

Modules | Macros | Functions | Variables
BOARD
AT32F413_board

onboard periph driver More...

Modules

BOARD_pins_definition
BOARD_exported_functions

Macros

#define | STEP_DELAY_MS 50
#define | PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Functions

int | fputc (int ch, FILE *f)
retargets the c library printf function to the usart. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...
void | at32_board_init ()
board initialize interface init led and button More...
void | at32_button_init (void)
configure button gpio More...
uint8_t | at32_button_state (void)
returns the selected button state More...
button_type at32_button_press ()
returns which button have press down More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | delay_init ()
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...

Variables

gpio_type * | led_gpio_port [3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}
uint16_t | led_gpio_pin [3] = {LED2_PIN, LED3_PIN, LED4_PIN}
crm_periph_clock_type | led_gpio_crm_clk [3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}
static __IO uint32_t | fac_us
static __IO uint32_t | fac_ms

Detailed Description

onboard periph driver

Macro Definition Documentation

◆ PUTCHAR_PROTOTYPE

#define PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Definition at line 84 of file at32f413_board.c.

◆ STEP_DELAY_MS

#define STEP_DELAY_MS 50

Definition at line 37 of file at32f413_board.c.

Function Documentation

◆ at32_board_init()

void at32_board_init ( void )

board initialize interface init led and button

Parameters
none
Return values
none

Definition at line 157 of file at32f413_board.c.

Referenced by main().

◆ at32_button_init()

void at32_button_init ( void )

configure button gpio

Parameters
button specifies the button to be configured.
Return values
none

< gpio pins number 0

Definition at line 179 of file at32f413_board.c.

Referenced by at32_board_init().

◆ at32_button_press()

button_type at32_button_press ( void )

returns which button have press down

Parameters
none
Return values
the button have press down

Definition at line 213 of file at32f413_board.c.

Referenced by main().

◆ at32_button_state()

uint8_t at32_button_state ( void )

returns the selected button state

Parameters
none
Return values
the button gpio pin value

< gpio pins number 0

Definition at line 203 of file at32f413_board.c.

Referenced by at32_button_press().

◆ at32_led_init()

void at32_led_init ( led_type led )

configure led gpio

Parameters
led specifies the led to be configured.
Return values
none

Definition at line 237 of file at32f413_board.c.

Referenced by at32_board_init(), and main().

◆ at32_led_off()

void at32_led_off ( led_type led )

turns selected led off.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 282 of file at32f413_board.c.

Referenced by at32_board_init(), main(), sd_test_error(), TAMPER_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_on()

void at32_led_on ( led_type led )

turns selected led on.

Parameters
led specifies the led to be set on. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 265 of file at32f413_board.c.

Referenced by DMA2_Channel1_IRQHandler(), main(), sd_test_error(), TAMPER_IRQHandler(), USART2_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_toggle()

void at32_led_toggle ( led_type led )

turns selected led toggle.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 299 of file at32f413_board.c.

Referenced by ACC_IRQHandler(), ADC1_2_IRQHandler(), error_handler(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), led2_task_function(), led3_task_function(), main(), PVM_IRQHandler(), result_error(), RTC_IRQHandler(), RTCAlarm_IRQHandler(), spim_operate(), spim_run(), systick_handler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), USART1_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ delay_init()

void delay_init ( void )

initialize delay function

Parameters
none
Return values
none

Definition at line 312 of file at32f413_board.c.

Referenced by at32_board_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ delay_ms()

void delay_ms ( uint16_t nms )

inserts a delay time.

Parameters
nms specifies the delay time length, in milliseconds.
Return values
none

Definition at line 345 of file at32f413_board.c.

Referenced by at32_button_press(), button_isr(), delay_sec(), error_handler(), flash_fat16_loop_status(), FLASH_IRQHandler(), iap_loop(), main(), randnum_test(), sd_power_on(), sd_test_error(), spim_operate(), spim_run(), usb_delay_ms(), and usb_reset().

◆ delay_sec()

void delay_sec ( uint16_t sec )

inserts a delay time.

Parameters
sec specifies the delay time, in seconds.
Return values
none

Definition at line 377 of file at32f413_board.c.

Referenced by main(), and result_error().

◆ delay_us()

void delay_us ( uint32_t nus )

inserts a delay time.

Parameters
nus specifies the delay time length, in microsecond.
Return values
none

Definition at line 325 of file at32f413_board.c.

Referenced by main(), and usb_delay_us().

◆ fputc()

int fputc | ( | int | ch,
 |  | FILE * | f
 | ) |  |

retargets the c library printf function to the usart.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart transmit data complete flag

Definition at line 92 of file at32f413_board.c.

◆ uart_print_init()

void uart_print_init ( uint32_t baudrate )

initialize uart

Parameters
baudrate uart baudrate
Return values
none

< gpio pins number 9

Definition at line 124 of file at32f413_board.c.

Referenced by main().

Variable Documentation

◆ fac_ms

__IO uint32_t fac_ms
static

Definition at line 46 of file at32f413_board.c.

Referenced by delay_init(), and delay_ms().

◆ fac_us

__IO uint32_t fac_us
static

Definition at line 45 of file at32f413_board.c.

Referenced by delay_init(), and delay_us().

◆ led_gpio_crm_clk

crm_periph_clock_type led_gpio_crm_clk[3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}

Definition at line 42 of file at32f413_board.c.

Referenced by at32_led_init().

◆ led_gpio_pin

uint16_t led_gpio_pin[3] = {LED2_PIN, LED3_PIN, LED4_PIN}

Definition at line 41 of file at32f413_board.c.

Referenced by at32_led_init(), at32_led_off(), at32_led_on(), and at32_led_toggle().

◆ led_gpio_port

gpio_type* led_gpio_port[3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}

Definition at line 40 of file at32f413_board.c.

Referenced by at32_led_init(), at32_led_off(), at32_led_on(), and at32_led_toggle().


AT32F413 Firmwary Library: BOARD_pins_definition

Macros | Enumerations
BOARD_pins_definition
AT32F413_board » BOARD

Macros

#define | LED_NUM 3
#define | PRINT_UART USART1
#define | PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN GPIO_PINS_9
#define | PRINT_UART_TX_GPIO GPIOA
#define | PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | USER_BUTTON_PIN GPIO_PINS_0
#define | USER_BUTTON_PORT GPIOA
#define | USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Enumerations

enum | led_type { LED2 = 0 , LED3 = 1 , LED4 = 2 }
enum | button_type { USER_BUTTON = 0 , NO_BUTTON = 1 }

Detailed Description

Macro Definition Documentation

◆ LED_NUM

#define LED_NUM 3

Definition at line 66 of file at32f413_board.h.

◆ PRINT_UART

#define PRINT_UART USART1

Definition at line 83 of file at32f413_board.h.

◆ PRINT_UART_CRM_CLK

#define PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK

Definition at line 84 of file at32f413_board.h.

◆ PRINT_UART_TX_GPIO

#define PRINT_UART_TX_GPIO GPIOA

Definition at line 86 of file at32f413_board.h.

◆ PRINT_UART_TX_GPIO_CRM_CLK

#define PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 87 of file at32f413_board.h.

◆ PRINT_UART_TX_PIN

#define PRINT_UART_TX_PIN GPIO_PINS_9

Definition at line 85 of file at32f413_board.h.

◆ USER_BUTTON_CRM_CLK

#define USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 98 of file at32f413_board.h.

◆ USER_BUTTON_PIN

#define USER_BUTTON_PIN GPIO_PINS_0

Definition at line 96 of file at32f413_board.h.

◆ USER_BUTTON_PORT

#define USER_BUTTON_PORT GPIOA

Definition at line 97 of file at32f413_board.h.

Enumeration Type Documentation

◆ button_type

enum button_type
Enumerator
USER_BUTTON
NO_BUTTON

Definition at line 90 of file at32f413_board.h.

◆ led_type

enum led_type

this header include define support list:

  1. at-start-f413 v1.x board if define AT_START_F413_V1, the header file support at-start-f413 v1.x board
Enumerator
LED2
LED3
LED4

Definition at line 59 of file at32f413_board.h.


AT32F413 Firmwary Library: BOARD_exported_functions

Functions
BOARD_exported_functions
AT32F413_board » BOARD

Functions

void | at32_board_init (void)
board initialize interface init led and button More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | at32_button_init (void)
configure button gpio More...
button_type | at32_button_press (void)
returns which button have press down More...
uint8_t | at32_button_state (void)
returns the selected button state More...
void | delay_init (void)
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...

Detailed Description

Function Documentation

◆ at32_board_init()

void at32_board_init ( void )

board initialize interface init led and button

Parameters
none
Return values
none

Definition at line 157 of file at32f413_board.c.

Referenced by main().

◆ at32_button_init()

void at32_button_init ( void )

configure button gpio

Parameters
button specifies the button to be configured.
Return values
none

< gpio pins number 0

Definition at line 179 of file at32f413_board.c.

Referenced by at32_board_init().

◆ at32_button_press()

button_type at32_button_press ( void )

returns which button have press down

Parameters
none
Return values
the button have press down

Definition at line 213 of file at32f413_board.c.

Referenced by main().

◆ at32_button_state()

uint8_t at32_button_state ( void )

returns the selected button state

Parameters
none
Return values
the button gpio pin value

< gpio pins number 0

Definition at line 203 of file at32f413_board.c.

Referenced by at32_button_press().

◆ at32_led_init()

void at32_led_init ( led_type led )

configure led gpio

Parameters
led specifies the led to be configured.
Return values
none

Definition at line 237 of file at32f413_board.c.

Referenced by at32_board_init(), and main().

◆ at32_led_off()

void at32_led_off ( led_type led )

turns selected led off.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 282 of file at32f413_board.c.

Referenced by at32_board_init(), main(), sd_test_error(), TAMPER_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_on()

void at32_led_on ( led_type led )

turns selected led on.

Parameters
led specifies the led to be set on. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 265 of file at32f413_board.c.

Referenced by DMA2_Channel1_IRQHandler(), main(), sd_test_error(), TAMPER_IRQHandler(), USART2_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_toggle()

void at32_led_toggle ( led_type led )

turns selected led toggle.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 299 of file at32f413_board.c.

Referenced by ACC_IRQHandler(), ADC1_2_IRQHandler(), error_handler(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), led2_task_function(), led3_task_function(), main(), PVM_IRQHandler(), result_error(), RTC_IRQHandler(), RTCAlarm_IRQHandler(), spim_operate(), spim_run(), systick_handler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), USART1_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ delay_init()

void delay_init ( void )

initialize delay function

Parameters
none
Return values
none

Definition at line 312 of file at32f413_board.c.

Referenced by at32_board_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ delay_ms()

void delay_ms ( uint16_t nms )

inserts a delay time.

Parameters
nms specifies the delay time length, in milliseconds.
Return values
none

Definition at line 345 of file at32f413_board.c.

Referenced by at32_button_press(), button_isr(), delay_sec(), error_handler(), flash_fat16_loop_status(), FLASH_IRQHandler(), iap_loop(), main(), randnum_test(), sd_power_on(), sd_test_error(), spim_operate(), spim_run(), usb_delay_ms(), and usb_reset().

◆ delay_sec()

void delay_sec ( uint16_t sec )

inserts a delay time.

Parameters
sec specifies the delay time, in seconds.
Return values
none

Definition at line 377 of file at32f413_board.c.

Referenced by main(), and result_error().

◆ delay_us()

void delay_us ( uint32_t nus )

inserts a delay time.

Parameters
nus specifies the delay time length, in microsecond.
Return values
none

Definition at line 325 of file at32f413_board.c.

Referenced by main(), and usb_delay_us().

◆ uart_print_init()

void uart_print_init ( uint32_t baudrate )

initialize uart

Parameters
baudrate uart baudrate
Return values
none

< gpio pins number 9

Definition at line 124 of file at32f413_board.c.

Referenced by main().


AT32F413 Firmwary Library: AT32F413_periph_examples

Modules
AT32F413_periph_examples

Modules

ACC_calibration
ADC_combine_mode_ordinary_simult
ADC_current_vref_value_check
ADC_exint_trigger_partitioned
ADC_internal_temperature_sensor
ADC_repeat_conversion_loop_transfer
ADC_software_trigger_repeat
ADC_tmr_trigger_automatic_preempted
ADC_voltage_monitoring
BPR_data
BPR_tamper
CAN_communication_mode
CAN_filter
CAN_loopback_mode
CORTEX_m4_bit_band
CORTEX_m4_cmsis_dsp
CORTEX_m4_fpu
CORTEX_m4_systick_interrupt
CRC_calculation
CRM_clock_failure_detection
CRM_sysclk_switch
DEBUG_tmr
DMA_data_to_gpio_flexible
DMA_flash_to_sram
EXINT_config
EXINT_software_trigger
FLASH_fap_enable
FLASH_write_read
FLASH_operate_spim
FLASH_run_in_spim
GPIO_io_toggle
GPIO_led_toggle
GPIO_swjtag_remap
I2C_communication_dma
I2C_communication_int
I2C_communication_poll
I2C_eeprom
I2S_halfduplex_dma
I2S_halfduplex_interrupt
I2S_spii2s_switch_halfduplex_polling
PWC_deepsleep_rtc
PWC_power_voltage_monitor
PWC_sleep_tmr2
PWC_sleep_usart1
PWC_standby_rtc
PWC_standby_wakeup_pin
RTC_calendar
RTC_lick_calibration
SDIO_sd_mmc_card
SDIO_sdio_fatfs
SPI_crc_transfer_polling
SPI_fullduplex_polling
SPI_halfduplex_interrupt
SPI_halfduplex_transceiver_switch
SPI_only_receive_mode_polling
SPI_use_jtagpin_hardwarecs_dma
SPI_w25q_flash
SRAM_extend_sram
TMR_6_steps
TMR_7_pwm_output
TMR_cascade_synchro
TMR_complementary_signals
TMR_dma
TMR_dma_burst
TMR_encoder_tmr2
TMR_external_clock
TMR_hall_xor_tmr2
TMR_hang_mode
TMR_input_capture
TMR_oc_high
TMR_oc_low
TMR_oc_toggle_tmr3
TMR_oc_toggle_tmr9
TMR_one_cycle
TMR_parallel_synchro
TMR_pwm_input
TMR_pwm_input_dma
TMR_pwm_output_simulate
TMR_pwm_output_tmr10
TMR_pwm_output_tmr3
TMR_timer_base
TMR_tmr1_synchro
TMR_tmr2_32bit
USART_half_duplex
USART_hw_flow_control
USART_idle_detection
USART_interrupt
USART_irda
USART_polling
USART_printf
USART_receiver_mute
F413_USART_rs485
USART_smartcard
USART_synchronous
USART_transfer_by_dma_interrupt
USART_transfer_by_dma_polling
USB_device_audio
USB_device_audio_hid
USB_device_composite_vcp_keyboard
USB_device_msc
USB_device_composite_vcp_msc
USB_device_custom_hid
USB_device_keyboard
USB_device_mouse
USB_device_printer
USB_device_vcp_loopback
USB_device_virtual_msc_iap
WDT_reset
WDT_standby
WWDT_reset

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: ACC_calibration

Macros | Functions | Variables
ACC_calibration
AT32F413_periph_examples

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00
#define | SCLK_FROM_HICK
#define | ACC_TRIM

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | system_clock_config_for_acc (void)
system clock config for acc More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
usbfs_l_can1_rx0 interrupt handler More...
void | ACC_IRQHandler (void)
acc interrupt handler More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
uint32_t | acc_c2_value = 0

Detailed Description

Macro Definition Documentation

◆ ACC_TRIM

#define ACC_TRIM

Definition at line 53 of file project/at_start_f413/examples/acc/calibration/src/main.c.

◆ EPT0_RX_ADDR

#define EPT0_RX_ADDR 0x80

Definition at line 73 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT0_TX_ADDR

#define EPT0_TX_ADDR 0x40

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer

user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size

Definition at line 72 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT1_RX_ADDR

#define EPT1_RX_ADDR 0x100

Definition at line 76 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT1_TX_ADDR

#define EPT1_TX_ADDR 0xC0

Definition at line 75 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT2_RX_ADDR

#define EPT2_RX_ADDR 0x180

Definition at line 79 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT2_TX_ADDR

#define EPT2_TX_ADDR 0x140

Definition at line 78 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT3_RX_ADDR

#define EPT3_RX_ADDR 0x00

Definition at line 82 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT3_TX_ADDR

#define EPT3_TX_ADDR 0x00

Definition at line 81 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT4_RX_ADDR

#define EPT4_RX_ADDR 0x00

Definition at line 85 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT4_TX_ADDR

#define EPT4_TX_ADDR 0x00

Definition at line 84 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT5_RX_ADDR

#define EPT5_RX_ADDR 0x00

Definition at line 88 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT5_TX_ADDR

#define EPT5_TX_ADDR 0x00

Definition at line 87 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT6_RX_ADDR

#define EPT6_RX_ADDR 0x00

Definition at line 91 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT6_TX_ADDR

#define EPT6_TX_ADDR 0x00

Definition at line 90 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT7_RX_ADDR

#define EPT7_RX_ADDR 0x00

Definition at line 94 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT7_TX_ADDR

#define EPT7_TX_ADDR 0x00

Definition at line 93 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ SCLK_FROM_HICK

#define SCLK_FROM_HICK

Definition at line 47 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Function Documentation

◆ ACC_IRQHandler()

void ACC_IRQHandler ( void )

acc interrupt handler

Parameters
none
Return values
none

< acc internal high-speed clock calibration ready error flag

< acc internal high-speed clock calibration ready error flag

< acc reference signal lost error flag

< acc reference signal lost error flag

Definition at line 133 of file project/at_start_f413/examples/acc/calibration/src/main.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

< acc reference signal lost interrupt enable

< acc hick trim

Definition at line 264 of file project/at_start_f413/examples/acc/calibration/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ system_clock_config_for_acc()

void system_clock_config_for_acc ( void )

system clock config for acc

Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 156 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 66 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

usbfs_l_can1_rx0 interrupt handler

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Variable Documentation

◆ acc_c2_value

uint32_t acc_c2_value = 0

Definition at line 58 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by acc_write_c2(), and main().

◆ usb_buffer

uint8_t usb_buffer[256]

Definition at line 43 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: ADC_combine_mode_ordinary_simult

Functions | Variables
ADC_combine_mode_ordinary_simult
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag = 0

Detailed Description

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 142 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 70 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 49 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 142 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint32_t adc1_ordinary_valuetab[5][3]

Definition at line 37 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by dma_config(), and main().

◆ dma1_trans_complete_flag

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 38 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().


AT32F413 Firmwary Library: ADC_current_vref_value_check

Functions | Variables
ADC_current_vref_value_check
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 72 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 103 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_value

__IO uint16_t adc1_ordinary_value = 0

Definition at line 36 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

Referenced by dma_config(), and main().


AT32F413 Firmwary Library: ADC_exint_trigger_partitioned

Functions | Variables
ADC_exint_trigger_partitioned
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | exint_config (void)
exint configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [3][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_trigger_count = 0

Detailed Description

Function Documentation

◆ ADC1_2_IRQHandler()

void ADC1_2_IRQHandler ( void )

this function handles adc1_2 handler.

Parameters
none
Return values
none

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 157 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< preempt channels conversion end interrupt

Definition at line 141 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 143 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 113 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ exint_config()

static void exint_config ( void )
static

exint configuration.

Parameters
none
Return values
none

< gpio pins number 11

< gpio pins number 15

< external interrupt line 11

< external interrupt line 15

Definition at line 73 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 52 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 183 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[3][3] = {0}

Definition at line 37 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_preempt_valuetab

__IO uint16_t adc1_preempt_valuetab[3][3] = {0}

Definition at line 38 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ preempt_trigger_count

__IO uint16_t preempt_trigger_count = 0

Definition at line 40 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().


AT32F413 Firmwary Library: ADC_internal_temperature_sensor

Macros | Functions | Variables
ADC_internal_temperature_sensor
AT32F413_periph_examples

Macros

#define | ADC_VREF (3.3)
#define | ADC_TEMP_BASE (1.26)
#define | ADC_TEMP_SLOPE (-0.00423)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

Macro Definition Documentation

◆ ADC_TEMP_BASE

#define ADC_TEMP_BASE (1.26)

Definition at line 38 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

◆ ADC_TEMP_SLOPE

#define ADC_TEMP_SLOPE (-0.00423)

Definition at line 39 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

◆ ADC_VREF

#define ADC_VREF (3.3)

Definition at line 37 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 108 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_value

__IO uint16_t adc1_ordinary_value = 0

Definition at line 41 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by dma_config(), and main().


AT32F413 Firmwary Library: ADC_repeat_conversion_loop_transfer

Functions | Variables
ADC_repeat_conversion_loop_transfer
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0

Detailed Description

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 141 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 64 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 48 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 36 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c.

Referenced by dma_config().

◆ dma_trans_complete_flag

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 37 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c.


AT32F413 Firmwary Library: ADC_software_trigger_repeat

Functions | Variables
ADC_software_trigger_repeat
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0

Detailed Description

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 141 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 64 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 48 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 36 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by dma_config().

◆ dma_trans_complete_flag

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 37 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.


AT32F413 Firmwary Library: ADC_tmr_trigger_automatic_preempted

Functions | Variables
ADC_tmr_trigger_automatic_preempted
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0

Detailed Description

Function Documentation

◆ ADC1_2_IRQHandler()

void ADC1_2_IRQHandler ( void )

this function handles adc1_2 handler.

Parameters
none
Return values
none

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 158 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< preempt channels conversion end interrupt

Definition at line 139 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 144 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 72 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 51 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 183 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 100 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[5][3] = {0}

Definition at line 36 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_preempt_valuetab

__IO uint16_t adc1_preempt_valuetab[5][3] = {0}

Definition at line 37 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().

◆ dma_trans_complete_flag

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 38 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().

◆ preempt_conversion_count

__IO uint16_t preempt_conversion_count = 0

Definition at line 39 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().


AT32F413 Firmwary Library: ADC_voltage_monitoring

Functions | Variables
ADC_voltage_monitoring
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | vmor_flag_index = 0

Detailed Description

Function Documentation

◆ ADC1_2_IRQHandler()

void ADC1_2_IRQHandler ( void )

this function handles adc1_2 handler.

Parameters
none
Return values
none

< voltage monitoring out of range flag

< voltage monitoring out of range flag

Definition at line 143 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< voltage monitoring out of range interrupt

Definition at line 90 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 48 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 36 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by dma_config(), and main().

◆ vmor_flag_index

__IO uint16_t vmor_flag_index = 0

Definition at line 37 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().


AT32F413 Firmwary Library: BPR_data

Macros | Functions | Variables
BPR_data
AT32F413_periph_examples

Macros

#define BPR_DR_NUMBER 42

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

Macro Definition Documentation

◆ BPR_DR_NUMBER

#define BPR_DR_NUMBER 42

Definition at line 36 of file project/at_start_f413/examples/bpr/bpr_data/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< bpr tamper event flag

Definition at line 98 of file project/at_start_f413/examples/bpr/bpr_data/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file app_led3_toggle/src/usart.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

Variable Documentation

◆ bpr_addr_tab

bpr_data_type bpr_addr_tab[42]
Initial value:
=
{
BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
BPR_DATA41, BPR_DATA42
}
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:91
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:93
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:96
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:73
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:90
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:104
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:72
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:77
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:94
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:84
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:66
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:101
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:74
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:75
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:92
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:85
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:103
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:102
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:106
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:78
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:69
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:97
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:81
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:76
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:89
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:88
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:70
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:83
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:82
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:107
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:86
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:98
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:105
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:95
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:67
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:79
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:80
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:68
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:87
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:99
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:100
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:71

Definition at line 38 of file project/at_start_f413/examples/bpr/bpr_data/src/main.c.

Referenced by bpr_reg_check(), and bpr_reg_write().


AT32F413 Firmwary Library: BPR_tamper

Macros | Functions | Variables
BPR_tamper
AT32F413_periph_examples

Macros

#define BPR_DR_NUMBER 42

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMPER_IRQHandler (void)
this function handles tamper interrupt request. More...
void | bpr_reg_write (void)
write data to bpr dt registers. More...
uint8_t | bpr_reg_check (void)
checks if the bpr dt registers values are correct or not. More...
uint32_t | bpr_reg_judge (void)
checks if the bpr dt registers are reset or not. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

Macro Definition Documentation

◆ BPR_DR_NUMBER

#define BPR_DR_NUMBER 42

Definition at line 36 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Function Documentation

◆ bpr_reg_check()

uint8_t bpr_reg_check ( void )

checks if the bpr dt registers values are correct or not.

Parameters
none.
Return values
- TRUE: all bpr dt registers values are correct
  • FALSE: number of the bpr register which value is not correct

Definition at line 78 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by main().

◆ bpr_reg_judge()

uint32_t bpr_reg_judge ( void )

checks if the bpr dt registers are reset or not.

Parameters
none
Return values
- 0: all bpr dt registers are reset
  • value different from 0: number of the first bpr register not reset

Definition at line 101 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by TAMPER_IRQHandler().

◆ bpr_reg_write()

void bpr_reg_write ( void )

write data to bpr dt registers.

Parameters
none.
Return values
none

Definition at line 60 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< bpr tamper event flag

Definition at line 121 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ TAMPER_IRQHandler()

void TAMPER_IRQHandler ( void )

this function handles tamper interrupt request.

Parameters
none
Return values
none

< bpr tamper interrupt flag

< bpr tamper interrupt flag

< bpr tamper event flag

Definition at line 141 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

Variable Documentation

◆ bpr_addr_tab

bpr_data_type bpr_addr_tab[42]
Initial value:
=
{
BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
BPR_DATA41, BPR_DATA42
}
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:91
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:93
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:96
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:73
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:90
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:104
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:72
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:77
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:94
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:84
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:66
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:101
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:74
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:75
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:92
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:85
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:103
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:102
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:106
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:78
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:69
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:97
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:81
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:76
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:89
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:88
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:70
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:83
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:82
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:107
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:86
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:98
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:105
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:95
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:67
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:79
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:80
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:68
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:87
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:99
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:100
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:71

Definition at line 38 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by bpr_reg_check(), bpr_reg_judge(), and bpr_reg_write().


AT32F413 Firmwary Library: CAN_communication_mode

Functions
CAN_communication_mode
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

Definition at line 166 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 70 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< can_rx(pb8), can_tx(pb9)

< gpio pins number 9

< gpio pins number 8

Definition at line 41 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 187 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

Definition at line 148 of file project/at_start_f413/examples/can/communication_mode/src/main.c.


AT32F413 Firmwary Library: CAN_filter

Macros | Functions | Variables
CAN_filter
AT32F413_periph_examples

Macros

#define | FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
#define | FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
#define | FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
#define | FILTER_STD_ID1 ((uint16_t)0x04F6)
#define | FILTER_STD_ID2 ((uint16_t)0x04F7)
#define | FILTER_STD_ID3 ((uint16_t)0x04F8)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Variables

uint8_t test_result = 0

Detailed Description

Macro Definition Documentation

◆ FILTER_EXT_ID1

#define FILTER_EXT_ID1 ((uint32_t)0x18F5F100)

Definition at line 37 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID2

#define FILTER_EXT_ID2 ((uint32_t)0x18F5F200)

Definition at line 38 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID3

#define FILTER_EXT_ID3 ((uint32_t)0x18F5F300)

Definition at line 39 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_STD_ID1

#define FILTER_STD_ID1 ((uint16_t)0x04F6)

Definition at line 42 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_STD_ID2

#define FILTER_STD_ID2 ((uint16_t)0x04F7)

Definition at line 43 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_STD_ID3

#define FILTER_STD_ID3 ((uint16_t)0x04F8)

Definition at line 44 of file project/at_start_f413/examples/can/filter/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

Definition at line 288 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 83 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< can_rx(pb8), can_tx(pb9)

< gpio pins number 9

< gpio pins number 8

Definition at line 52 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 147 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 309 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

Definition at line 260 of file project/at_start_f413/examples/can/filter/src/main.c.

Variable Documentation

◆ test_result

uint8_t test_result = 0

Definition at line 46 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: CAN_loopback_mode

Functions
CAN_loopback_mode
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

Definition at line 164 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 70 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< can_rx(pb8), can_tx(pb9)

< gpio pins number 9

< gpio pins number 8

Definition at line 41 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 185 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

Definition at line 148 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.


AT32F413 Firmwary Library: CORTEX_m4_bit_band

Macros | Functions | Variables
CORTEX_m4_bit_band
AT32F413_periph_examples

Macros

#define | RAM_BASE 0x20000000
#define | RAM_BITBAND_BASE 0x22000000
#define | VARIABLES_RESET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | VARIABLES_SET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | VARIABLES_GET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
#define | PERIPHERAL_BASE 0x40000000
#define | PERIPHERAL_BITBAND_BASE 0x42000000
#define | PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | PERIPHERAL_SET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | result_error (void)
led4 flick for error. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | variables
__IO uint32_t | variables_addr = 0
__IO uint32_t | variables_bit_val = 0

Detailed Description

Macro Definition Documentation

◆ PERIPHERAL_BASE

#define PERIPHERAL_BASE 0x40000000

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_BITBAND_BASE

#define PERIPHERAL_BITBAND_BASE 0x42000000

Definition at line 52 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_RESET_BIT

#define PERIPHERAL_RESET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_SET_BIT

#define PERIPHERAL_SET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BASE

#define RAM_BASE 0x20000000

Definition at line 38 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BITBAND_BASE

#define RAM_BITBAND_BASE 0x22000000

Definition at line 39 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_GET_BIT

#define VARIABLES_GET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))

Definition at line 47 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_RESET_BIT

#define VARIABLES_RESET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 41 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_SET_BIT

#define VARIABLES_SET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ result_error()

void result_error ( void )

led4 flick for error.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

Variable Documentation

◆ variables

__IO uint32_t variables

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ variables_addr

__IO uint32_t variables_addr = 0

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ variables_bit_val

__IO uint32_t variables_bit_val = 0

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.


AT32F413 Firmwary Library: CORTEX_m4_cmsis_dsp

Macros | Functions | Variables
CORTEX_m4_cmsis_dsp
AT32F413_periph_examples

Macros

#define | USE_STATIC_INIT
#define | TEST_LENGTH_SAMPLES (20*4)
#define | NUMSTUDENTS 20
#define | NUMSUBJECTS 4

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int32_t | main ()
main function. More...

Variables

const float32_t | testMarks_f32 [(20 *4)]
const float32_t | testUnity_f32 [4]
static float32_t | testOutput [(20 *4)]
uint32_t | numStudents = 20
uint32_t | numSubjects = 4
float32_t | max_marks
float32_t | min_marks
float32_t | mean
float32_t | std
float32_t | var
uint32_t | student_num

Detailed Description

Macro Definition Documentation

◆ NUMSTUDENTS

#define NUMSTUDENTS 20

Definition at line 81 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ NUMSUBJECTS

#define NUMSUBJECTS 4

Definition at line 82 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES (20*4)

Definition at line 41 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ USE_STATIC_INIT

#define USE_STATIC_INIT

Definition at line 37 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ main()

int32_t main ( void )

main function.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

Variable Documentation

◆ max_marks

float32_t max_marks

Definition at line 88 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ mean

float32_t mean

Definition at line 88 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ min_marks

float32_t min_marks

Definition at line 88 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ numStudents

uint32_t numStudents = 20

Definition at line 86 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ numSubjects

uint32_t numSubjects = 4

Definition at line 87 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ std

float32_t std

Definition at line 88 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ student_num

uint32_t student_num

Definition at line 89 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testMarks_f32

const float32_t testMarks_f32[(20 *4)]
Initial value:
=
{
42.000000, 37.000000, 81.000000, 28.000000,
83.000000, 72.000000, 36.000000, 38.000000,
32.000000, 51.000000, 63.000000, 64.000000,
97.000000, 82.000000, 95.000000, 90.000000,
66.000000, 51.000000, 54.000000, 42.000000,
67.000000, 56.000000, 45.000000, 57.000000,
67.000000, 69.000000, 35.000000, 52.000000,
29.000000, 81.000000, 58.000000, 47.000000,
38.000000, 76.000000, 100.000000, 29.000000,
33.000000, 47.000000, 29.000000, 50.000000,
34.000000, 41.000000, 61.000000, 46.000000,
52.000000, 50.000000, 48.000000, 36.000000,
47.000000, 55.000000, 44.000000, 40.000000,
100.000000, 94.000000, 84.000000, 37.000000,
32.000000, 71.000000, 47.000000, 77.000000,
31.000000, 50.000000, 49.000000, 35.000000,
63.000000, 67.000000, 40.000000, 31.000000,
29.000000, 68.000000, 61.000000, 38.000000,
31.000000, 28.000000, 28.000000, 76.000000,
55.000000, 33.000000, 29.000000, 39.000000
}

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testOutput

float32_t testOutput[(20 *4)]
static

Definition at line 77 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testUnity_f32

const float32_t testUnity_f32[4]
Initial value:
=
{
1.000, 1.000, 1.000, 1.000
}

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ var

float32_t var

Definition at line 88 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: CORTEX_m4_fpu

Modules | Macros | Functions | Variables
CORTEX_m4_fpu
AT32F413_periph_examples

Modules

JULIA_fpu_functions

Macros

#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)
#define | SCREEN_X_SIZE ((uint16_t)160)
#define | SCREEN_Y_SIZE ((uint16_t)120)
#define | ZOOM ((uint16_t)100)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...
int | main (void)
main function. More...

Variables

uint8_t buffer [((uint16_t) 160) *((uint16_t) 120)]

Detailed Description

Macro Definition Documentation

◆ IMG_CONSTANT

#define IMG_CONSTANT (0.01f)

Definition at line 45 of file julia_fpu.h.

◆ ITERATION

#define ITERATION 200

Definition at line 43 of file julia_fpu.h.

◆ REAL_CONSTANT

#define REAL_CONSTANT (0.285f)

Definition at line 44 of file julia_fpu.h.

◆ SCREEN_X_SIZE

#define SCREEN_X_SIZE ((uint16_t)160)

Definition at line 37 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

◆ SCREEN_Y_SIZE

#define SCREEN_Y_SIZE ((uint16_t)120)

Definition at line 38 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

◆ ZOOM

#define ZOOM ((uint16_t)100)

Definition at line 39 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ generate_julia_fpu()

void generate_julia_fpu | ( | uint16_t | size_x,
 |  | uint16_t | size_y,
 |  | uint16_t | offset_x,
 |  | uint16_t | offset_y,
 |  | uint16_t | zoom,
 |  | uint8_t * | buffer
 | ) |  |

julia calculation test with fpu option enable or disable

Parameters
size_x | width in pixel
size_y | height in pixel
offset_x | x offset for starting point
offset_y | y offset for starting point
zoom | iteration zoom ratio
buffer | pointer to output buffer where values are stored
Return values
none

Definition at line 46 of file julia_fpu.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

Variable Documentation

◆ buffer

uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]

Definition at line 41 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

Referenced by audio_codec_mic_get_data(), bot_scsi_send_data(), generate_julia_fpu(), main(), memset16_buffer(), usbd_ctrl_recv(), usbd_ctrl_send(), usbd_ept_recv(), and usbd_ept_send().


AT32F413 Firmwary Library: JULIA_fpu_functions

Functions
JULIA_fpu_functions
AT32F413_periph_examples » CORTEX_m4_fpu

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

Function Documentation

◆ generate_julia_fpu()

void generate_julia_fpu | ( | uint16_t | size_x,
 |  | uint16_t | size_y,
 |  | uint16_t | offset_x,
 |  | uint16_t | offset_y,
 |  | uint16_t | zoom,
 |  | uint8_t * | buffer
 | ) |  |

julia calculation test with fpu option enable or disable

Parameters
size_x | width in pixel
size_y | height in pixel
offset_x | x offset for starting point
offset_y | y offset for starting point
zoom | iteration zoom ratio
buffer | pointer to output buffer where values are stored
Return values
none

Definition at line 46 of file julia_fpu.c.

Referenced by main().


AT32F413 Firmwary Library: CORTEX_m4_systick_interrupt

Macros | Functions
CORTEX_m4_systick_interrupt
AT32F413_periph_examples

Macros

#define | MS_TICK (system_core_clock / 1000U)
#define | DELAY 200 /* 200 ms ticks */

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | systick_handler (void)
systick interrupt handler. More...
int | main (void)
main function. More...

Detailed Description

Macro Definition Documentation

◆ DELAY

#define DELAY 200 /* 200 ms ticks */

Definition at line 37 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

◆ MS_TICK

#define MS_TICK (system_core_clock / 1000U)

Definition at line 36 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ systick_handler()

void systick_handler ( void )

systick interrupt handler.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

Referenced by SysTick_Handler().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: CRC_calculation

Macros | Functions | Variables
CRC_calculation
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 120

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

static const uint32_t | data_buffer [120]
__IO uint32_t | crc_value = 0

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 120

Definition at line 36 of file project/at_start_f413/examples/crc/calculation/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f413/examples/crc/calculation/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

Variable Documentation

◆ crc_value

__IO uint32_t crc_value = 0

Definition at line 62 of file project/at_start_f413/examples/crc/calculation/src/main.c.

Referenced by iap_crc(), and main().

◆ data_buffer

const uint32_t data_buffer[120]
static
Initial value:
=
{
0xc33dd31c, 0xe37ff35e, 0x129022f3, 0x32d24235, 0x52146277, 0x7256b5ea,
0x4a755a54, 0x6a377a16, 0x0af11ad0, 0x2ab33a92, 0xed0fdd6c, 0xcd4dbdaa,
0xbb3bab1a, 0x6ca67c87, 0x5cc52c22, 0x3c030c60, 0x1c41edae, 0xfd8fcdec,
0xad8b9de8, 0x8dc97c26, 0x5c644c45, 0x3ca22c83, 0x1ce00cc1, 0xef1fff3e,
0x95a88589, 0xf56ee54f, 0xd52cc50d, 0x34e224c3, 0x04817466, 0x64475424,
0x78066827, 0x18c008e1, 0x28a3cb7d, 0xdb5ceb3f, 0xfb1e8bf9, 0x9bd8abbb,
0xdf7caf9b, 0xbfba8fd9, 0x9ff86e17, 0x7e364e55, 0x2e933eb2, 0x0ed11ef0,
0xa35ad3bd, 0xc39cf3ff, 0xe3de2462, 0x34430420, 0x64e674c7, 0x44a45485,
0xad2abd0b, 0x8d689d49, 0x7e976eb6, 0x5ed54ef4, 0x2e321e51, 0x0e70ff9f,
0xefbedfdd, 0xcffcbf1b, 0x9f598f78, 0x918881a9, 0xb1caa1eb, 0xd10cc12d,
0xe16f1080, 0x00a130c2, 0x20e35004, 0x40257046, 0x83b99398, 0xa3fbb3da,
0x00001021, 0x20423063, 0x408450a5, 0x60c670e7, 0x9129a14a, 0xb16bc18c,
0x569546b4, 0xb75ba77a, 0x97198738, 0xf7dfe7fe, 0xc7bc48c4, 0x58e56886,
0x4405a7db, 0xb7fa8799, 0xe75ff77e, 0xc71dd73c, 0x26d336f2, 0x069116b0,
0x76764615, 0x5634d94c, 0xc96df90e, 0xe92f99c8, 0xb98aa9ab, 0x58444865,
0x78a70840, 0x18612802, 0xc9ccd9ed, 0xe98ef9af, 0x89489969, 0xa90ab92b,
0xd1ade1ce, 0xf1ef1231, 0x32732252, 0x52b54294, 0x72f762d6, 0x93398318,
0xa56ab54b, 0x85289509, 0xf5cfc5ac, 0xd58d3653, 0x26721611, 0x063076d7,
0x8d689d49, 0xf7dfe7fe, 0xe98ef9af, 0x063076d7, 0x93398318, 0xb98aa9ab,
0x4ad47ab7, 0x6a961a71, 0x0a503a33, 0x2a12dbfd, 0xfbbfeb9e, 0x9b798b58
}

Definition at line 38 of file project/at_start_f413/examples/crc/calculation/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: CRM_clock_failure_detection

Functions
CRM_clock_failure_detection
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | clkout_config (void)
clkout configuration. More...
static void | sclk_192m_hick_config (void)
config sclk 192 mhz with hick clock source. More...
void | clock_failure_detection_handler (void)
clock failure detection handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ clkout_config()

static void clkout_config ( void )
static

clkout configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 45 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

Referenced by main(), and sclk_192m_hick_config().

◆ clock_failure_detection_handler()

void clock_failure_detection_handler ( void )

clock failure detection handler.

Parameters
none
Return values
none

< clock failure interrupt ready flag

< clock failure interrupt ready flag

Definition at line 74 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

Referenced by NMI_Handler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 169 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ sclk_192m_hick_config()

static void sclk_192m_hick_config ( void )
static

config sclk 192 mhz with hick clock source.

Note
the system clock is configured as follow: system clock (sclk) = hick / 2 * pll_mult system clock source = pll (hick)
  • hick = HICK_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 108 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

Referenced by clock_failure_detection_handler().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.


AT32F413 Firmwary Library: CRM_sysclk_switch

Functions
CRM_sysclk_switch
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | clkout_config (void)
clkout configuration. More...
static void | sclk_64m_hick_config (void)
config sclk 64 mhz with hick clock source. More...
static void | sclk_96m_hext_config (void)
config sclk 96 mhz with hext clock source. More...
static void | switch_system_clock (void)
sclk switch function. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ clkout_config()

static void clkout_config ( void )
static

clkout configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 46 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by main(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 240 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ sclk_64m_hick_config()

static void sclk_64m_hick_config ( void )
static

config sclk 64 mhz with hick clock source.

Note
the system clock is configured as follow: system clock (sclk) = hick / 2 * pll_mult system clock source = pll (hick)
  • hick = HICK_VALUE
  • sclk = 64000000
  • ahbdiv = 1
  • ahbclk = 64000000
  • apb2div = 2
  • apb2clk = 32000000
  • apb1div = 2
  • apb1clk = 32000000
  • pll_mult = 16
  • pll_range = LE72MHZ (less equal 72 mhz)
Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 105 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by switch_system_clock().

◆ sclk_96m_hext_config()

static void sclk_96m_hext_config ( void )
static

config sclk 96 mhz with hext clock source.

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 96000000
  • ahbdiv = 1
  • ahbclk = 96000000
  • apb2div = 2
  • apb2clk = 48000000
  • apb1div = 2
  • apb1clk = 48000000
  • pll_mult = 24
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 179 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by switch_system_clock().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ switch_system_clock()

static void switch_system_clock ( void )
static

sclk switch function.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.


AT32F413 Firmwary Library: DEBUG_tmr

Functions | Variables
DEBUG_tmr
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles tmr1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | counter = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< debug timer1 pause

< tmr interrupt overflow

Definition at line 60 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

this function handles tmr1 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 45 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

Variable Documentation

◆ counter

uint16_t counter = 0

Definition at line 38 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

Referenced by can_receive_error_counter_get(), can_transmit_error_counter_get(), and main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

Referenced by main(), tmr1_config(), tmr2_config(), and tmr_init().


AT32F413 Firmwary Library: DMA_data_to_gpio_flexible

Macros | Functions | Variables
DMA_data_to_gpio_flexible
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel1_IRQHandler (void)
this function handles DMA2 channel1 handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
uint16_t | src_buffer [16]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 16

Definition at line 39 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ DMA2_Channel1_IRQHandler()

void DMA2_Channel1_IRQHandler ( void )

this function handles DMA2 channel1 handler.

Parameters
none
Return values
none

< dma2 channel1 full data transfer flag

< dma2 channel1 full data transfer flag

Definition at line 48 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< jtag-dp disabled and sw-dp enabled

< jtag-dp disabled and sw-dp enabled

< gpio all pins

< dma full data transfer interrupt

< dma flexible channel1

Definition at line 65 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

Variable Documentation

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spim_init(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ src_buffer

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000A, 0x000B, 0x000C, 0x000D, 0x000E, 0x000F, 0x0010}

Definition at line 40 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: DMA_flash_to_sram

Macros | Functions | Variables
DMA_flash_to_sram
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 37 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | const uint32_t * | pbuffer,
 |  | uint32_t * | pbuffer1,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer,pbuffer1 | buffers to be compared.
buffer_length | buffer's length
Return values
SUCCESS pbuffer identical to pbuffer1 ERROR: pbuffer differs from pbuffer1

Definition at line 76 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1 channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 60 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 97 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

Variable Documentation

◆ data_counter_end

__IO uint32_t data_counter_end = 0x01

Definition at line 50 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 49 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ dst_buffer

uint32_t dst_buffer[32]

Definition at line 47 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 48 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

◆ src_const_buffer

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 39 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ transfer_status

error_status transfer_status = ERROR

Definition at line 51 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: EXINT_config

Functions
EXINT_config
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | exint_line0_config (void)
exint line0 config. configure pa0 in interrupt mode More...
int | main (void)
main function. More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 94 of file project/at_start_f413/examples/exint/exint_config/src/main.c.

◆ exint_line0_config()

void exint_line0_config ( void )

exint line0 config. configure pa0 in interrupt mode

Parameters
None
Return values
None

< external interrupt line 0

Definition at line 69 of file project/at_start_f413/examples/exint/exint_config/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/exint/exint_config/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.


AT32F413 Firmwary Library: EXINT_software_trigger

Functions
EXINT_software_trigger
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | exint_line4_config (void)
exint line4 config. configure pa0 in interrupt mode More...
static void | tmr1_config (void)
tmr1 configuration. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
tmr1 interrupt handler More...
void | EXINT4_IRQHandler (void)
exint4 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ EXINT4_IRQHandler()

void EXINT4_IRQHandler ( void )

exint4 interrupt handler

Parameters
none
Return values
none

< external interrupt line 4

< external interrupt line 4

Definition at line 104 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

◆ exint_line4_config()

void exint_line4_config ( void )

exint line4 config. configure pa0 in interrupt mode

Parameters
None
Return values
None

< external interrupt line 4

Definition at line 46 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< tmr interrupt overflow

Definition at line 67 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

Referenced by main().

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

tmr1 interrupt handler

Parameters
none
Return values
none

< tmr flag overflow

< external interrupt line 4

< tmr flag overflow

Definition at line 89 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.


AT32F413 Firmwary Library: FLASH_fap_enable

Functions
FLASH_fap_enable
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< flash common operation timeout

< flash bank1 program error flag

< flash bank1 erase/program protection error flag

Definition at line 41 of file project/at_start_f413/examples/flash/fap_enable/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.


AT32F413 Firmwary Library: FLASH_write_read

Modules | Macros | Functions | Variables
FLASH_write_read
AT32F413_periph_examples

Modules

FLASH_write_read_functions

Macros

#define | SECTOR_SIZE 1024 /* this parameter depends on the specific model of the chip */
#define | TEST_BUFEER_SIZE 3000
#define | TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking More...
int | main (void)
main function. More...

Variables

uint16_t | flash_buf [1024/2]
uint16_t | buffer_write [3000]
uint16_t | buffer_read [3000]

Detailed Description

Macro Definition Documentation

◆ SECTOR_SIZE

#define SECTOR_SIZE 1024 /* this parameter depends on the specific model of the chip */

Definition at line 39 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

◆ TEST_BUFEER_SIZE

#define TEST_BUFEER_SIZE 3000

Definition at line 37 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

◆ TEST_FLASH_ADDRESS_START

#define TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)

Definition at line 38 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ flash_read()

void flash_read | ( | uint32_t | read_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_read
 | ) |  |

read data using halfword mode

Parameters
read_addr | the address of reading
p_buffer | the buffer of reading data
num_read | the number of reading data
Return values
none

Definition at line 51 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write(), and main().

◆ flash_write()

error_status flash_write | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode with checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 89 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by main().

◆ flash_write_nocheck()

error_status flash_write_nocheck | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode without checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 68 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

Variable Documentation

◆ buffer_read

uint16_t buffer_read[3000]

Definition at line 41 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

Referenced by main().

◆ buffer_write

uint16_t buffer_write[3000]

Definition at line 40 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

Referenced by main().

◆ flash_buf

uint16_t flash_buf[1024/2]

Definition at line 42 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().


AT32F413 Firmwary Library: FLASH_write_read_functions

Functions
FLASH_write_read_functions
AT32F413_periph_examples » FLASH_write_read

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking More...

Detailed Description

Function Documentation

◆ flash_read()

void flash_read | ( | uint32_t | read_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_read
 | ) |  |

read data using halfword mode

Parameters
read_addr | the address of reading
p_buffer | the buffer of reading data
num_read | the number of reading data
Return values
none

Definition at line 51 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write(), and main().

◆ flash_write()

error_status flash_write | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode with checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 89 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by main().

◆ flash_write_nocheck()

error_status flash_write_nocheck | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode without checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 68 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().


AT32F413 Firmwary Library: FLASH_operate_spim

Modules | Macros | Functions | Variables
FLASH_operate_spim
AT32F413_periph_examples

Modules

FLASH_operate_spim_functions

Macros

#define | SPIM_SECTOR_SIZE 4096
#define | SPIM_TEST_ADDR 0x08400000

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | spim_init (void)
init the spim flash More...
void | sector_read (uint32_t address, uint32_t sector_size, uint8_t *buf)
read one sector from a specified address in spim flash More...
void | spim_operate (void)
operate spim flash More...

Variables

uint8_t | write_buffer [4096]
uint8_t | read_buffer [4096]

Detailed Description

Macro Definition Documentation

◆ SPIM_SECTOR_SIZE

#define SPIM_SECTOR_SIZE 4096

Definition at line 41 of file operate_spim.h.

◆ SPIM_TEST_ADDR

#define SPIM_TEST_ADDR 0x08400000

Definition at line 42 of file operate_spim.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/flash/operate_spim/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ sector_read()

void sector_read | ( | uint32_t | address,
 |  | uint32_t | sector_size,
 |  | uint8_t * | buf
 | ) |  |

read one sector from a specified address in spim flash

Parameters
address | specifies the sector starting address
sector_size | sector size in bytes
buf | the content read from spim flash
Return values
none

Definition at line 91 of file operate_spim.c.

Referenced by spim_operate().

◆ spim_init()

void spim_init ( void )

init the spim flash

Parameters
none
Return values
none

Definition at line 47 of file operate_spim.c.

Referenced by spim_operate().

◆ spim_operate()

void spim_operate ( void )

operate spim flash

Parameters
none
Return values
none

Definition at line 107 of file operate_spim.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

Variable Documentation

◆ read_buffer

uint8_t read_buffer[4096]

Definition at line 40 of file operate_spim.c.

Referenced by spim_operate().

◆ write_buffer

uint8_t write_buffer[4096]

Definition at line 39 of file operate_spim.c.

Referenced by spim_operate().


AT32F413 Firmwary Library: FLASH_operate_spim_functions

Functions
FLASH_operate_spim_functions
AT32F413_periph_examples » FLASH_operate_spim

Functions

void spim_operate (void)
operate spim flash More...

Detailed Description

Function Documentation

◆ spim_operate()

void spim_operate ( void )

operate spim flash

Parameters
none
Return values
none

Definition at line 107 of file operate_spim.c.

Referenced by main().


AT32F413 Firmwary Library: FLASH_run_in_spim

Functions
FLASH_run_in_spim
AT32F413_periph_examples

Functions

void | spim_run (void)
check the led toggle in spim More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | spim_init (void)
init the spim flash More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f413/examples/flash/run_in_spim/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ spim_init()

void spim_init ( void )

init the spim flash

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 1

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

< spim_sck(pb1), spim_cs(pa8), spim_io0(pb10), spim_io1(pb11), spim_io2(pb7), spim_sio3(pb6)

< flash spim operate busy flag

Definition at line 43 of file project/at_start_f413/examples/flash/run_in_spim/src/main.c.

Referenced by main().

◆ spim_run()

void spim_run ( void )

check the led toggle in spim

Parameters
none
Return values
none

Definition at line 43 of file run_in_spim.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.


AT32F413 Firmwary Library: GPIO_io_toggle

Functions
GPIO_io_toggle
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | gpio_config (void)
pa.01 gpio configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )

pa.01 gpio configuration.

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 1

Definition at line 42 of file project/at_start_f413/examples/gpio/io_toggle/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

Definition at line 66 of file project/at_start_f413/examples/gpio/io_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: GPIO_led_toggle

Functions
GPIO_led_toggle
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/gpio/led_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: GPIO_swjtag_remap

Functions
GPIO_swjtag_remap
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | swj_dp_config (void)
configure the gpio of swj-dp. More...
void | gpio_pins_toggle (gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ gpio_pins_toggle()

void gpio_pins_toggle | ( | gpio_type * | gpio_x,
 |  | uint16_t | gpio_pin
 | ) |  |

toggles the specified gpio pin

Parameters
gpiox | where x can be (a..g depending on device used) to select the gpio peripheral
gpio_pin | specifies the pins to be toggled.
Return values
none

Definition at line 68 of file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< full swj disabled (jtag-dp + sw-dp)

< full swj disabled (jtag-dp + sw-dp)

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 3

< gpio pins number 4

Definition at line 78 of file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ swj_dp_config()

void swj_dp_config ( void )

configure the gpio of swj-dp.

Parameters
none
Return values
none

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 3

< gpio pins number 4

Definition at line 45 of file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.


AT32F413 Firmwary Library: I2C_communication_dma

Macros | Functions | Variables
I2C_communication_dma
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6
#define | I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7
#define | I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel7_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel6_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | error_handler (uint32_t error_code)
error handler program More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 37 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 40 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 43 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_CLK

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_CHANNEL

#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_IRQn

#define I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_CHANNEL

#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6

Definition at line 54 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_IRQn

#define I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ERR_IRQn

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_EVT_IRQn

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 47 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 46 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_6

Definition at line 45 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 50 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_7

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 39 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ MASTER_BOARD

#define MASTER_BOARD

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ DMA1_Channel6_IRQHandler()

void DMA1_Channel6_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 156 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ DMA1_Channel7_IRQHandler()

void DMA1_Channel7_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 146 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 79 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2C1_ERR_IRQHandler()

void I2C1_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 176 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2C1_EVT_IRQHandler()

void I2C1_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 166 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 115 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 182 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ rx_buf

uint8_t rx_buf[8] = {0}

Definition at line 67 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ tx_buf

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2C_communication_int

Macros | Functions | Variables
I2C_communication_int
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | error_handler (uint32_t error_code)
error handler program More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 37 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 40 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 43 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ERR_IRQn

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 54 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_EVT_IRQn

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 53 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 47 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 46 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_6

Definition at line 45 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 50 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_7

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 39 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ MASTER_BOARD

#define MASTER_BOARD

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 89 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ I2C1_ERR_IRQHandler()

void I2C1_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 154 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ I2C1_EVT_IRQHandler()

void I2C1_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 144 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 109 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 149 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ rx_buf

uint8_t rx_buf[8] = {0}

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ tx_buf

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2C_communication_poll

Macros | Functions | Variables
I2C_communication_poll
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 53 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 37 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 40 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 43 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 47 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 46 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_6

Definition at line 45 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 50 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_7

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 39 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ MASTER_BOARD

#define MASTER_BOARD

Definition at line 54 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 86 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 70 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 106 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 142 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ rx_buf

uint8_t rx_buf[8] = {0}

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ tx_buf

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2C_eeprom

Macros | Functions | Variables
I2C_eeprom
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C2
#define | I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_10
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_11
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4
#define | I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5
#define | I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn
#define | I2Cx_EVT_IRQn I2C2_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C2_ERR_IRQn
#define | BUF_SIZE 8

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel5_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C2_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C2_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf1 [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | tx_buf2 [8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}
uint8_t | tx_buf3 [8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}
uint8_t | rx_buf1 [8] = {0}
uint8_t | rx_buf2 [8] = {0}
uint8_t | rx_buf3 [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 63 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 37 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 40 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C2_PERIPH_CLOCK

Definition at line 43 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_CLK

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_CHANNEL

#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5

Definition at line 57 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_IRQn

#define I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn

Definition at line 58 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_CHANNEL

#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4

Definition at line 54 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_IRQn

#define I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn

Definition at line 55 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ERR_IRQn

#define I2Cx_ERR_IRQn I2C2_ERR_IRQn

Definition at line 61 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_EVT_IRQn

#define I2Cx_EVT_IRQn I2C2_EVT_IRQn

Definition at line 60 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C2

Definition at line 42 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 47 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 46 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_10

Definition at line 45 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 50 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_11

Definition at line 49 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 39 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 99 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 156 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ DMA1_Channel5_IRQHandler()

void DMA1_Channel5_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 146 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 83 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2C2_ERR_IRQHandler()

void I2C2_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 176 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2C2_EVT_IRQHandler()

void I2C2_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 166 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 11

Definition at line 119 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 186 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 72 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf1

uint8_t rx_buf1[8] = {0}

Definition at line 68 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf2

uint8_t rx_buf2[8] = {0}

Definition at line 69 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf3

uint8_t rx_buf3[8] = {0}

Definition at line 70 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf1

uint8_t tx_buf1[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 65 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf2

uint8_t tx_buf2[8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}

Definition at line 66 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf3

uint8_t tx_buf3[8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}

Definition at line 67 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2S_halfduplex_dma

Functions | Variables
I2S_halfduplex_dma
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
volatile error_status | transfer_status = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 56 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 7

< gpio pins number 0

< gpio pins number 12

< gpio pins number 13

< gpio pins number 15

Definition at line 128 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ i2s_config()

static void i2s_config ( void )
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel4 full data transfer flag

Definition at line 184 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

Variable Documentation

◆ i2s1_buffer_tx

uint16_t i2s1_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 38 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ i2s2_buffer_rx

uint16_t i2s2_buffer_rx[32]

Definition at line 44 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 45 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2S_halfduplex_interrupt

Functions | Variables
I2S_halfduplex_interrupt
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
error_status | buffer_compare_24bits (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 57 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ buffer_compare_24bits()

error_status buffer_compare_24bits | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare_24bits function.

Parameters
none
Return values
the result of compare

Definition at line 77 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 7

< gpio pins number 0

< gpio pins number 12

< gpio pins number 13

< gpio pins number 15

Definition at line 134 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ i2s_config()

static void i2s_config | ( | i2s_data_channel_format_type | format,
 |  | i2s_audio_sampling_freq_type | freq
 | ) |  |
static

i2s configuration.

Parameters
none
Return values
none

< receive data buffer full interrupt

< transmit data buffer empty interrupt

Definition at line 100 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 190 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI1_IRQHandler()

void SPI1_IRQHandler ( void )

This function handles the spi1 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

Definition at line 157 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI2_IRQHandler()

void SPI2_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s receive data buffer full flag

Definition at line 144 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

Variable Documentation

◆ i2s1_buffer_tx

uint16_t i2s1_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 37 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ i2s2_buffer_rx

uint16_t i2s2_buffer_rx[32]

Definition at line 43 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ rx_index

__IO uint32_t rx_index = 0

Definition at line 44 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 45 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 45 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ tx_index

__IO uint32_t tx_index = 0

Definition at line 44 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2S_spii2s_switch_halfduplex_polling

Functions | Variables
I2S_spii2s_switch_halfduplex_polling
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
static void | i2s_config (i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | spi1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 66 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 7

< gpio pins number 0

< gpio pins number 12

< gpio pins number 13

< gpio pins number 15

Definition at line 145 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ i2s_config()

static void i2s_config | ( | i2s_operation_mode_type | i2s1_mode,
 |  | i2s_operation_mode_type | i2s2_mode
 | ) |  |
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

Definition at line 201 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

Variable Documentation

◆ i2s1_buffer_tx

uint16_t i2s1_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40
}

Definition at line 37 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main(), and SPI1_IRQHandler().

◆ i2s2_buffer_rx

uint16_t i2s2_buffer_rx[32]

Definition at line 51 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main(), and SPI2_IRQHandler().

◆ rx_index

__IO uint32_t rx_index = 0

Definition at line 53 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ spi1_buffer_tx

uint16_t spi1_buffer_tx[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C,
0x5D5E, 0x5F60, 0x6162, 0x6364, 0x6566, 0x6768,
0x696A, 0x6B6C, 0x6D6E, 0x6F70, 0x7172, 0x7374,
0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C,
0x8D8E, 0x8F90
}

Definition at line 44 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_rx

uint16_t spi2_buffer_rx[32]

Definition at line 52 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 54 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 54 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status3

volatile error_status transfer_status3 = ERROR

Definition at line 54 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ tx_index

__IO uint32_t tx_index = 0

Definition at line 53 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: PWC_deepsleep_rtc

Functions
PWC_deepsleep_rtc
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTCAlarm_IRQHandler (void)
this function handles the rtc alarm through exint line interrupt request. More...
void | rtc_config (void)
rtc configuration. More...
void | system_clock_recover (void)
systemclock recover. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 125 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ rtc_config()

void rtc_config ( void )

rtc configuration.

Parameters
none
Return values
none

< external interrupt line 17 connected to the rtc alarm event

< low speed internal clock stable flag

< rtc time alarm interrupt

Definition at line 43 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ RTCAlarm_IRQHandler()

void RTCAlarm_IRQHandler ( void )

this function handles the rtc alarm through exint line interrupt request.

Parameters
none
Return values
none

< rtc time alarm flag

< external interrupt line 17 connected to the rtc alarm event

< rtc time alarm flag

Definition at line 141 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

systemclock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 96 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_power_voltage_monitor

Functions
PWC_power_voltage_monitor
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | PVM_IRQHandler (void)
this function handles the power voltage monitoring output interrupt request. More...
void | pvm_exint_config (void)
power voltage monitor exint configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< external interrupt line 16 connected to the pvm output

< external interrupt line 16 connected to the pvm output

Definition at line 60 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ pvm_exint_config()

void pvm_exint_config ( void )

power voltage monitor exint configuration.

Parameters
none
Return values
none

< external interrupt line 16 connected to the pvm output

Definition at line 43 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c.

Referenced by main().

◆ PVM_IRQHandler()

void PVM_IRQHandler ( void )

this function handles the power voltage monitoring output interrupt request.

Parameters
none
Return values
none

< external interrupt line 16 connected to the pvm output

< external interrupt line 16 connected to the pvm output

Definition at line 141 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_sleep_tmr2

Functions
PWC_sleep_tmr2
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles the timer interrupt request. More...
void | tmr2_config (void)
tmr2 configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ tmr2_config()

void tmr2_config ( void )

tmr2 configuration.

Parameters
none
Return values
none

< tmr interrupt overflow

Definition at line 43 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c.

Referenced by main().

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles the timer interrupt request.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 140 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_sleep_usart1

Functions | Variables
PWC_sleep_usart1
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART1_IRQHandler (void)
this function handles the usatt interrupt request. More...
void | usart1_config (uint32_t baudrate)
usart1 configuration. More...
int | main (void)
main function. More...

Variables

uint16_t usart1_index = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/pwc/sleep_usart1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ usart1_config()

void usart1_config ( uint32_t baudrate )

usart1 configuration.

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< usart receive data buffer full interrupt

Definition at line 41 of file project/at_start_f413/examples/pwc/sleep_usart1/src/main.c.

Referenced by main().

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

this function handles the usatt interrupt request.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 142 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

Variable Documentation

◆ usart1_index

uint16_t usart1_index = 0

Definition at line 39 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

Referenced by USART1_IRQHandler().


AT32F413 Firmwary Library: PWC_standby_rtc

Functions
PWC_standby_rtc
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | rtc_config (void)
rtc configuration. More...
void | rtc_alarm_config (uint8_t alarm_time)
rtc alarm set. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< standby flag

< standby flag

< wakeup flag

< wakeup flag

Definition at line 99 of file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ rtc_alarm_config()

void rtc_alarm_config ( uint8_t alarm_time )

rtc alarm set.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 79 of file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.

Referenced by main().

◆ rtc_config()

void rtc_config ( void )

rtc configuration.

Parameters
none
Return values
none

< low speed internal clock stable flag

Definition at line 44 of file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_standby_wakeup_pin

Functions
PWC_standby_wakeup_pin
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< standby flag

< standby flag

< wakeup flag

< wakeup flag

< standby wake-up pin1

Definition at line 42 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.


AT32F413 Firmwary Library: RTC_calendar

Modules | Functions | Variables
RTC_calendar
AT32F413_periph_examples

Modules

RTC_calendar_type
RTC_calendar_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc handler. More...
void | alarm_init (void)
init alarm. More...
int | main (void)
main function. More...
uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | is_leap_year (uint16_t year)
judeg the leap year or common year. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_week_get (uint16_t year, uint8_t month, uint8_t day)
get current week by input leap year\mouth\day. More...
void | rtc_time_get (void)
get current time. More...

Variables

calendar_type calendar
char const | weekday_table [7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"}
calendar_type calendar
const uint8_t | table_week [12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5}
const uint8_t | mon_table [12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}

Detailed Description

Function Documentation

◆ alarm_init()

void alarm_init ( void )

init alarm.

Parameters
none
Return values
none

< rtc time alarm flag

< rtc time alarm interrupt

Definition at line 44 of file project/at_start_f413/examples/rtc/calendar/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ is_leap_year()

uint8_t is_leap_year ( uint16_t year )

judeg the leap year or common year.

  • month 1 2 3 4 5 6 7 8 9 10 11 12
  • leap year 31 29 31 30 31 30 31 31 30 31 30 31
  • common year 31 28 31 30 31 30 31 31 30 31 30 31
    Parameters
    year
    Return values
    1 leap year 2: common year

Definition at line 115 of file rtc.c.

Referenced by rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 80 of file project/at_start_f413/examples/rtc/calendar/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ rtc_alarm_clock_set()

uint8_t rtc_alarm_clock_set ( calendar_type * calendar )

set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set alarm right. 1: set alarm failed.

Definition at line 215 of file rtc.c.

Referenced by alarm_init().

◆ rtc_init()

uint8_t rtc_init ( calendar_type * calendar )

rtc peripheral initialization.

Parameters
calendar
Return values
0 rtc already init 1: rtc init

Definition at line 49 of file rtc.c.

Referenced by main().

◆ RTC_IRQHandler()

void RTC_IRQHandler ( void )

this function handles rtc handler.

Parameters
none
Return values
none

< rtc time alarm flag

< rtc time alarm flag

Definition at line 140 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ rtc_time_get()

void rtc_time_get ( void )

get current time.

Parameters
none.
Return values
none.

Definition at line 307 of file rtc.c.

Referenced by main().

◆ rtc_time_set()

uint8_t rtc_time_set ( calendar_type * calendar )

set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set time right. 1: set time failed.

Definition at line 149 of file rtc.c.

Referenced by rtc_init().

◆ rtc_week_get()

uint8_t rtc_week_get | ( | uint16_t | year,
 |  | uint8_t | month,
 |  | uint8_t | day
 | ) |  |

get current week by input leap year\mouth\day.

Parameters
year | : year
mon | : month
day | : day
Return values
week number.

Definition at line 277 of file rtc.c.

Referenced by rtc_time_get().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

Variable Documentation

◆ calendar [1/2]

calendar_type calendar
extern

Definition at line 35 of file rtc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_init(), rtc_time_get(), and rtc_time_set().

◆ calendar [2/2]

calendar_type calendar

Definition at line 35 of file rtc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_init(), rtc_time_get(), and rtc_time_set().

◆ mon_table

const uint8_t mon_table[12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}

Definition at line 41 of file rtc.c.

Referenced by rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ table_week

const uint8_t table_week[12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5}

Definition at line 38 of file rtc.c.

Referenced by rtc_week_get().

◆ weekday_table

char const weekday_table[7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"}

Definition at line 37 of file project/at_start_f413/examples/rtc/calendar/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: RTC_calendar_type

Data Structures
RTC_calendar_type
AT32F413_periph_examples » RTC_calendar

Data Structures

struct calendar_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: calendar_type Struct Reference

Data Fields
calendar_type Struct Reference
AT32F413_periph_examples » RTC_calendar » RTC_calendar_type

#include <rtc.h>

Data Fields

__IO uint16_t | year
__IO uint8_t | month
__IO uint8_t | date
__IO uint8_t | hour
__IO uint8_t | min
__IO uint8_t | sec
__IO uint8_t | week

Detailed Description

Definition at line 46 of file rtc.h.

Field Documentation

◆ date

__IO uint8_t calendar_type::date

specifies the date of calendar.

Definition at line 50 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ hour

__IO uint8_t calendar_type::hour

specifies the hours of calendar.

Definition at line 51 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ min

__IO uint8_t calendar_type::min

specifies the minutes of calendar.

Definition at line 52 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ month

__IO uint8_t calendar_type::month

specifies the months of calendar.

Definition at line 49 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ sec

__IO uint8_t calendar_type::sec

specifies the second of calendar.

Definition at line 53 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ week

__IO uint8_t calendar_type::week

specifies the weeks of calendar.

Definition at line 54 of file rtc.h.

Referenced by main(), and rtc_time_get().

◆ year

__IO uint16_t calendar_type::year

specifies the years of calendar.

Definition at line 48 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

The documentation for this struct was generated from the following file:
  • rtc.h


AT32F413 Firmwary Library: RTC_calendar_exported_functions

Functions
RTC_calendar_exported_functions
AT32F413_periph_examples » RTC_calendar

Functions

uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
void | rtc_time_get (void)
get current time. More...

Detailed Description

Function Documentation

◆ rtc_alarm_clock_set()

uint8_t rtc_alarm_clock_set ( calendar_type * calendar )

set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set alarm right. 1: set alarm failed.

Definition at line 215 of file rtc.c.

Referenced by alarm_init().

◆ rtc_init()

uint8_t rtc_init ( calendar_type * calendar )

rtc peripheral initialization.

Parameters
calendar
Return values
0 rtc already init 1: rtc init

Definition at line 49 of file rtc.c.

Referenced by main().

◆ rtc_time_get()

void rtc_time_get ( void )

get current time.

Parameters
none.
Return values
none.

Definition at line 307 of file rtc.c.

Referenced by main().

◆ rtc_time_set()

uint8_t rtc_time_set ( calendar_type * calendar )

set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set time right. 1: set time failed.

Definition at line 149 of file rtc.c.

Referenced by rtc_init().


AT32F413 Firmwary Library: RTC_lick_calibration

Functions | Variables
RTC_lick_calibration
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc global interrupt request. More...
void | TMR5_GLOBAL_IRQHandler (void)
this function handles tmr5 global interrupt request. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
void | rtc_configuration (void)
configures the rtc. More...
uint32_t | incrementvar_operationcomplete (void)
increments operationcomplete variable and return its value before increment operation. More...
uint32_t | getvar_operationcomplete (void)
returns operationcomplete value. More...
void | setvar_periodvalue (uint32_t value)
sets the periodvalue variable with input parameter. More...
int | main (void)
main function. More...

Variables

uint16_t | tmpCC4 [2] = {0, 0}
crm_clocks_freq_type crm_clocks
__IO uint32_t | periodvalue = 0
__IO uint32_t | lickfreq = 0
__IO uint32_t | operationcomplete = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ getvar_operationcomplete()

uint32_t getvar_operationcomplete ( void )

returns operationcomplete value.

Parameters
none
Return values
operationcomplete value

Definition at line 128 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 61 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ incrementvar_operationcomplete()

uint32_t incrementvar_operationcomplete ( void )

increments operationcomplete variable and return its value before increment operation.

Parameters
none
Return values
operationcomplete value before increment

Definition at line 116 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< lick connected to tmr5_ch4 input capture for calibration

< lick connected to tmr5_ch4 input capture for calibration

< tmr flag channel 4

< tmr interrupt channel 4

Definition at line 148 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 74 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )

configures the nested vectored interrupt controller.

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ rtc_configuration()

void rtc_configuration ( void )

configures the rtc.

Parameters
none
Return values
none

< low speed internal clock stable flag

< rtc time second interrupt

Definition at line 63 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ RTC_IRQHandler()

void RTC_IRQHandler ( void )

this function handles rtc global interrupt request.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 149 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ setvar_periodvalue()

void setvar_periodvalue ( uint32_t value )

sets the periodvalue variable with input parameter.

Parameters
value value of periodvalue to be set.
Return values
none

Definition at line 138 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 140 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ TMR5_GLOBAL_IRQHandler()

void TMR5_GLOBAL_IRQHandler ( void )

this function handles tmr5 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 4

< tmr flag channel 4

< tmr interrupt channel 4

Definition at line 168 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 100 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks

crm_clocks_freq_type crm_clocks

Definition at line 36 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ lickfreq

__IO uint32_t lickfreq = 0

Definition at line 38 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ operationcomplete

__IO uint32_t operationcomplete = 0

Definition at line 39 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by getvar_operationcomplete(), incrementvar_operationcomplete(), and main().

◆ periodvalue

__IO uint32_t periodvalue = 0

Definition at line 37 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main(), and setvar_periodvalue().

◆ tmpCC4

uint16_t tmpCC4[2] = {0, 0}

Definition at line 45 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

Referenced by TMR5_GLOBAL_IRQHandler().


AT32F413 Firmwary Library: SDIO_sd_mmc_card

Modules | Macros | Functions | Variables
SDIO_sd_mmc_card
AT32F413_periph_examples

Modules

SDIO_sd_mmc_card_instance_definition
SDIO_sd_mmc_card_exported_types
SDIO_sd_mmc_card_command_index_definition
SDIO_sd_mmc_card_paremeters_definition
SDIO_sd_mmc_card_response_definition
SDIO_sd_mmc_card_command_class_definition
SDIO_sd_mmc_card_cmd8_definition
SDIO_sd_mmc_card_mmc_extend_definition
SDIO_sd_mmc_card_interrupt_flags_definition
SDIO_sd_mmc_card_exported_functions

Macros

#define | BLOCK_SIZE (512)
#define | BLOCKS_NUMBER (8)
#define | MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
#define | STREAM_BUFFER_SIZE (1024)

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static error_status | sd_single_block_test (void)
sd card single block read/write test. More...
static error_status | sd_multiple_blocks_test (void)
sd card multiple blocks read/write test. More...
static void | sd_test_error (void)
LED2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | mmc_stream_test (void)
mmc card data stream read/write test. More...
void | show_card_info (void)
show sd/mmc card info. More...
int | main (void)
main function. More...

Variables

sd_card_info_struct_type sd_card_info
sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
static uint8_t | sblock_tbuffer [(512)]
static uint8_t | sblock_rbuffer [(512)]
static uint8_t | mblock_tbuffer [((512) *(8))]
static uint8_t | mblock_rbuffer [((512) *(8))]
static uint8_t | stream_tbuffer [(1024)]
static uint8_t | stream_rbuffer [(1024)]

Detailed Description

Macro Definition Documentation

◆ BLOCK_SIZE

#define BLOCK_SIZE (512)

Definition at line 39 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ BLOCKS_NUMBER

#define BLOCKS_NUMBER (8)

Definition at line 40 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ MULTI_BUFFER_SIZE

#define MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)

Definition at line 41 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ STREAM_BUFFER_SIZE

#define STREAM_BUFFER_SIZE (1024)

Definition at line 42 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 271 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1644 of file sd_mmc_card/src/at32_sdio.c.

◆ mmc_stream_test()

static error_status mmc_stream_test ( void )
static

mmc card data stream read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 155 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1691 of file sd_mmc_card/src/at32_sdio.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )
static

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 236 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1179 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1358 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1021 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 523 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 408 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 798 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 777 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2697 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 70 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1780 of file sd_mmc_card/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1268 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1480 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_multiple_blocks_test()

static error_status sd_multiple_blocks_test ( void )
static

sd card multiple blocks read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 107 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 394 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 194 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_single_block_test()

static error_status sd_single_block_test ( void )
static

sd card single block read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 60 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2480 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2443 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_test_error()

static void sd_test_error ( void )
static

LED2 on off every 300ms for sd test failed.

Parameters
none
Return values
none

Definition at line 223 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 734 of file sd_mmc_card/src/at32_sdio.c.

◆ SDIO1_IRQHandler()

void SDIO1_IRQHandler ( void )

sdio1 isr.

Parameters
none.
Return values
none.

Definition at line 1760 of file sd_mmc_card/src/at32_sdio.c.

◆ SDIO2_IRQHandler()

void SDIO2_IRQHandler ( void )

sdio2 isr.

Parameters
none.
Return values
none.

Definition at line 1770 of file sd_mmc_card/src/at32_sdio.c.

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 179 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_data_send()

sd_error_status_type sdio_command_data_send | ( | sdio_command_struct_type * | sdio_cmd_init_t,
 |  | sdio_data_struct_type * | sdio_data_init_t,
 |  | uint32_t * | buf
 | ) |  |

read data from or write data to sd card.

Parameters
sdio_cmd_init_struct | pointer to sdio_command_struct_type structure.
sdio_data_init_struct | pointer to sdio_data_struct_type structure.
buf | pointer to data buffer read or write.
Return values
sd_error_status_type sd card error code.

Definition at line 821 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ show_card_info()

void show_card_info ( void )

show sd/mmc card info.

Parameters
none
Return values
none

Definition at line 247 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

Variable Documentation

◆ card_type

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 40 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_info_get(), sd_card_init(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_wide_bus_operation_config(), and speed_change().

◆ cid_table

uint32_t cid_table[4]
static

Definition at line 41 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ csd_table

uint32_t csd_table[4]
static

Definition at line 41 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ device_mode

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 42 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_device_mode_set(), and sdio_command_data_send().

◆ mblock_rbuffer

uint8_t mblock_rbuffer[((512) *(8))]
static

Definition at line 45 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ mblock_tbuffer

uint8_t mblock_tbuffer[((512) *(8))]
static

Definition at line 45 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ rca

uint32_t rca = 0
static

Definition at line 41 of file sd_mmc_card/src/at32_sdio.c.

Referenced by check_card_programming(), sd_card_info_get(), sd_card_init(), sd_mult_blocks_write(), and sd_status_send().

◆ sblock_rbuffer

uint8_t sblock_rbuffer[(512)]
static

Definition at line 44 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sblock_tbuffer

uint8_t sblock_tbuffer[(512)]
static

Definition at line 44 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sd_card_info [1/2]

sd_card_info_struct_type sd_card_info
extern

Definition at line 46 of file sd_mmc_card/src/at32_sdio.c.

Referenced by disk_ioctl(), main(), and show_card_info().

◆ sd_card_info [2/2]

sd_card_info_struct_type sd_card_info

Definition at line 46 of file sd_mmc_card/src/at32_sdio.c.

Referenced by scr_find(), sd_bus_wide_enable(), sd_init(), and speed_change().

◆ sdio_command_init_struct

sdio_command_struct_type sdio_command_init_struct

Definition at line 37 of file sd_mmc_card/src/at32_sdio.c.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), and sd_switch().

◆ sdio_data_init_struct

sdio_data_struct_type sdio_data_init_struct

Definition at line 38 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ stop_flag

uint8_t stop_flag = 0
static

Definition at line 43 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_command_data_send().

◆ stream_rbuffer

uint8_t stream_rbuffer[(1024)]
static

Definition at line 46 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ stream_tbuffer

uint8_t stream_tbuffer[(1024)]
static

Definition at line 46 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ transfer_end

volatile uint8_t transfer_end = 0

Definition at line 45 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_error

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 44 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().


AT32F413 Firmwary Library: SDIO_sd_mmc_card_instance_definition

Macros
SDIO_sd_mmc_card_instance_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define SDIOx SDIO1

Detailed Description

Macro Definition Documentation

◆ SDIOx

#define SDIOx SDIO1

Definition at line 49 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_exported_types

Data Structures | Enumerations
SDIO_sd_mmc_card_exported_types
AT32F413_periph_examples » SDIO_sd_mmc_card

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Detailed Description

Enumeration Type Documentation

◆ sd_card_state_type

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 184 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 62 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_error_status_type

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 71 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_memory_card_type

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 200 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: sd_csd_struct_type Struct Reference

Data Fields
sd_csd_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

uint8_t | csd_struct
uint8_t | spec_version
uint8_t | reserved1
uint8_t | taac
uint8_t | nsac
uint8_t | max_bus_clk_freq
uint16_t | card_cmd_classes
uint8_t | max_read_blk_length
uint8_t | part_blk_read
uint8_t | write_blk_misalign
uint8_t | read_blk_misalign
uint8_t | dsr_implemented
uint8_t | reserved2
uint32_t | device_size
uint8_t | max_read_current_vdd_min
uint8_t | max_read_current_vdd_max
uint8_t | max_write_current_vdd_min
uint8_t | max_write_current_vdd_max
uint8_t | device_size_mult
uint8_t | erase_group_size
uint8_t | erase_group_size_mult
uint8_t | write_protect_group_size
uint8_t | write_protect_group_enable
uint8_t | manufacturer_default_ecc
uint8_t | write_speed_factor
uint8_t | max_write_blk_length
uint8_t | part_blk_write
uint8_t | reserved3
uint8_t | content_protect_app
uint8_t | file_format_group
uint8_t | copy_flag
uint8_t | permanent_write_protect
uint8_t | temp_write_protect
uint8_t | file_formart
uint8_t | ecc_code
uint8_t | csd_crc
uint8_t | reserved4

Detailed Description

card specific data: csd register

Definition at line 123 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ card_cmd_classes

uint16_t sd_csd_struct_type::card_cmd_classes

card command classes

Definition at line 131 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ content_protect_app

uint8_t sd_csd_struct_type::content_protect_app

content protection application

Definition at line 153 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ copy_flag

uint8_t sd_csd_struct_type::copy_flag

copy flag (otp)

Definition at line 155 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ csd_crc

uint8_t sd_csd_struct_type::csd_crc

csd crc

Definition at line 160 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ csd_struct

uint8_t sd_csd_struct_type::csd_struct

csd structure

Definition at line 125 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ device_size

uint32_t sd_csd_struct_type::device_size

device size

Definition at line 138 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ device_size_mult

uint8_t sd_csd_struct_type::device_size_mult

device size multiplier

Definition at line 143 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ dsr_implemented

uint8_t sd_csd_struct_type::dsr_implemented

dsr implemented

Definition at line 136 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ ecc_code

uint8_t sd_csd_struct_type::ecc_code

ecc code

Definition at line 159 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ erase_group_size

uint8_t sd_csd_struct_type::erase_group_size

erase group size

Definition at line 144 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ erase_group_size_mult

uint8_t sd_csd_struct_type::erase_group_size_mult

erase group size multiplier

Definition at line 145 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ file_formart

uint8_t sd_csd_struct_type::file_formart

file format

Definition at line 158 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ file_format_group

uint8_t sd_csd_struct_type::file_format_group

file format group

Definition at line 154 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufacturer_default_ecc

uint8_t sd_csd_struct_type::manufacturer_default_ecc

manufacturer default ecc

Definition at line 148 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_bus_clk_freq

uint8_t sd_csd_struct_type::max_bus_clk_freq

max. bus clock frequency

Definition at line 130 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_blk_length

uint8_t sd_csd_struct_type::max_read_blk_length

max. read data block length

Definition at line 132 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_current_vdd_max

uint8_t sd_csd_struct_type::max_read_current_vdd_max

max. read current @ vdd max

Definition at line 140 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_current_vdd_min

uint8_t sd_csd_struct_type::max_read_current_vdd_min

max. read current @ vdd min

Definition at line 139 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_blk_length

uint8_t sd_csd_struct_type::max_write_blk_length

max. write data block length

Definition at line 150 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_current_vdd_max

uint8_t sd_csd_struct_type::max_write_current_vdd_max

max. write current @ vdd max

Definition at line 142 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_current_vdd_min

uint8_t sd_csd_struct_type::max_write_current_vdd_min

max. write current @ vdd min

Definition at line 141 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ nsac

uint8_t sd_csd_struct_type::nsac

data read access-time 2 in clk cycles

Definition at line 129 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ part_blk_read

uint8_t sd_csd_struct_type::part_blk_read

partial blocks for read allowed

Definition at line 133 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ part_blk_write

uint8_t sd_csd_struct_type::part_blk_write

partial blocks for write allowed

Definition at line 151 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ permanent_write_protect

uint8_t sd_csd_struct_type::permanent_write_protect

permanent write protection

Definition at line 156 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ read_blk_misalign

uint8_t sd_csd_struct_type::read_blk_misalign

read block misalignment

Definition at line 135 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved1

uint8_t sd_csd_struct_type::reserved1

reserved

Definition at line 127 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved2

uint8_t sd_csd_struct_type::reserved2

reserved

Definition at line 137 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved3

uint8_t sd_csd_struct_type::reserved3

reserded

Definition at line 152 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved4

uint8_t sd_csd_struct_type::reserved4

always

Definition at line 161 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ spec_version

uint8_t sd_csd_struct_type::spec_version

system specification version

Definition at line 126 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and sd_init().

◆ taac

uint8_t sd_csd_struct_type::taac

data read access-time 1

Definition at line 128 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ temp_write_protect

uint8_t sd_csd_struct_type::temp_write_protect

temporary write protection

Definition at line 157 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_blk_misalign

uint8_t sd_csd_struct_type::write_blk_misalign

write block misalignment

Definition at line 134 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_protect_group_enable

uint8_t sd_csd_struct_type::write_protect_group_enable

write protect group enable

Definition at line 147 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_protect_group_size

uint8_t sd_csd_struct_type::write_protect_group_size

write protect group size

Definition at line 146 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_speed_factor

uint8_t sd_csd_struct_type::write_speed_factor

write speed factor

Definition at line 149 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: sd_cid_struct_type Struct Reference

Data Fields
sd_cid_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

uint8_t | manufacturer_id
uint16_t | oem_app_id
uint32_t | product_name1
uint8_t | product_name2
uint8_t | product_reversion
uint32_t | product_sn
uint8_t | reserved1
uint16_t | manufact_date
uint8_t | cid_crc
uint8_t | reserved2

Detailed Description

card identification data: cid register

Definition at line 167 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ cid_crc

uint8_t sd_cid_struct_type::cid_crc

cid crc

Definition at line 177 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufact_date

uint16_t sd_cid_struct_type::manufact_date

manufacturing date

Definition at line 176 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufacturer_id

uint8_t sd_cid_struct_type::manufacturer_id

manufacturer id

Definition at line 169 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ oem_app_id

uint16_t sd_cid_struct_type::oem_app_id

oem/application id

Definition at line 170 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_name1

uint32_t sd_cid_struct_type::product_name1

product name part1

Definition at line 171 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_name2

uint8_t sd_cid_struct_type::product_name2

product name part2

Definition at line 172 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_reversion

uint8_t sd_cid_struct_type::product_reversion

product revision

Definition at line 173 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_sn

uint32_t sd_cid_struct_type::product_sn

product serial number

Definition at line 174 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved1

uint8_t sd_cid_struct_type::reserved1

reserved1

Definition at line 175 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved2

uint8_t sd_cid_struct_type::reserved2

always 1

Definition at line 178 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: sd_scr_struct_type Struct Reference

Data Fields
sd_scr_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

uint32_t | sd_spec:4
uint32_t | scr_structure:4
uint32_t | sd_bus_width:4
uint32_t | sd_security:3
uint32_t | data_stat_after_erase:1
uint32_t | reserved1:7
uint32_t | sd_spec3:1
uint32_t | cmd20_support:1
uint32_t | cmd23_support:1
uint32_t | reserverd2:6
uint32_t | reserverd3

Detailed Description

sd card scr information

Definition at line 216 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ cmd20_support

uint32_t sd_scr_struct_type::cmd20_support

Definition at line 225 of file sd_mmc_card/inc/at32_sdio.h.

◆ cmd23_support

uint32_t sd_scr_struct_type::cmd23_support

Definition at line 226 of file sd_mmc_card/inc/at32_sdio.h.

◆ data_stat_after_erase

uint32_t sd_scr_struct_type::data_stat_after_erase

Definition at line 222 of file sd_mmc_card/inc/at32_sdio.h.

◆ reserved1

uint32_t sd_scr_struct_type::reserved1

Definition at line 223 of file sd_mmc_card/inc/at32_sdio.h.

◆ reserverd2

uint32_t sd_scr_struct_type::reserverd2

Definition at line 227 of file sd_mmc_card/inc/at32_sdio.h.

◆ reserverd3

uint32_t sd_scr_struct_type::reserverd3

Definition at line 228 of file sd_mmc_card/inc/at32_sdio.h.

◆ scr_structure

uint32_t sd_scr_struct_type::scr_structure

Definition at line 219 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_bus_width

uint32_t sd_scr_struct_type::sd_bus_width

Definition at line 220 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_bus_wide_enable().

◆ sd_security

uint32_t sd_scr_struct_type::sd_security

Definition at line 221 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_spec

uint32_t sd_scr_struct_type::sd_spec

Definition at line 218 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by speed_change().

◆ sd_spec3

uint32_t sd_scr_struct_type::sd_spec3

Definition at line 224 of file sd_mmc_card/inc/at32_sdio.h.

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: sd_card_info_struct_type Struct Reference

Data Fields
sd_card_info_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

sd_csd_struct_type sd_csd_reg
sd_cid_struct_type sd_cid_reg
sd_scr_struct_type sd_scr_reg
long long | card_capacity
uint32_t | card_blk_size
uint16_t | rca
uint8_t | card_type

Detailed Description

sd card information

Definition at line 234 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ card_blk_size

uint32_t sd_card_info_struct_type::card_blk_size

Definition at line 240 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by disk_ioctl(), sd_card_info_get(), and show_card_info().

◆ card_capacity

long long sd_card_info_struct_type::card_capacity

Definition at line 239 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by disk_ioctl(), sd_card_info_get(), and show_card_info().

◆ card_type

uint8_t sd_card_info_struct_type::card_type

Definition at line 242 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by main(), sd_card_info_get(), sd_init(), and show_card_info().

◆ rca

uint16_t sd_card_info_struct_type::rca

Definition at line 241 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by scr_find(), sd_bus_wide_enable(), sd_card_info_get(), sd_init(), and show_card_info().

◆ sd_cid_reg

sd_cid_struct_type sd_card_info_struct_type::sd_cid_reg

Definition at line 237 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ sd_csd_reg

sd_csd_struct_type sd_card_info_struct_type::sd_csd_reg

Definition at line 236 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), sd_init(), and show_card_info().

◆ sd_scr_reg

sd_scr_struct_type sd_card_info_struct_type::sd_scr_reg

Definition at line 238 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by scr_find(), sd_bus_wide_enable(), and speed_change().

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: SDIO_sdio_fatfs_exported_types

Data Structures | Enumerations
SDIO_sdio_fatfs_exported_types
AT32F413_periph_examples » SDIO_sdio_fatfs

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Detailed Description

Enumeration Type Documentation

◆ sd_card_state_type

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 184 of file sdio_fatfs/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 62 of file sdio_fatfs/inc/at32_sdio.h.

◆ sd_error_status_type

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 71 of file sdio_fatfs/inc/at32_sdio.h.

◆ sd_memory_card_type

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 200 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_command_index_definition

Macros
SDIO_sd_mmc_card_command_index_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Detailed Description

Macro Definition Documentation

◆ SD_CMD_ALL_SEND_CID

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 258 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 293 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 301 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 283 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 289 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 288 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 287 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 290 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 294 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 256 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 271 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 291 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 270 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 275 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 264 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 262 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 292 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 295 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 280 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 281 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 267 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 274 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 273 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 323 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 319 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 317 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 315 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 314 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 304 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 322 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 320 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 324 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 321 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 303 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 306 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 318 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 316 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 305 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 302 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 286 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 285 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 307 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 308 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 261 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 263 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 266 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 265 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 257 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 269 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 284 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 277 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 272 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 260 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 259 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 282 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 268 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 276 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 279 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 278 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_paremeters_definition

Macros
SDIO_sd_mmc_card_paremeters_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)

Detailed Description

Macro Definition Documentation

◆ NULL

#define NULL 0

sdio paremeters

Definition at line 337 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 339 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 340 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_FIFO_Address

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 341 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 338 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_response_definition

Macros
SDIO_sd_mmc_card_response_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ MMC_SWITCH_ERROR

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 372 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_0TO7BITS

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 402 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_16TO23BITS

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 404 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_24TO31BITS

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 405 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_8TO15BITS

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 403 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_ALLZERO

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 395 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_LOCKED

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 398 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 399 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 400 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 392 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_DATATIMEOUT

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 401 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFO

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 407 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 408 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 390 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 406 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 394 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 355 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 354 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 373 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 356 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 364 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 370 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 363 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 368 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 361 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 371 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 357 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 374 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 365 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 362 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 358 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 360 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 366 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 367 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 369 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 359 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_ERROR

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 381 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 380 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 379 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 388 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 386 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 387 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 397 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_STD_CAPACITY

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 391 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 393 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 389 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 396 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_command_class_definition

Macros
SDIO_sd_mmc_card_command_class_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ SD_CCCC_ERASE

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 423 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 421 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 422 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_cmd8_definition

Macros
SDIO_sd_mmc_card_cmd8_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

Detailed Description

Macro Definition Documentation

◆ SDIO_SEND_IF_COND

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 436 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_mmc_extend_definition

Macros
SDIO_sd_mmc_card_mmc_extend_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185

Detailed Description

Macro Definition Documentation

◆ EXT_CSD_BUS_WIDTH

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 461 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte

#define EXT_CSD_Clear_byte 0x2

Definition at line 451 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 456 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 454 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 455 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Command_set

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 449 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING

#define EXT_CSD_HS_TIMING 185

Definition at line 462 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit

#define EXT_CSD_Set_bit 0x1

Definition at line 450 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte

#define EXT_CSD_Write_byte 0x3

Definition at line 452 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_interrupt_flags_definition

Macros
SDIO_sd_mmc_card_interrupt_flags_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Detailed Description

Macro Definition Documentation

◆ SDIO_INTR_STS_READ_MASK

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:84
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:88
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:86
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:92

Definition at line 474 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:87

Definition at line 472 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_exported_functions

Functions
SDIO_sd_mmc_card_exported_functions
AT32F413_periph_examples » SDIO_sd_mmc_card

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Detailed Description

Function Documentation

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1644 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1691 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1179 of file sd_mmc_card/src/at32_sdio.c.

Referenced by __align(), and sd_single_block_test().

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1358 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_single_block_test(), and sd_write_disk().

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1021 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 523 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 408 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 798 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 777 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2697 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 70 of file sd_mmc_card/src/at32_sdio.c.

Referenced by disk_initialize(), and main().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1780 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1268 of file sd_mmc_card/src/at32_sdio.c.

Referenced by __align(), and sd_multiple_blocks_test().

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1480 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_write_disk().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 394 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 194 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2480 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2443 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 734 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test(), sd_multiple_blocks_test(), and sd_single_block_test().

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 179 of file sd_mmc_card/src/at32_sdio.c.


AT32F413 Firmwary Library: SDIO_sdio_fatfs

Modules | Functions | Variables
SDIO_sdio_fatfs
AT32F413_periph_examples

Modules

SDIO_sdio_fatfs_instance_definition
SDIO_sdio_fatfs_exported_types
SDIO_sdio_fatfs_command_index_definition
SDIO_sdio_fatfs_paremeters_definition
SDIO_sdio_fatfs_response_definition
SDIO_sdio_fatfs_command_class_definition
SDIO_sdio_fatfs_cmd8_definition
SDIO_sdio_fatfs_mmc_extend_definition
SDIO_sdio_fatfs_interrupt_flags_definition
SDIO_sdio_fatfs_exported_functions

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
led2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | fatfs_test (void)
fatfs file read/write test. More...
int | main (void)
main function. More...

Variables

sd_card_info_struct_type sd_card_info
sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
FATFS | fs
FIL | file
BYTE | work [FF_MAX_SS]

Detailed Description

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 55 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ check_card_programming()

sd_error_status_type check_card_programming ( uint8_t * p_status )

checks if the sd card is in programming state.

Parameters
p_status pointer to the variable that will contain the sd card state.
Return values
sd_error_status_type sd card error code.

Definition at line 2396 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_write(), sd_block_write(), sd_blocks_erase(), and sd_mult_blocks_write().

◆ command_error()

sd_error_status_type command_error ( void )

checks for error conditions for cmd0.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1871 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ command_rsp1_error()

sd_error_status_type command_rsp1_error ( uint8_t cmd )

checks for error conditions for R1 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 1935 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ command_rsp2_error()

sd_error_status_type command_rsp2_error ( void )

checks for error conditions for R2 (cid or csd) response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 2008 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_init().

◆ command_rsp3_error()

sd_error_status_type command_rsp3_error ( void )

checks for error conditions for R3 (ocr) response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1978 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ command_rsp4_error()

sd_error_status_type command_rsp4_error ( uint8_t cmd )

checks for error conditions for r4 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 2048 of file sdio_fatfs/src/at32_sdio.c.

◆ command_rsp5_error()

sd_error_status_type command_rsp5_error ( uint8_t cmd )

checks for error conditions for r5 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 2091 of file sdio_fatfs/src/at32_sdio.c.

◆ command_rsp6_error()

sd_error_status_type command_rsp6_error | ( | uint8_t | cmd,
 |  | uint16_t * | prca
 | ) |  |

checks for error conditions for r6 (rca) response.

Parameters
cmd | the sent command index.
prca | pointer to the variable that will contain the sd card relative address rca.
Return values
sd_error_status_type sd card error code.

Definition at line 2154 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_init().

◆ command_rsp7_error()

sd_error_status_type command_rsp7_error ( void )

checks for error conditions for R7 response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1898 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ convert_from_bytes_to_power_of_two()

uint8_t convert_from_bytes_to_power_of_two ( uint16_t number_of_bytes )

converts the number of bytes in power of two and returns the power.

Parameters
number_of_bytes number of bytes.
Return values
none

Definition at line 2683 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ fatfs_test()

static error_status fatfs_test ( void )
static

fatfs file read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 99 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 203 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1651 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1698 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_switch()

sd_error_status_type mmc_switch | ( | uint8_t | set,
 |  | uint8_t | index,
 |  | uint8_t | value
 | ) |  |

switch mmc card speed to high speed

Parameters
set | new state of the sdio wide bus mode.
index | offset.
value | expect speed.
Return values
sd_error_status_type sd card error code.

Definition at line 2289 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_wide_bus_operation_config(), and speed_change().

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )
static

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ scr_find()

sd_error_status_type scr_find ( void )

find the sd card scr register value.

Return values
sd_error_status_type sd card error code.

Definition at line 2505 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1186 of file sdio_fatfs/src/at32_sdio.c.

Referenced by __align(), and sd_single_block_test().

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1365 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_single_block_test(), and sd_write_disk().

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1028 of file sdio_fatfs/src/at32_sdio.c.

◆ sd_bus_wide_enable()

sd_error_status_type sd_bus_wide_enable ( confirm_state new_state )

enable or disable the sdio wide bus mode.

Parameters
new_state new state of the sdio wide bus mode. (true or false)
Return values
sd_error_status_type sd card error code.

Definition at line 2220 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_wide_bus_operation_config().

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 530 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 415 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 805 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 784 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2704 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 71 of file sdio_fatfs/src/at32_sdio.c.

Referenced by disk_initialize(), main(), and sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1787 of file sdio_fatfs/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1275 of file sdio_fatfs/src/at32_sdio.c.

Referenced by __align(), and sd_multiple_blocks_test().

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1487 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_write_disk().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 401 of file sdio_fatfs/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 201 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2487 of file sdio_fatfs/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2450 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_switch()

sd_error_status_type sd_switch | ( | uint32_t | mode,
 |  | uint32_t | group,
 |  | uint8_t | value,
 |  | uint8_t * | rsp
 | ) |  |

switch sd card speed to high speed

Parameters
mode | polling mode or dma mode
group | selected group
value | wanted speed
rsp | switch status
Return values
sd_error_status_type sd card error code.

Definition at line 2340 of file sdio_fatfs/src/at32_sdio.c.

Referenced by speed_change().

◆ sd_test_error()

static void sd_test_error ( void )
static

led2 on off every 300ms for sd test failed.

Parameters
none
Return values
none

Definition at line 74 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 741 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test(), sd_init(), sd_multiple_blocks_test(), and sd_single_block_test().

◆ SDIO1_IRQHandler()

void SDIO1_IRQHandler ( void )

sdio1 isr.

Parameters
none.
Return values
none.

Definition at line 1767 of file sdio_fatfs/src/at32_sdio.c.

◆ SDIO2_IRQHandler()

void SDIO2_IRQHandler ( void )

sdio2 isr.

Parameters
none.
Return values
none.

Definition at line 1777 of file sdio_fatfs/src/at32_sdio.c.

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 186 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_data_send()

sd_error_status_type sdio_command_data_send | ( | sdio_command_struct_type * | sdio_cmd_init_t,
 |  | sdio_data_struct_type * | sdio_data_init_t,
 |  | uint32_t * | buf
 | ) |  |

read data from or write data to sd card.

Parameters
sdio_cmd_init_struct | pointer to sdio_command_struct_type structure.
sdio_data_init_struct | pointer to sdio_data_struct_type structure.
buf | pointer to data buffer read or write.
Return values
sd_error_status_type sd card error code.

Definition at line 828 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ speed_change()

sd_error_status_type speed_change ( uint8_t speed )

set bus speed

Parameters
speed 0,normal speed; 1,high speed.
Return values
sd_error_status_type sd card error code.

Definition at line 2619 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

Variable Documentation

◆ card_type

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 41 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_info_get(), sd_card_init(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_wide_bus_operation_config(), and speed_change().

◆ cid_table

uint32_t cid_table[4]
static

Definition at line 42 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ csd_table

uint32_t csd_table[4]
static

Definition at line 42 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ device_mode

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 43 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_device_mode_set(), and sdio_command_data_send().

◆ file

FIL file

Definition at line 41 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ fs

FATFS fs

Definition at line 40 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ rca

uint32_t rca = 0
static

Definition at line 42 of file sdio_fatfs/src/at32_sdio.c.

Referenced by check_card_programming(), sd_card_info_get(), sd_card_init(), sd_mult_blocks_write(), and sd_status_send().

◆ sd_card_info [1/2]

sd_card_info_struct_type sd_card_info
extern

Definition at line 46 of file sd_mmc_card/src/at32_sdio.c.

Referenced by scr_find(), sd_bus_wide_enable(), sd_init(), and speed_change().

◆ sd_card_info [2/2]

sd_card_info_struct_type sd_card_info

Definition at line 47 of file sdio_fatfs/src/at32_sdio.c.

Referenced by disk_ioctl(), main(), scr_find(), sd_bus_wide_enable(), sd_init(), show_card_info(), and speed_change().

◆ sdio_command_init_struct

sdio_command_struct_type sdio_command_init_struct

Definition at line 38 of file sdio_fatfs/src/at32_sdio.c.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), and sd_switch().

◆ sdio_data_init_struct

sdio_data_struct_type sdio_data_init_struct

Definition at line 39 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ stop_flag

uint8_t stop_flag = 0
static

Definition at line 44 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_command_data_send().

◆ transfer_end

volatile uint8_t transfer_end = 0

Definition at line 46 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_error

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 45 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ work

BYTE work[FF_MAX_SS]

Definition at line 42 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().


AT32F413 Firmwary Library: SDIO_sdio_fatfs_instance_definition

Macros
SDIO_sdio_fatfs_instance_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define SDIOx SDIO1

Detailed Description

Macro Definition Documentation

◆ SDIOx

#define SDIOx SDIO1

Definition at line 49 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_command_index_definition

Macros
SDIO_sdio_fatfs_command_index_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Detailed Description

Macro Definition Documentation

◆ SD_CMD_ALL_SEND_CID

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 258 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 293 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 301 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 283 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 289 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 288 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 287 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 290 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 294 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 256 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 271 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 291 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 270 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 275 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 264 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 262 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 292 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 295 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 280 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 281 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 267 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 274 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 273 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 323 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 319 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 317 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 315 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 314 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 304 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 322 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 320 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 324 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 321 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 303 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 306 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 318 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 316 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 305 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 302 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 286 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 285 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 307 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 308 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 261 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 263 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 266 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 265 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 257 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 269 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 284 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 277 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 272 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 260 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 259 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 282 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 268 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 276 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 279 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 278 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_paremeters_definition

Macros
SDIO_sdio_fatfs_paremeters_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)

Detailed Description

Macro Definition Documentation

◆ NULL

#define NULL 0

sdio paremeters

Definition at line 337 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 339 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 340 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_FIFO_Address

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 341 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 338 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_response_definition

Macros
SDIO_sdio_fatfs_response_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ MMC_SWITCH_ERROR

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 372 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_0TO7BITS

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 402 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_16TO23BITS

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 404 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_24TO31BITS

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 405 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_8TO15BITS

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 403 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_ALLZERO

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 395 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_LOCKED

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 398 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 399 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 400 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 392 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_DATATIMEOUT

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 401 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFO

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 407 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 408 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 390 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 406 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 394 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 355 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 354 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 373 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 356 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 364 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 370 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 363 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 368 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 361 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 371 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 357 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 374 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 365 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 362 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 358 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 360 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 366 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 367 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 369 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 359 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_ERROR

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 381 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 380 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 379 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 388 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 386 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 387 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 397 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_STD_CAPACITY

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 391 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 393 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 389 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 396 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_command_class_definition

Macros
SDIO_sdio_fatfs_command_class_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ SD_CCCC_ERASE

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 423 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 421 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 422 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_cmd8_definition

Macros
SDIO_sdio_fatfs_cmd8_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

Detailed Description

Macro Definition Documentation

◆ SDIO_SEND_IF_COND

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 436 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_mmc_extend_definition

Macros
SDIO_sdio_fatfs_mmc_extend_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185

Detailed Description

Macro Definition Documentation

◆ EXT_CSD_BUS_WIDTH

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 461 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte

#define EXT_CSD_Clear_byte 0x2

Definition at line 451 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 456 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 454 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 455 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Command_set

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 449 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING

#define EXT_CSD_HS_TIMING 185

Definition at line 462 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit

#define EXT_CSD_Set_bit 0x1

Definition at line 450 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte

#define EXT_CSD_Write_byte 0x3

Definition at line 452 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_interrupt_flags_definition

Macros
SDIO_sdio_fatfs_interrupt_flags_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Detailed Description

Macro Definition Documentation

◆ SDIO_INTR_STS_READ_MASK

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:84
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:88
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:86
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:92

Definition at line 474 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:87

Definition at line 472 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_exported_functions

Functions
SDIO_sdio_fatfs_exported_functions
AT32F413_periph_examples » SDIO_sdio_fatfs

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Detailed Description

Function Documentation

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1644 of file sd_mmc_card/src/at32_sdio.c.

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1691 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1179 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1358 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1021 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 523 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 408 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 798 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 777 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2697 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 70 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1780 of file sd_mmc_card/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1268 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1480 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 394 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 194 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2480 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2443 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 734 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 179 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().


AT32F413 Firmwary Library: SPI_crc_transfer_polling

Macros | Functions | Variables
SPI_crc_transfer_polling
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | spi1_tx_buffer [32]
uint16_t | spi2_tx_buffer [32]
uint16_t | spi1_rx_buffer [32]
uint16_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
__IO uint16_t | crc1_value = 0
__IO uint16_t | crc2_value = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 37 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 62 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

Definition at line 113 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

Definition at line 167 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

Variable Documentation

◆ crc1_value

__IO uint16_t crc1_value = 0

Definition at line 49 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ crc2_value

__IO uint16_t crc2_value = 0

Definition at line 49 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ rx_index

uint32_t rx_index = 0

Definition at line 48 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi1_rx_buffer

uint16_t spi1_rx_buffer[32]

Definition at line 47 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi1_tx_buffer

uint16_t spi1_tx_buffer[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C, 0x0D0E, 0x0F10,
0x1112, 0x1314, 0x1516, 0x1718, 0x191A, 0x1B1C, 0x1D1E, 0x1F20,
0x2122, 0x2324, 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C, 0x3D3E, 0x3F40}

Definition at line 39 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint16_t spi2_rx_buffer[32]

Definition at line 47 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint16_t spi2_tx_buffer[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C, 0x5D5E, 0x5F60,
0x6162, 0x6364, 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C, 0x8D8E, 0x8F90}

Definition at line 43 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 50 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 50 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ tx_index

uint32_t tx_index = 0

Definition at line 48 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_fullduplex_polling

Macros | Functions | Variables
SPI_fullduplex_polling
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (uint16_t spi1_mode, uint16_t spi2_mode)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
volatile error_status | transfer_status4 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 37 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | bufferlength
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 63 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config | ( | uint16_t | spi1_mode,
 |  | uint16_t | spi2_mode
 | ) |  |
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

Definition at line 110 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

Definition at line 202 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

Variable Documentation

◆ rx_index

uint32_t rx_index = 0

Definition at line 49 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi1_rx_buffer

uint8_t spi1_rx_buffer[32]

Definition at line 48 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 40 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 48 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint8_t spi2_tx_buffer[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 44 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 39 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 50 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 50 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status3

volatile error_status transfer_status3 = ERROR

Definition at line 51 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status4

volatile error_status transfer_status4 = ERROR

Definition at line 51 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ tx_index

uint32_t tx_index = 0

Definition at line 49 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_halfduplex_interrupt

Macros | Functions | Variables
SPI_halfduplex_interrupt
AT32F413_periph_examples

Macros

#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 36 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

◆ BUFFERSIZE

#define BUFFERSIZE 32

Definition at line 42 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 58 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 13

Definition at line 111 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 152 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI1_IRQHandler()

void SPI1_IRQHandler ( void )

This function handles the spi1 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

Definition at line 146 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI2_IRQHandler()

void SPI2_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s receive data buffer full flag

Definition at line 163 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

Definition at line 78 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

Variable Documentation

◆ rx_index

volatile uint32_t rx_index = 0

Definition at line 45 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 40 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 44 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 38 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by spi_config().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 46 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ tx_index

volatile uint32_t tx_index = 0

Definition at line 45 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.


AT32F413 Firmwary Library: SPI_halfduplex_transceiver_switch

Macros | Functions | Variables
SPI_halfduplex_transceiver_switch
AT32F413_periph_examples

Macros

#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 36 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ BUFFERSIZE

#define BUFFERSIZE 32

Definition at line 44 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 62 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 13

Definition at line 115 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

< receive data buffer full interrupt

< transmit data buffer empty interrupt

Definition at line 156 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ SPI1_IRQHandler()

void SPI1_IRQHandler ( void )

This function handles the spi1 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

< receive data buffer full interrupt

Definition at line 148 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ SPI2_IRQHandler()

void SPI2_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

Definition at line 181 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

Definition at line 82 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

Variable Documentation

◆ rx_index

volatile uint32_t rx_index = 0

Definition at line 49 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi1_rx_buffer

uint8_t spi1_rx_buffer[32]

Definition at line 48 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main(), and SPI1_IRQHandler().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 40 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 48 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint8_t spi2_tx_buffer[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 44 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 39 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main(), and spi_config().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 50 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 50 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ tx_index

volatile uint32_t tx_index = 0

Definition at line 49 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_only_receive_mode_polling

Macros | Functions | Variables
SPI_only_receive_mode_polling
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 36 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 57 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 7

< gpio pins number 13

< gpio pins number 15

< gpio pins number 13

Definition at line 105 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

Definition at line 146 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

Variable Documentation

◆ rx_index

uint32_t rx_index = 0

Definition at line 44 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main(), SPI1_IRQHandler(), and SPI2_IRQHandler().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 39 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 43 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 38 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by spi_config().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 45 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ tx_index

uint32_t tx_index = 0

Definition at line 44 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_use_jtagpin_hardwarecs_dma

Macros | Functions | Variables
SPI_use_jtagpin_hardwarecs_dma
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
__IO uint8_t | tx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 36 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 56 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< jtag-dp disabled and sw-dp enabled

< spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb6)

< spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb0)

< gpio pins number 3

< gpio pins number 5

< gpio pins number 15

< gpio pins number 13

< gpio pins number 14

< gpio pins number 12

Definition at line 124 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< dma1 channel4 full data transfer flag

Definition at line 177 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

Variable Documentation

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 38 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and SPI1_IRQHandler().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 42 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and spi_config().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 44 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ tx_index

__IO uint8_t tx_index = 0

Definition at line 43 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), SPI1_IRQHandler(), and SPI2_IRQHandler().


AT32F413 Firmwary Library: SPI_w25q_flash

Modules | Macros | Functions | Variables
SPI_w25q_flash
AT32F413_periph_examples

Modules

SPI_flash_cs_pin_definition
SPI_flash_id_definition
SPI_flash_operation_definition
SPI_flash_exported_functions

Macros

#define | SPI_TRANS_DMA
#define | FLASH_TEST_ADDR 0x1000
#define | BUF_SIZE 0x256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | tx_data_fill (void)
transfer data fill. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...
void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Variables

uint8_t | tx_buffer [0x256]
uint8_t | rx_buffer [0x256]
volatile error_status | transfer_status = ERROR
uint8_t | spiflash_sector_buf [SPIF_SECTOR_SIZE]

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 0x256

Definition at line 38 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

◆ FLASH_TEST_ADDR

#define FLASH_TEST_ADDR 0x1000

Definition at line 37 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

◆ SPI_TRANS_DMA

#define SPI_TRANS_DMA

Definition at line 44 of file spi_flash.h.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 67 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ spi_byte_read()

uint8_t spi_byte_read ( void )

read a byte to flash

Parameters
none
Return values
flash return data

Definition at line 502 of file spi_flash.c.

Referenced by spiflash_read_id(), and spiflash_read_sr1().

◆ spi_byte_write()

uint8_t spi_byte_write ( uint8_t data )

write a byte to flash

Parameters
data data to write
Return values
flash return data

Definition at line 485 of file spi_flash.c.

Referenced by spi_byte_read(), spiflash_page_write(), spiflash_read(), spiflash_read_id(), spiflash_read_sr1(), spiflash_sector_erase(), and spiflash_write_enable().

◆ spi_bytes_read()

void spi_bytes_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

read data continuously

Parameters
pbuffer | buffer to save data
length | buffer length
Return values
none

Definition at line 366 of file spi_flash.c.

Referenced by spiflash_read().

◆ spi_bytes_write()

void spi_bytes_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

write data continuously

Parameters
pbuffer | the pointer for data buffer
length | buffer length
Return values
none

Definition at line 301 of file spi_flash.c.

Referenced by spiflash_page_write().

◆ spiflash_init()

void spiflash_init ( void )

spi configuration.

Parameters
none
Return values
none

Definition at line 42 of file spi_flash.c.

Referenced by main().

◆ spiflash_page_write()

void spiflash_page_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write a page data

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 270 of file spi_flash.c.

Referenced by spiflash_write_nocheck().

◆ spiflash_read()

void spiflash_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | read_addr,
 |  | uint32_t | length
 | ) |  |

read data from flash

Parameters
pbuffer | the pointer for data buffer
read_addr | the address where the data is read
length | buffer length
Return values
none

Definition at line 185 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_read_id()

uint16_t spiflash_read_id ( void )

read device id

Parameters
none
Return values
device id

Definition at line 466 of file spi_flash.c.

Referenced by main().

◆ spiflash_read_sr1()

uint8_t spiflash_read_sr1 ( void )

read sr1 register

Parameters
none
Return values
none

Definition at line 439 of file spi_flash.c.

Referenced by spiflash_wait_busy().

◆ spiflash_sector_erase()

void spiflash_sector_erase ( uint32_t erase_addr )

erase a sector data

Parameters
erase_addr sector address to erase
Return values
none

Definition at line 201 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_wait_busy()

void spiflash_wait_busy ( void )

wait program done

Parameters
none
Return values
none

Definition at line 429 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write()

void spiflash_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data to flash

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 97 of file spi_flash.c.

Referenced by main().

◆ spiflash_write_enable()

void spiflash_write_enable ( void )

enable write operation

Parameters
none
Return values
none

Definition at line 454 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write_nocheck()

void spiflash_write_nocheck | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data without check

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 222 of file spi_flash.c.

Referenced by spiflash_write().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ tx_data_fill()

void tx_data_fill ( void )

transfer data fill.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

Variable Documentation

◆ rx_buffer

uint8_t rx_buffer[0x256]

Definition at line 41 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ spiflash_sector_buf

uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]

Definition at line 35 of file spi_flash.c.

Referenced by spiflash_write().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 42 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ tx_buffer

uint8_t tx_buffer[0x256]

Definition at line 40 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main(), and tx_data_fill().


AT32F413 Firmwary Library: SPI_flash_cs_pin_definition

Macros
SPI_flash_cs_pin_definition
AT32F413_periph_examples » SPI_w25q_flash

Macros

#define | FLASH_CS_HIGH() gpio_bits_set(GPIOB, GPIO_PINS_12)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOB, GPIO_PINS_12)

Detailed Description

Macro Definition Documentation

◆ FLASH_CS_HIGH

#define FLASH_CS_HIGH ( ) gpio_bits_set(GPIOB, GPIO_PINS_12)

Definition at line 50 of file spi_flash.h.

◆ FLASH_CS_LOW

#define FLASH_CS_LOW ( ) gpio_bits_reset(GPIOB, GPIO_PINS_12)

Definition at line 51 of file spi_flash.h.


AT32F413 Firmwary Library: SPI_flash_id_definition

Macros
SPI_flash_id_definition
AT32F413_periph_examples » SPI_w25q_flash

Macros

#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17

Detailed Description

Macro Definition Documentation

◆ W25Q128

#define W25Q128 0xEF17

Definition at line 69 of file spi_flash.h.

◆ W25Q16

#define W25Q16 0xEF14

Definition at line 65 of file spi_flash.h.

◆ W25Q32

#define W25Q32 0xEF15

Definition at line 66 of file spi_flash.h.

◆ W25Q64

#define W25Q64 0xEF16

Definition at line 67 of file spi_flash.h.

◆ W25Q80

#define W25Q80 0xEF13

Definition at line 64 of file spi_flash.h.


AT32F413 Firmwary Library: SPI_flash_operation_definition

Macros
SPI_flash_operation_definition
AT32F413_periph_examples » SPI_w25q_flash

Macros

#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5

Detailed Description

Macro Definition Documentation

◆ FLASH_SPI_DUMMY_BYTE

#define FLASH_SPI_DUMMY_BYTE 0xA5

Definition at line 107 of file spi_flash.h.

◆ SPIF_BLOCKERASE

#define SPIF_BLOCKERASE 0xD8

Definition at line 99 of file spi_flash.h.

◆ SPIF_CHIP_SIZE

#define SPIF_CHIP_SIZE 0x1000000

Definition at line 79 of file spi_flash.h.

◆ SPIF_CHIPERASE

#define SPIF_CHIPERASE 0xC7

Definition at line 101 of file spi_flash.h.

◆ SPIF_DEVICEID

#define SPIF_DEVICEID 0xAB

Definition at line 104 of file spi_flash.h.

◆ SPIF_FASTREADDATA

#define SPIF_FASTREADDATA 0x0B

Definition at line 95 of file spi_flash.h.

◆ SPIF_FASTREADDUAL

#define SPIF_FASTREADDUAL 0x3B

Definition at line 96 of file spi_flash.h.

◆ SPIF_JEDECDEVICEID

#define SPIF_JEDECDEVICEID 0x9F

Definition at line 106 of file spi_flash.h.

◆ SPIF_MANUFACTDEVICEID

#define SPIF_MANUFACTDEVICEID 0x90

Definition at line 105 of file spi_flash.h.

◆ SPIF_PAGE_SIZE

#define SPIF_PAGE_SIZE 256

Definition at line 81 of file spi_flash.h.

◆ SPIF_PAGEPROGRAM

#define SPIF_PAGEPROGRAM 0x02

Definition at line 97 of file spi_flash.h.

◆ SPIF_POWERDOWN

#define SPIF_POWERDOWN 0xB9

Definition at line 102 of file spi_flash.h.

◆ SPIF_READDATA

#define SPIF_READDATA 0x03

Definition at line 94 of file spi_flash.h.

◆ SPIF_READSTATUSREG1

#define SPIF_READSTATUSREG1 0x05

Definition at line 86 of file spi_flash.h.

◆ SPIF_READSTATUSREG2

#define SPIF_READSTATUSREG2 0x35

Definition at line 89 of file spi_flash.h.

◆ SPIF_READSTATUSREG3

#define SPIF_READSTATUSREG3 0x15

Definition at line 92 of file spi_flash.h.

◆ SPIF_RELEASEPOWERDOWN

#define SPIF_RELEASEPOWERDOWN 0xAB

Definition at line 103 of file spi_flash.h.

◆ SPIF_SECTOR_SIZE

#define SPIF_SECTOR_SIZE 4096

Definition at line 80 of file spi_flash.h.

◆ SPIF_SECTORERASE

#define SPIF_SECTORERASE 0x20

Definition at line 100 of file spi_flash.h.

◆ SPIF_WRITEDISABLE

#define SPIF_WRITEDISABLE 0x04

Definition at line 84 of file spi_flash.h.

◆ SPIF_WRITEENABLE

#define SPIF_WRITEENABLE 0x06

Definition at line 83 of file spi_flash.h.

◆ SPIF_WRITESTATUSREG1

#define SPIF_WRITESTATUSREG1 0x01

Definition at line 87 of file spi_flash.h.

◆ SPIF_WRITESTATUSREG2

#define SPIF_WRITESTATUSREG2 0x31

Definition at line 90 of file spi_flash.h.

◆ SPIF_WRITESTATUSREG3

#define SPIF_WRITESTATUSREG3 0x11

Definition at line 93 of file spi_flash.h.


AT32F413 Firmwary Library: SPI_flash_exported_functions

Functions
SPI_flash_exported_functions
AT32F413_periph_examples » SPI_w25q_flash

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Detailed Description

Function Documentation

◆ spi_byte_read()

uint8_t spi_byte_read ( void )

read a byte to flash

Parameters
none
Return values
flash return data

Definition at line 502 of file spi_flash.c.

Referenced by spiflash_read_id(), and spiflash_read_sr1().

◆ spi_byte_write()

uint8_t spi_byte_write ( uint8_t data )

write a byte to flash

Parameters
data data to write
Return values
flash return data

Definition at line 485 of file spi_flash.c.

Referenced by spi_byte_read(), spiflash_page_write(), spiflash_read(), spiflash_read_id(), spiflash_read_sr1(), spiflash_sector_erase(), and spiflash_write_enable().

◆ spi_bytes_read()

void spi_bytes_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

read data continuously

Parameters
pbuffer | buffer to save data
length | buffer length
Return values
none

Definition at line 366 of file spi_flash.c.

Referenced by spiflash_read().

◆ spi_bytes_write()

void spi_bytes_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

write data continuously

Parameters
pbuffer | the pointer for data buffer
length | buffer length
Return values
none

Definition at line 301 of file spi_flash.c.

Referenced by spiflash_page_write().

◆ spiflash_init()

void spiflash_init ( void )

spi configuration.

Parameters
none
Return values
none

Definition at line 42 of file spi_flash.c.

Referenced by main().

◆ spiflash_page_write()

void spiflash_page_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write a page data

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 270 of file spi_flash.c.

Referenced by spiflash_write_nocheck().

◆ spiflash_read()

void spiflash_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | read_addr,
 |  | uint32_t | length
 | ) |  |

read data from flash

Parameters
pbuffer | the pointer for data buffer
read_addr | the address where the data is read
length | buffer length
Return values
none

Definition at line 185 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_read_id()

uint16_t spiflash_read_id ( void )

read device id

Parameters
none
Return values
device id

Definition at line 466 of file spi_flash.c.

Referenced by main().

◆ spiflash_read_sr1()

uint8_t spiflash_read_sr1 ( void )

read sr1 register

Parameters
none
Return values
none

Definition at line 439 of file spi_flash.c.

Referenced by spiflash_wait_busy().

◆ spiflash_sector_erase()

void spiflash_sector_erase ( uint32_t erase_addr )

erase a sector data

Parameters
erase_addr sector address to erase
Return values
none

Definition at line 201 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_wait_busy()

void spiflash_wait_busy ( void )

wait program done

Parameters
none
Return values
none

Definition at line 429 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write()

void spiflash_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data to flash

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 97 of file spi_flash.c.

Referenced by main().

◆ spiflash_write_enable()

void spiflash_write_enable ( void )

enable write operation

Parameters
none
Return values
none

Definition at line 454 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write_nocheck()

void spiflash_write_nocheck | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data without check

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 222 of file spi_flash.c.

Referenced by spiflash_write().


AT32F413 Firmwary Library: SRAM_extend_sram

Functions
SRAM_extend_sram
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | extend_sram (void)
to extend sram size More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ extend_sram()

void extend_sram ( void )

to extend sram size

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/sram/extend_sram/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/sram/extend_sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.


AT32F413 Firmwary Library: TMR_6_steps

Functions | Variables
TMR_6_steps
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | systick_configuration (void)
configures the systick. More...
int | main (void)
main function. More...
void | TMR1_TRG_HALL_TMR11_IRQHandler (void)
this function handles tmr1 trigger and hall interrupts requests. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint32_t | step = 1

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

< tmr interrupt hall

Definition at line 51 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ systick_configuration()

void systick_configuration ( void )

configures the systick.

Parameters
none
Return values
none

Definition at line 183 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ TMR1_TRG_HALL_TMR11_IRQHandler()

void TMR1_TRG_HALL_TMR11_IRQHandler ( void )

this function handles tmr1 trigger and hall interrupts requests.

Parameters
none
Return values
none

< tmr flag hall

Definition at line 200 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main(), and systick_configuration().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ step

__IO uint32_t step = 1

Definition at line 41 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_brkdt_config_struct

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 37 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().


AT32F413 Firmwary Library: TMR_7_pwm_output

Functions | Variables
TMR_7_pwm_output
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0
uint16_t | channel4_pulse = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

Definition at line 48 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

Variable Documentation

◆ channel1_pulse

uint16_t channel1_pulse = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel2_pulse

uint16_t channel2_pulse = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel3_pulse

uint16_t channel3_pulse = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel4_pulse

uint16_t channel4_pulse = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 40 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 37 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_cascade_synchro

Functions | Variables
TMR_cascade_synchro
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

Definition at line 44 of file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

Variable Documentation

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 37 of file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_complementary_signals

Functions | Variables
TMR_complementary_signals
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

Definition at line 49 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

Variable Documentation

◆ channel1_pulse

uint16_t channel1_pulse = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ channel2_pulse

uint16_t channel2_pulse = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ channel3_pulse

uint16_t channel3_pulse = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ tmr_brkdt_config_struct

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 37 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_dma

Functions | Variables
TMR_dma
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0, 0, 0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 15

Definition at line 49 of file project/at_start_f413/examples/tmr/dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ src_buffer

uint16_t src_buffer[3] = {0, 0, 0}

Definition at line 42 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 37 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_dma_burst

Functions | Variables
TMR_dma_burst
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0x0FFF, 0x0000, 0x0555}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 49 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ src_buffer

uint16_t src_buffer[3] = {0x0FFF, 0x0000, 0x0555}

Definition at line 42 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 37 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_encoder_tmr2

Functions | Variables
TMR_encoder_tmr2
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | delay (uint32_t time)
delay function More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint32_t | counter

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ delay()

void delay ( uint32_t time )

delay function

Parameters
time number of time to delay
Return values
none

Definition at line 118 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 47 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

Variable Documentation

◆ counter

uint32_t counter

Definition at line 40 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_external_clock

Functions | Variables
TMR_external_clock
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 7

Definition at line 46 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 38 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_hall_xor_tmr2

Functions | Variables
TMR_hall_xor_tmr2
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles TMR2 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< tmr interrupt trigger

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

Definition at line 46 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles TMR2 trigger exception.

Parameters
none
Return values
none

< tmr flag trigger

< gpio pins number 8

< tmr flag trigger

Definition at line 137 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 38 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.


AT32F413 Firmwary Library: TMR_hang_mode

Functions | Variables
TMR_hang_mode
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

Definition at line 46 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 38 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_input_capture

Functions | Variables
TMR_input_capture
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 trigger exception. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_input_config_type tmr_input_config_struct
__IO uint32_t | tmr3freq = 0
__IO uint32_t | sys_counter = 0
__IO uint16_t | capturenumber = 0
__IO uint16_t | ch3readvalue1 = 0
__IO uint16_t | ch3readvalue2 = 0
__IO uint32_t | capture = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 7

< tmr interrupt channel 2

Definition at line 89 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 trigger exception.

Parameters
none
Return values
none

< tmr flag channel 2

< tmr flag channel 2

Definition at line 51 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file app_led3_toggle/src/usart.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

Variable Documentation

◆ capture

__IO uint32_t capture = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ capturenumber

__IO uint16_t capturenumber = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ch3readvalue1

__IO uint16_t ch3readvalue1 = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ch3readvalue2

__IO uint16_t ch3readvalue2 = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main(), and TMR3_GLOBAL_IRQHandler().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main().

◆ sys_counter

__IO uint32_t sys_counter = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

◆ tmr3freq

__IO uint32_t tmr3freq = 0

Definition at line 40 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 38 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_oc_high

Functions | Variables
TMR_oc_high
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles tmr2 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

Definition at line 138 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 1000

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 500

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 250

Definition at line 40 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 125

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 37 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by crm_adc_clock_div_set(), crm_clocks_freq_get(), crm_usb_clock_div_set(), main(), rtc_divider_set(), and system_core_clock_update().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().


AT32F413 Firmwary Library: TMR_oc_low

Functions | Variables
TMR_oc_low
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...
void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the gpioc pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles tmr2 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

Definition at line 138 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 1000

Definition at line 37 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 500

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 250

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 125

Definition at line 40 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_oc_toggle_tmr3

Functions | Variables
TMR_oc_toggle_tmr3
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

uint32_t | capture = 0
tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
__IO uint16_t | ch3_val = 8192
__IO uint16_t | ch4_val = 4096
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

Definition at line 91 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ nvic_configuration()

void nvic_configuration ( void )

configures the nested vectored interrupt controller.

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

< tmr flag channel 3

< tmr flag channel 3

< tmr flag channel 4

< tmr flag channel 4

Definition at line 145 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

Variable Documentation

◆ capture

uint32_t capture = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ch1_val

__IO uint16_t ch1_val = 32768

Definition at line 37 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ch2_val

__IO uint16_t ch2_val = 16384

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ch3_val

__IO uint16_t ch3_val = 8192

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ch4_val

__IO uint16_t ch4_val = 4096

Definition at line 40 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_oc_toggle_tmr9

Functions | Variables
TMR_oc_toggle_tmr9
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_BRK_TMR9_IRQHandler (void)
this function handles TMR9 global interrupt request. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr9 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

uint16_t | capture = 0
tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr9 pins.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

Definition at line 84 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ nvic_configuration()

void nvic_configuration ( void )

configures the nested vectored interrupt controller.

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ TMR1_BRK_TMR9_IRQHandler()

void TMR1_BRK_TMR9_IRQHandler ( void )

this function handles TMR9 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

Definition at line 143 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

Variable Documentation

◆ capture

uint16_t capture = 0

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

Referenced by TMR1_BRK_TMR9_IRQHandler().

◆ ch1_val

__IO uint16_t ch1_val = 32768

Definition at line 37 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ ch2_val

__IO uint16_t ch2_val = 16384

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_one_cycle

Functions | Variables
TMR_one_cycle
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
tmr_input_config_type tmr_ic_init_structure
uint16_t div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 7

< gpio pins number 6

Definition at line 48 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

Variable Documentation

◆ div_value

uint16_t div_value = 0

Definition at line 38 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ tmr_ic_init_structure

tmr_input_config_type tmr_ic_init_structure

Definition at line 37 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_parallel_synchro

Functions | Variables
TMR_parallel_synchro
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

Definition at line 46 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 88 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

Variable Documentation

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_input

Functions | Variables
TMR_pwm_input
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | ic2value = 0
tmr_input_config_type tmr_ic_init_structure
__IO uint16_t | duty_cycle = 0
__IO uint32_t | frequency = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 7

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 2

Definition at line 82 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 2

Definition at line 143 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

Variable Documentation

◆ duty_cycle

__IO uint16_t duty_cycle = 0

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ frequency

__IO uint32_t frequency = 0

Definition at line 39 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ ic2value

__IO uint16_t ic2value = 0

Definition at line 39 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ tmr_ic_init_structure

tmr_input_config_type tmr_ic_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_input_dma

Macros | Functions | Variables
TMR_pwm_input_dma
AT32F413_periph_examples

Macros

#define | TMR1_C1DT_ADDRESS 0x40012C34
#define | TMR1_C2DT_ADDRESS 0x40012C38
#define | SAMPLING_NUM 1000

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
void | DMA1_Channel2_IRQHandler (void)
int | main (void)
main function. More...

Variables

tmr_input_config_type tmr_ic_init_structure
dma_init_type dma_init_structure
__IO uint16_t | buffer_ch1 [1000]
__IO uint16_t | buffer_ch2 [1000]
__IO uint32_t | frequency = 0
__IO float | duty_cycle = 0
uint32_t | freq_result
float | duty_result

Detailed Description

Macro Definition Documentation

◆ SAMPLING_NUM

#define SAMPLING_NUM 1000

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ TMR1_C1DT_ADDRESS

#define TMR1_C1DT_ADDRESS 0x40012C34

Definition at line 37 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ TMR1_C2DT_ADDRESS

#define TMR1_C2DT_ADDRESS 0x40012C38

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 101 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

< dma1 channel2 full data transfer flag

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 82 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 118 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

Variable Documentation

◆ buffer_ch1

__IO uint16_t buffer_ch1[1000]

Definition at line 45 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ buffer_ch2

__IO uint16_t buffer_ch2[1000]

Definition at line 46 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ dma_init_structure

dma_init_type dma_init_structure

Definition at line 43 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ duty_cycle

__IO float duty_cycle = 0

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ duty_result

float duty_result

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ freq_result

uint32_t freq_result

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ frequency

__IO uint32_t frequency = 0

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_ic_init_structure

tmr_input_config_type tmr_ic_init_structure

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_output_simulate

Functions | Variables
TMR_pwm_output_simulate
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

uint16_t | capture = 0
tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 40961
uint16_t | ch2_val = 27309
uint16_t | ch3_val = 13654
uint16_t | ch4_val = 6826
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

Definition at line 85 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

< gpio pins number 9

Definition at line 140 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

Variable Documentation

◆ capture

uint16_t capture = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ ch1_val

uint16_t ch1_val = 40961

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 27309

Definition at line 39 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 13654

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 6826

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_output_tmr10

Functions | Variables
TMR_pwm_output_tmr10
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 250
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 250

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 39 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_output_tmr3

Functions | Variables
TMR_pwm_output_tmr3
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 333
uint16_t | ch2_val = 249
uint16_t | ch3_val = 166
uint16_t | ch4_val = 83
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 333

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 249

Definition at line 39 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 166

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 83

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_timer_base

Functions | Variables
TMR_timer_base
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | clkout_config (void)
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ clkout_config()

void clkout_config ( void )

< gpio pins number 8

Definition at line 38 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt overflow

Definition at line 83 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

this function handles timer1 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 68 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 36 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_tmr1_synchro

Functions | Variables
TMR_tmr1_synchro
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 8

< gpio pins number 6

Definition at line 46 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

Variable Documentation

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_tmr2_32bit

Functions | Variables
TMR_tmr2_32bit
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint32_t | ch1_val = 0x7FFFF
uint32_t | ch2_val = 0x3FFFF
uint32_t | ch3_val = 0x1FFFF
uint32_t | ch4_val = 0xFFFF

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

Definition at line 51 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint32_t ch1_val = 0x7FFFF

Definition at line 38 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ch2_val

uint32_t ch2_val = 0x3FFFF

Definition at line 39 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ch3_val

uint32_t ch3_val = 0x1FFFF

Definition at line 40 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ch4_val

uint32_t ch4_val = 0xFFFF

Definition at line 41 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 36 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_half_duplex

Macros | Functions | Variables
USART_half_duplex
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart half-duplex transfer: usart2 -> usart3"
uint8_t | usart3_tx_buffer [] = "usart half-duplex transfer: usart3 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | data_count

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 36 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 37 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 38 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 99 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 118 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

Definition at line 51 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

Variable Documentation

◆ data_count

uint8_t data_count

Definition at line 44 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 42 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart half-duplex transfer: usart2 -> usart3"

Definition at line 40 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 43 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart half-duplex transfer: usart3 -> usart2"

Definition at line 41 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_hw_flow_control

Macros | Functions | Variables
USART_hw_flow_control
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | rx_buffer [16]
uint8_t | data_count

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 16

Definition at line 36 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart transmit data buffer empty flag

Definition at line 85 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 1

< gpio pins number 3

< gpio pins number 0

Definition at line 46 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Referenced by main().

Variable Documentation

◆ data_count

uint8_t data_count

Definition at line 39 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Referenced by main().

◆ rx_buffer

uint8_t rx_buffer[16]

Definition at line 38 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_idle_detection

Functions
USART_idle_detection
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 84 of file project/at_start_f413/examples/usart/idle_detection/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart idle flag

Definition at line 139 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< usart idle interrupt

Definition at line 41 of file project/at_start_f413/examples/usart/idle_detection/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_interrupt

Macros | Functions | Variables
USART_interrupt
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_counter = 0x00
volatile uint8_t | usart3_tx_counter = 0x00
volatile uint8_t | usart2_rx_counter = 0x00
volatile uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 36 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 37 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 38 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 127 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 61 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 146 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 74 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 140 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 100 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

Definition at line 149 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ USART3_IRQHandler()

void USART3_IRQHandler ( void )

this function handles usart3 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

Definition at line 187 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

< usart transmit data buffer empty interrupt

< usart transmit data buffer empty interrupt

Definition at line 56 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 42 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_rx_counter

volatile uint8_t usart2_rx_counter = 0x00

Definition at line 46 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 40 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 48 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_counter

volatile uint8_t usart2_tx_counter = 0x00

Definition at line 44 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 43 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_rx_counter

volatile uint8_t usart3_rx_counter = 0x00

Definition at line 47 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 41 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 49 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_counter

volatile uint8_t usart3_tx_counter = 0x00

Definition at line 45 of file project/at_start_f413/examples/usart/interrupt/src/main.c.


AT32F413 Firmwary Library: USART_irda

Functions
USART_irda
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/usart/irda/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

Definition at line 41 of file project/at_start_f413/examples/usart/irda/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_polling

Macros | Functions | Variables
USART_polling
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 36 of file project/at_start_f413/examples/usart/polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 37 of file project/at_start_f413/examples/usart/polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 38 of file project/at_start_f413/examples/usart/polling/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 116 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 135 of file project/at_start_f413/examples/usart/polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

Definition at line 56 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 42 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_rx_counter

uint8_t usart2_rx_counter = 0x00

Definition at line 46 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 40 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 48 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_counter

uint8_t usart2_tx_counter = 0x00

Definition at line 44 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 43 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_rx_counter

uint8_t usart3_rx_counter = 0x00

Definition at line 47 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main(), and USART3_IRQHandler().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 41 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 49 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart3_tx_counter

uint8_t usart3_tx_counter = 0x00

Definition at line 45 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main(), and USART3_IRQHandler().


AT32F413 Firmwary Library: USART_printf

Functions | Variables
USART_printf
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

__IO uint32_t time_cnt = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/printf/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

Variable Documentation

◆ time_cnt

__IO uint32_t time_cnt = 0

Definition at line 36 of file project/at_start_f413/examples/usart/printf/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_receiver_mute

Macros | Functions | Variables
USART_receiver_mute
AT32F413_periph_examples

Macros

#define | BUFFER_SIZE 7
#define | MATCH_ID_VAL 0x81
#define | ERROR_ID_VAL 0x82
#define | DATA1_VAL 0x7F
#define | DATA2_VAL 0x7A
#define | DATA3_VAL 0x7B
#define | DATA4_VAL 0x7C

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }
uint8_t | usart3_rx_buffer [7]
uint8_t | tx_counter = 0
uint8_t | rx_counter = 0

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 7

Definition at line 36 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA1_VAL

#define DATA1_VAL 0x7F

Definition at line 39 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA2_VAL

#define DATA2_VAL 0x7A

Definition at line 40 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA3_VAL

#define DATA3_VAL 0x7B

Definition at line 41 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA4_VAL

#define DATA4_VAL 0x7C

Definition at line 42 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ ERROR_ID_VAL

#define ERROR_ID_VAL 0x82

Definition at line 38 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ MATCH_ID_VAL

#define MATCH_ID_VAL 0x81

Definition at line 37 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart transmit data complete flag

Definition at line 108 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ USART3_IRQHandler()

void USART3_IRQHandler ( void )

this function handles usart3 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 141 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 11

< usart receive data buffer full interrupt

Definition at line 54 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().

Variable Documentation

◆ rx_counter

uint8_t rx_counter = 0

Definition at line 47 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by USART3_IRQHandler().

◆ tx_counter

uint8_t tx_counter = 0

Definition at line 46 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }

Definition at line 44 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[7]

Definition at line 45 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: F413_USART_rs485

Macros | Functions | Variables
F413_USART_rs485
AT32F413_periph_examples

Macros

#define | RS485_BAUDRATE 9600
#define | RS485_BUFFER_SIZE 128

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | rs485_config (void)
rs485 configiguration. More...
static void | rs485_send_data (u8 *buf, u8 cnt)
rs485 send data More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
usart2 interrupt handler More...

Variables

uint8_t | rs485_buffer_rx [128]
uint8_t | rs485_buffer_rx_cnt = 0

Detailed Description

Macro Definition Documentation

◆ RS485_BAUDRATE

#define RS485_BAUDRATE 9600

Definition at line 36 of file project/at_start_f413/examples/usart/rs485/src/main.c.

◆ RS485_BUFFER_SIZE

#define RS485_BUFFER_SIZE 128

Definition at line 37 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart idle flag

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

Definition at line 112 of file project/at_start_f413/examples/usart/rs485/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ rs485_config()

static void rs485_config ( void )
static

rs485 configiguration.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 1

< gpio pins number 1

< usart receive data buffer full flag

< usart receive data buffer full interrupt

Definition at line 47 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main().

◆ rs485_send_data()

static void rs485_send_data | ( | u8 * | buf,
 |  | u8 | cnt
 | ) |  |
static

rs485 send data

Parameters
buf | pointer to the buffer that contain the data to be transferred.
cnt | size of buffer in bytes.
Return values
none

< gpio pins number 1

< usart transmit data buffer empty flag

< usart transmit data complete flag

< gpio pins number 1

Definition at line 96 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

usart2 interrupt handler

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 143 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Variable Documentation

◆ rs485_buffer_rx

uint8_t rs485_buffer_rx[128]

Definition at line 39 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main(), and USART2_IRQHandler().

◆ rs485_buffer_rx_cnt

uint8_t rs485_buffer_rx_cnt = 0

Definition at line 40 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main(), and USART2_IRQHandler().


AT32F413 Firmwary Library: USART_smartcard

Data Structures | Macros | Functions | Variables
USART_smartcard
AT32F413_periph_examples

Data Structures

struct sc_atr_type

Macros

#define | T0_PROTOCOL 0x00 /* t0 protocol */
#define | SETUP_LENGTH 20
#define | HIST_LENGTH 20
#define | SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
#define | SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
#define | SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EXINT9_5_IRQHandler (void)
this function handles external lines 9 to 5 interrupt request. More...
void | SC_USART_IRQHandler (void)
this function handles sc_usart global interrupt request. More...
void | usart_configuration (void)
config usart More...
uint8_t | sc_response_decode (__IO uint8_t *card)
decode the card atr response. More...
int | main (void)
main function. More...

Variables

sc_atr_type sc_a2r_struct
uint32_t | sc_baud_rate = 0
uint32_t | sc_clock_freq = 0
uint32_t | counter = 0
error_status atr_decode_status = ERROR
uint32_t | card_inserted = 0
uint32_t | card_protocol = 1
uint8_t | dst_buffer [50]

Detailed Description

Macro Definition Documentation

◆ HIST_LENGTH

#define HIST_LENGTH 20

Definition at line 39 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SC_F_DIV_D

#define SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Definition at line 43 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SC_RECEIVE_TIMEOUT

#define SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */

Definition at line 40 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SC_USART_DIV_VAL

#define SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */

Definition at line 42 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SETUP_LENGTH

#define SETUP_LENGTH 20

Definition at line 38 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ T0_PROTOCOL

#define T0_PROTOCOL 0x00 /* t0 protocol */

Definition at line 37 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ EXINT9_5_IRQHandler()

void EXINT9_5_IRQHandler ( void )

this function handles external lines 9 to 5 interrupt request.

Parameters
none
Return values
none

Definition at line 141 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 276 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ sc_response_decode()

uint8_t sc_response_decode ( __IO uint8_t * card )

decode the card atr response.

Parameters
card pointer to the buffer containing the card atr.
Return values
card protocol

Definition at line 200 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ SC_USART_IRQHandler()

void SC_USART_IRQHandler ( void )

this function handles sc_usart global interrupt request.

Parameters
none
Return values
none

< usart parity error flag

< usart receive data buffer full interrupt

< usart receive data buffer full flag

< usart receive data buffer full interrupt

Definition at line 164 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< usart parity error interrupt

Definition at line 73 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

Variable Documentation

◆ atr_decode_status

error_status atr_decode_status = ERROR

Definition at line 60 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ card_inserted

uint32_t card_inserted = 0

Definition at line 61 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by EXINT9_5_IRQHandler(), and main().

◆ card_protocol

uint32_t card_protocol = 1

Definition at line 61 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ counter

uint32_t counter = 0

Definition at line 59 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ dst_buffer

uint8_t dst_buffer[50]
Initial value:
= {
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1
}

Definition at line 62 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ sc_a2r_struct

sc_atr_type sc_a2r_struct

Definition at line 56 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ sc_baud_rate

uint32_t sc_baud_rate = 0

Definition at line 57 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by usart_configuration().

◆ sc_clock_freq

uint32_t sc_clock_freq = 0

Definition at line 58 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by usart_configuration().


AT32F413 Firmwary Library: sc_atr_type Struct Reference

Data Fields
sc_atr_type Struct Reference
AT32F413_periph_examples » USART_smartcard

Data Fields

uint8_t | ts
uint8_t | t0
uint8_t | t [20]
uint8_t | h [20]
uint8_t | tlength
uint8_t | hlength

Detailed Description

Definition at line 46 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Field Documentation

◆ h

uint8_t sc_atr_type::h[20]

Definition at line 51 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ hlength

uint8_t sc_atr_type::hlength

Definition at line 53 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ t

uint8_t sc_atr_type::t[20]

Definition at line 50 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ t0

uint8_t sc_atr_type::t0

Definition at line 49 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ tlength

uint8_t sc_atr_type::tlength

Definition at line 52 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ ts

uint8_t sc_atr_type::ts

Definition at line 48 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

The documentation for this struct was generated from the following file:
  • project/at_start_f413/examples/usart/smartcard/src/main.c


AT32F413 Firmwary Library: USART_synchronous

Macros | Functions | Variables
USART_synchronous
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)
#define | DYMMY_BYTE 0x00

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_spi_configuration (void)
config usart and spi More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart synchronous example: usart2 -> spi2"
uint8_t | spi2_tx_buffer [] = "usart synchronous example: spi2 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]
uint8_t | spi2_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | spi2_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | spi2_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | spi2_tx_buffer_size = ((sizeof( spi2_tx_buffer ) / sizeof(*( spi2_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 36 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ DYMMY_BYTE

#define DYMMY_BYTE 0x00

Definition at line 39 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ SPI2_TX_BUFFER_SIZE

#define SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)

Definition at line 38 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 37 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 132 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< usart receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 151 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ usart_spi_configuration()

void usart_spi_configuration ( void )

config usart and spi

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 4

< gpio pins number 3

< gpio pins number 15

< gpio pins number 13

< gpio pins number 14

Definition at line 57 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

Variable Documentation

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and SPI2_IRQHandler().

◆ spi2_rx_counter

uint8_t spi2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint8_t spi2_tx_buffer[] = "usart synchronous example: spi2 -> usart2"

Definition at line 42 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and SPI2_IRQHandler().

◆ spi2_tx_buffer_size

uint8_t spi2_tx_buffer_size = ((sizeof( spi2_tx_buffer ) / sizeof(*( spi2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi2_tx_counter

uint8_t spi2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]

Definition at line 43 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_rx_counter

uint8_t usart2_rx_counter = 0x00

Definition at line 47 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and USART2_IRQHandler().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart synchronous example: usart2 -> spi2"

Definition at line 41 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 49 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart2_tx_counter

uint8_t usart2_tx_counter = 0x00

Definition at line 45 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and USART2_IRQHandler().


AT32F413 Firmwary Library: USART_transfer_by_dma_interrupt

Macros | Functions | Variables
USART_transfer_by_dma_interrupt
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma1 channel2 handler. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 handler. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 handler. More...
void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_dma_status = 0
volatile uint8_t | usart2_rx_dma_status = 0
volatile uint8_t | usart3_tx_dma_status = 0
volatile uint8_t | usart3_rx_dma_status = 0

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 36 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 37 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 38 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 229 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1 channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 143 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

this function handles dma1 channel2 handler.

Parameters
none
Return values
none

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

Definition at line 158 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 handler.

Parameters
none
Return values
none

< dma1 channel3 full data transfer flag

< dma1 channel3 full data transfer flag

Definition at line 173 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 handler.

Parameters
none
Return values
none

< dma1 channel4 full data transfer flag

< dma1 channel4 full data transfer flag

Definition at line 188 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ dma_configuration()

void dma_configuration ( void )

config dma for usart2 and usart3

Parameters
none
Return values
none

< dma full data transfer interrupt

< dma flexible channel1

< dma full data transfer interrupt

< dma flexible channel2

< dma full data transfer interrupt

< dma flexible channel3

< dma full data transfer interrupt

< dma flexible channel4

Definition at line 113 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 248 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

Definition at line 54 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 42 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_rx_dma_status

volatile uint8_t usart2_rx_dma_status = 0

Definition at line 45 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 40 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_tx_dma_status

volatile uint8_t usart2_tx_dma_status = 0

Definition at line 44 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 43 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_rx_dma_status

volatile uint8_t usart3_rx_dma_status = 0

Definition at line 47 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel4_IRQHandler(), and main().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 41 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_tx_dma_status

volatile uint8_t usart3_tx_dma_status = 0

Definition at line 46 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel3_IRQHandler(), and main().


AT32F413 Firmwary Library: USART_transfer_by_dma_polling

Macros | Functions | Variables
USART_transfer_by_dma_polling
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 36 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 37 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 38 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 201 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ dma_configuration()

void dma_configuration ( void )

config dma for usart2 and usart3

Parameters
none
Return values
none

< dma flexible channel1

< dma flexible channel2

< dma flexible channel3

< dma flexible channel4

Definition at line 109 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

Definition at line 220 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

Definition at line 50 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 42 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART2_IRQHandler().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 40 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART2_IRQHandler().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 43 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART3_IRQHandler().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 41 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART3_IRQHandler().


AT32F413 Firmwary Library: USB_device_audio

Modules | Macros | Functions | Variables
USB_device_audio
AT32F413_periph_examples

Modules

USB_device_audio_codec_reg_definition
USB_device_audio_codec_pin_definition
USB_device_audio_codec_exported_functions

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
usbd_core_type usb_core_dev

Detailed Description

Macro Definition Documentation

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 39 of file audio/src/audio_codec.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0x00

Definition at line 42 of file audio/src/audio_codec.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 45 of file audio/src/audio_codec.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 44 of file audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 48 of file audio/src/audio_codec.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_8

Definition at line 47 of file audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 52 of file audio/src/audio_codec.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_9

Definition at line 51 of file audio/src/audio_codec.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 41 of file audio/src/audio_codec.c.

◆ USB_BUFFER_SIZE_EX

#define USB_BUFFER_SIZE_EX

usb endpoint max num define

usb buffer extend to 768-1280 bytes usb enable extend buffer

Definition at line 55 of file project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

auto malloc usb endpoint buffer

usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h.

◆ WM8988_REG_BITW16

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 64 of file audio/src/audio_codec.c.

◆ WM8988_REG_FREQ16K

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 59 of file audio/src/audio_codec.c.

◆ WM8988_REG_FREQ48K

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 58 of file audio/src/audio_codec.c.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 792 of file audio/src/audio_codec.c.

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 851 of file audio/src/audio_codec.c.

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 167 of file audio/src/audio_codec.c.

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 280 of file audio/src/audio_codec.c.

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 340 of file audio/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 119 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 182 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 204 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 135 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 193 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 215 of file audio/src/audio_codec.c.

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 152 of file audio/src/audio_codec.c.

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 226 of file audio/src/audio_codec.c.

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

codec speaker write fifo

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 242 of file audio/src/audio_codec.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 interrupt.

Parameters
none
Return values
none

Definition at line 647 of file audio/src/audio_codec.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 interrupt.

Parameters
none
Return values
none

Definition at line 722 of file audio/src/audio_codec.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

Definition at line 397 of file audio/src/audio_codec.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 48 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 167 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 178 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 157 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

Variable Documentation

◆ audio_codec

audio_codec_type audio_codec

Definition at line 104 of file audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_mic_get_data(), audio_codec_set_mic_freq(), audio_codec_set_mic_mute(), audio_codec_set_mic_volume(), audio_codec_set_spk_freq(), audio_codec_set_spk_mute(), audio_codec_set_spk_volume(), audio_codec_spk_feedback(), audio_codec_spk_fifo_write(), DMA1_Channel3_IRQHandler(), and DMA1_Channel4_IRQHandler().

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 102 of file audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), and audio_codec_modify_freq().

◆ mic_dma_buffer

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 106 of file audio/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ reg_addr_data

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 69 of file audio/src/audio_codec.c.

Referenced by audio_codec_init().

◆ spk_dma_buffer

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 105 of file audio/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 41 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_audio_codec_reg_definition

Macros
USB_device_audio_codec_reg_definition
AT32F413_periph_examples » USB_device_audio

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36

Detailed Description

Macro Definition Documentation

◆ WM8988_I2C_ADDR_CSB_HIGH

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 92 of file audio/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 91 of file audio/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 48 of file audio/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 58 of file audio/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 59 of file audio/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 60 of file audio/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 61 of file audio/inc/audio_codec.h.

◆ WM8988_R14_

#define WM8988_R14_

Definition at line 62 of file audio/inc/audio_codec.h.

◆ WM8988_R15_RESET

#define WM8988_R15_RESET 0x0F

Definition at line 63 of file audio/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 64 of file audio/inc/audio_codec.h.

◆ WM8988_R17_ALC1

#define WM8988_R17_ALC1 0x11

Definition at line 65 of file audio/inc/audio_codec.h.

◆ WM8988_R18_ALC2

#define WM8988_R18_ALC2 0x12

Definition at line 66 of file audio/inc/audio_codec.h.

◆ WM8988_R19_ALC3

#define WM8988_R19_ALC3 0x13

Definition at line 67 of file audio/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 49 of file audio/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 68 of file audio/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 69 of file audio/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 70 of file audio/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 71 of file audio/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 72 of file audio/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 73 of file audio/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 74 of file audio/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 75 of file audio/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 50 of file audio/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 77 of file audio/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 78 of file audio/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 79 of file audio/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 80 of file audio/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 81 of file audio/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 82 of file audio/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 83 of file audio/inc/audio_codec.h.

◆ WM8988_R38_RESERVED

#define WM8988_R38_RESERVED

Definition at line 84 of file audio/inc/audio_codec.h.

◆ WM8988_R39_RESERVED

#define WM8988_R39_RESERVED

Definition at line 85 of file audio/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 51 of file audio/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 86 of file audio/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 87 of file audio/inc/audio_codec.h.

◆ WM8988_R42_RESERVED

#define WM8988_R42_RESERVED

Definition at line 88 of file audio/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 89 of file audio/inc/audio_codec.h.

◆ WM8988_R4_RESERVED

#define WM8988_R4_RESERVED 0x04

Definition at line 52 of file audio/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 53 of file audio/inc/audio_codec.h.

◆ WM8988_R6_RESERVED

#define WM8988_R6_RESERVED 0x06

Definition at line 54 of file audio/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 55 of file audio/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 56 of file audio/inc/audio_codec.h.

◆ WM8988_R9_RESERVED

#define WM8988_R9_RESERVED 0x09

Definition at line 57 of file audio/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_codec_pin_definition

Macros
USB_device_audio_codec_pin_definition
AT32F413_periph_examples » USB_device_audio

Macros

#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)

Detailed Description

Macro Definition Documentation

◆ I2S1_CK_PIN

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 102 of file audio/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 106 of file audio/inc/audio_codec.h.

◆ I2S1_GPIO

#define I2S1_GPIO GPIOA

Definition at line 104 of file audio/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 105 of file audio/inc/audio_codec.h.

◆ I2S1_SD_PIN

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 103 of file audio/inc/audio_codec.h.

◆ I2S1_WS_PIN

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 101 of file audio/inc/audio_codec.h.

◆ I2S2_CK_PIN

#define I2S2_CK_PIN GPIO_PINS_13

Definition at line 110 of file audio/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 114 of file audio/inc/audio_codec.h.

◆ I2S2_GPIO

#define I2S2_GPIO GPIOB

Definition at line 112 of file audio/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK

#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 113 of file audio/inc/audio_codec.h.

◆ I2S2_SD_PIN

#define I2S2_SD_PIN GPIO_PINS_15

Definition at line 111 of file audio/inc/audio_codec.h.

◆ I2S2_WS_PIN

#define I2S2_WS_PIN GPIO_PINS_12

Definition at line 109 of file audio/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 116 of file audio/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_codec_exported_functions

Data Structures | Macros | Functions
USB_device_audio_codec_exported_functions
AT32F413_periph_examples » USB_device_audio

Data Structures

struct audio_codec_type

Macros

#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

Macro Definition Documentation

◆ DMA_BUFFER_SIZE

#define DMA_BUFFER_SIZE 288

Definition at line 127 of file audio/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE

#define MIC_BUFFER_SIZE 1024

Definition at line 125 of file audio/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE

#define SPK_BUFFER_SIZE 4096

Definition at line 126 of file audio/inc/audio_codec.h.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 792 of file audio/src/audio_codec.c.

Referenced by main().

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 851 of file audio/src/audio_codec.c.

Referenced by main().

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 167 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 280 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 340 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 119 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 182 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 204 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 135 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 193 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 215 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 152 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 226 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

audio codec interface

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 242 of file audio/src/audio_codec.c.

Referenced by class_out_handler().


AT32F413 Firmwary Library: audio_codec_type Struct Reference

Data Fields
audio_codec_type Struct Reference
AT32F413_periph_examples » USB_device_audio » USB_device_audio_codec_exported_functions | AT32F413_periph_examples » USB_device_audio_hid » USB_device_audio_hid_codec_exported_functions

#include <audio_codec.h>

Data Fields

uint32_t | audio_freq
uint32_t | audio_bitw
uint16_t | spk_buffer [4096]
uint16_t * | spk_roff
uint16_t * | spk_woff
uint16_t * | spk_rend
uint32_t | spk_freq
uint32_t | spk_wtotal
uint32_t | spk_rtotal
uint16_t | spk_threshold
uint16_t | spk_calc
uint8_t | spk_stage
uint16_t | mic_buffer [1024]
uint16_t * | mic_roff
uint16_t * | mic_woff
uint16_t * | mic_wend
uint32_t | mic_wtotal
uint32_t | mic_rtotal
uint32_t | mic_delta
uint16_t | mic_calc
uint16_t | mic_adj_count
uint8_t | mic_adj_stage
uint8_t | mic_stage
uint8_t | mic_mute
uint8_t | spk_mute
uint16_t | mic_volume
uint16_t | spk_volume
uint32_t | spk_tx_size
uint32_t | mic_rx_size
uint32_t | spk_enable
uint32_t | mic_enable

Detailed Description

Definition at line 129 of file audio/inc/audio_codec.h.

Field Documentation

◆ audio_bitw

uint32_t audio_codec_type::audio_bitw

Definition at line 132 of file audio/inc/audio_codec.h.

Referenced by audio_codec_init(), and codec_i2s_init().

◆ audio_freq

uint32_t audio_codec_type::audio_freq

Definition at line 131 of file audio/inc/audio_codec.h.

Referenced by audio_codec_init(), audio_codec_set_mic_freq(), audio_codec_set_spk_freq(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ mic_adj_count

uint16_t audio_codec_type::mic_adj_count

Definition at line 154 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_adj_stage

uint8_t audio_codec_type::mic_adj_stage

Definition at line 155 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_buffer

uint16_t audio_codec_type::mic_buffer

Definition at line 146 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_calc

uint16_t audio_codec_type::mic_calc

Definition at line 153 of file audio/inc/audio_codec.h.

Referenced by DMA1_Channel4_IRQHandler().

◆ mic_delta

uint32_t audio_codec_type::mic_delta

Definition at line 152 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_enable

uint32_t audio_codec_type::mic_enable

Definition at line 168 of file audio/inc/audio_codec.h.

◆ mic_mute

uint8_t audio_codec_type::mic_mute

Definition at line 158 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_mic_mute().

◆ mic_roff

uint16_t * audio_codec_type::mic_roff

Definition at line 147 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_rtotal

uint32_t audio_codec_type::mic_rtotal

Definition at line 151 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_rx_size

uint32_t audio_codec_type::mic_rx_size

Definition at line 165 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_stage

uint8_t audio_codec_type::mic_stage

Definition at line 156 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_volume

uint16_t audio_codec_type::mic_volume

Definition at line 161 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_mic_volume().

◆ mic_wend

uint16_t * audio_codec_type::mic_wend

Definition at line 149 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_woff

uint16_t * audio_codec_type::mic_woff

Definition at line 148 of file audio/inc/audio_codec.h.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_wtotal

uint32_t audio_codec_type::mic_wtotal

Definition at line 150 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ spk_buffer

uint16_t audio_codec_type::spk_buffer

Definition at line 134 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_calc

uint16_t audio_codec_type::spk_calc

Definition at line 142 of file audio/inc/audio_codec.h.

Referenced by DMA1_Channel3_IRQHandler().

◆ spk_enable

uint32_t audio_codec_type::spk_enable

Definition at line 167 of file audio/inc/audio_codec.h.

◆ spk_freq

uint32_t audio_codec_type::spk_freq

Definition at line 138 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_feedback(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_mute

uint8_t audio_codec_type::spk_mute

Definition at line 159 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_spk_mute().

◆ spk_rend

uint16_t * audio_codec_type::spk_rend

Definition at line 137 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_roff

uint16_t * audio_codec_type::spk_roff

Definition at line 135 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_rtotal

uint32_t audio_codec_type::spk_rtotal

Definition at line 140 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_stage

uint8_t audio_codec_type::spk_stage

Definition at line 143 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_threshold

uint16_t audio_codec_type::spk_threshold

Definition at line 141 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_tx_size

uint32_t audio_codec_type::spk_tx_size

Definition at line 164 of file audio/inc/audio_codec.h.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_volume

uint16_t audio_codec_type::spk_volume

Definition at line 162 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_spk_volume().

◆ spk_woff

uint16_t * audio_codec_type::spk_woff

Definition at line 136 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_wtotal

uint32_t audio_codec_type::spk_wtotal

Definition at line 139 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

The documentation for this struct was generated from the following files:
  • audio/inc/audio_codec.h
  • composite_audio_hid/inc/audio_codec.h


AT32F413 Firmwary Library: USB_device_audio_hid

Modules | Macros | Functions | Variables
USB_device_audio_hid
AT32F413_periph_examples

Modules

USB_device_audio_hid_codec_reg_definition
USB_device_audio_hid_codec_pin_definition
USB_device_audio_hid_codec_exported_functions

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 200000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
usbd_core_type usb_core_dev
uint8_t | report_buf [USBD_AUHID_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 39 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0x00

Definition at line 42 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 45 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 44 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 48 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_8

Definition at line 47 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 52 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_9

Definition at line 51 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 200000

Definition at line 41 of file composite_audio_hid/src/audio_codec.c.

◆ USB_BUFFER_SIZE_EX

#define USB_BUFFER_SIZE_EX

usb endpoint max num define

usb buffer extend to 768-1280 bytes usb enable extend buffer

Definition at line 55 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

auto malloc usb endpoint buffer

usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ WM8988_REG_BITW16

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 64 of file composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ16K

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 59 of file composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ48K

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 58 of file composite_audio_hid/src/audio_codec.c.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 794 of file composite_audio_hid/src/audio_codec.c.

Referenced by main().

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 853 of file composite_audio_hid/src/audio_codec.c.

Referenced by main().

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 167 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 280 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 340 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 119 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 182 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 204 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 135 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 193 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 215 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 152 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 226 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

codec speaker write fifo

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 242 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_out_handler().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ codec_i2s_init()

void codec_i2s_init ( audio_codec_type * param )

audio codec i2s init

Parameters
freq | audio sampling freq
bitw_format | bit width
Return values
error status

Definition at line 491 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ codec_i2s_reset()

void codec_i2s_reset ( void )

audio codec i2s reset

Parameters
none
Return values
none

Definition at line 477 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ copy_buff()

void copy_buff | ( | uint16_t * | dest,
 |  | uint16_t * | src,
 |  | uint32_t | len
 | ) |  |

copy buffer

Parameters
dest | dest data buffer
src | src data buffer
len | data length
Return values
none

Definition at line 383 of file composite_audio_hid/src/audio_codec.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 interrupt.

Parameters
none
Return values
none

Definition at line 649 of file composite_audio_hid/src/audio_codec.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 interrupt.

Parameters
none
Return values
none

Definition at line 724 of file composite_audio_hid/src/audio_codec.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

Definition at line 397 of file composite_audio_hid/src/audio_codec.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

◆ mclk_tmr1_init()

void mclk_tmr1_init ( void )

mclk clock conifg

Parameters
none
Return values
none

Definition at line 435 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init().

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ memset16_buffer()

void memset16_buffer | ( | uint16_t * | buffer,
 |  | uint32_t | set,
 |  | uint32_t | len
 | ) |  |

buffer memset

Parameters
buffer | buffer
set | memset data
len | data length
Return values
none

Definition at line 367 of file composite_audio_hid/src/audio_codec.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 176 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 187 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 166 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Variable Documentation

◆ audio_codec

audio_codec_type audio_codec

Definition at line 104 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_mic_get_data(), audio_codec_set_mic_freq(), audio_codec_set_mic_mute(), audio_codec_set_mic_volume(), audio_codec_set_spk_freq(), audio_codec_set_spk_mute(), audio_codec_set_spk_volume(), audio_codec_spk_feedback(), audio_codec_spk_fifo_write(), DMA1_Channel3_IRQHandler(), and DMA1_Channel4_IRQHandler().

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 102 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), DMA1_Channel4_IRQHandler(), DMA1_Channel5_IRQHandler(), DMA1_Channel6_IRQHandler(), DMA1_Channel7_IRQHandler(), I2C1_ERR_IRQHandler(), I2C1_EVT_IRQHandler(), I2C2_ERR_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ mic_dma_buffer

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 106 of file composite_audio_hid/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ reg_addr_data

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 69 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init().

◆ report_buf

uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE]

Definition at line 44 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main().

◆ spk_dma_buffer

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 105 of file composite_audio_hid/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_audio_hid_codec_reg_definition

Macros
USB_device_audio_hid_codec_reg_definition
AT32F413_periph_examples » USB_device_audio_hid

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36

Detailed Description

Macro Definition Documentation

◆ WM8988_I2C_ADDR_CSB_HIGH

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 92 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 91 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 48 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 58 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 59 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 60 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 61 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R14_

#define WM8988_R14_

Definition at line 62 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R15_RESET

#define WM8988_R15_RESET 0x0F

Definition at line 63 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 64 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R17_ALC1

#define WM8988_R17_ALC1 0x11

Definition at line 65 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R18_ALC2

#define WM8988_R18_ALC2 0x12

Definition at line 66 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R19_ALC3

#define WM8988_R19_ALC3 0x13

Definition at line 67 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 49 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 68 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 69 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 70 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 71 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 72 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 73 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 74 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 75 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 50 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 77 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 78 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 79 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 80 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 81 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 82 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 83 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R38_RESERVED

#define WM8988_R38_RESERVED

Definition at line 84 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R39_RESERVED

#define WM8988_R39_RESERVED

Definition at line 85 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 51 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 86 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 87 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R42_RESERVED

#define WM8988_R42_RESERVED

Definition at line 88 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 89 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R4_RESERVED

#define WM8988_R4_RESERVED 0x04

Definition at line 52 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 53 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R6_RESERVED

#define WM8988_R6_RESERVED 0x06

Definition at line 54 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 55 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 56 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R9_RESERVED

#define WM8988_R9_RESERVED 0x09

Definition at line 57 of file composite_audio_hid/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_hid_codec_pin_definition

Macros
USB_device_audio_hid_codec_pin_definition
AT32F413_periph_examples » USB_device_audio_hid

Macros

#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)

Detailed Description

Macro Definition Documentation

◆ I2S1_CK_PIN

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 102 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 107 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO

#define I2S1_GPIO GPIOA

Definition at line 105 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 106 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_PIN

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 103 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_PIN

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 101 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_PIN

#define I2S2_CK_PIN GPIO_PINS_13

Definition at line 111 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 117 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO

#define I2S2_GPIO GPIOB

Definition at line 115 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK

#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 116 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_PIN

#define I2S2_SD_PIN GPIO_PINS_15

Definition at line 112 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_PIN

#define I2S2_WS_PIN GPIO_PINS_12

Definition at line 110 of file composite_audio_hid/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 119 of file composite_audio_hid/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_hid_codec_exported_functions

Data Structures | Macros | Functions
USB_device_audio_hid_codec_exported_functions
AT32F413_periph_examples » USB_device_audio_hid

Data Structures

struct audio_codec_type

Macros

#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

Macro Definition Documentation

◆ DMA_BUFFER_SIZE

#define DMA_BUFFER_SIZE 288

Definition at line 130 of file composite_audio_hid/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE

#define MIC_BUFFER_SIZE 1024

Definition at line 128 of file composite_audio_hid/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE

#define SPK_BUFFER_SIZE 4096

Definition at line 129 of file composite_audio_hid/inc/audio_codec.h.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 792 of file audio/src/audio_codec.c.

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 851 of file audio/src/audio_codec.c.

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 167 of file audio/src/audio_codec.c.

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 280 of file audio/src/audio_codec.c.

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 340 of file audio/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 119 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 182 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 204 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 135 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 193 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 215 of file audio/src/audio_codec.c.

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 152 of file audio/src/audio_codec.c.

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 226 of file audio/src/audio_codec.c.

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

audio codec interface

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 242 of file audio/src/audio_codec.c.


AT32F413 Firmwary Library: USB_device_composite_vcp_keyboard

Macros | Functions | Variables
USB_device_composite_vcp_keyboard
AT32F413_periph_examples

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER [1/2]

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER [2/2]

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 153 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 49 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 233 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 244 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 223 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Variable Documentation

◆ usb_buffer

uint8_t usb_buffer[256]

Definition at line 41 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 40 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by keyboard_send_string(), main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_msc

Macros | Functions | Variables
USB_device_msc
AT32F413_periph_examples

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
usbd_core_type usb_core_dev
uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

Macro Definition Documentation

◆ INTERNAL_FLASH_LUN [1/2]

#define INTERNAL_FLASH_LUN 0

Definition at line 43 of file composite_vcp_msc/inc/msc_diskio.h.

◆ INTERNAL_FLASH_LUN [2/2]

#define INTERNAL_FLASH_LUN 0

Definition at line 43 of file msc/inc/msc_diskio.h.

◆ SD_LUN [1/2]

#define SD_LUN 2

Definition at line 45 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SD_LUN [2/2]

#define SD_LUN 2

Definition at line 45 of file msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [1/2]

#define SECTOR_SIZE_1K 1024

Definition at line 49 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [2/2]

#define SECTOR_SIZE_1K 1024

Definition at line 49 of file msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [1/2]

#define SECTOR_SIZE_2K 2048

Definition at line 50 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [2/2]

#define SECTOR_SIZE_2K 2048

Definition at line 50 of file msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [1/2]

#define SECTOR_SIZE_4K 4096

Definition at line 51 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [2/2]

#define SECTOR_SIZE_4K 4096

Definition at line 51 of file msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [1/2]

#define SPI_FLASH_LUN 1

Definition at line 44 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [2/2]

#define SPI_FLASH_LUN 1

Definition at line 44 of file msc/inc/msc_diskio.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h.

◆ USB_FLASH_ADDR_OFFSET [1/2]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 47 of file composite_vcp_msc/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [2/2]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 47 of file msc/inc/msc_diskio.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 49 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 161 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 172 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 151 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

Variable Documentation

◆ msc_flash_size [1/2]

uint32_t msc_flash_size

Definition at line 35 of file composite_vcp_msc/src/msc_diskio.c.

Referenced by msc_disk_capacity().

◆ msc_flash_size [2/2]

uint32_t msc_flash_size

Definition at line 35 of file msc/src/msc_diskio.c.

◆ scsi_inquiry [1/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:155

Definition at line 36 of file composite_vcp_msc/src/msc_diskio.c.

Referenced by get_inquiry().

◆ scsi_inquiry [2/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}

Definition at line 36 of file msc/src/msc_diskio.c.

◆ sector_size [1/2]

uint32_t sector_size = 2048

Definition at line 34 of file composite_vcp_msc/src/msc_diskio.c.

Referenced by msc_disk_capacity(), and sector_read().

◆ sector_size [2/2]

uint32_t sector_size = 2048

Definition at line 34 of file msc/src/msc_diskio.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 41 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_composite_vcp_msc

Functions | Variables
USB_device_composite_vcp_msc
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 48 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 191 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 202 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 181 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Variable Documentation

◆ usb_buffer

uint8_t usb_buffer[256]

Definition at line 41 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 40 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_custom_hid

Macros | Functions | Variables
USB_device_custom_hid
AT32F413_periph_examples

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
uint8_t report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 48 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 168 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 179 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 158 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Variable Documentation

◆ report_buf

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 41 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 40 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_keyboard

Macros | Functions | Variables
USB_device_keyboard
AT32F413_periph_examples

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | system_clock_recover (void)
systemclock recover. More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t hid_suspend_flag

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 101 of file project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ keyboard_send_string()

void keyboard_send_string | ( | void * | udev,
 |  | uint8_t * | string,
 |  | uint8_t | len
 | ) |  |

keyboard send string

Parameters
string | send string
len | send string length
Return values
none

Definition at line 53 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 155 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

systemclock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 96 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 87 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 334 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 345 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 324 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Variable Documentation

◆ hid_suspend_flag

__IO uint8_t hid_suspend_flag
extern

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 40 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_mouse

Macros | Functions | Variables
USB_device_mouse
AT32F413_periph_examples

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | system_clock_recover (void)
systemclock recover. More...
void | button_exint_init (void)
configure button exint More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t | press_mouse = 0
__IO uint8_t | hid_suspend_flag
uint8_t | report_buf [USBD_MOUSE_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 101 of file project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

Definition at line 50 of file project/at_start_f413/templates/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

systemclock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 96 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 52 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 310 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 321 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 299 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Variable Documentation

◆ hid_suspend_flag

__IO uint8_t hid_suspend_flag
extern

Referenced by main().

◆ press_mouse

__IO uint8_t press_mouse = 0

Definition at line 41 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Referenced by main().

◆ report_buf

uint8_t report_buf[USBD_MOUSE_IN_MAXPACKET_SIZE]

Definition at line 43 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 40 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_printer

Macros | Functions | Variables
USB_device_printer
AT32F413_periph_examples

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

uint8_t usb_buffer [256]
usbd_core_type usb_core_dev

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 48 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 167 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 178 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 157 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

Variable Documentation

◆ usb_buffer

uint8_t usb_buffer[256]

Definition at line 40 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 41 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_vcp_loopback

Macros | Functions | Variables
USB_device_vcp_loopback
AT32F413_periph_examples

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00
#define | USB_VIRTUAL_COMPORT
usb endpoint max num define More...
#define | EPT0_TX_ADDR 0x40
user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00
#define | usart_buffer_size 2048

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
void | usart_gpio_config (void)
this function handles usart2 gpio config. More...
void | usart_send_data (uint8_t *send_data, uint16_t len)
this function handles usart2 send data. More...
uint16_t | usart_receive_data (void)
this function handles usart2 receive data. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
linecoding_type linecoding
uint8_t | usart_rx_buffer [2048]
uint16_t | hw_usart_rx_index = 0
uint16_t | hw_usart_read_index = 0
uint16_t | usart_rx_data_len = 0
uint16_t | ov_cnt = 0

Detailed Description

Macro Definition Documentation

◆ EPT0_RX_ADDR [1/2]

#define EPT0_RX_ADDR 0x80

usb endpoint 0 rx buffer address offset

Definition at line 73 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT0_RX_ADDR [2/2]

#define EPT0_RX_ADDR 0x80

usb endpoint 0 rx buffer address offset

Definition at line 77 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT0_TX_ADDR [1/2]

#define EPT0_TX_ADDR 0x40

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer

user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size usb endpoint 0 tx buffer address offset

Definition at line 72 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT0_TX_ADDR [2/2]

#define EPT0_TX_ADDR 0x40

user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size

usb endpoint 0 tx buffer address offset

Definition at line 76 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT1_RX_ADDR [1/2]

#define EPT1_RX_ADDR 0x100

usb endpoint 1 rx buffer address offset

Definition at line 76 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT1_RX_ADDR [2/2]

#define EPT1_RX_ADDR 0x100

usb endpoint 1 rx buffer address offset

Definition at line 80 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT1_TX_ADDR [1/2]

#define EPT1_TX_ADDR 0xC0

usb endpoint 1 tx buffer address offset

Definition at line 75 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT1_TX_ADDR [2/2]

#define EPT1_TX_ADDR 0xC0

usb endpoint 1 tx buffer address offset

Definition at line 79 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT2_RX_ADDR [1/2]

#define EPT2_RX_ADDR 0x180

usb endpoint 2 rx buffer address offset

Definition at line 79 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT2_RX_ADDR [2/2]

#define EPT2_RX_ADDR 0x180

usb endpoint 2 rx buffer address offset

Definition at line 83 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT2_TX_ADDR [1/2]

#define EPT2_TX_ADDR 0x140

usb endpoint 2 tx buffer address offset

Definition at line 78 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT2_TX_ADDR [2/2]

#define EPT2_TX_ADDR 0x140

usb endpoint 2 tx buffer address offset

Definition at line 82 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT3_RX_ADDR [1/2]

#define EPT3_RX_ADDR 0x00

usb endpoint 3 rx buffer address offset

Definition at line 82 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT3_RX_ADDR [2/2]

#define EPT3_RX_ADDR 0x00

usb endpoint 3 rx buffer address offset

Definition at line 86 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT3_TX_ADDR [1/2]

#define EPT3_TX_ADDR 0x00

usb endpoint 3 tx buffer address offset

Definition at line 81 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT3_TX_ADDR [2/2]

#define EPT3_TX_ADDR 0x00

usb endpoint 3 tx buffer address offset

Definition at line 85 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT4_RX_ADDR [1/2]

#define EPT4_RX_ADDR 0x00

usb endpoint 4 rx buffer address offset

Definition at line 85 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT4_RX_ADDR [2/2]

#define EPT4_RX_ADDR 0x00

usb endpoint 4 rx buffer address offset

Definition at line 89 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT4_TX_ADDR [1/2]

#define EPT4_TX_ADDR 0x00

usb endpoint 4 tx buffer address offset

Definition at line 84 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT4_TX_ADDR [2/2]

#define EPT4_TX_ADDR 0x00

usb endpoint 4 tx buffer address offset

Definition at line 88 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT5_RX_ADDR [1/2]

#define EPT5_RX_ADDR 0x00

usb endpoint 5 rx buffer address offset

Definition at line 88 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT5_RX_ADDR [2/2]

#define EPT5_RX_ADDR 0x00

usb endpoint 5 rx buffer address offset

Definition at line 92 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT5_TX_ADDR [1/2]

#define EPT5_TX_ADDR 0x00

usb endpoint 5 tx buffer address offset

Definition at line 87 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT5_TX_ADDR [2/2]

#define EPT5_TX_ADDR 0x00

usb endpoint 5 tx buffer address offset

Definition at line 91 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT6_RX_ADDR [1/2]

#define EPT6_RX_ADDR 0x00

usb endpoint 6 rx buffer address offset

Definition at line 91 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT6_RX_ADDR [2/2]

#define EPT6_RX_ADDR 0x00

usb endpoint 6 rx buffer address offset

Definition at line 95 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT6_TX_ADDR [1/2]

#define EPT6_TX_ADDR 0x00

usb endpoint 6 tx buffer address offset

Definition at line 90 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT6_TX_ADDR [2/2]

#define EPT6_TX_ADDR 0x00

usb endpoint 6 tx buffer address offset

Definition at line 94 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT7_RX_ADDR [1/2]

#define EPT7_RX_ADDR 0x00

usb endpoint 7 rx buffer address offset

Definition at line 94 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT7_RX_ADDR [2/2]

#define EPT7_RX_ADDR 0x00

usb endpoint 7 rx buffer address offset

Definition at line 98 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT7_TX_ADDR [1/2]

#define EPT7_TX_ADDR 0x00

usb endpoint 7 tx buffer address offset

Definition at line 93 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT7_TX_ADDR [2/2]

#define EPT7_TX_ADDR 0x00

usb endpoint 7 tx buffer address offset

Definition at line 97 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ usart_buffer_size

#define usart_buffer_size 2048

Definition at line 47 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ USB_VIRTUAL_COMPORT

#define USB_VIRTUAL_COMPORT

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer

usb virtual comport

Definition at line 66 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 282 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_gpio_config()

void usart_gpio_config ( void )

this function handles usart2 gpio config.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

Definition at line 405 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_receive_data()

uint16_t usart_receive_data ( void )

this function handles usart2 receive data.

Parameters
none
Return values
the data len

Definition at line 256 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_send_data()

void usart_send_data | ( | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

this function handles usart2 send data.

Parameters
send_data | pointer to data
len | data len
Return values
none

< usart transmit data buffer empty flag

Definition at line 237 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

< acc hick trim

Definition at line 48 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 193 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 204 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

Definition at line 297 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usb_vcp_cmd_process().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 183 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Variable Documentation

◆ hw_usart_read_index

uint16_t hw_usart_read_index = 0

Definition at line 50 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usart_receive_data().

◆ hw_usart_rx_index

uint16_t hw_usart_rx_index = 0

Definition at line 49 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by USART2_IRQHandler(), and usart_receive_data().

◆ linecoding

linecoding_type linecoding
extern

Definition at line 55 of file cdc_class.c.

Referenced by cdc_struct_init(), and usb_usart_config().

◆ ov_cnt

uint16_t ov_cnt = 0

Definition at line 52 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_rx_buffer

uint8_t usart_rx_buffer[2048]

Definition at line 48 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart_rx_data_len

uint16_t usart_rx_data_len = 0

Definition at line 51 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 41 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 41 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usb_core_dev [1/2]

usbd_core_type usb_core_dev

Definition at line 40 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ usb_core_dev [2/2]

usbd_core_type usb_core_dev

Definition at line 40 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.


AT32F413 Firmwary Library: USB_device_virtual_msc_iap

Modules | Macros | Functions | Variables
USB_device_virtual_msc_iap
AT32F413_periph_examples

Modules

USB_device_virtual_msc_iap_definition

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000
#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | FAT16_SECTOR_SIZE 62

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
uint32_t | flash_fat16_boot_dir_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write More...
uint32_t | flash_fat16_sector_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector More...
uint32_t | fat16_memory_copy (uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function More...
uint32_t | fat16_memory_memset (uint8_t *dst, uint32_t set, uint32_t len)
memset function More...
uint32_t | flash_write_data (uint32_t address, uint8_t *data, uint32_t len)
write data to flash More...
uint32_t | flash_read_data (uint32_t address, uint8_t *data, uint32_t len)
read data from flash More...
uint32_t | fat16_memory_cmp (uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function More...
uint32_t | flash_crc_check (uint32_t address, uint8_t *data, uint32_t len)
crc check More...
void | flash_fat16_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | flash_fat16_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint32_t | flash_fat16_addr_offset (uint8_t *file_name)
get offset address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | jump_to_app (uint32_t address)
jump to app More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | usb_reset ()
usb re-connect More...
void | flash_fat16_loop_status (void)
loop status More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0
usbd_core_type usb_core_dev
void(* | pftarget )(void)
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
iapfun jump_to_app
jump to app More...

Detailed Description

Macro Definition Documentation

◆ FAT16_SECTOR_SIZE

#define FAT16_SECTOR_SIZE 62

Definition at line 34 of file flash_fat16.c.

◆ INTERNAL_FLASH_LUN

#define INTERNAL_FLASH_LUN 0

Definition at line 43 of file virtual_msc_iap/inc/msc_diskio.h.

◆ SD_LUN

#define SD_LUN 2

Definition at line 45 of file virtual_msc_iap/inc/msc_diskio.h.

◆ SPI_FLASH_LUN

#define SPI_FLASH_LUN 1

Definition at line 44 of file virtual_msc_iap/inc/msc_diskio.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USB_FLASH_ADDR_OFFSET

#define USB_FLASH_ADDR_OFFSET 0x08004000

Definition at line 47 of file virtual_msc_iap/inc/msc_diskio.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ fat16_memory_cmp()

uint32_t fat16_memory_cmp | ( | uint8_t * | dst,
 |  | uint8_t * | src,
 |  | uint32_t | len
 | ) |  |

memory compare function

Parameters
dst | dest buffer pointer
src | src buffer pointer
len | compare length
Return values
compare result

Definition at line 227 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ fat16_memory_copy()

uint32_t fat16_memory_copy | ( | uint8_t * | dst,
 |  | const uint8_t * | src,
 |  | uint32_t | len
 | ) |  |

memory copy function

Parameters
dst | dest buffer pointer
src | src buffer pointer
len | copy length
Return values
nubmer of data copy

Definition at line 193 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_read().

◆ fat16_memory_memset()

uint32_t fat16_memory_memset | ( | uint8_t * | dst,
 |  | uint32_t | set,
 |  | uint32_t | len
 | ) |  |

memset function

Parameters
dst | dest buffer pointer
set | set value
len | set length
Return values
nubmer of data set

Definition at line 210 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_read().

◆ flash_crc_check()

uint32_t flash_crc_check | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

crc check

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
crc result

Definition at line 601 of file flash_fat16.c.

Referenced by flash_write_data().

◆ flash_fat16_addr_offset()

uint32_t flash_fat16_addr_offset ( uint8_t * file_name )

get offset address

Parameters
file_name file name
Return values
offset address

Definition at line 437 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ flash_fat16_boot_dir_write()

uint32_t flash_fat16_boot_dir_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

boot dir write

Parameters
fat_lbk | logical block address
data | pointer to array to store data
len | data length
Return values
nubmer of data

Definition at line 379 of file flash_fat16.c.

Referenced by flash_fat16_write().

◆ flash_fat16_clear_upgrade_flag()

void flash_fat16_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 243 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ flash_fat16_get_upgrade_flag()

uint8_t flash_fat16_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the iap flag

Definition at line 268 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_init()

void flash_fat16_init ( void )

flash fat16 iap init

Parameters
none
Return values
none

Definition at line 720 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_loop_status()

void flash_fat16_loop_status ( void )

loop status

Parameters
none
Return values
none

Definition at line 177 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ flash_fat16_read()

uint32_t flash_fat16_read | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 288 of file flash_fat16.c.

Referenced by msc_disk_read().

◆ flash_fat16_sector_write()

uint32_t flash_fat16_sector_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write sector

Parameters
fat_lbk | logical block address
data | pointer to array to store data
len | data length
Return values
nubmer of data

Definition at line 486 of file flash_fat16.c.

Referenced by flash_fat16_write().

◆ flash_fat16_set_name()

uint32_t flash_fat16_set_name | ( | const uint8_t * | file_name,
 |  | uint8_t | len
 | ) |  |

set file name

Parameters
file_name | file name
len | filename length
Return values
filename length

Definition at line 357 of file flash_fat16.c.

Referenced by flash_fat16_loop_status().

◆ flash_fat16_set_upgrade_flag()

void flash_fat16_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 255 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ flash_fat16_write()

uint32_t flash_fat16_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 329 of file flash_fat16.c.

Referenced by msc_disk_write().

◆ flash_read_data()

uint32_t flash_read_data | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read data from flash

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
read length

Definition at line 652 of file flash_fat16.c.

◆ flash_write_data()

uint32_t flash_write_data | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write data to flash

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
write status

Definition at line 671 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ get_inquiry()

uint8_t * get_inquiry ( uint8_t lun )

get disk inquiry

Parameters
lun logical units number
Return values
inquiry string

Definition at line 57 of file virtual_msc_iap/src/msc_diskio.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 232 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status(), and main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ msc_disk_capacity()

usb_sts_type msc_disk_capacity | ( | uint8_t | lun,
 |  | uint32_t * | blk_nbr,
 |  | uint32_t * | blk_size
 | ) |  |

disk capacity

Parameters
lun | logical units number
blk_nbr | pointer to number of block
blk_size | pointer to block size
Return values
status of usb_sts_type

Definition at line 115 of file virtual_msc_iap/src/msc_diskio.c.

◆ msc_disk_read()

usb_sts_type msc_disk_read | ( | uint8_t | lun,
 |  | uint64_t | addr,
 |  | uint8_t * | read_buf,
 |  | uint32_t | len
 | ) |  |

disk read

Parameters
lun | logical units number
addr | logical address
read_buf | pointer to read buffer
len | read length
Return values
status of usb_sts_type

Definition at line 73 of file virtual_msc_iap/src/msc_diskio.c.

◆ msc_disk_write()

usb_sts_type msc_disk_write | ( | uint8_t | lun,
 |  | uint64_t | addr,
 |  | uint8_t * | buf,
 |  | uint32_t | len
 | ) |  |

disk write

Parameters
lun | logical units number
addr | logical address
buf | pointer to write buffer
len | write length
Return values
status of usb_sts_type

Definition at line 95 of file virtual_msc_iap/src/msc_diskio.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 53 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 265 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 276 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

◆ usb_reset()

void usb_reset ( )

usb re-connect

Parameters
none
Return values
none

Definition at line 164 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 255 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Variable Documentation

◆ fat16_file_name

uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Initial value:
=
{
'R',
'e',
'a',
'd',
'y',
' ',
' ',
' ',
'T',
'X',
'T'
}

Definition at line 155 of file flash_fat16.c.

Referenced by flash_fat16_read(), and flash_fat16_set_name().

◆ fat16_root_dir_sector

const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]

Definition at line 106 of file flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_sector

uint8_t fat16_sector[62]
static

Definition at line 35 of file flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_table_sector0

const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Initial value:
=
{
0xF8,
0xFF,
0xFF,
0xFF
}

Definition at line 147 of file flash_fat16.c.

Referenced by flash_fat16_read().

◆ file_match

uint8_t file_match = 0

Definition at line 173 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ file_write_nr

uint32_t file_write_nr = 0

Definition at line 172 of file flash_fat16.c.

◆ flash_iap

flash_iap_type flash_iap

Definition at line 171 of file flash_fat16.c.

Referenced by flash_fat16_addr_offset(), flash_fat16_boot_dir_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_loop_status(), flash_fat16_sector_write(), flash_fat16_set_upgrade_flag(), flash_write_data(), and main().

◆ g_file_attr

fat_dir_type g_file_attr

Definition at line 170 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ jump_to_app

void jump_to_app

jump to app

Parameters
none
Return values
none

Definition at line 44 of file bootloader/src/iap.c.

Referenced by app_load(), and main().

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 43 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by jump_to_app().

◆ scsi_inquiry

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
},
}
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:155

Definition at line 36 of file virtual_msc_iap/src/msc_diskio.c.

Referenced by get_inquiry().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 41 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main(), usb_reset(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_virtual_msc_iap_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_device_virtual_msc_iap_definition
AT32F413_periph_examples » USB_device_virtual_msc_iap

Data Structures

struct | fat_dir_type
struct | flash_iap_type

Macros

#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08005000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1

Enumerations

enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}

Functions

uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | flash_fat16_loop_status (void)
loop status More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...

Variables

flash_iap_type flash_iap

Detailed Description

Macro Definition Documentation

◆ FAT16_BYTE_PER_SIZE

#define FAT16_BYTE_PER_SIZE 2048

Definition at line 48 of file flash_fat16.h.

◆ FAT16_DIR_SIZE

#define FAT16_DIR_SIZE 47

Definition at line 50 of file flash_fat16.h.

◆ FAT16_FILENAME_SIZE

#define FAT16_FILENAME_SIZE 11

Definition at line 49 of file flash_fat16.h.

◆ FAT16_SECTOR_SIZE

#define FAT16_SECTOR_SIZE 62

Definition at line 46 of file flash_fat16.h.

◆ FAT16_TABLE_SIZE

#define FAT16_TABLE_SIZE 4

Definition at line 47 of file flash_fat16.h.

◆ FILE_SUFFIX1_LEN

#define FILE_SUFFIX1_LEN 3

Definition at line 68 of file flash_fat16.h.

◆ FILE_SUFFIX1_NAME

#define FILE_SUFFIX1_NAME "BIN"

Definition at line 70 of file flash_fat16.h.

◆ FILE_SUFFIX2_LEN

#define FILE_SUFFIX2_LEN 3

Definition at line 69 of file flash_fat16.h.

◆ FILE_SUFFIX2_NAME

#define FILE_SUFFIX2_NAME "bin"

Definition at line 71 of file flash_fat16.h.

◆ FLASH_APP_START_ADDR

#define FLASH_APP_START_ADDR 0x08005000

Definition at line 58 of file flash_fat16.h.

◆ FLASH_FAT16_1_ADDR

#define FLASH_FAT16_1_ADDR 0x3000

Definition at line 53 of file flash_fat16.h.

◆ FLASH_FAT16_2_ADDR

#define FLASH_FAT16_2_ADDR 0x3800

Definition at line 54 of file flash_fat16.h.

◆ FLASH_FAT16_BOOT_SECTOR_ADDR

#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00

Definition at line 52 of file flash_fat16.h.

◆ FLASH_FAT16_FILE_START_ADDR

#define FLASH_FAT16_FILE_START_ADDR 0x8800

Definition at line 56 of file flash_fat16.h.

◆ FLASH_FAT16_ROOT_ADDR

#define FLASH_FAT16_ROOT_ADDR 0x4000

Definition at line 55 of file flash_fat16.h.

◆ FLASH_SECTOR_1K_ALLGNED

#define FLASH_SECTOR_1K_ALLGNED 0x3FF

Definition at line 64 of file flash_fat16.h.

◆ FLASH_SECTOR_1K_SIZE

#define FLASH_SECTOR_1K_SIZE 0x400

Definition at line 60 of file flash_fat16.h.

◆ FLASH_SECTOR_2K_ALLGNED

#define FLASH_SECTOR_2K_ALLGNED 0x7FF

Definition at line 65 of file flash_fat16.h.

◆ FLASH_SECTOR_2K_SIZE

#define FLASH_SECTOR_2K_SIZE 0x800

Definition at line 61 of file flash_fat16.h.

◆ FLASH_SECTOR_4K_ALLGNED

#define FLASH_SECTOR_4K_ALLGNED 0xFFF

Definition at line 66 of file flash_fat16.h.

◆ FLASH_SECTOR_4K_SIZE

#define FLASH_SECTOR_4K_SIZE 0x1000

Definition at line 62 of file flash_fat16.h.

◆ IAP_FAILED

#define IAP_FAILED 1

Definition at line 76 of file flash_fat16.h.

◆ IAP_SUCCESS

#define IAP_SUCCESS 0

Definition at line 75 of file flash_fat16.h.

◆ IAP_UPGRADE_COMPLETE_FLAG

#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38

Definition at line 74 of file flash_fat16.h.

◆ INVAILD_OFFSET_ADDR

#define INVAILD_OFFSET_ADDR 0xFFFFFFFF

Definition at line 73 of file flash_fat16.h.

Enumeration Type Documentation

◆ upgrade_status_type

enum upgrade_status_type
Enumerator
UPGRADE_READY
UPGRAGE_ONGOING
UPGRADE_SUCCESS
UPGRADE_FAILED
UPGRADE_LARGE
UPGRADE_UNKNOWN
UPGRADE_DONE
UPGRADE_JUMP

Definition at line 78 of file flash_fat16.h.

Function Documentation

◆ flash_fat16_get_upgrade_flag()

uint8_t flash_fat16_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the iap flag

Definition at line 268 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_init()

void flash_fat16_init ( void )

flash fat16 iap init

Parameters
none
Return values
none

Definition at line 720 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_loop_status()

void flash_fat16_loop_status ( void )

loop status

Parameters
none
Return values
none

Definition at line 177 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ flash_fat16_read()

uint32_t flash_fat16_read | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 288 of file flash_fat16.c.

Referenced by msc_disk_read().

◆ flash_fat16_set_name()

uint32_t flash_fat16_set_name | ( | const uint8_t * | file_name,
 |  | uint8_t | len
 | ) |  |

set file name

Parameters
file_name | file name
len | filename length
Return values
filename length

Definition at line 357 of file flash_fat16.c.

Referenced by flash_fat16_loop_status().

◆ flash_fat16_write()

uint32_t flash_fat16_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 329 of file flash_fat16.c.

Referenced by msc_disk_write().

Variable Documentation

◆ flash_iap

flash_iap_type flash_iap
extern

Definition at line 171 of file flash_fat16.c.

Referenced by flash_fat16_addr_offset(), flash_fat16_boot_dir_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_loop_status(), flash_fat16_sector_write(), flash_fat16_set_upgrade_flag(), flash_write_data(), and main().


AT32F413 Firmwary Library: fat_dir_type Struct Reference

Data Fields
fat_dir_type Struct Reference
AT32F413_periph_examples » USB_device_virtual_msc_iap » USB_device_virtual_msc_iap_definition

#include <flash_fat16.h>

Data Fields

uint8_t | file_name [11]
uint8_t | attr
uint8_t | res
uint8_t | create_time_tenth
uint16_t | create_time
uint16_t | create_data
uint16_t | last_access_data
uint16_t | clus_high
uint16_t | write_time
uint16_t | write_data
uint16_t | clus_low
uint32_t | file_size

Detailed Description

Definition at line 90 of file flash_fat16.h.

Field Documentation

◆ attr

uint8_t fat_dir_type::attr

Definition at line 93 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

◆ clus_high

uint16_t fat_dir_type::clus_high

Definition at line 99 of file flash_fat16.h.

◆ clus_low

uint16_t fat_dir_type::clus_low

Definition at line 102 of file flash_fat16.h.

◆ create_data

uint16_t fat_dir_type::create_data

Definition at line 97 of file flash_fat16.h.

◆ create_time

uint16_t fat_dir_type::create_time

Definition at line 96 of file flash_fat16.h.

◆ create_time_tenth

uint8_t fat_dir_type::create_time_tenth

Definition at line 95 of file flash_fat16.h.

◆ file_name

uint8_t fat_dir_type::file_name[11]

Definition at line 92 of file flash_fat16.h.

Referenced by flash_fat16_sector_write().

◆ file_size

uint32_t fat_dir_type::file_size

Definition at line 103 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ last_access_data

uint16_t fat_dir_type::last_access_data

Definition at line 98 of file flash_fat16.h.

◆ res

uint8_t fat_dir_type::res

Definition at line 94 of file flash_fat16.h.

◆ write_data

uint16_t fat_dir_type::write_data

Definition at line 101 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

◆ write_time

uint16_t fat_dir_type::write_time

Definition at line 100 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

The documentation for this struct was generated from the following file:
  • flash_fat16.h


AT32F413 Firmwary Library: flash_iap_type Struct Reference

Data Fields
flash_iap_type Struct Reference
AT32F413_periph_examples » USB_device_virtual_msc_iap » USB_device_virtual_msc_iap_definition

#include <flash_fat16.h>

Data Fields

uint32_t | flash_base_addr
uint32_t | flash_app_addr
uint32_t | flash_size
uint32_t | flash_app_size
uint32_t | sector_size
uint32_t | sector_mask
uint32_t | firmware_length
uint32_t | write_crc
uint32_t | read_crc
uint32_t | write_addr
uint32_t | file_write_nr
upgrade_status_type msc_up_status

Detailed Description

Definition at line 106 of file flash_fat16.h.

Field Documentation

◆ file_write_nr

uint32_t flash_iap_type::file_write_nr

Definition at line 119 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ firmware_length

uint32_t flash_iap_type::firmware_length

Definition at line 114 of file flash_fat16.h.

◆ flash_app_addr

uint32_t flash_iap_type::flash_app_addr

Definition at line 109 of file flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_set_upgrade_flag(), and main().

◆ flash_app_size

uint32_t flash_iap_type::flash_app_size

Definition at line 111 of file flash_fat16.h.

Referenced by flash_fat16_init(), and flash_fat16_sector_write().

◆ flash_base_addr

uint32_t flash_iap_type::flash_base_addr

Definition at line 108 of file flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_init(), flash_fat16_sector_write(), and flash_write_data().

◆ flash_size

uint32_t flash_iap_type::flash_size

Definition at line 110 of file flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_init(), and flash_write_data().

◆ msc_up_status

upgrade_status_type flash_iap_type::msc_up_status

Definition at line 120 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), flash_fat16_loop_status(), and flash_fat16_sector_write().

◆ read_crc

uint32_t flash_iap_type::read_crc

Definition at line 116 of file flash_fat16.h.

◆ sector_mask

uint32_t flash_iap_type::sector_mask

Definition at line 113 of file flash_fat16.h.

Referenced by flash_fat16_init(), and flash_write_data().

◆ sector_size

uint32_t flash_iap_type::sector_size

Definition at line 112 of file flash_fat16.h.

Referenced by flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_set_upgrade_flag(), and flash_write_data().

◆ write_addr

uint32_t flash_iap_type::write_addr

Definition at line 118 of file flash_fat16.h.

Referenced by flash_fat16_init(), flash_fat16_loop_status(), and flash_fat16_sector_write().

◆ write_crc

uint32_t flash_iap_type::write_crc

Definition at line 115 of file flash_fat16.h.

The documentation for this struct was generated from the following file:
  • flash_fat16.h


AT32F413 Firmwary Library: WDT_reset

Functions
WDT_reset
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< watchdog timer reset flag

< watchdog timer reset flag

Definition at line 42 of file project/at_start_f413/examples/wdt/wdt_reset/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: WDT_standby

Functions
WDT_standby
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< watchdog timer reset flag

< watchdog timer reset flag

Definition at line 42 of file project/at_start_f413/examples/wdt/wdt_standby/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.


AT32F413 Firmwary Library: WWDT_reset

Functions
WWDT_reset
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< window watchdog timer reset flag

< window watchdog timer reset flag

Definition at line 41 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: AT32F413_periph_template

Modules
AT32F413_periph_template

Modules

Library_configuration
System_clock_configuration
LED_toggle

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: Library_configuration

Macros
Library_configuration
AT32F413_periph_template

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 83 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 80 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 51 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 60 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 84 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 81 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 82 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 79 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 78 of file project/at_start_f413/templates/inc/at32f413_conf.h.


AT32F413 Firmwary Library: System_clock_configuration

Functions
System_clock_configuration
AT32F413_periph_template

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 54 of file project/at_start_f413/templates/src/at32f413_clock.c.


AT32F413 Firmwary Library: LED_toggle

Macros | Functions | Variables
LED_toggle
AT32F413_periph_template

Macros

#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...

Variables

uint8_t g_speed = 1

Detailed Description

Macro Definition Documentation

◆ DELAY

#define DELAY 100

Definition at line 36 of file project/at_start_f413/templates/src/main.c.

◆ FAST

#define FAST 1

Definition at line 37 of file project/at_start_f413/templates/src/main.c.

◆ SLOW

#define SLOW 4

Definition at line 38 of file project/at_start_f413/templates/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

Definition at line 50 of file project/at_start_f413/templates/src/main.c.

Referenced by main().

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

Definition at line 73 of file project/at_start_f413/templates/src/main.c.

Referenced by EXINT0_IRQHandler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/templates/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/templates/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/templates/src/at32f413_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 40 of file project/at_start_f413/templates/src/main.c.

Referenced by button_isr(), and main().


AT32F413 Firmwary Library: UTILITIES_examples

Modules
UTILITIES_examples

Modules

FreeRTOS_demo
GEN_random_number_demo
SLIB_project_l0
SLIB_project_l1
USART_iap_app_led3_toggle
USART_iap_app_led4_toggle
USART_iap_bootloader
USB_iap_app_led3_toggle
USB_iap_app_led4_toggle
USB_iap_bootloader

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: FreeRTOS_demo

Functions | Variables
FreeRTOS_demo
UTILITIES_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | DebugMon_Handler (void)
this function handles svcall exception. More...
void | led2_task_function (void *pvParameters)
void | led3_task_function (void *pvParameters)
int | main (void)
main function. More...

Variables

TaskHandle_t | led2_handler
TaskHandle_t | led3_handler

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles svcall exception.

this function handles debug monitor exception.

Parameters
none
Return values
none

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ led2_task_function()

void led2_task_function ( void * pvParameters )

Definition at line 103 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().

◆ led3_task_function()

void led3_task_function ( void * pvParameters )

Definition at line 113 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_freertos_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

Variable Documentation

◆ led2_handler

TaskHandle_t led2_handler

Definition at line 37 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().

◆ led3_handler

TaskHandle_t led3_handler

Definition at line 38 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: GEN_random_number_demo

Modules | Macros | Functions
GEN_random_number_demo
UTILITIES_examples

Modules

RTC_asseed_definition
GEN_random_number_demo_exported_functions

Macros

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
int | get_uid_for_seed (void)
get uid value as seed More...
void | randnum_test (void)
enable rtc as seed More...

Detailed Description

Macro Definition Documentation

◆ DEVICE_ID_ADDR1

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Definition at line 39 of file random.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ get_uid_for_seed()

int get_uid_for_seed ( void )

get uid value as seed

Parameters
none
Return values
uid_one_word

Definition at line 46 of file random.c.

Referenced by randnum_test().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_gen_random_number_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ randnum_test()

void randnum_test ( void )

enable rtc as seed

Parameters
none
Return values
none

random number test

Parameters
none
Return values
none

Definition at line 120 of file random.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.


AT32F413 Firmwary Library: RTC_asseed_definition

Macros
RTC_asseed_definition
UTILITIES_examples » GEN_random_number_demo

Macros

#define ENABLE_RTC_ASSEED (1)

Detailed Description

Macro Definition Documentation

◆ ENABLE_RTC_ASSEED

#define ENABLE_RTC_ASSEED (1)

Definition at line 47 of file random.h.


AT32F413 Firmwary Library: GEN_random_number_demo_exported_functions

Functions
GEN_random_number_demo_exported_functions
UTILITIES_examples » GEN_random_number_demo

Functions

void randnum_test (void)
enable rtc as seed More...

Detailed Description

Function Documentation

◆ randnum_test()

void randnum_test ( void )

enable rtc as seed

Parameters
none
Return values
none

random number test

Parameters
none
Return values
none

Definition at line 120 of file random.c.

Referenced by main().


AT32F413 Firmwary Library: SLIB_project_l0

Macros | Functions | Variables
SLIB_project_l0
UTILITIES_examples

Macros

#define | USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */
#define | FLASH_START_ADDR 0x08000000
#define | TEST_SLIB_PSW 0x55665566
#define | SLIB_START_ADDR 0x08001000
#define | SLIB_DATA_ADDR 0x08002000
#define | SLIB_END_ADDR 0x08002800
#define | FLASH_SECTOR_SIZE 0x800
#define | SECTOR_NUM(dwAddr) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)
#define | SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */
#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...
flash_status_type | slib_enable (void)
config slib enable and program slib area. More...
int | main (void)
main function. More...

Variables

uint32_t | dw_start_sector
uint32_t | dw_data_start_sector
uint32_t | dw_end_sector
uint32_t | temp_buf [512]
static float32_t | testOutput [320]

Detailed Description

Macro Definition Documentation

◆ FLASH_SECTOR_SIZE

#define FLASH_SECTOR_SIZE 0x800

Definition at line 50 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ FLASH_START_ADDR

#define FLASH_START_ADDR 0x08000000

Definition at line 45 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SECTOR_NUM

#define SECTOR_NUM ( dwAddr ) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)

Definition at line 51 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SECTOR_WORD_CNT

#define SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */

Definition at line 52 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SLIB_DATA_ADDR

#define SLIB_DATA_ADDR 0x08002000

Definition at line 48 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SLIB_END_ADDR

#define SLIB_END_ADDR 0x08002800

Definition at line 49 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SLIB_START_ADDR

#define SLIB_START_ADDR 0x08001000

Definition at line 47 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SNR_THRESHOLD_F32

#define SNR_THRESHOLD_F32 140.0f

Definition at line 54 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES 320

Definition at line 55 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ TEST_SLIB_PSW

#define TEST_SLIB_PSW 0x55665566

Definition at line 46 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ USE_SLIB_FUNCTION

#define USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */

Definition at line 42 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ FLASH_IRQHandler()

void FLASH_IRQHandler ( void )

flash handler.

Parameters
none
Return values
none

< flash bank1 erase/program protection error flag

< flash bank1 erase/program protection error flag

Definition at line 139 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 127 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ slib_enable()

flash_status_type slib_enable ( void )

config slib enable and program slib area.

Parameters
none
Return values
flash status

Definition at line 91 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

Variable Documentation

◆ dw_data_start_sector

uint32_t dw_data_start_sector

Definition at line 58 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ dw_end_sector

uint32_t dw_end_sector

Definition at line 58 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ dw_start_sector

uint32_t dw_start_sector

Definition at line 58 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ temp_buf

uint32_t temp_buf[512]

Definition at line 59 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ testOutput

float32_t testOutput[320]
static

Definition at line 62 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SLIB_project_l1

Macros | Functions | Variables
SLIB_project_l1
UTILITIES_examples

Macros

#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...
void | config_flash_interrupt (void)
config flash error interrupt. More...
int | main (void)
main function. More...

Variables

static float32_t testOutput [320]

Detailed Description

Macro Definition Documentation

◆ SNR_THRESHOLD_F32

#define SNR_THRESHOLD_F32 140.0f

Definition at line 42 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES 320

Definition at line 43 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 77 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ config_flash_interrupt()

void config_flash_interrupt ( void )

config flash error interrupt.

Parameters
none
Return values
flash status

< flash bank1 error interrupt

Definition at line 54 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 112 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ FLASH_IRQHandler()

void FLASH_IRQHandler ( void )

flash handler.

Parameters
none
Return values
none

< flash bank1 erase/program protection error flag

< flash bank1 erase/program protection error flag

Definition at line 139 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 51 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 70 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 64 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 42 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 121 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 103 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 130 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 90 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

Variable Documentation

◆ testOutput

float32_t testOutput[320]
static

Definition at line 45 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_iap_app_led3_toggle

Modules | Functions | Variables
USART_iap_app_led3_toggle
UTILITIES_examples

Modules

App_led3_definition
App_led3_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 118 of file app_led3_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 105 of file app_led3_toggle/src/usart.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 42 of file app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 59 of file app_led3_toggle/src/iap.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 44 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 70 of file app_led3_toggle/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 42 of file app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file app_led3_toggle/src/usart.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 85 of file app_led3_toggle/src/usart.c.

Variable Documentation

◆ iap_flag

uint8_t iap_flag = IAP_REV_FLAG_NO

Definition at line 36 of file app_led3_toggle/src/usart.c.

Referenced by USART1_IRQHandler().


AT32F413 Firmwary Library: App_led3_definition

Macros
App_led3_definition
UTILITIES_examples » USART_iap_app_led3_toggle

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38
#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08004000

Definition at line 47 of file app_led3_toggle/inc/iap.h.

◆ IAP_REV_FLAG_5A

#define IAP_REV_FLAG_5A 1

Definition at line 49 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_DONE

#define IAP_REV_FLAG_DONE 2

Definition at line 50 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_ERROR

#define IAP_REV_FLAG_ERROR 3

Definition at line 51 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_NO

#define IAP_REV_FLAG_NO 0

Definition at line 48 of file app_led3_toggle/inc/usart.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 54 of file app_led3_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)

Definition at line 50 of file app_led3_toggle/inc/iap.h.


AT32F413 Firmwary Library: App_led3_exported_functions

Functions
App_led3_exported_functions
UTILITIES_examples » USART_iap_app_led3_toggle

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 118 of file app_led3_toggle/src/usart.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 105 of file app_led3_toggle/src/usart.c.

Referenced by main().

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 42 of file app_led3_toggle/src/iap.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 59 of file app_led3_toggle/src/iap.c.

Referenced by main().

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 42 of file app_led3_toggle/src/tmr.c.

Referenced by main().

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: USART_iap_app_led4_toggle

Modules | Functions | Variables
USART_iap_app_led4_toggle
UTILITIES_examples

Modules

App_led4_definition
App_led4_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 118 of file app_led4_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 105 of file app_led4_toggle/src/usart.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 42 of file app_led4_toggle/src/iap.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 59 of file app_led4_toggle/src/iap.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 44 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 70 of file app_led4_toggle/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 42 of file app_led4_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file app_led4_toggle/src/usart.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 85 of file app_led4_toggle/src/usart.c.

Variable Documentation

◆ iap_flag

uint8_t iap_flag = IAP_REV_FLAG_NO

Definition at line 36 of file app_led4_toggle/src/usart.c.

Referenced by iap_command_handle(), and USART1_IRQHandler().


AT32F413 Firmwary Library: App_led4_definition

Macros
App_led4_definition
UTILITIES_examples » USART_iap_app_led4_toggle

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38
#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08004000

Definition at line 47 of file app_led4_toggle/inc/iap.h.

◆ IAP_REV_FLAG_5A

#define IAP_REV_FLAG_5A 1

Definition at line 49 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_DONE

#define IAP_REV_FLAG_DONE 2

Definition at line 50 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_ERROR

#define IAP_REV_FLAG_ERROR 3

Definition at line 51 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_NO

#define IAP_REV_FLAG_NO 0

Definition at line 48 of file app_led4_toggle/inc/usart.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 54 of file app_led4_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)

Definition at line 50 of file app_led4_toggle/inc/iap.h.


AT32F413 Firmwary Library: App_led4_exported_functions

Functions
App_led4_exported_functions
UTILITIES_examples » USART_iap_app_led4_toggle

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 118 of file app_led3_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 105 of file app_led3_toggle/src/usart.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 42 of file app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 59 of file app_led3_toggle/src/iap.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 42 of file app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: USART_iap_bootloader

Modules | Functions | Variables
USART_iap_bootloader
UTILITIES_examples

Modules

Bootloader_definition
Bootloader_exported_functions
Bootloader_exported_types

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
void | app_load (uint32_t app_addr)
app load. More...
uint8_t | data_take (void)
take data from usart buf. More...
void | command_handle (void)
command analysis handle. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...
void | app_update_handle (void)
app update flow handle. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...

Variables

cmd_data_group_type cmd_data_group_type_struct
cmd_data_step_type cmd_data_step
cmd_ctr_step_type cmd_ctr_step
update_status_type update_status
usart_group_type usart_group_struct
cmd_data_step_type cmd_data_step = CMD_DATA_IDLE
cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE
cmd_data_group_type cmd_data_group_struct
update_status_type update_status = UPDATE_PRE
static uint8_t | cmd_addr_cnt = 0
static uint32_t | cmd_data_cnt = 0
uint8_t | time_ira_cnt =0
uint8_t | get_data_from_usart_flag = 0
usart_group_type usart_group_struct

Detailed Description

Function Documentation

◆ app_load()

void app_load ( uint32_t app_addr )

app load.

Parameters
app_addr app code starting address
Return values
none

Definition at line 58 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ app_update_handle()

void app_update_handle ( void )

app update flow handle.

Parameters
none
Return values
none

Definition at line 260 of file bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 239 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and TMR3_GLOBAL_IRQHandler().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 226 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ command_handle()

void command_handle ( void )

command analysis handle.

Parameters
none
Return values
none

Definition at line 104 of file bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ data_take()

uint8_t data_take ( void )

take data from usart buf.

Parameters
app_addr app code starting address
Return values
val took data

Definition at line 87 of file bootloader/src/iap.c.

Referenced by command_handle().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by app_update_handle().

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ iap_upgrade_app_handle()

void iap_upgrade_app_handle ( void )

iap upgrade app handle.

Parameters
none
Return values
none

Definition at line 342 of file bootloader/src/iap.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 45 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 73 of file bootloader/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 45 of file bootloader/src/tmr.c.

Referenced by main().

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file bootloader/src/usart.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 85 of file bootloader/src/usart.c.

Variable Documentation

◆ cmd_addr_cnt

uint8_t cmd_addr_cnt = 0
static

Definition at line 42 of file bootloader/src/iap.c.

Referenced by back_err(), and command_handle().

◆ cmd_ctr_step [1/2]

cmd_ctr_step_type cmd_ctr_step
extern

Definition at line 39 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_ctr_step [2/2]

cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE

Definition at line 39 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_data_cnt

uint32_t cmd_data_cnt = 0
static

Definition at line 43 of file bootloader/src/iap.c.

Referenced by back_err(), and command_handle().

◆ cmd_data_group_struct

cmd_data_group_type cmd_data_group_struct

Definition at line 40 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and command_handle().

◆ cmd_data_group_type_struct

cmd_data_group_type cmd_data_group_type_struct
extern

◆ cmd_data_step [1/2]

cmd_data_step_type cmd_data_step
extern

Definition at line 38 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_data_step [2/2]

cmd_data_step_type cmd_data_step = CMD_DATA_IDLE

Definition at line 38 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ get_data_from_usart_flag

uint8_t get_data_from_usart_flag = 0

Definition at line 38 of file bootloader/src/tmr.c.

Referenced by app_update_handle(), back_err(), and TMR3_GLOBAL_IRQHandler().

◆ time_ira_cnt

uint8_t time_ira_cnt =0

Definition at line 37 of file bootloader/src/tmr.c.

Referenced by back_err(), TMR3_GLOBAL_IRQHandler(), and USART1_IRQHandler().

◆ update_status [1/2]

update_status_type update_status
extern

Definition at line 41 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ update_status [2/2]

update_status_type update_status = UPDATE_PRE

Definition at line 41 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ usart_group_struct [1/2]

usart_group_type usart_group_struct
extern

Definition at line 36 of file bootloader/src/usart.c.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().

◆ usart_group_struct [2/2]

usart_group_type usart_group_struct

Definition at line 36 of file bootloader/src/usart.c.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().


AT32F413 Firmwary Library: Bootloader_definition

Macros
Bootloader_definition
UTILITIES_examples » USART_iap_bootloader | UTILITIES_examples » USB_iap_bootloader

Macros

#define | FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */
#define | SRAM_SIZE 64 /* sram size, unit:kbyte */
#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38
#define | USART_REC_LEN 1024
#define | FLASH_APP_ADDRESS 0x08006000

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08004000

Definition at line 47 of file bootloader/inc/iap.h.

◆ FLASH_APP_ADDRESS

#define FLASH_APP_ADDRESS 0x08006000

Definition at line 47 of file bootloader/inc/hid_iap_user.h.

◆ FLASH_SIZE

#define FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */

Definition at line 46 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 54 of file bootloader/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)

Definition at line 50 of file bootloader/inc/iap.h.

◆ SRAM_SIZE

#define SRAM_SIZE 64 /* sram size, unit:kbyte */

Definition at line 47 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h.

◆ USART_REC_LEN

#define USART_REC_LEN 1024

Definition at line 46 of file bootloader/inc/usart.h.


AT32F413 Firmwary Library: Bootloader_exported_functions

Functions
Bootloader_exported_functions
UTILITIES_examples » USART_iap_bootloader | UTILITIES_examples » USB_iap_bootloader

Functions

void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
void | command_handle (void)
command analysis handle. More...
void | back_err (void)
command response error. More...
void | back_ok (void)
command response ok. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
void | app_load (uint32_t appxaddr)
app load. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_loop (void)
iap loop More...
void | jump_to_app (uint32_t address)
jump to app More...

Detailed Description

Function Documentation

◆ app_load()

void app_load ( uint32_t app_addr )

app load.

Parameters
app_addr app code starting address
Return values
none

Definition at line 58 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 118 of file app_led3_toggle/src/usart.c.

Referenced by app_update_handle().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 105 of file app_led3_toggle/src/usart.c.

Referenced by app_update_handle().

◆ command_handle()

void command_handle ( void )

command analysis handle.

Parameters
none
Return values
none

Definition at line 104 of file bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by app_update_handle().

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by main().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 59 of file app_led3_toggle/src/iap.c.

Referenced by iap_idle(), and iap_start().

◆ iap_loop()

void iap_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 471 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_upgrade_app_handle()

void iap_upgrade_app_handle ( void )

iap upgrade app handle.

Parameters
none
Return values
none

Definition at line 342 of file bootloader/src/iap.c.

Referenced by main().

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 232 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status(), iap_loop(), and main().

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 42 of file app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 43 of file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: Bootloader_exported_types

Data Structures | Typedefs | Enumerations
Bootloader_exported_types
UTILITIES_examples » USART_iap_bootloader

Data Structures

struct | cmd_data_group_type
cmd data group type More...
struct | usart_group_type
usart group type More...

Typedefs

typedef void(* iapfun) (void)

Enumerations

enum cmd_data_step_type {
CMD_DATA_IDLE , CMD_DATA_ADDR , CMD_DATA_BUF , CMD_DATA_CHACK ,
CMD_DATA_DONE , CMD_DATA_ERR
}
cmd data step type More...
enum cmd_ctr_step_type {
CMD_CTR_IDLE , CMD_CTR_INIT , CMD_CTR_DONE , CMD_CTR_ERR ,
CMD_CTR_APP
}
cmd ctr step type More...
enum update_status_type { UPDATE_PRE , UPDATE_CLEAR_FLAG , UPDATE_ING , UPDATE_DONE }
update status type More...

Detailed Description

Typedef Documentation

◆ iapfun

typedef void(* iapfun) (void)

Definition at line 111 of file bootloader/inc/iap.h.

Enumeration Type Documentation

◆ cmd_ctr_step_type

enum cmd_ctr_step_type

cmd ctr step type

Enumerator
CMD_CTR_IDLE
CMD_CTR_INIT
CMD_CTR_DONE
CMD_CTR_ERR
CMD_CTR_APP

Definition at line 91 of file bootloader/inc/iap.h.

◆ cmd_data_step_type

enum cmd_data_step_type

cmd data step type

Enumerator
CMD_DATA_IDLE
CMD_DATA_ADDR
CMD_DATA_BUF
CMD_DATA_CHACK
CMD_DATA_DONE
CMD_DATA_ERR

Definition at line 78 of file bootloader/inc/iap.h.

◆ update_status_type

enum update_status_type

update status type

Enumerator
UPDATE_PRE
UPDATE_CLEAR_FLAG
UPDATE_ING
UPDATE_DONE

Definition at line 103 of file bootloader/inc/iap.h.


AT32F413 Firmwary Library: cmd_data_group_type Struct Reference

Data Fields
cmd_data_group_type Struct Reference
UTILITIES_examples » USART_iap_bootloader » Bootloader_exported_types

cmd data group type More...

#include <iap.h>

Data Fields

uint8_t | cmd_head
uint8_t | cmd_addr [4]
uint8_t | cmd_buf [0x800]
uint8_t | cmd_check

Detailed Description

cmd data group type

Definition at line 67 of file bootloader/inc/iap.h.

Field Documentation

◆ cmd_addr

uint8_t cmd_data_group_type::cmd_addr[4]

Definition at line 70 of file bootloader/inc/iap.h.

Referenced by app_update_handle(), and command_handle().

◆ cmd_buf

uint8_t cmd_data_group_type::cmd_buf[0x800]

Definition at line 71 of file bootloader/inc/iap.h.

Referenced by app_update_handle(), and command_handle().

◆ cmd_check

uint8_t cmd_data_group_type::cmd_check

Definition at line 72 of file bootloader/inc/iap.h.

◆ cmd_head

uint8_t cmd_data_group_type::cmd_head

Definition at line 69 of file bootloader/inc/iap.h.

The documentation for this struct was generated from the following file:
  • bootloader/inc/iap.h


AT32F413 Firmwary Library: usart_group_type Struct Reference

Data Fields
usart_group_type Struct Reference
UTILITIES_examples » USART_iap_bootloader » Bootloader_exported_types

usart group type More...

#include <usart.h>

Data Fields

uint16_t | buf [1024]
uint16_t | head
uint16_t | tail
uint16_t | count

Detailed Description

usart group type

Definition at line 59 of file bootloader/inc/usart.h.

Field Documentation

◆ buf

uint16_t usart_group_type::buf[1024]

Definition at line 61 of file bootloader/inc/usart.h.

Referenced by data_take(), and USART1_IRQHandler().

◆ count

uint16_t usart_group_type::count

Definition at line 64 of file bootloader/inc/usart.h.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().

◆ head

uint16_t usart_group_type::head

Definition at line 62 of file bootloader/inc/usart.h.

Referenced by USART1_IRQHandler().

◆ tail

uint16_t usart_group_type::tail

Definition at line 63 of file bootloader/inc/usart.h.

Referenced by data_take(), and USART1_IRQHandler().

The documentation for this struct was generated from the following file:
  • bootloader/inc/usart.h


AT32F413 Firmwary Library: USB_iap_app_led3_toggle

Modules | Macros | Functions | Variables
USB_iap_app_led3_toggle
UTILITIES_examples

Modules

App_led3_toggle_definition
App_led3_toggle_exported_functions

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
int | main (void)
main function. More...

Variables

void(* pftarget )(void)
usbd_core_type usb_core_dev

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 251 of file app_led3_toggle/src/hid_iap_user.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ iap_finish()

void iap_finish ( void )

Definition at line 313 of file bootloader/src/hid_iap_user.c.

◆ iap_get()

void iap_get ( )

Definition at line 157 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 95 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by iap_idle(), and iap_start().

◆ iap_jump()

void iap_jump ( void )

Definition at line 146 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 175 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 149 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 128 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 139 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 238 of file app_led3_toggle/src/hid_iap_user.c.

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 192 of file app_led3_toggle/src/hid_iap_user.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 118 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Variable Documentation

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 37 of file app_led3_toggle/src/hid_iap_user.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 41 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: App_led3_toggle_definition

Macros
App_led3_toggle_definition
UTILITIES_examples » USB_iap_app_led3_toggle

Macros

#define FLASH_APP_ADDRESS 0x08006000

Detailed Description

Macro Definition Documentation

◆ FLASH_APP_ADDRESS

#define FLASH_APP_ADDRESS 0x08006000

Definition at line 47 of file app_led3_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: App_led3_toggle_exported_functions

Functions
App_led3_toggle_exported_functions
UTILITIES_examples » USB_iap_app_led3_toggle

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 251 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by main().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 59 of file app_led3_toggle/src/iap.c.


AT32F413 Firmwary Library: USB_iap_app_led4_toggle

Modules | Macros | Functions | Variables
USB_iap_app_led4_toggle
UTILITIES_examples

Modules

App_led4_toggle_definition
App_led4_toggle_exported_functions

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
int | main (void)
main function. More...

Variables

void(* pftarget )(void)
usbd_core_type usb_core_dev

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 251 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ crc_cal()

uint32_t crc_cal | ( | uint32_t | addr,
 |  | uint16_t | nk
 | ) |  |

crc cal

Parameters
addr | start address
nk | nk byte
Return values
crc value

Definition at line 153 of file bootloader/src/hid_iap_user.c.

Referenced by iap_crc().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ iap_clear_upgrade_flag()

void iap_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 53 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by app_loop().

◆ iap_finish()

void iap_finish ( void )

Definition at line 313 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get()

void iap_get ( )

Definition at line 157 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led4_toggle/src/hid_iap_user.c.

◆ iap_idle()

void iap_idle ( void )

iap idle function

Parameters
none
Return values
none

Definition at line 122 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 95 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by iap_idle(), and iap_start().

◆ iap_jump()

void iap_jump ( void )

Definition at line 146 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 175 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ iap_set_upgrade_flag()

void iap_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 65 of file app_led4_toggle/src/hid_iap_user.c.

◆ iap_start()

void iap_start ( void )

iap start function

Parameters
none
Return values
none

Definition at line 134 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 149 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 128 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 139 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 238 of file app_led4_toggle/src/hid_iap_user.c.

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 192 of file app_led4_toggle/src/hid_iap_user.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 118 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Variable Documentation

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 37 of file app_led4_toggle/src/hid_iap_user.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 41 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: App_led4_toggle_definition

Macros
App_led4_toggle_definition
UTILITIES_examples » USB_iap_app_led4_toggle

Macros

#define FLASH_APP_ADDRESS 0x08006000

Detailed Description

Macro Definition Documentation

◆ FLASH_APP_ADDRESS

#define FLASH_APP_ADDRESS 0x08006000

Definition at line 47 of file app_led4_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: App_led4_toggle_exported_functions

Functions
App_led4_toggle_exported_functions
UTILITIES_examples » USB_iap_app_led4_toggle

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 251 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 59 of file app_led3_toggle/src/iap.c.


AT32F413 Firmwary Library: USB_iap_bootloader

Modules | Macros | Functions | Variables
USB_iap_bootloader
UTILITIES_examples

Modules

Bootloader_definition
Bootloader_exported_functions

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
iap_result_type | iap_address (uint8_t *pdata, uint32_t len)
iap parse address More...
void | iap_finish (void)
iap_result_type | iap_data_write (uint8_t *pdata, uint32_t len)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
void | jump_to_app (uint32_t address)
jump to app More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_erase_sector (uint32_t address)
set iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_crc (uint8_t *pdata, uint32_t len)
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | iap_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
int | main (void)
main function. More...

Variables

void(* pftarget )(void)
usbd_core_type usb_core_dev

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ crc_cal()

uint32_t crc_cal | ( | uint32_t | addr,
 |  | uint16_t | nk
 | ) |  |

crc cal

Parameters
addr | start address
nk | nk byte
Return values
crc value

Definition at line 153 of file bootloader/src/hid_iap_user.c.

Referenced by iap_crc().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ iap_address()

iap_result_type iap_address | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

iap parse address

Parameters
pdata | data buffer pointer.
len | data length
Return values
the result of the address parse

Definition at line 227 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_clear_upgrade_flag()

void iap_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 80 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address().

◆ iap_crc()

void iap_crc | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

Definition at line 326 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_data_write()

iap_result_type iap_data_write | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

Definition at line 268 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_erase_sector()

void iap_erase_sector ( uint32_t address )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 122 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address().

◆ iap_finish()

void iap_finish ( void )

Definition at line 313 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get()

void iap_get ( )

Definition at line 365 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 104 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_idle()

void iap_idle ( void )

iap idle function

Parameters
none
Return values
none

Definition at line 202 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 175 of file bootloader/src/hid_iap_user.c.

Referenced by iap_idle(), iap_start(), and main().

◆ iap_jump()

void iap_jump ( void )

Definition at line 354 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_loop()

void iap_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 471 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 383 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address(), iap_crc(), iap_data_write(), iap_finish(), iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ iap_set_upgrade_flag()

void iap_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 92 of file bootloader/src/hid_iap_user.c.

Referenced by iap_finish().

◆ iap_start()

void iap_start ( void )

iap start function

Parameters
none
Return values
none

Definition at line 214 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 55 of file bootloader/src/hid_iap_user.c.

Referenced by iap_loop().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 150 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 129 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 140 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 458 of file bootloader/src/hid_iap_user.c.

Referenced by class_in_handler().

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 400 of file bootloader/src/hid_iap_user.c.

Referenced by class_out_handler().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 119 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

Variable Documentation

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 37 of file bootloader/src/hid_iap_user.c.

Referenced by jump_to_app().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 41 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: Data Structures

Data Structures
Here are the data structures with brief descriptions:
C acc_type | Type define acc register all
C adc_base_config_type | Adc base config type
C adc_type | Type define adc register all
C audio_codec_type |
C bpr_type | Type define bpr register all
C calendar_type |
C can_base_type | Can init structure definition
C can_baudrate_type | Can baudrate structure definition
C can_fifo_mailbox_type | Can controller area network fifo mailbox
C can_filter_init_type | Can filter init structure definition
C can_filter_register_type | Can controller area network filter bit register
C can_rx_message_type | Can rx message structure definition
C can_tx_mailbox_type | Can controller area network tx mailbox
C can_tx_message_type | Can tx message structure definition
C can_type | Type define can register all
C cbd_extended_type | Extended command block description
C cbd_typical_type | Typical command block description
C cbw_type | Command block wrapper
C cdc_msc_struct_type | Usb cdc class struct
C cdc_struct_type | Usb cdc class struct
C cmd_data_group_type | Cmd data group type
C crc_type | Type define crc register all
C crm_clocks_freq_type | Crm clocks freqency structure
C crm_type | Type define crm register all
C csw_type | Command block wrapper
C custom_hid_type |
C debug_type | Type define debug register all
C dma_channel_type | Type define dma channel register all
C dma_init_type | Dma init type
C dma_type | Type define dma register
C exint_init_type | Exint init type
C exint_type | Type define exint register all
C fat_dir_type |
C flash_iap_type |
C flash_type | Type define flash register all
C gpio_init_type | Gpio init type
C gpio_type | Type define gpio register all
C i2c_handle_type |
C i2c_type | Type define i2c register all
C i2s_init_type | I2s init type
C iap_info_type |
C iomux_type | Type define iomux register all
C keyboard_type |
C linecoding_type | Usb cdc class set line coding struct
C mouse_type |
C msc_type |
C printer_type |
C pwc_type | Type define pwc register all
C rtc_type | Type define rtc register all
C sc_atr_type |
C sd_card_info_struct_type |
C sd_cid_struct_type |
C sd_csd_struct_type |
C sd_scr_struct_type |
C sdio_command_struct_type | Sdio command structure
C sdio_data_struct_type | Sdio data structure
C sdio_type | Type define sdio register all
C sense_type | Request sense standard data
C spi_init_type | Spi init type
C spi_type | Type define spi register all
C tmr_brkdt_config_type | Tmr brkdt config type
C tmr_input_config_type | Tmr input capture config type
C tmr_output_config_type | Tmr output config type
C tmr_type | Type define tmr register all
C usart_group_type | Usart group type
C usart_type | Type define usart register all
C usb_audio_hid_type | Usb audio control struct
C usb_audio_type | Usb audio control struct
C usb_configuration_desc_type | Format of standard configuration descriptor
C usb_device_desc_type | Format of standard device descriptor
C usb_endpoint_desc_type | Format of standard endpoint descriptor
C usb_ept_info | Usb endpoint infomation structure definition
C usb_header_desc_type | Format of header
C usb_interface_desc_type | Format of standard interface descriptor
C usb_setup_type | Format of usb setup data
C usbd_class_handler | Usb device class handler
C usbd_core_type | Usb device core struct type
C usbd_desc_handler | Usb device descriptor handler
C usbd_desc_t | Usb device descriptor struct
C usbd_type | Type define usb register all
C usd_type | User system data
C vcp_keyboard_type |
C wdt_type | Type define wdt register all
C wwdt_type | Type define wwdt register all


AT32F413 Firmwary Library: Data Structure Index

Data Structure Index
A | B | C | D | E | F | G | I | K | L | M | P | R | S | T | U | V | W
A
acc_type
adc_base_config_type
adc_type
audio_codec_type
B
bpr_type
C
calendar_type
can_base_type
can_baudrate_type
can_fifo_mailbox_type
can_filter_init_type
can_filter_register_type
can_rx_message_type
can_tx_mailbox_type
can_tx_message_type
can_type
cbd_extended_type
cbd_typical_type
cbw_type
cdc_msc_struct_type
cdc_struct_type
cmd_data_group_type
crc_type
crm_clocks_freq_type
crm_type
csw_type
custom_hid_type
D
debug_type
dma_channel_type
dma_init_type
dma_type
E
exint_init_type
exint_type
F
fat_dir_type
flash_iap_type
flash_type
G
gpio_init_type
gpio_type
I
i2c_handle_type
i2c_type
i2s_init_type
iap_info_type
iomux_type
K
keyboard_type
L
linecoding_type
M
mouse_type
msc_type
P
printer_type
pwc_type
R
rtc_type
S
sc_atr_type
sd_card_info_struct_type
sd_cid_struct_type
sd_csd_struct_type
sd_scr_struct_type
sdio_command_struct_type
sdio_data_struct_type
sdio_type
sense_type
spi_init_type
spi_type
T
tmr_brkdt_config_type
tmr_input_config_type
tmr_output_config_type
tmr_type
U
usart_group_type
usart_type
usb_audio_hid_type
usb_audio_type
usb_configuration_desc_type
usb_device_desc_type
usb_endpoint_desc_type
usb_ept_info
usb_header_desc_type
usb_interface_desc_type
usb_setup_type
usbd_class_handler
usbd_core_type
usbd_desc_handler
usbd_desc_t
usbd_type
usd_type
V
vcp_keyboard_type
W
wdt_type
wwdt_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • accen : crm_type
  • accrst : crm_type
  • acken : i2c_type
  • ackfail : i2c_type
  • acs : spi_type
  • adc1_eto_gmux : iomux_type
  • adc1_etp_gmux : iomux_type
  • adc1_extrgord_mux : iomux_type
  • adc1_extrgpre_mux : iomux_type
  • adc1en : crm_type
  • adc1rst : crm_type
  • adc2_eto_gmux : iomux_type
  • adc2_etp_gmux : iomux_type
  • adc2_extrgord_mux : iomux_type
  • adc2_extrgpre_mux : iomux_type
  • adc2en : crm_type
  • adc2odt : adc_type
  • adc2rst : crm_type
  • adc_freq : crm_clocks_freq_type
  • adcal : adc_type
  • adcalinit : adc_type
  • adcdiv_h : crm_type
  • adcdiv_l : crm_type
  • adcen : adc_type
  • addr : flash_type, tmr_type, usbd_type
  • addr1 : i2c_type
  • addr1mode : i2c_type
  • addr2 : i2c_type
  • addr2en : i2c_type
  • addr3 : flash_type
  • addr3_bit : flash_type
  • addr7f : i2c_type
  • addr_bit : flash_type
  • address : cbd_extended_type, cbd_typical_type
  • addrhf : i2c_type
  • aebo_enable : can_base_type
  • aeboen : can_type
  • aed_enable : can_base_type
  • aeden : can_type
  • ahb_freq : crm_clocks_freq_type
  • ahbdiv : crm_type
  • ahben : crm_type
  • ahben_bit : crm_type
  • alertf : i2c_type
  • alloc_length : cbd_extended_type, cbd_typical_type
  • alt_setting : cdc_msc_struct_type, cdc_struct_type, custom_hid_type, iap_info_type, keyboard_type, mouse_type, msc_type, printer_type, usb_audio_hid_type, vcp_keyboard_type
  • aoen : tmr_type
  • apb1_freq : crm_clocks_freq_type
  • apb1div : crm_type
  • apb1en : crm_type
  • apb1en_bit : crm_type
  • apb1rst : crm_type
  • apb1rst_bit : crm_type
  • apb2_freq : crm_clocks_freq_type
  • apb2div : crm_type
  • apb2en : crm_type
  • apb2en_bit : crm_type
  • apb2rst : crm_type
  • apb2rst_bit : crm_type
  • app_address : iap_info_type
  • argu : sdio_type
  • argu_bit : sdio_type
  • argument : sdio_command_struct_type
  • arlost : i2c_type
  • arpen : i2c_type
  • as_length : sense_type
  • asc : sense_type
  • ascq : sense_type
  • attr : fat_dir_type
  • audio_bitw : audio_codec_type
  • audio_cmd : usb_audio_hid_type, usb_audio_type
  • audio_cmd_len : usb_audio_hid_type, usb_audio_type
  • audio_feed_back : usb_audio_hid_type, usb_audio_type
  • audio_freq : audio_codec_type
  • audio_mic_data : usb_audio_hid_type, usb_audio_type
  • audio_protocol : i2s_init_type
  • audio_sampling_freq : i2s_init_type
  • audio_spk_data : usb_audio_hid_type, usb_audio_type
  • auto_output_enable : tmr_brkdt_config_type
  • auto_step_en : crm_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • bAlternateSetting : usb_interface_desc_type
  • bankers : flash_type
  • baudr : usart_type
  • baudr_bit : usart_type
  • baudrate_div : can_baudrate_type
  • bCBWCBLength : cbw_type
  • bCBWLUN : cbw_type
  • bcdDevice : usb_device_desc_type
  • bcdUSB : usb_device_desc_type
  • bConfigurationValue : usb_configuration_desc_type
  • bCSWStatus : csw_type
  • bDescriptorType : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • bDeviceClass : usb_device_desc_type
  • bDeviceProtocol : usb_device_desc_type
  • bDeviceSubClass : usb_device_desc_type
  • be : usbd_type
  • beien : usbd_type
  • bEndpointAddress : usb_endpoint_desc_type
  • bf : spi_type
  • bfbn : usart_type
  • bff : usart_type
  • bfien : usart_type
  • bInterfaceClass : usb_interface_desc_type
  • bInterfaceNumber : usb_interface_desc_type
  • bInterfaceProtocol : usb_interface_desc_type
  • bInterfaceSubClass : usb_interface_desc_type
  • bInterval : usb_endpoint_desc_type
  • bitrate : linecoding_type
  • bLength : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • blk_addr : cdc_msc_struct_type, msc_type
  • blk_len : cdc_msc_struct_type, msc_type
  • blk_nbr : cdc_msc_struct_type, msc_type
  • blk_size : cdc_msc_struct_type, msc_type
  • blksize : sdio_type
  • block_size : sdio_data_struct_type
  • bmAttributes : usb_configuration_desc_type, usb_endpoint_desc_type
  • bMaxPacketSize0 : usb_device_desc_type
  • bMaxPower : usb_configuration_desc_type
  • bmCBWFlags : cbw_type
  • bmRequestType : usb_setup_type
  • bNumConfigurations : usb_device_desc_type
  • bNumEndpoints : usb_interface_desc_type
  • bNumInterfaces : usb_configuration_desc_type
  • bof : can_type
  • boien : can_type
  • bot_status : cdc_msc_struct_type, msc_type
  • bpdc : crm_type
  • bpdc_bit : crm_type
  • bpdrst : crm_type
  • bpren : crm_type
  • bprrst : crm_type
  • bpwen : pwc_type
  • brdiv : can_type
  • bRequest : usb_setup_type
  • brk : tmr_type
  • brk_bit : tmr_type
  • brk_enable : tmr_brkdt_config_type
  • brk_polarity : tmr_brkdt_config_type
  • brken : tmr_type
  • brkie : tmr_type
  • brkif : tmr_type
  • brkswtr : tmr_type
  • brkv : tmr_type
  • btaddr : usbd_type
  • btmg : can_type
  • btmg_bit : can_type
  • bts1 : can_type
  • bts1_size : can_baudrate_type
  • bts2 : can_type
  • bts2_size : can_baudrate_type
  • buf : sdio_type, usart_group_type
  • buf_bit : sdio_type
  • bufcnt : sdio_type
  • bufcnt_bit : sdio_type
  • buffer_size : dma_init_type
  • buftbl : usbd_type
  • buftbl_bit : usbd_type
  • buserr : i2c_type
  • busws : sdio_type
  • busyf : i2c_type
  • bypsen : sdio_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • c1 : acc_type
  • c1_bit : acc_type
  • c1c : tmr_type
  • c1cen : tmr_type
  • c1cios : tmr_type
  • c1cp : tmr_type
  • c1den : tmr_type
  • c1df : tmr_type
  • c1dt : tmr_type
  • c1dt_bit : tmr_type
  • c1en : tmr_type
  • c1idiv : tmr_type
  • c1ien : tmr_type
  • c1if : tmr_type
  • c1insel : tmr_type
  • c1ios : tmr_type
  • c1oben : tmr_type
  • c1octrl : tmr_type
  • c1oien : tmr_type
  • c1osen : tmr_type
  • c1p : tmr_type
  • c1rf : tmr_type
  • c1swtr : tmr_type
  • c2 : acc_type
  • c2_bit : acc_type
  • c2c : tmr_type
  • c2cen : tmr_type
  • c2cios : tmr_type
  • c2cp : tmr_type
  • c2den : tmr_type
  • c2df : tmr_type
  • c2dt : tmr_type
  • c2dt_bit : tmr_type
  • c2en : tmr_type
  • c2idiv : tmr_type
  • c2ien : tmr_type
  • c2if : tmr_type
  • c2ios : tmr_type
  • c2oben : tmr_type
  • c2octrl : tmr_type
  • c2oien : tmr_type
  • c2osen : tmr_type
  • c2p : tmr_type
  • c2rf : tmr_type
  • c2swtr : tmr_type
  • c3 : acc_type
  • c3_bit : acc_type
  • c3c : tmr_type
  • c3cen : tmr_type
  • c3cios : tmr_type
  • c3cp : tmr_type
  • c3den : tmr_type
  • c3df : tmr_type
  • c3dt : tmr_type
  • c3dt_bit : tmr_type
  • c3en : tmr_type
  • c3idiv : tmr_type
  • c3ien : tmr_type
  • c3if : tmr_type
  • c3ios : tmr_type
  • c3oben : tmr_type
  • c3octrl : tmr_type
  • c3oien : tmr_type
  • c3osen : tmr_type
  • c3p : tmr_type
  • c3rf : tmr_type
  • c3swtr : tmr_type
  • c4c : tmr_type
  • c4den : tmr_type
  • c4df : tmr_type
  • c4dt : tmr_type
  • c4dt_bit : tmr_type
  • c4en : tmr_type
  • c4idiv : tmr_type
  • c4ien : tmr_type
  • c4if : tmr_type
  • c4ios : tmr_type
  • c4oben : tmr_type
  • c4octrl : tmr_type
  • c4oien : tmr_type
  • c4osen : tmr_type
  • c4p : tmr_type
  • c4rf : tmr_type
  • c4swtr : tmr_type
  • calon : acc_type
  • calout : bpr_type
  • calrdy : acc_type
  • calrdyien : acc_type
  • calval : bpr_type
  • can1_gmux : iomux_type
  • can1_pause : debug_type
  • can1en : crm_type
  • can1rst : crm_type
  • can2_gmux : iomux_type
  • can2_pause : debug_type
  • can2en : crm_type
  • can2rst : crm_type
  • can_mux : iomux_type
  • card_blk_size : sd_card_info_struct_type
  • card_capacity : sd_card_info_struct_type
  • card_cmd_classes : sd_csd_struct_type
  • card_type : sd_card_info_struct_type
  • cardsts1 : sdio_type
  • cardsts2 : sdio_type
  • cardsts3 : sdio_type
  • cardsts4 : sdio_type
  • cbctrl : tmr_type
  • cbw_struct : cdc_msc_struct_type, msc_type
  • CBWCB : cbw_type
  • cce : adc_type
  • cceien : adc_type
  • ccen : spi_type
  • ccerr : spi_type
  • ccfs : tmr_type
  • ccos : bpr_type
  • ccsmen : sdio_type
  • cctrl : tmr_type
  • cctrl_bit : tmr_type
  • cdt : crc_type
  • cdt_bit : crc_type
  • cen : usbd_type
  • cfden : crm_type
  • cfdf : crm_type
  • cfdfc : crm_type
  • cfg : crm_type, usbd_type, wwdt_type
  • cfg_bit : crm_type, usbd_type, wwdt_type
  • cfgen : rtc_type
  • cfgf : rtc_type
  • cfghr : gpio_type
  • cfghr_bit : gpio_type
  • cfglr : gpio_type
  • cfglr_bit : gpio_type
  • ch1_src : dma_type
  • ch2_src : dma_type
  • ch3_src : dma_type
  • ch4_src : dma_type
  • ch5_src : dma_type
  • ch6_src : dma_type
  • ch7_src : dma_type
  • chen : dma_channel_type
  • chpers : flash_type
  • chpl : dma_channel_type
  • cid_crc : sd_cid_struct_type
  • class_handler : usbd_core_type
  • clck : usbd_type
  • clear_handler : usbd_class_handler
  • clk_to_tmr : crm_type
  • clkctrl : i2c_type, sdio_type
  • clkctrl_bit : i2c_type, sdio_type
  • clkdiv : tmr_type
  • clkdiv_h : sdio_type
  • clkdiv_l : sdio_type
  • clkegs : sdio_type
  • clken : usart_type
  • clkfreq : i2c_type
  • clkint : crm_type
  • clkint_bit : crm_type
  • clkoen : sdio_type
  • clkout_sel : crm_type
  • clkoutdiv : crm_type
  • clkpha : spi_type, usart_type
  • clkpol : spi_type, usart_type
  • clock_phase : spi_init_type
  • clock_polarity : i2s_init_type, spi_init_type
  • clr : dma_type, gpio_type
  • clr_bit : dma_type, gpio_type
  • clsef : pwc_type
  • clswef : pwc_type
  • clus_high : fat_dir_type
  • clus_low : fat_dir_type
  • cm1 : tmr_type
  • cm1_input_bit : tmr_type
  • cm1_output_bit : tmr_type
  • cm2 : tmr_type
  • cm2_input_bit : tmr_type
  • cm2_output_bit : tmr_type
  • cmd : wdt_type
  • cmd20_support : sd_scr_struct_type
  • cmd23_support : sd_scr_struct_type
  • cmd_addr : cmd_data_group_type
  • cmd_bit : wdt_type
  • cmd_buf : cmd_data_group_type
  • cmd_check : cmd_data_group_type
  • cmd_head : cmd_data_group_type
  • cmd_index : sdio_command_struct_type
  • cmdcmpl : sdio_type
  • cmdcmplien : sdio_type
  • cmdctrl : sdio_type
  • cmdctrl_bit : sdio_type
  • cmdfail : sdio_type
  • cmdfailien : sdio_type
  • cmdidx : sdio_type
  • cmdrspcmpl : sdio_type
  • cmdrspcmplien : sdio_type
  • cmdtimeout : sdio_type
  • cmdtimeoutien : sdio_type
  • cnt : dma_channel_type, rtc_type, sdio_type, wwdt_type
  • cnt_dir : tmr_type
  • cnth : rtc_type
  • cnth_bit : rtc_type
  • cntl : rtc_type
  • cntl_bit : rtc_type
  • config_status : usbd_core_type
  • conn_state : usbd_core_type
  • content_protect_app : sd_csd_struct_type
  • copy_flag : sd_csd_struct_type
  • count : usart_group_type
  • cpoly : spi_type
  • cpoly_bit : spi_type
  • crc_chkr : flash_type
  • crc_chkr_bit : flash_type
  • crc_ctrl : flash_type
  • crc_ctrl_bit : flash_type
  • crc_sn : flash_type
  • crc_ss : flash_type
  • crc_strt : flash_type
  • crcen : crm_type
  • create_data : fat_dir_type
  • create_time : fat_dir_type
  • create_time_tenth : fat_dir_type
  • cs_mode_selection : spi_init_type
  • csd_crc : sd_csd_struct_type
  • csd_struct : sd_csd_struct_type
  • cspt0 : adc_type
  • cspt1 : adc_type
  • cspt10 : adc_type
  • cspt11 : adc_type
  • cspt12 : adc_type
  • cspt13 : adc_type
  • cspt14 : adc_type
  • cspt15 : adc_type
  • cspt16 : adc_type
  • cspt17 : adc_type
  • cspt2 : adc_type
  • cspt3 : adc_type
  • cspt4 : adc_type
  • cspt5 : adc_type
  • cspt6 : adc_type
  • cspt7 : adc_type
  • cspt8 : adc_type
  • cspt9 : adc_type
  • csrst : usbd_type
  • csw_struct : cdc_msc_struct_type, msc_type
  • ctrl : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrl1 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl1_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl3 : flash_type, usart_type
  • ctrl3_bit : flash_type, usart_type
  • ctrl_bit : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrlh : rtc_type
  • ctrlh_bit : rtc_type
  • ctrll : rtc_type
  • ctrll_bit : rtc_type
  • ctrlsts : bpr_type, crm_type, pwc_type
  • ctrlsts_bit : bpr_type, crm_type, pwc_type
  • ctscf : usart_type
  • ctscfien : usart_type
  • ctsen : usart_type
  • curs : can_type
  • cuss : can_type
  • cval : tmr_type
  • cval_bit : tmr_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • da : flash_type
  • da_bit : flash_type
  • data : can_rx_message_type, can_tx_message_type, cdc_msc_struct_type, linecoding_type, msc_type
  • data0 : usd_type
  • data1 : usd_type
  • data2 : usd_type
  • data3 : usd_type
  • data4 : usd_type
  • data5 : usd_type
  • data6 : usd_type
  • data7 : usd_type
  • data_align : adc_base_config_type
  • data_channel_format : i2s_init_type
  • data_len : cdc_msc_struct_type, msc_type
  • data_length : sdio_data_struct_type
  • data_stat_after_erase : sd_scr_struct_type
  • dataien : i2c_type
  • date : calendar_type
  • dbn : usart_type
  • dCBWDataTransferLength : cbw_type
  • dCBWSignature : cbw_type
  • dCBWTage : cbw_type
  • dCSWDataResidue : csw_type
  • dCSWSignature : csw_type
  • dCSWTag : csw_type
  • deadtime : tmr_brkdt_config_type
  • deepsleep_debug : debug_type
  • default_config : usbd_core_type
  • depslp_rst : flash_type
  • desc_handler : usbd_core_type
  • descriptor : usbd_desc_t
  • dev_config : usbd_core_type
  • devaddr : usbd_type
  • devaddr_bit : usbd_type
  • devaddrf : i2c_type
  • device_addr : usbd_core_type
  • device_size : sd_csd_struct_type
  • device_size_mult : sd_csd_struct_type
  • direction : dma_init_type
  • dirf : i2c_type
  • disusb : usbd_type
  • div : rtc_type, tmr_type, usart_type, wdt_type, wwdt_type
  • div_bit : tmr_type, wdt_type
  • divcnt : rtc_type
  • divcnth : rtc_type
  • divcnth_bit : rtc_type
  • divcntl : rtc_type
  • divcntl_bit : rtc_type
  • divf : wdt_type
  • divh : rtc_type
  • divh_bit : rtc_type
  • divl : rtc_type
  • divl_bit : rtc_type
  • dlc : can_rx_message_type, can_tx_message_type
  • dma1en : crm_type
  • dma2en : crm_type
  • dma_flex_en : dma_type
  • dma_init_struct : i2c_handle_type
  • dma_rx_channel : i2c_handle_type
  • dma_tx_channel : i2c_handle_type
  • dmactrl : tmr_type
  • dmactrl_bit : tmr_type
  • dmadt : tmr_type
  • dmadt_bit : tmr_type
  • dmaen : i2c_type, sdio_type
  • dmaend : i2c_type
  • dmaren : spi_type, usart_type
  • dmaten : spi_type, usart_type
  • dmsts : usbd_type
  • docmd : sdio_type
  • docmdien : sdio_type
  • dorx : sdio_type
  • dorxien : sdio_type
  • dotx : sdio_type
  • dotxien : sdio_type
  • dpsts : usbd_type
  • drs : tmr_type
  • dsr_implemented : sd_csd_struct_type
  • dt : bpr_type, crc_type, i2c_type, sdio_type, spi_type, usart_type
  • dt1 : bpr_type
  • dt10 : bpr_type
  • dt10_bit : bpr_type
  • dt11 : bpr_type
  • dt11_bit : bpr_type
  • dt12 : bpr_type
  • dt12_bit : bpr_type
  • dt13 : bpr_type
  • dt13_bit : bpr_type
  • dt14 : bpr_type
  • dt14_bit : bpr_type
  • dt15 : bpr_type
  • dt15_bit : bpr_type
  • dt16 : bpr_type
  • dt16_bit : bpr_type
  • dt17 : bpr_type
  • dt17_bit : bpr_type
  • dt18 : bpr_type
  • dt18_bit : bpr_type
  • dt19 : bpr_type
  • dt19_bit : bpr_type
  • dt1_bit : bpr_type
  • dt2 : bpr_type
  • dt20 : bpr_type
  • dt20_bit : bpr_type
  • dt21 : bpr_type
  • dt21_bit : bpr_type
  • dt22 : bpr_type
  • dt22_bit : bpr_type
  • dt23 : bpr_type
  • dt23_bit : bpr_type
  • dt24 : bpr_type
  • dt24_bit : bpr_type
  • dt25 : bpr_type
  • dt25_bit : bpr_type
  • dt26 : bpr_type
  • dt26_bit : bpr_type
  • dt27 : bpr_type
  • dt27_bit : bpr_type
  • dt28 : bpr_type
  • dt28_bit : bpr_type
  • dt29 : bpr_type
  • dt29_bit : bpr_type
  • dt2_bit : bpr_type
  • dt3 : bpr_type
  • dt30 : bpr_type
  • dt30_bit : bpr_type
  • dt31 : bpr_type
  • dt31_bit : bpr_type
  • dt32 : bpr_type
  • dt32_bit : bpr_type
  • dt33 : bpr_type
  • dt33_bit : bpr_type
  • dt34 : bpr_type
  • dt34_bit : bpr_type
  • dt35 : bpr_type
  • dt35_bit : bpr_type
  • dt36 : bpr_type
  • dt36_bit : bpr_type
  • dt37 : bpr_type
  • dt37_bit : bpr_type
  • dt38 : bpr_type
  • dt38_bit : bpr_type
  • dt39 : bpr_type
  • dt39_bit : bpr_type
  • dt3_bit : bpr_type
  • dt4 : bpr_type
  • dt40 : bpr_type
  • dt40_bit : bpr_type
  • dt41 : bpr_type
  • dt41_bit : bpr_type
  • dt42 : bpr_type
  • dt42_bit : bpr_type
  • dt4_bit : bpr_type
  • dt5 : bpr_type
  • dt5_bit : bpr_type
  • dt6 : bpr_type
  • dt6_bit : bpr_type
  • dt7 : bpr_type
  • dt7_bit : bpr_type
  • dt8 : bpr_type
  • dt8_bit : bpr_type
  • dt9 : bpr_type
  • dt9_bit : bpr_type
  • dt_bit : crc_type, i2c_type, spi_type, usart_type
  • dtalign : adc_type
  • dtb : tmr_type
  • dtblkcmpl : sdio_type
  • dtblkcmplien : sdio_type
  • dtc : tmr_type
  • dtcmpl : sdio_type
  • dtcmplien : sdio_type
  • dtcnt : dma_channel_type, sdio_type
  • dtcnt_bit : dma_channel_type, sdio_type
  • dtctrl : sdio_type
  • dtctrl_bit : sdio_type
  • dtd : dma_channel_type
  • dterrf1 : dma_type
  • dterrf2 : dma_type
  • dterrf3 : dma_type
  • dterrf4 : dma_type
  • dterrf5 : dma_type
  • dterrf6 : dma_type
  • dterrf7 : dma_type
  • dterrfc1 : dma_type
  • dterrfc2 : dma_type
  • dterrfc3 : dma_type
  • dterrfc4 : dma_type
  • dterrfc5 : dma_type
  • dterrfc6 : dma_type
  • dterrfc7 : dma_type
  • dterrien : dma_channel_type
  • dtfail : sdio_type
  • dtfailien : sdio_type
  • dtlen : sdio_type
  • dtlen_bit : sdio_type
  • dttimeout : sdio_type
  • dttimeoutien : sdio_type
  • dttmr : sdio_type
  • dttmr_bit : sdio_type
  • dutymode : i2c_type
  • dzc : can_type
  • dzen : can_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • eaf : can_type
  • eaien : can_type
  • ecc_code : sd_csd_struct_type
  • ecmben : tmr_type
  • edzien : can_type
  • edzif : can_type
  • eien : acc_type
  • enpd : usb_audio_hid_type, usb_audio_type
  • entrim : acc_type
  • eoien : can_type
  • eoif : can_type
  • eopb0 : usd_type
  • epf : can_type
  • epien : can_type
  • epp0 : usd_type
  • epp1 : usd_type
  • epp2 : usd_type
  • epp3 : usd_type
  • epperr : flash_type
  • epps : flash_type
  • epps_bit : flash_type
  • ept : usbd_type
  • ept0_rx_handler : usbd_class_handler
  • ept0_slen : usb_ept_info
  • ept0_sts : usbd_core_type
  • ept0_tx_handler : usbd_class_handler
  • ept0_wlength : usbd_core_type
  • ept_address : usb_ept_info
  • ept_bit : usbd_type
  • ept_in : usbd_core_type
  • ept_num : usbd_type
  • ept_out : usbd_core_type
  • eptaddr : usbd_type
  • eptn : usb_ept_info
  • erase_group_size : sd_csd_struct_type
  • erase_group_size_mult : sd_csd_struct_type
  • err_code : sense_type
  • errie : flash_type, spi_type
  • errien : i2c_type, usart_type
  • error_code : i2c_handle_type
  • erstr : flash_type
  • esdiv : tmr_type
  • esf : tmr_type
  • esp : tmr_type
  • ests : can_type
  • ests_bit : can_type
  • etr : can_type
  • etrien : can_type
  • event_handler : usbd_class_handler
  • evoen : iomux_type
  • evten : exint_type
  • evten_bit : exint_type
  • evtenx : exint_type
  • evtien : i2c_type
  • evtout : iomux_type
  • evtout_bit : iomux_type
  • exf : usbd_type
  • exint0 : iomux_type
  • exint1 : iomux_type
  • exint10 : iomux_type
  • exint11 : iomux_type
  • exint12 : iomux_type
  • exint13 : iomux_type
  • exint14 : iomux_type
  • exint15 : iomux_type
  • exint2 : iomux_type
  • exint3 : iomux_type
  • exint4 : iomux_type
  • exint5 : iomux_type
  • exint6 : iomux_type
  • exint7 : iomux_type
  • exint8 : iomux_type
  • exint9 : iomux_type
  • exintc1 : iomux_type
  • exintc1_bit : iomux_type
  • exintc2 : iomux_type
  • exintc2_bit : iomux_type
  • exintc3 : iomux_type
  • exintc3_bit : iomux_type
  • exintc4 : iomux_type
  • exintc4_bit : iomux_type
  • exintrst : crm_type
  • ext_flash_key : usd_type
  • ext_spim_en_mux : iomux_type
  • ext_spim_gen : iomux_type
  • ext_spim_gmux : iomux_type
  • extended_id : can_rx_message_type, can_tx_message_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fa : flash_type
  • facfg : can_type
  • facfg_bit : can_type
  • faen0 : can_type
  • faen1 : can_type
  • faen10 : can_type
  • faen11 : can_type
  • faen12 : can_type
  • faen13 : can_type
  • faen2 : can_type
  • faen3 : can_type
  • faen4 : can_type
  • faen5 : can_type
  • faen6 : can_type
  • faen7 : can_type
  • faen8 : can_type
  • faen9 : can_type
  • fap : flash_type, usd_type
  • fbn : spi_type
  • fbwcfg : can_type
  • fbwcfg_bit : can_type
  • fbwsel0 : can_type
  • fbwsel1 : can_type
  • fbwsel10 : can_type
  • fbwsel11 : can_type
  • fbwsel12 : can_type
  • fbwsel13 : can_type
  • fbwsel2 : can_type
  • fbwsel3 : can_type
  • fbwsel4 : can_type
  • fbwsel5 : can_type
  • fbwsel6 : can_type
  • fbwsel7 : can_type
  • fbwsel8 : can_type
  • fbwsel9 : can_type
  • fcs : can_type
  • fcsodis : tmr_type
  • fcsodis_state : tmr_brkdt_config_type
  • fcsoen : tmr_type
  • fcsoen_state : tmr_brkdt_config_type
  • fctrl : can_type
  • fctrl_bit : can_type
  • fda : flash_type
  • fdtf1 : dma_type
  • fdtf2 : dma_type
  • fdtf3 : dma_type
  • fdtf4 : dma_type
  • fdtf5 : dma_type
  • fdtf6 : dma_type
  • fdtf7 : dma_type
  • fdtfc1 : dma_type
  • fdtfc2 : dma_type
  • fdtfc3 : dma_type
  • fdtfc4 : dma_type
  • fdtfc5 : dma_type
  • fdtfc6 : dma_type
  • fdtfc7 : dma_type
  • fdtien : dma_channel_type
  • ferr : usart_type
  • ffb : can_type
  • ffdb1 : can_filter_register_type
  • ffdb2 : can_filter_register_type
  • fifo_length : iap_info_type
  • fifo_mailbox : can_type
  • file_formart : sd_csd_struct_type
  • file_format_group : sd_csd_struct_type
  • file_name : fat_dir_type
  • file_size : fat_dir_type
  • file_write_nr : flash_iap_type
  • filter_activate_enable : can_filter_init_type
  • filter_bit : can_filter_init_type
  • filter_fifo : can_filter_init_type
  • filter_id_high : can_filter_init_type
  • filter_id_low : can_filter_init_type
  • filter_index : can_rx_message_type
  • filter_mask_high : can_filter_init_type
  • filter_mask_low : can_filter_init_type
  • filter_mode : can_filter_init_type
  • filter_number : can_filter_init_type
  • firmware_length : flash_iap_type
  • first_bit_transmission : spi_init_type
  • flag_address : iap_info_type
  • flash_app_addr : flash_iap_type
  • flash_app_size : flash_iap_type
  • flash_base_addr : flash_iap_type
  • flash_end_address : iap_info_type
  • flash_size : flash_iap_type, iap_info_type
  • flash_start_address : iap_info_type
  • flashen : crm_type
  • fmcfg : can_type
  • fmcfg_bit : can_type
  • fmsel0 : can_type
  • fmsel1 : can_type
  • fmsel10 : can_type
  • fmsel11 : can_type
  • fmsel12 : can_type
  • fmsel13 : can_type
  • fmsel2 : can_type
  • fmsel3 : can_type
  • fmsel4 : can_type
  • fmsel5 : can_type
  • fmsel6 : can_type
  • fmsel7 : can_type
  • fmsel8 : can_type
  • fmsel9 : can_type
  • format : linecoding_type
  • fprgm : flash_type
  • fpx : exint_type
  • frame_bit_num : spi_init_type
  • frame_type : can_rx_message_type, can_tx_message_type
  • frf : can_type
  • frf_bit : can_type
  • frfsel0 : can_type
  • frfsel1 : can_type
  • frfsel10 : can_type
  • frfsel11 : can_type
  • frfsel12 : can_type
  • frfsel13 : can_type
  • frfsel2 : can_type
  • frfsel3 : can_type
  • frfsel4 : can_type
  • frfsel5 : can_type
  • frfsel6 : can_type
  • frfsel7 : can_type
  • frfsel8 : can_type
  • frfsel9 : can_type
  • fzc : can_type
  • fzen : can_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • g_audio_cur : usb_audio_hid_type, usb_audio_type
  • g_cmd : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_keyboard_tx_completed : vcp_keyboard_type
  • g_len : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_printer_data : printer_type
  • g_printer_port_status : printer_type
  • g_req : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_rx_buff : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rxhid_buff : custom_hid_type, iap_info_type, usb_audio_hid_type
  • g_rxlen : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_tx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_txhid_buff : custom_hid_type, usb_audio_hid_type
  • g_u8tx_completed : keyboard_type
  • gcaddrf : i2c_type
  • gcaen : i2c_type
  • gdiv : usart_type
  • gdiv_bit : usart_type
  • genstart : i2c_type
  • genstop : i2c_type
  • get_device_config_string : usbd_desc_handler
  • get_device_configuration : usbd_desc_handler
  • get_device_descriptor : usbd_desc_handler
  • get_device_interface_string : usbd_desc_handler
  • get_device_lang_id : usbd_desc_handler
  • get_device_manufacturer_string : usbd_desc_handler
  • get_device_other_speed : usbd_desc_handler
  • get_device_product_string : usbd_desc_handler
  • get_device_qualifier : usbd_desc_handler
  • get_device_serial_string : usbd_desc_handler
  • gf1 : dma_type
  • gf2 : dma_type
  • gf3 : dma_type
  • gf4 : dma_type
  • gf5 : dma_type
  • gf6 : dma_type
  • gf7 : dma_type
  • gfc1 : dma_type
  • gfc2 : dma_type
  • gfc3 : dma_type
  • gfc4 : dma_type
  • gfc5 : dma_type
  • gfc6 : dma_type
  • gfc7 : dma_type
  • gpio_drive_strength : gpio_init_type
  • gpio_mode : gpio_init_type
  • gpio_out_type : gpio_init_type
  • gpio_pins : gpio_init_type
  • gpio_pull : gpio_init_type
  • gpioaen : crm_type
  • gpioarst : crm_type
  • gpioben : crm_type
  • gpiobrst : crm_type
  • gpiocen : crm_type
  • gpiocrst : crm_type
  • gpioden : crm_type
  • gpiodrst : crm_type
  • gpioerst : crm_type
  • gpiofen : crm_type
  • gresume : usbd_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • h : sc_atr_type
  • hallde : tmr_type
  • hallien : tmr_type
  • hallif : tmr_type
  • hallswtr : tmr_type
  • hdtf1 : dma_type
  • hdtf2 : dma_type
  • hdtf3 : dma_type
  • hdtf4 : dma_type
  • hdtf5 : dma_type
  • hdtf6 : dma_type
  • hdtf7 : dma_type
  • hdtfc1 : dma_type
  • hdtfc2 : dma_type
  • hdtfc3 : dma_type
  • hdtfc4 : dma_type
  • hdtfc5 : dma_type
  • hdtfc6 : dma_type
  • hdtfc7 : dma_type
  • hdtien : dma_channel_type
  • head : usart_group_type
  • hextbyps : crm_type
  • hexten : crm_type
  • hextstbl : crm_type
  • hextstblf : crm_type
  • hextstblfc : crm_type
  • hextstblien : crm_type
  • hfcen : sdio_type
  • hick_to_sclk : crm_type
  • hick_to_usb : crm_type
  • hickcal : acc_type, crm_type
  • hickcal_key : crm_type
  • hickdiv : crm_type
  • hicken : crm_type
  • hickstbl : crm_type
  • hickstblf : crm_type
  • hickstblfc : crm_type
  • hickstblien : crm_type
  • hicktrim : acc_type, crm_type
  • hid_get_report : custom_hid_type
  • hid_protocol : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_idle : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_report : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_state : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_suspend_flag : keyboard_type, mouse_type
  • hlength : sc_atr_type
  • hostaddrf : i2c_type
  • hour : calendar_type
  • hwcsoe : spi_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • i2c1_gmux : iomux_type
  • i2c1_mux : iomux_type
  • i2c1_smbus_timeout : debug_type
  • i2c1en : crm_type
  • i2c1rst : crm_type
  • i2c2_gmux : iomux_type
  • i2c2_smbus_timeout : debug_type
  • i2c2en : crm_type
  • i2c2rst : crm_type
  • i2cen : i2c_type
  • i2cx : i2c_handle_type
  • i2scbn : spi_type
  • i2sclk : spi_type
  • i2sclk_bit : spi_type
  • i2sclkpol : spi_type
  • i2sctrl : spi_type
  • i2sctrl_bit : spi_type
  • i2sdbn : spi_type
  • i2sdiv_h : spi_type
  • i2sdiv_l : spi_type
  • i2sen : spi_type
  • i2smclkoe : spi_type
  • i2smsel : spi_type
  • i2sodd : spi_type
  • iap_address : iap_info_type
  • iap_fifo : iap_info_type
  • iap_rx : iap_info_type
  • iap_tx : iap_info_type
  • iConfiguration : usb_configuration_desc_type
  • id : usart_type
  • id_type : can_rx_message_type, can_tx_message_type
  • idcode_bit : debug_type
  • iden : tmr_type
  • iden_bit : tmr_type
  • idlef : usart_type
  • idleien : usart_type
  • idProduct : usb_device_desc_type
  • idt : crc_type, gpio_type
  • idt0 : gpio_type
  • idt1 : gpio_type
  • idt10 : gpio_type
  • idt11 : gpio_type
  • idt12 : gpio_type
  • idt13 : gpio_type
  • idt14 : gpio_type
  • idt15 : gpio_type
  • idt2 : gpio_type
  • idt3 : gpio_type
  • idt4 : gpio_type
  • idt5 : gpio_type
  • idt6 : gpio_type
  • idt7 : gpio_type
  • idt8 : gpio_type
  • idt9 : gpio_type
  • idt_bit : crc_type, gpio_type
  • idVendor : usb_device_desc_type
  • iInterface : usb_interface_desc_type
  • iManufacturer : usb_device_desc_type
  • in_handler : usbd_class_handler
  • information : sense_type
  • init_handler : usbd_class_handler
  • inout : usb_ept_info, usbd_type
  • input_channel_select : tmr_input_config_type
  • input_filter_value : tmr_input_config_type
  • input_mapped_select : tmr_input_config_type
  • input_polarity_select : tmr_input_config_type
  • intclr : sdio_type
  • intclr_bit : sdio_type
  • inten : can_type, exint_type, sdio_type
  • inten_bit : can_type, exint_type, sdio_type
  • intenx : exint_type
  • interface : usb_audio_hid_type, usb_audio_type
  • intmap : crm_type
  • intmap_bit : crm_type
  • intsts : exint_type, usbd_type
  • intsts_bit : exint_type, usbd_type
  • intwt : sdio_type
  • iocb0 : gpio_type
  • iocb1 : gpio_type
  • iocb10 : gpio_type
  • iocb11 : gpio_type
  • iocb12 : gpio_type
  • iocb13 : gpio_type
  • iocb14 : gpio_type
  • iocb15 : gpio_type
  • iocb2 : gpio_type
  • iocb3 : gpio_type
  • iocb4 : gpio_type
  • iocb5 : gpio_type
  • iocb6 : gpio_type
  • iocb7 : gpio_type
  • iocb8 : gpio_type
  • iocb9 : gpio_type
  • ioen : sdio_type
  • iofc0 : gpio_type
  • iofc1 : gpio_type
  • iofc10 : gpio_type
  • iofc11 : gpio_type
  • iofc12 : gpio_type
  • iofc13 : gpio_type
  • iofc14 : gpio_type
  • iofc15 : gpio_type
  • iofc2 : gpio_type
  • iofc3 : gpio_type
  • iofc4 : gpio_type
  • iofc5 : gpio_type
  • iofc6 : gpio_type
  • iofc7 : gpio_type
  • iofc8 : gpio_type
  • iofc9 : gpio_type
  • ioif : sdio_type
  • ioifien : sdio_type
  • iomc0 : gpio_type
  • iomc1 : gpio_type
  • iomc10 : gpio_type
  • iomc11 : gpio_type
  • iomc12 : gpio_type
  • iomc13 : gpio_type
  • iomc14 : gpio_type
  • iomc15 : gpio_type
  • iomc2 : gpio_type
  • iomc3 : gpio_type
  • iomc4 : gpio_type
  • iomc5 : gpio_type
  • iomc6 : gpio_type
  • iomc7 : gpio_type
  • iomc8 : gpio_type
  • iomc9 : gpio_type
  • iomuxen : crm_type
  • iomuxrst : crm_type
  • iosb0 : gpio_type
  • iosb1 : gpio_type
  • iosb10 : gpio_type
  • iosb11 : gpio_type
  • iosb12 : gpio_type
  • iosb13 : gpio_type
  • iosb14 : gpio_type
  • iosb15 : gpio_type
  • iosb2 : gpio_type
  • iosb3 : gpio_type
  • iosb4 : gpio_type
  • iosb5 : gpio_type
  • iosb6 : gpio_type
  • iosb7 : gpio_type
  • iosb8 : gpio_type
  • iosb9 : gpio_type
  • iosusp : sdio_type
  • iProduct : usb_device_desc_type
  • irdaen : usart_type
  • irdalp : usart_type
  • is_double_buffer : usb_ept_info
  • isdiv : usart_type
  • iSerialNumber : usb_device_desc_type
  • ists : tmr_type
  • ists_bit : tmr_type
  • itsrven : adc_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • keyboard_buf : keyboard_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • last_access_data : fat_dir_type
  • last_len : usb_ept_info
  • lbcp : usart_type
  • lben : can_type
  • length : usbd_desc_t
  • lextbyps : crm_type
  • lexten : crm_type
  • lextstbl : crm_type
  • lextstblf : crm_type
  • lextstblfc : crm_type
  • lextstblien : crm_type
  • licken : crm_type
  • lickstbl : crm_type
  • lickstblf : crm_type
  • lickstblfc : crm_type
  • lickstblien : crm_type
  • line_enable : exint_init_type
  • line_mode : exint_init_type
  • line_polarity : exint_init_type
  • line_select : exint_init_type
  • linecoding : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • linen : usart_type
  • linex : exint_type
  • lm : dma_channel_type
  • loen : can_type
  • loop_mode_enable : dma_init_type
  • lpm : usbd_type
  • lprstf : crm_type
  • lpsel : pwc_type
  • lsamprx : can_type
  • lsof : usbd_type
  • lsofien : usbd_type
  • lsofnum : usbd_type
  • ltf : spi_type
  • lun : cbd_extended_type, cbd_typical_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • m2m : dma_channel_type
  • mackctrl : i2c_type
  • maddr : dma_channel_type
  • maddr_bit : dma_channel_type
  • manufact_date : sd_cid_struct_type
  • manufacturer_default_ecc : sd_csd_struct_type
  • manufacturer_id : sd_cid_struct_type
  • master_slave_mode : spi_init_type
  • max_bus_clk_freq : sd_csd_struct_type
  • max_lun : cdc_msc_struct_type, msc_type
  • max_read_blk_length : sd_csd_struct_type
  • max_read_current_vdd_max : sd_csd_struct_type
  • max_read_current_vdd_min : sd_csd_struct_type
  • max_write_blk_length : sd_csd_struct_type
  • max_write_current_vdd_max : sd_csd_struct_type
  • max_write_current_vdd_min : sd_csd_struct_type
  • maxpacket : usb_ept_info
  • mclk_freq_division : spi_init_type
  • mclk_output_enable : i2s_init_type
  • mctrl : can_type
  • mctrl_bit : can_type
  • mdiv_h : spi_type
  • mdiv_l : spi_type
  • mdrsel : can_type
  • mdrsel_selection : can_base_type
  • memory_base_addr : dma_init_type
  • memory_data_width : dma_init_type
  • memory_inc_enable : dma_init_type
  • mic_adj_count : audio_codec_type
  • mic_adj_stage : audio_codec_type
  • mic_alt_setting : usb_audio_hid_type, usb_audio_type
  • mic_buffer : audio_codec_type
  • mic_calc : audio_codec_type
  • mic_delta : audio_codec_type
  • mic_enable : audio_codec_type
  • mic_freq : usb_audio_hid_type, usb_audio_type
  • mic_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_roff : audio_codec_type
  • mic_rtotal : audio_codec_type
  • mic_rx_size : audio_codec_type
  • mic_stage : audio_codec_type
  • mic_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_volume_limits : usb_audio_hid_type, usb_audio_type
  • mic_wend : audio_codec_type
  • mic_woff : audio_codec_type
  • mic_wtotal : audio_codec_type
  • min : calendar_type
  • mincm : dma_channel_type
  • misc1 : crm_type
  • misc1_bit : crm_type
  • misc2 : crm_type
  • misc2_bit : crm_type
  • misc3 : crm_type
  • misc3_bit : crm_type
  • mmerr : spi_type
  • mmssr : can_type
  • mmssr_selection : can_base_type
  • mode : i2c_handle_type
  • mode_selection : can_base_type
  • month : calendar_type
  • mouse_buffer : mouse_type
  • msc_state : cdc_msc_struct_type, msc_type
  • msc_up_status : flash_iap_type
  • mssel : adc_type
  • msten : spi_type
  • msts : can_type
  • msts_bit : can_type
  • mwidth : dma_channel_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • nerr : usart_type
  • nrstf : crm_type
  • nsac : sd_csd_struct_type
  • ntc : spi_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • oaddr1 : i2c_type
  • oaddr1_bit : i2c_type
  • oaddr2 : i2c_type
  • oaddr2_bit : i2c_type
  • obf : flash_type
  • oc_idle_state : tmr_output_config_type
  • oc_mode : tmr_output_config_type
  • oc_output_state : tmr_output_config_type
  • oc_polarity : tmr_output_config_type
  • occ_idle_state : tmr_output_config_type
  • occ_output_state : tmr_output_config_type
  • occ_polarity : tmr_output_config_type
  • occs : adc_type
  • ocdmaen : adc_type
  • oclen : adc_type
  • ocmen : tmr_type
  • ocpcnt : adc_type
  • ocpen : adc_type
  • ocswtrg : adc_type
  • octen : adc_type
  • octesel_h : adc_type
  • octesel_l : adc_type
  • ocvmen : adc_type
  • odf : flash_type
  • odfie : flash_type
  • odt : adc_type, gpio_type
  • odt0 : gpio_type
  • odt1 : gpio_type
  • odt10 : gpio_type
  • odt11 : gpio_type
  • odt12 : gpio_type
  • odt13 : gpio_type
  • odt14 : gpio_type
  • odt15 : gpio_type
  • odt2 : gpio_type
  • odt3 : gpio_type
  • odt4 : gpio_type
  • odt5 : gpio_type
  • odt6 : gpio_type
  • odt7 : gpio_type
  • odt8 : gpio_type
  • odt9 : gpio_type
  • odt_bit : adc_type, gpio_type
  • oem_app_id : sd_cid_struct_type
  • oen : tmr_type
  • old_conn_state : usbd_core_type
  • opcode : cbd_extended_type, cbd_typical_type
  • operation_mode : i2s_init_type
  • opersel : spi_type
  • oplk : flash_type
  • ora : spi_type
  • ordinary_channel_length : adc_base_config_type
  • osn1 : adc_type
  • osn10 : adc_type
  • osn11 : adc_type
  • osn12 : adc_type
  • osn13 : adc_type
  • osn14 : adc_type
  • osn15 : adc_type
  • osn16 : adc_type
  • osn2 : adc_type
  • osn3 : adc_type
  • osn4 : adc_type
  • osn5 : adc_type
  • osn6 : adc_type
  • osn7 : adc_type
  • osn8 : adc_type
  • osn9 : adc_type
  • osq1 : adc_type
  • osq1_bit : adc_type
  • osq2 : adc_type
  • osq2_bit : adc_type
  • osq3 : adc_type
  • osq3_bit : adc_type
  • ouf : i2c_type
  • out_handler : usbd_class_handler
  • outen : bpr_type
  • outm : bpr_type
  • outsel : bpr_type
  • ovfden : tmr_type
  • ovfen : tmr_type
  • ovff : rtc_type
  • ovfien : rtc_type, tmr_type
  • ovfif : tmr_type
  • ovfs : tmr_type
  • ovfswtr : tmr_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • paddr : dma_channel_type
  • paddr_bit : dma_channel_type
  • parity : linecoding_type
  • part_blk_read : sd_csd_struct_type
  • part_blk_write : sd_csd_struct_type
  • pbuff : i2c_handle_type
  • pcautoen : adc_type
  • pcce : adc_type
  • pcceien : adc_type
  • pccs : adc_type
  • pcdto1 : adc_type
  • pcdto1_bit : adc_type
  • pcdto2 : adc_type
  • pcdto2_bit : adc_type
  • pcdto3 : adc_type
  • pcdto3_bit : adc_type
  • pcdto4 : adc_type
  • pcdto4_bit : adc_type
  • pclen : adc_type
  • pcmfssel : spi_type
  • pcount : i2c_handle_type
  • pcpen : adc_type
  • pcswtrg : adc_type
  • pcten : adc_type
  • pctesel_h : adc_type
  • pctesel_l : adc_type
  • pcvmen : adc_type
  • pd01_gmux : iomux_type
  • pd01_mux : iomux_type
  • pdata : usbd_class_handler
  • pdt1 : adc_type
  • pdt1_bit : adc_type
  • pdt2 : adc_type
  • pdt2_bit : adc_type
  • pdt3 : adc_type
  • pdt3_bit : adc_type
  • pdt4 : adc_type
  • pdt4_bit : adc_type
  • pecen : i2c_type
  • pecerr : i2c_type
  • pecten : i2c_type
  • pecval : i2c_type
  • pen : usart_type
  • peripheral_base_addr : dma_init_type
  • peripheral_data_width : dma_init_type
  • peripheral_inc_enable : dma_init_type
  • permanent_write_protect : sd_csd_struct_type
  • permode : i2c_type
  • perr : usart_type
  • perrien : usart_type
  • pid : debug_type
  • pincm : dma_channel_type
  • pllen : crm_type
  • pllhextdiv : crm_type
  • pllmult_h : crm_type
  • pllmult_l : crm_type
  • pllrange : crm_type
  • pllrcs : crm_type
  • pllstbl : crm_type
  • pllstblf : crm_type
  • pllstblfc : crm_type
  • pllstblien : crm_type
  • pmen : tmr_type
  • pndwt : sdio_type
  • polcfg1 : exint_type
  • polcfg1_bit : exint_type
  • polcfg2 : exint_type
  • polcfg2_bit : exint_type
  • poly : crc_type
  • poly_bit : crc_type
  • poly_size : crc_type
  • porrstf : crm_type
  • pr : tmr_type
  • pr_bit : tmr_type
  • prben : tmr_type
  • prgmerr : flash_type
  • priority : dma_init_type
  • product_name1 : sd_cid_struct_type
  • product_name2 : sd_cid_struct_type
  • product_reversion : sd_cid_struct_type
  • product_sn : sd_cid_struct_type
  • prsf_enable : can_base_type
  • prsfen : can_type
  • ps : sdio_type
  • psel : usart_type
  • psn1 : adc_type
  • psn2 : adc_type
  • psn3 : adc_type
  • psn4 : adc_type
  • psq : adc_type
  • psq_bit : adc_type
  • psr : flash_type
  • psr_bit : flash_type
  • ptd : can_type
  • ptos : tmr_type
  • pvmen : pwc_type
  • pvmof : pwc_type
  • pvmsel : pwc_type
  • pwcen : crm_type
  • pwcrst : crm_type
  • pwidth : dma_channel_type
  • pwrctrl : sdio_type
  • pwrctrl_bit : sdio_type
  • pwrsven : sdio_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • qdzien : can_type
  • qdzif : can_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • rca : sd_card_info_struct_type
  • rcrc : spi_type
  • rcrc_bit : spi_type
  • rdbf : i2c_type, spi_type, usart_type
  • rdbfie : spi_type
  • rdbfien : usart_type
  • rdwtmode : sdio_type
  • rdwtstart : sdio_type
  • rdwtstop : sdio_type
  • read_blk_misalign : sd_csd_struct_type
  • read_crc : flash_iap_type
  • realrx : can_type
  • rec : can_type
  • rem0_len : usb_ept_info
  • remap : iomux_type
  • remap2 : iomux_type
  • remap2_bit : iomux_type
  • remap3 : iomux_type
  • remap3_bit : iomux_type
  • remap4 : iomux_type
  • remap4_bit : iomux_type
  • remap5 : iomux_type
  • remap5_bit : iomux_type
  • remap6 : iomux_type
  • remap6_bit : iomux_type
  • remap7 : iomux_type
  • remap7_bit : iomux_type
  • remap_bit : iomux_type
  • remote_wakup : usbd_core_type
  • ren : usart_type
  • repeat_mode : adc_base_config_type
  • request_no : usb_audio_hid_type, usb_audio_type
  • res : fat_dir_type
  • reserved : tmr_type, usd_type
  • reserved1 : acc_type, adc_type, bpr_type, can_fifo_mailbox_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, dma_channel_type, dma_type, exint_type, flash_type, gpio_type, i2c_type, iomux_type, pwc_type, rtc_type, sd_cid_struct_type, sd_csd_struct_type, sd_scr_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type, wdt_type, wwdt_type
  • reserved2 : acc_type, adc_type, bpr_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, pwc_type, sd_cid_struct_type, sd_csd_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type
  • reserved3 : acc_type, adc_type, bpr_type, can_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, sd_csd_struct_type, sense_type, usart_type
  • reserved4 : adc_type, can_type, crm_type, debug_type, flash_type, iomux_type, sd_csd_struct_type
  • reserved5 : can_type, crm_type, flash_type
  • reserved6 : can_type, crm_type, flash_type
  • reserverd2 : sd_scr_struct_type
  • reserverd3 : sd_scr_struct_type
  • reset : i2c_type
  • respond_flag : iap_info_type
  • revid : crc_type
  • revod : crc_type
  • rf0 : can_type
  • rf0_bit : can_type
  • rf0ff : can_type
  • rf0fien : can_type
  • rf0mien : can_type
  • rf0mn : can_type
  • rf0of : can_type
  • rf0oien : can_type
  • rf0r : can_type
  • rf1 : can_type
  • rf1_bit : can_type
  • rf1ff : can_type
  • rf1fien : can_type
  • rf1mien : can_type
  • rf1mn : can_type
  • rf1of : can_type
  • rf1oien : can_type
  • rf1r : can_type
  • rfc : can_fifo_mailbox_type
  • rfc_bit : can_fifo_mailbox_type
  • rfdt0 : can_fifo_mailbox_type
  • rfdt1 : can_fifo_mailbox_type
  • rfdt2 : can_fifo_mailbox_type
  • rfdt3 : can_fifo_mailbox_type
  • rfdt4 : can_fifo_mailbox_type
  • rfdt5 : can_fifo_mailbox_type
  • rfdt6 : can_fifo_mailbox_type
  • rfdt7 : can_fifo_mailbox_type
  • rfdth : can_fifo_mailbox_type
  • rfdth_bit : can_fifo_mailbox_type
  • rfdtl : can_fifo_mailbox_type
  • rfdtl_bit : can_fifo_mailbox_type
  • rfeid : can_fifo_mailbox_type
  • rffmn : can_fifo_mailbox_type
  • rffri : can_fifo_mailbox_type
  • rfi : can_fifo_mailbox_type
  • rfi_bit : can_fifo_mailbox_type
  • rfidi : can_fifo_mailbox_type
  • rfsid : can_fifo_mailbox_type
  • rfts : can_fifo_mailbox_type
  • risetime : i2c_type
  • rld : wdt_type
  • rld_bit : wdt_type
  • rldf : wdt_type, wwdt_type
  • rldien : wwdt_type
  • rm : usart_type
  • roerr : spi_type, usart_type
  • rpen : adc_type
  • rpr : tmr_type
  • rpr_bit : tmr_type
  • rpx : exint_type
  • rsaw : can_type
  • rsaw_size : can_baudrate_type
  • rslost : acc_type
  • rsp1 : sdio_type
  • rsp1_bit : sdio_type
  • rsp2 : sdio_type
  • rsp2_bit : sdio_type
  • rsp3 : sdio_type
  • rsp3_bit : sdio_type
  • rsp4 : sdio_type
  • rsp4_bit : sdio_type
  • rsp_type : sdio_command_struct_type
  • rspcmd : sdio_type
  • rspcmd_bit : sdio_type
  • rspwt : sdio_type
  • rst : crc_type, usbd_type
  • rstfc : crm_type
  • rstien : usbd_type
  • rtccal : bpr_type
  • rtccal_bit : bpr_type
  • rtcen : crm_type
  • rtcsel : crm_type
  • rtsen : usart_type
  • rx_addr : usb_ept_info
  • rxbuf : sdio_type
  • rxbufe : sdio_type
  • rxbufeien : sdio_type
  • rxbuff : sdio_type
  • rxbuffien : sdio_type
  • rxbufh : sdio_type
  • rxbufhien : sdio_type
  • rxbufien : sdio_type
  • rxdts : usbd_type
  • rxerro : sdio_type
  • rxerroien : sdio_type
  • rxsts : usbd_type
  • rxtc : usbd_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • sbf : usart_type
  • sbiterr : sdio_type
  • sbiterrien : sdio_type
  • scgt : usart_type
  • sclk_freq : crm_clocks_freq_type
  • sclksel : crm_type
  • sclksts : crm_type
  • scmen : usart_type
  • scnacken : usart_type
  • scr : gpio_type
  • scr_bit : gpio_type
  • scr_structure : sd_scr_struct_type
  • sd_bus_width : sd_scr_struct_type
  • sd_cid_reg : sd_card_info_struct_type
  • sd_csd_reg : sd_card_info_struct_type
  • sd_scr_reg : sd_card_info_struct_type
  • sd_security : sd_scr_struct_type
  • sd_spec : sd_scr_struct_type
  • sd_spec3 : sd_scr_struct_type
  • sdio1_gmux : iomux_type
  • sdio1en : crm_type
  • sec : calendar_type
  • secers : flash_type
  • sector_mask : flash_iap_type
  • sector_size : flash_iap_type, iap_info_type
  • sef : pwc_type
  • select : flash_type
  • select_bit : flash_type
  • selpin : iomux_type
  • selport : iomux_type
  • sense_key : sense_type
  • sequence_mode : adc_base_config_type
  • setup : usbd_core_type
  • setup_buffer : usbd_core_type
  • setup_handler : usbd_class_handler
  • setuptc : usbd_type
  • slben : spi_type, usart_type
  • slbtd : spi_type
  • sleep_debug : debug_type
  • slib_dat_ss : flash_type
  • slib_dss_set : flash_type
  • slib_enf : flash_type
  • slib_es : flash_type
  • slib_es_set : flash_type
  • slib_misc_sts : flash_type
  • slib_misc_sts_bit : flash_type
  • slib_pclr_val : flash_type
  • slib_pset_val : flash_type
  • slib_pwd_clr : flash_type
  • slib_pwd_clr_bit : flash_type
  • slib_pwd_err : flash_type
  • slib_pwd_ok : flash_type
  • slib_rcnt : flash_type
  • slib_set_pwd : flash_type
  • slib_set_pwd_bit : flash_type
  • slib_set_range : flash_type
  • slib_set_range_bit : flash_type
  • slib_ss : flash_type
  • slib_ss_set : flash_type
  • slib_sts0 : flash_type
  • slib_sts0_bit : flash_type
  • slib_sts1 : flash_type
  • slib_sts1_bit : flash_type
  • slib_ukval : flash_type
  • slib_ulkf : flash_type
  • slib_unlock : flash_type
  • slib_unlock_bit : flash_type
  • smbalert : i2c_type
  • smbmode : i2c_type
  • smsel : tmr_type
  • sof : usbd_type
  • sof_handler : usbd_class_handler
  • sofien : usbd_type
  • sofnum : usbd_type
  • sofouten : usbd_type
  • sofrnum : usbd_type
  • sofrnum_bit : usbd_type
  • sp : usbd_type
  • spec_version : sd_csd_struct_type
  • speed : i2c_type, usbd_core_type
  • speedmode : i2c_type
  • spi1_gmux : iomux_type
  • spi1_mux_h : iomux_type
  • spi1_mux_l : iomux_type
  • spi1en : crm_type
  • spi1rst : crm_type
  • spi2_gmux : iomux_type
  • spi2en : crm_type
  • spi2rst : crm_type
  • spien : spi_type, usbd_type
  • spk_alt_setting : usb_audio_hid_type, usb_audio_type
  • spk_buffer : audio_codec_type
  • spk_calc : audio_codec_type
  • spk_enable : audio_codec_type
  • spk_freq : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_rend : audio_codec_type
  • spk_roff : audio_codec_type
  • spk_rtotal : audio_codec_type
  • spk_stage : audio_codec_type
  • spk_threshold : audio_codec_type
  • spk_tx_size : audio_codec_type
  • spk_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_volume_limits : usb_audio_hid_type, usb_audio_type
  • spk_woff : audio_codec_type
  • spk_wtotal : audio_codec_type
  • sprst : can_type
  • spt1 : adc_type
  • spt1_bit : adc_type
  • spt2 : adc_type
  • spt2_bit : adc_type
  • sqen : adc_type
  • sramen : crm_type
  • src_sel0 : dma_type
  • src_sel0_bit : dma_type
  • src_sel1 : dma_type
  • src_sel1_bit : dma_type
  • ssb : usd_type
  • ssp : usbd_type
  • stall : usb_ept_info
  • standard_id : can_rx_message_type, can_tx_message_type
  • standby_debug : debug_type
  • startf : i2c_type
  • state : iap_info_type
  • status : i2c_handle_type, usb_ept_info
  • stctrl : tmr_type
  • stctrl_bit : tmr_type
  • stdby_rst : flash_type
  • stdsel : spi_type
  • step : acc_type
  • stis : tmr_type
  • stopbn : usart_type
  • stopf : i2c_type
  • stretch : i2c_type
  • sts : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, tmr_type, usart_type, wdt_type, wwdt_type
  • sts1 : i2c_type
  • sts1_bit : i2c_type
  • sts2 : i2c_type
  • sts2_bit : i2c_type
  • sts3 : flash_type
  • sts3_bit : flash_type
  • sts_bit : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, usart_type, wdt_type, wwdt_type
  • swcsen : spi_type
  • swcsil : spi_type
  • swef : pwc_type
  • swevt : tmr_type
  • swevt_bit : tmr_type
  • swjtag_conf : iomux_type
  • swjtag_gmux : iomux_type
  • swpen : pwc_type
  • swrstf : crm_type
  • swtrg : exint_type
  • swtrg_bit : exint_type
  • swtx : exint_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • t : sc_atr_type
  • t0 : sc_atr_type
  • ta : rtc_type
  • taac : sd_csd_struct_type
  • taf : rtc_type
  • tah : rtc_type
  • tah_bit : rtc_type
  • taien : rtc_type
  • tail : usart_group_type
  • tal : rtc_type
  • tal_bit : rtc_type
  • tc : usbd_type
  • tcien : can_type, usbd_type
  • tcrc : spi_type
  • tcrc_bit : spi_type
  • tdbe : i2c_type, spi_type, usart_type
  • tdbeie : spi_type
  • tdbeien : usart_type
  • tdc : i2c_type, usart_type
  • tdcien : usart_type
  • tden : tmr_type
  • tec : can_type
  • temp : keyboard_type
  • temp_write_protect : sd_csd_struct_type
  • ten : usart_type
  • tfrdir : sdio_type
  • tfren : sdio_type
  • tfrmode : sdio_type
  • tien : tmr_type
  • timeout : i2c_handle_type, sdio_data_struct_type, sdio_type
  • tlength : sc_atr_type
  • tm0alf : can_type
  • tm0ct : can_type
  • tm0ef : can_type
  • tm0lpf : can_type
  • tm0tcf : can_type
  • tm0tef : can_type
  • tm0tsf : can_type
  • tm1alf : can_type
  • tm1ct : can_type
  • tm1ef : can_type
  • tm1lpf : can_type
  • tm1tcf : can_type
  • tm1tef : can_type
  • tm1tsf : can_type
  • tm2alf : can_type
  • tm2ct : can_type
  • tm2ef : can_type
  • tm2lpf : can_type
  • tm2tcf : can_type
  • tm2tef : can_type
  • tm2tsf : can_type
  • tmc : can_tx_mailbox_type
  • tmc_bit : can_tx_mailbox_type
  • tmdt0 : can_tx_mailbox_type
  • tmdt1 : can_tx_mailbox_type
  • tmdt2 : can_tx_mailbox_type
  • tmdt3 : can_tx_mailbox_type
  • tmdt4 : can_tx_mailbox_type
  • tmdt5 : can_tx_mailbox_type
  • tmdt6 : can_tx_mailbox_type
  • tmdt7 : can_tx_mailbox_type
  • tmdtbl : can_tx_mailbox_type
  • tmdth : can_tx_mailbox_type
  • tmdth_bit : can_tx_mailbox_type
  • tmdtl : can_tx_mailbox_type
  • tmdtl_bit : can_tx_mailbox_type
  • tmeid : can_tx_mailbox_type
  • tmfrsel : can_tx_mailbox_type
  • tmi : can_tx_mailbox_type
  • tmi_bit : can_tx_mailbox_type
  • tmidsel : can_tx_mailbox_type
  • tmnr : can_type
  • tmout : i2c_type
  • tmr10_gmux : iomux_type
  • tmr10_pause : debug_type
  • tmr10en : crm_type
  • tmr10rst : crm_type
  • tmr11_gmux : iomux_type
  • tmr11_pause : debug_type
  • tmr11en : crm_type
  • tmr11rst : crm_type
  • tmr1_gmux : iomux_type
  • tmr1_mux : iomux_type
  • tmr1_pause : debug_type
  • tmr1en : crm_type
  • tmr1rst : crm_type
  • tmr2_gmux : iomux_type
  • tmr2_mux : iomux_type
  • tmr2_pause : debug_type
  • tmr2en : crm_type
  • tmr2itr1_gmux : iomux_type
  • tmr2rst : crm_type
  • tmr3_gmux : iomux_type
  • tmr3_mux : iomux_type
  • tmr3_pause : debug_type
  • tmr3en : crm_type
  • tmr3rst : crm_type
  • tmr4_pause : debug_type
  • tmr4en : crm_type
  • tmr4rst : crm_type
  • tmr5_gmux : iomux_type
  • tmr5_pause : debug_type
  • tmr5ch4_gmux : iomux_type
  • tmr5ch4_mux : iomux_type
  • tmr5en : crm_type
  • tmr5rst : crm_type
  • tmr8_pause : debug_type
  • tmr8en : crm_type
  • tmr8rst : crm_type
  • tmr9_gmux : iomux_type
  • tmr9_pause : debug_type
  • tmr9en : crm_type
  • tmr9rst : crm_type
  • tmren : tmr_type
  • tmrise : i2c_type
  • tmrise_bit : i2c_type
  • tmsid : can_tx_mailbox_type
  • tmsr : can_tx_mailbox_type
  • tmts : can_tx_mailbox_type
  • tmtsten : can_tx_mailbox_type
  • total_len : usb_ept_info
  • tpef : bpr_type
  • tpefclr : bpr_type
  • tpen : bpr_type
  • tpien : bpr_type
  • tpif : bpr_type
  • tpifclr : bpr_type
  • tpp : bpr_type
  • trace_ioen : debug_type
  • trace_mode : debug_type
  • trans_buf : usb_ept_info
  • trans_len : usb_ept_info
  • trans_type : usb_ept_info, usbd_type
  • transfer_direction : sdio_data_struct_type
  • transfer_mode : sdio_data_struct_type
  • transmission_mode : spi_init_type
  • trgif : tmr_type
  • trgswtr : tmr_type
  • trmode : i2c_type
  • ts : sc_atr_type
  • tsf : rtc_type
  • tsien : rtc_type
  • tsts : can_type
  • tsts_bit : can_type
  • ttc_enable : can_base_type
  • ttcen : can_type
  • tuerr : spi_type
  • tx_addr : usb_ept_info
  • tx_length : iap_info_type
  • tx_mailbox : can_type
  • txbuf : sdio_type
  • txbufe : sdio_type
  • txbufeien : sdio_type
  • txbuff : sdio_type
  • txbuffien : sdio_type
  • txbufh : sdio_type
  • txbufhien : sdio_type
  • txbufien : sdio_type
  • txdts : usbd_type
  • txerru : sdio_type
  • txerruien : sdio_type
  • txsts : usbd_type
  • txtc : usbd_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • uart4_gmux : iomux_type
  • uart4en : crm_type
  • uart4rst : crm_type
  • uart5en : crm_type
  • uart5rst : crm_type
  • ucfor : usbd_type
  • ucforien : usbd_type
  • uen : usart_type
  • ukval : flash_type
  • unlock : flash_type
  • unlock3 : flash_type
  • unlock3_bit : flash_type
  • unlock_bit : flash_type
  • updf : rtc_type
  • usart1_gmux : iomux_type
  • usart1_mux : iomux_type
  • usart1en : crm_type
  • usart1rst : crm_type
  • usart2en : crm_type
  • usart2rst : crm_type
  • usart3_gmux : iomux_type
  • usart3_mux : iomux_type
  • usart3en : crm_type
  • usart3rst : crm_type
  • usb_reg : usbd_core_type
  • usbbufs : crm_type
  • usbdiv_h : crm_type
  • usbdiv_l : crm_type
  • usben : crm_type
  • usbintmap : crm_type
  • usbrst : crm_type
  • usd : flash_type
  • usd_bit : flash_type
  • usd_ukval : flash_type
  • usd_unlock : flash_type
  • usd_unlock_bit : flash_type
  • usderr : flash_type
  • usders : flash_type
  • usdprgm : flash_type
  • usdulks : flash_type
  • user_d0 : flash_type
  • user_d1 : flash_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • vmcsel : adc_type
  • vmhb : adc_type
  • vmhb_bit : adc_type
  • vmlb : adc_type
  • vmlb_bit : adc_type
  • vmor : adc_type
  • vmorien : adc_type
  • vmsgen : adc_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • wait_type : sdio_command_struct_type
  • wdt_ato_en : flash_type
  • wdt_pause : debug_type
  • wdtrstf : crm_type
  • week : calendar_type
  • win : wwdt_type
  • wIndex : usb_setup_type
  • wk : usbd_type
  • wkien : usbd_type
  • wLength : usb_setup_type
  • wMaxPacketSize : usb_endpoint_desc_type
  • wp_level : tmr_brkdt_config_type
  • wpc : tmr_type
  • wpen0 : gpio_type
  • wpen1 : gpio_type
  • wpen10 : gpio_type
  • wpen11 : gpio_type
  • wpen12 : gpio_type
  • wpen13 : gpio_type
  • wpen14 : gpio_type
  • wpen15 : gpio_type
  • wpen2 : gpio_type
  • wpen3 : gpio_type
  • wpen4 : gpio_type
  • wpen5 : gpio_type
  • wpen6 : gpio_type
  • wpen7 : gpio_type
  • wpen8 : gpio_type
  • wpen9 : gpio_type
  • wpr : gpio_type
  • wpr_bit : gpio_type
  • wpseq : gpio_type
  • write_addr : flash_iap_type
  • write_blk_misalign : sd_csd_struct_type
  • write_crc : flash_iap_type
  • write_data : fat_dir_type
  • write_protect_group_enable : sd_csd_struct_type
  • write_protect_group_size : sd_csd_struct_type
  • write_speed_factor : sd_csd_struct_type
  • write_time : fat_dir_type
  • wTotalLength : usb_configuration_desc_type
  • wum : usart_type
  • wValue : usb_setup_type
  • wwdt_pause : debug_type
  • wwdten : crm_type, wwdt_type
  • wwdtrst : crm_type
  • wwdtrstf : crm_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • year : calendar_type


AT32F413 Firmwary Library: Data Fields - Variables

- a -

  • accen : crm_type
  • accrst : crm_type
  • acken : i2c_type
  • ackfail : i2c_type
  • acs : spi_type
  • adc1_eto_gmux : iomux_type
  • adc1_etp_gmux : iomux_type
  • adc1_extrgord_mux : iomux_type
  • adc1_extrgpre_mux : iomux_type
  • adc1en : crm_type
  • adc1rst : crm_type
  • adc2_eto_gmux : iomux_type
  • adc2_etp_gmux : iomux_type
  • adc2_extrgord_mux : iomux_type
  • adc2_extrgpre_mux : iomux_type
  • adc2en : crm_type
  • adc2odt : adc_type
  • adc2rst : crm_type
  • adc_freq : crm_clocks_freq_type
  • adcal : adc_type
  • adcalinit : adc_type
  • adcdiv_h : crm_type
  • adcdiv_l : crm_type
  • adcen : adc_type
  • addr : flash_type, tmr_type, usbd_type
  • addr1 : i2c_type
  • addr1mode : i2c_type
  • addr2 : i2c_type
  • addr2en : i2c_type
  • addr3 : flash_type
  • addr3_bit : flash_type
  • addr7f : i2c_type
  • addr_bit : flash_type
  • address : cbd_extended_type, cbd_typical_type
  • addrhf : i2c_type
  • aebo_enable : can_base_type
  • aeboen : can_type
  • aed_enable : can_base_type
  • aeden : can_type
  • ahb_freq : crm_clocks_freq_type
  • ahbdiv : crm_type
  • ahben : crm_type
  • ahben_bit : crm_type
  • alertf : i2c_type
  • alloc_length : cbd_extended_type, cbd_typical_type
  • alt_setting : cdc_msc_struct_type, cdc_struct_type, custom_hid_type, iap_info_type, keyboard_type, mouse_type, msc_type, printer_type, usb_audio_hid_type, vcp_keyboard_type
  • aoen : tmr_type
  • apb1_freq : crm_clocks_freq_type
  • apb1div : crm_type
  • apb1en : crm_type
  • apb1en_bit : crm_type
  • apb1rst : crm_type
  • apb1rst_bit : crm_type
  • apb2_freq : crm_clocks_freq_type
  • apb2div : crm_type
  • apb2en : crm_type
  • apb2en_bit : crm_type
  • apb2rst : crm_type
  • apb2rst_bit : crm_type
  • app_address : iap_info_type
  • argu : sdio_type
  • argu_bit : sdio_type
  • argument : sdio_command_struct_type
  • arlost : i2c_type
  • arpen : i2c_type
  • as_length : sense_type
  • asc : sense_type
  • ascq : sense_type
  • attr : fat_dir_type
  • audio_bitw : audio_codec_type
  • audio_cmd : usb_audio_hid_type, usb_audio_type
  • audio_cmd_len : usb_audio_hid_type, usb_audio_type
  • audio_feed_back : usb_audio_hid_type, usb_audio_type
  • audio_freq : audio_codec_type
  • audio_mic_data : usb_audio_hid_type, usb_audio_type
  • audio_protocol : i2s_init_type
  • audio_sampling_freq : i2s_init_type
  • audio_spk_data : usb_audio_hid_type, usb_audio_type
  • auto_output_enable : tmr_brkdt_config_type
  • auto_step_en : crm_type


AT32F413 Firmwary Library: Data Fields - Variables

- b -

  • bAlternateSetting : usb_interface_desc_type
  • bankers : flash_type
  • baudr : usart_type
  • baudr_bit : usart_type
  • baudrate_div : can_baudrate_type
  • bCBWCBLength : cbw_type
  • bCBWLUN : cbw_type
  • bcdDevice : usb_device_desc_type
  • bcdUSB : usb_device_desc_type
  • bConfigurationValue : usb_configuration_desc_type
  • bCSWStatus : csw_type
  • bDescriptorType : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • bDeviceClass : usb_device_desc_type
  • bDeviceProtocol : usb_device_desc_type
  • bDeviceSubClass : usb_device_desc_type
  • be : usbd_type
  • beien : usbd_type
  • bEndpointAddress : usb_endpoint_desc_type
  • bf : spi_type
  • bfbn : usart_type
  • bff : usart_type
  • bfien : usart_type
  • bInterfaceClass : usb_interface_desc_type
  • bInterfaceNumber : usb_interface_desc_type
  • bInterfaceProtocol : usb_interface_desc_type
  • bInterfaceSubClass : usb_interface_desc_type
  • bInterval : usb_endpoint_desc_type
  • bitrate : linecoding_type
  • bLength : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • blk_addr : cdc_msc_struct_type, msc_type
  • blk_len : cdc_msc_struct_type, msc_type
  • blk_nbr : cdc_msc_struct_type, msc_type
  • blk_size : cdc_msc_struct_type, msc_type
  • blksize : sdio_type
  • block_size : sdio_data_struct_type
  • bmAttributes : usb_configuration_desc_type, usb_endpoint_desc_type
  • bMaxPacketSize0 : usb_device_desc_type
  • bMaxPower : usb_configuration_desc_type
  • bmCBWFlags : cbw_type
  • bmRequestType : usb_setup_type
  • bNumConfigurations : usb_device_desc_type
  • bNumEndpoints : usb_interface_desc_type
  • bNumInterfaces : usb_configuration_desc_type
  • bof : can_type
  • boien : can_type
  • bot_status : cdc_msc_struct_type, msc_type
  • bpdc : crm_type
  • bpdc_bit : crm_type
  • bpdrst : crm_type
  • bpren : crm_type
  • bprrst : crm_type
  • bpwen : pwc_type
  • brdiv : can_type
  • bRequest : usb_setup_type
  • brk : tmr_type
  • brk_bit : tmr_type
  • brk_enable : tmr_brkdt_config_type
  • brk_polarity : tmr_brkdt_config_type
  • brken : tmr_type
  • brkie : tmr_type
  • brkif : tmr_type
  • brkswtr : tmr_type
  • brkv : tmr_type
  • btaddr : usbd_type
  • btmg : can_type
  • btmg_bit : can_type
  • bts1 : can_type
  • bts1_size : can_baudrate_type
  • bts2 : can_type
  • bts2_size : can_baudrate_type
  • buf : sdio_type, usart_group_type
  • buf_bit : sdio_type
  • bufcnt : sdio_type
  • bufcnt_bit : sdio_type
  • buffer_size : dma_init_type
  • buftbl : usbd_type
  • buftbl_bit : usbd_type
  • buserr : i2c_type
  • busws : sdio_type
  • busyf : i2c_type
  • bypsen : sdio_type


AT32F413 Firmwary Library: Data Fields - Variables

- c -

  • c1 : acc_type
  • c1_bit : acc_type
  • c1c : tmr_type
  • c1cen : tmr_type
  • c1cios : tmr_type
  • c1cp : tmr_type
  • c1den : tmr_type
  • c1df : tmr_type
  • c1dt : tmr_type
  • c1dt_bit : tmr_type
  • c1en : tmr_type
  • c1idiv : tmr_type
  • c1ien : tmr_type
  • c1if : tmr_type
  • c1insel : tmr_type
  • c1ios : tmr_type
  • c1oben : tmr_type
  • c1octrl : tmr_type
  • c1oien : tmr_type
  • c1osen : tmr_type
  • c1p : tmr_type
  • c1rf : tmr_type
  • c1swtr : tmr_type
  • c2 : acc_type
  • c2_bit : acc_type
  • c2c : tmr_type
  • c2cen : tmr_type
  • c2cios : tmr_type
  • c2cp : tmr_type
  • c2den : tmr_type
  • c2df : tmr_type
  • c2dt : tmr_type
  • c2dt_bit : tmr_type
  • c2en : tmr_type
  • c2idiv : tmr_type
  • c2ien : tmr_type
  • c2if : tmr_type
  • c2ios : tmr_type
  • c2oben : tmr_type
  • c2octrl : tmr_type
  • c2oien : tmr_type
  • c2osen : tmr_type
  • c2p : tmr_type
  • c2rf : tmr_type
  • c2swtr : tmr_type
  • c3 : acc_type
  • c3_bit : acc_type
  • c3c : tmr_type
  • c3cen : tmr_type
  • c3cios : tmr_type
  • c3cp : tmr_type
  • c3den : tmr_type
  • c3df : tmr_type
  • c3dt : tmr_type
  • c3dt_bit : tmr_type
  • c3en : tmr_type
  • c3idiv : tmr_type
  • c3ien : tmr_type
  • c3if : tmr_type
  • c3ios : tmr_type
  • c3oben : tmr_type
  • c3octrl : tmr_type
  • c3oien : tmr_type
  • c3osen : tmr_type
  • c3p : tmr_type
  • c3rf : tmr_type
  • c3swtr : tmr_type
  • c4c : tmr_type
  • c4den : tmr_type
  • c4df : tmr_type
  • c4dt : tmr_type
  • c4dt_bit : tmr_type
  • c4en : tmr_type
  • c4idiv : tmr_type
  • c4ien : tmr_type
  • c4if : tmr_type
  • c4ios : tmr_type
  • c4oben : tmr_type
  • c4octrl : tmr_type
  • c4oien : tmr_type
  • c4osen : tmr_type
  • c4p : tmr_type
  • c4rf : tmr_type
  • c4swtr : tmr_type
  • calon : acc_type
  • calout : bpr_type
  • calrdy : acc_type
  • calrdyien : acc_type
  • calval : bpr_type
  • can1_gmux : iomux_type
  • can1_pause : debug_type
  • can1en : crm_type
  • can1rst : crm_type
  • can2_gmux : iomux_type
  • can2_pause : debug_type
  • can2en : crm_type
  • can2rst : crm_type
  • can_mux : iomux_type
  • card_blk_size : sd_card_info_struct_type
  • card_capacity : sd_card_info_struct_type
  • card_cmd_classes : sd_csd_struct_type
  • card_type : sd_card_info_struct_type
  • cardsts1 : sdio_type
  • cardsts2 : sdio_type
  • cardsts3 : sdio_type
  • cardsts4 : sdio_type
  • cbctrl : tmr_type
  • cbw_struct : cdc_msc_struct_type, msc_type
  • CBWCB : cbw_type
  • cce : adc_type
  • cceien : adc_type
  • ccen : spi_type
  • ccerr : spi_type
  • ccfs : tmr_type
  • ccos : bpr_type
  • ccsmen : sdio_type
  • cctrl : tmr_type
  • cctrl_bit : tmr_type
  • cdt : crc_type
  • cdt_bit : crc_type
  • cen : usbd_type
  • cfden : crm_type
  • cfdf : crm_type
  • cfdfc : crm_type
  • cfg : crm_type, usbd_type, wwdt_type
  • cfg_bit : crm_type, usbd_type, wwdt_type
  • cfgen : rtc_type
  • cfgf : rtc_type
  • cfghr : gpio_type
  • cfghr_bit : gpio_type
  • cfglr : gpio_type
  • cfglr_bit : gpio_type
  • ch1_src : dma_type
  • ch2_src : dma_type
  • ch3_src : dma_type
  • ch4_src : dma_type
  • ch5_src : dma_type
  • ch6_src : dma_type
  • ch7_src : dma_type
  • chen : dma_channel_type
  • chpers : flash_type
  • chpl : dma_channel_type
  • cid_crc : sd_cid_struct_type
  • class_handler : usbd_core_type
  • clck : usbd_type
  • clear_handler : usbd_class_handler
  • clk_to_tmr : crm_type
  • clkctrl : i2c_type, sdio_type
  • clkctrl_bit : i2c_type, sdio_type
  • clkdiv : tmr_type
  • clkdiv_h : sdio_type
  • clkdiv_l : sdio_type
  • clkegs : sdio_type
  • clken : usart_type
  • clkfreq : i2c_type
  • clkint : crm_type
  • clkint_bit : crm_type
  • clkoen : sdio_type
  • clkout_sel : crm_type
  • clkoutdiv : crm_type
  • clkpha : spi_type, usart_type
  • clkpol : spi_type, usart_type
  • clock_phase : spi_init_type
  • clock_polarity : i2s_init_type, spi_init_type
  • clr : dma_type, gpio_type
  • clr_bit : dma_type, gpio_type
  • clsef : pwc_type
  • clswef : pwc_type
  • clus_high : fat_dir_type
  • clus_low : fat_dir_type
  • cm1 : tmr_type
  • cm1_input_bit : tmr_type
  • cm1_output_bit : tmr_type
  • cm2 : tmr_type
  • cm2_input_bit : tmr_type
  • cm2_output_bit : tmr_type
  • cmd : wdt_type
  • cmd20_support : sd_scr_struct_type
  • cmd23_support : sd_scr_struct_type
  • cmd_addr : cmd_data_group_type
  • cmd_bit : wdt_type
  • cmd_buf : cmd_data_group_type
  • cmd_check : cmd_data_group_type
  • cmd_head : cmd_data_group_type
  • cmd_index : sdio_command_struct_type
  • cmdcmpl : sdio_type
  • cmdcmplien : sdio_type
  • cmdctrl : sdio_type
  • cmdctrl_bit : sdio_type
  • cmdfail : sdio_type
  • cmdfailien : sdio_type
  • cmdidx : sdio_type
  • cmdrspcmpl : sdio_type
  • cmdrspcmplien : sdio_type
  • cmdtimeout : sdio_type
  • cmdtimeoutien : sdio_type
  • cnt : dma_channel_type, rtc_type, sdio_type, wwdt_type
  • cnt_dir : tmr_type
  • cnth : rtc_type
  • cnth_bit : rtc_type
  • cntl : rtc_type
  • cntl_bit : rtc_type
  • config_status : usbd_core_type
  • conn_state : usbd_core_type
  • content_protect_app : sd_csd_struct_type
  • copy_flag : sd_csd_struct_type
  • count : usart_group_type
  • cpoly : spi_type
  • cpoly_bit : spi_type
  • crc_chkr : flash_type
  • crc_chkr_bit : flash_type
  • crc_ctrl : flash_type
  • crc_ctrl_bit : flash_type
  • crc_sn : flash_type
  • crc_ss : flash_type
  • crc_strt : flash_type
  • crcen : crm_type
  • create_data : fat_dir_type
  • create_time : fat_dir_type
  • create_time_tenth : fat_dir_type
  • cs_mode_selection : spi_init_type
  • csd_crc : sd_csd_struct_type
  • csd_struct : sd_csd_struct_type
  • cspt0 : adc_type
  • cspt1 : adc_type
  • cspt10 : adc_type
  • cspt11 : adc_type
  • cspt12 : adc_type
  • cspt13 : adc_type
  • cspt14 : adc_type
  • cspt15 : adc_type
  • cspt16 : adc_type
  • cspt17 : adc_type
  • cspt2 : adc_type
  • cspt3 : adc_type
  • cspt4 : adc_type
  • cspt5 : adc_type
  • cspt6 : adc_type
  • cspt7 : adc_type
  • cspt8 : adc_type
  • cspt9 : adc_type
  • csrst : usbd_type
  • csw_struct : cdc_msc_struct_type, msc_type
  • ctrl : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrl1 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl1_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl3 : flash_type, usart_type
  • ctrl3_bit : flash_type, usart_type
  • ctrl_bit : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrlh : rtc_type
  • ctrlh_bit : rtc_type
  • ctrll : rtc_type
  • ctrll_bit : rtc_type
  • ctrlsts : bpr_type, crm_type, pwc_type
  • ctrlsts_bit : bpr_type, crm_type, pwc_type
  • ctscf : usart_type
  • ctscfien : usart_type
  • ctsen : usart_type
  • curs : can_type
  • cuss : can_type
  • cval : tmr_type
  • cval_bit : tmr_type


AT32F413 Firmwary Library: Data Fields - Variables

- d -

  • da : flash_type
  • da_bit : flash_type
  • data : can_rx_message_type, can_tx_message_type, cdc_msc_struct_type, linecoding_type, msc_type
  • data0 : usd_type
  • data1 : usd_type
  • data2 : usd_type
  • data3 : usd_type
  • data4 : usd_type
  • data5 : usd_type
  • data6 : usd_type
  • data7 : usd_type
  • data_align : adc_base_config_type
  • data_channel_format : i2s_init_type
  • data_len : cdc_msc_struct_type, msc_type
  • data_length : sdio_data_struct_type
  • data_stat_after_erase : sd_scr_struct_type
  • dataien : i2c_type
  • date : calendar_type
  • dbn : usart_type
  • dCBWDataTransferLength : cbw_type
  • dCBWSignature : cbw_type
  • dCBWTage : cbw_type
  • dCSWDataResidue : csw_type
  • dCSWSignature : csw_type
  • dCSWTag : csw_type
  • deadtime : tmr_brkdt_config_type
  • deepsleep_debug : debug_type
  • default_config : usbd_core_type
  • depslp_rst : flash_type
  • desc_handler : usbd_core_type
  • descriptor : usbd_desc_t
  • dev_config : usbd_core_type
  • devaddr : usbd_type
  • devaddr_bit : usbd_type
  • devaddrf : i2c_type
  • device_addr : usbd_core_type
  • device_size : sd_csd_struct_type
  • device_size_mult : sd_csd_struct_type
  • direction : dma_init_type
  • dirf : i2c_type
  • disusb : usbd_type
  • div : rtc_type, tmr_type, usart_type, wdt_type, wwdt_type
  • div_bit : tmr_type, wdt_type
  • divcnt : rtc_type
  • divcnth : rtc_type
  • divcnth_bit : rtc_type
  • divcntl : rtc_type
  • divcntl_bit : rtc_type
  • divf : wdt_type
  • divh : rtc_type
  • divh_bit : rtc_type
  • divl : rtc_type
  • divl_bit : rtc_type
  • dlc : can_rx_message_type, can_tx_message_type
  • dma1en : crm_type
  • dma2en : crm_type
  • dma_flex_en : dma_type
  • dma_init_struct : i2c_handle_type
  • dma_rx_channel : i2c_handle_type
  • dma_tx_channel : i2c_handle_type
  • dmactrl : tmr_type
  • dmactrl_bit : tmr_type
  • dmadt : tmr_type
  • dmadt_bit : tmr_type
  • dmaen : i2c_type, sdio_type
  • dmaend : i2c_type
  • dmaren : spi_type, usart_type
  • dmaten : spi_type, usart_type
  • dmsts : usbd_type
  • docmd : sdio_type
  • docmdien : sdio_type
  • dorx : sdio_type
  • dorxien : sdio_type
  • dotx : sdio_type
  • dotxien : sdio_type
  • dpsts : usbd_type
  • drs : tmr_type
  • dsr_implemented : sd_csd_struct_type
  • dt : bpr_type, crc_type, i2c_type, sdio_type, spi_type, usart_type
  • dt1 : bpr_type
  • dt10 : bpr_type
  • dt10_bit : bpr_type
  • dt11 : bpr_type
  • dt11_bit : bpr_type
  • dt12 : bpr_type
  • dt12_bit : bpr_type
  • dt13 : bpr_type
  • dt13_bit : bpr_type
  • dt14 : bpr_type
  • dt14_bit : bpr_type
  • dt15 : bpr_type
  • dt15_bit : bpr_type
  • dt16 : bpr_type
  • dt16_bit : bpr_type
  • dt17 : bpr_type
  • dt17_bit : bpr_type
  • dt18 : bpr_type
  • dt18_bit : bpr_type
  • dt19 : bpr_type
  • dt19_bit : bpr_type
  • dt1_bit : bpr_type
  • dt2 : bpr_type
  • dt20 : bpr_type
  • dt20_bit : bpr_type
  • dt21 : bpr_type
  • dt21_bit : bpr_type
  • dt22 : bpr_type
  • dt22_bit : bpr_type
  • dt23 : bpr_type
  • dt23_bit : bpr_type
  • dt24 : bpr_type
  • dt24_bit : bpr_type
  • dt25 : bpr_type
  • dt25_bit : bpr_type
  • dt26 : bpr_type
  • dt26_bit : bpr_type
  • dt27 : bpr_type
  • dt27_bit : bpr_type
  • dt28 : bpr_type
  • dt28_bit : bpr_type
  • dt29 : bpr_type
  • dt29_bit : bpr_type
  • dt2_bit : bpr_type
  • dt3 : bpr_type
  • dt30 : bpr_type
  • dt30_bit : bpr_type
  • dt31 : bpr_type
  • dt31_bit : bpr_type
  • dt32 : bpr_type
  • dt32_bit : bpr_type
  • dt33 : bpr_type
  • dt33_bit : bpr_type
  • dt34 : bpr_type
  • dt34_bit : bpr_type
  • dt35 : bpr_type
  • dt35_bit : bpr_type
  • dt36 : bpr_type
  • dt36_bit : bpr_type
  • dt37 : bpr_type
  • dt37_bit : bpr_type
  • dt38 : bpr_type
  • dt38_bit : bpr_type
  • dt39 : bpr_type
  • dt39_bit : bpr_type
  • dt3_bit : bpr_type
  • dt4 : bpr_type
  • dt40 : bpr_type
  • dt40_bit : bpr_type
  • dt41 : bpr_type
  • dt41_bit : bpr_type
  • dt42 : bpr_type
  • dt42_bit : bpr_type
  • dt4_bit : bpr_type
  • dt5 : bpr_type
  • dt5_bit : bpr_type
  • dt6 : bpr_type
  • dt6_bit : bpr_type
  • dt7 : bpr_type
  • dt7_bit : bpr_type
  • dt8 : bpr_type
  • dt8_bit : bpr_type
  • dt9 : bpr_type
  • dt9_bit : bpr_type
  • dt_bit : crc_type, i2c_type, spi_type, usart_type
  • dtalign : adc_type
  • dtb : tmr_type
  • dtblkcmpl : sdio_type
  • dtblkcmplien : sdio_type
  • dtc : tmr_type
  • dtcmpl : sdio_type
  • dtcmplien : sdio_type
  • dtcnt : dma_channel_type, sdio_type
  • dtcnt_bit : dma_channel_type, sdio_type
  • dtctrl : sdio_type
  • dtctrl_bit : sdio_type
  • dtd : dma_channel_type
  • dterrf1 : dma_type
  • dterrf2 : dma_type
  • dterrf3 : dma_type
  • dterrf4 : dma_type
  • dterrf5 : dma_type
  • dterrf6 : dma_type
  • dterrf7 : dma_type
  • dterrfc1 : dma_type
  • dterrfc2 : dma_type
  • dterrfc3 : dma_type
  • dterrfc4 : dma_type
  • dterrfc5 : dma_type
  • dterrfc6 : dma_type
  • dterrfc7 : dma_type
  • dterrien : dma_channel_type
  • dtfail : sdio_type
  • dtfailien : sdio_type
  • dtlen : sdio_type
  • dtlen_bit : sdio_type
  • dttimeout : sdio_type
  • dttimeoutien : sdio_type
  • dttmr : sdio_type
  • dttmr_bit : sdio_type
  • dutymode : i2c_type
  • dzc : can_type
  • dzen : can_type


AT32F413 Firmwary Library: Data Fields - Variables

- e -

  • eaf : can_type
  • eaien : can_type
  • ecc_code : sd_csd_struct_type
  • ecmben : tmr_type
  • edzien : can_type
  • edzif : can_type
  • eien : acc_type
  • enpd : usb_audio_hid_type, usb_audio_type
  • entrim : acc_type
  • eoien : can_type
  • eoif : can_type
  • eopb0 : usd_type
  • epf : can_type
  • epien : can_type
  • epp0 : usd_type
  • epp1 : usd_type
  • epp2 : usd_type
  • epp3 : usd_type
  • epperr : flash_type
  • epps : flash_type
  • epps_bit : flash_type
  • ept : usbd_type
  • ept0_rx_handler : usbd_class_handler
  • ept0_slen : usb_ept_info
  • ept0_sts : usbd_core_type
  • ept0_tx_handler : usbd_class_handler
  • ept0_wlength : usbd_core_type
  • ept_address : usb_ept_info
  • ept_bit : usbd_type
  • ept_in : usbd_core_type
  • ept_num : usbd_type
  • ept_out : usbd_core_type
  • eptaddr : usbd_type
  • eptn : usb_ept_info
  • erase_group_size : sd_csd_struct_type
  • erase_group_size_mult : sd_csd_struct_type
  • err_code : sense_type
  • errie : flash_type, spi_type
  • errien : i2c_type, usart_type
  • error_code : i2c_handle_type
  • erstr : flash_type
  • esdiv : tmr_type
  • esf : tmr_type
  • esp : tmr_type
  • ests : can_type
  • ests_bit : can_type
  • etr : can_type
  • etrien : can_type
  • event_handler : usbd_class_handler
  • evoen : iomux_type
  • evten : exint_type
  • evten_bit : exint_type
  • evtenx : exint_type
  • evtien : i2c_type
  • evtout : iomux_type
  • evtout_bit : iomux_type
  • exf : usbd_type
  • exint0 : iomux_type
  • exint1 : iomux_type
  • exint10 : iomux_type
  • exint11 : iomux_type
  • exint12 : iomux_type
  • exint13 : iomux_type
  • exint14 : iomux_type
  • exint15 : iomux_type
  • exint2 : iomux_type
  • exint3 : iomux_type
  • exint4 : iomux_type
  • exint5 : iomux_type
  • exint6 : iomux_type
  • exint7 : iomux_type
  • exint8 : iomux_type
  • exint9 : iomux_type
  • exintc1 : iomux_type
  • exintc1_bit : iomux_type
  • exintc2 : iomux_type
  • exintc2_bit : iomux_type
  • exintc3 : iomux_type
  • exintc3_bit : iomux_type
  • exintc4 : iomux_type
  • exintc4_bit : iomux_type
  • exintrst : crm_type
  • ext_flash_key : usd_type
  • ext_spim_en_mux : iomux_type
  • ext_spim_gen : iomux_type
  • ext_spim_gmux : iomux_type
  • extended_id : can_rx_message_type, can_tx_message_type


AT32F413 Firmwary Library: Data Fields - Variables

- f -

  • fa : flash_type
  • facfg : can_type
  • facfg_bit : can_type
  • faen0 : can_type
  • faen1 : can_type
  • faen10 : can_type
  • faen11 : can_type
  • faen12 : can_type
  • faen13 : can_type
  • faen2 : can_type
  • faen3 : can_type
  • faen4 : can_type
  • faen5 : can_type
  • faen6 : can_type
  • faen7 : can_type
  • faen8 : can_type
  • faen9 : can_type
  • fap : flash_type, usd_type
  • fbn : spi_type
  • fbwcfg : can_type
  • fbwcfg_bit : can_type
  • fbwsel0 : can_type
  • fbwsel1 : can_type
  • fbwsel10 : can_type
  • fbwsel11 : can_type
  • fbwsel12 : can_type
  • fbwsel13 : can_type
  • fbwsel2 : can_type
  • fbwsel3 : can_type
  • fbwsel4 : can_type
  • fbwsel5 : can_type
  • fbwsel6 : can_type
  • fbwsel7 : can_type
  • fbwsel8 : can_type
  • fbwsel9 : can_type
  • fcs : can_type
  • fcsodis : tmr_type
  • fcsodis_state : tmr_brkdt_config_type
  • fcsoen : tmr_type
  • fcsoen_state : tmr_brkdt_config_type
  • fctrl : can_type
  • fctrl_bit : can_type
  • fda : flash_type
  • fdtf1 : dma_type
  • fdtf2 : dma_type
  • fdtf3 : dma_type
  • fdtf4 : dma_type
  • fdtf5 : dma_type
  • fdtf6 : dma_type
  • fdtf7 : dma_type
  • fdtfc1 : dma_type
  • fdtfc2 : dma_type
  • fdtfc3 : dma_type
  • fdtfc4 : dma_type
  • fdtfc5 : dma_type
  • fdtfc6 : dma_type
  • fdtfc7 : dma_type
  • fdtien : dma_channel_type
  • ferr : usart_type
  • ffb : can_type
  • ffdb1 : can_filter_register_type
  • ffdb2 : can_filter_register_type
  • fifo_length : iap_info_type
  • fifo_mailbox : can_type
  • file_formart : sd_csd_struct_type
  • file_format_group : sd_csd_struct_type
  • file_name : fat_dir_type
  • file_size : fat_dir_type
  • file_write_nr : flash_iap_type
  • filter_activate_enable : can_filter_init_type
  • filter_bit : can_filter_init_type
  • filter_fifo : can_filter_init_type
  • filter_id_high : can_filter_init_type
  • filter_id_low : can_filter_init_type
  • filter_index : can_rx_message_type
  • filter_mask_high : can_filter_init_type
  • filter_mask_low : can_filter_init_type
  • filter_mode : can_filter_init_type
  • filter_number : can_filter_init_type
  • firmware_length : flash_iap_type
  • first_bit_transmission : spi_init_type
  • flag_address : iap_info_type
  • flash_app_addr : flash_iap_type
  • flash_app_size : flash_iap_type
  • flash_base_addr : flash_iap_type
  • flash_end_address : iap_info_type
  • flash_size : flash_iap_type, iap_info_type
  • flash_start_address : iap_info_type
  • flashen : crm_type
  • fmcfg : can_type
  • fmcfg_bit : can_type
  • fmsel0 : can_type
  • fmsel1 : can_type
  • fmsel10 : can_type
  • fmsel11 : can_type
  • fmsel12 : can_type
  • fmsel13 : can_type
  • fmsel2 : can_type
  • fmsel3 : can_type
  • fmsel4 : can_type
  • fmsel5 : can_type
  • fmsel6 : can_type
  • fmsel7 : can_type
  • fmsel8 : can_type
  • fmsel9 : can_type
  • format : linecoding_type
  • fprgm : flash_type
  • fpx : exint_type
  • frame_bit_num : spi_init_type
  • frame_type : can_rx_message_type, can_tx_message_type
  • frf : can_type
  • frf_bit : can_type
  • frfsel0 : can_type
  • frfsel1 : can_type
  • frfsel10 : can_type
  • frfsel11 : can_type
  • frfsel12 : can_type
  • frfsel13 : can_type
  • frfsel2 : can_type
  • frfsel3 : can_type
  • frfsel4 : can_type
  • frfsel5 : can_type
  • frfsel6 : can_type
  • frfsel7 : can_type
  • frfsel8 : can_type
  • frfsel9 : can_type
  • fzc : can_type
  • fzen : can_type


AT32F413 Firmwary Library: Data Fields - Variables

- g -

  • g_audio_cur : usb_audio_hid_type, usb_audio_type
  • g_cmd : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_keyboard_tx_completed : vcp_keyboard_type
  • g_len : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_printer_data : printer_type
  • g_printer_port_status : printer_type
  • g_req : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_rx_buff : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rxhid_buff : custom_hid_type, iap_info_type, usb_audio_hid_type
  • g_rxlen : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_tx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_txhid_buff : custom_hid_type, usb_audio_hid_type
  • g_u8tx_completed : keyboard_type
  • gcaddrf : i2c_type
  • gcaen : i2c_type
  • gdiv : usart_type
  • gdiv_bit : usart_type
  • genstart : i2c_type
  • genstop : i2c_type
  • get_device_config_string : usbd_desc_handler
  • get_device_configuration : usbd_desc_handler
  • get_device_descriptor : usbd_desc_handler
  • get_device_interface_string : usbd_desc_handler
  • get_device_lang_id : usbd_desc_handler
  • get_device_manufacturer_string : usbd_desc_handler
  • get_device_other_speed : usbd_desc_handler
  • get_device_product_string : usbd_desc_handler
  • get_device_qualifier : usbd_desc_handler
  • get_device_serial_string : usbd_desc_handler
  • gf1 : dma_type
  • gf2 : dma_type
  • gf3 : dma_type
  • gf4 : dma_type
  • gf5 : dma_type
  • gf6 : dma_type
  • gf7 : dma_type
  • gfc1 : dma_type
  • gfc2 : dma_type
  • gfc3 : dma_type
  • gfc4 : dma_type
  • gfc5 : dma_type
  • gfc6 : dma_type
  • gfc7 : dma_type
  • gpio_drive_strength : gpio_init_type
  • gpio_mode : gpio_init_type
  • gpio_out_type : gpio_init_type
  • gpio_pins : gpio_init_type
  • gpio_pull : gpio_init_type
  • gpioaen : crm_type
  • gpioarst : crm_type
  • gpioben : crm_type
  • gpiobrst : crm_type
  • gpiocen : crm_type
  • gpiocrst : crm_type
  • gpioden : crm_type
  • gpiodrst : crm_type
  • gpioerst : crm_type
  • gpiofen : crm_type
  • gresume : usbd_type


AT32F413 Firmwary Library: Data Fields - Variables

- h -

  • h : sc_atr_type
  • hallde : tmr_type
  • hallien : tmr_type
  • hallif : tmr_type
  • hallswtr : tmr_type
  • hdtf1 : dma_type
  • hdtf2 : dma_type
  • hdtf3 : dma_type
  • hdtf4 : dma_type
  • hdtf5 : dma_type
  • hdtf6 : dma_type
  • hdtf7 : dma_type
  • hdtfc1 : dma_type
  • hdtfc2 : dma_type
  • hdtfc3 : dma_type
  • hdtfc4 : dma_type
  • hdtfc5 : dma_type
  • hdtfc6 : dma_type
  • hdtfc7 : dma_type
  • hdtien : dma_channel_type
  • head : usart_group_type
  • hextbyps : crm_type
  • hexten : crm_type
  • hextstbl : crm_type
  • hextstblf : crm_type
  • hextstblfc : crm_type
  • hextstblien : crm_type
  • hfcen : sdio_type
  • hick_to_sclk : crm_type
  • hick_to_usb : crm_type
  • hickcal : acc_type, crm_type
  • hickcal_key : crm_type
  • hickdiv : crm_type
  • hicken : crm_type
  • hickstbl : crm_type
  • hickstblf : crm_type
  • hickstblfc : crm_type
  • hickstblien : crm_type
  • hicktrim : acc_type, crm_type
  • hid_get_report : custom_hid_type
  • hid_protocol : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_idle : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_report : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_state : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_suspend_flag : keyboard_type, mouse_type
  • hlength : sc_atr_type
  • hostaddrf : i2c_type
  • hour : calendar_type
  • hwcsoe : spi_type


AT32F413 Firmwary Library: Data Fields - Variables

- i -

  • i2c1_gmux : iomux_type
  • i2c1_mux : iomux_type
  • i2c1_smbus_timeout : debug_type
  • i2c1en : crm_type
  • i2c1rst : crm_type
  • i2c2_gmux : iomux_type
  • i2c2_smbus_timeout : debug_type
  • i2c2en : crm_type
  • i2c2rst : crm_type
  • i2cen : i2c_type
  • i2cx : i2c_handle_type
  • i2scbn : spi_type
  • i2sclk : spi_type
  • i2sclk_bit : spi_type
  • i2sclkpol : spi_type
  • i2sctrl : spi_type
  • i2sctrl_bit : spi_type
  • i2sdbn : spi_type
  • i2sdiv_h : spi_type
  • i2sdiv_l : spi_type
  • i2sen : spi_type
  • i2smclkoe : spi_type
  • i2smsel : spi_type
  • i2sodd : spi_type
  • iap_address : iap_info_type
  • iap_fifo : iap_info_type
  • iap_rx : iap_info_type
  • iap_tx : iap_info_type
  • iConfiguration : usb_configuration_desc_type
  • id : usart_type
  • id_type : can_rx_message_type, can_tx_message_type
  • idcode_bit : debug_type
  • iden : tmr_type
  • iden_bit : tmr_type
  • idlef : usart_type
  • idleien : usart_type
  • idProduct : usb_device_desc_type
  • idt : crc_type, gpio_type
  • idt0 : gpio_type
  • idt1 : gpio_type
  • idt10 : gpio_type
  • idt11 : gpio_type
  • idt12 : gpio_type
  • idt13 : gpio_type
  • idt14 : gpio_type
  • idt15 : gpio_type
  • idt2 : gpio_type
  • idt3 : gpio_type
  • idt4 : gpio_type
  • idt5 : gpio_type
  • idt6 : gpio_type
  • idt7 : gpio_type
  • idt8 : gpio_type
  • idt9 : gpio_type
  • idt_bit : crc_type, gpio_type
  • idVendor : usb_device_desc_type
  • iInterface : usb_interface_desc_type
  • iManufacturer : usb_device_desc_type
  • in_handler : usbd_class_handler
  • information : sense_type
  • init_handler : usbd_class_handler
  • inout : usb_ept_info, usbd_type
  • input_channel_select : tmr_input_config_type
  • input_filter_value : tmr_input_config_type
  • input_mapped_select : tmr_input_config_type
  • input_polarity_select : tmr_input_config_type
  • intclr : sdio_type
  • intclr_bit : sdio_type
  • inten : can_type, exint_type, sdio_type
  • inten_bit : can_type, exint_type, sdio_type
  • intenx : exint_type
  • interface : usb_audio_hid_type, usb_audio_type
  • intmap : crm_type
  • intmap_bit : crm_type
  • intsts : exint_type, usbd_type
  • intsts_bit : exint_type, usbd_type
  • intwt : sdio_type
  • iocb0 : gpio_type
  • iocb1 : gpio_type
  • iocb10 : gpio_type
  • iocb11 : gpio_type
  • iocb12 : gpio_type
  • iocb13 : gpio_type
  • iocb14 : gpio_type
  • iocb15 : gpio_type
  • iocb2 : gpio_type
  • iocb3 : gpio_type
  • iocb4 : gpio_type
  • iocb5 : gpio_type
  • iocb6 : gpio_type
  • iocb7 : gpio_type
  • iocb8 : gpio_type
  • iocb9 : gpio_type
  • ioen : sdio_type
  • iofc0 : gpio_type
  • iofc1 : gpio_type
  • iofc10 : gpio_type
  • iofc11 : gpio_type
  • iofc12 : gpio_type
  • iofc13 : gpio_type
  • iofc14 : gpio_type
  • iofc15 : gpio_type
  • iofc2 : gpio_type
  • iofc3 : gpio_type
  • iofc4 : gpio_type
  • iofc5 : gpio_type
  • iofc6 : gpio_type
  • iofc7 : gpio_type
  • iofc8 : gpio_type
  • iofc9 : gpio_type
  • ioif : sdio_type
  • ioifien : sdio_type
  • iomc0 : gpio_type
  • iomc1 : gpio_type
  • iomc10 : gpio_type
  • iomc11 : gpio_type
  • iomc12 : gpio_type
  • iomc13 : gpio_type
  • iomc14 : gpio_type
  • iomc15 : gpio_type
  • iomc2 : gpio_type
  • iomc3 : gpio_type
  • iomc4 : gpio_type
  • iomc5 : gpio_type
  • iomc6 : gpio_type
  • iomc7 : gpio_type
  • iomc8 : gpio_type
  • iomc9 : gpio_type
  • iomuxen : crm_type
  • iomuxrst : crm_type
  • iosb0 : gpio_type
  • iosb1 : gpio_type
  • iosb10 : gpio_type
  • iosb11 : gpio_type
  • iosb12 : gpio_type
  • iosb13 : gpio_type
  • iosb14 : gpio_type
  • iosb15 : gpio_type
  • iosb2 : gpio_type
  • iosb3 : gpio_type
  • iosb4 : gpio_type
  • iosb5 : gpio_type
  • iosb6 : gpio_type
  • iosb7 : gpio_type
  • iosb8 : gpio_type
  • iosb9 : gpio_type
  • iosusp : sdio_type
  • iProduct : usb_device_desc_type
  • irdaen : usart_type
  • irdalp : usart_type
  • is_double_buffer : usb_ept_info
  • isdiv : usart_type
  • iSerialNumber : usb_device_desc_type
  • ists : tmr_type
  • ists_bit : tmr_type
  • itsrven : adc_type


AT32F413 Firmwary Library: Data Fields - Variables

- k -

  • keyboard_buf : keyboard_type


AT32F413 Firmwary Library: Data Fields - Variables

- l -

  • last_access_data : fat_dir_type
  • last_len : usb_ept_info
  • lbcp : usart_type
  • lben : can_type
  • length : usbd_desc_t
  • lextbyps : crm_type
  • lexten : crm_type
  • lextstbl : crm_type
  • lextstblf : crm_type
  • lextstblfc : crm_type
  • lextstblien : crm_type
  • licken : crm_type
  • lickstbl : crm_type
  • lickstblf : crm_type
  • lickstblfc : crm_type
  • lickstblien : crm_type
  • line_enable : exint_init_type
  • line_mode : exint_init_type
  • line_polarity : exint_init_type
  • line_select : exint_init_type
  • linecoding : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • linen : usart_type
  • linex : exint_type
  • lm : dma_channel_type
  • loen : can_type
  • loop_mode_enable : dma_init_type
  • lpm : usbd_type
  • lprstf : crm_type
  • lpsel : pwc_type
  • lsamprx : can_type
  • lsof : usbd_type
  • lsofien : usbd_type
  • lsofnum : usbd_type
  • ltf : spi_type
  • lun : cbd_extended_type, cbd_typical_type


AT32F413 Firmwary Library: Data Fields - Variables

- m -

  • m2m : dma_channel_type
  • mackctrl : i2c_type
  • maddr : dma_channel_type
  • maddr_bit : dma_channel_type
  • manufact_date : sd_cid_struct_type
  • manufacturer_default_ecc : sd_csd_struct_type
  • manufacturer_id : sd_cid_struct_type
  • master_slave_mode : spi_init_type
  • max_bus_clk_freq : sd_csd_struct_type
  • max_lun : cdc_msc_struct_type, msc_type
  • max_read_blk_length : sd_csd_struct_type
  • max_read_current_vdd_max : sd_csd_struct_type
  • max_read_current_vdd_min : sd_csd_struct_type
  • max_write_blk_length : sd_csd_struct_type
  • max_write_current_vdd_max : sd_csd_struct_type
  • max_write_current_vdd_min : sd_csd_struct_type
  • maxpacket : usb_ept_info
  • mclk_freq_division : spi_init_type
  • mclk_output_enable : i2s_init_type
  • mctrl : can_type
  • mctrl_bit : can_type
  • mdiv_h : spi_type
  • mdiv_l : spi_type
  • mdrsel : can_type
  • mdrsel_selection : can_base_type
  • memory_base_addr : dma_init_type
  • memory_data_width : dma_init_type
  • memory_inc_enable : dma_init_type
  • mic_adj_count : audio_codec_type
  • mic_adj_stage : audio_codec_type
  • mic_alt_setting : usb_audio_hid_type, usb_audio_type
  • mic_buffer : audio_codec_type
  • mic_calc : audio_codec_type
  • mic_delta : audio_codec_type
  • mic_enable : audio_codec_type
  • mic_freq : usb_audio_hid_type, usb_audio_type
  • mic_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_roff : audio_codec_type
  • mic_rtotal : audio_codec_type
  • mic_rx_size : audio_codec_type
  • mic_stage : audio_codec_type
  • mic_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_volume_limits : usb_audio_hid_type, usb_audio_type
  • mic_wend : audio_codec_type
  • mic_woff : audio_codec_type
  • mic_wtotal : audio_codec_type
  • min : calendar_type
  • mincm : dma_channel_type
  • misc1 : crm_type
  • misc1_bit : crm_type
  • misc2 : crm_type
  • misc2_bit : crm_type
  • misc3 : crm_type
  • misc3_bit : crm_type
  • mmerr : spi_type
  • mmssr : can_type
  • mmssr_selection : can_base_type
  • mode : i2c_handle_type
  • mode_selection : can_base_type
  • month : calendar_type
  • mouse_buffer : mouse_type
  • msc_state : cdc_msc_struct_type, msc_type
  • msc_up_status : flash_iap_type
  • mssel : adc_type
  • msten : spi_type
  • msts : can_type
  • msts_bit : can_type
  • mwidth : dma_channel_type


AT32F413 Firmwary Library: Data Fields - Variables

- n -

  • nerr : usart_type
  • nrstf : crm_type
  • nsac : sd_csd_struct_type
  • ntc : spi_type


AT32F413 Firmwary Library: Data Fields - Variables

- o -

  • oaddr1 : i2c_type
  • oaddr1_bit : i2c_type
  • oaddr2 : i2c_type
  • oaddr2_bit : i2c_type
  • obf : flash_type
  • oc_idle_state : tmr_output_config_type
  • oc_mode : tmr_output_config_type
  • oc_output_state : tmr_output_config_type
  • oc_polarity : tmr_output_config_type
  • occ_idle_state : tmr_output_config_type
  • occ_output_state : tmr_output_config_type
  • occ_polarity : tmr_output_config_type
  • occs : adc_type
  • ocdmaen : adc_type
  • oclen : adc_type
  • ocmen : tmr_type
  • ocpcnt : adc_type
  • ocpen : adc_type
  • ocswtrg : adc_type
  • octen : adc_type
  • octesel_h : adc_type
  • octesel_l : adc_type
  • ocvmen : adc_type
  • odf : flash_type
  • odfie : flash_type
  • odt : adc_type, gpio_type
  • odt0 : gpio_type
  • odt1 : gpio_type
  • odt10 : gpio_type
  • odt11 : gpio_type
  • odt12 : gpio_type
  • odt13 : gpio_type
  • odt14 : gpio_type
  • odt15 : gpio_type
  • odt2 : gpio_type
  • odt3 : gpio_type
  • odt4 : gpio_type
  • odt5 : gpio_type
  • odt6 : gpio_type
  • odt7 : gpio_type
  • odt8 : gpio_type
  • odt9 : gpio_type
  • odt_bit : adc_type, gpio_type
  • oem_app_id : sd_cid_struct_type
  • oen : tmr_type
  • old_conn_state : usbd_core_type
  • opcode : cbd_extended_type, cbd_typical_type
  • operation_mode : i2s_init_type
  • opersel : spi_type
  • oplk : flash_type
  • ora : spi_type
  • ordinary_channel_length : adc_base_config_type
  • osn1 : adc_type
  • osn10 : adc_type
  • osn11 : adc_type
  • osn12 : adc_type
  • osn13 : adc_type
  • osn14 : adc_type
  • osn15 : adc_type
  • osn16 : adc_type
  • osn2 : adc_type
  • osn3 : adc_type
  • osn4 : adc_type
  • osn5 : adc_type
  • osn6 : adc_type
  • osn7 : adc_type
  • osn8 : adc_type
  • osn9 : adc_type
  • osq1 : adc_type
  • osq1_bit : adc_type
  • osq2 : adc_type
  • osq2_bit : adc_type
  • osq3 : adc_type
  • osq3_bit : adc_type
  • ouf : i2c_type
  • out_handler : usbd_class_handler
  • outen : bpr_type
  • outm : bpr_type
  • outsel : bpr_type
  • ovfden : tmr_type
  • ovfen : tmr_type
  • ovff : rtc_type
  • ovfien : rtc_type, tmr_type
  • ovfif : tmr_type
  • ovfs : tmr_type
  • ovfswtr : tmr_type


AT32F413 Firmwary Library: Data Fields - Variables

- p -

  • paddr : dma_channel_type
  • paddr_bit : dma_channel_type
  • parity : linecoding_type
  • part_blk_read : sd_csd_struct_type
  • part_blk_write : sd_csd_struct_type
  • pbuff : i2c_handle_type
  • pcautoen : adc_type
  • pcce : adc_type
  • pcceien : adc_type
  • pccs : adc_type
  • pcdto1 : adc_type
  • pcdto1_bit : adc_type
  • pcdto2 : adc_type
  • pcdto2_bit : adc_type
  • pcdto3 : adc_type
  • pcdto3_bit : adc_type
  • pcdto4 : adc_type
  • pcdto4_bit : adc_type
  • pclen : adc_type
  • pcmfssel : spi_type
  • pcount : i2c_handle_type
  • pcpen : adc_type
  • pcswtrg : adc_type
  • pcten : adc_type
  • pctesel_h : adc_type
  • pctesel_l : adc_type
  • pcvmen : adc_type
  • pd01_gmux : iomux_type
  • pd01_mux : iomux_type
  • pdata : usbd_class_handler
  • pdt1 : adc_type
  • pdt1_bit : adc_type
  • pdt2 : adc_type
  • pdt2_bit : adc_type
  • pdt3 : adc_type
  • pdt3_bit : adc_type
  • pdt4 : adc_type
  • pdt4_bit : adc_type
  • pecen : i2c_type
  • pecerr : i2c_type
  • pecten : i2c_type
  • pecval : i2c_type
  • pen : usart_type
  • peripheral_base_addr : dma_init_type
  • peripheral_data_width : dma_init_type
  • peripheral_inc_enable : dma_init_type
  • permanent_write_protect : sd_csd_struct_type
  • permode : i2c_type
  • perr : usart_type
  • perrien : usart_type
  • pid : debug_type
  • pincm : dma_channel_type
  • pllen : crm_type
  • pllhextdiv : crm_type
  • pllmult_h : crm_type
  • pllmult_l : crm_type
  • pllrange : crm_type
  • pllrcs : crm_type
  • pllstbl : crm_type
  • pllstblf : crm_type
  • pllstblfc : crm_type
  • pllstblien : crm_type
  • pmen : tmr_type
  • pndwt : sdio_type
  • polcfg1 : exint_type
  • polcfg1_bit : exint_type
  • polcfg2 : exint_type
  • polcfg2_bit : exint_type
  • poly : crc_type
  • poly_bit : crc_type
  • poly_size : crc_type
  • porrstf : crm_type
  • pr : tmr_type
  • pr_bit : tmr_type
  • prben : tmr_type
  • prgmerr : flash_type
  • priority : dma_init_type
  • product_name1 : sd_cid_struct_type
  • product_name2 : sd_cid_struct_type
  • product_reversion : sd_cid_struct_type
  • product_sn : sd_cid_struct_type
  • prsf_enable : can_base_type
  • prsfen : can_type
  • ps : sdio_type
  • psel : usart_type
  • psn1 : adc_type
  • psn2 : adc_type
  • psn3 : adc_type
  • psn4 : adc_type
  • psq : adc_type
  • psq_bit : adc_type
  • psr : flash_type
  • psr_bit : flash_type
  • ptd : can_type
  • ptos : tmr_type
  • pvmen : pwc_type
  • pvmof : pwc_type
  • pvmsel : pwc_type
  • pwcen : crm_type
  • pwcrst : crm_type
  • pwidth : dma_channel_type
  • pwrctrl : sdio_type
  • pwrctrl_bit : sdio_type
  • pwrsven : sdio_type


AT32F413 Firmwary Library: Data Fields - Variables

- q -

  • qdzien : can_type
  • qdzif : can_type


AT32F413 Firmwary Library: Data Fields - Variables

- r -

  • rca : sd_card_info_struct_type
  • rcrc : spi_type
  • rcrc_bit : spi_type
  • rdbf : i2c_type, spi_type, usart_type
  • rdbfie : spi_type
  • rdbfien : usart_type
  • rdwtmode : sdio_type
  • rdwtstart : sdio_type
  • rdwtstop : sdio_type
  • read_blk_misalign : sd_csd_struct_type
  • read_crc : flash_iap_type
  • realrx : can_type
  • rec : can_type
  • rem0_len : usb_ept_info
  • remap : iomux_type
  • remap2 : iomux_type
  • remap2_bit : iomux_type
  • remap3 : iomux_type
  • remap3_bit : iomux_type
  • remap4 : iomux_type
  • remap4_bit : iomux_type
  • remap5 : iomux_type
  • remap5_bit : iomux_type
  • remap6 : iomux_type
  • remap6_bit : iomux_type
  • remap7 : iomux_type
  • remap7_bit : iomux_type
  • remap_bit : iomux_type
  • remote_wakup : usbd_core_type
  • ren : usart_type
  • repeat_mode : adc_base_config_type
  • request_no : usb_audio_hid_type, usb_audio_type
  • res : fat_dir_type
  • reserved : tmr_type, usd_type
  • reserved1 : acc_type, adc_type, bpr_type, can_fifo_mailbox_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, dma_channel_type, dma_type, exint_type, flash_type, gpio_type, i2c_type, iomux_type, pwc_type, rtc_type, sd_cid_struct_type, sd_csd_struct_type, sd_scr_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type, wdt_type, wwdt_type
  • reserved2 : acc_type, adc_type, bpr_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, pwc_type, sd_cid_struct_type, sd_csd_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type
  • reserved3 : acc_type, adc_type, bpr_type, can_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, sd_csd_struct_type, sense_type, usart_type
  • reserved4 : adc_type, can_type, crm_type, debug_type, flash_type, iomux_type, sd_csd_struct_type
  • reserved5 : can_type, crm_type, flash_type
  • reserved6 : can_type, crm_type, flash_type
  • reserverd2 : sd_scr_struct_type
  • reserverd3 : sd_scr_struct_type
  • reset : i2c_type
  • respond_flag : iap_info_type
  • revid : crc_type
  • revod : crc_type
  • rf0 : can_type
  • rf0_bit : can_type
  • rf0ff : can_type
  • rf0fien : can_type
  • rf0mien : can_type
  • rf0mn : can_type
  • rf0of : can_type
  • rf0oien : can_type
  • rf0r : can_type
  • rf1 : can_type
  • rf1_bit : can_type
  • rf1ff : can_type
  • rf1fien : can_type
  • rf1mien : can_type
  • rf1mn : can_type
  • rf1of : can_type
  • rf1oien : can_type
  • rf1r : can_type
  • rfc : can_fifo_mailbox_type
  • rfc_bit : can_fifo_mailbox_type
  • rfdt0 : can_fifo_mailbox_type
  • rfdt1 : can_fifo_mailbox_type
  • rfdt2 : can_fifo_mailbox_type
  • rfdt3 : can_fifo_mailbox_type
  • rfdt4 : can_fifo_mailbox_type
  • rfdt5 : can_fifo_mailbox_type
  • rfdt6 : can_fifo_mailbox_type
  • rfdt7 : can_fifo_mailbox_type
  • rfdth : can_fifo_mailbox_type
  • rfdth_bit : can_fifo_mailbox_type
  • rfdtl : can_fifo_mailbox_type
  • rfdtl_bit : can_fifo_mailbox_type
  • rfeid : can_fifo_mailbox_type
  • rffmn : can_fifo_mailbox_type
  • rffri : can_fifo_mailbox_type
  • rfi : can_fifo_mailbox_type
  • rfi_bit : can_fifo_mailbox_type
  • rfidi : can_fifo_mailbox_type
  • rfsid : can_fifo_mailbox_type
  • rfts : can_fifo_mailbox_type
  • risetime : i2c_type
  • rld : wdt_type
  • rld_bit : wdt_type
  • rldf : wdt_type, wwdt_type
  • rldien : wwdt_type
  • rm : usart_type
  • roerr : spi_type, usart_type
  • rpen : adc_type
  • rpr : tmr_type
  • rpr_bit : tmr_type
  • rpx : exint_type
  • rsaw : can_type
  • rsaw_size : can_baudrate_type
  • rslost : acc_type
  • rsp1 : sdio_type
  • rsp1_bit : sdio_type
  • rsp2 : sdio_type
  • rsp2_bit : sdio_type
  • rsp3 : sdio_type
  • rsp3_bit : sdio_type
  • rsp4 : sdio_type
  • rsp4_bit : sdio_type
  • rsp_type : sdio_command_struct_type
  • rspcmd : sdio_type
  • rspcmd_bit : sdio_type
  • rspwt : sdio_type
  • rst : crc_type, usbd_type
  • rstfc : crm_type
  • rstien : usbd_type
  • rtccal : bpr_type
  • rtccal_bit : bpr_type
  • rtcen : crm_type
  • rtcsel : crm_type
  • rtsen : usart_type
  • rx_addr : usb_ept_info
  • rxbuf : sdio_type
  • rxbufe : sdio_type
  • rxbufeien : sdio_type
  • rxbuff : sdio_type
  • rxbuffien : sdio_type
  • rxbufh : sdio_type
  • rxbufhien : sdio_type
  • rxbufien : sdio_type
  • rxdts : usbd_type
  • rxerro : sdio_type
  • rxerroien : sdio_type
  • rxsts : usbd_type
  • rxtc : usbd_type


AT32F413 Firmwary Library: Data Fields - Variables

- s -

  • sbf : usart_type
  • sbiterr : sdio_type
  • sbiterrien : sdio_type
  • scgt : usart_type
  • sclk_freq : crm_clocks_freq_type
  • sclksel : crm_type
  • sclksts : crm_type
  • scmen : usart_type
  • scnacken : usart_type
  • scr : gpio_type
  • scr_bit : gpio_type
  • scr_structure : sd_scr_struct_type
  • sd_bus_width : sd_scr_struct_type
  • sd_cid_reg : sd_card_info_struct_type
  • sd_csd_reg : sd_card_info_struct_type
  • sd_scr_reg : sd_card_info_struct_type
  • sd_security : sd_scr_struct_type
  • sd_spec : sd_scr_struct_type
  • sd_spec3 : sd_scr_struct_type
  • sdio1_gmux : iomux_type
  • sdio1en : crm_type
  • sec : calendar_type
  • secers : flash_type
  • sector_mask : flash_iap_type
  • sector_size : flash_iap_type, iap_info_type
  • sef : pwc_type
  • select : flash_type
  • select_bit : flash_type
  • selpin : iomux_type
  • selport : iomux_type
  • sense_key : sense_type
  • sequence_mode : adc_base_config_type
  • setup : usbd_core_type
  • setup_buffer : usbd_core_type
  • setup_handler : usbd_class_handler
  • setuptc : usbd_type
  • slben : spi_type, usart_type
  • slbtd : spi_type
  • sleep_debug : debug_type
  • slib_dat_ss : flash_type
  • slib_dss_set : flash_type
  • slib_enf : flash_type
  • slib_es : flash_type
  • slib_es_set : flash_type
  • slib_misc_sts : flash_type
  • slib_misc_sts_bit : flash_type
  • slib_pclr_val : flash_type
  • slib_pset_val : flash_type
  • slib_pwd_clr : flash_type
  • slib_pwd_clr_bit : flash_type
  • slib_pwd_err : flash_type
  • slib_pwd_ok : flash_type
  • slib_rcnt : flash_type
  • slib_set_pwd : flash_type
  • slib_set_pwd_bit : flash_type
  • slib_set_range : flash_type
  • slib_set_range_bit : flash_type
  • slib_ss : flash_type
  • slib_ss_set : flash_type
  • slib_sts0 : flash_type
  • slib_sts0_bit : flash_type
  • slib_sts1 : flash_type
  • slib_sts1_bit : flash_type
  • slib_ukval : flash_type
  • slib_ulkf : flash_type
  • slib_unlock : flash_type
  • slib_unlock_bit : flash_type
  • smbalert : i2c_type
  • smbmode : i2c_type
  • smsel : tmr_type
  • sof : usbd_type
  • sof_handler : usbd_class_handler
  • sofien : usbd_type
  • sofnum : usbd_type
  • sofouten : usbd_type
  • sofrnum : usbd_type
  • sofrnum_bit : usbd_type
  • sp : usbd_type
  • spec_version : sd_csd_struct_type
  • speed : i2c_type, usbd_core_type
  • speedmode : i2c_type
  • spi1_gmux : iomux_type
  • spi1_mux_h : iomux_type
  • spi1_mux_l : iomux_type
  • spi1en : crm_type
  • spi1rst : crm_type
  • spi2_gmux : iomux_type
  • spi2en : crm_type
  • spi2rst : crm_type
  • spien : spi_type, usbd_type
  • spk_alt_setting : usb_audio_hid_type, usb_audio_type
  • spk_buffer : audio_codec_type
  • spk_calc : audio_codec_type
  • spk_enable : audio_codec_type
  • spk_freq : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_rend : audio_codec_type
  • spk_roff : audio_codec_type
  • spk_rtotal : audio_codec_type
  • spk_stage : audio_codec_type
  • spk_threshold : audio_codec_type
  • spk_tx_size : audio_codec_type
  • spk_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_volume_limits : usb_audio_hid_type, usb_audio_type
  • spk_woff : audio_codec_type
  • spk_wtotal : audio_codec_type
  • sprst : can_type
  • spt1 : adc_type
  • spt1_bit : adc_type
  • spt2 : adc_type
  • spt2_bit : adc_type
  • sqen : adc_type
  • sramen : crm_type
  • src_sel0 : dma_type
  • src_sel0_bit : dma_type
  • src_sel1 : dma_type
  • src_sel1_bit : dma_type
  • ssb : usd_type
  • ssp : usbd_type
  • stall : usb_ept_info
  • standard_id : can_rx_message_type, can_tx_message_type
  • standby_debug : debug_type
  • startf : i2c_type
  • state : iap_info_type
  • status : i2c_handle_type, usb_ept_info
  • stctrl : tmr_type
  • stctrl_bit : tmr_type
  • stdby_rst : flash_type
  • stdsel : spi_type
  • step : acc_type
  • stis : tmr_type
  • stopbn : usart_type
  • stopf : i2c_type
  • stretch : i2c_type
  • sts : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, tmr_type, usart_type, wdt_type, wwdt_type
  • sts1 : i2c_type
  • sts1_bit : i2c_type
  • sts2 : i2c_type
  • sts2_bit : i2c_type
  • sts3 : flash_type
  • sts3_bit : flash_type
  • sts_bit : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, usart_type, wdt_type, wwdt_type
  • swcsen : spi_type
  • swcsil : spi_type
  • swef : pwc_type
  • swevt : tmr_type
  • swevt_bit : tmr_type
  • swjtag_conf : iomux_type
  • swjtag_gmux : iomux_type
  • swpen : pwc_type
  • swrstf : crm_type
  • swtrg : exint_type
  • swtrg_bit : exint_type
  • swtx : exint_type


AT32F413 Firmwary Library: Data Fields - Variables

- t -

  • t : sc_atr_type
  • t0 : sc_atr_type
  • ta : rtc_type
  • taac : sd_csd_struct_type
  • taf : rtc_type
  • tah : rtc_type
  • tah_bit : rtc_type
  • taien : rtc_type
  • tail : usart_group_type
  • tal : rtc_type
  • tal_bit : rtc_type
  • tc : usbd_type
  • tcien : can_type, usbd_type
  • tcrc : spi_type
  • tcrc_bit : spi_type
  • tdbe : i2c_type, spi_type, usart_type
  • tdbeie : spi_type
  • tdbeien : usart_type
  • tdc : i2c_type, usart_type
  • tdcien : usart_type
  • tden : tmr_type
  • tec : can_type
  • temp : keyboard_type
  • temp_write_protect : sd_csd_struct_type
  • ten : usart_type
  • tfrdir : sdio_type
  • tfren : sdio_type
  • tfrmode : sdio_type
  • tien : tmr_type
  • timeout : i2c_handle_type, sdio_data_struct_type, sdio_type
  • tlength : sc_atr_type
  • tm0alf : can_type
  • tm0ct : can_type
  • tm0ef : can_type
  • tm0lpf : can_type
  • tm0tcf : can_type
  • tm0tef : can_type
  • tm0tsf : can_type
  • tm1alf : can_type
  • tm1ct : can_type
  • tm1ef : can_type
  • tm1lpf : can_type
  • tm1tcf : can_type
  • tm1tef : can_type
  • tm1tsf : can_type
  • tm2alf : can_type
  • tm2ct : can_type
  • tm2ef : can_type
  • tm2lpf : can_type
  • tm2tcf : can_type
  • tm2tef : can_type
  • tm2tsf : can_type
  • tmc : can_tx_mailbox_type
  • tmc_bit : can_tx_mailbox_type
  • tmdt0 : can_tx_mailbox_type
  • tmdt1 : can_tx_mailbox_type
  • tmdt2 : can_tx_mailbox_type
  • tmdt3 : can_tx_mailbox_type
  • tmdt4 : can_tx_mailbox_type
  • tmdt5 : can_tx_mailbox_type
  • tmdt6 : can_tx_mailbox_type
  • tmdt7 : can_tx_mailbox_type
  • tmdtbl : can_tx_mailbox_type
  • tmdth : can_tx_mailbox_type
  • tmdth_bit : can_tx_mailbox_type
  • tmdtl : can_tx_mailbox_type
  • tmdtl_bit : can_tx_mailbox_type
  • tmeid : can_tx_mailbox_type
  • tmfrsel : can_tx_mailbox_type
  • tmi : can_tx_mailbox_type
  • tmi_bit : can_tx_mailbox_type
  • tmidsel : can_tx_mailbox_type
  • tmnr : can_type
  • tmout : i2c_type
  • tmr10_gmux : iomux_type
  • tmr10_pause : debug_type
  • tmr10en : crm_type
  • tmr10rst : crm_type
  • tmr11_gmux : iomux_type
  • tmr11_pause : debug_type
  • tmr11en : crm_type
  • tmr11rst : crm_type
  • tmr1_gmux : iomux_type
  • tmr1_mux : iomux_type
  • tmr1_pause : debug_type
  • tmr1en : crm_type
  • tmr1rst : crm_type
  • tmr2_gmux : iomux_type
  • tmr2_mux : iomux_type
  • tmr2_pause : debug_type
  • tmr2en : crm_type
  • tmr2itr1_gmux : iomux_type
  • tmr2rst : crm_type
  • tmr3_gmux : iomux_type
  • tmr3_mux : iomux_type
  • tmr3_pause : debug_type
  • tmr3en : crm_type
  • tmr3rst : crm_type
  • tmr4_pause : debug_type
  • tmr4en : crm_type
  • tmr4rst : crm_type
  • tmr5_gmux : iomux_type
  • tmr5_pause : debug_type
  • tmr5ch4_gmux : iomux_type
  • tmr5ch4_mux : iomux_type
  • tmr5en : crm_type
  • tmr5rst : crm_type
  • tmr8_pause : debug_type
  • tmr8en : crm_type
  • tmr8rst : crm_type
  • tmr9_gmux : iomux_type
  • tmr9_pause : debug_type
  • tmr9en : crm_type
  • tmr9rst : crm_type
  • tmren : tmr_type
  • tmrise : i2c_type
  • tmrise_bit : i2c_type
  • tmsid : can_tx_mailbox_type
  • tmsr : can_tx_mailbox_type
  • tmts : can_tx_mailbox_type
  • tmtsten : can_tx_mailbox_type
  • total_len : usb_ept_info
  • tpef : bpr_type
  • tpefclr : bpr_type
  • tpen : bpr_type
  • tpien : bpr_type
  • tpif : bpr_type
  • tpifclr : bpr_type
  • tpp : bpr_type
  • trace_ioen : debug_type
  • trace_mode : debug_type
  • trans_buf : usb_ept_info
  • trans_len : usb_ept_info
  • trans_type : usb_ept_info, usbd_type
  • transfer_direction : sdio_data_struct_type
  • transfer_mode : sdio_data_struct_type
  • transmission_mode : spi_init_type
  • trgif : tmr_type
  • trgswtr : tmr_type
  • trmode : i2c_type
  • ts : sc_atr_type
  • tsf : rtc_type
  • tsien : rtc_type
  • tsts : can_type
  • tsts_bit : can_type
  • ttc_enable : can_base_type
  • ttcen : can_type
  • tuerr : spi_type
  • tx_addr : usb_ept_info
  • tx_length : iap_info_type
  • tx_mailbox : can_type
  • txbuf : sdio_type
  • txbufe : sdio_type
  • txbufeien : sdio_type
  • txbuff : sdio_type
  • txbuffien : sdio_type
  • txbufh : sdio_type
  • txbufhien : sdio_type
  • txbufien : sdio_type
  • txdts : usbd_type
  • txerru : sdio_type
  • txerruien : sdio_type
  • txsts : usbd_type
  • txtc : usbd_type


AT32F413 Firmwary Library: Data Fields - Variables

- u -

  • uart4_gmux : iomux_type
  • uart4en : crm_type
  • uart4rst : crm_type
  • uart5en : crm_type
  • uart5rst : crm_type
  • ucfor : usbd_type
  • ucforien : usbd_type
  • uen : usart_type
  • ukval : flash_type
  • unlock : flash_type
  • unlock3 : flash_type
  • unlock3_bit : flash_type
  • unlock_bit : flash_type
  • updf : rtc_type
  • usart1_gmux : iomux_type
  • usart1_mux : iomux_type
  • usart1en : crm_type
  • usart1rst : crm_type
  • usart2en : crm_type
  • usart2rst : crm_type
  • usart3_gmux : iomux_type
  • usart3_mux : iomux_type
  • usart3en : crm_type
  • usart3rst : crm_type
  • usb_reg : usbd_core_type
  • usbbufs : crm_type
  • usbdiv_h : crm_type
  • usbdiv_l : crm_type
  • usben : crm_type
  • usbintmap : crm_type
  • usbrst : crm_type
  • usd : flash_type
  • usd_bit : flash_type
  • usd_ukval : flash_type
  • usd_unlock : flash_type
  • usd_unlock_bit : flash_type
  • usderr : flash_type
  • usders : flash_type
  • usdprgm : flash_type
  • usdulks : flash_type
  • user_d0 : flash_type
  • user_d1 : flash_type


AT32F413 Firmwary Library: Data Fields - Variables

- v -

  • vmcsel : adc_type
  • vmhb : adc_type
  • vmhb_bit : adc_type
  • vmlb : adc_type
  • vmlb_bit : adc_type
  • vmor : adc_type
  • vmorien : adc_type
  • vmsgen : adc_type


AT32F413 Firmwary Library: Data Fields - Variables

- w -

  • wait_type : sdio_command_struct_type
  • wdt_ato_en : flash_type
  • wdt_pause : debug_type
  • wdtrstf : crm_type
  • week : calendar_type
  • win : wwdt_type
  • wIndex : usb_setup_type
  • wk : usbd_type
  • wkien : usbd_type
  • wLength : usb_setup_type
  • wMaxPacketSize : usb_endpoint_desc_type
  • wp_level : tmr_brkdt_config_type
  • wpc : tmr_type
  • wpen0 : gpio_type
  • wpen1 : gpio_type
  • wpen10 : gpio_type
  • wpen11 : gpio_type
  • wpen12 : gpio_type
  • wpen13 : gpio_type
  • wpen14 : gpio_type
  • wpen15 : gpio_type
  • wpen2 : gpio_type
  • wpen3 : gpio_type
  • wpen4 : gpio_type
  • wpen5 : gpio_type
  • wpen6 : gpio_type
  • wpen7 : gpio_type
  • wpen8 : gpio_type
  • wpen9 : gpio_type
  • wpr : gpio_type
  • wpr_bit : gpio_type
  • wpseq : gpio_type
  • write_addr : flash_iap_type
  • write_blk_misalign : sd_csd_struct_type
  • write_crc : flash_iap_type
  • write_data : fat_dir_type
  • write_protect_group_enable : sd_csd_struct_type
  • write_protect_group_size : sd_csd_struct_type
  • write_speed_factor : sd_csd_struct_type
  • write_time : fat_dir_type
  • wTotalLength : usb_configuration_desc_type
  • wum : usart_type
  • wValue : usb_setup_type
  • wwdt_pause : debug_type
  • wwdten : crm_type, wwdt_type
  • wwdtrst : crm_type
  • wwdtrstf : crm_type


AT32F413 Firmwary Library: Data Fields - Variables

- y -

  • year : calendar_type


AT32F413 Firmwary Library: File List

File List
Here is a list of all files with brief descriptions:
at32f413.h | At32f413 header file
system_at32f413.c | All the functions for cmsis cortex-m4 system source file
system_at32f413.h | Cmsis cortex-m4 system header file
at32f413_acc.h | At32f413 acc header file
at32f413_adc.h | At32f413 adc header file
at32f413_bpr.h | At32f413 bpr header file
at32f413_can.h | At32f413 can header file
at32f413_crc.h | At32f413 crc header file
at32f413_crm.h | At32f413 crm header file
at32f413_debug.h | At32f413 debug header file
at32f413_def.h | At32f413 macros header file
at32f413_dma.h | At32f413 dma header file
at32f413_exint.h | At32f413 exint header file
at32f413_flash.h | At32f413 flash header file
at32f413_gpio.h | At32f413 gpio header file
at32f413_i2c.h | At32f413 i2c header file
at32f413_misc.h | At32f413 misc header file
at32f413_pwc.h | At32f413 pwc header file
at32f413_rtc.h | At32f413 rtc header file
at32f413_sdio.h | At32f413 sdio header file
at32f413_spi.h | At32f413 spi header file
at32f413_tmr.h | At32f413 tmr header file
at32f413_usart.h | At32f413 usart header file
at32f413_usb.h | At32f413 usb header file
at32f413_wdt.h | At32f413 wdt header file
at32f413_wwdt.h | At32f413 wwdt header file
at32f413_acc.c | All the functions for the acc firmware library
at32f413_adc.c | All the functions for the adc firmware library
at32f413_bpr.c | All the functions for the bpr firmware library
at32f413_can.c | All the functions for the can firmware library
at32f413_crc.c | All the functions for the crc firmware library
at32f413_crm.c | All the functions for the crm firmware library
at32f413_debug.c | All the functions for the debug firmware library
at32f413_dma.c | All the functions for the dma firmware library
at32f413_exint.c | All the functions for the exint firmware library
at32f413_flash.c | All the functions for the flash firmware library
at32f413_gpio.c | All the functions for the gpio firmware library
at32f413_i2c.c | All the functions for the i2c firmware library
at32f413_misc.c | All the functions for the misc firmware library
at32f413_pwc.c | All the functions for the pwc firmware library
at32f413_rtc.c | All the functions for the rtc firmware library
at32f413_sdio.c | All the functions for the sdio firmware library
at32f413_spi.c | All the functions for the spi firmware library
at32f413_tmr.c | All the functions for the tmr firmware library
at32f413_usart.c | All the functions for the usart firmware library
at32f413_usb.c | Functions for the usb firmware library
at32f413_wdt.c | All the functions for the wdt firmware library
at32f413_wwdt.c | All the functions for the wwdt firmware library
main_page.h |
i2c_application.c | Driver library of the i2c peripheral
i2c_application.h | I2c application libray header file
audio_class.c | Usb audio class type
audio_class.h | Usb audio class file
audio/audio_conf.h | Usb audio config
audio_hid/audio_conf.h | Usb audio config
audio_desc.c | Usb audio device descriptor
audio_desc.h | Usb audio descriptor header file
audio_hid_class.c |
audio_hid_class.h |
audio_hid_desc.c |
audio_hid_desc.h |
cdc_class.c | Usb cdc class type
cdc_class.h | Usb cdc class file
cdc_desc.c | Usb cdc device descriptor
cdc_desc.h | Usb cdc descriptor header file
cdc_keyboard_class.c | Usb cdc and keyboard class type
cdc_keyboard_class.h | Usb cdc and keyboard class file
cdc_keyboard_desc.c | Usb cdc and keyboard device descriptor
cdc_keyboard_desc.h | Usb cdc and keyboard descriptor header file
cdc_msc_class.c | Usb cdc class type
cdc_msc_class.h | Usb cdc class file
cdc_msc_desc.c | Usb cdc device descriptor
cdc_msc_desc.h | Usb cdc descriptor header file
composite_cdc_msc/msc_bot_scsi.c | Usb mass storage bulk-only transport and scsi command
msc/msc_bot_scsi.c | Usb mass storage bulk-only transport and scsi command
custom_hid_class.c | Usb custom hid class type
custom_hid_class.h | Usb custom hid header file
custom_hid_desc.c | Usb hid device descriptor
custom_hid_desc.h | Usb custom hid descriptor header file
hid_iap_class.c | Usb hid iap class type
hid_iap_class.h | Usb hid iap header file
hid_iap_desc.c | Usb hid device descriptor
hid_iap_desc.h | Usb hid descriptor header file
keyboard_class.c | Usb hid keyboard class type
keyboard_class.h | Usb hid keyboard header file
keyboard_desc.c | Usb hid keyboard device descriptor
keyboard_desc.h | Usb keyboard descriptor header file
mouse_class.c | Usb hid mouse class type
mouse_class.h | Usb hid mouse header file
mouse_desc.c | Usb hid mouse device descriptor
mouse_desc.h | Usb mouse descriptor header file
msc_bot_scsi.h | Usb mass storage bulk-only transport and scsi command header file
msc_class.c | Usb msc class type
msc_class.h | Usb msc class file
msc_desc.c | Usb msc device descriptor
msc_desc.h | Usb msc descriptor header file
printer_class.c | Usb printer class type
printer_class.h | Usb printer class file
printer_desc.c | Usb printer device descriptor
printer_desc.h | Usb printer descriptor header file
usb_std.h | Usb standard header file
usbd_core.h | Usb device core header file
usbd_int.h |
usbd_sdr.h | Usb standard request header file
usbd_core.c | Usb driver
usbd_int.c | Usb interrupt request
usbd_sdr.c | Usb standard device request
at32f413_board.c | Set of firmware functions to manage leds and push-button. initialize delay function
at32f413_board.h | Header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function
project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/can/filter/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/templates/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_freertos_demo/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/can/filter/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/templates/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_freertos_demo/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/can/filter/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/irda/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/printf/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/templates/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_freertos_demo/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/acc/calibration/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h | Usb config header file
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h | Usb config header file
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h | Usb config header file
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/can/filter/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/irda/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/printf/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c | System clock config program
project/at_start_f413/templates/src/at32f413_clock.c | System clock config program
utilities/at32f413_freertos_demo/src/at32f413_clock.c | System clock config program
utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c | System clock config program
utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c | System clock config program
utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c | System clock config program
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c | System clock config program
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/acc/calibration/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/can/filter/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/crc/calculation/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/irda/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/printf/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/rs485/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/templates/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_freertos_demo/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_gen_random_number_demo/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/acc/calibration/src/main.c | Main program
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c | Main program
project/at_start_f413/examples/adc/current_vref_value_check/src/main.c | Main program
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c | Main program
project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c | Main program
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c | Main program
project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c | Main program
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c | Main program
project/at_start_f413/examples/adc/voltage_monitoring/src/main.c | Main program
project/at_start_f413/examples/bpr/bpr_data/src/main.c | Main program
project/at_start_f413/examples/bpr/tamper/src/main.c | Main program
project/at_start_f413/examples/can/communication_mode/src/main.c | Main program
project/at_start_f413/examples/can/filter/src/main.c | Main program
project/at_start_f413/examples/can/loopback_mode/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/bit_band/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/fpu/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c | Main program
project/at_start_f413/examples/crc/calculation/src/main.c | Main program
project/at_start_f413/examples/crm/clock_failure_detection/src/main.c | Main program
project/at_start_f413/examples/crm/sysclk_switch/src/main.c | Main program
project/at_start_f413/examples/debug/tmr1/src/main.c | Main program
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c | Main program
project/at_start_f413/examples/dma/flash_to_sram/src/main.c | Main program
project/at_start_f413/examples/exint/exint_config/src/main.c | Main program
project/at_start_f413/examples/exint/exint_software_trigger/src/main.c | Main program
project/at_start_f413/examples/flash/fap_enable/src/main.c | Main program
project/at_start_f413/examples/flash/flash_write_read/src/main.c | Main program
project/at_start_f413/examples/flash/operate_spim/src/main.c | Main program
project/at_start_f413/examples/flash/run_in_spim/src/main.c | Main program
project/at_start_f413/examples/gpio/io_toggle/src/main.c | Main program
project/at_start_f413/examples/gpio/led_toggle/src/main.c | Main program
project/at_start_f413/examples/gpio/swjtag_remap/src/main.c | Main program
project/at_start_f413/examples/i2c/communication_dma/src/main.c | Main program
project/at_start_f413/examples/i2c/communication_int/src/main.c | Main program
project/at_start_f413/examples/i2c/communication_poll/src/main.c | Main program
project/at_start_f413/examples/i2c/eeprom/src/main.c | Main program
project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c | Main program
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c | Main program
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c | Main program
project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c | Main program
project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c | Main program
project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c | Main program
project/at_start_f413/examples/pwc/sleep_usart1/src/main.c | Main program
project/at_start_f413/examples/pwc/standby_rtc/src/main.c | Main program
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c | Main program
project/at_start_f413/examples/rtc/calendar/src/main.c | Main program
project/at_start_f413/examples/rtc/lick_calibration/src/main.c | Main program
project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c | Main program
project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c | Main program
project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c | Main program
project/at_start_f413/examples/spi/fullduplex_polling/src/main.c | Main program
project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c | Main program
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c | Main program
project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c | Main program
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c | Main program
project/at_start_f413/examples/spi/w25q_flash/src/main.c | Main program
project/at_start_f413/examples/sram/extend_sram/src/main.c | Main program
project/at_start_f413/examples/tmr/6_steps/src/main.c | Main program
project/at_start_f413/examples/tmr/7_pwm_output/src/main.c | Main program
project/at_start_f413/examples/tmr/cascade_synchro/src/main.c | Main program
project/at_start_f413/examples/tmr/complementary_signals/src/main.c | Main program
project/at_start_f413/examples/tmr/dma/src/main.c | Main program
project/at_start_f413/examples/tmr/dma_burst/src/main.c | Main program
project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c | Main program
project/at_start_f413/examples/tmr/external_clock/src/main.c | Main program
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c | Main program
project/at_start_f413/examples/tmr/hang_mode/src/main.c | Main program
project/at_start_f413/examples/tmr/input_capture/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_high/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_low/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c | Main program
project/at_start_f413/examples/tmr/one_cycle/src/main.c | Main program
project/at_start_f413/examples/tmr/parallel_synchro/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_input/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c | Main program
project/at_start_f413/examples/tmr/timer_base/src/main.c | Main program
project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c | Main program
project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c | Main program
project/at_start_f413/examples/usart/half_duplex/src/main.c | Main program
project/at_start_f413/examples/usart/hw_flow_control/src/main.c | Main program
project/at_start_f413/examples/usart/idle_detection/src/main.c | Main program
project/at_start_f413/examples/usart/interrupt/src/main.c | Main program
project/at_start_f413/examples/usart/irda/src/main.c | Main program
project/at_start_f413/examples/usart/polling/src/main.c | Main program
project/at_start_f413/examples/usart/printf/src/main.c | Main program
project/at_start_f413/examples/usart/receiver_mute/src/main.c | Main program
project/at_start_f413/examples/usart/rs485/src/main.c | Main program
project/at_start_f413/examples/usart/smartcard/src/main.c | Main program
project/at_start_f413/examples/usart/synchronous/src/main.c | Main program
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c | Main program
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c | Main program
project/at_start_f413/examples/usb_device/audio/src/main.c | Main program
project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c | Main program
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c | Main program
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c | Main program
project/at_start_f413/examples/usb_device/custom_hid/src/main.c | Main program
project/at_start_f413/examples/usb_device/keyboard/src/main.c | Main program
project/at_start_f413/examples/usb_device/mouse/src/main.c | Main program
project/at_start_f413/examples/usb_device/msc/src/main.c | Main program
project/at_start_f413/examples/usb_device/printer/src/main.c | Main program
project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c | Main program
project/at_start_f413/examples/usb_device/virtual_comport/src/main.c | Main program
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c | Main program
project/at_start_f413/examples/wdt/wdt_reset/src/main.c | Main program
project/at_start_f413/examples/wdt/wdt_standby/src/main.c | Main program
project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c | Main program
project/at_start_f413/templates/src/main.c | Main program
utilities/at32f413_freertos_demo/src/main.c | Main program
utilities/at32f413_gen_random_number_demo/src/main.c | Main program
utilities/at32f413_slib_demo/project_l0/src/main.c | Main program
utilities/at32f413_slib_demo/project_l1/src/main.c | Main program
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c | Main program
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c | Main program
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c | Main program
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c | Main program
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c | Main program
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c | Main program
julia_fpu.h | Julia_fpu header file
julia_fpu.c | Julia_fpu source file
project/at_start_f413/examples/flash/flash_write_read/inc/flash.h | Flash header file
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h | Flash header file
project/at_start_f413/examples/flash/flash_write_read/src/flash.c | Flash program
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c | Flash program
operate_spim.h | Operate_spim header file
operate_spim.c | Operate spim program
run_in_spim.h | Run_in_spim header file
run_in_spim.c | Run in spim program
rtc.h | This file provides template for calendar api
rtc.c | This file provides template for calendar api
sd_mmc_card/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
sdio_fatfs/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
ffconf.h |
sd_mmc_card/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
sdio_fatfs/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
diskio.c |
spi_flash.h | Header file of spi_flash
spi_flash.c | Spi_flash source code
smartcard_config.h | Header file of clock program
audio/inc/audio_codec.h | Audio codec header file
composite_audio_hid/inc/audio_codec.h | Audio codec header file
audio/src/audio_codec.c | Audio codec function
composite_audio_hid/src/audio_codec.c | Audio codec function
composite_vcp_msc/inc/msc_diskio.h | Usb mass storage disk interface header file
msc/inc/msc_diskio.h | Usb mass storage disk interface header file
virtual_msc_iap/inc/msc_diskio.h | Usb mass storage disk interface header file
composite_vcp_msc/src/msc_diskio.c | Usb mass storage disk function
msc/src/msc_diskio.c | Usb mass storage disk function
virtual_msc_iap/src/msc_diskio.c | Usb mass storage disk function
flash_fat16.h | Fat16 file system header file
flash_fat16.c | Fat16 file system
FreeRTOSConfig.h |
include_port.c | Include_port program
random.h | At32f413 random header file
random.c | Set of firmware functions to random function
project_l0/inc/fir_filter.h |
project_l1/inc/fir_filter.h |
project_l0/inc/math_helper.h |
project_l1/inc/math_helper.h |
project_l0/src/arm_fir_data.c |
project_l1/src/arm_fir_data.c |
arm_fir_init_f32.c |
fir_coefficient.c |
fir_filter.c |
project_l0/src/math_helper.c |
project_l1/src/math_helper.c |
app_led3_toggle/inc/iap.h | Iap header file
app_led4_toggle/inc/iap.h | Iap header file
bootloader/inc/iap.h | Iap header file
app_led3_toggle/inc/tmr.h | Tmr header file
app_led4_toggle/inc/tmr.h | Tmr header file
bootloader/inc/tmr.h | Tmr header file
app_led3_toggle/inc/usart.h | Usart header file
app_led4_toggle/inc/usart.h | Usart header file
bootloader/inc/usart.h | Usart header file
app_led3_toggle/src/iap.c | Iap program
app_led4_toggle/src/iap.c | Iap program
bootloader/src/iap.c | Iap program
app_led3_toggle/src/tmr.c | Tmr program
app_led4_toggle/src/tmr.c | Tmr program
bootloader/src/tmr.c | Tmr program
app_led3_toggle/src/usart.c | Usart program
app_led4_toggle/src/usart.c | Usart program
bootloader/src/usart.c | Usart program
app_led3_toggle/inc/hid_iap_user.h | Usb config header file
app_led4_toggle/inc/hid_iap_user.h | Usb config header file
bootloader/inc/hid_iap_user.h | Usb config header file
app_led3_toggle/src/hid_iap_user.c | Usb hid iap user file
app_led4_toggle/src/hid_iap_user.c | Usb hid iap user file
bootloader/src/hid_iap_user.c | Usb hid iap user file


AT32F413 Firmwary Library: at32f413.h File Reference

  • AT32F413_Firmware_Library_V2.1.0
  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Typedefs | Enumerations
at32f413.h File Reference

at32f413 header file More...

#include "core_cm4.h"
#include "system_at32f413.h"
#include <stdint.h>
#include "at32f413_def.h"
#include "at32f413_conf.h"

Go to the source code of this file.

Macros

#define | __AT32F413_LIBRARY_VERSION_MAJOR (0x02)
at32f413 standard peripheral library version number More...
#define | __AT32F413_LIBRARY_VERSION_MIDDLE (0x01)
#define | __AT32F413_LIBRARY_VERSION_MINOR (0x00)
#define | __AT32F413_LIBRARY_VERSION_RC (0x00)
#define | __AT32F413_LIBRARY_VERSION
#define | __CM4_REV 0x0001U
configuration of the cortex-m4 processor and core peripherals More...
#define | __MPU_PRESENT 1
#define | __NVIC_PRIO_BITS 4
#define | __Vendor_SysTickConfig 0
#define | __FPU_PRESENT 1U
#define | REG8(addr) *(volatile uint8_t *)(addr)
#define | REG16(addr) *(volatile uint16_t *)(addr)
#define | REG32(addr) *(volatile uint32_t *)(addr)
#define | MAKE_VALUE(reg_offset, bit_num) (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))
#define | PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
#define | PERIPH_REG_BIT(value) (0x1U << (value & 0x1F))
#define | FLASH_BASE ((uint32_t)0x08000000)
#define | SPIM_FLASH_BASE ((uint32_t)0x08400000)
#define | USD_BASE ((uint32_t)0x1FFFF800)
#define | SRAM_BASE ((uint32_t)0x20000000)
#define | PERIPH_BASE ((uint32_t)0x40000000)
#define | XMC_REG_BASE ((uint32_t)0xA0000000)
#define | DEBUG_BASE ((uint32_t)0xE0042000)
#define | APB1PERIPH_BASE (PERIPH_BASE + 0x00000)
#define | APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
#define | AHBPERIPH_BASE (PERIPH_BASE + 0x20000)
#define | TMR2_BASE (APB1PERIPH_BASE + 0x0000)
#define | TMR3_BASE (APB1PERIPH_BASE + 0x0400)
#define | TMR4_BASE (APB1PERIPH_BASE + 0x0800)
#define | TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
#define | RTC_BASE (APB1PERIPH_BASE + 0x2800)
#define | WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
#define | WDT_BASE (APB1PERIPH_BASE + 0x3000)
#define | SPI2_BASE (APB1PERIPH_BASE + 0x3800)
#define | USART2_BASE (APB1PERIPH_BASE + 0x4400)
#define | USART3_BASE (APB1PERIPH_BASE + 0x4800)
#define | UART4_BASE (APB1PERIPH_BASE + 0x4C00)
#define | UART5_BASE (APB1PERIPH_BASE + 0x5000)
#define | I2C1_BASE (APB1PERIPH_BASE + 0x5400)
#define | I2C2_BASE (APB1PERIPH_BASE + 0x5800)
#define | USBFS_BASE (APB1PERIPH_BASE + 0x5C00)
#define | CAN1_BASE (APB1PERIPH_BASE + 0x6400)
#define | CAN2_BASE (APB1PERIPH_BASE + 0x6800)
#define | BPR_BASE (APB1PERIPH_BASE + 0x6C00)
#define | PWC_BASE (APB1PERIPH_BASE + 0x7000)
#define | IOMUX_BASE (APB2PERIPH_BASE + 0x0000)
#define | EXINT_BASE (APB2PERIPH_BASE + 0x0400)
#define | GPIOA_BASE (APB2PERIPH_BASE + 0x0800)
#define | GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)
#define | GPIOC_BASE (APB2PERIPH_BASE + 0x1000)
#define | GPIOD_BASE (APB2PERIPH_BASE + 0x1400)
#define | GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)
#define | ADC1_BASE (APB2PERIPH_BASE + 0x2400)
#define | ADC2_BASE (APB2PERIPH_BASE + 0x2800)
#define | TMR1_BASE (APB2PERIPH_BASE + 0x2C00)
#define | SPI1_BASE (APB2PERIPH_BASE + 0x3000)
#define | TMR8_BASE (APB2PERIPH_BASE + 0x3400)
#define | USART1_BASE (APB2PERIPH_BASE + 0x3800)
#define | TMR9_BASE (APB2PERIPH_BASE + 0x4C00)
#define | TMR10_BASE (APB2PERIPH_BASE + 0x5000)
#define | TMR11_BASE (APB2PERIPH_BASE + 0x5400)
#define | ACC_BASE (APB2PERIPH_BASE + 0x5800)
#define | SDIO1_BASE (APB2PERIPH_BASE + 0x8000)
#define | DMA1_BASE (AHBPERIPH_BASE + 0x0000)
#define | DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)
#define | DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)
#define | DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)
#define | DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)
#define | DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)
#define | DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)
#define | DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)
#define | DMA2_BASE (AHBPERIPH_BASE + 0x0400)
#define | DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)
#define | DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)
#define | DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)
#define | DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)
#define | DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)
#define | DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)
#define | DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)
#define | CRM_BASE (AHBPERIPH_BASE + 0x1000)
#define | FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)
#define | CRC_BASE (AHBPERIPH_BASE + 0x3000)

Typedefs

typedef enum IRQn | IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...
typedef int32_t | INT32
typedef int16_t | INT16
typedef int8_t | INT8
typedef uint32_t | UINT32
typedef uint16_t | UINT16
typedef uint8_t | UINT8
typedef int32_t | s32
typedef int16_t | s16
typedef int8_t | s8
typedef const int32_t | sc32
typedef const int16_t | sc16
typedef const int8_t | sc8
typedef __IO int32_t | vs32
typedef __IO int16_t | vs16
typedef __IO int8_t | vs8
typedef __I int32_t | vsc32
typedef __I int16_t | vsc16
typedef __I int8_t | vsc8
typedef uint32_t | u32
typedef uint16_t | u16
typedef uint8_t | u8
typedef const uint32_t | uc32
typedef const uint16_t | uc16
typedef const uint8_t | uc8
typedef __IO uint32_t | vu32
typedef __IO uint16_t | vu16
typedef __IO uint8_t | vu8
typedef __I uint32_t | vuc32
typedef __I uint16_t | vuc16
typedef __I uint8_t | vuc8

Enumerations

enum IRQn {
Reset_IRQn = -15 , NonMaskableInt_IRQn = -14 , HardFault_IRQn = -13 , MemoryManagement_IRQn = -12 ,
BusFault_IRQn = -11 , UsageFault_IRQn = -10 , SVCall_IRQn = -5 , DebugMonitor_IRQn = -4 ,
PendSV_IRQn = -2 , SysTick_IRQn = -1 , WWDT_IRQn = 0 , PVM_IRQn = 1 ,
TAMPER_IRQn = 2 , RTC_IRQn = 3 , FLASH_IRQn = 4 , CRM_IRQn = 5 ,
EXINT0_IRQn = 6 , EXINT1_IRQn = 7 , EXINT2_IRQn = 8 , EXINT3_IRQn = 9 ,
EXINT4_IRQn = 10 , DMA1_Channel1_IRQn = 11 , DMA1_Channel2_IRQn = 12 , DMA1_Channel3_IRQn = 13 ,
DMA1_Channel4_IRQn = 14 , DMA1_Channel5_IRQn = 15 , DMA1_Channel6_IRQn = 16 , DMA1_Channel7_IRQn = 17 ,
ADC1_2_IRQn = 18 , USBFS_H_CAN1_TX_IRQn = 19 , USBFS_L_CAN1_RX0_IRQn = 20 , CAN1_RX1_IRQn = 21 ,
CAN1_SE_IRQn = 22 , EXINT9_5_IRQn = 23 , TMR1_BRK_TMR9_IRQn = 24 , TMR1_OVF_TMR10_IRQn = 25 ,
TMR1_TRG_HALL_TMR11_IRQn = 26 , TMR1_CH_IRQn = 27 , TMR2_GLOBAL_IRQn = 28 , TMR3_GLOBAL_IRQn = 29 ,
TMR4_GLOBAL_IRQn = 30 , I2C1_EVT_IRQn = 31 , I2C1_ERR_IRQn = 32 , I2C2_EVT_IRQn = 33 ,
I2C2_ERR_IRQn = 34 , SPI1_IRQn = 35 , SPI2_IRQn = 36 , USART1_IRQn = 37 ,
USART2_IRQn = 38 , USART3_IRQn = 39 , EXINT15_10_IRQn = 40 , RTCAlarm_IRQn = 41 ,
USBFSWakeUp_IRQn = 42 , TMR8_BRK_IRQn = 43 , TMR8_OVF_IRQn = 44 , TMR8_TRG_HALL_IRQn = 45 ,
TMR8_CH_IRQn = 46 , SDIO1_IRQn = 49 , TMR5_GLOBAL_IRQn = 50 , UART4_IRQn = 52 ,
UART5_IRQn = 53 , DMA2_Channel1_IRQn = 56 , DMA2_Channel2_IRQn = 57 , DMA2_Channel3_IRQn = 58 ,
DMA2_Channel4_5_IRQn = 59 , CAN2_TX_IRQn = 68 , CAN2_RX0_IRQn = 69 , CAN2_RX1_IRQn = 70 ,
CAN2_SE_IRQn = 71 , ACC_IRQn = 72 , USBFS_MAPH_IRQn = 73 , USBFS_MAPL_IRQn = 74 ,
DMA2_Channel6_7_IRQn = 75
}
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...
enum | flag_status { RESET = 0 , SET = !RESET }
flag status More...
enum | confirm_state { FALSE = 0 , TRUE = !FALSE }
confirm state More...
enum | error_status { ERROR = 0 , SUCCESS = !ERROR }
error status More...

Detailed Description

at32f413 header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413.h.


AT32F413 Firmwary Library: system_at32f413.c File Reference

  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Functions | Variables
system_at32f413.c File Reference

contains all the functions for cmsis cortex-m4 system source file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define VECT_TAB_OFFSET 0x0

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Variables

unsigned int system_core_clock = ((uint32_t)8000000)

Detailed Description

contains all the functions for cmsis cortex-m4 system source file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file system_at32f413.c.


AT32F413 Firmwary Library: system_at32f413.h File Reference

  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Functions | Variables
system_at32f413.h File Reference

cmsis cortex-m4 system header file. More...

Go to the source code of this file.

Macros

#define | HEXT_STABLE_DELAY (5000u)
#define | PLL_STABLE_DELAY (500u)
#define | SystemCoreClock system_core_clock

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Variables

unsigned int system_core_clock

Detailed Description

cmsis cortex-m4 system header file.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file system_at32f413.h.


AT32F413 Firmwary Library: at32f413_acc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f413_acc.h File Reference

at32f413 acc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct acc_type
type define acc register all More...

Macros

#define | ACC_CAL_HICKCAL ((uint16_t)0x0000)
#define | ACC_CAL_HICKTRIM ((uint16_t)0x0002)
#define | ACC_RSLOST_FLAG ((uint16_t)0x0002)
#define | ACC_CALRDY_FLAG ((uint16_t)0x0001)
#define | ACC_CALRDYIEN_INT ((uint16_t)0x0020)
#define | ACC_EIEN_INT ((uint16_t)0x0010)
#define | ACC ((acc_type *) ACC_BASE)

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

at32f413 acc header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_acc.h.


AT32F413 Firmwary Library: at32f413_adc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_adc.h File Reference

at32f413 adc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | adc_base_config_type
adc base config type More...
struct | adc_type
type define adc register all More...

Macros

#define | ADC_CCE_INT ((uint32_t)0x00000020)
#define | ADC_VMOR_INT ((uint32_t)0x00000040)
#define | ADC_PCCE_INT ((uint32_t)0x00000080)
#define | ADC_VMOR_FLAG ((uint8_t)0x01)
#define | ADC_CCE_FLAG ((uint8_t)0x02)
#define | ADC_PCCE_FLAG ((uint8_t)0x04)
#define | ADC_PCCS_FLAG ((uint8_t)0x08)
#define | ADC_OCCS_FLAG ((uint8_t)0x10)
#define | ADC1 ((adc_type *) ADC1_BASE)
#define | ADC2 ((adc_type *) ADC2_BASE)

Enumerations

enum adc_combine_mode_type {
ADC_INDEPENDENT_MODE = 0x00 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE = 0x01 , ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE = 0x02 , ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE = 0x03 ,
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE = 0x04 , ADC_PREEMPT_SMLT_ONLY_MODE = 0x05 , ADC_ORDINARY_SMLT_ONLY_MODE = 0x06 , ADC_ORDINARY_SHORTSHIFT_ONLY_MODE = 0x07 ,
ADC_ORDINARY_LONGSHIFT_ONLY_MODE = 0x08 , ADC_PREEMPT_INTERLTRIG_ONLY_MODE = 0x09
}
adc combine mode type(these options are reserved in adc2) More...
enum | adc_data_align_type { ADC_RIGHT_ALIGNMENT = 0x00 , ADC_LEFT_ALIGNMENT = 0x01 }
adc data align type More...
enum adc_channel_select_type {
ADC_CHANNEL_0 = 0x00 , ADC_CHANNEL_1 = 0x01 , ADC_CHANNEL_2 = 0x02 , ADC_CHANNEL_3 = 0x03 ,
ADC_CHANNEL_4 = 0x04 , ADC_CHANNEL_5 = 0x05 , ADC_CHANNEL_6 = 0x06 , ADC_CHANNEL_7 = 0x07 ,
ADC_CHANNEL_8 = 0x08 , ADC_CHANNEL_9 = 0x09 , ADC_CHANNEL_10 = 0x0A , ADC_CHANNEL_11 = 0x0B ,
ADC_CHANNEL_12 = 0x0C , ADC_CHANNEL_13 = 0x0D , ADC_CHANNEL_14 = 0x0E , ADC_CHANNEL_15 = 0x0F ,
ADC_CHANNEL_16 = 0x10 , ADC_CHANNEL_17 = 0x11
}
adc channel select type More...
enum adc_sampletime_select_type {
ADC_SAMPLETIME_1_5 = 0x00 , ADC_SAMPLETIME_7_5 = 0x01 , ADC_SAMPLETIME_13_5 = 0x02 , ADC_SAMPLETIME_28_5 = 0x03 ,
ADC_SAMPLETIME_41_5 = 0x04 , ADC_SAMPLETIME_55_5 = 0x05 , ADC_SAMPLETIME_71_5 = 0x06 , ADC_SAMPLETIME_239_5 = 0x07
}
adc sampletime select type More...
enum adc_ordinary_trig_select_type {
ADC12_ORDINARY_TRIG_TMR1CH1 = 0x00 , ADC12_ORDINARY_TRIG_TMR1CH2 = 0x01 , ADC12_ORDINARY_TRIG_TMR1CH3 = 0x02 , ADC12_ORDINARY_TRIG_TMR2CH2 = 0x03 ,
ADC12_ORDINARY_TRIG_TMR3TRGOUT = 0x04 , ADC12_ORDINARY_TRIG_TMR4CH4 = 0x05 , ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT = 0x06 , ADC12_ORDINARY_TRIG_SOFTWARE = 0x07 ,
ADC12_ORDINARY_TRIG_TMR1TRGOUT = 0x0D , ADC12_ORDINARY_TRIG_TMR8CH1 = 0x0E , ADC12_ORDINARY_TRIG_TMR8CH2 = 0x0F
}
adc ordinary group trigger event select type More...
enum adc_preempt_trig_select_type {
ADC12_PREEMPT_TRIG_TMR1TRGOUT = 0x00 , ADC12_PREEMPT_TRIG_TMR1CH4 = 0x01 , ADC12_PREEMPT_TRIG_TMR2TRGOUT = 0x02 , ADC12_PREEMPT_TRIG_TMR2CH1 = 0x03 ,
ADC12_PREEMPT_TRIG_TMR3CH4 = 0x04 , ADC12_PREEMPT_TRIG_TMR4TRGOUT = 0x05 , ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 = 0x06 , ADC12_PREEMPT_TRIG_SOFTWARE = 0x07 ,
ADC12_PREEMPT_TRIG_TMR1CH1 = 0x0D , ADC12_PREEMPT_TRIG_TMR8CH1 = 0x0E , ADC12_PREEMPT_TRIG_TMR8TRGOUT = 0x0F
}
adc preempt group trigger event select type More...
enum | adc_preempt_channel_type { ADC_PREEMPT_CHANNEL_1 = 0x00 , ADC_PREEMPT_CHANNEL_2 = 0x01 , ADC_PREEMPT_CHANNEL_3 = 0x02 , ADC_PREEMPT_CHANNEL_4 = 0x03 }
adc preempt channel type More...
enum adc_voltage_monitoring_type {
ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200 , ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200 , ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200 , ADC_VMONITOR_ALL_ORDINARY = 0x00800000 ,
ADC_VMONITOR_ALL_PREEMPT = 0x00400000 , ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000 , ADC_VMONITOR_NONE = 0x00000000
}
adc voltage_monitoring type More...

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

at32f413 adc header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_adc.h.


AT32F413 Firmwary Library: at32f413_bpr.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_bpr.h File Reference

at32f413 bpr header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct bpr_type
type define bpr register all More...

Macros

#define | BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)
#define | BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)
#define | BPR ((bpr_type *) BPR_BASE)

Enumerations

enum bpr_data_type {
BPR_DATA1 = 0x04 , BPR_DATA2 = 0x08 , BPR_DATA3 = 0x0C , BPR_DATA4 = 0x10 ,
BPR_DATA5 = 0x14 , BPR_DATA6 = 0x18 , BPR_DATA7 = 0x1C , BPR_DATA8 = 0x20 ,
BPR_DATA9 = 0x24 , BPR_DATA10 = 0x28 , BPR_DATA11 = 0x40 , BPR_DATA12 = 0x44 ,
BPR_DATA13 = 0x48 , BPR_DATA14 = 0x4C , BPR_DATA15 = 0x50 , BPR_DATA16 = 0x54 ,
BPR_DATA17 = 0x58 , BPR_DATA18 = 0x5C , BPR_DATA19 = 0x60 , BPR_DATA20 = 0x64 ,
BPR_DATA21 = 0x68 , BPR_DATA22 = 0x6C , BPR_DATA23 = 0x70 , BPR_DATA24 = 0x74 ,
BPR_DATA25 = 0x78 , BPR_DATA26 = 0x7C , BPR_DATA27 = 0x80 , BPR_DATA28 = 0x84 ,
BPR_DATA29 = 0x88 , BPR_DATA30 = 0x8C , BPR_DATA31 = 0x90 , BPR_DATA32 = 0x94 ,
BPR_DATA33 = 0x98 , BPR_DATA34 = 0x9C , BPR_DATA35 = 0xA0 , BPR_DATA36 = 0xA4 ,
BPR_DATA37 = 0xA8 , BPR_DATA38 = 0xAC , BPR_DATA39 = 0xB0 , BPR_DATA40 = 0xB4 ,
BPR_DATA41 = 0xB8 , BPR_DATA42 = 0xBC
}
battery powered register data type More...
enum bpr_rtc_output_type {
BPR_RTC_OUTPUT_NONE = 0x000 , BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE = 0x080 , BPR_RTC_OUTPUT_ALARM = 0x100 , BPR_RTC_OUTPUT_SECOND = 0x300 ,
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER = 0x480 , BPR_RTC_OUTPUT_ALARM_TOGGLE = 0x900 , BPR_RTC_OUTPUT_SECOND_TOGGLE = 0xB00
}
bpr rtc output type More...
enum bpr_tamper_pin_active_level_type { BPR_TAMPER_PIN_ACTIVE_HIGH = 0x00 , BPR_TAMPER_PIN_ACTIVE_LOW = 0x01 }
tamper pin active level type More...

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

at32f413 bpr header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_bpr.h.


AT32F413 Firmwary Library: at32f413_can.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_can.h File Reference

at32f413 can header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | can_base_type
can init structure definition More...
struct | can_baudrate_type
can baudrate structure definition More...
struct | can_filter_init_type
can filter init structure definition More...
struct | can_tx_message_type
can tx message structure definition More...
struct | can_rx_message_type
can rx message structure definition More...
struct | can_tx_mailbox_type
can controller area network tx mailbox More...
struct | can_fifo_mailbox_type
can controller area network fifo mailbox More...
struct | can_filter_register_type
can controller area network filter bit register More...
struct | can_type
type define can register all More...

Macros

#define | FZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | DZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | CAN_EAF_FLAG ((uint32_t)0x01)
#define | CAN_EPF_FLAG ((uint32_t)0x02)
#define | CAN_BOF_FLAG ((uint32_t)0x03)
#define | CAN_ETR_FLAG ((uint32_t)0x04)
#define | CAN_EOIF_FLAG ((uint32_t)0x05)
#define | CAN_TM0TCF_FLAG ((uint32_t)0x06)
#define | CAN_TM1TCF_FLAG ((uint32_t)0x07)
#define | CAN_TM2TCF_FLAG ((uint32_t)0x08)
#define | CAN_RF0MN_FLAG ((uint32_t)0x09)
#define | CAN_RF0FF_FLAG ((uint32_t)0x0A)
#define | CAN_RF0OF_FLAG ((uint32_t)0x0B)
#define | CAN_RF1MN_FLAG ((uint32_t)0x0C)
#define | CAN_RF1FF_FLAG ((uint32_t)0x0D)
#define | CAN_RF1OF_FLAG ((uint32_t)0x0E)
#define | CAN_QDZIF_FLAG ((uint32_t)0x0F)
#define | CAN_EDZC_FLAG ((uint32_t)0x10)
#define | CAN_TMEF_FLAG ((uint32_t)0x11)
#define | CAN_TCIEN_INT ((uint32_t)0x00000001)
#define | CAN_RF0MIEN_INT ((uint32_t)0x00000002)
#define | CAN_RF0FIEN_INT ((uint32_t)0x00000004)
#define | CAN_RF0OIEN_INT ((uint32_t)0x00000008)
#define | CAN_RF1MIEN_INT ((uint32_t)0x00000010)
#define | CAN_RF1FIEN_INT ((uint32_t)0x00000020)
#define | CAN_RF1OIEN_INT ((uint32_t)0x00000040)
#define | CAN_EAIEN_INT ((uint32_t)0x00000100)
#define | CAN_EPIEN_INT ((uint32_t)0x00000200)
#define | CAN_BOIEN_INT ((uint32_t)0x00000400)
#define | CAN_ETRIEN_INT ((uint32_t)0x00000800)
#define | CAN_EOIEN_INT ((uint32_t)0x00008000)
#define | CAN_QDZIEN_INT ((uint32_t)0x00010000)
#define | CAN_EDZIEN_INT ((uint32_t)0x00020000)
#define | CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
can flag clear operation macro definition val More...
#define | CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
#define | CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
#define | CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
#define | CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
#define | CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
#define | CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
#define | CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
#define | CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
#define | CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
#define | CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
#define | CAN1 ((can_type *) CAN1_BASE)

Enumerations

enum | can_filter_fifo_type { CAN_FILTER_FIFO0 = 0x00 , CAN_FILTER_FIFO1 = 0x01 }
can filter fifo More...
enum | can_filter_mode_type { CAN_FILTER_MODE_ID_MASK = 0x00 , CAN_FILTER_MODE_ID_LIST = 0x01 }
can filter mode More...
enum | can_filter_bit_width_type { CAN_FILTER_16BIT = 0x00 , CAN_FILTER_32BIT = 0x01 }
can filter bit width select More...
enum | can_mode_type { CAN_MODE_COMMUNICATE = 0x00 , CAN_MODE_LOOPBACK = 0x01 , CAN_MODE_LISTENONLY = 0x02 , CAN_MODE_LISTENONLY_LOOPBACK = 0x03 }
can mode More...
enum | can_operating_mode_type { CAN_OPERATINGMODE_FREEZE = 0x00 , CAN_OPERATINGMODE_DOZE = 0x01 , CAN_OPERATINGMODE_COMMUNICATE = 0x02 }
can operating mode More...
enum | can_rsaw_type { CAN_RSAW_1TQ = 0x00 , CAN_RSAW_2TQ = 0x01 , CAN_RSAW_3TQ = 0x02 , CAN_RSAW_4TQ = 0x03 }
can resynchronization adjust width More...
enum can_bts1_type {
CAN_BTS1_1TQ = 0x00 , CAN_BTS1_2TQ = 0x01 , CAN_BTS1_3TQ = 0x02 , CAN_BTS1_4TQ = 0x03 ,
CAN_BTS1_5TQ = 0x04 , CAN_BTS1_6TQ = 0x05 , CAN_BTS1_7TQ = 0x06 , CAN_BTS1_8TQ = 0x07 ,
CAN_BTS1_9TQ = 0x08 , CAN_BTS1_10TQ = 0x09 , CAN_BTS1_11TQ = 0x0A , CAN_BTS1_12TQ = 0x0B ,
CAN_BTS1_13TQ = 0x0C , CAN_BTS1_14TQ = 0x0D , CAN_BTS1_15TQ = 0x0E , CAN_BTS1_16TQ = 0x0F
}
can bit time segment 1 More...
enum can_bts2_type {
CAN_BTS2_1TQ = 0x00 , CAN_BTS2_2TQ = 0x01 , CAN_BTS2_3TQ = 0x02 , CAN_BTS2_4TQ = 0x03 ,
CAN_BTS2_5TQ = 0x04 , CAN_BTS2_6TQ = 0x05 , CAN_BTS2_7TQ = 0x06 , CAN_BTS2_8TQ = 0x07
}
can bit time segment 2 More...
enum | can_identifier_type { CAN_ID_STANDARD = 0x00 , CAN_ID_EXTENDED = 0x01 }
can identifier type More...
enum | can_trans_frame_type { CAN_TFT_DATA = 0x00 , CAN_TFT_REMOTE = 0x01 }
can transmission frame type More...
enum | can_tx_mailbox_num_type { CAN_TX_MAILBOX0 = 0x00 , CAN_TX_MAILBOX1 = 0x01 , CAN_TX_MAILBOX2 = 0x02 }
can tx mailboxes More...
enum | can_rx_fifo_num_type { CAN_RX_FIFO0 = 0x00 , CAN_RX_FIFO1 = 0x01 }
can receive fifo More...
enum | can_transmit_status_type { CAN_TX_STATUS_FAILED = 0x00 , CAN_TX_STATUS_SUCCESSFUL = 0x01 , CAN_TX_STATUS_PENDING = 0x02 , CAN_TX_STATUS_NO_EMPTY = 0x04 }
can transmit status More...
enum | can_enter_doze_status_type { CAN_ENTER_DOZE_FAILED = 0x00 , CAN_ENTER_DOZE_SUCCESSFUL = 0x01 }
can enter doze mode status More...
enum | can_quit_doze_status_type { CAN_QUIT_DOZE_FAILED = 0x00 , CAN_QUIT_DOZE_SUCCESSFUL = 0x01 }
can quit doze mode status More...
enum | can_msg_discarding_rule_type { CAN_DISCARDING_FIRST_RECEIVED = 0x00 , CAN_DISCARDING_LAST_RECEIVED = 0x01 }
can message discarding rule select when overflow More...
enum | can_msg_sending_rule_type { CAN_SENDING_BY_ID = 0x00 , CAN_SENDING_BY_REQUEST = 0x01 }
can multiple message sending sequence rule More...
enum can_error_record_type {
CAN_ERRORRECORD_NOERR = 0x00 , CAN_ERRORRECORD_STUFFERR = 0x01 , CAN_ERRORRECORD_FORMERR = 0x02 , CAN_ERRORRECORD_ACKERR = 0x03 ,
CAN_ERRORRECORD_BITRECESSIVEERR = 0x04 , CAN_ERRORRECORD_BITDOMINANTERR = 0x05 , CAN_ERRORRECORD_CRCERR = 0x06 , CAN_ERRORRECORD_SOFTWARESETERR = 0x07
}
can error type record More...

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

at32f413 can header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_can.h.


AT32F413 Firmwary Library: at32f413_crc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_crc.h File Reference

at32f413 crc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct crc_type
type define crc register all More...

Macros

#define CRC ((crc_type *) CRC_BASE)

Enumerations

enum | crc_reverse_input_type { CRC_REVERSE_INPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_INPUT_BY_BYTE = 0x01 , CRC_REVERSE_INPUT_BY_HALFWORD = 0x02 , CRC_REVERSE_INPUT_BY_WORD = 0x03 }
crc reverse input data More...
enum | crc_reverse_output_type { CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_OUTPUT_DATA = 0x01 }
crc reverse output data More...
enum | crc_poly_size_type { CRC_POLY_SIZE_32B = 0x00 , CRC_POLY_SIZE_16B = 0x01 , CRC_POLY_SIZE_8B = 0x02 , CRC_POLY_SIZE_7B = 0x03 }
crc polynomial size More...

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_data_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...
void | crc_poly_value_set (uint32_t value)
config crc polynomial value More...
uint32_t | crc_poly_value_get (void)
return crc polynomial value More...
void | crc_poly_size_set (crc_poly_size_type size)
config crc polynomial data size More...
crc_poly_size_type | crc_poly_size_get (void)
return crc polynomial data size More...

Detailed Description

at32f413 crc header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crc.h.


AT32F413 Firmwary Library: at32f413_crm.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_crm.h File Reference

at32f413 crm header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | crm_clocks_freq_type
crm clocks freqency structure More...
struct | crm_type
type define crm register all More...

Macros

#define | CRM_REG(value) PERIPH_REG(CRM_BASE, value)
#define | CRM_REG_BIT(value) PERIPH_REG_BIT(value)
#define | CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
#define | CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
#define | CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
#define | CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)
#define | CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)
#define | CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)
#define | CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)
#define | CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)
#define | CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)
#define | CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)
#define | CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)
#define | CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)
#define | CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)
#define | CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)
#define | CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)
#define | CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)
#define | CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)
#define | CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)
#define | CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
#define | CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
#define | CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
#define | CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
#define | CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
#define | CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)
#define | CRM ((crm_type *) CRM_BASE)

Enumerations

enum crm_periph_clock_type {
CRM_DMA1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 0 & 0x1F)) , CRM_DMA2_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 1 & 0x1F)) , CRM_CRC_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 6 & 0x1F)) , CRM_SDIO1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 10 & 0x1F)) ,
CRM_IOMUX_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 0 & 0x1F)) , CRM_GPIOA_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 3 & 0x1F)) , CRM_GPIOC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 4 & 0x1F)) ,
CRM_GPIOD_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 9 & 0x1F)) , CRM_ADC2_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 10 & 0x1F)) ,
CRM_TMR1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 13 & 0x1F)) , CRM_USART1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 14 & 0x1F)) ,
CRM_TMR9_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 21 & 0x1F)) , CRM_ACC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 22 & 0x1F)) ,
CRM_TMR2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 2 & 0x1F)) , CRM_TMR5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 3 & 0x1F)) ,
CRM_WWDT_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 17 & 0x1F)) , CRM_USART3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 18 & 0x1F)) ,
CRM_UART4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 21 & 0x1F)) , CRM_I2C2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 22 & 0x1F)) ,
CRM_USB_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 27 & 0x1F)) , CRM_PWC_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 28 & 0x1F)) ,
CRM_CAN2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 31 & 0x1F))
}
crm periph clock More...
enum crm_periph_reset_type {
CRM_IOMUX_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 0 & 0x1F)) , CRM_EXINT_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 1 & 0x1F)) , CRM_GPIOA_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 3 & 0x1F)) ,
CRM_GPIOC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 4 & 0x1F)) , CRM_GPIOD_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 9 & 0x1F)) ,
CRM_ADC2_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 10 & 0x1F)) , CRM_TMR1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 13 & 0x1F)) ,
CRM_USART1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 14 & 0x1F)) , CRM_TMR9_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 21 & 0x1F)) ,
CRM_ACC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 22 & 0x1F)) , CRM_TMR2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 2 & 0x1F)) ,
CRM_TMR5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 3 & 0x1F)) , CRM_WWDT_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 17 & 0x1F)) ,
CRM_USART3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 18 & 0x1F)) , CRM_UART4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 21 & 0x1F)) ,
CRM_I2C2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 22 & 0x1F)) , CRM_USB_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 27 & 0x1F)) ,
CRM_PWC_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 28 & 0x1F)) , CRM_CAN2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 31 & 0x1F))
}
crm periph reset More...
enum | crm_periph_clock_sleepmd_type { CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 2 & 0x1F)) , CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 4 & 0x1F)) }
crm periph clock in sleep mode More...
enum crm_pll_mult_type {
CRM_PLL_MULT_2 = 0 , CRM_PLL_MULT_3 = 1 , CRM_PLL_MULT_4 = 2 , CRM_PLL_MULT_5 = 3 ,
CRM_PLL_MULT_6 = 4 , CRM_PLL_MULT_7 = 5 , CRM_PLL_MULT_8 = 6 , CRM_PLL_MULT_9 = 7 ,
CRM_PLL_MULT_10 = 8 , CRM_PLL_MULT_11 = 9 , CRM_PLL_MULT_12 = 10 , CRM_PLL_MULT_13 = 11 ,
CRM_PLL_MULT_14 = 12 , CRM_PLL_MULT_15 = 13 , CRM_PLL_MULT_16 = 15 , CRM_PLL_MULT_17 = 16 ,
CRM_PLL_MULT_18 = 17 , CRM_PLL_MULT_19 = 18 , CRM_PLL_MULT_20 = 19 , CRM_PLL_MULT_21 = 20 ,
CRM_PLL_MULT_22 = 21 , CRM_PLL_MULT_23 = 22 , CRM_PLL_MULT_24 = 23 , CRM_PLL_MULT_25 = 24 ,
CRM_PLL_MULT_26 = 25 , CRM_PLL_MULT_27 = 26 , CRM_PLL_MULT_28 = 27 , CRM_PLL_MULT_29 = 28 ,
CRM_PLL_MULT_30 = 29 , CRM_PLL_MULT_31 = 30 , CRM_PLL_MULT_32 = 31 , CRM_PLL_MULT_33 = 32 ,
CRM_PLL_MULT_34 = 33 , CRM_PLL_MULT_35 = 34 , CRM_PLL_MULT_36 = 35 , CRM_PLL_MULT_37 = 36 ,
CRM_PLL_MULT_38 = 37 , CRM_PLL_MULT_39 = 38 , CRM_PLL_MULT_40 = 39 , CRM_PLL_MULT_41 = 40 ,
CRM_PLL_MULT_42 = 41 , CRM_PLL_MULT_43 = 42 , CRM_PLL_MULT_44 = 43 , CRM_PLL_MULT_45 = 44 ,
CRM_PLL_MULT_46 = 45 , CRM_PLL_MULT_47 = 46 , CRM_PLL_MULT_48 = 47 , CRM_PLL_MULT_49 = 48 ,
CRM_PLL_MULT_50 = 49 , CRM_PLL_MULT_51 = 50 , CRM_PLL_MULT_52 = 51 , CRM_PLL_MULT_53 = 52 ,
CRM_PLL_MULT_54 = 53 , CRM_PLL_MULT_55 = 54 , CRM_PLL_MULT_56 = 55 , CRM_PLL_MULT_57 = 56 ,
CRM_PLL_MULT_58 = 57 , CRM_PLL_MULT_59 = 58 , CRM_PLL_MULT_60 = 59 , CRM_PLL_MULT_61 = 60 ,
CRM_PLL_MULT_62 = 61 , CRM_PLL_MULT_63 = 62 , CRM_PLL_MULT_64 = 63
}
crm pll mult_x More...
enum | crm_pll_clock_source_type { CRM_PLL_SOURCE_HICK = 0x00 , CRM_PLL_SOURCE_HEXT = 0x01 , CRM_PLL_SOURCE_HEXT_DIV = 0x02 }
crm pll clock source More...
enum | crm_pll_output_range_type { CRM_PLL_OUTPUT_RANGE_LE72MHZ = 0x00 , CRM_PLL_OUTPUT_RANGE_GT72MHZ = 0x01 }
crm pll clock output range More...
enum crm_clock_source_type {
CRM_CLOCK_SOURCE_HICK = 0x00 , CRM_CLOCK_SOURCE_HEXT = 0x01 , CRM_CLOCK_SOURCE_PLL = 0x02 , CRM_CLOCK_SOURCE_LEXT = 0x03 ,
CRM_CLOCK_SOURCE_LICK = 0x04
}
crm clock source More...
enum crm_ahb_div_type {
CRM_AHB_DIV_1 = 0x00 , CRM_AHB_DIV_2 = 0x08 , CRM_AHB_DIV_4 = 0x09 , CRM_AHB_DIV_8 = 0x0A ,
CRM_AHB_DIV_16 = 0x0B , CRM_AHB_DIV_64 = 0x0C , CRM_AHB_DIV_128 = 0x0D , CRM_AHB_DIV_256 = 0x0E ,
CRM_AHB_DIV_512 = 0x0F
}
crm ahb division More...
enum crm_apb1_div_type {
CRM_APB1_DIV_1 = 0x00 , CRM_APB1_DIV_2 = 0x04 , CRM_APB1_DIV_4 = 0x05 , CRM_APB1_DIV_8 = 0x06 ,
CRM_APB1_DIV_16 = 0x07
}
crm apb1 division More...
enum crm_apb2_div_type {
CRM_APB2_DIV_1 = 0x00 , CRM_APB2_DIV_2 = 0x04 , CRM_APB2_DIV_4 = 0x05 , CRM_APB2_DIV_8 = 0x06 ,
CRM_APB2_DIV_16 = 0x07
}
crm apb2 division More...
enum crm_adc_div_type {
CRM_ADC_DIV_2 = 0x00 , CRM_ADC_DIV_4 = 0x01 , CRM_ADC_DIV_6 = 0x02 , CRM_ADC_DIV_8 = 0x03 ,
CRM_ADC_DIV_12 = 0x05 , CRM_ADC_DIV_16 = 0x07
}
crm adc division More...
enum crm_usb_div_type {
CRM_USB_DIV_1_5 = 0x00 , CRM_USB_DIV_1 = 0x01 , CRM_USB_DIV_2_5 = 0x02 , CRM_USB_DIV_2 = 0x03 ,
CRM_USB_DIV_3_5 = 0x04 , CRM_USB_DIV_3 = 0x05 , CRM_USB_DIV_4 = 0x06
}
crm usb division More...
enum | crm_rtc_clock_type { CRM_RTC_CLOCK_NOCLK = 0x00 , CRM_RTC_CLOCK_LEXT = 0x01 , CRM_RTC_CLOCK_LICK = 0x02 , CRM_RTC_CLOCK_HEXT_DIV = 0x03 }
crm rtc clock More...
enum | crm_hick_div_6_type { CRM_HICK48_DIV6 = 0x00 , CRM_HICK48_NODIV = 0x01 }
crm hick 48mhz division More...
enum | crm_sclk_type { CRM_SCLK_HICK = 0x00 , CRM_SCLK_HEXT = 0x01 , CRM_SCLK_PLL = 0x02 }
crm sclk select More...
enum crm_clkout_select_type {
CRM_CLKOUT_NOCLK = 0x00 , CRM_CLKOUT_LICK = 0x02 , CRM_CLKOUT_LEXT = 0x03 , CRM_CLKOUT_SCLK = 0x04 ,
CRM_CLKOUT_HICK = 0x05 , CRM_CLKOUT_HEXT = 0x06 , CRM_CLKOUT_PLL_DIV_2 = 0x07 , CRM_CLKOUT_PLL_DIV_4 = 0x0C ,
CRM_CLKOUT_USB = 0x0D , CRM_CLKOUT_ADC = 0x0E
}
crm clkout select More...
enum crm_clkout_div_type {
CRM_CLKOUT_DIV_1 = 0x00 , CRM_CLKOUT_DIV_2 = 0x08 , CRM_CLKOUT_DIV_4 = 0x09 , CRM_CLKOUT_DIV_8 = 0x0A ,
CRM_CLKOUT_DIV_16 = 0x0B , CRM_CLKOUT_DIV_64 = 0x0C , CRM_CLKOUT_DIV_128 = 0x0D , CRM_CLKOUT_DIV_256 = 0x0E ,
CRM_CLKOUT_DIV_512 = 0x0F
}
crm clkout division More...
enum | crm_auto_step_mode_type { CRM_AUTO_STEP_MODE_DISABLE = 0x00 , CRM_AUTO_STEP_MODE_ENABLE = 0x03 }
crm auto step mode More...
enum | crm_usb_int_map_type { CRM_USB_INT19_INT20 = 0x00 , CRM_USB_INT73_INT74 = 0x01 }
crm usbdev interrupt remap More...
enum | crm_usb_clock_source_type { CRM_USB_CLOCK_SOURCE_PLL = 0x00 , CRM_USB_CLOCK_SOURCE_HICK = 0x01 }
crm usb 48 mhz clock source select More...
enum | crm_hick_sclk_frequency_type { CRM_HICK_SCLK_8MHZ = 0x00 , CRM_HICK_SCLK_48MHZ = 0x01 }
crm hick as system clock frequency select More...

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

at32f413 crm header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crm.h.


AT32F413 Firmwary Library: at32f413_debug.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f413_debug.h File Reference

at32f413 debug header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct debug_type
type define debug register all More...

Macros

#define | DEBUG_SLEEP 0x00000001
#define | DEBUG_DEEPSLEEP 0x00000002
#define | DEBUG_STANDBY 0x00000004
#define | DEBUG_WDT_PAUSE 0x00000100
#define | DEBUG_WWDT_PAUSE 0x00000200
#define | DEBUG_TMR1_PAUSE 0x00000400
#define | DEBUG_TMR2_PAUSE 0x00000800
#define | DEBUG_TMR3_PAUSE 0x00001000
#define | DEBUG_TMR4_PAUSE 0x00002000
#define | DEBUG_CAN1_PAUSE 0x00004000
#define | DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000
#define | DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000
#define | DEBUG_TMR8_PAUSE 0x00020000
#define | DEBUG_TMR5_PAUSE 0x00040000
#define | DEBUG_CAN2_PAUSE 0x00200000
#define | DEBUG_TMR9_PAUSE 0x10000000
#define | DEBUG_TMR10_PAUSE 0x20000000
#define | DEBUG_TMR11_PAUSE 0x40000000
#define | DEBUGMCU ((debug_type *) DEBUG_BASE)

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

at32f413 debug header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_debug.h.


AT32F413 Firmwary Library: at32f413_def.h File Reference

  • libraries
  • drivers
  • inc
Macros
at32f413_def.h File Reference

at32f413 macros header file More...

Go to the source code of this file.

Macros

#define UNUSED(x) (void)x /* to avoid gcc/g++ warnings */

Detailed Description

at32f413 macros header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_def.h.

Macro Definition Documentation

◆ UNUSED

#define UNUSED ( x ) (void)x /* to avoid gcc/g++ warnings */

Definition at line 63 of file at32f413_def.h.


AT32F413 Firmwary Library: at32f413_dma.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_dma.h File Reference

at32f413 dma header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | dma_init_type
dma init type More...
struct | dma_type
type define dma register More...
struct | dma_channel_type
type define dma channel register all More...

Macros

#define | DMA_FDT_INT ((uint32_t)0x00000002)
#define | DMA_HDT_INT ((uint32_t)0x00000004)
#define | DMA_DTERR_INT ((uint32_t)0x00000008)
#define | FLEX_CHANNEL1 ((uint8_t)0x01)
#define | FLEX_CHANNEL2 ((uint8_t)0x02)
#define | FLEX_CHANNEL3 ((uint8_t)0x03)
#define | FLEX_CHANNEL4 ((uint8_t)0x04)
#define | FLEX_CHANNEL5 ((uint8_t)0x05)
#define | FLEX_CHANNEL6 ((uint8_t)0x06)
#define | FLEX_CHANNEL7 ((uint8_t)0x07)
#define | DMA1_GL1_FLAG ((uint32_t)0x00000001)
#define | DMA1_FDT1_FLAG ((uint32_t)0x00000002)
#define | DMA1_HDT1_FLAG ((uint32_t)0x00000004)
#define | DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
#define | DMA1_GL2_FLAG ((uint32_t)0x00000010)
#define | DMA1_FDT2_FLAG ((uint32_t)0x00000020)
#define | DMA1_HDT2_FLAG ((uint32_t)0x00000040)
#define | DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
#define | DMA1_GL3_FLAG ((uint32_t)0x00000100)
#define | DMA1_FDT3_FLAG ((uint32_t)0x00000200)
#define | DMA1_HDT3_FLAG ((uint32_t)0x00000400)
#define | DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
#define | DMA1_GL4_FLAG ((uint32_t)0x00001000)
#define | DMA1_FDT4_FLAG ((uint32_t)0x00002000)
#define | DMA1_HDT4_FLAG ((uint32_t)0x00004000)
#define | DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
#define | DMA1_GL5_FLAG ((uint32_t)0x00010000)
#define | DMA1_FDT5_FLAG ((uint32_t)0x00020000)
#define | DMA1_HDT5_FLAG ((uint32_t)0x00040000)
#define | DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
#define | DMA1_GL6_FLAG ((uint32_t)0x00100000)
#define | DMA1_FDT6_FLAG ((uint32_t)0x00200000)
#define | DMA1_HDT6_FLAG ((uint32_t)0x00400000)
#define | DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
#define | DMA1_GL7_FLAG ((uint32_t)0x01000000)
#define | DMA1_FDT7_FLAG ((uint32_t)0x02000000)
#define | DMA1_HDT7_FLAG ((uint32_t)0x04000000)
#define | DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
#define | DMA2_GL1_FLAG ((uint32_t)0x10000001)
#define | DMA2_FDT1_FLAG ((uint32_t)0x10000002)
#define | DMA2_HDT1_FLAG ((uint32_t)0x10000004)
#define | DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
#define | DMA2_GL2_FLAG ((uint32_t)0x10000010)
#define | DMA2_FDT2_FLAG ((uint32_t)0x10000020)
#define | DMA2_HDT2_FLAG ((uint32_t)0x10000040)
#define | DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
#define | DMA2_GL3_FLAG ((uint32_t)0x10000100)
#define | DMA2_FDT3_FLAG ((uint32_t)0x10000200)
#define | DMA2_HDT3_FLAG ((uint32_t)0x10000400)
#define | DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
#define | DMA2_GL4_FLAG ((uint32_t)0x10001000)
#define | DMA2_FDT4_FLAG ((uint32_t)0x10002000)
#define | DMA2_HDT4_FLAG ((uint32_t)0x10004000)
#define | DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
#define | DMA2_GL5_FLAG ((uint32_t)0x10010000)
#define | DMA2_FDT5_FLAG ((uint32_t)0x10020000)
#define | DMA2_HDT5_FLAG ((uint32_t)0x10040000)
#define | DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
#define | DMA2_GL6_FLAG ((uint32_t)0x10100000)
#define | DMA2_FDT6_FLAG ((uint32_t)0x10200000)
#define | DMA2_HDT6_FLAG ((uint32_t)0x10400000)
#define | DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
#define | DMA2_GL7_FLAG ((uint32_t)0x11000000)
#define | DMA2_FDT7_FLAG ((uint32_t)0x12000000)
#define | DMA2_HDT7_FLAG ((uint32_t)0x14000000)
#define | DMA2_DTERR7_FLAG ((uint32_t)0x18000000)
#define | DMA1 ((dma_type *) DMA1_BASE)
#define | DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
#define | DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
#define | DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
#define | DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
#define | DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
#define | DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
#define | DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
#define | DMA2 ((dma_type *) DMA2_BASE)
#define | DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
#define | DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
#define | DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
#define | DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
#define | DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
#define | DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
#define | DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)

Enumerations

enum dma_flexible_request_type {
DMA_FLEXIBLE_ADC1 = 0x01 , DMA_FLEXIBLE_SPI1_RX = 0x09 , DMA_FLEXIBLE_SPI1_TX = 0x0A , DMA_FLEXIBLE_SPI2_RX = 0x0B ,
DMA_FLEXIBLE_SPI2_TX = 0x0C , DMA_FLEXIBLE_UART1_RX = 0x19 , DMA_FLEXIBLE_UART1_TX = 0x1A , DMA_FLEXIBLE_UART2_RX = 0x1B ,
DMA_FLEXIBLE_UART2_TX = 0x1C , DMA_FLEXIBLE_UART3_RX = 0x1D , DMA_FLEXIBLE_UART3_TX = 0x1E , DMA_FLEXIBLE_UART4_RX = 0x1F ,
DMA_FLEXIBLE_UART4_TX = 0x20 , DMA_FLEXIBLE_UART5_RX = 0x21 , DMA_FLEXIBLE_UART5_TX = 0x22 , DMA_FLEXIBLE_I2C1_RX = 0x29 ,
DMA_FLEXIBLE_I2C1_TX = 0x2A , DMA_FLEXIBLE_I2C2_RX = 0x2B , DMA_FLEXIBLE_I2C2_TX = 0x2C , DMA_FLEXIBLE_SDIO1 = 0x31 ,
DMA_FLEXIBLE_TMR1_TRIG = 0x35 , DMA_FLEXIBLE_TMR1_HALL = 0x36 , DMA_FLEXIBLE_TMR1_OVERFLOW = 0x37 , DMA_FLEXIBLE_TMR1_CH1 = 0x38 ,
DMA_FLEXIBLE_TMR1_CH2 = 0x39 , DMA_FLEXIBLE_TMR1_CH3 = 0x3A , DMA_FLEXIBLE_TMR1_CH4 = 0x3B , DMA_FLEXIBLE_TMR2_TRIG = 0x3D ,
DMA_FLEXIBLE_TMR2_OVERFLOW = 0x3F , DMA_FLEXIBLE_TMR2_CH1 = 0x40 , DMA_FLEXIBLE_TMR2_CH2 = 0x41 , DMA_FLEXIBLE_TMR2_CH3 = 0x42 ,
DMA_FLEXIBLE_TMR2_CH4 = 0x43 , DMA_FLEXIBLE_TMR3_TRIG = 0x45 , DMA_FLEXIBLE_TMR3_OVERFLOW = 0x47 , DMA_FLEXIBLE_TMR3_CH1 = 0x48 ,
DMA_FLEXIBLE_TMR3_CH2 = 0x49 , DMA_FLEXIBLE_TMR3_CH3 = 0x4A , DMA_FLEXIBLE_TMR3_CH4 = 0x4B , DMA_FLEXIBLE_TMR4_TRIG = 0x4D ,
DMA_FLEXIBLE_TMR4_OVERFLOW = 0x4F , DMA_FLEXIBLE_TMR4_CH1 = 0x50 , DMA_FLEXIBLE_TMR4_CH2 = 0x51 , DMA_FLEXIBLE_TMR4_CH3 = 0x52 ,
DMA_FLEXIBLE_TMR4_CH4 = 0x53 , DMA_FLEXIBLE_TMR5_TRIG = 0x55 , DMA_FLEXIBLE_TMR5_OVERFLOW = 0x57 , DMA_FLEXIBLE_TMR5_CH1 = 0x58 ,
DMA_FLEXIBLE_TMR5_CH2 = 0x59 , DMA_FLEXIBLE_TMR5_CH3 = 0x5A , DMA_FLEXIBLE_TMR5_CH4 = 0x5B , DMA_FLEXIBLE_TMR8_TRIG = 0x6D ,
DMA_FLEXIBLE_TMR8_HALL = 0x6E , DMA_FLEXIBLE_TMR8_OVERFLOW = 0x6F , DMA_FLEXIBLE_TMR8_CH1 = 0x70 , DMA_FLEXIBLE_TMR8_CH2 = 0x71 ,
DMA_FLEXIBLE_TMR8_CH3 = 0x72 , DMA_FLEXIBLE_TMR8_CH4 = 0x73
}
dma flexible request type More...
enum | dma_dir_type { DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000 , DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010 , DMA_DIR_MEMORY_TO_MEMORY = 0x4000 }
dma direction type More...
enum | dma_peripheral_inc_type { DMA_PERIPHERAL_INC_DISABLE = 0x00 , DMA_PERIPHERAL_INC_ENABLE = 0x01 }
dma peripheral incremented type More...
enum | dma_memory_inc_type { DMA_MEMORY_INC_DISABLE = 0x00 , DMA_MEMORY_INC_ENABLE = 0x01 }
dma memory incremented type More...
enum | dma_peripheral_data_size_type { DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
dma peripheral data size type More...
enum | dma_memory_data_size_type { DMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , DMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
dma memory data size type More...
enum | dma_priority_level_type { DMA_PRIORITY_LOW = 0x00 , DMA_PRIORITY_MEDIUM = 0x01 , DMA_PRIORITY_HIGH = 0x02 , DMA_PRIORITY_VERY_HIGH = 0x03 }
dma priority level type More...

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...

Detailed Description

at32f413 dma header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_dma.h.


AT32F413 Firmwary Library: at32f413_exint.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_exint.h File Reference

at32f413 exint header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | exint_init_type
exint init type More...
struct | exint_type
type define exint register all More...

Macros

#define | EXINT_LINE_NONE ((uint32_t)0x000000)
#define | EXINT_LINE_0 ((uint32_t)0x000001)
#define | EXINT_LINE_1 ((uint32_t)0x000002)
#define | EXINT_LINE_2 ((uint32_t)0x000004)
#define | EXINT_LINE_3 ((uint32_t)0x000008)
#define | EXINT_LINE_4 ((uint32_t)0x000010)
#define | EXINT_LINE_5 ((uint32_t)0x000020)
#define | EXINT_LINE_6 ((uint32_t)0x000040)
#define | EXINT_LINE_7 ((uint32_t)0x000080)
#define | EXINT_LINE_8 ((uint32_t)0x000100)
#define | EXINT_LINE_9 ((uint32_t)0x000200)
#define | EXINT_LINE_10 ((uint32_t)0x000400)
#define | EXINT_LINE_11 ((uint32_t)0x000800)
#define | EXINT_LINE_12 ((uint32_t)0x001000)
#define | EXINT_LINE_13 ((uint32_t)0x002000)
#define | EXINT_LINE_14 ((uint32_t)0x004000)
#define | EXINT_LINE_15 ((uint32_t)0x008000)
#define | EXINT_LINE_16 ((uint32_t)0x010000)
#define | EXINT_LINE_17 ((uint32_t)0x020000)
#define | EXINT_LINE_18 ((uint32_t)0x040000)
#define | EXINT ((exint_type *) EXINT_BASE)

Enumerations

enum | exint_line_mode_type { EXINT_LINE_INTERRUPUT = 0x00 , EXINT_LINE_EVENT = 0x01 }
exint line mode type More...
enum | exint_polarity_config_type { EXINT_TRIGGER_RISING_EDGE = 0x00 , EXINT_TRIGGER_FALLING_EDGE = 0x01 , EXINT_TRIGGER_BOTH_EDGE = 0x02 }
exint polarity configuration type More...

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

at32f413 exint header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_exint.h.


AT32F413 Firmwary Library: at32f413_flash.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_flash.h File Reference

at32f413 flash header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | flash_type
type define flash register all More...
struct | usd_type
user system data More...

Macros

#define | FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
#define | FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
#define | FAP_RELIEVE_KEY ((uint16_t)0x00A5)
#define | SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)
#define | FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)
#define | FLASH_OBF_FLAG ((uint32_t)0x00000001)
#define | FLASH_ODF_FLAG ((uint32_t)0x00000020)
#define | FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)
#define | FLASH_EPPERR_FLAG ((uint32_t)0x00000010)
#define | FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)
#define | FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)
#define | FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)
#define | FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)
#define | FLASH_USDERR_FLAG ((uint32_t)0x40000001)
#define | FLASH_ERR_INT ((uint32_t)0x00000001)
#define | FLASH_ODF_INT ((uint32_t)0x00000002)
#define | FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)
#define | FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)
#define | FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)
#define | FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)
#define | FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)
#define | USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
#define | USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
#define | USD_DEPSLP_NO_RST ((uint16_t)0x0002)
#define | USD_DEPSLP_RST ((uint16_t)0x0000)
#define | USD_STDBY_NO_RST ((uint16_t)0x0004)
#define | USD_STDBY_RST ((uint16_t)0x0000)
#define | ERASE_TIMEOUT ((uint32_t)0x40000000)
#define | PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | OPERATION_TIMEOUT ((uint32_t)0x10000000)
#define | FLASH ((flash_type *) FLASH_REG_BASE)
#define | USD ((usd_type *) USD_BASE)

Enumerations

enum flash_status_type {
FLASH_OPERATE_BUSY = 0x00 , FLASH_PROGRAM_ERROR = 0x01 , FLASH_EPP_ERROR = 0x02 , FLASH_OPERATE_DONE = 0x03 ,
FLASH_OPERATE_TIMEOUT = 0x04
}
flash status type More...
enum flash_spim_model_type { FLASH_SPIM_MODEL1 = 0x01 , FLASH_SPIM_MODEL2 = 0x02 }
flash spim model type More...

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
void | flash_spim_dummy_read (void)
operate the flash spim dummy read. More...
flash_status_type | flash_spim_mass_program (uint32_t address, uint8_t *buf, uint32_t cnt)
mass program for flash spim. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datastart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

at32f413 flash header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_flash.h.


AT32F413 Firmwary Library: at32f413_gpio.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_gpio.h File Reference

at32f413 gpio header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | gpio_init_type
gpio init type More...
struct | gpio_type
type define gpio register all More...
struct | iomux_type
type define iomux register all More...

Macros

#define | GPIO_PINS_0 0x0001
#define | GPIO_PINS_1 0x0002
#define | GPIO_PINS_2 0x0004
#define | GPIO_PINS_3 0x0008
#define | GPIO_PINS_4 0x0010
#define | GPIO_PINS_5 0x0020
#define | GPIO_PINS_6 0x0040
#define | GPIO_PINS_7 0x0080
#define | GPIO_PINS_8 0x0100
#define | GPIO_PINS_9 0x0200
#define | GPIO_PINS_10 0x0400
#define | GPIO_PINS_11 0x0800
#define | GPIO_PINS_12 0x1000
#define | GPIO_PINS_13 0x2000
#define | GPIO_PINS_14 0x4000
#define | GPIO_PINS_15 0x8000
#define | GPIO_PINS_ALL 0xFFFF
#define | IOMUX_MAKE_VALUE(reg_offset, bit_addr, bit_num, bit_val) (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))
#define | SPI1_MUX_01 SPI1_GMUX_0001
#define | I2C1_MUX I2C1_GMUX_0001
#define | USART1_MUX USART1_GMUX_0001
#define | USART3_MUX_01 USART3_GMUX_0001
#define | TMR1_MUX_01 TMR1_GMUX_0001
#define | TMR2_MUX_01 TMR2_GMUX_001
#define | TMR2_MUX_10 TMR2_GMUX_010
#define | TMR2_MUX_11 TMR2_GMUX_011
#define | TMR3_MUX_10 TMR3_GMUX_0010
#define | TMR3_MUX_11 TMR3_GMUX_0011
#define | CAN_MUX_10 CAN1_GMUX_0010
#define | PD01_MUX PD01_GMUX
#define | TMR5CH4_MUX TMR5CH4_GMUX
#define | ADC1_ETP_MUX ADC1_ETP_GMUX
#define | ADC1_ETO_MUX ADC1_ETO_GMUX
#define | ADC2_ETP_MUX ADC2_ETP_GMUX
#define | ADC2_ETO_MUX ADC2_ETO_GMUX
#define | SWJTAG_CONF_001 SWJTAG_GMUX_001
#define | SWJTAG_CONF_010 SWJTAG_GMUX_010
#define | SWJTAG_CONF_100 SWJTAG_GMUX_100
#define | EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000
#define | TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)
#define | TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)
#define | TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)
#define | TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)
#define | TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)
#define | TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)
#define | TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)
#define | TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)
#define | TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)
#define | TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)
#define | TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)
#define | TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)
#define | I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)
#define | I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)
#define | I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)
#define | SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)
#define | CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)
#define | CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)
#define | SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)
#define | SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)
#define | SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)
#define | SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)
#define | USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)
#define | USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)
#define | UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)
#define | EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)
#define | EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)
#define | ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)
#define | ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)
#define | ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)
#define | ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)
#define | SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)
#define | SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)
#define | SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)
#define | PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)
#define | GPIOA ((gpio_type *) GPIOA_BASE)
#define | GPIOB ((gpio_type *) GPIOB_BASE)
#define | GPIOC ((gpio_type *) GPIOC_BASE)
#define | GPIOD ((gpio_type *) GPIOD_BASE)
#define | GPIOF ((gpio_type *) GPIOF_BASE)
#define | IOMUX ((iomux_type *) IOMUX_BASE)

Enumerations

enum | gpio_mode_type { GPIO_MODE_INPUT = 0x00 , GPIO_MODE_OUTPUT = 0x10 , GPIO_MODE_MUX = 0x08 , GPIO_MODE_ANALOG = 0x03 }
gpio mode select More...
enum | gpio_drive_type { GPIO_DRIVE_STRENGTH_STRONGER = 0x01 , GPIO_DRIVE_STRENGTH_MODERATE = 0x02 , GPIO_DRIVE_STRENGTH_MAXIMUM = 0x03 }
gpio output drive strength select More...
enum | gpio_output_type { GPIO_OUTPUT_PUSH_PULL = 0x00 , GPIO_OUTPUT_OPEN_DRAIN = 0x04 }
gpio output type More...
enum | gpio_pull_type { GPIO_PULL_NONE = 0x0004 , GPIO_PULL_UP = 0x0018 , GPIO_PULL_DOWN = 0x0028 }
gpio pull type More...
enum gpio_pins_source_type {
GPIO_PINS_SOURCE0 = 0x00 , GPIO_PINS_SOURCE1 = 0x01 , GPIO_PINS_SOURCE2 = 0x02 , GPIO_PINS_SOURCE3 = 0x03 ,
GPIO_PINS_SOURCE4 = 0x04 , GPIO_PINS_SOURCE5 = 0x05 , GPIO_PINS_SOURCE6 = 0x06 , GPIO_PINS_SOURCE7 = 0x07 ,
GPIO_PINS_SOURCE8 = 0x08 , GPIO_PINS_SOURCE9 = 0x09 , GPIO_PINS_SOURCE10 = 0x0A , GPIO_PINS_SOURCE11 = 0x0B ,
GPIO_PINS_SOURCE12 = 0x0C , GPIO_PINS_SOURCE13 = 0x0D , GPIO_PINS_SOURCE14 = 0x0E , GPIO_PINS_SOURCE15 = 0x0F
}
gpio pins source type More...
enum gpio_port_source_type {
GPIO_PORT_SOURCE_GPIOA = 0x00 , GPIO_PORT_SOURCE_GPIOB = 0x01 , GPIO_PORT_SOURCE_GPIOC = 0x02 , GPIO_PORT_SOURCE_GPIOD = 0x03 ,
GPIO_PORT_SOURCE_GPIOF = 0x05
}
gpio port source type More...

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

at32f413 gpio header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_gpio.h.


AT32F413 Firmwary Library: at32f413_i2c.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_i2c.h File Reference

at32f413 i2c header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct i2c_type
type define i2c register all More...

Macros

#define | I2C_STARTF_FLAG ((uint32_t)0x00000001)
#define | I2C_ADDR7F_FLAG ((uint32_t)0x00000002)
#define | I2C_TDC_FLAG ((uint32_t)0x00000004)
#define | I2C_ADDRHF_FLAG ((uint32_t)0x00000008)
#define | I2C_STOPF_FLAG ((uint32_t)0x00000010)
#define | I2C_RDBF_FLAG ((uint32_t)0x00000040)
#define | I2C_TDBE_FLAG ((uint32_t)0x00000080)
#define | I2C_BUSERR_FLAG ((uint32_t)0x00000100)
#define | I2C_ARLOST_FLAG ((uint32_t)0x00000200)
#define | I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)
#define | I2C_OUF_FLAG ((uint32_t)0x00000800)
#define | I2C_PECERR_FLAG ((uint32_t)0x00001000)
#define | I2C_TMOUT_FLAG ((uint32_t)0x00004000)
#define | I2C_ALERTF_FLAG ((uint32_t)0x00008000)
#define | I2C_TRMODE_FLAG ((uint32_t)0x10010000)
#define | I2C_BUSYF_FLAG ((uint32_t)0x10020000)
#define | I2C_DIRF_FLAG ((uint32_t)0x10040000)
#define | I2C_GCADDRF_FLAG ((uint32_t)0x10100000)
#define | I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)
#define | I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)
#define | I2C_ADDR2_FLAG ((uint32_t)0x10800000)
#define | I2C_DATA_INT ((uint16_t)0x0400)
#define | I2C_EVT_INT ((uint16_t)0x0200)
#define | I2C_ERR_INT ((uint16_t)0x0100)
#define | I2C1 ((i2c_type *) I2C1_BASE)
#define | I2C2 ((i2c_type *) I2C2_BASE)

Enumerations

enum | i2c_master_ack_type { I2C_MASTER_ACK_CURRENT = 0x00 , I2C_MASTER_ACK_NEXT = 0x01 }
i2c master receiving mode acknowledge control More...
enum | i2c_pec_position_type { I2C_PEC_POSITION_CURRENT = 0x00 , I2C_PEC_POSITION_NEXT = 0x01 }
i2c pec position set More...
enum | i2c_smbus_alert_set_type { I2C_SMBUS_ALERT_HIGH = 0x00 , I2C_SMBUS_ALERT_LOW = 0x01 }
i2c smbus alert pin set More...
enum | i2c_smbus_mode_set_type { I2C_SMBUS_MODE_DEVICE = 0x00 , I2C_SMBUS_MODE_HOST = 0x01 }
i2c smbus mode set More...
enum | i2c_fsmode_duty_cycle_type { I2C_FSMODE_DUTY_2_1 = 0x00 , I2C_FSMODE_DUTY_16_9 = 0x01 }
i2c fast mode duty cycle More...
enum | i2c_address_mode_type { I2C_ADDRESS_MODE_7BIT = 0x00 , I2C_ADDRESS_MODE_10BIT = 0x01 }
i2c address mode More...
enum | i2c_direction_type { I2C_DIRECTION_TRANSMIT = 0x00 , I2C_DIRECTION_RECEIVE = 0x01 }
i2c address direction More...

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

at32f413 i2c header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_i2c.h.


AT32F413 Firmwary Library: at32f413_misc.h File Reference

  • libraries
  • drivers
  • inc
Macros | Enumerations | Functions
at32f413_misc.h File Reference

at32f413 misc header file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define | NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
#define | NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

Enumerations

enum nvic_priority_group_type {
NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7) , NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6) , NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5) , NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4) ,
NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
}
nvic interrupt priority group More...
enum | nvic_lowpower_mode_type { NVIC_LP_SLEEPONEXIT = 0x02 , NVIC_LP_SLEEPDEEP = 0x04 , NVIC_LP_SEVONPEND = 0x10 }
nvic low power mode More...
enum | systick_clock_source_type { SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000) , SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004) }
systick clock source More...

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

at32f413 misc header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_misc.h.


AT32F413 Firmwary Library: at32f413_pwc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_pwc.h File Reference

at32f413 pwc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct pwc_type
type define pwc register all More...

Macros

#define | PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
#define | PWC_STANDBY_FLAG ((uint32_t)0x00000002)
#define | PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)
#define | PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
pwc wakeup pin num definition More...
#define | PWC ((pwc_type *) PWC_BASE)

Enumerations

enum pwc_pvm_voltage_type {
PWC_PVM_VOLTAGE_2V3 = 0x01 , PWC_PVM_VOLTAGE_2V4 = 0x02 , PWC_PVM_VOLTAGE_2V5 = 0x03 , PWC_PVM_VOLTAGE_2V6 = 0x04 ,
PWC_PVM_VOLTAGE_2V7 = 0x05 , PWC_PVM_VOLTAGE_2V8 = 0x06 , PWC_PVM_VOLTAGE_2V9 = 0x07
}
pwc pvm voltage type More...
enum | pwc_sleep_enter_type { PWC_SLEEP_ENTER_WFI = 0x00 , PWC_SLEEP_ENTER_WFE = 0x01 }
pwc sleep enter type More...
enum | pwc_deep_sleep_enter_type { PWC_DEEP_SLEEP_ENTER_WFI = 0x00 , PWC_DEEP_SLEEP_ENTER_WFE = 0x01 }
pwc deep sleep enter type More...

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

at32f413 pwc header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_pwc.h.


AT32F413 Firmwary Library: at32f413_rtc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f413_rtc.h File Reference

at32f413 rtc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct rtc_type
type define rtc register all More...

Macros

#define | RTC_TS_INT ((uint16_t)0x0001)
#define | RTC_TA_INT ((uint16_t)0x0002)
#define | RTC_OVF_INT ((uint16_t)0x0004)
#define | RTC_TS_FLAG ((uint16_t)0x0001)
#define | RTC_TA_FLAG ((uint16_t)0x0002)
#define | RTC_OVF_FLAG ((uint16_t)0x0004)
#define | RTC_UPDF_FLAG ((uint16_t)0x0008)
#define | RTC_CFGF_FLAG ((uint16_t)0x0020)
#define | RTC ((rtc_type *) RTC_BASE)

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

at32f413 rtc header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_rtc.h.


AT32F413 Firmwary Library: at32f413_sdio.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_sdio.h File Reference

at32f413 sdio header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | sdio_command_struct_type
sdio command structure More...
struct | sdio_data_struct_type
sdio data structure More...
struct | sdio_type
type define sdio register all More...

Macros

#define | SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_INT ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
#define | SDIO_TXERRU_INT ((uint32_t)0x00000010)
#define | SDIO_RXERRO_INT ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
#define | SDIO_DTCMP_INT ((uint32_t)0x00000100)
#define | SDIO_SBITERR_INT ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
#define | SDIO_DOCMD_INT ((uint32_t)0x00000800)
#define | SDIO_DOTX_INT ((uint32_t)0x00001000)
#define | SDIO_DORX_INT ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_INT ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_INT ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_INT ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_INT ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_INT ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_INT ((uint32_t)0x00080000)
#define | SDIO_TXBUF_INT ((uint32_t)0x00100000)
#define | SDIO_RXBUF_INT ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_INT ((uint32_t)0x00400000)
#define | SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
#define | SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
#define | SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
#define | SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
#define | SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
#define | SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
#define | SDIO_DOTX_FLAG ((uint32_t)0x00001000)
#define | SDIO_DORX_FLAG ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
#define | SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
#define | SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)

Enumerations

enum | sdio_power_state_type { SDIO_POWER_OFF = 0x00 , SDIO_POWER_ON = 0x03 }
sdio power state More...
enum | sdio_edge_phase_type { SDIO_CLOCK_EDGE_RISING = 0x00 , SDIO_CLOCK_EDGE_FALLING = 0x01 }
sdio edge phase More...
enum | sdio_bus_width_type { SDIO_BUS_WIDTH_D1 = 0x00 , SDIO_BUS_WIDTH_D4 = 0x01 , SDIO_BUS_WIDTH_D8 = 0x02 }
sdio bus width More...
enum | sdio_reponse_type { SDIO_RESPONSE_NO = 0x00 , SDIO_RESPONSE_SHORT = 0x01 , SDIO_RESPONSE_LONG = 0x03 }
sdio response type More...
enum | sdio_wait_type { SDIO_WAIT_FOR_NO = 0x00 , SDIO_WAIT_FOR_INT = 0x01 , SDIO_WAIT_FOR_PEND = 0x02 }
sdio wait type More...
enum | sdio_rsp_index_type { SDIO_RSP1_INDEX = 0x00 , SDIO_RSP2_INDEX = 0x01 , SDIO_RSP3_INDEX = 0x02 , SDIO_RSP4_INDEX = 0x03 }
sdio response register index More...
enum sdio_block_size_type {
SDIO_DATA_BLOCK_SIZE_1B = 0x00 , SDIO_DATA_BLOCK_SIZE_2B = 0x01 , SDIO_DATA_BLOCK_SIZE_4B = 0x02 , SDIO_DATA_BLOCK_SIZE_8B = 0x03 ,
SDIO_DATA_BLOCK_SIZE_16B = 0x04 , SDIO_DATA_BLOCK_SIZE_32B = 0x05 , SDIO_DATA_BLOCK_SIZE_64B = 0x06 , SDIO_DATA_BLOCK_SIZE_128B = 0x07 ,
SDIO_DATA_BLOCK_SIZE_256B = 0x08 , SDIO_DATA_BLOCK_SIZE_512B = 0x09 , SDIO_DATA_BLOCK_SIZE_1024B = 0x0A , SDIO_DATA_BLOCK_SIZE_2048B = 0x0B ,
SDIO_DATA_BLOCK_SIZE_4096B = 0x0C , SDIO_DATA_BLOCK_SIZE_8192B = 0x0D , SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
}
sdio data block size More...
enum | sdio_transfer_mode_type { SDIO_DATA_BLOCK_TRANSFER = 0x00 , SDIO_DATA_STREAM_TRANSFER = 0x01 }
sdio data transfer mode More...
enum | sdio_transfer_direction_type { SDIO_DATA_TRANSFER_TO_CARD = 0x00 , SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01 }
sdio data transfer direction More...
enum | sdio_read_wait_mode_type { SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00 , SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01 }
sdio read wait mode More...

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

at32f413 sdio header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_sdio.h.


AT32F413 Firmwary Library: at32f413_spi.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_spi.h File Reference

at32f413 spi header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | spi_init_type
spi init type More...
struct | i2s_init_type
i2s init type More...
struct | spi_type
type define spi register all More...

Macros

#define | SPI_I2S_RDBF_FLAG 0x0001
#define | SPI_I2S_TDBE_FLAG 0x0002
#define | I2S_ACS_FLAG 0x0004
#define | I2S_TUERR_FLAG 0x0008
#define | SPI_CCERR_FLAG 0x0010
#define | SPI_MMERR_FLAG 0x0020
#define | SPI_I2S_ROERR_FLAG 0x0040
#define | SPI_I2S_BF_FLAG 0x0080
#define | SPI_I2S_ERROR_INT 0x0020
#define | SPI_I2S_RDBF_INT 0x0040
#define | SPI_I2S_TDBE_INT 0x0080
#define | SPI1 ((spi_type *) SPI1_BASE)
#define | SPI2 ((spi_type *) SPI2_BASE)

Enumerations

enum | spi_frame_bit_num_type { SPI_FRAME_8BIT = 0x00 , SPI_FRAME_16BIT = 0x01 }
spi frame bit num type More...
enum | spi_master_slave_mode_type { SPI_MODE_SLAVE = 0x00 , SPI_MODE_MASTER = 0x01 }
spi master/slave mode type More...
enum | spi_clock_polarity_type { SPI_CLOCK_POLARITY_LOW = 0x00 , SPI_CLOCK_POLARITY_HIGH = 0x01 }
spi clock polarity (clkpol) type More...
enum | spi_clock_phase_type { SPI_CLOCK_PHASE_1EDGE = 0x00 , SPI_CLOCK_PHASE_2EDGE = 0x01 }
spi clock phase (clkpha) type More...
enum | spi_cs_mode_type { SPI_CS_HARDWARE_MODE = 0x00 , SPI_CS_SOFTWARE_MODE = 0x01 }
spi cs mode type More...
enum spi_mclk_freq_div_type {
SPI_MCLK_DIV_2 = 0x00 , SPI_MCLK_DIV_4 = 0x01 , SPI_MCLK_DIV_8 = 0x02 , SPI_MCLK_DIV_16 = 0x03 ,
SPI_MCLK_DIV_32 = 0x04 , SPI_MCLK_DIV_64 = 0x05 , SPI_MCLK_DIV_128 = 0x06 , SPI_MCLK_DIV_256 = 0x07 ,
SPI_MCLK_DIV_512 = 0x08 , SPI_MCLK_DIV_1024 = 0x09
}
spi master clock frequency division type More...
enum | spi_first_bit_type { SPI_FIRST_BIT_MSB = 0x00 , SPI_FIRST_BIT_LSB = 0x01 }
spi transmit first bit (lsb/msb) type More...
enum | spi_transmission_mode_type { SPI_TRANSMIT_FULL_DUPLEX = 0x00 , SPI_TRANSMIT_SIMPLEX_RX = 0x01 , SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02 , SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03 }
spi transmission mode type More...
enum | spi_crc_direction_type { SPI_CRC_RX = 0x0014 , SPI_CRC_TX = 0x0018 }
spi crc direction type More...
enum | spi_half_duplex_direction_type { SPI_HALF_DUPLEX_DIRECTION_RX = 0x00 , SPI_HALF_DUPLEX_DIRECTION_TX = 0x01 }
spi single line bidirectional direction type More...
enum | spi_software_cs_level_type { SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00 , SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01 }
spi software cs internal level type More...
enum i2s_audio_protocol_type {
I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00 , I2S_AUDIO_PROTOCOL_MSB = 0x01 , I2S_AUDIO_PROTOCOL_LSB = 0x02 , I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03 ,
I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
}
i2s audio protocol type More...
enum i2s_audio_sampling_freq_type {
I2S_AUDIO_FREQUENCY_DEFAULT = 2 , I2S_AUDIO_FREQUENCY_8K = 8000 , I2S_AUDIO_FREQUENCY_11_025K = 11025 , I2S_AUDIO_FREQUENCY_16K = 16000 ,
I2S_AUDIO_FREQUENCY_22_05K = 22050 , I2S_AUDIO_FREQUENCY_32K = 32000 , I2S_AUDIO_FREQUENCY_44_1K = 44100 , I2S_AUDIO_FREQUENCY_48K = 48000 ,
I2S_AUDIO_FREQUENCY_96K = 96000 , I2S_AUDIO_FREQUENCY_192K = 192000
}
i2s audio frequency type More...
enum | i2s_data_channel_format_type { I2S_DATA_16BIT_CHANNEL_16BIT = 0x01 , I2S_DATA_16BIT_CHANNEL_32BIT = 0x02 , I2S_DATA_24BIT_CHANNEL_32BIT = 0x03 , I2S_DATA_32BIT_CHANNEL_32BIT = 0x04 }
i2s data bit num and channel bit num type More...
enum | i2s_operation_mode_type { I2S_MODE_SLAVE_TX = 0x00 , I2S_MODE_SLAVE_RX = 0x01 , I2S_MODE_MASTER_TX = 0x02 , I2S_MODE_MASTER_RX = 0x03 }
i2s operation mode type More...
enum | i2s_clock_polarity_type { I2S_CLOCK_POLARITY_LOW = 0x00 , I2S_CLOCK_POLARITY_HIGH = 0x01 }
i2s clock polarity type More...

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

at32f413 spi header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_spi.h.


AT32F413 Firmwary Library: at32f413_tmr.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_tmr.h File Reference

at32f413 tmr header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | tmr_output_config_type
tmr output config type More...
struct | tmr_input_config_type
tmr input capture config type More...
struct | tmr_brkdt_config_type
tmr brkdt config type More...
struct | tmr_type
type define tmr register all More...

Macros

#define | TMR_OVF_FLAG ((uint32_t)0x000001)
#define | TMR_C1_FLAG ((uint32_t)0x000002)
#define | TMR_C2_FLAG ((uint32_t)0x000004)
#define | TMR_C3_FLAG ((uint32_t)0x000008)
#define | TMR_C4_FLAG ((uint32_t)0x000010)
#define | TMR_HALL_FLAG ((uint32_t)0x000020)
#define | TMR_TRIGGER_FLAG ((uint32_t)0x000040)
#define | TMR_BRK_FLAG ((uint32_t)0x000080)
#define | TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
#define | TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
#define | TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
#define | TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)
#define | TMR_OVF_INT ((uint32_t)0x000001)
#define | TMR_C1_INT ((uint32_t)0x000002)
#define | TMR_C2_INT ((uint32_t)0x000004)
#define | TMR_C3_INT ((uint32_t)0x000008)
#define | TMR_C4_INT ((uint32_t)0x000010)
#define | TMR_HALL_INT ((uint32_t)0x000020)
#define | TMR_TRIGGER_INT ((uint32_t)0x000040)
#define | TMR_BRK_INT ((uint32_t)0x000080)
#define | TMR1 ((tmr_type *) TMR1_BASE)
#define | TMR2 ((tmr_type *) TMR2_BASE)
#define | TMR3 ((tmr_type *) TMR3_BASE)
#define | TMR4 ((tmr_type *) TMR4_BASE)

Enumerations

enum | tmr_clock_division_type { TMR_CLOCK_DIV1 = 0x00 , TMR_CLOCK_DIV2 = 0x01 , TMR_CLOCK_DIV4 = 0x02 }
tmr clock division type More...
enum tmr_count_mode_type {
TMR_COUNT_UP = 0x00 , TMR_COUNT_DOWN = 0x01 , TMR_COUNT_TWO_WAY_1 = 0x02 , TMR_COUNT_TWO_WAY_2 = 0x04 ,
TMR_COUNT_TWO_WAY_3 = 0x06
}
tmr counter mode type More...
enum tmr_primary_select_type {
TMR_PRIMARY_SEL_RESET = 0x00 , TMR_PRIMARY_SEL_ENABLE = 0x01 , TMR_PRIMARY_SEL_OVERFLOW = 0x02 , TMR_PRIMARY_SEL_COMPARE = 0x03 ,
TMR_PRIMARY_SEL_C1ORAW = 0x04 , TMR_PRIMARY_SEL_C2ORAW = 0x05 , TMR_PRIMARY_SEL_C3ORAW = 0x06 , TMR_PRIMARY_SEL_C4ORAW = 0x07
}
tmr primary mode select type More...
enum sub_tmr_input_sel_type {
TMR_SUB_INPUT_SEL_IS0 = 0x00 , TMR_SUB_INPUT_SEL_IS1 = 0x01 , TMR_SUB_INPUT_SEL_IS2 = 0x02 , TMR_SUB_INPUT_SEL_IS3 = 0x03 ,
TMR_SUB_INPUT_SEL_C1INC = 0x04 , TMR_SUB_INPUT_SEL_C1DF1 = 0x05 , TMR_SUB_INPUT_SEL_C2DF2 = 0x06 , TMR_SUB_INPUT_SEL_EXTIN = 0x07
}
tmr subordinate mode input select type More...
enum tmr_sub_mode_select_type {
TMR_SUB_MODE_DIABLE = 0x00 , TMR_SUB_ENCODER_MODE_A = 0x01 , TMR_SUB_ENCODER_MODE_B = 0x02 , TMR_SUB_ENCODER_MODE_C = 0x03 ,
TMR_SUB_RESET_MODE = 0x04 , TMR_SUB_HANG_MODE = 0x05 , TMR_SUB_TRIGGER_MODE = 0x06 , TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
}
tmr subordinate mode select type More...
enum | tmr_encoder_mode_type { TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A , TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B , TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C }
tmr encoder mode type More...
enum tmr_output_control_mode_type {
TMR_OUTPUT_CONTROL_OFF = 0x00 , TMR_OUTPUT_CONTROL_HIGH = 0x01 , TMR_OUTPUT_CONTROL_LOW = 0x02 , TMR_OUTPUT_CONTROL_SWITCH = 0x03 ,
TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04 , TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05 , TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06 , TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
}
tmr output control mode type More...
enum | tmr_force_output_type { TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH , TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW }
tmr force output type More...
enum | tmr_output_polarity_type { TMR_OUTPUT_ACTIVE_HIGH = 0x00 , TMR_OUTPUT_ACTIVE_LOW = 0x01 }
tmr output channel polarity type More...
enum | tmr_input_polarity_type { TMR_INPUT_RISING_EDGE = 0x00 , TMR_INPUT_FALLING_EDGE = 0x01 , TMR_INPUT_BOTH_EDGE = 0x03 }
tmr input channel polarity type More...
enum tmr_channel_select_type {
TMR_SELECT_CHANNEL_1 = 0x00 , TMR_SELECT_CHANNEL_1C = 0x01 , TMR_SELECT_CHANNEL_2 = 0x02 , TMR_SELECT_CHANNEL_2C = 0x03 ,
TMR_SELECT_CHANNEL_3 = 0x04 , TMR_SELECT_CHANNEL_3C = 0x05 , TMR_SELECT_CHANNEL_4 = 0x06
}
tmr channel select type More...
enum | tmr_channel1_input_connected_type { TMR_CHANEL1_CONNECTED_C1IRAW = 0x00 , TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01 }
tmr channel1 input connected type More...
enum | tmr_input_direction_mapped_type { TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01 , TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02 , TMR_CC_CHANNEL_MAPPED_STI = 0x03 }
tmr input channel mapped type channel direction More...
enum | tmr_channel_input_divider_type { TMR_CHANNEL_INPUT_DIV_1 = 0x00 , TMR_CHANNEL_INPUT_DIV_2 = 0x01 , TMR_CHANNEL_INPUT_DIV_4 = 0x02 , TMR_CHANNEL_INPUT_DIV_8 = 0x03 }
tmr input divider type More...
enum | tmr_dma_request_source_type { TMR_DMA_REQUEST_BY_CHANNEL = 0x00 , TMR_DMA_REQUEST_BY_OVERFLOW = 0x01 }
tmr dma request source select type More...
enum tmr_dma_request_type {
TMR_OVERFLOW_DMA_REQUEST = 0x00000100 , TMR_C1_DMA_REQUEST = 0x00000200 , TMR_C2_DMA_REQUEST = 0x00000400 , TMR_C3_DMA_REQUEST = 0x00000800 ,
TMR_C4_DMA_REQUEST = 0x00001000 , TMR_HALL_DMA_REQUEST = 0x00002000 , TMR_TRIGGER_DMA_REQUEST = 0x00004000
}
tmr dma request type More...
enum tmr_event_trigger_type {
TMR_OVERFLOW_SWTRIG = 0x00000001 , TMR_C1_SWTRIG = 0x00000002 , TMR_C2_SWTRIG = 0x00000004 , TMR_C3_SWTRIG = 0x00000008 ,
TMR_C4_SWTRIG = 0x00000010 , TMR_HALL_SWTRIG = 0x00000020 , TMR_TRIGGER_SWTRIG = 0x00000040 , TMR_BRK_SWTRIG = 0x00000080
}
tmr event triggered by software type More...
enum | tmr_polarity_active_type { TMR_POLARITY_ACTIVE_HIGH = 0x00 , TMR_POLARITY_ACTIVE_LOW = 0x01 , TMR_POLARITY_ACTIVE_BOTH = 0x02 }
tmr polarity active type More...
enum | tmr_external_signal_divider_type { TMR_ES_FREQUENCY_DIV_1 = 0x00 , TMR_ES_FREQUENCY_DIV_2 = 0x01 , TMR_ES_FREQUENCY_DIV_4 = 0x02 , TMR_ES_FREQUENCY_DIV_8 = 0x03 }
tmr external signal divider type More...
enum | tmr_external_signal_polarity_type { TMR_ES_POLARITY_NON_INVERTED = 0x00 , TMR_ES_POLARITY_INVERTED = 0x01 }
tmr external signal polarity type More...
enum tmr_dma_transfer_length_type {
TMR_DMA_TRANSFER_1BYTE = 0x00 , TMR_DMA_TRANSFER_2BYTES = 0x01 , TMR_DMA_TRANSFER_3BYTES = 0x02 , TMR_DMA_TRANSFER_4BYTES = 0x03 ,
TMR_DMA_TRANSFER_5BYTES = 0x04 , TMR_DMA_TRANSFER_6BYTES = 0x05 , TMR_DMA_TRANSFER_7BYTES = 0x06 , TMR_DMA_TRANSFER_8BYTES = 0x07 ,
TMR_DMA_TRANSFER_9BYTES = 0x08 , TMR_DMA_TRANSFER_10BYTES = 0x09 , TMR_DMA_TRANSFER_11BYTES = 0x0A , TMR_DMA_TRANSFER_12BYTES = 0x0B ,
TMR_DMA_TRANSFER_13BYTES = 0x0C , TMR_DMA_TRANSFER_14BYTES = 0x0D , TMR_DMA_TRANSFER_15BYTES = 0x0E , TMR_DMA_TRANSFER_16BYTES = 0x0F ,
TMR_DMA_TRANSFER_17BYTES = 0x10 , TMR_DMA_TRANSFER_18BYTES = 0x11
}
tmr dma transfer length type More...
enum tmr_dma_address_type {
TMR_CTRL1_ADDRESS = 0x0000 , TMR_CTRL2_ADDRESS = 0x0001 , TMR_STCTRL_ADDRESS = 0x0002 , TMR_IDEN_ADDRESS = 0x0003 ,
TMR_ISTS_ADDRESS = 0x0004 , TMR_SWEVT_ADDRESS = 0x0005 , TMR_CM1_ADDRESS = 0x0006 , TMR_CM2_ADDRESS = 0x0007 ,
TMR_CCTRL_ADDRESS = 0x0008 , TMR_CVAL_ADDRESS = 0x0009 , TMR_DIV_ADDRESS = 0x000A , TMR_PR_ADDRESS = 0x000B ,
TMR_RPR_ADDRESS = 0x000C , TMR_C1DT_ADDRESS = 0x000D , TMR_C2DT_ADDRESS = 0x000E , TMR_C3DT_ADDRESS = 0x000F ,
TMR_C4DT_ADDRESS = 0x0010 , TMR_BRK_ADDRESS = 0x0011 , TMR_DMACTRL_ADDRESS = 0x0012
}
tmr dma base address type More...
enum | tmr_brk_polarity_type { TMR_BRK_INPUT_ACTIVE_LOW = 0x00 , TMR_BRK_INPUT_ACTIVE_HIGH = 0x01 }
tmr brk polarity type More...
enum | tmr_wp_level_type { TMR_WP_OFF = 0x00 , TMR_WP_LEVEL_3 = 0x01 , TMR_WP_LEVEL_2 = 0x02 , TMR_WP_LEVEL_1 = 0x03 }
tmr write protect level type More...

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time More...

Detailed Description

at32f413 tmr header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_tmr.h.


AT32F413 Firmwary Library: at32f413_usart.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_usart.h File Reference

at32f413 usart header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct usart_type
type define usart register all More...

Macros

#define | USART_PERR_FLAG ((uint32_t)0x00000001)
#define | USART_FERR_FLAG ((uint32_t)0x00000002)
#define | USART_NERR_FLAG ((uint32_t)0x00000004)
#define | USART_ROERR_FLAG ((uint32_t)0x00000008)
#define | USART_IDLEF_FLAG ((uint32_t)0x00000010)
#define | USART_RDBF_FLAG ((uint32_t)0x00000020)
#define | USART_TDC_FLAG ((uint32_t)0x00000040)
#define | USART_TDBE_FLAG ((uint32_t)0x00000080)
#define | USART_BFF_FLAG ((uint32_t)0x00000100)
#define | USART_CTSCF_FLAG ((uint32_t)0x00000200)
#define | USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
#define | USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
#define | USART_TDC_INT MAKE_VALUE(0x0C,0x06)
#define | USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
#define | USART_PERR_INT MAKE_VALUE(0x0C,0x08)
#define | USART_BF_INT MAKE_VALUE(0x10,0x06)
#define | USART_ERR_INT MAKE_VALUE(0x14,0x00)
#define | USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)
#define | USART1 ((usart_type *) USART1_BASE)
#define | USART2 ((usart_type *) USART2_BASE)

Enumerations

enum | usart_parity_selection_type { USART_PARITY_NONE = 0x00 , USART_PARITY_EVEN = 0x01 , USART_PARITY_ODD = 0x02 }
usart parity selection type More...
enum | usart_wakeup_mode_type { USART_WAKEUP_BY_IDLE_FRAME = 0x00 , USART_WAKEUP_BY_MATCHING_ID = 0x01 }
usart wakeup mode type More...
enum | usart_data_bit_num_type { USART_DATA_8BITS = 0x00 , USART_DATA_9BITS = 0x01 }
usart data bit num type More...
enum | usart_break_bit_num_type { USART_BREAK_10BITS = 0x00 , USART_BREAK_11BITS = 0x01 }
usart break frame bit num type More...
enum | usart_clock_phase_type { USART_CLOCK_PHASE_1EDGE = 0x00 , USART_CLOCK_PHASE_2EDGE = 0x01 }
usart phase of the clock type More...
enum | usart_clock_polarity_type { USART_CLOCK_POLARITY_LOW = 0x00 , USART_CLOCK_POLARITY_HIGH = 0x01 }
usart polarity of the clock type More...
enum | usart_lbcp_type { USART_CLOCK_LAST_BIT_NONE = 0x00 , USART_CLOCK_LAST_BIT_OUTPUT = 0x01 }
usart last bit clock pulse type More...
enum | usart_stop_bit_num_type { USART_STOP_1_BIT = 0x00 , USART_STOP_0_5_BIT = 0x01 , USART_STOP_2_BIT = 0x02 , USART_STOP_1_5_BIT = 0x03 }
usart stop bit num type More...
enum | usart_hardware_flow_control_type { USART_HARDWARE_FLOW_NONE = 0x00 , USART_HARDWARE_FLOW_RTS = 0x01 , USART_HARDWARE_FLOW_CTS = 0x02 , USART_HARDWARE_FLOW_RTS_CTS = 0x03 }
usart hardware flow control type More...

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

at32f413 usart header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usart.h.


AT32F413 Firmwary Library: at32f413_usb.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
at32f413_usb.h File Reference

at32f413 usb header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | usb_ept_info
usb endpoint infomation structure definition More...
struct | usbd_type
type define usb register all More...

Macros

#define | USB_LSOF_INT ((uint32_t)0x00000100)
#define | USB_SOF_INT ((uint32_t)0x00000200)
#define | USB_RST_INT ((uint32_t)0x00000400)
#define | USB_SP_INT ((uint32_t)0x00000800)
#define | USB_WK_INT ((uint32_t)0x00001000)
#define | USB_BE_INT ((uint32_t)0x00002000)
#define | USB_UCFOR_INT ((uint32_t)0x00004000)
#define | USB_TC_INT ((uint32_t)0x00008000)
#define | USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)
#define | USB_INOUT_FLAG ((uint32_t)0x00000010)
#define | USB_LSOF_FLAG ((uint32_t)0x00000100)
#define | USB_SOF_FLAG ((uint32_t)0x00000200)
#define | USB_RST_FLAG ((uint32_t)0x00000400)
#define | USB_SP_FLAG ((uint32_t)0x00000800)
#define | USB_WK_FLAG ((uint32_t)0x00001000)
#define | USB_BE_FLAG ((uint32_t)0x00002000)
#define | USB_UCFOR_FLAG ((uint32_t)0x00004000)
#define | USB_TC_FLAG ((uint32_t)0x00008000)
#define | USB_EPTADDR ((uint32_t)0x0000000F)
#define | USB_TXSTS ((uint32_t)0x00000030)
#define | USB_TXDTS ((uint32_t)0x00000040)
#define | USB_TXTC ((uint32_t)0x00000080)
#define | USB_EXF ((uint32_t)0x00000100)
#define | USB_TRANS_TYPE ((uint32_t)0x00000600)
#define | USB_SETUPTC ((uint32_t)0x00000800)
#define | USB_RXSTS ((uint32_t)0x00003000)
#define | USB_RXDTS ((uint32_t)0x00004000)
#define | USB_RXTC ((uint32_t)0x00008000)
#define | USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)
#define | USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)
#define | USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)
#define | USB_TX_DISABLE ((uint32_t)0x00000000)
#define | USB_TX_STALL ((uint32_t)0x00000010)
#define | USB_TX_NAK ((uint32_t)0x00000020)
#define | USB_TX_VALID ((uint32_t)0x00000030)
#define | USB_TXDTS0 ((uint32_t)0x00000010)
#define | USB_TXDTS1 ((uint32_t)0x00000020)
#define | USB_RX_DISABLE ((uint32_t)0x00000000)
#define | USB_RX_STALL ((uint32_t)0x00001000)
#define | USB_RX_NAK ((uint32_t)0x00002000)
#define | USB_RX_VALID ((uint32_t)0x00003000)
#define | USB_RXDTS0 ((uint32_t)0x00001000)
#define | USB_RXDTS1 ((uint32_t)0x00002000)
#define | USB_EPT_CONTROL ((uint32_t)0x00000200)
#define | USB_EPT_BULK ((uint32_t)0x00000000)
#define | USB_EPT_INT ((uint32_t)0x00000600)
#define | USB_EPT_ISO ((uint32_t)0x00000400)
#define | USB_BUFFER_TABLE_ADDRESS 0x0000
#define | USB_PACKET_BUFFER_ADDRESS 0x40006000
#define | USB_PACKET_BUFFER_ADDRESS_EX 0x40007800
#define | USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status More...
#define | USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status More...
#define | GET_TX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)
get usb endpoint tx/rx length address More...
#define | GET_RX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)
#define | USB_GET_TX_LEN(eptn) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)
get usb endpoint tx/rx data length More...
#define | USB_GET_RX_LEN(eptn) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)
#define | USB_DBUF0_GET_LEN(eptn) USB_GET_TX_LEN(eptn)
double buffer mode get endpoint buf0/buf1 data length More...
#define | USB_DBUF1_GET_LEN(eptn) USB_GET_RX_LEN(eptn)
#define | BLK32(reg, len, blks)
set usb length of rx buffer More...
#define | BLK2(reg, len, blks)
#define | USB_SET_RXLEN_REG(reg, len)
#define | USB_SET_TXLEN(eptn, len) (*(GET_TX_LEN_ADDR(eptn)) = (len))
set endpoint tx/rx transfer length More...
#define | USB_SET_RXLEN(eptn, len)
#define | USB_OUT_EPT_DOUBLE_BUF0(eptn, len)
double buffer mode set endpoint rx buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length More...
#define | USB_SET_TX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)
set usb endpoint tx/rx fifo address More...
#define | USB_SET_RX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)
#define | USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address) (USB_SET_TX_ADDRESS(eptn, address))
set double buffer mode usb endpoint buf0/buf1 fifo address More...
#define | USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address) (USB_SET_RX_ADDRESS(eptn, address))
#define | USB_TOGGLE_TXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))
set usb tx/rx toggle More...
#define | USB_TOGGLE_RXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))
#define | USB_CLEAR_TXDTS(eptn)
clear usb tx/rx toggle More...
#define | USB_CLEAR_RXDTS(eptn)
#define | USB_SET_TRANS_TYPE(eptn, type) (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)
set usb endpoint type More...
#define | USB_SET_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))
set/clear usb extend function More...
#define | USB_CLEAR_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))
#define | USB_SET_EPT_ADDRESS(eptn, address) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))
set usb device address More...
#define | USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application More...
#define | USB_CLEAR_TXTC(eptn) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)
clear tx/rx transfer completed flag More...
#define | USB_CLEAR_RXTC(eptn) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)
#define | USB_SET_EPT_DOUBLE_BUFFER(eptn) USB_SET_EXF(eptn)
set/clear endpoint double buffer mode More...
#define | USB_CLEAR_EPT_DOUBLE_BUFFER(eptn) USB_CLEAR_EXF(eptn)
#define | USB ((usbd_type *) USBFS_BASE)

Typedefs

typedef usbd_type usb_reg_type

Enumerations

enum usb_ept_number_type {
USB_EPT0 = 0x00 , USB_EPT1 = 0x01 , USB_EPT2 = 0x02 , USB_EPT3 = 0x03 ,
USB_EPT4 = 0x04 , USB_EPT5 = 0x05 , USB_EPT6 = 0x06 , USB_EPT7 = 0x07
}
usb endpoint number define More...
enum | ept_trans_type { EPT_CONTROL_TYPE = 0x00 , EPT_ISO_TYPE = 0x01 , EPT_BULK_TYPE = 0x02 , EPT_INT_TYPE = 0x03 }
usb endpoint max num define More...
enum | ept_inout_type { EPT_IN = 0x00 , EPT_OUT = 0x01 }
endpoint endpoint direction define More...
enum | data_trans_dir { DATA_TRANS_OUT = 0x00 , DATA_TRANS_IN = 0x01 }
data transfer direction More...
enum | usb_clk48_s { USB_CLK_HICK , USB_CLK_HEXT }
usb clock select More...

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Variables

uint32_t g_usb_packet_address

Detailed Description

at32f413 usb header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usb.h.


AT32F413 Firmwary Library: at32f413_wdt.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_wdt.h File Reference

at32f413 wdt header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct wdt_type
type define wdt register all More...

Macros

#define | WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
#define | WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)
#define | WDT ((wdt_type *) WDT_BASE)

Enumerations

enum wdt_division_type {
WDT_CLK_DIV_4 = 0x00 , WDT_CLK_DIV_8 = 0x01 , WDT_CLK_DIV_16 = 0x02 , WDT_CLK_DIV_32 = 0x03 ,
WDT_CLK_DIV_64 = 0x04 , WDT_CLK_DIV_128 = 0x05 , WDT_CLK_DIV_256 = 0x06
}
wdt division value type More...
enum wdt_cmd_value_type { WDT_CMD_LOCK = 0x0000 , WDT_CMD_UNLOCK = 0x5555 , WDT_CMD_ENABLE = 0xCCCC , WDT_CMD_RELOAD = 0xAAAA }
wdt cmd value type More...

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

at32f413 wdt header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wdt.h.


AT32F413 Firmwary Library: at32f413_wwdt.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_wwdt.h File Reference

at32f413 wwdt header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct wwdt_type
type define wwdt register all More...

Macros

#define | WWDT_EN_BIT ((uint32_t)0x00000080)
#define | WWDT ((wwdt_type *) WWDT_BASE)

Enumerations

enum wwdt_division_type { WWDT_PCLK1_DIV_4096 = 0x00 , WWDT_PCLK1_DIV_8192 = 0x01 , WWDT_PCLK1_DIV_16384 = 0x02 , WWDT_PCLK1_DIV_32768 = 0x03 }
wwdt division type More...

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

at32f413 wwdt header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wwdt.h.


AT32F413 Firmwary Library: at32f413_acc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_acc.c File Reference

contains all the functions for the acc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

contains all the functions for the acc firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_acc.c.


AT32F413 Firmwary Library: at32f413_adc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_adc.c File Reference

contains all the functions for the adc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

contains all the functions for the adc firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_adc.c.


AT32F413 Firmwary Library: at32f413_bpr.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_bpr.c File Reference

contains all the functions for the bpr firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

contains all the functions for the bpr firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_bpr.c.


AT32F413 Firmwary Library: at32f413_can.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_can.c File Reference

contains all the functions for the can firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

contains all the functions for the can firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_can.c.


AT32F413 Firmwary Library: at32f413_crc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_crc.c File Reference

contains all the functions for the crc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_data_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...
void | crc_poly_value_set (uint32_t value)
config crc polynomial value More...
uint32_t | crc_poly_value_get (void)
return crc polynomial value More...
void | crc_poly_size_set (crc_poly_size_type size)
config crc polynomial data size More...
crc_poly_size_type | crc_poly_size_get (void)
return crc polynomial data size More...

Detailed Description

contains all the functions for the crc firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crc.c.


AT32F413 Firmwary Library: at32f413_crm.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_crm.c File Reference

contains all the functions for the crm firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

contains all the functions for the crm firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crm.c.


AT32F413 Firmwary Library: at32f413_debug.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_debug.c File Reference

contains all the functions for the debug firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

contains all the functions for the debug firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_debug.c.


AT32F413 Firmwary Library: at32f413_dma.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_dma.c File Reference

contains all the functions for the dma firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...

Detailed Description

contains all the functions for the dma firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_dma.c.


AT32F413 Firmwary Library: at32f413_exint.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_exint.c File Reference

contains all the functions for the exint firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

contains all the functions for the exint firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_exint.c.


AT32F413 Firmwary Library: at32f413_flash.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_flash.c File Reference

contains all the functions for the flash firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
void | flash_spim_dummy_read (void)
operate the flash spim dummy read. More...
flash_status_type | flash_spim_mass_program (uint32_t address, uint8_t *buf, uint32_t cnt)
mass program for flash spim. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datastart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

contains all the functions for the flash firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_flash.c.


AT32F413 Firmwary Library: at32f413_gpio.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_gpio.c File Reference

contains all the functions for the gpio firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

contains all the functions for the gpio firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_gpio.c.


AT32F413 Firmwary Library: at32f413_i2c.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_i2c.c File Reference

contains all the functions for the i2c firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

contains all the functions for the i2c firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_i2c.c.


AT32F413 Firmwary Library: at32f413_misc.c File Reference

  • libraries
  • drivers
  • src
Macros | Functions
at32f413_misc.c File Reference

contains all the functions for the misc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Macros

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

contains all the functions for the misc firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_misc.c.


AT32F413 Firmwary Library: at32f413_pwc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_pwc.c File Reference

contains all the functions for the pwc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

contains all the functions for the pwc firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_pwc.c.


AT32F413 Firmwary Library: at32f413_rtc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_rtc.c File Reference

contains all the functions for the rtc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

contains all the functions for the rtc firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_rtc.c.


AT32F413 Firmwary Library: at32f413_sdio.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_sdio.c File Reference

contains all the functions for the sdio firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

contains all the functions for the sdio firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_sdio.c.


AT32F413 Firmwary Library: at32f413_spi.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_spi.c File Reference

contains all the functions for the spi firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

contains all the functions for the spi firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_spi.c.


AT32F413 Firmwary Library: at32f413_tmr.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_tmr.c File Reference

contains all the functions for the tmr firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time More...

Detailed Description

contains all the functions for the tmr firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_tmr.c.


AT32F413 Firmwary Library: at32f413_usart.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_usart.c File Reference

contains all the functions for the usart firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

contains all the functions for the usart firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usart.c.


AT32F413 Firmwary Library: at32f413_usb.c File Reference

  • libraries
  • drivers
  • src
Macros | Functions | Variables
at32f413_usb.c File Reference

contains the functions for the usb firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Macros

#define USB_ENDP_DESC_TABLE_OFFSET 0x40
usb packet buffer start address More...

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Variables

uint32_t | g_usb_packet_address = 0x40006000
static uint16_t | g_usb_offset_addr = 0x40

Detailed Description

contains the functions for the usb firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usb.c.


AT32F413 Firmwary Library: at32f413_wdt.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_wdt.c File Reference

contains all the functions for the wdt firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

contains all the functions for the wdt firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wdt.c.


AT32F413 Firmwary Library: at32f413_wwdt.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_wwdt.c File Reference

contains all the functions for the wwdt firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

contains all the functions for the wwdt firmware library

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wwdt.c.


AT32F413 Firmwary Library: main_page.h File Reference

  • main_page
main_page.h File Reference

Go to the source code of this file.


AT32F413 Firmwary Library: i2c_application.c File Reference

  • middlewares
  • i2c_application_library
Macros | Functions
i2c_application.c File Reference

the driver library of the i2c peripheral More...

#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel More...
#define | DMA_GET_HT_FLAG(DMA_CHANNEL)
get the dma half transfer flag through the channel More...
#define | DMA_GET_TERR_FLAG(DMA_CHANNEL)
get the dma transfer error flag through the channel More...
#define | I2C_START 0
i2c transmission status More...
#define | I2C_END 1

Functions

__WEAK void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set More...
void | i2c_dma_config (i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint8_t *pdata, uint16_t size)
dma transfer cofiguration. More...
i2c_status_type | i2c_master_write_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master transmits mode. More...
i2c_status_type | i2c_master_read_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master receive mode. More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_memory_address_send (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t mem_address, int32_t timeout)
send memory address. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_master_tx_isr_int (i2c_handle_type *hi2c)
master transfer mode interrupt procession function More...
void | i2c_master_rx_isr_int (i2c_handle_type *hi2c)
master receive mode interrupt procession function More...
void | i2c_slave_tx_isr_int (i2c_handle_type *hi2c)
slave transfer mode interrupt procession function More...
void | i2c_slave_rx_isr_int (i2c_handle_type *hi2c)
slave receive mode interrupt procession function More...
void | i2c_master_tx_isr_dma (i2c_handle_type *hi2c)
master interrupt processing function in dma mode. More...
void | i2c_slave_tx_rx_isr_dma (i2c_handle_type *hi2c)
slave interrupt processing function in dma mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...

Detailed Description

the driver library of the i2c peripheral

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file i2c_application.c.


AT32F413 Firmwary Library: i2c_application.h File Reference

  • middlewares
  • i2c_application_library
Data Structures | Macros | Enumerations | Functions
i2c_application.h File Reference

i2c application libray header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct i2c_handle_type

Macros

#define | I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
#define | I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
#define | I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

Enumerations

enum i2c_mem_address_width_type { I2C_MEM_ADDR_WIDIH_8 = 0x01 , I2C_MEM_ADDR_WIDIH_16 = 0x02 }
enum i2c_mode_type {
I2C_INT_MA_TX = 0 , I2C_INT_MA_RX , I2C_INT_SLA_TX , I2C_INT_SLA_RX ,
I2C_DMA_MA_TX , I2C_DMA_MA_RX , I2C_DMA_SLA_TX , I2C_DMA_SLA_RX
}
enum i2c_status_type {
I2C_OK = 0 , I2C_ERR_STEP_1 , I2C_ERR_STEP_2 , I2C_ERR_STEP_3 ,
I2C_ERR_STEP_4 , I2C_ERR_STEP_5 , I2C_ERR_STEP_6 , I2C_ERR_STEP_7 ,
I2C_ERR_STEP_8 , I2C_ERR_STEP_9 , I2C_ERR_STEP_10 , I2C_ERR_STEP_11 ,
I2C_ERR_STEP_12 , I2C_ERR_START , I2C_ERR_ADDR10 , I2C_ERR_ADDR ,
I2C_ERR_STOP , I2C_ERR_ACKFAIL , I2C_ERR_TIMEOUT , I2C_ERR_INTERRUPT
}

Functions

void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...

Detailed Description

i2c application libray header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file i2c_application.h.


AT32F413 Firmwary Library: audio_class.c File Reference

  • middlewares
  • usbd_class
  • audio
Functions | Variables
audio_class.c File Reference

usb audio class type More...

#include "usbd_core.h"
#include "audio_class.h"
#include "audio_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...

Variables

usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_class_handler

Detailed Description

usb audio class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_class.c.


AT32F413 Firmwary Library: audio_class.h File Reference

  • middlewares
  • usbd_class
  • audio
Data Structures | Macros | Variables
audio_class.h File Reference

usb audio class file More...

#include "usb_std.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Data Structures

struct usb_audio_type
usb audio control struct More...

Macros

#define | USBD_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUDIO_FEEDBACK_EPT 0x83
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Variables

usbd_class_handler audio_class_handler

Detailed Description

usb audio class file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_class.h.


AT32F413 Firmwary Library: audio_conf.h File Reference

  • middlewares
  • usbd_class
  • audio
Macros
audio/audio_conf.h File Reference

usb audio config More...

Go to the source code of this file.

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 1
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

usb audio config

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio/audio_conf.h.


AT32F413 Firmwary Library: audio_conf.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Macros
audio_hid/audio_conf.h File Reference

usb audio config More...

Go to the source code of this file.

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

usb audio config

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_hid/audio_conf.h.


AT32F413 Firmwary Library: audio_desc.c File Reference

  • middlewares
  • usbd_class
  • audio
Functions | Variables
audio_desc.c File Reference

usb audio device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "audio_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler audio_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb audio device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_desc.c.


AT32F413 Firmwary Library: audio_desc.h File Reference

  • middlewares
  • usbd_class
  • audio
Macros | Variables
audio_desc.h File Reference

usb audio descriptor header file More...

#include "audio_class.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Macros

#define | AUDIO_BCD_NUM 0x0100
#define | USBD_AUDIO_VENDOR_ID 0x2E3C
#define | USBD_AUDIO_PRODUCT_ID 0x5730
#define | USBD_AUDIO_SIZ_STRING_LANGID 4
#define | USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x0D
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUDIO_BINTERVAL_TIME 0x01
#define | USBD_AUDIO_CONFIG_DESC_SIZE
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler audio_desc_handler
device descriptor handler structure More...

Detailed Description

usb audio descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_desc.h.


AT32F413 Firmwary Library: audio_hid_class.c File Reference

  • middlewares
  • usbd_class
  • audio_hid
Functions | Variables
audio_hid_class.c File Reference
#include "usbd_core.h"
#include "audio_hid_class.h"
#include "audio_hid_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
usb_sts_type | class_audio_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | class_hid_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_hid_class_handler


AT32F413 Firmwary Library: audio_hid_class.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Data Structures | Macros | Functions | Variables
audio_hid_class.h File Reference
#include "usb_std.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Data Structures

struct usb_audio_hid_type
usb audio control struct More...

Macros

#define | USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
#define | USBD_AUHID_HID_IN_EPT 0x84
usb custom hid use endpoint define More...
#define | USBD_AUHID_HID_OUT_EPT 0x05
#define | USBD_AUHID_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Functions

usb_sts_type audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler audio_hid_class_handler


AT32F413 Firmwary Library: audio_hid_desc.c File Reference

  • middlewares
  • usbd_class
  • audio_hid
Functions | Variables
audio_hid_desc.c File Reference
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "audio_hid_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc


AT32F413 Firmwary Library: audio_hid_desc.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Macros | Variables
audio_hid_desc.h File Reference
#include "audio_hid_class.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Macros

#define | AUHID_BCD_NUM 0x0100
#define | USBD_AUHID_VENDOR_ID 0x2E3C
#define | USBD_AUHID_PRODUCT_ID 0x5555
#define | USBD_AUHID_SIZ_STRING_LANGID 4
#define | USBD_AUHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x0D
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | HID_INTERFACE_NUMBER 0x03
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUHID_HID_BINTERVAL_TIME 0x01
#define | AUHID_HID_BCD_NUM 0x0110
usb bcd number define More...
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | USBD_AUHID_HID_SIZ_REPORT_DESC 126
#define | USBD_AUHID_HID_DESC_SIZE 32
#define | USBD_AUHID_CONFIG_DESC_SIZE

Variables

uint8_t | g_usbd_audio_hid_report [126]
usb hid report descriptor More...
uint8_t | g_audio_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...


AT32F413 Firmwary Library: cdc_class.c File Reference

  • middlewares
  • usbd_class
  • cdc
Functions | Variables
cdc_class.c File Reference

usb cdc class type More...

#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_struct_init (cdc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_struct_type cdc_struct
usbd_class_handler cdc_class_handler

Detailed Description

usb cdc class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_class.c.


AT32F413 Firmwary Library: cdc_class.h File Reference

  • middlewares
  • usbd_class
  • cdc
Data Structures | Macros | Functions | Variables
cdc_class.h File Reference

usb cdc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct cdc_struct_type
usb cdc class struct More...

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x81
#define | USBD_CDC_BULK_OUT_EPT 0x01
#define | USBD_CDC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_class_handler

Detailed Description

usb cdc class file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_class.h.


AT32F413 Firmwary Library: cdc_desc.c File Reference

  • middlewares
  • usbd_class
  • cdc
Functions | Variables
cdc_desc.c File Reference

usb cdc device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_desc.c.


AT32F413 Firmwary Library: cdc_desc.h File Reference

  • middlewares
  • usbd_class
  • cdc
Macros | Variables
cdc_desc.h File Reference

usb cdc descriptor header file More...

#include "cdc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_PRODUCT_ID 0x5740
#define | USBD_CDC_CONFIG_DESC_SIZE 67
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_desc.h.


AT32F413 Firmwary Library: cdc_keyboard_class.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Macros | Functions | Variables
cdc_keyboard_class.c File Reference

usb cdc and keyboard class type More...

#include "usbd_core.h"
#include "cdc_keyboard_class.h"
#include "cdc_keyboard_desc.h"

Go to the source code of this file.

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | keyboard_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

vcp_keyboard_type vcp_keyboard_struct
static const unsigned char _asciimap [128]
linecoding_type linecoding_vcpkybrd
usbd_class_handler cdc_keyboard_class_handler

Detailed Description

usb cdc and keyboard class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_class.c.


AT32F413 Firmwary Library: cdc_keyboard_class.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Data Structures | Macros | Functions | Variables
cdc_keyboard_class.h File Reference

usb cdc and keyboard class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct vcp_keyboard_type

Macros

#define | USBD_VCPKYBRD_CDC_INT_EPT 0x82
usb use endpoint define More...
#define | USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
#define | USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
#define | USBD_VCPKYBRD_HID_IN_EPT 0x83
#define | USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
usb in and out max packet size define More...
#define | USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
#define | USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Functions

uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

usbd_class_handler cdc_keyboard_class_handler

Detailed Description

usb cdc and keyboard class file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_class.h.


AT32F413 Firmwary Library: cdc_keyboard_desc.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Functions | Variables
cdc_keyboard_desc.c File Reference

usb cdc and keyboard device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_keyboard_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc and keyboard device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_desc.c.


AT32F413 Firmwary Library: cdc_keyboard_desc.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Macros | Variables
cdc_keyboard_desc.h File Reference

usb cdc and keyboard descriptor header file More...

#include "cdc_keyboard_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | VCPKYBRD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_VCPKYBRD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_VCPKYBRD_PRODUCT_ID 0x5750
#define | USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
usb descriptor size define More...
#define | USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
#define | USBD_VCPKYBRD_SIZ_STRING_LANGID 4
#define | USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
#define | USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
#define | USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
#define | USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
#define | VCPKYBRD_HID_BINTERVAL_TIME 0x0A
usb endpoint interval define More...
#define | VCPKYBRD_CDC_INTERFACE 0x00
usb interface define More...
#define | VCPKYBRD_CDC_DATA_INTERFACE 0x01
#define | VCPKYBRD_KEYBOARD_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_vcpkybrd_hid_report [63]
usb hid keyboard report descriptor More...
uint8_t | g_vcpkybrd_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc and keyboard descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_desc.h.


AT32F413 Firmwary Library: cdc_msc_class.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Functions | Variables
cdc_msc_class.c File Reference

usb cdc class type More...

#include "usbd_core.h"
#include "cdc_msc_class.h"
#include "cdc_msc_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static usb_sts_type | cdc_struct_init (cdc_msc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | msc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_msc_struct_type cdc_msc_struct
usbd_class_handler cdc_msc_class_handler

Detailed Description

usb cdc class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_class.c.


AT32F413 Firmwary Library: cdc_msc_class.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Data Structures | Macros | Functions | Variables
cdc_msc_class.h File Reference

usb cdc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type
struct | cdc_msc_struct_type
usb cdc class struct More...

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x83
#define | USBD_CDC_BULK_OUT_EPT 0x02
#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08
#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Variables

usbd_class_handler cdc_msc_class_handler

Detailed Description

usb cdc class file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_class.h.


AT32F413 Firmwary Library: cdc_msc_desc.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Macros | Functions | Variables
cdc_msc_desc.c File Reference

usb cdc device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_msc_desc.h"

Go to the source code of this file.

Macros

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_desc.c.


AT32F413 Firmwary Library: cdc_msc_desc.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Macros | Variables
cdc_msc_desc.h File Reference

usb cdc descriptor header file More...

#include "cdc_msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_MSC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_MSC_PRODUCT_ID 0x5760
#define | USBD_CDC_MSC_CONFIG_DESC_SIZE 106
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | VCPMSC_MSC_INTERFACE 0x00
usb interface define More...
#define | VCPMSC_CDC_INTERFACE 0x01
#define | VCPMSC_CDC_DATA_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_desc.h.


AT32F413 Firmwary Library: msc_bot_scsi.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Functions | Variables
composite_cdc_msc/msc_bot_scsi.c File Reference

usb mass storage bulk-only transport and scsi command More...

#include "cdc_msc_class.h"
#include "msc_diskio.h"

Go to the source code of this file.

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL

Detailed Description

usb mass storage bulk-only transport and scsi command

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_cdc_msc/msc_bot_scsi.c.


AT32F413 Firmwary Library: msc_bot_scsi.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc/msc_bot_scsi.c File Reference

usb mass storage bulk-only transport and scsi command More...

#include "msc_bot_scsi.h"
#include "msc_diskio.h"

Go to the source code of this file.

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL

Detailed Description

usb mass storage bulk-only transport and scsi command

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc/msc_bot_scsi.c.


AT32F413 Firmwary Library: custom_hid_class.c File Reference

  • middlewares
  • usbd_class
  • custom_hid
Functions | Variables
custom_hid_class.c File Reference

usb custom hid class type More...

#include "usbd_core.h"
#include "custom_hid_class.h"
#include "custom_hid_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device class report function More...
usb_sts_type | custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

custom_hid_type custom_hid_struct
usbd_class_handler custom_hid_class_handler

Detailed Description

usb custom hid class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_class.c.


AT32F413 Firmwary Library: custom_hid_class.h File Reference

  • middlewares
  • usbd_class
  • custom_hid
Data Structures | Macros | Functions | Variables
custom_hid_class.h File Reference

usb custom hid header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct custom_hid_type

Macros

#define | USBD_CUSTOM_HID_IN_EPT 0x81
usb custom hid use endpoint define More...
#define | USBD_CUSTOM_HID_OUT_EPT 0x01
#define | USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Functions

usb_sts_type custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler custom_hid_class_handler

Detailed Description

usb custom hid header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_class.h.


AT32F413 Firmwary Library: custom_hid_desc.c File Reference

  • middlewares
  • usbd_class
  • custom_hid
Functions | Variables
custom_hid_desc.c File Reference

usb hid device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "custom_hid_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_desc.c.


AT32F413 Firmwary Library: custom_hid_desc.h File Reference

  • middlewares
  • usbd_class
  • custom_hid
Macros | Variables
custom_hid_desc.h File Reference

usb custom hid descriptor header file More...

#include "custom_hid_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CUSHID_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CUSHID_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CUSHID_PRODUCT_ID 0x5745
#define | USBD_CUSHID_CONFIG_DESC_SIZE 41
usb descriptor size define More...
#define | USBD_CUSHID_SIZ_REPORT_DESC 126
#define | USBD_CUSHID_SIZ_STRING_LANGID 4
#define | USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
#define | USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
#define | USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
#define | CUSHID_BINTERVAL_TIME 0x0A
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_custom_hid_report [126]
usb hid report descriptor More...
uint8_t | g_custom_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...

Detailed Description

usb custom hid descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_desc.h.


AT32F413 Firmwary Library: hid_iap_class.c File Reference

  • middlewares
  • usbd_class
  • hid_iap
Functions | Variables
hid_iap_class.c File Reference

usb hid iap class type More...

#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

iap_info_type iap_info
usbd_class_handler hid_iap_class_handler

Detailed Description

usb hid iap class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_class.c.


AT32F413 Firmwary Library: hid_iap_class.h File Reference

  • middlewares
  • usbd_class
  • hid_iap
Data Structures | Macros | Enumerations | Functions | Variables
hid_iap_class.h File Reference

usb hid iap header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct iap_info_type

Macros

#define | USBD_HIDIAP_IN_EPT 0x81
#define | USBD_HIDIAP_OUT_EPT 0x01
#define | USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
#define | USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
#define | FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
#define | KB_TO_B(kb) ((kb) << 10)
#define | SECTOR_SIZE_1K 0x400
#define | SECTOR_SIZE_2K 0x800
#define | SECTOR_SIZE_4K 0x1000
#define | IAP_CMD_IDLE 0x5AA0
iap command More...
#define | IAP_CMD_START 0x5AA1
#define | IAP_CMD_ADDR 0x5AA2
#define | IAP_CMD_DATA 0x5AA3
#define | IAP_CMD_FINISH 0x5AA4
#define | IAP_CMD_CRC 0x5AA5
#define | IAP_CMD_JMP 0x5AA6
#define | IAP_CMD_GET 0x5AA7
#define | HID_IAP_BUFFER_LEN 1024
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | CONVERT_ENDIAN(dwValue)
#define | IAP_ACK 0xFF00
#define | IAP_NACK 0x00FF

Enumerations

enum iap_result_type { IAP_SUCCESS , IAP_WAIT , IAP_FAILED }
enum iap_machine_state_type {
IAP_STS_IDLE , IAP_STS_START , IAP_STS_ADDR , IAP_STS_DATA ,
IAP_STS_FINISH , IAP_STS_CRC , IAP_STS_JMP_WAIT , IAP_STS_JMP
}

Functions

usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *report, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...

Variables

usbd_class_handler hid_iap_class_handler
iap_info_type iap_info

Detailed Description

usb hid iap header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_class.h.


AT32F413 Firmwary Library: hid_iap_desc.c File Reference

  • middlewares
  • usbd_class
  • hid_iap
Functions | Variables
hid_iap_desc.c File Reference

usb hid device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "hid_iap_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_desc.c.


AT32F413 Firmwary Library: hid_iap_desc.h File Reference

  • middlewares
  • usbd_class
  • hid_iap
Macros | Variables
hid_iap_desc.h File Reference

usb hid descriptor header file More...

#include "hid_iap_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | HIDIAP_BCD_NUM 0x0110
#define | USBD_HIDIAP_VENDOR_ID 0x2E3C
#define | USBD_HIDIAP_PRODUCT_ID 0xAF01
#define | USBD_HIDIAP_CONFIG_DESC_SIZE 41
#define | USBD_HIDIAP_SIZ_REPORT_DESC 32
#define | USBD_HIDIAP_SIZ_STRING_LANGID 4
#define | USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
#define | USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
#define | USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
#define | USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
#define | HIDIAP_BINTERVAL_TIME 0x01
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_hidiap_report [32]
usb hid report descriptor More...
uint8_t | g_hidiap_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...

Detailed Description

usb hid descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_desc.h.


AT32F413 Firmwary Library: keyboard_class.c File Reference

  • middlewares
  • usbd_class
  • keyboard
Macros | Functions | Variables
keyboard_class.c File Reference

usb hid keyboard class type More...

#include "usbd_core.h"
#include "keyboard_class.h"
#include "keyboard_desc.h"

Go to the source code of this file.

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

keyboard_type keyboard_struct
static const unsigned char _asciimap [128]
usbd_class_handler keyboard_class_handler

Detailed Description

usb hid keyboard class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_class.c.


AT32F413 Firmwary Library: keyboard_class.h File Reference

  • middlewares
  • usbd_class
  • keyboard
Data Structures | Macros | Functions | Variables
keyboard_class.h File Reference

usb hid keyboard header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct keyboard_type

Macros

#define | USBD_KEYBOARD_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Functions

usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

usbd_class_handler keyboard_class_handler

Detailed Description

usb hid keyboard header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_class.h.


AT32F413 Firmwary Library: keyboard_desc.c File Reference

  • middlewares
  • usbd_class
  • keyboard
Functions | Variables
keyboard_desc.c File Reference

usb hid keyboard device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "keyboard_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid keyboard device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_desc.c.


AT32F413 Firmwary Library: keyboard_desc.h File Reference

  • middlewares
  • usbd_class
  • keyboard
Macros | Variables
keyboard_desc.h File Reference

usb keyboard descriptor header file More...

#include "keyboard_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | KEYBOARD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_KEYBOARD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_KEYBOARD_PRODUCT_ID 0x6040
#define | USBD_KEYBOARD_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_KEYBOARD_SIZ_REPORT_DESC 63
#define | USBD_KEYBOARD_SIZ_STRING_LANGID 4
#define | USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
#define | USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
#define | USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
#define | USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
#define | KEYBOARD_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_keyboard_report [63]
usb mouse report descriptor More...
uint8_t | g_keyboard_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...

Detailed Description

usb keyboard descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_desc.h.


AT32F413 Firmwary Library: mouse_class.c File Reference

  • middlewares
  • usbd_class
  • mouse
Functions | Variables
mouse_class.c File Reference

usb hid mouse class type More...

#include "usbd_core.h"
#include "mouse_class.h"
#include "mouse_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

mouse_type mouse_struct
usbd_class_handler mouse_class_handler

Detailed Description

usb hid mouse class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_class.c.


AT32F413 Firmwary Library: mouse_class.h File Reference

  • middlewares
  • usbd_class
  • mouse
Data Structures | Macros | Functions | Variables
mouse_class.h File Reference

usb hid mouse header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct mouse_type

Macros

#define | USBD_MOUSE_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | MOVE_STEP 20
usb hid mouse operation More...
#define | BUTTON_RELEASE 0
#define | LEFT_BUTTON 1
#define | RIGHT_BUTTON 2
#define | LEFT_MOVE 3
#define | RIGHT_MOVE 4
#define | UP_MOVE 5
#define | DOWN_MOVE 6

Functions

usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

usbd_class_handler mouse_class_handler

Detailed Description

usb hid mouse header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_class.h.


AT32F413 Firmwary Library: mouse_desc.c File Reference

  • middlewares
  • usbd_class
  • mouse
Functions | Variables
mouse_desc.c File Reference

usb hid mouse device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "mouse_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid mouse device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_desc.c.


AT32F413 Firmwary Library: mouse_desc.h File Reference

  • middlewares
  • usbd_class
  • mouse
Macros | Variables
mouse_desc.h File Reference

usb mouse descriptor header file More...

#include "mouse_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | MOUSE_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_MOUSE_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_MOUSE_PRODUCT_ID 0x5710
#define | USBD_MOUSE_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_MOUSE_SIZ_REPORT_DESC 74
#define | USBD_MOUSE_SIZ_STRING_LANGID 4
#define | USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
#define | USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
#define | USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
#define | USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
#define | MOUSE_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_mouse_report [74]
usb mouse report descriptor More...
uint8_t | g_mouse_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...

Detailed Description

usb mouse descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_desc.h.


AT32F413 Firmwary Library: msc_bot_scsi.h File Reference

  • middlewares
  • usbd_class
  • msc
Data Structures | Macros | Functions
msc_bot_scsi.h File Reference

usb mass storage bulk-only transport and scsi command header file More...

#include "msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type

Macros

#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Detailed Description

usb mass storage bulk-only transport and scsi command header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_bot_scsi.h.


AT32F413 Firmwary Library: msc_class.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc_class.c File Reference

usb msc class type More...

#include "usbd_core.h"
#include "msc_class.h"
#include "msc_desc.h"
#include "msc_bot_scsi.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...

Variables

msc_type msc_struct
usbd_class_handler msc_class_handler

Detailed Description

usb msc class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_class.c.


AT32F413 Firmwary Library: msc_class.h File Reference

  • middlewares
  • usbd_class
  • msc
Macros | Variables
msc_class.h File Reference

usb msc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_IN_MAXPACKET_SIZE 0x40
#define | USBD_OUT_MAXPACKET_SIZE 0x40

Variables

usbd_class_handler msc_class_handler

Detailed Description

usb msc class file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_class.h.


AT32F413 Firmwary Library: msc_desc.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc_desc.c File Reference

usb msc device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "msc_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler msc_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb msc device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_desc.c.


AT32F413 Firmwary Library: msc_desc.h File Reference

  • middlewares
  • usbd_class
  • msc
Macros | Variables
msc_desc.h File Reference

usb msc descriptor header file More...

#include "msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | MSC_BCD_NUM 0x0110
#define | USBD_MSC_VENDOR_ID 0x2E3C
#define | USBD_MSC_PRODUCT_ID 0x5720
#define | USBD_MSC_CONFIG_DESC_SIZE 32
#define | USBD_MSC_SIZ_STRING_LANGID 4
#define | USBD_MSC_SIZ_STRING_SERIAL 0x1A
#define | USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
#define | USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
#define | USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb msc descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_desc.h.


AT32F413 Firmwary Library: printer_class.c File Reference

  • middlewares
  • usbd_class
  • printer
Functions | Variables
printer_class.c File Reference

usb printer class type More...

#include "usbd_core.h"
#include "printer_class.h"
#include "printer_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

static ALIGNED_HEAD uint8_t printer_device_id[24] ALIGNED_TAIL
printer_type printer_struct
usbd_class_handler printer_class_handler

Detailed Description

usb printer class type

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_class.c.


AT32F413 Firmwary Library: printer_class.h File Reference

  • middlewares
  • usbd_class
  • printer
Data Structures | Macros | Enumerations | Functions | Variables
printer_class.h File Reference

usb printer class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct printer_type

Macros

#define | USBD_PRINTER_BULK_IN_EPT 0x81
#define | USBD_PRINTER_BULK_OUT_EPT 0x01
#define | USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
#define | USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
#define | PRINTER_DEVICE_ID_LEN 24

Enumerations

enum printer_req_type { PRINTER_REQ_GET_DEVICE_ID = 0x00 , PRINTER_REQ_GET_PORT_STATUS = 0x01 , PRINTER_REQ_GET_SOFT_RESET = 0x02 }

Functions

uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler printer_class_handler

Detailed Description

usb printer class file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_class.h.


AT32F413 Firmwary Library: printer_desc.c File Reference

  • middlewares
  • usbd_class
  • printer
Functions | Variables
printer_desc.c File Reference

usb printer device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "printer_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] | ALIGNED_TAIL
usb device standard descriptor More...
usbd_desc_handler printer_desc_handler
device descriptor handler structure More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb printer device descriptor

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_desc.c.


AT32F413 Firmwary Library: printer_desc.h File Reference

  • middlewares
  • usbd_class
  • printer
Macros | Variables
printer_desc.h File Reference

usb printer descriptor header file More...

#include "printer_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | PRINTER_BCD_NUM 0x0110
#define | USBD_PRINTER_VENDOR_ID 0x2E3C
#define | USBD_PRINTER_PRODUCT_ID 0x57FF
#define | USBD_PRINTER_CONFIG_DESC_SIZE 32
#define | USBD_PRINTER_SIZ_STRING_LANGID 4
#define | USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
#define | USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
#define | USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
#define | USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
#define | PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
#define | PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
#define | PRINTER_PROTOCOL_1284_4 0x03
#define | PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler printer_desc_handler
device descriptor handler structure More...

Detailed Description

usb printer descriptor header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_desc.h.


AT32F413 Firmwary Library: usb_std.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Data Structures | Macros | Enumerations
usb_std.h File Reference

usb standard header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | linecoding_type
usb cdc class set line coding struct More...
struct | usb_setup_type
format of usb setup data More...
struct | usb_device_desc_type
format of standard device descriptor More...
struct | usb_configuration_desc_type
format of standard configuration descriptor More...
struct | usb_interface_desc_type
format of standard interface descriptor More...
struct | usb_endpoint_desc_type
format of standard endpoint descriptor More...
struct | usb_header_desc_type
format of header More...

Macros

#define | USB_REQ_RECIPIENT_DEVICE 0x00
usb request recipient More...
#define | USB_REQ_RECIPIENT_INTERFACE 0x01
#define | USB_REQ_RECIPIENT_ENDPOINT 0x02
#define | USB_REQ_RECIPIENT_OTHER 0x03
#define | USB_REQ_RECIPIENT_MASK 0x1F
#define | USB_REQ_TYPE_STANDARD 0x00
usb request type More...
#define | USB_REQ_TYPE_CLASS 0x20
#define | USB_REQ_TYPE_VENDOR 0x40
#define | USB_REQ_TYPE_RESERVED 0x60
#define | USB_REQ_DIR_HTD 0x00
usb request data transfer direction More...
#define | USB_REQ_DIR_DTH 0x80
#define | USB_STD_REQ_GET_STATUS 0
usb standard device requests codes More...
#define | USB_STD_REQ_CLEAR_FEATURE 1
#define | USB_STD_REQ_SET_FEATURE 3
#define | USB_STD_REQ_SET_ADDRESS 5
#define | USB_STD_REQ_GET_DESCRIPTOR 6
#define | USB_STD_REQ_SET_DESCRIPTOR 7
#define | USB_STD_REQ_GET_CONFIGURATION 8
#define | USB_STD_REQ_SET_CONFIGURATION 9
#define | USB_STD_REQ_GET_INTERFACE 10
#define | USB_STD_REQ_SET_INTERFACE 11
#define | USB_STD_REQ_SYNCH_FRAME 12
#define | USB_DESCIPTOR_TYPE_DEVICE 1
usb standard device type More...
#define | USB_DESCIPTOR_TYPE_CONFIGURATION 2
#define | USB_DESCIPTOR_TYPE_STRING 3
#define | USB_DESCIPTOR_TYPE_INTERFACE 4
#define | USB_DESCIPTOR_TYPE_ENDPOINT 5
#define | USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
#define | USB_DESCIPTOR_TYPE_OTHER_SPEED 7
#define | USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
#define | USB_LANGID_STRING 0
usb standard string type More...
#define | USB_MFC_STRING 1
#define | USB_PRODUCT_STRING 2
#define | USB_SERIAL_STRING 3
#define | USB_CONFIG_STRING 4
#define | USB_INTERFACE_STRING 5
#define | USB_CONF_REMOTE_WAKEUP 2
usb configuration attributes More...
#define | USB_CONF_SELF_POWERED 1
#define | USB_FEATURE_EPT_HALT 0
usb standard feature selectors More...
#define | USB_FEATURE_REMOTE_WAKEUP 1
#define | USB_FEATURE_TEST_MODE 2
#define | USB_EPT0_IDLE 0
endpoint 0 state More...
#define | USB_EPT0_SETUP 1
#define | USB_EPT0_DATA_IN 2
#define | USB_EPT0_DATA_OUT 3
#define | USB_EPT0_STATUS_IN 4
#define | USB_EPT0_STATUS_OUT 5
#define | USB_EPT0_STALL 6
#define | USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
usb descriptor length More...
#define | USB_DEVICE_DESC_LEN 0x12
#define | USB_DEVICE_CFG_DESC_LEN 0x09
#define | USB_DEVICE_IF_DESC_LEN 0x09
#define | USB_DEVICE_EPT_LEN 0x07
#define | USB_DEVICE_OTG_DESC_LEN 0x03
#define | USB_DEVICE_LANGID_STR_DESC_LEN 0x04
#define | USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
#define | USB_CLASS_CODE_AUDIO 0x01
usb class code More...
#define | USB_CLASS_CODE_CDC 0x02
#define | USB_CLASS_CODE_HID 0x03
#define | USB_CLASS_CODE_PRINTER 0x07
#define | USB_CLASS_CODE_MSC 0x08
#define | USB_CLASS_CODE_HUB 0x09
#define | USB_CLASS_CODE_CDCDATA 0x0A
#define | USB_CLASS_CODE_CCID 0x0B
#define | USB_CLASS_CODE_VIDEO 0x0E
#define | USB_CLASS_CODE_VENDOR 0xFF
#define | USB_EPT_DESC_CONTROL 0x00
usb endpoint type More...
#define | USB_EPT_DESC_ISO 0x01
#define | USB_EPT_DESC_BULK 0x02
#define | USB_EPT_DESC_INTERRUPT 0x03
#define | USB_EPT_DESC_NSYNC 0x00
#define | USB_ETP_DESC_ASYNC 0x04
#define | USB_ETP_DESC_ADAPTIVE 0x08
#define | USB_ETP_DESC_SYNC 0x0C
#define | USB_EPT_DESC_DATA_EPT 0x00
#define | USB_EPT_DESC_FD_EPT 0x10
#define | USB_EPT_DESC_FDDATA_EPT 0x20
#define | USBD_CDC_CS_INTERFACE 0x24
usb cdc class descriptor define More...
#define | USBD_CDC_CS_ENDPOINT 0x25
#define | USBD_CDC_SUBTYPE_HEADER 0x00
usb cdc class sub-type define More...
#define | USBD_CDC_SUBTYPE_CMF 0x01
#define | USBD_CDC_SUBTYPE_ACM 0x02
#define | USBD_CDC_SUBTYPE_UFD 0x06
#define | SET_LINE_CODING 0x20
usb cdc class request code define More...
#define | GET_LINE_CODING 0x21
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REQ_SET_PROTOCOL 0x0B
usb hid class request code define More...
#define | HID_REQ_GET_PROTOCOL 0x03
#define | HID_REQ_SET_IDLE 0x0A
#define | HID_REQ_GET_IDLE 0x02
#define | HID_REQ_SET_REPORT 0x09
#define | HID_REQ_GET_REPORT 0x01
#define | HID_DESCRIPTOR_TYPE 0x21
#define | HID_REPORT_DESC 0x22
#define | USB_MAX_EP0_SIZE 64
endpoint 0 max size More...
#define | SWAPBYTE(addr)
usb swap address More...
#define | MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
min and max define More...
#define | MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
#define | LBYTE(x) ((uint8_t)(x & 0x00FF))
low byte and high byte define More...
#define | HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))

Enumerations

enum usbd_conn_state { USB_CONN_STATE_DEFAULT =1 , USB_CONN_STATE_ADDRESSED , USB_CONN_STATE_CONFIGURED , USB_CONN_STATE_SUSPENDED }
usb device connect state More...
enum usb_sts_type {
USB_OK , USB_FAIL , USB_WAIT , USB_NOT_SUPPORT ,
USB_ERROR
}
usb return status More...

Detailed Description

usb standard header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usb_std.h.


AT32F413 Firmwary Library: usbd_core.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Data Structures | Enumerations | Functions
usbd_core.h File Reference

usb device core header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Data Structures

struct | usbd_desc_t
usb device descriptor struct More...
struct | usbd_desc_handler
usb device descriptor handler More...
struct | usbd_class_handler
usb device class handler More...
struct | usbd_core_type
usb device core struct type More...

Enumerations

enum usbd_event_type {
USBD_NOP_EVENT , USBD_RESET_EVENT , USBD_SUSPEND_EVENT , USBD_WAKEUP_EVENT ,
USBD_ERR_EVENT
}
usb device event More...

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

usb device core header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_core.h.


AT32F413 Firmwary Library: usbd_int.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Functions
usbd_int.h File Reference
#include "usbd_core.h"

Go to the source code of this file.

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...


AT32F413 Firmwary Library: usbd_sdr.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Functions
usbd_sdr.h File Reference

usb standard request header file More...

#include "usbd_core.h"

Go to the source code of this file.

Functions

void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

usb standard request header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_sdr.h.


AT32F413 Firmwary Library: usbd_core.c File Reference

  • middlewares
  • usbd_drivers
  • src
Functions
usbd_core.c File Reference

usb driver More...

#include "usbd_core.h"
#include "usbd_sdr.h"

Go to the source code of this file.

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

usb driver

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_core.c.


AT32F413 Firmwary Library: usbd_int.c File Reference

  • middlewares
  • usbd_drivers
  • src
Functions
usbd_int.c File Reference

usb interrupt request More...

#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

usb interrupt request

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_int.c.


AT32F413 Firmwary Library: usbd_sdr.c File Reference

  • middlewares
  • usbd_drivers
  • src
Functions
usbd_sdr.c File Reference

usb standard device request More...

#include "usbd_sdr.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbd_get_descriptor (usbd_core_type *udev)
get usb standard device description request More...
static usb_sts_type | usbd_set_address (usbd_core_type *udev)
this request sets the device address More...
static usb_sts_type | usbd_get_status (usbd_core_type *udev)
get usb status request More...
static usb_sts_type | usbd_clear_feature (usbd_core_type *udev)
clear usb feature request More...
static usb_sts_type | usbd_set_feature (usbd_core_type *udev)
set usb feature request More...
static usb_sts_type | usbd_get_configuration (usbd_core_type *udev)
get usb configuration request More...
static usb_sts_type | usbd_set_configuration (usbd_core_type *udev)
sets the usb device configuration request More...
void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

usb standard device request

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_sdr.c.


AT32F413 Firmwary Library: at32f413_board.c File Reference

  • project
  • at32f413_board
Macros | Functions | Variables
at32f413_board.c File Reference

set of firmware functions to manage leds and push-button. initialize delay function. More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | STEP_DELAY_MS 50
#define | PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Functions

int | fputc (int ch, FILE *f)
retargets the c library printf function to the usart. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...
void | at32_board_init ()
board initialize interface init led and button More...
void | at32_button_init (void)
configure button gpio More...
uint8_t | at32_button_state (void)
returns the selected button state More...
button_type at32_button_press ()
returns which button have press down More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | delay_init ()
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...

Variables

gpio_type * | led_gpio_port [3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}
uint16_t | led_gpio_pin [3] = {LED2_PIN, LED3_PIN, LED4_PIN}
crm_periph_clock_type | led_gpio_crm_clk [3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}
static __IO uint32_t | fac_us
static __IO uint32_t | fac_ms

Detailed Description

set of firmware functions to manage leds and push-button. initialize delay function.

        Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_board.c.


AT32F413 Firmwary Library: at32f413_board.h File Reference

  • at32f413_board
Macros | Enumerations | Functions
at32f413_board.h File Reference

header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function. More...

#include "stdio.h"
#include "at32f413.h"

Go to the source code of this file.

Macros

#define | LED_NUM 3
#define | PRINT_UART USART1
#define | PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN GPIO_PINS_9
#define | PRINT_UART_TX_GPIO GPIOA
#define | PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | USER_BUTTON_PIN GPIO_PINS_0
#define | USER_BUTTON_PORT GPIOA
#define | USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Enumerations

enum | led_type { LED2 = 0 , LED3 = 1 , LED4 = 2 }
enum | button_type { USER_BUTTON = 0 , NO_BUTTON = 1 }

Functions

void | at32_board_init (void)
board initialize interface init led and button More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | at32_button_init (void)
configure button gpio More...
button_type | at32_button_press (void)
returns which button have press down More...
uint8_t | at32_button_state (void)
returns the selected button state More...
void | delay_init (void)
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...

Detailed Description

header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function.

        Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_board.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • at_start_f413
  • examples
  • acc
  • calibration
  • inc
Functions
project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
Functions
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • repeat_conversion_loop_transfer
  • inc
Functions
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • bpr
  • bpr_data
  • inc
Functions
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • bpr
  • tamper
  • inc
Functions
project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • can
  • communication_mode
  • inc
Functions
project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • can
  • filter
  • inc
Functions
project/at_start_f413/examples/can/filter/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • can
  • loopback_mode
  • inc
Functions
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • crc
  • calculation
  • inc
Functions
project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • debug
  • tmr1
  • inc
Functions
project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • dma
  • data_to_gpio_flexible
  • inc
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • exint
  • exint_config
  • inc
Functions
project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • flash
  • fap_enable
  • inc
Functions
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • flash
  • operate_spim
  • inc
Functions
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • flash
  • run_in_spim
  • inc
Functions
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • gpio
  • io_toggle
  • inc
Functions
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • gpio
  • swjtag_remap
  • inc
Functions
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • communication_int
  • inc
Functions
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • eeprom
  • inc
Functions
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • deepsleep_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • standby_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • rtc
  • calendar
  • inc
Functions
project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • rtc
  • lick_calibration
  • inc
Functions
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • sram
  • extend_sram
  • inc
Functions
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • dma
  • inc
Functions
project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • external_clock
  • inc
Functions
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • input_capture
  • inc
Functions
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_high
  • inc
Functions
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_low
  • inc
Functions
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • timer_base
  • inc
Functions
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • half_duplex
  • inc
Functions
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • idle_detection
  • inc
Functions
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • interrupt
  • inc
Functions
project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • irda
  • inc
Functions
project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • polling
  • inc
Functions
project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • printf
  • inc
Functions
project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • rs485
  • inc
Functions
project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • smartcard
  • inc
Functions
project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • synchronous
  • inc
Functions
project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • audio
  • inc
Functions
project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • mouse
  • inc
Functions
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • msc
  • inc
Functions
project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • printer
  • inc
Functions
project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • templates
  • inc
Functions
project/at_start_f413/templates/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Functions
utilities/at32f413_freertos_demo/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Functions
utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • acc
  • calibration
  • inc
Macros
project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
Macros
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • current_vref_value_check
  • inc
Macros
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • exint_trigger_partitioned
  • inc
Macros
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • internal_temperature_sensor
  • inc
Macros
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • repeat_conversion_loop_transfer
  • inc
Macros
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • software_trigger_repeat
  • inc
Macros
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
Macros
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • voltage_monitoring
  • inc
Macros
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • bpr
  • bpr_data
  • inc
Macros
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • bpr
  • tamper
  • inc
Macros
project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • can
  • communication_mode
  • inc
Macros
project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • can
  • filter
  • inc
Macros
project/at_start_f413/examples/can/filter/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • can
  • loopback_mode
  • inc
Macros
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • bit_band
  • inc
Macros
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • cmsis_dsp
  • inc
Macros
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • fpu
  • inc
Macros
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • systick_interrupt
  • inc
Macros
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • crc
  • calculation
  • inc
Macros
project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • crm
  • clock_failure_detection
  • inc
Macros
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • crm
  • sysclk_switch
  • inc
Macros
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • debug
  • tmr1
  • inc
Macros
project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • dma
  • data_to_gpio_flexible
  • inc
Macros
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • dma
  • flash_to_sram
  • inc
Macros
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • exint
  • exint_config
  • inc
Macros
project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • exint
  • exint_software_trigger
  • inc
Macros
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • flash
  • fap_enable
  • inc
Macros
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • flash
  • flash_write_read
  • inc
Macros
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • flash
  • operate_spim
  • inc
Macros
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • flash
  • run_in_spim
  • inc
Macros
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • gpio
  • io_toggle
  • inc
Macros
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • gpio
  • led_toggle
  • inc
Macros
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • gpio
  • swjtag_remap
  • inc
Macros
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • communication_dma
  • inc
Macros
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • communication_int
  • inc
Macros
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • communication_poll
  • inc
Macros
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • eeprom
  • inc
Macros
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2s
  • halfduplex_dma
  • inc
Macros
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2s
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Macros
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • deepsleep_rtc
  • inc
Macros
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • power_voltage_monitor
  • inc
Macros
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • sleep_tmr2
  • inc
Macros
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • sleep_usart1
  • inc
Macros
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • standby_rtc
  • inc
Macros
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • standby_wakeup_pin
  • inc
Macros
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • rtc
  • calendar
  • inc
Macros
project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • rtc
  • lick_calibration
  • inc
Macros
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Macros
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Macros
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • crc_transfer_polling
  • inc
Macros
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • fullduplex_polling
  • inc
Macros
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
Macros
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • only_receive_mode_polling
  • inc
Macros
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Macros
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • w25q_flash
  • inc
Macros
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • sram
  • extend_sram
  • inc
Macros
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • 6_steps
  • inc
Macros
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • 7_pwm_output
  • inc
Macros
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • cascade_synchro
  • inc
Macros
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • complementary_signals
  • inc
Macros
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • dma
  • inc
Macros
project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • dma_burst
  • inc
Macros
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • encoder_tmr2
  • inc
Macros
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • external_clock
  • inc
Macros
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • hall_xor_tmr2
  • inc
Macros
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • hang_mode
  • inc
Macros
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • input_capture
  • inc
Macros
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_high
  • inc
Macros
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_low
  • inc
Macros
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_toggle_tmr3
  • inc
Macros
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_toggle_tmr9
  • inc
Macros
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • one_cycle
  • inc
Macros
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • parallel_synchro
  • inc
Macros
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_input
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_input_dma
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_output_simulate
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_output_tmr10
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_output_tmr3
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • timer_base
  • inc
Macros
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • tmr1_synchro
  • inc
Macros
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • tmr2_32bit
  • inc
Macros
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • half_duplex
  • inc
Macros
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • hw_flow_control
  • inc
Macros
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • idle_detection
  • inc
Macros
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • interrupt
  • inc
Macros
project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • irda
  • inc
Macros
project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • polling
  • inc
Macros
project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • printf
  • inc
Macros
project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • receiver_mute
  • inc
Macros
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • rs485
  • inc
Macros
project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • smartcard
  • inc
Macros
project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • synchronous
  • inc
Macros
project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
Macros
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • transfer_by_dma_polling
  • inc
Macros
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • audio
  • inc
Macros
project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Macros
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Macros
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Macros
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • custom_hid
  • inc
Macros
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • keyboard
  • inc
Macros
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • mouse
  • inc
Macros
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • msc
  • inc
Macros
project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • printer
  • inc
Macros
project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Macros
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • virtual_comport
  • inc
Macros
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Macros
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • wdt
  • wdt_reset
  • inc
Macros
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • wdt
  • wdt_standby
  • inc
Macros
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • wwdt
  • wwdt_reset
  • inc
Macros
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • templates
  • inc
Macros
project/at_start_f413/templates/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Macros
utilities/at32f413_freertos_demo/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Macros
utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Macros
utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Macros
utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Macros
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | LEXT_VALUE ((uint32_t)32768)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 54 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 49 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 42 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 50 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ LEXT_VALUE

#define LEXT_VALUE ((uint32_t)32768)

value of the low speed exernal clock in hz

Definition at line 51 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • acc
  • calibration
  • inc
Functions
project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
Functions
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • repeat_conversion_loop_transfer
  • inc
Functions
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • bpr
  • bpr_data
  • inc
Functions
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • bpr
  • tamper
  • inc
Functions
project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • can
  • communication_mode
  • inc
Functions
project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • can
  • filter
  • inc
Functions
project/at_start_f413/examples/can/filter/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • can
  • loopback_mode
  • inc
Functions
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • crc
  • calculation
  • inc
Functions
project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • debug
  • tmr1
  • inc
Functions
project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • dma
  • data_to_gpio_flexible
  • inc
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • exint
  • exint_config
  • inc
Functions
project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • flash
  • fap_enable
  • inc
Functions
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • flash
  • operate_spim
  • inc
Functions
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • flash
  • run_in_spim
  • inc
Functions
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • gpio
  • io_toggle
  • inc
Functions
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • gpio
  • swjtag_remap
  • inc
Functions
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • communication_int
  • inc
Functions
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • eeprom
  • inc
Functions
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • deepsleep_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • standby_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • rtc
  • calendar
  • inc
Functions
project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • rtc
  • lick_calibration
  • inc
Functions
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • sram
  • extend_sram
  • inc
Functions
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • dma
  • inc
Functions
project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • external_clock
  • inc
Functions
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • input_capture
  • inc
Functions
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_high
  • inc
Functions
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_low
  • inc
Functions
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • timer_base
  • inc
Functions
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • half_duplex
  • inc
Functions
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • idle_detection
  • inc
Functions
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • interrupt
  • inc
Functions
project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • irda
  • inc
Functions
project/at_start_f413/examples/usart/irda/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • polling
  • inc
Functions
project/at_start_f413/examples/usart/polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • printf
  • inc
Functions
project/at_start_f413/examples/usart/printf/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • rs485
  • inc
Functions
project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • smartcard
  • inc
Functions
project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • synchronous
  • inc
Functions
project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • audio
  • inc
Functions
project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • mouse
  • inc
Functions
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • msc
  • inc
Functions
project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • printer
  • inc
Functions
project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • templates
  • inc
Functions
project/at_start_f413/templates/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Functions
utilities/at32f413_freertos_demo/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Functions
utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • acc
  • calibration
  • inc
Macros | Functions
project/at_start_f413/examples/acc/calibration/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • audio
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • custom_hid
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • keyboard
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • mouse
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • msc
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • printer
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • virtual_comport
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_VIRTUAL_COMPORT
usb endpoint max num define More...
#define | EPT0_TX_ADDR 0x40
user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • acc
  • calibration
  • src
Functions
project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • combine_mode_ordinary_simult
  • src
Functions
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • current_vref_value_check
  • src
Functions
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • exint_trigger_partitioned
  • src
Functions
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • internal_temperature_sensor
  • src
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • repeat_conversion_loop_transfer
  • src
Functions
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • software_trigger_repeat
  • src
Functions
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • voltage_monitoring
  • src
Functions
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • bpr
  • bpr_data
  • src
Functions
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • bpr
  • tamper
  • src
Functions
project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • can
  • communication_mode
  • src
Functions
project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • can
  • filter
  • src
Functions
project/at_start_f413/examples/can/filter/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/can/filter/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • can
  • loopback_mode
  • src
Functions
project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • bit_band
  • src
Functions
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • cmsis_dsp
  • src
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • fpu
  • src
Functions
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • systick_interrupt
  • src
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • crc
  • calculation
  • src
Functions
project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • debug
  • tmr1
  • src
Functions
project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • dma
  • data_to_gpio_flexible
  • src
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • dma
  • flash_to_sram
  • src
Functions
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • exint
  • exint_config
  • src
Functions
project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • flash
  • fap_enable
  • src
Functions
project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • flash
  • flash_write_read
  • src
Functions
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • flash
  • operate_spim
  • src
Functions
project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • flash
  • run_in_spim
  • src
Functions
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • gpio
  • io_toggle
  • src
Functions
project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • gpio
  • led_toggle
  • src
Functions
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • gpio
  • swjtag_remap
  • src
Functions
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • communication_dma
  • src
Functions
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • communication_int
  • src
Functions
project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • communication_poll
  • src
Functions
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • eeprom
  • src
Functions
project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2s
  • halfduplex_dma
  • src
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2s
  • halfduplex_interrupt
  • src
Functions
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • deepsleep_rtc
  • src
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • sleep_usart1
  • src
Functions
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • standby_rtc
  • src
Functions
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • rtc
  • calendar
  • src
Functions
project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • rtc
  • lick_calibration
  • src
Functions
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • sdio
  • sd_mmc_card
  • src
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • crc_transfer_polling
  • src
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • fullduplex_polling
  • src
Functions
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • halfduplex_interrupt
  • src
Functions
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • halfduplex_transceiver_switch
  • src
Functions
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • only_receive_mode_polling
  • src
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • w25q_flash
  • src
Functions
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • sram
  • extend_sram
  • src
Functions
project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • 6_steps
  • src
Functions
project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • 7_pwm_output
  • src
Functions
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • cascade_synchro
  • src
Functions
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • complementary_signals
  • src
Functions
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • dma
  • src
Functions
project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • dma_burst
  • src
Functions
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • encoder_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • external_clock
  • src
Functions
project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • hall_xor_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • hang_mode
  • src
Functions
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • input_capture
  • src
Functions
project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_high
  • src
Functions
project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_low
  • src
Functions
project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_toggle_tmr3
  • src
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_toggle_tmr9
  • src
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • one_cycle
  • src
Functions
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • parallel_synchro
  • src
Functions
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_input
  • src
Functions
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_input_dma
  • src
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_output_simulate
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_output_tmr10
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_output_tmr3
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • timer_base
  • src
Functions
project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • tmr1_synchro
  • src
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • tmr2_32bit
  • src
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • half_duplex
  • src
Functions
project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • hw_flow_control
  • src
Functions
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • idle_detection
  • src
Functions
project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • interrupt
  • src
Functions
project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • irda
  • src
Functions
project/at_start_f413/examples/usart/irda/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/irda/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • polling
  • src
Functions
project/at_start_f413/examples/usart/polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • printf
  • src
Functions
project/at_start_f413/examples/usart/printf/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/printf/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • receiver_mute
  • src
Functions
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • rs485
  • src
Functions
project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • smartcard
  • src
Functions
project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • synchronous
  • src
Functions
project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • transfer_by_dma_interrupt
  • src
Functions
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • transfer_by_dma_polling
  • src
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • audio
  • src
Functions
project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • composite_vcp_keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • custom_hid
  • src
Functions
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • mouse
  • src
Functions
project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • msc
  • src
Functions
project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • printer
  • src
Functions
project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • vcp_loopback
  • src
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • virtual_comport
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • wdt
  • wdt_reset
  • src
Functions
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • wdt
  • wdt_standby
  • src
Functions
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • wwdt
  • wwdt_reset
  • src
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow: system clock (sclk) = hext / 2 * pll_mult system clock source = pll (hext)
  • hext = HEXT_VALUE
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 46 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • templates
  • src
Functions
project/at_start_f413/templates/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_freertos_demo
  • src
Functions
utilities/at32f413_freertos_demo/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Functions
utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Functions
utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • acc
  • calibration
  • src
Functions
project/at_start_f413/examples/acc/calibration/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • combine_mode_ordinary_simult
  • src
Functions | Variables
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...

Variables

__IO uint32_t | adc1_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • current_vref_value_check
  • src
Functions
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • exint_trigger_partitioned
  • src
Functions | Variables
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [3][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_trigger_count

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • internal_temperature_sensor
  • src
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • repeat_conversion_loop_transfer
  • src
Functions | Variables
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...

Variables

__IO uint16_t dma_trans_complete_flag

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • software_trigger_repeat
  • src
Functions | Variables
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...

Variables

__IO uint16_t dma_trans_complete_flag

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions | Variables
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3]
__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • voltage_monitoring
  • src
Functions | Variables
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3]
__IO uint16_t | vmor_flag_index

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • bpr
  • bpr_data
  • src
Functions
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • bpr
  • tamper
  • src
Functions
project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

uint32_t | bpr_reg_judge (void)
checks if the bpr dt registers are reset or not. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMPER_IRQHandler (void)
this function handles tamper interrupt request. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • can
  • communication_mode
  • src
Functions
project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • can
  • filter
  • src
Functions
project/at_start_f413/examples/can/filter/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • can
  • loopback_mode
  • src
Functions
project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • bit_band
  • src
Functions
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • cmsis_dsp
  • src
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • fpu
  • src
Functions
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • systick_interrupt
  • src
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | systick_handler (void)
systick interrupt handler. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • crc
  • calculation
  • src
Functions
project/at_start_f413/examples/crc/calculation/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | clock_failure_detection_handler (void)
clock failure detection handler. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • debug
  • tmr1
  • src
Functions
project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • dma
  • data_to_gpio_flexible
  • src
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • dma
  • flash_to_sram
  • src
Functions
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • exint
  • exint_config
  • src
Functions
project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • flash
  • fap_enable
  • src
Functions
project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • flash
  • flash_write_read
  • src
Functions
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • flash
  • operate_spim
  • src
Functions
project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • flash
  • run_in_spim
  • src
Functions
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • gpio
  • io_toggle
  • src
Functions
project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • gpio
  • led_toggle
  • src
Functions
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • gpio
  • swjtag_remap
  • src
Functions
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • communication_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel6_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel7_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel7_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel6_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

Macro Definition Documentation

◆ I2Cx_DMA_RX_IRQHandler

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel7_IRQHandler

Definition at line 32 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2Cx_DMA_TX_IRQHandler

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel6_IRQHandler

Definition at line 31 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2Cx_ERR_IRQHandler

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 34 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2Cx_EVT_IRQHandler

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 33 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • communication_int
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

Macro Definition Documentation

◆ I2Cx_ERR_IRQHandler

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 32 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ I2Cx_EVT_IRQHandler

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 31 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • communication_poll
  • src
Functions
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • eeprom
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel4_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel5_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel5_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C2_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C2_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

Macro Definition Documentation

◆ I2Cx_DMA_RX_IRQHandler

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel5_IRQHandler

Definition at line 32 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2Cx_DMA_TX_IRQHandler

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel4_IRQHandler

Definition at line 31 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2Cx_ERR_IRQHandler

#define I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler

Definition at line 34 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2Cx_EVT_IRQHandler

#define I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler

Definition at line 33 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2s
  • halfduplex_dma
  • src
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2s
  • halfduplex_interrupt
  • src
Functions | Variables
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...

Variables

uint16_t | i2s1_buffer_tx []
uint16_t | i2s2_buffer_rx []
__IO uint32_t | tx_index
__IO uint32_t | rx_index

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

Variable Documentation

◆ rx_index

__IO uint32_t rx_index

Definition at line 31 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

Referenced by SPI2_IRQHandler().


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • deepsleep_rtc
  • src
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTCAlarm_IRQHandler (void)
this function handles the rtc alarm through exint line interrupt request. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | PVM_IRQHandler (void)
this function handles the power voltage monitoring output interrupt request. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles the timer interrupt request. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • sleep_usart1
  • src
Functions | Variables
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART1_IRQHandler (void)
this function handles the usatt interrupt request. More...

Variables

uint16_t usart1_index = 0

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • standby_rtc
  • src
Functions
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • rtc
  • calendar
  • src
Functions
project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • rtc
  • lick_calibration
  • src
Functions | Variables
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Functions

uint32_t | incrementvar_operationcomplete (void)
increments operationcomplete variable and return its value before increment operation. More...
uint32_t | getvar_operationcomplete (void)
returns operationcomplete value. More...
void | setvar_periodvalue (uint32_t Value)
sets the periodvalue variable with input parameter. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc global interrupt request. More...
void | TMR5_GLOBAL_IRQHandler (void)
this function handles tmr5 global interrupt request. More...

Variables

__IO uint32_t | periodvalue
__IO uint32_t | operationcomplete
uint16_t | tmpCC4 [2] = {0, 0}

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • sdio
  • sd_mmc_card
  • src
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • crc_transfer_polling
  • src
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • fullduplex_polling
  • src
Functions
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • halfduplex_interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define BUFFERSIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...

Variables

uint8_t | spi1_tx_buffer []
uint8_t | spi2_rx_buffer []
uint32_t | tx_index
uint32_t | rx_index

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • halfduplex_transceiver_switch
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define BUFFERSIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...

Variables

uint8_t | spi1_tx_buffer []
uint8_t | spi2_tx_buffer []
uint8_t | spi1_rx_buffer []
uint8_t | spi2_rx_buffer []
uint32_t | tx_index
uint32_t | rx_index

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • only_receive_mode_polling
  • src
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • w25q_flash
  • src
Functions
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • sram
  • extend_sram
  • src
Functions
project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • 6_steps
  • src
Functions
project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • 7_pwm_output
  • src
Functions
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • cascade_synchro
  • src
Functions
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • complementary_signals
  • src
Functions
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • dma
  • src
Functions
project/at_start_f413/examples/tmr/dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • dma_burst
  • src
Functions
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • encoder_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • external_clock
  • src
Functions
project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • hall_xor_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • hang_mode
  • src
Functions
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • input_capture
  • src
Functions
project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_high
  • src
Functions
project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_low
  • src
Functions
project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_toggle_tmr3
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...

Variables

__IO uint16_t | ch1_val
__IO uint16_t | ch2_val
__IO uint16_t | ch3_val
__IO uint16_t | ch4_val
uint32_t | capture = 0

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_toggle_tmr9
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_BRK_TMR9_IRQHandler (void)
this function handles TMR9 global interrupt request. More...

Variables

__IO uint16_t | ch1_val
__IO uint16_t | ch2_val
uint16_t | capture = 0

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • one_cycle
  • src
Functions
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • parallel_synchro
  • src
Functions
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_input
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...

Variables

uint16_t | duty_cycle
uint32_t | frequency
__IO uint16_t | ic2value = 0

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_input_dma
  • src
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_output_simulate
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)

Variables

__IO uint16_t | ch1_val
__IO uint16_t | ch2_val
__IO uint16_t | ch3_val
__IO uint16_t | ch4_val
uint16_t | capture = 0

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_output_tmr10
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_output_tmr3
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • timer_base
  • src
Functions
project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • tmr1_synchro
  • src
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • tmr2_32bit
  • src
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • half_duplex
  • src
Functions
project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • hw_flow_control
  • src
Functions
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • idle_detection
  • src
Functions
project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • interrupt
  • src
Functions | Variables
project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...

Variables

uint8_t | usart2_tx_buffer []
uint8_t | usart3_tx_buffer []
uint8_t | usart2_rx_buffer []
uint8_t | usart3_rx_buffer []
uint8_t | usart2_tx_counter
uint8_t | usart3_tx_counter
uint8_t | usart2_rx_counter
uint8_t | usart3_rx_counter
uint8_t | usart2_tx_buffer_size
uint8_t | usart3_tx_buffer_size

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • irda
  • src
Functions
project/at_start_f413/examples/usart/irda/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • polling
  • src
Functions
project/at_start_f413/examples/usart/polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • printf
  • src
Functions
project/at_start_f413/examples/usart/printf/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • receiver_mute
  • src
Functions | Variables
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...

Variables

uint8_t | usart3_rx_buffer []
uint8_t | rx_counter

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • rs485
  • src
Functions
project/at_start_f413/examples/usart/rs485/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • smartcard
  • src
Functions | Variables
project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "smartcard_config.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EXINT9_5_IRQHandler (void)
this function handles external lines 9 to 5 interrupt request. More...
void | SC_USART_IRQHandler (void)
this function handles sc_usart global interrupt request. More...

Variables

uint32_t card_inserted

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • synchronous
  • src
Functions
project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • transfer_by_dma_interrupt
  • src
Functions | Variables
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma1 channel2 handler. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 handler. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 handler. More...

Variables

uint8_t | usart2_tx_dma_status
uint8_t | usart2_rx_dma_status
uint8_t | usart3_tx_dma_status
uint8_t | usart3_rx_dma_status

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • transfer_by_dma_polling
  • src
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • audio
  • src
Functions
project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • composite_vcp_keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • custom_hid
  • src
Functions
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • mouse
  • src
Functions
project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • msc
  • src
Functions
project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • printer
  • src
Functions
project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • vcp_loopback
  • src
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • virtual_comport
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • wdt
  • wdt_reset
  • src
Functions
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • wdt
  • wdt_standby
  • src
Functions
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • wwdt
  • wwdt_reset
  • src
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • templates
  • src
Functions
project/at_start_f413/templates/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_freertos_demo
  • src
Functions
utilities/at32f413_freertos_demo/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | DebugMon_Handler (void)
this function handles svcall exception. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Functions
utilities/at32f413_gen_random_number_demo/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Functions
utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.


AT32F413 Firmwary Library: main.c File Reference

  • acc
  • calibration
  • src
Macros | Functions | Variables
project/at_start_f413/examples/acc/calibration/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Macros

#define | SCLK_FROM_HICK
#define | ACC_TRIM

Functions

void | system_clock_config_for_acc (void)
system clock config for acc More...
void | clkout_config (void)
clkout configuration More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
usbfs_l_can1_rx0 interrupt handler More...
void | ACC_IRQHandler (void)
acc interrupt handler More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
uint32_t | acc_c2_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • combine_mode_ordinary_simult
  • src
Functions | Variables
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • current_vref_value_check
  • src
Functions | Variables
project/at_start_f413/examples/adc/current_vref_value_check/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • exint_trigger_partitioned
  • src
Functions | Variables
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | exint_config (void)
exint configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [3][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_trigger_count = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • internal_temperature_sensor
  • src
Macros | Functions | Variables
project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | ADC_VREF (3.3)
#define | ADC_TEMP_BASE (1.26)
#define | ADC_TEMP_SLOPE (-0.00423)

Functions

static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • repeat_conversion_loop_transfer
  • src
Functions | Variables
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • software_trigger_repeat
  • src
Functions | Variables
project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions | Variables
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • voltage_monitoring
  • src
Functions | Variables
project/at_start_f413/examples/adc/voltage_monitoring/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | vmor_flag_index = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • bpr
  • bpr_data
  • src
Macros | Functions | Variables
project/at_start_f413/examples/bpr/bpr_data/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BPR_DR_NUMBER 42

Functions

void | bpr_reg_write (void)
write data to bpr dt register. More...
uint8_t | bpr_reg_check (void)
checks if the bpr dt register values are correct or not. More...
void | uart_init (uint32_t baudrate)
init usart. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • bpr
  • tamper
  • src
Macros | Functions | Variables
project/at_start_f413/examples/bpr/tamper/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BPR_DR_NUMBER 42

Functions

void | bpr_reg_write (void)
write data to bpr dt registers. More...
uint8_t | bpr_reg_check (void)
checks if the bpr dt registers values are correct or not. More...
uint32_t | bpr_reg_judge (void)
checks if the bpr dt registers are reset or not. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • can
  • communication_mode
  • src
Functions
project/at_start_f413/examples/can/communication_mode/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • can
  • filter
  • src
Macros | Functions | Variables
project/at_start_f413/examples/can/filter/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
#define | FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
#define | FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
#define | FILTER_STD_ID1 ((uint16_t)0x04F6)
#define | FILTER_STD_ID2 ((uint16_t)0x04F7)
#define | FILTER_STD_ID3 ((uint16_t)0x04F8)

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Variables

uint8_t test_result = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • can
  • loopback_mode
  • src
Functions
project/at_start_f413/examples/can/loopback_mode/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • bit_band
  • src
Macros | Functions | Variables
project/at_start_f413/examples/cortex_m4/bit_band/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | RAM_BASE 0x20000000
#define | RAM_BITBAND_BASE 0x22000000
#define | VARIABLES_RESET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | VARIABLES_SET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | VARIABLES_GET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
#define | PERIPHERAL_BASE 0x40000000
#define | PERIPHERAL_BITBAND_BASE 0x42000000
#define | PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | PERIPHERAL_SET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Functions

void | result_error (void)
led4 flick for error. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | variables
__IO uint32_t | variables_addr = 0
__IO uint32_t | variables_bit_val = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • cmsis_dsp
  • src
Macros | Functions | Variables
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "arm_math.h"

Go to the source code of this file.

Macros

#define | USE_STATIC_INIT
#define | TEST_LENGTH_SAMPLES (20*4)
#define | NUMSTUDENTS 20
#define | NUMSUBJECTS 4

Functions

int32_t main ()
main function. More...

Variables

const float32_t | testMarks_f32 [(20 *4)]
const float32_t | testUnity_f32 [4]
static float32_t | testOutput [(20 *4)]
uint32_t | numStudents = 20
uint32_t | numSubjects = 4
float32_t | max_marks
float32_t | min_marks
float32_t | mean
float32_t | std
float32_t | var
uint32_t | student_num

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • fpu
  • src
Macros | Functions | Variables
project/at_start_f413/examples/cortex_m4/fpu/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "julia_fpu.h"

Go to the source code of this file.

Macros

#define | SCREEN_X_SIZE ((uint16_t)160)
#define | SCREEN_Y_SIZE ((uint16_t)120)
#define | ZOOM ((uint16_t)100)

Functions

int main (void)
main function. More...

Variables

uint8_t buffer [((uint16_t) 160) *((uint16_t) 120)]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • systick_interrupt
  • src
Macros | Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | MS_TICK (system_core_clock / 1000U)
#define | DELAY 200 /* 200 ms ticks */

Functions

void | systick_handler (void)
systick interrupt handler. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • crc
  • calculation
  • src
Macros | Functions | Variables
project/at_start_f413/examples/crc/calculation/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 120

Functions

int main (void)
main function. More...

Variables

static const uint32_t | data_buffer [120]
__IO uint32_t | crc_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f413/examples/crm/clock_failure_detection/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | clkout_config (void)
clkout configuration. More...
static void | sclk_192m_hick_config (void)
config sclk 192 mhz with hick clock source. More...
void | clock_failure_detection_handler (void)
clock failure detection handler. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f413/examples/crm/sysclk_switch/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | clkout_config (void)
clkout configuration. More...
static void | sclk_64m_hick_config (void)
config sclk 64 mhz with hick clock source. More...
static void | sclk_96m_hext_config (void)
config sclk 96 mhz with hext clock source. More...
static void | switch_system_clock (void)
sclk switch function. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • debug
  • tmr1
  • src
Functions | Variables
project/at_start_f413/examples/debug/tmr1/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles tmr1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | counter = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • dma
  • data_to_gpio_flexible
  • src
Macros | Functions | Variables
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | DMA2_Channel1_IRQHandler (void)
this function handles DMA2 channel1 handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
uint16_t | src_buffer [16]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • dma
  • flash_to_sram
  • src
Macros | Functions | Variables
project/at_start_f413/examples/dma/flash_to_sram/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • exint
  • exint_config
  • src
Functions
project/at_start_f413/examples/exint/exint_config/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | exint_line0_config (void)
exint line0 config. configure pa0 in interrupt mode More...
int | main (void)
main function. More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f413/examples/exint/exint_software_trigger/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | exint_line4_config (void)
exint line4 config. configure pa0 in interrupt mode More...
static void | tmr1_config (void)
tmr1 configuration. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
tmr1 interrupt handler More...
void | EXINT4_IRQHandler (void)
exint4 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • flash
  • fap_enable
  • src
Functions
project/at_start_f413/examples/flash/fap_enable/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/fap_enable/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • flash
  • flash_write_read
  • src
Macros | Functions | Variables
project/at_start_f413/examples/flash/flash_write_read/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "flash.h"

Go to the source code of this file.

Macros

#define | TEST_BUFEER_SIZE 3000
#define | TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)

Functions

error_status | buffer_compare (uint16_t *p_buffer1, uint16_t *p_buffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint16_t | buffer_write [3000]
uint16_t | buffer_read [3000]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • flash
  • operate_spim
  • src
Functions
project/at_start_f413/examples/flash/operate_spim/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "operate_spim.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • flash
  • run_in_spim
  • src
Functions
project/at_start_f413/examples/flash/run_in_spim/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "run_in_spim.h"

Go to the source code of this file.

Functions

void | spim_init (void)
init the spim flash More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • gpio
  • io_toggle
  • src
Functions
project/at_start_f413/examples/gpio/io_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | gpio_config (void)
pa.01 gpio configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/io_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • gpio
  • led_toggle
  • src
Functions
project/at_start_f413/examples/gpio/led_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • gpio
  • swjtag_remap
  • src
Functions
project/at_start_f413/examples/gpio/swjtag_remap/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | swj_dp_config (void)
configure the gpio of swj-dp. More...
void | gpio_pins_toggle (gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • communication_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6
#define | I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7
#define | I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | error_handler (uint32_t error_code)
error handler program More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • communication_int
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_int/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | error_handler (uint32_t error_code)
error handler program More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • communication_poll
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_poll/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • eeprom
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/eeprom/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C2
#define | I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_10
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_11
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4
#define | I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5
#define | I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn
#define | I2Cx_EVT_IRQn I2C2_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C2_ERR_IRQn
#define | BUF_SIZE 8

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf1 [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | tx_buf2 [8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}
uint8_t | tx_buf3 [8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}
uint8_t | rx_buf1 [8] = {0}
uint8_t | rx_buf2 [8] = {0}
uint8_t | rx_buf3 [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2s
  • halfduplex_dma
  • src
Functions | Variables
project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
volatile error_status | transfer_status = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2s
  • halfduplex_interrupt
  • src
Functions | Variables
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
error_status | buffer_compare_24bits (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions | Variables
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
static void | i2s_config (i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | spi1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • deepsleep_rtc
  • src
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

void | rtc_config (void)
rtc configuration. More...
void | system_clock_recover (void)
systemclock recover. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | pvm_exint_config (void)
power voltage monitor exint configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | tmr2_config (void)
tmr2 configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • sleep_usart1
  • src
Functions
project/at_start_f413/examples/pwc/sleep_usart1/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | usart1_config (uint32_t baudrate)
usart1 configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • standby_rtc
  • src
Functions
project/at_start_f413/examples/pwc/standby_rtc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

void | rtc_config (void)
rtc configuration. More...
void | rtc_alarm_config (uint8_t alarm_time)
rtc alarm set. More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • rtc
  • calendar
  • src
Functions | Variables
project/at_start_f413/examples/rtc/calendar/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "rtc.h"

Go to the source code of this file.

Functions

void | alarm_init (void)
init alarm. More...
int | main (void)
main function. More...

Variables

char const weekday_table [7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"}

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • rtc
  • lick_calibration
  • src
Functions | Variables
project/at_start_f413/examples/rtc/lick_calibration/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
void | rtc_configuration (void)
configures the rtc. More...
uint32_t | incrementvar_operationcomplete (void)
increments operationcomplete variable and return its value before increment operation. More...
uint32_t | getvar_operationcomplete (void)
returns operationcomplete value. More...
void | setvar_periodvalue (uint32_t value)
sets the periodvalue variable with input parameter. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type crm_clocks
__IO uint32_t | periodvalue = 0
__IO uint32_t | lickfreq = 0
__IO uint32_t | operationcomplete = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • sdio
  • sd_mmc_card
  • src
Macros | Functions | Variables
project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c File Reference

main program More...

#include <stdbool.h>
#include <string.h>
#include "at32_sdio.h"
#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | BLOCK_SIZE (512)
#define | BLOCKS_NUMBER (8)
#define | MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
#define | STREAM_BUFFER_SIZE (1024)

Functions

static error_status | sd_single_block_test (void)
sd card single block read/write test. More...
static error_status | sd_multiple_blocks_test (void)
sd card multiple blocks read/write test. More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
LED2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | mmc_stream_test (void)
mmc card data stream read/write test. More...
void | show_card_info (void)
show sd/mmc card info. More...
int | main (void)
main function. More...

Variables

static uint8_t | sblock_tbuffer [(512)]
static uint8_t | sblock_rbuffer [(512)]
static uint8_t | mblock_tbuffer [((512) *(8))]
static uint8_t | mblock_rbuffer [((512) *(8))]
static uint8_t | stream_tbuffer [(1024)]
static uint8_t | stream_rbuffer [(1024)]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions | Variables
project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c File Reference

main program More...

#include <stdbool.h>
#include <string.h>
#include "at32_sdio.h"
#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "ff.h"

Go to the source code of this file.

Functions

uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
led2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | fatfs_test (void)
fatfs file read/write test. More...
int | main (void)
main function. More...

Variables

FATFS | fs
FIL | file
BYTE | work [FF_MAX_SS]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • crc_transfer_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | spi1_tx_buffer [32]
uint16_t | spi2_tx_buffer [32]
uint16_t | spi1_rx_buffer [32]
uint16_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
__IO uint16_t | crc1_value = 0
__IO uint16_t | crc2_value = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • fullduplex_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/fullduplex_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (uint16_t spi1_mode, uint16_t spi2_mode)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
volatile error_status | transfer_status4 = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • halfduplex_interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • halfduplex_transceiver_switch
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • only_receive_mode_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
__IO uint8_t | tx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • w25q_flash
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/w25q_flash/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "spi_flash.h"

Go to the source code of this file.

Macros

#define | FLASH_TEST_ADDR 0x1000
#define | BUF_SIZE 0x256

Functions

void | tx_data_fill (void)
transfer data fill. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buffer [0x256]
uint8_t | rx_buffer [0x256]
volatile error_status | transfer_status = ERROR

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • sram
  • extend_sram
  • src
Functions
project/at_start_f413/examples/sram/extend_sram/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | extend_sram (void)
to extend sram size More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • 6_steps
  • src
Functions | Variables
project/at_start_f413/examples/tmr/6_steps/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | systick_configuration (void)
configures the systick. More...
int | main (void)
main function. More...
void | TMR1_TRG_HALL_TMR11_IRQHandler (void)
this function handles tmr1 trigger and hall interrupts requests. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint32_t | step = 1

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • 7_pwm_output
  • src
Functions | Variables
project/at_start_f413/examples/tmr/7_pwm_output/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0
uint16_t | channel4_pulse = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • cascade_synchro
  • src
Functions | Variables
project/at_start_f413/examples/tmr/cascade_synchro/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • complementary_signals
  • src
Functions | Variables
project/at_start_f413/examples/tmr/complementary_signals/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • dma
  • src
Functions | Variables
project/at_start_f413/examples/tmr/dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0, 0, 0}

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • dma_burst
  • src
Functions | Variables
project/at_start_f413/examples/tmr/dma_burst/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0x0FFF, 0x0000, 0x0555}

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • encoder_tmr2
  • src
Functions | Variables
project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | delay (uint32_t time)
delay function More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint32_t | counter

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • external_clock
  • src
Functions | Variables
project/at_start_f413/examples/tmr/external_clock/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • hall_xor_tmr2
  • src
Functions | Variables
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int | main (void)
main function. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles TMR2 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • hang_mode
  • src
Functions | Variables
project/at_start_f413/examples/tmr/hang_mode/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • input_capture
  • src
Functions | Variables
project/at_start_f413/examples/tmr/input_capture/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 trigger exception. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_input_config_type tmr_input_config_struct
__IO uint32_t | tmr3freq = 0
__IO uint32_t | sys_counter = 0
__IO uint16_t | capturenumber = 0
__IO uint16_t | ch3readvalue1 = 0
__IO uint16_t | ch3readvalue2 = 0
__IO uint32_t | capture = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_high
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_high/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_low
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_low/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_toggle_tmr3
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
__IO uint16_t | ch3_val = 8192
__IO uint16_t | ch4_val = 4096
uint16_t | div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_toggle_tmr9
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr9 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
uint16_t | div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • one_cycle
  • src
Functions | Variables
project/at_start_f413/examples/tmr/one_cycle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
tmr_input_config_type tmr_ic_init_structure
uint16_t div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • parallel_synchro
  • src
Functions | Variables
project/at_start_f413/examples/tmr/parallel_synchro/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_input
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_input/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_input_config_type tmr_ic_init_structure
__IO uint16_t | duty_cycle = 0
__IO uint32_t | frequency = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_input_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | TMR1_C1DT_ADDRESS 0x40012C34
#define | TMR1_C2DT_ADDRESS 0x40012C38
#define | SAMPLING_NUM 1000

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
void | DMA1_Channel2_IRQHandler (void)
int | main (void)
main function. More...

Variables

tmr_input_config_type tmr_ic_init_structure
dma_init_type dma_init_structure
__IO uint16_t | buffer_ch1 [1000]
__IO uint16_t | buffer_ch2 [1000]
__IO uint32_t | frequency = 0
__IO float | duty_cycle = 0
uint32_t | freq_result
float | duty_result

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_output_simulate
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 40961
uint16_t | ch2_val = 27309
uint16_t | ch3_val = 13654
uint16_t | ch4_val = 6826
uint16_t | div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_output_tmr10
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 250
uint16_t | div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_output_tmr3
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 333
uint16_t | ch2_val = 249
uint16_t | ch3_val = 166
uint16_t | ch4_val = 83
uint16_t | div_value = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • timer_base
  • src
Functions | Variables
project/at_start_f413/examples/tmr/timer_base/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | clkout_config (void)
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • tmr1_synchro
  • src
Functions | Variables
project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • tmr2_32bit
  • src
Functions | Variables
project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint32_t | ch1_val = 0x7FFFF
uint32_t | ch2_val = 0x3FFFF
uint32_t | ch3_val = 0x1FFFF
uint32_t | ch4_val = 0xFFFF

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • half_duplex
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/half_duplex/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart half-duplex transfer: usart2 -> usart3"
uint8_t | usart3_tx_buffer [] = "usart half-duplex transfer: usart3 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | data_count

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • hw_flow_control
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/hw_flow_control/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | rx_buffer [16]
uint8_t | data_count

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • idle_detection
  • src
Functions
project/at_start_f413/examples/usart/idle_detection/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_counter = 0x00
volatile uint8_t | usart3_tx_counter = 0x00
volatile uint8_t | usart2_rx_counter = 0x00
volatile uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • irda
  • src
Functions
project/at_start_f413/examples/usart/irda/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • printf
  • src
Functions | Variables
project/at_start_f413/examples/usart/printf/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

__IO uint32_t time_cnt = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • receiver_mute
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/receiver_mute/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | BUFFER_SIZE 7
#define | MATCH_ID_VAL 0x81
#define | ERROR_ID_VAL 0x82
#define | DATA1_VAL 0x7F
#define | DATA2_VAL 0x7A
#define | DATA3_VAL 0x7B
#define | DATA4_VAL 0x7C

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }
uint8_t | usart3_rx_buffer [7]
uint8_t | tx_counter = 0
uint8_t | rx_counter = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • rs485
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/rs485/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | RS485_BAUDRATE 9600
#define | RS485_BUFFER_SIZE 128

Functions

static void | rs485_config (void)
rs485 configiguration. More...
static void | rs485_send_data (u8 *buf, u8 cnt)
rs485 send data More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
usart2 interrupt handler More...

Variables

uint8_t | rs485_buffer_rx [128]
uint8_t | rs485_buffer_rx_cnt = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • smartcard
  • src
Data Structures | Macros | Functions | Variables
project/at_start_f413/examples/usart/smartcard/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "smartcard_config.h"

Go to the source code of this file.

Data Structures

struct sc_atr_type

Macros

#define | T0_PROTOCOL 0x00 /* t0 protocol */
#define | SETUP_LENGTH 20
#define | HIST_LENGTH 20
#define | SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
#define | SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
#define | SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Functions

void | usart_configuration (void)
config usart More...
uint8_t | sc_response_decode (__IO uint8_t *card)
decode the card atr response. More...
int | main (void)
main function. More...

Variables

sc_atr_type sc_a2r_struct
uint32_t | sc_baud_rate = 0
uint32_t | sc_clock_freq = 0
uint32_t | counter = 0
error_status atr_decode_status = ERROR
uint32_t | card_inserted = 0
uint32_t | card_protocol = 1
uint8_t | dst_buffer [50]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • synchronous
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/synchronous/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)
#define | DYMMY_BYTE 0x00

Functions

void | usart_spi_configuration (void)
config usart and spi More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart synchronous example: usart2 -> spi2"
uint8_t | spi2_tx_buffer [] = "usart synchronous example: spi2 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]
uint8_t | spi2_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | spi2_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | spi2_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | spi2_tx_buffer_size = ((sizeof( spi2_tx_buffer ) / sizeof(*( spi2_tx_buffer ))) - 1)

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • transfer_by_dma_interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_dma_status = 0
volatile uint8_t | usart2_rx_dma_status = 0
volatile uint8_t | usart3_tx_dma_status = 0
volatile uint8_t | usart3_rx_dma_status = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • transfer_by_dma_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • audio
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/audio/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "audio_class.h"
#include "audio_desc.h"
#include "usbd_int.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "usbd_int.h"
#include "audio_hid_class.h"
#include "audio_hid_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t report_buf [USBD_AUHID_IN_MAXPACKET_SIZE]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • composite_vcp_keyboard
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_keyboard_class.h"
#include "cdc_keyboard_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_msc_class.h"
#include "cdc_msc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • custom_hid
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/custom_hid/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "custom_hid_class.h"
#include "custom_hid_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • keyboard
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/keyboard/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "keyboard_class.h"
#include "keyboard_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | system_clock_recover (void)
systemclock recover. More...
void | button_exint_init (void)
configure button exint More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t hid_suspend_flag

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • mouse
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/mouse/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "mouse_class.h"
#include "mouse_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | system_clock_recover (void)
systemclock recover. More...
void | button_exint_init (void)
configure button exint More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t | press_mouse = 0
__IO uint8_t | hid_suspend_flag
uint8_t | report_buf [USBD_MOUSE_IN_MAXPACKET_SIZE]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • msc
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/msc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "msc_class.h"
#include "msc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • printer
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/printer/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "printer_class.h"
#include "printer_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

uint8_t usb_buffer [256]
usbd_core_type usb_core_dev

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • vcp_loopback
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • virtual_comport
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usb_device/virtual_comport/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Macros

#define usart_buffer_size 2048

Functions

void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
void | usart_gpio_config (void)
this function handles usart2 gpio config. More...
void | usart_send_data (uint8_t *send_data, uint16_t len)
this function handles usart2 send data. More...
uint16_t | usart_receive_data (void)
this function handles usart2 receive data. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
linecoding_type linecoding
uint8_t | usart_rx_buffer [2048]
uint16_t | hw_usart_rx_index = 0
uint16_t | hw_usart_read_index = 0
uint16_t | usart_rx_data_len = 0
uint16_t | ov_cnt = 0

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "msc_class.h"
#include "msc_desc.h"
#include "usbd_int.h"
#include "flash_fat16.h"

Go to the source code of this file.

Functions

void | jump_to_app (uint32_t address)
jump to app More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | usb_reset ()
usb re-connect More...
void | flash_fat16_loop_status (void)
loop status More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
void(* pftarget )(void)

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • wdt
  • wdt_reset
  • src
Functions
project/at_start_f413/examples/wdt/wdt_reset/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • wdt
  • wdt_standby
  • src
Functions
project/at_start_f413/examples/wdt/wdt_standby/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • wwdt
  • wwdt_reset
  • src
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • templates
  • src
Macros | Functions | Variables
project/at_start_f413/templates/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...

Variables

uint8_t g_speed = 1

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_freertos_demo
  • src
Functions | Variables
utilities/at32f413_freertos_demo/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "FreeRTOS.h"
#include "task.h"

Go to the source code of this file.

Functions

void | led2_task_function (void *pvParameters)
void | led3_task_function (void *pvParameters)
int | main (void)
main function. More...

Variables

TaskHandle_t | led2_handler
TaskHandle_t | led3_handler

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Functions
utilities/at32f413_gen_random_number_demo/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "stdio.h"
#include "random.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Macros | Functions | Variables
utilities/at32f413_slib_demo/project_l0/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>
#include "math_helper.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define | USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */
#define | FLASH_START_ADDR 0x08000000
#define | TEST_SLIB_PSW 0x55665566
#define | SLIB_START_ADDR 0x08001000
#define | SLIB_DATA_ADDR 0x08002000
#define | SLIB_END_ADDR 0x08002800
#define | FLASH_SECTOR_SIZE 0x800
#define | SECTOR_NUM(dwAddr) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)
#define | SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */
#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

flash_status_type | slib_enable (void)
config slib enable and program slib area. More...
void | config_flash_interrupt (void)
config flash error interrupt. More...
int | main (void)
main function. More...

Variables

float32_t | testInput_f32_1kHz_15kHz []
float32_t | refOutput []
uint32_t | dw_start_sector
uint32_t | dw_data_start_sector
uint32_t | dw_end_sector
uint32_t | temp_buf [512]
static float32_t | testOutput [320]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/src/main.c.

Variable Documentation

◆ refOutput

float32_t refOutput[]
extern

Definition at line 96 of file project_l0/src/arm_fir_data.c.

Referenced by main().

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[]
extern

Definition at line 48 of file project_l0/src/arm_fir_data.c.

Referenced by main().


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Macros | Functions | Variables
utilities/at32f413_slib_demo/project_l1/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>
#include "math_helper.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | config_flash_interrupt (void)
config flash error interrupt. More...
int | main (void)
main function. More...

Variables

float32_t | testInput_f32_1kHz_15kHz []
float32_t | refOutput []
static float32_t | testOutput [320]

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/src/main.c.

Variable Documentation

◆ refOutput

float32_t refOutput[]
extern

Definition at line 96 of file project_l0/src/arm_fir_data.c.

Referenced by main().

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[]
extern

Definition at line 48 of file project_l0/src/arm_fir_data.c.

Referenced by main().


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "tmr.h"
#include "usart.h"
#include "iap.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "tmr.h"
#include "usart.h"
#include "iap.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "tmr.h"
#include "usart.h"
#include "flash.h"
#include "iap.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions | Variables
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"
#include "hid_iap_user.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions | Variables
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"
#include "hid_iap_user.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"
#include "hid_iap_user.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.


AT32F413 Firmwary Library: julia_fpu.h File Reference

  • cortex_m4
  • fpu
  • inc
Macros | Functions
julia_fpu.h File Reference

julia_fpu header file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file julia_fpu.h.


AT32F413 Firmwary Library: julia_fpu.c File Reference

  • cortex_m4
  • fpu
  • src
Functions
julia_fpu.c File Reference

julia_fpu source file More...

#include "julia_fpu.h"

Go to the source code of this file.

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu source file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file julia_fpu.c.


AT32F413 Firmwary Library: flash.h File Reference

  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f413/examples/flash/flash_write_read/inc/flash.h File Reference

flash header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking More...

Detailed Description

flash header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/flash.h.


AT32F413 Firmwary Library: flash.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h File Reference

flash header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */
#define | SRAM_SIZE 64 /* sram size, unit:kbyte */

Functions

void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...

Detailed Description

flash header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h.


AT32F413 Firmwary Library: flash.c File Reference

  • flash
  • flash_write_read
  • src
Macros | Functions | Variables
project/at_start_f413/examples/flash/flash_write_read/src/flash.c File Reference

flash program More...

#include "at32f413_board.h"
#include "flash.h"

Go to the source code of this file.

Macros

#define SECTOR_SIZE 1024 /* this parameter depends on the specific model of the chip */

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking More...

Variables

uint16_t flash_buf [1024/2]

Detailed Description

flash program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.


AT32F413 Firmwary Library: flash.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c File Reference

flash program More...

#include "flash.h"
#include "usart.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...

Detailed Description

flash program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.


AT32F413 Firmwary Library: operate_spim.h File Reference

  • flash
  • operate_spim
  • inc
Macros | Functions
operate_spim.h File Reference

operate_spim header file More...

Go to the source code of this file.

Macros

#define | SPIM_SECTOR_SIZE 4096
#define | SPIM_TEST_ADDR 0x08400000

Functions

void spim_operate (void)
operate spim flash More...

Detailed Description

operate_spim header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file operate_spim.h.


AT32F413 Firmwary Library: operate_spim.c File Reference

  • flash
  • operate_spim
  • src
Functions | Variables
operate_spim.c File Reference

operate spim program More...

#include "at32f413_board.h"
#include "operate_spim.h"
#include <string.h>

Go to the source code of this file.

Functions

void | spim_init (void)
init the spim flash More...
void | sector_read (uint32_t address, uint32_t sector_size, uint8_t *buf)
read one sector from a specified address in spim flash More...
void | spim_operate (void)
operate spim flash More...

Variables

uint8_t | write_buffer [4096]
uint8_t | read_buffer [4096]

Detailed Description

operate spim program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file operate_spim.c.


AT32F413 Firmwary Library: run_in_spim.h File Reference

  • flash
  • run_in_spim
  • inc
Functions
run_in_spim.h File Reference

run_in_spim header file More...

Go to the source code of this file.

Functions

void spim_run (void)
check the led toggle in spim More...

Detailed Description

run_in_spim header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file run_in_spim.h.


AT32F413 Firmwary Library: run_in_spim.c File Reference

  • flash
  • run_in_spim
  • src
Functions
run_in_spim.c File Reference

run in spim program More...

#include "at32f413_board.h"
#include "run_in_spim.h"

Go to the source code of this file.

Functions

void spim_run (void)
check the led toggle in spim More...

Detailed Description

run in spim program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file run_in_spim.c.


AT32F413 Firmwary Library: rtc.h File Reference

  • rtc
  • calendar
  • inc
Data Structures | Functions | Variables
rtc.h File Reference

this file provides template for calendar api. More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct calendar_type

Functions

uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
void | rtc_time_get (void)
get current time. More...

Variables

calendar_type calendar

Detailed Description

this file provides template for calendar api.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file rtc.h.


AT32F413 Firmwary Library: rtc.c File Reference

  • rtc
  • calendar
  • src
Functions | Variables
rtc.c File Reference

this file provides template for calendar api. More...

#include "rtc.h"

Go to the source code of this file.

Functions

uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | is_leap_year (uint16_t year)
judeg the leap year or common year. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_week_get (uint16_t year, uint8_t month, uint8_t day)
get current week by input leap year\mouth\day. More...
void | rtc_time_get (void)
get current time. More...

Variables

calendar_type calendar
const uint8_t | table_week [12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5}
const uint8_t | mon_table [12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}

Detailed Description

this file provides template for calendar api.

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file rtc.c.


AT32F413 Firmwary Library: at32_sdio.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
sd_mmc_card/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

        Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: at32_sdio.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
sdio_fatfs/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

        Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: ffconf.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Macros
ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 1
#define | FF_USE_FASTSEEK 1
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 3
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 1
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 1

Definition at line 240 of file ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 1

Definition at line 37 of file ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 1

Definition at line 33 of file ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 3

Definition at line 169 of file ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file ffconf.h.


AT32F413 Firmwary Library: at32_sdio.c File Reference

  • sdio
  • sd_mmc_card
  • src
Functions | Variables
sd_mmc_card/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include "at32_sdio.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

        Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sd_mmc_card/src/at32_sdio.c.


AT32F413 Firmwary Library: at32_sdio.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions | Variables
sdio_fatfs/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include <string.h>
#include "at32_sdio.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

        Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sdio_fatfs/src/at32_sdio.c.


AT32F413 Firmwary Library: diskio.c File Reference

  • sdio
  • sdio_fatfs
  • src
Macros | Functions
diskio.c File Reference
#include "ff.h"
#include "diskio.h"
#include <string.h>
#include "at32_sdio.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

__align (4)
sd_error_status_type | sd_write_disk (const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector More...
DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)

Macro Definition Documentation

◆ DEV_MMC

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 19 of file diskio.c.

◆ DEV_RAM

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 18 of file diskio.c.

◆ DEV_USB

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 20 of file diskio.c.

Function Documentation

◆ __align()

__align ( 4 )

Definition at line 22 of file diskio.c.

◆ disk_initialize()

DSTATUS disk_initialize ( BYTE pdrv )

Definition at line 141 of file diskio.c.

◆ disk_ioctl()

DRESULT disk_ioctl | ( | BYTE | pdrv,
 |  | BYTE | cmd,
 |  | void * | buff
 | ) |  |

Definition at line 245 of file diskio.c.

◆ disk_read()

DRESULT disk_read | ( | BYTE | pdrv,
 |  | BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 172 of file diskio.c.

◆ disk_status()

DSTATUS disk_status ( BYTE pdrv )

Definition at line 110 of file diskio.c.

◆ disk_write()

DRESULT disk_write | ( | BYTE | pdrv,
 |  | const BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 209 of file diskio.c.

◆ sd_write_disk()

sd_error_status_type sd_write_disk | ( | const uint8_t * | buf,
 |  | uint32_t | sector,
 |  | uint8_t | cnt
 | ) |  |

write sd card sector

Parameters
buf | write data buf
sector | sector address
cnt | sector count
Return values
sd_error_status_type sd card error code.

Definition at line 74 of file diskio.c.

Referenced by disk_write().


AT32F413 Firmwary Library: spi_flash.h File Reference

  • spi
  • w25q_flash
  • inc
Macros | Functions
spi_flash.h File Reference

header file of spi_flash More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define | SPI_TRANS_DMA
#define | FLASH_CS_HIGH() gpio_bits_set(GPIOB, GPIO_PINS_12)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOB, GPIO_PINS_12)
#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17
#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Detailed Description

header file of spi_flash

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file spi_flash.h.


AT32F413 Firmwary Library: spi_flash.c File Reference

  • spi
  • w25q_flash
  • src
Functions | Variables
spi_flash.c File Reference

spi_flash source code More...

#include "spi_flash.h"

Go to the source code of this file.

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Variables

uint8_t spiflash_sector_buf [SPIF_SECTOR_SIZE]

Detailed Description

spi_flash source code

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file spi_flash.c.


AT32F413 Firmwary Library: smartcard_config.h File Reference

  • usart
  • smartcard
  • inc
Macros
smartcard_config.h File Reference

header file of clock program More...

Go to the source code of this file.

Macros

#define | SC_USART USART2
#define | SC_USART_CLK CRM_USART2_PERIPH_CLOCK
#define | SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_USART_TX_PIN GPIO_PINS_2
#define | SC_USART_TX_PORT GPIOA
#define | SC_USART_CLK_PIN GPIO_PINS_4
#define | SC_USART_CLK_PORT GPIOA
#define | SC_USART_IRQn USART2_IRQn
#define | SC_USART_IRQHandler USART2_IRQHandler
#define | SC_3_5V_PIN GPIO_PINS_5
#define | SC_RESET_PIN GPIO_PINS_6
#define | SC_CMDVCC_PIN GPIO_PINS_7
#define | SC_OFF_PIN GPIO_PINS_8
#define | SC_3_5V_PORT GPIOA
#define | SC_RESET_PORT GPIOA
#define | SC_CMDVCC_PORT GPIOA
#define | SC_OFF_PORT GPIOA
#define | SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_EXINT EXINT_LINE_8
#define | SC_OFF_PORTSOURCE GPIO_PORT_SOURCE_GPIOA
#define | SC_OFF_PINSOURCE GPIO_PINS_SOURCE8
#define | SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Detailed Description

header file of clock program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file smartcard_config.h.

Macro Definition Documentation

◆ SC_3_5V_CLK

#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 53 of file smartcard_config.h.

◆ SC_3_5V_PIN

#define SC_3_5V_PIN GPIO_PINS_5

Definition at line 45 of file smartcard_config.h.

◆ SC_3_5V_PORT

#define SC_3_5V_PORT GPIOA

Definition at line 49 of file smartcard_config.h.

◆ SC_CMDVCC_CLK

#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 55 of file smartcard_config.h.

◆ SC_CMDVCC_PIN

#define SC_CMDVCC_PIN GPIO_PINS_7

Definition at line 47 of file smartcard_config.h.

◆ SC_CMDVCC_PORT

#define SC_CMDVCC_PORT GPIOA

Definition at line 51 of file smartcard_config.h.

◆ SC_OFF_CLK

#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 56 of file smartcard_config.h.

◆ SC_OFF_EXINT

#define SC_OFF_EXINT EXINT_LINE_8

Definition at line 57 of file smartcard_config.h.

◆ SC_OFF_EXINT_IRQ

#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Definition at line 60 of file smartcard_config.h.

◆ SC_OFF_PIN

#define SC_OFF_PIN GPIO_PINS_8

Definition at line 48 of file smartcard_config.h.

◆ SC_OFF_PINSOURCE

#define SC_OFF_PINSOURCE GPIO_PINS_SOURCE8

Definition at line 59 of file smartcard_config.h.

◆ SC_OFF_PORT

#define SC_OFF_PORT GPIOA

Definition at line 52 of file smartcard_config.h.

◆ SC_OFF_PORTSOURCE

#define SC_OFF_PORTSOURCE GPIO_PORT_SOURCE_GPIOA

Definition at line 58 of file smartcard_config.h.

◆ SC_RESET_CLK

#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 54 of file smartcard_config.h.

◆ SC_RESET_PIN

#define SC_RESET_PIN GPIO_PINS_6

Definition at line 46 of file smartcard_config.h.

◆ SC_RESET_PORT

#define SC_RESET_PORT GPIOA

Definition at line 50 of file smartcard_config.h.

◆ SC_USART

#define SC_USART USART2

Definition at line 34 of file smartcard_config.h.

◆ SC_USART_CLK

#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK

Definition at line 35 of file smartcard_config.h.

◆ SC_USART_CLK_PIN

#define SC_USART_CLK_PIN GPIO_PINS_4

Definition at line 39 of file smartcard_config.h.

◆ SC_USART_CLK_PORT

#define SC_USART_CLK_PORT GPIOA

Definition at line 40 of file smartcard_config.h.

◆ SC_USART_GPIO_CLK

#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 36 of file smartcard_config.h.

◆ SC_USART_IRQHandler

#define SC_USART_IRQHandler ( void ) USART2_IRQHandler

Definition at line 42 of file smartcard_config.h.

◆ SC_USART_IRQn

#define SC_USART_IRQn USART2_IRQn

Definition at line 41 of file smartcard_config.h.

◆ SC_USART_TX_PIN

#define SC_USART_TX_PIN GPIO_PINS_2

Definition at line 37 of file smartcard_config.h.

◆ SC_USART_TX_PORT

#define SC_USART_TX_PORT GPIOA

Definition at line 38 of file smartcard_config.h.


AT32F413 Firmwary Library: audio_codec.h File Reference

  • usb_device
  • audio
  • inc
Data Structures | Macros | Functions
audio/inc/audio_codec.h File Reference

audio codec header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio/inc/audio_codec.h.


AT32F413 Firmwary Library: audio_codec.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Data Structures | Macros | Functions
composite_audio_hid/inc/audio_codec.h File Reference

audio codec header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_audio_hid/inc/audio_codec.h.


AT32F413 Firmwary Library: audio_codec.c File Reference

  • usb_device
  • audio
  • src
Macros | Functions | Variables
audio/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio/src/audio_codec.c.


AT32F413 Firmwary Library: audio_codec.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Macros | Functions | Variables
composite_audio_hid/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 200000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_audio_hid/src/audio_codec.c.


AT32F413 Firmwary Library: msc_diskio.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Macros | Functions
composite_vcp_msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_vcp_msc/inc/msc_diskio.h.


AT32F413 Firmwary Library: msc_diskio.h File Reference

  • usb_device
  • msc
  • inc
Macros | Functions
msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc/inc/msc_diskio.h.


AT32F413 Firmwary Library: msc_diskio.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Macros | Functions
virtual_msc_iap/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file virtual_msc_iap/inc/msc_diskio.h.


AT32F413 Firmwary Library: msc_diskio.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions | Variables
composite_vcp_msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "cdc_msc_class.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_vcp_msc/src/msc_diskio.c.


AT32F413 Firmwary Library: msc_diskio.c File Reference

  • usb_device
  • msc
  • src
Functions | Variables
msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc/src/msc_diskio.c.


AT32F413 Firmwary Library: msc_diskio.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions | Variables
virtual_msc_iap/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"
#include "flash_fat16.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint8_t scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file virtual_msc_iap/src/msc_diskio.c.


AT32F413 Firmwary Library: flash_fat16.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
flash_fat16.h File Reference

fat16 file system header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | fat_dir_type
struct | flash_iap_type

Macros

#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08005000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1

Enumerations

enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}

Functions

uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | flash_fat16_loop_status (void)
loop status More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...

Variables

flash_iap_type flash_iap

Detailed Description

fat16 file system header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file flash_fat16.h.


AT32F413 Firmwary Library: flash_fat16.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Macros | Functions | Variables
flash_fat16.c File Reference

fat16 file system More...

#include "flash_fat16.h"
#include "usb_conf.h"

Go to the source code of this file.

Macros

#define FAT16_SECTOR_SIZE 62

Functions

uint32_t | flash_fat16_boot_dir_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write More...
uint32_t | flash_fat16_sector_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector More...
uint32_t | fat16_memory_copy (uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function More...
uint32_t | fat16_memory_memset (uint8_t *dst, uint32_t set, uint32_t len)
memset function More...
uint32_t | flash_write_data (uint32_t address, uint8_t *data, uint32_t len)
write data to flash More...
uint32_t | flash_read_data (uint32_t address, uint8_t *data, uint32_t len)
read data from flash More...
uint32_t | fat16_memory_cmp (uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function More...
uint32_t | flash_crc_check (uint32_t address, uint8_t *data, uint32_t len)
crc check More...
void | flash_fat16_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | flash_fat16_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint32_t | flash_fat16_addr_offset (uint8_t *file_name)
get offset address More...
void | flash_fat16_init (void)
flash fat16 iap init More...

Variables

static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0

Detailed Description

fat16 file system

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file flash_fat16.c.


AT32F413 Firmwary Library: FreeRTOSConfig.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Macros
FreeRTOSConfig.h File Reference

Go to the source code of this file.

Macros

#define | configUSE_PREEMPTION 1
#define | configUSE_IDLE_HOOK 0
#define | configUSE_TICK_HOOK 0
#define | configCPU_CLOCK_HZ ( ( unsigned long ) system_core_clock )
#define | configTICK_RATE_HZ ( ( TickType_t ) 1000 )
#define | configMAX_PRIORITIES ( 5 )
#define | configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )
#define | configSUPPORT_DYNAMIC_ALLOCATION 1
#define | configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )
#define | configMAX_TASK_NAME_LEN ( 16 )
#define | configUSE_16_BIT_TICKS 0
#define | configIDLE_SHOULD_YIELD 1
#define | configUSE_CO_ROUTINES 0
#define | configMAX_CO_ROUTINE_PRIORITIES ( 2 )
#define | INCLUDE_vTaskPrioritySet 1
#define | INCLUDE_uxTaskPriorityGet 1
#define | INCLUDE_vTaskDelete 1
#define | INCLUDE_vTaskCleanUpResources 0
#define | INCLUDE_vTaskSuspend 1
#define | INCLUDE_vTaskDelayUntil 1
#define | INCLUDE_vTaskDelay 1
#define | INCLUDE_xTaskGetCurrentTaskHandle 1
#define | configPRIO_BITS 4 /* 15 priority levels */
#define | configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f
#define | configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01
#define | configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
#define | configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
#define | configASSERT(x) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }
#define | vPortSVCHandler SVC_Handler
#define | xPortPendSVHandler PendSV_Handler
#define | xPortSysTickHandler SysTick_Handler

Macro Definition Documentation

◆ configASSERT

#define configASSERT ( x ) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }

Definition at line 168 of file FreeRTOSConfig.h.

◆ configCPU_CLOCK_HZ

#define configCPU_CLOCK_HZ ( ( unsigned long ) system_core_clock )

Definition at line 115 of file FreeRTOSConfig.h.

◆ configIDLE_SHOULD_YIELD

#define configIDLE_SHOULD_YIELD 1

Definition at line 123 of file FreeRTOSConfig.h.

◆ configKERNEL_INTERRUPT_PRIORITY

#define configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )

Definition at line 161 of file FreeRTOSConfig.h.

◆ configLIBRARY_LOWEST_INTERRUPT_PRIORITY

#define configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f

Definition at line 151 of file FreeRTOSConfig.h.

◆ configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY

#define configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01

Definition at line 157 of file FreeRTOSConfig.h.

◆ configMAX_CO_ROUTINE_PRIORITIES

#define configMAX_CO_ROUTINE_PRIORITIES ( 2 )

Definition at line 128 of file FreeRTOSConfig.h.

◆ configMAX_PRIORITIES

#define configMAX_PRIORITIES ( 5 )

Definition at line 117 of file FreeRTOSConfig.h.

◆ configMAX_SYSCALL_INTERRUPT_PRIORITY

#define configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )

Definition at line 164 of file FreeRTOSConfig.h.

◆ configMAX_TASK_NAME_LEN

#define configMAX_TASK_NAME_LEN ( 16 )

Definition at line 121 of file FreeRTOSConfig.h.

◆ configMINIMAL_STACK_SIZE

#define configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )

Definition at line 118 of file FreeRTOSConfig.h.

◆ configPRIO_BITS

#define configPRIO_BITS 4 /* 15 priority levels */

Definition at line 146 of file FreeRTOSConfig.h.

◆ configSUPPORT_DYNAMIC_ALLOCATION

#define configSUPPORT_DYNAMIC_ALLOCATION 1

Definition at line 119 of file FreeRTOSConfig.h.

◆ configTICK_RATE_HZ

#define configTICK_RATE_HZ ( ( TickType_t ) 1000 )

Definition at line 116 of file FreeRTOSConfig.h.

◆ configTOTAL_HEAP_SIZE

#define configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )

Definition at line 120 of file FreeRTOSConfig.h.

◆ configUSE_16_BIT_TICKS

#define configUSE_16_BIT_TICKS 0

Definition at line 122 of file FreeRTOSConfig.h.

◆ configUSE_CO_ROUTINES

#define configUSE_CO_ROUTINES 0

Definition at line 127 of file FreeRTOSConfig.h.

◆ configUSE_IDLE_HOOK

#define configUSE_IDLE_HOOK 0

Definition at line 113 of file FreeRTOSConfig.h.

◆ configUSE_PREEMPTION

#define configUSE_PREEMPTION 1

Definition at line 112 of file FreeRTOSConfig.h.

◆ configUSE_TICK_HOOK

#define configUSE_TICK_HOOK 0

Definition at line 114 of file FreeRTOSConfig.h.

◆ INCLUDE_uxTaskPriorityGet

#define INCLUDE_uxTaskPriorityGet 1

Definition at line 134 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskCleanUpResources

#define INCLUDE_vTaskCleanUpResources 0

Definition at line 136 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelay

#define INCLUDE_vTaskDelay 1

Definition at line 139 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelayUntil

#define INCLUDE_vTaskDelayUntil 1

Definition at line 138 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelete

#define INCLUDE_vTaskDelete 1

Definition at line 135 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskPrioritySet

#define INCLUDE_vTaskPrioritySet 1

Definition at line 133 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskSuspend

#define INCLUDE_vTaskSuspend 1

Definition at line 137 of file FreeRTOSConfig.h.

◆ INCLUDE_xTaskGetCurrentTaskHandle

#define INCLUDE_xTaskGetCurrentTaskHandle 1

Definition at line 140 of file FreeRTOSConfig.h.

◆ vPortSVCHandler

#define vPortSVCHandler SVC_Handler

Definition at line 172 of file FreeRTOSConfig.h.

◆ xPortPendSVHandler

#define xPortPendSVHandler PendSV_Handler

Definition at line 173 of file FreeRTOSConfig.h.

◆ xPortSysTickHandler

#define xPortSysTickHandler SysTick_Handler

Definition at line 174 of file FreeRTOSConfig.h.


AT32F413 Firmwary Library: include_port.c File Reference

  • utilities
  • at32f413_freertos_demo
  • src
include_port.c File Reference

include_port program More...

#include "..\..\..\middlewares\freertos\source\portable\rvds\ARM_CM4F\port.c"

Go to the source code of this file.

Detailed Description

include_port program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file include_port.c.


AT32F413 Firmwary Library: random.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Macros | Functions
random.h File Reference

at32f413 random header file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define ENABLE_RTC_ASSEED (1)

Functions

void randnum_test (void)
enable rtc as seed More...

Detailed Description

at32f413 random header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file random.h.


AT32F413 Firmwary Library: random.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Macros | Functions
random.c File Reference

set of firmware functions to random function More...

#include "at32f413_board.h"
#include "random.h"
#include "stdio.h"
#include <stdlib.h>

Go to the source code of this file.

Macros

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Functions

int | get_uid_for_seed (void)
get uid value as seed More...
void | randnum_test (void)
enable rtc as seed More...

Detailed Description

set of firmware functions to random function

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file random.c.


AT32F413 Firmwary Library: fir_filter.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
project_l0/inc/fir_filter.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

void | arm_fir_init_f32 (arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter. More...
void | arm_fir_f32 (const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
void | FIR_lowpass_filter (float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)

Function Documentation

◆ arm_fir_f32()

void arm_fir_f32 | ( | const arm_fir_instance_f32 * | S,
 |  | const float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | blockSize
 | ) |  |

Referenced by FIR_lowpass_filter().

◆ arm_fir_init_f32()

void arm_fir_init_f32 | ( | arm_fir_instance_f32 * | S,
 |  | uint16_t | numTaps,
 |  | const float32_t * | pCoeffs,
 |  | float32_t * | pState,
 |  | uint32_t | blockSize
 | ) |  |

Initialization function for the floating-point FIR filter.

File : Step1-ST_Customer_level_n/Inc/fir_filter.h Version: V1.3.0 Date : 2021-03-18 Brief : This file contains the headers of FIR filter IP-Code.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. may be used to endorse or promote products derived from this software without specific prior written permission.

AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Parameters
[in,out] | S | points to an instance of the floating-point FIR filter structure
[in] | numTaps | number of filter coefficients in the filter
[in] | pCoeffs | points to the filter coefficients buffer
[in] | pState | points to the state buffer
[in] | blockSize | number of samples processed per call
Returns
none
Details
pCoeffs points to the array of filter coefficients stored in time reversed order:
    {b[numTaps-1], b[numTaps-2], b[N-2], ..., b[1], b[0]}
pState points to the array of state variables. pState is of length numTaps+blockSize-1 samples, where blockSize is the number of input samples processed by each call to arm_fir_f32().
Initialization of Helium version
For Helium version the array of coefficients must be a multiple of 16 even if less then 16 coefficients are used. The additional coefficients must be set to 0. It does not mean that all the coefficients will be used in the filter (numTaps is still set to its right value in the init function.) It just means that the implementation may require to read more coefficients due to the vectorization and to avoid having to manage too many different cases in the code.

Definition at line 59 of file arm_fir_init_f32.c.

Referenced by FIR_lowpass_filter().

◆ FIR_lowpass_filter()

void FIR_lowpass_filter | ( | float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | testlengthsamples
 | ) |  |

Definition at line 76 of file fir_filter.c.

Referenced by main().


AT32F413 Firmwary Library: fir_filter.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
project_l1/inc/fir_filter.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

void | arm_fir_init_f32 (arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter. More...
void | arm_fir_f32 (const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
void | FIR_lowpass_filter (float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)

Function Documentation

◆ arm_fir_f32()

void arm_fir_f32 | ( | const arm_fir_instance_f32 * | S,
 |  | const float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | blockSize
 | ) |  |

◆ arm_fir_init_f32()

void arm_fir_init_f32 | ( | arm_fir_instance_f32 * | S,
 |  | uint16_t | numTaps,
 |  | const float32_t * | pCoeffs,
 |  | float32_t * | pState,
 |  | uint32_t | blockSize
 | ) |  |

Initialization function for the floating-point FIR filter.

File : Step1-ST_Customer_level_n/Inc/fir_filter.h Version: V1.3.0 Date : 2021-03-18 Brief : This file contains the headers of FIR filter IP-Code.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. may be used to endorse or promote products derived from this software without specific prior written permission.

AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Parameters
[in,out] | S | points to an instance of the floating-point FIR filter structure
[in] | numTaps | number of filter coefficients in the filter
[in] | pCoeffs | points to the filter coefficients buffer
[in] | pState | points to the state buffer
[in] | blockSize | number of samples processed per call
Returns
none
Details
pCoeffs points to the array of filter coefficients stored in time reversed order:
    {b[numTaps-1], b[numTaps-2], b[N-2], ..., b[1], b[0]}
pState points to the array of state variables. pState is of length numTaps+blockSize-1 samples, where blockSize is the number of input samples processed by each call to arm_fir_f32().
Initialization of Helium version
For Helium version the array of coefficients must be a multiple of 16 even if less then 16 coefficients are used. The additional coefficients must be set to 0. It does not mean that all the coefficients will be used in the filter (numTaps is still set to its right value in the init function.) It just means that the implementation may require to read more coefficients due to the vectorization and to avoid having to manage too many different cases in the code.

Definition at line 59 of file arm_fir_init_f32.c.

◆ FIR_lowpass_filter()

void FIR_lowpass_filter | ( | float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | testlengthsamples
 | ) |  |

Definition at line 76 of file fir_filter.c.


AT32F413 Firmwary Library: math_helper.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
project_l0/inc/math_helper.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_calc_2pow (uint32_t guard_bits)
Calculates pow(2, numShifts) More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l0/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l0/src/math_helper.c.

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l0/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l0/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l0/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l0/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l0/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l0/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l0/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l0/src/math_helper.c.

Referenced by main().


AT32F413 Firmwary Library: math_helper.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
project_l1/inc/math_helper.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_calc_2pow (uint32_t guard_bits)
Calculates pow(2, numShifts) More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l0/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l0/src/math_helper.c.

Referenced by arm_apply_guard_bits().

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l0/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l0/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l0/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l0/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l0/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l0/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l0/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l0/src/math_helper.c.


AT32F413 Firmwary Library: arm_fir_data.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Variables
project_l0/src/arm_fir_data.c File Reference
#include "at32f413.h"
#include "arm_math.h"

Go to the source code of this file.

Variables

float32_t | testInput_f32_1kHz_15kHz [320]
float32_t | refOutput [320]

Variable Documentation

◆ refOutput

float32_t refOutput[320]

Definition at line 96 of file project_l0/src/arm_fir_data.c.

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[320]

Definition at line 48 of file project_l0/src/arm_fir_data.c.


AT32F413 Firmwary Library: arm_fir_data.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Variables
project_l1/src/arm_fir_data.c File Reference
#include "at32f413.h"
#include "arm_math.h"

Go to the source code of this file.

Variables

float32_t | testInput_f32_1kHz_15kHz [320]
float32_t | refOutput [320]

Variable Documentation

◆ refOutput

float32_t refOutput[320]

Definition at line 96 of file project_l1/src/arm_fir_data.c.

Referenced by main().

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[320]

Definition at line 48 of file project_l1/src/arm_fir_data.c.

Referenced by main().


AT32F413 Firmwary Library: arm_fir_init_f32.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
arm_fir_init_f32.c File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

void * | my_memset (void *s, int c, size_t n)
void | arm_fir_init_f32 (arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter. More...

Function Documentation

◆ arm_fir_init_f32()

void arm_fir_init_f32 | ( | arm_fir_instance_f32 * | S,
 |  | uint16_t | numTaps,
 |  | const float32_t * | pCoeffs,
 |  | float32_t * | pState,
 |  | uint32_t | blockSize
 | ) |  |

Initialization function for the floating-point FIR filter.

Parameters
[in,out] | S | points to an instance of the floating-point FIR filter structure
[in] | numTaps | number of filter coefficients in the filter
[in] | pCoeffs | points to the filter coefficients buffer
[in] | pState | points to the state buffer
[in] | blockSize | number of samples processed per call
Returns
none
Details
pCoeffs points to the array of filter coefficients stored in time reversed order:
    {b[numTaps-1], b[numTaps-2], b[N-2], ..., b[1], b[0]}
pState points to the array of state variables. pState is of length numTaps+blockSize-1 samples, where blockSize is the number of input samples processed by each call to arm_fir_f32().
Initialization of Helium version
For Helium version the array of coefficients must be a multiple of 16 even if less then 16 coefficients are used. The additional coefficients must be set to 0. It does not mean that all the coefficients will be used in the filter (numTaps is still set to its right value in the init function.) It just means that the implementation may require to read more coefficients due to the vectorization and to avoid having to manage too many different cases in the code.

Definition at line 59 of file arm_fir_init_f32.c.

Referenced by FIR_lowpass_filter().

◆ my_memset()

void * my_memset | ( | void * | s,
 |  | int | c,
 |  | size_t | n
 | ) |  |

Definition at line 79 of file arm_fir_init_f32.c.

Referenced by arm_fir_init_f32().


AT32F413 Firmwary Library: fir_coefficient.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Macros | Variables
fir_coefficient.c File Reference
#include "at32f413.h"
#include "arm_math.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define NUM_TAPS 29

Variables

const float32_t firCoeffs32 [29]

Macro Definition Documentation

◆ NUM_TAPS

#define NUM_TAPS 29

Definition at line 51 of file fir_coefficient.c.

Variable Documentation

◆ firCoeffs32

const float32_t firCoeffs32[29]
Initial value:
= {
-0.0018225230f, -0.0015879294f, +0.0000000000f, +0.0036977508f, +0.0080754303f, +0.0085302217f, -0.0000000000f, -0.0173976984f,
-0.0341458607f, -0.0333591565f, +0.0000000000f, +0.0676308395f, +0.1522061835f, +0.2229246956f, +0.2504960933f, +0.2229246956f,
+0.1522061835f, +0.0676308395f, +0.0000000000f, -0.0333591565f, -0.0341458607f, -0.0173976984f, -0.0000000000f, +0.0085302217f,
+0.0080754303f, +0.0036977508f, +0.0000000000f, -0.0015879294f, -0.0018225230f
}

Definition at line 62 of file fir_coefficient.c.

Referenced by FIR_lowpass_filter().


AT32F413 Firmwary Library: fir_filter.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Macros | Functions | Variables
fir_filter.c File Reference
#include "at32f413.h"
#include "arm_math.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define | BLOCK_SIZE 32
#define | NUM_TAPS 29

Functions

void FIR_lowpass_filter (float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)

Variables

const float32_t | firCoeffs32 []
static float32_t | firStateF32 [32+29 - 1]

Macro Definition Documentation

◆ BLOCK_SIZE

#define BLOCK_SIZE 32

Definition at line 53 of file fir_filter.c.

◆ NUM_TAPS

#define NUM_TAPS 29

Definition at line 54 of file fir_filter.c.

Function Documentation

◆ FIR_lowpass_filter()

void FIR_lowpass_filter | ( | float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | testlengthsamples
 | ) |  |

Definition at line 76 of file fir_filter.c.

Referenced by main().

Variable Documentation

◆ firCoeffs32

const float32_t firCoeffs32[]
extern

Definition at line 62 of file fir_coefficient.c.

Referenced by FIR_lowpass_filter().

◆ firStateF32

float32_t firStateF32[32+ 29 - 1]
static

Definition at line 66 of file fir_filter.c.

Referenced by FIR_lowpass_filter().


AT32F413 Firmwary Library: math_helper.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
project_l0/src/math_helper.c File Reference
#include <math.h>
#include "math_helper.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q7 (q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_calc_2pow (uint32_t numShifts)
Calculates pow(2, numShifts) More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l0/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l0/src/math_helper.c.

Referenced by arm_apply_guard_bits().

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l0/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l0/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l0/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l0/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l0/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l0/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q7()

void arm_provide_guard_bits_q7 | ( | q7_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 245 of file project_l0/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l0/src/math_helper.c.


AT32F413 Firmwary Library: math_helper.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Functions
project_l1/src/math_helper.c File Reference
#include <math.h>
#include "math_helper.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q7 (q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_calc_2pow (uint32_t numShifts)
Calculates pow(2, numShifts) More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l1/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l1/src/math_helper.c.

Referenced by arm_apply_guard_bits().

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l1/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l1/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l1/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l1/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l1/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l1/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l1/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l1/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l1/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l1/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l1/src/math_helper.c.

◆ arm_provide_guard_bits_q7()

void arm_provide_guard_bits_q7 | ( | q7_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 245 of file project_l1/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l1/src/math_helper.c.

Referenced by main().


AT32F413 Firmwary Library: iap.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
app_led3_toggle/inc/iap.h File Reference

iap header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/iap.h.


AT32F413 Firmwary Library: iap.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
app_led4_toggle/inc/iap.h File Reference

iap header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/iap.h.


AT32F413 Firmwary Library: iap.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
bootloader/inc/iap.h File Reference

iap header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Data Structures

struct cmd_data_group_type
cmd data group type More...

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38

Typedefs

typedef void(* iapfun) (void)

Enumerations

enum cmd_data_step_type {
CMD_DATA_IDLE , CMD_DATA_ADDR , CMD_DATA_BUF , CMD_DATA_CHACK ,
CMD_DATA_DONE , CMD_DATA_ERR
}
cmd data step type More...
enum cmd_ctr_step_type {
CMD_CTR_IDLE , CMD_CTR_INIT , CMD_CTR_DONE , CMD_CTR_ERR ,
CMD_CTR_APP
}
cmd ctr step type More...
enum update_status_type { UPDATE_PRE , UPDATE_CLEAR_FLAG , UPDATE_ING , UPDATE_DONE }
update status type More...

Functions

void | command_handle (void)
command analysis handle. More...
void | back_err (void)
command response error. More...
void | back_ok (void)
command response ok. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
void | app_load (uint32_t appxaddr)
app load. More...

Variables

cmd_data_group_type cmd_data_group_type_struct
cmd_data_step_type cmd_data_step
cmd_ctr_step_type cmd_ctr_step
update_status_type update_status

Detailed Description

iap header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/iap.h.


AT32F413 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
app_led3_toggle/inc/tmr.h File Reference

tmr header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/tmr.h.


AT32F413 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
app_led4_toggle/inc/tmr.h File Reference

tmr header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/tmr.h.


AT32F413 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions | Variables
bootloader/inc/tmr.h File Reference

tmr header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Variables

uint8_t | time_ira_cnt
uint8_t | get_data_from_usart_flag

Detailed Description

tmr header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/tmr.h.


AT32F413 Firmwary Library: usart.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions | Variables
app_led3_toggle/inc/usart.h File Reference

usart header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag

Detailed Description

usart header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/usart.h.


AT32F413 Firmwary Library: usart.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions | Variables
app_led4_toggle/inc/usart.h File Reference

usart header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag

Detailed Description

usart header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/usart.h.


AT32F413 Firmwary Library: usart.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Data Structures | Macros | Functions | Variables
bootloader/inc/usart.h File Reference

usart header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Data Structures

struct usart_group_type
usart group type More...

Macros

#define USART_REC_LEN 1024

Functions

void uart_init (uint32_t baudrate)
init usart. More...

Variables

usart_group_type usart_group_struct

Detailed Description

usart header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/usart.h.


AT32F413 Firmwary Library: iap.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
app_led3_toggle/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/iap.c.


AT32F413 Firmwary Library: iap.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
app_led4_toggle/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/iap.c.


AT32F413 Firmwary Library: iap.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "flash.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | app_load (uint32_t app_addr)
app load. More...
uint8_t | data_take (void)
take data from usart buf. More...
void | command_handle (void)
command analysis handle. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...
void | app_update_handle (void)
app update flow handle. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...

Variables

cmd_data_step_type cmd_data_step = CMD_DATA_IDLE
cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE
cmd_data_group_type cmd_data_group_struct
update_status_type update_status = UPDATE_PRE
static uint8_t | cmd_addr_cnt = 0
static uint32_t | cmd_data_cnt = 0
iapfun jump_to_app
jump to app More...

Detailed Description

iap program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/iap.c.


AT32F413 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
app_led3_toggle/src/tmr.c File Reference

tmr program More...

#include "at32f413_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/tmr.c.


AT32F413 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
app_led4_toggle/src/tmr.c File Reference

tmr program More...

#include "at32f413_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/tmr.c.


AT32F413 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/tmr.c File Reference

tmr program More...

#include "at32f413_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Variables

uint8_t | time_ira_cnt =0
uint8_t | get_data_from_usart_flag = 0

Detailed Description

tmr program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/tmr.c.


AT32F413 Firmwary Library: usart.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions | Variables
app_led3_toggle/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

usart program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: usart.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions | Variables
app_led4_toggle/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

usart program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/usart.c.


AT32F413 Firmwary Library: usart.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...

Variables

usart_group_type usart_group_struct

Detailed Description

usart program

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/usart.c.


AT32F413 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
app_led3_toggle/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08006000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
app_led4_toggle/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08006000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Functions
bootloader/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08006000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_loop (void)
iap loop More...
void | jump_to_app (uint32_t address)
jump to app More...

Detailed Description

usb config header file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/hid_iap_user.h.


AT32F413 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions | Variables
app_led3_toggle/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...

Variables

void(* pftarget )(void)

Detailed Description

usb hid iap user file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/hid_iap_user.c.


AT32F413 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions | Variables
app_led4_toggle/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...

Variables

void(* pftarget )(void)

Detailed Description

usb hid iap user file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/hid_iap_user.c.


AT32F413 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
iap_result_type | iap_address (uint8_t *pdata, uint32_t len)
iap parse address More...
void | iap_finish (void)
iap_result_type | iap_data_write (uint8_t *pdata, uint32_t len)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
void | jump_to_app (uint32_t address)
jump to app More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_erase_sector (uint32_t address)
set iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_crc (uint8_t *pdata, uint32_t len)
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | iap_loop (void)
iap loop More...

Variables

void(* pftarget )(void)

Detailed Description

usb hid iap user file

                  Copyright notice & Disclaimer

The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/hid_iap_user.c.


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __align() : diskio.c
  • __AT32F413_LIBRARY_VERSION : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MAJOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MIDDLE : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MINOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_RC : at32f413.h
  • __CM4_REV : at32f413.h
  • __FPU_PRESENT : at32f413.h
  • __MPU_PRESENT : at32f413.h
  • __NVIC_PRIO_BITS : at32f413.h
  • __Vendor_SysTickConfig : at32f413.h
  • _asciimap : cdc_keyboard_class.c, keyboard_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • ACC : at32f413_acc.h
  • ACC_BASE : at32f413.h
  • acc_c2_value : project/at_start_f413/examples/acc/calibration/src/main.c
  • ACC_CAL_HICKCAL : at32f413_acc.h
  • ACC_CAL_HICKTRIM : at32f413_acc.h
  • acc_calibration_mode_enable() : at32f413_acc.h, at32f413_acc.c
  • ACC_CALRDY_FLAG : at32f413_acc.h
  • ACC_CALRDYIEN_INT : at32f413_acc.h
  • ACC_EIEN_INT : at32f413_acc.h
  • acc_flag_clear() : at32f413_acc.h, at32f413_acc.c
  • acc_flag_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hickcal_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hicktrim_get() : at32f413_acc.h, at32f413_acc.c
  • acc_interrupt_enable() : at32f413_acc.h, at32f413_acc.c
  • ACC_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c
  • ACC_IRQn : at32f413.h
  • ACC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • acc_read_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c3() : at32f413_acc.h, at32f413_acc.c
  • ACC_RSLOST_FLAG : at32f413_acc.h
  • acc_step_set() : at32f413_acc.h, at32f413_acc.c
  • ACC_TRIM : project/at_start_f413/examples/acc/calibration/src/main.c
  • acc_write_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c3() : at32f413_acc.h, at32f413_acc.c
  • ADC1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH3 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR2CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR4CH4 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH2 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR3CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR4TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8TRGOUT : at32f413_adc.h
  • ADC1_2_IRQHandler() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c
  • ADC1_2_IRQn : at32f413.h
  • ADC1_BASE : at32f413.h
  • ADC1_ETO_GMUX : at32f413_gpio.h
  • ADC1_ETO_MUX : at32f413_gpio.h
  • ADC1_ETP_GMUX : at32f413_gpio.h
  • ADC1_ETP_MUX : at32f413_gpio.h
  • adc1_ordinary_value : project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • adc1_ordinary_valuetab : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc1_preempt_valuetab : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • ADC2 : at32f413_adc.h
  • ADC2_BASE : at32f413.h
  • ADC2_ETO_GMUX : at32f413_gpio.h
  • ADC2_ETO_MUX : at32f413_gpio.h
  • ADC2_ETP_GMUX : at32f413_gpio.h
  • ADC2_ETP_MUX : at32f413_gpio.h
  • adc_base_config() : at32f413_adc.h, at32f413_adc.c
  • adc_base_default_para_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_start() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_status_get() : at32f413_adc.h, at32f413_adc.c
  • ADC_CCE_FLAG : at32f413_adc.h
  • ADC_CCE_INT : at32f413_adc.h
  • ADC_CHANNEL_0 : at32f413_adc.h
  • ADC_CHANNEL_1 : at32f413_adc.h
  • ADC_CHANNEL_10 : at32f413_adc.h
  • ADC_CHANNEL_11 : at32f413_adc.h
  • ADC_CHANNEL_12 : at32f413_adc.h
  • ADC_CHANNEL_13 : at32f413_adc.h
  • ADC_CHANNEL_14 : at32f413_adc.h
  • ADC_CHANNEL_15 : at32f413_adc.h
  • ADC_CHANNEL_16 : at32f413_adc.h
  • ADC_CHANNEL_17 : at32f413_adc.h
  • ADC_CHANNEL_2 : at32f413_adc.h
  • ADC_CHANNEL_3 : at32f413_adc.h
  • ADC_CHANNEL_4 : at32f413_adc.h
  • ADC_CHANNEL_5 : at32f413_adc.h
  • ADC_CHANNEL_6 : at32f413_adc.h
  • ADC_CHANNEL_7 : at32f413_adc.h
  • ADC_CHANNEL_8 : at32f413_adc.h
  • ADC_CHANNEL_9 : at32f413_adc.h
  • adc_channel_select_type : at32f413_adc.h
  • adc_combine_mode_select() : at32f413_adc.h, at32f413_adc.c
  • adc_combine_mode_type : at32f413_adc.h
  • adc_combine_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc_data_align_type : at32f413_adc.h
  • adc_dma_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_clear() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_get() : at32f413_adc.h, at32f413_adc.c
  • ADC_INDEPENDENT_MODE : at32f413_adc.h
  • adc_interrupt_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_LEFT_ALIGNMENT : at32f413_adc.h
  • ADC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • ADC_OCCS_FLAG : at32f413_adc.h
  • adc_ordinary_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • adc_ordinary_part_count_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • adc_ordinary_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_trig_select_type : at32f413_adc.h
  • ADC_PCCE_FLAG : at32f413_adc.h
  • ADC_PCCE_INT : at32f413_adc.h
  • ADC_PCCS_FLAG : at32f413_adc.h
  • adc_preempt_auto_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_PREEMPT_CHANNEL_1 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_2 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_3 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_4 : at32f413_adc.h
  • adc_preempt_channel_length_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_type : at32f413_adc.h
  • adc_preempt_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE : at32f413_adc.h
  • adc_preempt_offset_value_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_PREEMPT_SMLT_ONLY_MODE : at32f413_adc.h
  • adc_preempt_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_trig_select_type : at32f413_adc.h
  • adc_reset() : at32f413_adc.h, at32f413_adc.c
  • ADC_RIGHT_ALIGNMENT : at32f413_adc.h
  • ADC_SAMPLETIME_13_5 : at32f413_adc.h
  • ADC_SAMPLETIME_1_5 : at32f413_adc.h
  • ADC_SAMPLETIME_239_5 : at32f413_adc.h
  • ADC_SAMPLETIME_28_5 : at32f413_adc.h
  • ADC_SAMPLETIME_41_5 : at32f413_adc.h
  • ADC_SAMPLETIME_55_5 : at32f413_adc.h
  • ADC_SAMPLETIME_71_5 : at32f413_adc.h
  • ADC_SAMPLETIME_7_5 : at32f413_adc.h
  • adc_sampletime_select_type : at32f413_adc.h
  • ADC_TEMP_BASE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_TEMP_SLOPE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • adc_tempersensor_vintrv_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_VMONITOR_ALL_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_ALL_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_NONE : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_PREEMPT : at32f413_adc.h
  • ADC_VMOR_FLAG : at32f413_adc.h
  • ADC_VMOR_INT : at32f413_adc.h
  • adc_voltage_monitor_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_single_channel_select() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_threshold_value_set() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitoring_type : at32f413_adc.h
  • ADC_VREF : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADDRESS_OUT_OF_RANGE : cdc_msc_class.h, msc_bot_scsi.h
  • AHBPERIPH_BASE : at32f413.h
  • AIRCR_VECTKEY_MASK : at32f413_misc.c
  • alarm_init() : project/at_start_f413/examples/rtc/calendar/src/main.c
  • ALIGNED_TAIL : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, composite_cdc_msc/msc_bot_scsi.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc/msc_bot_scsi.c, msc_desc.c, printer_class.c, printer_desc.c
  • APB1PERIPH_BASE : at32f413.h
  • APB2PERIPH_BASE : at32f413.h
  • app_load() : bootloader/inc/iap.h, bootloader/src/iap.c
  • app_loop() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c
  • APP_START_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • app_update_handle() : bootloader/src/iap.c
  • arm_apply_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_2pow() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_clip_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_fir_f32() : project_l0/inc/fir_filter.h, project_l1/inc/fir_filter.h
  • arm_fir_init_f32() : project_l0/inc/fir_filter.h, arm_fir_init_f32.c, project_l1/inc/fir_filter.h
  • arm_float_to_q12_20() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q14() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q28() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q29() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q30() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q7() : project_l0/src/math_helper.c, project_l1/src/math_helper.c
  • arm_snr_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • AT32_AUDIO_FREQ_16K : audio_desc.h, audio_hid_desc.h
  • AT32_AUDIO_FREQ_48K : audio_desc.h, audio_hid_desc.h
  • at32_board_init() : at32f413_board.c, at32f413_board.h
  • at32_button_init() : at32f413_board.c, at32f413_board.h
  • at32_button_press() : at32f413_board.c, at32f413_board.h
  • at32_button_state() : at32f413_board.c, at32f413_board.h
  • at32_led_init() : at32f413_board.c, at32f413_board.h
  • at32_led_off() : at32f413_board.c, at32f413_board.h
  • at32_led_on() : at32f413_board.c, at32f413_board.h
  • at32_led_toggle() : at32f413_board.c, at32f413_board.h
  • atr_decode_status : project/at_start_f413/examples/usart/smartcard/src/main.c
  • AUDIO_AC_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_EXTENSION_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_FEATURE_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_HEADER : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_INPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_MIXER_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_OUTPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_PROCESSING_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_SELECTOR_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_SPECIFIC : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_TYPE : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_GENERAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_BCD_NUM : audio_desc.h
  • AUDIO_BINTERVAL_TIME : audio_desc.h
  • AUDIO_BITW_16 : audio/audio_conf.h, audio_hid/audio_conf.h
  • audio_class_handler : audio_class.c, audio_class.h
  • audio_codec : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • audio_codec_init() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_loop() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_get_data() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_modify_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_feedback() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_fifo_write() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • AUDIO_CS_CONFIGURATION : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_DEVICE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_ENDPOINT : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_STRING : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DEFAULT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • audio_desc_handler : audio_desc.c, audio_desc.h
  • AUDIO_DESCRIPTOR_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_DESCRIPTOR_TYPE : audio_class.h, audio_hid_class.h
  • AUDIO_FEATURE_UNIT_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_FEEDBACK_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_FORMAT_TYPE_I : audio_desc.h, audio_hid_desc.h
  • AUDIO_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_SET_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_FU_BASS_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_CONTROL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MID_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MUTE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_TREBLE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_VOLUME_CONTROL : audio_desc.h, audio_hid_desc.h
  • audio_get_interface() : audio_class.c, audio_hid_class.c
  • audio_hid_class_handler : audio_hid_class.c, audio_hid_class.h
  • audio_hid_class_send_report() : audio_hid_class.c, audio_hid_class.h
  • audio_hid_desc_handler : audio_hid_desc.c, audio_hid_desc.h
  • audio_hid_struct : audio_hid_class.c
  • AUDIO_INPUT_TERMINAL_MICROPHONE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_LEN : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_NUM : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_IN_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_MIC_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MUTE_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_OUTPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_SPEAKER : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_PROTOCOL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_REMAIN_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_ENDPOINT : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_INTERFACE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_MASK : audio_class.h, audio_hid_class.h
  • audio_req_get_cur() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_CUR : audio_desc.h, audio_hid_desc.h
  • audio_req_get_max() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MEM : audio_desc.h, audio_hid_desc.h
  • audio_req_get_min() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_RES : audio_desc.h, audio_hid_desc.h
  • audio_req_get_res() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_STAT : audio_desc.h, audio_hid_desc.h
  • audio_req_set_cur() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_SET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQUEST_CODE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • audio_set_interface() : audio_class.c, audio_hid_class.c
  • AUDIO_SPK_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_OUT_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_SPK_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • audio_struct : audio_class.c
  • AUDIO_SUBCLASS_AUDIOCONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOSTREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_MIDISTREMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUPPORT_FEEDBACK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MAX_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MIC : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_SPK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_TERMINAL_TYPE_STREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_VENDOR : audio_desc.h, audio_hid_desc.h
  • AUDIO_VOLUME_CONTROL : audio_class.h, audio_hid_class.h
  • AUHID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BINTERVAL_TIME : audio_hid_desc.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • back_err() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • back_ok() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • BLK2 : at32f413_usb.h
  • BLK32 : at32f413_usb.h
  • BLOCK_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, fir_filter.c
  • BLOCKS_NUMBER : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • bot_cbw_decode() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_allow_medium_removal() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_check_address() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_clear_feature() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_cmd_process() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_datain_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_dataout_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_format_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_init() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_inquiry() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense6() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_read10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_request_sense() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_reset() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_csw() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_data() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_sense_code() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_stall() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_start_stop() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_test_unit() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_verify() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_write10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • BPR : at32f413_bpr.h
  • bpr_addr_tab : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • BPR_BASE : at32f413.h
  • BPR_DATA1 : at32f413_bpr.h
  • BPR_DATA10 : at32f413_bpr.h
  • BPR_DATA11 : at32f413_bpr.h
  • BPR_DATA12 : at32f413_bpr.h
  • BPR_DATA13 : at32f413_bpr.h
  • BPR_DATA14 : at32f413_bpr.h
  • BPR_DATA15 : at32f413_bpr.h
  • BPR_DATA16 : at32f413_bpr.h
  • BPR_DATA17 : at32f413_bpr.h
  • BPR_DATA18 : at32f413_bpr.h
  • BPR_DATA19 : at32f413_bpr.h
  • BPR_DATA2 : at32f413_bpr.h
  • BPR_DATA20 : at32f413_bpr.h
  • BPR_DATA21 : at32f413_bpr.h
  • BPR_DATA22 : at32f413_bpr.h
  • BPR_DATA23 : at32f413_bpr.h
  • BPR_DATA24 : at32f413_bpr.h
  • BPR_DATA25 : at32f413_bpr.h
  • BPR_DATA26 : at32f413_bpr.h
  • BPR_DATA27 : at32f413_bpr.h
  • BPR_DATA28 : at32f413_bpr.h
  • BPR_DATA29 : at32f413_bpr.h
  • BPR_DATA3 : at32f413_bpr.h
  • BPR_DATA30 : at32f413_bpr.h
  • BPR_DATA31 : at32f413_bpr.h
  • BPR_DATA32 : at32f413_bpr.h
  • BPR_DATA33 : at32f413_bpr.h
  • BPR_DATA34 : at32f413_bpr.h
  • BPR_DATA35 : at32f413_bpr.h
  • BPR_DATA36 : at32f413_bpr.h
  • BPR_DATA37 : at32f413_bpr.h
  • BPR_DATA38 : at32f413_bpr.h
  • BPR_DATA39 : at32f413_bpr.h
  • BPR_DATA4 : at32f413_bpr.h
  • BPR_DATA40 : at32f413_bpr.h
  • BPR_DATA41 : at32f413_bpr.h
  • BPR_DATA42 : at32f413_bpr.h
  • BPR_DATA5 : at32f413_bpr.h
  • BPR_DATA6 : at32f413_bpr.h
  • BPR_DATA7 : at32f413_bpr.h
  • BPR_DATA8 : at32f413_bpr.h
  • BPR_DATA9 : at32f413_bpr.h
  • bpr_data_read() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_data_type : at32f413_bpr.h
  • bpr_data_write() : at32f413_bpr.h, at32f413_bpr.c
  • BPR_DR_NUMBER : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_flag_clear() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_flag_get() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_interrupt_enable() : at32f413_bpr.h, at32f413_bpr.c
  • BPR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • bpr_reg_check() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_judge() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_write() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reset() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_clock_calibration_value_set() : at32f413_bpr.h, at32f413_bpr.c
  • BPR_RTC_OUTPUT_ALARM : at32f413_bpr.h
  • BPR_RTC_OUTPUT_ALARM_TOGGLE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_NONE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND_TOGGLE : at32f413_bpr.h
  • bpr_rtc_output_select() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_output_type : at32f413_bpr.h
  • BPR_TAMPER_EVENT_FLAG : at32f413_bpr.h
  • BPR_TAMPER_INTERRUPT_FLAG : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_HIGH : at32f413_bpr.h
  • bpr_tamper_pin_active_level_set() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_tamper_pin_active_level_type : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_LOW : at32f413_bpr.h
  • bpr_tamper_pin_enable() : at32f413_bpr.h, at32f413_bpr.c
  • BUF_SIZE : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • buffer : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • buffer_ch1 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_ch2 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_compare() : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • buffer_compare_24bits() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c
  • buffer_read : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • BUFFER_SIZE : project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • buffer_write : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • BUFFERSIZE : project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • BusFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • BusFault_IRQn : at32f413.h
  • button_exint_init() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/templates/src/main.c
  • button_isr() : project/at_start_f413/templates/src/main.c
  • BUTTON_RELEASE : mouse_class.h
  • button_type : at32f413_board.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • calendar : rtc.h, rtc.c
  • CAN1 : at32f413_can.h
  • CAN1_BASE : at32f413.h
  • CAN1_GMUX_0010 : at32f413_gpio.h
  • CAN1_RX1_IRQn : at32f413.h
  • CAN1_SE_IRQHandler() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • CAN1_SE_IRQn : at32f413.h
  • CAN2_BASE : at32f413.h
  • CAN2_GMUX_0001 : at32f413_gpio.h
  • CAN2_RX0_IRQn : at32f413.h
  • CAN2_RX1_IRQn : at32f413.h
  • CAN2_SE_IRQn : at32f413.h
  • CAN2_TX_IRQn : at32f413.h
  • can_base_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_set() : at32f413_can.h, at32f413_can.c
  • CAN_BOF_FLAG : at32f413_can.h
  • CAN_BOIEN_INT : at32f413_can.h
  • CAN_BTS1_10TQ : at32f413_can.h
  • CAN_BTS1_11TQ : at32f413_can.h
  • CAN_BTS1_12TQ : at32f413_can.h
  • CAN_BTS1_13TQ : at32f413_can.h
  • CAN_BTS1_14TQ : at32f413_can.h
  • CAN_BTS1_15TQ : at32f413_can.h
  • CAN_BTS1_16TQ : at32f413_can.h
  • CAN_BTS1_1TQ : at32f413_can.h
  • CAN_BTS1_2TQ : at32f413_can.h
  • CAN_BTS1_3TQ : at32f413_can.h
  • CAN_BTS1_4TQ : at32f413_can.h
  • CAN_BTS1_5TQ : at32f413_can.h
  • CAN_BTS1_6TQ : at32f413_can.h
  • CAN_BTS1_7TQ : at32f413_can.h
  • CAN_BTS1_8TQ : at32f413_can.h
  • CAN_BTS1_9TQ : at32f413_can.h
  • can_bts1_type : at32f413_can.h
  • CAN_BTS2_1TQ : at32f413_can.h
  • CAN_BTS2_2TQ : at32f413_can.h
  • CAN_BTS2_3TQ : at32f413_can.h
  • CAN_BTS2_4TQ : at32f413_can.h
  • CAN_BTS2_5TQ : at32f413_can.h
  • CAN_BTS2_6TQ : at32f413_can.h
  • CAN_BTS2_7TQ : at32f413_can.h
  • CAN_BTS2_8TQ : at32f413_can.h
  • can_bts2_type : at32f413_can.h
  • can_configuration() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_debug_transmission_prohibit() : at32f413_can.h, at32f413_can.c
  • can_default_para_init() : at32f413_can.h, at32f413_can.c
  • CAN_DISCARDING_FIRST_RECEIVED : at32f413_can.h
  • CAN_DISCARDING_LAST_RECEIVED : at32f413_can.h
  • can_doze_mode_enter() : at32f413_can.h, at32f413_can.c
  • can_doze_mode_exit() : at32f413_can.h, at32f413_can.c
  • CAN_EAF_FLAG : at32f413_can.h
  • CAN_EAIEN_INT : at32f413_can.h
  • CAN_EDZC_FLAG : at32f413_can.h
  • CAN_EDZIEN_INT : at32f413_can.h
  • CAN_ENTER_DOZE_FAILED : at32f413_can.h
  • can_enter_doze_status_type : at32f413_can.h
  • CAN_ENTER_DOZE_SUCCESSFUL : at32f413_can.h
  • CAN_EOIEN_INT : at32f413_can.h
  • CAN_EOIF_FLAG : at32f413_can.h
  • CAN_EPF_FLAG : at32f413_can.h
  • CAN_EPIEN_INT : at32f413_can.h
  • can_error_record_type : at32f413_can.h
  • can_error_type_record_get() : at32f413_can.h, at32f413_can.c
  • CAN_ERRORRECORD_ACKERR : at32f413_can.h
  • CAN_ERRORRECORD_BITDOMINANTERR : at32f413_can.h
  • CAN_ERRORRECORD_BITRECESSIVEERR : at32f413_can.h
  • CAN_ERRORRECORD_CRCERR : at32f413_can.h
  • CAN_ERRORRECORD_FORMERR : at32f413_can.h
  • CAN_ERRORRECORD_NOERR : at32f413_can.h
  • CAN_ERRORRECORD_SOFTWARESETERR : at32f413_can.h
  • CAN_ERRORRECORD_STUFFERR : at32f413_can.h
  • CAN_ETR_FLAG : at32f413_can.h
  • CAN_ETRIEN_INT : at32f413_can.h
  • CAN_FILTER_16BIT : at32f413_can.h
  • CAN_FILTER_32BIT : at32f413_can.h
  • can_filter_bit_width_type : at32f413_can.h
  • can_filter_default_para_init() : at32f413_can.h, at32f413_can.c
  • CAN_FILTER_FIFO0 : at32f413_can.h
  • CAN_FILTER_FIFO1 : at32f413_can.h
  • can_filter_fifo_type : at32f413_can.h
  • can_filter_init() : at32f413_can.h, at32f413_can.c
  • CAN_FILTER_MODE_ID_LIST : at32f413_can.h
  • CAN_FILTER_MODE_ID_MASK : at32f413_can.h
  • can_filter_mode_type : at32f413_can.h
  • can_flag_clear() : at32f413_can.h, at32f413_can.c
  • can_flag_get() : at32f413_can.h, at32f413_can.c
  • can_gpio_config() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • CAN_ID_EXTENDED : at32f413_can.h
  • CAN_ID_STANDARD : at32f413_can.h
  • can_identifier_type : at32f413_can.h
  • can_interrupt_enable() : at32f413_can.h, at32f413_can.c
  • can_message_receive() : at32f413_can.h, at32f413_can.c
  • can_message_transmit() : at32f413_can.h, at32f413_can.c
  • CAN_MODE_COMMUNICATE : at32f413_can.h
  • CAN_MODE_LISTENONLY : at32f413_can.h
  • CAN_MODE_LISTENONLY_LOOPBACK : at32f413_can.h
  • CAN_MODE_LOOPBACK : at32f413_can.h
  • can_mode_type : at32f413_can.h
  • CAN_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • can_msg_discarding_rule_type : at32f413_can.h
  • can_msg_sending_rule_type : at32f413_can.h
  • CAN_MSTS_EDZIF_VAL : at32f413_can.h
  • CAN_MSTS_EOIF_VAL : at32f413_can.h
  • CAN_MSTS_QDZIF_VAL : at32f413_can.h
  • CAN_MUX_10 : at32f413_gpio.h
  • can_operating_mode_set() : at32f413_can.h, at32f413_can.c
  • can_operating_mode_type : at32f413_can.h
  • CAN_OPERATINGMODE_COMMUNICATE : at32f413_can.h
  • CAN_OPERATINGMODE_DOZE : at32f413_can.h
  • CAN_OPERATINGMODE_FREEZE : at32f413_can.h
  • CAN_QDZIEN_INT : at32f413_can.h
  • CAN_QDZIF_FLAG : at32f413_can.h
  • CAN_QUIT_DOZE_FAILED : at32f413_can.h
  • can_quit_doze_status_type : at32f413_can.h
  • CAN_QUIT_DOZE_SUCCESSFUL : at32f413_can.h
  • can_receive_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_receive_fifo_release() : at32f413_can.h, at32f413_can.c
  • can_receive_message_pending_get() : at32f413_can.h, at32f413_can.c
  • can_reset() : at32f413_can.h, at32f413_can.c
  • CAN_RF0_RF0FF_VAL : at32f413_can.h
  • CAN_RF0_RF0OF_VAL : at32f413_can.h
  • CAN_RF0_RF0R_VAL : at32f413_can.h
  • CAN_RF0FF_FLAG : at32f413_can.h
  • CAN_RF0FIEN_INT : at32f413_can.h
  • CAN_RF0MIEN_INT : at32f413_can.h
  • CAN_RF0MN_FLAG : at32f413_can.h
  • CAN_RF0OF_FLAG : at32f413_can.h
  • CAN_RF0OIEN_INT : at32f413_can.h
  • CAN_RF1_RF1FF_VAL : at32f413_can.h
  • CAN_RF1_RF1OF_VAL : at32f413_can.h
  • CAN_RF1_RF1R_VAL : at32f413_can.h
  • CAN_RF1FF_FLAG : at32f413_can.h
  • CAN_RF1FIEN_INT : at32f413_can.h
  • CAN_RF1MIEN_INT : at32f413_can.h
  • CAN_RF1MN_FLAG : at32f413_can.h
  • CAN_RF1OF_FLAG : at32f413_can.h
  • CAN_RF1OIEN_INT : at32f413_can.h
  • CAN_RSAW_1TQ : at32f413_can.h
  • CAN_RSAW_2TQ : at32f413_can.h
  • CAN_RSAW_3TQ : at32f413_can.h
  • CAN_RSAW_4TQ : at32f413_can.h
  • can_rsaw_type : at32f413_can.h
  • CAN_RX_FIFO0 : at32f413_can.h
  • CAN_RX_FIFO1 : at32f413_can.h
  • can_rx_fifo_num_type : at32f413_can.h
  • CAN_SENDING_BY_ID : at32f413_can.h
  • CAN_SENDING_BY_REQUEST : at32f413_can.h
  • CAN_TCIEN_INT : at32f413_can.h
  • CAN_TFT_DATA : at32f413_can.h
  • CAN_TFT_REMOTE : at32f413_can.h
  • CAN_TM0TCF_FLAG : at32f413_can.h
  • CAN_TM1TCF_FLAG : at32f413_can.h
  • CAN_TM2TCF_FLAG : at32f413_can.h
  • CAN_TMEF_FLAG : at32f413_can.h
  • can_trans_frame_type : at32f413_can.h
  • can_transmit_cancel() : at32f413_can.h, at32f413_can.c
  • can_transmit_data() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_transmit_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_transmit_status_get() : at32f413_can.h, at32f413_can.c
  • can_transmit_status_type : at32f413_can.h
  • CAN_TSTS_TM0CT_VAL : at32f413_can.h
  • CAN_TSTS_TM0TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM1CT_VAL : at32f413_can.h
  • CAN_TSTS_TM1TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM2CT_VAL : at32f413_can.h
  • CAN_TSTS_TM2TCF_VAL : at32f413_can.h
  • can_ttc_mode_enable() : at32f413_can.h, at32f413_can.c
  • CAN_TX_MAILBOX0 : at32f413_can.h
  • CAN_TX_MAILBOX1 : at32f413_can.h
  • CAN_TX_MAILBOX2 : at32f413_can.h
  • can_tx_mailbox_num_type : at32f413_can.h
  • CAN_TX_STATUS_FAILED : at32f413_can.h
  • CAN_TX_STATUS_NO_EMPTY : at32f413_can.h
  • CAN_TX_STATUS_PENDING : at32f413_can.h
  • CAN_TX_STATUS_SUCCESSFUL : at32f413_can.h
  • capture : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • capturenumber : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • card_inserted : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_protocol : project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_type : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • CBW_BMCBWFLAGS_DIR_IN : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_BMCBWFLAGS_DIR_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_DCBWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CDC_BCD_NUM : cdc_desc.h, cdc_msc_desc.h
  • cdc_class_handler : cdc_class.c, cdc_class.h
  • cdc_class_setup_handler() : cdc_keyboard_class.c, cdc_msc_class.c
  • cdc_desc_handler : cdc_desc.c, cdc_desc.h
  • CDC_HID_BINTERVAL_TIME : cdc_desc.h, cdc_msc_desc.h
  • cdc_keyboard_class_handler : cdc_keyboard_class.c, cdc_keyboard_class.h
  • cdc_keyboard_desc_handler : cdc_keyboard_desc.c, cdc_keyboard_desc.h
  • cdc_msc_class_handler : cdc_msc_class.c, cdc_msc_class.h
  • cdc_msc_desc_handler : cdc_msc_desc.c, cdc_msc_desc.h
  • cdc_msc_struct : cdc_msc_class.c
  • cdc_struct : cdc_class.c
  • cdc_struct_init() : cdc_class.c, cdc_msc_class.c
  • ch1_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch2_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3readvalue1 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch3readvalue2 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch4_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • channel1_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel2_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel3_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel4_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c
  • check_card_programming() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • cid_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • class_audio_setup_handler() : audio_hid_class.c
  • class_clear_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_rx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_tx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_event_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_hid_setup_handler() : audio_hid_class.c
  • class_in_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_init_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_out_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_setup_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_sof_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • clkout_config() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • clock_failure_detection_handler() : project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • cmd_addr_cnt : bootloader/src/iap.c
  • CMD_CTR_APP : bootloader/inc/iap.h
  • CMD_CTR_DONE : bootloader/inc/iap.h
  • CMD_CTR_ERR : bootloader/inc/iap.h
  • CMD_CTR_IDLE : bootloader/inc/iap.h
  • CMD_CTR_INIT : bootloader/inc/iap.h
  • cmd_ctr_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • cmd_ctr_step_type : bootloader/inc/iap.h
  • CMD_DATA_ADDR : bootloader/inc/iap.h
  • CMD_DATA_BUF : bootloader/inc/iap.h
  • CMD_DATA_CHACK : bootloader/inc/iap.h
  • cmd_data_cnt : bootloader/src/iap.c
  • CMD_DATA_DONE : bootloader/inc/iap.h
  • CMD_DATA_ERR : bootloader/inc/iap.h
  • cmd_data_group_struct : bootloader/src/iap.c
  • cmd_data_group_type_struct : bootloader/inc/iap.h
  • CMD_DATA_IDLE : bootloader/inc/iap.h
  • cmd_data_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • cmd_data_step_type : bootloader/inc/iap.h
  • codec_i2s_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • codec_i2s_reset() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • command_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • command_rsp1_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp2_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp3_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp4_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp5_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp6_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp7_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • config_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • config_flash_interrupt() : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • configASSERT : FreeRTOSConfig.h
  • configCPU_CLOCK_HZ : FreeRTOSConfig.h
  • configIDLE_SHOULD_YIELD : FreeRTOSConfig.h
  • configKERNEL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_LOWEST_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_CO_ROUTINE_PRIORITIES : FreeRTOSConfig.h
  • configMAX_PRIORITIES : FreeRTOSConfig.h
  • configMAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_TASK_NAME_LEN : FreeRTOSConfig.h
  • configMINIMAL_STACK_SIZE : FreeRTOSConfig.h
  • configPRIO_BITS : FreeRTOSConfig.h
  • configSUPPORT_DYNAMIC_ALLOCATION : FreeRTOSConfig.h
  • configTICK_RATE_HZ : FreeRTOSConfig.h
  • configTOTAL_HEAP_SIZE : FreeRTOSConfig.h
  • configUSE_16_BIT_TICKS : FreeRTOSConfig.h
  • configUSE_CO_ROUTINES : FreeRTOSConfig.h
  • configUSE_IDLE_HOOK : FreeRTOSConfig.h
  • configUSE_PREEMPTION : FreeRTOSConfig.h
  • configUSE_TICK_HOOK : FreeRTOSConfig.h
  • confirm_state : at32f413.h
  • CONVERT_ENDIAN : hid_iap_class.h
  • convert_from_bytes_to_power_of_two() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • copy_buff() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • counter : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • COUNTOF : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • CRC : at32f413_crc.h
  • crc1_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • crc2_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • CRC_BASE : at32f413.h
  • crc_block_calculate() : at32f413_crc.h, at32f413_crc.c
  • crc_cal() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • crc_common_data_get() : at32f413_crc.h, at32f413_crc.c
  • crc_common_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_data_get() : at32f413_crc.h, at32f413_crc.c
  • crc_data_reset() : at32f413_crc.h, at32f413_crc.c
  • crc_init_data_set() : at32f413_crc.h, at32f413_crc.c
  • CRC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • crc_one_word_calculate() : at32f413_crc.h, at32f413_crc.c
  • CRC_POLY_SIZE_16B : at32f413_crc.h
  • CRC_POLY_SIZE_32B : at32f413_crc.h
  • CRC_POLY_SIZE_7B : at32f413_crc.h
  • CRC_POLY_SIZE_8B : at32f413_crc.h
  • crc_poly_size_get() : at32f413_crc.h, at32f413_crc.c
  • crc_poly_size_set() : at32f413_crc.h, at32f413_crc.c
  • crc_poly_size_type : at32f413_crc.h
  • crc_poly_value_get() : at32f413_crc.h, at32f413_crc.c
  • crc_poly_value_set() : at32f413_crc.h, at32f413_crc.c
  • CRC_REVERSE_INPUT_BY_BYTE : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_HALFWORD : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_WORD : at32f413_crc.h
  • crc_reverse_input_data_set() : at32f413_crc.h, at32f413_crc.c
  • CRC_REVERSE_INPUT_NO_AFFECTE : at32f413_crc.h
  • crc_reverse_input_type : at32f413_crc.h
  • CRC_REVERSE_OUTPUT_DATA : at32f413_crc.h
  • crc_reverse_output_data_set() : at32f413_crc.h, at32f413_crc.c
  • CRC_REVERSE_OUTPUT_NO_AFFECTE : at32f413_crc.h
  • crc_reverse_output_type : at32f413_crc.h
  • crc_value : project/at_start_f413/examples/crc/calculation/src/main.c
  • CRM : at32f413_crm.h
  • CRM_ACC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ACC_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC1_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC2_PERIPH_RESET : at32f413_crm.h
  • crm_adc_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • CRM_ADC_DIV_12 : at32f413_crm.h
  • CRM_ADC_DIV_16 : at32f413_crm.h
  • CRM_ADC_DIV_2 : at32f413_crm.h
  • CRM_ADC_DIV_4 : at32f413_crm.h
  • CRM_ADC_DIV_6 : at32f413_crm.h
  • CRM_ADC_DIV_8 : at32f413_crm.h
  • crm_adc_div_type : at32f413_crm.h
  • CRM_AHB_DIV_1 : at32f413_crm.h
  • CRM_AHB_DIV_128 : at32f413_crm.h
  • CRM_AHB_DIV_16 : at32f413_crm.h
  • CRM_AHB_DIV_2 : at32f413_crm.h
  • CRM_AHB_DIV_256 : at32f413_crm.h
  • CRM_AHB_DIV_4 : at32f413_crm.h
  • CRM_AHB_DIV_512 : at32f413_crm.h
  • CRM_AHB_DIV_64 : at32f413_crm.h
  • CRM_AHB_DIV_8 : at32f413_crm.h
  • crm_ahb_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_ahb_div_type : at32f413_crm.h
  • CRM_ALL_RESET_FLAG : at32f413_crm.h
  • CRM_APB1_DIV_1 : at32f413_crm.h
  • CRM_APB1_DIV_16 : at32f413_crm.h
  • CRM_APB1_DIV_2 : at32f413_crm.h
  • CRM_APB1_DIV_4 : at32f413_crm.h
  • CRM_APB1_DIV_8 : at32f413_crm.h
  • crm_apb1_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb1_div_type : at32f413_crm.h
  • CRM_APB2_DIV_1 : at32f413_crm.h
  • CRM_APB2_DIV_16 : at32f413_crm.h
  • CRM_APB2_DIV_2 : at32f413_crm.h
  • CRM_APB2_DIV_4 : at32f413_crm.h
  • CRM_APB2_DIV_8 : at32f413_crm.h
  • crm_apb2_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb2_div_type : at32f413_crm.h
  • CRM_AUTO_STEP_MODE_DISABLE : at32f413_crm.h
  • CRM_AUTO_STEP_MODE_ENABLE : at32f413_crm.h
  • crm_auto_step_mode_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_auto_step_mode_type : at32f413_crm.h
  • CRM_BASE : at32f413.h
  • crm_battery_powered_domain_reset() : at32f413_crm.h, at32f413_crm.c
  • CRM_BPR_PERIPH_CLOCK : at32f413_crm.h
  • CRM_BPR_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN1_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN2_PERIPH_RESET : at32f413_crm.h
  • CRM_CLKOUT_ADC : at32f413_crm.h
  • CRM_CLKOUT_DIV_1 : at32f413_crm.h
  • CRM_CLKOUT_DIV_128 : at32f413_crm.h
  • CRM_CLKOUT_DIV_16 : at32f413_crm.h
  • CRM_CLKOUT_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_DIV_256 : at32f413_crm.h
  • CRM_CLKOUT_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_DIV_512 : at32f413_crm.h
  • CRM_CLKOUT_DIV_64 : at32f413_crm.h
  • CRM_CLKOUT_DIV_8 : at32f413_crm.h
  • crm_clkout_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clkout_div_type : at32f413_crm.h
  • CRM_CLKOUT_HEXT : at32f413_crm.h
  • CRM_CLKOUT_HICK : at32f413_crm.h
  • CRM_CLKOUT_LEXT : at32f413_crm.h
  • CRM_CLKOUT_LICK : at32f413_crm.h
  • CRM_CLKOUT_NOCLK : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_SCLK : at32f413_crm.h
  • crm_clkout_select_type : at32f413_crm.h
  • crm_clkout_to_tmr10_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_CLKOUT_USB : at32f413_crm.h
  • crm_clock_failure_detection_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_CLOCK_FAILURE_INT : at32f413_crm.h
  • CRM_CLOCK_FAILURE_INT_FLAG : at32f413_crm.h
  • crm_clock_out_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_source_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_CLOCK_SOURCE_HEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_PLL : at32f413_crm.h
  • crm_clock_source_type : at32f413_crm.h
  • crm_clocks : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • crm_clocks_freq_get() : at32f413_crm.h, at32f413_crm.c
  • crm_clocks_freq_struct : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • crm_configuration() : project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • CRM_CRC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_EXINT_PERIPH_RESET : at32f413_crm.h
  • crm_flag_clear() : at32f413_crm.h, at32f413_crm.c
  • crm_flag_get() : at32f413_crm.h, at32f413_crm.c
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_GPIOA_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOA_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOB_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOC_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOD_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOD_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOF_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOF_PERIPH_RESET : at32f413_crm.h
  • crm_hext_bypass() : at32f413_crm.h, at32f413_crm.c
  • CRM_HEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_INT : at32f413_crm.h
  • crm_hext_stable_wait() : at32f413_crm.h, at32f413_crm.c
  • CRM_HICK48_DIV6 : at32f413_crm.h
  • CRM_HICK48_NODIV : at32f413_crm.h
  • crm_hick_clock_calibration_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_clock_trimming_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_div_6_type : at32f413_crm.h
  • crm_hick_divider_select() : at32f413_crm.h, at32f413_crm.c
  • CRM_HICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_HICK_SCLK_48MHZ : at32f413_crm.h
  • CRM_HICK_SCLK_8MHZ : at32f413_crm.h
  • crm_hick_sclk_frequency_select() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_sclk_frequency_type : at32f413_crm.h
  • CRM_HICK_STABLE_FLAG : at32f413_crm.h
  • CRM_HICK_STABLE_INT : at32f413_crm.h
  • CRM_I2C1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C1_PERIPH_RESET : at32f413_crm.h
  • CRM_I2C2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C2_PERIPH_RESET : at32f413_crm.h
  • crm_interrupt_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_IOMUX_PERIPH_CLOCK : at32f413_crm.h
  • CRM_IOMUX_PERIPH_RESET : at32f413_crm.h
  • CRM_IRQn : at32f413.h
  • crm_lext_bypass() : at32f413_crm.h, at32f413_crm.c
  • CRM_LEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_INT : at32f413_crm.h
  • CRM_LICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_INT : at32f413_crm.h
  • CRM_LOWPOWER_RESET_FLAG : at32f413_crm.h
  • CRM_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CRM_NRST_RESET_FLAG : at32f413_crm.h
  • crm_periph_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_clock_sleepmd_type : at32f413_crm.h
  • crm_periph_clock_type : at32f413_crm.h
  • crm_periph_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_reset_type : at32f413_crm.h
  • crm_periph_sleep_mode_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_pll_clock_source_type : at32f413_crm.h
  • crm_pll_config() : at32f413_crm.h, at32f413_crm.c
  • CRM_PLL_MULT_10 : at32f413_crm.h
  • CRM_PLL_MULT_11 : at32f413_crm.h
  • CRM_PLL_MULT_12 : at32f413_crm.h
  • CRM_PLL_MULT_13 : at32f413_crm.h
  • CRM_PLL_MULT_14 : at32f413_crm.h
  • CRM_PLL_MULT_15 : at32f413_crm.h
  • CRM_PLL_MULT_16 : at32f413_crm.h
  • CRM_PLL_MULT_17 : at32f413_crm.h
  • CRM_PLL_MULT_18 : at32f413_crm.h
  • CRM_PLL_MULT_19 : at32f413_crm.h
  • CRM_PLL_MULT_2 : at32f413_crm.h
  • CRM_PLL_MULT_20 : at32f413_crm.h
  • CRM_PLL_MULT_21 : at32f413_crm.h
  • CRM_PLL_MULT_22 : at32f413_crm.h
  • CRM_PLL_MULT_23 : at32f413_crm.h
  • CRM_PLL_MULT_24 : at32f413_crm.h
  • CRM_PLL_MULT_25 : at32f413_crm.h
  • CRM_PLL_MULT_26 : at32f413_crm.h
  • CRM_PLL_MULT_27 : at32f413_crm.h
  • CRM_PLL_MULT_28 : at32f413_crm.h
  • CRM_PLL_MULT_29 : at32f413_crm.h
  • CRM_PLL_MULT_3 : at32f413_crm.h
  • CRM_PLL_MULT_30 : at32f413_crm.h
  • CRM_PLL_MULT_31 : at32f413_crm.h
  • CRM_PLL_MULT_32 : at32f413_crm.h
  • CRM_PLL_MULT_33 : at32f413_crm.h
  • CRM_PLL_MULT_34 : at32f413_crm.h
  • CRM_PLL_MULT_35 : at32f413_crm.h
  • CRM_PLL_MULT_36 : at32f413_crm.h
  • CRM_PLL_MULT_37 : at32f413_crm.h
  • CRM_PLL_MULT_38 : at32f413_crm.h
  • CRM_PLL_MULT_39 : at32f413_crm.h
  • CRM_PLL_MULT_4 : at32f413_crm.h
  • CRM_PLL_MULT_40 : at32f413_crm.h
  • CRM_PLL_MULT_41 : at32f413_crm.h
  • CRM_PLL_MULT_42 : at32f413_crm.h
  • CRM_PLL_MULT_43 : at32f413_crm.h
  • CRM_PLL_MULT_44 : at32f413_crm.h
  • CRM_PLL_MULT_45 : at32f413_crm.h
  • CRM_PLL_MULT_46 : at32f413_crm.h
  • CRM_PLL_MULT_47 : at32f413_crm.h
  • CRM_PLL_MULT_48 : at32f413_crm.h
  • CRM_PLL_MULT_49 : at32f413_crm.h
  • CRM_PLL_MULT_5 : at32f413_crm.h
  • CRM_PLL_MULT_50 : at32f413_crm.h
  • CRM_PLL_MULT_51 : at32f413_crm.h
  • CRM_PLL_MULT_52 : at32f413_crm.h
  • CRM_PLL_MULT_53 : at32f413_crm.h
  • CRM_PLL_MULT_54 : at32f413_crm.h
  • CRM_PLL_MULT_55 : at32f413_crm.h
  • CRM_PLL_MULT_56 : at32f413_crm.h
  • CRM_PLL_MULT_57 : at32f413_crm.h
  • CRM_PLL_MULT_58 : at32f413_crm.h
  • CRM_PLL_MULT_59 : at32f413_crm.h
  • CRM_PLL_MULT_6 : at32f413_crm.h
  • CRM_PLL_MULT_60 : at32f413_crm.h
  • CRM_PLL_MULT_61 : at32f413_crm.h
  • CRM_PLL_MULT_62 : at32f413_crm.h
  • CRM_PLL_MULT_63 : at32f413_crm.h
  • CRM_PLL_MULT_64 : at32f413_crm.h
  • CRM_PLL_MULT_7 : at32f413_crm.h
  • CRM_PLL_MULT_8 : at32f413_crm.h
  • CRM_PLL_MULT_9 : at32f413_crm.h
  • crm_pll_mult_type : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ : at32f413_crm.h
  • crm_pll_output_range_type : at32f413_crm.h
  • CRM_PLL_READY_INT_FLAG : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT_DIV : at32f413_crm.h
  • CRM_PLL_SOURCE_HICK : at32f413_crm.h
  • CRM_PLL_STABLE_FLAG : at32f413_crm.h
  • CRM_PLL_STABLE_INT : at32f413_crm.h
  • CRM_POR_RESET_FLAG : at32f413_crm.h
  • CRM_PWC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_PWC_PERIPH_RESET : at32f413_crm.h
  • CRM_REG : at32f413_crm.h
  • CRM_REG_BIT : at32f413_crm.h
  • crm_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_RTC_CLOCK_HEXT_DIV : at32f413_crm.h
  • CRM_RTC_CLOCK_LEXT : at32f413_crm.h
  • CRM_RTC_CLOCK_LICK : at32f413_crm.h
  • CRM_RTC_CLOCK_NOCLK : at32f413_crm.h
  • crm_rtc_clock_select() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_type : at32f413_crm.h
  • CRM_SCLK_HEXT : at32f413_crm.h
  • CRM_SCLK_HICK : at32f413_crm.h
  • CRM_SCLK_PLL : at32f413_crm.h
  • crm_sclk_type : at32f413_crm.h
  • CRM_SDIO1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_RESET : at32f413_crm.h
  • CRM_SPI2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI2_PERIPH_RESET : at32f413_crm.h
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_SW_RESET_FLAG : at32f413_crm.h
  • crm_sysclk_switch() : at32f413_crm.h, at32f413_crm.c
  • crm_sysclk_switch_status_get() : at32f413_crm.h, at32f413_crm.c
  • CRM_TMR10_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR10_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR11_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR11_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR1_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR2_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR3_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR4_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR5_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR8_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR8_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR9_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR9_PERIPH_RESET : at32f413_crm.h
  • CRM_UART4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART4_PERIPH_RESET : at32f413_crm.h
  • CRM_UART5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART5_PERIPH_RESET : at32f413_crm.h
  • CRM_USART1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART1_PERIPH_RESET : at32f413_crm.h
  • CRM_USART2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART2_PERIPH_RESET : at32f413_crm.h
  • CRM_USART3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART3_PERIPH_RESET : at32f413_crm.h
  • crm_usb_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • CRM_USB_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_USB_CLOCK_SOURCE_PLL : at32f413_crm.h
  • crm_usb_clock_source_select() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_clock_source_type : at32f413_crm.h
  • CRM_USB_DIV_1 : at32f413_crm.h
  • CRM_USB_DIV_1_5 : at32f413_crm.h
  • CRM_USB_DIV_2 : at32f413_crm.h
  • CRM_USB_DIV_2_5 : at32f413_crm.h
  • CRM_USB_DIV_3 : at32f413_crm.h
  • CRM_USB_DIV_3_5 : at32f413_crm.h
  • CRM_USB_DIV_4 : at32f413_crm.h
  • crm_usb_div_type : at32f413_crm.h
  • CRM_USB_INT19_INT20 : at32f413_crm.h
  • CRM_USB_INT73_INT74 : at32f413_crm.h
  • crm_usb_int_map_type : at32f413_crm.h
  • crm_usb_interrupt_remapping_set() : at32f413_crm.h, at32f413_crm.c
  • CRM_USB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USB_PERIPH_RESET : at32f413_crm.h
  • CRM_WDT_RESET_FLAG : at32f413_crm.h
  • CRM_WWDT_PERIPH_CLOCK : at32f413_crm.h
  • CRM_WWDT_PERIPH_RESET : at32f413_crm.h
  • CRM_WWDT_RESET_FLAG : at32f413_crm.h
  • csd_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • CSW_BCSWSTATUS_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PASS : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PHASE_ERR : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_DCSWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CUSHID_BCD_NUM : custom_hid_desc.h
  • CUSHID_BINTERVAL_TIME : custom_hid_desc.h
  • custom_hid_class_handler : custom_hid_class.c, custom_hid_class.h
  • custom_hid_class_send_report() : custom_hid_class.c, custom_hid_class.h
  • custom_hid_desc_handler : custom_hid_desc.c, custom_hid_desc.h
  • custom_hid_struct : custom_hid_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • DATA1_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA2_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA3_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA4_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • data_buffer : project/at_start_f413/examples/crc/calculation/src/main.c
  • data_count : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • data_counter_end : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • data_take() : bootloader/src/iap.c
  • data_trans_dir : at32f413_usb.h
  • DATA_TRANS_IN : at32f413_usb.h
  • DATA_TRANS_OUT : at32f413_usb.h
  • DEBUG_BASE : at32f413.h
  • DEBUG_CAN1_PAUSE : at32f413_debug.h
  • DEBUG_CAN2_PAUSE : at32f413_debug.h
  • DEBUG_DEEPSLEEP : at32f413_debug.h
  • debug_device_id_get() : at32f413_debug.h, at32f413_debug.c
  • DEBUG_I2C1_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_I2C2_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • debug_periph_mode_set() : at32f413_debug.h, at32f413_debug.c
  • DEBUG_SLEEP : at32f413_debug.h
  • DEBUG_STANDBY : at32f413_debug.h
  • DEBUG_TMR10_PAUSE : at32f413_debug.h
  • DEBUG_TMR11_PAUSE : at32f413_debug.h
  • DEBUG_TMR1_PAUSE : at32f413_debug.h
  • DEBUG_TMR2_PAUSE : at32f413_debug.h
  • DEBUG_TMR3_PAUSE : at32f413_debug.h
  • DEBUG_TMR4_PAUSE : at32f413_debug.h
  • DEBUG_TMR5_PAUSE : at32f413_debug.h
  • DEBUG_TMR8_PAUSE : at32f413_debug.h
  • DEBUG_TMR9_PAUSE : at32f413_debug.h
  • DEBUG_WDT_PAUSE : at32f413_debug.h
  • DEBUG_WWDT_PAUSE : at32f413_debug.h
  • DEBUGMCU : at32f413_debug.h
  • DebugMon_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • DebugMonitor_IRQn : at32f413.h
  • delay() : project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c
  • DELAY : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/templates/src/main.c
  • delay_init() : at32f413_board.c, at32f413_board.h
  • delay_ms() : at32f413_board.c, at32f413_board.h
  • delay_sec() : at32f413_board.c, at32f413_board.h
  • delay_us() : at32f413_board.c, at32f413_board.h
  • DEV_MMC : diskio.c
  • DEV_RAM : diskio.c
  • DEV_USB : diskio.c
  • device_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • DEVICE_ID_ADDR1 : random.c
  • device_mode : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • disk_initialize() : diskio.c
  • disk_ioctl() : diskio.c
  • disk_read() : diskio.c
  • disk_status() : diskio.c
  • disk_write() : diskio.c
  • div_value : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c
  • DMA1 : at32f413_dma.h
  • DMA1_BASE : at32f413.h
  • DMA1_CHANNEL1 : at32f413_dma.h
  • DMA1_CHANNEL1_BASE : at32f413.h
  • DMA1_Channel1_IRQHandler() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel1_IRQn : at32f413.h
  • DMA1_CHANNEL2 : at32f413_dma.h
  • DMA1_CHANNEL2_BASE : at32f413.h
  • DMA1_Channel2_IRQHandler() : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel2_IRQn : at32f413.h
  • DMA1_CHANNEL3 : at32f413_dma.h
  • DMA1_CHANNEL3_BASE : at32f413.h
  • DMA1_Channel3_IRQHandler() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel3_IRQn : at32f413.h
  • DMA1_CHANNEL4 : at32f413_dma.h
  • DMA1_CHANNEL4_BASE : at32f413.h
  • DMA1_Channel4_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel4_IRQn : at32f413.h
  • DMA1_CHANNEL5 : at32f413_dma.h
  • DMA1_CHANNEL5_BASE : at32f413.h
  • DMA1_Channel5_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • DMA1_Channel5_IRQn : at32f413.h
  • DMA1_CHANNEL6 : at32f413_dma.h
  • DMA1_CHANNEL6_BASE : at32f413.h
  • DMA1_Channel6_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA1_Channel6_IRQn : at32f413.h
  • DMA1_CHANNEL7 : at32f413_dma.h
  • DMA1_CHANNEL7_BASE : at32f413.h
  • DMA1_Channel7_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA1_Channel7_IRQn : at32f413.h
  • DMA1_DTERR1_FLAG : at32f413_dma.h
  • DMA1_DTERR2_FLAG : at32f413_dma.h
  • DMA1_DTERR3_FLAG : at32f413_dma.h
  • DMA1_DTERR4_FLAG : at32f413_dma.h
  • DMA1_DTERR5_FLAG : at32f413_dma.h
  • DMA1_DTERR6_FLAG : at32f413_dma.h
  • DMA1_DTERR7_FLAG : at32f413_dma.h
  • DMA1_FDT1_FLAG : at32f413_dma.h
  • DMA1_FDT2_FLAG : at32f413_dma.h
  • DMA1_FDT3_FLAG : at32f413_dma.h
  • DMA1_FDT4_FLAG : at32f413_dma.h
  • DMA1_FDT5_FLAG : at32f413_dma.h
  • DMA1_FDT6_FLAG : at32f413_dma.h
  • DMA1_FDT7_FLAG : at32f413_dma.h
  • DMA1_GL1_FLAG : at32f413_dma.h
  • DMA1_GL2_FLAG : at32f413_dma.h
  • DMA1_GL3_FLAG : at32f413_dma.h
  • DMA1_GL4_FLAG : at32f413_dma.h
  • DMA1_GL5_FLAG : at32f413_dma.h
  • DMA1_GL6_FLAG : at32f413_dma.h
  • DMA1_GL7_FLAG : at32f413_dma.h
  • DMA1_HDT1_FLAG : at32f413_dma.h
  • DMA1_HDT2_FLAG : at32f413_dma.h
  • DMA1_HDT3_FLAG : at32f413_dma.h
  • DMA1_HDT4_FLAG : at32f413_dma.h
  • DMA1_HDT5_FLAG : at32f413_dma.h
  • DMA1_HDT6_FLAG : at32f413_dma.h
  • DMA1_HDT7_FLAG : at32f413_dma.h
  • dma1_trans_complete_flag : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c
  • DMA2 : at32f413_dma.h
  • DMA2_BASE : at32f413.h
  • DMA2_CHANNEL1 : at32f413_dma.h
  • DMA2_CHANNEL1_BASE : at32f413.h
  • DMA2_Channel1_IRQHandler() : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c
  • DMA2_Channel1_IRQn : at32f413.h
  • DMA2_CHANNEL2 : at32f413_dma.h
  • DMA2_CHANNEL2_BASE : at32f413.h
  • DMA2_Channel2_IRQn : at32f413.h
  • DMA2_CHANNEL3 : at32f413_dma.h
  • DMA2_CHANNEL3_BASE : at32f413.h
  • DMA2_Channel3_IRQn : at32f413.h
  • DMA2_CHANNEL4 : at32f413_dma.h
  • DMA2_Channel4_5_IRQn : at32f413.h
  • DMA2_CHANNEL4_BASE : at32f413.h
  • DMA2_CHANNEL5 : at32f413_dma.h
  • DMA2_CHANNEL5_BASE : at32f413.h
  • DMA2_CHANNEL6 : at32f413_dma.h
  • DMA2_Channel6_7_IRQn : at32f413.h
  • DMA2_CHANNEL6_BASE : at32f413.h
  • DMA2_CHANNEL7 : at32f413_dma.h
  • DMA2_CHANNEL7_BASE : at32f413.h
  • DMA2_DTERR1_FLAG : at32f413_dma.h
  • DMA2_DTERR2_FLAG : at32f413_dma.h
  • DMA2_DTERR3_FLAG : at32f413_dma.h
  • DMA2_DTERR4_FLAG : at32f413_dma.h
  • DMA2_DTERR5_FLAG : at32f413_dma.h
  • DMA2_DTERR6_FLAG : at32f413_dma.h
  • DMA2_DTERR7_FLAG : at32f413_dma.h
  • DMA2_FDT1_FLAG : at32f413_dma.h
  • DMA2_FDT2_FLAG : at32f413_dma.h
  • DMA2_FDT3_FLAG : at32f413_dma.h
  • DMA2_FDT4_FLAG : at32f413_dma.h
  • DMA2_FDT5_FLAG : at32f413_dma.h
  • DMA2_FDT6_FLAG : at32f413_dma.h
  • DMA2_FDT7_FLAG : at32f413_dma.h
  • DMA2_GL1_FLAG : at32f413_dma.h
  • DMA2_GL2_FLAG : at32f413_dma.h
  • DMA2_GL3_FLAG : at32f413_dma.h
  • DMA2_GL4_FLAG : at32f413_dma.h
  • DMA2_GL5_FLAG : at32f413_dma.h
  • DMA2_GL6_FLAG : at32f413_dma.h
  • DMA2_GL7_FLAG : at32f413_dma.h
  • DMA2_HDT1_FLAG : at32f413_dma.h
  • DMA2_HDT2_FLAG : at32f413_dma.h
  • DMA2_HDT3_FLAG : at32f413_dma.h
  • DMA2_HDT4_FLAG : at32f413_dma.h
  • DMA2_HDT5_FLAG : at32f413_dma.h
  • DMA2_HDT6_FLAG : at32f413_dma.h
  • DMA2_HDT7_FLAG : at32f413_dma.h
  • DMA_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • dma_channel_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • dma_configuration() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • dma_data_number_get() : at32f413_dma.h, at32f413_dma.c
  • dma_data_number_set() : at32f413_dma.h, at32f413_dma.c
  • dma_default_para_init() : at32f413_dma.h, at32f413_dma.c
  • DMA_DIR_MEMORY_TO_MEMORY : at32f413_dma.h
  • DMA_DIR_MEMORY_TO_PERIPHERAL : at32f413_dma.h
  • DMA_DIR_PERIPHERAL_TO_MEMORY : at32f413_dma.h
  • dma_dir_type : at32f413_dma.h
  • DMA_DTERR_INT : at32f413_dma.h
  • DMA_FDT_INT : at32f413_dma.h
  • dma_flag_clear() : at32f413_dma.h, at32f413_dma.c
  • dma_flag_get() : at32f413_dma.h, at32f413_dma.c
  • DMA_FLEXIBLE_ADC1 : at32f413_dma.h
  • dma_flexible_config() : at32f413_dma.h, at32f413_dma.c
  • DMA_FLEXIBLE_I2C1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_TX : at32f413_dma.h
  • dma_flexible_request_type : at32f413_dma.h
  • DMA_FLEXIBLE_SDIO1 : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_TX : at32f413_dma.h
  • DMA_GET_HT_FLAG : i2c_application.c
  • DMA_GET_TC_FLAG : i2c_application.c
  • DMA_GET_TERR_FLAG : i2c_application.c
  • DMA_HDT_INT : at32f413_dma.h
  • dma_init() : at32f413_dma.h, at32f413_dma.c
  • dma_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • dma_init_structure : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dma_interrupt_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_memory_data_size_type : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_MEMORY_INC_DISABLE : at32f413_dma.h
  • DMA_MEMORY_INC_ENABLE : at32f413_dma.h
  • dma_memory_inc_type : at32f413_dma.h
  • DMA_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • dma_peripheral_data_size_type : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_PERIPHERAL_INC_DISABLE : at32f413_dma.h
  • DMA_PERIPHERAL_INC_ENABLE : at32f413_dma.h
  • dma_peripheral_inc_type : at32f413_dma.h
  • DMA_PRIORITY_HIGH : at32f413_dma.h
  • dma_priority_level_type : at32f413_dma.h
  • DMA_PRIORITY_LOW : at32f413_dma.h
  • DMA_PRIORITY_MEDIUM : at32f413_dma.h
  • DMA_PRIORITY_VERY_HIGH : at32f413_dma.h
  • dma_reset() : at32f413_dma.h, at32f413_dma.c
  • dma_trans_complete_flag : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • DOWN_MOVE : mouse_class.h
  • dst_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • duty_cycle : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • duty_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dw_data_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_end_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • DYMMY_BYTE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • DZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • ENABLE_RTC_ASSEED : random.h
  • EPT0_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT0_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT_BULK_TYPE : at32f413_usb.h
  • EPT_CONTROL_TYPE : at32f413_usb.h
  • EPT_IN : at32f413_usb.h
  • ept_inout_type : at32f413_usb.h
  • EPT_INT_TYPE : at32f413_usb.h
  • EPT_ISO_TYPE : at32f413_usb.h
  • EPT_OUT : at32f413_usb.h
  • ept_trans_type : at32f413_usb.h
  • ERASE_TIMEOUT : at32f413_flash.h
  • ERROR : at32f413.h
  • error_handler() : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • ERROR_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • error_status : at32f413.h
  • EXINT : at32f413_exint.h
  • EXINT0_IRQHandler() : project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/templates/src/main.c
  • EXINT0_IRQn : at32f413.h
  • EXINT15_10_IRQn : at32f413.h
  • EXINT1_IRQn : at32f413.h
  • EXINT2_IRQn : at32f413.h
  • EXINT3_IRQn : at32f413.h
  • EXINT4_IRQHandler() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • EXINT4_IRQn : at32f413.h
  • EXINT9_5_IRQHandler() : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • EXINT9_5_IRQn : at32f413.h
  • EXINT_BASE : at32f413.h
  • exint_config() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • exint_default_para_init() : at32f413_exint.h, at32f413_exint.c
  • exint_event_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_clear() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_get() : at32f413_exint.h, at32f413_exint.c
  • exint_init() : at32f413_exint.h, at32f413_exint.c
  • exint_interrupt_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_line0_config() : project/at_start_f413/examples/exint/exint_config/src/main.c
  • exint_line4_config() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • EXINT_LINE_0 : at32f413_exint.h
  • EXINT_LINE_1 : at32f413_exint.h
  • EXINT_LINE_10 : at32f413_exint.h
  • EXINT_LINE_11 : at32f413_exint.h
  • EXINT_LINE_12 : at32f413_exint.h
  • EXINT_LINE_13 : at32f413_exint.h
  • EXINT_LINE_14 : at32f413_exint.h
  • EXINT_LINE_15 : at32f413_exint.h
  • EXINT_LINE_16 : at32f413_exint.h
  • EXINT_LINE_17 : at32f413_exint.h
  • EXINT_LINE_18 : at32f413_exint.h
  • EXINT_LINE_2 : at32f413_exint.h
  • EXINT_LINE_3 : at32f413_exint.h
  • EXINT_LINE_4 : at32f413_exint.h
  • EXINT_LINE_5 : at32f413_exint.h
  • EXINT_LINE_6 : at32f413_exint.h
  • EXINT_LINE_7 : at32f413_exint.h
  • EXINT_LINE_8 : at32f413_exint.h
  • EXINT_LINE_9 : at32f413_exint.h
  • EXINT_LINE_EVENT : at32f413_exint.h
  • EXINT_LINE_INTERRUPUT : at32f413_exint.h
  • exint_line_mode_type : at32f413_exint.h
  • EXINT_LINE_NONE : at32f413_exint.h
  • EXINT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • exint_polarity_config_type : at32f413_exint.h
  • exint_reset() : at32f413_exint.h, at32f413_exint.c
  • exint_software_interrupt_event_generate() : at32f413_exint.h, at32f413_exint.c
  • EXINT_TRIGGER_BOTH_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_FALLING_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_RISING_EDGE : at32f413_exint.h
  • EXT_CSD_BUS_WIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Clear_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_CPSECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_NORMAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_SECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Command_set : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_HS_TIMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Set_bit : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Write_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_SPIM_EN_MUX : at32f413_gpio.h
  • EXT_SPIM_GMUX_1000 : at32f413_gpio.h
  • EXT_SPIM_GMUX_1001 : at32f413_gpio.h
  • extend_sram() : project/at_start_f413/examples/sram/extend_sram/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • fac_ms : at32f413_board.c
  • fac_us : at32f413_board.c
  • FALSE : at32f413.h
  • FAP_RELIEVE_KEY : at32f413_flash.h
  • FAST : project/at_start_f413/templates/src/main.c
  • FAT16_BYTE_PER_SIZE : flash_fat16.h
  • FAT16_DIR_SIZE : flash_fat16.h
  • fat16_file_name : flash_fat16.c
  • FAT16_FILENAME_SIZE : flash_fat16.h
  • fat16_memory_cmp() : flash_fat16.c
  • fat16_memory_copy() : flash_fat16.c
  • fat16_memory_memset() : flash_fat16.c
  • fat16_root_dir_sector : flash_fat16.c
  • fat16_sector : flash_fat16.c
  • FAT16_SECTOR_SIZE : flash_fat16.h, flash_fat16.c
  • fat16_table_sector0 : flash_fat16.c
  • FAT16_TABLE_SIZE : flash_fat16.h
  • fatfs_test() : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • FEEDBACK_REFRESH_TIME : audio_class.h, audio_hid_class.h
  • FF_CODE_PAGE : ffconf.h
  • FF_FS_EXFAT : ffconf.h
  • FF_FS_LOCK : ffconf.h
  • FF_FS_MINIMIZE : ffconf.h
  • FF_FS_NOFSINFO : ffconf.h
  • FF_FS_NORTC : ffconf.h
  • FF_FS_READONLY : ffconf.h
  • FF_FS_REENTRANT : ffconf.h
  • FF_FS_RPATH : ffconf.h
  • FF_FS_TIMEOUT : ffconf.h
  • FF_FS_TINY : ffconf.h
  • FF_LBA64 : ffconf.h
  • FF_LFN_BUF : ffconf.h
  • FF_LFN_UNICODE : ffconf.h
  • FF_MAX_LFN : ffconf.h
  • FF_MAX_SS : ffconf.h
  • FF_MIN_GPT : ffconf.h
  • FF_MIN_SS : ffconf.h
  • FF_MULTI_PARTITION : ffconf.h
  • FF_NORTC_MDAY : ffconf.h
  • FF_NORTC_MON : ffconf.h
  • FF_NORTC_YEAR : ffconf.h
  • FF_PRINT_FLOAT : ffconf.h
  • FF_PRINT_LLI : ffconf.h
  • FF_SFN_BUF : ffconf.h
  • FF_STR_VOLUME_ID : ffconf.h
  • FF_STRF_ENCODE : ffconf.h
  • FF_SYNC_t : ffconf.h
  • FF_USE_CHMOD : ffconf.h
  • FF_USE_EXPAND : ffconf.h
  • FF_USE_FASTSEEK : ffconf.h
  • FF_USE_FIND : ffconf.h
  • FF_USE_FORWARD : ffconf.h
  • FF_USE_LABEL : ffconf.h
  • FF_USE_LFN : ffconf.h
  • FF_USE_MKFS : ffconf.h
  • FF_USE_STRFUNC : ffconf.h
  • FF_USE_TRIM : ffconf.h
  • FF_VOLUME_STRS : ffconf.h
  • FF_VOLUMES : ffconf.h
  • FFCONF_DEF : ffconf.h
  • file : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • file_match : flash_fat16.c
  • FILE_SUFFIX1_LEN : flash_fat16.h
  • FILE_SUFFIX1_NAME : flash_fat16.h
  • FILE_SUFFIX2_LEN : flash_fat16.h
  • FILE_SUFFIX2_NAME : flash_fat16.h
  • file_write_nr : flash_fat16.c
  • FILTER_EXT_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FIR_lowpass_filter() : project_l0/inc/fir_filter.h, fir_filter.c, project_l1/inc/fir_filter.h
  • firCoeffs32 : fir_coefficient.c, fir_filter.c
  • firStateF32 : fir_filter.c
  • flag_status : at32f413.h
  • FLASH : at32f413_flash.h
  • flash_2kb_write() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • FLASH_APP_ADDRESS : app_led3_toggle/inc/hid_iap_user.h, app_led4_toggle/inc/hid_iap_user.h, bootloader/inc/hid_iap_user.h
  • FLASH_APP_START_ADDR : flash_fat16.h
  • FLASH_BASE : at32f413.h
  • flash_buf : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_byte_program() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_calibrate() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_check() : flash_fat16.c
  • FLASH_CS_HIGH : spi_flash.h
  • FLASH_CS_LOW : spi_flash.h
  • FLASH_EPP_ERROR : at32f413_flash.h
  • flash_epp_set() : at32f413_flash.h, at32f413_flash.c
  • flash_epp_status_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_EPPERR_FLAG : at32f413_flash.h
  • FLASH_ERR_INT : at32f413_flash.h
  • flash_fap_enable() : at32f413_flash.h, at32f413_flash.c
  • flash_fap_status_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_FAT16_1_ADDR : flash_fat16.h
  • FLASH_FAT16_2_ADDR : flash_fat16.h
  • flash_fat16_addr_offset() : flash_fat16.c
  • flash_fat16_boot_dir_write() : flash_fat16.c
  • FLASH_FAT16_BOOT_SECTOR_ADDR : flash_fat16.h
  • flash_fat16_clear_upgrade_flag() : flash_fat16.c
  • FLASH_FAT16_FILE_START_ADDR : flash_fat16.h
  • flash_fat16_get_upgrade_flag() : flash_fat16.h, flash_fat16.c
  • flash_fat16_init() : flash_fat16.h, flash_fat16.c
  • flash_fat16_loop_status() : flash_fat16.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • flash_fat16_read() : flash_fat16.h, flash_fat16.c
  • FLASH_FAT16_ROOT_ADDR : flash_fat16.h
  • flash_fat16_sector_write() : flash_fat16.c
  • flash_fat16_set_name() : flash_fat16.h, flash_fat16.c
  • flash_fat16_set_upgrade_flag() : flash_fat16.c
  • flash_fat16_write() : flash_fat16.h, flash_fat16.c
  • flash_flag_clear() : at32f413_flash.h, at32f413_flash.c
  • flash_flag_get() : at32f413_flash.h, at32f413_flash.c
  • flash_halfword_program() : at32f413_flash.h, at32f413_flash.c
  • flash_iap : flash_fat16.h, flash_fat16.c
  • flash_internal_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_interrupt_enable() : at32f413_flash.h, at32f413_flash.c
  • FLASH_IRQHandler() : utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c
  • FLASH_IRQn : at32f413.h
  • flash_lock() : at32f413_flash.h, at32f413_flash.c
  • FLASH_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • FLASH_OBF_FLAG : at32f413_flash.h
  • FLASH_ODF_FLAG : at32f413_flash.h
  • FLASH_ODF_INT : at32f413_flash.h
  • FLASH_OPERATE_BUSY : at32f413_flash.h
  • FLASH_OPERATE_DONE : at32f413_flash.h
  • FLASH_OPERATE_TIMEOUT : at32f413_flash.h
  • flash_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • FLASH_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_PROGRAM_ERROR : at32f413_flash.h
  • flash_read() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_read_data() : flash_fat16.c
  • FLASH_REG_BASE : at32f413.h
  • FLASH_SECTOR_1K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_1K_SIZE : flash_fat16.h
  • FLASH_SECTOR_2K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_2K_SIZE : flash_fat16.h
  • FLASH_SECTOR_4K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_4K_SIZE : flash_fat16.h
  • flash_sector_erase() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SECTOR_SIZE : utilities/at32f413_slib_demo/project_l0/src/main.c
  • FLASH_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • FLASH_SIZE_REG : hid_iap_class.h
  • FLASH_SLIB_DATA_START_SECTOR : at32f413_flash.h
  • flash_slib_datastart_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_disable() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_enable() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SLIB_END_SECTOR : at32f413_flash.h
  • flash_slib_end_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_remaining_count_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SLIB_START_SECTOR : at32f413_flash.h
  • flash_slib_start_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_state_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPI_DUMMY_BYTE : spi_flash.h
  • flash_spim_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_dummy_read() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_encryption_range_set() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPIM_EPPERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_ERR_INT : at32f413_flash.h
  • flash_spim_lock() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_mass_program() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPIM_MODEL1 : at32f413_flash.h
  • FLASH_SPIM_MODEL2 : at32f413_flash.h
  • flash_spim_model_select() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_model_type : at32f413_flash.h
  • FLASH_SPIM_OBF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_INT : at32f413_flash.h
  • flash_spim_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPIM_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_START_ADDR : at32f413_flash.h
  • flash_spim_unlock() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_set() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_status_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • flash_status_type : at32f413_flash.h
  • FLASH_TEST_ADDR : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • flash_unlock() : at32f413_flash.h, at32f413_flash.c
  • FLASH_UNLOCK_KEY1 : at32f413_flash.h
  • FLASH_UNLOCK_KEY2 : at32f413_flash.h
  • flash_upgrade_flag_read() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • FLASH_USDERR_FLAG : at32f413_flash.h
  • flash_user_system_data_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_user_system_data_program() : at32f413_flash.h, at32f413_flash.c
  • flash_word_program() : at32f413_flash.h, at32f413_flash.c
  • flash_write() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_write_data() : flash_fat16.c
  • flash_write_nocheck() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • FLEX_CHANNEL1 : at32f413_dma.h
  • FLEX_CHANNEL2 : at32f413_dma.h
  • FLEX_CHANNEL3 : at32f413_dma.h
  • FLEX_CHANNEL4 : at32f413_dma.h
  • FLEX_CHANNEL5 : at32f413_dma.h
  • FLEX_CHANNEL6 : at32f413_dma.h
  • FLEX_CHANNEL7 : at32f413_dma.h
  • fputc() : at32f413_board.c
  • freq_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • frequency : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • fs : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • FZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • g_audio_hid_usb_desc : audio_hid_desc.h
  • g_custom_hid_usb_desc : custom_hid_desc.h
  • g_file_attr : flash_fat16.c
  • g_hidiap_usb_desc : hid_iap_desc.h
  • g_keyboard_usb_desc : keyboard_desc.h
  • g_mouse_usb_desc : mouse_desc.h
  • g_speed : project/at_start_f413/templates/src/main.c
  • g_usb_offset_addr : at32f413_usb.c
  • g_usb_packet_address : at32f413_usb.h, at32f413_usb.c
  • g_usbd_audio_hid_report : audio_hid_desc.h
  • g_usbd_custom_hid_report : custom_hid_desc.h
  • g_usbd_hidiap_report : hid_iap_desc.h
  • g_usbd_keyboard_report : keyboard_desc.h
  • g_usbd_mouse_report : mouse_desc.h
  • g_usbd_vcpkybrd_hid_report : cdc_keyboard_desc.h
  • g_vcpkybrd_hid_usb_desc : cdc_keyboard_desc.h
  • generate_julia_fpu() : julia_fpu.h, julia_fpu.c
  • get_data_from_usart_flag : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • get_device_config_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_configuration() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_descriptor() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_interface_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_lang_id() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_manufacturer_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_other_speed() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_product_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_qualifier() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_serial_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_inquiry() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • GET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • GET_RX_LEN_ADDR : at32f413_usb.h
  • get_serial_num() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • GET_TX_LEN_ADDR : at32f413_usb.h
  • get_uid_for_seed() : random.c
  • getvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • gpio_bits_reset() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_set() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_write() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/gpio/io_toggle/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • gpio_configuration() : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • gpio_default_para_init() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_DRIVE_STRENGTH_MAXIMUM : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_MODERATE : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_STRONGER : at32f413_gpio.h
  • gpio_drive_type : at32f413_gpio.h
  • gpio_event_output_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_event_output_enable() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_exint_line_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_init() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c
  • gpio_input_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_input_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_iomux_reset() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_MODE_ANALOG : at32f413_gpio.h
  • GPIO_MODE_INPUT : at32f413_gpio.h
  • GPIO_MODE_MUX : at32f413_gpio.h
  • GPIO_MODE_OUTPUT : at32f413_gpio.h
  • gpio_mode_type : at32f413_gpio.h
  • GPIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • gpio_output_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_output_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_OUTPUT_OPEN_DRAIN : at32f413_gpio.h
  • GPIO_OUTPUT_PUSH_PULL : at32f413_gpio.h
  • gpio_output_type : at32f413_gpio.h
  • gpio_pin_remap_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pin_wp_config() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_PINS_0 : at32f413_gpio.h
  • GPIO_PINS_1 : at32f413_gpio.h
  • GPIO_PINS_10 : at32f413_gpio.h
  • GPIO_PINS_11 : at32f413_gpio.h
  • GPIO_PINS_12 : at32f413_gpio.h
  • GPIO_PINS_13 : at32f413_gpio.h
  • GPIO_PINS_14 : at32f413_gpio.h
  • GPIO_PINS_15 : at32f413_gpio.h
  • GPIO_PINS_2 : at32f413_gpio.h
  • GPIO_PINS_3 : at32f413_gpio.h
  • GPIO_PINS_4 : at32f413_gpio.h
  • GPIO_PINS_5 : at32f413_gpio.h
  • GPIO_PINS_6 : at32f413_gpio.h
  • GPIO_PINS_7 : at32f413_gpio.h
  • GPIO_PINS_8 : at32f413_gpio.h
  • GPIO_PINS_9 : at32f413_gpio.h
  • GPIO_PINS_ALL : at32f413_gpio.h
  • GPIO_PINS_SOURCE0 : at32f413_gpio.h
  • GPIO_PINS_SOURCE1 : at32f413_gpio.h
  • GPIO_PINS_SOURCE10 : at32f413_gpio.h
  • GPIO_PINS_SOURCE11 : at32f413_gpio.h
  • GPIO_PINS_SOURCE12 : at32f413_gpio.h
  • GPIO_PINS_SOURCE13 : at32f413_gpio.h
  • GPIO_PINS_SOURCE14 : at32f413_gpio.h
  • GPIO_PINS_SOURCE15 : at32f413_gpio.h
  • GPIO_PINS_SOURCE2 : at32f413_gpio.h
  • GPIO_PINS_SOURCE3 : at32f413_gpio.h
  • GPIO_PINS_SOURCE4 : at32f413_gpio.h
  • GPIO_PINS_SOURCE5 : at32f413_gpio.h
  • GPIO_PINS_SOURCE6 : at32f413_gpio.h
  • GPIO_PINS_SOURCE7 : at32f413_gpio.h
  • GPIO_PINS_SOURCE8 : at32f413_gpio.h
  • GPIO_PINS_SOURCE9 : at32f413_gpio.h
  • gpio_pins_source_type : at32f413_gpio.h
  • gpio_pins_toggle() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • GPIO_PORT_SOURCE_GPIOA : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOB : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOC : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOD : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOF : at32f413_gpio.h
  • gpio_port_source_type : at32f413_gpio.h
  • gpio_port_write() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_PULL_DOWN : at32f413_gpio.h
  • GPIO_PULL_NONE : at32f413_gpio.h
  • gpio_pull_type : at32f413_gpio.h
  • GPIO_PULL_UP : at32f413_gpio.h
  • gpio_reset() : at32f413_gpio.h, at32f413_gpio.c
  • GPIOA : at32f413_gpio.h
  • GPIOA_BASE : at32f413.h
  • GPIOB : at32f413_gpio.h
  • GPIOB_BASE : at32f413.h
  • GPIOC : at32f413_gpio.h
  • GPIOC_BASE : at32f413.h
  • GPIOD : at32f413_gpio.h
  • GPIOD_BASE : at32f413.h
  • GPIOF : at32f413_gpio.h
  • GPIOF_BASE : at32f413.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- h -

  • HardFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • HardFault_IRQn : at32f413.h
  • HBYTE : usb_std.h
  • HEXT_STABLE_DELAY : system_at32f413.h
  • HEXT_STARTUP_TIMEOUT : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HEXT_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • hi2cx : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • HICK_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HID_CLASS_DESC_HID : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_PHYSICAL : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_REPORT : audio_hid_desc.h, usb_std.h
  • HID_DESCRIPTOR_TYPE : usb_std.h
  • HID_IAP_BUFFER_LEN : hid_iap_class.h
  • hid_iap_class_handler : hid_iap_class.c, hid_iap_class.h
  • hid_iap_desc_handler : hid_iap_desc.c, hid_iap_desc.h
  • HID_INTERFACE_NUMBER : audio_hid_desc.h
  • HID_REPORT_DESC : usb_std.h
  • HID_REPORT_ID_1 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_2 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_3 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_4 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_5 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_6 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REQ_GET_IDLE : usb_std.h
  • HID_REQ_GET_PROTOCOL : usb_std.h
  • HID_REQ_GET_REPORT : usb_std.h
  • HID_REQ_SET_IDLE : usb_std.h
  • HID_REQ_SET_PROTOCOL : usb_std.h
  • HID_REQ_SET_REPORT : usb_std.h
  • hid_suspend_flag : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • HIDIAP_BCD_NUM : hid_iap_desc.h
  • HIDIAP_BINTERVAL_TIME : hid_iap_desc.h
  • HIST_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c
  • hw_usart_read_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • hw_usart_rx_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • I2C1 : at32f413_i2c.h
  • I2C1_BASE : at32f413.h
  • I2C1_ERR_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C1_ERR_IRQn : at32f413.h
  • I2C1_EVT_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C1_EVT_IRQn : at32f413.h
  • I2C1_GMUX_0001 : at32f413_gpio.h
  • I2C1_GMUX_0011 : at32f413_gpio.h
  • I2C1_MUX : at32f413_gpio.h
  • I2C2 : at32f413_i2c.h
  • I2C2_BASE : at32f413.h
  • I2C2_ERR_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2C2_ERR_IRQn : at32f413.h
  • I2C2_EVT_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2C2_EVT_IRQn : at32f413.h
  • I2C2_GMUX_0001 : at32f413_gpio.h
  • I2C2_GMUX_0010 : at32f413_gpio.h
  • I2C2_GMUX_0011 : at32f413_gpio.h
  • i2c_7bit_address_send() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_ack_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_ACKFAIL_FLAG : at32f413_i2c.h
  • I2C_ADDR2_FLAG : at32f413_i2c.h
  • I2C_ADDR7F_FLAG : at32f413_i2c.h
  • I2C_ADDRESS_MODE_10BIT : at32f413_i2c.h
  • I2C_ADDRESS_MODE_7BIT : at32f413_i2c.h
  • i2c_address_mode_type : at32f413_i2c.h
  • I2C_ADDRHF_FLAG : at32f413_i2c.h
  • I2C_ALERTF_FLAG : at32f413_i2c.h
  • I2C_ARLOST_FLAG : at32f413_i2c.h
  • i2c_arp_mode_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_BUSERR_FLAG : at32f413_i2c.h
  • I2C_BUSYF_FLAG : at32f413_i2c.h
  • i2c_clock_stretch_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_config() : i2c_application.c, i2c_application.h
  • I2C_DATA_INT : at32f413_i2c.h
  • i2c_data_receive() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_data_send() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_DEVADDRF_FLAG : at32f413_i2c.h
  • I2C_DIRECTION_RECEIVE : at32f413_i2c.h
  • I2C_DIRECTION_TRANSMIT : at32f413_i2c.h
  • i2c_direction_type : at32f413_i2c.h
  • I2C_DIRF_FLAG : at32f413_i2c.h
  • i2c_dma_config() : i2c_application.c
  • i2c_dma_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_end_transfer_set() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_DMA_MA_RX : i2c_application.h
  • I2C_DMA_MA_TX : i2c_application.h
  • i2c_dma_rx_irq_handler() : i2c_application.c, i2c_application.h
  • I2C_DMA_SLA_RX : i2c_application.h
  • I2C_DMA_SLA_TX : i2c_application.h
  • i2c_dma_tx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_END : i2c_application.c
  • I2C_ERR_ACKFAIL : i2c_application.h
  • I2C_ERR_ADDR : i2c_application.h
  • I2C_ERR_ADDR10 : i2c_application.h
  • I2C_ERR_INT : at32f413_i2c.h
  • I2C_ERR_INTERRUPT : i2c_application.h
  • i2c_err_irq_handler() : i2c_application.c, i2c_application.h
  • I2C_ERR_START : i2c_application.h
  • I2C_ERR_STEP_1 : i2c_application.h
  • I2C_ERR_STEP_10 : i2c_application.h
  • I2C_ERR_STEP_11 : i2c_application.h
  • I2C_ERR_STEP_12 : i2c_application.h
  • I2C_ERR_STEP_2 : i2c_application.h
  • I2C_ERR_STEP_3 : i2c_application.h
  • I2C_ERR_STEP_4 : i2c_application.h
  • I2C_ERR_STEP_5 : i2c_application.h
  • I2C_ERR_STEP_6 : i2c_application.h
  • I2C_ERR_STEP_7 : i2c_application.h
  • I2C_ERR_STEP_8 : i2c_application.h
  • I2C_ERR_STEP_9 : i2c_application.h
  • I2C_ERR_STOP : i2c_application.h
  • I2C_ERR_TIMEOUT : i2c_application.h
  • I2C_EVENT_CHECK_ACKFAIL : i2c_application.h
  • I2C_EVENT_CHECK_NONE : i2c_application.h
  • I2C_EVENT_CHECK_STOP : i2c_application.h
  • I2C_EVT_INT : at32f413_i2c.h
  • i2c_evt_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_fast_mode_duty_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_clear() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_get() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_FSMODE_DUTY_16_9 : at32f413_i2c.h
  • I2C_FSMODE_DUTY_2_1 : at32f413_i2c.h
  • i2c_fsmode_duty_cycle_type : at32f413_i2c.h
  • I2C_GCADDRF_FLAG : at32f413_i2c.h
  • i2c_general_call_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_HOSTADDRF_FLAG : at32f413_i2c.h
  • i2c_init() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_INT_MA_RX : i2c_application.h
  • I2C_INT_MA_TX : i2c_application.h
  • I2C_INT_SLA_RX : i2c_application.h
  • I2C_INT_SLA_TX : i2c_application.h
  • i2c_interrupt_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_lowlevel_init() : i2c_application.c, i2c_application.h, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2C_MASTER_ACK_CURRENT : at32f413_i2c.h
  • I2C_MASTER_ACK_NEXT : at32f413_i2c.h
  • i2c_master_ack_type : at32f413_i2c.h
  • i2c_master_read_addr() : i2c_application.c
  • i2c_master_receive() : i2c_application.c, i2c_application.h
  • i2c_master_receive_ack_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_master_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_master_receive_int() : i2c_application.c, i2c_application.h
  • i2c_master_rx_isr_int() : i2c_application.c
  • i2c_master_transmit() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_master_tx_isr_dma() : i2c_application.c
  • i2c_master_tx_isr_int() : i2c_application.c
  • i2c_master_write_addr() : i2c_application.c
  • I2C_MEM_ADDR_WIDIH_16 : i2c_application.h
  • I2C_MEM_ADDR_WIDIH_8 : i2c_application.h
  • i2c_mem_address_width_type : i2c_application.h
  • i2c_memory_address_send() : i2c_application.c
  • i2c_memory_read() : i2c_application.c, i2c_application.h
  • i2c_memory_read_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_read_int() : i2c_application.c, i2c_application.h
  • i2c_memory_write() : i2c_application.c, i2c_application.h
  • i2c_memory_write_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_write_int() : i2c_application.c, i2c_application.h
  • i2c_mode_type : i2c_application.h
  • I2C_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • I2C_OK : i2c_application.h
  • I2C_OUF_FLAG : at32f413_i2c.h
  • i2c_own_address1_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_calculate_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_PEC_POSITION_CURRENT : at32f413_i2c.h
  • I2C_PEC_POSITION_NEXT : at32f413_i2c.h
  • i2c_pec_position_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_position_type : at32f413_i2c.h
  • i2c_pec_transmit_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_value_get() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_PECERR_FLAG : at32f413_i2c.h
  • I2C_RDBF_FLAG : at32f413_i2c.h
  • i2c_reset() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_int() : i2c_application.c, i2c_application.h
  • i2c_slave_rx_isr_int() : i2c_application.c
  • i2c_slave_transmit() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_slave_tx_isr_int() : i2c_application.c
  • i2c_slave_tx_rx_isr_dma() : i2c_application.c
  • I2C_SMBUS_ALERT_HIGH : at32f413_i2c.h
  • I2C_SMBUS_ALERT_LOW : at32f413_i2c.h
  • i2c_smbus_alert_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_alert_set_type : at32f413_i2c.h
  • i2c_smbus_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_SMBUS_MODE_DEVICE : at32f413_i2c.h
  • I2C_SMBUS_MODE_HOST : at32f413_i2c.h
  • i2c_smbus_mode_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_mode_set_type : at32f413_i2c.h
  • i2c_software_reset() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_START : i2c_application.c
  • i2c_start_generate() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_STARTF_FLAG : at32f413_i2c.h
  • i2c_status_type : i2c_application.h
  • i2c_stop_generate() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_STOPF_FLAG : at32f413_i2c.h
  • I2C_TDBE_FLAG : at32f413_i2c.h
  • I2C_TDC_FLAG : at32f413_i2c.h
  • I2C_TIMEOUT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2C_TMOUT_FLAG : at32f413_i2c.h
  • I2C_TRMODE_FLAG : at32f413_i2c.h
  • i2c_wait_end() : i2c_application.c, i2c_application.h
  • i2c_wait_flag() : i2c_application.c, i2c_application.h
  • I2Cx_ADDRESS : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_DMA_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_RX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_TX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_ERR_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_ERR_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_EVT_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_EVT_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SPEED : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • i2s1_buffer_tx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S1_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • i2s2_buffer_rx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S2_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S_ACS_FLAG : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_11_025K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_16K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_192K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_22_05K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_32K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_44_1K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_48K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_8K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_96K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_DEFAULT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_LSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_MSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_LONG : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_SHORT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PHILLIPS : at32f413_spi.h
  • i2s_audio_protocol_type : at32f413_spi.h
  • i2s_audio_sampling_freq_type : at32f413_spi.h
  • I2S_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • I2S_CLOCK_POLARITY_LOW : at32f413_spi.h
  • i2s_clock_polarity_type : at32f413_spi.h
  • i2s_config() : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S_DATA_16BIT_CHANNEL_16BIT : at32f413_spi.h
  • I2S_DATA_16BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_24BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_32BIT_CHANNEL_32BIT : at32f413_spi.h
  • i2s_data_channel_format_type : at32f413_spi.h
  • i2s_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • i2s_enable() : at32f413_spi.h, at32f413_spi.c
  • i2s_init() : at32f413_spi.h, at32f413_spi.c
  • I2S_MODE_MASTER_RX : at32f413_spi.h
  • I2S_MODE_MASTER_TX : at32f413_spi.h
  • I2S_MODE_SLAVE_RX : at32f413_spi.h
  • I2S_MODE_SLAVE_TX : at32f413_spi.h
  • i2s_operation_mode_type : at32f413_spi.h
  • I2S_TUERR_FLAG : at32f413_spi.h
  • IAP_ACK : hid_iap_class.h
  • iap_address() : bootloader/src/hid_iap_user.c
  • iap_clear_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • IAP_CMD_ADDR : hid_iap_class.h
  • IAP_CMD_CRC : hid_iap_class.h
  • IAP_CMD_DATA : hid_iap_class.h
  • IAP_CMD_FINISH : hid_iap_class.h
  • IAP_CMD_GET : hid_iap_class.h
  • IAP_CMD_IDLE : hid_iap_class.h
  • IAP_CMD_JMP : hid_iap_class.h
  • IAP_CMD_START : hid_iap_class.h
  • iap_command_handle() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c
  • iap_crc() : bootloader/src/hid_iap_user.c
  • iap_data_write() : bootloader/src/hid_iap_user.c
  • iap_erase_sector() : bootloader/src/hid_iap_user.c
  • IAP_FAILED : flash_fat16.h, hid_iap_class.h
  • iap_finish() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_flag : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c
  • iap_get() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get_upgrade_flag() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_idle() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_info : hid_iap_class.c, hid_iap_class.h
  • iap_init() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c, app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_jump() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_loop() : bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_machine_state_type : hid_iap_class.h
  • IAP_NACK : hid_iap_class.h
  • iap_respond() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_result_type : hid_iap_class.h
  • IAP_REV_FLAG_5A : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_DONE : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_ERROR : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_NO : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • iap_set_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_start() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • IAP_STS_ADDR : hid_iap_class.h
  • IAP_STS_CRC : hid_iap_class.h
  • IAP_STS_DATA : hid_iap_class.h
  • IAP_STS_FINISH : hid_iap_class.h
  • IAP_STS_IDLE : hid_iap_class.h
  • IAP_STS_JMP : hid_iap_class.h
  • IAP_STS_JMP_WAIT : hid_iap_class.h
  • IAP_STS_START : hid_iap_class.h
  • IAP_SUCCESS : flash_fat16.h, hid_iap_class.h
  • iap_upgrade_app_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • IAP_UPGRADE_COMPLETE_FLAG : hid_iap_class.h, flash_fat16.h
  • IAP_UPGRADE_FLAG : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IAP_UPGRADE_FLAG_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IAP_WAIT : hid_iap_class.h
  • iapfun : bootloader/inc/iap.h
  • ic2value : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c
  • IMG_CONSTANT : julia_fpu.h
  • INCLUDE_uxTaskPriorityGet : FreeRTOSConfig.h
  • INCLUDE_vTaskCleanUpResources : FreeRTOSConfig.h
  • INCLUDE_vTaskDelay : FreeRTOSConfig.h
  • INCLUDE_vTaskDelayUntil : FreeRTOSConfig.h
  • INCLUDE_vTaskDelete : FreeRTOSConfig.h
  • INCLUDE_vTaskPrioritySet : FreeRTOSConfig.h
  • INCLUDE_vTaskSuspend : FreeRTOSConfig.h
  • INCLUDE_xTaskGetCurrentTaskHandle : FreeRTOSConfig.h
  • incrementvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • INT16 : at32f413.h
  • INT32 : at32f413.h
  • INT8 : at32f413.h
  • INTERNAL_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • INVAILD_OFFSET_ADDR : flash_fat16.h
  • INVALID_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELD_IN_PARAMETER_LIST : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELED_IN_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • IOMUX : at32f413_gpio.h
  • IOMUX_BASE : at32f413.h
  • IOMUX_MAKE_VALUE : at32f413_gpio.h
  • IRQn : at32f413.h
  • IRQn_Type : at32f413.h
  • is_leap_year() : rtc.c
  • ITERATION : julia_fpu.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- j -

  • jump_to_app : bootloader/src/iap.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- k -

  • KB_TO_B : hid_iap_class.h
  • KEYBOARD_BCD_NUM : keyboard_desc.h
  • KEYBOARD_BINTERVAL_TIME : keyboard_desc.h
  • keyboard_class_handler : keyboard_class.c, keyboard_class.h
  • keyboard_class_setup_handler() : cdc_keyboard_class.c
  • keyboard_desc_handler : keyboard_desc.c, keyboard_desc.h
  • keyboard_send_string() : project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c
  • keyboard_struct : keyboard_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • langid_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • LBYTE : usb_std.h
  • LED2 : at32f413_board.h
  • led2_handler : utilities/at32f413_freertos_demo/src/main.c
  • led2_task_function() : utilities/at32f413_freertos_demo/src/main.c
  • LED3 : at32f413_board.h
  • led3_handler : utilities/at32f413_freertos_demo/src/main.c
  • led3_task_function() : utilities/at32f413_freertos_demo/src/main.c
  • LED4 : at32f413_board.h
  • led_gpio_crm_clk : at32f413_board.c
  • led_gpio_pin : at32f413_board.c
  • led_gpio_port : at32f413_board.c
  • LED_NUM : at32f413_board.h
  • led_type : at32f413_board.h
  • LEFT_BUTTON : mouse_class.h
  • LEFT_MOVE : mouse_class.h
  • LEXT_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • lickfreq : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • linecoding : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • linecoding_vcpkybrd : cdc_keyboard_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • main() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/cortex_m4/bit_band/src/main.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f413/examples/cortex_m4/fpu/src/main.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/flash/fap_enable/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/flash/operate_spim/src/main.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c, project/at_start_f413/examples/gpio/io_toggle/src/main.c, project/at_start_f413/examples/gpio/led_toggle/src/main.c, project/at_start_f413/examples/gpio/swjtag_remap/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c, project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c, project/at_start_f413/examples/pwc/sleep_usart1/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c, project/at_start_f413/examples/rtc/calendar/src/main.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/sram/extend_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/printf/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f413/examples/wdt/wdt_reset/src/main.c, project/at_start_f413/examples/wdt/wdt_standby/src/main.c, project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c, project/at_start_f413/templates/src/main.c, utilities/at32f413_freertos_demo/src/main.c, utilities/at32f413_gen_random_number_demo/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • MAKE_VALUE : at32f413.h
  • MASTER_BOARD : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • MATCH_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • MAX : usb_std.h
  • max_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mclk_tmr1_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MCU_ID1 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID2 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID3 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • mean : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • MEDIUM_HAVE_CHANGED : cdc_msc_class.h, msc_bot_scsi.h
  • MEDIUM_NOT_PRESENT : cdc_msc_class.h, msc_bot_scsi.h
  • MemManage_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • MemoryManagement_IRQn : at32f413.h
  • memset16_buffer() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MIC_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • mic_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MIN : usb_std.h
  • min_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • MISC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • mmc_stream_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_stream_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mmc_stream_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • MMC_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • mon_table : rtc.c
  • MOUSE_BCD_NUM : mouse_desc.h
  • MOUSE_BINTERVAL_TIME : mouse_desc.h
  • mouse_class_handler : mouse_class.c, mouse_class.h
  • mouse_desc_handler : mouse_desc.c, mouse_desc.h
  • mouse_struct : mouse_class.c
  • MOVE_STEP : mouse_class.h
  • MS_TICK : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
  • MSC_BCD_NUM : msc_desc.h
  • MSC_BOT_STATE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_RECOVERY : cdc_msc_class.h, msc_bot_scsi.h
  • msc_class_handler : msc_class.c, msc_class.h
  • msc_class_setup_handler() : cdc_msc_class.c
  • MSC_CMD_ALLOW_MEDIUM_REMOVAL : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_FORMAT_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_INQUIRY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE6 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_FORMAT_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_REQUEST_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_START_STOP : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_TEST_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • msc_desc_handler : msc_desc.c, msc_desc.h
  • msc_disk_capacity() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_read() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_write() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_flash_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • MSC_MAX_DATA_BUF_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_BO_RESET : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_GET_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_CMD : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_IN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_LAST_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_SEND_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_STATUS : cdc_msc_class.h, msc_bot_scsi.h
  • msc_struct : msc_class.c
  • MSC_SUPPORT_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MULTI_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • my_memset() : arm_fir_init_f32.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • NMI_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • NO_BUTTON : at32f413_board.h
  • NonMaskableInt_IRQn : at32f413.h
  • NULL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • NUM_TAPS : fir_coefficient.c, fir_filter.c
  • NUMSTUDENTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • numStudents : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • NUMSUBJECTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • numSubjects : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • nvic_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c
  • nvic_irq_disable() : at32f413_misc.h, at32f413_misc.c
  • nvic_irq_enable() : at32f413_misc.h, at32f413_misc.c
  • nvic_lowpower_mode_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_lowpower_mode_type : at32f413_misc.h
  • NVIC_LP_SEVONPEND : at32f413_misc.h
  • NVIC_LP_SLEEPDEEP : at32f413_misc.h
  • NVIC_LP_SLEEPONEXIT : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_0 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_1 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_2 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_3 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_4 : at32f413_misc.h
  • nvic_priority_group_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_priority_group_type : at32f413_misc.h
  • nvic_system_reset() : at32f413_misc.h, at32f413_misc.c
  • nvic_vector_table_set() : at32f413_misc.h, at32f413_misc.c
  • NVIC_VECTTAB_FLASH : at32f413_misc.h
  • NVIC_VECTTAB_RAM : at32f413_misc.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • OPERATION_TIMEOUT : at32f413_flash.h
  • operationcomplete : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • ov_cnt : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • PARAMETER_LIST_LENGTH_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • PD01_GMUX : at32f413_gpio.h
  • PD01_MUX : at32f413_gpio.h
  • PendSV_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • PendSV_IRQn : at32f413.h
  • periodvalue : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • PERIPH_BASE : at32f413.h
  • PERIPH_REG : at32f413.h
  • PERIPH_REG_BIT : at32f413.h
  • PERIPHERAL_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • pftarget : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • PLL_STABLE_DELAY : system_at32f413.h
  • preempt_conversion_count : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • preempt_trigger_count : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • press_mouse : project/at_start_f413/examples/usb_device/mouse/src/main.c
  • PRINT_UART : at32f413_board.h
  • PRINT_UART_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_GPIO : at32f413_board.h
  • PRINT_UART_TX_GPIO_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_PIN : at32f413_board.h
  • PRINTER_BCD_NUM : printer_desc.h
  • printer_class_handler : printer_class.c, printer_class.h
  • printer_desc_handler : printer_desc.c, printer_desc.h
  • PRINTER_DEVICE_ID_LEN : printer_class.h
  • PRINTER_PROTOCOL_1284_4 : printer_desc.h
  • PRINTER_PROTOCOL_BI_DIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_UNIDIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_VENDOR_SPECIFIC : printer_desc.h
  • PRINTER_REQ_GET_DEVICE_ID : printer_class.h
  • PRINTER_REQ_GET_PORT_STATUS : printer_class.h
  • PRINTER_REQ_GET_SOFT_RESET : printer_class.h
  • printer_req_type : printer_class.h
  • printer_struct : printer_class.c
  • PROGRAMMING_TIMEOUT : at32f413_flash.h
  • PUTCHAR_PROTOTYPE : at32f413_board.c
  • pvm_exint_config() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c
  • PVM_IRQHandler() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c
  • PVM_IRQn : at32f413.h
  • PWC : at32f413_pwc.h
  • PWC_BASE : at32f413.h
  • pwc_battery_powered_domain_access() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_deep_sleep_enter_type : at32f413_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFI : at32f413_pwc.h
  • pwc_deep_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_clear() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_get() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • pwc_power_voltage_monitor_enable() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_pvm_level_select() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_PVM_OUTPUT_FLAG : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V3 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V4 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V5 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V6 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V7 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V8 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V9 : at32f413_pwc.h
  • pwc_pvm_voltage_type : at32f413_pwc.h
  • pwc_reset() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_sleep_enter_type : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFI : at32f413_pwc.h
  • pwc_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_STANDBY_FLAG : at32f413_pwc.h
  • pwc_standby_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_WAKEUP_FLAG : at32f413_pwc.h
  • PWC_WAKEUP_PIN_1 : at32f413_pwc.h
  • pwc_wakeup_pin_enable() : at32f413_pwc.h, at32f413_pwc.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • RAM_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • RAM_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • randnum_test() : random.h, random.c
  • rca : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • read_buffer : operate_spim.c
  • REAL_CONSTANT : julia_fpu.h
  • refOutput : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • REG16 : at32f413.h
  • REG32 : at32f413.h
  • REG8 : at32f413.h
  • reg_addr_data : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • report_buf : project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • REQ_SENSE_STANDARD_DATA_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • RESET : at32f413.h
  • Reset_IRQn : at32f413.h
  • result_error() : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • RIGHT_BUTTON : mouse_class.h
  • RIGHT_MOVE : mouse_class.h
  • RS485_BAUDRATE : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_buffer_rx : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_buffer_rx_cnt : project/at_start_f413/examples/usart/rs485/src/main.c
  • RS485_BUFFER_SIZE : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_config() : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_send_data() : project/at_start_f413/examples/usart/rs485/src/main.c
  • RTC : at32f413_rtc.h
  • rtc_alarm_clock_set() : rtc.h, rtc.c
  • rtc_alarm_config() : project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_alarm_set() : at32f413_rtc.h, at32f413_rtc.c
  • RTC_BASE : at32f413.h
  • RTC_CFGF_FLAG : at32f413_rtc.h
  • rtc_config() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • rtc_counter_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_counter_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_clear() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_init() : rtc.h, rtc.c
  • rtc_interrupt_enable() : at32f413_rtc.h, at32f413_rtc.c
  • RTC_IRQHandler() : project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • RTC_IRQn : at32f413.h
  • RTC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • RTC_OVF_FLAG : at32f413_rtc.h
  • RTC_OVF_INT : at32f413_rtc.h
  • RTC_TA_FLAG : at32f413_rtc.h
  • RTC_TA_INT : at32f413_rtc.h
  • rtc_time_get() : rtc.h, rtc.c
  • rtc_time_set() : rtc.h, rtc.c
  • RTC_TS_FLAG : at32f413_rtc.h
  • RTC_TS_INT : at32f413_rtc.h
  • RTC_UPDF_FLAG : at32f413_rtc.h
  • rtc_wait_config_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_wait_update_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_week_get() : rtc.c
  • RTCAlarm_IRQHandler() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c
  • RTCAlarm_IRQn : at32f413.h
  • rx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • rx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • rx_counter : project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • rx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • s16 : at32f413.h
  • s32 : at32f413.h
  • s8 : at32f413.h
  • SAMPLE_FREQ : audio_desc.h, audio_hid_desc.h
  • SAMPLING_NUM : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • sblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sc16 : at32f413.h
  • sc32 : at32f413.h
  • sc8 : at32f413.h
  • SC_3_5V_CLK : smartcard_config.h
  • SC_3_5V_PIN : smartcard_config.h
  • SC_3_5V_PORT : smartcard_config.h
  • sc_a2r_struct : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_baud_rate : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_clock_freq : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_CMDVCC_CLK : smartcard_config.h
  • SC_CMDVCC_PIN : smartcard_config.h
  • SC_CMDVCC_PORT : smartcard_config.h
  • SC_F_DIV_D : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_OFF_CLK : smartcard_config.h
  • SC_OFF_EXINT : smartcard_config.h
  • SC_OFF_EXINT_IRQ : smartcard_config.h
  • SC_OFF_PIN : smartcard_config.h
  • SC_OFF_PINSOURCE : smartcard_config.h
  • SC_OFF_PORT : smartcard_config.h
  • SC_OFF_PORTSOURCE : smartcard_config.h
  • SC_RECEIVE_TIMEOUT : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_RESET_CLK : smartcard_config.h
  • SC_RESET_PIN : smartcard_config.h
  • SC_RESET_PORT : smartcard_config.h
  • sc_response_decode() : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART : smartcard_config.h
  • SC_USART_CLK : smartcard_config.h
  • SC_USART_CLK_PIN : smartcard_config.h
  • SC_USART_CLK_PORT : smartcard_config.h
  • SC_USART_DIV_VAL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART_GPIO_CLK : smartcard_config.h
  • SC_USART_IRQHandler : smartcard_config.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • SC_USART_IRQn : smartcard_config.h
  • SC_USART_TX_PIN : smartcard_config.h
  • SC_USART_TX_PORT : smartcard_config.h
  • sclk_192m_hick_config() : project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • sclk_64m_hick_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • sclk_96m_hext_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • SCLK_FROM_HICK : project/at_start_f413/examples/acc/calibration/src/main.c
  • scr_find() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SCREEN_X_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • SCREEN_Y_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • scsi_inquiry : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c, virtual_msc_iap/src/msc_diskio.c
  • SCSI_INQUIRY_DATA_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • SD_0TO7BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_16TO23BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_24TO31BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_8TO15BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ALLZERO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_block_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_block_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_blocks_erase() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_bus_wide_enable() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SD_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_DISCONNECTED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_IDENTIFICATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_card_info : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_card_info_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_card_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_CARD_LOCKED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h, sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_READY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h, sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_SENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_STANDBY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_card_state_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_TRANSFER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CHECK_PATTERN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CID_CSD_OVERWRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ALL_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_SD_SET_BUSWIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CLR_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAST_IO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GEN_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IDLE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_INACTIVE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IRQ_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_READ : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_WRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SEND_EXT_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SWITCH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_NO_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_RSP_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_CHANGE_SECURE_AREA : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RES1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RN2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_SCR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RES2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RN1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CLR_CARD_DETECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_STAUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_DIRECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_EXTENDED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_SEN_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEL_DESEL_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_STATUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCK_COUNT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCKLEN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_DSR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_REL_ADDR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_STOP_TRANSMISSION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_data_transfer_mode_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_deselect_select() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_device_mode_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_dma_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_error_status_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFOBYTES : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HIGH_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_INTERNAL_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_PARAMETER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_VOLTRANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_irq_service() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SD_MAX_DATA_LENGTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_MAX_VOLT_TRIAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_memory_card_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_mult_blocks_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_multiple_blocks_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SD_NOT_CONFIGURED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CID_CSD_OVERWRIETE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERRORBITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_power_off() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_power_on() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_R5_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_FUNCTION_NUMBER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_NOT_APPLICABLE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_PENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_RX_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_BUSY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_UNKNOWN_FUNC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_single_block_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SD_SINGLE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_START_BIT_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_state_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_status_send() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_STD_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SD_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_test_error() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • SD_TRANSFER_DMA_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_POLLING_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TX_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_FEATURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_HW : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_MMC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_SD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_wide_bus_operation_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_WIDE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_write_disk() : diskio.c
  • SDIO1_BASE : at32f413.h
  • SDIO1_GMUX_0100 : at32f413_gpio.h
  • SDIO1_GMUX_0101 : at32f413_gpio.h
  • SDIO1_GMUX_0110 : at32f413_gpio.h
  • SDIO1_GMUX_0111 : at32f413_gpio.h
  • SDIO1_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SDIO1_IRQn : at32f413.h
  • SDIO2_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_block_size_type : at32f413_sdio.h
  • sdio_buffer_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_bus_width_config() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_BUS_WIDTH_D1 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D4 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D8 : at32f413_sdio.h
  • sdio_bus_width_type : at32f413_sdio.h
  • sdio_clock_bypass() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_config() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_CLOCK_EDGE_FALLING : at32f413_sdio.h
  • SDIO_CLOCK_EDGE_RISING : at32f413_sdio.h
  • sdio_clock_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SDIO_CMD0TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_CMDCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDCMPL_INT : at32f413_sdio.h
  • SDIO_CMDFAIL_FLAG : at32f413_sdio.h
  • SDIO_CMDFAIL_INT : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_INT : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_INT : at32f413_sdio.h
  • sdio_command_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_data_send() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_command_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_command_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DATA_BLOCK_SIZE_1024B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_128B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16384B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2048B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_256B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_32B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4096B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_512B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_64B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8192B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_TRANSFER : at32f413_sdio.h
  • sdio_data_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_data_read() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DATA_STREAM_TRANSFER : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CARD : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CONTROLLER : at32f413_sdio.h
  • sdio_data_write() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_dma_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DOCMD_FLAG : at32f413_sdio.h
  • SDIO_DOCMD_INT : at32f413_sdio.h
  • SDIO_DORX_FLAG : at32f413_sdio.h
  • SDIO_DORX_INT : at32f413_sdio.h
  • SDIO_DOTX_FLAG : at32f413_sdio.h
  • SDIO_DOTX_INT : at32f413_sdio.h
  • SDIO_DTBLKCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTBLKCMPL_INT : at32f413_sdio.h
  • SDIO_DTCMP_INT : at32f413_sdio.h
  • SDIO_DTCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_INT : at32f413_sdio.h
  • SDIO_DTTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_DTTIMEOUT_INT : at32f413_sdio.h
  • sdio_edge_phase_type : at32f413_sdio.h
  • SDIO_FIFO_Address : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_flag_clear() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flag_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flow_control_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_HIGH_CAPACITY_MMC_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_CAPACITY_SD_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_SPEED_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_interrupt_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_INTR_STS_READ_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_WRITE_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_io_function_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_io_suspend_command_set() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • SDIO_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_POWER_OFF : at32f413_sdio.h
  • SDIO_POWER_ON : at32f413_sdio.h
  • sdio_power_saving_mode_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_state_type : at32f413_sdio.h
  • sdio_power_status_get() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_READ_WAIT_CONTROLLED_BY_CK : at32f413_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_D2 : at32f413_sdio.h
  • sdio_read_wait_mode_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_mode_type : at32f413_sdio.h
  • sdio_read_wait_start() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_stop() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_reponse_type : at32f413_sdio.h
  • sdio_reset() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_RESPONSE_LONG : at32f413_sdio.h
  • SDIO_RESPONSE_NO : at32f413_sdio.h
  • SDIO_RESPONSE_SHORT : at32f413_sdio.h
  • SDIO_RSP1_INDEX : at32f413_sdio.h
  • SDIO_RSP2_INDEX : at32f413_sdio.h
  • SDIO_RSP3_INDEX : at32f413_sdio.h
  • SDIO_RSP4_INDEX : at32f413_sdio.h
  • sdio_rsp_index_type : at32f413_sdio.h
  • SDIO_RXBUF_FLAG : at32f413_sdio.h
  • SDIO_RXBUF_INT : at32f413_sdio.h
  • SDIO_RXBUFE_FLAG : at32f413_sdio.h
  • SDIO_RXBUFE_INT : at32f413_sdio.h
  • SDIO_RXBUFF_FLAG : at32f413_sdio.h
  • SDIO_RXBUFF_INT : at32f413_sdio.h
  • SDIO_RXBUFH_FLAG : at32f413_sdio.h
  • SDIO_RXBUFH_INT : at32f413_sdio.h
  • SDIO_RXERRO_FLAG : at32f413_sdio.h
  • SDIO_RXERRO_INT : at32f413_sdio.h
  • SDIO_SBITERR_FLAG : at32f413_sdio.h
  • SDIO_SBITERR_INT : at32f413_sdio.h
  • SDIO_SDIO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SDIOIF_FLAG : at32f413_sdio.h
  • SDIO_SDIOIF_INT : at32f413_sdio.h
  • SDIO_SECURE_DIGITAL_IO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_COMBO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SEND_IF_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STATIC_FLAGS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V1_1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V2_0 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_transfer_direction_type : at32f413_sdio.h
  • sdio_transfer_mode_type : at32f413_sdio.h
  • SDIO_TXBUF_FLAG : at32f413_sdio.h
  • SDIO_TXBUF_INT : at32f413_sdio.h
  • SDIO_TXBUFE_FLAG : at32f413_sdio.h
  • SDIO_TXBUFE_INT : at32f413_sdio.h
  • SDIO_TXBUFF_FLAG : at32f413_sdio.h
  • SDIO_TXBUFF_INT : at32f413_sdio.h
  • SDIO_TXBUFH_FLAG : at32f413_sdio.h
  • SDIO_TXBUFH_INT : at32f413_sdio.h
  • SDIO_TXERRU_FLAG : at32f413_sdio.h
  • SDIO_TXERRU_INT : at32f413_sdio.h
  • SDIO_WAIT_FOR_INT : at32f413_sdio.h
  • SDIO_WAIT_FOR_NO : at32f413_sdio.h
  • SDIO_WAIT_FOR_PEND : at32f413_sdio.h
  • sdio_wait_type : at32f413_sdio.h
  • SDIOx : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SECTOR_NUM : utilities/at32f413_slib_demo/project_l0/src/main.c
  • sector_read() : operate_spim.c
  • sector_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • SECTOR_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • SECTOR_SIZE_1K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_2K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_4K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_WORD_CNT : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SENSE_KEY_ABORTED_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_BLANK_CHECK : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_DATA_PROTECT : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_HARDWARE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_ILLEGAL_REQUEST : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MEDIUM_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MISCOMPARE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NO_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NOT_READY : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_RECOVERED_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_UNIT_ATTENTION : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VENDERO_SPECIFIC : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VOLUME_OVERFLOW : cdc_msc_class.h, msc_bot_scsi.h
  • serial_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • SET : at32f413.h
  • SET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • SETUP_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c
  • setvar_periodvalue() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • SHIFT : cdc_keyboard_class.c, keyboard_class.c
  • show_card_info() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SLIB_DATA_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • slib_enable() : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_END_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_UNLOCK_KEY : at32f413_flash.h
  • SLOW : project/at_start_f413/templates/src/main.c
  • SNR_THRESHOLD_F32 : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • speed_change() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SPI1 : at32f413_spi.h
  • SPI1_BASE : at32f413.h
  • spi1_buffer_tx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • SPI1_GMUX_0001 : at32f413_gpio.h
  • SPI1_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • SPI1_IRQn : at32f413.h
  • SPI1_MUX_01 : at32f413_gpio.h
  • spi1_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • spi1_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • SPI2 : at32f413_spi.h
  • SPI2_BASE : at32f413.h
  • spi2_buffer_rx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • SPI2_GMUX_0001 : at32f413_gpio.h
  • SPI2_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • SPI2_IRQn : at32f413.h
  • spi2_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_rx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • SPI2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer_size : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi_byte_read() : spi_flash.h, spi_flash.c
  • spi_byte_write() : spi_flash.h, spi_flash.c
  • spi_bytes_read() : spi_flash.h, spi_flash.c
  • spi_bytes_write() : spi_flash.h, spi_flash.c
  • SPI_CCERR_FLAG : at32f413_spi.h
  • SPI_CLOCK_PHASE_1EDGE : at32f413_spi.h
  • SPI_CLOCK_PHASE_2EDGE : at32f413_spi.h
  • spi_clock_phase_type : at32f413_spi.h
  • SPI_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • SPI_CLOCK_POLARITY_LOW : at32f413_spi.h
  • spi_clock_polarity_type : at32f413_spi.h
  • spi_config() : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_crc_direction_type : at32f413_spi.h
  • spi_crc_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_next_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_get() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_set() : at32f413_spi.h, at32f413_spi.c
  • SPI_CRC_RX : at32f413_spi.h
  • SPI_CRC_TX : at32f413_spi.h
  • spi_crc_value_get() : at32f413_spi.h, at32f413_spi.c
  • SPI_CS_HARDWARE_MODE : at32f413_spi.h
  • spi_cs_mode_type : at32f413_spi.h
  • SPI_CS_SOFTWARE_MODE : at32f413_spi.h
  • spi_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • spi_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_FIRST_BIT_LSB : at32f413_spi.h
  • SPI_FIRST_BIT_MSB : at32f413_spi.h
  • spi_first_bit_type : at32f413_spi.h
  • SPI_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SPI_FRAME_16BIT : at32f413_spi.h
  • SPI_FRAME_8BIT : at32f413_spi.h
  • spi_frame_bit_num_set() : at32f413_spi.h, at32f413_spi.c
  • spi_frame_bit_num_type : at32f413_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_RX : at32f413_spi.h
  • spi_half_duplex_direction_set() : at32f413_spi.h, at32f413_spi.c
  • SPI_HALF_DUPLEX_DIRECTION_TX : at32f413_spi.h
  • spi_half_duplex_direction_type : at32f413_spi.h
  • spi_hardware_cs_output_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_BF_FLAG : at32f413_spi.h
  • spi_i2s_data_receive() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_data_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_receiver_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_transmitter_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_ERROR_INT : at32f413_spi.h
  • spi_i2s_flag_clear() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_flag_get() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_interrupt_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_RDBF_FLAG : at32f413_spi.h
  • SPI_I2S_RDBF_INT : at32f413_spi.h
  • spi_i2s_reset() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_ROERR_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_INT : at32f413_spi.h
  • spi_init() : at32f413_spi.h, at32f413_spi.c
  • spi_init_struct : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c
  • spi_master_slave_mode_type : at32f413_spi.h
  • SPI_MCLK_DIV_1024 : at32f413_spi.h
  • SPI_MCLK_DIV_128 : at32f413_spi.h
  • SPI_MCLK_DIV_16 : at32f413_spi.h
  • SPI_MCLK_DIV_2 : at32f413_spi.h
  • SPI_MCLK_DIV_256 : at32f413_spi.h
  • SPI_MCLK_DIV_32 : at32f413_spi.h
  • SPI_MCLK_DIV_4 : at32f413_spi.h
  • SPI_MCLK_DIV_512 : at32f413_spi.h
  • SPI_MCLK_DIV_64 : at32f413_spi.h
  • SPI_MCLK_DIV_8 : at32f413_spi.h
  • spi_mclk_freq_div_type : at32f413_spi.h
  • SPI_MMERR_FLAG : at32f413_spi.h
  • SPI_MODE_MASTER : at32f413_spi.h
  • SPI_MODE_SLAVE : at32f413_spi.h
  • SPI_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • spi_software_cs_internal_level_set() : at32f413_spi.h, at32f413_spi.c
  • spi_software_cs_level_type : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_LOW : at32f413_spi.h
  • SPI_TRANS_DMA : spi_flash.h
  • spi_transmission_mode_type : at32f413_spi.h
  • SPI_TRANSMIT_FULL_DUPLEX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_RX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_TX : at32f413_spi.h
  • SPI_TRANSMIT_SIMPLEX_RX : at32f413_spi.h
  • SPIF_BLOCKERASE : spi_flash.h
  • SPIF_CHIP_SIZE : spi_flash.h
  • SPIF_CHIPERASE : spi_flash.h
  • SPIF_DEVICEID : spi_flash.h
  • SPIF_FASTREADDATA : spi_flash.h
  • SPIF_FASTREADDUAL : spi_flash.h
  • SPIF_JEDECDEVICEID : spi_flash.h
  • SPIF_MANUFACTDEVICEID : spi_flash.h
  • SPIF_PAGE_SIZE : spi_flash.h
  • SPIF_PAGEPROGRAM : spi_flash.h
  • SPIF_POWERDOWN : spi_flash.h
  • SPIF_READDATA : spi_flash.h
  • SPIF_READSTATUSREG1 : spi_flash.h
  • SPIF_READSTATUSREG2 : spi_flash.h
  • SPIF_READSTATUSREG3 : spi_flash.h
  • SPIF_RELEASEPOWERDOWN : spi_flash.h
  • SPIF_SECTOR_SIZE : spi_flash.h
  • SPIF_SECTORERASE : spi_flash.h
  • SPIF_WRITEDISABLE : spi_flash.h
  • SPIF_WRITEENABLE : spi_flash.h
  • SPIF_WRITESTATUSREG1 : spi_flash.h
  • SPIF_WRITESTATUSREG2 : spi_flash.h
  • SPIF_WRITESTATUSREG3 : spi_flash.h
  • spiflash_init() : spi_flash.h, spi_flash.c
  • spiflash_page_write() : spi_flash.h, spi_flash.c
  • spiflash_read() : spi_flash.h, spi_flash.c
  • spiflash_read_id() : spi_flash.h, spi_flash.c
  • spiflash_read_sr1() : spi_flash.h, spi_flash.c
  • spiflash_sector_buf : spi_flash.c
  • spiflash_sector_erase() : spi_flash.h, spi_flash.c
  • spiflash_wait_busy() : spi_flash.h, spi_flash.c
  • spiflash_write() : spi_flash.h, spi_flash.c
  • spiflash_write_enable() : spi_flash.h, spi_flash.c
  • spiflash_write_nocheck() : spi_flash.h, spi_flash.c
  • SPIM_ERASE_TIMEOUT : at32f413_flash.h
  • SPIM_FLASH_BASE : at32f413.h
  • spim_init() : operate_spim.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c
  • spim_operate() : operate_spim.h, operate_spim.c
  • SPIM_PROGRAMMING_TIMEOUT : at32f413_flash.h
  • spim_run() : run_in_spim.h
  • SPIM_SECTOR_SIZE : operate_spim.h
  • SPIM_TEST_ADDR : operate_spim.h
  • SPK_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • spk_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • SPK_TX_FIFO_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • SRAM_BASE : at32f413.h
  • SRAM_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • src_buffer : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • src_const_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • std : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • step : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • STEP_DELAY_MS : at32f413_board.c
  • stop_flag : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • STREAM_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • stream_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • stream_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • student_num : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • sub_tmr_input_sel_type : at32f413_tmr.h
  • SUCCESS : at32f413.h
  • SVC_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • SVCall_IRQn : at32f413.h
  • SWAPBYTE : usb_std.h
  • switch_system_clock() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • swj_dp_config() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • SWJTAG_CONF_001 : at32f413_gpio.h
  • SWJTAG_CONF_010 : at32f413_gpio.h
  • SWJTAG_CONF_100 : at32f413_gpio.h
  • SWJTAG_GMUX_001 : at32f413_gpio.h
  • SWJTAG_GMUX_010 : at32f413_gpio.h
  • SWJTAG_GMUX_100 : at32f413_gpio.h
  • sys_counter : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • system_clock_config() : project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h, project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_clock.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c, project/at_start_f413/examples/can/filter/inc/at32f413_clock.h, project/at_start_f413/examples/can/filter/src/at32f413_clock.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h, project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_clock.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h, project/at_start_f413/examples/usart/irda/src/at32f413_clock.c, project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/polling/src/at32f413_clock.c, project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h, project/at_start_f413/examples/usart/printf/src/at32f413_clock.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h, project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c, project/at_start_f413/templates/inc/at32f413_clock.h, project/at_start_f413/templates/src/at32f413_clock.c, utilities/at32f413_freertos_demo/inc/at32f413_clock.h, utilities/at32f413_freertos_demo/src/at32f413_clock.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h, utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c
  • system_clock_config_for_acc() : project/at_start_f413/examples/acc/calibration/src/main.c
  • system_clock_recover() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • system_core_clock : system_at32f413.c, system_at32f413.h
  • system_core_clock_update() : system_at32f413.c, system_at32f413.h
  • SystemCoreClock : system_at32f413.h
  • SystemInit() : system_at32f413.c, system_at32f413.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 : at32f413_misc.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV : at32f413_misc.h
  • systick_clock_source_config() : at32f413_misc.h, at32f413_misc.c
  • systick_clock_source_type : at32f413_misc.h
  • systick_configuration() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • SysTick_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • systick_handler() : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
  • SysTick_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • T0_PROTOCOL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • table_week : rtc.c
  • TAMPER_IRQHandler() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c
  • TAMPER_IRQn : at32f413.h
  • temp_buf : utilities/at32f413_slib_demo/project_l0/src/main.c
  • TEST_BUFEER_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_FLASH_ADDRESS_START : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_LENGTH_SAMPLES : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • test_result : project/at_start_f413/examples/can/filter/src/main.c
  • TEST_SLIB_PSW : utilities/at32f413_slib_demo/project_l0/src/main.c
  • testInput_f32_1kHz_15kHz : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testMarks_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • testOutput : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testUnity_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • time_cnt : project/at_start_f413/examples/usart/printf/src/main.c
  • time_ira_cnt : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • timer_period : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • tmpCC4 : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • TMR1 : at32f413_tmr.h
  • TMR10_BASE : at32f413.h
  • TMR10_GMUX : at32f413_gpio.h
  • TMR11_BASE : at32f413.h
  • TMR11_GMUX : at32f413_gpio.h
  • TMR1_BASE : at32f413.h
  • TMR1_BRK_TMR9_IRQHandler() : project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c
  • TMR1_BRK_TMR9_IRQn : at32f413.h
  • TMR1_C1DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_C2DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_CH_IRQn : at32f413.h
  • tmr1_config() : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • TMR1_GMUX_0001 : at32f413_gpio.h
  • TMR1_MUX_01 : at32f413_gpio.h
  • TMR1_OVF_TMR10_IRQHandler() : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • TMR1_OVF_TMR10_IRQn : at32f413.h
  • TMR1_TRG_HALL_TMR11_IRQHandler() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • TMR1_TRG_HALL_TMR11_IRQn : at32f413.h
  • TMR2 : at32f413_tmr.h
  • TMR2_BASE : at32f413.h
  • tmr2_config() : project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c
  • TMR2_GLOBAL_IRQHandler() : project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • TMR2_GLOBAL_IRQn : at32f413.h
  • TMR2_GMUX_001 : at32f413_gpio.h
  • TMR2_GMUX_010 : at32f413_gpio.h
  • TMR2_GMUX_011 : at32f413_gpio.h
  • TMR2_MUX_01 : at32f413_gpio.h
  • TMR2_MUX_10 : at32f413_gpio.h
  • TMR2_MUX_11 : at32f413_gpio.h
  • TMR2ITR1_GMUX : at32f413_gpio.h
  • TMR3 : at32f413_tmr.h
  • TMR3_BASE : at32f413.h
  • TMR3_GLOBAL_IRQHandler() : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, app_led3_toggle/src/tmr.c, app_led4_toggle/src/tmr.c, bootloader/src/tmr.c
  • TMR3_GLOBAL_IRQn : at32f413.h
  • TMR3_GMUX_0010 : at32f413_gpio.h
  • TMR3_GMUX_0011 : at32f413_gpio.h
  • TMR3_MUX_10 : at32f413_gpio.h
  • TMR3_MUX_11 : at32f413_gpio.h
  • tmr3freq : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • TMR4 : at32f413_tmr.h
  • TMR4_BASE : at32f413.h
  • TMR4_GLOBAL_IRQn : at32f413.h
  • TMR5_BASE : at32f413.h
  • TMR5_GLOBAL_IRQHandler() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • TMR5_GLOBAL_IRQn : at32f413.h
  • TMR5_GMUX_001 : at32f413_gpio.h
  • TMR5CH4_GMUX : at32f413_gpio.h
  • TMR5CH4_MUX : at32f413_gpio.h
  • TMR8_BASE : at32f413.h
  • TMR8_BRK_IRQn : at32f413.h
  • TMR8_CH_IRQn : at32f413.h
  • TMR8_OVF_IRQn : at32f413.h
  • TMR8_TRG_HALL_IRQn : at32f413.h
  • TMR9_BASE : at32f413.h
  • TMR9_GMUX : at32f413_gpio.h
  • tmr_32_bit_function_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_base_init() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_BRK_ADDRESS : at32f413_tmr.h
  • TMR_BRK_FLAG : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_LOW : at32f413_tmr.h
  • TMR_BRK_INT : at32f413_tmr.h
  • tmr_brk_polarity_type : at32f413_tmr.h
  • TMR_BRK_SWTRIG : at32f413_tmr.h
  • tmr_brkdt_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_brkdt_config_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • tmr_brkdt_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_C1_DMA_REQUEST : at32f413_tmr.h
  • TMR_C1_FLAG : at32f413_tmr.h
  • TMR_C1_INT : at32f413_tmr.h
  • TMR_C1_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C1_SWTRIG : at32f413_tmr.h
  • TMR_C1DT_ADDRESS : at32f413_tmr.h
  • TMR_C2_DMA_REQUEST : at32f413_tmr.h
  • TMR_C2_FLAG : at32f413_tmr.h
  • TMR_C2_INT : at32f413_tmr.h
  • TMR_C2_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C2_SWTRIG : at32f413_tmr.h
  • TMR_C2DT_ADDRESS : at32f413_tmr.h
  • TMR_C3_DMA_REQUEST : at32f413_tmr.h
  • TMR_C3_FLAG : at32f413_tmr.h
  • TMR_C3_INT : at32f413_tmr.h
  • TMR_C3_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C3_SWTRIG : at32f413_tmr.h
  • TMR_C3DT_ADDRESS : at32f413_tmr.h
  • TMR_C4_DMA_REQUEST : at32f413_tmr.h
  • TMR_C4_FLAG : at32f413_tmr.h
  • TMR_C4_INT : at32f413_tmr.h
  • TMR_C4_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C4_SWTRIG : at32f413_tmr.h
  • TMR_C4DT_ADDRESS : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_DIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_INDIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_STI : at32f413_tmr.h
  • TMR_CCTRL_ADDRESS : at32f413_tmr.h
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR : at32f413_tmr.h
  • TMR_CHANEL1_CONNECTED_C1IRAW : at32f413_tmr.h
  • tmr_channel1_input_connected_type : at32f413_tmr.h
  • tmr_channel1_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_dma_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_enable() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CHANNEL_INPUT_DIV_1 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_2 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_4 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_8 : at32f413_tmr.h
  • tmr_channel_input_divider_type : at32f413_tmr.h
  • tmr_channel_select_type : at32f413_tmr.h
  • tmr_channel_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CLOCK_DIV1 : at32f413_tmr.h
  • TMR_CLOCK_DIV2 : at32f413_tmr.h
  • TMR_CLOCK_DIV4 : at32f413_tmr.h
  • tmr_clock_division_type : at32f413_tmr.h
  • tmr_clock_source_div_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CM1_ADDRESS : at32f413_tmr.h
  • TMR_CM2_ADDRESS : at32f413_tmr.h
  • tmr_cnt_dir_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_COUNT_DOWN : at32f413_tmr.h
  • tmr_count_mode_type : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_1 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_2 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_3 : at32f413_tmr.h
  • TMR_COUNT_UP : at32f413_tmr.h
  • tmr_counter_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CTRL1_ADDRESS : at32f413_tmr.h
  • TMR_CTRL2_ADDRESS : at32f413_tmr.h
  • TMR_CVAL_ADDRESS : at32f413_tmr.h
  • TMR_DIV_ADDRESS : at32f413_tmr.h
  • tmr_div_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_div_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_address_type : at32f413_tmr.h
  • tmr_dma_control_config() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_DMA_REQUEST_BY_CHANNEL : at32f413_tmr.h
  • TMR_DMA_REQUEST_BY_OVERFLOW : at32f413_tmr.h
  • tmr_dma_request_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_request_source_type : at32f413_tmr.h
  • tmr_dma_request_type : at32f413_tmr.h
  • TMR_DMA_TRANSFER_10BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_11BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_12BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_13BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_14BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_15BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_16BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_17BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_18BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_1BYTE : at32f413_tmr.h
  • TMR_DMA_TRANSFER_2BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_3BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_4BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_5BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_6BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_7BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_8BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_9BYTES : at32f413_tmr.h
  • tmr_dma_transfer_length_type : at32f413_tmr.h
  • TMR_DMACTRL_ADDRESS : at32f413_tmr.h
  • TMR_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_ENCODER_MODE_C : at32f413_tmr.h
  • tmr_encoder_mode_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_encoder_mode_type : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_1 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_2 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_4 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_8 : at32f413_tmr.h
  • TMR_ES_POLARITY_INVERTED : at32f413_tmr.h
  • TMR_ES_POLARITY_NON_INVERTED : at32f413_tmr.h
  • tmr_event_sw_trigger() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_event_trigger_type : at32f413_tmr.h
  • tmr_external_clock_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode1_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode2_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_signal_divider_type : at32f413_tmr.h
  • tmr_external_signal_polarity_type : at32f413_tmr.h
  • tmr_flag_clear() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_flag_get() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_FORCE_OUTPUT_HIGH : at32f413_tmr.h
  • TMR_FORCE_OUTPUT_LOW : at32f413_tmr.h
  • tmr_force_output_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_force_output_type : at32f413_tmr.h
  • TMR_HALL_DMA_REQUEST : at32f413_tmr.h
  • TMR_HALL_FLAG : at32f413_tmr.h
  • TMR_HALL_INT : at32f413_tmr.h
  • tmr_hall_select() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_HALL_SWTRIG : at32f413_tmr.h
  • tmr_ic_init_structure : project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR_IDEN_ADDRESS : at32f413_tmr.h
  • tmr_init() : app_led3_toggle/inc/tmr.h, app_led3_toggle/src/tmr.c, app_led4_toggle/inc/tmr.h, app_led4_toggle/src/tmr.c, bootloader/inc/tmr.h, bootloader/src/tmr.c
  • TMR_INPUT_BOTH_EDGE : at32f413_tmr.h
  • tmr_input_channel_divider_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_filter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_config_struct : project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c
  • tmr_input_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_direction_mapped_type : at32f413_tmr.h
  • TMR_INPUT_FALLING_EDGE : at32f413_tmr.h
  • tmr_input_polarity_type : at32f413_tmr.h
  • TMR_INPUT_RISING_EDGE : at32f413_tmr.h
  • tmr_internal_clock_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_interrupt_enable() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_ISTS_ADDRESS : at32f413_tmr.h
  • TMR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • tmr_oc_init_structure : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • tmr_one_cycle_mode_enable() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_OUTPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_ACTIVE_LOW : at32f413_tmr.h
  • tmr_output_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_immediately_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_polarity_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_switch_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_OUTPUT_CONTROL_FORCE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_LOW : at32f413_tmr.h
  • tmr_output_control_mode_type : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_OFF : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_A : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_B : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_SWITCH : at32f413_tmr.h
  • tmr_output_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_polarity_type : at32f413_tmr.h
  • tmr_output_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c
  • TMR_OVERFLOW_DMA_REQUEST : at32f413_tmr.h
  • tmr_overflow_event_disable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_overflow_request_source_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_OVERFLOW_SWTRIG : at32f413_tmr.h
  • TMR_OVF_FLAG : at32f413_tmr.h
  • TMR_OVF_INT : at32f413_tmr.h
  • tmr_period_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_POLARITY_ACTIVE_BOTH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_LOW : at32f413_tmr.h
  • tmr_polarity_active_type : at32f413_tmr.h
  • TMR_PR_ADDRESS : at32f413_tmr.h
  • tmr_primary_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_PRIMARY_SEL_C1ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C2ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C3ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C4ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_COMPARE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_ENABLE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_OVERFLOW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_RESET : at32f413_tmr.h
  • tmr_primary_select_type : at32f413_tmr.h
  • tmr_pwm_input_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_repetition_counter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_reset() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_RPR_ADDRESS : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_4 : at32f413_tmr.h
  • TMR_STCTRL_ADDRESS : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_C : at32f413_tmr.h
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A : at32f413_tmr.h
  • TMR_SUB_HANG_MODE : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1DF1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1INC : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C2DF2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_EXTIN : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS0 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS3 : at32f413_tmr.h
  • TMR_SUB_MODE_DIABLE : at32f413_tmr.h
  • tmr_sub_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_sub_mode_select_type : at32f413_tmr.h
  • TMR_SUB_RESET_MODE : at32f413_tmr.h
  • tmr_sub_sync_mode_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_SUB_TRIGGER_MODE : at32f413_tmr.h
  • TMR_SWEVT_ADDRESS : at32f413_tmr.h
  • TMR_TRIGGER_DMA_REQUEST : at32f413_tmr.h
  • TMR_TRIGGER_FLAG : at32f413_tmr.h
  • tmr_trigger_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_TRIGGER_INT : at32f413_tmr.h
  • TMR_TRIGGER_SWTRIG : at32f413_tmr.h
  • TMR_WP_LEVEL_1 : at32f413_tmr.h
  • TMR_WP_LEVEL_2 : at32f413_tmr.h
  • TMR_WP_LEVEL_3 : at32f413_tmr.h
  • tmr_wp_level_type : at32f413_tmr.h
  • TMR_WP_OFF : at32f413_tmr.h
  • transfer_end : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_error : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_status : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • transfer_status1 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status2 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status3 : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • transfer_status4 : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • TRUE : at32f413.h
  • tx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • tx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • tx_counter : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • tx_data_fill() : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • tx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • u16 : at32f413.h
  • u32 : at32f413.h
  • u8 : at32f413.h
  • UART4_BASE : at32f413.h
  • UART4_GMUX_0001 : at32f413_gpio.h
  • UART4_IRQn : at32f413.h
  • UART5_BASE : at32f413.h
  • UART5_IRQn : at32f413.h
  • uart_init() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/usart.h, bootloader/src/usart.c
  • uart_print_init() : at32f413_board.c, at32f413_board.h
  • uc16 : at32f413.h
  • uc32 : at32f413.h
  • uc8 : at32f413.h
  • UINT16 : at32f413.h
  • UINT32 : at32f413.h
  • UINT8 : at32f413.h
  • UNUSED : at32f413_def.h
  • UP_MOVE : mouse_class.h
  • UPDATE_CLEAR_FLAG : bootloader/inc/iap.h
  • UPDATE_DONE : bootloader/inc/iap.h
  • UPDATE_ING : bootloader/inc/iap.h
  • UPDATE_PRE : bootloader/inc/iap.h
  • update_status : bootloader/inc/iap.h, bootloader/src/iap.c
  • update_status_type : bootloader/inc/iap.h
  • UPGRADE_DONE : flash_fat16.h
  • UPGRADE_FAILED : flash_fat16.h
  • UPGRADE_JUMP : flash_fat16.h
  • UPGRADE_LARGE : flash_fat16.h
  • UPGRADE_READY : flash_fat16.h
  • upgrade_status_type : flash_fat16.h
  • UPGRADE_SUCCESS : flash_fat16.h
  • UPGRADE_UNKNOWN : flash_fat16.h
  • UPGRAGE_ONGOING : flash_fat16.h
  • UsageFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • UsageFault_IRQn : at32f413.h
  • USART1 : at32f413_usart.h
  • USART1_BASE : at32f413.h
  • usart1_config() : project/at_start_f413/examples/pwc/sleep_usart1/src/main.c
  • USART1_GMUX_0001 : at32f413_gpio.h
  • usart1_index : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c
  • USART1_IRQHandler() : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/src/usart.c
  • USART1_IRQn : at32f413.h
  • USART1_MUX : at32f413_gpio.h
  • USART2 : at32f413_usart.h
  • USART2_BASE : at32f413.h
  • USART2_IRQHandler() : project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • USART2_IRQn : at32f413.h
  • usart2_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart2_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • USART3_BASE : at32f413.h
  • USART3_GMUX_0001 : at32f413_gpio.h
  • USART3_IRQHandler() : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c
  • USART3_IRQn : at32f413.h
  • USART3_MUX_01 : at32f413_gpio.h
  • usart3_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART3_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • USART_BF_INT : at32f413_usart.h
  • USART_BFF_FLAG : at32f413_usart.h
  • USART_BREAK_10BITS : at32f413_usart.h
  • USART_BREAK_11BITS : at32f413_usart.h
  • usart_break_bit_num_set() : at32f413_usart.h, at32f413_usart.c
  • usart_break_bit_num_type : at32f413_usart.h
  • usart_break_send() : at32f413_usart.h, at32f413_usart.c
  • usart_buffer_size : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_clock_config() : at32f413_usart.h, at32f413_usart.c
  • usart_clock_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_CLOCK_LAST_BIT_NONE : at32f413_usart.h
  • USART_CLOCK_LAST_BIT_OUTPUT : at32f413_usart.h
  • USART_CLOCK_PHASE_1EDGE : at32f413_usart.h
  • USART_CLOCK_PHASE_2EDGE : at32f413_usart.h
  • usart_clock_phase_type : at32f413_usart.h
  • USART_CLOCK_POLARITY_HIGH : at32f413_usart.h
  • USART_CLOCK_POLARITY_LOW : at32f413_usart.h
  • usart_clock_polarity_type : at32f413_usart.h
  • usart_configuration() : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART_CTSCF_FLAG : at32f413_usart.h
  • USART_CTSCF_INT : at32f413_usart.h
  • USART_DATA_8BITS : at32f413_usart.h
  • USART_DATA_9BITS : at32f413_usart.h
  • usart_data_bit_num_type : at32f413_usart.h
  • usart_data_receive() : at32f413_usart.h, at32f413_usart.c
  • usart_data_transmit() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_ERR_INT : at32f413_usart.h
  • USART_FERR_FLAG : at32f413_usart.h
  • usart_flag_clear() : at32f413_usart.h, at32f413_usart.c
  • usart_flag_get() : at32f413_usart.h, at32f413_usart.c
  • usart_gpio_config() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_group_struct : bootloader/inc/usart.h, bootloader/src/usart.c
  • usart_hardware_flow_control_set() : at32f413_usart.h, at32f413_usart.c
  • usart_hardware_flow_control_type : at32f413_usart.h
  • USART_HARDWARE_FLOW_CTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_NONE : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS_CTS : at32f413_usart.h
  • USART_IDLE_INT : at32f413_usart.h
  • USART_IDLEF_FLAG : at32f413_usart.h
  • usart_init() : at32f413_usart.h, at32f413_usart.c
  • usart_interrupt_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_low_power_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_smartcard_division_set() : at32f413_usart.h, at32f413_usart.c
  • usart_lbcp_type : at32f413_usart.h
  • usart_lin_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • USART_NERR_FLAG : at32f413_usart.h
  • USART_PARITY_EVEN : at32f413_usart.h
  • USART_PARITY_NONE : at32f413_usart.h
  • USART_PARITY_ODD : at32f413_usart.h
  • usart_parity_selection_config() : at32f413_usart.h, at32f413_usart.c
  • usart_parity_selection_type : at32f413_usart.h
  • USART_PERR_FLAG : at32f413_usart.h
  • USART_PERR_INT : at32f413_usart.h
  • USART_RDBF_FLAG : at32f413_usart.h
  • USART_RDBF_INT : at32f413_usart.h
  • USART_REC_LEN : bootloader/inc/usart.h
  • usart_receive_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_receiver_mute_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_reset() : at32f413_usart.h, at32f413_usart.c
  • USART_ROERR_FLAG : at32f413_usart.h
  • usart_rx_buffer : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_rx_data_len : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_send_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_single_line_halfduplex_select() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_guard_time_set() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_nack_set() : at32f413_usart.h, at32f413_usart.c
  • usart_spi_configuration() : project/at_start_f413/examples/usart/synchronous/src/main.c
  • USART_STOP_0_5_BIT : at32f413_usart.h
  • USART_STOP_1_5_BIT : at32f413_usart.h
  • USART_STOP_1_BIT : at32f413_usart.h
  • USART_STOP_2_BIT : at32f413_usart.h
  • usart_stop_bit_num_type : at32f413_usart.h
  • USART_TDBE_FLAG : at32f413_usart.h
  • USART_TDBE_INT : at32f413_usart.h
  • USART_TDC_FLAG : at32f413_usart.h
  • USART_TDC_INT : at32f413_usart.h
  • usart_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_WAKEUP_BY_IDLE_FRAME : at32f413_usart.h
  • USART_WAKEUP_BY_MATCHING_ID : at32f413_usart.h
  • usart_wakeup_id_set() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_mode_set() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_mode_type : at32f413_usart.h
  • USB : at32f413_usb.h
  • USB_BE_FLAG : at32f413_usb.h
  • USB_BE_INT : at32f413_usb.h
  • usb_buffer : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_buffer_free() : at32f413_usb.h, at32f413_usb.c
  • usb_buffer_malloc() : at32f413_usb.h, at32f413_usb.c
  • USB_BUFFER_SIZE_EX : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h
  • USB_BUFFER_TABLE_ADDRESS : at32f413_usb.h
  • USB_CLASS_CODE_AUDIO : usb_std.h
  • USB_CLASS_CODE_CCID : usb_std.h
  • USB_CLASS_CODE_CDC : usb_std.h
  • USB_CLASS_CODE_CDCDATA : usb_std.h
  • USB_CLASS_CODE_HID : usb_std.h
  • USB_CLASS_CODE_HUB : usb_std.h
  • USB_CLASS_CODE_MSC : usb_std.h
  • USB_CLASS_CODE_PRINTER : usb_std.h
  • USB_CLASS_CODE_VENDOR : usb_std.h
  • USB_CLASS_CODE_VIDEO : usb_std.h
  • USB_CLEAR_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_CLEAR_EXF : at32f413_usb.h
  • USB_CLEAR_RXDTS : at32f413_usb.h
  • USB_CLEAR_RXTC : at32f413_usb.h
  • USB_CLEAR_TXDTS : at32f413_usb.h
  • USB_CLEAR_TXTC : at32f413_usb.h
  • usb_clk48_s : at32f413_usb.h
  • USB_CLK_HEXT : at32f413_usb.h
  • USB_CLK_HICK : at32f413_usb.h
  • usb_clock48m_select() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_CONF_REMOTE_WAKEUP : usb_std.h
  • USB_CONF_SELF_POWERED : usb_std.h
  • USB_CONFIG_STRING : usb_std.h
  • USB_CONN_STATE_ADDRESSED : usb_std.h
  • USB_CONN_STATE_CONFIGURED : usb_std.h
  • USB_CONN_STATE_DEFAULT : usb_std.h
  • USB_CONN_STATE_SUSPENDED : usb_std.h
  • usb_connect() : at32f413_usb.h, at32f413_usb.c
  • usb_core_dev : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_DBUF0_GET_LEN : at32f413_usb.h
  • USB_DBUF1_GET_LEN : at32f413_usb.h
  • usb_delay_ms() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • usb_delay_us() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_DESCIPTOR_TYPE_CONFIGURATION : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER : usb_std.h
  • USB_DESCIPTOR_TYPE_ENDPOINT : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE_POWER : usb_std.h
  • USB_DESCIPTOR_TYPE_OTHER_SPEED : usb_std.h
  • USB_DESCIPTOR_TYPE_STRING : usb_std.h
  • usb_dev_init() : at32f413_usb.h, at32f413_usb.c
  • USB_DEVICE_CFG_DESC_LEN : usb_std.h
  • USB_DEVICE_DESC_LEN : usb_std.h
  • USB_DEVICE_EPT_LEN : usb_std.h
  • USB_DEVICE_IF_DESC_LEN : usb_std.h
  • USB_DEVICE_LANGID_STR_DESC_LEN : usb_std.h
  • USB_DEVICE_OTG_DESC_LEN : usb_std.h
  • USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN : usb_std.h
  • USB_DEVICE_QUALIFIER_DESC_LEN : usb_std.h
  • usb_disconnect() : at32f413_usb.h, at32f413_usb.c
  • USB_ENDP_DESC_TABLE_OFFSET : at32f413_usb.c
  • usb_enter_suspend() : at32f413_usb.h, at32f413_usb.c
  • USB_EPT0 : at32f413_usb.h
  • USB_EPT0_DATA_IN : usb_std.h
  • USB_EPT0_DATA_OUT : usb_std.h
  • USB_EPT0_IDLE : usb_std.h
  • USB_EPT0_SETUP : usb_std.h
  • USB_EPT0_STALL : usb_std.h
  • USB_EPT0_STATUS_IN : usb_std.h
  • USB_EPT0_STATUS_OUT : usb_std.h
  • USB_EPT1 : at32f413_usb.h
  • USB_EPT2 : at32f413_usb.h
  • USB_EPT3 : at32f413_usb.h
  • USB_EPT4 : at32f413_usb.h
  • USB_EPT5 : at32f413_usb.h
  • USB_EPT6 : at32f413_usb.h
  • USB_EPT7 : at32f413_usb.h
  • USB_EPT_AUTO_MALLOC_BUFFER : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_EPT_BIT_MASK : at32f413_usb.h
  • USB_EPT_BULK : at32f413_usb.h
  • usb_ept_close() : at32f413_usb.h, at32f413_usb.c
  • USB_EPT_CONTROL : at32f413_usb.h
  • USB_EPT_DESC_BULK : usb_std.h
  • USB_EPT_DESC_CONTROL : usb_std.h
  • USB_EPT_DESC_DATA_EPT : usb_std.h
  • USB_EPT_DESC_FD_EPT : usb_std.h
  • USB_EPT_DESC_FDDATA_EPT : usb_std.h
  • USB_EPT_DESC_INTERRUPT : usb_std.h
  • USB_EPT_DESC_ISO : usb_std.h
  • USB_EPT_DESC_NSYNC : usb_std.h
  • USB_EPT_INT : at32f413_usb.h
  • USB_EPT_ISO : at32f413_usb.h
  • USB_EPT_NUM_FLAG : at32f413_usb.h
  • usb_ept_number_type : at32f413_usb.h
  • usb_ept_open() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_stall() : at32f413_usb.h, at32f413_usb.c
  • USB_EPTADDR : at32f413_usb.h
  • USB_ERROR : usb_std.h
  • USB_ETP_DESC_ADAPTIVE : usb_std.h
  • USB_ETP_DESC_ASYNC : usb_std.h
  • USB_ETP_DESC_SYNC : usb_std.h
  • USB_EXF : at32f413_usb.h
  • usb_exit_suspend() : at32f413_usb.h, at32f413_usb.c
  • USB_FAIL : usb_std.h
  • USB_FEATURE_EPT_HALT : usb_std.h
  • USB_FEATURE_REMOTE_WAKEUP : usb_std.h
  • USB_FEATURE_TEST_MODE : usb_std.h
  • usb_flag_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_flag_get() : at32f413_usb.h, at32f413_usb.c
  • USB_FLASH_ADDR_OFFSET : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • USB_FREE_DB_USER_BUFFER : at32f413_usb.h
  • USB_GET_RX_LEN : at32f413_usb.h
  • USB_GET_TX_LEN : at32f413_usb.h
  • usb_hid_buf_process() : audio_hid_class.c, custom_hid_class.c
  • usb_hid_keyboard_send_char() : keyboard_class.c, keyboard_class.h
  • usb_hid_mouse_send() : mouse_class.c, mouse_class.h
  • usb_iap_class_send_report() : hid_iap_class.c, hid_iap_class.h
  • USB_INOUT_FLAG : at32f413_usb.h
  • USB_INTERFACE_ASSOCIATION_TYPE : cdc_msc_desc.c
  • USB_INTERFACE_STRING : usb_std.h
  • usb_interrupt_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_keyboard_class_send_report() : keyboard_class.c, keyboard_class.h
  • USB_LANGID_STRING : usb_std.h
  • usb_low_power_wakeup_config() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • USB_LOW_POWER_WAKUP : project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h
  • USB_LSOF_FLAG : at32f413_usb.h
  • USB_LSOF_INT : at32f413_usb.h
  • USB_MAX_EP0_SIZE : usb_std.h
  • USB_MFC_STRING : usb_std.h
  • USB_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • usb_mouse_class_send_report() : mouse_class.c, mouse_class.h
  • USB_NOT_SUPPORT : usb_std.h
  • USB_OK : usb_std.h
  • USB_OUT_EPT_DOUBLE_BUF0 : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS_EX : at32f413_usb.h
  • usb_printer_get_rxdata() : printer_class.c, printer_class.h
  • usb_printer_send_data() : printer_class.c, printer_class.h
  • USB_PRODUCT_STRING : usb_std.h
  • usb_read_packet() : at32f413_usb.h, at32f413_usb.c
  • usb_reg_type : at32f413_usb.h
  • usb_remote_wkup_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_remote_wkup_set() : at32f413_usb.h, at32f413_usb.c
  • USB_REQ_DIR_DTH : usb_std.h
  • USB_REQ_DIR_HTD : usb_std.h
  • USB_REQ_RECIPIENT_DEVICE : usb_std.h
  • USB_REQ_RECIPIENT_ENDPOINT : usb_std.h
  • USB_REQ_RECIPIENT_INTERFACE : usb_std.h
  • USB_REQ_RECIPIENT_MASK : usb_std.h
  • USB_REQ_RECIPIENT_OTHER : usb_std.h
  • USB_REQ_TYPE_CLASS : usb_std.h
  • USB_REQ_TYPE_RESERVED : usb_std.h
  • USB_REQ_TYPE_STANDARD : usb_std.h
  • USB_REQ_TYPE_VENDOR : usb_std.h
  • usb_reset() : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • USB_RST_FLAG : at32f413_usb.h
  • USB_RST_INT : at32f413_usb.h
  • USB_RX_DISABLE : at32f413_usb.h
  • USB_RX_MASK : at32f413_usb.h
  • USB_RX_NAK : at32f413_usb.h
  • USB_RX_STALL : at32f413_usb.h
  • USB_RX_VALID : at32f413_usb.h
  • USB_RXDTS : at32f413_usb.h
  • USB_RXDTS0 : at32f413_usb.h
  • USB_RXDTS1 : at32f413_usb.h
  • USB_RXSTS : at32f413_usb.h
  • USB_RXTC : at32f413_usb.h
  • USB_SERIAL_STRING : usb_std.h
  • usb_set_address() : at32f413_usb.h, at32f413_usb.c
  • USB_SET_DOUBLE_BUFF0_ADDRESS : at32f413_usb.h
  • USB_SET_DOUBLE_BUFF1_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF0_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF1_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_SET_EXF : at32f413_usb.h
  • USB_SET_RX_ADDRESS : at32f413_usb.h
  • USB_SET_RXLEN : at32f413_usb.h
  • USB_SET_RXLEN_REG : at32f413_usb.h
  • USB_SET_RXSTS : at32f413_usb.h
  • USB_SET_TRANS_TYPE : at32f413_usb.h
  • USB_SET_TX_ADDRESS : at32f413_usb.h
  • USB_SET_TXLEN : at32f413_usb.h
  • USB_SET_TXSTS : at32f413_usb.h
  • USB_SETUPTC : at32f413_usb.h
  • USB_SOF_FLAG : at32f413_usb.h
  • USB_SOF_INT : at32f413_usb.h
  • USB_SP_FLAG : at32f413_usb.h
  • USB_SP_INT : at32f413_usb.h
  • USB_STD_REQ_CLEAR_FEATURE : usb_std.h
  • USB_STD_REQ_GET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_GET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_GET_INTERFACE : usb_std.h
  • USB_STD_REQ_GET_STATUS : usb_std.h
  • USB_STD_REQ_SET_ADDRESS : usb_std.h
  • USB_STD_REQ_SET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_SET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_SET_FEATURE : usb_std.h
  • USB_STD_REQ_SET_INTERFACE : usb_std.h
  • USB_STD_REQ_SYNCH_FRAME : usb_std.h
  • usb_sts_type : usb_std.h
  • USB_TC_FLAG : at32f413_usb.h
  • USB_TC_INT : at32f413_usb.h
  • USB_TOGGLE_RXDTS : at32f413_usb.h
  • USB_TOGGLE_TXDTS : at32f413_usb.h
  • USB_TRANS_TYPE : at32f413_usb.h
  • USB_TX_DISABLE : at32f413_usb.h
  • USB_TX_MASK : at32f413_usb.h
  • USB_TX_NAK : at32f413_usb.h
  • USB_TX_STALL : at32f413_usb.h
  • USB_TX_VALID : at32f413_usb.h
  • USB_TXDTS : at32f413_usb.h
  • USB_TXDTS0 : at32f413_usb.h
  • USB_TXDTS1 : at32f413_usb.h
  • USB_TXSTS : at32f413_usb.h
  • USB_TXTC : at32f413_usb.h
  • USB_UCFOR_FLAG : at32f413_usb.h
  • USB_UCFOR_INT : at32f413_usb.h
  • usb_usart_config() : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_usbbufs_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_vcp_cmd_process() : cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c
  • usb_vcp_get_rxdata() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcp_send_data() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcpkybrd_class_send_report() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_keyboard_send_char() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_get_rxdata() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_send_data() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • USB_VIRTUAL_COMPORT : project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • USB_WAIT : usb_std.h
  • USB_WK_FLAG : at32f413_usb.h
  • USB_WK_INT : at32f413_usb.h
  • usb_write_packet() : at32f413_usb.h, at32f413_usb.c
  • USBD_AUDIO_CONFIG_DESC_SIZE : audio_desc.h
  • USBD_AUDIO_DESC_CONFIGURATION_STRING : audio_desc.h
  • USBD_AUDIO_DESC_INTERFACE_STRING : audio_desc.h
  • USBD_AUDIO_DESC_MANUFACTURER_STRING : audio_desc.h
  • USBD_AUDIO_DESC_PRODUCT_STRING : audio_desc.h
  • USBD_AUDIO_FEEDBACK_EPT : audio_class.h
  • USBD_AUDIO_MIC_IN_EPT : audio_class.h
  • USBD_AUDIO_PRODUCT_ID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_LANGID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_SERIAL : audio_desc.h
  • USBD_AUDIO_SPK_OUT_EPT : audio_class.h
  • USBD_AUDIO_VENDOR_ID : audio_desc.h
  • USBD_AUHID_AUDIO_FEEDBACK_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_MIC_IN_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_SPK_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_CONFIG_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_DESC_CONFIGURATION_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_INTERFACE_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_MANUFACTURER_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_PRODUCT_STRING : audio_hid_desc.h
  • USBD_AUHID_HID_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_HID_IN_EPT : audio_hid_class.h
  • USBD_AUHID_HID_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_HID_SIZ_REPORT_DESC : audio_hid_desc.h
  • USBD_AUHID_IN_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_OUT_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_PRODUCT_ID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_LANGID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_SERIAL : audio_hid_desc.h
  • USBD_AUHID_VENDOR_ID : audio_hid_desc.h
  • USBD_CDC_BULK_IN_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_BULK_OUT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CMD_MAXPACKET_SIZE : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CONFIG_DESC_SIZE : cdc_desc.h
  • USBD_CDC_CS_ENDPOINT : usb_std.h
  • USBD_CDC_CS_INTERFACE : usb_std.h
  • USBD_CDC_DESC_CONFIGURATION_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_INTERFACE_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_MANUFACTURER_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_PRODUCT_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_IN_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_INT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_MSC_CONFIG_DESC_SIZE : cdc_msc_desc.h
  • USBD_CDC_MSC_IN_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_OUT_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_PRODUCT_ID : cdc_msc_desc.h
  • USBD_CDC_MSC_VENDOR_ID : cdc_msc_desc.h
  • USBD_CDC_OUT_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_PRODUCT_ID : cdc_desc.h
  • USBD_CDC_SIZ_STRING_LANGID : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SIZ_STRING_SERIAL : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SUBTYPE_ACM : usb_std.h
  • USBD_CDC_SUBTYPE_CMF : usb_std.h
  • USBD_CDC_SUBTYPE_HEADER : usb_std.h
  • USBD_CDC_SUBTYPE_UFD : usb_std.h
  • USBD_CDC_VENDOR_ID : cdc_desc.h
  • usbd_clear_feature() : usbd_sdr.c
  • usbd_clear_stall() : usbd_core.h, usbd_core.c
  • usbd_conn_state : usb_std.h
  • usbd_connect() : usbd_core.h, usbd_core.c
  • usbd_connect_state_get() : usbd_core.h, usbd_core.c
  • usbd_core_in_handler() : usbd_core.h, usbd_core.c
  • usbd_core_init() : usbd_core.h, usbd_core.c
  • usbd_core_out_handler() : usbd_core.h, usbd_core.c
  • usbd_core_setup_handler() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_unsupport() : usbd_core.h, usbd_core.c
  • USBD_CUSHID_CONFIG_DESC_SIZE : custom_hid_desc.h
  • USBD_CUSHID_DESC_CONFIGURATION_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_INTERFACE_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_MANUFACTURER_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_PRODUCT_STRING : custom_hid_desc.h
  • USBD_CUSHID_PRODUCT_ID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_REPORT_DESC : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_LANGID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_SERIAL : custom_hid_desc.h
  • USBD_CUSHID_VENDOR_ID : custom_hid_desc.h
  • USBD_CUSTOM_HID_IN_EPT : custom_hid_class.h
  • USBD_CUSTOM_HID_OUT_EPT : custom_hid_class.h
  • USBD_CUSTOM_IN_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_CUSTOM_OUT_MAXPACKET_SIZE : custom_hid_class.h
  • usbd_device_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_disconnect() : usbd_core.h, usbd_core.c
  • usbd_endpoint_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_enter_suspend() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_auto_define() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_custom_define() : usbd_core.h, usbd_core.c
  • usbd_ept_close() : usbd_core.h, usbd_core.c
  • usbd_ept_dbuffer_enable() : usbd_core.h, usbd_core.c
  • usbd_ept_defaut_init() : usbd_core.h, usbd_core.c
  • usbd_ept_loop_handler() : usbd_int.h, usbd_int.c
  • usbd_ept_open() : usbd_core.h, usbd_core.c
  • usbd_ept_recv() : usbd_core.h, usbd_core.c
  • usbd_ept_send() : usbd_core.h, usbd_core.c
  • usbd_eptn_handler() : usbd_int.h, usbd_int.c
  • USBD_ERR_EVENT : usbd_core.h
  • usbd_event_type : usbd_core.h
  • usbd_get_configuration() : usbd_sdr.c
  • usbd_get_descriptor() : usbd_sdr.c
  • usbd_get_recv_len() : usbd_core.h, usbd_core.c
  • usbd_get_status() : usbd_sdr.c
  • usbd_hid_iap_in_complete() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_hid_iap_process() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • USBD_HIDIAP_CONFIG_DESC_SIZE : hid_iap_desc.h
  • USBD_HIDIAP_DESC_CONFIGURATION_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_INTERFACE_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_MANUFACTURER_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_PRODUCT_STRING : hid_iap_desc.h
  • USBD_HIDIAP_IN_EPT : hid_iap_class.h
  • USBD_HIDIAP_IN_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_OUT_EPT : hid_iap_class.h
  • USBD_HIDIAP_OUT_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_PRODUCT_ID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_REPORT_DESC : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_LANGID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_SERIAL : hid_iap_desc.h
  • USBD_HIDIAP_VENDOR_ID : hid_iap_desc.h
  • USBD_IN_MAXPACKET_SIZE : msc_class.h
  • usbd_int_to_unicode() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_interface_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_irq_handler() : usbd_int.h, usbd_int.c
  • USBD_KEYBOARD_CONFIG_DESC_SIZE : keyboard_desc.h
  • USBD_KEYBOARD_DESC_CONFIGURATION_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_INTERFACE_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_MANUFACTURER_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_PRODUCT_STRING : keyboard_desc.h
  • USBD_KEYBOARD_IN_EPT : keyboard_class.h
  • USBD_KEYBOARD_IN_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_OUT_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_PRODUCT_ID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_REPORT_DESC : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_LANGID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_SERIAL : keyboard_desc.h
  • USBD_KEYBOARD_VENDOR_ID : keyboard_desc.h
  • USBD_MOUSE_CONFIG_DESC_SIZE : mouse_desc.h
  • USBD_MOUSE_DESC_CONFIGURATION_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_INTERFACE_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_MANUFACTURER_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_PRODUCT_STRING : mouse_desc.h
  • USBD_MOUSE_IN_EPT : mouse_class.h
  • USBD_MOUSE_IN_MAXPACKET_SIZE : mouse_class.h
  • USBD_MOUSE_PRODUCT_ID : mouse_desc.h
  • USBD_MOUSE_SIZ_REPORT_DESC : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_LANGID : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_SERIAL : mouse_desc.h
  • USBD_MOUSE_VENDOR_ID : mouse_desc.h
  • USBD_MSC_BULK_IN_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_BULK_OUT_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_CONFIG_DESC_SIZE : msc_desc.h
  • USBD_MSC_DESC_CONFIGURATION_STRING : msc_desc.h
  • USBD_MSC_DESC_INTERFACE_STRING : msc_desc.h
  • USBD_MSC_DESC_MANUFACTURER_STRING : msc_desc.h
  • USBD_MSC_DESC_PRODUCT_STRING : msc_desc.h
  • USBD_MSC_PRODUCT_ID : msc_desc.h
  • USBD_MSC_SIZ_STRING_LANGID : msc_desc.h
  • USBD_MSC_SIZ_STRING_SERIAL : msc_desc.h
  • USBD_MSC_VENDOR_ID : msc_desc.h
  • USBD_NOP_EVENT : usbd_core.h
  • USBD_OUT_MAXPACKET_SIZE : msc_class.h
  • USBD_PRINTER_BULK_IN_EPT : printer_class.h
  • USBD_PRINTER_BULK_OUT_EPT : printer_class.h
  • USBD_PRINTER_CONFIG_DESC_SIZE : printer_desc.h
  • USBD_PRINTER_DESC_CONFIGURATION_STRING : printer_desc.h
  • USBD_PRINTER_DESC_INTERFACE_STRING : printer_desc.h
  • USBD_PRINTER_DESC_MANUFACTURER_STRING : printer_desc.h
  • USBD_PRINTER_DESC_PRODUCT_STRING : printer_desc.h
  • USBD_PRINTER_IN_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_OUT_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_PRODUCT_ID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_LANGID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_SERIAL : printer_desc.h
  • USBD_PRINTER_VENDOR_ID : printer_desc.h
  • usbd_remote_wakeup() : usbd_core.h, usbd_core.c
  • USBD_RESET_EVENT : usbd_core.h
  • usbd_reset_handler() : usbd_int.h, usbd_int.c
  • usbd_set_address() : usbd_sdr.c
  • usbd_set_configuration() : usbd_sdr.c
  • usbd_set_device_addr() : usbd_core.h, usbd_core.c
  • usbd_set_feature() : usbd_sdr.c
  • usbd_set_stall() : usbd_core.h, usbd_core.c
  • usbd_setup_request_parse() : usbd_sdr.h, usbd_sdr.c
  • usbd_sof_handler() : usbd_int.h, usbd_int.c
  • USBD_SUSPEND_EVENT : usbd_core.h
  • usbd_suspend_handler() : usbd_int.h, usbd_int.c
  • usbd_unicode_convert() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • USBD_VCPKYBRD_CDC_BULK_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_BULK_OUT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_INT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CMD_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CONFIG_DESC_SIZE : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_CONFIGURATION_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_INTERFACE_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_MANUFACTURER_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_PRODUCT_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_HID_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_HID_SIZ_REPORT_DESC : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_IN_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_OUT_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_PRODUCT_ID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_LANGID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_SERIAL : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_VENDOR_ID : cdc_keyboard_desc.h
  • USBD_WAKEUP_EVENT : usbd_core.h
  • usbd_wakeup_handler() : usbd_int.h, usbd_int.c
  • USBFS_BASE : at32f413.h
  • USBFS_H_CAN1_TX_IRQn : at32f413.h
  • USBFS_L_CAN1_RX0_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • USBFS_L_CAN1_RX0_IRQn : at32f413.h
  • USBFS_MAPH_IRQn : at32f413.h
  • USBFS_MAPL_IRQn : at32f413.h
  • USBFSWakeUp_IRQn : at32f413.h
  • USD : at32f413_flash.h
  • USD_BASE : at32f413.h
  • USD_DEPSLP_NO_RST : at32f413_flash.h
  • USD_DEPSLP_RST : at32f413_flash.h
  • USD_STDBY_NO_RST : at32f413_flash.h
  • USD_STDBY_RST : at32f413_flash.h
  • USD_WDT_ATO_DISABLE : at32f413_flash.h
  • USD_WDT_ATO_ENABLE : at32f413_flash.h
  • USE_SLIB_FUNCTION : utilities/at32f413_slib_demo/project_l0/src/main.c
  • USE_STATIC_INIT : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • USER_BUTTON : at32f413_board.h
  • USER_BUTTON_CRM_CLK : at32f413_board.h
  • USER_BUTTON_PIN : at32f413_board.h
  • USER_BUTTON_PORT : at32f413_board.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • var : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • variables : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_addr : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_bit_val : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_GET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • vcp_keyboard_struct : cdc_keyboard_class.c
  • VCPKYBRD_BCD_NUM : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_DATA_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_HID_BINTERVAL_TIME : cdc_keyboard_desc.h
  • VCPKYBRD_KEYBOARD_INTERFACE : cdc_keyboard_desc.h
  • VCPMSC_CDC_DATA_INTERFACE : cdc_msc_desc.h
  • VCPMSC_CDC_INTERFACE : cdc_msc_desc.h
  • VCPMSC_MSC_INTERFACE : cdc_msc_desc.h
  • VECT_TAB_OFFSET : system_at32f413.c
  • vmor_flag_index : project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • vp_desc : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • vPortSVCHandler : FreeRTOSConfig.h
  • vs16 : at32f413.h
  • vs32 : at32f413.h
  • vs8 : at32f413.h
  • vsc16 : at32f413.h
  • vsc32 : at32f413.h
  • vsc8 : at32f413.h
  • vu16 : at32f413.h
  • vu32 : at32f413.h
  • vu8 : at32f413.h
  • vuc16 : at32f413.h
  • vuc32 : at32f413.h
  • vuc8 : at32f413.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • W25Q128 : spi_flash.h
  • W25Q16 : spi_flash.h
  • W25Q32 : spi_flash.h
  • W25Q64 : spi_flash.h
  • W25Q80 : spi_flash.h
  • WDT : at32f413_wdt.h
  • WDT_BASE : at32f413.h
  • WDT_CLK_DIV_128 : at32f413_wdt.h
  • WDT_CLK_DIV_16 : at32f413_wdt.h
  • WDT_CLK_DIV_256 : at32f413_wdt.h
  • WDT_CLK_DIV_32 : at32f413_wdt.h
  • WDT_CLK_DIV_4 : at32f413_wdt.h
  • WDT_CLK_DIV_64 : at32f413_wdt.h
  • WDT_CLK_DIV_8 : at32f413_wdt.h
  • WDT_CMD_ENABLE : at32f413_wdt.h
  • WDT_CMD_LOCK : at32f413_wdt.h
  • WDT_CMD_RELOAD : at32f413_wdt.h
  • WDT_CMD_UNLOCK : at32f413_wdt.h
  • wdt_cmd_value_type : at32f413_wdt.h
  • wdt_counter_reload() : at32f413_wdt.h, at32f413_wdt.c
  • WDT_DIVF_UPDATE_FLAG : at32f413_wdt.h
  • wdt_divider_set() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_division_type : at32f413_wdt.h
  • wdt_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_flag_get() : at32f413_wdt.h, at32f413_wdt.c
  • WDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • wdt_register_write_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_reload_value_set() : at32f413_wdt.h, at32f413_wdt.c
  • WDT_RLDF_UPDATE_FLAG : at32f413_wdt.h
  • weekday_table : project/at_start_f413/examples/rtc/calendar/src/main.c
  • WM8988_I2C_ADDR_CSB_HIGH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_I2C_ADDR_CSB_LOW : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R0_LEFT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R10_LEFT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R11_RIGHT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R12_BASS_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R13_TREBLE_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R14_ : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R15_RESET : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R16_3D_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R17_ALC1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R18_ALC2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R19_ALC3 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R1_RIGHT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R20_NOISE_GATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R21_LEFT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R22_RIGHT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R23_ADDITIONAL_1_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R24_ADDITIONAL_2_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R25_PWR_1_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R26_PWR_2_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R27_ADDITIONAL_3_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R2_LOUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R31_ADC_INPUT_MODE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R32_ADC_L_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R33_ADC_R_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R34_LEFT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R35_LEFT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R36_RIGHT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R37_RIGHT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R38_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R39_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R3_ROUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R40_LOUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R41_ROUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R42_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R43_LOW_POWER_PALYBACK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R4_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R5_ADC_DAC_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R6_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R7_AUDIO_INTERFACE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R8_SAMPLE_RATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R9_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_REG_BITW16 : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ16K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ48K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • work : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • write_buffer : operate_spim.c
  • WWDT : at32f413_wwdt.h
  • WWDT_BASE : at32f413.h
  • wwdt_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_divider_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_division_type : at32f413_wwdt.h
  • WWDT_EN_BIT : at32f413_wwdt.h
  • wwdt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_clear() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_get() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_interrupt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • WWDT_IRQn : at32f413.h
  • WWDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • WWDT_PCLK1_DIV_16384 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_32768 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_4096 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_8192 : at32f413_wwdt.h
  • wwdt_reset() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_window_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- x -

  • XMC_REG_BASE : at32f413.h
  • xPortPendSVHandler : FreeRTOSConfig.h
  • xPortSysTickHandler : FreeRTOSConfig.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- z -

  • ZOOM : project/at_start_f413/examples/cortex_m4/fpu/src/main.c


AT32F413 Firmwary Library: Globals

- _ -

  • __align() : diskio.c


AT32F413 Firmwary Library: Globals

- a -

  • acc_calibration_mode_enable() : at32f413_acc.h, at32f413_acc.c
  • acc_flag_clear() : at32f413_acc.h, at32f413_acc.c
  • acc_flag_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hickcal_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hicktrim_get() : at32f413_acc.h, at32f413_acc.c
  • acc_interrupt_enable() : at32f413_acc.h, at32f413_acc.c
  • ACC_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c
  • acc_read_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c3() : at32f413_acc.h, at32f413_acc.c
  • acc_step_set() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c3() : at32f413_acc.h, at32f413_acc.c
  • ADC1_2_IRQHandler() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c
  • adc_base_config() : at32f413_adc.h, at32f413_adc.c
  • adc_base_default_para_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_start() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_combine_mode_select() : at32f413_adc.h, at32f413_adc.c
  • adc_combine_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc_dma_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_clear() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_get() : at32f413_adc.h, at32f413_adc.c
  • adc_interrupt_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_part_count_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_auto_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_length_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_offset_value_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_reset() : at32f413_adc.h, at32f413_adc.c
  • adc_tempersensor_vintrv_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_single_channel_select() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_threshold_value_set() : at32f413_adc.h, at32f413_adc.c
  • alarm_init() : project/at_start_f413/examples/rtc/calendar/src/main.c
  • app_load() : bootloader/inc/iap.h, bootloader/src/iap.c
  • app_loop() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c
  • app_update_handle() : bootloader/src/iap.c
  • arm_apply_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_2pow() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_clip_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_fir_f32() : project_l0/inc/fir_filter.h, project_l1/inc/fir_filter.h
  • arm_fir_init_f32() : project_l0/inc/fir_filter.h, arm_fir_init_f32.c, project_l1/inc/fir_filter.h
  • arm_float_to_q12_20() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q14() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q28() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q29() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q30() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q7() : project_l0/src/math_helper.c, project_l1/src/math_helper.c
  • arm_snr_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • at32_board_init() : at32f413_board.c, at32f413_board.h
  • at32_button_init() : at32f413_board.c, at32f413_board.h
  • at32_button_press() : at32f413_board.c, at32f413_board.h
  • at32_button_state() : at32f413_board.c, at32f413_board.h
  • at32_led_init() : at32f413_board.c, at32f413_board.h
  • at32_led_off() : at32f413_board.c, at32f413_board.h
  • at32_led_on() : at32f413_board.c, at32f413_board.h
  • at32_led_toggle() : at32f413_board.c, at32f413_board.h
  • audio_codec_init() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_loop() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_get_data() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_modify_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_feedback() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_fifo_write() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_get_interface() : audio_class.c, audio_hid_class.c
  • audio_hid_class_send_report() : audio_hid_class.c, audio_hid_class.h
  • audio_req_get_cur() : audio_class.c, audio_hid_class.c
  • audio_req_get_max() : audio_class.c, audio_hid_class.c
  • audio_req_get_min() : audio_class.c, audio_hid_class.c
  • audio_req_get_res() : audio_class.c, audio_hid_class.c
  • audio_req_set_cur() : audio_class.c, audio_hid_class.c
  • audio_set_interface() : audio_class.c, audio_hid_class.c


AT32F413 Firmwary Library: Globals

- b -

  • back_err() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • back_ok() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • bot_cbw_decode() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_allow_medium_removal() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_check_address() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_clear_feature() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_cmd_process() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_datain_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_dataout_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_format_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_init() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_inquiry() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense6() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_read10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_request_sense() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_reset() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_csw() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_data() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_sense_code() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_stall() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_start_stop() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_test_unit() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_verify() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_write10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bpr_data_read() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_data_write() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_flag_clear() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_flag_get() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_interrupt_enable() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_reg_check() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_judge() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_write() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reset() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_clock_calibration_value_set() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_output_select() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_tamper_pin_active_level_set() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_tamper_pin_enable() : at32f413_bpr.h, at32f413_bpr.c
  • buffer_compare() : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • buffer_compare_24bits() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c
  • BusFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • button_exint_init() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/templates/src/main.c
  • button_isr() : project/at_start_f413/templates/src/main.c


AT32F413 Firmwary Library: Globals

- c -

  • CAN1_SE_IRQHandler() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_base_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_set() : at32f413_can.h, at32f413_can.c
  • can_configuration() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_debug_transmission_prohibit() : at32f413_can.h, at32f413_can.c
  • can_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_doze_mode_enter() : at32f413_can.h, at32f413_can.c
  • can_doze_mode_exit() : at32f413_can.h, at32f413_can.c
  • can_error_type_record_get() : at32f413_can.h, at32f413_can.c
  • can_filter_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_filter_init() : at32f413_can.h, at32f413_can.c
  • can_flag_clear() : at32f413_can.h, at32f413_can.c
  • can_flag_get() : at32f413_can.h, at32f413_can.c
  • can_gpio_config() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_interrupt_enable() : at32f413_can.h, at32f413_can.c
  • can_message_receive() : at32f413_can.h, at32f413_can.c
  • can_message_transmit() : at32f413_can.h, at32f413_can.c
  • can_operating_mode_set() : at32f413_can.h, at32f413_can.c
  • can_receive_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_receive_fifo_release() : at32f413_can.h, at32f413_can.c
  • can_receive_message_pending_get() : at32f413_can.h, at32f413_can.c
  • can_reset() : at32f413_can.h, at32f413_can.c
  • can_transmit_cancel() : at32f413_can.h, at32f413_can.c
  • can_transmit_data() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_transmit_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_transmit_status_get() : at32f413_can.h, at32f413_can.c
  • can_ttc_mode_enable() : at32f413_can.h, at32f413_can.c
  • cdc_class_setup_handler() : cdc_keyboard_class.c, cdc_msc_class.c
  • cdc_struct_init() : cdc_class.c, cdc_msc_class.c
  • check_card_programming() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • class_audio_setup_handler() : audio_hid_class.c
  • class_clear_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_rx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_tx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_event_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_hid_setup_handler() : audio_hid_class.c
  • class_in_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_init_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_out_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_setup_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_sof_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • clkout_config() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • clock_failure_detection_handler() : project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • codec_i2s_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • codec_i2s_reset() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • command_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • command_rsp1_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp2_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp3_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp4_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp5_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp6_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp7_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • config_flash_interrupt() : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • convert_from_bytes_to_power_of_two() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • copy_buff() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • crc_block_calculate() : at32f413_crc.h, at32f413_crc.c
  • crc_cal() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • crc_common_data_get() : at32f413_crc.h, at32f413_crc.c
  • crc_common_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_data_get() : at32f413_crc.h, at32f413_crc.c
  • crc_data_reset() : at32f413_crc.h, at32f413_crc.c
  • crc_init_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_one_word_calculate() : at32f413_crc.h, at32f413_crc.c
  • crc_poly_size_get() : at32f413_crc.h, at32f413_crc.c
  • crc_poly_size_set() : at32f413_crc.h, at32f413_crc.c
  • crc_poly_value_get() : at32f413_crc.h, at32f413_crc.c
  • crc_poly_value_set() : at32f413_crc.h, at32f413_crc.c
  • crc_reverse_input_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_reverse_output_data_set() : at32f413_crc.h, at32f413_crc.c
  • crm_adc_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_ahb_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb1_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb2_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_auto_step_mode_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_battery_powered_domain_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_clkout_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clkout_to_tmr10_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_failure_detection_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_out_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_source_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_clocks_freq_get() : at32f413_crm.h, at32f413_crm.c
  • crm_configuration() : project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • crm_flag_clear() : at32f413_crm.h, at32f413_crm.c
  • crm_flag_get() : at32f413_crm.h, at32f413_crm.c
  • crm_hext_bypass() : at32f413_crm.h, at32f413_crm.c
  • crm_hext_stable_wait() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_clock_calibration_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_clock_trimming_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_divider_select() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_sclk_frequency_select() : at32f413_crm.h, at32f413_crm.c
  • crm_interrupt_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_lext_bypass() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_sleep_mode_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_pll_config() : at32f413_crm.h, at32f413_crm.c
  • crm_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_select() : at32f413_crm.h, at32f413_crm.c
  • crm_sysclk_switch() : at32f413_crm.h, at32f413_crm.c
  • crm_sysclk_switch_status_get() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_clock_source_select() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_interrupt_remapping_set() : at32f413_crm.h, at32f413_crm.c
  • custom_hid_class_send_report() : custom_hid_class.c, custom_hid_class.h


AT32F413 Firmwary Library: Globals

- d -

  • data_take() : bootloader/src/iap.c
  • debug_device_id_get() : at32f413_debug.h, at32f413_debug.c
  • debug_periph_mode_set() : at32f413_debug.h, at32f413_debug.c
  • DebugMon_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • delay() : project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c
  • delay_init() : at32f413_board.c, at32f413_board.h
  • delay_ms() : at32f413_board.c, at32f413_board.h
  • delay_sec() : at32f413_board.c, at32f413_board.h
  • delay_us() : at32f413_board.c, at32f413_board.h
  • disk_initialize() : diskio.c
  • disk_ioctl() : diskio.c
  • disk_read() : diskio.c
  • disk_status() : diskio.c
  • disk_write() : diskio.c
  • DMA1_Channel1_IRQHandler() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel2_IRQHandler() : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel3_IRQHandler() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel4_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel5_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • DMA1_Channel6_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA1_Channel7_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA2_Channel1_IRQHandler() : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c
  • dma_channel_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • dma_configuration() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • dma_data_number_get() : at32f413_dma.h, at32f413_dma.c
  • dma_data_number_set() : at32f413_dma.h, at32f413_dma.c
  • dma_default_para_init() : at32f413_dma.h, at32f413_dma.c
  • dma_flag_clear() : at32f413_dma.h, at32f413_dma.c
  • dma_flag_get() : at32f413_dma.h, at32f413_dma.c
  • dma_flexible_config() : at32f413_dma.h, at32f413_dma.c
  • dma_init() : at32f413_dma.h, at32f413_dma.c
  • dma_interrupt_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_reset() : at32f413_dma.h, at32f413_dma.c


AT32F413 Firmwary Library: Globals

- e -

  • error_handler() : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • EXINT0_IRQHandler() : project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/templates/src/main.c
  • EXINT4_IRQHandler() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • EXINT9_5_IRQHandler() : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • exint_config() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • exint_default_para_init() : at32f413_exint.h, at32f413_exint.c
  • exint_event_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_clear() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_get() : at32f413_exint.h, at32f413_exint.c
  • exint_init() : at32f413_exint.h, at32f413_exint.c
  • exint_interrupt_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_line0_config() : project/at_start_f413/examples/exint/exint_config/src/main.c
  • exint_line4_config() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • exint_reset() : at32f413_exint.h, at32f413_exint.c
  • exint_software_interrupt_event_generate() : at32f413_exint.h, at32f413_exint.c
  • extend_sram() : project/at_start_f413/examples/sram/extend_sram/src/main.c


AT32F413 Firmwary Library: Globals

- f -

  • fat16_memory_cmp() : flash_fat16.c
  • fat16_memory_copy() : flash_fat16.c
  • fat16_memory_memset() : flash_fat16.c
  • fatfs_test() : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • FIR_lowpass_filter() : project_l0/inc/fir_filter.h, fir_filter.c, project_l1/inc/fir_filter.h
  • flash_2kb_write() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • flash_byte_program() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_calibrate() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_check() : flash_fat16.c
  • flash_epp_set() : at32f413_flash.h, at32f413_flash.c
  • flash_epp_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_fap_enable() : at32f413_flash.h, at32f413_flash.c
  • flash_fap_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_fat16_addr_offset() : flash_fat16.c
  • flash_fat16_boot_dir_write() : flash_fat16.c
  • flash_fat16_clear_upgrade_flag() : flash_fat16.c
  • flash_fat16_get_upgrade_flag() : flash_fat16.h, flash_fat16.c
  • flash_fat16_init() : flash_fat16.h, flash_fat16.c
  • flash_fat16_loop_status() : flash_fat16.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • flash_fat16_read() : flash_fat16.h, flash_fat16.c
  • flash_fat16_sector_write() : flash_fat16.c
  • flash_fat16_set_name() : flash_fat16.h, flash_fat16.c
  • flash_fat16_set_upgrade_flag() : flash_fat16.c
  • flash_fat16_write() : flash_fat16.h, flash_fat16.c
  • flash_flag_clear() : at32f413_flash.h, at32f413_flash.c
  • flash_flag_get() : at32f413_flash.h, at32f413_flash.c
  • flash_halfword_program() : at32f413_flash.h, at32f413_flash.c
  • flash_internal_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_interrupt_enable() : at32f413_flash.h, at32f413_flash.c
  • FLASH_IRQHandler() : utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c
  • flash_lock() : at32f413_flash.h, at32f413_flash.c
  • flash_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • flash_read() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_read_data() : flash_fat16.c
  • flash_sector_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_datastart_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_disable() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_enable() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_end_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_remaining_count_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_start_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_state_get() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_dummy_read() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_encryption_range_set() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_lock() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_mass_program() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_model_select() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_unlock() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_set() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_unlock() : at32f413_flash.h, at32f413_flash.c
  • flash_upgrade_flag_read() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • flash_user_system_data_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_user_system_data_program() : at32f413_flash.h, at32f413_flash.c
  • flash_word_program() : at32f413_flash.h, at32f413_flash.c
  • flash_write() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_write_data() : flash_fat16.c
  • flash_write_nocheck() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • fputc() : at32f413_board.c


AT32F413 Firmwary Library: Globals

- g -

  • generate_julia_fpu() : julia_fpu.h, julia_fpu.c
  • get_device_config_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_configuration() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_descriptor() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_interface_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_lang_id() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_manufacturer_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_other_speed() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_product_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_qualifier() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_serial_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_inquiry() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • get_serial_num() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_uid_for_seed() : random.c
  • getvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • gpio_bits_reset() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_set() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_write() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/gpio/io_toggle/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • gpio_configuration() : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • gpio_default_para_init() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_event_output_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_event_output_enable() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_exint_line_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_init() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_input_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_input_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_iomux_reset() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_output_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_output_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pin_remap_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pin_wp_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pins_toggle() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • gpio_port_write() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_reset() : at32f413_gpio.h, at32f413_gpio.c


AT32F413 Firmwary Library: Globals

- h -

  • HardFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c


AT32F413 Firmwary Library: Globals

- i -

  • I2C1_ERR_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C1_EVT_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C2_ERR_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2C2_EVT_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • i2c_7bit_address_send() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_ack_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_arp_mode_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_clock_stretch_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_config() : i2c_application.c, i2c_application.h
  • i2c_data_receive() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_data_send() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_config() : i2c_application.c
  • i2c_dma_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_end_transfer_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_rx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_dma_tx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_err_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_evt_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_fast_mode_duty_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_clear() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_get() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_general_call_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_init() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_interrupt_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_lowlevel_init() : i2c_application.c, i2c_application.h, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • i2c_master_read_addr() : i2c_application.c
  • i2c_master_receive() : i2c_application.c, i2c_application.h
  • i2c_master_receive_ack_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_master_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_master_receive_int() : i2c_application.c, i2c_application.h
  • i2c_master_rx_isr_int() : i2c_application.c
  • i2c_master_transmit() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_master_tx_isr_dma() : i2c_application.c
  • i2c_master_tx_isr_int() : i2c_application.c
  • i2c_master_write_addr() : i2c_application.c
  • i2c_memory_address_send() : i2c_application.c
  • i2c_memory_read() : i2c_application.c, i2c_application.h
  • i2c_memory_read_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_read_int() : i2c_application.c, i2c_application.h
  • i2c_memory_write() : i2c_application.c, i2c_application.h
  • i2c_memory_write_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_write_int() : i2c_application.c, i2c_application.h
  • i2c_own_address1_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_calculate_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_position_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_transmit_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_value_get() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_reset() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_int() : i2c_application.c, i2c_application.h
  • i2c_slave_rx_isr_int() : i2c_application.c
  • i2c_slave_transmit() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_slave_tx_isr_int() : i2c_application.c
  • i2c_slave_tx_rx_isr_dma() : i2c_application.c
  • i2c_smbus_alert_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_mode_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_software_reset() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_start_generate() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_stop_generate() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_wait_end() : i2c_application.c, i2c_application.h
  • i2c_wait_flag() : i2c_application.c, i2c_application.h
  • i2s_config() : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • i2s_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • i2s_enable() : at32f413_spi.h, at32f413_spi.c
  • i2s_init() : at32f413_spi.h, at32f413_spi.c
  • iap_address() : bootloader/src/hid_iap_user.c
  • iap_clear_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_command_handle() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c
  • iap_crc() : bootloader/src/hid_iap_user.c
  • iap_data_write() : bootloader/src/hid_iap_user.c
  • iap_erase_sector() : bootloader/src/hid_iap_user.c
  • iap_finish() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get_upgrade_flag() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_idle() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_init() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c, app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_jump() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_loop() : bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_respond() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_set_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_start() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_upgrade_app_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • incrementvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • is_leap_year() : rtc.c


AT32F413 Firmwary Library: Globals

- j -

  • jump_to_app() : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c


AT32F413 Firmwary Library: Globals

- k -

  • keyboard_class_setup_handler() : cdc_keyboard_class.c
  • keyboard_send_string() : project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c


AT32F413 Firmwary Library: Globals

- l -

  • led2_task_function() : utilities/at32f413_freertos_demo/src/main.c
  • led3_task_function() : utilities/at32f413_freertos_demo/src/main.c


AT32F413 Firmwary Library: Globals

- m -

  • main() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/cortex_m4/bit_band/src/main.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f413/examples/cortex_m4/fpu/src/main.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/flash/fap_enable/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/flash/operate_spim/src/main.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c, project/at_start_f413/examples/gpio/io_toggle/src/main.c, project/at_start_f413/examples/gpio/led_toggle/src/main.c, project/at_start_f413/examples/gpio/swjtag_remap/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c, project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c, project/at_start_f413/examples/pwc/sleep_usart1/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c, project/at_start_f413/examples/rtc/calendar/src/main.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/sram/extend_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/printf/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f413/examples/wdt/wdt_reset/src/main.c, project/at_start_f413/examples/wdt/wdt_standby/src/main.c, project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c, project/at_start_f413/templates/src/main.c, utilities/at32f413_freertos_demo/src/main.c, utilities/at32f413_gen_random_number_demo/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • mclk_tmr1_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MemManage_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • memset16_buffer() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • mmc_stream_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_stream_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mmc_stream_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • msc_class_setup_handler() : cdc_msc_class.c
  • msc_disk_capacity() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_read() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_write() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • my_memset() : arm_fir_init_f32.c


AT32F413 Firmwary Library: Globals

- n -

  • NMI_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • nvic_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c
  • nvic_irq_disable() : at32f413_misc.h, at32f413_misc.c
  • nvic_irq_enable() : at32f413_misc.h, at32f413_misc.c
  • nvic_lowpower_mode_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_priority_group_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_system_reset() : at32f413_misc.h, at32f413_misc.c
  • nvic_vector_table_set() : at32f413_misc.h, at32f413_misc.c


AT32F413 Firmwary Library: Globals

- p -

  • PendSV_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • pvm_exint_config() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c
  • PVM_IRQHandler() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c
  • pwc_battery_powered_domain_access() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_deep_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_clear() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_get() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_power_voltage_monitor_enable() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_pvm_level_select() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_reset() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_standby_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_wakeup_pin_enable() : at32f413_pwc.h, at32f413_pwc.c


AT32F413 Firmwary Library: Globals

- r -

  • randnum_test() : random.h, random.c
  • result_error() : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • rs485_config() : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_send_data() : project/at_start_f413/examples/usart/rs485/src/main.c
  • rtc_alarm_clock_set() : rtc.h, rtc.c
  • rtc_alarm_config() : project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_alarm_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_config() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • rtc_counter_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_counter_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_clear() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_init() : rtc.h, rtc.c
  • rtc_interrupt_enable() : at32f413_rtc.h, at32f413_rtc.c
  • RTC_IRQHandler() : project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • rtc_time_get() : rtc.h, rtc.c
  • rtc_time_set() : rtc.h, rtc.c
  • rtc_wait_config_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_wait_update_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_week_get() : rtc.c
  • RTCAlarm_IRQHandler() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c


AT32F413 Firmwary Library: Globals

- s -

  • sc_response_decode() : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART_IRQHandler() : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • sclk_192m_hick_config() : project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • sclk_64m_hick_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • sclk_96m_hext_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • scr_find() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sd_block_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_block_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_blocks_erase() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_bus_wide_enable() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sd_card_info_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_card_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_deselect_select() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_device_mode_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_dma_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_irq_service() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_multiple_blocks_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sd_power_off() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_power_on() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_single_block_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sd_state_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_status_send() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sd_test_error() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • sd_wide_bus_operation_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_write_disk() : diskio.c
  • SDIO1_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SDIO2_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_buffer_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_bus_width_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_bypass() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sdio_command_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_data_send() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_command_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_read() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_write() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_dma_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flag_clear() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flag_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flow_control_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_interrupt_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_io_function_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_io_suspend_command_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_saving_mode_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_status_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_mode_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_start() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_stop() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_reset() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • sector_read() : operate_spim.c
  • setvar_periodvalue() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • show_card_info() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • slib_enable() : utilities/at32f413_slib_demo/project_l0/src/main.c
  • speed_change() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SPI1_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • SPI2_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • spi_byte_read() : spi_flash.h, spi_flash.c
  • spi_byte_write() : spi_flash.h, spi_flash.c
  • spi_bytes_read() : spi_flash.h, spi_flash.c
  • spi_bytes_write() : spi_flash.h, spi_flash.c
  • spi_config() : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_crc_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_next_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_get() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_set() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_value_get() : at32f413_spi.h, at32f413_spi.c
  • spi_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • spi_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_frame_bit_num_set() : at32f413_spi.h, at32f413_spi.c
  • spi_half_duplex_direction_set() : at32f413_spi.h, at32f413_spi.c
  • spi_hardware_cs_output_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_data_receive() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_data_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_receiver_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_transmitter_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_flag_clear() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_flag_get() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_interrupt_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_reset() : at32f413_spi.h, at32f413_spi.c
  • spi_init() : at32f413_spi.h, at32f413_spi.c
  • spi_software_cs_internal_level_set() : at32f413_spi.h, at32f413_spi.c
  • spiflash_init() : spi_flash.h, spi_flash.c
  • spiflash_page_write() : spi_flash.h, spi_flash.c
  • spiflash_read() : spi_flash.h, spi_flash.c
  • spiflash_read_id() : spi_flash.h, spi_flash.c
  • spiflash_read_sr1() : spi_flash.h, spi_flash.c
  • spiflash_sector_erase() : spi_flash.h, spi_flash.c
  • spiflash_wait_busy() : spi_flash.h, spi_flash.c
  • spiflash_write() : spi_flash.h, spi_flash.c
  • spiflash_write_enable() : spi_flash.h, spi_flash.c
  • spiflash_write_nocheck() : spi_flash.h, spi_flash.c
  • spim_init() : operate_spim.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c
  • spim_operate() : operate_spim.h, operate_spim.c
  • spim_run() : run_in_spim.h
  • SVC_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • switch_system_clock() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • swj_dp_config() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • system_clock_config() : project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h, project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_clock.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c, project/at_start_f413/examples/can/filter/inc/at32f413_clock.h, project/at_start_f413/examples/can/filter/src/at32f413_clock.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h, project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_clock.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h, project/at_start_f413/examples/usart/irda/src/at32f413_clock.c, project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/polling/src/at32f413_clock.c, project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h, project/at_start_f413/examples/usart/printf/src/at32f413_clock.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h, project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c, project/at_start_f413/templates/inc/at32f413_clock.h, project/at_start_f413/templates/src/at32f413_clock.c, utilities/at32f413_freertos_demo/inc/at32f413_clock.h, utilities/at32f413_freertos_demo/src/at32f413_clock.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h, utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c
  • system_clock_config_for_acc() : project/at_start_f413/examples/acc/calibration/src/main.c
  • system_clock_recover() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • system_core_clock_update() : system_at32f413.c, system_at32f413.h
  • SystemInit() : system_at32f413.c, system_at32f413.h
  • systick_clock_source_config() : at32f413_misc.h, at32f413_misc.c
  • systick_configuration() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • SysTick_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • systick_handler() : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c


AT32F413 Firmwary Library: Globals

- t -

  • TAMPER_IRQHandler() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c
  • TMR1_BRK_TMR9_IRQHandler() : project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c
  • tmr1_config() : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • TMR1_OVF_TMR10_IRQHandler() : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • TMR1_TRG_HALL_TMR11_IRQHandler() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • tmr2_config() : project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c
  • TMR2_GLOBAL_IRQHandler() : project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • TMR3_GLOBAL_IRQHandler() : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, app_led3_toggle/src/tmr.c, app_led4_toggle/src/tmr.c, bootloader/src/tmr.c
  • TMR5_GLOBAL_IRQHandler() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • tmr_32_bit_function_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_base_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_brkdt_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_brkdt_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel1_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_dma_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_clock_source_div_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_cnt_dir_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_div_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_div_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_control_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_request_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_encoder_mode_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_event_sw_trigger() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode1_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode2_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_flag_clear() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_flag_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_force_output_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_hall_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_init() : app_led3_toggle/inc/tmr.h, app_led3_toggle/src/tmr.c, app_led4_toggle/inc/tmr.h, app_led4_toggle/src/tmr.c, bootloader/inc/tmr.h, bootloader/src/tmr.c
  • tmr_input_channel_divider_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_filter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_internal_clock_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_interrupt_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_one_cycle_mode_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_immediately_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_polarity_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_switch_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_overflow_event_disable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_overflow_request_source_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_primary_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_pwm_input_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_repetition_counter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_reset() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_sub_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_sub_sync_mode_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_trigger_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • tx_data_fill() : project/at_start_f413/examples/spi/w25q_flash/src/main.c


AT32F413 Firmwary Library: Globals

- u -

  • uart_init() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/usart.h, bootloader/src/usart.c
  • uart_print_init() : at32f413_board.c, at32f413_board.h
  • UsageFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h, project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • usart1_config() : project/at_start_f413/examples/pwc/sleep_usart1/src/main.c
  • USART1_IRQHandler() : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/src/usart.c
  • USART2_IRQHandler() : project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • USART3_IRQHandler() : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c
  • usart_break_bit_num_set() : at32f413_usart.h, at32f413_usart.c
  • usart_break_send() : at32f413_usart.h, at32f413_usart.c
  • usart_clock_config() : at32f413_usart.h, at32f413_usart.c
  • usart_clock_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_configuration() : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart_data_receive() : at32f413_usart.h, at32f413_usart.c
  • usart_data_transmit() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_flag_clear() : at32f413_usart.h, at32f413_usart.c
  • usart_flag_get() : at32f413_usart.h, at32f413_usart.c
  • usart_gpio_config() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_hardware_flow_control_set() : at32f413_usart.h, at32f413_usart.c
  • usart_init() : at32f413_usart.h, at32f413_usart.c
  • usart_interrupt_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_low_power_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_smartcard_division_set() : at32f413_usart.h, at32f413_usart.c
  • usart_lin_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_parity_selection_config() : at32f413_usart.h, at32f413_usart.c
  • usart_receive_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_receiver_mute_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_reset() : at32f413_usart.h, at32f413_usart.c
  • usart_send_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_single_line_halfduplex_select() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_guard_time_set() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_nack_set() : at32f413_usart.h, at32f413_usart.c
  • usart_spi_configuration() : project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_id_set() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_mode_set() : at32f413_usart.h, at32f413_usart.c
  • usb_buffer_free() : at32f413_usb.h, at32f413_usb.c
  • usb_buffer_malloc() : at32f413_usb.h, at32f413_usb.c
  • usb_clock48m_select() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_connect() : at32f413_usb.h, at32f413_usb.c
  • usb_delay_ms() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • usb_delay_us() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • usb_dev_init() : at32f413_usb.h, at32f413_usb.c
  • usb_disconnect() : at32f413_usb.h, at32f413_usb.c
  • usb_enter_suspend() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_close() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_open() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_stall() : at32f413_usb.h, at32f413_usb.c
  • usb_exit_suspend() : at32f413_usb.h, at32f413_usb.c
  • usb_flag_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_flag_get() : at32f413_usb.h, at32f413_usb.c
  • usb_hid_buf_process() : audio_hid_class.c, custom_hid_class.c
  • usb_hid_keyboard_send_char() : keyboard_class.c, keyboard_class.h
  • usb_hid_mouse_send() : mouse_class.c, mouse_class.h
  • usb_iap_class_send_report() : hid_iap_class.c, hid_iap_class.h
  • usb_interrupt_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_keyboard_class_send_report() : keyboard_class.c, keyboard_class.h
  • usb_low_power_wakeup_config() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • usb_mouse_class_send_report() : mouse_class.c, mouse_class.h
  • usb_printer_get_rxdata() : printer_class.c, printer_class.h
  • usb_printer_send_data() : printer_class.c, printer_class.h
  • usb_read_packet() : at32f413_usb.h, at32f413_usb.c
  • usb_remote_wkup_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_remote_wkup_set() : at32f413_usb.h, at32f413_usb.c
  • usb_reset() : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • usb_set_address() : at32f413_usb.h, at32f413_usb.c
  • usb_usart_config() : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_usbbufs_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_vcp_cmd_process() : cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c
  • usb_vcp_get_rxdata() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcp_send_data() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcpkybrd_class_send_report() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_keyboard_send_char() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_get_rxdata() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_send_data() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_write_packet() : at32f413_usb.h, at32f413_usb.c
  • usbd_clear_feature() : usbd_sdr.c
  • usbd_clear_stall() : usbd_core.h, usbd_core.c
  • usbd_connect() : usbd_core.h, usbd_core.c
  • usbd_connect_state_get() : usbd_core.h, usbd_core.c
  • usbd_core_in_handler() : usbd_core.h, usbd_core.c
  • usbd_core_init() : usbd_core.h, usbd_core.c
  • usbd_core_out_handler() : usbd_core.h, usbd_core.c
  • usbd_core_setup_handler() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_unsupport() : usbd_core.h, usbd_core.c
  • usbd_device_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_disconnect() : usbd_core.h, usbd_core.c
  • usbd_endpoint_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_enter_suspend() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_auto_define() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_custom_define() : usbd_core.h, usbd_core.c
  • usbd_ept_close() : usbd_core.h, usbd_core.c
  • usbd_ept_dbuffer_enable() : usbd_core.h, usbd_core.c
  • usbd_ept_defaut_init() : usbd_core.h, usbd_core.c
  • usbd_ept_loop_handler() : usbd_int.h, usbd_int.c
  • usbd_ept_open() : usbd_core.h, usbd_core.c
  • usbd_ept_recv() : usbd_core.h, usbd_core.c
  • usbd_ept_send() : usbd_core.h, usbd_core.c
  • usbd_eptn_handler() : usbd_int.h, usbd_int.c
  • usbd_get_configuration() : usbd_sdr.c
  • usbd_get_descriptor() : usbd_sdr.c
  • usbd_get_recv_len() : usbd_core.h, usbd_core.c
  • usbd_get_status() : usbd_sdr.c
  • usbd_hid_iap_in_complete() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_hid_iap_process() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_int_to_unicode() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_interface_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_irq_handler() : usbd_int.h, usbd_int.c
  • usbd_remote_wakeup() : usbd_core.h, usbd_core.c
  • usbd_reset_handler() : usbd_int.h, usbd_int.c
  • usbd_set_address() : usbd_sdr.c
  • usbd_set_configuration() : usbd_sdr.c
  • usbd_set_device_addr() : usbd_core.h, usbd_core.c
  • usbd_set_feature() : usbd_sdr.c
  • usbd_set_stall() : usbd_core.h, usbd_core.c
  • usbd_setup_request_parse() : usbd_sdr.h, usbd_sdr.c
  • usbd_sof_handler() : usbd_int.h, usbd_int.c
  • usbd_suspend_handler() : usbd_int.h, usbd_int.c
  • usbd_unicode_convert() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_wakeup_handler() : usbd_int.h, usbd_int.c
  • USBFS_L_CAN1_RX0_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c


AT32F413 Firmwary Library: Globals

- w -

  • wdt_counter_reload() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_divider_set() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_flag_get() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_register_write_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_reload_value_set() : at32f413_wdt.h, at32f413_wdt.c
  • wwdt_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_divider_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_clear() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_get() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_interrupt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_reset() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_window_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c


AT32F413 Firmwary Library: Globals

- _ -

  • _asciimap : cdc_keyboard_class.c, keyboard_class.c


AT32F413 Firmwary Library: Globals

- a -

  • acc_c2_value : project/at_start_f413/examples/acc/calibration/src/main.c
  • adc1_ordinary_value : project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • adc1_ordinary_valuetab : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc1_preempt_valuetab : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • ALIGNED_TAIL : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, composite_cdc_msc/msc_bot_scsi.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc/msc_bot_scsi.c, msc_desc.c, printer_class.c, printer_desc.c
  • atr_decode_status : project/at_start_f413/examples/usart/smartcard/src/main.c
  • audio_class_handler : audio_class.c, audio_class.h
  • audio_codec : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • audio_desc_handler : audio_desc.c, audio_desc.h
  • audio_hid_class_handler : audio_hid_class.c, audio_hid_class.h
  • audio_hid_desc_handler : audio_hid_desc.c, audio_hid_desc.h
  • audio_hid_struct : audio_hid_class.c
  • audio_struct : audio_class.c


AT32F413 Firmwary Library: Globals

- b -

  • bpr_addr_tab : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • buffer : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • buffer_ch1 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_ch2 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_read : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • buffer_write : project/at_start_f413/examples/flash/flash_write_read/src/main.c


AT32F413 Firmwary Library: Globals

- c -

  • calendar : rtc.h, rtc.c
  • capture : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • capturenumber : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • card_inserted : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_protocol : project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_type : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • cdc_class_handler : cdc_class.c, cdc_class.h
  • cdc_desc_handler : cdc_desc.c, cdc_desc.h
  • cdc_keyboard_class_handler : cdc_keyboard_class.c, cdc_keyboard_class.h
  • cdc_keyboard_desc_handler : cdc_keyboard_desc.c, cdc_keyboard_desc.h
  • cdc_msc_class_handler : cdc_msc_class.c, cdc_msc_class.h
  • cdc_msc_desc_handler : cdc_msc_desc.c, cdc_msc_desc.h
  • cdc_msc_struct : cdc_msc_class.c
  • cdc_struct : cdc_class.c
  • ch1_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch2_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3readvalue1 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch3readvalue2 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch4_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • channel1_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel2_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel3_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel4_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c
  • cid_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • cmd_addr_cnt : bootloader/src/iap.c
  • cmd_ctr_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • cmd_data_cnt : bootloader/src/iap.c
  • cmd_data_group_struct : bootloader/src/iap.c
  • cmd_data_group_type_struct : bootloader/inc/iap.h
  • cmd_data_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • config_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • counter : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • crc1_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • crc2_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • crc_value : project/at_start_f413/examples/crc/calculation/src/main.c
  • crm_clocks : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • crm_clocks_freq_struct : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • csd_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • custom_hid_class_handler : custom_hid_class.c, custom_hid_class.h
  • custom_hid_desc_handler : custom_hid_desc.c, custom_hid_desc.h
  • custom_hid_struct : custom_hid_class.c


AT32F413 Firmwary Library: Globals

- d -

  • data_buffer : project/at_start_f413/examples/crc/calculation/src/main.c
  • data_count : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • data_counter_end : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • device_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • device_mode : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • div_value : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c
  • dma1_trans_complete_flag : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c
  • dma_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • dma_init_structure : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dma_trans_complete_flag : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • dst_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • duty_cycle : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • duty_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dw_data_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_end_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c


AT32F413 Firmwary Library: Globals

- f -

  • fac_ms : at32f413_board.c
  • fac_us : at32f413_board.c
  • fat16_file_name : flash_fat16.c
  • fat16_root_dir_sector : flash_fat16.c
  • fat16_sector : flash_fat16.c
  • fat16_table_sector0 : flash_fat16.c
  • file : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • file_match : flash_fat16.c
  • file_write_nr : flash_fat16.c
  • firCoeffs32 : fir_coefficient.c, fir_filter.c
  • firStateF32 : fir_filter.c
  • flash_buf : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_iap : flash_fat16.h, flash_fat16.c
  • freq_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • frequency : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • fs : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c


AT32F413 Firmwary Library: Globals

- g -

  • g_audio_hid_usb_desc : audio_hid_desc.h
  • g_custom_hid_usb_desc : custom_hid_desc.h
  • g_file_attr : flash_fat16.c
  • g_hidiap_usb_desc : hid_iap_desc.h
  • g_keyboard_usb_desc : keyboard_desc.h
  • g_mouse_usb_desc : mouse_desc.h
  • g_speed : project/at_start_f413/templates/src/main.c
  • g_usb_offset_addr : at32f413_usb.c
  • g_usb_packet_address : at32f413_usb.h, at32f413_usb.c
  • g_usbd_audio_hid_report : audio_hid_desc.h
  • g_usbd_custom_hid_report : custom_hid_desc.h
  • g_usbd_hidiap_report : hid_iap_desc.h
  • g_usbd_keyboard_report : keyboard_desc.h
  • g_usbd_mouse_report : mouse_desc.h
  • g_usbd_vcpkybrd_hid_report : cdc_keyboard_desc.h
  • g_vcpkybrd_hid_usb_desc : cdc_keyboard_desc.h
  • get_data_from_usart_flag : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • gpio_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c


AT32F413 Firmwary Library: Globals

- h -

  • hi2cx : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • hid_iap_class_handler : hid_iap_class.c, hid_iap_class.h
  • hid_iap_desc_handler : hid_iap_desc.c, hid_iap_desc.h
  • hid_suspend_flag : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • hw_usart_read_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • hw_usart_rx_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

- i -

  • i2s1_buffer_tx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • i2s2_buffer_rx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • iap_flag : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c
  • iap_info : hid_iap_class.c, hid_iap_class.h
  • ic2value : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c


AT32F413 Firmwary Library: Globals

- j -

  • jump_to_app : bootloader/src/iap.c


AT32F413 Firmwary Library: Globals

- k -

  • keyboard_class_handler : keyboard_class.c, keyboard_class.h
  • keyboard_desc_handler : keyboard_desc.c, keyboard_desc.h
  • keyboard_struct : keyboard_class.c


AT32F413 Firmwary Library: Globals

- l -

  • langid_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • led2_handler : utilities/at32f413_freertos_demo/src/main.c
  • led3_handler : utilities/at32f413_freertos_demo/src/main.c
  • led_gpio_crm_clk : at32f413_board.c
  • led_gpio_pin : at32f413_board.c
  • led_gpio_port : at32f413_board.c
  • lickfreq : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • linecoding : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • linecoding_vcpkybrd : cdc_keyboard_class.c


AT32F413 Firmwary Library: Globals

- m -

  • max_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mean : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mic_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • min_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mon_table : rtc.c
  • mouse_class_handler : mouse_class.c, mouse_class.h
  • mouse_desc_handler : mouse_desc.c, mouse_desc.h
  • mouse_struct : mouse_class.c
  • msc_class_handler : msc_class.c, msc_class.h
  • msc_desc_handler : msc_desc.c, msc_desc.h
  • msc_flash_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • msc_struct : msc_class.c


AT32F413 Firmwary Library: Globals

- n -

  • numStudents : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • numSubjects : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c


AT32F413 Firmwary Library: Globals

- o -

  • operationcomplete : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • ov_cnt : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

- p -

  • periodvalue : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • pftarget : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • preempt_conversion_count : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • preempt_trigger_count : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • press_mouse : project/at_start_f413/examples/usb_device/mouse/src/main.c
  • printer_class_handler : printer_class.c, printer_class.h
  • printer_desc_handler : printer_desc.c, printer_desc.h
  • printer_struct : printer_class.c


AT32F413 Firmwary Library: Globals

- r -

  • rca : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • read_buffer : operate_spim.c
  • refOutput : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • reg_addr_data : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • report_buf : project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • rs485_buffer_rx : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_buffer_rx_cnt : project/at_start_f413/examples/usart/rs485/src/main.c
  • rx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • rx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • rx_counter : project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • rx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c


AT32F413 Firmwary Library: Globals

- s -

  • sblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sc_a2r_struct : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_baud_rate : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_clock_freq : project/at_start_f413/examples/usart/smartcard/src/main.c
  • scsi_inquiry : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c, virtual_msc_iap/src/msc_diskio.c
  • sd_card_info : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sdio_command_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_data_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sector_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • serial_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • spi1_buffer_tx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • spi1_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • spi1_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi2_buffer_rx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • spi2_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_rx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer_size : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi_init_struct : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c
  • spiflash_sector_buf : spi_flash.c
  • spk_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • src_buffer : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • src_const_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • std : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • step : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • stop_flag : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • stream_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • stream_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • student_num : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • sys_counter : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • system_core_clock : system_at32f413.c, system_at32f413.h


AT32F413 Firmwary Library: Globals

- t -

  • table_week : rtc.c
  • temp_buf : utilities/at32f413_slib_demo/project_l0/src/main.c
  • test_result : project/at_start_f413/examples/can/filter/src/main.c
  • testInput_f32_1kHz_15kHz : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testMarks_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • testOutput : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testUnity_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • time_cnt : project/at_start_f413/examples/usart/printf/src/main.c
  • time_ira_cnt : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • timer_period : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • tmpCC4 : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • tmr3freq : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • tmr_brkdt_config_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • tmr_ic_init_structure : project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • tmr_input_config_struct : project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c
  • tmr_oc_init_structure : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • tmr_output_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c
  • transfer_end : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_error : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_status : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • transfer_status1 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status2 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status3 : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • transfer_status4 : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • tx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • tx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • tx_counter : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • tx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c


AT32F413 Firmwary Library: Globals

- u -

  • update_status : bootloader/inc/iap.h, bootloader/src/iap.c
  • usart1_index : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c
  • usart2_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart2_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart_group_struct : bootloader/inc/usart.h, bootloader/src/usart.c
  • usart_rx_buffer : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_rx_data_len : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_buffer : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_core_dev : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c


AT32F413 Firmwary Library: Globals

- v -

  • var : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • variables : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_addr : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_bit_val : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • vcp_keyboard_struct : cdc_keyboard_class.c
  • vmor_flag_index : project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • vp_desc : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c


AT32F413 Firmwary Library: Globals

- w -

  • weekday_table : project/at_start_f413/examples/rtc/calendar/src/main.c
  • work : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • write_buffer : operate_spim.c


AT32F413 Firmwary Library: Globals

- i -

  • iapfun : bootloader/inc/iap.h
  • INT16 : at32f413.h
  • INT32 : at32f413.h
  • INT8 : at32f413.h
  • IRQn_Type : at32f413.h

- s -

  • s16 : at32f413.h
  • s32 : at32f413.h
  • s8 : at32f413.h
  • sc16 : at32f413.h
  • sc32 : at32f413.h
  • sc8 : at32f413.h

- u -

  • u16 : at32f413.h
  • u32 : at32f413.h
  • u8 : at32f413.h
  • uc16 : at32f413.h
  • uc32 : at32f413.h
  • uc8 : at32f413.h
  • UINT16 : at32f413.h
  • UINT32 : at32f413.h
  • UINT8 : at32f413.h
  • usb_reg_type : at32f413_usb.h

- v -

  • vs16 : at32f413.h
  • vs32 : at32f413.h
  • vs8 : at32f413.h
  • vsc16 : at32f413.h
  • vsc32 : at32f413.h
  • vsc8 : at32f413.h
  • vu16 : at32f413.h
  • vu32 : at32f413.h
  • vu8 : at32f413.h
  • vuc16 : at32f413.h
  • vuc32 : at32f413.h
  • vuc8 : at32f413.h


AT32F413 Firmwary Library: Globals

- a -

  • adc_channel_select_type : at32f413_adc.h
  • adc_combine_mode_type : at32f413_adc.h
  • adc_data_align_type : at32f413_adc.h
  • adc_ordinary_trig_select_type : at32f413_adc.h
  • adc_preempt_channel_type : at32f413_adc.h
  • adc_preempt_trig_select_type : at32f413_adc.h
  • adc_sampletime_select_type : at32f413_adc.h
  • adc_voltage_monitoring_type : at32f413_adc.h

- b -

  • bpr_data_type : at32f413_bpr.h
  • bpr_rtc_output_type : at32f413_bpr.h
  • bpr_tamper_pin_active_level_type : at32f413_bpr.h
  • button_type : at32f413_board.h

- c -

  • can_bts1_type : at32f413_can.h
  • can_bts2_type : at32f413_can.h
  • can_enter_doze_status_type : at32f413_can.h
  • can_error_record_type : at32f413_can.h
  • can_filter_bit_width_type : at32f413_can.h
  • can_filter_fifo_type : at32f413_can.h
  • can_filter_mode_type : at32f413_can.h
  • can_identifier_type : at32f413_can.h
  • can_mode_type : at32f413_can.h
  • can_msg_discarding_rule_type : at32f413_can.h
  • can_msg_sending_rule_type : at32f413_can.h
  • can_operating_mode_type : at32f413_can.h
  • can_quit_doze_status_type : at32f413_can.h
  • can_rsaw_type : at32f413_can.h
  • can_rx_fifo_num_type : at32f413_can.h
  • can_trans_frame_type : at32f413_can.h
  • can_transmit_status_type : at32f413_can.h
  • can_tx_mailbox_num_type : at32f413_can.h
  • cmd_ctr_step_type : bootloader/inc/iap.h
  • cmd_data_step_type : bootloader/inc/iap.h
  • confirm_state : at32f413.h
  • crc_poly_size_type : at32f413_crc.h
  • crc_reverse_input_type : at32f413_crc.h
  • crc_reverse_output_type : at32f413_crc.h
  • crm_adc_div_type : at32f413_crm.h
  • crm_ahb_div_type : at32f413_crm.h
  • crm_apb1_div_type : at32f413_crm.h
  • crm_apb2_div_type : at32f413_crm.h
  • crm_auto_step_mode_type : at32f413_crm.h
  • crm_clkout_div_type : at32f413_crm.h
  • crm_clkout_select_type : at32f413_crm.h
  • crm_clock_source_type : at32f413_crm.h
  • crm_hick_div_6_type : at32f413_crm.h
  • crm_hick_sclk_frequency_type : at32f413_crm.h
  • crm_periph_clock_sleepmd_type : at32f413_crm.h
  • crm_periph_clock_type : at32f413_crm.h
  • crm_periph_reset_type : at32f413_crm.h
  • crm_pll_clock_source_type : at32f413_crm.h
  • crm_pll_mult_type : at32f413_crm.h
  • crm_pll_output_range_type : at32f413_crm.h
  • crm_rtc_clock_type : at32f413_crm.h
  • crm_sclk_type : at32f413_crm.h
  • crm_usb_clock_source_type : at32f413_crm.h
  • crm_usb_div_type : at32f413_crm.h
  • crm_usb_int_map_type : at32f413_crm.h

- d -

  • data_trans_dir : at32f413_usb.h
  • dma_dir_type : at32f413_dma.h
  • dma_flexible_request_type : at32f413_dma.h
  • dma_memory_data_size_type : at32f413_dma.h
  • dma_memory_inc_type : at32f413_dma.h
  • dma_peripheral_data_size_type : at32f413_dma.h
  • dma_peripheral_inc_type : at32f413_dma.h
  • dma_priority_level_type : at32f413_dma.h

- e -

  • ept_inout_type : at32f413_usb.h
  • ept_trans_type : at32f413_usb.h
  • error_status : at32f413.h
  • exint_line_mode_type : at32f413_exint.h
  • exint_polarity_config_type : at32f413_exint.h

- f -

  • flag_status : at32f413.h
  • flash_spim_model_type : at32f413_flash.h
  • flash_status_type : at32f413_flash.h

- g -

  • gpio_drive_type : at32f413_gpio.h
  • gpio_mode_type : at32f413_gpio.h
  • gpio_output_type : at32f413_gpio.h
  • gpio_pins_source_type : at32f413_gpio.h
  • gpio_port_source_type : at32f413_gpio.h
  • gpio_pull_type : at32f413_gpio.h

- i -

  • i2c_address_mode_type : at32f413_i2c.h
  • i2c_direction_type : at32f413_i2c.h
  • i2c_fsmode_duty_cycle_type : at32f413_i2c.h
  • i2c_master_ack_type : at32f413_i2c.h
  • i2c_mem_address_width_type : i2c_application.h
  • i2c_mode_type : i2c_application.h
  • i2c_pec_position_type : at32f413_i2c.h
  • i2c_smbus_alert_set_type : at32f413_i2c.h
  • i2c_smbus_mode_set_type : at32f413_i2c.h
  • i2c_status_type : i2c_application.h
  • i2s_audio_protocol_type : at32f413_spi.h
  • i2s_audio_sampling_freq_type : at32f413_spi.h
  • i2s_clock_polarity_type : at32f413_spi.h
  • i2s_data_channel_format_type : at32f413_spi.h
  • i2s_operation_mode_type : at32f413_spi.h
  • iap_machine_state_type : hid_iap_class.h
  • iap_result_type : hid_iap_class.h
  • IRQn : at32f413.h

- l -

  • led_type : at32f413_board.h

- n -

  • nvic_lowpower_mode_type : at32f413_misc.h
  • nvic_priority_group_type : at32f413_misc.h

- p -

  • printer_req_type : printer_class.h
  • pwc_deep_sleep_enter_type : at32f413_pwc.h
  • pwc_pvm_voltage_type : at32f413_pwc.h
  • pwc_sleep_enter_type : at32f413_pwc.h

- s -

  • sd_card_state_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_data_transfer_mode_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_error_status_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_memory_card_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_block_size_type : at32f413_sdio.h
  • sdio_bus_width_type : at32f413_sdio.h
  • sdio_edge_phase_type : at32f413_sdio.h
  • sdio_power_state_type : at32f413_sdio.h
  • sdio_read_wait_mode_type : at32f413_sdio.h
  • sdio_reponse_type : at32f413_sdio.h
  • sdio_rsp_index_type : at32f413_sdio.h
  • sdio_transfer_direction_type : at32f413_sdio.h
  • sdio_transfer_mode_type : at32f413_sdio.h
  • sdio_wait_type : at32f413_sdio.h
  • spi_clock_phase_type : at32f413_spi.h
  • spi_clock_polarity_type : at32f413_spi.h
  • spi_crc_direction_type : at32f413_spi.h
  • spi_cs_mode_type : at32f413_spi.h
  • spi_first_bit_type : at32f413_spi.h
  • spi_frame_bit_num_type : at32f413_spi.h
  • spi_half_duplex_direction_type : at32f413_spi.h
  • spi_master_slave_mode_type : at32f413_spi.h
  • spi_mclk_freq_div_type : at32f413_spi.h
  • spi_software_cs_level_type : at32f413_spi.h
  • spi_transmission_mode_type : at32f413_spi.h
  • sub_tmr_input_sel_type : at32f413_tmr.h
  • systick_clock_source_type : at32f413_misc.h

- t -

  • tmr_brk_polarity_type : at32f413_tmr.h
  • tmr_channel1_input_connected_type : at32f413_tmr.h
  • tmr_channel_input_divider_type : at32f413_tmr.h
  • tmr_channel_select_type : at32f413_tmr.h
  • tmr_clock_division_type : at32f413_tmr.h
  • tmr_count_mode_type : at32f413_tmr.h
  • tmr_dma_address_type : at32f413_tmr.h
  • tmr_dma_request_source_type : at32f413_tmr.h
  • tmr_dma_request_type : at32f413_tmr.h
  • tmr_dma_transfer_length_type : at32f413_tmr.h
  • tmr_encoder_mode_type : at32f413_tmr.h
  • tmr_event_trigger_type : at32f413_tmr.h
  • tmr_external_signal_divider_type : at32f413_tmr.h
  • tmr_external_signal_polarity_type : at32f413_tmr.h
  • tmr_force_output_type : at32f413_tmr.h
  • tmr_input_direction_mapped_type : at32f413_tmr.h
  • tmr_input_polarity_type : at32f413_tmr.h
  • tmr_output_control_mode_type : at32f413_tmr.h
  • tmr_output_polarity_type : at32f413_tmr.h
  • tmr_polarity_active_type : at32f413_tmr.h
  • tmr_primary_select_type : at32f413_tmr.h
  • tmr_sub_mode_select_type : at32f413_tmr.h
  • tmr_wp_level_type : at32f413_tmr.h

- u -

  • update_status_type : bootloader/inc/iap.h
  • upgrade_status_type : flash_fat16.h
  • usart_break_bit_num_type : at32f413_usart.h
  • usart_clock_phase_type : at32f413_usart.h
  • usart_clock_polarity_type : at32f413_usart.h
  • usart_data_bit_num_type : at32f413_usart.h
  • usart_hardware_flow_control_type : at32f413_usart.h
  • usart_lbcp_type : at32f413_usart.h
  • usart_parity_selection_type : at32f413_usart.h
  • usart_stop_bit_num_type : at32f413_usart.h
  • usart_wakeup_mode_type : at32f413_usart.h
  • usb_clk48_s : at32f413_usb.h
  • usb_ept_number_type : at32f413_usb.h
  • usb_sts_type : usb_std.h
  • usbd_conn_state : usb_std.h
  • usbd_event_type : usbd_core.h

- w -

  • wdt_cmd_value_type : at32f413_wdt.h
  • wdt_division_type : at32f413_wdt.h
  • wwdt_division_type : at32f413_wwdt.h


AT32F413 Firmwary Library: Globals

- a -

  • ACC_IRQn : at32f413.h
  • ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH3 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR2CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR4CH4 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH2 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR3CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR4TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8TRGOUT : at32f413_adc.h
  • ADC1_2_IRQn : at32f413.h
  • ADC_CHANNEL_0 : at32f413_adc.h
  • ADC_CHANNEL_1 : at32f413_adc.h
  • ADC_CHANNEL_10 : at32f413_adc.h
  • ADC_CHANNEL_11 : at32f413_adc.h
  • ADC_CHANNEL_12 : at32f413_adc.h
  • ADC_CHANNEL_13 : at32f413_adc.h
  • ADC_CHANNEL_14 : at32f413_adc.h
  • ADC_CHANNEL_15 : at32f413_adc.h
  • ADC_CHANNEL_16 : at32f413_adc.h
  • ADC_CHANNEL_17 : at32f413_adc.h
  • ADC_CHANNEL_2 : at32f413_adc.h
  • ADC_CHANNEL_3 : at32f413_adc.h
  • ADC_CHANNEL_4 : at32f413_adc.h
  • ADC_CHANNEL_5 : at32f413_adc.h
  • ADC_CHANNEL_6 : at32f413_adc.h
  • ADC_CHANNEL_7 : at32f413_adc.h
  • ADC_CHANNEL_8 : at32f413_adc.h
  • ADC_CHANNEL_9 : at32f413_adc.h
  • ADC_INDEPENDENT_MODE : at32f413_adc.h
  • ADC_LEFT_ALIGNMENT : at32f413_adc.h
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_1 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_2 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_3 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_4 : at32f413_adc.h
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE : at32f413_adc.h
  • ADC_PREEMPT_SMLT_ONLY_MODE : at32f413_adc.h
  • ADC_RIGHT_ALIGNMENT : at32f413_adc.h
  • ADC_SAMPLETIME_13_5 : at32f413_adc.h
  • ADC_SAMPLETIME_1_5 : at32f413_adc.h
  • ADC_SAMPLETIME_239_5 : at32f413_adc.h
  • ADC_SAMPLETIME_28_5 : at32f413_adc.h
  • ADC_SAMPLETIME_41_5 : at32f413_adc.h
  • ADC_SAMPLETIME_55_5 : at32f413_adc.h
  • ADC_SAMPLETIME_71_5 : at32f413_adc.h
  • ADC_SAMPLETIME_7_5 : at32f413_adc.h
  • ADC_VMONITOR_ALL_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_ALL_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_NONE : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_PREEMPT : at32f413_adc.h


AT32F413 Firmwary Library: Globals

- b -

  • BPR_DATA1 : at32f413_bpr.h
  • BPR_DATA10 : at32f413_bpr.h
  • BPR_DATA11 : at32f413_bpr.h
  • BPR_DATA12 : at32f413_bpr.h
  • BPR_DATA13 : at32f413_bpr.h
  • BPR_DATA14 : at32f413_bpr.h
  • BPR_DATA15 : at32f413_bpr.h
  • BPR_DATA16 : at32f413_bpr.h
  • BPR_DATA17 : at32f413_bpr.h
  • BPR_DATA18 : at32f413_bpr.h
  • BPR_DATA19 : at32f413_bpr.h
  • BPR_DATA2 : at32f413_bpr.h
  • BPR_DATA20 : at32f413_bpr.h
  • BPR_DATA21 : at32f413_bpr.h
  • BPR_DATA22 : at32f413_bpr.h
  • BPR_DATA23 : at32f413_bpr.h
  • BPR_DATA24 : at32f413_bpr.h
  • BPR_DATA25 : at32f413_bpr.h
  • BPR_DATA26 : at32f413_bpr.h
  • BPR_DATA27 : at32f413_bpr.h
  • BPR_DATA28 : at32f413_bpr.h
  • BPR_DATA29 : at32f413_bpr.h
  • BPR_DATA3 : at32f413_bpr.h
  • BPR_DATA30 : at32f413_bpr.h
  • BPR_DATA31 : at32f413_bpr.h
  • BPR_DATA32 : at32f413_bpr.h
  • BPR_DATA33 : at32f413_bpr.h
  • BPR_DATA34 : at32f413_bpr.h
  • BPR_DATA35 : at32f413_bpr.h
  • BPR_DATA36 : at32f413_bpr.h
  • BPR_DATA37 : at32f413_bpr.h
  • BPR_DATA38 : at32f413_bpr.h
  • BPR_DATA39 : at32f413_bpr.h
  • BPR_DATA4 : at32f413_bpr.h
  • BPR_DATA40 : at32f413_bpr.h
  • BPR_DATA41 : at32f413_bpr.h
  • BPR_DATA42 : at32f413_bpr.h
  • BPR_DATA5 : at32f413_bpr.h
  • BPR_DATA6 : at32f413_bpr.h
  • BPR_DATA7 : at32f413_bpr.h
  • BPR_DATA8 : at32f413_bpr.h
  • BPR_DATA9 : at32f413_bpr.h
  • BPR_RTC_OUTPUT_ALARM : at32f413_bpr.h
  • BPR_RTC_OUTPUT_ALARM_TOGGLE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_NONE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND_TOGGLE : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_HIGH : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_LOW : at32f413_bpr.h
  • BusFault_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- c -

  • CAN1_RX1_IRQn : at32f413.h
  • CAN1_SE_IRQn : at32f413.h
  • CAN2_RX0_IRQn : at32f413.h
  • CAN2_RX1_IRQn : at32f413.h
  • CAN2_SE_IRQn : at32f413.h
  • CAN2_TX_IRQn : at32f413.h
  • CAN_BTS1_10TQ : at32f413_can.h
  • CAN_BTS1_11TQ : at32f413_can.h
  • CAN_BTS1_12TQ : at32f413_can.h
  • CAN_BTS1_13TQ : at32f413_can.h
  • CAN_BTS1_14TQ : at32f413_can.h
  • CAN_BTS1_15TQ : at32f413_can.h
  • CAN_BTS1_16TQ : at32f413_can.h
  • CAN_BTS1_1TQ : at32f413_can.h
  • CAN_BTS1_2TQ : at32f413_can.h
  • CAN_BTS1_3TQ : at32f413_can.h
  • CAN_BTS1_4TQ : at32f413_can.h
  • CAN_BTS1_5TQ : at32f413_can.h
  • CAN_BTS1_6TQ : at32f413_can.h
  • CAN_BTS1_7TQ : at32f413_can.h
  • CAN_BTS1_8TQ : at32f413_can.h
  • CAN_BTS1_9TQ : at32f413_can.h
  • CAN_BTS2_1TQ : at32f413_can.h
  • CAN_BTS2_2TQ : at32f413_can.h
  • CAN_BTS2_3TQ : at32f413_can.h
  • CAN_BTS2_4TQ : at32f413_can.h
  • CAN_BTS2_5TQ : at32f413_can.h
  • CAN_BTS2_6TQ : at32f413_can.h
  • CAN_BTS2_7TQ : at32f413_can.h
  • CAN_BTS2_8TQ : at32f413_can.h
  • CAN_DISCARDING_FIRST_RECEIVED : at32f413_can.h
  • CAN_DISCARDING_LAST_RECEIVED : at32f413_can.h
  • CAN_ENTER_DOZE_FAILED : at32f413_can.h
  • CAN_ENTER_DOZE_SUCCESSFUL : at32f413_can.h
  • CAN_ERRORRECORD_ACKERR : at32f413_can.h
  • CAN_ERRORRECORD_BITDOMINANTERR : at32f413_can.h
  • CAN_ERRORRECORD_BITRECESSIVEERR : at32f413_can.h
  • CAN_ERRORRECORD_CRCERR : at32f413_can.h
  • CAN_ERRORRECORD_FORMERR : at32f413_can.h
  • CAN_ERRORRECORD_NOERR : at32f413_can.h
  • CAN_ERRORRECORD_SOFTWARESETERR : at32f413_can.h
  • CAN_ERRORRECORD_STUFFERR : at32f413_can.h
  • CAN_FILTER_16BIT : at32f413_can.h
  • CAN_FILTER_32BIT : at32f413_can.h
  • CAN_FILTER_FIFO0 : at32f413_can.h
  • CAN_FILTER_FIFO1 : at32f413_can.h
  • CAN_FILTER_MODE_ID_LIST : at32f413_can.h
  • CAN_FILTER_MODE_ID_MASK : at32f413_can.h
  • CAN_ID_EXTENDED : at32f413_can.h
  • CAN_ID_STANDARD : at32f413_can.h
  • CAN_MODE_COMMUNICATE : at32f413_can.h
  • CAN_MODE_LISTENONLY : at32f413_can.h
  • CAN_MODE_LISTENONLY_LOOPBACK : at32f413_can.h
  • CAN_MODE_LOOPBACK : at32f413_can.h
  • CAN_OPERATINGMODE_COMMUNICATE : at32f413_can.h
  • CAN_OPERATINGMODE_DOZE : at32f413_can.h
  • CAN_OPERATINGMODE_FREEZE : at32f413_can.h
  • CAN_QUIT_DOZE_FAILED : at32f413_can.h
  • CAN_QUIT_DOZE_SUCCESSFUL : at32f413_can.h
  • CAN_RSAW_1TQ : at32f413_can.h
  • CAN_RSAW_2TQ : at32f413_can.h
  • CAN_RSAW_3TQ : at32f413_can.h
  • CAN_RSAW_4TQ : at32f413_can.h
  • CAN_RX_FIFO0 : at32f413_can.h
  • CAN_RX_FIFO1 : at32f413_can.h
  • CAN_SENDING_BY_ID : at32f413_can.h
  • CAN_SENDING_BY_REQUEST : at32f413_can.h
  • CAN_TFT_DATA : at32f413_can.h
  • CAN_TFT_REMOTE : at32f413_can.h
  • CAN_TX_MAILBOX0 : at32f413_can.h
  • CAN_TX_MAILBOX1 : at32f413_can.h
  • CAN_TX_MAILBOX2 : at32f413_can.h
  • CAN_TX_STATUS_FAILED : at32f413_can.h
  • CAN_TX_STATUS_NO_EMPTY : at32f413_can.h
  • CAN_TX_STATUS_PENDING : at32f413_can.h
  • CAN_TX_STATUS_SUCCESSFUL : at32f413_can.h
  • CMD_CTR_APP : bootloader/inc/iap.h
  • CMD_CTR_DONE : bootloader/inc/iap.h
  • CMD_CTR_ERR : bootloader/inc/iap.h
  • CMD_CTR_IDLE : bootloader/inc/iap.h
  • CMD_CTR_INIT : bootloader/inc/iap.h
  • CMD_DATA_ADDR : bootloader/inc/iap.h
  • CMD_DATA_BUF : bootloader/inc/iap.h
  • CMD_DATA_CHACK : bootloader/inc/iap.h
  • CMD_DATA_DONE : bootloader/inc/iap.h
  • CMD_DATA_ERR : bootloader/inc/iap.h
  • CMD_DATA_IDLE : bootloader/inc/iap.h
  • CRC_POLY_SIZE_16B : at32f413_crc.h
  • CRC_POLY_SIZE_32B : at32f413_crc.h
  • CRC_POLY_SIZE_7B : at32f413_crc.h
  • CRC_POLY_SIZE_8B : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_BYTE : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_HALFWORD : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_WORD : at32f413_crc.h
  • CRC_REVERSE_INPUT_NO_AFFECTE : at32f413_crc.h
  • CRC_REVERSE_OUTPUT_DATA : at32f413_crc.h
  • CRC_REVERSE_OUTPUT_NO_AFFECTE : at32f413_crc.h
  • CRM_ACC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ACC_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC1_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC2_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC_DIV_12 : at32f413_crm.h
  • CRM_ADC_DIV_16 : at32f413_crm.h
  • CRM_ADC_DIV_2 : at32f413_crm.h
  • CRM_ADC_DIV_4 : at32f413_crm.h
  • CRM_ADC_DIV_6 : at32f413_crm.h
  • CRM_ADC_DIV_8 : at32f413_crm.h
  • CRM_AHB_DIV_1 : at32f413_crm.h
  • CRM_AHB_DIV_128 : at32f413_crm.h
  • CRM_AHB_DIV_16 : at32f413_crm.h
  • CRM_AHB_DIV_2 : at32f413_crm.h
  • CRM_AHB_DIV_256 : at32f413_crm.h
  • CRM_AHB_DIV_4 : at32f413_crm.h
  • CRM_AHB_DIV_512 : at32f413_crm.h
  • CRM_AHB_DIV_64 : at32f413_crm.h
  • CRM_AHB_DIV_8 : at32f413_crm.h
  • CRM_APB1_DIV_1 : at32f413_crm.h
  • CRM_APB1_DIV_16 : at32f413_crm.h
  • CRM_APB1_DIV_2 : at32f413_crm.h
  • CRM_APB1_DIV_4 : at32f413_crm.h
  • CRM_APB1_DIV_8 : at32f413_crm.h
  • CRM_APB2_DIV_1 : at32f413_crm.h
  • CRM_APB2_DIV_16 : at32f413_crm.h
  • CRM_APB2_DIV_2 : at32f413_crm.h
  • CRM_APB2_DIV_4 : at32f413_crm.h
  • CRM_APB2_DIV_8 : at32f413_crm.h
  • CRM_AUTO_STEP_MODE_DISABLE : at32f413_crm.h
  • CRM_AUTO_STEP_MODE_ENABLE : at32f413_crm.h
  • CRM_BPR_PERIPH_CLOCK : at32f413_crm.h
  • CRM_BPR_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN1_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN2_PERIPH_RESET : at32f413_crm.h
  • CRM_CLKOUT_ADC : at32f413_crm.h
  • CRM_CLKOUT_DIV_1 : at32f413_crm.h
  • CRM_CLKOUT_DIV_128 : at32f413_crm.h
  • CRM_CLKOUT_DIV_16 : at32f413_crm.h
  • CRM_CLKOUT_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_DIV_256 : at32f413_crm.h
  • CRM_CLKOUT_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_DIV_512 : at32f413_crm.h
  • CRM_CLKOUT_DIV_64 : at32f413_crm.h
  • CRM_CLKOUT_DIV_8 : at32f413_crm.h
  • CRM_CLKOUT_HEXT : at32f413_crm.h
  • CRM_CLKOUT_HICK : at32f413_crm.h
  • CRM_CLKOUT_LEXT : at32f413_crm.h
  • CRM_CLKOUT_LICK : at32f413_crm.h
  • CRM_CLKOUT_NOCLK : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_SCLK : at32f413_crm.h
  • CRM_CLKOUT_USB : at32f413_crm.h
  • CRM_CLOCK_SOURCE_HEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_PLL : at32f413_crm.h
  • CRM_CRC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_EXINT_PERIPH_RESET : at32f413_crm.h
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_GPIOA_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOA_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOB_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOC_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOD_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOD_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOF_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOF_PERIPH_RESET : at32f413_crm.h
  • CRM_HICK48_DIV6 : at32f413_crm.h
  • CRM_HICK48_NODIV : at32f413_crm.h
  • CRM_HICK_SCLK_48MHZ : at32f413_crm.h
  • CRM_HICK_SCLK_8MHZ : at32f413_crm.h
  • CRM_I2C1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C1_PERIPH_RESET : at32f413_crm.h
  • CRM_I2C2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C2_PERIPH_RESET : at32f413_crm.h
  • CRM_IOMUX_PERIPH_CLOCK : at32f413_crm.h
  • CRM_IOMUX_PERIPH_RESET : at32f413_crm.h
  • CRM_IRQn : at32f413.h
  • CRM_PLL_MULT_10 : at32f413_crm.h
  • CRM_PLL_MULT_11 : at32f413_crm.h
  • CRM_PLL_MULT_12 : at32f413_crm.h
  • CRM_PLL_MULT_13 : at32f413_crm.h
  • CRM_PLL_MULT_14 : at32f413_crm.h
  • CRM_PLL_MULT_15 : at32f413_crm.h
  • CRM_PLL_MULT_16 : at32f413_crm.h
  • CRM_PLL_MULT_17 : at32f413_crm.h
  • CRM_PLL_MULT_18 : at32f413_crm.h
  • CRM_PLL_MULT_19 : at32f413_crm.h
  • CRM_PLL_MULT_2 : at32f413_crm.h
  • CRM_PLL_MULT_20 : at32f413_crm.h
  • CRM_PLL_MULT_21 : at32f413_crm.h
  • CRM_PLL_MULT_22 : at32f413_crm.h
  • CRM_PLL_MULT_23 : at32f413_crm.h
  • CRM_PLL_MULT_24 : at32f413_crm.h
  • CRM_PLL_MULT_25 : at32f413_crm.h
  • CRM_PLL_MULT_26 : at32f413_crm.h
  • CRM_PLL_MULT_27 : at32f413_crm.h
  • CRM_PLL_MULT_28 : at32f413_crm.h
  • CRM_PLL_MULT_29 : at32f413_crm.h
  • CRM_PLL_MULT_3 : at32f413_crm.h
  • CRM_PLL_MULT_30 : at32f413_crm.h
  • CRM_PLL_MULT_31 : at32f413_crm.h
  • CRM_PLL_MULT_32 : at32f413_crm.h
  • CRM_PLL_MULT_33 : at32f413_crm.h
  • CRM_PLL_MULT_34 : at32f413_crm.h
  • CRM_PLL_MULT_35 : at32f413_crm.h
  • CRM_PLL_MULT_36 : at32f413_crm.h
  • CRM_PLL_MULT_37 : at32f413_crm.h
  • CRM_PLL_MULT_38 : at32f413_crm.h
  • CRM_PLL_MULT_39 : at32f413_crm.h
  • CRM_PLL_MULT_4 : at32f413_crm.h
  • CRM_PLL_MULT_40 : at32f413_crm.h
  • CRM_PLL_MULT_41 : at32f413_crm.h
  • CRM_PLL_MULT_42 : at32f413_crm.h
  • CRM_PLL_MULT_43 : at32f413_crm.h
  • CRM_PLL_MULT_44 : at32f413_crm.h
  • CRM_PLL_MULT_45 : at32f413_crm.h
  • CRM_PLL_MULT_46 : at32f413_crm.h
  • CRM_PLL_MULT_47 : at32f413_crm.h
  • CRM_PLL_MULT_48 : at32f413_crm.h
  • CRM_PLL_MULT_49 : at32f413_crm.h
  • CRM_PLL_MULT_5 : at32f413_crm.h
  • CRM_PLL_MULT_50 : at32f413_crm.h
  • CRM_PLL_MULT_51 : at32f413_crm.h
  • CRM_PLL_MULT_52 : at32f413_crm.h
  • CRM_PLL_MULT_53 : at32f413_crm.h
  • CRM_PLL_MULT_54 : at32f413_crm.h
  • CRM_PLL_MULT_55 : at32f413_crm.h
  • CRM_PLL_MULT_56 : at32f413_crm.h
  • CRM_PLL_MULT_57 : at32f413_crm.h
  • CRM_PLL_MULT_58 : at32f413_crm.h
  • CRM_PLL_MULT_59 : at32f413_crm.h
  • CRM_PLL_MULT_6 : at32f413_crm.h
  • CRM_PLL_MULT_60 : at32f413_crm.h
  • CRM_PLL_MULT_61 : at32f413_crm.h
  • CRM_PLL_MULT_62 : at32f413_crm.h
  • CRM_PLL_MULT_63 : at32f413_crm.h
  • CRM_PLL_MULT_64 : at32f413_crm.h
  • CRM_PLL_MULT_7 : at32f413_crm.h
  • CRM_PLL_MULT_8 : at32f413_crm.h
  • CRM_PLL_MULT_9 : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT_DIV : at32f413_crm.h
  • CRM_PLL_SOURCE_HICK : at32f413_crm.h
  • CRM_PWC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_PWC_PERIPH_RESET : at32f413_crm.h
  • CRM_RTC_CLOCK_HEXT_DIV : at32f413_crm.h
  • CRM_RTC_CLOCK_LEXT : at32f413_crm.h
  • CRM_RTC_CLOCK_LICK : at32f413_crm.h
  • CRM_RTC_CLOCK_NOCLK : at32f413_crm.h
  • CRM_SCLK_HEXT : at32f413_crm.h
  • CRM_SCLK_HICK : at32f413_crm.h
  • CRM_SCLK_PLL : at32f413_crm.h
  • CRM_SDIO1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_RESET : at32f413_crm.h
  • CRM_SPI2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI2_PERIPH_RESET : at32f413_crm.h
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_TMR10_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR10_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR11_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR11_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR1_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR2_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR3_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR4_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR5_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR8_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR8_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR9_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR9_PERIPH_RESET : at32f413_crm.h
  • CRM_UART4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART4_PERIPH_RESET : at32f413_crm.h
  • CRM_UART5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART5_PERIPH_RESET : at32f413_crm.h
  • CRM_USART1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART1_PERIPH_RESET : at32f413_crm.h
  • CRM_USART2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART2_PERIPH_RESET : at32f413_crm.h
  • CRM_USART3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART3_PERIPH_RESET : at32f413_crm.h
  • CRM_USB_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_USB_CLOCK_SOURCE_PLL : at32f413_crm.h
  • CRM_USB_DIV_1 : at32f413_crm.h
  • CRM_USB_DIV_1_5 : at32f413_crm.h
  • CRM_USB_DIV_2 : at32f413_crm.h
  • CRM_USB_DIV_2_5 : at32f413_crm.h
  • CRM_USB_DIV_3 : at32f413_crm.h
  • CRM_USB_DIV_3_5 : at32f413_crm.h
  • CRM_USB_DIV_4 : at32f413_crm.h
  • CRM_USB_INT19_INT20 : at32f413_crm.h
  • CRM_USB_INT73_INT74 : at32f413_crm.h
  • CRM_USB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USB_PERIPH_RESET : at32f413_crm.h
  • CRM_WWDT_PERIPH_CLOCK : at32f413_crm.h
  • CRM_WWDT_PERIPH_RESET : at32f413_crm.h


AT32F413 Firmwary Library: Globals

- d -

  • DATA_TRANS_IN : at32f413_usb.h
  • DATA_TRANS_OUT : at32f413_usb.h
  • DebugMonitor_IRQn : at32f413.h
  • DMA1_Channel1_IRQn : at32f413.h
  • DMA1_Channel2_IRQn : at32f413.h
  • DMA1_Channel3_IRQn : at32f413.h
  • DMA1_Channel4_IRQn : at32f413.h
  • DMA1_Channel5_IRQn : at32f413.h
  • DMA1_Channel6_IRQn : at32f413.h
  • DMA1_Channel7_IRQn : at32f413.h
  • DMA2_Channel1_IRQn : at32f413.h
  • DMA2_Channel2_IRQn : at32f413.h
  • DMA2_Channel3_IRQn : at32f413.h
  • DMA2_Channel4_5_IRQn : at32f413.h
  • DMA2_Channel6_7_IRQn : at32f413.h
  • DMA_DIR_MEMORY_TO_MEMORY : at32f413_dma.h
  • DMA_DIR_MEMORY_TO_PERIPHERAL : at32f413_dma.h
  • DMA_DIR_PERIPHERAL_TO_MEMORY : at32f413_dma.h
  • DMA_FLEXIBLE_ADC1 : at32f413_dma.h
  • DMA_FLEXIBLE_I2C1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_SDIO1 : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_TX : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_MEMORY_INC_DISABLE : at32f413_dma.h
  • DMA_MEMORY_INC_ENABLE : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_PERIPHERAL_INC_DISABLE : at32f413_dma.h
  • DMA_PERIPHERAL_INC_ENABLE : at32f413_dma.h
  • DMA_PRIORITY_HIGH : at32f413_dma.h
  • DMA_PRIORITY_LOW : at32f413_dma.h
  • DMA_PRIORITY_MEDIUM : at32f413_dma.h
  • DMA_PRIORITY_VERY_HIGH : at32f413_dma.h


AT32F413 Firmwary Library: Globals

- e -

  • EPT_BULK_TYPE : at32f413_usb.h
  • EPT_CONTROL_TYPE : at32f413_usb.h
  • EPT_IN : at32f413_usb.h
  • EPT_INT_TYPE : at32f413_usb.h
  • EPT_ISO_TYPE : at32f413_usb.h
  • EPT_OUT : at32f413_usb.h
  • ERROR : at32f413.h
  • EXINT0_IRQn : at32f413.h
  • EXINT15_10_IRQn : at32f413.h
  • EXINT1_IRQn : at32f413.h
  • EXINT2_IRQn : at32f413.h
  • EXINT3_IRQn : at32f413.h
  • EXINT4_IRQn : at32f413.h
  • EXINT9_5_IRQn : at32f413.h
  • EXINT_LINE_EVENT : at32f413_exint.h
  • EXINT_LINE_INTERRUPUT : at32f413_exint.h
  • EXINT_TRIGGER_BOTH_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_FALLING_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_RISING_EDGE : at32f413_exint.h


AT32F413 Firmwary Library: Globals

- f -

  • FALSE : at32f413.h
  • FLASH_EPP_ERROR : at32f413_flash.h
  • FLASH_IRQn : at32f413.h
  • FLASH_OPERATE_BUSY : at32f413_flash.h
  • FLASH_OPERATE_DONE : at32f413_flash.h
  • FLASH_OPERATE_TIMEOUT : at32f413_flash.h
  • FLASH_PROGRAM_ERROR : at32f413_flash.h
  • FLASH_SPIM_MODEL1 : at32f413_flash.h
  • FLASH_SPIM_MODEL2 : at32f413_flash.h


AT32F413 Firmwary Library: Globals

- g -

  • GPIO_DRIVE_STRENGTH_MAXIMUM : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_MODERATE : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_STRONGER : at32f413_gpio.h
  • GPIO_MODE_ANALOG : at32f413_gpio.h
  • GPIO_MODE_INPUT : at32f413_gpio.h
  • GPIO_MODE_MUX : at32f413_gpio.h
  • GPIO_MODE_OUTPUT : at32f413_gpio.h
  • GPIO_OUTPUT_OPEN_DRAIN : at32f413_gpio.h
  • GPIO_OUTPUT_PUSH_PULL : at32f413_gpio.h
  • GPIO_PINS_SOURCE0 : at32f413_gpio.h
  • GPIO_PINS_SOURCE1 : at32f413_gpio.h
  • GPIO_PINS_SOURCE10 : at32f413_gpio.h
  • GPIO_PINS_SOURCE11 : at32f413_gpio.h
  • GPIO_PINS_SOURCE12 : at32f413_gpio.h
  • GPIO_PINS_SOURCE13 : at32f413_gpio.h
  • GPIO_PINS_SOURCE14 : at32f413_gpio.h
  • GPIO_PINS_SOURCE15 : at32f413_gpio.h
  • GPIO_PINS_SOURCE2 : at32f413_gpio.h
  • GPIO_PINS_SOURCE3 : at32f413_gpio.h
  • GPIO_PINS_SOURCE4 : at32f413_gpio.h
  • GPIO_PINS_SOURCE5 : at32f413_gpio.h
  • GPIO_PINS_SOURCE6 : at32f413_gpio.h
  • GPIO_PINS_SOURCE7 : at32f413_gpio.h
  • GPIO_PINS_SOURCE8 : at32f413_gpio.h
  • GPIO_PINS_SOURCE9 : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOA : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOB : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOC : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOD : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOF : at32f413_gpio.h
  • GPIO_PULL_DOWN : at32f413_gpio.h
  • GPIO_PULL_NONE : at32f413_gpio.h
  • GPIO_PULL_UP : at32f413_gpio.h


AT32F413 Firmwary Library: Globals

- h -

  • HardFault_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- i -

  • I2C1_ERR_IRQn : at32f413.h
  • I2C1_EVT_IRQn : at32f413.h
  • I2C2_ERR_IRQn : at32f413.h
  • I2C2_EVT_IRQn : at32f413.h
  • I2C_ADDRESS_MODE_10BIT : at32f413_i2c.h
  • I2C_ADDRESS_MODE_7BIT : at32f413_i2c.h
  • I2C_DIRECTION_RECEIVE : at32f413_i2c.h
  • I2C_DIRECTION_TRANSMIT : at32f413_i2c.h
  • I2C_DMA_MA_RX : i2c_application.h
  • I2C_DMA_MA_TX : i2c_application.h
  • I2C_DMA_SLA_RX : i2c_application.h
  • I2C_DMA_SLA_TX : i2c_application.h
  • I2C_ERR_ACKFAIL : i2c_application.h
  • I2C_ERR_ADDR : i2c_application.h
  • I2C_ERR_ADDR10 : i2c_application.h
  • I2C_ERR_INTERRUPT : i2c_application.h
  • I2C_ERR_START : i2c_application.h
  • I2C_ERR_STEP_1 : i2c_application.h
  • I2C_ERR_STEP_10 : i2c_application.h
  • I2C_ERR_STEP_11 : i2c_application.h
  • I2C_ERR_STEP_12 : i2c_application.h
  • I2C_ERR_STEP_2 : i2c_application.h
  • I2C_ERR_STEP_3 : i2c_application.h
  • I2C_ERR_STEP_4 : i2c_application.h
  • I2C_ERR_STEP_5 : i2c_application.h
  • I2C_ERR_STEP_6 : i2c_application.h
  • I2C_ERR_STEP_7 : i2c_application.h
  • I2C_ERR_STEP_8 : i2c_application.h
  • I2C_ERR_STEP_9 : i2c_application.h
  • I2C_ERR_STOP : i2c_application.h
  • I2C_ERR_TIMEOUT : i2c_application.h
  • I2C_FSMODE_DUTY_16_9 : at32f413_i2c.h
  • I2C_FSMODE_DUTY_2_1 : at32f413_i2c.h
  • I2C_INT_MA_RX : i2c_application.h
  • I2C_INT_MA_TX : i2c_application.h
  • I2C_INT_SLA_RX : i2c_application.h
  • I2C_INT_SLA_TX : i2c_application.h
  • I2C_MASTER_ACK_CURRENT : at32f413_i2c.h
  • I2C_MASTER_ACK_NEXT : at32f413_i2c.h
  • I2C_MEM_ADDR_WIDIH_16 : i2c_application.h
  • I2C_MEM_ADDR_WIDIH_8 : i2c_application.h
  • I2C_OK : i2c_application.h
  • I2C_PEC_POSITION_CURRENT : at32f413_i2c.h
  • I2C_PEC_POSITION_NEXT : at32f413_i2c.h
  • I2C_SMBUS_ALERT_HIGH : at32f413_i2c.h
  • I2C_SMBUS_ALERT_LOW : at32f413_i2c.h
  • I2C_SMBUS_MODE_DEVICE : at32f413_i2c.h
  • I2C_SMBUS_MODE_HOST : at32f413_i2c.h
  • I2S_AUDIO_FREQUENCY_11_025K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_16K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_192K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_22_05K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_32K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_44_1K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_48K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_8K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_96K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_DEFAULT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_LSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_MSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_LONG : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_SHORT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PHILLIPS : at32f413_spi.h
  • I2S_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • I2S_CLOCK_POLARITY_LOW : at32f413_spi.h
  • I2S_DATA_16BIT_CHANNEL_16BIT : at32f413_spi.h
  • I2S_DATA_16BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_24BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_32BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_MODE_MASTER_RX : at32f413_spi.h
  • I2S_MODE_MASTER_TX : at32f413_spi.h
  • I2S_MODE_SLAVE_RX : at32f413_spi.h
  • I2S_MODE_SLAVE_TX : at32f413_spi.h
  • IAP_FAILED : hid_iap_class.h
  • IAP_STS_ADDR : hid_iap_class.h
  • IAP_STS_CRC : hid_iap_class.h
  • IAP_STS_DATA : hid_iap_class.h
  • IAP_STS_FINISH : hid_iap_class.h
  • IAP_STS_IDLE : hid_iap_class.h
  • IAP_STS_JMP : hid_iap_class.h
  • IAP_STS_JMP_WAIT : hid_iap_class.h
  • IAP_STS_START : hid_iap_class.h
  • IAP_SUCCESS : hid_iap_class.h
  • IAP_WAIT : hid_iap_class.h


AT32F413 Firmwary Library: Globals

- l -

  • LED2 : at32f413_board.h
  • LED3 : at32f413_board.h
  • LED4 : at32f413_board.h


AT32F413 Firmwary Library: Globals

- m -

  • MemoryManagement_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- n -

  • NO_BUTTON : at32f413_board.h
  • NonMaskableInt_IRQn : at32f413.h
  • NVIC_LP_SEVONPEND : at32f413_misc.h
  • NVIC_LP_SLEEPDEEP : at32f413_misc.h
  • NVIC_LP_SLEEPONEXIT : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_0 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_1 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_2 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_3 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_4 : at32f413_misc.h


AT32F413 Firmwary Library: Globals

- p -

  • PendSV_IRQn : at32f413.h
  • PRINTER_REQ_GET_DEVICE_ID : printer_class.h
  • PRINTER_REQ_GET_PORT_STATUS : printer_class.h
  • PRINTER_REQ_GET_SOFT_RESET : printer_class.h
  • PVM_IRQn : at32f413.h
  • PWC_DEEP_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFI : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V3 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V4 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V5 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V6 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V7 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V8 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V9 : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFI : at32f413_pwc.h


AT32F413 Firmwary Library: Globals

- r -

  • RESET : at32f413.h
  • Reset_IRQn : at32f413.h
  • RTC_IRQn : at32f413.h
  • RTCAlarm_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- s -

  • SD_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_DISCONNECTED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_IDENTIFICATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_READY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_SENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_STANDBY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_TRANSFER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CID_CSD_OVERWRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_RSP_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INTERNAL_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_PARAMETER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_VOLTRANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_NOT_CONFIGURED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_NOT_APPLICABLE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_PENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_RX_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_BUSY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_UNKNOWN_FUNC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_START_BIT_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_DMA_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_POLLING_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TX_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_FEATURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_HW : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO1_IRQn : at32f413.h
  • SDIO_BUS_WIDTH_D1 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D4 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D8 : at32f413_sdio.h
  • SDIO_CLOCK_EDGE_FALLING : at32f413_sdio.h
  • SDIO_CLOCK_EDGE_RISING : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1024B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_128B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16384B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2048B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_256B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_32B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4096B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_512B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_64B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8192B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_TRANSFER : at32f413_sdio.h
  • SDIO_DATA_STREAM_TRANSFER : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CARD : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CONTROLLER : at32f413_sdio.h
  • SDIO_HIGH_CAPACITY_MMC_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_CAPACITY_SD_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_SPEED_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_POWER_OFF : at32f413_sdio.h
  • SDIO_POWER_ON : at32f413_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_CK : at32f413_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_D2 : at32f413_sdio.h
  • SDIO_RESPONSE_LONG : at32f413_sdio.h
  • SDIO_RESPONSE_NO : at32f413_sdio.h
  • SDIO_RESPONSE_SHORT : at32f413_sdio.h
  • SDIO_RSP1_INDEX : at32f413_sdio.h
  • SDIO_RSP2_INDEX : at32f413_sdio.h
  • SDIO_RSP3_INDEX : at32f413_sdio.h
  • SDIO_RSP4_INDEX : at32f413_sdio.h
  • SDIO_SDIO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_COMBO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V1_1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V2_0 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_WAIT_FOR_INT : at32f413_sdio.h
  • SDIO_WAIT_FOR_NO : at32f413_sdio.h
  • SDIO_WAIT_FOR_PEND : at32f413_sdio.h
  • SET : at32f413.h
  • SPI1_IRQn : at32f413.h
  • SPI2_IRQn : at32f413.h
  • SPI_CLOCK_PHASE_1EDGE : at32f413_spi.h
  • SPI_CLOCK_PHASE_2EDGE : at32f413_spi.h
  • SPI_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • SPI_CLOCK_POLARITY_LOW : at32f413_spi.h
  • SPI_CRC_RX : at32f413_spi.h
  • SPI_CRC_TX : at32f413_spi.h
  • SPI_CS_HARDWARE_MODE : at32f413_spi.h
  • SPI_CS_SOFTWARE_MODE : at32f413_spi.h
  • SPI_FIRST_BIT_LSB : at32f413_spi.h
  • SPI_FIRST_BIT_MSB : at32f413_spi.h
  • SPI_FRAME_16BIT : at32f413_spi.h
  • SPI_FRAME_8BIT : at32f413_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_RX : at32f413_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_TX : at32f413_spi.h
  • SPI_MCLK_DIV_1024 : at32f413_spi.h
  • SPI_MCLK_DIV_128 : at32f413_spi.h
  • SPI_MCLK_DIV_16 : at32f413_spi.h
  • SPI_MCLK_DIV_2 : at32f413_spi.h
  • SPI_MCLK_DIV_256 : at32f413_spi.h
  • SPI_MCLK_DIV_32 : at32f413_spi.h
  • SPI_MCLK_DIV_4 : at32f413_spi.h
  • SPI_MCLK_DIV_512 : at32f413_spi.h
  • SPI_MCLK_DIV_64 : at32f413_spi.h
  • SPI_MCLK_DIV_8 : at32f413_spi.h
  • SPI_MODE_MASTER : at32f413_spi.h
  • SPI_MODE_SLAVE : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_LOW : at32f413_spi.h
  • SPI_TRANSMIT_FULL_DUPLEX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_RX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_TX : at32f413_spi.h
  • SPI_TRANSMIT_SIMPLEX_RX : at32f413_spi.h
  • SUCCESS : at32f413.h
  • SVCall_IRQn : at32f413.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 : at32f413_misc.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV : at32f413_misc.h
  • SysTick_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- t -

  • TAMPER_IRQn : at32f413.h
  • TMR1_BRK_TMR9_IRQn : at32f413.h
  • TMR1_CH_IRQn : at32f413.h
  • TMR1_OVF_TMR10_IRQn : at32f413.h
  • TMR1_TRG_HALL_TMR11_IRQn : at32f413.h
  • TMR2_GLOBAL_IRQn : at32f413.h
  • TMR3_GLOBAL_IRQn : at32f413.h
  • TMR4_GLOBAL_IRQn : at32f413.h
  • TMR5_GLOBAL_IRQn : at32f413.h
  • TMR8_BRK_IRQn : at32f413.h
  • TMR8_CH_IRQn : at32f413.h
  • TMR8_OVF_IRQn : at32f413.h
  • TMR8_TRG_HALL_IRQn : at32f413.h
  • TMR_BRK_ADDRESS : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_LOW : at32f413_tmr.h
  • TMR_BRK_SWTRIG : at32f413_tmr.h
  • TMR_C1_DMA_REQUEST : at32f413_tmr.h
  • TMR_C1_SWTRIG : at32f413_tmr.h
  • TMR_C1DT_ADDRESS : at32f413_tmr.h
  • TMR_C2_DMA_REQUEST : at32f413_tmr.h
  • TMR_C2_SWTRIG : at32f413_tmr.h
  • TMR_C2DT_ADDRESS : at32f413_tmr.h
  • TMR_C3_DMA_REQUEST : at32f413_tmr.h
  • TMR_C3_SWTRIG : at32f413_tmr.h
  • TMR_C3DT_ADDRESS : at32f413_tmr.h
  • TMR_C4_DMA_REQUEST : at32f413_tmr.h
  • TMR_C4_SWTRIG : at32f413_tmr.h
  • TMR_C4DT_ADDRESS : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_DIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_INDIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_STI : at32f413_tmr.h
  • TMR_CCTRL_ADDRESS : at32f413_tmr.h
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR : at32f413_tmr.h
  • TMR_CHANEL1_CONNECTED_C1IRAW : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_1 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_2 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_4 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_8 : at32f413_tmr.h
  • TMR_CLOCK_DIV1 : at32f413_tmr.h
  • TMR_CLOCK_DIV2 : at32f413_tmr.h
  • TMR_CLOCK_DIV4 : at32f413_tmr.h
  • TMR_CM1_ADDRESS : at32f413_tmr.h
  • TMR_CM2_ADDRESS : at32f413_tmr.h
  • TMR_COUNT_DOWN : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_1 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_2 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_3 : at32f413_tmr.h
  • TMR_COUNT_UP : at32f413_tmr.h
  • TMR_CTRL1_ADDRESS : at32f413_tmr.h
  • TMR_CTRL2_ADDRESS : at32f413_tmr.h
  • TMR_CVAL_ADDRESS : at32f413_tmr.h
  • TMR_DIV_ADDRESS : at32f413_tmr.h
  • TMR_DMA_REQUEST_BY_CHANNEL : at32f413_tmr.h
  • TMR_DMA_REQUEST_BY_OVERFLOW : at32f413_tmr.h
  • TMR_DMA_TRANSFER_10BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_11BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_12BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_13BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_14BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_15BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_16BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_17BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_18BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_1BYTE : at32f413_tmr.h
  • TMR_DMA_TRANSFER_2BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_3BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_4BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_5BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_6BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_7BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_8BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_9BYTES : at32f413_tmr.h
  • TMR_DMACTRL_ADDRESS : at32f413_tmr.h
  • TMR_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_ENCODER_MODE_C : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_1 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_2 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_4 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_8 : at32f413_tmr.h
  • TMR_ES_POLARITY_INVERTED : at32f413_tmr.h
  • TMR_ES_POLARITY_NON_INVERTED : at32f413_tmr.h
  • TMR_FORCE_OUTPUT_HIGH : at32f413_tmr.h
  • TMR_FORCE_OUTPUT_LOW : at32f413_tmr.h
  • TMR_HALL_DMA_REQUEST : at32f413_tmr.h
  • TMR_HALL_SWTRIG : at32f413_tmr.h
  • TMR_IDEN_ADDRESS : at32f413_tmr.h
  • TMR_INPUT_BOTH_EDGE : at32f413_tmr.h
  • TMR_INPUT_FALLING_EDGE : at32f413_tmr.h
  • TMR_INPUT_RISING_EDGE : at32f413_tmr.h
  • TMR_ISTS_ADDRESS : at32f413_tmr.h
  • TMR_OUTPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_ACTIVE_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_OFF : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_A : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_B : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_SWITCH : at32f413_tmr.h
  • TMR_OVERFLOW_DMA_REQUEST : at32f413_tmr.h
  • TMR_OVERFLOW_SWTRIG : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_BOTH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_LOW : at32f413_tmr.h
  • TMR_PR_ADDRESS : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C1ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C2ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C3ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C4ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_COMPARE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_ENABLE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_OVERFLOW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_RESET : at32f413_tmr.h
  • TMR_RPR_ADDRESS : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_4 : at32f413_tmr.h
  • TMR_STCTRL_ADDRESS : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_C : at32f413_tmr.h
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A : at32f413_tmr.h
  • TMR_SUB_HANG_MODE : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1DF1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1INC : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C2DF2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_EXTIN : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS0 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS3 : at32f413_tmr.h
  • TMR_SUB_MODE_DIABLE : at32f413_tmr.h
  • TMR_SUB_RESET_MODE : at32f413_tmr.h
  • TMR_SUB_TRIGGER_MODE : at32f413_tmr.h
  • TMR_SWEVT_ADDRESS : at32f413_tmr.h
  • TMR_TRIGGER_DMA_REQUEST : at32f413_tmr.h
  • TMR_TRIGGER_SWTRIG : at32f413_tmr.h
  • TMR_WP_LEVEL_1 : at32f413_tmr.h
  • TMR_WP_LEVEL_2 : at32f413_tmr.h
  • TMR_WP_LEVEL_3 : at32f413_tmr.h
  • TMR_WP_OFF : at32f413_tmr.h
  • TRUE : at32f413.h


AT32F413 Firmwary Library: Globals

- u -

  • UART4_IRQn : at32f413.h
  • UART5_IRQn : at32f413.h
  • UPDATE_CLEAR_FLAG : bootloader/inc/iap.h
  • UPDATE_DONE : bootloader/inc/iap.h
  • UPDATE_ING : bootloader/inc/iap.h
  • UPDATE_PRE : bootloader/inc/iap.h
  • UPGRADE_DONE : flash_fat16.h
  • UPGRADE_FAILED : flash_fat16.h
  • UPGRADE_JUMP : flash_fat16.h
  • UPGRADE_LARGE : flash_fat16.h
  • UPGRADE_READY : flash_fat16.h
  • UPGRADE_SUCCESS : flash_fat16.h
  • UPGRADE_UNKNOWN : flash_fat16.h
  • UPGRAGE_ONGOING : flash_fat16.h
  • UsageFault_IRQn : at32f413.h
  • USART1_IRQn : at32f413.h
  • USART2_IRQn : at32f413.h
  • USART3_IRQn : at32f413.h
  • USART_BREAK_10BITS : at32f413_usart.h
  • USART_BREAK_11BITS : at32f413_usart.h
  • USART_CLOCK_LAST_BIT_NONE : at32f413_usart.h
  • USART_CLOCK_LAST_BIT_OUTPUT : at32f413_usart.h
  • USART_CLOCK_PHASE_1EDGE : at32f413_usart.h
  • USART_CLOCK_PHASE_2EDGE : at32f413_usart.h
  • USART_CLOCK_POLARITY_HIGH : at32f413_usart.h
  • USART_CLOCK_POLARITY_LOW : at32f413_usart.h
  • USART_DATA_8BITS : at32f413_usart.h
  • USART_DATA_9BITS : at32f413_usart.h
  • USART_HARDWARE_FLOW_CTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_NONE : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS_CTS : at32f413_usart.h
  • USART_PARITY_EVEN : at32f413_usart.h
  • USART_PARITY_NONE : at32f413_usart.h
  • USART_PARITY_ODD : at32f413_usart.h
  • USART_STOP_0_5_BIT : at32f413_usart.h
  • USART_STOP_1_5_BIT : at32f413_usart.h
  • USART_STOP_1_BIT : at32f413_usart.h
  • USART_STOP_2_BIT : at32f413_usart.h
  • USART_WAKEUP_BY_IDLE_FRAME : at32f413_usart.h
  • USART_WAKEUP_BY_MATCHING_ID : at32f413_usart.h
  • USB_CLK_HEXT : at32f413_usb.h
  • USB_CLK_HICK : at32f413_usb.h
  • USB_CONN_STATE_ADDRESSED : usb_std.h
  • USB_CONN_STATE_CONFIGURED : usb_std.h
  • USB_CONN_STATE_DEFAULT : usb_std.h
  • USB_CONN_STATE_SUSPENDED : usb_std.h
  • USB_EPT0 : at32f413_usb.h
  • USB_EPT1 : at32f413_usb.h
  • USB_EPT2 : at32f413_usb.h
  • USB_EPT3 : at32f413_usb.h
  • USB_EPT4 : at32f413_usb.h
  • USB_EPT5 : at32f413_usb.h
  • USB_EPT6 : at32f413_usb.h
  • USB_EPT7 : at32f413_usb.h
  • USB_ERROR : usb_std.h
  • USB_FAIL : usb_std.h
  • USB_NOT_SUPPORT : usb_std.h
  • USB_OK : usb_std.h
  • USB_WAIT : usb_std.h
  • USBD_ERR_EVENT : usbd_core.h
  • USBD_NOP_EVENT : usbd_core.h
  • USBD_RESET_EVENT : usbd_core.h
  • USBD_SUSPEND_EVENT : usbd_core.h
  • USBD_WAKEUP_EVENT : usbd_core.h
  • USBFS_H_CAN1_TX_IRQn : at32f413.h
  • USBFS_L_CAN1_RX0_IRQn : at32f413.h
  • USBFS_MAPH_IRQn : at32f413.h
  • USBFS_MAPL_IRQn : at32f413.h
  • USBFSWakeUp_IRQn : at32f413.h
  • USER_BUTTON : at32f413_board.h


AT32F413 Firmwary Library: Globals

- w -

  • WDT_CLK_DIV_128 : at32f413_wdt.h
  • WDT_CLK_DIV_16 : at32f413_wdt.h
  • WDT_CLK_DIV_256 : at32f413_wdt.h
  • WDT_CLK_DIV_32 : at32f413_wdt.h
  • WDT_CLK_DIV_4 : at32f413_wdt.h
  • WDT_CLK_DIV_64 : at32f413_wdt.h
  • WDT_CLK_DIV_8 : at32f413_wdt.h
  • WDT_CMD_ENABLE : at32f413_wdt.h
  • WDT_CMD_LOCK : at32f413_wdt.h
  • WDT_CMD_RELOAD : at32f413_wdt.h
  • WDT_CMD_UNLOCK : at32f413_wdt.h
  • WWDT_IRQn : at32f413.h
  • WWDT_PCLK1_DIV_16384 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_32768 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_4096 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_8192 : at32f413_wwdt.h


AT32F413 Firmwary Library: Globals

- _ -

  • __AT32F413_LIBRARY_VERSION : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MAJOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MIDDLE : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MINOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_RC : at32f413.h
  • __CM4_REV : at32f413.h
  • __FPU_PRESENT : at32f413.h
  • __MPU_PRESENT : at32f413.h
  • __NVIC_PRIO_BITS : at32f413.h
  • __Vendor_SysTickConfig : at32f413.h


AT32F413 Firmwary Library: Globals

- a -

  • ACC : at32f413_acc.h
  • ACC_BASE : at32f413.h
  • ACC_CAL_HICKCAL : at32f413_acc.h
  • ACC_CAL_HICKTRIM : at32f413_acc.h
  • ACC_CALRDY_FLAG : at32f413_acc.h
  • ACC_CALRDYIEN_INT : at32f413_acc.h
  • ACC_EIEN_INT : at32f413_acc.h
  • ACC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • ACC_RSLOST_FLAG : at32f413_acc.h
  • ACC_TRIM : project/at_start_f413/examples/acc/calibration/src/main.c
  • ADC1 : at32f413_adc.h
  • ADC1_BASE : at32f413.h
  • ADC1_ETO_GMUX : at32f413_gpio.h
  • ADC1_ETO_MUX : at32f413_gpio.h
  • ADC1_ETP_GMUX : at32f413_gpio.h
  • ADC1_ETP_MUX : at32f413_gpio.h
  • ADC2 : at32f413_adc.h
  • ADC2_BASE : at32f413.h
  • ADC2_ETO_GMUX : at32f413_gpio.h
  • ADC2_ETO_MUX : at32f413_gpio.h
  • ADC2_ETP_GMUX : at32f413_gpio.h
  • ADC2_ETP_MUX : at32f413_gpio.h
  • ADC_CCE_FLAG : at32f413_adc.h
  • ADC_CCE_INT : at32f413_adc.h
  • ADC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • ADC_OCCS_FLAG : at32f413_adc.h
  • ADC_PCCE_FLAG : at32f413_adc.h
  • ADC_PCCE_INT : at32f413_adc.h
  • ADC_PCCS_FLAG : at32f413_adc.h
  • ADC_TEMP_BASE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_TEMP_SLOPE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_VMOR_FLAG : at32f413_adc.h
  • ADC_VMOR_INT : at32f413_adc.h
  • ADC_VREF : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADDRESS_OUT_OF_RANGE : cdc_msc_class.h, msc_bot_scsi.h
  • AHBPERIPH_BASE : at32f413.h
  • AIRCR_VECTKEY_MASK : at32f413_misc.c
  • APB1PERIPH_BASE : at32f413.h
  • APB2PERIPH_BASE : at32f413.h
  • APP_START_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • AT32_AUDIO_FREQ_16K : audio_desc.h, audio_hid_desc.h
  • AT32_AUDIO_FREQ_48K : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_EXTENSION_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_FEATURE_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_HEADER : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_INPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_MIXER_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_OUTPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_PROCESSING_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_SELECTOR_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_SPECIFIC : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_TYPE : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_GENERAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_BCD_NUM : audio_desc.h
  • AUDIO_BINTERVAL_TIME : audio_desc.h
  • AUDIO_BITW_16 : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_CS_CONFIGURATION : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_DEVICE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_ENDPOINT : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_STRING : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DEFAULT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DESCRIPTOR_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_DESCRIPTOR_TYPE : audio_class.h, audio_hid_class.h
  • AUDIO_FEATURE_UNIT_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_FEEDBACK_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_FORMAT_TYPE_I : audio_desc.h, audio_hid_desc.h
  • AUDIO_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_SET_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_FU_BASS_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_CONTROL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MID_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MUTE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_TREBLE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_VOLUME_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_MICROPHONE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_LEN : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_NUM : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_IN_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_MIC_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MUTE_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_OUTPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_SPEAKER : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_PROTOCOL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_REMAIN_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_ENDPOINT : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_INTERFACE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_MASK : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_GET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_STAT : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQUEST_CODE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_OUT_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_SPK_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOCONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOSTREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_MIDISTREMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUPPORT_FEEDBACK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MAX_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MIC : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_SPK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_TERMINAL_TYPE_STREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_VENDOR : audio_desc.h, audio_hid_desc.h
  • AUDIO_VOLUME_CONTROL : audio_class.h, audio_hid_class.h
  • AUHID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BINTERVAL_TIME : audio_hid_desc.h


AT32F413 Firmwary Library: Globals

- b -

  • BLK2 : at32f413_usb.h
  • BLK32 : at32f413_usb.h
  • BLOCK_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, fir_filter.c
  • BLOCKS_NUMBER : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • BPR : at32f413_bpr.h
  • BPR_BASE : at32f413.h
  • BPR_DR_NUMBER : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • BPR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • BPR_TAMPER_EVENT_FLAG : at32f413_bpr.h
  • BPR_TAMPER_INTERRUPT_FLAG : at32f413_bpr.h
  • BUF_SIZE : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • BUFFER_SIZE : project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • BUFFERSIZE : project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • BUTTON_RELEASE : mouse_class.h


AT32F413 Firmwary Library: Globals

- c -

  • CAN1 : at32f413_can.h
  • CAN1_BASE : at32f413.h
  • CAN1_GMUX_0010 : at32f413_gpio.h
  • CAN2_BASE : at32f413.h
  • CAN2_GMUX_0001 : at32f413_gpio.h
  • CAN_BOF_FLAG : at32f413_can.h
  • CAN_BOIEN_INT : at32f413_can.h
  • CAN_EAF_FLAG : at32f413_can.h
  • CAN_EAIEN_INT : at32f413_can.h
  • CAN_EDZC_FLAG : at32f413_can.h
  • CAN_EDZIEN_INT : at32f413_can.h
  • CAN_EOIEN_INT : at32f413_can.h
  • CAN_EOIF_FLAG : at32f413_can.h
  • CAN_EPF_FLAG : at32f413_can.h
  • CAN_EPIEN_INT : at32f413_can.h
  • CAN_ETR_FLAG : at32f413_can.h
  • CAN_ETRIEN_INT : at32f413_can.h
  • CAN_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CAN_MSTS_EDZIF_VAL : at32f413_can.h
  • CAN_MSTS_EOIF_VAL : at32f413_can.h
  • CAN_MSTS_QDZIF_VAL : at32f413_can.h
  • CAN_MUX_10 : at32f413_gpio.h
  • CAN_QDZIEN_INT : at32f413_can.h
  • CAN_QDZIF_FLAG : at32f413_can.h
  • CAN_RF0_RF0FF_VAL : at32f413_can.h
  • CAN_RF0_RF0OF_VAL : at32f413_can.h
  • CAN_RF0_RF0R_VAL : at32f413_can.h
  • CAN_RF0FF_FLAG : at32f413_can.h
  • CAN_RF0FIEN_INT : at32f413_can.h
  • CAN_RF0MIEN_INT : at32f413_can.h
  • CAN_RF0MN_FLAG : at32f413_can.h
  • CAN_RF0OF_FLAG : at32f413_can.h
  • CAN_RF0OIEN_INT : at32f413_can.h
  • CAN_RF1_RF1FF_VAL : at32f413_can.h
  • CAN_RF1_RF1OF_VAL : at32f413_can.h
  • CAN_RF1_RF1R_VAL : at32f413_can.h
  • CAN_RF1FF_FLAG : at32f413_can.h
  • CAN_RF1FIEN_INT : at32f413_can.h
  • CAN_RF1MIEN_INT : at32f413_can.h
  • CAN_RF1MN_FLAG : at32f413_can.h
  • CAN_RF1OF_FLAG : at32f413_can.h
  • CAN_RF1OIEN_INT : at32f413_can.h
  • CAN_TCIEN_INT : at32f413_can.h
  • CAN_TM0TCF_FLAG : at32f413_can.h
  • CAN_TM1TCF_FLAG : at32f413_can.h
  • CAN_TM2TCF_FLAG : at32f413_can.h
  • CAN_TMEF_FLAG : at32f413_can.h
  • CAN_TSTS_TM0CT_VAL : at32f413_can.h
  • CAN_TSTS_TM0TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM1CT_VAL : at32f413_can.h
  • CAN_TSTS_TM1TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM2CT_VAL : at32f413_can.h
  • CAN_TSTS_TM2TCF_VAL : at32f413_can.h
  • CBW_BMCBWFLAGS_DIR_IN : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_BMCBWFLAGS_DIR_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_DCBWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CDC_BCD_NUM : cdc_desc.h, cdc_msc_desc.h
  • CDC_HID_BINTERVAL_TIME : cdc_desc.h, cdc_msc_desc.h
  • configASSERT : FreeRTOSConfig.h
  • configCPU_CLOCK_HZ : FreeRTOSConfig.h
  • configIDLE_SHOULD_YIELD : FreeRTOSConfig.h
  • configKERNEL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_LOWEST_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_CO_ROUTINE_PRIORITIES : FreeRTOSConfig.h
  • configMAX_PRIORITIES : FreeRTOSConfig.h
  • configMAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_TASK_NAME_LEN : FreeRTOSConfig.h
  • configMINIMAL_STACK_SIZE : FreeRTOSConfig.h
  • configPRIO_BITS : FreeRTOSConfig.h
  • configSUPPORT_DYNAMIC_ALLOCATION : FreeRTOSConfig.h
  • configTICK_RATE_HZ : FreeRTOSConfig.h
  • configTOTAL_HEAP_SIZE : FreeRTOSConfig.h
  • configUSE_16_BIT_TICKS : FreeRTOSConfig.h
  • configUSE_CO_ROUTINES : FreeRTOSConfig.h
  • configUSE_IDLE_HOOK : FreeRTOSConfig.h
  • configUSE_PREEMPTION : FreeRTOSConfig.h
  • configUSE_TICK_HOOK : FreeRTOSConfig.h
  • CONVERT_ENDIAN : hid_iap_class.h
  • COUNTOF : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • CRC : at32f413_crc.h
  • CRC_BASE : at32f413.h
  • CRC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CRM : at32f413_crm.h
  • CRM_ALL_RESET_FLAG : at32f413_crm.h
  • CRM_BASE : at32f413.h
  • CRM_CLOCK_FAILURE_INT : at32f413_crm.h
  • CRM_CLOCK_FAILURE_INT_FLAG : at32f413_crm.h
  • CRM_HEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_INT : at32f413_crm.h
  • CRM_HICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_HICK_STABLE_FLAG : at32f413_crm.h
  • CRM_HICK_STABLE_INT : at32f413_crm.h
  • CRM_LEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_INT : at32f413_crm.h
  • CRM_LICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_INT : at32f413_crm.h
  • CRM_LOWPOWER_RESET_FLAG : at32f413_crm.h
  • CRM_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CRM_NRST_RESET_FLAG : at32f413_crm.h
  • CRM_PLL_READY_INT_FLAG : at32f413_crm.h
  • CRM_PLL_STABLE_FLAG : at32f413_crm.h
  • CRM_PLL_STABLE_INT : at32f413_crm.h
  • CRM_POR_RESET_FLAG : at32f413_crm.h
  • CRM_REG : at32f413_crm.h
  • CRM_REG_BIT : at32f413_crm.h
  • CRM_SW_RESET_FLAG : at32f413_crm.h
  • CRM_WDT_RESET_FLAG : at32f413_crm.h
  • CRM_WWDT_RESET_FLAG : at32f413_crm.h
  • CSW_BCSWSTATUS_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PASS : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PHASE_ERR : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_DCSWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CUSHID_BCD_NUM : custom_hid_desc.h
  • CUSHID_BINTERVAL_TIME : custom_hid_desc.h


AT32F413 Firmwary Library: Globals

- d -

  • DATA1_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA2_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA3_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA4_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DEBUG_BASE : at32f413.h
  • DEBUG_CAN1_PAUSE : at32f413_debug.h
  • DEBUG_CAN2_PAUSE : at32f413_debug.h
  • DEBUG_DEEPSLEEP : at32f413_debug.h
  • DEBUG_I2C1_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_I2C2_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • DEBUG_SLEEP : at32f413_debug.h
  • DEBUG_STANDBY : at32f413_debug.h
  • DEBUG_TMR10_PAUSE : at32f413_debug.h
  • DEBUG_TMR11_PAUSE : at32f413_debug.h
  • DEBUG_TMR1_PAUSE : at32f413_debug.h
  • DEBUG_TMR2_PAUSE : at32f413_debug.h
  • DEBUG_TMR3_PAUSE : at32f413_debug.h
  • DEBUG_TMR4_PAUSE : at32f413_debug.h
  • DEBUG_TMR5_PAUSE : at32f413_debug.h
  • DEBUG_TMR8_PAUSE : at32f413_debug.h
  • DEBUG_TMR9_PAUSE : at32f413_debug.h
  • DEBUG_WDT_PAUSE : at32f413_debug.h
  • DEBUG_WWDT_PAUSE : at32f413_debug.h
  • DEBUGMCU : at32f413_debug.h
  • DELAY : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/templates/src/main.c
  • DEV_MMC : diskio.c
  • DEV_RAM : diskio.c
  • DEV_USB : diskio.c
  • DEVICE_ID_ADDR1 : random.c
  • DMA1 : at32f413_dma.h
  • DMA1_BASE : at32f413.h
  • DMA1_CHANNEL1 : at32f413_dma.h
  • DMA1_CHANNEL1_BASE : at32f413.h
  • DMA1_CHANNEL2 : at32f413_dma.h
  • DMA1_CHANNEL2_BASE : at32f413.h
  • DMA1_CHANNEL3 : at32f413_dma.h
  • DMA1_CHANNEL3_BASE : at32f413.h
  • DMA1_CHANNEL4 : at32f413_dma.h
  • DMA1_CHANNEL4_BASE : at32f413.h
  • DMA1_CHANNEL5 : at32f413_dma.h
  • DMA1_CHANNEL5_BASE : at32f413.h
  • DMA1_CHANNEL6 : at32f413_dma.h
  • DMA1_CHANNEL6_BASE : at32f413.h
  • DMA1_CHANNEL7 : at32f413_dma.h
  • DMA1_CHANNEL7_BASE : at32f413.h
  • DMA1_DTERR1_FLAG : at32f413_dma.h
  • DMA1_DTERR2_FLAG : at32f413_dma.h
  • DMA1_DTERR3_FLAG : at32f413_dma.h
  • DMA1_DTERR4_FLAG : at32f413_dma.h
  • DMA1_DTERR5_FLAG : at32f413_dma.h
  • DMA1_DTERR6_FLAG : at32f413_dma.h
  • DMA1_DTERR7_FLAG : at32f413_dma.h
  • DMA1_FDT1_FLAG : at32f413_dma.h
  • DMA1_FDT2_FLAG : at32f413_dma.h
  • DMA1_FDT3_FLAG : at32f413_dma.h
  • DMA1_FDT4_FLAG : at32f413_dma.h
  • DMA1_FDT5_FLAG : at32f413_dma.h
  • DMA1_FDT6_FLAG : at32f413_dma.h
  • DMA1_FDT7_FLAG : at32f413_dma.h
  • DMA1_GL1_FLAG : at32f413_dma.h
  • DMA1_GL2_FLAG : at32f413_dma.h
  • DMA1_GL3_FLAG : at32f413_dma.h
  • DMA1_GL4_FLAG : at32f413_dma.h
  • DMA1_GL5_FLAG : at32f413_dma.h
  • DMA1_GL6_FLAG : at32f413_dma.h
  • DMA1_GL7_FLAG : at32f413_dma.h
  • DMA1_HDT1_FLAG : at32f413_dma.h
  • DMA1_HDT2_FLAG : at32f413_dma.h
  • DMA1_HDT3_FLAG : at32f413_dma.h
  • DMA1_HDT4_FLAG : at32f413_dma.h
  • DMA1_HDT5_FLAG : at32f413_dma.h
  • DMA1_HDT6_FLAG : at32f413_dma.h
  • DMA1_HDT7_FLAG : at32f413_dma.h
  • DMA2 : at32f413_dma.h
  • DMA2_BASE : at32f413.h
  • DMA2_CHANNEL1 : at32f413_dma.h
  • DMA2_CHANNEL1_BASE : at32f413.h
  • DMA2_CHANNEL2 : at32f413_dma.h
  • DMA2_CHANNEL2_BASE : at32f413.h
  • DMA2_CHANNEL3 : at32f413_dma.h
  • DMA2_CHANNEL3_BASE : at32f413.h
  • DMA2_CHANNEL4 : at32f413_dma.h
  • DMA2_CHANNEL4_BASE : at32f413.h
  • DMA2_CHANNEL5 : at32f413_dma.h
  • DMA2_CHANNEL5_BASE : at32f413.h
  • DMA2_CHANNEL6 : at32f413_dma.h
  • DMA2_CHANNEL6_BASE : at32f413.h
  • DMA2_CHANNEL7 : at32f413_dma.h
  • DMA2_CHANNEL7_BASE : at32f413.h
  • DMA2_DTERR1_FLAG : at32f413_dma.h
  • DMA2_DTERR2_FLAG : at32f413_dma.h
  • DMA2_DTERR3_FLAG : at32f413_dma.h
  • DMA2_DTERR4_FLAG : at32f413_dma.h
  • DMA2_DTERR5_FLAG : at32f413_dma.h
  • DMA2_DTERR6_FLAG : at32f413_dma.h
  • DMA2_DTERR7_FLAG : at32f413_dma.h
  • DMA2_FDT1_FLAG : at32f413_dma.h
  • DMA2_FDT2_FLAG : at32f413_dma.h
  • DMA2_FDT3_FLAG : at32f413_dma.h
  • DMA2_FDT4_FLAG : at32f413_dma.h
  • DMA2_FDT5_FLAG : at32f413_dma.h
  • DMA2_FDT6_FLAG : at32f413_dma.h
  • DMA2_FDT7_FLAG : at32f413_dma.h
  • DMA2_GL1_FLAG : at32f413_dma.h
  • DMA2_GL2_FLAG : at32f413_dma.h
  • DMA2_GL3_FLAG : at32f413_dma.h
  • DMA2_GL4_FLAG : at32f413_dma.h
  • DMA2_GL5_FLAG : at32f413_dma.h
  • DMA2_GL6_FLAG : at32f413_dma.h
  • DMA2_GL7_FLAG : at32f413_dma.h
  • DMA2_HDT1_FLAG : at32f413_dma.h
  • DMA2_HDT2_FLAG : at32f413_dma.h
  • DMA2_HDT3_FLAG : at32f413_dma.h
  • DMA2_HDT4_FLAG : at32f413_dma.h
  • DMA2_HDT5_FLAG : at32f413_dma.h
  • DMA2_HDT6_FLAG : at32f413_dma.h
  • DMA2_HDT7_FLAG : at32f413_dma.h
  • DMA_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • DMA_DTERR_INT : at32f413_dma.h
  • DMA_FDT_INT : at32f413_dma.h
  • DMA_GET_HT_FLAG : i2c_application.c
  • DMA_GET_TC_FLAG : i2c_application.c
  • DMA_GET_TERR_FLAG : i2c_application.c
  • DMA_HDT_INT : at32f413_dma.h
  • DMA_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • DOWN_MOVE : mouse_class.h
  • DYMMY_BYTE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • DZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

- e -

  • ENABLE_RTC_ASSEED : random.h
  • EPT0_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT0_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • ERASE_TIMEOUT : at32f413_flash.h
  • ERROR_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • EXINT : at32f413_exint.h
  • EXINT_BASE : at32f413.h
  • EXINT_LINE_0 : at32f413_exint.h
  • EXINT_LINE_1 : at32f413_exint.h
  • EXINT_LINE_10 : at32f413_exint.h
  • EXINT_LINE_11 : at32f413_exint.h
  • EXINT_LINE_12 : at32f413_exint.h
  • EXINT_LINE_13 : at32f413_exint.h
  • EXINT_LINE_14 : at32f413_exint.h
  • EXINT_LINE_15 : at32f413_exint.h
  • EXINT_LINE_16 : at32f413_exint.h
  • EXINT_LINE_17 : at32f413_exint.h
  • EXINT_LINE_18 : at32f413_exint.h
  • EXINT_LINE_2 : at32f413_exint.h
  • EXINT_LINE_3 : at32f413_exint.h
  • EXINT_LINE_4 : at32f413_exint.h
  • EXINT_LINE_5 : at32f413_exint.h
  • EXINT_LINE_6 : at32f413_exint.h
  • EXINT_LINE_7 : at32f413_exint.h
  • EXINT_LINE_8 : at32f413_exint.h
  • EXINT_LINE_9 : at32f413_exint.h
  • EXINT_LINE_NONE : at32f413_exint.h
  • EXINT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • EXT_CSD_BUS_WIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Clear_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_CPSECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_NORMAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_SECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Command_set : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_HS_TIMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Set_bit : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Write_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_SPIM_EN_MUX : at32f413_gpio.h
  • EXT_SPIM_GMUX_1000 : at32f413_gpio.h
  • EXT_SPIM_GMUX_1001 : at32f413_gpio.h


AT32F413 Firmwary Library: Globals

- f -

  • FAP_RELIEVE_KEY : at32f413_flash.h
  • FAST : project/at_start_f413/templates/src/main.c
  • FAT16_BYTE_PER_SIZE : flash_fat16.h
  • FAT16_DIR_SIZE : flash_fat16.h
  • FAT16_FILENAME_SIZE : flash_fat16.h
  • FAT16_SECTOR_SIZE : flash_fat16.h, flash_fat16.c
  • FAT16_TABLE_SIZE : flash_fat16.h
  • FEEDBACK_REFRESH_TIME : audio_class.h, audio_hid_class.h
  • FF_CODE_PAGE : ffconf.h
  • FF_FS_EXFAT : ffconf.h
  • FF_FS_LOCK : ffconf.h
  • FF_FS_MINIMIZE : ffconf.h
  • FF_FS_NOFSINFO : ffconf.h
  • FF_FS_NORTC : ffconf.h
  • FF_FS_READONLY : ffconf.h
  • FF_FS_REENTRANT : ffconf.h
  • FF_FS_RPATH : ffconf.h
  • FF_FS_TIMEOUT : ffconf.h
  • FF_FS_TINY : ffconf.h
  • FF_LBA64 : ffconf.h
  • FF_LFN_BUF : ffconf.h
  • FF_LFN_UNICODE : ffconf.h
  • FF_MAX_LFN : ffconf.h
  • FF_MAX_SS : ffconf.h
  • FF_MIN_GPT : ffconf.h
  • FF_MIN_SS : ffconf.h
  • FF_MULTI_PARTITION : ffconf.h
  • FF_NORTC_MDAY : ffconf.h
  • FF_NORTC_MON : ffconf.h
  • FF_NORTC_YEAR : ffconf.h
  • FF_PRINT_FLOAT : ffconf.h
  • FF_PRINT_LLI : ffconf.h
  • FF_SFN_BUF : ffconf.h
  • FF_STR_VOLUME_ID : ffconf.h
  • FF_STRF_ENCODE : ffconf.h
  • FF_SYNC_t : ffconf.h
  • FF_USE_CHMOD : ffconf.h
  • FF_USE_EXPAND : ffconf.h
  • FF_USE_FASTSEEK : ffconf.h
  • FF_USE_FIND : ffconf.h
  • FF_USE_FORWARD : ffconf.h
  • FF_USE_LABEL : ffconf.h
  • FF_USE_LFN : ffconf.h
  • FF_USE_MKFS : ffconf.h
  • FF_USE_STRFUNC : ffconf.h
  • FF_USE_TRIM : ffconf.h
  • FF_VOLUME_STRS : ffconf.h
  • FF_VOLUMES : ffconf.h
  • FFCONF_DEF : ffconf.h
  • FILE_SUFFIX1_LEN : flash_fat16.h
  • FILE_SUFFIX1_NAME : flash_fat16.h
  • FILE_SUFFIX2_LEN : flash_fat16.h
  • FILE_SUFFIX2_NAME : flash_fat16.h
  • FILTER_EXT_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FLASH : at32f413_flash.h
  • FLASH_APP_ADDRESS : app_led3_toggle/inc/hid_iap_user.h, app_led4_toggle/inc/hid_iap_user.h, bootloader/inc/hid_iap_user.h
  • FLASH_APP_START_ADDR : flash_fat16.h
  • FLASH_BASE : at32f413.h
  • FLASH_CS_HIGH : spi_flash.h
  • FLASH_CS_LOW : spi_flash.h
  • FLASH_EPPERR_FLAG : at32f413_flash.h
  • FLASH_ERR_INT : at32f413_flash.h
  • FLASH_FAT16_1_ADDR : flash_fat16.h
  • FLASH_FAT16_2_ADDR : flash_fat16.h
  • FLASH_FAT16_BOOT_SECTOR_ADDR : flash_fat16.h
  • FLASH_FAT16_FILE_START_ADDR : flash_fat16.h
  • FLASH_FAT16_ROOT_ADDR : flash_fat16.h
  • FLASH_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • FLASH_OBF_FLAG : at32f413_flash.h
  • FLASH_ODF_FLAG : at32f413_flash.h
  • FLASH_ODF_INT : at32f413_flash.h
  • FLASH_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_REG_BASE : at32f413.h
  • FLASH_SECTOR_1K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_1K_SIZE : flash_fat16.h
  • FLASH_SECTOR_2K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_2K_SIZE : flash_fat16.h
  • FLASH_SECTOR_4K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_4K_SIZE : flash_fat16.h
  • FLASH_SECTOR_SIZE : utilities/at32f413_slib_demo/project_l0/src/main.c
  • FLASH_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • FLASH_SIZE_REG : hid_iap_class.h
  • FLASH_SLIB_DATA_START_SECTOR : at32f413_flash.h
  • FLASH_SLIB_END_SECTOR : at32f413_flash.h
  • FLASH_SLIB_START_SECTOR : at32f413_flash.h
  • FLASH_SPI_DUMMY_BYTE : spi_flash.h
  • FLASH_SPIM_EPPERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_ERR_INT : at32f413_flash.h
  • FLASH_SPIM_OBF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_INT : at32f413_flash.h
  • FLASH_SPIM_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_START_ADDR : at32f413_flash.h
  • FLASH_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • FLASH_TEST_ADDR : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • FLASH_UNLOCK_KEY1 : at32f413_flash.h
  • FLASH_UNLOCK_KEY2 : at32f413_flash.h
  • FLASH_USDERR_FLAG : at32f413_flash.h
  • FLEX_CHANNEL1 : at32f413_dma.h
  • FLEX_CHANNEL2 : at32f413_dma.h
  • FLEX_CHANNEL3 : at32f413_dma.h
  • FLEX_CHANNEL4 : at32f413_dma.h
  • FLEX_CHANNEL5 : at32f413_dma.h
  • FLEX_CHANNEL6 : at32f413_dma.h
  • FLEX_CHANNEL7 : at32f413_dma.h
  • FZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

- g -

  • GET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • GET_RX_LEN_ADDR : at32f413_usb.h
  • GET_TX_LEN_ADDR : at32f413_usb.h
  • GPIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • GPIO_PINS_0 : at32f413_gpio.h
  • GPIO_PINS_1 : at32f413_gpio.h
  • GPIO_PINS_10 : at32f413_gpio.h
  • GPIO_PINS_11 : at32f413_gpio.h
  • GPIO_PINS_12 : at32f413_gpio.h
  • GPIO_PINS_13 : at32f413_gpio.h
  • GPIO_PINS_14 : at32f413_gpio.h
  • GPIO_PINS_15 : at32f413_gpio.h
  • GPIO_PINS_2 : at32f413_gpio.h
  • GPIO_PINS_3 : at32f413_gpio.h
  • GPIO_PINS_4 : at32f413_gpio.h
  • GPIO_PINS_5 : at32f413_gpio.h
  • GPIO_PINS_6 : at32f413_gpio.h
  • GPIO_PINS_7 : at32f413_gpio.h
  • GPIO_PINS_8 : at32f413_gpio.h
  • GPIO_PINS_9 : at32f413_gpio.h
  • GPIO_PINS_ALL : at32f413_gpio.h
  • GPIOA : at32f413_gpio.h
  • GPIOA_BASE : at32f413.h
  • GPIOB : at32f413_gpio.h
  • GPIOB_BASE : at32f413.h
  • GPIOC : at32f413_gpio.h
  • GPIOC_BASE : at32f413.h
  • GPIOD : at32f413_gpio.h
  • GPIOD_BASE : at32f413.h
  • GPIOF : at32f413_gpio.h
  • GPIOF_BASE : at32f413.h


AT32F413 Firmwary Library: Globals

- h -

  • HBYTE : usb_std.h
  • HEXT_STABLE_DELAY : system_at32f413.h
  • HEXT_STARTUP_TIMEOUT : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HEXT_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HICK_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HID_CLASS_DESC_HID : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_PHYSICAL : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_REPORT : audio_hid_desc.h, usb_std.h
  • HID_DESCRIPTOR_TYPE : usb_std.h
  • HID_IAP_BUFFER_LEN : hid_iap_class.h
  • HID_INTERFACE_NUMBER : audio_hid_desc.h
  • HID_REPORT_DESC : usb_std.h
  • HID_REPORT_ID_1 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_2 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_3 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_4 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_5 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_6 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REQ_GET_IDLE : usb_std.h
  • HID_REQ_GET_PROTOCOL : usb_std.h
  • HID_REQ_GET_REPORT : usb_std.h
  • HID_REQ_SET_IDLE : usb_std.h
  • HID_REQ_SET_PROTOCOL : usb_std.h
  • HID_REQ_SET_REPORT : usb_std.h
  • HIDIAP_BCD_NUM : hid_iap_desc.h
  • HIDIAP_BINTERVAL_TIME : hid_iap_desc.h
  • HIST_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c


AT32F413 Firmwary Library: Globals

- i -

  • I2C1 : at32f413_i2c.h
  • I2C1_BASE : at32f413.h
  • I2C1_GMUX_0001 : at32f413_gpio.h
  • I2C1_GMUX_0011 : at32f413_gpio.h
  • I2C1_MUX : at32f413_gpio.h
  • I2C2 : at32f413_i2c.h
  • I2C2_BASE : at32f413.h
  • I2C2_GMUX_0001 : at32f413_gpio.h
  • I2C2_GMUX_0010 : at32f413_gpio.h
  • I2C2_GMUX_0011 : at32f413_gpio.h
  • I2C_ACKFAIL_FLAG : at32f413_i2c.h
  • I2C_ADDR2_FLAG : at32f413_i2c.h
  • I2C_ADDR7F_FLAG : at32f413_i2c.h
  • I2C_ADDRHF_FLAG : at32f413_i2c.h
  • I2C_ALERTF_FLAG : at32f413_i2c.h
  • I2C_ARLOST_FLAG : at32f413_i2c.h
  • I2C_BUSERR_FLAG : at32f413_i2c.h
  • I2C_BUSYF_FLAG : at32f413_i2c.h
  • I2C_DATA_INT : at32f413_i2c.h
  • I2C_DEVADDRF_FLAG : at32f413_i2c.h
  • I2C_DIRF_FLAG : at32f413_i2c.h
  • I2C_END : i2c_application.c
  • I2C_ERR_INT : at32f413_i2c.h
  • I2C_EVENT_CHECK_ACKFAIL : i2c_application.h
  • I2C_EVENT_CHECK_NONE : i2c_application.h
  • I2C_EVENT_CHECK_STOP : i2c_application.h
  • I2C_EVT_INT : at32f413_i2c.h
  • I2C_GCADDRF_FLAG : at32f413_i2c.h
  • I2C_HOSTADDRF_FLAG : at32f413_i2c.h
  • I2C_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • I2C_OUF_FLAG : at32f413_i2c.h
  • I2C_PECERR_FLAG : at32f413_i2c.h
  • I2C_RDBF_FLAG : at32f413_i2c.h
  • I2C_START : i2c_application.c
  • I2C_STARTF_FLAG : at32f413_i2c.h
  • I2C_STOPF_FLAG : at32f413_i2c.h
  • I2C_TDBE_FLAG : at32f413_i2c.h
  • I2C_TDC_FLAG : at32f413_i2c.h
  • I2C_TIMEOUT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2C_TMOUT_FLAG : at32f413_i2c.h
  • I2C_TRMODE_FLAG : at32f413_i2c.h
  • I2Cx_ADDRESS : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_DMA_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_RX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_TX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_ERR_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_ERR_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_EVT_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_EVT_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SPEED : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2S1_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S_ACS_FLAG : at32f413_spi.h
  • I2S_TUERR_FLAG : at32f413_spi.h
  • IAP_ACK : hid_iap_class.h
  • IAP_CMD_ADDR : hid_iap_class.h
  • IAP_CMD_CRC : hid_iap_class.h
  • IAP_CMD_DATA : hid_iap_class.h
  • IAP_CMD_FINISH : hid_iap_class.h
  • IAP_CMD_GET : hid_iap_class.h
  • IAP_CMD_IDLE : hid_iap_class.h
  • IAP_CMD_JMP : hid_iap_class.h
  • IAP_CMD_START : hid_iap_class.h
  • IAP_FAILED : flash_fat16.h
  • IAP_NACK : hid_iap_class.h
  • IAP_REV_FLAG_5A : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_DONE : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_ERROR : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_NO : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_SUCCESS : flash_fat16.h
  • IAP_UPGRADE_COMPLETE_FLAG : hid_iap_class.h, flash_fat16.h
  • IAP_UPGRADE_FLAG : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IAP_UPGRADE_FLAG_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IMG_CONSTANT : julia_fpu.h
  • INCLUDE_uxTaskPriorityGet : FreeRTOSConfig.h
  • INCLUDE_vTaskCleanUpResources : FreeRTOSConfig.h
  • INCLUDE_vTaskDelay : FreeRTOSConfig.h
  • INCLUDE_vTaskDelayUntil : FreeRTOSConfig.h
  • INCLUDE_vTaskDelete : FreeRTOSConfig.h
  • INCLUDE_vTaskPrioritySet : FreeRTOSConfig.h
  • INCLUDE_vTaskSuspend : FreeRTOSConfig.h
  • INCLUDE_xTaskGetCurrentTaskHandle : FreeRTOSConfig.h
  • INTERNAL_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • INVAILD_OFFSET_ADDR : flash_fat16.h
  • INVALID_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELD_IN_PARAMETER_LIST : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELED_IN_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • IOMUX : at32f413_gpio.h
  • IOMUX_BASE : at32f413.h
  • IOMUX_MAKE_VALUE : at32f413_gpio.h
  • ITERATION : julia_fpu.h


AT32F413 Firmwary Library: Globals

- k -

  • KB_TO_B : hid_iap_class.h
  • KEYBOARD_BCD_NUM : keyboard_desc.h
  • KEYBOARD_BINTERVAL_TIME : keyboard_desc.h


AT32F413 Firmwary Library: Globals

- l -

  • LBYTE : usb_std.h
  • LED_NUM : at32f413_board.h
  • LEFT_BUTTON : mouse_class.h
  • LEFT_MOVE : mouse_class.h
  • LEXT_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h


AT32F413 Firmwary Library: Globals

- m -

  • MAKE_VALUE : at32f413.h
  • MASTER_BOARD : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • MATCH_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • MAX : usb_std.h
  • MCU_ID1 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID2 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID3 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MEDIUM_HAVE_CHANGED : cdc_msc_class.h, msc_bot_scsi.h
  • MEDIUM_NOT_PRESENT : cdc_msc_class.h, msc_bot_scsi.h
  • MIC_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • MIN : usb_std.h
  • MISC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • MMC_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • MOUSE_BCD_NUM : mouse_desc.h
  • MOUSE_BINTERVAL_TIME : mouse_desc.h
  • MOVE_STEP : mouse_class.h
  • MS_TICK : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
  • MSC_BCD_NUM : msc_desc.h
  • MSC_BOT_STATE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_RECOVERY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_ALLOW_MEDIUM_REMOVAL : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_FORMAT_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_INQUIRY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE6 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_FORMAT_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_REQUEST_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_START_STOP : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_TEST_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_MAX_DATA_BUF_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_BO_RESET : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_GET_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_CMD : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_IN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_LAST_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_SEND_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_STATUS : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_SUPPORT_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MULTI_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c


AT32F413 Firmwary Library: Globals

- n -

  • NULL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • NUM_TAPS : fir_coefficient.c, fir_filter.c
  • NUMSTUDENTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • NUMSUBJECTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • NVIC_VECTTAB_FLASH : at32f413_misc.h
  • NVIC_VECTTAB_RAM : at32f413_misc.h


AT32F413 Firmwary Library: Globals

- o -

  • OPERATION_TIMEOUT : at32f413_flash.h


AT32F413 Firmwary Library: Globals

- p -

  • PARAMETER_LIST_LENGTH_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • PD01_GMUX : at32f413_gpio.h
  • PD01_MUX : at32f413_gpio.h
  • PERIPH_BASE : at32f413.h
  • PERIPH_REG : at32f413.h
  • PERIPH_REG_BIT : at32f413.h
  • PERIPHERAL_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PLL_STABLE_DELAY : system_at32f413.h
  • PRINT_UART : at32f413_board.h
  • PRINT_UART_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_GPIO : at32f413_board.h
  • PRINT_UART_TX_GPIO_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_PIN : at32f413_board.h
  • PRINTER_BCD_NUM : printer_desc.h
  • PRINTER_DEVICE_ID_LEN : printer_class.h
  • PRINTER_PROTOCOL_1284_4 : printer_desc.h
  • PRINTER_PROTOCOL_BI_DIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_UNIDIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_VENDOR_SPECIFIC : printer_desc.h
  • PROGRAMMING_TIMEOUT : at32f413_flash.h
  • PUTCHAR_PROTOTYPE : at32f413_board.c
  • PWC : at32f413_pwc.h
  • PWC_BASE : at32f413.h
  • PWC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • PWC_PVM_OUTPUT_FLAG : at32f413_pwc.h
  • PWC_STANDBY_FLAG : at32f413_pwc.h
  • PWC_WAKEUP_FLAG : at32f413_pwc.h
  • PWC_WAKEUP_PIN_1 : at32f413_pwc.h


AT32F413 Firmwary Library: Globals

- r -

  • RAM_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • RAM_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • REAL_CONSTANT : julia_fpu.h
  • REG16 : at32f413.h
  • REG32 : at32f413.h
  • REG8 : at32f413.h
  • REQ_SENSE_STANDARD_DATA_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • RIGHT_BUTTON : mouse_class.h
  • RIGHT_MOVE : mouse_class.h
  • RS485_BAUDRATE : project/at_start_f413/examples/usart/rs485/src/main.c
  • RS485_BUFFER_SIZE : project/at_start_f413/examples/usart/rs485/src/main.c
  • RTC : at32f413_rtc.h
  • RTC_BASE : at32f413.h
  • RTC_CFGF_FLAG : at32f413_rtc.h
  • RTC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • RTC_OVF_FLAG : at32f413_rtc.h
  • RTC_OVF_INT : at32f413_rtc.h
  • RTC_TA_FLAG : at32f413_rtc.h
  • RTC_TA_INT : at32f413_rtc.h
  • RTC_TS_FLAG : at32f413_rtc.h
  • RTC_TS_INT : at32f413_rtc.h
  • RTC_UPDF_FLAG : at32f413_rtc.h


AT32F413 Firmwary Library: Globals

- s -

  • SAMPLE_FREQ : audio_desc.h, audio_hid_desc.h
  • SAMPLING_NUM : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • SC_3_5V_CLK : smartcard_config.h
  • SC_3_5V_PIN : smartcard_config.h
  • SC_3_5V_PORT : smartcard_config.h
  • SC_CMDVCC_CLK : smartcard_config.h
  • SC_CMDVCC_PIN : smartcard_config.h
  • SC_CMDVCC_PORT : smartcard_config.h
  • SC_F_DIV_D : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_OFF_CLK : smartcard_config.h
  • SC_OFF_EXINT : smartcard_config.h
  • SC_OFF_EXINT_IRQ : smartcard_config.h
  • SC_OFF_PIN : smartcard_config.h
  • SC_OFF_PINSOURCE : smartcard_config.h
  • SC_OFF_PORT : smartcard_config.h
  • SC_OFF_PORTSOURCE : smartcard_config.h
  • SC_RECEIVE_TIMEOUT : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_RESET_CLK : smartcard_config.h
  • SC_RESET_PIN : smartcard_config.h
  • SC_RESET_PORT : smartcard_config.h
  • SC_USART : smartcard_config.h
  • SC_USART_CLK : smartcard_config.h
  • SC_USART_CLK_PIN : smartcard_config.h
  • SC_USART_CLK_PORT : smartcard_config.h
  • SC_USART_DIV_VAL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART_GPIO_CLK : smartcard_config.h
  • SC_USART_IRQHandler : smartcard_config.h
  • SC_USART_IRQn : smartcard_config.h
  • SC_USART_TX_PIN : smartcard_config.h
  • SC_USART_TX_PORT : smartcard_config.h
  • SCLK_FROM_HICK : project/at_start_f413/examples/acc/calibration/src/main.c
  • SCREEN_X_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • SCREEN_Y_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • SCSI_INQUIRY_DATA_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • SD_0TO7BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_16TO23BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_24TO31BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_8TO15BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ALLZERO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_LOCKED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CHECK_PATTERN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ALL_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_SD_SET_BUSWIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CLR_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAST_IO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GEN_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IDLE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_INACTIVE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IRQ_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_READ : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_WRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SEND_EXT_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SWITCH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_NO_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_CHANGE_SECURE_AREA : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RES1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RN2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_SCR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RES2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RN1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CLR_CARD_DETECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_STAUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_DIRECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_EXTENDED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_SEN_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEL_DESEL_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_STATUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCK_COUNT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCKLEN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_DSR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_REL_ADDR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_STOP_TRANSMISSION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFOBYTES : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HIGH_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SD_MAX_DATA_LENGTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_MAX_VOLT_TRIAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CID_CSD_OVERWRIETE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERRORBITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_FUNCTION_NUMBER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SINGLE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STD_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_MMC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_SD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WIDE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO1_BASE : at32f413.h
  • SDIO1_GMUX_0100 : at32f413_gpio.h
  • SDIO1_GMUX_0101 : at32f413_gpio.h
  • SDIO1_GMUX_0110 : at32f413_gpio.h
  • SDIO1_GMUX_0111 : at32f413_gpio.h
  • SDIO_CMD0TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_CMDCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDCMPL_INT : at32f413_sdio.h
  • SDIO_CMDFAIL_FLAG : at32f413_sdio.h
  • SDIO_CMDFAIL_INT : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_INT : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_INT : at32f413_sdio.h
  • SDIO_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_DOCMD_FLAG : at32f413_sdio.h
  • SDIO_DOCMD_INT : at32f413_sdio.h
  • SDIO_DORX_FLAG : at32f413_sdio.h
  • SDIO_DORX_INT : at32f413_sdio.h
  • SDIO_DOTX_FLAG : at32f413_sdio.h
  • SDIO_DOTX_INT : at32f413_sdio.h
  • SDIO_DTBLKCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTBLKCMPL_INT : at32f413_sdio.h
  • SDIO_DTCMP_INT : at32f413_sdio.h
  • SDIO_DTCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_INT : at32f413_sdio.h
  • SDIO_DTTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_DTTIMEOUT_INT : at32f413_sdio.h
  • SDIO_FIFO_Address : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_READ_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_WRITE_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • SDIO_RXBUF_FLAG : at32f413_sdio.h
  • SDIO_RXBUF_INT : at32f413_sdio.h
  • SDIO_RXBUFE_FLAG : at32f413_sdio.h
  • SDIO_RXBUFE_INT : at32f413_sdio.h
  • SDIO_RXBUFF_FLAG : at32f413_sdio.h
  • SDIO_RXBUFF_INT : at32f413_sdio.h
  • SDIO_RXBUFH_FLAG : at32f413_sdio.h
  • SDIO_RXBUFH_INT : at32f413_sdio.h
  • SDIO_RXERRO_FLAG : at32f413_sdio.h
  • SDIO_RXERRO_INT : at32f413_sdio.h
  • SDIO_SBITERR_FLAG : at32f413_sdio.h
  • SDIO_SBITERR_INT : at32f413_sdio.h
  • SDIO_SDIOIF_FLAG : at32f413_sdio.h
  • SDIO_SDIOIF_INT : at32f413_sdio.h
  • SDIO_SEND_IF_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STATIC_FLAGS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_TXBUF_FLAG : at32f413_sdio.h
  • SDIO_TXBUF_INT : at32f413_sdio.h
  • SDIO_TXBUFE_FLAG : at32f413_sdio.h
  • SDIO_TXBUFE_INT : at32f413_sdio.h
  • SDIO_TXBUFF_FLAG : at32f413_sdio.h
  • SDIO_TXBUFF_INT : at32f413_sdio.h
  • SDIO_TXBUFH_FLAG : at32f413_sdio.h
  • SDIO_TXBUFH_INT : at32f413_sdio.h
  • SDIO_TXERRU_FLAG : at32f413_sdio.h
  • SDIO_TXERRU_INT : at32f413_sdio.h
  • SDIOx : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SECTOR_NUM : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SECTOR_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • SECTOR_SIZE_1K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_2K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_4K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_WORD_CNT : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SENSE_KEY_ABORTED_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_BLANK_CHECK : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_DATA_PROTECT : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_HARDWARE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_ILLEGAL_REQUEST : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MEDIUM_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MISCOMPARE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NO_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NOT_READY : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_RECOVERED_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_UNIT_ATTENTION : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VENDERO_SPECIFIC : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VOLUME_OVERFLOW : cdc_msc_class.h, msc_bot_scsi.h
  • SET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • SETUP_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SHIFT : cdc_keyboard_class.c, keyboard_class.c
  • SLIB_DATA_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_END_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_UNLOCK_KEY : at32f413_flash.h
  • SLOW : project/at_start_f413/templates/src/main.c
  • SNR_THRESHOLD_F32 : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • SPI1 : at32f413_spi.h
  • SPI1_BASE : at32f413.h
  • SPI1_GMUX_0001 : at32f413_gpio.h
  • SPI1_MUX_01 : at32f413_gpio.h
  • SPI2 : at32f413_spi.h
  • SPI2_BASE : at32f413.h
  • SPI2_GMUX_0001 : at32f413_gpio.h
  • SPI2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • SPI_CCERR_FLAG : at32f413_spi.h
  • SPI_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SPI_I2S_BF_FLAG : at32f413_spi.h
  • SPI_I2S_ERROR_INT : at32f413_spi.h
  • SPI_I2S_RDBF_FLAG : at32f413_spi.h
  • SPI_I2S_RDBF_INT : at32f413_spi.h
  • SPI_I2S_ROERR_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_INT : at32f413_spi.h
  • SPI_MMERR_FLAG : at32f413_spi.h
  • SPI_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • SPI_TRANS_DMA : spi_flash.h
  • SPIF_BLOCKERASE : spi_flash.h
  • SPIF_CHIP_SIZE : spi_flash.h
  • SPIF_CHIPERASE : spi_flash.h
  • SPIF_DEVICEID : spi_flash.h
  • SPIF_FASTREADDATA : spi_flash.h
  • SPIF_FASTREADDUAL : spi_flash.h
  • SPIF_JEDECDEVICEID : spi_flash.h
  • SPIF_MANUFACTDEVICEID : spi_flash.h
  • SPIF_PAGE_SIZE : spi_flash.h
  • SPIF_PAGEPROGRAM : spi_flash.h
  • SPIF_POWERDOWN : spi_flash.h
  • SPIF_READDATA : spi_flash.h
  • SPIF_READSTATUSREG1 : spi_flash.h
  • SPIF_READSTATUSREG2 : spi_flash.h
  • SPIF_READSTATUSREG3 : spi_flash.h
  • SPIF_RELEASEPOWERDOWN : spi_flash.h
  • SPIF_SECTOR_SIZE : spi_flash.h
  • SPIF_SECTORERASE : spi_flash.h
  • SPIF_WRITEDISABLE : spi_flash.h
  • SPIF_WRITEENABLE : spi_flash.h
  • SPIF_WRITESTATUSREG1 : spi_flash.h
  • SPIF_WRITESTATUSREG2 : spi_flash.h
  • SPIF_WRITESTATUSREG3 : spi_flash.h
  • SPIM_ERASE_TIMEOUT : at32f413_flash.h
  • SPIM_FLASH_BASE : at32f413.h
  • SPIM_PROGRAMMING_TIMEOUT : at32f413_flash.h
  • SPIM_SECTOR_SIZE : operate_spim.h
  • SPIM_TEST_ADDR : operate_spim.h
  • SPK_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • SPK_TX_FIFO_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • SRAM_BASE : at32f413.h
  • SRAM_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • STEP_DELAY_MS : at32f413_board.c
  • STREAM_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SWAPBYTE : usb_std.h
  • SWJTAG_CONF_001 : at32f413_gpio.h
  • SWJTAG_CONF_010 : at32f413_gpio.h
  • SWJTAG_CONF_100 : at32f413_gpio.h
  • SWJTAG_GMUX_001 : at32f413_gpio.h
  • SWJTAG_GMUX_010 : at32f413_gpio.h
  • SWJTAG_GMUX_100 : at32f413_gpio.h
  • SystemCoreClock : system_at32f413.h


AT32F413 Firmwary Library: Globals

- t -

  • T0_PROTOCOL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • TEST_BUFEER_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_FLASH_ADDRESS_START : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_LENGTH_SAMPLES : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • TEST_SLIB_PSW : utilities/at32f413_slib_demo/project_l0/src/main.c
  • TMR1 : at32f413_tmr.h
  • TMR10_BASE : at32f413.h
  • TMR10_GMUX : at32f413_gpio.h
  • TMR11_BASE : at32f413.h
  • TMR11_GMUX : at32f413_gpio.h
  • TMR1_BASE : at32f413.h
  • TMR1_C1DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_C2DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_GMUX_0001 : at32f413_gpio.h
  • TMR1_MUX_01 : at32f413_gpio.h
  • TMR2 : at32f413_tmr.h
  • TMR2_BASE : at32f413.h
  • TMR2_GMUX_001 : at32f413_gpio.h
  • TMR2_GMUX_010 : at32f413_gpio.h
  • TMR2_GMUX_011 : at32f413_gpio.h
  • TMR2_MUX_01 : at32f413_gpio.h
  • TMR2_MUX_10 : at32f413_gpio.h
  • TMR2_MUX_11 : at32f413_gpio.h
  • TMR2ITR1_GMUX : at32f413_gpio.h
  • TMR3 : at32f413_tmr.h
  • TMR3_BASE : at32f413.h
  • TMR3_GMUX_0010 : at32f413_gpio.h
  • TMR3_GMUX_0011 : at32f413_gpio.h
  • TMR3_MUX_10 : at32f413_gpio.h
  • TMR3_MUX_11 : at32f413_gpio.h
  • TMR4 : at32f413_tmr.h
  • TMR4_BASE : at32f413.h
  • TMR5_BASE : at32f413.h
  • TMR5_GMUX_001 : at32f413_gpio.h
  • TMR5CH4_GMUX : at32f413_gpio.h
  • TMR5CH4_MUX : at32f413_gpio.h
  • TMR8_BASE : at32f413.h
  • TMR9_BASE : at32f413.h
  • TMR9_GMUX : at32f413_gpio.h
  • TMR_BRK_FLAG : at32f413_tmr.h
  • TMR_BRK_INT : at32f413_tmr.h
  • TMR_C1_FLAG : at32f413_tmr.h
  • TMR_C1_INT : at32f413_tmr.h
  • TMR_C1_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C2_FLAG : at32f413_tmr.h
  • TMR_C2_INT : at32f413_tmr.h
  • TMR_C2_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C3_FLAG : at32f413_tmr.h
  • TMR_C3_INT : at32f413_tmr.h
  • TMR_C3_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C4_FLAG : at32f413_tmr.h
  • TMR_C4_INT : at32f413_tmr.h
  • TMR_C4_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_HALL_FLAG : at32f413_tmr.h
  • TMR_HALL_INT : at32f413_tmr.h
  • TMR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • TMR_OVF_FLAG : at32f413_tmr.h
  • TMR_OVF_INT : at32f413_tmr.h
  • TMR_TRIGGER_FLAG : at32f413_tmr.h
  • TMR_TRIGGER_INT : at32f413_tmr.h


AT32F413 Firmwary Library: Globals

- u -

  • UART4_BASE : at32f413.h
  • UART4_GMUX_0001 : at32f413_gpio.h
  • UART5_BASE : at32f413.h
  • UNUSED : at32f413_def.h
  • UP_MOVE : mouse_class.h
  • USART1 : at32f413_usart.h
  • USART1_BASE : at32f413.h
  • USART1_GMUX_0001 : at32f413_gpio.h
  • USART1_MUX : at32f413_gpio.h
  • USART2 : at32f413_usart.h
  • USART2_BASE : at32f413.h
  • USART2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART3_BASE : at32f413.h
  • USART3_GMUX_0001 : at32f413_gpio.h
  • USART3_MUX_01 : at32f413_gpio.h
  • USART3_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART_BF_INT : at32f413_usart.h
  • USART_BFF_FLAG : at32f413_usart.h
  • usart_buffer_size : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • USART_CTSCF_FLAG : at32f413_usart.h
  • USART_CTSCF_INT : at32f413_usart.h
  • USART_ERR_INT : at32f413_usart.h
  • USART_FERR_FLAG : at32f413_usart.h
  • USART_IDLE_INT : at32f413_usart.h
  • USART_IDLEF_FLAG : at32f413_usart.h
  • USART_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • USART_NERR_FLAG : at32f413_usart.h
  • USART_PERR_FLAG : at32f413_usart.h
  • USART_PERR_INT : at32f413_usart.h
  • USART_RDBF_FLAG : at32f413_usart.h
  • USART_RDBF_INT : at32f413_usart.h
  • USART_REC_LEN : bootloader/inc/usart.h
  • USART_ROERR_FLAG : at32f413_usart.h
  • USART_TDBE_FLAG : at32f413_usart.h
  • USART_TDBE_INT : at32f413_usart.h
  • USART_TDC_FLAG : at32f413_usart.h
  • USART_TDC_INT : at32f413_usart.h
  • USB : at32f413_usb.h
  • USB_BE_FLAG : at32f413_usb.h
  • USB_BE_INT : at32f413_usb.h
  • USB_BUFFER_SIZE_EX : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h
  • USB_BUFFER_TABLE_ADDRESS : at32f413_usb.h
  • USB_CLASS_CODE_AUDIO : usb_std.h
  • USB_CLASS_CODE_CCID : usb_std.h
  • USB_CLASS_CODE_CDC : usb_std.h
  • USB_CLASS_CODE_CDCDATA : usb_std.h
  • USB_CLASS_CODE_HID : usb_std.h
  • USB_CLASS_CODE_HUB : usb_std.h
  • USB_CLASS_CODE_MSC : usb_std.h
  • USB_CLASS_CODE_PRINTER : usb_std.h
  • USB_CLASS_CODE_VENDOR : usb_std.h
  • USB_CLASS_CODE_VIDEO : usb_std.h
  • USB_CLEAR_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_CLEAR_EXF : at32f413_usb.h
  • USB_CLEAR_RXDTS : at32f413_usb.h
  • USB_CLEAR_RXTC : at32f413_usb.h
  • USB_CLEAR_TXDTS : at32f413_usb.h
  • USB_CLEAR_TXTC : at32f413_usb.h
  • USB_CONF_REMOTE_WAKEUP : usb_std.h
  • USB_CONF_SELF_POWERED : usb_std.h
  • USB_CONFIG_STRING : usb_std.h
  • USB_DBUF0_GET_LEN : at32f413_usb.h
  • USB_DBUF1_GET_LEN : at32f413_usb.h
  • USB_DESCIPTOR_TYPE_CONFIGURATION : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER : usb_std.h
  • USB_DESCIPTOR_TYPE_ENDPOINT : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE_POWER : usb_std.h
  • USB_DESCIPTOR_TYPE_OTHER_SPEED : usb_std.h
  • USB_DESCIPTOR_TYPE_STRING : usb_std.h
  • USB_DEVICE_CFG_DESC_LEN : usb_std.h
  • USB_DEVICE_DESC_LEN : usb_std.h
  • USB_DEVICE_EPT_LEN : usb_std.h
  • USB_DEVICE_IF_DESC_LEN : usb_std.h
  • USB_DEVICE_LANGID_STR_DESC_LEN : usb_std.h
  • USB_DEVICE_OTG_DESC_LEN : usb_std.h
  • USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN : usb_std.h
  • USB_DEVICE_QUALIFIER_DESC_LEN : usb_std.h
  • USB_ENDP_DESC_TABLE_OFFSET : at32f413_usb.c
  • USB_EPT0_DATA_IN : usb_std.h
  • USB_EPT0_DATA_OUT : usb_std.h
  • USB_EPT0_IDLE : usb_std.h
  • USB_EPT0_SETUP : usb_std.h
  • USB_EPT0_STALL : usb_std.h
  • USB_EPT0_STATUS_IN : usb_std.h
  • USB_EPT0_STATUS_OUT : usb_std.h
  • USB_EPT_AUTO_MALLOC_BUFFER : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_EPT_BIT_MASK : at32f413_usb.h
  • USB_EPT_BULK : at32f413_usb.h
  • USB_EPT_CONTROL : at32f413_usb.h
  • USB_EPT_DESC_BULK : usb_std.h
  • USB_EPT_DESC_CONTROL : usb_std.h
  • USB_EPT_DESC_DATA_EPT : usb_std.h
  • USB_EPT_DESC_FD_EPT : usb_std.h
  • USB_EPT_DESC_FDDATA_EPT : usb_std.h
  • USB_EPT_DESC_INTERRUPT : usb_std.h
  • USB_EPT_DESC_ISO : usb_std.h
  • USB_EPT_DESC_NSYNC : usb_std.h
  • USB_EPT_INT : at32f413_usb.h
  • USB_EPT_ISO : at32f413_usb.h
  • USB_EPT_NUM_FLAG : at32f413_usb.h
  • USB_EPTADDR : at32f413_usb.h
  • USB_ETP_DESC_ADAPTIVE : usb_std.h
  • USB_ETP_DESC_ASYNC : usb_std.h
  • USB_ETP_DESC_SYNC : usb_std.h
  • USB_EXF : at32f413_usb.h
  • USB_FEATURE_EPT_HALT : usb_std.h
  • USB_FEATURE_REMOTE_WAKEUP : usb_std.h
  • USB_FEATURE_TEST_MODE : usb_std.h
  • USB_FLASH_ADDR_OFFSET : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • USB_FREE_DB_USER_BUFFER : at32f413_usb.h
  • USB_GET_RX_LEN : at32f413_usb.h
  • USB_GET_TX_LEN : at32f413_usb.h
  • USB_INOUT_FLAG : at32f413_usb.h
  • USB_INTERFACE_ASSOCIATION_TYPE : cdc_msc_desc.c
  • USB_INTERFACE_STRING : usb_std.h
  • USB_LANGID_STRING : usb_std.h
  • USB_LOW_POWER_WAKUP : project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h
  • USB_LSOF_FLAG : at32f413_usb.h
  • USB_LSOF_INT : at32f413_usb.h
  • USB_MAX_EP0_SIZE : usb_std.h
  • USB_MFC_STRING : usb_std.h
  • USB_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • USB_OUT_EPT_DOUBLE_BUF0 : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS_EX : at32f413_usb.h
  • USB_PRODUCT_STRING : usb_std.h
  • USB_REQ_DIR_DTH : usb_std.h
  • USB_REQ_DIR_HTD : usb_std.h
  • USB_REQ_RECIPIENT_DEVICE : usb_std.h
  • USB_REQ_RECIPIENT_ENDPOINT : usb_std.h
  • USB_REQ_RECIPIENT_INTERFACE : usb_std.h
  • USB_REQ_RECIPIENT_MASK : usb_std.h
  • USB_REQ_RECIPIENT_OTHER : usb_std.h
  • USB_REQ_TYPE_CLASS : usb_std.h
  • USB_REQ_TYPE_RESERVED : usb_std.h
  • USB_REQ_TYPE_STANDARD : usb_std.h
  • USB_REQ_TYPE_VENDOR : usb_std.h
  • USB_RST_FLAG : at32f413_usb.h
  • USB_RST_INT : at32f413_usb.h
  • USB_RX_DISABLE : at32f413_usb.h
  • USB_RX_MASK : at32f413_usb.h
  • USB_RX_NAK : at32f413_usb.h
  • USB_RX_STALL : at32f413_usb.h
  • USB_RX_VALID : at32f413_usb.h
  • USB_RXDTS : at32f413_usb.h
  • USB_RXDTS0 : at32f413_usb.h
  • USB_RXDTS1 : at32f413_usb.h
  • USB_RXSTS : at32f413_usb.h
  • USB_RXTC : at32f413_usb.h
  • USB_SERIAL_STRING : usb_std.h
  • USB_SET_DOUBLE_BUFF0_ADDRESS : at32f413_usb.h
  • USB_SET_DOUBLE_BUFF1_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF0_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF1_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_SET_EXF : at32f413_usb.h
  • USB_SET_RX_ADDRESS : at32f413_usb.h
  • USB_SET_RXLEN : at32f413_usb.h
  • USB_SET_RXLEN_REG : at32f413_usb.h
  • USB_SET_RXSTS : at32f413_usb.h
  • USB_SET_TRANS_TYPE : at32f413_usb.h
  • USB_SET_TX_ADDRESS : at32f413_usb.h
  • USB_SET_TXLEN : at32f413_usb.h
  • USB_SET_TXSTS : at32f413_usb.h
  • USB_SETUPTC : at32f413_usb.h
  • USB_SOF_FLAG : at32f413_usb.h
  • USB_SOF_INT : at32f413_usb.h
  • USB_SP_FLAG : at32f413_usb.h
  • USB_SP_INT : at32f413_usb.h
  • USB_STD_REQ_CLEAR_FEATURE : usb_std.h
  • USB_STD_REQ_GET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_GET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_GET_INTERFACE : usb_std.h
  • USB_STD_REQ_GET_STATUS : usb_std.h
  • USB_STD_REQ_SET_ADDRESS : usb_std.h
  • USB_STD_REQ_SET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_SET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_SET_FEATURE : usb_std.h
  • USB_STD_REQ_SET_INTERFACE : usb_std.h
  • USB_STD_REQ_SYNCH_FRAME : usb_std.h
  • USB_TC_FLAG : at32f413_usb.h
  • USB_TC_INT : at32f413_usb.h
  • USB_TOGGLE_RXDTS : at32f413_usb.h
  • USB_TOGGLE_TXDTS : at32f413_usb.h
  • USB_TRANS_TYPE : at32f413_usb.h
  • USB_TX_DISABLE : at32f413_usb.h
  • USB_TX_MASK : at32f413_usb.h
  • USB_TX_NAK : at32f413_usb.h
  • USB_TX_STALL : at32f413_usb.h
  • USB_TX_VALID : at32f413_usb.h
  • USB_TXDTS : at32f413_usb.h
  • USB_TXDTS0 : at32f413_usb.h
  • USB_TXDTS1 : at32f413_usb.h
  • USB_TXSTS : at32f413_usb.h
  • USB_TXTC : at32f413_usb.h
  • USB_UCFOR_FLAG : at32f413_usb.h
  • USB_UCFOR_INT : at32f413_usb.h
  • USB_VIRTUAL_COMPORT : project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • USB_WK_FLAG : at32f413_usb.h
  • USB_WK_INT : at32f413_usb.h
  • USBD_AUDIO_CONFIG_DESC_SIZE : audio_desc.h
  • USBD_AUDIO_DESC_CONFIGURATION_STRING : audio_desc.h
  • USBD_AUDIO_DESC_INTERFACE_STRING : audio_desc.h
  • USBD_AUDIO_DESC_MANUFACTURER_STRING : audio_desc.h
  • USBD_AUDIO_DESC_PRODUCT_STRING : audio_desc.h
  • USBD_AUDIO_FEEDBACK_EPT : audio_class.h
  • USBD_AUDIO_MIC_IN_EPT : audio_class.h
  • USBD_AUDIO_PRODUCT_ID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_LANGID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_SERIAL : audio_desc.h
  • USBD_AUDIO_SPK_OUT_EPT : audio_class.h
  • USBD_AUDIO_VENDOR_ID : audio_desc.h
  • USBD_AUHID_AUDIO_FEEDBACK_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_MIC_IN_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_SPK_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_CONFIG_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_DESC_CONFIGURATION_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_INTERFACE_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_MANUFACTURER_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_PRODUCT_STRING : audio_hid_desc.h
  • USBD_AUHID_HID_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_HID_IN_EPT : audio_hid_class.h
  • USBD_AUHID_HID_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_HID_SIZ_REPORT_DESC : audio_hid_desc.h
  • USBD_AUHID_IN_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_OUT_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_PRODUCT_ID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_LANGID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_SERIAL : audio_hid_desc.h
  • USBD_AUHID_VENDOR_ID : audio_hid_desc.h
  • USBD_CDC_BULK_IN_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_BULK_OUT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CMD_MAXPACKET_SIZE : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CONFIG_DESC_SIZE : cdc_desc.h
  • USBD_CDC_CS_ENDPOINT : usb_std.h
  • USBD_CDC_CS_INTERFACE : usb_std.h
  • USBD_CDC_DESC_CONFIGURATION_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_INTERFACE_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_MANUFACTURER_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_PRODUCT_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_IN_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_INT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_MSC_CONFIG_DESC_SIZE : cdc_msc_desc.h
  • USBD_CDC_MSC_IN_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_OUT_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_PRODUCT_ID : cdc_msc_desc.h
  • USBD_CDC_MSC_VENDOR_ID : cdc_msc_desc.h
  • USBD_CDC_OUT_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_PRODUCT_ID : cdc_desc.h
  • USBD_CDC_SIZ_STRING_LANGID : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SIZ_STRING_SERIAL : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SUBTYPE_ACM : usb_std.h
  • USBD_CDC_SUBTYPE_CMF : usb_std.h
  • USBD_CDC_SUBTYPE_HEADER : usb_std.h
  • USBD_CDC_SUBTYPE_UFD : usb_std.h
  • USBD_CDC_VENDOR_ID : cdc_desc.h
  • USBD_CUSHID_CONFIG_DESC_SIZE : custom_hid_desc.h
  • USBD_CUSHID_DESC_CONFIGURATION_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_INTERFACE_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_MANUFACTURER_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_PRODUCT_STRING : custom_hid_desc.h
  • USBD_CUSHID_PRODUCT_ID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_REPORT_DESC : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_LANGID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_SERIAL : custom_hid_desc.h
  • USBD_CUSHID_VENDOR_ID : custom_hid_desc.h
  • USBD_CUSTOM_HID_IN_EPT : custom_hid_class.h
  • USBD_CUSTOM_HID_OUT_EPT : custom_hid_class.h
  • USBD_CUSTOM_IN_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_CUSTOM_OUT_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_HIDIAP_CONFIG_DESC_SIZE : hid_iap_desc.h
  • USBD_HIDIAP_DESC_CONFIGURATION_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_INTERFACE_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_MANUFACTURER_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_PRODUCT_STRING : hid_iap_desc.h
  • USBD_HIDIAP_IN_EPT : hid_iap_class.h
  • USBD_HIDIAP_IN_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_OUT_EPT : hid_iap_class.h
  • USBD_HIDIAP_OUT_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_PRODUCT_ID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_REPORT_DESC : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_LANGID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_SERIAL : hid_iap_desc.h
  • USBD_HIDIAP_VENDOR_ID : hid_iap_desc.h
  • USBD_IN_MAXPACKET_SIZE : msc_class.h
  • USBD_KEYBOARD_CONFIG_DESC_SIZE : keyboard_desc.h
  • USBD_KEYBOARD_DESC_CONFIGURATION_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_INTERFACE_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_MANUFACTURER_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_PRODUCT_STRING : keyboard_desc.h
  • USBD_KEYBOARD_IN_EPT : keyboard_class.h
  • USBD_KEYBOARD_IN_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_OUT_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_PRODUCT_ID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_REPORT_DESC : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_LANGID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_SERIAL : keyboard_desc.h
  • USBD_KEYBOARD_VENDOR_ID : keyboard_desc.h
  • USBD_MOUSE_CONFIG_DESC_SIZE : mouse_desc.h
  • USBD_MOUSE_DESC_CONFIGURATION_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_INTERFACE_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_MANUFACTURER_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_PRODUCT_STRING : mouse_desc.h
  • USBD_MOUSE_IN_EPT : mouse_class.h
  • USBD_MOUSE_IN_MAXPACKET_SIZE : mouse_class.h
  • USBD_MOUSE_PRODUCT_ID : mouse_desc.h
  • USBD_MOUSE_SIZ_REPORT_DESC : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_LANGID : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_SERIAL : mouse_desc.h
  • USBD_MOUSE_VENDOR_ID : mouse_desc.h
  • USBD_MSC_BULK_IN_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_BULK_OUT_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_CONFIG_DESC_SIZE : msc_desc.h
  • USBD_MSC_DESC_CONFIGURATION_STRING : msc_desc.h
  • USBD_MSC_DESC_INTERFACE_STRING : msc_desc.h
  • USBD_MSC_DESC_MANUFACTURER_STRING : msc_desc.h
  • USBD_MSC_DESC_PRODUCT_STRING : msc_desc.h
  • USBD_MSC_PRODUCT_ID : msc_desc.h
  • USBD_MSC_SIZ_STRING_LANGID : msc_desc.h
  • USBD_MSC_SIZ_STRING_SERIAL : msc_desc.h
  • USBD_MSC_VENDOR_ID : msc_desc.h
  • USBD_OUT_MAXPACKET_SIZE : msc_class.h
  • USBD_PRINTER_BULK_IN_EPT : printer_class.h
  • USBD_PRINTER_BULK_OUT_EPT : printer_class.h
  • USBD_PRINTER_CONFIG_DESC_SIZE : printer_desc.h
  • USBD_PRINTER_DESC_CONFIGURATION_STRING : printer_desc.h
  • USBD_PRINTER_DESC_INTERFACE_STRING : printer_desc.h
  • USBD_PRINTER_DESC_MANUFACTURER_STRING : printer_desc.h
  • USBD_PRINTER_DESC_PRODUCT_STRING : printer_desc.h
  • USBD_PRINTER_IN_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_OUT_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_PRODUCT_ID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_LANGID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_SERIAL : printer_desc.h
  • USBD_PRINTER_VENDOR_ID : printer_desc.h
  • USBD_VCPKYBRD_CDC_BULK_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_BULK_OUT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_INT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CMD_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CONFIG_DESC_SIZE : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_CONFIGURATION_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_INTERFACE_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_MANUFACTURER_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_PRODUCT_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_HID_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_HID_SIZ_REPORT_DESC : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_IN_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_OUT_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_PRODUCT_ID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_LANGID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_SERIAL : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_VENDOR_ID : cdc_keyboard_desc.h
  • USBFS_BASE : at32f413.h
  • USD : at32f413_flash.h
  • USD_BASE : at32f413.h
  • USD_DEPSLP_NO_RST : at32f413_flash.h
  • USD_DEPSLP_RST : at32f413_flash.h
  • USD_STDBY_NO_RST : at32f413_flash.h
  • USD_STDBY_RST : at32f413_flash.h
  • USD_WDT_ATO_DISABLE : at32f413_flash.h
  • USD_WDT_ATO_ENABLE : at32f413_flash.h
  • USE_SLIB_FUNCTION : utilities/at32f413_slib_demo/project_l0/src/main.c
  • USE_STATIC_INIT : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • USER_BUTTON_CRM_CLK : at32f413_board.h
  • USER_BUTTON_PIN : at32f413_board.h
  • USER_BUTTON_PORT : at32f413_board.h


AT32F413 Firmwary Library: Globals

- v -

  • VARIABLES_GET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VCPKYBRD_BCD_NUM : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_DATA_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_HID_BINTERVAL_TIME : cdc_keyboard_desc.h
  • VCPKYBRD_KEYBOARD_INTERFACE : cdc_keyboard_desc.h
  • VCPMSC_CDC_DATA_INTERFACE : cdc_msc_desc.h
  • VCPMSC_CDC_INTERFACE : cdc_msc_desc.h
  • VCPMSC_MSC_INTERFACE : cdc_msc_desc.h
  • VECT_TAB_OFFSET : system_at32f413.c
  • vPortSVCHandler : FreeRTOSConfig.h


AT32F413 Firmwary Library: Globals

- w -

  • W25Q128 : spi_flash.h
  • W25Q16 : spi_flash.h
  • W25Q32 : spi_flash.h
  • W25Q64 : spi_flash.h
  • W25Q80 : spi_flash.h
  • WDT : at32f413_wdt.h
  • WDT_BASE : at32f413.h
  • WDT_DIVF_UPDATE_FLAG : at32f413_wdt.h
  • WDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • WDT_RLDF_UPDATE_FLAG : at32f413_wdt.h
  • WM8988_I2C_ADDR_CSB_HIGH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_I2C_ADDR_CSB_LOW : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R0_LEFT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R10_LEFT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R11_RIGHT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R12_BASS_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R13_TREBLE_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R14_ : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R15_RESET : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R16_3D_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R17_ALC1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R18_ALC2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R19_ALC3 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R1_RIGHT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R20_NOISE_GATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R21_LEFT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R22_RIGHT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R23_ADDITIONAL_1_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R24_ADDITIONAL_2_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R25_PWR_1_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R26_PWR_2_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R27_ADDITIONAL_3_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R2_LOUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R31_ADC_INPUT_MODE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R32_ADC_L_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R33_ADC_R_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R34_LEFT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R35_LEFT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R36_RIGHT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R37_RIGHT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R38_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R39_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R3_ROUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R40_LOUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R41_ROUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R42_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R43_LOW_POWER_PALYBACK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R4_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R5_ADC_DAC_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R6_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R7_AUDIO_INTERFACE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R8_SAMPLE_RATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R9_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_REG_BITW16 : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ16K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ48K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WWDT : at32f413_wwdt.h
  • WWDT_BASE : at32f413.h
  • WWDT_EN_BIT : at32f413_wwdt.h
  • WWDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h


AT32F413 Firmwary Library: Globals

- x -

  • XMC_REG_BASE : at32f413.h
  • xPortPendSVHandler : FreeRTOSConfig.h
  • xPortSysTickHandler : FreeRTOSConfig.h


AT32F413 Firmwary Library: Globals

- z -

  • ZOOM : project/at_start_f413/examples/cortex_m4/fpu/src/main.c


AT32F413 Firmwary Library: FreeRTOSConfig.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
FreeRTOSConfig.h
Go to the documentation of this file.
1/*
2 FreeRTOS V10.4.3 - Copyright (C) 2020 Real Time Engineers Ltd.
3 All rights reserved
4
5 VISIT http://www.FreeRTOS.org TO ENSURE YOU ARE USING THE LATEST VERSION.
6
7 This file is part of the FreeRTOS distribution.
8
9 FreeRTOS is free software; you can redistribute it and/or modify it under
10 the terms of the GNU General Public License (version 2) as published by the
11 Free Software Foundation >>>> AND MODIFIED BY <<<< the FreeRTOS exception.
12
13 ***************************************************************************
14 >>! NOTE: The modification to the GPL is included to allow you to !<<
15 >>! distribute a combined work that includes FreeRTOS without being !<<
16 >>! obliged to provide the source code for proprietary components !<<
17 >>! outside of the FreeRTOS kernel. !<<
18 ***************************************************************************
19
20 FreeRTOS is distributed in the hope that it will be useful, but WITHOUT ANY
21 WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
22 FOR A PARTICULAR PURPOSE. Full license text is available on the following
23 link: http://www.freertos.org/a00114.html
24
25 ***************************************************************************
26 * *
27 * FreeRTOS provides completely free yet professionally developed, *
28 * robust, strictly quality controlled, supported, and cross *
29 * platform software that is more than just the market leader, it *
30 * is the industry's de facto standard. *
31 * *
32 * Help yourself get started quickly while simultaneously helping *
33 * to support the FreeRTOS project by purchasing a FreeRTOS *
34 * tutorial book, reference manual, or both: *
35 * http://www.FreeRTOS.org/Documentation *
36 * *
37 ***************************************************************************
38
39 http://www.FreeRTOS.org/FAQHelp.html - Having a problem? Start by reading
40 the FAQ page "My application does not run, what could be wrong?". Have you
41 defined configASSERT()?
42
43 http://www.FreeRTOS.org/support - In return for receiving this top quality
44 embedded software for free we request you assist our global community by
45 participating in the support forum.
46
47 http://www.FreeRTOS.org/training - Investing in training allows your team to
48 be as productive as possible as early as possible. Now you can receive
49 FreeRTOS training directly from Richard Barry, CEO of Real Time Engineers
50 Ltd, and the world's leading authority on the world's leading RTOS.
51
52 http://www.FreeRTOS.org/plus - A selection of FreeRTOS ecosystem products,
53 including FreeRTOS+Trace - an indispensable productivity tool, a DOS
54 compatible FAT file system, and our tiny thread aware UDP/IP stack.
55
56 http://www.FreeRTOS.org/labs - Where new FreeRTOS products go to incubate.
57 Come and try FreeRTOS+TCP, our new open source TCP/IP stack for FreeRTOS.
58
59 http://www.OpenRTOS.com - Real Time Engineers ltd. license FreeRTOS to High
60 Integrity Systems ltd. to sell under the OpenRTOS brand. Low cost OpenRTOS
61 licenses offer ticketed support, indemnification and commercial middleware.
62
63 http://www.SafeRTOS.com - High Integrity Systems also provide a safety
64 engineered and independently SIL3 certified version for use in safety and
65 mission critical applications that require provable dependability.
66
67 1 tab == 4 spaces!
68 * Copyright notice & Disclaimer
69 *
70 * The software Board Support Package (BSP) that is made available to
71 * download from Artery official website is the copyrighted work of Artery.
72 * Artery authorizes customers to use, copy, and distribute the BSP
73 * software and its related documentation for the purpose of design and
74 * development in conjunction with Artery microcontrollers. Use of the
75 * software is governed by this copyright notice and the following disclaimer.
76 *
77 * THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES,
78 * GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS,
79 * TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR
80 * STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS,
81 * INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
82 * FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
83 *
84 **************************************************************************
85*/
86
87#ifndef FREERTOS_CONFIG_H
88#define FREERTOS_CONFIG_H
89
90#ifdef __cplusplus
91 extern "C" {
92#endif
93
94#if defined(__ICCARM__) || defined(__CC_ARM) || defined(__GNUC__)
95 #include <stdint.h>
96 #include "system_at32f413.h"
97#endif
98
99
100
101/*-----------------------------------------------------------
102 * Application specific definitions.
103 *
104 * These definitions should be adjusted for your particular hardware and
105 * application requirements.
106 *
107 * THESE PARAMETERS ARE DESCRIBED WITHIN THE 'CONFIGURATION' SECTION OF THE
108 * FreeRTOS API DOCUMENTATION AVAILABLE ON THE FreeRTOS.org WEB SITE.
109 *
110 * See http://www.freertos.org/a00110.html.
111 *----------------------------------------------------------*/
112#define configUSE_PREEMPTION 1
113#define configUSE_IDLE_HOOK 0
114#define configUSE_TICK_HOOK 0
115#define configCPU_CLOCK_HZ ( ( unsigned long ) system_core_clock )
116#define configTICK_RATE_HZ ( ( TickType_t ) 1000 )
117#define configMAX_PRIORITIES ( 5 )
118#define configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )
119#define configSUPPORT_DYNAMIC_ALLOCATION 1
120#define configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )
121#define configMAX_TASK_NAME_LEN ( 16 )
122#define configUSE_16_BIT_TICKS 0
123#define configIDLE_SHOULD_YIELD 1
124
125
126/* Co-routine definitions. */
127#define configUSE_CO_ROUTINES 0
128#define configMAX_CO_ROUTINE_PRIORITIES ( 2 )
129
130/* Set the following definitions to 1 to include the API function, or zero
131to exclude the API function. */
132
133#define INCLUDE_vTaskPrioritySet 1
134#define INCLUDE_uxTaskPriorityGet 1
135#define INCLUDE_vTaskDelete 1
136#define INCLUDE_vTaskCleanUpResources 0
137#define INCLUDE_vTaskSuspend 1
138#define INCLUDE_vTaskDelayUntil 1
139#define INCLUDE_vTaskDelay 1
140#define INCLUDE_xTaskGetCurrentTaskHandle 1
141/* Cortex-M specific definitions. */
142#ifdef __NVIC_PRIO_BITS
143 /* __BVIC_PRIO_BITS will be specified when CMSIS is being used. */
144 #define configPRIO_BITS __NVIC_PRIO_BITS
145#else
146 #define configPRIO_BITS 4 /* 15 priority levels */
147#endif
148
149/* The lowest interrupt priority that can be used in a call to a "set priority"
150function. */
151#define configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f
152
153/* The highest interrupt priority that can be used by any interrupt service
154routine that makes calls to interrupt safe FreeRTOS API functions. DO NOT CALL
155INTERRUPT SAFE FREERTOS API FUNCTIONS FROM ANY INTERRUPT THAT HAS A HIGHER
156PRIORITY THAN THIS! (higher priorities are lower numeric values. */
157#define configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01
158
159/* Interrupt priorities used by the kernel port layer itself. These are generic
160to all Cortex-M ports, and do not rely on any particular library functions. */
161#define configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
162/* !!!! configMAX_SYSCALL_INTERRUPT_PRIORITY must not be set to zero !!!!
163See http://www.FreeRTOS.org/RTOS-Cortex-M3-M4.html. */
164#define configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
165
166/* Normal assert() semantics without relying on the provision of an assert.h
167header file. */
168#define configASSERT( x ) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }
169
170/* Definitions that map the FreeRTOS port interrupt handlers to their CMSIS
171standard names. */
172#define vPortSVCHandler SVC_Handler
173#define xPortPendSVHandler PendSV_Handler
174#define xPortSysTickHandler SysTick_Handler
175
176#ifdef __cplusplus
177 }
178#endif
179
180#endif /* FREERTOS_CONFIG_H */
181
system_at32f413.h
cmsis cortex-m4 system header file.


AT32F413 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/hid_iap_user.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __HID_IAP_USER_H
27#define __HID_IAP_USER_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "hid_iap_class.h"
34
47#define FLASH_APP_ADDRESS 0x08006000
48
57void iap_init(void);
58 iap_result_type iap_get_upgrade_flag(void);
59void app_loop(void);
60
73#ifdef __cplusplus
74}
75#endif
76
77#endif
78
iap_result_type
iap_result_type
Definition: hid_iap_class.h:84
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:251
hid_iap_class.h
usb hid iap header file


AT32F413 Firmwary Library: iap.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/iap.h
Go to the documentation of this file.
1
25#ifndef __IAP_H__
26#define __IAP_H__
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
46/* app starting address */
47#define APP_START_ADDR 0x08004000
48
49/* the previous sector of app starting address is iap upgrade flag */
50#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
51
52/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
53indicates that an app upgrade will follow, see iap application note for more details */
54#define IAP_UPGRADE_FLAG 0x41544B38
55
64void iap_command_handle(void);
65void iap_init(void);
66
79#ifdef __cplusplus
80}
81#endif
82
83#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:42


AT32F413 Firmwary Library: tmr.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/tmr.h
Go to the documentation of this file.
1
25#ifndef __TMR_H
26#define __TMR_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
46void tmr_init(void);
47
60#ifdef __cplusplus
61}
62#endif
63
64#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:42


AT32F413 Firmwary Library: usart.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/usart.h
Go to the documentation of this file.
1
25#ifndef __USART_H
26#define __USART_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
34extern uint8_t iap_flag;
35
48#define IAP_REV_FLAG_NO 0
49#define IAP_REV_FLAG_5A 1
50#define IAP_REV_FLAG_DONE 2
51#define IAP_REV_FLAG_ERROR 3
52
61void uart_init(uint32_t baudrate);
62void back_ok(void);
63void back_err(void);
64
77#ifdef __cplusplus
78}
79#endif
80
81#endif
82
83
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:36
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:118
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:105


AT32F413 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/hid_iap_user.c
Go to the documentation of this file.
1
25#include "hid_iap_user.h"
26#include "hid_iap_class.h"
27#include "string.h"
28
37void (*pftarget)(void);
38void iap_clear_upgrade_flag(void);
39void iap_set_upgrade_flag(void);
40uint32_t crc_cal(uint32_t addr, uint16_t nk);
41
42void iap_idle(void);
43void iap_start(void);
44void iap_finish(void);
45void iap_jump(void);
46void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
47
53void iap_clear_upgrade_flag(void)
54{
55 flash_unlock();
56 flash_sector_erase(iap_info.flag_address);
57 flash_lock();
58}
59
65void iap_set_upgrade_flag(void)
66{
67 flash_unlock();
68 flash_word_program(iap_info.flag_address, IAP_UPGRADE_COMPLETE_FLAG);
69 flash_lock();
70}
71
77 iap_result_type iap_get_upgrade_flag(void)
78{
79 uint32_t flag_address = iap_info.flag_address;
80 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
81 {
82 return IAP_SUCCESS;
83 }
84 else
85 {
86 return IAP_FAILED;
87 }
88}
89
95void iap_init(void)
96{
97 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
98 if(iap_info.flash_size < KB_TO_B(256))
99 {
100 iap_info.sector_size = SECTOR_SIZE_1K;
101 }
102 else
103 {
104 iap_info.sector_size = SECTOR_SIZE_2K;
105 }
106
107 iap_info.flash_start_address = FLASH_BASE;
108 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
109
110 iap_info.app_address = FLASH_APP_ADDRESS;
111 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
112
113 iap_info.fifo_length = 0;
114 iap_info.iap_address = 0;
115}
116
122void iap_idle(void)
123{
124 iap_info.state = IAP_STS_JMP_WAIT;
125 iap_init();
126 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
127}
128
134void iap_start(void)
135{
136 iap_info.state = IAP_STS_START;
137 iap_init();
138 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
139}
140
141/*
142 * @brief iap jump
143 * @param none
144 * @retval none
145 */
146void iap_jump()
147{
148 iap_info.state = IAP_STS_JMP_WAIT;
149 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
150}
151
152/*
153 * @brief iap get
154 * @param none
155 * @retval none
156 */
157void iap_get()
158{
159 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
160 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
161 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
162 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
163 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
164}
165
166
167
168/*
169 * @brief iap respond
170 * @param res_buf: data buffer pointer.
171 * @param iap_cmd: iap command
172 * @param result: iap result
173 * @retval the result of the address parse
174 */
175void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
176{
177 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
178 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
179 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
180 res_buf[3] = (uint8_t)((result) & 0xFF);
181
182 iap_info.respond_flag = 1;
183}
184
192 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
193{
194 iap_result_type status = IAP_SUCCESS;
195 uint16_t iap_cmd;
196
197 if(len < 2)
198 {
199 return IAP_FAILED;
200 }
201
202 iap_info.respond_flag = 0;
203
204 iap_cmd = (pdata[0] << 8) | pdata[1];
205
206 switch(iap_cmd)
207 {
208 case IAP_CMD_IDLE:
209 iap_idle();
210 break;
211 case IAP_CMD_START:
212 iap_start();
213 break;
214 case IAP_CMD_JMP:
215 iap_jump();
216 break;
217 case IAP_CMD_GET:
218 iap_get();
219 break;
220 default:
221 status = IAP_FAILED;
222 break;
223 }
224
225 if(iap_info.respond_flag)
226 {
227 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
228 }
229
230 return status;
231}
232
238void usbd_hid_iap_in_complete(void *udev)
239{
240 if(iap_info.state == IAP_STS_JMP_WAIT)
241 {
242 iap_info.state = IAP_STS_JMP;
243 }
244}
245
251void app_loop(void)
252{
253 if(iap_info.state == IAP_STS_JMP)
254 {
255 iap_clear_upgrade_flag();
256 nvic_system_reset();
257 }
258}
259
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:66
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:73
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:59
iap_result_type
iap_result_type
Definition: hid_iap_class.h:84
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:80
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:60
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:76
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:56
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:67
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:72
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:57
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:87
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:85
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:93
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:99
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:98
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:52
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:319
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:65
iap_idle
void iap_idle(void)
iap idle function
Definition: app_led3_toggle/src/hid_iap_user.c:122
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: app_led3_toggle/src/hid_iap_user.c:175
iap_init
void iap_init(void)
iap init
Definition: app_led3_toggle/src/hid_iap_user.c:95
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:192
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:153
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:313
iap_start
void iap_start(void)
iap start function
Definition: app_led3_toggle/src/hid_iap_user.c:134
pftarget
void(* pftarget)(void)
Definition: app_led3_toggle/src/hid_iap_user.c:37
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: app_led3_toggle/src/hid_iap_user.c:53
iap_get
void iap_get()
Definition: app_led3_toggle/src/hid_iap_user.c:157
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:251
iap_jump
void iap_jump(void)
Definition: app_led3_toggle/src/hid_iap_user.c:146
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:238
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:47
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:122
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:114
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:119
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:113
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:116
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:117
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:109
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:120
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:107
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:112
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:131


AT32F413 Firmwary Library: iap.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/iap.c
Go to the documentation of this file.
1
25#include "iap.h"
26#include "usart.h"
27#include "tmr.h"
28
42void iap_command_handle(void)
43{
44 if(iap_flag==IAP_REV_FLAG_DONE)
45 {
46 flash_unlock();
47 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
48 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
49 flash_lock();
50 nvic_system_reset();
51 }
52}
53
59void iap_init(void)
60{
61 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
62 {
63 flash_unlock();
64 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
65 flash_lock();
66 }
67}
68
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:42
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:36
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: app_led3_toggle/inc/iap.h:50
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:50
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: app_led3_toggle/inc/iap.h:54


AT32F413 Firmwary Library: tmr.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/tmr.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "tmr.h"
27#include "iap.h"
28
42void tmr_init(void)
43{
44 crm_clocks_freq_type crm_clocks_freq_struct = {0};
45
46 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
47
48 /* enable the tmr3 global interrupt */
49 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
50
51 /* get system clock */
52 crm_clocks_freq_get(&crm_clocks_freq_struct);
53
54 /* time base configuration */
55 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
56 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
57
58 /* overflow interrupt enable */
59 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
60
61 /* enable tmr */
62 tmr_counter_enable(TMR3, TRUE);
63}
64
70void TMR3_GLOBAL_IRQHandler(void)
71{
72 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
73 {
74 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
75 at32_led_toggle(LED3);
76 }
77}
78
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:37
LED3
@ LED3
Definition: at32f413_board.h:62
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:50
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:72
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: app_led3_toggle/src/tmr.c:70
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:42
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:471


AT32F413 Firmwary Library: usart.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/usart.c
Go to the documentation of this file.
1
25#include "usart.h"
26#include "tmr.h"
27
36uint8_t iap_flag = IAP_REV_FLAG_NO;
37
43void uart_init(uint32_t baudrate)
44{
45 gpio_init_type gpio_init_struct;
46 /* enable the usart and it's io clock */
47 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
48 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
49
50 /* set default parameter */
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the usart1_tx pa9 */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_9;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 /* configure the usart1_rx pa10 */
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
64 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
65 gpio_init_struct.gpio_pins = GPIO_PINS_10;
66 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
67 gpio_init(GPIOA, &gpio_init_struct);
68
69 /*configure usart nvic interrupt */
70 nvic_irq_enable(USART1_IRQn, 0, 0);
71
72 /*configure usart param*/
73 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
74 usart_transmitter_enable(USART1, TRUE);
75 usart_receiver_enable(USART1, TRUE);
76 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
77 usart_enable(USART1, TRUE);
78}
79
85void USART1_IRQHandler(void)
86{
87 uint16_t reval;
88 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
89 {
90 reval = usart_data_receive(USART1);
91 if((reval == 0x5A) && (iap_flag == IAP_REV_FLAG_NO))
92 iap_flag = IAP_REV_FLAG_5A;
93 else if((reval == 0xA5) && (iap_flag == IAP_REV_FLAG_5A))
94 iap_flag = IAP_REV_FLAG_DONE;
95 else
96 iap_flag = IAP_REV_FLAG_NO;
97 }
98}
99
105void back_ok(void)
106{
107 usart_data_transmit(USART1, 0xCC);
108 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
109 usart_data_transmit(USART1, 0xDD);
110 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
111}
112
118void back_err(void)
119{
120 usart_data_transmit(USART1, 0xEE);
121 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
122 usart_data_transmit(USART1, 0xFF);
123 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
124}
125
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:208
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:56
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: app_led3_toggle/src/usart.c:85
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:36
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:118
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:105
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART1
#define USART1
Definition: at32f413_usart.h:317
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:50
IAP_REV_FLAG_NO
#define IAP_REV_FLAG_NO
Definition: app_led3_toggle/inc/usart.h:48
IAP_REV_FLAG_5A
#define IAP_REV_FLAG_5A
Definition: app_led3_toggle/inc/usart.h:49
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287


AT32F413 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/hid_iap_user.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __HID_IAP_USER_H
27#define __HID_IAP_USER_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "hid_iap_class.h"
34
47#define FLASH_APP_ADDRESS 0x08006000
48
57void iap_init(void);
58 iap_result_type iap_get_upgrade_flag(void);
59void app_loop(void);
60
73#ifdef __cplusplus
74}
75#endif
76
77#endif
78
iap_result_type
iap_result_type
Definition: hid_iap_class.h:84
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:251
hid_iap_class.h
usb hid iap header file


AT32F413 Firmwary Library: iap.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/iap.h
Go to the documentation of this file.
1
25#ifndef __IAP_H__
26#define __IAP_H__
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
46/* app starting address */
47#define APP_START_ADDR 0x08004000
48
49/* the previous sector of app starting address is iap upgrade flag */
50#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
51
52/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
53indicates that an app upgrade will follow, see iap application note for more details */
54#define IAP_UPGRADE_FLAG 0x41544B38
55
64void iap_command_handle(void);
65void iap_init(void);
66
79#ifdef __cplusplus
80}
81#endif
82
83#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:42


AT32F413 Firmwary Library: tmr.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/tmr.h
Go to the documentation of this file.
1
25#ifndef __TMR_H
26#define __TMR_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
46void tmr_init(void);
47
60#ifdef __cplusplus
61}
62#endif
63
64#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:42


AT32F413 Firmwary Library: usart.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/usart.h
Go to the documentation of this file.
1
25#ifndef __USART_H
26#define __USART_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
34extern uint8_t iap_flag;
35
48#define IAP_REV_FLAG_NO 0
49#define IAP_REV_FLAG_5A 1
50#define IAP_REV_FLAG_DONE 2
51#define IAP_REV_FLAG_ERROR 3
52
61void uart_init(uint32_t baudrate);
62void back_ok(void);
63void back_err(void);
64
77#ifdef __cplusplus
78}
79#endif
80
81#endif
82
83
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:36
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:118
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:105


AT32F413 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/hid_iap_user.c
Go to the documentation of this file.
1
25#include "hid_iap_user.h"
26#include "hid_iap_class.h"
27#include "string.h"
28
37void (*pftarget)(void);
38void iap_clear_upgrade_flag(void);
39void iap_set_upgrade_flag(void);
40uint32_t crc_cal(uint32_t addr, uint16_t nk);
41
42void iap_idle(void);
43void iap_start(void);
44void iap_finish(void);
45void iap_jump(void);
46void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
47
53void iap_clear_upgrade_flag(void)
54{
55 flash_unlock();
56 flash_sector_erase(iap_info.flag_address);
57 flash_lock();
58}
59
65void iap_set_upgrade_flag(void)
66{
67 flash_unlock();
68 flash_word_program(iap_info.flag_address, IAP_UPGRADE_COMPLETE_FLAG);
69 flash_lock();
70}
71
77 iap_result_type iap_get_upgrade_flag(void)
78{
79 uint32_t flag_address = iap_info.flag_address;
80 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
81 {
82 return IAP_SUCCESS;
83 }
84 else
85 {
86 return IAP_FAILED;
87 }
88}
89
95void iap_init(void)
96{
97 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
98 if(iap_info.flash_size < KB_TO_B(256))
99 {
100 iap_info.sector_size = SECTOR_SIZE_1K;
101 }
102 else
103 {
104 iap_info.sector_size = SECTOR_SIZE_2K;
105 }
106
107 iap_info.flash_start_address = FLASH_BASE;
108 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
109
110 iap_info.app_address = FLASH_APP_ADDRESS;
111 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
112
113 iap_info.fifo_length = 0;
114 iap_info.iap_address = 0;
115}
116
122void iap_idle(void)
123{
124 iap_info.state = IAP_STS_JMP_WAIT;
125 iap_init();
126 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
127}
128
134void iap_start(void)
135{
136 iap_info.state = IAP_STS_START;
137 iap_init();
138 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
139}
140
141/*
142 * @brief iap jump
143 * @param none
144 * @retval none
145 */
146void iap_jump()
147{
148 iap_info.state = IAP_STS_JMP_WAIT;
149 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
150}
151
152/*
153 * @brief iap get
154 * @param none
155 * @retval none
156 */
157void iap_get()
158{
159 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
160 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
161 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
162 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
163 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
164}
165
166
167
168/*
169 * @brief iap respond
170 * @param res_buf: data buffer pointer.
171 * @param iap_cmd: iap command
172 * @param result: iap result
173 * @retval the result of the address parse
174 */
175void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
176{
177 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
178 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
179 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
180 res_buf[3] = (uint8_t)((result) & 0xFF);
181
182 iap_info.respond_flag = 1;
183}
184
192 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
193{
194 iap_result_type status = IAP_SUCCESS;
195 uint16_t iap_cmd;
196
197 if(len < 2)
198 {
199 return IAP_FAILED;
200 }
201
202 iap_info.respond_flag = 0;
203
204 iap_cmd = (pdata[0] << 8) | pdata[1];
205
206 switch(iap_cmd)
207 {
208 case IAP_CMD_IDLE:
209 iap_idle();
210 break;
211 case IAP_CMD_START:
212 iap_start();
213 break;
214 case IAP_CMD_JMP:
215 iap_jump();
216 break;
217 case IAP_CMD_GET:
218 iap_get();
219 break;
220 default:
221 status = IAP_FAILED;
222 break;
223 }
224
225 if(iap_info.respond_flag)
226 {
227 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
228 }
229
230 return status;
231}
232
238void usbd_hid_iap_in_complete(void *udev)
239{
240 if(iap_info.state == IAP_STS_JMP_WAIT)
241 {
242 iap_info.state = IAP_STS_JMP;
243 }
244}
245
251void app_loop(void)
252{
253 if(iap_info.state == IAP_STS_JMP)
254 {
255 iap_clear_upgrade_flag();
256 nvic_system_reset();
257 }
258}
259
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:66
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:73
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:59
iap_result_type
iap_result_type
Definition: hid_iap_class.h:84
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:80
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:60
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:76
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:56
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:67
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:72
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:57
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:87
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:85
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:93
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:99
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:98
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:52
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:319
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: app_led4_toggle/src/hid_iap_user.c:65
iap_idle
void iap_idle(void)
iap idle function
Definition: app_led4_toggle/src/hid_iap_user.c:122
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: app_led4_toggle/src/hid_iap_user.c:175
iap_init
void iap_init(void)
iap init
Definition: app_led4_toggle/src/hid_iap_user.c:95
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: app_led4_toggle/src/hid_iap_user.c:192
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:153
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led4_toggle/src/hid_iap_user.c:77
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:313
iap_start
void iap_start(void)
iap start function
Definition: app_led4_toggle/src/hid_iap_user.c:134
pftarget
void(* pftarget)(void)
Definition: app_led4_toggle/src/hid_iap_user.c:37
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: app_led4_toggle/src/hid_iap_user.c:53
iap_get
void iap_get()
Definition: app_led4_toggle/src/hid_iap_user.c:157
app_loop
void app_loop(void)
iap loop
Definition: app_led4_toggle/src/hid_iap_user.c:251
iap_jump
void iap_jump(void)
Definition: app_led4_toggle/src/hid_iap_user.c:146
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led4_toggle/src/hid_iap_user.c:238
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:47
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:122
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:114
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:119
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:113
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:116
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:117
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:109
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:120
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:107
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:112
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:131


AT32F413 Firmwary Library: iap.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/iap.c
Go to the documentation of this file.
1
25#include "iap.h"
26#include "usart.h"
27#include "tmr.h"
28
42void iap_command_handle(void)
43{
44 if(iap_flag==IAP_REV_FLAG_DONE)
45 {
46 flash_unlock();
47 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
48 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
49 flash_lock();
50 nvic_system_reset();
51 }
52}
53
59void iap_init(void)
60{
61 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
62 {
63 flash_unlock();
64 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
65 flash_lock();
66 }
67}
68
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:36
iap_init
void iap_init(void)
iap init.
Definition: app_led4_toggle/src/iap.c:59
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led4_toggle/src/iap.c:42
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: app_led3_toggle/inc/iap.h:50
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:50
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: app_led3_toggle/inc/iap.h:54


AT32F413 Firmwary Library: tmr.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/tmr.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "tmr.h"
27#include "iap.h"
28
42void tmr_init(void)
43{
44 crm_clocks_freq_type crm_clocks_freq_struct = {0};
45
46 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
47
48 /* enable the tmr3 global interrupt */
49 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
50
51 /* get system clock */
52 crm_clocks_freq_get(&crm_clocks_freq_struct);
53
54 /* time base configuration */
55 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
56 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
57
58 /* overflow interrupt enable */
59 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
60
61 /* enable tmr */
62 tmr_counter_enable(TMR3, TRUE);
63}
64
70void TMR3_GLOBAL_IRQHandler(void)
71{
72 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
73 {
74 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
75 at32_led_toggle(LED4);
76 }
77}
78
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:37
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:50
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:72
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: app_led4_toggle/src/tmr.c:70
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led4_toggle/src/tmr.c:42
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:471


AT32F413 Firmwary Library: usart.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/usart.c
Go to the documentation of this file.
1
25#include "usart.h"
26#include "tmr.h"
27
36uint8_t iap_flag = IAP_REV_FLAG_NO;
37
43void uart_init(uint32_t baudrate)
44{
45 gpio_init_type gpio_init_struct;
46 /* enable the usart and it's io clock */
47 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
48 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
49
50 /* set default parameter */
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the usart1_tx pa9 */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_9;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 /* configure the usart1_rx pa10 */
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
64 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
65 gpio_init_struct.gpio_pins = GPIO_PINS_10;
66 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
67 gpio_init(GPIOA, &gpio_init_struct);
68
69 /*configure usart nvic interrupt */
70 nvic_irq_enable(USART1_IRQn, 0, 0);
71
72 /*configure usart param*/
73 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
74 usart_transmitter_enable(USART1, TRUE);
75 usart_receiver_enable(USART1, TRUE);
76 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
77 usart_enable(USART1, TRUE);
78}
79
85void USART1_IRQHandler(void)
86{
87 uint16_t reval;
88 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
89 {
90 reval = usart_data_receive(USART1);
91 if((reval == 0x5A) && (iap_flag == IAP_REV_FLAG_NO))
92 iap_flag = IAP_REV_FLAG_5A;
93 else if((reval == 0xA5) && (iap_flag == IAP_REV_FLAG_5A))
94 iap_flag = IAP_REV_FLAG_DONE;
95 else
96 iap_flag = IAP_REV_FLAG_NO;
97 }
98}
99
105void back_ok(void)
106{
107 usart_data_transmit(USART1, 0xCC);
108 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
109 usart_data_transmit(USART1, 0xDD);
110 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
111}
112
118void back_err(void)
119{
120 usart_data_transmit(USART1, 0xEE);
121 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
122 usart_data_transmit(USART1, 0xFF);
123 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
124}
125
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:208
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:56
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: app_led4_toggle/src/usart.c:85
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led4_toggle/src/usart.c:43
iap_flag
uint8_t iap_flag
Definition: app_led4_toggle/src/usart.c:36
back_err
void back_err(void)
command response error.
Definition: app_led4_toggle/src/usart.c:118
back_ok
void back_ok(void)
command response ok.
Definition: app_led4_toggle/src/usart.c:105
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART1
#define USART1
Definition: at32f413_usart.h:317
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:50
IAP_REV_FLAG_NO
#define IAP_REV_FLAG_NO
Definition: app_led3_toggle/inc/usart.h:48
IAP_REV_FLAG_5A
#define IAP_REV_FLAG_5A
Definition: app_led3_toggle/inc/usart.h:49
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287


AT32F413 Firmwary Library: arm_fir_init_f32.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
arm_fir_init_f32.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Project: CMSIS DSP Library
3 * Title: arm_fir_init_f32.c
4 * Description: Floating-point FIR filter initialization function
5 *
6 * $Date: 18. March 2019
7 * $Revision: V1.6.0
8 *
9 * Target Processor: Cortex-M cores
10 * -------------------------------------------------------------------- */
11/*
12 * Copyright (C) 2010-2019 ARM Limited or its affiliates. All rights reserved.
13 *
14 * SPDX-License-Identifier: Apache-2.0
15 *
16 * Licensed under the Apache License, Version 2.0 (the License); you may
17 * not use this file except in compliance with the License.
18 * You may obtain a copy of the License at
19 *
20 * www.apache.org/licenses/LICENSE-2.0
21 *
22 * Unless required by applicable law or agreed to in writing, software
23 * distributed under the License is distributed on an AS IS BASIS, WITHOUT
24 * WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
25 * See the License for the specific language governing permissions and
26 * limitations under the License.
27 */
28
29#include "arm_math.h"
30
31void* my_memset(void *s, int c, size_t n);
32
59void arm_fir_init_f32(
60 arm_fir_instance_f32 * S,
61 uint16_t numTaps,
62 const float32_t * pCoeffs,
63 float32_t * pState,
64 uint32_t blockSize)
65{
66 /* Assign filter taps */
67 S->numTaps = numTaps;
68
69 /* Assign coefficient pointer */
70 S->pCoeffs = pCoeffs;
71
72 /* Clear state buffer. The size is always (blockSize + numTaps - 1) */
73 my_memset(pState, 0, (numTaps + (blockSize - 1u)) * sizeof(float32_t));
74
75 /* Assign state pointer */
76 S->pState = pState;
77}
78
79void* my_memset(void *s, int c, size_t n)
80{
81 while (n>0)
82 *( (char*)s + n-- -1 ) = (char)c;
83
84 return (s);
85}
my_memset
void * my_memset(void *s, int c, size_t n)
Definition: arm_fir_init_f32.c:79
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F413 Firmwary Library: at32f413.h Source File

  • libraries
  • cmsis
  • cm4
  • device_support
at32f413.h
Go to the documentation of this file.
1
25#ifndef __AT32F413_H
26#define __AT32F413_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#if defined (__CC_ARM)
33 #pragma anon_unions
34#endif
35
53#if !defined (AT32F413KBU7_4) && !defined (AT32F413KCU7_4) && !defined (AT32F413CBU7) && \
54 !defined (AT32F413CCU7) && !defined (AT32F413C8T7) && !defined (AT32F413CBT7) && \
55 !defined (AT32F413CCT7) && !defined (AT32F413RBT7) && !defined (AT32F413RCT7) && \
56 !defined (AT32FEBKC8T7) && !defined (AT32F413TBU7)
57
58 #error "Please select first the target device used in your application (in at32f413.h file)"
59#endif
60
61#if defined (AT32F413KBU7_4) || defined (AT32F413KCU7_4) || defined (AT32F413CBU7) || \
62 defined (AT32F413CCU7) || defined (AT32F413C8T7) || defined (AT32F413CBT7) || \
63 defined (AT32F413CCT7) || defined (AT32F413RBT7) || defined (AT32F413RCT7) || \
64 defined (AT32FEBKC8T7) || defined (AT32F413TBU7)
65
66 #define AT32F413xx
67#endif
68
72#if defined (AT32F413RBT7) || defined (AT32F413RCT7)
73
74 #define AT32F413Rx
75#endif
76
77#if defined (AT32F413CBU7) || defined (AT32F413CCU7) || defined (AT32F413C8T7) || \
78 defined (AT32F413CBT7) || defined (AT32F413CCT7)
79
80 #define AT32F413Cx
81#endif
82
83#if defined (AT32F413KBU7_4) || defined (AT32F413KCU7_4)
84
85 #define AT32F413Kx
86#endif
87
91#if defined (AT32F413C8T7) || defined (AT32FEBKC8T7)
92
93 #define AT32F413x8
94#endif
95
96#if defined (AT32F413KBU7_4) || defined (AT32F413CBU7) || defined (AT32F413CBT7) || \
97 defined (AT32F413RBT7) || defined (AT32F413TBU7)
98
99 #define AT32F413xB
100#endif
101
102#if defined (AT32F413KCU7_4) || defined (AT32F413CCU7) || defined (AT32F413CCT7) || \
103 defined (AT32F413RCT7)
104
105 #define AT32F413xC
106#endif
107
108#ifndef USE_STDPERIPH_DRIVER
114 #ifdef _RTE_
115 #include "RTE_Components.h"
116 #ifdef RTE_DEVICE_STDPERIPH_FRAMEWORK
117 #define USE_STDPERIPH_DRIVER
118 #endif
119 #endif
120#endif
121
125#define __AT32F413_LIBRARY_VERSION_MAJOR (0x02)
126#define __AT32F413_LIBRARY_VERSION_MIDDLE (0x01)
127#define __AT32F413_LIBRARY_VERSION_MINOR (0x00)
128#define __AT32F413_LIBRARY_VERSION_RC (0x00)
129#define __AT32F413_LIBRARY_VERSION ((__AT32F413_LIBRARY_VERSION_MAJOR << 24) | \
130 (__AT32F413_LIBRARY_VERSION_MIDDLE << 16) | \
131 (__AT32F413_LIBRARY_VERSION_MINOR << 8) | \
132 (__AT32F413_LIBRARY_VERSION_RC))
133
145#define __CM4_REV 0x0001U
146#define __MPU_PRESENT 1
147#define __NVIC_PRIO_BITS 4
148#define __Vendor_SysTickConfig 0
149#define __FPU_PRESENT 1U
155typedef enum IRQn
156{
157 /****** cortex-m4 processor exceptions numbers ***************************************************/
158 Reset_IRQn = -15,
159 NonMaskableInt_IRQn = -14,
160 HardFault_IRQn = -13,
161 MemoryManagement_IRQn = -12,
162 BusFault_IRQn = -11,
163 UsageFault_IRQn = -10,
164 SVCall_IRQn = -5,
165 DebugMonitor_IRQn = -4,
166 PendSV_IRQn = -2,
167 SysTick_IRQn = -1,
169 /****** at32 specific interrupt numbers *********************************************************/
170 WWDT_IRQn = 0,
171 PVM_IRQn = 1,
172 TAMPER_IRQn = 2,
173 RTC_IRQn = 3,
174 FLASH_IRQn = 4,
175 CRM_IRQn = 5,
176 EXINT0_IRQn = 6,
177 EXINT1_IRQn = 7,
178 EXINT2_IRQn = 8,
179 EXINT3_IRQn = 9,
180 EXINT4_IRQn = 10,
181 DMA1_Channel1_IRQn = 11,
182 DMA1_Channel2_IRQn = 12,
183 DMA1_Channel3_IRQn = 13,
184 DMA1_Channel4_IRQn = 14,
185 DMA1_Channel5_IRQn = 15,
186 DMA1_Channel6_IRQn = 16,
187 DMA1_Channel7_IRQn = 17,
189 ADC1_2_IRQn = 18,
190 USBFS_H_CAN1_TX_IRQn = 19,
191 USBFS_L_CAN1_RX0_IRQn = 20,
192 CAN1_RX1_IRQn = 21,
193 CAN1_SE_IRQn = 22,
194 EXINT9_5_IRQn = 23,
195 TMR1_BRK_TMR9_IRQn = 24,
196 TMR1_OVF_TMR10_IRQn = 25,
197 TMR1_TRG_HALL_TMR11_IRQn = 26,
198 TMR1_CH_IRQn = 27,
199 TMR2_GLOBAL_IRQn = 28,
200 TMR3_GLOBAL_IRQn = 29,
201 TMR4_GLOBAL_IRQn = 30,
202 I2C1_EVT_IRQn = 31,
203 I2C1_ERR_IRQn = 32,
204 I2C2_EVT_IRQn = 33,
205 I2C2_ERR_IRQn = 34,
206 SPI1_IRQn = 35,
207 SPI2_IRQn = 36,
208 USART1_IRQn = 37,
209 USART2_IRQn = 38,
210 USART3_IRQn = 39,
211 EXINT15_10_IRQn = 40,
212 RTCAlarm_IRQn = 41,
213 USBFSWakeUp_IRQn = 42,
214 TMR8_BRK_IRQn = 43,
215 TMR8_OVF_IRQn = 44,
216 TMR8_TRG_HALL_IRQn = 45,
217 TMR8_CH_IRQn = 46,
218 SDIO1_IRQn = 49,
219 TMR5_GLOBAL_IRQn = 50,
220 UART4_IRQn = 52,
221 UART5_IRQn = 53,
222 DMA2_Channel1_IRQn = 56,
223 DMA2_Channel2_IRQn = 57,
224 DMA2_Channel3_IRQn = 58,
225 DMA2_Channel4_5_IRQn = 59,
226 CAN2_TX_IRQn = 68,
227 CAN2_RX0_IRQn = 69,
228 CAN2_RX1_IRQn = 70,
229 CAN2_SE_IRQn = 71,
230 ACC_IRQn = 72,
231 USBFS_MAPH_IRQn = 73,
232 USBFS_MAPL_IRQn = 74,
233 DMA2_Channel6_7_IRQn = 75,
235} IRQn_Type;
236
241#include "core_cm4.h"
242#include "system_at32f413.h"
243#include <stdint.h>
244
249typedef int32_t INT32;
250typedef int16_t INT16;
251typedef int8_t INT8;
252typedef uint32_t UINT32;
253typedef uint16_t UINT16;
254typedef uint8_t UINT8;
255
256typedef int32_t s32;
257typedef int16_t s16;
258typedef int8_t s8;
259
260typedef const int32_t sc32;
261typedef const int16_t sc16;
262typedef const int8_t sc8;
264typedef __IO int32_t vs32;
265typedef __IO int16_t vs16;
266typedef __IO int8_t vs8;
267
268typedef __I int32_t vsc32;
269typedef __I int16_t vsc16;
270typedef __I int8_t vsc8;
272typedef uint32_t u32;
273typedef uint16_t u16;
274typedef uint8_t u8;
275
276typedef const uint32_t uc32;
277typedef const uint16_t uc16;
278typedef const uint8_t uc8;
280typedef __IO uint32_t vu32;
281typedef __IO uint16_t vu16;
282typedef __IO uint8_t vu8;
283
284typedef __I uint32_t vuc32;
285typedef __I uint16_t vuc16;
286typedef __I uint8_t vuc8;
291typedef enum {RESET = 0, SET = !RESET} flag_status;
292
296typedef enum {FALSE = 0, TRUE = !FALSE} confirm_state;
297
301typedef enum {ERROR = 0, SUCCESS = !ERROR} error_status;
302
311#define REG8(addr) *(volatile uint8_t *)(addr)
312#define REG16(addr) *(volatile uint16_t *)(addr)
313#define REG32(addr) *(volatile uint32_t *)(addr)
314
315#define MAKE_VALUE(reg_offset, bit_num) (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))
316
317#define PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
318#define PERIPH_REG_BIT(value) (0x1U << (value & 0x1F))
319
328#define FLASH_BASE ((uint32_t)0x08000000)
329#define SPIM_FLASH_BASE ((uint32_t)0x08400000)
330#define USD_BASE ((uint32_t)0x1FFFF800)
331#define SRAM_BASE ((uint32_t)0x20000000)
332#define PERIPH_BASE ((uint32_t)0x40000000)
333#define XMC_REG_BASE ((uint32_t)0xA0000000)
334#define DEBUG_BASE ((uint32_t)0xE0042000)
335
336#define APB1PERIPH_BASE (PERIPH_BASE + 0x00000)
337#define APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
338#define AHBPERIPH_BASE (PERIPH_BASE + 0x20000)
339
340/* apb1 bus base address */
341#define TMR2_BASE (APB1PERIPH_BASE + 0x0000)
342#define TMR3_BASE (APB1PERIPH_BASE + 0x0400)
343#define TMR4_BASE (APB1PERIPH_BASE + 0x0800)
344#define TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
345#define RTC_BASE (APB1PERIPH_BASE + 0x2800)
346#define WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
347#define WDT_BASE (APB1PERIPH_BASE + 0x3000)
348#define SPI2_BASE (APB1PERIPH_BASE + 0x3800)
349#define USART2_BASE (APB1PERIPH_BASE + 0x4400)
350#define USART3_BASE (APB1PERIPH_BASE + 0x4800)
351#define UART4_BASE (APB1PERIPH_BASE + 0x4C00)
352#define UART5_BASE (APB1PERIPH_BASE + 0x5000)
353#define I2C1_BASE (APB1PERIPH_BASE + 0x5400)
354#define I2C2_BASE (APB1PERIPH_BASE + 0x5800)
355#define USBFS_BASE (APB1PERIPH_BASE + 0x5C00)
356#define CAN1_BASE (APB1PERIPH_BASE + 0x6400)
357#define CAN2_BASE (APB1PERIPH_BASE + 0x6800)
358#define BPR_BASE (APB1PERIPH_BASE + 0x6C00)
359#define PWC_BASE (APB1PERIPH_BASE + 0x7000)
360/* apb2 bus base address */
361#define IOMUX_BASE (APB2PERIPH_BASE + 0x0000)
362#define EXINT_BASE (APB2PERIPH_BASE + 0x0400)
363#define GPIOA_BASE (APB2PERIPH_BASE + 0x0800)
364#define GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)
365#define GPIOC_BASE (APB2PERIPH_BASE + 0x1000)
366#define GPIOD_BASE (APB2PERIPH_BASE + 0x1400)
367#define GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)
368#define ADC1_BASE (APB2PERIPH_BASE + 0x2400)
369#define ADC2_BASE (APB2PERIPH_BASE + 0x2800)
370#define TMR1_BASE (APB2PERIPH_BASE + 0x2C00)
371#define SPI1_BASE (APB2PERIPH_BASE + 0x3000)
372#define TMR8_BASE (APB2PERIPH_BASE + 0x3400)
373#define USART1_BASE (APB2PERIPH_BASE + 0x3800)
374#define TMR9_BASE (APB2PERIPH_BASE + 0x4C00)
375#define TMR10_BASE (APB2PERIPH_BASE + 0x5000)
376#define TMR11_BASE (APB2PERIPH_BASE + 0x5400)
377#define ACC_BASE (APB2PERIPH_BASE + 0x5800)
378#define SDIO1_BASE (APB2PERIPH_BASE + 0x8000)
379/* ahb bus base address */
380#define DMA1_BASE (AHBPERIPH_BASE + 0x0000)
381#define DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)
382#define DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)
383#define DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)
384#define DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)
385#define DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)
386#define DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)
387#define DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)
388#define DMA2_BASE (AHBPERIPH_BASE + 0x0400)
389#define DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)
390#define DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)
391#define DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)
392#define DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)
393#define DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)
394#define DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)
395#define DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)
396#define CRM_BASE (AHBPERIPH_BASE + 0x1000)
397#define FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)
398#define CRC_BASE (AHBPERIPH_BASE + 0x3000)
399
412#include "at32f413_def.h"
413#include "at32f413_conf.h"
414
415#ifdef __cplusplus
416}
417#endif
418
419#endif
at32f413_def.h
at32f413 macros header file
IRQn_Type
enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
IRQn
IRQn
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
Definition: at32f413.h:156
PendSV_IRQn
@ PendSV_IRQn
Definition: at32f413.h:166
TMR1_BRK_TMR9_IRQn
@ TMR1_BRK_TMR9_IRQn
Definition: at32f413.h:195
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:189
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f413.h:182
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:196
TAMPER_IRQn
@ TAMPER_IRQn
Definition: at32f413.h:172
TMR8_CH_IRQn
@ TMR8_CH_IRQn
Definition: at32f413.h:217
MemoryManagement_IRQn
@ MemoryManagement_IRQn
Definition: at32f413.h:161
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:183
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:209
DMA2_Channel6_7_IRQn
@ DMA2_Channel6_7_IRQn
Definition: at32f413.h:233
CAN2_SE_IRQn
@ CAN2_SE_IRQn
Definition: at32f413.h:229
TMR8_TRG_HALL_IRQn
@ TMR8_TRG_HALL_IRQn
Definition: at32f413.h:216
I2C1_ERR_IRQn
@ I2C1_ERR_IRQn
Definition: at32f413.h:203
SVCall_IRQn
@ SVCall_IRQn
Definition: at32f413.h:164
I2C1_EVT_IRQn
@ I2C1_EVT_IRQn
Definition: at32f413.h:202
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:207
Reset_IRQn
@ Reset_IRQn
Definition: at32f413.h:158
RTCAlarm_IRQn
@ RTCAlarm_IRQn
Definition: at32f413.h:212
DMA1_Channel7_IRQn
@ DMA1_Channel7_IRQn
Definition: at32f413.h:187
UsageFault_IRQn
@ UsageFault_IRQn
Definition: at32f413.h:163
SysTick_IRQn
@ SysTick_IRQn
Definition: at32f413.h:167
EXINT9_5_IRQn
@ EXINT9_5_IRQn
Definition: at32f413.h:194
EXINT1_IRQn
@ EXINT1_IRQn
Definition: at32f413.h:177
CAN2_RX0_IRQn
@ CAN2_RX0_IRQn
Definition: at32f413.h:227
BusFault_IRQn
@ BusFault_IRQn
Definition: at32f413.h:162
WWDT_IRQn
@ WWDT_IRQn
Definition: at32f413.h:170
TMR4_GLOBAL_IRQn
@ TMR4_GLOBAL_IRQn
Definition: at32f413.h:201
USBFS_MAPL_IRQn
@ USBFS_MAPL_IRQn
Definition: at32f413.h:232
USBFSWakeUp_IRQn
@ USBFSWakeUp_IRQn
Definition: at32f413.h:213
DebugMonitor_IRQn
@ DebugMonitor_IRQn
Definition: at32f413.h:165
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:176
FLASH_IRQn
@ FLASH_IRQn
Definition: at32f413.h:174
CRM_IRQn
@ CRM_IRQn
Definition: at32f413.h:175
PVM_IRQn
@ PVM_IRQn
Definition: at32f413.h:171
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f413.h:218
TMR5_GLOBAL_IRQn
@ TMR5_GLOBAL_IRQn
Definition: at32f413.h:219
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
EXINT3_IRQn
@ EXINT3_IRQn
Definition: at32f413.h:179
DMA1_Channel6_IRQn
@ DMA1_Channel6_IRQn
Definition: at32f413.h:186
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:206
HardFault_IRQn
@ HardFault_IRQn
Definition: at32f413.h:160
CAN2_RX1_IRQn
@ CAN2_RX1_IRQn
Definition: at32f413.h:228
USBFS_H_CAN1_TX_IRQn
@ USBFS_H_CAN1_TX_IRQn
Definition: at32f413.h:190
EXINT15_10_IRQn
@ EXINT15_10_IRQn
Definition: at32f413.h:211
DMA2_Channel1_IRQn
@ DMA2_Channel1_IRQn
Definition: at32f413.h:222
DMA1_Channel5_IRQn
@ DMA1_Channel5_IRQn
Definition: at32f413.h:185
UART5_IRQn
@ UART5_IRQn
Definition: at32f413.h:221
DMA2_Channel2_IRQn
@ DMA2_Channel2_IRQn
Definition: at32f413.h:223
TMR1_TRG_HALL_TMR11_IRQn
@ TMR1_TRG_HALL_TMR11_IRQn
Definition: at32f413.h:197
TMR1_CH_IRQn
@ TMR1_CH_IRQn
Definition: at32f413.h:198
USBFS_MAPH_IRQn
@ USBFS_MAPH_IRQn
Definition: at32f413.h:231
EXINT4_IRQn
@ EXINT4_IRQn
Definition: at32f413.h:180
I2C2_ERR_IRQn
@ I2C2_ERR_IRQn
Definition: at32f413.h:205
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:208
TMR8_BRK_IRQn
@ TMR8_BRK_IRQn
Definition: at32f413.h:214
DMA2_Channel3_IRQn
@ DMA2_Channel3_IRQn
Definition: at32f413.h:224
RTC_IRQn
@ RTC_IRQn
Definition: at32f413.h:173
DMA2_Channel4_5_IRQn
@ DMA2_Channel4_5_IRQn
Definition: at32f413.h:225
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:193
NonMaskableInt_IRQn
@ NonMaskableInt_IRQn
Definition: at32f413.h:159
UART4_IRQn
@ UART4_IRQn
Definition: at32f413.h:220
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:184
EXINT2_IRQn
@ EXINT2_IRQn
Definition: at32f413.h:178
TMR8_OVF_IRQn
@ TMR8_OVF_IRQn
Definition: at32f413.h:215
I2C2_EVT_IRQn
@ I2C2_EVT_IRQn
Definition: at32f413.h:204
ACC_IRQn
@ ACC_IRQn
Definition: at32f413.h:230
CAN2_TX_IRQn
@ CAN2_TX_IRQn
Definition: at32f413.h:226
CAN1_RX1_IRQn
@ CAN1_RX1_IRQn
Definition: at32f413.h:192
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:199
USART3_IRQn
@ USART3_IRQn
Definition: at32f413.h:210
vu32
__IO uint32_t vu32
Definition: at32f413.h:280
INT8
int8_t INT8
Definition: at32f413.h:251
vs16
__IO int16_t vs16
Definition: at32f413.h:265
error_status
error_status
error status
Definition: at32f413.h:301
INT32
int32_t INT32
Definition: at32f413.h:249
vuc32
__I uint32_t vuc32
Definition: at32f413.h:284
sc8
const int8_t sc8
Definition: at32f413.h:262
vsc16
__I int16_t vsc16
Definition: at32f413.h:269
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
vsc8
__I int8_t vsc8
Definition: at32f413.h:270
vs32
__IO int32_t vs32
Definition: at32f413.h:264
vu8
__IO uint8_t vu8
Definition: at32f413.h:282
uc32
const uint32_t uc32
Definition: at32f413.h:276
sc16
const int16_t sc16
Definition: at32f413.h:261
vuc16
__I uint16_t vuc16
Definition: at32f413.h:285
flag_status
flag_status
flag status
Definition: at32f413.h:291
u8
uint8_t u8
Definition: at32f413.h:274
vu16
__IO uint16_t vu16
Definition: at32f413.h:281
s8
int8_t s8
Definition: at32f413.h:258
vs8
__IO int8_t vs8
Definition: at32f413.h:266
s16
int16_t s16
Definition: at32f413.h:257
vuc8
__I uint8_t vuc8
Definition: at32f413.h:286
uc16
const uint16_t uc16
Definition: at32f413.h:277
uc8
const uint8_t uc8
Definition: at32f413.h:278
INT16
int16_t INT16
Definition: at32f413.h:250
UINT16
uint16_t UINT16
Definition: at32f413.h:253
u16
uint16_t u16
Definition: at32f413.h:273
sc32
const int32_t sc32
Definition: at32f413.h:260
UINT32
uint32_t UINT32
Definition: at32f413.h:252
s32
int32_t s32
Definition: at32f413.h:256
vsc32
__I int32_t vsc32
Definition: at32f413.h:268
UINT8
uint8_t UINT8
Definition: at32f413.h:254
u32
uint32_t u32
Definition: at32f413.h:272
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
system_at32f413.h
cmsis cortex-m4 system header file.
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_acc.c Source File

  • libraries
  • drivers
  • src
at32f413_acc.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef ACC_MODULE_ENABLED
37
51void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
52{
53 if(acc_trim == ACC_CAL_HICKCAL)
54 {
55 ACC->ctrl1_bit.entrim = FALSE;
56 }
57 else
58 {
59 ACC->ctrl1_bit.entrim = TRUE;
60 }
61 ACC->ctrl1_bit.calon = new_state;
62}
63
69void acc_step_set(uint8_t step_value)
70{
71 ACC->ctrl1_bit.step = step_value;
72}
73
83void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
84{
85 if(acc_int == ACC_CALRDYIEN_INT)
86 {
87 ACC->ctrl1_bit.calrdyien = new_state;
88 }
89 else
90 {
91 ACC->ctrl1_bit.eien = new_state;
92 }
93}
94
100uint8_t acc_hicktrim_get(void)
101{
102 return ((uint8_t)(ACC->ctrl2_bit.hicktrim));
103}
104
110uint8_t acc_hickcal_get(void)
111{
112 return ((uint8_t)(ACC->ctrl2_bit.hickcal));
113}
114
120void acc_write_c1(uint16_t acc_c1_value)
121{
122 ACC->c1 = acc_c1_value;
123}
124
130void acc_write_c2(uint16_t acc_c2_value)
131{
132 ACC->c2 = acc_c2_value;
133}
134
140void acc_write_c3(uint16_t acc_c3_value)
141{
142 ACC->c3 = acc_c3_value;
143}
144
150uint16_t acc_read_c1(void)
151{
152 return ((uint16_t)(ACC->c1));
153}
154
160uint16_t acc_read_c2(void)
161{
162 return ((uint16_t)(ACC->c2));
163}
164
170uint16_t acc_read_c3(void)
171{
172 return ((uint16_t)(ACC->c3));
173}
174
183 flag_status acc_flag_get(uint16_t acc_flag)
184{
185 if(acc_flag == ACC_CALRDY_FLAG)
186 return (flag_status)(ACC->sts_bit.calrdy);
187 else
188 return (flag_status)(ACC->sts_bit.rslost);
189}
190
199void acc_flag_clear(uint16_t acc_flag)
200{
201 ACC->sts = ~acc_flag;
202}
203
208#endif
209
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:58
ACC_CAL_HICKCAL
#define ACC_CAL_HICKCAL
Definition: at32f413_acc.h:50
ACC_CALRDYIEN_INT
#define ACC_CALRDYIEN_INT
Definition: at32f413_acc.h:56
ACC_CALRDY_FLAG
#define ACC_CALRDY_FLAG
Definition: at32f413_acc.h:54
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_step_set
void acc_step_set(uint8_t step_value)
store calibration step data in acc's ctrl1 register.
Definition: at32f413_acc.c:69
acc_read_c2
uint16_t acc_read_c2(void)
return the current acc c2 value.
Definition: at32f413_acc.c:160
acc_hickcal_get
uint8_t acc_hickcal_get(void)
return the current acc hickcal value.
Definition: at32f413_acc.c:110
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f413_acc.c:83
acc_read_c3
uint16_t acc_read_c3(void)
return the current acc c3 value.
Definition: at32f413_acc.c:170
acc_read_c1
uint16_t acc_read_c1(void)
return the current acc c1 value.
Definition: at32f413_acc.c:150
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f413_acc.c:183
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f413_acc.c:199
acc_hicktrim_get
uint8_t acc_hicktrim_get(void)
return the current acc hicktrim value.
Definition: at32f413_acc.c:100
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
ACC
#define ACC
Definition: at32f413_acc.h:164
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_acc.h Source File

  • libraries
  • drivers
  • inc
at32f413_acc.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_ACC_H
27#define __AT32F413_ACC_H
28
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35/* Includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
50#define ACC_CAL_HICKCAL ((uint16_t)0x0000)
51#define ACC_CAL_HICKTRIM ((uint16_t)0x0002)
53#define ACC_RSLOST_FLAG ((uint16_t)0x0002)
54#define ACC_CALRDY_FLAG ((uint16_t)0x0001)
56#define ACC_CALRDYIEN_INT ((uint16_t)0x0020)
57#define ACC_EIEN_INT ((uint16_t)0x0010)
70typedef struct
71{
72
76 union
77 {
78 __IO uint32_t sts;
79 struct
80 {
81 __IO uint32_t calrdy : 1; /* [0] */
82 __IO uint32_t rslost : 1; /* [1] */
83 __IO uint32_t reserved1 : 30;/* [31:2] */
84 } sts_bit;
85 };
86
90 union
91 {
92 __IO uint32_t ctrl1;
93 struct
94 {
95 __IO uint32_t calon : 1; /* [0] */
96 __IO uint32_t entrim : 1; /* [1] */
97 __IO uint32_t reserved1 : 2; /* [3:2] */
98 __IO uint32_t eien : 1; /* [4] */
99 __IO uint32_t calrdyien : 1; /* [5] */
100 __IO uint32_t reserved2 : 2; /* [7:6] */
101 __IO uint32_t step : 4; /* [11:8] */
102 __IO uint32_t reserved3 : 20;/* [31:12] */
103 } ctrl1_bit;
104 };
105
109 union
110 {
111 __IO uint32_t ctrl2;
112 struct
113 {
114 __IO uint32_t hickcal : 8; /* [7:0] */
115 __IO uint32_t hicktrim : 6; /* [13:8] */
116 __IO uint32_t reserved1 : 18;/* [31:14] */
117 } ctrl2_bit;
118 };
119
123 union
124 {
125 __IO uint32_t c1;
126 struct
127 {
128 __IO uint32_t c1 : 16;/* [15:0] */
129 __IO uint32_t reserved1 : 16;/* [31:16] */
130 } c1_bit;
131 };
132
136 union
137 {
138 __IO uint32_t c2;
139 struct
140 {
141 __IO uint32_t c2 : 16;/* [15:0] */
142 __IO uint32_t reserved1 : 16;/* [31:16] */
143 } c2_bit;
144 };
145
149 union
150 {
151 __IO uint32_t c3;
152 struct
153 {
154 __IO uint32_t c3 : 16;/* [15:0] */
155 __IO uint32_t reserved1 : 16;/* [31:16] */
156 } c3_bit;
157 };
158} acc_type;
159
164#define ACC ((acc_type *) ACC_BASE)
165
170void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state);
171void acc_step_set(uint8_t step_value);
172void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state);
173uint8_t acc_hicktrim_get(void);
174uint8_t acc_hickcal_get(void);
175void acc_write_c1(uint16_t acc_c1_value);
176void acc_write_c2(uint16_t acc_c2_value);
177void acc_write_c3(uint16_t acc_c3_value);
178uint16_t acc_read_c1(void);
179uint16_t acc_read_c2(void);
180uint16_t acc_read_c3(void);
181 flag_status acc_flag_get(uint16_t acc_flag);
182void acc_flag_clear(uint16_t acc_flag);
183
196#ifdef __cplusplus
197}
198#endif
199
200#endif
at32f413.h
at32f413 header file
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:58
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_step_set
void acc_step_set(uint8_t step_value)
store calibration step data in acc's ctrl1 register.
Definition: at32f413_acc.c:69
acc_read_c2
uint16_t acc_read_c2(void)
return the current acc c2 value.
Definition: at32f413_acc.c:160
acc_hickcal_get
uint8_t acc_hickcal_get(void)
return the current acc hickcal value.
Definition: at32f413_acc.c:110
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f413_acc.c:83
acc_read_c3
uint16_t acc_read_c3(void)
return the current acc c3 value.
Definition: at32f413_acc.c:170
acc_read_c1
uint16_t acc_read_c1(void)
return the current acc c1 value.
Definition: at32f413_acc.c:150
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f413_acc.c:183
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f413_acc.c:199
acc_hicktrim_get
uint8_t acc_hicktrim_get(void)
return the current acc hicktrim value.
Definition: at32f413_acc.c:100
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
acc_type
type define acc register all
Definition: at32f413_acc.h:71
acc_type::entrim
__IO uint32_t entrim
Definition: at32f413_acc.h:96
acc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_acc.h:92
acc_type::hicktrim
__IO uint32_t hicktrim
Definition: at32f413_acc.h:115
acc_type::c2
__IO uint32_t c2
Definition: at32f413_acc.h:138
acc_type::rslost
__IO uint32_t rslost
Definition: at32f413_acc.h:82
acc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_acc.h:100
acc_type::c3
__IO uint32_t c3
Definition: at32f413_acc.h:151
acc_type::calrdyien
__IO uint32_t calrdyien
Definition: at32f413_acc.h:99
acc_type::calon
__IO uint32_t calon
Definition: at32f413_acc.h:95
acc_type::eien
__IO uint32_t eien
Definition: at32f413_acc.h:98
acc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_acc.h:83
acc_type::sts
__IO uint32_t sts
Definition: at32f413_acc.h:78
acc_type::hickcal
__IO uint32_t hickcal
Definition: at32f413_acc.h:114
acc_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_acc.h:111
acc_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_acc.h:102
acc_type::c1
__IO uint32_t c1
Definition: at32f413_acc.h:125
acc_type::calrdy
__IO uint32_t calrdy
Definition: at32f413_acc.h:81
acc_type::step
__IO uint32_t step
Definition: at32f413_acc.h:101


AT32F413 Firmwary Library: at32f413_adc.c Source File

  • libraries
  • drivers
  • src
at32f413_adc.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef ADC_MODULE_ENABLED
37
49void adc_reset(adc_type *adc_x)
50{
51 if(adc_x == ADC1)
52 {
53 crm_periph_reset(CRM_ADC1_PERIPH_RESET, TRUE);
54 crm_periph_reset(CRM_ADC1_PERIPH_RESET, FALSE);
55 }
56 else if(adc_x == ADC2)
57 {
58 crm_periph_reset(CRM_ADC2_PERIPH_RESET, TRUE);
59 crm_periph_reset(CRM_ADC2_PERIPH_RESET, FALSE);
60 }
61}
62
73void adc_enable(adc_type *adc_x, confirm_state new_state)
74{
75 adc_x->ctrl2_bit.adcen = new_state;
76}
77
95void adc_combine_mode_select(adc_combine_mode_type combine_mode)
96{
97 ADC1->ctrl1_bit.mssel = combine_mode;
98}
99
115void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
116{
117 adc_base_struct->sequence_mode = FALSE;
118 adc_base_struct->repeat_mode = FALSE;
119 adc_base_struct->data_align = ADC_RIGHT_ALIGNMENT;
120 adc_base_struct->ordinary_channel_length = 1;
121}
122
141void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
142{
143 adc_x->ctrl1_bit.sqen = adc_base_struct->sequence_mode;
144 adc_x->ctrl2_bit.rpen = adc_base_struct->repeat_mode;
145 adc_x->ctrl2_bit.dtalign = adc_base_struct->data_align;
146 adc_x->osq1_bit.oclen = adc_base_struct->ordinary_channel_length - 1;
147}
148
159void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
160{
161 adc_x->ctrl2_bit.ocdmaen = new_state;
162}
163
178void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
179{
180 if(new_state == TRUE)
181 {
182 adc_x->ctrl1 |= adc_int;
183 }
184 else if(new_state == FALSE)
185 {
186 adc_x->ctrl1 &= ~adc_int;
187 }
188}
189
197void adc_calibration_init(adc_type *adc_x)
198{
199 adc_x->ctrl2_bit.adcalinit = TRUE;
200}
201
209 flag_status adc_calibration_init_status_get(adc_type *adc_x)
210{
211 if(adc_x->ctrl2_bit.adcalinit)
212 {
213 return SET;
214 }
215 else
216 {
217 return RESET;
218 }
219}
220
228void adc_calibration_start(adc_type *adc_x)
229{
230 adc_x->ctrl2_bit.adcal = TRUE;
231}
232
240 flag_status adc_calibration_status_get(adc_type *adc_x)
241{
242 if(adc_x->ctrl2_bit.adcal)
243 {
244 return SET;
245 }
246 else
247 {
248 return RESET;
249 }
250}
251
268void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
269{
270 adc_x->ctrl1_bit.ocvmen = FALSE;
271 adc_x->ctrl1_bit.pcvmen = FALSE;
272 adc_x->ctrl1_bit.vmsgen = FALSE;
273 adc_x->ctrl1 |= adc_voltage_monitoring;
274}
275
289void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
290{
291 adc_x->vmhb_bit.vmhb = adc_high_threshold;
292 adc_x->vmlb_bit.vmlb = adc_low_threshold;
293}
294
309void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
310{
311 adc_x->ctrl1_bit.vmcsel = adc_channel;
312}
313
341void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
342{
343 uint32_t tmp_reg;
344 if(adc_channel < ADC_CHANNEL_10)
345 {
346 tmp_reg = adc_x->spt2;
347 tmp_reg &= ~(0x07 << 3 * adc_channel);
348 tmp_reg |= adc_sampletime << 3 * adc_channel;
349 adc_x->spt2 = tmp_reg;
350 }
351 else
352 {
353 tmp_reg = adc_x->spt1;
354 tmp_reg &= ~(0x07 << 3 * (adc_channel - ADC_CHANNEL_10));
355 tmp_reg |= adc_sampletime << 3 * (adc_channel - ADC_CHANNEL_10);
356 adc_x->spt1 = tmp_reg;
357 }
358
359 if(adc_sequence >= 13)
360 {
361 tmp_reg = adc_x->osq1;
362 tmp_reg &= ~(0x01F << 5 * (adc_sequence - 13));
363 tmp_reg |= adc_channel << 5 * (adc_sequence - 13);
364 adc_x->osq1 = tmp_reg;
365 }
366 else if(adc_sequence >= 7)
367 {
368 tmp_reg = adc_x->osq2;
369 tmp_reg &= ~(0x01F << 5 * (adc_sequence - 7));
370 tmp_reg |= adc_channel << 5 * (adc_sequence - 7);
371 adc_x->osq2 = tmp_reg;
372 }
373 else
374 {
375 tmp_reg = adc_x->osq3;
376 tmp_reg &= ~(0x01F << 5 * (adc_sequence - 1));
377 tmp_reg |= adc_channel << 5 * (adc_sequence - 1);
378 adc_x->osq3 = tmp_reg;
379 }
380}
381
392void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
393{
394 adc_x->psq_bit.pclen = adc_channel_lenght - 1;
395}
396
424void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
425{
426 uint32_t tmp_reg;
427 uint8_t sequence_index;
428 if(adc_channel < ADC_CHANNEL_10)
429 {
430 tmp_reg = adc_x->spt2;
431 tmp_reg &= ~(0x07 << 3 * adc_channel);
432 tmp_reg |= adc_sampletime << 3 * adc_channel;
433 adc_x->spt2 = tmp_reg;
434 }
435 else
436 {
437 tmp_reg = adc_x->spt1;
438 tmp_reg &= ~(0x07 << 3 * (adc_channel - ADC_CHANNEL_10));
439 tmp_reg |= adc_sampletime << 3 * (adc_channel - ADC_CHANNEL_10);
440 adc_x->spt1 = tmp_reg;
441 }
442
443 sequence_index = adc_sequence + 3 - adc_x->psq_bit.pclen;
444 switch(sequence_index)
445 {
446 case 1:
447 adc_x->psq_bit.psn1 = adc_channel;
448 break;
449 case 2:
450 adc_x->psq_bit.psn2 = adc_channel;
451 break;
452 case 3:
453 adc_x->psq_bit.psn3 = adc_channel;
454 break;
455 case 4:
456 adc_x->psq_bit.psn4 = adc_channel;
457 break;
458 default:
459 break;
460 }
461}
462
479void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
480{
481 if(adc_ordinary_trig > 7)
482 {
483 adc_x->ctrl2_bit.octesel_h = 1;
484 adc_x->ctrl2_bit.octesel_l = adc_ordinary_trig & 0x7;
485 }
486 else
487 {
488 adc_x->ctrl2_bit.octesel_h = 0;
489 adc_x->ctrl2_bit.octesel_l = adc_ordinary_trig & 0x7;
490 }
491 adc_x->ctrl2_bit.octen = new_state;
492}
493
510void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
511{
512 if(adc_preempt_trig > 7)
513 {
514 adc_x->ctrl2_bit.pctesel_h = 1;
515 adc_x->ctrl2_bit.pctesel_l = adc_preempt_trig & 0x7;
516 }
517 else
518 {
519 adc_x->ctrl2_bit.pctesel_h = 0;
520 adc_x->ctrl2_bit.pctesel_l = adc_preempt_trig & 0x7;
521 }
522 adc_x->ctrl2_bit.pcten = new_state;
523}
524
525
542void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
543{
544 switch(adc_preempt_channel)
545 {
546 case ADC_PREEMPT_CHANNEL_1:
547 adc_x->pcdto1_bit.pcdto1 = adc_offset_value;
548 break;
549 case ADC_PREEMPT_CHANNEL_2:
550 adc_x->pcdto2_bit.pcdto2 = adc_offset_value;
551 break;
552 case ADC_PREEMPT_CHANNEL_3:
553 adc_x->pcdto3_bit.pcdto3 = adc_offset_value;
554 break;
555 case ADC_PREEMPT_CHANNEL_4:
556 adc_x->pcdto4_bit.pcdto4 = adc_offset_value;
557 break;
558 default:
559 break;
560 }
561}
562
573void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
574{
575
576 adc_x->ctrl1_bit.ocpcnt = adc_channel_count - 1;
577}
578
588void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
589{
590 adc_x->ctrl1_bit.ocpen = new_state;
591}
592
602void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
603{
604 adc_x->ctrl1_bit.pcpen = new_state;
605}
606
616void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
617{
618 adc_x->ctrl1_bit.pcautoen = new_state;
619}
620
628void adc_tempersensor_vintrv_enable(confirm_state new_state)
629{
630 ADC1->ctrl2_bit.itsrven = new_state;
631}
632
642void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
643{
644 adc_x->ctrl2_bit.ocswtrg = new_state;
645}
646
654 flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
655{
656 if(adc_x->ctrl2_bit.ocswtrg)
657 {
658 return SET;
659 }
660 else
661 {
662 return RESET;
663 }
664}
665
675void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
676{
677 adc_x->ctrl2_bit.pcswtrg = new_state;
678}
679
687 flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
688{
689 if(adc_x->ctrl2_bit.pcswtrg)
690 {
691 return SET;
692 }
693 else
694 {
695 return RESET;
696 }
697}
698
706uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
707{
708 return (uint16_t)(adc_x->odt_bit.odt);
709}
710
715uint32_t adc_combine_ordinary_conversion_data_get(void)
716{
717 return (uint32_t)(ADC1->odt);
718}
719
733uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
734{
735 uint16_t preempt_conv_data_index = 0;
736 switch(adc_preempt_channel)
737 {
738 case ADC_PREEMPT_CHANNEL_1:
739 preempt_conv_data_index = (uint16_t)(adc_x->pdt1_bit.pdt1);
740 break;
741 case ADC_PREEMPT_CHANNEL_2:
742 preempt_conv_data_index = (uint16_t)(adc_x->pdt2_bit.pdt2);
743 break;
744 case ADC_PREEMPT_CHANNEL_3:
745 preempt_conv_data_index = (uint16_t)(adc_x->pdt3_bit.pdt3);
746 break;
747 case ADC_PREEMPT_CHANNEL_4:
748 preempt_conv_data_index = (uint16_t)(adc_x->pdt4_bit.pdt4);
749 break;
750 default:
751 break;
752 }
753 return preempt_conv_data_index;
754}
755
770 flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
771{
772 flag_status status = RESET;
773
774 if((adc_x->sts & adc_flag) == RESET)
775 {
776 status = RESET;
777 }
778 else
779 {
780 status = SET;
781 }
782 return status;
783}
784
799void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
800{
801 adc_x->sts = ~adc_flag;
802}
803
808#endif
809
adc_voltage_monitoring_type
adc_voltage_monitoring_type
adc voltage_monitoring type
Definition: at32f413_adc.h:196
adc_channel_select_type
adc_channel_select_type
adc channel select type
Definition: at32f413_adc.h:107
adc_sampletime_select_type
adc_sampletime_select_type
adc sampletime select type
Definition: at32f413_adc.h:132
adc_preempt_trig_select_type
adc_preempt_trig_select_type
adc preempt group trigger event select type
Definition: at32f413_adc.h:166
adc_combine_mode_type
adc_combine_mode_type
adc combine mode type(these options are reserved in adc2)
Definition: at32f413_adc.h:81
adc_ordinary_trig_select_type
adc_ordinary_trig_select_type
adc ordinary group trigger event select type
Definition: at32f413_adc.h:147
adc_preempt_channel_type
adc_preempt_channel_type
adc preempt channel type
Definition: at32f413_adc.h:185
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f413_adc.h:118
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:188
ADC_PREEMPT_CHANNEL_4
@ ADC_PREEMPT_CHANNEL_4
Definition: at32f413_adc.h:189
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:187
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:186
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f413_adc.c:268
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f413_adc.c:309
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:706
adc_preempt_offset_value_set
void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral.
Definition: at32f413_adc.c:542
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_ordinary_software_trigger_status_get
flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:654
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f413_adc.c:616
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:628
adc_preempt_software_trigger_status_get
flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:687
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f413_adc.c:573
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:733
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:799
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:178
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f413_adc.c:289
adc_preempt_part_mode_enable
void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:602
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:510
adc_combine_ordinary_conversion_data_get
uint32_t adc_combine_ordinary_conversion_data_get(void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2).
Definition: at32f413_adc.c:715
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:770
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:424
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:588
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:392
adc_reset
void adc_reset(adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values.
Definition: at32f413_adc.c:49
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:675
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC1
#define ADC1
Definition: at32f413_adc.h:557
ADC2
#define ADC2
Definition: at32f413_adc.h:558
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
CRM_ADC2_PERIPH_RESET
@ CRM_ADC2_PERIPH_RESET
Definition: at32f413_crm.h:158
CRM_ADC1_PERIPH_RESET
@ CRM_ADC1_PERIPH_RESET
Definition: at32f413_crm.h:157
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
adc_type
type define adc register all
Definition: at32f413_adc.h:221
adc_type::dtalign
__IO uint32_t dtalign
Definition: at32f413_adc.h:281
adc_type::osq2
__IO uint32_t osq2
Definition: at32f413_adc.h:438
adc_type::ocdmaen
__IO uint32_t ocdmaen
Definition: at32f413_adc.h:279
adc_type::ocswtrg
__IO uint32_t ocswtrg
Definition: at32f413_adc.h:288
adc_type::rpen
__IO uint32_t rpen
Definition: at32f413_adc.h:275
adc_type::sqen
__IO uint32_t sqen
Definition: at32f413_adc.h:252
adc_type::pctesel_h
__IO uint32_t pctesel_h
Definition: at32f413_adc.h:290
adc_type::pdt4
__IO uint32_t pdt4
Definition: at32f413_adc.h:530
adc_type::pclen
__IO uint32_t pclen
Definition: at32f413_adc.h:481
adc_type::vmcsel
__IO uint32_t vmcsel
Definition: at32f413_adc.h:248
adc_type::odt
__IO uint32_t odt
Definition: at32f413_adc.h:543
adc_type::pcvmen
__IO uint32_t pcvmen
Definition: at32f413_adc.h:260
adc_type::pcdto1_bit
struct adc_type::@28::@63 pcdto1_bit
adc_type::pcdto4
__IO uint32_t pcdto4
Definition: at32f413_adc.h:382
adc_type::pdt1
__IO uint32_t pdt1
Definition: at32f413_adc.h:491
adc_type::pcdto2
__IO uint32_t pcdto2
Definition: at32f413_adc.h:356
adc_type::pcpen
__IO uint32_t pcpen
Definition: at32f413_adc.h:256
adc_type::vmsgen
__IO uint32_t vmsgen
Definition: at32f413_adc.h:253
adc_type::octen
__IO uint32_t octen
Definition: at32f413_adc.h:286
adc_type::pdt2_bit
struct adc_type::@50::@74 pdt2_bit
adc_type::pcdto4_bit
struct adc_type::@34::@66 pcdto4_bit
adc_type::ocvmen
__IO uint32_t ocvmen
Definition: at32f413_adc.h:261
adc_type::oclen
__IO uint32_t oclen
Definition: at32f413_adc.h:428
adc_type::pcdto1
__IO uint32_t pcdto1
Definition: at32f413_adc.h:343
adc_type::spt1
__IO uint32_t spt1
Definition: at32f413_adc.h:301
adc_type::psn4
__IO uint32_t psn4
Definition: at32f413_adc.h:480
adc_type::psq_bit
struct adc_type::@46::@72 psq_bit
adc_type::adcal
__IO uint32_t adcal
Definition: at32f413_adc.h:276
adc_type::octesel_l
__IO uint32_t octesel_l
Definition: at32f413_adc.h:285
adc_type::pctesel_l
__IO uint32_t pctesel_l
Definition: at32f413_adc.h:282
adc_type::odt_bit
struct adc_type::@56::@77 odt_bit
adc_type::ctrl1_bit
struct adc_type::@20::@59 ctrl1_bit
adc_type::osq1_bit
struct adc_type::@40::@69 osq1_bit
adc_type::octesel_h
__IO uint32_t octesel_h
Definition: at32f413_adc.h:291
adc_type::psn3
__IO uint32_t psn3
Definition: at32f413_adc.h:479
adc_type::spt2
__IO uint32_t spt2
Definition: at32f413_adc.h:321
adc_type::adcen
__IO uint32_t adcen
Definition: at32f413_adc.h:274
adc_type::vmhb
__IO uint32_t vmhb
Definition: at32f413_adc.h:395
adc_type::ocpen
__IO uint32_t ocpen
Definition: at32f413_adc.h:255
adc_type::pdt1_bit
struct adc_type::@48::@73 pdt1_bit
adc_type::adcalinit
__IO uint32_t adcalinit
Definition: at32f413_adc.h:277
adc_type::pdt3
__IO uint32_t pdt3
Definition: at32f413_adc.h:517
adc_type::ctrl2_bit
struct adc_type::@22::@60 ctrl2_bit
adc_type::psn1
__IO uint32_t psn1
Definition: at32f413_adc.h:477
adc_type::pdt3_bit
struct adc_type::@52::@75 pdt3_bit
adc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_adc.h:245
adc_type::sts
__IO uint32_t sts
Definition: at32f413_adc.h:228
adc_type::pcdto2_bit
struct adc_type::@30::@64 pcdto2_bit
adc_type::osq1
__IO uint32_t osq1
Definition: at32f413_adc.h:421
adc_type::psn2
__IO uint32_t psn2
Definition: at32f413_adc.h:478
adc_type::vmlb
__IO uint32_t vmlb
Definition: at32f413_adc.h:408
adc_type::pcdto3_bit
struct adc_type::@32::@65 pcdto3_bit
adc_type::pdt2
__IO uint32_t pdt2
Definition: at32f413_adc.h:504
adc_type::ocpcnt
__IO uint32_t ocpcnt
Definition: at32f413_adc.h:257
adc_type::pdt4_bit
struct adc_type::@54::@76 pdt4_bit
adc_type::vmhb_bit
struct adc_type::@36::@67 vmhb_bit
adc_type::osq3
__IO uint32_t osq3
Definition: at32f413_adc.h:456
adc_type::vmlb_bit
struct adc_type::@38::@68 vmlb_bit
adc_type::pcautoen
__IO uint32_t pcautoen
Definition: at32f413_adc.h:254
adc_type::pcdto3
__IO uint32_t pcdto3
Definition: at32f413_adc.h:369
adc_type::pcten
__IO uint32_t pcten
Definition: at32f413_adc.h:283
adc_type::pcswtrg
__IO uint32_t pcswtrg
Definition: at32f413_adc.h:287
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_adc.h Source File

  • libraries
  • drivers
  • inc
at32f413_adc.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_ADC_H
27#define __AT32F413_ADC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define ADC_CCE_INT ((uint32_t)0x00000020)
51#define ADC_VMOR_INT ((uint32_t)0x00000040)
52#define ADC_PCCE_INT ((uint32_t)0x00000080)
63#define ADC_VMOR_FLAG ((uint8_t)0x01)
64#define ADC_CCE_FLAG ((uint8_t)0x02)
65#define ADC_PCCE_FLAG ((uint8_t)0x04)
66#define ADC_PCCS_FLAG ((uint8_t)0x08)
67#define ADC_OCCS_FLAG ((uint8_t)0x10)
80typedef enum
81{
82 ADC_INDEPENDENT_MODE = 0x00,
83 ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE = 0x01,
84 ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE = 0x02,
85 ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE = 0x03,
86 ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE = 0x04,
87 ADC_PREEMPT_SMLT_ONLY_MODE = 0x05,
88 ADC_ORDINARY_SMLT_ONLY_MODE = 0x06,
89 ADC_ORDINARY_SHORTSHIFT_ONLY_MODE = 0x07,
90 ADC_ORDINARY_LONGSHIFT_ONLY_MODE = 0x08,
91 ADC_PREEMPT_INTERLTRIG_ONLY_MODE = 0x09
92} adc_combine_mode_type;
93
97typedef enum
98{
99 ADC_RIGHT_ALIGNMENT = 0x00,
100 ADC_LEFT_ALIGNMENT = 0x01
101} adc_data_align_type;
102
106typedef enum
107{
108 ADC_CHANNEL_0 = 0x00,
109 ADC_CHANNEL_1 = 0x01,
110 ADC_CHANNEL_2 = 0x02,
111 ADC_CHANNEL_3 = 0x03,
112 ADC_CHANNEL_4 = 0x04,
113 ADC_CHANNEL_5 = 0x05,
114 ADC_CHANNEL_6 = 0x06,
115 ADC_CHANNEL_7 = 0x07,
116 ADC_CHANNEL_8 = 0x08,
117 ADC_CHANNEL_9 = 0x09,
118 ADC_CHANNEL_10 = 0x0A,
119 ADC_CHANNEL_11 = 0x0B,
120 ADC_CHANNEL_12 = 0x0C,
121 ADC_CHANNEL_13 = 0x0D,
122 ADC_CHANNEL_14 = 0x0E,
123 ADC_CHANNEL_15 = 0x0F,
124 ADC_CHANNEL_16 = 0x10,
125 ADC_CHANNEL_17 = 0x11
126} adc_channel_select_type;
127
131typedef enum
132{
133 ADC_SAMPLETIME_1_5 = 0x00,
134 ADC_SAMPLETIME_7_5 = 0x01,
135 ADC_SAMPLETIME_13_5 = 0x02,
136 ADC_SAMPLETIME_28_5 = 0x03,
137 ADC_SAMPLETIME_41_5 = 0x04,
138 ADC_SAMPLETIME_55_5 = 0x05,
139 ADC_SAMPLETIME_71_5 = 0x06,
140 ADC_SAMPLETIME_239_5 = 0x07
141} adc_sampletime_select_type;
142
146typedef enum
147{
148 /*adc1 and adc2 ordinary trigger event*/
149 ADC12_ORDINARY_TRIG_TMR1CH1 = 0x00,
150 ADC12_ORDINARY_TRIG_TMR1CH2 = 0x01,
151 ADC12_ORDINARY_TRIG_TMR1CH3 = 0x02,
152 ADC12_ORDINARY_TRIG_TMR2CH2 = 0x03,
153 ADC12_ORDINARY_TRIG_TMR3TRGOUT = 0x04,
154 ADC12_ORDINARY_TRIG_TMR4CH4 = 0x05,
155 ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT = 0x06,
156 ADC12_ORDINARY_TRIG_SOFTWARE = 0x07,
157 ADC12_ORDINARY_TRIG_TMR1TRGOUT = 0x0D,
158 ADC12_ORDINARY_TRIG_TMR8CH1 = 0x0E,
159 ADC12_ORDINARY_TRIG_TMR8CH2 = 0x0F,
160} adc_ordinary_trig_select_type;
161
165typedef enum
166{
167 /*adc1 and adc2 preempt trigger event*/
168 ADC12_PREEMPT_TRIG_TMR1TRGOUT = 0x00,
169 ADC12_PREEMPT_TRIG_TMR1CH4 = 0x01,
170 ADC12_PREEMPT_TRIG_TMR2TRGOUT = 0x02,
171 ADC12_PREEMPT_TRIG_TMR2CH1 = 0x03,
172 ADC12_PREEMPT_TRIG_TMR3CH4 = 0x04,
173 ADC12_PREEMPT_TRIG_TMR4TRGOUT = 0x05,
174 ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 = 0x06,
175 ADC12_PREEMPT_TRIG_SOFTWARE = 0x07,
176 ADC12_PREEMPT_TRIG_TMR1CH1 = 0x0D,
177 ADC12_PREEMPT_TRIG_TMR8CH1 = 0x0E,
178 ADC12_PREEMPT_TRIG_TMR8TRGOUT = 0x0F,
179} adc_preempt_trig_select_type;
180
184typedef enum
185{
186 ADC_PREEMPT_CHANNEL_1 = 0x00,
187 ADC_PREEMPT_CHANNEL_2 = 0x01,
188 ADC_PREEMPT_CHANNEL_3 = 0x02,
189 ADC_PREEMPT_CHANNEL_4 = 0x03
190} adc_preempt_channel_type;
191
195typedef enum
196{
197 ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200,
198 ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200,
199 ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200,
200 ADC_VMONITOR_ALL_ORDINARY = 0x00800000,
201 ADC_VMONITOR_ALL_PREEMPT = 0x00400000,
202 ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000,
203 ADC_VMONITOR_NONE = 0x00000000
204} adc_voltage_monitoring_type;
205
209typedef struct
210{
211 confirm_state sequence_mode;
212 confirm_state repeat_mode;
213 adc_data_align_type data_align;
214 uint8_t ordinary_channel_length;
215} adc_base_config_type;
216
220typedef struct
221{
222
226 union
227 {
228 __IO uint32_t sts;
229 struct
230 {
231 __IO uint32_t vmor : 1; /* [0] */
232 __IO uint32_t cce : 1; /* [1] */
233 __IO uint32_t pcce : 1; /* [2] */
234 __IO uint32_t pccs : 1; /* [3] */
235 __IO uint32_t occs : 1; /* [4] */
236 __IO uint32_t reserved1 : 27;/* [31:5] */
237 } sts_bit;
238 };
239
243 union
244 {
245 __IO uint32_t ctrl1;
246 struct
247 {
248 __IO uint32_t vmcsel : 5; /* [4:0] */
249 __IO uint32_t cceien : 1; /* [5] */
250 __IO uint32_t vmorien : 1; /* [6] */
251 __IO uint32_t pcceien : 1; /* [7] */
252 __IO uint32_t sqen : 1; /* [8] */
253 __IO uint32_t vmsgen : 1; /* [9] */
254 __IO uint32_t pcautoen : 1; /* [10] */
255 __IO uint32_t ocpen : 1; /* [11] */
256 __IO uint32_t pcpen : 1; /* [12] */
257 __IO uint32_t ocpcnt : 3; /* [15:13] */
258 __IO uint32_t mssel : 4; /* [19:16] */
259 __IO uint32_t reserved1 : 2; /* [21:20] */
260 __IO uint32_t pcvmen : 1; /* [22] */
261 __IO uint32_t ocvmen : 1; /* [23] */
262 __IO uint32_t reserved2 : 8; /* [31:24] */
263 } ctrl1_bit;
264 };
265
269 union
270 {
271 __IO uint32_t ctrl2;
272 struct
273 {
274 __IO uint32_t adcen : 1; /* [0] */
275 __IO uint32_t rpen : 1; /* [1] */
276 __IO uint32_t adcal : 1; /* [2] */
277 __IO uint32_t adcalinit : 1; /* [3] */
278 __IO uint32_t reserved1 : 4; /* [7:4] */
279 __IO uint32_t ocdmaen : 1; /* [8] */
280 __IO uint32_t reserved2 : 2; /* [10:9] */
281 __IO uint32_t dtalign : 1; /* [11] */
282 __IO uint32_t pctesel_l : 3; /* [14:12] */
283 __IO uint32_t pcten : 1; /* [15] */
284 __IO uint32_t reserved3 : 1; /* [16] */
285 __IO uint32_t octesel_l : 3; /* [19:17] */
286 __IO uint32_t octen : 1; /* [20] */
287 __IO uint32_t pcswtrg : 1; /* [21] */
288 __IO uint32_t ocswtrg : 1; /* [22] */
289 __IO uint32_t itsrven : 1; /* [23] */
290 __IO uint32_t pctesel_h : 1; /* [24] */
291 __IO uint32_t octesel_h : 1; /* [25] */
292 __IO uint32_t reserved4 : 6; /* [31:26] */
293 } ctrl2_bit;
294 };
295
299 union
300 {
301 __IO uint32_t spt1;
302 struct
303 {
304 __IO uint32_t cspt10 : 3; /* [2:0] */
305 __IO uint32_t cspt11 : 3; /* [5:3] */
306 __IO uint32_t cspt12 : 3; /* [8:6] */
307 __IO uint32_t cspt13 : 3; /* [11:9] */
308 __IO uint32_t cspt14 : 3; /* [14:12] */
309 __IO uint32_t cspt15 : 3; /* [17:15] */
310 __IO uint32_t cspt16 : 3; /* [20:18] */
311 __IO uint32_t cspt17 : 3; /* [23:21] */
312 __IO uint32_t reserved1 : 8;/* [31:24] */
313 } spt1_bit;
314 };
315
319 union
320 {
321 __IO uint32_t spt2;
322 struct
323 {
324 __IO uint32_t cspt0 : 3;/* [2:0] */
325 __IO uint32_t cspt1 : 3;/* [5:3] */
326 __IO uint32_t cspt2 : 3;/* [8:6] */
327 __IO uint32_t cspt3 : 3;/* [11:9] */
328 __IO uint32_t cspt4 : 3;/* [14:12] */
329 __IO uint32_t cspt5 : 3;/* [17:15] */
330 __IO uint32_t cspt6 : 3;/* [20:18] */
331 __IO uint32_t cspt7 : 3;/* [23:21] */
332 __IO uint32_t cspt8 : 3;/* [26:24] */
333 __IO uint32_t cspt9 : 3;/* [29:27] */
334 __IO uint32_t reserved1 : 2;/* [31:30] */
335 } spt2_bit;
336 };
337
341 union
342 {
343 __IO uint32_t pcdto1;
344 struct
345 {
346 __IO uint32_t pcdto1 : 12; /* [11:0] */
347 __IO uint32_t reserved1 : 20; /* [31:12] */
348 } pcdto1_bit;
349 };
350
354 union
355 {
356 __IO uint32_t pcdto2;
357 struct
358 {
359 __IO uint32_t pcdto2 : 12; /* [11:0] */
360 __IO uint32_t reserved1 : 20; /* [31:12] */
361 } pcdto2_bit;
362 };
363
367 union
368 {
369 __IO uint32_t pcdto3;
370 struct
371 {
372 __IO uint32_t pcdto3 : 12; /* [11:0] */
373 __IO uint32_t reserved1 : 20; /* [31:12] */
374 } pcdto3_bit;
375 };
376
380 union
381 {
382 __IO uint32_t pcdto4;
383 struct
384 {
385 __IO uint32_t pcdto4 : 12; /* [11:0] */
386 __IO uint32_t reserved1 : 20; /* [31:12] */
387 } pcdto4_bit;
388 };
389
393 union
394 {
395 __IO uint32_t vmhb;
396 struct
397 {
398 __IO uint32_t vmhb : 12; /* [11:0] */
399 __IO uint32_t reserved1 : 20; /* [31:12] */
400 } vmhb_bit;
401 };
402
406 union
407 {
408 __IO uint32_t vmlb;
409 struct
410 {
411 __IO uint32_t vmlb : 12; /* [11:0] */
412 __IO uint32_t reserved1 : 20; /* [31:12] */
413 } vmlb_bit;
414 };
415
419 union
420 {
421 __IO uint32_t osq1;
422 struct
423 {
424 __IO uint32_t osn13 : 5; /* [4:0] */
425 __IO uint32_t osn14 : 5; /* [9:5] */
426 __IO uint32_t osn15 : 5; /* [14:10] */
427 __IO uint32_t osn16 : 5; /* [19:15] */
428 __IO uint32_t oclen : 4; /* [23:20] */
429 __IO uint32_t reserved1 : 8; /* [31:24] */
430 } osq1_bit;
431 };
432
436 union
437 {
438 __IO uint32_t osq2;
439 struct
440 {
441 __IO uint32_t osn7 : 5; /* [4:0] */
442 __IO uint32_t osn8 : 5; /* [9:5] */
443 __IO uint32_t osn9 : 5; /* [14:10] */
444 __IO uint32_t osn10 : 5; /* [19:15] */
445 __IO uint32_t osn11 : 5; /* [24:20] */
446 __IO uint32_t osn12 : 5; /* [29:25] */
447 __IO uint32_t reserved1 : 2; /* [31:30] */
448 } osq2_bit;
449 };
450
454 union
455 {
456 __IO uint32_t osq3;
457 struct
458 {
459 __IO uint32_t osn1 : 5; /* [4:0] */
460 __IO uint32_t osn2 : 5; /* [9:5] */
461 __IO uint32_t osn3 : 5; /* [14:10] */
462 __IO uint32_t osn4 : 5; /* [19:15] */
463 __IO uint32_t osn5 : 5; /* [24:20] */
464 __IO uint32_t osn6 : 5; /* [29:25] */
465 __IO uint32_t reserved1 : 2; /* [31:30] */
466 } osq3_bit;
467 };
468
472 union
473 {
474 __IO uint32_t psq;
475 struct
476 {
477 __IO uint32_t psn1 : 5; /* [4:0] */
478 __IO uint32_t psn2 : 5; /* [9:5] */
479 __IO uint32_t psn3 : 5; /* [14:10] */
480 __IO uint32_t psn4 : 5; /* [19:15] */
481 __IO uint32_t pclen : 2; /* [21:20] */
482 __IO uint32_t reserved1 : 10;/* [31:22] */
483 } psq_bit;
484 };
485
489 union
490 {
491 __IO uint32_t pdt1;
492 struct
493 {
494 __IO uint32_t pdt1 : 16; /* [15:0] */
495 __IO uint32_t reserved1 : 16; /* [31:16] */
496 } pdt1_bit;
497 };
498
502 union
503 {
504 __IO uint32_t pdt2;
505 struct
506 {
507 __IO uint32_t pdt2 : 16; /* [15:0] */
508 __IO uint32_t reserved1 : 16; /* [31:16] */
509 } pdt2_bit;
510 };
511
515 union
516 {
517 __IO uint32_t pdt3;
518 struct
519 {
520 __IO uint32_t pdt3 : 16; /* [15:0] */
521 __IO uint32_t reserved1 : 16; /* [31:16] */
522 } pdt3_bit;
523 };
524
528 union
529 {
530 __IO uint32_t pdt4;
531 struct
532 {
533 __IO uint32_t pdt4 : 16; /* [15:0] */
534 __IO uint32_t reserved1 : 16; /* [31:16] */
535 } pdt4_bit;
536 };
537
541 union
542 {
543 __IO uint32_t odt;
544 struct
545 {
546 __IO uint32_t odt : 16; /* [15:0] */
547 __IO uint32_t adc2odt : 16; /* [31:16] */
548 } odt_bit;
549 };
550
551} adc_type;
552
557#define ADC1 ((adc_type *) ADC1_BASE)
558#define ADC2 ((adc_type *) ADC2_BASE)
559
564void adc_reset(adc_type *adc_x);
565void adc_enable(adc_type *adc_x, confirm_state new_state);
566void adc_combine_mode_select(adc_combine_mode_type combine_mode);
567void adc_base_default_para_init(adc_base_config_type *adc_base_struct);
568void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct);
569void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state);
570void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state);
571void adc_calibration_init(adc_type *adc_x);
572 flag_status adc_calibration_init_status_get(adc_type *adc_x);
573void adc_calibration_start(adc_type *adc_x);
574 flag_status adc_calibration_status_get(adc_type *adc_x);
575void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring);
576void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold);
577void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel);
578void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime);
579void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght);
580void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime);
581void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state);
582void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state);
583void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value);
584void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count);
585void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state);
586void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state);
587void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state);
588void adc_tempersensor_vintrv_enable(confirm_state new_state);
589void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state);
590 flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x);
591void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state);
592 flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x);
593uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x);
594uint32_t adc_combine_ordinary_conversion_data_get(void);
595uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel);
596 flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag);
597void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag);
598
611#ifdef __cplusplus
612}
613#endif
614
615#endif
at32f413.h
at32f413 header file
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f413_adc.c:268
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f413_adc.c:309
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:706
adc_preempt_offset_value_set
void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral.
Definition: at32f413_adc.c:542
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_ordinary_software_trigger_status_get
flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:654
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f413_adc.c:616
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:628
adc_preempt_software_trigger_status_get
flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:687
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f413_adc.c:573
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:733
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:799
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:178
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f413_adc.c:289
adc_preempt_part_mode_enable
void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:602
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:510
adc_combine_ordinary_conversion_data_get
uint32_t adc_combine_ordinary_conversion_data_get(void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2).
Definition: at32f413_adc.c:715
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:770
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:424
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:588
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:392
adc_reset
void adc_reset(adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values.
Definition: at32f413_adc.c:49
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:675
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
adc_voltage_monitoring_type
adc_voltage_monitoring_type
adc voltage_monitoring type
Definition: at32f413_adc.h:196
adc_data_align_type
adc_data_align_type
adc data align type
Definition: at32f413_adc.h:98
adc_channel_select_type
adc_channel_select_type
adc channel select type
Definition: at32f413_adc.h:107
adc_sampletime_select_type
adc_sampletime_select_type
adc sampletime select type
Definition: at32f413_adc.h:132
adc_preempt_trig_select_type
adc_preempt_trig_select_type
adc preempt group trigger event select type
Definition: at32f413_adc.h:166
adc_combine_mode_type
adc_combine_mode_type
adc combine mode type(these options are reserved in adc2)
Definition: at32f413_adc.h:81
adc_ordinary_trig_select_type
adc_ordinary_trig_select_type
adc ordinary group trigger event select type
Definition: at32f413_adc.h:147
adc_preempt_channel_type
adc_preempt_channel_type
adc preempt channel type
Definition: at32f413_adc.h:185
ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
@ ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
Definition: at32f413_adc.h:199
ADC_VMONITOR_SINGLE_ORDINARY
@ ADC_VMONITOR_SINGLE_ORDINARY
Definition: at32f413_adc.h:197
ADC_VMONITOR_ALL_ORDINARY
@ ADC_VMONITOR_ALL_ORDINARY
Definition: at32f413_adc.h:200
ADC_VMONITOR_ALL_PREEMPT
@ ADC_VMONITOR_ALL_PREEMPT
Definition: at32f413_adc.h:201
ADC_VMONITOR_ALL_ORDINARY_PREEMPT
@ ADC_VMONITOR_ALL_ORDINARY_PREEMPT
Definition: at32f413_adc.h:202
ADC_VMONITOR_NONE
@ ADC_VMONITOR_NONE
Definition: at32f413_adc.h:203
ADC_VMONITOR_SINGLE_PREEMPT
@ ADC_VMONITOR_SINGLE_PREEMPT
Definition: at32f413_adc.h:198
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_LEFT_ALIGNMENT
@ ADC_LEFT_ALIGNMENT
Definition: at32f413_adc.h:100
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:117
ADC_CHANNEL_1
@ ADC_CHANNEL_1
Definition: at32f413_adc.h:109
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f413_adc.h:125
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:116
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:112
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f413_adc.h:120
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f413_adc.h:124
ADC_CHANNEL_0
@ ADC_CHANNEL_0
Definition: at32f413_adc.h:108
ADC_CHANNEL_3
@ ADC_CHANNEL_3
Definition: at32f413_adc.h:111
ADC_CHANNEL_14
@ ADC_CHANNEL_14
Definition: at32f413_adc.h:122
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f413_adc.h:118
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f413_adc.h:121
ADC_CHANNEL_2
@ ADC_CHANNEL_2
Definition: at32f413_adc.h:110
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:114
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:115
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:113
ADC_CHANNEL_11
@ ADC_CHANNEL_11
Definition: at32f413_adc.h:119
ADC_CHANNEL_15
@ ADC_CHANNEL_15
Definition: at32f413_adc.h:123
ADC_SAMPLETIME_41_5
@ ADC_SAMPLETIME_41_5
Definition: at32f413_adc.h:137
ADC_SAMPLETIME_55_5
@ ADC_SAMPLETIME_55_5
Definition: at32f413_adc.h:138
ADC_SAMPLETIME_71_5
@ ADC_SAMPLETIME_71_5
Definition: at32f413_adc.h:139
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC_SAMPLETIME_1_5
@ ADC_SAMPLETIME_1_5
Definition: at32f413_adc.h:133
ADC_SAMPLETIME_28_5
@ ADC_SAMPLETIME_28_5
Definition: at32f413_adc.h:136
ADC_SAMPLETIME_13_5
@ ADC_SAMPLETIME_13_5
Definition: at32f413_adc.h:135
ADC_SAMPLETIME_7_5
@ ADC_SAMPLETIME_7_5
Definition: at32f413_adc.h:134
ADC12_PREEMPT_TRIG_TMR8CH1
@ ADC12_PREEMPT_TRIG_TMR8CH1
Definition: at32f413_adc.h:177
ADC12_PREEMPT_TRIG_TMR4TRGOUT
@ ADC12_PREEMPT_TRIG_TMR4TRGOUT
Definition: at32f413_adc.h:173
ADC12_PREEMPT_TRIG_TMR2TRGOUT
@ ADC12_PREEMPT_TRIG_TMR2TRGOUT
Definition: at32f413_adc.h:170
ADC12_PREEMPT_TRIG_TMR1CH1
@ ADC12_PREEMPT_TRIG_TMR1CH1
Definition: at32f413_adc.h:176
ADC12_PREEMPT_TRIG_TMR1CH4
@ ADC12_PREEMPT_TRIG_TMR1CH4
Definition: at32f413_adc.h:169
ADC12_PREEMPT_TRIG_TMR1TRGOUT
@ ADC12_PREEMPT_TRIG_TMR1TRGOUT
Definition: at32f413_adc.h:168
ADC12_PREEMPT_TRIG_TMR3CH4
@ ADC12_PREEMPT_TRIG_TMR3CH4
Definition: at32f413_adc.h:172
ADC12_PREEMPT_TRIG_SOFTWARE
@ ADC12_PREEMPT_TRIG_SOFTWARE
Definition: at32f413_adc.h:175
ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
@ ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
Definition: at32f413_adc.h:174
ADC12_PREEMPT_TRIG_TMR8TRGOUT
@ ADC12_PREEMPT_TRIG_TMR8TRGOUT
Definition: at32f413_adc.h:178
ADC12_PREEMPT_TRIG_TMR2CH1
@ ADC12_PREEMPT_TRIG_TMR2CH1
Definition: at32f413_adc.h:171
ADC_PREEMPT_SMLT_ONLY_MODE
@ ADC_PREEMPT_SMLT_ONLY_MODE
Definition: at32f413_adc.h:87
ADC_PREEMPT_INTERLTRIG_ONLY_MODE
@ ADC_PREEMPT_INTERLTRIG_ONLY_MODE
Definition: at32f413_adc.h:91
ADC_ORDINARY_LONGSHIFT_ONLY_MODE
@ ADC_ORDINARY_LONGSHIFT_ONLY_MODE
Definition: at32f413_adc.h:90
ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
@ ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
Definition: at32f413_adc.h:85
ADC_ORDINARY_SMLT_ONLY_MODE
@ ADC_ORDINARY_SMLT_ONLY_MODE
Definition: at32f413_adc.h:88
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
@ ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
Definition: at32f413_adc.h:89
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
Definition: at32f413_adc.h:84
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
@ ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
Definition: at32f413_adc.h:86
ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
Definition: at32f413_adc.h:83
ADC12_ORDINARY_TRIG_TMR2CH2
@ ADC12_ORDINARY_TRIG_TMR2CH2
Definition: at32f413_adc.h:152
ADC12_ORDINARY_TRIG_TMR1TRGOUT
@ ADC12_ORDINARY_TRIG_TMR1TRGOUT
Definition: at32f413_adc.h:157
ADC12_ORDINARY_TRIG_TMR1CH2
@ ADC12_ORDINARY_TRIG_TMR1CH2
Definition: at32f413_adc.h:150
ADC12_ORDINARY_TRIG_TMR1CH1
@ ADC12_ORDINARY_TRIG_TMR1CH1
Definition: at32f413_adc.h:149
ADC12_ORDINARY_TRIG_TMR8CH2
@ ADC12_ORDINARY_TRIG_TMR8CH2
Definition: at32f413_adc.h:159
ADC12_ORDINARY_TRIG_TMR4CH4
@ ADC12_ORDINARY_TRIG_TMR4CH4
Definition: at32f413_adc.h:154
ADC12_ORDINARY_TRIG_TMR1CH3
@ ADC12_ORDINARY_TRIG_TMR1CH3
Definition: at32f413_adc.h:151
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:156
ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
@ ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
Definition: at32f413_adc.h:155
ADC12_ORDINARY_TRIG_TMR3TRGOUT
@ ADC12_ORDINARY_TRIG_TMR3TRGOUT
Definition: at32f413_adc.h:153
ADC12_ORDINARY_TRIG_TMR8CH1
@ ADC12_ORDINARY_TRIG_TMR8CH1
Definition: at32f413_adc.h:158
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:188
ADC_PREEMPT_CHANNEL_4
@ ADC_PREEMPT_CHANNEL_4
Definition: at32f413_adc.h:189
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:187
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:186
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
adc_type
type define adc register all
Definition: at32f413_adc.h:221
adc_type::cspt1
__IO uint32_t cspt1
Definition: at32f413_adc.h:325
adc_type::pcce
__IO uint32_t pcce
Definition: at32f413_adc.h:233
adc_type::adc2odt
__IO uint32_t adc2odt
Definition: at32f413_adc.h:547
adc_type::dtalign
__IO uint32_t dtalign
Definition: at32f413_adc.h:281
adc_type::osq2
__IO uint32_t osq2
Definition: at32f413_adc.h:438
adc_type::ocdmaen
__IO uint32_t ocdmaen
Definition: at32f413_adc.h:279
adc_type::ocswtrg
__IO uint32_t ocswtrg
Definition: at32f413_adc.h:288
adc_type::osn14
__IO uint32_t osn14
Definition: at32f413_adc.h:425
adc_type::rpen
__IO uint32_t rpen
Definition: at32f413_adc.h:275
adc_type::sqen
__IO uint32_t sqen
Definition: at32f413_adc.h:252
adc_type::pctesel_h
__IO uint32_t pctesel_h
Definition: at32f413_adc.h:290
adc_type::pdt4
__IO uint32_t pdt4
Definition: at32f413_adc.h:530
adc_type::cspt15
__IO uint32_t cspt15
Definition: at32f413_adc.h:309
adc_type::pclen
__IO uint32_t pclen
Definition: at32f413_adc.h:481
adc_type::vmcsel
__IO uint32_t vmcsel
Definition: at32f413_adc.h:248
adc_type::cspt7
__IO uint32_t cspt7
Definition: at32f413_adc.h:331
adc_type::odt
__IO uint32_t odt
Definition: at32f413_adc.h:543
adc_type::pcvmen
__IO uint32_t pcvmen
Definition: at32f413_adc.h:260
adc_type::osn1
__IO uint32_t osn1
Definition: at32f413_adc.h:459
adc_type::pcdto4
__IO uint32_t pcdto4
Definition: at32f413_adc.h:382
adc_type::pdt1
__IO uint32_t pdt1
Definition: at32f413_adc.h:491
adc_type::pcdto2
__IO uint32_t pcdto2
Definition: at32f413_adc.h:356
adc_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_adc.h:284
adc_type::cspt6
__IO uint32_t cspt6
Definition: at32f413_adc.h:330
adc_type::osn6
__IO uint32_t osn6
Definition: at32f413_adc.h:464
adc_type::osn8
__IO uint32_t osn8
Definition: at32f413_adc.h:442
adc_type::pcpen
__IO uint32_t pcpen
Definition: at32f413_adc.h:256
adc_type::osn16
__IO uint32_t osn16
Definition: at32f413_adc.h:427
adc_type::cspt13
__IO uint32_t cspt13
Definition: at32f413_adc.h:307
adc_type::vmsgen
__IO uint32_t vmsgen
Definition: at32f413_adc.h:253
adc_type::psq
__IO uint32_t psq
Definition: at32f413_adc.h:474
adc_type::osn3
__IO uint32_t osn3
Definition: at32f413_adc.h:461
adc_type::pcceien
__IO uint32_t pcceien
Definition: at32f413_adc.h:251
adc_type::octen
__IO uint32_t octen
Definition: at32f413_adc.h:286
adc_type::vmorien
__IO uint32_t vmorien
Definition: at32f413_adc.h:250
adc_type::ocvmen
__IO uint32_t ocvmen
Definition: at32f413_adc.h:261
adc_type::oclen
__IO uint32_t oclen
Definition: at32f413_adc.h:428
adc_type::pcdto1
__IO uint32_t pcdto1
Definition: at32f413_adc.h:343
adc_type::mssel
__IO uint32_t mssel
Definition: at32f413_adc.h:258
adc_type::occs
__IO uint32_t occs
Definition: at32f413_adc.h:235
adc_type::osn9
__IO uint32_t osn9
Definition: at32f413_adc.h:443
adc_type::cspt5
__IO uint32_t cspt5
Definition: at32f413_adc.h:329
adc_type::spt1
__IO uint32_t spt1
Definition: at32f413_adc.h:301
adc_type::psn4
__IO uint32_t psn4
Definition: at32f413_adc.h:480
adc_type::cspt12
__IO uint32_t cspt12
Definition: at32f413_adc.h:306
adc_type::adcal
__IO uint32_t adcal
Definition: at32f413_adc.h:276
adc_type::cspt14
__IO uint32_t cspt14
Definition: at32f413_adc.h:308
adc_type::octesel_l
__IO uint32_t octesel_l
Definition: at32f413_adc.h:285
adc_type::cceien
__IO uint32_t cceien
Definition: at32f413_adc.h:249
adc_type::pctesel_l
__IO uint32_t pctesel_l
Definition: at32f413_adc.h:282
adc_type::octesel_h
__IO uint32_t octesel_h
Definition: at32f413_adc.h:291
adc_type::psn3
__IO uint32_t psn3
Definition: at32f413_adc.h:479
adc_type::itsrven
__IO uint32_t itsrven
Definition: at32f413_adc.h:289
adc_type::spt2
__IO uint32_t spt2
Definition: at32f413_adc.h:321
adc_type::osn4
__IO uint32_t osn4
Definition: at32f413_adc.h:462
adc_type::adcen
__IO uint32_t adcen
Definition: at32f413_adc.h:274
adc_type::vmhb
__IO uint32_t vmhb
Definition: at32f413_adc.h:395
adc_type::ocpen
__IO uint32_t ocpen
Definition: at32f413_adc.h:255
adc_type::cspt9
__IO uint32_t cspt9
Definition: at32f413_adc.h:333
adc_type::adcalinit
__IO uint32_t adcalinit
Definition: at32f413_adc.h:277
adc_type::pdt3
__IO uint32_t pdt3
Definition: at32f413_adc.h:517
adc_type::psn1
__IO uint32_t psn1
Definition: at32f413_adc.h:477
adc_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_adc.h:292
adc_type::cspt10
__IO uint32_t cspt10
Definition: at32f413_adc.h:304
adc_type::osn10
__IO uint32_t osn10
Definition: at32f413_adc.h:444
adc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_adc.h:262
adc_type::osn12
__IO uint32_t osn12
Definition: at32f413_adc.h:446
adc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_adc.h:245
adc_type::sts
__IO uint32_t sts
Definition: at32f413_adc.h:228
adc_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_adc.h:271
adc_type::cspt0
__IO uint32_t cspt0
Definition: at32f413_adc.h:324
adc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_adc.h:236
adc_type::cce
__IO uint32_t cce
Definition: at32f413_adc.h:232
adc_type::osq1
__IO uint32_t osq1
Definition: at32f413_adc.h:421
adc_type::cspt16
__IO uint32_t cspt16
Definition: at32f413_adc.h:310
adc_type::psn2
__IO uint32_t psn2
Definition: at32f413_adc.h:478
adc_type::osn2
__IO uint32_t osn2
Definition: at32f413_adc.h:460
adc_type::vmor
__IO uint32_t vmor
Definition: at32f413_adc.h:231
adc_type::osn15
__IO uint32_t osn15
Definition: at32f413_adc.h:426
adc_type::osn11
__IO uint32_t osn11
Definition: at32f413_adc.h:445
adc_type::vmlb
__IO uint32_t vmlb
Definition: at32f413_adc.h:408
adc_type::osn5
__IO uint32_t osn5
Definition: at32f413_adc.h:463
adc_type::pdt2
__IO uint32_t pdt2
Definition: at32f413_adc.h:504
adc_type::cspt4
__IO uint32_t cspt4
Definition: at32f413_adc.h:328
adc_type::ocpcnt
__IO uint32_t ocpcnt
Definition: at32f413_adc.h:257
adc_type::osq3
__IO uint32_t osq3
Definition: at32f413_adc.h:456
adc_type::pcautoen
__IO uint32_t pcautoen
Definition: at32f413_adc.h:254
adc_type::cspt2
__IO uint32_t cspt2
Definition: at32f413_adc.h:326
adc_type::cspt17
__IO uint32_t cspt17
Definition: at32f413_adc.h:311
adc_type::cspt11
__IO uint32_t cspt11
Definition: at32f413_adc.h:305
adc_type::pcdto3
__IO uint32_t pcdto3
Definition: at32f413_adc.h:369
adc_type::cspt8
__IO uint32_t cspt8
Definition: at32f413_adc.h:332
adc_type::osn7
__IO uint32_t osn7
Definition: at32f413_adc.h:441
adc_type::pcten
__IO uint32_t pcten
Definition: at32f413_adc.h:283
adc_type::pcswtrg
__IO uint32_t pcswtrg
Definition: at32f413_adc.h:287
adc_type::osn13
__IO uint32_t osn13
Definition: at32f413_adc.h:424
adc_type::cspt3
__IO uint32_t cspt3
Definition: at32f413_adc.h:327
adc_type::pccs
__IO uint32_t pccs
Definition: at32f413_adc.h:234


AT32F413 Firmwary Library: at32f413_board.c Source File

  • at32f413_board
at32f413_board.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26
36/* delay macros */
37#define STEP_DELAY_MS 50
38
39/* at-start led resouce array */
40 gpio_type *led_gpio_port[LED_NUM] = {LED2_GPIO, LED3_GPIO, LED4_GPIO};
41uint16_t led_gpio_pin[LED_NUM] = {LED2_PIN, LED3_PIN, LED4_PIN};
42 crm_periph_clock_type led_gpio_crm_clk[LED_NUM] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK};
43
44/* delay variable */
45static __IO uint32_t fac_us;
46static __IO uint32_t fac_ms;
47
48/* support printf function, usemicrolib is unnecessary */
49#if (__ARMCC_VERSION > 6000000)
50 __asm (".global __use_no_semihosting\n\t");
51 void _sys_exit(int x)
52 {
53 x = x;
54 }
55 /* __use_no_semihosting was requested, but _ttywrch was */
56 void _ttywrch(int ch)
57 {
58 ch = ch;
59 }
60 FILE __stdout;
61#else
62 #ifdef __CC_ARM
63 #pragma import(__use_no_semihosting)
64 struct __FILE
65 {
66 int handle;
67 };
68 FILE __stdout;
69 void _sys_exit(int x)
70 {
71 x = x;
72 }
73 /* __use_no_semihosting was requested, but _ttywrch was */
74 void _ttywrch(int ch)
75 {
76 ch = ch;
77 }
78 #endif
79#endif
80
81#if defined (__GNUC__) && !defined (__clang__)
82 #define PUTCHAR_PROTOTYPE int __io_putchar(int ch)
83#else
84 #define PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)
85#endif
86
92 PUTCHAR_PROTOTYPE
93{
94 while(usart_flag_get(PRINT_UART, USART_TDBE_FLAG) == RESET);
95 usart_data_transmit(PRINT_UART, (uint16_t)ch);
96 while(usart_flag_get(PRINT_UART, USART_TDC_FLAG) == RESET);
97 return ch;
98}
99
100#if (defined (__GNUC__) && !defined (__clang__)) || (defined (__ICCARM__))
101#if defined (__GNUC__) && !defined (__clang__)
102int _write(int fd, char *pbuffer, int size)
103#elif defined ( __ICCARM__ )
104#pragma module_name = "?__write"
105int __write(int fd, char *pbuffer, int size)
106#endif
107{
108 for(int i = 0; i < size; i ++)
109 {
110 while(usart_flag_get(PRINT_UART, USART_TDBE_FLAG) == RESET);
111 usart_data_transmit(PRINT_UART, (uint16_t)(*pbuffer++));
112 while(usart_flag_get(PRINT_UART, USART_TDC_FLAG) == RESET);
113 }
114
115 return size;
116}
117#endif
118
124void uart_print_init(uint32_t baudrate)
125{
126 gpio_init_type gpio_init_struct;
127
128#if defined (__GNUC__) && !defined (__clang__)
129 setvbuf(stdout, NULL, _IONBF, 0);
130#endif
131
132 /* enable the uart and gpio clock */
133 crm_periph_clock_enable(PRINT_UART_CRM_CLK, TRUE);
134 crm_periph_clock_enable(PRINT_UART_TX_GPIO_CRM_CLK, TRUE);
135
136 gpio_default_para_init(&gpio_init_struct);
137
138 /* configure the uart tx pin */
139 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
140 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
141 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
142 gpio_init_struct.gpio_pins = PRINT_UART_TX_PIN;
143 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
144 gpio_init(PRINT_UART_TX_GPIO, &gpio_init_struct);
145
146 /* configure uart param */
147 usart_init(PRINT_UART, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
148 usart_transmitter_enable(PRINT_UART, TRUE);
149 usart_enable(PRINT_UART, TRUE);
150}
151
157void at32_board_init()
158{
159 /* initialize delay function */
160 delay_init();
161
162 /* configure led in at_start_board */
163 at32_led_init(LED2);
164 at32_led_init(LED3);
165 at32_led_init(LED4);
166 at32_led_off(LED2);
167 at32_led_off(LED3);
168 at32_led_off(LED4);
169
170 /* configure button in at_start board */
171 at32_button_init();
172}
173
179void at32_button_init(void)
180{
181 gpio_init_type gpio_init_struct;
182
183 /* enable the button clock */
184 crm_periph_clock_enable(USER_BUTTON_CRM_CLK, TRUE);
185
186 /* set default parameter */
187 gpio_default_para_init(&gpio_init_struct);
188
189 /* configure button pin as input with pull-up/pull-down */
190 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
191 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
192 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
193 gpio_init_struct.gpio_pins = USER_BUTTON_PIN;
194 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
195 gpio_init(USER_BUTTON_PORT, &gpio_init_struct);
196}
197
203uint8_t at32_button_state(void)
204{
205 return gpio_input_data_bit_read(USER_BUTTON_PORT, USER_BUTTON_PIN);
206}
207
213 button_type at32_button_press()
214{
215 static uint8_t pressed = 1;
216 /* get button state in at_start board */
217 if((pressed == 1) && (at32_button_state() != RESET))
218 {
219 /* debounce */
220 pressed = 0;
221 delay_ms(10);
222 if(at32_button_state() != RESET)
223 return USER_BUTTON;
224 }
225 else if(at32_button_state() == RESET)
226 {
227 pressed = 1;
228 }
229 return NO_BUTTON;
230}
231
237void at32_led_init(led_type led)
238{
239 gpio_init_type gpio_init_struct;
240
241 /* enable the led clock */
242 crm_periph_clock_enable(led_gpio_crm_clk[led], TRUE);
243
244 /* set default parameter */
245 gpio_default_para_init(&gpio_init_struct);
246
247 /* configure the led gpio */
248 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
249 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
250 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
251 gpio_init_struct.gpio_pins = led_gpio_pin[led];
252 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
253 gpio_init(led_gpio_port[led], &gpio_init_struct);
254}
255
265void at32_led_on(led_type led)
266{
267 if(led > (LED_NUM - 1))
268 return;
269 if(led_gpio_pin[led])
270 led_gpio_port[led]->clr = led_gpio_pin[led];
271}
272
282void at32_led_off(led_type led)
283{
284 if(led > (LED_NUM - 1))
285 return;
286 if(led_gpio_pin[led])
287 led_gpio_port[led]->scr = led_gpio_pin[led];
288}
289
299void at32_led_toggle(led_type led)
300{
301 if(led > (LED_NUM - 1))
302 return;
303 if(led_gpio_pin[led])
304 led_gpio_port[led]->odt ^= led_gpio_pin[led];
305}
306
312void delay_init()
313{
314 /* configure systick */
315 systick_clock_source_config(SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV);
316 fac_us = system_core_clock / (1000000U);
317 fac_ms = fac_us * (1000U);
318}
319
325void delay_us(uint32_t nus)
326{
327 uint32_t temp = 0;
328 SysTick->LOAD = (uint32_t)(nus * fac_us);
329 SysTick->VAL = 0x00;
330 SysTick->CTRL |= SysTick_CTRL_ENABLE_Msk ;
331 do
332 {
333 temp = SysTick->CTRL;
334 }while((temp & 0x01) && !(temp & (1 << 16)));
335
336 SysTick->CTRL &= ~SysTick_CTRL_ENABLE_Msk;
337 SysTick->VAL = 0x00;
338}
339
345void delay_ms(uint16_t nms)
346{
347 uint32_t temp = 0;
348 while(nms)
349 {
350 if(nms > STEP_DELAY_MS)
351 {
352 SysTick->LOAD = (uint32_t)(STEP_DELAY_MS * fac_ms);
353 nms -= STEP_DELAY_MS;
354 }
355 else
356 {
357 SysTick->LOAD = (uint32_t)(nms * fac_ms);
358 nms = 0;
359 }
360 SysTick->VAL = 0x00;
361 SysTick->CTRL |= SysTick_CTRL_ENABLE_Msk;
362 do
363 {
364 temp = SysTick->CTRL;
365 }while((temp & 0x01) && !(temp & (1 << 16)));
366
367 SysTick->CTRL &= ~SysTick_CTRL_ENABLE_Msk;
368 SysTick->VAL = 0x00;
369 }
370}
371
377void delay_sec(uint16_t sec)
378{
379 uint16_t index;
380 for(index = 0; index < sec; index++)
381 {
382 delay_ms(500);
383 delay_ms(500);
384 }
385}
386
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
USER_BUTTON_PORT
#define USER_BUTTON_PORT
Definition: at32f413_board.h:97
PRINT_UART_CRM_CLK
#define PRINT_UART_CRM_CLK
Definition: at32f413_board.h:84
USER_BUTTON_PIN
#define USER_BUTTON_PIN
Definition: at32f413_board.h:96
PRINT_UART_TX_PIN
#define PRINT_UART_TX_PIN
Definition: at32f413_board.h:85
LED_NUM
#define LED_NUM
Definition: at32f413_board.h:66
led_type
led_type
Definition: at32f413_board.h:60
PRINT_UART
#define PRINT_UART
Definition: at32f413_board.h:83
PRINT_UART_TX_GPIO
#define PRINT_UART_TX_GPIO
Definition: at32f413_board.h:86
USER_BUTTON_CRM_CLK
#define USER_BUTTON_CRM_CLK
Definition: at32f413_board.h:98
PRINT_UART_TX_GPIO_CRM_CLK
#define PRINT_UART_TX_GPIO_CRM_CLK
Definition: at32f413_board.h:87
button_type
button_type
Definition: at32f413_board.h:91
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:93
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
led_gpio_port
gpio_type * led_gpio_port[3]
Definition: at32f413_board.c:40
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
fac_ms
static __IO uint32_t fac_ms
Definition: at32f413_board.c:46
led_gpio_pin
uint16_t led_gpio_pin[3]
Definition: at32f413_board.c:41
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:237
delay_init
void delay_init()
initialize delay function
Definition: at32f413_board.c:312
at32_button_state
uint8_t at32_button_state(void)
returns the selected button state
Definition: at32f413_board.c:203
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
STEP_DELAY_MS
#define STEP_DELAY_MS
Definition: at32f413_board.c:37
led_gpio_crm_clk
crm_periph_clock_type led_gpio_crm_clk[3]
Definition: at32f413_board.c:42
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
PUTCHAR_PROTOTYPE
#define PUTCHAR_PROTOTYPE
Definition: at32f413_board.c:84
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
at32_button_init
void at32_button_init(void)
configure button gpio
Definition: at32f413_board.c:179
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
fac_us
static __IO uint32_t fac_us
Definition: at32f413_board.c:45
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f413_crm.h:100
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:201
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:145
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:88
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:56
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:298
gpio_type::scr
__IO uint32_t scr
Definition: at32f413_gpio.h:414
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:386
gpio_type::clr
__IO uint32_t clr
Definition: at32f413_gpio.h:457


AT32F413 Firmwary Library: at32f413_board.h Source File

  • at32f413_board
at32f413_board.h
Go to the documentation of this file.
1
26#ifndef __AT32F413_BOARD_H
27#define __AT32F413_BOARD_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "stdio.h"
34#include "at32f413.h"
35
54#if !defined (AT_START_F413_V1)
55#error "please select first the board at-start device used in your application (in at32f413_board.h file)"
56#endif
57
58/******************** define led ********************/
59typedef enum
60{
61 LED2 = 0,
62 LED3 = 1,
63 LED4 = 2
64} led_type;
65
66#define LED_NUM 3
67
68#if defined (AT_START_F413_V1)
69#define LED2_PIN GPIO_PINS_2
70#define LED2_GPIO GPIOC
71#define LED2_GPIO_CRM_CLK CRM_GPIOC_PERIPH_CLOCK
72
73#define LED3_PIN GPIO_PINS_3
74#define LED3_GPIO GPIOC
75#define LED3_GPIO_CRM_CLK CRM_GPIOC_PERIPH_CLOCK
76
77#define LED4_PIN GPIO_PINS_5
78#define LED4_GPIO GPIOC
79#define LED4_GPIO_CRM_CLK CRM_GPIOC_PERIPH_CLOCK
80#endif
81
82/**************** define print uart ******************/
83#define PRINT_UART USART1
84#define PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
85#define PRINT_UART_TX_PIN GPIO_PINS_9
86#define PRINT_UART_TX_GPIO GPIOA
87#define PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
88
89/******************* define button *******************/
90typedef enum
91{
92 USER_BUTTON = 0,
93 NO_BUTTON = 1
94} button_type;
95
96#define USER_BUTTON_PIN GPIO_PINS_0
97#define USER_BUTTON_PORT GPIOA
98#define USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
99
108/******************** functions ********************/
109void at32_board_init(void);
110
111/* led operation function */
112void at32_led_init(led_type led);
113void at32_led_on(led_type led);
114void at32_led_off(led_type led);
115void at32_led_toggle(led_type led);
116
117/* button operation function */
118void at32_button_init(void);
119 button_type at32_button_press(void);
120uint8_t at32_button_state(void);
121
122/* delay function */
123void delay_init(void);
124void delay_us(uint32_t nus);
125void delay_ms(uint16_t nms);
126void delay_sec(uint16_t sec);
127
128/* printf uart init function */
129void uart_print_init(uint32_t baudrate);
130
143#ifdef __cplusplus
144}
145#endif
146
147#endif
148
at32f413.h
at32f413 header file
at32_board_init
void at32_board_init(void)
board initialize interface init led and button
Definition: at32f413_board.c:157
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:237
at32_button_state
uint8_t at32_button_state(void)
returns the selected button state
Definition: at32f413_board.c:203
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_button_press
button_type at32_button_press(void)
returns which button have press down
Definition: at32f413_board.c:213
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
at32_button_init
void at32_button_init(void)
configure button gpio
Definition: at32f413_board.c:179
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
delay_init
void delay_init(void)
initialize delay function
Definition: at32f413_board.c:312
led_type
led_type
Definition: at32f413_board.h:60
button_type
button_type
Definition: at32f413_board.h:91
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:93
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92


AT32F413 Firmwary Library: at32f413_bpr.c Source File

  • libraries
  • drivers
  • src
at32f413_bpr.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef BPR_MODULE_ENABLED
37
47void bpr_reset(void)
48{
49 crm_battery_powered_domain_reset(TRUE);
50 crm_battery_powered_domain_reset(FALSE);
51}
52
61 flag_status bpr_flag_get(uint32_t flag)
62{
63 if(flag == BPR_TAMPER_INTERRUPT_FLAG)
64 {
65 return (flag_status)(BPR->ctrlsts_bit.tpif);
66 }
67 else
68 {
69 return (flag_status)(BPR->ctrlsts_bit.tpef);
70 }
71}
72
81void bpr_flag_clear(uint32_t flag)
82{
83 if(flag == BPR_TAMPER_INTERRUPT_FLAG)
84 {
85 BPR->ctrlsts_bit.tpifclr = TRUE;
86 }
87 else
88 {
89 BPR->ctrlsts_bit.tpefclr = TRUE;
90 }
91}
92
98void bpr_interrupt_enable(confirm_state new_state)
99{
100 BPR->ctrlsts_bit.tpien = new_state;
101}
102
114uint16_t bpr_data_read(bpr_data_type bpr_data)
115{
116 return (*(__IO uint16_t *)(BPR_BASE + bpr_data));
117}
118
131void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
132{
133 (*(__IO uint32_t *)(BPR_BASE + bpr_data)) = data_value;
134}
135
149void bpr_rtc_output_select(bpr_rtc_output_type output_source)
150{
151 /* clear cco,asoe,asos,ccos,togen bits */
152 BPR->rtccal &= (uint32_t)~0x0F80;
153
154 /* set output_source value */
155 BPR->rtccal |= output_source;
156}
157
163void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value)
164{
165 /* set rtc clock calibration value */
166 BPR->rtccal_bit.calval= calibration_value;
167}
168
174void bpr_tamper_pin_enable(confirm_state new_state)
175{
176 BPR->ctrl_bit.tpen = new_state;
177}
178
187void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
188{
189 BPR->ctrl_bit.tpp = active_level;
190}
191
196#endif
197
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:65
bpr_tamper_pin_active_level_type
bpr_tamper_pin_active_level_type
tamper pin active level type
Definition: at32f413_bpr.h:128
bpr_rtc_output_type
bpr_rtc_output_type
bpr rtc output type
Definition: at32f413_bpr.h:114
BPR_TAMPER_INTERRUPT_FLAG
#define BPR_TAMPER_INTERRUPT_FLAG
Definition: at32f413_bpr.h:50
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
bpr_rtc_clock_calibration_value_set
void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value)
set rtc clock calibration value
Definition: at32f413_bpr.c:163
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:174
bpr_interrupt_enable
void bpr_interrupt_enable(confirm_state new_state)
enable or disable bpr tamper interrupt
Definition: at32f413_bpr.c:98
bpr_rtc_output_select
void bpr_rtc_output_select(bpr_rtc_output_type output_source)
select bpr rtc output
Definition: at32f413_bpr.c:149
bpr_tamper_pin_active_level_set
void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level
Definition: at32f413_bpr.c:187
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:114
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:81
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:131
bpr_flag_get
flag_status bpr_flag_get(uint32_t flag)
bpr event flag get, for tamper event flag
Definition: at32f413_bpr.c:61
BPR
#define BPR
Definition: at32f413_bpr.h:754
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f413_crm.c:495
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
BPR_BASE
#define BPR_BASE
Definition: at32f413.h:358
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_bpr.h Source File

  • libraries
  • drivers
  • inc
at32f413_bpr.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_BPR_H
27#define __AT32F413_BPR_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)
51#define BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)
64typedef enum
65{
66 BPR_DATA1 = 0x04,
67 BPR_DATA2 = 0x08,
68 BPR_DATA3 = 0x0C,
69 BPR_DATA4 = 0x10,
70 BPR_DATA5 = 0x14,
71 BPR_DATA6 = 0x18,
72 BPR_DATA7 = 0x1C,
73 BPR_DATA8 = 0x20,
74 BPR_DATA9 = 0x24,
75 BPR_DATA10 = 0x28,
76 BPR_DATA11 = 0x40,
77 BPR_DATA12 = 0x44,
78 BPR_DATA13 = 0x48,
79 BPR_DATA14 = 0x4C,
80 BPR_DATA15 = 0x50,
81 BPR_DATA16 = 0x54,
82 BPR_DATA17 = 0x58,
83 BPR_DATA18 = 0x5C,
84 BPR_DATA19 = 0x60,
85 BPR_DATA20 = 0x64,
86 BPR_DATA21 = 0x68,
87 BPR_DATA22 = 0x6C,
88 BPR_DATA23 = 0x70,
89 BPR_DATA24 = 0x74,
90 BPR_DATA25 = 0x78,
91 BPR_DATA26 = 0x7C,
92 BPR_DATA27 = 0x80,
93 BPR_DATA28 = 0x84,
94 BPR_DATA29 = 0x88,
95 BPR_DATA30 = 0x8C,
96 BPR_DATA31 = 0x90,
97 BPR_DATA32 = 0x94,
98 BPR_DATA33 = 0x98,
99 BPR_DATA34 = 0x9C,
100 BPR_DATA35 = 0xA0,
101 BPR_DATA36 = 0xA4,
102 BPR_DATA37 = 0xA8,
103 BPR_DATA38 = 0xAC,
104 BPR_DATA39 = 0xB0,
105 BPR_DATA40 = 0xB4,
106 BPR_DATA41 = 0xB8,
107 BPR_DATA42 = 0xBC
108} bpr_data_type;
109
113typedef enum
114{
115 BPR_RTC_OUTPUT_NONE = 0x000,
116 BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE = 0x080,
117 BPR_RTC_OUTPUT_ALARM = 0x100,
118 BPR_RTC_OUTPUT_SECOND = 0x300,
119 BPR_RTC_OUTPUT_CLOCK_CAL_AFTER = 0x480,
120 BPR_RTC_OUTPUT_ALARM_TOGGLE = 0x900,
121 BPR_RTC_OUTPUT_SECOND_TOGGLE = 0xB00
122} bpr_rtc_output_type;
123
127typedef enum
128{
129 BPR_TAMPER_PIN_ACTIVE_HIGH = 0x00,
130 BPR_TAMPER_PIN_ACTIVE_LOW = 0x01
131} bpr_tamper_pin_active_level_type;
132
136typedef struct
137{
141 __IO uint32_t reserved1;
142
146 union
147 {
148 __IO uint32_t dt1;
149 struct
150 {
151 __IO uint32_t dt : 16;/* [15:0] */
152 __IO uint32_t reserved1 : 16;/* [31:15] */
153 } dt1_bit;
154 };
155
159 union
160 {
161 __IO uint32_t dt2;
162 struct
163 {
164 __IO uint32_t dt : 16;/* [15:0] */
165 __IO uint32_t reserved1 : 16;/* [31:15] */
166 } dt2_bit;
167 };
168
172 union
173 {
174 __IO uint32_t dt3;
175 struct
176 {
177 __IO uint32_t dt : 16;/* [15:0] */
178 __IO uint32_t reserved1 : 16;/* [31:15] */
179 } dt3_bit;
180 };
181
185 union
186 {
187 __IO uint32_t dt4;
188 struct
189 {
190 __IO uint32_t dt : 16;/* [15:0] */
191 __IO uint32_t reserved1 : 16;/* [31:15] */
192 } dt4_bit;
193 };
194
198 union
199 {
200 __IO uint32_t dt5;
201 struct
202 {
203 __IO uint32_t dt : 16;/* [15:0] */
204 __IO uint32_t reserved1 : 16;/* [31:15] */
205 } dt5_bit;
206 };
207
211 union
212 {
213 __IO uint32_t dt6;
214 struct
215 {
216 __IO uint32_t dt : 16;/* [15:0] */
217 __IO uint32_t reserved1 : 16;/* [31:15] */
218 } dt6_bit;
219 };
220
224 union
225 {
226 __IO uint32_t dt7;
227 struct
228 {
229 __IO uint32_t dt : 16;/* [15:0] */
230 __IO uint32_t reserved1 : 16;/* [31:15] */
231 } dt7_bit;
232 };
233
237 union
238 {
239 __IO uint32_t dt8;
240 struct
241 {
242 __IO uint32_t dt : 16;/* [15:0] */
243 __IO uint32_t reserved1 : 16;/* [31:15] */
244 } dt8_bit;
245 };
246
250 union
251 {
252 __IO uint32_t dt9;
253 struct
254 {
255 __IO uint32_t dt : 16;/* [15:0] */
256 __IO uint32_t reserved1 : 16;/* [31:15] */
257 } dt9_bit;
258 };
259
263 union
264 {
265 __IO uint32_t dt10;
266 struct
267 {
268 __IO uint32_t dt : 16;/* [15:0] */
269 __IO uint32_t reserved1 : 16;/* [31:15] */
270 } dt10_bit;
271 };
272
276 union
277 {
278 __IO uint32_t rtccal;
279 struct
280 {
281 __IO uint32_t calval : 7; /* [6:0] */
282 __IO uint32_t calout : 1; /* [7] */
283 __IO uint32_t outen : 1; /* [8] */
284 __IO uint32_t outsel : 1; /* [9] */
285 __IO uint32_t ccos : 1; /* [10] */
286 __IO uint32_t outm : 1; /* [11] */
287 __IO uint32_t reserved1 : 20;/* [31:12] */
288 } rtccal_bit;
289 };
290
294 union
295 {
296 __IO uint32_t ctrl;
297 struct
298 {
299 __IO uint32_t tpen : 1; /* [0] */
300 __IO uint32_t tpp : 1; /* [1] */
301 __IO uint32_t reserved1 : 30;/* [31:2] */
302 } ctrl_bit;
303 };
304
308 union
309 {
310 __IO uint32_t ctrlsts;
311 struct
312 {
313 __IO uint32_t tpefclr : 1;/* [0] */
314 __IO uint32_t tpifclr : 1;/* [1] */
315 __IO uint32_t tpien : 1;/* [2] */
316 __IO uint32_t reserved1 : 5;/* [7:3] */
317 __IO uint32_t tpef : 1;/* [8] */
318 __IO uint32_t tpif : 1;/* [9] */
319 __IO uint32_t reserved2 : 22;/* [31:10] */
320 } ctrlsts_bit;
321 };
322
326 __IO uint32_t reserved2;
327
331 __IO uint32_t reserved3;
332
336 union
337 {
338 __IO uint32_t dt11;
339 struct
340 {
341 __IO uint32_t dt : 16;/* [15:0] */
342 __IO uint32_t reserved1 : 16;/* [31:15] */
343 } dt11_bit;
344 };
345
349 union
350 {
351 __IO uint32_t dt12;
352 struct
353 {
354 __IO uint32_t dt : 16;/* [15:0] */
355 __IO uint32_t reserved1 : 16;/* [31:15] */
356 } dt12_bit;
357 };
358
362 union
363 {
364 __IO uint32_t dt13;
365 struct
366 {
367 __IO uint32_t dt : 16;/* [15:0] */
368 __IO uint32_t reserved1 : 16;/* [31:15] */
369 } dt13_bit;
370 };
371
375 union
376 {
377 __IO uint32_t dt14;
378 struct
379 {
380 __IO uint32_t dt : 16;/* [15:0] */
381 __IO uint32_t reserved1 : 16;/* [31:15] */
382 } dt14_bit;
383 };
384
388 union
389 {
390 __IO uint32_t dt15;
391 struct
392 {
393 __IO uint32_t dt : 16;/* [15:0] */
394 __IO uint32_t reserved1 : 16;/* [31:15] */
395 } dt15_bit;
396 };
397
401 union
402 {
403 __IO uint32_t dt16;
404 struct
405 {
406 __IO uint32_t dt : 16;/* [15:0] */
407 __IO uint32_t reserved1 : 16;/* [31:15] */
408 } dt16_bit;
409 };
410
414 union
415 {
416 __IO uint32_t dt17;
417 struct
418 {
419 __IO uint32_t dt : 16;/* [15:0] */
420 __IO uint32_t reserved1 : 16;/* [31:15] */
421 } dt17_bit;
422 };
423
427 union
428 {
429 __IO uint32_t dt18;
430 struct
431 {
432 __IO uint32_t dt : 16;/* [15:0] */
433 __IO uint32_t reserved1 : 16;/* [31:15] */
434 } dt18_bit;
435 };
436
440 union
441 {
442 __IO uint32_t dt19;
443 struct
444 {
445 __IO uint32_t dt : 16;/* [15:0] */
446 __IO uint32_t reserved1 : 16;/* [31:15] */
447 } dt19_bit;
448 };
449
453 union
454 {
455 __IO uint32_t dt20;
456 struct
457 {
458 __IO uint32_t dt : 16;/* [15:0] */
459 __IO uint32_t reserved1 : 16;/* [31:15] */
460 } dt20_bit;
461 };
462
466 union
467 {
468 __IO uint32_t dt21;
469 struct
470 {
471 __IO uint32_t dt : 16;/* [15:0] */
472 __IO uint32_t reserved1 : 16;/* [31:15] */
473 } dt21_bit;
474 };
475
479 union
480 {
481 __IO uint32_t dt22;
482 struct
483 {
484 __IO uint32_t dt : 16;/* [15:0] */
485 __IO uint32_t reserved1 : 16;/* [31:15] */
486 } dt22_bit;
487 };
488
492 union
493 {
494 __IO uint32_t dt23;
495 struct
496 {
497 __IO uint32_t dt : 16;/* [15:0] */
498 __IO uint32_t reserved1 : 16;/* [31:15] */
499 } dt23_bit;
500 };
501
505 union
506 {
507 __IO uint32_t dt24;
508 struct
509 {
510 __IO uint32_t dt : 16;/* [15:0] */
511 __IO uint32_t reserved1 : 16;/* [31:15] */
512 } dt24_bit;
513 };
514
518 union
519 {
520 __IO uint32_t dt25;
521 struct
522 {
523 __IO uint32_t dt : 16;/* [15:0] */
524 __IO uint32_t reserved1 : 16;/* [31:15] */
525 } dt25_bit;
526 };
527
531 union
532 {
533 __IO uint32_t dt26;
534 struct
535 {
536 __IO uint32_t dt : 16;/* [15:0] */
537 __IO uint32_t reserved1 : 16;/* [31:15] */
538 } dt26_bit;
539 };
540
544 union
545 {
546 __IO uint32_t dt27;
547 struct
548 {
549 __IO uint32_t dt : 16;/* [15:0] */
550 __IO uint32_t reserved1 : 16;/* [31:15] */
551 } dt27_bit;
552 };
553
557 union
558 {
559 __IO uint32_t dt28;
560 struct
561 {
562 __IO uint32_t dt : 16;/* [15:0] */
563 __IO uint32_t reserved1 : 16;/* [31:15] */
564 } dt28_bit;
565 };
566
570 union
571 {
572 __IO uint32_t dt29;
573 struct
574 {
575 __IO uint32_t dt : 16;/* [15:0] */
576 __IO uint32_t reserved1 : 16;/* [31:15] */
577 } dt29_bit;
578 };
579
583 union
584 {
585 __IO uint32_t dt30;
586 struct
587 {
588 __IO uint32_t dt : 16;/* [15:0] */
589 __IO uint32_t reserved1 : 16;/* [31:15] */
590 } dt30_bit;
591 };
592
596 union
597 {
598 __IO uint32_t dt31;
599 struct
600 {
601 __IO uint32_t dt : 16;/* [15:0] */
602 __IO uint32_t reserved1 : 16;/* [31:15] */
603 } dt31_bit;
604 };
605
609 union
610 {
611 __IO uint32_t dt32;
612 struct
613 {
614 __IO uint32_t dt : 16;/* [15:0] */
615 __IO uint32_t reserved1 : 16;/* [31:15] */
616 } dt32_bit;
617 };
618
622 union
623 {
624 __IO uint32_t dt33;
625 struct
626 {
627 __IO uint32_t dt : 16;/* [15:0] */
628 __IO uint32_t reserved1 : 16;/* [31:15] */
629 } dt33_bit;
630 };
631
635 union
636 {
637 __IO uint32_t dt34;
638 struct
639 {
640 __IO uint32_t dt : 16;/* [15:0] */
641 __IO uint32_t reserved1 : 16;/* [31:15] */
642 } dt34_bit;
643 };
644
648 union
649 {
650 __IO uint32_t dt35;
651 struct
652 {
653 __IO uint32_t dt : 16;/* [15:0] */
654 __IO uint32_t reserved1 : 16;/* [31:15] */
655 } dt35_bit;
656 };
657
661 union
662 {
663 __IO uint32_t dt36;
664 struct
665 {
666 __IO uint32_t dt : 16;/* [15:0] */
667 __IO uint32_t reserved1 : 16;/* [31:15] */
668 } dt36_bit;
669 };
670
674 union
675 {
676 __IO uint32_t dt37;
677 struct
678 {
679 __IO uint32_t dt : 16;/* [15:0] */
680 __IO uint32_t reserved1 : 16;/* [31:15] */
681 } dt37_bit;
682 };
683
687 union
688 {
689 __IO uint32_t dt38;
690 struct
691 {
692 __IO uint32_t dt : 16;/* [15:0] */
693 __IO uint32_t reserved1 : 16;/* [31:15] */
694 } dt38_bit;
695 };
696
700 union
701 {
702 __IO uint32_t dt39;
703 struct
704 {
705 __IO uint32_t dt : 16;/* [15:0] */
706 __IO uint32_t reserved1 : 16;/* [31:15] */
707 } dt39_bit;
708 };
709
713 union
714 {
715 __IO uint32_t dt40;
716 struct
717 {
718 __IO uint32_t dt : 16;/* [15:0] */
719 __IO uint32_t reserved1 : 16;/* [31:15] */
720 } dt40_bit;
721 };
722
726 union
727 {
728 __IO uint32_t dt41;
729 struct
730 {
731 __IO uint32_t dt : 16;/* [15:0] */
732 __IO uint32_t reserved1 : 16;/* [31:15] */
733 } dt41_bit;
734 };
735
739 union
740 {
741 __IO uint32_t dt42;
742 struct
743 {
744 __IO uint32_t dt : 16;/* [15:0] */
745 __IO uint32_t reserved1 : 16;/* [31:15] */
746 } dt42_bit;
747 };
748} bpr_type;
749
754#define BPR ((bpr_type *) BPR_BASE)
755
760void bpr_reset(void);
761 flag_status bpr_flag_get(uint32_t flag);
762void bpr_flag_clear(uint32_t flag);
763void bpr_interrupt_enable(confirm_state new_state);
764uint16_t bpr_data_read(bpr_data_type bpr_data);
765void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value);
766void bpr_rtc_output_select(bpr_rtc_output_type output_source);
767void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value);
768void bpr_tamper_pin_enable(confirm_state new_state);
769void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level);
770
783#ifdef __cplusplus
784}
785#endif
786
787#endif
at32f413.h
at32f413 header file
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
bpr_rtc_clock_calibration_value_set
void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value)
set rtc clock calibration value
Definition: at32f413_bpr.c:163
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:174
bpr_interrupt_enable
void bpr_interrupt_enable(confirm_state new_state)
enable or disable bpr tamper interrupt
Definition: at32f413_bpr.c:98
bpr_rtc_output_select
void bpr_rtc_output_select(bpr_rtc_output_type output_source)
select bpr rtc output
Definition: at32f413_bpr.c:149
bpr_tamper_pin_active_level_set
void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level
Definition: at32f413_bpr.c:187
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:114
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:81
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:131
bpr_flag_get
flag_status bpr_flag_get(uint32_t flag)
bpr event flag get, for tamper event flag
Definition: at32f413_bpr.c:61
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:65
bpr_tamper_pin_active_level_type
bpr_tamper_pin_active_level_type
tamper pin active level type
Definition: at32f413_bpr.h:128
bpr_rtc_output_type
bpr_rtc_output_type
bpr rtc output type
Definition: at32f413_bpr.h:114
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:91
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:93
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:96
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:73
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:90
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:104
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:72
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:77
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:94
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:84
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:66
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:101
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:74
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:75
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:92
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:85
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:103
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:102
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:106
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:78
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:69
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:97
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:81
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:76
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:89
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:88
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:70
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:83
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:82
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:107
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:86
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:98
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:105
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:95
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:67
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:79
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:80
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:68
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:87
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:99
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:100
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:71
BPR_TAMPER_PIN_ACTIVE_LOW
@ BPR_TAMPER_PIN_ACTIVE_LOW
Definition: at32f413_bpr.h:130
BPR_TAMPER_PIN_ACTIVE_HIGH
@ BPR_TAMPER_PIN_ACTIVE_HIGH
Definition: at32f413_bpr.h:129
BPR_RTC_OUTPUT_NONE
@ BPR_RTC_OUTPUT_NONE
Definition: at32f413_bpr.h:115
BPR_RTC_OUTPUT_ALARM
@ BPR_RTC_OUTPUT_ALARM
Definition: at32f413_bpr.h:117
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER
@ BPR_RTC_OUTPUT_CLOCK_CAL_AFTER
Definition: at32f413_bpr.h:119
BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE
@ BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE
Definition: at32f413_bpr.h:116
BPR_RTC_OUTPUT_SECOND
@ BPR_RTC_OUTPUT_SECOND
Definition: at32f413_bpr.h:118
BPR_RTC_OUTPUT_SECOND_TOGGLE
@ BPR_RTC_OUTPUT_SECOND_TOGGLE
Definition: at32f413_bpr.h:121
BPR_RTC_OUTPUT_ALARM_TOGGLE
@ BPR_RTC_OUTPUT_ALARM_TOGGLE
Definition: at32f413_bpr.h:120
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
bpr_type
type define bpr register all
Definition: at32f413_bpr.h:137
bpr_type::dt14
__IO uint32_t dt14
Definition: at32f413_bpr.h:377
bpr_type::dt32
__IO uint32_t dt32
Definition: at32f413_bpr.h:611
bpr_type::dt22
__IO uint32_t dt22
Definition: at32f413_bpr.h:481
bpr_type::reserved2
__IO uint32_t reserved2
reserved, offset:0x38
Definition: at32f413_bpr.h:319
bpr_type::dt17
__IO uint32_t dt17
Definition: at32f413_bpr.h:416
bpr_type::dt24
__IO uint32_t dt24
Definition: at32f413_bpr.h:507
bpr_type::outen
__IO uint32_t outen
Definition: at32f413_bpr.h:283
bpr_type::ccos
__IO uint32_t ccos
Definition: at32f413_bpr.h:285
bpr_type::dt11
__IO uint32_t dt11
Definition: at32f413_bpr.h:338
bpr_type::dt35
__IO uint32_t dt35
Definition: at32f413_bpr.h:650
bpr_type::dt30
__IO uint32_t dt30
Definition: at32f413_bpr.h:585
bpr_type::tpp
__IO uint32_t tpp
Definition: at32f413_bpr.h:300
bpr_type::dt19
__IO uint32_t dt19
Definition: at32f413_bpr.h:442
bpr_type::tpif
__IO uint32_t tpif
Definition: at32f413_bpr.h:318
bpr_type::dt38
__IO uint32_t dt38
Definition: at32f413_bpr.h:689
bpr_type::tpifclr
__IO uint32_t tpifclr
Definition: at32f413_bpr.h:314
bpr_type::dt8
__IO uint32_t dt8
Definition: at32f413_bpr.h:239
bpr_type::tpien
__IO uint32_t tpien
Definition: at32f413_bpr.h:315
bpr_type::dt25
__IO uint32_t dt25
Definition: at32f413_bpr.h:520
bpr_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_bpr.h:296
bpr_type::dt16
__IO uint32_t dt16
Definition: at32f413_bpr.h:403
bpr_type::dt31
__IO uint32_t dt31
Definition: at32f413_bpr.h:598
bpr_type::dt
__IO uint32_t dt
Definition: at32f413_bpr.h:151
bpr_type::dt37
__IO uint32_t dt37
Definition: at32f413_bpr.h:676
bpr_type::dt39
__IO uint32_t dt39
Definition: at32f413_bpr.h:702
bpr_type::dt34
__IO uint32_t dt34
Definition: at32f413_bpr.h:637
bpr_type::dt20
__IO uint32_t dt20
Definition: at32f413_bpr.h:455
bpr_type::dt1
__IO uint32_t dt1
Definition: at32f413_bpr.h:148
bpr_type::reserved3
__IO uint32_t reserved3
reserved, offset:0x3C
Definition: at32f413_bpr.h:331
bpr_type::tpefclr
__IO uint32_t tpefclr
Definition: at32f413_bpr.h:313
bpr_type::calout
__IO uint32_t calout
Definition: at32f413_bpr.h:282
bpr_type::calval
__IO uint32_t calval
Definition: at32f413_bpr.h:281
bpr_type::dt7
__IO uint32_t dt7
Definition: at32f413_bpr.h:226
bpr_type::dt3
__IO uint32_t dt3
Definition: at32f413_bpr.h:174
bpr_type::dt29
__IO uint32_t dt29
Definition: at32f413_bpr.h:572
bpr_type::dt6
__IO uint32_t dt6
Definition: at32f413_bpr.h:213
bpr_type::dt33
__IO uint32_t dt33
Definition: at32f413_bpr.h:624
bpr_type::dt18
__IO uint32_t dt18
Definition: at32f413_bpr.h:429
bpr_type::dt4
__IO uint32_t dt4
Definition: at32f413_bpr.h:187
bpr_type::dt13
__IO uint32_t dt13
Definition: at32f413_bpr.h:364
bpr_type::tpef
__IO uint32_t tpef
Definition: at32f413_bpr.h:317
bpr_type::dt42
__IO uint32_t dt42
Definition: at32f413_bpr.h:741
bpr_type::dt36
__IO uint32_t dt36
Definition: at32f413_bpr.h:663
bpr_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f413_bpr.h:310
bpr_type::dt12
__IO uint32_t dt12
Definition: at32f413_bpr.h:351
bpr_type::dt28
__IO uint32_t dt28
Definition: at32f413_bpr.h:559
bpr_type::dt9
__IO uint32_t dt9
Definition: at32f413_bpr.h:252
bpr_type::outsel
__IO uint32_t outsel
Definition: at32f413_bpr.h:284
bpr_type::dt15
__IO uint32_t dt15
Definition: at32f413_bpr.h:390
bpr_type::dt21
__IO uint32_t dt21
Definition: at32f413_bpr.h:468
bpr_type::dt26
__IO uint32_t dt26
Definition: at32f413_bpr.h:533
bpr_type::dt10
__IO uint32_t dt10
Definition: at32f413_bpr.h:265
bpr_type::dt2
__IO uint32_t dt2
Definition: at32f413_bpr.h:161
bpr_type::outm
__IO uint32_t outm
Definition: at32f413_bpr.h:286
bpr_type::dt40
__IO uint32_t dt40
Definition: at32f413_bpr.h:715
bpr_type::reserved1
__IO uint32_t reserved1
reserved, offset:0x00
Definition: at32f413_bpr.h:141
bpr_type::dt5
__IO uint32_t dt5
Definition: at32f413_bpr.h:200
bpr_type::tpen
__IO uint32_t tpen
Definition: at32f413_bpr.h:299
bpr_type::dt27
__IO uint32_t dt27
Definition: at32f413_bpr.h:546
bpr_type::rtccal
__IO uint32_t rtccal
Definition: at32f413_bpr.h:278
bpr_type::dt23
__IO uint32_t dt23
Definition: at32f413_bpr.h:494
bpr_type::dt41
__IO uint32_t dt41
Definition: at32f413_bpr.h:728


AT32F413 Firmwary Library: at32f413_can.c Source File

  • libraries
  • drivers
  • src
at32f413_can.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef CAN_MODULE_ENABLED
37
49void can_reset(can_type* can_x)
50{
51 if(can_x == CAN1)
52 {
53 crm_periph_reset(CRM_CAN1_PERIPH_RESET, TRUE);
54 crm_periph_reset(CRM_CAN1_PERIPH_RESET, FALSE);
55 }
56#if defined (AT32F413TBU7) || defined (AT32F413Rx) || defined (AT32F413Cx) || \
57 defined (AT32F413Kx)
58 else if(can_x == CAN2)
59 {
60 crm_periph_reset(CRM_CAN2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_CAN2_PERIPH_RESET, FALSE);
62 }
63#endif
64}
65
71void can_baudrate_default_para_init(can_baudrate_type* can_baudrate_struct)
72{
73 /* reset can baudrate structure parameters values */
74
75 /* baud rate division */
76 can_baudrate_struct->baudrate_div = 1;
77
78 /* resynchronization adjust width */
79 can_baudrate_struct->rsaw_size = CAN_RSAW_2TQ;
80
81 /* bit time segment 1 */
82 can_baudrate_struct->bts1_size = CAN_BTS1_4TQ;
83
84 /* bit time segment 2 */
85 can_baudrate_struct->bts2_size = CAN_BTS2_3TQ;
86}
87
100 error_status can_baudrate_set(can_type* can_x, can_baudrate_type* can_baudrate_struct)
101{
102 error_status status_index = ERROR;
103 uint32_t wait_ack_index = 0x00000000;
104 /* exit from doze mode */
105 can_x->mctrl_bit.dzen = FALSE;
106
107 /* request freeze mode */
108 can_x->mctrl_bit.fzen = TRUE;
109
110 /* wait the acknowledge */
111 while((!can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
112 {
113 wait_ack_index++;
114 }
115
116 /* check acknowledge */
117 if(can_x->msts_bit.fzc)
118 {
119 can_x->btmg_bit.brdiv = can_baudrate_struct->baudrate_div - 1;
120 can_x->btmg_bit.rsaw = can_baudrate_struct->rsaw_size;
121 can_x->btmg_bit.bts1 = can_baudrate_struct->bts1_size;
122 can_x->btmg_bit.bts2 = can_baudrate_struct->bts2_size;
123
124 /* request leave freeze mode */
125 can_x->mctrl_bit.fzen = FALSE;
126
127 /* wait the acknowledge */
128 wait_ack_index = 0;
129 while((can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
130 {
131 wait_ack_index++;
132 }
133
134 /* check acknowledged */
135 if(can_x->msts_bit.fzc)
136 {
137 status_index = ERROR;
138 }
139 else
140 {
141 status_index = SUCCESS ;
142 }
143 }
144 else
145 {
146 status_index = ERROR;
147 }
148
149 /* return the status of baudrate set */
150 return status_index;
151}
152
158void can_default_para_init(can_base_type* can_base_struct)
159{
160 /* reset can init structure parameters values */
161
162 /* initialize the time triggered communication mode */
163 can_base_struct->ttc_enable = FALSE;
164
165 /* initialize the automatic exit bus-off management */
166 can_base_struct->aebo_enable = FALSE;
167
168 /* initialize the automatic exit doze mode */
169 can_base_struct->aed_enable = FALSE;
170
171 /* initialize the prohibit retransmission when sending fails */
172 can_base_struct->prsf_enable = FALSE;
173
174 /* initialize the message discarding rule select when overflow */
175 can_base_struct->mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
176
177 /* initialize the multiple message sending sequence rule */
178 can_base_struct->mmssr_selection = CAN_SENDING_BY_ID;
179
180 /* initialize the can_mode */
181 can_base_struct->mode_selection = CAN_MODE_COMMUNICATE;
182}
183
195 error_status can_base_init(can_type* can_x, can_base_type* can_base_struct)
196{
197 error_status init_status_index = ERROR;
198 uint32_t wait_ack_index = 0x00000000;
199 /* exit from doze mode */
200 can_x->mctrl_bit.dzen = FALSE;
201
202 /* request freeze mode */
203 can_x->mctrl_bit.fzen = TRUE;
204
205 /* wait the acknowledge */
206 while((!can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
207 {
208 wait_ack_index++;
209 }
210
211 /* check acknowledge */
212 if(can_x->msts_bit.fzc)
213 {
214 /* set the time triggered communication mode */
215 can_x->mctrl_bit.ttcen = can_base_struct->ttc_enable;
216
217 /* set the automatic exit bus-off management */
218 can_x->mctrl_bit.aeboen = can_base_struct->aebo_enable;
219
220 /* set the automatic automatic exit doze mode */
221 can_x->mctrl_bit.aeden = can_base_struct->aed_enable;
222
223 /* set the prohibit retransmission when sending fails */
224 can_x->mctrl_bit.prsfen = can_base_struct->prsf_enable;
225
226 /* set the message discarding rule select when overflow */
227 can_x->mctrl_bit.mdrsel = can_base_struct->mdrsel_selection;
228
229 /* set the multiple message sending sequence rule */
230 can_x->mctrl_bit.mmssr = can_base_struct->mmssr_selection;
231
232 /* set the test mode */
233 can_x->btmg_bit.lben = can_base_struct->mode_selection & 0x01;
234 can_x->btmg_bit.loen = (can_base_struct->mode_selection >> 1) & 0x01;
235
236 /* request leave freeze mode */
237 can_x->mctrl_bit.fzen = FALSE;
238
239 /* wait the acknowledge */
240 wait_ack_index = 0;
241 while((can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
242 {
243 wait_ack_index++;
244 }
245
246 /* check acknowledged */
247 if(can_x->msts_bit.fzc)
248 {
249 init_status_index = ERROR;
250 }
251 else
252 {
253 init_status_index = SUCCESS ;
254 }
255 }
256 else
257 {
258 init_status_index = ERROR;
259 }
260
261 /* return the status of initialization */
262 return init_status_index;
263}
264
270void can_filter_default_para_init(can_filter_init_type* can_filter_init_struct)
271{
272 /* reset can filter init structure parameters values */
273
274 /* initialize the filter activate state */
275 can_filter_init_struct->filter_activate_enable = FALSE;
276
277 /* filter mode */
278 can_filter_init_struct->filter_mode = CAN_FILTER_MODE_ID_MASK;
279
280 /* filter relation fifo select */
281 can_filter_init_struct->filter_fifo = CAN_FILTER_FIFO0;
282
283 /* filter number select */
284 can_filter_init_struct->filter_number = 0;
285
286 /* initialize the filter bit width */
287 can_filter_init_struct->filter_bit = CAN_FILTER_16BIT;
288
289 /* initialize the filters filter data bit */
290 can_filter_init_struct->filter_id_high = 0;
291 can_filter_init_struct->filter_id_low = 0;
292 can_filter_init_struct->filter_mask_high = 0;
293 can_filter_init_struct->filter_mask_low = 0;
294}
295
305void can_filter_init(can_type* can_x, can_filter_init_type* can_filter_init_struct)
306{
307 uint32_t filter_number_bit_pos = 0;
308 filter_number_bit_pos = ((uint32_t)1) << can_filter_init_struct->filter_number;
309 /* set the filter turn into configuration condition */
310 can_x->fctrl_bit.fcs = TRUE;
311
312 /* filter activate disable */
313 can_x->facfg &= ~(uint32_t)filter_number_bit_pos;
314
315 /* filter bit width */
316 switch(can_filter_init_struct->filter_bit)
317 {
318 case CAN_FILTER_16BIT:
319 can_x->fbwcfg &= ~(uint32_t)filter_number_bit_pos;
320 /* first 16-bit identifier and first 16-bit mask or first 16-bit identifier and second 16-bit identifier */
321 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_low) << 16);
322 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_low);
323
324 /* second 16-bit identifier and second 16-bit mask or third 16-bit identifier and fourth 16-bit identifier */
325 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_high) << 16);
326 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_high);
327
328 break;
329 case CAN_FILTER_32BIT:
330 can_x->fbwcfg |= filter_number_bit_pos;
331 /* 32-bit identifier or first 32-bit identifier */
332 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_high) << 16);
333 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_low);
334
335 /* 32-bit mask or second 32-bit identifier */
336 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_high) << 16);
337 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_low);
338
339 break;
340 default:
341 break;
342 }
343
344 /* filter mode */
345 switch(can_filter_init_struct->filter_mode)
346 {
347 case CAN_FILTER_MODE_ID_MASK:
348 can_x->fmcfg &= ~(uint32_t)filter_number_bit_pos;
349 break;
350 case CAN_FILTER_MODE_ID_LIST:
351 can_x->fmcfg |= (uint32_t)filter_number_bit_pos;
352 break;
353 default:
354 break;
355 }
356
357 /* filter relation fifo select */
358 switch(can_filter_init_struct->filter_fifo)
359 {
360 case CAN_FILTER_FIFO0:
361 can_x->frf &= ~(uint32_t)filter_number_bit_pos;
362 break;
363 case CAN_FILTER_FIFO1:
364 can_x->frf |= (uint32_t)filter_number_bit_pos;
365 break;
366 default:
367 break;
368 }
369
370 /* filter activate enable */
371 switch(can_filter_init_struct->filter_activate_enable)
372 {
373 case TRUE:
374 can_x->facfg |= (uint32_t)filter_number_bit_pos;
375 break;
376 case FALSE:
377 can_x->facfg &= ~(uint32_t)filter_number_bit_pos;
378 break;
379 default:
380 break;
381 }
382
383 /* set the filter turn into working condition */
384 can_x->fctrl_bit.fcs = FALSE;
385}
386
396void can_debug_transmission_prohibit(can_type* can_x, confirm_state new_state)
397{
398 can_x->mctrl_bit.ptd = new_state;
399}
400
417void can_ttc_mode_enable(can_type* can_x, confirm_state new_state)
418{
419 /* config the ttc mode new_state */
420 can_x->mctrl_bit.ttcen = new_state;
421
422 /* config tmtsten bits new_state */
423 can_x->tx_mailbox[0].tmc_bit.tmtsten = new_state;
424 can_x->tx_mailbox[1].tmc_bit.tmtsten = new_state;
425 can_x->tx_mailbox[2].tmc_bit.tmtsten = new_state;
426}
427
441uint8_t can_message_transmit(can_type* can_x, can_tx_message_type* tx_message_struct)
442{
443 uint8_t transmit_mailbox = CAN_TX_STATUS_NO_EMPTY;
444
445 /* select one empty transmit mailbox */
446 if(can_x->tsts_bit.tm0ef)
447 {
448 transmit_mailbox = CAN_TX_MAILBOX0;
449 }
450 else if(can_x->tsts_bit.tm1ef)
451 {
452 transmit_mailbox = CAN_TX_MAILBOX1;
453 }
454 else if(can_x->tsts_bit.tm2ef)
455 {
456 transmit_mailbox = CAN_TX_MAILBOX2;
457 }
458 else
459 {
460 transmit_mailbox = CAN_TX_STATUS_NO_EMPTY;
461 }
462
463 if(transmit_mailbox != CAN_TX_STATUS_NO_EMPTY)
464 {
465 /* set up the id */
466 can_x->tx_mailbox[transmit_mailbox].tmi &= 0x00000001;
467 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmidsel = tx_message_struct->id_type;
468 switch(tx_message_struct->id_type)
469 {
470 case CAN_ID_STANDARD:
471 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmsid = tx_message_struct->standard_id;
472 break;
473 case CAN_ID_EXTENDED:
474 can_x->tx_mailbox[transmit_mailbox].tmi |= (tx_message_struct->extended_id << 3);
475 break;
476 default:
477 break;
478 }
479 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmfrsel = tx_message_struct->frame_type;
480 /* set up the dlc */
481 can_x->tx_mailbox[transmit_mailbox].tmc_bit.tmdtbl = (tx_message_struct->dlc & ((uint8_t)0x0F));
482
483 /* set up the data field */
484 can_x->tx_mailbox[transmit_mailbox].tmdtl = (((uint32_t)tx_message_struct->data[3] << 24) |
485 ((uint32_t)tx_message_struct->data[2] << 16) |
486 ((uint32_t)tx_message_struct->data[1] << 8) |
487 ((uint32_t)tx_message_struct->data[0]));
488 can_x->tx_mailbox[transmit_mailbox].tmdth = (((uint32_t)tx_message_struct->data[7] << 24) |
489 ((uint32_t)tx_message_struct->data[6] << 16) |
490 ((uint32_t)tx_message_struct->data[5] << 8) |
491 ((uint32_t)tx_message_struct->data[4]));
492
493 /* request transmission */
494 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmsr = TRUE;
495 }
496 return transmit_mailbox;
497}
498
515 can_transmit_status_type can_transmit_status_get(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox)
516{
517 can_transmit_status_type state_index = CAN_TX_STATUS_FAILED;
518 switch(transmit_mailbox)
519 {
520 case CAN_TX_MAILBOX0:
521 if(can_x->tsts_bit.tm0tcf != RESET)
522 {
523 if(can_x->tsts_bit.tm0tsf != RESET)
524 {
525 state_index = CAN_TX_STATUS_SUCCESSFUL;
526 }
527 else
528 {
529 state_index = CAN_TX_STATUS_FAILED;
530 }
531 }
532 else
533 {
534 state_index = CAN_TX_STATUS_PENDING;
535 }
536 break;
537 case CAN_TX_MAILBOX1:
538 if(can_x->tsts_bit.tm1tcf != RESET)
539 {
540 if(can_x->tsts_bit.tm1tsf != RESET)
541 {
542 state_index = CAN_TX_STATUS_SUCCESSFUL;
543 }
544 else
545 {
546 state_index = CAN_TX_STATUS_FAILED;
547 }
548 }
549 else
550 {
551 state_index = CAN_TX_STATUS_PENDING;
552 }
553 break;
554 case CAN_TX_MAILBOX2:
555 if(can_x->tsts_bit.tm2tcf != RESET)
556 {
557 if(can_x->tsts_bit.tm2tsf != RESET)
558 {
559 state_index = CAN_TX_STATUS_SUCCESSFUL;
560 }
561 else
562 {
563 state_index = CAN_TX_STATUS_FAILED;
564 }
565 }
566 else
567 {
568 state_index = CAN_TX_STATUS_PENDING;
569 }
570 break;
571 default:
572 state_index = CAN_TX_STATUS_FAILED;
573 break;
574 }
575 return state_index;
576}
577
590void can_transmit_cancel(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox)
591{
592 switch (transmit_mailbox)
593 {
594 case CAN_TX_MAILBOX0:
595 can_x->tsts = CAN_TSTS_TM0CT_VAL;
596 break;
597 case CAN_TX_MAILBOX1:
598 can_x->tsts = CAN_TSTS_TM1CT_VAL;
599 break;
600 case CAN_TX_MAILBOX2:
601 can_x->tsts = CAN_TSTS_TM2CT_VAL;
602 break;
603 default:
604 break;
605 }
606}
607
620void can_message_receive(can_type* can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type* rx_message_struct)
621{
622 /* get the id type */
623 rx_message_struct->id_type = (can_identifier_type)can_x->fifo_mailbox[fifo_number].rfi_bit.rfidi;
624 switch (rx_message_struct->id_type)
625 {
626 case CAN_ID_STANDARD:
627 rx_message_struct->standard_id = can_x->fifo_mailbox[fifo_number].rfi_bit.rfsid;
628 break;
629 case CAN_ID_EXTENDED:
630 rx_message_struct->extended_id = 0x1FFFFFFF & (can_x->fifo_mailbox[fifo_number].rfi >> 3);
631 break;
632 default:
633 break;
634 }
635 rx_message_struct->frame_type = (can_trans_frame_type)can_x->fifo_mailbox[fifo_number].rfi_bit.rffri;
636 /* get the dlc */
637 rx_message_struct->dlc = can_x->fifo_mailbox[fifo_number].rfc_bit.rfdtl;
638
639 /* get the filter match number */
640 rx_message_struct->filter_index = can_x->fifo_mailbox[fifo_number].rfc_bit.rffmn;
641
642 /* get the data field */
643 rx_message_struct->data[0] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt0;
644 rx_message_struct->data[1] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt1;
645 rx_message_struct->data[2] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt2;
646 rx_message_struct->data[3] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt3;
647 rx_message_struct->data[4] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt4;
648 rx_message_struct->data[5] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt5;
649 rx_message_struct->data[6] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt6;
650 rx_message_struct->data[7] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt7;
651
652 /* release the fifo */
653 can_receive_fifo_release(can_x, fifo_number);
654}
655
667void can_receive_fifo_release(can_type* can_x, can_rx_fifo_num_type fifo_number)
668{
669 switch (fifo_number)
670 {
671 case CAN_RX_FIFO0:
672 can_x->rf0 = CAN_RF0_RF0R_VAL;
673 break;
674 case CAN_RX_FIFO1:
675 can_x->rf1 = CAN_RF1_RF1R_VAL;
676 break;
677 default:
678 break;
679 }
680}
681
693uint8_t can_receive_message_pending_get(can_type* can_x, can_rx_fifo_num_type fifo_number)
694{
695 uint8_t message_pending = 0;
696 switch (fifo_number)
697 {
698 case CAN_RX_FIFO0:
699 message_pending = can_x->rf0_bit.rf0mn;
700 break;
701 case CAN_RX_FIFO1:
702 message_pending = can_x->rf1_bit.rf1mn;
703 break;
704 default:
705 break;
706 }
707 return message_pending;
708}
709
724 error_status can_operating_mode_set(can_type* can_x, can_operating_mode_type can_operating_mode)
725{
726 error_status status = ERROR;
727 uint32_t time_out_index = FZC_TIMEOUT;
728
729 if (can_operating_mode == CAN_OPERATINGMODE_FREEZE)
730 {
731 /* request enter freeze mode */
732 can_x->mctrl_bit.dzen = FALSE;
733 can_x->mctrl_bit.fzen = TRUE;
734
735 while(((can_x->msts_bit.dzc) || (!can_x->msts_bit.fzc)) && (time_out_index != 0))
736 {
737 time_out_index--;
738 }
739 if((can_x->msts_bit.dzc) || (!can_x->msts_bit.fzc))
740 {
741 status = ERROR;
742 }
743 else
744 {
745 status = SUCCESS;
746 }
747 }
748 else if(can_operating_mode == CAN_OPERATINGMODE_DOZE)
749 {
750 /* request enter doze mode */
751 can_x->mctrl_bit.dzen = TRUE;
752 can_x->mctrl_bit.fzen = FALSE;
753
754 while(((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
755 {
756 time_out_index--;
757 }
758 if((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
759 {
760 status = ERROR;
761 }
762 else
763 {
764 status = SUCCESS;
765 }
766 }
767 else if(can_operating_mode == CAN_OPERATINGMODE_COMMUNICATE)
768 {
769 /* request enter normal mode */
770 can_x->mctrl_bit.dzen = FALSE;
771 can_x->mctrl_bit.fzen = FALSE;
772
773 while(((can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
774 {
775 time_out_index--;
776 }
777 if((can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
778 {
779 status = ERROR;
780 }
781 else
782 {
783 status = SUCCESS;
784 }
785 }
786 else
787 {
788 status = ERROR;
789 }
790 return status;
791}
792
802 can_enter_doze_status_type can_doze_mode_enter(can_type* can_x)
803{
804 can_enter_doze_status_type status = CAN_ENTER_DOZE_FAILED;
805 uint32_t time_out_index = FZC_TIMEOUT;
806 can_x->mctrl_bit.fzen = FALSE;
807 can_x->mctrl_bit.dzen = TRUE;
808 while(((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
809 {
810 time_out_index--;
811 }
812 if((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
813 {
814 status = CAN_ENTER_DOZE_FAILED;
815 }
816 else
817 {
818 status = CAN_ENTER_DOZE_SUCCESSFUL;
819 }
820 return status;
821}
822
832 can_quit_doze_status_type can_doze_mode_exit(can_type* can_x)
833{
834 can_quit_doze_status_type status = CAN_QUIT_DOZE_FAILED;
835 uint32_t time_out_index = DZC_TIMEOUT;
836 can_x->mctrl_bit.dzen = FALSE;
837 while((can_x->msts_bit.dzc) && (time_out_index != 0))
838 {
839 time_out_index--;
840 }
841 if(!can_x->msts_bit.dzc)
842 {
843 status = CAN_QUIT_DOZE_SUCCESSFUL;
844 }
845 return status;
846}
847
864 can_error_record_type can_error_type_record_get(can_type* can_x)
865{
866 can_error_record_type error_code = CAN_ERRORRECORD_NOERR;
867
868 error_code = (can_error_record_type)can_x->ests_bit.etr;
869 return error_code;
870}
871
879uint8_t can_receive_error_counter_get(can_type* can_x)
880{
881 uint8_t counter = 0;
882 counter = can_x->ests_bit.rec;
883 return counter;
884}
885
893uint8_t can_transmit_error_counter_get(can_type* can_x)
894{
895 uint8_t counter = 0;
896 counter = can_x->ests_bit.tec;
897 return counter;
898}
899
925void can_interrupt_enable(can_type* can_x, uint32_t can_int, confirm_state new_state)
926{
927 if (new_state != FALSE)
928 {
929 can_x->inten |= can_int;
930 }
931 else
932 {
933 can_x->inten &= ~can_int;
934 }
935}
936
965 flag_status can_flag_get(can_type* can_x, uint32_t can_flag)
966{
967 flag_status bit_status = RESET;
968 switch(can_flag)
969 {
970 case CAN_EAF_FLAG:
971 bit_status = (flag_status)can_x->ests_bit.eaf;
972 break;
973 case CAN_EPF_FLAG:
974 bit_status = (flag_status)can_x->ests_bit.epf;
975 break;
976 case CAN_BOF_FLAG:
977 bit_status = (flag_status)can_x->ests_bit.bof;
978 break;
979 case CAN_ETR_FLAG:
980 if(can_x->ests_bit.etr != 0)
981 {
982 bit_status = SET;
983 }
984 else
985 {
986 bit_status = RESET;
987 }
988 break;
989 case CAN_EOIF_FLAG:
990 bit_status = (flag_status)can_x->msts_bit.eoif;
991 break;
992 case CAN_TM0TCF_FLAG:
993 bit_status = (flag_status)can_x->tsts_bit.tm0tcf;
994 break;
995 case CAN_TM1TCF_FLAG:
996 bit_status = (flag_status)can_x->tsts_bit.tm1tcf;
997 break;
998 case CAN_TM2TCF_FLAG:
999 bit_status = (flag_status)can_x->tsts_bit.tm2tcf;
1000 break;
1001 case CAN_RF0MN_FLAG:
1002 if(can_x->rf0_bit.rf0mn != 0)
1003 {
1004 bit_status = SET;
1005 }
1006 else
1007 {
1008 bit_status = RESET;
1009 }
1010 break;
1011 case CAN_RF0FF_FLAG:
1012 bit_status = (flag_status)can_x->rf0_bit.rf0ff;
1013 break;
1014 case CAN_RF0OF_FLAG:
1015 bit_status = (flag_status)can_x->rf0_bit.rf0of;
1016 break;
1017 case CAN_RF1MN_FLAG:
1018 if(can_x->rf1_bit.rf1mn != 0)
1019 {
1020 bit_status = SET;
1021 }
1022 else
1023 {
1024 bit_status = RESET;
1025 }
1026 break;
1027 case CAN_RF1FF_FLAG:
1028 bit_status = (flag_status)can_x->rf1_bit.rf1ff;
1029 break;
1030 case CAN_RF1OF_FLAG:
1031 bit_status = (flag_status)can_x->rf1_bit.rf1of;
1032 break;
1033 case CAN_QDZIF_FLAG:
1034 bit_status = (flag_status)can_x->msts_bit.qdzif;
1035 break;
1036 case CAN_EDZC_FLAG:
1037 if((can_x->msts_bit.dzc != RESET) ||(can_x->msts_bit.edzif != RESET))
1038 {
1039 bit_status = SET;
1040 }
1041 else
1042 {
1043 bit_status = RESET;
1044 }
1045 break;
1046 case CAN_TMEF_FLAG:
1047 if((can_x->tsts_bit.tm0ef != RESET) || (can_x->tsts_bit.tm1ef != RESET) || (can_x->tsts_bit.tm2ef != RESET))
1048 {
1049 bit_status = SET;
1050 }
1051 else
1052 {
1053 bit_status = RESET;
1054 }
1055 break;
1056 default:
1057 bit_status = RESET;
1058 break;
1059 }
1060 return bit_status;
1061}
1062
1089void can_flag_clear(can_type* can_x, uint32_t can_flag)
1090{
1091 switch(can_flag)
1092 {
1093 case CAN_EAF_FLAG:
1094 case CAN_EPF_FLAG:
1095 case CAN_BOF_FLAG:
1096 case CAN_EOIF_FLAG:
1097 can_x->msts = CAN_MSTS_EOIF_VAL;
1098 break;
1099 case CAN_ETR_FLAG:
1100 can_x->msts = CAN_MSTS_EOIF_VAL;
1101 can_x->ests = 0;
1102 break;
1103 case CAN_TM0TCF_FLAG:
1104 can_x->tsts = CAN_TSTS_TM0TCF_VAL;
1105 break;
1106 case CAN_TM1TCF_FLAG:
1107 can_x->tsts = CAN_TSTS_TM1TCF_VAL;
1108 break;
1109 case CAN_TM2TCF_FLAG:
1110 can_x->tsts = CAN_TSTS_TM2TCF_VAL;
1111 break;
1112 case CAN_RF0FF_FLAG:
1113 can_x->rf0 = CAN_RF0_RF0FF_VAL;
1114 break;
1115 case CAN_RF0OF_FLAG:
1116 can_x->rf0 = CAN_RF0_RF0OF_VAL;
1117 break;
1118 case CAN_RF1FF_FLAG:
1119 can_x->rf1 = CAN_RF1_RF1FF_VAL;
1120 break;
1121 case CAN_RF1OF_FLAG:
1122 can_x->rf1 = CAN_RF1_RF1OF_VAL;
1123 break;
1124 case CAN_QDZIF_FLAG:
1125 can_x->msts = CAN_MSTS_QDZIF_VAL;
1126 break;
1127 case CAN_EDZC_FLAG:
1128 can_x->msts = CAN_MSTS_EDZIF_VAL;
1129 break;
1130 case CAN_TMEF_FLAG:
1131 can_x->tsts = CAN_TSTS_TM0TCF_VAL | CAN_TSTS_TM1TCF_VAL | CAN_TSTS_TM2TCF_VAL;
1132 break;
1133 default:
1134 break;
1135 }
1136}
1137
1142#endif
1143
counter
uint16_t counter
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:38
can_transmit_status_type
can_transmit_status_type
can transmit status
Definition: at32f413_can.h:269
can_quit_doze_status_type
can_quit_doze_status_type
can quit doze mode status
Definition: at32f413_can.h:289
can_trans_frame_type
can_trans_frame_type
can transmission frame type
Definition: at32f413_can.h:241
can_error_record_type
can_error_record_type
can error type record
Definition: at32f413_can.h:316
can_operating_mode_type
can_operating_mode_type
can operating mode
Definition: at32f413_can.h:173
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:250
can_enter_doze_status_type
can_enter_doze_status_type
can enter doze mode status
Definition: at32f413_can.h:280
can_rx_fifo_num_type
can_rx_fifo_num_type
can receive fifo
Definition: at32f413_can.h:260
can_identifier_type
can_identifier_type
can identifier type
Definition: at32f413_can.h:232
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:136
CAN_FILTER_FIFO1
@ CAN_FILTER_FIFO1
Definition: at32f413_can.h:137
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:271
CAN_TX_STATUS_PENDING
@ CAN_TX_STATUS_PENDING
Definition: at32f413_can.h:272
CAN_TX_STATUS_NO_EMPTY
@ CAN_TX_STATUS_NO_EMPTY
Definition: at32f413_can.h:273
CAN_TX_STATUS_FAILED
@ CAN_TX_STATUS_FAILED
Definition: at32f413_can.h:270
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:299
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:220
CAN_QUIT_DOZE_FAILED
@ CAN_QUIT_DOZE_FAILED
Definition: at32f413_can.h:290
CAN_QUIT_DOZE_SUCCESSFUL
@ CAN_QUIT_DOZE_SUCCESSFUL
Definition: at32f413_can.h:291
CAN_BTS1_4TQ
@ CAN_BTS1_4TQ
Definition: at32f413_can.h:198
CAN_ERRORRECORD_NOERR
@ CAN_ERRORRECORD_NOERR
Definition: at32f413_can.h:317
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f413_can.h:146
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:145
CAN_OPERATINGMODE_FREEZE
@ CAN_OPERATINGMODE_FREEZE
Definition: at32f413_can.h:174
CAN_OPERATINGMODE_COMMUNICATE
@ CAN_OPERATINGMODE_COMMUNICATE
Definition: at32f413_can.h:176
CAN_OPERATINGMODE_DOZE
@ CAN_OPERATINGMODE_DOZE
Definition: at32f413_can.h:175
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:308
CAN_TX_MAILBOX2
@ CAN_TX_MAILBOX2
Definition: at32f413_can.h:253
CAN_TX_MAILBOX0
@ CAN_TX_MAILBOX0
Definition: at32f413_can.h:251
CAN_TX_MAILBOX1
@ CAN_TX_MAILBOX1
Definition: at32f413_can.h:252
CAN_FILTER_16BIT
@ CAN_FILTER_16BIT
Definition: at32f413_can.h:154
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:155
CAN_ENTER_DOZE_FAILED
@ CAN_ENTER_DOZE_FAILED
Definition: at32f413_can.h:281
CAN_ENTER_DOZE_SUCCESSFUL
@ CAN_ENTER_DOZE_SUCCESSFUL
Definition: at32f413_can.h:282
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:261
CAN_RX_FIFO1
@ CAN_RX_FIFO1
Definition: at32f413_can.h:262
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:233
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f413_can.h:234
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:163
CAN_RSAW_2TQ
@ CAN_RSAW_2TQ
Definition: at32f413_can.h:185
CAN_EDZC_FLAG
#define CAN_EDZC_FLAG
Definition: at32f413_can.h:77
CAN_TM1TCF_FLAG
#define CAN_TM1TCF_FLAG
Definition: at32f413_can.h:68
CAN_QDZIF_FLAG
#define CAN_QDZIF_FLAG
Definition: at32f413_can.h:76
CAN_TM0TCF_FLAG
#define CAN_TM0TCF_FLAG
Definition: at32f413_can.h:67
CAN_RF1FF_FLAG
#define CAN_RF1FF_FLAG
Definition: at32f413_can.h:74
CAN_RF0FF_FLAG
#define CAN_RF0FF_FLAG
Definition: at32f413_can.h:71
CAN_RF1MN_FLAG
#define CAN_RF1MN_FLAG
Definition: at32f413_can.h:73
CAN_EPF_FLAG
#define CAN_EPF_FLAG
Definition: at32f413_can.h:63
CAN_RF1OF_FLAG
#define CAN_RF1OF_FLAG
Definition: at32f413_can.h:75
CAN_EAF_FLAG
#define CAN_EAF_FLAG
Definition: at32f413_can.h:62
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:70
CAN_TM2TCF_FLAG
#define CAN_TM2TCF_FLAG
Definition: at32f413_can.h:69
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:65
CAN_RF0OF_FLAG
#define CAN_RF0OF_FLAG
Definition: at32f413_can.h:72
CAN_EOIF_FLAG
#define CAN_EOIF_FLAG
Definition: at32f413_can.h:66
CAN_TMEF_FLAG
#define CAN_TMEF_FLAG
Definition: at32f413_can.h:78
CAN_BOF_FLAG
#define CAN_BOF_FLAG
Definition: at32f413_can.h:64
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:195
can_reset
void can_reset(can_type *can_x)
deinitialize the can peripheral registers to their default reset values.
Definition: at32f413_can.c:49
can_transmit_error_counter_get
uint8_t can_transmit_error_counter_get(can_type *can_x)
return the transmit error counter of the specified can peripheral.
Definition: at32f413_can.c:893
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:515
can_ttc_mode_enable
void can_ttc_mode_enable(can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral.
Definition: at32f413_can.c:417
can_filter_default_para_init
void can_filter_default_para_init(can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value.
Definition: at32f413_can.c:270
can_receive_fifo_release
void can_receive_fifo_release(can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral.
Definition: at32f413_can.c:667
can_receive_error_counter_get
uint8_t can_receive_error_counter_get(can_type *can_x)
return the receive error counter (rec) of the specified can peripheral.
Definition: at32f413_can.c:879
can_operating_mode_set
error_status can_operating_mode_set(can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral.
Definition: at32f413_can.c:724
can_baudrate_default_para_init
void can_baudrate_default_para_init(can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value.
Definition: at32f413_can.c:71
can_transmit_cancel
void can_transmit_cancel(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral.
Definition: at32f413_can.c:590
can_receive_message_pending_get
uint8_t can_receive_message_pending_get(can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral.
Definition: at32f413_can.c:693
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:441
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:620
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:925
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:965
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1089
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:100
can_debug_transmission_prohibit
void can_debug_transmission_prohibit(can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral.
Definition: at32f413_can.c:396
can_error_type_record_get
can_error_record_type can_error_type_record_get(can_type *can_x)
return the error type record (etr) of the specified can peripheral.
Definition: at32f413_can.c:864
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:305
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:158
can_doze_mode_exit
can_quit_doze_status_type can_doze_mode_exit(can_type *can_x)
exit the doze mode of the specified can peripheral.
Definition: at32f413_can.c:832
can_doze_mode_enter
can_enter_doze_status_type can_doze_mode_enter(can_type *can_x)
enter the low power mode of the specified can peripheral.
Definition: at32f413_can.c:802
DZC_TIMEOUT
#define DZC_TIMEOUT
Definition: at32f413_can.h:51
FZC_TIMEOUT
#define FZC_TIMEOUT
Definition: at32f413_can.h:50
CAN_RF1_RF1FF_VAL
#define CAN_RF1_RF1FF_VAL
Definition: at32f413_can.h:123
CAN_RF0_RF0FF_VAL
#define CAN_RF0_RF0FF_VAL
Definition: at32f413_can.h:120
CAN_TSTS_TM0TCF_VAL
#define CAN_TSTS_TM0TCF_VAL
Definition: at32f413_can.h:114
CAN_TSTS_TM2CT_VAL
#define CAN_TSTS_TM2CT_VAL
Definition: at32f413_can.h:119
CAN_RF1_RF1R_VAL
#define CAN_RF1_RF1R_VAL
Definition: at32f413_can.h:125
CAN1
#define CAN1
Definition: at32f413_can.h:936
CAN_MSTS_EOIF_VAL
#define CAN_MSTS_EOIF_VAL
can flag clear operation macro definition val
Definition: at32f413_can.h:111
CAN_MSTS_QDZIF_VAL
#define CAN_MSTS_QDZIF_VAL
Definition: at32f413_can.h:112
CAN_TSTS_TM2TCF_VAL
#define CAN_TSTS_TM2TCF_VAL
Definition: at32f413_can.h:116
CAN_RF0_RF0OF_VAL
#define CAN_RF0_RF0OF_VAL
Definition: at32f413_can.h:121
CAN_RF0_RF0R_VAL
#define CAN_RF0_RF0R_VAL
Definition: at32f413_can.h:122
CAN_RF1_RF1OF_VAL
#define CAN_RF1_RF1OF_VAL
Definition: at32f413_can.h:124
CAN_TSTS_TM1TCF_VAL
#define CAN_TSTS_TM1TCF_VAL
Definition: at32f413_can.h:115
CAN_TSTS_TM0CT_VAL
#define CAN_TSTS_TM0CT_VAL
Definition: at32f413_can.h:117
CAN_TSTS_TM1CT_VAL
#define CAN_TSTS_TM1CT_VAL
Definition: at32f413_can.h:118
CAN_MSTS_EDZIF_VAL
#define CAN_MSTS_EDZIF_VAL
Definition: at32f413_can.h:113
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
CRM_CAN1_PERIPH_RESET
@ CRM_CAN1_PERIPH_RESET
Definition: at32f413_crm.h:181
CRM_CAN2_PERIPH_RESET
@ CRM_CAN2_PERIPH_RESET
Definition: at32f413_crm.h:184
error_status
error_status
error status
Definition: at32f413.h:301
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
can_base_type
can init structure definition
Definition: at32f413_can.h:331
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:340
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:342
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:338
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:344
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:334
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:332
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:336
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:352
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:353
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:355
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:359
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:357
can_fifo_mailbox_type::rfdt4
__IO uint32_t rfdt4
Definition: at32f413_can.h:564
can_fifo_mailbox_type::rfi
__IO uint32_t rfi
Definition: at32f413_can.h:515
can_fifo_mailbox_type::rfdt0
__IO uint32_t rfdt0
Definition: at32f413_can.h:549
can_fifo_mailbox_type::rfsid
__IO uint32_t rfsid
Definition: at32f413_can.h:522
can_fifo_mailbox_type::rfdt2
__IO uint32_t rfdt2
Definition: at32f413_can.h:551
can_fifo_mailbox_type::rfdtl
__IO uint32_t rfdtl
Definition: at32f413_can.h:534
can_fifo_mailbox_type::rfidi
__IO uint32_t rfidi
Definition: at32f413_can.h:520
can_fifo_mailbox_type::rfdt1
__IO uint32_t rfdt1
Definition: at32f413_can.h:550
can_fifo_mailbox_type::rfc_bit
struct can_fifo_mailbox_type::@227::@234 rfc_bit
can_fifo_mailbox_type::rfdt6
__IO uint32_t rfdt6
Definition: at32f413_can.h:566
can_fifo_mailbox_type::rffri
__IO uint32_t rffri
Definition: at32f413_can.h:519
can_fifo_mailbox_type::rfdtl_bit
struct can_fifo_mailbox_type::@229::@235 rfdtl_bit
can_fifo_mailbox_type::rfdt3
__IO uint32_t rfdt3
Definition: at32f413_can.h:552
can_fifo_mailbox_type::rfi_bit
struct can_fifo_mailbox_type::@225::@233 rfi_bit
can_fifo_mailbox_type::rfdt5
__IO uint32_t rfdt5
Definition: at32f413_can.h:565
can_fifo_mailbox_type::rfdt7
__IO uint32_t rfdt7
Definition: at32f413_can.h:567
can_fifo_mailbox_type::rffmn
__IO uint32_t rffmn
Definition: at32f413_can.h:536
can_fifo_mailbox_type::rfdth_bit
struct can_fifo_mailbox_type::@231::@236 rfdth_bit
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:367
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:387
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:374
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:372
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:376
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:370
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:368
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:384
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:378
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:381
can_filter_register_type::ffdb1
__IO uint32_t ffdb1
Definition: at32f413_can.h:577
can_filter_register_type::ffdb2
__IO uint32_t ffdb2
Definition: at32f413_can.h:578
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:417
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:418
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:424
can_rx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:426
can_rx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:431
can_rx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:428
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:421
can_rx_message_type::filter_index
uint8_t filter_index
Definition: at32f413_can.h:433
can_tx_mailbox_type::tmtsten
__IO uint32_t tmtsten
Definition: at32f413_can.h:468
can_tx_mailbox_type::tmi
__IO uint32_t tmi
Definition: at32f413_can.h:447
can_tx_mailbox_type::tmsr
__IO uint32_t tmsr
Definition: at32f413_can.h:450
can_tx_mailbox_type::tmdtl
__IO uint32_t tmdtl
Definition: at32f413_can.h:479
can_tx_mailbox_type::tmdtbl
__IO uint32_t tmdtbl
Definition: at32f413_can.h:466
can_tx_mailbox_type::tmfrsel
__IO uint32_t tmfrsel
Definition: at32f413_can.h:451
can_tx_mailbox_type::tmsid
__IO uint32_t tmsid
Definition: at32f413_can.h:454
can_tx_mailbox_type::tmi_bit
struct can_tx_mailbox_type::@213::@221 tmi_bit
can_tx_mailbox_type::tmc_bit
struct can_tx_mailbox_type::@215::@222 tmc_bit
can_tx_mailbox_type::tmdth
__IO uint32_t tmdth
Definition: at32f413_can.h:494
can_tx_mailbox_type::tmidsel
__IO uint32_t tmidsel
Definition: at32f413_can.h:452
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:395
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:399
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:404
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:409
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:406
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:402
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:396
can_type
type define can register all
Definition: at32f413_can.h:585
can_type::rf0of
__IO uint32_t rf0of
Definition: at32f413_can.h:679
can_type::tm2ef
__IO uint32_t tm2ef
Definition: at32f413_can.h:661
can_type::eaf
__IO uint32_t eaf
Definition: at32f413_can.h:738
can_type::rf1
__IO uint32_t rf1
Definition: at32f413_can.h:690
can_type::tm0tsf
__IO uint32_t tm0tsf
Definition: at32f413_can.h:641
can_type::aeden
__IO uint32_t aeden
Definition: at32f413_can.h:600
can_type::dzc
__IO uint32_t dzc
Definition: at32f413_can.h:619
can_type::mctrl_bit
struct can_type::@237::@263 mctrl_bit
can_type::tm0tcf
__IO uint32_t tm0tcf
Definition: at32f413_can.h:640
can_type::fctrl_bit
struct can_type::@253::@271 fctrl_bit
can_type::edzif
__IO uint32_t edzif
Definition: at32f413_can.h:622
can_type::mdrsel
__IO uint32_t mdrsel
Definition: at32f413_can.h:598
can_type::rf1ff
__IO uint32_t rf1ff
Definition: at32f413_can.h:695
can_type::bof
__IO uint32_t bof
Definition: at32f413_can.h:740
can_type::tec
__IO uint32_t tec
Definition: at32f413_can.h:744
can_type::ttcen
__IO uint32_t ttcen
Definition: at32f413_can.h:602
can_type::tx_mailbox
can_tx_mailbox_type tx_mailbox[3]
can controller area network tx mailbox register, offset:0x180~0x1AC
Definition: at32f413_can.h:777
can_type::tm1tcf
__IO uint32_t tm1tcf
Definition: at32f413_can.h:646
can_type::lben
__IO uint32_t lben
Definition: at32f413_can.h:764
can_type::ptd
__IO uint32_t ptd
Definition: at32f413_can.h:605
can_type::fzc
__IO uint32_t fzc
Definition: at32f413_can.h:618
can_type::ffb
can_filter_register_type ffb[14]
can ffb register, offset:0x240~0x2AC
Definition: at32f413_can.h:929
can_type::tm0ef
__IO uint32_t tm0ef
Definition: at32f413_can.h:659
can_type::bts2
__IO uint32_t bts2
Definition: at32f413_can.h:760
can_type::loen
__IO uint32_t loen
Definition: at32f413_can.h:765
can_type::ests
__IO uint32_t ests
Definition: at32f413_can.h:735
can_type::ests_bit
struct can_type::@249::@269 ests_bit
can_type::rf0_bit
struct can_type::@243::@266 rf0_bit
can_type::frf
__IO uint32_t frf
Definition: at32f413_can.h:869
can_type::rsaw
__IO uint32_t rsaw
Definition: at32f413_can.h:762
can_type::rf0
__IO uint32_t rf0
Definition: at32f413_can.h:673
can_type::tsts_bit
struct can_type::@241::@265 tsts_bit
can_type::rf1mn
__IO uint32_t rf1mn
Definition: at32f413_can.h:693
can_type::prsfen
__IO uint32_t prsfen
Definition: at32f413_can.h:599
can_type::btmg_bit
struct can_type::@251::@270 btmg_bit
can_type::facfg
__IO uint32_t facfg
Definition: at32f413_can.h:900
can_type::tm1ef
__IO uint32_t tm1ef
Definition: at32f413_can.h:660
can_type::aeboen
__IO uint32_t aeboen
Definition: at32f413_can.h:601
can_type::eoif
__IO uint32_t eoif
Definition: at32f413_can.h:620
can_type::tm2tcf
__IO uint32_t tm2tcf
Definition: at32f413_can.h:652
can_type::rf1_bit
struct can_type::@245::@267 rf1_bit
can_type::brdiv
__IO uint32_t brdiv
Definition: at32f413_can.h:757
can_type::epf
__IO uint32_t epf
Definition: at32f413_can.h:739
can_type::dzen
__IO uint32_t dzen
Definition: at32f413_can.h:596
can_type::etr
__IO uint32_t etr
Definition: at32f413_can.h:742
can_type::fifo_mailbox
can_fifo_mailbox_type fifo_mailbox[2]
can controller area network fifo mailbox register, offset:0x1B0~0x1CC
Definition: at32f413_can.h:782
can_type::tsts
__IO uint32_t tsts
Definition: at32f413_can.h:637
can_type::fbwcfg
__IO uint32_t fbwcfg
Definition: at32f413_can.h:838
can_type::qdzif
__IO uint32_t qdzif
Definition: at32f413_can.h:621
can_type::msts_bit
struct can_type::@239::@264 msts_bit
can_type::rf0mn
__IO uint32_t rf0mn
Definition: at32f413_can.h:676
can_type::rf0ff
__IO uint32_t rf0ff
Definition: at32f413_can.h:678
can_type::fcs
__IO uint32_t fcs
Definition: at32f413_can.h:797
can_type::msts
__IO uint32_t msts
Definition: at32f413_can.h:615
can_type::rec
__IO uint32_t rec
Definition: at32f413_can.h:745
can_type::bts1
__IO uint32_t bts1
Definition: at32f413_can.h:759
can_type::tm2tsf
__IO uint32_t tm2tsf
Definition: at32f413_can.h:653
can_type::rf1of
__IO uint32_t rf1of
Definition: at32f413_can.h:696
can_type::fzen
__IO uint32_t fzen
Definition: at32f413_can.h:595
can_type::mmssr
__IO uint32_t mmssr
Definition: at32f413_can.h:597
can_type::inten
__IO uint32_t inten
Definition: at32f413_can.h:707
can_type::fmcfg
__IO uint32_t fmcfg
Definition: at32f413_can.h:807
can_type::tm1tsf
__IO uint32_t tm1tsf
Definition: at32f413_can.h:647
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_can.h Source File

  • libraries
  • drivers
  • inc
at32f413_can.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CAN_H
27#define __AT32F413_CAN_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define FZC_TIMEOUT ((uint32_t)0x0000FFFF)
51#define DZC_TIMEOUT ((uint32_t)0x0000FFFF)
62#define CAN_EAF_FLAG ((uint32_t)0x01)
63#define CAN_EPF_FLAG ((uint32_t)0x02)
64#define CAN_BOF_FLAG ((uint32_t)0x03)
65#define CAN_ETR_FLAG ((uint32_t)0x04)
66#define CAN_EOIF_FLAG ((uint32_t)0x05)
67#define CAN_TM0TCF_FLAG ((uint32_t)0x06)
68#define CAN_TM1TCF_FLAG ((uint32_t)0x07)
69#define CAN_TM2TCF_FLAG ((uint32_t)0x08)
70#define CAN_RF0MN_FLAG ((uint32_t)0x09)
71#define CAN_RF0FF_FLAG ((uint32_t)0x0A)
72#define CAN_RF0OF_FLAG ((uint32_t)0x0B)
73#define CAN_RF1MN_FLAG ((uint32_t)0x0C)
74#define CAN_RF1FF_FLAG ((uint32_t)0x0D)
75#define CAN_RF1OF_FLAG ((uint32_t)0x0E)
76#define CAN_QDZIF_FLAG ((uint32_t)0x0F)
77#define CAN_EDZC_FLAG ((uint32_t)0x10)
78#define CAN_TMEF_FLAG ((uint32_t)0x11)
89#define CAN_TCIEN_INT ((uint32_t)0x00000001)
90#define CAN_RF0MIEN_INT ((uint32_t)0x00000002)
91#define CAN_RF0FIEN_INT ((uint32_t)0x00000004)
92#define CAN_RF0OIEN_INT ((uint32_t)0x00000008)
93#define CAN_RF1MIEN_INT ((uint32_t)0x00000010)
94#define CAN_RF1FIEN_INT ((uint32_t)0x00000020)
95#define CAN_RF1OIEN_INT ((uint32_t)0x00000040)
96#define CAN_EAIEN_INT ((uint32_t)0x00000100)
97#define CAN_EPIEN_INT ((uint32_t)0x00000200)
98#define CAN_BOIEN_INT ((uint32_t)0x00000400)
99#define CAN_ETRIEN_INT ((uint32_t)0x00000800)
100#define CAN_EOIEN_INT ((uint32_t)0x00008000)
101#define CAN_QDZIEN_INT ((uint32_t)0x00010000)
102#define CAN_EDZIEN_INT ((uint32_t)0x00020000)
111#define CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
112#define CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
113#define CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
114#define CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
115#define CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
116#define CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
117#define CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
118#define CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
119#define CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
120#define CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
121#define CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
122#define CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
123#define CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
124#define CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
125#define CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
134typedef enum
135{
136 CAN_FILTER_FIFO0 = 0x00,
137 CAN_FILTER_FIFO1 = 0x01
138} can_filter_fifo_type;
139
143typedef enum
144{
145 CAN_FILTER_MODE_ID_MASK = 0x00,
146 CAN_FILTER_MODE_ID_LIST = 0x01
147} can_filter_mode_type;
148
152typedef enum
153{
154 CAN_FILTER_16BIT = 0x00,
155 CAN_FILTER_32BIT = 0x01
156} can_filter_bit_width_type;
157
161typedef enum
162{
163 CAN_MODE_COMMUNICATE = 0x00,
164 CAN_MODE_LOOPBACK = 0x01,
165 CAN_MODE_LISTENONLY = 0x02,
166 CAN_MODE_LISTENONLY_LOOPBACK = 0x03
167} can_mode_type;
168
172typedef enum
173{
174 CAN_OPERATINGMODE_FREEZE = 0x00,
175 CAN_OPERATINGMODE_DOZE = 0x01,
176 CAN_OPERATINGMODE_COMMUNICATE = 0x02
177} can_operating_mode_type;
178
182typedef enum
183{
184 CAN_RSAW_1TQ = 0x00,
185 CAN_RSAW_2TQ = 0x01,
186 CAN_RSAW_3TQ = 0x02,
187 CAN_RSAW_4TQ = 0x03
188} can_rsaw_type;
189
193typedef enum
194{
195 CAN_BTS1_1TQ = 0x00,
196 CAN_BTS1_2TQ = 0x01,
197 CAN_BTS1_3TQ = 0x02,
198 CAN_BTS1_4TQ = 0x03,
199 CAN_BTS1_5TQ = 0x04,
200 CAN_BTS1_6TQ = 0x05,
201 CAN_BTS1_7TQ = 0x06,
202 CAN_BTS1_8TQ = 0x07,
203 CAN_BTS1_9TQ = 0x08,
204 CAN_BTS1_10TQ = 0x09,
205 CAN_BTS1_11TQ = 0x0A,
206 CAN_BTS1_12TQ = 0x0B,
207 CAN_BTS1_13TQ = 0x0C,
208 CAN_BTS1_14TQ = 0x0D,
209 CAN_BTS1_15TQ = 0x0E,
210 CAN_BTS1_16TQ = 0x0F
211} can_bts1_type;
212
216typedef enum
217{
218 CAN_BTS2_1TQ = 0x00,
219 CAN_BTS2_2TQ = 0x01,
220 CAN_BTS2_3TQ = 0x02,
221 CAN_BTS2_4TQ = 0x03,
222 CAN_BTS2_5TQ = 0x04,
223 CAN_BTS2_6TQ = 0x05,
224 CAN_BTS2_7TQ = 0x06,
225 CAN_BTS2_8TQ = 0x07
226} can_bts2_type;
227
231typedef enum
232{
233 CAN_ID_STANDARD = 0x00,
234 CAN_ID_EXTENDED = 0x01
235} can_identifier_type;
236
240typedef enum
241{
242 CAN_TFT_DATA = 0x00,
243 CAN_TFT_REMOTE = 0x01
244} can_trans_frame_type;
245
249typedef enum
250{
251 CAN_TX_MAILBOX0 = 0x00,
252 CAN_TX_MAILBOX1 = 0x01,
253 CAN_TX_MAILBOX2 = 0x02
254} can_tx_mailbox_num_type;
255
259typedef enum
260{
261 CAN_RX_FIFO0 = 0x00,
262 CAN_RX_FIFO1 = 0x01
263} can_rx_fifo_num_type;
264
268typedef enum
269{
270 CAN_TX_STATUS_FAILED = 0x00,
271 CAN_TX_STATUS_SUCCESSFUL = 0x01,
272 CAN_TX_STATUS_PENDING = 0x02,
273 CAN_TX_STATUS_NO_EMPTY = 0x04
274} can_transmit_status_type;
275
279typedef enum
280{
281 CAN_ENTER_DOZE_FAILED = 0x00,
282 CAN_ENTER_DOZE_SUCCESSFUL = 0x01
283} can_enter_doze_status_type;
284
288typedef enum
289{
290 CAN_QUIT_DOZE_FAILED = 0x00,
291 CAN_QUIT_DOZE_SUCCESSFUL = 0x01
292} can_quit_doze_status_type;
293
297typedef enum
298{
299 CAN_DISCARDING_FIRST_RECEIVED = 0x00,
300 CAN_DISCARDING_LAST_RECEIVED = 0x01
301} can_msg_discarding_rule_type;
302
306typedef enum
307{
308 CAN_SENDING_BY_ID = 0x00,
309 CAN_SENDING_BY_REQUEST = 0x01
310} can_msg_sending_rule_type;
311
315typedef enum
316{
317 CAN_ERRORRECORD_NOERR = 0x00,
318 CAN_ERRORRECORD_STUFFERR = 0x01,
319 CAN_ERRORRECORD_FORMERR = 0x02,
320 CAN_ERRORRECORD_ACKERR = 0x03,
321 CAN_ERRORRECORD_BITRECESSIVEERR = 0x04,
322 CAN_ERRORRECORD_BITDOMINANTERR = 0x05,
323 CAN_ERRORRECORD_CRCERR = 0x06,
324 CAN_ERRORRECORD_SOFTWARESETERR = 0x07
325} can_error_record_type;
326
330typedef struct
331{
332 can_mode_type mode_selection;
334 confirm_state ttc_enable;
336 confirm_state aebo_enable;
338 confirm_state aed_enable;
340 confirm_state prsf_enable;
342 can_msg_discarding_rule_type mdrsel_selection;
344 can_msg_sending_rule_type mmssr_selection;
346} can_base_type;
347
351typedef struct
352{
353 uint16_t baudrate_div;
355 can_rsaw_type rsaw_size;
357 can_bts1_type bts1_size;
359 can_bts2_type bts2_size;
361} can_baudrate_type;
362
366typedef struct
367{
368 confirm_state filter_activate_enable;
370 can_filter_mode_type filter_mode;
372 can_filter_fifo_type filter_fifo;
374 uint8_t filter_number;
376 can_filter_bit_width_type filter_bit;
378 uint16_t filter_id_high;
381 uint16_t filter_id_low;
384 uint16_t filter_mask_high;
387 uint16_t filter_mask_low;
389} can_filter_init_type;
390
394typedef struct
395{
396 uint32_t standard_id;
399 uint32_t extended_id;
402 can_identifier_type id_type;
404 can_trans_frame_type frame_type;
406 uint8_t dlc;
409 uint8_t data[8];
411} can_tx_message_type;
412
416typedef struct
417{
418 uint32_t standard_id;
421 uint32_t extended_id;
424 can_identifier_type id_type;
426 can_trans_frame_type frame_type;
428 uint8_t dlc;
431 uint8_t data[8];
433 uint8_t filter_index;
435} can_rx_message_type;
436
440typedef struct
441{
445 union
446 {
447 __IO uint32_t tmi;
448 struct
449 {
450 __IO uint32_t tmsr : 1; /* [0] */
451 __IO uint32_t tmfrsel : 1; /* [1] */
452 __IO uint32_t tmidsel : 1; /* [2] */
453 __IO uint32_t tmeid : 18;/* [20:3] */
454 __IO uint32_t tmsid : 11;/* [31:21] */
455 } tmi_bit;
456 };
457
461 union
462 {
463 __IO uint32_t tmc;
464 struct
465 {
466 __IO uint32_t tmdtbl : 4; /* [3:0] */
467 __IO uint32_t reserved1 : 4; /* [7:4] */
468 __IO uint32_t tmtsten : 1; /* [8] */
469 __IO uint32_t reserved2 : 7; /* [15:9] */
470 __IO uint32_t tmts : 16;/* [31:16] */
471 } tmc_bit;
472 };
473
477 union
478 {
479 __IO uint32_t tmdtl;
480 struct
481 {
482 __IO uint32_t tmdt0 : 8; /* [7:0] */
483 __IO uint32_t tmdt1 : 8; /* [15:8] */
484 __IO uint32_t tmdt2 : 8; /* [23:16] */
485 __IO uint32_t tmdt3 : 8; /* [31:24] */
486 } tmdtl_bit;
487 };
488
492 union
493 {
494 __IO uint32_t tmdth;
495 struct
496 {
497 __IO uint32_t tmdt4 : 8; /* [7:0] */
498 __IO uint32_t tmdt5 : 8; /* [15:8] */
499 __IO uint32_t tmdt6 : 8; /* [23:16] */
500 __IO uint32_t tmdt7 : 8; /* [31:24] */
501 } tmdth_bit;
502 };
503} can_tx_mailbox_type;
504
508typedef struct
509{
513 union
514 {
515 __IO uint32_t rfi;
516 struct
517 {
518 __IO uint32_t reserved1 : 1; /* [0] */
519 __IO uint32_t rffri : 1; /* [1] */
520 __IO uint32_t rfidi : 1; /* [2] */
521 __IO uint32_t rfeid : 18;/* [20:3] */
522 __IO uint32_t rfsid : 11;/* [31:21] */
523 } rfi_bit;
524 };
525
529 union
530 {
531 __IO uint32_t rfc;
532 struct
533 {
534 __IO uint32_t rfdtl : 4; /* [3:0] */
535 __IO uint32_t reserved1 : 4; /* [7:4] */
536 __IO uint32_t rffmn : 8; /* [15:8] */
537 __IO uint32_t rfts : 16;/* [31:16] */
538 } rfc_bit;
539 };
540
544 union
545 {
546 __IO uint32_t rfdtl;
547 struct
548 {
549 __IO uint32_t rfdt0 : 8; /* [7:0] */
550 __IO uint32_t rfdt1 : 8; /* [15:8] */
551 __IO uint32_t rfdt2 : 8; /* [23:16] */
552 __IO uint32_t rfdt3 : 8; /* [31:24] */
553 } rfdtl_bit;
554 };
555
559 union
560 {
561 __IO uint32_t rfdth;
562 struct
563 {
564 __IO uint32_t rfdt4 : 8; /* [7:0] */
565 __IO uint32_t rfdt5 : 8; /* [15:8] */
566 __IO uint32_t rfdt6 : 8; /* [23:16] */
567 __IO uint32_t rfdt7 : 8; /* [31:24] */
568 } rfdth_bit;
569 };
570} can_fifo_mailbox_type;
571
575typedef struct
576{
577 __IO uint32_t ffdb1;
578 __IO uint32_t ffdb2;
579} can_filter_register_type;
580
584typedef struct
585{
586
590 union
591 {
592 __IO uint32_t mctrl;
593 struct
594 {
595 __IO uint32_t fzen : 1; /* [0] */
596 __IO uint32_t dzen : 1; /* [1] */
597 __IO uint32_t mmssr : 1; /* [2] */
598 __IO uint32_t mdrsel : 1; /* [3] */
599 __IO uint32_t prsfen : 1; /* [4] */
600 __IO uint32_t aeden : 1; /* [5] */
601 __IO uint32_t aeboen : 1; /* [6] */
602 __IO uint32_t ttcen : 1; /* [7] */
603 __IO uint32_t reserved1 : 7; /* [14:8] */
604 __IO uint32_t sprst : 1; /* [15] */
605 __IO uint32_t ptd : 1; /* [16] */
606 __IO uint32_t reserved2 : 15;/*[31:17] */
607 } mctrl_bit;
608 };
609
613 union
614 {
615 __IO uint32_t msts;
616 struct
617 {
618 __IO uint32_t fzc : 1; /* [0] */
619 __IO uint32_t dzc : 1; /* [1] */
620 __IO uint32_t eoif : 1; /* [2] */
621 __IO uint32_t qdzif : 1; /* [3] */
622 __IO uint32_t edzif : 1; /* [4] */
623 __IO uint32_t reserved1 : 3; /* [7:5] */
624 __IO uint32_t cuss : 1; /* [8] */
625 __IO uint32_t curs : 1; /* [9] */
626 __IO uint32_t lsamprx : 1; /* [10] */
627 __IO uint32_t realrx : 1; /* [11] */
628 __IO uint32_t reserved2 : 20;/*[31:12] */
629 } msts_bit;
630 };
631
635 union
636 {
637 __IO uint32_t tsts;
638 struct
639 {
640 __IO uint32_t tm0tcf : 1; /* [0] */
641 __IO uint32_t tm0tsf : 1; /* [1] */
642 __IO uint32_t tm0alf : 1; /* [2] */
643 __IO uint32_t tm0tef : 1; /* [3] */
644 __IO uint32_t reserved1 : 3; /* [6:4] */
645 __IO uint32_t tm0ct : 1; /* [7] */
646 __IO uint32_t tm1tcf : 1; /* [8] */
647 __IO uint32_t tm1tsf : 1; /* [9] */
648 __IO uint32_t tm1alf : 1; /* [10] */
649 __IO uint32_t tm1tef : 1; /* [11] */
650 __IO uint32_t reserved2 : 3; /* [14:12] */
651 __IO uint32_t tm1ct : 1; /* [15] */
652 __IO uint32_t tm2tcf : 1; /* [16] */
653 __IO uint32_t tm2tsf : 1; /* [17] */
654 __IO uint32_t tm2alf : 1; /* [18] */
655 __IO uint32_t tm2tef : 1; /* [19] */
656 __IO uint32_t reserved3 : 3; /* [22:20] */
657 __IO uint32_t tm2ct : 1; /* [23] */
658 __IO uint32_t tmnr : 2; /* [25:24] */
659 __IO uint32_t tm0ef : 1; /* [26] */
660 __IO uint32_t tm1ef : 1; /* [27] */
661 __IO uint32_t tm2ef : 1; /* [28] */
662 __IO uint32_t tm0lpf : 1; /* [29] */
663 __IO uint32_t tm1lpf : 1; /* [30] */
664 __IO uint32_t tm2lpf : 1; /* [31] */
665 } tsts_bit;
666 };
667
671 union
672 {
673 __IO uint32_t rf0;
674 struct
675 {
676 __IO uint32_t rf0mn : 2; /* [1:0] */
677 __IO uint32_t reserved1 : 1; /* [2] */
678 __IO uint32_t rf0ff : 1; /* [3] */
679 __IO uint32_t rf0of : 1; /* [4] */
680 __IO uint32_t rf0r : 1; /* [5] */
681 __IO uint32_t reserved2 : 26;/* [31:6] */
682 } rf0_bit;
683 };
684
688 union
689 {
690 __IO uint32_t rf1;
691 struct
692 {
693 __IO uint32_t rf1mn : 2; /* [1:0] */
694 __IO uint32_t reserved1 : 1; /* [2] */
695 __IO uint32_t rf1ff : 1; /* [3] */
696 __IO uint32_t rf1of : 1; /* [4] */
697 __IO uint32_t rf1r : 1; /* [5] */
698 __IO uint32_t reserved2 : 26;/* [31:6] */
699 } rf1_bit;
700 };
701
705 union
706 {
707 __IO uint32_t inten;
708 struct
709 {
710 __IO uint32_t tcien : 1; /* [0] */
711 __IO uint32_t rf0mien : 1; /* [1] */
712 __IO uint32_t rf0fien : 1; /* [2] */
713 __IO uint32_t rf0oien : 1; /* [3] */
714 __IO uint32_t rf1mien : 1; /* [4] */
715 __IO uint32_t rf1fien : 1; /* [5] */
716 __IO uint32_t rf1oien : 1; /* [6] */
717 __IO uint32_t reserved1 : 1; /* [7] */
718 __IO uint32_t eaien : 1; /* [8] */
719 __IO uint32_t epien : 1; /* [9] */
720 __IO uint32_t boien : 1; /* [10] */
721 __IO uint32_t etrien : 1; /* [11] */
722 __IO uint32_t reserved2 : 3; /* [14:12] */
723 __IO uint32_t eoien : 1; /* [15] */
724 __IO uint32_t qdzien : 1; /* [16] */
725 __IO uint32_t edzien : 1; /* [17] */
726 __IO uint32_t reserved3 : 14;/* [31:18] */
727 } inten_bit;
728 };
729
733 union
734 {
735 __IO uint32_t ests;
736 struct
737 {
738 __IO uint32_t eaf : 1; /* [0] */
739 __IO uint32_t epf : 1; /* [1] */
740 __IO uint32_t bof : 1; /* [2] */
741 __IO uint32_t reserved1 : 1; /* [3] */
742 __IO uint32_t etr : 3; /* [6:4] */
743 __IO uint32_t reserved2 : 9; /* [15:7] */
744 __IO uint32_t tec : 8; /* [23:16] */
745 __IO uint32_t rec : 8; /* [31:24] */
746 } ests_bit;
747 };
748
752 union
753 {
754 __IO uint32_t btmg;
755 struct
756 {
757 __IO uint32_t brdiv : 12;/* [11:0] */
758 __IO uint32_t reserved1 : 4; /* [15:12] */
759 __IO uint32_t bts1 : 4; /* [19:16] */
760 __IO uint32_t bts2 : 3; /* [22:20] */
761 __IO uint32_t reserved2 : 1; /* [23] */
762 __IO uint32_t rsaw : 2; /* [25:24] */
763 __IO uint32_t reserved3 : 4; /* [29:26] */
764 __IO uint32_t lben : 1; /* [30] */
765 __IO uint32_t loen : 1; /* [31] */
766 } btmg_bit;
767 };
768
772 __IO uint32_t reserved1[88];
773
777 can_tx_mailbox_type tx_mailbox[3];
778
782 can_fifo_mailbox_type fifo_mailbox[2];
783
787 __IO uint32_t reserved2[12];
788
792 union
793 {
794 __IO uint32_t fctrl;
795 struct
796 {
797 __IO uint32_t fcs : 1; /* [0] */
798 __IO uint32_t reserved1 : 31;/* [31:1] */
799 } fctrl_bit;
800 };
801
805 union
806 {
807 __IO uint32_t fmcfg;
808 struct
809 {
810 __IO uint32_t fmsel0 : 1; /* [0] */
811 __IO uint32_t fmsel1 : 1; /* [1] */
812 __IO uint32_t fmsel2 : 1; /* [2] */
813 __IO uint32_t fmsel3 : 1; /* [3] */
814 __IO uint32_t fmsel4 : 1; /* [4] */
815 __IO uint32_t fmsel5 : 1; /* [5] */
816 __IO uint32_t fmsel6 : 1; /* [6] */
817 __IO uint32_t fmsel7 : 1; /* [7] */
818 __IO uint32_t fmsel8 : 1; /* [8] */
819 __IO uint32_t fmsel9 : 1; /* [9] */
820 __IO uint32_t fmsel10 : 1; /* [10] */
821 __IO uint32_t fmsel11 : 1; /* [11] */
822 __IO uint32_t fmsel12 : 1; /* [12] */
823 __IO uint32_t fmsel13 : 1; /* [13] */
824 __IO uint32_t reserved1 : 18;/* [31:14] */
825 } fmcfg_bit;
826 };
827
831 __IO uint32_t reserved3;
832
836 union
837 {
838 __IO uint32_t fbwcfg;
839 struct
840 {
841 __IO uint32_t fbwsel0 : 1; /* [0] */
842 __IO uint32_t fbwsel1 : 1; /* [1] */
843 __IO uint32_t fbwsel2 : 1; /* [2] */
844 __IO uint32_t fbwsel3 : 1; /* [3] */
845 __IO uint32_t fbwsel4 : 1; /* [4] */
846 __IO uint32_t fbwsel5 : 1; /* [5] */
847 __IO uint32_t fbwsel6 : 1; /* [6] */
848 __IO uint32_t fbwsel7 : 1; /* [7] */
849 __IO uint32_t fbwsel8 : 1; /* [8] */
850 __IO uint32_t fbwsel9 : 1; /* [9] */
851 __IO uint32_t fbwsel10 : 1; /* [10] */
852 __IO uint32_t fbwsel11 : 1; /* [11] */
853 __IO uint32_t fbwsel12 : 1; /* [12] */
854 __IO uint32_t fbwsel13 : 1; /* [13] */
855 __IO uint32_t reserved1 : 18;/* [31:14] */
856 } fbwcfg_bit;
857 };
858
862 __IO uint32_t reserved4;
863
867 union
868 {
869 __IO uint32_t frf;
870 struct
871 {
872 __IO uint32_t frfsel0 : 1; /* [0] */
873 __IO uint32_t frfsel1 : 1; /* [1] */
874 __IO uint32_t frfsel2 : 1; /* [2] */
875 __IO uint32_t frfsel3 : 1; /* [3] */
876 __IO uint32_t frfsel4 : 1; /* [4] */
877 __IO uint32_t frfsel5 : 1; /* [5] */
878 __IO uint32_t frfsel6 : 1; /* [6] */
879 __IO uint32_t frfsel7 : 1; /* [7] */
880 __IO uint32_t frfsel8 : 1; /* [8] */
881 __IO uint32_t frfsel9 : 1; /* [9] */
882 __IO uint32_t frfsel10 : 1; /* [10] */
883 __IO uint32_t frfsel11 : 1; /* [11] */
884 __IO uint32_t frfsel12 : 1; /* [12] */
885 __IO uint32_t frfsel13 : 1; /* [13] */
886 __IO uint32_t reserved1 : 18;/* [31:14] */
887 } frf_bit;
888 };
889
893 __IO uint32_t reserved5;
894
898 union
899 {
900 __IO uint32_t facfg;
901 struct
902 {
903 __IO uint32_t faen0 : 1; /* [0] */
904 __IO uint32_t faen1 : 1; /* [1] */
905 __IO uint32_t faen2 : 1; /* [2] */
906 __IO uint32_t faen3 : 1; /* [3] */
907 __IO uint32_t faen4 : 1; /* [4] */
908 __IO uint32_t faen5 : 1; /* [5] */
909 __IO uint32_t faen6 : 1; /* [6] */
910 __IO uint32_t faen7 : 1; /* [7] */
911 __IO uint32_t faen8 : 1; /* [8] */
912 __IO uint32_t faen9 : 1; /* [9] */
913 __IO uint32_t faen10 : 1; /* [10] */
914 __IO uint32_t faen11 : 1; /* [11] */
915 __IO uint32_t faen12 : 1; /* [12] */
916 __IO uint32_t faen13 : 1; /* [13] */
917 __IO uint32_t reserved1 : 18;/* [31:14] */
918 } facfg_bit;
919 };
920
924 __IO uint32_t reserved6[8];
925
929 can_filter_register_type ffb[14];
930} can_type;
931
936#define CAN1 ((can_type *) CAN1_BASE)
937#if defined (AT32F413TBU7) || defined (AT32F413Rx) || defined (AT32F413Cx) || \
938 defined (AT32F413Kx)
939#define CAN2 ((can_type *) CAN2_BASE)
940#endif
941
946void can_reset(can_type* can_x);
947void can_baudrate_default_para_init(can_baudrate_type* can_baudrate_struct);
948 error_status can_baudrate_set(can_type* can_x, can_baudrate_type* can_baudrate_struct);
949void can_default_para_init(can_base_type* can_base_struct);
950 error_status can_base_init(can_type* can_x, can_base_type* can_base_struct);
951void can_filter_default_para_init(can_filter_init_type* can_filter_init_struct);
952void can_filter_init(can_type* can_x, can_filter_init_type* can_filter_init_struct);
953void can_debug_transmission_prohibit(can_type* can_x, confirm_state new_state);
954void can_ttc_mode_enable(can_type* can_x, confirm_state new_state);
955uint8_t can_message_transmit(can_type* can_x, can_tx_message_type* tx_message_struct);
956 can_transmit_status_type can_transmit_status_get(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox);
957void can_transmit_cancel(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox);
958void can_message_receive(can_type* can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type* rx_message_struct);
959void can_receive_fifo_release(can_type* can_x, can_rx_fifo_num_type fifo_number);
960uint8_t can_receive_message_pending_get(can_type* can_x, can_rx_fifo_num_type fifo_number);
961 error_status can_operating_mode_set(can_type* can_x, can_operating_mode_type can_operating_mode);
962 can_enter_doze_status_type can_doze_mode_enter(can_type* can_x);
963 can_quit_doze_status_type can_doze_mode_exit(can_type* can_x);
964 can_error_record_type can_error_type_record_get(can_type* can_x);
965uint8_t can_receive_error_counter_get(can_type* can_x);
966uint8_t can_transmit_error_counter_get(can_type* can_x);
967void can_interrupt_enable(can_type* can_x, uint32_t can_int, confirm_state new_state);
968 flag_status can_flag_get(can_type* can_x, uint32_t can_flag);
969void can_flag_clear(can_type* can_x, uint32_t can_flag);
970
983#ifdef __cplusplus
984}
985#endif
986
987#endif
at32f413.h
at32f413 header file
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:195
can_reset
void can_reset(can_type *can_x)
deinitialize the can peripheral registers to their default reset values.
Definition: at32f413_can.c:49
can_transmit_error_counter_get
uint8_t can_transmit_error_counter_get(can_type *can_x)
return the transmit error counter of the specified can peripheral.
Definition: at32f413_can.c:893
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:515
can_ttc_mode_enable
void can_ttc_mode_enable(can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral.
Definition: at32f413_can.c:417
can_filter_default_para_init
void can_filter_default_para_init(can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value.
Definition: at32f413_can.c:270
can_receive_fifo_release
void can_receive_fifo_release(can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral.
Definition: at32f413_can.c:667
can_receive_error_counter_get
uint8_t can_receive_error_counter_get(can_type *can_x)
return the receive error counter (rec) of the specified can peripheral.
Definition: at32f413_can.c:879
can_operating_mode_set
error_status can_operating_mode_set(can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral.
Definition: at32f413_can.c:724
can_baudrate_default_para_init
void can_baudrate_default_para_init(can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value.
Definition: at32f413_can.c:71
can_transmit_cancel
void can_transmit_cancel(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral.
Definition: at32f413_can.c:590
can_receive_message_pending_get
uint8_t can_receive_message_pending_get(can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral.
Definition: at32f413_can.c:693
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:441
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:620
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:925
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:965
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1089
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:100
can_debug_transmission_prohibit
void can_debug_transmission_prohibit(can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral.
Definition: at32f413_can.c:396
can_error_type_record_get
can_error_record_type can_error_type_record_get(can_type *can_x)
return the error type record (etr) of the specified can peripheral.
Definition: at32f413_can.c:864
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:305
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:158
can_doze_mode_exit
can_quit_doze_status_type can_doze_mode_exit(can_type *can_x)
exit the doze mode of the specified can peripheral.
Definition: at32f413_can.c:832
can_doze_mode_enter
can_enter_doze_status_type can_doze_mode_enter(can_type *can_x)
enter the low power mode of the specified can peripheral.
Definition: at32f413_can.c:802
can_filter_fifo_type
can_filter_fifo_type
can filter fifo
Definition: at32f413_can.h:135
can_transmit_status_type
can_transmit_status_type
can transmit status
Definition: at32f413_can.h:269
can_msg_discarding_rule_type
can_msg_discarding_rule_type
can message discarding rule select when overflow
Definition: at32f413_can.h:298
can_bts2_type
can_bts2_type
can bit time segment 2
Definition: at32f413_can.h:217
can_quit_doze_status_type
can_quit_doze_status_type
can quit doze mode status
Definition: at32f413_can.h:289
can_trans_frame_type
can_trans_frame_type
can transmission frame type
Definition: at32f413_can.h:241
can_bts1_type
can_bts1_type
can bit time segment 1
Definition: at32f413_can.h:194
can_error_record_type
can_error_record_type
can error type record
Definition: at32f413_can.h:316
can_filter_mode_type
can_filter_mode_type
can filter mode
Definition: at32f413_can.h:144
can_operating_mode_type
can_operating_mode_type
can operating mode
Definition: at32f413_can.h:173
can_msg_sending_rule_type
can_msg_sending_rule_type
can multiple message sending sequence rule
Definition: at32f413_can.h:307
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:250
can_filter_bit_width_type
can_filter_bit_width_type
can filter bit width select
Definition: at32f413_can.h:153
can_enter_doze_status_type
can_enter_doze_status_type
can enter doze mode status
Definition: at32f413_can.h:280
can_rx_fifo_num_type
can_rx_fifo_num_type
can receive fifo
Definition: at32f413_can.h:260
can_identifier_type
can_identifier_type
can identifier type
Definition: at32f413_can.h:232
can_mode_type
can_mode_type
can mode
Definition: at32f413_can.h:162
can_rsaw_type
can_rsaw_type
can resynchronization adjust width
Definition: at32f413_can.h:183
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:136
CAN_FILTER_FIFO1
@ CAN_FILTER_FIFO1
Definition: at32f413_can.h:137
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:271
CAN_TX_STATUS_PENDING
@ CAN_TX_STATUS_PENDING
Definition: at32f413_can.h:272
CAN_TX_STATUS_NO_EMPTY
@ CAN_TX_STATUS_NO_EMPTY
Definition: at32f413_can.h:273
CAN_TX_STATUS_FAILED
@ CAN_TX_STATUS_FAILED
Definition: at32f413_can.h:270
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:299
CAN_DISCARDING_LAST_RECEIVED
@ CAN_DISCARDING_LAST_RECEIVED
Definition: at32f413_can.h:300
CAN_BTS2_4TQ
@ CAN_BTS2_4TQ
Definition: at32f413_can.h:221
CAN_BTS2_2TQ
@ CAN_BTS2_2TQ
Definition: at32f413_can.h:219
CAN_BTS2_5TQ
@ CAN_BTS2_5TQ
Definition: at32f413_can.h:222
CAN_BTS2_6TQ
@ CAN_BTS2_6TQ
Definition: at32f413_can.h:223
CAN_BTS2_7TQ
@ CAN_BTS2_7TQ
Definition: at32f413_can.h:224
CAN_BTS2_8TQ
@ CAN_BTS2_8TQ
Definition: at32f413_can.h:225
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:220
CAN_BTS2_1TQ
@ CAN_BTS2_1TQ
Definition: at32f413_can.h:218
CAN_QUIT_DOZE_FAILED
@ CAN_QUIT_DOZE_FAILED
Definition: at32f413_can.h:290
CAN_QUIT_DOZE_SUCCESSFUL
@ CAN_QUIT_DOZE_SUCCESSFUL
Definition: at32f413_can.h:291
CAN_TFT_REMOTE
@ CAN_TFT_REMOTE
Definition: at32f413_can.h:243
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:242
CAN_BTS1_7TQ
@ CAN_BTS1_7TQ
Definition: at32f413_can.h:201
CAN_BTS1_1TQ
@ CAN_BTS1_1TQ
Definition: at32f413_can.h:195
CAN_BTS1_14TQ
@ CAN_BTS1_14TQ
Definition: at32f413_can.h:208
CAN_BTS1_4TQ
@ CAN_BTS1_4TQ
Definition: at32f413_can.h:198
CAN_BTS1_15TQ
@ CAN_BTS1_15TQ
Definition: at32f413_can.h:209
CAN_BTS1_11TQ
@ CAN_BTS1_11TQ
Definition: at32f413_can.h:205
CAN_BTS1_10TQ
@ CAN_BTS1_10TQ
Definition: at32f413_can.h:204
CAN_BTS1_16TQ
@ CAN_BTS1_16TQ
Definition: at32f413_can.h:210
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:202
CAN_BTS1_3TQ
@ CAN_BTS1_3TQ
Definition: at32f413_can.h:197
CAN_BTS1_12TQ
@ CAN_BTS1_12TQ
Definition: at32f413_can.h:206
CAN_BTS1_9TQ
@ CAN_BTS1_9TQ
Definition: at32f413_can.h:203
CAN_BTS1_5TQ
@ CAN_BTS1_5TQ
Definition: at32f413_can.h:199
CAN_BTS1_6TQ
@ CAN_BTS1_6TQ
Definition: at32f413_can.h:200
CAN_BTS1_2TQ
@ CAN_BTS1_2TQ
Definition: at32f413_can.h:196
CAN_BTS1_13TQ
@ CAN_BTS1_13TQ
Definition: at32f413_can.h:207
CAN_ERRORRECORD_CRCERR
@ CAN_ERRORRECORD_CRCERR
Definition: at32f413_can.h:323
CAN_ERRORRECORD_FORMERR
@ CAN_ERRORRECORD_FORMERR
Definition: at32f413_can.h:319
CAN_ERRORRECORD_BITDOMINANTERR
@ CAN_ERRORRECORD_BITDOMINANTERR
Definition: at32f413_can.h:322
CAN_ERRORRECORD_BITRECESSIVEERR
@ CAN_ERRORRECORD_BITRECESSIVEERR
Definition: at32f413_can.h:321
CAN_ERRORRECORD_NOERR
@ CAN_ERRORRECORD_NOERR
Definition: at32f413_can.h:317
CAN_ERRORRECORD_STUFFERR
@ CAN_ERRORRECORD_STUFFERR
Definition: at32f413_can.h:318
CAN_ERRORRECORD_SOFTWARESETERR
@ CAN_ERRORRECORD_SOFTWARESETERR
Definition: at32f413_can.h:324
CAN_ERRORRECORD_ACKERR
@ CAN_ERRORRECORD_ACKERR
Definition: at32f413_can.h:320
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f413_can.h:146
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:145
CAN_OPERATINGMODE_FREEZE
@ CAN_OPERATINGMODE_FREEZE
Definition: at32f413_can.h:174
CAN_OPERATINGMODE_COMMUNICATE
@ CAN_OPERATINGMODE_COMMUNICATE
Definition: at32f413_can.h:176
CAN_OPERATINGMODE_DOZE
@ CAN_OPERATINGMODE_DOZE
Definition: at32f413_can.h:175
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:308
CAN_SENDING_BY_REQUEST
@ CAN_SENDING_BY_REQUEST
Definition: at32f413_can.h:309
CAN_TX_MAILBOX2
@ CAN_TX_MAILBOX2
Definition: at32f413_can.h:253
CAN_TX_MAILBOX0
@ CAN_TX_MAILBOX0
Definition: at32f413_can.h:251
CAN_TX_MAILBOX1
@ CAN_TX_MAILBOX1
Definition: at32f413_can.h:252
CAN_FILTER_16BIT
@ CAN_FILTER_16BIT
Definition: at32f413_can.h:154
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:155
CAN_ENTER_DOZE_FAILED
@ CAN_ENTER_DOZE_FAILED
Definition: at32f413_can.h:281
CAN_ENTER_DOZE_SUCCESSFUL
@ CAN_ENTER_DOZE_SUCCESSFUL
Definition: at32f413_can.h:282
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:261
CAN_RX_FIFO1
@ CAN_RX_FIFO1
Definition: at32f413_can.h:262
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:233
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f413_can.h:234
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:163
CAN_MODE_LISTENONLY
@ CAN_MODE_LISTENONLY
Definition: at32f413_can.h:165
CAN_MODE_LISTENONLY_LOOPBACK
@ CAN_MODE_LISTENONLY_LOOPBACK
Definition: at32f413_can.h:166
CAN_MODE_LOOPBACK
@ CAN_MODE_LOOPBACK
Definition: at32f413_can.h:164
CAN_RSAW_1TQ
@ CAN_RSAW_1TQ
Definition: at32f413_can.h:184
CAN_RSAW_4TQ
@ CAN_RSAW_4TQ
Definition: at32f413_can.h:187
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:186
CAN_RSAW_2TQ
@ CAN_RSAW_2TQ
Definition: at32f413_can.h:185
error_status
error_status
error status
Definition: at32f413.h:301
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
can_base_type
can init structure definition
Definition: at32f413_can.h:331
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:340
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:342
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:338
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:344
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:334
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:332
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:336
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:352
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:353
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:355
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:359
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:357
can_fifo_mailbox_type
can controller area network fifo mailbox
Definition: at32f413_can.h:509
can_fifo_mailbox_type::rfdt4
__IO uint32_t rfdt4
Definition: at32f413_can.h:564
can_fifo_mailbox_type::rfi
__IO uint32_t rfi
Definition: at32f413_can.h:515
can_fifo_mailbox_type::rfdt0
__IO uint32_t rfdt0
Definition: at32f413_can.h:549
can_fifo_mailbox_type::rfsid
__IO uint32_t rfsid
Definition: at32f413_can.h:522
can_fifo_mailbox_type::rfdt2
__IO uint32_t rfdt2
Definition: at32f413_can.h:551
can_fifo_mailbox_type::rfdth
__IO uint32_t rfdth
Definition: at32f413_can.h:561
can_fifo_mailbox_type::rfdtl
__IO uint32_t rfdtl
Definition: at32f413_can.h:534
can_fifo_mailbox_type::rfidi
__IO uint32_t rfidi
Definition: at32f413_can.h:520
can_fifo_mailbox_type::rfdt1
__IO uint32_t rfdt1
Definition: at32f413_can.h:550
can_fifo_mailbox_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_can.h:518
can_fifo_mailbox_type::rfdt6
__IO uint32_t rfdt6
Definition: at32f413_can.h:566
can_fifo_mailbox_type::rffri
__IO uint32_t rffri
Definition: at32f413_can.h:519
can_fifo_mailbox_type::rfc
__IO uint32_t rfc
Definition: at32f413_can.h:531
can_fifo_mailbox_type::rfdt3
__IO uint32_t rfdt3
Definition: at32f413_can.h:552
can_fifo_mailbox_type::rfdt5
__IO uint32_t rfdt5
Definition: at32f413_can.h:565
can_fifo_mailbox_type::rfdt7
__IO uint32_t rfdt7
Definition: at32f413_can.h:567
can_fifo_mailbox_type::rfts
__IO uint32_t rfts
Definition: at32f413_can.h:537
can_fifo_mailbox_type::rffmn
__IO uint32_t rffmn
Definition: at32f413_can.h:536
can_fifo_mailbox_type::rfeid
__IO uint32_t rfeid
Definition: at32f413_can.h:521
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:367
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:387
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:374
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:372
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:376
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:370
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:368
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:384
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:378
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:381
can_filter_register_type
can controller area network filter bit register
Definition: at32f413_can.h:576
can_filter_register_type::ffdb1
__IO uint32_t ffdb1
Definition: at32f413_can.h:577
can_filter_register_type::ffdb2
__IO uint32_t ffdb2
Definition: at32f413_can.h:578
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:417
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:418
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:424
can_rx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:426
can_rx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:428
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:421
can_rx_message_type::filter_index
uint8_t filter_index
Definition: at32f413_can.h:433
can_tx_mailbox_type
can controller area network tx mailbox
Definition: at32f413_can.h:441
can_tx_mailbox_type::tmdt5
__IO uint32_t tmdt5
Definition: at32f413_can.h:498
can_tx_mailbox_type::tmtsten
__IO uint32_t tmtsten
Definition: at32f413_can.h:468
can_tx_mailbox_type::tmi
__IO uint32_t tmi
Definition: at32f413_can.h:447
can_tx_mailbox_type::tmc
__IO uint32_t tmc
Definition: at32f413_can.h:463
can_tx_mailbox_type::tmts
__IO uint32_t tmts
Definition: at32f413_can.h:470
can_tx_mailbox_type::tmdt0
__IO uint32_t tmdt0
Definition: at32f413_can.h:482
can_tx_mailbox_type::tmsr
__IO uint32_t tmsr
Definition: at32f413_can.h:450
can_tx_mailbox_type::tmdtl
__IO uint32_t tmdtl
Definition: at32f413_can.h:479
can_tx_mailbox_type::tmdt2
__IO uint32_t tmdt2
Definition: at32f413_can.h:484
can_tx_mailbox_type::tmdtbl
__IO uint32_t tmdtbl
Definition: at32f413_can.h:466
can_tx_mailbox_type::tmdt3
__IO uint32_t tmdt3
Definition: at32f413_can.h:485
can_tx_mailbox_type::tmdt1
__IO uint32_t tmdt1
Definition: at32f413_can.h:483
can_tx_mailbox_type::tmdt4
__IO uint32_t tmdt4
Definition: at32f413_can.h:497
can_tx_mailbox_type::tmfrsel
__IO uint32_t tmfrsel
Definition: at32f413_can.h:451
can_tx_mailbox_type::tmsid
__IO uint32_t tmsid
Definition: at32f413_can.h:454
can_tx_mailbox_type::tmdt6
__IO uint32_t tmdt6
Definition: at32f413_can.h:499
can_tx_mailbox_type::tmdth
__IO uint32_t tmdth
Definition: at32f413_can.h:494
can_tx_mailbox_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_can.h:467
can_tx_mailbox_type::tmidsel
__IO uint32_t tmidsel
Definition: at32f413_can.h:452
can_tx_mailbox_type::tmdt7
__IO uint32_t tmdt7
Definition: at32f413_can.h:500
can_tx_mailbox_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_can.h:469
can_tx_mailbox_type::tmeid
__IO uint32_t tmeid
Definition: at32f413_can.h:453
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:395
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:399
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:404
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:406
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:402
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:396
can_type
type define can register all
Definition: at32f413_can.h:585
can_type::tmnr
__IO uint32_t tmnr
Definition: at32f413_can.h:658
can_type::fbwsel10
__IO uint32_t fbwsel10
Definition: at32f413_can.h:851
can_type::rf0of
__IO uint32_t rf0of
Definition: at32f413_can.h:679
can_type::tm1alf
__IO uint32_t tm1alf
Definition: at32f413_can.h:648
can_type::tm2lpf
__IO uint32_t tm2lpf
Definition: at32f413_can.h:664
can_type::fmsel13
__IO uint32_t fmsel13
Definition: at32f413_can.h:823
can_type::tm2ef
__IO uint32_t tm2ef
Definition: at32f413_can.h:661
can_type::tm2ct
__IO uint32_t tm2ct
Definition: at32f413_can.h:657
can_type::frfsel1
__IO uint32_t frfsel1
Definition: at32f413_can.h:873
can_type::frfsel12
__IO uint32_t frfsel12
Definition: at32f413_can.h:884
can_type::fmsel4
__IO uint32_t fmsel4
Definition: at32f413_can.h:814
can_type::etrien
__IO uint32_t etrien
Definition: at32f413_can.h:721
can_type::tm1tef
__IO uint32_t tm1tef
Definition: at32f413_can.h:649
can_type::fbwsel8
__IO uint32_t fbwsel8
Definition: at32f413_can.h:849
can_type::boien
__IO uint32_t boien
Definition: at32f413_can.h:720
can_type::eoien
__IO uint32_t eoien
Definition: at32f413_can.h:723
can_type::fctrl
__IO uint32_t fctrl
Definition: at32f413_can.h:794
can_type::frfsel4
__IO uint32_t frfsel4
Definition: at32f413_can.h:876
can_type::tm0ct
__IO uint32_t tm0ct
Definition: at32f413_can.h:645
can_type::eaf
__IO uint32_t eaf
Definition: at32f413_can.h:738
can_type::rf1
__IO uint32_t rf1
Definition: at32f413_can.h:690
can_type::tm0tsf
__IO uint32_t tm0tsf
Definition: at32f413_can.h:641
can_type::tm0lpf
__IO uint32_t tm0lpf
Definition: at32f413_can.h:662
can_type::frfsel2
__IO uint32_t frfsel2
Definition: at32f413_can.h:874
can_type::aeden
__IO uint32_t aeden
Definition: at32f413_can.h:600
can_type::dzc
__IO uint32_t dzc
Definition: at32f413_can.h:619
can_type::fmsel0
__IO uint32_t fmsel0
Definition: at32f413_can.h:810
can_type::faen4
__IO uint32_t faen4
Definition: at32f413_can.h:907
can_type::tm0tcf
__IO uint32_t tm0tcf
Definition: at32f413_can.h:640
can_type::fmsel12
__IO uint32_t fmsel12
Definition: at32f413_can.h:822
can_type::eaien
__IO uint32_t eaien
Definition: at32f413_can.h:718
can_type::fbwsel4
__IO uint32_t fbwsel4
Definition: at32f413_can.h:845
can_type::fbwsel9
__IO uint32_t fbwsel9
Definition: at32f413_can.h:850
can_type::reserved5
__IO uint32_t reserved5
can reserved register, offset:0x218
Definition: at32f413_can.h:893
can_type::edzif
__IO uint32_t edzif
Definition: at32f413_can.h:622
can_type::frfsel11
__IO uint32_t frfsel11
Definition: at32f413_can.h:883
can_type::fmsel9
__IO uint32_t fmsel9
Definition: at32f413_can.h:819
can_type::frfsel10
__IO uint32_t frfsel10
Definition: at32f413_can.h:882
can_type::mctrl
__IO uint32_t mctrl
Definition: at32f413_can.h:592
can_type::frfsel13
__IO uint32_t frfsel13
Definition: at32f413_can.h:885
can_type::faen7
__IO uint32_t faen7
Definition: at32f413_can.h:910
can_type::faen6
__IO uint32_t faen6
Definition: at32f413_can.h:909
can_type::mdrsel
__IO uint32_t mdrsel
Definition: at32f413_can.h:598
can_type::faen8
__IO uint32_t faen8
Definition: at32f413_can.h:911
can_type::rf0fien
__IO uint32_t rf0fien
Definition: at32f413_can.h:712
can_type::rf1ff
__IO uint32_t rf1ff
Definition: at32f413_can.h:695
can_type::cuss
__IO uint32_t cuss
Definition: at32f413_can.h:624
can_type::bof
__IO uint32_t bof
Definition: at32f413_can.h:740
can_type::faen10
__IO uint32_t faen10
Definition: at32f413_can.h:913
can_type::tec
__IO uint32_t tec
Definition: at32f413_can.h:744
can_type::btmg
__IO uint32_t btmg
Definition: at32f413_can.h:754
can_type::fbwsel0
__IO uint32_t fbwsel0
Definition: at32f413_can.h:841
can_type::sprst
__IO uint32_t sprst
Definition: at32f413_can.h:604
can_type::ttcen
__IO uint32_t ttcen
Definition: at32f413_can.h:602
can_type::tm1tcf
__IO uint32_t tm1tcf
Definition: at32f413_can.h:646
can_type::lben
__IO uint32_t lben
Definition: at32f413_can.h:764
can_type::ptd
__IO uint32_t ptd
Definition: at32f413_can.h:605
can_type::fzc
__IO uint32_t fzc
Definition: at32f413_can.h:618
can_type::epien
__IO uint32_t epien
Definition: at32f413_can.h:719
can_type::fbwsel11
__IO uint32_t fbwsel11
Definition: at32f413_can.h:852
can_type::faen3
__IO uint32_t faen3
Definition: at32f413_can.h:906
can_type::rf1oien
__IO uint32_t rf1oien
Definition: at32f413_can.h:716
can_type::rf0oien
__IO uint32_t rf0oien
Definition: at32f413_can.h:713
can_type::tm0ef
__IO uint32_t tm0ef
Definition: at32f413_can.h:659
can_type::fbwsel1
__IO uint32_t fbwsel1
Definition: at32f413_can.h:842
can_type::frfsel8
__IO uint32_t frfsel8
Definition: at32f413_can.h:880
can_type::fbwsel6
__IO uint32_t fbwsel6
Definition: at32f413_can.h:847
can_type::bts2
__IO uint32_t bts2
Definition: at32f413_can.h:760
can_type::loen
__IO uint32_t loen
Definition: at32f413_can.h:765
can_type::fbwsel7
__IO uint32_t fbwsel7
Definition: at32f413_can.h:848
can_type::fmsel3
__IO uint32_t fmsel3
Definition: at32f413_can.h:813
can_type::ests
__IO uint32_t ests
Definition: at32f413_can.h:735
can_type::frfsel9
__IO uint32_t frfsel9
Definition: at32f413_can.h:881
can_type::frf
__IO uint32_t frf
Definition: at32f413_can.h:869
can_type::reserved4
__IO uint32_t reserved4
can reserved register, offset:0x210
Definition: at32f413_can.h:862
can_type::qdzien
__IO uint32_t qdzien
Definition: at32f413_can.h:724
can_type::fbwsel13
__IO uint32_t fbwsel13
Definition: at32f413_can.h:854
can_type::reserved3
__IO uint32_t reserved3
can reserved register, offset:0x208
Definition: at32f413_can.h:656
can_type::rsaw
__IO uint32_t rsaw
Definition: at32f413_can.h:762
can_type::rf0r
__IO uint32_t rf0r
Definition: at32f413_can.h:680
can_type::rf0
__IO uint32_t rf0
Definition: at32f413_can.h:673
can_type::rf1mien
__IO uint32_t rf1mien
Definition: at32f413_can.h:714
can_type::fmsel1
__IO uint32_t fmsel1
Definition: at32f413_can.h:811
can_type::frfsel6
__IO uint32_t frfsel6
Definition: at32f413_can.h:878
can_type::tm1ct
__IO uint32_t tm1ct
Definition: at32f413_can.h:651
can_type::rf0mien
__IO uint32_t rf0mien
Definition: at32f413_can.h:711
can_type::rf1mn
__IO uint32_t rf1mn
Definition: at32f413_can.h:693
can_type::edzien
__IO uint32_t edzien
Definition: at32f413_can.h:725
can_type::reserved1
__IO uint32_t reserved1
can reserved register, offset:0x20~0x17C
Definition: at32f413_can.h:603
can_type::prsfen
__IO uint32_t prsfen
Definition: at32f413_can.h:599
can_type::facfg
__IO uint32_t facfg
Definition: at32f413_can.h:900
can_type::fmsel11
__IO uint32_t fmsel11
Definition: at32f413_can.h:821
can_type::tm1ef
__IO uint32_t tm1ef
Definition: at32f413_can.h:660
can_type::realrx
__IO uint32_t realrx
Definition: at32f413_can.h:627
can_type::aeboen
__IO uint32_t aeboen
Definition: at32f413_can.h:601
can_type::eoif
__IO uint32_t eoif
Definition: at32f413_can.h:620
can_type::tm2tcf
__IO uint32_t tm2tcf
Definition: at32f413_can.h:652
can_type::faen11
__IO uint32_t faen11
Definition: at32f413_can.h:914
can_type::faen1
__IO uint32_t faen1
Definition: at32f413_can.h:904
can_type::brdiv
__IO uint32_t brdiv
Definition: at32f413_can.h:757
can_type::fmsel2
__IO uint32_t fmsel2
Definition: at32f413_can.h:812
can_type::fbwsel3
__IO uint32_t fbwsel3
Definition: at32f413_can.h:844
can_type::frfsel7
__IO uint32_t frfsel7
Definition: at32f413_can.h:879
can_type::epf
__IO uint32_t epf
Definition: at32f413_can.h:739
can_type::faen0
__IO uint32_t faen0
Definition: at32f413_can.h:903
can_type::dzen
__IO uint32_t dzen
Definition: at32f413_can.h:596
can_type::tm2alf
__IO uint32_t tm2alf
Definition: at32f413_can.h:654
can_type::faen2
__IO uint32_t faen2
Definition: at32f413_can.h:905
can_type::fmsel10
__IO uint32_t fmsel10
Definition: at32f413_can.h:820
can_type::etr
__IO uint32_t etr
Definition: at32f413_can.h:742
can_type::tsts
__IO uint32_t tsts
Definition: at32f413_can.h:637
can_type::fbwsel5
__IO uint32_t fbwsel5
Definition: at32f413_can.h:846
can_type::fbwcfg
__IO uint32_t fbwcfg
Definition: at32f413_can.h:838
can_type::qdzif
__IO uint32_t qdzif
Definition: at32f413_can.h:621
can_type::tcien
__IO uint32_t tcien
Definition: at32f413_can.h:710
can_type::fbwsel2
__IO uint32_t fbwsel2
Definition: at32f413_can.h:843
can_type::fmsel8
__IO uint32_t fmsel8
Definition: at32f413_can.h:818
can_type::rf0mn
__IO uint32_t rf0mn
Definition: at32f413_can.h:676
can_type::fmsel5
__IO uint32_t fmsel5
Definition: at32f413_can.h:815
can_type::rf0ff
__IO uint32_t rf0ff
Definition: at32f413_can.h:678
can_type::frfsel0
__IO uint32_t frfsel0
Definition: at32f413_can.h:872
can_type::reserved2
__IO uint32_t reserved2
can reserved register, offset:0x1D0~0x1FC
Definition: at32f413_can.h:606
can_type::fcs
__IO uint32_t fcs
Definition: at32f413_can.h:797
can_type::msts
__IO uint32_t msts
Definition: at32f413_can.h:615
can_type::lsamprx
__IO uint32_t lsamprx
Definition: at32f413_can.h:626
can_type::faen13
__IO uint32_t faen13
Definition: at32f413_can.h:916
can_type::tm0alf
__IO uint32_t tm0alf
Definition: at32f413_can.h:642
can_type::rec
__IO uint32_t rec
Definition: at32f413_can.h:745
can_type::bts1
__IO uint32_t bts1
Definition: at32f413_can.h:759
can_type::fmsel7
__IO uint32_t fmsel7
Definition: at32f413_can.h:817
can_type::rf1r
__IO uint32_t rf1r
Definition: at32f413_can.h:697
can_type::tm1lpf
__IO uint32_t tm1lpf
Definition: at32f413_can.h:663
can_type::tm2tsf
__IO uint32_t tm2tsf
Definition: at32f413_can.h:653
can_type::frfsel5
__IO uint32_t frfsel5
Definition: at32f413_can.h:877
can_type::faen9
__IO uint32_t faen9
Definition: at32f413_can.h:912
can_type::fmsel6
__IO uint32_t fmsel6
Definition: at32f413_can.h:816
can_type::rf1fien
__IO uint32_t rf1fien
Definition: at32f413_can.h:715
can_type::faen5
__IO uint32_t faen5
Definition: at32f413_can.h:908
can_type::rf1of
__IO uint32_t rf1of
Definition: at32f413_can.h:696
can_type::fbwsel12
__IO uint32_t fbwsel12
Definition: at32f413_can.h:853
can_type::tm0tef
__IO uint32_t tm0tef
Definition: at32f413_can.h:643
can_type::fzen
__IO uint32_t fzen
Definition: at32f413_can.h:595
can_type::mmssr
__IO uint32_t mmssr
Definition: at32f413_can.h:597
can_type::faen12
__IO uint32_t faen12
Definition: at32f413_can.h:915
can_type::frfsel3
__IO uint32_t frfsel3
Definition: at32f413_can.h:875
can_type::tm2tef
__IO uint32_t tm2tef
Definition: at32f413_can.h:655
can_type::inten
__IO uint32_t inten
Definition: at32f413_can.h:707
can_type::fmcfg
__IO uint32_t fmcfg
Definition: at32f413_can.h:807
can_type::tm1tsf
__IO uint32_t tm1tsf
Definition: at32f413_can.h:647
can_type::curs
__IO uint32_t curs
Definition: at32f413_can.h:625


AT32F413 Firmwary Library: at32f413_crc.c Source File

  • libraries
  • drivers
  • src
at32f413_crc.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef CRC_MODULE_ENABLED
37
47void crc_data_reset(void)
48{
49 /* reset crc generator */
50 CRC->ctrl_bit.rst = 0x1;
51}
52
58uint32_t crc_one_word_calculate(uint32_t data)
59{
60 CRC->dt = data;
61 return (CRC->dt);
62}
63
70uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
71{
72 uint32_t index = 0;
73
74 for(index = 0; index < length; index++)
75 {
76 CRC->dt = pbuffer[index];
77 }
78
79 return (CRC->dt);
80}
81
87uint32_t crc_data_get(void)
88{
89 return (CRC->dt);
90}
91
97void crc_common_data_set(uint8_t cdt_value)
98{
99 CRC->cdt_bit.cdt = cdt_value;
100}
101
107uint8_t crc_common_data_get(void)
108{
109 return (CRC->cdt_bit.cdt);
110}
111
117void crc_init_data_set(uint32_t value)
118{
119 CRC->idt = value;
120}
121
132void crc_reverse_input_data_set(crc_reverse_input_type value)
133{
134 CRC->ctrl_bit.revid = value;
135}
136
145void crc_reverse_output_data_set(crc_reverse_output_type value)
146{
147 CRC->ctrl_bit.revod = value;
148}
149
156void crc_poly_value_set(uint32_t value)
157{
158 CRC->poly = value;
159}
160
166uint32_t crc_poly_value_get(void)
167{
168 return (CRC->poly);
169}
170
181void crc_poly_size_set(crc_poly_size_type size)
182{
183 CRC->ctrl_bit.poly_size = size;
184}
185
191 crc_poly_size_type crc_poly_size_get(void)
192{
193 return (crc_poly_size_type)(CRC->ctrl_bit.poly_size);
194}
195
200#endif
201
crc_reverse_output_type
crc_reverse_output_type
crc reverse output data
Definition: at32f413_crc.h:64
crc_reverse_input_type
crc_reverse_input_type
crc reverse input data
Definition: at32f413_crc.h:53
crc_poly_size_type
crc_poly_size_type
crc polynomial size
Definition: at32f413_crc.h:73
crc_poly_value_get
uint32_t crc_poly_value_get(void)
return crc polynomial value
Definition: at32f413_crc.c:166
crc_reverse_input_data_set
void crc_reverse_input_data_set(crc_reverse_input_type value)
control the reversal of the bit order in the input data
Definition: at32f413_crc.c:132
crc_poly_size_set
void crc_poly_size_set(crc_poly_size_type size)
config crc polynomial data size
Definition: at32f413_crc.c:181
crc_poly_value_set
void crc_poly_value_set(uint32_t value)
config crc polynomial value
Definition: at32f413_crc.c:156
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f413_crc.c:70
crc_init_data_set
void crc_init_data_set(uint32_t value)
set the 32-bit initial data of crc
Definition: at32f413_crc.c:117
crc_common_data_set
void crc_common_data_set(uint8_t cdt_value)
store a 8-bit data in the common data register.
Definition: at32f413_crc.c:97
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:47
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f413_crc.c:87
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:58
crc_poly_size_get
crc_poly_size_type crc_poly_size_get(void)
return crc polynomial data size
Definition: at32f413_crc.c:191
crc_reverse_output_data_set
void crc_reverse_output_data_set(crc_reverse_output_type value)
control the reversal of the bit order in the output data
Definition: at32f413_crc.c:145
crc_common_data_get
uint8_t crc_common_data_get(void)
return the 8-bit data stored in the common data register
Definition: at32f413_crc.c:107
CRC
#define CRC
Definition: at32f413_crc.h:162
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_crc.h Source File

  • libraries
  • drivers
  • inc
at32f413_crc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CRC_H
27#define __AT32F413_CRC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
52typedef enum
53{
54 CRC_REVERSE_INPUT_NO_AFFECTE = 0x00,
55 CRC_REVERSE_INPUT_BY_BYTE = 0x01,
56 CRC_REVERSE_INPUT_BY_HALFWORD = 0x02,
57 CRC_REVERSE_INPUT_BY_WORD = 0x03
58} crc_reverse_input_type;
59
63typedef enum
64{
65 CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00,
66 CRC_REVERSE_OUTPUT_DATA = 0x01
67} crc_reverse_output_type;
68
72typedef enum
73{
74 CRC_POLY_SIZE_32B = 0x00,
75 CRC_POLY_SIZE_16B = 0x01,
76 CRC_POLY_SIZE_8B = 0x02,
77 CRC_POLY_SIZE_7B = 0x03
78} crc_poly_size_type;
79
83typedef struct
84{
88 union
89 {
90 __IO uint32_t dt;
91 struct
92 {
93 __IO uint32_t dt : 32; /* [31:0] */
94 } dt_bit;
95 };
96
100 union
101 {
102 __IO uint32_t cdt;
103 struct
104 {
105 __IO uint32_t cdt : 8 ; /* [7:0] */
106 __IO uint32_t reserved1 : 24 ;/* [31:8] */
107 } cdt_bit;
108 };
109
113 union
114 {
115 __IO uint32_t ctrl;
116 struct
117 {
118 __IO uint32_t rst : 1 ; /* [0] */
119 __IO uint32_t reserved1 : 2 ; /* [2:1] */
120 __IO uint32_t poly_size : 2 ; /* [4:3] */
121 __IO uint32_t revid : 2 ; /* [6:5] */
122 __IO uint32_t revod : 1 ; /* [7] */
123 __IO uint32_t reserved2 : 24 ;/* [31:8] */
124 } ctrl_bit;
125 };
126
130 __IO uint32_t reserved1;
131
135 union
136 {
137 __IO uint32_t idt;
138 struct
139 {
140 __IO uint32_t idt : 32; /* [31:0] */
141 } idt_bit;
142 };
143
147 union
148 {
149 __IO uint32_t poly;
150 struct
151 {
152 __IO uint32_t poly : 32; /* [31:0] */
153 } poly_bit;
154 };
155
156} crc_type;
157
162#define CRC ((crc_type *) CRC_BASE)
163
168void crc_data_reset(void);
169uint32_t crc_one_word_calculate(uint32_t data);
170uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length);
171uint32_t crc_data_get(void);
172void crc_common_data_set(uint8_t cdt_value);
173uint8_t crc_common_data_get(void);
174void crc_init_data_set(uint32_t value);
175void crc_reverse_input_data_set(crc_reverse_input_type value);
176void crc_reverse_output_data_set(crc_reverse_output_type value);
177void crc_poly_value_set(uint32_t value);
178uint32_t crc_poly_value_get(void);
179void crc_poly_size_set(crc_poly_size_type size);
180 crc_poly_size_type crc_poly_size_get(void);
181
194#ifdef __cplusplus
195}
196#endif
197
198#endif
at32f413.h
at32f413 header file
crc_poly_value_get
uint32_t crc_poly_value_get(void)
return crc polynomial value
Definition: at32f413_crc.c:166
crc_reverse_input_data_set
void crc_reverse_input_data_set(crc_reverse_input_type value)
control the reversal of the bit order in the input data
Definition: at32f413_crc.c:132
crc_poly_size_set
void crc_poly_size_set(crc_poly_size_type size)
config crc polynomial data size
Definition: at32f413_crc.c:181
crc_poly_value_set
void crc_poly_value_set(uint32_t value)
config crc polynomial value
Definition: at32f413_crc.c:156
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f413_crc.c:70
crc_init_data_set
void crc_init_data_set(uint32_t value)
set the 32-bit initial data of crc
Definition: at32f413_crc.c:117
crc_common_data_set
void crc_common_data_set(uint8_t cdt_value)
store a 8-bit data in the common data register.
Definition: at32f413_crc.c:97
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:47
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f413_crc.c:87
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:58
crc_poly_size_get
crc_poly_size_type crc_poly_size_get(void)
return crc polynomial data size
Definition: at32f413_crc.c:191
crc_reverse_output_data_set
void crc_reverse_output_data_set(crc_reverse_output_type value)
control the reversal of the bit order in the output data
Definition: at32f413_crc.c:145
crc_common_data_get
uint8_t crc_common_data_get(void)
return the 8-bit data stored in the common data register
Definition: at32f413_crc.c:107
crc_reverse_output_type
crc_reverse_output_type
crc reverse output data
Definition: at32f413_crc.h:64
crc_reverse_input_type
crc_reverse_input_type
crc reverse input data
Definition: at32f413_crc.h:53
crc_poly_size_type
crc_poly_size_type
crc polynomial size
Definition: at32f413_crc.h:73
CRC_REVERSE_OUTPUT_DATA
@ CRC_REVERSE_OUTPUT_DATA
Definition: at32f413_crc.h:66
CRC_REVERSE_OUTPUT_NO_AFFECTE
@ CRC_REVERSE_OUTPUT_NO_AFFECTE
Definition: at32f413_crc.h:65
CRC_REVERSE_INPUT_BY_HALFWORD
@ CRC_REVERSE_INPUT_BY_HALFWORD
Definition: at32f413_crc.h:56
CRC_REVERSE_INPUT_BY_WORD
@ CRC_REVERSE_INPUT_BY_WORD
Definition: at32f413_crc.h:57
CRC_REVERSE_INPUT_BY_BYTE
@ CRC_REVERSE_INPUT_BY_BYTE
Definition: at32f413_crc.h:55
CRC_REVERSE_INPUT_NO_AFFECTE
@ CRC_REVERSE_INPUT_NO_AFFECTE
Definition: at32f413_crc.h:54
CRC_POLY_SIZE_8B
@ CRC_POLY_SIZE_8B
Definition: at32f413_crc.h:76
CRC_POLY_SIZE_32B
@ CRC_POLY_SIZE_32B
Definition: at32f413_crc.h:74
CRC_POLY_SIZE_7B
@ CRC_POLY_SIZE_7B
Definition: at32f413_crc.h:77
CRC_POLY_SIZE_16B
@ CRC_POLY_SIZE_16B
Definition: at32f413_crc.h:75
crc_type
type define crc register all
Definition: at32f413_crc.h:84
crc_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_crc.h:115
crc_type::cdt
__IO uint32_t cdt
Definition: at32f413_crc.h:102
crc_type::poly
__IO uint32_t poly
Definition: at32f413_crc.h:149
crc_type::dt
__IO uint32_t dt
Definition: at32f413_crc.h:90
crc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_crc.h:123
crc_type::rst
__IO uint32_t rst
Definition: at32f413_crc.h:118
crc_type::revod
__IO uint32_t revod
Definition: at32f413_crc.h:122
crc_type::idt
__IO uint32_t idt
Definition: at32f413_crc.h:137
crc_type::poly_size
__IO uint32_t poly_size
Definition: at32f413_crc.h:120
crc_type::reserved1
__IO uint32_t reserved1
crm reserved1 register, offset:0x0C
Definition: at32f413_crc.h:106
crc_type::revid
__IO uint32_t revid
Definition: at32f413_crc.h:121


AT32F413 Firmwary Library: at32f413_crm.c Source File

  • libraries
  • drivers
  • src
at32f413_crm.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef CRM_MODULE_ENABLED
37
47void crm_reset(void)
48{
49 /* reset the crm clock configuration to the default reset state(for debug purpose) */
50 /* set hicken bit */
51 CRM->ctrl_bit.hicken = TRUE;
52
53 /* wait hick stable */
54 while(CRM->ctrl_bit.hickstbl != SET);
55
56 /* hick used as system clock */
57 CRM->cfg_bit.sclksel = CRM_SCLK_HICK;
58
59 /* wait sclk switch status */
60 while(CRM->cfg_bit.sclksts != CRM_SCLK_HICK);
61
62 /* reset hexten, hextbyps, cfden and pllen bits */
63 CRM->ctrl &= ~(0x010D0000U);
64
65 /* reset cfg register, include sclk switch, ahbdiv, apb1div, apb2div, adcdiv,
66 clkout pllrcs, pllhextdiv, pllmult, usbdiv and pllrange bits */
67 CRM->cfg = 0;
68
69 /* reset clkout[3], usbbufs, hickdiv, clkoutdiv */
70 CRM->misc1 = 0;
71
72 /* disable all interrupts enable and clear pending bits */
73 CRM->clkint = 0x009F0000;
74}
75
81void crm_lext_bypass(confirm_state new_state)
82{
83 CRM->bpdc_bit.lextbyps = new_state;
84}
85
91void crm_hext_bypass(confirm_state new_state)
92{
93 CRM->ctrl_bit.hextbyps = new_state;
94}
95
120 flag_status crm_flag_get(uint32_t flag)
121{
122 flag_status status = RESET;
123 if((CRM_REG(flag) & CRM_REG_BIT(flag)) != CRM_REG_BIT(flag))
124 {
125 status = RESET;
126 }
127 else
128 {
129 status = SET;
130 }
131 return status;
132}
133
139 error_status crm_hext_stable_wait(void)
140{
141 uint32_t stable_cnt = 0;
142 error_status status = ERROR;
143
144 while((crm_flag_get(CRM_HEXT_STABLE_FLAG) != SET) && (stable_cnt < HEXT_STARTUP_TIMEOUT))
145 {
146 stable_cnt ++;
147 }
148
149 if(crm_flag_get(CRM_HEXT_STABLE_FLAG) != SET)
150 {
151 status = ERROR;
152 }
153 else
154 {
155 status = SUCCESS;
156 }
157
158 return status;
159}
160
166void crm_hick_clock_trimming_set(uint8_t trim_value)
167{
168 CRM->ctrl_bit.hicktrim = trim_value;
169}
170
176void crm_hick_clock_calibration_set(uint8_t cali_value)
177{
178 /* enable write hick calibration */
179 CRM->misc1_bit.hickcal_key = 0x5A;
180
181 /* write hick calibration value */
182 CRM->ctrl_bit.hickcal = cali_value;
183
184 /* disable write hick calibration */
185 CRM->misc1_bit.hickcal_key = 0x0;
186}
187
204void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
205{
206 /* enable periph clock */
207 if(TRUE == new_state)
208 {
209 CRM_REG(value) |= CRM_REG_BIT(value);
210 }
211 /* disable periph clock */
212 else
213 {
214 CRM_REG(value) &= ~(CRM_REG_BIT(value));
215 }
216}
217
234void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
235{
236 /* enable periph reset */
237 if(new_state == TRUE)
238 {
239 CRM_REG(value) |= (CRM_REG_BIT(value));
240 }
241 /* disable periph reset */
242 else
243 {
244 CRM_REG(value) &= ~(CRM_REG_BIT(value));
245 }
246}
247
257void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state)
258{
259 /* enable periph clock in sleep mode */
260 if(new_state == TRUE)
261 {
262 CRM_REG(value) |= (CRM_REG_BIT(value));
263 }
264 /* disable perph clock in sleep mode */
265 else
266 {
267 CRM_REG(value) &= ~(CRM_REG_BIT(value));
268 }
269}
270
283void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
284{
285 switch(source)
286 {
287 case CRM_CLOCK_SOURCE_HICK:
288 CRM->ctrl_bit.hicken = new_state;
289 break;
290 case CRM_CLOCK_SOURCE_HEXT:
291 CRM->ctrl_bit.hexten = new_state;
292 break;
293 case CRM_CLOCK_SOURCE_PLL:
294 CRM->ctrl_bit.pllen = new_state;
295 break;
296 case CRM_CLOCK_SOURCE_LEXT:
297 CRM->bpdc_bit.lexten = new_state;
298 break;
299 case CRM_CLOCK_SOURCE_LICK:
300 CRM->ctrlsts_bit.licken = new_state;
301 break;
302 default:
303 break;
304 }
305}
306
328void crm_flag_clear(uint32_t flag)
329{
330 switch(flag)
331 {
332 case CRM_NRST_RESET_FLAG:
333 case CRM_POR_RESET_FLAG:
334 case CRM_SW_RESET_FLAG:
335 case CRM_WDT_RESET_FLAG:
336 case CRM_WWDT_RESET_FLAG:
337 case CRM_LOWPOWER_RESET_FLAG:
338 case CRM_ALL_RESET_FLAG:
339 CRM->ctrlsts_bit.rstfc = TRUE;
340 while(CRM->ctrlsts_bit.rstfc == TRUE);
341 break;
342 case CRM_LICK_READY_INT_FLAG:
343 CRM->clkint_bit.lickstblfc = TRUE;
344 break;
345 case CRM_LEXT_READY_INT_FLAG:
346 CRM->clkint_bit.lextstblfc = TRUE;
347 break;
348 case CRM_HICK_READY_INT_FLAG:
349 CRM->clkint_bit.hickstblfc = TRUE;
350 break;
351 case CRM_HEXT_READY_INT_FLAG:
352 CRM->clkint_bit.hextstblfc = TRUE;
353 break;
354 case CRM_PLL_READY_INT_FLAG:
355 CRM->clkint_bit.pllstblfc = TRUE;
356 break;
357 case CRM_CLOCK_FAILURE_INT_FLAG:
358 CRM->clkint_bit.cfdfc = TRUE;
359 break;
360 default:
361 break;
362 }
363}
364
374void crm_rtc_clock_select(crm_rtc_clock_type value)
375{
376 CRM->bpdc_bit.rtcsel = value;
377}
378
384void crm_rtc_clock_enable(confirm_state new_state)
385{
386 CRM->bpdc_bit.rtcen = new_state;
387}
388
404void crm_ahb_div_set(crm_ahb_div_type value)
405{
406 CRM->cfg_bit.ahbdiv = value;
407}
408
421void crm_apb1_div_set(crm_apb1_div_type value)
422{
423 CRM->cfg_bit.apb1div = value;
424}
425
438void crm_apb2_div_set(crm_apb2_div_type value)
439{
440 CRM->cfg_bit.apb2div = value;
441}
442
455void crm_adc_clock_div_set(crm_adc_div_type div_value)
456{
457 CRM->cfg_bit.adcdiv_l = div_value & 0x03;
458 CRM->cfg_bit.adcdiv_h = (div_value >> 2) & 0x01;
459}
460
474void crm_usb_clock_div_set(crm_usb_div_type div_value)
475{
476 CRM->cfg_bit.usbdiv_l = div_value & 0x03;
477 CRM->cfg_bit.usbdiv_h = (div_value >> 2) & 0x01;
478}
479
485void crm_clock_failure_detection_enable(confirm_state new_state)
486{
487 CRM->ctrl_bit.cfden = new_state;
488}
489
495void crm_battery_powered_domain_reset(confirm_state new_state)
496{
497 CRM->bpdc_bit.bpdrst = new_state;
498}
499
514void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
515{
516 /* config pll clock source */
517 if(clock_source == CRM_PLL_SOURCE_HICK)
518 {
519 CRM->cfg_bit.pllrcs = FALSE;
520 CRM->misc1_bit.hickdiv = CRM_HICK48_NODIV;
521 }
522 else
523 {
524 CRM->cfg_bit.pllrcs = TRUE;
525 if(CRM_PLL_SOURCE_HEXT == clock_source)
526 {
527 CRM->cfg_bit.pllhextdiv = FALSE;
528 }
529 else
530 {
531 CRM->cfg_bit.pllhextdiv = TRUE;
532 }
533 }
534
535 /* config pll multiplication factor */
536 CRM->cfg_bit.pllmult_l = (mult_value & 0x0F);
537 CRM->cfg_bit.pllmult_h = ((mult_value & 0x30) >> 4);
538
539 /* config pll output range */
540 CRM->cfg_bit.pllrange = pll_range;
541}
542
552void crm_sysclk_switch(crm_sclk_type value)
553{
554 CRM->cfg_bit.sclksel = value;
555}
556
566 crm_sclk_type crm_sysclk_switch_status_get(void)
567{
568 return (crm_sclk_type)CRM->cfg_bit.sclksts;
569}
570
577void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
578{
579 uint32_t pll_mult = 0, pll_mult_h = 0, pll_clock_source = 0, temp = 0, div_value = 0;
580 crm_sclk_type sclk_source;
581
582 static const uint8_t sclk_ahb_div_table[16] = {0, 0, 0, 0, 0, 0, 0, 0, 1, 2, 3, 4, 6, 7, 8, 9};
583 static const uint8_t ahb_apb1_div_table[8] = {0, 0, 0, 0, 1, 2, 3, 4};
584 static const uint8_t ahb_apb2_div_table[8] = {0, 0, 0, 0, 1, 2, 3, 4};
585 static const uint8_t adc_div_table[8] = {2, 4, 6, 8, 2, 12, 8, 16};
586
587 /* get sclk source */
588 sclk_source = crm_sysclk_switch_status_get();
589
590 switch(sclk_source)
591 {
592 case CRM_SCLK_HICK:
593 if(((CRM->misc3_bit.hick_to_sclk) != RESET) && ((CRM->misc1_bit.hickdiv) != RESET))
594 clocks_struct->sclk_freq = HICK_VALUE * 6;
595 else
596 clocks_struct->sclk_freq = HICK_VALUE;
597 break;
598 case CRM_SCLK_HEXT:
599 clocks_struct->sclk_freq = HEXT_VALUE;
600 break;
601 case CRM_SCLK_PLL:
602 pll_clock_source = CRM->cfg_bit.pllrcs;
603 /* get multiplication factor */
604 pll_mult = CRM->cfg_bit.pllmult_l;
605 pll_mult_h = CRM->cfg_bit.pllmult_h;
606
607 /* process high bits */
608 if((pll_mult_h != 0U) || (pll_mult == 15U))
609 {
610 pll_mult += ((16U * pll_mult_h) + 1U);
611 }
612 else
613 {
614 pll_mult += 2U;
615 }
616
617 if (pll_clock_source == 0x00)
618 {
619 /* hick divided by 2 selected as pll clock entry */
620 clocks_struct->sclk_freq = (HICK_VALUE >> 1) * pll_mult;
621 }
622 else
623 {
624 /* hext selected as pll clock entry */
625 if (CRM->cfg_bit.pllhextdiv != RESET)
626 {
627 /* hext clock divided by 2 */
628 clocks_struct->sclk_freq = (HEXT_VALUE / 2) * pll_mult;
629 }
630 else
631 {
632 clocks_struct->sclk_freq = HEXT_VALUE * pll_mult;
633 }
634 }
635 break;
636 default:
637 clocks_struct->sclk_freq = HICK_VALUE;
638 break;
639 }
640
641 /* compute sclk, ahbclk, abp1clk apb2clk and adcclk frequencies */
642 /* get ahb division */
643 temp = CRM->cfg_bit.ahbdiv;
644 div_value = sclk_ahb_div_table[temp];
645 /* ahbclk frequency */
646 clocks_struct->ahb_freq = clocks_struct->sclk_freq >> div_value;
647
648 /* get apb1 division */
649 temp = CRM->cfg_bit.apb1div;
650 div_value = ahb_apb1_div_table[temp];
651 /* apb1clk frequency */
652 clocks_struct->apb1_freq = clocks_struct->ahb_freq >> div_value;
653
654 /* get apb2 division */
655 temp = CRM->cfg_bit.apb2div;
656 div_value = ahb_apb2_div_table[temp];
657 /* apb2clk frequency */
658 clocks_struct->apb2_freq = clocks_struct->ahb_freq >> div_value;
659
660 /* get adc division */
661 temp = CRM->cfg_bit.adcdiv_h;
662 temp = ((temp << 2) | (CRM->cfg_bit.adcdiv_l));
663 div_value = adc_div_table[temp];
664 /* adcclk clock frequency */
665 clocks_struct->adc_freq = clocks_struct->apb2_freq / div_value;
666}
667
684void crm_clock_out_set(crm_clkout_select_type clkout)
685{
686 CRM->cfg_bit.clkout_sel = clkout & 0x7;
687 CRM->misc1_bit.clkout_sel = (clkout >> 3) & 0x1;
688}
689
702void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
703{
704 if(new_state == TRUE)
705 CRM->clkint |= crm_int;
706 else
707 CRM->clkint &= ~crm_int;
708}
709
715void crm_auto_step_mode_enable(confirm_state new_state)
716{
717 if(new_state == TRUE)
718 CRM->misc3_bit.auto_step_en = CRM_AUTO_STEP_MODE_ENABLE;
719 else
720 CRM->misc3_bit.auto_step_en = CRM_AUTO_STEP_MODE_DISABLE;
721}
722
731void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap)
732{
733 CRM->intmap_bit.usbintmap = int_remap;
734}
735
744void crm_hick_divider_select(crm_hick_div_6_type value)
745{
746 CRM->misc1_bit.hickdiv = value;
747}
748
757void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
758{
759 crm_hick_divider_select(CRM_HICK48_NODIV);
760 CRM->misc3_bit.hick_to_sclk = value;
761}
762
771void crm_usb_clock_source_select(crm_usb_clock_source_type value)
772{
773 if(value == CRM_USB_CLOCK_SOURCE_HICK)
774 {
775 crm_hick_sclk_frequency_select(CRM_HICK_SCLK_48MHZ);
776 }
777 CRM->misc3_bit.hick_to_usb = value;
778}
779
785void crm_clkout_to_tmr10_enable(confirm_state new_state)
786{
787 CRM->misc2_bit.clk_to_tmr = new_state;
788}
789
805void crm_clkout_div_set(crm_clkout_div_type clkout_div)
806{
807 CRM->misc1_bit.clkoutdiv = clkout_div;
808}
809
814#endif
815
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f413_crm.h:100
crm_hick_sclk_frequency_type
crm_hick_sclk_frequency_type
crm hick as system clock frequency select
Definition: at32f413_crm.h:460
crm_apb1_div_type
crm_apb1_div_type
crm apb1 division
Definition: at32f413_crm.h:319
crm_clock_source_type
crm_clock_source_type
crm clock source
Definition: at32f413_crm.h:291
crm_usb_div_type
crm_usb_div_type
crm usb division
Definition: at32f413_crm.h:356
crm_clkout_div_type
crm_clkout_div_type
crm clkout division
Definition: at32f413_crm.h:417
crm_usb_clock_source_type
crm_usb_clock_source_type
crm usb 48 mhz clock source select
Definition: at32f413_crm.h:451
crm_periph_clock_sleepmd_type
crm_periph_clock_sleepmd_type
crm periph clock in sleep mode
Definition: at32f413_crm.h:192
crm_pll_clock_source_type
crm_pll_clock_source_type
crm pll clock source
Definition: at32f413_crm.h:272
crm_pll_mult_type
crm_pll_mult_type
crm pll mult_x
Definition: at32f413_crm.h:202
crm_ahb_div_type
crm_ahb_div_type
crm ahb division
Definition: at32f413_crm.h:303
crm_rtc_clock_type
crm_rtc_clock_type
crm rtc clock
Definition: at32f413_crm.h:370
crm_adc_div_type
crm_adc_div_type
crm adc division
Definition: at32f413_crm.h:343
crm_usb_int_map_type
crm_usb_int_map_type
crm usbdev interrupt remap
Definition: at32f413_crm.h:442
crm_clkout_select_type
crm_clkout_select_type
crm clkout select
Definition: at32f413_crm.h:400
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f413_crm.h:390
crm_periph_reset_type
crm_periph_reset_type
crm periph reset
Definition: at32f413_crm.h:148
crm_apb2_div_type
crm_apb2_div_type
crm apb2 division
Definition: at32f413_crm.h:331
crm_pll_output_range_type
crm_pll_output_range_type
crm pll clock output range
Definition: at32f413_crm.h:282
crm_hick_div_6_type
crm_hick_div_6_type
crm hick 48mhz division
Definition: at32f413_crm.h:381
CRM_HICK_SCLK_48MHZ
@ CRM_HICK_SCLK_48MHZ
Definition: at32f413_crm.h:462
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:292
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:295
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f413_crm.h:274
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:273
CRM_AUTO_STEP_MODE_ENABLE
@ CRM_AUTO_STEP_MODE_ENABLE
Definition: at32f413_crm.h:435
CRM_AUTO_STEP_MODE_DISABLE
@ CRM_AUTO_STEP_MODE_DISABLE
Definition: at32f413_crm.h:434
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f413_crm.h:391
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f413_crm.h:392
CRM_HICK48_NODIV
@ CRM_HICK48_NODIV
Definition: at32f413_crm.h:383
CRM_PLL_READY_INT_FLAG
#define CRM_PLL_READY_INT_FLAG
Definition: at32f413_crm.h:69
CRM_HEXT_READY_INT_FLAG
#define CRM_HEXT_READY_INT_FLAG
Definition: at32f413_crm.h:68
CRM_LOWPOWER_RESET_FLAG
#define CRM_LOWPOWER_RESET_FLAG
Definition: at32f413_crm.h:64
CRM_CLOCK_FAILURE_INT_FLAG
#define CRM_CLOCK_FAILURE_INT_FLAG
Definition: at32f413_crm.h:70
CRM_HICK_READY_INT_FLAG
#define CRM_HICK_READY_INT_FLAG
Definition: at32f413_crm.h:67
CRM_LEXT_READY_INT_FLAG
#define CRM_LEXT_READY_INT_FLAG
Definition: at32f413_crm.h:66
CRM_POR_RESET_FLAG
#define CRM_POR_RESET_FLAG
Definition: at32f413_crm.h:60
CRM_HEXT_STABLE_FLAG
#define CRM_HEXT_STABLE_FLAG
Definition: at32f413_crm.h:54
CRM_SW_RESET_FLAG
#define CRM_SW_RESET_FLAG
Definition: at32f413_crm.h:61
CRM_NRST_RESET_FLAG
#define CRM_NRST_RESET_FLAG
Definition: at32f413_crm.h:59
CRM_WWDT_RESET_FLAG
#define CRM_WWDT_RESET_FLAG
Definition: at32f413_crm.h:63
CRM_LICK_READY_INT_FLAG
#define CRM_LICK_READY_INT_FLAG
Definition: at32f413_crm.h:65
CRM_ALL_RESET_FLAG
#define CRM_ALL_RESET_FLAG
Definition: at32f413_crm.h:58
CRM_WDT_RESET_FLAG
#define CRM_WDT_RESET_FLAG
Definition: at32f413_crm.h:62
crm_periph_sleep_mode_clock_enable
void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode
Definition: at32f413_crm.c:257
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hick_clock_calibration_set
void crm_hick_clock_calibration_set(uint8_t cali_value)
set the crm calibration value
Definition: at32f413_crm.c:176
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:805
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:374
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:384
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_interrupt_enable
void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
config crm interrupt
Definition: at32f413_crm.c:702
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:328
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_lext_bypass
void crm_lext_bypass(confirm_state new_state)
enable or disable crm low speed external crystal bypass
Definition: at32f413_crm.c:81
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_hick_sclk_frequency_select
void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
hick as system clock frequency select
Definition: at32f413_crm.c:757
crm_hick_divider_select
void crm_hick_divider_select(crm_hick_div_6_type value)
config hick divider select
Definition: at32f413_crm.c:744
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:684
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f413_crm.c:485
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_clkout_to_tmr10_enable
void crm_clkout_to_tmr10_enable(confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1
Definition: at32f413_crm.c:785
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_usb_interrupt_remapping_set
void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap)
usbdev interrupt remapping control
Definition: at32f413_crm.c:731
crm_hick_clock_trimming_set
void crm_hick_clock_trimming_set(uint8_t trim_value)
set the hick trimming value
Definition: at32f413_crm.c:166
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f413_crm.c:495
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
crm_hext_bypass
void crm_hext_bypass(confirm_state new_state)
enable or disable crm high speed external crystal bypass
Definition: at32f413_crm.c:91
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_REG_BIT
#define CRM_REG_BIT(value)
Definition: at32f413_crm.h:46
CRM
#define CRM
Definition: at32f413_crm.h:842
CRM_REG
#define CRM_REG(value)
Definition: at32f413_crm.h:45
error_status
error_status
error status
Definition: at32f413.h:301
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
HEXT_VALUE
#define HEXT_VALUE
in the following line adjust the value of high speed exernal crystal (hext) used in your application
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:42
HICK_VALUE
#define HICK_VALUE
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:50
HEXT_STARTUP_TIMEOUT
#define HEXT_STARTUP_TIMEOUT
in the following line adjust the high speed exernal crystal (hext) startup timeout value
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:49
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::adc_freq
uint32_t adc_freq
Definition: at32f413_crm.h:474
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:473
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f413_crm.h:472
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:471
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_crm.h Source File

  • libraries
  • drivers
  • inc
at32f413_crm.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CRM_H
27#define __AT32F413_CRM_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
45#define CRM_REG(value) PERIPH_REG(CRM_BASE, value)
46#define CRM_REG_BIT(value) PERIPH_REG_BIT(value)
47
53#define CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
54#define CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
55#define CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
56#define CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)
57#define CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)
58#define CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)
59#define CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)
60#define CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)
61#define CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)
62#define CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)
63#define CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)
64#define CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)
65#define CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)
66#define CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)
67#define CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)
68#define CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)
69#define CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)
70#define CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)
81#define CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
82#define CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
83#define CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
84#define CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
85#define CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
86#define CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)
99typedef enum
100{
101 /* ahb periph */
102 CRM_DMA1_PERIPH_CLOCK = MAKE_VALUE(0x14, 0),
103 CRM_DMA2_PERIPH_CLOCK = MAKE_VALUE(0x14, 1),
104 CRM_CRC_PERIPH_CLOCK = MAKE_VALUE(0x14, 6),
105 CRM_SDIO1_PERIPH_CLOCK = MAKE_VALUE(0x14, 10),
106 /* apb2 periph */
107 CRM_IOMUX_PERIPH_CLOCK = MAKE_VALUE(0x18, 0),
108 CRM_GPIOA_PERIPH_CLOCK = MAKE_VALUE(0x18, 2),
109 CRM_GPIOB_PERIPH_CLOCK = MAKE_VALUE(0x18, 3),
110 CRM_GPIOC_PERIPH_CLOCK = MAKE_VALUE(0x18, 4),
111 CRM_GPIOD_PERIPH_CLOCK = MAKE_VALUE(0x18, 5),
112 CRM_GPIOF_PERIPH_CLOCK = MAKE_VALUE(0x18, 7),
113 CRM_ADC1_PERIPH_CLOCK = MAKE_VALUE(0x18, 9),
114 CRM_ADC2_PERIPH_CLOCK = MAKE_VALUE(0x18, 10),
115 CRM_TMR1_PERIPH_CLOCK = MAKE_VALUE(0x18, 11),
116 CRM_SPI1_PERIPH_CLOCK = MAKE_VALUE(0x18, 12),
117 CRM_TMR8_PERIPH_CLOCK = MAKE_VALUE(0x18, 13),
118 CRM_USART1_PERIPH_CLOCK = MAKE_VALUE(0x18, 14),
119 CRM_TMR9_PERIPH_CLOCK = MAKE_VALUE(0x18, 19),
120 CRM_TMR10_PERIPH_CLOCK = MAKE_VALUE(0x18, 20),
121 CRM_TMR11_PERIPH_CLOCK = MAKE_VALUE(0x18, 21),
122 CRM_ACC_PERIPH_CLOCK = MAKE_VALUE(0x18, 22),
123 /* apb1 periph */
124 CRM_TMR2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 0),
125 CRM_TMR3_PERIPH_CLOCK = MAKE_VALUE(0x1C, 1),
126 CRM_TMR4_PERIPH_CLOCK = MAKE_VALUE(0x1C, 2),
127 CRM_TMR5_PERIPH_CLOCK = MAKE_VALUE(0x1C, 3),
128 CRM_WWDT_PERIPH_CLOCK = MAKE_VALUE(0x1C, 11),
129 CRM_SPI2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 14),
130 CRM_USART2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 17),
131 CRM_USART3_PERIPH_CLOCK = MAKE_VALUE(0x1C, 18),
132 CRM_UART4_PERIPH_CLOCK = MAKE_VALUE(0x1C, 19),
133 CRM_UART5_PERIPH_CLOCK = MAKE_VALUE(0x1C, 20),
134 CRM_I2C1_PERIPH_CLOCK = MAKE_VALUE(0x1C, 21),
135 CRM_I2C2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 22),
136 CRM_USB_PERIPH_CLOCK = MAKE_VALUE(0x1C, 23),
137 CRM_CAN1_PERIPH_CLOCK = MAKE_VALUE(0x1C, 25),
138 CRM_BPR_PERIPH_CLOCK = MAKE_VALUE(0x1C, 27),
139 CRM_PWC_PERIPH_CLOCK = MAKE_VALUE(0x1C, 28),
140 CRM_CAN2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 31),
142} crm_periph_clock_type;
143
147typedef enum
148{
149 /* apb2 periph */
150 CRM_IOMUX_PERIPH_RESET = MAKE_VALUE(0x0C, 0),
151 CRM_EXINT_PERIPH_RESET = MAKE_VALUE(0x0C, 1),
152 CRM_GPIOA_PERIPH_RESET = MAKE_VALUE(0x0C, 2),
153 CRM_GPIOB_PERIPH_RESET = MAKE_VALUE(0x0C, 3),
154 CRM_GPIOC_PERIPH_RESET = MAKE_VALUE(0x0C, 4),
155 CRM_GPIOD_PERIPH_RESET = MAKE_VALUE(0x0C, 5),
156 CRM_GPIOF_PERIPH_RESET = MAKE_VALUE(0x0C, 7),
157 CRM_ADC1_PERIPH_RESET = MAKE_VALUE(0x0C, 9),
158 CRM_ADC2_PERIPH_RESET = MAKE_VALUE(0x0C, 10),
159 CRM_TMR1_PERIPH_RESET = MAKE_VALUE(0x0C, 11),
160 CRM_SPI1_PERIPH_RESET = MAKE_VALUE(0x0C, 12),
161 CRM_TMR8_PERIPH_RESET = MAKE_VALUE(0x0C, 13),
162 CRM_USART1_PERIPH_RESET = MAKE_VALUE(0x0C, 14),
163 CRM_TMR9_PERIPH_RESET = MAKE_VALUE(0x0C, 19),
164 CRM_TMR10_PERIPH_RESET = MAKE_VALUE(0x0C, 20),
165 CRM_TMR11_PERIPH_RESET = MAKE_VALUE(0x0C, 21),
166 CRM_ACC_PERIPH_RESET = MAKE_VALUE(0x0C, 22),
167 /* apb1 periph */
168 CRM_TMR2_PERIPH_RESET = MAKE_VALUE(0x10, 0),
169 CRM_TMR3_PERIPH_RESET = MAKE_VALUE(0x10, 1),
170 CRM_TMR4_PERIPH_RESET = MAKE_VALUE(0x10, 2),
171 CRM_TMR5_PERIPH_RESET = MAKE_VALUE(0x10, 3),
172 CRM_WWDT_PERIPH_RESET = MAKE_VALUE(0x10, 11),
173 CRM_SPI2_PERIPH_RESET = MAKE_VALUE(0x10, 14),
174 CRM_USART2_PERIPH_RESET = MAKE_VALUE(0x10, 17),
175 CRM_USART3_PERIPH_RESET = MAKE_VALUE(0x10, 18),
176 CRM_UART4_PERIPH_RESET = MAKE_VALUE(0x10, 19),
177 CRM_UART5_PERIPH_RESET = MAKE_VALUE(0x10, 20),
178 CRM_I2C1_PERIPH_RESET = MAKE_VALUE(0x10, 21),
179 CRM_I2C2_PERIPH_RESET = MAKE_VALUE(0x10, 22),
180 CRM_USB_PERIPH_RESET = MAKE_VALUE(0x10, 23),
181 CRM_CAN1_PERIPH_RESET = MAKE_VALUE(0x10, 25),
182 CRM_BPR_PERIPH_RESET = MAKE_VALUE(0x10, 27),
183 CRM_PWC_PERIPH_RESET = MAKE_VALUE(0x10, 28),
184 CRM_CAN2_PERIPH_RESET = MAKE_VALUE(0x10, 31),
186} crm_periph_reset_type;
187
191typedef enum
192{
193 /* ahb periph */
194 CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE = MAKE_VALUE(0x14, 2),
195 CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE = MAKE_VALUE(0x14, 4)
196} crm_periph_clock_sleepmd_type;
197
201typedef enum
202{
203 CRM_PLL_MULT_2 = 0,
204 CRM_PLL_MULT_3 = 1,
205 CRM_PLL_MULT_4 = 2,
206 CRM_PLL_MULT_5 = 3,
207 CRM_PLL_MULT_6 = 4,
208 CRM_PLL_MULT_7 = 5,
209 CRM_PLL_MULT_8 = 6,
210 CRM_PLL_MULT_9 = 7,
211 CRM_PLL_MULT_10 = 8,
212 CRM_PLL_MULT_11 = 9,
213 CRM_PLL_MULT_12 = 10,
214 CRM_PLL_MULT_13 = 11,
215 CRM_PLL_MULT_14 = 12,
216 CRM_PLL_MULT_15 = 13,
217 CRM_PLL_MULT_16 = 15,
218 CRM_PLL_MULT_17 = 16,
219 CRM_PLL_MULT_18 = 17,
220 CRM_PLL_MULT_19 = 18,
221 CRM_PLL_MULT_20 = 19,
222 CRM_PLL_MULT_21 = 20,
223 CRM_PLL_MULT_22 = 21,
224 CRM_PLL_MULT_23 = 22,
225 CRM_PLL_MULT_24 = 23,
226 CRM_PLL_MULT_25 = 24,
227 CRM_PLL_MULT_26 = 25,
228 CRM_PLL_MULT_27 = 26,
229 CRM_PLL_MULT_28 = 27,
230 CRM_PLL_MULT_29 = 28,
231 CRM_PLL_MULT_30 = 29,
232 CRM_PLL_MULT_31 = 30,
233 CRM_PLL_MULT_32 = 31,
234 CRM_PLL_MULT_33 = 32,
235 CRM_PLL_MULT_34 = 33,
236 CRM_PLL_MULT_35 = 34,
237 CRM_PLL_MULT_36 = 35,
238 CRM_PLL_MULT_37 = 36,
239 CRM_PLL_MULT_38 = 37,
240 CRM_PLL_MULT_39 = 38,
241 CRM_PLL_MULT_40 = 39,
242 CRM_PLL_MULT_41 = 40,
243 CRM_PLL_MULT_42 = 41,
244 CRM_PLL_MULT_43 = 42,
245 CRM_PLL_MULT_44 = 43,
246 CRM_PLL_MULT_45 = 44,
247 CRM_PLL_MULT_46 = 45,
248 CRM_PLL_MULT_47 = 46,
249 CRM_PLL_MULT_48 = 47,
250 CRM_PLL_MULT_49 = 48,
251 CRM_PLL_MULT_50 = 49,
252 CRM_PLL_MULT_51 = 50,
253 CRM_PLL_MULT_52 = 51,
254 CRM_PLL_MULT_53 = 52,
255 CRM_PLL_MULT_54 = 53,
256 CRM_PLL_MULT_55 = 54,
257 CRM_PLL_MULT_56 = 55,
258 CRM_PLL_MULT_57 = 56,
259 CRM_PLL_MULT_58 = 57,
260 CRM_PLL_MULT_59 = 58,
261 CRM_PLL_MULT_60 = 59,
262 CRM_PLL_MULT_61 = 60,
263 CRM_PLL_MULT_62 = 61,
264 CRM_PLL_MULT_63 = 62,
265 CRM_PLL_MULT_64 = 63
266} crm_pll_mult_type;
267
271typedef enum
272{
273 CRM_PLL_SOURCE_HICK = 0x00,
274 CRM_PLL_SOURCE_HEXT = 0x01,
275 CRM_PLL_SOURCE_HEXT_DIV = 0x02
276} crm_pll_clock_source_type;
277
281typedef enum
282{
283 CRM_PLL_OUTPUT_RANGE_LE72MHZ = 0x00,
284 CRM_PLL_OUTPUT_RANGE_GT72MHZ = 0x01
285} crm_pll_output_range_type;
286
290typedef enum
291{
292 CRM_CLOCK_SOURCE_HICK = 0x00,
293 CRM_CLOCK_SOURCE_HEXT = 0x01,
294 CRM_CLOCK_SOURCE_PLL = 0x02,
295 CRM_CLOCK_SOURCE_LEXT = 0x03,
296 CRM_CLOCK_SOURCE_LICK = 0x04
297} crm_clock_source_type;
298
302typedef enum
303{
304 CRM_AHB_DIV_1 = 0x00,
305 CRM_AHB_DIV_2 = 0x08,
306 CRM_AHB_DIV_4 = 0x09,
307 CRM_AHB_DIV_8 = 0x0A,
308 CRM_AHB_DIV_16 = 0x0B,
309 CRM_AHB_DIV_64 = 0x0C,
310 CRM_AHB_DIV_128 = 0x0D,
311 CRM_AHB_DIV_256 = 0x0E,
312 CRM_AHB_DIV_512 = 0x0F
313} crm_ahb_div_type;
314
318typedef enum
319{
320 CRM_APB1_DIV_1 = 0x00,
321 CRM_APB1_DIV_2 = 0x04,
322 CRM_APB1_DIV_4 = 0x05,
323 CRM_APB1_DIV_8 = 0x06,
324 CRM_APB1_DIV_16 = 0x07
325} crm_apb1_div_type;
326
330typedef enum
331{
332 CRM_APB2_DIV_1 = 0x00,
333 CRM_APB2_DIV_2 = 0x04,
334 CRM_APB2_DIV_4 = 0x05,
335 CRM_APB2_DIV_8 = 0x06,
336 CRM_APB2_DIV_16 = 0x07
337} crm_apb2_div_type;
338
342typedef enum
343{
344 CRM_ADC_DIV_2 = 0x00,
345 CRM_ADC_DIV_4 = 0x01,
346 CRM_ADC_DIV_6 = 0x02,
347 CRM_ADC_DIV_8 = 0x03,
348 CRM_ADC_DIV_12 = 0x05,
349 CRM_ADC_DIV_16 = 0x07
350} crm_adc_div_type;
351
355typedef enum
356{
357 CRM_USB_DIV_1_5 = 0x00,
358 CRM_USB_DIV_1 = 0x01,
359 CRM_USB_DIV_2_5 = 0x02,
360 CRM_USB_DIV_2 = 0x03,
361 CRM_USB_DIV_3_5 = 0x04,
362 CRM_USB_DIV_3 = 0x05,
363 CRM_USB_DIV_4 = 0x06
364} crm_usb_div_type;
365
369typedef enum
370{
371 CRM_RTC_CLOCK_NOCLK = 0x00,
372 CRM_RTC_CLOCK_LEXT = 0x01,
373 CRM_RTC_CLOCK_LICK = 0x02,
374 CRM_RTC_CLOCK_HEXT_DIV = 0x03
375} crm_rtc_clock_type;
376
380typedef enum
381{
382 CRM_HICK48_DIV6 = 0x00,
383 CRM_HICK48_NODIV = 0x01
384} crm_hick_div_6_type;
385
389typedef enum
390{
391 CRM_SCLK_HICK = 0x00,
392 CRM_SCLK_HEXT = 0x01,
393 CRM_SCLK_PLL = 0x02
394} crm_sclk_type;
395
399typedef enum
400{
401 CRM_CLKOUT_NOCLK = 0x00,
402 CRM_CLKOUT_LICK = 0x02,
403 CRM_CLKOUT_LEXT = 0x03,
404 CRM_CLKOUT_SCLK = 0x04,
405 CRM_CLKOUT_HICK = 0x05,
406 CRM_CLKOUT_HEXT = 0x06,
407 CRM_CLKOUT_PLL_DIV_2 = 0x07,
408 CRM_CLKOUT_PLL_DIV_4 = 0x0C,
409 CRM_CLKOUT_USB = 0x0D,
410 CRM_CLKOUT_ADC = 0x0E
411} crm_clkout_select_type;
412
416typedef enum
417{
418 CRM_CLKOUT_DIV_1 = 0x00,
419 CRM_CLKOUT_DIV_2 = 0x08,
420 CRM_CLKOUT_DIV_4 = 0x09,
421 CRM_CLKOUT_DIV_8 = 0x0A,
422 CRM_CLKOUT_DIV_16 = 0x0B,
423 CRM_CLKOUT_DIV_64 = 0x0C,
424 CRM_CLKOUT_DIV_128 = 0x0D,
425 CRM_CLKOUT_DIV_256 = 0x0E,
426 CRM_CLKOUT_DIV_512 = 0x0F
427} crm_clkout_div_type;
428
432typedef enum
433{
434 CRM_AUTO_STEP_MODE_DISABLE = 0x00,
435 CRM_AUTO_STEP_MODE_ENABLE = 0x03
436} crm_auto_step_mode_type;
437
441typedef enum
442{
443 CRM_USB_INT19_INT20 = 0x00,
444 CRM_USB_INT73_INT74 = 0x01
445} crm_usb_int_map_type;
446
450typedef enum
451{
452 CRM_USB_CLOCK_SOURCE_PLL = 0x00,
453 CRM_USB_CLOCK_SOURCE_HICK = 0x01
454} crm_usb_clock_source_type;
455
459typedef enum
460{
461 CRM_HICK_SCLK_8MHZ = 0x00,
462 CRM_HICK_SCLK_48MHZ = 0x01
463} crm_hick_sclk_frequency_type;
464
468typedef struct
469{
470 uint32_t sclk_freq;
471 uint32_t ahb_freq;
472 uint32_t apb2_freq;
473 uint32_t apb1_freq;
474 uint32_t adc_freq;
475} crm_clocks_freq_type;
476
480typedef struct
481{
485 union
486 {
487 __IO uint32_t ctrl;
488 struct
489 {
490 __IO uint32_t hicken : 1; /* [0] */
491 __IO uint32_t hickstbl : 1; /* [1] */
492 __IO uint32_t hicktrim : 6; /* [7:2] */
493 __IO uint32_t hickcal : 8; /* [15:8] */
494 __IO uint32_t hexten : 1; /* [16] */
495 __IO uint32_t hextstbl : 1; /* [17] */
496 __IO uint32_t hextbyps : 1; /* [18] */
497 __IO uint32_t cfden : 1; /* [19] */
498 __IO uint32_t reserved1 : 4; /* [23:20] */
499 __IO uint32_t pllen : 1; /* [24] */
500 __IO uint32_t pllstbl : 1; /* [25] */
501 __IO uint32_t reserved2 : 6; /* [31:26] */
502 } ctrl_bit;
503 };
504
508 union
509 {
510 __IO uint32_t cfg;
511 struct
512 {
513 __IO uint32_t sclksel : 2; /* [1:0] */
514 __IO uint32_t sclksts : 2; /* [3:2] */
515 __IO uint32_t ahbdiv : 4; /* [7:4] */
516 __IO uint32_t apb1div : 3; /* [10:8] */
517 __IO uint32_t apb2div : 3; /* [13:11] */
518 __IO uint32_t adcdiv_l : 2; /* [15:14] */
519 __IO uint32_t pllrcs : 1; /* [16] */
520 __IO uint32_t pllhextdiv : 1; /* [17] */
521 __IO uint32_t pllmult_l : 4; /* [21:18] */
522 __IO uint32_t usbdiv_l : 2; /* [23:22] */
523 __IO uint32_t clkout_sel : 3; /* [26:24] */
524 __IO uint32_t usbdiv_h : 1; /* [27] */
525 __IO uint32_t adcdiv_h : 1; /* [28] */
526 __IO uint32_t pllmult_h : 2; /* [30:29] */
527 __IO uint32_t pllrange : 1; /* [31] */
528 } cfg_bit;
529 };
530
534 union
535 {
536 __IO uint32_t clkint;
537 struct
538 {
539 __IO uint32_t lickstblf : 1; /* [0] */
540 __IO uint32_t lextstblf : 1; /* [1] */
541 __IO uint32_t hickstblf : 1; /* [2] */
542 __IO uint32_t hextstblf : 1; /* [3] */
543 __IO uint32_t pllstblf : 1; /* [4] */
544 __IO uint32_t reserved1 : 2; /* [6:5] */
545 __IO uint32_t cfdf : 1; /* [7] */
546 __IO uint32_t lickstblien : 1; /* [8] */
547 __IO uint32_t lextstblien : 1; /* [9] */
548 __IO uint32_t hickstblien : 1; /* [10] */
549 __IO uint32_t hextstblien : 1; /* [11] */
550 __IO uint32_t pllstblien : 1; /* [12] */
551 __IO uint32_t reserved2 : 3; /* [15:13] */
552 __IO uint32_t lickstblfc : 1; /* [16] */
553 __IO uint32_t lextstblfc : 1; /* [17] */
554 __IO uint32_t hickstblfc : 1; /* [18] */
555 __IO uint32_t hextstblfc : 1; /* [19] */
556 __IO uint32_t pllstblfc : 1; /* [20] */
557 __IO uint32_t reserved3 : 2; /* [22:21] */
558 __IO uint32_t cfdfc : 1; /* [23] */
559 __IO uint32_t reserved4 : 8; /* [31:24] */
560 } clkint_bit;
561 };
562
566 union
567 {
568 __IO uint32_t apb2rst;
569 struct
570 {
571 __IO uint32_t iomuxrst : 1; /* [0] */
572 __IO uint32_t exintrst : 1; /* [1] */
573 __IO uint32_t gpioarst : 1; /* [2] */
574 __IO uint32_t gpiobrst : 1; /* [3] */
575 __IO uint32_t gpiocrst : 1; /* [4] */
576 __IO uint32_t gpiodrst : 1; /* [5] */
577 __IO uint32_t reserved1 : 1; /* [6] */
578 __IO uint32_t gpioerst : 1; /* [7] */
579 __IO uint32_t reserved2 : 1; /* [8] */
580 __IO uint32_t adc1rst : 1; /* [9] */
581 __IO uint32_t adc2rst : 1; /* [10] */
582 __IO uint32_t tmr1rst : 1; /* [11] */
583 __IO uint32_t spi1rst : 1; /* [12] */
584 __IO uint32_t tmr8rst : 1; /* [13] */
585 __IO uint32_t usart1rst : 1; /* [14] */
586 __IO uint32_t reserved3 : 4; /* [18:15] */
587 __IO uint32_t tmr9rst : 1; /* [19] */
588 __IO uint32_t tmr10rst : 1; /* [20] */
589 __IO uint32_t tmr11rst : 1; /* [21] */
590 __IO uint32_t accrst : 1; /* [22] */
591 __IO uint32_t reserved4 : 9; /* [31:23] */
592 } apb2rst_bit;
593 };
594
598 union
599 {
600 __IO uint32_t apb1rst;
601 struct
602 {
603 __IO uint32_t tmr2rst : 1; /* [0] */
604 __IO uint32_t tmr3rst : 1; /* [1] */
605 __IO uint32_t tmr4rst : 1; /* [2] */
606 __IO uint32_t tmr5rst : 1; /* [3] */
607 __IO uint32_t reserved1 : 7; /* [10:4] */
608 __IO uint32_t wwdtrst : 1; /* [11] */
609 __IO uint32_t reserved2 : 2; /* [13:12] */
610 __IO uint32_t spi2rst : 1; /* [14] */
611 __IO uint32_t reserved3 : 2; /* [16:15] */
612 __IO uint32_t usart2rst : 1; /* [17] */
613 __IO uint32_t usart3rst : 1; /* [18] */
614 __IO uint32_t uart4rst : 1; /* [19] */
615 __IO uint32_t uart5rst : 1; /* [20] */
616 __IO uint32_t i2c1rst : 1; /* [21] */
617 __IO uint32_t i2c2rst : 1; /* [22] */
618 __IO uint32_t usbrst : 1; /* [23] */
619 __IO uint32_t reserved4 : 1; /* [24] */
620 __IO uint32_t can1rst : 1; /* [25] */
621 __IO uint32_t reserved5 : 1; /* [26] */
622 __IO uint32_t bprrst : 1; /* [27] */
623 __IO uint32_t pwcrst : 1; /* [28] */
624 __IO uint32_t reserved6 : 2; /* [31:30] */
625 __IO uint32_t can2rst : 1; /* [31] */
626 } apb1rst_bit;
627 };
628
632 union
633 {
634 __IO uint32_t ahben;
635 struct
636 {
637 __IO uint32_t dma1en : 1; /* [0] */
638 __IO uint32_t dma2en : 1; /* [1] */
639 __IO uint32_t sramen : 1; /* [2] */
640 __IO uint32_t reserved1 : 1; /* [3] */
641 __IO uint32_t flashen : 1; /* [4] */
642 __IO uint32_t reserved2 : 1; /* [5] */
643 __IO uint32_t crcen : 1; /* [6] */
644 __IO uint32_t reserved3 : 3; /* [9:7] */
645 __IO uint32_t sdio1en : 1; /* [10] */
646 __IO uint32_t reserved5 : 21;/* [31:11] */
647 } ahben_bit;
648 };
649
653 union
654 {
655 __IO uint32_t apb2en;
656 struct
657 {
658 __IO uint32_t iomuxen : 1; /* [0] */
659 __IO uint32_t reserved1 : 1; /* [1] */
660 __IO uint32_t gpioaen : 1; /* [2] */
661 __IO uint32_t gpioben : 1; /* [3] */
662 __IO uint32_t gpiocen : 1; /* [4] */
663 __IO uint32_t gpioden : 1; /* [5] */
664 __IO uint32_t reserved2 : 1; /* [6] */
665 __IO uint32_t gpiofen : 1; /* [7] */
666 __IO uint32_t reserved3 : 1; /* [8] */
667 __IO uint32_t adc1en : 1; /* [9] */
668 __IO uint32_t adc2en : 1; /* [10] */
669 __IO uint32_t tmr1en : 1; /* [11] */
670 __IO uint32_t spi1en : 1; /* [12] */
671 __IO uint32_t tmr8en : 1; /* [13] */
672 __IO uint32_t usart1en : 1; /* [14] */
673 __IO uint32_t reserved4 : 4; /* [18:15] */
674 __IO uint32_t tmr9en : 1; /* [19] */
675 __IO uint32_t tmr10en : 1; /* [20] */
676 __IO uint32_t tmr11en : 1; /* [21] */
677 __IO uint32_t accen : 1; /* [22] */
678 __IO uint32_t reserved5 : 9; /* [31:23] */
679 } apb2en_bit;
680 };
681
685 union
686 {
687 __IO uint32_t apb1en;
688 struct
689 {
690 __IO uint32_t tmr2en : 1; /* [0] */
691 __IO uint32_t tmr3en : 1; /* [1] */
692 __IO uint32_t tmr4en : 1; /* [2] */
693 __IO uint32_t tmr5en : 1; /* [3] */
694 __IO uint32_t reserved1 : 7; /* [10:4] */
695 __IO uint32_t wwdten : 1; /* [11] */
696 __IO uint32_t reserved2 : 2; /* [13:12] */
697 __IO uint32_t spi2en : 1; /* [14] */
698 __IO uint32_t reserved3 : 2; /* [16:15] */
699 __IO uint32_t usart2en : 1; /* [17] */
700 __IO uint32_t usart3en : 1; /* [18] */
701 __IO uint32_t uart4en : 1; /* [19] */
702 __IO uint32_t uart5en : 1; /* [20] */
703 __IO uint32_t i2c1en : 1; /* [21] */
704 __IO uint32_t i2c2en : 1; /* [22] */
705 __IO uint32_t usben : 1; /* [23] */
706 __IO uint32_t reserved4 : 1; /* [24] */
707 __IO uint32_t can1en : 1; /* [25] */
708 __IO uint32_t reserved5 : 1; /* [26] */
709 __IO uint32_t bpren : 1; /* [27] */
710 __IO uint32_t pwcen : 1; /* [28] */
711 __IO uint32_t reserved6 : 2; /* [30:29] */
712 __IO uint32_t can2en : 1; /* [31] */
713 } apb1en_bit;
714 };
715
719 union
720 {
721 __IO uint32_t bpdc;
722 struct
723 {
724 __IO uint32_t lexten : 1; /* [0] */
725 __IO uint32_t lextstbl : 1; /* [1] */
726 __IO uint32_t lextbyps : 1; /* [2] */
727 __IO uint32_t reserved1 : 5; /* [7:3] */
728 __IO uint32_t rtcsel : 2; /* [9:8] */
729 __IO uint32_t reserved2 : 5; /* [14:10] */
730 __IO uint32_t rtcen : 1; /* [15] */
731 __IO uint32_t bpdrst : 1; /* [16] */
732 __IO uint32_t reserved3 : 15;/* [31:17] */
733 } bpdc_bit;
734 };
735
739 union
740 {
741 __IO uint32_t ctrlsts;
742 struct
743 {
744 __IO uint32_t licken : 1; /* [0] */
745 __IO uint32_t lickstbl : 1; /* [1] */
746 __IO uint32_t reserved1 : 22;/* [23:2] */
747 __IO uint32_t rstfc : 1; /* [24] */
748 __IO uint32_t reserved2 : 1; /* [25] */
749 __IO uint32_t nrstf : 1; /* [26] */
750 __IO uint32_t porrstf : 1; /* [27] */
751 __IO uint32_t swrstf : 1; /* [28] */
752 __IO uint32_t wdtrstf : 1; /* [29] */
753 __IO uint32_t wwdtrstf : 1; /* [30] */
754 __IO uint32_t lprstf : 1; /* [31] */
755 } ctrlsts_bit;
756 };
757
761 __IO uint32_t reserved1[2];
762
766 union
767 {
768 __IO uint32_t misc1;
769 struct
770 {
771 __IO uint32_t hickcal_key : 8; /* [7:0] */
772 __IO uint32_t reserved1 : 8; /* [15:8] */
773 __IO uint32_t clkout_sel : 1; /* [16] */
774 __IO uint32_t reserved2 : 7; /* [23:17] */
775 __IO uint32_t usbbufs : 1; /* [24] */
776 __IO uint32_t hickdiv : 1; /* [25] */
777 __IO uint32_t reserved3 : 2; /* [27:26] */
778 __IO uint32_t clkoutdiv : 4; /* [31:28] */
779 } misc1_bit;
780 };
781
785 __IO uint32_t reserved2[7];
786
790 union
791 {
792 __IO uint32_t misc2;
793 struct
794 {
795 __IO uint32_t reserved1 : 16;/* [15:0] */
796 __IO uint32_t clk_to_tmr : 1; /* [16] */
797 __IO uint32_t reserved2 : 15;/* [31:17] */
798 } misc2_bit;
799 };
800
804 union
805 {
806 __IO uint32_t misc3;
807 struct
808 {
809 __IO uint32_t reserved1 : 4; /* [3:0] */
810 __IO uint32_t auto_step_en : 2; /* [5:4] */
811 __IO uint32_t reserved2 : 2; /* [7:6] */
812 __IO uint32_t hick_to_usb : 1; /* [8] */
813 __IO uint32_t hick_to_sclk : 1; /* [9] */
814 __IO uint32_t reserved3 : 22;/* [31:10] */
815 } misc3_bit;
816 };
817
821 __IO uint32_t reserved3;
822
826 union
827 {
828 __IO uint32_t intmap;
829 struct
830 {
831 __IO uint32_t usbintmap : 1; /* [0] */
832 __IO uint32_t reserved1 : 31;/* [31:1] */
833 } intmap_bit;
834 };
835
836} crm_type;
837
842#define CRM ((crm_type *) CRM_BASE)
843
848void crm_reset(void);
849void crm_lext_bypass(confirm_state new_state);
850void crm_hext_bypass(confirm_state new_state);
851 flag_status crm_flag_get(uint32_t flag);
852 error_status crm_hext_stable_wait(void);
853void crm_hick_clock_trimming_set(uint8_t trim_value);
854void crm_hick_clock_calibration_set(uint8_t cali_value);
855void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state);
856void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state);
857void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state);
858void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state);
859void crm_flag_clear(uint32_t flag);
860void crm_rtc_clock_select(crm_rtc_clock_type value);
861void crm_rtc_clock_enable(confirm_state new_state);
862void crm_ahb_div_set(crm_ahb_div_type value);
863void crm_apb1_div_set(crm_apb1_div_type value);
864void crm_apb2_div_set(crm_apb2_div_type value);
865void crm_adc_clock_div_set(crm_adc_div_type div_value);
866void crm_usb_clock_div_set(crm_usb_div_type div_value);
867void crm_clock_failure_detection_enable(confirm_state new_state);
868void crm_battery_powered_domain_reset(confirm_state new_state);
869void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range);
870void crm_sysclk_switch(crm_sclk_type value);
871 crm_sclk_type crm_sysclk_switch_status_get(void);
872void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct);
873void crm_clock_out_set(crm_clkout_select_type clkout);
874void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state);
875void crm_auto_step_mode_enable(confirm_state new_state);
876void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap);
877void crm_hick_divider_select(crm_hick_div_6_type value);
878void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value);
879void crm_usb_clock_source_select(crm_usb_clock_source_type value);
880void crm_clkout_to_tmr10_enable(confirm_state new_state);
881void crm_clkout_div_set(crm_clkout_div_type clkout_div);
882
895#ifdef __cplusplus
896}
897#endif
898
899#endif
at32f413.h
at32f413 header file
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
crm_periph_sleep_mode_clock_enable
void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode
Definition: at32f413_crm.c:257
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hick_clock_calibration_set
void crm_hick_clock_calibration_set(uint8_t cali_value)
set the crm calibration value
Definition: at32f413_crm.c:176
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:805
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:374
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:384
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_interrupt_enable
void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
config crm interrupt
Definition: at32f413_crm.c:702
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:328
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_lext_bypass
void crm_lext_bypass(confirm_state new_state)
enable or disable crm low speed external crystal bypass
Definition: at32f413_crm.c:81
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_hick_sclk_frequency_select
void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
hick as system clock frequency select
Definition: at32f413_crm.c:757
crm_hick_divider_select
void crm_hick_divider_select(crm_hick_div_6_type value)
config hick divider select
Definition: at32f413_crm.c:744
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:684
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f413_crm.c:485
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_clkout_to_tmr10_enable
void crm_clkout_to_tmr10_enable(confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1
Definition: at32f413_crm.c:785
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_usb_interrupt_remapping_set
void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap)
usbdev interrupt remapping control
Definition: at32f413_crm.c:731
crm_hick_clock_trimming_set
void crm_hick_clock_trimming_set(uint8_t trim_value)
set the hick trimming value
Definition: at32f413_crm.c:166
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f413_crm.c:495
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
crm_hext_bypass
void crm_hext_bypass(confirm_state new_state)
enable or disable crm high speed external crystal bypass
Definition: at32f413_crm.c:91
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f413_crm.h:100
crm_hick_sclk_frequency_type
crm_hick_sclk_frequency_type
crm hick as system clock frequency select
Definition: at32f413_crm.h:460
crm_apb1_div_type
crm_apb1_div_type
crm apb1 division
Definition: at32f413_crm.h:319
crm_clock_source_type
crm_clock_source_type
crm clock source
Definition: at32f413_crm.h:291
crm_usb_div_type
crm_usb_div_type
crm usb division
Definition: at32f413_crm.h:356
crm_clkout_div_type
crm_clkout_div_type
crm clkout division
Definition: at32f413_crm.h:417
crm_usb_clock_source_type
crm_usb_clock_source_type
crm usb 48 mhz clock source select
Definition: at32f413_crm.h:451
crm_periph_clock_sleepmd_type
crm_periph_clock_sleepmd_type
crm periph clock in sleep mode
Definition: at32f413_crm.h:192
crm_pll_clock_source_type
crm_pll_clock_source_type
crm pll clock source
Definition: at32f413_crm.h:272
crm_pll_mult_type
crm_pll_mult_type
crm pll mult_x
Definition: at32f413_crm.h:202
crm_ahb_div_type
crm_ahb_div_type
crm ahb division
Definition: at32f413_crm.h:303
crm_rtc_clock_type
crm_rtc_clock_type
crm rtc clock
Definition: at32f413_crm.h:370
crm_adc_div_type
crm_adc_div_type
crm adc division
Definition: at32f413_crm.h:343
crm_usb_int_map_type
crm_usb_int_map_type
crm usbdev interrupt remap
Definition: at32f413_crm.h:442
crm_clkout_select_type
crm_clkout_select_type
crm clkout select
Definition: at32f413_crm.h:400
crm_auto_step_mode_type
crm_auto_step_mode_type
crm auto step mode
Definition: at32f413_crm.h:433
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f413_crm.h:390
crm_periph_reset_type
crm_periph_reset_type
crm periph reset
Definition: at32f413_crm.h:148
crm_apb2_div_type
crm_apb2_div_type
crm apb2 division
Definition: at32f413_crm.h:331
crm_pll_output_range_type
crm_pll_output_range_type
crm pll clock output range
Definition: at32f413_crm.h:282
crm_hick_div_6_type
crm_hick_div_6_type
crm hick 48mhz division
Definition: at32f413_crm.h:381
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f413_crm.h:105
CRM_TMR10_PERIPH_CLOCK
@ CRM_TMR10_PERIPH_CLOCK
Definition: at32f413_crm.h:120
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_UART5_PERIPH_CLOCK
@ CRM_UART5_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_TMR9_PERIPH_CLOCK
@ CRM_TMR9_PERIPH_CLOCK
Definition: at32f413_crm.h:119
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_I2C1_PERIPH_CLOCK
@ CRM_I2C1_PERIPH_CLOCK
Definition: at32f413_crm.h:134
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_TMR8_PERIPH_CLOCK
@ CRM_TMR8_PERIPH_CLOCK
Definition: at32f413_crm.h:117
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_UART4_PERIPH_CLOCK
@ CRM_UART4_PERIPH_CLOCK
Definition: at32f413_crm.h:132
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:137
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_CAN2_PERIPH_CLOCK
@ CRM_CAN2_PERIPH_CLOCK
Definition: at32f413_crm.h:140
CRM_I2C2_PERIPH_CLOCK
@ CRM_I2C2_PERIPH_CLOCK
Definition: at32f413_crm.h:135
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:103
CRM_TMR5_PERIPH_CLOCK
@ CRM_TMR5_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
CRM_TMR11_PERIPH_CLOCK
@ CRM_TMR11_PERIPH_CLOCK
Definition: at32f413_crm.h:121
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_WWDT_PERIPH_CLOCK
@ CRM_WWDT_PERIPH_CLOCK
Definition: at32f413_crm.h:128
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f413_crm.h:114
CRM_HICK_SCLK_48MHZ
@ CRM_HICK_SCLK_48MHZ
Definition: at32f413_crm.h:462
CRM_HICK_SCLK_8MHZ
@ CRM_HICK_SCLK_8MHZ
Definition: at32f413_crm.h:461
CRM_APB1_DIV_8
@ CRM_APB1_DIV_8
Definition: at32f413_crm.h:323
CRM_APB1_DIV_4
@ CRM_APB1_DIV_4
Definition: at32f413_crm.h:322
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_APB1_DIV_16
@ CRM_APB1_DIV_16
Definition: at32f413_crm.h:324
CRM_APB1_DIV_1
@ CRM_APB1_DIV_1
Definition: at32f413_crm.h:320
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:292
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:295
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_CLKOUT_DIV_2
@ CRM_CLKOUT_DIV_2
Definition: at32f413_crm.h:419
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:418
CRM_CLKOUT_DIV_128
@ CRM_CLKOUT_DIV_128
Definition: at32f413_crm.h:424
CRM_CLKOUT_DIV_64
@ CRM_CLKOUT_DIV_64
Definition: at32f413_crm.h:423
CRM_CLKOUT_DIV_8
@ CRM_CLKOUT_DIV_8
Definition: at32f413_crm.h:421
CRM_CLKOUT_DIV_16
@ CRM_CLKOUT_DIV_16
Definition: at32f413_crm.h:422
CRM_CLKOUT_DIV_256
@ CRM_CLKOUT_DIV_256
Definition: at32f413_crm.h:425
CRM_CLKOUT_DIV_4
@ CRM_CLKOUT_DIV_4
Definition: at32f413_crm.h:420
CRM_CLKOUT_DIV_512
@ CRM_CLKOUT_DIV_512
Definition: at32f413_crm.h:426
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
CRM_USB_CLOCK_SOURCE_PLL
@ CRM_USB_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:452
CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
@ CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
Definition: at32f413_crm.h:195
CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
@ CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
Definition: at32f413_crm.h:194
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f413_crm.h:274
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:273
CRM_PLL_MULT_17
@ CRM_PLL_MULT_17
Definition: at32f413_crm.h:218
CRM_PLL_MULT_24
@ CRM_PLL_MULT_24
Definition: at32f413_crm.h:225
CRM_PLL_MULT_53
@ CRM_PLL_MULT_53
Definition: at32f413_crm.h:254
CRM_PLL_MULT_61
@ CRM_PLL_MULT_61
Definition: at32f413_crm.h:262
CRM_PLL_MULT_27
@ CRM_PLL_MULT_27
Definition: at32f413_crm.h:228
CRM_PLL_MULT_50
@ CRM_PLL_MULT_50
Definition: at32f413_crm.h:251
CRM_PLL_MULT_41
@ CRM_PLL_MULT_41
Definition: at32f413_crm.h:242
CRM_PLL_MULT_56
@ CRM_PLL_MULT_56
Definition: at32f413_crm.h:257
CRM_PLL_MULT_11
@ CRM_PLL_MULT_11
Definition: at32f413_crm.h:212
CRM_PLL_MULT_37
@ CRM_PLL_MULT_37
Definition: at32f413_crm.h:238
CRM_PLL_MULT_63
@ CRM_PLL_MULT_63
Definition: at32f413_crm.h:264
CRM_PLL_MULT_18
@ CRM_PLL_MULT_18
Definition: at32f413_crm.h:219
CRM_PLL_MULT_9
@ CRM_PLL_MULT_9
Definition: at32f413_crm.h:210
CRM_PLL_MULT_4
@ CRM_PLL_MULT_4
Definition: at32f413_crm.h:205
CRM_PLL_MULT_35
@ CRM_PLL_MULT_35
Definition: at32f413_crm.h:236
CRM_PLL_MULT_14
@ CRM_PLL_MULT_14
Definition: at32f413_crm.h:215
CRM_PLL_MULT_28
@ CRM_PLL_MULT_28
Definition: at32f413_crm.h:229
CRM_PLL_MULT_62
@ CRM_PLL_MULT_62
Definition: at32f413_crm.h:263
CRM_PLL_MULT_20
@ CRM_PLL_MULT_20
Definition: at32f413_crm.h:221
CRM_PLL_MULT_47
@ CRM_PLL_MULT_47
Definition: at32f413_crm.h:248
CRM_PLL_MULT_32
@ CRM_PLL_MULT_32
Definition: at32f413_crm.h:233
CRM_PLL_MULT_58
@ CRM_PLL_MULT_58
Definition: at32f413_crm.h:259
CRM_PLL_MULT_10
@ CRM_PLL_MULT_10
Definition: at32f413_crm.h:211
CRM_PLL_MULT_44
@ CRM_PLL_MULT_44
Definition: at32f413_crm.h:245
CRM_PLL_MULT_5
@ CRM_PLL_MULT_5
Definition: at32f413_crm.h:206
CRM_PLL_MULT_34
@ CRM_PLL_MULT_34
Definition: at32f413_crm.h:235
CRM_PLL_MULT_15
@ CRM_PLL_MULT_15
Definition: at32f413_crm.h:216
CRM_PLL_MULT_39
@ CRM_PLL_MULT_39
Definition: at32f413_crm.h:240
CRM_PLL_MULT_13
@ CRM_PLL_MULT_13
Definition: at32f413_crm.h:214
CRM_PLL_MULT_45
@ CRM_PLL_MULT_45
Definition: at32f413_crm.h:246
CRM_PLL_MULT_12
@ CRM_PLL_MULT_12
Definition: at32f413_crm.h:213
CRM_PLL_MULT_33
@ CRM_PLL_MULT_33
Definition: at32f413_crm.h:234
CRM_PLL_MULT_64
@ CRM_PLL_MULT_64
Definition: at32f413_crm.h:265
CRM_PLL_MULT_31
@ CRM_PLL_MULT_31
Definition: at32f413_crm.h:232
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_PLL_MULT_19
@ CRM_PLL_MULT_19
Definition: at32f413_crm.h:220
CRM_PLL_MULT_29
@ CRM_PLL_MULT_29
Definition: at32f413_crm.h:230
CRM_PLL_MULT_49
@ CRM_PLL_MULT_49
Definition: at32f413_crm.h:250
CRM_PLL_MULT_3
@ CRM_PLL_MULT_3
Definition: at32f413_crm.h:204
CRM_PLL_MULT_36
@ CRM_PLL_MULT_36
Definition: at32f413_crm.h:237
CRM_PLL_MULT_21
@ CRM_PLL_MULT_21
Definition: at32f413_crm.h:222
CRM_PLL_MULT_40
@ CRM_PLL_MULT_40
Definition: at32f413_crm.h:241
CRM_PLL_MULT_46
@ CRM_PLL_MULT_46
Definition: at32f413_crm.h:247
CRM_PLL_MULT_59
@ CRM_PLL_MULT_59
Definition: at32f413_crm.h:260
CRM_PLL_MULT_2
@ CRM_PLL_MULT_2
Definition: at32f413_crm.h:203
CRM_PLL_MULT_54
@ CRM_PLL_MULT_54
Definition: at32f413_crm.h:255
CRM_PLL_MULT_7
@ CRM_PLL_MULT_7
Definition: at32f413_crm.h:208
CRM_PLL_MULT_25
@ CRM_PLL_MULT_25
Definition: at32f413_crm.h:226
CRM_PLL_MULT_22
@ CRM_PLL_MULT_22
Definition: at32f413_crm.h:223
CRM_PLL_MULT_51
@ CRM_PLL_MULT_51
Definition: at32f413_crm.h:252
CRM_PLL_MULT_57
@ CRM_PLL_MULT_57
Definition: at32f413_crm.h:258
CRM_PLL_MULT_43
@ CRM_PLL_MULT_43
Definition: at32f413_crm.h:244
CRM_PLL_MULT_55
@ CRM_PLL_MULT_55
Definition: at32f413_crm.h:256
CRM_PLL_MULT_42
@ CRM_PLL_MULT_42
Definition: at32f413_crm.h:243
CRM_PLL_MULT_23
@ CRM_PLL_MULT_23
Definition: at32f413_crm.h:224
CRM_PLL_MULT_38
@ CRM_PLL_MULT_38
Definition: at32f413_crm.h:239
CRM_PLL_MULT_16
@ CRM_PLL_MULT_16
Definition: at32f413_crm.h:217
CRM_PLL_MULT_30
@ CRM_PLL_MULT_30
Definition: at32f413_crm.h:231
CRM_PLL_MULT_52
@ CRM_PLL_MULT_52
Definition: at32f413_crm.h:253
CRM_PLL_MULT_6
@ CRM_PLL_MULT_6
Definition: at32f413_crm.h:207
CRM_PLL_MULT_26
@ CRM_PLL_MULT_26
Definition: at32f413_crm.h:227
CRM_PLL_MULT_8
@ CRM_PLL_MULT_8
Definition: at32f413_crm.h:209
CRM_PLL_MULT_60
@ CRM_PLL_MULT_60
Definition: at32f413_crm.h:261
CRM_AHB_DIV_4
@ CRM_AHB_DIV_4
Definition: at32f413_crm.h:306
CRM_AHB_DIV_16
@ CRM_AHB_DIV_16
Definition: at32f413_crm.h:308
CRM_AHB_DIV_64
@ CRM_AHB_DIV_64
Definition: at32f413_crm.h:309
CRM_AHB_DIV_8
@ CRM_AHB_DIV_8
Definition: at32f413_crm.h:307
CRM_AHB_DIV_512
@ CRM_AHB_DIV_512
Definition: at32f413_crm.h:312
CRM_AHB_DIV_128
@ CRM_AHB_DIV_128
Definition: at32f413_crm.h:310
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_AHB_DIV_256
@ CRM_AHB_DIV_256
Definition: at32f413_crm.h:311
CRM_AHB_DIV_2
@ CRM_AHB_DIV_2
Definition: at32f413_crm.h:305
CRM_RTC_CLOCK_HEXT_DIV
@ CRM_RTC_CLOCK_HEXT_DIV
Definition: at32f413_crm.h:374
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:373
CRM_RTC_CLOCK_LEXT
@ CRM_RTC_CLOCK_LEXT
Definition: at32f413_crm.h:372
CRM_RTC_CLOCK_NOCLK
@ CRM_RTC_CLOCK_NOCLK
Definition: at32f413_crm.h:371
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
CRM_ADC_DIV_16
@ CRM_ADC_DIV_16
Definition: at32f413_crm.h:349
CRM_ADC_DIV_4
@ CRM_ADC_DIV_4
Definition: at32f413_crm.h:345
CRM_ADC_DIV_12
@ CRM_ADC_DIV_12
Definition: at32f413_crm.h:348
CRM_ADC_DIV_2
@ CRM_ADC_DIV_2
Definition: at32f413_crm.h:344
CRM_ADC_DIV_8
@ CRM_ADC_DIV_8
Definition: at32f413_crm.h:347
CRM_USB_INT73_INT74
@ CRM_USB_INT73_INT74
Definition: at32f413_crm.h:444
CRM_USB_INT19_INT20
@ CRM_USB_INT19_INT20
Definition: at32f413_crm.h:443
CRM_CLKOUT_NOCLK
@ CRM_CLKOUT_NOCLK
Definition: at32f413_crm.h:401
CRM_CLKOUT_HICK
@ CRM_CLKOUT_HICK
Definition: at32f413_crm.h:405
CRM_CLKOUT_USB
@ CRM_CLKOUT_USB
Definition: at32f413_crm.h:409
CRM_CLKOUT_LICK
@ CRM_CLKOUT_LICK
Definition: at32f413_crm.h:402
CRM_CLKOUT_PLL_DIV_2
@ CRM_CLKOUT_PLL_DIV_2
Definition: at32f413_crm.h:407
CRM_CLKOUT_ADC
@ CRM_CLKOUT_ADC
Definition: at32f413_crm.h:410
CRM_CLKOUT_LEXT
@ CRM_CLKOUT_LEXT
Definition: at32f413_crm.h:403
CRM_CLKOUT_SCLK
@ CRM_CLKOUT_SCLK
Definition: at32f413_crm.h:404
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:408
CRM_CLKOUT_HEXT
@ CRM_CLKOUT_HEXT
Definition: at32f413_crm.h:406
CRM_AUTO_STEP_MODE_ENABLE
@ CRM_AUTO_STEP_MODE_ENABLE
Definition: at32f413_crm.h:435
CRM_AUTO_STEP_MODE_DISABLE
@ CRM_AUTO_STEP_MODE_DISABLE
Definition: at32f413_crm.h:434
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f413_crm.h:391
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f413_crm.h:392
CRM_TMR2_PERIPH_RESET
@ CRM_TMR2_PERIPH_RESET
Definition: at32f413_crm.h:168
CRM_TMR4_PERIPH_RESET
@ CRM_TMR4_PERIPH_RESET
Definition: at32f413_crm.h:170
CRM_SPI1_PERIPH_RESET
@ CRM_SPI1_PERIPH_RESET
Definition: at32f413_crm.h:160
CRM_TMR10_PERIPH_RESET
@ CRM_TMR10_PERIPH_RESET
Definition: at32f413_crm.h:164
CRM_I2C2_PERIPH_RESET
@ CRM_I2C2_PERIPH_RESET
Definition: at32f413_crm.h:179
CRM_UART4_PERIPH_RESET
@ CRM_UART4_PERIPH_RESET
Definition: at32f413_crm.h:176
CRM_BPR_PERIPH_RESET
@ CRM_BPR_PERIPH_RESET
Definition: at32f413_crm.h:182
CRM_ADC2_PERIPH_RESET
@ CRM_ADC2_PERIPH_RESET
Definition: at32f413_crm.h:158
CRM_USART1_PERIPH_RESET
@ CRM_USART1_PERIPH_RESET
Definition: at32f413_crm.h:162
CRM_IOMUX_PERIPH_RESET
@ CRM_IOMUX_PERIPH_RESET
Definition: at32f413_crm.h:150
CRM_CAN1_PERIPH_RESET
@ CRM_CAN1_PERIPH_RESET
Definition: at32f413_crm.h:181
CRM_TMR5_PERIPH_RESET
@ CRM_TMR5_PERIPH_RESET
Definition: at32f413_crm.h:171
CRM_TMR9_PERIPH_RESET
@ CRM_TMR9_PERIPH_RESET
Definition: at32f413_crm.h:163
CRM_GPIOF_PERIPH_RESET
@ CRM_GPIOF_PERIPH_RESET
Definition: at32f413_crm.h:156
CRM_TMR1_PERIPH_RESET
@ CRM_TMR1_PERIPH_RESET
Definition: at32f413_crm.h:159
CRM_GPIOD_PERIPH_RESET
@ CRM_GPIOD_PERIPH_RESET
Definition: at32f413_crm.h:155
CRM_USART2_PERIPH_RESET
@ CRM_USART2_PERIPH_RESET
Definition: at32f413_crm.h:174
CRM_GPIOC_PERIPH_RESET
@ CRM_GPIOC_PERIPH_RESET
Definition: at32f413_crm.h:154
CRM_CAN2_PERIPH_RESET
@ CRM_CAN2_PERIPH_RESET
Definition: at32f413_crm.h:184
CRM_ACC_PERIPH_RESET
@ CRM_ACC_PERIPH_RESET
Definition: at32f413_crm.h:166
CRM_TMR8_PERIPH_RESET
@ CRM_TMR8_PERIPH_RESET
Definition: at32f413_crm.h:161
CRM_WWDT_PERIPH_RESET
@ CRM_WWDT_PERIPH_RESET
Definition: at32f413_crm.h:172
CRM_UART5_PERIPH_RESET
@ CRM_UART5_PERIPH_RESET
Definition: at32f413_crm.h:177
CRM_ADC1_PERIPH_RESET
@ CRM_ADC1_PERIPH_RESET
Definition: at32f413_crm.h:157
CRM_EXINT_PERIPH_RESET
@ CRM_EXINT_PERIPH_RESET
Definition: at32f413_crm.h:151
CRM_TMR3_PERIPH_RESET
@ CRM_TMR3_PERIPH_RESET
Definition: at32f413_crm.h:169
CRM_USB_PERIPH_RESET
@ CRM_USB_PERIPH_RESET
Definition: at32f413_crm.h:180
CRM_SPI2_PERIPH_RESET
@ CRM_SPI2_PERIPH_RESET
Definition: at32f413_crm.h:173
CRM_PWC_PERIPH_RESET
@ CRM_PWC_PERIPH_RESET
Definition: at32f413_crm.h:183
CRM_GPIOA_PERIPH_RESET
@ CRM_GPIOA_PERIPH_RESET
Definition: at32f413_crm.h:152
CRM_TMR11_PERIPH_RESET
@ CRM_TMR11_PERIPH_RESET
Definition: at32f413_crm.h:165
CRM_USART3_PERIPH_RESET
@ CRM_USART3_PERIPH_RESET
Definition: at32f413_crm.h:175
CRM_GPIOB_PERIPH_RESET
@ CRM_GPIOB_PERIPH_RESET
Definition: at32f413_crm.h:153
CRM_I2C1_PERIPH_RESET
@ CRM_I2C1_PERIPH_RESET
Definition: at32f413_crm.h:178
CRM_APB2_DIV_4
@ CRM_APB2_DIV_4
Definition: at32f413_crm.h:334
CRM_APB2_DIV_1
@ CRM_APB2_DIV_1
Definition: at32f413_crm.h:332
CRM_APB2_DIV_16
@ CRM_APB2_DIV_16
Definition: at32f413_crm.h:336
CRM_APB2_DIV_8
@ CRM_APB2_DIV_8
Definition: at32f413_crm.h:335
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_LE72MHZ
@ CRM_PLL_OUTPUT_RANGE_LE72MHZ
Definition: at32f413_crm.h:283
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_HICK48_NODIV
@ CRM_HICK48_NODIV
Definition: at32f413_crm.h:383
CRM_HICK48_DIV6
@ CRM_HICK48_DIV6
Definition: at32f413_crm.h:382
MAKE_VALUE
#define MAKE_VALUE(reg_offset, bit_num)
Definition: at32f413.h:315
error_status
error_status
error status
Definition: at32f413.h:301
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::adc_freq
uint32_t adc_freq
Definition: at32f413_crm.h:474
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:473
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f413_crm.h:472
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:471
crm_type
type define crm register all
Definition: at32f413_crm.h:481
crm_type::misc1
__IO uint32_t misc1
Definition: at32f413_crm.h:768
crm_type::lickstblien
__IO uint32_t lickstblien
Definition: at32f413_crm.h:546
crm_type::uart4en
__IO uint32_t uart4en
Definition: at32f413_crm.h:701
crm_type::auto_step_en
__IO uint32_t auto_step_en
Definition: at32f413_crm.h:810
crm_type::usart1en
__IO uint32_t usart1en
Definition: at32f413_crm.h:672
crm_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_crm.h:487
crm_type::adc2en
__IO uint32_t adc2en
Definition: at32f413_crm.h:668
crm_type::apb2en
__IO uint32_t apb2en
Definition: at32f413_crm.h:655
crm_type::apb1rst
__IO uint32_t apb1rst
Definition: at32f413_crm.h:600
crm_type::uart4rst
__IO uint32_t uart4rst
Definition: at32f413_crm.h:614
crm_type::misc2
__IO uint32_t misc2
Definition: at32f413_crm.h:792
crm_type::tmr11rst
__IO uint32_t tmr11rst
Definition: at32f413_crm.h:589
crm_type::accen
__IO uint32_t accen
Definition: at32f413_crm.h:677
crm_type::i2c2rst
__IO uint32_t i2c2rst
Definition: at32f413_crm.h:617
crm_type::apb2rst
__IO uint32_t apb2rst
Definition: at32f413_crm.h:568
crm_type::adc1rst
__IO uint32_t adc1rst
Definition: at32f413_crm.h:580
crm_type::adcdiv_h
__IO uint32_t adcdiv_h
Definition: at32f413_crm.h:525
crm_type::cfdf
__IO uint32_t cfdf
Definition: at32f413_crm.h:545
crm_type::gpioerst
__IO uint32_t gpioerst
Definition: at32f413_crm.h:578
crm_type::pllmult_l
__IO uint32_t pllmult_l
Definition: at32f413_crm.h:521
crm_type::reserved5
__IO uint32_t reserved5
Definition: at32f413_crm.h:621
crm_type::tmr3en
__IO uint32_t tmr3en
Definition: at32f413_crm.h:691
crm_type::usart2rst
__IO uint32_t usart2rst
Definition: at32f413_crm.h:612
crm_type::tmr3rst
__IO uint32_t tmr3rst
Definition: at32f413_crm.h:604
crm_type::hexten
__IO uint32_t hexten
Definition: at32f413_crm.h:494
crm_type::gpiocrst
__IO uint32_t gpiocrst
Definition: at32f413_crm.h:575
crm_type::bpdc
__IO uint32_t bpdc
Definition: at32f413_crm.h:721
crm_type::dma1en
__IO uint32_t dma1en
Definition: at32f413_crm.h:637
crm_type::tmr4en
__IO uint32_t tmr4en
Definition: at32f413_crm.h:692
crm_type::usbrst
__IO uint32_t usbrst
Definition: at32f413_crm.h:618
crm_type::tmr1en
__IO uint32_t tmr1en
Definition: at32f413_crm.h:669
crm_type::hickcal_key
__IO uint32_t hickcal_key
Definition: at32f413_crm.h:771
crm_type::pllstblfc
__IO uint32_t pllstblfc
Definition: at32f413_crm.h:556
crm_type::clk_to_tmr
__IO uint32_t clk_to_tmr
Definition: at32f413_crm.h:796
crm_type::rtcsel
__IO uint32_t rtcsel
Definition: at32f413_crm.h:728
crm_type::uart5en
__IO uint32_t uart5en
Definition: at32f413_crm.h:702
crm_type::hick_to_usb
__IO uint32_t hick_to_usb
Definition: at32f413_crm.h:812
crm_type::pllhextdiv
__IO uint32_t pllhextdiv
Definition: at32f413_crm.h:520
crm_type::lprstf
__IO uint32_t lprstf
Definition: at32f413_crm.h:754
crm_type::uart5rst
__IO uint32_t uart5rst
Definition: at32f413_crm.h:615
crm_type::hickcal
__IO uint32_t hickcal
Definition: at32f413_crm.h:493
crm_type::sclksel
__IO uint32_t sclksel
Definition: at32f413_crm.h:513
crm_type::gpioben
__IO uint32_t gpioben
Definition: at32f413_crm.h:661
crm_type::tmr11en
__IO uint32_t tmr11en
Definition: at32f413_crm.h:676
crm_type::gpioden
__IO uint32_t gpioden
Definition: at32f413_crm.h:663
crm_type::lextstblfc
__IO uint32_t lextstblfc
Definition: at32f413_crm.h:553
crm_type::reserved1
__IO uint32_t reserved1
crm reserved1 register, offset:0x28~0x2C
Definition: at32f413_crm.h:498
crm_type::usbbufs
__IO uint32_t usbbufs
Definition: at32f413_crm.h:775
crm_type::tmr8en
__IO uint32_t tmr8en
Definition: at32f413_crm.h:671
crm_type::gpiofen
__IO uint32_t gpiofen
Definition: at32f413_crm.h:665
crm_type::hextbyps
__IO uint32_t hextbyps
Definition: at32f413_crm.h:496
crm_type::wdtrstf
__IO uint32_t wdtrstf
Definition: at32f413_crm.h:752
crm_type::bpdrst
__IO uint32_t bpdrst
Definition: at32f413_crm.h:731
crm_type::tmr10en
__IO uint32_t tmr10en
Definition: at32f413_crm.h:675
crm_type::usart2en
__IO uint32_t usart2en
Definition: at32f413_crm.h:699
crm_type::lickstbl
__IO uint32_t lickstbl
Definition: at32f413_crm.h:745
crm_type::tmr9rst
__IO uint32_t tmr9rst
Definition: at32f413_crm.h:587
crm_type::tmr8rst
__IO uint32_t tmr8rst
Definition: at32f413_crm.h:584
crm_type::nrstf
__IO uint32_t nrstf
Definition: at32f413_crm.h:749
crm_type::sramen
__IO uint32_t sramen
Definition: at32f413_crm.h:639
crm_type::usbintmap
__IO uint32_t usbintmap
Definition: at32f413_crm.h:831
crm_type::lickstblfc
__IO uint32_t lickstblfc
Definition: at32f413_crm.h:552
crm_type::swrstf
__IO uint32_t swrstf
Definition: at32f413_crm.h:751
crm_type::cfdfc
__IO uint32_t cfdfc
Definition: at32f413_crm.h:558
crm_type::can2rst
__IO uint32_t can2rst
Definition: at32f413_crm.h:625
crm_type::gpioarst
__IO uint32_t gpioarst
Definition: at32f413_crm.h:573
crm_type::apb1en
__IO uint32_t apb1en
Definition: at32f413_crm.h:687
crm_type::tmr10rst
__IO uint32_t tmr10rst
Definition: at32f413_crm.h:588
crm_type::rstfc
__IO uint32_t rstfc
Definition: at32f413_crm.h:747
crm_type::tmr1rst
__IO uint32_t tmr1rst
Definition: at32f413_crm.h:582
crm_type::tmr5en
__IO uint32_t tmr5en
Definition: at32f413_crm.h:693
crm_type::hextstbl
__IO uint32_t hextstbl
Definition: at32f413_crm.h:495
crm_type::usart1rst
__IO uint32_t usart1rst
Definition: at32f413_crm.h:585
crm_type::gpioaen
__IO uint32_t gpioaen
Definition: at32f413_crm.h:660
crm_type::misc3
__IO uint32_t misc3
Definition: at32f413_crm.h:806
crm_type::spi2rst
__IO uint32_t spi2rst
Definition: at32f413_crm.h:610
crm_type::spi1rst
__IO uint32_t spi1rst
Definition: at32f413_crm.h:583
crm_type::cfg
__IO uint32_t cfg
Definition: at32f413_crm.h:510
crm_type::i2c1rst
__IO uint32_t i2c1rst
Definition: at32f413_crm.h:616
crm_type::licken
__IO uint32_t licken
Definition: at32f413_crm.h:744
crm_type::pllrcs
__IO uint32_t pllrcs
Definition: at32f413_crm.h:519
crm_type::tmr9en
__IO uint32_t tmr9en
Definition: at32f413_crm.h:674
crm_type::hickstblfc
__IO uint32_t hickstblfc
Definition: at32f413_crm.h:554
crm_type::hickstblien
__IO uint32_t hickstblien
Definition: at32f413_crm.h:548
crm_type::pllstblf
__IO uint32_t pllstblf
Definition: at32f413_crm.h:543
crm_type::hicktrim
__IO uint32_t hicktrim
Definition: at32f413_crm.h:492
crm_type::sdio1en
__IO uint32_t sdio1en
Definition: at32f413_crm.h:645
crm_type::ahben
__IO uint32_t ahben
Definition: at32f413_crm.h:634
crm_type::pllmult_h
__IO uint32_t pllmult_h
Definition: at32f413_crm.h:526
crm_type::wwdten
__IO uint32_t wwdten
Definition: at32f413_crm.h:695
crm_type::flashen
__IO uint32_t flashen
Definition: at32f413_crm.h:641
crm_type::reserved6
__IO uint32_t reserved6
Definition: at32f413_crm.h:624
crm_type::usart3rst
__IO uint32_t usart3rst
Definition: at32f413_crm.h:613
crm_type::gpiocen
__IO uint32_t gpiocen
Definition: at32f413_crm.h:662
crm_type::iomuxen
__IO uint32_t iomuxen
Definition: at32f413_crm.h:658
crm_type::usben
__IO uint32_t usben
Definition: at32f413_crm.h:705
crm_type::usbdiv_h
__IO uint32_t usbdiv_h
Definition: at32f413_crm.h:524
crm_type::lextstblf
__IO uint32_t lextstblf
Definition: at32f413_crm.h:540
crm_type::clkoutdiv
__IO uint32_t clkoutdiv
Definition: at32f413_crm.h:778
crm_type::rtcen
__IO uint32_t rtcen
Definition: at32f413_crm.h:730
crm_type::pwcrst
__IO uint32_t pwcrst
Definition: at32f413_crm.h:623
crm_type::apb2div
__IO uint32_t apb2div
Definition: at32f413_crm.h:517
crm_type::wwdtrst
__IO uint32_t wwdtrst
Definition: at32f413_crm.h:608
crm_type::usart3en
__IO uint32_t usart3en
Definition: at32f413_crm.h:700
crm_type::tmr2rst
__IO uint32_t tmr2rst
Definition: at32f413_crm.h:603
crm_type::adc1en
__IO uint32_t adc1en
Definition: at32f413_crm.h:667
crm_type::pllstbl
__IO uint32_t pllstbl
Definition: at32f413_crm.h:500
crm_type::pllstblien
__IO uint32_t pllstblien
Definition: at32f413_crm.h:550
crm_type::can1rst
__IO uint32_t can1rst
Definition: at32f413_crm.h:620
crm_type::can1en
__IO uint32_t can1en
Definition: at32f413_crm.h:707
crm_type::adc2rst
__IO uint32_t adc2rst
Definition: at32f413_crm.h:581
crm_type::exintrst
__IO uint32_t exintrst
Definition: at32f413_crm.h:572
crm_type::lextbyps
__IO uint32_t lextbyps
Definition: at32f413_crm.h:726
crm_type::lextstbl
__IO uint32_t lextstbl
Definition: at32f413_crm.h:725
crm_type::usbdiv_l
__IO uint32_t usbdiv_l
Definition: at32f413_crm.h:522
crm_type::reserved3
__IO uint32_t reserved3
crm reserved3 register, offset:0x58
Definition: at32f413_crm.h:557
crm_type::crcen
__IO uint32_t crcen
Definition: at32f413_crm.h:643
crm_type::tmr2en
__IO uint32_t tmr2en
Definition: at32f413_crm.h:690
crm_type::hick_to_sclk
__IO uint32_t hick_to_sclk
Definition: at32f413_crm.h:813
crm_type::sclksts
__IO uint32_t sclksts
Definition: at32f413_crm.h:514
crm_type::i2c1en
__IO uint32_t i2c1en
Definition: at32f413_crm.h:703
crm_type::hextstblien
__IO uint32_t hextstblien
Definition: at32f413_crm.h:549
crm_type::gpiodrst
__IO uint32_t gpiodrst
Definition: at32f413_crm.h:576
crm_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f413_crm.h:741
crm_type::bpren
__IO uint32_t bpren
Definition: at32f413_crm.h:709
crm_type::reserved2
__IO uint32_t reserved2
crm reserved2 register, offset:0x4C~0x34
Definition: at32f413_crm.h:501
crm_type::intmap
__IO uint32_t intmap
Definition: at32f413_crm.h:828
crm_type::hickdiv
__IO uint32_t hickdiv
Definition: at32f413_crm.h:776
crm_type::accrst
__IO uint32_t accrst
Definition: at32f413_crm.h:590
crm_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_crm.h:559
crm_type::wwdtrstf
__IO uint32_t wwdtrstf
Definition: at32f413_crm.h:753
crm_type::porrstf
__IO uint32_t porrstf
Definition: at32f413_crm.h:750
crm_type::pllrange
__IO uint32_t pllrange
Definition: at32f413_crm.h:527
crm_type::hextstblfc
__IO uint32_t hextstblfc
Definition: at32f413_crm.h:555
crm_type::tmr4rst
__IO uint32_t tmr4rst
Definition: at32f413_crm.h:605
crm_type::bprrst
__IO uint32_t bprrst
Definition: at32f413_crm.h:622
crm_type::iomuxrst
__IO uint32_t iomuxrst
Definition: at32f413_crm.h:571
crm_type::cfden
__IO uint32_t cfden
Definition: at32f413_crm.h:497
crm_type::adcdiv_l
__IO uint32_t adcdiv_l
Definition: at32f413_crm.h:518
crm_type::apb1div
__IO uint32_t apb1div
Definition: at32f413_crm.h:516
crm_type::pwcen
__IO uint32_t pwcen
Definition: at32f413_crm.h:710
crm_type::lextstblien
__IO uint32_t lextstblien
Definition: at32f413_crm.h:547
crm_type::lickstblf
__IO uint32_t lickstblf
Definition: at32f413_crm.h:539
crm_type::clkout_sel
__IO uint32_t clkout_sel
Definition: at32f413_crm.h:523
crm_type::hicken
__IO uint32_t hicken
Definition: at32f413_crm.h:490
crm_type::lexten
__IO uint32_t lexten
Definition: at32f413_crm.h:724
crm_type::hickstbl
__IO uint32_t hickstbl
Definition: at32f413_crm.h:491
crm_type::i2c2en
__IO uint32_t i2c2en
Definition: at32f413_crm.h:704
crm_type::spi1en
__IO uint32_t spi1en
Definition: at32f413_crm.h:670
crm_type::dma2en
__IO uint32_t dma2en
Definition: at32f413_crm.h:638
crm_type::hextstblf
__IO uint32_t hextstblf
Definition: at32f413_crm.h:542
crm_type::spi2en
__IO uint32_t spi2en
Definition: at32f413_crm.h:697
crm_type::gpiobrst
__IO uint32_t gpiobrst
Definition: at32f413_crm.h:574
crm_type::pllen
__IO uint32_t pllen
Definition: at32f413_crm.h:499
crm_type::tmr5rst
__IO uint32_t tmr5rst
Definition: at32f413_crm.h:606
crm_type::can2en
__IO uint32_t can2en
Definition: at32f413_crm.h:712
crm_type::hickstblf
__IO uint32_t hickstblf
Definition: at32f413_crm.h:541
crm_type::clkint
__IO uint32_t clkint
Definition: at32f413_crm.h:536
crm_type::ahbdiv
__IO uint32_t ahbdiv
Definition: at32f413_crm.h:515


AT32F413 Firmwary Library: at32f413_debug.c Source File

  • libraries
  • drivers
  • src
at32f413_debug.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef DEBUG_MODULE_ENABLED
37
47uint32_t debug_device_id_get(void)
48{
49 return DEBUGMCU->pid;
50}
51
77void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
78{
79
80 if(new_state != FALSE)
81 {
82 DEBUGMCU->ctrl |= periph_debug_mode;
83 }
84 else
85 {
86 DEBUGMCU->ctrl &= ~periph_debug_mode;
87 }
88}
89
94#endif
95
debug_periph_mode_set
void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode
Definition: at32f413_debug.c:77
debug_device_id_get
uint32_t debug_device_id_get(void)
get debug device id
Definition: at32f413_debug.c:47
DEBUGMCU
#define DEBUGMCU
Definition: at32f413_debug.h:134
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
FALSE
@ FALSE
Definition: at32f413.h:296
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_debug.h Source File

  • libraries
  • drivers
  • inc
at32f413_debug.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_DEBUG_H
27#define __AT32F413_DEBUG_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
49#define DEBUG_SLEEP 0x00000001
50#define DEBUG_DEEPSLEEP 0x00000002
51#define DEBUG_STANDBY 0x00000004
52#define DEBUG_WDT_PAUSE 0x00000100
53#define DEBUG_WWDT_PAUSE 0x00000200
54#define DEBUG_TMR1_PAUSE 0x00000400
55#define DEBUG_TMR2_PAUSE 0x00000800
56#define DEBUG_TMR3_PAUSE 0x00001000
57#define DEBUG_TMR4_PAUSE 0x00002000
58#define DEBUG_CAN1_PAUSE 0x00004000
59#define DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000
60#define DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000
61#define DEBUG_TMR8_PAUSE 0x00020000
62#define DEBUG_TMR5_PAUSE 0x00040000
63#define DEBUG_CAN2_PAUSE 0x00200000
64#define DEBUG_TMR9_PAUSE 0x10000000
65#define DEBUG_TMR10_PAUSE 0x20000000
66#define DEBUG_TMR11_PAUSE 0x40000000
79typedef struct
80{
84 union
85 {
86 __IO uint32_t pid;
87 struct
88 {
89 __IO uint32_t pid : 32;/* [31:0] */
90 } idcode_bit;
91 };
92
96 union
97 {
98 __IO uint32_t ctrl;
99 struct
100 {
101 __IO uint32_t sleep_debug : 1;/* [0] */
102 __IO uint32_t deepsleep_debug : 1;/* [1] */
103 __IO uint32_t standby_debug : 1;/* [2] */
104 __IO uint32_t reserved1 : 2;/* [4:3] */
105 __IO uint32_t trace_ioen : 1;/* [5] */
106 __IO uint32_t trace_mode : 2;/* [7:6] */
107 __IO uint32_t wdt_pause : 1;/* [8] */
108 __IO uint32_t wwdt_pause : 1;/* [9] */
109 __IO uint32_t tmr1_pause : 1;/* [10] */
110 __IO uint32_t tmr2_pause : 1;/* [11] */
111 __IO uint32_t tmr3_pause : 1;/* [12] */
112 __IO uint32_t tmr4_pause : 1;/* [13] */
113 __IO uint32_t can1_pause : 1;/* [14] */
114 __IO uint32_t i2c1_smbus_timeout : 1;/* [15] */
115 __IO uint32_t i2c2_smbus_timeout : 1;/* [16] */
116 __IO uint32_t tmr8_pause : 1;/* [17] */
117 __IO uint32_t tmr5_pause : 1;/* [18] */
118 __IO uint32_t reserved2 : 2;/* [20:19] */
119 __IO uint32_t can2_pause : 1;/* [21] */
120 __IO uint32_t reserved3 : 6;/* [27:22] */
121 __IO uint32_t tmr9_pause : 1;/* [28] */
122 __IO uint32_t tmr10_pause : 1;/* [29] */
123 __IO uint32_t tmr11_pause : 1;/* [30] */
124 __IO uint32_t reserved4 : 1;/* [31] */
125 } ctrl_bit;
126 };
127
128} debug_type;
129
134#define DEBUGMCU ((debug_type *) DEBUG_BASE)
135
140uint32_t debug_device_id_get(void);
141void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state);
142
155#ifdef __cplusplus
156}
157#endif
158
159#endif
at32f413.h
at32f413 header file
debug_periph_mode_set
void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode
Definition: at32f413_debug.c:77
debug_device_id_get
uint32_t debug_device_id_get(void)
get debug device id
Definition: at32f413_debug.c:47
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
debug_type
type define debug register all
Definition: at32f413_debug.h:80
debug_type::can2_pause
__IO uint32_t can2_pause
Definition: at32f413_debug.h:119
debug_type::tmr11_pause
__IO uint32_t tmr11_pause
Definition: at32f413_debug.h:123
debug_type::i2c2_smbus_timeout
__IO uint32_t i2c2_smbus_timeout
Definition: at32f413_debug.h:115
debug_type::pid
__IO uint32_t pid
Definition: at32f413_debug.h:86
debug_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_debug.h:118
debug_type::sleep_debug
__IO uint32_t sleep_debug
Definition: at32f413_debug.h:101
debug_type::tmr8_pause
__IO uint32_t tmr8_pause
Definition: at32f413_debug.h:116
debug_type::trace_ioen
__IO uint32_t trace_ioen
Definition: at32f413_debug.h:105
debug_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_debug.h:98
debug_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_debug.h:120
debug_type::tmr9_pause
__IO uint32_t tmr9_pause
Definition: at32f413_debug.h:121
debug_type::tmr2_pause
__IO uint32_t tmr2_pause
Definition: at32f413_debug.h:110
debug_type::wdt_pause
__IO uint32_t wdt_pause
Definition: at32f413_debug.h:107
debug_type::deepsleep_debug
__IO uint32_t deepsleep_debug
Definition: at32f413_debug.h:102
debug_type::tmr1_pause
__IO uint32_t tmr1_pause
Definition: at32f413_debug.h:109
debug_type::i2c1_smbus_timeout
__IO uint32_t i2c1_smbus_timeout
Definition: at32f413_debug.h:114
debug_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_debug.h:124
debug_type::trace_mode
__IO uint32_t trace_mode
Definition: at32f413_debug.h:106
debug_type::standby_debug
__IO uint32_t standby_debug
Definition: at32f413_debug.h:103
debug_type::tmr10_pause
__IO uint32_t tmr10_pause
Definition: at32f413_debug.h:122
debug_type::wwdt_pause
__IO uint32_t wwdt_pause
Definition: at32f413_debug.h:108
debug_type::can1_pause
__IO uint32_t can1_pause
Definition: at32f413_debug.h:113
debug_type::tmr4_pause
__IO uint32_t tmr4_pause
Definition: at32f413_debug.h:112
debug_type::tmr5_pause
__IO uint32_t tmr5_pause
Definition: at32f413_debug.h:117
debug_type::tmr3_pause
__IO uint32_t tmr3_pause
Definition: at32f413_debug.h:111
debug_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_debug.h:104


AT32F413 Firmwary Library: at32f413_def.h Source File

  • libraries
  • drivers
  • inc
at32f413_def.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_DEF_H
27#define __AT32F413_DEF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* gnu compiler */
34#if defined (__GNUC__)
35 #ifndef ALIGNED_HEAD
36 #define ALIGNED_HEAD
37 #endif
38 #ifndef ALIGNED_TAIL
39 #define ALIGNED_TAIL __attribute__ ((aligned (4)))
40 #endif
41#endif
42
43/* arm compiler */
44#if defined (__CC_ARM)
45 #ifndef ALIGNED_HEAD
46 #define ALIGNED_HEAD __align(4)
47 #endif
48 #ifndef ALIGNED_TAIL
49 #define ALIGNED_TAIL
50 #endif
51#endif
52
53/* iar compiler */
54#if defined (__ICCARM__)
55 #ifndef ALIGNED_HEAD
56 #define ALIGNED_HEAD
57 #endif
58 #ifndef ALIGNED_TAIL
59 #define ALIGNED_TAIL
60 #endif
61#endif
62
63#define UNUSED(x) (void)x /* to avoid gcc/g++ warnings */
64
65#ifdef __cplusplus
66}
67#endif
68
69#endif


AT32F413 Firmwary Library: at32f413_dma.c Source File

  • libraries
  • drivers
  • src
at32f413_dma.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef DMA_MODULE_ENABLED
37
62void dma_reset(dma_channel_type* dmax_channely)
63{
64 uint32_t temp = 0;
65 dmax_channely->ctrl_bit.chen = FALSE;
66 dmax_channely->ctrl = 0;
67 dmax_channely->dtcnt = 0;
68 dmax_channely->paddr = 0;
69 dmax_channely->maddr = 0;
70
71 temp = (uint32_t)dmax_channely;
72
73 if((temp & 0x4ff) < 0x408)
74 {
75 /* dma1 channel */
76 DMA1->clr |= (uint32_t)(0x0f << ((((temp & 0xff) - 0x08) / 0x14) * 4));
77 }
78 else if((temp & 0x4ff) < 0x488)
79 {
80 /* dma2 channel */
81 DMA2->clr |= (uint32_t)(0x0f << ((((temp & 0xff) - 0x08) / 0x14) * 4));
82 }
83}
84
107void dma_data_number_set(dma_channel_type* dmax_channely, uint16_t data_number)
108{
109 dmax_channely->dtcnt = data_number;
110}
111
132uint16_t dma_data_number_get(dma_channel_type* dmax_channely)
133{
134 return (uint16_t)dmax_channely->dtcnt;
135}
136
163void dma_interrupt_enable(dma_channel_type* dmax_channely, uint32_t dma_int, confirm_state new_state)
164{
165 if (new_state != FALSE)
166 {
167 dmax_channely->ctrl |= dma_int;
168 }
169 else
170 {
171 dmax_channely->ctrl &= ~dma_int;
172 }
173}
174
196void dma_channel_enable(dma_channel_type* dmax_channely, confirm_state new_state)
197{
198 dmax_channely->ctrl_bit.chen = new_state;
199}
200
236void dma_flexible_config(dma_type* dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
237{
238 if(dma_x->src_sel1_bit.dma_flex_en == RESET)
239 {
240 dma_x->src_sel1_bit.dma_flex_en = TRUE;
241 }
242
243 if(flex_channelx == FLEX_CHANNEL1)
244 {
245 dma_x->src_sel0_bit.ch1_src = flexible_request;
246 }
247 else if(flex_channelx == FLEX_CHANNEL2)
248 {
249 dma_x->src_sel0_bit.ch2_src = flexible_request;
250 }
251 else if(flex_channelx == FLEX_CHANNEL3)
252 {
253 dma_x->src_sel0_bit.ch3_src = flexible_request;
254 }
255 else if(flex_channelx == FLEX_CHANNEL4)
256 {
257 dma_x->src_sel0_bit.ch4_src = flexible_request;
258 }
259 else if(flex_channelx == FLEX_CHANNEL5)
260 {
261 dma_x->src_sel1_bit.ch5_src = flexible_request;
262 }
263 else if(flex_channelx == FLEX_CHANNEL6)
264 {
265 dma_x->src_sel1_bit.ch6_src = flexible_request;
266 }
267 else
268 {
269 if(flex_channelx == FLEX_CHANNEL7)
270 {
271 dma_x->src_sel1_bit.ch7_src = flexible_request;
272 }
273 }
274}
275
296 flag_status dma_flag_get(uint32_t dmax_flag)
297{
298 flag_status status = RESET;
299 uint32_t temp = 0;
300
301 if(dmax_flag > 0x10000000)
302 {
303 temp = DMA2->sts;
304 }
305 else
306 {
307 temp = DMA1->sts;
308 }
309
310 if ((temp & dmax_flag) != (uint16_t)RESET)
311 {
312 status = SET;
313 }
314 else
315 {
316 status = RESET;
317 }
318
319 return status;
320}
321
342void dma_flag_clear(uint32_t dmax_flag)
343{
344 if(dmax_flag > ((uint32_t)0x10000000))
345 {
346 DMA2->clr = (uint32_t)(dmax_flag & 0x0FFFFFFF);
347 }
348 else
349 {
350 DMA1->clr = dmax_flag;
351 }
352}
353
360void dma_default_para_init(dma_init_type* dma_init_struct)
361{
362 dma_init_struct->peripheral_base_addr = 0x0;
363 dma_init_struct->memory_base_addr = 0x0;
364 dma_init_struct->direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
365 dma_init_struct->buffer_size = 0x0;
366 dma_init_struct->peripheral_inc_enable = FALSE;
367 dma_init_struct->memory_inc_enable = FALSE;
368 dma_init_struct->peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
369 dma_init_struct->memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
370 dma_init_struct->loop_mode_enable = FALSE;
371 dma_init_struct->priority = DMA_PRIORITY_LOW;
372}
373
395void dma_init(dma_channel_type* dmax_channely, dma_init_type* dma_init_struct)
396{
397 /* clear ctrl register dtd bit and m2m bit */
398 dmax_channely->ctrl &= 0xbfef;
399 dmax_channely->ctrl |= dma_init_struct->direction;
400
401 dmax_channely->ctrl_bit.chpl = dma_init_struct->priority;
402 dmax_channely->ctrl_bit.mwidth = dma_init_struct->memory_data_width;
403 dmax_channely->ctrl_bit.pwidth = dma_init_struct->peripheral_data_width;
404 dmax_channely->ctrl_bit.mincm = dma_init_struct->memory_inc_enable;
405 dmax_channely->ctrl_bit.pincm = dma_init_struct->peripheral_inc_enable;
406 dmax_channely->ctrl_bit.lm = dma_init_struct->loop_mode_enable;
407 dmax_channely->dtcnt = dma_init_struct->buffer_size;
408 dmax_channely->paddr = dma_init_struct->peripheral_base_addr;
409 dmax_channely->maddr = dma_init_struct->memory_base_addr;
410}
411
416#endif
417
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
dma_flexible_request_type
dma_flexible_request_type
dma flexible request type
Definition: at32f413_dma.h:149
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:263
FLEX_CHANNEL5
#define FLEX_CHANNEL5
Definition: at32f413_dma.h:66
FLEX_CHANNEL7
#define FLEX_CHANNEL7
Definition: at32f413_dma.h:68
FLEX_CHANNEL3
#define FLEX_CHANNEL3
Definition: at32f413_dma.h:64
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:62
FLEX_CHANNEL6
#define FLEX_CHANNEL6
Definition: at32f413_dma.h:67
FLEX_CHANNEL4
#define FLEX_CHANNEL4
Definition: at32f413_dma.h:65
FLEX_CHANNEL2
#define FLEX_CHANNEL2
Definition: at32f413_dma.h:63
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:236
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_data_number_get
uint16_t dma_data_number_get(dma_channel_type *dmax_channely)
get number of data from dtcnt register
Definition: at32f413_dma.c:132
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
dma_data_number_set
void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred
Definition: at32f413_dma.c:107
DMA2
#define DMA2
Definition: at32f413_dma.h:486
DMA1
#define DMA1
Definition: at32f413_dma.h:477
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:410
dma_channel_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_dma.h:440
dma_channel_type::pwidth
__IO uint32_t pwidth
Definition: at32f413_dma.h:427
dma_channel_type::paddr
__IO uint32_t paddr
Definition: at32f413_dma.h:453
dma_channel_type::mincm
__IO uint32_t mincm
Definition: at32f413_dma.h:426
dma_channel_type::ctrl_bit
struct dma_channel_type::@351::@359 ctrl_bit
dma_channel_type::chen
__IO uint32_t chen
Definition: at32f413_dma.h:419
dma_channel_type::lm
__IO uint32_t lm
Definition: at32f413_dma.h:424
dma_channel_type::mwidth
__IO uint32_t mwidth
Definition: at32f413_dma.h:428
dma_channel_type::maddr
__IO uint32_t maddr
Definition: at32f413_dma.h:465
dma_channel_type::pincm
__IO uint32_t pincm
Definition: at32f413_dma.h:425
dma_channel_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_dma.h:416
dma_channel_type::chpl
__IO uint32_t chpl
Definition: at32f413_dma.h:429
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
dma_type
type define dma register
Definition: at32f413_dma.h:290
dma_type::src_sel1_bit
struct dma_type::@345::@350 src_sel1_bit
dma_type::ch2_src
__IO uint32_t ch2_src
Definition: at32f413_dma.h:383
dma_type::ch3_src
__IO uint32_t ch3_src
Definition: at32f413_dma.h:384
dma_type::dma_flex_en
__IO uint32_t dma_flex_en
Definition: at32f413_dma.h:400
dma_type::ch5_src
__IO uint32_t ch5_src
Definition: at32f413_dma.h:397
dma_type::src_sel0_bit
struct dma_type::@343::@349 src_sel0_bit
dma_type::ch1_src
__IO uint32_t ch1_src
Definition: at32f413_dma.h:382
dma_type::ch7_src
__IO uint32_t ch7_src
Definition: at32f413_dma.h:399
dma_type::ch4_src
__IO uint32_t ch4_src
Definition: at32f413_dma.h:385
dma_type::ch6_src
__IO uint32_t ch6_src
Definition: at32f413_dma.h:398
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_dma.h Source File

  • libraries
  • drivers
  • inc
at32f413_dma.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_DMA_H
27#define __AT32F413_DMA_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define DMA_FDT_INT ((uint32_t)0x00000002)
51#define DMA_HDT_INT ((uint32_t)0x00000004)
52#define DMA_DTERR_INT ((uint32_t)0x00000008)
62#define FLEX_CHANNEL1 ((uint8_t)0x01)
63#define FLEX_CHANNEL2 ((uint8_t)0x02)
64#define FLEX_CHANNEL3 ((uint8_t)0x03)
65#define FLEX_CHANNEL4 ((uint8_t)0x04)
66#define FLEX_CHANNEL5 ((uint8_t)0x05)
67#define FLEX_CHANNEL6 ((uint8_t)0x06)
68#define FLEX_CHANNEL7 ((uint8_t)0x07)
79#define DMA1_GL1_FLAG ((uint32_t)0x00000001)
80#define DMA1_FDT1_FLAG ((uint32_t)0x00000002)
81#define DMA1_HDT1_FLAG ((uint32_t)0x00000004)
82#define DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
83#define DMA1_GL2_FLAG ((uint32_t)0x00000010)
84#define DMA1_FDT2_FLAG ((uint32_t)0x00000020)
85#define DMA1_HDT2_FLAG ((uint32_t)0x00000040)
86#define DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
87#define DMA1_GL3_FLAG ((uint32_t)0x00000100)
88#define DMA1_FDT3_FLAG ((uint32_t)0x00000200)
89#define DMA1_HDT3_FLAG ((uint32_t)0x00000400)
90#define DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
91#define DMA1_GL4_FLAG ((uint32_t)0x00001000)
92#define DMA1_FDT4_FLAG ((uint32_t)0x00002000)
93#define DMA1_HDT4_FLAG ((uint32_t)0x00004000)
94#define DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
95#define DMA1_GL5_FLAG ((uint32_t)0x00010000)
96#define DMA1_FDT5_FLAG ((uint32_t)0x00020000)
97#define DMA1_HDT5_FLAG ((uint32_t)0x00040000)
98#define DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
99#define DMA1_GL6_FLAG ((uint32_t)0x00100000)
100#define DMA1_FDT6_FLAG ((uint32_t)0x00200000)
101#define DMA1_HDT6_FLAG ((uint32_t)0x00400000)
102#define DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
103#define DMA1_GL7_FLAG ((uint32_t)0x01000000)
104#define DMA1_FDT7_FLAG ((uint32_t)0x02000000)
105#define DMA1_HDT7_FLAG ((uint32_t)0x04000000)
106#define DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
108#define DMA2_GL1_FLAG ((uint32_t)0x10000001)
109#define DMA2_FDT1_FLAG ((uint32_t)0x10000002)
110#define DMA2_HDT1_FLAG ((uint32_t)0x10000004)
111#define DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
112#define DMA2_GL2_FLAG ((uint32_t)0x10000010)
113#define DMA2_FDT2_FLAG ((uint32_t)0x10000020)
114#define DMA2_HDT2_FLAG ((uint32_t)0x10000040)
115#define DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
116#define DMA2_GL3_FLAG ((uint32_t)0x10000100)
117#define DMA2_FDT3_FLAG ((uint32_t)0x10000200)
118#define DMA2_HDT3_FLAG ((uint32_t)0x10000400)
119#define DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
120#define DMA2_GL4_FLAG ((uint32_t)0x10001000)
121#define DMA2_FDT4_FLAG ((uint32_t)0x10002000)
122#define DMA2_HDT4_FLAG ((uint32_t)0x10004000)
123#define DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
124#define DMA2_GL5_FLAG ((uint32_t)0x10010000)
125#define DMA2_FDT5_FLAG ((uint32_t)0x10020000)
126#define DMA2_HDT5_FLAG ((uint32_t)0x10040000)
127#define DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
128#define DMA2_GL6_FLAG ((uint32_t)0x10100000)
129#define DMA2_FDT6_FLAG ((uint32_t)0x10200000)
130#define DMA2_HDT6_FLAG ((uint32_t)0x10400000)
131#define DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
132#define DMA2_GL7_FLAG ((uint32_t)0x11000000)
133#define DMA2_FDT7_FLAG ((uint32_t)0x12000000)
134#define DMA2_HDT7_FLAG ((uint32_t)0x14000000)
135#define DMA2_DTERR7_FLAG ((uint32_t)0x18000000)
148typedef enum
149{
150 DMA_FLEXIBLE_ADC1 = 0x01,
151 DMA_FLEXIBLE_SPI1_RX = 0x09,
152 DMA_FLEXIBLE_SPI1_TX = 0x0A,
153 DMA_FLEXIBLE_SPI2_RX = 0x0B,
154 DMA_FLEXIBLE_SPI2_TX = 0x0C,
155 DMA_FLEXIBLE_UART1_RX = 0x19,
156 DMA_FLEXIBLE_UART1_TX = 0x1A,
157 DMA_FLEXIBLE_UART2_RX = 0x1B,
158 DMA_FLEXIBLE_UART2_TX = 0x1C,
159 DMA_FLEXIBLE_UART3_RX = 0x1D,
160 DMA_FLEXIBLE_UART3_TX = 0x1E,
161 DMA_FLEXIBLE_UART4_RX = 0x1F,
162 DMA_FLEXIBLE_UART4_TX = 0x20,
163 DMA_FLEXIBLE_UART5_RX = 0x21,
164 DMA_FLEXIBLE_UART5_TX = 0x22,
165 DMA_FLEXIBLE_I2C1_RX = 0x29,
166 DMA_FLEXIBLE_I2C1_TX = 0x2A,
167 DMA_FLEXIBLE_I2C2_RX = 0x2B,
168 DMA_FLEXIBLE_I2C2_TX = 0x2C,
169 DMA_FLEXIBLE_SDIO1 = 0x31,
170 DMA_FLEXIBLE_TMR1_TRIG = 0x35,
171 DMA_FLEXIBLE_TMR1_HALL = 0x36,
172 DMA_FLEXIBLE_TMR1_OVERFLOW = 0x37,
173 DMA_FLEXIBLE_TMR1_CH1 = 0x38,
174 DMA_FLEXIBLE_TMR1_CH2 = 0x39,
175 DMA_FLEXIBLE_TMR1_CH3 = 0x3A,
176 DMA_FLEXIBLE_TMR1_CH4 = 0x3B,
177 DMA_FLEXIBLE_TMR2_TRIG = 0x3D,
178 DMA_FLEXIBLE_TMR2_OVERFLOW = 0x3F,
179 DMA_FLEXIBLE_TMR2_CH1 = 0x40,
180 DMA_FLEXIBLE_TMR2_CH2 = 0x41,
181 DMA_FLEXIBLE_TMR2_CH3 = 0x42,
182 DMA_FLEXIBLE_TMR2_CH4 = 0x43,
183 DMA_FLEXIBLE_TMR3_TRIG = 0x45,
184 DMA_FLEXIBLE_TMR3_OVERFLOW = 0x47,
185 DMA_FLEXIBLE_TMR3_CH1 = 0x48,
186 DMA_FLEXIBLE_TMR3_CH2 = 0x49,
187 DMA_FLEXIBLE_TMR3_CH3 = 0x4A,
188 DMA_FLEXIBLE_TMR3_CH4 = 0x4B,
189 DMA_FLEXIBLE_TMR4_TRIG = 0x4D,
190 DMA_FLEXIBLE_TMR4_OVERFLOW = 0x4F,
191 DMA_FLEXIBLE_TMR4_CH1 = 0x50,
192 DMA_FLEXIBLE_TMR4_CH2 = 0x51,
193 DMA_FLEXIBLE_TMR4_CH3 = 0x52,
194 DMA_FLEXIBLE_TMR4_CH4 = 0x53,
195 DMA_FLEXIBLE_TMR5_TRIG = 0x55,
196 DMA_FLEXIBLE_TMR5_OVERFLOW = 0x57,
197 DMA_FLEXIBLE_TMR5_CH1 = 0x58,
198 DMA_FLEXIBLE_TMR5_CH2 = 0x59,
199 DMA_FLEXIBLE_TMR5_CH3 = 0x5A,
200 DMA_FLEXIBLE_TMR5_CH4 = 0x5B,
201 DMA_FLEXIBLE_TMR8_TRIG = 0x6D,
202 DMA_FLEXIBLE_TMR8_HALL = 0x6E,
203 DMA_FLEXIBLE_TMR8_OVERFLOW = 0x6F,
204 DMA_FLEXIBLE_TMR8_CH1 = 0x70,
205 DMA_FLEXIBLE_TMR8_CH2 = 0x71,
206 DMA_FLEXIBLE_TMR8_CH3 = 0x72,
207 DMA_FLEXIBLE_TMR8_CH4 = 0x73,
208} dma_flexible_request_type;
209
213typedef enum
214{
215 DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000,
216 DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010,
217 DMA_DIR_MEMORY_TO_MEMORY = 0x4000
218} dma_dir_type;
219
223typedef enum
224{
225 DMA_PERIPHERAL_INC_DISABLE = 0x00,
226 DMA_PERIPHERAL_INC_ENABLE = 0x01
227} dma_peripheral_inc_type;
228
232typedef enum
233{
234 DMA_MEMORY_INC_DISABLE = 0x00,
235 DMA_MEMORY_INC_ENABLE = 0x01
236} dma_memory_inc_type;
237
241typedef enum
242{
243 DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00,
244 DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01,
245 DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02
246} dma_peripheral_data_size_type;
247
251typedef enum
252{
253 DMA_MEMORY_DATA_WIDTH_BYTE = 0x00,
254 DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01,
255 DMA_MEMORY_DATA_WIDTH_WORD = 0x02
256} dma_memory_data_size_type;
257
261typedef enum
262{
263 DMA_PRIORITY_LOW = 0x00,
264 DMA_PRIORITY_MEDIUM = 0x01,
265 DMA_PRIORITY_HIGH = 0x02,
266 DMA_PRIORITY_VERY_HIGH = 0x03
267} dma_priority_level_type;
268
272typedef struct
273{
274 uint32_t peripheral_base_addr;
275 uint32_t memory_base_addr;
276 dma_dir_type direction;
277 uint16_t buffer_size;
278 confirm_state peripheral_inc_enable;
279 confirm_state memory_inc_enable;
280 dma_peripheral_data_size_type peripheral_data_width;
281 dma_memory_data_size_type memory_data_width;
282 confirm_state loop_mode_enable;
283 dma_priority_level_type priority;
284} dma_init_type;
285
289typedef struct
290{
294 union
295 {
296 __IO uint32_t sts;
297 struct
298 {
299 __IO uint32_t gf1 : 1; /* [0] */
300 __IO uint32_t fdtf1 : 1; /* [1] */
301 __IO uint32_t hdtf1 : 1; /* [2] */
302 __IO uint32_t dterrf1 : 1; /* [3] */
303 __IO uint32_t gf2 : 1; /* [4] */
304 __IO uint32_t fdtf2 : 1; /* [5] */
305 __IO uint32_t hdtf2 : 1; /* [6] */
306 __IO uint32_t dterrf2 : 1; /* [7] */
307 __IO uint32_t gf3 : 1; /* [8] */
308 __IO uint32_t fdtf3 : 1; /* [9] */
309 __IO uint32_t hdtf3 : 1; /* [10] */
310 __IO uint32_t dterrf3 : 1; /* [11] */
311 __IO uint32_t gf4 : 1; /* [12] */
312 __IO uint32_t fdtf4 : 1; /* [13] */
313 __IO uint32_t hdtf4 : 1; /* [14] */
314 __IO uint32_t dterrf4 : 1; /* [15] */
315 __IO uint32_t gf5 : 1; /* [16] */
316 __IO uint32_t fdtf5 : 1; /* [17] */
317 __IO uint32_t hdtf5 : 1; /* [18] */
318 __IO uint32_t dterrf5 : 1; /* [19] */
319 __IO uint32_t gf6 : 1; /* [20] */
320 __IO uint32_t fdtf6 : 1; /* [21] */
321 __IO uint32_t hdtf6 : 1; /* [22] */
322 __IO uint32_t dterrf6 : 1; /* [23] */
323 __IO uint32_t gf7 : 1; /* [24] */
324 __IO uint32_t fdtf7 : 1; /* [25] */
325 __IO uint32_t hdtf7 : 1; /* [26] */
326 __IO uint32_t dterrf7 : 1; /* [27] */
327 __IO uint32_t reserved1 : 4; /* [31:28] */
328 } sts_bit;
329 };
330
334 union
335 {
336 __IO uint32_t clr;
337 struct
338 {
339 __IO uint32_t gfc1 : 1; /* [0] */
340 __IO uint32_t fdtfc1 : 1; /* [1] */
341 __IO uint32_t hdtfc1 : 1; /* [2] */
342 __IO uint32_t dterrfc1 : 1; /* [3] */
343 __IO uint32_t gfc2 : 1; /* [4] */
344 __IO uint32_t fdtfc2 : 1; /* [5] */
345 __IO uint32_t hdtfc2 : 1; /* [6] */
346 __IO uint32_t dterrfc2 : 1; /* [7] */
347 __IO uint32_t gfc3 : 1; /* [8] */
348 __IO uint32_t fdtfc3 : 1; /* [9] */
349 __IO uint32_t hdtfc3 : 1; /* [10] */
350 __IO uint32_t dterrfc3 : 1; /* [11] */
351 __IO uint32_t gfc4 : 1; /* [12] */
352 __IO uint32_t fdtfc4 : 1; /* [13] */
353 __IO uint32_t hdtfc4 : 1; /* [14] */
354 __IO uint32_t dterrfc4 : 1; /* [15] */
355 __IO uint32_t gfc5 : 1; /* [16] */
356 __IO uint32_t fdtfc5 : 1; /* [17] */
357 __IO uint32_t hdtfc5 : 1; /* [18] */
358 __IO uint32_t dterrfc5 : 1; /* [19] */
359 __IO uint32_t gfc6 : 1; /* [20] */
360 __IO uint32_t fdtfc6 : 1; /* [21] */
361 __IO uint32_t hdtfc6 : 1; /* [22] */
362 __IO uint32_t dterrfc6 : 1; /* [23] */
363 __IO uint32_t gfc7 : 1; /* [24] */
364 __IO uint32_t fdtfc7 : 1; /* [25] */
365 __IO uint32_t hdtfc7 : 1; /* [26] */
366 __IO uint32_t dterrfc7 : 1; /* [27] */
367 __IO uint32_t reserved1 : 4; /* [31:28] */
368 } clr_bit;
369 };
373 __IO uint32_t reserved1[38];
377 union
378 {
379 __IO uint32_t src_sel0;
380 struct
381 {
382 __IO uint32_t ch1_src : 8; /* [7:0] */
383 __IO uint32_t ch2_src : 8; /* [15:8] */
384 __IO uint32_t ch3_src : 8; /* [23:16] */
385 __IO uint32_t ch4_src : 8; /* [31:24] */
386 } src_sel0_bit;
387 };
388
392 union
393 {
394 __IO uint32_t src_sel1;
395 struct
396 {
397 __IO uint32_t ch5_src : 8; /* [7:0] */
398 __IO uint32_t ch6_src : 8; /* [15:8] */
399 __IO uint32_t ch7_src : 8; /* [23:16] */
400 __IO uint32_t dma_flex_en : 1; /* [24] */
401 __IO uint32_t reserved1 : 7; /* [31:25] */
402 } src_sel1_bit;
403 };
404} dma_type;
405
409typedef struct
410{
414 union
415 {
416 __IO uint32_t ctrl;
417 struct
418 {
419 __IO uint32_t chen : 1; /* [0] */
420 __IO uint32_t fdtien : 1; /* [1] */
421 __IO uint32_t hdtien : 1; /* [2] */
422 __IO uint32_t dterrien : 1; /* [3] */
423 __IO uint32_t dtd : 1; /* [4] */
424 __IO uint32_t lm : 1; /* [5] */
425 __IO uint32_t pincm : 1; /* [6] */
426 __IO uint32_t mincm : 1; /* [7] */
427 __IO uint32_t pwidth : 2; /* [9:8] */
428 __IO uint32_t mwidth : 2; /* [11:10] */
429 __IO uint32_t chpl : 2; /* [13:12] */
430 __IO uint32_t m2m : 1; /* [14] */
431 __IO uint32_t reserved1 : 17;/* [31:15] */
432 } ctrl_bit;
433 };
434
438 union
439 {
440 __IO uint32_t dtcnt;
441 struct
442 {
443 __IO uint32_t cnt : 16;/* [15:0] */
444 __IO uint32_t reserved1 : 16;/* [31:16] */
445 } dtcnt_bit;
446 };
447
451 union
452 {
453 __IO uint32_t paddr;
454 struct
455 {
456 __IO uint32_t paddr : 32;/* [31:0] */
457 } paddr_bit;
458 };
459
463 union
464 {
465 __IO uint32_t maddr;
466 struct
467 {
468 __IO uint32_t maddr : 32;/* [31:0] */
469 } maddr_bit;
470 };
471} dma_channel_type;
472
477#define DMA1 ((dma_type *) DMA1_BASE)
478#define DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
479#define DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
480#define DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
481#define DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
482#define DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
483#define DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
484#define DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
485
486#define DMA2 ((dma_type *) DMA2_BASE)
487#define DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
488#define DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
489#define DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
490#define DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
491#define DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
492#define DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
493#define DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)
494
499void dma_reset(dma_channel_type* dmax_channely);
500void dma_default_para_init(dma_init_type* dma_init_struct);
501void dma_init(dma_channel_type* dmax_channely, dma_init_type* dma_init_struct);
502void dma_channel_enable(dma_channel_type* dmax_channely, confirm_state new_state);
503void dma_flexible_config(dma_type* dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request);
504void dma_data_number_set(dma_channel_type* dmax_channely, uint16_t data_number);
505uint16_t dma_data_number_get(dma_channel_type* dmax_channely);
506void dma_interrupt_enable(dma_channel_type* dmax_channely, uint32_t dma_int, confirm_state new_state);
507 flag_status dma_flag_get(uint32_t dmax_flag);
508void dma_flag_clear(uint32_t dmax_flag);
509
510
523#ifdef __cplusplus
524}
525#endif
526
527#endif
at32f413.h
at32f413 header file
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:236
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_data_number_get
uint16_t dma_data_number_get(dma_channel_type *dmax_channely)
get number of data from dtcnt register
Definition: at32f413_dma.c:132
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
dma_data_number_set
void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred
Definition: at32f413_dma.c:107
dma_peripheral_inc_type
dma_peripheral_inc_type
dma peripheral incremented type
Definition: at32f413_dma.h:224
dma_peripheral_data_size_type
dma_peripheral_data_size_type
dma peripheral data size type
Definition: at32f413_dma.h:242
dma_flexible_request_type
dma_flexible_request_type
dma flexible request type
Definition: at32f413_dma.h:149
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:214
dma_memory_data_size_type
dma_memory_data_size_type
dma memory data size type
Definition: at32f413_dma.h:252
dma_priority_level_type
dma_priority_level_type
dma priority level type
Definition: at32f413_dma.h:262
dma_memory_inc_type
dma_memory_inc_type
dma memory incremented type
Definition: at32f413_dma.h:233
DMA_PERIPHERAL_INC_DISABLE
@ DMA_PERIPHERAL_INC_DISABLE
Definition: at32f413_dma.h:225
DMA_PERIPHERAL_INC_ENABLE
@ DMA_PERIPHERAL_INC_ENABLE
Definition: at32f413_dma.h:226
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:245
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_FLEXIBLE_TMR4_OVERFLOW
@ DMA_FLEXIBLE_TMR4_OVERFLOW
Definition: at32f413_dma.h:190
DMA_FLEXIBLE_TMR8_CH4
@ DMA_FLEXIBLE_TMR8_CH4
Definition: at32f413_dma.h:207
DMA_FLEXIBLE_TMR4_CH4
@ DMA_FLEXIBLE_TMR4_CH4
Definition: at32f413_dma.h:194
DMA_FLEXIBLE_SDIO1
@ DMA_FLEXIBLE_SDIO1
Definition: at32f413_dma.h:169
DMA_FLEXIBLE_UART5_RX
@ DMA_FLEXIBLE_UART5_RX
Definition: at32f413_dma.h:163
DMA_FLEXIBLE_UART3_TX
@ DMA_FLEXIBLE_UART3_TX
Definition: at32f413_dma.h:160
DMA_FLEXIBLE_TMR4_CH2
@ DMA_FLEXIBLE_TMR4_CH2
Definition: at32f413_dma.h:192
DMA_FLEXIBLE_I2C2_TX
@ DMA_FLEXIBLE_I2C2_TX
Definition: at32f413_dma.h:168
DMA_FLEXIBLE_TMR8_HALL
@ DMA_FLEXIBLE_TMR8_HALL
Definition: at32f413_dma.h:202
DMA_FLEXIBLE_TMR4_CH3
@ DMA_FLEXIBLE_TMR4_CH3
Definition: at32f413_dma.h:193
DMA_FLEXIBLE_TMR5_CH3
@ DMA_FLEXIBLE_TMR5_CH3
Definition: at32f413_dma.h:199
DMA_FLEXIBLE_TMR2_OVERFLOW
@ DMA_FLEXIBLE_TMR2_OVERFLOW
Definition: at32f413_dma.h:178
DMA_FLEXIBLE_UART2_RX
@ DMA_FLEXIBLE_UART2_RX
Definition: at32f413_dma.h:157
DMA_FLEXIBLE_TMR4_TRIG
@ DMA_FLEXIBLE_TMR4_TRIG
Definition: at32f413_dma.h:189
DMA_FLEXIBLE_TMR1_HALL
@ DMA_FLEXIBLE_TMR1_HALL
Definition: at32f413_dma.h:171
DMA_FLEXIBLE_TMR3_OVERFLOW
@ DMA_FLEXIBLE_TMR3_OVERFLOW
Definition: at32f413_dma.h:184
DMA_FLEXIBLE_TMR3_CH2
@ DMA_FLEXIBLE_TMR3_CH2
Definition: at32f413_dma.h:186
DMA_FLEXIBLE_TMR8_TRIG
@ DMA_FLEXIBLE_TMR8_TRIG
Definition: at32f413_dma.h:201
DMA_FLEXIBLE_SPI2_RX
@ DMA_FLEXIBLE_SPI2_RX
Definition: at32f413_dma.h:153
DMA_FLEXIBLE_UART1_TX
@ DMA_FLEXIBLE_UART1_TX
Definition: at32f413_dma.h:156
DMA_FLEXIBLE_TMR2_TRIG
@ DMA_FLEXIBLE_TMR2_TRIG
Definition: at32f413_dma.h:177
DMA_FLEXIBLE_TMR8_CH2
@ DMA_FLEXIBLE_TMR8_CH2
Definition: at32f413_dma.h:205
DMA_FLEXIBLE_TMR3_CH1
@ DMA_FLEXIBLE_TMR3_CH1
Definition: at32f413_dma.h:185
DMA_FLEXIBLE_TMR2_CH2
@ DMA_FLEXIBLE_TMR2_CH2
Definition: at32f413_dma.h:180
DMA_FLEXIBLE_TMR3_CH4
@ DMA_FLEXIBLE_TMR3_CH4
Definition: at32f413_dma.h:188
DMA_FLEXIBLE_TMR5_CH1
@ DMA_FLEXIBLE_TMR5_CH1
Definition: at32f413_dma.h:197
DMA_FLEXIBLE_TMR2_CH1
@ DMA_FLEXIBLE_TMR2_CH1
Definition: at32f413_dma.h:179
DMA_FLEXIBLE_TMR8_CH1
@ DMA_FLEXIBLE_TMR8_CH1
Definition: at32f413_dma.h:204
DMA_FLEXIBLE_TMR1_CH4
@ DMA_FLEXIBLE_TMR1_CH4
Definition: at32f413_dma.h:176
DMA_FLEXIBLE_I2C1_RX
@ DMA_FLEXIBLE_I2C1_RX
Definition: at32f413_dma.h:165
DMA_FLEXIBLE_TMR2_CH4
@ DMA_FLEXIBLE_TMR2_CH4
Definition: at32f413_dma.h:182
DMA_FLEXIBLE_TMR5_CH4
@ DMA_FLEXIBLE_TMR5_CH4
Definition: at32f413_dma.h:200
DMA_FLEXIBLE_TMR1_CH1
@ DMA_FLEXIBLE_TMR1_CH1
Definition: at32f413_dma.h:173
DMA_FLEXIBLE_ADC1
@ DMA_FLEXIBLE_ADC1
Definition: at32f413_dma.h:150
DMA_FLEXIBLE_UART2_TX
@ DMA_FLEXIBLE_UART2_TX
Definition: at32f413_dma.h:158
DMA_FLEXIBLE_UART4_TX
@ DMA_FLEXIBLE_UART4_TX
Definition: at32f413_dma.h:162
DMA_FLEXIBLE_TMR4_CH1
@ DMA_FLEXIBLE_TMR4_CH1
Definition: at32f413_dma.h:191
DMA_FLEXIBLE_TMR1_TRIG
@ DMA_FLEXIBLE_TMR1_TRIG
Definition: at32f413_dma.h:170
DMA_FLEXIBLE_UART1_RX
@ DMA_FLEXIBLE_UART1_RX
Definition: at32f413_dma.h:155
DMA_FLEXIBLE_SPI1_RX
@ DMA_FLEXIBLE_SPI1_RX
Definition: at32f413_dma.h:151
DMA_FLEXIBLE_UART3_RX
@ DMA_FLEXIBLE_UART3_RX
Definition: at32f413_dma.h:159
DMA_FLEXIBLE_TMR1_CH2
@ DMA_FLEXIBLE_TMR1_CH2
Definition: at32f413_dma.h:174
DMA_FLEXIBLE_TMR5_OVERFLOW
@ DMA_FLEXIBLE_TMR5_OVERFLOW
Definition: at32f413_dma.h:196
DMA_FLEXIBLE_TMR5_TRIG
@ DMA_FLEXIBLE_TMR5_TRIG
Definition: at32f413_dma.h:195
DMA_FLEXIBLE_UART4_RX
@ DMA_FLEXIBLE_UART4_RX
Definition: at32f413_dma.h:161
DMA_FLEXIBLE_TMR3_TRIG
@ DMA_FLEXIBLE_TMR3_TRIG
Definition: at32f413_dma.h:183
DMA_FLEXIBLE_I2C2_RX
@ DMA_FLEXIBLE_I2C2_RX
Definition: at32f413_dma.h:167
DMA_FLEXIBLE_TMR2_CH3
@ DMA_FLEXIBLE_TMR2_CH3
Definition: at32f413_dma.h:181
DMA_FLEXIBLE_I2C1_TX
@ DMA_FLEXIBLE_I2C1_TX
Definition: at32f413_dma.h:166
DMA_FLEXIBLE_TMR8_OVERFLOW
@ DMA_FLEXIBLE_TMR8_OVERFLOW
Definition: at32f413_dma.h:203
DMA_FLEXIBLE_SPI1_TX
@ DMA_FLEXIBLE_SPI1_TX
Definition: at32f413_dma.h:152
DMA_FLEXIBLE_TMR5_CH2
@ DMA_FLEXIBLE_TMR5_CH2
Definition: at32f413_dma.h:198
DMA_FLEXIBLE_SPI2_TX
@ DMA_FLEXIBLE_SPI2_TX
Definition: at32f413_dma.h:154
DMA_FLEXIBLE_TMR8_CH3
@ DMA_FLEXIBLE_TMR8_CH3
Definition: at32f413_dma.h:206
DMA_FLEXIBLE_TMR1_OVERFLOW
@ DMA_FLEXIBLE_TMR1_OVERFLOW
Definition: at32f413_dma.h:172
DMA_FLEXIBLE_TMR1_CH3
@ DMA_FLEXIBLE_TMR1_CH3
Definition: at32f413_dma.h:175
DMA_FLEXIBLE_TMR3_CH3
@ DMA_FLEXIBLE_TMR3_CH3
Definition: at32f413_dma.h:187
DMA_FLEXIBLE_UART5_TX
@ DMA_FLEXIBLE_UART5_TX
Definition: at32f413_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:255
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
DMA_PRIORITY_VERY_HIGH
@ DMA_PRIORITY_VERY_HIGH
Definition: at32f413_dma.h:266
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:263
DMA_MEMORY_INC_ENABLE
@ DMA_MEMORY_INC_ENABLE
Definition: at32f413_dma.h:235
DMA_MEMORY_INC_DISABLE
@ DMA_MEMORY_INC_DISABLE
Definition: at32f413_dma.h:234
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:410
dma_channel_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_dma.h:440
dma_channel_type::cnt
__IO uint32_t cnt
Definition: at32f413_dma.h:443
dma_channel_type::pwidth
__IO uint32_t pwidth
Definition: at32f413_dma.h:427
dma_channel_type::paddr
__IO uint32_t paddr
Definition: at32f413_dma.h:453
dma_channel_type::mincm
__IO uint32_t mincm
Definition: at32f413_dma.h:426
dma_channel_type::dterrien
__IO uint32_t dterrien
Definition: at32f413_dma.h:422
dma_channel_type::chen
__IO uint32_t chen
Definition: at32f413_dma.h:419
dma_channel_type::lm
__IO uint32_t lm
Definition: at32f413_dma.h:424
dma_channel_type::mwidth
__IO uint32_t mwidth
Definition: at32f413_dma.h:428
dma_channel_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_dma.h:431
dma_channel_type::dtd
__IO uint32_t dtd
Definition: at32f413_dma.h:423
dma_channel_type::maddr
__IO uint32_t maddr
Definition: at32f413_dma.h:465
dma_channel_type::hdtien
__IO uint32_t hdtien
Definition: at32f413_dma.h:421
dma_channel_type::m2m
__IO uint32_t m2m
Definition: at32f413_dma.h:430
dma_channel_type::pincm
__IO uint32_t pincm
Definition: at32f413_dma.h:425
dma_channel_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_dma.h:416
dma_channel_type::fdtien
__IO uint32_t fdtien
Definition: at32f413_dma.h:420
dma_channel_type::chpl
__IO uint32_t chpl
Definition: at32f413_dma.h:429
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
dma_type
type define dma register
Definition: at32f413_dma.h:290
dma_type::gfc3
__IO uint32_t gfc3
Definition: at32f413_dma.h:347
dma_type::dterrfc1
__IO uint32_t dterrfc1
Definition: at32f413_dma.h:342
dma_type::ch2_src
__IO uint32_t ch2_src
Definition: at32f413_dma.h:383
dma_type::gfc2
__IO uint32_t gfc2
Definition: at32f413_dma.h:343
dma_type::src_sel1
__IO uint32_t src_sel1
Definition: at32f413_dma.h:394
dma_type::ch3_src
__IO uint32_t ch3_src
Definition: at32f413_dma.h:384
dma_type::hdtfc3
__IO uint32_t hdtfc3
Definition: at32f413_dma.h:349
dma_type::fdtfc2
__IO uint32_t fdtfc2
Definition: at32f413_dma.h:344
dma_type::hdtf7
__IO uint32_t hdtf7
Definition: at32f413_dma.h:325
dma_type::gfc1
__IO uint32_t gfc1
Definition: at32f413_dma.h:339
dma_type::gf4
__IO uint32_t gf4
Definition: at32f413_dma.h:311
dma_type::hdtf2
__IO uint32_t hdtf2
Definition: at32f413_dma.h:305
dma_type::hdtf3
__IO uint32_t hdtf3
Definition: at32f413_dma.h:309
dma_type::dma_flex_en
__IO uint32_t dma_flex_en
Definition: at32f413_dma.h:400
dma_type::fdtf7
__IO uint32_t fdtf7
Definition: at32f413_dma.h:324
dma_type::reserved1
__IO uint32_t reserved1
reserved, offset:0x08~0x9C
Definition: at32f413_dma.h:327
dma_type::dterrfc2
__IO uint32_t dterrfc2
Definition: at32f413_dma.h:346
dma_type::dterrf4
__IO uint32_t dterrf4
Definition: at32f413_dma.h:314
dma_type::gf7
__IO uint32_t gf7
Definition: at32f413_dma.h:323
dma_type::fdtfc4
__IO uint32_t fdtfc4
Definition: at32f413_dma.h:352
dma_type::src_sel0
__IO uint32_t src_sel0
Definition: at32f413_dma.h:379
dma_type::gf2
__IO uint32_t gf2
Definition: at32f413_dma.h:303
dma_type::hdtfc6
__IO uint32_t hdtfc6
Definition: at32f413_dma.h:361
dma_type::dterrf5
__IO uint32_t dterrf5
Definition: at32f413_dma.h:318
dma_type::hdtf5
__IO uint32_t hdtf5
Definition: at32f413_dma.h:317
dma_type::fdtfc5
__IO uint32_t fdtfc5
Definition: at32f413_dma.h:356
dma_type::fdtfc1
__IO uint32_t fdtfc1
Definition: at32f413_dma.h:340
dma_type::hdtf4
__IO uint32_t hdtf4
Definition: at32f413_dma.h:313
dma_type::ch5_src
__IO uint32_t ch5_src
Definition: at32f413_dma.h:397
dma_type::fdtf1
__IO uint32_t fdtf1
Definition: at32f413_dma.h:300
dma_type::gfc6
__IO uint32_t gfc6
Definition: at32f413_dma.h:359
dma_type::dterrf6
__IO uint32_t dterrf6
Definition: at32f413_dma.h:322
dma_type::fdtf4
__IO uint32_t fdtf4
Definition: at32f413_dma.h:312
dma_type::dterrf2
__IO uint32_t dterrf2
Definition: at32f413_dma.h:306
dma_type::gfc4
__IO uint32_t gfc4
Definition: at32f413_dma.h:351
dma_type::dterrfc3
__IO uint32_t dterrfc3
Definition: at32f413_dma.h:350
dma_type::dterrf1
__IO uint32_t dterrf1
Definition: at32f413_dma.h:302
dma_type::hdtfc1
__IO uint32_t hdtfc1
Definition: at32f413_dma.h:341
dma_type::sts
__IO uint32_t sts
Definition: at32f413_dma.h:296
dma_type::dterrf3
__IO uint32_t dterrf3
Definition: at32f413_dma.h:310
dma_type::fdtf5
__IO uint32_t fdtf5
Definition: at32f413_dma.h:316
dma_type::clr
__IO uint32_t clr
Definition: at32f413_dma.h:336
dma_type::fdtfc7
__IO uint32_t fdtfc7
Definition: at32f413_dma.h:364
dma_type::fdtf2
__IO uint32_t fdtf2
Definition: at32f413_dma.h:304
dma_type::gf1
__IO uint32_t gf1
Definition: at32f413_dma.h:299
dma_type::fdtf3
__IO uint32_t fdtf3
Definition: at32f413_dma.h:308
dma_type::hdtfc5
__IO uint32_t hdtfc5
Definition: at32f413_dma.h:357
dma_type::gf3
__IO uint32_t gf3
Definition: at32f413_dma.h:307
dma_type::dterrfc6
__IO uint32_t dterrfc6
Definition: at32f413_dma.h:362
dma_type::fdtfc3
__IO uint32_t fdtfc3
Definition: at32f413_dma.h:348
dma_type::hdtfc2
__IO uint32_t hdtfc2
Definition: at32f413_dma.h:345
dma_type::fdtfc6
__IO uint32_t fdtfc6
Definition: at32f413_dma.h:360
dma_type::ch1_src
__IO uint32_t ch1_src
Definition: at32f413_dma.h:382
dma_type::dterrfc7
__IO uint32_t dterrfc7
Definition: at32f413_dma.h:366
dma_type::gf6
__IO uint32_t gf6
Definition: at32f413_dma.h:319
dma_type::fdtf6
__IO uint32_t fdtf6
Definition: at32f413_dma.h:320
dma_type::gfc5
__IO uint32_t gfc5
Definition: at32f413_dma.h:355
dma_type::hdtfc7
__IO uint32_t hdtfc7
Definition: at32f413_dma.h:365
dma_type::dterrfc5
__IO uint32_t dterrfc5
Definition: at32f413_dma.h:358
dma_type::gfc7
__IO uint32_t gfc7
Definition: at32f413_dma.h:363
dma_type::hdtf1
__IO uint32_t hdtf1
Definition: at32f413_dma.h:301
dma_type::ch7_src
__IO uint32_t ch7_src
Definition: at32f413_dma.h:399
dma_type::ch4_src
__IO uint32_t ch4_src
Definition: at32f413_dma.h:385
dma_type::dterrf7
__IO uint32_t dterrf7
Definition: at32f413_dma.h:326
dma_type::dterrfc4
__IO uint32_t dterrfc4
Definition: at32f413_dma.h:354
dma_type::gf5
__IO uint32_t gf5
Definition: at32f413_dma.h:315
dma_type::hdtfc4
__IO uint32_t hdtfc4
Definition: at32f413_dma.h:353
dma_type::ch6_src
__IO uint32_t ch6_src
Definition: at32f413_dma.h:398
dma_type::hdtf6
__IO uint32_t hdtf6
Definition: at32f413_dma.h:321


AT32F413 Firmwary Library: at32f413_exint.c Source File

  • libraries
  • drivers
  • src
at32f413_exint.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef EXINT_MODULE_ENABLED
37
47void exint_reset(void)
48{
49 EXINT->inten = 0x00000000;
50 EXINT->polcfg1 = 0x00000000;
51 EXINT->polcfg2 = 0x00000000;
52 EXINT->evten = 0x00000000;
53 EXINT->intsts = 0x0007FFFF;
54}
55
62void exint_default_para_init(exint_init_type *exint_struct)
63{
64 exint_struct->line_enable = FALSE;
65 exint_struct->line_select = EXINT_LINE_NONE;
66 exint_struct->line_polarity = EXINT_TRIGGER_FALLING_EDGE;
67 exint_struct->line_mode = EXINT_LINE_EVENT;
68}
69
76void exint_init(exint_init_type *exint_struct)
77{
78 uint32_t line_index = 0;
79 line_index = exint_struct->line_select;
80
81 EXINT->inten &= ~line_index;
82 EXINT->evten &= ~line_index;
83
84 if(exint_struct->line_enable != FALSE)
85 {
86 if(exint_struct->line_mode == EXINT_LINE_INTERRUPUT)
87 {
88 EXINT->inten |= line_index;
89 }
90 else
91 {
92 EXINT->evten |= line_index;
93 }
94
95 EXINT->polcfg1 &= ~line_index;
96 EXINT->polcfg2 &= ~line_index;
97 if(exint_struct->line_polarity == EXINT_TRIGGER_RISING_EDGE)
98 {
99 EXINT->polcfg1 |= line_index;
100 }
101 else if(exint_struct->line_polarity == EXINT_TRIGGER_FALLING_EDGE)
102 {
103 EXINT->polcfg2 |= line_index;
104 }
105 else
106 {
107 EXINT->polcfg1 |= line_index;
108 EXINT->polcfg2 |= line_index;
109 }
110 }
111}
112
124void exint_flag_clear(uint32_t exint_line)
125{
126 EXINT->intsts = exint_line;
127}
128
140 flag_status exint_flag_get(uint32_t exint_line)
141{
142 flag_status status = RESET;
143 uint32_t exint_flag =0;
144 exint_flag = EXINT->intsts & exint_line;
145 if((exint_flag != (uint16_t)RESET))
146 {
147 status = SET;
148 }
149 else
150 {
151 status = RESET;
152 }
153 return status;
154}
155
167void exint_software_interrupt_event_generate(uint32_t exint_line)
168{
169 EXINT->swtrg |= exint_line;
170}
171
185void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
186{
187 if(new_state == TRUE)
188 {
189 EXINT->inten |= exint_line;
190 }
191 else
192 {
193 EXINT->inten &= ~exint_line;
194 }
195}
196
210void exint_event_enable(uint32_t exint_line, confirm_state new_state)
211{
212 if(new_state == TRUE)
213 {
214 EXINT->evten |= exint_line;
215 }
216 else
217 {
218 EXINT->evten &= ~exint_line;
219 }
220}
221
226#endif
227
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f413_exint.h:83
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_TRIGGER_FALLING_EDGE
@ EXINT_TRIGGER_FALLING_EDGE
Definition: at32f413_exint.h:92
EXINT_LINE_NONE
#define EXINT_LINE_NONE
Definition: at32f413_exint.h:49
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:140
exint_interrupt_enable
void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt
Definition: at32f413_exint.c:185
exint_event_enable
void exint_event_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint event
Definition: at32f413_exint.c:210
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_reset
void exint_reset(void)
exint reset
Definition: at32f413_exint.c:47
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f413_exint.c:167
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT
#define EXINT
Definition: at32f413_exint.h:196
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_exint.h Source File

  • libraries
  • drivers
  • inc
at32f413_exint.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_EXINT_H
27#define __AT32F413_EXINT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
49#define EXINT_LINE_NONE ((uint32_t)0x000000)
50#define EXINT_LINE_0 ((uint32_t)0x000001)
51#define EXINT_LINE_1 ((uint32_t)0x000002)
52#define EXINT_LINE_2 ((uint32_t)0x000004)
53#define EXINT_LINE_3 ((uint32_t)0x000008)
54#define EXINT_LINE_4 ((uint32_t)0x000010)
55#define EXINT_LINE_5 ((uint32_t)0x000020)
56#define EXINT_LINE_6 ((uint32_t)0x000040)
57#define EXINT_LINE_7 ((uint32_t)0x000080)
58#define EXINT_LINE_8 ((uint32_t)0x000100)
59#define EXINT_LINE_9 ((uint32_t)0x000200)
60#define EXINT_LINE_10 ((uint32_t)0x000400)
61#define EXINT_LINE_11 ((uint32_t)0x000800)
62#define EXINT_LINE_12 ((uint32_t)0x001000)
63#define EXINT_LINE_13 ((uint32_t)0x002000)
64#define EXINT_LINE_14 ((uint32_t)0x004000)
65#define EXINT_LINE_15 ((uint32_t)0x008000)
66#define EXINT_LINE_16 ((uint32_t)0x010000)
67#define EXINT_LINE_17 ((uint32_t)0x020000)
68#define EXINT_LINE_18 ((uint32_t)0x040000)
80typedef enum
81{
82 EXINT_LINE_INTERRUPUT = 0x00,
83 EXINT_LINE_EVENT = 0x01
84} exint_line_mode_type;
85
89typedef enum
90{
91 EXINT_TRIGGER_RISING_EDGE = 0x00,
92 EXINT_TRIGGER_FALLING_EDGE = 0x01,
93 EXINT_TRIGGER_BOTH_EDGE = 0x02
94} exint_polarity_config_type;
95
99typedef struct
100{
101 exint_line_mode_type line_mode;
102 uint32_t line_select;
103 exint_polarity_config_type line_polarity;
104 confirm_state line_enable;
105} exint_init_type;
106
110typedef struct
111{
112
116 union
117 {
118 __IO uint32_t inten;
119 struct
120 {
121 __IO uint32_t intenx : 23;/* [22:0] */
122 __IO uint32_t reserved1 : 9;/* [31:23] */
123 } inten_bit;
124 };
125
129 union
130 {
131 __IO uint32_t evten;
132 struct
133 {
134 __IO uint32_t evtenx : 23;/* [22:0] */
135 __IO uint32_t reserved1 : 9;/* [31:23] */
136 } evten_bit;
137 };
138
142 union
143 {
144 __IO uint32_t polcfg1;
145 struct
146 {
147 __IO uint32_t rpx : 23;/* [22:0] */
148 __IO uint32_t reserved1 : 9;/* [31:23] */
149 } polcfg1_bit;
150 };
151
155 union
156 {
157 __IO uint32_t polcfg2;
158 struct
159 {
160 __IO uint32_t fpx : 23;/* [22:0] */
161 __IO uint32_t reserved1 : 9;/* [31:23] */
162 } polcfg2_bit;
163 };
164
168 union
169 {
170 __IO uint32_t swtrg;
171 struct
172 {
173 __IO uint32_t swtx : 23;/* [22:0] */
174 __IO uint32_t reserved1 : 9;/* [31:23] */
175 } swtrg_bit;
176 };
177
181 union
182 {
183 __IO uint32_t intsts;
184 struct
185 {
186 __IO uint32_t linex : 23;/* [22:0] */
187 __IO uint32_t reserved1 : 9;/* [31:23] */
188 } intsts_bit;
189 };
190} exint_type;
191
196#define EXINT ((exint_type *) EXINT_BASE)
197
202void exint_reset(void);
203void exint_default_para_init(exint_init_type *exint_struct);
204void exint_init(exint_init_type *exint_struct);
205void exint_flag_clear(uint32_t exint_line);
206 flag_status exint_flag_get(uint32_t exint_line);
207void exint_software_interrupt_event_generate(uint32_t exint_line);
208void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state);
209void exint_event_enable(uint32_t exint_line, confirm_state new_state);
210
223#ifdef __cplusplus
224}
225#endif
226
227#endif
at32f413.h
at32f413 header file
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:140
exint_interrupt_enable
void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt
Definition: at32f413_exint.c:185
exint_event_enable
void exint_event_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint event
Definition: at32f413_exint.c:210
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_reset
void exint_reset(void)
exint reset
Definition: at32f413_exint.c:47
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f413_exint.c:167
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
exint_line_mode_type
exint_line_mode_type
exint line mode type
Definition: at32f413_exint.h:81
exint_polarity_config_type
exint_polarity_config_type
exint polarity configuration type
Definition: at32f413_exint.h:90
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f413_exint.h:83
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_TRIGGER_FALLING_EDGE
@ EXINT_TRIGGER_FALLING_EDGE
Definition: at32f413_exint.h:92
EXINT_TRIGGER_BOTH_EDGE
@ EXINT_TRIGGER_BOTH_EDGE
Definition: at32f413_exint.h:93
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
exint_type
type define exint register all
Definition: at32f413_exint.h:111
exint_type::polcfg1
__IO uint32_t polcfg1
Definition: at32f413_exint.h:144
exint_type::intsts
__IO uint32_t intsts
Definition: at32f413_exint.h:183
exint_type::polcfg2
__IO uint32_t polcfg2
Definition: at32f413_exint.h:157
exint_type::fpx
__IO uint32_t fpx
Definition: at32f413_exint.h:160
exint_type::intenx
__IO uint32_t intenx
Definition: at32f413_exint.h:121
exint_type::rpx
__IO uint32_t rpx
Definition: at32f413_exint.h:147
exint_type::evtenx
__IO uint32_t evtenx
Definition: at32f413_exint.h:134
exint_type::linex
__IO uint32_t linex
Definition: at32f413_exint.h:186
exint_type::inten
__IO uint32_t inten
Definition: at32f413_exint.h:118
exint_type::evten
__IO uint32_t evten
Definition: at32f413_exint.h:131
exint_type::swtx
__IO uint32_t swtx
Definition: at32f413_exint.h:173
exint_type::swtrg
__IO uint32_t swtrg
Definition: at32f413_exint.h:170
exint_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_exint.h:122


AT32F413 Firmwary Library: at32f413_flash.c Source File

  • libraries
  • drivers
  • src
at32f413_flash.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef FLASH_MODULE_ENABLED
37
57 flag_status flash_flag_get(uint32_t flash_flag)
58{
59 flag_status status = RESET;
60 uint32_t flag_position;
61 flag_position = flash_flag & 0x70000000;
62 flash_flag &= 0x8FFFFFFF;
63 switch(flag_position)
64 {
65 case 0x00000000:
66 if(FLASH->sts & flash_flag)
67 status = SET;
68 break;
69 case 0x20000000:
70 if(FLASH->sts3 & flash_flag)
71 status = SET;
72 break;
73 case 0x40000000:
74 if(FLASH->usd & flash_flag)
75 status = SET;
76 break;
77 default:
78 break;
79 }
80 /* return the new state of flash_flag (SET or RESET) */
81 return status;
82}
83
96void flash_flag_clear(uint32_t flash_flag)
97{
98 uint32_t flag_position;
99 flag_position = flash_flag & 0x70000000;
100 flash_flag &= 0x8FFFFFFF;
101 switch(flag_position)
102 {
103 case 0x00000000:
104 FLASH->sts = flash_flag;
105 break;
106 case 0x20000000:
107 FLASH->sts3 = flash_flag;
108 break;
109 default:
110 break;
111 }
112}
113
120 flash_status_type flash_operation_status_get(void)
121{
122 flash_status_type flash_status = FLASH_OPERATE_DONE;
123 if(FLASH->sts_bit.obf != RESET)
124 {
125 flash_status = FLASH_OPERATE_BUSY;
126 }
127 else if(FLASH->sts_bit.prgmerr != RESET)
128 {
129 flash_status = FLASH_PROGRAM_ERROR;
130 }
131 else if(FLASH->sts_bit.epperr != RESET)
132 {
133 flash_status = FLASH_EPP_ERROR;
134 }
135 else
136 {
137 flash_status = FLASH_OPERATE_DONE;
138 }
139 /* return the flash status */
140 return flash_status;
141}
142
149 flash_status_type flash_spim_operation_status_get(void)
150{
151 flash_status_type flash_status = FLASH_OPERATE_DONE;
152 if(FLASH->sts3_bit.obf != RESET)
153 {
154 flash_status = FLASH_OPERATE_BUSY;
155 }
156 else if(FLASH->sts3_bit.prgmerr != RESET)
157 {
158 flash_status = FLASH_PROGRAM_ERROR;
159 }
160 else if(FLASH->sts3_bit.epperr != RESET)
161 {
162 flash_status = FLASH_EPP_ERROR;
163 }
164 else
165 {
166 flash_status = FLASH_OPERATE_DONE;
167 }
168 /* return the flash status */
169 return flash_status;
170}
171
178 flash_status_type flash_operation_wait_for(uint32_t time_out)
179{
180 flash_status_type status = FLASH_OPERATE_DONE;
181 /* check for the flash status */
182 status = flash_operation_status_get();
183
184 while((status == FLASH_OPERATE_BUSY) && (time_out != 0x00))
185 {
186 status = flash_operation_status_get();
187 time_out--;
188 }
189 if(time_out == 0x00)
190 {
191 status = FLASH_OPERATE_TIMEOUT;
192 }
193 /* return the status */
194 return status;
195}
196
203 flash_status_type flash_spim_operation_wait_for(uint32_t time_out)
204{
205 flash_status_type status = FLASH_OPERATE_DONE;
206 /* check for the flash status */
207 status = flash_spim_operation_status_get();
208
209 while((status == FLASH_OPERATE_BUSY) && (time_out != 0x00))
210 {
211 status = flash_spim_operation_status_get();
212 time_out--;
213 }
214 if(time_out == 0x00)
215 {
216 status = FLASH_OPERATE_TIMEOUT;
217 }
218 /* return the operation status */
219 return status;
220}
221
227void flash_unlock(void)
228{
229 FLASH->unlock = FLASH_UNLOCK_KEY1;
230 FLASH->unlock = FLASH_UNLOCK_KEY2;
231}
232
238void flash_spim_unlock(void)
239{
240 FLASH->unlock3 = FLASH_UNLOCK_KEY1;
241 FLASH->unlock3 = FLASH_UNLOCK_KEY2;
242}
243
249void flash_lock(void)
250{
251 FLASH->ctrl_bit.oplk = TRUE;
252}
253
259void flash_spim_lock(void)
260{
261 FLASH->ctrl3_bit.oplk = TRUE;
262}
263
270 flash_status_type flash_sector_erase(uint32_t sector_address)
271{
272 flash_status_type status = FLASH_OPERATE_DONE;
273 /* spim : external flash */
274 if(sector_address >= FLASH_SPIM_START_ADDR)
275 {
276 FLASH->ctrl3_bit.secers = TRUE;
277 FLASH->addr3 = sector_address;
278 FLASH->ctrl3_bit.erstr = TRUE;
279
280 /* wait for operation to be completed */
281 status = flash_spim_operation_wait_for(SPIM_ERASE_TIMEOUT);
282
283 /* disable the secers bit */
284 FLASH->ctrl3_bit.secers = FALSE;
285
286 /* dummy read */
287 flash_spim_dummy_read();
288 }
289 else
290 {
291 FLASH->ctrl_bit.secers = TRUE;
292 FLASH->addr = sector_address;
293 FLASH->ctrl_bit.erstr = TRUE;
294
295 /* wait for operation to be completed */
296 status = flash_operation_wait_for(ERASE_TIMEOUT);
297
298 /* disable the secers bit */
299 FLASH->ctrl_bit.secers = FALSE;
300 }
301 /* return the erase status */
302 return status;
303}
304
311 flash_status_type flash_internal_all_erase(void)
312{
313 flash_status_type status = FLASH_OPERATE_DONE;
314
315 FLASH->ctrl_bit.bankers = TRUE;
316 FLASH->ctrl_bit.erstr = TRUE;
317
318 /* wait for operation to be completed */
319 status = flash_operation_wait_for(ERASE_TIMEOUT);
320
321 /* disable the bankers bit */
322 FLASH->ctrl_bit.bankers = FALSE;
323
324 /* return the erase status */
325 return status;
326}
327
334 flash_status_type flash_spim_all_erase(void)
335{
336 flash_status_type status = FLASH_OPERATE_DONE;
337
338 FLASH->ctrl3_bit.chpers = TRUE;
339 FLASH->ctrl3_bit.erstr = TRUE;
340
341 /* wait for operation to be completed */
342 status = flash_spim_operation_wait_for(SPIM_ERASE_TIMEOUT);
343
344 /* disable the chpers bit */
345 FLASH->ctrl3_bit.chpers = FALSE;
346
347 /* dummy read */
348 flash_spim_dummy_read();
349
350 /* return the erase status */
351 return status;
352}
353
361 flash_status_type flash_user_system_data_erase(void)
362{
363 flash_status_type status = FLASH_OPERATE_DONE;
364 uint16_t fap_val = FAP_RELIEVE_KEY;
365 /* get the flash access protection status */
366 if(flash_fap_status_get() != RESET)
367 {
368 fap_val = 0x0000;
369 }
370
371 /* unlock the user system data */
372 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
373 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
374 while(FLASH->ctrl_bit.usdulks == RESET);
375
376 /* erase the user system data */
377 FLASH->ctrl_bit.usders = TRUE;
378 FLASH->ctrl_bit.erstr = TRUE;
379
380 /* wait for operation to be completed */
381 status = flash_operation_wait_for(ERASE_TIMEOUT);
382
383 /* disable the usders bit */
384 FLASH->ctrl_bit.usders = FALSE;
385
386 if((status == FLASH_OPERATE_DONE) && (fap_val == FAP_RELIEVE_KEY))
387 {
388 /* enable the user system data programming operation */
389 FLASH->ctrl_bit.usdprgm = TRUE;
390
391 /* restore the last flash access protection value */
392 USD->fap = (uint16_t)fap_val;
393
394 /* wait for operation to be completed */
395 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
396
397 /*disable the usdprgm bit */
398 FLASH->ctrl_bit.usdprgm = FALSE;
399 }
400
401 /* return the erase status */
402 return status;
403}
404
412 flash_status_type flash_word_program(uint32_t address, uint32_t data)
413{
414 flash_status_type status = FLASH_OPERATE_DONE;
415 /* spim : external flash */
416 if(address >= FLASH_SPIM_START_ADDR)
417 {
418 FLASH->ctrl3_bit.fprgm = TRUE;
419 *(__IO uint32_t*)address = data;
420 /* wait for operation to be completed */
421 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
422
423 /* disable the fprgm bit */
424 FLASH->ctrl3_bit.fprgm = FALSE;
425
426 /* dummy read */
427 flash_spim_dummy_read();
428 }
429 else
430 {
431 FLASH->ctrl_bit.fprgm = TRUE;
432 *(__IO uint32_t*)address = data;
433 /* wait for operation to be completed */
434 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
435
436 /* disable the fprgm bit */
437 FLASH->ctrl_bit.fprgm = FALSE;
438 }
439 /* return the program status */
440 return status;
441}
442
450 flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
451{
452 flash_status_type status = FLASH_OPERATE_DONE;
453 /* spim : external flash */
454 if(address >= FLASH_SPIM_START_ADDR)
455 {
456 FLASH->ctrl3_bit.fprgm = TRUE;
457 *(__IO uint16_t*)address = data;
458 /* wait for operation to be completed */
459 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
460
461 /* disable the fprgm bit */
462 FLASH->ctrl3_bit.fprgm = FALSE;
463
464 /* dummy read */
465 flash_spim_dummy_read();
466 }
467 else
468 {
469 FLASH->ctrl_bit.fprgm = TRUE;
470 *(__IO uint16_t*)address = data;
471 /* wait for operation to be completed */
472 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
473
474 /* disable the fprgm bit */
475 FLASH->ctrl_bit.fprgm = FALSE;
476 }
477 /* return the program status */
478 return status;
479}
480
489 flash_status_type flash_byte_program(uint32_t address, uint8_t data)
490{
491 flash_status_type status = FLASH_OPERATE_DONE;
492
493 FLASH->ctrl_bit.fprgm = TRUE;
494 *(__IO uint8_t*)address = data;
495 /* wait for operation to be completed */
496 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
497
498 /* disable the fprgm bit */
499 FLASH->ctrl_bit.fprgm = FALSE;
500
501 /* return the program status */
502 return status;
503}
504
512 flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
513{
514 flash_status_type status = FLASH_OPERATE_DONE;
515
516 if(address == USD_BASE)
517 {
518 if(data != 0xA5)
519 return FLASH_OPERATE_DONE;
520 }
521
522 /* unlock the user system data */
523 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
524 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
525 while(FLASH->ctrl_bit.usdulks==RESET);
526
527 /* enable the user system data programming operation */
528 FLASH->ctrl_bit.usdprgm = TRUE;
529 *(__IO uint16_t*)address = data;
530
531 /* wait for operation to be completed */
532 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
533
534 /* disable the usdprgm bit */
535 FLASH->ctrl_bit.usdprgm = FALSE;
536
537 /* return the user system data program status */
538 return status;
539}
540
550 flash_status_type flash_epp_set(uint32_t *sector_bits)
551{
552 uint16_t epp_data[4] = {0xFFFF,0xFFFF,0xFFFF,0xFFFF};
553 flash_status_type status = FLASH_OPERATE_DONE;
554 sector_bits[0] = (uint32_t)(~sector_bits[0]);
555 epp_data[0] = (uint16_t)((sector_bits[0] >> 0) & 0xFF);
556 epp_data[1] = (uint16_t)((sector_bits[0] >> 8) & 0xFF);
557 epp_data[2] = (uint16_t)((sector_bits[0] >> 16) & 0xFF);
558 epp_data[3] = (uint16_t)((sector_bits[0] >> 24) & 0xFF);
559
560 /* unlock the user system data */
561 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
562 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
563 while(FLASH->ctrl_bit.usdulks==RESET);
564
565 FLASH->ctrl_bit.usdprgm = TRUE;
566 USD->epp0 = epp_data[0];
567 /* wait for operation to be completed */
568 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
569
570 if(status == FLASH_OPERATE_DONE)
571 {
572 USD->epp1 = epp_data[1];
573 /* wait for operation to be completed */
574 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
575 }
576 if(status == FLASH_OPERATE_DONE)
577 {
578 USD->epp2 = epp_data[2];
579 /* wait for operation to be completed */
580 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
581 }
582 if(status == FLASH_OPERATE_DONE)
583 {
584 USD->epp3 = epp_data[3];
585 /* wait for operation to be completed */
586 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
587 }
588 /* disable the usdprgm bit */
589 FLASH->ctrl_bit.usdprgm = FALSE;
590
591 /* return the erase/program protection operation status */
592 return status;
593}
594
600void flash_epp_status_get(uint32_t *sector_bits)
601{
602 /* return the flash erase/program protection register value */
603 sector_bits[0] = (uint32_t)(FLASH->epps);
604}
605
615 flash_status_type flash_fap_enable(confirm_state new_state)
616{
617 flash_status_type status = FLASH_OPERATE_DONE;
618
619 /* unlock the user system data */
620 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
621 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
622 while(FLASH->ctrl_bit.usdulks==RESET);
623
624 FLASH->ctrl_bit.usders = TRUE;
625 FLASH->ctrl_bit.erstr = TRUE;
626 /* wait for operation to be completed */
627 status = flash_operation_wait_for(ERASE_TIMEOUT);
628
629 /* disable the usders bit */
630 FLASH->ctrl_bit.usders = FALSE;
631
632 if(status == FLASH_OPERATE_DONE)
633 {
634 if(new_state == FALSE)
635 {
636 /* enable the user system data programming operation */
637 FLASH->ctrl_bit.usdprgm = TRUE;
638 USD->fap = FAP_RELIEVE_KEY;
639
640 /* Wait for operation to be completed */
641 status = flash_operation_wait_for(ERASE_TIMEOUT);
642
643 /* disable the usdprgm bit */
644 FLASH->ctrl_bit.usdprgm = FALSE;
645 }
646 }
647
648 /* return the flash access protection operation status */
649 return status;
650}
651
657 flag_status flash_fap_status_get(void)
658{
659 return (flag_status)FLASH->usd_bit.fap;
660}
661
681 flash_status_type flash_ssb_set(uint8_t usd_ssb)
682{
683 flash_status_type status = FLASH_OPERATE_DONE;
684
685 /* unlock the user system data */
686 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
687 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
688 while(FLASH->ctrl_bit.usdulks==RESET);
689
690 /* enable the user system data programming operation */
691 FLASH->ctrl_bit.usdprgm = TRUE;
692
693 USD->ssb = usd_ssb;
694 /* wait for operation to be completed */
695 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
696
697 /* disable the usdprgm bit */
698 FLASH->ctrl_bit.usdprgm = FALSE;
699
700 /* return the user system data program status */
701 return status;
702}
703
709uint8_t flash_ssb_status_get(void)
710{
711 /* return the system setting byte status */
712 return (uint8_t)(FLASH->usd >> 2);
713}
714
727void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
728{
729 if(flash_int & FLASH_ERR_INT)
730 FLASH->ctrl_bit.errie = new_state;
731 if(flash_int & FLASH_ODF_INT)
732 FLASH->ctrl_bit.odfie = new_state;
733 if(flash_int & FLASH_SPIM_ERR_INT)
734 FLASH->ctrl3_bit.errie = new_state;
735 if(flash_int & FLASH_SPIM_ODF_INT)
736 FLASH->ctrl3_bit.odfie = new_state;
737}
738
744void flash_spim_model_select(flash_spim_model_type mode)
745{
746 FLASH->select = mode;
747
748 /* dummy read */
749 flash_spim_dummy_read();
750}
751
759void flash_spim_encryption_range_set(uint32_t decode_address)
760{
761 FLASH->da = decode_address;
762}
763
769void flash_spim_dummy_read(void)
770{
771 UNUSED(*(__IO uint32_t*)FLASH_SPIM_START_ADDR);
772 UNUSED(*(__IO uint32_t*)(FLASH_SPIM_START_ADDR + 0x1000));
773 UNUSED(*(__IO uint32_t*)(FLASH_SPIM_START_ADDR + 0x2000));
774}
775
784 flash_status_type flash_spim_mass_program(uint32_t address, uint8_t *buf, uint32_t cnt)
785{
786 flash_status_type status = FLASH_OPERATE_DONE;
787 uint32_t index, temp_offset;
788 if(address >= FLASH_SPIM_START_ADDR)
789 {
790 temp_offset = cnt % 4;
791 if((temp_offset != 0) && (temp_offset != 2))
792 return status;
793
794 FLASH->ctrl3_bit.fprgm = TRUE;
795 for(index = 0; index < cnt / 4; index++)
796 {
797 *(__IO uint32_t*)(address + index * 4) = *(uint32_t*)(buf + index * 4);
798 /* wait for operation to be completed */
799 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
800 if(status != FLASH_OPERATE_DONE)
801 return status;
802 }
803 if(temp_offset == 2)
804 {
805 *(__IO uint16_t*)(address + index * 4) = *(uint16_t*)(buf + index * 4);
806 /* wait for operation to be completed */
807 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
808 }
809 /* disable the fprgm bit */
810 FLASH->ctrl3_bit.fprgm = FALSE;
811
812 /* dummy read */
813 flash_spim_dummy_read();
814 }
815
816 /* return the program status */
817 return status;
818}
819
829 flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
830{
831 uint32_t slib_range;
832 flash_status_type status = FLASH_OPERATE_DONE;
833
834 /*check range param limits*/
835 if((start_sector>=data_start_sector) || ((data_start_sector > end_sector) && \
836 (data_start_sector != 0x7FF)) || (start_sector > end_sector))
837 return FLASH_PROGRAM_ERROR;
838
839
840 /* unlock slib cfg register */
841 FLASH->slib_unlock = SLIB_UNLOCK_KEY;
842 while(FLASH->slib_misc_sts_bit.slib_ulkf==RESET);
843
844 slib_range = ((uint32_t)(data_start_sector << 11) & FLASH_SLIB_DATA_START_SECTOR) | \
845 ((uint32_t)(end_sector << 22) & FLASH_SLIB_END_SECTOR) | \
846 (start_sector & FLASH_SLIB_START_SECTOR);
847 /* configure slib, set pwd and range */
848 FLASH->slib_set_pwd = pwd;
849 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
850 if(status == FLASH_OPERATE_DONE)
851 {
852 FLASH->slib_set_range = slib_range;
853 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
854 }
855
856 return status;
857}
858
864 error_status flash_slib_disable(uint32_t pwd)
865{
866 flash_status_type status = FLASH_OPERATE_DONE;
867 /* write password to disable slib */
868 FLASH->slib_pwd_clr = pwd;
869
870 status = flash_operation_wait_for(ERASE_TIMEOUT);
871 if(status == FLASH_OPERATE_DONE)
872 {
873 if(FLASH->slib_misc_sts_bit.slib_pwd_ok)
874 return SUCCESS;
875 else
876 return ERROR;
877 }
878 return ERROR;
879}
880
886uint32_t flash_slib_remaining_count_get(void)
887{
888 return (uint32_t)FLASH->slib_misc_sts_bit.slib_rcnt;
889}
890
896 flag_status flash_slib_state_get(void)
897{
898 if(FLASH->slib_sts0_bit.slib_enf)
899 return SET;
900 else
901 return RESET;
902}
903
909uint16_t flash_slib_start_sector_get(void)
910{
911 return (uint16_t)FLASH->slib_sts1_bit.slib_ss;
912}
913
919uint16_t flash_slib_datastart_sector_get(void)
920{
921 return (uint16_t)FLASH->slib_sts1_bit.slib_dat_ss;
922}
923
929uint16_t flash_slib_end_sector_get(void)
930{
931 return (uint16_t)FLASH->slib_sts1_bit.slib_es;
932}
933
940uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
941{
942 FLASH->crc_ctrl_bit.crc_ss = start_sector;
943 FLASH->crc_ctrl_bit.crc_sn = sector_cnt;
944 FLASH->crc_ctrl_bit.crc_strt = TRUE;
945 flash_operation_wait_for(OPERATION_TIMEOUT);
946 return FLASH->crc_chkr;
947}
948
953#endif
954
UNUSED
#define UNUSED(x)
Definition: at32f413_def.h:63
error_status
error_status
error status
Definition: at32f413.h:301
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
flash_spim_model_type
flash_spim_model_type
flash spim model type
Definition: at32f413_flash.h:169
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:157
FLASH_OPERATE_BUSY
@ FLASH_OPERATE_BUSY
Definition: at32f413_flash.h:158
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:161
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f413_flash.h:162
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f413_flash.h:159
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f413_flash.h:160
FLASH_ERR_INT
#define FLASH_ERR_INT
Definition: at32f413_flash.h:94
FLASH_SPIM_ERR_INT
#define FLASH_SPIM_ERR_INT
Definition: at32f413_flash.h:96
FLASH_SPIM_ODF_INT
#define FLASH_SPIM_ODF_INT
Definition: at32f413_flash.h:97
FLASH_ODF_INT
#define FLASH_ODF_INT
Definition: at32f413_flash.h:95
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f413_flash.c:896
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f413_flash.c:829
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f413_flash.c:657
flash_slib_remaining_count_get
uint32_t flash_slib_remaining_count_get(void)
get remaining count of slib(range: 256~0).
Definition: at32f413_flash.c:886
flash_slib_disable
error_status flash_slib_disable(uint32_t pwd)
disable slib when slib enabled.
Definition: at32f413_flash.c:864
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:450
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f413_flash.c:512
flash_spim_lock
void flash_spim_lock(void)
lock the flash spim controller.
Definition: at32f413_flash.c:259
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:489
flash_spim_dummy_read
void flash_spim_dummy_read(void)
operate the flash spim dummy read.
Definition: at32f413_flash.c:769
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:238
flash_spim_mass_program
flash_status_type flash_spim_mass_program(uint32_t address, uint8_t *buf, uint32_t cnt)
mass program for flash spim.
Definition: at32f413_flash.c:784
flash_operation_status_get
flash_status_type flash_operation_status_get(void)
return the flash operation status.
Definition: at32f413_flash.c:120
flash_epp_set
flash_status_type flash_epp_set(uint32_t *sector_bits)
config erase/program protection for the desired sectors.
Definition: at32f413_flash.c:550
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:744
flash_ssb_set
flash_status_type flash_ssb_set(uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.
Definition: at32f413_flash.c:681
flash_crc_calibrate
uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block.
Definition: at32f413_flash.c:940
flash_spim_operation_wait_for
flash_status_type flash_spim_operation_wait_for(uint32_t time_out)
wait for flash spim operation complete or timeout.
Definition: at32f413_flash.c:203
flash_slib_start_sector_get
uint16_t flash_slib_start_sector_get(void)
get the start sector of slib.
Definition: at32f413_flash.c:909
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:727
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f413_flash.c:615
flash_slib_end_sector_get
uint16_t flash_slib_end_sector_get(void)
get the end sector of slib.
Definition: at32f413_flash.c:929
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_slib_datastart_sector_get
uint16_t flash_slib_datastart_sector_get(void)
get the data start sector of slib.
Definition: at32f413_flash.c:919
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:759
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:57
flash_spim_operation_status_get
flash_status_type flash_spim_operation_status_get(void)
return the flash spim operation status.
Definition: at32f413_flash.c:149
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f413_flash.c:361
flash_internal_all_erase
flash_status_type flash_internal_all_erase(void)
erase flash all internal sectors.
Definition: at32f413_flash.c:311
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f413_flash.c:178
flash_ssb_status_get
uint8_t flash_ssb_status_get(void)
return the flash system setting byte status.
Definition: at32f413_flash.c:709
flash_epp_status_get
void flash_epp_status_get(uint32_t *sector_bits)
return the flash erase/program protection status.
Definition: at32f413_flash.c:600
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:96
flash_spim_all_erase
flash_status_type flash_spim_all_erase(void)
erase flash spim sectors.
Definition: at32f413_flash.c:334
FLASH_SLIB_END_SECTOR
#define FLASH_SLIB_END_SECTOR
Definition: at32f413_flash.h:110
FLASH_SLIB_DATA_START_SECTOR
#define FLASH_SLIB_DATA_START_SECTOR
Definition: at32f413_flash.h:109
FLASH_SLIB_START_SECTOR
#define FLASH_SLIB_START_SECTOR
Definition: at32f413_flash.h:108
FLASH_SPIM_START_ADDR
#define FLASH_SPIM_START_ADDR
Definition: at32f413_flash.h:64
PROGRAMMING_TIMEOUT
#define PROGRAMMING_TIMEOUT
Definition: at32f413_flash.h:140
SPIM_ERASE_TIMEOUT
#define SPIM_ERASE_TIMEOUT
Definition: at32f413_flash.h:141
OPERATION_TIMEOUT
#define OPERATION_TIMEOUT
Definition: at32f413_flash.h:143
ERASE_TIMEOUT
#define ERASE_TIMEOUT
Definition: at32f413_flash.h:139
SPIM_PROGRAMMING_TIMEOUT
#define SPIM_PROGRAMMING_TIMEOUT
Definition: at32f413_flash.h:142
FAP_RELIEVE_KEY
#define FAP_RELIEVE_KEY
Definition: at32f413_flash.h:53
FLASH_UNLOCK_KEY2
#define FLASH_UNLOCK_KEY2
Definition: at32f413_flash.h:52
FLASH_UNLOCK_KEY1
#define FLASH_UNLOCK_KEY1
Definition: at32f413_flash.h:51
SLIB_UNLOCK_KEY
#define SLIB_UNLOCK_KEY
Definition: at32f413_flash.h:54
USD
#define USD
Definition: at32f413_flash.h:563
FLASH
#define FLASH
Definition: at32f413_flash.h:562
USD_BASE
#define USD_BASE
Definition: at32f413.h:330
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_flash.h Source File

  • libraries
  • drivers
  • inc
at32f413_flash.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_FLASH_H
27#define __AT32F413_FLASH_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
37
51#define FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
52#define FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
53#define FAP_RELIEVE_KEY ((uint16_t)0x00A5)
54#define SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)
64#define FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)
75#define FLASH_OBF_FLAG ((uint32_t)0x00000001)
76#define FLASH_ODF_FLAG ((uint32_t)0x00000020)
77#define FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)
78#define FLASH_EPPERR_FLAG ((uint32_t)0x00000010)
79#define FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)
80#define FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)
81#define FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)
82#define FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)
83#define FLASH_USDERR_FLAG ((uint32_t)0x40000001)
94#define FLASH_ERR_INT ((uint32_t)0x00000001)
95#define FLASH_ODF_INT ((uint32_t)0x00000002)
96#define FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)
97#define FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)
108#define FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)
109#define FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)
110#define FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)
121#define USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
122#define USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
124#define USD_DEPSLP_NO_RST ((uint16_t)0x0002)
125#define USD_DEPSLP_RST ((uint16_t)0x0000)
127#define USD_STDBY_NO_RST ((uint16_t)0x0004)
128#define USD_STDBY_RST ((uint16_t)0x0000)
139#define ERASE_TIMEOUT ((uint32_t)0x40000000)
140#define PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
141#define SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)
142#define SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
143#define OPERATION_TIMEOUT ((uint32_t)0x10000000)
156typedef enum
157{
158 FLASH_OPERATE_BUSY = 0x00,
159 FLASH_PROGRAM_ERROR = 0x01,
160 FLASH_EPP_ERROR = 0x02,
161 FLASH_OPERATE_DONE = 0x03,
162 FLASH_OPERATE_TIMEOUT = 0x04
163} flash_status_type;
164
168typedef enum
169{
170 FLASH_SPIM_MODEL1 = 0x01,
171 FLASH_SPIM_MODEL2 = 0x02,
172} flash_spim_model_type;
173
177typedef struct
178{
182 union
183 {
184 __IO uint32_t psr;
185 struct
186 {
187 __IO uint32_t reserved1 : 32; /* [31:0] */
188 } psr_bit;
189 };
190
194 union
195 {
196 __IO uint32_t unlock;
197 struct
198 {
199 __IO uint32_t ukval : 32;/* [31:0] */
200 } unlock_bit;
201 };
202
206 union
207 {
208 __IO uint32_t usd_unlock;
209 struct
210 {
211 __IO uint32_t usd_ukval : 32;/* [31:0] */
212 } usd_unlock_bit;
213 };
214
218 union
219 {
220 __IO uint32_t sts;
221 struct
222 {
223 __IO uint32_t obf : 1; /* [0] */
224 __IO uint32_t reserved1 : 1; /* [1] */
225 __IO uint32_t prgmerr : 1; /* [2] */
226 __IO uint32_t reserved2 : 1; /* [3] */
227 __IO uint32_t epperr : 1; /* [4] */
228 __IO uint32_t odf : 1; /* [5] */
229 __IO uint32_t reserved3 : 26;/* [31:6] */
230 } sts_bit;
231 };
232
236 union
237 {
238 __IO uint32_t ctrl;
239 struct
240 {
241 __IO uint32_t fprgm : 1; /* [0] */
242 __IO uint32_t secers : 1; /* [1] */
243 __IO uint32_t bankers : 1; /* [2] */
244 __IO uint32_t reserved1 : 1; /* [3] */
245 __IO uint32_t usdprgm : 1; /* [4] */
246 __IO uint32_t usders : 1; /* [5] */
247 __IO uint32_t erstr : 1; /* [6] */
248 __IO uint32_t oplk : 1; /* [7] */
249 __IO uint32_t reserved2 : 1; /* [8] */
250 __IO uint32_t usdulks : 1; /* [9] */
251 __IO uint32_t errie : 1; /* [10] */
252 __IO uint32_t reserved3 : 1; /* [11] */
253 __IO uint32_t odfie : 1; /* [12] */
254 __IO uint32_t reserved4 : 19;/* [31:13] */
255 } ctrl_bit;
256 };
257
261 union
262 {
263 __IO uint32_t addr;
264 struct
265 {
266 __IO uint32_t fa : 32;/* [31:0] */
267 } addr_bit;
268 };
269
273 __IO uint32_t reserved1;
274
278 union
279 {
280 __IO uint32_t usd;
281 struct
282 {
283 __IO uint32_t usderr : 1; /* [0] */
284 __IO uint32_t fap : 1; /* [1] */
285 __IO uint32_t wdt_ato_en : 1; /* [2] */
286 __IO uint32_t depslp_rst : 1; /* [3] */
287 __IO uint32_t stdby_rst : 1; /* [4] */
288 __IO uint32_t reserved1 : 5; /* [9:5] */
289 __IO uint32_t user_d0 : 8; /* [17:10] */
290 __IO uint32_t user_d1 : 8; /* [25:18] */
291 __IO uint32_t reserved2 : 6; /* [31:26] */
292 } usd_bit;
293 };
294
298 union
299 {
300 __IO uint32_t epps;
301 struct
302 {
303 __IO uint32_t epps : 32;/* [31:0] */
304 } epps_bit;
305 };
306
310 __IO uint32_t reserved2[24];
311
315 union
316 {
317 __IO uint32_t unlock3;
318 struct
319 {
320 __IO uint32_t ukval : 32;/* [31:0] */
321 } unlock3_bit;
322 };
323
327 union
328 {
329 __IO uint32_t select;
330 struct
331 {
332 __IO uint32_t select : 32;/* [31:0] */
333 } select_bit;
334 };
335
339 union
340 {
341 __IO uint32_t sts3;
342 struct
343 {
344 __IO uint32_t obf : 1; /* [0] */
345 __IO uint32_t reserved1 : 1; /* [1] */
346 __IO uint32_t prgmerr : 1; /* [2] */
347 __IO uint32_t reserved2 : 1; /* [3] */
348 __IO uint32_t epperr : 1; /* [4] */
349 __IO uint32_t odf : 1; /* [5] */
350 __IO uint32_t reserved3 : 26;/* [31:6] */
351 } sts3_bit;
352 };
353
357 union
358 {
359 __IO uint32_t ctrl3;
360 struct
361 {
362 __IO uint32_t fprgm : 1; /* [0] */
363 __IO uint32_t secers : 1; /* [1] */
364 __IO uint32_t chpers : 1; /* [2] */
365 __IO uint32_t reserved1 : 3; /* [5:3] */
366 __IO uint32_t erstr : 1; /* [6] */
367 __IO uint32_t oplk : 1; /* [7] */
368 __IO uint32_t reserved2 : 2; /* [9:8] */
369 __IO uint32_t errie : 1; /* [10] */
370 __IO uint32_t reserved3 : 1; /* [11] */
371 __IO uint32_t odfie : 1; /* [12] */
372 __IO uint32_t reserved4 : 19;/* [31:13] */
373 } ctrl3_bit;
374 };
375
379 union
380 {
381 __IO uint32_t addr3;
382 struct
383 {
384 __IO uint32_t fa : 32;/* [31:0] */
385 } addr3_bit;
386 };
387
391 union
392 {
393 __IO uint32_t da;
394 struct
395 {
396 __IO uint32_t fda : 32;/* [31:0] */
397 } da_bit;
398 };
399
403 __IO uint32_t reserved5[12];
404
408 union
409 {
410 __IO uint32_t slib_sts0;
411 struct
412 {
413 __IO uint32_t reserved1 : 3; /* [2:0] */
414 __IO uint32_t slib_enf : 1; /* [3] */
415 __IO uint32_t reserved2 : 28;/* [31:4] */
416 } slib_sts0_bit;
417 };
418
422 union
423 {
424 __IO uint32_t slib_sts1;
425 struct
426 {
427 __IO uint32_t slib_ss : 11;/* [10:0] */
428 __IO uint32_t slib_dat_ss : 11;/* [21:11] */
429 __IO uint32_t slib_es : 10;/* [31:22] */
430 } slib_sts1_bit;
431 };
432
436 union
437 {
438 __IO uint32_t slib_pwd_clr;
439 struct
440 {
441 __IO uint32_t slib_pclr_val : 32;/* [31:0] */
442 } slib_pwd_clr_bit;
443 };
444
448 union
449 {
450 __IO uint32_t slib_misc_sts;
451 struct
452 {
453 __IO uint32_t slib_pwd_err : 1; /* [0] */
454 __IO uint32_t slib_pwd_ok : 1; /* [1] */
455 __IO uint32_t slib_ulkf : 1; /* [2] */
456 __IO uint32_t reserved1 : 13;/* [15:3] */
457 __IO uint32_t slib_rcnt : 9; /* [24:16] */
458 __IO uint32_t reserved2 : 7; /* [31:25] */
459 } slib_misc_sts_bit;
460 };
461
465 union
466 {
467 __IO uint32_t slib_set_pwd;
468 struct
469 {
470 __IO uint32_t slib_pset_val : 32;/* [31:0] */
471 } slib_set_pwd_bit;
472 };
473
477 union
478 {
479 __IO uint32_t slib_set_range;
480 struct
481 {
482 __IO uint32_t slib_ss_set : 11;/* [10:0] */
483 __IO uint32_t slib_dss_set : 11;/* [21:11] */
484 __IO uint32_t slib_es_set : 10;/* [31:22] */
485 } slib_set_range_bit;
486 };
487
491 __IO uint32_t reserved6[3];
492
496 union
497 {
498 __IO uint32_t slib_unlock;
499 struct
500 {
501 __IO uint32_t slib_ukval : 32;/* [31:0] */
502 } slib_unlock_bit;
503 };
504
508 union
509 {
510 __IO uint32_t crc_ctrl;
511 struct
512 {
513 __IO uint32_t crc_ss : 12;/* [11:0] */
514 __IO uint32_t crc_sn : 12;/* [23:12] */
515 __IO uint32_t reserved1 : 7; /* [30:24] */
516 __IO uint32_t crc_strt : 1; /* [31] */
517 } crc_ctrl_bit;
518 };
519
523 union
524 {
525 __IO uint32_t crc_chkr;
526 struct
527 {
528 __IO uint32_t crc_chkr : 32;/* [31:0] */
529 } crc_chkr_bit;
530 };
531
532} flash_type;
533
537typedef struct
538{
539 __IO uint16_t fap;
540 __IO uint16_t ssb;
541 __IO uint16_t data0;
542 __IO uint16_t data1;
543 __IO uint16_t epp0;
544 __IO uint16_t epp1;
545 __IO uint16_t epp2;
546 __IO uint16_t epp3;
547 __IO uint16_t eopb0;
548 __IO uint16_t reserved;
549 __IO uint16_t data2;
550 __IO uint16_t data3;
551 __IO uint16_t data4;
552 __IO uint16_t data5;
553 __IO uint16_t data6;
554 __IO uint16_t data7;
555 __IO uint16_t ext_flash_key[8];
556} usd_type;
557
562#define FLASH ((flash_type *) FLASH_REG_BASE)
563#define USD ((usd_type *) USD_BASE)
564
569 flag_status flash_flag_get(uint32_t flash_flag);
570void flash_flag_clear(uint32_t flash_flag);
571 flash_status_type flash_operation_status_get(void);
572 flash_status_type flash_spim_operation_status_get(void);
573 flash_status_type flash_operation_wait_for(uint32_t time_out);
574 flash_status_type flash_spim_operation_wait_for(uint32_t time_out);
575void flash_unlock(void);
576void flash_spim_unlock(void);
577void flash_lock(void);
578void flash_spim_lock(void);
579 flash_status_type flash_sector_erase(uint32_t sector_address);
580 flash_status_type flash_internal_all_erase(void);
581 flash_status_type flash_spim_all_erase(void);
582 flash_status_type flash_user_system_data_erase(void);
583 flash_status_type flash_word_program(uint32_t address, uint32_t data);
584 flash_status_type flash_halfword_program(uint32_t address, uint16_t data);
585 flash_status_type flash_byte_program(uint32_t address, uint8_t data);
586 flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data);
587 flash_status_type flash_epp_set(uint32_t *sector_bits);
588void flash_epp_status_get(uint32_t *sector_bits);
589 flash_status_type flash_fap_enable(confirm_state new_state);
590 flag_status flash_fap_status_get(void);
591 flash_status_type flash_ssb_set(uint8_t usd_ssb);
592uint8_t flash_ssb_status_get(void);
593void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state);
594void flash_spim_model_select(flash_spim_model_type mode);
595void flash_spim_encryption_range_set(uint32_t decode_address);
596void flash_spim_dummy_read(void);
597 flash_status_type flash_spim_mass_program(uint32_t address, uint8_t *buf, uint32_t cnt);
598 flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector);
599 error_status flash_slib_disable(uint32_t pwd);
600uint32_t flash_slib_remaining_count_get(void);
601 flag_status flash_slib_state_get(void);
602uint16_t flash_slib_start_sector_get(void);
603uint16_t flash_slib_datastart_sector_get(void);
604uint16_t flash_slib_end_sector_get(void);
605uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt);
606
619#ifdef __cplusplus
620}
621#endif
622
623#endif
at32f413.h
at32f413 header file
error_status
error_status
error status
Definition: at32f413.h:301
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f413_flash.c:896
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f413_flash.c:829
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f413_flash.c:657
flash_slib_remaining_count_get
uint32_t flash_slib_remaining_count_get(void)
get remaining count of slib(range: 256~0).
Definition: at32f413_flash.c:886
flash_slib_disable
error_status flash_slib_disable(uint32_t pwd)
disable slib when slib enabled.
Definition: at32f413_flash.c:864
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:450
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f413_flash.c:512
flash_spim_lock
void flash_spim_lock(void)
lock the flash spim controller.
Definition: at32f413_flash.c:259
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:489
flash_spim_dummy_read
void flash_spim_dummy_read(void)
operate the flash spim dummy read.
Definition: at32f413_flash.c:769
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:238
flash_spim_mass_program
flash_status_type flash_spim_mass_program(uint32_t address, uint8_t *buf, uint32_t cnt)
mass program for flash spim.
Definition: at32f413_flash.c:784
flash_operation_status_get
flash_status_type flash_operation_status_get(void)
return the flash operation status.
Definition: at32f413_flash.c:120
flash_epp_set
flash_status_type flash_epp_set(uint32_t *sector_bits)
config erase/program protection for the desired sectors.
Definition: at32f413_flash.c:550
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:744
flash_ssb_set
flash_status_type flash_ssb_set(uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.
Definition: at32f413_flash.c:681
flash_crc_calibrate
uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block.
Definition: at32f413_flash.c:940
flash_spim_operation_wait_for
flash_status_type flash_spim_operation_wait_for(uint32_t time_out)
wait for flash spim operation complete or timeout.
Definition: at32f413_flash.c:203
flash_slib_start_sector_get
uint16_t flash_slib_start_sector_get(void)
get the start sector of slib.
Definition: at32f413_flash.c:909
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:727
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f413_flash.c:615
flash_slib_end_sector_get
uint16_t flash_slib_end_sector_get(void)
get the end sector of slib.
Definition: at32f413_flash.c:929
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_slib_datastart_sector_get
uint16_t flash_slib_datastart_sector_get(void)
get the data start sector of slib.
Definition: at32f413_flash.c:919
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:759
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:57
flash_spim_operation_status_get
flash_status_type flash_spim_operation_status_get(void)
return the flash spim operation status.
Definition: at32f413_flash.c:149
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f413_flash.c:361
flash_internal_all_erase
flash_status_type flash_internal_all_erase(void)
erase flash all internal sectors.
Definition: at32f413_flash.c:311
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f413_flash.c:178
flash_ssb_status_get
uint8_t flash_ssb_status_get(void)
return the flash system setting byte status.
Definition: at32f413_flash.c:709
flash_epp_status_get
void flash_epp_status_get(uint32_t *sector_bits)
return the flash erase/program protection status.
Definition: at32f413_flash.c:600
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:96
flash_spim_all_erase
flash_status_type flash_spim_all_erase(void)
erase flash spim sectors.
Definition: at32f413_flash.c:334
flash_spim_model_type
flash_spim_model_type
flash spim model type
Definition: at32f413_flash.h:169
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:157
FLASH_SPIM_MODEL1
@ FLASH_SPIM_MODEL1
Definition: at32f413_flash.h:170
FLASH_SPIM_MODEL2
@ FLASH_SPIM_MODEL2
Definition: at32f413_flash.h:171
FLASH_OPERATE_BUSY
@ FLASH_OPERATE_BUSY
Definition: at32f413_flash.h:158
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:161
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f413_flash.h:162
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f413_flash.h:159
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f413_flash.h:160
flash_type
type define flash register all
Definition: at32f413_flash.h:178
flash_type::secers
__IO uint32_t secers
Definition: at32f413_flash.h:242
flash_type::unlock
__IO uint32_t unlock
Definition: at32f413_flash.h:196
flash_type::reserved2
__IO uint32_t reserved2
flash reserved2 register, offset:0x80~0x24
Definition: at32f413_flash.h:226
flash_type::crc_sn
__IO uint32_t crc_sn
Definition: at32f413_flash.h:514
flash_type::psr
__IO uint32_t psr
Definition: at32f413_flash.h:184
flash_type::user_d0
__IO uint32_t user_d0
Definition: at32f413_flash.h:289
flash_type::unlock3
__IO uint32_t unlock3
Definition: at32f413_flash.h:317
flash_type::slib_set_pwd
__IO uint32_t slib_set_pwd
Definition: at32f413_flash.h:467
flash_type::slib_pwd_err
__IO uint32_t slib_pwd_err
Definition: at32f413_flash.h:453
flash_type::ukval
__IO uint32_t ukval
Definition: at32f413_flash.h:199
flash_type::slib_ukval
__IO uint32_t slib_ukval
Definition: at32f413_flash.h:501
flash_type::bankers
__IO uint32_t bankers
Definition: at32f413_flash.h:243
flash_type::slib_set_range
__IO uint32_t slib_set_range
Definition: at32f413_flash.h:479
flash_type::usd_ukval
__IO uint32_t usd_ukval
Definition: at32f413_flash.h:211
flash_type::select
__IO uint32_t select
Definition: at32f413_flash.h:329
flash_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_flash.h:238
flash_type::slib_rcnt
__IO uint32_t slib_rcnt
Definition: at32f413_flash.h:457
flash_type::stdby_rst
__IO uint32_t stdby_rst
Definition: at32f413_flash.h:287
flash_type::crc_strt
__IO uint32_t crc_strt
Definition: at32f413_flash.h:516
flash_type::slib_dat_ss
__IO uint32_t slib_dat_ss
Definition: at32f413_flash.h:428
flash_type::epps
__IO uint32_t epps
Definition: at32f413_flash.h:300
flash_type::fprgm
__IO uint32_t fprgm
Definition: at32f413_flash.h:241
flash_type::reserved1
__IO uint32_t reserved1
flash reserved1 register, offset:0x18
Definition: at32f413_flash.h:187
flash_type::slib_sts1
__IO uint32_t slib_sts1
Definition: at32f413_flash.h:424
flash_type::erstr
__IO uint32_t erstr
Definition: at32f413_flash.h:247
flash_type::usderr
__IO uint32_t usderr
Definition: at32f413_flash.h:283
flash_type::crc_ss
__IO uint32_t crc_ss
Definition: at32f413_flash.h:513
flash_type::crc_chkr
__IO uint32_t crc_chkr
Definition: at32f413_flash.h:525
flash_type::slib_misc_sts
__IO uint32_t slib_misc_sts
Definition: at32f413_flash.h:450
flash_type::usdulks
__IO uint32_t usdulks
Definition: at32f413_flash.h:250
flash_type::slib_pclr_val
__IO uint32_t slib_pclr_val
Definition: at32f413_flash.h:441
flash_type::slib_ulkf
__IO uint32_t slib_ulkf
Definition: at32f413_flash.h:455
flash_type::epperr
__IO uint32_t epperr
Definition: at32f413_flash.h:227
flash_type::ctrl3
__IO uint32_t ctrl3
Definition: at32f413_flash.h:359
flash_type::odfie
__IO uint32_t odfie
Definition: at32f413_flash.h:253
flash_type::fda
__IO uint32_t fda
Definition: at32f413_flash.h:396
flash_type::slib_ss
__IO uint32_t slib_ss
Definition: at32f413_flash.h:427
flash_type::da
__IO uint32_t da
Definition: at32f413_flash.h:393
flash_type::fa
__IO uint32_t fa
Definition: at32f413_flash.h:266
flash_type::slib_es
__IO uint32_t slib_es
Definition: at32f413_flash.h:429
flash_type::slib_ss_set
__IO uint32_t slib_ss_set
Definition: at32f413_flash.h:482
flash_type::prgmerr
__IO uint32_t prgmerr
Definition: at32f413_flash.h:225
flash_type::slib_unlock
__IO uint32_t slib_unlock
Definition: at32f413_flash.h:498
flash_type::errie
__IO uint32_t errie
Definition: at32f413_flash.h:251
flash_type::user_d1
__IO uint32_t user_d1
Definition: at32f413_flash.h:290
flash_type::chpers
__IO uint32_t chpers
Definition: at32f413_flash.h:364
flash_type::usd
__IO uint32_t usd
Definition: at32f413_flash.h:280
flash_type::depslp_rst
__IO uint32_t depslp_rst
Definition: at32f413_flash.h:286
flash_type::slib_pwd_clr
__IO uint32_t slib_pwd_clr
Definition: at32f413_flash.h:438
flash_type::usd_unlock
__IO uint32_t usd_unlock
Definition: at32f413_flash.h:208
flash_type::wdt_ato_en
__IO uint32_t wdt_ato_en
Definition: at32f413_flash.h:285
flash_type::usdprgm
__IO uint32_t usdprgm
Definition: at32f413_flash.h:245
flash_type::slib_pwd_ok
__IO uint32_t slib_pwd_ok
Definition: at32f413_flash.h:454
flash_type::sts3
__IO uint32_t sts3
Definition: at32f413_flash.h:341
flash_type::slib_es_set
__IO uint32_t slib_es_set
Definition: at32f413_flash.h:484
flash_type::usders
__IO uint32_t usders
Definition: at32f413_flash.h:246
flash_type::oplk
__IO uint32_t oplk
Definition: at32f413_flash.h:248
flash_type::addr
__IO uint32_t addr
Definition: at32f413_flash.h:263
flash_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_flash.h:254
flash_type::slib_dss_set
__IO uint32_t slib_dss_set
Definition: at32f413_flash.h:483
flash_type::slib_sts0
__IO uint32_t slib_sts0
Definition: at32f413_flash.h:410
flash_type::odf
__IO uint32_t odf
Definition: at32f413_flash.h:228
flash_type::addr3
__IO uint32_t addr3
Definition: at32f413_flash.h:381
flash_type::fap
__IO uint32_t fap
Definition: at32f413_flash.h:284
flash_type::crc_ctrl
__IO uint32_t crc_ctrl
Definition: at32f413_flash.h:510
flash_type::sts
__IO uint32_t sts
Definition: at32f413_flash.h:220
flash_type::slib_pset_val
__IO uint32_t slib_pset_val
Definition: at32f413_flash.h:470
flash_type::slib_enf
__IO uint32_t slib_enf
Definition: at32f413_flash.h:414
flash_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_flash.h:229
flash_type::obf
__IO uint32_t obf
Definition: at32f413_flash.h:223
usd_type
user system data
Definition: at32f413_flash.h:538
usd_type::eopb0
__IO uint16_t eopb0
Definition: at32f413_flash.h:547
usd_type::epp2
__IO uint16_t epp2
Definition: at32f413_flash.h:545
usd_type::data7
__IO uint16_t data7
Definition: at32f413_flash.h:554
usd_type::reserved
__IO uint16_t reserved
Definition: at32f413_flash.h:548
usd_type::epp0
__IO uint16_t epp0
Definition: at32f413_flash.h:543
usd_type::data3
__IO uint16_t data3
Definition: at32f413_flash.h:550
usd_type::epp3
__IO uint16_t epp3
Definition: at32f413_flash.h:546
usd_type::data6
__IO uint16_t data6
Definition: at32f413_flash.h:553
usd_type::data2
__IO uint16_t data2
Definition: at32f413_flash.h:549
usd_type::data1
__IO uint16_t data1
Definition: at32f413_flash.h:542
usd_type::ssb
__IO uint16_t ssb
Definition: at32f413_flash.h:540
usd_type::fap
__IO uint16_t fap
Definition: at32f413_flash.h:539
usd_type::epp1
__IO uint16_t epp1
Definition: at32f413_flash.h:544
usd_type::data0
__IO uint16_t data0
Definition: at32f413_flash.h:541
usd_type::data4
__IO uint16_t data4
Definition: at32f413_flash.h:551
usd_type::data5
__IO uint16_t data5
Definition: at32f413_flash.h:552


AT32F413 Firmwary Library: at32f413_gpio.c Source File

  • libraries
  • drivers
  • src
at32f413_gpio.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef GPIO_MODULE_ENABLED
37
49void gpio_reset(gpio_type *gpio_x)
50{
51 if(gpio_x == GPIOA)
52 {
53 crm_periph_reset(CRM_GPIOA_PERIPH_RESET, TRUE);
54 crm_periph_reset(CRM_GPIOA_PERIPH_RESET, FALSE);
55 }
56 else if(gpio_x == GPIOB)
57 {
58 crm_periph_reset(CRM_GPIOB_PERIPH_RESET, TRUE);
59 crm_periph_reset(CRM_GPIOB_PERIPH_RESET, FALSE);
60 }
61 else if(gpio_x == GPIOC)
62 {
63 crm_periph_reset(CRM_GPIOC_PERIPH_RESET, TRUE);
64 crm_periph_reset(CRM_GPIOC_PERIPH_RESET, FALSE);
65 }
66 else if(gpio_x == GPIOD)
67 {
68 crm_periph_reset(CRM_GPIOD_PERIPH_RESET, TRUE);
69 crm_periph_reset(CRM_GPIOD_PERIPH_RESET, FALSE);
70 }
71 else if(gpio_x == GPIOF)
72 {
73 crm_periph_reset(CRM_GPIOF_PERIPH_RESET, TRUE);
74 crm_periph_reset(CRM_GPIOF_PERIPH_RESET, FALSE);
75 }
76}
77
84void gpio_iomux_reset(void)
85{
86 crm_periph_reset(CRM_IOMUX_PERIPH_RESET, TRUE);
87 crm_periph_reset(CRM_IOMUX_PERIPH_RESET, FALSE);
88}
89
98void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
99{
100 uint32_t temp;
101 uint16_t pinx_value, pin_index;
102
103 pin_index = (uint16_t)gpio_init_struct->gpio_pins;
104
105 /* pinx_value indecate pin grounp bit[3:0] from modey[1:0] confy[1:0] */
106
107 /* pin input analog config */
108 if(gpio_init_struct->gpio_mode == GPIO_MODE_ANALOG)
109 {
110 pinx_value = 0x00;
111 }
112 /* pin input config */
113 else if(gpio_init_struct->gpio_mode == GPIO_MODE_INPUT)
114 {
115 pinx_value = gpio_init_struct->gpio_pull & 0x0F;
116
117 if(gpio_init_struct->gpio_pull == GPIO_PULL_UP)
118 {
119 gpio_x->scr = pin_index;
120 }
121 else if(gpio_init_struct->gpio_pull == GPIO_PULL_DOWN)
122 {
123 gpio_x->clr = pin_index;
124 }
125 }
126 else
127 {
128 pinx_value = (gpio_init_struct->gpio_mode & 0x08) | (gpio_init_struct->gpio_out_type & 0x04) | \
129 (gpio_init_struct->gpio_drive_strength & 0x03);
130 }
131
132 /* pin 0~7 config */
133 if(((uint32_t)pin_index & ((uint32_t)0x00FF)) != 0x00)
134 {
135 for(temp = 0; temp < 0x08; temp++)
136 {
137 if((1 << temp) & pin_index)
138 {
139 gpio_x->cfglr &= (uint32_t)~(0x0F << (temp * 4));
140 gpio_x->cfglr |= (uint32_t)(pinx_value << (temp * 4));
141 }
142 }
143 }
144
145 /* pin 8~15 config */
146 if(pin_index > 0x00ff)
147 {
148 pin_index = pin_index >> 8;
149
150 for(temp = 0; temp < 0x8; temp++)
151 {
152 if((1 << temp) & pin_index)
153 {
154 gpio_x->cfghr &= (uint32_t)~(0xf << (temp * 4));
155 gpio_x->cfghr |= (uint32_t)(pinx_value << (temp * 4));
156 }
157 }
158 }
159}
160
166void gpio_default_para_init(gpio_init_type *gpio_init_struct)
167{
168 /* reset gpio init structure parameters values */
169 gpio_init_struct->gpio_pins = GPIO_PINS_ALL;
170 gpio_init_struct->gpio_mode = GPIO_MODE_INPUT;
171 gpio_init_struct->gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
172 gpio_init_struct->gpio_pull = GPIO_PULL_NONE;
173 gpio_init_struct->gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
174}
175
201 flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
202{
203 flag_status status = RESET;
204
205 if(pins != (pins & gpio_x->idt))
206 {
207 status = RESET;
208 }
209 else
210 {
211 status = SET;
212 }
213
214 return status;
215}
216
224uint16_t gpio_input_data_read(gpio_type *gpio_x)
225{
226 return ((uint16_t)(gpio_x->idt));
227}
228
254 flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
255{
256 flag_status status = RESET;
257
258 if((gpio_x->odt & pins) != RESET)
259 {
260 status = SET;
261 }
262 else
263 {
264 status = RESET;
265 }
266
267 return status;
268}
269
277uint16_t gpio_output_data_read(gpio_type *gpio_x)
278{
279 return ((uint16_t)(gpio_x->odt));
280}
281
308void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
309{
310 gpio_x->scr = pins;
311}
312
339void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
340{
341 gpio_x->clr = pins;
342}
343
371void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
372{
373 if(bit_state != FALSE)
374 {
375 gpio_x->scr = pins;
376 }
377 else
378 {
379 gpio_x->clr = pins;
380 }
381}
382
391void gpio_port_write(gpio_type *gpio_x, uint16_t port_value)
392{
393 gpio_x->odt = port_value;
394}
395
422void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
423{
424 uint32_t temp = 0x00010000;
425
426 temp |= pins;
427 /* set wpen bit */
428 gpio_x->wpr = temp;
429 /* reset wpen bit */
430 gpio_x->wpr = pins;
431 /* set wpen bit */
432 gpio_x->wpr = temp;
433 /* read wpen bit*/
434 temp = gpio_x->wpr;
435 /* read wpen bit*/
436 temp = gpio_x->wpr;
437}
438
469void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
470{
471 uint32_t tmpreg = 0x00;
472
473 tmpreg = IOMUX->evtout;
474
475 /* clear the port[6:4] and pin[3:0] bits */
476 tmpreg &= 0x80;
477 tmpreg |= (uint32_t)gpio_port_source << 0x04;
478 tmpreg |= gpio_pin_source;
479 IOMUX->evtout = tmpreg;
480}
481
488void gpio_event_output_enable(confirm_state new_state)
489{
490 IOMUX->evtout_bit.evoen = new_state;
491}
492
515void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
516{
517 uint32_t reg_addr, remap_mask;
518 uint8_t bit_offset, bit_num, bit_val;
519
520 /* get register address, bit offset, bit number and remap value */
521 reg_addr = IOMUX_BASE + (gpio_remap >> 24);
522 bit_offset = (gpio_remap >> 16) & 0xFF;
523 bit_num = (gpio_remap >> 8) & 0xFF;
524 bit_val = gpio_remap & 0xFF;
525
526 /* get remap mask value */
527 remap_mask = 0xFFFFFFFF << (32 - bit_num - bit_offset);
528 remap_mask = remap_mask >> (32 - bit_num - bit_offset);
529 remap_mask = remap_mask >> bit_offset;
530 remap_mask = remap_mask << bit_offset;
531
532 /* clear remap value */
533 *(uint32_t*)reg_addr &= ~remap_mask;
534
535 if(new_state != FALSE)
536 {
537 /* set remap value */
538 *(uint32_t*)reg_addr |= (uint32_t)(bit_val << bit_offset);
539 }
540}
541
571void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
572{
573 uint32_t tmp = 0x00;
574 tmp = ((uint32_t)0x0F) << (0x04 * (gpio_pin_source & (uint8_t)0x03));
575
576 switch (gpio_pin_source >> 0x02)
577 {
578 case 0:
579 IOMUX->exintc1 &= ~tmp;
580 IOMUX->exintc1 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
581 break;
582 case 1:
583 IOMUX->exintc2 &= ~tmp;
584 IOMUX->exintc2 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
585 break;
586 case 2:
587 IOMUX->exintc3 &= ~tmp;
588 IOMUX->exintc3 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
589 break;
590 case 3:
591 IOMUX->exintc4 &= ~tmp;
592 IOMUX->exintc4 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
593 break;
594 default:
595 break;
596 }
597}
598
603#endif
604
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
CRM_IOMUX_PERIPH_RESET
@ CRM_IOMUX_PERIPH_RESET
Definition: at32f413_crm.h:150
CRM_GPIOF_PERIPH_RESET
@ CRM_GPIOF_PERIPH_RESET
Definition: at32f413_crm.h:156
CRM_GPIOD_PERIPH_RESET
@ CRM_GPIOD_PERIPH_RESET
Definition: at32f413_crm.h:155
CRM_GPIOC_PERIPH_RESET
@ CRM_GPIOC_PERIPH_RESET
Definition: at32f413_crm.h:154
CRM_GPIOA_PERIPH_RESET
@ CRM_GPIOA_PERIPH_RESET
Definition: at32f413_crm.h:152
CRM_GPIOB_PERIPH_RESET
@ CRM_GPIOB_PERIPH_RESET
Definition: at32f413_crm.h:153
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
gpio_pins_source_type
gpio_pins_source_type
gpio pins source type
Definition: at32f413_gpio.h:251
gpio_port_source_type
gpio_port_source_type
gpio port source type
Definition: at32f413_gpio.h:274
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_ALL
#define GPIO_PINS_ALL
Definition: at32f413_gpio.h:65
gpio_iomux_reset
void gpio_iomux_reset(void)
reset the mux functions (remap, event control and exint configuration) registers to their default val...
Definition: at32f413_gpio.c:84
gpio_output_data_read
uint16_t gpio_output_data_read(gpio_type *gpio_x)
read the specified gpio ouput data port.
Definition: at32f413_gpio.c:277
gpio_event_output_config
void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output.
Definition: at32f413_gpio.c:469
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f413_gpio.c:254
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f413_gpio.c:371
gpio_event_output_enable
void gpio_event_output_enable(confirm_state new_state)
enable or disable the event output.
Definition: at32f413_gpio.c:488
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
gpio_input_data_read
uint16_t gpio_input_data_read(gpio_type *gpio_x)
read the specified gpio input data port.
Definition: at32f413_gpio.c:224
gpio_pin_wp_config
void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers.
Definition: at32f413_gpio.c:422
gpio_port_write
void gpio_port_write(gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port.
Definition: at32f413_gpio.c:391
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:201
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
gpio_reset
void gpio_reset(gpio_type *gpio_x)
reset the gpio register
Definition: at32f413_gpio.c:49
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
GPIOF
#define GPIOF
Definition: at32f413_gpio.h:750
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOD
#define GPIOD
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
IOMUX
#define IOMUX
Definition: at32f413_gpio.h:751
IOMUX_BASE
#define IOMUX_BASE
Definition: at32f413.h:361
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:298
gpio_type::scr
__IO uint32_t scr
Definition: at32f413_gpio.h:414
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:386
gpio_type::clr
__IO uint32_t clr
Definition: at32f413_gpio.h:457
gpio_type::cfghr
__IO uint32_t cfghr
Definition: at32f413_gpio.h:331
gpio_type::cfglr
__IO uint32_t cfglr
Definition: at32f413_gpio.h:304
gpio_type::idt
__IO uint32_t idt
Definition: at32f413_gpio.h:358
gpio_type::wpr
__IO uint32_t wpr
Definition: at32f413_gpio.h:485
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_gpio.h Source File

  • libraries
  • drivers
  • inc
at32f413_gpio.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_GPIO_H
27#define __AT32F413_GPIO_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
49#define GPIO_PINS_0 0x0001
50#define GPIO_PINS_1 0x0002
51#define GPIO_PINS_2 0x0004
52#define GPIO_PINS_3 0x0008
53#define GPIO_PINS_4 0x0010
54#define GPIO_PINS_5 0x0020
55#define GPIO_PINS_6 0x0040
56#define GPIO_PINS_7 0x0080
57#define GPIO_PINS_8 0x0100
58#define GPIO_PINS_9 0x0200
59#define GPIO_PINS_10 0x0400
60#define GPIO_PINS_11 0x0800
61#define GPIO_PINS_12 0x1000
62#define GPIO_PINS_13 0x2000
63#define GPIO_PINS_14 0x4000
64#define GPIO_PINS_15 0x8000
65#define GPIO_PINS_ALL 0xFFFF
71#define IOMUX_MAKE_VALUE(reg_offset, bit_addr ,bit_num, bit_val) \
72 (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))
73
79#define SPI1_MUX_01 SPI1_GMUX_0001
80#define I2C1_MUX I2C1_GMUX_0001
81#define USART1_MUX USART1_GMUX_0001
82#define USART3_MUX_01 USART3_GMUX_0001
83#define TMR1_MUX_01 TMR1_GMUX_0001
84#define TMR2_MUX_01 TMR2_GMUX_001
85#define TMR2_MUX_10 TMR2_GMUX_010
86#define TMR2_MUX_11 TMR2_GMUX_011
87#define TMR3_MUX_10 TMR3_GMUX_0010
88#define TMR3_MUX_11 TMR3_GMUX_0011
89#define CAN_MUX_10 CAN1_GMUX_0010
90#define PD01_MUX PD01_GMUX
91#define TMR5CH4_MUX TMR5CH4_GMUX
92#define ADC1_ETP_MUX ADC1_ETP_GMUX
93#define ADC1_ETO_MUX ADC1_ETO_GMUX
94#define ADC2_ETP_MUX ADC2_ETP_GMUX
95#define ADC2_ETO_MUX ADC2_ETO_GMUX
96#define SWJTAG_CONF_001 SWJTAG_GMUX_001
97#define SWJTAG_CONF_010 SWJTAG_GMUX_010
98#define SWJTAG_CONF_100 SWJTAG_GMUX_100
109#define EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000
120#define TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)
121#define TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)
122#define TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)
133#define TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)
134#define TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)
135#define TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)
136#define TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)
137#define TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)
138#define TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)
139#define TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)
140#define TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)
141#define TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)
152#define I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)
153#define I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)
154#define I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
155#define I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
156#define I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
157#define SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)
158#define SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)
169#define CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)
170#define CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)
171#define SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)
172#define SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)
173#define SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)
174#define SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)
175#define USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)
176#define USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)
177#define UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)
188#define EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)
189#define EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)
190#define ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)
191#define ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)
192#define ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)
193#define ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)
194#define SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)
195#define SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)
196#define SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)
197#define PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)
210typedef enum
211{
212 GPIO_MODE_INPUT = 0x00,
213 GPIO_MODE_OUTPUT = 0x10,
214 GPIO_MODE_MUX = 0x08,
215 GPIO_MODE_ANALOG = 0x03
216} gpio_mode_type;
217
221typedef enum
222{
223 GPIO_DRIVE_STRENGTH_STRONGER = 0x01,
224 GPIO_DRIVE_STRENGTH_MODERATE = 0x02,
225 GPIO_DRIVE_STRENGTH_MAXIMUM = 0x03
226} gpio_drive_type;
227
231typedef enum
232{
233 GPIO_OUTPUT_PUSH_PULL = 0x00,
234 GPIO_OUTPUT_OPEN_DRAIN = 0x04
235} gpio_output_type;
236
240typedef enum
241{
242 GPIO_PULL_NONE = 0x0004,
243 GPIO_PULL_UP = 0x0018,
244 GPIO_PULL_DOWN = 0x0028
245} gpio_pull_type;
246
250typedef enum
251{
252 GPIO_PINS_SOURCE0 = 0x00,
253 GPIO_PINS_SOURCE1 = 0x01,
254 GPIO_PINS_SOURCE2 = 0x02,
255 GPIO_PINS_SOURCE3 = 0x03,
256 GPIO_PINS_SOURCE4 = 0x04,
257 GPIO_PINS_SOURCE5 = 0x05,
258 GPIO_PINS_SOURCE6 = 0x06,
259 GPIO_PINS_SOURCE7 = 0x07,
260 GPIO_PINS_SOURCE8 = 0x08,
261 GPIO_PINS_SOURCE9 = 0x09,
262 GPIO_PINS_SOURCE10 = 0x0A,
263 GPIO_PINS_SOURCE11 = 0x0B,
264 GPIO_PINS_SOURCE12 = 0x0C,
265 GPIO_PINS_SOURCE13 = 0x0D,
266 GPIO_PINS_SOURCE14 = 0x0E,
267 GPIO_PINS_SOURCE15 = 0x0F
268} gpio_pins_source_type;
269
273typedef enum
274{
275 GPIO_PORT_SOURCE_GPIOA = 0x00,
276 GPIO_PORT_SOURCE_GPIOB = 0x01,
277 GPIO_PORT_SOURCE_GPIOC = 0x02,
278 GPIO_PORT_SOURCE_GPIOD = 0x03,
279 GPIO_PORT_SOURCE_GPIOF = 0x05,
280} gpio_port_source_type;
281
285typedef struct
286{
287 uint32_t gpio_pins;
288 gpio_output_type gpio_out_type;
289 gpio_pull_type gpio_pull;
290 gpio_mode_type gpio_mode;
291 gpio_drive_type gpio_drive_strength;
292} gpio_init_type;
293
297typedef struct
298{
302 union
303 {
304 __IO uint32_t cfglr;
305 struct
306 {
307 __IO uint32_t iomc0 : 2; /* [1:0] */
308 __IO uint32_t iofc0 : 2; /* [3:2] */
309 __IO uint32_t iomc1 : 2; /* [5:4] */
310 __IO uint32_t iofc1 : 2; /* [7:6] */
311 __IO uint32_t iomc2 : 2; /* [9:8] */
312 __IO uint32_t iofc2 : 2; /* [11:10] */
313 __IO uint32_t iomc3 : 2; /* [13:12] */
314 __IO uint32_t iofc3 : 2; /* [15:14] */
315 __IO uint32_t iomc4 : 2; /* [17:16] */
316 __IO uint32_t iofc4 : 2; /* [19:18] */
317 __IO uint32_t iomc5 : 2; /* [21:20] */
318 __IO uint32_t iofc5 : 2; /* [23:22] */
319 __IO uint32_t iomc6 : 2; /* [25:24] */
320 __IO uint32_t iofc6 : 2; /* [27:26] */
321 __IO uint32_t iomc7 : 2; /* [29:28] */
322 __IO uint32_t iofc7 : 2; /* [31:30] */
323 } cfglr_bit;
324 };
325
329 union
330 {
331 __IO uint32_t cfghr;
332 struct
333 {
334 __IO uint32_t iomc8 : 2; /* [1:0] */
335 __IO uint32_t iofc8 : 2; /* [3:2] */
336 __IO uint32_t iomc9 : 2; /* [5:4] */
337 __IO uint32_t iofc9 : 2; /* [7:6] */
338 __IO uint32_t iomc10 : 2; /* [9:8] */
339 __IO uint32_t iofc10 : 2; /* [11:10] */
340 __IO uint32_t iomc11 : 2; /* [13:12] */
341 __IO uint32_t iofc11 : 2; /* [15:14] */
342 __IO uint32_t iomc12 : 2; /* [17:16] */
343 __IO uint32_t iofc12 : 2; /* [19:18] */
344 __IO uint32_t iomc13 : 2; /* [21:20] */
345 __IO uint32_t iofc13 : 2; /* [23:22] */
346 __IO uint32_t iomc14 : 2; /* [25:24] */
347 __IO uint32_t iofc14 : 2; /* [27:26] */
348 __IO uint32_t iomc15 : 2; /* [29:28] */
349 __IO uint32_t iofc15 : 2; /* [31:30] */
350 } cfghr_bit;
351 };
352
356 union
357 {
358 __IO uint32_t idt;
359 struct
360 {
361 __IO uint32_t idt0 : 1; /* [0] */
362 __IO uint32_t idt1 : 1; /* [1] */
363 __IO uint32_t idt2 : 1; /* [2] */
364 __IO uint32_t idt3 : 1; /* [3] */
365 __IO uint32_t idt4 : 1; /* [4] */
366 __IO uint32_t idt5 : 1; /* [5] */
367 __IO uint32_t idt6 : 1; /* [6] */
368 __IO uint32_t idt7 : 1; /* [7] */
369 __IO uint32_t idt8 : 1; /* [8] */
370 __IO uint32_t idt9 : 1; /* [9] */
371 __IO uint32_t idt10 : 1; /* [10] */
372 __IO uint32_t idt11 : 1; /* [11] */
373 __IO uint32_t idt12 : 1; /* [12] */
374 __IO uint32_t idt13 : 1; /* [13] */
375 __IO uint32_t idt14 : 1; /* [14] */
376 __IO uint32_t idt15 : 1; /* [15] */
377 __IO uint32_t reserved1 : 16;/* [31:16] */
378 } idt_bit;
379 };
380
384 union
385 {
386 __IO uint32_t odt;
387 struct
388 {
389 __IO uint32_t odt0 : 1; /* [0] */
390 __IO uint32_t odt1 : 1; /* [1] */
391 __IO uint32_t odt2 : 1; /* [2] */
392 __IO uint32_t odt3 : 1; /* [3] */
393 __IO uint32_t odt4 : 1; /* [4] */
394 __IO uint32_t odt5 : 1; /* [5] */
395 __IO uint32_t odt6 : 1; /* [6] */
396 __IO uint32_t odt7 : 1; /* [7] */
397 __IO uint32_t odt8 : 1; /* [8] */
398 __IO uint32_t odt9 : 1; /* [9] */
399 __IO uint32_t odt10 : 1; /* [10] */
400 __IO uint32_t odt11 : 1; /* [11] */
401 __IO uint32_t odt12 : 1; /* [12] */
402 __IO uint32_t odt13 : 1; /* [13] */
403 __IO uint32_t odt14 : 1; /* [14] */
404 __IO uint32_t odt15 : 1; /* [15] */
405 __IO uint32_t reserved1 : 16;/* [31:16] */
406 } odt_bit;
407 };
408
412 union
413 {
414 __IO uint32_t scr;
415 struct
416 {
417 __IO uint32_t iosb0 : 1; /* [0] */
418 __IO uint32_t iosb1 : 1; /* [1] */
419 __IO uint32_t iosb2 : 1; /* [2] */
420 __IO uint32_t iosb3 : 1; /* [3] */
421 __IO uint32_t iosb4 : 1; /* [4] */
422 __IO uint32_t iosb5 : 1; /* [5] */
423 __IO uint32_t iosb6 : 1; /* [6] */
424 __IO uint32_t iosb7 : 1; /* [7] */
425 __IO uint32_t iosb8 : 1; /* [8] */
426 __IO uint32_t iosb9 : 1; /* [9] */
427 __IO uint32_t iosb10 : 1; /* [10] */
428 __IO uint32_t iosb11 : 1; /* [11] */
429 __IO uint32_t iosb12 : 1; /* [12] */
430 __IO uint32_t iosb13 : 1; /* [13] */
431 __IO uint32_t iosb14 : 1; /* [14] */
432 __IO uint32_t iosb15 : 1; /* [15] */
433 __IO uint32_t iocb0 : 1; /* [16] */
434 __IO uint32_t iocb1 : 1; /* [17] */
435 __IO uint32_t iocb2 : 1; /* [18] */
436 __IO uint32_t iocb3 : 1; /* [19] */
437 __IO uint32_t iocb4 : 1; /* [20] */
438 __IO uint32_t iocb5 : 1; /* [21] */
439 __IO uint32_t iocb6 : 1; /* [22] */
440 __IO uint32_t iocb7 : 1; /* [23] */
441 __IO uint32_t iocb8 : 1; /* [24] */
442 __IO uint32_t iocb9 : 1; /* [25] */
443 __IO uint32_t iocb10 : 1; /* [26] */
444 __IO uint32_t iocb11 : 1; /* [27] */
445 __IO uint32_t iocb12 : 1; /* [28] */
446 __IO uint32_t iocb13 : 1; /* [29] */
447 __IO uint32_t iocb14 : 1; /* [30] */
448 __IO uint32_t iocb15 : 1; /* [31] */
449 } scr_bit;
450 };
451
455 union
456 {
457 __IO uint32_t clr;
458 struct
459 {
460 __IO uint32_t iocb0 : 1; /* [0] */
461 __IO uint32_t iocb1 : 1; /* [1] */
462 __IO uint32_t iocb2 : 1; /* [2] */
463 __IO uint32_t iocb3 : 1; /* [3] */
464 __IO uint32_t iocb4 : 1; /* [4] */
465 __IO uint32_t iocb5 : 1; /* [5] */
466 __IO uint32_t iocb6 : 1; /* [6] */
467 __IO uint32_t iocb7 : 1; /* [7] */
468 __IO uint32_t iocb8 : 1; /* [8] */
469 __IO uint32_t iocb9 : 1; /* [9] */
470 __IO uint32_t iocb10 : 1; /* [10] */
471 __IO uint32_t iocb11 : 1; /* [11] */
472 __IO uint32_t iocb12 : 1; /* [12] */
473 __IO uint32_t iocb13 : 1; /* [13] */
474 __IO uint32_t iocb14 : 1; /* [14] */
475 __IO uint32_t iocb15 : 1; /* [15] */
476 __IO uint32_t reserved1 : 16;/* [31:16] */
477 } clr_bit;
478 };
479
483 union
484 {
485 __IO uint32_t wpr;
486 struct
487 {
488 __IO uint32_t wpen0 : 1; /* [0] */
489 __IO uint32_t wpen1 : 1; /* [1] */
490 __IO uint32_t wpen2 : 1; /* [2] */
491 __IO uint32_t wpen3 : 1; /* [3] */
492 __IO uint32_t wpen4 : 1; /* [4] */
493 __IO uint32_t wpen5 : 1; /* [5] */
494 __IO uint32_t wpen6 : 1; /* [6] */
495 __IO uint32_t wpen7 : 1; /* [7] */
496 __IO uint32_t wpen8 : 1; /* [8] */
497 __IO uint32_t wpen9 : 1; /* [9] */
498 __IO uint32_t wpen10 : 1; /* [10] */
499 __IO uint32_t wpen11 : 1; /* [11] */
500 __IO uint32_t wpen12 : 1; /* [12] */
501 __IO uint32_t wpen13 : 1; /* [13] */
502 __IO uint32_t wpen14 : 1; /* [14] */
503 __IO uint32_t wpen15 : 1; /* [15] */
504 __IO uint32_t wpseq : 1; /* [16] */
505 __IO uint32_t reserved1 : 15;/* [31:17] */
506 } wpr_bit;
507 };
508
509} gpio_type;
510
514typedef struct
515{
519 union
520 {
521 __IO uint32_t evtout;
522 struct
523 {
524 __IO uint32_t selpin : 4; /* [3:0] */
525 __IO uint32_t selport : 3; /* [6:4] */
526 __IO uint32_t evoen : 1; /* [7] */
527 __IO uint32_t reserved1 : 24;/* [31:8] */
528 } evtout_bit;
529 };
530
534 union
535 {
536 __IO uint32_t remap;
537 struct
538 {
539 __IO uint32_t spi1_mux_l : 1; /* [0] */
540 __IO uint32_t i2c1_mux : 1; /* [1] */
541 __IO uint32_t usart1_mux : 1; /* [2] */
542 __IO uint32_t reserved1 : 1; /* [3] */
543 __IO uint32_t usart3_mux : 2; /* [5:4] */
544 __IO uint32_t tmr1_mux : 2; /* [7:6] */
545 __IO uint32_t tmr2_mux : 2; /* [9:8] */
546 __IO uint32_t tmr3_mux : 2; /* [11:10] */
547 __IO uint32_t reserved2 : 1; /* [12] */
548 __IO uint32_t can_mux : 2; /* [14:13] */
549 __IO uint32_t pd01_mux : 1; /* [15] */
550 __IO uint32_t tmr5ch4_mux : 1; /* [16] */
551 __IO uint32_t adc1_extrgpre_mux : 1; /* [17] */
552 __IO uint32_t adc1_extrgord_mux : 1; /* [18] */
553 __IO uint32_t adc2_extrgpre_mux : 1; /* [19] */
554 __IO uint32_t adc2_extrgord_mux : 1; /* [20] */
555 __IO uint32_t reserved3 : 3; /* [23:21] */
556 __IO uint32_t swjtag_conf : 3; /* [26:24] */
557 __IO uint32_t reserved4 : 4; /* [30:27] */
558 __IO uint32_t spi1_mux_h : 1; /* [31] */
559 } remap_bit;
560 };
561
565 union
566 {
567 __IO uint32_t exintc1;
568 struct
569 {
570 __IO uint32_t exint0 : 4; /* [3:0] */
571 __IO uint32_t exint1 : 4; /* [7:4] */
572 __IO uint32_t exint2 : 4; /* [11:8] */
573 __IO uint32_t exint3 : 4; /* [15:12] */
574 __IO uint32_t reserved1 : 16;/* [31:16] */
575 } exintc1_bit;
576 };
577
581 union
582 {
583 __IO uint32_t exintc2;
584 struct
585 {
586 __IO uint32_t exint4 : 4; /* [3:0] */
587 __IO uint32_t exint5 : 4; /* [7:4] */
588 __IO uint32_t exint6 : 4; /* [11:8] */
589 __IO uint32_t exint7 : 4; /* [15:12] */
590 __IO uint32_t reserved1 : 16;/* [31:16] */
591 } exintc2_bit;
592 };
593
597 union
598 {
599 __IO uint32_t exintc3;
600 struct
601 {
602 __IO uint32_t exint8 : 4; /* [3:0] */
603 __IO uint32_t exint9 : 4; /* [7:4] */
604 __IO uint32_t exint10 : 4; /* [11:8] */
605 __IO uint32_t exint11 : 4; /* [15:12] */
606 __IO uint32_t reserved1 : 16;/* [31:16] */
607 } exintc3_bit;
608 };
609
613 union
614 {
615 __IO uint32_t exintc4;
616 struct
617 {
618 __IO uint32_t exint12 : 4; /* [3:0] */
619 __IO uint32_t exint13 : 4; /* [7:4] */
620 __IO uint32_t exint14 : 4; /* [11:8] */
621 __IO uint32_t exint15 : 4; /* [15:12] */
622 __IO uint32_t reserved1 : 16;/* [31:16] */
623 } exintc4_bit;
624 };
625
629 __IO uint32_t reserved1;
630
634 union
635 {
636 __IO uint32_t remap2;
637 struct
638 {
639 __IO uint32_t reserved1 : 21;/* [20:0] */
640 __IO uint32_t ext_spim_en_mux : 1; /* [21] */
641 __IO uint32_t reserved2 : 10;/* [31:22] */
642 } remap2_bit;
643 };
644
648 union
649 {
650 __IO uint32_t remap3;
651 struct
652 {
653 __IO uint32_t tmr9_gmux : 4; /* [3:0] */
654 __IO uint32_t tmr10_gmux : 4; /* [7:4] */
655 __IO uint32_t tmr11_gmux : 4; /* [11:8] */
656 __IO uint32_t reserved1 : 20;/* [31:12] */
657 } remap3_bit;
658 };
659
663 union
664 {
665 __IO uint32_t remap4;
666 struct
667 {
668 __IO uint32_t tmr1_gmux : 4; /* [3:0] */
669 __IO uint32_t tmr2_gmux : 3; /* [6:4] */
670 __IO uint32_t tmr2itr1_gmux : 1; /* [7] */
671 __IO uint32_t tmr3_gmux : 4; /* [11:8] */
672 __IO uint32_t reserved1 : 4; /* [15:12] */
673 __IO uint32_t tmr5_gmux : 3; /* [18:16] */
674 __IO uint32_t tmr5ch4_gmux : 1; /* [19] */
675 __IO uint32_t reserved2 : 12;/* [31:20] */
676 } remap4_bit;
677 };
678
682 union
683 {
684 __IO uint32_t remap5;
685 struct
686 {
687 __IO uint32_t reserved1 : 4; /* [3:0] */
688 __IO uint32_t i2c1_gmux : 4; /* [7:4] */
689 __IO uint32_t i2c2_gmux : 4; /* [11:8] */
690 __IO uint32_t reserved2 : 4; /* [15:12] */
691 __IO uint32_t spi1_gmux : 4; /* [19:16] */
692 __IO uint32_t spi2_gmux : 4; /* [23:20] */
693 __IO uint32_t reserved3 : 8; /* [31:24] */
694 } remap5_bit;
695 };
696
700 union
701 {
702 __IO uint32_t remap6;
703 struct
704 {
705 __IO uint32_t can1_gmux : 4; /* [3:0] */
706 __IO uint32_t can2_gmux : 4; /* [7:4] */
707 __IO uint32_t sdio1_gmux : 4; /* [11:8] */
708 __IO uint32_t reserved1 : 4; /* [15:12] */
709 __IO uint32_t usart1_gmux : 4; /* [19:16] */
710 __IO uint32_t reserved2 : 4; /* [23:20] */
711 __IO uint32_t usart3_gmux : 4; /* [27:24] */
712 __IO uint32_t uart4_gmux : 4; /* [31:28] */
713 } remap6_bit;
714 };
715
719 union
720 {
721 __IO uint32_t remap7;
722 struct
723 {
724 __IO uint32_t ext_spim_gmux : 3; /* [2:0] */
725 __IO uint32_t ext_spim_gen : 1; /* [3] */
726 __IO uint32_t adc1_etp_gmux : 1; /* [4] */
727 __IO uint32_t adc1_eto_gmux : 1; /* [5] */
728 __IO uint32_t reserved1 : 2; /* [7:6] */
729 __IO uint32_t adc2_etp_gmux : 1; /* [8] */
730 __IO uint32_t adc2_eto_gmux : 1; /* [9] */
731 __IO uint32_t reserved2 : 6; /* [15:10] */
732 __IO uint32_t swjtag_gmux : 3; /* [18:16] */
733 __IO uint32_t reserved3 : 1; /* [19] */
734 __IO uint32_t pd01_gmux : 1; /* [20] */
735 __IO uint32_t reserved4 : 11;/* [31:21] */
736
737 } remap7_bit;
738 };
739
740} iomux_type;
741
746#define GPIOA ((gpio_type *) GPIOA_BASE)
747#define GPIOB ((gpio_type *) GPIOB_BASE)
748#define GPIOC ((gpio_type *) GPIOC_BASE)
749#define GPIOD ((gpio_type *) GPIOD_BASE)
750#define GPIOF ((gpio_type *) GPIOF_BASE)
751#define IOMUX ((iomux_type *) IOMUX_BASE)
752
757void gpio_reset(gpio_type *gpio_x);
758void gpio_iomux_reset(void);
759void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct);
760void gpio_default_para_init(gpio_init_type *gpio_init_struct);
761 flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins);
762uint16_t gpio_input_data_read(gpio_type *gpio_x);
763 flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins);
764uint16_t gpio_output_data_read(gpio_type *gpio_x);
765void gpio_bits_set(gpio_type *gpio_x, uint16_t pins);
766void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins);
767void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state);
768void gpio_port_write(gpio_type *gpio_x, uint16_t port_value);
769void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins);
770void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source);
771void gpio_event_output_enable(confirm_state new_state);
772void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state);
773void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source);
774
787#ifdef __cplusplus
788}
789#endif
790
791#endif
at32f413.h
at32f413 header file
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
gpio_iomux_reset
void gpio_iomux_reset(void)
reset the mux functions (remap, event control and exint configuration) registers to their default val...
Definition: at32f413_gpio.c:84
gpio_output_data_read
uint16_t gpio_output_data_read(gpio_type *gpio_x)
read the specified gpio ouput data port.
Definition: at32f413_gpio.c:277
gpio_event_output_config
void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output.
Definition: at32f413_gpio.c:469
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f413_gpio.c:254
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f413_gpio.c:371
gpio_event_output_enable
void gpio_event_output_enable(confirm_state new_state)
enable or disable the event output.
Definition: at32f413_gpio.c:488
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
gpio_input_data_read
uint16_t gpio_input_data_read(gpio_type *gpio_x)
read the specified gpio input data port.
Definition: at32f413_gpio.c:224
gpio_pin_wp_config
void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers.
Definition: at32f413_gpio.c:422
gpio_port_write
void gpio_port_write(gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port.
Definition: at32f413_gpio.c:391
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:201
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
gpio_reset
void gpio_reset(gpio_type *gpio_x)
reset the gpio register
Definition: at32f413_gpio.c:49
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
gpio_mode_type
gpio_mode_type
gpio mode select
Definition: at32f413_gpio.h:211
gpio_drive_type
gpio_drive_type
gpio output drive strength select
Definition: at32f413_gpio.h:222
gpio_pins_source_type
gpio_pins_source_type
gpio pins source type
Definition: at32f413_gpio.h:251
gpio_port_source_type
gpio_port_source_type
gpio port source type
Definition: at32f413_gpio.h:274
gpio_pull_type
gpio_pull_type
gpio pull type
Definition: at32f413_gpio.h:241
gpio_output_type
gpio_output_type
gpio output type
Definition: at32f413_gpio.h:232
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_MAXIMUM
@ GPIO_DRIVE_STRENGTH_MAXIMUM
Definition: at32f413_gpio.h:225
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:224
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f413_gpio.h:255
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f413_gpio.h:253
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f413_gpio.h:259
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f413_gpio.h:264
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f413_gpio.h:265
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f413_gpio.h:258
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:252
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f413_gpio.h:254
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f413_gpio.h:262
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f413_gpio.h:261
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f413_gpio.h:256
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f413_gpio.h:263
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f413_gpio.h:267
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f413_gpio.h:266
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f413_gpio.h:257
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f413_gpio.h:260
GPIO_PORT_SOURCE_GPIOF
@ GPIO_PORT_SOURCE_GPIOF
Definition: at32f413_gpio.h:279
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:275
GPIO_PORT_SOURCE_GPIOB
@ GPIO_PORT_SOURCE_GPIOB
Definition: at32f413_gpio.h:276
GPIO_PORT_SOURCE_GPIOD
@ GPIO_PORT_SOURCE_GPIOD
Definition: at32f413_gpio.h:278
GPIO_PORT_SOURCE_GPIOC
@ GPIO_PORT_SOURCE_GPIOC
Definition: at32f413_gpio.h:277
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:298
gpio_type::iocb9
__IO uint32_t iocb9
Definition: at32f413_gpio.h:442
gpio_type::idt4
__IO uint32_t idt4
Definition: at32f413_gpio.h:365
gpio_type::iocb4
__IO uint32_t iocb4
Definition: at32f413_gpio.h:437
gpio_type::iocb6
__IO uint32_t iocb6
Definition: at32f413_gpio.h:439
gpio_type::iomc13
__IO uint32_t iomc13
Definition: at32f413_gpio.h:344
gpio_type::odt11
__IO uint32_t odt11
Definition: at32f413_gpio.h:400
gpio_type::iocb7
__IO uint32_t iocb7
Definition: at32f413_gpio.h:440
gpio_type::idt3
__IO uint32_t idt3
Definition: at32f413_gpio.h:364
gpio_type::idt7
__IO uint32_t idt7
Definition: at32f413_gpio.h:368
gpio_type::iosb12
__IO uint32_t iosb12
Definition: at32f413_gpio.h:429
gpio_type::iomc5
__IO uint32_t iomc5
Definition: at32f413_gpio.h:317
gpio_type::iofc13
__IO uint32_t iofc13
Definition: at32f413_gpio.h:345
gpio_type::iosb4
__IO uint32_t iosb4
Definition: at32f413_gpio.h:421
gpio_type::idt1
__IO uint32_t idt1
Definition: at32f413_gpio.h:362
gpio_type::idt14
__IO uint32_t idt14
Definition: at32f413_gpio.h:375
gpio_type::idt6
__IO uint32_t idt6
Definition: at32f413_gpio.h:367
gpio_type::iofc2
__IO uint32_t iofc2
Definition: at32f413_gpio.h:312
gpio_type::scr
__IO uint32_t scr
Definition: at32f413_gpio.h:414
gpio_type::odt6
__IO uint32_t odt6
Definition: at32f413_gpio.h:395
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:386
gpio_type::wpen0
__IO uint32_t wpen0
Definition: at32f413_gpio.h:488
gpio_type::wpen9
__IO uint32_t wpen9
Definition: at32f413_gpio.h:497
gpio_type::iomc0
__IO uint32_t iomc0
Definition: at32f413_gpio.h:307
gpio_type::odt5
__IO uint32_t odt5
Definition: at32f413_gpio.h:394
gpio_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_gpio.h:377
gpio_type::odt2
__IO uint32_t odt2
Definition: at32f413_gpio.h:391
gpio_type::iosb7
__IO uint32_t iosb7
Definition: at32f413_gpio.h:424
gpio_type::iocb15
__IO uint32_t iocb15
Definition: at32f413_gpio.h:448
gpio_type::idt12
__IO uint32_t idt12
Definition: at32f413_gpio.h:373
gpio_type::idt9
__IO uint32_t idt9
Definition: at32f413_gpio.h:370
gpio_type::iofc5
__IO uint32_t iofc5
Definition: at32f413_gpio.h:318
gpio_type::odt14
__IO uint32_t odt14
Definition: at32f413_gpio.h:403
gpio_type::iomc6
__IO uint32_t iomc6
Definition: at32f413_gpio.h:319
gpio_type::wpen14
__IO uint32_t wpen14
Definition: at32f413_gpio.h:502
gpio_type::idt8
__IO uint32_t idt8
Definition: at32f413_gpio.h:369
gpio_type::clr
__IO uint32_t clr
Definition: at32f413_gpio.h:457
gpio_type::iosb9
__IO uint32_t iosb9
Definition: at32f413_gpio.h:426
gpio_type::iomc2
__IO uint32_t iomc2
Definition: at32f413_gpio.h:311
gpio_type::iocb14
__IO uint32_t iocb14
Definition: at32f413_gpio.h:447
gpio_type::iofc3
__IO uint32_t iofc3
Definition: at32f413_gpio.h:314
gpio_type::iosb2
__IO uint32_t iosb2
Definition: at32f413_gpio.h:419
gpio_type::wpen8
__IO uint32_t wpen8
Definition: at32f413_gpio.h:496
gpio_type::wpen1
__IO uint32_t wpen1
Definition: at32f413_gpio.h:489
gpio_type::iocb13
__IO uint32_t iocb13
Definition: at32f413_gpio.h:446
gpio_type::wpen13
__IO uint32_t wpen13
Definition: at32f413_gpio.h:501
gpio_type::iofc14
__IO uint32_t iofc14
Definition: at32f413_gpio.h:347
gpio_type::odt15
__IO uint32_t odt15
Definition: at32f413_gpio.h:404
gpio_type::iocb12
__IO uint32_t iocb12
Definition: at32f413_gpio.h:445
gpio_type::iocb3
__IO uint32_t iocb3
Definition: at32f413_gpio.h:436
gpio_type::iosb13
__IO uint32_t iosb13
Definition: at32f413_gpio.h:430
gpio_type::odt3
__IO uint32_t odt3
Definition: at32f413_gpio.h:392
gpio_type::odt9
__IO uint32_t odt9
Definition: at32f413_gpio.h:398
gpio_type::iofc11
__IO uint32_t iofc11
Definition: at32f413_gpio.h:341
gpio_type::idt5
__IO uint32_t idt5
Definition: at32f413_gpio.h:366
gpio_type::iosb5
__IO uint32_t iosb5
Definition: at32f413_gpio.h:422
gpio_type::iosb14
__IO uint32_t iosb14
Definition: at32f413_gpio.h:431
gpio_type::iosb1
__IO uint32_t iosb1
Definition: at32f413_gpio.h:418
gpio_type::iofc6
__IO uint32_t iofc6
Definition: at32f413_gpio.h:320
gpio_type::odt12
__IO uint32_t odt12
Definition: at32f413_gpio.h:401
gpio_type::wpen15
__IO uint32_t wpen15
Definition: at32f413_gpio.h:503
gpio_type::iomc8
__IO uint32_t iomc8
Definition: at32f413_gpio.h:334
gpio_type::wpseq
__IO uint32_t wpseq
Definition: at32f413_gpio.h:504
gpio_type::idt10
__IO uint32_t idt10
Definition: at32f413_gpio.h:371
gpio_type::wpen12
__IO uint32_t wpen12
Definition: at32f413_gpio.h:500
gpio_type::iofc10
__IO uint32_t iofc10
Definition: at32f413_gpio.h:339
gpio_type::iomc9
__IO uint32_t iomc9
Definition: at32f413_gpio.h:336
gpio_type::iocb8
__IO uint32_t iocb8
Definition: at32f413_gpio.h:441
gpio_type::iosb6
__IO uint32_t iosb6
Definition: at32f413_gpio.h:423
gpio_type::iocb1
__IO uint32_t iocb1
Definition: at32f413_gpio.h:434
gpio_type::iocb2
__IO uint32_t iocb2
Definition: at32f413_gpio.h:435
gpio_type::wpen2
__IO uint32_t wpen2
Definition: at32f413_gpio.h:490
gpio_type::iofc12
__IO uint32_t iofc12
Definition: at32f413_gpio.h:343
gpio_type::iomc7
__IO uint32_t iomc7
Definition: at32f413_gpio.h:321
gpio_type::idt13
__IO uint32_t idt13
Definition: at32f413_gpio.h:374
gpio_type::odt13
__IO uint32_t odt13
Definition: at32f413_gpio.h:402
gpio_type::iocb5
__IO uint32_t iocb5
Definition: at32f413_gpio.h:438
gpio_type::odt7
__IO uint32_t odt7
Definition: at32f413_gpio.h:396
gpio_type::odt4
__IO uint32_t odt4
Definition: at32f413_gpio.h:393
gpio_type::iosb0
__IO uint32_t iosb0
Definition: at32f413_gpio.h:417
gpio_type::wpen6
__IO uint32_t wpen6
Definition: at32f413_gpio.h:494
gpio_type::cfghr
__IO uint32_t cfghr
Definition: at32f413_gpio.h:331
gpio_type::iofc0
__IO uint32_t iofc0
Definition: at32f413_gpio.h:308
gpio_type::wpen11
__IO uint32_t wpen11
Definition: at32f413_gpio.h:499
gpio_type::wpen4
__IO uint32_t wpen4
Definition: at32f413_gpio.h:492
gpio_type::wpen5
__IO uint32_t wpen5
Definition: at32f413_gpio.h:493
gpio_type::idt11
__IO uint32_t idt11
Definition: at32f413_gpio.h:372
gpio_type::idt2
__IO uint32_t idt2
Definition: at32f413_gpio.h:363
gpio_type::odt1
__IO uint32_t odt1
Definition: at32f413_gpio.h:390
gpio_type::cfglr
__IO uint32_t cfglr
Definition: at32f413_gpio.h:304
gpio_type::wpen7
__IO uint32_t wpen7
Definition: at32f413_gpio.h:495
gpio_type::iomc11
__IO uint32_t iomc11
Definition: at32f413_gpio.h:340
gpio_type::iocb10
__IO uint32_t iocb10
Definition: at32f413_gpio.h:443
gpio_type::iofc9
__IO uint32_t iofc9
Definition: at32f413_gpio.h:337
gpio_type::iomc15
__IO uint32_t iomc15
Definition: at32f413_gpio.h:348
gpio_type::iomc14
__IO uint32_t iomc14
Definition: at32f413_gpio.h:346
gpio_type::iofc8
__IO uint32_t iofc8
Definition: at32f413_gpio.h:335
gpio_type::iomc12
__IO uint32_t iomc12
Definition: at32f413_gpio.h:342
gpio_type::iosb15
__IO uint32_t iosb15
Definition: at32f413_gpio.h:432
gpio_type::odt10
__IO uint32_t odt10
Definition: at32f413_gpio.h:399
gpio_type::iofc7
__IO uint32_t iofc7
Definition: at32f413_gpio.h:322
gpio_type::iosb3
__IO uint32_t iosb3
Definition: at32f413_gpio.h:420
gpio_type::odt0
__IO uint32_t odt0
Definition: at32f413_gpio.h:389
gpio_type::wpen3
__IO uint32_t wpen3
Definition: at32f413_gpio.h:491
gpio_type::idt15
__IO uint32_t idt15
Definition: at32f413_gpio.h:376
gpio_type::idt
__IO uint32_t idt
Definition: at32f413_gpio.h:358
gpio_type::odt8
__IO uint32_t odt8
Definition: at32f413_gpio.h:397
gpio_type::iofc15
__IO uint32_t iofc15
Definition: at32f413_gpio.h:349
gpio_type::iofc1
__IO uint32_t iofc1
Definition: at32f413_gpio.h:310
gpio_type::idt0
__IO uint32_t idt0
Definition: at32f413_gpio.h:361
gpio_type::wpr
__IO uint32_t wpr
Definition: at32f413_gpio.h:485
gpio_type::iomc3
__IO uint32_t iomc3
Definition: at32f413_gpio.h:313
gpio_type::iocb0
__IO uint32_t iocb0
Definition: at32f413_gpio.h:433
gpio_type::iosb8
__IO uint32_t iosb8
Definition: at32f413_gpio.h:425
gpio_type::iosb11
__IO uint32_t iosb11
Definition: at32f413_gpio.h:428
gpio_type::iomc4
__IO uint32_t iomc4
Definition: at32f413_gpio.h:315
gpio_type::iomc10
__IO uint32_t iomc10
Definition: at32f413_gpio.h:338
gpio_type::iomc1
__IO uint32_t iomc1
Definition: at32f413_gpio.h:309
gpio_type::iofc4
__IO uint32_t iofc4
Definition: at32f413_gpio.h:316
gpio_type::wpen10
__IO uint32_t wpen10
Definition: at32f413_gpio.h:498
gpio_type::iosb10
__IO uint32_t iosb10
Definition: at32f413_gpio.h:427
gpio_type::iocb11
__IO uint32_t iocb11
Definition: at32f413_gpio.h:444
iomux_type
type define iomux register all
Definition: at32f413_gpio.h:515
iomux_type::adc1_etp_gmux
__IO uint32_t adc1_etp_gmux
Definition: at32f413_gpio.h:726
iomux_type::exint1
__IO uint32_t exint1
Definition: at32f413_gpio.h:571
iomux_type::remap
__IO uint32_t remap
Definition: at32f413_gpio.h:536
iomux_type::tmr3_gmux
__IO uint32_t tmr3_gmux
Definition: at32f413_gpio.h:671
iomux_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_gpio.h:555
iomux_type::exint9
__IO uint32_t exint9
Definition: at32f413_gpio.h:603
iomux_type::remap2
__IO uint32_t remap2
Definition: at32f413_gpio.h:636
iomux_type::tmr1_gmux
__IO uint32_t tmr1_gmux
Definition: at32f413_gpio.h:668
iomux_type::tmr2_gmux
__IO uint32_t tmr2_gmux
Definition: at32f413_gpio.h:669
iomux_type::adc2_eto_gmux
__IO uint32_t adc2_eto_gmux
Definition: at32f413_gpio.h:730
iomux_type::exint15
__IO uint32_t exint15
Definition: at32f413_gpio.h:621
iomux_type::can2_gmux
__IO uint32_t can2_gmux
Definition: at32f413_gpio.h:706
iomux_type::remap6
__IO uint32_t remap6
Definition: at32f413_gpio.h:702
iomux_type::exint13
__IO uint32_t exint13
Definition: at32f413_gpio.h:619
iomux_type::usart1_gmux
__IO uint32_t usart1_gmux
Definition: at32f413_gpio.h:709
iomux_type::remap5
__IO uint32_t remap5
Definition: at32f413_gpio.h:684
iomux_type::uart4_gmux
__IO uint32_t uart4_gmux
Definition: at32f413_gpio.h:712
iomux_type::ext_spim_en_mux
__IO uint32_t ext_spim_en_mux
Definition: at32f413_gpio.h:640
iomux_type::exint10
__IO uint32_t exint10
Definition: at32f413_gpio.h:604
iomux_type::tmr3_mux
__IO uint32_t tmr3_mux
Definition: at32f413_gpio.h:546
iomux_type::tmr10_gmux
__IO uint32_t tmr10_gmux
Definition: at32f413_gpio.h:654
iomux_type::adc2_extrgpre_mux
__IO uint32_t adc2_extrgpre_mux
Definition: at32f413_gpio.h:553
iomux_type::reserved1
__IO uint32_t reserved1
iomux reserved1 register, offset:0x18
Definition: at32f413_gpio.h:527
iomux_type::i2c1_mux
__IO uint32_t i2c1_mux
Definition: at32f413_gpio.h:540
iomux_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_gpio.h:547
iomux_type::adc2_etp_gmux
__IO uint32_t adc2_etp_gmux
Definition: at32f413_gpio.h:729
iomux_type::exint12
__IO uint32_t exint12
Definition: at32f413_gpio.h:618
iomux_type::pd01_mux
__IO uint32_t pd01_mux
Definition: at32f413_gpio.h:549
iomux_type::exint11
__IO uint32_t exint11
Definition: at32f413_gpio.h:605
iomux_type::adc1_extrgpre_mux
__IO uint32_t adc1_extrgpre_mux
Definition: at32f413_gpio.h:551
iomux_type::exint7
__IO uint32_t exint7
Definition: at32f413_gpio.h:589
iomux_type::exint6
__IO uint32_t exint6
Definition: at32f413_gpio.h:588
iomux_type::remap7
__IO uint32_t remap7
Definition: at32f413_gpio.h:721
iomux_type::remap4
__IO uint32_t remap4
Definition: at32f413_gpio.h:665
iomux_type::pd01_gmux
__IO uint32_t pd01_gmux
Definition: at32f413_gpio.h:734
iomux_type::evoen
__IO uint32_t evoen
Definition: at32f413_gpio.h:526
iomux_type::adc2_extrgord_mux
__IO uint32_t adc2_extrgord_mux
Definition: at32f413_gpio.h:554
iomux_type::i2c2_gmux
__IO uint32_t i2c2_gmux
Definition: at32f413_gpio.h:689
iomux_type::exint3
__IO uint32_t exint3
Definition: at32f413_gpio.h:573
iomux_type::swjtag_conf
__IO uint32_t swjtag_conf
Definition: at32f413_gpio.h:556
iomux_type::tmr1_mux
__IO uint32_t tmr1_mux
Definition: at32f413_gpio.h:544
iomux_type::usart3_gmux
__IO uint32_t usart3_gmux
Definition: at32f413_gpio.h:711
iomux_type::tmr11_gmux
__IO uint32_t tmr11_gmux
Definition: at32f413_gpio.h:655
iomux_type::tmr9_gmux
__IO uint32_t tmr9_gmux
Definition: at32f413_gpio.h:653
iomux_type::selpin
__IO uint32_t selpin
Definition: at32f413_gpio.h:524
iomux_type::spi1_gmux
__IO uint32_t spi1_gmux
Definition: at32f413_gpio.h:691
iomux_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_gpio.h:557
iomux_type::tmr2_mux
__IO uint32_t tmr2_mux
Definition: at32f413_gpio.h:545
iomux_type::spi2_gmux
__IO uint32_t spi2_gmux
Definition: at32f413_gpio.h:692
iomux_type::exint4
__IO uint32_t exint4
Definition: at32f413_gpio.h:586
iomux_type::spi1_mux_h
__IO uint32_t spi1_mux_h
Definition: at32f413_gpio.h:558
iomux_type::exint8
__IO uint32_t exint8
Definition: at32f413_gpio.h:602
iomux_type::sdio1_gmux
__IO uint32_t sdio1_gmux
Definition: at32f413_gpio.h:707
iomux_type::can1_gmux
__IO uint32_t can1_gmux
Definition: at32f413_gpio.h:705
iomux_type::exintc4
__IO uint32_t exintc4
Definition: at32f413_gpio.h:615
iomux_type::exint2
__IO uint32_t exint2
Definition: at32f413_gpio.h:572
iomux_type::exint5
__IO uint32_t exint5
Definition: at32f413_gpio.h:587
iomux_type::selport
__IO uint32_t selport
Definition: at32f413_gpio.h:525
iomux_type::exint0
__IO uint32_t exint0
Definition: at32f413_gpio.h:570
iomux_type::exint14
__IO uint32_t exint14
Definition: at32f413_gpio.h:620
iomux_type::adc1_eto_gmux
__IO uint32_t adc1_eto_gmux
Definition: at32f413_gpio.h:727
iomux_type::remap3
__IO uint32_t remap3
Definition: at32f413_gpio.h:650
iomux_type::spi1_mux_l
__IO uint32_t spi1_mux_l
Definition: at32f413_gpio.h:539
iomux_type::usart1_mux
__IO uint32_t usart1_mux
Definition: at32f413_gpio.h:541
iomux_type::ext_spim_gen
__IO uint32_t ext_spim_gen
Definition: at32f413_gpio.h:725
iomux_type::exintc3
__IO uint32_t exintc3
Definition: at32f413_gpio.h:599
iomux_type::tmr5ch4_gmux
__IO uint32_t tmr5ch4_gmux
Definition: at32f413_gpio.h:674
iomux_type::can_mux
__IO uint32_t can_mux
Definition: at32f413_gpio.h:548
iomux_type::usart3_mux
__IO uint32_t usart3_mux
Definition: at32f413_gpio.h:543
iomux_type::tmr5ch4_mux
__IO uint32_t tmr5ch4_mux
Definition: at32f413_gpio.h:550
iomux_type::evtout
__IO uint32_t evtout
Definition: at32f413_gpio.h:521
iomux_type::adc1_extrgord_mux
__IO uint32_t adc1_extrgord_mux
Definition: at32f413_gpio.h:552
iomux_type::tmr5_gmux
__IO uint32_t tmr5_gmux
Definition: at32f413_gpio.h:673
iomux_type::exintc2
__IO uint32_t exintc2
Definition: at32f413_gpio.h:583
iomux_type::swjtag_gmux
__IO uint32_t swjtag_gmux
Definition: at32f413_gpio.h:732
iomux_type::ext_spim_gmux
__IO uint32_t ext_spim_gmux
Definition: at32f413_gpio.h:724
iomux_type::tmr2itr1_gmux
__IO uint32_t tmr2itr1_gmux
Definition: at32f413_gpio.h:670
iomux_type::exintc1
__IO uint32_t exintc1
Definition: at32f413_gpio.h:567
iomux_type::i2c1_gmux
__IO uint32_t i2c1_gmux
Definition: at32f413_gpio.h:688


AT32F413 Firmwary Library: at32f413_i2c.c Source File

  • libraries
  • drivers
  • src
at32f413_i2c.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef I2C_MODULE_ENABLED
37
49void i2c_reset(i2c_type *i2c_x)
50{
51 if(i2c_x == I2C1)
52 {
53 crm_periph_reset(CRM_I2C1_PERIPH_RESET, TRUE);
54 crm_periph_reset(CRM_I2C1_PERIPH_RESET, FALSE);
55 }
56 else if(i2c_x == I2C2)
57 {
58 crm_periph_reset(CRM_I2C2_PERIPH_RESET, TRUE);
59 crm_periph_reset(CRM_I2C2_PERIPH_RESET, FALSE);
60 }
61}
62
71void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state)
72{
73 i2c_x->ctrl1_bit.reset = new_state;
74}
75
88void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
89{
90 uint32_t apb_freq = 0;
91 uint16_t freq_mhz = 0, temp = 0;
92
93 crm_clocks_freq_type clocks;
94
95 /* disable i2c peripherals */
96 i2c_x->ctrl1_bit.i2cen = FALSE;
97
98 /* get system clock */
99 crm_clocks_freq_get(&clocks);
100
101 if((i2c_x == I2C1) || (i2c_x == I2C2))
102 {
103 apb_freq = clocks.apb1_freq;
104 }
105
106 freq_mhz = (apb_freq / 1000000);
107
108 /* set i2c input clock frequency */
109 i2c_x->ctrl2_bit.clkfreq = freq_mhz;
110
111 /* standard mode */
112 if(speed <= 100000)
113 {
114 temp = (uint16_t)(apb_freq / (speed << 1));
115
116 if (temp < 0x04)
117 {
118 temp = 0x04;
119 }
120
121 /* set scl clock */
122 i2c_x->clkctrl_bit.speed = temp;
123
124 /* disable fast mode */
125 i2c_x->clkctrl_bit.speedmode = FALSE;
126
127 /* set the maximum rise time */
128 if((freq_mhz + 1) > 0x3F)
129 {
130 i2c_x->tmrise_bit.risetime = 0x3F;
131 }
132 else
133 {
134 i2c_x->tmrise_bit.risetime = (freq_mhz + 1);
135 }
136 }
137 /* fast mode */
138 else
139 {
140 if (duty == I2C_FSMODE_DUTY_2_1)
141 {
142 temp = (uint16_t)(apb_freq / (speed * 3));
143
144 /* the ratio of high level to low level is 1:2 */
145 i2c_x->clkctrl_bit.dutymode = I2C_FSMODE_DUTY_2_1;
146 }
147 else
148 {
149 temp = (uint16_t)(apb_freq / (speed * 25));
150
151 /* the ratio of high level to low level is 9:16 */
152 i2c_x->clkctrl_bit.dutymode = I2C_FSMODE_DUTY_16_9;
153 }
154
155 if (temp == 0)
156 {
157 temp = 0x0001;
158 }
159
160 /* set scl clock*/
161 i2c_x->clkctrl_bit.speed = temp;
162
163 /* set the mode to fast mode */
164 i2c_x->clkctrl_bit.speedmode = TRUE;
165
166 /* set the maximum rise time */
167 i2c_x->tmrise_bit.risetime = (uint16_t)(((freq_mhz * (uint16_t)300) / (uint16_t)1000) + (uint16_t)1);
168 }
169}
170
183void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
184{
185 /* set address mode */
186 i2c_x->oaddr1_bit.addr1mode = mode;
187
188 /* set own address1 */
189 i2c_x->oaddr1_bit.addr1 = address;
190}
191
200void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address)
201{
202 i2c_x->oaddr2_bit.addr2 = (address >> 1);
203}
204
213void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
214{
215 i2c_x->oaddr2_bit.addr2en = new_state;
216}
217
226void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state)
227{
228 i2c_x->ctrl1_bit.permode = new_state;
229}
230
239void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
240{
241 i2c_x->ctrl1_bit.i2cen = new_state;
242}
243
255void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
256{
257 i2c_x->clkctrl_bit.dutymode = duty;
258}
259
268void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
269{
270 i2c_x->ctrl1_bit.stretch = !new_state;
271}
272
281void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
282{
283 i2c_x->ctrl1_bit.acken = new_state;
284}
285
297void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
298{
299 i2c_x->ctrl1_bit.mackctrl = pos;
300}
301
313void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos)
314{
315 i2c_x->ctrl1_bit.mackctrl = pos;
316}
317
326void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
327{
328 i2c_x->ctrl1_bit.gcaen = new_state;
329}
330
339void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state)
340{
341 i2c_x->ctrl1_bit.arpen = new_state;
342}
343
355void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
356{
357 i2c_x->ctrl1_bit.smbmode = mode;
358}
359
371void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
372{
373 i2c_x->ctrl1_bit.smbalert = level;
374}
375
384void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
385{
386 i2c_x->ctrl1_bit.pecten = new_state;
387}
388
397void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
398{
399 i2c_x->ctrl1_bit.pecen = new_state;
400}
401
409uint8_t i2c_pec_value_get(i2c_type *i2c_x)
410{
411 return i2c_x->sts2_bit.pecval;
412}
413
422void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
423{
424 i2c_x->ctrl2_bit.dmaend = new_state;
425}
426
435void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
436{
437 i2c_x->ctrl2_bit.dmaen = new_state;
438}
439
453void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
454{
455 if (new_state != FALSE)
456 {
457 i2c_x->ctrl2 |= source;
458 }
459 else
460 {
461 i2c_x->ctrl2 &= (uint16_t)~source;
462 }
463}
464
472void i2c_start_generate(i2c_type *i2c_x)
473{
474 i2c_x->ctrl1_bit.genstart = TRUE;
475}
476
484void i2c_stop_generate(i2c_type *i2c_x)
485{
486 i2c_x->ctrl1_bit.genstop = TRUE;
487}
488
501void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
502{
503 if(direction == I2C_DIRECTION_TRANSMIT)
504 {
505 i2c_x->dt = address & 0xFE;
506 }
507 else
508 {
509 i2c_x->dt = address | 0x01;
510 }
511}
512
521void i2c_data_send(i2c_type *i2c_x, uint8_t data)
522{
523 i2c_x->dt = data;
524}
525
533uint8_t i2c_data_receive(i2c_type *i2c_x)
534{
535 return (uint8_t)i2c_x->dt;
536}
537
568 flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
569{
570 __IO uint32_t reg = 0, value = 0;
571
572 reg = flag >> 28;
573
574 flag &= (uint32_t)0x00FFFFFF;
575
576 if(reg == 0)
577 {
578 value = i2c_x->sts1;
579 }
580 else
581 {
582 flag = (uint32_t)(flag >> 16);
583
584 value = i2c_x->sts2;
585 }
586
587 if((value & flag) != (uint32_t)RESET)
588 {
589 return SET;
590 }
591 else
592 {
593 return RESET;
594 }
595}
596
615void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
616{
617 i2c_x->sts1 = (uint16_t)~(flag & (uint32_t)0x0000DF00);
618
619 if(i2c_x->sts1 & I2C_ADDR7F_FLAG)
620 {
621 UNUSED(i2c_x->sts2);
622 }
623
624 if(i2c_x->sts1 & I2C_STOPF_FLAG)
625 {
626 i2c_x->ctrl1_bit.i2cen = TRUE;
627 }
628}
629
634#endif
635
UNUSED
#define UNUSED(x)
Definition: at32f413_def.h:63
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_I2C2_PERIPH_RESET
@ CRM_I2C2_PERIPH_RESET
Definition: at32f413_crm.h:179
CRM_I2C1_PERIPH_RESET
@ CRM_I2C1_PERIPH_RESET
Definition: at32f413_crm.h:178
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
i2c_fsmode_duty_cycle_type
i2c_fsmode_duty_cycle_type
i2c fast mode duty cycle
Definition: at32f413_i2c.h:145
i2c_smbus_mode_set_type
i2c_smbus_mode_set_type
i2c smbus mode set
Definition: at32f413_i2c.h:135
i2c_direction_type
i2c_direction_type
i2c address direction
Definition: at32f413_i2c.h:163
i2c_master_ack_type
i2c_master_ack_type
i2c master receiving mode acknowledge control
Definition: at32f413_i2c.h:107
i2c_address_mode_type
i2c_address_mode_type
i2c address mode
Definition: at32f413_i2c.h:154
i2c_smbus_alert_set_type
i2c_smbus_alert_set_type
i2c smbus alert pin set
Definition: at32f413_i2c.h:126
i2c_pec_position_type
i2c_pec_position_type
i2c pec position set
Definition: at32f413_i2c.h:116
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_FSMODE_DUTY_16_9
@ I2C_FSMODE_DUTY_16_9
Definition: at32f413_i2c.h:147
I2C_DIRECTION_TRANSMIT
@ I2C_DIRECTION_TRANSMIT
Definition: at32f413_i2c.h:164
i2c_pec_position_set
void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set.
Definition: at32f413_i2c.c:313
i2c_pec_transmit_enable
void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer.
Definition: at32f413_i2c.c:384
i2c_arp_mode_enable
void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode.
Definition: at32f413_i2c.c:339
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f413_i2c.c:533
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f413_i2c.c:49
i2c_smbus_alert_set
void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low.
Definition: at32f413_i2c.c:371
i2c_smbus_enable
void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode
Definition: at32f413_i2c.c:226
i2c_pec_value_get
uint8_t i2c_pec_value_get(i2c_type *i2c_x)
get pec value.
Definition: at32f413_i2c.c:409
i2c_software_reset
void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state)
software reset.
Definition: at32f413_i2c.c:71
i2c_general_call_enable
void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable general call.
Definition: at32f413_i2c.c:326
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge.
Definition: at32f413_i2c.c:281
i2c_own_address2_set
void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address)
config own address2.
Definition: at32f413_i2c.c:200
i2c_7bit_address_send
void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address.
Definition: at32f413_i2c.c:501
i2c_dma_end_transfer_set
void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one.
Definition: at32f413_i2c.c:422
i2c_own_address2_enable
void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2.
Definition: at32f413_i2c.c:213
i2c_pec_calculate_enable
void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion.
Definition: at32f413_i2c.c:397
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f413_i2c.c:484
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph
Definition: at32f413_i2c.c:239
i2c_fast_mode_duty_set
void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle
Definition: at32f413_i2c.c:255
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status
Definition: at32f413_i2c.c:568
i2c_smbus_mode_set
void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device.
Definition: at32f413_i2c.c:355
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt
Definition: at32f413_i2c.c:453
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f413_i2c.c:615
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests.
Definition: at32f413_i2c.c:435
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f413_i2c.c:521
i2c_clock_stretch_enable
void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch.
Definition: at32f413_i2c.c:268
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
i2c_master_receive_ack_set
void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control.
Definition: at32f413_i2c.c:297
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f413_i2c.c:472
I2C_ADDR7F_FLAG
#define I2C_ADDR7F_FLAG
Definition: at32f413_i2c.h:51
I2C_STOPF_FLAG
#define I2C_STOPF_FLAG
Definition: at32f413_i2c.h:54
I2C1
#define I2C1
Definition: at32f413_i2c.h:345
I2C2
#define I2C2
Definition: at32f413_i2c.h:346
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:473
i2c_type
type define i2c register all
Definition: at32f413_i2c.h:172
i2c_type::smbalert
__IO uint32_t smbalert
Definition: at32f413_i2c.h:194
i2c_type::dmaend
__IO uint32_t dmaend
Definition: at32f413_i2c.h:214
i2c_type::genstop
__IO uint32_t genstop
Definition: at32f413_i2c.h:190
i2c_type::clkctrl_bit
struct i2c_type::@521::@532 clkctrl_bit
i2c_type::addr2en
__IO uint32_t addr2en
Definition: at32f413_i2c.h:242
i2c_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_i2c.h:213
i2c_type::gcaen
__IO uint32_t gcaen
Definition: at32f413_i2c.h:187
i2c_type::clkfreq
__IO uint32_t clkfreq
Definition: at32f413_i2c.h:209
i2c_type::addr2
__IO uint32_t addr2
Definition: at32f413_i2c.h:243
i2c_type::tmrise_bit
struct i2c_type::@523::@533 tmrise_bit
i2c_type::sts1
__IO uint32_t sts1
Definition: at32f413_i2c.h:266
i2c_type::risetime
__IO uint32_t risetime
Definition: at32f413_i2c.h:334
i2c_type::permode
__IO uint32_t permode
Definition: at32f413_i2c.h:182
i2c_type::genstart
__IO uint32_t genstart
Definition: at32f413_i2c.h:189
i2c_type::speedmode
__IO uint32_t speedmode
Definition: at32f413_i2c.h:321
i2c_type::pecten
__IO uint32_t pecten
Definition: at32f413_i2c.h:193
i2c_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_i2c.h:206
i2c_type::speed
__IO uint32_t speed
Definition: at32f413_i2c.h:318
i2c_type::oaddr2_bit
struct i2c_type::@513::@528 oaddr2_bit
i2c_type::ctrl2_bit
struct i2c_type::@509::@526 ctrl2_bit
i2c_type::ctrl1_bit
struct i2c_type::@507::@525 ctrl1_bit
i2c_type::stretch
__IO uint32_t stretch
Definition: at32f413_i2c.h:188
i2c_type::dutymode
__IO uint32_t dutymode
Definition: at32f413_i2c.h:320
i2c_type::arpen
__IO uint32_t arpen
Definition: at32f413_i2c.h:185
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f413_i2c.h:229
i2c_type::oaddr1_bit
struct i2c_type::@511::@527 oaddr1_bit
i2c_type::reset
__IO uint32_t reset
Definition: at32f413_i2c.h:196
i2c_type::pecval
__IO uint32_t pecval
Definition: at32f413_i2c.h:305
i2c_type::sts2_bit
struct i2c_type::@519::@531 sts2_bit
i2c_type::dt
__IO uint32_t dt
Definition: at32f413_i2c.h:253
i2c_type::acken
__IO uint32_t acken
Definition: at32f413_i2c.h:191
i2c_type::i2cen
__IO uint32_t i2cen
Definition: at32f413_i2c.h:181
i2c_type::addr1
__IO uint32_t addr1
Definition: at32f413_i2c.h:227
i2c_type::sts2
__IO uint32_t sts2
Definition: at32f413_i2c.h:294
i2c_type::mackctrl
__IO uint32_t mackctrl
Definition: at32f413_i2c.h:192
i2c_type::pecen
__IO uint32_t pecen
Definition: at32f413_i2c.h:186
i2c_type::smbmode
__IO uint32_t smbmode
Definition: at32f413_i2c.h:184
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_i2c.h Source File

  • libraries
  • drivers
  • inc
at32f413_i2c.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_I2C_H
27#define __AT32F413_I2C_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define I2C_STARTF_FLAG ((uint32_t)0x00000001)
51#define I2C_ADDR7F_FLAG ((uint32_t)0x00000002)
52#define I2C_TDC_FLAG ((uint32_t)0x00000004)
53#define I2C_ADDRHF_FLAG ((uint32_t)0x00000008)
54#define I2C_STOPF_FLAG ((uint32_t)0x00000010)
55#define I2C_RDBF_FLAG ((uint32_t)0x00000040)
56#define I2C_TDBE_FLAG ((uint32_t)0x00000080)
57#define I2C_BUSERR_FLAG ((uint32_t)0x00000100)
58#define I2C_ARLOST_FLAG ((uint32_t)0x00000200)
59#define I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)
60#define I2C_OUF_FLAG ((uint32_t)0x00000800)
61#define I2C_PECERR_FLAG ((uint32_t)0x00001000)
62#define I2C_TMOUT_FLAG ((uint32_t)0x00004000)
63#define I2C_ALERTF_FLAG ((uint32_t)0x00008000)
74#define I2C_TRMODE_FLAG ((uint32_t)0x10010000)
75#define I2C_BUSYF_FLAG ((uint32_t)0x10020000)
76#define I2C_DIRF_FLAG ((uint32_t)0x10040000)
77#define I2C_GCADDRF_FLAG ((uint32_t)0x10100000)
78#define I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)
79#define I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)
80#define I2C_ADDR2_FLAG ((uint32_t)0x10800000)
91#define I2C_DATA_INT ((uint16_t)0x0400)
92#define I2C_EVT_INT ((uint16_t)0x0200)
93#define I2C_ERR_INT ((uint16_t)0x0100)
106typedef enum
107{
108 I2C_MASTER_ACK_CURRENT = 0x00,
109 I2C_MASTER_ACK_NEXT = 0x01
110} i2c_master_ack_type;
111
115typedef enum
116{
117 I2C_PEC_POSITION_CURRENT = 0x00,
118 I2C_PEC_POSITION_NEXT = 0x01
119} i2c_pec_position_type;
120
121
125typedef enum
126{
127 I2C_SMBUS_ALERT_HIGH = 0x00,
128 I2C_SMBUS_ALERT_LOW = 0x01
129} i2c_smbus_alert_set_type;
130
134typedef enum
135{
136 I2C_SMBUS_MODE_DEVICE = 0x00,
137 I2C_SMBUS_MODE_HOST = 0x01
138} i2c_smbus_mode_set_type;
139
140
144typedef enum
145{
146 I2C_FSMODE_DUTY_2_1 = 0x00,
147 I2C_FSMODE_DUTY_16_9 = 0x01
148} i2c_fsmode_duty_cycle_type;
149
153typedef enum
154{
155 I2C_ADDRESS_MODE_7BIT = 0x00,
156 I2C_ADDRESS_MODE_10BIT = 0x01
157} i2c_address_mode_type;
158
162typedef enum
163{
164 I2C_DIRECTION_TRANSMIT = 0x00,
165 I2C_DIRECTION_RECEIVE = 0x01
166} i2c_direction_type;
167
171typedef struct
172{
176 union
177 {
178 __IO uint32_t ctrl1;
179 struct
180 {
181 __IO uint32_t i2cen : 1; /* [0] */
182 __IO uint32_t permode : 1; /* [1] */
183 __IO uint32_t reserved1 : 1; /* [2] */
184 __IO uint32_t smbmode : 1; /* [3] */
185 __IO uint32_t arpen : 1; /* [4] */
186 __IO uint32_t pecen : 1; /* [5] */
187 __IO uint32_t gcaen : 1; /* [6] */
188 __IO uint32_t stretch : 1; /* [7] */
189 __IO uint32_t genstart : 1; /* [8] */
190 __IO uint32_t genstop : 1; /* [9] */
191 __IO uint32_t acken : 1; /* [10] */
192 __IO uint32_t mackctrl : 1; /* [11] */
193 __IO uint32_t pecten : 1; /* [12] */
194 __IO uint32_t smbalert : 1; /* [13] */
195 __IO uint32_t reserved2 : 1; /* [14] */
196 __IO uint32_t reset : 1; /* [15] */
197 __IO uint32_t reserved3 : 16;/* [31:16] */
198 } ctrl1_bit;
199 };
200
204 union
205 {
206 __IO uint32_t ctrl2;
207 struct
208 {
209 __IO uint32_t clkfreq : 8; /* [7:0] */
210 __IO uint32_t errien : 1; /* [8] */
211 __IO uint32_t evtien : 1; /* [9] */
212 __IO uint32_t dataien : 1; /* [10] */
213 __IO uint32_t dmaen : 1; /* [11] */
214 __IO uint32_t dmaend : 1; /* [12] */
215 __IO uint32_t reserved1 : 19;/* [31:13] */
216 } ctrl2_bit;
217 };
218
222 union
223 {
224 __IO uint32_t oaddr1;
225 struct
226 {
227 __IO uint32_t addr1 : 10;/* [9:0] */
228 __IO uint32_t reserved1 : 5; /* [14:10] */
229 __IO uint32_t addr1mode : 1; /* [15] */
230 __IO uint32_t reserved2 : 16;/* [31:16] */
231 } oaddr1_bit;
232 };
233
237 union
238 {
239 __IO uint32_t oaddr2;
240 struct
241 {
242 __IO uint32_t addr2en : 1; /* [0] */
243 __IO uint32_t addr2 : 7; /* [7:1] */
244 __IO uint32_t reserved1 : 24;/* [31:8] */
245 } oaddr2_bit;
246 };
247
251 union
252 {
253 __IO uint32_t dt;
254 struct
255 {
256 __IO uint32_t dt : 8; /* [7:0] */
257 __IO uint32_t reserved1 : 24;/* [31:8] */
258 } dt_bit;
259 };
260
264 union
265 {
266 __IO uint32_t sts1;
267 struct
268 {
269 __IO uint32_t startf : 1; /* [0] */
270 __IO uint32_t addr7f : 1; /* [1] */
271 __IO uint32_t tdc : 1; /* [2] */
272 __IO uint32_t addrhf : 1; /* [3] */
273 __IO uint32_t stopf : 1; /* [4] */
274 __IO uint32_t reserved1 : 1; /* [5] */
275 __IO uint32_t rdbf : 1; /* [6] */
276 __IO uint32_t tdbe : 1; /* [7] */
277 __IO uint32_t buserr : 1; /* [8] */
278 __IO uint32_t arlost : 1; /* [9] */
279 __IO uint32_t ackfail : 1; /* [10] */
280 __IO uint32_t ouf : 1; /* [11] */
281 __IO uint32_t pecerr : 1; /* [12] */
282 __IO uint32_t reserved2 : 1; /* [13] */
283 __IO uint32_t tmout : 1; /* [14] */
284 __IO uint32_t alertf : 1; /* [15] */
285 __IO uint32_t reserved3 : 16; /* [31:16] */
286 } sts1_bit;
287 };
288
292 union
293 {
294 __IO uint32_t sts2;
295 struct
296 {
297 __IO uint32_t trmode : 1; /* [0] */
298 __IO uint32_t busyf : 1; /* [1] */
299 __IO uint32_t dirf : 1; /* [2] */
300 __IO uint32_t reserved1 : 1; /* [3] */
301 __IO uint32_t gcaddrf : 1; /* [4] */
302 __IO uint32_t devaddrf : 1; /* [5] */
303 __IO uint32_t hostaddrf : 1; /* [6] */
304 __IO uint32_t addr2 : 1; /* [7] */
305 __IO uint32_t pecval : 8; /* [15:8] */
306 __IO uint32_t reserved2 : 16;/* [31:16] */
307 } sts2_bit;
308 };
309
313 union
314 {
315 __IO uint32_t clkctrl;
316 struct
317 {
318 __IO uint32_t speed : 12;/* [11:0] */
319 __IO uint32_t reserved1 : 2; /* [13:12] */
320 __IO uint32_t dutymode : 1; /* [14] */
321 __IO uint32_t speedmode : 1; /* [15] */
322 __IO uint32_t reserved2 : 16;/* [31:16] */
323 } clkctrl_bit;
324 };
325
329 union
330 {
331 __IO uint32_t tmrise;
332 struct
333 {
334 __IO uint32_t risetime : 6; /* [5:0] */
335 __IO uint32_t reserved1 : 26;/* [31:6] */
336 } tmrise_bit;
337 };
338
339} i2c_type;
340
345#define I2C1 ((i2c_type *) I2C1_BASE)
346#define I2C2 ((i2c_type *) I2C2_BASE)
347
352void i2c_reset(i2c_type *i2c_x);
353void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state);
354void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed);
355void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address);
356void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address);
357void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state);
358void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state);
359void i2c_enable(i2c_type *i2c_x, confirm_state new_state);
360void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty);
361void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state);
362void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state);
363void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos);
364void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos);
365void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state);
366void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state);
367void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode);
368void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level);
369void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state);
370void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state);
371uint8_t i2c_pec_value_get(i2c_type *i2c_x);
372void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state);
373void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state);
374void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state);
375void i2c_start_generate(i2c_type *i2c_x);
376void i2c_stop_generate(i2c_type *i2c_x);
377void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction);
378void i2c_data_send(i2c_type *i2c_x, uint8_t data);
379uint8_t i2c_data_receive(i2c_type *i2c_x);
380 flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag);
381void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag);
382
395#ifdef __cplusplus
396}
397#endif
398
399#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
i2c_pec_position_set
void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set.
Definition: at32f413_i2c.c:313
i2c_pec_transmit_enable
void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer.
Definition: at32f413_i2c.c:384
i2c_arp_mode_enable
void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode.
Definition: at32f413_i2c.c:339
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f413_i2c.c:533
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f413_i2c.c:49
i2c_smbus_alert_set
void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low.
Definition: at32f413_i2c.c:371
i2c_smbus_enable
void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode
Definition: at32f413_i2c.c:226
i2c_pec_value_get
uint8_t i2c_pec_value_get(i2c_type *i2c_x)
get pec value.
Definition: at32f413_i2c.c:409
i2c_software_reset
void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state)
software reset.
Definition: at32f413_i2c.c:71
i2c_general_call_enable
void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable general call.
Definition: at32f413_i2c.c:326
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge.
Definition: at32f413_i2c.c:281
i2c_own_address2_set
void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address)
config own address2.
Definition: at32f413_i2c.c:200
i2c_7bit_address_send
void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address.
Definition: at32f413_i2c.c:501
i2c_dma_end_transfer_set
void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one.
Definition: at32f413_i2c.c:422
i2c_own_address2_enable
void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2.
Definition: at32f413_i2c.c:213
i2c_pec_calculate_enable
void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion.
Definition: at32f413_i2c.c:397
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f413_i2c.c:484
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph
Definition: at32f413_i2c.c:239
i2c_fast_mode_duty_set
void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle
Definition: at32f413_i2c.c:255
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status
Definition: at32f413_i2c.c:568
i2c_smbus_mode_set
void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device.
Definition: at32f413_i2c.c:355
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt
Definition: at32f413_i2c.c:453
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f413_i2c.c:615
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests.
Definition: at32f413_i2c.c:435
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f413_i2c.c:521
i2c_clock_stretch_enable
void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch.
Definition: at32f413_i2c.c:268
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
i2c_master_receive_ack_set
void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control.
Definition: at32f413_i2c.c:297
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f413_i2c.c:472
i2c_fsmode_duty_cycle_type
i2c_fsmode_duty_cycle_type
i2c fast mode duty cycle
Definition: at32f413_i2c.h:145
i2c_smbus_mode_set_type
i2c_smbus_mode_set_type
i2c smbus mode set
Definition: at32f413_i2c.h:135
i2c_direction_type
i2c_direction_type
i2c address direction
Definition: at32f413_i2c.h:163
i2c_master_ack_type
i2c_master_ack_type
i2c master receiving mode acknowledge control
Definition: at32f413_i2c.h:107
i2c_address_mode_type
i2c_address_mode_type
i2c address mode
Definition: at32f413_i2c.h:154
i2c_smbus_alert_set_type
i2c_smbus_alert_set_type
i2c smbus alert pin set
Definition: at32f413_i2c.h:126
i2c_pec_position_type
i2c_pec_position_type
i2c pec position set
Definition: at32f413_i2c.h:116
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_FSMODE_DUTY_16_9
@ I2C_FSMODE_DUTY_16_9
Definition: at32f413_i2c.h:147
I2C_SMBUS_MODE_HOST
@ I2C_SMBUS_MODE_HOST
Definition: at32f413_i2c.h:137
I2C_SMBUS_MODE_DEVICE
@ I2C_SMBUS_MODE_DEVICE
Definition: at32f413_i2c.h:136
I2C_DIRECTION_RECEIVE
@ I2C_DIRECTION_RECEIVE
Definition: at32f413_i2c.h:165
I2C_DIRECTION_TRANSMIT
@ I2C_DIRECTION_TRANSMIT
Definition: at32f413_i2c.h:164
I2C_MASTER_ACK_CURRENT
@ I2C_MASTER_ACK_CURRENT
Definition: at32f413_i2c.h:108
I2C_MASTER_ACK_NEXT
@ I2C_MASTER_ACK_NEXT
Definition: at32f413_i2c.h:109
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
I2C_ADDRESS_MODE_10BIT
@ I2C_ADDRESS_MODE_10BIT
Definition: at32f413_i2c.h:156
I2C_SMBUS_ALERT_HIGH
@ I2C_SMBUS_ALERT_HIGH
Definition: at32f413_i2c.h:127
I2C_SMBUS_ALERT_LOW
@ I2C_SMBUS_ALERT_LOW
Definition: at32f413_i2c.h:128
I2C_PEC_POSITION_NEXT
@ I2C_PEC_POSITION_NEXT
Definition: at32f413_i2c.h:118
I2C_PEC_POSITION_CURRENT
@ I2C_PEC_POSITION_CURRENT
Definition: at32f413_i2c.h:117
i2c_type
type define i2c register all
Definition: at32f413_i2c.h:172
i2c_type::smbalert
__IO uint32_t smbalert
Definition: at32f413_i2c.h:194
i2c_type::dmaend
__IO uint32_t dmaend
Definition: at32f413_i2c.h:214
i2c_type::genstop
__IO uint32_t genstop
Definition: at32f413_i2c.h:190
i2c_type::tmrise
__IO uint32_t tmrise
Definition: at32f413_i2c.h:331
i2c_type::tdc
__IO uint32_t tdc
Definition: at32f413_i2c.h:271
i2c_type::addr2en
__IO uint32_t addr2en
Definition: at32f413_i2c.h:242
i2c_type::pecerr
__IO uint32_t pecerr
Definition: at32f413_i2c.h:281
i2c_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_i2c.h:213
i2c_type::gcaen
__IO uint32_t gcaen
Definition: at32f413_i2c.h:187
i2c_type::clkfreq
__IO uint32_t clkfreq
Definition: at32f413_i2c.h:209
i2c_type::addr2
__IO uint32_t addr2
Definition: at32f413_i2c.h:243
i2c_type::buserr
__IO uint32_t buserr
Definition: at32f413_i2c.h:277
i2c_type::tmout
__IO uint32_t tmout
Definition: at32f413_i2c.h:283
i2c_type::stopf
__IO uint32_t stopf
Definition: at32f413_i2c.h:273
i2c_type::sts1
__IO uint32_t sts1
Definition: at32f413_i2c.h:266
i2c_type::risetime
__IO uint32_t risetime
Definition: at32f413_i2c.h:334
i2c_type::hostaddrf
__IO uint32_t hostaddrf
Definition: at32f413_i2c.h:303
i2c_type::dirf
__IO uint32_t dirf
Definition: at32f413_i2c.h:299
i2c_type::permode
__IO uint32_t permode
Definition: at32f413_i2c.h:182
i2c_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_i2c.h:183
i2c_type::genstart
__IO uint32_t genstart
Definition: at32f413_i2c.h:189
i2c_type::speedmode
__IO uint32_t speedmode
Definition: at32f413_i2c.h:321
i2c_type::pecten
__IO uint32_t pecten
Definition: at32f413_i2c.h:193
i2c_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_i2c.h:206
i2c_type::speed
__IO uint32_t speed
Definition: at32f413_i2c.h:318
i2c_type::trmode
__IO uint32_t trmode
Definition: at32f413_i2c.h:297
i2c_type::ouf
__IO uint32_t ouf
Definition: at32f413_i2c.h:280
i2c_type::arlost
__IO uint32_t arlost
Definition: at32f413_i2c.h:278
i2c_type::stretch
__IO uint32_t stretch
Definition: at32f413_i2c.h:188
i2c_type::dutymode
__IO uint32_t dutymode
Definition: at32f413_i2c.h:320
i2c_type::arpen
__IO uint32_t arpen
Definition: at32f413_i2c.h:185
i2c_type::dataien
__IO uint32_t dataien
Definition: at32f413_i2c.h:212
i2c_type::startf
__IO uint32_t startf
Definition: at32f413_i2c.h:269
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f413_i2c.h:229
i2c_type::tdbe
__IO uint32_t tdbe
Definition: at32f413_i2c.h:276
i2c_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_i2c.h:195
i2c_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_i2c.h:197
i2c_type::reset
__IO uint32_t reset
Definition: at32f413_i2c.h:196
i2c_type::pecval
__IO uint32_t pecval
Definition: at32f413_i2c.h:305
i2c_type::addrhf
__IO uint32_t addrhf
Definition: at32f413_i2c.h:272
i2c_type::addr7f
__IO uint32_t addr7f
Definition: at32f413_i2c.h:270
i2c_type::dt
__IO uint32_t dt
Definition: at32f413_i2c.h:253
i2c_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_i2c.h:178
i2c_type::ackfail
__IO uint32_t ackfail
Definition: at32f413_i2c.h:279
i2c_type::acken
__IO uint32_t acken
Definition: at32f413_i2c.h:191
i2c_type::i2cen
__IO uint32_t i2cen
Definition: at32f413_i2c.h:181
i2c_type::rdbf
__IO uint32_t rdbf
Definition: at32f413_i2c.h:275
i2c_type::busyf
__IO uint32_t busyf
Definition: at32f413_i2c.h:298
i2c_type::oaddr1
__IO uint32_t oaddr1
Definition: at32f413_i2c.h:224
i2c_type::errien
__IO uint32_t errien
Definition: at32f413_i2c.h:210
i2c_type::addr1
__IO uint32_t addr1
Definition: at32f413_i2c.h:227
i2c_type::sts2
__IO uint32_t sts2
Definition: at32f413_i2c.h:294
i2c_type::evtien
__IO uint32_t evtien
Definition: at32f413_i2c.h:211
i2c_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f413_i2c.h:315
i2c_type::mackctrl
__IO uint32_t mackctrl
Definition: at32f413_i2c.h:192
i2c_type::oaddr2
__IO uint32_t oaddr2
Definition: at32f413_i2c.h:239
i2c_type::pecen
__IO uint32_t pecen
Definition: at32f413_i2c.h:186
i2c_type::gcaddrf
__IO uint32_t gcaddrf
Definition: at32f413_i2c.h:301
i2c_type::smbmode
__IO uint32_t smbmode
Definition: at32f413_i2c.h:184
i2c_type::devaddrf
__IO uint32_t devaddrf
Definition: at32f413_i2c.h:302
i2c_type::alertf
__IO uint32_t alertf
Definition: at32f413_i2c.h:284


AT32F413 Firmwary Library: at32f413_misc.c Source File

  • libraries
  • drivers
  • src
at32f413_misc.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_conf.h"
27
37#ifdef MISC_MODULE_ENABLED
38
43#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)
44
50void nvic_system_reset(void)
51{
52 NVIC_SystemReset();
53}
54
62void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
63{
64 uint32_t temp_priority = 0;
65
66 /* encode priority */
67 temp_priority = NVIC_EncodePriority(NVIC_GetPriorityGrouping(), preempt_priority, sub_priority);
68 /* set priority */
69 NVIC_SetPriority(irqn, temp_priority);
70 /* enable irqn */
71 NVIC_EnableIRQ(irqn);
72}
73
79void nvic_irq_disable(IRQn_Type irqn)
80{
81 NVIC_DisableIRQ(irqn);
82}
83
95void nvic_priority_group_config(nvic_priority_group_type priority_group)
96{
97 /* set the prigroup[10:8] bits according to nvic_prioritygroup value */
98 NVIC_SetPriorityGrouping(priority_group);
99}
100
110void nvic_vector_table_set(uint32_t base, uint32_t offset)
111{
112 SCB->VTOR = base | (offset & (uint32_t)0x1FFFFF80);
113}
114
125void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
126{
127 if(new_state != FALSE)
128 {
129 SCB->SCR |= lp_mode;
130 }
131 else
132 {
133 SCB->SCR &= (uint32_t)(~(uint32_t)lp_mode);
134 }
135}
136
145void systick_clock_source_config(systick_clock_source_type source)
146{
147 if(source == SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV)
148 {
149 SysTick->CTRL |= SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV;
150 }
151 else
152 {
153 SysTick->CTRL &= ~(uint32_t)SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV;
154 }
155}
156
161#endif
162
IRQn_Type
enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
FALSE
@ FALSE
Definition: at32f413.h:296
nvic_lowpower_mode_type
nvic_lowpower_mode_type
nvic low power mode
Definition: at32f413_misc.h:76
nvic_priority_group_type
nvic_priority_group_type
nvic interrupt priority group
Definition: at32f413_misc.h:64
systick_clock_source_type
systick_clock_source_type
systick clock source
Definition: at32f413_misc.h:86
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:88
nvic_lowpower_mode_config
void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode
Definition: at32f413_misc.c:125
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:110
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:79
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:145
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_misc.h Source File

  • libraries
  • drivers
  • inc
at32f413_misc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_MISC_H
27#define __AT32F413_MISC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
49#define NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
50#define NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)
63typedef enum
64{
65 NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7),
66 NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6),
67 NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5),
68 NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4),
69 NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
70} nvic_priority_group_type;
71
75typedef enum
76{
77 NVIC_LP_SLEEPONEXIT = 0x02,
78 NVIC_LP_SLEEPDEEP = 0x04,
79 NVIC_LP_SEVONPEND = 0x10
80} nvic_lowpower_mode_type;
81
85typedef enum
86{
87 SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000),
88 SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004)
89} systick_clock_source_type;
90
99void nvic_system_reset(void);
100void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority);
101void nvic_irq_disable(IRQn_Type irqn);
102void nvic_priority_group_config(nvic_priority_group_type priority_group);
103void nvic_vector_table_set(uint32_t base, uint32_t offset);
104void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state);
105void systick_clock_source_config(systick_clock_source_type source);
106
119#ifdef __cplusplus
120}
121#endif
122
123#endif
at32f413.h
at32f413 header file
IRQn_Type
enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
nvic_lowpower_mode_config
void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode
Definition: at32f413_misc.c:125
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:110
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:79
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:145
nvic_lowpower_mode_type
nvic_lowpower_mode_type
nvic low power mode
Definition: at32f413_misc.h:76
nvic_priority_group_type
nvic_priority_group_type
nvic interrupt priority group
Definition: at32f413_misc.h:64
systick_clock_source_type
systick_clock_source_type
systick clock source
Definition: at32f413_misc.h:86
NVIC_LP_SEVONPEND
@ NVIC_LP_SEVONPEND
Definition: at32f413_misc.h:79
NVIC_LP_SLEEPONEXIT
@ NVIC_LP_SLEEPONEXIT
Definition: at32f413_misc.h:77
NVIC_LP_SLEEPDEEP
@ NVIC_LP_SLEEPDEEP
Definition: at32f413_misc.h:78
NVIC_PRIORITY_GROUP_1
@ NVIC_PRIORITY_GROUP_1
Definition: at32f413_misc.h:66
NVIC_PRIORITY_GROUP_3
@ NVIC_PRIORITY_GROUP_3
Definition: at32f413_misc.h:68
NVIC_PRIORITY_GROUP_2
@ NVIC_PRIORITY_GROUP_2
Definition: at32f413_misc.h:67
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
NVIC_PRIORITY_GROUP_0
@ NVIC_PRIORITY_GROUP_0
Definition: at32f413_misc.h:65
SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
@ SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
Definition: at32f413_misc.h:87
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:88


AT32F413 Firmwary Library: at32f413_pwc.c Source File

  • libraries
  • drivers
  • src
at32f413_pwc.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef PWC_MODULE_ENABLED
37
47void pwc_reset(void)
48{
49 crm_periph_reset(CRM_PWC_PERIPH_RESET, TRUE);
50 crm_periph_reset(CRM_PWC_PERIPH_RESET, FALSE);
51}
52
59void pwc_battery_powered_domain_access(confirm_state new_state)
60{
61 PWC->ctrl_bit.bpwen = new_state;
62}
63
77void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
78{
79 PWC->ctrl_bit.pvmsel = pvm_voltage;
80}
81
88void pwc_power_voltage_monitor_enable(confirm_state new_state)
89{
90 PWC->ctrl_bit.pvmen = new_state;
91}
92
104void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
105{
106 if(new_state == TRUE)
107 {
108 PWC->ctrlsts |= pin_num;
109 }
110 else
111 {
112 PWC->ctrlsts &= ~pin_num;
113 }
114}
115
125void pwc_flag_clear(uint32_t pwc_flag)
126{
127 if(pwc_flag & PWC_STANDBY_FLAG)
128 PWC->ctrl_bit.clsef = TRUE;
129 if(pwc_flag & PWC_WAKEUP_FLAG)
130 PWC->ctrl_bit.clswef = TRUE;
131}
132
142 flag_status pwc_flag_get(uint32_t pwc_flag)
143{
144 flag_status status = RESET;
145 if ((PWC->ctrlsts & pwc_flag) == RESET)
146 {
147 status = RESET;
148 }
149 else
150 {
151 status = SET;
152 }
153 return status;
154}
155
164void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
165{
166 SCB->SCR &= (uint32_t)~0x4;
167 if(pwc_sleep_enter == PWC_SLEEP_ENTER_WFE)
168 {
169 __SEV();
170 __WFE();
171 __WFE();
172 }
173 else if(pwc_sleep_enter == PWC_SLEEP_ENTER_WFI)
174 {
175 __WFI();
176 }
177}
178
187void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
188{
189 SCB->SCR |= 0x04;
190 if(pwc_deep_sleep_enter == PWC_DEEP_SLEEP_ENTER_WFE)
191 {
192 __SEV();
193 __WFE();
194 __WFE();
195 }
196 else if(pwc_deep_sleep_enter == PWC_DEEP_SLEEP_ENTER_WFI)
197 {
198 __WFI();
199 }
200 SCB->SCR &= (uint32_t)~0x4;
201}
202
208void pwc_standby_mode_enter(void)
209{
210 PWC->ctrl_bit.clswef = TRUE;
211 PWC->ctrl_bit.lpsel = TRUE;
212 SCB->SCR |= 0x04;
213#if defined (__CC_ARM)
214 __force_stores();
215#endif
216 while(1)
217 {
218 __WFI();
219 }
220}
221
226#endif
227
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
CRM_PWC_PERIPH_RESET
@ CRM_PWC_PERIPH_RESET
Definition: at32f413_crm.h:183
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
pwc_pvm_voltage_type
pwc_pvm_voltage_type
pwc pvm voltage type
Definition: at32f413_pwc.h:71
pwc_deep_sleep_enter_type
pwc_deep_sleep_enter_type
pwc deep sleep enter type
Definition: at32f413_pwc.h:94
pwc_sleep_enter_type
pwc_sleep_enter_type
pwc sleep enter type
Definition: at32f413_pwc.h:85
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:95
PWC_DEEP_SLEEP_ENTER_WFE
@ PWC_DEEP_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:96
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:86
PWC_SLEEP_ENTER_WFE
@ PWC_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:87
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f413_pwc.h:51
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f413_pwc.h:50
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:208
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f413_pwc.c:88
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:164
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:187
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:142
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:125
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f413_pwc.c:77
pwc_reset
void pwc_reset(void)
deinitialize the pwc peripheral registers to their default reset values.
Definition: at32f413_pwc.c:47
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f413_pwc.c:104
PWC
#define PWC
Definition: at32f413_pwc.h:146
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_pwc.h Source File

  • libraries
  • drivers
  • inc
at32f413_pwc.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_PWC_H
27#define __AT32F413_PWC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
51#define PWC_STANDBY_FLAG ((uint32_t)0x00000002)
52#define PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)
61#define PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
70typedef enum
71{
72 PWC_PVM_VOLTAGE_2V3 = 0x01,
73 PWC_PVM_VOLTAGE_2V4 = 0x02,
74 PWC_PVM_VOLTAGE_2V5 = 0x03,
75 PWC_PVM_VOLTAGE_2V6 = 0x04,
76 PWC_PVM_VOLTAGE_2V7 = 0x05,
77 PWC_PVM_VOLTAGE_2V8 = 0x06,
78 PWC_PVM_VOLTAGE_2V9 = 0x07
79} pwc_pvm_voltage_type;
80
84typedef enum
85{
86 PWC_SLEEP_ENTER_WFI = 0x00,
87 PWC_SLEEP_ENTER_WFE = 0x01
88} pwc_sleep_enter_type;
89
93typedef enum
94{
95 PWC_DEEP_SLEEP_ENTER_WFI = 0x00,
96 PWC_DEEP_SLEEP_ENTER_WFE = 0x01
97} pwc_deep_sleep_enter_type;
98
102typedef struct
103{
107 union
108 {
109 __IO uint32_t ctrl;
110 struct
111 {
112 __IO uint32_t reserved1 : 1; /* [0] */
113 __IO uint32_t lpsel : 1; /* [1] */
114 __IO uint32_t clswef : 1; /* [2] */
115 __IO uint32_t clsef : 1; /* [3] */
116 __IO uint32_t pvmen : 1; /* [4] */
117 __IO uint32_t pvmsel : 3; /* [7:5] */
118 __IO uint32_t bpwen : 1; /* [8] */
119 __IO uint32_t reserved2 : 23;/* [31:9] */
120 } ctrl_bit;
121 };
122
126 union
127 {
128 __IO uint32_t ctrlsts;
129 struct
130 {
131 __IO uint32_t swef : 1; /* [0] */
132 __IO uint32_t sef : 1; /* [1] */
133 __IO uint32_t pvmof : 1; /* [2] */
134 __IO uint32_t reserved1 : 5; /* [7:3] */
135 __IO uint32_t swpen : 1; /* [8] */
136 __IO uint32_t reserved2 : 23;/* [31:9] */
137 } ctrlsts_bit;
138 };
139
140} pwc_type;
141
146#define PWC ((pwc_type *) PWC_BASE)
147
152void pwc_reset(void);
153void pwc_battery_powered_domain_access(confirm_state new_state);
154void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage);
155void pwc_power_voltage_monitor_enable(confirm_state new_state);
156void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state);
157void pwc_flag_clear(uint32_t pwc_flag);
158 flag_status pwc_flag_get(uint32_t pwc_flag);
159void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter);
160void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter);
161void pwc_standby_mode_enter(void);
162
175#ifdef __cplusplus
176}
177#endif
178
179#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:208
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f413_pwc.c:88
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:164
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:187
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:142
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:125
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f413_pwc.c:77
pwc_reset
void pwc_reset(void)
deinitialize the pwc peripheral registers to their default reset values.
Definition: at32f413_pwc.c:47
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f413_pwc.c:104
pwc_pvm_voltage_type
pwc_pvm_voltage_type
pwc pvm voltage type
Definition: at32f413_pwc.h:71
pwc_deep_sleep_enter_type
pwc_deep_sleep_enter_type
pwc deep sleep enter type
Definition: at32f413_pwc.h:94
pwc_sleep_enter_type
pwc_sleep_enter_type
pwc sleep enter type
Definition: at32f413_pwc.h:85
PWC_PVM_VOLTAGE_2V7
@ PWC_PVM_VOLTAGE_2V7
Definition: at32f413_pwc.h:76
PWC_PVM_VOLTAGE_2V3
@ PWC_PVM_VOLTAGE_2V3
Definition: at32f413_pwc.h:72
PWC_PVM_VOLTAGE_2V8
@ PWC_PVM_VOLTAGE_2V8
Definition: at32f413_pwc.h:77
PWC_PVM_VOLTAGE_2V4
@ PWC_PVM_VOLTAGE_2V4
Definition: at32f413_pwc.h:73
PWC_PVM_VOLTAGE_2V5
@ PWC_PVM_VOLTAGE_2V5
Definition: at32f413_pwc.h:74
PWC_PVM_VOLTAGE_2V6
@ PWC_PVM_VOLTAGE_2V6
Definition: at32f413_pwc.h:75
PWC_PVM_VOLTAGE_2V9
@ PWC_PVM_VOLTAGE_2V9
Definition: at32f413_pwc.h:78
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:95
PWC_DEEP_SLEEP_ENTER_WFE
@ PWC_DEEP_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:96
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:86
PWC_SLEEP_ENTER_WFE
@ PWC_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:87
pwc_type
type define pwc register all
Definition: at32f413_pwc.h:103
pwc_type::bpwen
__IO uint32_t bpwen
Definition: at32f413_pwc.h:118
pwc_type::clswef
__IO uint32_t clswef
Definition: at32f413_pwc.h:114
pwc_type::pvmof
__IO uint32_t pvmof
Definition: at32f413_pwc.h:133
pwc_type::lpsel
__IO uint32_t lpsel
Definition: at32f413_pwc.h:113
pwc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_pwc.h:112
pwc_type::pvmen
__IO uint32_t pvmen
Definition: at32f413_pwc.h:116
pwc_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_pwc.h:109
pwc_type::swef
__IO uint32_t swef
Definition: at32f413_pwc.h:131
pwc_type::clsef
__IO uint32_t clsef
Definition: at32f413_pwc.h:115
pwc_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f413_pwc.h:128
pwc_type::sef
__IO uint32_t sef
Definition: at32f413_pwc.h:132
pwc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_pwc.h:119
pwc_type::swpen
__IO uint32_t swpen
Definition: at32f413_pwc.h:135
pwc_type::pvmsel
__IO uint32_t pvmsel
Definition: at32f413_pwc.h:117


AT32F413 Firmwary Library: at32f413_rtc.c Source File

  • libraries
  • drivers
  • src
at32f413_rtc.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef RTC_MODULE_ENABLED
37
47void rtc_counter_set(uint32_t counter_value)
48{
49 /* enter rtc config mode */
50 RTC->ctrll = 0x003F;
51
52 /* set rtc counter */
53 RTC->cnth_bit.cnt = (uint16_t)(counter_value >> 16);
54 RTC->cntl_bit.cnt = (uint16_t)(counter_value & 0x0000FFFF);
55
56 /* exit rtc config mode */
57 RTC->ctrll = 0x000F;
58}
59
65uint32_t rtc_counter_get(void)
66{
67 uint32_t cnt = 0;
68
69 cnt = RTC->cnth;
70 cnt = (cnt << 16) | RTC->cntl;
71
72 return cnt;
73}
74
80void rtc_divider_set(uint32_t div_value)
81{
82 /* enter rtc config mode */
83 RTC->ctrll = 0x003F;
84
85 /* set rtc divider */
86 RTC->divh_bit.div = (uint16_t)(div_value >> 16);
87 RTC->divl_bit.div = (uint16_t)(div_value & 0x0000FFFF);
88
89 /* exit rtc config mode */
90 RTC->ctrll = 0x000F;
91}
92
98uint32_t rtc_divider_get(void)
99{
100 uint32_t div = 0;
101
102 div = RTC->divcnth;
103 div = (div << 16) | RTC->divcntl;
104
105 return div;
106}
107
113void rtc_alarm_set(uint32_t alarm_value)
114{
115 /* enter rtc config mode */
116 RTC->ctrll = 0x003F;
117
118 /* set rtc alarm value */
119 RTC->tah_bit.ta = (uint16_t)(alarm_value >> 16);
120 RTC->tal_bit.ta = (uint16_t)(alarm_value & 0x0000FFFF);
121
122 /* exit rtc config mode */
123 RTC->ctrll = 0x000F;
124}
125
136void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
137{
138 if(new_state == FALSE)
139 {
140 RTC->ctrlh &= ~source;
141 }
142 else
143 {
144 RTC->ctrlh |= source;
145 }
146}
147
159 flag_status rtc_flag_get(uint16_t flag)
160{
161 flag_status status = RESET;
162
163 if ((RTC->ctrll & flag) != (uint16_t)RESET)
164 {
165 status = SET;
166 }
167 else
168 {
169 status = RESET;
170 }
171
172 return status;
173}
174
185void rtc_flag_clear(uint16_t flag)
186{
187 RTC->ctrll = ~(flag | 0x10) | (RTC->ctrll_bit.cfgen << 4);
188}
189
195void rtc_wait_config_finish(void)
196{
197 while (RTC->ctrll_bit.cfgf == 0);
198}
199
205void rtc_wait_update_finish(void)
206{
207 while (RTC->ctrll_bit.updf == 0);
208}
209
214#endif
215
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:113
rtc_divider_get
uint32_t rtc_divider_get(void)
rtc divider get
Definition: at32f413_rtc.c:98
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:65
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:205
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:136
rtc_counter_set
void rtc_counter_set(uint32_t counter_value)
rtc counter set
Definition: at32f413_rtc.c:47
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:80
RTC
#define RTC
Definition: at32f413_rtc.h:226
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_rtc.h Source File

  • libraries
  • drivers
  • inc
at32f413_rtc.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_RTC_H
27#define __AT32F413_RTC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define RTC_TS_INT ((uint16_t)0x0001)
51#define RTC_TA_INT ((uint16_t)0x0002)
52#define RTC_OVF_INT ((uint16_t)0x0004)
63#define RTC_TS_FLAG ((uint16_t)0x0001)
64#define RTC_TA_FLAG ((uint16_t)0x0002)
65#define RTC_OVF_FLAG ((uint16_t)0x0004)
66#define RTC_UPDF_FLAG ((uint16_t)0x0008)
67#define RTC_CFGF_FLAG ((uint16_t)0x0020)
80typedef struct
81{
82
86 union
87 {
88 __IO uint32_t ctrlh;
89 struct
90 {
91 __IO uint32_t tsien : 1; /* [0] */
92 __IO uint32_t taien : 1; /* [1] */
93 __IO uint32_t ovfien : 1; /* [2] */
94 __IO uint32_t reserved1 : 29;/* [31:3] */
95 } ctrlh_bit;
96 };
97
101 union
102 {
103 __IO uint32_t ctrll;
104 struct
105 {
106 __IO uint32_t tsf : 1; /* [0] */
107 __IO uint32_t taf : 1; /* [1] */
108 __IO uint32_t ovff : 1; /* [2] */
109 __IO uint32_t updf : 1; /* [3] */
110 __IO uint32_t cfgen : 1; /* [4] */
111 __IO uint32_t cfgf : 1; /* [5] */
112 __IO uint32_t reserved1 : 26;/* [31:6] */
113 } ctrll_bit;
114 };
115
119 union
120 {
121 __IO uint32_t divh;
122 struct
123 {
124 __IO uint32_t div : 4; /* [3:0] */
125 __IO uint32_t reserved1 : 28;/* [31:4] */
126 } divh_bit;
127 };
128
132 union
133 {
134 __IO uint32_t divl;
135 struct
136 {
137 __IO uint32_t div : 16;/* [15:0] */
138 __IO uint32_t reserved1 : 16;/* [31:15] */
139 } divl_bit;
140 };
141
145 union
146 {
147 __IO uint32_t divcnth;
148 struct
149 {
150 __IO uint32_t divcnt : 4; /* [3:0] */
151 __IO uint32_t reserved1 : 28;/* [31:15] */
152 } divcnth_bit;
153 };
154
158 union
159 {
160 __IO uint32_t divcntl;
161 struct
162 {
163 __IO uint32_t divcnt : 16;/* [15:0] */
164 __IO uint32_t reserved1 : 16;/* [31:15] */
165 } divcntl_bit;
166 };
167
171 union
172 {
173 __IO uint32_t cnth;
174 struct
175 {
176 __IO uint32_t cnt : 16;/* [15:0] */
177 __IO uint32_t reserved1 : 16;/* [31:15] */
178 } cnth_bit;
179 };
180
184 union
185 {
186 __IO uint32_t cntl;
187 struct
188 {
189 __IO uint32_t cnt : 16;/* [15:0] */
190 __IO uint32_t reserved1 : 16;/* [31:15] */
191 } cntl_bit;
192 };
193
197 union
198 {
199 __IO uint32_t tah;
200 struct
201 {
202 __IO uint32_t ta : 16;/* [15:0] */
203 __IO uint32_t reserved1 : 16;/* [31:15] */
204 } tah_bit;
205 };
206
210 union
211 {
212 __IO uint32_t tal;
213 struct
214 {
215 __IO uint32_t ta : 16;/* [15:0] */
216 __IO uint32_t reserved1 : 16;/* [31:15] */
217 } tal_bit;
218 };
219
220} rtc_type;
221
226#define RTC ((rtc_type *) RTC_BASE)
227
232void rtc_counter_set(uint32_t counter_value);
233uint32_t rtc_counter_get(void);
234void rtc_divider_set(uint32_t div_value);
235uint32_t rtc_divider_get(void);
236void rtc_alarm_set(uint32_t alarm_value);
237void rtc_interrupt_enable(uint16_t source, confirm_state new_state);
238 flag_status rtc_flag_get(uint16_t flag);
239void rtc_flag_clear(uint16_t flag);
240void rtc_wait_config_finish(void);
241void rtc_wait_update_finish(void);
242
255#ifdef __cplusplus
256}
257#endif
258
259#endif
at32f413.h
at32f413 header file
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:113
rtc_divider_get
uint32_t rtc_divider_get(void)
rtc divider get
Definition: at32f413_rtc.c:98
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:65
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:205
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:136
rtc_counter_set
void rtc_counter_set(uint32_t counter_value)
rtc counter set
Definition: at32f413_rtc.c:47
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:80
rtc_type
type define rtc register all
Definition: at32f413_rtc.h:81
rtc_type::div
__IO uint32_t div
Definition: at32f413_rtc.h:124
rtc_type::cntl
__IO uint32_t cntl
Definition: at32f413_rtc.h:186
rtc_type::tsien
__IO uint32_t tsien
Definition: at32f413_rtc.h:91
rtc_type::ovff
__IO uint32_t ovff
Definition: at32f413_rtc.h:108
rtc_type::cfgf
__IO uint32_t cfgf
Definition: at32f413_rtc.h:111
rtc_type::ovfien
__IO uint32_t ovfien
Definition: at32f413_rtc.h:93
rtc_type::divl
__IO uint32_t divl
Definition: at32f413_rtc.h:134
rtc_type::cnt
__IO uint32_t cnt
Definition: at32f413_rtc.h:176
rtc_type::taf
__IO uint32_t taf
Definition: at32f413_rtc.h:107
rtc_type::divcnth
__IO uint32_t divcnth
Definition: at32f413_rtc.h:147
rtc_type::ta
__IO uint32_t ta
Definition: at32f413_rtc.h:202
rtc_type::cfgen
__IO uint32_t cfgen
Definition: at32f413_rtc.h:110
rtc_type::cnth
__IO uint32_t cnth
Definition: at32f413_rtc.h:173
rtc_type::ctrll
__IO uint32_t ctrll
Definition: at32f413_rtc.h:103
rtc_type::updf
__IO uint32_t updf
Definition: at32f413_rtc.h:109
rtc_type::tsf
__IO uint32_t tsf
Definition: at32f413_rtc.h:106
rtc_type::divh
__IO uint32_t divh
Definition: at32f413_rtc.h:121
rtc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_rtc.h:94
rtc_type::tal
__IO uint32_t tal
Definition: at32f413_rtc.h:212
rtc_type::divcnt
__IO uint32_t divcnt
Definition: at32f413_rtc.h:150
rtc_type::divcntl
__IO uint32_t divcntl
Definition: at32f413_rtc.h:160
rtc_type::taien
__IO uint32_t taien
Definition: at32f413_rtc.h:92
rtc_type::tah
__IO uint32_t tah
Definition: at32f413_rtc.h:199
rtc_type::ctrlh
__IO uint32_t ctrlh
Definition: at32f413_rtc.h:88


AT32F413 Firmwary Library: at32f413_sdio.c Source File

  • libraries
  • drivers
  • src
at32f413_sdio.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef SDIO_MODULE_ENABLED
37
49void sdio_reset(sdio_type *sdio_x)
50{
51 sdio_x->pwrctrl = 0x0;
52 sdio_x->clkctrl = 0x0;
53 sdio_x->argu = 0x0;
54 sdio_x->cmdctrl = 0x0;
55 sdio_x->dttmr = 0x0;
56 sdio_x->dtlen = 0x0;
57 sdio_x->dtctrl = 0x0;
58 sdio_x->inten = 0x0;
59 sdio_x->intclr = 0x004007FF;
60}
61
73void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
74{
75 sdio_x->pwrctrl_bit.ps = power_state;
76}
77
85 sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
86{
87 return (sdio_power_state_type)(sdio_x->pwrctrl_bit.ps);
88}
89
102void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
103{
104 /* config clock edge */
105 sdio_x->clkctrl_bit.clkegs = clk_edg;
106
107 /* config clock divide [7:0] */
108 sdio_x->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
109
110 /* config clock divide [9:8] */
111 sdio_x->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
112}
113
126void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
127{
128 sdio_x->clkctrl_bit.busws = width;
129}
130
139void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
140{
141 sdio_x->clkctrl_bit.bypsen = new_state;
142}
143
153void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
154{
155 sdio_x->clkctrl_bit.pwrsven = new_state;
156}
157
166void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
167{
168 sdio_x->clkctrl_bit.hfcen = new_state;
169}
170
179void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
180{
181 sdio_x->clkctrl_bit.clkoen = new_state;
182}
183
192void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
193{
194 sdio_x->dtctrl_bit.dmaen = new_state;
195}
196
230void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
231{
232 /* enable interrupt */
233 if(TRUE == new_state)
234 {
235 sdio_x->inten |= int_opt;
236 }
237 /* disable interrupt */
238 else
239 {
240 sdio_x->inten &= ~(int_opt);
241 }
242}
243
276 flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
277{
278 flag_status status = RESET;
279
280 if((sdio_x->sts & flag) == flag)
281 {
282 status = SET;
283 }
284 else
285 {
286 status = RESET;
287 }
288
289 return status;
290}
291
313void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
314{
315 sdio_x->intclr = flag;
316}
317
327void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
328{
329 /* disable command path state machine */
330 sdio_x->cmdctrl_bit.ccsmen = FALSE;
331
332 /* config command argument */
333 sdio_x->argu = command_struct->argument;
334
335 /* config command register */
336 sdio_x->cmdctrl_bit.cmdidx = command_struct->cmd_index;
337 sdio_x->cmdctrl_bit.rspwt = command_struct->rsp_type;
338 sdio_x->cmdctrl_bit.intwt = (command_struct->wait_type & 0x1); /* [1:0] -> [0] */
339 sdio_x->cmdctrl_bit.pndwt = (command_struct->wait_type & 0x2)>>1; /* [1:0] -> [1] */
340}
341
350void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
351{
352 sdio_x->cmdctrl_bit.ccsmen = new_state;
353}
354
363uint8_t sdio_command_response_get(sdio_type *sdio_x)
364{
365 return sdio_x->rspcmd_bit.rspcmd;
366}
367
381uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
382{
383 uint32_t response_value = 0;
384
385 switch(reg_index)
386 {
387 case SDIO_RSP1_INDEX:
388 response_value = sdio_x->rsp1;
389 break;
390 case SDIO_RSP2_INDEX:
391 response_value = sdio_x->rsp2;
392 break;
393 case SDIO_RSP3_INDEX:
394 response_value = sdio_x->rsp3;
395 break;
396 case SDIO_RSP4_INDEX:
397 response_value = sdio_x->rsp4;
398 break;
399 default: break;
400 }
401
402 return response_value;
403}
404
414void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
415{
416 /* disable data path state machine */
417 sdio_x->dtctrl_bit.tfren = FALSE;
418
419 /* config data block, transfer mode and transfer direction */
420 sdio_x->dtctrl_bit.blksize = data_struct->block_size;
421 sdio_x->dtctrl_bit.tfrdir = data_struct->transfer_direction;
422 sdio_x->dtctrl_bit.tfrmode = data_struct->transfer_mode;
423
424 /* config data length */
425 sdio_x->dtlen_bit.dtlen = data_struct->data_length;
426
427 /* config data transfer timeout */
428 sdio_x->dttmr_bit.timeout = data_struct->timeout;
429}
430
439void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
440{
441 sdio_x->dtctrl_bit.tfren = new_state;
442}
443
451uint32_t sdio_data_counter_get(sdio_type *sdio_x)
452{
453 return sdio_x->dtcnt;
454}
455
463uint32_t sdio_data_read(sdio_type *sdio_x)
464{
465 return sdio_x->buf;
466}
467
475uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
476{
477 return sdio_x->bufcnt;
478}
479
488void sdio_data_write(sdio_type *sdio_x, uint32_t data)
489{
490 sdio_x->buf = data;
491}
492
504void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
505{
506 sdio_x->dtctrl_bit.rdwtmode = mode;
507}
508
517void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
518{
519 sdio_x->dtctrl_bit.rdwtstart = new_state;
520}
521
530void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
531{
532 sdio_x->dtctrl_bit.rdwtstop = new_state;
533}
534
543void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
544{
545 sdio_x->dtctrl_bit.ioen = new_state;
546}
547
556void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
557{
558 sdio_x->cmdctrl_bit.iosusp = new_state;
559}
560
565#endif
566
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
sdio_read_wait_mode_type
sdio_read_wait_mode_type
sdio read wait mode
Definition: at32f413_sdio.h:218
sdio_edge_phase_type
sdio_edge_phase_type
sdio edge phase
Definition: at32f413_sdio.h:128
sdio_power_state_type
sdio_power_state_type
sdio power state
Definition: at32f413_sdio.h:119
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:137
sdio_rsp_index_type
sdio_rsp_index_type
sdio response register index
Definition: at32f413_sdio.h:167
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:170
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:169
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:168
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:327
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:488
sdio_io_suspend_command_set
void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending.
Definition: at32f413_sdio.c:556
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:414
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:463
sdio_io_function_enable
void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function.
Definition: at32f413_sdio.c:543
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:350
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:139
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:166
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:73
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:102
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:126
sdio_read_wait_stop
void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation.
Definition: at32f413_sdio.c:530
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:230
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:313
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:85
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:381
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:439
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:153
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:276
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:192
sdio_data_counter_get
uint32_t sdio_data_counter_get(sdio_type *sdio_x)
get the number of remaining data bytes to be transferred.
Definition: at32f413_sdio.c:451
sdio_buffer_counter_get
uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
get the number of words left to be written to or read from fifo..
Definition: at32f413_sdio.c:475
sdio_read_wait_start
void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation.
Definition: at32f413_sdio.c:517
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:49
sdio_read_wait_mode_set
void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode.
Definition: at32f413_sdio.c:504
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:179
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:363
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:227
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:229
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:228
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:231
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:230
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:238
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:243
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:239
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:242
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:240
sdio_type
type define sdio register all
Definition: at32f413_sdio.h:250
sdio_type::ps
__IO uint32_t ps
Definition: at32f413_sdio.h:259
sdio_type::dtlen_bit
struct sdio_type::@590::@616 dtlen_bit
sdio_type::dtlen
__IO uint32_t dtlen
Definition: at32f413_sdio.h:392
sdio_type::intclr
__IO uint32_t intclr
Definition: at32f413_sdio.h:474
sdio_type::rdwtstart
__IO uint32_t rdwtstart
Definition: at32f413_sdio.h:413
sdio_type::rdwtstop
__IO uint32_t rdwtstop
Definition: at32f413_sdio.h:414
sdio_type::rspwt
__IO uint32_t rspwt
Definition: at32f413_sdio.h:305
sdio_type::hfcen
__IO uint32_t hfcen
Definition: at32f413_sdio.h:278
sdio_type::tfrmode
__IO uint32_t tfrmode
Definition: at32f413_sdio.h:410
sdio_type::clkegs
__IO uint32_t clkegs
Definition: at32f413_sdio.h:277
sdio_type::tfrdir
__IO uint32_t tfrdir
Definition: at32f413_sdio.h:409
sdio_type::tfren
__IO uint32_t tfren
Definition: at32f413_sdio.h:408
sdio_type::dttmr
__IO uint32_t dttmr
Definition: at32f413_sdio.h:380
sdio_type::clkctrl_bit
struct sdio_type::@572::@607 clkctrl_bit
sdio_type::inten
__IO uint32_t inten
Definition: at32f413_sdio.h:499
sdio_type::pndwt
__IO uint32_t pndwt
Definition: at32f413_sdio.h:307
sdio_type::cmdctrl
__IO uint32_t cmdctrl
Definition: at32f413_sdio.h:301
sdio_type::clkoen
__IO uint32_t clkoen
Definition: at32f413_sdio.h:273
sdio_type::ioen
__IO uint32_t ioen
Definition: at32f413_sdio.h:416
sdio_type::bufcnt
__IO uint32_t bufcnt
Definition: at32f413_sdio.h:539
sdio_type::intwt
__IO uint32_t intwt
Definition: at32f413_sdio.h:306
sdio_type::rsp2
__IO uint32_t rsp2
Definition: at32f413_sdio.h:344
sdio_type::dtctrl
__IO uint32_t dtctrl
Definition: at32f413_sdio.h:405
sdio_type::pwrctrl_bit
struct sdio_type::@570::@606 pwrctrl_bit
sdio_type::ccsmen
__IO uint32_t ccsmen
Definition: at32f413_sdio.h:308
sdio_type::pwrsven
__IO uint32_t pwrsven
Definition: at32f413_sdio.h:274
sdio_type::cmdidx
__IO uint32_t cmdidx
Definition: at32f413_sdio.h:304
sdio_type::pwrctrl
__IO uint32_t pwrctrl
Definition: at32f413_sdio.h:256
sdio_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_sdio.h:411
sdio_type::sts
__IO uint32_t sts
Definition: at32f413_sdio.h:439
sdio_type::blksize
__IO uint32_t blksize
Definition: at32f413_sdio.h:412
sdio_type::rdwtmode
__IO uint32_t rdwtmode
Definition: at32f413_sdio.h:415
sdio_type::rsp1
__IO uint32_t rsp1
Definition: at32f413_sdio.h:332
sdio_type::rsp4
__IO uint32_t rsp4
Definition: at32f413_sdio.h:368
sdio_type::bypsen
__IO uint32_t bypsen
Definition: at32f413_sdio.h:275
sdio_type::rspcmd_bit
struct sdio_type::@578::@610 rspcmd_bit
sdio_type::buf
__IO uint32_t buf
Definition: at32f413_sdio.h:557
sdio_type::dtctrl_bit
struct sdio_type::@592::@617 dtctrl_bit
sdio_type::dttmr_bit
struct sdio_type::@588::@615 dttmr_bit
sdio_type::clkdiv_l
__IO uint32_t clkdiv_l
Definition: at32f413_sdio.h:272
sdio_type::cmdctrl_bit
struct sdio_type::@576::@609 cmdctrl_bit
sdio_type::rspcmd
__IO uint32_t rspcmd
Definition: at32f413_sdio.h:319
sdio_type::argu
__IO uint32_t argu
Definition: at32f413_sdio.h:289
sdio_type::timeout
__IO uint32_t timeout
Definition: at32f413_sdio.h:383
sdio_type::busws
__IO uint32_t busws
Definition: at32f413_sdio.h:276
sdio_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_sdio.h:426
sdio_type::clkdiv_h
__IO uint32_t clkdiv_h
Definition: at32f413_sdio.h:279
sdio_type::iosusp
__IO uint32_t iosusp
Definition: at32f413_sdio.h:309
sdio_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f413_sdio.h:269
sdio_type::rsp3
__IO uint32_t rsp3
Definition: at32f413_sdio.h:356
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_sdio.h Source File

  • libraries
  • drivers
  • inc
at32f413_sdio.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_SDIO_H
27#define __AT32F413_SDIO_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
51#define SDIO_DTFAIL_INT ((uint32_t)0x00000002)
52#define SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
53#define SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
54#define SDIO_TXERRU_INT ((uint32_t)0x00000010)
55#define SDIO_RXERRO_INT ((uint32_t)0x00000020)
56#define SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
57#define SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
58#define SDIO_DTCMP_INT ((uint32_t)0x00000100)
59#define SDIO_SBITERR_INT ((uint32_t)0x00000200)
60#define SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
61#define SDIO_DOCMD_INT ((uint32_t)0x00000800)
62#define SDIO_DOTX_INT ((uint32_t)0x00001000)
63#define SDIO_DORX_INT ((uint32_t)0x00002000)
64#define SDIO_TXBUFH_INT ((uint32_t)0x00004000)
65#define SDIO_RXBUFH_INT ((uint32_t)0x00008000)
66#define SDIO_TXBUFF_INT ((uint32_t)0x00010000)
67#define SDIO_RXBUFF_INT ((uint32_t)0x00020000)
68#define SDIO_TXBUFE_INT ((uint32_t)0x00040000)
69#define SDIO_RXBUFE_INT ((uint32_t)0x00080000)
70#define SDIO_TXBUF_INT ((uint32_t)0x00100000)
71#define SDIO_RXBUF_INT ((uint32_t)0x00200000)
72#define SDIO_SDIOIF_INT ((uint32_t)0x00400000)
83#define SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
84#define SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
85#define SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
86#define SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
87#define SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
88#define SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
89#define SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
90#define SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
91#define SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
92#define SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
93#define SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
94#define SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
95#define SDIO_DOTX_FLAG ((uint32_t)0x00001000)
96#define SDIO_DORX_FLAG ((uint32_t)0x00002000)
97#define SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
98#define SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
99#define SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
100#define SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
101#define SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
102#define SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
103#define SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
104#define SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
105#define SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)
118typedef enum
119{
120 SDIO_POWER_OFF = 0x00,
121 SDIO_POWER_ON = 0x03
122} sdio_power_state_type;
123
127typedef enum
128{
129 SDIO_CLOCK_EDGE_RISING = 0x00,
130 SDIO_CLOCK_EDGE_FALLING = 0x01
131} sdio_edge_phase_type;
132
136typedef enum
137{
138 SDIO_BUS_WIDTH_D1 = 0x00,
139 SDIO_BUS_WIDTH_D4 = 0x01,
140 SDIO_BUS_WIDTH_D8 = 0x02
141} sdio_bus_width_type;
142
146typedef enum
147{
148 SDIO_RESPONSE_NO = 0x00,
149 SDIO_RESPONSE_SHORT = 0x01,
150 SDIO_RESPONSE_LONG = 0x03
151} sdio_reponse_type;
152
156typedef enum
157{
158 SDIO_WAIT_FOR_NO = 0x00,
159 SDIO_WAIT_FOR_INT = 0x01,
160 SDIO_WAIT_FOR_PEND = 0x02
161} sdio_wait_type;
162
166typedef enum
167{
168 SDIO_RSP1_INDEX = 0x00,
169 SDIO_RSP2_INDEX = 0x01,
170 SDIO_RSP3_INDEX = 0x02,
171 SDIO_RSP4_INDEX = 0x03
172} sdio_rsp_index_type;
173
177typedef enum
178{
179 SDIO_DATA_BLOCK_SIZE_1B = 0x00,
180 SDIO_DATA_BLOCK_SIZE_2B = 0x01,
181 SDIO_DATA_BLOCK_SIZE_4B = 0x02,
182 SDIO_DATA_BLOCK_SIZE_8B = 0x03,
183 SDIO_DATA_BLOCK_SIZE_16B = 0x04,
184 SDIO_DATA_BLOCK_SIZE_32B = 0x05,
185 SDIO_DATA_BLOCK_SIZE_64B = 0x06,
186 SDIO_DATA_BLOCK_SIZE_128B = 0x07,
187 SDIO_DATA_BLOCK_SIZE_256B = 0x08,
188 SDIO_DATA_BLOCK_SIZE_512B = 0x09,
189 SDIO_DATA_BLOCK_SIZE_1024B = 0x0A,
190 SDIO_DATA_BLOCK_SIZE_2048B = 0x0B,
191 SDIO_DATA_BLOCK_SIZE_4096B = 0x0C,
192 SDIO_DATA_BLOCK_SIZE_8192B = 0x0D,
193 SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
194} sdio_block_size_type;
195
199typedef enum
200{
201 SDIO_DATA_BLOCK_TRANSFER = 0x00,
202 SDIO_DATA_STREAM_TRANSFER = 0x01
203} sdio_transfer_mode_type;
204
208typedef enum
209{
210 SDIO_DATA_TRANSFER_TO_CARD = 0x00,
211 SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01
212} sdio_transfer_direction_type;
213
217typedef enum
218{
219 SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00,
220 SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01
221} sdio_read_wait_mode_type;
222
226typedef struct
227{
228 uint32_t argument;
229 uint8_t cmd_index;
230 sdio_reponse_type rsp_type;
231 sdio_wait_type wait_type;
232} sdio_command_struct_type;
233
237typedef struct
238{
239 uint32_t timeout;
240 uint32_t data_length;
241 sdio_block_size_type block_size;
242 sdio_transfer_mode_type transfer_mode;
243 sdio_transfer_direction_type transfer_direction;
244} sdio_data_struct_type;
245
249typedef struct
250{
254 union
255 {
256 __IO uint32_t pwrctrl;
257 struct
258 {
259 __IO uint32_t ps : 2; /* [1:0] */
260 __IO uint32_t reserved1 : 30;/* [31:2] */
261 } pwrctrl_bit;
262 };
263
267 union
268 {
269 __IO uint32_t clkctrl;
270 struct
271 {
272 __IO uint32_t clkdiv_l : 8; /* [7:0] */
273 __IO uint32_t clkoen : 1; /* [8] */
274 __IO uint32_t pwrsven : 1; /* [9] */
275 __IO uint32_t bypsen : 1; /* [10] */
276 __IO uint32_t busws : 2; /* [12:11] */
277 __IO uint32_t clkegs : 1; /* [13] */
278 __IO uint32_t hfcen : 1; /* [14] */
279 __IO uint32_t clkdiv_h : 2; /* [16:15] */
280 __IO uint32_t reserved1 : 15;/* [31:17] */
281 } clkctrl_bit;
282 };
283
287 union
288 {
289 __IO uint32_t argu;
290 struct
291 {
292 __IO uint32_t argu : 32;/* [31:0] */
293 } argu_bit;
294 };
295
299 union
300 {
301 __IO uint32_t cmdctrl;
302 struct
303 {
304 __IO uint32_t cmdidx : 6; /* [5:0] */
305 __IO uint32_t rspwt : 2; /* [7:6] */
306 __IO uint32_t intwt : 1; /* [8] */
307 __IO uint32_t pndwt : 1; /* [9] */
308 __IO uint32_t ccsmen : 1; /* [10] */
309 __IO uint32_t iosusp : 1; /* [11] */
310 __IO uint32_t reserved1 : 20;/* [31:12] */
311 } cmdctrl_bit;
312 };
313
317 union
318 {
319 __IO uint32_t rspcmd;
320 struct
321 {
322 __IO uint32_t rspcmd : 6; /* [5:0] */
323 __IO uint32_t reserved1 : 26;/* [31:6] */
324 } rspcmd_bit;
325 };
326
330 union
331 {
332 __IO uint32_t rsp1;
333 struct
334 {
335 __IO uint32_t cardsts1 : 32;/* [31:0] */
336 } rsp1_bit;
337 };
338
342 union
343 {
344 __IO uint32_t rsp2;
345 struct
346 {
347 __IO uint32_t cardsts2 : 32;/* [31:0] */
348 } rsp2_bit;
349 };
350
354 union
355 {
356 __IO uint32_t rsp3;
357 struct
358 {
359 __IO uint32_t cardsts3 : 32;/* [31:0] */
360 } rsp3_bit;
361 };
362
366 union
367 {
368 __IO uint32_t rsp4;
369 struct
370 {
371 __IO uint32_t cardsts4 : 32;/* [31:0] */
372 } rsp4_bit;
373 };
374
378 union
379 {
380 __IO uint32_t dttmr;
381 struct
382 {
383 __IO uint32_t timeout : 32;/* [31:0] */
384 } dttmr_bit;
385 };
386
390 union
391 {
392 __IO uint32_t dtlen;
393 struct
394 {
395 __IO uint32_t dtlen : 25;/* [24:0] */
396 __IO uint32_t reserved1 : 7; /* [31:25] */
397 } dtlen_bit;
398 };
399
403 union
404 {
405 __IO uint32_t dtctrl;
406 struct
407 {
408 __IO uint32_t tfren : 1; /* [0] */
409 __IO uint32_t tfrdir : 1; /* [1] */
410 __IO uint32_t tfrmode : 1; /* [2] */
411 __IO uint32_t dmaen : 1; /* [3] */
412 __IO uint32_t blksize : 4; /* [7:4] */
413 __IO uint32_t rdwtstart : 1; /* [8] */
414 __IO uint32_t rdwtstop : 1; /* [9] */
415 __IO uint32_t rdwtmode : 1; /* [10] */
416 __IO uint32_t ioen : 1; /* [11] */
417 __IO uint32_t reserved1 : 20;/* [31:12] */
418 } dtctrl_bit;
419 };
420
424 union
425 {
426 __IO uint32_t dtcnt;
427 struct
428 {
429 __IO uint32_t cnt : 25;/* [24:0] */
430 __IO uint32_t reserved1 : 7; /* [31:25] */
431 } dtcnt_bit;
432 };
433
437 union
438 {
439 __IO uint32_t sts;
440 struct
441 {
442 __IO uint32_t cmdfail : 1; /* [0] */
443 __IO uint32_t dtfail : 1; /* [1] */
444 __IO uint32_t cmdtimeout : 1; /* [2] */
445 __IO uint32_t dttimeout : 1; /* [3] */
446 __IO uint32_t txerru : 1; /* [4] */
447 __IO uint32_t rxerro : 1; /* [5] */
448 __IO uint32_t cmdrspcmpl : 1; /* [6] */
449 __IO uint32_t cmdcmpl : 1; /* [7] */
450 __IO uint32_t dtcmpl : 1; /* [8] */
451 __IO uint32_t sbiterr : 1; /* [9] */
452 __IO uint32_t dtblkcmpl : 1; /* [10] */
453 __IO uint32_t docmd : 1; /* [11] */
454 __IO uint32_t dotx : 1; /* [12] */
455 __IO uint32_t dorx : 1; /* [13] */
456 __IO uint32_t txbufh : 1; /* [14] */
457 __IO uint32_t rxbufh : 1; /* [15] */
458 __IO uint32_t txbuff : 1; /* [16] */
459 __IO uint32_t rxbuff : 1; /* [17] */
460 __IO uint32_t txbufe : 1; /* [18] */
461 __IO uint32_t rxbufe : 1; /* [19] */
462 __IO uint32_t txbuf : 1; /* [20] */
463 __IO uint32_t rxbuf : 1; /* [21] */
464 __IO uint32_t ioif : 1; /* [22] */
465 __IO uint32_t reserved1 : 9; /* [31:23] */
466 } sts_bit;
467 };
468
472 union
473 {
474 __IO uint32_t intclr;
475 struct
476 {
477 __IO uint32_t cmdfail : 1; /* [0] */
478 __IO uint32_t dtfail : 1; /* [1] */
479 __IO uint32_t cmdtimeout : 1; /* [2] */
480 __IO uint32_t dttimeout : 1; /* [3] */
481 __IO uint32_t txerru : 1; /* [4] */
482 __IO uint32_t rxerro : 1; /* [5] */
483 __IO uint32_t cmdrspcmpl : 1; /* [6] */
484 __IO uint32_t cmdcmpl : 1; /* [7] */
485 __IO uint32_t dtcmpl : 1; /* [8] */
486 __IO uint32_t sbiterr : 1; /* [9] */
487 __IO uint32_t dtblkcmpl : 1; /* [10] */
488 __IO uint32_t reserved1 : 11;/* [21:11] */
489 __IO uint32_t ioif : 1; /* [22] */
490 __IO uint32_t reserved2 : 9; /* [31:23] */
491 } intclr_bit;
492 };
493
497 union
498 {
499 __IO uint32_t inten;
500 struct
501 {
502 __IO uint32_t cmdfailien : 1; /* [0] */
503 __IO uint32_t dtfailien : 1; /* [1] */
504 __IO uint32_t cmdtimeoutien : 1; /* [2] */
505 __IO uint32_t dttimeoutien : 1; /* [3] */
506 __IO uint32_t txerruien : 1; /* [4] */
507 __IO uint32_t rxerroien : 1; /* [5] */
508 __IO uint32_t cmdrspcmplien : 1; /* [6] */
509 __IO uint32_t cmdcmplien : 1; /* [7] */
510 __IO uint32_t dtcmplien : 1; /* [8] */
511 __IO uint32_t sbiterrien : 1; /* [9] */
512 __IO uint32_t dtblkcmplien : 1; /* [10] */
513 __IO uint32_t docmdien : 1; /* [11] */
514 __IO uint32_t dotxien : 1; /* [12] */
515 __IO uint32_t dorxien : 1; /* [13] */
516 __IO uint32_t txbufhien : 1; /* [14] */
517 __IO uint32_t rxbufhien : 1; /* [15] */
518 __IO uint32_t txbuffien : 1; /* [16] */
519 __IO uint32_t rxbuffien : 1; /* [17] */
520 __IO uint32_t txbufeien : 1; /* [18] */
521 __IO uint32_t rxbufeien : 1; /* [19] */
522 __IO uint32_t txbufien : 1; /* [20] */
523 __IO uint32_t rxbufien : 1; /* [21] */
524 __IO uint32_t ioifien : 1; /* [22] */
525 __IO uint32_t reserved1 : 9; /* [31:23] */
526 } inten_bit;
527 };
528
532 __IO uint32_t reserved1[2];
533
537 union
538 {
539 __IO uint32_t bufcnt;
540 struct
541 {
542 __IO uint32_t cnt : 24;/* [23:0] */
543 __IO uint32_t reserved1 : 8; /* [31:24] */
544 } bufcnt_bit;
545 };
546
550 __IO uint32_t reserved2[13];
551
555 union
556 {
557 __IO uint32_t buf;
558 struct
559 {
560 __IO uint32_t dt : 32;/* [31:0] */
561 } buf_bit;
562 };
563
564} sdio_type;
565
570#if defined (AT32F413TBU7) || defined (AT32F413Rx) || defined (AT32F413Cx) || \
571 defined (AT32F413Kx)
572#define SDIO1 ((sdio_type *) SDIO1_BASE)
573#endif
574
579void sdio_reset(sdio_type *sdio_x);
580void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state);
581 sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x);
582void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg);
583void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width);
584void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state);
585void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state);
586void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state);
587void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state);
588void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state);
589void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state);
590 flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag);
591void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag);
592void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct);
593void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state);
594uint8_t sdio_command_response_get(sdio_type *sdio_x);
595uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index);
596void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct);
597void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state);
598uint32_t sdio_data_counter_get(sdio_type *sdio_x);
599uint32_t sdio_data_read(sdio_type *sdio_x);
600uint32_t sdio_buffer_counter_get(sdio_type *sdio_x);
601void sdio_data_write(sdio_type *sdio_x, uint32_t data);
602void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode);
603void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state);
604void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state);
605void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state);
606void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state);
607
620#ifdef __cplusplus
621}
622#endif
623
624#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:327
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:488
sdio_io_suspend_command_set
void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending.
Definition: at32f413_sdio.c:556
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:414
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:463
sdio_io_function_enable
void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function.
Definition: at32f413_sdio.c:543
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:350
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:139
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:166
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:73
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:102
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:126
sdio_read_wait_stop
void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation.
Definition: at32f413_sdio.c:530
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:230
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:313
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:85
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:381
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:439
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:153
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:276
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:192
sdio_data_counter_get
uint32_t sdio_data_counter_get(sdio_type *sdio_x)
get the number of remaining data bytes to be transferred.
Definition: at32f413_sdio.c:451
sdio_buffer_counter_get
uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
get the number of words left to be written to or read from fifo..
Definition: at32f413_sdio.c:475
sdio_read_wait_start
void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation.
Definition: at32f413_sdio.c:517
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:49
sdio_read_wait_mode_set
void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode.
Definition: at32f413_sdio.c:504
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:179
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:363
sdio_wait_type
sdio_wait_type
sdio wait type
Definition: at32f413_sdio.h:157
sdio_reponse_type
sdio_reponse_type
sdio response type
Definition: at32f413_sdio.h:147
sdio_read_wait_mode_type
sdio_read_wait_mode_type
sdio read wait mode
Definition: at32f413_sdio.h:218
sdio_edge_phase_type
sdio_edge_phase_type
sdio edge phase
Definition: at32f413_sdio.h:128
sdio_transfer_direction_type
sdio_transfer_direction_type
sdio data transfer direction
Definition: at32f413_sdio.h:209
sdio_power_state_type
sdio_power_state_type
sdio power state
Definition: at32f413_sdio.h:119
sdio_transfer_mode_type
sdio_transfer_mode_type
sdio data transfer mode
Definition: at32f413_sdio.h:200
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:137
sdio_rsp_index_type
sdio_rsp_index_type
sdio response register index
Definition: at32f413_sdio.h:167
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f413_sdio.h:178
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f413_sdio.h:158
SDIO_WAIT_FOR_PEND
@ SDIO_WAIT_FOR_PEND
Definition: at32f413_sdio.h:160
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f413_sdio.h:159
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f413_sdio.h:150
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f413_sdio.h:149
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f413_sdio.h:148
SDIO_READ_WAIT_CONTROLLED_BY_CK
@ SDIO_READ_WAIT_CONTROLLED_BY_CK
Definition: at32f413_sdio.h:220
SDIO_READ_WAIT_CONTROLLED_BY_D2
@ SDIO_READ_WAIT_CONTROLLED_BY_D2
Definition: at32f413_sdio.h:219
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f413_sdio.h:130
SDIO_CLOCK_EDGE_RISING
@ SDIO_CLOCK_EDGE_RISING
Definition: at32f413_sdio.h:129
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f413_sdio.h:210
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f413_sdio.h:211
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f413_sdio.h:120
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f413_sdio.h:121
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f413_sdio.h:201
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f413_sdio.h:202
SDIO_BUS_WIDTH_D8
@ SDIO_BUS_WIDTH_D8
Definition: at32f413_sdio.h:140
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f413_sdio.h:138
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f413_sdio.h:139
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:170
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:169
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:168
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f413_sdio.h:182
SDIO_DATA_BLOCK_SIZE_128B
@ SDIO_DATA_BLOCK_SIZE_128B
Definition: at32f413_sdio.h:186
SDIO_DATA_BLOCK_SIZE_2048B
@ SDIO_DATA_BLOCK_SIZE_2048B
Definition: at32f413_sdio.h:190
SDIO_DATA_BLOCK_SIZE_4096B
@ SDIO_DATA_BLOCK_SIZE_4096B
Definition: at32f413_sdio.h:191
SDIO_DATA_BLOCK_SIZE_16B
@ SDIO_DATA_BLOCK_SIZE_16B
Definition: at32f413_sdio.h:183
SDIO_DATA_BLOCK_SIZE_1024B
@ SDIO_DATA_BLOCK_SIZE_1024B
Definition: at32f413_sdio.h:189
SDIO_DATA_BLOCK_SIZE_64B
@ SDIO_DATA_BLOCK_SIZE_64B
Definition: at32f413_sdio.h:185
SDIO_DATA_BLOCK_SIZE_32B
@ SDIO_DATA_BLOCK_SIZE_32B
Definition: at32f413_sdio.h:184
SDIO_DATA_BLOCK_SIZE_8192B
@ SDIO_DATA_BLOCK_SIZE_8192B
Definition: at32f413_sdio.h:192
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f413_sdio.h:179
SDIO_DATA_BLOCK_SIZE_512B
@ SDIO_DATA_BLOCK_SIZE_512B
Definition: at32f413_sdio.h:188
SDIO_DATA_BLOCK_SIZE_2B
@ SDIO_DATA_BLOCK_SIZE_2B
Definition: at32f413_sdio.h:180
SDIO_DATA_BLOCK_SIZE_256B
@ SDIO_DATA_BLOCK_SIZE_256B
Definition: at32f413_sdio.h:187
SDIO_DATA_BLOCK_SIZE_4B
@ SDIO_DATA_BLOCK_SIZE_4B
Definition: at32f413_sdio.h:181
SDIO_DATA_BLOCK_SIZE_16384B
@ SDIO_DATA_BLOCK_SIZE_16384B
Definition: at32f413_sdio.h:193
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:227
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:229
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:228
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:231
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:230
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:238
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:243
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:239
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:242
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:240
sdio_type
type define sdio register all
Definition: at32f413_sdio.h:250
sdio_type::ps
__IO uint32_t ps
Definition: at32f413_sdio.h:259
sdio_type::dorx
__IO uint32_t dorx
Definition: at32f413_sdio.h:455
sdio_type::sbiterr
__IO uint32_t sbiterr
Definition: at32f413_sdio.h:451
sdio_type::dtlen
__IO uint32_t dtlen
Definition: at32f413_sdio.h:392
sdio_type::intclr
__IO uint32_t intclr
Definition: at32f413_sdio.h:474
sdio_type::rdwtstart
__IO uint32_t rdwtstart
Definition: at32f413_sdio.h:413
sdio_type::rdwtstop
__IO uint32_t rdwtstop
Definition: at32f413_sdio.h:414
sdio_type::rspwt
__IO uint32_t rspwt
Definition: at32f413_sdio.h:305
sdio_type::rxbuf
__IO uint32_t rxbuf
Definition: at32f413_sdio.h:463
sdio_type::hfcen
__IO uint32_t hfcen
Definition: at32f413_sdio.h:278
sdio_type::rxbufeien
__IO uint32_t rxbufeien
Definition: at32f413_sdio.h:521
sdio_type::tfrmode
__IO uint32_t tfrmode
Definition: at32f413_sdio.h:410
sdio_type::cmdtimeout
__IO uint32_t cmdtimeout
Definition: at32f413_sdio.h:444
sdio_type::clkegs
__IO uint32_t clkegs
Definition: at32f413_sdio.h:277
sdio_type::cmdcmplien
__IO uint32_t cmdcmplien
Definition: at32f413_sdio.h:509
sdio_type::cmdcmpl
__IO uint32_t cmdcmpl
Definition: at32f413_sdio.h:449
sdio_type::dtfailien
__IO uint32_t dtfailien
Definition: at32f413_sdio.h:503
sdio_type::rxbufhien
__IO uint32_t rxbufhien
Definition: at32f413_sdio.h:517
sdio_type::tfrdir
__IO uint32_t tfrdir
Definition: at32f413_sdio.h:409
sdio_type::tfren
__IO uint32_t tfren
Definition: at32f413_sdio.h:408
sdio_type::dttmr
__IO uint32_t dttmr
Definition: at32f413_sdio.h:380
sdio_type::reserved1
__IO uint32_t reserved1
sdio reserved1 register, offset:0x40~0x44
Definition: at32f413_sdio.h:260
sdio_type::cnt
__IO uint32_t cnt
Definition: at32f413_sdio.h:429
sdio_type::cardsts4
__IO uint32_t cardsts4
Definition: at32f413_sdio.h:371
sdio_type::cmdfail
__IO uint32_t cmdfail
Definition: at32f413_sdio.h:442
sdio_type::txbufhien
__IO uint32_t txbufhien
Definition: at32f413_sdio.h:516
sdio_type::txbuffien
__IO uint32_t txbuffien
Definition: at32f413_sdio.h:518
sdio_type::rxbufe
__IO uint32_t rxbufe
Definition: at32f413_sdio.h:461
sdio_type::dtblkcmpl
__IO uint32_t dtblkcmpl
Definition: at32f413_sdio.h:452
sdio_type::inten
__IO uint32_t inten
Definition: at32f413_sdio.h:499
sdio_type::dtcmpl
__IO uint32_t dtcmpl
Definition: at32f413_sdio.h:450
sdio_type::docmd
__IO uint32_t docmd
Definition: at32f413_sdio.h:453
sdio_type::pndwt
__IO uint32_t pndwt
Definition: at32f413_sdio.h:307
sdio_type::cmdctrl
__IO uint32_t cmdctrl
Definition: at32f413_sdio.h:301
sdio_type::dtcmplien
__IO uint32_t dtcmplien
Definition: at32f413_sdio.h:510
sdio_type::clkoen
__IO uint32_t clkoen
Definition: at32f413_sdio.h:273
sdio_type::ioen
__IO uint32_t ioen
Definition: at32f413_sdio.h:416
sdio_type::bufcnt
__IO uint32_t bufcnt
Definition: at32f413_sdio.h:539
sdio_type::intwt
__IO uint32_t intwt
Definition: at32f413_sdio.h:306
sdio_type::rsp2
__IO uint32_t rsp2
Definition: at32f413_sdio.h:344
sdio_type::dtctrl
__IO uint32_t dtctrl
Definition: at32f413_sdio.h:405
sdio_type::dtfail
__IO uint32_t dtfail
Definition: at32f413_sdio.h:443
sdio_type::docmdien
__IO uint32_t docmdien
Definition: at32f413_sdio.h:513
sdio_type::dotxien
__IO uint32_t dotxien
Definition: at32f413_sdio.h:514
sdio_type::dotx
__IO uint32_t dotx
Definition: at32f413_sdio.h:454
sdio_type::rxerroien
__IO uint32_t rxerroien
Definition: at32f413_sdio.h:507
sdio_type::ccsmen
__IO uint32_t ccsmen
Definition: at32f413_sdio.h:308
sdio_type::txerruien
__IO uint32_t txerruien
Definition: at32f413_sdio.h:506
sdio_type::dttimeoutien
__IO uint32_t dttimeoutien
Definition: at32f413_sdio.h:505
sdio_type::pwrsven
__IO uint32_t pwrsven
Definition: at32f413_sdio.h:274
sdio_type::cmdidx
__IO uint32_t cmdidx
Definition: at32f413_sdio.h:304
sdio_type::cardsts3
__IO uint32_t cardsts3
Definition: at32f413_sdio.h:359
sdio_type::cardsts1
__IO uint32_t cardsts1
Definition: at32f413_sdio.h:335
sdio_type::pwrctrl
__IO uint32_t pwrctrl
Definition: at32f413_sdio.h:256
sdio_type::ioifien
__IO uint32_t ioifien
Definition: at32f413_sdio.h:524
sdio_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_sdio.h:411
sdio_type::reserved2
__IO uint32_t reserved2
sdio reserved2 register, offset:0x4C~0x7C
Definition: at32f413_sdio.h:490
sdio_type::dtblkcmplien
__IO uint32_t dtblkcmplien
Definition: at32f413_sdio.h:512
sdio_type::rxbuffien
__IO uint32_t rxbuffien
Definition: at32f413_sdio.h:519
sdio_type::txbufh
__IO uint32_t txbufh
Definition: at32f413_sdio.h:456
sdio_type::sts
__IO uint32_t sts
Definition: at32f413_sdio.h:439
sdio_type::blksize
__IO uint32_t blksize
Definition: at32f413_sdio.h:412
sdio_type::cardsts2
__IO uint32_t cardsts2
Definition: at32f413_sdio.h:347
sdio_type::rdwtmode
__IO uint32_t rdwtmode
Definition: at32f413_sdio.h:415
sdio_type::txbufeien
__IO uint32_t txbufeien
Definition: at32f413_sdio.h:520
sdio_type::ioif
__IO uint32_t ioif
Definition: at32f413_sdio.h:464
sdio_type::cmdrspcmplien
__IO uint32_t cmdrspcmplien
Definition: at32f413_sdio.h:508
sdio_type::rxbufien
__IO uint32_t rxbufien
Definition: at32f413_sdio.h:523
sdio_type::dttimeout
__IO uint32_t dttimeout
Definition: at32f413_sdio.h:445
sdio_type::rxbufh
__IO uint32_t rxbufh
Definition: at32f413_sdio.h:457
sdio_type::txbufien
__IO uint32_t txbufien
Definition: at32f413_sdio.h:522
sdio_type::rsp1
__IO uint32_t rsp1
Definition: at32f413_sdio.h:332
sdio_type::rxbuff
__IO uint32_t rxbuff
Definition: at32f413_sdio.h:459
sdio_type::rsp4
__IO uint32_t rsp4
Definition: at32f413_sdio.h:368
sdio_type::bypsen
__IO uint32_t bypsen
Definition: at32f413_sdio.h:275
sdio_type::txbufe
__IO uint32_t txbufe
Definition: at32f413_sdio.h:460
sdio_type::cmdfailien
__IO uint32_t cmdfailien
Definition: at32f413_sdio.h:502
sdio_type::buf
__IO uint32_t buf
Definition: at32f413_sdio.h:557
sdio_type::clkdiv_l
__IO uint32_t clkdiv_l
Definition: at32f413_sdio.h:272
sdio_type::txerru
__IO uint32_t txerru
Definition: at32f413_sdio.h:446
sdio_type::dorxien
__IO uint32_t dorxien
Definition: at32f413_sdio.h:515
sdio_type::dt
__IO uint32_t dt
Definition: at32f413_sdio.h:560
sdio_type::rspcmd
__IO uint32_t rspcmd
Definition: at32f413_sdio.h:319
sdio_type::argu
__IO uint32_t argu
Definition: at32f413_sdio.h:289
sdio_type::timeout
__IO uint32_t timeout
Definition: at32f413_sdio.h:383
sdio_type::cmdtimeoutien
__IO uint32_t cmdtimeoutien
Definition: at32f413_sdio.h:504
sdio_type::busws
__IO uint32_t busws
Definition: at32f413_sdio.h:276
sdio_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_sdio.h:426
sdio_type::clkdiv_h
__IO uint32_t clkdiv_h
Definition: at32f413_sdio.h:279
sdio_type::iosusp
__IO uint32_t iosusp
Definition: at32f413_sdio.h:309
sdio_type::txbuff
__IO uint32_t txbuff
Definition: at32f413_sdio.h:458
sdio_type::cmdrspcmpl
__IO uint32_t cmdrspcmpl
Definition: at32f413_sdio.h:448
sdio_type::txbuf
__IO uint32_t txbuf
Definition: at32f413_sdio.h:462
sdio_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f413_sdio.h:269
sdio_type::sbiterrien
__IO uint32_t sbiterrien
Definition: at32f413_sdio.h:511
sdio_type::rsp3
__IO uint32_t rsp3
Definition: at32f413_sdio.h:356
sdio_type::rxerro
__IO uint32_t rxerro
Definition: at32f413_sdio.h:447


AT32F413 Firmwary Library: at32f413_spi.c Source File

  • libraries
  • drivers
  • src
at32f413_spi.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef SPI_MODULE_ENABLED
37
49void spi_i2s_reset(spi_type *spi_x)
50{
51 if(spi_x == SPI1)
52 {
53 crm_periph_reset(CRM_SPI1_PERIPH_RESET, TRUE);
54 crm_periph_reset(CRM_SPI1_PERIPH_RESET, FALSE);
55 }
56 else if(spi_x == SPI2)
57 {
58 crm_periph_reset(CRM_SPI2_PERIPH_RESET, TRUE);
59 crm_periph_reset(CRM_SPI2_PERIPH_RESET, FALSE);
60 }
61}
62
69void spi_default_para_init(spi_init_type* spi_init_struct)
70{
71 spi_init_struct->transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
72 spi_init_struct->master_slave_mode = SPI_MODE_SLAVE;
73 spi_init_struct->mclk_freq_division = SPI_MCLK_DIV_2;
74 spi_init_struct->first_bit_transmission = SPI_FIRST_BIT_MSB;
75 spi_init_struct->frame_bit_num = SPI_FRAME_8BIT;
76 spi_init_struct->clock_polarity = SPI_CLOCK_POLARITY_LOW;
77 spi_init_struct->clock_phase = SPI_CLOCK_PHASE_1EDGE;
78 spi_init_struct->cs_mode_selection = SPI_CS_SOFTWARE_MODE;
79}
80
89void spi_init(spi_type* spi_x, spi_init_type* spi_init_struct)
90{
91 spi_x->i2sctrl_bit.i2smsel = FALSE;
92 if(spi_init_struct->transmission_mode == SPI_TRANSMIT_FULL_DUPLEX)
93 {
94 spi_x->ctrl1_bit.slben = FALSE;
95 spi_x->ctrl1_bit.slbtd = FALSE;
96 spi_x->ctrl1_bit.ora = FALSE;
97 }
98 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_SIMPLEX_RX)
99 {
100 spi_x->ctrl1_bit.slben = FALSE;
101 spi_x->ctrl1_bit.slbtd = FALSE;
102 spi_x->ctrl1_bit.ora = TRUE;
103 }
104 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_HALF_DUPLEX_RX)
105 {
106 spi_x->ctrl1_bit.slben = TRUE;
107 spi_x->ctrl1_bit.slbtd = FALSE;
108 spi_x->ctrl1_bit.ora = FALSE;
109 }
110 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_HALF_DUPLEX_TX)
111 {
112 spi_x->ctrl1_bit.slben = TRUE;
113 spi_x->ctrl1_bit.slbtd = TRUE;
114 spi_x->ctrl1_bit.ora = FALSE;
115 }
116
117 spi_x->ctrl1_bit.swcsen = spi_init_struct->cs_mode_selection;
118 if((spi_init_struct->master_slave_mode == SPI_MODE_MASTER) && (spi_init_struct->cs_mode_selection == SPI_CS_SOFTWARE_MODE))
119 {
120 spi_x->ctrl1_bit.swcsil = TRUE;
121 }
122 else
123 {
124 spi_x->ctrl1_bit.swcsil = FALSE;
125 }
126 spi_x->ctrl1_bit.msten = spi_init_struct->master_slave_mode;
127 if(spi_init_struct->mclk_freq_division > SPI_MCLK_DIV_256)
128 {
129 spi_x->ctrl2_bit.mdiv_h = 1;
130 spi_x->ctrl1_bit.mdiv_l = spi_init_struct->mclk_freq_division & 0x7;
131 }
132 else
133 {
134 spi_x->ctrl2_bit.mdiv_h = 0;
135 spi_x->ctrl1_bit.mdiv_l = spi_init_struct->mclk_freq_division;
136 }
137 spi_x->ctrl1_bit.ltf = spi_init_struct->first_bit_transmission;
138 spi_x->ctrl1_bit.fbn = spi_init_struct->frame_bit_num;
139 spi_x->ctrl1_bit.clkpol = spi_init_struct->clock_polarity;
140 spi_x->ctrl1_bit.clkpha = spi_init_struct->clock_phase;
141}
142
150void spi_crc_next_transmit(spi_type* spi_x)
151{
152 spi_x->ctrl1_bit.ntc = TRUE;
153}
154
163void spi_crc_polynomial_set(spi_type* spi_x, uint16_t crc_poly)
164{
165 spi_x->cpoly_bit.cpoly = crc_poly;
166}
167
175uint16_t spi_crc_polynomial_get(spi_type* spi_x)
176{
177 return spi_x->cpoly_bit.cpoly;
178}
179
189void spi_crc_enable(spi_type* spi_x, confirm_state new_state)
190{
191 spi_x->ctrl1_bit.ccen = new_state;
192}
193
204uint16_t spi_crc_value_get(spi_type* spi_x, spi_crc_direction_type crc_direction)
205{
206 if(crc_direction == SPI_CRC_RX)
207 return spi_x->rcrc_bit.rcrc;
208 else
209 return spi_x->tcrc_bit.tcrc;
210}
211
222void spi_hardware_cs_output_enable(spi_type* spi_x, confirm_state new_state)
223{
224 spi_x->ctrl2_bit.hwcsoe = new_state;
225}
226
240void spi_software_cs_internal_level_set(spi_type* spi_x, spi_software_cs_level_type level)
241{
242 spi_x->ctrl1_bit.swcsil = level;
243}
244
255void spi_frame_bit_num_set(spi_type* spi_x, spi_frame_bit_num_type bit_num)
256{
257 spi_x->ctrl1_bit.fbn = bit_num;
258}
259
271void spi_half_duplex_direction_set(spi_type* spi_x, spi_half_duplex_direction_type direction)
272{
273 spi_x->ctrl1_bit.slbtd = direction;
274}
275
285void spi_enable(spi_type* spi_x, confirm_state new_state)
286{
287 spi_x->ctrl1_bit.spien = new_state;
288}
289
296void i2s_default_para_init(i2s_init_type* i2s_init_struct)
297{
298 i2s_init_struct->operation_mode = I2S_MODE_SLAVE_TX;
299 i2s_init_struct->audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
300 i2s_init_struct->audio_sampling_freq = I2S_AUDIO_FREQUENCY_DEFAULT;
301 i2s_init_struct->data_channel_format = I2S_DATA_16BIT_CHANNEL_16BIT;
302 i2s_init_struct->clock_polarity = I2S_CLOCK_POLARITY_LOW;
303 i2s_init_struct->mclk_output_enable = FALSE;
304}
305
314void i2s_init(spi_type* spi_x, i2s_init_type* i2s_init_struct)
315{
316 crm_clocks_freq_type clocks_freq;
317 uint32_t i2s_sclk_index = 0;
318 uint32_t i2sdiv_index = 2, i2sodd_index = 0, frequency_index = 0;
319
320 /* i2s audio frequency config */
321 if(i2s_init_struct->audio_sampling_freq == I2S_AUDIO_FREQUENCY_DEFAULT)
322 {
323 i2sodd_index = 0;
324 i2sdiv_index = 2;
325 }
326 else
327 {
328 crm_clocks_freq_get(&clocks_freq);
329 i2s_sclk_index = clocks_freq.sclk_freq;
330 if((i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_SHORT) || (i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_LONG))
331 {
332 if(i2s_init_struct->mclk_output_enable == TRUE)
333 {
334 frequency_index = (((i2s_sclk_index / 128) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
335 }
336 else
337 {
338 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
339 frequency_index = (((i2s_sclk_index / 16) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
340 else
341 frequency_index = (((i2s_sclk_index / 32) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
342 }
343 }
344 else
345 {
346 if(i2s_init_struct->mclk_output_enable == TRUE)
347 {
348 frequency_index = (((i2s_sclk_index / 256) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
349 }
350 else
351 {
352 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
353 frequency_index = (((i2s_sclk_index / 32) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
354 else
355 frequency_index = (((i2s_sclk_index / 64) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
356 }
357 }
358 }
359 frequency_index = frequency_index / 10;
360 i2sodd_index = frequency_index & (uint16_t)0x0001;
361 i2sdiv_index = (frequency_index - i2sodd_index) / 2;
362 if((i2sdiv_index < 2) || (i2sdiv_index > 0x03FF))
363 {
364 i2sodd_index = 0;
365 i2sdiv_index = 2;
366 }
367 spi_x->i2sclk_bit.i2sodd = i2sodd_index;
368 if(i2sdiv_index > 0x00FF)
369 {
370 spi_x->i2sclk_bit.i2sdiv_h = (i2sdiv_index >> 8) & 0x0003;
371 spi_x->i2sclk_bit.i2sdiv_l = i2sdiv_index & 0x00FF;
372 }
373 else
374 {
375 spi_x->i2sclk_bit.i2sdiv_h = 0;
376 spi_x->i2sclk_bit.i2sdiv_l = i2sdiv_index;
377 }
378
379 /* i2s audio_protocol set*/
380 if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_LONG)
381 {
382 spi_x->i2sctrl_bit.pcmfssel = 1;
383 spi_x->i2sctrl_bit.stdsel = 3;
384 }
385 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_SHORT)
386 {
387 spi_x->i2sctrl_bit.pcmfssel = 0;
388 spi_x->i2sctrl_bit.stdsel = 3;
389 }
390 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_LSB)
391 {
392 spi_x->i2sctrl_bit.pcmfssel = 0;
393 spi_x->i2sctrl_bit.stdsel = 2;
394 }
395 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_MSB)
396 {
397 spi_x->i2sctrl_bit.pcmfssel = 0;
398 spi_x->i2sctrl_bit.stdsel = 1;
399 }
400 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PHILLIPS)
401 {
402 spi_x->i2sctrl_bit.pcmfssel = 0;
403 spi_x->i2sctrl_bit.stdsel = 0;
404 }
405
406 /* i2s data_channel_format set*/
407 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
408 {
409 spi_x->i2sctrl_bit.i2scbn = 0;
410 spi_x->i2sctrl_bit.i2sdbn = 0;
411 }
412 else if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_32BIT)
413 {
414 spi_x->i2sctrl_bit.i2scbn = 1;
415 spi_x->i2sctrl_bit.i2sdbn = 0;
416 }
417 else if(i2s_init_struct->data_channel_format == I2S_DATA_24BIT_CHANNEL_32BIT)
418 {
419 spi_x->i2sctrl_bit.i2scbn = 1;
420 spi_x->i2sctrl_bit.i2sdbn = 1;
421 }
422 else if(i2s_init_struct->data_channel_format == I2S_DATA_32BIT_CHANNEL_32BIT)
423 {
424 spi_x->i2sctrl_bit.i2scbn = 1;
425 spi_x->i2sctrl_bit.i2sdbn = 2;
426 }
427
428 spi_x->i2sctrl_bit.i2sclkpol = i2s_init_struct->clock_polarity;
429 spi_x->i2sclk_bit.i2smclkoe = i2s_init_struct->mclk_output_enable;
430 spi_x->i2sctrl_bit.opersel = i2s_init_struct->operation_mode;
431 spi_x->i2sctrl_bit.i2smsel = TRUE;
432}
433
443void i2s_enable(spi_type* spi_x, confirm_state new_state)
444{
445 spi_x->i2sctrl_bit.i2sen = new_state;
446}
447
462void spi_i2s_interrupt_enable(spi_type* spi_x, uint32_t spi_i2s_int, confirm_state new_state)
463{
464 if(new_state != FALSE)
465 {
466 spi_x->ctrl2 |= spi_i2s_int;
467 }
468 else
469 {
470 spi_x->ctrl2 &= ~spi_i2s_int;
471 }
472}
473
483void spi_i2s_dma_transmitter_enable(spi_type* spi_x, confirm_state new_state)
484{
485 spi_x->ctrl2_bit.dmaten = new_state;
486}
487
497void spi_i2s_dma_receiver_enable(spi_type* spi_x, confirm_state new_state)
498{
499 spi_x->ctrl2_bit.dmaren = new_state;
500}
501
512void spi_i2s_data_transmit(spi_type* spi_x, uint16_t tx_data)
513{
514 spi_x->dt = tx_data;
515}
516
524uint16_t spi_i2s_data_receive(spi_type* spi_x)
525{
526 return (uint16_t)spi_x->dt;
527}
528
546 flag_status spi_i2s_flag_get(spi_type* spi_x, uint32_t spi_i2s_flag)
547{
548 flag_status status = RESET;
549 if ((spi_x->sts & spi_i2s_flag) == RESET)
550 {
551 status = RESET;
552 }
553 else
554 {
555 status = SET;
556 }
557 return status;
558}
559
578void spi_i2s_flag_clear(spi_type* spi_x, uint32_t spi_i2s_flag)
579{
580 if(spi_i2s_flag == SPI_CCERR_FLAG)
581 spi_x->sts = ~SPI_CCERR_FLAG;
582 else if(spi_i2s_flag == SPI_I2S_RDBF_FLAG)
583 UNUSED(spi_x->dt);
584 else if(spi_i2s_flag == I2S_TUERR_FLAG)
585 UNUSED(spi_x->sts);
586 else if(spi_i2s_flag == SPI_MMERR_FLAG)
587 {
588 UNUSED(spi_x->sts);
589 spi_x->ctrl1 = spi_x->ctrl1;
590 }
591 else if(spi_i2s_flag == SPI_I2S_ROERR_FLAG)
592 {
593 UNUSED(spi_x->dt);
594 UNUSED(spi_x->sts);
595 }
596}
597
602#endif
603
UNUSED
#define UNUSED(x)
Definition: at32f413_def.h:63
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_SPI1_PERIPH_RESET
@ CRM_SPI1_PERIPH_RESET
Definition: at32f413_crm.h:160
CRM_SPI2_PERIPH_RESET
@ CRM_SPI2_PERIPH_RESET
Definition: at32f413_crm.h:173
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
I2S_TUERR_FLAG
#define I2S_TUERR_FLAG
Definition: at32f413_spi.h:54
SPI_CCERR_FLAG
#define SPI_CCERR_FLAG
Definition: at32f413_spi.h:55
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
SPI_MMERR_FLAG
#define SPI_MMERR_FLAG
Definition: at32f413_spi.h:56
SPI_I2S_ROERR_FLAG
#define SPI_I2S_ROERR_FLAG
Definition: at32f413_spi.h:57
spi_software_cs_level_type
spi_software_cs_level_type
spi software cs internal level type
Definition: at32f413_spi.h:186
spi_half_duplex_direction_type
spi_half_duplex_direction_type
spi single line bidirectional direction type
Definition: at32f413_spi.h:177
spi_frame_bit_num_type
spi_frame_bit_num_type
spi frame bit num type
Definition: at32f413_spi.h:86
spi_crc_direction_type
spi_crc_direction_type
spi crc direction type
Definition: at32f413_spi.h:168
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:247
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:225
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:227
I2S_DATA_32BIT_CHANNEL_32BIT
@ I2S_DATA_32BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:228
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:226
SPI_CLOCK_PHASE_1EDGE
@ SPI_CLOCK_PHASE_1EDGE
Definition: at32f413_spi.h:114
I2S_AUDIO_FREQUENCY_DEFAULT
@ I2S_AUDIO_FREQUENCY_DEFAULT
Definition: at32f413_spi.h:208
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:158
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:161
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:159
I2S_AUDIO_PROTOCOL_PCM_LONG
@ I2S_AUDIO_PROTOCOL_PCM_LONG
Definition: at32f413_spi.h:200
I2S_AUDIO_PROTOCOL_LSB
@ I2S_AUDIO_PROTOCOL_LSB
Definition: at32f413_spi.h:198
I2S_AUDIO_PROTOCOL_MSB
@ I2S_AUDIO_PROTOCOL_MSB
Definition: at32f413_spi.h:197
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:196
I2S_AUDIO_PROTOCOL_PCM_SHORT
@ I2S_AUDIO_PROTOCOL_PCM_SHORT
Definition: at32f413_spi.h:199
SPI_MCLK_DIV_2
@ SPI_MCLK_DIV_2
Definition: at32f413_spi.h:132
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f413_spi.h:139
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI_CRC_RX
@ SPI_CRC_RX
Definition: at32f413_spi.h:169
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:236
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:314
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f413_spi.c:189
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:497
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:443
spi_crc_polynomial_get
uint16_t spi_crc_polynomial_get(spi_type *spi_x)
return the crc polynomial register value for the spi peripheral.
Definition: at32f413_spi.c:175
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f413_spi.c:150
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f413_spi.c:163
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_crc_value_get
uint16_t spi_crc_value_get(spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral.
Definition: at32f413_spi.c:204
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:49
spi_half_duplex_direction_set
void spi_half_duplex_direction_set(spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi periphera...
Definition: at32f413_spi.c:271
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f413_spi.c:222
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:578
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:296
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:483
spi_frame_bit_num_set
void spi_frame_bit_num_set(spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral.
Definition: at32f413_spi.c:255
spi_software_cs_internal_level_set
void spi_software_cs_internal_level_set(spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral.
Definition: at32f413_spi.c:240
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
i2s_init_type
i2s init type
Definition: at32f413_spi.h:270
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:273
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:274
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:276
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:272
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:271
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:275
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
spi_type
type define spi register all
Definition: at32f413_spi.h:283
spi_type::i2sctrl_bit
struct spi_type::@638::@649 i2sctrl_bit
spi_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_spi.h:293
spi_type::hwcsoe
__IO uint32_t hwcsoe
Definition: at32f413_spi.h:321
spi_type::slben
__IO uint32_t slben
Definition: at32f413_spi.h:306
spi_type::ntc
__IO uint32_t ntc
Definition: at32f413_spi.h:303
spi_type::mdiv_h
__IO uint32_t mdiv_h
Definition: at32f413_spi.h:326
spi_type::ctrl2_bit
struct spi_type::@626::@643 ctrl2_bit
spi_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_spi.h:319
spi_type::i2sdbn
__IO uint32_t i2sdbn
Definition: at32f413_spi.h:412
spi_type::ctrl1_bit
struct spi_type::@624::@642 ctrl1_bit
spi_type::rcrc
__IO uint32_t rcrc
Definition: at32f413_spi.h:382
spi_type::i2scbn
__IO uint32_t i2scbn
Definition: at32f413_spi.h:411
spi_type::i2sclkpol
__IO uint32_t i2sclkpol
Definition: at32f413_spi.h:413
spi_type::cpoly
__IO uint32_t cpoly
Definition: at32f413_spi.h:369
spi_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_spi.h:290
spi_type::i2sodd
__IO uint32_t i2sodd
Definition: at32f413_spi.h:433
spi_type::swcsil
__IO uint32_t swcsil
Definition: at32f413_spi.h:299
spi_type::tcrc
__IO uint32_t tcrc
Definition: at32f413_spi.h:395
spi_type::i2smclkoe
__IO uint32_t i2smclkoe
Definition: at32f413_spi.h:434
spi_type::ltf
__IO uint32_t ltf
Definition: at32f413_spi.h:298
spi_type::i2sclk_bit
struct spi_type::@640::@650 i2sclk_bit
spi_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_spi.h:294
spi_type::slbtd
__IO uint32_t slbtd
Definition: at32f413_spi.h:305
spi_type::tcrc_bit
struct spi_type::@636::@648 tcrc_bit
spi_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_spi.h:320
spi_type::ccen
__IO uint32_t ccen
Definition: at32f413_spi.h:304
spi_type::fbn
__IO uint32_t fbn
Definition: at32f413_spi.h:302
spi_type::dt
__IO uint32_t dt
Definition: at32f413_spi.h:356
spi_type::msten
__IO uint32_t msten
Definition: at32f413_spi.h:295
spi_type::sts
__IO uint32_t sts
Definition: at32f413_spi.h:336
spi_type::cpoly_bit
struct spi_type::@632::@646 cpoly_bit
spi_type::i2sdiv_h
__IO uint32_t i2sdiv_h
Definition: at32f413_spi.h:435
spi_type::opersel
__IO uint32_t opersel
Definition: at32f413_spi.h:417
spi_type::i2sdiv_l
__IO uint32_t i2sdiv_l
Definition: at32f413_spi.h:432
spi_type::i2smsel
__IO uint32_t i2smsel
Definition: at32f413_spi.h:419
spi_type::pcmfssel
__IO uint32_t pcmfssel
Definition: at32f413_spi.h:416
spi_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_spi.h:316
spi_type::rcrc_bit
struct spi_type::@634::@647 rcrc_bit
spi_type::stdsel
__IO uint32_t stdsel
Definition: at32f413_spi.h:414
spi_type::mdiv_l
__IO uint32_t mdiv_l
Definition: at32f413_spi.h:296
spi_type::spien
__IO uint32_t spien
Definition: at32f413_spi.h:297
spi_type::swcsen
__IO uint32_t swcsen
Definition: at32f413_spi.h:300
spi_type::ora
__IO uint32_t ora
Definition: at32f413_spi.h:301
spi_type::i2sen
__IO uint32_t i2sen
Definition: at32f413_spi.h:418
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_spi.h Source File

  • libraries
  • drivers
  • inc
at32f413_spi.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_SPI_H
27#define __AT32F413_SPI_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
51#define SPI_I2S_RDBF_FLAG 0x0001
52#define SPI_I2S_TDBE_FLAG 0x0002
53#define I2S_ACS_FLAG 0x0004
54#define I2S_TUERR_FLAG 0x0008
55#define SPI_CCERR_FLAG 0x0010
56#define SPI_MMERR_FLAG 0x0020
57#define SPI_I2S_ROERR_FLAG 0x0040
58#define SPI_I2S_BF_FLAG 0x0080
70#define SPI_I2S_ERROR_INT 0x0020
71#define SPI_I2S_RDBF_INT 0x0040
72#define SPI_I2S_TDBE_INT 0x0080
85typedef enum
86{
87 SPI_FRAME_8BIT = 0x00,
88 SPI_FRAME_16BIT = 0x01
89} spi_frame_bit_num_type;
90
94typedef enum
95{
96 SPI_MODE_SLAVE = 0x00,
97 SPI_MODE_MASTER = 0x01
98} spi_master_slave_mode_type;
99
103typedef enum
104{
105 SPI_CLOCK_POLARITY_LOW = 0x00,
106 SPI_CLOCK_POLARITY_HIGH = 0x01
107} spi_clock_polarity_type;
108
112typedef enum
113{
114 SPI_CLOCK_PHASE_1EDGE = 0x00,
115 SPI_CLOCK_PHASE_2EDGE = 0x01
116} spi_clock_phase_type;
117
121typedef enum
122{
123 SPI_CS_HARDWARE_MODE = 0x00,
124 SPI_CS_SOFTWARE_MODE = 0x01
125} spi_cs_mode_type;
126
130typedef enum
131{
132 SPI_MCLK_DIV_2 = 0x00,
133 SPI_MCLK_DIV_4 = 0x01,
134 SPI_MCLK_DIV_8 = 0x02,
135 SPI_MCLK_DIV_16 = 0x03,
136 SPI_MCLK_DIV_32 = 0x04,
137 SPI_MCLK_DIV_64 = 0x05,
138 SPI_MCLK_DIV_128 = 0x06,
139 SPI_MCLK_DIV_256 = 0x07,
140 SPI_MCLK_DIV_512 = 0x08,
141 SPI_MCLK_DIV_1024 = 0x09
142} spi_mclk_freq_div_type;
143
147typedef enum
148{
149 SPI_FIRST_BIT_MSB = 0x00,
150 SPI_FIRST_BIT_LSB = 0x01
151} spi_first_bit_type;
152
156typedef enum
157{
158 SPI_TRANSMIT_FULL_DUPLEX = 0x00,
159 SPI_TRANSMIT_SIMPLEX_RX = 0x01,
160 SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02,
161 SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03
162} spi_transmission_mode_type;
163
167typedef enum
168{
169 SPI_CRC_RX = 0x0014,
170 SPI_CRC_TX = 0x0018
171} spi_crc_direction_type;
172
176typedef enum
177{
178 SPI_HALF_DUPLEX_DIRECTION_RX = 0x00,
179 SPI_HALF_DUPLEX_DIRECTION_TX = 0x01
180} spi_half_duplex_direction_type;
181
185typedef enum
186{
187 SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00,
188 SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01
189} spi_software_cs_level_type;
190
194typedef enum
195{
196 I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00,
197 I2S_AUDIO_PROTOCOL_MSB = 0x01,
198 I2S_AUDIO_PROTOCOL_LSB = 0x02,
199 I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03,
200 I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
201} i2s_audio_protocol_type;
202
206typedef enum
207{
208 I2S_AUDIO_FREQUENCY_DEFAULT = 2,
209 I2S_AUDIO_FREQUENCY_8K = 8000,
210 I2S_AUDIO_FREQUENCY_11_025K = 11025,
211 I2S_AUDIO_FREQUENCY_16K = 16000,
212 I2S_AUDIO_FREQUENCY_22_05K = 22050,
213 I2S_AUDIO_FREQUENCY_32K = 32000,
214 I2S_AUDIO_FREQUENCY_44_1K = 44100,
215 I2S_AUDIO_FREQUENCY_48K = 48000,
216 I2S_AUDIO_FREQUENCY_96K = 96000,
217 I2S_AUDIO_FREQUENCY_192K = 192000
218} i2s_audio_sampling_freq_type;
219
223typedef enum
224{
225 I2S_DATA_16BIT_CHANNEL_16BIT = 0x01,
226 I2S_DATA_16BIT_CHANNEL_32BIT = 0x02,
227 I2S_DATA_24BIT_CHANNEL_32BIT = 0x03,
228 I2S_DATA_32BIT_CHANNEL_32BIT = 0x04
229} i2s_data_channel_format_type;
230
234typedef enum
235{
236 I2S_MODE_SLAVE_TX = 0x00,
237 I2S_MODE_SLAVE_RX = 0x01,
238 I2S_MODE_MASTER_TX = 0x02,
239 I2S_MODE_MASTER_RX = 0x03
240} i2s_operation_mode_type;
241
245typedef enum
246{
247 I2S_CLOCK_POLARITY_LOW = 0x00,
248 I2S_CLOCK_POLARITY_HIGH = 0x01
249} i2s_clock_polarity_type;
250
254typedef struct
255{
256 spi_transmission_mode_type transmission_mode;
257 spi_master_slave_mode_type master_slave_mode;
258 spi_mclk_freq_div_type mclk_freq_division;
259 spi_first_bit_type first_bit_transmission;
260 spi_frame_bit_num_type frame_bit_num;
261 spi_clock_polarity_type clock_polarity;
262 spi_clock_phase_type clock_phase;
263 spi_cs_mode_type cs_mode_selection;
264} spi_init_type;
265
269typedef struct
270{
271 i2s_operation_mode_type operation_mode;
272 i2s_audio_protocol_type audio_protocol;
273 i2s_audio_sampling_freq_type audio_sampling_freq;
274 i2s_data_channel_format_type data_channel_format;
275 i2s_clock_polarity_type clock_polarity;
276 confirm_state mclk_output_enable;
277} i2s_init_type;
278
282typedef struct
283{
284
288 union
289 {
290 __IO uint32_t ctrl1;
291 struct
292 {
293 __IO uint32_t clkpha : 1; /* [0] */
294 __IO uint32_t clkpol : 1; /* [1] */
295 __IO uint32_t msten : 1; /* [2] */
296 __IO uint32_t mdiv_l : 3; /* [5:3] */
297 __IO uint32_t spien : 1; /* [6] */
298 __IO uint32_t ltf : 1; /* [7] */
299 __IO uint32_t swcsil : 1; /* [8] */
300 __IO uint32_t swcsen : 1; /* [9] */
301 __IO uint32_t ora : 1; /* [10] */
302 __IO uint32_t fbn : 1; /* [11] */
303 __IO uint32_t ntc : 1; /* [12] */
304 __IO uint32_t ccen : 1; /* [13] */
305 __IO uint32_t slbtd : 1; /* [14] */
306 __IO uint32_t slben : 1; /* [15] */
307 __IO uint32_t reserved1 : 16;/* [31:16] */
308 } ctrl1_bit;
309 };
310
314 union
315 {
316 __IO uint32_t ctrl2;
317 struct
318 {
319 __IO uint32_t dmaren : 1; /* [0] */
320 __IO uint32_t dmaten : 1; /* [1] */
321 __IO uint32_t hwcsoe : 1; /* [2] */
322 __IO uint32_t reserved1 : 2; /* [4:3] */
323 __IO uint32_t errie : 1; /* [5] */
324 __IO uint32_t rdbfie : 1; /* [6] */
325 __IO uint32_t tdbeie : 1; /* [7] */
326 __IO uint32_t mdiv_h : 1; /* [8] */
327 __IO uint32_t reserved2 : 23;/* [31:9] */
328 } ctrl2_bit;
329 };
330
334 union
335 {
336 __IO uint32_t sts;
337 struct
338 {
339 __IO uint32_t rdbf : 1; /* [0] */
340 __IO uint32_t tdbe : 1; /* [1] */
341 __IO uint32_t acs : 1; /* [2] */
342 __IO uint32_t tuerr : 1; /* [3] */
343 __IO uint32_t ccerr : 1; /* [4] */
344 __IO uint32_t mmerr : 1; /* [5] */
345 __IO uint32_t roerr : 1; /* [6] */
346 __IO uint32_t bf : 1; /* [7] */
347 __IO uint32_t reserved1 : 24;/* [31:8] */
348 } sts_bit;
349 };
350
354 union
355 {
356 __IO uint32_t dt;
357 struct
358 {
359 __IO uint32_t dt : 16;/* [15:0] */
360 __IO uint32_t reserved1 : 16;/* [31:16] */
361 } dt_bit;
362 };
363
367 union
368 {
369 __IO uint32_t cpoly;
370 struct
371 {
372 __IO uint32_t cpoly : 16;/* [15:0] */
373 __IO uint32_t reserved1 : 16;/* [31:16] */
374 } cpoly_bit;
375 };
376
380 union
381 {
382 __IO uint32_t rcrc;
383 struct
384 {
385 __IO uint32_t rcrc : 16;/* [15:0] */
386 __IO uint32_t reserved1 : 16;/* [31:16] */
387 } rcrc_bit;
388 };
389
393 union
394 {
395 __IO uint32_t tcrc;
396 struct
397 {
398 __IO uint32_t tcrc : 16;/* [15:0] */
399 __IO uint32_t reserved1 : 16;/* [31:16] */
400 } tcrc_bit;
401 };
402
406 union
407 {
408 __IO uint32_t i2sctrl;
409 struct
410 {
411 __IO uint32_t i2scbn : 1; /* [0] */
412 __IO uint32_t i2sdbn : 2; /* [2:1] */
413 __IO uint32_t i2sclkpol : 1; /* [3] */
414 __IO uint32_t stdsel : 2; /* [5:4] */
415 __IO uint32_t reserved1 : 1; /* [6] */
416 __IO uint32_t pcmfssel : 1; /* [7] */
417 __IO uint32_t opersel : 2; /* [9:8] */
418 __IO uint32_t i2sen : 1; /* [10] */
419 __IO uint32_t i2smsel : 1; /* [11] */
420 __IO uint32_t reserved2 : 20;/* [31:12] */
421 } i2sctrl_bit;
422 };
423
427 union
428 {
429 __IO uint32_t i2sclk;
430 struct
431 {
432 __IO uint32_t i2sdiv_l : 8; /* [7:0] */
433 __IO uint32_t i2sodd : 1; /* [8] */
434 __IO uint32_t i2smclkoe : 1; /* [9] */
435 __IO uint32_t i2sdiv_h : 2; /* [11:10] */
436 __IO uint32_t reserved1 : 20;/* [31:12] */
437 } i2sclk_bit;
438 };
439
440} spi_type;
441
446#define SPI1 ((spi_type *) SPI1_BASE)
447#define SPI2 ((spi_type *) SPI2_BASE)
448
449
454void spi_i2s_reset(spi_type *spi_x);
455void spi_default_para_init(spi_init_type* spi_init_struct);
456void spi_init(spi_type* spi_x, spi_init_type* spi_init_struct);
457void spi_crc_next_transmit(spi_type* spi_x);
458void spi_crc_polynomial_set(spi_type* spi_x, uint16_t crc_poly);
459uint16_t spi_crc_polynomial_get(spi_type* spi_x);
460void spi_crc_enable(spi_type* spi_x, confirm_state new_state);
461uint16_t spi_crc_value_get(spi_type* spi_x, spi_crc_direction_type crc_direction);
462void spi_hardware_cs_output_enable(spi_type* spi_x, confirm_state new_state);
463void spi_software_cs_internal_level_set(spi_type* spi_x, spi_software_cs_level_type level);
464void spi_frame_bit_num_set(spi_type* spi_x, spi_frame_bit_num_type bit_num);
465void spi_half_duplex_direction_set(spi_type* spi_x, spi_half_duplex_direction_type direction);
466void spi_enable(spi_type* spi_x, confirm_state new_state);
467void i2s_default_para_init(i2s_init_type* i2s_init_struct);
468void i2s_init(spi_type* spi_x, i2s_init_type* i2s_init_struct);
469void i2s_enable(spi_type* spi_x, confirm_state new_state);
470void spi_i2s_interrupt_enable(spi_type* spi_x, uint32_t spi_i2s_int, confirm_state new_state);
471void spi_i2s_dma_transmitter_enable(spi_type* spi_x, confirm_state new_state);
472void spi_i2s_dma_receiver_enable(spi_type* spi_x, confirm_state new_state);
473void spi_i2s_data_transmit(spi_type* spi_x, uint16_t tx_data);
474uint16_t spi_i2s_data_receive(spi_type* spi_x);
475 flag_status spi_i2s_flag_get(spi_type* spi_x, uint32_t spi_i2s_flag);
476void spi_i2s_flag_clear(spi_type* spi_x, uint32_t spi_i2s_flag);
477
490#ifdef __cplusplus
491}
492#endif
493
494#endif
at32f413.h
at32f413 header file
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:314
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f413_spi.c:189
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:497
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:443
spi_crc_polynomial_get
uint16_t spi_crc_polynomial_get(spi_type *spi_x)
return the crc polynomial register value for the spi peripheral.
Definition: at32f413_spi.c:175
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f413_spi.c:150
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f413_spi.c:163
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_crc_value_get
uint16_t spi_crc_value_get(spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral.
Definition: at32f413_spi.c:204
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:49
spi_half_duplex_direction_set
void spi_half_duplex_direction_set(spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi periphera...
Definition: at32f413_spi.c:271
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f413_spi.c:222
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:578
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:296
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:483
spi_frame_bit_num_set
void spi_frame_bit_num_set(spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral.
Definition: at32f413_spi.c:255
spi_software_cs_internal_level_set
void spi_software_cs_internal_level_set(spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral.
Definition: at32f413_spi.c:240
i2s_clock_polarity_type
i2s_clock_polarity_type
i2s clock polarity type
Definition: at32f413_spi.h:246
spi_master_slave_mode_type
spi_master_slave_mode_type
spi master/slave mode type
Definition: at32f413_spi.h:95
spi_software_cs_level_type
spi_software_cs_level_type
spi software cs internal level type
Definition: at32f413_spi.h:186
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:224
spi_clock_phase_type
spi_clock_phase_type
spi clock phase (clkpha) type
Definition: at32f413_spi.h:113
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:207
spi_cs_mode_type
spi_cs_mode_type
spi cs mode type
Definition: at32f413_spi.h:122
spi_first_bit_type
spi_first_bit_type
spi transmit first bit (lsb/msb) type
Definition: at32f413_spi.h:148
spi_clock_polarity_type
spi_clock_polarity_type
spi clock polarity (clkpol) type
Definition: at32f413_spi.h:104
spi_half_duplex_direction_type
spi_half_duplex_direction_type
spi single line bidirectional direction type
Definition: at32f413_spi.h:177
spi_transmission_mode_type
spi_transmission_mode_type
spi transmission mode type
Definition: at32f413_spi.h:157
i2s_audio_protocol_type
i2s_audio_protocol_type
i2s audio protocol type
Definition: at32f413_spi.h:195
spi_mclk_freq_div_type
spi_mclk_freq_div_type
spi master clock frequency division type
Definition: at32f413_spi.h:131
spi_frame_bit_num_type
spi_frame_bit_num_type
spi frame bit num type
Definition: at32f413_spi.h:86
spi_crc_direction_type
spi_crc_direction_type
spi crc direction type
Definition: at32f413_spi.h:168
i2s_operation_mode_type
i2s_operation_mode_type
i2s operation mode type
Definition: at32f413_spi.h:235
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:247
I2S_CLOCK_POLARITY_HIGH
@ I2S_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:248
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_SWCS_INTERNAL_LEVEL_LOW
@ SPI_SWCS_INTERNAL_LEVEL_LOW
Definition: at32f413_spi.h:187
SPI_SWCS_INTERNAL_LEVEL_HIGHT
@ SPI_SWCS_INTERNAL_LEVEL_HIGHT
Definition: at32f413_spi.h:188
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:225
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:227
I2S_DATA_32BIT_CHANNEL_32BIT
@ I2S_DATA_32BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:228
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:226
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CLOCK_PHASE_1EDGE
@ SPI_CLOCK_PHASE_1EDGE
Definition: at32f413_spi.h:114
I2S_AUDIO_FREQUENCY_44_1K
@ I2S_AUDIO_FREQUENCY_44_1K
Definition: at32f413_spi.h:214
I2S_AUDIO_FREQUENCY_11_025K
@ I2S_AUDIO_FREQUENCY_11_025K
Definition: at32f413_spi.h:210
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:215
I2S_AUDIO_FREQUENCY_DEFAULT
@ I2S_AUDIO_FREQUENCY_DEFAULT
Definition: at32f413_spi.h:208
I2S_AUDIO_FREQUENCY_8K
@ I2S_AUDIO_FREQUENCY_8K
Definition: at32f413_spi.h:209
I2S_AUDIO_FREQUENCY_32K
@ I2S_AUDIO_FREQUENCY_32K
Definition: at32f413_spi.h:213
I2S_AUDIO_FREQUENCY_192K
@ I2S_AUDIO_FREQUENCY_192K
Definition: at32f413_spi.h:217
I2S_AUDIO_FREQUENCY_96K
@ I2S_AUDIO_FREQUENCY_96K
Definition: at32f413_spi.h:216
I2S_AUDIO_FREQUENCY_22_05K
@ I2S_AUDIO_FREQUENCY_22_05K
Definition: at32f413_spi.h:212
I2S_AUDIO_FREQUENCY_16K
@ I2S_AUDIO_FREQUENCY_16K
Definition: at32f413_spi.h:211
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_CS_HARDWARE_MODE
@ SPI_CS_HARDWARE_MODE
Definition: at32f413_spi.h:123
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:150
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:106
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_HALF_DUPLEX_DIRECTION_TX
@ SPI_HALF_DUPLEX_DIRECTION_TX
Definition: at32f413_spi.h:179
SPI_HALF_DUPLEX_DIRECTION_RX
@ SPI_HALF_DUPLEX_DIRECTION_RX
Definition: at32f413_spi.h:178
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:158
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:161
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:159
I2S_AUDIO_PROTOCOL_PCM_LONG
@ I2S_AUDIO_PROTOCOL_PCM_LONG
Definition: at32f413_spi.h:200
I2S_AUDIO_PROTOCOL_LSB
@ I2S_AUDIO_PROTOCOL_LSB
Definition: at32f413_spi.h:198
I2S_AUDIO_PROTOCOL_MSB
@ I2S_AUDIO_PROTOCOL_MSB
Definition: at32f413_spi.h:197
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:196
I2S_AUDIO_PROTOCOL_PCM_SHORT
@ I2S_AUDIO_PROTOCOL_PCM_SHORT
Definition: at32f413_spi.h:199
SPI_MCLK_DIV_16
@ SPI_MCLK_DIV_16
Definition: at32f413_spi.h:135
SPI_MCLK_DIV_64
@ SPI_MCLK_DIV_64
Definition: at32f413_spi.h:137
SPI_MCLK_DIV_128
@ SPI_MCLK_DIV_128
Definition: at32f413_spi.h:138
SPI_MCLK_DIV_4
@ SPI_MCLK_DIV_4
Definition: at32f413_spi.h:133
SPI_MCLK_DIV_512
@ SPI_MCLK_DIV_512
Definition: at32f413_spi.h:140
SPI_MCLK_DIV_32
@ SPI_MCLK_DIV_32
Definition: at32f413_spi.h:136
SPI_MCLK_DIV_2
@ SPI_MCLK_DIV_2
Definition: at32f413_spi.h:132
SPI_MCLK_DIV_1024
@ SPI_MCLK_DIV_1024
Definition: at32f413_spi.h:141
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f413_spi.h:139
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f413_spi.h:88
SPI_CRC_RX
@ SPI_CRC_RX
Definition: at32f413_spi.h:169
SPI_CRC_TX
@ SPI_CRC_TX
Definition: at32f413_spi.h:170
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:238
I2S_MODE_MASTER_RX
@ I2S_MODE_MASTER_RX
Definition: at32f413_spi.h:239
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:237
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:236
i2s_init_type
i2s init type
Definition: at32f413_spi.h:270
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:273
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:274
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:276
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:272
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:271
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:275
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
spi_type
type define spi register all
Definition: at32f413_spi.h:283
spi_type::tdbe
__IO uint32_t tdbe
Definition: at32f413_spi.h:340
spi_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_spi.h:293
spi_type::hwcsoe
__IO uint32_t hwcsoe
Definition: at32f413_spi.h:321
spi_type::slben
__IO uint32_t slben
Definition: at32f413_spi.h:306
spi_type::ntc
__IO uint32_t ntc
Definition: at32f413_spi.h:303
spi_type::mdiv_h
__IO uint32_t mdiv_h
Definition: at32f413_spi.h:326
spi_type::rdbfie
__IO uint32_t rdbfie
Definition: at32f413_spi.h:324
spi_type::mmerr
__IO uint32_t mmerr
Definition: at32f413_spi.h:344
spi_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_spi.h:319
spi_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_spi.h:327
spi_type::bf
__IO uint32_t bf
Definition: at32f413_spi.h:346
spi_type::i2sdbn
__IO uint32_t i2sdbn
Definition: at32f413_spi.h:412
spi_type::rcrc
__IO uint32_t rcrc
Definition: at32f413_spi.h:382
spi_type::errie
__IO uint32_t errie
Definition: at32f413_spi.h:323
spi_type::i2scbn
__IO uint32_t i2scbn
Definition: at32f413_spi.h:411
spi_type::i2sclkpol
__IO uint32_t i2sclkpol
Definition: at32f413_spi.h:413
spi_type::cpoly
__IO uint32_t cpoly
Definition: at32f413_spi.h:369
spi_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_spi.h:290
spi_type::i2sodd
__IO uint32_t i2sodd
Definition: at32f413_spi.h:433
spi_type::swcsil
__IO uint32_t swcsil
Definition: at32f413_spi.h:299
spi_type::i2sclk
__IO uint32_t i2sclk
Definition: at32f413_spi.h:429
spi_type::tcrc
__IO uint32_t tcrc
Definition: at32f413_spi.h:395
spi_type::acs
__IO uint32_t acs
Definition: at32f413_spi.h:341
spi_type::i2smclkoe
__IO uint32_t i2smclkoe
Definition: at32f413_spi.h:434
spi_type::ltf
__IO uint32_t ltf
Definition: at32f413_spi.h:298
spi_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_spi.h:294
spi_type::slbtd
__IO uint32_t slbtd
Definition: at32f413_spi.h:305
spi_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_spi.h:320
spi_type::ccen
__IO uint32_t ccen
Definition: at32f413_spi.h:304
spi_type::fbn
__IO uint32_t fbn
Definition: at32f413_spi.h:302
spi_type::dt
__IO uint32_t dt
Definition: at32f413_spi.h:356
spi_type::msten
__IO uint32_t msten
Definition: at32f413_spi.h:295
spi_type::ccerr
__IO uint32_t ccerr
Definition: at32f413_spi.h:343
spi_type::sts
__IO uint32_t sts
Definition: at32f413_spi.h:336
spi_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_spi.h:307
spi_type::i2sdiv_h
__IO uint32_t i2sdiv_h
Definition: at32f413_spi.h:435
spi_type::opersel
__IO uint32_t opersel
Definition: at32f413_spi.h:417
spi_type::i2sdiv_l
__IO uint32_t i2sdiv_l
Definition: at32f413_spi.h:432
spi_type::i2smsel
__IO uint32_t i2smsel
Definition: at32f413_spi.h:419
spi_type::pcmfssel
__IO uint32_t pcmfssel
Definition: at32f413_spi.h:416
spi_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_spi.h:316
spi_type::roerr
__IO uint32_t roerr
Definition: at32f413_spi.h:345
spi_type::i2sctrl
__IO uint32_t i2sctrl
Definition: at32f413_spi.h:408
spi_type::stdsel
__IO uint32_t stdsel
Definition: at32f413_spi.h:414
spi_type::rdbf
__IO uint32_t rdbf
Definition: at32f413_spi.h:339
spi_type::tuerr
__IO uint32_t tuerr
Definition: at32f413_spi.h:342
spi_type::mdiv_l
__IO uint32_t mdiv_l
Definition: at32f413_spi.h:296
spi_type::spien
__IO uint32_t spien
Definition: at32f413_spi.h:297
spi_type::swcsen
__IO uint32_t swcsen
Definition: at32f413_spi.h:300
spi_type::ora
__IO uint32_t ora
Definition: at32f413_spi.h:301
spi_type::i2sen
__IO uint32_t i2sen
Definition: at32f413_spi.h:418
spi_type::tdbeie
__IO uint32_t tdbeie
Definition: at32f413_spi.h:325


AT32F413 Firmwary Library: at32f413_tmr.c Source File

  • libraries
  • drivers
  • src
at32f413_tmr.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef TMR_MODULE_ENABLED
37
50void tmr_reset(tmr_type *tmr_x)
51{
52 if(tmr_x == TMR1)
53 {
54 crm_periph_reset(CRM_TMR1_PERIPH_RESET, TRUE);
55 crm_periph_reset(CRM_TMR1_PERIPH_RESET, FALSE);
56 }
57 else if(tmr_x == TMR2)
58 {
59 crm_periph_reset(CRM_TMR2_PERIPH_RESET, TRUE);
60 crm_periph_reset(CRM_TMR2_PERIPH_RESET, FALSE);
61 }
62 else if(tmr_x == TMR3)
63 {
64 crm_periph_reset(CRM_TMR3_PERIPH_RESET, TRUE);
65 crm_periph_reset(CRM_TMR3_PERIPH_RESET, FALSE);
66 }
67 else if(tmr_x == TMR4)
68 {
69 crm_periph_reset(CRM_TMR4_PERIPH_RESET, TRUE);
70 crm_periph_reset(CRM_TMR4_PERIPH_RESET, FALSE);
71 }
72#if defined (AT32F413TBU7) || defined (AT32F413Rx) || defined (AT32F413Cx) || \
73 defined (AT32F413Kx)
74 else if(tmr_x == TMR5)
75 {
76 crm_periph_reset(CRM_TMR5_PERIPH_RESET, TRUE);
77 crm_periph_reset(CRM_TMR5_PERIPH_RESET, FALSE);
78 }
79#if defined (AT32F413CCU7) || defined (AT32F413CCT7) || defined (AT32F413RCT7)
80 else if(tmr_x == TMR8)
81 {
82 crm_periph_reset(CRM_TMR8_PERIPH_RESET, TRUE);
83 crm_periph_reset(CRM_TMR8_PERIPH_RESET, FALSE);
84 }
85#endif
86 else if(tmr_x == TMR9)
87 {
88 crm_periph_reset(CRM_TMR9_PERIPH_RESET, TRUE);
89 crm_periph_reset(CRM_TMR9_PERIPH_RESET, FALSE);
90 }
91 else if(tmr_x == TMR10)
92 {
93 crm_periph_reset(CRM_TMR10_PERIPH_RESET, TRUE);
94 crm_periph_reset(CRM_TMR10_PERIPH_RESET, FALSE);
95 }
96 else if(tmr_x == TMR11)
97 {
98 crm_periph_reset(CRM_TMR11_PERIPH_RESET, TRUE);
99 crm_periph_reset(CRM_TMR11_PERIPH_RESET, FALSE);
100 }
101#endif
102}
103
113void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
114{
115 /* tmr counter enable */
116 tmr_x->ctrl1_bit.tmren = new_state;
117}
118
125void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
126{
127 tmr_output_struct->oc_mode = TMR_OUTPUT_CONTROL_OFF;
128 tmr_output_struct->oc_idle_state = FALSE;
129 tmr_output_struct->occ_idle_state = FALSE;
130 tmr_output_struct->oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
131 tmr_output_struct->occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
132 tmr_output_struct->oc_output_state = FALSE;
133 tmr_output_struct->occ_output_state = FALSE;
134}
135
142void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
143{
144 tmr_input_struct->input_channel_select = TMR_SELECT_CHANNEL_1;
145 tmr_input_struct->input_polarity_select = TMR_INPUT_RISING_EDGE;
146 tmr_input_struct->input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
147 tmr_input_struct->input_filter_value = 0x0;
148}
149
156void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
157{
158 tmr_brkdt_struct->deadtime = 0x0;
159 tmr_brkdt_struct->brk_polarity = TMR_BRK_INPUT_ACTIVE_LOW;
160 tmr_brkdt_struct->wp_level = TMR_WP_OFF;
161 tmr_brkdt_struct->auto_output_enable = FALSE ;
162 tmr_brkdt_struct->fcsoen_state = FALSE ;
163 tmr_brkdt_struct->fcsodis_state = FALSE ;
164 tmr_brkdt_struct->brk_enable = FALSE ;
165}
166
178void tmr_base_init(tmr_type* tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
179{
180 /* set the pr value */
181 tmr_x->pr = tmr_pr;
182
183 /* set the div value */
184 tmr_x->div = tmr_div;
185
186 /* trigger the overflow event to immediately reload pr value and div value */
187 tmr_x->swevt_bit.ovfswtr = TRUE;
188}
189
203void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
204{
205 /* set tmr clock source division */
206 tmr_x->ctrl1_bit.clkdiv = tmr_clock_div;
207}
208
224void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
225{
226 /* set the cnt direct */
227 tmr_x->ctrl1_bit.cnt_dir = tmr_cnt_dir;
228}
229
238void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
239{
240 /* set the repetition counter value */
241 tmr_x->rpr_bit.rpr = tmr_rpr_value;
242}
243
254void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
255{
256 /* set the tmr counter value */
257 tmr_x->cval = tmr_cnt_value;
258}
259
268uint32_t tmr_counter_value_get(tmr_type *tmr_x)
269{
270 return tmr_x->cval;
271}
272
282void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
283{
284 /* set the tmr div value */
285 tmr_x->div = tmr_div_value;
286}
287
296uint32_t tmr_div_value_get(tmr_type *tmr_x)
297{
298 return tmr_x->div;
299}
300
317void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
318 tmr_output_config_type *tmr_output_struct)
319{
320 uint16_t channel_index = 0, channel_c_index = 0, channel = 0, chx_offset, chcx_offset;
321
322 chx_offset = (8 + tmr_channel);
323 chcx_offset = (9 + tmr_channel);
324
325 /* get channel idle state bit position in ctrl2 register */
326 channel_index = (uint16_t)(tmr_output_struct->oc_idle_state << chx_offset);
327
328 /* get channel complementary idle state bit position in ctrl2 register */
329 channel_c_index = (uint16_t)(tmr_output_struct->occ_idle_state << chcx_offset);
330
331 /* set output channel complementary idle state */
332 tmr_x->ctrl2 &= ~(1<<chcx_offset);
333 tmr_x->ctrl2 |= channel_c_index;
334
335 /* set output channel idle state */
336 tmr_x->ctrl2 &= ~(1<<chx_offset);
337 tmr_x->ctrl2 |= channel_index;
338
339 /* set channel output mode */
340 channel = tmr_channel;
341
342 switch(channel)
343 {
344 case TMR_SELECT_CHANNEL_1:
345 tmr_x->cm1_output_bit.c1octrl = tmr_output_struct->oc_mode;
346 break;
347
348 case TMR_SELECT_CHANNEL_2:
349 tmr_x->cm1_output_bit.c2octrl = tmr_output_struct->oc_mode;
350 break;
351
352 case TMR_SELECT_CHANNEL_3:
353 tmr_x->cm2_output_bit.c3octrl = tmr_output_struct->oc_mode;
354 break;
355
356 case TMR_SELECT_CHANNEL_4:
357 tmr_x->cm2_output_bit.c4octrl = tmr_output_struct->oc_mode;
358 break;
359
360 default:
361 break;
362 }
363
364 chx_offset = ((tmr_channel * 2) + 1);
365 chcx_offset = ((tmr_channel * 2) + 3);
366
367 /* get channel polarity bit position in cctrl register */
368 channel_index = (uint16_t)(tmr_output_struct->oc_polarity << chx_offset);
369
370 /* get channel complementary polarity bit position in cctrl register */
371 channel_c_index = (uint16_t)(tmr_output_struct->occ_polarity << chcx_offset);
372
373 /* set output channel complementary polarity */
374 tmr_x->cctrl &= ~(1<<chcx_offset);
375 tmr_x->cctrl |= channel_c_index;
376
377 /* set output channel polarity */
378 tmr_x->cctrl &= ~(1<<chx_offset);
379 tmr_x->cctrl |= channel_index;
380
381 chx_offset = (tmr_channel * 2);
382 chcx_offset = ((tmr_channel * 2) + 2);
383
384 /* get channel enable bit position in cctrl register */
385 channel_index = (uint16_t)(tmr_output_struct->oc_output_state << (tmr_channel * 2));
386
387 /* get channel complementary enable bit position in cctrl register */
388 channel_c_index = (uint16_t)(tmr_output_struct->occ_output_state << ((tmr_channel * 2) + 2));
389
390 /* set output channel complementary enable bit */
391 tmr_x->cctrl &= ~(1<<chcx_offset);
392 tmr_x->cctrl |= channel_c_index;
393
394 /* set output channel enable bit */
395 tmr_x->cctrl &= ~(1<<chx_offset);
396 tmr_x->cctrl |= channel_index;
397}
398
423void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
424 tmr_output_control_mode_type oc_mode)
425{
426 uint16_t channel;
427
428 channel = tmr_channel;
429
430 switch(channel)
431 {
432 case TMR_SELECT_CHANNEL_1:
433 tmr_x->cm1_output_bit.c1octrl = oc_mode;
434 break;
435
436 case TMR_SELECT_CHANNEL_2:
437 tmr_x->cm1_output_bit.c2octrl = oc_mode;
438 break;
439
440 case TMR_SELECT_CHANNEL_3:
441 tmr_x->cm2_output_bit.c3octrl = oc_mode;
442 break;
443
444 case TMR_SELECT_CHANNEL_4:
445 tmr_x->cm2_output_bit.c4octrl = oc_mode;
446 break;
447
448 default:
449 break;
450 }
451}
463void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
464{
465 /* set tmr period value */
466 tmr_x->pr = tmr_pr_value;
467}
468
479uint32_t tmr_period_value_get(tmr_type *tmr_x)
480{
481 return tmr_x->pr;
482}
483
500void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
501 uint32_t tmr_channel_value)
502{
503 uint16_t channel;
504
505 channel = tmr_channel;
506
507 /* set tmr channel value */
508 switch(channel)
509 {
510 case TMR_SELECT_CHANNEL_1:
511 tmr_x->c1dt = tmr_channel_value;
512 break;
513
514 case TMR_SELECT_CHANNEL_2:
515 tmr_x->c2dt = tmr_channel_value;
516 break;
517
518 case TMR_SELECT_CHANNEL_3:
519 tmr_x->c3dt = tmr_channel_value;
520 break;
521
522 case TMR_SELECT_CHANNEL_4:
523 tmr_x->c4dt = tmr_channel_value;
524 break;
525
526 default:
527 break;
528 }
529}
530
545uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
546{
547 uint32_t cc_value_get = 0;
548 uint16_t channel;
549
550 channel = tmr_channel;
551
552 /* get tmr channel value */
553 switch(channel)
554 {
555 case TMR_SELECT_CHANNEL_1:
556 cc_value_get = tmr_x->c1dt;
557 break;
558
559 case TMR_SELECT_CHANNEL_2:
560 cc_value_get = tmr_x->c2dt;
561 break;
562
563 case TMR_SELECT_CHANNEL_3:
564 cc_value_get = tmr_x->c3dt;
565 break;
566
567 case TMR_SELECT_CHANNEL_4:
568 cc_value_get = tmr_x->c4dt;
569 break;
570
571 default:
572 break;
573 }
574
575 return cc_value_get;
576}
586void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
587{
588 /* tmr period buffer set */
589 tmr_x->ctrl1_bit.prben = new_state;
590}
591
607void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
608 confirm_state new_state)
609{
610 uint16_t channel;
611
612 channel = tmr_channel;
613
614 /* get tmr channel value */
615 switch(channel)
616 {
617 case TMR_SELECT_CHANNEL_1:
618 tmr_x->cm1_output_bit.c1oben = new_state;
619 break;
620
621 case TMR_SELECT_CHANNEL_2:
622 tmr_x->cm1_output_bit.c2oben = new_state;
623 break;
624
625 case TMR_SELECT_CHANNEL_3:
626 tmr_x->cm2_output_bit.c3oben = new_state;
627 break;
628
629 case TMR_SELECT_CHANNEL_4:
630 tmr_x->cm2_output_bit.c4oben = new_state;
631 break;
632
633 default:
634 break;
635 }
636}
637
653void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
654 confirm_state new_state)
655{
656 uint16_t channel;
657
658 channel = tmr_channel;
659
660 /* get tmr channel value */
661 switch(channel)
662 {
663 case TMR_SELECT_CHANNEL_1:
664 tmr_x->cm1_output_bit.c1oien = new_state;
665 break;
666
667 case TMR_SELECT_CHANNEL_2:
668 tmr_x->cm1_output_bit.c2oien = new_state;
669 break;
670
671 case TMR_SELECT_CHANNEL_3:
672 tmr_x->cm2_output_bit.c3oien = new_state;
673 break;
674
675 case TMR_SELECT_CHANNEL_4:
676 tmr_x->cm2_output_bit.c4oien = new_state;
677 break;
678
679 default:
680 break;
681 }
682}
683
699void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
700 confirm_state new_state)
701{
702 uint16_t channel;
703
704 channel = tmr_channel;
705
706 /* get tmr channel value */
707 switch(channel)
708 {
709 case TMR_SELECT_CHANNEL_1:
710 tmr_x->cm1_output_bit.c1osen = new_state;
711 break;
712
713 case TMR_SELECT_CHANNEL_2:
714 tmr_x->cm1_output_bit.c2osen = new_state;
715 break;
716
717 case TMR_SELECT_CHANNEL_3:
718 tmr_x->cm2_output_bit.c3osen = new_state;
719 break;
720
721 case TMR_SELECT_CHANNEL_4:
722 tmr_x->cm2_output_bit.c4osen = new_state;
723 break;
724
725 default:
726 break;
727 }
728}
729
738void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
739{
740 /* tmr one cycle mode enable */
741 tmr_x->ctrl1_bit.ocmen = new_state;
742}
743
752void tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
753{
754 /* tmr 32 bit function(plus mode) enable,only for TMR2/TMR5 */
755 if((tmr_x == TMR2)
756#if defined (AT32F413TBU7) || defined (AT32F413Rx) || defined (AT32F413Cx) || \
757 defined (AT32F413Kx)
758 || (tmr_x == TMR5)
759#endif
760 )
761 {
762 tmr_x->ctrl1_bit.pmen = new_state;
763 }
764}
765
775void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
776{
777 tmr_x->ctrl1_bit.ovfs = new_state;
778}
779
789void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
790{
791 tmr_x->ctrl1_bit.ovfen = new_state;
792}
793
810void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct,
811 tmr_channel_input_divider_type divider_factor)
812{
813 uint16_t channel = 0;
814
815 /* get channel selected */
816 channel = input_struct->input_channel_select;
817
818 switch(channel)
819 {
820 case TMR_SELECT_CHANNEL_1:
821 tmr_x->cctrl_bit.c1en = FALSE;
822 tmr_x->cctrl_bit.c1p = (uint32_t)input_struct->input_polarity_select;
823 tmr_x->cctrl_bit.c1cp = (input_struct->input_polarity_select & 0x2) >> 1;
824 tmr_x->cm1_input_bit.c1c = input_struct->input_mapped_select;
825 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
826 tmr_x->cm1_input_bit.c1idiv = divider_factor;
827 tmr_x->cctrl_bit.c1en = TRUE;
828 break;
829
830 case TMR_SELECT_CHANNEL_2:
831 tmr_x->cctrl_bit.c2en = FALSE;
832 tmr_x->cctrl_bit.c2p = (uint32_t)input_struct->input_polarity_select;
833 tmr_x->cctrl_bit.c2cp = (input_struct->input_polarity_select & 0x2) >> 1;
834 tmr_x->cm1_input_bit.c2c = input_struct->input_mapped_select;
835 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
836 tmr_x->cm1_input_bit.c2idiv = divider_factor;
837 tmr_x->cctrl_bit.c2en = TRUE;
838 break;
839
840 case TMR_SELECT_CHANNEL_3:
841 tmr_x->cctrl_bit.c3en = FALSE;
842 tmr_x->cctrl_bit.c3p = (uint32_t)input_struct->input_polarity_select;
843 tmr_x->cctrl_bit.c3cp = (input_struct->input_polarity_select & 0x2) >> 1;
844 tmr_x->cm2_input_bit.c3c = input_struct->input_mapped_select;
845 tmr_x->cm2_input_bit.c3df = input_struct->input_filter_value;
846 tmr_x->cm2_input_bit.c3idiv = divider_factor;
847 tmr_x->cctrl_bit.c3en = TRUE;
848 break;
849
850 case TMR_SELECT_CHANNEL_4:
851 tmr_x->cctrl_bit.c4en = FALSE;
852 tmr_x->cctrl_bit.c4p = (uint32_t)input_struct->input_polarity_select;
853 tmr_x->cm2_input_bit.c4c = input_struct->input_mapped_select;
854 tmr_x->cm2_input_bit.c4df = input_struct->input_filter_value;
855 tmr_x->cm2_input_bit.c4idiv = divider_factor;
856 tmr_x->cctrl_bit.c4en = TRUE;
857 break;
858
859 default:
860 break;
861 }
862}
863
882void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
883{
884 uint16_t channel;
885
886 channel = tmr_channel;
887
888 switch(channel)
889 {
890 case TMR_SELECT_CHANNEL_1:
891 tmr_x->cctrl_bit.c1en = new_state;
892 break;
893
894 case TMR_SELECT_CHANNEL_1C:
895 tmr_x->cctrl_bit.c1cen = new_state;
896 break;
897
898 case TMR_SELECT_CHANNEL_2:
899 tmr_x->cctrl_bit.c2en = new_state;
900 break;
901
902 case TMR_SELECT_CHANNEL_2C:
903 tmr_x->cctrl_bit.c2cen = new_state;
904 break;
905
906 case TMR_SELECT_CHANNEL_3:
907 tmr_x->cctrl_bit.c3en = new_state;
908 break;
909
910 case TMR_SELECT_CHANNEL_3C:
911 tmr_x->cctrl_bit.c3cen = new_state;
912 break;
913
914 case TMR_SELECT_CHANNEL_4:
915 tmr_x->cctrl_bit.c4en = new_state;
916 break;
917
918 default:
919 break;
920 }
921}
922
938void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
939 uint16_t filter_value)
940{
941 uint16_t channel;
942
943 channel = tmr_channel;
944
945 switch(channel)
946 {
947 case TMR_SELECT_CHANNEL_1:
948 tmr_x->cm1_input_bit.c1df = filter_value;
949 break;
950
951 case TMR_SELECT_CHANNEL_2:
952 tmr_x->cm1_input_bit.c2df = filter_value;
953 break;
954
955 case TMR_SELECT_CHANNEL_3:
956 tmr_x->cm2_input_bit.c3df = filter_value;
957 break;
958
959 case TMR_SELECT_CHANNEL_4:
960 tmr_x->cm2_input_bit.c4df = filter_value;
961 break;
962
963 default:
964 break;
965 }
966}
967
984void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct,
985 tmr_channel_input_divider_type divider_factor)
986{
987 uint16_t channel = 0;
988
989 /* get channel selected */
990 channel = input_struct->input_channel_select;
991
992 switch(channel)
993 {
994 case TMR_SELECT_CHANNEL_1:
995 if(input_struct->input_polarity_select == TMR_INPUT_RISING_EDGE)
996 {
997 /* set channel polarity */
998 tmr_x->cctrl_bit.c1p = TMR_INPUT_RISING_EDGE;
999 tmr_x->cctrl_bit.c2p = TMR_INPUT_FALLING_EDGE;
1000 }
1001 else if(input_struct->input_polarity_select == TMR_INPUT_FALLING_EDGE)
1002 {
1003 /* set channel polarity */
1004 tmr_x->cctrl_bit.c1p = TMR_INPUT_FALLING_EDGE;
1005 tmr_x->cctrl_bit.c2p = TMR_INPUT_RISING_EDGE;
1006 }
1007
1008 if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_DIRECT)
1009 {
1010 /* ic1 is mapped on ti1 */
1011 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1012
1013 /* ic1 is mapped on ti2 */
1014 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1015 }
1016 else if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_INDIRECT)
1017 {
1018 /* ic1 is mapped on ti1 */
1019 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1020
1021 /* ic1 is mapped on ti2 */
1022 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1023 }
1024
1025 /* set input ch1 and ch2 filter value*/
1026 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
1027 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
1028
1029 /*set input ch1 and ch2 divider value*/
1030 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1031 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1032
1033 tmr_x->cctrl_bit.c1en = TRUE;
1034 tmr_x->cctrl_bit.c2en = TRUE;
1035 break;
1036
1037 case TMR_SELECT_CHANNEL_2:
1038 if(input_struct->input_polarity_select == TMR_INPUT_RISING_EDGE)
1039 {
1040 /* set channel polarity */
1041 tmr_x->cctrl_bit.c2p = TMR_INPUT_RISING_EDGE;
1042 tmr_x->cctrl_bit.c1p = TMR_INPUT_FALLING_EDGE;
1043 }
1044 else if(input_struct->input_polarity_select == TMR_INPUT_FALLING_EDGE)
1045 {
1046 /* set channel polarity */
1047 tmr_x->cctrl_bit.c2p = TMR_INPUT_FALLING_EDGE;
1048 tmr_x->cctrl_bit.c1p = TMR_INPUT_RISING_EDGE;
1049 }
1050
1051 if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_DIRECT)
1052 {
1053 /* set mapped direct */
1054 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1055 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1056 }
1057 else if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_INDIRECT)
1058 {
1059 /* set mapped direct */
1060 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1061 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1062 }
1063
1064 /* set input ch1 and ch2 filter value*/
1065 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
1066 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
1067
1068 /*set input ch1 and ch2 divider value*/
1069 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1070 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1071
1072 tmr_x->cctrl_bit.c1en = TRUE;
1073 tmr_x->cctrl_bit.c2en = TRUE;
1074 break;
1075
1076 default:
1077 break;
1078 }
1079}
1080
1092void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
1093{
1094 tmr_x->ctrl2_bit.c1insel = ch1_connect;
1095}
1096
1117void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
1118 tmr_channel_input_divider_type divider_factor)
1119{
1120 uint16_t channel;
1121
1122 channel = tmr_channel;
1123
1124 switch(channel)
1125 {
1126 case TMR_SELECT_CHANNEL_1:
1127 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1128 break;
1129
1130 case TMR_SELECT_CHANNEL_2:
1131 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1132 break;
1133
1134 case TMR_SELECT_CHANNEL_3:
1135 tmr_x->cm2_input_bit.c3idiv = divider_factor;
1136 break;
1137
1138 case TMR_SELECT_CHANNEL_4:
1139 tmr_x->cm2_input_bit.c4idiv = divider_factor;
1140 break;
1141
1142 default:
1143 break;
1144 }
1145}
1146
1164void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
1165{
1166 tmr_x->ctrl2_bit.ptos = primary_mode;
1167}
1168
1186void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
1187{
1188 tmr_x->stctrl_bit.smsel = sub_mode;
1189}
1190
1202void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
1203{
1204 tmr_x->ctrl2_bit.drs = cc_dma_select;
1205}
1206
1215void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
1216{
1217 tmr_x->ctrl2_bit.ccfs = new_state;
1218}
1219
1228void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
1229{
1230 tmr_x->ctrl2_bit.cbctrl = new_state;
1231}
1232
1250void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
1251{
1252 tmr_x->stctrl_bit.stis = trigger_select;
1253}
1254
1263void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
1264{
1265 tmr_x->stctrl_bit.sts = new_state;
1266}
1267
1286void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
1287{
1288 if(new_state == TRUE)
1289 {
1290 tmr_x->iden |= dma_request;
1291 }
1292 else if(new_state == FALSE)
1293 {
1294 tmr_x->iden &= ~dma_request;
1295 }
1296}
1297
1317void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
1318{
1319 if(new_state == TRUE)
1320 {
1321 tmr_x->iden |= tmr_interrupt;
1322 }
1323 else if(new_state == FALSE)
1324 {
1325 tmr_x->iden &= ~tmr_interrupt;
1326 }
1327}
1328
1351 flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
1352{
1353 flag_status status = RESET;
1354
1355 if((tmr_x->ists & tmr_flag) != RESET)
1356 {
1357 status = SET;
1358 }
1359 else
1360 {
1361 status = RESET;
1362 }
1363
1364 return status;
1365}
1366
1389void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
1390{
1391 tmr_x->ists = ~tmr_flag;
1392}
1393
1412void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
1413{
1414 tmr_x->swevt |= tmr_event;
1415}
1416
1425void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
1426{
1427 tmr_x->brk_bit.oen = new_state;
1428}
1429
1437void tmr_internal_clock_set(tmr_type *tmr_x)
1438{
1439 tmr_x->stctrl_bit.smsel = TMR_SUB_MODE_DIABLE;
1440}
1441
1463void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
1464 tmr_polarity_active_type oc_polarity)
1465{
1466 uint16_t channel;
1467
1468 channel = tmr_channel;
1469
1470 switch(channel)
1471 {
1472 case TMR_SELECT_CHANNEL_1:
1473 tmr_x->cctrl_bit.c1p = (uint32_t)oc_polarity;
1474 break;
1475
1476 case TMR_SELECT_CHANNEL_2:
1477 tmr_x->cctrl_bit.c2p = (uint32_t)oc_polarity;
1478 break;
1479
1480 case TMR_SELECT_CHANNEL_3:
1481 tmr_x->cctrl_bit.c3p = (uint32_t)oc_polarity;
1482 break;
1483
1484 case TMR_SELECT_CHANNEL_4:
1485 tmr_x->cctrl_bit.c4p = (uint32_t)oc_polarity;
1486 break;
1487
1488 case TMR_SELECT_CHANNEL_1C:
1489 tmr_x->cctrl_bit.c1cp = (uint32_t)oc_polarity;
1490 break;
1491
1492 case TMR_SELECT_CHANNEL_2C:
1493 tmr_x->cctrl_bit.c2cp = (uint32_t)oc_polarity;
1494 break;
1495
1496 case TMR_SELECT_CHANNEL_3C:
1497 tmr_x->cctrl_bit.c3cp = (uint32_t)oc_polarity;
1498 break;
1499
1500 default:
1501 break;
1502 }
1503}
1504
1523void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide,
1524 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1525{
1526 tmr_x->stctrl_bit.esdiv = es_divide;
1527 tmr_x->stctrl_bit.esp = es_polarity;
1528 tmr_x->stctrl_bit.esf = es_filter;
1529}
1530
1549void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide,
1550 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1551{
1552 tmr_external_clock_config(tmr_x, es_divide, es_polarity, es_filter);
1553 tmr_x->stctrl_bit.smsel = TMR_SUB_EXTERNAL_CLOCK_MODE_A;
1554 tmr_x->stctrl_bit.stis = TMR_SUB_INPUT_SEL_EXTIN;
1555}
1556
1575void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide,
1576 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1577{
1578 tmr_external_clock_config(tmr_x, es_divide, es_polarity, es_filter);
1579 tmr_x->stctrl_bit.ecmben = TRUE;
1580}
1581
1604void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type
1605 ic1_polarity, tmr_input_polarity_type ic2_polarity)
1606{
1607 tmr_x->stctrl_bit.smsel = encoder_mode;
1608
1609 /* set ic1 polarity */
1610 tmr_x->cctrl_bit.c1p = (ic1_polarity & 0x1);
1611 tmr_x->cctrl_bit.c1cp = (ic1_polarity >> 1);
1612 /* set ic1 as input channel */
1613 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1614
1615 /* set ic2 polarity */
1616 tmr_x->cctrl_bit.c2p = (ic2_polarity & 0x1);
1617 tmr_x->cctrl_bit.c2cp = (ic2_polarity >> 1);
1618 /* set ic2 as input channel */
1619 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1620}
1621
1640void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
1641 tmr_force_output_type force_output)
1642{
1643 uint16_t channel;
1644
1645 channel = tmr_channel;
1646
1647 switch(channel)
1648 {
1649 case TMR_SELECT_CHANNEL_1:
1650 tmr_x->cm1_output_bit.c1octrl = force_output;
1651 break;
1652
1653 case TMR_SELECT_CHANNEL_2:
1654 tmr_x->cm1_output_bit.c2octrl = force_output;
1655 break;
1656
1657 case TMR_SELECT_CHANNEL_3:
1658 tmr_x->cm2_output_bit.c3octrl = force_output;
1659 break;
1660
1661 case TMR_SELECT_CHANNEL_4:
1662 tmr_x->cm2_output_bit.c4octrl = force_output;
1663 break;
1664
1665 default:
1666 break;
1667 }
1668}
1669
1706void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length,
1707 tmr_dma_address_type dma_base_address)
1708{
1709 tmr_x->dmactrl_bit.dtb = dma_length;
1710 tmr_x->dmactrl_bit.addr = dma_base_address;
1711}
1712
1722void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
1723{
1724 tmr_x->brk_bit.brken = brkdt_struct->brk_enable;
1725 tmr_x->brk_bit.dtc = brkdt_struct->deadtime;
1726 tmr_x->brk_bit.fcsodis = brkdt_struct->fcsodis_state;
1727 tmr_x->brk_bit.fcsoen = brkdt_struct->fcsoen_state;
1728 tmr_x->brk_bit.brkv = brkdt_struct->brk_polarity;
1729 tmr_x->brk_bit.aoen = brkdt_struct->auto_output_enable;
1730 tmr_x->brk_bit.wpc = brkdt_struct->wp_level;
1731}
1732
1737#endif
1738
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:37
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
CRM_TMR2_PERIPH_RESET
@ CRM_TMR2_PERIPH_RESET
Definition: at32f413_crm.h:168
CRM_TMR4_PERIPH_RESET
@ CRM_TMR4_PERIPH_RESET
Definition: at32f413_crm.h:170
CRM_TMR10_PERIPH_RESET
@ CRM_TMR10_PERIPH_RESET
Definition: at32f413_crm.h:164
CRM_TMR5_PERIPH_RESET
@ CRM_TMR5_PERIPH_RESET
Definition: at32f413_crm.h:171
CRM_TMR9_PERIPH_RESET
@ CRM_TMR9_PERIPH_RESET
Definition: at32f413_crm.h:163
CRM_TMR1_PERIPH_RESET
@ CRM_TMR1_PERIPH_RESET
Definition: at32f413_crm.h:159
CRM_TMR8_PERIPH_RESET
@ CRM_TMR8_PERIPH_RESET
Definition: at32f413_crm.h:161
CRM_TMR3_PERIPH_RESET
@ CRM_TMR3_PERIPH_RESET
Definition: at32f413_crm.h:169
CRM_TMR11_PERIPH_RESET
@ CRM_TMR11_PERIPH_RESET
Definition: at32f413_crm.h:165
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
tmr_dma_request_type
tmr_dma_request_type
tmr dma request type
Definition: at32f413_tmr.h:266
tmr_external_signal_divider_type
tmr_external_signal_divider_type
tmr external signal divider type
Definition: at32f413_tmr.h:305
tmr_polarity_active_type
tmr_polarity_active_type
tmr polarity active type
Definition: at32f413_tmr.h:295
tmr_count_mode_type
tmr_count_mode_type
tmr counter mode type
Definition: at32f413_tmr.h:103
tmr_input_polarity_type
tmr_input_polarity_type
tmr input channel polarity type
Definition: at32f413_tmr.h:203
tmr_dma_request_source_type
tmr_dma_request_source_type
tmr dma request source select type
Definition: at32f413_tmr.h:257
tmr_channel_select_type
tmr_channel_select_type
tmr channel select type
Definition: at32f413_tmr.h:213
tmr_external_signal_polarity_type
tmr_external_signal_polarity_type
tmr external signal polarity type
Definition: at32f413_tmr.h:316
tmr_dma_address_type
tmr_dma_address_type
tmr dma base address type
Definition: at32f413_tmr.h:350
tmr_channel1_input_connected_type
tmr_channel1_input_connected_type
tmr channel1 input connected type
Definition: at32f413_tmr.h:227
tmr_clock_division_type
tmr_clock_division_type
tmr clock division type
Definition: at32f413_tmr.h:93
tmr_event_trigger_type
tmr_event_trigger_type
tmr event triggered by software type
Definition: at32f413_tmr.h:280
tmr_output_control_mode_type
tmr_output_control_mode_type
tmr output control mode type
Definition: at32f413_tmr.h:170
tmr_dma_transfer_length_type
tmr_dma_transfer_length_type
tmr dma transfer length type
Definition: at32f413_tmr.h:325
sub_tmr_input_sel_type
sub_tmr_input_sel_type
tmr subordinate mode input select type
Definition: at32f413_tmr.h:130
tmr_force_output_type
tmr_force_output_type
tmr force output type
Definition: at32f413_tmr.h:185
tmr_sub_mode_select_type
tmr_sub_mode_select_type
tmr subordinate mode select type
Definition: at32f413_tmr.h:145
tmr_primary_select_type
tmr_primary_select_type
tmr primary mode select type
Definition: at32f413_tmr.h:115
tmr_encoder_mode_type
tmr_encoder_mode_type
tmr encoder mode type
Definition: at32f413_tmr.h:160
tmr_channel_input_divider_type
tmr_channel_input_divider_type
tmr input divider type
Definition: at32f413_tmr.h:246
TMR_INPUT_FALLING_EDGE
@ TMR_INPUT_FALLING_EDGE
Definition: at32f413_tmr.h:205
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f413_tmr.h:215
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f413_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f413_tmr.h:219
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f413_tmr.h:386
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_CC_CHANNEL_MAPPED_INDIRECT
@ TMR_CC_CHANNEL_MAPPED_INDIRECT
Definition: at32f413_tmr.h:238
TMR_BRK_INPUT_ACTIVE_LOW
@ TMR_BRK_INPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:377
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:171
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_SUB_INPUT_SEL_EXTIN
@ TMR_SUB_INPUT_SEL_EXTIN
Definition: at32f413_tmr.h:138
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f413_tmr.h:153
TMR_SUB_MODE_DIABLE
@ TMR_SUB_MODE_DIABLE
Definition: at32f413_tmr.h:146
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f413_tmr.c:1706
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:545
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_period_value_get
uint32_t tmr_period_value_get(tmr_type *tmr_x)
get tmr period value
Definition: at32f413_tmr.c:479
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer
Definition: at32f413_tmr.c:1228
tmr_overflow_request_source_set
void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources
Definition: at32f413_tmr.c:775
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f413_tmr.c:423
tmr_input_channel_divider_set
void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider
Definition: at32f413_tmr.c:1117
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1286
tmr_external_clock_config
void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock
Definition: at32f413_tmr.c:1523
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f413_tmr.c:238
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:586
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_internal_clock_set
void tmr_internal_clock_set(tmr_type *tmr_x)
set tmr select internal clock
Definition: at32f413_tmr.c:1437
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:156
tmr_force_output_set
void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output
Definition: at32f413_tmr.c:1640
tmr_counter_value_set
void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value
Definition: at32f413_tmr.c:254
tmr_div_value_get
uint32_t tmr_div_value_get(tmr_type *tmr_x)
get tmr div value
Definition: at32f413_tmr.c:296
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_input_channel_filter_set
void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter
Definition: at32f413_tmr.c:938
tmr_period_value_set
void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value
Definition: at32f413_tmr.c:463
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:268
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time
Definition: at32f413_tmr.c:1722
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_external_clock_mode2_config
void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2
Definition: at32f413_tmr.c:1575
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:142
tmr_div_value_set
void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value
Definition: at32f413_tmr.c:282
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1263
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_hall_select
void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
select tmr hall
Definition: at32f413_tmr.c:1215
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input
Definition: at32f413_tmr.c:1092
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:752
tmr_external_clock_mode1_config
void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1
Definition: at32f413_tmr.c:1549
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:984
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:607
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1164
tmr_overflow_event_disable
void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation
Definition: at32f413_tmr.c:789
tmr_channel_dma_select
void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma
Definition: at32f413_tmr.c:1202
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_output_channel_immediately_set
void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately
Definition: at32f413_tmr.c:653
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f413_tmr.c:1604
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:882
tmr_output_channel_switch_set
void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch
Definition: at32f413_tmr.c:699
tmr_reset
void tmr_reset(tmr_type *tmr_x)
tmr reset by crm reset register
Definition: at32f413_tmr.c:50
tmr_output_channel_polarity_set
void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity
Definition: at32f413_tmr.c:1463
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f413_tmr.c:738
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
TMR4
#define TMR4
Definition: at32f413_tmr.h:833
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:421
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:422
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:425
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:423
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
tmr_type
type define tmr register all
Definition: at32f413_tmr.h:435
tmr_type::swevt_bit
struct tmr_type::@661::@696 swevt_bit
tmr_type::c1cen
__IO uint32_t c1cen
Definition: at32f413_tmr.h:663
tmr_type::pmen
__IO uint32_t pmen
Definition: at32f413_tmr.h:451
tmr_type::brken
__IO uint32_t brken
Definition: at32f413_tmr.h:789
tmr_type::c1idiv
__IO uint32_t c1idiv
Definition: at32f413_tmr.h:604
tmr_type::dtc
__IO uint32_t dtc
Definition: at32f413_tmr.h:785
tmr_type::c1en
__IO uint32_t c1en
Definition: at32f413_tmr.h:661
tmr_type::c4df
__IO uint32_t c4df
Definition: at32f413_tmr.h:648
tmr_type::c3octrl
__IO uint32_t c3octrl
Definition: at32f413_tmr.h:628
tmr_type::c2osen
__IO uint32_t c2osen
Definition: at32f413_tmr.h:594
tmr_type::swevt
__IO uint32_t swevt
Definition: at32f413_tmr.h:558
tmr_type::c2en
__IO uint32_t c2en
Definition: at32f413_tmr.h:665
tmr_type::c3df
__IO uint32_t c3df
Definition: at32f413_tmr.h:645
tmr_type::wpc
__IO uint32_t wpc
Definition: at32f413_tmr.h:786
tmr_type::c3oben
__IO uint32_t c3oben
Definition: at32f413_tmr.h:627
tmr_type::cnt_dir
__IO uint32_t cnt_dir
Definition: at32f413_tmr.h:448
tmr_type::rpr_bit
struct tmr_type::@675::@705 rpr_bit
tmr_type::c4octrl
__IO uint32_t c4octrl
Definition: at32f413_tmr.h:633
tmr_type::c1insel
__IO uint32_t c1insel
Definition: at32f413_tmr.h:469
tmr_type::div
__IO uint32_t div
Definition: at32f413_tmr.h:696
tmr_type::esf
__IO uint32_t esf
Definition: at32f413_tmr.h:493
tmr_type::cm2_input_bit
struct tmr_type::@665::@700 cm2_input_bit
input capture mode
tmr_type::c1osen
__IO uint32_t c1osen
Definition: at32f413_tmr.h:589
tmr_type::c2cen
__IO uint32_t c2cen
Definition: at32f413_tmr.h:667
tmr_type::cm2_output_bit
struct tmr_type::@665::@699 cm2_output_bit
channel mode
tmr_type::drs
__IO uint32_t drs
Definition: at32f413_tmr.h:467
tmr_type::iden
__IO uint32_t iden
Definition: at32f413_tmr.h:506
tmr_type::c1oben
__IO uint32_t c1oben
Definition: at32f413_tmr.h:587
tmr_type::ists
__IO uint32_t ists
Definition: at32f413_tmr.h:533
tmr_type::c1c
__IO uint32_t c1c
Definition: at32f413_tmr.h:585
tmr_type::c3cen
__IO uint32_t c3cen
Definition: at32f413_tmr.h:671
tmr_type::c4p
__IO uint32_t c4p
Definition: at32f413_tmr.h:674
tmr_type::brkv
__IO uint32_t brkv
Definition: at32f413_tmr.h:790
tmr_type::ctrl1_bit
struct tmr_type::@651::@691 ctrl1_bit
tmr_type::stis
__IO uint32_t stis
Definition: at32f413_tmr.h:491
tmr_type::ovfswtr
__IO uint32_t ovfswtr
Definition: at32f413_tmr.h:561
tmr_type::c3idiv
__IO uint32_t c3idiv
Definition: at32f413_tmr.h:644
tmr_type::c4osen
__IO uint32_t c4osen
Definition: at32f413_tmr.h:634
tmr_type::c1octrl
__IO uint32_t c1octrl
Definition: at32f413_tmr.h:588
tmr_type::tmren
__IO uint32_t tmren
Definition: at32f413_tmr.h:444
tmr_type::oen
__IO uint32_t oen
Definition: at32f413_tmr.h:792
tmr_type::sts
__IO uint32_t sts
Definition: at32f413_tmr.h:492
tmr_type::c2idiv
__IO uint32_t c2idiv
Definition: at32f413_tmr.h:607
tmr_type::c1p
__IO uint32_t c1p
Definition: at32f413_tmr.h:662
tmr_type::c1oien
__IO uint32_t c1oien
Definition: at32f413_tmr.h:586
tmr_type::pr
__IO uint32_t pr
Definition: at32f413_tmr.h:709
tmr_type::c3oien
__IO uint32_t c3oien
Definition: at32f413_tmr.h:626
tmr_type::c1dt
uint32_t c1dt
Definition: at32f413_tmr.h:734
tmr_type::c2oben
__IO uint32_t c2oben
Definition: at32f413_tmr.h:592
tmr_type::ctrl2_bit
struct tmr_type::@653::@692 ctrl2_bit
tmr_type::cm1_output_bit
struct tmr_type::@663::@697 cm1_output_bit
channel mode
tmr_type::c2octrl
__IO uint32_t c2octrl
Definition: at32f413_tmr.h:593
tmr_type::smsel
__IO uint32_t smsel
Definition: at32f413_tmr.h:489
tmr_type::c3p
__IO uint32_t c3p
Definition: at32f413_tmr.h:670
tmr_type::c1cp
__IO uint32_t c1cp
Definition: at32f413_tmr.h:664
tmr_type::c3c
__IO uint32_t c3c
Definition: at32f413_tmr.h:625
tmr_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f413_tmr.h:450
tmr_type::ovfs
__IO uint32_t ovfs
Definition: at32f413_tmr.h:446
tmr_type::dmactrl_bit
struct tmr_type::@687::@711 dmactrl_bit
tmr_type::cbctrl
__IO uint32_t cbctrl
Definition: at32f413_tmr.h:464
tmr_type::dtb
__IO uint32_t dtb
Definition: at32f413_tmr.h:806
tmr_type::prben
__IO uint32_t prben
Definition: at32f413_tmr.h:449
tmr_type::ccfs
__IO uint32_t ccfs
Definition: at32f413_tmr.h:466
tmr_type::ecmben
__IO uint32_t ecmben
Definition: at32f413_tmr.h:495
tmr_type::ovfen
__IO uint32_t ovfen
Definition: at32f413_tmr.h:445
tmr_type::c4en
__IO uint32_t c4en
Definition: at32f413_tmr.h:673
tmr_type::fcsoen
__IO uint32_t fcsoen
Definition: at32f413_tmr.h:788
tmr_type::esdiv
__IO uint32_t esdiv
Definition: at32f413_tmr.h:494
tmr_type::c3en
__IO uint32_t c3en
Definition: at32f413_tmr.h:669
tmr_type::c2p
__IO uint32_t c2p
Definition: at32f413_tmr.h:666
tmr_type::ocmen
__IO uint32_t ocmen
Definition: at32f413_tmr.h:447
tmr_type::c4oien
__IO uint32_t c4oien
Definition: at32f413_tmr.h:631
tmr_type::c2dt
uint32_t c2dt
Definition: at32f413_tmr.h:746
tmr_type::addr
__IO uint32_t addr
Definition: at32f413_tmr.h:804
tmr_type::c3cp
__IO uint32_t c3cp
Definition: at32f413_tmr.h:672
tmr_type::c2df
__IO uint32_t c2df
Definition: at32f413_tmr.h:608
tmr_type::c4idiv
__IO uint32_t c4idiv
Definition: at32f413_tmr.h:647
tmr_type::c3osen
__IO uint32_t c3osen
Definition: at32f413_tmr.h:629
tmr_type::rpr
__IO uint32_t rpr
Definition: at32f413_tmr.h:721
tmr_type::c2c
__IO uint32_t c2c
Definition: at32f413_tmr.h:590
tmr_type::c1df
__IO uint32_t c1df
Definition: at32f413_tmr.h:605
tmr_type::c2oien
__IO uint32_t c2oien
Definition: at32f413_tmr.h:591
tmr_type::c4dt
__IO uint32_t c4dt
Definition: at32f413_tmr.h:770
tmr_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_tmr.h:461
tmr_type::stctrl_bit
struct tmr_type::@655::@693 stctrl_bit
tmr_type::c3dt
__IO uint32_t c3dt
Definition: at32f413_tmr.h:758
tmr_type::c2cp
__IO uint32_t c2cp
Definition: at32f413_tmr.h:668
tmr_type::cctrl
uint32_t cctrl
Definition: at32f413_tmr.h:658
tmr_type::c4c
__IO uint32_t c4c
Definition: at32f413_tmr.h:630
tmr_type::c4oben
__IO uint32_t c4oben
Definition: at32f413_tmr.h:632
tmr_type::fcsodis
__IO uint32_t fcsodis
Definition: at32f413_tmr.h:787
tmr_type::cctrl_bit
struct tmr_type::@667::@701 cctrl_bit
tmr_type::cval
__IO uint32_t cval
Definition: at32f413_tmr.h:684
tmr_type::cm1_input_bit
struct tmr_type::@663::@698 cm1_input_bit
input capture mode
tmr_type::brk_bit
struct tmr_type::@685::@710 brk_bit
tmr_type::esp
__IO uint32_t esp
Definition: at32f413_tmr.h:496
tmr_type::ptos
__IO uint32_t ptos
Definition: at32f413_tmr.h:468
tmr_type::aoen
__IO uint32_t aoen
Definition: at32f413_tmr.h:791
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_tmr.h Source File

  • libraries
  • drivers
  • inc
at32f413_tmr.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_TMR_H
27#define __AT32F413_TMR_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define TMR_OVF_FLAG ((uint32_t)0x000001)
51#define TMR_C1_FLAG ((uint32_t)0x000002)
52#define TMR_C2_FLAG ((uint32_t)0x000004)
53#define TMR_C3_FLAG ((uint32_t)0x000008)
54#define TMR_C4_FLAG ((uint32_t)0x000010)
55#define TMR_HALL_FLAG ((uint32_t)0x000020)
56#define TMR_TRIGGER_FLAG ((uint32_t)0x000040)
57#define TMR_BRK_FLAG ((uint32_t)0x000080)
58#define TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
59#define TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
60#define TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
61#define TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)
72#define TMR_OVF_INT ((uint32_t)0x000001)
73#define TMR_C1_INT ((uint32_t)0x000002)
74#define TMR_C2_INT ((uint32_t)0x000004)
75#define TMR_C3_INT ((uint32_t)0x000008)
76#define TMR_C4_INT ((uint32_t)0x000010)
77#define TMR_HALL_INT ((uint32_t)0x000020)
78#define TMR_TRIGGER_INT ((uint32_t)0x000040)
79#define TMR_BRK_INT ((uint32_t)0x000080)
92typedef enum
93{
94 TMR_CLOCK_DIV1 = 0x00,
95 TMR_CLOCK_DIV2 = 0x01,
96 TMR_CLOCK_DIV4 = 0x02
97} tmr_clock_division_type;
98
102typedef enum
103{
104 TMR_COUNT_UP = 0x00,
105 TMR_COUNT_DOWN = 0x01,
106 TMR_COUNT_TWO_WAY_1 = 0x02,
107 TMR_COUNT_TWO_WAY_2 = 0x04,
108 TMR_COUNT_TWO_WAY_3 = 0x06
109} tmr_count_mode_type;
110
114typedef enum
115{
116 TMR_PRIMARY_SEL_RESET = 0x00,
117 TMR_PRIMARY_SEL_ENABLE = 0x01,
118 TMR_PRIMARY_SEL_OVERFLOW = 0x02,
119 TMR_PRIMARY_SEL_COMPARE = 0x03,
120 TMR_PRIMARY_SEL_C1ORAW = 0x04,
121 TMR_PRIMARY_SEL_C2ORAW = 0x05,
122 TMR_PRIMARY_SEL_C3ORAW = 0x06,
123 TMR_PRIMARY_SEL_C4ORAW = 0x07
124} tmr_primary_select_type;
125
129typedef enum
130{
131 TMR_SUB_INPUT_SEL_IS0 = 0x00,
132 TMR_SUB_INPUT_SEL_IS1 = 0x01,
133 TMR_SUB_INPUT_SEL_IS2 = 0x02,
134 TMR_SUB_INPUT_SEL_IS3 = 0x03,
135 TMR_SUB_INPUT_SEL_C1INC = 0x04,
136 TMR_SUB_INPUT_SEL_C1DF1 = 0x05,
137 TMR_SUB_INPUT_SEL_C2DF2 = 0x06,
138 TMR_SUB_INPUT_SEL_EXTIN = 0x07
139} sub_tmr_input_sel_type;
140
144typedef enum
145{
146 TMR_SUB_MODE_DIABLE = 0x00,
147 TMR_SUB_ENCODER_MODE_A = 0x01,
148 TMR_SUB_ENCODER_MODE_B = 0x02,
149 TMR_SUB_ENCODER_MODE_C = 0x03,
150 TMR_SUB_RESET_MODE = 0x04,
151 TMR_SUB_HANG_MODE = 0x05,
152 TMR_SUB_TRIGGER_MODE = 0x06,
153 TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
154} tmr_sub_mode_select_type;
155
159typedef enum
160{
161 TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A,
162 TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B,
163 TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C
164} tmr_encoder_mode_type;
165
169typedef enum
170{
171 TMR_OUTPUT_CONTROL_OFF = 0x00,
172 TMR_OUTPUT_CONTROL_HIGH = 0x01,
173 TMR_OUTPUT_CONTROL_LOW = 0x02,
174 TMR_OUTPUT_CONTROL_SWITCH = 0x03,
175 TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04,
176 TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05,
177 TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06,
178 TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
179} tmr_output_control_mode_type;
180
184typedef enum
185{
186 TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH,
187 TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW
188} tmr_force_output_type;
189
193typedef enum
194{
195 TMR_OUTPUT_ACTIVE_HIGH = 0x00,
196 TMR_OUTPUT_ACTIVE_LOW = 0x01
197} tmr_output_polarity_type;
198
202typedef enum
203{
204 TMR_INPUT_RISING_EDGE = 0x00,
205 TMR_INPUT_FALLING_EDGE = 0x01,
206 TMR_INPUT_BOTH_EDGE = 0x03
207} tmr_input_polarity_type;
208
212typedef enum
213{
214 TMR_SELECT_CHANNEL_1 = 0x00,
215 TMR_SELECT_CHANNEL_1C = 0x01,
216 TMR_SELECT_CHANNEL_2 = 0x02,
217 TMR_SELECT_CHANNEL_2C = 0x03,
218 TMR_SELECT_CHANNEL_3 = 0x04,
219 TMR_SELECT_CHANNEL_3C = 0x05,
220 TMR_SELECT_CHANNEL_4 = 0x06
221} tmr_channel_select_type;
222
226typedef enum
227{
228 TMR_CHANEL1_CONNECTED_C1IRAW = 0x00,
229 TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01
230} tmr_channel1_input_connected_type;
231
235typedef enum
236{
237 TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01,
238 TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02,
239 TMR_CC_CHANNEL_MAPPED_STI = 0x03
240} tmr_input_direction_mapped_type;
241
245typedef enum
246{
247 TMR_CHANNEL_INPUT_DIV_1 = 0x00,
248 TMR_CHANNEL_INPUT_DIV_2 = 0x01,
249 TMR_CHANNEL_INPUT_DIV_4 = 0x02,
250 TMR_CHANNEL_INPUT_DIV_8 = 0x03
251} tmr_channel_input_divider_type;
252
256typedef enum
257{
258 TMR_DMA_REQUEST_BY_CHANNEL = 0x00,
259 TMR_DMA_REQUEST_BY_OVERFLOW = 0x01
260} tmr_dma_request_source_type;
261
265typedef enum
266{
267 TMR_OVERFLOW_DMA_REQUEST = 0x00000100,
268 TMR_C1_DMA_REQUEST = 0x00000200,
269 TMR_C2_DMA_REQUEST = 0x00000400,
270 TMR_C3_DMA_REQUEST = 0x00000800,
271 TMR_C4_DMA_REQUEST = 0x00001000,
272 TMR_HALL_DMA_REQUEST = 0x00002000,
273 TMR_TRIGGER_DMA_REQUEST = 0x00004000
274} tmr_dma_request_type;
275
279typedef enum
280{
281 TMR_OVERFLOW_SWTRIG = 0x00000001,
282 TMR_C1_SWTRIG = 0x00000002,
283 TMR_C2_SWTRIG = 0x00000004,
284 TMR_C3_SWTRIG = 0x00000008,
285 TMR_C4_SWTRIG = 0x00000010,
286 TMR_HALL_SWTRIG = 0x00000020,
287 TMR_TRIGGER_SWTRIG = 0x00000040,
288 TMR_BRK_SWTRIG = 0x00000080
289}tmr_event_trigger_type;
290
294typedef enum
295{
296 TMR_POLARITY_ACTIVE_HIGH = 0x00,
297 TMR_POLARITY_ACTIVE_LOW = 0x01,
298 TMR_POLARITY_ACTIVE_BOTH = 0x02
299}tmr_polarity_active_type;
300
304typedef enum
305{
306 TMR_ES_FREQUENCY_DIV_1 = 0x00,
307 TMR_ES_FREQUENCY_DIV_2 = 0x01,
308 TMR_ES_FREQUENCY_DIV_4 = 0x02,
309 TMR_ES_FREQUENCY_DIV_8 = 0x03
310}tmr_external_signal_divider_type;
311
315typedef enum
316{
317 TMR_ES_POLARITY_NON_INVERTED = 0x00,
318 TMR_ES_POLARITY_INVERTED = 0x01
319}tmr_external_signal_polarity_type;
320
324typedef enum
325{
326 TMR_DMA_TRANSFER_1BYTE = 0x00,
327 TMR_DMA_TRANSFER_2BYTES = 0x01,
328 TMR_DMA_TRANSFER_3BYTES = 0x02,
329 TMR_DMA_TRANSFER_4BYTES = 0x03,
330 TMR_DMA_TRANSFER_5BYTES = 0x04,
331 TMR_DMA_TRANSFER_6BYTES = 0x05,
332 TMR_DMA_TRANSFER_7BYTES = 0x06,
333 TMR_DMA_TRANSFER_8BYTES = 0x07,
334 TMR_DMA_TRANSFER_9BYTES = 0x08,
335 TMR_DMA_TRANSFER_10BYTES = 0x09,
336 TMR_DMA_TRANSFER_11BYTES = 0x0A,
337 TMR_DMA_TRANSFER_12BYTES = 0x0B,
338 TMR_DMA_TRANSFER_13BYTES = 0x0C,
339 TMR_DMA_TRANSFER_14BYTES = 0x0D,
340 TMR_DMA_TRANSFER_15BYTES = 0x0E,
341 TMR_DMA_TRANSFER_16BYTES = 0x0F,
342 TMR_DMA_TRANSFER_17BYTES = 0x10,
343 TMR_DMA_TRANSFER_18BYTES = 0x11
344}tmr_dma_transfer_length_type;
345
349typedef enum
350{
351 TMR_CTRL1_ADDRESS = 0x0000,
352 TMR_CTRL2_ADDRESS = 0x0001,
353 TMR_STCTRL_ADDRESS = 0x0002,
354 TMR_IDEN_ADDRESS = 0x0003,
355 TMR_ISTS_ADDRESS = 0x0004,
356 TMR_SWEVT_ADDRESS = 0x0005,
357 TMR_CM1_ADDRESS = 0x0006,
358 TMR_CM2_ADDRESS = 0x0007,
359 TMR_CCTRL_ADDRESS = 0x0008,
360 TMR_CVAL_ADDRESS = 0x0009,
361 TMR_DIV_ADDRESS = 0x000A,
362 TMR_PR_ADDRESS = 0x000B,
363 TMR_RPR_ADDRESS = 0x000C,
364 TMR_C1DT_ADDRESS = 0x000D,
365 TMR_C2DT_ADDRESS = 0x000E,
366 TMR_C3DT_ADDRESS = 0x000F,
367 TMR_C4DT_ADDRESS = 0x0010,
368 TMR_BRK_ADDRESS = 0x0011,
369 TMR_DMACTRL_ADDRESS = 0x0012
370}tmr_dma_address_type;
371
375typedef enum
376{
377 TMR_BRK_INPUT_ACTIVE_LOW = 0x00,
378 TMR_BRK_INPUT_ACTIVE_HIGH = 0x01
379}tmr_brk_polarity_type;
380
384typedef enum
385{
386 TMR_WP_OFF = 0x00,
387 TMR_WP_LEVEL_3 = 0x01,
388 TMR_WP_LEVEL_2 = 0x02,
389 TMR_WP_LEVEL_1 = 0x03
390}tmr_wp_level_type;
391
395typedef struct
396{
397 tmr_output_control_mode_type oc_mode;
398 confirm_state oc_idle_state;
399 confirm_state occ_idle_state;
400 tmr_output_polarity_type oc_polarity;
401 tmr_output_polarity_type occ_polarity;
402 confirm_state oc_output_state;
403 confirm_state occ_output_state;
404} tmr_output_config_type;
405
409typedef struct
410{
411 tmr_channel_select_type input_channel_select;
412 tmr_input_polarity_type input_polarity_select;
413 tmr_input_direction_mapped_type input_mapped_select;
414 uint8_t input_filter_value;
415} tmr_input_config_type;
416
420typedef struct
421{
422 uint8_t deadtime;
423 tmr_brk_polarity_type brk_polarity;
424 tmr_wp_level_type wp_level;
425 confirm_state auto_output_enable;
426 confirm_state fcsoen_state;
427 confirm_state fcsodis_state;
428 confirm_state brk_enable;
429} tmr_brkdt_config_type;
430
434typedef struct
435{
439 union
440 {
441 __IO uint32_t ctrl1;
442 struct
443 {
444 __IO uint32_t tmren : 1; /* [0] */
445 __IO uint32_t ovfen : 1; /* [1] */
446 __IO uint32_t ovfs : 1; /* [2] */
447 __IO uint32_t ocmen : 1; /* [3] */
448 __IO uint32_t cnt_dir : 3; /* [6:4] */
449 __IO uint32_t prben : 1; /* [7] */
450 __IO uint32_t clkdiv : 2; /* [9:8] */
451 __IO uint32_t pmen : 1; /* [10] */
452 __IO uint32_t reserved1 : 21;/* [31:11] */
453 } ctrl1_bit;
454 };
455
459 union
460 {
461 __IO uint32_t ctrl2;
462 struct
463 {
464 __IO uint32_t cbctrl : 1; /* [0] */
465 __IO uint32_t reserved1 : 1; /* [1] */
466 __IO uint32_t ccfs : 1; /* [2] */
467 __IO uint32_t drs : 1; /* [3] */
468 __IO uint32_t ptos : 3; /* [6:4] */
469 __IO uint32_t c1insel : 1; /* [7] */
470 __IO uint32_t c1ios : 1; /* [8] */
471 __IO uint32_t c1cios : 1; /* [9] */
472 __IO uint32_t c2ios : 1; /* [10] */
473 __IO uint32_t c2cios : 1; /* [11] */
474 __IO uint32_t c3ios : 1; /* [12] */
475 __IO uint32_t c3cios : 1; /* [13] */
476 __IO uint32_t c4ios : 1; /* [14] */
477 __IO uint32_t reserved2 : 17;/* [31:15] */
478 } ctrl2_bit;
479 };
480
484 union
485 {
486 __IO uint32_t stctrl;
487 struct
488 {
489 __IO uint32_t smsel : 3; /* [2:0] */
490 __IO uint32_t reserved1 : 1; /* [3] */
491 __IO uint32_t stis : 3; /* [6:4] */
492 __IO uint32_t sts : 1; /* [7] */
493 __IO uint32_t esf : 4; /* [11:8] */
494 __IO uint32_t esdiv : 2; /* [13:12] */
495 __IO uint32_t ecmben : 1; /* [14] */
496 __IO uint32_t esp : 1; /* [15] */
497 __IO uint32_t reserved2 : 16;/* [31:16] */
498 } stctrl_bit;
499 };
500
504 union
505 {
506 __IO uint32_t iden;
507 struct
508 {
509 __IO uint32_t ovfien : 1; /* [0] */
510 __IO uint32_t c1ien : 1; /* [1] */
511 __IO uint32_t c2ien : 1; /* [2] */
512 __IO uint32_t c3ien : 1; /* [3] */
513 __IO uint32_t c4ien : 1; /* [4] */
514 __IO uint32_t hallien : 1; /* [5] */
515 __IO uint32_t tien : 1; /* [6] */
516 __IO uint32_t brkie : 1; /* [7] */
517 __IO uint32_t ovfden : 1; /* [8] */
518 __IO uint32_t c1den : 1; /* [9] */
519 __IO uint32_t c2den : 1; /* [10] */
520 __IO uint32_t c3den : 1; /* [11] */
521 __IO uint32_t c4den : 1; /* [12] */
522 __IO uint32_t hallde : 1; /* [13] */
523 __IO uint32_t tden : 1; /* [14] */
524 __IO uint32_t reserved1 : 17;/* [31:15] */
525 } iden_bit;
526 };
527
531 union
532 {
533 __IO uint32_t ists;
534 struct
535 {
536 __IO uint32_t ovfif : 1; /* [0] */
537 __IO uint32_t c1if : 1; /* [1] */
538 __IO uint32_t c2if : 1; /* [2] */
539 __IO uint32_t c3if : 1; /* [3] */
540 __IO uint32_t c4if : 1; /* [4] */
541 __IO uint32_t hallif : 1; /* [5] */
542 __IO uint32_t trgif : 1; /* [6] */
543 __IO uint32_t brkif : 1; /* [7] */
544 __IO uint32_t reserved1 : 1; /* [8] */
545 __IO uint32_t c1rf : 1; /* [9] */
546 __IO uint32_t c2rf : 1; /* [10] */
547 __IO uint32_t c3rf : 1; /* [11] */
548 __IO uint32_t c4rf : 1; /* [12] */
549 __IO uint32_t reserved2 : 19;/* [31:13] */
550 } ists_bit;
551 };
552
556 union
557 {
558 __IO uint32_t swevt;
559 struct
560 {
561 __IO uint32_t ovfswtr : 1; /* [0] */
562 __IO uint32_t c1swtr : 1; /* [1] */
563 __IO uint32_t c2swtr : 1; /* [2] */
564 __IO uint32_t c3swtr : 1; /* [3] */
565 __IO uint32_t c4swtr : 1; /* [4] */
566 __IO uint32_t hallswtr : 1; /* [5] */
567 __IO uint32_t trgswtr : 1; /* [6] */
568 __IO uint32_t brkswtr : 1; /* [7] */
569 __IO uint32_t reserved : 24;/* [31:8] */
570 } swevt_bit;
571 };
572
576 union
577 {
578 __IO uint32_t cm1;
579
583 struct
584 {
585 __IO uint32_t c1c : 2; /* [1:0] */
586 __IO uint32_t c1oien : 1; /* [2] */
587 __IO uint32_t c1oben : 1; /* [3] */
588 __IO uint32_t c1octrl : 3; /* [6:4] */
589 __IO uint32_t c1osen : 1; /* [7] */
590 __IO uint32_t c2c : 2; /* [9:8] */
591 __IO uint32_t c2oien : 1; /* [10] */
592 __IO uint32_t c2oben : 1; /* [11] */
593 __IO uint32_t c2octrl : 3; /* [14:12] */
594 __IO uint32_t c2osen : 1; /* [15] */
595 __IO uint32_t reserved1 : 16;/* [31:16] */
596 } cm1_output_bit;
597
601 struct
602 {
603 __IO uint32_t c1c : 2; /* [1:0] */
604 __IO uint32_t c1idiv : 2; /* [3:2] */
605 __IO uint32_t c1df : 4; /* [7:4] */
606 __IO uint32_t c2c : 2; /* [9:8] */
607 __IO uint32_t c2idiv : 2; /* [11:10] */
608 __IO uint32_t c2df : 4; /* [15:12] */
609 __IO uint32_t reserved1 : 16;/* [31:16] */
610 } cm1_input_bit;
611 };
612
616 union
617 {
618 __IO uint32_t cm2;
619
623 struct
624 {
625 __IO uint32_t c3c : 2; /* [1:0] */
626 __IO uint32_t c3oien : 1; /* [2] */
627 __IO uint32_t c3oben : 1; /* [3] */
628 __IO uint32_t c3octrl : 3; /* [6:4] */
629 __IO uint32_t c3osen : 1; /* [7] */
630 __IO uint32_t c4c : 2; /* [9:8] */
631 __IO uint32_t c4oien : 1; /* [10] */
632 __IO uint32_t c4oben : 1; /* [11] */
633 __IO uint32_t c4octrl : 3; /* [14:12] */
634 __IO uint32_t c4osen : 1; /* [15] */
635 __IO uint32_t reserved1 : 16;/* [31:16] */
636 } cm2_output_bit;
637
641 struct
642 {
643 __IO uint32_t c3c : 2; /* [1:0] */
644 __IO uint32_t c3idiv : 2; /* [3:2] */
645 __IO uint32_t c3df : 4; /* [7:4] */
646 __IO uint32_t c4c : 2; /* [9:8] */
647 __IO uint32_t c4idiv : 2; /* [11:10] */
648 __IO uint32_t c4df : 4; /* [15:12] */
649 __IO uint32_t reserved1 : 16;/* [31:16] */
650 } cm2_input_bit;
651 };
652
656 union
657 {
658 uint32_t cctrl;
659 struct
660 {
661 __IO uint32_t c1en : 1; /* [0] */
662 __IO uint32_t c1p : 1; /* [1] */
663 __IO uint32_t c1cen : 1; /* [2] */
664 __IO uint32_t c1cp : 1; /* [3] */
665 __IO uint32_t c2en : 1; /* [4] */
666 __IO uint32_t c2p : 1; /* [5] */
667 __IO uint32_t c2cen : 1; /* [6] */
668 __IO uint32_t c2cp : 1; /* [7] */
669 __IO uint32_t c3en : 1; /* [8] */
670 __IO uint32_t c3p : 1; /* [9] */
671 __IO uint32_t c3cen : 1; /* [10] */
672 __IO uint32_t c3cp : 1; /* [11] */
673 __IO uint32_t c4en : 1; /* [12] */
674 __IO uint32_t c4p : 1; /* [13] */
675 __IO uint32_t reserved1 : 18;/* [31:14] */
676 } cctrl_bit;
677 };
678
682 union
683 {
684 __IO uint32_t cval;
685 struct
686 {
687 __IO uint32_t cval : 32;/* [31:0] */
688 } cval_bit;
689 };
690
694 union
695 {
696 __IO uint32_t div;
697 struct
698 {
699 __IO uint32_t div : 16;/* [15:0] */
700 __IO uint32_t reserved1 : 16;/* [31:16] */
701 } div_bit;
702 };
703
707 union
708 {
709 __IO uint32_t pr;
710 struct
711 {
712 __IO uint32_t pr : 32;/* [31:0] */
713 } pr_bit;
714 };
715
719 union
720 {
721 __IO uint32_t rpr;
722 struct
723 {
724 __IO uint32_t rpr : 8; /* [7:0] */
725 __IO uint32_t reserved1 : 24;/* [31:8] */
726 } rpr_bit;
727 };
728
732 union
733 {
734 uint32_t c1dt;
735 struct
736 {
737 __IO uint32_t c1dt : 32;/* [31:0] */
738 } c1dt_bit;
739 };
740
744 union
745 {
746 uint32_t c2dt;
747 struct
748 {
749 __IO uint32_t c2dt : 32;/* [31:0] */
750 } c2dt_bit;
751 };
752
756 union
757 {
758 __IO uint32_t c3dt;
759 struct
760 {
761 __IO uint32_t c3dt : 32;/* [31:0] */
762 } c3dt_bit;
763 };
764
768 union
769 {
770 __IO uint32_t c4dt;
771 struct
772 {
773 __IO uint32_t c4dt : 32;/* [31:0] */
774 } c4dt_bit;
775 };
776
780 union
781 {
782 __IO uint32_t brk;
783 struct
784 {
785 __IO uint32_t dtc : 8; /* [7:0] */
786 __IO uint32_t wpc : 2; /* [9:8] */
787 __IO uint32_t fcsodis : 1; /* [10] */
788 __IO uint32_t fcsoen : 1; /* [11] */
789 __IO uint32_t brken : 1; /* [12] */
790 __IO uint32_t brkv : 1; /* [13] */
791 __IO uint32_t aoen : 1; /* [14] */
792 __IO uint32_t oen : 1; /* [15] */
793 __IO uint32_t reserved1 : 16; /* [31:16] */
794 } brk_bit;
795 };
799 union
800 {
801 __IO uint32_t dmactrl;
802 struct
803 {
804 __IO uint32_t addr : 5; /* [4:0] */
805 __IO uint32_t reserved1 : 3; /* [7:5] */
806 __IO uint32_t dtb : 5; /* [12:8] */
807 __IO uint32_t reserved2 : 19;/* [31:13] */
808 } dmactrl_bit;
809 };
810
814 union
815 {
816 __IO uint32_t dmadt;
817 struct
818 {
819 __IO uint32_t dmadt : 16;/* [15:0] */
820 __IO uint32_t reserved1 : 16;/* [31:16] */
821 } dmadt_bit;
822 };
823
824} tmr_type;
825
830#define TMR1 ((tmr_type *) TMR1_BASE)
831#define TMR2 ((tmr_type *) TMR2_BASE)
832#define TMR3 ((tmr_type *) TMR3_BASE)
833#define TMR4 ((tmr_type *) TMR4_BASE)
834#if defined (AT32F413TBU7) || defined (AT32F413Rx) || defined (AT32F413Cx) || \
835 defined (AT32F413Kx)
836#define TMR5 ((tmr_type *) TMR5_BASE)
837#if defined (AT32F413CCU7) || defined (AT32F413CCT7) || defined (AT32F413RCT7)
838#define TMR8 ((tmr_type *) TMR8_BASE)
839#endif
840#define TMR9 ((tmr_type *) TMR9_BASE)
841#define TMR10 ((tmr_type *) TMR10_BASE)
842#define TMR11 ((tmr_type *) TMR11_BASE)
843#endif
844
849void tmr_reset(tmr_type *tmr_x);
850void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state);
851void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct);
852void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct);
853void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct);
854void tmr_base_init(tmr_type* tmr_x, uint32_t tmr_pr, uint32_t tmr_div);
855void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div);
856void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir);
857void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value);
858void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value);
859uint32_t tmr_counter_value_get(tmr_type *tmr_x);
860void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value);
861uint32_t tmr_div_value_get(tmr_type *tmr_x);
862void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
863 tmr_output_config_type *tmr_output_struct);
864void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
865 tmr_output_control_mode_type oc_mode);
866void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value);
867uint32_t tmr_period_value_get(tmr_type *tmr_x);
868void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
869 uint32_t tmr_channel_value);
870uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel);
871void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state);
872void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
873 confirm_state new_state);
874void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
875 confirm_state new_state);
876void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
877 confirm_state new_state);
878void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state);
879void tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state);
880void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state);
881void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state);
882void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
883 tmr_channel_input_divider_type divider_factor);
884void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state);
885void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
886 uint16_t filter_value);
887void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
888 tmr_channel_input_divider_type divider_factor);
889void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect);
890void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
891 tmr_channel_input_divider_type divider_factor);
892void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode);
893void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode);
894void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select);
895void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state);
896void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state);
897void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select);
898void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state);
899void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state);
900void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state);
901 flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag);
902void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag);
903void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event);
904void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state);
905void tmr_internal_clock_set(tmr_type *tmr_x);
906
907void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
908 tmr_polarity_active_type oc_polarity);
909void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
910 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
911void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
912 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
913void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
914 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
915void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type \
916 ic1_polarity, tmr_input_polarity_type ic2_polarity);
917void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
918 tmr_force_output_type force_output);
919void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, \
920 tmr_dma_address_type dma_base_address);
921void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct);
922
935#ifdef __cplusplus
936}
937#endif
938
939#endif
at32f413.h
at32f413 header file
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:37
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f413_tmr.c:1706
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:545
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_period_value_get
uint32_t tmr_period_value_get(tmr_type *tmr_x)
get tmr period value
Definition: at32f413_tmr.c:479
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer
Definition: at32f413_tmr.c:1228
tmr_overflow_request_source_set
void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources
Definition: at32f413_tmr.c:775
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f413_tmr.c:423
tmr_input_channel_divider_set
void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider
Definition: at32f413_tmr.c:1117
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1286
tmr_external_clock_config
void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock
Definition: at32f413_tmr.c:1523
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f413_tmr.c:238
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:586
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_internal_clock_set
void tmr_internal_clock_set(tmr_type *tmr_x)
set tmr select internal clock
Definition: at32f413_tmr.c:1437
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:156
tmr_force_output_set
void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output
Definition: at32f413_tmr.c:1640
tmr_counter_value_set
void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value
Definition: at32f413_tmr.c:254
tmr_div_value_get
uint32_t tmr_div_value_get(tmr_type *tmr_x)
get tmr div value
Definition: at32f413_tmr.c:296
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_input_channel_filter_set
void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter
Definition: at32f413_tmr.c:938
tmr_period_value_set
void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value
Definition: at32f413_tmr.c:463
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:268
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time
Definition: at32f413_tmr.c:1722
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_external_clock_mode2_config
void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2
Definition: at32f413_tmr.c:1575
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:142
tmr_div_value_set
void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value
Definition: at32f413_tmr.c:282
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1263
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_hall_select
void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
select tmr hall
Definition: at32f413_tmr.c:1215
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input
Definition: at32f413_tmr.c:1092
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:752
tmr_external_clock_mode1_config
void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1
Definition: at32f413_tmr.c:1549
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:984
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:607
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1164
tmr_overflow_event_disable
void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation
Definition: at32f413_tmr.c:789
tmr_channel_dma_select
void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma
Definition: at32f413_tmr.c:1202
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_output_channel_immediately_set
void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately
Definition: at32f413_tmr.c:653
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f413_tmr.c:1604
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:882
tmr_output_channel_switch_set
void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch
Definition: at32f413_tmr.c:699
tmr_reset
void tmr_reset(tmr_type *tmr_x)
tmr reset by crm reset register
Definition: at32f413_tmr.c:50
tmr_output_channel_polarity_set
void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity
Definition: at32f413_tmr.c:1463
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f413_tmr.c:738
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
tmr_dma_request_type
tmr_dma_request_type
tmr dma request type
Definition: at32f413_tmr.h:266
tmr_external_signal_divider_type
tmr_external_signal_divider_type
tmr external signal divider type
Definition: at32f413_tmr.h:305
tmr_polarity_active_type
tmr_polarity_active_type
tmr polarity active type
Definition: at32f413_tmr.h:295
tmr_count_mode_type
tmr_count_mode_type
tmr counter mode type
Definition: at32f413_tmr.h:103
tmr_input_polarity_type
tmr_input_polarity_type
tmr input channel polarity type
Definition: at32f413_tmr.h:203
tmr_dma_request_source_type
tmr_dma_request_source_type
tmr dma request source select type
Definition: at32f413_tmr.h:257
tmr_channel_select_type
tmr_channel_select_type
tmr channel select type
Definition: at32f413_tmr.h:213
tmr_external_signal_polarity_type
tmr_external_signal_polarity_type
tmr external signal polarity type
Definition: at32f413_tmr.h:316
tmr_dma_address_type
tmr_dma_address_type
tmr dma base address type
Definition: at32f413_tmr.h:350
tmr_wp_level_type
tmr_wp_level_type
tmr write protect level type
Definition: at32f413_tmr.h:385
tmr_channel1_input_connected_type
tmr_channel1_input_connected_type
tmr channel1 input connected type
Definition: at32f413_tmr.h:227
tmr_input_direction_mapped_type
tmr_input_direction_mapped_type
tmr input channel mapped type channel direction
Definition: at32f413_tmr.h:236
tmr_clock_division_type
tmr_clock_division_type
tmr clock division type
Definition: at32f413_tmr.h:93
tmr_event_trigger_type
tmr_event_trigger_type
tmr event triggered by software type
Definition: at32f413_tmr.h:280
tmr_brk_polarity_type
tmr_brk_polarity_type
tmr brk polarity type
Definition: at32f413_tmr.h:376
tmr_output_control_mode_type
tmr_output_control_mode_type
tmr output control mode type
Definition: at32f413_tmr.h:170
tmr_output_polarity_type
tmr_output_polarity_type
tmr output channel polarity type
Definition: at32f413_tmr.h:194
tmr_dma_transfer_length_type
tmr_dma_transfer_length_type
tmr dma transfer length type
Definition: at32f413_tmr.h:325
sub_tmr_input_sel_type
sub_tmr_input_sel_type
tmr subordinate mode input select type
Definition: at32f413_tmr.h:130
tmr_force_output_type
tmr_force_output_type
tmr force output type
Definition: at32f413_tmr.h:185
tmr_sub_mode_select_type
tmr_sub_mode_select_type
tmr subordinate mode select type
Definition: at32f413_tmr.h:145
tmr_primary_select_type
tmr_primary_select_type
tmr primary mode select type
Definition: at32f413_tmr.h:115
tmr_encoder_mode_type
tmr_encoder_mode_type
tmr encoder mode type
Definition: at32f413_tmr.h:160
tmr_channel_input_divider_type
tmr_channel_input_divider_type
tmr input divider type
Definition: at32f413_tmr.h:246
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:267
TMR_HALL_DMA_REQUEST
@ TMR_HALL_DMA_REQUEST
Definition: at32f413_tmr.h:272
TMR_C1_DMA_REQUEST
@ TMR_C1_DMA_REQUEST
Definition: at32f413_tmr.h:268
TMR_C2_DMA_REQUEST
@ TMR_C2_DMA_REQUEST
Definition: at32f413_tmr.h:269
TMR_C3_DMA_REQUEST
@ TMR_C3_DMA_REQUEST
Definition: at32f413_tmr.h:270
TMR_TRIGGER_DMA_REQUEST
@ TMR_TRIGGER_DMA_REQUEST
Definition: at32f413_tmr.h:273
TMR_C4_DMA_REQUEST
@ TMR_C4_DMA_REQUEST
Definition: at32f413_tmr.h:271
TMR_ES_FREQUENCY_DIV_1
@ TMR_ES_FREQUENCY_DIV_1
Definition: at32f413_tmr.h:306
TMR_ES_FREQUENCY_DIV_8
@ TMR_ES_FREQUENCY_DIV_8
Definition: at32f413_tmr.h:309
TMR_ES_FREQUENCY_DIV_4
@ TMR_ES_FREQUENCY_DIV_4
Definition: at32f413_tmr.h:308
TMR_ES_FREQUENCY_DIV_2
@ TMR_ES_FREQUENCY_DIV_2
Definition: at32f413_tmr.h:307
TMR_POLARITY_ACTIVE_HIGH
@ TMR_POLARITY_ACTIVE_HIGH
Definition: at32f413_tmr.h:296
TMR_POLARITY_ACTIVE_LOW
@ TMR_POLARITY_ACTIVE_LOW
Definition: at32f413_tmr.h:297
TMR_POLARITY_ACTIVE_BOTH
@ TMR_POLARITY_ACTIVE_BOTH
Definition: at32f413_tmr.h:298
TMR_COUNT_DOWN
@ TMR_COUNT_DOWN
Definition: at32f413_tmr.h:105
TMR_COUNT_TWO_WAY_2
@ TMR_COUNT_TWO_WAY_2
Definition: at32f413_tmr.h:107
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_COUNT_TWO_WAY_3
@ TMR_COUNT_TWO_WAY_3
Definition: at32f413_tmr.h:108
TMR_COUNT_TWO_WAY_1
@ TMR_COUNT_TWO_WAY_1
Definition: at32f413_tmr.h:106
TMR_INPUT_BOTH_EDGE
@ TMR_INPUT_BOTH_EDGE
Definition: at32f413_tmr.h:206
TMR_INPUT_FALLING_EDGE
@ TMR_INPUT_FALLING_EDGE
Definition: at32f413_tmr.h:205
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_DMA_REQUEST_BY_CHANNEL
@ TMR_DMA_REQUEST_BY_CHANNEL
Definition: at32f413_tmr.h:258
TMR_DMA_REQUEST_BY_OVERFLOW
@ TMR_DMA_REQUEST_BY_OVERFLOW
Definition: at32f413_tmr.h:259
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f413_tmr.h:215
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f413_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f413_tmr.h:219
TMR_ES_POLARITY_INVERTED
@ TMR_ES_POLARITY_INVERTED
Definition: at32f413_tmr.h:318
TMR_ES_POLARITY_NON_INVERTED
@ TMR_ES_POLARITY_NON_INVERTED
Definition: at32f413_tmr.h:317
TMR_C2DT_ADDRESS
@ TMR_C2DT_ADDRESS
Definition: at32f413_tmr.h:365
TMR_C1DT_ADDRESS
@ TMR_C1DT_ADDRESS
Definition: at32f413_tmr.h:364
TMR_STCTRL_ADDRESS
@ TMR_STCTRL_ADDRESS
Definition: at32f413_tmr.h:353
TMR_BRK_ADDRESS
@ TMR_BRK_ADDRESS
Definition: at32f413_tmr.h:368
TMR_CTRL2_ADDRESS
@ TMR_CTRL2_ADDRESS
Definition: at32f413_tmr.h:352
TMR_PR_ADDRESS
@ TMR_PR_ADDRESS
Definition: at32f413_tmr.h:362
TMR_CVAL_ADDRESS
@ TMR_CVAL_ADDRESS
Definition: at32f413_tmr.h:360
TMR_CM1_ADDRESS
@ TMR_CM1_ADDRESS
Definition: at32f413_tmr.h:357
TMR_IDEN_ADDRESS
@ TMR_IDEN_ADDRESS
Definition: at32f413_tmr.h:354
TMR_DMACTRL_ADDRESS
@ TMR_DMACTRL_ADDRESS
Definition: at32f413_tmr.h:369
TMR_CCTRL_ADDRESS
@ TMR_CCTRL_ADDRESS
Definition: at32f413_tmr.h:359
TMR_RPR_ADDRESS
@ TMR_RPR_ADDRESS
Definition: at32f413_tmr.h:363
TMR_ISTS_ADDRESS
@ TMR_ISTS_ADDRESS
Definition: at32f413_tmr.h:355
TMR_C4DT_ADDRESS
@ TMR_C4DT_ADDRESS
Definition: at32f413_tmr.h:367
TMR_DIV_ADDRESS
@ TMR_DIV_ADDRESS
Definition: at32f413_tmr.h:361
TMR_SWEVT_ADDRESS
@ TMR_SWEVT_ADDRESS
Definition: at32f413_tmr.h:356
TMR_CM2_ADDRESS
@ TMR_CM2_ADDRESS
Definition: at32f413_tmr.h:358
TMR_C3DT_ADDRESS
@ TMR_C3DT_ADDRESS
Definition: at32f413_tmr.h:366
TMR_CTRL1_ADDRESS
@ TMR_CTRL1_ADDRESS
Definition: at32f413_tmr.h:351
TMR_WP_LEVEL_3
@ TMR_WP_LEVEL_3
Definition: at32f413_tmr.h:387
TMR_WP_LEVEL_2
@ TMR_WP_LEVEL_2
Definition: at32f413_tmr.h:388
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f413_tmr.h:386
TMR_WP_LEVEL_1
@ TMR_WP_LEVEL_1
Definition: at32f413_tmr.h:389
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
@ TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Definition: at32f413_tmr.h:229
TMR_CHANEL1_CONNECTED_C1IRAW
@ TMR_CHANEL1_CONNECTED_C1IRAW
Definition: at32f413_tmr.h:228
TMR_CC_CHANNEL_MAPPED_STI
@ TMR_CC_CHANNEL_MAPPED_STI
Definition: at32f413_tmr.h:239
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_CC_CHANNEL_MAPPED_INDIRECT
@ TMR_CC_CHANNEL_MAPPED_INDIRECT
Definition: at32f413_tmr.h:238
TMR_CLOCK_DIV2
@ TMR_CLOCK_DIV2
Definition: at32f413_tmr.h:95
TMR_CLOCK_DIV4
@ TMR_CLOCK_DIV4
Definition: at32f413_tmr.h:96
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_C1_SWTRIG
@ TMR_C1_SWTRIG
Definition: at32f413_tmr.h:282
TMR_C3_SWTRIG
@ TMR_C3_SWTRIG
Definition: at32f413_tmr.h:284
TMR_C2_SWTRIG
@ TMR_C2_SWTRIG
Definition: at32f413_tmr.h:283
TMR_C4_SWTRIG
@ TMR_C4_SWTRIG
Definition: at32f413_tmr.h:285
TMR_BRK_SWTRIG
@ TMR_BRK_SWTRIG
Definition: at32f413_tmr.h:288
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR_TRIGGER_SWTRIG
@ TMR_TRIGGER_SWTRIG
Definition: at32f413_tmr.h:287
TMR_OVERFLOW_SWTRIG
@ TMR_OVERFLOW_SWTRIG
Definition: at32f413_tmr.h:281
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:378
TMR_BRK_INPUT_ACTIVE_LOW
@ TMR_BRK_INPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:377
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:178
TMR_OUTPUT_CONTROL_FORCE_HIGH
@ TMR_OUTPUT_CONTROL_FORCE_HIGH
Definition: at32f413_tmr.h:176
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:174
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:171
TMR_OUTPUT_CONTROL_LOW
@ TMR_OUTPUT_CONTROL_LOW
Definition: at32f413_tmr.h:173
TMR_OUTPUT_CONTROL_FORCE_LOW
@ TMR_OUTPUT_CONTROL_FORCE_LOW
Definition: at32f413_tmr.h:175
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_CONTROL_HIGH
@ TMR_OUTPUT_CONTROL_HIGH
Definition: at32f413_tmr.h:172
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR_DMA_TRANSFER_15BYTES
@ TMR_DMA_TRANSFER_15BYTES
Definition: at32f413_tmr.h:340
TMR_DMA_TRANSFER_11BYTES
@ TMR_DMA_TRANSFER_11BYTES
Definition: at32f413_tmr.h:336
TMR_DMA_TRANSFER_13BYTES
@ TMR_DMA_TRANSFER_13BYTES
Definition: at32f413_tmr.h:338
TMR_DMA_TRANSFER_14BYTES
@ TMR_DMA_TRANSFER_14BYTES
Definition: at32f413_tmr.h:339
TMR_DMA_TRANSFER_2BYTES
@ TMR_DMA_TRANSFER_2BYTES
Definition: at32f413_tmr.h:327
TMR_DMA_TRANSFER_18BYTES
@ TMR_DMA_TRANSFER_18BYTES
Definition: at32f413_tmr.h:343
TMR_DMA_TRANSFER_9BYTES
@ TMR_DMA_TRANSFER_9BYTES
Definition: at32f413_tmr.h:334
TMR_DMA_TRANSFER_12BYTES
@ TMR_DMA_TRANSFER_12BYTES
Definition: at32f413_tmr.h:337
TMR_DMA_TRANSFER_7BYTES
@ TMR_DMA_TRANSFER_7BYTES
Definition: at32f413_tmr.h:332
TMR_DMA_TRANSFER_17BYTES
@ TMR_DMA_TRANSFER_17BYTES
Definition: at32f413_tmr.h:342
TMR_DMA_TRANSFER_16BYTES
@ TMR_DMA_TRANSFER_16BYTES
Definition: at32f413_tmr.h:341
TMR_DMA_TRANSFER_5BYTES
@ TMR_DMA_TRANSFER_5BYTES
Definition: at32f413_tmr.h:330
TMR_DMA_TRANSFER_10BYTES
@ TMR_DMA_TRANSFER_10BYTES
Definition: at32f413_tmr.h:335
TMR_DMA_TRANSFER_1BYTE
@ TMR_DMA_TRANSFER_1BYTE
Definition: at32f413_tmr.h:326
TMR_DMA_TRANSFER_6BYTES
@ TMR_DMA_TRANSFER_6BYTES
Definition: at32f413_tmr.h:331
TMR_DMA_TRANSFER_4BYTES
@ TMR_DMA_TRANSFER_4BYTES
Definition: at32f413_tmr.h:329
TMR_DMA_TRANSFER_8BYTES
@ TMR_DMA_TRANSFER_8BYTES
Definition: at32f413_tmr.h:333
TMR_DMA_TRANSFER_3BYTES
@ TMR_DMA_TRANSFER_3BYTES
Definition: at32f413_tmr.h:328
TMR_SUB_INPUT_SEL_IS2
@ TMR_SUB_INPUT_SEL_IS2
Definition: at32f413_tmr.h:133
TMR_SUB_INPUT_SEL_IS0
@ TMR_SUB_INPUT_SEL_IS0
Definition: at32f413_tmr.h:131
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:137
TMR_SUB_INPUT_SEL_EXTIN
@ TMR_SUB_INPUT_SEL_EXTIN
Definition: at32f413_tmr.h:138
TMR_SUB_INPUT_SEL_IS3
@ TMR_SUB_INPUT_SEL_IS3
Definition: at32f413_tmr.h:134
TMR_SUB_INPUT_SEL_C1DF1
@ TMR_SUB_INPUT_SEL_C1DF1
Definition: at32f413_tmr.h:136
TMR_SUB_INPUT_SEL_C1INC
@ TMR_SUB_INPUT_SEL_C1INC
Definition: at32f413_tmr.h:135
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f413_tmr.h:132
TMR_FORCE_OUTPUT_HIGH
@ TMR_FORCE_OUTPUT_HIGH
Definition: at32f413_tmr.h:186
TMR_FORCE_OUTPUT_LOW
@ TMR_FORCE_OUTPUT_LOW
Definition: at32f413_tmr.h:187
TMR_SUB_ENCODER_MODE_A
@ TMR_SUB_ENCODER_MODE_A
Definition: at32f413_tmr.h:147
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f413_tmr.h:153
TMR_SUB_ENCODER_MODE_C
@ TMR_SUB_ENCODER_MODE_C
Definition: at32f413_tmr.h:149
TMR_SUB_MODE_DIABLE
@ TMR_SUB_MODE_DIABLE
Definition: at32f413_tmr.h:146
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:150
TMR_SUB_ENCODER_MODE_B
@ TMR_SUB_ENCODER_MODE_B
Definition: at32f413_tmr.h:148
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:151
TMR_SUB_TRIGGER_MODE
@ TMR_SUB_TRIGGER_MODE
Definition: at32f413_tmr.h:152
TMR_PRIMARY_SEL_RESET
@ TMR_PRIMARY_SEL_RESET
Definition: at32f413_tmr.h:116
TMR_PRIMARY_SEL_C2ORAW
@ TMR_PRIMARY_SEL_C2ORAW
Definition: at32f413_tmr.h:121
TMR_PRIMARY_SEL_C1ORAW
@ TMR_PRIMARY_SEL_C1ORAW
Definition: at32f413_tmr.h:120
TMR_PRIMARY_SEL_C4ORAW
@ TMR_PRIMARY_SEL_C4ORAW
Definition: at32f413_tmr.h:123
TMR_PRIMARY_SEL_COMPARE
@ TMR_PRIMARY_SEL_COMPARE
Definition: at32f413_tmr.h:119
TMR_PRIMARY_SEL_ENABLE
@ TMR_PRIMARY_SEL_ENABLE
Definition: at32f413_tmr.h:117
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:118
TMR_PRIMARY_SEL_C3ORAW
@ TMR_PRIMARY_SEL_C3ORAW
Definition: at32f413_tmr.h:122
TMR_ENCODER_MODE_C
@ TMR_ENCODER_MODE_C
Definition: at32f413_tmr.h:163
TMR_ENCODER_MODE_A
@ TMR_ENCODER_MODE_A
Definition: at32f413_tmr.h:161
TMR_ENCODER_MODE_B
@ TMR_ENCODER_MODE_B
Definition: at32f413_tmr.h:162
TMR_CHANNEL_INPUT_DIV_4
@ TMR_CHANNEL_INPUT_DIV_4
Definition: at32f413_tmr.h:249
TMR_CHANNEL_INPUT_DIV_2
@ TMR_CHANNEL_INPUT_DIV_2
Definition: at32f413_tmr.h:248
TMR_CHANNEL_INPUT_DIV_8
@ TMR_CHANNEL_INPUT_DIV_8
Definition: at32f413_tmr.h:250
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:421
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:422
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:425
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:423
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
tmr_type
type define tmr register all
Definition: at32f413_tmr.h:435
tmr_type::ovfif
__IO uint32_t ovfif
Definition: at32f413_tmr.h:536
tmr_type::c1cen
__IO uint32_t c1cen
Definition: at32f413_tmr.h:663
tmr_type::pmen
__IO uint32_t pmen
Definition: at32f413_tmr.h:451
tmr_type::trgif
__IO uint32_t trgif
Definition: at32f413_tmr.h:542
tmr_type::brken
__IO uint32_t brken
Definition: at32f413_tmr.h:789
tmr_type::c1idiv
__IO uint32_t c1idiv
Definition: at32f413_tmr.h:604
tmr_type::dmactrl
__IO uint32_t dmactrl
Definition: at32f413_tmr.h:801
tmr_type::dtc
__IO uint32_t dtc
Definition: at32f413_tmr.h:785
tmr_type::c1en
__IO uint32_t c1en
Definition: at32f413_tmr.h:661
tmr_type::c4df
__IO uint32_t c4df
Definition: at32f413_tmr.h:648
tmr_type::c3octrl
__IO uint32_t c3octrl
Definition: at32f413_tmr.h:628
tmr_type::brkif
__IO uint32_t brkif
Definition: at32f413_tmr.h:543
tmr_type::c2osen
__IO uint32_t c2osen
Definition: at32f413_tmr.h:594
tmr_type::swevt
__IO uint32_t swevt
Definition: at32f413_tmr.h:558
tmr_type::ovfden
__IO uint32_t ovfden
Definition: at32f413_tmr.h:517
tmr_type::c2en
__IO uint32_t c2en
Definition: at32f413_tmr.h:665
tmr_type::stctrl
__IO uint32_t stctrl
Definition: at32f413_tmr.h:486
tmr_type::c3df
__IO uint32_t c3df
Definition: at32f413_tmr.h:645
tmr_type::wpc
__IO uint32_t wpc
Definition: at32f413_tmr.h:786
tmr_type::c3oben
__IO uint32_t c3oben
Definition: at32f413_tmr.h:627
tmr_type::cnt_dir
__IO uint32_t cnt_dir
Definition: at32f413_tmr.h:448
tmr_type::c2if
__IO uint32_t c2if
Definition: at32f413_tmr.h:538
tmr_type::c3if
__IO uint32_t c3if
Definition: at32f413_tmr.h:539
tmr_type::c4octrl
__IO uint32_t c4octrl
Definition: at32f413_tmr.h:633
tmr_type::hallif
__IO uint32_t hallif
Definition: at32f413_tmr.h:541
tmr_type::c1insel
__IO uint32_t c1insel
Definition: at32f413_tmr.h:469
tmr_type::c2cios
__IO uint32_t c2cios
Definition: at32f413_tmr.h:473
tmr_type::div
__IO uint32_t div
Definition: at32f413_tmr.h:696
tmr_type::hallswtr
__IO uint32_t hallswtr
Definition: at32f413_tmr.h:566
tmr_type::esf
__IO uint32_t esf
Definition: at32f413_tmr.h:493
tmr_type::c1osen
__IO uint32_t c1osen
Definition: at32f413_tmr.h:589
tmr_type::c2cen
__IO uint32_t c2cen
Definition: at32f413_tmr.h:667
tmr_type::c2ien
__IO uint32_t c2ien
Definition: at32f413_tmr.h:511
tmr_type::drs
__IO uint32_t drs
Definition: at32f413_tmr.h:467
tmr_type::iden
__IO uint32_t iden
Definition: at32f413_tmr.h:506
tmr_type::c1oben
__IO uint32_t c1oben
Definition: at32f413_tmr.h:587
tmr_type::ists
__IO uint32_t ists
Definition: at32f413_tmr.h:533
tmr_type::c1c
__IO uint32_t c1c
Definition: at32f413_tmr.h:585
tmr_type::c3cen
__IO uint32_t c3cen
Definition: at32f413_tmr.h:671
tmr_type::c4p
__IO uint32_t c4p
Definition: at32f413_tmr.h:674
tmr_type::brkv
__IO uint32_t brkv
Definition: at32f413_tmr.h:790
tmr_type::brk
__IO uint32_t brk
Definition: at32f413_tmr.h:782
tmr_type::stis
__IO uint32_t stis
Definition: at32f413_tmr.h:491
tmr_type::ovfswtr
__IO uint32_t ovfswtr
Definition: at32f413_tmr.h:561
tmr_type::c3idiv
__IO uint32_t c3idiv
Definition: at32f413_tmr.h:644
tmr_type::c4osen
__IO uint32_t c4osen
Definition: at32f413_tmr.h:634
tmr_type::c1ien
__IO uint32_t c1ien
Definition: at32f413_tmr.h:510
tmr_type::c1octrl
__IO uint32_t c1octrl
Definition: at32f413_tmr.h:588
tmr_type::hallien
__IO uint32_t hallien
Definition: at32f413_tmr.h:514
tmr_type::tmren
__IO uint32_t tmren
Definition: at32f413_tmr.h:444
tmr_type::oen
__IO uint32_t oen
Definition: at32f413_tmr.h:792
tmr_type::sts
__IO uint32_t sts
Definition: at32f413_tmr.h:492
tmr_type::brkie
__IO uint32_t brkie
Definition: at32f413_tmr.h:516
tmr_type::c2idiv
__IO uint32_t c2idiv
Definition: at32f413_tmr.h:607
tmr_type::c1p
__IO uint32_t c1p
Definition: at32f413_tmr.h:662
tmr_type::brkswtr
__IO uint32_t brkswtr
Definition: at32f413_tmr.h:568
tmr_type::c1rf
__IO uint32_t c1rf
Definition: at32f413_tmr.h:545
tmr_type::ovfien
__IO uint32_t ovfien
Definition: at32f413_tmr.h:509
tmr_type::c1oien
__IO uint32_t c1oien
Definition: at32f413_tmr.h:586
tmr_type::pr
__IO uint32_t pr
Definition: at32f413_tmr.h:709
tmr_type::c3oien
__IO uint32_t c3oien
Definition: at32f413_tmr.h:626
tmr_type::c2swtr
__IO uint32_t c2swtr
Definition: at32f413_tmr.h:563
tmr_type::c1dt
uint32_t c1dt
Definition: at32f413_tmr.h:734
tmr_type::c2oben
__IO uint32_t c2oben
Definition: at32f413_tmr.h:592
tmr_type::c1den
__IO uint32_t c1den
Definition: at32f413_tmr.h:518
tmr_type::cm2
__IO uint32_t cm2
Definition: at32f413_tmr.h:618
tmr_type::c2octrl
__IO uint32_t c2octrl
Definition: at32f413_tmr.h:593
tmr_type::smsel
__IO uint32_t smsel
Definition: at32f413_tmr.h:489
tmr_type::c3p
__IO uint32_t c3p
Definition: at32f413_tmr.h:670
tmr_type::c2dt
__IO uint32_t c2dt
Definition: at32f413_tmr.h:749
tmr_type::dmadt
__IO uint32_t dmadt
Definition: at32f413_tmr.h:816
tmr_type::c1if
__IO uint32_t c1if
Definition: at32f413_tmr.h:537
tmr_type::c1cp
__IO uint32_t c1cp
Definition: at32f413_tmr.h:664
tmr_type::c3c
__IO uint32_t c3c
Definition: at32f413_tmr.h:625
tmr_type::c4rf
__IO uint32_t c4rf
Definition: at32f413_tmr.h:548
tmr_type::c3cios
__IO uint32_t c3cios
Definition: at32f413_tmr.h:475
tmr_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f413_tmr.h:450
tmr_type::tden
__IO uint32_t tden
Definition: at32f413_tmr.h:523
tmr_type::ovfs
__IO uint32_t ovfs
Definition: at32f413_tmr.h:446
tmr_type::c1dt
__IO uint32_t c1dt
Definition: at32f413_tmr.h:737
tmr_type::c3swtr
__IO uint32_t c3swtr
Definition: at32f413_tmr.h:564
tmr_type::cbctrl
__IO uint32_t cbctrl
Definition: at32f413_tmr.h:464
tmr_type::dtb
__IO uint32_t dtb
Definition: at32f413_tmr.h:806
tmr_type::c4ios
__IO uint32_t c4ios
Definition: at32f413_tmr.h:476
tmr_type::c4swtr
__IO uint32_t c4swtr
Definition: at32f413_tmr.h:565
tmr_type::prben
__IO uint32_t prben
Definition: at32f413_tmr.h:449
tmr_type::tien
__IO uint32_t tien
Definition: at32f413_tmr.h:515
tmr_type::ccfs
__IO uint32_t ccfs
Definition: at32f413_tmr.h:466
tmr_type::ecmben
__IO uint32_t ecmben
Definition: at32f413_tmr.h:495
tmr_type::ovfen
__IO uint32_t ovfen
Definition: at32f413_tmr.h:445
tmr_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_tmr.h:477
tmr_type::cm1
__IO uint32_t cm1
Definition: at32f413_tmr.h:578
tmr_type::c2den
__IO uint32_t c2den
Definition: at32f413_tmr.h:519
tmr_type::c4en
__IO uint32_t c4en
Definition: at32f413_tmr.h:673
tmr_type::reserved
__IO uint32_t reserved
Definition: at32f413_tmr.h:569
tmr_type::trgswtr
__IO uint32_t trgswtr
Definition: at32f413_tmr.h:567
tmr_type::fcsoen
__IO uint32_t fcsoen
Definition: at32f413_tmr.h:788
tmr_type::esdiv
__IO uint32_t esdiv
Definition: at32f413_tmr.h:494
tmr_type::c3en
__IO uint32_t c3en
Definition: at32f413_tmr.h:669
tmr_type::c2p
__IO uint32_t c2p
Definition: at32f413_tmr.h:666
tmr_type::c3ios
__IO uint32_t c3ios
Definition: at32f413_tmr.h:474
tmr_type::ocmen
__IO uint32_t ocmen
Definition: at32f413_tmr.h:447
tmr_type::hallde
__IO uint32_t hallde
Definition: at32f413_tmr.h:522
tmr_type::c1swtr
__IO uint32_t c1swtr
Definition: at32f413_tmr.h:562
tmr_type::c3rf
__IO uint32_t c3rf
Definition: at32f413_tmr.h:547
tmr_type::c3den
__IO uint32_t c3den
Definition: at32f413_tmr.h:520
tmr_type::c4oien
__IO uint32_t c4oien
Definition: at32f413_tmr.h:631
tmr_type::c2dt
uint32_t c2dt
Definition: at32f413_tmr.h:746
tmr_type::addr
__IO uint32_t addr
Definition: at32f413_tmr.h:804
tmr_type::c3cp
__IO uint32_t c3cp
Definition: at32f413_tmr.h:672
tmr_type::c2df
__IO uint32_t c2df
Definition: at32f413_tmr.h:608
tmr_type::c4idiv
__IO uint32_t c4idiv
Definition: at32f413_tmr.h:647
tmr_type::c2ios
__IO uint32_t c2ios
Definition: at32f413_tmr.h:472
tmr_type::c3osen
__IO uint32_t c3osen
Definition: at32f413_tmr.h:629
tmr_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_tmr.h:452
tmr_type::rpr
__IO uint32_t rpr
Definition: at32f413_tmr.h:721
tmr_type::c2c
__IO uint32_t c2c
Definition: at32f413_tmr.h:590
tmr_type::c1ios
__IO uint32_t c1ios
Definition: at32f413_tmr.h:470
tmr_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_tmr.h:441
tmr_type::c4den
__IO uint32_t c4den
Definition: at32f413_tmr.h:521
tmr_type::c1df
__IO uint32_t c1df
Definition: at32f413_tmr.h:605
tmr_type::c2oien
__IO uint32_t c2oien
Definition: at32f413_tmr.h:591
tmr_type::c4dt
__IO uint32_t c4dt
Definition: at32f413_tmr.h:770
tmr_type::c4if
__IO uint32_t c4if
Definition: at32f413_tmr.h:540
tmr_type::c3ien
__IO uint32_t c3ien
Definition: at32f413_tmr.h:512
tmr_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_tmr.h:461
tmr_type::c3dt
__IO uint32_t c3dt
Definition: at32f413_tmr.h:758
tmr_type::c2cp
__IO uint32_t c2cp
Definition: at32f413_tmr.h:668
tmr_type::cctrl
uint32_t cctrl
Definition: at32f413_tmr.h:658
tmr_type::c4c
__IO uint32_t c4c
Definition: at32f413_tmr.h:630
tmr_type::c4oben
__IO uint32_t c4oben
Definition: at32f413_tmr.h:632
tmr_type::fcsodis
__IO uint32_t fcsodis
Definition: at32f413_tmr.h:787
tmr_type::cval
__IO uint32_t cval
Definition: at32f413_tmr.h:684
tmr_type::c4ien
__IO uint32_t c4ien
Definition: at32f413_tmr.h:513
tmr_type::esp
__IO uint32_t esp
Definition: at32f413_tmr.h:496
tmr_type::ptos
__IO uint32_t ptos
Definition: at32f413_tmr.h:468
tmr_type::c1cios
__IO uint32_t c1cios
Definition: at32f413_tmr.h:471
tmr_type::aoen
__IO uint32_t aoen
Definition: at32f413_tmr.h:791
tmr_type::c2rf
__IO uint32_t c2rf
Definition: at32f413_tmr.h:546


AT32F413 Firmwary Library: at32f413_usart.c Source File

  • libraries
  • drivers
  • src
at32f413_usart.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_conf.h"
27
37#ifdef USART_MODULE_ENABLED
38
50void usart_reset(usart_type* usart_x)
51{
52 if(usart_x == USART1)
53 {
54 crm_periph_reset(CRM_USART1_PERIPH_RESET, TRUE);
55 crm_periph_reset(CRM_USART1_PERIPH_RESET, FALSE);
56 }
57 else if(usart_x == USART2)
58 {
59 crm_periph_reset(CRM_USART2_PERIPH_RESET, TRUE);
60 crm_periph_reset(CRM_USART2_PERIPH_RESET, FALSE);
61 }
62#if defined (AT32F413Rx) || defined (AT32F413Cx) || defined (AT32FEBKC8T7)
63 else if(usart_x == USART3)
64 {
65 crm_periph_reset(CRM_USART3_PERIPH_RESET, TRUE);
66 crm_periph_reset(CRM_USART3_PERIPH_RESET, FALSE);
67 }
68#endif
69#if defined (AT32F413Rx)
70 else if(usart_x == UART4)
71 {
72 crm_periph_reset(CRM_UART4_PERIPH_RESET, TRUE);
73 crm_periph_reset(CRM_UART4_PERIPH_RESET, FALSE);
74 }
75 else if(usart_x == UART5)
76 {
77 crm_periph_reset(CRM_UART5_PERIPH_RESET, TRUE);
78 crm_periph_reset(CRM_UART5_PERIPH_RESET, FALSE);
79 }
80#endif
81}
82
104void usart_init(usart_type* usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
105{
106 crm_clocks_freq_type clocks_freq;
107 uint32_t apb_clock, temp_val;
108 crm_clocks_freq_get(&clocks_freq);
109 if(usart_x == USART1)
110 {
111 apb_clock = clocks_freq.apb2_freq;
112 }
113 else
114 {
115 apb_clock = clocks_freq.apb1_freq;
116 }
117 temp_val = (apb_clock * 10 / baud_rate);
118 if((temp_val % 10) < 5)
119 {
120 temp_val = (temp_val / 10);
121 }
122 else
123 {
124 temp_val = (temp_val / 10) + 1;
125 }
126 usart_x->baudr_bit.div = temp_val;
127 usart_x->ctrl1_bit.dbn = data_bit;
128 usart_x->ctrl2_bit.stopbn = stop_bit;
129}
130
143void usart_parity_selection_config(usart_type* usart_x, usart_parity_selection_type parity)
144{
145 if(parity == USART_PARITY_NONE)
146 {
147 usart_x->ctrl1_bit.psel = FALSE;
148 usart_x->ctrl1_bit.pen = FALSE;
149 }
150 else if(parity == USART_PARITY_EVEN)
151 {
152 usart_x->ctrl1_bit.psel = FALSE;
153 usart_x->ctrl1_bit.pen = TRUE;
154 }
155 else if(parity == USART_PARITY_ODD)
156 {
157 usart_x->ctrl1_bit.psel = TRUE;
158 usart_x->ctrl1_bit.pen = TRUE;
159 }
160}
161
171void usart_enable(usart_type* usart_x, confirm_state new_state)
172{
173 usart_x->ctrl1_bit.uen = new_state;
174}
175
184void usart_transmitter_enable(usart_type* usart_x, confirm_state new_state)
185{
186 usart_x->ctrl1_bit.ten = new_state;
187}
188
197void usart_receiver_enable(usart_type* usart_x, confirm_state new_state)
198{
199 usart_x->ctrl1_bit.ren = new_state;
200}
201
222void usart_clock_config(usart_type* usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
223{
224 usart_x->ctrl2_bit.clkpol = clk_pol;
225 usart_x->ctrl2_bit.clkpha = clk_pha;
226 usart_x->ctrl2_bit.lbcp = clk_lb;
227}
228
238void usart_clock_enable(usart_type* usart_x, confirm_state new_state)
239{
240 usart_x->ctrl2_bit.clken = new_state;
241}
242
262void usart_interrupt_enable(usart_type* usart_x, uint32_t usart_int, confirm_state new_state)
263{
264 if(new_state == TRUE)
265 PERIPH_REG((uint32_t)usart_x, usart_int) |= PERIPH_REG_BIT(usart_int);
266 else
267 PERIPH_REG((uint32_t)usart_x, usart_int) &= ~PERIPH_REG_BIT(usart_int);
268}
269
279void usart_dma_transmitter_enable(usart_type* usart_x, confirm_state new_state)
280{
281 usart_x->ctrl3_bit.dmaten = new_state;
282}
283
293void usart_dma_receiver_enable(usart_type* usart_x, confirm_state new_state)
294{
295 usart_x->ctrl3_bit.dmaren = new_state;
296}
297
306void usart_wakeup_id_set(usart_type* usart_x, uint8_t usart_id)
307{
308 usart_x->ctrl2_bit.id = usart_id;
309}
310
322void usart_wakeup_mode_set(usart_type* usart_x, usart_wakeup_mode_type wakeup_mode)
323{
324 usart_x->ctrl1_bit.wum = wakeup_mode;
325}
326
336void usart_receiver_mute_enable(usart_type* usart_x, confirm_state new_state)
337{
338 usart_x->ctrl1_bit.rm = new_state;
339}
340
352void usart_break_bit_num_set(usart_type* usart_x, usart_break_bit_num_type break_bit)
353{
354 usart_x->ctrl2_bit.bfbn = break_bit;
355}
356
366void usart_lin_mode_enable(usart_type* usart_x, confirm_state new_state)
367{
368 usart_x->ctrl2_bit.linen = new_state;
369}
370
379void usart_data_transmit(usart_type* usart_x, uint16_t data)
380{
381 usart_x->dt = (data & 0x01FF);
382}
383
391uint16_t usart_data_receive(usart_type* usart_x)
392{
393 return (uint16_t)(usart_x->dt);
394}
395
403void usart_break_send(usart_type* usart_x)
404{
405 usart_x->ctrl1_bit.sbf = TRUE;
406}
407
417void usart_smartcard_guard_time_set(usart_type* usart_x, uint8_t guard_time_val)
418{
419 usart_x->gdiv_bit.scgt = guard_time_val;
420}
421
431void usart_irda_smartcard_division_set(usart_type* usart_x, uint8_t div_val)
432{
433 usart_x->gdiv_bit.isdiv = div_val;
434}
435
446void usart_smartcard_mode_enable(usart_type* usart_x, confirm_state new_state)
447{
448 usart_x->ctrl3_bit.scmen = new_state;
449}
450
461void usart_smartcard_nack_set(usart_type* usart_x, confirm_state new_state)
462{
463 usart_x->ctrl3_bit.scnacken = new_state;
464}
465
475void usart_single_line_halfduplex_select(usart_type* usart_x, confirm_state new_state)
476{
477 usart_x->ctrl3_bit.slben = new_state;
478}
479
489void usart_irda_mode_enable(usart_type* usart_x, confirm_state new_state)
490{
491 usart_x->ctrl3_bit.irdaen = new_state;
492}
493
503void usart_irda_low_power_enable(usart_type* usart_x, confirm_state new_state)
504{
505 usart_x->ctrl3_bit.irdalp = new_state;
506}
507
521void usart_hardware_flow_control_set(usart_type* usart_x,usart_hardware_flow_control_type flow_state)
522{
523 if(flow_state == USART_HARDWARE_FLOW_NONE)
524 {
525 usart_x->ctrl3_bit.rtsen = FALSE;
526 usart_x->ctrl3_bit.ctsen = FALSE;
527 }
528 else if(flow_state == USART_HARDWARE_FLOW_RTS)
529 {
530 usart_x->ctrl3_bit.rtsen = TRUE;
531 usart_x->ctrl3_bit.ctsen = FALSE;
532 }
533 else if(flow_state == USART_HARDWARE_FLOW_CTS)
534 {
535 usart_x->ctrl3_bit.rtsen = FALSE;
536 usart_x->ctrl3_bit.ctsen = TRUE;
537 }
538 else if(flow_state == USART_HARDWARE_FLOW_RTS_CTS)
539 {
540 usart_x->ctrl3_bit.rtsen = TRUE;
541 usart_x->ctrl3_bit.ctsen = TRUE;
542 }
543}
544
564 flag_status usart_flag_get(usart_type* usart_x, uint32_t flag)
565{
566 if(usart_x->sts & flag)
567 {
568 return SET;
569 }
570 else
571 {
572 return RESET;
573 }
574}
575
602void usart_flag_clear(usart_type* usart_x, uint32_t flag)
603{
604 if(flag & (USART_PERR_FLAG | USART_FERR_FLAG | USART_NERR_FLAG | USART_ROERR_FLAG | USART_IDLEF_FLAG))
605 {
606 UNUSED(usart_x->sts);
607 UNUSED(usart_x->dt);
608 }
609 else
610 {
611 usart_x->sts = ~flag;
612 }
613}
614
619#endif
620
UNUSED
#define UNUSED(x)
Definition: at32f413_def.h:63
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_UART4_PERIPH_RESET
@ CRM_UART4_PERIPH_RESET
Definition: at32f413_crm.h:176
CRM_USART1_PERIPH_RESET
@ CRM_USART1_PERIPH_RESET
Definition: at32f413_crm.h:162
CRM_USART2_PERIPH_RESET
@ CRM_USART2_PERIPH_RESET
Definition: at32f413_crm.h:174
CRM_UART5_PERIPH_RESET
@ CRM_UART5_PERIPH_RESET
Definition: at32f413_crm.h:177
CRM_USART3_PERIPH_RESET
@ CRM_USART3_PERIPH_RESET
Definition: at32f413_crm.h:175
PERIPH_REG
#define PERIPH_REG(periph_base, value)
Definition: at32f413.h:317
PERIPH_REG_BIT
#define PERIPH_REG_BIT(value)
Definition: at32f413.h:318
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
usart_break_bit_num_type
usart_break_bit_num_type
usart break frame bit num type
Definition: at32f413_usart.h:119
usart_clock_polarity_type
usart_clock_polarity_type
usart polarity of the clock type
Definition: at32f413_usart.h:137
usart_hardware_flow_control_type
usart_hardware_flow_control_type
usart hardware flow control type
Definition: at32f413_usart.h:166
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f413_usart.h:155
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f413_usart.h:110
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f413_usart.h:91
usart_lbcp_type
usart_lbcp_type
usart last bit clock pulse type
Definition: at32f413_usart.h:146
usart_wakeup_mode_type
usart_wakeup_mode_type
usart wakeup mode type
Definition: at32f413_usart.h:101
usart_clock_phase_type
usart_clock_phase_type
usart phase of the clock type
Definition: at32f413_usart.h:128
USART_HARDWARE_FLOW_CTS
@ USART_HARDWARE_FLOW_CTS
Definition: at32f413_usart.h:169
USART_HARDWARE_FLOW_RTS
@ USART_HARDWARE_FLOW_RTS
Definition: at32f413_usart.h:168
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f413_usart.h:167
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f413_usart.h:170
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f413_usart.h:94
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:93
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:92
USART_NERR_FLAG
#define USART_NERR_FLAG
Definition: at32f413_usart.h:52
USART_FERR_FLAG
#define USART_FERR_FLAG
Definition: at32f413_usart.h:51
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f413_usart.h:54
USART_ROERR_FLAG
#define USART_ROERR_FLAG
Definition: at32f413_usart.h:53
USART_PERR_FLAG
#define USART_PERR_FLAG
Definition: at32f413_usart.h:50
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:238
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f413_usart.c:461
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f413_usart.c:222
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:143
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f413_usart.c:306
usart_reset
void usart_reset(usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values.
Definition: at32f413_usart.c:50
usart_lin_mode_enable
void usart_lin_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode.
Definition: at32f413_usart.c:366
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:293
usart_irda_low_power_enable
void usart_irda_low_power_enable(usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power.
Definition: at32f413_usart.c:503
usart_break_send
void usart_break_send(usart_type *usart_x)
transmit break characters.
Definition: at32f413_usart.c:403
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:431
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f413_usart.c:417
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f413_usart.c:602
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f413_usart.c:322
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f413_usart.c:489
usart_break_bit_num_set
void usart_break_bit_num_set(usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num.
Definition: at32f413_usart.c:352
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:521
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f413_usart.c:475
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:279
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f413_usart.c:446
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f413_usart.c:336
USART1
#define USART1
Definition: at32f413_usart.h:317
USART2
#define USART2
Definition: at32f413_usart.h:318
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:473
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f413_crm.h:472
usart_type
type define usart register all
Definition: at32f413_usart.h:177
usart_type::scmen
__IO uint32_t scmen
Definition: at32f413_usart.h:288
usart_type::scgt
__IO uint32_t scgt
Definition: at32f413_usart.h:307
usart_type::clken
__IO uint32_t clken
Definition: at32f413_usart.h:268
usart_type::linen
__IO uint32_t linen
Definition: at32f413_usart.h:270
usart_type::psel
__IO uint32_t psel
Definition: at32f413_usart.h:243
usart_type::sbf
__IO uint32_t sbf
Definition: at32f413_usart.h:234
usart_type::slben
__IO uint32_t slben
Definition: at32f413_usart.h:286
usart_type::gdiv_bit
struct usart_type::@725::@733 gdiv_bit
usart_type::isdiv
__IO uint32_t isdiv
Definition: at32f413_usart.h:306
usart_type::id
__IO uint32_t id
Definition: at32f413_usart.h:260
usart_type::ctrl3_bit
struct usart_type::@723::@732 ctrl3_bit
usart_type::wum
__IO uint32_t wum
Definition: at32f413_usart.h:245
usart_type::ctrl1_bit
struct usart_type::@719::@730 ctrl1_bit
usart_type::pen
__IO uint32_t pen
Definition: at32f413_usart.h:244
usart_type::scnacken
__IO uint32_t scnacken
Definition: at32f413_usart.h:287
usart_type::ctsen
__IO uint32_t ctsen
Definition: at32f413_usart.h:292
usart_type::baudr_bit
struct usart_type::@717::@729 baudr_bit
usart_type::uen
__IO uint32_t uen
Definition: at32f413_usart.h:247
usart_type::dbn
__IO uint32_t dbn
Definition: at32f413_usart.h:246
usart_type::rm
__IO uint32_t rm
Definition: at32f413_usart.h:235
usart_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_usart.h:266
usart_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_usart.h:267
usart_type::rtsen
__IO uint32_t rtsen
Definition: at32f413_usart.h:291
usart_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_usart.h:289
usart_type::lbcp
__IO uint32_t lbcp
Definition: at32f413_usart.h:265
usart_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_usart.h:290
usart_type::sts
__IO uint32_t sts
Definition: at32f413_usart.h:183
usart_type::ren
__IO uint32_t ren
Definition: at32f413_usart.h:236
usart_type::irdaen
__IO uint32_t irdaen
Definition: at32f413_usart.h:284
usart_type::ten
__IO uint32_t ten
Definition: at32f413_usart.h:237
usart_type::div
__IO uint32_t div
Definition: at32f413_usart.h:221
usart_type::stopbn
__IO uint32_t stopbn
Definition: at32f413_usart.h:269
usart_type::irdalp
__IO uint32_t irdalp
Definition: at32f413_usart.h:285
usart_type::dt
__IO uint32_t dt
Definition: at32f413_usart.h:205
usart_type::bfbn
__IO uint32_t bfbn
Definition: at32f413_usart.h:262
usart_type::ctrl2_bit
struct usart_type::@721::@731 ctrl2_bit
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_usart.h Source File

  • libraries
  • drivers
  • inc
at32f413_usart.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_USART_H
27#define __AT32F413_USART_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define USART_PERR_FLAG ((uint32_t)0x00000001)
51#define USART_FERR_FLAG ((uint32_t)0x00000002)
52#define USART_NERR_FLAG ((uint32_t)0x00000004)
53#define USART_ROERR_FLAG ((uint32_t)0x00000008)
54#define USART_IDLEF_FLAG ((uint32_t)0x00000010)
55#define USART_RDBF_FLAG ((uint32_t)0x00000020)
56#define USART_TDC_FLAG ((uint32_t)0x00000040)
57#define USART_TDBE_FLAG ((uint32_t)0x00000080)
58#define USART_BFF_FLAG ((uint32_t)0x00000100)
59#define USART_CTSCF_FLAG ((uint32_t)0x00000200)
70#define USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
71#define USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
72#define USART_TDC_INT MAKE_VALUE(0x0C,0x06)
73#define USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
74#define USART_PERR_INT MAKE_VALUE(0x0C,0x08)
75#define USART_BF_INT MAKE_VALUE(0x10,0x06)
76#define USART_ERR_INT MAKE_VALUE(0x14,0x00)
77#define USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)
90typedef enum
91{
92 USART_PARITY_NONE = 0x00,
93 USART_PARITY_EVEN = 0x01,
94 USART_PARITY_ODD = 0x02
95} usart_parity_selection_type;
96
100typedef enum
101{
102 USART_WAKEUP_BY_IDLE_FRAME = 0x00,
103 USART_WAKEUP_BY_MATCHING_ID = 0x01
104} usart_wakeup_mode_type;
105
109typedef enum
110{
111 USART_DATA_8BITS = 0x00,
112 USART_DATA_9BITS = 0x01
113} usart_data_bit_num_type;
114
118typedef enum
119{
120 USART_BREAK_10BITS = 0x00,
121 USART_BREAK_11BITS = 0x01
122} usart_break_bit_num_type;
123
127typedef enum
128{
129 USART_CLOCK_PHASE_1EDGE = 0x00,
130 USART_CLOCK_PHASE_2EDGE = 0x01
131} usart_clock_phase_type;
132
136typedef enum
137{
138 USART_CLOCK_POLARITY_LOW = 0x00,
139 USART_CLOCK_POLARITY_HIGH = 0x01
140} usart_clock_polarity_type;
141
145typedef enum
146{
147 USART_CLOCK_LAST_BIT_NONE = 0x00,
148 USART_CLOCK_LAST_BIT_OUTPUT = 0x01
149} usart_lbcp_type;
150
154typedef enum
155{
156 USART_STOP_1_BIT = 0x00,
157 USART_STOP_0_5_BIT = 0x01,
158 USART_STOP_2_BIT = 0x02,
159 USART_STOP_1_5_BIT = 0x03
160} usart_stop_bit_num_type;
161
165typedef enum
166{
167 USART_HARDWARE_FLOW_NONE = 0x00,
168 USART_HARDWARE_FLOW_RTS = 0x01,
169 USART_HARDWARE_FLOW_CTS = 0x02,
170 USART_HARDWARE_FLOW_RTS_CTS = 0x03
171} usart_hardware_flow_control_type;
172
176typedef struct
177{
181 union
182 {
183 __IO uint32_t sts;
184 struct
185 {
186 __IO uint32_t perr : 1; /* [0] */
187 __IO uint32_t ferr : 1; /* [1] */
188 __IO uint32_t nerr : 1; /* [2] */
189 __IO uint32_t roerr : 1; /* [3] */
190 __IO uint32_t idlef : 1; /* [4] */
191 __IO uint32_t rdbf : 1; /* [5] */
192 __IO uint32_t tdc : 1; /* [6] */
193 __IO uint32_t tdbe : 1; /* [7] */
194 __IO uint32_t bff : 1; /* [8] */
195 __IO uint32_t ctscf : 1; /* [9] */
196 __IO uint32_t reserved1 : 22;/* [31:10] */
197 } sts_bit;
198 };
199
203 union
204 {
205 __IO uint32_t dt;
206 struct
207 {
208 __IO uint32_t dt : 9; /* [8:0] */
209 __IO uint32_t reserved1 : 23;/* [31:9] */
210 } dt_bit;
211 };
212
216 union
217 {
218 __IO uint32_t baudr;
219 struct
220 {
221 __IO uint32_t div : 16;/* [15:0] */
222 __IO uint32_t reserved1 : 16;/* [31:16] */
223 } baudr_bit;
224 };
225
229 union
230 {
231 __IO uint32_t ctrl1;
232 struct
233 {
234 __IO uint32_t sbf : 1; /* [0] */
235 __IO uint32_t rm : 1; /* [1] */
236 __IO uint32_t ren : 1; /* [2] */
237 __IO uint32_t ten : 1; /* [3] */
238 __IO uint32_t idleien : 1; /* [4] */
239 __IO uint32_t rdbfien : 1; /* [5] */
240 __IO uint32_t tdcien : 1; /* [6] */
241 __IO uint32_t tdbeien : 1; /* [7] */
242 __IO uint32_t perrien : 1; /* [8] */
243 __IO uint32_t psel : 1; /* [9] */
244 __IO uint32_t pen : 1; /* [10] */
245 __IO uint32_t wum : 1; /* [11] */
246 __IO uint32_t dbn : 1; /* [12] */
247 __IO uint32_t uen : 1; /* [13] */
248 __IO uint32_t reserved1 : 18;/* [31:14] */
249 } ctrl1_bit;
250 };
251
255 union
256 {
257 __IO uint32_t ctrl2;
258 struct
259 {
260 __IO uint32_t id : 4; /* [3:0] */
261 __IO uint32_t reserved1 : 1; /* [4] */
262 __IO uint32_t bfbn : 1; /* [5] */
263 __IO uint32_t bfien : 1; /* [6] */
264 __IO uint32_t reserved2 : 1; /* [7] */
265 __IO uint32_t lbcp : 1; /* [8] */
266 __IO uint32_t clkpha : 1; /* [9] */
267 __IO uint32_t clkpol : 1; /* [10] */
268 __IO uint32_t clken : 1; /* [11] */
269 __IO uint32_t stopbn : 2; /* [13:12] */
270 __IO uint32_t linen : 1; /* [14] */
271 __IO uint32_t reserved3 : 17;/* [31:15] */
272 } ctrl2_bit;
273 };
274
278 union
279 {
280 __IO uint32_t ctrl3;
281 struct
282 {
283 __IO uint32_t errien : 1; /* [0] */
284 __IO uint32_t irdaen : 1; /* [1] */
285 __IO uint32_t irdalp : 1; /* [2] */
286 __IO uint32_t slben : 1; /* [3] */
287 __IO uint32_t scnacken : 1; /* [4] */
288 __IO uint32_t scmen : 1; /* [5] */
289 __IO uint32_t dmaren : 1; /* [6] */
290 __IO uint32_t dmaten : 1; /* [7] */
291 __IO uint32_t rtsen : 1; /* [8] */
292 __IO uint32_t ctsen : 1; /* [9] */
293 __IO uint32_t ctscfien : 1; /* [10] */
294 __IO uint32_t reserved1 : 21;/* [31:11] */
295 } ctrl3_bit;
296 };
297
301 union
302 {
303 __IO uint32_t gdiv;
304 struct
305 {
306 __IO uint32_t isdiv : 8; /* [7:0] */
307 __IO uint32_t scgt : 8; /* [15:8] */
308 __IO uint32_t reserved1 : 16;/* [31:16] */
309 } gdiv_bit;
310 };
311} usart_type;
312
317#define USART1 ((usart_type *) USART1_BASE)
318#define USART2 ((usart_type *) USART2_BASE)
319#if defined (AT32F413Rx) || defined (AT32F413Cx) || defined (AT32FEBKC8T7)
320#define USART3 ((usart_type *) USART3_BASE)
321#endif
322#if defined (AT32F413Rx)
323#define UART4 ((usart_type *) UART4_BASE)
324#define UART5 ((usart_type *) UART5_BASE)
325#endif
326
331void usart_reset(usart_type* usart_x);
332void usart_init(usart_type* usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit);
333void usart_parity_selection_config(usart_type* usart_x, usart_parity_selection_type parity);
334void usart_enable(usart_type* usart_x, confirm_state new_state);
335void usart_transmitter_enable(usart_type* usart_x, confirm_state new_state);
336void usart_receiver_enable(usart_type* usart_x, confirm_state new_state);
337void usart_clock_config(usart_type* usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb);
338void usart_clock_enable(usart_type* usart_x, confirm_state new_state);
339void usart_interrupt_enable(usart_type* usart_x, uint32_t usart_int, confirm_state new_state);
340void usart_dma_transmitter_enable(usart_type* usart_x, confirm_state new_state);
341void usart_dma_receiver_enable(usart_type* usart_x, confirm_state new_state);
342void usart_wakeup_id_set(usart_type* usart_x, uint8_t usart_id);
343void usart_wakeup_mode_set(usart_type* usart_x, usart_wakeup_mode_type wakeup_mode);
344void usart_receiver_mute_enable(usart_type* usart_x, confirm_state new_state);
345void usart_break_bit_num_set(usart_type* usart_x, usart_break_bit_num_type break_bit);
346void usart_lin_mode_enable(usart_type* usart_x, confirm_state new_state);
347void usart_data_transmit(usart_type* usart_x, uint16_t data);
348uint16_t usart_data_receive(usart_type* usart_x);
349void usart_break_send(usart_type* usart_x);
350void usart_smartcard_guard_time_set(usart_type* usart_x, uint8_t guard_time_val);
351void usart_irda_smartcard_division_set(usart_type* usart_x, uint8_t div_val);
352void usart_smartcard_mode_enable(usart_type* usart_x, confirm_state new_state);
353void usart_smartcard_nack_set(usart_type* usart_x, confirm_state new_state);
354void usart_single_line_halfduplex_select(usart_type* usart_x, confirm_state new_state);
355void usart_irda_mode_enable(usart_type* usart_x, confirm_state new_state);
356void usart_irda_low_power_enable(usart_type* usart_x, confirm_state new_state);
357void usart_hardware_flow_control_set(usart_type* usart_x,usart_hardware_flow_control_type flow_state);
358 flag_status usart_flag_get(usart_type* usart_x, uint32_t flag);
359void usart_flag_clear(usart_type* usart_x, uint32_t flag);
360
373#ifdef __cplusplus
374}
375#endif
376
377#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:238
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f413_usart.c:461
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f413_usart.c:222
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:143
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f413_usart.c:306
usart_reset
void usart_reset(usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values.
Definition: at32f413_usart.c:50
usart_lin_mode_enable
void usart_lin_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode.
Definition: at32f413_usart.c:366
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:293
usart_irda_low_power_enable
void usart_irda_low_power_enable(usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power.
Definition: at32f413_usart.c:503
usart_break_send
void usart_break_send(usart_type *usart_x)
transmit break characters.
Definition: at32f413_usart.c:403
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:431
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f413_usart.c:417
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f413_usart.c:602
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f413_usart.c:322
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f413_usart.c:489
usart_break_bit_num_set
void usart_break_bit_num_set(usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num.
Definition: at32f413_usart.c:352
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:521
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f413_usart.c:475
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:279
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f413_usart.c:446
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f413_usart.c:336
usart_break_bit_num_type
usart_break_bit_num_type
usart break frame bit num type
Definition: at32f413_usart.h:119
usart_clock_polarity_type
usart_clock_polarity_type
usart polarity of the clock type
Definition: at32f413_usart.h:137
usart_hardware_flow_control_type
usart_hardware_flow_control_type
usart hardware flow control type
Definition: at32f413_usart.h:166
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f413_usart.h:155
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f413_usart.h:110
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f413_usart.h:91
usart_lbcp_type
usart_lbcp_type
usart last bit clock pulse type
Definition: at32f413_usart.h:146
usart_wakeup_mode_type
usart_wakeup_mode_type
usart wakeup mode type
Definition: at32f413_usart.h:101
usart_clock_phase_type
usart_clock_phase_type
usart phase of the clock type
Definition: at32f413_usart.h:128
USART_BREAK_11BITS
@ USART_BREAK_11BITS
Definition: at32f413_usart.h:121
USART_BREAK_10BITS
@ USART_BREAK_10BITS
Definition: at32f413_usart.h:120
USART_CLOCK_POLARITY_HIGH
@ USART_CLOCK_POLARITY_HIGH
Definition: at32f413_usart.h:139
USART_CLOCK_POLARITY_LOW
@ USART_CLOCK_POLARITY_LOW
Definition: at32f413_usart.h:138
USART_HARDWARE_FLOW_CTS
@ USART_HARDWARE_FLOW_CTS
Definition: at32f413_usart.h:169
USART_HARDWARE_FLOW_RTS
@ USART_HARDWARE_FLOW_RTS
Definition: at32f413_usart.h:168
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f413_usart.h:167
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f413_usart.h:170
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f413_usart.h:159
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_STOP_0_5_BIT
@ USART_STOP_0_5_BIT
Definition: at32f413_usart.h:157
USART_STOP_2_BIT
@ USART_STOP_2_BIT
Definition: at32f413_usart.h:158
USART_DATA_9BITS
@ USART_DATA_9BITS
Definition: at32f413_usart.h:112
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f413_usart.h:94
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:93
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:92
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f413_usart.h:148
USART_CLOCK_LAST_BIT_NONE
@ USART_CLOCK_LAST_BIT_NONE
Definition: at32f413_usart.h:147
USART_WAKEUP_BY_MATCHING_ID
@ USART_WAKEUP_BY_MATCHING_ID
Definition: at32f413_usart.h:103
USART_WAKEUP_BY_IDLE_FRAME
@ USART_WAKEUP_BY_IDLE_FRAME
Definition: at32f413_usart.h:102
USART_CLOCK_PHASE_1EDGE
@ USART_CLOCK_PHASE_1EDGE
Definition: at32f413_usart.h:129
USART_CLOCK_PHASE_2EDGE
@ USART_CLOCK_PHASE_2EDGE
Definition: at32f413_usart.h:130
usart_type
type define usart register all
Definition: at32f413_usart.h:177
usart_type::scmen
__IO uint32_t scmen
Definition: at32f413_usart.h:288
usart_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_usart.h:257
usart_type::tdcien
__IO uint32_t tdcien
Definition: at32f413_usart.h:240
usart_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_usart.h:196
usart_type::ctrl3
__IO uint32_t ctrl3
Definition: at32f413_usart.h:280
usart_type::scgt
__IO uint32_t scgt
Definition: at32f413_usart.h:307
usart_type::clken
__IO uint32_t clken
Definition: at32f413_usart.h:268
usart_type::linen
__IO uint32_t linen
Definition: at32f413_usart.h:270
usart_type::rdbf
__IO uint32_t rdbf
Definition: at32f413_usart.h:191
usart_type::psel
__IO uint32_t psel
Definition: at32f413_usart.h:243
usart_type::rdbfien
__IO uint32_t rdbfien
Definition: at32f413_usart.h:239
usart_type::sbf
__IO uint32_t sbf
Definition: at32f413_usart.h:234
usart_type::slben
__IO uint32_t slben
Definition: at32f413_usart.h:286
usart_type::tdbeien
__IO uint32_t tdbeien
Definition: at32f413_usart.h:241
usart_type::isdiv
__IO uint32_t isdiv
Definition: at32f413_usart.h:306
usart_type::baudr
__IO uint32_t baudr
Definition: at32f413_usart.h:218
usart_type::ferr
__IO uint32_t ferr
Definition: at32f413_usart.h:187
usart_type::id
__IO uint32_t id
Definition: at32f413_usart.h:260
usart_type::wum
__IO uint32_t wum
Definition: at32f413_usart.h:245
usart_type::pen
__IO uint32_t pen
Definition: at32f413_usart.h:244
usart_type::scnacken
__IO uint32_t scnacken
Definition: at32f413_usart.h:287
usart_type::roerr
__IO uint32_t roerr
Definition: at32f413_usart.h:189
usart_type::ctscfien
__IO uint32_t ctscfien
Definition: at32f413_usart.h:293
usart_type::gdiv
__IO uint32_t gdiv
Definition: at32f413_usart.h:303
usart_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_usart.h:231
usart_type::ctsen
__IO uint32_t ctsen
Definition: at32f413_usart.h:292
usart_type::uen
__IO uint32_t uen
Definition: at32f413_usart.h:247
usart_type::idlef
__IO uint32_t idlef
Definition: at32f413_usart.h:190
usart_type::dbn
__IO uint32_t dbn
Definition: at32f413_usart.h:246
usart_type::rm
__IO uint32_t rm
Definition: at32f413_usart.h:235
usart_type::tdbe
__IO uint32_t tdbe
Definition: at32f413_usart.h:193
usart_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_usart.h:266
usart_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_usart.h:267
usart_type::perr
__IO uint32_t perr
Definition: at32f413_usart.h:186
usart_type::rtsen
__IO uint32_t rtsen
Definition: at32f413_usart.h:291
usart_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_usart.h:271
usart_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_usart.h:289
usart_type::tdc
__IO uint32_t tdc
Definition: at32f413_usart.h:192
usart_type::lbcp
__IO uint32_t lbcp
Definition: at32f413_usart.h:265
usart_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_usart.h:290
usart_type::sts
__IO uint32_t sts
Definition: at32f413_usart.h:183
usart_type::ren
__IO uint32_t ren
Definition: at32f413_usart.h:236
usart_type::errien
__IO uint32_t errien
Definition: at32f413_usart.h:283
usart_type::bff
__IO uint32_t bff
Definition: at32f413_usart.h:194
usart_type::irdaen
__IO uint32_t irdaen
Definition: at32f413_usart.h:284
usart_type::ten
__IO uint32_t ten
Definition: at32f413_usart.h:237
usart_type::div
__IO uint32_t div
Definition: at32f413_usart.h:221
usart_type::ctscf
__IO uint32_t ctscf
Definition: at32f413_usart.h:195
usart_type::nerr
__IO uint32_t nerr
Definition: at32f413_usart.h:188
usart_type::stopbn
__IO uint32_t stopbn
Definition: at32f413_usart.h:269
usart_type::irdalp
__IO uint32_t irdalp
Definition: at32f413_usart.h:285
usart_type::dt
__IO uint32_t dt
Definition: at32f413_usart.h:205
usart_type::perrien
__IO uint32_t perrien
Definition: at32f413_usart.h:242
usart_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_usart.h:264
usart_type::bfien
__IO uint32_t bfien
Definition: at32f413_usart.h:263
usart_type::bfbn
__IO uint32_t bfbn
Definition: at32f413_usart.h:262
usart_type::idleien
__IO uint32_t idleien
Definition: at32f413_usart.h:238


AT32F413 Firmwary Library: at32f413_usb.c Source File

  • libraries
  • drivers
  • src
at32f413_usb.c
Go to the documentation of this file.
1
34#include "at32f413_conf.h"
35
36
37#ifdef USB_MODULE_ENABLED
38
46#define USB_ENDP_DESC_TABLE_OFFSET 0x40
47uint32_t g_usb_packet_address = USB_PACKET_BUFFER_ADDRESS;
48static uint16_t g_usb_offset_addr = USB_ENDP_DESC_TABLE_OFFSET;
49
56void usb_dev_init(usbd_type *usbx)
57{
58 /* clear usb core reset */
59 usbx->ctrl_bit.csrst = 0;
60
61 /* clear usb interrupt status */
62 usbx->intsts = 0;
63
64 /* set usb packet buffer descirption table address */
65 usbx->buftbl = USB_BUFFER_TABLE_ADDRESS;
66
67 /* enable usb core and set device address to 0 */
68 usbx->devaddr = 0x80;
69
70 usb_interrupt_enable(usbx, USB_SOF_INT | USB_RST_INT | USB_SP_INT | USB_WK_INT | USB_TC_INT, TRUE);
71}
72
79void usb_connect(usbd_type *usbx)
80{
81 /* enable usb phy */
82 usbx->ctrl_bit.disusb = 0;
83}
84
91void usb_disconnect(usbd_type *usbx)
92{
93 /* disable usb phy */
94 usbx->ctrl_bit.disusb = TRUE;
95}
96
97
114void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
115{
116 if(state == TRUE)
117 {
118 /* enable usbbufs */
119 g_usb_packet_address = USB_PACKET_BUFFER_ADDRESS_EX;
120 CRM->misc1_bit.usbbufs = TRUE;
121 }
122 else
123 {
124 /* disable usbbufs */
125 g_usb_packet_address = USB_PACKET_BUFFER_ADDRESS;
126 CRM->misc1_bit.usbbufs = FALSE;
127 }
128}
129
137void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
138{
139 uint16_t type = 0;
140
141 /* set endpoint address */
142 USB_SET_EPT_ADDRESS(ept_info->eptn, ept_info->ept_address);
143
144 /* select endpoint transfer type */
145 if(ept_info->trans_type == EPT_CONTROL_TYPE)
146 {
147 type = USB_EPT_CONTROL;
148 }
149 else if(ept_info->trans_type == EPT_BULK_TYPE)
150 {
151 type = USB_EPT_BULK;
152 }
153 else if(ept_info->trans_type == EPT_INT_TYPE)
154 {
155 type = USB_EPT_INT;
156 }
157 else if(ept_info->trans_type == EPT_ISO_TYPE)
158 {
159 type = USB_EPT_ISO;
160 ept_info->is_double_buffer = TRUE;
161 }
162
163 /* configure endpoint transfer type (control, bulk, interrupt, isochronous) */
164 USB_SET_TRANS_TYPE(ept_info->eptn, type);
165
166 /* endpoint is in transfer */
167 if(ept_info->inout == DATA_TRANS_IN)
168 {
169 if(ept_info->is_double_buffer == 0)
170 {
171 /* set in endpoint tx offset address */
172 USB_SET_TX_ADDRESS(ept_info->eptn, ept_info->tx_addr);
173
174 /* clear in endpoint data toggle */
175 USB_CLEAR_TXDTS(ept_info->eptn);
176
177 /* set endpoint transmission status: nak */
178 USB_SET_TXSTS(ept_info->eptn, USB_TX_NAK);
179 }
180 else
181 {
182 /* set double buffer endpoint*/
183 USB_SET_EPT_DOUBLE_BUFFER(ept_info->eptn);
184
185 /* set in endpoint offset address0 and address1 */
186 USB_SET_DOUBLE_BUFF0_ADDRESS(ept_info->eptn, ept_info->tx_addr);
187 USB_SET_DOUBLE_BUFF1_ADDRESS(ept_info->eptn, ept_info->rx_addr);
188
189 /* clear in and out data toggle */
190 USB_CLEAR_TXDTS(ept_info->eptn);
191 USB_CLEAR_RXDTS(ept_info->eptn);
192
193 /* toggle rx data toggle flag */
194 USB_TOGGLE_RXDTS(ept_info->eptn);
195
196 /* set endpoint reception status: disable */
197 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
198
199 /* set endpoint transmision status: nak */
200 USB_SET_TXSTS(ept_info->eptn, USB_TX_NAK);
201 }
202 }
203 else
204 {
205 if(ept_info->is_double_buffer == 0)
206 {
207 /* set out endpoint rx offset address */
208 USB_SET_RX_ADDRESS(ept_info->eptn, ept_info->rx_addr);
209
210 /* clear out endpoint data toggle */
211 USB_CLEAR_RXDTS(ept_info->eptn);
212
213 /* set out endpoint max reception buffer size */
214 USB_SET_RXLEN(ept_info->eptn, ept_info->maxpacket);
215
216 /* set endpoint reception status: valid */
217 USB_SET_RXSTS(ept_info->eptn, USB_RX_VALID);
218 }
219 else
220 {
221 /* set double buffer endpoint */
222 USB_SET_EPT_DOUBLE_BUFFER(ept_info->eptn);
223
224 /* set out endpoint offset address0 and address1 */
225 USB_SET_DOUBLE_BUFF0_ADDRESS(ept_info->eptn, ept_info->tx_addr);
226 USB_SET_DOUBLE_BUFF1_ADDRESS(ept_info->eptn, ept_info->rx_addr);
227
228 /* set out endpoint max reception buffer size */
229 USB_SET_EPT_DOUBLE_BUF0_LEN(ept_info->eptn, ept_info->maxpacket, DATA_TRANS_OUT);
230 USB_SET_EPT_DOUBLE_BUF1_LEN(ept_info->eptn, ept_info->maxpacket, DATA_TRANS_OUT);
231
232 /* clear in and out data toggle */
233 USB_CLEAR_TXDTS(ept_info->eptn);
234 USB_CLEAR_RXDTS(ept_info->eptn);
235
236 /* toggle tx data toggle flag */
237 USB_TOGGLE_TXDTS(ept_info->eptn);
238
239 /* set endpoint reception status: valid */
240 USB_SET_RXSTS(ept_info->eptn, USB_RX_VALID);
241
242 /* set endpoint transmision status: disable */
243 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
244 }
245 }
246}
247
248
256void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
257{
258 if(ept_info->is_double_buffer == 0)
259 {
260 if(ept_info->inout == DATA_TRANS_IN)
261 {
262 /*clear tx data toggle */
263 USB_CLEAR_TXDTS(ept_info->eptn);
264
265 /* set tx status: disable */
266 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
267 }
268 else
269 {
270 /*clear rx data toggle */
271 USB_CLEAR_RXDTS(ept_info->eptn);
272
273 /* set rx status: disable */
274 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
275
276 }
277 }
278 else
279 {
280 /* double buffer */
281
282 /*clear rx and tx data toggle */
283 USB_CLEAR_TXDTS(ept_info->eptn);
284 USB_CLEAR_RXDTS(ept_info->eptn);
285
286 if(ept_info->inout == DATA_TRANS_IN)
287 {
288 /* toggle tx */
289 USB_TOGGLE_TXDTS(ept_info->eptn);
290
291 /* set tx and rx status: disable */
292 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
293 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
294 }
295 else
296 {
297 /* toggle rx */
298 USB_TOGGLE_RXDTS(ept_info->eptn);
299
300 /* set tx and rx status: disable */
301 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
302 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
303 }
304 }
305}
306
314void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
315{
316 /* endpoint tx buffer address */
317 __IO uint16_t *d_addr = (__IO uint16_t *)(offset_addr * 2 + g_usb_packet_address);
318
319 uint32_t nhbytes = (nbytes + 1) >> 1;
320 uint32_t n_index;
321 uint16_t *pbuf = (uint16_t *)pusr_buf;
322 for(n_index = 0; n_index < nhbytes; n_index ++)
323 {
324#if defined (__ICCARM__) && (__VER__ < 7000000)
325 *d_addr++ = *(__packed uint16_t *)pbuf;
326#else
327 *d_addr++ = __UNALIGNED_UINT16_READ(pbuf);
328#endif
329 d_addr ++;
330 pbuf ++;
331 }
332}
333
341void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
342{
343 __IO uint16_t *s_addr = (__IO uint16_t *)(offset_addr * 2 + g_usb_packet_address);
344 uint32_t nhbytes = (nbytes + 1) >> 1;
345 uint32_t n_index;
346 uint16_t *pbuf = (uint16_t *)pusr_buf;
347 for(n_index = 0; n_index < nhbytes; n_index ++)
348 {
349#if defined (__ICCARM__) && (__VER__ < 7000000)
350 *(__packed uint16_t *)pbuf = *(__IO uint16_t *)s_addr ++;
351#else
352 __UNALIGNED_UINT16_WRITE(pbuf, *(__IO uint16_t *)s_addr ++);
353#endif
354 s_addr ++;
355 pbuf ++;
356 }
357}
358
359
377void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
378{
379 if(new_state == TRUE)
380 {
381 usbx->ctrl |= interrupt;
382 }
383 else
384 {
385 usbx->ctrl &= ~interrupt;
386 }
387}
388
396void usb_set_address(usbd_type *usbx, uint8_t address)
397{
398 usbx->devaddr_bit.addr = address;
399 usbx->devaddr_bit.cen = TRUE;
400}
401
409void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info)
410{
411 if(ept_info->inout == DATA_TRANS_IN)
412 {
413 USB_SET_TXSTS(ept_info->eptn, USB_TX_STALL)
414 }
415 else
416 {
417 USB_SET_RXSTS(ept_info->eptn, USB_RX_STALL)
418 }
419}
420
427void usb_enter_suspend(usbd_type *usbx)
428{
429 usbx->ctrl_bit.ssp = TRUE;
430 usbx->ctrl_bit.lpm = TRUE;
431}
432
439void usb_exit_suspend(usbd_type *usbx)
440{
441 usbx->ctrl_bit.ssp = FALSE;
442 usbx->ctrl_bit.lpm = FALSE;
443}
444
451void usb_remote_wkup_set(usbd_type *usbx)
452{
453 usbx->ctrl_bit.gresume = TRUE;
454}
455
462void usb_remote_wkup_clear(usbd_type *usbx)
463{
464 usbx->ctrl_bit.gresume = FALSE;
465}
466
472uint16_t usb_buffer_malloc(uint16_t maxpacket)
473{
474 uint16_t offset = g_usb_offset_addr;
475 g_usb_offset_addr += maxpacket;
476 return offset;
477}
478
484void usb_buffer_free(void)
485{
486 g_usb_offset_addr = USB_ENDP_DESC_TABLE_OFFSET;
487}
488
505 flag_status usb_flag_get(usbd_type *usbx, uint16_t flag)
506{
507 flag_status status = RESET;
508
509 if((usbx->intsts & flag) == RESET)
510 {
511 status = RESET;
512 }
513 else
514 {
515 status = SET;
516 }
517 return status;
518}
519
536void usb_flag_clear(usbd_type *usbx, uint16_t flag)
537{
538 usbx->intsts = ~flag;
539}
540
545#endif
546
CRM
#define CRM
Definition: at32f413_crm.h:842
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
USB_BUFFER_TABLE_ADDRESS
#define USB_BUFFER_TABLE_ADDRESS
Definition: at32f413_usb.h:153
USB_EPT_CONTROL
#define USB_EPT_CONTROL
Definition: at32f413_usb.h:139
USB_EPT_INT
#define USB_EPT_INT
Definition: at32f413_usb.h:141
USB_EPT_BULK
#define USB_EPT_BULK
Definition: at32f413_usb.h:140
USB_EPT_ISO
#define USB_EPT_ISO
Definition: at32f413_usb.h:142
USB_RX_STALL
#define USB_RX_STALL
Definition: at32f413_usb.h:123
USB_RX_DISABLE
#define USB_RX_DISABLE
Definition: at32f413_usb.h:122
USB_TX_NAK
#define USB_TX_NAK
Definition: at32f413_usb.h:116
USB_TX_STALL
#define USB_TX_STALL
Definition: at32f413_usb.h:115
USB_TX_DISABLE
#define USB_TX_DISABLE
Definition: at32f413_usb.h:114
USB_RX_VALID
#define USB_RX_VALID
Definition: at32f413_usb.h:125
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:221
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:222
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:202
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f413_usb.h:201
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:203
USB_SP_INT
#define USB_SP_INT
Definition: at32f413_usb.h:55
USB_TC_INT
#define USB_TC_INT
Definition: at32f413_usb.h:59
USB_RST_INT
#define USB_RST_INT
Definition: at32f413_usb.h:54
USB_WK_INT
#define USB_WK_INT
Definition: at32f413_usb.h:56
USB_SOF_INT
#define USB_SOF_INT
Definition: at32f413_usb.h:53
USB_CLEAR_TXDTS
#define USB_CLEAR_TXDTS(eptn)
clear usb tx/rx toggle
Definition: at32f413_usb.h:417
USB_SET_EPT_DOUBLE_BUF1_LEN
#define USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length
Definition: at32f413_usb.h:375
USB_SET_RXLEN
#define USB_SET_RXLEN(eptn, len)
Definition: at32f413_usb.h:334
USB_SET_RXSTS
#define USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status
Definition: at32f413_usb.h:262
USB_SET_EPT_DOUBLE_BUFFER
#define USB_SET_EPT_DOUBLE_BUFFER(eptn)
set/clear endpoint double buffer mode
Definition: at32f413_usb.h:484
USB_CLEAR_RXDTS
#define USB_CLEAR_RXDTS(eptn)
Definition: at32f413_usb.h:421
USB_TOGGLE_RXDTS
#define USB_TOGGLE_RXDTS(eptn)
Definition: at32f413_usb.h:410
USB_SET_EPT_ADDRESS
#define USB_SET_EPT_ADDRESS(eptn, address)
set usb device address
Definition: at32f413_usb.h:452
USB_SET_TRANS_TYPE
#define USB_SET_TRANS_TYPE(eptn, type)
set usb endpoint type
Definition: at32f413_usb.h:436
USB_SET_DOUBLE_BUFF1_ADDRESS
#define USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address)
Definition: at32f413_usb.h:402
USB_SET_TXSTS
#define USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status
Definition: at32f413_usb.h:247
USB_SET_TX_ADDRESS
#define USB_SET_TX_ADDRESS(eptn, address)
set usb endpoint tx/rx fifo address
Definition: at32f413_usb.h:392
USB_TOGGLE_TXDTS
#define USB_TOGGLE_TXDTS(eptn)
set usb tx/rx toggle
Definition: at32f413_usb.h:409
USB_SET_EPT_DOUBLE_BUF0_LEN
#define USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length
Definition: at32f413_usb.h:357
USB_SET_RX_ADDRESS
#define USB_SET_RX_ADDRESS(eptn, address)
Definition: at32f413_usb.h:393
USB_SET_DOUBLE_BUFF0_ADDRESS
#define USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address)
set double buffer mode usb endpoint buf0/buf1 fifo address
Definition: at32f413_usb.h:401
USB_PACKET_BUFFER_ADDRESS
#define USB_PACKET_BUFFER_ADDRESS
Definition: at32f413_usb.h:164
USB_PACKET_BUFFER_ADDRESS_EX
#define USB_PACKET_BUFFER_ADDRESS_EX
Definition: at32f413_usb.h:165
usb_flag_get
flag_status usb_flag_get(usbd_type *usbx, uint16_t flag)
get flag of usb.
Definition: at32f413_usb.c:505
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:439
usb_buffer_free
void usb_buffer_free(void)
free usb endpoint buffer
Definition: at32f413_usb.c:484
usb_flag_clear
void usb_flag_clear(usbd_type *usbx, uint16_t flag)
clear flag of usb.
Definition: at32f413_usb.c:536
usb_write_packet
void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f413_usb.c:314
usb_read_packet
void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f413_usb.c:341
g_usb_packet_address
uint32_t g_usb_packet_address
Definition: at32f413_usb.c:47
usb_disconnect
void usb_disconnect(usbd_type *usbx)
disconnect usb device
Definition: at32f413_usb.c:91
USB_ENDP_DESC_TABLE_OFFSET
#define USB_ENDP_DESC_TABLE_OFFSET
usb packet buffer start address
Definition: at32f413_usb.c:46
usb_enter_suspend
void usb_enter_suspend(usbd_type *usbx)
usb device enter suspend mode
Definition: at32f413_usb.c:427
usb_interrupt_enable
void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable
Definition: at32f413_usb.c:377
usb_remote_wkup_clear
void usb_remote_wkup_clear(usbd_type *usbx)
usb remote wakeup clear
Definition: at32f413_usb.c:462
usb_usbbufs_enable
void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area,...
Definition: at32f413_usb.c:114
usb_ept_stall
void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall
Definition: at32f413_usb.c:409
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:396
g_usb_offset_addr
static uint16_t g_usb_offset_addr
Definition: at32f413_usb.c:48
usb_buffer_malloc
uint16_t usb_buffer_malloc(uint16_t maxpacket)
usb auto malloc endpoint buffer
Definition: at32f413_usb.c:472
usb_remote_wkup_set
void usb_remote_wkup_set(usbd_type *usbx)
usb remote wakeup set
Definition: at32f413_usb.c:451
usb_connect
void usb_connect(usbd_type *usbx)
connect usb device
Definition: at32f413_usb.c:79
usb_ept_open
void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f413_usb.c:137
usb_dev_init
void usb_dev_init(usbd_type *usbx)
initialize usb peripheral controller register
Definition: at32f413_usb.c:56
usb_ept_close
void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f413_usb.c:256
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:499
usb_ept_info::ept_address
uint8_t ept_address
Definition: at32f413_usb.h:501
usb_ept_info::inout
uint8_t inout
Definition: at32f413_usb.h:502
usb_ept_info::maxpacket
uint16_t maxpacket
Definition: at32f413_usb.h:507
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:506
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:508
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:505
usb_ept_info::eptn
uint8_t eptn
Definition: at32f413_usb.h:500
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f413_usb.h:503
usbd_type
type define usb register all
Definition: at32f413_usb.h:526
usbd_type::devaddr
__IO uint32_t devaddr
Definition: at32f413_usb.h:622
usbd_type::intsts
__IO uint32_t intsts
Definition: at32f413_usb.h:582
usbd_type::cen
__IO uint32_t cen
Definition: at32f413_usb.h:626
usbd_type::buftbl
__IO uint32_t buftbl
Definition: at32f413_usb.h:636
usbd_type::ssp
__IO uint32_t ssp
Definition: at32f413_usb.h:562
usbd_type::devaddr_bit
struct usbd_type::@742::@752 devaddr_bit
usbd_type::csrst
__IO uint32_t csrst
Definition: at32f413_usb.h:559
usbd_type::lpm
__IO uint32_t lpm
Definition: at32f413_usb.h:561
usbd_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_usb.h:556
usbd_type::gresume
__IO uint32_t gresume
Definition: at32f413_usb.h:563
usbd_type::disusb
__IO uint32_t disusb
Definition: at32f413_usb.h:560
usbd_type::addr
__IO uint32_t addr
Definition: at32f413_usb.h:625
usbd_type::ctrl_bit
struct usbd_type::@736::@749 ctrl_bit
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_usb.h Source File

  • libraries
  • drivers
  • inc
at32f413_usb.h
Go to the documentation of this file.
1
33/* define to prevent recursive inclusion -------------------------------------*/
34#ifndef __AT32F413_USB_H
35#define __AT32F413_USB_H
36
37#ifdef __cplusplus
38extern "C" {
39#endif
40
41
42/* includes ------------------------------------------------------------------*/
43#include "at32f413.h"
44
45
46
52#define USB_LSOF_INT ((uint32_t)0x00000100)
53#define USB_SOF_INT ((uint32_t)0x00000200)
54#define USB_RST_INT ((uint32_t)0x00000400)
55#define USB_SP_INT ((uint32_t)0x00000800)
56#define USB_WK_INT ((uint32_t)0x00001000)
57#define USB_BE_INT ((uint32_t)0x00002000)
58#define USB_UCFOR_INT ((uint32_t)0x00004000)
59#define USB_TC_INT ((uint32_t)0x00008000)
70#define USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)
71#define USB_INOUT_FLAG ((uint32_t)0x00000010)
72#define USB_LSOF_FLAG ((uint32_t)0x00000100)
73#define USB_SOF_FLAG ((uint32_t)0x00000200)
74#define USB_RST_FLAG ((uint32_t)0x00000400)
75#define USB_SP_FLAG ((uint32_t)0x00000800)
76#define USB_WK_FLAG ((uint32_t)0x00001000)
77#define USB_BE_FLAG ((uint32_t)0x00002000)
78#define USB_UCFOR_FLAG ((uint32_t)0x00004000)
79#define USB_TC_FLAG ((uint32_t)0x00008000)
90#define USB_EPTADDR ((uint32_t)0x0000000F)
91#define USB_TXSTS ((uint32_t)0x00000030)
92#define USB_TXDTS ((uint32_t)0x00000040)
93#define USB_TXTC ((uint32_t)0x00000080)
94#define USB_EXF ((uint32_t)0x00000100)
95#define USB_TRANS_TYPE ((uint32_t)0x00000600)
96#define USB_SETUPTC ((uint32_t)0x00000800)
97#define USB_RXSTS ((uint32_t)0x00003000)
98#define USB_RXDTS ((uint32_t)0x00004000)
99#define USB_RXTC ((uint32_t)0x00008000)
101#define USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)
102#define USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)
103#define USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)
114#define USB_TX_DISABLE ((uint32_t)0x00000000)
115#define USB_TX_STALL ((uint32_t)0x00000010)
116#define USB_TX_NAK ((uint32_t)0x00000020)
117#define USB_TX_VALID ((uint32_t)0x00000030)
119#define USB_TXDTS0 ((uint32_t)0x00000010)
120#define USB_TXDTS1 ((uint32_t)0x00000020)
122#define USB_RX_DISABLE ((uint32_t)0x00000000)
123#define USB_RX_STALL ((uint32_t)0x00001000)
124#define USB_RX_NAK ((uint32_t)0x00002000)
125#define USB_RX_VALID ((uint32_t)0x00003000)
127#define USB_RXDTS0 ((uint32_t)0x00001000)
128#define USB_RXDTS1 ((uint32_t)0x00002000)
139#define USB_EPT_CONTROL ((uint32_t)0x00000200)
140#define USB_EPT_BULK ((uint32_t)0x00000000)
141#define USB_EPT_INT ((uint32_t)0x00000600)
142#define USB_EPT_ISO ((uint32_t)0x00000400)
153#define USB_BUFFER_TABLE_ADDRESS 0x0000
164#define USB_PACKET_BUFFER_ADDRESS 0x40006000
165#define USB_PACKET_BUFFER_ADDRESS_EX 0x40007800
178typedef enum
179{
180 USB_EPT0 = 0x00,
181 USB_EPT1 = 0x01,
182 USB_EPT2 = 0x02,
183 USB_EPT3 = 0x03,
184 USB_EPT4 = 0x04,
185 USB_EPT5 = 0x05,
186 USB_EPT6 = 0x06,
187 USB_EPT7 = 0x07
188} usb_ept_number_type;
189
193#ifndef USB_EPT_MAX_NUM
194#define USB_EPT_MAX_NUM 8
195#endif
199typedef enum
200{
201 EPT_CONTROL_TYPE = 0x00,
202 EPT_ISO_TYPE = 0x01,
203 EPT_BULK_TYPE = 0x02,
204 EPT_INT_TYPE = 0x03
205}ept_trans_type;
206
210typedef enum
211{
212 EPT_IN = 0x00,
213 EPT_OUT = 0x01
214}ept_inout_type;
215
219typedef enum
220{
221 DATA_TRANS_OUT = 0x00,
222 DATA_TRANS_IN = 0x01
223}data_trans_dir;
224
228typedef enum
229{
230 USB_CLK_HICK,
231 USB_CLK_HEXT
232}usb_clk48_s;
247#define USB_SET_TXSTS(ept_num, new_sts) { \
248 register uint16_t epsts = (USB->ept[ept_num]) & USB_TX_MASK; \
249 if((new_sts & USB_TXDTS0) != 0) \
250 epsts ^= USB_TXDTS0; \
251 if((new_sts & USB_TXDTS1) != 0) \
252 epsts ^= USB_TXDTS1; \
253 USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
254}
255
262#define USB_SET_RXSTS(ept_num, new_sts) { \
263 register uint16_t epsts = (USB->ept[ept_num]) & USB_RX_MASK; \
264 if((new_sts & USB_RXDTS0) != 0) \
265 epsts ^= USB_RXDTS0; \
266 if((new_sts & USB_RXDTS1) != 0) \
267 epsts ^= USB_RXDTS1; \
268 USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
269}
270
276#define GET_TX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)
277#define GET_RX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)
278
284#define USB_GET_TX_LEN(eptn) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)
285#define USB_GET_RX_LEN(eptn) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)
286
292#define USB_DBUF0_GET_LEN(eptn) USB_GET_TX_LEN(eptn)
293#define USB_DBUF1_GET_LEN(eptn) USB_GET_RX_LEN(eptn)
294
301#define BLK32(reg, len, blks) { \
302 blks = (len) >> 5; \
303 if(((len) & 0x1F) == 0) \
304 blks --; \
305 *reg = ((uint16_t)((blks) << 10) | 0x8000); \
306}
307
308#define BLK2(reg, len, blks) { \
309 blks = (len) >> 1; \
310 if(((len) & 0x1) == 0) \
311 blks ++; \
312 *reg = (uint16_t)((blks) << 10); \
313}
314
315#define USB_SET_RXLEN_REG(reg, len) { \
316 uint16_t blks; \
317 if(len > 62) \
318 { \
319 BLK32(reg, len, blks); \
320 } \
321 else \
322 { \
323 BLK2(reg, len, blks); \
324 } \
325}
326
333#define USB_SET_TXLEN(eptn, len) (*(GET_TX_LEN_ADDR(eptn)) = (len))
334#define USB_SET_RXLEN(eptn, len) { \
335 uint32_t *rx_reg = GET_RX_LEN_ADDR(eptn); \
336 USB_SET_RXLEN_REG(rx_reg, (len)); \
337}
338
345#define USB_OUT_EPT_DOUBLE_BUF0(eptn, len) { \
346 uint32_t *rx_reg = GET_TX_LEN_ADDR(eptn); \
347 USB_SET_RXLEN_REG(rx_reg, (len)); \
348}
349
357#define USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir) { \
358 if(dir == DATA_TRANS_OUT) \
359 { \
360 USB_OUT_EPT_DOUBLE_BUF0(eptn, len); \
361 } \
362 else \
363 { \
364 *(GET_TX_LEN_ADDR(eptn)) = (len); \
365 } \
366}
367
375#define USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir) { \
376 if(dir == DATA_TRANS_OUT) \
377 { \
378 USB_SET_RXLEN(eptn, len); \
379 } \
380 else \
381 { \
382 *(GET_RX_LEN_ADDR(eptn)) = (len); \
383 } \
384}
385
392#define USB_SET_TX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)
393#define USB_SET_RX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)
394
401#define USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address) (USB_SET_TX_ADDRESS(eptn, address))
402#define USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address) (USB_SET_RX_ADDRESS(eptn, address))
403
409#define USB_TOGGLE_TXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))
410#define USB_TOGGLE_RXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))
411
417#define USB_CLEAR_TXDTS(eptn) { \
418 if(USB->ept_bit[eptn].txdts != 0) \
419 USB_TOGGLE_TXDTS(eptn); \
420}
421#define USB_CLEAR_RXDTS(eptn) { \
422 if(USB->ept_bit[eptn].rxdts != 0) \
423 USB_TOGGLE_RXDTS(eptn); \
424}
425
436#define USB_SET_TRANS_TYPE(eptn, type) (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)
437
443#define USB_SET_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))
444#define USB_CLEAR_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))
445
452#define USB_SET_EPT_ADDRESS(eptn, address) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))
453
460#define USB_FREE_DB_USER_BUFFER(eptn, inout) { \
461 if(inout == DATA_TRANS_IN) \
462 { \
463 USB_TOGGLE_RXDTS(eptn); \
464 } \
465 else \
466 { \
467 USB_TOGGLE_TXDTS(eptn); \
468 } \
469}
470
476#define USB_CLEAR_TXTC(eptn) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)
477#define USB_CLEAR_RXTC(eptn) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)
478
484#define USB_SET_EPT_DOUBLE_BUFFER(eptn) USB_SET_EXF(eptn)
485#define USB_CLEAR_EPT_DOUBLE_BUFFER(eptn) USB_CLEAR_EXF(eptn)
486
498typedef struct
499{
500 uint8_t eptn;
501 uint8_t ept_address;
502 uint8_t inout;
503 uint8_t trans_type;
505 uint16_t tx_addr;
506 uint16_t rx_addr;
507 uint16_t maxpacket;
508 uint8_t is_double_buffer;
509 uint8_t stall;
510 uint16_t status;
512 /* transmission buffer and count */
513 uint16_t total_len;
514 uint16_t trans_len;
515 uint8_t *trans_buf;
517 uint16_t last_len;
518 uint16_t rem0_len;
519 uint16_t ept0_slen;
520}usb_ept_info;
521
525typedef struct
526{
530 union
531 {
532 __IO uint32_t ept[8];
533 struct
534 {
535 __IO uint32_t eptaddr : 4; /* [3:0] */
536 __IO uint32_t txsts : 2; /* [5:4] */
537 __IO uint32_t txdts : 1; /* [6] */
538 __IO uint32_t txtc : 1; /* [7] */
539 __IO uint32_t exf : 1; /* [8] */
540 __IO uint32_t trans_type : 2; /* [10:9] */
541 __IO uint32_t setuptc : 1; /* [11] */
542 __IO uint32_t rxsts : 2; /* [13:12] */
543 __IO uint32_t rxdts : 1; /* [14] */
544 __IO uint32_t rxtc : 1; /* [15] */
545 __IO uint32_t reserved1 : 16; /* [31:16] */
546 } ept_bit[8];
547 };
548
549 __IO uint32_t reserved1[8];
550
554 union
555 {
556 __IO uint32_t ctrl;
557 struct
558 {
559 __IO uint32_t csrst : 1; /* [0] */
560 __IO uint32_t disusb : 1; /* [1] */
561 __IO uint32_t lpm : 1; /* [2] */
562 __IO uint32_t ssp : 1; /* [3] */
563 __IO uint32_t gresume : 1; /* [4] */
564 __IO uint32_t reserved1 : 3; /* [7:5] */
565 __IO uint32_t lsofien : 1; /* [8] */
566 __IO uint32_t sofien : 1; /* [9] */
567 __IO uint32_t rstien : 1; /* [10] */
568 __IO uint32_t spien : 1; /* [11] */
569 __IO uint32_t wkien : 1; /* [12] */
570 __IO uint32_t beien : 1; /* [13] */
571 __IO uint32_t ucforien : 1; /* [14] */
572 __IO uint32_t tcien : 1; /* [15] */
573 __IO uint32_t reserved2 : 16; /* [31:16] */
574 } ctrl_bit;
575 };
576
580 union
581 {
582 __IO uint32_t intsts;
583 struct
584 {
585 __IO uint32_t ept_num : 4; /* [3:0] */
586 __IO uint32_t inout : 1; /* [4] */
587 __IO uint32_t reserved1 : 3; /* [7:5] */
588 __IO uint32_t lsof : 1; /* [8] */
589 __IO uint32_t sof : 1; /* [9] */
590 __IO uint32_t rst : 1; /* [10] */
591 __IO uint32_t sp : 1; /* [11] */
592 __IO uint32_t wk : 1; /* [12] */
593 __IO uint32_t be : 1; /* [13] */
594 __IO uint32_t ucfor : 1; /* [14] */
595 __IO uint32_t tc : 1; /* [15] */
596 __IO uint32_t reserved2 : 16; /* [31:16] */
597 } intsts_bit;
598 };
599
603 union
604 {
605 __IO uint32_t sofrnum;
606 struct
607 {
608 __IO uint32_t sofnum : 11; /* [10:0] */
609 __IO uint32_t lsofnum : 2; /* [12:11] */
610 __IO uint32_t clck : 1; /* [13] */
611 __IO uint32_t dmsts : 1; /* [14] */
612 __IO uint32_t dpsts : 1; /* [15] */
613 __IO uint32_t reserved1 : 16; /* [31:16] */
614 } sofrnum_bit;
615 };
616
620 union
621 {
622 __IO uint32_t devaddr;
623 struct
624 {
625 __IO uint32_t addr : 7; /* [6:0] */
626 __IO uint32_t cen : 1; /* [7] */
627 __IO uint32_t reserved1 : 24; /* [31:8] */
628 } devaddr_bit;
629 };
630
634 union
635 {
636 __IO uint32_t buftbl;
637 struct
638 {
639 __IO uint32_t reserved1 : 3; /* [2:0] */
640 __IO uint32_t btaddr : 13; /* [15:3] */
641 __IO uint32_t reserved2 : 16; /* [31:16] */
642 } buftbl_bit;
643 };
644 __IO uint32_t reserved2[3];
648 union
649 {
650 __IO uint32_t cfg;
651 struct
652 {
653 __IO uint32_t sofouten : 1; /* [0] */
654 __IO uint32_t reserved1 : 31; /* [31:1] */
655 } cfg_bit;
656 };
657
658} usbd_type;
659
664#define USB ((usbd_type *) USBFS_BASE)
665
666typedef usbd_type usb_reg_type;
667extern uint32_t g_usb_packet_address;
668
673void usb_dev_init(usbd_type *usbx);
674void usb_connect(usbd_type *usbx);
675void usb_disconnect(usbd_type *usbx);
676void usb_usbbufs_enable(usbd_type *usbx, confirm_state state);
677void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info);
678void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info);
679void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes);
680void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes);
681void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state);
682void usb_set_address(usbd_type *usbx, uint8_t address);
683void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info);
684void usb_enter_suspend(usbd_type *usbx);
685void usb_exit_suspend(usbd_type *usbx);
686void usb_remote_wkup_set(usbd_type *usbx);
687void usb_remote_wkup_clear(usbd_type *usbx);
688uint16_t usb_buffer_malloc(uint16_t maxpacket);
689void usb_buffer_free(void);
690 flag_status usb_flag_get(usbd_type *usbx, uint16_t flag);
691void usb_flag_clear(usbd_type *usbx, uint16_t flag);
692
693
694#ifdef __cplusplus
695}
696#endif
697
698#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
data_trans_dir
data_trans_dir
data transfer direction
Definition: at32f413_usb.h:220
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
ept_inout_type
ept_inout_type
endpoint endpoint direction define
Definition: at32f413_usb.h:211
usb_ept_number_type
usb_ept_number_type
usb endpoint number define
Definition: at32f413_usb.h:179
ept_trans_type
ept_trans_type
usb endpoint max num define
Definition: at32f413_usb.h:200
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:221
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:222
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
EPT_IN
@ EPT_IN
Definition: at32f413_usb.h:212
EPT_OUT
@ EPT_OUT
Definition: at32f413_usb.h:213
USB_EPT4
@ USB_EPT4
Definition: at32f413_usb.h:184
USB_EPT6
@ USB_EPT6
Definition: at32f413_usb.h:186
USB_EPT5
@ USB_EPT5
Definition: at32f413_usb.h:185
USB_EPT7
@ USB_EPT7
Definition: at32f413_usb.h:187
USB_EPT0
@ USB_EPT0
Definition: at32f413_usb.h:180
USB_EPT2
@ USB_EPT2
Definition: at32f413_usb.h:182
USB_EPT1
@ USB_EPT1
Definition: at32f413_usb.h:181
USB_EPT3
@ USB_EPT3
Definition: at32f413_usb.h:183
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:202
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f413_usb.h:201
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:203
usb_flag_get
flag_status usb_flag_get(usbd_type *usbx, uint16_t flag)
get flag of usb.
Definition: at32f413_usb.c:505
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:439
usb_buffer_free
void usb_buffer_free(void)
free usb endpoint buffer
Definition: at32f413_usb.c:484
usb_flag_clear
void usb_flag_clear(usbd_type *usbx, uint16_t flag)
clear flag of usb.
Definition: at32f413_usb.c:536
usb_write_packet
void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f413_usb.c:314
usb_read_packet
void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f413_usb.c:341
usb_disconnect
void usb_disconnect(usbd_type *usbx)
disconnect usb device
Definition: at32f413_usb.c:91
usb_enter_suspend
void usb_enter_suspend(usbd_type *usbx)
usb device enter suspend mode
Definition: at32f413_usb.c:427
usb_interrupt_enable
void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable
Definition: at32f413_usb.c:377
usb_remote_wkup_clear
void usb_remote_wkup_clear(usbd_type *usbx)
usb remote wakeup clear
Definition: at32f413_usb.c:462
usb_usbbufs_enable
void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area,...
Definition: at32f413_usb.c:114
usb_ept_stall
void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall
Definition: at32f413_usb.c:409
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:396
usb_buffer_malloc
uint16_t usb_buffer_malloc(uint16_t maxpacket)
usb auto malloc endpoint buffer
Definition: at32f413_usb.c:472
usb_remote_wkup_set
void usb_remote_wkup_set(usbd_type *usbx)
usb remote wakeup set
Definition: at32f413_usb.c:451
usb_connect
void usb_connect(usbd_type *usbx)
connect usb device
Definition: at32f413_usb.c:79
usb_ept_open
void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f413_usb.c:137
usb_dev_init
void usb_dev_init(usbd_type *usbx)
initialize usb peripheral controller register
Definition: at32f413_usb.c:56
usb_ept_close
void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f413_usb.c:256
usb_reg_type
usbd_type usb_reg_type
Definition: at32f413_usb.h:666
g_usb_packet_address
uint32_t g_usb_packet_address
Definition: at32f413_usb.c:47
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:499
usb_ept_info::total_len
uint16_t total_len
Definition: at32f413_usb.h:513
usb_ept_info::ept_address
uint8_t ept_address
Definition: at32f413_usb.h:501
usb_ept_info::trans_len
uint16_t trans_len
Definition: at32f413_usb.h:514
usb_ept_info::inout
uint8_t inout
Definition: at32f413_usb.h:502
usb_ept_info::maxpacket
uint16_t maxpacket
Definition: at32f413_usb.h:507
usb_ept_info::ept0_slen
uint16_t ept0_slen
Definition: at32f413_usb.h:519
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:506
usb_ept_info::trans_buf
uint8_t * trans_buf
Definition: at32f413_usb.h:515
usb_ept_info::stall
uint8_t stall
Definition: at32f413_usb.h:509
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:508
usb_ept_info::last_len
uint16_t last_len
Definition: at32f413_usb.h:517
usb_ept_info::status
uint16_t status
Definition: at32f413_usb.h:510
usb_ept_info::rem0_len
uint16_t rem0_len
Definition: at32f413_usb.h:518
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:505
usb_ept_info::eptn
uint8_t eptn
Definition: at32f413_usb.h:500
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f413_usb.h:503
usbd_type
type define usb register all
Definition: at32f413_usb.h:526
usbd_type::rxtc
__IO uint32_t rxtc
Definition: at32f413_usb.h:544
usbd_type::sofien
__IO uint32_t sofien
Definition: at32f413_usb.h:566
usbd_type::devaddr
__IO uint32_t devaddr
Definition: at32f413_usb.h:622
usbd_type::intsts
__IO uint32_t intsts
Definition: at32f413_usb.h:582
usbd_type::txtc
__IO uint32_t txtc
Definition: at32f413_usb.h:538
usbd_type::lsofien
__IO uint32_t lsofien
Definition: at32f413_usb.h:565
usbd_type::cen
__IO uint32_t cen
Definition: at32f413_usb.h:626
usbd_type::rstien
__IO uint32_t rstien
Definition: at32f413_usb.h:567
usbd_type::sofnum
__IO uint32_t sofnum
Definition: at32f413_usb.h:608
usbd_type::dpsts
__IO uint32_t dpsts
Definition: at32f413_usb.h:612
usbd_type::btaddr
__IO uint32_t btaddr
Definition: at32f413_usb.h:640
usbd_type::be
__IO uint32_t be
Definition: at32f413_usb.h:593
usbd_type::exf
__IO uint32_t exf
Definition: at32f413_usb.h:539
usbd_type::dmsts
__IO uint32_t dmsts
Definition: at32f413_usb.h:611
usbd_type::lsofnum
__IO uint32_t lsofnum
Definition: at32f413_usb.h:609
usbd_type::sofouten
__IO uint32_t sofouten
Definition: at32f413_usb.h:653
usbd_type::inout
__IO uint32_t inout
Definition: at32f413_usb.h:586
usbd_type::rxdts
__IO uint32_t rxdts
Definition: at32f413_usb.h:543
usbd_type::rst
__IO uint32_t rst
Definition: at32f413_usb.h:590
usbd_type::txdts
__IO uint32_t txdts
Definition: at32f413_usb.h:537
usbd_type::setuptc
__IO uint32_t setuptc
Definition: at32f413_usb.h:541
usbd_type::buftbl
__IO uint32_t buftbl
Definition: at32f413_usb.h:636
usbd_type::wk
__IO uint32_t wk
Definition: at32f413_usb.h:592
usbd_type::ssp
__IO uint32_t ssp
Definition: at32f413_usb.h:562
usbd_type::wkien
__IO uint32_t wkien
Definition: at32f413_usb.h:569
usbd_type::txsts
__IO uint32_t txsts
Definition: at32f413_usb.h:536
usbd_type::clck
__IO uint32_t clck
Definition: at32f413_usb.h:610
usbd_type::sofrnum
__IO uint32_t sofrnum
Definition: at32f413_usb.h:605
usbd_type::ucfor
__IO uint32_t ucfor
Definition: at32f413_usb.h:594
usbd_type::spien
__IO uint32_t spien
Definition: at32f413_usb.h:568
usbd_type::csrst
__IO uint32_t csrst
Definition: at32f413_usb.h:559
usbd_type::lpm
__IO uint32_t lpm
Definition: at32f413_usb.h:561
usbd_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_usb.h:556
usbd_type::trans_type
__IO uint32_t trans_type
Definition: at32f413_usb.h:540
usbd_type::ucforien
__IO uint32_t ucforien
Definition: at32f413_usb.h:571
usbd_type::gresume
__IO uint32_t gresume
Definition: at32f413_usb.h:563
usbd_type::lsof
__IO uint32_t lsof
Definition: at32f413_usb.h:588
usbd_type::sof
__IO uint32_t sof
Definition: at32f413_usb.h:589
usbd_type::sp
__IO uint32_t sp
Definition: at32f413_usb.h:591
usbd_type::tcien
__IO uint32_t tcien
Definition: at32f413_usb.h:572
usbd_type::disusb
__IO uint32_t disusb
Definition: at32f413_usb.h:560
usbd_type::eptaddr
__IO uint32_t eptaddr
Definition: at32f413_usb.h:535
usbd_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_usb.h:545
usbd_type::tc
__IO uint32_t tc
Definition: at32f413_usb.h:595
usbd_type::addr
__IO uint32_t addr
Definition: at32f413_usb.h:625
usbd_type::cfg
__IO uint32_t cfg
Definition: at32f413_usb.h:650
usbd_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_usb.h:573
usbd_type::ept_num
__IO uint32_t ept_num
Definition: at32f413_usb.h:585
usbd_type::rxsts
__IO uint32_t rxsts
Definition: at32f413_usb.h:542
usbd_type::beien
__IO uint32_t beien
Definition: at32f413_usb.h:570


AT32F413 Firmwary Library: at32f413_wdt.c Source File

  • libraries
  • drivers
  • src
at32f413_wdt.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef WDT_MODULE_ENABLED
37
47void wdt_enable(void)
48{
49 WDT->cmd = WDT_CMD_ENABLE;
50}
51
57void wdt_counter_reload(void)
58{
59 WDT->cmd = WDT_CMD_RELOAD;
60}
61
67void wdt_reload_value_set(uint16_t reload_value)
68{
69 WDT->rld = reload_value;
70}
71
85void wdt_divider_set(wdt_division_type division)
86{
87 WDT->div_bit.div = division;
88}
89
95void wdt_register_write_enable( confirm_state new_state)
96{
97 if(new_state == FALSE)
98 {
99 WDT->cmd = WDT_CMD_LOCK;
100 }
101 else
102 {
103 WDT->cmd = WDT_CMD_UNLOCK;
104 }
105}
106
115 flag_status wdt_flag_get(uint16_t wdt_flag)
116{
117 flag_status status = RESET;
118
119 if ((WDT->sts & wdt_flag) != (uint16_t)RESET)
120 {
121 status = SET;
122 }
123 else
124 {
125 status = RESET;
126 }
127
128 return status;
129}
130
135#endif
136
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
wdt_division_type
wdt_division_type
wdt division value type
Definition: at32f413_wdt.h:66
WDT_CMD_ENABLE
@ WDT_CMD_ENABLE
Definition: at32f413_wdt.h:83
WDT_CMD_UNLOCK
@ WDT_CMD_UNLOCK
Definition: at32f413_wdt.h:82
WDT_CMD_RELOAD
@ WDT_CMD_RELOAD
Definition: at32f413_wdt.h:84
WDT_CMD_LOCK
@ WDT_CMD_LOCK
Definition: at32f413_wdt.h:81
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:95
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:47
wdt_flag_get
flag_status wdt_flag_get(uint16_t wdt_flag)
get wdt flag
Definition: at32f413_wdt.c:115
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f413_wdt.c:57
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:67
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:85
WDT
#define WDT
Definition: at32f413_wdt.h:152
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_wdt.h Source File

  • libraries
  • drivers
  • inc
at32f413_wdt.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_WDT_H
27#define __AT32F413_WDT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
51#define WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
52#define WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)
65typedef enum
66{
67 WDT_CLK_DIV_4 = 0x00,
68 WDT_CLK_DIV_8 = 0x01,
69 WDT_CLK_DIV_16 = 0x02,
70 WDT_CLK_DIV_32 = 0x03,
71 WDT_CLK_DIV_64 = 0x04,
72 WDT_CLK_DIV_128 = 0x05,
73 WDT_CLK_DIV_256 = 0x06
74} wdt_division_type;
75
79typedef enum
80{
81 WDT_CMD_LOCK = 0x0000,
82 WDT_CMD_UNLOCK = 0x5555,
83 WDT_CMD_ENABLE = 0xCCCC,
84 WDT_CMD_RELOAD = 0xAAAA
85} wdt_cmd_value_type;
86
90typedef struct
91{
92
96 union
97 {
98 __IO uint32_t cmd;
99 struct
100 {
101 __IO uint32_t cmd : 16;/* [15:0] */
102 __IO uint32_t reserved1 : 16;/* [31:16] */
103 } cmd_bit;
104 };
105
109 union
110 {
111 __IO uint32_t div;
112 struct
113 {
114 __IO uint32_t div : 3; /* [2:0] */
115 __IO uint32_t reserved1 : 29;/* [31:3] */
116 } div_bit;
117 };
118
122 union
123 {
124 __IO uint32_t rld;
125 struct
126 {
127 __IO uint32_t rld : 12;/* [11:0] */
128 __IO uint32_t reserved1 : 20;/* [31:12] */
129 } rld_bit;
130 };
131
135 union
136 {
137 __IO uint32_t sts;
138 struct
139 {
140 __IO uint32_t divf : 1; /* [0] */
141 __IO uint32_t rldf : 1; /* [1] */
142 __IO uint32_t reserved1 : 30;/* [31:2] */
143 } sts_bit;
144 };
145
146} wdt_type;
147
152#define WDT ((wdt_type *) WDT_BASE)
153
158void wdt_enable(void);
159void wdt_counter_reload(void);
160void wdt_reload_value_set(uint16_t reload_value);
161void wdt_divider_set(wdt_division_type division);
162void wdt_register_write_enable( confirm_state new_state);
163 flag_status wdt_flag_get(uint16_t wdt_flag);
164
177#ifdef __cplusplus
178}
179#endif
180
181#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
flag_status
flag_status
flag status
Definition: at32f413.h:291
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:95
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:47
wdt_flag_get
flag_status wdt_flag_get(uint16_t wdt_flag)
get wdt flag
Definition: at32f413_wdt.c:115
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f413_wdt.c:57
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:67
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:85
wdt_cmd_value_type
wdt_cmd_value_type
wdt cmd value type
Definition: at32f413_wdt.h:80
wdt_division_type
wdt_division_type
wdt division value type
Definition: at32f413_wdt.h:66
WDT_CMD_ENABLE
@ WDT_CMD_ENABLE
Definition: at32f413_wdt.h:83
WDT_CMD_UNLOCK
@ WDT_CMD_UNLOCK
Definition: at32f413_wdt.h:82
WDT_CMD_RELOAD
@ WDT_CMD_RELOAD
Definition: at32f413_wdt.h:84
WDT_CMD_LOCK
@ WDT_CMD_LOCK
Definition: at32f413_wdt.h:81
WDT_CLK_DIV_64
@ WDT_CLK_DIV_64
Definition: at32f413_wdt.h:71
WDT_CLK_DIV_8
@ WDT_CLK_DIV_8
Definition: at32f413_wdt.h:68
WDT_CLK_DIV_256
@ WDT_CLK_DIV_256
Definition: at32f413_wdt.h:73
WDT_CLK_DIV_4
@ WDT_CLK_DIV_4
Definition: at32f413_wdt.h:67
WDT_CLK_DIV_16
@ WDT_CLK_DIV_16
Definition: at32f413_wdt.h:69
WDT_CLK_DIV_32
@ WDT_CLK_DIV_32
Definition: at32f413_wdt.h:70
WDT_CLK_DIV_128
@ WDT_CLK_DIV_128
Definition: at32f413_wdt.h:72
wdt_type
type define wdt register all
Definition: at32f413_wdt.h:91
wdt_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_wdt.h:102
wdt_type::div
__IO uint32_t div
Definition: at32f413_wdt.h:111
wdt_type::divf
__IO uint32_t divf
Definition: at32f413_wdt.h:140
wdt_type::rld
__IO uint32_t rld
Definition: at32f413_wdt.h:124
wdt_type::rldf
__IO uint32_t rldf
Definition: at32f413_wdt.h:141
wdt_type::sts
__IO uint32_t sts
Definition: at32f413_wdt.h:137
wdt_type::cmd
__IO uint32_t cmd
Definition: at32f413_wdt.h:98


AT32F413 Firmwary Library: at32f413_wwdt.c Source File

  • libraries
  • drivers
  • src
at32f413_wwdt.c
Go to the documentation of this file.
1
25#include "at32f413_conf.h"
26
36#ifdef WWDT_MODULE_ENABLED
37
46void wwdt_reset(void)
47{
48 crm_periph_reset(CRM_WWDT_PERIPH_RESET, TRUE);
49 crm_periph_reset(CRM_WWDT_PERIPH_RESET, FALSE);
50}
51
62void wwdt_divider_set(wwdt_division_type division)
63{
64 WWDT->cfg_bit.div = division;
65}
66
72void wwdt_flag_clear(void)
73{
74 WWDT->sts = 0;
75}
76
82void wwdt_enable(uint8_t wwdt_cnt)
83{
84 WWDT->ctrl = wwdt_cnt | WWDT_EN_BIT;
85}
86
92void wwdt_interrupt_enable(void)
93{
94 WWDT->cfg_bit.rldien = TRUE;
95}
96
102 flag_status wwdt_flag_get(void)
103{
104 return (flag_status)WWDT->sts_bit.rldf;
105}
106
112void wwdt_counter_set(uint8_t wwdt_cnt)
113{
114 WWDT->ctrl_bit.cnt = wwdt_cnt;
115}
116
122void wwdt_window_counter_set(uint8_t window_cnt)
123{
124 WWDT->cfg_bit.win = window_cnt;
125}
126
131#endif
132
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
CRM_WWDT_PERIPH_RESET
@ CRM_WWDT_PERIPH_RESET
Definition: at32f413_crm.h:172
flag_status
flag_status
flag status
Definition: at32f413.h:291
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
WWDT_EN_BIT
#define WWDT_EN_BIT
Definition: at32f413_wwdt.h:50
wwdt_division_type
wwdt_division_type
wwdt division type
Definition: at32f413_wwdt.h:64
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f413_wwdt.c:112
wwdt_flag_clear
void wwdt_flag_clear(void)
wwdt reload counter interrupt flag clear
Definition: at32f413_wwdt.c:72
wwdt_interrupt_enable
void wwdt_interrupt_enable(void)
wwdt reload counter interrupt enable
Definition: at32f413_wwdt.c:92
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f413_wwdt.c:62
wwdt_reset
void wwdt_reset(void)
wwdt reset by crm reset register
Definition: at32f413_wwdt.c:46
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f413_wwdt.c:122
wwdt_flag_get
flag_status wwdt_flag_get(void)
wwdt reload counter interrupt flag get
Definition: at32f413_wwdt.c:102
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f413_wwdt.c:82
WWDT
#define WWDT
Definition: at32f413_wwdt.h:125
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_wwdt.h Source File

  • libraries
  • drivers
  • inc
at32f413_wwdt.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_WWDT_H
27#define __AT32F413_WWDT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* Includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
50#define WWDT_EN_BIT ((uint32_t)0x00000080)
63typedef enum
64{
65 WWDT_PCLK1_DIV_4096 = 0x00,
66 WWDT_PCLK1_DIV_8192 = 0x01,
67 WWDT_PCLK1_DIV_16384 = 0x02,
68 WWDT_PCLK1_DIV_32768 = 0x03
69} wwdt_division_type;
70
74typedef struct
75{
76
80 union
81 {
82 __IO uint32_t ctrl;
83 struct
84 {
85 __IO uint32_t cnt : 7; /* [6:0] */
86 __IO uint32_t wwdten : 1; /* [7] */
87 __IO uint32_t reserved1 : 24;/* [31:8] */
88 } ctrl_bit;
89 };
90
94 union
95 {
96 __IO uint32_t cfg;
97 struct
98 {
99 __IO uint32_t win : 7; /* [6:0] */
100 __IO uint32_t div : 2; /* [8:7] */
101 __IO uint32_t rldien : 1; /* [9] */
102 __IO uint32_t reserved1 : 22;/* [31:10] */
103 } cfg_bit;
104 };
105
109 union
110 {
111 __IO uint32_t sts;
112 struct
113 {
114 __IO uint32_t rldf : 1; /* [0] */
115 __IO uint32_t reserved1 : 31;/* [31:1] */
116 } sts_bit;
117 };
118
119} wwdt_type;
120
125#define WWDT ((wwdt_type *) WWDT_BASE)
126
131void wwdt_reset(void);
132void wwdt_divider_set(wwdt_division_type division);
133void wwdt_flag_clear(void);
134void wwdt_enable(uint8_t wwdt_cnt);
135void wwdt_interrupt_enable(void);
136 flag_status wwdt_flag_get(void);
137void wwdt_counter_set(uint8_t wwdt_cnt);
138void wwdt_window_counter_set(uint8_t window_cnt);
139
152#ifdef __cplusplus
153}
154#endif
155
156#endif
at32f413.h
at32f413 header file
flag_status
flag_status
flag status
Definition: at32f413.h:291
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f413_wwdt.c:112
wwdt_flag_clear
void wwdt_flag_clear(void)
wwdt reload counter interrupt flag clear
Definition: at32f413_wwdt.c:72
wwdt_interrupt_enable
void wwdt_interrupt_enable(void)
wwdt reload counter interrupt enable
Definition: at32f413_wwdt.c:92
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f413_wwdt.c:62
wwdt_reset
void wwdt_reset(void)
wwdt reset by crm reset register
Definition: at32f413_wwdt.c:46
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f413_wwdt.c:122
wwdt_flag_get
flag_status wwdt_flag_get(void)
wwdt reload counter interrupt flag get
Definition: at32f413_wwdt.c:102
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f413_wwdt.c:82
wwdt_division_type
wwdt_division_type
wwdt division type
Definition: at32f413_wwdt.h:64
WWDT_PCLK1_DIV_16384
@ WWDT_PCLK1_DIV_16384
Definition: at32f413_wwdt.h:67
WWDT_PCLK1_DIV_8192
@ WWDT_PCLK1_DIV_8192
Definition: at32f413_wwdt.h:66
WWDT_PCLK1_DIV_32768
@ WWDT_PCLK1_DIV_32768
Definition: at32f413_wwdt.h:68
WWDT_PCLK1_DIV_4096
@ WWDT_PCLK1_DIV_4096
Definition: at32f413_wwdt.h:65
wwdt_type
type define wwdt register all
Definition: at32f413_wwdt.h:75
wwdt_type::div
__IO uint32_t div
Definition: at32f413_wwdt.h:100
wwdt_type::win
__IO uint32_t win
Definition: at32f413_wwdt.h:99
wwdt_type::cfg
__IO uint32_t cfg
Definition: at32f413_wwdt.h:96
wwdt_type::cnt
__IO uint32_t cnt
Definition: at32f413_wwdt.h:85
wwdt_type::wwdten
__IO uint32_t wwdten
Definition: at32f413_wwdt.h:86
wwdt_type::sts
__IO uint32_t sts
Definition: at32f413_wwdt.h:111
wwdt_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_wwdt.h:82
wwdt_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_wwdt.h:87
wwdt_type::rldien
__IO uint32_t rldien
Definition: at32f413_wwdt.h:101
wwdt_type::rldf
__IO uint32_t rldf
Definition: at32f413_wwdt.h:114


AT32F413 Firmwary Library: audio_conf.h Source File

  • middlewares
  • usbd_class
  • audio
audio/audio_conf.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_CONF_H
27#define __AUDIO_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
45#define AUDIO_SUPPORT_SPK 1
46#define AUDIO_SUPPORT_MIC 1
47#define AUDIO_SUPPORT_FEEDBACK 1
48
49#define AUDIO_SUPPORT_FREQ_16K 1
50#define AUDIO_SUPPORT_FREQ_48K 1
51
52
53#define AUDIO_SUPPORT_FREQ (AUDIO_SUPPORT_FREQ_16K + \
54 AUDIO_SUPPORT_FREQ_48K \
55 )
56
57#define AUDIO_FREQ_16K 16000
58#define AUDIO_FREQ_48K 48000
59#define AUDIO_BITW_16 16
60
61#define AUDIO_MIC_CHANEL_NUM 2
62#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
63
64#define AUDIO_SPK_CHANEL_NUM 2
65#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
66
67
68#define AUDIO_SUPPORT_MAX_FREQ 48
69#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
70#define AUDIO_DEFAULT_BITW AUDIO_BITW_16
71
83#ifdef __cplusplus
84}
85#endif
86
87#endif
88
89
90


AT32F413 Firmwary Library: audio_codec.h Source File

  • usb_device
  • audio
  • inc
audio/inc/audio_codec.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_CODEC_H
27#define __AUDIO_CODEC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
42/* includes ------------------------------------------------------------------*/
43#include "at32f413.h"
44
48#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
49#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
50#define WM8988_R2_LOUT1_VOLUME 0x02
51#define WM8988_R3_ROUT1_VOLUME 0x03
52#define WM8988_R4_RESERVED 0x04
53#define WM8988_R5_ADC_DAC_CONTROL 0x05
54#define WM8988_R6_RESERVED 0x06
55#define WM8988_R7_AUDIO_INTERFACE 0x07
56#define WM8988_R8_SAMPLE_RATE 0x08
57#define WM8988_R9_RESERVED 0x09
58#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
59#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
60#define WM8988_R12_BASS_CONTROL 0x0C
61#define WM8988_R13_TREBLE_CONTROL 0x0D
62#define WM8988_R14_
63#define WM8988_R15_RESET 0x0F
64#define WM8988_R16_3D_CONTROL 0x10
65#define WM8988_R17_ALC1 0x11
66#define WM8988_R18_ALC2 0x12
67#define WM8988_R19_ALC3 0x13
68#define WM8988_R20_NOISE_GATE 0x14
69#define WM8988_R21_LEFT_ADC_VOLUME 0x15
70#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
71#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
72#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
73#define WM8988_R25_PWR_1_MGMT 0x19
74#define WM8988_R26_PWR_2_MGMT 0x1A
75#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
76
77#define WM8988_R31_ADC_INPUT_MODE 0x1F
78#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
79#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
80#define WM8988_R34_LEFT_OUT_MIX_1 0x22
81#define WM8988_R35_LEFT_OUT_MIX_2 0x23
82#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
83#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
84#define WM8988_R38_RESERVED
85#define WM8988_R39_RESERVED
86#define WM8988_R40_LOUT2_VOLUME 0x28
87#define WM8988_R41_ROUT2_VOLUME 0x29
88#define WM8988_R42_RESERVED
89#define WM8988_R43_LOW_POWER_PALYBACK 0x43
90
91#define WM8988_I2C_ADDR_CSB_LOW 0x34
92#define WM8988_I2C_ADDR_CSB_HIGH 0x36
93
101#define I2S1_WS_PIN GPIO_PINS_4
102#define I2S1_CK_PIN GPIO_PINS_5
103#define I2S1_SD_PIN GPIO_PINS_7
104#define I2S1_GPIO GPIOA
105#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
106#define I2S1_DT_ADDRESS (&(SPI1->dt))
107
108/*I2S2 Pin*/
109#define I2S2_WS_PIN GPIO_PINS_12
110#define I2S2_CK_PIN GPIO_PINS_13
111#define I2S2_SD_PIN GPIO_PINS_15
112#define I2S2_GPIO GPIOB
113#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
114#define I2S2_DT_ADDRESS (&(SPI2->dt))
115
116#define SPK_TX_FIFO_SIZE (1024 * 4)
117
125#define MIC_BUFFER_SIZE 1024
126#define SPK_BUFFER_SIZE 4096
127#define DMA_BUFFER_SIZE 288
128
129typedef struct
130{
131 uint32_t audio_freq;
132 uint32_t audio_bitw;
133 //spk part
134 uint16_t spk_buffer[SPK_BUFFER_SIZE];
135 uint16_t *spk_roff;
136 uint16_t *spk_woff;
137 uint16_t *spk_rend;
138 uint32_t spk_freq;
139 uint32_t spk_wtotal;
140 uint32_t spk_rtotal;
141 uint16_t spk_threshold;
142 uint16_t spk_calc;
143 uint8_t spk_stage;
144
145 //mic part
146 uint16_t mic_buffer[MIC_BUFFER_SIZE];
147 uint16_t *mic_roff;
148 uint16_t *mic_woff;
149 uint16_t *mic_wend;
150 uint32_t mic_wtotal;
151 uint32_t mic_rtotal;
152 uint32_t mic_delta;
153 uint16_t mic_calc;
154 uint16_t mic_adj_count;
155 uint8_t mic_adj_stage;
156 uint8_t mic_stage;
157
158 uint8_t mic_mute;
159 uint8_t spk_mute;
160
161 uint16_t mic_volume;
162 uint16_t spk_volume;
163
164 uint32_t spk_tx_size;
165 uint32_t mic_rx_size;
166
167 uint32_t spk_enable;
168 uint32_t mic_enable;
169
170}audio_codec_type;
171
172 error_status audio_codec_init(void);
173 error_status audio_codec_loop(void);
174void audio_codec_modify_freq(uint32_t freq);
175
179void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
180uint32_t audio_codec_mic_get_data(uint8_t *buffer);
181uint8_t audio_codec_spk_feedback(uint8_t *feedback);
182void audio_codec_spk_alt_setting(uint32_t alt_seting);
183void audio_codec_mic_alt_setting(uint32_t alt_seting);
184void audio_codec_set_mic_mute(uint8_t mute);
185void audio_codec_set_spk_mute(uint8_t mute);
186void audio_codec_set_mic_volume(uint16_t volume);
187void audio_codec_set_spk_volume(uint16_t volume);
188void audio_codec_set_mic_freq(uint32_t freq);
189void audio_codec_set_spk_freq(uint32_t freq);
200#ifdef __cplusplus
201}
202#endif
203
204#endif
205
at32f413.h
at32f413 header file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
error_status
error_status
error status
Definition: at32f413.h:301
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:167
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:215
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:193
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:125
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:119
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:280
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:851
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:126
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:182
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:242
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:226
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: audio/src/audio_codec.c:340
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:204
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:152
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:792
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:135
audio_codec_type
Definition: audio/inc/audio_codec.h:130
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: audio/inc/audio_codec.h:159
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: audio/inc/audio_codec.h:141
audio_codec_type::mic_enable
uint32_t mic_enable
Definition: audio/inc/audio_codec.h:168
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: audio/inc/audio_codec.h:143
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: audio/inc/audio_codec.h:147
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: audio/inc/audio_codec.h:161
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: audio/inc/audio_codec.h:135
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: audio/inc/audio_codec.h:140
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: audio/inc/audio_codec.h:152
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: audio/inc/audio_codec.h:142
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: audio/inc/audio_codec.h:148
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: audio/inc/audio_codec.h:156
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: audio/inc/audio_codec.h:154
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: audio/inc/audio_codec.h:138
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: audio/inc/audio_codec.h:132
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: audio/inc/audio_codec.h:149
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: audio/inc/audio_codec.h:137
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: audio/inc/audio_codec.h:150
audio_codec_type::spk_enable
uint32_t spk_enable
Definition: audio/inc/audio_codec.h:167
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: audio/inc/audio_codec.h:151
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: audio/inc/audio_codec.h:131
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: audio/inc/audio_codec.h:158
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: audio/inc/audio_codec.h:162
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: audio/inc/audio_codec.h:153
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: audio/inc/audio_codec.h:139
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: audio/inc/audio_codec.h:155
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: audio/inc/audio_codec.h:164
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: audio/inc/audio_codec.h:165
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: audio/inc/audio_codec.h:136


AT32F413 Firmwary Library: audio_codec.c Source File

  • usb_device
  • audio
  • src
audio/src/audio_codec.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "audio_codec.h"
27#include "i2c_application.h"
28#include "audio_conf.h"
29#include <string.h>
30
39#define I2C_TIMEOUT 0xFFFFFFFF
40
41#define I2Cx_SPEED 100000
42#define I2Cx_ADDRESS 0x00
43
44#define I2Cx_PORT I2C1
45#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
46
47#define I2Cx_SCL_PIN GPIO_PINS_8
48#define I2Cx_SCL_GPIO_PORT GPIOB
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50
51#define I2Cx_SDA_PIN GPIO_PINS_9
52#define I2Cx_SDA_GPIO_PORT GPIOB
53#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54
58#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
59#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
60
64#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
65
69uint16_t reg_addr_data[] =
70{
71 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
72 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
73 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
74 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
75 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
76 (WM8988_REG_BITW16),
77 (WM8988_REG_FREQ16K),
78 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
79 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
80 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
81 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
82 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
83 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
84 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
85 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
86 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
87 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
88 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
89 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
90 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
91 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
92 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
93 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
94 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
95 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
96 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
97 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
98 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
99 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
100};
101
102 i2c_handle_type hi2cx;
103
104 audio_codec_type audio_codec;
105uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
106uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
107
108void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
109void codec_i2s_reset(void);
110void codec_i2s_init(audio_codec_type *param);
111void mclk_tmr1_init(void);
112void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
113
119void audio_codec_set_mic_freq(uint32_t freq)
120{
121 if(audio_codec.audio_freq != freq)
122 {
123 audio_codec.audio_freq = freq;
124 codec_i2s_reset();
125 audio_codec_modify_freq(freq);
126 codec_i2s_init(&audio_codec);
127 }
128}
129
135void audio_codec_set_spk_freq(uint32_t freq)
136{
137 if(audio_codec.audio_freq != freq)
138 {
139 audio_codec.audio_freq = freq;
140 codec_i2s_reset();
141 audio_codec_modify_freq(freq);
142 codec_i2s_init(&audio_codec);
143 }
144}
145
146
152void audio_codec_spk_alt_setting(uint32_t alt_seting)
153{
154 if(alt_seting == 0)
155 {
156 }
157 else
158 {
159 }
160}
161
167void audio_codec_mic_alt_setting(uint32_t alt_seting)
168{
169 if(alt_seting == 0)
170 {
171 }
172 else
173 {
174 }
175}
176
182void audio_codec_set_mic_mute(uint8_t mute)
183{
184 audio_codec.mic_mute = mute;
185}
186
187
193void audio_codec_set_spk_mute(uint8_t mute)
194{
195 audio_codec.spk_mute = mute;
196}
197
198
204void audio_codec_set_mic_volume(uint16_t volume)
205{
206 /* wm8988 adc have 256 steps */
207 audio_codec.mic_volume = volume;
208}
209
215void audio_codec_set_spk_volume(uint16_t volume)
216{
217 /* wm8988 dac have 80 steps */
218 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
219}
220
226uint8_t audio_codec_spk_feedback(uint8_t *feedback)
227{
228 uint32_t feedback_value = (audio_codec.spk_freq);
229 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
230 feedback[0] = (uint8_t)(feedback_value);
231 feedback[1] = (uint8_t)(feedback_value >> 8);
232 feedback[2] = (uint8_t)(feedback_value >> 16);
233 return 3;
234}
235
242void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
243{
244 uint16_t ulen = len / 2, i;
245 uint16_t *u16data = (uint16_t *)data;
246
247 switch(audio_codec.spk_stage)
248 {
249 case 0:
250 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
251 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
252 audio_codec.spk_stage = 1;
253 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
254 break;
255 case 1:
256 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
257 {
258 audio_codec.spk_stage = 2;
259 }
260 break;
261 case 2:
262 break;
263 }
264 for( i = 0; i < ulen; ++i )
265 {
266 *audio_codec.spk_woff++ = *u16data++;
267 if( audio_codec.spk_woff >= audio_codec.spk_rend )
268 {
269 audio_codec.spk_woff = audio_codec.spk_buffer;
270 }
271 }
272 audio_codec.spk_wtotal += ulen;
273}
274
280uint32_t audio_codec_mic_get_data(uint8_t *buffer)
281{
282 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
283 uint16_t len = audio_codec.mic_rx_size << 1;
284 uint16_t i;
285 uint16_t* u16buf = (uint16_t*)buffer;
286 switch(audio_codec.mic_stage)
287 {
288 case 0:
289 audio_codec.mic_stage = 1;
290 memset( buffer, 0, len );
291 return len;
292 case 1:
293 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
294 {
295 audio_codec.mic_stage = 2;
296 }
297 return len;
298 }
299 switch( audio_codec.mic_adj_stage )
300 {
301 case 0:
302 break;
303 case 1:
304 if( audio_codec.mic_adj_count >= 4 ){
305 len += 4;
306 audio_codec.mic_adj_count -= 4;
307 }
308 break;
309 case 2:
310 if( audio_codec.mic_adj_count >= 4 ){
311 len -= 4;
312 audio_codec.mic_adj_count -= 4;
313 }
314 break;
315 }
316
317 for( i = 0; i < len/2; ++i )
318 {
319 *u16buf++ = *audio_codec.mic_roff++;
320 if( audio_codec.mic_roff >= audio_codec.mic_wend )
321 {
322 audio_codec.mic_roff = audio_codec.mic_buffer;
323 }
324 }
325 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
326 { //should not happen
327 while(1);
328 }
329
330 audio_codec.mic_rtotal += len/2;
331 audio_codec.mic_delta += len/2;
332 return len;
333}
334
340void audio_codec_modify_freq(uint32_t freq)
341{
342 uint16_t codec_cmd;
343 uint8_t i2c_cmd[2];
344 if(freq == AUDIO_FREQ_16K)
345 {
346 codec_cmd = WM8988_REG_FREQ16K;
347 }
348 else if(freq == AUDIO_FREQ_48K)
349 {
350 codec_cmd = WM8988_REG_FREQ48K;
351 }
352 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
353 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
354 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
355 {
356 while(1);
357 }
358}
359
367void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
368{
369 uint32_t i_index = 0;
370 for(i_index = 0; i_index < len; i_index ++)
371 {
372 buffer[i_index] = (uint16_t)set;
373 }
374}
375
383void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
384{
385 uint16_t i_index;
386 for(i_index = 0; i_index < len; i_index ++)
387 {
388 dest[i_index] = src[i_index];
389 }
390}
391
397void i2c_lowlevel_init(i2c_handle_type* hi2c)
398{
399 gpio_init_type gpio_initstructure;
400
401 if(hi2c->i2cx == I2Cx_PORT)
402 {
403 /* i2c periph clock enable */
404 crm_periph_clock_enable(I2Cx_CLK, TRUE);
405 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
406 gpio_pin_remap_config(I2C1_MUX, TRUE);
407 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
408 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
409
410 /* gpio configuration */
411 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
412 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
413 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
414 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
415
416 /* configure i2c pins: scl */
417 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
418 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
419
420 /* configure i2c pins: sda */
421 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
422 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
423
424 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
425
426 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
427 }
428}
429
435void mclk_tmr1_init(void)
436{
437 gpio_init_type gpio_init_struct;
438 tmr_output_config_type tmr_oc_init_structure;
439 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
440
441 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
442 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
443 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
444
445 gpio_default_para_init(&gpio_init_struct);
446
447 gpio_init_struct.gpio_pins = GPIO_PINS_8;
448 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
449 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
450 gpio_init(GPIOA, &gpio_init_struct);
451
452 tmr_base_init(TMR1, 1, prescaler_value);
453 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
454 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
455
456 tmr_output_default_para_init(&tmr_oc_init_structure);
457 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
458 tmr_oc_init_structure.oc_idle_state = FALSE;
459 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
460 tmr_oc_init_structure.oc_output_state = TRUE;
461 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
462 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
463 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
464
465 /* tmr enable counter */
466 tmr_counter_enable(TMR1, TRUE);
467 tmr_output_enable(TMR1, TRUE);
468}
469
470
476void codec_i2s_reset(void)
477{
478 i2s_enable(SPI1, FALSE);
479 i2s_enable(SPI2, FALSE);
480 dma_channel_enable(DMA1_CHANNEL3, FALSE);
481 dma_channel_enable(DMA1_CHANNEL4, FALSE);
482}
483
490void codec_i2s_init(audio_codec_type *param)
491{
492 gpio_init_type gpio_init_struct;
493 dma_init_type dma_init_struct;
494 i2s_init_type i2s_init_struct;
495 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
496
497 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
498 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
499 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
500 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
501 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
502
503 param->spk_freq = param->audio_freq;
504
505 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
506 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
507
508 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
509 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
510
511 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
512 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
513
514 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
515 {
516 param->mic_wend += param->mic_rx_size;
517 }
518 param->mic_wend -= param->mic_rx_size;
519 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
520 {
521 param->spk_rend += param->spk_tx_size;
522 }
523 param->spk_rend -= param->spk_tx_size;
524 if(param->audio_bitw == 16)
525 {
526 format = I2S_DATA_16BIT_CHANNEL_16BIT;
527 }
528 else
529 {
530 format = I2S_DATA_24BIT_CHANNEL_32BIT;
531 }
532 gpio_default_para_init(&gpio_init_struct);
533
534 /* i2s1 ws pins */
535 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
536 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
537 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
538 gpio_init(I2S1_GPIO, &gpio_init_struct);
539
540 /* i2s1 ck pins */
541 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
542 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
543 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
544 gpio_init(I2S1_GPIO, &gpio_init_struct);
545
546 /* i2s1 sd pins slave tx */
547 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
548 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
549 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
550 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
551 gpio_init(I2S1_GPIO, &gpio_init_struct);
552
553 /* i2s2 ws pins */
554 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
555 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
556 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
557 gpio_init(I2S2_GPIO, &gpio_init_struct);
558
559 /* i2s2 ck pins */
560 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
561 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
562 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
563 gpio_init(I2S2_GPIO, &gpio_init_struct);
564
565 /* i2s2 sd pins slave rx */
566 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
567 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
568 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
569 gpio_init(I2S2_GPIO, &gpio_init_struct);
570
571 /* dma config */
572 dma_reset(DMA1_CHANNEL3);
573 dma_reset(DMA1_CHANNEL4);
574
575 /* dma1 channel3: speaker i2s1 tx */
576 dma_default_para_init(&dma_init_struct);
577 dma_init_struct.buffer_size = param->spk_tx_size << 1;
578 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
579 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
580 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
581 dma_init_struct.memory_inc_enable = TRUE;
582 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
583 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
584 dma_init_struct.peripheral_inc_enable = FALSE;
585 dma_init_struct.priority = DMA_PRIORITY_HIGH;
586 dma_init_struct.loop_mode_enable = TRUE;
587 dma_init(DMA1_CHANNEL3, &dma_init_struct);
588 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
589 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
590 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
591
592 /* dma1 channel4: microphone i2s2 rx */
593 dma_default_para_init(&dma_init_struct);
594 dma_init_struct.buffer_size = param->mic_rx_size << 1;
595 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
596 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
597 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
598 dma_init_struct.memory_inc_enable = TRUE;
599 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
600 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
601 dma_init_struct.peripheral_inc_enable = FALSE;
602 dma_init_struct.priority = DMA_PRIORITY_HIGH;
603 dma_init_struct.loop_mode_enable = TRUE;
604 dma_init(DMA1_CHANNEL4, &dma_init_struct);
605 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
606 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
607 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
608
609 /* i2s1 tx init */
610 spi_i2s_reset(SPI1);
611 i2s_default_para_init(&i2s_init_struct);
612 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
613 i2s_init_struct.data_channel_format = format;
614 i2s_init_struct.mclk_output_enable = FALSE;
615 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
616 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
617 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
618 i2s_init(SPI1, &i2s_init_struct);
619
620 /* i2s2 rx init */
621 spi_i2s_reset(SPI2);
622 i2s_default_para_init(&i2s_init_struct);
623 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
624 i2s_init_struct.data_channel_format = format;
625 i2s_init_struct.mclk_output_enable = FALSE;
626 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
627 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
628 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
629 i2s_init(SPI2, &i2s_init_struct);
630
631
632 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
633 spi_i2s_dma_receiver_enable(SPI2, TRUE);
634 i2s_enable(SPI1, TRUE);
635 i2s_enable(SPI2, TRUE);
636
637 dma_channel_enable(DMA1_CHANNEL3, TRUE);
638 dma_channel_enable(DMA1_CHANNEL4, TRUE);
639
640}
641
647void DMA1_Channel3_IRQHandler(void)
648{
649 uint16_t half_size = audio_codec.spk_tx_size;
650 uint16_t *pdst;
651
652 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
653 {
654 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
655 pdst = spk_dma_buffer;
656 dma_flag_clear(DMA1_HDT3_FLAG);
657 }
658 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
659 {
660 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
661 pdst = spk_dma_buffer + half_size;
662 dma_flag_clear(DMA1_FDT3_FLAG);
663 }
664
665 switch( audio_codec.spk_stage )
666 {
667 case 0:
668 case 1:
669 memset( pdst, 0, half_size << 1);
670 break;
671 case 2:
672 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
673 {
674 while(1);//should not happen;
675 }
676 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
677 {
678 audio_codec.spk_stage = 0;
679 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
680 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
681 }
682 else
683 {
684 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
685 audio_codec.spk_roff += half_size;
686 audio_codec.spk_rtotal += half_size;
687 if( audio_codec.spk_roff >= audio_codec.spk_rend )
688 {
689 audio_codec.spk_roff = audio_codec.spk_buffer;
690 }
691 if( ++audio_codec.spk_calc == 256 )
692 {
693 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
694 audio_codec.spk_calc = 0;
695 if( delta < audio_codec.spk_threshold - half_size )
696 {
697 audio_codec.spk_threshold -= half_size;
698 audio_codec.spk_freq += audio_codec.audio_freq/1024;
699 }
700 else if( delta > audio_codec.spk_threshold + half_size )
701 {
702 audio_codec.spk_threshold += half_size;
703 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
704 }
705 if(audio_codec.spk_rtotal > 0x20000000)
706 {
707 audio_codec.spk_rtotal -= 0x10000000;
708 audio_codec.spk_wtotal -= 0x10000000;
709 }
710 }
711 }
712 break;
713 }
714
715}
716
722void DMA1_Channel4_IRQHandler(void)
723{
724 uint16_t *psrc;
725 uint16_t len = audio_codec.mic_rx_size << 1;
726
727 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
728 {
729 dma_flag_clear(DMA1_HDT4_FLAG);
730 psrc = mic_dma_buffer;
731 }
732 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
733 {
734 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
735 dma_flag_clear(DMA1_FDT4_FLAG);
736 }
737 if( audio_codec.mic_stage )
738 {
739 memcpy( audio_codec.mic_woff, psrc, len );
740 audio_codec.mic_woff += len/2;
741 audio_codec.mic_wtotal += len/2;
742 if( audio_codec.mic_woff >= audio_codec.mic_wend )
743 {
744 audio_codec.mic_woff = audio_codec.mic_buffer;
745 }
746 if( audio_codec.mic_stage == 2 )
747 {
748 if( 1024 == ++audio_codec.mic_calc )
749 {
750 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
751 audio_codec.mic_calc = 0;
752 if( audio_codec.mic_delta > size_estimate )
753 {
754 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
755 audio_codec.mic_adj_stage = 2;
756 }
757 else if( audio_codec.mic_delta < size_estimate )
758 {
759 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
760 audio_codec.mic_adj_stage = 1;
761 }
762 else
763 {
764 audio_codec.mic_adj_count = 0;
765 audio_codec.mic_adj_stage = 0;
766 }
767 audio_codec.mic_delta = 0;
768 if( audio_codec.mic_rtotal >= 0x80000000 )
769 {
770 audio_codec.mic_rtotal -= 0x80000000;
771 audio_codec.mic_wtotal -= 0x80000000;
772 }
773 }
774 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
775 {
776 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
777 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
778 audio_codec.mic_stage = 0;
779 audio_codec.mic_adj_stage = 0;
780 audio_codec.mic_adj_count = 0;
781 audio_codec.mic_calc = 0;
782 }
783 }
784 }
785}
786
792 error_status audio_codec_init(void)
793{
794 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
795 uint32_t i_index = 0;
796 uint8_t i2c_cmd[2];
797
798 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
799 {
800 reg_addr_data[6] = WM8988_REG_FREQ16K;
801 audio_codec.audio_freq = AUDIO_FREQ_16K;
802 }
803 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
804 {
805 reg_addr_data[6] = WM8988_REG_FREQ48K;
806 audio_codec.audio_freq = AUDIO_FREQ_48K;
807 }
808 else
809 {
810 return ERROR;
811 }
812
813 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
814 {
815 reg_addr_data[5] = WM8988_REG_BITW16;
816 audio_codec.audio_bitw = AUDIO_BITW_16;
817 }
818 else
819 {
820 return ERROR;
821 }
822
823 /* i2c init */
824 hi2cx.i2cx = I2Cx_PORT;
825
826 i2c_config(&hi2cx);
827
828 for(i_index = 0; i_index < reg_len; i_index ++)
829 {
830 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
831 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
832 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
833 {
834 return ERROR;
835 }
836 }
837
838 /* timer init */
839 mclk_tmr1_init();
840
841 codec_i2s_init(&audio_codec);
842
843 return SUCCESS;
844}
845
851 error_status audio_codec_loop(void)
852{
853 static uint8_t mic_mute = 0;
854 static uint16_t mic_volume = 0;
855 static uint8_t spk_mute = 0;
856 static uint16_t spk_volume = 0;
857 uint16_t audio_ctrl_l;
858 uint16_t audio_ctrl_r;
859 uint8_t i2c_cmd[2];
860
861 if(mic_mute != audio_codec.mic_mute)
862 {
863 mic_mute = audio_codec.mic_mute;
864 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
865 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
866 if(audio_codec.mic_mute == 0)
867 {
868 audio_ctrl_l |= audio_codec.mic_volume;
869 audio_ctrl_r |= audio_codec.mic_volume;
870 }
871 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
872 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
873 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
874 {
875 return ERROR;
876 }
877 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
878 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
879 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
880 {
881 return ERROR;
882 }
883 }
884
885 if(mic_volume != audio_codec.mic_volume)
886 {
887 mic_volume = audio_codec.mic_volume;
888 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
889 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
890 audio_ctrl_l |= audio_codec.mic_volume;
891 audio_ctrl_r |= audio_codec.mic_volume;
892 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
893 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
894 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
895 {
896 return ERROR;
897 }
898 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
899 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
900 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
901 {
902 return ERROR;
903 }
904 }
905
906 if(spk_mute != audio_codec.spk_mute)
907 {
908 spk_mute = audio_codec.spk_mute;
909 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
910 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
911 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
912 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
913 {
914 return ERROR;
915 }
916 }
917
918 if(spk_volume != audio_codec.spk_volume)
919 {
920 spk_volume = audio_codec.spk_volume;
921 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
922 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
923 audio_ctrl_l |= audio_codec.spk_volume;
924 audio_ctrl_r |= audio_codec.spk_volume;
925
926 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
927 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
928
929 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
930 {
931 return ERROR;
932 }
933 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
934 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
935 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
936 {
937 return ERROR;
938 }
939 }
940 return SUCCESS;
941}
942
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:36
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: audio/src/audio_codec.c:69
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:167
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: audio/src/audio_codec.c:476
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: audio/src/audio_codec.c:105
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:215
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:193
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: audio/src/audio_codec.c:58
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:119
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: audio/src/audio_codec.c:42
I2Cx_CLK
#define I2Cx_CLK
Definition: audio/src/audio_codec.c:45
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:280
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: audio/src/audio_codec.c:64
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:851
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: audio/src/audio_codec.c:490
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:182
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
codec speaker write fifo
Definition: audio/src/audio_codec.c:242
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: audio/src/audio_codec.c:51
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: audio/src/audio_codec.c:47
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: audio/src/audio_codec.c:106
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:226
hi2cx
i2c_handle_type hi2cx
Definition: audio/src/audio_codec.c:102
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 interrupt.
Definition: audio/src/audio_codec.c:722
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: audio/src/audio_codec.c:340
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: audio/src/audio_codec.c:52
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:204
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: audio/src/audio_codec.c:435
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 interrupt.
Definition: audio/src/audio_codec.c:647
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: audio/src/audio_codec.c:53
audio_codec
audio_codec_type audio_codec
Definition: audio/src/audio_codec.c:104
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:152
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: audio/src/audio_codec.c:397
I2Cx_SPEED
#define I2Cx_SPEED
Definition: audio/src/audio_codec.c:41
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:792
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: audio/src/audio_codec.c:59
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: audio/src/audio_codec.c:383
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: audio/src/audio_codec.c:367
I2Cx_PORT
#define I2Cx_PORT
Definition: audio/src/audio_codec.c:44
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:135
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: audio/src/audio_codec.c:49
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: audio/src/audio_codec.c:48
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:420
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:183
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:184
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f413_dma.h:93
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f413_dma.h:89
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:88
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f413_dma.h:51
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:224
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
I2C1_MUX
#define I2C1_MUX
Definition: at32f413_gpio.h:80
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:314
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:497
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:443
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:49
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:296
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:483
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:224
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:207
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:247
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:225
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:227
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:196
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:237
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:236
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:607
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:125
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:126
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:127
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: audio/inc/audio_codec.h:114
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: audio/inc/audio_codec.h:103
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: audio/inc/audio_codec.h:102
I2S2_GPIO
#define I2S2_GPIO
Definition: audio/inc/audio_codec.h:112
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: audio/inc/audio_codec.h:111
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: audio/inc/audio_codec.h:109
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:113
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: audio/inc/audio_codec.h:106
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:105
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: audio/inc/audio_codec.h:101
I2S1_GPIO
#define I2S1_GPIO
Definition: audio/inc/audio_codec.h:104
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: audio/inc/audio_codec.h:110
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: audio/inc/audio_codec.h:75
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: audio/inc/audio_codec.h:91
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:58
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:49
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: audio/inc/audio_codec.h:51
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:82
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:69
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: audio/inc/audio_codec.h:77
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: audio/inc/audio_codec.h:61
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: audio/inc/audio_codec.h:64
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:70
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:48
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: audio/inc/audio_codec.h:71
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:81
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: audio/inc/audio_codec.h:89
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:78
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: audio/inc/audio_codec.h:74
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:59
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: audio/inc/audio_codec.h:72
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: audio/inc/audio_codec.h:86
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:80
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: audio/inc/audio_codec.h:53
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: audio/inc/audio_codec.h:73
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: audio/inc/audio_codec.h:87
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: audio/inc/audio_codec.h:50
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:83
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:79
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: audio/inc/audio_codec.h:60
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:59
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:61
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:69
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:57
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:64
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:70
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:58
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: audio/inc/audio_codec.h:130
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: audio/inc/audio_codec.h:159
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: audio/inc/audio_codec.h:141
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: audio/inc/audio_codec.h:143
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: audio/inc/audio_codec.h:147
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: audio/inc/audio_codec.h:134
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: audio/inc/audio_codec.h:161
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: audio/inc/audio_codec.h:135
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: audio/inc/audio_codec.h:140
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: audio/inc/audio_codec.h:152
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: audio/inc/audio_codec.h:142
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: audio/inc/audio_codec.h:148
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: audio/inc/audio_codec.h:156
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: audio/inc/audio_codec.h:154
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: audio/inc/audio_codec.h:138
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: audio/inc/audio_codec.h:132
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: audio/inc/audio_codec.h:149
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: audio/inc/audio_codec.h:137
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: audio/inc/audio_codec.h:150
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: audio/inc/audio_codec.h:151
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: audio/inc/audio_codec.h:131
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: audio/inc/audio_codec.h:158
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: audio/inc/audio_codec.h:162
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: audio/inc/audio_codec.h:153
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: audio/inc/audio_codec.h:139
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: audio/inc/audio_codec.h:155
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: audio/inc/audio_codec.h:164
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: audio/inc/audio_codec.h:165
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: audio/inc/audio_codec.h:136
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: audio/inc/audio_codec.h:146
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
i2s_init_type
i2s init type
Definition: at32f413_spi.h:270
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:273
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:274
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:276
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:272
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:271
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:275
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400


AT32F413 Firmwary Library: audio_class.c Source File

  • middlewares
  • usbd_class
  • audio
audio_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "audio_class.h"
26#include "audio_desc.h"
27#include "audio_codec.h"
28
42static usb_sts_type class_init_handler(void *udev);
43static usb_sts_type class_clear_handler(void *udev);
44static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
45static usb_sts_type class_ept0_tx_handler(void *udev);
46static usb_sts_type class_ept0_rx_handler(void *udev);
47static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_sof_handler(void *udev);
50static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
51
52static void audio_req_get_cur(void *udev, usb_setup_type *setup);
53static void audio_req_set_cur(void *udev, usb_setup_type *setup);
54static void audio_req_get_min(void *udev, usb_setup_type *setup);
55static void audio_req_get_max(void *udev, usb_setup_type *setup);
56static void audio_req_get_res(void *udev, usb_setup_type *setup);
57static void audio_get_interface(void *udev, usb_setup_type *setup);
58static void audio_set_interface(void *udev, usb_setup_type *setup);
59
60 usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0};
61
62/* usb device class handler */
63 usbd_class_handler audio_class_handler =
64{
65 class_init_handler,
66 class_clear_handler,
67 class_setup_handler,
68 class_ept0_tx_handler,
69 class_ept0_rx_handler,
70 class_in_handler,
71 class_out_handler,
72 class_sof_handler,
73 class_event_handler,
74 &audio_struct
75};
76
82static usb_sts_type class_init_handler(void *udev)
83{
84 usb_sts_type status = USB_OK;
85 usbd_core_type *pudev = (usbd_core_type *)udev;
86 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
87 /* enable microphone in endpoint double buffer mode */
88 usbd_ept_dbuffer_enable(pudev, USBD_AUDIO_MIC_IN_EPT);
89
90 /* open microphone in endpoint */
91 usbd_ept_open(pudev, USBD_AUDIO_MIC_IN_EPT, EPT_ISO_TYPE, AUDIO_MIC_IN_MAXPACKET_SIZE);
92
93 /* enable speaker out endpoint double buffer mode */
94 usbd_ept_dbuffer_enable(pudev, USBD_AUDIO_SPK_OUT_EPT);
95
96 /* open speaker out endpoint */
97 usbd_ept_open(pudev, USBD_AUDIO_SPK_OUT_EPT, EPT_ISO_TYPE, AUDIO_SPK_OUT_MAXPACKET_SIZE);
98
99 /* enable speaker feedback endpoint double buffer mode */
100 usbd_ept_dbuffer_enable(pudev, USBD_AUDIO_FEEDBACK_EPT);
101
102 /* open speaker feedback endpoint */
103 usbd_ept_open(pudev, USBD_AUDIO_FEEDBACK_EPT, EPT_ISO_TYPE, AUDIO_FEEDBACK_MAXPACKET_SIZE);
104
105 /* start receive speaker out data */
106 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
107
108 return status;
109}
110
116static usb_sts_type class_clear_handler(void *udev)
117{
118 usb_sts_type status = USB_OK;
119 usbd_core_type *pudev = (usbd_core_type *)udev;
120
121 /* close in endpoint */
122 usbd_ept_close(pudev, USBD_AUDIO_MIC_IN_EPT);
123
124 /* close in endpoint */
125 usbd_ept_close(pudev, USBD_AUDIO_FEEDBACK_EPT);
126
127 /* close out endpoint */
128 usbd_ept_close(pudev, USBD_AUDIO_SPK_OUT_EPT);
129
130 return status;
131}
132
139static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
140{
141 usb_sts_type status = USB_OK;
142 usbd_core_type *pudev = (usbd_core_type *)udev;
143 uint16_t len;
144
145 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
146 {
147 /* class request */
148 case USB_REQ_TYPE_CLASS:
149 switch(setup->bRequest)
150 {
151 case AUDIO_REQ_GET_CUR:
152 audio_req_get_cur(pudev, setup);
153 break;
154
155 case AUDIO_REQ_SET_CUR:
156 audio_req_set_cur(pudev, setup);
157 break;
158
159 case AUDIO_REQ_GET_MIN:
160 audio_req_get_min(pudev, setup);
161 break;
162
163 case AUDIO_REQ_GET_MAX:
164 audio_req_get_max(pudev, setup);
165 break;
166
167 case AUDIO_REQ_GET_RES:
168 audio_req_get_res(pudev, setup);
169 break;
170
171 default:
172 usbd_ctrl_unsupport(pudev);
173 break;
174 }
175 break;
176 /* standard request */
177 case USB_REQ_TYPE_STANDARD:
178 switch(setup->bRequest)
179 {
180 case USB_STD_REQ_GET_DESCRIPTOR:
181 if((setup->wValue >> 8) == AUDIO_DESCRIPTOR_TYPE)
182 {
183 usbd_desc_t *config = pudev->desc_handler->get_device_configuration();
184 len = MIN(AUDIO_DESCRIPTOR_SIZE, setup->wLength);
185 usbd_ctrl_send(pudev, config->descriptor + 18, len);
186 }
187 else
188 {
189 usbd_ctrl_unsupport(pudev);
190 }
191 break;
192 case USB_STD_REQ_GET_INTERFACE:
193 audio_get_interface(udev, setup);
194 break;
195
196 case USB_STD_REQ_SET_INTERFACE:
197 audio_set_interface(udev, setup);
198 usbd_ctrl_send_status(pudev);
199 break;
200 case USB_STD_REQ_CLEAR_FEATURE:
201 break;
202 case USB_STD_REQ_SET_FEATURE:
203 break;
204 default:
205 usbd_ctrl_unsupport(pudev);
206 break;
207 }
208 break;
209
210 default:
211 usbd_ctrl_unsupport(pudev);
212 break;
213 }
214 return status;
215}
216
222static usb_sts_type class_ept0_tx_handler(void *udev)
223{
224 usb_sts_type status = USB_OK;
225
226 /* ...user code... */
227
228 return status;
229}
230
236static usb_sts_type class_ept0_rx_handler(void *udev)
237{
238 usb_sts_type status = USB_OK;
239 usbd_core_type *pudev = (usbd_core_type *)udev;
240 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
241 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
242 /* ...user code... */
243 if( paudio->audio_cmd == AUDIO_REQ_SET_CUR)
244 {
245 /* class process */
246 switch( paudio->request_no)
247 {
248 case AUDIO_VOLUME_CONTROL:
249 if( paudio->interface == AUDIO_SPK_FEATURE_UNIT_ID)
250 {
251 paudio->spk_volume = (uint16_t)( paudio->g_audio_cur[0] |
252 ( paudio->g_audio_cur[1] << 8));
253 /* set volume */
254 audio_codec_set_spk_volume(paudio->spk_volume*100/paudio->spk_volume_limits[1]);
255 }
256 else
257 {
258 paudio->mic_volume = (uint16_t)(paudio->g_audio_cur[0] |
259 (paudio->g_audio_cur[1] << 8));
260
261 audio_codec_set_mic_volume(paudio->mic_volume*256/paudio->mic_volume_limits[1]);
262 }
263 break;
264 case AUDIO_MUTE_CONTROL:
265 if(paudio->interface == AUDIO_SPK_FEATURE_UNIT_ID)
266 {
267 paudio->spk_mute = paudio->g_audio_cur[0];
268 audio_codec_set_spk_mute(paudio->spk_mute);
269 }
270 else
271 {
272 paudio->mic_mute = paudio->g_audio_cur[0];
273 audio_codec_set_mic_mute(paudio->mic_mute);
274 }
275
276 break;
277 case AUDIO_FREQ_SET_CONTROL:
278 if(paudio->enpd == USBD_AUDIO_MIC_IN_EPT)
279 {
280 paudio->mic_freq = (paudio->g_audio_cur[0] |
281 (paudio->g_audio_cur[1] << 8) |
282 (paudio->g_audio_cur[2] << 16));
283 audio_codec_set_mic_freq(paudio->mic_freq);
284 }
285 else
286 {
287 paudio->spk_freq = (paudio->g_audio_cur[0] |
288 (paudio->g_audio_cur[1] << 8) |
289 (paudio->g_audio_cur[2] << 16));
290 audio_codec_set_spk_freq(paudio->spk_freq);
291 }
292 break;
293 default:
294 break;
295 }
296 }
297
298 return status;
299}
300
307static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
308{
309 usb_sts_type status = USB_OK;
310 usbd_core_type *pudev = (usbd_core_type *)udev;
311 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
312 uint32_t len = 0;
313
314 /* ...user code...
315 trans next packet data
316 */
317 if((ept_num & 0x7F) == (USBD_AUDIO_MIC_IN_EPT & 0x7F))
318 {
319 len = audio_codec_mic_get_data(paudio->audio_mic_data);
320 usbd_ept_send(udev, USBD_AUDIO_MIC_IN_EPT, paudio->audio_mic_data, len);
321 }
322
323 else if((ept_num & 0x7F) == (USBD_AUDIO_FEEDBACK_EPT & 0x7F))
324 {
325 len = audio_codec_spk_feedback(paudio->audio_feed_back);
326 usbd_ept_send(udev, USBD_AUDIO_FEEDBACK_EPT, paudio->audio_feed_back, len);
327 }
328
329 return status;
330}
331
338static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
339{
340 usb_sts_type status = USB_OK;
341 usbd_core_type *pudev = (usbd_core_type *)udev;
342 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
343 uint16_t g_rxlen;
344
345 /* get endpoint receive data length */
346 g_rxlen = usbd_get_recv_len(pudev, ept_num);
347
348 if((ept_num & 0x7F) == (USBD_AUDIO_SPK_OUT_EPT & 0x7F))
349 {
350 /* speaker data*/
351 audio_codec_spk_fifo_write(paudio->audio_spk_data, g_rxlen);
352
353 /* get next data */
354 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
355 }
356
357 return status;
358}
359
365static usb_sts_type class_sof_handler(void *udev)
366{
367 usb_sts_type status = USB_OK;
368
369 /* ...user code... */
370
371 return status;
372}
373
380 usb_sts_type class_event_handler(void *udev, usbd_event_type event)
381{
382 usb_sts_type status = USB_OK;
383 usbd_core_type *pudev = (usbd_core_type *)udev;
384 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
385 switch(event)
386 {
387 case USBD_RESET_EVENT:
388
389 /* ...user code... */
390
391 break;
392 case USBD_SUSPEND_EVENT:
393 paudio->spk_alt_setting = 0;
394 audio_codec_spk_alt_setting(paudio->spk_alt_setting);
395 paudio->mic_alt_setting = 0;
396 audio_codec_mic_alt_setting(paudio->spk_alt_setting);
397 /* ...user code... */
398
399 break;
400 case USBD_WAKEUP_EVENT:
401 /* ...user code... */
402
403 break;
404 default:
405 break;
406 }
407 return status;
408}
409
416static void audio_req_get_cur(void *udev, usb_setup_type *setup)
417{
418 usbd_core_type *pudev = (usbd_core_type *)udev;
419 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
420 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
421 {
422 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
423 {
424 paudio->g_audio_cur[0] = paudio->spk_mute;
425 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
426 }
427 else
428 {
429 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume;
430 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
431 }
432 }
433 else
434 {
435 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
436 {
437 paudio->g_audio_cur[0] = paudio->mic_mute;
438 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
439 }
440 else
441 {
442 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume;
443 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
444 }
445
446 }
447}
448
455static void audio_req_set_cur(void *udev, usb_setup_type *setup)
456{
457 usbd_core_type *pudev = (usbd_core_type *)udev;
458 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
459 if(setup->wLength > 0)
460 {
461 usbd_ctrl_recv(pudev, paudio->g_audio_cur, setup->wLength);
462
463 paudio->audio_cmd = AUDIO_REQ_SET_CUR;
464 paudio->audio_cmd_len = setup->wLength;
465
466 switch(setup->bmRequestType & AUDIO_REQ_CONTROL_MASK)
467 {
468 case AUDIO_REQ_CONTROL_INTERFACE:
469 paudio->interface = HBYTE(setup->wIndex);
470 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
471 {
472 paudio->request_no = AUDIO_MUTE_CONTROL;
473 }
474 else
475 {
476 paudio->request_no = AUDIO_VOLUME_CONTROL;
477 }
478 break;
479 case AUDIO_REQ_CONTROL_ENDPOINT:
480 paudio->enpd = setup->wIndex;
481 paudio->request_no = AUDIO_FREQ_SET_CONTROL;
482 break;
483 default:
484 break;
485 }
486 }
487}
488
495static void audio_req_get_min(void *udev, usb_setup_type *setup)
496{
497 usbd_core_type *pudev = (usbd_core_type *)udev;
498 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
499 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
500 {
501 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[0];
502 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
503 }
504 else
505 {
506 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[0];
507 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
508 }
509}
510
517static void audio_req_get_max(void *udev, usb_setup_type *setup)
518{
519 usbd_core_type *pudev = (usbd_core_type *)udev;
520 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
521 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
522 {
523 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[1];
524 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
525 }
526 else
527 {
528 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[1];
529 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
530 }
531}
532
539static void audio_req_get_res(void *udev, usb_setup_type *setup)
540{
541 usbd_core_type *pudev = (usbd_core_type *)udev;
542 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
543 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
544 {
545 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[2];
546 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
547 }
548 else
549 {
550 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[2];
551 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
552 }
553}
554
561static void audio_set_interface(void *udev, usb_setup_type *setup)
562{
563 uint32_t len;
564 usbd_core_type *pudev = (usbd_core_type *)udev;
565 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
566 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
567 {
568 paudio->spk_alt_setting = setup->wValue;
569 audio_codec_spk_alt_setting(paudio->spk_alt_setting);
570 if(paudio->spk_alt_setting )
571 {
572 int len = audio_codec_spk_feedback(paudio->audio_feed_back);
573 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
574 usbd_ept_send(pudev, USBD_AUDIO_FEEDBACK_EPT, paudio->audio_feed_back, len);
575 }
576
577 }
578 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
579 {
580 paudio->mic_alt_setting = setup->wValue;
581 audio_codec_mic_alt_setting(paudio->mic_alt_setting);
582 if(paudio->mic_alt_setting)
583 {
584 len = audio_codec_mic_get_data(paudio->audio_mic_data);
585 usbd_ept_send(pudev, USBD_AUDIO_MIC_IN_EPT, paudio->audio_mic_data, len);
586 }
587 }
588
589}
590
591
598static void audio_get_interface(void *udev, usb_setup_type *setup)
599{
600 usbd_core_type *pudev = (usbd_core_type *)udev;
601 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
602 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
603 {
604 usbd_ctrl_send(pudev, (uint8_t *)&paudio->spk_alt_setting, 1);
605 }
606 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
607 {
608 usbd_ctrl_send(pudev, (uint8_t *)&paudio->mic_alt_setting, 1);
609 }
610
611}
612
613
audio_class.h
usb audio class file
audio_desc.h
usb audio descriptor header file
AUDIO_DESCRIPTOR_TYPE
#define AUDIO_DESCRIPTOR_TYPE
audio descriptor type
Definition: audio_class.h:81
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:60
AUDIO_MUTE_CONTROL
#define AUDIO_MUTE_CONTROL
audio set cur type define
Definition: audio_class.h:74
AUDIO_REQ_CONTROL_INTERFACE
#define AUDIO_REQ_CONTROL_INTERFACE
request type define
Definition: audio_class.h:67
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:61
AUDIO_VOLUME_CONTROL
#define AUDIO_VOLUME_CONTROL
Definition: audio_class.h:75
AUDIO_FREQ_SET_CONTROL
#define AUDIO_FREQ_SET_CONTROL
Definition: audio_class.h:76
AUDIO_REQ_CONTROL_ENDPOINT
#define AUDIO_REQ_CONTROL_ENDPOINT
Definition: audio_class.h:68
AUDIO_REQ_CONTROL_MASK
#define AUDIO_REQ_CONTROL_MASK
Definition: audio_class.h:69
USBD_AUDIO_SPK_OUT_EPT
#define USBD_AUDIO_SPK_OUT_EPT
Definition: audio_class.h:53
USBD_AUDIO_MIC_IN_EPT
#define USBD_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_class.h:52
AUDIO_DESCRIPTOR_SIZE
#define AUDIO_DESCRIPTOR_SIZE
Definition: audio_class.h:82
USBD_AUDIO_FEEDBACK_EPT
#define USBD_AUDIO_FEEDBACK_EPT
Definition: audio_class.h:54
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:62
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_class.c:365
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_class.c:307
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_class.c:116
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_class.c:139
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_class.c:222
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_class.c:380
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:63
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_class.c:236
audio_req_get_res
static void audio_req_get_res(void *udev, usb_setup_type *setup)
usb audio request get res
Definition: audio_class.c:539
audio_get_interface
static void audio_get_interface(void *udev, usb_setup_type *setup)
usb audio get interface
Definition: audio_class.c:598
audio_req_set_cur
static void audio_req_set_cur(void *udev, usb_setup_type *setup)
usb audio request set cur
Definition: audio_class.c:455
audio_struct
usb_audio_type audio_struct
Definition: audio_class.c:60
audio_req_get_max
static void audio_req_get_max(void *udev, usb_setup_type *setup)
usb audio request get max
Definition: audio_class.c:517
audio_req_get_min
static void audio_req_get_min(void *udev, usb_setup_type *setup)
usb audio request get min
Definition: audio_class.c:495
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_class.c:82
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_class.c:338
audio_req_get_cur
static void audio_req_get_cur(void *udev, usb_setup_type *setup)
usb audio request get cur
Definition: audio_class.c:416
audio_set_interface
static void audio_set_interface(void *udev, usb_setup_type *setup)
usb audio set interface
Definition: audio_class.c:561
AUDIO_REQ_GET_CUR
#define AUDIO_REQ_GET_CUR
Definition: audio_desc.h:111
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:178
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:176
AUDIO_REQ_GET_MAX
#define AUDIO_REQ_GET_MAX
Definition: audio_desc.h:115
AUDIO_REQ_GET_MIN
#define AUDIO_REQ_GET_MIN
Definition: audio_desc.h:113
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:170
AUDIO_REQ_GET_RES
#define AUDIO_REQ_GET_RES
Definition: audio_desc.h:117
AUDIO_REQ_SET_CUR
#define AUDIO_REQ_SET_CUR
Definition: audio_desc.h:110
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:167
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:215
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:193
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:119
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:280
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:182
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:242
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:226
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:204
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:152
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:135
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:202
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:404
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:209
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
usb_audio_type
usb audio control struct
Definition: audio_class.h:88
usb_audio_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_class.h:104
usb_audio_type::enpd
uint8_t enpd
Definition: audio_class.h:89
usb_audio_type::mic_freq
uint32_t mic_freq
Definition: audio_class.h:97
usb_audio_type::spk_volume_limits
uint16_t spk_volume_limits[3]
Definition: audio_class.h:98
usb_audio_type::audio_spk_data
uint8_t audio_spk_data[(48 *2 *(16/8)+40)]
Definition: audio_class.h:106
usb_audio_type::mic_volume_limits
uint16_t mic_volume_limits[3]
Definition: audio_class.h:99
usb_audio_type::interface
uint8_t interface
Definition: audio_class.h:90
usb_audio_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_class.h:102
usb_audio_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_class.h:103
usb_audio_type::spk_volume
uint16_t spk_volume
Definition: audio_class.h:94
usb_audio_type::mic_volume
uint16_t mic_volume
Definition: audio_class.h:95
usb_audio_type::spk_freq
uint32_t spk_freq
Definition: audio_class.h:96
usb_audio_type::audio_mic_data
uint8_t audio_mic_data[(48 *2 *(16/8)+40)]
Definition: audio_class.h:107
usb_audio_type::g_audio_cur
uint8_t g_audio_cur[64]
Definition: audio_class.h:105
usb_audio_type::spk_mute
uint8_t spk_mute
Definition: audio_class.h:92
usb_audio_type::request_no
uint8_t request_no
Definition: audio_class.h:91
usb_audio_type::audio_cmd
uint8_t audio_cmd
Definition: audio_class.h:101
usb_audio_type::audio_feed_back
uint8_t audio_feed_back[0x3+1]
Definition: audio_class.h:108
usb_audio_type::mic_mute
uint8_t mic_mute
Definition: audio_class.h:93
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:294
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:112
usbd_desc_handler::get_device_configuration
usbd_desc_t *(* get_device_configuration)(void)
Definition: usbd_core.h:77
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_class.h Source File

  • middlewares
  • usbd_class
  • audio
audio_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_CLASS_H
27#define __AUDIO_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35#include "audio_conf.h"
36
52#define USBD_AUDIO_MIC_IN_EPT 0x81
53#define USBD_AUDIO_SPK_OUT_EPT 0x02
54#define USBD_AUDIO_FEEDBACK_EPT 0x83
55
59#define AUDIO_REMAIN_SIZE 40
60#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
61#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
62#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
63#define FEEDBACK_REFRESH_TIME 0x8
67#define AUDIO_REQ_CONTROL_INTERFACE 0x01
68#define AUDIO_REQ_CONTROL_ENDPOINT 0x02
69#define AUDIO_REQ_CONTROL_MASK 0x03
70
74#define AUDIO_MUTE_CONTROL 0x01
75#define AUDIO_VOLUME_CONTROL 0x02
76#define AUDIO_FREQ_SET_CONTROL 0x03
77
81#define AUDIO_DESCRIPTOR_TYPE 0x21
82#define AUDIO_DESCRIPTOR_SIZE 0x09
83
87typedef struct
88{
89 uint8_t enpd;
90 uint8_t interface;
91 uint8_t request_no;
92 uint8_t spk_mute;
93 uint8_t mic_mute;
94 uint16_t spk_volume;
95 uint16_t mic_volume;
96 uint32_t spk_freq;
97 uint32_t mic_freq;
98 uint16_t spk_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
99 uint16_t mic_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
100
101 uint8_t audio_cmd;
102 uint32_t audio_cmd_len;
103 uint32_t spk_alt_setting;
104 uint32_t mic_alt_setting;
105 uint8_t g_audio_cur[64];
106 uint8_t audio_spk_data[AUDIO_SPK_OUT_MAXPACKET_SIZE];
107 uint8_t audio_mic_data[AUDIO_MIC_IN_MAXPACKET_SIZE];
108 uint8_t audio_feed_back[AUDIO_FEEDBACK_MAXPACKET_SIZE+1];
109}usb_audio_type;
110
111extern usbd_class_handler audio_class_handler;
112
125#ifdef __cplusplus
126}
127#endif
128
129#endif
130
audio_conf.h
usb audio config
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:60
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:63
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:61
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:62
usb_audio_type
usb audio control struct
Definition: audio_class.h:88
usb_audio_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_class.h:104
usb_audio_type::enpd
uint8_t enpd
Definition: audio_class.h:89
usb_audio_type::mic_freq
uint32_t mic_freq
Definition: audio_class.h:97
usb_audio_type::interface
uint8_t interface
Definition: audio_class.h:90
usb_audio_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_class.h:102
usb_audio_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_class.h:103
usb_audio_type::spk_volume
uint16_t spk_volume
Definition: audio_class.h:94
usb_audio_type::mic_volume
uint16_t mic_volume
Definition: audio_class.h:95
usb_audio_type::spk_freq
uint32_t spk_freq
Definition: audio_class.h:96
usb_audio_type::spk_mute
uint8_t spk_mute
Definition: audio_class.h:92
usb_audio_type::request_no
uint8_t request_no
Definition: audio_class.h:91
usb_audio_type::audio_cmd
uint8_t audio_cmd
Definition: audio_class.h:101
usb_audio_type::mic_mute
uint8_t mic_mute
Definition: audio_class.h:93
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_desc.c Source File

  • middlewares
  • usbd_class
  • audio
audio_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "audio_desc.h"
28
41static usbd_desc_t *get_device_descriptor(void);
42static usbd_desc_t *get_device_qualifier(void);
43static usbd_desc_t *get_device_configuration(void);
44static usbd_desc_t *get_device_other_speed(void);
45static usbd_desc_t *get_device_lang_id(void);
46static usbd_desc_t *get_device_manufacturer_string(void);
47static usbd_desc_t *get_device_product_string(void);
48static usbd_desc_t *get_device_serial_string(void);
49static usbd_desc_t *get_device_interface_string(void);
50static usbd_desc_t *get_device_config_string(void);
51
52static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
53static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
54static void get_serial_num(void);
55#if defined ( __ICCARM__ ) /* iar compiler */
56 #pragma data_alignment=4
57#endif
58ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
59
63 usbd_desc_handler audio_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0x00, /* bDeviceClass */
90 0x00, /* bDeviceSubClass */
91 0x00, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_AUDIO_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_AUDIO_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_AUDIO_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_AUDIO_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 0x01 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_AUDIO_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_AUDIO_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_AUDIO_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x1 + AUDIO_INTERFACE_NUM, /* bNumInterfaces: n interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xC0, /* bmAttributes: self powered */
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
125 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
126 0x00, /* bInterfaceNumber: number of interface */
127 0x00, /* bAlternateSetting: alternate set */
128 0x00, /* bNumEndpoints: number of endpoints */
129 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio class code */
130 AUDIO_SUBCLASS_AUDIOCONTROL, /* bInterfaceSubClass: audio control */
131 AUDIO_PROTOCOL_UNDEFINED, /* bInterfaceProtocol: undefined */
132 0x00, /* iInterface: index of string descriptor */
133
134 0x08+AUDIO_INTERFACE_NUM, /* bLength: size of this descriptor, in bytes 8+n */
135 AUDIO_CS_INTERFACE, /* bDescriptorType: cs interface descriptor type */
136 AUDIO_AC_HEADER, /* bDescriptorSubtype: Header function Descriptor*/
137 LBYTE(AUDIO_BCD_NUM),
138 HBYTE(AUDIO_BCD_NUM), /* bcdCDC: audio device class specification release number */
139 LBYTE(AUDIO_INTERFACE_LEN),
140 HBYTE(AUDIO_INTERFACE_LEN), /* wTotalLength: total number of bytes returned for the class-specific audio control interface */
141 AUDIO_INTERFACE_NUM, /* bInClollection: the number of audio streaming */
142#if (AUDIO_INTERFACE_NUM == 2) /* two interface */
143 0x02,
144 0x01,
145#else
146 0x01,
147#endif
148
149 /* usb microphone config */
150#if (AUDIO_SUPPORT_MIC == 1)
151 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
152 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
153 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
154 AUDIO_MIC_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
155 LBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),
156 HBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),/* wTerminalType: terminal is microphone */
157 0x00, /* bAssocTerminal: no association */
158 AUDIO_MIC_CHR, /* bNrChannels: two channel */
159#if (AUDIO_MIC_CHR == 2)
160 0x03, /* wChannelConfig: left front and right front */
161#endif
162#if (AUDIO_MIC_CHR == 1)
163 0x00, /* wChannelConfig */
164#endif
165 0x00, /* wChannelConfig */
166 0x00, /* iChannelNames: unused */
167 0x00, /* iTerminal: unused */
168
169 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
170 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
171 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
172 AUDIO_MIC_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
173 AUDIO_MIC_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
174 0x02, /* bControlSize: 2 byte */
175 0x03, /* bmaControls0: mute & volume*/
176 0x00,
177 0x00, /* bmaControls1 */
178 0x00,
179 0x00, /* bmaControls2 */
180 0x00,
181 0x00, /* iFeature: unused */
182
183 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
184 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
185 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
186 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
187 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING),
188 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
189 0x00, /* bAssocTerminal: unused */
190 AUDIO_MIC_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
191 0x00, /* iTerminal: unused */
192#endif
193
194#if (AUDIO_SUPPORT_SPK == 1)
195 /* speaker config */
196 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
197 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
198 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
199 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
200 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
201 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
202 0x00, /* bAssocTerminal: no association */
203 AUDIO_SPK_CHR, /* bNrChannels: two channel */
204#if (AUDIO_SPK_CHR == 2)
205 0x03, /* wChannelConfig: left front and right front */
206#endif
207#if (AUDIO_SPK_CHR == 1)
208 0x00, /* wChannelConfig */
209#endif
210 0x00, /* wChannelConfig */
211 0x00, /* iChannelNames: unused */
212 0x00, /* iTerminal: unused */
213
214 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
215 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
216 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
217 AUDIO_SPK_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
218 AUDIO_SPK_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
219 0x02, /* bControlSize: 2 byte */
220 0x03, /* bmaControls0: mute & volume*/
221 0x00,
222 0x00, /* bmaControls1: 0x0000 */
223 0x00,
224 0x00, /* bmaControls2: 0x0000 */
225 0x00,
226 0x00, /* iFeature: unused */
227
228 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
229 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
230 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
231 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
232 LBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
233 HBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
234 0x00, /* bAssocTerminal: unused */
235 AUDIO_SPK_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
236 0x00, /* iTerminal: unused */
237#endif
238
239#if (AUDIO_SUPPORT_MIC == 1)
240 /* microphone interface */
241 0x09, /* bLength: descriptor size */
242 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
243 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
244 0x00, /* bAlternateSetting: index of this setting */
245 0x00, /* bNumEndpoints: 0 endpoints */
246 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
247 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
248 0x00, /* bInterfaceProtocol: unused */
249 0x00, /* iInterface: unused */
250
251 0x09, /* bLength: descriptor size */
252 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
253 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
254 0x01, /* bAlternateSetting: index of this setting */
255 0x01, /* bNumEndpoints: 1 endpoints */
256 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
257 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
258 0x00, /* bInterfaceProtocol: unused */
259 0x00, /* iInterface: unused */
260
261 0x07, /* bLength: configuration descriptor size */
262 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
263 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
264 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalLink: unit id of the output terminal */
265 0x01, /* bDelay: interface delay */
266 0x01, /* wFormatTag: pcm format*/
267 0x00, /* wFormatTag: pcm format*/
268
269 0x08 + AUDIO_MIC_FREQ_SIZE * 3, /* bLength: descriptor size */
270 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
271 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
272 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
273 AUDIO_MIC_CHR, /* bNrChannels: channel number */
274 AUDIO_MIC_BITW / 8, /* bSubFrameSize: per audio subframe */
275 AUDIO_MIC_BITW, /* bBitResolution: n bits per sample */
276 AUDIO_MIC_FREQ_SIZE, /* bSamFreqType: n frequency supported */
277#if (AUDIO_SUPPORT_FREQ_16K == 1)
278 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
279#endif
280#if (AUDIO_SUPPORT_FREQ_48K == 1)
281 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
282#endif
283
284 0x09, /* bLength: size of endpoint descriptor in bytes */
285 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
286 USBD_AUDIO_MIC_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
287 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
288 LBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE),
289 HBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
290 AUDIO_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
291 0x00, /* bRefresh: unused */
292 0x00, /* bSynchAddress: unused */
293
294 0x07, /* bLength: size of endpoint descriptor in bytes */
295 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
296 0x01, /* bDescriptorSubtype: general subtype */
297 0x01, /* bmAttributes */
298 0x00, /* bLockDelayUnits: unused */
299 0x00, /* wLockDelay: unused */
300 0x00, /* wLockDelay: unused */
301#endif
302
303#if (AUDIO_SUPPORT_SPK == 1)
304 /* speaker interface */
305 0x09, /* bLength: descriptor size */
306 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
307 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
308 0x00, /* bAlternateSetting: index of this setting */
309 0x00, /* bNumEndpoints: 0 endpoints */
310 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
311 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
312 0x00, /* bInterfaceProtocol: unused */
313 0x00, /* iInterface: unused */
314
315 0x09, /* bLength: descriptor size */
316 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
317 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
318 0x01, /* bAlternateSetting: index of this setting */
319 0x01 + AUDIO_SUPPORT_FEEDBACK, /* bNumEndpoints: endpoints */
320 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
321 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
322 0x00, /* bInterfaceProtocol: unused */
323 0x00, /* iInterface: unused */
324
325 0x07, /* bLength: configuration descriptor size */
326 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
327 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
328 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalLink: unit id of the input terminal */
329 0x01, /* bDelay: interface delay */
330 0x01, /* wFormatTag: pcm format*/
331 0x00, /* wFormatTag: pcm format*/
332
333 0x08 + AUDIO_SPK_FREQ_SIZE * 3, /* bLength: descriptor size */
334 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
335 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
336 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
337 AUDIO_SPK_CHR, /* bNrChannels: channel number */
338 AUDIO_SPK_BITW / 8, /* bSubFrameSize: per audio subframe */
339 AUDIO_SPK_BITW, /* bBitResolution: n bits per sample */
340 AUDIO_SPK_FREQ_SIZE, /* bSamFreqType: n frequency supported */
341#if (AUDIO_SUPPORT_FREQ_16K == 1)
342 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
343#endif
344#if (AUDIO_SUPPORT_FREQ_48K == 1)
345 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
346#endif
347
348 0x09, /* bLength: size of endpoint descriptor in bytes */
349 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
350 USBD_AUDIO_SPK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
351 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
352 LBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE),
353 HBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
354 AUDIO_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
355 0x00, /* bRefresh: unused */
356#if (AUDIO_SUPPORT_FEEDBACK == 1)
357 USBD_AUDIO_FEEDBACK_EPT, /* bSynchAddress: feedback endpoint */
358#else
359 0x00, /* bSynchAddress: unused */
360#endif
361
362 0x07, /* bLength: size of endpoint descriptor in bytes */
363 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
364 0x01, /* bDescriptorSubtype: general subtype */
365 0x01, /* bmAttributes */
366 0x00, /* bLockDelayUnits: unused */
367 0x00, /* wLockDelay: unused */
368 0x00, /* wLockDelay: unused */
369
370#if (AUDIO_SUPPORT_FEEDBACK == 1)
371 0x09, /* bLength: size of endpoint descriptor in bytes */
372 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
373 USBD_AUDIO_FEEDBACK_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
374 0x11, /* bmAttributes: endpoint attributes */
375 LBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
376 HBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
377 1, /* bInterval: interval for polling endpoint for data transfers */
378 FEEDBACK_REFRESH_TIME, /* bRefresh: this field indicates the rate at which an iso syncronization
379 pipe provides new syncronization feedback data. this rate must be a power of
380 2, therefore only the power is reported back and the range of this field is from
381 1(2ms) to 9(512ms) */
382 0x00 /* bSynchAddress: 0x00*/
383#endif
384
385#endif
386};
387
391#if defined ( __ICCARM__ ) /* iar compiler */
392 #pragma data_alignment=4
393#endif
394ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_AUDIO_SIZ_STRING_LANGID] ALIGNED_TAIL =
395{
396 USBD_AUDIO_SIZ_STRING_LANGID,
397 USB_DESCIPTOR_TYPE_STRING,
398 0x09,
399 0x04,
400};
401
405#if defined ( __ICCARM__ ) /* iar compiler */
406 #pragma data_alignment=4
407#endif
408ALIGNED_HEAD static uint8_t g_string_serial[USBD_AUDIO_SIZ_STRING_SERIAL] ALIGNED_TAIL =
409{
410 USBD_AUDIO_SIZ_STRING_SERIAL,
411 USB_DESCIPTOR_TYPE_STRING,
412};
413
414
415/* device descriptor */
416static usbd_desc_t device_descriptor =
417{
418 USB_DEVICE_DESC_LEN,
419 g_usbd_descriptor
420};
421
422/* config descriptor */
423static usbd_desc_t config_descriptor =
424{
425 USBD_AUDIO_CONFIG_DESC_SIZE,
426 g_usbd_configuration
427};
428
429/* langid descriptor */
430static usbd_desc_t langid_descriptor =
431{
432 USBD_AUDIO_SIZ_STRING_LANGID,
433 g_string_lang_id
434};
435
436/* serial descriptor */
437static usbd_desc_t serial_descriptor =
438{
439 USBD_AUDIO_SIZ_STRING_SERIAL,
440 g_string_serial
441};
442
443static usbd_desc_t vp_desc;
444
451static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
452{
453 uint16_t str_len = 0, id_pos = 2;
454 uint8_t *tmp_str = string;
455
456 while(*tmp_str != '\0')
457 {
458 str_len ++;
459 unicode_buf[id_pos ++] = *tmp_str ++;
460 unicode_buf[id_pos ++] = 0x00;
461 }
462
463 str_len = str_len * 2 + 2;
464 unicode_buf[0] = str_len;
465 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
466
467 return str_len;
468}
469
477static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
478{
479 uint8_t idx = 0;
480
481 for( idx = 0 ; idx < len ; idx ++)
482 {
483 if( ((value >> 28)) < 0xA )
484 {
485 pbuf[2 * idx] = (value >> 28) + '0';
486 }
487 else
488 {
489 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
490 }
491
492 value = value << 4;
493
494 pbuf[2 * idx + 1] = 0;
495 }
496}
497
503static void get_serial_num(void)
504{
505 uint32_t serial0, serial1, serial2;
506
507 serial0 = *(uint32_t*)MCU_ID1;
508 serial1 = *(uint32_t*)MCU_ID2;
509 serial2 = *(uint32_t*)MCU_ID3;
510
511 serial0 += serial2;
512
513 if (serial0 != 0)
514 {
515 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
516 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
517 }
518}
519
525static usbd_desc_t *get_device_descriptor(void)
526{
527 return &device_descriptor;
528}
529
535static usbd_desc_t * get_device_qualifier(void)
536{
537 return NULL;
538}
539
545static usbd_desc_t *get_device_configuration(void)
546{
547 return &config_descriptor;
548}
549
555static usbd_desc_t *get_device_other_speed(void)
556{
557 return NULL;
558}
559
565static usbd_desc_t *get_device_lang_id(void)
566{
567 return &langid_descriptor;
568}
569
570
576static usbd_desc_t *get_device_manufacturer_string(void)
577{
578 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
579 vp_desc.descriptor = g_usbd_desc_buffer;
580 return &vp_desc;
581}
582
588static usbd_desc_t *get_device_product_string(void)
589{
590 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
591 vp_desc.descriptor = g_usbd_desc_buffer;
592 return &vp_desc;
593}
594
600static usbd_desc_t *get_device_serial_string(void)
601{
602 get_serial_num();
603 return &serial_descriptor;
604}
605
611static usbd_desc_t *get_device_interface_string(void)
612{
613 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
614 vp_desc.descriptor = g_usbd_desc_buffer;
615 return &vp_desc;
616}
617
623static usbd_desc_t *get_device_config_string(void)
624{
625 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
626 vp_desc.descriptor = g_usbd_desc_buffer;
627 return &vp_desc;
628}
629
audio_desc.h
usb audio descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:60
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:61
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:63
USBD_AUDIO_SPK_OUT_EPT
#define USBD_AUDIO_SPK_OUT_EPT
Definition: audio_class.h:53
USBD_AUDIO_MIC_IN_EPT
#define USBD_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_class.h:52
USBD_AUDIO_FEEDBACK_EPT
#define USBD_AUDIO_FEEDBACK_EPT
Definition: audio_class.h:54
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_MIC_FEATURE_UNIT_ID
#define AUDIO_MIC_FEATURE_UNIT_ID
Definition: audio_desc.h:167
AUDIO_CS_ENDPOINT
#define AUDIO_CS_ENDPOINT
Definition: audio_desc.h:74
AUDIO_AC_HEADER
#define AUDIO_AC_HEADER
Definition: audio_desc.h:89
AUDIO_SUBCLASS_AUDIOCONTROL
#define AUDIO_SUBCLASS_AUDIOCONTROL
Definition: audio_desc.h:66
AUDIO_INPUT_TERMINAL_SIZE
#define AUDIO_INPUT_TERMINAL_SIZE
audio interface descriptor size define
Definition: audio_desc.h:159
AUDIO_TERMINAL_TYPE_STREAMING
#define AUDIO_TERMINAL_TYPE_STREAMING
Definition: audio_desc.h:136
AUDIO_SPK_CHR
#define AUDIO_SPK_CHR
Definition: audio_desc.h:200
USBD_AUDIO_DESC_PRODUCT_STRING
#define USBD_AUDIO_DESC_PRODUCT_STRING
Definition: audio_desc.h:58
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:178
AUDIO_MIC_OUTPUT_TERMINAL_ID
#define AUDIO_MIC_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:168
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:176
USBD_AUDIO_PRODUCT_ID
#define USBD_AUDIO_PRODUCT_ID
Definition: audio_desc.h:52
USBD_AUDIO_CONFIG_DESC_SIZE
#define USBD_AUDIO_CONFIG_DESC_SIZE
Definition: audio_desc.h:206
AUDIO_BCD_NUM
#define AUDIO_BCD_NUM
Definition: audio_desc.h:49
SAMPLE_FREQ
#define SAMPLE_FREQ(frq)
Definition: audio_desc.h:211
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:192
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:199
AT32_AUDIO_FREQ_48K
#define AT32_AUDIO_FREQ_48K
Definition: audio_desc.h:187
AUDIO_FORMAT_TYPE_I
#define AUDIO_FORMAT_TYPE_I
audio format type 1
Definition: audio_desc.h:146
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
AUDIO_AS_GENERAL
#define AUDIO_AS_GENERAL
Definition: audio_desc.h:102
USBD_AUDIO_DESC_CONFIGURATION_STRING
#define USBD_AUDIO_DESC_CONFIGURATION_STRING
Definition: audio_desc.h:59
USBD_AUDIO_DESC_INTERFACE_STRING
#define USBD_AUDIO_DESC_INTERFACE_STRING
Definition: audio_desc.h:60
AUDIO_INTERFACE_NUM
#define AUDIO_INTERFACE_NUM
audio interface config
Definition: audio_desc.h:151
AUDIO_CS_INTERFACE
#define AUDIO_CS_INTERFACE
audio class-specific descriptor types
Definition: audio_desc.h:73
USBD_AUDIO_SIZ_STRING_SERIAL
#define USBD_AUDIO_SIZ_STRING_SERIAL
Definition: audio_desc.h:55
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:170
USBD_AUDIO_SIZ_STRING_LANGID
#define USBD_AUDIO_SIZ_STRING_LANGID
Definition: audio_desc.h:54
AUDIO_OUTPUT_TERMINAL_SIZE
#define AUDIO_OUTPUT_TERMINAL_SIZE
Definition: audio_desc.h:160
AUDIO_SPK_OUTPUT_TERMINAL_ID
#define AUDIO_SPK_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:171
AUDIO_AC_INPUT_TERMINAL
#define AUDIO_AC_INPUT_TERMINAL
Definition: audio_desc.h:90
AUDIO_MIC_CHR
#define AUDIO_MIC_CHR
Definition: audio_desc.h:193
AUDIO_OUTPUT_TERMINAL_SPEAKER
#define AUDIO_OUTPUT_TERMINAL_SPEAKER
Definition: audio_desc.h:141
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
AT32_AUDIO_FREQ_16K
#define AT32_AUDIO_FREQ_16K
audio support freq
Definition: audio_desc.h:186
AUDIO_AS_FORMAT_TYPE
#define AUDIO_AS_FORMAT_TYPE
Definition: audio_desc.h:103
AUDIO_MIC_INPUT_TERMINAL_ID
#define AUDIO_MIC_INPUT_TERMINAL_ID
audio terminal id define
Definition: audio_desc.h:166
AUDIO_SPK_BITW
#define AUDIO_SPK_BITW
Definition: audio_desc.h:201
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
AUDIO_FEATURE_UNIT_SIZE
#define AUDIO_FEATURE_UNIT_SIZE
Definition: audio_desc.h:161
AUDIO_PROTOCOL_UNDEFINED
#define AUDIO_PROTOCOL_UNDEFINED
audio interface protocol codes
Definition: audio_desc.h:83
AUDIO_MIC_BITW
#define AUDIO_MIC_BITW
Definition: audio_desc.h:194
USBD_AUDIO_VENDOR_ID
#define USBD_AUDIO_VENDOR_ID
Definition: audio_desc.h:51
AUDIO_AC_FEATURE_UNIT
#define AUDIO_AC_FEATURE_UNIT
Definition: audio_desc.h:94
AUDIO_SPK_INPUT_TERMINAL_ID
#define AUDIO_SPK_INPUT_TERMINAL_ID
Definition: audio_desc.h:169
AUDIO_BINTERVAL_TIME
#define AUDIO_BINTERVAL_TIME
Definition: audio_desc.h:203
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:152
AUDIO_SUBCLASS_AUDIOSTREAMING
#define AUDIO_SUBCLASS_AUDIOSTREAMING
Definition: audio_desc.h:67
USBD_AUDIO_DESC_MANUFACTURER_STRING
#define USBD_AUDIO_DESC_MANUFACTURER_STRING
Definition: audio_desc.h:57
AUDIO_AC_OUTPUT_TERMINAL
#define AUDIO_AC_OUTPUT_TERMINAL
Definition: audio_desc.h:91
AUDIO_INPUT_TERMINAL_MICROPHONE
#define AUDIO_INPUT_TERMINAL_MICROPHONE
Definition: audio_desc.h:139
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: audio_desc.c:437
device_descriptor
static usbd_desc_t device_descriptor
Definition: audio_desc.c:416
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_desc.c:545
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: audio_desc.c:430
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_desc.c:525
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_desc.c:576
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_desc.c:535
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_desc.c:611
vp_desc
static usbd_desc_t vp_desc
Definition: audio_desc.c:443
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_desc.c:555
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: audio_desc.c:58
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_desc.c:588
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_desc.c:623
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: audio_desc.c:451
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_desc.c:565
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: audio_desc.c:503
config_descriptor
static usbd_desc_t config_descriptor
Definition: audio_desc.c:423
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_desc.c:600
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:63
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: audio_desc.c:477
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:47
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_EPT_DESC_ISO
#define USB_EPT_DESC_ISO
Definition: usb_std.h:174
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_CLASS_CODE_AUDIO
#define USB_CLASS_CODE_AUDIO
usb class code
Definition: usb_std.h:159
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_ETP_DESC_ASYNC
#define USB_ETP_DESC_ASYNC
Definition: usb_std.h:179
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: audio_desc.h Source File

  • middlewares
  • usbd_class
  • audio
audio_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_DESC_H
27#define __AUDIO_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "audio_class.h"
34#include "usbd_core.h"
35#include "audio_conf.h"
36
49#define AUDIO_BCD_NUM 0x0100
50
51#define USBD_AUDIO_VENDOR_ID 0x2E3C
52#define USBD_AUDIO_PRODUCT_ID 0x5730
53
54#define USBD_AUDIO_SIZ_STRING_LANGID 4
55#define USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
56
57#define USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
58#define USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
59#define USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
60#define USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
61
65#define AUDIO_SUBCLASS_UNDEFINED 0x00
66#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01
67#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
68#define AUDIO_SUBCLASS_MIDISTREMING 0x03
69
73#define AUDIO_CS_INTERFACE 0x24
74#define AUDIO_CS_ENDPOINT 0x25
75#define AUDIO_CS_STRING 0x23
76#define AUDIO_CS_CONFIGURATION 0x22
77#define AUDIO_CS_DEVICE 0x21
78#define AUDIO_CS_UNDEFINED 0x20
79
83#define AUDIO_PROTOCOL_UNDEFINED 0x00
84
88#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
89#define AUDIO_AC_HEADER 0x01
90#define AUDIO_AC_INPUT_TERMINAL 0x02
91#define AUDIO_AC_OUTPUT_TERMINAL 0x03
92#define AUDIO_AC_MIXER_UNIT 0x04
93#define AUDIO_AC_SELECTOR_UNIT 0x05
94#define AUDIO_AC_FEATURE_UNIT 0x06
95#define AUDIO_AC_PROCESSING_UNIT 0x07
96#define AUDIO_AC_EXTENSION_UNIT 0x08
97
101#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
102#define AUDIO_AS_GENERAL 0x01
103#define AUDIO_AS_FORMAT_TYPE 0x02
104#define AUDIO_AS_FORMAT_SPECIFIC 0x03
105
109#define AUDIO_REQUEST_CODE_UNDEFINED 0x00
110#define AUDIO_REQ_SET_CUR 0x01
111#define AUDIO_REQ_GET_CUR 0x81
112#define AUDIO_REQ_SET_MIN 0x02
113#define AUDIO_REQ_GET_MIN 0x82
114#define AUDIO_REQ_SET_MAX 0x03
115#define AUDIO_REQ_GET_MAX 0x83
116#define AUDIO_REQ_SET_RES 0x04
117#define AUDIO_REQ_GET_RES 0x84
118#define AUDIO_REQ_SET_MEM 0x05
119#define AUDIO_REQ_GET_MEM 0x85
120#define AUDIO_REQ_GET_STAT 0xFF
121
125#define AUDIO_FU_CONTROL_UNDEFINED 0x00
126#define AUDIO_FU_MUTE_CONTROL 0x01
127#define AUDIO_FU_VOLUME_CONTROL 0x02
128#define AUDIO_FU_BASS_CONTROL 0x03
129#define AUDIO_FU_MID_CONTROL 0x04
130#define AUDIO_FU_TREBLE_CONTROL 0x05
131
135#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
136#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101
137#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
138#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
139#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
140#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
141#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
142
146#define AUDIO_FORMAT_TYPE_I 0x01
147
151#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
152#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)
153#define AUDIO_MIC_INTERFACE 0x01
154#define AUDIO_SPK_INTERFACE 0x02
155
159#define AUDIO_INPUT_TERMINAL_SIZE 0x0C
160#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09
161#define AUDIO_FEATURE_UNIT_SIZE 0x0D
162
166#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01
167#define AUDIO_MIC_FEATURE_UNIT_ID 0x02
168#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
169#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04
170#define AUDIO_SPK_FEATURE_UNIT_ID 0x05
171#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
172
176#define AUDIO_MIC_INTERFACE_NUMBER 0x01
177#if (AUDIO_SUPPORT_MIC == 1)
178#define AUDIO_SPK_INTERFACE_NUMBER 0x02
179#else
180#define AUDIO_SPK_INTERFACE_NUMBER 0x01
181#endif
182
186#define AT32_AUDIO_FREQ_16K 16000
187#define AT32_AUDIO_FREQ_48K 48000
188
192#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
193#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
194#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
195
199#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
200#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
201#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
202
203#define AUDIO_BINTERVAL_TIME 0x01
204
205
206#define USBD_AUDIO_CONFIG_DESC_SIZE ( 0x12 + AUDIO_INTERFACE_LEN + \
207 + (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
208 + (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
209 + (9 * AUDIO_SUPPORT_FEEDBACK) \
210 )
211#define SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
212
213#define MCU_ID1 (0x1FFFF7E8)
214#define MCU_ID2 (0x1FFFF7EC)
215#define MCU_ID3 (0x1FFFF7F0)
216
217extern usbd_desc_handler audio_desc_handler;
218
230#ifdef __cplusplus
231}
232#endif
233
234#endif
235
audio_class.h
usb audio class file
audio_conf.h
usb audio config
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:63
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_conf.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid/audio_conf.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_CONF_H
27#define __AUDIO_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
45#define AUDIO_SUPPORT_SPK 1
46#define AUDIO_SUPPORT_MIC 1
47#define AUDIO_SUPPORT_FEEDBACK 1
48
49#define AUDIO_SUPPORT_FREQ_16K 0
50#define AUDIO_SUPPORT_FREQ_48K 1
51
52
53#define AUDIO_SUPPORT_FREQ (AUDIO_SUPPORT_FREQ_16K + \
54 AUDIO_SUPPORT_FREQ_48K \
55 )
56
57#define AUDIO_FREQ_16K 16000
58#define AUDIO_FREQ_48K 48000
59#define AUDIO_BITW_16 16
60
61#define AUDIO_MIC_CHANEL_NUM 2
62#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
63
64#define AUDIO_SPK_CHANEL_NUM 2
65#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
66
67
68#define AUDIO_SUPPORT_MAX_FREQ 48
69#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
70#define AUDIO_DEFAULT_BITW AUDIO_BITW_16
71
83#ifdef __cplusplus
84}
85#endif
86
87#endif
88
89
90


AT32F413 Firmwary Library: audio_hid_class.c Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "audio_hid_class.h"
26#include "audio_hid_desc.h"
27#include "audio_codec.h"
28
42static usb_sts_type class_init_handler(void *udev);
43static usb_sts_type class_clear_handler(void *udev);
44static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
45static usb_sts_type class_ept0_tx_handler(void *udev);
46static usb_sts_type class_ept0_rx_handler(void *udev);
47static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_sof_handler(void *udev);
50static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
51
52static void audio_req_get_cur(void *udev, usb_setup_type *setup);
53static void audio_req_set_cur(void *udev, usb_setup_type *setup);
54static void audio_req_get_min(void *udev, usb_setup_type *setup);
55static void audio_req_get_max(void *udev, usb_setup_type *setup);
56static void audio_req_get_res(void *udev, usb_setup_type *setup);
57static void audio_get_interface(void *udev, usb_setup_type *setup);
58static void audio_set_interface(void *udev, usb_setup_type *setup);
59static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len);
60 usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0};
61
62 usbd_class_handler audio_hid_class_handler =
63{
64 class_init_handler,
65 class_clear_handler,
66 class_setup_handler,
67 class_ept0_tx_handler,
68 class_ept0_rx_handler,
69 class_in_handler,
70 class_out_handler,
71 class_sof_handler,
72 class_event_handler,
73 &audio_hid_struct
74};
75
81static usb_sts_type class_init_handler(void *udev)
82{
83 usb_sts_type status = USB_OK;
84 usbd_core_type *pudev = (usbd_core_type *)udev;
85 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
86 /* enable microphone in endpoint double buffer mode */
87 usbd_ept_dbuffer_enable(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT);
88
89 /* open microphone in endpoint */
90 usbd_ept_open(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT, EPT_ISO_TYPE, AUDIO_MIC_IN_MAXPACKET_SIZE);
91
92 /* enable speaker out endpoint double buffer mode */
93 usbd_ept_dbuffer_enable(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT);
94
95 /* open speaker out endpoint */
96 usbd_ept_open(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, EPT_ISO_TYPE, AUDIO_SPK_OUT_MAXPACKET_SIZE);
97#if AUDIO_SUPPORT_FEEDBACK
98 /* enable speaker feedback endpoint double buffer mode */
99 usbd_ept_dbuffer_enable(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT);
100
101 /* open speaker feedback endpoint */
102 usbd_ept_open(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, EPT_ISO_TYPE, AUDIO_FEEDBACK_MAXPACKET_SIZE);
103#endif
104 /* start receive speaker out data */
105 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
106
107 /*open hid endpoint */
108
109 /* open custom hid in endpoint */
110 usbd_ept_open(pudev, USBD_AUHID_HID_IN_EPT, EPT_INT_TYPE, USBD_AUHID_IN_MAXPACKET_SIZE);
111
112 /* open custom hid out endpoint */
113 usbd_ept_open(pudev, USBD_AUHID_HID_OUT_EPT, EPT_INT_TYPE, USBD_AUHID_OUT_MAXPACKET_SIZE);
114
115 /* set out endpoint to receive status */
116 usbd_ept_recv(pudev, USBD_AUHID_HID_OUT_EPT, paudio_hid->g_rxhid_buff, USBD_AUHID_OUT_MAXPACKET_SIZE);
117
118 return status;
119}
120
126static usb_sts_type class_clear_handler(void *udev)
127{
128 usb_sts_type status = USB_OK;
129 usbd_core_type *pudev = (usbd_core_type *)udev;
130
131 /* close in endpoint */
132 usbd_ept_close(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT);
133
134#if AUDIO_SUPPORT_FEEDBACK
135 /* close in endpoint */
136 usbd_ept_close(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT);
137#endif
138
139 /* close out endpoint */
140 usbd_ept_close(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT);
141
142 /* close custom hid in endpoint */
143 usbd_ept_close(pudev, USBD_AUHID_HID_IN_EPT);
144
145 /* close custom hid out endpoint */
146 usbd_ept_close(pudev, USBD_AUHID_HID_OUT_EPT);
147
148 return status;
149}
150
157 usb_sts_type class_audio_setup_handler(void *udev, usb_setup_type *setup)
158{
159 usb_sts_type status = USB_OK;
160 usbd_core_type *pudev = (usbd_core_type *)udev;
161 uint16_t len;
162
163 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
164 {
165 /* class request */
166 case USB_REQ_TYPE_CLASS:
167 switch(setup->bRequest)
168 {
169 case AUDIO_REQ_GET_CUR:
170 audio_req_get_cur(pudev, setup);
171 break;
172
173 case AUDIO_REQ_SET_CUR:
174 audio_req_set_cur(pudev, setup);
175 break;
176
177 case AUDIO_REQ_GET_MIN:
178 audio_req_get_min(pudev, setup);
179 break;
180
181 case AUDIO_REQ_GET_MAX:
182 audio_req_get_max(pudev, setup);
183 break;
184
185 case AUDIO_REQ_GET_RES:
186 audio_req_get_res(pudev, setup);
187 break;
188
189 default:
190 usbd_ctrl_unsupport(pudev);
191 break;
192 }
193 break;
194 /* standard request */
195 case USB_REQ_TYPE_STANDARD:
196 switch(setup->bRequest)
197 {
198 case USB_STD_REQ_GET_DESCRIPTOR:
199 if((setup->wValue >> 8) == AUDIO_DESCRIPTOR_TYPE)
200 {
201 usbd_desc_t *config = pudev->desc_handler->get_device_configuration();
202 len = MIN(AUDIO_DESCRIPTOR_SIZE, setup->wLength);
203 usbd_ctrl_send(pudev, config->descriptor + 18, len);
204 }
205 else
206 {
207 usbd_ctrl_unsupport(pudev);
208 }
209 break;
210 case USB_STD_REQ_GET_INTERFACE:
211 audio_get_interface(udev, setup);
212 break;
213
214 case USB_STD_REQ_SET_INTERFACE:
215 audio_set_interface(udev, setup);
216 usbd_ctrl_send_status(pudev);
217 break;
218
219 case USB_STD_REQ_CLEAR_FEATURE:
220 break;
221 case USB_STD_REQ_SET_FEATURE:
222 break;
223 default:
224 usbd_ctrl_unsupport(pudev);
225 break;
226 }
227 break;
228
229 default:
230 usbd_ctrl_unsupport(pudev);
231 break;
232 }
233 return status;
234
235}
236
243 usb_sts_type class_hid_setup_handler(void *udev, usb_setup_type *setup)
244{
245 usb_sts_type status = USB_OK;
246 usbd_core_type *pudev = (usbd_core_type *)udev;
247 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
248 uint16_t len;
249 uint8_t *buf;
250
251 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
252 {
253 /* class request */
254 case USB_REQ_TYPE_CLASS:
255 switch(setup->bRequest)
256 {
257 case HID_REQ_SET_PROTOCOL:
258 paudio_hid->hid_protocol = (uint8_t)setup->wValue;
259 break;
260 case HID_REQ_GET_PROTOCOL:
261 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->hid_protocol, 1);
262 break;
263 case HID_REQ_SET_IDLE:
264 paudio_hid->hid_set_idle = (uint8_t)(setup->wValue >> 8);
265 break;
266 case HID_REQ_GET_IDLE:
267 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->hid_set_idle, 1);
268 break;
269 case HID_REQ_SET_REPORT:
270 paudio_hid->hid_state = HID_REQ_SET_REPORT;
271 usbd_ctrl_recv(pudev, paudio_hid->hid_set_report, setup->wLength);
272 break;
273 default:
274 usbd_ctrl_unsupport(pudev);
275 break;
276 }
277 break;
278 /* standard request */
279 case USB_REQ_TYPE_STANDARD:
280 switch(setup->bRequest)
281 {
282 case USB_STD_REQ_GET_DESCRIPTOR:
283 if(setup->wValue >> 8 == HID_REPORT_DESC)
284 {
285 len = MIN(USBD_AUHID_HID_SIZ_REPORT_DESC, setup->wLength);
286 buf = (uint8_t *)g_usbd_audio_hid_report;
287 }
288 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
289 {
290 len = MIN(9, setup->wLength);
291 buf = (uint8_t *)g_audio_hid_usb_desc;
292 }
293 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
294 break;
295 case USB_STD_REQ_GET_INTERFACE:
296 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->alt_setting, 1);
297 break;
298 case USB_STD_REQ_SET_INTERFACE:
299 paudio_hid->alt_setting = setup->wValue;
300 break;
301 case USB_STD_REQ_CLEAR_FEATURE:
302 break;
303 case USB_STD_REQ_SET_FEATURE:
304 break;
305 default:
306 usbd_ctrl_unsupport(pudev);
307 break;
308 }
309 break;
310 default:
311 usbd_ctrl_unsupport(pudev);
312 break;
313 }
314 return status;
315}
322 usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
323{
324 usb_sts_type status = USB_OK;
325 usbd_core_type *pudev = (usbd_core_type *)udev;
326 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
327 {
328 case USB_REQ_RECIPIENT_INTERFACE:
329 if(setup->wIndex == HID_INTERFACE_NUMBER)
330 {
331 class_hid_setup_handler(udev, setup);
332 }
333 else
334 {
335 class_audio_setup_handler(pudev, setup);
336 }
337 break;
338 case USB_REQ_RECIPIENT_ENDPOINT:
339 class_audio_setup_handler(pudev, setup);
340 break;
341
342 }
343 return status;
344
345
346}
347
353 usb_sts_type class_ept0_tx_handler(void *udev)
354{
355 usb_sts_type status = USB_OK;
356
357 /* ...user code... */
358
359 return status;
360}
361
367static usb_sts_type class_ept0_rx_handler(void *udev)
368{
369 usb_sts_type status = USB_OK;
370 usbd_core_type *pudev = (usbd_core_type *)udev;
371 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
372 usb_setup_type *setup = &pudev->setup;
373 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
374
375 /* ...user code... */
376 if(setup->wIndex == HID_INTERFACE_NUMBER)
377 {
378 if( paudio_hid->hid_state == HID_REQ_SET_REPORT)
379 {
380 /* hid buffer process */
381 usb_hid_buf_process(udev, paudio_hid->hid_set_report, recv_len);
382 paudio_hid->hid_state = 0;
383 }
384 }
385 else
386 {
387 /* ...user code... */
388 if( paudio_hid->audio_cmd == AUDIO_REQ_SET_CUR)
389 {
390 /* class process */
391 switch(paudio_hid->request_no)
392 {
393 case AUDIO_VOLUME_CONTROL:
394 if(paudio_hid->interface == AUDIO_SPK_FEATURE_UNIT_ID)
395 {
396 paudio_hid->spk_volume = (uint16_t)(paudio_hid->g_audio_cur[0] |
397 (paudio_hid->g_audio_cur[1] << 8));
398 /* set volume */
399 audio_codec_set_spk_volume(paudio_hid->spk_volume*100/paudio_hid->spk_volume_limits[1]);
400 }
401 else
402 {
403 paudio_hid->mic_volume = (uint16_t)(paudio_hid->g_audio_cur[0] |
404 (paudio_hid->g_audio_cur[1] << 8));
405
406 audio_codec_set_mic_volume(paudio_hid->mic_volume*256/paudio_hid->mic_volume_limits[1]);
407 }
408 break;
409 case AUDIO_MUTE_CONTROL:
410 if(paudio_hid->interface == AUDIO_SPK_FEATURE_UNIT_ID)
411 {
412 paudio_hid->spk_mute = paudio_hid->g_audio_cur[0];
413 audio_codec_set_spk_mute(paudio_hid->spk_mute);
414 }
415 else
416 {
417 paudio_hid->mic_mute = paudio_hid->g_audio_cur[0];
418 audio_codec_set_mic_mute(paudio_hid->mic_mute);
419 }
420
421 break;
422 case AUDIO_FREQ_SET_CONTROL:
423 if(paudio_hid->enpd == USBD_AUHID_AUDIO_MIC_IN_EPT)
424 {
425 paudio_hid->mic_freq = (paudio_hid->g_audio_cur[0] |
426 (paudio_hid->g_audio_cur[1] << 8) |
427 (paudio_hid->g_audio_cur[2] << 16));
428 audio_codec_set_mic_freq(paudio_hid->mic_freq);
429 }
430 else
431 {
432 paudio_hid->spk_freq = (paudio_hid->g_audio_cur[0] |
433 (paudio_hid->g_audio_cur[1] << 8) |
434 (paudio_hid->g_audio_cur[2] << 16));
435 audio_codec_set_spk_freq(paudio_hid->spk_freq);
436 }
437 break;
438 default:
439 break;
440 }
441 }
442 }
443
444 return status;
445}
446
453 usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
454{
455 usb_sts_type status = USB_OK;
456 usbd_core_type *pudev = (usbd_core_type *)udev;
457 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
458 uint32_t len = 0;
459
460 /* ...user code...
461 trans next packet data
462 */
463 if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_MIC_IN_EPT & 0x7F))
464 {
465 len = audio_codec_mic_get_data(paudio_hid->audio_mic_data);
466 usbd_ept_send(udev, USBD_AUHID_AUDIO_MIC_IN_EPT, paudio_hid->audio_mic_data, len);
467 }
468#if AUDIO_SUPPORT_FEEDBACK
469 else if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_FEEDBACK_EPT & 0x7F))
470 {
471 len = audio_codec_spk_feedback(paudio_hid->audio_feed_back);
472 usbd_ept_send(udev, USBD_AUHID_AUDIO_FEEDBACK_EPT, paudio_hid->audio_feed_back, len);
473 }
474#endif
475 else if((ept_num & 0x7F) == (USBD_AUHID_HID_IN_EPT & 0x7F))
476 {
477
478 }
479
480 return status;
481}
482
489static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
490{
491 usb_sts_type status = USB_OK;
492 usbd_core_type *pudev = (usbd_core_type *)udev;
493 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
494 uint16_t g_rxlen;
495
496 /* get endpoint receive data length */
497 g_rxlen = usbd_get_recv_len(pudev, ept_num);
498
499 if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_SPK_OUT_EPT & 0x7F))
500 {
501 /* speaker data*/
502 audio_codec_spk_fifo_write(paudio_hid->audio_spk_data, g_rxlen);
503
504 /* get next data */
505 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
506 }
507 else if((ept_num & 0x7F) == (USBD_AUHID_HID_OUT_EPT & 0x7F))
508 {
509 /* hid buffer process */
510 usb_hid_buf_process(udev, paudio_hid->g_rxhid_buff, g_rxlen);
511
512 /* start receive next packet */
513 usbd_ept_recv(pudev, USBD_AUHID_HID_OUT_EPT, paudio_hid->g_rxhid_buff, USBD_AUHID_OUT_MAXPACKET_SIZE);
514 }
515 return status;
516}
517
523static usb_sts_type class_sof_handler(void *udev)
524{
525 usb_sts_type status = USB_OK;
526
527 /* ...user code... */
528
529 return status;
530}
531
538static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
539{
540 usb_sts_type status = USB_OK;
541 usbd_core_type *pudev = (usbd_core_type *)udev;
542 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
543 switch(event)
544 {
545 case USBD_RESET_EVENT:
546
547 /* ...user code... */
548
549 break;
550 case USBD_SUSPEND_EVENT:
551 paudio_hid->spk_alt_setting = 0;
552 audio_codec_spk_alt_setting(paudio_hid->spk_alt_setting);
553 paudio_hid->mic_alt_setting = 0;
554 audio_codec_mic_alt_setting(paudio_hid->spk_alt_setting);
555 /* ...user code... */
556
557 break;
558 case USBD_WAKEUP_EVENT:
559 /* ...user code... */
560
561 break;
562 default:
563 break;
564 }
565 return status;
566}
567
574static void audio_req_get_cur(void *udev, usb_setup_type *setup)
575{
576 usbd_core_type *pudev = (usbd_core_type *)udev;
577 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
578 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
579 {
580 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
581 {
582 paudio_hid->g_audio_cur[0] = paudio_hid->spk_mute;
583 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
584 }
585 else
586 {
587 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume;
588 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
589 }
590 }
591 else
592 {
593 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
594 {
595 paudio_hid->g_audio_cur[0] = paudio_hid->mic_mute;
596 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
597 }
598 else
599 {
600 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume;
601 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
602 }
603
604 }
605}
606
613static void audio_req_set_cur(void *udev, usb_setup_type *setup)
614{
615 usbd_core_type *pudev = (usbd_core_type *)udev;
616 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
617 if(setup->wLength > 0)
618 {
619 usbd_ctrl_recv(pudev, paudio_hid->g_audio_cur, setup->wLength);
620
621 paudio_hid->audio_cmd = AUDIO_REQ_SET_CUR;
622 paudio_hid->audio_cmd_len = setup->wLength;
623
624 switch(setup->bmRequestType & AUDIO_REQ_CONTROL_MASK)
625 {
626 case AUDIO_REQ_CONTROL_INTERFACE:
627 paudio_hid->interface = HBYTE(setup->wIndex);
628 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
629 {
630 paudio_hid->request_no = AUDIO_MUTE_CONTROL;
631 }
632 else
633 {
634 paudio_hid->request_no = AUDIO_VOLUME_CONTROL;
635 }
636 break;
637 case AUDIO_REQ_CONTROL_ENDPOINT:
638 paudio_hid->enpd = setup->wIndex;
639 paudio_hid->request_no = AUDIO_FREQ_SET_CONTROL;
640 break;
641 default:
642 break;
643 }
644 }
645}
646
653static void audio_req_get_min(void *udev, usb_setup_type *setup)
654{
655 usbd_core_type *pudev = (usbd_core_type *)udev;
656 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
657 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
658 {
659 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[0];
660 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
661 }
662 else
663 {
664 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[0];
665 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
666 }
667}
668
675static void audio_req_get_max(void *udev, usb_setup_type *setup)
676{
677 usbd_core_type *pudev = (usbd_core_type *)udev;
678 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
679 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
680 {
681 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[1];
682 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
683 }
684 else
685 {
686 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[1];
687 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
688 }
689}
690
697static void audio_req_get_res(void *udev, usb_setup_type *setup)
698{
699 usbd_core_type *pudev = (usbd_core_type *)udev;
700 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
701 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
702 {
703 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[2];
704 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
705 }
706 else
707 {
708 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[2];
709 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
710 }
711}
712
719static void audio_set_interface(void *udev, usb_setup_type *setup)
720{
721 uint32_t len;
722 usbd_core_type *pudev = (usbd_core_type *)udev;
723 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
724 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
725 {
726 paudio_hid->spk_alt_setting = setup->wValue;
727 audio_codec_spk_alt_setting(paudio_hid->spk_alt_setting);
728 if(paudio_hid->spk_alt_setting )
729 {
730 int len = audio_codec_spk_feedback(paudio_hid->audio_feed_back);
731 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
732 usbd_ept_send(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, paudio_hid->audio_feed_back, len);
733 }
734
735 }
736 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
737 {
738 paudio_hid->mic_alt_setting = setup->wValue;
739 audio_codec_mic_alt_setting(paudio_hid->mic_alt_setting);
740 if(paudio_hid->mic_alt_setting)
741 {
742 len = audio_codec_mic_get_data(paudio_hid->audio_mic_data);
743 usbd_ept_send(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT, paudio_hid->audio_mic_data, len);
744 }
745 }
746
747}
748
749
756static void audio_get_interface(void *udev, usb_setup_type *setup)
757{
758 usbd_core_type *pudev = (usbd_core_type *)udev;
759 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
760 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
761 {
762 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->spk_alt_setting, 1);
763 }
764 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
765 {
766 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->mic_alt_setting, 1);
767 }
768
769}
770
778 usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
779{
780 usb_sts_type status = USB_OK;
781 usbd_core_type *pudev = (usbd_core_type *)udev;
782
783 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
784 usbd_ept_send(pudev, USBD_AUHID_HID_IN_EPT, report, len);
785
786 return status;
787}
788
789
797static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
798{
799 uint32_t i_index;
800 usbd_core_type *pudev = (usbd_core_type *)udev;
801 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
802
803 switch(report[0])
804 {
805 case HID_REPORT_ID_2:
806 if(paudio_hid->g_rxhid_buff[1] == 0)
807 {
808 at32_led_off(LED2);
809 }
810 else
811 {
812 at32_led_on(LED2);
813 }
814 break;
815 case HID_REPORT_ID_3:
816 if(paudio_hid->g_rxhid_buff[1] == 0)
817 {
818 at32_led_off(LED3);
819 }
820 else
821 {
822 at32_led_on(LED3);
823 }
824 break;
825 case HID_REPORT_ID_4:
826 if(paudio_hid->g_rxhid_buff[1] == 0)
827 {
828 at32_led_off(LED4);
829 }
830 else
831 {
832 at32_led_on(LED4);
833 }
834 break;
835 case HID_REPORT_ID_6:
836 for(i_index = 0; i_index < len; i_index ++)
837 {
838 paudio_hid->g_txhid_buff[i_index] = report[i_index];
839 }
840 usbd_ept_send(pudev, USBD_AUHID_HID_IN_EPT, paudio_hid->g_txhid_buff, len);
841 break;
842 default:
843 break;
844 }
845
846}
847
848
audio_hid_class.h
audio_hid_desc.h
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
AUDIO_DESCRIPTOR_TYPE
#define AUDIO_DESCRIPTOR_TYPE
audio descriptor type
Definition: audio_class.h:81
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:60
AUDIO_MUTE_CONTROL
#define AUDIO_MUTE_CONTROL
audio set cur type define
Definition: audio_class.h:74
AUDIO_REQ_CONTROL_INTERFACE
#define AUDIO_REQ_CONTROL_INTERFACE
request type define
Definition: audio_class.h:67
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:61
AUDIO_VOLUME_CONTROL
#define AUDIO_VOLUME_CONTROL
Definition: audio_class.h:75
AUDIO_FREQ_SET_CONTROL
#define AUDIO_FREQ_SET_CONTROL
Definition: audio_class.h:76
AUDIO_REQ_CONTROL_ENDPOINT
#define AUDIO_REQ_CONTROL_ENDPOINT
Definition: audio_class.h:68
AUDIO_REQ_CONTROL_MASK
#define AUDIO_REQ_CONTROL_MASK
Definition: audio_class.h:69
AUDIO_DESCRIPTOR_SIZE
#define AUDIO_DESCRIPTOR_SIZE
Definition: audio_class.h:82
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_REQ_GET_CUR
#define AUDIO_REQ_GET_CUR
Definition: audio_desc.h:111
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:178
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:176
AUDIO_REQ_GET_MAX
#define AUDIO_REQ_GET_MAX
Definition: audio_desc.h:115
AUDIO_REQ_GET_MIN
#define AUDIO_REQ_GET_MIN
Definition: audio_desc.h:113
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:170
AUDIO_REQ_GET_RES
#define AUDIO_REQ_GET_RES
Definition: audio_desc.h:117
AUDIO_REQ_SET_CUR
#define AUDIO_REQ_SET_CUR
Definition: audio_desc.h:110
USBD_AUHID_AUDIO_MIC_IN_EPT
#define USBD_AUHID_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_hid_class.h:52
USBD_AUHID_HID_IN_EPT
#define USBD_AUHID_HID_IN_EPT
usb custom hid use endpoint define
Definition: audio_hid_class.h:59
USBD_AUHID_HID_OUT_EPT
#define USBD_AUHID_HID_OUT_EPT
Definition: audio_hid_class.h:60
USBD_AUHID_AUDIO_FEEDBACK_EPT
#define USBD_AUHID_AUDIO_FEEDBACK_EPT
Definition: audio_hid_class.h:54
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:66
USBD_AUHID_AUDIO_SPK_OUT_EPT
#define USBD_AUHID_AUDIO_SPK_OUT_EPT
Definition: audio_hid_class.h:53
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:65
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_hid_class.c:523
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:778
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_hid_class.c:126
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:62
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_hid_class.c:367
audio_req_get_res
static void audio_req_get_res(void *udev, usb_setup_type *setup)
usb audio request get res
Definition: audio_hid_class.c:697
audio_get_interface
static void audio_get_interface(void *udev, usb_setup_type *setup)
usb audio get interface
Definition: audio_hid_class.c:756
class_hid_setup_handler
usb_sts_type class_hid_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:243
audio_req_set_cur
static void audio_req_set_cur(void *udev, usb_setup_type *setup)
usb audio request set cur
Definition: audio_hid_class.c:613
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_hid_class.c:538
audio_req_get_max
static void audio_req_get_max(void *udev, usb_setup_type *setup)
usb audio request get max
Definition: audio_hid_class.c:675
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:322
usb_hid_buf_process
static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
usb device report function
Definition: audio_hid_class.c:797
audio_req_get_min
static void audio_req_get_min(void *udev, usb_setup_type *setup)
usb audio request get min
Definition: audio_hid_class.c:653
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_hid_class.c:81
audio_hid_struct
usb_audio_hid_type audio_hid_struct
Definition: audio_hid_class.c:60
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_hid_class.c:353
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_hid_class.c:489
audio_req_get_cur
static void audio_req_get_cur(void *udev, usb_setup_type *setup)
usb audio request get cur
Definition: audio_hid_class.c:574
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_hid_class.c:453
audio_set_interface
static void audio_set_interface(void *udev, usb_setup_type *setup)
usb audio set interface
Definition: audio_hid_class.c:719
class_audio_setup_handler
usb_sts_type class_audio_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:157
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:234
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:221
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:223
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:225
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:222
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:530
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:432
HID_INTERFACE_NUMBER
#define HID_INTERFACE_NUMBER
Definition: audio_hid_desc.h:181
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:167
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:215
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:193
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:119
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:280
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:182
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:242
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:226
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:204
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:152
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:135
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:202
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:234
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:229
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:228
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:235
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:230
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:231
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:232
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:56
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:54
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:53
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:404
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:209
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
usb_audio_hid_type
usb audio control struct
Definition: audio_hid_class.h:111
usb_audio_hid_type::spk_volume_limits
uint16_t spk_volume_limits[3]
Definition: audio_hid_class.h:121
usb_audio_hid_type::audio_cmd
uint8_t audio_cmd
Definition: audio_hid_class.h:124
usb_audio_hid_type::request_no
uint8_t request_no
Definition: audio_hid_class.h:114
usb_audio_hid_type::g_txhid_buff
uint8_t g_txhid_buff[0x40]
Definition: audio_hid_class.h:140
usb_audio_hid_type::mic_freq
uint32_t mic_freq
Definition: audio_hid_class.h:120
usb_audio_hid_type::interface
uint8_t interface
Definition: audio_hid_class.h:113
usb_audio_hid_type::audio_spk_data
uint8_t audio_spk_data[(48 *2 *(16/8)+40)]
Definition: audio_hid_class.h:129
usb_audio_hid_type::spk_volume
uint16_t spk_volume
Definition: audio_hid_class.h:117
usb_audio_hid_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_hid_class.h:127
usb_audio_hid_type::mic_volume
uint16_t mic_volume
Definition: audio_hid_class.h:118
usb_audio_hid_type::alt_setting
uint32_t alt_setting
Definition: audio_hid_class.h:137
usb_audio_hid_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_hid_class.h:126
usb_audio_hid_type::enpd
uint8_t enpd
Definition: audio_hid_class.h:112
usb_audio_hid_type::hid_state
uint8_t hid_state
Definition: audio_hid_class.h:141
usb_audio_hid_type::mic_mute
uint8_t mic_mute
Definition: audio_hid_class.h:116
usb_audio_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: audio_hid_class.h:136
usb_audio_hid_type::mic_volume_limits
uint16_t mic_volume_limits[3]
Definition: audio_hid_class.h:122
usb_audio_hid_type::audio_feed_back
uint8_t audio_feed_back[0x3+1]
Definition: audio_hid_class.h:131
usb_audio_hid_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_hid_class.h:125
usb_audio_hid_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: audio_hid_class.h:139
usb_audio_hid_type::spk_freq
uint32_t spk_freq
Definition: audio_hid_class.h:119
usb_audio_hid_type::audio_mic_data
uint8_t audio_mic_data[(48 *2 *(16/8)+40)]
Definition: audio_hid_class.h:130
usb_audio_hid_type::hid_set_report
uint8_t hid_set_report[64]
Definition: audio_hid_class.h:138
usb_audio_hid_type::g_audio_cur
uint8_t g_audio_cur[64]
Definition: audio_hid_class.h:128
usb_audio_hid_type::hid_protocol
uint32_t hid_protocol
Definition: audio_hid_class.h:135
usb_audio_hid_type::spk_mute
uint8_t spk_mute
Definition: audio_hid_class.h:115
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:294
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:117
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:112
usbd_desc_handler::get_device_configuration
usbd_desc_t *(* get_device_configuration)(void)
Definition: usbd_core.h:77
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_hid_class.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_HID_CLASS_H
27#define __AUDIO_HID_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35#include "audio_conf.h"
36
52#define USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
53#define USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
54#define USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
55
59#define USBD_AUHID_HID_IN_EPT 0x84
60#define USBD_AUHID_HID_OUT_EPT 0x05
61
65#define USBD_AUHID_IN_MAXPACKET_SIZE 0x40
66#define USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
67
71#define AUDIO_REMAIN_SIZE 40
72#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
73#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
74#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
75#define FEEDBACK_REFRESH_TIME 0x8
79#define AUDIO_REQ_CONTROL_INTERFACE 0x01
80#define AUDIO_REQ_CONTROL_ENDPOINT 0x02
81#define AUDIO_REQ_CONTROL_MASK 0x03
82
86#define AUDIO_MUTE_CONTROL 0x01
87#define AUDIO_VOLUME_CONTROL 0x02
88#define AUDIO_FREQ_SET_CONTROL 0x03
89
97#define AUDIO_MUTE_CONTROL 0x01
98#define AUDIO_VOLUME_CONTROL 0x02
99#define AUDIO_FREQ_SET_CONTROL 0x03
100
104#define AUDIO_DESCRIPTOR_TYPE 0x21
105#define AUDIO_DESCRIPTOR_SIZE 0x09
106
110typedef struct
111{
112 uint8_t enpd;
113 uint8_t interface;
114 uint8_t request_no;
115 uint8_t spk_mute;
116 uint8_t mic_mute;
117 uint16_t spk_volume;
118 uint16_t mic_volume;
119 uint32_t spk_freq;
120 uint32_t mic_freq;
121 uint16_t spk_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
122 uint16_t mic_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
123
124 uint8_t audio_cmd;
125 uint32_t audio_cmd_len;
126 uint32_t spk_alt_setting;
127 uint32_t mic_alt_setting;
128 uint8_t g_audio_cur[64];
129 uint8_t audio_spk_data[AUDIO_SPK_OUT_MAXPACKET_SIZE];
130 uint8_t audio_mic_data[AUDIO_MIC_IN_MAXPACKET_SIZE];
131 uint8_t audio_feed_back[AUDIO_FEEDBACK_MAXPACKET_SIZE+1];
132
133
134 /* hid */
135 uint32_t hid_protocol;
136 uint32_t hid_set_idle;
137 uint32_t alt_setting;
138 uint8_t hid_set_report[64];
139 uint8_t g_rxhid_buff[USBD_AUHID_OUT_MAXPACKET_SIZE];
140 uint8_t g_txhid_buff[USBD_AUHID_IN_MAXPACKET_SIZE];
141 uint8_t hid_state;
142}usb_audio_hid_type;
143
144extern usbd_class_handler audio_hid_class_handler;
145
146 usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len);
147
160#ifdef __cplusplus
161}
162#endif
163
164#endif
165
audio_conf.h
usb audio config
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:778
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_hid_class.h:72
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:62
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:73
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:66
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:65
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_hid_class.h:74
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
usb_audio_hid_type
usb audio control struct
Definition: audio_hid_class.h:111
usb_audio_hid_type::audio_cmd
uint8_t audio_cmd
Definition: audio_hid_class.h:124
usb_audio_hid_type::request_no
uint8_t request_no
Definition: audio_hid_class.h:114
usb_audio_hid_type::mic_freq
uint32_t mic_freq
Definition: audio_hid_class.h:120
usb_audio_hid_type::interface
uint8_t interface
Definition: audio_hid_class.h:113
usb_audio_hid_type::spk_volume
uint16_t spk_volume
Definition: audio_hid_class.h:117
usb_audio_hid_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_hid_class.h:127
usb_audio_hid_type::mic_volume
uint16_t mic_volume
Definition: audio_hid_class.h:118
usb_audio_hid_type::alt_setting
uint32_t alt_setting
Definition: audio_hid_class.h:137
usb_audio_hid_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_hid_class.h:126
usb_audio_hid_type::enpd
uint8_t enpd
Definition: audio_hid_class.h:112
usb_audio_hid_type::hid_state
uint8_t hid_state
Definition: audio_hid_class.h:141
usb_audio_hid_type::mic_mute
uint8_t mic_mute
Definition: audio_hid_class.h:116
usb_audio_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: audio_hid_class.h:136
usb_audio_hid_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_hid_class.h:125
usb_audio_hid_type::spk_freq
uint32_t spk_freq
Definition: audio_hid_class.h:119
usb_audio_hid_type::hid_protocol
uint32_t hid_protocol
Definition: audio_hid_class.h:135
usb_audio_hid_type::spk_mute
uint8_t spk_mute
Definition: audio_hid_class.h:115
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_hid_desc.c Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "audio_hid_desc.h"
28
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57#if defined ( __ICCARM__ ) /* iar compiler */
58 #pragma data_alignment=4
59#endif
60ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
61
65 usbd_desc_handler audio_hid_desc_handler =
66{
67 get_device_descriptor,
68 get_device_qualifier,
69 get_device_configuration,
70 get_device_other_speed,
71 get_device_lang_id,
72 get_device_manufacturer_string,
73 get_device_product_string,
74 get_device_serial_string,
75 get_device_interface_string,
76 get_device_config_string,
77};
78
82#if defined ( __ICCARM__ ) /* iar compiler */
83 #pragma data_alignment=4
84#endif
85ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
86{
87 USB_DEVICE_DESC_LEN, /* bLength */
88 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
89 0x00, /* bcdUSB */
90 0x02,
91 0x00, /* bDeviceClass */
92 0x00, /* bDeviceSubClass */
93 0x00, /* bDeviceProtocol */
94 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
95 LBYTE(USBD_AUHID_VENDOR_ID), /* idVendor */
96 HBYTE(USBD_AUHID_VENDOR_ID), /* idVendor */
97 LBYTE(USBD_AUHID_PRODUCT_ID), /* idProduct */
98 HBYTE(USBD_AUHID_PRODUCT_ID), /* idProduct */
99 0x00, /* bcdDevice rel. 2.00 */
100 0x02,
101 USB_MFC_STRING, /* Index of manufacturer string */
102 USB_PRODUCT_STRING, /* Index of product string */
103 USB_SERIAL_STRING, /* Index of serial number string */
104 0x01 /* bNumConfigurations */
105};
106
110#if defined ( __ICCARM__ ) /* iar compiler */
111 #pragma data_alignment=4
112#endif
113ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_AUHID_CONFIG_DESC_SIZE] ALIGNED_TAIL =
114{
115 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
116 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
117 LBYTE(USBD_AUHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 HBYTE(USBD_AUHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 0x1 + AUDIO_INTERFACE_NUM + 0x1, /* bNumInterfaces: n interface */
120 0x01, /* bConfigurationValue: configuration value */
121 0x00, /* iConfiguration: index of string descriptor describing
122 the configuration */
123 0xC0, /* bmAttributes: self powered */
124 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
125
126 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
127 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
128 0x00, /* bInterfaceNumber: number of interface */
129 0x00, /* bAlternateSetting: alternate set */
130 0x00, /* bNumEndpoints: number of endpoints */
131 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio class code */
132 AUDIO_SUBCLASS_AUDIOCONTROL, /* bInterfaceSubClass: audio control */
133 AUDIO_PROTOCOL_UNDEFINED, /* bInterfaceProtocol: undefined */
134 0x00, /* iInterface: index of string descriptor */
135
136 0x08+AUDIO_INTERFACE_NUM, /* bLength: size of this descriptor, in bytes 8+n */
137 AUDIO_CS_INTERFACE, /* bDescriptorType: cs interface descriptor type */
138 AUDIO_AC_HEADER, /* bDescriptorSubtype: Header function Descriptor*/
139 LBYTE(AUHID_BCD_NUM),
140 HBYTE(AUHID_BCD_NUM), /* bcdCDC: audio device class specification release number */
141 LBYTE(AUDIO_INTERFACE_LEN),
142 HBYTE(AUDIO_INTERFACE_LEN), /* wTotalLength: total number of bytes returned for the class-specific audio control interface */
143 AUDIO_INTERFACE_NUM, /* bInClollection: the number of audio streaming */
144#if (AUDIO_INTERFACE_NUM == 2) /* two interface */
145 0x02,
146 0x01,
147#else
148 0x01,
149#endif
150
151 /* usb microphone config */
152#if (AUDIO_SUPPORT_MIC == 1)
153 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
154 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
155 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
156 AUDIO_MIC_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
157 LBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),
158 HBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),/* wTerminalType: terminal is microphone */
159 0x00, /* bAssocTerminal: no association */
160 AUDIO_MIC_CHR, /* bNrChannels: two channel */
161#if (AUDIO_MIC_CHR == 2)
162 0x03, /* wChannelConfig: left front and right front */
163#endif
164#if (AUDIO_MIC_CHR == 1)
165 0x00, /* wChannelConfig */
166#endif
167 0x00, /* wChannelConfig */
168 0x00, /* iChannelNames: unused */
169 0x00, /* iTerminal: unused */
170
171 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
172 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
173 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
174 AUDIO_MIC_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
175 AUDIO_MIC_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
176 0x02, /* bControlSize: 2 byte */
177 0x03, /* bmaControls0: mute & volume*/
178 0x00,
179 0x00, /* bmaControls1 */
180 0x00,
181 0x00, /* bmaControls2 */
182 0x00,
183 0x00, /* iFeature: unused */
184
185 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
186 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
187 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
188 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
189 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING),
190 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
191 0x00, /* bAssocTerminal: unused */
192 AUDIO_MIC_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
193 0x00, /* iTerminal: unused */
194#endif
195
196#if (AUDIO_SUPPORT_SPK == 1)
197 /* speaker config */
198 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
199 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
200 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
201 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
202 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
203 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
204 0x00, /* bAssocTerminal: no association */
205 AUDIO_SPK_CHR, /* bNrChannels: two channel */
206#if (AUDIO_SPK_CHR == 2)
207 0x03, /* wChannelConfig: left front and right front */
208#endif
209#if (AUDIO_SPK_CHR == 1)
210 0x00, /* wChannelConfig */
211#endif
212 0x00, /* wChannelConfig */
213 0x00, /* iChannelNames: unused */
214 0x00, /* iTerminal: unused */
215
216 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
217 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
218 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
219 AUDIO_SPK_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
220 AUDIO_SPK_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
221 0x02, /* bControlSize: 2 byte */
222 0x03, /* bmaControls0: mute & volume*/
223 0x00,
224 0x00, /* bmaControls1: 0x0000 */
225 0x00,
226 0x00, /* bmaControls2: 0x0000 */
227 0x00,
228 0x00, /* iFeature: unused */
229
230 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
231 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
232 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
233 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
234 LBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
235 HBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
236 0x00, /* bAssocTerminal: unused */
237 AUDIO_SPK_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
238 0x00, /* iTerminal: unused */
239#endif
240
241#if (AUDIO_SUPPORT_MIC == 1)
242 /* microphone interface */
243 0x09, /* bLength: descriptor size */
244 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
245 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
246 0x00, /* bAlternateSetting: index of this setting */
247 0x00, /* bNumEndpoints: 0 endpoints */
248 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
249 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
250 0x00, /* bInterfaceProtocol: unused */
251 0x00, /* iInterface: unused */
252
253 0x09, /* bLength: descriptor size */
254 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
255 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
256 0x01, /* bAlternateSetting: index of this setting */
257 0x01, /* bNumEndpoints: 1 endpoints */
258 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
259 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
260 0x00, /* bInterfaceProtocol: unused */
261 0x00, /* iInterface: unused */
262
263 0x07, /* bLength: configuration descriptor size */
264 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
265 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
266 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalLink: unit id of the output terminal */
267 0x01, /* bDelay: interface delay */
268 0x01, /* wFormatTag: pcm format*/
269 0x00, /* wFormatTag: pcm format*/
270
271 0x08 + AUDIO_MIC_FREQ_SIZE * 3, /* bLength: descriptor size */
272 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
273 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
274 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
275 AUDIO_MIC_CHR, /* bNrChannels: channel number */
276 AUDIO_MIC_BITW / 8, /* bSubFrameSize: per audio subframe */
277 AUDIO_MIC_BITW, /* bBitResolution: n bits per sample */
278 AUDIO_MIC_FREQ_SIZE, /* bSamFreqType: n frequency supported */
279#if (AUDIO_SUPPORT_FREQ_16K == 1)
280 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
281#endif
282#if (AUDIO_SUPPORT_FREQ_48K == 1)
283 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
284#endif
285
286 0x09, /* bLength: size of endpoint descriptor in bytes */
287 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
288 USBD_AUHID_AUDIO_MIC_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
289 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
290 LBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE),
291 HBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
292 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
293 0x00, /* bRefresh: unused */
294 0x00, /* bSynchAddress: unused */
295
296 0x07, /* bLength: size of endpoint descriptor in bytes */
297 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
298 0x01, /* bDescriptorSubtype: general subtype */
299 0x01, /* bmAttributes */
300 0x00, /* bLockDelayUnits: unused */
301 0x00, /* wLockDelay: unused */
302 0x00, /* wLockDelay: unused */
303#endif
304
305#if (AUDIO_SUPPORT_SPK == 1)
306 /* speaker interface */
307 0x09, /* bLength: descriptor size */
308 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
309 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
310 0x00, /* bAlternateSetting: index of this setting */
311 0x00, /* bNumEndpoints: 0 endpoints */
312 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
313 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
314 0x00, /* bInterfaceProtocol: unused */
315 0x00, /* iInterface: unused */
316
317 0x09, /* bLength: descriptor size */
318 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
319 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
320 0x01, /* bAlternateSetting: index of this setting */
321 0x01 + AUDIO_SUPPORT_FEEDBACK, /* bNumEndpoints: endpoints */
322 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
323 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
324 0x00, /* bInterfaceProtocol: unused */
325 0x00, /* iInterface: unused */
326
327 0x07, /* bLength: configuration descriptor size */
328 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
329 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
330 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalLink: unit id of the input terminal */
331 0x01, /* bDelay: interface delay */
332 0x01, /* wFormatTag: pcm format*/
333 0x00, /* wFormatTag: pcm format*/
334
335 0x08 + AUDIO_SPK_FREQ_SIZE * 3, /* bLength: descriptor size */
336 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
337 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
338 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
339 AUDIO_SPK_CHR, /* bNrChannels: channel number */
340 AUDIO_SPK_BITW / 8, /* bSubFrameSize: per audio subframe */
341 AUDIO_SPK_BITW, /* bBitResolution: n bits per sample */
342 AUDIO_SPK_FREQ_SIZE, /* bSamFreqType: n frequency supported */
343#if (AUDIO_SUPPORT_FREQ_16K == 1)
344 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
345#endif
346#if (AUDIO_SUPPORT_FREQ_48K == 1)
347 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
348#endif
349
350 0x09, /* bLength: size of endpoint descriptor in bytes */
351 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
352 USBD_AUHID_AUDIO_SPK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
353 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
354 LBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE),
355 HBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
356 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
357 0x00, /* bRefresh: unused */
358#if (AUDIO_SUPPORT_FEEDBACK == 1)
359 USBD_AUHID_AUDIO_FEEDBACK_EPT, /* bSynchAddress: feedback endpoint */
360#else
361 0x00, /* bSynchAddress: unused */
362#endif
363
364 0x07, /* bLength: size of endpoint descriptor in bytes */
365 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
366 0x01, /* bDescriptorSubtype: general subtype */
367 0x01, /* bmAttributes */
368 0x00, /* bLockDelayUnits: unused */
369 0x00, /* wLockDelay: unused */
370 0x00, /* wLockDelay: unused */
371
372#if (AUDIO_SUPPORT_FEEDBACK == 1)
373 0x09, /* bLength: size of endpoint descriptor in bytes */
374 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
375 USBD_AUHID_AUDIO_FEEDBACK_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
376 0x11, /* bmAttributes: endpoint attributes */
377 LBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
378 HBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
379 1, /* bInterval: interval for polling endpoint for data transfers */
380 FEEDBACK_REFRESH_TIME, /* bRefresh: this field indicates the rate at which an iso syncronization
381 pipe provides new syncronization feedback data. this rate must be a power of
382 2, therefore only the power is reported back and the range of this field is from
383 1(2ms) to 9(512ms) */
384 0x00, /* bSynchAddress: 0x00*/
385#endif
386
387#endif
388
389 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
390 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
391 HID_INTERFACE_NUMBER, /* bInterfaceNumber: number of interface */
392 0x00, /* bAlternateSetting: alternate set */
393 0x02, /* bNumEndpoints: number of endpoints */
394 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
395 0x00, /* bInterfaceSubClass: subclass code */
396 0x00, /* bInterfaceProtocol: protocol code */
397 0x00, /* iInterface: index of string descriptor */
398
399 0x09, /* bLength: size of HID descriptor in bytes */
400 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
401 LBYTE(AUHID_HID_BCD_NUM),
402 HBYTE(AUHID_HID_BCD_NUM), /* bcdHID: HID class specification release number */
403 0x00, /* bCountryCode: hardware target conutry */
404 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
405 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
406 LBYTE(sizeof(g_usbd_audio_hid_report)),
407 HBYTE(sizeof(g_usbd_audio_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
408
409 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
410 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
411 USBD_AUHID_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
412 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
413 LBYTE(USBD_AUHID_IN_MAXPACKET_SIZE),
414 HBYTE(USBD_AUHID_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
415 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
416
417 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
418 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
419 USBD_AUHID_HID_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
420 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
421 LBYTE(USBD_AUHID_OUT_MAXPACKET_SIZE),
422 HBYTE(USBD_AUHID_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
423 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
424};
425
429#if defined ( __ICCARM__ ) /* iar compiler */
430 #pragma data_alignment=4
431#endif
432ALIGNED_HEAD uint8_t g_usbd_audio_hid_report[USBD_AUHID_HID_SIZ_REPORT_DESC] ALIGNED_TAIL =
433{
434 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
435 0x09, 0x01, /* USAGE (Demo Kit) */
436 0xa1, 0x01, /* COLLECTION (Application) */
437 /* 7 */
438
439 /* Led 2 */
440 0x85, HID_REPORT_ID_2, /* REPORT_ID 2 */
441 0x09, 0x02, /* USAGE (LED 2) */
442 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
443 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
444 0x75, 0x08, /* REPORT_SIZE (8) */
445 0x95, 0x3F, /* REPORT_COUNT (1) */
446 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
447
448 0x85, 0x02, /* REPORT_ID (2) */
449 0x09, 0x02, /* USAGE (LED 2) */
450 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
451 /* 27 */
452
453 /* Led 3 */
454 0x85, HID_REPORT_ID_3, /* REPORT_ID (3) */
455 0x09, 0x03, /* USAGE (LED 3) */
456 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
457 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
458 0x75, 0x08, /* REPORT_SIZE (8) */
459 0x95, 0x3F, /* REPORT_COUNT (1) */
460 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
461
462 0x85, 0x03, /* REPORT_ID (3) */
463 0x09, 0x03, /* USAGE (LED 3) */
464 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
465 /* 47 */
466
467 /* Led 4 */
468 0x85, HID_REPORT_ID_4, /* REPORT_ID 4) */
469 0x09, 0x04, /* USAGE (LED 4) */
470 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
471 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
472 0x75, 0x08, /* REPORT_SIZE (8) */
473 0x95, 0x3F, /* REPORT_COUNT (1) */
474 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
475
476 0x85, 0x04, /* REPORT_ID (4) */
477 0x09, 0x04, /* USAGE (LED 4) */
478 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
479 /* 67 */
480
481 /* key Push Button */
482 0x85, HID_REPORT_ID_5, /* REPORT_ID (5) */
483 0x09, 0x05, /* USAGE (Push Button) */
484 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
485 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
486 0x75, 0x01, /* REPORT_SIZE (1) */
487 0x81, 0x82, /* INPUT (Data,Var,Abs,Vol) */
488
489 0x09, 0x05, /* USAGE (Push Button) */
490 0x75, 0x01, /* REPORT_SIZE (1) */
491 0xb1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
492
493 0x75, 0x07, /* REPORT_SIZE (7) */
494 0x81, 0x83, /* INPUT (Cnst,Var,Abs,Vol) */
495 0x85, 0x05, /* REPORT_ID (5) */
496
497 0x75, 0x07, /* REPORT_SIZE (7) */
498 0xb1, 0x83, /* FEATURE (Cnst,Var,Abs,Vol) */
499 /* 95 */
500
501 /* Data OUT */
502 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
503 0x09, 0x06, /* USAGE */
504 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
505 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
506 0x75, 0x08, /* REPORT_SIZE (8) */
507 0x95, 0x3F, /* REPORT_COUNT (64) */
508 0x91, 0x02, /* OUTPUT(Data,Var,Abs,Vol) */
509 /* 110 */
510
511 /* Data IN */
512 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
513 0x09, 0x07, /* USAGE */
514 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
515 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
516 0x75, 0x08, /* REPORT_SIZE (8) */
517 0x95, 0x3F, /* REPORT_COUNT (64) */
518 0x81, 0x82, /* INPUT(Data,Var,Abs,Vol) */
519
520 /* 125 */
521 0xc0 /* END_COLLECTION */
522};
523
527#if defined ( __ICCARM__ ) /* iar compiler */
528 #pragma data_alignment=4
529#endif
530ALIGNED_HEAD uint8_t g_audio_hid_usb_desc[9] ALIGNED_TAIL =
531{
532 0x09, /* bLength: size of HID descriptor in bytes */
533 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
534 LBYTE(AUHID_HID_BCD_NUM),
535 HBYTE(AUHID_HID_BCD_NUM), /* bcdHID: HID class specification release number */
536 0x00, /* bCountryCode: hardware target conutry */
537 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
538 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
539 LBYTE(sizeof(g_usbd_audio_hid_report)),
540 HBYTE(sizeof(g_usbd_audio_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
541};
542
546#if defined ( __ICCARM__ ) /* iar compiler */
547 #pragma data_alignment=4
548#endif
549ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_AUHID_SIZ_STRING_LANGID] ALIGNED_TAIL =
550{
551 USBD_AUHID_SIZ_STRING_LANGID,
552 USB_DESCIPTOR_TYPE_STRING,
553 0x09,
554 0x04,
555};
556
560#if defined ( __ICCARM__ ) /* iar compiler */
561 #pragma data_alignment=4
562#endif
563ALIGNED_HEAD static uint8_t g_string_serial[USBD_AUHID_SIZ_STRING_SERIAL] ALIGNED_TAIL =
564{
565 USBD_AUHID_SIZ_STRING_SERIAL,
566 USB_DESCIPTOR_TYPE_STRING,
567};
568
569
570/* device descriptor */
571static usbd_desc_t device_descriptor =
572{
573 USB_DEVICE_DESC_LEN,
574 g_usbd_descriptor
575};
576
577/* config descriptor */
578static usbd_desc_t config_descriptor =
579{
580 USBD_AUHID_CONFIG_DESC_SIZE,
581 g_usbd_configuration
582};
583
584/* langid descriptor */
585static usbd_desc_t langid_descriptor =
586{
587 USBD_AUHID_SIZ_STRING_LANGID,
588 g_string_lang_id
589};
590
591/* serial descriptor */
592static usbd_desc_t serial_descriptor =
593{
594 USBD_AUHID_SIZ_STRING_SERIAL,
595 g_string_serial
596};
597
598static usbd_desc_t vp_desc;
599
606static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
607{
608 uint16_t str_len = 0, id_pos = 2;
609 uint8_t *tmp_str = string;
610
611 while(*tmp_str != '\0')
612 {
613 str_len ++;
614 unicode_buf[id_pos ++] = *tmp_str ++;
615 unicode_buf[id_pos ++] = 0x00;
616 }
617
618 str_len = str_len * 2 + 2;
619 unicode_buf[0] = str_len;
620 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
621
622 return str_len;
623}
624
632static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
633{
634 uint8_t idx = 0;
635
636 for( idx = 0 ; idx < len ; idx ++)
637 {
638 if( ((value >> 28)) < 0xA )
639 {
640 pbuf[2 * idx] = (value >> 28) + '0';
641 }
642 else
643 {
644 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
645 }
646
647 value = value << 4;
648
649 pbuf[2 * idx + 1] = 0;
650 }
651}
652
658static void get_serial_num(void)
659{
660 uint32_t serial0, serial1, serial2;
661
662 serial0 = *(uint32_t*)MCU_ID1;
663 serial1 = *(uint32_t*)MCU_ID2;
664 serial2 = *(uint32_t*)MCU_ID3;
665
666 serial0 += serial2;
667
668 if (serial0 != 0)
669 {
670 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
671 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
672 }
673}
674
680static usbd_desc_t *get_device_descriptor(void)
681{
682 return &device_descriptor;
683}
684
690static usbd_desc_t * get_device_qualifier(void)
691{
692 return NULL;
693}
694
700static usbd_desc_t *get_device_configuration(void)
701{
702 return &config_descriptor;
703}
704
710static usbd_desc_t *get_device_other_speed(void)
711{
712 return NULL;
713}
714
720static usbd_desc_t *get_device_lang_id(void)
721{
722 return &langid_descriptor;
723}
724
725
731static usbd_desc_t *get_device_manufacturer_string(void)
732{
733 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
734 vp_desc.descriptor = g_usbd_desc_buffer;
735 return &vp_desc;
736}
737
743static usbd_desc_t *get_device_product_string(void)
744{
745 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
746 vp_desc.descriptor = g_usbd_desc_buffer;
747 return &vp_desc;
748}
749
755static usbd_desc_t *get_device_serial_string(void)
756{
757 get_serial_num();
758 return &serial_descriptor;
759}
760
766static usbd_desc_t *get_device_interface_string(void)
767{
768 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
769 vp_desc.descriptor = g_usbd_desc_buffer;
770 return &vp_desc;
771}
772
778static usbd_desc_t *get_device_config_string(void)
779{
780 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
781 vp_desc.descriptor = g_usbd_desc_buffer;
782 return &vp_desc;
783}
784
audio_hid_desc.h
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:60
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:61
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:63
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_MIC_FEATURE_UNIT_ID
#define AUDIO_MIC_FEATURE_UNIT_ID
Definition: audio_desc.h:167
AUDIO_CS_ENDPOINT
#define AUDIO_CS_ENDPOINT
Definition: audio_desc.h:74
AUDIO_AC_HEADER
#define AUDIO_AC_HEADER
Definition: audio_desc.h:89
AUDIO_SUBCLASS_AUDIOCONTROL
#define AUDIO_SUBCLASS_AUDIOCONTROL
Definition: audio_desc.h:66
AUDIO_INPUT_TERMINAL_SIZE
#define AUDIO_INPUT_TERMINAL_SIZE
audio interface descriptor size define
Definition: audio_desc.h:159
AUDIO_TERMINAL_TYPE_STREAMING
#define AUDIO_TERMINAL_TYPE_STREAMING
Definition: audio_desc.h:136
AUDIO_SPK_CHR
#define AUDIO_SPK_CHR
Definition: audio_desc.h:200
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:178
AUDIO_MIC_OUTPUT_TERMINAL_ID
#define AUDIO_MIC_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:168
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:176
SAMPLE_FREQ
#define SAMPLE_FREQ(frq)
Definition: audio_desc.h:211
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:192
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:199
AT32_AUDIO_FREQ_48K
#define AT32_AUDIO_FREQ_48K
Definition: audio_desc.h:187
AUDIO_FORMAT_TYPE_I
#define AUDIO_FORMAT_TYPE_I
audio format type 1
Definition: audio_desc.h:146
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
AUDIO_AS_GENERAL
#define AUDIO_AS_GENERAL
Definition: audio_desc.h:102
AUDIO_INTERFACE_NUM
#define AUDIO_INTERFACE_NUM
audio interface config
Definition: audio_desc.h:151
AUDIO_CS_INTERFACE
#define AUDIO_CS_INTERFACE
audio class-specific descriptor types
Definition: audio_desc.h:73
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:170
AUDIO_OUTPUT_TERMINAL_SIZE
#define AUDIO_OUTPUT_TERMINAL_SIZE
Definition: audio_desc.h:160
AUDIO_SPK_OUTPUT_TERMINAL_ID
#define AUDIO_SPK_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:171
AUDIO_AC_INPUT_TERMINAL
#define AUDIO_AC_INPUT_TERMINAL
Definition: audio_desc.h:90
AUDIO_MIC_CHR
#define AUDIO_MIC_CHR
Definition: audio_desc.h:193
AUDIO_OUTPUT_TERMINAL_SPEAKER
#define AUDIO_OUTPUT_TERMINAL_SPEAKER
Definition: audio_desc.h:141
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
AT32_AUDIO_FREQ_16K
#define AT32_AUDIO_FREQ_16K
audio support freq
Definition: audio_desc.h:186
AUDIO_AS_FORMAT_TYPE
#define AUDIO_AS_FORMAT_TYPE
Definition: audio_desc.h:103
AUDIO_MIC_INPUT_TERMINAL_ID
#define AUDIO_MIC_INPUT_TERMINAL_ID
audio terminal id define
Definition: audio_desc.h:166
AUDIO_SPK_BITW
#define AUDIO_SPK_BITW
Definition: audio_desc.h:201
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
AUDIO_FEATURE_UNIT_SIZE
#define AUDIO_FEATURE_UNIT_SIZE
Definition: audio_desc.h:161
AUDIO_PROTOCOL_UNDEFINED
#define AUDIO_PROTOCOL_UNDEFINED
audio interface protocol codes
Definition: audio_desc.h:83
AUDIO_MIC_BITW
#define AUDIO_MIC_BITW
Definition: audio_desc.h:194
AUDIO_AC_FEATURE_UNIT
#define AUDIO_AC_FEATURE_UNIT
Definition: audio_desc.h:94
AUDIO_SPK_INPUT_TERMINAL_ID
#define AUDIO_SPK_INPUT_TERMINAL_ID
Definition: audio_desc.h:169
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:152
AUDIO_SUBCLASS_AUDIOSTREAMING
#define AUDIO_SUBCLASS_AUDIOSTREAMING
Definition: audio_desc.h:67
AUDIO_AC_OUTPUT_TERMINAL
#define AUDIO_AC_OUTPUT_TERMINAL
Definition: audio_desc.h:91
AUDIO_INPUT_TERMINAL_MICROPHONE
#define AUDIO_INPUT_TERMINAL_MICROPHONE
Definition: audio_desc.h:139
USBD_AUHID_AUDIO_MIC_IN_EPT
#define USBD_AUHID_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_hid_class.h:52
USBD_AUHID_HID_IN_EPT
#define USBD_AUHID_HID_IN_EPT
usb custom hid use endpoint define
Definition: audio_hid_class.h:59
USBD_AUHID_HID_OUT_EPT
#define USBD_AUHID_HID_OUT_EPT
Definition: audio_hid_class.h:60
USBD_AUHID_AUDIO_FEEDBACK_EPT
#define USBD_AUHID_AUDIO_FEEDBACK_EPT
Definition: audio_hid_class.h:54
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:66
USBD_AUHID_AUDIO_SPK_OUT_EPT
#define USBD_AUHID_AUDIO_SPK_OUT_EPT
Definition: audio_hid_class.h:53
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:65
USBD_AUHID_DESC_CONFIGURATION_STRING
#define USBD_AUHID_DESC_CONFIGURATION_STRING
Definition: audio_hid_desc.h:59
USBD_AUHID_DESC_MANUFACTURER_STRING
#define USBD_AUHID_DESC_MANUFACTURER_STRING
Definition: audio_hid_desc.h:57
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:234
AUHID_BCD_NUM
#define AUHID_BCD_NUM
Definition: audio_hid_desc.h:49
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:221
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:223
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
AUHID_HID_BINTERVAL_TIME
#define AUHID_HID_BINTERVAL_TIME
Definition: audio_hid_desc.h:203
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:225
USBD_AUHID_SIZ_STRING_LANGID
#define USBD_AUHID_SIZ_STRING_LANGID
Definition: audio_hid_desc.h:54
AUHID_HID_BCD_NUM
#define AUHID_HID_BCD_NUM
usb bcd number define
Definition: audio_hid_desc.h:208
USBD_AUHID_PRODUCT_ID
#define USBD_AUHID_PRODUCT_ID
Definition: audio_hid_desc.h:52
USBD_AUHID_CONFIG_DESC_SIZE
#define USBD_AUHID_CONFIG_DESC_SIZE
Definition: audio_hid_desc.h:236
USBD_AUHID_DESC_INTERFACE_STRING
#define USBD_AUHID_DESC_INTERFACE_STRING
Definition: audio_hid_desc.h:60
USBD_AUHID_DESC_PRODUCT_STRING
#define USBD_AUHID_DESC_PRODUCT_STRING
Definition: audio_hid_desc.h:58
USBD_AUHID_SIZ_STRING_SERIAL
#define USBD_AUHID_SIZ_STRING_SERIAL
Definition: audio_hid_desc.h:55
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:222
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:530
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:432
USBD_AUHID_VENDOR_ID
#define USBD_AUHID_VENDOR_ID
Definition: audio_hid_desc.h:51
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:224
HID_INTERFACE_NUMBER
#define HID_INTERFACE_NUMBER
Definition: audio_hid_desc.h:181
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: audio_hid_desc.c:592
device_descriptor
static usbd_desc_t device_descriptor
Definition: audio_hid_desc.c:571
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_hid_desc.c:700
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: audio_hid_desc.c:585
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_hid_desc.c:680
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_hid_desc.c:731
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_hid_desc.c:690
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_hid_desc.c:766
vp_desc
static usbd_desc_t vp_desc
Definition: audio_hid_desc.c:598
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:65
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_hid_desc.c:710
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: audio_hid_desc.c:60
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_hid_desc.c:743
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_hid_desc.c:778
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: audio_hid_desc.c:606
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_hid_desc.c:720
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: audio_hid_desc.c:658
config_descriptor
static usbd_desc_t config_descriptor
Definition: audio_hid_desc.c:578
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_hid_desc.c:755
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: audio_hid_desc.c:632
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:47
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_EPT_DESC_ISO
#define USB_EPT_DESC_ISO
Definition: usb_std.h:174
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_CLASS_CODE_AUDIO
#define USB_CLASS_CODE_AUDIO
usb class code
Definition: usb_std.h:159
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_ETP_DESC_ASYNC
#define USB_ETP_DESC_ASYNC
Definition: usb_std.h:179
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:161
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: audio_hid_desc.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_HID_DESC_H
27#define __AUDIO_HID_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "audio_hid_class.h"
34#include "usbd_core.h"
35#include "audio_conf.h"
36
49#define AUHID_BCD_NUM 0x0100
50
51#define USBD_AUHID_VENDOR_ID 0x2E3C
52#define USBD_AUHID_PRODUCT_ID 0x5555
53
54#define USBD_AUHID_SIZ_STRING_LANGID 4
55#define USBD_AUHID_SIZ_STRING_SERIAL 0x1A
56
57#define USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
58#define USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
59#define USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
60#define USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
64#define AUDIO_SUBCLASS_UNDEFINED 0x00
65#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01
66#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
67#define AUDIO_SUBCLASS_MIDISTREMING 0x03
68
72#define AUDIO_CS_INTERFACE 0x24
73#define AUDIO_CS_ENDPOINT 0x25
74#define AUDIO_CS_STRING 0x23
75#define AUDIO_CS_CONFIGURATION 0x22
76#define AUDIO_CS_DEVICE 0x21
77#define AUDIO_CS_UNDEFINED 0x20
78
82#define AUDIO_PROTOCOL_UNDEFINED 0x00
83
87#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
88#define AUDIO_AC_HEADER 0x01
89#define AUDIO_AC_INPUT_TERMINAL 0x02
90#define AUDIO_AC_OUTPUT_TERMINAL 0x03
91#define AUDIO_AC_MIXER_UNIT 0x04
92#define AUDIO_AC_SELECTOR_UNIT 0x05
93#define AUDIO_AC_FEATURE_UNIT 0x06
94#define AUDIO_AC_PROCESSING_UNIT 0x07
95#define AUDIO_AC_EXTENSION_UNIT 0x08
96
100#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
101#define AUDIO_AS_GENERAL 0x01
102#define AUDIO_AS_FORMAT_TYPE 0x02
103#define AUDIO_AS_FORMAT_SPECIFIC 0x03
104
108#define AUDIO_REQUEST_CODE_UNDEFINED 0x00
109#define AUDIO_REQ_SET_CUR 0x01
110#define AUDIO_REQ_GET_CUR 0x81
111#define AUDIO_REQ_SET_MIN 0x02
112#define AUDIO_REQ_GET_MIN 0x82
113#define AUDIO_REQ_SET_MAX 0x03
114#define AUDIO_REQ_GET_MAX 0x83
115#define AUDIO_REQ_SET_RES 0x04
116#define AUDIO_REQ_GET_RES 0x84
117#define AUDIO_REQ_SET_MEM 0x05
118#define AUDIO_REQ_GET_MEM 0x85
119#define AUDIO_REQ_GET_STAT 0xFF
120
124#define AUDIO_FU_CONTROL_UNDEFINED 0x00
125#define AUDIO_FU_MUTE_CONTROL 0x01
126#define AUDIO_FU_VOLUME_CONTROL 0x02
127#define AUDIO_FU_BASS_CONTROL 0x03
128#define AUDIO_FU_MID_CONTROL 0x04
129#define AUDIO_FU_TREBLE_CONTROL 0x05
130
134#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
135#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101
136#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
137#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
138#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
139#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
140#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
141
145#define AUDIO_FORMAT_TYPE_I 0x01
146
150#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
151#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x22)
152#define AUDIO_MIC_INTERFACE 0x01
153#define AUDIO_SPK_INTERFACE 0x02
154
158#define AUDIO_INPUT_TERMINAL_SIZE 0x0C
159#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09
160#define AUDIO_FEATURE_UNIT_SIZE 0x0D
161
165#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01
166#define AUDIO_MIC_FEATURE_UNIT_ID 0x02
167#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
168#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04
169#define AUDIO_SPK_FEATURE_UNIT_ID 0x05
170#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
171
175#define AUDIO_MIC_INTERFACE_NUMBER 0x01
176#if (AUDIO_SUPPORT_MIC == 1)
177#define AUDIO_SPK_INTERFACE_NUMBER 0x02
178#else
179#define AUDIO_SPK_INTERFACE_NUMBER 0x01
180#endif
181#define HID_INTERFACE_NUMBER 0x03
182
186#define AT32_AUDIO_FREQ_16K 16000
187#define AT32_AUDIO_FREQ_48K 48000
188
192#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
193#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
194#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
195
199#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
200#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
201#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
202
203#define AUHID_HID_BINTERVAL_TIME 0x01
204
208#define AUHID_HID_BCD_NUM 0x0110
209
213#define HID_CLASS_DESC_HID 0x21
214#define HID_CLASS_DESC_REPORT 0x22
215#define HID_CLASS_DESC_PHYSICAL 0x23
216
220#define HID_REPORT_ID_1 0x01
221#define HID_REPORT_ID_2 0x02
222#define HID_REPORT_ID_3 0x03
223#define HID_REPORT_ID_4 0x04
224#define HID_REPORT_ID_5 0x05
225#define HID_REPORT_ID_6 0xF0
226
227#define MCU_ID1 (0x1FFFF7E8)
228#define MCU_ID2 (0x1FFFF7EC)
229#define MCU_ID3 (0x1FFFF7F0)
230
231
232#define SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
233
234#define USBD_AUHID_HID_SIZ_REPORT_DESC 126
235#define USBD_AUHID_HID_DESC_SIZE 32
236#define USBD_AUHID_CONFIG_DESC_SIZE ( 0x12 + AUDIO_INTERFACE_LEN + \
237 + (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
238 + (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
239 + (9 * AUDIO_SUPPORT_FEEDBACK) \
240 + USBD_AUHID_HID_DESC_SIZE)
241
242extern uint8_t g_usbd_audio_hid_report[USBD_AUHID_HID_SIZ_REPORT_DESC];
243extern uint8_t g_audio_hid_usb_desc[9];
244
245extern usbd_desc_handler audio_hid_desc_handler;
246
258#ifdef __cplusplus
259}
260#endif
261
262#endif
263
audio_conf.h
usb audio config
audio_hid_class.h
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:234
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:65
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:530
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:432
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/hid_iap_user.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __HID_IAP_USER_H
27#define __HID_IAP_USER_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "hid_iap_class.h"
34
47#define FLASH_APP_ADDRESS 0x08006000
48
57void iap_init(void);
58 iap_result_type iap_get_upgrade_flag(void);
59void iap_loop(void);
60void jump_to_app(uint32_t address);
61
74#ifdef __cplusplus
75}
76#endif
77
78#endif
79
80
iap_result_type
iap_result_type
Definition: hid_iap_class.h:84
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:232
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:471
hid_iap_class.h
usb hid iap header file


AT32F413 Firmwary Library: iap.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/iap.h
Go to the documentation of this file.
1
25#ifndef __IAP_H__
26#define __IAP_H__
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
46/* app starting address */
47#define APP_START_ADDR 0x08004000
48
49/* the previous sector of app starting address is iap upgrade flag */
50#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
51
52/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
53indicates that an app upgrade will follow, see iap application note for more details */
54#define IAP_UPGRADE_FLAG 0x41544B38
55
67typedef struct
68{
69 uint8_t cmd_head;
70 uint8_t cmd_addr[4];
71 uint8_t cmd_buf[0x800];
72 uint8_t cmd_check;
73} cmd_data_group_type;
74
78typedef enum
79{
80 CMD_DATA_IDLE,
81 CMD_DATA_ADDR,
82 CMD_DATA_BUF,
83 CMD_DATA_CHACK,
84 CMD_DATA_DONE,
85 CMD_DATA_ERR,
86} cmd_data_step_type;
87
91typedef enum
92{
93 CMD_CTR_IDLE,
94 CMD_CTR_INIT,
95 CMD_CTR_DONE,
96 CMD_CTR_ERR,
97 CMD_CTR_APP,
98} cmd_ctr_step_type;
99
103typedef enum
104{
105 UPDATE_PRE,
106 UPDATE_CLEAR_FLAG,
107 UPDATE_ING,
108 UPDATE_DONE,
109} update_status_type;
110
111typedef void (*iapfun)(void);
112
117extern cmd_data_group_type cmd_data_group_type_struct;
118extern cmd_data_step_type cmd_data_step;
119extern cmd_ctr_step_type cmd_ctr_step;
120extern update_status_type update_status;
121
126void command_handle(void);
127void back_err(void);
128void back_ok(void);
129void iap_upgrade_app_handle(void);
130void app_load(uint32_t appxaddr);
131
144#ifdef __cplusplus
145}
146#endif
147
148#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
update_status
update_status_type update_status
Definition: bootloader/src/iap.c:41
cmd_data_group_type_struct
cmd_data_group_type cmd_data_group_type_struct
cmd_data_step
cmd_data_step_type cmd_data_step
Definition: bootloader/src/iap.c:38
cmd_ctr_step
cmd_ctr_step_type cmd_ctr_step
Definition: bootloader/src/iap.c:39
command_handle
void command_handle(void)
command analysis handle.
Definition: bootloader/src/iap.c:104
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: bootloader/src/iap.c:342
app_load
void app_load(uint32_t appxaddr)
app load.
Definition: bootloader/src/iap.c:58
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:118
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:105
iapfun
void(* iapfun)(void)
Definition: bootloader/inc/iap.h:111
update_status_type
update_status_type
update status type
Definition: bootloader/inc/iap.h:104
cmd_ctr_step_type
cmd_ctr_step_type
cmd ctr step type
Definition: bootloader/inc/iap.h:92
cmd_data_step_type
cmd_data_step_type
cmd data step type
Definition: bootloader/inc/iap.h:79
UPDATE_PRE
@ UPDATE_PRE
Definition: bootloader/inc/iap.h:105
UPDATE_DONE
@ UPDATE_DONE
Definition: bootloader/inc/iap.h:108
UPDATE_ING
@ UPDATE_ING
Definition: bootloader/inc/iap.h:107
UPDATE_CLEAR_FLAG
@ UPDATE_CLEAR_FLAG
Definition: bootloader/inc/iap.h:106
CMD_CTR_ERR
@ CMD_CTR_ERR
Definition: bootloader/inc/iap.h:96
CMD_CTR_DONE
@ CMD_CTR_DONE
Definition: bootloader/inc/iap.h:95
CMD_CTR_INIT
@ CMD_CTR_INIT
Definition: bootloader/inc/iap.h:94
CMD_CTR_APP
@ CMD_CTR_APP
Definition: bootloader/inc/iap.h:97
CMD_CTR_IDLE
@ CMD_CTR_IDLE
Definition: bootloader/inc/iap.h:93
CMD_DATA_DONE
@ CMD_DATA_DONE
Definition: bootloader/inc/iap.h:84
CMD_DATA_ERR
@ CMD_DATA_ERR
Definition: bootloader/inc/iap.h:85
CMD_DATA_BUF
@ CMD_DATA_BUF
Definition: bootloader/inc/iap.h:82
CMD_DATA_IDLE
@ CMD_DATA_IDLE
Definition: bootloader/inc/iap.h:80
CMD_DATA_CHACK
@ CMD_DATA_CHACK
Definition: bootloader/inc/iap.h:83
CMD_DATA_ADDR
@ CMD_DATA_ADDR
Definition: bootloader/inc/iap.h:81
cmd_data_group_type
cmd data group type
Definition: bootloader/inc/iap.h:68
cmd_data_group_type::cmd_head
uint8_t cmd_head
Definition: bootloader/inc/iap.h:69
cmd_data_group_type::cmd_check
uint8_t cmd_check
Definition: bootloader/inc/iap.h:72


AT32F413 Firmwary Library: tmr.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/tmr.h
Go to the documentation of this file.
1
25#ifndef __TMR_H
26#define __TMR_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
34extern uint8_t time_ira_cnt;
35extern uint8_t get_data_from_usart_flag;
36
49void tmr_init(void);
50
63#ifdef __cplusplus
64}
65#endif
66
67#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:37
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: bootloader/src/tmr.c:38
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:42


AT32F413 Firmwary Library: usart.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/usart.h
Go to the documentation of this file.
1
25#ifndef __USART_H
26#define __USART_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
46#define USART_REC_LEN 1024
47
59typedef struct
60{
61 uint16_t buf[USART_REC_LEN];
62 uint16_t head;
63 uint16_t tail;
64 uint16_t count;
65} usart_group_type;
66
71extern usart_group_type usart_group_struct;
72
77void uart_init(uint32_t baudrate);
78
91#ifdef __cplusplus
92}
93#endif
94
95#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:36
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:46
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
usart_group_type
usart group type
Definition: bootloader/inc/usart.h:60
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:63
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:64
usart_group_type::head
uint16_t head
Definition: bootloader/inc/usart.h:62


AT32F413 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/hid_iap_user.c
Go to the documentation of this file.
1
25#include "hid_iap_user.h"
26#include "hid_iap_class.h"
27#include "string.h"
28
37void (*pftarget)(void);
38void iap_clear_upgrade_flag(void);
39void iap_set_upgrade_flag(void);
40uint32_t crc_cal(uint32_t addr, uint16_t nk);
41
42void iap_idle(void);
43void iap_start(void);
44 iap_result_type iap_address(uint8_t *pdata, uint32_t len);
45void iap_finish(void);
46 iap_result_type iap_data_write(uint8_t *pdata, uint32_t len);
47void iap_jump(void);
48void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
49
55void jump_to_app(uint32_t address)
56{
57 uint32_t stkptr, jumpaddr;
58 stkptr = *(uint32_t *)address;
59 jumpaddr = *(uint32_t *)(address + sizeof(uint32_t));
60
61 /* disable nvic irq and periph clock, clear pending */
62 nvic_irq_disable(USBFS_L_CAN1_RX0_IRQn);
63 __NVIC_ClearPendingIRQ(USBFS_L_CAN1_RX0_IRQn);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, FALSE);
65 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, FALSE);
66
67 crm_periph_reset(CRM_USB_PERIPH_RESET, TRUE);
68 crm_periph_reset(CRM_USB_PERIPH_RESET, FALSE);
69
70 __set_MSP(stkptr);
71 pftarget = (void (*) (void))jumpaddr;
72 pftarget();
73}
74
80void iap_clear_upgrade_flag(void)
81{
82 flash_unlock();
83 flash_sector_erase(iap_info.flag_address);
84 flash_lock();
85}
86
92void iap_set_upgrade_flag(void)
93{
94 flash_unlock();
95 flash_word_program(iap_info.flag_address, IAP_UPGRADE_COMPLETE_FLAG);
96 flash_lock();
97}
98
104 iap_result_type iap_get_upgrade_flag(void)
105{
106 uint32_t flag_address = iap_info.flag_address;
107 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
108 {
109 return IAP_SUCCESS;
110 }
111 else
112 {
113 return IAP_FAILED;
114 }
115}
116
122void iap_erase_sector(uint32_t address)
123{
124 flash_unlock();
125 if(iap_info.sector_size == SECTOR_SIZE_1K)
126 {
127 flash_sector_erase(address);
128 }
129 else if(iap_info.sector_size == SECTOR_SIZE_2K)
130 {
131 /* check the address is sector align */
132 if((address & (SECTOR_SIZE_2K-1)) == 0)
133 {
134 flash_sector_erase(address);
135 }
136 }
137 else if(iap_info.sector_size == SECTOR_SIZE_4K)
138 {
139 if((address & (SECTOR_SIZE_4K-1)) == 0)
140 {
141 flash_sector_erase(address);
142 }
143 }
144 flash_lock();
145}
146
153uint32_t crc_cal(uint32_t addr, uint16_t nk)
154{
155 uint32_t *paddr = (uint32_t *)addr;
156 uint32_t wlen = nk * 1024 / sizeof(uint32_t);
157 uint32_t value, i_index = 0;
158 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
159 crc_data_reset();
160
161 for(i_index = 0; i_index < wlen; i_index ++)
162 {
163 value = *paddr;
164 crc_one_word_calculate(CONVERT_ENDIAN(value));
165 paddr ++;
166 }
167 return crc_data_get();
168}
169
175void iap_init(void)
176{
177 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
178 if(iap_info.flash_size < KB_TO_B(256))
179 {
180 iap_info.sector_size = SECTOR_SIZE_1K;
181 }
182 else
183 {
184 iap_info.sector_size = SECTOR_SIZE_2K;
185 }
186
187 iap_info.flash_start_address = FLASH_BASE;
188 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
189
190 iap_info.app_address = FLASH_APP_ADDRESS;
191 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
192
193 iap_info.fifo_length = 0;
194 iap_info.iap_address = 0;
195}
196
202void iap_idle(void)
203{
204 iap_info.state = IAP_STS_START;
205 iap_init();
206 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
207}
208
214void iap_start(void)
215{
216 iap_info.state = IAP_STS_START;
217 iap_init();
218 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
219}
220
227 iap_result_type iap_address(uint8_t *pdata, uint32_t len)
228{
229 iap_result_type status = IAP_SUCCESS;
230 uint16_t result = IAP_ACK;
231 uint8_t *paddr = pdata + 2; /* skip iap cmd */
232 uint32_t address;
233
234 address = (paddr[0] << 24) |
235 (paddr[1] << 16) |
236 (paddr[2] << 8) |
237 paddr[3];
238
239 /* check the address is valid */
240 if(address < iap_info.app_address || address > iap_info.flash_end_address)
241 {
242 status = IAP_FAILED;
243 result = IAP_NACK;
244 }
245 else
246 {
247 iap_info.iap_address = address;
248
249 if(iap_info.state == IAP_STS_START)
250 {
251 iap_clear_upgrade_flag();
252 }
253 iap_erase_sector(iap_info.iap_address);
254 }
255
256 iap_info.state = IAP_STS_ADDR;
257
258 iap_respond(iap_info.iap_tx, IAP_CMD_ADDR, result);
259
260 return status;
261}
262/*
263 * @brief iap data write
264 * @param pdata: data buffer pointer.
265 * @param len: buffer length
266 * @retval the result of the address parse
267 */
268 iap_result_type iap_data_write(uint8_t *pdata, uint32_t len)
269{
270 uint32_t data_len = (pdata[2] << 8 | pdata[3]);
271 uint8_t *valid_data = pdata + 4;
272 uint32_t *pbuf;
273 uint32_t i_index = 0;
274
275 if(iap_info.state == IAP_STS_ADDR)
276 {
277 if(data_len + iap_info.fifo_length <= HID_IAP_BUFFER_LEN)
278 {
279 for(i_index = 0; i_index < data_len; i_index ++)
280 {
281 iap_info.iap_fifo[iap_info.fifo_length ++] = valid_data[i_index];
282 }
283 }
284 /* buffer full */
285 if(iap_info.fifo_length == HID_IAP_BUFFER_LEN)
286 {
287 flash_unlock();
288 pbuf = (uint32_t *)iap_info.iap_fifo;
289 for(i_index = 0; i_index < iap_info.fifo_length / sizeof(uint32_t); i_index ++)
290 {
291 flash_word_program(iap_info.iap_address, *pbuf ++);
292 iap_info.iap_address += 4;
293 }
294 flash_lock();
295
296 iap_info.fifo_length = 0;
297 iap_info.iap_address = 0;
298 iap_respond(iap_info.iap_tx, IAP_CMD_DATA, IAP_ACK);
299 }
300 }
301 else
302 {
303 iap_respond(iap_info.iap_tx, IAP_CMD_DATA, IAP_NACK);
304 }
305 return IAP_SUCCESS;
306}
307
308/*
309 * @brief iap finish
310 * @param none
311 * @retval none
312 */
313void iap_finish()
314{
315 iap_info.state = IAP_STS_FINISH;
316 iap_set_upgrade_flag();
317 iap_respond(iap_info.iap_tx, IAP_CMD_FINISH, IAP_ACK);
318}
319
320/*
321 * @brief iap crc
322 * @param pdata: data buffer pointer.
323 * @param len: buffer length
324 * @retval the result of the address parse
325 */
326void iap_crc(uint8_t *pdata, uint32_t len)
327{
328 uint8_t *paddr = pdata + 2; /* skip iap cmd */
329 uint16_t crc_nk;
330 uint32_t crc_value;
331 uint32_t address = (paddr[0] << 24) |
332 (paddr[1] << 16) |
333 (paddr[2] << 8) |
334 paddr[3];
335 paddr = pdata + 6;
336
337 crc_nk = (paddr[0] << 16) | paddr[1];
338
339 crc_value = crc_cal(address, crc_nk);
340
341 iap_respond(iap_info.iap_tx, IAP_CMD_CRC, IAP_ACK);
342 iap_info.iap_tx[4] = (uint8_t)((crc_value >> 24) & 0xFF);
343 iap_info.iap_tx[5] = (uint8_t)((crc_value >> 16) & 0xFF);
344 iap_info.iap_tx[6] = (uint8_t)((crc_value >> 8) & 0xFF);
345 iap_info.iap_tx[7] = (uint8_t)((crc_value) & 0xFF);
346
347}
348
349/*
350 * @brief iap jump
351 * @param none
352 * @retval none
353 */
354void iap_jump()
355{
356 iap_info.state = IAP_STS_JMP_WAIT;
357 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
358}
359
360/*
361 * @brief iap get
362 * @param none
363 * @retval none
364 */
365void iap_get()
366{
367 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
368 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
369 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
370 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
371 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
372}
373
374
375
376/*
377 * @brief iap respond
378 * @param res_buf: data buffer pointer.
379 * @param iap_cmd: iap command
380 * @param result: iap result
381 * @retval the result of the address parse
382 */
383void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
384{
385 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
386 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
387 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
388 res_buf[3] = (uint8_t)((result) & 0xFF);
389
390 iap_info.respond_flag = 1;
391}
392
400 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
401{
402 iap_result_type status = IAP_SUCCESS;
403 uint16_t iap_cmd;
404
405 if(len < 2)
406 {
407 return IAP_FAILED;
408 }
409
410 iap_info.respond_flag = 0;
411
412 iap_cmd = (pdata[0] << 8) | pdata[1];
413
414 switch(iap_cmd)
415 {
416 case IAP_CMD_IDLE:
417 iap_idle();
418 break;
419 case IAP_CMD_START:
420 iap_start();
421 break;
422 case IAP_CMD_ADDR:
423 iap_address(pdata, len);
424 break;
425 case IAP_CMD_DATA:
426 iap_data_write(pdata, len);
427 break;
428 case IAP_CMD_FINISH:
429 iap_finish();
430 break;
431 case IAP_CMD_CRC:
432 iap_crc(pdata, len);
433 break;
434 case IAP_CMD_JMP:
435 iap_jump();
436 break;
437 case IAP_CMD_GET:
438 iap_get();
439 break;
440 default:
441 status = IAP_FAILED;
442 break;
443 }
444
445 if(iap_info.respond_flag)
446 {
447 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
448 }
449
450 return status;
451}
452
458void usbd_hid_iap_in_complete(void *udev)
459{
460 if(iap_info.state == IAP_STS_JMP_WAIT)
461 {
462 iap_info.state = IAP_STS_JMP;
463 }
464}
465
471void iap_loop(void)
472{
473 if(iap_info.state == IAP_STS_JMP)
474 {
475 delay_ms(100);
476 jump_to_app(iap_info.app_address);
477 }
478}
479
crc_value
__IO uint32_t crc_value
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:62
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:47
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f413_crc.c:87
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:58
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_USB_PERIPH_RESET
@ CRM_USB_PERIPH_RESET
Definition: at32f413_crm.h:180
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:79
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
HID_IAP_BUFFER_LEN
#define HID_IAP_BUFFER_LEN
Definition: hid_iap_class.h:75
IAP_CMD_DATA
#define IAP_CMD_DATA
Definition: hid_iap_class.h:69
IAP_CMD_FINISH
#define IAP_CMD_FINISH
Definition: hid_iap_class.h:70
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:66
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:73
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:59
iap_result_type
iap_result_type
Definition: hid_iap_class.h:84
IAP_NACK
#define IAP_NACK
Definition: hid_iap_class.h:81
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:80
IAP_CMD_CRC
#define IAP_CMD_CRC
Definition: hid_iap_class.h:71
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:60
CONVERT_ENDIAN
#define CONVERT_ENDIAN(dwValue)
Definition: hid_iap_class.h:77
IAP_CMD_ADDR
#define IAP_CMD_ADDR
Definition: hid_iap_class.h:68
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:61
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:76
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:56
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:67
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:72
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:57
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:87
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:85
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:93
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:99
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:98
IAP_STS_FINISH
@ IAP_STS_FINISH
Definition: hid_iap_class.h:96
IAP_STS_ADDR
@ IAP_STS_ADDR
Definition: hid_iap_class.h:94
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:52
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:319
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:92
iap_idle
void iap_idle(void)
iap idle function
Definition: bootloader/src/hid_iap_user.c:202
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: bootloader/src/hid_iap_user.c:383
iap_data_write
iap_result_type iap_data_write(uint8_t *pdata, uint32_t len)
Definition: bootloader/src/hid_iap_user.c:268
iap_init
void iap_init(void)
iap init
Definition: bootloader/src/hid_iap_user.c:175
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: bootloader/src/hid_iap_user.c:400
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: bootloader/src/hid_iap_user.c:55
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:153
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:104
iap_address
iap_result_type iap_address(uint8_t *pdata, uint32_t len)
iap parse address
Definition: bootloader/src/hid_iap_user.c:227
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:313
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:471
iap_start
void iap_start(void)
iap start function
Definition: bootloader/src/hid_iap_user.c:214
iap_crc
void iap_crc(uint8_t *pdata, uint32_t len)
Definition: bootloader/src/hid_iap_user.c:326
pftarget
void(* pftarget)(void)
Definition: bootloader/src/hid_iap_user.c:37
iap_erase_sector
void iap_erase_sector(uint32_t address)
set iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:122
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: bootloader/src/hid_iap_user.c:80
iap_get
void iap_get()
Definition: bootloader/src/hid_iap_user.c:365
iap_jump
void iap_jump(void)
Definition: bootloader/src/hid_iap_user.c:354
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: bootloader/src/hid_iap_user.c:458
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:47
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:122
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:114
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:119
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:113
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:116
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:117
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:109
iap_info_type::iap_fifo
uint8_t iap_fifo[1024]
Definition: hid_iap_class.h:105
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:120
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:107
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:112
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:131


AT32F413 Firmwary Library: iap.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/iap.c
Go to the documentation of this file.
1
25#include "iap.h"
26#include "usart.h"
27#include "flash.h"
28#include "tmr.h"
29
38 cmd_data_step_type cmd_data_step = CMD_DATA_IDLE;
39 cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE;
40 cmd_data_group_type cmd_data_group_struct;
41 update_status_type update_status = UPDATE_PRE;
42static uint8_t cmd_addr_cnt = 0;
43static uint32_t cmd_data_cnt = 0;
44 iapfun jump_to_app;
45
46/* app_load don't optimize */
47#if defined (__CC_ARM)
48 #pragma O0
49#elif defined (__ICCARM__)
50 #pragma optimize=s none
51#endif
58void app_load(uint32_t app_addr)
59{
60 /* check the address of stack */
61 if(((*(uint32_t*)app_addr) - 0x20000000) <= (SRAM_SIZE * 1024))
62 {
63 /* disable periph clock */
64 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, FALSE);
65 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, FALSE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, FALSE);
67
68 /* disable nvic irq and clear pending */
69 nvic_irq_disable(USART1_IRQn);
70 nvic_irq_disable(TMR3_GLOBAL_IRQn);
71 __NVIC_ClearPendingIRQ(USART1_IRQn);
72 __NVIC_ClearPendingIRQ(TMR3_GLOBAL_IRQn);
73
74 jump_to_app = (iapfun)*(uint32_t*)(app_addr + 4); /* code second word is reset address */
75 __set_MSP(*(uint32_t*)app_addr); /* init app stack pointer(code first word is stack address) */
76 jump_to_app(); /* jump to user app */
77 }
78}
79
87uint8_t data_take(void)
88{
89 uint8_t val;
90 usart_interrupt_enable(USART1, USART_RDBF_INT, FALSE);
91 usart_group_struct.count--;
92 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
93 val = usart_group_struct.buf[usart_group_struct.tail++];
94 if(usart_group_struct.tail > (USART_REC_LEN-1))
95 usart_group_struct.tail = 0;
96 return val;
97}
98
104void command_handle(void)
105{
106 uint8_t val, checksum;
107 uint16_t index;
108 /* check whether received usart data */
109 if(usart_group_struct.count > 0)
110 val = data_take();
111 else
112 return;
113
114 if(update_status == UPDATE_PRE)
115 {
116 if(cmd_ctr_step == CMD_CTR_IDLE)
117 {
118 if(val == 0x5A)
119 cmd_ctr_step = CMD_CTR_INIT;
120 }
121 else if(cmd_ctr_step == CMD_CTR_INIT)
122 {
123 if(val == 0x01)
124 {
125 cmd_ctr_step = CMD_CTR_DONE;
126 }
127 else if(val == 0xA5)
128 {
129 cmd_ctr_step = CMD_CTR_APP;
130 }
131 else
132 {
133 cmd_ctr_step = CMD_CTR_ERR;
134 }
135 }
136 }
137 else if(update_status == UPDATE_ING)
138 {
139 switch(cmd_data_step)
140 {
141 case CMD_DATA_IDLE:
142 if(val == 0x31)
143 {
144 cmd_data_step = CMD_DATA_ADDR;
145 cmd_addr_cnt = 0;
146 cmd_data_cnt = 0;
147 }
148 if(val == 0x5A)
149 {
150 if(cmd_ctr_step == CMD_CTR_IDLE)
151 {
152 cmd_ctr_step = CMD_CTR_INIT;
153 update_status = UPDATE_DONE;
154 }
155 }
156 break;
157 case CMD_DATA_ADDR:
158 cmd_data_group_struct.cmd_addr[cmd_addr_cnt] = val;
159 cmd_addr_cnt++;
160 if(cmd_addr_cnt >= 4)
161 {
162 cmd_addr_cnt = 0;
163 cmd_data_step = CMD_DATA_BUF;
164 }
165 break;
166 case CMD_DATA_BUF:
167 cmd_data_group_struct.cmd_buf[cmd_data_cnt] = val;
168 cmd_data_cnt++;
169 if(cmd_data_cnt >= 2048)
170 {
171 cmd_data_cnt = 0;
172 cmd_data_step = CMD_DATA_CHACK;
173 }
174 break;
175 case CMD_DATA_CHACK:
176 checksum = 0;
177 for(index = 0;index < 4;index++)
178 {
179 checksum += cmd_data_group_struct.cmd_addr[index];
180 }
181 for(index = 0;index < 0x800; index++)
182 {
183 checksum += cmd_data_group_struct.cmd_buf[index];
184 }
185 if(checksum == val)
186 {
187 cmd_data_step = CMD_DATA_DONE;
188 }
189 else
190 {
191 cmd_data_step = CMD_DATA_ERR;
192 }
193 break;
194 default:
195 break;
196 }
197 }
198 else if(update_status == UPDATE_DONE)
199 {
200 if(cmd_ctr_step == CMD_CTR_IDLE)
201 {
202 if(val == 0x5A)
203 {
204 cmd_ctr_step = CMD_CTR_INIT;
205 }
206 }
207 else if(cmd_ctr_step == CMD_CTR_INIT)
208 {
209 if(val == 0x02)
210 {
211 cmd_ctr_step = CMD_CTR_DONE;
212 }
213 else
214 {
215 cmd_ctr_step = CMD_CTR_ERR;
216 }
217 }
218 }
219}
220
226void back_ok(void)
227{
228 usart_data_transmit(USART1, 0xCC);
229 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
230 usart_data_transmit(USART1, 0xDD);
231 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
232}
233
239void back_err(void)
240{
241 usart_data_transmit(USART1, 0xEE);
242 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
243 usart_data_transmit(USART1, 0xFF);
244 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
245 /* reset state machine of udgrade flow */
246 cmd_data_step = CMD_DATA_IDLE;
247 cmd_ctr_step = CMD_CTR_IDLE;
248 update_status = UPDATE_PRE;
249 cmd_addr_cnt = 0;
250 cmd_data_cnt = 0;
251 time_ira_cnt = 0;
252 get_data_from_usart_flag = 0;
253}
254
260void app_update_handle(void)
261{
262 uint32_t write_addr=0;
263 if(update_status == UPDATE_PRE)
264 {
265 if(cmd_ctr_step == CMD_CTR_DONE)
266 {
267 cmd_ctr_step = CMD_CTR_IDLE;
268 update_status = UPDATE_CLEAR_FLAG;
269 }
270 else if(cmd_ctr_step == CMD_CTR_APP)
271 {
272 cmd_ctr_step = CMD_CTR_IDLE;
273 back_ok();
274 }
275 else if(cmd_ctr_step == CMD_CTR_ERR)
276 {
277 cmd_ctr_step = CMD_CTR_IDLE;
278 back_err();
279 }
280 }
281 else if(update_status == UPDATE_CLEAR_FLAG)
282 {
283 get_data_from_usart_flag = 1;
284 update_status = UPDATE_ING;
285 back_ok();
286 }
287 else if(update_status == UPDATE_ING)
288 {
289 if(cmd_data_step == CMD_DATA_DONE)
290 {
291 write_addr = (cmd_data_group_struct.cmd_addr[0] << 24) + (cmd_data_group_struct.cmd_addr[1] << 16) + \
292 (cmd_data_group_struct.cmd_addr[2] << 8) + cmd_data_group_struct.cmd_addr[3];
293 if((write_addr >= APP_START_ADDR) && (write_addr < FLASH_BASE + 1024 * FLASH_SIZE))
294 {
295 flash_2kb_write(write_addr, cmd_data_group_struct.cmd_buf);
296 cmd_data_step = CMD_DATA_IDLE;
297 back_ok();
298 }
299 else
300 {
301 cmd_data_step = CMD_DATA_IDLE;
302 back_err();
303 }
304 }
305 else if(cmd_data_step == CMD_DATA_ERR)
306 {
307 cmd_data_step = CMD_DATA_IDLE;
308 back_err();
309 }
310 }
311 else if(update_status == UPDATE_DONE)
312 {
313 if(cmd_ctr_step == CMD_CTR_DONE)
314 {
315 cmd_ctr_step = CMD_CTR_IDLE;
316 back_ok();
317 /* check app starting address whether 0x08xxxxxx */
318 if(((*(uint32_t*)(APP_START_ADDR + 4)) & 0xFF000000) == 0x08000000)
319 {
320 crm_reset();
321 /* jump and run in app */
322 app_load(APP_START_ADDR);
323 }
324 else
325 {
326 cmd_ctr_step = CMD_CTR_ERR;
327 }
328 }
329 else if(cmd_ctr_step == CMD_CTR_ERR)
330 {
331 cmd_ctr_step = CMD_CTR_IDLE;
332 back_err();
333 }
334 }
335}
336
342void iap_upgrade_app_handle(void)
343{
344 command_handle();
345 app_update_handle();
346}
347
jump_to_app
iapfun jump_to_app
jump to app
Definition: bootloader/src/iap.c:44
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:208
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:79
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:56
cmd_addr_cnt
static uint8_t cmd_addr_cnt
Definition: bootloader/src/iap.c:42
app_update_handle
void app_update_handle(void)
app update flow handle.
Definition: bootloader/src/iap.c:260
data_take
uint8_t data_take(void)
take data from usart buf.
Definition: bootloader/src/iap.c:87
command_handle
void command_handle(void)
command analysis handle.
Definition: bootloader/src/iap.c:104
update_status
update_status_type update_status
Definition: bootloader/src/iap.c:41
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: bootloader/src/iap.c:342
cmd_data_group_struct
cmd_data_group_type cmd_data_group_struct
Definition: bootloader/src/iap.c:40
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:37
cmd_data_cnt
static uint32_t cmd_data_cnt
Definition: bootloader/src/iap.c:43
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: bootloader/src/tmr.c:38
cmd_data_step
cmd_data_step_type cmd_data_step
Definition: bootloader/src/iap.c:38
app_load
void app_load(uint32_t app_addr)
app load.
Definition: bootloader/src/iap.c:58
cmd_ctr_step
cmd_ctr_step_type cmd_ctr_step
Definition: bootloader/src/iap.c:39
back_err
void back_err(void)
command response error.
Definition: bootloader/src/iap.c:239
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:36
back_ok
void back_ok(void)
command response ok.
Definition: bootloader/src/iap.c:226
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART1
#define USART1
Definition: at32f413_usart.h:317
APP_START_ADDR
#define APP_START_ADDR
Definition: app_led3_toggle/inc/iap.h:47
SRAM_SIZE
#define SRAM_SIZE
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h:47
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:46
FLASH_SIZE
#define FLASH_SIZE
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h:46
flash_2kb_write
void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:43
iapfun
void(* iapfun)(void)
Definition: bootloader/inc/iap.h:111
update_status_type
update_status_type
update status type
Definition: bootloader/inc/iap.h:104
cmd_ctr_step_type
cmd_ctr_step_type
cmd ctr step type
Definition: bootloader/inc/iap.h:92
cmd_data_step_type
cmd_data_step_type
cmd data step type
Definition: bootloader/inc/iap.h:79
UPDATE_PRE
@ UPDATE_PRE
Definition: bootloader/inc/iap.h:105
UPDATE_DONE
@ UPDATE_DONE
Definition: bootloader/inc/iap.h:108
UPDATE_ING
@ UPDATE_ING
Definition: bootloader/inc/iap.h:107
UPDATE_CLEAR_FLAG
@ UPDATE_CLEAR_FLAG
Definition: bootloader/inc/iap.h:106
CMD_CTR_ERR
@ CMD_CTR_ERR
Definition: bootloader/inc/iap.h:96
CMD_CTR_DONE
@ CMD_CTR_DONE
Definition: bootloader/inc/iap.h:95
CMD_CTR_INIT
@ CMD_CTR_INIT
Definition: bootloader/inc/iap.h:94
CMD_CTR_APP
@ CMD_CTR_APP
Definition: bootloader/inc/iap.h:97
CMD_CTR_IDLE
@ CMD_CTR_IDLE
Definition: bootloader/inc/iap.h:93
CMD_DATA_DONE
@ CMD_DATA_DONE
Definition: bootloader/inc/iap.h:84
CMD_DATA_ERR
@ CMD_DATA_ERR
Definition: bootloader/inc/iap.h:85
CMD_DATA_BUF
@ CMD_DATA_BUF
Definition: bootloader/inc/iap.h:82
CMD_DATA_IDLE
@ CMD_DATA_IDLE
Definition: bootloader/inc/iap.h:80
CMD_DATA_CHACK
@ CMD_DATA_CHACK
Definition: bootloader/inc/iap.h:83
CMD_DATA_ADDR
@ CMD_DATA_ADDR
Definition: bootloader/inc/iap.h:81
cmd_data_group_type
cmd data group type
Definition: bootloader/inc/iap.h:68
cmd_data_group_type::cmd_addr
uint8_t cmd_addr[4]
Definition: bootloader/inc/iap.h:70
cmd_data_group_type::cmd_buf
uint8_t cmd_buf[0x800]
Definition: bootloader/inc/iap.h:71
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:63
usart_group_type::buf
uint16_t buf[1024]
Definition: bootloader/inc/usart.h:61
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:64


AT32F413 Firmwary Library: tmr.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/tmr.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "tmr.h"
27#include "iap.h"
28
37uint8_t time_ira_cnt=0;
38uint8_t get_data_from_usart_flag = 0; /* flag for timer out in upgrade flow */
39
45void tmr_init(void)
46{
47 crm_clocks_freq_type crm_clocks_freq_struct = {0};
48
49 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
50
51 /* enable the tmr3 global interrupt */
52 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
53
54 /* get system clock */
55 crm_clocks_freq_get(&crm_clocks_freq_struct);
56
57 /* time base configuration */
58 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
59 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
60
61 /* overflow interrupt enable */
62 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
63
64 /* enable tmr */
65 tmr_counter_enable(TMR3, TRUE);
66}
67
73void TMR3_GLOBAL_IRQHandler(void)
74{
75 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
76 {
77 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
78 at32_led_toggle(LED2);
79 if(get_data_from_usart_flag)
80 {
81 if((++time_ira_cnt) == 0x00)
82 time_ira_cnt = 0xFF;
83 if(time_ira_cnt > 2)
84 back_err();
85 if(time_ira_cnt > 5)
86 crm_periph_clock_enable(LED2_GPIO_CRM_CLK, FALSE);
87 }
88 }
89}
90
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:37
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:50
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:72
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:37
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: bootloader/src/tmr.c:73
tmr_init
void tmr_init(void)
init tmr.
Definition: bootloader/src/tmr.c:45
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: bootloader/src/tmr.c:38
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:118
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:471


AT32F413 Firmwary Library: usart.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/usart.c
Go to the documentation of this file.
1
25#include "usart.h"
26#include "tmr.h"
27
36 usart_group_type usart_group_struct;
37
43void uart_init(uint32_t baudrate)
44{
45 gpio_init_type gpio_init_struct;
46 /* enable the usart and it's io clock */
47 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
48 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
49
50 /* set default parameter */
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the usart1_tx pa9 */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_9;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 /* configure the usart1_rx pa10 */
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
64 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
65 gpio_init_struct.gpio_pins = GPIO_PINS_10;
66 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
67 gpio_init(GPIOA, &gpio_init_struct);
68
69 /*configure usart nvic interrupt */
70 nvic_irq_enable(USART1_IRQn, 0, 0);
71
72 /*configure usart param*/
73 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
74 usart_transmitter_enable(USART1, TRUE);
75 usart_receiver_enable(USART1, TRUE);
76 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
77 usart_enable(USART1, TRUE);
78}
79
85void USART1_IRQHandler(void)
86{
87 uint16_t reval;
88 time_ira_cnt = 0; /* clear upgrade time out flag */
89 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
90 {
91 reval = usart_data_receive(USART1);
92 if(usart_group_struct.count > (USART_REC_LEN - 1))
93 {
94 usart_group_struct.count = 0;
95 usart_group_struct.head = 0;
96 usart_group_struct.tail = 0;
97 }
98 else
99 {
100 usart_group_struct.count++;
101 usart_group_struct.buf[usart_group_struct.head++] = reval;
102 if(usart_group_struct.head > (USART_REC_LEN - 1))
103 {
104 usart_group_struct.head = 0;
105 }
106 }
107 }
108}
109
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:208
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:37
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: bootloader/src/usart.c:85
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: bootloader/src/usart.c:43
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:36
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART1
#define USART1
Definition: at32f413_usart.h:317
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:46
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
usart_group_type
usart group type
Definition: bootloader/inc/usart.h:60
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:63
usart_group_type::buf
uint16_t buf[1024]
Definition: bootloader/inc/usart.h:61
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:64
usart_group_type::head
uint16_t head
Definition: bootloader/inc/usart.h:62


AT32F413 Firmwary Library: cdc_class.c Source File

  • middlewares
  • usbd_class
  • cdc
cdc_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "cdc_class.h"
26#include "cdc_desc.h"
27
41static usb_sts_type class_init_handler(void *udev);
42static usb_sts_type class_clear_handler(void *udev);
43static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
44static usb_sts_type class_ept0_tx_handler(void *udev);
45static usb_sts_type class_ept0_rx_handler(void *udev);
46static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
47static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_sof_handler(void *udev);
49static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
50
51static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc);
52extern void usb_usart_config( linecoding_type linecoding);
53static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
54
55 linecoding_type linecoding =
56{
57 115200,
58 0,
59 0,
60 8
61};
62
63/* cdc data struct */
64 cdc_struct_type cdc_struct;
65
66/* usb device class handler */
67 usbd_class_handler cdc_class_handler =
68{
69 class_init_handler,
70 class_clear_handler,
71 class_setup_handler,
72 class_ept0_tx_handler,
73 class_ept0_rx_handler,
74 class_in_handler,
75 class_out_handler,
76 class_sof_handler,
77 class_event_handler,
78 &cdc_struct
79};
80
86static usb_sts_type class_init_handler(void *udev)
87{
88 usb_sts_type status = USB_OK;
89 usbd_core_type *pudev = (usbd_core_type *)udev;
90 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
91
92#ifndef USB_EPT_AUTO_MALLOC_BUFFER
93 /* use user define buffer address */
94 usbd_ept_buf_custom_define(pudev, USBD_CDC_INT_EPT, EPT2_TX_ADDR);
95 usbd_ept_buf_custom_define(pudev, USBD_CDC_BULK_IN_EPT, EPT1_TX_ADDR);
96 usbd_ept_buf_custom_define(pudev, USBD_CDC_BULK_OUT_EPT, EPT1_RX_ADDR);
97#endif
98
99 /* open in endpoint */
100 usbd_ept_open(pudev, USBD_CDC_INT_EPT, EPT_INT_TYPE, USBD_CDC_CMD_MAXPACKET_SIZE);
101
102 /* open in endpoint */
103 usbd_ept_open(pudev, USBD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_IN_MAXPACKET_SIZE);
104
105 /* open out endpoint */
106 usbd_ept_open(pudev, USBD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_OUT_MAXPACKET_SIZE);
107
108 /* set out endpoint to receive status */
109 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_OUT_MAXPACKET_SIZE);
110
111 cdc_struct_init(pcdc);
112
113 return status;
114}
115
121static usb_sts_type class_clear_handler(void *udev)
122{
123 usb_sts_type status = USB_OK;
124 usbd_core_type *pudev = (usbd_core_type *)udev;
125
126 /* close in endpoint */
127 usbd_ept_close(pudev, USBD_CDC_INT_EPT);
128
129 /* close in endpoint */
130 usbd_ept_close(pudev, USBD_CDC_BULK_IN_EPT);
131
132 /* close out endpoint */
133 usbd_ept_close(pudev, USBD_CDC_BULK_OUT_EPT);
134
135 return status;
136}
137
144static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
145{
146 usb_sts_type status = USB_OK;
147 usbd_core_type *pudev = (usbd_core_type *)udev;
148 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
149
150 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
151 {
152 /* class request */
153 case USB_REQ_TYPE_CLASS:
154 if(setup->wLength)
155 {
156 if(setup->bmRequestType & USB_REQ_DIR_DTH)
157 {
158 usb_vcp_cmd_process(udev, setup->bRequest, pcdc->g_cmd, setup->wLength);
159 usbd_ctrl_send(pudev, pcdc->g_cmd, setup->wLength);
160 }
161 else
162 {
163 pcdc->g_req = setup->bRequest;
164 pcdc->g_len = setup->wLength;
165 usbd_ctrl_recv(pudev, pcdc->g_cmd, pcdc->g_len);
166
167 }
168 }
169 break;
170 /* standard request */
171 case USB_REQ_TYPE_STANDARD:
172 switch(setup->bRequest)
173 {
174 case USB_STD_REQ_GET_DESCRIPTOR:
175 usbd_ctrl_unsupport(pudev);
176 break;
177 case USB_STD_REQ_GET_INTERFACE:
178 usbd_ctrl_send(pudev, (uint8_t *)&pcdc->alt_setting, 1);
179 break;
180 case USB_STD_REQ_SET_INTERFACE:
181 pcdc->alt_setting = setup->wValue;
182 break;
183 case USB_STD_REQ_CLEAR_FEATURE:
184 break;
185 case USB_STD_REQ_SET_FEATURE:
186 break;
187 default:
188 usbd_ctrl_unsupport(pudev);
189 break;
190 }
191 break;
192 default:
193 usbd_ctrl_unsupport(pudev);
194 break;
195 }
196 return status;
197}
198
204static usb_sts_type class_ept0_tx_handler(void *udev)
205{
206 usb_sts_type status = USB_OK;
207
208 /* ...user code... */
209
210 return status;
211}
212
218static usb_sts_type class_ept0_rx_handler(void *udev)
219{
220 usb_sts_type status = USB_OK;
221 usbd_core_type *pudev = (usbd_core_type *)udev;
222 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
223 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
224 /* ...user code... */
225 if( pcdc->g_req == SET_LINE_CODING)
226 {
227 /* class process */
228 usb_vcp_cmd_process(udev, pcdc->g_req, pcdc->g_cmd, recv_len);
229 }
230
231 return status;
232}
233
240static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
241{
242 usbd_core_type *pudev = (usbd_core_type *)udev;
243 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
244 usb_sts_type status = USB_OK;
245
246 /* ...user code...
247 trans next packet data
248 */
249 pcdc->g_tx_completed = 1;
250
251 return status;
252}
253
260static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
261{
262 usb_sts_type status = USB_OK;
263 usbd_core_type *pudev = (usbd_core_type *)udev;
264 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
265
266 /* get endpoint receive data length */
267 pcdc->g_rxlen = usbd_get_recv_len(pudev, ept_num);
268
269 /*set recv flag*/
270 pcdc->g_rx_completed = 1;
271
272 return status;
273}
274
280static usb_sts_type class_sof_handler(void *udev)
281{
282 usb_sts_type status = USB_OK;
283
284 /* ...user code... */
285
286 return status;
287}
288
295static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
296{
297 usb_sts_type status = USB_OK;
298 switch(event)
299 {
300 case USBD_RESET_EVENT:
301
302 /* ...user code... */
303
304 break;
305 case USBD_SUSPEND_EVENT:
306
307 /* ...user code... */
308
309 break;
310 case USBD_WAKEUP_EVENT:
311 /* ...user code... */
312
313 break;
314 default:
315 break;
316 }
317 return status;
318}
319
325static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc)
326{
327 pcdc->g_tx_completed = 1;
328 pcdc->g_rx_completed = 0;
329 pcdc->alt_setting = 0;
330 pcdc->linecoding.bitrate = linecoding.bitrate;
331 pcdc->linecoding.data = linecoding.data;
332 pcdc->linecoding.format = linecoding.format;
333 pcdc->linecoding.parity = linecoding.parity;
334 return USB_OK;
335}
336
343uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
344{
345 uint16_t i_index = 0;
346 uint16_t tmp_len = 0;
347 usbd_core_type *pudev = (usbd_core_type *)udev;
348 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
349
350 if(pcdc->g_rx_completed == 0)
351 {
352 return 0;
353 }
354 pcdc->g_rx_completed = 0;
355 tmp_len = pcdc->g_rxlen;
356 for(i_index = 0; i_index < pcdc->g_rxlen; i_index ++)
357 {
358 recv_data[i_index] = pcdc->g_rx_buff[i_index];
359 }
360
361 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_OUT_MAXPACKET_SIZE);
362
363 return tmp_len;
364}
365
373 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
374{
375 error_status status = SUCCESS;
376 usbd_core_type *pudev = (usbd_core_type *)udev;
377 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
378 if(pcdc->g_tx_completed)
379 {
380 pcdc->g_tx_completed = 0;
381 usbd_ept_send(pudev, USBD_CDC_BULK_IN_EPT, send_data, len);
382 }
383 else
384 {
385 status = ERROR;
386 }
387 return status;
388}
389
390
399static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
400{
401 usbd_core_type *pudev = (usbd_core_type *)udev;
402 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
403 switch(cmd)
404 {
405 case SET_LINE_CODING:
406 pcdc->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
407 pcdc->linecoding.format = buff[4];
408 pcdc->linecoding.parity = buff[5];
409 pcdc->linecoding.data = buff[6];
410#ifdef USB_VIRTUAL_COMPORT
411 /* set hardware usart */
412 usb_usart_config(pcdc->linecoding);
413#endif
414 break;
415
416 case GET_LINE_CODING:
417 buff[0] = (uint8_t)pcdc->linecoding.bitrate;
418 buff[1] = (uint8_t)(pcdc->linecoding.bitrate >> 8);
419 buff[2] = (uint8_t)(pcdc->linecoding.bitrate >> 16);
420 buff[3] = (uint8_t)(pcdc->linecoding.bitrate >> 24);
421 buff[4] = (uint8_t)(pcdc->linecoding.format);
422 buff[5] = (uint8_t)(pcdc->linecoding.parity);
423 buff[6] = (uint8_t)(pcdc->linecoding.data);
424 break;
425
426 default:
427 break;
428 }
429}
430
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
EPT1_RX_ADDR
#define EPT1_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:76
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:75
EPT2_TX_ADDR
#define EPT2_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:78
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:61
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:60
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:53
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:51
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:52
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:59
USBD_CDC_IN_MAXPACKET_SIZE
#define USBD_CDC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_class.h:58
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_class.c:280
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_class.c:240
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_class.c:121
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_class.c:144
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:297
linecoding
linecoding_type linecoding
Definition: cdc_class.c:55
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_class.c:204
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:343
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_class.c:218
cdc_struct_init
static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc)
usb device cdc init
Definition: cdc_class.c:325
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_class.c:295
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function
Definition: cdc_class.c:399
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:373
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_class.c:86
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_class.c:260
cdc_struct
cdc_struct_type cdc_struct
Definition: cdc_class.c:64
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:67
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:203
GET_LINE_CODING
#define GET_LINE_CODING
Definition: cdc_msc_class.h:105
SET_LINE_CODING
#define SET_LINE_CODING
Definition: cdc_msc_class.h:104
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:70
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
cdc_struct_type
usb cdc class struct
Definition: cdc_class.h:74
cdc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_class.h:75
cdc_struct_type::g_req
uint8_t g_req
Definition: cdc_class.h:78
cdc_struct_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_class.h:79
cdc_struct_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_class.h:80
cdc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_class.h:81
cdc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_class.h:80
cdc_struct_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_class.h:77
cdc_struct_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_class.h:76
cdc_struct_type::g_len
uint16_t g_len
Definition: cdc_class.h:79
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:212
linecoding_type::data
uint8_t data
Definition: usb_std.h:215
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:214
linecoding_type::format
uint8_t format
Definition: usb_std.h:213
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_class.h Source File

  • middlewares
  • usbd_class
  • cdc
cdc_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CDC_CLASS_H
27#define __CDC_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
51#define USBD_CDC_INT_EPT 0x82
52#define USBD_CDC_BULK_IN_EPT 0x81
53#define USBD_CDC_BULK_OUT_EPT 0x01
54
58#define USBD_CDC_IN_MAXPACKET_SIZE 0x40
59#define USBD_CDC_OUT_MAXPACKET_SIZE 0x40
60#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08
61
73typedef struct
74{
75 uint32_t alt_setting;
76 uint8_t g_rx_buff[USBD_CDC_OUT_MAXPACKET_SIZE];
77 uint8_t g_cmd[USBD_CDC_CMD_MAXPACKET_SIZE];
78 uint8_t g_req;
79 uint16_t g_len, g_rxlen;
80 __IO uint8_t g_tx_completed, g_rx_completed;
81 linecoding_type linecoding;
82}cdc_struct_type;
83
84
92extern usbd_class_handler cdc_class_handler;
93uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data);
94 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
95
108#ifdef __cplusplus
109}
110#endif
111
112#endif
113
114
115
error_status
error_status
error status
Definition: at32f413.h:301
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:60
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:59
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:343
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:373
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:67
cdc_struct_type
usb cdc class struct
Definition: cdc_class.h:74
cdc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_class.h:75
cdc_struct_type::g_req
uint8_t g_req
Definition: cdc_class.h:78
cdc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_class.h:81
cdc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_class.h:80
cdc_struct_type::g_len
uint16_t g_len
Definition: cdc_class.h:79
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_desc.c Source File

  • middlewares
  • usbd_class
  • cdc
cdc_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "cdc_desc.h"
28
42static usbd_desc_t *get_device_descriptor(void);
43static usbd_desc_t *get_device_qualifier(void);
44static usbd_desc_t *get_device_configuration(void);
45static usbd_desc_t *get_device_other_speed(void);
46static usbd_desc_t *get_device_lang_id(void);
47static usbd_desc_t *get_device_manufacturer_string(void);
48static usbd_desc_t *get_device_product_string(void);
49static usbd_desc_t *get_device_serial_string(void);
50static usbd_desc_t *get_device_interface_string(void);
51static usbd_desc_t *get_device_config_string(void);
52
53static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
54static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
55static void get_serial_num(void);
56#if defined ( __ICCARM__ ) /* iar compiler */
57 #pragma data_alignment=4
58#endif
59ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
60
64 usbd_desc_handler cdc_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x02, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_CDC_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_CDC_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_CDC_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_CDC_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CDC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_CDC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_CDC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x02, /* bNumInterfaces: 2 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x00, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xC0, /* bmAttributes: self powered */
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x01, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
131 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
132 0x01, /* bInterfaceProtocol: protocol code, AT Command */
133 0x00, /* iInterface: index of string descriptor */
134
135 0x05, /* bFunctionLength: size of this descriptor in bytes */
136 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
137 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
138 LBYTE(CDC_BCD_NUM),
139 HBYTE(CDC_BCD_NUM), /* bcdCDC: USB class definitions for communications */
140
141 0x05, /* bFunctionLength: size of this descriptor in bytes */
142 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
143 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
144 0x00, /* bmCapabilities: 0x00*/
145 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
146
147 0x04, /* bFunctionLength: size of this descriptor in bytes */
148 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
149 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
150 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
151
152 0x05, /* bFunctionLength: size of this descriptor in bytes */
153 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
154 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
155 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
156 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
157
158 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
159 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
160 USBD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
161 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
162 LBYTE(USBD_CDC_CMD_MAXPACKET_SIZE),
163 HBYTE(USBD_CDC_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
164 CDC_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
165
166
167 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
168 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
169 0x01, /* bInterfaceNumber: number of interface */
170 0x00, /* bAlternateSetting: alternate set */
171 0x02, /* bNumEndpoints: number of endpoints */
172 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
173 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
174 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
175 0x00, /* iInterface: index of string descriptor */
176
177 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
178 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
179 USBD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
180 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
181 LBYTE(USBD_CDC_IN_MAXPACKET_SIZE),
182 HBYTE(USBD_CDC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
183 0x00, /* bInterval: interval for polling endpoint for data transfers */
184
185 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
186 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
187 USBD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
188 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
189 LBYTE(USBD_CDC_OUT_MAXPACKET_SIZE),
190 HBYTE(USBD_CDC_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
191 0x00, /* bInterval: interval for polling endpoint for data transfers */
192};
193
197#if defined ( __ICCARM__ ) /* iar compiler */
198 #pragma data_alignment=4
199#endif
200ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CDC_SIZ_STRING_LANGID] ALIGNED_TAIL =
201{
202 USBD_CDC_SIZ_STRING_LANGID,
203 USB_DESCIPTOR_TYPE_STRING,
204 0x09,
205 0x04,
206};
207
211#if defined ( __ICCARM__ ) /* iar compiler */
212 #pragma data_alignment=4
213#endif
214ALIGNED_HEAD static uint8_t g_string_serial[USBD_CDC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
215{
216 USBD_CDC_SIZ_STRING_SERIAL,
217 USB_DESCIPTOR_TYPE_STRING,
218};
219
220
221/* device descriptor */
222static usbd_desc_t device_descriptor =
223{
224 USB_DEVICE_DESC_LEN,
225 g_usbd_descriptor
226};
227
228/* config descriptor */
229static usbd_desc_t config_descriptor =
230{
231 USBD_CDC_CONFIG_DESC_SIZE,
232 g_usbd_configuration
233};
234
235/* langid descriptor */
236static usbd_desc_t langid_descriptor =
237{
238 USBD_CDC_SIZ_STRING_LANGID,
239 g_string_lang_id
240};
241
242/* serial descriptor */
243static usbd_desc_t serial_descriptor =
244{
245 USBD_CDC_SIZ_STRING_SERIAL,
246 g_string_serial
247};
248
249static usbd_desc_t vp_desc;
250
257static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
258{
259 uint16_t str_len = 0, id_pos = 2;
260 uint8_t *tmp_str = string;
261
262 while(*tmp_str != '\0')
263 {
264 str_len ++;
265 unicode_buf[id_pos ++] = *tmp_str ++;
266 unicode_buf[id_pos ++] = 0x00;
267 }
268
269 str_len = str_len * 2 + 2;
270 unicode_buf[0] = (uint8_t)str_len;
271 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
272
273 return str_len;
274}
275
283static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
284{
285 uint8_t idx = 0;
286
287 for( idx = 0 ; idx < len ; idx ++)
288 {
289 if( ((value >> 28)) < 0xA )
290 {
291 pbuf[ 2 * idx] = (value >> 28) + '0';
292 }
293 else
294 {
295 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
296 }
297
298 value = value << 4;
299
300 pbuf[2 * idx + 1] = 0;
301 }
302}
303
309static void get_serial_num(void)
310{
311 uint32_t serial0, serial1, serial2;
312
313 serial0 = *(uint32_t*)MCU_ID1;
314 serial1 = *(uint32_t*)MCU_ID2;
315 serial2 = *(uint32_t*)MCU_ID3;
316
317 serial0 += serial2;
318
319 if (serial0 != 0)
320 {
321 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
322 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
323 }
324}
325
331static usbd_desc_t *get_device_descriptor(void)
332{
333 return &device_descriptor;
334}
335
341static usbd_desc_t * get_device_qualifier(void)
342{
343 return NULL;
344}
345
351static usbd_desc_t *get_device_configuration(void)
352{
353 return &config_descriptor;
354}
355
361static usbd_desc_t *get_device_other_speed(void)
362{
363 return NULL;
364}
365
371static usbd_desc_t *get_device_lang_id(void)
372{
373 return &langid_descriptor;
374}
375
376
382static usbd_desc_t *get_device_manufacturer_string(void)
383{
384 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
385 vp_desc.descriptor = g_usbd_desc_buffer;
386 return &vp_desc;
387}
388
394static usbd_desc_t *get_device_product_string(void)
395{
396 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
397 vp_desc.descriptor = g_usbd_desc_buffer;
398 return &vp_desc;
399}
400
406static usbd_desc_t *get_device_serial_string(void)
407{
408 get_serial_num();
409 return &serial_descriptor;
410}
411
417static usbd_desc_t *get_device_interface_string(void)
418{
419 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
420 vp_desc.descriptor = g_usbd_desc_buffer;
421 return &vp_desc;
422}
423
429static usbd_desc_t *get_device_config_string(void)
430{
431 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
432 vp_desc.descriptor = g_usbd_desc_buffer;
433 return &vp_desc;
434}
435
cdc_desc.h
usb cdc descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:60
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:53
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:51
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:52
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:59
USBD_CDC_IN_MAXPACKET_SIZE
#define USBD_CDC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_class.h:58
CDC_BCD_NUM
#define CDC_BCD_NUM
usb bcd number define
Definition: cdc_desc.h:50
USBD_CDC_DESC_MANUFACTURER_STRING
#define USBD_CDC_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_desc.h:68
USBD_CDC_DESC_CONFIGURATION_STRING
#define USBD_CDC_DESC_CONFIGURATION_STRING
Definition: cdc_desc.h:70
USBD_CDC_SIZ_STRING_LANGID
#define USBD_CDC_SIZ_STRING_LANGID
Definition: cdc_desc.h:62
USBD_CDC_PRODUCT_ID
#define USBD_CDC_PRODUCT_ID
Definition: cdc_desc.h:56
USBD_CDC_DESC_PRODUCT_STRING
#define USBD_CDC_DESC_PRODUCT_STRING
Definition: cdc_desc.h:69
USBD_CDC_VENDOR_ID
#define USBD_CDC_VENDOR_ID
usb vendor id and product id define
Definition: cdc_desc.h:55
CDC_HID_BINTERVAL_TIME
#define CDC_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_desc.h:76
USBD_CDC_CONFIG_DESC_SIZE
#define USBD_CDC_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_desc.h:61
USBD_CDC_SIZ_STRING_SERIAL
#define USBD_CDC_SIZ_STRING_SERIAL
Definition: cdc_desc.h:63
USBD_CDC_DESC_INTERFACE_STRING
#define USBD_CDC_DESC_INTERFACE_STRING
Definition: cdc_desc.h:71
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_desc.c:243
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_desc.c:222
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_desc.c:351
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_desc.c:236
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_desc.c:331
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_desc.c:382
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_desc.c:341
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_desc.c:417
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_desc.c:249
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_desc.c:361
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_desc.c:59
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_desc.c:394
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_desc.c:429
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_desc.c:257
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_desc.c:371
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_desc.c:309
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_desc.c:229
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_desc.c:406
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_desc.c:283
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:197
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:175
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:196
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:190
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:165
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:160
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:199
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:198
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: cdc_desc.h Source File

  • middlewares
  • usbd_class
  • cdc
cdc_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CDC_DESC_H
27#define __CDC_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "cdc_class.h"
34#include "usbd_core.h"
35
50#define CDC_BCD_NUM 0x0110
51
55#define USBD_CDC_VENDOR_ID 0x2E3C
56#define USBD_CDC_PRODUCT_ID 0x5740
57
61#define USBD_CDC_CONFIG_DESC_SIZE 67
62#define USBD_CDC_SIZ_STRING_LANGID 4
63#define USBD_CDC_SIZ_STRING_SERIAL 0x1A
64
68#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
69#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
70#define USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
71#define USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
72
76#define CDC_HID_BINTERVAL_TIME 0xFF
77
81#define MCU_ID1 (0x1FFFF7E8)
82#define MCU_ID2 (0x1FFFF7EC)
83#define MCU_ID3 (0x1FFFF7F0)
88extern usbd_desc_handler cdc_desc_handler;
89
90
98#ifdef __cplusplus
99}
100#endif
101
102#endif
cdc_class.h
usb cdc class file
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_keyboard_class.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "cdc_keyboard_class.h"
26#include "cdc_keyboard_desc.h"
27
41static usb_sts_type class_init_handler(void *udev);
42static usb_sts_type class_clear_handler(void *udev);
43static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
44static usb_sts_type class_ept0_tx_handler(void *udev);
45static usb_sts_type class_ept0_rx_handler(void *udev);
46static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
47static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_sof_handler(void *udev);
49static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
50static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup);
51static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup);
52
53static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
54
55 vcp_keyboard_type vcp_keyboard_struct;
56
57#define SHIFT 0x80
58const static unsigned char _asciimap[128] =
59{
60 0x00,// NUL
61 0x00,// SOH
62 0x00,// STX
63 0x00,// ETX
64 0x00,// EOT
65 0x00,// ENQ
66 0x00,// ACK
67 0x00,// BEL
68 0x2A,// BS Backspace
69 0x2B,// TAB Tab
70 0x28,// LF Enter
71 0x00,// VT
72 0x00,// FF
73 0x00,// CR
74 0x00,// SO
75 0x00,// SI
76 0x00,// DEL
77 0x00,// DC1
78 0x00,// DC2
79 0x00,// DC3
80 0x00,// DC4
81 0x00,// NAK
82 0x00,// SYN
83 0x00,// ETB
84 0x00,// CAN
85 0x00,// EM
86 0x00,// SUB
87 0x00,// ESC
88 0x00,// FS
89 0x00,// GS
90 0x00,// RS
91 0x00,// US
92
93 0x2C,// ' '
94 0x1E|SHIFT,// !
95 0x34|SHIFT,// "
96 0x20|SHIFT,// #
97 0x21|SHIFT,// $
98 0x22|SHIFT,// %
99 0x24|SHIFT,// &
100 0x34, // '
101 0x26|SHIFT,// (
102 0x27|SHIFT,// )
103 0x25|SHIFT,// *
104 0x2E|SHIFT,// +
105 0x36,// ,
106 0x2D,// -
107 0x37,// .
108 0x38,// /
109 0x27,// 0
110 0x1E,// 1
111 0x1F,// 2
112 0x20,// 3
113 0x21,// 4
114 0x22,// 5
115 0x23,// 6
116 0x24,// 7
117 0x25,// 8
118 0x26,// 9
119 0x33|SHIFT,// :
120 0x33, // ;
121 0x36|SHIFT,// <
122 0x2E, // =
123 0x37|SHIFT,// >
124 0x38|SHIFT,// ?
125 0x1F|SHIFT,// @
126 0x04|SHIFT,// A
127 0x05|SHIFT,// B
128 0x06|SHIFT,// C
129 0x07|SHIFT,// D
130 0x08|SHIFT,// E
131 0x09|SHIFT,// F
132 0x0A|SHIFT,// G
133 0x0B|SHIFT,// H
134 0x0C|SHIFT,// I
135 0x0D|SHIFT,// J
136 0x0E|SHIFT,// K
137 0x0F|SHIFT,// L
138 0x10|SHIFT,// M
139 0x11|SHIFT,// N
140 0x12|SHIFT,// O
141 0x13|SHIFT,// P
142 0x14|SHIFT,// Q
143 0x15|SHIFT,// R
144 0x16|SHIFT,// S
145 0x17|SHIFT,// T
146 0x18|SHIFT,// U
147 0x19|SHIFT,// V
148 0x1A|SHIFT,// W
149 0x1B|SHIFT,// X
150 0x1C|SHIFT,// Y
151 0x1D|SHIFT,// Z
152 0x2F, // [
153 0x31, // bslash
154 0x30, // ]
155 0x23|SHIFT,// ^
156 0x2D|SHIFT,// _
157 0x35, // `
158 0x04, // a
159 0x05, // b
160 0x06, // c
161 0x07, // d
162 0x08, // e
163 0x09, // f
164 0x0A, // g
165 0x0B, // h
166 0x0C, // i
167 0x0D, // j
168 0x0E, // k
169 0x0F, // l
170 0x10, // m
171 0x11, // n
172 0x12, // o
173 0x13, // p
174 0x14, // q
175 0x15, // r
176 0x16, // s
177 0x17, // t
178 0x18, // u
179 0x19, // v
180 0x1A, // w
181 0x1B, // x
182 0x1C, // y
183 0x1D, // z
184 0x2f|SHIFT,//
185 0x31|SHIFT,// |
186 0x30|SHIFT,// }
187 0x35|SHIFT,// ~
188 0 // DEL
189};
190
191 linecoding_type linecoding_vcpkybrd =
192{
193 115200,
194 0x00,
195 0x00,
196 0x08
197};
198
199/* static variable */
200
201
202/* usb device class handler */
203 usbd_class_handler cdc_keyboard_class_handler =
204{
205 class_init_handler,
206 class_clear_handler,
207 class_setup_handler,
208 class_ept0_tx_handler,
209 class_ept0_rx_handler,
210 class_in_handler,
211 class_out_handler,
212 class_sof_handler,
213 class_event_handler,
214 &vcp_keyboard_struct
215};
216
222static usb_sts_type class_init_handler(void *udev)
223{
224 usb_sts_type status = USB_OK;
225 usbd_core_type *pudev = (usbd_core_type *)udev;
226 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
227#ifndef USB_EPT_AUTO_MALLOC_BUFFER
228 /* use user define buffer address */
229 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_CDC_INT_EPT, EPT2_TX_ADDR);
230 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, EPT1_TX_ADDR);
231 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, EPT1_RX_ADDR);
232 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_HID_IN_EPT, EPT3_TX_ADDR);
233#endif
234
235 /* open in endpoint */
236 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_INT_EPT, EPT_INT_TYPE, USBD_VCPKYBRD_CMD_MAXPACKET_SIZE);
237
238 /* open in endpoint */
239 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_VCPKYBRD_IN_MAXPACKET_SIZE);
240
241 /* open out endpoint */
242 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
243
244 /* open hid in endpoint */
245 usbd_ept_open(pudev, USBD_VCPKYBRD_HID_IN_EPT, EPT_INT_TYPE, USBD_VCPKYBRD_IN_MAXPACKET_SIZE);
246
247 /* set out endpoint to receive status */
248 usbd_ept_recv(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, vcpkybrd->g_rx_buff, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
249
250 vcpkybrd->g_tx_completed = 1;
251 vcpkybrd->g_keyboard_tx_completed = 1;
252
253 vcpkybrd->linecoding.bitrate = linecoding_vcpkybrd.bitrate;
254 vcpkybrd->linecoding.data = linecoding_vcpkybrd.data;
255 vcpkybrd->linecoding.format = linecoding_vcpkybrd.format;
256 vcpkybrd->linecoding.parity = linecoding_vcpkybrd.parity;
257 return status;
258}
259
265static usb_sts_type class_clear_handler(void *udev)
266{
267 usb_sts_type status = USB_OK;
268 usbd_core_type *pudev = (usbd_core_type *)udev;
269
270 /* close in endpoint */
271 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_INT_EPT);
272
273 /* close in endpoint */
274 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT);
275
276 /* close out endpoint */
277 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT);
278
279 /* close in endpoint */
280 usbd_ept_close(pudev, USBD_VCPKYBRD_HID_IN_EPT);
281
282 return status;
283}
284
291static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
292{
293 usb_sts_type status = USB_OK;
294 usbd_core_type *pudev = (usbd_core_type *)udev;
295 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
296 {
297 case USB_REQ_RECIPIENT_INTERFACE:
298 if(setup->wIndex == VCPKYBRD_KEYBOARD_INTERFACE)
299 {
300 keyboard_class_setup_handler(pudev, setup);
301 }
302 else
303 {
304 cdc_class_setup_handler(pudev, setup);
305 }
306 break;
307 case USB_REQ_RECIPIENT_ENDPOINT:
308 break;
309
310 }
311 return status;
312}
313
320static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
321{
322 usb_sts_type status = USB_OK;
323 usbd_core_type *pudev = (usbd_core_type *)udev;
324 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
325
326 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
327 {
328 /* class request */
329 case USB_REQ_TYPE_CLASS:
330 if(setup->wLength)
331 {
332 if(setup->bmRequestType & USB_REQ_DIR_DTH)
333 {
334 usb_vcp_cmd_process(udev, setup->bRequest, vcpkybrd->g_cmd, setup->wLength);
335 usbd_ctrl_send(pudev, vcpkybrd->g_cmd, setup->wLength);
336 }
337 else
338 {
339 vcpkybrd->g_req = setup->bRequest;
340 vcpkybrd->g_len = setup->wLength;
341 usbd_ctrl_recv(pudev, vcpkybrd->g_cmd, vcpkybrd->g_len);
342
343 }
344 }
345 break;
346 /* standard request */
347 case USB_REQ_TYPE_STANDARD:
348 switch(setup->bRequest)
349 {
350 case USB_STD_REQ_GET_DESCRIPTOR:
351 usbd_ctrl_unsupport(pudev);
352 break;
353 case USB_STD_REQ_GET_INTERFACE:
354 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->alt_setting, 1);
355 break;
356 case USB_STD_REQ_SET_INTERFACE:
357 vcpkybrd->alt_setting = setup->wValue;
358 break;
359 case USB_STD_REQ_CLEAR_FEATURE:
360 break;
361 case USB_STD_REQ_SET_FEATURE:
362 break;
363 default:
364 usbd_ctrl_unsupport(pudev);
365 break;
366 }
367 break;
368 default:
369 usbd_ctrl_unsupport(pudev);
370 break;
371 }
372 return status;
373}
374
381static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup)
382{
383 usb_sts_type status = USB_OK;
384 usbd_core_type *pudev = (usbd_core_type *)udev;
385 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
386 uint16_t len;
387 uint8_t *buf;
388
389 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
390 {
391 /* class request */
392 case USB_REQ_TYPE_CLASS:
393 switch(setup->bRequest)
394 {
395 case HID_REQ_SET_PROTOCOL:
396 vcpkybrd->hid_protocol = (uint8_t)setup->wValue;
397 break;
398 case HID_REQ_GET_PROTOCOL:
399 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->hid_protocol, 1);
400 break;
401 case HID_REQ_SET_IDLE:
402 vcpkybrd->hid_set_idle = (uint8_t)(setup->wValue >> 8);
403 break;
404 case HID_REQ_GET_IDLE:
405 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->hid_set_idle, 1);
406 break;
407 case HID_REQ_SET_REPORT:
408 vcpkybrd->hid_state = HID_REQ_SET_REPORT;
409 usbd_ctrl_recv(pudev, vcpkybrd->hid_set_report, setup->wLength);
410 break;
411 default:
412 usbd_ctrl_unsupport(pudev);
413 break;
414 }
415 break;
416 /* standard request */
417 case USB_REQ_TYPE_STANDARD:
418 switch(setup->bRequest)
419 {
420 case USB_STD_REQ_GET_DESCRIPTOR:
421 if(setup->wValue >> 8 == HID_REPORT_DESC)
422 {
423 len = MIN(USBD_VCPKYBRD_HID_SIZ_REPORT_DESC, setup->wLength);
424 buf = (uint8_t *)g_usbd_vcpkybrd_hid_report;
425 }
426 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
427 {
428 len = MIN(9, setup->wLength);
429 buf = (uint8_t *)g_vcpkybrd_hid_usb_desc;
430 }
431 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
432 break;
433 case USB_STD_REQ_GET_INTERFACE:
434 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->alt_setting, 1);
435 break;
436 case USB_STD_REQ_SET_INTERFACE:
437 vcpkybrd->alt_setting = setup->wValue;
438 break;
439 case USB_STD_REQ_CLEAR_FEATURE:
440 break;
441 case USB_STD_REQ_SET_FEATURE:
442 break;
443 default:
444 usbd_ctrl_unsupport(pudev);
445 break;
446 }
447 break;
448 default:
449 usbd_ctrl_unsupport(pudev);
450 break;
451 }
452 return status;
453}
454
460static usb_sts_type class_ept0_tx_handler(void *udev)
461{
462 usb_sts_type status = USB_OK;
463
464 /* ...user code... */
465
466 return status;
467}
468
474static usb_sts_type class_ept0_rx_handler(void *udev)
475{
476 usb_sts_type status = USB_OK;
477 usbd_core_type *pudev = (usbd_core_type *)udev;
478 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
479 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
480 /* ...user code... */
481 if( vcpkybrd->g_req == SET_LINE_CODING)
482 {
483 /* class process */
484 usb_vcp_cmd_process(udev, vcpkybrd->g_req, vcpkybrd->g_cmd, recv_len);
485 }
486
487 if( vcpkybrd->hid_state == HID_REQ_SET_REPORT)
488 {
489 /* hid buffer process */
490 vcpkybrd->hid_state = 0;
491 }
492 return status;
493}
494
501static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
502{
503 usb_sts_type status = USB_OK;
504 usbd_core_type *pudev = (usbd_core_type *)udev;
505 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
506
507 /* ...user code...
508 trans next packet data
509 */
510 if((ept_num & 0x7F) == (USBD_VCPKYBRD_CDC_BULK_IN_EPT & 0x7F))
511 {
512 vcpkybrd->g_tx_completed = 1;
513 }
514 if((ept_num & 0x7F) == (USBD_VCPKYBRD_HID_IN_EPT & 0x7F))
515 {
516 vcpkybrd->g_keyboard_tx_completed = 1;
517 }
518
519
520 return status;
521}
522
529static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
530{
531 usb_sts_type status = USB_OK;
532 usbd_core_type *pudev = (usbd_core_type *)udev;
533 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
534
535 /* get endpoint receive data length */
536 vcpkybrd->g_rxlen = usbd_get_recv_len(pudev, ept_num);
537
538 /*set recv flag*/
539 vcpkybrd->g_rx_completed = 1;
540
541 return status;
542}
543
549static usb_sts_type class_sof_handler(void *udev)
550{
551 usb_sts_type status = USB_OK;
552
553 /* ...user code... */
554
555 return status;
556}
557
564static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
565{
566 usb_sts_type status = USB_OK;
567 switch(event)
568 {
569 case USBD_RESET_EVENT:
570
571 /* ...user code... */
572
573 break;
574 case USBD_SUSPEND_EVENT:
575
576 /* ...user code... */
577
578 break;
579 case USBD_WAKEUP_EVENT:
580 /* ...user code... */
581
582 break;
583 default:
584 break;
585 }
586 return status;
587}
588
595uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
596{
597 uint16_t i_index = 0;
598 usbd_core_type *pudev = (usbd_core_type *)udev;
599 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
600 uint16_t tmp_len = 0;
601
602 if(vcpkybrd->g_rx_completed == 0)
603 {
604 return 0;
605 }
606 vcpkybrd->g_rx_completed = 0;
607
608 tmp_len = vcpkybrd->g_rxlen;
609 for(i_index = 0; i_index < vcpkybrd->g_rxlen; i_index ++)
610 {
611 recv_data[i_index] = vcpkybrd->g_rx_buff[i_index];
612 }
613
614 usbd_ept_recv(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, vcpkybrd->g_rx_buff, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
615
616 return tmp_len;
617}
618
626 error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
627{
628 error_status status = SUCCESS;
629 usbd_core_type *pudev = (usbd_core_type *)udev;
630 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
631 if(vcpkybrd->g_tx_completed)
632 {
633 vcpkybrd->g_tx_completed = 0;
634 usbd_ept_send(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, send_data, len);
635 }
636 else
637 {
638 status = ERROR;
639 }
640 return status;
641}
642
643
652static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
653{
654 usbd_core_type *pudev = (usbd_core_type *)udev;
655 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
656 switch(cmd)
657 {
658 case SET_LINE_CODING:
659 vcpkybrd->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
660 vcpkybrd->linecoding.format = buff[4];
661 vcpkybrd->linecoding.parity = buff[5];
662 vcpkybrd->linecoding.data = buff[6];
663 break;
664
665 case GET_LINE_CODING:
666 buff[0] = (uint8_t)vcpkybrd->linecoding.bitrate;
667 buff[1] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 8);
668 buff[2] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 16);
669 buff[3] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 24);
670 buff[4] = (uint8_t)(vcpkybrd->linecoding.format);
671 buff[5] = (uint8_t)(vcpkybrd->linecoding.parity);
672 buff[6] = (uint8_t)(vcpkybrd->linecoding.data);
673 break;
674
675 default:
676 break;
677 }
678}
679
687 usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
688{
689 usb_sts_type status = USB_OK;
690 usbd_core_type *pudev = (usbd_core_type *)udev;
691
692 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
693 usbd_ept_send(pudev, USBD_VCPKYBRD_HID_IN_EPT, report, len);
694
695 return status;
696}
697
698
705void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
706{
707 uint8_t key_data = 0;
708 static uint8_t temp = 0;
709 static uint8_t keyboard_buf[8] = {0, 0, 6, 0, 0, 0, 0, 0};
710
711 if(ascii_code > 128)
712 {
713 ascii_code = 0;
714 }
715 else
716 {
717 ascii_code = _asciimap[ascii_code];
718 if(!ascii_code)
719 {
720 ascii_code = 0;
721 }
722
723 if(ascii_code & SHIFT)
724 {
725 key_data = 0x2;
726 ascii_code &= 0x7F;
727 }
728 }
729
730 if((temp == ascii_code) && (ascii_code != 0))
731 {
732 keyboard_buf[0] = 0;
733 keyboard_buf[2] = 0;
734 usb_vcpkybrd_class_send_report(udev, keyboard_buf, 8);
735 }
736 else
737 {
738 keyboard_buf[0] = key_data;
739 keyboard_buf[2] = ascii_code;
740 usb_vcpkybrd_class_send_report(udev, keyboard_buf, 8);
741 }
742}
743
cdc_keyboard_class.h
usb cdc and keyboard class file
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
EPT3_TX_ADDR
#define EPT3_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:81
EPT1_RX_ADDR
#define EPT1_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:76
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:75
EPT2_TX_ADDR
#define EPT2_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:78
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:61
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:61
USBD_VCPKYBRD_HID_IN_EPT
#define USBD_VCPKYBRD_HID_IN_EPT
Definition: cdc_keyboard_class.h:54
USBD_VCPKYBRD_IN_MAXPACKET_SIZE
#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE
usb in and out max packet size define
Definition: cdc_keyboard_class.h:59
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:60
USBD_VCPKYBRD_CDC_INT_EPT
#define USBD_VCPKYBRD_CDC_INT_EPT
usb use endpoint define
Definition: cdc_keyboard_class.h:51
USBD_VCPKYBRD_CDC_BULK_IN_EPT
#define USBD_VCPKYBRD_CDC_BULK_IN_EPT
Definition: cdc_keyboard_class.h:52
USBD_VCPKYBRD_CDC_BULK_OUT_EPT
#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT
Definition: cdc_keyboard_class.h:53
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_keyboard_class.c:549
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:626
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_keyboard_class.c:501
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:705
usb_vcpkybrd_class_send_report
usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: cdc_keyboard_class.c:687
_asciimap
static const unsigned char _asciimap[128]
Definition: cdc_keyboard_class.c:58
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_keyboard_class.c:265
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:291
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_keyboard_class.c:460
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_keyboard_class.c:474
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:203
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_keyboard_class.c:564
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function
Definition: cdc_keyboard_class.c:652
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_keyboard_class.c:222
cdc_class_setup_handler
static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:320
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_keyboard_class.c:529
SHIFT
#define SHIFT
Definition: cdc_keyboard_class.c:57
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:595
vcp_keyboard_struct
vcp_keyboard_type vcp_keyboard_struct
Definition: cdc_keyboard_class.c:55
keyboard_class_setup_handler
static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:381
linecoding_vcpkybrd
linecoding_type linecoding_vcpkybrd
Definition: cdc_keyboard_class.c:191
VCPKYBRD_KEYBOARD_INTERFACE
#define VCPKYBRD_KEYBOARD_INTERFACE
Definition: cdc_keyboard_desc.h:86
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:64
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:264
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:245
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:203
GET_LINE_CODING
#define GET_LINE_CODING
Definition: cdc_msc_class.h:105
SET_LINE_CODING
#define SET_LINE_CODING
Definition: cdc_msc_class.h:104
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:234
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:229
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:228
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:235
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:230
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:231
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:70
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:232
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:56
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:54
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:53
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:212
linecoding_type::data
uint8_t data
Definition: usb_std.h:215
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:214
linecoding_type::format
uint8_t format
Definition: usb_std.h:213
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:294
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
vcp_keyboard_type
Definition: cdc_keyboard_class.h:73
vcp_keyboard_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_keyboard_class.h:80
vcp_keyboard_type::g_len
uint16_t g_len
Definition: cdc_keyboard_class.h:83
vcp_keyboard_type::hid_state
uint8_t hid_state
Definition: cdc_keyboard_class.h:82
vcp_keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: cdc_keyboard_class.h:76
vcp_keyboard_type::alt_setting
uint32_t alt_setting
Definition: cdc_keyboard_class.h:74
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:86
vcp_keyboard_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_keyboard_class.h:83
vcp_keyboard_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_keyboard_class.h:84
vcp_keyboard_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_keyboard_class.h:79
vcp_keyboard_type::g_req
uint8_t g_req
Definition: cdc_keyboard_class.h:81
vcp_keyboard_type::hid_set_report
uint8_t hid_set_report[64]
Definition: cdc_keyboard_class.h:78
vcp_keyboard_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::linecoding
linecoding_type linecoding
Definition: cdc_keyboard_class.h:88
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_keyboard_class.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CDC_KEYBOARD_CLASS_H
27#define __CDC_KEYBOARD_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
51#define USBD_VCPKYBRD_CDC_INT_EPT 0x82
52#define USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
53#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
54#define USBD_VCPKYBRD_HID_IN_EPT 0x83
55
59#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
60#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
61#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08
62
63
72typedef struct
73{
74 uint32_t alt_setting;
75 uint32_t hid_protocol;
76 uint32_t hid_set_idle;
77
78 uint8_t hid_set_report[64];
79 uint8_t g_rx_buff[USBD_VCPKYBRD_OUT_MAXPACKET_SIZE];
80 uint8_t g_cmd[USBD_VCPKYBRD_CMD_MAXPACKET_SIZE];
81 uint8_t g_req;
82 uint8_t hid_state;
83 uint16_t g_len, g_rxlen;
84 __IO uint8_t g_tx_completed;
85 __IO uint8_t g_rx_completed;
86 __IO uint8_t g_keyboard_tx_completed;
87
88 linecoding_type linecoding;
89}vcp_keyboard_type;
90
98extern usbd_class_handler cdc_keyboard_class_handler;
99uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data);
100 error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
101 usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len);
102void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code);
103
115#ifdef __cplusplus
116}
117#endif
118
119#endif
120
121
122
123
error_status
error_status
error status
Definition: at32f413.h:301
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:626
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:705
usb_vcpkybrd_class_send_report
usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: cdc_keyboard_class.c:687
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:203
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:595
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:61
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:60
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
vcp_keyboard_type
Definition: cdc_keyboard_class.h:73
vcp_keyboard_type::g_len
uint16_t g_len
Definition: cdc_keyboard_class.h:83
vcp_keyboard_type::hid_state
uint8_t hid_state
Definition: cdc_keyboard_class.h:82
vcp_keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: cdc_keyboard_class.h:76
vcp_keyboard_type::alt_setting
uint32_t alt_setting
Definition: cdc_keyboard_class.h:74
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:86
vcp_keyboard_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_keyboard_class.h:84
vcp_keyboard_type::g_req
uint8_t g_req
Definition: cdc_keyboard_class.h:81
vcp_keyboard_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::linecoding
linecoding_type linecoding
Definition: cdc_keyboard_class.h:88
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_keyboard_desc.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "cdc_keyboard_desc.h"
41static usbd_desc_t *get_device_descriptor(void);
42static usbd_desc_t *get_device_qualifier(void);
43static usbd_desc_t *get_device_configuration(void);
44static usbd_desc_t *get_device_other_speed(void);
45static usbd_desc_t *get_device_lang_id(void);
46static usbd_desc_t *get_device_manufacturer_string(void);
47static usbd_desc_t *get_device_product_string(void);
48static usbd_desc_t *get_device_serial_string(void);
49static usbd_desc_t *get_device_interface_string(void);
50static usbd_desc_t *get_device_config_string(void);
51
52static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
53static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
54static void get_serial_num(void);
55#if defined ( __ICCARM__ ) /* iar compiler */
56 #pragma data_alignment=4
57#endif
58ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
59
63 usbd_desc_handler cdc_keyboard_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0xEF, /* bDeviceClass */
90 0x02, /* bDeviceSubClass */
91 0x01, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_VCPKYBRD_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_VCPKYBRD_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_VCPKYBRD_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_VCPKYBRD_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 1 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_VCPKYBRD_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_VCPKYBRD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_VCPKYBRD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x03, /* bNumInterfaces: 2 interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xC0, /* bmAttributes: self powered */
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 0x08, /* bLength */
125 0x0B, /* bDescriptorType */
126 0x00, /* bFirstInterface */
127 0x02, /* bInterfaceCount */
128 0x02, /* bFunctionClass */
129 0x02, /* bFunctionSubClass */
130 0x01, /* bFunctionProtocol */
131 0x00, /* iFunction (Index of string descriptor describing this function) */
132
133 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
134 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
135 VCPKYBRD_CDC_INTERFACE, /* bInterfaceNumber: number of interface */
136 0x00, /* bAlternateSetting: alternate set */
137 0x01, /* bNumEndpoints: number of endpoints */
138 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
139 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
140 0x01, /* bInterfaceProtocol: protocol code, AT Command */
141 0x00, /* iInterface: index of string descriptor */
142
143 0x05, /* bFunctionLength: size of this descriptor in bytes */
144 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
145 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
146 LBYTE(VCPKYBRD_BCD_NUM),
147 HBYTE(VCPKYBRD_BCD_NUM), /* bcdCDC: USB class definitions for communications */
148
149 0x05, /* bFunctionLength: size of this descriptor in bytes */
150 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
151 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
152 0x00, /* bmCapabilities: 0x00*/
153 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
154
155 0x04, /* bFunctionLength: size of this descriptor in bytes */
156 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
157 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
158 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
159
160 0x05, /* bFunctionLength: size of this descriptor in bytes */
161 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
162 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
163 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
164 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
165
166 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
167 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
168 USBD_VCPKYBRD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
169 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
170 LBYTE(USBD_VCPKYBRD_CMD_MAXPACKET_SIZE),
171 HBYTE(USBD_VCPKYBRD_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
172 VCPKYBRD_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
173
174
175 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
176 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
177 VCPKYBRD_CDC_DATA_INTERFACE, /* bInterfaceNumber: number of interface */
178 0x00, /* bAlternateSetting: alternate set */
179 0x02, /* bNumEndpoints: number of endpoints */
180 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
181 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
182 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
183 0x00, /* iInterface: index of string descriptor */
184
185 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
186 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
187 USBD_VCPKYBRD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
188 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
189 LBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),
190 HBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
191 0x00, /* bInterval: interval for polling endpoint for data transfers */
192
193 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
194 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
195 USBD_VCPKYBRD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
196 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
197 LBYTE(USBD_VCPKYBRD_OUT_MAXPACKET_SIZE),
198 HBYTE(USBD_VCPKYBRD_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
199 0x00, /* bInterval: interval for polling endpoint for data transfers */
200
201 0x08, /* bLength */
202 0x0B, /* bDescriptorType */
203 0x02, /* bFirstInterface */
204 0x01, /* bInterfaceCount */
205 0x03, /* bFunctionClass */
206 0x00, /* bFunctionSubClass */
207 0x01, /* bFunctionProtocol */
208 0x00, /* iFunction (Index of string descriptor describing this function) */
209
210 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
211 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
212 VCPKYBRD_KEYBOARD_INTERFACE, /* bInterfaceNumber: number of interface */
213 0x00, /* bAlternateSetting: alternate set */
214 0x01, /* bNumEndpoints: number of endpoints */
215 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
216 0x01, /* bInterfaceSubClass: subclass code */
217 0x01, /* bInterfaceProtocol: protocol code */
218 0x00, /* iInterface: index of string descriptor */
219
220 0x09, /* bLength: size of HID descriptor in bytes */
221 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
222 LBYTE(VCPKYBRD_BCD_NUM),
223 HBYTE(VCPKYBRD_BCD_NUM), /* bcdHID: HID class specification release number */
224 0x00, /* bCountryCode: hardware target conutry */
225 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
226 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
227 LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
228 HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
229
230 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
231 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
232 USBD_VCPKYBRD_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
233 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
234 LBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),
235 HBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
236 VCPKYBRD_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
237};
238
242#if defined ( __ICCARM__ ) /* iar compiler */
243 #pragma data_alignment=4
244#endif
245ALIGNED_HEAD uint8_t g_vcpkybrd_hid_usb_desc[9] ALIGNED_TAIL =
246{
247 0x09, /* bLength: size of HID descriptor in bytes */
248 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
249 LBYTE(VCPKYBRD_BCD_NUM),
250 HBYTE(VCPKYBRD_BCD_NUM), /* bcdHID: HID class specification release number */
251 0x00, /* bCountryCode: hardware target conutry */
252 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
253 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
254 LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
255 HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
256};
257
261#if defined ( __ICCARM__ ) /* iar compiler */
262 #pragma data_alignment=4
263#endif
264ALIGNED_HEAD uint8_t g_usbd_vcpkybrd_hid_report[USBD_VCPKYBRD_HID_SIZ_REPORT_DESC] ALIGNED_TAIL =
265{
266 0x05, 0x01, // USAGE_PAGE (Generic Desktop)
267 0x09, 0x06, // USAGE (Keyboard)
268 0xa1, 0x01, // COLLECTION (Application)
269 0x05, 0x07, // USAGE_PAGE (Keyboard)
270 0x19, 0xe0, // USAGE_MINIMUM (Keyboard LeftControl)
271 0x29, 0xe7, // USAGE_MAXIMUM (Keyboard Right GUI)
272 0x15, 0x00, // LOGICAL_MINIMUM (0)
273 0x25, 0x01, // LOGICAL_MAXIMUM (1)
274 0x75, 0x01, // REPORT_SIZE (1)
275 0x95, 0x08, // REPORT_COUNT (8)
276 0x81, 0x02, // INPUT (Data,Var,Abs)
277 0x95, 0x01, // REPORT_COUNT (1)
278 0x75, 0x08, // REPORT_SIZE (8)
279 0x81, 0x03, // INPUT (Cnst,Var,Abs)
280 0x95, 0x05, // REPORT_COUNT (5)
281 0x75, 0x01, // REPORT_SIZE (1)
282 0x05, 0x08, // USAGE_PAGE (LEDs)
283 0x19, 0x01, // USAGE_MINIMUM (Num Lock)
284 0x29, 0x05, // USAGE_MAXIMUM (Kana)
285 0x91, 0x02, // OUTPUT (Data,Var,Abs)
286 0x95, 0x01, // REPORT_COUNT (1)
287 0x75, 0x03, // REPORT_SIZE (3)
288 0x91, 0x03, // OUTPUT (Cnst,Var,Abs)
289 0x95, 0x06, // REPORT_COUNT (6)
290 0x75, 0x08, // REPORT_SIZE (8)
291 0x15, 0x00, // LOGICAL_MINIMUM (0)
292 0x25, 0xFF, // LOGICAL_MAXIMUM (255)
293 0x05, 0x07, // USAGE_PAGE (Keyboard)
294 0x19, 0x00, // USAGE_MINIMUM (Reserved (no event indicated))
295 0x29, 0x65, // USAGE_MAXIMUM (Keyboard Application)
296 0x81, 0x00, // INPUT (Data,Ary,Abs)
297 0xc0 // END_COLLECTION
298};
302#if defined ( __ICCARM__ ) /* iar compiler */
303 #pragma data_alignment=4
304#endif
305ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_VCPKYBRD_SIZ_STRING_LANGID] ALIGNED_TAIL =
306{
307 USBD_VCPKYBRD_SIZ_STRING_LANGID,
308 USB_DESCIPTOR_TYPE_STRING,
309 0x09,
310 0x04,
311};
312
316#if defined ( __ICCARM__ ) /* iar compiler */
317 #pragma data_alignment=4
318#endif
319ALIGNED_HEAD static uint8_t g_string_serial[USBD_VCPKYBRD_SIZ_STRING_SERIAL] ALIGNED_TAIL =
320{
321 USBD_VCPKYBRD_SIZ_STRING_SERIAL,
322 USB_DESCIPTOR_TYPE_STRING,
323};
324
325
326/* device descriptor */
327static usbd_desc_t device_descriptor =
328{
329 USB_DEVICE_DESC_LEN,
330 g_usbd_descriptor
331};
332
333/* config descriptor */
334static usbd_desc_t config_descriptor =
335{
336 USBD_VCPKYBRD_CONFIG_DESC_SIZE,
337 g_usbd_configuration
338};
339
340/* langid descriptor */
341static usbd_desc_t langid_descriptor =
342{
343 USBD_VCPKYBRD_SIZ_STRING_LANGID,
344 g_string_lang_id
345};
346
347/* serial descriptor */
348static usbd_desc_t serial_descriptor =
349{
350 USBD_VCPKYBRD_SIZ_STRING_SERIAL,
351 g_string_serial
352};
353
354static usbd_desc_t vp_desc;
355
362static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
363{
364 uint16_t str_len = 0, id_pos = 2;
365 uint8_t *tmp_str = string;
366
367 while(*tmp_str != '\0')
368 {
369 str_len ++;
370 unicode_buf[id_pos ++] = *tmp_str ++;
371 unicode_buf[id_pos ++] = 0x00;
372 }
373
374 str_len = str_len * 2 + 2;
375 unicode_buf[0] = str_len;
376 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
377
378 return str_len;
379}
380
388static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
389{
390 uint8_t idx = 0;
391
392 for( idx = 0 ; idx < len ; idx ++)
393 {
394 if( ((value >> 28)) < 0xA )
395 {
396 pbuf[ 2 * idx] = (value >> 28) + '0';
397 }
398 else
399 {
400 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
401 }
402
403 value = value << 4;
404
405 pbuf[2 * idx + 1] = 0;
406 }
407}
408
414static void get_serial_num(void)
415{
416 uint32_t serial0, serial1, serial2;
417
418 serial0 = *(uint32_t*)MCU_ID1;
419 serial1 = *(uint32_t*)MCU_ID2;
420 serial2 = *(uint32_t*)MCU_ID3;
421
422 serial0 += serial2;
423
424 if (serial0 != 0)
425 {
426 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
427 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
428 }
429}
430
436static usbd_desc_t *get_device_descriptor(void)
437{
438 return &device_descriptor;
439}
440
446static usbd_desc_t * get_device_qualifier(void)
447{
448 return NULL;
449}
450
456static usbd_desc_t *get_device_configuration(void)
457{
458 return &config_descriptor;
459}
460
466static usbd_desc_t *get_device_other_speed(void)
467{
468 return NULL;
469}
470
476static usbd_desc_t *get_device_lang_id(void)
477{
478 return &langid_descriptor;
479}
480
481
487static usbd_desc_t *get_device_manufacturer_string(void)
488{
489 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
490 vp_desc.descriptor = g_usbd_desc_buffer;
491 return &vp_desc;
492}
493
499static usbd_desc_t *get_device_product_string(void)
500{
501 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
502 vp_desc.descriptor = g_usbd_desc_buffer;
503 return &vp_desc;
504}
505
511static usbd_desc_t *get_device_serial_string(void)
512{
513 get_serial_num();
514 return &serial_descriptor;
515}
516
522static usbd_desc_t *get_device_interface_string(void)
523{
524 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
525 vp_desc.descriptor = g_usbd_desc_buffer;
526 return &vp_desc;
527}
528
534static usbd_desc_t *get_device_config_string(void)
535{
536 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
537 vp_desc.descriptor = g_usbd_desc_buffer;
538 return &vp_desc;
539}
540
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:61
USBD_VCPKYBRD_HID_IN_EPT
#define USBD_VCPKYBRD_HID_IN_EPT
Definition: cdc_keyboard_class.h:54
USBD_VCPKYBRD_IN_MAXPACKET_SIZE
#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE
usb in and out max packet size define
Definition: cdc_keyboard_class.h:59
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:60
USBD_VCPKYBRD_CDC_INT_EPT
#define USBD_VCPKYBRD_CDC_INT_EPT
usb use endpoint define
Definition: cdc_keyboard_class.h:51
USBD_VCPKYBRD_CDC_BULK_IN_EPT
#define USBD_VCPKYBRD_CDC_BULK_IN_EPT
Definition: cdc_keyboard_class.h:52
USBD_VCPKYBRD_CDC_BULK_OUT_EPT
#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT
Definition: cdc_keyboard_class.h:53
USBD_VCPKYBRD_DESC_INTERFACE_STRING
#define USBD_VCPKYBRD_DESC_INTERFACE_STRING
Definition: cdc_keyboard_desc.h:74
VCPKYBRD_CDC_INTERFACE
#define VCPKYBRD_CDC_INTERFACE
usb interface define
Definition: cdc_keyboard_desc.h:84
VCPKYBRD_KEYBOARD_INTERFACE
#define VCPKYBRD_KEYBOARD_INTERFACE
Definition: cdc_keyboard_desc.h:86
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:64
USBD_VCPKYBRD_DESC_MANUFACTURER_STRING
#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_keyboard_desc.h:71
USBD_VCPKYBRD_PRODUCT_ID
#define USBD_VCPKYBRD_PRODUCT_ID
Definition: cdc_keyboard_desc.h:57
VCPKYBRD_BCD_NUM
#define VCPKYBRD_BCD_NUM
usb bcd number define
Definition: cdc_keyboard_desc.h:51
VCPKYBRD_CDC_DATA_INTERFACE
#define VCPKYBRD_CDC_DATA_INTERFACE
Definition: cdc_keyboard_desc.h:85
USBD_VCPKYBRD_DESC_CONFIGURATION_STRING
#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING
Definition: cdc_keyboard_desc.h:73
USBD_VCPKYBRD_CONFIG_DESC_SIZE
#define USBD_VCPKYBRD_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_keyboard_desc.h:63
VCPKYBRD_HID_BINTERVAL_TIME
#define VCPKYBRD_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_keyboard_desc.h:79
USBD_VCPKYBRD_SIZ_STRING_SERIAL
#define USBD_VCPKYBRD_SIZ_STRING_SERIAL
Definition: cdc_keyboard_desc.h:66
USBD_VCPKYBRD_VENDOR_ID
#define USBD_VCPKYBRD_VENDOR_ID
usb vendor id and product id define
Definition: cdc_keyboard_desc.h:56
USBD_VCPKYBRD_SIZ_STRING_LANGID
#define USBD_VCPKYBRD_SIZ_STRING_LANGID
Definition: cdc_keyboard_desc.h:65
USBD_VCPKYBRD_DESC_PRODUCT_STRING
#define USBD_VCPKYBRD_DESC_PRODUCT_STRING
Definition: cdc_keyboard_desc.h:72
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_keyboard_desc.c:348
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_keyboard_desc.c:327
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_keyboard_desc.c:456
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_keyboard_desc.c:341
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_keyboard_desc.c:436
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_keyboard_desc.c:487
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_keyboard_desc.c:446
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_keyboard_desc.c:522
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_keyboard_desc.c:354
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:264
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_keyboard_desc.c:466
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_keyboard_desc.c:58
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_keyboard_desc.c:499
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_keyboard_desc.c:534
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_keyboard_desc.c:362
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:63
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_keyboard_desc.c:476
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_keyboard_desc.c:414
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:245
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_keyboard_desc.c:334
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_keyboard_desc.c:511
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_keyboard_desc.c:388
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:197
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:175
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:196
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:190
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:165
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:160
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:161
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:199
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:198
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: cdc_keyboard_desc.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CDC_KEYBOARD_DESC_H
27#define __CDC_KEYBOARD_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "cdc_keyboard_class.h"
34#include "usbd_core.h"
35
51#define VCPKYBRD_BCD_NUM 0x0110
52
56#define USBD_VCPKYBRD_VENDOR_ID 0x2E3C
57#define USBD_VCPKYBRD_PRODUCT_ID 0x5750
58
59
63#define USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
64#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
65#define USBD_VCPKYBRD_SIZ_STRING_LANGID 4
66#define USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
67
71#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
72#define USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
73#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
74#define USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
75
79#define VCPKYBRD_HID_BINTERVAL_TIME 0x0A
80
84#define VCPKYBRD_CDC_INTERFACE 0x00
85#define VCPKYBRD_CDC_DATA_INTERFACE 0x01
86#define VCPKYBRD_KEYBOARD_INTERFACE 0x02
87
91#define MCU_ID1 (0x1FFFF7E8)
92#define MCU_ID2 (0x1FFFF7EC)
93#define MCU_ID3 (0x1FFFF7F0)
94
98extern uint8_t g_usbd_vcpkybrd_hid_report[USBD_VCPKYBRD_HID_SIZ_REPORT_DESC];
99extern uint8_t g_vcpkybrd_hid_usb_desc[9];
100extern usbd_desc_handler cdc_keyboard_desc_handler;
101
102
110#ifdef __cplusplus
111}
112#endif
113
114#endif
cdc_keyboard_class.h
usb cdc and keyboard class file
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:64
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:264
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:245
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:63
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_msc_class.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "cdc_msc_class.h"
26#include "cdc_msc_desc.h"
27
41static usb_sts_type class_init_handler(void *udev);
42static usb_sts_type class_clear_handler(void *udev);
43static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
44static usb_sts_type class_ept0_tx_handler(void *udev);
45static usb_sts_type class_ept0_rx_handler(void *udev);
46static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
47static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_sof_handler(void *udev);
49static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
50
51static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc);
52extern void usb_usart_config( linecoding_type linecoding);
53static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
54
55static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup);
56static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup);
57
58 linecoding_type linecoding =
59{
60 115200,
61 0,
62 0,
63 8
64};
65
66/* cdc data struct */
67 cdc_msc_struct_type cdc_msc_struct;
68
69/* usb device class handler */
70 usbd_class_handler cdc_msc_class_handler =
71{
72 class_init_handler,
73 class_clear_handler,
74 class_setup_handler,
75 class_ept0_tx_handler,
76 class_ept0_rx_handler,
77 class_in_handler,
78 class_out_handler,
79 class_sof_handler,
80 class_event_handler,
81 &cdc_msc_struct //cdc_struct
82};
88static usb_sts_type class_init_handler(void *udev)
89{
90 usb_sts_type status = USB_OK;
91 usbd_core_type *pudev = (usbd_core_type *)udev;
92 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
93
94 /* init cdc struct */
95 cdc_struct_init(pcdcmsc);
96
97 /* open in endpoint */
98 usbd_ept_open(pudev, USBD_CDC_INT_EPT, EPT_INT_TYPE, USBD_CDC_CMD_MAXPACKET_SIZE);
99
100 /* open in endpoint */
101 usbd_ept_open(pudev, USBD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
102
103 /* open out endpoint */
104 usbd_ept_open(pudev, USBD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
105
106 /* set out endpoint to receive status */
107 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdcmsc->g_rx_buff, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
108
109 /* open in endpoint */
110 usbd_ept_open(pudev, USBD_MSC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
111
112 /* open out endpoint */
113 usbd_ept_open(pudev, USBD_MSC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
114
115 bot_scsi_init(udev);
116
117 return status;
118}
119
125static usb_sts_type class_clear_handler(void *udev)
126{
127 usb_sts_type status = USB_OK;
128 usbd_core_type *pudev = (usbd_core_type *)udev;
129
130 /* close in endpoint */
131 usbd_ept_close(pudev, USBD_CDC_INT_EPT);
132
133 /* close in endpoint */
134 usbd_ept_close(pudev, USBD_CDC_BULK_IN_EPT);
135
136 /* close out endpoint */
137 usbd_ept_close(pudev, USBD_CDC_BULK_OUT_EPT);
138
139 /* close in endpoint */
140 usbd_ept_close(pudev, USBD_MSC_BULK_IN_EPT);
141
142 /* close out endpoint */
143 usbd_ept_close(pudev, USBD_MSC_BULK_OUT_EPT);
144
145 return status;
146}
147
154static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
155{
156 usb_sts_type status = USB_OK;
157 usbd_core_type *pudev = (usbd_core_type *)udev;
158 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
159 {
160 case USB_REQ_RECIPIENT_INTERFACE:
161 if(setup->wIndex == VCPMSC_MSC_INTERFACE)
162 {
163 msc_class_setup_handler(udev, setup);
164 }
165 else
166 {
167 cdc_class_setup_handler(pudev, setup);
168 }
169 break;
170 case USB_REQ_RECIPIENT_ENDPOINT:
171 if(setup->wIndex == (USBD_MSC_BULK_IN_EPT | USBD_MSC_BULK_OUT_EPT))
172 {
173 msc_class_setup_handler(udev, setup);
174 }
175 else
176 {
177 cdc_class_setup_handler(pudev, setup);
178 }
179 break;
180
181 }
182 return status;
183}
184
191static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
192{
193 usb_sts_type status = USB_OK;
194 usbd_core_type *pudev = (usbd_core_type *)udev;
195 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
196
197 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
198 {
199 /* class request */
200 case USB_REQ_TYPE_CLASS:
201 if(setup->wLength)
202 {
203 if(setup->bmRequestType & USB_REQ_DIR_DTH)
204 {
205 usb_vcp_cmd_process(udev, setup->bRequest, pcdc->g_cmd, setup->wLength);
206 usbd_ctrl_send(pudev, pcdc->g_cmd, setup->wLength);
207 }
208 else
209 {
210 pcdc->g_req = setup->bRequest;
211 pcdc->g_len = setup->wLength;
212 usbd_ctrl_recv(pudev, pcdc->g_cmd, pcdc->g_len);
213
214 }
215 }
216 break;
217 /* standard request */
218 case USB_REQ_TYPE_STANDARD:
219 switch(setup->bRequest)
220 {
221 case USB_STD_REQ_GET_DESCRIPTOR:
222 usbd_ctrl_unsupport(pudev);
223 break;
224 case USB_STD_REQ_GET_INTERFACE:
225 usbd_ctrl_send(pudev, (uint8_t *)&pcdc->alt_setting, 1);
226 break;
227 case USB_STD_REQ_SET_INTERFACE:
228 pcdc->alt_setting = setup->wValue;
229 break;
230 case USB_STD_REQ_CLEAR_FEATURE:
231 break;
232 case USB_STD_REQ_SET_FEATURE:
233 break;
234 default:
235 usbd_ctrl_unsupport(pudev);
236 break;
237 }
238 break;
239 default:
240 usbd_ctrl_unsupport(pudev);
241 break;
242 }
243 return status;
244}
245
252static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup)
253{
254 usb_sts_type status = USB_OK;
255 usbd_core_type *pudev = (usbd_core_type *)udev;
256 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
257 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
258 {
259 /* class request */
260 case USB_REQ_TYPE_CLASS:
261
262 switch(setup->bRequest)
263 {
264 case MSC_REQ_GET_MAX_LUN:
265 usbd_ctrl_send(pudev, (uint8_t *)&cdc_msc_struct.max_lun, 1);
266 break;
267 case MSC_REQ_BO_RESET:
268 bot_scsi_reset(udev);
269 usbd_ctrl_send_status(pudev);
270 break;
271 default:
272 usbd_ctrl_unsupport(pudev);
273 break;
274
275 }
276 break;
277 /* standard request */
278 case USB_REQ_TYPE_STANDARD:
279
280 switch(setup->bRequest)
281 {
282 case USB_STD_REQ_GET_DESCRIPTOR:
283 usbd_ctrl_unsupport(pudev);
284 break;
285 case USB_STD_REQ_GET_INTERFACE:
286 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->alt_setting, 1);
287 break;
288 case USB_STD_REQ_SET_INTERFACE:
289 pmsc->alt_setting = setup->wValue;
290 break;
291 case USB_STD_REQ_CLEAR_FEATURE:
292 usbd_ept_close(pudev, (uint8_t)setup->wIndex);
293
294 if((setup->wIndex & 0x80) == 0x80)
295 {
296 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
297 }
298 else
299 {
300 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
301 }
302 bot_scsi_clear_feature(udev, setup->wIndex);
303 break;
304 case USB_STD_REQ_SET_FEATURE:
305 break;
306 default:
307 usbd_ctrl_unsupport(pudev);
308 break;
309 }
310 break;
311 default:
312 usbd_ctrl_unsupport(pudev);
313 break;
314 }
315 return status;
316}
317
323static usb_sts_type class_ept0_tx_handler(void *udev)
324{
325 usb_sts_type status = USB_OK;
326
327 /* ...user code... */
328
329 return status;
330}
331
337static usb_sts_type class_ept0_rx_handler(void *udev)
338{
339 usb_sts_type status = USB_OK;
340 usbd_core_type *pudev = (usbd_core_type *)udev;
341 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
342 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
343 /* ...user code... */
344 if( pcdc->g_req == SET_LINE_CODING)
345 {
346 /* class process */
347 usb_vcp_cmd_process(udev, pcdc->g_req, pcdc->g_cmd, recv_len);
348 }
349
350 return status;
351}
352
359static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
360{
361 usbd_core_type *pudev = (usbd_core_type *)udev;
362 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
363 usb_sts_type status = USB_OK;
364
365 /* ...user code...
366 trans next packet data
367 */
368
369 if((ept_num & 0x7F) == (USBD_CDC_BULK_IN_EPT & 0x7F))
370 {
371 pcdcmsc->g_tx_completed = 1;
372 }
373 if((ept_num & 0x7F) == (USBD_MSC_BULK_IN_EPT & 0x7F))
374 {
375 bot_scsi_datain_handler(udev, ept_num);
376 }
377
378 return status;
379}
380
387static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
388{
389 usb_sts_type status = USB_OK;
390 usbd_core_type *pudev = (usbd_core_type *)udev;
391 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
392
393
394
395 if((ept_num & 0x7F) == (USBD_CDC_BULK_OUT_EPT & 0x7F))
396 {
397 /* get endpoint receive data length */
398 pcdcmsc->g_rxlen = usbd_get_recv_len(pudev, ept_num);
399
400 /*set recv flag*/
401 pcdcmsc->g_rx_completed = 1;
402 }
403 if((ept_num & 0x7F) == (USBD_MSC_BULK_OUT_EPT & 0x7F))
404 {
405 bot_scsi_dataout_handler(udev, ept_num);
406 }
407
408 return status;
409}
410
416static usb_sts_type class_sof_handler(void *udev)
417{
418 usb_sts_type status = USB_OK;
419
420 /* ...user code... */
421
422 return status;
423}
424
431static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
432{
433 usb_sts_type status = USB_OK;
434 switch(event)
435 {
436 case USBD_RESET_EVENT:
437
438 /* ...user code... */
439
440 break;
441 case USBD_SUSPEND_EVENT:
442
443 /* ...user code... */
444
445 break;
446 case USBD_WAKEUP_EVENT:
447 /* ...user code... */
448
449 break;
450 default:
451 break;
452 }
453 return status;
454}
455
461static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc)
462{
463 pcdc->g_tx_completed = 1;
464 pcdc->g_rx_completed = 0;
465 pcdc->alt_setting = 0;
466 pcdc->linecoding.bitrate = linecoding.bitrate;
467 pcdc->linecoding.data = linecoding.data;
468 pcdc->linecoding.format = linecoding.format;
469 pcdc->linecoding.parity = linecoding.parity;
470 return USB_OK;
471}
472
479uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
480{
481 uint16_t i_index = 0;
482 uint16_t tmp_len = 0;
483 usbd_core_type *pudev = (usbd_core_type *)udev;
484 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
485
486 if(pcdc->g_rx_completed == 0)
487 {
488 return 0;
489 }
490 pcdc->g_rx_completed = 0;
491 tmp_len = pcdc->g_rxlen;
492 for(i_index = 0; i_index < pcdc->g_rxlen; i_index ++)
493 {
494 recv_data[i_index] = pcdc->g_rx_buff[i_index];
495 }
496
497 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
498
499 return tmp_len;
500}
501
509 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
510{
511 error_status status = SUCCESS;
512 usbd_core_type *pudev = (usbd_core_type *)udev;
513 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
514 if(pcdc->g_tx_completed)
515 {
516 pcdc->g_tx_completed = 0;
517 usbd_ept_send(pudev, USBD_CDC_BULK_IN_EPT, send_data, len);
518 }
519 else
520 {
521 status = ERROR;
522 }
523 return status;
524}
525
534static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
535{
536 usbd_core_type *pudev = (usbd_core_type *)udev;
537 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
538 switch(cmd)
539 {
540 case SET_LINE_CODING:
541 pcdc->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
542 pcdc->linecoding.format = buff[4];
543 pcdc->linecoding.parity = buff[5];
544 pcdc->linecoding.data = buff[6];
545#ifdef USB_VIRTUAL_COMPORT
546 /* set hardware usart */
547 usb_usart_config(pcdc->linecoding);
548#endif
549 break;
550
551 case GET_LINE_CODING:
552 buff[0] = (uint8_t)pcdc->linecoding.bitrate;
553 buff[1] = (uint8_t)(pcdc->linecoding.bitrate >> 8);
554 buff[2] = (uint8_t)(pcdc->linecoding.bitrate >> 16);
555 buff[3] = (uint8_t)(pcdc->linecoding.bitrate >> 24);
556 buff[4] = (uint8_t)(pcdc->linecoding.format);
557 buff[5] = (uint8_t)(pcdc->linecoding.parity);
558 buff[6] = (uint8_t)(pcdc->linecoding.data);
559 break;
560
561 default:
562 break;
563 }
564}
565
cdc_msc_class.h
usb cdc class file
cdc_msc_desc.h
usb cdc descriptor header file
cdc_msc_struct_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_msc_class.h:258
cdc_msc_struct_type::g_req
uint8_t g_req
Definition: cdc_msc_class.h:256
cdc_msc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:253
cdc_msc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_msc_class.h:259
cdc_msc_struct_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_msc_class.h:254
cdc_msc_struct_type::g_len
uint16_t g_len
Definition: cdc_msc_class.h:257
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:264
cdc_msc_struct_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_msc_class.h:255
cdc_msc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_msc_class.h:258
cdc_msc_struct_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_msc_class.h:257
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:60
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:63
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:53
USBD_CDC_MSC_IN_MAXPACKET_SIZE
#define USBD_CDC_MSC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_msc_class.h:61
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:51
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:52
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:55
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:56
VCPMSC_MSC_INTERFACE
#define VCPMSC_MSC_INTERFACE
usb interface define
Definition: cdc_msc_desc.h:82
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:143
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:125
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:102
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:172
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:729
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_msc_class.c:416
cdc_msc_struct
cdc_msc_struct_type cdc_msc_struct
Definition: cdc_msc_class.c:67
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_msc_class.c:359
cdc_struct_init
static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc)
usb device cdc init
Definition: cdc_msc_class.c:461
msc_class_setup_handler
static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:252
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_msc_class.c:125
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:154
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:297
linecoding
linecoding_type linecoding
Definition: cdc_msc_class.c:58
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_msc_class.c:323
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_msc_class.c:479
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_msc_class.c:337
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_msc_class.c:431
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function
Definition: cdc_msc_class.c:534
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_msc_class.c:509
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_msc_class.c:88
cdc_class_setup_handler
static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:191
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_msc_class.c:387
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:70
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:203
MSC_REQ_BO_RESET
#define MSC_REQ_BO_RESET
Definition: cdc_msc_class.h:102
GET_LINE_CODING
#define GET_LINE_CODING
Definition: cdc_msc_class.h:105
SET_LINE_CODING
#define SET_LINE_CODING
Definition: cdc_msc_class.h:104
MSC_REQ_GET_MAX_LUN
#define MSC_REQ_GET_MAX_LUN
Definition: cdc_msc_class.h:101
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:70
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:56
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:54
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:53
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:209
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:251
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:212
linecoding_type::data
uint8_t data
Definition: usb_std.h:215
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:214
linecoding_type::format
uint8_t format
Definition: usb_std.h:213
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:294
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_msc_class.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CDC_MSC_CLASS_H
27#define __CDC_MSC_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
51#define USBD_CDC_INT_EPT 0x82
52#define USBD_CDC_BULK_IN_EPT 0x83
53#define USBD_CDC_BULK_OUT_EPT 0x02
54
55#define USBD_MSC_BULK_IN_EPT 0x81
56#define USBD_MSC_BULK_OUT_EPT 0x01
57
61#define USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
62
63#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
64#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08
65
66
67
68
81#define MSC_SUPPORT_MAX_LUN 1
82#define MSC_MAX_DATA_BUF_LEN 4096
83
84#define MSC_CMD_FORMAT_UNIT 0x04
85#define MSC_CMD_INQUIRY 0x12
86#define MSC_CMD_START_STOP 0x1B
87#define MSC_CMD_MODE_SENSE6 0x1A
88#define MSC_CMD_MODE_SENSE10 0x5A
89#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
90#define MSC_CMD_READ_10 0x28
91#define MSC_CMD_READ_12 0xA8
92#define MSC_CMD_READ_CAPACITY 0x25
93#define MSC_CMD_READ_FORMAT_CAPACITY 0x23
94#define MSC_CMD_REQUEST_SENSE 0x03
95#define MSC_CMD_TEST_UNIT 0x00
96#define MSC_CMD_VERIFY 0x2F
97#define MSC_CMD_WRITE_10 0x2A
98#define MSC_CMD_WRITE_12 0xAA
99#define MSC_CMD_WRITE_VERIFY 0x2E
100
101#define MSC_REQ_GET_MAX_LUN 0xFE
102#define MSC_REQ_BO_RESET 0xFF
104#define SET_LINE_CODING 0x20
105#define GET_LINE_CODING 0x21
106
107#define CBW_CMD_LENGTH 31
108#define CBW_DCBWSIGNATURE 0x43425355
109#define CBW_BMCBWFLAGS_DIR_OUT 0x00
110#define CBW_BMCBWFLAGS_DIR_IN 0x80
111
112#define CSW_CMD_LENGTH 13
113#define CSW_DCSWSIGNATURE 0x53425355
114#define CSW_BCSWSTATUS_PASS 0x00
115#define CSW_BCSWSTATUS_FAILED 0x01
116#define CSW_BCSWSTATUS_PHASE_ERR 0x02
117
118#define MSC_STATE_MACHINE_CMD 0x00
119#define MSC_STATE_MACHINE_DATA_IN 0x01
120#define MSC_STATE_MACHINE_DATA_OUT 0x02
121#define MSC_STATE_MACHINE_SEND_DATA 0x03
122#define MSC_STATE_MACHINE_LAST_DATA 0x04
123#define MSC_STATE_MACHINE_STATUS 0x05
124#define MSC_STATE_MACHINE_FAILED 0x06
125#define MSC_STATE_MACHINE_IDLE 0x07
126
127#define MSC_BOT_STATE_IDLE 0x00
128#define MSC_BOT_STATE_RECOVERY 0x01
129#define MSC_BOT_STATE_ERROR 0x02
130
131#define REQ_SENSE_STANDARD_DATA_LEN 0x12
132#define SENSE_KEY_NO_SENSE 0x00
133#define SENSE_KEY_RECOVERED_ERROR 0x01
134#define SENSE_KEY_NOT_READY 0x02
135#define SENSE_KEY_MEDIUM_ERROR 0x03
136#define SENSE_KEY_HARDWARE_ERROR 0x04
137#define SENSE_KEY_ILLEGAL_REQUEST 0x05
138#define SENSE_KEY_UNIT_ATTENTION 0x06
139#define SENSE_KEY_DATA_PROTECT 0x07
140#define SENSE_KEY_BLANK_CHECK 0x08
141#define SENSE_KEY_VENDERO_SPECIFIC 0x09
142#define SENSE_KEY_ABORTED_COMMAND 0x0B
143#define SENSE_KEY_VOLUME_OVERFLOW 0x0D
144#define SENSE_KEY_MISCOMPARE 0x0E
145
146
147#define INVALID_COMMAND 0x20
148#define INVALID_FIELED_IN_COMMAND 0x24
149#define PARAMETER_LIST_LENGTH_ERROR 0x1A
150#define INVALID_FIELD_IN_PARAMETER_LIST 0x26
151#define ADDRESS_OUT_OF_RANGE 0x21
152#define MEDIUM_NOT_PRESENT 0x3A
153#define MEDIUM_HAVE_CHANGED 0x28
154
155#define SCSI_INQUIRY_DATA_LENGTH 36
156
160typedef struct
161{
162 uint8_t opcode;
163 uint8_t lun;
164 uint32_t address;
165 uint8_t reserved1;
166 uint32_t alloc_length;
167 uint16_t reserved2;
168}cbd_typical_type;
169
173typedef struct
174{
175 uint8_t opcode;
176 uint8_t lun;
177 uint32_t address;
178 uint8_t reserved1;
179 uint32_t alloc_length;
180 uint16_t reserved2;
181}cbd_extended_type;
182
186typedef struct
187{
188 uint32_t dCBWSignature;
189 uint32_t dCBWTage;
190 uint32_t dCBWDataTransferLength;
191 uint8_t bmCBWFlags;
192 uint8_t bCBWLUN;
193 uint8_t bCBWCBLength;
194 uint8_t CBWCB[16];
195}cbw_type;
196
200typedef struct
201{
202 uint32_t dCSWSignature;
203 uint32_t dCSWTag;
204 uint32_t dCSWDataResidue;
205 uint32_t bCSWStatus;
206}csw_type;
207
211typedef struct
212{
213 uint8_t err_code;
214 uint8_t reserved1;
215 uint8_t sense_key;
216 uint32_t information;
217 uint8_t as_length;
218 uint32_t reserved2;
219 uint8_t asc;
220 uint8_t ascq;
221 uint32_t reserved3;
222}sense_type;
223
224
225typedef struct
226{
227 uint8_t msc_state;
228 uint8_t bot_status;
229 uint32_t max_lun;
230
231 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
232 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
233
234 uint32_t blk_addr;
235 uint32_t blk_len;
236
237 uint32_t data_len;
238 uint8_t data[MSC_MAX_DATA_BUF_LEN];
239
240 uint32_t alt_setting;
241
242 cbw_type cbw_struct;
243 csw_type csw_struct;
244
245}msc_type;
246
250typedef struct
251{
252 //used for CDC
253 uint32_t alt_setting;
254 uint8_t g_rx_buff[USBD_CDC_MSC_OUT_MAXPACKET_SIZE];
255 uint8_t g_cmd[USBD_CDC_CMD_MAXPACKET_SIZE];
256 uint8_t g_req;
257 uint16_t g_len, g_rxlen;
258 __IO uint8_t g_tx_completed, g_rx_completed;
259 linecoding_type linecoding;
260
261 //used for MSC
262 uint8_t msc_state;
263 uint8_t bot_status;
264 uint32_t max_lun;
265
266 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
267 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
268
269 uint64_t blk_addr;
270 uint32_t blk_len;
271
272 uint32_t data_len;
273 uint8_t data[MSC_MAX_DATA_BUF_LEN];
274
275 cbw_type cbw_struct;
276 csw_type csw_struct;
277}cdc_msc_struct_type; //cdc_struct_type;
278
279
287extern usbd_class_handler cdc_msc_class_handler; //cdc_class_handler;
288uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data);
289 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
290
291void bot_scsi_init(void *udev);
292void bot_scsi_reset(void *udev);
293void bot_scsi_datain_handler(void *pudev, uint8_t ept_num);
294void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num);
295void bot_cbw_decode(void *udev);
296void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len);
297void bot_scsi_send_csw(void *udev, uint8_t status);
298void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc);
299 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count);
300void bot_scsi_stall(void *udev);
301 usb_sts_type bot_scsi_cmd_process(void *udev);
302
303 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun);
304 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun);
305 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun);
306 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun);
307 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun);
308 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun);
309 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun);
310 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun);
311 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun);
312 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun);
313 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun);
314 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun);
315void bot_scsi_clear_feature(void *udev, uint8_t ept_num);
316
328#ifdef __cplusplus
329}
330#endif
331
332#endif
333
334
335
336
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
cdc_msc_struct_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:275
cbd_typical_type::opcode
uint8_t opcode
Definition: cdc_msc_class.h:162
cbd_typical_type::address
uint32_t address
Definition: cdc_msc_class.h:164
cbd_typical_type::alloc_length
uint32_t alloc_length
Definition: cdc_msc_class.h:166
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:192
msc_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:242
sense_type::err_code
uint8_t err_code
Definition: cdc_msc_class.h:213
cdc_msc_struct_type::g_req
uint8_t g_req
Definition: cdc_msc_class.h:256
sense_type::ascq
uint8_t ascq
Definition: cdc_msc_class.h:220
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:193
cdc_msc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:253
cdc_msc_struct_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:262
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:202
cbd_typical_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:165
sense_type::reserved3
uint32_t reserved3
Definition: cdc_msc_class.h:221
cbd_extended_type::alloc_length
uint32_t alloc_length
Definition: cdc_msc_class.h:179
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:205
cdc_msc_struct_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:270
sense_type::asc
uint8_t asc
Definition: cdc_msc_class.h:219
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:203
cbd_extended_type::opcode
uint8_t opcode
Definition: cdc_msc_class.h:175
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:204
cbd_extended_type::address
uint32_t address
Definition: cdc_msc_class.h:177
cdc_msc_struct_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:276
msc_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:243
msc_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:235
sense_type::as_length
uint8_t as_length
Definition: cdc_msc_class.h:217
sense_type::reserved2
uint32_t reserved2
Definition: cdc_msc_class.h:218
cdc_msc_struct_type::blk_addr
uint64_t blk_addr
Definition: cdc_msc_class.h:269
msc_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:234
cbd_extended_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:178
cbd_extended_type::reserved2
uint16_t reserved2
Definition: cdc_msc_class.h:180
cdc_msc_struct_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:272
cdc_msc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_msc_class.h:259
sense_type::sense_key
uint8_t sense_key
Definition: cdc_msc_class.h:215
cbd_typical_type::lun
uint8_t lun
Definition: cdc_msc_class.h:163
cbd_typical_type::reserved2
uint16_t reserved2
Definition: cdc_msc_class.h:167
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:229
msc_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:228
cbd_extended_type::lun
uint8_t lun
Definition: cdc_msc_class.h:176
msc_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:227
sense_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:214
msc_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:240
cdc_msc_struct_type::g_len
uint16_t g_len
Definition: cdc_msc_class.h:257
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:190
sense_type::information
uint32_t information
Definition: cdc_msc_class.h:216
msc_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:237
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:264
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:189
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:188
cdc_msc_struct_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:263
cdc_msc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_msc_class.h:258
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:191
error_status
error_status
error status
Definition: at32f413.h:301
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_msc_class.h:64
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:63
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: msc/msc_bot_scsi.c:504
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:143
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: msc/msc_bot_scsi.c:409
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: msc/msc_bot_scsi.c:539
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:343
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: msc/msc_bot_scsi.c:598
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: msc/msc_bot_scsi.c:303
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: msc/msc_bot_scsi.c:659
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:125
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: msc/msc_bot_scsi.c:457
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: msc/msc_bot_scsi.c:288
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: msc/msc_bot_scsi.c:196
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: msc/msc_bot_scsi.c:570
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: msc/msc_bot_scsi.c:423
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:373
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:102
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: msc/msc_bot_scsi.c:749
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:172
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: msc/msc_bot_scsi.c:437
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: msc/msc_bot_scsi.c:320
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: msc/msc_bot_scsi.c:243
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: msc/msc_bot_scsi.c:346
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: msc/msc_bot_scsi.c:368
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: msc/msc_bot_scsi.c:477
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:70
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:729
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: msc/msc_bot_scsi.c:264
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:82
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:81
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
cbd_extended_type
extended command block description
Definition: cdc_msc_class.h:174
cbd_typical_type
typical command block description
Definition: cdc_msc_class.h:161
cbw_type
command block wrapper
Definition: cdc_msc_class.h:187
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:251
csw_type
command block wrapper
Definition: cdc_msc_class.h:201
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
msc_type
Definition: cdc_msc_class.h:226
sense_type
request sense standard data
Definition: cdc_msc_class.h:212
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_msc_desc.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_desc.c
Go to the documentation of this file.
1
24#include "stdio.h"
25#include "usb_std.h"
26#include "usbd_sdr.h"
27#include "usbd_core.h"
28#include "cdc_msc_desc.h"
29
43#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B
44
45static usbd_desc_t *get_device_descriptor(void);
46static usbd_desc_t *get_device_qualifier(void);
47static usbd_desc_t *get_device_configuration(void);
48static usbd_desc_t *get_device_other_speed(void);
49static usbd_desc_t *get_device_lang_id(void);
50static usbd_desc_t *get_device_manufacturer_string(void);
51static usbd_desc_t *get_device_product_string(void);
52static usbd_desc_t *get_device_serial_string(void);
53static usbd_desc_t *get_device_interface_string(void);
54static usbd_desc_t *get_device_config_string(void);
55
56static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
57static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
58static void get_serial_num(void);
59#if defined ( __ICCARM__ ) /* iar compiler */
60 #pragma data_alignment=4
61#endif
62ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
63
67 usbd_desc_handler cdc_msc_desc_handler =
68{
69 get_device_descriptor,
70 get_device_qualifier,
71 get_device_configuration,
72 get_device_other_speed,
73 get_device_lang_id,
74 get_device_manufacturer_string,
75 get_device_product_string,
76 get_device_serial_string,
77 get_device_interface_string,
78 get_device_config_string,
79};
80
84#if defined ( __ICCARM__ ) /* iar compiler */
85 #pragma data_alignment=4
86#endif
87ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
88{
89 USB_DEVICE_DESC_LEN, /* bLength */
90 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
91 0x00, /* bcdUSB */
92 0x02,
93 0xEF, /* bDeviceClass */
94 0x02, /* bDeviceSubClass */
95 0x01, /* bDeviceProtocol */
96 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
97 LBYTE(USBD_CDC_MSC_VENDOR_ID), /* idVendor */
98 HBYTE(USBD_CDC_MSC_VENDOR_ID), /* idVendor */
99 LBYTE(USBD_CDC_MSC_PRODUCT_ID), /* idProduct */
100 HBYTE(USBD_CDC_MSC_PRODUCT_ID), /* idProduct */
101 0x00, /* bcdDevice rel. 2.00 */
102 0x02,
103 USB_MFC_STRING, /* Index of manufacturer string */
104 USB_PRODUCT_STRING, /* Index of product string */
105 USB_SERIAL_STRING, /* Index of serial number string */
106 1 /* bNumConfigurations */
107};
108
112#if defined ( __ICCARM__ ) /* iar compiler */
113 #pragma data_alignment=4
114#endif
115ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CDC_MSC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
116{
117 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
118 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
119 LBYTE(USBD_CDC_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
120 HBYTE(USBD_CDC_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
121 0x03, /* bNumInterfaces: 3 interface */
122 0x01, /* bConfigurationValue: configuration value */
123 0x00, /* iConfiguration: index of string descriptor describing
124 the configuration */
125 0xC0, /* bmAttributes: self powered */
126 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
127
128 // IAD (Interface Association Descriptor) for MSC
129 0x08, /* bLength */
130 USB_INTERFACE_ASSOCIATION_TYPE, /* bDescriptorType */
131 0x00, /* bFirstInterface */
132 0x01, /* bInterfaceCount */
133 0x08, /* bFunctionClass */
134 0x06, /* bFunctionSubClass */
135 0x50, /* bFunctionProtocol */
136 0x00, /* iFunction (Index of string descriptor describing this function) */
137
138 // Configuration Descriptor for MSC
139 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
140 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
141 VCPMSC_MSC_INTERFACE, /* bInterfaceNumber: number of interface */
142 0x00, /* bAlternateSetting: alternate set */
143 0x02, /* bNumEndpoints: number of endpoints */
144 USB_CLASS_CODE_MSC, /* bInterfaceClass: msc class code */
145 0x06, /* bInterfaceSubClass: subclass code scsi */
146 0x50, /* bInterfaceProtocol: protocol code BBB */
147 0x00, /* iInterface: index of string descriptor */
148
149 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
150 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
151 USBD_MSC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
152 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
153 LBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE),
154 HBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
155 0x00, /* bInterval: interval for polling endpoint for data transfers */
156
157 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
158 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
159 USBD_MSC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
160 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
161 LBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),
162 HBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
163 0x00, /* bInterval: interval for polling endpoint for data transfers */
164
165 // IAD (Interface Association Descriptor) for CDC
166 0x08, /* bLength */
167 USB_INTERFACE_ASSOCIATION_TYPE, /* bDescriptorType */
168 0x01, /* bFirstInterface */
169 0x02, /* bInterfaceCount */
170 USB_CLASS_CODE_CDC, /* bFunctionClass */
171 0x02, /* bFunctionSubClass */
172 0x01, /* bFunctionProtocol */
173 0x00, /* iFunction (Index of string descriptor describing this function) */
174
175 // Configuration Descriptor for CDC
176 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
177 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
178 VCPMSC_CDC_INTERFACE, /* bInterfaceNumber: number of interface */
179 0x00, /* bAlternateSetting: alternate set */
180 0x01, /* bNumEndpoints: number of endpoints */
181 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
182 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
183 0x01, /* bInterfaceProtocol: protocol code, AT Command */
184 0x00, /* iInterface: index of string descriptor */
185
186 0x05, /* bFunctionLength: size of this descriptor in bytes */
187 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
188 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
189 LBYTE(CDC_BCD_NUM),
190 HBYTE(CDC_BCD_NUM), /* bcdCDC: USB class definitions for communications */
191
192 0x05, /* bFunctionLength: size of this descriptor in bytes */
193 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
194 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
195 0x00, /* bmCapabilities: 0x00*/
196 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
197
198 0x04, /* bFunctionLength: size of this descriptor in bytes */
199 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
200 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
201 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
202
203 0x05, /* bFunctionLength: size of this descriptor in bytes */
204 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
205 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
206 0x01, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
207 0x02, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
208
209 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
210 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
211 USBD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
212 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
213 LBYTE(USBD_CDC_CMD_MAXPACKET_SIZE),
214 HBYTE(USBD_CDC_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
215 CDC_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
216
217
218 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
219 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
220 VCPMSC_CDC_DATA_INTERFACE, /* bInterfaceNumber: number of interface */
221 0x00, /* bAlternateSetting: alternate set */
222 0x02, /* bNumEndpoints: number of endpoints */
223 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
224 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
225 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
226 0x00, /* iInterface: index of string descriptor */
227
228 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
229 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
230 USBD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
231 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
232 LBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE),
233 HBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
234 0x00, /* bInterval: interval for polling endpoint for data transfers */
235
236 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
237 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
238 USBD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
239 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
240 LBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),
241 HBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
242 0x00, /* bInterval: interval for polling endpoint for data transfers */
243
244
245};
246
250#if defined ( __ICCARM__ ) /* iar compiler */
251 #pragma data_alignment=4
252#endif
253ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CDC_SIZ_STRING_LANGID] ALIGNED_TAIL =
254{
255 USBD_CDC_SIZ_STRING_LANGID,
256 USB_DESCIPTOR_TYPE_STRING,
257 0x09,
258 0x04,
259};
260
264#if defined ( __ICCARM__ ) /* iar compiler */
265 #pragma data_alignment=4
266#endif
267ALIGNED_HEAD static uint8_t g_string_serial[USBD_CDC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
268{
269 USBD_CDC_SIZ_STRING_SERIAL,
270 USB_DESCIPTOR_TYPE_STRING,
271};
272
273
274/* device descriptor */
275static usbd_desc_t device_descriptor =
276{
277 USB_DEVICE_DESC_LEN,
278 g_usbd_descriptor
279};
280
281/* config descriptor */
282static usbd_desc_t config_descriptor =
283{
284 USBD_CDC_MSC_CONFIG_DESC_SIZE,
285 g_usbd_configuration
286};
287
288/* langid descriptor */
289static usbd_desc_t langid_descriptor =
290{
291 USBD_CDC_SIZ_STRING_LANGID,
292 g_string_lang_id
293};
294
295/* serial descriptor */
296static usbd_desc_t serial_descriptor =
297{
298 USBD_CDC_SIZ_STRING_SERIAL,
299 g_string_serial
300};
301
302static usbd_desc_t vp_desc;
303
310static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
311{
312 uint16_t str_len = 0, id_pos = 2;
313 uint8_t *tmp_str = string;
314
315 while(*tmp_str != '\0')
316 {
317 str_len ++;
318 unicode_buf[id_pos ++] = *tmp_str ++;
319 unicode_buf[id_pos ++] = 0x00;
320 }
321
322 str_len = str_len * 2 + 2;
323 unicode_buf[0] = (uint8_t)str_len;
324 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
325
326 return str_len;
327}
328
336static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
337{
338 uint8_t idx = 0;
339
340 for( idx = 0 ; idx < len ; idx ++)
341 {
342 if( ((value >> 28)) < 0xA )
343 {
344 pbuf[ 2 * idx] = (value >> 28) + '0';
345 }
346 else
347 {
348 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
349 }
350
351 value = value << 4;
352
353 pbuf[2 * idx + 1] = 0;
354 }
355}
356
362static void get_serial_num(void)
363{
364 uint32_t serial0, serial1, serial2;
365
366 serial0 = *(uint32_t*)MCU_ID1;
367 serial1 = *(uint32_t*)MCU_ID2;
368 serial2 = *(uint32_t*)MCU_ID3;
369
370 serial0 += serial2;
371
372 if (serial0 != 0)
373 {
374 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
375 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
376 }
377}
378
384static usbd_desc_t *get_device_descriptor(void)
385{
386 return &device_descriptor;
387}
388
394static usbd_desc_t * get_device_qualifier(void)
395{
396 return NULL;
397}
398
404static usbd_desc_t *get_device_configuration(void)
405{
406 return &config_descriptor;
407}
408
414static usbd_desc_t *get_device_other_speed(void)
415{
416 return NULL;
417}
418
424static usbd_desc_t *get_device_lang_id(void)
425{
426 return &langid_descriptor;
427}
428
429
435static usbd_desc_t *get_device_manufacturer_string(void)
436{
437 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
438 vp_desc.descriptor = g_usbd_desc_buffer;
439 return &vp_desc;
440}
441
447static usbd_desc_t *get_device_product_string(void)
448{
449 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
450 vp_desc.descriptor = g_usbd_desc_buffer;
451 return &vp_desc;
452}
453
459static usbd_desc_t *get_device_serial_string(void)
460{
461 get_serial_num();
462 return &serial_descriptor;
463}
464
470static usbd_desc_t *get_device_interface_string(void)
471{
472 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
473 vp_desc.descriptor = g_usbd_desc_buffer;
474 return &vp_desc;
475}
476
482static usbd_desc_t *get_device_config_string(void)
483{
484 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
485 vp_desc.descriptor = g_usbd_desc_buffer;
486 return &vp_desc;
487}
488
cdc_msc_desc.h
usb cdc descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:60
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:63
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:53
USBD_CDC_MSC_IN_MAXPACKET_SIZE
#define USBD_CDC_MSC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_msc_class.h:61
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:51
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:52
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:55
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:56
CDC_BCD_NUM
#define CDC_BCD_NUM
usb bcd number define
Definition: cdc_desc.h:50
USBD_CDC_DESC_MANUFACTURER_STRING
#define USBD_CDC_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_desc.h:68
USBD_CDC_DESC_CONFIGURATION_STRING
#define USBD_CDC_DESC_CONFIGURATION_STRING
Definition: cdc_desc.h:70
USBD_CDC_SIZ_STRING_LANGID
#define USBD_CDC_SIZ_STRING_LANGID
Definition: cdc_desc.h:62
USBD_CDC_DESC_PRODUCT_STRING
#define USBD_CDC_DESC_PRODUCT_STRING
Definition: cdc_desc.h:69
VCPMSC_MSC_INTERFACE
#define VCPMSC_MSC_INTERFACE
usb interface define
Definition: cdc_msc_desc.h:82
USBD_CDC_MSC_CONFIG_DESC_SIZE
#define USBD_CDC_MSC_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_msc_desc.h:62
CDC_HID_BINTERVAL_TIME
#define CDC_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_desc.h:76
VCPMSC_CDC_INTERFACE
#define VCPMSC_CDC_INTERFACE
Definition: cdc_msc_desc.h:83
USBD_CDC_SIZ_STRING_SERIAL
#define USBD_CDC_SIZ_STRING_SERIAL
Definition: cdc_desc.h:63
USBD_CDC_DESC_INTERFACE_STRING
#define USBD_CDC_DESC_INTERFACE_STRING
Definition: cdc_desc.h:71
USBD_CDC_MSC_PRODUCT_ID
#define USBD_CDC_MSC_PRODUCT_ID
Definition: cdc_msc_desc.h:56
VCPMSC_CDC_DATA_INTERFACE
#define VCPMSC_CDC_DATA_INTERFACE
Definition: cdc_msc_desc.h:84
USBD_CDC_MSC_VENDOR_ID
#define USBD_CDC_MSC_VENDOR_ID
usb vendor id and product id define
Definition: cdc_msc_desc.h:55
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_msc_desc.c:296
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:67
USB_INTERFACE_ASSOCIATION_TYPE
#define USB_INTERFACE_ASSOCIATION_TYPE
Definition: cdc_msc_desc.c:43
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_msc_desc.c:275
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_msc_desc.c:404
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_msc_desc.c:289
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_msc_desc.c:384
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_msc_desc.c:435
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_msc_desc.c:394
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_msc_desc.c:470
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_msc_desc.c:302
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_msc_desc.c:414
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_msc_desc.c:62
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_msc_desc.c:447
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_msc_desc.c:482
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_msc_desc.c:310
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_msc_desc.c:424
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_msc_desc.c:362
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_msc_desc.c:282
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_msc_desc.c:459
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_msc_desc.c:336
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
USB_CLASS_CODE_MSC
#define USB_CLASS_CODE_MSC
Definition: usb_std.h:163
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:197
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:175
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:196
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:190
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:165
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:160
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:199
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:198
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: cdc_msc_desc.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CDC_MSC_DESC_H
27#define __CDC_MSC_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "cdc_msc_class.h"
34#include "usbd_core.h"
35
50#define CDC_BCD_NUM 0x0110
51
55#define USBD_CDC_MSC_VENDOR_ID 0x2E3C
56#define USBD_CDC_MSC_PRODUCT_ID 0x5760
57
62#define USBD_CDC_MSC_CONFIG_DESC_SIZE 106
63#define USBD_CDC_SIZ_STRING_LANGID 4
64#define USBD_CDC_SIZ_STRING_SERIAL 0x1A
65
69#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
70#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
71#define USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
72#define USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
73
77#define CDC_HID_BINTERVAL_TIME 0xFF
78
82#define VCPMSC_MSC_INTERFACE 0x00
83#define VCPMSC_CDC_INTERFACE 0x01
84#define VCPMSC_CDC_DATA_INTERFACE 0x02
85
86
90#define MCU_ID1 (0x1FFFF7E8)
91#define MCU_ID2 (0x1FFFF7EC)
92#define MCU_ID3 (0x1FFFF7F0)
97extern usbd_desc_handler cdc_msc_desc_handler;
98
99
107#ifdef __cplusplus
108}
109#endif
110
111#endif
cdc_msc_class.h
usb cdc class file
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:67
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_codec.h Source File

  • usb_device
  • composite_audio_hid
  • inc
composite_audio_hid/inc/audio_codec.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AUDIO_CODEC_H
27#define __AUDIO_CODEC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
42/* includes ------------------------------------------------------------------*/
43#include "at32f413.h"
44
48#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
49#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
50#define WM8988_R2_LOUT1_VOLUME 0x02
51#define WM8988_R3_ROUT1_VOLUME 0x03
52#define WM8988_R4_RESERVED 0x04
53#define WM8988_R5_ADC_DAC_CONTROL 0x05
54#define WM8988_R6_RESERVED 0x06
55#define WM8988_R7_AUDIO_INTERFACE 0x07
56#define WM8988_R8_SAMPLE_RATE 0x08
57#define WM8988_R9_RESERVED 0x09
58#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
59#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
60#define WM8988_R12_BASS_CONTROL 0x0C
61#define WM8988_R13_TREBLE_CONTROL 0x0D
62#define WM8988_R14_
63#define WM8988_R15_RESET 0x0F
64#define WM8988_R16_3D_CONTROL 0x10
65#define WM8988_R17_ALC1 0x11
66#define WM8988_R18_ALC2 0x12
67#define WM8988_R19_ALC3 0x13
68#define WM8988_R20_NOISE_GATE 0x14
69#define WM8988_R21_LEFT_ADC_VOLUME 0x15
70#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
71#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
72#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
73#define WM8988_R25_PWR_1_MGMT 0x19
74#define WM8988_R26_PWR_2_MGMT 0x1A
75#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
76
77#define WM8988_R31_ADC_INPUT_MODE 0x1F
78#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
79#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
80#define WM8988_R34_LEFT_OUT_MIX_1 0x22
81#define WM8988_R35_LEFT_OUT_MIX_2 0x23
82#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
83#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
84#define WM8988_R38_RESERVED
85#define WM8988_R39_RESERVED
86#define WM8988_R40_LOUT2_VOLUME 0x28
87#define WM8988_R41_ROUT2_VOLUME 0x29
88#define WM8988_R42_RESERVED
89#define WM8988_R43_LOW_POWER_PALYBACK 0x43
90
91#define WM8988_I2C_ADDR_CSB_LOW 0x34
92#define WM8988_I2C_ADDR_CSB_HIGH 0x36
93
101#define I2S1_WS_PIN GPIO_PINS_4
102#define I2S1_CK_PIN GPIO_PINS_5
103#define I2S1_SD_PIN GPIO_PINS_7
104
105#define I2S1_GPIO GPIOA
106#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
107#define I2S1_DT_ADDRESS (&(SPI1->dt))
108
109/*I2S2 Pin*/
110#define I2S2_WS_PIN GPIO_PINS_12
111#define I2S2_CK_PIN GPIO_PINS_13
112#define I2S2_SD_PIN GPIO_PINS_15
113
114
115#define I2S2_GPIO GPIOB
116#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
117#define I2S2_DT_ADDRESS (&(SPI2->dt))
118
119#define SPK_TX_FIFO_SIZE (1024 * 4)
120
128#define MIC_BUFFER_SIZE 1024
129#define SPK_BUFFER_SIZE 4096
130#define DMA_BUFFER_SIZE 288
131
132typedef struct
133{
134 uint32_t audio_freq;
135 uint32_t audio_bitw;
136 //spk part
137 uint16_t spk_buffer[SPK_BUFFER_SIZE];
138 uint16_t *spk_roff;
139 uint16_t *spk_woff;
140 uint16_t *spk_rend;
141 uint32_t spk_freq;
142 uint32_t spk_wtotal;
143 uint32_t spk_rtotal;
144 uint16_t spk_threshold;
145 uint16_t spk_calc;
146 uint8_t spk_stage;
147
148 //mic part
149 uint16_t mic_buffer[MIC_BUFFER_SIZE];
150 uint16_t *mic_roff;
151 uint16_t *mic_woff;
152 uint16_t *mic_wend;
153 uint32_t mic_wtotal;
154 uint32_t mic_rtotal;
155 uint32_t mic_delta;
156 uint16_t mic_calc;
157 uint16_t mic_adj_count;
158 uint8_t mic_adj_stage;
159 uint8_t mic_stage;
160
161 uint8_t mic_mute;
162 uint8_t spk_mute;
163
164 uint16_t mic_volume;
165 uint16_t spk_volume;
166
167 uint32_t spk_tx_size;
168 uint32_t mic_rx_size;
169
170 uint32_t spk_enable;
171 uint32_t mic_enable;
172
173}audio_codec_type;
174
175 error_status audio_codec_init(void);
176 error_status audio_codec_loop(void);
177void audio_codec_modify_freq(uint32_t freq);
178
182void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
183uint32_t audio_codec_mic_get_data(uint8_t *buffer);
184uint8_t audio_codec_spk_feedback(uint8_t *feedback);
185void audio_codec_spk_alt_setting(uint32_t alt_seting);
186void audio_codec_mic_alt_setting(uint32_t alt_seting);
187void audio_codec_set_mic_mute(uint8_t mute);
188void audio_codec_set_spk_mute(uint8_t mute);
189void audio_codec_set_mic_volume(uint16_t volume);
190void audio_codec_set_spk_volume(uint16_t volume);
191void audio_codec_set_mic_freq(uint32_t freq);
192void audio_codec_set_spk_freq(uint32_t freq);
193
205#ifdef __cplusplus
206}
207#endif
208
209#endif
210
at32f413.h
at32f413 header file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
error_status
error_status
error status
Definition: at32f413.h:301
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:167
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:215
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:193
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: composite_audio_hid/inc/audio_codec.h:128
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:119
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:280
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:851
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: composite_audio_hid/inc/audio_codec.h:129
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:182
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:242
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:226
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: audio/src/audio_codec.c:340
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:204
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:152
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:792
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:135
audio_codec_type
Definition: audio/inc/audio_codec.h:130


AT32F413 Firmwary Library: audio_codec.c Source File

  • usb_device
  • composite_audio_hid
  • src
composite_audio_hid/src/audio_codec.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "audio_codec.h"
27#include "i2c_application.h"
28#include "audio_conf.h"
29#include <string.h>
30
39#define I2C_TIMEOUT 0xFFFFFFFF
40
41#define I2Cx_SPEED 200000
42#define I2Cx_ADDRESS 0x00
43
44#define I2Cx_PORT I2C1
45#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
46
47#define I2Cx_SCL_PIN GPIO_PINS_8
48#define I2Cx_SCL_GPIO_PORT GPIOB
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50
51#define I2Cx_SDA_PIN GPIO_PINS_9
52#define I2Cx_SDA_GPIO_PORT GPIOB
53#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54
58#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
59#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
60
64#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
65
69uint16_t reg_addr_data[] =
70{
71 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
72 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
73 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
74 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
75 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
76 (WM8988_REG_BITW16),
77 (WM8988_REG_FREQ16K),
78 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
79 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
80 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
81 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
82 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
83 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
84 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
85 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
86 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
87 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
88 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
89 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
90 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
91 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
92 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
93 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
94 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
95 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
96 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
97 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
98 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
99 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
100};
101
102 i2c_handle_type hi2cx;
103
104 audio_codec_type audio_codec;
105uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
106uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
107
108void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
109void codec_i2s_reset(void);
110void codec_i2s_init(audio_codec_type *param);
111void mclk_tmr1_init(void);
112void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
113
119void audio_codec_set_mic_freq(uint32_t freq)
120{
121 if(audio_codec.audio_freq != freq)
122 {
123 audio_codec.audio_freq = freq;
124 codec_i2s_reset();
125 audio_codec_modify_freq(freq);
126 codec_i2s_init(&audio_codec);
127 }
128}
129
135void audio_codec_set_spk_freq(uint32_t freq)
136{
137 if(audio_codec.audio_freq != freq)
138 {
139 audio_codec.audio_freq = freq;
140 codec_i2s_reset();
141 audio_codec_modify_freq(freq);
142 codec_i2s_init(&audio_codec);
143 }
144}
145
146
152void audio_codec_spk_alt_setting(uint32_t alt_seting)
153{
154 if(alt_seting == 0)
155 {
156 }
157 else
158 {
159 }
160}
161
167void audio_codec_mic_alt_setting(uint32_t alt_seting)
168{
169 if(alt_seting == 0)
170 {
171 }
172 else
173 {
174 }
175}
176
182void audio_codec_set_mic_mute(uint8_t mute)
183{
184 audio_codec.mic_mute = mute;
185}
186
187
193void audio_codec_set_spk_mute(uint8_t mute)
194{
195 audio_codec.spk_mute = mute;
196}
197
198
204void audio_codec_set_mic_volume(uint16_t volume)
205{
206 /* wm8988 adc have 256 steps */
207 audio_codec.mic_volume = volume;
208}
209
215void audio_codec_set_spk_volume(uint16_t volume)
216{
217 /* wm8988 dac have 80 steps */
218 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
219}
220
226uint8_t audio_codec_spk_feedback(uint8_t *feedback)
227{
228 uint32_t feedback_value = (audio_codec.spk_freq);
229 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
230 feedback[0] = (uint8_t)(feedback_value);
231 feedback[1] = (uint8_t)(feedback_value >> 8);
232 feedback[2] = (uint8_t)(feedback_value >> 16);
233 return 3;
234}
235
242void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
243{
244 uint16_t ulen = len / 2, i;
245 uint16_t *u16data = (uint16_t *)data;
246
247 switch(audio_codec.spk_stage)
248 {
249 case 0:
250 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
251 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
252 audio_codec.spk_stage = 1;
253 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
254 break;
255 case 1:
256 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
257 {
258 audio_codec.spk_stage = 2;
259 }
260 break;
261 case 2:
262 break;
263 }
264 for( i = 0; i < ulen; ++i )
265 {
266 *audio_codec.spk_woff++ = *u16data++;
267 if( audio_codec.spk_woff >= audio_codec.spk_rend )
268 {
269 audio_codec.spk_woff = audio_codec.spk_buffer;
270 }
271 }
272 audio_codec.spk_wtotal += ulen;
273}
274
280uint32_t audio_codec_mic_get_data(uint8_t *buffer)
281{
282 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
283 uint16_t len = audio_codec.mic_rx_size << 1;
284 uint16_t i;
285 uint16_t* u16buf = (uint16_t*)buffer;
286 switch(audio_codec.mic_stage)
287 {
288 case 0:
289 audio_codec.mic_stage = 1;
290 memset( buffer, 0, len );
291 return len;
292 case 1:
293 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
294 {
295 audio_codec.mic_stage = 2;
296 }
297 return len;
298 }
299 switch( audio_codec.mic_adj_stage )
300 {
301 case 0:
302 break;
303 case 1:
304 if( audio_codec.mic_adj_count >= 4 ){
305 len += 4;
306 audio_codec.mic_adj_count -= 4;
307 }
308 break;
309 case 2:
310 if( audio_codec.mic_adj_count >= 4 ){
311 len -= 4;
312 audio_codec.mic_adj_count -= 4;
313 }
314 break;
315 }
316
317 for( i = 0; i < len/2; ++i )
318 {
319 *u16buf++ = *audio_codec.mic_roff++;
320 if( audio_codec.mic_roff >= audio_codec.mic_wend )
321 {
322 audio_codec.mic_roff = audio_codec.mic_buffer;
323 }
324 }
325 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
326 { //should not happen
327 while(1);
328 }
329
330 audio_codec.mic_rtotal += len/2;
331 audio_codec.mic_delta += len/2;
332 return len;
333}
334
340void audio_codec_modify_freq(uint32_t freq)
341{
342 uint16_t codec_cmd;
343 uint8_t i2c_cmd[2];
344 if(freq == AUDIO_FREQ_16K)
345 {
346 codec_cmd = WM8988_REG_FREQ16K;
347 }
348 else if(freq == AUDIO_FREQ_48K)
349 {
350 codec_cmd = WM8988_REG_FREQ48K;
351 }
352 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
353 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
354 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
355 {
356 while(1);
357 }
358}
359
367void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
368{
369 uint32_t i_index = 0;
370 for(i_index = 0; i_index < len; i_index ++)
371 {
372 buffer[i_index] = (uint16_t)set;
373 }
374}
375
383void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
384{
385 uint16_t i_index;
386 for(i_index = 0; i_index < len; i_index ++)
387 {
388 dest[i_index] = src[i_index];
389 }
390}
391
397void i2c_lowlevel_init(i2c_handle_type* hi2c)
398{
399 gpio_init_type gpio_initstructure;
400
401 if(hi2c->i2cx == I2Cx_PORT)
402 {
403 /* i2c periph clock enable */
404 crm_periph_clock_enable(I2Cx_CLK, TRUE);
405 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
406 gpio_pin_remap_config(I2C1_MUX, TRUE);
407 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
408 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
409
410 /* gpio configuration */
411 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
412 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
413 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
414 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
415
416 /* configure i2c pins: scl */
417 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
418 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
419
420 /* configure i2c pins: sda */
421 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
422 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
423
424 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
425
426 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
427 }
428}
429
435void mclk_tmr1_init(void)
436{
437 gpio_init_type gpio_init_struct;
438 tmr_output_config_type tmr_oc_init_structure;
439 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
440
441 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
442 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
443 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
444
445 gpio_default_para_init(&gpio_init_struct);
446
447
448 gpio_init_struct.gpio_pins = GPIO_PINS_8;
449 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
450 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
451 gpio_init(GPIOA, &gpio_init_struct);
452
453 tmr_base_init(TMR1, 1, prescaler_value);
454 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
455 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
456
457 tmr_output_default_para_init(&tmr_oc_init_structure);
458 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
459 tmr_oc_init_structure.oc_idle_state = FALSE;
460 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
461 tmr_oc_init_structure.oc_output_state = TRUE;
462 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
463 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
464 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
465
466 /* tmr enable counter */
467 tmr_counter_enable(TMR1, TRUE);
468 tmr_output_enable(TMR1, TRUE);
469}
470
471
477void codec_i2s_reset(void)
478{
479 i2s_enable(SPI1, FALSE);
480 i2s_enable(SPI2, FALSE);
481 dma_channel_enable(DMA1_CHANNEL3, FALSE);
482 dma_channel_enable(DMA1_CHANNEL4, FALSE);
483}
484
491void codec_i2s_init(audio_codec_type *param)
492{
493 gpio_init_type gpio_init_struct;
494 dma_init_type dma_init_struct;
495 i2s_init_type i2s_init_struct;
496 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
497
498 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
499 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
500 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
501 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
502 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
503
504 param->spk_freq = param->audio_freq;
505
506 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
507 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
508
509 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
510 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
511
512 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
513 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
514
515 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
516 {
517 param->mic_wend += param->mic_rx_size;
518 }
519 param->mic_wend -= param->mic_rx_size;
520 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
521 {
522 param->spk_rend += param->spk_tx_size;
523 }
524 param->spk_rend -= param->spk_tx_size;
525 if(param->audio_bitw == 16)
526 {
527 format = I2S_DATA_16BIT_CHANNEL_16BIT;
528 }
529 else
530 {
531 format = I2S_DATA_24BIT_CHANNEL_32BIT;
532 }
533
534 gpio_default_para_init(&gpio_init_struct);
535
536 /* i2s1 ws pins */
537 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
538 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
539 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
540 gpio_init(I2S1_GPIO, &gpio_init_struct);
541
542 /* i2s1 ck pins */
543 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
544 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
545 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
546 gpio_init(I2S1_GPIO, &gpio_init_struct);
547
548 /* i2s1 sd pins slave tx */
549 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
550 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
551 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
552 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
553 gpio_init(I2S1_GPIO, &gpio_init_struct);
554
555 /* i2s2 ws pins */
556 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
557 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
558 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
559 gpio_init(I2S2_GPIO, &gpio_init_struct);
560
561 /* i2s2 ck pins */
562 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
563 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
564 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
565 gpio_init(I2S2_GPIO, &gpio_init_struct);
566
567 /* i2s2 sd pins slave rx */
568 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
569 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
570 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
571 gpio_init(I2S2_GPIO, &gpio_init_struct);
572
573 /* dma config */
574 dma_reset(DMA1_CHANNEL3);
575 dma_reset(DMA1_CHANNEL4);
576
577 /* dma1 channel3: speaker i2s1 tx */
578 dma_default_para_init(&dma_init_struct);
579 dma_init_struct.buffer_size = param->spk_tx_size << 1;
580 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
581 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
582 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
583 dma_init_struct.memory_inc_enable = TRUE;
584 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
585 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
586 dma_init_struct.peripheral_inc_enable = FALSE;
587 dma_init_struct.priority = DMA_PRIORITY_HIGH;
588 dma_init_struct.loop_mode_enable = TRUE;
589 dma_init(DMA1_CHANNEL3, &dma_init_struct);
590 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
591 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
592 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
593
594 /* dma1 channel4: microphone i2s2 rx */
595 dma_default_para_init(&dma_init_struct);
596 dma_init_struct.buffer_size = param->mic_rx_size << 1;
597 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
598 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
599 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
600 dma_init_struct.memory_inc_enable = TRUE;
601 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
602 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
603 dma_init_struct.peripheral_inc_enable = FALSE;
604 dma_init_struct.priority = DMA_PRIORITY_HIGH;
605 dma_init_struct.loop_mode_enable = TRUE;
606 dma_init(DMA1_CHANNEL4, &dma_init_struct);
607 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
608 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
609 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
610
611 /* i2s1 tx init */
612 spi_i2s_reset(SPI1);
613 i2s_default_para_init(&i2s_init_struct);
614 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
615 i2s_init_struct.data_channel_format = format;
616 i2s_init_struct.mclk_output_enable = FALSE;
617 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
618 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
619 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
620 i2s_init(SPI1, &i2s_init_struct);
621
622 /* i2s2 rx init */
623 spi_i2s_reset(SPI2);
624 i2s_default_para_init(&i2s_init_struct);
625 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
626 i2s_init_struct.data_channel_format = format;
627 i2s_init_struct.mclk_output_enable = FALSE;
628 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
629 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
630 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
631 i2s_init(SPI2, &i2s_init_struct);
632
633
634 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
635 spi_i2s_dma_receiver_enable(SPI2, TRUE);
636 i2s_enable(SPI1, TRUE);
637 i2s_enable(SPI2, TRUE);
638
639 dma_channel_enable(DMA1_CHANNEL3, TRUE);
640 dma_channel_enable(DMA1_CHANNEL4, TRUE);
641
642}
643
649void DMA1_Channel3_IRQHandler(void)
650{
651 uint16_t half_size = audio_codec.spk_tx_size;
652 uint16_t *pdst;
653
654 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
655 {
656 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
657 pdst = spk_dma_buffer;
658 dma_flag_clear(DMA1_HDT3_FLAG);
659 }
660 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
661 {
662 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
663 pdst = spk_dma_buffer + half_size;
664 dma_flag_clear(DMA1_FDT3_FLAG);
665 }
666
667 switch( audio_codec.spk_stage )
668 {
669 case 0:
670 case 1:
671 memset( pdst, 0, half_size << 1);
672 break;
673 case 2:
674 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
675 {
676 while(1);//should not happen;
677 }
678 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
679 {
680 audio_codec.spk_stage = 0;
681 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
682 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
683 }
684 else
685 {
686 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
687 audio_codec.spk_roff += half_size;
688 audio_codec.spk_rtotal += half_size;
689 if( audio_codec.spk_roff >= audio_codec.spk_rend )
690 {
691 audio_codec.spk_roff = audio_codec.spk_buffer;
692 }
693 if( ++audio_codec.spk_calc == 256 )
694 {
695 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
696 audio_codec.spk_calc = 0;
697 if( delta < audio_codec.spk_threshold - half_size )
698 {
699 audio_codec.spk_threshold -= half_size;
700 audio_codec.spk_freq += audio_codec.audio_freq/1024;
701 }
702 else if( delta > audio_codec.spk_threshold + half_size )
703 {
704 audio_codec.spk_threshold += half_size;
705 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
706 }
707 if(audio_codec.spk_rtotal > 0x20000000)
708 {
709 audio_codec.spk_rtotal -= 0x10000000;
710 audio_codec.spk_wtotal -= 0x10000000;
711 }
712 }
713 }
714 break;
715 }
716
717}
718
724void DMA1_Channel4_IRQHandler(void)
725{
726 uint16_t *psrc;
727 uint16_t len = audio_codec.mic_rx_size << 1;
728
729 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
730 {
731 dma_flag_clear(DMA1_HDT4_FLAG);
732 psrc = mic_dma_buffer;
733 }
734 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
735 {
736 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
737 dma_flag_clear(DMA1_FDT4_FLAG);
738 }
739 if( audio_codec.mic_stage )
740 {
741 memcpy( audio_codec.mic_woff, psrc, len );
742 audio_codec.mic_woff += len/2;
743 audio_codec.mic_wtotal += len/2;
744 if( audio_codec.mic_woff >= audio_codec.mic_wend )
745 {
746 audio_codec.mic_woff = audio_codec.mic_buffer;
747 }
748 if( audio_codec.mic_stage == 2 )
749 {
750 if( 1024 == ++audio_codec.mic_calc )
751 {
752 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
753 audio_codec.mic_calc = 0;
754 if( audio_codec.mic_delta > size_estimate )
755 {
756 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
757 audio_codec.mic_adj_stage = 2;
758 }
759 else if( audio_codec.mic_delta < size_estimate )
760 {
761 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
762 audio_codec.mic_adj_stage = 1;
763 }
764 else
765 {
766 audio_codec.mic_adj_count = 0;
767 audio_codec.mic_adj_stage = 0;
768 }
769 audio_codec.mic_delta = 0;
770 if( audio_codec.mic_rtotal >= 0x80000000 )
771 {
772 audio_codec.mic_rtotal -= 0x80000000;
773 audio_codec.mic_wtotal -= 0x80000000;
774 }
775 }
776 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
777 {
778 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
779 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
780 audio_codec.mic_stage = 0;
781 audio_codec.mic_adj_stage = 0;
782 audio_codec.mic_adj_count = 0;
783 audio_codec.mic_calc = 0;
784 }
785 }
786 }
787}
788
794 error_status audio_codec_init(void)
795{
796 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
797 uint32_t i_index = 0;
798 uint8_t i2c_cmd[2];
799
800 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
801 {
802 reg_addr_data[6] = WM8988_REG_FREQ16K;
803 audio_codec.audio_freq = AUDIO_FREQ_16K;
804 }
805 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
806 {
807 reg_addr_data[6] = WM8988_REG_FREQ48K;
808 audio_codec.audio_freq = AUDIO_FREQ_48K;
809 }
810 else
811 {
812 return ERROR;
813 }
814
815 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
816 {
817 reg_addr_data[5] = WM8988_REG_BITW16;
818 audio_codec.audio_bitw = AUDIO_BITW_16;
819 }
820 else
821 {
822 return ERROR;
823 }
824
825 /* i2c init */
826 hi2cx.i2cx = I2Cx_PORT;
827
828 i2c_config(&hi2cx);
829
830 for(i_index = 0; i_index < reg_len; i_index ++)
831 {
832 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
833 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
834 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
835 {
836 return ERROR;
837 }
838 }
839
840 /* timer init */
841 mclk_tmr1_init();
842
843 codec_i2s_init(&audio_codec);
844
845 return SUCCESS;
846}
847
853 error_status audio_codec_loop(void)
854{
855 static uint8_t mic_mute = 0;
856 static uint16_t mic_volume = 0;
857 static uint8_t spk_mute = 0;
858 static uint16_t spk_volume = 0;
859 uint16_t audio_ctrl_l;
860 uint16_t audio_ctrl_r;
861 uint8_t i2c_cmd[2];
862
863 if(mic_mute != audio_codec.mic_mute)
864 {
865 mic_mute = audio_codec.mic_mute;
866 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
867 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
868 if(audio_codec.mic_mute == 0)
869 {
870 audio_ctrl_l |= audio_codec.mic_volume;
871 audio_ctrl_r |= audio_codec.mic_volume;
872 }
873 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
874 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
875 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
876 {
877 return ERROR;
878 }
879 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
880 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
881 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
882 {
883 return ERROR;
884 }
885 }
886
887 if(mic_volume != audio_codec.mic_volume)
888 {
889 mic_volume = audio_codec.mic_volume;
890 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
891 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
892 audio_ctrl_l |= audio_codec.mic_volume;
893 audio_ctrl_r |= audio_codec.mic_volume;
894 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
895 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
896 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
897 {
898 return ERROR;
899 }
900 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
901 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
902 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
903 {
904 return ERROR;
905 }
906 }
907
908 if(spk_mute != audio_codec.spk_mute)
909 {
910 spk_mute = audio_codec.spk_mute;
911 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
912 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
913 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
914 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
915 {
916 return ERROR;
917 }
918 }
919
920 if(spk_volume != audio_codec.spk_volume)
921 {
922 spk_volume = audio_codec.spk_volume;
923 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
924 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
925 audio_ctrl_l |= audio_codec.spk_volume;
926 audio_ctrl_r |= audio_codec.spk_volume;
927
928 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
929 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
930
931 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
932 {
933 return ERROR;
934 }
935 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
936 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
937 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
938 {
939 return ERROR;
940 }
941 }
942 return SUCCESS;
943}
944
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:36
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: composite_audio_hid/src/audio_codec.c:69
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: composite_audio_hid/src/audio_codec.c:167
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: composite_audio_hid/src/audio_codec.c:477
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: composite_audio_hid/src/audio_codec.c:105
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: composite_audio_hid/src/audio_codec.c:215
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: composite_audio_hid/src/audio_codec.c:193
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: composite_audio_hid/src/audio_codec.c:58
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: composite_audio_hid/src/audio_codec.c:119
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: composite_audio_hid/src/audio_codec.c:42
I2Cx_CLK
#define I2Cx_CLK
Definition: composite_audio_hid/src/audio_codec.c:45
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: composite_audio_hid/src/audio_codec.c:280
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: composite_audio_hid/src/audio_codec.c:64
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: composite_audio_hid/src/audio_codec.c:853
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: composite_audio_hid/src/audio_codec.c:491
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: composite_audio_hid/src/audio_codec.c:182
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
codec speaker write fifo
Definition: composite_audio_hid/src/audio_codec.c:242
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: composite_audio_hid/src/audio_codec.c:51
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: composite_audio_hid/src/audio_codec.c:47
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: composite_audio_hid/src/audio_codec.c:106
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: composite_audio_hid/src/audio_codec.c:226
hi2cx
i2c_handle_type hi2cx
Definition: composite_audio_hid/src/audio_codec.c:102
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 interrupt.
Definition: composite_audio_hid/src/audio_codec.c:724
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: composite_audio_hid/src/audio_codec.c:340
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: composite_audio_hid/src/audio_codec.c:52
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: composite_audio_hid/src/audio_codec.c:204
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: composite_audio_hid/src/audio_codec.c:435
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 interrupt.
Definition: composite_audio_hid/src/audio_codec.c:649
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: composite_audio_hid/src/audio_codec.c:53
audio_codec
audio_codec_type audio_codec
Definition: composite_audio_hid/src/audio_codec.c:104
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: composite_audio_hid/src/audio_codec.c:152
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: composite_audio_hid/src/audio_codec.c:397
I2Cx_SPEED
#define I2Cx_SPEED
Definition: composite_audio_hid/src/audio_codec.c:41
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: composite_audio_hid/src/audio_codec.c:794
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: composite_audio_hid/src/audio_codec.c:59
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: composite_audio_hid/src/audio_codec.c:383
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: composite_audio_hid/src/audio_codec.c:367
I2Cx_PORT
#define I2Cx_PORT
Definition: composite_audio_hid/src/audio_codec.c:44
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: composite_audio_hid/src/audio_codec.c:135
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: composite_audio_hid/src/audio_codec.c:49
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: composite_audio_hid/src/audio_codec.c:48
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:420
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:183
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:184
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f413_dma.h:93
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f413_dma.h:89
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:88
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f413_dma.h:51
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:224
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
I2C1_MUX
#define I2C1_MUX
Definition: at32f413_gpio.h:80
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:314
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:497
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:443
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:49
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:296
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:483
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:224
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:207
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:247
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:225
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:227
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:196
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:237
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:236
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:607
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:125
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:126
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:127
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: audio/inc/audio_codec.h:114
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: audio/inc/audio_codec.h:103
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: audio/inc/audio_codec.h:102
I2S2_GPIO
#define I2S2_GPIO
Definition: audio/inc/audio_codec.h:112
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: audio/inc/audio_codec.h:111
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: audio/inc/audio_codec.h:109
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:113
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: audio/inc/audio_codec.h:106
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:105
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: audio/inc/audio_codec.h:101
I2S1_GPIO
#define I2S1_GPIO
Definition: audio/inc/audio_codec.h:104
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: audio/inc/audio_codec.h:110
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: audio/inc/audio_codec.h:75
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: audio/inc/audio_codec.h:91
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:58
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:49
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: audio/inc/audio_codec.h:51
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:82
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:69
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: audio/inc/audio_codec.h:77
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: audio/inc/audio_codec.h:61
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: audio/inc/audio_codec.h:64
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:70
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:48
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: audio/inc/audio_codec.h:71
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:81
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: audio/inc/audio_codec.h:89
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:78
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: audio/inc/audio_codec.h:74
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:59
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: audio/inc/audio_codec.h:72
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: audio/inc/audio_codec.h:86
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:80
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: audio/inc/audio_codec.h:53
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: audio/inc/audio_codec.h:73
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: audio/inc/audio_codec.h:87
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: audio/inc/audio_codec.h:50
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:83
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:79
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: audio/inc/audio_codec.h:60
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:59
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:61
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:69
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:57
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:64
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:70
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:58
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: audio/inc/audio_codec.h:130
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: audio/inc/audio_codec.h:159
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: audio/inc/audio_codec.h:141
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: audio/inc/audio_codec.h:143
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: audio/inc/audio_codec.h:147
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: audio/inc/audio_codec.h:134
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: audio/inc/audio_codec.h:161
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: audio/inc/audio_codec.h:135
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: audio/inc/audio_codec.h:140
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: audio/inc/audio_codec.h:152
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: audio/inc/audio_codec.h:142
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: audio/inc/audio_codec.h:148
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: audio/inc/audio_codec.h:156
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: audio/inc/audio_codec.h:154
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: audio/inc/audio_codec.h:138
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: audio/inc/audio_codec.h:132
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: audio/inc/audio_codec.h:149
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: audio/inc/audio_codec.h:137
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: audio/inc/audio_codec.h:150
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: audio/inc/audio_codec.h:151
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: audio/inc/audio_codec.h:131
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: audio/inc/audio_codec.h:158
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: audio/inc/audio_codec.h:162
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: audio/inc/audio_codec.h:153
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: audio/inc/audio_codec.h:139
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: audio/inc/audio_codec.h:155
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: audio/inc/audio_codec.h:164
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: audio/inc/audio_codec.h:165
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: audio/inc/audio_codec.h:136
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: audio/inc/audio_codec.h:146
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
i2s_init_type
i2s init type
Definition: at32f413_spi.h:270
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:273
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:274
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:276
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:272
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:271
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:275
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400


AT32F413 Firmwary Library: msc_bot_scsi.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
composite_cdc_msc/msc_bot_scsi.c
Go to the documentation of this file.
1
24#include "cdc_msc_class.h"
25#include "msc_diskio.h"
26
41#if defined ( __ICCARM__ ) /* iar compiler */
42 #pragma data_alignment=4
43#endif
44ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL = {
45 0x00,
46 0x00,
47 0x00,
48 0x00,
49 0x00,
50
51};
52#if defined ( __ICCARM__ ) /* iar compiler */
53 #pragma data_alignment=4
54#endif
55ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL =
56{
57 0x70,
58 0x00,
59 SENSE_KEY_ILLEGAL_REQUEST,
60 0x00000000,
61 0x0A,
62 0x00000000,
63 0x20,
64 0x00,
65 0x00000000
66};
67
68#if defined ( __ICCARM__ ) /* iar compiler */
69 #pragma data_alignment=4
70#endif
71ALIGNED_HEAD uint8_t mode_sense6_data[8] ALIGNED_TAIL =
72{
73 0x00,
74 0x00,
75 0x00,
76 0x00,
77 0x00,
78 0x00,
79 0x00,
80 0x00
81};
82
83#if defined ( __ICCARM__ ) /* iar compiler */
84 #pragma data_alignment=4
85#endif
86ALIGNED_HEAD uint8_t mode_sense10_data[8] ALIGNED_TAIL =
87{
88 0x00,
89 0x06,
90 0x00,
91 0x00,
92 0x00,
93 0x00,
94 0x00,
95 0x00
96};
102void bot_scsi_init(void *udev)
103{
104 usbd_core_type *pudev = (usbd_core_type *)udev;
105 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
106 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
107 pmsc->bot_status = MSC_BOT_STATE_IDLE;
108 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
109
110 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
111 pmsc->csw_struct.dCSWDataResidue = 0;
112 pmsc->csw_struct.dCSWSignature = 0;
113 pmsc->csw_struct.dCSWTag = CSW_BCSWSTATUS_PASS;
114
115 /* set out endpoint to receive status */
116 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
117}
118
124void bot_scsi_reset(void *udev)
125{
126 usbd_core_type *pudev = (usbd_core_type *)udev;
127 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
128 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
129 pmsc->bot_status = MSC_BOT_STATE_RECOVERY;
130 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
131
132 /* set out endpoint to receive status */
133 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
134}
135
142void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
143{
144 usbd_core_type *pudev = (usbd_core_type *)udev;
145 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
146 switch(pmsc->msc_state)
147 {
148 case MSC_STATE_MACHINE_DATA_IN:
149 if(bot_scsi_cmd_process(udev) != USB_OK)
150 {
151 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
152 }
153 break;
154
155 case MSC_STATE_MACHINE_LAST_DATA:
156 case MSC_STATE_MACHINE_SEND_DATA:
157 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
158 break;
159
160 default:
161 break;
162 }
163}
164
171void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
172{
173 usbd_core_type *pudev = (usbd_core_type *)udev;
174 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
175 switch(pmsc->msc_state)
176 {
177 case MSC_STATE_MACHINE_IDLE:
178 bot_cbw_decode(udev);
179 break;
180
181 case MSC_STATE_MACHINE_DATA_OUT:
182 if(bot_scsi_cmd_process(udev) != USB_OK)
183 {
184 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
185 }
186 break;
187 }
188}
189
195void bot_cbw_decode(void *udev)
196{
197 usbd_core_type *pudev = (usbd_core_type *)udev;
198 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
199
200 pmsc->csw_struct.dCSWTag = pmsc->cbw_struct.dCBWTage;
201 pmsc->csw_struct.dCSWDataResidue = pmsc->cbw_struct.dCBWDataTransferLength;
202
203 /* check param */
204 if((pmsc->cbw_struct.dCBWSignature != CBW_DCBWSIGNATURE) ||
205 (usbd_get_recv_len(pudev, USBD_MSC_BULK_OUT_EPT) != CBW_CMD_LENGTH)
206 || (pmsc->cbw_struct.bCBWLUN > MSC_SUPPORT_MAX_LUN) ||
207 (pmsc->cbw_struct.bCBWCBLength < 1) || (pmsc->cbw_struct.bCBWCBLength > 16))
208 {
209 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
210 pmsc->bot_status = MSC_BOT_STATE_ERROR;
211 bot_scsi_stall(udev);
212 }
213 else
214 {
215 if(bot_scsi_cmd_process(udev) != USB_OK)
216 {
217 bot_scsi_stall(udev);
218 }
219 else if((pmsc->msc_state != MSC_STATE_MACHINE_DATA_IN) &&
220 (pmsc->msc_state != MSC_STATE_MACHINE_DATA_OUT) &&
221 (pmsc->msc_state != MSC_STATE_MACHINE_LAST_DATA))
222 {
223 if(pmsc->data_len == 0)
224 {
225 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
226 }
227 else if(pmsc->data_len > 0)
228 {
229 bot_scsi_send_data(udev, pmsc->data, pmsc->data_len);
230 }
231 }
232 }
233}
234
242void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
243{
244 usbd_core_type *pudev = (usbd_core_type *)udev;
245 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
246 uint32_t data_len = MIN(len, pmsc->cbw_struct.dCBWDataTransferLength);
247
248 pmsc->csw_struct.dCSWDataResidue -= data_len;
249 pmsc->csw_struct.bCSWStatus = CSW_BCSWSTATUS_PASS;
250
251 pmsc->msc_state = MSC_STATE_MACHINE_SEND_DATA;
252
253 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
254 buffer, data_len);
255}
256
263void bot_scsi_send_csw(void *udev, uint8_t status)
264{
265 usbd_core_type *pudev = (usbd_core_type *)udev;
266 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
267
268 pmsc->csw_struct.bCSWStatus = status;
269 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
270 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
271
272 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
273 (uint8_t *)&pmsc->csw_struct, CSW_CMD_LENGTH);
274
275 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
276 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
277}
278
279
287void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
288{
289 sense_data.sense_key = sense_key;
290 sense_data.asc = asc;
291}
292
293
302 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
303{
304 usbd_core_type *pudev = (usbd_core_type *)udev;
305 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
306 if((blk_offset + blk_count) > pmsc->blk_nbr[lun])
307 {
308 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, ADDRESS_OUT_OF_RANGE);
309 return USB_FAIL;
310 }
311 return USB_OK;
312}
313
319void bot_scsi_stall(void *udev)
320{
321 usbd_core_type *pudev = (usbd_core_type *)udev;
322 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
323
324 if((pmsc->cbw_struct.dCBWDataTransferLength != 0) &&
325 (pmsc->cbw_struct.bmCBWFlags == 0) &&
326 pmsc->bot_status == MSC_BOT_STATE_IDLE)
327 {
328 usbd_set_stall(pudev, USBD_MSC_BULK_OUT_EPT);
329 }
330 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
331
332 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
333 {
334 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
335 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
336 }
337}
338
345 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
346{
347 usb_sts_type status = USB_OK;
348 usbd_core_type *pudev = (usbd_core_type *)udev;
349 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
350
351 if(pmsc->cbw_struct.dCBWDataTransferLength != 0)
352 {
353 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
354 return USB_FAIL;
355 }
356
357 pmsc->data_len = 0;
358 return status;
359}
360
367 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
368{
369 uint8_t *pdata;
370 uint32_t trans_len = 0;
371 usb_sts_type status = USB_OK;
372 usbd_core_type *pudev = (usbd_core_type *)udev;
373 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
374
375 if(pmsc->cbw_struct.CBWCB[1] & 0x01)
376 {
377 pdata = page00_inquiry_data;
378 trans_len = 5;
379 }
380 else
381 {
382 pdata = get_inquiry(lun);
383 if(pmsc->cbw_struct.dCBWDataTransferLength < SCSI_INQUIRY_DATA_LENGTH)
384 {
385 trans_len = pmsc->cbw_struct.dCBWDataTransferLength;
386 }
387 else
388 {
389 trans_len = SCSI_INQUIRY_DATA_LENGTH;
390 }
391 }
392
393 pmsc->data_len = trans_len;
394 while(trans_len)
395 {
396 trans_len --;
397 pmsc->data[trans_len] = pdata[trans_len];
398 }
399 return status;
400}
401
408 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
409{
410 usbd_core_type *pudev = (usbd_core_type *)udev;
411 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
412 pmsc->data_len = 0;
413 return USB_OK;
414}
415
422 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
423{
424 usbd_core_type *pudev = (usbd_core_type *)udev;
425 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
426 pmsc->data_len = 0;
427 return USB_OK;
428}
429
436 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
437{
438 uint8_t data_len = 8;
439 usbd_core_type *pudev = (usbd_core_type *)udev;
440 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
441 pmsc->data_len = 8;
442 while(data_len)
443 {
444 data_len --;
445 pmsc->data[data_len] = mode_sense6_data[data_len];
446 };
447 return USB_OK;
448}
449
456 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
457{
458 uint8_t data_len = 8;
459 usbd_core_type *pudev = (usbd_core_type *)udev;
460 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
461 pmsc->data_len = 8;
462 while(data_len)
463 {
464 data_len --;
465 pmsc->data[data_len] = mode_sense10_data[data_len];
466 };
467 return USB_OK;
468}
469
476 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
477{
478 usbd_core_type *pudev = (usbd_core_type *)udev;
479 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
480 uint8_t *pdata = pmsc->data;
481 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
482
483 pdata[0] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
484 pdata[1] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
485 pdata[2] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
486 pdata[3] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
487
488 pdata[4] = (uint8_t)((pmsc->blk_size[lun]) >> 24);
489 pdata[5] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
490 pdata[6] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
491 pdata[7] = (uint8_t)((pmsc->blk_size[lun]));
492
493 pmsc->data_len = 8;
494 return USB_OK;
495}
496
503 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
504{
505 usbd_core_type *pudev = (usbd_core_type *)udev;
506 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
507 uint8_t *pdata = pmsc->data;
508
509 pdata[0] = 0;
510 pdata[1] = 0;
511 pdata[2] = 0;
512 pdata[3] = 0x08;
513
514 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
515
516 pdata[4] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
517 pdata[5] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
518 pdata[6] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
519 pdata[7] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
520
521 pdata[8] = 0x02;
522
523 pdata[9] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
524 pdata[10] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
525 pdata[11] = (uint8_t)((pmsc->blk_size[lun]));
526
527 pmsc->data_len = 12;
528
529 return USB_OK;
530}
531
538 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
539{
540 uint32_t trans_len = 0x12;
541 usbd_core_type *pudev = (usbd_core_type *)udev;
542 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
543 uint8_t *pdata = pmsc->data;
544 uint8_t *sdata = (uint8_t *)&sense_data;
545
546 while(trans_len)
547 {
548 trans_len --;
549 pdata[trans_len] = sdata[trans_len];
550 }
551
552 if(pmsc->cbw_struct.dCBWDataTransferLength < REQ_SENSE_STANDARD_DATA_LEN)
553 {
554 pmsc->data_len = pmsc->cbw_struct.dCBWDataTransferLength;
555 }
556 else
557 {
558 pmsc->data_len = REQ_SENSE_STANDARD_DATA_LEN;
559 }
560 return USB_OK;
561}
562
569 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
570{
571 usbd_core_type *pudev = (usbd_core_type *)udev;
572 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
573 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
574 if((pmsc->cbw_struct.CBWCB[1] & 0x02) == 0x02)
575 {
576 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_FIELED_IN_COMMAND);
577 return USB_FAIL;
578 }
579
580 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
581 pmsc->blk_len = cmd[7] << 8 | cmd[8];
582
583 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
584 {
585 return USB_FAIL;
586 }
587 pmsc->data_len = 0;
588 return USB_OK;
589}
590
597 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
598{
599 usbd_core_type *pudev = (usbd_core_type *)udev;
600 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
601 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
602 uint32_t len;
603
604 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
605 {
606 if((pmsc->cbw_struct.bmCBWFlags & 0x80) != 0x80)
607 {
608 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
609 return USB_FAIL;
610 }
611
612 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
613 pmsc->blk_len = cmd[7] << 8 | cmd[8];
614
615 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
616 {
617 return USB_FAIL;
618 }
619
620 pmsc->blk_addr *= pmsc->blk_size[lun];
621 pmsc->blk_len *= pmsc->blk_size[lun];
622
623 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
624 {
625 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
626 return USB_FAIL;
627 }
628 pmsc->msc_state = MSC_STATE_MACHINE_DATA_IN;
629 }
630 pmsc->data_len = MSC_MAX_DATA_BUF_LEN;
631
632 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
633 if( msc_disk_read(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
634 {
635 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
636 return USB_FAIL;
637 }
638 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT, pmsc->data, len);
639 pmsc->blk_addr += len;
640 pmsc->blk_len -= len;
641
642 pmsc->csw_struct.dCSWDataResidue -= len;
643 if(pmsc->blk_len == 0)
644 {
645 pmsc->msc_state = MSC_STATE_MACHINE_LAST_DATA;
646 }
647
648 return USB_OK;
649}
650
651
658 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
659{
660 usbd_core_type *pudev = (usbd_core_type *)udev;
661 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
662 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
663 uint32_t len;
664
665 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
666 {
667 if((pmsc->cbw_struct.bmCBWFlags & 0x80) == 0x80)
668 {
669 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
670 return USB_FAIL;
671 }
672
673 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
674 pmsc->blk_len = cmd[7] << 8 | cmd[8];
675
676 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
677 {
678 return USB_FAIL;
679 }
680
681 pmsc->blk_addr *= pmsc->blk_size[lun];
682 pmsc->blk_len *= pmsc->blk_size[lun];
683
684 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
685 {
686 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
687 return USB_FAIL;
688 }
689
690 pmsc->msc_state = MSC_STATE_MACHINE_DATA_OUT;
691 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
692 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
693
694 }
695 else
696 {
697 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
698 if(msc_disk_write(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
699 {
700 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
701 return USB_FAIL;
702 }
703
704 pmsc->blk_addr += len;
705 pmsc->blk_len -= len;
706
707 pmsc->csw_struct.dCSWDataResidue -= len;
708
709 if(pmsc->blk_len == 0)
710 {
711 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
712 }
713 else
714 {
715 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
716 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
717 }
718 }
719 return USB_OK;
720}
721
728void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
729{
730 usbd_core_type *pudev = (usbd_core_type *)udev;
731 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
732 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
733 {
734 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
735 pmsc->bot_status = MSC_BOT_STATE_IDLE;
736 }
737 else if(((ept_num & 0x80) == 0x80) && (pmsc->bot_status != MSC_BOT_STATE_RECOVERY))
738 {
739 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
740 }
741}
742
748 usb_sts_type bot_scsi_cmd_process(void *udev)
749{
750 usb_sts_type status = USB_FAIL;
751 usbd_core_type *pudev = (usbd_core_type *)udev;
752 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
753 switch(pmsc->cbw_struct.CBWCB[0])
754 {
755 case MSC_CMD_INQUIRY:
756 status = bot_scsi_inquiry(udev, pmsc->cbw_struct.bCBWLUN);
757 break;
758
759 case MSC_CMD_START_STOP:
760 status = bot_scsi_start_stop(udev, pmsc->cbw_struct.bCBWLUN);
761 break;
762
763 case MSC_CMD_MODE_SENSE6:
764 status = bot_scsi_mode_sense6(udev, pmsc->cbw_struct.bCBWLUN);
765 break;
766
767 case MSC_CMD_MODE_SENSE10:
768 status = bot_scsi_mode_sense10(udev, pmsc->cbw_struct.bCBWLUN);
769 break;
770
771 case MSC_CMD_ALLOW_MEDIUM_REMOVAL:
772 status = bot_scsi_allow_medium_removal(udev, pmsc->cbw_struct.bCBWLUN);
773 break;
774
775 case MSC_CMD_READ_10:
776 status = bot_scsi_read10(udev, pmsc->cbw_struct.bCBWLUN);
777 break;
778
779 case MSC_CMD_READ_CAPACITY:
780 status = bot_scsi_capacity(udev, pmsc->cbw_struct.bCBWLUN);
781 break;
782
783 case MSC_CMD_REQUEST_SENSE:
784 status = bot_scsi_request_sense(udev, pmsc->cbw_struct.bCBWLUN);
785 break;
786
787 case MSC_CMD_TEST_UNIT:
788 status = bot_scsi_test_unit(udev, pmsc->cbw_struct.bCBWLUN);
789 break;
790
791 case MSC_CMD_VERIFY:
792 status = bot_scsi_verify(udev, pmsc->cbw_struct.bCBWLUN);
793 break;
794
795 case MSC_CMD_WRITE_10:
796 status = bot_scsi_write10(udev, pmsc->cbw_struct.bCBWLUN);
797 break;
798
799 case MSC_CMD_READ_FORMAT_CAPACITY:
800 status = bot_scsi_format_capacity(udev, pmsc->cbw_struct.bCBWLUN);
801 break;
802
803 default:
804 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
805 status = USB_FAIL;
806 break;
807 }
808 return status;
809}
810
cdc_msc_class.h
usb cdc class file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:134
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:100
cdc_msc_struct_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:275
cdc_msc_struct_type::data
uint8_t data[4096]
Definition: cdc_msc_class.h:273
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:192
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:193
cdc_msc_struct_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:262
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:202
cbw_type::CBWCB
uint8_t CBWCB[16]
Definition: cdc_msc_class.h:194
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:205
cdc_msc_struct_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:270
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:203
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:204
cdc_msc_struct_type::blk_size
uint32_t blk_size[1]
Definition: cdc_msc_class.h:267
cdc_msc_struct_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:276
cdc_msc_struct_type::blk_addr
uint64_t blk_addr
Definition: cdc_msc_class.h:269
cdc_msc_struct_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:272
cdc_msc_struct_type::blk_nbr
uint32_t blk_nbr[1]
Definition: cdc_msc_class.h:266
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:190
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:264
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:189
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:188
cdc_msc_struct_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:263
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:191
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:55
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:56
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:503
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
bulk-only transport data in handler
Definition: composite_cdc_msc/msc_bot_scsi.c:142
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: composite_cdc_msc/msc_bot_scsi.c:408
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: composite_cdc_msc/msc_bot_scsi.c:538
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: composite_cdc_msc/msc_bot_scsi.c:597
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: composite_cdc_msc/msc_bot_scsi.c:302
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: composite_cdc_msc/msc_bot_scsi.c:658
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:124
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: composite_cdc_msc/msc_bot_scsi.c:456
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: composite_cdc_msc/msc_bot_scsi.c:287
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: composite_cdc_msc/msc_bot_scsi.c:195
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: composite_cdc_msc/msc_bot_scsi.c:569
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: composite_cdc_msc/msc_bot_scsi.c:422
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:102
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: composite_cdc_msc/msc_bot_scsi.c:748
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
bulk-only transport data out handler
Definition: composite_cdc_msc/msc_bot_scsi.c:171
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: composite_cdc_msc/msc_bot_scsi.c:436
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: composite_cdc_msc/msc_bot_scsi.c:319
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: composite_cdc_msc/msc_bot_scsi.c:242
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: composite_cdc_msc/msc_bot_scsi.c:345
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: composite_cdc_msc/msc_bot_scsi.c:367
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:476
ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL
Definition: composite_cdc_msc/msc_bot_scsi.c:44
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: composite_cdc_msc/msc_bot_scsi.c:728
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: composite_cdc_msc/msc_bot_scsi.c:263
MSC_STATE_MACHINE_DATA_IN
#define MSC_STATE_MACHINE_DATA_IN
Definition: cdc_msc_class.h:119
MSC_CMD_START_STOP
#define MSC_CMD_START_STOP
Definition: cdc_msc_class.h:86
MSC_CMD_VERIFY
#define MSC_CMD_VERIFY
Definition: cdc_msc_class.h:96
ADDRESS_OUT_OF_RANGE
#define ADDRESS_OUT_OF_RANGE
Definition: cdc_msc_class.h:151
SENSE_KEY_HARDWARE_ERROR
#define SENSE_KEY_HARDWARE_ERROR
Definition: cdc_msc_class.h:136
MEDIUM_NOT_PRESENT
#define MEDIUM_NOT_PRESENT
Definition: cdc_msc_class.h:152
MSC_CMD_MODE_SENSE6
#define MSC_CMD_MODE_SENSE6
Definition: cdc_msc_class.h:87
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:155
MSC_CMD_ALLOW_MEDIUM_REMOVAL
#define MSC_CMD_ALLOW_MEDIUM_REMOVAL
Definition: cdc_msc_class.h:89
CSW_CMD_LENGTH
#define CSW_CMD_LENGTH
Definition: cdc_msc_class.h:112
MSC_BOT_STATE_IDLE
#define MSC_BOT_STATE_IDLE
Definition: cdc_msc_class.h:127
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:82
CSW_DCSWSIGNATURE
#define CSW_DCSWSIGNATURE
Definition: cdc_msc_class.h:113
MSC_CMD_INQUIRY
#define MSC_CMD_INQUIRY
Definition: cdc_msc_class.h:85
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:81
INVALID_COMMAND
#define INVALID_COMMAND
Definition: cdc_msc_class.h:147
MSC_CMD_WRITE_10
#define MSC_CMD_WRITE_10
Definition: cdc_msc_class.h:97
MSC_STATE_MACHINE_IDLE
#define MSC_STATE_MACHINE_IDLE
Definition: cdc_msc_class.h:125
MSC_CMD_READ_FORMAT_CAPACITY
#define MSC_CMD_READ_FORMAT_CAPACITY
Definition: cdc_msc_class.h:93
MSC_CMD_MODE_SENSE10
#define MSC_CMD_MODE_SENSE10
Definition: cdc_msc_class.h:88
SENSE_KEY_ILLEGAL_REQUEST
#define SENSE_KEY_ILLEGAL_REQUEST
Definition: cdc_msc_class.h:137
MSC_STATE_MACHINE_DATA_OUT
#define MSC_STATE_MACHINE_DATA_OUT
Definition: cdc_msc_class.h:120
CSW_BCSWSTATUS_PASS
#define CSW_BCSWSTATUS_PASS
Definition: cdc_msc_class.h:114
INVALID_FIELED_IN_COMMAND
#define INVALID_FIELED_IN_COMMAND
Definition: cdc_msc_class.h:148
REQ_SENSE_STANDARD_DATA_LEN
#define REQ_SENSE_STANDARD_DATA_LEN
Definition: cdc_msc_class.h:131
MSC_STATE_MACHINE_SEND_DATA
#define MSC_STATE_MACHINE_SEND_DATA
Definition: cdc_msc_class.h:121
CBW_DCBWSIGNATURE
#define CBW_DCBWSIGNATURE
Definition: cdc_msc_class.h:108
MSC_CMD_READ_10
#define MSC_CMD_READ_10
Definition: cdc_msc_class.h:90
MSC_BOT_STATE_RECOVERY
#define MSC_BOT_STATE_RECOVERY
Definition: cdc_msc_class.h:128
CBW_CMD_LENGTH
#define CBW_CMD_LENGTH
Definition: cdc_msc_class.h:107
MSC_STATE_MACHINE_LAST_DATA
#define MSC_STATE_MACHINE_LAST_DATA
Definition: cdc_msc_class.h:122
MSC_CMD_TEST_UNIT
#define MSC_CMD_TEST_UNIT
Definition: cdc_msc_class.h:95
CSW_BCSWSTATUS_FAILED
#define CSW_BCSWSTATUS_FAILED
Definition: cdc_msc_class.h:115
MSC_CMD_READ_CAPACITY
#define MSC_CMD_READ_CAPACITY
Definition: cdc_msc_class.h:92
MSC_BOT_STATE_ERROR
#define MSC_BOT_STATE_ERROR
Definition: cdc_msc_class.h:129
MSC_CMD_REQUEST_SENSE
#define MSC_CMD_REQUEST_SENSE
Definition: cdc_msc_class.h:94
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:280
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:259
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:251
sense_type
request sense standard data
Definition: cdc_msc_class.h:212
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111


AT32F413 Firmwary Library: msc_diskio.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
composite_vcp_msc/inc/msc_diskio.h
Go to the documentation of this file.
1
24/* Define to prevent recursive inclusion -------------------------------------*/
25#ifndef __MSC_DISKIO_H
26#define __MSC_DISKIO_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32
33#include "usb_conf.h"
34#include "usb_std.h"
35
43#define INTERNAL_FLASH_LUN 0
44#define SPI_FLASH_LUN 1
45#define SD_LUN 2
46
47#define USB_FLASH_ADDR_OFFSET 0x08005000
48
49#define SECTOR_SIZE_1K 1024
50#define SECTOR_SIZE_2K 2048
51#define SECTOR_SIZE_4K 4096
52
53uint8_t *get_inquiry(uint8_t lun);
54 usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len);
55 usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len);
56 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
57
66#ifdef __cplusplus
67}
68#endif
69
70#endif
71
72
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:134
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:100
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F413 Firmwary Library: msc_diskio.c Source File

  • usb_device
  • composite_vcp_msc
  • src
composite_vcp_msc/src/msc_diskio.c
Go to the documentation of this file.
1
24#include "msc_diskio.h"
25#include "cdc_msc_class.h"
26
34uint32_t sector_size = 2048;
35uint32_t msc_flash_size;
36uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
37{
38 /* lun = 0 */
39 {
40 0x00, /* peripheral device type (direct-access device) */
41 0x80, /* removable media bit */
42 0x00, /* ansi version, ecma version, iso version */
43 0x01, /* respond data format */
44 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
45 0x00, 0x00, 0x00, /* reserved */
46 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
47 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
48 '2', '.', '0', '0' /* product revision level */
49 }
50};
51
57uint8_t *get_inquiry(uint8_t lun)
58{
59 if(lun < MSC_SUPPORT_MAX_LUN)
60 return (uint8_t *)scsi_inquiry[lun];
61 else
62 return NULL;
63}
64
73 usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
74{
75 uint32_t i = 0;
76 uint32_t flash_addr = (uint32_t)addr + USB_FLASH_ADDR_OFFSET;
77 switch(lun)
78 {
79 case 0:
80 for(i = 0; i < len; i ++)
81 {
82 read_buf[i] = *((uint8_t *)flash_addr);
83 flash_addr += 1;
84 }
85 break;
86 case 1:
87 break;
88 }
89 return USB_OK;
90}
91
100 usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
101{
102 uint32_t flash_addr = (uint32_t)addr + USB_FLASH_ADDR_OFFSET;
103 uint32_t i = 0, page_len = 2048, tolen = len;
104 uint32_t erase_addr = flash_addr;
105 switch(lun)
106 {
107 case 0:
108 flash_unlock();
109 while(tolen >= page_len)
110 {
111 flash_sector_erase(erase_addr);
112 tolen -= page_len;
113 erase_addr += page_len;
114 }
115 for(i = 0; i < len; i ++)
116 {
117 flash_byte_program(flash_addr+i, buf[i]);
118 }
119 flash_lock();
120 break;
121 case 1:
122 break;
123 }
124 return USB_OK;
125}
126
134 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
135{
136 uint32_t flash_s = *((uint32_t *)0x1FFFF7E0);
137 msc_flash_size = (flash_s << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
138
139 if(flash_s < 256)
140 {
141 sector_size = SECTOR_SIZE_1K;
142 }
143 else
144 {
145 sector_size = SECTOR_SIZE_2K;
146 }
147
148 switch(lun)
149 {
150 case INTERNAL_FLASH_LUN:
151 *blk_nbr = msc_flash_size / sector_size;
152 *blk_size = sector_size;
153 break;
154 case SPI_FLASH_LUN:
155 break;
156 case SD_LUN:
157 break;
158 default:
159 break;
160 }
161 return USB_OK;
162}
163
cdc_msc_class.h
usb cdc class file
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: composite_vcp_msc/inc/msc_diskio.h:47
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:43
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:134
msc_flash_size
uint32_t msc_flash_size
Definition: composite_vcp_msc/src/msc_diskio.c:35
sector_size
uint32_t sector_size
Definition: composite_vcp_msc/src/msc_diskio.c:34
SD_LUN
#define SD_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:45
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: composite_vcp_msc/src/msc_diskio.c:36
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:44
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:100
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:489
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:59
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:60
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:155
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:81
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279


AT32F413 Firmwary Library: custom_hid_class.c Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "custom_hid_class.h"
26#include "custom_hid_desc.h"
27
41static usb_sts_type class_init_handler(void *udev);
42static usb_sts_type class_clear_handler(void *udev);
43static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
44static usb_sts_type class_ept0_tx_handler(void *udev);
45static usb_sts_type class_ept0_rx_handler(void *udev);
46static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
47static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_sof_handler(void *udev);
49static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
50
51static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len);
52 custom_hid_type custom_hid_struct;
53
54/* usb device class handler */
55 usbd_class_handler custom_hid_class_handler =
56{
57 class_init_handler,
58 class_clear_handler,
59 class_setup_handler,
60 class_ept0_tx_handler,
61 class_ept0_rx_handler,
62 class_in_handler,
63 class_out_handler,
64 class_sof_handler,
65 class_event_handler,
66 &custom_hid_struct
67};
68
74 usb_sts_type class_init_handler(void *udev)
75{
76 usb_sts_type status = USB_OK;
77 usbd_core_type *pudev = (usbd_core_type *)udev;
78 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
79#ifndef USB_EPT_AUTO_MALLOC_BUFFER
80 /* use user define buffer address */
81 usbd_ept_buf_custom_define(pudev, USBD_CUSTOM_HID_IN_EPT, EPT1_TX_ADDR);
82 usbd_ept_buf_custom_define(pudev, USBD_CUSTOM_HID_OUT_EPT, EPT1_RX_ADDR);
83#endif
84
85 /* open custom hid in endpoint */
86 usbd_ept_open(pudev, USBD_CUSTOM_HID_IN_EPT, EPT_INT_TYPE, USBD_CUSTOM_IN_MAXPACKET_SIZE);
87
88 /* open custom hid out endpoint */
89 usbd_ept_open(pudev, USBD_CUSTOM_HID_OUT_EPT, EPT_INT_TYPE, USBD_CUSTOM_OUT_MAXPACKET_SIZE);
90
91 /* set out endpoint to receive status */
92 usbd_ept_recv(pudev, USBD_CUSTOM_HID_OUT_EPT, pcshid->g_rxhid_buff, USBD_CUSTOM_OUT_MAXPACKET_SIZE);
93
94 return status;
95}
96
102static usb_sts_type class_clear_handler(void *udev)
103{
104 usb_sts_type status = USB_OK;
105 usbd_core_type *pudev = (usbd_core_type *)udev;
106
107 /* close custom hid in endpoint */
108 usbd_ept_close(pudev, USBD_CUSTOM_HID_IN_EPT);
109
110 /* close custom hid out endpoint */
111 usbd_ept_close(pudev, USBD_CUSTOM_HID_OUT_EPT);
112
113 return status;
114}
115
122static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
123{
124 usb_sts_type status = USB_OK;
125 usbd_core_type *pudev = (usbd_core_type *)udev;
126 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
127 uint16_t len;
128 uint8_t *buf;
129
130 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
131 {
132 /* class request */
133 case USB_REQ_TYPE_CLASS:
134 switch(setup->bRequest)
135 {
136 case HID_REQ_SET_PROTOCOL:
137 pcshid->hid_protocol = (uint8_t)setup->wValue;
138 break;
139 case HID_REQ_GET_PROTOCOL:
140 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->hid_protocol, 1);
141 break;
142 case HID_REQ_SET_IDLE:
143 pcshid->hid_set_idle = (uint8_t)(setup->wValue >> 8);
144 break;
145 case HID_REQ_GET_IDLE:
146 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->hid_set_idle, 1);
147 break;
148 case HID_REQ_SET_REPORT:
149 pcshid->hid_state = HID_REQ_SET_REPORT;
150 usbd_ctrl_recv(pudev, pcshid->hid_set_report, setup->wLength);
151 break;
152 case HID_REQ_GET_REPORT:
153 usbd_ctrl_send(pudev, pcshid->hid_get_report, setup->wLength);
154 break;
155 default:
156 usbd_ctrl_unsupport(pudev);
157 break;
158 }
159 break;
160 /* standard request */
161 case USB_REQ_TYPE_STANDARD:
162 switch(setup->bRequest)
163 {
164 case USB_STD_REQ_GET_DESCRIPTOR:
165 if(setup->wValue >> 8 == HID_REPORT_DESC)
166 {
167 len = MIN(USBD_CUSHID_SIZ_REPORT_DESC, setup->wLength);
168 buf = (uint8_t *)g_usbd_custom_hid_report;
169 }
170 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
171 {
172 len = MIN(9, setup->wLength);
173 buf = (uint8_t *)g_custom_hid_usb_desc;
174 }
175 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
176 break;
177 case USB_STD_REQ_GET_INTERFACE:
178 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->alt_setting, 1);
179 break;
180 case USB_STD_REQ_SET_INTERFACE:
181 pcshid->alt_setting = setup->wValue;
182 break;
183 case USB_STD_REQ_CLEAR_FEATURE:
184 break;
185 case USB_STD_REQ_SET_FEATURE:
186 break;
187 default:
188 usbd_ctrl_unsupport(pudev);
189 break;
190 }
191 break;
192 default:
193 usbd_ctrl_unsupport(pudev);
194 break;
195 }
196 return status;
197}
198
204static usb_sts_type class_ept0_tx_handler(void *udev)
205{
206 usb_sts_type status = USB_OK;
207
208 /* ...user code... */
209
210 return status;
211}
212
218static usb_sts_type class_ept0_rx_handler(void *udev)
219{
220 usb_sts_type status = USB_OK;
221 usbd_core_type *pudev = (usbd_core_type *)udev;
222 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
223 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
224 /* ...user code... */
225 if( pcshid->hid_state == HID_REQ_SET_REPORT)
226 {
227 /* hid buffer process */
228 usb_hid_buf_process(udev, pcshid->hid_set_report, recv_len);
229 pcshid->hid_state = 0;
230 }
231
232 return status;
233}
234
241static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
242{
243 usb_sts_type status = USB_OK;
244
245 /* ...user code...
246 trans next packet data
247 */
248
249 return status;
250}
251
258static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
259{
260 usb_sts_type status = USB_OK;
261 usbd_core_type *pudev = (usbd_core_type *)udev;
262 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
263
264 /* get endpoint receive data length */
265 uint32_t recv_len = usbd_get_recv_len(pudev, ept_num);
266
267 /* hid buffer process */
268 usb_hid_buf_process(udev, pcshid->g_rxhid_buff, recv_len);
269
270 /* start receive next packet */
271 usbd_ept_recv(pudev, USBD_CUSTOM_HID_OUT_EPT, pcshid->g_rxhid_buff, recv_len);
272
273 return status;
274}
275
281static usb_sts_type class_sof_handler(void *udev)
282{
283 usb_sts_type status = USB_OK;
284
285 /* ...user code... */
286
287 return status;
288}
289
296static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
297{
298 usb_sts_type status = USB_OK;
299 switch(event)
300 {
301 case USBD_RESET_EVENT:
302
303 /* ...user code... */
304
305 break;
306 case USBD_SUSPEND_EVENT:
307
308 /* ...user code... */
309
310 break;
311 case USBD_WAKEUP_EVENT:
312 /* ...user code... */
313
314 break;
315 default:
316 break;
317 }
318 return status;
319}
320
328 usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
329{
330 usb_sts_type status = USB_OK;
331 usbd_core_type *pudev = (usbd_core_type *)udev;
332
333 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
334 usbd_ept_send(pudev, USBD_CUSTOM_HID_IN_EPT, report, len);
335
336 return status;
337}
338
346static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
347{
348 uint32_t i_index;
349 usbd_core_type *pudev = (usbd_core_type *)udev;
350 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
351
352 switch(report[0])
353 {
354 case HID_REPORT_ID_2:
355 if(pcshid->g_rxhid_buff[1] == 0)
356 {
357 at32_led_off(LED2);
358 }
359 else
360 {
361 at32_led_on(LED2);
362 }
363 break;
364 case HID_REPORT_ID_3:
365 if(pcshid->g_rxhid_buff[1] == 0)
366 {
367 at32_led_off(LED3);
368 }
369 else
370 {
371 at32_led_on(LED3);
372 }
373 break;
374 case HID_REPORT_ID_4:
375 if(pcshid->g_rxhid_buff[1] == 0)
376 {
377 at32_led_off(LED4);
378 }
379 else
380 {
381 at32_led_on(LED4);
382 }
383 break;
384 case HID_REPORT_ID_6:
385 for(i_index = 0; i_index < len; i_index ++)
386 {
387 pcshid->g_txhid_buff[i_index] = report[i_index];
388 }
389 usbd_ept_send(pudev, USBD_CUSTOM_HID_IN_EPT, pcshid->g_txhid_buff, len);
390 break;
391 default:
392 break;
393 }
394
395}
396
custom_hid_class.h
usb custom hid header file
custom_hid_desc.h
usb custom hid descriptor header file
EPT1_RX_ADDR
#define EPT1_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:76
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:75
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:61
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:221
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:223
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:225
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:222
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:57
USBD_CUSTOM_HID_IN_EPT
#define USBD_CUSTOM_HID_IN_EPT
usb custom hid use endpoint define
Definition: custom_hid_class.h:51
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:58
USBD_CUSTOM_HID_OUT_EPT
#define USBD_CUSTOM_HID_OUT_EPT
Definition: custom_hid_class.h:52
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: custom_hid_class.c:281
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: custom_hid_class.c:241
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: custom_hid_class.c:102
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: custom_hid_class.c:122
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: custom_hid_class.c:204
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:328
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: custom_hid_class.c:218
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: custom_hid_class.c:296
usb_hid_buf_process
static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
usb device class report function
Definition: custom_hid_class.c:346
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: custom_hid_class.c:258
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: custom_hid_class.c:74
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:55
custom_hid_struct
custom_hid_type custom_hid_struct
Definition: custom_hid_class.c:52
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:64
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:265
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:167
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
HID_REQ_GET_REPORT
#define HID_REQ_GET_REPORT
Definition: usb_std.h:233
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:234
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:229
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:228
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:235
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:230
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:231
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:232
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
custom_hid_type
Definition: custom_hid_class.h:69
custom_hid_type::g_txhid_buff
uint8_t g_txhid_buff[0x40]
Definition: custom_hid_class.h:71
custom_hid_type::alt_setting
uint32_t alt_setting
Definition: custom_hid_class.h:75
custom_hid_type::hid_set_report
uint8_t hid_set_report[64]
Definition: custom_hid_class.h:77
custom_hid_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: custom_hid_class.h:70
custom_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: custom_hid_class.h:74
custom_hid_type::hid_protocol
uint32_t hid_protocol
Definition: custom_hid_class.h:73
custom_hid_type::hid_state
uint8_t hid_state
Definition: custom_hid_class.h:79
custom_hid_type::hid_get_report
uint8_t hid_get_report[64]
Definition: custom_hid_class.h:78
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: custom_hid_class.h Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CUSTOM_HID_CLASS_H
27#define __CUSTOM_HID_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
51#define USBD_CUSTOM_HID_IN_EPT 0x81
52#define USBD_CUSTOM_HID_OUT_EPT 0x01
53
57#define USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
58#define USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40
59
68typedef struct
69{
70 uint8_t g_rxhid_buff[USBD_CUSTOM_OUT_MAXPACKET_SIZE];
71 uint8_t g_txhid_buff[USBD_CUSTOM_IN_MAXPACKET_SIZE];
72
73 uint32_t hid_protocol;
74 uint32_t hid_set_idle;
75 uint32_t alt_setting;
76
77 uint8_t hid_set_report[64];
78 uint8_t hid_get_report[64];
79 uint8_t hid_state;
80}custom_hid_type;
81
89extern usbd_class_handler custom_hid_class_handler;
90 usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len);
102#ifdef __cplusplus
103}
104#endif
105
106#endif
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:57
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:58
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:328
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:55
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
custom_hid_type
Definition: custom_hid_class.h:69
custom_hid_type::alt_setting
uint32_t alt_setting
Definition: custom_hid_class.h:75
custom_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: custom_hid_class.h:74
custom_hid_type::hid_protocol
uint32_t hid_protocol
Definition: custom_hid_class.h:73
custom_hid_type::hid_state
uint8_t hid_state
Definition: custom_hid_class.h:79
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: custom_hid_desc.c Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "custom_hid_desc.h"
28
41static usbd_desc_t *get_device_descriptor(void);
42static usbd_desc_t *get_device_qualifier(void);
43static usbd_desc_t *get_device_configuration(void);
44static usbd_desc_t *get_device_other_speed(void);
45static usbd_desc_t *get_device_lang_id(void);
46static usbd_desc_t *get_device_manufacturer_string(void);
47static usbd_desc_t *get_device_product_string(void);
48static usbd_desc_t *get_device_serial_string(void);
49static usbd_desc_t *get_device_interface_string(void);
50static usbd_desc_t *get_device_config_string(void);
51
52static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
53static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
54static void get_serial_num(void);
55#if defined ( __ICCARM__ ) /* iar compiler */
56 #pragma data_alignment=4
57#endif
58ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
59
63 usbd_desc_handler custom_hid_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0x00, /* bDeviceClass */
90 0x00, /* bDeviceSubClass */
91 0x00, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_CUSHID_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_CUSHID_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_CUSHID_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_CUSHID_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 1 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CUSHID_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_CUSHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_CUSHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x01, /* bNumInterfaces: 1 interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xC0, /* bmAttributes: self powered */
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
125 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
126 0x00, /* bInterfaceNumber: number of interface */
127 0x00, /* bAlternateSetting: alternate set */
128 0x02, /* bNumEndpoints: number of endpoints */
129 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
130 0x00, /* bInterfaceSubClass: subclass code */
131 0x00, /* bInterfaceProtocol: protocol code */
132 0x00, /* iInterface: index of string descriptor */
133
134 0x09, /* bLength: size of HID descriptor in bytes */
135 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
136 LBYTE(CUSHID_BCD_NUM),
137 HBYTE(CUSHID_BCD_NUM), /* bcdHID: HID class specification release number */
138 0x00, /* bCountryCode: hardware target conutry */
139 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
140 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
141 LBYTE(sizeof(g_usbd_custom_hid_report)),
142 HBYTE(sizeof(g_usbd_custom_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
143
144 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
145 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
146 USBD_CUSTOM_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
147 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
148 LBYTE(USBD_CUSTOM_IN_MAXPACKET_SIZE),
149 HBYTE(USBD_CUSTOM_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
150 CUSHID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
151
152 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
153 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
154 USBD_CUSTOM_HID_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
155 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
156 LBYTE(USBD_CUSTOM_OUT_MAXPACKET_SIZE),
157 HBYTE(USBD_CUSTOM_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
158 CUSHID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
159};
160
164#if defined ( __ICCARM__ ) /* iar compiler */
165 #pragma data_alignment=4
166#endif
167ALIGNED_HEAD uint8_t g_usbd_custom_hid_report[USBD_CUSHID_SIZ_REPORT_DESC] ALIGNED_TAIL =
168{
169 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
170 0x09, 0x01, /* USAGE (Demo Kit) */
171 0xa1, 0x01, /* COLLECTION (Application) */
172 /* 7 */
173
174 /* Led 2 */
175 0x85, HID_REPORT_ID_2, /* REPORT_ID 2 */
176 0x09, 0x02, /* USAGE (LED 2) */
177 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
178 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
179 0x75, 0x08, /* REPORT_SIZE (8) */
180 0x95, 0x3F, /* REPORT_COUNT (1) */
181 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
182
183 0x85, 0x02, /* REPORT_ID (2) */
184 0x09, 0x02, /* USAGE (LED 2) */
185 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
186 /* 27 */
187
188 /* Led 3 */
189 0x85, HID_REPORT_ID_3, /* REPORT_ID (3) */
190 0x09, 0x03, /* USAGE (LED 3) */
191 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
192 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
193 0x75, 0x08, /* REPORT_SIZE (8) */
194 0x95, 0x3F, /* REPORT_COUNT (1) */
195 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
196
197 0x85, 0x03, /* REPORT_ID (3) */
198 0x09, 0x03, /* USAGE (LED 3) */
199 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
200 /* 47 */
201
202 /* Led 4 */
203 0x85, HID_REPORT_ID_4, /* REPORT_ID 4) */
204 0x09, 0x04, /* USAGE (LED 4) */
205 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
206 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
207 0x75, 0x08, /* REPORT_SIZE (8) */
208 0x95, 0x3F, /* REPORT_COUNT (1) */
209 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
210
211 0x85, 0x04, /* REPORT_ID (4) */
212 0x09, 0x04, /* USAGE (LED 4) */
213 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
214 /* 67 */
215
216 /* key Push Button */
217 0x85, HID_REPORT_ID_5, /* REPORT_ID (5) */
218 0x09, 0x05, /* USAGE (Push Button) */
219 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
220 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
221 0x75, 0x01, /* REPORT_SIZE (1) */
222 0x81, 0x82, /* INPUT (Data,Var,Abs,Vol) */
223
224 0x09, 0x05, /* USAGE (Push Button) */
225 0x75, 0x01, /* REPORT_SIZE (1) */
226 0xb1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
227
228 0x75, 0x07, /* REPORT_SIZE (7) */
229 0x81, 0x83, /* INPUT (Cnst,Var,Abs,Vol) */
230 0x85, 0x05, /* REPORT_ID (5) */
231
232 0x75, 0x07, /* REPORT_SIZE (7) */
233 0xb1, 0x83, /* FEATURE (Cnst,Var,Abs,Vol) */
234 /* 95 */
235
236 /* Data OUT */
237 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
238 0x09, 0x06, /* USAGE */
239 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
240 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
241 0x75, 0x08, /* REPORT_SIZE (8) */
242 0x95, 0x3F, /* REPORT_COUNT (64) */
243 0x91, 0x02, /* OUTPUT(Data,Var,Abs,Vol) */
244 /* 110 */
245
246 /* Data IN */
247 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
248 0x09, 0x07, /* USAGE */
249 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
250 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
251 0x75, 0x08, /* REPORT_SIZE (8) */
252 0x95, 0x3F, /* REPORT_COUNT (64) */
253 0x81, 0x82, /* INPUT(Data,Var,Abs,Vol) */
254
255 /* 125 */
256 0xc0 /* END_COLLECTION */
257};
258
262#if defined ( __ICCARM__ ) /* iar compiler */
263 #pragma data_alignment=4
264#endif
265ALIGNED_HEAD uint8_t g_custom_hid_usb_desc[9] ALIGNED_TAIL =
266{
267 0x09, /* bLength: size of HID descriptor in bytes */
268 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
269 LBYTE(CUSHID_BCD_NUM),
270 HBYTE(CUSHID_BCD_NUM), /* bcdHID: HID class specification release number */
271 0x00, /* bCountryCode: hardware target conutry */
272 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
273 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
274 LBYTE(sizeof(g_usbd_custom_hid_report)),
275 HBYTE(sizeof(g_usbd_custom_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
276};
277
278
282#if defined ( __ICCARM__ ) /* iar compiler */
283 #pragma data_alignment=4
284#endif
285ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CUSHID_SIZ_STRING_LANGID] ALIGNED_TAIL =
286{
287 USBD_CUSHID_SIZ_STRING_LANGID,
288 USB_DESCIPTOR_TYPE_STRING,
289 0x09,
290 0x04,
291};
292
296#if defined ( __ICCARM__ ) /* iar compiler */
297 #pragma data_alignment=4
298#endif
299ALIGNED_HEAD static uint8_t g_string_serial[USBD_CUSHID_SIZ_STRING_SERIAL] ALIGNED_TAIL =
300{
301 USBD_CUSHID_SIZ_STRING_SERIAL,
302 USB_DESCIPTOR_TYPE_STRING,
303};
304
305
306/* device descriptor */
307static usbd_desc_t device_descriptor =
308{
309 USB_DEVICE_DESC_LEN,
310 g_usbd_descriptor
311};
312
313/* config descriptor */
314static usbd_desc_t config_descriptor =
315{
316 USBD_CUSHID_CONFIG_DESC_SIZE,
317 g_usbd_configuration
318};
319
320/* langid descriptor */
321static usbd_desc_t langid_descriptor =
322{
323 USBD_CUSHID_SIZ_STRING_LANGID,
324 g_string_lang_id
325};
326
327/* serial descriptor */
328static usbd_desc_t serial_descriptor =
329{
330 USBD_CUSHID_SIZ_STRING_SERIAL,
331 g_string_serial
332};
333
334static usbd_desc_t vp_desc;
335
342static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
343{
344 uint16_t str_len = 0, id_pos = 2;
345 uint8_t *tmp_str = string;
346
347 while(*tmp_str != '\0')
348 {
349 str_len ++;
350 unicode_buf[id_pos ++] = *tmp_str ++;
351 unicode_buf[id_pos ++] = 0x00;
352 }
353
354 str_len = str_len * 2 + 2;
355 unicode_buf[0] = str_len;
356 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
357
358 return str_len;
359}
360
368static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
369{
370 uint8_t idx = 0;
371
372 for( idx = 0 ; idx < len ; idx ++)
373 {
374 if( ((value >> 28)) < 0xA )
375 {
376 pbuf[ 2 * idx] = (value >> 28) + '0';
377 }
378 else
379 {
380 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
381 }
382
383 value = value << 4;
384
385 pbuf[2 * idx + 1] = 0;
386 }
387}
388
394static void get_serial_num(void)
395{
396 uint32_t serial0, serial1, serial2;
397
398 serial0 = *(uint32_t*)MCU_ID1;
399 serial1 = *(uint32_t*)MCU_ID2;
400 serial2 = *(uint32_t*)MCU_ID3;
401
402 serial0 += serial2;
403
404 if (serial0 != 0)
405 {
406 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
407 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
408 }
409}
410
416static usbd_desc_t *get_device_descriptor(void)
417{
418 return &device_descriptor;
419}
420
426static usbd_desc_t * get_device_qualifier(void)
427{
428 return NULL;
429}
430
436static usbd_desc_t *get_device_configuration(void)
437{
438 return &config_descriptor;
439}
440
446static usbd_desc_t *get_device_other_speed(void)
447{
448 return NULL;
449}
450
456static usbd_desc_t *get_device_lang_id(void)
457{
458 return &langid_descriptor;
459}
460
461
467static usbd_desc_t *get_device_manufacturer_string(void)
468{
469 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
470 vp_desc.descriptor = g_usbd_desc_buffer;
471 return &vp_desc;
472}
473
479static usbd_desc_t *get_device_product_string(void)
480{
481 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
482 vp_desc.descriptor = g_usbd_desc_buffer;
483 return &vp_desc;
484}
485
491static usbd_desc_t *get_device_serial_string(void)
492{
493 get_serial_num();
494 return &serial_descriptor;
495}
496
502static usbd_desc_t *get_device_interface_string(void)
503{
504 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
505 vp_desc.descriptor = g_usbd_desc_buffer;
506 return &vp_desc;
507}
508
514static usbd_desc_t *get_device_config_string(void)
515{
516 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
517 vp_desc.descriptor = g_usbd_desc_buffer;
518 return &vp_desc;
519}
520
custom_hid_desc.h
usb custom hid descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:221
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:223
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:225
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:222
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:224
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:57
USBD_CUSTOM_HID_IN_EPT
#define USBD_CUSTOM_HID_IN_EPT
usb custom hid use endpoint define
Definition: custom_hid_class.h:51
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:58
USBD_CUSTOM_HID_OUT_EPT
#define USBD_CUSTOM_HID_OUT_EPT
Definition: custom_hid_class.h:52
USBD_CUSHID_SIZ_STRING_SERIAL
#define USBD_CUSHID_SIZ_STRING_SERIAL
Definition: custom_hid_desc.h:66
USBD_CUSHID_VENDOR_ID
#define USBD_CUSHID_VENDOR_ID
usb vendor id and product id define
Definition: custom_hid_desc.h:57
USBD_CUSHID_DESC_CONFIGURATION_STRING
#define USBD_CUSHID_DESC_CONFIGURATION_STRING
Definition: custom_hid_desc.h:73
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:64
CUSHID_BINTERVAL_TIME
#define CUSHID_BINTERVAL_TIME
Definition: custom_hid_desc.h:76
USBD_CUSHID_DESC_MANUFACTURER_STRING
#define USBD_CUSHID_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: custom_hid_desc.h:71
USBD_CUSHID_CONFIG_DESC_SIZE
#define USBD_CUSHID_CONFIG_DESC_SIZE
usb descriptor size define
Definition: custom_hid_desc.h:63
USBD_CUSHID_DESC_INTERFACE_STRING
#define USBD_CUSHID_DESC_INTERFACE_STRING
Definition: custom_hid_desc.h:74
USBD_CUSHID_PRODUCT_ID
#define USBD_CUSHID_PRODUCT_ID
Definition: custom_hid_desc.h:58
USBD_CUSHID_SIZ_STRING_LANGID
#define USBD_CUSHID_SIZ_STRING_LANGID
Definition: custom_hid_desc.h:65
USBD_CUSHID_DESC_PRODUCT_STRING
#define USBD_CUSHID_DESC_PRODUCT_STRING
Definition: custom_hid_desc.h:72
CUSHID_BCD_NUM
#define CUSHID_BCD_NUM
usb bcd number define
Definition: custom_hid_desc.h:52
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: custom_hid_desc.c:328
device_descriptor
static usbd_desc_t device_descriptor
Definition: custom_hid_desc.c:307
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: custom_hid_desc.c:436
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: custom_hid_desc.c:321
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: custom_hid_desc.c:416
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: custom_hid_desc.c:467
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: custom_hid_desc.c:426
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: custom_hid_desc.c:502
vp_desc
static usbd_desc_t vp_desc
Definition: custom_hid_desc.c:334
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: custom_hid_desc.c:446
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: custom_hid_desc.c:58
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: custom_hid_desc.c:479
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:63
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: custom_hid_desc.c:514
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:265
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: custom_hid_desc.c:342
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:167
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: custom_hid_desc.c:456
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: custom_hid_desc.c:394
config_descriptor
static usbd_desc_t config_descriptor
Definition: custom_hid_desc.c:314
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: custom_hid_desc.c:491
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: custom_hid_desc.c:368
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:161
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: custom_hid_desc.h Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __CUSTOM_HID_DESC_H
27#define __CUSTOM_HID_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "custom_hid_class.h"
34#include "usbd_core.h"
35
52#define CUSHID_BCD_NUM 0x0110
53
57#define USBD_CUSHID_VENDOR_ID 0x2E3C
58#define USBD_CUSHID_PRODUCT_ID 0x5745
59
63#define USBD_CUSHID_CONFIG_DESC_SIZE 41
64#define USBD_CUSHID_SIZ_REPORT_DESC 126
65#define USBD_CUSHID_SIZ_STRING_LANGID 4
66#define USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
67
71#define USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
72#define USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
73#define USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
74#define USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
75
76#define CUSHID_BINTERVAL_TIME 0x0A
77
84#define HID_REPORT_ID_1 0x01
85#define HID_REPORT_ID_2 0x02
86#define HID_REPORT_ID_3 0x03
87#define HID_REPORT_ID_4 0x04
88#define HID_REPORT_ID_5 0x05
89#define HID_REPORT_ID_6 0xF0
90
94#define MCU_ID1 (0x1FFFF7E8)
95#define MCU_ID2 (0x1FFFF7EC)
96#define MCU_ID3 (0x1FFFF7F0)
97
101extern uint8_t g_usbd_custom_hid_report[USBD_CUSHID_SIZ_REPORT_DESC];
102extern uint8_t g_custom_hid_usb_desc[9];
103extern usbd_desc_handler custom_hid_desc_handler;
104
112#ifdef __cplusplus
113}
114#endif
115
116#endif
117
118
custom_hid_class.h
usb custom hid header file
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:64
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:265
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:167
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:63
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: calculation Directory Reference

  • crc
  • calculation
calculation Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: tmr1 Directory Reference

  • debug
  • tmr1
tmr1 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: oc_high Directory Reference

  • tmr
  • oc_high
oc_high Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • only_receive_mode_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • exint_trigger_partitioned
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • middlewares
  • usbd_drivers
  • inc
inc Directory Reference

Files

file | usb_std.h [code]
usb standard header file
file | usbd_core.h [code]
usb device core header file
file | usbd_int.h [code]
file | usbd_sdr.h [code]
usb standard request header file


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • vcp_loopback
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_high
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_input_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: voltage_monitoring Directory Reference

  • adc
  • voltage_monitoring
voltage_monitoring Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • debug
  • tmr1
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/debug/tmr1/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • flash
  • operate_spim
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/flash/operate_spim/src/main.c [code]
main program
file | operate_spim.c [code]
operate spim program


AT32F413 Firmwary Library: pwm_output_tmr3 Directory Reference

  • tmr
  • pwm_output_tmr3
pwm_output_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • sdio
  • sdio_fatfs
  • inc
inc Directory Reference

Files

file | sdio_fatfs/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | ffconf.h [code]


AT32F413 Firmwary Library: inc Directory Reference

  • bpr
  • tamper
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • communication_poll
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • rtc
  • calendar
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/rtc/calendar/src/main.c [code]
main program
file | rtc.c [code]
this file provides template for calendar api.


AT32F413 Firmwary Library: bpr_data Directory Reference

  • bpr
  • bpr_data
bpr_data Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • power_voltage_monitor
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • exint
  • exint_software_trigger
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/exint/exint_software_trigger/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_output_tmr10
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • power_voltage_monitor
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • printer
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/printer/src/main.c [code]
main program


AT32F413 Firmwary Library: bpr Directory Reference

  • bpr
bpr Directory Reference

Directories

directory | bpr_data
directory | tamper


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • sleep_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • flash
  • flash_write_read
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/flash/flash_write_read/src/flash.c [code]
flash program
file | project/at_start_f413/examples/flash/flash_write_read/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: power_voltage_monitor Directory Reference

  • pwc
  • power_voltage_monitor
power_voltage_monitor Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_toggle_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: calibration Directory Reference

  • acc
  • calibration
calibration Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • libraries
  • drivers
  • inc
inc Directory Reference

Files

file | at32f413_acc.h [code]
at32f413 acc header file
file | at32f413_adc.h [code]
at32f413 adc header file
file | at32f413_bpr.h [code]
at32f413 bpr header file
file | at32f413_can.h [code]
at32f413 can header file
file | at32f413_crc.h [code]
at32f413 crc header file
file | at32f413_crm.h [code]
at32f413 crm header file
file | at32f413_debug.h [code]
at32f413 debug header file
file | at32f413_def.h [code]
at32f413 macros header file
file | at32f413_dma.h [code]
at32f413 dma header file
file | at32f413_exint.h [code]
at32f413 exint header file
file | at32f413_flash.h [code]
at32f413 flash header file
file | at32f413_gpio.h [code]
at32f413 gpio header file
file | at32f413_i2c.h [code]
at32f413 i2c header file
file | at32f413_misc.h [code]
at32f413 misc header file
file | at32f413_pwc.h [code]
at32f413 pwc header file
file | at32f413_rtc.h [code]
at32f413 rtc header file
file | at32f413_sdio.h [code]
at32f413 sdio header file
file | at32f413_spi.h [code]
at32f413 spi header file
file | at32f413_tmr.h [code]
at32f413 tmr header file
file | at32f413_usart.h [code]
at32f413 usart header file
file | at32f413_usb.h [code]
at32f413 usb header file
file | at32f413_wdt.h [code]
at32f413 wdt header file
file | at32f413_wwdt.h [code]
at32f413 wwdt header file


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • i2s
  • halfduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_high
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_high/src/main.c [code]
main program


AT32F413 Firmwary Library: pwm_input_dma Directory Reference

  • tmr
  • pwm_input_dma
pwm_input_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: utilities Directory Reference

  • utilities
utilities Directory Reference

Directories

directory | at32f413_freertos_demo
directory | at32f413_gen_random_number_demo
directory | at32f413_slib_demo
directory | at32f413_usart_iap_demo
directory | at32f413_usb_iap_demo


AT32F413 Firmwary Library: crc Directory Reference

  • crc
crc Directory Reference

Directories

directory calculation


AT32F413 Firmwary Library: i2s Directory Reference

  • i2s
i2s Directory Reference

Directories

directory | halfduplex_dma
directory | halfduplex_interrupt
directory | spii2s_switch_halfduplex_polling


AT32F413 Firmwary Library: usbd_drivers Directory Reference

  • middlewares
  • usbd_drivers
usbd_drivers Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: usbd_class Directory Reference

  • middlewares
  • usbd_class
usbd_class Directory Reference

Directories

directory | audio
directory | audio_hid
directory | cdc
directory | composite_cdc_keyboard
directory | composite_cdc_msc
directory | custom_hid
directory | hid_iap
directory | keyboard
directory | mouse
directory | msc
directory | printer


AT32F413 Firmwary Library: spi Directory Reference

  • spi
spi Directory Reference

Directories

directory | crc_transfer_polling
directory | fullduplex_polling
directory | halfduplex_interrupt
directory | halfduplex_transceiver_switch
directory | only_receive_mode_polling
directory | use_jtagpin_hardwarecs_dma
directory | w25q_flash


AT32F413 Firmwary Library: i2c_application_library Directory Reference

  • middlewares
  • i2c_application_library
i2c_application_library Directory Reference

Files

file | i2c_application.c [code]
the driver library of the i2c peripheral
file | i2c_application.h [code]
i2c application libray header file


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
src Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c [code]
main interrupt service routines.
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c [code]
flash program
file | bootloader/src/iap.c [code]
iap program
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c [code]
main program
file | bootloader/src/tmr.c [code]
tmr program
file | bootloader/src/usart.c [code]
usart program


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • crc_transfer_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • 7_pwm_output
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/7_pwm_output/src/main.c [code]
main program


AT32F413 Firmwary Library: flash Directory Reference

  • flash
flash Directory Reference

Directories

directory | fap_enable
directory | flash_write_read
directory | operate_spim
directory | run_in_spim


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • receiver_mute
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • acc
  • calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/acc/calibration/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: sd_mmc_card Directory Reference

  • sdio
  • sd_mmc_card
sd_mmc_card Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • templates
  • src
src Directory Reference

Files

file | project/at_start_f413/templates/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/templates/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/templates/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • combine_mode_ordinary_simult
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • tmr2_32bit
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • bit_band
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/cortex_m4/bit_band/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • rtc
  • lick_calibration
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/rtc/lick_calibration/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • gpio
  • io_toggle
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: current_vref_value_check Directory Reference

  • adc
  • current_vref_value_check
current_vref_value_check Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: pwc Directory Reference

  • pwc
pwc Directory Reference

Directories

directory | deepsleep_rtc
directory | power_voltage_monitor
directory | sleep_tmr2
directory | sleep_usart1
directory | standby_rtc
directory | standby_wakeup_pin


AT32F413 Firmwary Library: timer_base Directory Reference

  • tmr
  • timer_base
timer_base Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: vcp_loopback Directory Reference

  • usb_device
  • vcp_loopback
vcp_loopback Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: led_toggle Directory Reference

  • gpio
  • led_toggle
led_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • 7_pwm_output
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: wdt_standby Directory Reference

  • wdt
  • wdt_standby
wdt_standby Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: combine_mode_ordinary_simult Directory Reference

  • adc
  • combine_mode_ordinary_simult
combine_mode_ordinary_simult Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_low
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • voltage_monitoring
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/voltage_monitoring/src/main.c [code]
main program


AT32F413 Firmwary Library: cmsis Directory Reference

  • libraries
  • cmsis
cmsis Directory Reference

Directories

directory cm4


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: 7_pwm_output Directory Reference

  • tmr
  • 7_pwm_output
7_pwm_output Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • synchronous
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • sleep_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_toggle_tmr9
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c [code]
main program


AT32F413 Firmwary Library: wdt_reset Directory Reference

  • wdt
  • wdt_reset
wdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • hang_mode
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/hang_mode/src/main.c [code]
main program


AT32F413 Firmwary Library: printer Directory Reference

  • middlewares
  • usbd_class
  • printer
printer Directory Reference

Files

file | printer_class.c [code]
usb printer class type
file | printer_class.h [code]
usb printer class file
file | printer_desc.c [code]
usb printer device descriptor
file | printer_desc.h [code]
usb printer descriptor header file


AT32F413 Firmwary Library: crm Directory Reference

  • crm
crm Directory Reference

Directories

directory | clock_failure_detection
directory | sysclk_switch


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • transfer_by_dma_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
src Directory Reference

Files

file | project_l0/src/arm_fir_data.c [code]
file | arm_fir_init_f32.c [code]
file | utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c [code]
main interrupt service routines.
file | fir_coefficient.c [code]
file | fir_filter.c [code]
file | utilities/at32f413_slib_demo/project_l0/src/main.c [code]
main program
file | project_l0/src/math_helper.c [code]


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
src Directory Reference

Files

file | project_l1/src/arm_fir_data.c [code]
file | utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c [code]
main interrupt service routines.
file | utilities/at32f413_slib_demo/project_l1/src/main.c [code]
main program
file | project_l1/src/math_helper.c [code]


AT32F413 Firmwary Library: src Directory Reference

  • bpr
  • tamper
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/bpr/tamper/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • only_receive_mode_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • smartcard
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | smartcard_config.h [code]
header file of clock program


AT32F413 Firmwary Library: io_toggle Directory Reference

  • gpio
  • io_toggle
io_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
inc Directory Reference

Files

file | utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | random.h [code]
at32f413 random header file


AT32F413 Firmwary Library: calendar Directory Reference

  • rtc
  • calendar
calendar Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: pwm_input Directory Reference

  • tmr
  • pwm_input
pwm_input Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • dma
  • flash_to_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: exint Directory Reference

  • exint
exint Directory Reference

Directories

directory | exint_config
directory | exint_software_trigger


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • external_clock
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/external_clock/src/main.c [code]
main program


AT32F413 Firmwary Library: usart Directory Reference

  • usart
usart Directory Reference

Directories

directory | half_duplex
directory | hw_flow_control
directory | idle_detection
directory | interrupt
directory | irda
directory | polling
directory | printf
directory | receiver_mute
directory | rs485
directory | smartcard
directory | synchronous
directory | transfer_by_dma_interrupt
directory | transfer_by_dma_polling


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • standby_rtc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/standby_rtc/src/main.c [code]
main program


AT32F413 Firmwary Library: main_page Directory Reference

  • main_page
main_page Directory Reference

Files

file main_page.h [code]


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • wwdt
  • wwdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: run_in_spim Directory Reference

  • flash
  • run_in_spim
run_in_spim Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: pwm_output_tmr10 Directory Reference

  • tmr
  • pwm_output_tmr10
pwm_output_tmr10 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: communication_mode Directory Reference

  • can
  • communication_mode
communication_mode Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • mouse
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/mouse/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • dma
  • data_to_gpio_flexible
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: printf Directory Reference

  • usart
  • printf
printf Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • flash
  • operate_spim
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | operate_spim.h [code]
operate_spim header file


AT32F413 Firmwary Library: synchronous Directory Reference

  • usart
  • synchronous
synchronous Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: composite_cdc_msc Directory Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
composite_cdc_msc Directory Reference

Files

file | cdc_msc_class.c [code]
usb cdc class type
file | cdc_msc_class.h [code]
usb cdc class file
file | cdc_msc_desc.c [code]
usb cdc device descriptor
file | cdc_msc_desc.h [code]
usb cdc descriptor header file
file | composite_cdc_msc/msc_bot_scsi.c [code]
usb mass storage bulk-only transport and scsi command


AT32F413 Firmwary Library: src Directory Reference

  • wdt
  • wdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/wdt/wdt_reset/src/main.c [code]
main program


AT32F413 Firmwary Library: systick_interrupt Directory Reference

  • cortex_m4
  • systick_interrupt
systick_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • virtual_msc_iap
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c [code]
main interrupt service routines.
file | flash_fat16.c [code]
fat16 file system
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c [code]
main program
file | virtual_msc_iap/src/msc_diskio.c [code]
usb mass storage disk function


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/dma/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • can
  • communication_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • crm
  • sysclk_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: use_jtagpin_hardwarecs_dma Directory Reference

  • spi
  • use_jtagpin_hardwarecs_dma
use_jtagpin_hardwarecs_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: composite_vcp_msc Directory Reference

  • usb_device
  • composite_vcp_msc
composite_vcp_msc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • eeprom
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: tmr Directory Reference

  • tmr
tmr Directory Reference

Directories

directory | 6_steps
directory | 7_pwm_output
directory | cascade_synchro
directory | complementary_signals
directory | dma
directory | dma_burst
directory | encoder_tmr2
directory | external_clock
directory | hall_xor_tmr2
directory | hang_mode
directory | input_capture
directory | oc_high
directory | oc_low
directory | oc_toggle_tmr3
directory | oc_toggle_tmr9
directory | one_cycle
directory | parallel_synchro
directory | pwm_input
directory | pwm_input_dma
directory | pwm_output_simulate
directory | pwm_output_tmr10
directory | pwm_output_tmr3
directory | timer_base
directory | tmr1_synchro
directory | tmr2_32bit


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_toggle_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • gpio
  • led_toggle
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • transfer_by_dma_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led3_toggle/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: oc_toggle_tmr9 Directory Reference

  • tmr
  • oc_toggle_tmr9
oc_toggle_tmr9 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: sdio_fatfs Directory Reference

  • sdio
  • sdio_fatfs
sdio_fatfs Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led3_toggle/src/iap.c [code]
iap program
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c [code]
main program
file | app_led3_toggle/src/tmr.c [code]
tmr program
file | app_led3_toggle/src/usart.c [code]
usart program


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • composite_vcp_msc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | composite_vcp_msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • acc
  • calibration
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/acc/calibration/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/acc/calibration/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • can
  • filter
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/can/filter/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/can/filter/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/can/filter/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • flash
  • run_in_spim
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/flash/run_in_spim/src/main.c [code]
main program
file | run_in_spim.c [code]
run in spim program


AT32F413 Firmwary Library: inc Directory Reference

  • crm
  • clock_failure_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: complementary_signals Directory Reference

  • tmr
  • complementary_signals
complementary_signals Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
inc Directory Reference

Files

file | utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project_l0/inc/fir_filter.h [code]
file | project_l0/inc/math_helper.h [code]


AT32F413 Firmwary Library: at32f413_usb_iap_demo Directory Reference

  • utilities
  • at32f413_usb_iap_demo
at32f413_usb_iap_demo Directory Reference

Directories

directory source_code


AT32F413 Firmwary Library: swjtag_remap Directory Reference

  • gpio
  • swjtag_remap
swjtag_remap Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: oc_toggle_tmr3 Directory Reference

  • tmr
  • oc_toggle_tmr3
oc_toggle_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: hang_mode Directory Reference

  • tmr
  • hang_mode
hang_mode Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • flash
  • fap_enable
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/flash/fap_enable/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • msc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: cmsis_dsp Directory Reference

  • cortex_m4
  • cmsis_dsp
cmsis_dsp Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • communication_int
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/communication_int/src/main.c [code]
main program


AT32F413 Firmwary Library: receiver_mute Directory Reference

  • usart
  • receiver_mute
receiver_mute Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • fullduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • systick_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • virtual_comport
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: AT32F413_Firmware_Library_V2.1.0 Directory Reference

AT32F413_Firmware_Library_V2.1.0 Directory Reference

Directories

directory | libraries
directory | main_page
directory | middlewares
directory | project
directory | utilities


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led3_toggle/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • encoder_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: communication_dma Directory Reference

  • i2c
  • communication_dma
communication_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • printf
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/printf/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/printf/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/printf/src/main.c [code]
main program


AT32F413 Firmwary Library: w25q_flash Directory Reference

  • spi
  • w25q_flash
w25q_flash Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • irda
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/irda/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/irda/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/irda/src/main.c [code]
main program


AT32F413 Firmwary Library: halfduplex_transceiver_switch Directory Reference

  • spi
  • halfduplex_transceiver_switch
halfduplex_transceiver_switch Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • sdio
  • sdio_fatfs
  • src
src Directory Reference

Files

file | sdio_fatfs/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c [code]
main interrupt service routines.
file | diskio.c [code]
file | project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c [code]
main program


AT32F413 Firmwary Library: communication_int Directory Reference

  • i2c
  • communication_int
communication_int Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: middlewares Directory Reference

  • middlewares
middlewares Directory Reference

Directories

directory | i2c_application_library
directory | usbd_class
directory | usbd_drivers


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • current_vref_value_check
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/current_vref_value_check/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_output_simulate
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_freertos_demo
  • src
src Directory Reference

Files

file | utilities/at32f413_freertos_demo/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_freertos_demo/src/at32f413_int.c [code]
main interrupt service routines.
file | include_port.c [code]
include_port program
file | utilities/at32f413_freertos_demo/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led4_toggle/src/iap.c [code]
iap program
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c [code]
main program
file | app_led4_toggle/src/tmr.c [code]
tmr program
file | app_led4_toggle/src/usart.c [code]
usart program


AT32F413 Firmwary Library: virtual_msc_iap Directory Reference

  • usb_device
  • virtual_msc_iap
virtual_msc_iap Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: crc_transfer_polling Directory Reference

  • spi
  • crc_transfer_polling
crc_transfer_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • internal_temperature_sensor
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c [code]
main program


AT32F413 Firmwary Library: audio Directory Reference

  • usb_device
  • audio
audio Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • crm
  • sysclk_switch
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/crm/sysclk_switch/src/main.c [code]
main program


AT32F413 Firmwary Library: drivers Directory Reference

  • libraries
  • drivers
drivers Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: clock_failure_detection Directory Reference

  • crm
  • clock_failure_detection
clock_failure_detection Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: fpu Directory Reference

  • cortex_m4
  • fpu
fpu Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • hw_flow_control
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/hw_flow_control/src/main.c [code]
main program


AT32F413 Firmwary Library: internal_temperature_sensor Directory Reference

  • adc
  • internal_temperature_sensor
internal_temperature_sensor Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • cascade_synchro
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/cascade_synchro/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • hall_xor_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c [code]
main program


AT32F413 Firmwary Library: irda Directory Reference

  • usart
  • irda
irda Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • gpio
  • led_toggle
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/gpio/led_toggle/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • exint
  • exint_config
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_input
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_input/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • keyboard
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/keyboard/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • wdt
  • wdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • composite_audio_hid
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c [code]
main interrupt service routines.
file | composite_audio_hid/src/audio_codec.c [code]
audio codec function
file | project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • vcp_loopback
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • dma
  • data_to_gpio_flexible
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c [code]
main program


AT32F413 Firmwary Library: composite_vcp_keyboard Directory Reference

  • usb_device
  • composite_vcp_keyboard
composite_vcp_keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: smartcard Directory Reference

  • usart
  • smartcard
smartcard Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • parallel_synchro
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/parallel_synchro/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • templates
  • inc
inc Directory Reference

Files

file | project/at_start_f413/templates/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/templates/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/templates/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • communication_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h [code]
flash header file
file | bootloader/inc/iap.h [code]
iap header file
file | bootloader/inc/tmr.h [code]
tmr header file
file | bootloader/inc/usart.h [code]
usart header file


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_toggle_tmr9
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • deepsleep_rtc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c [code]
main program


AT32F413 Firmwary Library: msc Directory Reference

  • middlewares
  • usbd_class
  • msc
msc Directory Reference

Files

file | msc/msc_bot_scsi.c [code]
usb mass storage bulk-only transport and scsi command
file | msc_bot_scsi.h [code]
usb mass storage bulk-only transport and scsi command header file
file | msc_class.c [code]
usb msc class type
file | msc_class.h [code]
usb msc class file
file | msc_desc.c [code]
usb msc device descriptor
file | msc_desc.h [code]
usb msc descriptor header file


AT32F413 Firmwary Library: hall_xor_tmr2 Directory Reference

  • tmr
  • hall_xor_tmr2
hall_xor_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • audio
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | audio/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • standby_rtc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: exint_trigger_partitioned Directory Reference

  • adc
  • exint_trigger_partitioned
exint_trigger_partitioned Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: encoder_tmr2 Directory Reference

  • tmr
  • encoder_tmr2
encoder_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: fullduplex_polling Directory Reference

  • spi
  • fullduplex_polling
fullduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: transfer_by_dma_interrupt Directory Reference

  • usart
  • transfer_by_dma_interrupt
transfer_by_dma_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: keyboard Directory Reference

  • middlewares
  • usbd_class
  • keyboard
keyboard Directory Reference

Files

file | keyboard_class.c [code]
usb hid keyboard class type
file | keyboard_class.h [code]
usb hid keyboard header file
file | keyboard_desc.c [code]
usb hid keyboard device descriptor
file | keyboard_desc.h [code]
usb keyboard descriptor header file


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • 6_steps
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: audio_hid Directory Reference

  • middlewares
  • usbd_class
  • audio_hid
audio_hid Directory Reference

Files

file | audio_hid/audio_conf.h [code]
usb audio config
file | audio_hid_class.c [code]
file | audio_hid_class.h [code]
file | audio_hid_desc.c [code]
file | audio_hid_desc.h [code]


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led4_toggle/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c [code]
main program


AT32F413 Firmwary Library: halfduplex_interrupt Directory Reference

  • i2s
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • dma
  • flash_to_sram
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/dma/flash_to_sram/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • hang_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • w25q_flash
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/w25q_flash/src/main.c [code]
main program
file | spi_flash.c [code]
spi_flash source code


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_input_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: lick_calibration Directory Reference

  • rtc
  • lick_calibration
lick_calibration Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • virtual_comport
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/virtual_comport/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • internal_temperature_sensor
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • hall_xor_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: cm4 Directory Reference

  • libraries
  • cmsis
  • cm4
cm4 Directory Reference

Directories

directory device_support


AT32F413 Firmwary Library: sysclk_switch Directory Reference

  • crm
  • sysclk_switch
sysclk_switch Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • rs485
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: data_to_gpio_flexible Directory Reference

  • dma
  • data_to_gpio_flexible
data_to_gpio_flexible Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • composite_vcp_msc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c [code]
main program
file | composite_vcp_msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F413 Firmwary Library: src Directory Reference

  • bpr
  • bpr_data
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/bpr/bpr_data/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | bootloader/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • audio
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c [code]
main interrupt service routines.
file | audio/src/audio_codec.c [code]
audio codec function
file | project/at_start_f413/examples/usb_device/audio/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • cmsis_dsp
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • wdt
  • wdt_standby
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: rs485 Directory Reference

  • usart
  • rs485
rs485 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • transfer_by_dma_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: hw_flow_control Directory Reference

  • usart
  • hw_flow_control
hw_flow_control Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • i2s
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: halfduplex_dma Directory Reference

  • i2s
  • halfduplex_dma
halfduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: transfer_by_dma_polling Directory Reference

  • usart
  • transfer_by_dma_polling
transfer_by_dma_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • libraries
  • drivers
  • src
src Directory Reference

Files

file | at32f413_acc.c [code]
contains all the functions for the acc firmware library
file | at32f413_adc.c [code]
contains all the functions for the adc firmware library
file | at32f413_bpr.c [code]
contains all the functions for the bpr firmware library
file | at32f413_can.c [code]
contains all the functions for the can firmware library
file | at32f413_crc.c [code]
contains all the functions for the crc firmware library
file | at32f413_crm.c [code]
contains all the functions for the crm firmware library
file | at32f413_debug.c [code]
contains all the functions for the debug firmware library
file | at32f413_dma.c [code]
contains all the functions for the dma firmware library
file | at32f413_exint.c [code]
contains all the functions for the exint firmware library
file | at32f413_flash.c [code]
contains all the functions for the flash firmware library
file | at32f413_gpio.c [code]
contains all the functions for the gpio firmware library
file | at32f413_i2c.c [code]
contains all the functions for the i2c firmware library
file | at32f413_misc.c [code]
contains all the functions for the misc firmware library
file | at32f413_pwc.c [code]
contains all the functions for the pwc firmware library
file | at32f413_rtc.c [code]
contains all the functions for the rtc firmware library
file | at32f413_sdio.c [code]
contains all the functions for the sdio firmware library
file | at32f413_spi.c [code]
contains all the functions for the spi firmware library
file | at32f413_tmr.c [code]
contains all the functions for the tmr firmware library
file | at32f413_usart.c [code]
contains all the functions for the usart firmware library
file | at32f413_usb.c [code]
contains the functions for the usb firmware library
file | at32f413_wdt.c [code]
contains all the functions for the wdt firmware library
file | at32f413_wwdt.c [code]
contains all the functions for the wwdt firmware library


AT32F413 Firmwary Library: custom_hid Directory Reference

  • usb_device
  • custom_hid
custom_hid Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • crc_transfer_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: app_led3_toggle Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
app_led3_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led4_toggle/inc/iap.h [code]
iap header file
file | app_led4_toggle/inc/tmr.h [code]
tmr header file
file | app_led4_toggle/inc/usart.h [code]
usart header file


AT32F413 Firmwary Library: app_led4_toggle Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
app_led4_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: software_trigger_repeat Directory Reference

  • adc
  • software_trigger_repeat
software_trigger_repeat Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: adc Directory Reference

  • adc
adc Directory Reference

Directories

directory | combine_mode_ordinary_simult
directory | current_vref_value_check
directory | exint_trigger_partitioned
directory | internal_temperature_sensor
directory | repeat_conversion_loop_transfer
directory | software_trigger_repeat
directory | tmr_trigger_automatic_preempted
directory | voltage_monitoring


AT32F413 Firmwary Library: usb_device Directory Reference

  • usb_device
usb_device Directory Reference

Directories

directory | audio
directory | composite_audio_hid
directory | composite_vcp_keyboard
directory | composite_vcp_msc
directory | custom_hid
directory | keyboard
directory | mouse
directory | msc
directory | printer
directory | vcp_loopback
directory | virtual_comport
directory | virtual_msc_iap


AT32F413 Firmwary Library: repeat_conversion_loop_transfer Directory Reference

  • adc
  • repeat_conversion_loop_transfer
repeat_conversion_loop_transfer Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • sleep_usart1
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • bpr
  • bpr_data
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: operate_spim Directory Reference

  • flash
  • operate_spim
operate_spim Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • sram
  • extend_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • fullduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/fullduplex_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • dma_burst
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • idle_detection
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/idle_detection/src/main.c [code]
main program


AT32F413 Firmwary Library: at_start_f413 Directory Reference

at_start_f413 Directory Reference

Directories

directory | examples
directory | templates


AT32F413 Firmwary Library: external_clock Directory Reference

  • tmr
  • external_clock
external_clock Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • crc
  • calculation
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • half_duplex
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/half_duplex/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/polling/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • encoder_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • rs485
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/rs485/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/rs485/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • standby_wakeup_pin
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c [code]
main program


AT32F413 Firmwary Library: rtc Directory Reference

  • rtc
rtc Directory Reference

Directories

directory | calendar
directory | lick_calibration


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • custom_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • halfduplex_transceiver_switch
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c [code]
main program


AT32F413 Firmwary Library: communication_poll Directory Reference

  • i2c
  • communication_poll
communication_poll Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • complementary_signals
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
inc Directory Reference

Files

file | utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project_l1/inc/fir_filter.h [code]
file | project_l1/inc/math_helper.h [code]


AT32F413 Firmwary Library: fap_enable Directory Reference

  • flash
  • fap_enable
fap_enable Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: standby_wakeup_pin Directory Reference

  • pwc
  • standby_wakeup_pin
standby_wakeup_pin Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: dma Directory Reference

  • dma
dma Directory Reference

Directories

directory | data_to_gpio_flexible
directory | flash_to_sram


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • w25q_flash
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | spi_flash.h [code]
header file of spi_flash


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • mouse
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_output_tmr10
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • half_duplex
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • i2s
  • halfduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: composite_audio_hid Directory Reference

  • usb_device
  • composite_audio_hid
composite_audio_hid Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: msc Directory Reference

  • usb_device
  • msc
msc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: one_cycle Directory Reference

  • tmr
  • one_cycle
one_cycle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: spii2s_switch_halfduplex_polling Directory Reference

  • i2s
  • spii2s_switch_halfduplex_polling
spii2s_switch_halfduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: hid_iap Directory Reference

  • middlewares
  • usbd_class
  • hid_iap
hid_iap Directory Reference

Files

file | hid_iap_class.c [code]
usb hid iap class type
file | hid_iap_class.h [code]
usb hid iap header file
file | hid_iap_desc.c [code]
usb hid device descriptor
file | hid_iap_desc.h [code]
usb hid descriptor header file


AT32F413 Firmwary Library: sleep_tmr2 Directory Reference

  • pwc
  • sleep_tmr2
sleep_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: sleep_usart1 Directory Reference

  • pwc
  • sleep_usart1
sleep_usart1 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • wwdt
  • wwdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • bit_band
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • can
  • filter
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/can/filter/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/can/filter/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/can/filter/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: virtual_comport Directory Reference

  • usb_device
  • virtual_comport
virtual_comport Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • gpio
  • io_toggle
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/gpio/io_toggle/src/main.c [code]
main program


AT32F413 Firmwary Library: project Directory Reference

  • project
project Directory Reference

Directories

directory | at32f413_board
directory | at_start_f413


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • repeat_conversion_loop_transfer
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c [code]
main program


AT32F413 Firmwary Library: wwdt Directory Reference

  • wwdt
wwdt Directory Reference

Directories

directory wwdt_reset


AT32F413 Firmwary Library: at32f413_slib_demo Directory Reference

  • utilities
  • at32f413_slib_demo
at32f413_slib_demo Directory Reference

Directories

directory | project_l0
directory | project_l1


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • software_trigger_repeat
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • idle_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • input_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: examples Directory Reference

examples Directory Reference

Directories

directory | acc
directory | adc
directory | bpr
directory | can
directory | cortex_m4
directory | crc
directory | crm
directory | debug
directory | dma
directory | exint
directory | flash
directory | gpio
directory | i2c
directory | i2s
directory | pwc
directory | rtc
directory | sdio
directory | spi
directory | sram
directory | tmr
directory | usart
directory | usb_device
directory | wdt
directory | wwdt


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • printer
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • voltage_monitoring
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: oc_low Directory Reference

  • tmr
  • oc_low
oc_low Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: libraries Directory Reference

  • libraries
libraries Directory Reference

Directories

directory | cmsis
directory | drivers


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • timer_base
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: dma_burst Directory Reference

  • tmr
  • dma_burst
dma_burst Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: parallel_synchro Directory Reference

  • tmr
  • parallel_synchro
parallel_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • flash
  • run_in_spim
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | run_in_spim.h [code]
run_in_spim header file


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_output_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: at32f413_freertos_demo Directory Reference

  • utilities
  • at32f413_freertos_demo
at32f413_freertos_demo Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: standby_rtc Directory Reference

  • pwc
  • standby_rtc
standby_rtc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • tmr1_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: templates Directory Reference

  • templates
templates Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • sdio
  • sd_mmc_card
  • inc
inc Directory Reference

Files

file | sd_mmc_card/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: tmr_trigger_automatic_preempted Directory Reference

  • adc
  • tmr_trigger_automatic_preempted
tmr_trigger_automatic_preempted Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • current_vref_value_check
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • exint
  • exint_config
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/exint/exint_config/src/main.c [code]
main program


AT32F413 Firmwary Library: i2c Directory Reference

  • i2c
i2c Directory Reference

Directories

directory | communication_dma
directory | communication_int
directory | communication_poll
directory | eeprom


AT32F413 Firmwary Library: 6_steps Directory Reference

  • tmr
  • 6_steps
6_steps Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
src Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c [code]
main interrupt service routines.
file | bootloader/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • sleep_usart1
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/sleep_usart1/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • exint_trigger_partitioned
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: debug Directory Reference

  • debug
debug Directory Reference

Directories

directory tmr1


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_freertos_demo
  • inc
inc Directory Reference

Files

file | utilities/at32f413_freertos_demo/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_freertos_demo/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_freertos_demo/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | FreeRTOSConfig.h [code]


AT32F413 Firmwary Library: src Directory Reference

  • wdt
  • wdt_standby
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/wdt/wdt_standby/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • eeprom
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/eeprom/src/main.c [code]
main program


AT32F413 Firmwary Library: exint_config Directory Reference

  • exint
  • exint_config
exint_config Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: mouse Directory Reference

  • middlewares
  • usbd_class
  • mouse
mouse Directory Reference

Files

file | mouse_class.c [code]
usb hid mouse class type
file | mouse_class.h [code]
usb hid mouse header file
file | mouse_desc.c [code]
usb hid mouse device descriptor
file | mouse_desc.h [code]
usb mouse descriptor header file


AT32F413 Firmwary Library: deepsleep_rtc Directory Reference

  • pwc
  • deepsleep_rtc
deepsleep_rtc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • systick_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: project_l1 Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
project_l1 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led4_toggle/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_output_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • one_cycle
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/one_cycle/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • flash
  • fap_enable
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/flash/fap_enable/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • rtc
  • calendar
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | rtc.h [code]
this file provides template for calendar api.


AT32F413 Firmwary Library: idle_detection Directory Reference

  • usart
  • idle_detection
idle_detection Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: acc Directory Reference

  • acc
acc Directory Reference

Directories

directory calibration


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • fpu
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c [code]
main interrupt service routines.
file | julia_fpu.c [code]
julia_fpu source file
file | project/at_start_f413/examples/cortex_m4/fpu/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • tmr1_synchro
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c [code]
main program


AT32F413 Firmwary Library: only_receive_mode_polling Directory Reference

  • spi
  • only_receive_mode_polling
only_receive_mode_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: gpio Directory Reference

  • gpio
gpio Directory Reference

Directories

directory | io_toggle
directory | led_toggle
directory | swjtag_remap


AT32F413 Firmwary Library: project_l0 Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
project_l0 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: polling Directory Reference

  • usart
  • polling
polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • cascade_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • dma_burst
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/dma_burst/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • can
  • loopback_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • crc
  • calculation
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/crc/calculation/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/crc/calculation/src/main.c [code]
main program


AT32F413 Firmwary Library: bit_band Directory Reference

  • cortex_m4
  • bit_band
bit_band Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: mouse Directory Reference

  • usb_device
  • mouse
mouse Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • virtual_msc_iap
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | flash_fat16.h [code]
fat16 file system header file
file | virtual_msc_iap/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: source_code Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
source_code Directory Reference

Directories

directory | app_led3_toggle
directory | app_led4_toggle
directory | bootloader


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • communication_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/communication_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • custom_hid
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/custom_hid/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • exint
  • exint_software_trigger
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_input
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: cdc Directory Reference

  • middlewares
  • usbd_class
  • cdc
cdc Directory Reference

Files

file | cdc_class.c [code]
usb cdc class type
file | cdc_class.h [code]
usb cdc class file
file | cdc_desc.c [code]
usb cdc device descriptor
file | cdc_desc.h [code]
usb cdc descriptor header file


AT32F413 Firmwary Library: inc Directory Reference

  • gpio
  • swjtag_remap
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: composite_cdc_keyboard Directory Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
composite_cdc_keyboard Directory Reference

Files

file | cdc_keyboard_class.c [code]
usb cdc and keyboard class type
file | cdc_keyboard_class.h [code]
usb cdc and keyboard class file
file | cdc_keyboard_desc.c [code]
usb cdc and keyboard device descriptor
file | cdc_keyboard_desc.h [code]
usb cdc and keyboard descriptor header file


AT32F413 Firmwary Library: cascade_synchro Directory Reference

  • tmr
  • cascade_synchro
cascade_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • complementary_signals
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/complementary_signals/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • repeat_conversion_loop_transfer
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • can
  • loopback_mode
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/can/loopback_mode/src/main.c [code]
main program


AT32F413 Firmwary Library: printer Directory Reference

  • usb_device
  • printer
printer Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: cortex_m4 Directory Reference

  • cortex_m4
cortex_m4 Directory Reference

Directories

directory | bit_band
directory | cmsis_dsp
directory | fpu
directory | systick_interrupt


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • composite_audio_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | composite_audio_hid/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • communication_poll
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/communication_poll/src/main.c [code]
main program


AT32F413 Firmwary Library: interrupt Directory Reference

  • usart
  • interrupt
interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • timer_base
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/timer_base/src/main.c [code]
main program


AT32F413 Firmwary Library: dma Directory Reference

  • tmr
  • dma
dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_low
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_low/src/main.c [code]
main program


AT32F413 Firmwary Library: app_led4_toggle Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
app_led4_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • input_capture
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/input_capture/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • deepsleep_rtc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • crm
  • clock_failure_detection
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/crm/clock_failure_detection/src/main.c [code]
main program


AT32F413 Firmwary Library: app_led3_toggle Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
app_led3_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • one_cycle
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • i2s
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: loopback_mode Directory Reference

  • can
  • loopback_mode
loopback_mode Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • composite_vcp_keyboard
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • communication_int
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
src Directory Reference

Files

file | utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_gen_random_number_demo/src/at32f413_int.c [code]
main interrupt service routines.
file | utilities/at32f413_gen_random_number_demo/src/main.c [code]
main program
file | random.c [code]
set of firmware functions to random function


AT32F413 Firmwary Library: src Directory Reference

  • can
  • communication_mode
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/can/communication_mode/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • receiver_mute
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/receiver_mute/src/main.c [code]
main program


AT32F413 Firmwary Library: pwm_output_simulate Directory Reference

  • tmr
  • pwm_output_simulate
pwm_output_simulate Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: exint_software_trigger Directory Reference

  • exint
  • exint_software_trigger
exint_software_trigger Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • parallel_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: input_capture Directory Reference

  • tmr
  • input_capture
input_capture Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: halfduplex_interrupt Directory Reference

  • spi
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: audio Directory Reference

  • middlewares
  • usbd_class
  • audio
audio Directory Reference

Files

file | audio_class.c [code]
usb audio class type
file | audio_class.h [code]
usb audio class file
file | audio/audio_conf.h [code]
usb audio config
file | audio_desc.c [code]
usb audio device descriptor
file | audio_desc.h [code]
usb audio descriptor header file


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • tmr2_32bit
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • fpu
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | julia_fpu.h [code]
julia_fpu header file


AT32F413 Firmwary Library: at32f413_usart_iap_demo Directory Reference

  • utilities
  • at32f413_usart_iap_demo
at32f413_usart_iap_demo Directory Reference

Directories

directory source_code


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • standby_wakeup_pin
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • smartcard
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/smartcard/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led3_toggle/inc/iap.h [code]
iap header file
file | app_led3_toggle/inc/tmr.h [code]
tmr header file
file | app_led3_toggle/inc/usart.h [code]
usart header file


AT32F413 Firmwary Library: src Directory Reference

  • gpio
  • swjtag_remap
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/gpio/swjtag_remap/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • software_trigger_repeat
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c [code]
main program


AT32F413 Firmwary Library: at32f413_board Directory Reference

  • at32f413_board
at32f413_board Directory Reference

Files

file | at32f413_board.c [code]
set of firmware functions to manage leds and push-button. initialize delay function.
file | at32f413_board.h [code]
header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • hw_flow_control
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_output_simulate
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • cmsis_dsp
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: bootloader Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
bootloader Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: wdt Directory Reference

  • wdt
wdt Directory Reference

Directories

directory | wdt_reset
directory | wdt_standby


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: half_duplex Directory Reference

  • usart
  • half_duplex
half_duplex Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: keyboard Directory Reference

  • usb_device
  • keyboard
keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: sram Directory Reference

  • sram
sram Directory Reference

Directories

directory extend_sram


AT32F413 Firmwary Library: inc Directory Reference

  • flash
  • flash_write_read
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/flash/flash_write_read/inc/flash.h [code]
flash header file


AT32F413 Firmwary Library: bootloader Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
bootloader Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: at32f413_gen_random_number_demo Directory Reference

  • utilities
  • at32f413_gen_random_number_demo
at32f413_gen_random_number_demo Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: tamper Directory Reference

  • bpr
  • tamper
tamper Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • sdio
  • sd_mmc_card
  • src
src Directory Reference

Files

file | sd_mmc_card/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c [code]
main program


AT32F413 Firmwary Library: can Directory Reference

  • can
can Directory Reference

Directories

directory | communication_mode
directory | filter
directory | loopback_mode


AT32F413 Firmwary Library: tmr2_32bit Directory Reference

  • tmr
  • tmr2_32bit
tmr2_32bit Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: eeprom Directory Reference

  • i2c
  • eeprom
eeprom Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • irda
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/irda/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: tmr1_synchro Directory Reference

  • tmr
  • tmr1_synchro
tmr1_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: flash_write_read Directory Reference

  • flash
  • flash_write_read
flash_write_read Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: extend_sram Directory Reference

  • sram
  • extend_sram
extend_sram Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • debug
  • tmr1
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • rtc
  • lick_calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: wwdt_reset Directory Reference

  • wwdt
  • wwdt_reset
wwdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • printf
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/printf/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • 6_steps
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/6_steps/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • msc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/msc/src/main.c [code]
main program
file | msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F413 Firmwary Library: sdio Directory Reference

  • sdio
sdio Directory Reference

Directories

directory | sd_mmc_card
directory | sdio_fatfs


AT32F413 Firmwary Library: flash_to_sram Directory Reference

  • dma
  • flash_to_sram
flash_to_sram Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: custom_hid Directory Reference

  • middlewares
  • usbd_class
  • custom_hid
custom_hid Directory Reference

Files

file | custom_hid_class.c [code]
usb custom hid class type
file | custom_hid_class.h [code]
usb custom hid header file
file | custom_hid_desc.c [code]
usb hid device descriptor
file | custom_hid_desc.h [code]
usb custom hid descriptor header file


AT32F413 Firmwary Library: src Directory Reference

  • sram
  • extend_sram
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/sram/extend_sram/src/main.c [code]
main program


AT32F413 Firmwary Library: filter Directory Reference

  • can
  • filter
filter Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • external_clock
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • middlewares
  • usbd_drivers
  • src
src Directory Reference

Files

file | usbd_core.c [code]
usb driver
file | usbd_int.c [code]
usb interrupt request
file | usbd_sdr.c [code]
usb standard device request


AT32F413 Firmwary Library: source_code Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
source_code Directory Reference

Directories

directory | app_led3_toggle
directory | app_led4_toggle
directory | bootloader


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • synchronous
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/synchronous/src/main.c [code]
main program


AT32F413 Firmwary Library: device_support Directory Reference

  • libraries
  • cmsis
  • cm4
  • device_support
device_support Directory Reference

Files

file | at32f413.h [code]
at32f413 header file
file | system_at32f413.c [code]
contains all the functions for cmsis cortex-m4 system source file
file | system_at32f413.h [code]
cmsis cortex-m4 system header file.


AT32F413 Firmwary Library: diskio.c Source File

  • sdio
  • sdio_fatfs
  • src
diskio.c
Go to the documentation of this file.
1/*-----------------------------------------------------------------------*/
2/* Low level disk I/O module SKELETON for FatFs (C)ChaN, 2019 */
3/*-----------------------------------------------------------------------*/
4/* If a working storage control module is available, it should be */
5/* attached to the FatFs via a glue function rather than modifying it. */
6/* This is an example of glue functions to attach various exsisting */
7/* storage control modules to the FatFs module with a defined API. */
8/*-----------------------------------------------------------------------*/
9
10
11#include "ff.h" /* Obtains integer types */
12#include "diskio.h" /* Declarations of disk functions */
13
14#include <string.h>
15#include "at32_sdio.h" /* Example: Header file of existing MMC/SDC contorl module */
16
17/* Definitions of physical drive number for each drive */
18#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
19#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
20#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
21
22 __align(4) uint8_t sdio_data_buffer[512]; /* buf for sd_read_disk/sd_write_disk function used. */
23
24 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt);
25 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt);
26
34 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt)
35{
36 sd_error_status_type sta = SD_OK;
37 long long lsector = sector;
38 uint8_t n;
39
40 /* data address is in block (512 byte) units. */
41 lsector <<= 9;
42
43 if((uint32_t)buf % 4 != 0)
44 {
45 for(n = 0; n < cnt; n++)
46 {
47 sta = sd_block_read(sdio_data_buffer, lsector + 512 * n, 512);
48 memcpy(buf, sdio_data_buffer, 512);
49 buf += 512;
50 }
51 }
52 else
53 {
54 if(cnt == 1)
55 {
56 sta = sd_block_read(buf, lsector, 512);
57 }
58 else
59 {
60 sta = sd_mult_blocks_read(buf, lsector, 512, cnt);
61 }
62 }
63
64 return sta;
65}
66
74 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
75{
76 sd_error_status_type sta = SD_OK;
77 uint8_t n;
78 long long lsector = sector;
79
80 /* data address is in block (512 byte) units. */
81 lsector <<= 9;
82
83 if((uint32_t)buf % 4 != 0)
84 {
85 for(n = 0; n < cnt; n++)
86 {
87 memcpy(sdio_data_buffer, buf, 512);
88 sta = sd_block_write(sdio_data_buffer, lsector + 512*n, 512);
89 buf += 512;
90 }
91 }
92 else
93 {
94 if(cnt == 1)
95 {
96 sta = sd_block_write(buf, lsector, 512);
97 }
98 else
99 {
100 sta = sd_mult_blocks_write(buf, lsector, 512, cnt);
101 }
102 }
103
104 return sta;
105}
106
107/*-----------------------------------------------------------------------*/
108/* Get Drive Status */
109/*-----------------------------------------------------------------------*/
110DSTATUS disk_status (
111 BYTE pdrv /* Physical drive nmuber to identify the drive */
112)
113{
114 DSTATUS stat;
115 int result;
116
117 switch (pdrv) {
118 case DEV_RAM :
119 result = 1;
120 stat = (DSTATUS)result;
121 return stat;
122
123 case DEV_MMC :
124 result = 0;
125 stat = (DSTATUS)result;
126 return stat;
127
128 case DEV_USB :
129 result = 1;
130 stat = (DSTATUS)result;
131 return stat;
132 }
133 return STA_NOINIT;
134}
135
136
137
138/*-----------------------------------------------------------------------*/
139/* Inidialize a Drive */
140/*-----------------------------------------------------------------------*/
141DSTATUS disk_initialize (
142 BYTE pdrv /* Physical drive nmuber to identify the drive */
143)
144{
145 DSTATUS stat;
146 int result;
147
148 switch (pdrv) {
149 case DEV_RAM :
150 result = 1;
151 stat = (DSTATUS)result;
152 return stat;
153
154 case DEV_MMC :
155 result = sd_init();
156 stat = (DSTATUS)result;
157 return stat;
158
159 case DEV_USB :
160 result = 1;
161 stat = (DSTATUS)result;
162 return stat;
163 }
164 return STA_NOINIT;
165}
166
167
168
169/*-----------------------------------------------------------------------*/
170/* Read Sector(s) */
171/*-----------------------------------------------------------------------*/
172DRESULT disk_read (
173 BYTE pdrv, /* Physical drive nmuber to identify the drive */
174 BYTE *buff, /* Data buffer to store read data */
175 LBA_t sector, /* Start sector in LBA */
176 UINT count /* Number of sectors to read */
177)
178{
179 DRESULT res;
180 int result;
181
182 switch (pdrv) {
183 case DEV_RAM :
184 result = 1;
185 res = (DRESULT)result;
186 return res;
187
188 case DEV_MMC :
189 result = sd_read_disk(buff, sector, count);
190 res = (DRESULT)result;
191 return res;
192
193 case DEV_USB :
194 result = 1;
195 res = (DRESULT)result;
196 return res;
197 }
198
199 return RES_PARERR;
200}
201
202
203
204/*-----------------------------------------------------------------------*/
205/* Write Sector(s) */
206/*-----------------------------------------------------------------------*/
207#if FF_FS_READONLY == 0
208
209DRESULT disk_write (
210 BYTE pdrv, /* Physical drive nmuber to identify the drive */
211 const BYTE *buff, /* Data to be written */
212 LBA_t sector, /* Start sector in LBA */
213 UINT count /* Number of sectors to write */
214)
215{
216 DRESULT res;
217 int result;
218
219 switch (pdrv) {
220 case DEV_RAM :
221 result = 1;
222 res = (DRESULT)result;
223 return res;
224
225 case DEV_MMC :
226 result = sd_write_disk(buff, sector, count);
227 res = (DRESULT)result;
228 return res;
229
230 case DEV_USB :
231 result = 1;
232 res = (DRESULT)result;
233 return res;
234 }
235
236 return RES_PARERR;
237}
238
239#endif
240
241
242/*-----------------------------------------------------------------------*/
243/* Miscellaneous Functions */
244/*-----------------------------------------------------------------------*/
245DRESULT disk_ioctl (
246 BYTE pdrv, /* Physical drive nmuber (0..) */
247 BYTE cmd, /* Control code */
248 void *buff /* Buffer to send/receive control data */
249)
250{
251 DRESULT res;
252 int result;
253
254 switch (pdrv) {
255 case DEV_RAM :
256 result = 1;
257 res = (DRESULT)result;
258 return res;
259
260 case DEV_MMC :
261 switch(cmd){
262 case CTRL_SYNC:
263 result = RES_OK;
264 break;
265 case GET_SECTOR_SIZE:
266 *(DWORD*)buff = 512;
267 result = RES_OK;
268 break;
269 case GET_SECTOR_COUNT:
270 *(DWORD*)buff = sd_card_info.card_capacity/512;
271 result = RES_OK;
272 break;
273 case GET_BLOCK_SIZE:
274 *(DWORD*)buff = sd_card_info.card_blk_size;
275 result = RES_OK;
276 break;
277 default:
278 result = RES_PARERR;
279 break;
280 }
281 res = (DRESULT)result;
282 return res;
283
284 case DEV_USB :
285 result = 1;
286 res = (DRESULT)result;
287 return res;
288 }
289
290 return RES_PARERR;
291}
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: diskio.c:172
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: diskio.c:141
__align
__align(4)
Definition: diskio.c:22
DEV_USB
#define DEV_USB
Definition: diskio.c:20
DEV_RAM
#define DEV_RAM
Definition: diskio.c:18
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: diskio.c:110
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: diskio.c:245
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: diskio.c:209
DEV_MMC
#define DEV_MMC
Definition: diskio.c:19
sd_write_disk
sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector
Definition: diskio.c:74
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:46
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1179
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1480
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1358
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:70
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1268
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:72
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:117
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:240


AT32F413 Firmwary Library: ffconf.h Source File

  • sdio
  • sdio_fatfs
  • inc
ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 1//0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 1//0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 3//1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 1//0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F413 Firmwary Library: fir_coefficient.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
fir_coefficient.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3 *
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8 * Title: arm_fir_example_f32.c
9 *
10 * Description: Example code demonstrating how an FIR filter can be used
11 * as a low pass filter.
12 *
13 * Target Processor: Cortex-M4/Cortex-M3
14 *
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42** Include Files
43** ------------------------------------------------------------------- */
44#include "at32f413.h"
45#include "arm_math.h"
46#include "fir_filter.h"
47/* ----------------------------------------------------------------------
48** Macro Defines
49** ------------------------------------------------------------------- */
50
51#define NUM_TAPS 29
52
53/* ----------------------------------------------------------------------
54** FIR Coefficients buffer generated using fir1() MATLAB function.
55** fir1(28, 6/24)
56** ------------------------------------------------------------------- */
57//#if defined ( __ICCARM__ )
58//const float32_t firCoeffs32[NUM_TAPS] @ 0x08002000 ={
59//#elif defined ( __CC_ARM )
60//const float32_t firCoeffs32[NUM_TAPS] __attribute__((at(0x08002000))) = {
61//#endif
62const float32_t firCoeffs32[NUM_TAPS] = {
63 -0.0018225230f, -0.0015879294f, +0.0000000000f, +0.0036977508f, +0.0080754303f, +0.0085302217f, -0.0000000000f, -0.0173976984f,
64 -0.0341458607f, -0.0333591565f, +0.0000000000f, +0.0676308395f, +0.1522061835f, +0.2229246956f, +0.2504960933f, +0.2229246956f,
65 +0.1522061835f, +0.0676308395f, +0.0000000000f, -0.0333591565f, -0.0341458607f, -0.0173976984f, -0.0000000000f, +0.0085302217f,
66 +0.0080754303f, +0.0036977508f, +0.0000000000f, -0.0015879294f, -0.0018225230f
67};
68
at32f413.h
at32f413 header file
firCoeffs32
const float32_t firCoeffs32[29]
Definition: fir_coefficient.c:62
NUM_TAPS
#define NUM_TAPS
Definition: fir_coefficient.c:51


AT32F413 Firmwary Library: fir_filter.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
fir_filter.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3 *
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8 * Title: arm_fir_example_f32.c
9 *
10 * Description: Example code demonstrating how an FIR filter can be used
11 * as a low pass filter.
12 *
13 * Target Processor: Cortex-M4/Cortex-M3
14 *
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42** Include Files
43** ------------------------------------------------------------------- */
44#include "at32f413.h"
45#include "arm_math.h"
46#include "fir_filter.h"
47
48extern const float32_t firCoeffs32[];
49
50/* ----------------------------------------------------------------------
51** Macro Defines
52** ------------------------------------------------------------------- */
53#define BLOCK_SIZE 32
54#define NUM_TAPS 29
55
56/* -------------------------------------------------------------------
57 * Declare State buffer of size (numTaps + blockSize - 1)
58 * ------------------------------------------------------------------- */
59
60
61//#if defined ( __ICCARM__ )
62//static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] @ 0x20017000 ;
63//#elif defined ( __CC_ARM )
64//static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] __attribute__((at(0x20017000)));
65//#endif
66static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] ;
67
68/* ----------------------------------------------------------------------
69** FIR Coefficients buffer generated using fir1() MATLAB function.
70** fir1(28, 6/24)
71** ------------------------------------------------------------------- */
72
73/* ----------------------------------------------------------------------
74 * FIR LPF Example
75 * ------------------------------------------------------------------- */
76void FIR_lowpass_filter(float32_t * pSrc, float32_t * pDst, uint32_t testlengthsamples)
77{
78 uint32_t i;
79 uint32_t blockSize = BLOCK_SIZE;
80 uint32_t numBlocks = testlengthsamples/BLOCK_SIZE;
81 arm_fir_instance_f32 S;
82
83
84 /* Call FIR init function to initialize the instance structure. */
85 arm_fir_init_f32(&S, NUM_TAPS, (float32_t *)&firCoeffs32[0], &firStateF32[0], blockSize);
86 /* ----------------------------------------------------------------------
87 ** Call the FIR process function for every blockSize samples
88 ** ------------------------------------------------------------------- */
89 for(i=0; i < numBlocks; i++)
90 {
91 arm_fir_f32(&S, pSrc + (i * blockSize), pDst + (i * blockSize), blockSize);
92 }
93
94}
at32f413.h
at32f413 header file
firCoeffs32
const float32_t firCoeffs32[]
Definition: fir_coefficient.c:62
firStateF32
static float32_t firStateF32[32+29 - 1]
Definition: fir_filter.c:66
NUM_TAPS
#define NUM_TAPS
Definition: fir_filter.c:54
BLOCK_SIZE
#define BLOCK_SIZE
Definition: fir_filter.c:53
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F413 Firmwary Library: flash_fat16.c Source File

  • usb_device
  • virtual_msc_iap
  • src
flash_fat16.c
Go to the documentation of this file.
1
24#include "flash_fat16.h"
25#include "usb_conf.h"
26
34#define FAT16_SECTOR_SIZE 62
35static uint8_t fat16_sector[FAT16_SECTOR_SIZE] =
36{
37 0xEB, /*0*/
38 0x3C, /*1*/
39 0x90, /*2*/
40 0x4D, /*3*/
41 0x53, /*4*/
42 0x44, /*5*/
43 0x4F, /*6*/
44 0x53, /*7*/
45 0x35, /*8*/
46 0x2E, /*9*/
47 0x30, /*10*/
48 0x00, /*11*/
49 0x08, /*12*/ //2K
50 0x04, /*13*/
51 0x06, /*14*/
52 0x00, /*15*/
53
54 0x02, /*16*/
55 0x00, /*17*/
56 0x02, /*18*/
57 0xFF, /*19*/
58 0x0F, /*20*/
59 0xF8, /*21*/
60 0x01, /*22*/
61 0x00, /*23*/
62 0x01, /*24*/
63 0x00, /*25*/
64 0x01, /*26*/
65 0x00, /*27*/
66 0x00, /*28*/
67 0x00, /*29*/
68 0x00, /*30*/
69 0x00, /*31*/
70
71 0x00, /*32*/
72 0x00, /*33*/
73 0x00, /*34*/
74 0x00, /*35*/
75 0x00, /*36*/
76 0x00, /*37*/
77 0x29, /*38*/
78 0x96, /*39*/
79 0x16, /*40*/
80 0x66, /*41*/
81 0xD3, /*42*/
82 0x20, /*43*/
83 0x20, /*44*/
84 0x20, /*45*/
85 0x20, /*46*/
86 0x20, /*47*/
87
88 0x20, /*48*/
89 0x20, /*49*/
90 0x20, /*50*/
91 0x20, /*51*/
92 0x20, /*52*/
93 0x20, /*53*/
94 0x46, /*54*/
95 0x41, /*55*/
96 0x54, /*56*/
97 0x31, /*57*/
98 0x36, /*58*/
99 0x20, /*59*/
100 0x20, /*60*/
101 0x20 /*61*/
102};
103
104
105
106const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]=
107{
108 0x20, /*11 - Archive Attribute set */
109 0x00, /*12 - Reserved */
110 0x4B, /*13 - Create Time Tenth */
111 0x9C, /*14 - Create Time */
112 0x42, /*15 - Create Time */
113 0x92, /*16 - Create Date */
114 0x38, /*17 - Create Date */
115 0x92, /*18 - Last Access Date */
116 0x38, /*19 - Last Access Date */
117 0x00, /*20 - Not used in FAT16 */
118 0x00, /*21 - Not used in FAT16 */
119 0x9D, /*22 - Write Time */
120 0x42, /*23 - Write Time */
121 0x92, /*24 - Write Date */
122 0x38, /*25 - Write Date */
123 0x00, /*26 - First Cluster (none, because file is empty) */
124 0x00, /*27 - First Cluster (none, because file is empty) */
125 0x00, /*28 - File Size */
126 0x00, /*29 - File Size */
127 0x00, /*30 - File Size */
128 0x00, /*31 - File Size */
129 'A','T','3','2',' ','I','A','P',' ',' ',' ', /*32-42 - Volume label */
130 0x08, /*43 - File attribute = Volume label */
131 0x00, /*44 - Reserved */
132 0x00, /*45 - Create Time Tenth */
133 0x00, /*46 - Create Time */
134 0x00, /*47 - Create Time */
135 0x00, /*48 - Create Date */
136 0x00, /*49 - Create Date */
137 0x00, /*50 - Last Access Date */
138 0x00, /*51 - Last Access Date */
139 0x00, /*52 - Not used in FAT16 */
140 0x00, /*53 - Not used in FAT16 */
141 0x9D, /*54 - Write Time */
142 0x42, /*55 - Write Time */
143 0x92, /*56 - Write Date */
144 0x38, /*57 - Write Date */
145};
146
147const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE] =
148{
149 0xF8,
150 0xFF,
151 0xFF,
152 0xFF
153};
154
155uint8_t fat16_file_name[FAT16_FILENAME_SIZE] =
156{
157 'R',
158 'e',
159 'a',
160 'd',
161 'y',
162 ' ',
163 ' ',
164 ' ',
165 'T',
166 'X',
167 'T'
168};
169
170 fat_dir_type g_file_attr;
171 flash_iap_type flash_iap;
172uint32_t file_write_nr = 0;
173uint8_t file_match = 0;
174
175uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
176uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
177uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len);
178uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len);
179uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len);
180uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len);
181uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len);
182uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len);
183void flash_fat16_clear_upgrade_flag(void);
184void flash_fat16_set_upgrade_flag(void);
185
193uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
194{
195 uint32_t i_index;
196 for(i_index = 0; i_index < len; i_index ++)
197 {
198 dst[i_index] = src[i_index];
199 }
200 return i_index;
201}
202
210uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
211{
212 uint32_t i_index;
213 for(i_index = 0; i_index < len; i_index ++)
214 {
215 dst[i_index] = (uint8_t)set;
216 }
217 return i_index;
218}
219
227uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
228{
229 uint32_t i_index;
230 for(i_index = 0; i_index < len; i_index ++)
231 {
232 if(dst[i_index] != src[i_index])
233 return 1;
234 }
235 return 0;
236}
237
243void flash_fat16_clear_upgrade_flag(void)
244{
245 flash_unlock();
246 flash_sector_erase(flash_iap.flash_app_addr - flash_iap.sector_size);
247 flash_lock();
248}
249
255void flash_fat16_set_upgrade_flag(void)
256{
257 flash_unlock();
258 flash_word_program(flash_iap.flash_app_addr - flash_iap.sector_size,
259 IAP_UPGRADE_COMPLETE_FLAG);
260 flash_lock();
261}
262
268uint8_t flash_fat16_get_upgrade_flag(void)
269{
270 uint32_t flag_address = flash_iap.flash_app_addr - flash_iap.sector_size;
271 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
272 {
273 return IAP_SUCCESS;
274 }
275 else
276 {
277 return IAP_FAILED;
278 }
279}
280
288uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
289{
290 uint32_t i_index = 0;
291 switch(fat_lbk)
292 {
293 case FLASH_FAT16_BOOT_SECTOR_ADDR:
294 i_index += fat16_memory_copy(data, fat16_sector, FAT16_SECTOR_SIZE);
295 i_index += 2;
296
297 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
298 data[510] = 0x55;
299 data[511] = 0xAA;
300
301 break;
302 case FLASH_FAT16_1_ADDR:
303 case FLASH_FAT16_2_ADDR:
304 i_index += fat16_memory_copy(data, fat16_table_sector0, FAT16_TABLE_SIZE);
305
306 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
307 break;
308 case FLASH_FAT16_ROOT_ADDR:
309 i_index += fat16_memory_copy(data, fat16_file_name, FAT16_FILENAME_SIZE);
310 i_index += fat16_memory_copy(data + i_index, fat16_root_dir_sector, FAT16_DIR_SIZE);
311
312 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
313 break;
314 default:
315 i_index = 0;
316 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
317 break;
318 }
319 return FAT16_BYTE_PER_SIZE;
320}
321
329uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
330{
331 switch(fat_lbk)
332 {
333 case FLASH_FAT16_BOOT_SECTOR_ADDR:
334 case FLASH_FAT16_1_ADDR:
335 case FLASH_FAT16_2_ADDR:
336 break;
337 case FLASH_FAT16_ROOT_ADDR:
338 flash_fat16_boot_dir_write(fat_lbk, data, len);
339 break;
340 default:
341 if(fat_lbk >= FLASH_FAT16_FILE_START_ADDR)
342 {
343 flash_fat16_sector_write(fat_lbk, data, len);
344 }
345 break;
346
347 }
348 return len;
349}
350
357uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
358{
359 uint8_t i_index = 0;
360 for(i_index = 0; i_index < len && i_index < 8; i_index ++)
361 {
362 fat16_file_name[i_index] = file_name[i_index];
363 }
364
365 for(; i_index < 8; i_index ++)
366 {
367 fat16_file_name[i_index] = ' ';
368 }
369 return i_index;
370}
371
379uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
380{
381 fat_dir_type *pdir = (fat_dir_type *)data;
382 uint32_t i_index = 2, loop_len = 0;
383
384 pdir ++;
385 pdir ++;
386 loop_len += 64;
387
388 while(i_index ++ < 512 && loop_len < len)
389 {
390 if((pdir->attr == 0x20) && ((pdir + 1)->attr == 0x00))
391 {
392 break;
393 }
394 else
395 {
396 pdir ++;
397 }
398 loop_len += 32;
399 }
400
401 if(i_index <= 512 && loop_len < len)
402 {
403 fat16_memory_copy((uint8_t *)&g_file_attr, (const uint8_t *)pdir, 32);
404
405 if(file_match == 1)
406 {
407 file_match = 0;
408 if(g_file_attr.file_size > 0)
409 {
410 if(flash_iap.file_write_nr >= g_file_attr.file_size)
411 {
412 /* upgrade finish */
413 flash_iap.file_write_nr = 0;
414 flash_iap.msc_up_status = UPGRADE_SUCCESS;
415
416 /* set the upgrade done flag to flash */
417 flash_fat16_set_upgrade_flag();
418 }
419 }
420 }
421 g_file_attr.write_data = 0;
422 g_file_attr.write_time = 0;
423 flash_iap.file_write_nr = 0;
424 }
425 else
426 {
427 fat16_memory_memset((uint8_t *)&g_file_attr, 0, 32);
428 }
429 return len;
430}
431
437uint32_t flash_fat16_addr_offset(uint8_t *file_name)
438{
439 uint8_t i_index = 0, offset_shift = 20;
440 uint32_t offset = 0;
441 uint8_t *pfile = file_name;
442
443 if(*pfile != 'A')
444 {
445 return INVAILD_OFFSET_ADDR;
446 }
447 pfile += 1;
448
449 for(i_index = 0; i_index < 6; i_index ++)
450 {
451 if(*pfile >= '0' && *pfile <= '9')
452 {
453 offset |= (*pfile - '0') << offset_shift;
454 }
455 else if(*pfile >= 'A' && *pfile <= 'F')
456 {
457 offset |= (*pfile - 'A' + 0xA) << offset_shift;
458 }
459 else if(*pfile >= 'a' && *pfile <= 'f')
460 {
461 offset |= (*pfile - 'a' + 0xA) << offset_shift;
462 }
463 else
464 {
465 return INVAILD_OFFSET_ADDR;
466 }
467 pfile ++;
468 offset_shift -= 4;
469 }
470
471 if((offset < (flash_iap.flash_app_addr - flash_iap.flash_base_addr)) ||
472 (offset > flash_iap.flash_size ))
473 {
474 return INVAILD_OFFSET_ADDR;
475 }
476 return offset;
477}
478
486uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
487{
488 uint32_t file_size = g_file_attr.file_size;
489 uint32_t flash_offset = 0;
490 uint32_t status;
491 static uint32_t s_bin_sp = 0;
492 static uint32_t s_bin_pc = 0;
493
494 if(s_bin_sp == 0 && s_bin_pc == 0)
495 {
496 s_bin_sp = *(uint32_t *)data;
497 s_bin_pc = *(uint32_t *)(data+4);
498 }
499
500 /* check the suffix is .bin or .BIN*/
501 if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
502 (uint8_t *)FILE_SUFFIX1_NAME, FILE_SUFFIX1_LEN) == 0) ||
503 (fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
504 (uint8_t *)FILE_SUFFIX2_NAME, FILE_SUFFIX2_LEN) == 0)
505 ||
506 ((s_bin_sp & 0xF0000000) == 0x20000000 && (s_bin_pc & 0xFF000000) == 0x08000000))
507 {
508 /* check the upgrade status */
509 if(flash_iap.msc_up_status == UPGRADE_DONE || flash_iap.msc_up_status == UPGRADE_SUCCESS)
510 {
511 return 0;
512 }
513
514 if(g_file_attr.file_size == 0)
515 {
516 g_file_attr.file_size = flash_iap.flash_app_size;
517 file_match = 1;
518 }
519
520 file_size = g_file_attr.file_size;
521
522 if(flash_iap.msc_up_status == UPGRADE_READY)
523 {
524 /* get offset address from filename */
525 flash_offset = flash_fat16_addr_offset(g_file_attr.file_name);
526
527 if(flash_offset == INVAILD_OFFSET_ADDR)
528 {
529 /* use default app address */
530 flash_iap.write_addr = FLASH_APP_START_ADDR;
531 }
532 else
533 {
534 flash_iap.write_addr = flash_offset + flash_iap.flash_base_addr;
535 }
536 /* clear upgrade flag */
537 flash_fat16_clear_upgrade_flag();
538
539 flash_iap.msc_up_status = UPGRAGE_ONGOING;
540 }
541
542 if(flash_iap.flash_app_size >= g_file_attr.file_size)
543 {
544 if((flash_iap.file_write_nr + len) >= file_size)
545 {
546 len = file_size - flash_iap.file_write_nr;
547 }
548 /* write data to flash and check crc */
549 status = flash_write_data(flash_iap.write_addr + flash_iap.file_write_nr, data, len);
550
551 flash_iap.file_write_nr += len;
552
553 if(status == 0)
554 {
555 if(flash_iap.file_write_nr >= file_size)
556 {
557 /* upgrade finish */
558 flash_iap.file_write_nr = 0;
559 flash_iap.msc_up_status = UPGRADE_SUCCESS;
560 s_bin_sp = 0;
561 s_bin_pc = 0;
562 /* set the upgrade done flag to flash */
563 flash_fat16_set_upgrade_flag();
564 }
565 }
566 else
567 {
568 /* upgrade failed */
569 flash_iap.file_write_nr = 0;
570 flash_iap.msc_up_status = UPGRADE_FAILED;
571 }
572 }
573 else
574 {
575 /* upgrade file is large than flash size */
576 flash_iap.msc_up_status = UPGRADE_LARGE;
577 }
578
579 }
580 else if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[0],
581 (uint8_t *)"JUMP", 4) == 0))
582 {
583 /* receive jump command file */
584 flash_iap.msc_up_status = UPGRADE_JUMP;
585 }
586 else
587 {
588 /* unkonw upgrade status */
589 }
590
591 return len;
592}
593
601uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
602{
603 uint32_t flash_crc = 0;
604 uint32_t data_crc = 0;
605 uint32_t i_index = 0;
606 uint32_t wlen = len / sizeof(uint32_t);
607 uint32_t remain_len = len % sizeof(uint32_t);
608 uint32_t *u32data = (uint32_t *)data;
609 uint32_t *flash_addr = (uint32_t *)address;
610
611 /* enable crc clock */
612 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
613
614 if(remain_len)
615 {
616 wlen += 1;
617 for(i_index = 0; i_index < (4 - remain_len); i_index ++)
618 {
619 data[len+i_index] = 0xFF;
620 }
621 }
622
623 /* calculate write buffer */
624 crc_data_reset();
625 for(i_index = 0; i_index < wlen; i_index ++)
626 {
627 data_crc = crc_one_word_calculate(u32data[i_index]);
628 }
629
630 /* calculate flash data */
631 crc_data_reset();
632 for(i_index = 0; i_index < wlen; i_index ++)
633 {
634 flash_crc = crc_one_word_calculate(*flash_addr++);
635 }
636 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, FALSE);
637
638 if(data_crc != flash_crc)
639 return 1;
640
641 return 0;
642
643}
644
652uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
653{
654 uint32_t i_index;
655 for(i_index = 0; i_index < len; i_index ++)
656 {
657 data[i_index] = *(uint8_t *)address;
658 address += 1;
659 }
660 return i_index;
661}
662
663
671uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
672{
673 uint32_t waddr = address;
674 uint32_t wlength = len;
675 uint32_t i_index = 0;
676 if((address + len) > flash_iap.flash_base_addr + flash_iap.flash_size)
677 {
678 return 1;
679 }
680
681 if((waddr & flash_iap.sector_mask) == 0)
682 {
683 flash_unlock();
684 if(len > flash_iap.sector_size)
685 {
686 for(; wlength >= flash_iap.sector_size; wlength -= flash_iap.sector_size)
687 {
688 flash_sector_erase(waddr);
689 waddr += flash_iap.sector_size;
690 }
691 if(wlength > 0)
692 {
693 flash_sector_erase(waddr);
694 }
695 }
696 else
697 {
698 flash_sector_erase(waddr);
699 }
700
701 flash_lock();
702 }
703
704 waddr = address;
705 flash_unlock();
706 for(i_index = 0; i_index < len; i_index ++)
707 {
708 flash_byte_program(waddr+i_index, data[i_index]);
709 }
710 flash_lock();
711
712 return flash_crc_check(address, data, len);
713}
714
720void flash_fat16_init(void)
721{
722 uint32_t flash_size = *(uint32_t *)0x1FFFF7E0;
723 flash_iap.flash_base_addr = FLASH_BASE;
724 flash_iap.flash_app_addr = FLASH_APP_START_ADDR;
725 flash_iap.write_addr = FLASH_APP_START_ADDR;
726 flash_iap.flash_size = flash_size << 10;
727
728 flash_iap.flash_app_size = flash_iap.flash_size -
729 (flash_iap.flash_app_addr -
730 flash_iap.flash_base_addr);
731
732 if(flash_size < 0x100)
733 {
734 flash_iap.sector_size = FLASH_SECTOR_1K_SIZE;
735 flash_iap.sector_mask = FLASH_SECTOR_1K_ALLGNED;
736 }
737 else
738 {
739 flash_iap.sector_size = FLASH_SECTOR_2K_SIZE;
740 flash_iap.sector_mask = FLASH_SECTOR_2K_ALLGNED;
741 }
742
743}
744
745
746
flash_fat16.h
fat16 file system header file
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: flash_fat16.c:357
FAT16_SECTOR_SIZE
#define FAT16_SECTOR_SIZE
Definition: flash_fat16.c:34
g_file_attr
fat_dir_type g_file_attr
Definition: flash_fat16.c:170
fat16_sector
static uint8_t fat16_sector[62]
Definition: flash_fat16.c:35
flash_read_data
uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
read data from flash
Definition: flash_fat16.c:652
file_match
uint8_t file_match
Definition: flash_fat16.c:173
fat16_root_dir_sector
const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]
Definition: flash_fat16.c:106
file_write_nr
uint32_t file_write_nr
Definition: flash_fat16.c:172
flash_fat16_addr_offset
uint32_t flash_fat16_addr_offset(uint8_t *file_name)
get offset address
Definition: flash_fat16.c:437
fat16_table_sector0
const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Definition: flash_fat16.c:147
flash_fat16_clear_upgrade_flag
void flash_fat16_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: flash_fat16.c:243
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: flash_fat16.c:268
fat16_memory_memset
uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
memset function
Definition: flash_fat16.c:210
flash_iap
flash_iap_type flash_iap
Definition: flash_fat16.c:171
flash_crc_check
uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
crc check
Definition: flash_fat16.c:601
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: flash_fat16.c:329
fat16_memory_cmp
uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function
Definition: flash_fat16.c:227
flash_fat16_sector_write
uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector
Definition: flash_fat16.c:486
flash_fat16_set_upgrade_flag
void flash_fat16_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: flash_fat16.c:255
flash_write_data
uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
write data to flash
Definition: flash_fat16.c:671
fat16_memory_copy
uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function
Definition: flash_fat16.c:193
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: flash_fat16.c:720
flash_fat16_boot_dir_write
uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write
Definition: flash_fat16.c:379
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: flash_fat16.c:288
fat16_file_name
uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Definition: flash_fat16.c:155
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:47
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:58
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:104
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:489
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
FLASH_APP_START_ADDR
#define FLASH_APP_START_ADDR
Definition: flash_fat16.h:58
FLASH_SECTOR_1K_ALLGNED
#define FLASH_SECTOR_1K_ALLGNED
Definition: flash_fat16.h:64
FAT16_TABLE_SIZE
#define FAT16_TABLE_SIZE
Definition: flash_fat16.h:47
INVAILD_OFFSET_ADDR
#define INVAILD_OFFSET_ADDR
Definition: flash_fat16.h:73
FLASH_FAT16_2_ADDR
#define FLASH_FAT16_2_ADDR
Definition: flash_fat16.h:54
FLASH_FAT16_1_ADDR
#define FLASH_FAT16_1_ADDR
Definition: flash_fat16.h:53
FLASH_FAT16_ROOT_ADDR
#define FLASH_FAT16_ROOT_ADDR
Definition: flash_fat16.h:55
FAT16_DIR_SIZE
#define FAT16_DIR_SIZE
Definition: flash_fat16.h:50
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: flash_fat16.h:61
FILE_SUFFIX1_NAME
#define FILE_SUFFIX1_NAME
Definition: flash_fat16.h:70
FLASH_FAT16_FILE_START_ADDR
#define FLASH_FAT16_FILE_START_ADDR
Definition: flash_fat16.h:56
FILE_SUFFIX2_LEN
#define FILE_SUFFIX2_LEN
Definition: flash_fat16.h:69
FLASH_SECTOR_2K_ALLGNED
#define FLASH_SECTOR_2K_ALLGNED
Definition: flash_fat16.h:65
FLASH_FAT16_BOOT_SECTOR_ADDR
#define FLASH_FAT16_BOOT_SECTOR_ADDR
Definition: flash_fat16.h:52
FILE_SUFFIX1_LEN
#define FILE_SUFFIX1_LEN
Definition: flash_fat16.h:68
FAT16_BYTE_PER_SIZE
#define FAT16_BYTE_PER_SIZE
Definition: flash_fat16.h:48
FILE_SUFFIX2_NAME
#define FILE_SUFFIX2_NAME
Definition: flash_fat16.h:71
FAT16_FILENAME_SIZE
#define FAT16_FILENAME_SIZE
Definition: flash_fat16.h:49
FLASH_SECTOR_1K_SIZE
#define FLASH_SECTOR_1K_SIZE
Definition: flash_fat16.h:60
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: flash_fat16.h:84
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: flash_fat16.h:87
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: flash_fat16.h:83
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: flash_fat16.h:82
UPGRADE_READY
@ UPGRADE_READY
Definition: flash_fat16.h:80
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: flash_fat16.h:81
UPGRADE_DONE
@ UPGRADE_DONE
Definition: flash_fat16.h:86
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:76
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:87
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:85
fat_dir_type
Definition: flash_fat16.h:91
fat_dir_type::write_data
uint16_t write_data
Definition: flash_fat16.h:101
fat_dir_type::file_size
uint32_t file_size
Definition: flash_fat16.h:103
fat_dir_type::write_time
uint16_t write_time
Definition: flash_fat16.h:100
fat_dir_type::file_name
uint8_t file_name[11]
Definition: flash_fat16.h:92
fat_dir_type::attr
uint8_t attr
Definition: flash_fat16.h:93
flash_iap_type
Definition: flash_fat16.h:107
flash_iap_type::flash_size
uint32_t flash_size
Definition: flash_fat16.h:110
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: flash_fat16.h:120
flash_iap_type::flash_base_addr
uint32_t flash_base_addr
Definition: flash_fat16.h:108
flash_iap_type::sector_size
uint32_t sector_size
Definition: flash_fat16.h:112
flash_iap_type::sector_mask
uint32_t sector_mask
Definition: flash_fat16.h:113
flash_iap_type::file_write_nr
uint32_t file_write_nr
Definition: flash_fat16.h:119
flash_iap_type::flash_app_size
uint32_t flash_app_size
Definition: flash_fat16.h:111
flash_iap_type::write_addr
uint32_t write_addr
Definition: flash_fat16.h:118
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: flash_fat16.h:109


AT32F413 Firmwary Library: flash_fat16.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
flash_fat16.h
Go to the documentation of this file.
1
24/* Define to prevent recursive inclusion -------------------------------------*/
25#ifndef __FLASH_FAT16_H
26#define __FLASH_FAT16_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32
33#include "usb_conf.h"
34
46#define FAT16_SECTOR_SIZE 62
47#define FAT16_TABLE_SIZE 4
48#define FAT16_BYTE_PER_SIZE 2048
49#define FAT16_FILENAME_SIZE 11
50#define FAT16_DIR_SIZE 47
51
52#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
53#define FLASH_FAT16_1_ADDR 0x3000
54#define FLASH_FAT16_2_ADDR 0x3800
55#define FLASH_FAT16_ROOT_ADDR 0x4000
56#define FLASH_FAT16_FILE_START_ADDR 0x8800
57
58#define FLASH_APP_START_ADDR 0x08005000
59
60#define FLASH_SECTOR_1K_SIZE 0x400
61#define FLASH_SECTOR_2K_SIZE 0x800
62#define FLASH_SECTOR_4K_SIZE 0x1000
63
64#define FLASH_SECTOR_1K_ALLGNED 0x3FF
65#define FLASH_SECTOR_2K_ALLGNED 0x7FF
66#define FLASH_SECTOR_4K_ALLGNED 0xFFF
67
68#define FILE_SUFFIX1_LEN 3
69#define FILE_SUFFIX2_LEN 3
70#define FILE_SUFFIX1_NAME "BIN"
71#define FILE_SUFFIX2_NAME "bin"
72
73#define INVAILD_OFFSET_ADDR 0xFFFFFFFF
74#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
75#define IAP_SUCCESS 0
76#define IAP_FAILED 1
77
78typedef enum
79{
80 UPGRADE_READY = 0,
81 UPGRAGE_ONGOING,
82 UPGRADE_SUCCESS,
83 UPGRADE_FAILED,
84 UPGRADE_LARGE,
85 UPGRADE_UNKNOWN,
86 UPGRADE_DONE,
87 UPGRADE_JUMP
88}upgrade_status_type;
89
90typedef struct
91{
92 uint8_t file_name[11];
93 uint8_t attr;
94 uint8_t res;
95 uint8_t create_time_tenth;
96 uint16_t create_time;
97 uint16_t create_data;
98 uint16_t last_access_data;
99 uint16_t clus_high;
100 uint16_t write_time;
101 uint16_t write_data;
102 uint16_t clus_low;
103 uint32_t file_size;
104}fat_dir_type;
105
106typedef struct
107{
108 uint32_t flash_base_addr;
109 uint32_t flash_app_addr;
110 uint32_t flash_size;
111 uint32_t flash_app_size;
112 uint32_t sector_size;
113 uint32_t sector_mask;
114 uint32_t firmware_length;
115 uint32_t write_crc;
116 uint32_t read_crc;
117
118 uint32_t write_addr;
119 uint32_t file_write_nr;
120 upgrade_status_type msc_up_status;
121}flash_iap_type;
122
123extern flash_iap_type flash_iap;
124
125uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
126uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len);
127
128void flash_fat16_init(void);
129void flash_fat16_loop_status(void);
130uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len);
131uint8_t flash_fat16_get_upgrade_flag(void);
132
145#ifdef __cplusplus
146}
147#endif
148
149#endif
150
upgrade_status_type
upgrade_status_type
Definition: flash_fat16.h:79
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: flash_fat16.c:357
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: flash_fat16.c:268
flash_fat16_loop_status
void flash_fat16_loop_status(void)
loop status
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:177
flash_iap
flash_iap_type flash_iap
Definition: flash_fat16.c:171
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: flash_fat16.c:329
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: flash_fat16.c:720
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: flash_fat16.c:288
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: flash_fat16.h:84
UPGRADE_UNKNOWN
@ UPGRADE_UNKNOWN
Definition: flash_fat16.h:85
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: flash_fat16.h:87
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: flash_fat16.h:83
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: flash_fat16.h:82
UPGRADE_READY
@ UPGRADE_READY
Definition: flash_fat16.h:80
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: flash_fat16.h:81
UPGRADE_DONE
@ UPGRADE_DONE
Definition: flash_fat16.h:86
fat_dir_type
Definition: flash_fat16.h:91
fat_dir_type::clus_low
uint16_t clus_low
Definition: flash_fat16.h:102
fat_dir_type::write_data
uint16_t write_data
Definition: flash_fat16.h:101
fat_dir_type::file_size
uint32_t file_size
Definition: flash_fat16.h:103
fat_dir_type::last_access_data
uint16_t last_access_data
Definition: flash_fat16.h:98
fat_dir_type::write_time
uint16_t write_time
Definition: flash_fat16.h:100
fat_dir_type::create_time
uint16_t create_time
Definition: flash_fat16.h:96
fat_dir_type::create_time_tenth
uint8_t create_time_tenth
Definition: flash_fat16.h:95
fat_dir_type::create_data
uint16_t create_data
Definition: flash_fat16.h:97
fat_dir_type::clus_high
uint16_t clus_high
Definition: flash_fat16.h:99
fat_dir_type::res
uint8_t res
Definition: flash_fat16.h:94
fat_dir_type::attr
uint8_t attr
Definition: flash_fat16.h:93
flash_iap_type
Definition: flash_fat16.h:107
flash_iap_type::flash_size
uint32_t flash_size
Definition: flash_fat16.h:110
flash_iap_type::read_crc
uint32_t read_crc
Definition: flash_fat16.h:116
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: flash_fat16.h:120
flash_iap_type::flash_base_addr
uint32_t flash_base_addr
Definition: flash_fat16.h:108
flash_iap_type::write_crc
uint32_t write_crc
Definition: flash_fat16.h:115
flash_iap_type::sector_size
uint32_t sector_size
Definition: flash_fat16.h:112
flash_iap_type::firmware_length
uint32_t firmware_length
Definition: flash_fat16.h:114
flash_iap_type::sector_mask
uint32_t sector_mask
Definition: flash_fat16.h:113
flash_iap_type::file_write_nr
uint32_t file_write_nr
Definition: flash_fat16.h:119
flash_iap_type::flash_app_size
uint32_t flash_app_size
Definition: flash_fat16.h:111
flash_iap_type::write_addr
uint32_t write_addr
Definition: flash_fat16.h:118
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: flash_fat16.h:109
usb_conf.h
usb config header file


AT32F413 Firmwary Library: hid_iap_class.c Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "hid_iap_class.h"
26#include "hid_iap_desc.h"
27
42static usb_sts_type class_init_handler(void *udev);
43static usb_sts_type class_clear_handler(void *udev);
44static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
45static usb_sts_type class_ept0_tx_handler(void *udev);
46static usb_sts_type class_ept0_rx_handler(void *udev);
47static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_sof_handler(void *udev);
50static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
51
52 iap_info_type iap_info;
53
54/* usb device class handler */
55 usbd_class_handler hid_iap_class_handler =
56{
57 class_init_handler,
58 class_clear_handler,
59 class_setup_handler,
60 class_ept0_tx_handler,
61 class_ept0_rx_handler,
62 class_in_handler,
63 class_out_handler,
64 class_sof_handler,
65 class_event_handler,
66 &iap_info
67};
68
74static usb_sts_type class_init_handler(void *udev)
75{
76 usb_sts_type status = USB_OK;
77 usbd_core_type *pudev = (usbd_core_type *)udev;
78 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
79 /* open hid iap in endpoint */
80 usbd_ept_open(pudev, USBD_HIDIAP_IN_EPT, EPT_INT_TYPE, USBD_HIDIAP_IN_MAXPACKET_SIZE);
81
82 /* open hid iap out endpoint */
83 usbd_ept_open(pudev, USBD_HIDIAP_OUT_EPT, EPT_INT_TYPE, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
84
85 /* set out endpoint to receive status */
86 usbd_ept_recv(pudev, USBD_HIDIAP_OUT_EPT, piap->g_rxhid_buff, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
87
88 return status;
89}
90
96static usb_sts_type class_clear_handler(void *udev)
97{
98 usb_sts_type status = USB_OK;
99 usbd_core_type *pudev = (usbd_core_type *)udev;
100
101 /* close hid iap in endpoint */
102 usbd_ept_close(pudev, USBD_HIDIAP_IN_EPT);
103
104 /* close hid iap out endpoint */
105 usbd_ept_close(pudev, USBD_HIDIAP_OUT_EPT);
106
107 return status;
108}
109
116static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
117{
118 usb_sts_type status = USB_OK;
119 usbd_core_type *pudev = (usbd_core_type *)udev;
120 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
121 uint16_t len;
122 uint8_t *buf;
123
124 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
125 {
126 /* class request */
127 case USB_REQ_TYPE_CLASS:
128 switch(setup->bRequest)
129 {
130 case HID_REQ_SET_PROTOCOL:
131 piap->hid_protocol = (uint8_t)setup->wValue;
132 break;
133 case HID_REQ_GET_PROTOCOL:
134 usbd_ctrl_send(pudev, (uint8_t *)&piap->hid_protocol, 1);
135 break;
136 case HID_REQ_SET_IDLE:
137 piap->hid_set_idle = (uint8_t)(setup->wValue >> 8);
138 break;
139 case HID_REQ_GET_IDLE:
140 usbd_ctrl_send(pudev, (uint8_t *)&piap->hid_set_idle, 1);
141 break;
142 case HID_REQ_SET_REPORT:
143 piap->hid_state = HID_REQ_SET_REPORT;
144 usbd_ctrl_recv(pudev, piap->hid_set_report, setup->wLength);
145 break;
146 default:
147 usbd_ctrl_unsupport(pudev);
148 break;
149 }
150 break;
151 /* standard request */
152 case USB_REQ_TYPE_STANDARD:
153 switch(setup->bRequest)
154 {
155 case USB_STD_REQ_GET_DESCRIPTOR:
156 if(setup->wValue >> 8 == HID_REPORT_DESC)
157 {
158 len = MIN(USBD_HIDIAP_SIZ_REPORT_DESC, setup->wLength);
159 buf = (uint8_t *)g_usbd_hidiap_report;
160 }
161 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
162 {
163 len = MIN(9, setup->wLength);
164 buf = (uint8_t *)g_hidiap_usb_desc;
165 }
166 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
167 break;
168 case USB_STD_REQ_GET_INTERFACE:
169 usbd_ctrl_send(pudev, (uint8_t *)&piap->alt_setting, 1);
170 break;
171 case USB_STD_REQ_SET_INTERFACE:
172 piap->alt_setting = setup->wValue;
173 break;
174 case USB_STD_REQ_CLEAR_FEATURE:
175 break;
176 case USB_STD_REQ_SET_FEATURE:
177 break;
178 default:
179 usbd_ctrl_unsupport(pudev);
180 break;
181 }
182 break;
183 default:
184 usbd_ctrl_unsupport(pudev);
185 break;
186 }
187 return status;
188}
189
195static usb_sts_type class_ept0_tx_handler(void *udev)
196{
197 usb_sts_type status = USB_OK;
198
199 /* ...user code... */
200
201 return status;
202}
203
209static usb_sts_type class_ept0_rx_handler(void *udev)
210{
211 usb_sts_type status = USB_OK;
212 usbd_core_type *pudev = (usbd_core_type *)udev;
213 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
214 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
215 /* ...user code... */
216 if( piap->hid_state == HID_REQ_SET_REPORT)
217 {
218 /* hid buffer process */
219 piap->hid_state = 0;
220 }
221
222 return status;
223}
224
231static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
232{
233 usb_sts_type status = USB_OK;
234
235 /* ...user code...
236 trans next packet data
237 */
238 usbd_hid_iap_in_complete(udev);
239
240 return status;
241}
242
249static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
250{
251 usb_sts_type status = USB_OK;
252 usbd_core_type *pudev = (usbd_core_type *)udev;
253 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
254
255 /* get endpoint receive data length */
256 uint32_t recv_len = usbd_get_recv_len(pudev, ept_num);
257
258 /* hid iap process */
259 usbd_hid_iap_process(udev, piap->g_rxhid_buff, recv_len);
260
261 /* start receive next packet */
262 usbd_ept_recv(pudev, USBD_HIDIAP_OUT_EPT, piap->g_rxhid_buff, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
263
264 return status;
265}
266
272static usb_sts_type class_sof_handler(void *udev)
273{
274 usb_sts_type status = USB_OK;
275
276 /* ...user code... */
277
278 return status;
279}
280
287static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
288{
289 usb_sts_type status = USB_OK;
290 switch(event)
291 {
292 case USBD_RESET_EVENT:
293
294 /* ...user code... */
295
296 break;
297 case USBD_SUSPEND_EVENT:
298
299 /* ...user code... */
300
301 break;
302 case USBD_WAKEUP_EVENT:
303 /* ...user code... */
304
305 break;
306 default:
307 break;
308 }
309 return status;
310}
311
319 usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
320{
321 usb_sts_type status = USB_OK;
322 usbd_core_type *pudev = (usbd_core_type *)udev;
323
324 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
325 usbd_ept_send(pudev, USBD_HIDIAP_IN_EPT, report, len);
326
327 return status;
328}
329
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:54
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:192
USBD_HIDIAP_IN_EPT
#define USBD_HIDIAP_IN_EPT
Definition: hid_iap_class.h:50
USBD_HIDIAP_OUT_EPT
#define USBD_HIDIAP_OUT_EPT
Definition: hid_iap_class.h:51
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:53
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:238
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: hid_iap_class.c:272
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:52
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: hid_iap_class.c:231
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: hid_iap_class.c:96
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: hid_iap_class.c:116
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:319
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: hid_iap_class.c:195
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: hid_iap_class.c:209
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: hid_iap_class.c:287
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:55
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: hid_iap_class.c:74
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: hid_iap_class.c:249
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:201
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:55
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:170
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:234
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:229
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:228
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:235
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:230
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:231
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:232
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
iap_info_type
Definition: hid_iap_class.h:103
iap_info_type::hid_state
uint32_t hid_state
Definition: hid_iap_class.h:128
iap_info_type::hid_set_idle
uint32_t hid_set_idle
Definition: hid_iap_class.h:126
iap_info_type::hid_protocol
uint32_t hid_protocol
Definition: hid_iap_class.h:125
iap_info_type::hid_set_report
uint8_t hid_set_report[64]
Definition: hid_iap_class.h:129
iap_info_type::alt_setting
uint32_t alt_setting
Definition: hid_iap_class.h:127
iap_info_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: hid_iap_class.h:124
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: hid_iap_class.h Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __HID_IAP_CLASS_H
27#define __HID_IAP_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
36
50#define USBD_HIDIAP_IN_EPT 0x81
51#define USBD_HIDIAP_OUT_EPT 0x01
52
53#define USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
54#define USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
55
56#define FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
57#define KB_TO_B(kb) ((kb) << 10)
58
59#define SECTOR_SIZE_1K 0x400
60#define SECTOR_SIZE_2K 0x800
61#define SECTOR_SIZE_4K 0x1000
62
66#define IAP_CMD_IDLE 0x5AA0
67#define IAP_CMD_START 0x5AA1
68#define IAP_CMD_ADDR 0x5AA2
69#define IAP_CMD_DATA 0x5AA3
70#define IAP_CMD_FINISH 0x5AA4
71#define IAP_CMD_CRC 0x5AA5
72#define IAP_CMD_JMP 0x5AA6
73#define IAP_CMD_GET 0x5AA7
74
75#define HID_IAP_BUFFER_LEN 1024
76#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
77#define CONVERT_ENDIAN(dwValue) ((dwValue >> 24) | ((dwValue >> 8) & 0xFF00) | \
78 ((dwValue << 8) & 0xFF0000) | (dwValue << 24) )
79
80#define IAP_ACK 0xFF00
81#define IAP_NACK 0x00FF
82
83typedef enum
84{
85 IAP_SUCCESS,
86 IAP_WAIT,
87 IAP_FAILED
88}iap_result_type;
89
90typedef enum
91{
92 IAP_STS_IDLE,
93 IAP_STS_START,
94 IAP_STS_ADDR,
95 IAP_STS_DATA,
96 IAP_STS_FINISH,
97 IAP_STS_CRC,
98 IAP_STS_JMP_WAIT,
99 IAP_STS_JMP,
100}iap_machine_state_type;
101
102typedef struct
103{
104
105 uint8_t iap_fifo[HID_IAP_BUFFER_LEN];
106 uint8_t iap_rx[USBD_HIDIAP_OUT_MAXPACKET_SIZE];
107 uint8_t iap_tx[USBD_HIDIAP_IN_MAXPACKET_SIZE];
108
109 uint32_t fifo_length;
110 uint32_t tx_length;
111
112 uint32_t app_address;
113 uint32_t iap_address;
114 uint32_t flag_address;
115
116 uint32_t flash_start_address;
117 uint32_t flash_end_address;
118
119 uint32_t sector_size;
120 uint32_t flash_size;
121
122 uint32_t respond_flag;
123
124 uint8_t g_rxhid_buff[USBD_HIDIAP_OUT_MAXPACKET_SIZE];
125 uint32_t hid_protocol;
126 uint32_t hid_set_idle;
127 uint32_t alt_setting;
128 uint32_t hid_state;
129 uint8_t hid_set_report[64];
130
131 iap_machine_state_type state;
132}iap_info_type;
133
134extern usbd_class_handler hid_iap_class_handler;
135extern iap_info_type iap_info;
136 usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len);
137 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len);
138void usbd_hid_iap_in_complete(void *udev);
139
151#ifdef __cplusplus
152}
153#endif
154
155#endif
156
157
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:52
HID_IAP_BUFFER_LEN
#define HID_IAP_BUFFER_LEN
Definition: hid_iap_class.h:75
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:54
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:319
iap_result_type
iap_result_type
Definition: hid_iap_class.h:84
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:192
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:55
iap_machine_state_type
iap_machine_state_type
Definition: hid_iap_class.h:91
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:53
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:238
IAP_WAIT
@ IAP_WAIT
Definition: hid_iap_class.h:86
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:87
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:85
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:93
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:99
IAP_STS_DATA
@ IAP_STS_DATA
Definition: hid_iap_class.h:95
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:98
IAP_STS_IDLE
@ IAP_STS_IDLE
Definition: hid_iap_class.h:92
IAP_STS_FINISH
@ IAP_STS_FINISH
Definition: hid_iap_class.h:96
IAP_STS_ADDR
@ IAP_STS_ADDR
Definition: hid_iap_class.h:94
IAP_STS_CRC
@ IAP_STS_CRC
Definition: hid_iap_class.h:97
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
iap_info_type
Definition: hid_iap_class.h:103
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:122
iap_info_type::hid_state
uint32_t hid_state
Definition: hid_iap_class.h:128
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:114
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:119
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:113
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:116
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:117
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:109
iap_info_type::hid_set_idle
uint32_t hid_set_idle
Definition: hid_iap_class.h:126
iap_info_type::hid_protocol
uint32_t hid_protocol
Definition: hid_iap_class.h:125
iap_info_type::tx_length
uint32_t tx_length
Definition: hid_iap_class.h:110
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:120
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:112
iap_info_type::alt_setting
uint32_t alt_setting
Definition: hid_iap_class.h:127
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:131
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: hid_iap_desc.c Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "hid_iap_desc.h"
28
29
44static usbd_desc_t *get_device_descriptor(void);
45static usbd_desc_t *get_device_qualifier(void);
46static usbd_desc_t *get_device_configuration(void);
47static usbd_desc_t *get_device_other_speed(void);
48static usbd_desc_t *get_device_lang_id(void);
49static usbd_desc_t *get_device_manufacturer_string(void);
50static usbd_desc_t *get_device_product_string(void);
51static usbd_desc_t *get_device_serial_string(void);
52static usbd_desc_t *get_device_interface_string(void);
53static usbd_desc_t *get_device_config_string(void);
54
55static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
56static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
57static void get_serial_num(void);
58#if defined ( __ICCARM__ ) /* iar compiler */
59 #pragma data_alignment=4
60#endif
61ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
62
66 usbd_desc_handler hid_iap_desc_handler =
67{
68 get_device_descriptor,
69 get_device_qualifier,
70 get_device_configuration,
71 get_device_other_speed,
72 get_device_lang_id,
73 get_device_manufacturer_string,
74 get_device_product_string,
75 get_device_serial_string,
76 get_device_interface_string,
77 get_device_config_string,
78};
79
83#if defined ( __ICCARM__ ) /* iar compiler */
84 #pragma data_alignment=4
85#endif
86ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
87{
88 USB_DEVICE_DESC_LEN, /* bLength */
89 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
90 0x00, /* bcdUSB */
91 0x02,
92 0x00, /* bDeviceClass */
93 0x00, /* bDeviceSubClass */
94 0x00, /* bDeviceProtocol */
95 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
96 LBYTE(USBD_HIDIAP_VENDOR_ID), /* idVendor */
97 HBYTE(USBD_HIDIAP_VENDOR_ID), /* idVendor */
98 LBYTE(USBD_HIDIAP_PRODUCT_ID), /* idProduct */
99 HBYTE(USBD_HIDIAP_PRODUCT_ID), /* idProduct */
100 0x00, /* bcdDevice rel. 2.00 */
101 0x02,
102 USB_MFC_STRING, /* Index of manufacturer string */
103 USB_PRODUCT_STRING, /* Index of product string */
104 USB_SERIAL_STRING, /* Index of serial number string */
105 1 /* bNumConfigurations */
106};
107
111#if defined ( __ICCARM__ ) /* iar compiler */
112 #pragma data_alignment=4
113#endif
114ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_HIDIAP_CONFIG_DESC_SIZE] ALIGNED_TAIL =
115{
116 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
117 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
118 LBYTE(USBD_HIDIAP_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 HBYTE(USBD_HIDIAP_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
120 0x01, /* bNumInterfaces: 1 interface */
121 0x01, /* bConfigurationValue: configuration value */
122 0x00, /* iConfiguration: index of string descriptor describing
123 the configuration */
124 0xC0, /* bmAttributes: self powered */
125 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
126
127 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
128 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
129 0x00, /* bInterfaceNumber: number of interface */
130 0x00, /* bAlternateSetting: alternate set */
131 0x02, /* bNumEndpoints: number of endpoints */
132 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
133 0x00, /* bInterfaceSubClass: subclass code */
134 0x00, /* bInterfaceProtocol: protocol code */
135 0x00, /* iInterface: index of string descriptor */
136
137 0x09, /* bLength: size of HID descriptor in bytes */
138 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
139 LBYTE(HIDIAP_BCD_NUM),
140 HBYTE(HIDIAP_BCD_NUM), /* bcdHID: HID class specification release number */
141 0x00, /* bCountryCode: hardware target conutry */
142 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
143 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
144 LBYTE(sizeof(g_usbd_hidiap_report)),
145 HBYTE(sizeof(g_usbd_hidiap_report)), /* wDescriptorLength: total length of reprot descriptor */
146
147 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
148 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
149 USBD_HIDIAP_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
150 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
151 LBYTE(USBD_HIDIAP_IN_MAXPACKET_SIZE),
152 HBYTE(USBD_HIDIAP_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
153 HIDIAP_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
154
155 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
156 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
157 USBD_HIDIAP_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
158 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
159 LBYTE(USBD_HIDIAP_OUT_MAXPACKET_SIZE),
160 HBYTE(USBD_HIDIAP_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
161 HIDIAP_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
162};
163
167#if defined ( __ICCARM__ ) /* iar compiler */
168 #pragma data_alignment=4
169#endif
170ALIGNED_HEAD uint8_t g_usbd_hidiap_report[USBD_HIDIAP_SIZ_REPORT_DESC] ALIGNED_TAIL =
171{
172 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
173 0x09, 0x01, /* USAGE (Demo Kit) */
174 0xa1, 0x01, /* COLLECTION (Application) */
175
176 /* 6 */
177 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
178 0x25, 0xFF, /* LOGICAL_MAXIMUM (255) */
179 0x75, 0x08, /* REPORT_SIZE (8) */
180 0x95, 0x40, /* REPORT_COUNT (64) */
181
182 0x09, 0x01,
183 0x81, 0x02,
184 0x95, 0x40,
185
186 0x09, 0x01,
187 0x91, 0x02,
188 0x95, 0x01,
189
190 0x09, 0x01,
191 0xB1, 0x02,
192 0xC0
193};
194
198#if defined ( __ICCARM__ ) /* iar compiler */
199 #pragma data_alignment=4
200#endif
201ALIGNED_HEAD uint8_t g_hidiap_usb_desc[9] ALIGNED_TAIL =
202{
203 0x09, /* bLength: size of HID descriptor in bytes */
204 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
205 LBYTE(HIDIAP_BCD_NUM),
206 HBYTE(HIDIAP_BCD_NUM), /* bcdHID: HID class specification release number */
207 0x00, /* bCountryCode: hardware target conutry */
208 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
209 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
210 LBYTE(sizeof(g_usbd_hidiap_report)),
211 HBYTE(sizeof(g_usbd_hidiap_report)), /* wDescriptorLength: total length of reprot descriptor */
212};
213
214
218#if defined ( __ICCARM__ ) /* iar compiler */
219 #pragma data_alignment=4
220#endif
221ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_HIDIAP_SIZ_STRING_LANGID] ALIGNED_TAIL =
222{
223 USBD_HIDIAP_SIZ_STRING_LANGID,
224 USB_DESCIPTOR_TYPE_STRING,
225 0x09,
226 0x04,
227};
228
232#if defined ( __ICCARM__ ) /* iar compiler */
233 #pragma data_alignment=4
234#endif
235ALIGNED_HEAD static uint8_t g_string_serial[USBD_HIDIAP_SIZ_STRING_SERIAL] ALIGNED_TAIL =
236{
237 USBD_HIDIAP_SIZ_STRING_SERIAL,
238 USB_DESCIPTOR_TYPE_STRING,
239};
240
241
242/* device descriptor */
243static usbd_desc_t device_descriptor =
244{
245 USB_DEVICE_DESC_LEN,
246 g_usbd_descriptor
247};
248
249/* config descriptor */
250static usbd_desc_t config_descriptor =
251{
252 USBD_HIDIAP_CONFIG_DESC_SIZE,
253 g_usbd_configuration
254};
255
256/* langid descriptor */
257static usbd_desc_t langid_descriptor =
258{
259 USBD_HIDIAP_SIZ_STRING_LANGID,
260 g_string_lang_id
261};
262
263/* serial descriptor */
264static usbd_desc_t serial_descriptor =
265{
266 USBD_HIDIAP_SIZ_STRING_SERIAL,
267 g_string_serial
268};
269
270static usbd_desc_t vp_desc;
271
278static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
279{
280 uint16_t str_len = 0, id_pos = 2;
281 uint8_t *tmp_str = string;
282
283 while(*tmp_str != '\0')
284 {
285 str_len ++;
286 unicode_buf[id_pos ++] = *tmp_str ++;
287 unicode_buf[id_pos ++] = 0x00;
288 }
289
290 str_len = str_len * 2 + 2;
291 unicode_buf[0] = str_len;
292 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
293
294 return str_len;
295}
296
304static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
305{
306 uint8_t idx = 0;
307
308 for( idx = 0 ; idx < len ; idx ++)
309 {
310 if( ((value >> 28)) < 0xA )
311 {
312 pbuf[ 2 * idx] = (value >> 28) + '0';
313 }
314 else
315 {
316 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
317 }
318
319 value = value << 4;
320
321 pbuf[2 * idx + 1] = 0;
322 }
323}
324
330static void get_serial_num(void)
331{
332 uint32_t serial0, serial1, serial2;
333
334 serial0 = *(uint32_t*)MCU_ID1;
335 serial1 = *(uint32_t*)MCU_ID2;
336 serial2 = *(uint32_t*)MCU_ID3;
337
338 serial0 += serial2;
339
340 if (serial0 != 0)
341 {
342 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
343 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
344 }
345}
346
352static usbd_desc_t *get_device_descriptor(void)
353{
354 return &device_descriptor;
355}
356
362static usbd_desc_t * get_device_qualifier(void)
363{
364 return NULL;
365}
366
372static usbd_desc_t *get_device_configuration(void)
373{
374 return &config_descriptor;
375}
376
382static usbd_desc_t *get_device_other_speed(void)
383{
384 return NULL;
385}
386
392static usbd_desc_t *get_device_lang_id(void)
393{
394 return &langid_descriptor;
395}
396
397
403static usbd_desc_t *get_device_manufacturer_string(void)
404{
405 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
406 vp_desc.descriptor = g_usbd_desc_buffer;
407 return &vp_desc;
408}
409
415static usbd_desc_t *get_device_product_string(void)
416{
417 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
418 vp_desc.descriptor = g_usbd_desc_buffer;
419 return &vp_desc;
420}
421
427static usbd_desc_t *get_device_serial_string(void)
428{
429 get_serial_num();
430 return &serial_descriptor;
431}
432
438static usbd_desc_t *get_device_interface_string(void)
439{
440 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
441 vp_desc.descriptor = g_usbd_desc_buffer;
442 return &vp_desc;
443}
444
450static usbd_desc_t *get_device_config_string(void)
451{
452 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
453 vp_desc.descriptor = g_usbd_desc_buffer;
454 return &vp_desc;
455}
456
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:54
USBD_HIDIAP_IN_EPT
#define USBD_HIDIAP_IN_EPT
Definition: hid_iap_class.h:50
USBD_HIDIAP_OUT_EPT
#define USBD_HIDIAP_OUT_EPT
Definition: hid_iap_class.h:51
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:53
USBD_HIDIAP_SIZ_STRING_LANGID
#define USBD_HIDIAP_SIZ_STRING_LANGID
Definition: hid_iap_desc.h:56
USBD_HIDIAP_SIZ_STRING_SERIAL
#define USBD_HIDIAP_SIZ_STRING_SERIAL
Definition: hid_iap_desc.h:57
USBD_HIDIAP_VENDOR_ID
#define USBD_HIDIAP_VENDOR_ID
Definition: hid_iap_desc.h:51
HIDIAP_BCD_NUM
#define HIDIAP_BCD_NUM
Definition: hid_iap_desc.h:49
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:201
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:55
USBD_HIDIAP_DESC_INTERFACE_STRING
#define USBD_HIDIAP_DESC_INTERFACE_STRING
Definition: hid_iap_desc.h:62
HIDIAP_BINTERVAL_TIME
#define HIDIAP_BINTERVAL_TIME
Definition: hid_iap_desc.h:64
USBD_HIDIAP_DESC_CONFIGURATION_STRING
#define USBD_HIDIAP_DESC_CONFIGURATION_STRING
Definition: hid_iap_desc.h:61
USBD_HIDIAP_DESC_MANUFACTURER_STRING
#define USBD_HIDIAP_DESC_MANUFACTURER_STRING
Definition: hid_iap_desc.h:59
USBD_HIDIAP_DESC_PRODUCT_STRING
#define USBD_HIDIAP_DESC_PRODUCT_STRING
Definition: hid_iap_desc.h:60
USBD_HIDIAP_CONFIG_DESC_SIZE
#define USBD_HIDIAP_CONFIG_DESC_SIZE
Definition: hid_iap_desc.h:54
USBD_HIDIAP_PRODUCT_ID
#define USBD_HIDIAP_PRODUCT_ID
Definition: hid_iap_desc.h:52
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:170
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: hid_iap_desc.c:264
device_descriptor
static usbd_desc_t device_descriptor
Definition: hid_iap_desc.c:243
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: hid_iap_desc.c:372
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: hid_iap_desc.c:257
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: hid_iap_desc.c:352
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: hid_iap_desc.c:403
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: hid_iap_desc.c:362
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: hid_iap_desc.c:438
vp_desc
static usbd_desc_t vp_desc
Definition: hid_iap_desc.c:270
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: hid_iap_desc.c:382
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: hid_iap_desc.c:61
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: hid_iap_desc.c:415
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: hid_iap_desc.c:450
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:66
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: hid_iap_desc.c:278
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: hid_iap_desc.c:392
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: hid_iap_desc.c:330
config_descriptor
static usbd_desc_t config_descriptor
Definition: hid_iap_desc.c:250
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: hid_iap_desc.c:427
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: hid_iap_desc.c:304
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:161
hid_iap_desc.h
usb hid descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: hid_iap_desc.h Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __HID_IAP_DESC_H
27#define __HID_IAP_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "hid_iap_class.h"
34#include "usbd_core.h"
35
49#define HIDIAP_BCD_NUM 0x0110
50
51#define USBD_HIDIAP_VENDOR_ID 0x2E3C
52#define USBD_HIDIAP_PRODUCT_ID 0xAF01
53
54#define USBD_HIDIAP_CONFIG_DESC_SIZE 41
55#define USBD_HIDIAP_SIZ_REPORT_DESC 32
56#define USBD_HIDIAP_SIZ_STRING_LANGID 4
57#define USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
61#define USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
62#define USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
63
64#define HIDIAP_BINTERVAL_TIME 0x01
65
66#define MCU_ID1 (0x1FFFF7E8)
67#define MCU_ID2 (0x1FFFF7EC)
68#define MCU_ID3 (0x1FFFF7F0)
69extern uint8_t g_usbd_hidiap_report[USBD_HIDIAP_SIZ_REPORT_DESC];
70extern uint8_t g_hidiap_usb_desc[9];
71
72extern usbd_desc_handler hid_iap_desc_handler;
73
74
87#ifdef __cplusplus
88}
89#endif
90
91#endif
92
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:201
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:55
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:66
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:170
hid_iap_class.h
usb hid iap header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: i2c_application.c Source File

  • middlewares
  • i2c_application_library
i2c_application.c
Go to the documentation of this file.
1
25#include "i2c_application.h"
26
35#define DMA_GET_TC_FLAG(DMA_CHANNEL) \
36(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_FDT1_FLAG : \
37 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_FDT2_FLAG : \
38 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_FDT3_FLAG : \
39 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_FDT4_FLAG : \
40 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_FDT5_FLAG : \
41 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_FDT6_FLAG : \
42 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_FDT7_FLAG : \
43 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_FDT1_FLAG : \
44 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_FDT2_FLAG : \
45 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_FDT3_FLAG : \
46 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_FDT4_FLAG : \
47 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_FDT5_FLAG : \
48 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_FDT6_FLAG : \
49 DMA2_FDT7_FLAG)
50
54#define DMA_GET_HT_FLAG(DMA_CHANNEL) \
55(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_HDT1_FLAG : \
56 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_HDT2_FLAG : \
57 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_HDT3_FLAG : \
58 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_HDT4_FLAG : \
59 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_HDT5_FLAG : \
60 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_HDT6_FLAG : \
61 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_HDT7_FLAG : \
62 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_HDT1_FLAG : \
63 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_HDT2_FLAG : \
64 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_HDT3_FLAG : \
65 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_HDT4_FLAG : \
66 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_HDT5_FLAG : \
67 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_HDT6_FLAG : \
68 DMA2_HDT7_FLAG)
69
73#define DMA_GET_TERR_FLAG(DMA_CHANNEL) \
74(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_DTERR1_FLAG : \
75 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_DTERR2_FLAG : \
76 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_DTERR3_FLAG : \
77 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_DTERR4_FLAG : \
78 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_DTERR5_FLAG : \
79 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_DTERR6_FLAG : \
80 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_DTERR7_FLAG : \
81 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_DTERR1_FLAG : \
82 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_DTERR2_FLAG : \
83 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_DTERR3_FLAG : \
84 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_DTERR4_FLAG : \
85 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_DTERR5_FLAG : \
86 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_DTERR6_FLAG : \
87 DMA2_DTERR7_FLAG)
88
92#define I2C_START 0
93#define I2C_END 1
94
100__WEAK void i2c_lowlevel_init(i2c_handle_type* hi2c)
101{
102
103}
104
110void i2c_config(i2c_handle_type* hi2c)
111{
112 /* reset i2c peripheral */
113 i2c_reset(hi2c->i2cx);
114
115 /* i2c peripheral initialization */
116 i2c_lowlevel_init(hi2c);
117
118 /* i2c peripheral enable */
119 i2c_enable(hi2c->i2cx, TRUE);
120}
121
128 i2c_status_type i2c_wait_end(i2c_handle_type* hi2c, uint32_t timeout)
129{
130 while(hi2c->status != I2C_END)
131 {
132 /* check timeout */
133 if((timeout--) == 0)
134 {
135 return I2C_ERR_TIMEOUT;
136 }
137 }
138
139 if(hi2c->error_code != I2C_OK)
140 {
141 return hi2c->error_code;
142 }
143 else
144 {
145 return I2C_OK;
146 }
147}
148
184 i2c_status_type i2c_wait_flag(i2c_handle_type* hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
185{
186 if(flag == I2C_BUSYF_FLAG)
187 {
188 while(i2c_flag_get(hi2c->i2cx, flag) != RESET)
189 {
190 /* check timeout */
191 if((timeout--) == 0)
192 {
193 hi2c->error_code = I2C_ERR_TIMEOUT;
194
195 return I2C_ERR_TIMEOUT;
196 }
197 }
198 }
199 else
200 {
201 while(i2c_flag_get(hi2c->i2cx, flag) == RESET)
202 {
203 /* check the ack fail flag */
204 if(event_check & I2C_EVENT_CHECK_ACKFAIL)
205 {
206 if(i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
207 {
208 /* generate stop condtion */
209 i2c_stop_generate(hi2c->i2cx);
210
211 /* clear ack fail flag */
212 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
213
214 hi2c->error_code = I2C_ERR_ACKFAIL;
215
216 return I2C_ERR_ACKFAIL;
217 }
218 }
219
220 /* check the stop flag */
221 if(event_check & I2C_EVENT_CHECK_STOP)
222 {
223 if(i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
224 {
225 /* clear stop flag */
226 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
227
228 hi2c->error_code = I2C_ERR_STOP;
229
230 return I2C_ERR_STOP;
231 }
232 }
233
234 /* check timeout */
235 if((timeout--) == 0)
236 {
237 hi2c->error_code = I2C_ERR_TIMEOUT;
238
239 return I2C_ERR_TIMEOUT;
240 }
241 }
242 }
243
244 return I2C_OK;
245}
246
255void i2c_dma_config(i2c_handle_type* hi2c, dma_channel_type* dma_channelx, uint8_t* pdata, uint16_t size)
256{
257 /* disable the dma channel */
258 dma_channel_enable(dma_channelx, FALSE);
259
260 /* disable the transfer complete interrupt */
261 dma_interrupt_enable(dma_channelx, DMA_FDT_INT , FALSE);
262
263 /* configure buffer address and buffer size */
264 hi2c->dma_init_struct.memory_base_addr = (uint32_t)pdata;
265 hi2c->dma_init_struct.direction = (dma_channelx == hi2c->dma_tx_channel) ? DMA_DIR_MEMORY_TO_PERIPHERAL : DMA_DIR_PERIPHERAL_TO_MEMORY;
266 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->dt;
267 hi2c->dma_init_struct.buffer_size = (uint32_t)size;
268 dma_init(dma_channelx, &hi2c->dma_init_struct);
269
270 /* enable the transfer complete interrupt */
271 dma_interrupt_enable(dma_channelx, DMA_FDT_INT , TRUE);
272
273 /* enable the dma channel */
274 dma_channel_enable(dma_channelx, TRUE);
275}
276
284 i2c_status_type i2c_master_write_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
285{
286 /* generate start condtion */
287 i2c_start_generate(hi2c->i2cx);
288
289 /* wait for the start flag to be set */
290 if(i2c_wait_flag(hi2c, I2C_STARTF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
291 {
292 hi2c->error_code = I2C_ERR_START;
293
294 return I2C_ERR_START;
295 }
296
297 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_7BIT)
298 {
299 /* send slave address */
300 i2c_7bit_address_send(hi2c->i2cx, address, I2C_DIRECTION_TRANSMIT);
301 }
302 else
303 {
304 /* send slave 10-bit address header */
305 i2c_data_send(hi2c->i2cx, (uint8_t)((address & 0x0300) >> 7) | 0xF0);
306
307 /* wait for the addrh flag to be set */
308 if(i2c_wait_flag(hi2c, I2C_ADDRHF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
309 {
310 hi2c->error_code = I2C_ERR_ADDR10;
311
312 return I2C_ERR_ADDR10;
313 }
314
315 /* send slave address */
316 i2c_data_send(hi2c->i2cx, (uint8_t)(address & 0x00FF));
317 }
318
319 /* wait for the addr7 flag to be set */
320 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
321 {
322 hi2c->error_code = I2C_ERR_ADDR;
323
324 return I2C_ERR_ADDR;
325 }
326
327 return I2C_OK;
328}
329
337 i2c_status_type i2c_master_read_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
338{
339 /* enable ack */
340 i2c_ack_enable(hi2c->i2cx, TRUE);
341
342 /* generate start condtion */
343 i2c_start_generate(hi2c->i2cx);
344
345 /* wait for the start flag to be set */
346 if(i2c_wait_flag(hi2c, I2C_STARTF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
347 {
348 hi2c->error_code = I2C_ERR_START;
349
350 return I2C_ERR_START;
351 }
352
353 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_7BIT)
354 {
355 /* send slave address */
356 i2c_7bit_address_send(hi2c->i2cx, address, I2C_DIRECTION_RECEIVE);
357 }
358 else
359 {
360 /* send slave 10-bit address header */
361 i2c_data_send(hi2c->i2cx, (uint8_t)((address & 0x0300) >> 7) | 0xF0);
362
363 /* wait for the addrh flag to be set */
364 if(i2c_wait_flag(hi2c, I2C_ADDRHF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
365 {
366 hi2c->error_code = I2C_ERR_ADDR10;
367
368 return I2C_ERR_ADDR10;
369 }
370
371 /* send slave address */
372 i2c_data_send(hi2c->i2cx, (uint8_t)(address & 0x00FF));
373
374 /* wait for the addr7 flag to be set */
375 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
376 {
377 hi2c->error_code = I2C_ERR_ADDR;
378
379 return I2C_ERR_ADDR;
380 }
381
382 /* clear addr flag */
383 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
384
385 /* generate restart condtion */
386 i2c_start_generate(hi2c->i2cx);
387
388 /* wait for the start flag to be set */
389 if(i2c_wait_flag(hi2c, I2C_STARTF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
390 {
391 hi2c->error_code = I2C_ERR_START;
392
393 return I2C_ERR_START;
394 }
395
396 /* send slave 10-bit address header */
397 i2c_data_send(hi2c->i2cx, (uint8_t)((address & 0x0300) >> 7) | 0xF1);
398 }
399
400 /* wait for the addr7 flag to be set */
401 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
402 {
403 hi2c->error_code = I2C_ERR_ADDR;
404
405 return I2C_ERR_ADDR;
406 }
407
408 return I2C_OK;
409}
410
420 i2c_status_type i2c_master_transmit(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
421{
422 /* initialization parameters */
423 hi2c->pbuff = pdata;
424 hi2c->pcount = size;
425
426 hi2c->error_code = I2C_OK;
427
428 /* wait for the busy flag to be reset */
429 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
430 {
431 return I2C_ERR_STEP_1;
432 }
433
434 /* ack acts on the current byte */
435 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
436
437 /* send slave address */
438 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
439 {
440 /* generate stop condtion */
441 i2c_stop_generate(hi2c->i2cx);
442
443 return I2C_ERR_STEP_2;
444 }
445
446 /* clear addr flag */
447 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
448
449 while(size > 0)
450 {
451 /* wait for the tdbe flag to be set */
452 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
453 {
454 /* generate stop condtion */
455 i2c_stop_generate(hi2c->i2cx);
456
457 return I2C_ERR_STEP_3;
458 }
459
460 /* write data */
461 i2c_data_send(hi2c->i2cx, (*pdata++));
462 size--;
463 }
464
465 /* wait for the tdc flag to be set */
466 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
467 {
468 /* generate stop condtion */
469 i2c_stop_generate(hi2c->i2cx);
470
471 return I2C_ERR_STEP_4;
472 }
473
474 /* generate stop condtion */
475 i2c_stop_generate(hi2c->i2cx);
476
477 return I2C_OK;
478}
479
488 i2c_status_type i2c_slave_receive(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
489{
490 /* initialization parameters */
491 hi2c->pbuff = pdata;
492 hi2c->pcount = size;
493
494 hi2c->error_code = I2C_OK;
495
496 /* wait for the busy flag to be reset */
497 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
498 {
499 return I2C_ERR_STEP_1;
500 }
501
502 /* ack acts on the current byte */
503 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
504
505 /* enable ack */
506 i2c_ack_enable(hi2c->i2cx, TRUE);
507
508 /* wait for the addr7 flag to be set */
509 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
510 {
511 /* disable ack */
512 i2c_ack_enable(hi2c->i2cx, FALSE);
513
514 return I2C_ERR_STEP_2;
515 }
516
517 /* clear addr flag */
518 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
519
520 while(size > 0)
521 {
522 /* wait for the rdbf flag to be set */
523 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_STOP, timeout) != I2C_OK)
524 {
525 /* disable ack */
526 i2c_ack_enable(hi2c->i2cx, FALSE);
527
528 return I2C_ERR_STEP_3;
529 }
530
531 /* read data */
532 (*pdata++) = i2c_data_receive(hi2c->i2cx);
533 size--;
534 }
535
536 /* wait for the stop flag to be set */
537 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
538 {
539 /* disable ack */
540 i2c_ack_enable(hi2c->i2cx, FALSE);
541
542 return I2C_ERR_STEP_4;
543 }
544
545 /* clear stop flag */
546 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
547
548 /* disable ack */
549 i2c_ack_enable(hi2c->i2cx, FALSE);
550
551 return I2C_OK;
552}
553
563 i2c_status_type i2c_master_receive(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
564{
565 /* initialization parameters */
566 hi2c->pbuff = pdata;
567 hi2c->pcount = size;
568
569 hi2c->error_code = I2C_OK;
570
571 /* wait for the busy flag to be reset */
572 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
573 {
574 return I2C_ERR_STEP_1;
575 }
576
577 /* ack acts on the current byte */
578 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
579
580 /* enable ack */
581 i2c_ack_enable(hi2c->i2cx, TRUE);
582
583 /* send slave address */
584 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
585 {
586 /* generate stop condtion */
587 i2c_stop_generate(hi2c->i2cx);
588
589 return I2C_ERR_STEP_2;
590 }
591
592 if(size == 1)
593 {
594 /* disable ack */
595 i2c_ack_enable(hi2c->i2cx, FALSE);
596
597 /* clear addr flag */
598 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
599
600 /* generate stop condtion */
601 i2c_stop_generate(hi2c->i2cx);
602 }
603 else if(size == 2)
604 {
605 /* ack acts on the next byte */
606 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
607
608 /* disable ack */
609 i2c_ack_enable(hi2c->i2cx, FALSE);
610
611 /* clear addr flag */
612 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
613 }
614 else
615 {
616 /* enable ack */
617 i2c_ack_enable(hi2c->i2cx, TRUE);
618
619 /* clear addr flag */
620 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
621 }
622
623 while(size > 0)
624 {
625 if(size <= 3)
626 {
627 /* 1 byte */
628 if(size == 1)
629 {
630 /* wait for the rdbf flag to be set */
631 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
632 {
633 /* generate stop condtion */
634 i2c_stop_generate(hi2c->i2cx);
635
636 return I2C_ERR_STEP_3;
637 }
638
639 /* read data */
640 (*pdata++) = i2c_data_receive(hi2c->i2cx);
641 size--;
642 }
643 /* 2 bytes */
644 else if(size == 2)
645 {
646 /* wait for the tdc flag to be set */
647 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
648 {
649 /* generate stop condtion */
650 i2c_stop_generate(hi2c->i2cx);
651
652 return I2C_ERR_STEP_4;
653 }
654
655 /* generate stop condtion */
656 i2c_stop_generate(hi2c->i2cx);
657
658 /* read data */
659 (*pdata++) = i2c_data_receive(hi2c->i2cx);
660 size--;
661
662 /* read data */
663 (*pdata++) = i2c_data_receive(hi2c->i2cx);
664 size--;
665 }
666 /* 3 last bytes */
667 else
668 {
669 /* wait for the tdc flag to be set */
670 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
671 {
672 /* generate stop condtion */
673 i2c_stop_generate(hi2c->i2cx);
674
675 return I2C_ERR_STEP_5;
676 }
677
678 /* disable ack */
679 i2c_ack_enable(hi2c->i2cx, FALSE);
680
681 /* read data */
682 (*pdata++) = i2c_data_receive(hi2c->i2cx);
683 size--;
684
685 /* wait for the tdc flag to be set */
686 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
687 {
688 /* generate stop condtion */
689 i2c_stop_generate(hi2c->i2cx);
690
691 return I2C_ERR_STEP_6;
692 }
693
694 /* generate stop condtion */
695 i2c_stop_generate(hi2c->i2cx);
696
697 /* read data */
698 (*pdata++) = i2c_data_receive(hi2c->i2cx);
699 size--;
700
701 /* read data */
702 (*pdata++) = i2c_data_receive(hi2c->i2cx);
703 size--;
704 }
705 }
706 else
707 {
708 /* wait for the rdbf flag to be set */
709 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
710 {
711 /* generate stop condtion */
712 i2c_stop_generate(hi2c->i2cx);
713
714 return I2C_ERR_STEP_7;
715 }
716
717 /* read data */
718 (*pdata++) = i2c_data_receive(hi2c->i2cx);
719 size--;
720 }
721 }
722
723 return I2C_OK;
724}
725
734 i2c_status_type i2c_slave_transmit(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
735{
736 /* initialization parameters */
737 hi2c->pbuff = pdata;
738 hi2c->pcount = size;
739
740 hi2c->error_code = I2C_OK;
741
742 /* wait for the busy flag to be reset */
743 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
744 {
745 return I2C_ERR_STEP_1;
746 }
747
748 /* ack acts on the current byte */
749 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
750
751 /* enable ack */
752 i2c_ack_enable(hi2c->i2cx, TRUE);
753
754 /* wait for the addr7 flag to be set */
755 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
756 {
757 /* disable ack */
758 i2c_ack_enable(hi2c->i2cx, FALSE);
759
760 return I2C_ERR_STEP_2;
761 }
762
763 /* clear addr flag */
764 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
765
766 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_10BIT)
767 {
768 /* wait for the addr7 flag to be set */
769 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
770 {
771 /* disable ack */
772 i2c_ack_enable(hi2c->i2cx, FALSE);
773
774 return I2C_ERR_STEP_3;
775 }
776
777 /* clear addr flag */
778 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
779 }
780
781 while(size > 0)
782 {
783 /* wait for the tdbe flag to be set */
784 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
785 {
786 /* disable ack */
787 i2c_ack_enable(hi2c->i2cx, FALSE);
788
789 return I2C_ERR_STEP_4;
790 }
791
792 /* write data */
793 i2c_data_send(hi2c->i2cx, *pdata++);
794 size--;
795 }
796
797 /* wait for the ackfail flag to be set */
798 if(i2c_wait_flag(hi2c, I2C_ACKFAIL_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
799 {
800 return I2C_ERR_STEP_5;
801 }
802
803 /* clear ackfail flag */
804 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
805
806 /* disable ack */
807 i2c_ack_enable(hi2c->i2cx, FALSE);
808
809 return I2C_OK;
810}
811
821 i2c_status_type i2c_master_transmit_int(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
822{
823 /* initialization parameters */
824 hi2c->mode = I2C_INT_MA_TX;
825 hi2c->status = I2C_START;
826
827 hi2c->pbuff = pdata;
828 hi2c->pcount = size;
829
830 hi2c->timeout = timeout;
831 hi2c->error_code = I2C_OK;
832
833 /* wait for the busy flag to be reset */
834 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
835 {
836 return I2C_ERR_STEP_1;
837 }
838
839 /* ack acts on the current byte */
840 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
841
842 /* send slave address */
843 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
844 {
845 /* generate stop condtion */
846 i2c_stop_generate(hi2c->i2cx);
847
848 return I2C_ERR_STEP_2;
849 }
850
851 /* clear addr flag */
852 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
853
854 /* enable interrupt */
855 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
856
857 return I2C_OK;
858}
859
868 i2c_status_type i2c_slave_receive_int(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
869{
870 /* initialization parameters */
871 hi2c->mode = I2C_INT_SLA_RX;
872 hi2c->status = I2C_START;
873
874 hi2c->pbuff = pdata;
875 hi2c->pcount = size;
876
877 hi2c->timeout = timeout;
878 hi2c->error_code = I2C_OK;
879
880 /* wait for the busy flag to be reset */
881 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
882 {
883 return I2C_ERR_STEP_1;
884 }
885
886 /* ack acts on the current byte */
887 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
888
889 /* enable ack */
890 i2c_ack_enable(hi2c->i2cx, TRUE);
891
892 /* enable interrupt */
893 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
894
895 return I2C_OK;
896}
897
907 i2c_status_type i2c_master_receive_int(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
908{
909 /* initialization parameters */
910 hi2c->mode = I2C_INT_MA_RX;
911 hi2c->status = I2C_START;
912
913 hi2c->pbuff = pdata;
914 hi2c->pcount = size;
915
916 hi2c->timeout = timeout;
917 hi2c->error_code = I2C_OK;
918
919 /* wait for the busy flag to be reset */
920 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
921 {
922 return I2C_ERR_STEP_1;
923 }
924
925 /* ack acts on the current byte */
926 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
927
928 /* enable ack */
929 i2c_ack_enable(hi2c->i2cx, TRUE);
930
931 /* send slave address */
932 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
933 {
934 /* generate stop condtion */
935 i2c_stop_generate(hi2c->i2cx);
936
937 return I2C_ERR_STEP_2;
938 }
939
940 if(hi2c->pcount == 1)
941 {
942 /* disable ack */
943 i2c_ack_enable(hi2c->i2cx, FALSE);
944
945 /* clear addr flag */
946 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
947
948 /* generate stop condtion */
949 i2c_stop_generate(hi2c->i2cx);
950 }
951 else if(hi2c->pcount == 2)
952 {
953 /* ack acts on the next byte */
954 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
955
956 /* clear addr flag */
957 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
958
959 /* disable ack */
960 i2c_ack_enable(hi2c->i2cx, FALSE);
961 }
962 else
963 {
964 /* enable ack */
965 i2c_ack_enable(hi2c->i2cx, TRUE);
966
967 /* clear addr flag */
968 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
969 }
970
971 /* enable interrupt */
972 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
973
974 return I2C_OK;
975}
976
985 i2c_status_type i2c_slave_transmit_int(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
986{
987 /* initialization parameters */
988 hi2c->mode = I2C_INT_SLA_TX;
989 hi2c->status = I2C_START;
990
991 hi2c->pbuff = pdata;
992 hi2c->pcount = size;
993
994 hi2c->timeout = timeout;
995 hi2c->error_code = I2C_OK;
996
997 /* wait for the busy flag to be reset */
998 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
999 {
1000 return I2C_ERR_STEP_1;
1001 }
1002
1003 /* ack acts on the current byte */
1004 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1005
1006 /* enable ack */
1007 i2c_ack_enable(hi2c->i2cx, TRUE);
1008
1009 /* enable interrupt */
1010 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
1011
1012 return I2C_OK;
1013}
1014
1024 i2c_status_type i2c_master_transmit_dma(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1025{
1026 /* initialization parameters */
1027 hi2c->mode = I2C_DMA_MA_TX;
1028 hi2c->status = I2C_START;
1029
1030 hi2c->pbuff = pdata;
1031 hi2c->pcount = size;
1032
1033 hi2c->timeout = timeout;
1034 hi2c->error_code = I2C_OK;
1035
1036 /* wait for the busy flag to be reset */
1037 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1038 {
1039 return I2C_ERR_STEP_1;
1040 }
1041
1042 /* ack acts on the current byte */
1043 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1044
1045 /* disable dma request */
1046 i2c_dma_enable(hi2c->i2cx, FALSE);
1047
1048 /* configure the dma channel */
1049 i2c_dma_config(hi2c, hi2c->dma_tx_channel, pdata, size);
1050
1051 /* send slave address */
1052 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1053 {
1054 /* generate stop condtion */
1055 i2c_stop_generate(hi2c->i2cx);
1056
1057 return I2C_ERR_STEP_2;
1058 }
1059
1060 /* clear addr flag */
1061 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1062
1063 /* enable dma request */
1064 i2c_dma_enable(hi2c->i2cx, TRUE);
1065
1066 return I2C_OK;
1067}
1068
1077 i2c_status_type i2c_slave_receive_dma(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
1078{
1079 /* initialization parameters */
1080 hi2c->mode = I2C_DMA_SLA_RX;
1081 hi2c->status = I2C_START;
1082
1083 hi2c->pbuff = pdata;
1084 hi2c->pcount = size;
1085
1086 hi2c->timeout = timeout;
1087 hi2c->error_code = I2C_OK;
1088
1089 /* wait for the busy flag to be reset */
1090 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1091 {
1092 return I2C_ERR_STEP_1;
1093 }
1094
1095 /* ack acts on the current byte */
1096 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1097
1098 /* enable ack */
1099 i2c_ack_enable(hi2c->i2cx, TRUE);
1100
1101 /* disable dma request */
1102 i2c_dma_enable(hi2c->i2cx, FALSE);
1103
1104 /* configure the dma channel */
1105 i2c_dma_config(hi2c, hi2c->dma_rx_channel, pdata, size);
1106
1107 /* enable dma request */
1108 i2c_dma_enable(hi2c->i2cx, TRUE);
1109
1110 /* enable address interrupt */
1111 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT, TRUE);
1112
1113 return I2C_OK;
1114}
1115
1125 i2c_status_type i2c_master_receive_dma(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1126{
1127 /* initialization parameters */
1128 hi2c->mode = I2C_DMA_MA_RX;
1129 hi2c->status = I2C_START;
1130
1131 hi2c->pbuff = pdata;
1132 hi2c->pcount = size;
1133
1134 hi2c->timeout = timeout;
1135 hi2c->error_code = I2C_OK;
1136
1137 /* wait for the busy flag to be reset */
1138 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1139 {
1140 return I2C_ERR_STEP_1;
1141 }
1142
1143 /* ack acts on the current byte */
1144 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1145
1146 /* enable ack */
1147 i2c_ack_enable(hi2c->i2cx, TRUE);
1148
1149 /* disable dma request */
1150 i2c_dma_enable(hi2c->i2cx, FALSE);
1151
1152 /* configure the dma channel */
1153 i2c_dma_config(hi2c, hi2c->dma_rx_channel, pdata, size);
1154
1155 /* send slave address */
1156 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1157 {
1158 /* generate stop condtion */
1159 i2c_stop_generate(hi2c->i2cx);
1160
1161 return I2C_ERR_STEP_2;
1162 }
1163
1164 if(size == 1)
1165 {
1166 /* clear addr flag */
1167 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1168
1169 /* disable ack */
1170 i2c_ack_enable(hi2c->i2cx, FALSE);
1171
1172 /* generate stop condtion */
1173 i2c_stop_generate(hi2c->i2cx);
1174
1175 /* enable dma request */
1176 i2c_dma_enable(hi2c->i2cx, TRUE);
1177 }
1178 else
1179 {
1180 /* enable dma end transfer */
1181 i2c_dma_end_transfer_set(hi2c->i2cx, TRUE);
1182
1183 /* enable dma request */
1184 i2c_dma_enable(hi2c->i2cx, TRUE);
1185
1186 /* clear addr flag */
1187 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1188 }
1189
1190 return I2C_OK;
1191}
1192
1201 i2c_status_type i2c_slave_transmit_dma(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
1202{
1203 /* initialization parameters */
1204 hi2c->mode = I2C_DMA_SLA_TX;
1205 hi2c->status = I2C_START;
1206
1207 hi2c->pbuff = pdata;
1208 hi2c->pcount = size;
1209
1210 hi2c->timeout = timeout;
1211 hi2c->error_code = I2C_OK;
1212
1213 /* wait for the busy flag to be reset */
1214 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1215 {
1216 return I2C_ERR_STEP_1;
1217 }
1218
1219 /* ack acts on the current byte */
1220 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1221
1222 /* enable ack */
1223 i2c_ack_enable(hi2c->i2cx, TRUE);
1224
1225 /* disable dma request */
1226 i2c_dma_enable(hi2c->i2cx, FALSE);
1227
1228 /* configure the dma channel */
1229 i2c_dma_config(hi2c, hi2c->dma_tx_channel, pdata, size);
1230
1231 /* enable dma request */
1232 i2c_dma_enable(hi2c->i2cx, TRUE);
1233
1234 /* enable address interrupt */
1235 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT, TRUE);
1236
1237 return I2C_OK;
1238}
1239
1252 i2c_status_type i2c_memory_address_send(i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t mem_address, int32_t timeout)
1253{
1254 i2c_status_type err_code;
1255
1256 if(mem_address_width == I2C_MEM_ADDR_WIDIH_8)
1257 {
1258 /* send memory address */
1259 i2c_data_send(hi2c->i2cx, mem_address & 0xFF);
1260 }
1261 else
1262 {
1263 /* send memory address */
1264 i2c_data_send(hi2c->i2cx, (mem_address >> 8) & 0xFF);
1265
1266 /* wait for the tdbe flag to be set */
1267 err_code = i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout);
1268
1269 if(err_code != I2C_OK)
1270 {
1271 /* generate stop condtion */
1272 i2c_stop_generate(hi2c->i2cx);
1273
1274 return err_code;
1275 }
1276
1277 /* send memory address */
1278 i2c_data_send(hi2c->i2cx, mem_address & 0xFF);
1279 }
1280
1281 return I2C_OK;
1282}
1283
1298 i2c_status_type i2c_memory_write(i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1299{
1300 /* initialization parameters */
1301 hi2c->pbuff = pdata;
1302 hi2c->pcount = size;
1303
1304 hi2c->error_code = I2C_OK;
1305
1306 /* wait for the busy flag to be reset */
1307 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1308 {
1309 return I2C_ERR_STEP_1;
1310 }
1311
1312 /* ack acts on the current byte */
1313 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1314
1315 /* send slave address */
1316 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1317 {
1318 /* generate stop condtion */
1319 i2c_stop_generate(hi2c->i2cx);
1320
1321 return I2C_ERR_STEP_2;
1322 }
1323
1324 /* clear addr flag */
1325 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1326
1327 /* wait for the tdbe flag to be set */
1328 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1329 {
1330 /* generate stop condtion */
1331 i2c_stop_generate(hi2c->i2cx);
1332
1333 return I2C_ERR_STEP_3;
1334 }
1335
1336 /* send memory address */
1337 if(i2c_memory_address_send(hi2c, mem_address_width, mem_address, timeout) != I2C_OK)
1338 {
1339 return I2C_ERR_STEP_4;
1340 }
1341
1342 while(size > 0)
1343 {
1344 /* wait for the tdbe flag to be set */
1345 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1346 {
1347 /* generate stop condtion */
1348 i2c_stop_generate(hi2c->i2cx);
1349
1350 return I2C_ERR_STEP_5;
1351 }
1352
1353 /* write data */
1354 i2c_data_send(hi2c->i2cx, (*pdata++));
1355 size--;
1356 }
1357
1358 /* wait for the tdc flag to be set */
1359 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1360 {
1361 /* generate stop condtion */
1362 i2c_stop_generate(hi2c->i2cx);
1363
1364 return I2C_ERR_STEP_6;
1365 }
1366
1367 /* generate stop condtion */
1368 i2c_stop_generate(hi2c->i2cx);
1369
1370 return I2C_OK;
1371}
1372
1387 i2c_status_type i2c_memory_read(i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1388{
1389 /* initialization parameters */
1390 hi2c->pbuff = pdata;
1391 hi2c->pcount = size;
1392
1393 hi2c->error_code = I2C_OK;
1394
1395 /* wait for the busy flag to be reset */
1396 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1397 {
1398 return I2C_ERR_STEP_1;
1399 }
1400
1401 /* ack acts on the current byte */
1402 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1403
1404 /* enable ack */
1405 i2c_ack_enable(hi2c->i2cx, TRUE);
1406
1407 /* send slave address */
1408 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1409 {
1410 /* generate stop condtion */
1411 i2c_stop_generate(hi2c->i2cx);
1412
1413 return I2C_ERR_STEP_2;
1414 }
1415
1416 /* clear addr flag */
1417 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1418
1419 /* wait for the tdbe flag to be set */
1420 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1421 {
1422 /* generate stop condtion */
1423 i2c_stop_generate(hi2c->i2cx);
1424
1425 return I2C_ERR_STEP_3;
1426 }
1427
1428 /* send memory address */
1429 if(i2c_memory_address_send(hi2c, mem_address_width, mem_address, timeout) != I2C_OK)
1430 {
1431 return I2C_ERR_STEP_4;
1432 }
1433
1434 /* wait for the tdbe flag to be set */
1435 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1436 {
1437 /* generate stop condtion */
1438 i2c_stop_generate(hi2c->i2cx);
1439
1440 return I2C_ERR_STEP_5;
1441 }
1442
1443 /* send slave address */
1444 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1445 {
1446 /* generate stop condtion */
1447 i2c_stop_generate(hi2c->i2cx);
1448
1449 return I2C_ERR_STEP_6;
1450 }
1451
1452 if(size == 1)
1453 {
1454 /* disable ack */
1455 i2c_ack_enable(hi2c->i2cx, FALSE);
1456
1457 /* clear addr flag */
1458 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1459
1460 /* generate stop condtion */
1461 i2c_stop_generate(hi2c->i2cx);
1462 }
1463 else if(size == 2)
1464 {
1465 /* ack acts on the next byte */
1466 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
1467
1468 /* clear addr flag */
1469 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1470
1471 /* disable ack */
1472 i2c_ack_enable(hi2c->i2cx, FALSE);
1473 }
1474 else
1475 {
1476 /* enable ack */
1477 i2c_ack_enable(hi2c->i2cx, TRUE);
1478
1479 /* clear addr flag */
1480 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1481 }
1482
1483 while(size > 0)
1484 {
1485 if(size <= 3)
1486 {
1487 /* 1 byte */
1488 if(size == 1)
1489 {
1490 /* wait for the rdbf flag to be set */
1491 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1492 {
1493 /* generate stop condtion */
1494 i2c_stop_generate(hi2c->i2cx);
1495
1496 return I2C_ERR_STEP_7;
1497 }
1498
1499 /* read data */
1500 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1501 size--;
1502 }
1503 /* 2 bytes */
1504 else if(size == 2)
1505 {
1506 /* wait for the tdc flag to be set */
1507 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1508 {
1509 /* generate stop condtion */
1510 i2c_stop_generate(hi2c->i2cx);
1511
1512 return I2C_ERR_STEP_8;
1513 }
1514
1515 /* generate stop condtion */
1516 i2c_stop_generate(hi2c->i2cx);
1517
1518 /* read data */
1519 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1520 size--;
1521
1522 /* read data */
1523 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1524 size--;
1525 }
1526 /* 3 last bytes */
1527 else
1528 {
1529 /* wait for the tdc flag to be set */
1530 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1531 {
1532 /* generate stop condtion */
1533 i2c_stop_generate(hi2c->i2cx);
1534
1535 return I2C_ERR_STEP_9;
1536 }
1537
1538 /* disable ack */
1539 i2c_ack_enable(hi2c->i2cx, FALSE);
1540
1541 /* read data */
1542 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1543 size--;
1544
1545 /* wait for the tdc flag to be set */
1546 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1547 {
1548 /* generate stop condtion */
1549 i2c_stop_generate(hi2c->i2cx);
1550
1551 return I2C_ERR_STEP_10;
1552 }
1553
1554 /* generate stop condtion */
1555 i2c_stop_generate(hi2c->i2cx);
1556
1557 /* read data */
1558 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1559 size--;
1560
1561 /* read data */
1562 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1563 size--;
1564 }
1565 }
1566 else
1567 {
1568 /* wait for the rdbf flag to be set */
1569 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1570 {
1571 /* generate stop condtion */
1572 i2c_stop_generate(hi2c->i2cx);
1573
1574 return I2C_ERR_STEP_11;
1575 }
1576
1577 /* read data */
1578 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1579 size--;
1580 }
1581 }
1582
1583 return I2C_OK;
1584}
1585
1600 i2c_status_type i2c_memory_write_int(i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1601{
1602 /* initialization parameters */
1603 hi2c->mode = I2C_INT_MA_TX;
1604 hi2c->status = I2C_START;
1605
1606 hi2c->pbuff = pdata;
1607 hi2c->pcount = size;
1608
1609 hi2c->timeout = timeout;
1610 hi2c->error_code = I2C_OK;
1611
1612 /* wait for the busy flag to be reset */
1613 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1614 {
1615 return I2C_ERR_STEP_1;
1616 }
1617
1618 /* ack acts on the current byte */
1619 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1620
1621 /* send slave address */
1622 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1623 {
1624 /* generate stop condtion */
1625 i2c_stop_generate(hi2c->i2cx);
1626
1627 return I2C_ERR_STEP_2;
1628 }
1629
1630 /* clear addr flag */
1631 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1632
1633 /* wait for the tdbe flag to be set */
1634 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1635 {
1636 /* generate stop condtion */
1637 i2c_stop_generate(hi2c->i2cx);
1638
1639 return I2C_ERR_STEP_3;
1640 }
1641
1642 /* send memory address */
1643 if(i2c_memory_address_send(hi2c, mem_address_width, mem_address, timeout) != I2C_OK)
1644 {
1645 return I2C_ERR_STEP_4;
1646 }
1647
1648 /* wait for the tdbe flag to be set */
1649 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1650 {
1651 /* generate stop condtion */
1652 i2c_stop_generate(hi2c->i2cx);
1653
1654 return I2C_ERR_STEP_5;
1655 }
1656
1657 /* enable interrupt */
1658 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
1659
1660 return I2C_OK;
1661}
1662
1677 i2c_status_type i2c_memory_read_int(i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1678{
1679 /* initialization parameters */
1680 hi2c->mode = I2C_INT_MA_RX;
1681 hi2c->status = I2C_START;
1682
1683 hi2c->pbuff = pdata;
1684 hi2c->pcount = size;
1685
1686 hi2c->timeout = timeout;
1687 hi2c->error_code = I2C_OK;
1688
1689 /* wait for the busy flag to be reset */
1690 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1691 {
1692 return I2C_ERR_STEP_1;
1693 }
1694
1695 /* ack acts on the current byte */
1696 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1697
1698 /* send slave address */
1699 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1700 {
1701 /* generate stop condtion */
1702 i2c_stop_generate(hi2c->i2cx);
1703
1704 return I2C_ERR_STEP_2;
1705 }
1706
1707 /* clear addr flag */
1708 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1709
1710 /* wait for the tdbe flag to be set */
1711 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1712 {
1713 /* generate stop condtion */
1714 i2c_stop_generate(hi2c->i2cx);
1715
1716 return I2C_ERR_STEP_3;
1717 }
1718
1719 /* send memory address */
1720 if(i2c_memory_address_send(hi2c, mem_address_width, mem_address, timeout) != I2C_OK)
1721 {
1722 return I2C_ERR_STEP_4;
1723 }
1724
1725 /* wait for the tdbe flag to be set */
1726 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1727 {
1728 /* generate stop condtion */
1729 i2c_stop_generate(hi2c->i2cx);
1730
1731 return I2C_ERR_STEP_5;
1732 }
1733
1734 /* send slave address */
1735 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1736 {
1737 /* generate stop condtion */
1738 i2c_stop_generate(hi2c->i2cx);
1739
1740 return I2C_ERR_STEP_6;
1741 }
1742
1743 if(hi2c->pcount == 1)
1744 {
1745 /* disable ack */
1746 i2c_ack_enable(hi2c->i2cx, FALSE);
1747
1748 /* clear addr flag */
1749 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1750
1751 /* generate stop condtion */
1752 i2c_stop_generate(hi2c->i2cx);
1753 }
1754 else if(hi2c->pcount == 2)
1755 {
1756 /* ack acts on the next byte */
1757 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
1758
1759 /* clear addr flag */
1760 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1761
1762 /* disable ack */
1763 i2c_ack_enable(hi2c->i2cx, FALSE);
1764 }
1765 else
1766 {
1767 /* enable ack */
1768 i2c_ack_enable(hi2c->i2cx, TRUE);
1769
1770 /* clear addr flag */
1771 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1772 }
1773
1774 /* enable interrupt */
1775 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
1776
1777 return I2C_OK;
1778}
1779
1794 i2c_status_type i2c_memory_write_dma(i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1795{
1796 /* initialization parameters */
1797 hi2c->mode = I2C_DMA_MA_TX;
1798 hi2c->status = I2C_START;
1799
1800 hi2c->pbuff = pdata;
1801 hi2c->pcount = size;
1802
1803 hi2c->timeout = timeout;
1804 hi2c->error_code = I2C_OK;
1805
1806 /* wait for the busy flag to be reset */
1807 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1808 {
1809 return I2C_ERR_STEP_1;
1810 }
1811
1812 /* ack acts on the current byte */
1813 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1814
1815 /* disable dma request */
1816 i2c_dma_enable(hi2c->i2cx, FALSE);
1817
1818 /* configure the dma channel */
1819 i2c_dma_config(hi2c, hi2c->dma_tx_channel, pdata, size);
1820
1821 /* send slave address */
1822 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1823 {
1824 /* generate stop condtion */
1825 i2c_stop_generate(hi2c->i2cx);
1826
1827 return I2C_ERR_STEP_2;
1828 }
1829
1830 /* clear addr flag */
1831 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1832
1833 /* wait for the tdbe flag to be set */
1834 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1835 {
1836 /* generate stop condtion */
1837 i2c_stop_generate(hi2c->i2cx);
1838
1839 return I2C_ERR_STEP_3;
1840 }
1841
1842 /* send memory address */
1843 if(i2c_memory_address_send(hi2c, mem_address_width, mem_address, timeout) != I2C_OK)
1844 {
1845 return I2C_ERR_STEP_4;
1846 }
1847
1848 /* wait for the tdbe flag to be set */
1849 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1850 {
1851 /* generate stop condtion */
1852 i2c_stop_generate(hi2c->i2cx);
1853
1854 return I2C_ERR_STEP_5;
1855 }
1856
1857 /* enable dma request */
1858 i2c_dma_enable(hi2c->i2cx, TRUE);
1859
1860 return I2C_OK;
1861}
1862
1877 i2c_status_type i2c_memory_read_dma(i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1878{
1879 /* initialization parameters */
1880 hi2c->mode = I2C_DMA_MA_RX;
1881 hi2c->status = I2C_START;
1882
1883 hi2c->pbuff = pdata;
1884 hi2c->pcount = size;
1885
1886 hi2c->timeout = timeout;
1887 hi2c->error_code = I2C_OK;
1888
1889 /* wait for the busy flag to be reset */
1890 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1891 {
1892 return I2C_ERR_STEP_1;
1893 }
1894
1895 /* ack acts on the current byte */
1896 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1897
1898 /* enable ack */
1899 i2c_ack_enable(hi2c->i2cx, TRUE);
1900
1901 /* disable dma request */
1902 i2c_dma_enable(hi2c->i2cx, FALSE);
1903
1904 /* configure the dma channel */
1905 i2c_dma_config(hi2c, hi2c->dma_rx_channel, pdata, size);
1906
1907 /* send slave address */
1908 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1909 {
1910 /* generate stop condtion */
1911 i2c_stop_generate(hi2c->i2cx);
1912
1913 return I2C_ERR_STEP_2;
1914 }
1915
1916 /* clear addr flag */
1917 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1918
1919 /* wait for the tdbe flag to be set */
1920 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1921 {
1922 /* generate stop condtion */
1923 i2c_stop_generate(hi2c->i2cx);
1924
1925 return I2C_ERR_STEP_3;
1926 }
1927
1928 /* send memory address */
1929 if(i2c_memory_address_send(hi2c, mem_address_width, mem_address, timeout) != I2C_OK)
1930 {
1931 return I2C_ERR_STEP_4;
1932 }
1933
1934 /* wait for the tdbe flag to be set */
1935 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1936 {
1937 /* generate stop condtion */
1938 i2c_stop_generate(hi2c->i2cx);
1939
1940 return I2C_ERR_STEP_5;
1941 }
1942
1943 /* send slave address */
1944 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1945 {
1946 /* generate stop condtion */
1947 i2c_stop_generate(hi2c->i2cx);
1948
1949 return I2C_ERR_STEP_6;
1950 }
1951
1952 if(size == 1)
1953 {
1954 /* clear addr flag */
1955 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1956
1957 /* disable ack */
1958 i2c_ack_enable(hi2c->i2cx, FALSE);
1959
1960 /* generate stop condtion */
1961 i2c_stop_generate(hi2c->i2cx);
1962
1963 /* enable dma request */
1964 i2c_dma_enable(hi2c->i2cx, TRUE);
1965 }
1966 else
1967 {
1968 /* enable dma end transfer */
1969 i2c_dma_end_transfer_set(hi2c->i2cx, TRUE);
1970
1971 /* enable dma request */
1972 i2c_dma_enable(hi2c->i2cx, TRUE);
1973
1974 /* clear addr flag */
1975 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
1976 }
1977
1978 return I2C_OK;
1979}
1980
1986void i2c_master_tx_isr_int(i2c_handle_type* hi2c)
1987{
1988 /* step 1: transfer data */
1989 if(i2c_flag_get(hi2c->i2cx, I2C_TDBE_FLAG) != RESET)
1990 {
1991 if(hi2c->pcount == 0)
1992 {
1993 /* transfer complete */
1994 hi2c->status = I2C_END;
1995
1996 /* disable interrupt */
1997 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
1998
1999 /* generate stop condtion */
2000 i2c_stop_generate(hi2c->i2cx);
2001 }
2002 else
2003 {
2004 /* write data */
2005 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
2006 hi2c->pcount--;
2007 }
2008 }
2009}
2010
2016void i2c_master_rx_isr_int(i2c_handle_type* hi2c)
2017{
2018 if(i2c_flag_get(hi2c->i2cx, I2C_TDC_FLAG) != RESET)
2019 {
2020 if(hi2c->pcount == 3)
2021 {
2022 /* disable ack */
2023 i2c_ack_enable(hi2c->i2cx, FALSE);
2024
2025 /* read data */
2026 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2027 hi2c->pcount--;
2028 }
2029 else if(hi2c->pcount == 2)
2030 {
2031 /* generate stop condtion */
2032 i2c_stop_generate(hi2c->i2cx);
2033
2034 /* read data */
2035 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2036 hi2c->pcount--;
2037
2038 /* read data */
2039 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2040 hi2c->pcount--;
2041
2042 /* transfer complete */
2043 hi2c->status = I2C_END;
2044
2045 /* disable interrupt */
2046 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
2047 }
2048 else
2049 {
2050 /* read data */
2051 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2052 hi2c->pcount--;
2053 }
2054 }
2055
2056 else if(i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
2057 {
2058 if(hi2c->pcount > 3)
2059 {
2060 /* read data */
2061 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2062 hi2c->pcount--;
2063 }
2064 else if((hi2c->pcount == 3) || (hi2c->pcount == 2))
2065 {
2066 /* disable rdbf interrupt */
2067 i2c_interrupt_enable(hi2c->i2cx, I2C_DATA_INT, FALSE);
2068 }
2069 else
2070 {
2071 /* read data */
2072 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2073 hi2c->pcount--;
2074
2075 /* transfer complete */
2076 hi2c->status = I2C_END;
2077
2078 /* disable interrupt */
2079 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
2080 }
2081 }
2082}
2083
2089void i2c_slave_tx_isr_int(i2c_handle_type* hi2c)
2090{
2091 /* step 1: receive slave address */
2092 if(i2c_flag_get(hi2c->i2cx, I2C_ADDR7F_FLAG) != RESET)
2093 {
2094 /* clear addr flag */
2095 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
2096 }
2097
2098 /* step 2: transfer data */
2099 else if(i2c_flag_get(hi2c->i2cx, I2C_TDBE_FLAG) != RESET)
2100 {
2101 if(hi2c->pcount)
2102 {
2103 /* send data */
2104 i2c_data_send(hi2c->i2cx, (*hi2c->pbuff++));
2105 hi2c->pcount--;
2106
2107 if(hi2c->pcount == 0)
2108 {
2109 /* disable interrupt */
2110 i2c_interrupt_enable(hi2c->i2cx, I2C_DATA_INT | I2C_EVT_INT | I2C_ERR_INT, FALSE);
2111
2112 /* wait for the ackfail flag to be set */
2113 hi2c->status = i2c_wait_flag(hi2c, I2C_ACKFAIL_FLAG, I2C_EVENT_CHECK_NONE, hi2c->timeout);
2114
2115 /* clear ackfail flag */
2116 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2117
2118 /* transfer complete */
2119 hi2c->status = I2C_END;
2120 }
2121 }
2122 }
2123}
2124
2130void i2c_slave_rx_isr_int(i2c_handle_type* hi2c)
2131{
2132 /* step 1: receive slave address */
2133 if(i2c_flag_get(hi2c->i2cx, I2C_ADDR7F_FLAG) != RESET)
2134 {
2135 /* clear addr flag */
2136 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
2137 }
2138
2139 /* step 2: receive data */
2140 else if(i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
2141 {
2142 if(hi2c->pcount)
2143 {
2144 /* read data */
2145 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2146
2147 hi2c->pcount--;
2148 }
2149 }
2150
2151 /* step 3: stop conditon is received, transfer ends */
2152 else if(i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
2153 {
2154 /* clear stop flag */
2155 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
2156
2157 /* transfer complete */
2158 hi2c->status = I2C_END;
2159
2160 /* disable interrupt */
2161 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
2162 }
2163}
2164
2170void i2c_master_tx_isr_dma(i2c_handle_type* hi2c)
2171{
2172 /* tdc interrupt */
2173 if(i2c_flag_get(hi2c->i2cx, I2C_TDC_FLAG) != RESET)
2174 {
2175 /* generate stop condtion */
2176 i2c_stop_generate(hi2c->i2cx);
2177
2178 /* disable evt interrupt */
2179 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT, FALSE);
2180
2181 /* transfer complete */
2182 hi2c->status = I2C_END;
2183 }
2184}
2185
2191void i2c_slave_tx_rx_isr_dma(i2c_handle_type* hi2c)
2192{
2193 /* receive slave address */
2194 if(i2c_flag_get(hi2c->i2cx, I2C_ADDR7F_FLAG) != RESET)
2195 {
2196 /* clear addr flag */
2197 i2c_flag_clear(hi2c->i2cx, I2C_ADDR7F_FLAG);
2198 }
2199
2200 /* wait for the stop flag to be set, trasnfer end */
2201 if(i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
2202 {
2203 /* clear stop flag */
2204 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
2205
2206 /* disable evt interrupt */
2207 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT, FALSE);
2208
2209 /* disable ack */
2210 i2c_ack_enable(hi2c->i2cx, TRUE);
2211
2212 /* transfer complete */
2213 hi2c->status = I2C_END;
2214 }
2215}
2216
2222void i2c_evt_irq_handler(i2c_handle_type* hi2c)
2223{
2224 switch(hi2c->mode)
2225 {
2226 case I2C_INT_MA_TX:
2227 i2c_master_tx_isr_int(hi2c);
2228 break;
2229 case I2C_INT_MA_RX:
2230 i2c_master_rx_isr_int(hi2c);
2231 break;
2232 case I2C_INT_SLA_TX:
2233 i2c_slave_tx_isr_int(hi2c);
2234 break;
2235 case I2C_INT_SLA_RX:
2236 i2c_slave_rx_isr_int(hi2c);
2237 break;
2238 case I2C_DMA_MA_TX:
2239 i2c_master_tx_isr_dma(hi2c);
2240 break;
2241 case I2C_DMA_SLA_TX:
2242 case I2C_DMA_SLA_RX:
2243 i2c_slave_tx_rx_isr_dma(hi2c);
2244 break;
2245 default:
2246 break;
2247 }
2248}
2249
2255void i2c_dma_tx_irq_handler(i2c_handle_type* hi2c)
2256{
2257 /* transfer complete */
2258 if(dma_flag_get(DMA_GET_TC_FLAG(hi2c->dma_tx_channel)) != RESET)
2259 {
2260 /* disable the transfer complete interrupt */
2261 dma_interrupt_enable(hi2c->dma_tx_channel, DMA_FDT_INT, FALSE);
2262
2263 /* clear the transfer complete flag */
2264 dma_flag_clear(DMA_GET_TC_FLAG(hi2c->dma_tx_channel));
2265
2266 /* disable dma request */
2267 i2c_dma_enable(hi2c->i2cx, FALSE);
2268
2269 hi2c->pcount = 0;
2270
2271 switch(hi2c->mode)
2272 {
2273 case I2C_DMA_MA_TX:
2274 /* enable tdc interrupt, generate stop condition in tdc interrupt */
2275 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT, TRUE);
2276 break;
2277 case I2C_DMA_SLA_TX:
2278 /* enable ackfail interrupt, generate stop condition in ackfail interrupt */
2279 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT, TRUE);
2280 break;
2281 default:
2282 break;
2283 }
2284 }
2285}
2286
2292void i2c_dma_rx_irq_handler(i2c_handle_type* hi2c)
2293{
2294 /* transfer complete */
2295 if(dma_flag_get(DMA_GET_TC_FLAG(hi2c->dma_rx_channel)) != RESET)
2296 {
2297 /* disable the transfer complete interrupt */
2298 dma_interrupt_enable(hi2c->dma_rx_channel, DMA_FDT_INT, FALSE);
2299
2300 /* clear the transfer complete flag */
2301 dma_flag_clear(DMA_GET_TC_FLAG(hi2c->dma_rx_channel));
2302
2303 /* disable dma request */
2304 i2c_dma_enable(hi2c->i2cx, FALSE);
2305
2306 hi2c->pcount = 0;
2307
2308 switch(hi2c->mode)
2309 {
2310 case I2C_DMA_MA_RX:
2311 /* clear ackfail flag */
2312 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2313
2314 if(hi2c->pcount != 1)
2315 {
2316 /* generate stop condtion */
2317 i2c_stop_generate(hi2c->i2cx);
2318 }
2319
2320 /* transfer complete */
2321 hi2c->status = I2C_END;
2322 break;
2323 case I2C_DMA_SLA_RX:
2324 /* enable stop interrupt, wait for the stop flag to be set */
2325 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT, TRUE);
2326 break;
2327 default:
2328 break;
2329 }
2330 }
2331}
2332
2338void i2c_err_irq_handler(i2c_handle_type* hi2c)
2339{
2340 /* buserr */
2341 if(i2c_flag_get(hi2c->i2cx, I2C_BUSERR_FLAG) != RESET)
2342 {
2343 i2c_flag_clear(hi2c->i2cx, I2C_BUSERR_FLAG);
2344
2345 hi2c->error_code = I2C_ERR_INTERRUPT;
2346 }
2347
2348 /* arlost */
2349 if(i2c_flag_get(hi2c->i2cx, I2C_ARLOST_FLAG) != RESET)
2350 {
2351 i2c_flag_clear(hi2c->i2cx, I2C_ARLOST_FLAG);
2352
2353 hi2c->error_code = I2C_ERR_INTERRUPT;
2354 }
2355
2356 /* ackfail */
2357 if(i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
2358 {
2359 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2360
2361 switch(hi2c->mode)
2362 {
2363 case I2C_DMA_SLA_TX:
2364 /* disable ack */
2365 i2c_ack_enable(hi2c->i2cx, FALSE);
2366
2367 /* disable evt interrupt */
2368 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT, FALSE);
2369
2370 /* transfer complete */
2371 hi2c->status = I2C_END;
2372 break;
2373 default:
2374 hi2c->error_code = I2C_ERR_INTERRUPT;
2375 break;
2376 }
2377 }
2378
2379 /* ouf */
2380 if(i2c_flag_get(hi2c->i2cx, I2C_OUF_FLAG) != RESET)
2381 {
2382 i2c_flag_clear(hi2c->i2cx, I2C_OUF_FLAG);
2383
2384 hi2c->error_code = I2C_ERR_INTERRUPT;
2385 }
2386
2387 /* pecerr */
2388 if(i2c_flag_get(hi2c->i2cx, I2C_PECERR_FLAG) != RESET)
2389 {
2390 i2c_flag_clear(hi2c->i2cx, I2C_PECERR_FLAG);
2391
2392 hi2c->error_code = I2C_ERR_INTERRUPT;
2393 }
2394
2395 /* tmout */
2396 if(i2c_flag_get(hi2c->i2cx, I2C_TMOUT_FLAG) != RESET)
2397 {
2398 i2c_flag_clear(hi2c->i2cx, I2C_TMOUT_FLAG);
2399
2400 hi2c->error_code = I2C_ERR_INTERRUPT;
2401 }
2402
2403 /* alertf */
2404 if(i2c_flag_get(hi2c->i2cx, I2C_ALERTF_FLAG) != RESET)
2405 {
2406 i2c_flag_clear(hi2c->i2cx, I2C_ALERTF_FLAG);
2407
2408 hi2c->error_code = I2C_ERR_INTERRUPT;
2409 }
2410
2411 /* disable all interrupts */
2412 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT, FALSE);
2413}
2414
i2c_wait_flag
i2c_status_type i2c_wait_flag(i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are wai...
Definition: i2c_application.c:184
i2c_master_rx_isr_int
void i2c_master_rx_isr_int(i2c_handle_type *hi2c)
master receive mode interrupt procession function
Definition: i2c_application.c:2016
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1877
i2c_slave_rx_isr_int
void i2c_slave_rx_isr_int(i2c_handle_type *hi2c)
slave receive mode interrupt procession function
Definition: i2c_application.c:2130
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:128
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1794
i2c_slave_tx_rx_isr_dma
void i2c_slave_tx_rx_isr_dma(i2c_handle_type *hi2c)
slave interrupt processing function in dma mode.
Definition: i2c_application.c:2191
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2222
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1600
i2c_master_tx_isr_int
void i2c_master_tx_isr_int(i2c_handle_type *hi2c)
master transfer mode interrupt procession function
Definition: i2c_application.c:1986
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:985
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2338
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2292
i2c_master_write_addr
i2c_status_type i2c_master_write_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master transmits mode.
Definition: i2c_application.c:284
I2C_START
#define I2C_START
i2c transmission status
Definition: i2c_application.c:92
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:488
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:1201
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:907
i2c_slave_tx_isr_int
void i2c_slave_tx_isr_int(i2c_handle_type *hi2c)
slave transfer mode interrupt procession function
Definition: i2c_application.c:2089
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1298
i2c_master_read_addr
i2c_status_type i2c_master_read_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master receive mode.
Definition: i2c_application.c:337
I2C_END
#define I2C_END
Definition: i2c_application.c:93
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:1024
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_master_tx_isr_dma
void i2c_master_tx_isr_dma(i2c_handle_type *hi2c)
master interrupt processing function in dma mode.
Definition: i2c_application.c:2170
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1387
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1677
i2c_memory_address_send
i2c_status_type i2c_memory_address_send(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t mem_address, int32_t timeout)
send memory address.
Definition: i2c_application.c:1252
DMA_GET_TC_FLAG
#define DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel
Definition: i2c_application.c:35
i2c_dma_config
void i2c_dma_config(i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint8_t *pdata, uint16_t size)
dma transfer cofiguration.
Definition: i2c_application.c:255
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2255
i2c_lowlevel_init
__WEAK void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:100
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:1077
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:821
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:563
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:1125
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:868
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:420
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:734
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f413_i2c.c:533
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f413_i2c.c:49
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge.
Definition: at32f413_i2c.c:281
i2c_7bit_address_send
void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address.
Definition: at32f413_i2c.c:501
i2c_dma_end_transfer_set
void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one.
Definition: at32f413_i2c.c:422
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f413_i2c.c:484
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph
Definition: at32f413_i2c.c:239
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status
Definition: at32f413_i2c.c:568
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt
Definition: at32f413_i2c.c:453
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f413_i2c.c:615
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests.
Definition: at32f413_i2c.c:435
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f413_i2c.c:521
i2c_master_receive_ack_set
void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control.
Definition: at32f413_i2c.c:297
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f413_i2c.c:472
I2C_DIRECTION_RECEIVE
@ I2C_DIRECTION_RECEIVE
Definition: at32f413_i2c.h:165
I2C_DIRECTION_TRANSMIT
@ I2C_DIRECTION_TRANSMIT
Definition: at32f413_i2c.h:164
I2C_MASTER_ACK_CURRENT
@ I2C_MASTER_ACK_CURRENT
Definition: at32f413_i2c.h:108
I2C_MASTER_ACK_NEXT
@ I2C_MASTER_ACK_NEXT
Definition: at32f413_i2c.h:109
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
I2C_ADDRESS_MODE_10BIT
@ I2C_ADDRESS_MODE_10BIT
Definition: at32f413_i2c.h:156
I2C_EVT_INT
#define I2C_EVT_INT
Definition: at32f413_i2c.h:92
I2C_ERR_INT
#define I2C_ERR_INT
Definition: at32f413_i2c.h:93
I2C_DATA_INT
#define I2C_DATA_INT
Definition: at32f413_i2c.h:91
I2C_EVENT_CHECK_STOP
#define I2C_EVENT_CHECK_STOP
Definition: i2c_application.h:47
I2C_EVENT_CHECK_NONE
#define I2C_EVENT_CHECK_NONE
Definition: i2c_application.h:45
I2C_EVENT_CHECK_ACKFAIL
#define I2C_EVENT_CHECK_ACKFAIL
Definition: i2c_application.h:46
i2c_mem_address_width_type
i2c_mem_address_width_type
Definition: i2c_application.h:58
I2C_MEM_ADDR_WIDIH_8
@ I2C_MEM_ADDR_WIDIH_8
Definition: i2c_application.h:59
i2c_status_type
i2c_status_type
Definition: i2c_application.h:93
I2C_ERR_STEP_1
@ I2C_ERR_STEP_1
Definition: i2c_application.h:95
I2C_ERR_TIMEOUT
@ I2C_ERR_TIMEOUT
Definition: i2c_application.h:112
I2C_ERR_ADDR10
@ I2C_ERR_ADDR10
Definition: i2c_application.h:108
I2C_ERR_START
@ I2C_ERR_START
Definition: i2c_application.h:107
I2C_ERR_STEP_11
@ I2C_ERR_STEP_11
Definition: i2c_application.h:105
I2C_ERR_INTERRUPT
@ I2C_ERR_INTERRUPT
Definition: i2c_application.h:113
I2C_ERR_STEP_3
@ I2C_ERR_STEP_3
Definition: i2c_application.h:97
I2C_ERR_STEP_6
@ I2C_ERR_STEP_6
Definition: i2c_application.h:100
I2C_ERR_STEP_5
@ I2C_ERR_STEP_5
Definition: i2c_application.h:99
I2C_ERR_STEP_9
@ I2C_ERR_STEP_9
Definition: i2c_application.h:103
I2C_ERR_STEP_7
@ I2C_ERR_STEP_7
Definition: i2c_application.h:101
I2C_ERR_STOP
@ I2C_ERR_STOP
Definition: i2c_application.h:110
I2C_ERR_STEP_8
@ I2C_ERR_STEP_8
Definition: i2c_application.h:102
I2C_ERR_ACKFAIL
@ I2C_ERR_ACKFAIL
Definition: i2c_application.h:111
I2C_ERR_ADDR
@ I2C_ERR_ADDR
Definition: i2c_application.h:109
I2C_ERR_STEP_2
@ I2C_ERR_STEP_2
Definition: i2c_application.h:96
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
I2C_ERR_STEP_10
@ I2C_ERR_STEP_10
Definition: i2c_application.h:104
I2C_ERR_STEP_4
@ I2C_ERR_STEP_4
Definition: i2c_application.h:98
I2C_DMA_MA_RX
@ I2C_DMA_MA_RX
Definition: i2c_application.h:78
I2C_DMA_SLA_RX
@ I2C_DMA_SLA_RX
Definition: i2c_application.h:80
I2C_INT_SLA_RX
@ I2C_INT_SLA_RX
Definition: i2c_application.h:76
I2C_DMA_MA_TX
@ I2C_DMA_MA_TX
Definition: i2c_application.h:77
I2C_INT_MA_RX
@ I2C_INT_MA_RX
Definition: i2c_application.h:74
I2C_INT_SLA_TX
@ I2C_INT_SLA_TX
Definition: i2c_application.h:75
I2C_INT_MA_TX
@ I2C_INT_MA_TX
Definition: i2c_application.h:73
I2C_DMA_SLA_TX
@ I2C_DMA_SLA_TX
Definition: i2c_application.h:79
I2C_STARTF_FLAG
#define I2C_STARTF_FLAG
Definition: at32f413_i2c.h:50
I2C_TMOUT_FLAG
#define I2C_TMOUT_FLAG
Definition: at32f413_i2c.h:62
I2C_ADDR7F_FLAG
#define I2C_ADDR7F_FLAG
Definition: at32f413_i2c.h:51
I2C_ALERTF_FLAG
#define I2C_ALERTF_FLAG
Definition: at32f413_i2c.h:63
I2C_BUSERR_FLAG
#define I2C_BUSERR_FLAG
Definition: at32f413_i2c.h:57
I2C_ACKFAIL_FLAG
#define I2C_ACKFAIL_FLAG
Definition: at32f413_i2c.h:59
I2C_OUF_FLAG
#define I2C_OUF_FLAG
Definition: at32f413_i2c.h:60
I2C_ARLOST_FLAG
#define I2C_ARLOST_FLAG
Definition: at32f413_i2c.h:58
I2C_STOPF_FLAG
#define I2C_STOPF_FLAG
Definition: at32f413_i2c.h:54
I2C_TDC_FLAG
#define I2C_TDC_FLAG
Definition: at32f413_i2c.h:52
I2C_ADDRHF_FLAG
#define I2C_ADDRHF_FLAG
Definition: at32f413_i2c.h:53
I2C_TDBE_FLAG
#define I2C_TDBE_FLAG
Definition: at32f413_i2c.h:56
I2C_RDBF_FLAG
#define I2C_RDBF_FLAG
Definition: at32f413_i2c.h:55
I2C_PECERR_FLAG
#define I2C_PECERR_FLAG
Definition: at32f413_i2c.h:61
I2C_BUSYF_FLAG
#define I2C_BUSYF_FLAG
Definition: at32f413_i2c.h:75
i2c_application.h
i2c application libray header file
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:410
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:135
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
i2c_handle_type::status
__IO uint32_t status
Definition: i2c_application.h:132
i2c_handle_type::pbuff
uint8_t * pbuff
Definition: i2c_application.h:128
i2c_handle_type::mode
__IO uint32_t mode
Definition: i2c_application.h:130
i2c_handle_type::timeout
__IO uint32_t timeout
Definition: i2c_application.h:131
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:136
i2c_handle_type::error_code
__IO i2c_status_type error_code
Definition: i2c_application.h:133
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:134
i2c_handle_type::pcount
__IO uint16_t pcount
Definition: i2c_application.h:129
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f413_i2c.h:229
i2c_type::oaddr1_bit
struct i2c_type::@511::@527 oaddr1_bit
i2c_type::dt
__IO uint32_t dt
Definition: at32f413_i2c.h:253


AT32F413 Firmwary Library: i2c_application.h Source File

  • middlewares
  • i2c_application_library
i2c_application.h
Go to the documentation of this file.
1
26#ifndef __I2C_APPLICATION_H
27#define __I2C_APPLICATION_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
45#define I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
46#define I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
47#define I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)
57typedef enum
58{
59 I2C_MEM_ADDR_WIDIH_8 = 0x01,
60 I2C_MEM_ADDR_WIDIH_16 = 0x02,
61} i2c_mem_address_width_type;
62
71typedef enum
72{
73 I2C_INT_MA_TX = 0,
74 I2C_INT_MA_RX,
75 I2C_INT_SLA_TX,
76 I2C_INT_SLA_RX,
77 I2C_DMA_MA_TX,
78 I2C_DMA_MA_RX,
79 I2C_DMA_SLA_TX,
80 I2C_DMA_SLA_RX,
81} i2c_mode_type;
82
83
92typedef enum
93{
94 I2C_OK = 0,
95 I2C_ERR_STEP_1,
96 I2C_ERR_STEP_2,
97 I2C_ERR_STEP_3,
98 I2C_ERR_STEP_4,
99 I2C_ERR_STEP_5,
100 I2C_ERR_STEP_6,
101 I2C_ERR_STEP_7,
102 I2C_ERR_STEP_8,
103 I2C_ERR_STEP_9,
104 I2C_ERR_STEP_10,
105 I2C_ERR_STEP_11,
106 I2C_ERR_STEP_12,
107 I2C_ERR_START,
108 I2C_ERR_ADDR10,
109 I2C_ERR_ADDR,
110 I2C_ERR_STOP,
111 I2C_ERR_ACKFAIL,
112 I2C_ERR_TIMEOUT,
113 I2C_ERR_INTERRUPT,
115} i2c_status_type;
116
125typedef struct
126{
127 i2c_type *i2cx;
128 uint8_t *pbuff;
129 __IO uint16_t pcount;
130 __IO uint32_t mode;
131 __IO uint32_t timeout;
132 __IO uint32_t status;
133 __IO i2c_status_type error_code;
134 dma_channel_type *dma_tx_channel;
135 dma_channel_type *dma_rx_channel;
136 dma_init_type dma_init_struct;
137} i2c_handle_type;
138
147void i2c_config (i2c_handle_type* hi2c);
148void i2c_lowlevel_init (i2c_handle_type* hi2c);
149 i2c_status_type i2c_wait_end (i2c_handle_type* hi2c, uint32_t timeout);
150 i2c_status_type i2c_wait_flag (i2c_handle_type* hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout);
151
152 i2c_status_type i2c_master_transmit (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
153 i2c_status_type i2c_master_receive (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
154 i2c_status_type i2c_slave_transmit (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
155 i2c_status_type i2c_slave_receive (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
156
157 i2c_status_type i2c_master_transmit_int (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
158 i2c_status_type i2c_master_receive_int (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
159 i2c_status_type i2c_slave_transmit_int (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
160 i2c_status_type i2c_slave_receive_int (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
161
162 i2c_status_type i2c_master_transmit_dma (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
163 i2c_status_type i2c_master_receive_dma (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
164 i2c_status_type i2c_slave_transmit_dma (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
165 i2c_status_type i2c_slave_receive_dma (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
166
167 i2c_status_type i2c_memory_write (i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
168 i2c_status_type i2c_memory_write_int (i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
169 i2c_status_type i2c_memory_write_dma (i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
170 i2c_status_type i2c_memory_read (i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
171 i2c_status_type i2c_memory_read_int (i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
172 i2c_status_type i2c_memory_read_dma (i2c_handle_type* hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
173
174void i2c_evt_irq_handler (i2c_handle_type* hi2c);
175void i2c_err_irq_handler (i2c_handle_type* hi2c);
176void i2c_dma_tx_irq_handler (i2c_handle_type* hi2c);
177void i2c_dma_rx_irq_handler (i2c_handle_type* hi2c);
178
187#ifdef __cplusplus
188}
189#endif
190
191#endif
at32f413.h
at32f413 header file
i2c_wait_flag
i2c_status_type i2c_wait_flag(i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are wai...
Definition: i2c_application.c:184
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1877
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:128
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1794
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2222
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1600
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:985
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2338
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2292
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:488
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:1201
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:907
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1298
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:1024
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1387
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1677
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2255
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:100
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:1077
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:821
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:563
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:1125
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:868
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:420
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:734
i2c_mem_address_width_type
i2c_mem_address_width_type
Definition: i2c_application.h:58
I2C_MEM_ADDR_WIDIH_8
@ I2C_MEM_ADDR_WIDIH_8
Definition: i2c_application.h:59
I2C_MEM_ADDR_WIDIH_16
@ I2C_MEM_ADDR_WIDIH_16
Definition: i2c_application.h:60
i2c_status_type
i2c_status_type
Definition: i2c_application.h:93
I2C_ERR_STEP_1
@ I2C_ERR_STEP_1
Definition: i2c_application.h:95
I2C_ERR_TIMEOUT
@ I2C_ERR_TIMEOUT
Definition: i2c_application.h:112
I2C_ERR_ADDR10
@ I2C_ERR_ADDR10
Definition: i2c_application.h:108
I2C_ERR_START
@ I2C_ERR_START
Definition: i2c_application.h:107
I2C_ERR_STEP_11
@ I2C_ERR_STEP_11
Definition: i2c_application.h:105
I2C_ERR_INTERRUPT
@ I2C_ERR_INTERRUPT
Definition: i2c_application.h:113
I2C_ERR_STEP_3
@ I2C_ERR_STEP_3
Definition: i2c_application.h:97
I2C_ERR_STEP_6
@ I2C_ERR_STEP_6
Definition: i2c_application.h:100
I2C_ERR_STEP_5
@ I2C_ERR_STEP_5
Definition: i2c_application.h:99
I2C_ERR_STEP_9
@ I2C_ERR_STEP_9
Definition: i2c_application.h:103
I2C_ERR_STEP_7
@ I2C_ERR_STEP_7
Definition: i2c_application.h:101
I2C_ERR_STOP
@ I2C_ERR_STOP
Definition: i2c_application.h:110
I2C_ERR_STEP_8
@ I2C_ERR_STEP_8
Definition: i2c_application.h:102
I2C_ERR_ACKFAIL
@ I2C_ERR_ACKFAIL
Definition: i2c_application.h:111
I2C_ERR_ADDR
@ I2C_ERR_ADDR
Definition: i2c_application.h:109
I2C_ERR_STEP_12
@ I2C_ERR_STEP_12
Definition: i2c_application.h:106
I2C_ERR_STEP_2
@ I2C_ERR_STEP_2
Definition: i2c_application.h:96
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
I2C_ERR_STEP_10
@ I2C_ERR_STEP_10
Definition: i2c_application.h:104
I2C_ERR_STEP_4
@ I2C_ERR_STEP_4
Definition: i2c_application.h:98
i2c_mode_type
i2c_mode_type
Definition: i2c_application.h:72
I2C_DMA_MA_RX
@ I2C_DMA_MA_RX
Definition: i2c_application.h:78
I2C_DMA_SLA_RX
@ I2C_DMA_SLA_RX
Definition: i2c_application.h:80
I2C_INT_SLA_RX
@ I2C_INT_SLA_RX
Definition: i2c_application.h:76
I2C_DMA_MA_TX
@ I2C_DMA_MA_TX
Definition: i2c_application.h:77
I2C_INT_MA_RX
@ I2C_INT_MA_RX
Definition: i2c_application.h:74
I2C_INT_SLA_TX
@ I2C_INT_SLA_TX
Definition: i2c_application.h:75
I2C_INT_MA_TX
@ I2C_INT_MA_TX
Definition: i2c_application.h:73
I2C_DMA_SLA_TX
@ I2C_DMA_SLA_TX
Definition: i2c_application.h:79
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:410
dma_init_type
dma init type
Definition: at32f413_dma.h:273
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:135
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
i2c_handle_type::status
__IO uint32_t status
Definition: i2c_application.h:132
i2c_handle_type::pbuff
uint8_t * pbuff
Definition: i2c_application.h:128
i2c_handle_type::mode
__IO uint32_t mode
Definition: i2c_application.h:130
i2c_handle_type::timeout
__IO uint32_t timeout
Definition: i2c_application.h:131
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:136
i2c_handle_type::error_code
__IO i2c_status_type error_code
Definition: i2c_application.h:133
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:134
i2c_handle_type::pcount
__IO uint16_t pcount
Definition: i2c_application.h:129
i2c_type
type define i2c register all
Definition: at32f413_i2c.h:172


AT32F413 Firmwary Library: include_port.c Source File

  • utilities
  • at32f413_freertos_demo
  • src
include_port.c
Go to the documentation of this file.
1
33/* support ac5 and ac6 compiler */
34#if (__ARMCC_VERSION > 6000000)
35
36#include "..\..\..\middlewares\freertos\source\portable\GCC\ARM_CM4F\port.c"
37
38#else
39
40#include "..\..\..\middlewares\freertos\source\portable\rvds\ARM_CM4F\port.c"
41
42#endif
43


AT32F413 Firmwary Library: julia_fpu.c Source File

  • cortex_m4
  • fpu
  • src
julia_fpu.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "julia_fpu.h"
27
46void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer)
47{
48 float tmp1, tmp2;
49 float num_real, num_img;
50 float rayon;
51 uint16_t i;
52 uint16_t x, y;
53 for (y = 0; y < size_y; y++)
54 {
55 for (x = 0; x < size_x; x++)
56 {
57 num_real = y - offset_y;
58 num_real = num_real / zoom;
59 num_img = x - offset_x;
60 num_img = num_img / zoom;
61 i = 0;
62 rayon = 0;
63 while((i < ITERATION - 1) && (rayon < 4))
64 {
65 tmp1 = num_real * num_real;
66 tmp2 = num_img * num_img;
67 num_img = 2 * num_real * num_img + IMG_CONSTANT;
68 num_real = tmp1 - tmp2 + REAL_CONSTANT;
69 rayon = tmp1 + tmp2;
70 i++;
71 }
72 /* store the value in the buffer */
73 buffer[x + y * size_x] = i;
74 }
75 }
76}
77
IMG_CONSTANT
#define IMG_CONSTANT
Definition: julia_fpu.h:45
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: julia_fpu.c:46
REAL_CONSTANT
#define REAL_CONSTANT
Definition: julia_fpu.h:44
ITERATION
#define ITERATION
Definition: julia_fpu.h:43
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
julia_fpu.h
julia_fpu header file


AT32F413 Firmwary Library: julia_fpu.h Source File

  • cortex_m4
  • fpu
  • inc
julia_fpu.h
Go to the documentation of this file.
1
25#ifndef __JULIA_FPU_H
26#define __JULIA_FPU_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32/* includes ------------------------------------------------------------------*/
33#include "at32f413.h"
34
43#define ITERATION 200
44#define REAL_CONSTANT (0.285f)
45#define IMG_CONSTANT (0.01f)
46
51void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer);
52
65#ifdef __cplusplus
66}
67#endif
68
69#endif
70
at32f413.h
at32f413 header file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: julia_fpu.c:46


AT32F413 Firmwary Library: keyboard_class.c Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "keyboard_class.h"
26#include "keyboard_desc.h"
27
41static usb_sts_type class_init_handler(void *udev);
42static usb_sts_type class_clear_handler(void *udev);
43static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
44static usb_sts_type class_ept0_tx_handler(void *udev);
45static usb_sts_type class_ept0_rx_handler(void *udev);
46static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
47static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_sof_handler(void *udev);
49static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
50
51 keyboard_type keyboard_struct;
52#define SHIFT 0x80
53const static unsigned char _asciimap[128] =
54{
55 0x00,// NUL
56 0x00,// SOH
57 0x00,// STX
58 0x00,// ETX
59 0x00,// EOT
60 0x00,// ENQ
61 0x00,// ACK
62 0x00,// BEL
63 0x2A,// BS Backspace
64 0x2B,// TAB Tab
65 0x28,// LF Enter
66 0x00,// VT
67 0x00,// FF
68 0x00,// CR
69 0x00,// SO
70 0x00,// SI
71 0x00,// DEL
72 0x00,// DC1
73 0x00,// DC2
74 0x00,// DC3
75 0x00,// DC4
76 0x00,// NAK
77 0x00,// SYN
78 0x00,// ETB
79 0x00,// CAN
80 0x00,// EM
81 0x00,// SUB
82 0x00,// ESC
83 0x00,// FS
84 0x00,// GS
85 0x00,// RS
86 0x00,// US
87
88 0x2C,// ' '
89 0x1E|SHIFT,// !
90 0x34|SHIFT,// "
91 0x20|SHIFT,// #
92 0x21|SHIFT,// $
93 0x22|SHIFT,// %
94 0x24|SHIFT,// &
95 0x34, // '
96 0x26|SHIFT,// (
97 0x27|SHIFT,// )
98 0x25|SHIFT,// *
99 0x2E|SHIFT,// +
100 0x36,// ,
101 0x2D,// -
102 0x37,// .
103 0x38,// /
104 0x27,// 0
105 0x1E,// 1
106 0x1F,// 2
107 0x20,// 3
108 0x21,// 4
109 0x22,// 5
110 0x23,// 6
111 0x24,// 7
112 0x25,// 8
113 0x26,// 9
114 0x33|SHIFT,// :
115 0x33, // ;
116 0x36|SHIFT,// <
117 0x2E, // =
118 0x37|SHIFT,// >
119 0x38|SHIFT,// ?
120 0x1F|SHIFT,// @
121 0x04|SHIFT,// A
122 0x05|SHIFT,// B
123 0x06|SHIFT,// C
124 0x07|SHIFT,// D
125 0x08|SHIFT,// E
126 0x09|SHIFT,// F
127 0x0A|SHIFT,// G
128 0x0B|SHIFT,// H
129 0x0C|SHIFT,// I
130 0x0D|SHIFT,// J
131 0x0E|SHIFT,// K
132 0x0F|SHIFT,// L
133 0x10|SHIFT,// M
134 0x11|SHIFT,// N
135 0x12|SHIFT,// O
136 0x13|SHIFT,// P
137 0x14|SHIFT,// Q
138 0x15|SHIFT,// R
139 0x16|SHIFT,// S
140 0x17|SHIFT,// T
141 0x18|SHIFT,// U
142 0x19|SHIFT,// V
143 0x1A|SHIFT,// W
144 0x1B|SHIFT,// X
145 0x1C|SHIFT,// Y
146 0x1D|SHIFT,// Z
147 0x2F, // [
148 0x31, // bslash
149 0x30, // ]
150 0x23|SHIFT,// ^
151 0x2D|SHIFT,// _
152 0x35, // `
153 0x04, // a
154 0x05, // b
155 0x06, // c
156 0x07, // d
157 0x08, // e
158 0x09, // f
159 0x0A, // g
160 0x0B, // h
161 0x0C, // i
162 0x0D, // j
163 0x0E, // k
164 0x0F, // l
165 0x10, // m
166 0x11, // n
167 0x12, // o
168 0x13, // p
169 0x14, // q
170 0x15, // r
171 0x16, // s
172 0x17, // t
173 0x18, // u
174 0x19, // v
175 0x1A, // w
176 0x1B, // x
177 0x1C, // y
178 0x1D, // z
179 0x2f|SHIFT,//
180 0x31|SHIFT,// |
181 0x30|SHIFT,// }
182 0x35|SHIFT,// ~
183 0 // DEL
184};
185
186/* usb device class handler */
187 usbd_class_handler keyboard_class_handler =
188{
189 class_init_handler,
190 class_clear_handler,
191 class_setup_handler,
192 class_ept0_tx_handler,
193 class_ept0_rx_handler,
194 class_in_handler,
195 class_out_handler,
196 class_sof_handler,
197 class_event_handler,
198 &keyboard_struct
199};
200
206static usb_sts_type class_init_handler(void *udev)
207{
208 usb_sts_type status = USB_OK;
209 usbd_core_type *pudev = (usbd_core_type *)udev;
210 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
211#ifndef USB_EPT_AUTO_MALLOC_BUFFER
212 /* use user define buffer address */
213 usbd_ept_buf_custom_define(pudev, USBD_KEYBOARD_IN_EPT, EPT1_TX_ADDR);
214#endif
215
216 /* open hid in endpoint */
217 usbd_ept_open(pudev, USBD_KEYBOARD_IN_EPT, EPT_INT_TYPE, USBD_KEYBOARD_IN_MAXPACKET_SIZE);
218
219 pkeyboard->g_u8tx_completed = 1;
220
221 return status;
222}
223
229static usb_sts_type class_clear_handler(void *udev)
230{
231 usb_sts_type status = USB_OK;
232 usbd_core_type *pudev = (usbd_core_type *)udev;
233
234 /* close hid in endpoint */
235 usbd_ept_close(pudev, USBD_KEYBOARD_IN_EPT);
236
237 return status;
238}
239
246static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
247{
248 usb_sts_type status = USB_OK;
249 usbd_core_type *pudev = (usbd_core_type *)udev;
250 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
251 uint16_t len;
252 uint8_t *buf;
253
254 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
255 {
256 /* class request */
257 case USB_REQ_TYPE_CLASS:
258 switch(setup->bRequest)
259 {
260 case HID_REQ_SET_PROTOCOL:
261 pkeyboard->hid_protocol = (uint8_t)setup->wValue;
262 break;
263 case HID_REQ_GET_PROTOCOL:
264 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->hid_protocol, 1);
265 break;
266 case HID_REQ_SET_IDLE:
267 pkeyboard->hid_set_idle = (uint8_t)(setup->wValue >> 8);
268 break;
269 case HID_REQ_GET_IDLE:
270 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->hid_set_idle, 1);
271 break;
272 case HID_REQ_SET_REPORT:
273 pkeyboard->hid_state = HID_REQ_SET_REPORT;
274 usbd_ctrl_recv(pudev, pkeyboard->hid_set_report, setup->wLength);
275 break;
276 default:
277 usbd_ctrl_unsupport(pudev);
278 break;
279 }
280 break;
281 /* standard request */
282 case USB_REQ_TYPE_STANDARD:
283 switch(setup->bRequest)
284 {
285 case USB_STD_REQ_GET_DESCRIPTOR:
286 if(setup->wValue >> 8 == HID_REPORT_DESC)
287 {
288 len = MIN(USBD_KEYBOARD_SIZ_REPORT_DESC, setup->wLength);
289 buf = (uint8_t *)g_usbd_keyboard_report;
290 }
291 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
292 {
293 len = MIN(9, setup->wLength);
294 buf = (uint8_t *)g_keyboard_usb_desc;
295 }
296 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
297 break;
298 case USB_STD_REQ_GET_INTERFACE:
299 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->alt_setting, 1);
300 break;
301 case USB_STD_REQ_SET_INTERFACE:
302 pkeyboard->alt_setting = setup->wValue;
303 break;
304 case USB_STD_REQ_CLEAR_FEATURE:
305 break;
306 case USB_STD_REQ_SET_FEATURE:
307 break;
308 default:
309 usbd_ctrl_unsupport(pudev);
310 break;
311 }
312 break;
313 default:
314 usbd_ctrl_unsupport(pudev);
315 break;
316 }
317 return status;
318}
319
325static usb_sts_type class_ept0_tx_handler(void *udev)
326{
327 usb_sts_type status = USB_OK;
328
329 /* ...user code... */
330
331 return status;
332}
333
339static usb_sts_type class_ept0_rx_handler(void *udev)
340{
341 usb_sts_type status = USB_OK;
342 usbd_core_type *pudev = (usbd_core_type *)udev;
343 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
344 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
345 /* ...user code... */
346 if( pkeyboard->hid_state == HID_REQ_SET_REPORT)
347 {
348 /* hid buffer process */
349 pkeyboard->hid_state = 0;
350 }
351
352 return status;
353}
354
361static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
362{
363 usb_sts_type status = USB_OK;
364 usbd_core_type *pudev = (usbd_core_type *)udev;
365 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
366
367 /* ...user code...
368 trans next packet data
369 */
370 pkeyboard->g_u8tx_completed = 1;
371
372 return status;
373}
374
381static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
382{
383 usb_sts_type status = USB_OK;
384
385 return status;
386}
387
393static usb_sts_type class_sof_handler(void *udev)
394{
395 usb_sts_type status = USB_OK;
396
397 /* ...user code... */
398
399 return status;
400}
401
408static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
409{
410 usb_sts_type status = USB_OK;
411 usbd_core_type *pudev = (usbd_core_type *)udev;
412 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
413 switch(event)
414 {
415 case USBD_RESET_EVENT:
416
417 /* ...user code... */
418
419 break;
420 case USBD_SUSPEND_EVENT:
421 pkeyboard->hid_suspend_flag = 1;
422 /* ...user code... */
423
424 break;
425 case USBD_WAKEUP_EVENT:
426 /* ...user code... */
427
428 break;
429 default:
430 break;
431 }
432 return status;
433}
434
442 usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
443{
444 usb_sts_type status = USB_OK;
445 usbd_core_type *pudev = (usbd_core_type *)udev;
446
447 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
448 usbd_ept_send(pudev, USBD_KEYBOARD_IN_EPT, report, len);
449
450 return status;
451}
452
453
460void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
461{
462 uint8_t key_data = 0;
463 usbd_core_type *pudev = (usbd_core_type *)udev;
464 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
465
466 if(ascii_code > 128)
467 {
468 ascii_code = 0;
469 }
470 else
471 {
472 ascii_code = _asciimap[ascii_code];
473 if(!ascii_code)
474 {
475 ascii_code = 0;
476 }
477
478 if(ascii_code & SHIFT)
479 {
480 key_data = 0x2;
481 ascii_code &= 0x7F;
482 }
483 }
484
485 if((pkeyboard->temp == ascii_code) && (ascii_code != 0))
486 {
487 pkeyboard->keyboard_buf[0] = 0;
488 pkeyboard->keyboard_buf[2] = 0;
489 usb_keyboard_class_send_report(udev, pkeyboard->keyboard_buf, 8);
490 }
491 else
492 {
493 pkeyboard->keyboard_buf[0] = key_data;
494 pkeyboard->keyboard_buf[2] = ascii_code;
495 usb_keyboard_class_send_report(udev, pkeyboard->keyboard_buf, 8);
496 }
497}
498
499
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:75
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:61
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
USBD_KEYBOARD_IN_MAXPACKET_SIZE
#define USBD_KEYBOARD_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: keyboard_class.h:56
USBD_KEYBOARD_IN_EPT
#define USBD_KEYBOARD_IN_EPT
usb hid use endpoint define
Definition: keyboard_class.h:51
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: keyboard_class.c:393
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: keyboard_class.c:361
keyboard_struct
keyboard_type keyboard_struct
Definition: keyboard_class.c:51
_asciimap
static const unsigned char _asciimap[128]
Definition: keyboard_class.c:53
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: keyboard_class.c:229
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: keyboard_class.c:246
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: keyboard_class.c:325
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:460
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: keyboard_class.c:339
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: keyboard_class.c:408
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: keyboard_class.c:206
usb_keyboard_class_send_report
usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: keyboard_class.c:442
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:187
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: keyboard_class.c:381
SHIFT
#define SHIFT
Definition: keyboard_class.c:52
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:63
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:160
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:202
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:234
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:229
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:228
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:235
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:230
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:231
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:232
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
keyboard_class.h
usb hid keyboard header file
keyboard_desc.h
usb keyboard descriptor header file
keyboard_type
Definition: keyboard_class.h:65
keyboard_type::keyboard_buf
uint8_t keyboard_buf[8]
Definition: keyboard_class.h:70
keyboard_type::hid_set_report
uint8_t hid_set_report[64]
Definition: keyboard_class.h:69
keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: keyboard_class.h:67
keyboard_type::alt_setting
uint32_t alt_setting
Definition: keyboard_class.h:68
keyboard_type::temp
uint8_t temp
Definition: keyboard_class.h:75
keyboard_type::hid_state
uint8_t hid_state
Definition: keyboard_class.h:74
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:73
keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: keyboard_class.h:66
keyboard_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: keyboard_class.h:72
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: keyboard_class.h Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __KEYBOARD_CLASS_H
27#define __KEYBOARD_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
51#define USBD_KEYBOARD_IN_EPT 0x81
52
56#define USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
57#define USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40
58
64typedef struct
65{
66 uint32_t hid_protocol;
67 uint32_t hid_set_idle;
68 uint32_t alt_setting;
69 uint8_t hid_set_report[64];
70 uint8_t keyboard_buf[8];
71
72 __IO uint8_t hid_suspend_flag;
73 __IO uint8_t g_u8tx_completed;
74 uint8_t hid_state;
75 uint8_t temp;
76
77}keyboard_type;
78
82extern usbd_class_handler keyboard_class_handler;
83
84 usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len);
85void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code);
97#ifdef __cplusplus
98}
99#endif
100
101#endif
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:460
usb_keyboard_class_send_report
usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: keyboard_class.c:442
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
keyboard_type
Definition: keyboard_class.h:65
keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: keyboard_class.h:67
keyboard_type::alt_setting
uint32_t alt_setting
Definition: keyboard_class.h:68
keyboard_type::temp
uint8_t temp
Definition: keyboard_class.h:75
keyboard_type::hid_state
uint8_t hid_state
Definition: keyboard_class.h:74
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:73
keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: keyboard_class.h:66
keyboard_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: keyboard_class.h:72
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: keyboard_desc.c Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "keyboard_desc.h"
28
42static usbd_desc_t *get_device_descriptor(void);
43static usbd_desc_t *get_device_qualifier(void);
44static usbd_desc_t *get_device_configuration(void);
45static usbd_desc_t *get_device_other_speed(void);
46static usbd_desc_t *get_device_lang_id(void);
47static usbd_desc_t *get_device_manufacturer_string(void);
48static usbd_desc_t *get_device_product_string(void);
49static usbd_desc_t *get_device_serial_string(void);
50static usbd_desc_t *get_device_interface_string(void);
51static usbd_desc_t *get_device_config_string(void);
52
53static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
54static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
55static void get_serial_num(void);
56#if defined ( __ICCARM__ ) /* iar compiler */
57 #pragma data_alignment=4
58#endif
59ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
60
64 usbd_desc_handler keyboard_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x00, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_KEYBOARD_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_KEYBOARD_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_KEYBOARD_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_KEYBOARD_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_KEYBOARD_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_KEYBOARD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_KEYBOARD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x01, /* bNumInterfaces: 1 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x00, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xE0, /* bmAttributes: self powered and support remote wakeup*/
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x01, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
131 0x01, /* bInterfaceSubClass: subclass code */
132 0x01, /* bInterfaceProtocol: protocol code */
133 0x00, /* iInterface: index of string descriptor */
134
135 0x09, /* bLength: size of HID descriptor in bytes */
136 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
137 LBYTE(KEYBOARD_BCD_NUM),
138 HBYTE(KEYBOARD_BCD_NUM), /* bcdHID: HID class specification release number */
139 0x00, /* bCountryCode: hardware target conutry */
140 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
141 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
142 LBYTE(sizeof(g_usbd_keyboard_report)),
143 HBYTE(sizeof(g_usbd_keyboard_report)), /* wDescriptorLength: total length of reprot descriptor */
144
145 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
146 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
147 USBD_KEYBOARD_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
148 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
149 LBYTE(USBD_KEYBOARD_IN_MAXPACKET_SIZE),
150 HBYTE(USBD_KEYBOARD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
151 KEYBOARD_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
152};
153
157#if defined ( __ICCARM__ ) /* iar compiler */
158 #pragma data_alignment=4
159#endif
160ALIGNED_HEAD uint8_t g_usbd_keyboard_report[USBD_KEYBOARD_SIZ_REPORT_DESC] ALIGNED_TAIL =
161{
162 0x05, 0x01, // USAGE_PAGE (Generic Desktop)
163 0x09, 0x06, // USAGE (Keyboard)
164 0xa1, 0x01, // COLLECTION (Application)
165 0x05, 0x07, // USAGE_PAGE (Keyboard)
166 0x19, 0xe0, // USAGE_MINIMUM (Keyboard LeftControl)
167 0x29, 0xe7, // USAGE_MAXIMUM (Keyboard Right GUI)
168 0x15, 0x00, // LOGICAL_MINIMUM (0)
169 0x25, 0x01, // LOGICAL_MAXIMUM (1)
170 0x75, 0x01, // REPORT_SIZE (1)
171 0x95, 0x08, // REPORT_COUNT (8)
172 0x81, 0x02, // INPUT (Data,Var,Abs)
173 0x95, 0x01, // REPORT_COUNT (1)
174 0x75, 0x08, // REPORT_SIZE (8)
175 0x81, 0x03, // INPUT (Cnst,Var,Abs)
176 0x95, 0x05, // REPORT_COUNT (5)
177 0x75, 0x01, // REPORT_SIZE (1)
178 0x05, 0x08, // USAGE_PAGE (LEDs)
179 0x19, 0x01, // USAGE_MINIMUM (Num Lock)
180 0x29, 0x05, // USAGE_MAXIMUM (Kana)
181 0x91, 0x02, // OUTPUT (Data,Var,Abs)
182 0x95, 0x01, // REPORT_COUNT (1)
183 0x75, 0x03, // REPORT_SIZE (3)
184 0x91, 0x03, // OUTPUT (Cnst,Var,Abs)
185 0x95, 0x06, // REPORT_COUNT (6)
186 0x75, 0x08, // REPORT_SIZE (8)
187 0x15, 0x00, // LOGICAL_MINIMUM (0)
188 0x25, 0xFF, // LOGICAL_MAXIMUM (255)
189 0x05, 0x07, // USAGE_PAGE (Keyboard)
190 0x19, 0x00, // USAGE_MINIMUM (Reserved (no event indicated))
191 0x29, 0x65, // USAGE_MAXIMUM (Keyboard Application)
192 0x81, 0x00, // INPUT (Data,Ary,Abs)
193 0xc0 // END_COLLECTION
194};
195
199#if defined ( __ICCARM__ ) /* iar compiler */
200 #pragma data_alignment=4
201#endif
202ALIGNED_HEAD uint8_t g_keyboard_usb_desc[9] ALIGNED_TAIL =
203{
204 0x09, /* bLength: size of HID descriptor in bytes */
205 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
206 LBYTE(KEYBOARD_BCD_NUM),
207 HBYTE(KEYBOARD_BCD_NUM), /* bcdHID: HID class specification release number */
208 0x00, /* bCountryCode: hardware target conutry */
209 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
210 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
211 LBYTE(sizeof(g_usbd_keyboard_report)),
212 HBYTE(sizeof(g_usbd_keyboard_report)), /* wDescriptorLength: total length of reprot descriptor */
213};
214
215
219#if defined ( __ICCARM__ ) /* iar compiler */
220 #pragma data_alignment=4
221#endif
222ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_KEYBOARD_SIZ_STRING_LANGID] ALIGNED_TAIL =
223{
224 USBD_KEYBOARD_SIZ_STRING_LANGID,
225 USB_DESCIPTOR_TYPE_STRING,
226 0x09,
227 0x04,
228};
229
233#if defined ( __ICCARM__ ) /* iar compiler */
234 #pragma data_alignment=4
235#endif
236ALIGNED_HEAD static uint8_t g_string_serial[USBD_KEYBOARD_SIZ_STRING_SERIAL] ALIGNED_TAIL =
237{
238 USBD_KEYBOARD_SIZ_STRING_SERIAL,
239 USB_DESCIPTOR_TYPE_STRING,
240};
241
242
243/* device descriptor */
244static usbd_desc_t device_descriptor =
245{
246 USB_DEVICE_DESC_LEN,
247 g_usbd_descriptor
248};
249
250/* config descriptor */
251static usbd_desc_t config_descriptor =
252{
253 USBD_KEYBOARD_CONFIG_DESC_SIZE,
254 g_usbd_configuration
255};
256
257/* langid descriptor */
258static usbd_desc_t langid_descriptor =
259{
260 USBD_KEYBOARD_SIZ_STRING_LANGID,
261 g_string_lang_id
262};
263
264/* serial descriptor */
265static usbd_desc_t serial_descriptor =
266{
267 USBD_KEYBOARD_SIZ_STRING_SERIAL,
268 g_string_serial
269};
270
271static usbd_desc_t vp_desc;
272
279static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
280{
281 uint16_t str_len = 0, id_pos = 2;
282 uint8_t *tmp_str = string;
283
284 while(*tmp_str != '\0')
285 {
286 str_len ++;
287 unicode_buf[id_pos ++] = *tmp_str ++;
288 unicode_buf[id_pos ++] = 0x00;
289 }
290
291 str_len = str_len * 2 + 2;
292 unicode_buf[0] = str_len;
293 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
294
295 return str_len;
296}
297
305static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
306{
307 uint8_t idx = 0;
308
309 for( idx = 0 ; idx < len ; idx ++)
310 {
311 if( ((value >> 28)) < 0xA )
312 {
313 pbuf[ 2 * idx] = (value >> 28) + '0';
314 }
315 else
316 {
317 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
318 }
319
320 value = value << 4;
321
322 pbuf[2 * idx + 1] = 0;
323 }
324}
325
331static void get_serial_num(void)
332{
333 uint32_t serial0, serial1, serial2;
334
335 serial0 = *(uint32_t*)MCU_ID1;
336 serial1 = *(uint32_t*)MCU_ID2;
337 serial2 = *(uint32_t*)MCU_ID3;
338
339 serial0 += serial2;
340
341 if (serial0 != 0)
342 {
343 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
344 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
345 }
346}
347
353static usbd_desc_t *get_device_descriptor(void)
354{
355 return &device_descriptor;
356}
357
363static usbd_desc_t * get_device_qualifier(void)
364{
365 return NULL;
366}
367
373static usbd_desc_t *get_device_configuration(void)
374{
375 return &config_descriptor;
376}
377
383static usbd_desc_t *get_device_other_speed(void)
384{
385 return NULL;
386}
387
393static usbd_desc_t *get_device_lang_id(void)
394{
395 return &langid_descriptor;
396}
397
398
404static usbd_desc_t *get_device_manufacturer_string(void)
405{
406 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
407 vp_desc.descriptor = g_usbd_desc_buffer;
408 return &vp_desc;
409}
410
416static usbd_desc_t *get_device_product_string(void)
417{
418 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
419 vp_desc.descriptor = g_usbd_desc_buffer;
420 return &vp_desc;
421}
422
428static usbd_desc_t *get_device_serial_string(void)
429{
430 get_serial_num();
431 return &serial_descriptor;
432}
433
439static usbd_desc_t *get_device_interface_string(void)
440{
441 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
442 vp_desc.descriptor = g_usbd_desc_buffer;
443 return &vp_desc;
444}
445
451static usbd_desc_t *get_device_config_string(void)
452{
453 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
454 vp_desc.descriptor = g_usbd_desc_buffer;
455 return &vp_desc;
456}
457
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
USBD_KEYBOARD_IN_MAXPACKET_SIZE
#define USBD_KEYBOARD_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: keyboard_class.h:56
USBD_KEYBOARD_IN_EPT
#define USBD_KEYBOARD_IN_EPT
usb hid use endpoint define
Definition: keyboard_class.h:51
USBD_KEYBOARD_VENDOR_ID
#define USBD_KEYBOARD_VENDOR_ID
usb vendor id and product id define
Definition: keyboard_desc.h:56
USBD_KEYBOARD_DESC_CONFIGURATION_STRING
#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING
Definition: keyboard_desc.h:72
USBD_KEYBOARD_CONFIG_DESC_SIZE
#define USBD_KEYBOARD_CONFIG_DESC_SIZE
usb descriptor size define
Definition: keyboard_desc.h:62
USBD_KEYBOARD_SIZ_STRING_LANGID
#define USBD_KEYBOARD_SIZ_STRING_LANGID
Definition: keyboard_desc.h:64
USBD_KEYBOARD_DESC_MANUFACTURER_STRING
#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: keyboard_desc.h:70
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:63
KEYBOARD_BCD_NUM
#define KEYBOARD_BCD_NUM
usb bcd number define
Definition: keyboard_desc.h:51
KEYBOARD_BINTERVAL_TIME
#define KEYBOARD_BINTERVAL_TIME
usb hid endpoint interval define
Definition: keyboard_desc.h:78
USBD_KEYBOARD_DESC_PRODUCT_STRING
#define USBD_KEYBOARD_DESC_PRODUCT_STRING
Definition: keyboard_desc.h:71
USBD_KEYBOARD_SIZ_STRING_SERIAL
#define USBD_KEYBOARD_SIZ_STRING_SERIAL
Definition: keyboard_desc.h:65
USBD_KEYBOARD_PRODUCT_ID
#define USBD_KEYBOARD_PRODUCT_ID
Definition: keyboard_desc.h:57
USBD_KEYBOARD_DESC_INTERFACE_STRING
#define USBD_KEYBOARD_DESC_INTERFACE_STRING
Definition: keyboard_desc.h:73
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: keyboard_desc.c:265
device_descriptor
static usbd_desc_t device_descriptor
Definition: keyboard_desc.c:244
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: keyboard_desc.c:373
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: keyboard_desc.c:258
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: keyboard_desc.c:353
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: keyboard_desc.c:404
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: keyboard_desc.c:363
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: keyboard_desc.c:439
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:160
vp_desc
static usbd_desc_t vp_desc
Definition: keyboard_desc.c:271
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: keyboard_desc.c:383
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: keyboard_desc.c:59
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: keyboard_desc.c:416
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:64
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: keyboard_desc.c:451
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:202
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: keyboard_desc.c:279
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: keyboard_desc.c:393
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: keyboard_desc.c:331
config_descriptor
static usbd_desc_t config_descriptor
Definition: keyboard_desc.c:251
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: keyboard_desc.c:428
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: keyboard_desc.c:305
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:161
keyboard_desc.h
usb keyboard descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: keyboard_desc.h Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __KEYBOARD_DESC_H
27#define __KEYBOARD_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "keyboard_class.h"
34#include "usbd_core.h"
35
51#define KEYBOARD_BCD_NUM 0x0110
52
56#define USBD_KEYBOARD_VENDOR_ID 0x2E3C
57#define USBD_KEYBOARD_PRODUCT_ID 0x6040
58
62#define USBD_KEYBOARD_CONFIG_DESC_SIZE 34
63#define USBD_KEYBOARD_SIZ_REPORT_DESC 63
64#define USBD_KEYBOARD_SIZ_STRING_LANGID 4
65#define USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
66
70#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
71#define USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
72#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
73#define USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
74
78#define KEYBOARD_BINTERVAL_TIME 0x0A
79
83#define MCU_ID1 (0x1FFFF7E8)
84#define MCU_ID2 (0x1FFFF7EC)
85#define MCU_ID3 (0x1FFFF7F0)
86
90extern uint8_t g_usbd_keyboard_report[USBD_KEYBOARD_SIZ_REPORT_DESC];
91extern uint8_t g_keyboard_usb_desc[9];
92extern usbd_desc_handler keyboard_desc_handler;
93
101#ifdef __cplusplus
102}
103#endif
104
105#endif
106
107
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:63
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:160
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:202
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:64
keyboard_class.h
usb hid keyboard header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: main_page.h Source File

  • main_page
main_page.h
Go to the documentation of this file.
1


AT32F413 Firmwary Library: mouse_class.c Source File

  • middlewares
  • usbd_class
  • mouse
mouse_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "mouse_class.h"
26#include "mouse_desc.h"
27
41static usb_sts_type class_init_handler(void *udev);
42static usb_sts_type class_clear_handler(void *udev);
43static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
44static usb_sts_type class_ept0_tx_handler(void *udev);
45static usb_sts_type class_ept0_rx_handler(void *udev);
46static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
47static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_sof_handler(void *udev);
49static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
50
51 mouse_type mouse_struct;
52
53/* usb device class handler */
54 usbd_class_handler mouse_class_handler =
55{
56 class_init_handler,
57 class_clear_handler,
58 class_setup_handler,
59 class_ept0_tx_handler,
60 class_ept0_rx_handler,
61 class_in_handler,
62 class_out_handler,
63 class_sof_handler,
64 class_event_handler,
65 &mouse_struct
66};
67
73static usb_sts_type class_init_handler(void *udev)
74{
75 usb_sts_type status = USB_OK;
76 usbd_core_type *pudev = (usbd_core_type *)udev;
77
78#ifndef USB_EPT_AUTO_MALLOC_BUFFER
79 /* use user define buffer address */
80 usbd_ept_buf_custom_define(pudev, USBD_MOUSE_IN_EPT, EPT1_TX_ADDR);
81#endif
82
83 /* open hid in endpoint */
84 usbd_ept_open(pudev, USBD_MOUSE_IN_EPT, EPT_INT_TYPE, USBD_MOUSE_IN_MAXPACKET_SIZE);
85
86 return status;
87}
88
94static usb_sts_type class_clear_handler(void *udev)
95{
96 usb_sts_type status = USB_OK;
97 usbd_core_type *pudev = (usbd_core_type *)udev;
98
99 /* close hid in endpoint */
100 usbd_ept_close(pudev, USBD_MOUSE_IN_EPT);
101
102 return status;
103}
104
111static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
112{
113 usb_sts_type status = USB_OK;
114 usbd_core_type *pudev = (usbd_core_type *)udev;
115 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
116 uint16_t len;
117 uint8_t *buf;
118
119 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
120 {
121 /* class request */
122 case USB_REQ_TYPE_CLASS:
123 switch(setup->bRequest)
124 {
125 case HID_REQ_SET_PROTOCOL:
126 pmouse->hid_protocol = (uint8_t)setup->wValue;
127 break;
128 case HID_REQ_GET_PROTOCOL:
129 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->hid_protocol, 1);
130 break;
131 case HID_REQ_SET_IDLE:
132 pmouse->hid_set_idle = (uint8_t)(setup->wValue >> 8);
133 break;
134 case HID_REQ_GET_IDLE:
135 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->hid_set_idle, 1);
136 break;
137 case HID_REQ_SET_REPORT:
138 pmouse->hid_state = HID_REQ_SET_REPORT;
139 usbd_ctrl_recv(pudev, pmouse->hid_set_report, setup->wLength);
140 break;
141 default:
142 usbd_ctrl_unsupport(pudev);
143 break;
144 }
145 break;
146 /* standard request */
147 case USB_REQ_TYPE_STANDARD:
148 switch(setup->bRequest)
149 {
150 case USB_STD_REQ_GET_DESCRIPTOR:
151 if(setup->wValue >> 8 == HID_REPORT_DESC)
152 {
153 len = MIN(USBD_MOUSE_SIZ_REPORT_DESC, setup->wLength);
154 buf = (uint8_t *)g_usbd_mouse_report;
155 }
156 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
157 {
158 len = MIN(9, setup->wLength);
159 buf = (uint8_t *)g_mouse_usb_desc;
160 }
161 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
162 break;
163 case USB_STD_REQ_GET_INTERFACE:
164 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->alt_setting, 1);
165 break;
166 case USB_STD_REQ_SET_INTERFACE:
167 pmouse->alt_setting = setup->wValue;
168 break;
169 case USB_STD_REQ_CLEAR_FEATURE:
170 break;
171 case USB_STD_REQ_SET_FEATURE:
172 break;
173 default:
174 usbd_ctrl_unsupport(pudev);
175 break;
176 }
177 break;
178 default:
179 usbd_ctrl_unsupport(pudev);
180 break;
181 }
182 return status;
183}
184
190static usb_sts_type class_ept0_tx_handler(void *udev)
191{
192 usb_sts_type status = USB_OK;
193
194 /* ...user code... */
195
196 return status;
197}
198
204static usb_sts_type class_ept0_rx_handler(void *udev)
205{
206 usb_sts_type status = USB_OK;
207 usbd_core_type *pudev = (usbd_core_type *)udev;
208 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
209 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
210 /* ...user code... */
211 if( pmouse->hid_state == HID_REQ_SET_REPORT)
212 {
213 /* hid buffer process */
214 pmouse->hid_state = 0;
215 }
216
217 return status;
218}
219
226static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
227{
228 usb_sts_type status = USB_OK;
229
230 /* ...user code...
231 trans next packet data
232 */
233
234 return status;
235}
236
243static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
244{
245 usb_sts_type status = USB_OK;
246
247 return status;
248}
249
255static usb_sts_type class_sof_handler(void *udev)
256{
257 usb_sts_type status = USB_OK;
258
259 /* ...user code... */
260
261 return status;
262}
263
270static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
271{
272 usb_sts_type status = USB_OK;
273 usbd_core_type *pudev = (usbd_core_type *)udev;
274 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
275 switch(event)
276 {
277 case USBD_RESET_EVENT:
278
279 /* ...user code... */
280
281 break;
282 case USBD_SUSPEND_EVENT:
283 pmouse->hid_suspend_flag = 1;
284 /* ...user code... */
285
286 break;
287 case USBD_WAKEUP_EVENT:
288 /* ...user code... */
289
290 break;
291 default:
292 break;
293 }
294 return status;
295}
296
304 usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
305{
306 usb_sts_type status = USB_OK;
307 usbd_core_type *pudev = (usbd_core_type *)udev;
308
309 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
310 usbd_ept_send(pudev, USBD_MOUSE_IN_EPT, report, len);
311
312 return status;
313}
314
321void usb_hid_mouse_send(void *udev, uint8_t op)
322{
323 usbd_core_type *pudev = (usbd_core_type *)udev;
324 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
325 int8_t posx = 0, posy = 0, button = 0;
326 switch(op)
327 {
328 case LEFT_BUTTON:
329 button = 0x01;
330 break;
331
332 case RIGHT_BUTTON:
333 button = 0x2;
334 break;
335
336 case UP_MOVE:
337 posy -= MOVE_STEP;
338 break;
339
340 case DOWN_MOVE:
341 posy += MOVE_STEP;
342 break;
343
344 case LEFT_MOVE:
345 posx -= MOVE_STEP;
346 break;
347
348 case RIGHT_MOVE:
349 posx += MOVE_STEP;
350 break;
351
352 default:
353 break;
354 }
355 pmouse->mouse_buffer[0] = button;
356 pmouse->mouse_buffer[1] = posx;
357 pmouse->mouse_buffer[2] = posy;
358
359 usb_mouse_class_send_report(udev, pmouse->mouse_buffer, 4);
360}
361
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:75
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:204
USBD_MOUSE_IN_EPT
#define USBD_MOUSE_IN_EPT
usb hid use endpoint define
Definition: mouse_class.h:51
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:56
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: mouse_class.c:255
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: mouse_class.c:226
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: mouse_class.c:94
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: mouse_class.c:111
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: mouse_class.c:190
usb_mouse_class_send_report
usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: mouse_class.c:304
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: mouse_class.c:204
mouse_struct
mouse_type mouse_struct
Definition: mouse_class.c:51
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: mouse_class.c:270
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: mouse_class.c:73
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: mouse_class.c:243
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:54
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:321
MOVE_STEP
#define MOVE_STEP
usb hid mouse operation
Definition: mouse_class.h:70
LEFT_MOVE
#define LEFT_MOVE
Definition: mouse_class.h:75
DOWN_MOVE
#define DOWN_MOVE
Definition: mouse_class.h:78
RIGHT_MOVE
#define RIGHT_MOVE
Definition: mouse_class.h:76
LEFT_BUTTON
#define LEFT_BUTTON
Definition: mouse_class.h:73
RIGHT_BUTTON
#define RIGHT_BUTTON
Definition: mouse_class.h:74
UP_MOVE
#define UP_MOVE
Definition: mouse_class.h:77
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:63
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:160
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:216
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:234
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:229
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:228
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:235
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:230
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:231
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:232
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
mouse_class.h
usb hid mouse header file
mouse_desc.h
usb mouse descriptor header file
mouse_type
Definition: mouse_class.h:81
mouse_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: mouse_class.h:89
mouse_type::hid_protocol
uint32_t hid_protocol
Definition: mouse_class.h:82
mouse_type::hid_set_idle
uint32_t hid_set_idle
Definition: mouse_class.h:83
mouse_type::mouse_buffer
uint8_t mouse_buffer[4]
Definition: mouse_class.h:87
mouse_type::hid_set_report
uint8_t hid_set_report[64]
Definition: mouse_class.h:86
mouse_type::alt_setting
uint32_t alt_setting
Definition: mouse_class.h:84
mouse_type::hid_state
uint8_t hid_state
Definition: mouse_class.h:88
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: mouse_class.h Source File

  • middlewares
  • usbd_class
  • mouse
mouse_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __MOUSE_CLASS_H
27#define __MOUSE_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
51#define USBD_MOUSE_IN_EPT 0x81
52
56#define USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
57
70#define MOVE_STEP 20
71
72#define BUTTON_RELEASE 0
73#define LEFT_BUTTON 1
74#define RIGHT_BUTTON 2
75#define LEFT_MOVE 3
76#define RIGHT_MOVE 4
77#define UP_MOVE 5
78#define DOWN_MOVE 6
79
80typedef struct
81{
82 uint32_t hid_protocol;
83 uint32_t hid_set_idle;
84 uint32_t alt_setting;
85
86 uint8_t hid_set_report[64];
87 uint8_t mouse_buffer[4];
88 uint8_t hid_state;
89 __IO uint8_t hid_suspend_flag;
90}mouse_type;
91
99extern usbd_class_handler mouse_class_handler;
100 usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len);
101void usb_hid_mouse_send(void *udev, uint8_t op);
113#ifdef __cplusplus
114}
115#endif
116
117#endif
usb_mouse_class_send_report
usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: mouse_class.c:304
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:54
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:321
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
mouse_type
Definition: mouse_class.h:81
mouse_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: mouse_class.h:89
mouse_type::hid_protocol
uint32_t hid_protocol
Definition: mouse_class.h:82
mouse_type::hid_set_idle
uint32_t hid_set_idle
Definition: mouse_class.h:83
mouse_type::alt_setting
uint32_t alt_setting
Definition: mouse_class.h:84
mouse_type::hid_state
uint8_t hid_state
Definition: mouse_class.h:88
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: mouse_desc.c Source File

  • middlewares
  • usbd_class
  • mouse
mouse_desc.c
Go to the documentation of this file.
1
24#include "usb_std.h"
25#include "usbd_sdr.h"
26#include "usbd_core.h"
27#include "mouse_desc.h"
28
42static usbd_desc_t *get_device_descriptor(void);
43static usbd_desc_t *get_device_qualifier(void);
44static usbd_desc_t *get_device_configuration(void);
45static usbd_desc_t *get_device_other_speed(void);
46static usbd_desc_t *get_device_lang_id(void);
47static usbd_desc_t *get_device_manufacturer_string(void);
48static usbd_desc_t *get_device_product_string(void);
49static usbd_desc_t *get_device_serial_string(void);
50static usbd_desc_t *get_device_interface_string(void);
51static usbd_desc_t *get_device_config_string(void);
52
53static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
54static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
55static void get_serial_num(void);
56#if defined ( __ICCARM__ ) /* iar compiler */
57 #pragma data_alignment=4
58#endif
59ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
60
64 usbd_desc_handler mouse_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x00, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_MOUSE_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_MOUSE_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_MOUSE_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_MOUSE_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_MOUSE_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_MOUSE_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_MOUSE_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x01, /* bNumInterfaces: 1 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x00, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xE0, /* bmAttributes: self powered and support remote wakeup*/
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x01, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
131 0x01, /* bInterfaceSubClass: subclass code */
132 0x02, /* bInterfaceProtocol: protocol code */
133 0x00, /* iInterface: index of string descriptor */
134
135 0x09, /* bLength: size of HID descriptor in bytes */
136 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
137 LBYTE(MOUSE_BCD_NUM),
138 HBYTE(MOUSE_BCD_NUM), /* bcdHID: HID class specification release number */
139 0x00, /* bCountryCode: hardware target conutry */
140 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
141 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
142 LBYTE(sizeof(g_usbd_mouse_report)),
143 HBYTE(sizeof(g_usbd_mouse_report)), /* wDescriptorLength: total length of reprot descriptor */
144
145 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
146 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
147 USBD_MOUSE_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
148 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
149 LBYTE(USBD_MOUSE_IN_MAXPACKET_SIZE),
150 HBYTE(USBD_MOUSE_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
151 MOUSE_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
152};
153
157#if defined ( __ICCARM__ ) /* iar compiler */
158 #pragma data_alignment=4
159#endif
160ALIGNED_HEAD uint8_t g_usbd_mouse_report[USBD_MOUSE_SIZ_REPORT_DESC] ALIGNED_TAIL =
161{
162 0x05,0x01,
163 0x09,0x02,
164 0xA1,0x01,
165 0x09,0x01,
166
167 0xA1,0x00,
168 0x05,0x09,
169 0x19,0x01,
170 0x29,0x03,
171
172 0x15,0x00,
173 0x25,0x01,
174 0x95,0x03,
175 0x75,0x01,
176
177 0x81,0x02,
178 0x95,0x01,
179 0x75,0x05,
180 0x81,0x01,
181
182 0x05,0x01,
183 0x09,0x30,
184 0x09,0x31,
185 0x09,0x38,
186
187 0x15,0x81,
188 0x25,0x7F,
189 0x75,0x08,
190 0x95,0x03,
191
192 0x81,0x06,
193 0xC0,0x09,
194 0x3c,0x05,
195 0xff,0x09,
196
197 0x01,0x15,
198 0x00,0x25,
199 0x01,0x75,
200 0x01,0x95,
201
202 0x02,0xb1,
203 0x22,0x75,
204 0x06,0x95,
205 0x01,0xb1,
206
207 0x01,0xc0
208};
209
213#if defined ( __ICCARM__ ) /* iar compiler */
214 #pragma data_alignment=4
215#endif
216ALIGNED_HEAD uint8_t g_mouse_usb_desc[9] ALIGNED_TAIL =
217{
218 0x09, /* bLength: size of HID descriptor in bytes */
219 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
220 LBYTE(MOUSE_BCD_NUM),
221 HBYTE(MOUSE_BCD_NUM), /* bcdHID: HID class specification release number */
222 0x00, /* bCountryCode: hardware target conutry */
223 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
224 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
225 LBYTE(sizeof(g_usbd_mouse_report)),
226 HBYTE(sizeof(g_usbd_mouse_report)), /* wDescriptorLength: total length of reprot descriptor */
227};
228
229
233#if defined ( __ICCARM__ ) /* iar compiler */
234 #pragma data_alignment=4
235#endif
236ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_MOUSE_SIZ_STRING_LANGID] ALIGNED_TAIL =
237{
238 USBD_MOUSE_SIZ_STRING_LANGID,
239 USB_DESCIPTOR_TYPE_STRING,
240 0x09,
241 0x04,
242};
243
247#if defined ( __ICCARM__ ) /* iar compiler */
248 #pragma data_alignment=4
249#endif
250ALIGNED_HEAD static uint8_t g_string_serial[USBD_MOUSE_SIZ_STRING_SERIAL] ALIGNED_TAIL =
251{
252 USBD_MOUSE_SIZ_STRING_SERIAL,
253 USB_DESCIPTOR_TYPE_STRING,
254};
255
256
257/* device descriptor */
258static usbd_desc_t device_descriptor =
259{
260 USB_DEVICE_DESC_LEN,
261 g_usbd_descriptor
262};
263
264/* config descriptor */
265static usbd_desc_t config_descriptor =
266{
267 USBD_MOUSE_CONFIG_DESC_SIZE,
268 g_usbd_configuration
269};
270
271/* langid descriptor */
272static usbd_desc_t langid_descriptor =
273{
274 USBD_MOUSE_SIZ_STRING_LANGID,
275 g_string_lang_id
276};
277
278/* serial descriptor */
279static usbd_desc_t serial_descriptor =
280{
281 USBD_MOUSE_SIZ_STRING_SERIAL,
282 g_string_serial
283};
284
285static usbd_desc_t vp_desc;
286
293static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
294{
295 uint16_t str_len = 0, id_pos = 2;
296 uint8_t *tmp_str = string;
297
298 while(*tmp_str != '\0')
299 {
300 str_len ++;
301 unicode_buf[id_pos ++] = *tmp_str ++;
302 unicode_buf[id_pos ++] = 0x00;
303 }
304
305 str_len = str_len * 2 + 2;
306 unicode_buf[0] = str_len;
307 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
308
309 return str_len;
310}
311
319static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
320{
321 uint8_t idx = 0;
322
323 for( idx = 0 ; idx < len ; idx ++)
324 {
325 if( ((value >> 28)) < 0xA )
326 {
327 pbuf[ 2 * idx] = (value >> 28) + '0';
328 }
329 else
330 {
331 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
332 }
333
334 value = value << 4;
335
336 pbuf[2 * idx + 1] = 0;
337 }
338}
339
345static void get_serial_num(void)
346{
347 uint32_t serial0, serial1, serial2;
348
349 serial0 = *(uint32_t*)MCU_ID1;
350 serial1 = *(uint32_t*)MCU_ID2;
351 serial2 = *(uint32_t*)MCU_ID3;
352
353 serial0 += serial2;
354
355 if (serial0 != 0)
356 {
357 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
358 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
359 }
360}
361
367static usbd_desc_t *get_device_descriptor(void)
368{
369 return &device_descriptor;
370}
371
377static usbd_desc_t * get_device_qualifier(void)
378{
379 return NULL;
380}
381
387static usbd_desc_t *get_device_configuration(void)
388{
389 return &config_descriptor;
390}
391
397static usbd_desc_t *get_device_other_speed(void)
398{
399 return NULL;
400}
401
407static usbd_desc_t *get_device_lang_id(void)
408{
409 return &langid_descriptor;
410}
411
412
418static usbd_desc_t *get_device_manufacturer_string(void)
419{
420 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
421 vp_desc.descriptor = g_usbd_desc_buffer;
422 return &vp_desc;
423}
424
430static usbd_desc_t *get_device_product_string(void)
431{
432 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
433 vp_desc.descriptor = g_usbd_desc_buffer;
434 return &vp_desc;
435}
436
442static usbd_desc_t *get_device_serial_string(void)
443{
444 get_serial_num();
445 return &serial_descriptor;
446}
447
453static usbd_desc_t *get_device_interface_string(void)
454{
455 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
456 vp_desc.descriptor = g_usbd_desc_buffer;
457 return &vp_desc;
458}
459
465static usbd_desc_t *get_device_config_string(void)
466{
467 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
468 vp_desc.descriptor = g_usbd_desc_buffer;
469 return &vp_desc;
470}
471
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:213
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:214
USBD_MOUSE_IN_EPT
#define USBD_MOUSE_IN_EPT
usb hid use endpoint define
Definition: mouse_class.h:51
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:56
USBD_MOUSE_DESC_INTERFACE_STRING
#define USBD_MOUSE_DESC_INTERFACE_STRING
Definition: mouse_desc.h:73
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:63
USBD_MOUSE_DESC_CONFIGURATION_STRING
#define USBD_MOUSE_DESC_CONFIGURATION_STRING
Definition: mouse_desc.h:72
USBD_MOUSE_SIZ_STRING_LANGID
#define USBD_MOUSE_SIZ_STRING_LANGID
Definition: mouse_desc.h:64
USBD_MOUSE_VENDOR_ID
#define USBD_MOUSE_VENDOR_ID
usb vendor id and product id define
Definition: mouse_desc.h:56
USBD_MOUSE_CONFIG_DESC_SIZE
#define USBD_MOUSE_CONFIG_DESC_SIZE
usb descriptor size define
Definition: mouse_desc.h:62
MOUSE_BINTERVAL_TIME
#define MOUSE_BINTERVAL_TIME
usb hid endpoint interval define
Definition: mouse_desc.h:78
USBD_MOUSE_PRODUCT_ID
#define USBD_MOUSE_PRODUCT_ID
Definition: mouse_desc.h:57
USBD_MOUSE_DESC_PRODUCT_STRING
#define USBD_MOUSE_DESC_PRODUCT_STRING
Definition: mouse_desc.h:71
USBD_MOUSE_SIZ_STRING_SERIAL
#define USBD_MOUSE_SIZ_STRING_SERIAL
Definition: mouse_desc.h:65
USBD_MOUSE_DESC_MANUFACTURER_STRING
#define USBD_MOUSE_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: mouse_desc.h:70
MOUSE_BCD_NUM
#define MOUSE_BCD_NUM
usb bcd number define
Definition: mouse_desc.h:51
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: mouse_desc.c:279
device_descriptor
static usbd_desc_t device_descriptor
Definition: mouse_desc.c:258
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: mouse_desc.c:387
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:64
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: mouse_desc.c:272
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: mouse_desc.c:367
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: mouse_desc.c:418
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: mouse_desc.c:377
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: mouse_desc.c:453
vp_desc
static usbd_desc_t vp_desc
Definition: mouse_desc.c:285
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: mouse_desc.c:397
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: mouse_desc.c:59
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: mouse_desc.c:430
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:160
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: mouse_desc.c:465
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: mouse_desc.c:293
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: mouse_desc.c:407
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:216
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: mouse_desc.c:345
config_descriptor
static usbd_desc_t config_descriptor
Definition: mouse_desc.c:265
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: mouse_desc.c:442
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: mouse_desc.c:319
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:176
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:161
mouse_desc.h
usb mouse descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: mouse_desc.h Source File

  • middlewares
  • usbd_class
  • mouse
mouse_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __MOUSE_DESC_H
27#define __MOUSE_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "mouse_class.h"
34#include "usbd_core.h"
35
51#define MOUSE_BCD_NUM 0x0110
52
56#define USBD_MOUSE_VENDOR_ID 0x2E3C
57#define USBD_MOUSE_PRODUCT_ID 0x5710
58
62#define USBD_MOUSE_CONFIG_DESC_SIZE 34
63#define USBD_MOUSE_SIZ_REPORT_DESC 74
64#define USBD_MOUSE_SIZ_STRING_LANGID 4
65#define USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
66
70#define USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
71#define USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
72#define USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
73#define USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
74
78#define MOUSE_BINTERVAL_TIME 0x0A
79
83#define MCU_ID1 (0x1FFFF7E8)
84#define MCU_ID2 (0x1FFFF7EC)
85#define MCU_ID3 (0x1FFFF7F0)
86
90extern uint8_t g_usbd_mouse_report[USBD_MOUSE_SIZ_REPORT_DESC];
91extern uint8_t g_mouse_usb_desc[9];
92extern usbd_desc_handler mouse_desc_handler;
93
101#ifdef __cplusplus
102}
103#endif
104
105#endif
106
107
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:63
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:160
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:216
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:64
mouse_class.h
usb hid mouse header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_diskio.h Source File

  • usb_device
  • msc
  • inc
msc/inc/msc_diskio.h
Go to the documentation of this file.
1
24/* Define to prevent recursive inclusion -------------------------------------*/
25#ifndef __MSC_DISKIO_H
26#define __MSC_DISKIO_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32
33#include "usb_conf.h"
34#include "usb_std.h"
35
43#define INTERNAL_FLASH_LUN 0
44#define SPI_FLASH_LUN 1
45#define SD_LUN 2
46
47#define USB_FLASH_ADDR_OFFSET 0x08005000
48
49#define SECTOR_SIZE_1K 1024
50#define SECTOR_SIZE_2K 2048
51#define SECTOR_SIZE_4K 4096
52
53uint8_t *get_inquiry(uint8_t lun);
54 usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len);
55 usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len);
56 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
57
66#ifdef __cplusplus
67}
68#endif
69
70#endif
71
72
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:134
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:100
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F413 Firmwary Library: msc_bot_scsi.c Source File

  • middlewares
  • usbd_class
  • msc
msc/msc_bot_scsi.c
Go to the documentation of this file.
1
24#include "msc_bot_scsi.h"
25#include "msc_diskio.h"
26
41#if defined ( __ICCARM__ ) /* iar compiler */
42 #pragma data_alignment=4
43#endif
44ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL = {
45 0x00,
46 0x00,
47 0x00,
48 0x00,
49 0x00,
50
51};
52#if defined ( __ICCARM__ ) /* iar compiler */
53 #pragma data_alignment=4
54#endif
55ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL =
56{
57 0x70,
58 0x00,
59 SENSE_KEY_ILLEGAL_REQUEST,
60 0x00000000,
61 0x0A,
62 0x00000000,
63 0x20,
64 0x00,
65 0x00000000
66};
67
68#if defined ( __ICCARM__ ) /* iar compiler */
69 #pragma data_alignment=4
70#endif
71ALIGNED_HEAD uint8_t mode_sense6_data[8] ALIGNED_TAIL =
72{
73 0x00,
74 0x00,
75 0x00,
76 0x00,
77 0x00,
78 0x00,
79 0x00,
80 0x00
81};
82
83#if defined ( __ICCARM__ ) /* iar compiler */
84 #pragma data_alignment=4
85#endif
86ALIGNED_HEAD uint8_t mode_sense10_data[8] ALIGNED_TAIL =
87{
88 0x00,
89 0x06,
90 0x00,
91 0x00,
92 0x00,
93 0x00,
94 0x00,
95 0x00
96};
102void bot_scsi_init(void *udev)
103{
104 usbd_core_type *pudev = (usbd_core_type *)udev;
105 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
106 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
107 pmsc->bot_status = MSC_BOT_STATE_IDLE;
108 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
109
110 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
111 pmsc->csw_struct.dCSWDataResidue = 0;
112 pmsc->csw_struct.dCSWSignature = 0;
113 pmsc->csw_struct.dCSWTag = CSW_BCSWSTATUS_PASS;
114
115
116 /* set out endpoint to receive status */
117 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
118}
119
125void bot_scsi_reset(void *udev)
126{
127 usbd_core_type *pudev = (usbd_core_type *)udev;
128 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
129 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
130 pmsc->bot_status = MSC_BOT_STATE_RECOVERY;
131 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
132
133 /* set out endpoint to receive status */
134 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
135}
136
143void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
144{
145 usbd_core_type *pudev = (usbd_core_type *)udev;
146 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
147 switch(pmsc->msc_state)
148 {
149 case MSC_STATE_MACHINE_DATA_IN:
150 if(bot_scsi_cmd_process(udev) != USB_OK)
151 {
152 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
153 }
154 break;
155
156 case MSC_STATE_MACHINE_LAST_DATA:
157 case MSC_STATE_MACHINE_SEND_DATA:
158 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
159 break;
160
161 default:
162 break;
163 }
164}
165
172void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
173{
174 usbd_core_type *pudev = (usbd_core_type *)udev;
175 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
176 switch(pmsc->msc_state)
177 {
178 case MSC_STATE_MACHINE_IDLE:
179 bot_cbw_decode(udev);
180 break;
181
182 case MSC_STATE_MACHINE_DATA_OUT:
183 if(bot_scsi_cmd_process(udev) != USB_OK)
184 {
185 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
186 }
187 break;
188 }
189}
190
196void bot_cbw_decode(void *udev)
197{
198 usbd_core_type *pudev = (usbd_core_type *)udev;
199 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
200
201 pmsc->csw_struct.dCSWTag = pmsc->cbw_struct.dCBWTage;
202 pmsc->csw_struct.dCSWDataResidue = pmsc->cbw_struct.dCBWDataTransferLength;
203
204 /* check param */
205 if((pmsc->cbw_struct.dCBWSignature != CBW_DCBWSIGNATURE) ||
206 (usbd_get_recv_len(pudev, USBD_MSC_BULK_OUT_EPT) != CBW_CMD_LENGTH)
207 || (pmsc->cbw_struct.bCBWLUN > MSC_SUPPORT_MAX_LUN) ||
208 (pmsc->cbw_struct.bCBWCBLength < 1) || (pmsc->cbw_struct.bCBWCBLength > 16))
209 {
210 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
211 pmsc->bot_status = MSC_BOT_STATE_ERROR;
212 bot_scsi_stall(udev);
213 }
214 else
215 {
216 if(bot_scsi_cmd_process(udev) != USB_OK)
217 {
218 bot_scsi_stall(udev);
219 }
220 else if((pmsc->msc_state != MSC_STATE_MACHINE_DATA_IN) &&
221 (pmsc->msc_state != MSC_STATE_MACHINE_DATA_OUT) &&
222 (pmsc->msc_state != MSC_STATE_MACHINE_LAST_DATA))
223 {
224 if(pmsc->data_len == 0)
225 {
226 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
227 }
228 else if(pmsc->data_len > 0)
229 {
230 bot_scsi_send_data(udev, pmsc->data, pmsc->data_len);
231 }
232 }
233 }
234}
235
243void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
244{
245 usbd_core_type *pudev = (usbd_core_type *)udev;
246 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
247 uint32_t data_len = MIN(len, pmsc->cbw_struct.dCBWDataTransferLength);
248
249 pmsc->csw_struct.dCSWDataResidue -= data_len;
250 pmsc->csw_struct.bCSWStatus = CSW_BCSWSTATUS_PASS;
251
252 pmsc->msc_state = MSC_STATE_MACHINE_SEND_DATA;
253
254 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
255 buffer, data_len);
256}
257
264void bot_scsi_send_csw(void *udev, uint8_t status)
265{
266 usbd_core_type *pudev = (usbd_core_type *)udev;
267 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
268
269 pmsc->csw_struct.bCSWStatus = status;
270 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
271 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
272
273 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
274 (uint8_t *)&pmsc->csw_struct, CSW_CMD_LENGTH);
275
276 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
277 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
278}
279
280
288void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
289{
290 sense_data.sense_key = sense_key;
291 sense_data.asc = asc;
292}
293
294
303 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
304{
305 usbd_core_type *pudev = (usbd_core_type *)udev;
306 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
307 if((blk_offset + blk_count) > pmsc->blk_nbr[lun])
308 {
309 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, ADDRESS_OUT_OF_RANGE);
310 return USB_FAIL;
311 }
312 return USB_OK;
313}
314
320void bot_scsi_stall(void *udev)
321{
322 usbd_core_type *pudev = (usbd_core_type *)udev;
323 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
324
325 if((pmsc->cbw_struct.dCBWDataTransferLength != 0) &&
326 (pmsc->cbw_struct.bmCBWFlags == 0) &&
327 pmsc->bot_status == MSC_BOT_STATE_IDLE)
328 {
329 usbd_set_stall(pudev, USBD_MSC_BULK_OUT_EPT);
330 }
331 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
332
333 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
334 {
335 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
336 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
337 }
338}
339
346 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
347{
348 usb_sts_type status = USB_OK;
349 usbd_core_type *pudev = (usbd_core_type *)udev;
350 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
351
352 if(pmsc->cbw_struct.dCBWDataTransferLength != 0)
353 {
354 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
355 return USB_FAIL;
356 }
357
358 pmsc->data_len = 0;
359 return status;
360}
361
368 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
369{
370 uint8_t *pdata;
371 uint32_t trans_len = 0;
372 usb_sts_type status = USB_OK;
373 usbd_core_type *pudev = (usbd_core_type *)udev;
374 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
375
376 if(pmsc->cbw_struct.CBWCB[1] & 0x01)
377 {
378 pdata = page00_inquiry_data;
379 trans_len = 5;
380 }
381 else
382 {
383 pdata = get_inquiry(lun);
384 if(pmsc->cbw_struct.dCBWDataTransferLength < SCSI_INQUIRY_DATA_LENGTH)
385 {
386 trans_len = pmsc->cbw_struct.dCBWDataTransferLength;
387 }
388 else
389 {
390 trans_len = SCSI_INQUIRY_DATA_LENGTH;
391 }
392 }
393
394 pmsc->data_len = trans_len;
395 while(trans_len)
396 {
397 trans_len --;
398 pmsc->data[trans_len] = pdata[trans_len];
399 }
400 return status;
401}
402
409 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
410{
411 usbd_core_type *pudev = (usbd_core_type *)udev;
412 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
413 pmsc->data_len = 0;
414 return USB_OK;
415}
416
423 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
424{
425 usbd_core_type *pudev = (usbd_core_type *)udev;
426 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
427 pmsc->data_len = 0;
428 return USB_OK;
429}
430
437 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
438{
439 uint8_t data_len = 8;
440 usbd_core_type *pudev = (usbd_core_type *)udev;
441 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
442 pmsc->data_len = 8;
443 while(data_len)
444 {
445 data_len --;
446 pmsc->data[data_len] = mode_sense6_data[data_len];
447 };
448 return USB_OK;
449}
450
457 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
458{
459 uint8_t data_len = 8;
460 usbd_core_type *pudev = (usbd_core_type *)udev;
461 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
462 pmsc->data_len = 8;
463 while(data_len)
464 {
465 data_len --;
466 pmsc->data[data_len] = mode_sense10_data[data_len];
467 };
468 return USB_OK;
469}
470
477 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
478{
479 usbd_core_type *pudev = (usbd_core_type *)udev;
480 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
481 uint8_t *pdata = pmsc->data;
482 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
483
484 pdata[0] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
485 pdata[1] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
486 pdata[2] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
487 pdata[3] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
488
489 pdata[4] = (uint8_t)((pmsc->blk_size[lun]) >> 24);
490 pdata[5] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
491 pdata[6] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
492 pdata[7] = (uint8_t)((pmsc->blk_size[lun]));
493
494 pmsc->data_len = 8;
495 return USB_OK;
496}
497
504 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
505{
506 usbd_core_type *pudev = (usbd_core_type *)udev;
507 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
508 uint8_t *pdata = pmsc->data;
509
510 pdata[0] = 0;
511 pdata[1] = 0;
512 pdata[2] = 0;
513 pdata[3] = 0x08;
514
515 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
516
517 pdata[4] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
518 pdata[5] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
519 pdata[6] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
520 pdata[7] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
521
522 pdata[8] = 0x02;
523
524 pdata[9] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
525 pdata[10] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
526 pdata[11] = (uint8_t)((pmsc->blk_size[lun]));
527
528 pmsc->data_len = 12;
529
530 return USB_OK;
531}
532
539 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
540{
541 uint32_t trans_len = 0x12;
542 usbd_core_type *pudev = (usbd_core_type *)udev;
543 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
544 uint8_t *pdata = pmsc->data;
545 uint8_t *sdata = (uint8_t *)&sense_data;
546
547 while(trans_len)
548 {
549 trans_len --;
550 pdata[trans_len] = sdata[trans_len];
551 }
552
553 if(pmsc->cbw_struct.dCBWDataTransferLength < REQ_SENSE_STANDARD_DATA_LEN)
554 {
555 pmsc->data_len = pmsc->cbw_struct.dCBWDataTransferLength;
556 }
557 else
558 {
559 pmsc->data_len = REQ_SENSE_STANDARD_DATA_LEN;
560 }
561 return USB_OK;
562}
563
570 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
571{
572 usbd_core_type *pudev = (usbd_core_type *)udev;
573 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
574 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
575 if((pmsc->cbw_struct.CBWCB[1] & 0x02) == 0x02)
576 {
577 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_FIELED_IN_COMMAND);
578 return USB_FAIL;
579 }
580
581 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
582 pmsc->blk_len = cmd[7] << 8 | cmd[8];
583
584 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
585 {
586 return USB_FAIL;
587 }
588 pmsc->data_len = 0;
589 return USB_OK;
590}
591
598 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
599{
600 usbd_core_type *pudev = (usbd_core_type *)udev;
601 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
602 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
603 uint32_t len;
604
605 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
606 {
607 if((pmsc->cbw_struct.bmCBWFlags & 0x80) != 0x80)
608 {
609 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
610 return USB_FAIL;
611 }
612
613 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
614 pmsc->blk_len = cmd[7] << 8 | cmd[8];
615
616 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
617 {
618 return USB_FAIL;
619 }
620
621 pmsc->blk_addr *= pmsc->blk_size[lun];
622 pmsc->blk_len *= pmsc->blk_size[lun];
623
624 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
625 {
626 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
627 return USB_FAIL;
628 }
629 pmsc->msc_state = MSC_STATE_MACHINE_DATA_IN;
630 }
631 pmsc->data_len = MSC_MAX_DATA_BUF_LEN;
632
633 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
634 if( msc_disk_read(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
635 {
636 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
637 return USB_FAIL;
638 }
639 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT, pmsc->data, len);
640 pmsc->blk_addr += len;
641 pmsc->blk_len -= len;
642
643 pmsc->csw_struct.dCSWDataResidue -= len;
644 if(pmsc->blk_len == 0)
645 {
646 pmsc->msc_state = MSC_STATE_MACHINE_LAST_DATA;
647 }
648
649 return USB_OK;
650}
651
652
659 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
660{
661 usbd_core_type *pudev = (usbd_core_type *)udev;
662 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
663 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
664 uint32_t len;
665
666 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
667 {
668 if((pmsc->cbw_struct.bmCBWFlags & 0x80) == 0x80)
669 {
670 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
671 return USB_FAIL;
672 }
673
674 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
675 pmsc->blk_len = cmd[7] << 8 | cmd[8];
676
677 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
678 {
679 return USB_FAIL;
680 }
681
682 pmsc->blk_addr *= pmsc->blk_size[lun];
683 pmsc->blk_len *= pmsc->blk_size[lun];
684
685 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
686 {
687 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
688 return USB_FAIL;
689 }
690
691 pmsc->msc_state = MSC_STATE_MACHINE_DATA_OUT;
692 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
693 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
694
695 }
696 else
697 {
698 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
699 if(msc_disk_write(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
700 {
701 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
702 return USB_FAIL;
703 }
704
705 pmsc->blk_addr += len;
706 pmsc->blk_len -= len;
707
708 pmsc->csw_struct.dCSWDataResidue -= len;
709
710 if(pmsc->blk_len == 0)
711 {
712 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
713 }
714 else
715 {
716 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
717 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
718 }
719 }
720 return USB_OK;
721}
722
729void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
730{
731 usbd_core_type *pudev = (usbd_core_type *)udev;
732 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
733 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
734 {
735 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
736 pmsc->bot_status = MSC_BOT_STATE_IDLE;
737 }
738 else if(((ept_num & 0x80) == 0x80) && (pmsc->bot_status != MSC_BOT_STATE_RECOVERY))
739 {
740 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
741 }
742}
743
749 usb_sts_type bot_scsi_cmd_process(void *udev)
750{
751 usb_sts_type status = USB_FAIL;
752 usbd_core_type *pudev = (usbd_core_type *)udev;
753 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
754 switch(pmsc->cbw_struct.CBWCB[0])
755 {
756 case MSC_CMD_INQUIRY:
757 status = bot_scsi_inquiry(udev, pmsc->cbw_struct.bCBWLUN);
758 break;
759
760 case MSC_CMD_START_STOP:
761 status = bot_scsi_start_stop(udev, pmsc->cbw_struct.bCBWLUN);
762 break;
763
764 case MSC_CMD_MODE_SENSE6:
765 status = bot_scsi_mode_sense6(udev, pmsc->cbw_struct.bCBWLUN);
766 break;
767
768 case MSC_CMD_MODE_SENSE10:
769 status = bot_scsi_mode_sense10(udev, pmsc->cbw_struct.bCBWLUN);
770 break;
771
772 case MSC_CMD_ALLOW_MEDIUM_REMOVAL:
773 status = bot_scsi_allow_medium_removal(udev, pmsc->cbw_struct.bCBWLUN);
774 break;
775
776 case MSC_CMD_READ_10:
777 status = bot_scsi_read10(udev, pmsc->cbw_struct.bCBWLUN);
778 break;
779
780 case MSC_CMD_READ_CAPACITY:
781 status = bot_scsi_capacity(udev, pmsc->cbw_struct.bCBWLUN);
782 break;
783
784 case MSC_CMD_REQUEST_SENSE:
785 status = bot_scsi_request_sense(udev, pmsc->cbw_struct.bCBWLUN);
786 break;
787
788 case MSC_CMD_TEST_UNIT:
789 status = bot_scsi_test_unit(udev, pmsc->cbw_struct.bCBWLUN);
790 break;
791
792 case MSC_CMD_VERIFY:
793 status = bot_scsi_verify(udev, pmsc->cbw_struct.bCBWLUN);
794 break;
795
796 case MSC_CMD_WRITE_10:
797 status = bot_scsi_write10(udev, pmsc->cbw_struct.bCBWLUN);
798 break;
799
800 case MSC_CMD_READ_FORMAT_CAPACITY:
801 status = bot_scsi_format_capacity(udev, pmsc->cbw_struct.bCBWLUN);
802 break;
803
804 default:
805 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
806 status = USB_FAIL;
807 break;
808 }
809 return status;
810}
811
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:134
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:100
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:192
msc_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:242
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:193
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:202
cbw_type::CBWCB
uint8_t CBWCB[16]
Definition: cdc_msc_class.h:194
msc_type::blk_size
uint32_t blk_size[1]
Definition: cdc_msc_class.h:232
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:205
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:203
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:204
msc_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:243
msc_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:235
msc_type::data
uint8_t data[4096]
Definition: cdc_msc_class.h:238
msc_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:234
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:229
msc_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:228
msc_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:227
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:190
msc_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:237
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:189
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:188
msc_type::blk_nbr
uint32_t blk_nbr[1]
Definition: cdc_msc_class.h:231
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:191
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:55
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:56
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: msc/msc_bot_scsi.c:504
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:143
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: msc/msc_bot_scsi.c:409
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: msc/msc_bot_scsi.c:539
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: msc/msc_bot_scsi.c:598
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: msc/msc_bot_scsi.c:303
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: msc/msc_bot_scsi.c:659
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:125
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: msc/msc_bot_scsi.c:457
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: msc/msc_bot_scsi.c:288
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: msc/msc_bot_scsi.c:196
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: msc/msc_bot_scsi.c:570
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: msc/msc_bot_scsi.c:423
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:102
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: msc/msc_bot_scsi.c:749
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:172
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: msc/msc_bot_scsi.c:437
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: msc/msc_bot_scsi.c:320
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: msc/msc_bot_scsi.c:243
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: msc/msc_bot_scsi.c:346
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: msc/msc_bot_scsi.c:368
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: msc/msc_bot_scsi.c:477
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:729
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: msc/msc_bot_scsi.c:264
ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL
Definition: msc/msc_bot_scsi.c:44
MSC_STATE_MACHINE_DATA_IN
#define MSC_STATE_MACHINE_DATA_IN
Definition: cdc_msc_class.h:119
MSC_CMD_START_STOP
#define MSC_CMD_START_STOP
Definition: cdc_msc_class.h:86
MSC_CMD_VERIFY
#define MSC_CMD_VERIFY
Definition: cdc_msc_class.h:96
ADDRESS_OUT_OF_RANGE
#define ADDRESS_OUT_OF_RANGE
Definition: cdc_msc_class.h:151
SENSE_KEY_HARDWARE_ERROR
#define SENSE_KEY_HARDWARE_ERROR
Definition: cdc_msc_class.h:136
MEDIUM_NOT_PRESENT
#define MEDIUM_NOT_PRESENT
Definition: cdc_msc_class.h:152
MSC_CMD_MODE_SENSE6
#define MSC_CMD_MODE_SENSE6
Definition: cdc_msc_class.h:87
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:155
MSC_CMD_ALLOW_MEDIUM_REMOVAL
#define MSC_CMD_ALLOW_MEDIUM_REMOVAL
Definition: cdc_msc_class.h:89
CSW_CMD_LENGTH
#define CSW_CMD_LENGTH
Definition: cdc_msc_class.h:112
MSC_BOT_STATE_IDLE
#define MSC_BOT_STATE_IDLE
Definition: cdc_msc_class.h:127
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:82
CSW_DCSWSIGNATURE
#define CSW_DCSWSIGNATURE
Definition: cdc_msc_class.h:113
MSC_CMD_INQUIRY
#define MSC_CMD_INQUIRY
Definition: cdc_msc_class.h:85
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:81
INVALID_COMMAND
#define INVALID_COMMAND
Definition: cdc_msc_class.h:147
MSC_CMD_WRITE_10
#define MSC_CMD_WRITE_10
Definition: cdc_msc_class.h:97
MSC_STATE_MACHINE_IDLE
#define MSC_STATE_MACHINE_IDLE
Definition: cdc_msc_class.h:125
MSC_CMD_READ_FORMAT_CAPACITY
#define MSC_CMD_READ_FORMAT_CAPACITY
Definition: cdc_msc_class.h:93
MSC_CMD_MODE_SENSE10
#define MSC_CMD_MODE_SENSE10
Definition: cdc_msc_class.h:88
SENSE_KEY_ILLEGAL_REQUEST
#define SENSE_KEY_ILLEGAL_REQUEST
Definition: cdc_msc_class.h:137
MSC_STATE_MACHINE_DATA_OUT
#define MSC_STATE_MACHINE_DATA_OUT
Definition: cdc_msc_class.h:120
CSW_BCSWSTATUS_PASS
#define CSW_BCSWSTATUS_PASS
Definition: cdc_msc_class.h:114
INVALID_FIELED_IN_COMMAND
#define INVALID_FIELED_IN_COMMAND
Definition: cdc_msc_class.h:148
REQ_SENSE_STANDARD_DATA_LEN
#define REQ_SENSE_STANDARD_DATA_LEN
Definition: cdc_msc_class.h:131
MSC_STATE_MACHINE_SEND_DATA
#define MSC_STATE_MACHINE_SEND_DATA
Definition: cdc_msc_class.h:121
CBW_DCBWSIGNATURE
#define CBW_DCBWSIGNATURE
Definition: cdc_msc_class.h:108
MSC_CMD_READ_10
#define MSC_CMD_READ_10
Definition: cdc_msc_class.h:90
MSC_BOT_STATE_RECOVERY
#define MSC_BOT_STATE_RECOVERY
Definition: cdc_msc_class.h:128
CBW_CMD_LENGTH
#define CBW_CMD_LENGTH
Definition: cdc_msc_class.h:107
MSC_STATE_MACHINE_LAST_DATA
#define MSC_STATE_MACHINE_LAST_DATA
Definition: cdc_msc_class.h:122
MSC_CMD_TEST_UNIT
#define MSC_CMD_TEST_UNIT
Definition: cdc_msc_class.h:95
CSW_BCSWSTATUS_FAILED
#define CSW_BCSWSTATUS_FAILED
Definition: cdc_msc_class.h:115
MSC_CMD_READ_CAPACITY
#define MSC_CMD_READ_CAPACITY
Definition: cdc_msc_class.h:92
MSC_BOT_STATE_ERROR
#define MSC_BOT_STATE_ERROR
Definition: cdc_msc_class.h:129
MSC_CMD_REQUEST_SENSE
#define MSC_CMD_REQUEST_SENSE
Definition: cdc_msc_class.h:94
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:280
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:259
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file
msc_type
Definition: cdc_msc_class.h:226
sense_type
request sense standard data
Definition: cdc_msc_class.h:212
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111


AT32F413 Firmwary Library: msc_diskio.c Source File

  • usb_device
  • msc
  • src
msc/src/msc_diskio.c
Go to the documentation of this file.
1
24#include "msc_diskio.h"
25#include "msc_bot_scsi.h"
26
34uint32_t sector_size = 2048;
35uint32_t msc_flash_size;
36uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
37{
38 /* lun = 0 */
39 {
40 0x00, /* peripheral device type (direct-access device) */
41 0x80, /* removable media bit */
42 0x00, /* ansi version, ecma version, iso version */
43 0x01, /* respond data format */
44 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
45 0x00, 0x00, 0x00, /* reserved */
46 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
47 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
48 '2', '.', '0', '0' /* product revision level */
49 }
50};
51
57uint8_t *get_inquiry(uint8_t lun)
58{
59 if(lun < MSC_SUPPORT_MAX_LUN)
60 return (uint8_t *)scsi_inquiry[lun];
61 else
62 return NULL;
63}
64
73 usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
74{
75 uint32_t i = 0;
76 uint32_t flash_addr = (uint32_t)addr + USB_FLASH_ADDR_OFFSET;
77 switch(lun)
78 {
79 case 0:
80 for(i = 0; i < len; i ++)
81 {
82 read_buf[i] = *((uint8_t *)flash_addr);
83 flash_addr += 1;
84 }
85 break;
86 case 1:
87 break;
88 }
89 return USB_OK;
90}
91
100 usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
101{
102 uint32_t flash_addr = (uint32_t)addr + USB_FLASH_ADDR_OFFSET;
103 uint32_t i = 0, page_len = 2048, tolen = len;
104 uint32_t erase_addr = flash_addr;
105 switch(lun)
106 {
107 case 0:
108 flash_unlock();
109 while(tolen >= page_len)
110 {
111 flash_sector_erase(erase_addr);
112 tolen -= page_len;
113 erase_addr += page_len;
114 }
115 for(i = 0; i < len; i ++)
116 {
117 flash_byte_program(flash_addr+i, buf[i]);
118 }
119 flash_lock();
120 break;
121 case 1:
122 break;
123 }
124 return USB_OK;
125}
126
134 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
135{
136 uint32_t flash_s = *((uint32_t *)0x1FFFF7E0);
137 msc_flash_size = (flash_s << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
138
139 if(flash_s < 256)
140 {
141 sector_size = SECTOR_SIZE_1K;
142 }
143 else
144 {
145 sector_size = SECTOR_SIZE_2K;
146 }
147
148 switch(lun)
149 {
150 case INTERNAL_FLASH_LUN:
151 *blk_nbr = msc_flash_size / sector_size;
152 *blk_size = sector_size;
153 break;
154 case SPI_FLASH_LUN:
155 break;
156 case SD_LUN:
157 break;
158 default:
159 break;
160 }
161 return USB_OK;
162}
163
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: composite_vcp_msc/inc/msc_diskio.h:47
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:43
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:134
msc_flash_size
uint32_t msc_flash_size
Definition: msc/src/msc_diskio.c:35
sector_size
uint32_t sector_size
Definition: msc/src/msc_diskio.c:34
SD_LUN
#define SD_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:45
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: msc/src/msc_diskio.c:36
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:44
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:100
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:489
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:59
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:60
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:155
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:81
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file


AT32F413 Firmwary Library: msc_bot_scsi.h Source File

  • middlewares
  • usbd_class
  • msc
msc_bot_scsi.h
Go to the documentation of this file.
1
24/* define to prevent recursive inclusion -------------------------------------*/
25#ifndef __MSC_BOT_SCSI_H
26#define __MSC_BOT_SCSI_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "msc_class.h"
33#include "usbd_core.h"
34
47#define MSC_SUPPORT_MAX_LUN 1
48#define MSC_MAX_DATA_BUF_LEN 4096
49
50#define MSC_CMD_FORMAT_UNIT 0x04
51#define MSC_CMD_INQUIRY 0x12
52#define MSC_CMD_START_STOP 0x1B
53#define MSC_CMD_MODE_SENSE6 0x1A
54#define MSC_CMD_MODE_SENSE10 0x5A
55#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
56#define MSC_CMD_READ_10 0x28
57#define MSC_CMD_READ_12 0xA8
58#define MSC_CMD_READ_CAPACITY 0x25
59#define MSC_CMD_READ_FORMAT_CAPACITY 0x23
60#define MSC_CMD_REQUEST_SENSE 0x03
61#define MSC_CMD_TEST_UNIT 0x00
62#define MSC_CMD_VERIFY 0x2F
63#define MSC_CMD_WRITE_10 0x2A
64#define MSC_CMD_WRITE_12 0xAA
65#define MSC_CMD_WRITE_VERIFY 0x2E
66
67#define MSC_REQ_GET_MAX_LUN 0xFE
68#define MSC_REQ_BO_RESET 0xFF
70#define SET_LINE_CODING 0x20
71#define GET_LINE_CODING 0x21
72
73#define CBW_CMD_LENGTH 31
74#define CBW_DCBWSIGNATURE 0x43425355
75#define CBW_BMCBWFLAGS_DIR_OUT 0x00
76#define CBW_BMCBWFLAGS_DIR_IN 0x80
77
78#define CSW_CMD_LENGTH 13
79#define CSW_DCSWSIGNATURE 0x53425355
80#define CSW_BCSWSTATUS_PASS 0x00
81#define CSW_BCSWSTATUS_FAILED 0x01
82#define CSW_BCSWSTATUS_PHASE_ERR 0x02
83
84#define MSC_STATE_MACHINE_CMD 0x00
85#define MSC_STATE_MACHINE_DATA_IN 0x01
86#define MSC_STATE_MACHINE_DATA_OUT 0x02
87#define MSC_STATE_MACHINE_SEND_DATA 0x03
88#define MSC_STATE_MACHINE_LAST_DATA 0x04
89#define MSC_STATE_MACHINE_STATUS 0x05
90#define MSC_STATE_MACHINE_FAILED 0x06
91#define MSC_STATE_MACHINE_IDLE 0x07
92
93#define MSC_BOT_STATE_IDLE 0x00
94#define MSC_BOT_STATE_RECOVERY 0x01
95#define MSC_BOT_STATE_ERROR 0x02
96
97#define REQ_SENSE_STANDARD_DATA_LEN 0x12
98#define SENSE_KEY_NO_SENSE 0x00
99#define SENSE_KEY_RECOVERED_ERROR 0x01
100#define SENSE_KEY_NOT_READY 0x02
101#define SENSE_KEY_MEDIUM_ERROR 0x03
102#define SENSE_KEY_HARDWARE_ERROR 0x04
103#define SENSE_KEY_ILLEGAL_REQUEST 0x05
104#define SENSE_KEY_UNIT_ATTENTION 0x06
105#define SENSE_KEY_DATA_PROTECT 0x07
106#define SENSE_KEY_BLANK_CHECK 0x08
107#define SENSE_KEY_VENDERO_SPECIFIC 0x09
108#define SENSE_KEY_ABORTED_COMMAND 0x0B
109#define SENSE_KEY_VOLUME_OVERFLOW 0x0D
110#define SENSE_KEY_MISCOMPARE 0x0E
111
112
113#define INVALID_COMMAND 0x20
114#define INVALID_FIELED_IN_COMMAND 0x24
115#define PARAMETER_LIST_LENGTH_ERROR 0x1A
116#define INVALID_FIELD_IN_PARAMETER_LIST 0x26
117#define ADDRESS_OUT_OF_RANGE 0x21
118#define MEDIUM_NOT_PRESENT 0x3A
119#define MEDIUM_HAVE_CHANGED 0x28
120
121#define SCSI_INQUIRY_DATA_LENGTH 36
122
126typedef struct
127{
128 uint8_t opcode;
129 uint8_t lun;
130 uint32_t address;
131 uint8_t reserved1;
132 uint32_t alloc_length;
133 uint16_t reserved2;
134}cbd_typical_type;
135
139typedef struct
140{
141 uint8_t opcode;
142 uint8_t lun;
143 uint32_t address;
144 uint8_t reserved1;
145 uint32_t alloc_length;
146 uint16_t reserved2;
147}cbd_extended_type;
148
152typedef struct
153{
154 uint32_t dCBWSignature;
155 uint32_t dCBWTage;
156 uint32_t dCBWDataTransferLength;
157 uint8_t bmCBWFlags;
158 uint8_t bCBWLUN;
159 uint8_t bCBWCBLength;
160 uint8_t CBWCB[16];
161}cbw_type;
162
166typedef struct
167{
168 uint32_t dCSWSignature;
169 uint32_t dCSWTag;
170 uint32_t dCSWDataResidue;
171 uint32_t bCSWStatus;
172}csw_type;
173
177typedef struct
178{
179 uint8_t err_code;
180 uint8_t reserved1;
181 uint8_t sense_key;
182 uint32_t information;
183 uint8_t as_length;
184 uint32_t reserved2;
185 uint8_t asc;
186 uint8_t ascq;
187 uint32_t reserved3;
188}sense_type;
189
190
191typedef struct
192{
193 uint8_t msc_state;
194 uint8_t bot_status;
195 uint32_t max_lun;
196
197 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
198 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
199
200 uint64_t blk_addr;
201 uint32_t blk_len;
202
203 uint32_t data_len;
204 uint8_t data[MSC_MAX_DATA_BUF_LEN];
205
206 uint32_t alt_setting;
207
208 cbw_type cbw_struct;
209 csw_type csw_struct;
210
211}msc_type;
212
213void bot_scsi_init(void *udev);
214void bot_scsi_reset(void *udev);
215void bot_scsi_datain_handler(void *pudev, uint8_t ept_num);
216void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num);
217void bot_cbw_decode(void *udev);
218void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len);
219void bot_scsi_send_csw(void *udev, uint8_t status);
220void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc);
221 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count);
222void bot_scsi_stall(void *udev);
223 usb_sts_type bot_scsi_cmd_process(void *udev);
224
225 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun);
226 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun);
227 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun);
228 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun);
229 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun);
230 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun);
231 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun);
232 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun);
233 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun);
234 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun);
235 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun);
236 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun);
237void bot_scsi_clear_feature(void *udev, uint8_t ept_num);
238
250#ifdef __cplusplus
251}
252#endif
253
254#endif
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:503
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: composite_cdc_msc/msc_bot_scsi.c:408
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: composite_cdc_msc/msc_bot_scsi.c:538
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: composite_cdc_msc/msc_bot_scsi.c:171
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: msc_bot_scsi.h:48
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: composite_cdc_msc/msc_bot_scsi.c:597
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: composite_cdc_msc/msc_bot_scsi.c:302
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: msc_bot_scsi.h:47
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: composite_cdc_msc/msc_bot_scsi.c:658
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:124
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: composite_cdc_msc/msc_bot_scsi.c:456
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: composite_cdc_msc/msc_bot_scsi.c:287
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: composite_cdc_msc/msc_bot_scsi.c:195
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: composite_cdc_msc/msc_bot_scsi.c:569
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: composite_cdc_msc/msc_bot_scsi.c:422
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:102
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: composite_cdc_msc/msc_bot_scsi.c:748
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: composite_cdc_msc/msc_bot_scsi.c:142
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: composite_cdc_msc/msc_bot_scsi.c:436
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: composite_cdc_msc/msc_bot_scsi.c:319
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: composite_cdc_msc/msc_bot_scsi.c:242
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: composite_cdc_msc/msc_bot_scsi.c:345
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: composite_cdc_msc/msc_bot_scsi.c:367
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:476
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: composite_cdc_msc/msc_bot_scsi.c:728
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: composite_cdc_msc/msc_bot_scsi.c:263
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
msc_class.h
usb msc class file
cbd_extended_type
extended command block description
Definition: cdc_msc_class.h:174
cbd_typical_type
typical command block description
Definition: cdc_msc_class.h:161
cbw_type
command block wrapper
Definition: cdc_msc_class.h:187
csw_type
command block wrapper
Definition: cdc_msc_class.h:201
msc_type
Definition: cdc_msc_class.h:226
msc_type::blk_addr
uint64_t blk_addr
Definition: msc_bot_scsi.h:200
sense_type
request sense standard data
Definition: cdc_msc_class.h:212
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_class.c Source File

  • middlewares
  • usbd_class
  • msc
msc_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "msc_class.h"
26#include "msc_desc.h"
27#include "msc_bot_scsi.h"
28
42static usb_sts_type class_init_handler(void *udev);
43static usb_sts_type class_clear_handler(void *udev);
44static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
45static usb_sts_type class_ept0_tx_handler(void *udev);
46static usb_sts_type class_ept0_rx_handler(void *udev);
47static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_sof_handler(void *udev);
50static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
51
52 msc_type msc_struct;
53
54/* usb device class handler */
55 usbd_class_handler msc_class_handler =
56{
57 class_init_handler,
58 class_clear_handler,
59 class_setup_handler,
60 class_ept0_tx_handler,
61 class_ept0_rx_handler,
62 class_in_handler,
63 class_out_handler,
64 class_sof_handler,
65 class_event_handler,
66 &msc_struct
67};
68
74static usb_sts_type class_init_handler(void *udev)
75{
76 usb_sts_type status = USB_OK;
77 usbd_core_type *pudev = (usbd_core_type *)udev;
78
79 /* open in endpoint */
80 usbd_ept_open(pudev, USBD_MSC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
81
82 /* open out endpoint */
83 usbd_ept_open(pudev, USBD_MSC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
84
85 bot_scsi_init(udev);
86
87 return status;
88}
89
95static usb_sts_type class_clear_handler(void *udev)
96{
97 usb_sts_type status = USB_OK;
98 usbd_core_type *pudev = (usbd_core_type *)udev;
99
100 /* close in endpoint */
101 usbd_ept_close(pudev, USBD_MSC_BULK_IN_EPT);
102
103 /* close out endpoint */
104 usbd_ept_close(pudev, USBD_MSC_BULK_OUT_EPT);
105
106 return status;
107}
108
115static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
116{
117 usb_sts_type status = USB_OK;
118 usbd_core_type *pudev = (usbd_core_type *)udev;
119 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
120 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
121 {
122 /* class request */
123 case USB_REQ_TYPE_CLASS:
124
125 switch(setup->bRequest)
126 {
127 case MSC_REQ_GET_MAX_LUN:
128 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->max_lun, 1);
129 break;
130 case MSC_REQ_BO_RESET:
131 bot_scsi_reset(udev);
132 usbd_ctrl_send_status(pudev);
133 break;
134 default:
135 usbd_ctrl_unsupport(pudev);
136 break;
137
138 }
139 break;
140 /* standard request */
141 case USB_REQ_TYPE_STANDARD:
142
143 switch(setup->bRequest)
144 {
145 case USB_STD_REQ_GET_DESCRIPTOR:
146 usbd_ctrl_unsupport(pudev);
147 break;
148 case USB_STD_REQ_GET_INTERFACE:
149 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->alt_setting, 1);
150 break;
151 case USB_STD_REQ_SET_INTERFACE:
152 pmsc->alt_setting = setup->wValue;
153 break;
154 case USB_STD_REQ_CLEAR_FEATURE:
155 usbd_ept_close(pudev, (uint8_t)setup->wIndex);
156
157 if((setup->wIndex & 0x80) == 0x80)
158 {
159 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_IN_MAXPACKET_SIZE);
160 }
161 else
162 {
163 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
164 }
165 bot_scsi_clear_feature(udev, setup->wIndex);
166 break;
167 case USB_STD_REQ_SET_FEATURE:
168 break;
169 default:
170 usbd_ctrl_unsupport(pudev);
171 break;
172 }
173 break;
174 default:
175 usbd_ctrl_unsupport(pudev);
176 break;
177 }
178 return status;
179}
180
186static usb_sts_type class_ept0_tx_handler(void *udev)
187{
188 usb_sts_type status = USB_OK;
189
190 /* ...user code... */
191
192 return status;
193}
194
200static usb_sts_type class_ept0_rx_handler(void *udev)
201{
202 usb_sts_type status = USB_OK;
203 usbd_core_type *pudev = (usbd_core_type *)udev;
204 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
205 /* ...user code... */
206 return status;
207}
208
215static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
216{
217 usb_sts_type status = USB_OK;
218
219 bot_scsi_datain_handler(udev, ept_num);
220 return status;
221}
222
229static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
230{
231 usb_sts_type status = USB_OK;
232 bot_scsi_dataout_handler(udev, ept_num);
233 return status;
234}
235
241static usb_sts_type class_sof_handler(void *udev)
242{
243 usb_sts_type status = USB_OK;
244
245 /* ...user code... */
246
247 return status;
248}
249
256static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
257{
258 usb_sts_type status = USB_OK;
259 switch(event)
260 {
261 case USBD_RESET_EVENT:
262
263 /* ...user code... */
264
265 break;
266 case USBD_SUSPEND_EVENT:
267
268 /* ...user code... */
269
270 break;
271 case USBD_WAKEUP_EVENT:
272 /* ...user code... */
273
274 break;
275
276 default:
277 break;
278 }
279 return status;
280}
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:229
msc_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:240
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:55
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:56
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:143
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:125
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:102
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:172
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:729
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:203
MSC_REQ_BO_RESET
#define MSC_REQ_BO_RESET
Definition: cdc_msc_class.h:102
MSC_REQ_GET_MAX_LUN
#define MSC_REQ_GET_MAX_LUN
Definition: cdc_msc_class.h:101
USBD_OUT_MAXPACKET_SIZE
#define USBD_OUT_MAXPACKET_SIZE
Definition: msc_class.h:51
USBD_IN_MAXPACKET_SIZE
#define USBD_IN_MAXPACKET_SIZE
Definition: msc_class.h:50
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: msc_class.c:241
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: msc_class.c:215
msc_struct
msc_type msc_struct
Definition: msc_class.c:52
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: msc_class.c:95
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: msc_class.c:115
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: msc_class.c:186
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: msc_class.c:200
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: msc_class.c:256
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: msc_class.c:74
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:55
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: msc_class.c:229
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:209
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
msc_type
Definition: cdc_msc_class.h:226
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:294
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_class.h Source File

  • middlewares
  • usbd_class
  • msc
msc_class.h
Go to the documentation of this file.
1
24 /* define to prevent recursive inclusion -------------------------------------*/
25#ifndef __MSC_CLASS_H
26#define __MSC_CLASS_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "usb_std.h"
33#include "usbd_core.h"
34
47#define USBD_MSC_BULK_IN_EPT 0x81
48#define USBD_MSC_BULK_OUT_EPT 0x01
49
50#define USBD_IN_MAXPACKET_SIZE 0x40
51#define USBD_OUT_MAXPACKET_SIZE 0x40
52
53
54extern usbd_class_handler msc_class_handler;
66#ifdef __cplusplus
67}
68#endif
69
70#endif
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:55
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_desc.c Source File

  • middlewares
  • usbd_class
  • msc
msc_desc.c
Go to the documentation of this file.
1
24#include "stdio.h"
25#include "usb_std.h"
26#include "usbd_sdr.h"
27#include "usbd_core.h"
28#include "msc_desc.h"
29
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57#if defined ( __ICCARM__ ) /* iar compiler */
58 #pragma data_alignment=4
59#endif
60ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
61
65 usbd_desc_handler msc_desc_handler =
66{
67 get_device_descriptor,
68 get_device_qualifier,
69 get_device_configuration,
70 get_device_other_speed,
71 get_device_lang_id,
72 get_device_manufacturer_string,
73 get_device_product_string,
74 get_device_serial_string,
75 get_device_interface_string,
76 get_device_config_string,
77};
78
82#if defined ( __ICCARM__ ) /* iar compiler */
83 #pragma data_alignment=4
84#endif
85ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
86{
87 USB_DEVICE_DESC_LEN, /* bLength */
88 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
89 0x00, /* bcdUSB */
90 0x02,
91 0x00, /* bDeviceClass */
92 0x00, /* bDeviceSubClass */
93 0x00, /* bDeviceProtocol */
94 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
95 LBYTE(USBD_MSC_VENDOR_ID), /* idVendor */
96 HBYTE(USBD_MSC_VENDOR_ID), /* idVendor */
97 LBYTE(USBD_MSC_PRODUCT_ID), /* idProduct */
98 HBYTE(USBD_MSC_PRODUCT_ID), /* idProduct */
99 0x00, /* bcdDevice rel. 2.00 */
100 0x02,
101 USB_MFC_STRING, /* Index of manufacturer string */
102 USB_PRODUCT_STRING, /* Index of product string */
103 USB_SERIAL_STRING, /* Index of serial number string */
104 1 /* bNumConfigurations */
105};
106
110#if defined ( __ICCARM__ ) /* iar compiler */
111 #pragma data_alignment=4
112#endif
113ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_MSC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
114{
115 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
116 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
117 LBYTE(USBD_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 HBYTE(USBD_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 0x01, /* bNumInterfaces: 2 interface */
120 0x01, /* bConfigurationValue: configuration value */
121 0x04, /* iConfiguration: index of string descriptor describing
122 the configuration */
123 0xC0, /* bmAttributes: self powered */
124 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
125
126 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
127 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
128 0x00, /* bInterfaceNumber: number of interface */
129 0x00, /* bAlternateSetting: alternate set */
130 0x02, /* bNumEndpoints: number of endpoints */
131 USB_CLASS_CODE_MSC, /* bInterfaceClass: msc class code */
132 0x06, /* bInterfaceSubClass: subclass code scsi */
133 0x50, /* bInterfaceProtocol: protocol code BBB */
134 0x05, /* iInterface: index of string descriptor */
135
136 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
137 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
138 USBD_MSC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
139 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
140 LBYTE(USBD_IN_MAXPACKET_SIZE),
141 HBYTE(USBD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
142 0x00, /* bInterval: interval for polling endpoint for data transfers */
143
144 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
145 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
146 USBD_MSC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
147 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
148 LBYTE(USBD_OUT_MAXPACKET_SIZE),
149 HBYTE(USBD_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
150 0x00, /* bInterval: interval for polling endpoint for data transfers */
151};
152
156#if defined ( __ICCARM__ ) /* iar compiler */
157 #pragma data_alignment=4
158#endif
159ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_MSC_SIZ_STRING_LANGID] ALIGNED_TAIL =
160{
161 USBD_MSC_SIZ_STRING_LANGID,
162 USB_DESCIPTOR_TYPE_STRING,
163 0x09,
164 0x04,
165};
166
170#if defined ( __ICCARM__ ) /* iar compiler */
171 #pragma data_alignment=4
172#endif
173ALIGNED_HEAD static uint8_t g_string_serial[USBD_MSC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
174{
175 USBD_MSC_SIZ_STRING_SERIAL,
176 USB_DESCIPTOR_TYPE_STRING,
177};
178
179
180/* device descriptor */
181static usbd_desc_t device_descriptor =
182{
183 USB_DEVICE_DESC_LEN,
184 g_usbd_descriptor
185};
186
187/* config descriptor */
188static usbd_desc_t config_descriptor =
189{
190 USBD_MSC_CONFIG_DESC_SIZE,
191 g_usbd_configuration
192};
193
194/* langid descriptor */
195static usbd_desc_t langid_descriptor =
196{
197 USBD_MSC_SIZ_STRING_LANGID,
198 g_string_lang_id
199};
200
201/* serial descriptor */
202static usbd_desc_t serial_descriptor =
203{
204 USBD_MSC_SIZ_STRING_SERIAL,
205 g_string_serial
206};
207
208static usbd_desc_t vp_desc;
209
216static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
217{
218 uint16_t str_len = 0, id_pos = 2;
219 uint8_t *tmp_str = string;
220
221 while(*tmp_str != '\0')
222 {
223 str_len ++;
224 unicode_buf[id_pos ++] = *tmp_str ++;
225 unicode_buf[id_pos ++] = 0x00;
226 }
227
228 str_len = str_len * 2 + 2;
229 unicode_buf[0] = (uint8_t)str_len;
230 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
231
232 return str_len;
233}
234
242static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
243{
244 uint8_t idx = 0;
245
246 for( idx = 0 ; idx < len ; idx ++)
247 {
248 if( ((value >> 28)) < 0xA )
249 {
250 pbuf[ 2 * idx] = (value >> 28) + '0';
251 }
252 else
253 {
254 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
255 }
256
257 value = value << 4;
258
259 pbuf[2 * idx + 1] = 0;
260 }
261}
262
268static void get_serial_num(void)
269{
270 uint32_t serial0, serial1, serial2;
271
272 serial0 = *(uint32_t*)MCU_ID1;
273 serial1 = *(uint32_t*)MCU_ID2;
274 serial2 = *(uint32_t*)MCU_ID3;
275
276 serial0 += serial2;
277
278 if (serial0 != 0)
279 {
280 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
281 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
282 }
283}
284
290static usbd_desc_t *get_device_descriptor(void)
291{
292 return &device_descriptor;
293}
294
300static usbd_desc_t * get_device_qualifier(void)
301{
302 return NULL;
303}
304
310static usbd_desc_t *get_device_configuration(void)
311{
312 return &config_descriptor;
313}
314
320static usbd_desc_t *get_device_other_speed(void)
321{
322 return NULL;
323}
324
330static usbd_desc_t *get_device_lang_id(void)
331{
332 return &langid_descriptor;
333}
334
335
341static usbd_desc_t *get_device_manufacturer_string(void)
342{
343 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
344 vp_desc.descriptor = g_usbd_desc_buffer;
345 return &vp_desc;
346}
347
353static usbd_desc_t *get_device_product_string(void)
354{
355 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
356 vp_desc.descriptor = g_usbd_desc_buffer;
357 return &vp_desc;
358}
359
365static usbd_desc_t *get_device_serial_string(void)
366{
367 get_serial_num();
368 return &serial_descriptor;
369}
370
376static usbd_desc_t *get_device_interface_string(void)
377{
378 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
379 vp_desc.descriptor = g_usbd_desc_buffer;
380 return &vp_desc;
381}
382
388static usbd_desc_t *get_device_config_string(void)
389{
390 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
391 vp_desc.descriptor = g_usbd_desc_buffer;
392 return &vp_desc;
393}
394
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:55
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:56
USBD_OUT_MAXPACKET_SIZE
#define USBD_OUT_MAXPACKET_SIZE
Definition: msc_class.h:51
USBD_IN_MAXPACKET_SIZE
#define USBD_IN_MAXPACKET_SIZE
Definition: msc_class.h:50
USBD_MSC_SIZ_STRING_SERIAL
#define USBD_MSC_SIZ_STRING_SERIAL
Definition: msc_desc.h:55
USBD_MSC_DESC_PRODUCT_STRING
#define USBD_MSC_DESC_PRODUCT_STRING
Definition: msc_desc.h:58
USBD_MSC_DESC_CONFIGURATION_STRING
#define USBD_MSC_DESC_CONFIGURATION_STRING
Definition: msc_desc.h:59
USBD_MSC_DESC_INTERFACE_STRING
#define USBD_MSC_DESC_INTERFACE_STRING
Definition: msc_desc.h:60
USBD_MSC_CONFIG_DESC_SIZE
#define USBD_MSC_CONFIG_DESC_SIZE
Definition: msc_desc.h:53
USBD_MSC_PRODUCT_ID
#define USBD_MSC_PRODUCT_ID
Definition: msc_desc.h:51
USBD_MSC_SIZ_STRING_LANGID
#define USBD_MSC_SIZ_STRING_LANGID
Definition: msc_desc.h:54
USBD_MSC_VENDOR_ID
#define USBD_MSC_VENDOR_ID
Definition: msc_desc.h:50
USBD_MSC_DESC_MANUFACTURER_STRING
#define USBD_MSC_DESC_MANUFACTURER_STRING
Definition: msc_desc.h:57
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: msc_desc.c:202
device_descriptor
static usbd_desc_t device_descriptor
Definition: msc_desc.c:181
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: msc_desc.c:310
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: msc_desc.c:195
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: msc_desc.c:290
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: msc_desc.c:341
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: msc_desc.c:300
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: msc_desc.c:376
vp_desc
static usbd_desc_t vp_desc
Definition: msc_desc.c:208
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: msc_desc.c:320
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: msc_desc.c:60
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: msc_desc.c:353
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: msc_desc.c:388
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: msc_desc.c:216
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: msc_desc.c:330
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: msc_desc.c:268
config_descriptor
static usbd_desc_t config_descriptor
Definition: msc_desc.c:188
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:65
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: msc_desc.c:365
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: msc_desc.c:242
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
USB_CLASS_CODE_MSC
#define USB_CLASS_CODE_MSC
Definition: usb_std.h:163
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:175
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
msc_desc.h
usb msc descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: msc_desc.h Source File

  • middlewares
  • usbd_class
  • msc
msc_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __MSC_DESC_H
27#define __MSC_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "msc_class.h"
34#include "usbd_core.h"
35
48#define MSC_BCD_NUM 0x0110
49
50#define USBD_MSC_VENDOR_ID 0x2E3C
51#define USBD_MSC_PRODUCT_ID 0x5720
52
53#define USBD_MSC_CONFIG_DESC_SIZE 32
54#define USBD_MSC_SIZ_STRING_LANGID 4
55#define USBD_MSC_SIZ_STRING_SERIAL 0x1A
56
57#define USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
58#define USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
59#define USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
60#define USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
61
62#define MCU_ID1 (0x1FFFF7E8)
63#define MCU_ID2 (0x1FFFF7EC)
64#define MCU_ID3 (0x1FFFF7F0)
65
66extern usbd_desc_handler msc_desc_handler;
67
79#ifdef __cplusplus
80}
81#endif
82
83#endif
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:65
msc_class.h
usb msc class file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: operate_spim.c Source File

  • flash
  • operate_spim
  • src
operate_spim.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "operate_spim.h"
27#include <string.h>
28
29
39uint8_t write_buffer[4096]; /* the content writed to spim flash */
40uint8_t read_buffer[4096]; /* the content read from spim flash */
41
47void spim_init(void)
48{
49 gpio_init_type gpio_init_struct;
50
51 /* enable the clock */
52 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
55
56 /* init spim io */
57 gpio_default_para_init(&gpio_init_struct);
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
61 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
62 gpio_init_struct.gpio_pins = GPIO_PINS_8;
63 gpio_init(GPIOA, &gpio_init_struct);
64 gpio_init_struct.gpio_pins = GPIO_PINS_1 | GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_10 | GPIO_PINS_11;
65 gpio_init(GPIOB, &gpio_init_struct);
66
67 /* enable spim, and select pb10, pb11 as spim io */
68 gpio_pin_remap_config(EXT_SPIM_GMUX_1001, TRUE);
69
70 /* in this example, use on-board en25qh128a as spim flash */
71 flash_spim_model_select(FLASH_SPIM_MODEL2);
72
73 /* unlock the spim flash program erase controller */
74 while(flash_flag_get(FLASH_SPIM_OBF_FLAG));
75 flash_spim_unlock();
76 while(FLASH->ctrl3_bit.oplk);
77
78 /* if the data written to spim flash need to be scrambled, please specify the scrambled range */
79 flash_spim_encryption_range_set(0);
80
81 return;
82}
83
91void sector_read(uint32_t address, uint32_t sector_size, uint8_t *buf)
92{
93 while(sector_size)
94 {
95 *(uint32_t *)buf = *(uint32_t *)address;
96 sector_size -= sizeof(uint32_t);
97 address += sizeof(uint32_t);
98 buf += sizeof(uint32_t);
99 }
100}
101
107void spim_operate(void)
108{
109 uint16_t i = 0;
110 flash_status_type status = FLASH_OPERATE_DONE;
111
112 /* configures the spim flash */
113 spim_init();
114
115 /* fill the content to be writed to spim flash */
116 for(i = 0; i < SPIM_SECTOR_SIZE; i++)
117 {
118 write_buffer[i] = i % 256;
119 }
120
121 /* wait for operation to be completed */
122 status = flash_operation_wait_for(ERASE_TIMEOUT);
123
124 if((status == FLASH_PROGRAM_ERROR) || (status == FLASH_EPP_ERROR))
125 flash_flag_clear(FLASH_PRGMERR_FLAG | FLASH_EPPERR_FLAG);
126 else if(status == FLASH_OPERATE_TIMEOUT)
127 {
128 /* test spim fail */
129 return;
130 }
131 /* erase an spim flash sector */
132 if(flash_sector_erase(SPIM_TEST_ADDR) != FLASH_OPERATE_DONE)
133 {
134 /* test spim fail */
135 return;
136 }
137
138 /* read an spim flash sector */
139 memset(read_buffer, 0, SPIM_SECTOR_SIZE);
140 sector_read(SPIM_TEST_ADDR, SPIM_SECTOR_SIZE, read_buffer);
141
142 /* check if the desired sector are erased */
143 for(i = 0; i < SPIM_SECTOR_SIZE; i++)
144 {
145 if(read_buffer[i] != 0xff)
146 {
147 /* test spim fail */
148 return;
149 }
150 }
151
152 /* program an spim flash sector */
153 i = 0;
154 while(i < SPIM_SECTOR_SIZE)
155 {
156 status = flash_word_program(SPIM_TEST_ADDR + i, *(uint32_t *)(write_buffer + i));
157 if(status != FLASH_OPERATE_DONE)
158 {
159 /* test spim fail */
160 return;
161 }
162 i = i + 4;
163 }
164
165 /* read an spim flash sector */
166 memset(read_buffer, 0, SPIM_SECTOR_SIZE);
167 sector_read(SPIM_TEST_ADDR, SPIM_SECTOR_SIZE, read_buffer);
168
169 /* check if reading result and writing content are the same */
170 for(i = 0; i < SPIM_SECTOR_SIZE; i++)
171 {
172 if(read_buffer[i] != write_buffer[i])
173 {
174 /* test spim fail */
175 return;
176 }
177 }
178
179 while(1)
180 {
181 /* toggle led */
182 at32_led_toggle(LED2);
183 delay_ms(100);
184 at32_led_toggle(LED3);
185 delay_ms(100);
186 at32_led_toggle(LED4);
187 delay_ms(100);
188 }
189}
190
191
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
write_buffer
uint8_t write_buffer[4096]
Definition: operate_spim.c:39
SPIM_SECTOR_SIZE
#define SPIM_SECTOR_SIZE
Definition: operate_spim.h:41
sector_read
void sector_read(uint32_t address, uint32_t sector_size, uint8_t *buf)
read one sector from a specified address in spim flash
Definition: operate_spim.c:91
spim_init
void spim_init(void)
init the spim flash
Definition: operate_spim.c:47
read_buffer
uint8_t read_buffer[4096]
Definition: operate_spim.c:40
SPIM_TEST_ADDR
#define SPIM_TEST_ADDR
Definition: operate_spim.h:42
spim_operate
void spim_operate(void)
operate spim flash
Definition: operate_spim.c:107
sector_size
uint32_t sector_size
Definition: composite_vcp_msc/src/msc_diskio.c:34
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
TRUE
@ TRUE
Definition: at32f413.h:296
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:238
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:744
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:759
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:57
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f413_flash.c:178
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:96
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:157
FLASH_SPIM_MODEL2
@ FLASH_SPIM_MODEL2
Definition: at32f413_flash.h:171
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:161
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f413_flash.h:162
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f413_flash.h:159
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f413_flash.h:160
FLASH_SPIM_OBF_FLAG
#define FLASH_SPIM_OBF_FLAG
Definition: at32f413_flash.h:79
FLASH_PRGMERR_FLAG
#define FLASH_PRGMERR_FLAG
Definition: at32f413_flash.h:77
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f413_flash.h:78
ERASE_TIMEOUT
#define ERASE_TIMEOUT
Definition: at32f413_flash.h:139
FLASH
#define FLASH
Definition: at32f413_flash.h:562
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
EXT_SPIM_GMUX_1001
#define EXT_SPIM_GMUX_1001
Definition: at32f413_gpio.h:189
operate_spim.h
operate_spim header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287


AT32F413 Firmwary Library: operate_spim.h Source File

  • flash
  • operate_spim
  • inc
operate_spim.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __OPERATE_SPIM_H
27#define __OPERATE_SPIM_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#define SPIM_SECTOR_SIZE 4096
42#define SPIM_TEST_ADDR 0x08400000
43
48void spim_operate(void);
49
63#ifdef __cplusplus
64}
65#endif
66
67#endif /* __OPERATE_SPIM_H */
spim_operate
void spim_operate(void)
operate spim flash
Definition: operate_spim.c:107


AT32F413 Firmwary Library: printer_class.c Source File

  • middlewares
  • usbd_class
  • printer
printer_class.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "printer_class.h"
26#include "printer_desc.h"
27
41static usb_sts_type class_init_handler(void *udev);
42static usb_sts_type class_clear_handler(void *udev);
43static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
44static usb_sts_type class_ept0_tx_handler(void *udev);
45static usb_sts_type class_ept0_rx_handler(void *udev);
46static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
47static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
48static usb_sts_type class_sof_handler(void *udev);
49static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
50
51ALIGNED_HEAD static uint8_t printer_device_id[PRINTER_DEVICE_ID_LEN] ALIGNED_TAIL=
52{
53 0x00, 0x16,
54 'M', 'F', 'G',':','A','r','t','e', 'r', 'y' ,' ',
55 'C','M', 'D', ':', 'E', 'S', 'C', 'P', 'O', 'S',' ',
56};
57
58/* static variable */
59 printer_type printer_struct;
60
61/* usb device class handler */
62 usbd_class_handler printer_class_handler =
63{
64 class_init_handler,
65 class_clear_handler,
66 class_setup_handler,
67 class_ept0_tx_handler,
68 class_ept0_rx_handler,
69 class_in_handler,
70 class_out_handler,
71 class_sof_handler,
72 class_event_handler,
73 &printer_struct
74};
75
81static usb_sts_type class_init_handler(void *udev)
82{
83 usb_sts_type status = USB_OK;
84 usbd_core_type *pudev = (usbd_core_type *)udev;
85 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
86
87 /* open in endpoint */
88 usbd_ept_open(pudev, USBD_PRINTER_BULK_IN_EPT, EPT_BULK_TYPE, USBD_PRINTER_IN_MAXPACKET_SIZE);
89
90 /* open out endpoint */
91 usbd_ept_open(pudev, USBD_PRINTER_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_PRINTER_OUT_MAXPACKET_SIZE);
92
93 /* set out endpoint to receive status */
94 usbd_ept_recv(pudev, USBD_PRINTER_BULK_OUT_EPT, pprter->g_rx_buff, USBD_PRINTER_OUT_MAXPACKET_SIZE);
95
96 pprter->g_tx_completed = 1;
97 pprter->g_printer_port_status = 0x18;
98
99 return status;
100}
101
107static usb_sts_type class_clear_handler(void *udev)
108{
109 usb_sts_type status = USB_OK;
110 usbd_core_type *pudev = (usbd_core_type *)udev;
111
112 /* close in endpoint */
113 usbd_ept_close(pudev, USBD_PRINTER_BULK_IN_EPT);
114
115 /* close out endpoint */
116 usbd_ept_close(pudev, USBD_PRINTER_BULK_OUT_EPT);
117
118 return status;
119}
120
127static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
128{
129 usb_sts_type status = USB_OK;
130 usbd_core_type *pudev = (usbd_core_type *)udev;
131 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
132
133 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
134 {
135 /* class request */
136 case USB_REQ_TYPE_CLASS:
137 switch(setup->bRequest)
138 {
139 case PRINTER_REQ_GET_DEVICE_ID:
140 usbd_ctrl_send(pudev, printer_device_id, PRINTER_DEVICE_ID_LEN);
141 break;
142 case PRINTER_REQ_GET_PORT_STATUS:
143 usbd_ctrl_send(pudev, (uint8_t *)&pprter->g_printer_port_status, 1);
144 break;
145 case PRINTER_REQ_GET_SOFT_RESET:
146 usbd_ctrl_recv(pudev, pprter->g_printer_data, USBD_PRINTER_OUT_MAXPACKET_SIZE);
147 break;
148 default:
149 usbd_ctrl_unsupport(pudev);
150 break;
151 }
152 break;
153 /* standard request */
154 case USB_REQ_TYPE_STANDARD:
155 switch(setup->bRequest)
156 {
157 case USB_STD_REQ_GET_DESCRIPTOR:
158 usbd_ctrl_unsupport(pudev);
159 break;
160 case USB_STD_REQ_GET_INTERFACE:
161 usbd_ctrl_send(pudev, (uint8_t *)&pprter->alt_setting, 1);
162 break;
163 case USB_STD_REQ_SET_INTERFACE:
164 pprter->alt_setting = setup->wValue;
165 break;
166 case USB_STD_REQ_CLEAR_FEATURE:
167 break;
168 case USB_STD_REQ_SET_FEATURE:
169 break;
170 default:
171 usbd_ctrl_unsupport(pudev);
172 break;
173 }
174 break;
175 default:
176 usbd_ctrl_unsupport(pudev);
177 break;
178 }
179 return status;
180}
181
187static usb_sts_type class_ept0_tx_handler(void *udev)
188{
189 usb_sts_type status = USB_OK;
190
191 /* ...user code... */
192
193 return status;
194}
195
201static usb_sts_type class_ept0_rx_handler(void *udev)
202{
203 usb_sts_type status = USB_OK;
204
205 /* ...user code... */
206
207 return status;
208}
209
216static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
217{
218 usbd_core_type *pudev = (usbd_core_type *)udev;
219 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
220 usb_sts_type status = USB_OK;
221
222 /* ...user code...
223 trans next packet data
224 */
225 pprter->g_tx_completed = 1;
226
227 return status;
228}
229
236static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
237{
238 usb_sts_type status = USB_OK;
239 usbd_core_type *pudev = (usbd_core_type *)udev;
240 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
241 /* get endpoint receive data length */
242 pprter->g_rxlen = usbd_get_recv_len(pudev, ept_num);
243
244 /*set recv flag*/
245 pprter->g_rx_completed = 1;
246
247 return status;
248}
249
255static usb_sts_type class_sof_handler(void *udev)
256{
257 usb_sts_type status = USB_OK;
258
259 /* ...user code... */
260
261 return status;
262}
263
270static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
271{
272 usb_sts_type status = USB_OK;
273 switch(event)
274 {
275 case USBD_RESET_EVENT:
276
277 /* ...user code... */
278
279 break;
280 case USBD_SUSPEND_EVENT:
281
282 /* ...user code... */
283
284 break;
285 case USBD_WAKEUP_EVENT:
286 /* ...user code... */
287
288 break;
289
290 default:
291 break;
292 }
293 return status;
294}
295
302uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
303{
304 uint16_t i_index = 0;
305 usbd_core_type *pudev = (usbd_core_type *)udev;
306 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
307 uint16_t tmp_len = 0;
308
309 if(pprter->g_rx_completed == 0)
310 {
311 return 0;
312 }
313 pprter->g_rx_completed = 0;
314 tmp_len = pprter->g_rxlen;
315 for(i_index = 0; i_index < pprter->g_rxlen; i_index ++)
316 {
317 recv_data[i_index] = pprter->g_rx_buff[i_index];
318 }
319
320 usbd_ept_recv(pudev, USBD_PRINTER_BULK_OUT_EPT, pprter->g_rx_buff, USBD_PRINTER_OUT_MAXPACKET_SIZE);
321
322 return tmp_len;
323}
324
332 error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
333{
334 error_status status = SUCCESS;
335 usbd_core_type *pudev = (usbd_core_type *)udev;
336 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
337 if(pprter->g_tx_completed)
338 {
339 pprter->g_tx_completed = 0;
340 usbd_ept_send(pudev, USBD_PRINTER_BULK_IN_EPT, send_data, len);
341 }
342 else
343 {
344 status = ERROR;
345 }
346 return status;
347}
348
349
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:203
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:53
USBD_PRINTER_IN_MAXPACKET_SIZE
#define USBD_PRINTER_IN_MAXPACKET_SIZE
Definition: printer_class.h:52
PRINTER_DEVICE_ID_LEN
#define PRINTER_DEVICE_ID_LEN
Definition: printer_class.h:55
USBD_PRINTER_BULK_OUT_EPT
#define USBD_PRINTER_BULK_OUT_EPT
Definition: printer_class.h:49
USBD_PRINTER_BULK_IN_EPT
#define USBD_PRINTER_BULK_IN_EPT
Definition: printer_class.h:48
PRINTER_REQ_GET_SOFT_RESET
@ PRINTER_REQ_GET_SOFT_RESET
Definition: printer_class.h:61
PRINTER_REQ_GET_PORT_STATUS
@ PRINTER_REQ_GET_PORT_STATUS
Definition: printer_class.h:60
PRINTER_REQ_GET_DEVICE_ID
@ PRINTER_REQ_GET_DEVICE_ID
Definition: printer_class.h:59
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: printer_class.c:255
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: printer_class.c:216
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: printer_class.c:107
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: printer_class.c:127
usb_printer_get_rxdata
uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: printer_class.c:302
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: printer_class.c:187
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:62
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: printer_class.c:201
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: printer_class.c:270
usb_printer_send_data
error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: printer_class.c:332
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: printer_class.c:81
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: printer_class.c:236
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t printer_device_id[24] ALIGNED_TAIL
Definition: printer_class.c:51
printer_struct
printer_type printer_struct
Definition: printer_class.c:59
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:84
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:83
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:62
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
printer_class.h
usb printer class file
printer_desc.h
usb printer descriptor header file
printer_type
Definition: printer_class.h:66
printer_type::g_printer_data
uint8_t g_printer_data[0x40]
Definition: printer_class.h:70
printer_type::g_rxlen
uint32_t g_rxlen
Definition: printer_class.h:73
printer_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: printer_class.h:72
printer_type::g_printer_port_status
uint32_t g_printer_port_status
Definition: printer_class.h:68
printer_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: printer_class.h:69
printer_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: printer_class.h:71
printer_type::alt_setting
uint32_t alt_setting
Definition: printer_class.h:67
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: printer_class.h Source File

  • middlewares
  • usbd_class
  • printer
printer_class.h
Go to the documentation of this file.
1
25 /* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __PRINTER_CLASS_H
27#define __PRINTER_CLASS_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "usb_std.h"
34#include "usbd_core.h"
35
48#define USBD_PRINTER_BULK_IN_EPT 0x81
49#define USBD_PRINTER_BULK_OUT_EPT 0x01
50
51
52#define USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
53#define USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
54
55#define PRINTER_DEVICE_ID_LEN 24
56
57typedef enum
58{
59 PRINTER_REQ_GET_DEVICE_ID = 0x00,
60 PRINTER_REQ_GET_PORT_STATUS = 0x01,
61 PRINTER_REQ_GET_SOFT_RESET = 0x02
62}printer_req_type;
63
64
65typedef struct
66{
67 uint32_t alt_setting;
68 uint32_t g_printer_port_status;
69 uint8_t g_rx_buff[USBD_PRINTER_OUT_MAXPACKET_SIZE];
70 uint8_t g_printer_data[USBD_PRINTER_OUT_MAXPACKET_SIZE];
71 __IO uint8_t g_tx_completed;
72 __IO uint8_t g_rx_completed;
73 uint32_t g_rxlen;
74}printer_type;
75
76extern usbd_class_handler printer_class_handler;
77uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data);
78 error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len);
90#ifdef __cplusplus
91}
92#endif
93
94#endif
95
error_status
error_status
error status
Definition: at32f413.h:301
printer_req_type
printer_req_type
Definition: printer_class.h:58
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:53
usb_printer_get_rxdata
uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: printer_class.c:302
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:62
usb_printer_send_data
error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: printer_class.c:332
PRINTER_REQ_GET_SOFT_RESET
@ PRINTER_REQ_GET_SOFT_RESET
Definition: printer_class.h:61
PRINTER_REQ_GET_PORT_STATUS
@ PRINTER_REQ_GET_PORT_STATUS
Definition: printer_class.h:60
PRINTER_REQ_GET_DEVICE_ID
@ PRINTER_REQ_GET_DEVICE_ID
Definition: printer_class.h:59
printer_type
Definition: printer_class.h:66
printer_type::g_rxlen
uint32_t g_rxlen
Definition: printer_class.h:73
printer_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: printer_class.h:72
printer_type::g_printer_port_status
uint32_t g_printer_port_status
Definition: printer_class.h:68
printer_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: printer_class.h:71
printer_type::alt_setting
uint32_t alt_setting
Definition: printer_class.h:67
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: printer_desc.c Source File

  • middlewares
  • usbd_class
  • printer
printer_desc.c
Go to the documentation of this file.
1
24#include "stdio.h"
25#include "usb_std.h"
26#include "usbd_sdr.h"
27#include "usbd_core.h"
28#include "printer_desc.h"
29
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57#if defined ( __ICCARM__ ) /* iar compiler */
58 #pragma data_alignment=4
59#endif
60ALIGNED_HEAD static uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL;
61
65 usbd_desc_handler printer_desc_handler =
66{
67 get_device_descriptor,
68 get_device_qualifier,
69 get_device_configuration,
70 get_device_other_speed,
71 get_device_lang_id,
72 get_device_manufacturer_string,
73 get_device_product_string,
74 get_device_serial_string,
75 get_device_interface_string,
76 get_device_config_string,
77};
78
82#if defined ( __ICCARM__ ) /* iar compiler */
83 #pragma data_alignment=4
84#endif
85ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
86{
87 USB_DEVICE_DESC_LEN, /* bLength */
88 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
89 0x00, /* bcdUSB */
90 0x02,
91 0x00, /* bDeviceClass */
92 0x00, /* bDeviceSubClass */
93 0x00, /* bDeviceProtocol */
94 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
95 LBYTE(USBD_PRINTER_VENDOR_ID), /* idVendor */
96 HBYTE(USBD_PRINTER_VENDOR_ID), /* idVendor */
97 LBYTE(USBD_PRINTER_PRODUCT_ID), /* idProduct */
98 HBYTE(USBD_PRINTER_PRODUCT_ID), /* idProduct */
99 0x00, /* bcdDevice rel. 2.00 */
100 0x02,
101 USB_MFC_STRING, /* Index of manufacturer string */
102 USB_PRODUCT_STRING, /* Index of product string */
103 USB_SERIAL_STRING, /* Index of serial number string */
104 1 /* bNumConfigurations */
105};
106
110#if defined ( __ICCARM__ ) /* iar compiler */
111 #pragma data_alignment=4
112#endif
113ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_PRINTER_CONFIG_DESC_SIZE] ALIGNED_TAIL =
114{
115 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
116 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
117 LBYTE(USBD_PRINTER_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 HBYTE(USBD_PRINTER_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 0x01, /* bNumInterfaces: 1 interface */
120 0x01, /* bConfigurationValue: configuration value */
121 0x00, /* iConfiguration: index of string descriptor describing
122 the configuration */
123 0xC0, /* bmAttributes: self powered */
124 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
125
126 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
127 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
128 0x00, /* bInterfaceNumber: number of interface */
129 0x00, /* bAlternateSetting: alternate set */
130 0x02, /* bNumEndpoints: number of endpoints */
131 USB_CLASS_CODE_PRINTER, /* bInterfaceClass: printer class code */
132 0x01, /* bInterfaceSubClass: subclass code*/
133 PRINTER_PROTOCOL_BI_DIRECTIONAL, /* bInterfaceProtocol: printer interface type */
134 0x00, /* iInterface: index of string descriptor */
135
136 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
137 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
138 USBD_PRINTER_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
139 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
140 LBYTE(USBD_PRINTER_IN_MAXPACKET_SIZE),
141 HBYTE(USBD_PRINTER_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
142 0x00, /* bInterval: interval for polling endpoint for data transfers */
143
144 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
145 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
146 USBD_PRINTER_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
147 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
148 LBYTE(USBD_PRINTER_OUT_MAXPACKET_SIZE),
149 HBYTE(USBD_PRINTER_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
150 0x00, /* bInterval: interval for polling endpoint for data transfers */
151};
152
156#if defined ( __ICCARM__ ) /* iar compiler */
157 #pragma data_alignment=4
158#endif
159ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_PRINTER_SIZ_STRING_LANGID] ALIGNED_TAIL =
160{
161 USBD_PRINTER_SIZ_STRING_LANGID,
162 USB_DESCIPTOR_TYPE_STRING,
163 0x09,
164 0x04,
165};
166
170#if defined ( __ICCARM__ ) /* iar compiler */
171 #pragma data_alignment=4
172#endif
173ALIGNED_HEAD static uint8_t g_string_serial[USBD_PRINTER_SIZ_STRING_SERIAL] ALIGNED_TAIL =
174{
175 USBD_PRINTER_SIZ_STRING_SERIAL,
176 USB_DESCIPTOR_TYPE_STRING,
177};
178
179
180/* device descriptor */
181static usbd_desc_t device_descriptor =
182{
183 USB_DEVICE_DESC_LEN,
184 g_usbd_descriptor
185};
186
187/* config descriptor */
188static usbd_desc_t config_descriptor =
189{
190 USBD_PRINTER_CONFIG_DESC_SIZE,
191 g_usbd_configuration
192};
193
194/* langid descriptor */
195static usbd_desc_t langid_descriptor =
196{
197 USBD_PRINTER_SIZ_STRING_LANGID,
198 g_string_lang_id
199};
200
201/* serial descriptor */
202static usbd_desc_t serial_descriptor =
203{
204 USBD_PRINTER_SIZ_STRING_SERIAL,
205 g_string_serial
206};
207
208static usbd_desc_t vp_desc;
209
216static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
217{
218 uint16_t str_len = 0, id_pos = 2;
219 uint8_t *tmp_str = string;
220
221 while(*tmp_str != '\0')
222 {
223 str_len ++;
224 unicode_buf[id_pos ++] = *tmp_str ++;
225 unicode_buf[id_pos ++] = 0x00;
226 }
227
228 str_len = str_len * 2 + 2;
229 unicode_buf[0] = (uint8_t)str_len;
230 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
231
232 return str_len;
233}
234
242static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
243{
244 uint8_t idx = 0;
245
246 for( idx = 0 ; idx < len ; idx ++)
247 {
248 if( ((value >> 28)) < 0xA )
249 {
250 pbuf[ 2 * idx] = (value >> 28) + '0';
251 }
252 else
253 {
254 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
255 }
256
257 value = value << 4;
258
259 pbuf[2 * idx + 1] = 0;
260 }
261}
262
268static void get_serial_num(void)
269{
270 uint32_t serial0, serial1, serial2;
271
272 serial0 = *(uint32_t*)MCU_ID1;
273 serial1 = *(uint32_t*)MCU_ID2;
274 serial2 = *(uint32_t*)MCU_ID3;
275
276 serial0 += serial2;
277
278 if (serial0 != 0)
279 {
280 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
281 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
282 }
283}
284
290static usbd_desc_t *get_device_descriptor(void)
291{
292 return &device_descriptor;
293}
294
300static usbd_desc_t * get_device_qualifier(void)
301{
302 return NULL;
303}
304
310static usbd_desc_t *get_device_configuration(void)
311{
312 return &config_descriptor;
313}
314
320static usbd_desc_t *get_device_other_speed(void)
321{
322 return NULL;
323}
324
330static usbd_desc_t *get_device_lang_id(void)
331{
332 return &langid_descriptor;
333}
334
335
341static usbd_desc_t *get_device_manufacturer_string(void)
342{
343 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
344 vp_desc.descriptor = g_usbd_desc_buffer;
345 return &vp_desc;
346}
347
353static usbd_desc_t *get_device_product_string(void)
354{
355 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
356 vp_desc.descriptor = g_usbd_desc_buffer;
357 return &vp_desc;
358}
359
365static usbd_desc_t *get_device_serial_string(void)
366{
367 get_serial_num();
368 return &serial_descriptor;
369}
370
376static usbd_desc_t *get_device_interface_string(void)
377{
378 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
379 vp_desc.descriptor = g_usbd_desc_buffer;
380 return &vp_desc;
381}
382
388static usbd_desc_t *get_device_config_string(void)
389{
390 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
391 vp_desc.descriptor = g_usbd_desc_buffer;
392 return &vp_desc;
393}
394
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:213
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:214
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:215
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:53
USBD_PRINTER_IN_MAXPACKET_SIZE
#define USBD_PRINTER_IN_MAXPACKET_SIZE
Definition: printer_class.h:52
USBD_PRINTER_BULK_OUT_EPT
#define USBD_PRINTER_BULK_OUT_EPT
Definition: printer_class.h:49
USBD_PRINTER_BULK_IN_EPT
#define USBD_PRINTER_BULK_IN_EPT
Definition: printer_class.h:48
USBD_PRINTER_DESC_PRODUCT_STRING
#define USBD_PRINTER_DESC_PRODUCT_STRING
Definition: printer_desc.h:58
USBD_PRINTER_CONFIG_DESC_SIZE
#define USBD_PRINTER_CONFIG_DESC_SIZE
Definition: printer_desc.h:53
USBD_PRINTER_DESC_CONFIGURATION_STRING
#define USBD_PRINTER_DESC_CONFIGURATION_STRING
Definition: printer_desc.h:59
PRINTER_PROTOCOL_BI_DIRECTIONAL
#define PRINTER_PROTOCOL_BI_DIRECTIONAL
Definition: printer_desc.h:63
USBD_PRINTER_DESC_INTERFACE_STRING
#define USBD_PRINTER_DESC_INTERFACE_STRING
Definition: printer_desc.h:60
USBD_PRINTER_DESC_MANUFACTURER_STRING
#define USBD_PRINTER_DESC_MANUFACTURER_STRING
Definition: printer_desc.h:57
USBD_PRINTER_PRODUCT_ID
#define USBD_PRINTER_PRODUCT_ID
Definition: printer_desc.h:51
USBD_PRINTER_SIZ_STRING_SERIAL
#define USBD_PRINTER_SIZ_STRING_SERIAL
Definition: printer_desc.h:55
USBD_PRINTER_SIZ_STRING_LANGID
#define USBD_PRINTER_SIZ_STRING_LANGID
Definition: printer_desc.h:54
USBD_PRINTER_VENDOR_ID
#define USBD_PRINTER_VENDOR_ID
Definition: printer_desc.h:50
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: printer_desc.c:202
device_descriptor
static usbd_desc_t device_descriptor
Definition: printer_desc.c:181
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: printer_desc.c:310
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: printer_desc.c:195
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: printer_desc.c:290
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: printer_desc.c:341
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: printer_desc.c:300
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: printer_desc.c:376
vp_desc
static usbd_desc_t vp_desc
Definition: printer_desc.c:208
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: printer_desc.c:320
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_desc_buffer[256] ALIGNED_TAIL
usb device standard descriptor
Definition: printer_desc.c:60
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: printer_desc.c:353
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: printer_desc.c:388
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: printer_desc.c:216
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:65
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: printer_desc.c:330
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: printer_desc.c:268
config_descriptor
static usbd_desc_t config_descriptor
Definition: printer_desc.c:188
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: printer_desc.c:365
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: printer_desc.c:242
USB_CLASS_CODE_PRINTER
#define USB_CLASS_CODE_PRINTER
Definition: usb_std.h:162
HBYTE
#define HBYTE(x)
Definition: usb_std.h:264
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:151
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:240
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:94
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:148
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:175
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:150
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:149
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:93
printer_desc.h
usb printer descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: printer_desc.h Source File

  • middlewares
  • usbd_class
  • printer
printer_desc.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __PRINTER_DESC_H
27#define __PRINTER_DESC_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "printer_class.h"
34#include "usbd_core.h"
35
48#define PRINTER_BCD_NUM 0x0110
49
50#define USBD_PRINTER_VENDOR_ID 0x2E3C
51#define USBD_PRINTER_PRODUCT_ID 0x57FF
52
53#define USBD_PRINTER_CONFIG_DESC_SIZE 32
54#define USBD_PRINTER_SIZ_STRING_LANGID 4
55#define USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
56
57#define USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
58#define USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
59#define USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
60#define USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
61
62#define PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
63#define PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
64#define PRINTER_PROTOCOL_1284_4 0x03
65#define PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
66
67
68#define MCU_ID1 (0x1FFFF7E8)
69#define MCU_ID2 (0x1FFFF7EC)
70#define MCU_ID3 (0x1FFFF7F0)
71
72
73extern usbd_desc_handler printer_desc_handler;
74
86#ifdef __cplusplus
87}
88#endif
89
90#endif
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:65
printer_class.h
usb printer class file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:111


AT32F413 Firmwary Library: usb_conf.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX
56
57
61//#define USB_EPT_AUTO_MALLOC_BUFFER
62
63
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
74
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
77
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
80
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
83
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
86
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
89
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
92
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
95
96#endif
97void usb_delay_ms(uint32_t ms);
98void usb_delay_us(uint32_t us);
99
107#ifdef __cplusplus
108}
109#endif
110
111#endif
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • acc
  • calibration
  • src
project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • acc
  • calibration
  • src
project/at_start_f413/examples/acc/calibration/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • acc
  • calibration
  • src
project/at_start_f413/examples/acc/calibration/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "cdc_class.h"
29#include "cdc_desc.h"
30#include "usbd_int.h"
31
32
33
42 usbd_core_type usb_core_dev;
43uint8_t usb_buffer[256];
44
45/* select system clock source from hext or hick */
46//#define SCLK_FROM_HEXT
47#define SCLK_FROM_HICK
48
49/* ACC_CAL : the step is incremented or decremented by one, the hickcal will be incremented or decremented by 40khz */
50/* ACC_TRIM : the step is incremented or decremented by one, the hicktrim will be incremented or decremented by 20khz */
51/* define ACC_TRIM in order to get higher calibration accuracy */
52//#define ACC_CAL
53#define ACC_TRIM
54
55void system_clock_config_for_acc(void);
56void clkout_config(void);
57
58uint32_t acc_c2_value = 0;
59
60
66void usb_clock48m_select(usb_clk48_s clk_s)
67{
68 if(clk_s == USB_CLK_HICK)
69 {
70 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
71 }
72 else
73 {
74 switch(system_core_clock)
75 {
76 /* 48MHz */
77 case 48000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1);
79 break;
80
81 /* 72MHz */
82 case 72000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
84 break;
85
86 /* 96MHz */
87 case 96000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2);
89 break;
90
91 /* 120MHz */
92 case 120000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
94 break;
95
96 /* 144MHz */
97 case 144000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3);
99 break;
100
101 /* 168MHz */
102 case 168000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
104 break;
105
106 /* 192MHz */
107 case 192000000:
108 crm_usb_clock_div_set(CRM_USB_DIV_4);
109 break;
110
111 default:
112 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
113 break;
114 }
115 }
116}
117
123void USBFS_L_CAN1_RX0_IRQHandler(void)
124{
125 usbd_irq_handler(&usb_core_dev);
126}
127
133void ACC_IRQHandler(void)
134{
135 if(acc_flag_get(ACC_CALRDY_FLAG) != RESET)
136 {
137 at32_led_toggle(LED2);
138
139 /* clear acc calibration ready flag */
140 acc_flag_clear(ACC_CALRDY_FLAG);
141 }
142 if(acc_flag_get(ACC_RSLOST_FLAG) != RESET)
143 {
144 at32_led_toggle(LED3);
145
146 /* clear acc reference signal lost flag */
147 acc_flag_clear(ACC_RSLOST_FLAG);
148 }
149}
150
156void system_clock_config_for_acc(void)
157{
158 /* reset crm */
159 crm_reset();
160
161 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
162
163 /* wait till hick is ready */
164 while(SET != crm_flag_get(CRM_HICK_STABLE_FLAG))
165 {
166 }
167
168 /* config pll clock resource */
169 crm_pll_config(CRM_PLL_SOURCE_HICK, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
170
171 /* enable pll */
172 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
173
174 /* wait till pll is ready */
175 while(SET != crm_flag_get(CRM_PLL_STABLE_FLAG))
176 {
177 }
178
179 /* config ahbclk */
180 crm_ahb_div_set(CRM_AHB_DIV_1);
181
182 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
183 crm_apb2_div_set(CRM_APB2_DIV_2);
184
185 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
186 crm_apb1_div_set(CRM_APB1_DIV_2);
187
188 /* enable auto step mode */
189 crm_auto_step_mode_enable(TRUE);
190
191 /* select pll as system clock source */
192 crm_sysclk_switch(CRM_SCLK_PLL);
193
194 /* wait till pll is used as system clock source */
195 while(CRM_SCLK_PLL != crm_sysclk_switch_status_get())
196 {
197 }
198
199 /* disable auto step mode */
200 crm_auto_step_mode_enable(FALSE);
201
202 /* update system_core_clock global variable */
203 system_core_clock_update();
204
205 /* pa8 output usb clk */
206 clkout_config();
207}
208
214void clkout_config(void)
215{
216 gpio_init_type gpio_init_struct;
217
218 /* enable gpio port clock */
219 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
220
221 /* set default parameter */
222 gpio_default_para_init(&gpio_init_struct);
223
224 /* clkout gpio init */
225 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
226 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
227 gpio_init_struct.gpio_pins = GPIO_PINS_8;
228 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
229 gpio_init(GPIOA, &gpio_init_struct);
230
231 /* config clkout division */
232 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
233
234 /* config clkout clock */
235 crm_clock_out_set(CRM_CLKOUT_USB);
236}
237
243void usb_delay_ms(uint32_t ms)
244{
245 /* user can define self delay function */
246 delay_ms(ms);
247}
248
254void usb_delay_us(uint32_t us)
255{
256 delay_us(us);
257}
258
264int main(void)
265{
266 uint16_t data_len;
267
268 uint32_t timeout;
269
270 uint8_t send_zero_packet = 0;
271
272 /* config nvic priority group */
273 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
274
275 /* sclk = 240mhz from hick */
276 system_clock_config_for_acc();
277
278 at32_board_init();
279
280 usb_clock48m_select(USB_CLK_HICK);
281
282 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
283
284 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 1, 0);
285
286 usbd_core_init(&usb_core_dev, USB, &cdc_class_handler, &cdc_desc_handler, 0);
287
288 usbd_connect(&usb_core_dev);
289
290 /* acc config */
291 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
292
293 /* enable the acc calibration ready interrupt */
294 acc_interrupt_enable(ACC_CALRDYIEN_INT, TRUE);
295
296 /* enable the acc reference signal lost interrupt */
297 acc_interrupt_enable(ACC_EIEN_INT, TRUE);
298
299 /* config nvic for acc int */
300 nvic_irq_enable(ACC_IRQn, 2, 0);
301
302 /* update the c1\c2\c3 value */
303 acc_c2_value = 8000;
304 #ifdef ACC_CAL
305 acc_write_c1(acc_c2_value - 20);
306 acc_write_c2(acc_c2_value);
307 acc_write_c3(acc_c2_value + 20);
308 #else
309 acc_write_c1(acc_c2_value - 10);
310 acc_write_c2(acc_c2_value);
311 acc_write_c3(acc_c2_value + 10);
312 #endif
313
314 /* open acc calibration */
315 #if defined(ACC_CAL)
316 acc_calibration_mode_enable(ACC_CAL_HICKCAL, TRUE);
317 #elif defined(ACC_TRIM)
318 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
319 #endif
320
321 while(1)
322 {
323 /* get usb vcp receive data */
324 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
325
326 if(data_len > 0 || send_zero_packet == 1)
327 {
328
329 /* bulk transfer is complete when the endpoint does one of the following
330 1 has transferred exactly the amount of data expected
331 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
332 */
333 if(data_len > 0)
334 send_zero_packet = 1;
335
336 if(data_len == 0)
337 send_zero_packet = 0;
338
339 timeout = 5000000;
340 do
341 {
342 /* send data to host */
343 if(usb_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
344 {
345 break;
346 }
347 }while(timeout --);
348 }
349 }
350}
351
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
clkout_config
void clkout_config(void)
clkout configuration
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:214
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:66
system_clock_config_for_acc
void system_clock_config_for_acc(void)
system clock config for acc
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:156
ACC_IRQHandler
void ACC_IRQHandler(void)
acc interrupt handler
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:133
main
int main(void)
main function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:264
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
usbfs_l_can1_rx0 interrupt handler
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:123
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:43
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:58
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:42
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
ACC_CAL_HICKCAL
#define ACC_CAL_HICKCAL
Definition: at32f413_acc.h:50
ACC_RSLOST_FLAG
#define ACC_RSLOST_FLAG
Definition: at32f413_acc.h:53
ACC_EIEN_INT
#define ACC_EIEN_INT
Definition: at32f413_acc.h:57
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
ACC_CALRDYIEN_INT
#define ACC_CALRDYIEN_INT
Definition: at32f413_acc.h:56
ACC_CALRDY_FLAG
#define ACC_CALRDY_FLAG
Definition: at32f413_acc.h:54
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f413_acc.c:83
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f413_acc.c:183
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f413_acc.c:199
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:805
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:684
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:292
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:418
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:273
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_CLKOUT_USB
@ CRM_CLKOUT_USB
Definition: at32f413_crm.h:409
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f413_crm.h:53
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
ACC_IRQn
@ ACC_IRQn
Definition: at32f413.h:230
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:343
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:373
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:67
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • combine_mode_ordinary_simult
  • inc
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • combine_mode_ordinary_simult
  • inc
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • combine_mode_ordinary_simult
  • inc
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • combine_mode_ordinary_simult
  • src
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • combine_mode_ordinary_simult
  • src
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern __IO uint32_t adc1_ordinary_valuetab[5][3];
30extern __IO uint32_t dma1_trans_complete_flag;
31
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
142void DMA1_Channel1_IRQHandler(void)
143{
144 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
145 {
146 dma_flag_clear(DMA1_FDT1_FLAG);
147 dma1_trans_complete_flag = 1;
148 }
149}
150
151
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:124
adc1_ordinary_valuetab
__IO uint32_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:37
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:45
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:38
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:142
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:80
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:115
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • combine_mode_ordinary_simult
  • src
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
37__IO uint32_t adc1_ordinary_valuetab[5][3];
38__IO uint32_t dma1_trans_complete_flag = 0;
39
40static void gpio_config(void);
41static void dma_config(void);
42static void adc_config(void);
43
49static void gpio_config(void)
50{
51 gpio_init_type gpio_initstructure;
52 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
54
55 gpio_default_para_init(&gpio_initstructure);
56 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
57 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
58 gpio_init(GPIOA, &gpio_initstructure);
59
60 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
61 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
62 gpio_init(GPIOB, &gpio_initstructure);
63}
64
70static void dma_config(void)
71{
72 dma_init_type dma_init_struct;
73 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
74 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
75 dma_reset(DMA1_CHANNEL1);
76 dma_default_para_init(&dma_init_struct);
77 dma_init_struct.buffer_size = 15;
78 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
79 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
80 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
81 dma_init_struct.memory_inc_enable = TRUE;
82 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
83 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
84 dma_init_struct.peripheral_inc_enable = FALSE;
85 dma_init_struct.priority = DMA_PRIORITY_HIGH;
86 dma_init_struct.loop_mode_enable = FALSE;
87 dma_init(DMA1_CHANNEL1, &dma_init_struct);
88
89 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
90 dma_channel_enable(DMA1_CHANNEL1, TRUE);
91}
92
98static void adc_config(void)
99{
100 adc_base_config_type adc_base_struct;
101 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
102 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
103 crm_adc_clock_div_set(CRM_ADC_DIV_6);
104
105 /* select combine mode */
106 adc_combine_mode_select(ADC_ORDINARY_SMLT_ONLY_MODE);
107 adc_base_default_para_init(&adc_base_struct);
108 adc_base_struct.sequence_mode = TRUE;
109 adc_base_struct.repeat_mode = FALSE;
110 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
111 adc_base_struct.ordinary_channel_length = 3;
112 adc_base_config(ADC1, &adc_base_struct);
113 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
114 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
115 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
116 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
117 adc_dma_mode_enable(ADC1, TRUE);
118
119 adc_base_config(ADC2, &adc_base_struct);
120 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_239_5);
121 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_239_5);
122 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_239_5);
123 adc_ordinary_conversion_trigger_set(ADC2, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
124
125 adc_enable(ADC1, TRUE);
126 adc_enable(ADC2, TRUE);
127 adc_calibration_init(ADC1);
128 while(adc_calibration_init_status_get(ADC1));
129 adc_calibration_start(ADC1);
130 while(adc_calibration_status_get(ADC1));
131 adc_calibration_init(ADC2);
132 while(adc_calibration_init_status_get(ADC2));
133 adc_calibration_start(ADC2);
134 while(adc_calibration_status_get(ADC2));
135}
136
142int main(void)
143{
144 __IO uint32_t index = 0;
145 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
146 system_clock_config();
147 at32_board_init();
148 at32_led_off(LED2);
149 at32_led_off(LED3);
150 at32_led_off(LED4);
151 uart_print_init(115200);
152 gpio_config();
153 dma_config();
154 adc_config();
155 printf("combine_mode_ordinary_simult \r\n");
156 while(dma1_trans_complete_flag == 0)
157 {
158 delay_ms(100);
159 adc_ordinary_software_trigger_enable(ADC1, TRUE);
160 }
161 for(index = 0; index < 5; index++)
162 {
163 printf("adc1_ordinary_channel4[%d] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0] & 0xFFFF);
164 printf("adc1_ordinary_channel5[%d] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1] & 0xFFFF);
165 printf("adc1_ordinary_channel6[%d] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2] & 0xFFFF);
166 printf("adc2_ordinary_channel7[%d] = 0x%x\r\n",index, (adc1_ordinary_valuetab[index][0] >> 16) & 0xFFFF);
167 printf("adc2_ordinary_channel8[%d] = 0x%x\r\n",index, (adc1_ordinary_valuetab[index][1] >> 16) & 0xFFFF);
168 printf("adc2_ordinary_channel9[%d] = 0x%x\r\n",index, (adc1_ordinary_valuetab[index][2] >> 16) & 0xFFFF);
169 printf("\r\n");
170 }
171 at32_led_on(LED2);
172 while(1)
173 {
174 }
175}
176
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:70
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:98
adc1_ordinary_valuetab
__IO uint32_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:37
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:142
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:49
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:117
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:116
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:114
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:115
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:113
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC_ORDINARY_SMLT_ONLY_MODE
@ ADC_ORDINARY_SMLT_ONLY_MODE
Definition: at32f413_adc.h:88
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:156
ADC1
#define ADC1
Definition: at32f413_adc.h:557
ADC2
#define ADC2
Definition: at32f413_adc.h:558
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f413_crm.h:114
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:245
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:255
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • current_vref_value_check
  • inc
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • current_vref_value_check
  • inc
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • current_vref_value_check
  • inc
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • current_vref_value_check
  • src
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • current_vref_value_check
  • src
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
136
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • current_vref_value_check
  • src
project/at_start_f413/examples/adc/current_vref_value_check/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36__IO uint16_t adc1_ordinary_value = 0;
37
38static void dma_config(void);
39static void adc_config(void);
40
46static void dma_config(void)
47{
48 dma_init_type dma_init_struct;
49 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
50 dma_reset(DMA1_CHANNEL1);
51 dma_default_para_init(&dma_init_struct);
52 dma_init_struct.buffer_size = 1;
53 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
54 dma_init_struct.memory_base_addr = (uint32_t)&adc1_ordinary_value;
55 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
56 dma_init_struct.memory_inc_enable = FALSE;
57 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
58 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
59 dma_init_struct.peripheral_inc_enable = FALSE;
60 dma_init_struct.priority = DMA_PRIORITY_HIGH;
61 dma_init_struct.loop_mode_enable = TRUE;
62 dma_init(DMA1_CHANNEL1, &dma_init_struct);
63
64 dma_channel_enable(DMA1_CHANNEL1, TRUE);
65}
66
72static void adc_config(void)
73{
74 adc_base_config_type adc_base_struct;
75 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
76 crm_adc_clock_div_set(CRM_ADC_DIV_6);
77
78 /* select combine mode */
79 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
80 adc_base_default_para_init(&adc_base_struct);
81 adc_base_struct.sequence_mode = FALSE;
82 adc_base_struct.repeat_mode = FALSE;
83 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
84 adc_base_struct.ordinary_channel_length = 1;
85 adc_base_config(ADC1, &adc_base_struct);
86 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_17, 1, ADC_SAMPLETIME_239_5);
87 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
88 adc_dma_mode_enable(ADC1, TRUE);
89 adc_tempersensor_vintrv_enable(TRUE);
90
91 adc_enable(ADC1, TRUE);
92 adc_calibration_init(ADC1);
93 while(adc_calibration_init_status_get(ADC1));
94 adc_calibration_start(ADC1);
95 while(adc_calibration_status_get(ADC1));
96}
97
103int main(void)
104{
105 __IO uint32_t index = 0;
106 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
107 system_clock_config();
108 at32_board_init();
109 at32_led_off(LED2);
110 at32_led_off(LED3);
111 at32_led_off(LED4);
112 uart_print_init(115200);
113 dma_config();
114 adc_config();
115 printf("adc1_vref_check \r\n");
116 while(1)
117 {
118 at32_led_on(LED2);
119 delay_sec(1);
120 adc_ordinary_software_trigger_enable(ADC1, TRUE);
121 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
122 dma_flag_clear(DMA1_FDT1_FLAG);
123 printf("vref_value = %f V\r\n", ((double)1.2 * 4095) / adc1_ordinary_value);
124 }
125}
126
127
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:46
adc1_ordinary_value
__IO uint16_t adc1_ordinary_value
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:36
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:72
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:103
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:628
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f413_adc.h:125
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:156
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern __IO uint16_t adc1_preempt_valuetab[3][3];
30extern __IO uint16_t dma_trans_complete_flag;
31extern __IO uint16_t preempt_trigger_count;
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void DMA1_Channel1_IRQHandler(void)
144{
145 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
146 {
147 dma_flag_clear(DMA1_FDT1_FLAG);
148 dma_trans_complete_flag = 1;
149 }
150}
151
157void ADC1_2_IRQHandler(void)
158{
159 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
160 {
161 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
162 if(preempt_trigger_count < 3)
163 {
164 adc1_preempt_valuetab[preempt_trigger_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
165 adc1_preempt_valuetab[preempt_trigger_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
166 adc1_preempt_valuetab[preempt_trigger_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
167 preempt_trigger_count++;
168 }
169 }
170}
171
172
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[3][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:38
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:107
ADC1_2_IRQHandler
void ADC1_2_IRQHandler(void)
this function handles adc1_2 handler.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:157
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:46
preempt_trigger_count
__IO uint16_t preempt_trigger_count
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:40
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:143
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:116
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:733
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:799
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:770
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:188
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:187
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:186
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f413_adc.h:65
ADC1
#define ADC1
Definition: at32f413_adc.h:557
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
37__IO uint16_t adc1_ordinary_valuetab[3][3] = {0};
38__IO uint16_t adc1_preempt_valuetab[3][3] = {0};
39__IO uint16_t dma_trans_complete_flag = 0;
40__IO uint16_t preempt_trigger_count = 0;
41
42static void gpio_config(void);
43static void exint_config(void);
44static void dma_config(void);
45static void adc_config(void);
46
52static void gpio_config(void)
53{
54 gpio_init_type gpio_initstructure;
55 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
57
58 gpio_default_para_init(&gpio_initstructure);
59 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
60 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
61 gpio_init(GPIOA, &gpio_initstructure);
62
63 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
64 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
65 gpio_init(GPIOB, &gpio_initstructure);
66}
67
73static void exint_config(void)
74{
75 gpio_init_type gpio_initstructure;
76 exint_init_type exint_init_struct;
77
78 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
79 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
80 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
81
82 gpio_default_para_init(&gpio_initstructure);
83 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
84 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
85 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
86 gpio_initstructure.gpio_pins = GPIO_PINS_11;
87 gpio_init(GPIOC, &gpio_initstructure);
88 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
89 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
90 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
91 gpio_initstructure.gpio_pins = GPIO_PINS_15;
92 gpio_init(GPIOA, &gpio_initstructure);
93
94 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOC, GPIO_PINS_SOURCE11);
95 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE15);
96
97 exint_default_para_init(&exint_init_struct);
98 exint_init_struct.line_enable = TRUE;
99 exint_init_struct.line_mode = EXINT_LINE_EVENT;
100 exint_init_struct.line_select = EXINT_LINE_11;
101 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
102 exint_init(&exint_init_struct);
103
104 exint_init_struct.line_select = EXINT_LINE_15;
105 exint_init(&exint_init_struct);
106}
107
113static void dma_config(void)
114{
115 dma_init_type dma_init_struct;
116 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
117 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
118 dma_reset(DMA1_CHANNEL1);
119 dma_default_para_init(&dma_init_struct);
120 dma_init_struct.buffer_size = 9;
121 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
122 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
123 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
124 dma_init_struct.memory_inc_enable = TRUE;
125 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
126 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
127 dma_init_struct.peripheral_inc_enable = FALSE;
128 dma_init_struct.priority = DMA_PRIORITY_HIGH;
129 dma_init_struct.loop_mode_enable = FALSE;
130 dma_init(DMA1_CHANNEL1, &dma_init_struct);
131
132 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
133 dma_channel_enable(DMA1_CHANNEL1, TRUE);
134}
135
141static void adc_config(void)
142{
143 adc_base_config_type adc_base_struct;
144 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
145 crm_adc_clock_div_set(CRM_ADC_DIV_6);
146 nvic_irq_enable(ADC1_2_IRQn, 0, 0);
147
148 /* select combine mode */
149 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
150 adc_base_default_para_init(&adc_base_struct);
151 adc_base_struct.sequence_mode = TRUE;
152 adc_base_struct.repeat_mode = FALSE;
153 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
154 adc_base_struct.ordinary_channel_length = 3;
155 adc_base_config(ADC1, &adc_base_struct);
156 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
157 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
158 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
159 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT, TRUE);
160 adc_dma_mode_enable(ADC1, TRUE);
161 adc_ordinary_part_count_set(ADC1, 1);
162 adc_ordinary_part_mode_enable(ADC1, TRUE);
163
164 adc_preempt_channel_length_set(ADC1, 3);
165 adc_preempt_channel_set(ADC1, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_239_5);
166 adc_preempt_channel_set(ADC1, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_239_5);
167 adc_preempt_channel_set(ADC1, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_239_5);
168 adc_preempt_conversion_trigger_set(ADC1, ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4, TRUE);
169 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
170
171 adc_enable(ADC1, TRUE);
172 adc_calibration_init(ADC1);
173 while(adc_calibration_init_status_get(ADC1));
174 adc_calibration_start(ADC1);
175 while(adc_calibration_status_get(ADC1));
176}
177
183int main(void)
184{
185 __IO uint32_t index = 0;
186 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
187 system_clock_config();
188 at32_board_init();
189 at32_led_off(LED2);
190 at32_led_off(LED3);
191 at32_led_off(LED4);
192 uart_print_init(115200);
193 gpio_config();
194 exint_config();
195 dma_config();
196 adc_config();
197 printf("exint_trigger_partitioned \r\n");
198 while(dma_trans_complete_flag == 0);
199 while(preempt_trigger_count != 3);
200 for(index = 0; index < 3; index++)
201 {
202 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0]);
203 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1]);
204 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2]);
205 printf("adc1_preempt_valuetab[%d][0] = 0x%x\r\n",index, adc1_preempt_valuetab[index][0]);
206 printf("adc1_preempt_valuetab[%d][1] = 0x%x\r\n",index, adc1_preempt_valuetab[index][1]);
207 printf("adc1_preempt_valuetab[%d][2] = 0x%x\r\n",index, adc1_preempt_valuetab[index][2]);
208 printf("\r\n");
209 }
210 at32_led_on(LED2);
211 while(1)
212 {
213 }
214}
215
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[3][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:38
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:39
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:113
exint_config
static void exint_config(void)
exint configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:73
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:141
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:37
preempt_trigger_count
__IO uint16_t preempt_trigger_count
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:183
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:52
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f413_adc.c:573
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:178
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:510
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:424
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:588
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:392
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:117
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:116
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:114
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:115
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:113
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
@ ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
Definition: at32f413_adc.h:174
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
@ ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
Definition: at32f413_adc.h:155
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f413_adc.h:52
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:189
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f413_exint.h:83
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_LINE_15
#define EXINT_LINE_15
Definition: at32f413_exint.h:65
EXINT_LINE_11
#define EXINT_LINE_11
Definition: at32f413_exint.h:61
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f413_gpio.h:263
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f413_gpio.h:267
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:275
GPIO_PORT_SOURCE_GPIOC
@ GPIO_PORT_SOURCE_GPIOC
Definition: at32f413_gpio.h:277
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • internal_temperature_sensor
  • src
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • internal_temperature_sensor
  • src
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
136
137
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • internal_temperature_sensor
  • src
project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
37#define ADC_VREF (3.3)
38#define ADC_TEMP_BASE (1.26)
39#define ADC_TEMP_SLOPE (-0.00423)
40
41__IO uint16_t adc1_ordinary_value = 0;
42
43static void dma_config(void);
44static void adc_config(void);
45
51static void dma_config(void)
52{
53 dma_init_type dma_init_struct;
54 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
55 dma_reset(DMA1_CHANNEL1);
56 dma_default_para_init(&dma_init_struct);
57 dma_init_struct.buffer_size = 1;
58 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
59 dma_init_struct.memory_base_addr = (uint32_t)&adc1_ordinary_value;
60 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
61 dma_init_struct.memory_inc_enable = FALSE;
62 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
63 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
64 dma_init_struct.peripheral_inc_enable = FALSE;
65 dma_init_struct.priority = DMA_PRIORITY_HIGH;
66 dma_init_struct.loop_mode_enable = TRUE;
67 dma_init(DMA1_CHANNEL1, &dma_init_struct);
68
69 dma_channel_enable(DMA1_CHANNEL1, TRUE);
70}
71
77static void adc_config(void)
78{
79 adc_base_config_type adc_base_struct;
80 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
81 crm_adc_clock_div_set(CRM_ADC_DIV_6);
82
83 /* select combine mode */
84 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
85 adc_base_default_para_init(&adc_base_struct);
86 adc_base_struct.sequence_mode = FALSE;
87 adc_base_struct.repeat_mode = TRUE;
88 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
89 adc_base_struct.ordinary_channel_length = 1;
90 adc_base_config(ADC1, &adc_base_struct);
91 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_16, 1, ADC_SAMPLETIME_239_5);
92 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
93 adc_dma_mode_enable(ADC1, TRUE);
94 adc_tempersensor_vintrv_enable(TRUE);
95
96 adc_enable(ADC1, TRUE);
97 adc_calibration_init(ADC1);
98 while(adc_calibration_init_status_get(ADC1));
99 adc_calibration_start(ADC1);
100 while(adc_calibration_status_get(ADC1));
101}
102
108int main(void)
109{
110 __IO uint32_t index = 0;
111 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
112 system_clock_config();
113 at32_board_init();
114 at32_led_off(LED2);
115 at32_led_off(LED3);
116 at32_led_off(LED4);
117 uart_print_init(115200);
118 dma_config();
119 adc_config();
120 printf("internal_temperature_sensor \r\n");
121 adc_ordinary_software_trigger_enable(ADC1, TRUE);
122 while(1)
123 {
124 at32_led_on(LED2);
125 delay_sec(1);
126 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
127 dma_flag_clear(DMA1_FDT1_FLAG);
128 printf("internal_temperature = %f deg C\r\n",(ADC_TEMP_BASE - (double)adc1_ordinary_value * ADC_VREF / 4096) / ADC_TEMP_SLOPE + 25);
129 }
130}
131
132
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:51
adc1_ordinary_value
__IO uint16_t adc1_ordinary_value
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:41
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:77
ADC_VREF
#define ADC_VREF
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:108
ADC_TEMP_SLOPE
#define ADC_TEMP_SLOPE
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:39
ADC_TEMP_BASE
#define ADC_TEMP_BASE
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:628
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f413_adc.h:124
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:156
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • repeat_conversion_loop_transfer
  • inc
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • repeat_conversion_loop_transfer
  • inc
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • repeat_conversion_loop_transfer
  • inc
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • repeat_conversion_loop_transfer
  • src
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • repeat_conversion_loop_transfer
  • src
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern __IO uint16_t dma_trans_complete_flag;
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void DMA1_Channel1_IRQHandler(void)
142{
143 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
144 {
145 dma_flag_clear(DMA1_FDT1_FLAG);
146 dma_trans_complete_flag++;
147 }
148}
149
150
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:44
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:141
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/at32f413_int.c:114
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • repeat_conversion_loop_transfer
  • src
project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36__IO uint16_t adc1_ordinary_valuetab[3] = {0};
37__IO uint16_t dma_trans_complete_flag = 0;
38
39static void gpio_config(void);
40static void dma_config(void);
41static void adc_config(void);
42
48static void gpio_config(void)
49{
50 gpio_init_type gpio_initstructure;
51 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
52
53 gpio_default_para_init(&gpio_initstructure);
54 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
55 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
56 gpio_init(GPIOA, &gpio_initstructure);
57}
58
64static void dma_config(void)
65{
66 dma_init_type dma_init_struct;
67 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
68 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
69 dma_reset(DMA1_CHANNEL1);
70 dma_default_para_init(&dma_init_struct);
71 dma_init_struct.buffer_size = 3;
72 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
73 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
74 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
75 dma_init_struct.memory_inc_enable = TRUE;
76 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
77 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
78 dma_init_struct.peripheral_inc_enable = FALSE;
79 dma_init_struct.priority = DMA_PRIORITY_HIGH;
80 dma_init_struct.loop_mode_enable = TRUE;
81 dma_init(DMA1_CHANNEL1, &dma_init_struct);
82
83 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
84 dma_channel_enable(DMA1_CHANNEL1, TRUE);
85}
86
92static void adc_config(void)
93{
94 adc_base_config_type adc_base_struct;
95 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
96 crm_adc_clock_div_set(CRM_ADC_DIV_6);
97
98 /* select combine mode */
99 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
100 adc_base_default_para_init(&adc_base_struct);
101 adc_base_struct.sequence_mode = TRUE;
102 adc_base_struct.repeat_mode = TRUE;
103 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
104 adc_base_struct.ordinary_channel_length = 3;
105 adc_base_config(ADC1, &adc_base_struct);
106 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
107 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
108 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
109 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
110 adc_dma_mode_enable(ADC1, TRUE);
111
112 adc_enable(ADC1, TRUE);
113 adc_calibration_init(ADC1);
114 while(adc_calibration_init_status_get(ADC1));
115 adc_calibration_start(ADC1);
116 while(adc_calibration_status_get(ADC1));
117}
118
124int main(void)
125{
126 __IO uint32_t index = 0;
127 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
128 system_clock_config();
129 at32_board_init();
130 at32_led_off(LED2);
131 at32_led_off(LED3);
132 at32_led_off(LED4);
133 uart_print_init(115200);
134 gpio_config();
135 dma_config();
136 adc_config();
137 printf("repeat_conversion_loop_transfer \r\n");
138 printf("please_debug_check_data_and_conversion_times \r\n");
139 adc_ordinary_software_trigger_enable(ADC1, TRUE);
140 at32_led_on(LED2);
141 while(1)
142 {
143 }
144}
145
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c:37
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c:64
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c:92
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c:124
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c:36
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/repeat_conversion_loop_transfer/src/main.c:48
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:114
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:113
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:156
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • software_trigger_repeat
  • inc
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • software_trigger_repeat
  • inc
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • software_trigger_repeat
  • inc
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • software_trigger_repeat
  • src
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • software_trigger_repeat
  • src
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern __IO uint16_t dma_trans_complete_flag;
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void DMA1_Channel1_IRQHandler(void)
142{
143 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
144 {
145 dma_flag_clear(DMA1_FDT1_FLAG);
146 dma_trans_complete_flag++;
147 }
148}
149
150
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:44
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:141
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:114
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • software_trigger_repeat
  • src
project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36__IO uint16_t adc1_ordinary_valuetab[3] = {0};
37__IO uint16_t dma_trans_complete_flag = 0;
38
39static void gpio_config(void);
40static void dma_config(void);
41static void adc_config(void);
42
48static void gpio_config(void)
49{
50 gpio_init_type gpio_initstructure;
51 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
52
53 gpio_default_para_init(&gpio_initstructure);
54 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
55 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
56 gpio_init(GPIOA, &gpio_initstructure);
57}
58
64static void dma_config(void)
65{
66 dma_init_type dma_init_struct;
67 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
68 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
69 dma_reset(DMA1_CHANNEL1);
70 dma_default_para_init(&dma_init_struct);
71 dma_init_struct.buffer_size = 3;
72 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
73 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
74 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
75 dma_init_struct.memory_inc_enable = TRUE;
76 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
77 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
78 dma_init_struct.peripheral_inc_enable = FALSE;
79 dma_init_struct.priority = DMA_PRIORITY_HIGH;
80 dma_init_struct.loop_mode_enable = TRUE;
81 dma_init(DMA1_CHANNEL1, &dma_init_struct);
82
83 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
84 dma_channel_enable(DMA1_CHANNEL1, TRUE);
85}
86
92static void adc_config(void)
93{
94 adc_base_config_type adc_base_struct;
95 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
96 crm_adc_clock_div_set(CRM_ADC_DIV_6);
97
98 /* select combine mode */
99 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
100 adc_base_default_para_init(&adc_base_struct);
101 adc_base_struct.sequence_mode = TRUE;
102 adc_base_struct.repeat_mode = TRUE;
103 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
104 adc_base_struct.ordinary_channel_length = 3;
105 adc_base_config(ADC1, &adc_base_struct);
106 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
107 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
108 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
109 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
110 adc_dma_mode_enable(ADC1, TRUE);
111
112 adc_enable(ADC1, TRUE);
113 adc_calibration_init(ADC1);
114 while(adc_calibration_init_status_get(ADC1));
115 adc_calibration_start(ADC1);
116 while(adc_calibration_status_get(ADC1));
117}
118
124int main(void)
125{
126 __IO uint32_t index = 0;
127 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
128 system_clock_config();
129 at32_board_init();
130 at32_led_off(LED2);
131 at32_led_off(LED3);
132 at32_led_off(LED4);
133 uart_print_init(115200);
134 gpio_config();
135 dma_config();
136 adc_config();
137 printf("software_trigger_repeat \r\n");
138 printf("please_debug_check_data_and_conversion_times \r\n");
139 adc_ordinary_software_trigger_enable(ADC1, TRUE);
140 at32_led_on(LED2);
141 while(1)
142 {
143 }
144}
145
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:37
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:64
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:92
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:124
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:36
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:48
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:114
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:113
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:156
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern __IO uint16_t adc1_ordinary_valuetab[5][3];
30extern __IO uint16_t adc1_preempt_valuetab[5][3];
31extern __IO uint16_t dma_trans_complete_flag;
32extern __IO uint16_t preempt_conversion_count;
33
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void DMA1_Channel1_IRQHandler(void)
145{
146 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
147 {
148 dma_flag_clear(DMA1_FDT1_FLAG);
149 dma_trans_complete_flag = 1;
150 }
151}
152
158void ADC1_2_IRQHandler(void)
159{
160 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
161 {
162 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
163 if(preempt_conversion_count < 5)
164 {
165 adc1_preempt_valuetab[preempt_conversion_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
166 adc1_preempt_valuetab[preempt_conversion_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
167 adc1_preempt_valuetab[preempt_conversion_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
168 preempt_conversion_count++;
169 }
170 at32_led_toggle(LED3);
171 }
172}
173
174
175
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:37
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:38
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:108
ADC1_2_IRQHandler
void ADC1_2_IRQHandler(void)
this function handles adc1_2 handler.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:158
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:47
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:144
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:135
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:39
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:117
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:733
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:799
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:770
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:188
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:187
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:186
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f413_adc.h:65
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36__IO uint16_t adc1_ordinary_valuetab[5][3] = {0};
37__IO uint16_t adc1_preempt_valuetab[5][3] = {0};
38__IO uint16_t dma_trans_complete_flag = 0;
39__IO uint16_t preempt_conversion_count = 0;
40
41static void gpio_config(void);
42static void dma_config(void);
43static void tmr1_config(void);
44static void adc_config(void);
45
51static void gpio_config(void)
52{
53 gpio_init_type gpio_initstructure;
54 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
56
57 gpio_default_para_init(&gpio_initstructure);
58 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
59 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
60 gpio_init(GPIOA, &gpio_initstructure);
61
62 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
63 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
64 gpio_init(GPIOB, &gpio_initstructure);
65}
66
72static void dma_config(void)
73{
74 dma_init_type dma_init_struct;
75 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
76 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
77 dma_reset(DMA1_CHANNEL1);
78 dma_default_para_init(&dma_init_struct);
79 dma_init_struct.buffer_size = 15;
80 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
81 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
82 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
83 dma_init_struct.memory_inc_enable = TRUE;
84 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
85 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
86 dma_init_struct.peripheral_inc_enable = FALSE;
87 dma_init_struct.priority = DMA_PRIORITY_HIGH;
88 dma_init_struct.loop_mode_enable = FALSE;
89 dma_init(DMA1_CHANNEL1, &dma_init_struct);
90
91 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
92 dma_channel_enable(DMA1_CHANNEL1, TRUE);
93}
94
100static void tmr1_config(void)
101{
102 gpio_init_type gpio_initstructure;
103 tmr_output_config_type tmr_oc_init_structure;
104 crm_clocks_freq_type crm_clocks_freq_struct = {0};
105 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
106
107 gpio_default_para_init(&gpio_initstructure);
108 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
109 gpio_initstructure.gpio_pins = GPIO_PINS_8;
110 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
111 gpio_initstructure.gpio_pull = GPIO_PULL_NONE;
112 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
113 gpio_init(GPIOA, &gpio_initstructure);
114
115 /* get system clock */
116 crm_clocks_freq_get(&crm_clocks_freq_struct);
117
118 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
119
120 /* (systemclock/(systemclock/10000))/1000 = 10Hz(100ms) */
121 tmr_base_init(TMR1, 999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
122 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
123 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
124
125 tmr_output_default_para_init(&tmr_oc_init_structure);
126 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
127 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
128 tmr_oc_init_structure.oc_output_state = TRUE;
129 tmr_oc_init_structure.oc_idle_state = FALSE;
130 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
131 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 500);
132}
133
139static void adc_config(void)
140{
141 adc_base_config_type adc_base_struct;
142 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
143 crm_adc_clock_div_set(CRM_ADC_DIV_6);
144 nvic_irq_enable(ADC1_2_IRQn, 0, 0);
145
146 /* select combine mode */
147 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
148 adc_base_default_para_init(&adc_base_struct);
149 adc_base_struct.sequence_mode = TRUE;
150 adc_base_struct.repeat_mode = FALSE;
151 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
152 adc_base_struct.ordinary_channel_length = 3;
153 adc_base_config(ADC1, &adc_base_struct);
154 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
155 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
156 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
157 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_TMR1CH1, TRUE);
158 adc_dma_mode_enable(ADC1, TRUE);
159
160 adc_preempt_channel_length_set(ADC1, 3);
161 adc_preempt_channel_set(ADC1, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_239_5);
162 adc_preempt_channel_set(ADC1, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_239_5);
163 adc_preempt_channel_set(ADC1, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_239_5);
164 adc_preempt_conversion_trigger_set(ADC1, ADC12_PREEMPT_TRIG_SOFTWARE, TRUE);
165 adc_preempt_auto_mode_enable(ADC1, TRUE);
166 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
167
168 adc_enable(ADC1, TRUE);
169 adc_calibration_init(ADC1);
170 while(adc_calibration_init_status_get(ADC1));
171 adc_calibration_start(ADC1);
172 while(adc_calibration_status_get(ADC1));
173}
174
175
176
177
183int main(void)
184{
185 __IO uint32_t index = 0;
186 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
187 system_clock_config();
188 at32_board_init();
189 at32_led_off(LED2);
190 at32_led_off(LED3);
191 at32_led_off(LED4);
192 uart_print_init(115200);
193 gpio_config();
194 tmr1_config();
195 dma_config();
196 adc_config();
197 printf("tmr_trigger_automatic_preempted \r\n");
198 tmr_counter_enable(TMR1, TRUE);
199 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
200 tmr_output_enable(TMR1, TRUE);
201 while(preempt_conversion_count < 5);
202 while(dma_trans_complete_flag == 0);
203 tmr_counter_enable(TMR1, FALSE);
204 for(index = 0; index < 5; index++)
205 {
206 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][0]);
207 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][1]);
208 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][2]);
209 printf("adc1_preempted_valuetab[%d][0] = 0x%x\r\n", index, adc1_preempt_valuetab[index][0]);
210 printf("adc1_preempted_valuetab[%d][1] = 0x%x\r\n", index, adc1_preempt_valuetab[index][1]);
211 printf("adc1_preempted_valuetab[%d][2] = 0x%x\r\n", index, adc1_preempt_valuetab[index][2]);
212 printf("\r\n");
213 }
214 at32_led_on(LED2);
215 while(1)
216 {
217 }
218}
219
220
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:38
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:72
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:37
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:36
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:139
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:183
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:100
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:39
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:37
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:36
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f413_adc.c:616
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:178
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:510
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:424
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:392
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:117
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:116
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:114
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:115
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:113
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC12_PREEMPT_TRIG_SOFTWARE
@ ADC12_PREEMPT_TRIG_SOFTWARE
Definition: at32f413_adc.h:175
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC12_ORDINARY_TRIG_TMR1CH1
@ ADC12_ORDINARY_TRIG_TMR1CH1
Definition: at32f413_adc.h:149
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f413_adc.h:52
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:189
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:882
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • voltage_monitoring
  • inc
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • voltage_monitoring
  • inc
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • voltage_monitoring
  • inc
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • voltage_monitoring
  • src
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • voltage_monitoring
  • src
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern __IO uint16_t adc1_ordinary_valuetab[3];
30extern __IO uint16_t vmor_flag_index;
31
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void ADC1_2_IRQHandler(void)
144{
145 if(adc_flag_get(ADC1, ADC_VMOR_FLAG) != RESET)
146 {
147 at32_led_toggle(LED3);
148 adc_flag_clear(ADC1, ADC_VMOR_FLAG);
149 vmor_flag_index = 1;
150 }
151}
152
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:37
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:107
ADC1_2_IRQHandler
void ADC1_2_IRQHandler(void)
this function handles adc1_2 handler.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:143
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:134
vmor_flag_index
__IO uint16_t vmor_flag_index
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:37
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:116
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:799
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:770
ADC_VMOR_FLAG
#define ADC_VMOR_FLAG
Definition: at32f413_adc.h:63
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • voltage_monitoring
  • src
project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36__IO uint16_t adc1_ordinary_valuetab[3] = {0};
37__IO uint16_t vmor_flag_index = 0;
38
39static void gpio_config(void);
40static void dma_config(void);
41static void adc_config(void);
42
48static void gpio_config(void)
49{
50 gpio_init_type gpio_initstructure;
51 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
52
53 gpio_default_para_init(&gpio_initstructure);
54 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
55 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
56 gpio_init(GPIOA, &gpio_initstructure);
57}
58
64static void dma_config(void)
65{
66 dma_init_type dma_init_struct;
67 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
68 dma_reset(DMA1_CHANNEL1);
69 dma_default_para_init(&dma_init_struct);
70 dma_init_struct.buffer_size = 3;
71 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
72 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
73 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
74 dma_init_struct.memory_inc_enable = TRUE;
75 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
76 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
77 dma_init_struct.peripheral_inc_enable = FALSE;
78 dma_init_struct.priority = DMA_PRIORITY_HIGH;
79 dma_init_struct.loop_mode_enable = TRUE;
80 dma_init(DMA1_CHANNEL1, &dma_init_struct);
81
82 dma_channel_enable(DMA1_CHANNEL1, TRUE);
83}
84
90static void adc_config(void)
91{
92 adc_base_config_type adc_base_struct;
93 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
94 crm_adc_clock_div_set(CRM_ADC_DIV_6);
95 nvic_irq_enable(ADC1_2_IRQn, 0, 0);
96
97 /* select combine mode */
98 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
99 adc_base_default_para_init(&adc_base_struct);
100 adc_base_struct.sequence_mode = TRUE;
101 adc_base_struct.repeat_mode = FALSE;
102 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
103 adc_base_struct.ordinary_channel_length = 3;
104 adc_base_config(ADC1, &adc_base_struct);
105 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
106 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
107 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
108 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
109 adc_dma_mode_enable(ADC1, TRUE);
110 adc_voltage_monitor_enable(ADC1, ADC_VMONITOR_SINGLE_ORDINARY);
111 adc_voltage_monitor_threshold_value_set(ADC1, 0xBBB, 0xAAA);
112 adc_voltage_monitor_single_channel_select(ADC1, ADC_CHANNEL_5);
113 adc_interrupt_enable(ADC1, ADC_VMOR_INT, TRUE);
114
115 adc_enable(ADC1, TRUE);
116 adc_calibration_init(ADC1);
117 while(adc_calibration_init_status_get(ADC1));
118 adc_calibration_start(ADC1);
119 while(adc_calibration_status_get(ADC1));
120}
121
127int main(void)
128{
129 __IO uint32_t index = 0;
130 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
131 system_clock_config();
132 at32_board_init();
133 at32_led_off(LED2);
134 at32_led_off(LED3);
135 at32_led_off(LED4);
136 uart_print_init(115200);
137 gpio_config();
138 dma_config();
139 adc_config();
140 printf("voltage_monitoring \r\n");
141 while(1)
142 {
143 at32_led_toggle(LED2);
144 delay_sec(1);
145 if(vmor_flag_index == 1)
146 {
147 vmor_flag_index = 0;
148 printf("out of range:adc1_channel_5 value is = %x!\r\n", adc1_ordinary_valuetab[1]);
149 }
150 adc_ordinary_software_trigger_enable(ADC1, TRUE);
151 }
152}
153
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:64
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:90
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:127
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:36
vmor_flag_index
__IO uint16_t vmor_flag_index
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:37
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:48
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:642
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f413_adc.c:268
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f413_adc.c:309
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:141
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:73
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:178
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:115
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:228
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:240
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f413_adc.c:289
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:479
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:197
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:209
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:159
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:95
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:341
ADC_VMONITOR_SINGLE_ORDINARY
@ ADC_VMONITOR_SINGLE_ORDINARY
Definition: at32f413_adc.h:197
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:99
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:114
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:113
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:140
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:82
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:156
ADC_VMOR_INT
#define ADC_VMOR_INT
Definition: at32f413_adc.h:51
ADC1
#define ADC1
Definition: at32f413_adc.h:557
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:346
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:189
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:215
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:210
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:213
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:212
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:211
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:214
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • bpr
  • bpr_data
  • inc
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • bpr
  • bpr_data
  • inc
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • bpr
  • bpr_data
  • inc
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • bpr
  • bpr_data
  • src
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • bpr
  • bpr_data
  • src
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • bpr
  • bpr_data
  • src
project/at_start_f413/examples/bpr/bpr_data/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BPR_DR_NUMBER 42
37
38 bpr_data_type bpr_addr_tab[BPR_DR_NUMBER] =
39{
40 BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
41 BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
42 BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
43 BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
44 BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
45 BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
46 BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
47 BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
48 BPR_DATA41, BPR_DATA42
49};
50
51void bpr_reg_write(void);
52uint8_t bpr_reg_check(void);
53void uart_init(uint32_t baudrate);
54
60void bpr_reg_write(void)
61{
62 uint32_t index = 0;
63
64 for(index = 0; index < BPR_DR_NUMBER; index++)
65 {
66 bpr_data_write(bpr_addr_tab[index], 0x5A00 | bpr_addr_tab[index]);
67 }
68}
69
78uint8_t bpr_reg_check(void)
79{
80 uint32_t index = 0;
81
82 for(index = 0; index < BPR_DR_NUMBER; index++)
83 {
84 if(bpr_data_read(bpr_addr_tab[index]) != (0x5A00 | bpr_addr_tab[index]))
85 {
86 return FALSE;
87 }
88 }
89
90 return TRUE;
91}
92
98int main(void)
99{
100 system_clock_config();
101
102 uart_print_init(115200);
103
104 /* enable pwc and bpr clock */
105 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
106 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
107
108 /* enable write access to bpr domain */
109 pwc_battery_powered_domain_access(TRUE);
110
111 /* clear tamper pin event pending flag */
112 bpr_flag_clear(BPR_TAMPER_EVENT_FLAG);
113
114 /* check data from bpr dt register */
115 if(bpr_reg_check() == TRUE)
116 {
117 printf("bpr reg => none reset\r\n");
118 }
119 else
120 {
121 printf("bpr reg => reset\r\n");
122 }
123
124 /* reset bpr domain */
125 bpr_reset();
126
127 /* write data to bpr dt register */
128 bpr_reg_write();
129
130 /* check if the written data are correct */
131 if(bpr_reg_check() == TRUE)
132 {
133 printf("write bpr reg ok\r\n");
134 }
135 else
136 {
137 printf("write bpr reg fail\r\n");
138 }
139
140 /* disable pwc and bpr clock for power saving */
141 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, FALSE);
142 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, FALSE);
143
144 while(1)
145 {
146 }
147}
148
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
bpr_addr_tab
bpr_data_type bpr_addr_tab[42]
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:38
BPR_DR_NUMBER
#define BPR_DR_NUMBER
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:36
bpr_reg_write
void bpr_reg_write(void)
write data to bpr dt register.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:60
main
int main(void)
main function.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:98
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
bpr_reg_check
uint8_t bpr_reg_check(void)
checks if the bpr dt register values are correct or not.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:78
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:114
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:81
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:131
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:65
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:91
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:93
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:96
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:73
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:90
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:104
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:72
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:77
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:94
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:84
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:66
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:101
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:74
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:75
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:92
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:85
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:103
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:102
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:106
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:78
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:69
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:97
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:81
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:76
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:89
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:88
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:70
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:83
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:82
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:107
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:86
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:98
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:105
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:95
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:67
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:79
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:80
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:68
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:87
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:99
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:100
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:71
BPR_TAMPER_EVENT_FLAG
#define BPR_TAMPER_EVENT_FLAG
Definition: at32f413_bpr.h:51
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • bpr
  • tamper
  • inc
project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • bpr
  • tamper
  • inc
project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • bpr
  • tamper
  • inc
project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • bpr
  • tamper
  • src
project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • bpr
  • tamper
  • src
project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern uint32_t bpr_reg_judge(void);
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void TAMPER_IRQHandler(void)
142{
143 if(bpr_flag_get(BPR_TAMPER_INTERRUPT_FLAG) != RESET)
144 {
145 /* check if bpr registers are cleared */
146 if(bpr_reg_judge() == 0)
147 {
148 /* ok, bpr registers are reset as expected */
149 at32_led_on(LED3);
150 }
151 else
152 {
153 /* bpr registers are not reset */
154 at32_led_off(LED3);
155 }
156
157 /* clear tamper pin interrupt pending bit */
158 bpr_flag_clear(BPR_TAMPER_INTERRUPT_FLAG);
159
160 /* clear tamper pin event(te) pending flag */
161 bpr_flag_clear(BPR_TAMPER_EVENT_FLAG);
162
163 /* disable tamper pin */
164 bpr_tamper_pin_enable(FALSE);
165
166 /* enable tamper pin */
167 bpr_tamper_pin_enable(TRUE);
168 }
169}
170
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:105
bpr_reg_judge
uint32_t bpr_reg_judge(void)
checks if the bpr dt registers are reset or not.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:101
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:44
TAMPER_IRQHandler
void TAMPER_IRQHandler(void)
this function handles tamper interrupt request.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:141
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:114
LED3
@ LED3
Definition: at32f413_board.h:62
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:174
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:81
bpr_flag_get
flag_status bpr_flag_get(uint32_t flag)
bpr event flag get, for tamper event flag
Definition: at32f413_bpr.c:61
BPR_TAMPER_EVENT_FLAG
#define BPR_TAMPER_EVENT_FLAG
Definition: at32f413_bpr.h:51
BPR_TAMPER_INTERRUPT_FLAG
#define BPR_TAMPER_INTERRUPT_FLAG
Definition: at32f413_bpr.h:50
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • bpr
  • tamper
  • src
project/at_start_f413/examples/bpr/tamper/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BPR_DR_NUMBER 42
37
38 bpr_data_type bpr_addr_tab[BPR_DR_NUMBER] =
39{
40 BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
41 BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
42 BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
43 BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
44 BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
45 BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
46 BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
47 BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
48 BPR_DATA41, BPR_DATA42
49};
50
51void bpr_reg_write(void);
52uint8_t bpr_reg_check(void);
53uint32_t bpr_reg_judge(void);
54
60void bpr_reg_write(void)
61{
62 uint32_t index = 0;
63
64 for(index = 0; index < BPR_DR_NUMBER; index++)
65 {
66 bpr_data_write(bpr_addr_tab[index], 0x5A00 | bpr_addr_tab[index]);
67 }
68}
69
78uint8_t bpr_reg_check(void)
79{
80 uint32_t index = 0;
81
82 for(index = 0; index < BPR_DR_NUMBER; index++)
83 {
84 if(bpr_data_read(bpr_addr_tab[index]) != (0x5A00 | bpr_addr_tab[index]))
85 {
86 return FALSE;
87 }
88 }
89
90 return TRUE;
91}
92
101uint32_t bpr_reg_judge(void)
102{
103 uint32_t index = 0;
104
105 for(index = 0; index < BPR_DR_NUMBER; index++)
106 {
107 if(bpr_data_read(bpr_addr_tab[index]) != 0x0000)
108 {
109 return (index + 1);
110 }
111 }
112
113 return 0;
114}
115
121int main(void)
122{
123 /* config nvic priority group */
124 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
125
126 system_clock_config();
127
128 at32_board_init();
129
130 /* nvic configuration */
131 nvic_irq_enable(TAMPER_IRQn, 0, 0);
132
133 /* enable pwc and bpr clock */
134 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
135 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
136
137 /* enable write access to bpr domain */
138 pwc_battery_powered_domain_access(TRUE);
139
140 /* disable tamper pin */
141 bpr_tamper_pin_enable(FALSE);
142
143 /* disable tamper interrupt */
144 bpr_interrupt_enable(FALSE);
145
146 /* tamper pin active on low level */
147 bpr_tamper_pin_active_level_set(BPR_TAMPER_PIN_ACTIVE_LOW);
148
149 /* clear tamper pin event pending flag */
150 bpr_flag_clear(BPR_TAMPER_EVENT_FLAG);
151
152 /* write data to bpr dt registers */
153 bpr_reg_write();
154
155 /* enable tamper interrupt */
156 bpr_interrupt_enable(TRUE);
157
158 /* enable tamper pin */
159 bpr_tamper_pin_enable(TRUE);
160
161 /* check if the written data are correct */
162 if(bpr_reg_check() == TRUE)
163 {
164 at32_led_on(LED2);
165 }
166 else
167 {
168 at32_led_off(LED2);
169 }
170
171 while(1)
172 {
173 }
174}
175
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
bpr_addr_tab
bpr_data_type bpr_addr_tab[42]
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:38
BPR_DR_NUMBER
#define BPR_DR_NUMBER
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:36
bpr_reg_judge
uint32_t bpr_reg_judge(void)
checks if the bpr dt registers are reset or not.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:101
bpr_reg_write
void bpr_reg_write(void)
write data to bpr dt registers.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:60
main
int main(void)
main function.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:121
bpr_reg_check
uint8_t bpr_reg_check(void)
checks if the bpr dt registers values are correct or not.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:78
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:174
bpr_interrupt_enable
void bpr_interrupt_enable(confirm_state new_state)
enable or disable bpr tamper interrupt
Definition: at32f413_bpr.c:98
bpr_tamper_pin_active_level_set
void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level
Definition: at32f413_bpr.c:187
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:114
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:81
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:131
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:65
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:91
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:93
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:96
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:73
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:90
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:104
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:72
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:77
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:94
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:84
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:66
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:101
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:74
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:75
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:92
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:85
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:103
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:102
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:106
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:78
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:69
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:97
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:81
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:76
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:89
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:88
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:70
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:83
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:82
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:107
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:86
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:98
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:105
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:95
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:67
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:79
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:80
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:68
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:87
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:99
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:100
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:71
BPR_TAMPER_PIN_ACTIVE_LOW
@ BPR_TAMPER_PIN_ACTIVE_LOW
Definition: at32f413_bpr.h:130
BPR_TAMPER_EVENT_FLAG
#define BPR_TAMPER_EVENT_FLAG
Definition: at32f413_bpr.h:51
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
TAMPER_IRQn
@ TAMPER_IRQn
Definition: at32f413.h:172
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • can
  • communication_mode
  • inc
project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • can
  • communication_mode
  • inc
project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • can
  • communication_mode
  • inc
project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • can
  • communication_mode
  • src
project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • can
  • communication_mode
  • src
project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • can
  • communication_mode
  • src
project/at_start_f413/examples/can/communication_mode/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
41static void can_gpio_config(void)
42{
43 gpio_init_type gpio_init_struct;
44
45 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
46 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
47 gpio_pin_remap_config(CAN1_GMUX_0010,TRUE);
48
49 gpio_default_para_init(&gpio_init_struct);
50 /* can tx pin */
51 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
52 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
53 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
54 gpio_init_struct.gpio_pins = GPIO_PINS_9;
55 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
56 gpio_init(GPIOB, &gpio_init_struct);
57 /* can rx pin */
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
60 gpio_init_struct.gpio_pins = GPIO_PINS_8;
61 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
62 gpio_init(GPIOB, &gpio_init_struct);
63}
64
70static void can_configuration(void)
71{
72 can_base_type can_base_struct;
73 can_baudrate_type can_baudrate_struct;
74 can_filter_init_type can_filter_init_struct;
75
76 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
77 /* can base init */
78 can_default_para_init(&can_base_struct);
79 can_base_struct.mode_selection = CAN_MODE_COMMUNICATE;
80 can_base_struct.ttc_enable = FALSE;
81 can_base_struct.aebo_enable = TRUE;
82 can_base_struct.aed_enable = TRUE;
83 can_base_struct.prsf_enable = FALSE;
84 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
85 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
86 can_base_init(CAN1, &can_base_struct);
87
88 /* can baudrate, set baudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
89 can_baudrate_struct.baudrate_div = 8;
90 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
91 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
92 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
93 can_baudrate_set(CAN1, &can_baudrate_struct);
94
95 /* can filter init */
96 can_filter_init_struct.filter_activate_enable = TRUE;
97 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_MASK;
98 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
99 can_filter_init_struct.filter_number = 0;
100 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
101 can_filter_init_struct.filter_id_high = 0;
102 can_filter_init_struct.filter_id_low = 0;
103 can_filter_init_struct.filter_mask_high = 0;
104 can_filter_init_struct.filter_mask_low = 0;
105 can_filter_init(CAN1, &can_filter_init_struct);
106
107 /* can interrupt config */
108 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
109 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0x00, 0x00);
110 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
111
112 /* error interrupt enable */
113 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
114 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
115}
116
122static void can_transmit_data(void)
123{
124 uint8_t transmit_mailbox;
125 can_tx_message_type tx_message_struct;
126 tx_message_struct.standard_id = 0x400;
127 tx_message_struct.extended_id = 0;
128 tx_message_struct.id_type = CAN_ID_STANDARD;
129 tx_message_struct.frame_type = CAN_TFT_DATA;
130 tx_message_struct.dlc = 8;
131 tx_message_struct.data[0] = 0x11;
132 tx_message_struct.data[1] = 0x22;
133 tx_message_struct.data[2] = 0x33;
134 tx_message_struct.data[3] = 0x44;
135 tx_message_struct.data[4] = 0x55;
136 tx_message_struct.data[5] = 0x66;
137 tx_message_struct.data[6] = 0x77;
138 tx_message_struct.data[7] = 0x88;
139 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
140 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
141}
142
148void USBFS_L_CAN1_RX0_IRQHandler (void)
149{
150 can_rx_message_type rx_message_struct;
151 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
152 {
153 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
154 if(rx_message_struct.standard_id == 0x400)
155 at32_led_toggle(LED2);
156 else
157 at32_led_toggle(LED3);
158 }
159}
160
166void CAN1_SE_IRQHandler(void)
167{
168 __IO uint32_t err_index = 0;
169 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
170 {
171 err_index = CAN1->ests & 0x70;
172 can_flag_clear(CAN1, CAN_ETR_FLAG);
173 /* error type is stuff error */
174 if(err_index == 0x00000010)
175 {
176 /* when stuff error occur: in order to ensure communication normally,
177 user must restart can or send a frame of highest priority message here */
178 }
179 }
180}
181
187int main(void)
188{
189 system_clock_config();
190 at32_board_init();
191 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
192 can_gpio_config();
193 can_configuration();
194 while(1)
195 {
196 can_transmit_data();
197 at32_led_toggle(LED4);
198 delay_sec(1);
199 }
200}
201
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:166
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:122
main
int main(void)
main function.
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:187
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:148
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:41
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:70
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:195
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:515
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:441
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:620
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:925
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:965
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1089
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:100
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:305
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:158
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:250
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:136
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:271
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:299
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:220
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:242
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:202
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:145
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:308
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:155
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:261
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:233
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:163
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:186
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:70
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:65
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f413_can.h:90
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f413_can.h:100
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f413_can.h:99
CAN1
#define CAN1
Definition: at32f413_can.h:936
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:137
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:193
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
CAN1_GMUX_0010
#define CAN1_GMUX_0010
Definition: at32f413_gpio.h:169
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
can_base_type
can init structure definition
Definition: at32f413_can.h:331
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:340
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:342
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:338
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:344
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:334
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:332
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:336
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:352
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:353
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:355
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:359
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:357
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:367
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:387
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:374
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:372
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:376
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:370
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:368
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:384
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:378
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:381
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:417
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:418
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:395
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:399
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:404
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:409
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:406
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:402
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:396
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • can
  • filter
  • inc
project/at_start_f413/examples/can/filter/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • can
  • filter
  • inc
project/at_start_f413/examples/can/filter/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • can
  • filter
  • inc
project/at_start_f413/examples/can/filter/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • can
  • filter
  • src
project/at_start_f413/examples/can/filter/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/can/filter/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • can
  • filter
  • src
project/at_start_f413/examples/can/filter/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • can
  • filter
  • src
project/at_start_f413/examples/can/filter/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36/* extended identifier */
37#define FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
38#define FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
39#define FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
40
41/* standard identifier */
42#define FILTER_STD_ID1 ((uint16_t)0x04F6)
43#define FILTER_STD_ID2 ((uint16_t)0x04F7)
44#define FILTER_STD_ID3 ((uint16_t)0x04F8)
45
46uint8_t test_result = 0;
52static void can_gpio_config(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
58 gpio_pin_remap_config(CAN1_GMUX_0010,TRUE);
59
60 gpio_default_para_init(&gpio_init_struct);
61
62 /* can tx pin */
63 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
64 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
65 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
66 gpio_init_struct.gpio_pins = GPIO_PINS_9;
67 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
68 gpio_init(GPIOB, &gpio_init_struct);
69
70 /* can rx pin */
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
73 gpio_init_struct.gpio_pins = GPIO_PINS_8;
74 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
75 gpio_init(GPIOB, &gpio_init_struct);
76}
77
83static void can_configuration(void)
84{
85 can_base_type can_base_struct;
86 can_baudrate_type can_baudrate_struct;
87 can_filter_init_type can_filter_init_struct;
88
89 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
90 /* can base init */
91 can_default_para_init(&can_base_struct);
92 can_base_struct.mode_selection = CAN_MODE_COMMUNICATE;
93 can_base_struct.ttc_enable = FALSE;
94 can_base_struct.aebo_enable = TRUE;
95 can_base_struct.aed_enable = TRUE;
96 can_base_struct.prsf_enable = FALSE;
97 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
98 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
99 can_base_init(CAN1, &can_base_struct);
100
101 /* can baudrate, set baudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
102 can_baudrate_struct.baudrate_div = 8;
103 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
104 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
105 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
106 can_baudrate_set(CAN1, &can_baudrate_struct);
107
108 /* can filter 0 config */
109 can_filter_init_struct.filter_activate_enable = TRUE;
110 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_LIST;
111 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
112 can_filter_init_struct.filter_number = 0;
113 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
114 can_filter_init_struct.filter_id_high = (((FILTER_EXT_ID1 << 3) >> 16) & 0xFFFF); /* extended identifier is 29 bit */
115 can_filter_init_struct.filter_id_low = ((FILTER_EXT_ID1 << 3) & 0xFFFF) | 0x04;
116 can_filter_init_struct.filter_mask_high = ((FILTER_EXT_ID2 << 3) >> 16) & 0xFFFF; /* extended identifier is 29 bit */
117 can_filter_init_struct.filter_mask_low = ((FILTER_EXT_ID2 << 3) & 0xFFFF) | 0x04;
118 can_filter_init(CAN1, &can_filter_init_struct);
119
120 /* can filter 1 config */
121 can_filter_init_struct.filter_activate_enable = TRUE;
122 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_LIST;
123 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
124 can_filter_init_struct.filter_number = 1;
125 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
126 can_filter_init_struct.filter_id_high = FILTER_STD_ID1 << 5; /* standard identifier is 11 bit */
127 can_filter_init_struct.filter_id_low = 0;
128 can_filter_init_struct.filter_mask_high = FILTER_STD_ID2 << 5;/* standard identifier is 11 bit */
129 can_filter_init_struct.filter_mask_low = 0;
130 can_filter_init(CAN1, &can_filter_init_struct);
131
132 /* can interrupt config */
133 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
134 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0x00, 0x00);
135 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
136
137 /* error interrupt enable */
138 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
139 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
140}
141
147static void can_transmit_data(void)
148{
149 uint8_t transmit_mailbox;
150 can_tx_message_type tx_message_struct;
151
152 /* transmit FILTER_STD_ID1 */
153 tx_message_struct.standard_id = FILTER_STD_ID1;
154 tx_message_struct.extended_id = 0;
155 tx_message_struct.id_type = CAN_ID_STANDARD;
156 tx_message_struct.frame_type = CAN_TFT_DATA;
157 tx_message_struct.dlc = 8;
158 tx_message_struct.data[0] = 0x11;
159 tx_message_struct.data[1] = 0x22;
160 tx_message_struct.data[2] = 0x33;
161 tx_message_struct.data[3] = 0x44;
162 tx_message_struct.data[4] = 0x55;
163 tx_message_struct.data[5] = 0x66;
164 tx_message_struct.data[6] = 0x77;
165 tx_message_struct.data[7] = 0x88;
166 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
167 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
168
169 /* transmit FILTER_STD_ID2 */
170 tx_message_struct.standard_id = FILTER_STD_ID2;
171 tx_message_struct.extended_id = 0;
172 tx_message_struct.id_type = CAN_ID_STANDARD;
173 tx_message_struct.frame_type = CAN_TFT_DATA;
174 tx_message_struct.dlc = 8;
175 tx_message_struct.data[0] = 0x11;
176 tx_message_struct.data[1] = 0x22;
177 tx_message_struct.data[2] = 0x33;
178 tx_message_struct.data[3] = 0x44;
179 tx_message_struct.data[4] = 0x55;
180 tx_message_struct.data[5] = 0x66;
181 tx_message_struct.data[6] = 0x77;
182 tx_message_struct.data[7] = 0x88;
183 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
184 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
185
186 /* transmit FILTER_STD_ID3 */
187 tx_message_struct.standard_id = FILTER_STD_ID3;
188 tx_message_struct.extended_id = 0;
189 tx_message_struct.id_type = CAN_ID_STANDARD;
190 tx_message_struct.frame_type = CAN_TFT_DATA;
191 tx_message_struct.dlc = 8;
192 tx_message_struct.data[0] = 0x11;
193 tx_message_struct.data[1] = 0x22;
194 tx_message_struct.data[2] = 0x33;
195 tx_message_struct.data[3] = 0x44;
196 tx_message_struct.data[4] = 0x55;
197 tx_message_struct.data[5] = 0x66;
198 tx_message_struct.data[6] = 0x77;
199 tx_message_struct.data[7] = 0x88;
200 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
201 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
202
203 /* transmit FILTER_EXT_ID1 */
204 tx_message_struct.standard_id = 0;
205 tx_message_struct.extended_id = FILTER_EXT_ID1;
206 tx_message_struct.id_type = CAN_ID_EXTENDED;
207 tx_message_struct.frame_type = CAN_TFT_DATA;
208 tx_message_struct.dlc = 8;
209 tx_message_struct.data[0] = 0x11;
210 tx_message_struct.data[1] = 0x22;
211 tx_message_struct.data[2] = 0x33;
212 tx_message_struct.data[3] = 0x44;
213 tx_message_struct.data[4] = 0x55;
214 tx_message_struct.data[5] = 0x66;
215 tx_message_struct.data[6] = 0x77;
216 tx_message_struct.data[7] = 0x88;
217 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
218 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
219
220 /* transmit FILTER_EXT_ID2 */
221 tx_message_struct.standard_id = 0;
222 tx_message_struct.extended_id = FILTER_EXT_ID2;
223 tx_message_struct.id_type = CAN_ID_EXTENDED;
224 tx_message_struct.frame_type = CAN_TFT_DATA;
225 tx_message_struct.dlc = 8;
226 tx_message_struct.data[0] = 0x11;
227 tx_message_struct.data[1] = 0x22;
228 tx_message_struct.data[2] = 0x33;
229 tx_message_struct.data[3] = 0x44;
230 tx_message_struct.data[4] = 0x55;
231 tx_message_struct.data[5] = 0x66;
232 tx_message_struct.data[6] = 0x77;
233 tx_message_struct.data[7] = 0x88;
234 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
235 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
236
237 /* transmit FILTER_EXT_ID3 */
238 tx_message_struct.standard_id = 0;
239 tx_message_struct.extended_id = FILTER_EXT_ID3;
240 tx_message_struct.id_type = CAN_ID_EXTENDED;
241 tx_message_struct.frame_type = CAN_TFT_DATA;
242 tx_message_struct.dlc = 8;
243 tx_message_struct.data[0] = 0x11;
244 tx_message_struct.data[1] = 0x22;
245 tx_message_struct.data[2] = 0x33;
246 tx_message_struct.data[3] = 0x44;
247 tx_message_struct.data[4] = 0x55;
248 tx_message_struct.data[5] = 0x66;
249 tx_message_struct.data[6] = 0x77;
250 tx_message_struct.data[7] = 0x88;
251 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
252 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
253}
254
260void USBFS_L_CAN1_RX0_IRQHandler (void)
261{
262 can_rx_message_type rx_message_struct;
263 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
264 {
265 if(test_result == 4)
266 {
267 test_result = 0;
268 }
269
270 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
271
272 if((rx_message_struct.id_type == CAN_ID_STANDARD) && (rx_message_struct.standard_id == FILTER_STD_ID1))
273 test_result++;
274 else if((rx_message_struct.id_type == CAN_ID_STANDARD) && (rx_message_struct.standard_id == FILTER_STD_ID2))
275 test_result++;
276 else if((rx_message_struct.id_type == CAN_ID_EXTENDED) && (rx_message_struct.extended_id == FILTER_EXT_ID1))
277 test_result++;
278 else if((rx_message_struct.id_type == CAN_ID_EXTENDED) && (rx_message_struct.extended_id == FILTER_EXT_ID2))
279 test_result++;
280 }
281}
282
288void CAN1_SE_IRQHandler(void)
289{
290 __IO uint32_t err_index = 0;
291 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
292 {
293 err_index = CAN1->ests & 0x70;
294 can_flag_clear(CAN1, CAN_ETR_FLAG);
295 /* error type is stuff error */
296 if(err_index == 0x00000010)
297 {
298 /* when stuff error occur: in order to ensure communication normally,
299 user must restart can or send a frame of highest priority message here */
300 }
301 }
302}
303
309int main(void)
310{
311 system_clock_config();
312 at32_board_init();
313 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
314 can_gpio_config();
315 can_configuration();
316 can_transmit_data();
317 while(1)
318 {
319 if(test_result == 4)
320 {
321 at32_led_toggle(LED2);
322 at32_led_toggle(LED3);
323 at32_led_toggle(LED4);
324 delay_sec(1);
325 }
326 }
327}
328
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f413/examples/can/filter/src/main.c:288
FILTER_EXT_ID3
#define FILTER_EXT_ID3
Definition: project/at_start_f413/examples/can/filter/src/main.c:39
FILTER_EXT_ID1
#define FILTER_EXT_ID1
Definition: project/at_start_f413/examples/can/filter/src/main.c:37
FILTER_STD_ID2
#define FILTER_STD_ID2
Definition: project/at_start_f413/examples/can/filter/src/main.c:43
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f413/examples/can/filter/src/main.c:147
main
int main(void)
main function.
Definition: project/at_start_f413/examples/can/filter/src/main.c:309
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f413/examples/can/filter/src/main.c:260
FILTER_EXT_ID2
#define FILTER_EXT_ID2
Definition: project/at_start_f413/examples/can/filter/src/main.c:38
FILTER_STD_ID3
#define FILTER_STD_ID3
Definition: project/at_start_f413/examples/can/filter/src/main.c:44
FILTER_STD_ID1
#define FILTER_STD_ID1
Definition: project/at_start_f413/examples/can/filter/src/main.c:42
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f413/examples/can/filter/src/main.c:52
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f413/examples/can/filter/src/main.c:83
test_result
uint8_t test_result
Definition: project/at_start_f413/examples/can/filter/src/main.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:195
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:515
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:441
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:620
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:925
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:965
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1089
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:100
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:305
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:158
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:250
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:136
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:271
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:299
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:220
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:242
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:202
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f413_can.h:146
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:308
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:155
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:261
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:233
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f413_can.h:234
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:163
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:186
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:70
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:65
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f413_can.h:90
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f413_can.h:100
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f413_can.h:99
CAN1
#define CAN1
Definition: at32f413_can.h:936
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:137
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:193
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
CAN1_GMUX_0010
#define CAN1_GMUX_0010
Definition: at32f413_gpio.h:169
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
can_base_type
can init structure definition
Definition: at32f413_can.h:331
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:340
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:342
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:338
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:344
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:334
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:332
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:336
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:352
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:353
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:355
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:359
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:357
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:367
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:387
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:374
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:372
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:376
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:370
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:368
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:384
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:378
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:381
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:417
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:418
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:424
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:421
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:395
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:399
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:404
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:409
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:406
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:402
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:396
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • can
  • loopback_mode
  • inc
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • can
  • loopback_mode
  • inc
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • can
  • loopback_mode
  • inc
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • can
  • loopback_mode
  • src
project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • can
  • loopback_mode
  • src
project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • can
  • loopback_mode
  • src
project/at_start_f413/examples/can/loopback_mode/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
41static void can_gpio_config(void)
42{
43 gpio_init_type gpio_init_struct;
44
45 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
46 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
47 gpio_pin_remap_config(CAN1_GMUX_0010,TRUE);
48
49 gpio_default_para_init(&gpio_init_struct);
50 /* can tx pin */
51 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
52 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
53 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
54 gpio_init_struct.gpio_pins = GPIO_PINS_9;
55 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
56 gpio_init(GPIOB, &gpio_init_struct);
57 /* can rx pin */
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
60 gpio_init_struct.gpio_pins = GPIO_PINS_8;
61 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
62 gpio_init(GPIOB, &gpio_init_struct);
63}
64
70static void can_configuration(void)
71{
72 can_base_type can_base_struct;
73 can_baudrate_type can_baudrate_struct;
74 can_filter_init_type can_filter_init_struct;
75
76 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
77 /* can base init */
78 can_default_para_init(&can_base_struct);
79 can_base_struct.mode_selection = CAN_MODE_LOOPBACK;
80 can_base_struct.ttc_enable = FALSE;
81 can_base_struct.aebo_enable = TRUE;
82 can_base_struct.aed_enable = TRUE;
83 can_base_struct.prsf_enable = FALSE;
84 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
85 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
86 can_base_init(CAN1, &can_base_struct);
87
88 /* can baudrate, set baudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
89 can_baudrate_struct.baudrate_div = 8;
90 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
91 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
92 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
93 can_baudrate_set(CAN1, &can_baudrate_struct);
94
95 /* can filter init */
96 can_filter_init_struct.filter_activate_enable = TRUE;
97 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_MASK;
98 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
99 can_filter_init_struct.filter_number = 0;
100 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
101 can_filter_init_struct.filter_id_high = 0;
102 can_filter_init_struct.filter_id_low = 0;
103 can_filter_init_struct.filter_mask_high = 0;
104 can_filter_init_struct.filter_mask_low = 0;
105 can_filter_init(CAN1, &can_filter_init_struct);
106
107 /* can interrupt config */
108 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
109 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0x00, 0x00);
110 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
111
112 /* error interrupt enable */
113 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
114 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
115}
116
122static void can_transmit_data(void)
123{
124 uint8_t transmit_mailbox;
125 can_tx_message_type tx_message_struct;
126 tx_message_struct.standard_id = 0x400;
127 tx_message_struct.extended_id = 0;
128 tx_message_struct.id_type = CAN_ID_STANDARD;
129 tx_message_struct.frame_type = CAN_TFT_DATA;
130 tx_message_struct.dlc = 8;
131 tx_message_struct.data[0] = 0x11;
132 tx_message_struct.data[1] = 0x22;
133 tx_message_struct.data[2] = 0x33;
134 tx_message_struct.data[3] = 0x44;
135 tx_message_struct.data[4] = 0x55;
136 tx_message_struct.data[5] = 0x66;
137 tx_message_struct.data[6] = 0x77;
138 tx_message_struct.data[7] = 0x88;
139 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
140 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
141}
142
148void USBFS_L_CAN1_RX0_IRQHandler (void)
149{
150 can_rx_message_type rx_message_struct;
151 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
152 {
153 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
154 if(rx_message_struct.standard_id == 0x400)
155 at32_led_toggle(LED2);
156 }
157}
158
164void CAN1_SE_IRQHandler(void)
165{
166 __IO uint32_t err_index = 0;
167 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
168 {
169 err_index = CAN1->ests & 0x70;
170 can_flag_clear(CAN1, CAN_ETR_FLAG);
171 /* error type is stuff error */
172 if(err_index == 0x00000010)
173 {
174 /* when stuff error occur: in order to ensure communication normally,
175 user must restart can or send a frame of highest priority message here */
176 }
177 }
178}
179
185int main(void)
186{
187 system_clock_config();
188 at32_board_init();
189 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
190 can_gpio_config();
191 can_configuration();
192 while(1)
193 {
194 can_transmit_data();
195 at32_led_toggle(LED4);
196 delay_sec(1);
197 }
198}
199
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:164
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:122
main
int main(void)
main function.
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:185
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:148
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:41
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:70
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:195
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:515
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:441
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:620
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:925
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:965
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1089
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:100
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:305
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:158
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:250
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:136
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:271
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:299
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:220
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:242
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:202
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:145
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:308
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:155
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:261
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:233
CAN_MODE_LOOPBACK
@ CAN_MODE_LOOPBACK
Definition: at32f413_can.h:164
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:186
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:70
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:65
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f413_can.h:90
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f413_can.h:100
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f413_can.h:99
CAN1
#define CAN1
Definition: at32f413_can.h:936
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:137
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:193
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
CAN1_GMUX_0010
#define CAN1_GMUX_0010
Definition: at32f413_gpio.h:169
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
can_base_type
can init structure definition
Definition: at32f413_can.h:331
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:340
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:342
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:338
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:344
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:334
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:332
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:336
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:352
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:353
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:355
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:359
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:357
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:367
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:387
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:374
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:372
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:376
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:370
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:368
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:384
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:378
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:381
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:417
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:418
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:395
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:399
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:404
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:409
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:406
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:402
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:396
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • bit_band
  • inc
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • bit_band
  • inc
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • bit_band
  • inc
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • bit_band
  • src
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • bit_band
  • src
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • bit_band
  • src
project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
37/* bit band for sram */
38#define RAM_BASE 0x20000000
39#define RAM_BITBAND_BASE 0x22000000
40
41#define VARIABLES_RESET_BIT(variables_addr, bit_number) \
42 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
43
44#define VARIABLES_SET_BIT(variables_addr, bit_number) \
45 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
46
47#define VARIABLES_GET_BIT(variables_addr, bit_number) \
48 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
49
50/* bit band for peripheral */
51#define PERIPHERAL_BASE 0x40000000
52#define PERIPHERAL_BITBAND_BASE 0x42000000
53
54#define PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) \
55 (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
56
57#define PERIPHERAL_SET_BIT(peripheral_addr, bit_number) \
58 (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)
59
60__IO uint32_t variables, variables_addr = 0, variables_bit_val = 0;
61
67void result_error(void)
68{
69 while(1)
70 {
71 at32_led_toggle(LED4);
72 delay_sec(1);
73 }
74}
75
81int main(void)
82{
83 system_clock_config();
84 at32_board_init();
85 variables = 0xA5A5A5A5;
86
87 /* get the variables address */
88 variables_addr = (uint32_t)&variables;
89
90 /* modify variables bit0 and check result */
91 VARIABLES_RESET_BIT(variables_addr, 0);
92 if((variables != 0xA5A5A5A4) || (VARIABLES_GET_BIT(variables_addr, 0) != 0))
93 {
94 result_error();
95 }
96
97 /* modify variables bit0 and check result */
98 VARIABLES_SET_BIT(variables_addr, 0);
99 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 0) != 1))
100 {
101 result_error();
102 }
103
104 /* modify variables bit16 and check result */
105 VARIABLES_RESET_BIT(variables_addr, 16);
106 if((variables != 0xA5A4A5A5) || (VARIABLES_GET_BIT(variables_addr, 16) != 0))
107 {
108 result_error();
109 }
110
111 /* modify variables bit16 and check result */
112 VARIABLES_SET_BIT(variables_addr, 16);
113 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 16) != 1))
114 {
115 result_error();
116 }
117
118 /* modify variables bit31 and check result */
119 VARIABLES_RESET_BIT(variables_addr, 31);
120 if((variables != 0x25A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 31) != 0))
121 {
122 result_error();
123 }
124
125 /* modify variables bit31 and check result */
126 VARIABLES_SET_BIT(variables_addr, 31);
127 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 31) != 1))
128 {
129 result_error();
130 }
131
132 while(1)
133 {
134 /* led2 toggle */
135 PERIPHERAL_RESET_BIT((uint32_t)&LED2_GPIO->odt, 2);
136 delay_ms(500);
137 PERIPHERAL_SET_BIT((uint32_t)&LED2_GPIO->odt, 2);
138 delay_ms(500);
139 }
140}
141
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
variables
__IO uint32_t variables
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:60
variables_addr
__IO uint32_t variables_addr
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:60
variables_bit_val
__IO uint32_t variables_bit_val
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:60
PERIPHERAL_SET_BIT
#define PERIPHERAL_SET_BIT(peripheral_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:57
main
int main(void)
main function.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:81
result_error
void result_error(void)
led4 flick for error.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:67
VARIABLES_SET_BIT
#define VARIABLES_SET_BIT(variables_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:44
PERIPHERAL_RESET_BIT
#define PERIPHERAL_RESET_BIT(peripheral_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:54
VARIABLES_RESET_BIT
#define VARIABLES_RESET_BIT(variables_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:41
VARIABLES_GET_BIT
#define VARIABLES_GET_BIT(variables_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:47
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED4
@ LED4
Definition: at32f413_board.h:63
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "arm_math.h"
28
37#define USE_STATIC_INIT
38
39 /* Global defines */
40
41#define TEST_LENGTH_SAMPLES (20*4)
42
43/* List of Marks scored by 20 students for 4 subjects */
44const float32_t testMarks_f32[TEST_LENGTH_SAMPLES] =
45{
46 42.000000, 37.000000, 81.000000, 28.000000,
47 83.000000, 72.000000, 36.000000, 38.000000,
48 32.000000, 51.000000, 63.000000, 64.000000,
49 97.000000, 82.000000, 95.000000, 90.000000,
50 66.000000, 51.000000, 54.000000, 42.000000,
51 67.000000, 56.000000, 45.000000, 57.000000,
52 67.000000, 69.000000, 35.000000, 52.000000,
53 29.000000, 81.000000, 58.000000, 47.000000,
54 38.000000, 76.000000, 100.000000, 29.000000,
55 33.000000, 47.000000, 29.000000, 50.000000,
56 34.000000, 41.000000, 61.000000, 46.000000,
57 52.000000, 50.000000, 48.000000, 36.000000,
58 47.000000, 55.000000, 44.000000, 40.000000,
59 100.000000, 94.000000, 84.000000, 37.000000,
60 32.000000, 71.000000, 47.000000, 77.000000,
61 31.000000, 50.000000, 49.000000, 35.000000,
62 63.000000, 67.000000, 40.000000, 31.000000,
63 29.000000, 68.000000, 61.000000, 38.000000,
64 31.000000, 28.000000, 28.000000, 76.000000,
65 55.000000, 33.000000, 29.000000, 39.000000
66};
67
68
69/* Number of subjects X 1 */
70const float32_t testUnity_f32[4] =
71{
72 1.000, 1.000, 1.000, 1.000
73};
74
75
76/* f32 Output buffer */
77static float32_t testOutput[TEST_LENGTH_SAMPLES];
78
79
80/* Global defines */
81#define NUMSTUDENTS 20
82#define NUMSUBJECTS 4
83
84/* Global variables */
85
86uint32_t numStudents = 20;
87uint32_t numSubjects = 4;
88float32_t max_marks, min_marks, mean, std, var;
89uint32_t student_num;
90
96int32_t main()
97{
98 system_clock_config();
99
100 uart_print_init(115200);
101
102#ifndef USE_STATIC_INIT
103
104 arm_matrix_instance_f32 srcA;
105 arm_matrix_instance_f32 srcB;
106 arm_matrix_instance_f32 dstC;
107
108 /* Input and output matrices initializations */
109 arm_mat_init_f32(&srcA, numStudents, numSubjects, (float32_t *)testMarks_f32);
110 arm_mat_init_f32(&srcB, numSubjects, 1, (float32_t *)testUnity_f32);
111 arm_mat_init_f32(&dstC, numStudents, 1, testOutput);
112
113#else
114
115 /* Static Initializations of Input and output matrix sizes and array */
116 arm_matrix_instance_f32 srcA = {NUMSTUDENTS, NUMSUBJECTS, (float32_t *)testMarks_f32};
117 arm_matrix_instance_f32 srcB = {NUMSUBJECTS, 1, (float32_t *)testUnity_f32};
118 arm_matrix_instance_f32 dstC = {NUMSTUDENTS, 1, testOutput};
119
120#endif
121
122 /* Call the Matrix multiplication process function */
123 arm_mat_mult_f32(&srcA, &srcB, &dstC);
124
125 /* Call the Max function to calculate max marks among numStudents */
126 arm_max_f32(testOutput, numStudents, &max_marks, &student_num);
127
128 /* Call the Min function to calculate min marks among numStudents */
129 arm_min_f32(testOutput, numStudents, &min_marks, &student_num);
130
131 /* Call the Mean function to calculate mean */
132 arm_mean_f32(testOutput, numStudents, &mean);
133
134 /* Call the std function to calculate standard deviation */
135 arm_std_f32(testOutput, numStudents, &std);
136
137 /* Call the var function to calculate variance */
138 arm_var_f32(testOutput, numStudents, &var);
139
140 printf("max_marks = %f, min_marks = %f, mean = %f, std = %f, var = %f\n", max_marks, min_marks, mean, std, var);
141
142 while (1);
143}
144
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
testMarks_f32
const float32_t testMarks_f32[(20 *4)]
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:44
std
float32_t std
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:88
main
int32_t main()
main function.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:96
var
float32_t var
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:88
numSubjects
uint32_t numSubjects
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:87
student_num
uint32_t student_num
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:89
NUMSUBJECTS
#define NUMSUBJECTS
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:82
testUnity_f32
const float32_t testUnity_f32[4]
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:70
NUMSTUDENTS
#define NUMSTUDENTS
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:81
max_marks
float32_t max_marks
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:88
numStudents
uint32_t numStudents
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:86
min_marks
float32_t min_marks
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:88
TEST_LENGTH_SAMPLES
#define TEST_LENGTH_SAMPLES
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:41
mean
float32_t mean
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:88
testOutput
static float32_t testOutput[(20 *4)]
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:77
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • fpu
  • inc
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • fpu
  • inc
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • fpu
  • inc
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • fpu
  • src
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • fpu
  • src
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • fpu
  • src
project/at_start_f413/examples/cortex_m4/fpu/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "julia_fpu.h"
28
37#define SCREEN_X_SIZE ((uint16_t)160)
38#define SCREEN_Y_SIZE ((uint16_t)120)
39#define ZOOM ((uint16_t)100)
40
41uint8_t buffer[SCREEN_X_SIZE * SCREEN_Y_SIZE];
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 while(1)
55 {
56 at32_led_toggle(LED4);
57
58 generate_julia_fpu(SCREEN_X_SIZE, SCREEN_Y_SIZE, SCREEN_X_SIZE / 2, SCREEN_Y_SIZE / 2, ZOOM, buffer);
59 }
60}
61
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
SCREEN_X_SIZE
#define SCREEN_X_SIZE
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:48
ZOOM
#define ZOOM
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:39
SCREEN_Y_SIZE
#define SCREEN_Y_SIZE
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:38
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: julia_fpu.c:46
julia_fpu.h
julia_fpu header file
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern void systick_handler(void);
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 systick_handler();
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:78
systick_handler
void systick_handler(void)
systick interrupt handler.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:44
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define MS_TICK (system_core_clock / 1000U)
37#define DELAY 200 /* 200 ms ticks */
38
44void systick_handler(void)
45{
46 static uint32_t ticks = 0;
47
48 ticks ++;
49
50 /* toggle led */
51 if(ticks > DELAY)
52 {
53 at32_led_toggle(LED2);
54 ticks = 0;
55 }
56}
57
63int main(void)
64{
65 system_clock_config();
66
67 /* config systick clock source */
68 systick_clock_source_config(SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV);
69
70 /* config systick reload value and enable interrupt */
71 SysTick_Config(MS_TICK);
72
73 /* configure led */
74 at32_led_init(LED2);
75
76 while(1)
77 {
78 }
79}
80
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
MS_TICK
#define MS_TICK
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:36
DELAY
#define DELAY
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:63
systick_handler
void systick_handler(void)
systick interrupt handler.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:237
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:145
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:88
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • crc
  • calculation
  • inc
project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • crc
  • calculation
  • inc
project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • crc
  • calculation
  • inc
project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • crc
  • calculation
  • src
project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • crc
  • calculation
  • src
project/at_start_f413/examples/crc/calculation/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • crc
  • calculation
  • src
project/at_start_f413/examples/crc/calculation/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BUFFER_SIZE 120
37
38static const uint32_t data_buffer[BUFFER_SIZE] =
39{
40 0xc33dd31c, 0xe37ff35e, 0x129022f3, 0x32d24235, 0x52146277, 0x7256b5ea,
41 0x4a755a54, 0x6a377a16, 0x0af11ad0, 0x2ab33a92, 0xed0fdd6c, 0xcd4dbdaa,
42 0xbb3bab1a, 0x6ca67c87, 0x5cc52c22, 0x3c030c60, 0x1c41edae, 0xfd8fcdec,
43 0xad8b9de8, 0x8dc97c26, 0x5c644c45, 0x3ca22c83, 0x1ce00cc1, 0xef1fff3e,
44 0x95a88589, 0xf56ee54f, 0xd52cc50d, 0x34e224c3, 0x04817466, 0x64475424,
45 0x78066827, 0x18c008e1, 0x28a3cb7d, 0xdb5ceb3f, 0xfb1e8bf9, 0x9bd8abbb,
46 0xdf7caf9b, 0xbfba8fd9, 0x9ff86e17, 0x7e364e55, 0x2e933eb2, 0x0ed11ef0,
47 0xa35ad3bd, 0xc39cf3ff, 0xe3de2462, 0x34430420, 0x64e674c7, 0x44a45485,
48 0xad2abd0b, 0x8d689d49, 0x7e976eb6, 0x5ed54ef4, 0x2e321e51, 0x0e70ff9f,
49 0xefbedfdd, 0xcffcbf1b, 0x9f598f78, 0x918881a9, 0xb1caa1eb, 0xd10cc12d,
50 0xe16f1080, 0x00a130c2, 0x20e35004, 0x40257046, 0x83b99398, 0xa3fbb3da,
51 0x00001021, 0x20423063, 0x408450a5, 0x60c670e7, 0x9129a14a, 0xb16bc18c,
52 0x569546b4, 0xb75ba77a, 0x97198738, 0xf7dfe7fe, 0xc7bc48c4, 0x58e56886,
53 0x4405a7db, 0xb7fa8799, 0xe75ff77e, 0xc71dd73c, 0x26d336f2, 0x069116b0,
54 0x76764615, 0x5634d94c, 0xc96df90e, 0xe92f99c8, 0xb98aa9ab, 0x58444865,
55 0x78a70840, 0x18612802, 0xc9ccd9ed, 0xe98ef9af, 0x89489969, 0xa90ab92b,
56 0xd1ade1ce, 0xf1ef1231, 0x32732252, 0x52b54294, 0x72f762d6, 0x93398318,
57 0xa56ab54b, 0x85289509, 0xf5cfc5ac, 0xd58d3653, 0x26721611, 0x063076d7,
58 0x8d689d49, 0xf7dfe7fe, 0xe98ef9af, 0x063076d7, 0x93398318, 0xb98aa9ab,
59 0x4ad47ab7, 0x6a961a71, 0x0a503a33, 0x2a12dbfd, 0xfbbfeb9e, 0x9b798b58
60};
61
62__IO uint32_t crc_value = 0;
63
69int main(void)
70{
71 system_clock_config();
72
73 at32_board_init();
74
75 /* enable crc clock */
76 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
77
78 crc_data_reset();
79
80 /* compute the crc of "data_buffer" */
81 crc_value = crc_block_calculate((uint32_t *)data_buffer, BUFFER_SIZE);
82
83 if(crc_value == 0xE5DFCF6D)
84 {
85 /* turn on led3 */
86 at32_led_on(LED3);
87 }
88 else
89 {
90 /* turn on led4 */
91 at32_led_on(LED4);
92 }
93
94 while(1)
95 {
96 }
97}
98
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:36
data_buffer
static const uint32_t data_buffer[120]
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:69
crc_value
__IO uint32_t crc_value
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:62
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f413_crc.c:70
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:47
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:104
TRUE
@ TRUE
Definition: at32f413.h:296
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • crm
  • clock_failure_detection
  • inc
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • crm
  • clock_failure_detection
  • inc
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • crm
  • clock_failure_detection
  • inc
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • crm
  • clock_failure_detection
  • src
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • crm
  • clock_failure_detection
  • src
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern void clock_failure_detection_handler(void);
29
43void NMI_Handler(void)
44{
45 clock_failure_detection_handler();
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:105
clock_failure_detection_handler
void clock_failure_detection_handler(void)
clock failure detection handler.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:74
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • crm
  • clock_failure_detection
  • src
project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36static void clkout_config(void);
37static void sclk_192m_hick_config(void);
38void clock_failure_detection_handler(void);
39
45static void clkout_config(void)
46{
47 gpio_init_type gpio_init_struct;
48
49 /* enable gpio port clock */
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* clkout gpio init */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
58 gpio_init_struct.gpio_pins = GPIO_PINS_8;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init(GPIOA, &gpio_init_struct);
61
62 /* config clkout division */
63 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
64
65 /* config clkout clock */
66 crm_clock_out_set(CRM_CLKOUT_PLL_DIV_4);
67}
68
74void clock_failure_detection_handler(void)
75{
76 /* check clock failure detection flag */
77 if(crm_flag_get(CRM_CLOCK_FAILURE_INT_FLAG) != RESET)
78 {
79 /* disable clock failure detection */
80 crm_clock_failure_detection_enable(FALSE);
81
82 /* config system clock */
83 sclk_192m_hick_config();
84
85 /* clear clock failure detection flag */
86 crm_flag_clear(CRM_CLOCK_FAILURE_INT_FLAG);
87 }
88}
89
108static void sclk_192m_hick_config(void)
109{
110 /* reset crm */
111 crm_reset();
112
113 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
114
115 /* wait till hick is ready */
116 while(crm_flag_get(CRM_HICK_STABLE_FLAG) != SET)
117 {
118 }
119
120 /* config pll clock resource */
121 crm_pll_config(CRM_PLL_SOURCE_HICK, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
122
123 /* enable pll */
124 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
125
126 /* wait till pll is ready */
127 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
128 {
129 }
130
131 /* config ahbclk */
132 crm_ahb_div_set(CRM_AHB_DIV_1);
133
134 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
135 crm_apb2_div_set(CRM_APB2_DIV_2);
136
137 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
138 crm_apb1_div_set(CRM_APB1_DIV_2);
139
140 /* enable auto step mode */
141 crm_auto_step_mode_enable(TRUE);
142
143 /* select pll as system clock source */
144 crm_sysclk_switch(CRM_SCLK_PLL);
145
146 /* wait till pll is used as system clock source */
147 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
148 {
149 }
150
151 /* disable auto step mode */
152 crm_auto_step_mode_enable(FALSE);
153
154 /* update system_core_clock global variable */
155 system_core_clock_update();
156
157 /* config systick delay */
158 delay_init();
159
160 /* config clkout */
161 clkout_config();
162}
163
169int main(void)
170{
171 system_clock_config();
172
173 at32_board_init();
174
175 /* clkout config */
176 clkout_config();
177
178 /* enable clock failure detection */
179 crm_clock_failure_detection_enable(TRUE);
180
181 while(1)
182 {
183 at32_led_toggle(LED2);
184 delay_ms(200);
185 }
186}
187
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
clkout_config
static void clkout_config(void)
clkout configuration.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:45
clock_failure_detection_handler
void clock_failure_detection_handler(void)
clock failure detection handler.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:74
main
int main(void)
main function.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:169
sclk_192m_hick_config
static void sclk_192m_hick_config(void)
config sclk 192 mhz with hick clock source.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:108
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
LED2
@ LED2
Definition: at32f413_board.h:61
delay_init
void delay_init()
initialize delay function
Definition: at32f413_board.c:312
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:805
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:328
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:684
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f413_crm.c:485
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:292
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:418
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:273
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:408
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
CRM_CLOCK_FAILURE_INT_FLAG
#define CRM_CLOCK_FAILURE_INT_FLAG
Definition: at32f413_crm.h:70
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f413_crm.h:53
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • crm
  • sysclk_switch
  • inc
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • crm
  • sysclk_switch
  • inc
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • crm
  • sysclk_switch
  • inc
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • crm
  • sysclk_switch
  • src
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • crm
  • sysclk_switch
  • src
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • crm
  • sysclk_switch
  • src
project/at_start_f413/examples/crm/sysclk_switch/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36static void clkout_config(void);
37static void sclk_64m_hick_config(void);
38static void sclk_96m_hext_config(void);
39static void switch_system_clock(void);
40
46void clkout_config(void)
47{
48 gpio_init_type gpio_init_struct;
49
50 /* enable gpio port clock */
51 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
52
53 /* set default parameter */
54 gpio_default_para_init(&gpio_init_struct);
55
56 /* clkout gpio init */
57 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pins = GPIO_PINS_8;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init(GPIOA, &gpio_init_struct);
62
63 /* config clkout division */
64 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
65
66 /* config clkout clock */
67 crm_clock_out_set(CRM_CLKOUT_PLL_DIV_4);
68}
69
75static void switch_system_clock(void)
76{
77 if(CRM->cfg_bit.pllrcs == RESET)
78 {
79 sclk_96m_hext_config();
80 }
81 else
82 {
83 sclk_64m_hick_config();
84 }
85}
86
105static void sclk_64m_hick_config(void)
106{
107 /* reset crm */
108 crm_reset();
109
110 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
111
112 /* wait till hick is ready */
113 while(crm_flag_get(CRM_HICK_STABLE_FLAG) != SET)
114 {
115 }
116
117 /* config pll clock resource */
118 crm_pll_config(CRM_PLL_SOURCE_HICK, CRM_PLL_MULT_16, CRM_PLL_OUTPUT_RANGE_LE72MHZ);
119
120 /* enable pll */
121 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
122
123 /* wait till pll is ready */
124 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
125 {
126 }
127
128 /* config ahbclk */
129 crm_ahb_div_set(CRM_AHB_DIV_1);
130
131 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
132 crm_apb2_div_set(CRM_APB2_DIV_2);
133
134 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
135 crm_apb1_div_set(CRM_APB1_DIV_2);
136
137 /* enable auto step mode */
138 crm_auto_step_mode_enable(TRUE);
139
140 /* select pll as system clock source */
141 crm_sysclk_switch(CRM_SCLK_PLL);
142
143 /* wait till pll is used as system clock source */
144 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
145 {
146 }
147
148 /* disable auto step mode */
149 crm_auto_step_mode_enable(FALSE);
150
151 /* update system_core_clock global variable */
152 system_core_clock_update();
153
154 /* config systick delay */
155 delay_init();
156
157 /* config clkout */
158 clkout_config();
159}
160
179static void sclk_96m_hext_config(void)
180{
181 /* reset crm */
182 crm_reset();
183
184 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
185
186 /* wait till hext is ready */
187 while(crm_hext_stable_wait() == ERROR)
188 {
189 }
190
191 /* config pll clock resource */
192 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_24, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
193
194 /* enable pll */
195 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
196
197 /* wait till pll is ready */
198 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
199 {
200 }
201
202 /* config ahbclk */
203 crm_ahb_div_set(CRM_AHB_DIV_1);
204
205 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
206 crm_apb2_div_set(CRM_APB2_DIV_2);
207
208 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
209 crm_apb1_div_set(CRM_APB1_DIV_2);
210
211 /* enable auto step mode */
212 crm_auto_step_mode_enable(TRUE);
213
214 /* select pll as system clock source */
215 crm_sysclk_switch(CRM_SCLK_PLL);
216
217 /* wait till pll is used as system clock source */
218 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
219 {
220 }
221
222 /* disable auto step mode */
223 crm_auto_step_mode_enable(FALSE);
224
225 /* update system_core_clock global variable */
226 system_core_clock_update();
227
228 /* config systick delay */
229 delay_init();
230
231 /* config clkout */
232 clkout_config();
233}
234
240int main(void)
241{
242 system_clock_config();
243
244 at32_board_init();
245
246 clkout_config();
247
248 while(1)
249 {
250 if(at32_button_press() == USER_BUTTON)
251 {
252 switch_system_clock();
253 at32_led_toggle(LED4);
254 }
255 at32_led_toggle(LED2);
256 delay_ms(100);
257 }
258}
259
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
clkout_config
static void clkout_config(void)
clkout configuration.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:46
sclk_96m_hext_config
static void sclk_96m_hext_config(void)
config sclk 96 mhz with hext clock source.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:179
main
int main(void)
main function.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:240
sclk_64m_hick_config
static void sclk_64m_hick_config(void)
config sclk 64 mhz with hick clock source.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:105
switch_system_clock
static void switch_system_clock(void)
sclk switch function.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:75
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
delay_init
void delay_init()
initialize delay function
Definition: at32f413_board.c:312
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:805
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:684
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:292
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:418
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:273
CRM_PLL_MULT_24
@ CRM_PLL_MULT_24
Definition: at32f413_crm.h:225
CRM_PLL_MULT_16
@ CRM_PLL_MULT_16
Definition: at32f413_crm.h:217
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:408
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_LE72MHZ
@ CRM_PLL_OUTPUT_RANGE_LE72MHZ
Definition: at32f413_crm.h:283
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f413_crm.h:53
CRM
#define CRM
Definition: at32f413_crm.h:842
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • debug
  • tmr1
  • inc
project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • debug
  • tmr1
  • inc
project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • debug
  • tmr1
  • inc
project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • debug
  • tmr1
  • src
project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • debug
  • tmr1
  • src
project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • debug
  • tmr1
  • src
project/at_start_f413/examples/debug/tmr1/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
37 crm_clocks_freq_type crm_clocks_freq_struct = {0};
38uint16_t counter = 0;
39
45void TMR1_OVF_TMR10_IRQHandler(void)
46{
47 if(tmr_flag_get(TMR1, TMR_OVF_FLAG) != RESET)
48 {
49 /* add user code... */
50 at32_led_toggle(LED3);
51 tmr_flag_clear(TMR1, TMR_OVF_FLAG);
52 }
53}
54
60int main(void)
61{
62 system_clock_config();
63
64 at32_board_init();
65
66 /* get system clock */
67 crm_clocks_freq_get(&crm_clocks_freq_struct);
68
69 /* turn led2/led3/led4 on */
70 at32_led_on(LED2);
71 at32_led_on(LED3);
72 at32_led_on(LED4);
73
74 /* enable tmr1 clock */
75 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
76
77 /* enable tmr1 debug mode */
78 debug_periph_mode_set(DEBUG_TMR1_PAUSE, TRUE);
79
80 /* tmr1 configuration */
81 tmr_base_init(TMR1, 10000, 0);
82 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
83
84 /* overflow interrupt enable */
85 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
86
87 /* tmr1 interrupt nvic init */
88 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
89 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 1, 0);
90
91 /* enable tmr1 */
92 tmr_counter_enable(TMR1, TRUE);
93
94 while(1)
95 {
96 /* in debug mode,tmr1 counter will pause */
97 counter = tmr_counter_value_get(TMR1);
98 counter = tmr_counter_value_get(TMR1);
99 counter = tmr_counter_value_get(TMR1);
100 counter = tmr_counter_value_get(TMR1);
101 counter = tmr_counter_value_get(TMR1);
102 }
103}
104
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:60
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:37
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
this function handles tmr1 overflow handler.
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:45
counter
uint16_t counter
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:196
debug_periph_mode_set
void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode
Definition: at32f413_debug.c:77
DEBUG_TMR1_PAUSE
#define DEBUG_TMR1_PAUSE
Definition: at32f413_debug.h:54
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:268
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:50
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:72
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • dma
  • data_to_gpio_flexible
  • inc
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • dma
  • data_to_gpio_flexible
  • inc
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • dma
  • data_to_gpio_flexible
  • inc
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • dma
  • data_to_gpio_flexible
  • src
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • dma
  • data_to_gpio_flexible
  • src
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • dma
  • data_to_gpio_flexible
  • src
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 dma_init_type dma_init_struct = {0};
38
39#define BUFFER_SIZE 16
40uint16_t src_buffer[BUFFER_SIZE] = {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
41 0x0009, 0x000A, 0x000B, 0x000C, 0x000D, 0x000E, 0x000F, 0x0010};
42
48void DMA2_Channel1_IRQHandler(void)
49{
50 if(dma_flag_get(DMA2_FDT1_FLAG) != RESET)
51 {
52 /* turn led2/led3/led4 on */
53 at32_led_on(LED2);
54 at32_led_on(LED3);
55 at32_led_on(LED4);
56 dma_flag_clear(DMA2_FDT1_FLAG);
57 }
58}
59
65int main(void)
66{
67 system_clock_config();
68
69 at32_board_init();
70
71 /* enable dma2/gpiob/tmr2 clock */
72 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
73 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
74 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
75 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
76 gpio_pin_remap_config(SWJTAG_CONF_010, TRUE);
77 /* config gpioc pin for output mode */
78 gpio_init_struct.gpio_pins = GPIO_PINS_ALL;
79 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
80 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
81 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
82 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
83 gpio_init(GPIOB, &gpio_init_struct);
84
85 tmr_base_init(TMR2, 0xFF, 0);
86 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
87
88 /* enable tmr2 overflow dma request */
89 tmr_dma_request_enable(TMR2, TMR_OVERFLOW_DMA_REQUEST, TRUE);
90
91 /* dma2 channel1 configuration */
92 dma_reset(DMA2_CHANNEL1);
93 dma_init_struct.buffer_size = BUFFER_SIZE;
94 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
95 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
96 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
97 dma_init_struct.memory_inc_enable = TRUE;
98 dma_init_struct.peripheral_base_addr = (uint32_t)&GPIOB->odt;
99 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
100 dma_init_struct.peripheral_inc_enable = FALSE;
101 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
102 dma_init_struct.loop_mode_enable = FALSE;
103 dma_init(DMA2_CHANNEL1, &dma_init_struct);
104
105 /* enable transfer full data interrupt */
106 dma_interrupt_enable(DMA2_CHANNEL1, DMA_FDT_INT, TRUE);
107
108 /* dma2 channel1 interrupt nvic init */
109 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
110 nvic_irq_enable(DMA2_Channel1_IRQn, 1, 0);
111
112 /* tmr2 flexible function enable */
113 dma_flexible_config(DMA2, FLEX_CHANNEL1, DMA_FLEXIBLE_TMR2_OVERFLOW);
114
115 /* enable dma channel */
116 dma_channel_enable(DMA2_CHANNEL1, TRUE);
117
118 /* enable tmr2 */
119 tmr_counter_enable(TMR2, TRUE);
120
121 while(1)
122 {
123 }
124}
125
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
DMA2_Channel1_IRQHandler
void DMA2_Channel1_IRQHandler(void)
this function handles DMA2 channel1 handler.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:48
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:65
src_buffer
uint16_t src_buffer[16]
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:103
DMA2_Channel1_IRQn
@ DMA2_Channel1_IRQn
Definition: at32f413.h:222
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:236
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_FLEXIBLE_TMR2_OVERFLOW
@ DMA_FLEXIBLE_TMR2_OVERFLOW
Definition: at32f413_dma.h:178
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f413_dma.h:109
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:62
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA2
#define DMA2
Definition: at32f413_dma.h:486
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f413_dma.h:487
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_ALL
#define GPIO_PINS_ALL
Definition: at32f413_gpio.h:65
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
SWJTAG_CONF_010
#define SWJTAG_CONF_010
Definition: at32f413_gpio.h:97
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1286
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:267
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • dma
  • flash_to_sram
  • inc
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • dma
  • flash_to_sram
  • inc
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • dma
  • flash_to_sram
  • inc
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • dma
  • flash_to_sram
  • src
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • dma
  • flash_to_sram
  • src
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • dma
  • flash_to_sram
  • src
project/at_start_f413/examples/dma/flash_to_sram/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
37#define BUFFER_SIZE 32
38
39const uint32_t src_const_buffer[BUFFER_SIZE]= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
40 0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
41 0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
42 0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
43 0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
44 0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
45 0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
46 0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80};
47uint32_t dst_buffer[BUFFER_SIZE];
48 gpio_init_type gpio_init_struct = {0};
49 dma_init_type dma_init_struct = {0};
50__IO uint32_t data_counter_end = 0x01; /* this variable should not be initialized to 0 */
51 error_status transfer_status = ERROR;
52
53 error_status buffer_compare(const uint32_t* pbuffer, uint32_t* pbuffer1, uint16_t buffer_length);
54
60void DMA1_Channel1_IRQHandler(void)
61{
62 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
63 {
64 data_counter_end = 0;
65 dma_flag_clear(DMA1_FDT1_FLAG);
66 }
67}
68
76 error_status buffer_compare(const uint32_t* pbuffer, uint32_t* pbuffer1, uint16_t buffer_length)
77{
78 while(buffer_length--)
79 {
80 if(*pbuffer != *pbuffer1)
81 {
82 return ERROR;
83 }
84
85 pbuffer++;
86 pbuffer1++;
87 }
88
89 return SUCCESS;
90}
91
97int main(void)
98{
99 system_clock_config();
100
101 at32_board_init();
102
103 /* enable dma1 clock */
104 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
105
106 /* dma1 channel1 configuration */
107 dma_reset(DMA1_CHANNEL1);
108 dma_init_struct.buffer_size = BUFFER_SIZE;
109 dma_init_struct.direction = DMA_DIR_MEMORY_TO_MEMORY;
110 dma_init_struct.memory_base_addr = (uint32_t)dst_buffer;
111 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
112 dma_init_struct.memory_inc_enable = TRUE;
113 dma_init_struct.peripheral_base_addr = (uint32_t)src_const_buffer;
114 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
115 dma_init_struct.peripheral_inc_enable = TRUE;
116 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
117 dma_init_struct.loop_mode_enable = FALSE;
118 dma_init(DMA1_CHANNEL1, &dma_init_struct);
119
120 /* enable transfer full data interrupt */
121 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
122
123 /* dma1 channel1 interrupt nvic init */
124 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
125 nvic_irq_enable(DMA1_Channel1_IRQn, 1, 0);
126
127 dma_channel_enable(DMA1_CHANNEL1, TRUE);
128
129 /* wait the end of transmission */
130 while(data_counter_end != 0)
131 {
132 }
133
134 /* check if the transmitted and received data are equal */
135 transfer_status = buffer_compare(src_const_buffer, dst_buffer, BUFFER_SIZE);
136
137 /* transfer_status = passed, if the transmitted and received data are the same
138 transfer_status = failed, if the transmitted and received data are different */
139 if(transfer_status == SUCCESS)
140 {
141 /* turn led2/led3/led4 on */
142 at32_led_on(LED2);
143 at32_led_on(LED3);
144 at32_led_on(LED4);
145 }
146
147 while(1)
148 {
149 }
150}
151
152
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:48
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:49
src_const_buffer
const uint32_t src_const_buffer[32]
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:39
data_counter_end
__IO uint32_t data_counter_end
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:50
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:37
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1 channel1 handler.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:60
main
int main(void)
main function.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:97
dst_buffer
uint32_t dst_buffer[32]
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:47
buffer_compare
error_status buffer_compare(const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:76
transfer_status
error_status transfer_status
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:51
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:245
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:255
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • exint
  • exint_config
  • inc
project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • exint
  • exint_config
  • inc
project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • exint
  • exint_config
  • inc
project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • exint
  • exint_config
  • src
project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • exint
  • exint_config
  • src
project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • exint
  • exint_config
  • src
project/at_start_f413/examples/exint/exint_config/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
38void exint_line0_config(void);
39
45int main(void)
46{
47 system_clock_config();
48
49 at32_board_init();
50
51 /* turn led2/led3/led4 on */
52 at32_led_on(LED2);
53 at32_led_on(LED3);
54 at32_led_on(LED4);
55
56 /* configure pa0 in interrupt mode */
57 exint_line0_config();
58
59 while(1)
60 {
61 }
62}
63
69void exint_line0_config(void)
70{
71 exint_init_type exint_init_struct;
72
73 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
74 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
75
76 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
77
78 exint_default_para_init(&exint_init_struct);
79 exint_init_struct.line_enable = TRUE;
80 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
81 exint_init_struct.line_select = EXINT_LINE_0;
82 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
83 exint_init(&exint_init_struct);
84
85 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
86 nvic_irq_enable(EXINT0_IRQn, 1, 0);
87}
88
94void EXINT0_IRQHandler(void)
95{
96 if(exint_flag_get(EXINT_LINE_0) != RESET)
97 {
98 at32_led_toggle(LED2);
99 at32_led_toggle(LED3);
100 at32_led_toggle(LED4);
101 exint_flag_clear(EXINT_LINE_0);
102 }
103}
104
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:45
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:94
exint_line0_config
void exint_line0_config(void)
exint line0 config. configure pa0 in interrupt mode
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:69
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:176
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:140
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:50
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:252
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:275
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • exint
  • exint_software_trigger
  • inc
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • exint
  • exint_software_trigger
  • inc
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • exint
  • exint_software_trigger
  • inc
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • exint
  • exint_software_trigger
  • src
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • exint
  • exint_software_trigger
  • src
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • exint
  • exint_software_trigger
  • src
project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
38void exint_line4_config(void);
39static void tmr1_config(void);
40
46void exint_line4_config(void)
47{
48 exint_init_type exint_init_struct;
49
50 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
51
52 exint_default_para_init(&exint_init_struct);
53 exint_init_struct.line_enable = TRUE;
54 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
55 exint_init_struct.line_select = EXINT_LINE_4;
56 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
57 exint_init(&exint_init_struct);
58
59 nvic_irq_enable(EXINT4_IRQn, 1, 0);
60}
61
67static void tmr1_config(void)
68{
69 crm_clocks_freq_type crm_clocks_freq_struct = {0};
70
71 /* get system clock */
72 crm_clocks_freq_get(&crm_clocks_freq_struct);
73
74 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
75
76 /* (systemclock / (system_core_clock/10000)) / 10000 = 1Hz(1s) */
77 tmr_base_init(TMR1, 10000-1, system_core_clock/10000-1);
78 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
79 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
80 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
81 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 0, 0);
82}
83
89void TMR1_OVF_TMR10_IRQHandler(void)
90{
91 if(tmr_flag_get(TMR1,TMR_OVF_FLAG) != RESET)
92 {
93 at32_led_toggle(LED2);
94 exint_software_interrupt_event_generate(EXINT_LINE_4);
95 tmr_flag_clear(TMR1,TMR_OVF_FLAG);
96 }
97}
98
104void EXINT4_IRQHandler(void)
105{
106 if(exint_flag_get(EXINT_LINE_4) != RESET)
107 {
108 at32_led_toggle(LED3);
109 at32_led_toggle(LED4);
110 exint_flag_clear(EXINT_LINE_4);
111 }
112}
113
119int main(void)
120{
121 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
122 system_clock_config();
123
124 at32_board_init();
125
126 /* turn led2/led3/led4 on */
127 at32_led_on(LED2);
128 at32_led_on(LED3);
129 at32_led_on(LED4);
130 tmr1_config();
131 exint_line4_config();
132 tmr_counter_enable(TMR1, TRUE);
133 while(1)
134 {
135 }
136}
137
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:37
exint_line4_config
void exint_line4_config(void)
exint line4 config. configure pa0 in interrupt mode
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:119
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:67
EXINT4_IRQHandler
void EXINT4_IRQHandler(void)
exint4 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:104
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
tmr1 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:89
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:196
EXINT4_IRQn
@ EXINT4_IRQn
Definition: at32f413.h:180
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:140
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f413_exint.c:167
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_LINE_4
#define EXINT_LINE_4
Definition: at32f413_exint.h:54
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:50
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:72
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • flash
  • fap_enable
  • inc
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • flash
  • fap_enable
  • inc
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • flash
  • fap_enable
  • inc
project/at_start_f413/examples/flash/fap_enable/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • flash
  • fap_enable
  • src
project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • flash
  • fap_enable
  • src
project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/flash/fap_enable/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • flash
  • fap_enable
  • src
project/at_start_f413/examples/flash/fap_enable/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
41int main(void)
42{
43 flash_status_type status = FLASH_OPERATE_DONE;
44 system_clock_config();
45 at32_board_init();
46 if(flash_fap_status_get() == RESET)
47 {
48 flash_unlock();
49 /* wait for operation to be completed */
50 status = flash_operation_wait_for(OPERATION_TIMEOUT);
51
52 if(status != FLASH_OPERATE_TIMEOUT)
53 {
54 if((status == FLASH_PROGRAM_ERROR) || (status == FLASH_EPP_ERROR))
55 flash_flag_clear(FLASH_PRGMERR_FLAG | FLASH_EPPERR_FLAG);
56
57 status = flash_fap_enable(TRUE);
58 if(status == FLASH_OPERATE_DONE)
59 nvic_system_reset();
60 }
61 }else
62 {
63 at32_led_on(LED2);
64 at32_led_on(LED3);
65 at32_led_on(LED4);
66 }
67 while(1)
68 {
69 }
70}
71
72
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/flash/fap_enable/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f413_flash.c:657
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f413_flash.c:615
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f413_flash.c:178
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:96
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:157
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:161
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f413_flash.h:162
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f413_flash.h:159
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f413_flash.h:160
FLASH_PRGMERR_FLAG
#define FLASH_PRGMERR_FLAG
Definition: at32f413_flash.h:77
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f413_flash.h:78
OPERATION_TIMEOUT
#define OPERATION_TIMEOUT
Definition: at32f413_flash.h:143
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: flash.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/flash.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __FLASH_H__
27#define __FLASH_H__
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413_board.h"
34
48void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read);
49 error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write);
50 error_status flash_write(uint32_t write_addr,uint16_t *p_Buffer, uint16_t num_write);
51
64#ifdef __cplusplus
65}
66#endif
67
68#endif
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
error_status
error_status
error status
Definition: at32f413.h:301
flash_write
error_status flash_write(uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:89
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:51
flash_write_nocheck
error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:68


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: flash.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/flash.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "flash.h"
27
36#if defined (AT32F413xC)
37#define SECTOR_SIZE 2048 /* this parameter depends on the specific model of the chip */
38#else
39#define SECTOR_SIZE 1024 /* this parameter depends on the specific model of the chip */
40#endif
41
42uint16_t flash_buf[SECTOR_SIZE / 2];
43
51void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
52{
53 uint16_t i;
54 for(i = 0; i < num_read; i++)
55 {
56 p_buffer[i] = *(uint16_t*)(read_addr);
57 read_addr += 2;
58 }
59}
60
68 error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
69{
70 uint16_t i;
71 flash_status_type status = FLASH_OPERATE_DONE;
72 for(i = 0; i < num_write; i++)
73 {
74 status = flash_halfword_program(write_addr, p_buffer[i]);
75 if(status != FLASH_OPERATE_DONE)
76 return ERROR;
77 write_addr += 2;
78 }
79 return SUCCESS;
80}
81
89 error_status flash_write(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
90{
91 uint32_t offset_addr;
92 uint32_t sector_position;
93 uint16_t sector_offset;
94 uint16_t sector_remain;
95 uint16_t i;
96 flash_status_type status = FLASH_OPERATE_DONE;
97
98 flash_unlock();
99 offset_addr = write_addr - FLASH_BASE;
100 sector_position = offset_addr / SECTOR_SIZE;
101 sector_offset = (offset_addr % SECTOR_SIZE) / 2;
102 sector_remain = SECTOR_SIZE / 2 - sector_offset;
103 if(num_write <= sector_remain)
104 sector_remain = num_write;
105 while(1)
106 {
107 flash_read(sector_position * SECTOR_SIZE + FLASH_BASE, flash_buf, SECTOR_SIZE / 2);
108 for(i = 0; i < sector_remain; i++)
109 {
110 if(flash_buf[sector_offset + i] != 0xFFFF)
111 break;
112 }
113 if(i < sector_remain)
114 {
115 /* wait for operation to be completed */
116 status = flash_operation_wait_for(ERASE_TIMEOUT);
117
118 if((status == FLASH_PROGRAM_ERROR) || (status == FLASH_EPP_ERROR))
119 flash_flag_clear(FLASH_PRGMERR_FLAG | FLASH_EPPERR_FLAG);
120 else if(status == FLASH_OPERATE_TIMEOUT)
121 return ERROR;
122 status = flash_sector_erase(sector_position * SECTOR_SIZE + FLASH_BASE);
123 if(status != FLASH_OPERATE_DONE)
124 return ERROR;
125 for(i = 0; i < sector_remain; i++)
126 {
127 flash_buf[i + sector_offset] = p_buffer[i];
128 }
129 if(flash_write_nocheck(sector_position * SECTOR_SIZE + FLASH_BASE, flash_buf, SECTOR_SIZE / 2) != SUCCESS)
130 return ERROR;
131 }
132 else
133 {
134 if(flash_write_nocheck(write_addr, p_buffer, sector_remain) != SUCCESS)
135 return ERROR;
136 }
137 if(num_write == sector_remain)
138 break;
139 else
140 {
141 sector_position++;
142 sector_offset = 0;
143 p_buffer += sector_remain;
144 write_addr += (sector_remain * 2);
145 num_write -= sector_remain;
146 if(num_write > (SECTOR_SIZE / 2))
147 sector_remain = SECTOR_SIZE / 2;
148 else
149 sector_remain = num_write;
150 }
151 }
152 flash_lock();
153 return SUCCESS;
154}
155
156
157
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
flash_buf
uint16_t flash_buf[1024/2]
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:42
flash_write
error_status flash_write(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:89
SECTOR_SIZE
#define SECTOR_SIZE
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:39
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:51
flash_write_nocheck
error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:68
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:450
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f413_flash.c:178
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:96
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:157
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:161
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f413_flash.h:162
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f413_flash.h:159
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f413_flash.h:160
FLASH_PRGMERR_FLAG
#define FLASH_PRGMERR_FLAG
Definition: at32f413_flash.h:77
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f413_flash.h:78
ERASE_TIMEOUT
#define ERASE_TIMEOUT
Definition: at32f413_flash.h:139
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328


AT32F413 Firmwary Library: main.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "flash.h"
28
37#define TEST_BUFEER_SIZE 3000
38#define TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)
39
40uint16_t buffer_write[TEST_BUFEER_SIZE];
41uint16_t buffer_read[TEST_BUFEER_SIZE];
42
43 error_status buffer_compare(uint16_t* p_buffer1, uint16_t* p_buffer2, uint16_t buffer_length);
44
52 error_status buffer_compare(uint16_t* p_buffer1, uint16_t* p_buffer2, uint16_t buffer_length)
53{
54 while(buffer_length--)
55 {
56 if(*p_buffer1 != *p_buffer2)
57 {
58 return ERROR;
59 }
60 p_buffer1++;
61 p_buffer2++;
62 }
63 return SUCCESS;
64}
65
71int main(void)
72{
73 uint32_t index=0;
74 error_status err_status;
75 system_clock_config();
76 at32_board_init();
77 /* fill buffer_write data to test */
78 for(index = 0; index < TEST_BUFEER_SIZE; index++)
79 {
80 buffer_write[index] = index;
81 }
82
83 /* write data to flash */
84 err_status = flash_write(TEST_FLASH_ADDRESS_START, buffer_write, TEST_BUFEER_SIZE);
85
86 /* read data from flash */
87 flash_read(TEST_FLASH_ADDRESS_START, buffer_read, TEST_BUFEER_SIZE);
88
89 /* compare the buffer */
90 if((buffer_compare(buffer_write, buffer_read, TEST_BUFEER_SIZE) == SUCCESS) && (err_status == SUCCESS))
91 {
92 at32_led_on(LED2);
93 at32_led_on(LED3);
94 at32_led_on(LED4);
95 }
96
97 while(1)
98 {
99 }
100}
101
102
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
TEST_BUFEER_SIZE
#define TEST_BUFEER_SIZE
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:37
buffer_compare
error_status buffer_compare(uint16_t *p_buffer1, uint16_t *p_buffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:52
buffer_read
uint16_t buffer_read[3000]
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:41
TEST_FLASH_ADDRESS_START
#define TEST_FLASH_ADDRESS_START
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:71
buffer_write
uint16_t buffer_write[3000]
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
flash_write
error_status flash_write(uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:89
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:51
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • flash
  • operate_spim
  • inc
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • flash
  • operate_spim
  • inc
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • flash
  • operate_spim
  • inc
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • flash
  • operate_spim
  • src
project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • flash
  • operate_spim
  • src
project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • flash
  • operate_spim
  • src
project/at_start_f413/examples/flash/operate_spim/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "operate_spim.h"
28
29
43int main(void)
44{
45 system_clock_config();
46
47 at32_board_init();
48
49 /* operate spim flash */
50 spim_operate();
51
52 while(1)
53 {
54
55 }
56}
57
58
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/flash/operate_spim/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
spim_operate
void spim_operate(void)
operate spim flash
Definition: operate_spim.c:107
operate_spim.h
operate_spim header file
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • flash
  • run_in_spim
  • inc
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • flash
  • run_in_spim
  • inc
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • flash
  • run_in_spim
  • inc
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • flash
  • run_in_spim
  • src
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • flash
  • run_in_spim
  • src
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • flash
  • run_in_spim
  • src
project/at_start_f413/examples/flash/run_in_spim/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "run_in_spim.h"
28
29
43void spim_init(void)
44{
45 gpio_init_type gpio_init_struct;
46
47 /* enable the clock */
48 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
51
52 /* init spim io */
53 gpio_default_para_init(&gpio_init_struct);
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init_struct.gpio_pins = GPIO_PINS_8;
59 gpio_init(GPIOA, &gpio_init_struct);
60 gpio_init_struct.gpio_pins = GPIO_PINS_1 | GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_10 | GPIO_PINS_11;
61 gpio_init(GPIOB, &gpio_init_struct);
62
63 /* enable spim, and select pb10, pb11 as spim io */
64 gpio_pin_remap_config(EXT_SPIM_GMUX_1001, TRUE);
65
66 /* in this example, use on-board en25qh128a as spim flash */
67 flash_spim_model_select(FLASH_SPIM_MODEL2);
68
69 /* unlock the spim flash program erase controller */
70 while(flash_flag_get(FLASH_SPIM_OBF_FLAG));
71 flash_spim_unlock();
72 while(FLASH->ctrl3_bit.oplk);
73
74 /* if the data written to spim flash need to be scrambled, please specify the scrambled range */
75 flash_spim_encryption_range_set(0);
76
77 return;
78}
79
85int main(void)
86{
87 system_clock_config();
88 at32_board_init();
89
90 /* configures the spim flash */
91 spim_init();
92
93 /* check the led toggle in spim */
94 spim_run();
95
96 while(1)
97 {
98 }
99}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
spim_run
void spim_run(void)
check the led toggle in spim
Definition: run_in_spim.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/main.c:85
spim_init
void spim_init(void)
init the spim flash
Definition: project/at_start_f413/examples/flash/run_in_spim/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
TRUE
@ TRUE
Definition: at32f413.h:296
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:238
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:744
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:759
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:57
FLASH_SPIM_MODEL2
@ FLASH_SPIM_MODEL2
Definition: at32f413_flash.h:171
FLASH_SPIM_OBF_FLAG
#define FLASH_SPIM_OBF_FLAG
Definition: at32f413_flash.h:79
FLASH
#define FLASH
Definition: at32f413_flash.h:562
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
EXT_SPIM_GMUX_1001
#define EXT_SPIM_GMUX_1001
Definition: at32f413_gpio.h:189
run_in_spim.h
run_in_spim header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • gpio
  • io_toggle
  • inc
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • gpio
  • io_toggle
  • inc
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • gpio
  • io_toggle
  • inc
project/at_start_f413/examples/gpio/io_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • gpio
  • io_toggle
  • src
project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • gpio
  • io_toggle
  • src
project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • gpio
  • io_toggle
  • src
project/at_start_f413/examples/gpio/io_toggle/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
42void gpio_config(void)
43{
44 gpio_init_type gpio_init_struct;
45
46 /* enable the gpioa clock */
47 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
48
49 /* set default parameter */
50 gpio_default_para_init(&gpio_init_struct);
51
52 /* configure the gpio */
53 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
54 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
55 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
56 gpio_init_struct.gpio_pins = GPIO_PINS_1;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init(GPIOA, &gpio_init_struct);
59}
60
66int main(void)
67{
68 system_clock_config();
69
70 gpio_config();
71
72 while(1)
73 {
74 /* set pa.01 */
75 GPIOA->scr = GPIO_PINS_1;
76 /* reset pa.01 */
77 GPIOA->clr = GPIO_PINS_1;
78
79 /* set pa.01 */
80 GPIOA->scr = GPIO_PINS_1;
81 /* reset pa.01 */
82 GPIOA->clr = GPIO_PINS_1;
83
84 /* set pa.01 */
85 GPIOA->scr = GPIO_PINS_1;
86 /* reset pa.01 */
87 GPIOA->clr = GPIO_PINS_1;
88
89 /* set pa.01 */
90 GPIOA->scr = GPIO_PINS_1;
91 /* reset pa.01 */
92 GPIOA->clr = GPIO_PINS_1;
93
94 /* set pa.01 */
95 GPIOA->scr = GPIO_PINS_1;
96 /* reset pa.01 */
97 GPIOA->clr = GPIO_PINS_1;
98
99 /* set pa.01 */
100 GPIOA->scr = GPIO_PINS_1;
101 /* reset pa.01 */
102 GPIOA->clr = GPIO_PINS_1;
103 }
104}
105
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
main
int main(void)
main function.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/main.c:66
gpio_config
void gpio_config(void)
pa.01 gpio configuration.
Definition: project/at_start_f413/examples/gpio/io_toggle/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • gpio
  • led_toggle
  • inc
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • gpio
  • led_toggle
  • inc
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • gpio
  • led_toggle
  • inc
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • gpio
  • led_toggle
  • src
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • gpio
  • led_toggle
  • src
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • gpio
  • led_toggle
  • src
project/at_start_f413/examples/gpio/led_toggle/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
42int main(void)
43{
44 system_clock_config();
45
46 at32_board_init();
47
48 while(1)
49 {
50 at32_led_toggle(LED2);
51 delay_ms(200);
52 at32_led_toggle(LED3);
53 delay_ms(200);
54 at32_led_toggle(LED4);
55 delay_ms(200);
56 }
57}
58
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • gpio
  • swjtag_remap
  • inc
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • gpio
  • swjtag_remap
  • inc
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • gpio
  • swjtag_remap
  • inc
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • gpio
  • swjtag_remap
  • src
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • gpio
  • swjtag_remap
  • src
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • gpio
  • swjtag_remap
  • src
project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
37void swj_dp_config(void);
38void gpio_pins_toggle(gpio_type* gpio_x, uint16_t gpio_pin);
39
45void swj_dp_config(void)
46{
47 gpio_init_type gpio_init_struct;
48
49 /* configure pa13 (jtms/swdat), pa14 (jtck/swclk) and pa15 (jtdi) as output push-pull */
50 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
51 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
52 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init(GPIOA, &gpio_init_struct);
56
57 /* configure pb3 (jtdo) and pb4 (jtrst) as output push-pull */
58 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4;
59 gpio_init(GPIOB, &gpio_init_struct);
60}
61
68void gpio_pins_toggle(gpio_type* gpio_x, uint16_t gpio_pin)
69{
70 gpio_x->odt ^= gpio_pin;
71}
72
78int main(void)
79{
80 system_clock_config();
81
82 at32_board_init();
83
84 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
85 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
86 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
87
88 swj_dp_config();
89
90 while(1)
91 {
92 if(USER_BUTTON == at32_button_press())
93 {
94 /* disable the serial wire jtag debug port swj-dp */
95 gpio_pin_remap_config(SWJTAG_CONF_100, TRUE);
96
97 /* turn on led3 */
98 at32_led_on(LED3);
99 }
100
101 /* toggle jtms/swdat pin */
102 gpio_pins_toggle(GPIOA, GPIO_PINS_13);
103 delay_us(200);
104
105 /* toggle jtck/swclk pin */
106 gpio_pins_toggle(GPIOA, GPIO_PINS_14);
107 delay_us(200);
108
109 /* toggle jtdi pin */
110 gpio_pins_toggle(GPIOA, GPIO_PINS_15);
111 delay_us(200);
112
113 /* toggle jtdo pin */
114 gpio_pins_toggle(GPIOB, GPIO_PINS_3);
115 delay_us(200);
116
117 /* toggle jtrst pin */
118 gpio_pins_toggle(GPIOB, GPIO_PINS_4);
119 delay_us(200);
120 }
121}
122
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
gpio_pins_toggle
void gpio_pins_toggle(gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/main.c:68
main
int main(void)
main function.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/main.c:78
swj_dp_config
void swj_dp_config(void)
configure the gpio of swj-dp.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
SWJTAG_CONF_100
#define SWJTAG_CONF_100
Definition: at32f413_gpio.h:98
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:298
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:386
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • communication_dma
  • inc
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • communication_dma
  • inc
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • communication_dma
  • inc
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • communication_dma
  • src
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • communication_dma
  • src
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "i2c_application.h"
28
29extern i2c_handle_type hi2cx;
30
31#define I2Cx_DMA_TX_IRQHandler DMA1_Channel6_IRQHandler
32#define I2Cx_DMA_RX_IRQHandler DMA1_Channel7_IRQHandler
33#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
34#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
35
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void I2Cx_DMA_RX_IRQHandler(void)
147{
148 i2c_dma_rx_irq_handler(&hi2cx);
149}
150
156void I2Cx_DMA_TX_IRQHandler(void)
157{
158 i2c_dma_tx_irq_handler(&hi2cx);
159}
160
166void I2Cx_EVT_IRQHandler(void)
167{
168 i2c_evt_irq_handler(&hi2cx);
169}
170
176void I2Cx_ERR_IRQHandler(void)
177{
178 i2c_err_irq_handler(&hi2cx);
179}
180
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:71
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:110
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:84
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:69
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:137
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:119
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2222
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2338
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2292
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2255
i2c_application.h
i2c application libray header file
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:33
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:34
I2Cx_DMA_TX_IRQHandler
#define I2Cx_DMA_TX_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:31
I2Cx_DMA_RX_IRQHandler
#define I2Cx_DMA_RX_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:32
i2c_handle_type
Definition: i2c_application.h:126
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • communication_dma
  • src
project/at_start_f413/examples/i2c/communication_dma/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "i2c_application.h"
28
37#define I2C_TIMEOUT 0xFFFFFFFF
38
39#define I2Cx_SPEED 100000
40#define I2Cx_ADDRESS 0xA0
41
42#define I2Cx_PORT I2C1
43#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
44
45#define I2Cx_SCL_PIN GPIO_PINS_6
46#define I2Cx_SCL_GPIO_PORT GPIOB
47#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
48
49#define I2Cx_SDA_PIN GPIO_PINS_7
50#define I2Cx_SDA_GPIO_PORT GPIOB
51#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
52
53#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
54#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6
55#define I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn
56
57#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7
58#define I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn
59
60#define I2Cx_EVT_IRQn I2C1_EVT_IRQn
61#define I2Cx_ERR_IRQn I2C1_ERR_IRQn
62
63#define BUF_SIZE 8
64#define MASTER_BOARD
65
66uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
67uint8_t rx_buf[BUF_SIZE] = {0};
68
69 i2c_handle_type hi2cx;
70
71uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
72void i2c_lowlevel_init(i2c_handle_type* hi2c);
73
79void error_handler(uint32_t error_code)
80{
81 while(1)
82 {
83 at32_led_toggle(LED2);
84 delay_ms(500);
85 }
86}
87
95uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
96{
97 uint32_t i;
98
99 for(i = 0; i < len; i++)
100 {
101 if(buffer1[i] != buffer2[i])
102 {
103 return 1;
104 }
105 }
106
107 return 0;
108}
109
115void i2c_lowlevel_init(i2c_handle_type* hi2c)
116{
117 gpio_init_type gpio_initstructure;
118
119 if(hi2c->i2cx == I2Cx_PORT)
120 {
121 /* i2c periph clock enable */
122 crm_periph_clock_enable(I2Cx_CLK, TRUE);
123 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
124 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
125
126 /* gpio configuration */
127 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
128 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
129 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
130 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
131
132 /* configure i2c pins: scl */
133 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
134 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
135
136 /* configure i2c pins: sda */
137 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
138 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
139
140 /* configure and enable i2c dma channel interrupt */
141 nvic_irq_enable(I2Cx_DMA_TX_IRQn, 0, 0);
142 nvic_irq_enable(I2Cx_DMA_RX_IRQn, 0, 0);
143
144 /* configure and enable i2c interrupt */
145 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
146 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
147
148 /* i2c dma tx and rx channels configuration */
149 /* enable the dma clock */
150 crm_periph_clock_enable(I2Cx_DMA_CLK, TRUE);
151
152 /* i2c dma channel configuration */
153 dma_reset(hi2c->dma_tx_channel);
154 dma_reset(hi2c->dma_rx_channel);
155
156 hi2c->dma_tx_channel = I2Cx_DMA_TX_CHANNEL;
157 hi2c->dma_rx_channel = I2Cx_DMA_RX_CHANNEL;
158
159 dma_default_para_init(&hi2c->dma_init_struct);
160 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
161 hi2c->dma_init_struct.memory_inc_enable = TRUE;
162 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
163 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
164 hi2c->dma_init_struct.loop_mode_enable = FALSE;
165 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
166 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
167
168 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
169 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
170
171 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
172
173 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
174 }
175}
176
182int main(void)
183{
184 i2c_status_type i2c_status;
185
186 /* config nvic priority group */
187 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
188
189 system_clock_config();
190
191 at32_board_init();
192
193 hi2cx.i2cx = I2Cx_PORT;
194
195 i2c_config(&hi2cx);
196
197 while(1)
198 {
199
200#if defined (MASTER_BOARD)
201
202 /* wait for key USER_BUTTON press before starting the communication */
203 while(at32_button_press() != USER_BUTTON)
204 {
205 }
206
207 /* start the request reception process */
208 if((i2c_status = i2c_master_transmit_dma(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
209 {
210 error_handler(i2c_status);
211 }
212
213 /* wait for the communication to end */
214 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
215 {
216 error_handler(i2c_status);
217 }
218
219 delay_ms(10);
220
221 /* start the request reception process */
222 if((i2c_status = i2c_master_receive_dma(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
223 {
224 error_handler(i2c_status);
225 }
226
227 /* wait for the communication to end */
228 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
229 {
230 error_handler(i2c_status);
231 }
232
233 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
234 {
235 at32_led_on(LED3);
236 }
237 else
238 {
239 error_handler(i2c_status);
240 }
241
242#else
243
244 /* wait for key USER_BUTTON press before starting the communication */
245 while(at32_button_press() != USER_BUTTON)
246 {
247 }
248
249 /* start the transmission process */
250 if((i2c_status = i2c_slave_receive_dma(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
251 {
252 error_handler(i2c_status);
253 }
254
255 /* wait for the communication to end */
256 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
257 {
258 error_handler(i2c_status);
259 }
260
261 if((i2c_status = i2c_slave_transmit_dma(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
262 {
263 error_handler(i2c_status);
264 }
265
266 /* wait for the communication to end */
267 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
268 {
269 error_handler(i2c_status);
270 }
271
272 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
273 {
274 at32_led_on(LED3);
275 }
276 else
277 {
278 error_handler(i2c_status);
279 }
280
281#endif
282
283 }
284}
285
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:67
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:66
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:40
I2Cx_DMA_RX_IRQn
#define I2Cx_DMA_RX_IRQn
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:58
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:43
I2Cx_DMA_TX_CHANNEL
#define I2Cx_DMA_TX_CHANNEL
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:54
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:63
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:182
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:45
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:69
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:50
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:95
I2Cx_DMA_CLK
#define I2Cx_DMA_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:53
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:51
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:61
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:79
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:115
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:39
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:42
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:47
I2Cx_DMA_RX_CHANNEL
#define I2Cx_DMA_RX_CHANNEL
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:57
I2Cx_DMA_TX_IRQn
#define I2Cx_DMA_TX_IRQn
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:55
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:60
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:46
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:128
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:1201
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:1024
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:1077
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:1125
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:263
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:224
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
i2c_status_type
i2c_status_type
Definition: i2c_application.h:93
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:135
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:136
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:134
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • communication_int
  • inc
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • communication_int
  • inc
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • communication_int
  • inc
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • communication_int
  • src
project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • communication_int
  • src
project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "i2c_application.h"
28
29extern i2c_handle_type hi2cx;
30
31#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
32#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
33
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void I2Cx_EVT_IRQHandler(void)
145{
146 i2c_evt_irq_handler(&hi2cx);
147}
148
154void I2Cx_ERR_IRQHandler(void)
155{
156 i2c_err_irq_handler(&hi2cx);
157}
158
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:69
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:108
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:117
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2222
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2338
i2c_application.h
i2c application libray header file
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:31
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:32
i2c_handle_type
Definition: i2c_application.h:126
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • communication_int
  • src
project/at_start_f413/examples/i2c/communication_int/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "i2c_application.h"
28
37#define I2C_TIMEOUT 0xFFFFFFFF
38
39#define I2Cx_SPEED 100000
40#define I2Cx_ADDRESS 0xA0
41
42#define I2Cx_PORT I2C1
43#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
44
45#define I2Cx_SCL_PIN GPIO_PINS_6
46#define I2Cx_SCL_GPIO_PORT GPIOB
47#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
48
49#define I2Cx_SDA_PIN GPIO_PINS_7
50#define I2Cx_SDA_GPIO_PORT GPIOB
51#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
52
53#define I2Cx_EVT_IRQn I2C1_EVT_IRQn
54#define I2Cx_ERR_IRQn I2C1_ERR_IRQn
55
56#define BUF_SIZE 8
57#define MASTER_BOARD
58
59uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
60uint8_t rx_buf[BUF_SIZE] = {0};
61
62 i2c_handle_type hi2cx;
63
64uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
65void error_handler(uint32_t error_code);
66void i2c_lowlevel_init(i2c_handle_type* hi2c);
67
73void error_handler(uint32_t error_code)
74{
75 while(1)
76 {
77 at32_led_toggle(LED2);
78 delay_ms(500);
79 }
80}
81
89uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
90{
91 uint32_t i;
92
93 for(i = 0; i < len; i++)
94 {
95 if(buffer1[i] != buffer2[i])
96 {
97 return 1;
98 }
99 }
100
101 return 0;
102}
103
109void i2c_lowlevel_init(i2c_handle_type* hi2c)
110{
111 gpio_init_type gpio_initstructure;
112
113 if(hi2c->i2cx == I2Cx_PORT)
114 {
115 /* i2c periph clock enable */
116 crm_periph_clock_enable(I2Cx_CLK, TRUE);
117 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
118 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
119
120 /* gpio configuration */
121 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
122 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
123 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
124 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
125
126 /* configure i2c pins: scl */
127 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
128 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
129
130 /* configure i2c pins: sda */
131 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
132 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
133
134 /* configure and enable i2c interrupt */
135 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
136 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
137
138 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
139
140 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
141 }
142}
143
149int main(void)
150{
151 i2c_status_type i2c_status;
152
153 /* config nvic priority group */
154 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
155
156 system_clock_config();
157
158 at32_board_init();
159
160 hi2cx.i2cx = I2Cx_PORT;
161
162 i2c_config(&hi2cx);
163
164 while(1)
165 {
166
167#if defined (MASTER_BOARD)
168
169 /* wait for key USER_BUTTON press before starting the communication */
170 while(at32_button_press() != USER_BUTTON)
171 {
172 }
173
174 /* start the request reception process */
175 if((i2c_status = i2c_master_transmit_int(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
176 {
177 error_handler(i2c_status);
178 }
179
180 /* wait for the communication to end */
181 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
182 {
183 error_handler(i2c_status);
184 }
185
186 delay_ms(10);
187
188 /* start the request reception process */
189 if((i2c_status = i2c_master_receive_int(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
190 {
191 error_handler(i2c_status);
192 }
193
194 /* wait for the communication to end */
195 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
196 {
197 error_handler(i2c_status);
198 }
199
200 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
201 {
202 at32_led_on(LED3);
203 }
204 else
205 {
206 error_handler(i2c_status);
207 }
208
209#else
210
211 /* wait for key USER_BUTTON press before starting the communication */
212 while(at32_button_press() != USER_BUTTON)
213 {
214 }
215
216 /* start the transmission process */
217 if((i2c_status = i2c_slave_receive_int(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
218 {
219 error_handler(i2c_status);
220 }
221
222 /* wait for the communication to end */
223 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
224 {
225 error_handler(i2c_status);
226 }
227
228 if((i2c_status = i2c_slave_transmit_int(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
229 {
230 error_handler(i2c_status);
231 }
232
233 /* wait for the communication to end */
234 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
235 {
236 error_handler(i2c_status);
237 }
238
239 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
240 {
241 at32_led_on(LED3);
242 }
243 else
244 {
245 error_handler(i2c_status);
246 }
247#endif
248
249 }
250}
251
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:60
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:59
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:40
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:43
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:56
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:149
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:45
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:62
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:50
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:89
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:51
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:54
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:73
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:109
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:39
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:42
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:47
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:53
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:46
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:128
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:985
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:907
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:821
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:868
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:224
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
i2c_status_type
i2c_status_type
Definition: i2c_application.h:93
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
i2c_application.h
i2c application libray header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • communication_poll
  • inc
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • communication_poll
  • inc
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • communication_poll
  • inc
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • communication_poll
  • src
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • communication_poll
  • src
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • communication_poll
  • src
project/at_start_f413/examples/i2c/communication_poll/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "i2c_application.h"
28
37#define I2C_TIMEOUT 0xFFFFFFFF
38
39#define I2Cx_SPEED 100000
40#define I2Cx_ADDRESS 0xA0
41
42#define I2Cx_PORT I2C1
43#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
44
45#define I2Cx_SCL_PIN GPIO_PINS_6
46#define I2Cx_SCL_GPIO_PORT GPIOB
47#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
48
49#define I2Cx_SDA_PIN GPIO_PINS_7
50#define I2Cx_SDA_GPIO_PORT GPIOB
51#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
52
53#define BUF_SIZE 8
54#define MASTER_BOARD
55
56uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
57uint8_t rx_buf[BUF_SIZE] = {0};
58
59 i2c_handle_type hi2cx;
60
61void error_handler(uint32_t error_code);
62uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
63void i2c_lowlevel_init(i2c_handle_type* hi2c);
64
70void error_handler(uint32_t error_code)
71{
72 while(1)
73 {
74 at32_led_toggle(LED2);
75 delay_ms(500);
76 }
77}
78
86uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
87{
88 uint32_t i;
89
90 for(i = 0; i < len; i++)
91 {
92 if(buffer1[i] != buffer2[i])
93 {
94 return 1;
95 }
96 }
97
98 return 0;
99}
100
106void i2c_lowlevel_init(i2c_handle_type* hi2c)
107{
108 gpio_init_type gpio_initstructure;
109
110 if(hi2c->i2cx == I2Cx_PORT)
111 {
112 /* i2c periph clock enable */
113 crm_periph_clock_enable(I2Cx_CLK, TRUE);
114 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
115 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
116
117 /* gpio configuration */
118 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
119 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
120 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
121 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
122
123 /* configure i2c pins: scl */
124 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
125 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
126
127 /* configure i2c pins: sda */
128 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
129 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
130
131 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
132
133 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
134 }
135}
136
142int main(void)
143{
144 i2c_status_type i2c_status;
145
146 system_clock_config();
147
148 at32_board_init();
149
150 hi2cx.i2cx = I2Cx_PORT;
151
152 i2c_config(&hi2cx);
153
154 while(1)
155 {
156
157#if defined (MASTER_BOARD)
158
159 /* wait for key USER_BUTTON press before starting the communication */
160 while(at32_button_press() != USER_BUTTON)
161 {
162 }
163
164 /* start the request reception process */
165 if((i2c_status = i2c_master_transmit(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
166 {
167 error_handler(i2c_status);
168 }
169
170 delay_ms(10);
171
172 /* start the request reception process */
173 if((i2c_status = i2c_master_receive(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
174 {
175 error_handler(i2c_status);
176 }
177
178 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
179 {
180 at32_led_on(LED3);
181 }
182 else
183 {
184 error_handler(i2c_status);
185 }
186#else
187
188 /* wait for key USER_BUTTON press before starting the communication */
189 while(at32_button_press() != USER_BUTTON)
190 {
191 }
192
193 /* start the transmission process */
194 if((i2c_status = i2c_slave_receive(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
195 {
196 error_handler(i2c_status);
197 }
198
199 if((i2c_status = i2c_slave_transmit(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
200 {
201 error_handler(i2c_status);
202 }
203
204 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
205 {
206 at32_led_on(LED3);
207 }
208 else
209 {
210 error_handler(i2c_status);
211 }
212#endif
213
214 }
215}
216
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:57
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:56
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:40
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:43
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:53
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:142
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:45
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:59
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:50
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:86
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:51
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:70
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:106
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:39
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:42
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:47
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:46
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:488
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:563
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:420
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:734
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:224
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
i2c_status_type
i2c_status_type
Definition: i2c_application.h:93
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
i2c_application.h
i2c application libray header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • eeprom
  • inc
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • eeprom
  • inc
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • eeprom
  • inc
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • eeprom
  • src
project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • eeprom
  • src
project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "i2c_application.h"
28
29extern i2c_handle_type hi2cx;
30
31#define I2Cx_DMA_TX_IRQHandler DMA1_Channel4_IRQHandler
32#define I2Cx_DMA_RX_IRQHandler DMA1_Channel5_IRQHandler
33#define I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
34#define I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler
35
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void I2Cx_DMA_RX_IRQHandler(void)
147{
148 i2c_dma_rx_irq_handler(&hi2cx);
149}
150
156void I2Cx_DMA_TX_IRQHandler(void)
157{
158 i2c_dma_tx_irq_handler(&hi2cx);
159}
160
166void I2Cx_EVT_IRQHandler(void)
167{
168 i2c_evt_irq_handler(&hi2cx);
169}
170
176void I2Cx_ERR_IRQHandler(void)
177{
178 i2c_err_irq_handler(&hi2cx);
179}
180
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:69
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:71
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:110
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:84
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:137
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:119
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2222
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2338
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2292
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2255
i2c_application.h
i2c application libray header file
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:33
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:34
I2Cx_DMA_TX_IRQHandler
#define I2Cx_DMA_TX_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:31
I2Cx_DMA_RX_IRQHandler
#define I2Cx_DMA_RX_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:32
i2c_handle_type
Definition: i2c_application.h:126
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • eeprom
  • src
project/at_start_f413/examples/i2c/eeprom/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "i2c_application.h"
28
37#define I2C_TIMEOUT 0xFFFFFFFF
38
39#define I2Cx_SPEED 100000
40#define I2Cx_ADDRESS 0xA0
41
42#define I2Cx_PORT I2C2
43#define I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
44
45#define I2Cx_SCL_PIN GPIO_PINS_10
46#define I2Cx_SCL_GPIO_PORT GPIOB
47#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
48
49#define I2Cx_SDA_PIN GPIO_PINS_11
50#define I2Cx_SDA_GPIO_PORT GPIOB
51#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
52
53#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
54#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4
55#define I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn
56
57#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5
58#define I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn
59
60#define I2Cx_EVT_IRQn I2C2_EVT_IRQn
61#define I2Cx_ERR_IRQn I2C2_ERR_IRQn
62
63#define BUF_SIZE 8
64
65uint8_t tx_buf1[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
66uint8_t tx_buf2[BUF_SIZE] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80};
67uint8_t tx_buf3[BUF_SIZE] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88};
68uint8_t rx_buf1[BUF_SIZE] = {0};
69uint8_t rx_buf2[BUF_SIZE] = {0};
70uint8_t rx_buf3[BUF_SIZE] = {0};
71
72 i2c_handle_type hi2cx;
73
74void error_handler(uint32_t error_code);
75uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
76void i2c_lowlevel_init(i2c_handle_type* hi2c);
77
83void error_handler(uint32_t error_code)
84{
85 while(1)
86 {
87 at32_led_toggle(LED2);
88 delay_ms(500);
89 }
90}
91
99uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
100{
101 uint32_t i;
102
103 for(i = 0; i < len; i++)
104 {
105 if(buffer1[i] != buffer2[i])
106 {
107 return 1;
108 }
109 }
110
111 return 0;
112}
113
119void i2c_lowlevel_init(i2c_handle_type* hi2c)
120{
121 gpio_init_type gpio_initstructure;
122
123 if(hi2c->i2cx == I2Cx_PORT)
124 {
125 /* i2c periph clock enable */
126 crm_periph_clock_enable(I2Cx_CLK, TRUE);
127 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
128 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
129
130 /* gpio configuration */
131 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
132 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
133 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
134 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
135
136 /* configure i2c pins: scl */
137 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
138 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
139
140 /* configure i2c pins: sda */
141 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
142 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
143
144 /* configure and enable i2c dma channel interrupt */
145 nvic_irq_enable(I2Cx_DMA_TX_IRQn, 0, 0);
146 nvic_irq_enable(I2Cx_DMA_RX_IRQn, 0, 0);
147
148 /* configure and enable i2c interrupt */
149 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
150 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
151
152 /* i2c dma tx and rx channels configuration */
153 /* enable the dma clock */
154 crm_periph_clock_enable(I2Cx_DMA_CLK, TRUE);
155
156 /* i2c dma channel configuration */
157 dma_reset(hi2c->dma_tx_channel);
158 dma_reset(hi2c->dma_rx_channel);
159
160 hi2c->dma_tx_channel = I2Cx_DMA_TX_CHANNEL;
161 hi2c->dma_rx_channel = I2Cx_DMA_RX_CHANNEL;
162
163 dma_default_para_init(&hi2c->dma_init_struct);
164 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
165 hi2c->dma_init_struct.memory_inc_enable = TRUE;
166 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
167 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
168 hi2c->dma_init_struct.loop_mode_enable = FALSE;
169 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
170 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
171
172 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
173 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
174
175 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
176
177 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
178 }
179}
180
186int main(void)
187{
188 i2c_status_type i2c_status;
189
190 /* config nvic priority group */
191 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
192
193 system_clock_config();
194
195 at32_board_init();
196
197 hi2cx.i2cx = I2Cx_PORT;
198
199 i2c_config(&hi2cx);
200
201 while(1)
202 {
203 /* wait for key USER_BUTTON press before starting the communication */
204 while(at32_button_press() != USER_BUTTON)
205 {
206 }
207
208 /* write data to memory device */
209 if((i2c_status = i2c_memory_write(&hi2cx, I2C_MEM_ADDR_WIDIH_8, I2Cx_ADDRESS, 0x00, tx_buf1, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
210 {
211 error_handler(i2c_status);
212 }
213
214 delay_ms(5);
215
216 /* read data from memory device */
217 if((i2c_status = i2c_memory_read(&hi2cx, I2C_MEM_ADDR_WIDIH_8, I2Cx_ADDRESS, 0x00, rx_buf1, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
218 {
219 error_handler(i2c_status);
220 }
221
222 /* write data to memory device */
223 if((i2c_status = i2c_memory_write_int(&hi2cx, I2C_MEM_ADDR_WIDIH_8, I2Cx_ADDRESS, 0x00, tx_buf2, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
224 {
225 error_handler(i2c_status);
226 }
227
228 /* wait for the communication to end */
229 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
230 {
231 error_handler(i2c_status);
232 }
233
234 delay_ms(5);
235
236 /* read data from memory device */
237 if((i2c_status = i2c_memory_read_int(&hi2cx, I2C_MEM_ADDR_WIDIH_8, I2Cx_ADDRESS, 0x00, rx_buf2, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
238 {
239 error_handler(i2c_status);
240 }
241
242 /* wait for the communication to end */
243 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
244 {
245 error_handler(i2c_status);
246 }
247
248 /* write data to memory device */
249 if((i2c_status = i2c_memory_write_dma(&hi2cx, I2C_MEM_ADDR_WIDIH_8, I2Cx_ADDRESS, 0x00, tx_buf3, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
250 {
251 error_handler(i2c_status);
252 }
253
254 /* wait for the communication to end */
255 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
256 {
257 error_handler(i2c_status);
258 }
259
260 delay_ms(5);
261
262 /* read data from memory device */
263 if((i2c_status = i2c_memory_read_dma(&hi2cx, I2C_MEM_ADDR_WIDIH_8, I2Cx_ADDRESS, 0x00, rx_buf3, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
264 {
265 error_handler(i2c_status);
266 }
267
268 /* wait for the communication to end */
269 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
270 {
271 error_handler(i2c_status);
272 }
273
274 if((buffer_compare(tx_buf1, rx_buf1, BUF_SIZE) == 0) &&
275 (buffer_compare(tx_buf2, rx_buf2, BUF_SIZE) == 0) &&
276 (buffer_compare(tx_buf3, rx_buf3, BUF_SIZE) == 0))
277 {
278 at32_led_on(LED3);
279 }
280 else
281 {
282 error_handler(i2c_status);
283 }
284
285 }
286}
287
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:40
I2Cx_DMA_RX_IRQn
#define I2Cx_DMA_RX_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:58
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:43
tx_buf3
uint8_t tx_buf3[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:67
I2Cx_DMA_TX_CHANNEL
#define I2Cx_DMA_TX_CHANNEL
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:54
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:63
rx_buf1
uint8_t rx_buf1[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:68
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:186
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:45
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:72
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:50
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:99
I2Cx_DMA_CLK
#define I2Cx_DMA_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:53
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:51
rx_buf2
uint8_t rx_buf2[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:69
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:61
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:83
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:119
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:39
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:42
rx_buf3
uint8_t rx_buf3[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:70
tx_buf2
uint8_t tx_buf2[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:66
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:47
I2Cx_DMA_RX_CHANNEL
#define I2Cx_DMA_RX_CHANNEL
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:57
I2Cx_DMA_TX_IRQn
#define I2Cx_DMA_TX_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:55
tx_buf1
uint8_t tx_buf1[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:65
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:60
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:46
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1877
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:128
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1794
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1600
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1298
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:110
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1387
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, i2c_mem_address_width_type mem_address_width, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1677
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:263
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:224
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:183
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:88
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:146
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:155
I2C_MEM_ADDR_WIDIH_8
@ I2C_MEM_ADDR_WIDIH_8
Definition: i2c_application.h:59
i2c_status_type
i2c_status_type
Definition: i2c_application.h:93
I2C_OK
@ I2C_OK
Definition: i2c_application.h:94
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2c_handle_type
Definition: i2c_application.h:126
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:135
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:127
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:136
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:134
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2s
  • halfduplex_dma
  • inc
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2s
  • halfduplex_dma
  • inc
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2s
  • halfduplex_dma
  • inc
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2s
  • halfduplex_dma
  • src
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2s
  • halfduplex_dma
  • src
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2s
  • halfduplex_dma
  • src
project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
29
38uint16_t i2s1_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
39 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
40 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
41 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
42 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
43 0x3D3E, 0x3F40};
44uint16_t i2s2_buffer_rx[32];
45volatile error_status transfer_status = ERROR;
46
47static void gpio_config(void);
48static void i2s_config(void);
49 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
50
56 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
57{
58 while(buffer_length--)
59 {
60 if(*pbuffer1 != *pbuffer2)
61 {
62 return ERROR;
63 }
64
65 pbuffer1++;
66 pbuffer2++;
67 }
68 return SUCCESS;
69}
70
76static void i2s_config(void)
77{
78 dma_init_type dma_init_struct;
79 i2s_init_type i2s_init_struct;
80
81 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
82 dma_reset(DMA1_CHANNEL4);
83 dma_reset(DMA1_CHANNEL3);
84 dma_default_para_init(&dma_init_struct);
85 dma_init_struct.buffer_size = 32;
86 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
87 dma_init_struct.memory_base_addr = (uint32_t)i2s1_buffer_tx;
88 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
89 dma_init_struct.memory_inc_enable = TRUE;
90 dma_init_struct.peripheral_base_addr = (uint32_t)0x4001300C;
91 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
92 dma_init_struct.peripheral_inc_enable = FALSE;
93 dma_init_struct.priority = DMA_PRIORITY_HIGH;
94 dma_init_struct.loop_mode_enable = FALSE;
95 dma_init(DMA1_CHANNEL3, &dma_init_struct);
96
97 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
98 dma_init_struct.memory_base_addr = (uint32_t)i2s2_buffer_rx;
99 dma_init_struct.peripheral_base_addr = (uint32_t)0x4000380C;
100 dma_init(DMA1_CHANNEL4, &dma_init_struct);
101
102 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
103 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
104 i2s_default_para_init(&i2s_init_struct);
105 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
106 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
107 i2s_init_struct.mclk_output_enable = TRUE;
108 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
109 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
110 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
111 i2s_init(SPI1, &i2s_init_struct);
112
113 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
114 i2s_init(SPI2, &i2s_init_struct);
115
116 dma_channel_enable(DMA1_CHANNEL3, TRUE);
117 dma_channel_enable(DMA1_CHANNEL4, TRUE);
118 spi_i2s_dma_receiver_enable(SPI2, TRUE);
119 i2s_enable(SPI1, TRUE);
120 i2s_enable(SPI2, TRUE);
121}
122
128static void gpio_config(void)
129{
130 gpio_init_type gpio_initstructure;
131 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
132 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
133
134 /* master ws pin */
135 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
136 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
137 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
138 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
139 gpio_initstructure.gpio_pins = GPIO_PINS_4;
140 gpio_init(GPIOA, &gpio_initstructure);
141
142 /* master ck pin */
143 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
144 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
145 gpio_initstructure.gpio_pins = GPIO_PINS_5;
146 gpio_init(GPIOA, &gpio_initstructure);
147
148 /* master sd pin */
149 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
150 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
151 gpio_initstructure.gpio_pins = GPIO_PINS_7;
152 gpio_init(GPIOA, &gpio_initstructure);
153
154 /* master mck pin */
155 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
156 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
157 gpio_initstructure.gpio_pins = GPIO_PINS_0;
158 gpio_init(GPIOB, &gpio_initstructure);
159
160 /* slave ws pin */
161 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
162 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
163 gpio_initstructure.gpio_pins = GPIO_PINS_12;
164 gpio_init(GPIOB, &gpio_initstructure);
165
166 /* slave ck pin */
167 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
168 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
169 gpio_initstructure.gpio_pins = GPIO_PINS_13;
170 gpio_init(GPIOB, &gpio_initstructure);
171
172 /* slave sd pin */
173 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
174 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
175 gpio_initstructure.gpio_pins = GPIO_PINS_15;
176 gpio_init(GPIOB, &gpio_initstructure);
177}
178
184int main(void)
185{
186 system_clock_config();
187 at32_board_init();
188 at32_led_off(LED2);
189 at32_led_off(LED3);
190 at32_led_off(LED4);
191 gpio_config();
192 i2s_config();
193 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
194
195 while(dma_flag_get(DMA1_FDT4_FLAG) == RESET);
196
197 /* test result:the data check */
198 transfer_status = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
199
200 /* test result indicate:if passed ,led2 lights */
201 if(transfer_status==SUCCESS)
202 {
203 at32_led_on(LED2);
204 }
205 else
206 {
207 at32_led_off(LED2);
208 }
209 while(1)
210 {
211 }
212}
213
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:56
i2s_config
static void i2s_config(void)
i2s configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:76
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:184
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:128
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:45
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:314
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:497
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:443
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:296
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:483
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:247
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:226
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:215
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:196
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:238
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:237
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2s_init_type
i2s init type
Definition: at32f413_spi.h:270
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:273
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:274
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:276
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:272
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:271
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:275
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern uint16_t i2s1_buffer_tx[];
30extern uint16_t i2s2_buffer_rx[];
31extern __IO uint32_t tx_index, rx_index;
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
138
144 void SPI2_IRQHandler(void)
145{
146 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
147 {
148 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
149 }
150}
151
157void SPI1_IRQHandler(void)
158{
159 if(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) != RESET)
160 {
161 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
162 if(tx_index == 32)
163 {
164 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
165 }
166 }
167}
168
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:38
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:44
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:68
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:44
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:125
SPI2_IRQHandler
void SPI2_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:144
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:81
SPI1_IRQHandler
void SPI1_IRQHandler(void)
This function handles the spi1 interrupt request.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:157
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:116
FALSE
@ FALSE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:72
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:31
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
37uint16_t i2s1_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
38 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
39 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
40 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
41 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
42 0x3D3E, 0x3F40};
43uint16_t i2s2_buffer_rx[32];
44__IO uint32_t tx_index = 0, rx_index = 0;
45volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
46
47static void gpio_config(void);
48static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq);
49 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
50 error_status buffer_compare_24bits(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
51
57 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
58{
59 while(buffer_length--)
60 {
61 if(*pbuffer1 != *pbuffer2)
62 {
63 return ERROR;
64 }
65
66 pbuffer1++;
67 pbuffer2++;
68 }
69 return SUCCESS;
70}
71
77 error_status buffer_compare_24bits(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
78{
79 while(buffer_length--)
80 {
81 if(*pbuffer1 != *pbuffer2)
82 {
83 if(*pbuffer1 != (*pbuffer2 & 0xFF00))
84 {
85 return ERROR;
86 }
87 }
88
89 pbuffer1++;
90 pbuffer2++;
91 }
92 return SUCCESS;
93}
94
100static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
101{
102 i2s_init_type i2s_init_struct;
103
104 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
105 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
106
107 nvic_irq_enable(SPI1_IRQn, 0, 0);
108 nvic_irq_enable(SPI2_IRQn, 0, 0);
109 spi_i2s_reset(SPI2);
110 spi_i2s_reset(SPI1);
111 i2s_default_para_init(&i2s_init_struct);
112 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
113 i2s_init_struct.data_channel_format = format;
114 i2s_init_struct.mclk_output_enable = TRUE;
115 i2s_init_struct.audio_sampling_freq = freq;
116 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
117 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
118 i2s_init(SPI1, &i2s_init_struct);
119
120 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
121 i2s_init(SPI2, &i2s_init_struct);
122
123 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
124 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, TRUE);
125 i2s_enable(SPI2, TRUE);
126 i2s_enable(SPI1, TRUE);
127}
128
134static void gpio_config(void)
135{
136 gpio_init_type gpio_initstructure;
137 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
138 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
139
140 /* master ws pin */
141 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
142 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
143 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
144 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
145 gpio_initstructure.gpio_pins = GPIO_PINS_4;
146 gpio_init(GPIOA, &gpio_initstructure);
147
148 /* master ck pin */
149 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
150 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
151 gpio_initstructure.gpio_pins = GPIO_PINS_5;
152 gpio_init(GPIOA, &gpio_initstructure);
153
154 /* master sd pin */
155 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
156 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
157 gpio_initstructure.gpio_pins = GPIO_PINS_7;
158 gpio_init(GPIOA, &gpio_initstructure);
159
160 /* master mck pin */
161 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
162 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
163 gpio_initstructure.gpio_pins = GPIO_PINS_0;
164 gpio_init(GPIOB, &gpio_initstructure);
165
166 /* slave ws pin */
167 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
168 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
169 gpio_initstructure.gpio_pins = GPIO_PINS_12;
170 gpio_init(GPIOB, &gpio_initstructure);
171
172 /* slave ck pin */
173 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
174 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
175 gpio_initstructure.gpio_pins = GPIO_PINS_13;
176 gpio_init(GPIOB, &gpio_initstructure);
177
178 /* slave sd pin */
179 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
180 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
181 gpio_initstructure.gpio_pins = GPIO_PINS_15;
182 gpio_init(GPIOB, &gpio_initstructure);
183}
184
190int main(void)
191{
192 __IO uint32_t index = 0;
193 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
194 system_clock_config();
195 at32_board_init();
196 at32_led_off(LED2);
197 at32_led_off(LED3);
198 at32_led_off(LED4);
199 gpio_config();
200 i2s_config(I2S_DATA_16BIT_CHANNEL_32BIT, I2S_AUDIO_FREQUENCY_48K);
201 while(rx_index < 32);
202
203 /* test result:the data check */
204 transfer_status1 = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
205
206 for(index = 0; index < 32; index++) i2s2_buffer_rx[index] = 0;
207 tx_index = 0;
208 rx_index = 0;
209
210 i2s_config(I2S_DATA_24BIT_CHANNEL_32BIT, I2S_AUDIO_FREQUENCY_16K);
211 while(rx_index < 32);
212
213 /* test result:the data check */
214 transfer_status2 = buffer_compare_24bits(i2s2_buffer_rx, i2s1_buffer_tx, 32);
215
216 /* test result indicate:if passed ,led2 lights */
217 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
218 {
219 at32_led_on(LED2);
220 }
221 else
222 {
223 at32_led_off(LED2);
224 }
225
226 while(1)
227 {
228 }
229}
230
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:57
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:44
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:45
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:37
i2s_config
static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:100
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:190
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:134
buffer_compare_24bits
error_status buffer_compare_24bits(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:77
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:44
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:207
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:206
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:72
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f413_spi.h:71
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:314
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:443
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:49
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:296
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:224
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:207
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:247
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:227
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:226
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:215
I2S_AUDIO_FREQUENCY_16K
@ I2S_AUDIO_FREQUENCY_16K
Definition: at32f413_spi.h:211
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:196
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:238
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:237
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2s_init_type
i2s init type
Definition: at32f413_spi.h:270
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:273
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:274
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:276
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:272
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:271
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:275
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
37uint16_t i2s1_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
38 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
39 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
40 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
41 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
42 0x3D3E, 0x3F40
43 };
44uint16_t spi1_buffer_tx[32] = {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C,
45 0x5D5E, 0x5F60, 0x6162, 0x6364, 0x6566, 0x6768,
46 0x696A, 0x6B6C, 0x6D6E, 0x6F70, 0x7172, 0x7374,
47 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
48 0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C,
49 0x8D8E, 0x8F90
50 };
51uint16_t i2s2_buffer_rx[32];
52uint16_t spi2_buffer_rx[32];
53__IO uint32_t tx_index = 0, rx_index = 0;
54volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR, transfer_status3 = ERROR;
55
56static void gpio_config(void);
57static void spi_config(void);
58static void i2s_config(i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode);
59 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
60
66 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
67{
68 while(buffer_length--)
69 {
70 if(*pbuffer1 != *pbuffer2)
71 {
72 return ERROR;
73 }
74
75 pbuffer1++;
76 pbuffer2++;
77 }
78 return SUCCESS;
79}
80
86static void i2s_config(i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
87{
88 i2s_init_type i2s_init_struct;
89
90 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
91 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
92
93 spi_i2s_reset(SPI2);
94 spi_i2s_reset(SPI1);
95 i2s_default_para_init(&i2s_init_struct);
96 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
97 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
98 i2s_init_struct.mclk_output_enable = FALSE;
99 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
100 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
101 i2s_init_struct.operation_mode = i2s1_mode;
102 i2s_init(SPI1, &i2s_init_struct);
103
104 i2s_init_struct.operation_mode =i2s2_mode;
105 i2s_init(SPI2, &i2s_init_struct);
106}
107
113static void spi_config(void)
114{
115 spi_init_type spi_init_struct;
116 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
117 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
118
119 spi_i2s_reset(SPI2);
120 spi_i2s_reset(SPI1);
121 spi_default_para_init(&spi_init_struct);
122 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
123 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
124 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
125 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
126 spi_init_struct.frame_bit_num = SPI_FRAME_16BIT;
127 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
128 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
129 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
130 spi_init(SPI1, &spi_init_struct);
131
132 spi_init_struct.transmission_mode = SPI_TRANSMIT_SIMPLEX_RX;
133 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
134 spi_init(SPI2, &spi_init_struct);
135
136 spi_enable(SPI2, TRUE);
137 spi_enable(SPI1, TRUE);
138}
139
145static void gpio_config(void)
146{
147 gpio_init_type gpio_initstructure;
148 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
149 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
150
151 /* master ws pin */
152 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
153 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
154 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
155 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
156 gpio_initstructure.gpio_pins = GPIO_PINS_4;
157 gpio_init(GPIOA, &gpio_initstructure);
158
159 /* master ck pin */
160 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
161 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
162 gpio_initstructure.gpio_pins = GPIO_PINS_5;
163 gpio_init(GPIOA, &gpio_initstructure);
164
165 /* master sd pin */
166 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
167 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
168 gpio_initstructure.gpio_pins = GPIO_PINS_7;
169 gpio_init(GPIOA, &gpio_initstructure);
170
171 /* master mck pin */
172 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
173 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
174 gpio_initstructure.gpio_pins = GPIO_PINS_0;
175 gpio_init(GPIOB, &gpio_initstructure);
176
177 /* slave ws pin */
178 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
179 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
180 gpio_initstructure.gpio_pins = GPIO_PINS_12;
181 gpio_init(GPIOB, &gpio_initstructure);
182
183 /* slave ck pin */
184 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
185 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
186 gpio_initstructure.gpio_pins = GPIO_PINS_13;
187 gpio_init(GPIOB, &gpio_initstructure);
188
189 /* slave sd pin */
190 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
191 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
192 gpio_initstructure.gpio_pins = GPIO_PINS_15;
193 gpio_init(GPIOB, &gpio_initstructure);
194}
195
201int main(void)
202{
203 __IO uint32_t index = 0;
204 system_clock_config();
205 at32_board_init();
206 at32_led_off(LED2);
207 at32_led_off(LED3);
208 at32_led_off(LED4);
209 gpio_config();
210 i2s_config(I2S_MODE_MASTER_TX, I2S_MODE_SLAVE_RX);
211 i2s_enable(SPI2, TRUE);
212 i2s_enable(SPI1, TRUE);
213 while(rx_index < 32)
214 {
215 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
216 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
217 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
218 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
219 }
220
221 /* test result:the data check */
222 transfer_status1 = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
223
224 tx_index = 0;
225 rx_index = 0;
226 spi_config();
227 while(rx_index < 32)
228 {
229 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
230 spi_i2s_data_transmit(SPI1, spi1_buffer_tx[tx_index++]);
231 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
232 spi2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
233 }
234
235 /* test result:the data check */
236 transfer_status2 = buffer_compare(spi2_buffer_rx, spi1_buffer_tx, 32);
237
238 for(index = 0; index < 32; index++) i2s2_buffer_rx[index] = 0;
239 tx_index = 0;
240 rx_index = 0;
241 i2s_config(I2S_MODE_SLAVE_TX, I2S_MODE_MASTER_RX);
242 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
243 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
244 i2s_enable(SPI1, TRUE);
245 i2s_enable(SPI2, TRUE);
246 while(rx_index < 32)
247 {
248 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
249 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
250 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
251 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
252 }
253
254 /* test result:the data check */
255 transfer_status3 = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
256
257 /* test result indicate:if passed ,led2 lights */
258 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS) && (transfer_status3 == SUCCESS))
259 {
260 at32_led_on(LED2);
261 }
262 else
263 {
264 at32_led_off(LED2);
265 }
266 while(1)
267 {
268 }
269}
270
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:66
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:53
transfer_status3
volatile error_status transfer_status3
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:54
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:113
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:54
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:37
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:54
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:201
i2s_config
static void i2s_config(i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:86
spi2_buffer_rx
uint16_t spi2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:52
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:145
spi1_buffer_tx
uint16_t spi1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:44
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:53
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:51
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:314
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:443
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:49
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:296
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
i2s_operation_mode_type
i2s_operation_mode_type
i2s operation mode type
Definition: at32f413_spi.h:235
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:247
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:226
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:215
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:161
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:159
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:196
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f413_spi.h:88
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:238
I2S_MODE_MASTER_RX
@ I2S_MODE_MASTER_RX
Definition: at32f413_spi.h:239
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:237
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:236
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
i2s_init_type
i2s init type
Definition: at32f413_spi.h:270
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:273
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:274
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:276
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:272
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:271
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:275
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • deepsleep_rtc
  • inc
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • deepsleep_rtc
  • inc
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • deepsleep_rtc
  • inc
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • deepsleep_rtc
  • src
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • deepsleep_rtc
  • src
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void RTCAlarm_IRQHandler(void)
142{
143 if(rtc_flag_get(RTC_TA_FLAG) != RESET)
144 {
145 /* clear exint line flag */
146 exint_flag_clear(EXINT_LINE_17);
147
148 /* toggle led */
149 at32_led_toggle(LED4);
150
151 /* wait for the register write to complete */
152 rtc_wait_config_finish();
153
154 /* clear alarm flag */
155 rtc_flag_clear(RTC_TA_FLAG);
156
157 /* wait for the register write to complete */
158 rtc_wait_config_finish();
159 }
160}
161
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:114
RTCAlarm_IRQHandler
void RTCAlarm_IRQHandler(void)
this function handles the rtc alarm through exint line interrupt request.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:141
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f413_exint.h:67
RESET
@ RESET
Definition: at32f413.h:291
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
RTC_TA_FLAG
#define RTC_TA_FLAG
Definition: at32f413_rtc.h:64
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • deepsleep_rtc
  • src
project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
29
43void rtc_config(void)
44{
45 exint_init_type exint_init_struct;
46
47 /* config the exint line of the rtc alarm */
48 exint_init_struct.line_select = EXINT_LINE_17;
49 exint_init_struct.line_enable = TRUE;
50 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
51 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
52 exint_init(&exint_init_struct);
53
54 /* enable the battery-powered domain write operations */
55 pwc_battery_powered_domain_access(TRUE);
56
57 /* reset battery-powered domain register */
58 bpr_reset();
59
60 /* enable the lick */
61 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
62
63 /* wait lick is ready */
64 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET);
65
66 /* select the rtc clock source */
67 crm_rtc_clock_select(CRM_RTC_CLOCK_LICK);
68
69 /* enable rtc clock */
70 crm_rtc_clock_enable(TRUE);
71
72 /* wait for rtc registers update */
73 rtc_wait_update_finish();
74
75 /* set rtc divider: set rtc period to 1sec */
76 rtc_divider_set(32767);
77
78 /* wait for the register write to complete */
79 rtc_wait_config_finish();
80
81 /* enable alarm interrupt */
82 rtc_interrupt_enable(RTC_TA_INT, TRUE);
83
84 /* wait for the register write to complete */
85 rtc_wait_config_finish();
86
87 /* configure and enable rtc alarm interrupt */
88 nvic_irq_enable(RTCAlarm_IRQn, 0, 0);
89}
90
96void system_clock_recover(void)
97{
98 /* enable external high-speed crystal oscillator - hext */
99 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
100
101 /* wait till hext is ready */
102 while(crm_hext_stable_wait() == ERROR);
103
104 /* enable pll */
105 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
106
107 /* wait till pll is ready */
108 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
109
110 /* enable auto step mode */
111 crm_auto_step_mode_enable(TRUE);
112
113 /* select pll as system clock source */
114 crm_sysclk_switch(CRM_SCLK_PLL);
115
116 /* wait till pll is used as system clock source */
117 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
118}
119
125int main(void)
126{
127 __IO uint32_t index = 0;
128 __IO uint32_t systick_index = 0;
129
130 /* congfig the system clock */
131 system_clock_config();
132
133 /* init at start board */
134 at32_board_init();
135
136 /* config priority group */
137 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
138
139 /* turn on the led light */
140 at32_led_on(LED2);
141 at32_led_on(LED3);
142 at32_led_on(LED4);
143
144 /* enable pwc and bpr clock */
145 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
146 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
147
148 /* config rtc */
149 rtc_config();
150
151 while(1)
152 {
153 /* clear second flag */
154 rtc_flag_clear(RTC_TS_FLAG);
155
156 /* wait for the second flag to be set */
157 while(rtc_flag_get(RTC_TS_FLAG) == RESET);
158
159 /* set the wakeup time to 3 seconds */
160 rtc_alarm_set(rtc_counter_get() + 3);
161
162 /* wait for the register write to complete */
163 rtc_wait_config_finish();
164
165 at32_led_off(LED2);
166
167 /* save systick register configuration */
168 systick_index = SysTick->CTRL;
169 systick_index &= ~((uint32_t)0xFFFFFFFE);
170
171 /* disable systick */
172 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
173
174 /* enter deep sleep mode */
175 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
176
177 /* restore systick register configuration */
178 SysTick->CTRL |= systick_index;
179
180 at32_led_on(LED2);
181
182 /* wait clock stable */
183 delay_us(120);
184
185 /* wake up from deep sleep mode, congfig the system clock */
186 system_clock_recover();
187
188 delay_ms(500);
189 }
190}
191
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rtc_config
void rtc_config(void)
rtc configuration.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:125
system_clock_recover
void system_clock_recover(void)
systemclock recover.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:96
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:374
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:384
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:373
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f413_crm.h:57
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
RTCAlarm_IRQn
@ RTCAlarm_IRQn
Definition: at32f413.h:212
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f413_exint.h:67
ERROR
@ ERROR
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:187
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:95
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:113
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:65
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:205
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:136
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:80
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:63
RTC_TA_INT
#define RTC_TA_INT
Definition: at32f413_rtc.h:51
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • power_voltage_monitor
  • src
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • power_voltage_monitor
  • src
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void PVM_IRQHandler(void)
142{
143 if(exint_flag_get(EXINT_LINE_16) != RESET)
144 {
145 /* clear exint line flag */
146 exint_flag_clear(EXINT_LINE_16);
147
148 /* toggle led */
149 at32_led_toggle(LED2);
150 at32_led_toggle(LED3);
151 at32_led_toggle(LED4);
152 }
153}
154
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:132
PVM_IRQHandler
void PVM_IRQHandler(void)
this function handles the power voltage monitoring output interrupt request.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:141
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:114
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:140
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
EXINT_LINE_16
#define EXINT_LINE_16
Definition: at32f413_exint.h:66
RESET
@ RESET
Definition: at32f413.h:291
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • power_voltage_monitor
  • src
project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
43void pvm_exint_config(void)
44{
45 exint_init_type exint_init_struct;
46
47 /* config the exint line of the power voltage monitor */
48 exint_init_struct.line_select = EXINT_LINE_16;
49 exint_init_struct.line_enable = TRUE;
50 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
51 exint_init_struct.line_polarity = EXINT_TRIGGER_BOTH_EDGE;
52 exint_init(&exint_init_struct);
53}
54
60int main(void)
61{
62 __IO uint32_t index = 0;
63
64 /* congfig the system clock */
65 system_clock_config();
66
67 /* init at start board */
68 at32_board_init();
69
70 /* config priority group */
71 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
72
73 /* turn on the led light */
74 at32_led_on(LED2);
75 at32_led_on(LED3);
76 at32_led_on(LED4);
77
78 /* enable pwc clock */
79 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
80
81 /* set the threshold voltage to 2.9v */
82 pwc_pvm_level_select(PWC_PVM_VOLTAGE_2V9);
83
84 /* enable power voltage monitor */
85 pwc_power_voltage_monitor_enable(TRUE);
86
87 /* config the exint line of the power voltage monitor */
88 pvm_exint_config();
89
90 /* when power voltage monitor enable,exint line16 flag will be set */
91 while(exint_flag_get(EXINT_LINE_16) == RESET);
92
93 /* clear the unexpected exint line flag */
94 exint_flag_clear(EXINT_LINE_16);
95
96 /* clear the unexpected nvic pending flag */
97 NVIC_ClearPendingIRQ(PVM_IRQn);
98
99 /* enable power voltage monitor interrupt */
100 nvic_irq_enable(PVM_IRQn, 0, 0);
101
102 while(1)
103 {
104 }
105}
106
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
pvm_exint_config
void pvm_exint_config(void)
power voltage monitor exint configuration.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c:60
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
PVM_IRQn
@ PVM_IRQn
Definition: at32f413.h:171
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:140
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_BOTH_EDGE
@ EXINT_TRIGGER_BOTH_EDGE
Definition: at32f413_exint.h:93
EXINT_LINE_16
#define EXINT_LINE_16
Definition: at32f413_exint.h:66
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f413_pwc.c:88
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f413_pwc.c:77
PWC_PVM_VOLTAGE_2V9
@ PWC_PVM_VOLTAGE_2V9
Definition: at32f413_pwc.h:78
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • sleep_tmr2
  • inc
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • sleep_tmr2
  • inc
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • sleep_tmr2
  • inc
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • sleep_tmr2
  • src
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • sleep_tmr2
  • src
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
140void TMR2_GLOBAL_IRQHandler(void)
141{
142 if(tmr_flag_get(TMR2, TMR_OVF_FLAG) != RESET)
143 {
144 /* clear timer 2 ovf flag */
145 tmr_flag_clear(TMR2, TMR_OVF_FLAG);
146
147 /* toggle led */
148 at32_led_toggle(LED4);
149 }
150}
151
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:104
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles the timer interrupt request.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:140
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:113
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
RESET
@ RESET
Definition: at32f413.h:291
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:50
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • sleep_tmr2
  • src
project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28
43void tmr2_config(void)
44{
45 crm_clocks_freq_type crm_clocks_freq_struct = {0};
46
47 /* enable tmr 2 clock */
48 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
49
50 /* get system clock */
51 crm_clocks_freq_get(&crm_clocks_freq_struct);
52
53 /* (systemclock/(systemclock/10000))/10000 = 1Hz(1s) */
54 tmr_base_init(TMR2, 9999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
55
56 /* config the counting direction */
57 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
58
59 /* config the clock divider value */
60 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
61
62 /* enable tmr 2 interrupt */
63 tmr_interrupt_enable(TMR2, TMR_OVF_INT, TRUE);
64
65 /* config tmr 2 nvic */
66 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
67
68 /* enable tmr 2 */
69 tmr_counter_enable(TMR2, TRUE);
70}
71
77int main(void)
78{
79 __IO uint32_t index = 0;
80 __IO uint32_t systick_index = 0;
81
82 /* congfig the system clock */
83 system_clock_config();
84
85 /* init at start board */
86 at32_board_init();
87
88 /* config priority group */
89 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
90
91 /* turn on the led light */
92 at32_led_on(LED2);
93 at32_led_on(LED3);
94 at32_led_on(LED4);
95
96 /* enable pwc clock */
97 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
98
99 /* config tmr 2 */
100 tmr2_config();
101
102 while(1)
103 {
104 at32_led_off(LED2);
105
106 /* save systick register configuration */
107 systick_index = SysTick->CTRL;
108 systick_index &= ~((uint32_t)0xFFFFFFFE);
109
110 /* disable systick */
111 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
112
113 /* enter sleep mode */
114 pwc_sleep_mode_enter(PWC_SLEEP_ENTER_WFI);
115
116 /* restore systick register configuration */
117 SysTick->CTRL |= systick_index;
118
119 /* wake up from sleep mode */
120 at32_led_on(LED2);
121 delay_ms(500);
122 }
123}
124
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:37
tmr2_config
void tmr2_config(void)
tmr2 configuration.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c:77
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:199
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:164
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:86
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:72
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • sleep_usart1
  • inc
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • sleep_usart1
  • inc
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • sleep_usart1
  • inc
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • sleep_usart1
  • src
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • sleep_usart1
  • src
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29
39uint16_t usart1_index = 0;
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
142void USART1_IRQHandler(void)
143{
144 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
145 {
146 /* clear rdbf flag */
147 usart1_index = usart_data_receive(USART1);
148
149 /* toggle led */
150 at32_led_toggle(LED4);
151 }
152}
153
154
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:45
USART1_IRQHandler
void USART1_IRQHandler(void)
this function handles the usatt interrupt request.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:142
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:80
usart1_index
uint16_t usart1_index
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:39
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:115
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
RESET
@ RESET
Definition: at32f413.h:291
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART1
#define USART1
Definition: at32f413_usart.h:317
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • sleep_usart1
  • src
project/at_start_f413/examples/pwc/sleep_usart1/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
41void usart1_config(uint32_t baudrate)
42{
43 gpio_init_type gpio_init_struct;
44
45 /* enable the uart1 and gpio clock */
46 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
47 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
48
49 gpio_default_para_init(&gpio_init_struct);
50
51 /* configure the uart1 tx pin */
52 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
55 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
56 gpio_init_struct.gpio_pins = GPIO_PINS_9;
57 gpio_init(GPIOA, &gpio_init_struct);
58
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
61 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
62 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
63 gpio_init_struct.gpio_pins = GPIO_PINS_10;
64 gpio_init(GPIOA, &gpio_init_struct);
65
66 /* configure uart param */
67 nvic_irq_enable(USART1_IRQn, 0, 0);
68
69 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
70 usart_parity_selection_config(USART1, USART_PARITY_NONE);
71 usart_transmitter_enable(USART1, TRUE);
72 usart_receiver_enable(USART1, TRUE);
73 usart_hardware_flow_control_set(USART1,USART_HARDWARE_FLOW_NONE);
74 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
75 usart_enable(USART1, TRUE);
76}
77
83int main(void)
84{
85 __IO uint32_t index = 0;
86 __IO uint32_t systick_index = 0;
87
88 /* congfig the system clock */
89 system_clock_config();
90
91 /* init at start board */
92 at32_board_init();
93
94 /* config priority group */
95 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
96
97 /* turn on the led light */
98 at32_led_on(LED2);
99 at32_led_on(LED3);
100 at32_led_on(LED4);
101
102 /* enable pwc clock */
103 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
104
105 /* config usart1 */
106 usart1_config(115200);
107
108 printf("exit sleep mode by usart1 rdbf interrupt \r\n");
109
110 while(1)
111 {
112 at32_led_off(LED2);
113 at32_led_off(LED3);
114 printf("now enter sleep mode \r\n");
115
116 /* save systick register configuration */
117 systick_index = SysTick->CTRL;
118 systick_index &= ~((uint32_t)0xFFFFFFFE);
119
120 /* disable systick */
121 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
122
123 /* enter sleep mode */
124 pwc_sleep_mode_enter(PWC_SLEEP_ENTER_WFI);
125
126 /* restore systick register configuration */
127 SysTick->CTRL |= systick_index;
128
129 /* wake up from sleep mode */
130 printf("now exit sleep mode by usart1 rdbf interrupt \r\n");
131
132 at32_led_on(LED2);
133 delay_ms(500);
134 }
135}
136
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/main.c:83
usart1_config
void usart1_config(uint32_t baudrate)
usart1 configuration.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:208
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:164
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:86
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:143
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:521
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f413_usart.h:167
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:92
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART1
#define USART1
Definition: at32f413_usart.h:317
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • standby_rtc
  • inc
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • standby_rtc
  • inc
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • standby_rtc
  • inc
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • standby_rtc
  • src
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • standby_rtc
  • src
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • standby_rtc
  • src
project/at_start_f413/examples/pwc/standby_rtc/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
29
44void rtc_config(void)
45{
46 /* enable the battery-powered domain write operations */
47 pwc_battery_powered_domain_access(TRUE);
48
49 /* reset battery-powered domain register */
50 bpr_reset();
51
52 /* enable the lick */
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
54
55 /* wait lick is ready */
56 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET);
57
58 /* select the rtc clock source */
59 crm_rtc_clock_select(CRM_RTC_CLOCK_LICK);
60
61 /* enable rtc clock */
62 crm_rtc_clock_enable(TRUE);
63
64 /* wait for rtc registers update */
65 rtc_wait_update_finish();
66
67 /* set rtc divider: set rtc period to 1sec */
68 rtc_divider_set(32767);
69
70 /* wait for the register write to complete */
71 rtc_wait_config_finish();
72}
73
79void rtc_alarm_config(uint8_t alarm_time)
80{
81 /* clear second flag */
82 rtc_flag_clear(RTC_TS_FLAG);
83
84 /* wait for the second flag to be set */
85 while(rtc_flag_get(RTC_TS_FLAG) == RESET);
86
87 /* config the wakeup time */
88 rtc_alarm_set(rtc_counter_get() + alarm_time);
89
90 /* wait for the register write to complete */
91 rtc_wait_config_finish();
92}
93
99int main(void)
100{
101 __IO uint32_t index = 0;
102
103 /* congfig the system clock */
104 system_clock_config();
105
106 /* init at start board */
107 at32_board_init();
108
109 /* config priority group */
110 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
111
112 /* turn on the led light */
113 at32_led_off(LED2);
114 at32_led_off(LED3);
115 at32_led_off(LED4);
116
117 /* enable pwc and bpr clock */
118 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
119 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
120
121 if(pwc_flag_get(PWC_STANDBY_FLAG) != RESET)
122 {
123 /* wakeup from standby */
124 pwc_flag_clear(PWC_STANDBY_FLAG);
125 at32_led_on(LED2);
126 }
127
128 if(pwc_flag_get(PWC_WAKEUP_FLAG) != RESET)
129 {
130 /* wakeup event occurs */
131 pwc_flag_clear(PWC_WAKEUP_FLAG);
132 at32_led_on(LED3);
133 }
134
135 /* config rtc */
136 rtc_config();
137
138 at32_led_on(LED4);
139
140 delay_ms(1000);
141
142 /* set the wakeup time to 10 seconds */
143 rtc_alarm_config(10);
144
145 /* enter standby mode */
146 pwc_standby_mode_enter();
147
148 while(1)
149 {
150 }
151}
152
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rtc_config
void rtc_config(void)
rtc configuration.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/main.c:44
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/main.c:99
rtc_alarm_config
void rtc_alarm_config(uint8_t alarm_time)
rtc alarm set.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/main.c:79
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:374
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:384
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:296
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:373
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f413_crm.h:57
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:208
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:142
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:125
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f413_pwc.h:51
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f413_pwc.h:50
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:113
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:65
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:205
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:80
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:63
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
42int main(void)
43{
44 __IO uint32_t index = 0;
45
46 /* congfig the system clock */
47 system_clock_config();
48
49 /* init at start board */
50 at32_board_init();
51
52 /* config priority group */
53 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
54
55 /* turn on the led light */
56 at32_led_off(LED2);
57 at32_led_off(LED3);
58 at32_led_off(LED4);
59
60 /* enable pwc clock */
61 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
62
63 if(pwc_flag_get(PWC_STANDBY_FLAG) != RESET)
64 {
65 /* wakeup from standby */
66 pwc_flag_clear(PWC_STANDBY_FLAG);
67 at32_led_on(LED2);
68 }
69
70 if(pwc_flag_get(PWC_WAKEUP_FLAG) != RESET)
71 {
72 /* wakeup event occurs */
73 pwc_flag_clear(PWC_WAKEUP_FLAG);
74 at32_led_on(LED3);
75 }
76
77 at32_led_on(LED4);
78
79 /*delay to check led status*/
80 delay_ms(1000);
81
82 /* enable wakeup pin - pa0 */
83 pwc_wakeup_pin_enable(PWC_WAKEUP_PIN_1, TRUE);
84
85 /* enter standby mode */
86 pwc_standby_mode_enter();
87 while(1)
88 {
89 }
90}
91
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:208
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:142
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:125
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f413_pwc.c:104
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f413_pwc.h:51
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f413_pwc.h:50
PWC_WAKEUP_PIN_1
#define PWC_WAKEUP_PIN_1
pwc wakeup pin num definition
Definition: at32f413_pwc.h:61
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • rtc
  • calendar
  • inc
project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • rtc
  • calendar
  • inc
project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • rtc
  • calendar
  • inc
project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • rtc
  • calendar
  • src
project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • rtc
  • calendar
  • src
project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
134
140void RTC_IRQHandler(void)
141{
142 if(rtc_flag_get(RTC_TA_FLAG) != RESET)
143 {
144 at32_led_toggle(LED4);
145
146 /* clear the rtc second flag */
147 rtc_flag_clear(RTC_TA_FLAG);
148 }
149}
150
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:130
RTC_IRQHandler
void RTC_IRQHandler(void)
this function handles rtc handler.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:140
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:112
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
RESET
@ RESET
Definition: at32f413.h:291
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
RTC_TA_FLAG
#define RTC_TA_FLAG
Definition: at32f413_rtc.h:64
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • rtc
  • calendar
  • src
project/at_start_f413/examples/rtc/calendar/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "rtc.h"
28
37char const weekday_table[7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"};
38
44void alarm_init(void)
45{
46 calendar_type alarm_struct;
47
48 /* clear alarm flag */
49 rtc_flag_clear(RTC_TA_FLAG);
50
51 /* wait for the register write to complete */
52 rtc_wait_config_finish();
53
54 /* configure and enable rtc interrupt */
55 nvic_irq_enable(RTC_IRQn, 0, 0);
56
57 /* enable alarm interrupt */
58 rtc_interrupt_enable(RTC_TA_INT, TRUE);
59
60 /* wait for the register write to complete */
61 rtc_wait_config_finish();
62
63 /* config alarm */
64
65 alarm_struct.year = 2021;
66 alarm_struct.month = 5;
67 alarm_struct.date = 1;
68 alarm_struct.hour = 12;
69 alarm_struct.min = 0;
70 alarm_struct.sec = 5;
71
72 rtc_alarm_clock_set(&alarm_struct);
73}
74
80int main(void)
81{
82 calendar_type time_struct;
83
84 /* config nvic priority group */
85 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
86
87 system_clock_config();
88
89 at32_board_init();
90
91 uart_print_init(115200);
92
93 /* config calendar */
94 time_struct.year = 2021;
95 time_struct.month = 5;
96 time_struct.date = 1;
97 time_struct.hour = 12;
98 time_struct.min = 0;
99 time_struct.sec = 0;
100 rtc_init(&time_struct);
101
102 /* config alarm */
103 alarm_init();
104
105 printf("initial ok\r\n");
106
107 while(1)
108 {
109 if(rtc_flag_get(RTC_TS_FLAG) != RESET)
110 {
111 at32_led_toggle(LED3);
112
113 /* get time */
114 rtc_time_get();
115
116 /* print time */
117 printf("%d/%d/%d ", calendar.year, calendar.month, calendar.date);
118 printf("%02d:%02d:%02d %s\r\n", calendar.hour, calendar.min, calendar.sec, weekday_table[calendar.week]);
119
120 /* wait for the register write to complete */
121 rtc_wait_config_finish();
122
123 /* clear the rtc second flag */
124 rtc_flag_clear(RTC_TS_FLAG);
125
126 /* wait for the register write to complete */
127 rtc_wait_config_finish();
128 }
129 }
130}
131
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
calendar
calendar_type calendar
Definition: rtc.c:35
main
int main(void)
main function.
Definition: project/at_start_f413/examples/rtc/calendar/src/main.c:80
weekday_table
char const weekday_table[7][10]
Definition: project/at_start_f413/examples/rtc/calendar/src/main.c:37
alarm_init
void alarm_init(void)
init alarm.
Definition: project/at_start_f413/examples/rtc/calendar/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
RTC_IRQn
@ RTC_IRQn
Definition: at32f413.h:173
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
rtc_time_get
void rtc_time_get(void)
get current time.
Definition: rtc.c:307
rtc_init
uint8_t rtc_init(calendar_type *calendar)
rtc peripheral initialization.
Definition: rtc.c:49
rtc_alarm_clock_set
uint8_t rtc_alarm_clock_set(calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:215
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:136
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
RTC_TA_FLAG
#define RTC_TA_FLAG
Definition: at32f413_rtc.h:64
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:63
RTC_TA_INT
#define RTC_TA_INT
Definition: at32f413_rtc.h:51
rtc.h
this file provides template for calendar api.
calendar_type
Definition: rtc.h:47
calendar_type::hour
__IO uint8_t hour
Definition: rtc.h:51
calendar_type::month
__IO uint8_t month
Definition: rtc.h:49
calendar_type::sec
__IO uint8_t sec
Definition: rtc.h:53
calendar_type::week
__IO uint8_t week
Definition: rtc.h:54
calendar_type::year
__IO uint16_t year
Definition: rtc.h:48
calendar_type::min
__IO uint8_t min
Definition: rtc.h:52
calendar_type::date
__IO uint8_t date
Definition: rtc.h:50
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • rtc
  • lick_calibration
  • inc
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • rtc
  • lick_calibration
  • inc
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • rtc
  • lick_calibration
  • inc
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • rtc
  • lick_calibration
  • src
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • rtc
  • lick_calibration
  • src
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28#include "stdio.h"
29
30extern uint32_t incrementvar_operationcomplete(void);
31extern uint32_t getvar_operationcomplete(void);
32extern void setvar_periodvalue(uint32_t Value);
33
34extern __IO uint32_t periodvalue;
35extern __IO uint32_t operationcomplete;
36
45uint16_t tmpCC4[2] = {0, 0};
46
52void NMI_Handler(void)
53{
54}
55
61void HardFault_Handler(void)
62{
63 /* go to infinite loop when hard fault exception occurs */
64 while(1)
65 {
66 }
67}
68
74void MemManage_Handler(void)
75{
76 /* go to infinite loop when memory manage exception occurs */
77 while(1)
78 {
79 }
80}
81
87void BusFault_Handler(void)
88{
89 /* go to infinite loop when bus fault exception occurs */
90 while(1)
91 {
92 }
93}
94
100void UsageFault_Handler(void)
101{
102 /* go to infinite loop when usage fault exception occurs */
103 while(1)
104 {
105 }
106}
107
113void SVC_Handler(void)
114{
115}
116
122void DebugMon_Handler(void)
123{
124}
125
131void PendSV_Handler(void)
132{
133}
134
140void SysTick_Handler(void)
141{
142}
143
149void RTC_IRQHandler(void)
150{
151 if(rtc_flag_get(RTC_TS_FLAG) != RESET)
152 {
153 /* toggle led3 */
154 at32_led_toggle(LED3);
155
156 /* clear interrupt pending bit */
157 rtc_flag_clear(RTC_TS_FLAG);
158
159 printf("%d\r\n", rtc_counter_get());
160 }
161}
162
168void TMR5_GLOBAL_IRQHandler(void)
169{
170 uint32_t tmp = 0;
171
172 if(tmr_flag_get(TMR5, TMR_C4_FLAG) == SET)
173 {
174 tmpCC4[incrementvar_operationcomplete()] = (uint16_t)(TMR5->c4dt);
175
176 tmr_flag_get(TMR5, TMR_C4_FLAG);
177
178 if(getvar_operationcomplete() >= 2)
179 {
180 /* compute the period length */
181 tmp = (uint16_t)(tmpCC4[1] - tmpCC4[0] + 1);
182 setvar_periodvalue(tmp);
183
184 /* disable the interrupt */
185 tmr_interrupt_enable(TMR5, TMR_C4_INT, FALSE);
186 tmr_counter_enable(TMR5, FALSE);
187 }
188 }
189}
190
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
operationcomplete
__IO uint32_t operationcomplete
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:100
setvar_periodvalue
void setvar_periodvalue(uint32_t Value)
sets the periodvalue variable with input parameter.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:138
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:61
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:74
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:113
incrementvar_operationcomplete
uint32_t incrementvar_operationcomplete(void)
increments operationcomplete variable and return its value before increment operation.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:116
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:131
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:52
periodvalue
__IO uint32_t periodvalue
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:37
tmpCC4
uint16_t tmpCC4[2]
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:45
getvar_operationcomplete
uint32_t getvar_operationcomplete(void)
returns operationcomplete value.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:128
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:87
TMR5_GLOBAL_IRQHandler
void TMR5_GLOBAL_IRQHandler(void)
this function handles tmr5 global interrupt request.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:168
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:140
RTC_IRQHandler
void RTC_IRQHandler(void)
this function handles rtc global interrupt request.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:149
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:122
LED3
@ LED3
Definition: at32f413_board.h:62
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
FALSE
@ FALSE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:159
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:65
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:185
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:63
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:54
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:76
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • rtc
  • lick_calibration
  • src
project/at_start_f413/examples/rtc/lick_calibration/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 crm_clocks_freq_type crm_clocks;
37__IO uint32_t periodvalue = 0;
38__IO uint32_t lickfreq = 0;
39__IO uint32_t operationcomplete = 0;
40
46void nvic_configuration(void)
47{
48 /* configure one bit for preemption priority */
49 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
50
51 /* enable the rtc interrupt */
52 nvic_irq_enable(RTC_IRQn, 0, 0);
53
54 /* enable the tmr5 interrupt */
55 nvic_irq_enable(TMR5_GLOBAL_IRQn, 0, 0);
56}
57
63void rtc_configuration(void)
64{
65 /* enable pwc and bpr clocks */
66 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
68
69 /* allow access to bpr domain */
70 pwc_battery_powered_domain_access(TRUE);
71
72 /* reset backup domain */
73 bpr_reset();
74
75 /* enable the lick osc */
76 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
77 /* wait till lick is ready */
78 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET);
79 /* select the rtc clock source */
80 crm_rtc_clock_select(CRM_RTC_CLOCK_LICK);
81
82 /* enable rtc clock */
83 crm_rtc_clock_enable(TRUE);
84
85 /* wait for rtc registers update */
86 rtc_wait_update_finish();
87
88 /* wait for the register write to complete */
89 rtc_wait_config_finish();
90
91 /* enable the rtc second */
92 rtc_interrupt_enable(RTC_TS_INT, TRUE);
93
94 /* wait for the register write to complete */
95 rtc_wait_config_finish();
96
97 /* set rtc divider: set rtc period to 1sec */
98 rtc_divider_set(40000);
99
100 /* wait for the register write to complete */
101 rtc_wait_config_finish();
102
103 /* tamper pin disabled */
104 bpr_tamper_pin_enable(FALSE);
105
106 /* enable the rtc second output on tamper pin */
107 bpr_rtc_output_select(BPR_RTC_OUTPUT_SECOND);
108}
109
116uint32_t incrementvar_operationcomplete(void)
117{
118 operationcomplete++;
119
120 return (uint32_t)(operationcomplete - 1);
121}
122
128uint32_t getvar_operationcomplete(void)
129{
130 return (uint32_t)operationcomplete;
131}
132
138void setvar_periodvalue(uint32_t value)
139{
140 periodvalue = (uint32_t)(value);
141}
142
148int main(void)
149{
150 tmr_input_config_type tmr_ic_init_structure;
151
152 system_clock_config();
153
154 at32_board_init();
155
156 uart_print_init(115200);
157
158 /* rtc configuration */
159 rtc_configuration();
160
161 printf("\r\n\nstart calib\r\n\r\n");
162
163 /* get the frequency value */
164 crm_clocks_freq_get(&crm_clocks);
165
166 /* enable tmr5 apb1 clocks */
167 crm_periph_clock_enable(CRM_TMR5_PERIPH_CLOCK, TRUE);
168 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
169
170 /* connect internally the tm5_ch4 input capture to the lick clock output */
171 gpio_pin_remap_config(TMR5CH4_MUX, TRUE);
172
173 /* tmr5 time base configuration */
174 tmr_base_init(TMR5, 0xFFFF, 0);
175 tmr_cnt_dir_set(TMR5, TMR_COUNT_UP);
176 tmr_clock_source_div_set(TMR5, TMR_CLOCK_DIV1);
177
178 /* tmr5 channel4 input capture mode configuration */
179 tmr_input_default_para_init(&tmr_ic_init_structure);
180 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_4;
181 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
182 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
183 tmr_ic_init_structure.input_filter_value = 0;
184 tmr_input_channel_init(TMR5, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
185
186 /* reinitialize the index for the interrupt */
187 operationcomplete = 0;
188
189 /* enable the tmr5 input capture counter */
190 tmr_counter_enable(TMR5, TRUE);
191
192 /* Reset all tmr5 flags */
193 tmr_flag_get(TMR5, TMR_C4_FLAG);
194
195 /* enable the tmr5 channel 4 */
196 tmr_interrupt_enable(TMR5, TMR_C4_INT, TRUE);
197
198 /* nvic configuration */
199 nvic_configuration();
200
201 /* wait the tmr5 measuring operation to be completed */
202 while(operationcomplete != 2);
203
204 /* compute the actual frequency of the lick. (tim5_clk = 1 * pclk1) */
205 if(periodvalue != 0)
206 {
207 lickfreq = (uint32_t)((uint32_t)(crm_clocks.apb1_freq * 2) / (uint32_t)periodvalue);
208 }
209
210 printf("apb1_freq = %d\r\n", crm_clocks.apb1_freq);
211 printf("period_value = %d\r\n", periodvalue);
212 printf("lick_freq = %d\r\n", lickfreq);
213
214 /* adjust the rtc prescaler value */
215 rtc_divider_set((lickfreq - 1));
216
217 /* wait for the register write to complete */
218 rtc_wait_config_finish();
219
220 /* turn on led2 */
221 at32_led_on(LED2);
222
223 while(1)
224 {
225 }
226}
227
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
operationcomplete
__IO uint32_t operationcomplete
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:39
setvar_periodvalue
void setvar_periodvalue(uint32_t value)
sets the periodvalue variable with input parameter.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:138
incrementvar_operationcomplete
uint32_t incrementvar_operationcomplete(void)
increments operationcomplete variable and return its value before increment operation.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:116
lickfreq
__IO uint32_t lickfreq
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:38
periodvalue
__IO uint32_t periodvalue
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:37
nvic_configuration
void nvic_configuration(void)
configures the nested vectored interrupt controller.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:46
getvar_operationcomplete
uint32_t getvar_operationcomplete(void)
returns operationcomplete value.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:128
main
int main(void)
main function.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:148
crm_clocks
crm_clocks_freq_type crm_clocks
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:36
rtc_configuration
void rtc_configuration(void)
configures the rtc.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:63
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:37
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:174
bpr_rtc_output_select
void bpr_rtc_output_select(bpr_rtc_output_type output_source)
select bpr rtc output
Definition: at32f413_bpr.c:149
BPR_RTC_OUTPUT_SECOND
@ BPR_RTC_OUTPUT_SECOND
Definition: at32f413_bpr.h:118
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:374
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:384
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_TMR5_PERIPH_CLOCK
@ CRM_TMR5_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:296
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:373
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f413_crm.h:57
TMR5_GLOBAL_IRQn
@ TMR5_GLOBAL_IRQn
Definition: at32f413.h:219
RTC_IRQn
@ RTC_IRQn
Definition: at32f413.h:173
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
TMR5CH4_MUX
#define TMR5CH4_MUX
Definition: at32f413_gpio.h:91
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:205
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:136
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:80
RTC_TS_INT
#define RTC_TS_INT
Definition: at32f413_rtc.h:50
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:142
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:54
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:76
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:473
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • sdio
  • sd_mmc_card
  • inc
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • sdio
  • sd_mmc_card
  • inc
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • sdio
  • sd_mmc_card
  • inc
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • sdio
  • sd_mmc_card
  • src
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • sdio
  • sd_mmc_card
  • src
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • sdio
  • sd_mmc_card
  • src
project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
Go to the documentation of this file.
1
25#include <stdbool.h>
26#include <string.h>
27#include "at32_sdio.h"
28#include "at32f413_board.h"
29#include "at32f413_clock.h"
30
39#define BLOCK_SIZE (512)
40#define BLOCKS_NUMBER (8)
41#define MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
42#define STREAM_BUFFER_SIZE (1024)
43
44static uint8_t sblock_tbuffer[BLOCK_SIZE], sblock_rbuffer[BLOCK_SIZE];
45static uint8_t mblock_tbuffer[MULTI_BUFFER_SIZE], mblock_rbuffer[MULTI_BUFFER_SIZE];
46static uint8_t stream_tbuffer[STREAM_BUFFER_SIZE], stream_rbuffer[STREAM_BUFFER_SIZE];
47
48static error_status sd_single_block_test(void);
49static error_status sd_multiple_blocks_test(void);
50uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
51static void sd_test_error(void);
52static void nvic_configuration(void);
53
60static error_status sd_single_block_test(void)
61{
62 sd_error_status_type status = SD_OK;
63 uint8_t bus_width;
64
65 /* test 1-bit and 4-bit width */
66 for(bus_width = 0; bus_width < 2; bus_width++)
67 {
68 memset(sblock_tbuffer, bus_width + 0xAB, BLOCK_SIZE);
69 memset(sblock_rbuffer, 0, BLOCK_SIZE);
70
71 /* set data width */
72 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
73 if(status != SD_OK)
74 {
75 return ERROR;
76 }
77
78 /* write block of 512 bytes on address 0 */
79 status = sd_block_write(sblock_tbuffer, 0x00, BLOCK_SIZE);
80 if(status != SD_OK)
81 {
82 return ERROR;
83 }
84
85 /* read block of 512 bytes from address 0 */
86 status = sd_block_read(sblock_rbuffer, 0x00, BLOCK_SIZE);
87 if(status != SD_OK)
88 {
89 return ERROR;
90 }
91
92 if(!buffer_compare(sblock_tbuffer, sblock_rbuffer, BLOCK_SIZE))
93 {
94 return ERROR;
95 }
96 }
97
98 return SUCCESS;
99}
100
107static error_status sd_multiple_blocks_test(void)
108{
109 sd_error_status_type status = SD_OK;
110 uint8_t bus_width;
111
112 /* test 1-bit and 4-bit width */
113 for(bus_width = 0; bus_width < 2; bus_width++)
114 {
115 memset(mblock_tbuffer, bus_width + 0x3C, MULTI_BUFFER_SIZE);
116 memset(mblock_rbuffer, 0, MULTI_BUFFER_SIZE);
117
118 /* set data width */
119 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
120 if(status != SD_OK)
121 {
122 return ERROR;
123 }
124
125 /* write multiple block of many bytes on address 0 */
126 status = sd_mult_blocks_write(mblock_tbuffer, 0x00, BLOCK_SIZE, BLOCKS_NUMBER);
127 if(status != SD_OK)
128 {
129 return ERROR;
130 }
131
132 /* read block of many bytes from address 0 */
133 status = sd_mult_blocks_read(mblock_rbuffer, 0x00, BLOCK_SIZE, BLOCKS_NUMBER);
134 if(status != SD_OK)
135 {
136 return ERROR;
137 }
138
139 /* check the correctness of written data */
140 if(!buffer_compare(mblock_tbuffer, mblock_rbuffer, MULTI_BUFFER_SIZE))
141 {
142 return ERROR;
143 }
144 }
145
146 return SUCCESS;
147}
148
155static error_status mmc_stream_test(void)
156{
157 sd_error_status_type status = SD_OK;
158 uint8_t bus_width;
159
160 /* only test 1-bit width */
161 for(bus_width = 0; bus_width < 1; bus_width++)
162 {
163 memset(stream_tbuffer, bus_width+0x5A, STREAM_BUFFER_SIZE);
164 memset(stream_rbuffer, 0, STREAM_BUFFER_SIZE);
165
166 /* set data width */
167 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
168 if(status != SD_OK)
169 {
170 return ERROR;
171 }
172
173 /* write stream of many bytes on address 0 */
174 status = mmc_stream_write(stream_tbuffer, 0x00, STREAM_BUFFER_SIZE);
175 if (status != SD_OK)
176 {
177 return ERROR;
178 }
179
180 /* read stream of many bytes from address 0 */
181 status = mmc_stream_read(stream_rbuffer, 0x00, STREAM_BUFFER_SIZE);
182 if (status != SD_OK)
183 {
184 return ERROR;
185 }
186
187 /* check the correctness of written data */
188 if(!buffer_compare(stream_tbuffer, stream_rbuffer, STREAM_BUFFER_SIZE))
189 {
190 return ERROR;
191 }
192 }
193
194 return SUCCESS;
195}
196
204uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
205{
206 while(buffer_length--)
207 {
208 if(*pbuffer1 != *pbuffer2)
209 {
210 return 0;
211 }
212 pbuffer1++;
213 pbuffer2++;
214 }
215 return 1;
216}
217
223static void sd_test_error(void)
224{
225 at32_led_on(LED2);
226 delay_ms(300);
227 at32_led_off(LED2);
228 delay_ms(300);
229}
230
236static void nvic_configuration(void)
237{
238 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
239 nvic_irq_enable(SDIO1_IRQn, 0, 0);
240}
241
247void show_card_info(void)
248{
249 printf("---------------------\r\n");
250 switch(sd_card_info.card_type)
251 {
252 case SDIO_STD_CAPACITY_SD_CARD_V1_1: printf("card type: SDSC V1.1\r\n");break;
253 case SDIO_STD_CAPACITY_SD_CARD_V2_0: printf("card type: SDSC V2.0\r\n");break;
254 case SDIO_HIGH_CAPACITY_SD_CARD: printf("card type: SDHC V2.0\r\n");break;
255 case SDIO_MULTIMEDIA_CARD: printf("card type: MMC Card\r\n");break;
256 }
257 printf("card manufacturer_id: %d\r\n", sd_card_info.sd_cid_reg.manufacturer_id);
258 printf("card rca: 0x%X\r\n", sd_card_info.rca);
259 printf("card c_size = %u\r\n", sd_card_info.sd_csd_reg.device_size);
260 printf("card capacity: %uMB %uKB\r\n", (uint32_t)(sd_card_info.card_capacity>>20), (uint32_t)(sd_card_info.card_capacity>>10));
261 printf("card block_size: %d\r\n", sd_card_info.card_blk_size);
262 printf("---------------------\r\n");
263}
264
265/* gloable functions ---------------------------------------------------------*/
271int main(void)
272{
273 system_clock_config();
274
275 at32_board_init();
276
277 nvic_configuration();
278
279 uart_print_init(115200);
280 printf("start test..\r\n");
281
282 /* sdio init */
283 if(SD_OK != sd_init())
284 {
285 printf("sdio init fail\r\n");
286 while(1)
287 {
288 sd_test_error();
289 }
290 }
291 printf("sdio init ok\r\n");
292 show_card_info();
293
294 /* sd card single block test */
295 if(SUCCESS != sd_single_block_test())
296 {
297 printf("sd card single block test fail\r\n");
298 /* single block test fail, led2 fresh */
299 while(1)
300 {
301 sd_test_error();
302 }
303 }
304 printf("sd card single block test ok\r\n");
305
306 /* sd card multiple blocks test */
307 if(SUCCESS != sd_multiple_blocks_test())
308 {
309 printf("sd card multiple blocks test fail\r\n");
310 /* multiple blocks test fail, led2 fresh */
311 while(1)
312 {
313 sd_test_error();
314 }
315 }
316 printf("sd card multiple blocks test ok\r\n");
317
318 /* mmc card stream data transfer test */
319 if(sd_card_info.card_type == SDIO_MULTIMEDIA_CARD)
320 {
321 if(SUCCESS != mmc_stream_test())
322 {
323 printf("mmc card stream data test fail\r\n");
324 /* mmc card stream data test fail, led2 fresh */
325 while(1)
326 {
327 sd_test_error();
328 }
329 }
330 printf("mmc card stream data test ok\r\n");
331 }
332
333 /* all tests pass, led3 and led4 fresh */
334 while(1)
335 {
336 at32_led_toggle(LED3);
337 at32_led_toggle(LED4);
338 delay_ms(300);
339 }
340}
341
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:46
STREAM_BUFFER_SIZE
#define STREAM_BUFFER_SIZE
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:42
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:204
stream_tbuffer
static uint8_t stream_tbuffer[(1024)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:46
sd_test_error
static void sd_test_error(void)
LED2 on off every 300ms for sd test failed.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:223
mmc_stream_test
static error_status mmc_stream_test(void)
mmc card data stream read/write test.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:155
BLOCKS_NUMBER
#define BLOCKS_NUMBER
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:40
sd_single_block_test
static error_status sd_single_block_test(void)
sd card single block read/write test.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:60
stream_rbuffer
static uint8_t stream_rbuffer[(1024)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:46
sblock_rbuffer
static uint8_t sblock_rbuffer[(512)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:44
sd_multiple_blocks_test
static error_status sd_multiple_blocks_test(void)
sd card multiple blocks read/write test.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:107
show_card_info
void show_card_info(void)
show sd/mmc card info.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:247
mblock_tbuffer
static uint8_t mblock_tbuffer[((512) *(8))]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:45
sblock_tbuffer
static uint8_t sblock_tbuffer[(512)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:44
MULTI_BUFFER_SIZE
#define MULTI_BUFFER_SIZE
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:41
nvic_configuration
static void nvic_configuration(void)
configures sdio1 irq channel.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:236
main
int main(void)
main function.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:271
BLOCK_SIZE
#define BLOCK_SIZE
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:39
mblock_rbuffer
static uint8_t mblock_rbuffer[((512) *(8))]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f413.h:218
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:137
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1691
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1179
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1480
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1358
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:70
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1644
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1268
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:734
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:72
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:117
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:202
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:203
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:205
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:236
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:169
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:138
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • sdio
  • sdio_fatfs
  • inc
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • sdio
  • sdio_fatfs
  • inc
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • sdio
  • sdio_fatfs
  • inc
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • sdio
  • sdio_fatfs
  • src
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • sdio
  • sdio_fatfs
  • src
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • sdio
  • sdio_fatfs
  • src
project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
Go to the documentation of this file.
1
25#include <stdbool.h>
26#include <string.h>
27#include "at32_sdio.h"
28#include "at32f413_board.h"
29#include "at32f413_clock.h"
30#include "ff.h"
31
40FATFS fs;
41FIL file;
42BYTE work[FF_MAX_SS];
43
44uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
45static void sd_test_error(void);
46static void nvic_configuration(void);
47
55uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
56{
57 while(buffer_length--)
58 {
59 if(*pbuffer1 != *pbuffer2)
60 {
61 return 0;
62 }
63 pbuffer1++;
64 pbuffer2++;
65 }
66 return 1;
67}
68
74static void sd_test_error(void)
75{
76 at32_led_on(LED2);
77 delay_ms(300);
78 at32_led_off(LED2);
79 delay_ms(300);
80}
81
87static void nvic_configuration(void)
88{
89 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
90 nvic_irq_enable(SDIO1_IRQn, 0, 0);
91}
92
99static error_status fatfs_test(void)
100{
101 FRESULT ret;
102 char filename[] = "1:/test1.txt";
103 const char wbuf[] = "this is my file for test fatfs!\r\n";
104 char rbuf[50];
105 UINT bytes_written = 0;
106 UINT bytes_read = 0;
107 DWORD fre_clust, fre_sect, tot_sect;
108 FATFS* pt_fs;
109
110 ret = f_mount(&fs, "1:", 1);
111 if(ret){
112 printf("fs mount err:%d.\r\n", ret);
113 if(ret == FR_NO_FILESYSTEM){
114 printf("create fatfs..\r\n");
115 ret = f_mkfs("1:", 0, work, sizeof(work));
116 if(ret){
117 printf("creates fatfs err:%d.\r\n", ret);
118 return ERROR;
119 }
120 else{
121 printf("creates fatfs ok.\r\n");
122 }
123 ret = f_mount(NULL, "1:", 1);
124 ret = f_mount(&fs, "1:", 1);
125 if(ret){
126 printf("fs mount err:%d.\r\n", ret);
127 return ERROR;
128 }
129 else{
130 printf("fs mount ok.\r\n");
131 }
132 }
133 else{
134 return ERROR;
135 }
136 }
137 else{
138 printf("fs mount ok.\r\n");
139 }
140
141 ret = f_open(&file, filename, FA_READ | FA_WRITE | FA_CREATE_ALWAYS);
142 if(ret){
143 printf("open file err:%d.\r\n", ret);
144 }
145 else{
146 printf("open file ok.\r\n");
147 }
148 ret = f_write(&file, wbuf, sizeof(wbuf), &bytes_written);
149 if(ret){
150 printf("write file err:%d.\r\n", ret);
151 }
152 else{
153 printf("write file ok, byte:%u.\r\n", bytes_written);
154 }
155 f_lseek(&file, 0);
156 ret = f_read(&file, rbuf, sizeof(rbuf), &bytes_read);
157 if(ret){
158 printf("read file err:%d.\r\n", ret);
159 }
160 else{
161 printf("read file ok, byte:%u.\r\n", bytes_read);
162 }
163 ret = f_close(&file);
164 if(ret){
165 printf("close file err:%d.\r\n", ret);
166 }
167 else{
168 printf("close file ok.\r\n");
169 }
170
171 pt_fs = &fs;
172 /* get volume information and free clusters of drive 1 */
173 ret = f_getfree("1:", &fre_clust, &pt_fs);
174 if(ret == FR_OK)
175 {
176 /* get total sectors and free sectors */
177 tot_sect = (pt_fs->n_fatent - 2) * pt_fs->csize;
178 fre_sect = fre_clust * pt_fs->csize;
179
180 /* print the free space (assuming 512 bytes/sector) */
181 printf("%10u KiB total drive space.\r\n%10u KiB available.\r\n", tot_sect / 2, fre_sect / 2);
182 }
183
184 ret = f_mount(NULL, "1:", 1);
185
186 if(1 == buffer_compare((uint8_t*)rbuf, (uint8_t*)wbuf, sizeof(wbuf))){
187 printf("r/w file data test ok.\r\n");
188 }
189 else{
190 printf("r/w file data test fail.\r\n");
191 return ERROR;
192 }
193
194 return SUCCESS;
195}
196
197/* gloable functions ---------------------------------------------------------*/
203int main(void)
204{
205 system_clock_config();
206
207 at32_board_init();
208
209 nvic_configuration();
210
211 uart_print_init(115200);
212 printf("start test fatfs r0.14b..\r\n");
213
214 if(SUCCESS != fatfs_test())
215 {
216 while(1)
217 {
218 sd_test_error();
219 }
220 }
221
222 /* all tests pass, led3 and led4 fresh */
223 while(1)
224 {
225 at32_led_toggle(LED3);
226 at32_led_toggle(LED4);
227 delay_ms(300);
228 }
229}
230
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
FF_MAX_SS
#define FF_MAX_SS
Definition: ffconf.h:197
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:55
file
FIL file
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:41
sd_test_error
static void sd_test_error(void)
led2 on off every 300ms for sd test failed.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:74
work
BYTE work[FF_MAX_SS]
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:42
nvic_configuration
static void nvic_configuration(void)
configures sdio1 irq channel.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:87
main
int main(void)
main function.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:203
fatfs_test
static error_status fatfs_test(void)
fatfs file read/write test.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:99
fs
FATFS fs
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f413.h:218
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • crc_transfer_polling
  • inc
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • crc_transfer_polling
  • inc
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • crc_transfer_polling
  • inc
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • crc_transfer_polling
  • src
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • crc_transfer_polling
  • src
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • crc_transfer_polling
  • src
project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
37#define BUFFER_SIZE 32
38
39uint16_t spi1_tx_buffer[BUFFER_SIZE] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C, 0x0D0E, 0x0F10,
40 0x1112, 0x1314, 0x1516, 0x1718, 0x191A, 0x1B1C, 0x1D1E, 0x1F20,
41 0x2122, 0x2324, 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
42 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C, 0x3D3E, 0x3F40};
43uint16_t spi2_tx_buffer[BUFFER_SIZE] = {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C, 0x5D5E, 0x5F60,
44 0x6162, 0x6364, 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
45 0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
46 0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C, 0x8D8E, 0x8F90};
47uint16_t spi1_rx_buffer[BUFFER_SIZE], spi2_rx_buffer[BUFFER_SIZE];
48uint32_t tx_index = 0, rx_index = 0;
49__IO uint16_t crc1_value = 0, crc2_value = 0;
50volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
51
52static void gpio_config(void);
53static void spi_config(void);
54 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
55
62 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
63{
64 while(buffer_length--)
65 {
66 if(*pbuffer1 != *pbuffer2)
67 {
68 return ERROR;
69 }
70 pbuffer1++;
71 pbuffer2++;
72 }
73 return SUCCESS;
74}
75
81static void spi_config(void)
82{
83 spi_init_type spi_init_struct;
84 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
85 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
86 spi_default_para_init(&spi_init_struct);
87 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
88 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
89 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
90 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
91 spi_init_struct.frame_bit_num = SPI_FRAME_16BIT;
92 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
93 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
94 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
95 spi_init(SPI1, &spi_init_struct);
96
97 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
98 spi_init(SPI2, &spi_init_struct);
99
100 spi_crc_polynomial_set(SPI1, 7);
101 spi_crc_polynomial_set(SPI2, 7);
102 spi_crc_enable(SPI1, TRUE);
103 spi_crc_enable(SPI2, TRUE);
104 spi_enable(SPI1, TRUE);
105 spi_enable(SPI2, TRUE);
106}
107
113static void gpio_config(void)
114{
115 gpio_init_type gpio_initstructure;
116 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
117 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
118
119 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
121 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
122 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
123 gpio_initstructure.gpio_pins = GPIO_PINS_5;
124 gpio_init(GPIOA, &gpio_initstructure);
125
126 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
127 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
128 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
129 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
130 gpio_initstructure.gpio_pins = GPIO_PINS_6;
131 gpio_init(GPIOA, &gpio_initstructure);
132
133 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
134 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
135 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
136 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
137 gpio_initstructure.gpio_pins = GPIO_PINS_7;
138 gpio_init(GPIOA, &gpio_initstructure);
139
140 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
141 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
142 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
143 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
144 gpio_initstructure.gpio_pins = GPIO_PINS_13;
145 gpio_init(GPIOB, &gpio_initstructure);
146
147 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
148 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
149 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
150 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
151 gpio_initstructure.gpio_pins = GPIO_PINS_14;
152 gpio_init(GPIOB, &gpio_initstructure);
153
154 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
155 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
156 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
157 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
158 gpio_initstructure.gpio_pins = GPIO_PINS_15;
159 gpio_init(GPIOB, &gpio_initstructure);
160}
161
167int main(void)
168{
169 system_clock_config();
170 at32_board_init();
171 gpio_config();
172 spi_config();
173
174 /* transfer procedure:the "BUFFER_SIZE-1" data transfer */
175 while(tx_index < BUFFER_SIZE - 1)
176 {
177 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
178 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index]);
179 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
180 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
181 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
182 spi2_rx_buffer[rx_index] = spi_i2s_data_receive(SPI2);
183 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
184 spi1_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI1);
185 }
186 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
187 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
188
189 /* transfer procedure:the last data and crc transfer */
190 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index]);
191 spi_crc_next_transmit(SPI2);
192 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index]);
193 spi_crc_next_transmit(SPI1);
194 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
195 spi1_rx_buffer[rx_index] = spi_i2s_data_receive(SPI1);
196 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
197 spi2_rx_buffer[rx_index] = spi_i2s_data_receive(SPI2);
198 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
199 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
200
201 /* test result:the data and crc check */
202 transfer_status1 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
203 transfer_status2 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
204 if((spi_i2s_flag_get(SPI1, SPI_CCERR_FLAG)) != RESET)
205 {
206 spi_i2s_flag_clear(SPI1, SPI_CCERR_FLAG);
207 transfer_status2 = ERROR;
208 }
209 if((spi_i2s_flag_get(SPI2, SPI_CCERR_FLAG)) != RESET)
210 {
211 spi_i2s_flag_clear(SPI2, SPI_CCERR_FLAG);
212 transfer_status1 = ERROR;
213 }
214 crc1_value = spi_i2s_data_receive(SPI1);
215 crc2_value = spi_i2s_data_receive(SPI2);
216
217 /* test result indicate:if success,led2 lights */
218 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
219 {
220 at32_led_on(LED2);
221 }
222 else
223 {
224 at32_led_off(LED2);
225 }
226 while(1)
227 {
228 }
229}
230
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
spi1_tx_buffer
uint16_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:39
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:62
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:81
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:50
spi2_tx_buffer
uint16_t spi2_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:43
spi1_rx_buffer
uint16_t spi1_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:47
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:37
crc2_value
__IO uint16_t crc2_value
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:49
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:50
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:167
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:48
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:48
spi2_rx_buffer
uint16_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:47
crc1_value
__IO uint16_t crc1_value
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:49
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:113
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
SPI_CCERR_FLAG
#define SPI_CCERR_FLAG
Definition: at32f413_spi.h:55
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f413_spi.c:189
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f413_spi.c:150
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f413_spi.c:163
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:578
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:158
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f413_spi.h:88
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • fullduplex_polling
  • inc
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • fullduplex_polling
  • inc
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • fullduplex_polling
  • inc
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • fullduplex_polling
  • src
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • fullduplex_polling
  • src
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • fullduplex_polling
  • src
project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28
37#define BUFFER_SIZE 32
38
39 spi_init_type spi_init_struct;
40uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
41 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
42 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
43 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
44uint8_t spi2_tx_buffer[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
45 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
46 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
47 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
48uint8_t spi1_rx_buffer[BUFFER_SIZE], spi2_rx_buffer[BUFFER_SIZE];
49uint32_t tx_index = 0, rx_index = 0;
50volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
51volatile error_status transfer_status3 = ERROR, transfer_status4 = ERROR;
52
53static void gpio_config(uint16_t spi1_mode, uint16_t spi2_mode);
54static void spi_config(void);
55 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength);
56
63 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength)
64{
65 while(bufferlength--)
66 {
67 if(*pbuffer1 != *pbuffer2)
68 {
69 return ERROR;
70 }
71
72 pbuffer1++;
73 pbuffer2++;
74 }
75 return SUCCESS;
76}
77
83static void spi_config(void)
84{
85 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
86 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
87 spi_default_para_init(&spi_init_struct);
88 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
89 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
90 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
91 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
92 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
93 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
94 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
95 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
96 spi_init(SPI1, &spi_init_struct);
97
98 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
99 spi_init(SPI2, &spi_init_struct);
100
101 spi_enable(SPI1, TRUE);
102 spi_enable(SPI2, TRUE);
103}
104
110static void gpio_config(uint16_t spi1_mode, uint16_t spi2_mode)
111{
112 gpio_init_type gpio_initstructure;
113 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
114 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
115 gpio_default_para_init(&gpio_initstructure);
116 /* spi1 sck pin */
117 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
118 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
119 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
120 if(spi1_mode == SPI_MODE_MASTER)
121 {
122 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
123 }
124 else
125 {
126 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
127 }
128 gpio_initstructure.gpio_pins = GPIO_PINS_5;
129 gpio_init(GPIOA, &gpio_initstructure);
130
131 /* spi1 miso pin */
132 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
133 if(spi1_mode == SPI_MODE_MASTER)
134 {
135 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
136 }
137 else
138 {
139 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
140 }
141 gpio_initstructure.gpio_pins = GPIO_PINS_6;
142 gpio_init(GPIOA, &gpio_initstructure);
143
144 /* spi1 mosi pin */
145 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
146 if(spi1_mode == SPI_MODE_MASTER)
147 {
148 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
149 }
150 else
151 {
152 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
153 }
154 gpio_initstructure.gpio_pins = GPIO_PINS_7;
155 gpio_init(GPIOA, &gpio_initstructure);
156
157 /* spi2 sck pin */
158 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
159 if(spi2_mode == SPI_MODE_SLAVE)
160 {
161 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
162 }
163 else
164 {
165 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
166 }
167 gpio_initstructure.gpio_pins = GPIO_PINS_13;
168 gpio_init(GPIOB, &gpio_initstructure);
169
170 /* spi2 miso pin */
171 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
172 if(spi2_mode == SPI_MODE_SLAVE)
173 {
174 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
175 }
176 else
177 {
178 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
179 }
180 gpio_initstructure.gpio_pins = GPIO_PINS_14;
181 gpio_init(GPIOB, &gpio_initstructure);
182
183 /* spi2 mosi pin */
184 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
185 if(spi2_mode == SPI_MODE_SLAVE)
186 {
187 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
188 }
189 else
190 {
191 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
192 }
193 gpio_initstructure.gpio_pins = GPIO_PINS_15;
194 gpio_init(GPIOB, &gpio_initstructure);
195}
196
202int main(void)
203{
204 __IO uint32_t index = 0;
205 system_clock_config();
206 at32_board_init();
207 gpio_config(SPI_MODE_MASTER, SPI_MODE_SLAVE);
208 spi_config();
209
210 /* transfer procedure:the "BUFFER_SIZE" data transfer */
211 while(tx_index < BUFFER_SIZE)
212 {
213 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
214 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index]);
215 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
216 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
217 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
218 spi2_rx_buffer[rx_index] = spi_i2s_data_receive(SPI2);
219 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
220 spi1_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI1);
221 }
222
223 /* test result:the data check */
224 transfer_status1 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
225 transfer_status2 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
226
227 /* master &slave mode switch */
228 spi_enable(SPI1, FALSE);
229 spi_enable(SPI2, FALSE);
230 gpio_config(SPI_MODE_SLAVE, SPI_MODE_MASTER);
231 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
232 spi_init(SPI1, &spi_init_struct);
233
234 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
235 spi_init(SPI2, &spi_init_struct);
236
237 tx_index = 0;
238 rx_index = 0;
239 for(index = 0; index < BUFFER_SIZE; index++)
240 spi1_rx_buffer[index] = 0;
241 for(index = 0; index < BUFFER_SIZE; index++)
242 spi2_rx_buffer[index] = 0;
243
244 spi_enable(SPI2, TRUE);
245 spi_enable(SPI1, TRUE);
246
247 /* transfer procedure:the "BUFFER_SIZE" data transfer */
248 while(tx_index < BUFFER_SIZE)
249 {
250 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
251 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index]);
252 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
253 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index++]);
254 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
255 spi1_rx_buffer[rx_index] = spi_i2s_data_receive(SPI1);
256 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
257 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
258 }
259
260 /* test result:the data check */
261 transfer_status3 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
262 transfer_status4 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
263
264 /* test result indicate:if success ,led2 lights */
265 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS) && \
266 (transfer_status3 == SUCCESS) && (transfer_status4 == SUCCESS))
267 {
268 at32_led_on(LED2);
269 }
270 else
271 {
272 at32_led_off(LED2);
273 }
274 while(1)
275 {
276 }
277}
278
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:63
transfer_status3
volatile error_status transfer_status3
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:51
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:83
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:50
transfer_status4
volatile error_status transfer_status4
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:51
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:37
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:50
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:202
gpio_config
static void gpio_config(uint16_t spi1_mode, uint16_t spi2_mode)
gpio configuration.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:110
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:48
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
spi1_rx_buffer
uint8_t spi1_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:48
spi2_tx_buffer
uint8_t spi2_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:44
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:49
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:49
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:150
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:158
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern uint8_t spi1_tx_buffer[];
30extern uint8_t spi2_rx_buffer[];
31extern uint32_t tx_index;
32extern uint32_t rx_index;
33
42#define BUFFERSIZE 32
43
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146 void SPI1_IRQHandler(void)
147{
148 if(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) != RESET)
149 {
150 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
151 if(tx_index == BUFFERSIZE)
152 {
153 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
154 }
155 }
156}
157
163 void SPI2_IRQHandler(void)
164{
165 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
166 {
167 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
168 }
169}
170
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:44
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:31
spi1_tx_buffer
uint8_t spi1_tx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:39
spi2_rx_buffer
uint8_t spi2_rx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:47
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:71
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:110
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:128
SPI2_IRQHandler
void SPI2_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:163
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:84
SPI1_IRQHandler
void SPI1_IRQHandler(void)
This function handles the spi1 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:146
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:137
BUFFERSIZE
#define BUFFERSIZE
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:42
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:119
FALSE
@ FALSE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:72
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BUFFER_SIZE 32
37
38 spi_init_type spi_init_struct;
39
40uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
41 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
42 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
43 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
44uint8_t spi2_rx_buffer[BUFFER_SIZE];
45volatile uint32_t tx_index = 0, rx_index = 0;
46volatile error_status transfer_status = ERROR;
47
48static void gpio_config(void);
49static void spi_config(void);
50 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
51
58 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
59{
60 while(buffer_length--)
61 {
62 if(*pbuffer1 != *pbuffer2)
63 {
64 return ERROR;
65 }
66
67 pbuffer1++;
68 pbuffer2++;
69 }
70 return SUCCESS;
71}
72
78static void spi_config(void)
79{
80 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
82 spi_default_para_init(&spi_init_struct);
83 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
84 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
85 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
86 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
87 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
88 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
89 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
90 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
91 spi_init(SPI1, &spi_init_struct);
92
93 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
94 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
95 spi_init(SPI2, &spi_init_struct);
96
97 nvic_irq_enable(SPI1_IRQn, 0, 0);
98 nvic_irq_enable(SPI2_IRQn, 0, 0);
99 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, TRUE);
100 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
101
102 spi_enable(SPI2, TRUE);
103 spi_enable(SPI1, TRUE);
104}
105
111static void gpio_config(void)
112{
113 gpio_init_type gpio_initstructure;
114 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
115 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
116 gpio_default_para_init(&gpio_initstructure);
117
118 /* spi1 sck pin */
119 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
121 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
122 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
123 gpio_initstructure.gpio_pins = GPIO_PINS_5;
124 gpio_init(GPIOA, &gpio_initstructure);
125
126 /* spi1 mosi pin */
127 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
128 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
129 gpio_initstructure.gpio_pins = GPIO_PINS_7;
130 gpio_init(GPIOA, &gpio_initstructure);
131
132 /* spi2 sck pin */
133 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
134 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
135 gpio_initstructure.gpio_pins = GPIO_PINS_13;
136 gpio_init(GPIOB, &gpio_initstructure);
137
138 /* spi2 miso pin */
139 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
140 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
141 gpio_initstructure.gpio_pins = GPIO_PINS_14;
142 gpio_init(GPIOB, &gpio_initstructure);
143
144 while(gpio_input_data_bit_read(GPIOB, GPIO_PINS_13)!=RESET);
145}
146
152int main(void)
153{
154 system_clock_config();
155 at32_board_init();
156 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
157 gpio_config();
158 /* config spi1 send spi2 receive */
159 spi_config();
160 while(rx_index < BUFFER_SIZE);
161
162 /* test result:the data check */
163 transfer_status = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
164
165 /* test result indicate:if success ,led2 lights */
166 if(transfer_status==SUCCESS)
167 {
168 at32_led_on(LED2);
169 }
170 else
171 {
172 at32_led_off(LED2);
173 }
174 while(1)
175 {
176 }
177}
178
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:58
tx_index
volatile uint32_t tx_index
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:45
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:78
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:36
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:152
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:44
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:38
rx_index
volatile uint32_t rx_index
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:45
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:111
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:46
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:207
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:206
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:201
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:72
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f413_spi.h:71
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:161
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
29extern uint8_t spi1_tx_buffer[];
30extern uint8_t spi2_tx_buffer[];
31extern uint8_t spi1_rx_buffer[];
32extern uint8_t spi2_rx_buffer[];
33extern uint32_t tx_index;
34extern uint32_t rx_index;
35
44#define BUFFERSIZE 32
45
51void NMI_Handler(void)
52{
53}
54
60void HardFault_Handler(void)
61{
62 /* go to infinite loop when hard fault exception occurs */
63 while(1)
64 {
65 }
66}
67
73void MemManage_Handler(void)
74{
75 /* go to infinite loop when memory manage exception occurs */
76 while(1)
77 {
78 }
79}
80
86void BusFault_Handler(void)
87{
88 /* go to infinite loop when bus fault exception occurs */
89 while(1)
90 {
91 }
92}
93
99void UsageFault_Handler(void)
100{
101 /* go to infinite loop when usage fault exception occurs */
102 while(1)
103 {
104 }
105}
106
112void SVC_Handler(void)
113{
114}
115
121void DebugMon_Handler(void)
122{
123}
124
130void PendSV_Handler(void)
131{
132}
133
139void SysTick_Handler(void)
140{
141}
142
148 void SPI1_IRQHandler(void)
149{
150 if(SPI1->ctrl2_bit.tdbeie != RESET)
151 {
152 if(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) != RESET)
153 {
154 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
155 if(tx_index == BUFFERSIZE)
156 {
157 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
158 }
159 }
160 }
161 if(SPI1->ctrl2_bit.rdbfie != RESET)
162 {
163 if(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) != RESET)
164 {
165 spi_enable(SPI1, FALSE);
166 spi1_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI1);
167 spi_enable(SPI1, TRUE);
168 if(rx_index == BUFFERSIZE)
169 {
170 spi_i2s_interrupt_enable(SPI1, SPI_I2S_RDBF_INT, FALSE);
171 }
172 }
173 }
174}
175
181 void SPI2_IRQHandler(void)
182{
183 if(SPI2->ctrl2_bit.tdbeie != RESET)
184 {
185 if(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) != RESET)
186 {
187 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index++]);
188 if(tx_index == BUFFERSIZE)
189 {
190 spi_i2s_interrupt_enable(SPI2, SPI_I2S_TDBE_INT, FALSE);
191 }
192 }
193 }
194 if(SPI2->ctrl2_bit.rdbfie != RESET)
195 {
196 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
197 {
198 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
199 }
200 }
201}
202
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:44
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:31
spi1_tx_buffer
uint8_t spi1_tx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:39
spi2_tx_buffer
uint8_t spi2_tx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:43
spi1_rx_buffer
uint8_t spi1_rx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:47
spi2_rx_buffer
uint8_t spi2_rx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:47
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:99
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:60
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:73
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:112
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:130
SPI2_IRQHandler
void SPI2_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:181
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:51
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:86
SPI1_IRQHandler
void SPI1_IRQHandler(void)
This function handles the spi1 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:148
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:139
BUFFERSIZE
#define BUFFERSIZE
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:44
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:121
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:72
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f413_spi.h:71
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BUFFER_SIZE 32
37
38
39 spi_init_type spi_init_struct;
40uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
41 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
42 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
43 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
44uint8_t spi2_tx_buffer[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
45 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
46 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
47 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
48uint8_t spi1_rx_buffer[BUFFER_SIZE], spi2_rx_buffer[BUFFER_SIZE];
49volatile uint32_t tx_index = 0, rx_index = 0;
50volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
51
52static void gpio_config(void);
53static void spi_config(void);
54 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
55
62 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
63{
64 while(buffer_length--)
65 {
66 if(*pbuffer1 != *pbuffer2)
67 {
68 return ERROR;
69 }
70
71 pbuffer1++;
72 pbuffer2++;
73 }
74 return SUCCESS;
75}
76
82static void spi_config(void)
83{
84 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
85 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
86 spi_default_para_init(&spi_init_struct);
87 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
88 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
89 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_256;
90 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
91 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
92 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
93 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
94 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
95 spi_init(SPI1, &spi_init_struct);
96
97 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
98 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
99 spi_init(SPI2, &spi_init_struct);
100
101 nvic_irq_enable(SPI1_IRQn, 0, 0);
102 nvic_irq_enable(SPI2_IRQn, 0, 0);
103 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, TRUE);
104 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
105
106 spi_enable(SPI1, TRUE);
107 spi_enable(SPI2, TRUE);
108}
109
115static void gpio_config(void)
116{
117 gpio_init_type gpio_initstructure;
118 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
119 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
120 gpio_default_para_init(&gpio_initstructure);
121
122 /* spi1 sck pin */
123 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
124 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
125 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
126 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
127 gpio_initstructure.gpio_pins = GPIO_PINS_5;
128 gpio_init(GPIOA, &gpio_initstructure);
129
130 /* spi1 mosi pin */
131 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
132 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
133 gpio_initstructure.gpio_pins = GPIO_PINS_7;
134 gpio_init(GPIOA, &gpio_initstructure);
135
136 /* spi2 sck pin */
137 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
138 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
139 gpio_initstructure.gpio_pins = GPIO_PINS_13;
140 gpio_init(GPIOB, &gpio_initstructure);
141
142 /* spi2 miso pin */
143 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
144 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
145 gpio_initstructure.gpio_pins = GPIO_PINS_14;
146 gpio_init(GPIOB, &gpio_initstructure);
147
148 while(gpio_input_data_bit_read(GPIOB, GPIO_PINS_13)!=RESET);
149}
150
156int main(void)
157{
158 system_clock_config();
159 at32_board_init();
160 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
161 gpio_config();
162 /* config spi1 send spi2 receive */
163 spi_config();
164 while(rx_index < BUFFER_SIZE);
165
166 /* test result:the data check */
167 transfer_status1 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
168
169 /* config spi2 send spi1 receive */
170 spi_enable(SPI1, FALSE);
171 spi_enable(SPI2, FALSE);
172 rx_index = 0;
173 tx_index = 0;
174 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
175 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, FALSE);
176
177 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
178 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
179 spi_init(SPI1, &spi_init_struct);
180
181 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
182 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
183 spi_init(SPI2, &spi_init_struct);
184
185 spi_i2s_interrupt_enable(SPI1, SPI_I2S_RDBF_INT, TRUE);
186 spi_i2s_interrupt_enable(SPI2, SPI_I2S_TDBE_INT, TRUE);
187 spi_enable(SPI2, TRUE);
188 spi_enable(SPI1, TRUE);
189 while(rx_index < BUFFER_SIZE);
190
191 /* test result:the data check */
192 transfer_status2 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
193
194 /* test result indicate:if passed ,led2 lights */
195 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
196 {
197 at32_led_on(LED2);
198 }
199 else
200 {
201 at32_led_off(LED2);
202 }
203 while(1)
204 {
205 }
206}
207
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:62
tx_index
volatile uint32_t tx_index
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:49
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:82
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:50
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:36
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:50
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:156
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:48
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:39
spi1_rx_buffer
uint8_t spi1_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:48
spi2_tx_buffer
uint8_t spi2_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:44
rx_index
volatile uint32_t rx_index
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:49
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:115
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:207
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:206
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:201
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:72
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f413_spi.h:71
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:462
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:161
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f413_spi.h:139
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • only_receive_mode_polling
  • src
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • only_receive_mode_polling
  • src
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • only_receive_mode_polling
  • src
project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BUFFER_SIZE 32
37
38 spi_init_type spi_init_struct;
39uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
40 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
41 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
42 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
43uint8_t spi2_rx_buffer[BUFFER_SIZE];
44uint32_t tx_index = 0, rx_index = 0;
45volatile error_status transfer_status = ERROR;
46
47static void gpio_config(void);
48static void spi_config(void);
49 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
50
57 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
58{
59 while(buffer_length--)
60 {
61 if(*pbuffer1 != *pbuffer2)
62 {
63 return ERROR;
64 }
65
66 pbuffer1++;
67 pbuffer2++;
68 }
69 return SUCCESS;
70}
71
77static void spi_config(void)
78{
79 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
80 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
81 spi_default_para_init(&spi_init_struct);
82 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
83 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
84 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
85 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
86 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
87 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
88 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
89 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
90 spi_init(SPI1, &spi_init_struct);
91
92 spi_init_struct.transmission_mode = SPI_TRANSMIT_SIMPLEX_RX;
93 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
94 spi_init(SPI2, &spi_init_struct);
95
96 spi_enable(SPI1, TRUE);
97 spi_enable(SPI2, TRUE);
98}
99
105static void gpio_config(void)
106{
107 gpio_init_type gpio_initstructure;
108 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
109 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
110 gpio_default_para_init(&gpio_initstructure);
111
112 /* spi1 sck pin */
113 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
114 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
115 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
116 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
117 gpio_initstructure.gpio_pins = GPIO_PINS_5;
118 gpio_init(GPIOA, &gpio_initstructure);
119
120 /* spi1 mosi pin */
121 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
122 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
123 gpio_initstructure.gpio_pins = GPIO_PINS_7;
124 gpio_init(GPIOA, &gpio_initstructure);
125
126 /* spi2 sck pin */
127 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
128 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
129 gpio_initstructure.gpio_pins = GPIO_PINS_13;
130 gpio_init(GPIOB, &gpio_initstructure);
131
132 /* spi2 mosi pin */
133 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
134 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
135 gpio_initstructure.gpio_pins = GPIO_PINS_15;
136 gpio_init(GPIOB, &gpio_initstructure);
137
138 while(gpio_input_data_bit_read(GPIOB, GPIO_PINS_13) != RESET);
139}
140
146int main(void)
147{
148 system_clock_config();
149 at32_board_init();
150 gpio_config();
151 spi_config();
152
153 /* transfer procedure:the "BUFFER_SIZE" data transfer */
154 while(tx_index < BUFFER_SIZE)
155 {
156 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
157 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
158 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
159 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
160 }
161
162 /* test result:the data check */
163 transfer_status = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
164
165 /* test result indicate:if SUCCESS ,led2 lights */
166 if(transfer_status == SUCCESS)
167 {
168 at32_led_on(LED2);
169 }
170 else
171 {
172 at32_led_off(LED2);
173 }
174 while(1)
175 {
176 }
177}
178
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:57
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:77
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:36
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:146
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:43
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:38
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:44
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:44
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:105
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:45
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:201
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:150
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:158
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:159
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BUFFER_SIZE 32
37
38uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
39 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
40 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
41 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
42uint8_t spi2_rx_buffer[BUFFER_SIZE];
43__IO uint8_t tx_index = 0;
44volatile error_status transfer_status = ERROR;
45
46static void gpio_config(void);
47static void spi_config(void);
48 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
49
56 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
57{
58 while(buffer_length--)
59 {
60 if(*pbuffer1 != *pbuffer2)
61 {
62 return ERROR;
63 }
64
65 pbuffer1++;
66 pbuffer2++;
67 }
68 return SUCCESS;
69}
70
76static void spi_config(void)
77{
78 dma_init_type dma_init_struct;
79 spi_init_type spi_init_struct;
80
81 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
82 dma_reset(DMA1_CHANNEL4);
83 dma_default_para_init(&dma_init_struct);
84 dma_init_struct.buffer_size = BUFFER_SIZE;
85 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
86 dma_init_struct.memory_base_addr = (uint32_t)spi2_rx_buffer;
87 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
88 dma_init_struct.memory_inc_enable = TRUE;
89 dma_init_struct.peripheral_base_addr = (uint32_t)0x4000380C;
90 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
91 dma_init_struct.peripheral_inc_enable = FALSE;
92 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
93 dma_init_struct.loop_mode_enable = FALSE;
94 dma_init(DMA1_CHANNEL4, &dma_init_struct);
95
96 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
97 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
98 spi_default_para_init(&spi_init_struct);
99 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
100 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
101 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
102 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
103 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
104 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
105 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
106 spi_init_struct.cs_mode_selection = SPI_CS_HARDWARE_MODE;
107 spi_init(SPI1, &spi_init_struct);
108
109 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
110 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
111 spi_init(SPI2, &spi_init_struct);
112
113 spi_hardware_cs_output_enable(SPI1, TRUE);
114 spi_i2s_dma_receiver_enable(SPI2, TRUE);
115 spi_enable(SPI1, TRUE);
116 spi_enable(SPI2, TRUE);
117}
118
124static void gpio_config(void)
125{
126 gpio_init_type gpio_initstructure;
127 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
128 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
129 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
130 gpio_pin_remap_config(SWJTAG_GMUX_010, TRUE);
131 gpio_pin_remap_config(SPI1_MUX_01, TRUE);
132
133 /* master sck pin */
134 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
135 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
136 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
137 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
138 gpio_initstructure.gpio_pins = GPIO_PINS_3;
139 gpio_init(GPIOB, &gpio_initstructure);
140
141 /* master mosi pin */
142 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
143 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
144 gpio_initstructure.gpio_pins = GPIO_PINS_5;
145 gpio_init(GPIOB, &gpio_initstructure);
146
147 /* master cs pin */
148 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
149 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
150 gpio_initstructure.gpio_pins = GPIO_PINS_15;
151 gpio_init(GPIOA, &gpio_initstructure);
152
153 /* slave sck pin */
154 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
155 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
156 gpio_initstructure.gpio_pins = GPIO_PINS_13;
157 gpio_init(GPIOB, &gpio_initstructure);
158
159 /* slave miso pin */
160 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
161 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
162 gpio_initstructure.gpio_pins = GPIO_PINS_14;
163 gpio_init(GPIOB, &gpio_initstructure);
164
165 /* slave cs pin */
166 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
167 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
168 gpio_initstructure.gpio_pins = GPIO_PINS_12;
169 gpio_init(GPIOB, &gpio_initstructure);
170}
171
177int main(void)
178{
179 system_clock_config();
180 at32_board_init();
181
182 /* button press:ensure code canbe download normally */
183 while(at32_button_press() == NO_BUTTON);
184
185 gpio_config();
186 spi_config();
187 dma_channel_enable(DMA1_CHANNEL4, TRUE);
188
189 /* transfer procedure:the "BUFFER_SIZE" data transfer */
190 while(tx_index < BUFFER_SIZE)
191 {
192 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
193 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
194 }
195 while(!dma_flag_get(DMA1_FDT4_FLAG));
196
197 /* test result:the data check */
198 transfer_status = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
199
200 /* test result indicate:if success ,led2 lights */
201 if(transfer_status == SUCCESS)
202 {
203 at32_led_on(LED2);
204 }
205 else
206 {
207 at32_led_off(LED2);
208 }
209 while(1)
210 {
211 }
212}
213
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:56
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:76
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:36
tx_index
__IO uint8_t tx_index
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:177
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:42
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:124
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:44
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:93
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:515
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
SWJTAG_GMUX_010
#define SWJTAG_GMUX_010
Definition: at32f413_gpio.h:195
SPI1_MUX_01
#define SPI1_MUX_01
Definition: at32f413_gpio.h:79
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:497
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f413_spi.c:222
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_HARDWARE_MODE
@ SPI_CS_HARDWARE_MODE
Definition: at32f413_spi.h:123
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:105
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:161
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI1
#define SPI1
Definition: at32f413_spi.h:446
SPI2
#define SPI2
Definition: at32f413_spi.h:447
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • w25q_flash
  • inc
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • w25q_flash
  • inc
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • w25q_flash
  • inc
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • w25q_flash
  • src
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • w25q_flash
  • src
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • w25q_flash
  • src
project/at_start_f413/examples/spi/w25q_flash/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "spi_flash.h"
28
37#define FLASH_TEST_ADDR 0x1000
38#define BUF_SIZE 0x256
39
40uint8_t tx_buffer[BUF_SIZE];
41uint8_t rx_buffer[BUF_SIZE];
42volatile error_status transfer_status = ERROR;
43
44void tx_data_fill(void);
45 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
46
52void tx_data_fill(void)
53{
54 uint32_t data_index = 0;
55 for(data_index = 0; data_index < BUF_SIZE; data_index++)
56 {
57 tx_buffer[data_index] = data_index;
58 }
59}
60
67 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
68{
69 while(buffer_length--)
70 {
71 if(*pbuffer1 != *pbuffer2)
72 {
73 return ERROR;
74 }
75
76 pbuffer1++;
77 pbuffer2++;
78 }
79 return SUCCESS;
80}
81
87int main(void)
88{
89 __IO uint32_t index = 0;
90 __IO uint32_t flash_id_index = 0;
91 system_clock_config();
92 at32_board_init();
93 tx_data_fill();
94 uart_print_init(115200);
95 spiflash_init();
96 flash_id_index = spiflash_read_id();
97if((flash_id_index != W25Q128)&&(flash_id_index != W25Q80)&&(flash_id_index != W25Q16)&&(flash_id_index != W25Q32)&&(flash_id_index != W25Q64)) {
98 printf("flash id check error!\r\n");
99 for(index = 0; index < 50; index++)
100 {
101 at32_led_toggle(LED2);
102 at32_led_toggle(LED3);
103 delay_ms(200);
104 }
105 return 1;
106 }
107 else
108 {
109 printf("flash id check success! id: %x\r\n", flash_id_index);
110 }
111
112 /* erase sector */
113 spiflash_sector_erase(FLASH_TEST_ADDR / SPIF_SECTOR_SIZE);
114
115 /* write data */
116 spiflash_write(tx_buffer, FLASH_TEST_ADDR, BUF_SIZE);
117
118 /* read data */
119 spiflash_read(rx_buffer, FLASH_TEST_ADDR, BUF_SIZE);
120
121 /* printf read data */
122 printf("Read Data: ");
123 for(index = 0; index < BUF_SIZE; index++)
124 {
125 printf("%x ", rx_buffer[index]);
126 }
127
128 /* test result:the data check */
129 transfer_status = buffer_compare(rx_buffer, tx_buffer, BUF_SIZE);
130
131 /* test result indicate:if SUCCESS ,led2 lights */
132 if(transfer_status == SUCCESS)
133 {
134 printf("\r\nflash data read write success!\r\n");
135 at32_led_on(LED2);
136 }
137 else
138 {
139 printf("\r\nflash data read write ERROR!\r\n");
140 at32_led_off(LED2);
141 }
142
143 while(1)
144 {
145 }
146}
147
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:67
FLASH_TEST_ADDR
#define FLASH_TEST_ADDR
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:37
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:87
rx_buffer
uint8_t rx_buffer[0x256]
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:41
tx_data_fill
void tx_data_fill(void)
transfer data fill.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:52
tx_buffer
uint8_t tx_buffer[0x256]
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:40
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: spi_flash.c:42
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: spi_flash.c:97
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: spi_flash.c:201
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: spi_flash.c:185
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: spi_flash.c:466
W25Q128
#define W25Q128
Definition: spi_flash.h:69
W25Q16
#define W25Q16
Definition: spi_flash.h:65
W25Q32
#define W25Q32
Definition: spi_flash.h:66
W25Q80
#define W25Q80
Definition: spi_flash.h:64
W25Q64
#define W25Q64
Definition: spi_flash.h:67
SPIF_SECTOR_SIZE
#define SPIF_SECTOR_SIZE
Definition: spi_flash.h:80
spi_flash.h
header file of spi_flash
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • sram
  • extend_sram
  • inc
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • sram
  • extend_sram
  • inc
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • sram
  • extend_sram
  • inc
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • sram
  • extend_sram
  • src
project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • sram
  • extend_sram
  • src
project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • sram
  • extend_sram
  • src
project/at_start_f413/examples/sram/extend_sram/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32void extend_sram(void);
33
34#ifdef __cplusplus
35}
36#endif
37
51void extend_sram(void)
52{
53 /* check if ram has been set to expectant size, if not, change eopb0 */
54 if(((USD->eopb0) & 0xFF) != EXTEND_SRAM)
55 {
56 flash_unlock();
57 /* erase user system data bytes */
58 flash_user_system_data_erase();
59
60 /* change sram size */
61 flash_user_system_data_program((uint32_t)&USD->eopb0, EXTEND_SRAM);
62
63 /* system reset */
64 nvic_system_reset();
65 }
66}
67
73int main(void)
74{
75 system_clock_config();
76 at32_board_init();
77
78 /* check eopb0 */
79 if(((USD->eopb0) & 0xFF) == EXTEND_SRAM)
80 {
81 at32_led_on(LED4);
82 }
83
84 while(1)
85 {
86 }
87}
88
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/sram/extend_sram/src/main.c:73
extend_sram
void extend_sram(void)
to extend sram size
Definition: project/at_start_f413/examples/sram/extend_sram/src/main.c:51
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f413_flash.c:512
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f413_flash.c:361
USD
#define USD
Definition: at32f413_flash.h:563
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • cascade_synchro
  • inc
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • cascade_synchro
  • inc
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • cascade_synchro
  • inc
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • cascade_synchro
  • src
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • cascade_synchro
  • src
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • cascade_synchro
  • src
project/at_start_f413/examples/tmr/cascade_synchro/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 tmr_output_config_type tmr_output_struct;
38
44int main(void)
45{
46 system_clock_config();
47
48 at32_board_init();
49
50 /* turn led2/led3/led4 on */
51 at32_led_on(LED2);
52 at32_led_on(LED3);
53 at32_led_on(LED4);
54
55 /* enable tmr2/tmr3/tmr4/gpioa/gpiob clock */
56 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
61
62 /* timer1 output pin Configuration */
63 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_0;
64 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
65 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
66 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
67 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
68 gpio_init(GPIOA, &gpio_init_struct);
69
70 gpio_init_struct.gpio_pins = GPIO_PINS_6;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
74 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
75 gpio_init(GPIOB, &gpio_init_struct);
76
77
78 /* timers synchronisation in cascade mode
79 1/tmr2 is configured as primary timer:
80 - pwm mode is used
81 - the tmr2 update event is used as trigger output
82
83 2/tmr3 is sub for tmr2 and primary for tmr4,
84 - pwm mode is used
85 - the itr1(tmr2) is used as input trigger
86 - gated mode is used, so start and stop of sub counter
87 are controlled by the master trigger output signal(tmr2 update event).
88 - the tmr3 update event is used as trigger output.
89
90 3/tmr4 is slave for tmr3,
91 - pwm mode is used
92 - the itr2(tmr3) is used as input trigger
93 - gated mode is used, so start and stop of sub counter
94 are controlled by the master trigger output signal(tmr3 overflow event).
95
96 the primary timer tmr2 is running at tmr2 frequency :
97 tim2 frequency = (tmr2 counter clock)/ (tmr2 period + 1) = 1 mhz
98 and the duty cycle = tmr2_c1dt/(tmr2_pr + 1) = 50%.
99
100 the tmr3 is running at:
101 (tmr2 frequency)/ (tmr3 period + 1) = 100 khz and a duty cycle equal
102 to tmr3_c1dt/(tmr3_pr + 1) = 50%
103
104 the tmr4 is running at:
105 (tmr3 frequency)/ (tmr4 period + 1) = 100 khz and a duty cycle equal
106 to tmr4_c1dt/(tmr4_pr + 1) = 50%
107
108 tmr2 pwm frequency = 1mhz, tmr3 pwm frequency = 100 khz,
109 and tmr4 pwm frequency = 10 khz */
110
111 tmr_base_init(TMR2, 191, 0);
112 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
113
114 tmr_base_init(TMR3, 9, 0);
115 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
116
117 tmr_base_init(TMR4, 9, 0);
118 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
119
120 /* channelx Configuration in output mode */
121 tmr_output_default_para_init(&tmr_output_struct);
122 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
123 tmr_output_struct.oc_output_state = TRUE;
124 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
125 tmr_output_struct.oc_idle_state = TRUE;
126 tmr_output_struct.occ_output_state = FALSE;
127 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
128 tmr_output_struct.occ_idle_state = FALSE;
129
130 /* timer2 channel 1 */
131 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
132 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, 96);
133
134 /* timer2 select enable signal to sub timer */
135 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
136 tmr_sub_sync_mode_set(TMR2, TRUE);
137
138 /* timer3 channel 1 */
139 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
140 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 5);
141
142 /* sub mode selection: tmr3 */
143 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
144 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS1);
145
146 /* timer3 select enable signal to sub timer */
147 tmr_primary_mode_select(TMR3, TMR_PRIMARY_SEL_OVERFLOW);
148 tmr_sub_sync_mode_set(TMR3, TRUE);
149
150 /* timer4 channel 1 */
151 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
152 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 5);
153
154 /* sub mode selection: tmr4 */
155 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
156 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS2);
157
158 /* enable tmr2/tmr3/tmr4 */
159 tmr_counter_enable(TMR2, TRUE);
160 tmr_counter_enable(TMR3, TRUE);
161 tmr_counter_enable(TMR4, TRUE);
162
163 while(1)
164 {
165 }
166}
167
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/main.c:36
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1263
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1164
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR_SUB_INPUT_SEL_IS2
@ TMR_SUB_INPUT_SEL_IS2
Definition: at32f413_tmr.h:133
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f413_tmr.h:132
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:151
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:118
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
TMR4
#define TMR4
Definition: at32f413_tmr.h:833
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • complementary_signals
  • inc
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • complementary_signals
  • inc
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • complementary_signals
  • inc
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • complementary_signals
  • src
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • complementary_signals
  • src
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • complementary_signals
  • src
project/at_start_f413/examples/tmr/complementary_signals/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 tmr_output_config_type tmr_output_struct;
38 crm_clocks_freq_type crm_clocks_freq_struct = {0};
39 tmr_brkdt_config_type tmr_brkdt_config_struct = {0};
40
41uint16_t timer_period = 0;
42uint16_t channel1_pulse = 0, channel2_pulse = 0, channel3_pulse = 0;
43
49int main(void)
50{
51 system_clock_config();
52
53 at32_board_init();
54
55 /* get system clock */
56 crm_clocks_freq_get(&crm_clocks_freq_struct);
57
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62
63 /* enable tmr1/gpioa/gpiob clock */
64 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 /* timer1 output pin configuration */
69 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
70 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
71 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
72 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init(GPIOA, &gpio_init_struct);
75
76 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
77 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
78 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
79 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
80 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
81 gpio_init(GPIOB, &gpio_init_struct);
82
83 gpio_init_struct.gpio_pins = GPIO_PINS_12;
84 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
85 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
86 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
87 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
88 gpio_init(GPIOB, &gpio_init_struct);
89
90 /* tmr1 configuration to:
91
92 1/ generate 3 complementary pwm signals with 3 different duty cycles:
93 tmr1clk is fixed to system_core_clock, the tmr1 prescaler is equal to 0 so the
94 tmr1 counter clock used is system_core_clock.
95
96 the objective is to generate pwm signal at 17.57 khz:
97 - tmr1_period = (system_core_clock / 17570) - 1
98
99 the three duty cycles are computed as the following description:
100
101 the channel 1 duty cycle is set to 50% so channel 1c is set to 50%.
102 the channel 2 duty cycle is set to 25% so channel 2c is set to 75%.
103 the channel 3 duty cycle is set to 12.5% so channel 3c is set to 87.5%.
104 the timer pulse is calculated as follows:
105 - channelxpulse = duty_cycle * (tmr1_period - 1) / 100
106
107 2/ insert a dead time equal to 11/system_core_clock ns
108 3/ configure the brake feature, active at high level, and using the automatic
109 output enable feature
110 4/ use the locking parameters level1. */
111
112 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
113 timer_period = (crm_clocks_freq_struct.sclk_freq / 17570 ) - 1;
114
115 /* compute c1dt value to generate a duty cycle at 50% for channel 1 and 1c */
116 channel1_pulse = (uint16_t) (((uint32_t) 5 * (timer_period - 1)) / 10);
117
118 /* compute c2dt value to generate a duty cycle at 25% for channel 2 and 2c */
119 channel2_pulse = (uint16_t) (((uint32_t) 25 * (timer_period - 1)) / 100);
120
121 /* compute c3dt value to generate a duty cycle at 12.5% for channel 3 and 3c */
122 channel3_pulse = (uint16_t) (((uint32_t) 125 * (timer_period - 1)) / 1000);
123
124 tmr_base_init(TMR1, timer_period, 0);
125 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
126
127 /* channel 1, 2, 3 and 4 Configuration in output mode */
128 tmr_output_default_para_init(&tmr_output_struct);
129 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
130 tmr_output_struct.oc_output_state = TRUE;
131 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
132 tmr_output_struct.oc_idle_state = TRUE;
133 tmr_output_struct.occ_output_state = TRUE;
134 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
135 tmr_output_struct.occ_idle_state = FALSE;
136
137 /* channel 1 */
138 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
139 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, channel1_pulse);
140
141 /* channel 2 */
142 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
143 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, channel2_pulse);
144
145 /* channel 3 */
146 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
147 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, channel3_pulse);
148
149 /* automatic output enable, stop, dead time and lock configuration */
150 tmr_brkdt_default_para_init(&tmr_brkdt_config_struct);
151 tmr_brkdt_config_struct.brk_enable = TRUE;
152 tmr_brkdt_config_struct.auto_output_enable = TRUE;
153 tmr_brkdt_config_struct.deadtime = 11;
154 tmr_brkdt_config_struct.fcsodis_state = TRUE;
155 tmr_brkdt_config_struct.fcsoen_state = TRUE;
156 tmr_brkdt_config_struct.brk_polarity = TMR_BRK_INPUT_ACTIVE_HIGH;
157 tmr_brkdt_config_struct.wp_level = TMR_WP_LEVEL_3;
158 tmr_brkdt_config(TMR1, &tmr_brkdt_config_struct);
159
160 /* output enable */
161 tmr_output_enable(TMR1, TRUE);
162
163 /* enable tmr1 */
164 tmr_counter_enable(TMR1, TRUE);
165
166 while(1)
167 {
168 }
169}
170
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:36
channel1_pulse
uint16_t channel1_pulse
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:42
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:37
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:41
channel2_pulse
uint16_t channel2_pulse
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:42
channel3_pulse
uint16_t channel3_pulse
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:49
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:38
tmr_brkdt_config_struct
tmr_brkdt_config_type tmr_brkdt_config_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:156
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time
Definition: at32f413_tmr.c:1722
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_WP_LEVEL_3
@ TMR_WP_LEVEL_3
Definition: at32f413_tmr.h:387
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:378
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:178
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:421
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:422
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:425
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:423
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • dma
  • inc
project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • dma
  • inc
project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • dma
  • inc
project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • dma
  • src
project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • dma
  • src
project/at_start_f413/examples/tmr/dma/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • dma
  • src
project/at_start_f413/examples/tmr/dma/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 tmr_output_config_type tmr_output_struct;
38 dma_init_type dma_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41uint16_t timer_period = 0;
42uint16_t src_buffer[3] = {0, 0, 0};
43
49int main(void)
50{
51 system_clock_config();
52
53 at32_board_init();
54
55 /* get system clock */
56 crm_clocks_freq_get(&crm_clocks_freq_struct);
57
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62
63 /* enable tmr1/gpioa/gpiob/dma clock */
64 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
68
69 /* timer1 output pin Configuration */
70 gpio_init_struct.gpio_pins = GPIO_PINS_10;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
74 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
75 gpio_init(GPIOA, &gpio_init_struct);
76
77 gpio_init_struct.gpio_pins = GPIO_PINS_15;
78 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
82 gpio_init(GPIOB, &gpio_init_struct);
83
84 /* tmr1 dma transfer example
85 tmr1clk = system_core_clock, prescaler = 0, tmr1 counter clock = system_core_clock
86
87 the objective is to configure tmr1 channel 3 to generate complementary pwm
88 signal with a frequency equal to 17.57 khz:
89 - tmr1_period = (system_core_clock / 17570) - 1
90 and a variable duty cycle that is changed by the dma after a specific number of
91 update dma request.
92
93 the number of this repetitive requests is defined by the tmr1 repetition counter,
94 each 3 update requests, the tmr1 channel 3 duty cycle changes to the next new
95 value defined by the src_buffer. */
96 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
97 timer_period = (crm_clocks_freq_struct.sclk_freq / 17570 ) - 1;
98 /* compute c1dt value to generate a duty cycle at 50% */
99 src_buffer[0] = (uint16_t) (((uint32_t) 5 * (timer_period - 1)) / 10);
100 /* compute c1dt value to generate a duty cycle at 37.5% */
101 src_buffer[1] = (uint16_t) (((uint32_t) 375 * (timer_period - 1)) / 1000);
102 /* compute c1dt value to generate a duty cycle at 25% */
103 src_buffer[2] = (uint16_t) (((uint32_t) 25 * (timer_period - 1)) / 100);
104
105 tmr_base_init(TMR1, timer_period, 0);
106 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
107
108 /* channel 3 configuration in output mode */
109 tmr_output_default_para_init(&tmr_output_struct);
110 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
111 tmr_output_struct.oc_output_state = TRUE;
112 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
113 tmr_output_struct.oc_idle_state = TRUE;
114 tmr_output_struct.occ_output_state = TRUE;
115 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
116 tmr_output_struct.occ_idle_state = FALSE;
117 /* channel 3 */
118 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
119 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, src_buffer[0]);
120
121 /* enable tmr1 overflow dma request */
122 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
123
124 /* dma config for tmr1 overflow dma request */
125 /* dma1 channel5 configuration */
126 dma_reset(DMA1_CHANNEL5);
127 dma_init_struct.buffer_size = 3;
128 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
129 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
130 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
131 dma_init_struct.memory_inc_enable = TRUE;
132 dma_init_struct.peripheral_base_addr = (uint32_t)0x40012C3C;
133 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
134 dma_init_struct.peripheral_inc_enable = FALSE;
135 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
136 dma_init_struct.loop_mode_enable = TRUE;
137 dma_init(DMA1_CHANNEL5, &dma_init_struct);
138
139 dma_channel_enable(DMA1_CHANNEL5, TRUE);
140
141 /* output enable */
142 tmr_output_enable(TMR1, TRUE);
143 /* enable tmr1 */
144 tmr_counter_enable(TMR1, TRUE);
145
146 while(1)
147 {
148 }
149}
150
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:37
src_buffer
uint16_t src_buffer[3]
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:42
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:49
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:482
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1286
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:267
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:178
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • dma_burst
  • inc
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • dma_burst
  • inc
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • dma_burst
  • inc
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • dma_burst
  • src
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • dma_burst
  • src
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • dma_burst
  • src
project/at_start_f413/examples/tmr/dma_burst/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 tmr_output_config_type tmr_output_struct;
38 dma_init_type dma_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41uint16_t timer_period = 0;
42uint16_t src_buffer[3] = {0x0FFF, 0x0000, 0x0555};
43
49int main(void)
50{
51 system_clock_config();
52
53 at32_board_init();
54
55 /* get system clock */
56 crm_clocks_freq_get(&crm_clocks_freq_struct);
57
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62
63 /* enable tmr1/gpioa/gpiob/dma clock */
64 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
68
69 /* timer1 output pin Configuration */
70 gpio_init_struct.gpio_pins = GPIO_PINS_8;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
74 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
75 gpio_init(GPIOA, &gpio_init_struct);
76
77 /* tmr1 configuration: generate 1 pwm signal using the dma burst mode:
78 the tmr1clk frequency is set to system_core_clock (hz), to get tmr1 counter
79 clock at 24 mhz the prescaler is computed as following:
80 - div = (tim1clk / tmr1 counter clock) - 1
81 the tmr1 period is 5.86 khz: tmr1 frequency = tmr1 counter clock/(pr + 1)
82 = 24 mhz / 4096 = 5.86khz
83 tmr1 channel1 duty cycle = (tim1_c1dt/ tmr1_pr)* 100 = 33.33% */
84
85 tmr_base_init(TMR1, 0xFFFF, (crm_clocks_freq_struct.sclk_freq/24000000)-1);
86 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
87
88 /* channel 3 configuration in output mode */
89 tmr_output_default_para_init(&tmr_output_struct);
90 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
91 tmr_output_struct.oc_output_state = TRUE;
92 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
93 tmr_output_struct.oc_idle_state = TRUE;
94 tmr_output_struct.occ_output_state = FALSE;
95 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
96 tmr_output_struct.occ_idle_state = FALSE;
97 /* channel 3 */
98 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
99 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 0xFFF);
100
101 /* enable tmr1 overflow dma request */
102 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
103 tmr_dma_control_config(TMR1, TMR_DMA_TRANSFER_3BYTES, TMR_PR_ADDRESS);
104
105 /* dma config for tmr1 overflow dma request */
106 /* dma1 channel5 configuration */
107 dma_reset(DMA1_CHANNEL5);
108 dma_init_struct.buffer_size = 3;
109 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
110 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
111 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
112 dma_init_struct.memory_inc_enable = TRUE;
113 dma_init_struct.peripheral_base_addr = (uint32_t)0x40012C4C;
114 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
115 dma_init_struct.peripheral_inc_enable = FALSE;
116 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
117 dma_init_struct.loop_mode_enable = TRUE;
118 dma_init(DMA1_CHANNEL5, &dma_init_struct);
119
120 dma_channel_enable(DMA1_CHANNEL5, TRUE);
121
122 /* output enable */
123 tmr_output_enable(TMR1, TRUE);
124 /* enable tmr1 */
125 tmr_counter_enable(TMR1, TRUE);
126
127 while(1)
128 {
129 }
130}
131
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:37
src_buffer
uint16_t src_buffer[3]
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:42
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:49
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:482
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f413_tmr.c:1706
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1286
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:267
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_PR_ADDRESS
@ TMR_PR_ADDRESS
Definition: at32f413_tmr.h:362
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:178
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR_DMA_TRANSFER_3BYTES
@ TMR_DMA_TRANSFER_3BYTES
Definition: at32f413_tmr.h:328
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • encoder_tmr2
  • inc
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • encoder_tmr2
  • inc
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • encoder_tmr2
  • inc
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • encoder_tmr2
  • src
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • encoder_tmr2
  • src
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • encoder_tmr2
  • src
project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 crm_clocks_freq_type crm_clocks_freq_struct = {0};
38
39void delay(uint32_t time);
40uint32_t counter;
41
47int main(void)
48{
49 system_clock_config();
50
51 at32_board_init();
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 /* turn led2/led3/led4 on */
57 at32_led_on(LED2);
58 at32_led_on(LED3);
59 at32_led_on(LED4);
60
61 /* enable tmr2/gpioa clock */
62 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
63 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
64
65 /* timer1 output pin Configuration */
66 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
67 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
68 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
69 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
70 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
71 gpio_init(GPIOA, &gpio_init_struct);
72
73 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
74 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
75 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
76 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 /* tmr2 encoder mode configuration
81 tmr2 c1ifp1 ,c2ifp2 as encoder input pin, tmr2 counter
82 changed each signal edge. */
83
84 /* enable tmr2 32bit function */
85 tmr_32_bit_function_enable(TMR2, TRUE);
86
87 tmr_base_init(TMR2, 0xFFFFFFFF, 0);
88 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
89
90 /* config encoder mode */
91 tmr_encoder_mode_config(TMR2, TMR_ENCODER_MODE_C, TMR_INPUT_RISING_EDGE, TMR_INPUT_RISING_EDGE);
92
93 /* enable tmr2 */
94 tmr_counter_enable(TMR2, TRUE);
95
96 while(1)
97 {
98 /* generate encoder signal */
99 gpio_bits_set(GPIOA, GPIO_PINS_2);
100 delay(150);
101 gpio_bits_set(GPIOA, GPIO_PINS_3);
102 delay(150);
103 gpio_bits_reset(GPIOA, GPIO_PINS_2);
104 delay(150);
105 gpio_bits_reset(GPIOA, GPIO_PINS_3);
106 delay(150);
107
108 /* get current counter value */
109 counter = tmr_counter_value_get(TMR2);
110 }
111}
112
118void delay(uint32_t time)
119{
120 uint32_t i;
121
122 for(i = 0; i < time; i++);
123}
124
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:36
delay
void delay(uint32_t time)
delay function
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:118
counter
uint32_t counter
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:47
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:37
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:268
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:752
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f413_tmr.c:1604
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_ENCODER_MODE_C
@ TMR_ENCODER_MODE_C
Definition: at32f413_tmr.h:163
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • external_clock
  • inc
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • external_clock
  • inc
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • external_clock
  • inc
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • external_clock
  • src
project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • external_clock
  • src
project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • external_clock
  • src
project/at_start_f413/examples/tmr/external_clock/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 crm_clocks_freq_type crm_clocks_freq_struct = {0};
38 tmr_output_config_type tmr_output_struct;
39 tmr_input_config_type tmr_input_config_struct;
40
46int main(void)
47{
48 system_clock_config();
49
50 at32_board_init();
51
52 /* get system clock */
53 crm_clocks_freq_get(&crm_clocks_freq_struct);
54
55 /* turn led2/led3/led4 on */
56 at32_led_on(LED2);
57 at32_led_on(LED3);
58 at32_led_on(LED4);
59
60 /* enable tmr2/tmr3/gpioa/gpiob clock */
61 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
63 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
65
66 /* timer2 and timer3 output pin Configuration */
67 gpio_init_struct.gpio_pins = GPIO_PINS_0;
68 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init(GPIOA, &gpio_init_struct);
73 gpio_init(GPIOB, &gpio_init_struct);
74
75 gpio_init_struct.gpio_pins = GPIO_PINS_7;
76 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 /* use tmr2 generate clock to drive tmr3
83 tmr2 pwm frequency = 192000000(systemclock)/192(period+1)/1000(div+1) = 1 khz
84 tmr3 pwm frequency = 1000(tmr2 pwm frequency)/10(period+1)/1(div+1) = 100 hz */
85
86 /* tmr2 and tmr3 counter mode configuration */
87 tmr_base_init(TMR2, 191, 999);
88 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
89
90 tmr_base_init(TMR3, 9, 0);
91 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
92
93 /* tmr2 and tmr3 output mode configuration */
94 tmr_output_default_para_init(&tmr_output_struct);
95 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
96 tmr_output_struct.oc_output_state = TRUE;
97 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
98 tmr_output_struct.oc_idle_state = TRUE;
99 tmr_output_struct.occ_output_state = FALSE;
100 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
101 tmr_output_struct.occ_idle_state = FALSE;
102 /* tmr2 channel 1 */
103 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
104 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, 96);
105 /* tmr3 channel 3 */
106 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
107 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, 5);
108
109 /* configure tmr3 channel2 to get clock signal */
110 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
111 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
112 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
113 tmr_input_channel_init(TMR3, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
114
115 /* select the tmr3 input trigger: C2IF2 */
116 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_C2DF2);
117
118 /* select the slave mode: external mode a */
119 tmr_sub_mode_select(TMR3, TMR_SUB_EXTERNAL_CLOCK_MODE_A);
120
121 /* enable tmr2 */
122 tmr_counter_enable(TMR2, TRUE);
123
124 /* enable tmr3 */
125 tmr_counter_enable(TMR3, TRUE);
126
127 while(1)
128 {
129 }
130}
131
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:36
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:46
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:37
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:137
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f413_tmr.h:153
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 crm_clocks_freq_type crm_clocks_freq_struct = {0};
38 tmr_output_config_type tmr_output_struct;
39 tmr_input_config_type tmr_input_config_struct;
40
46int main(void)
47{
48 system_clock_config();
49
50 at32_board_init();
51
52 /* get system clock */
53 crm_clocks_freq_get(&crm_clocks_freq_struct);
54
55 /* turn led2/led3/led4 on */
56 at32_led_on(LED2);
57 at32_led_on(LED3);
58 at32_led_on(LED4);
59
60 /* enable tmr2/tmr3/gpioa/gpiob clock */
61 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* tmr2 channel1 ,channel2 and channel3 configuration */
65 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2;
66 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
67 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
68 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
69 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
70 gpio_init(GPIOA, &gpio_init_struct);
71
72 /* hall signal (pa3 ,pa6 ,pa7) and trigger flag signal(pa8) configuration */
73 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8;
74 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
75 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
76 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 /* tmr2 xor mode configuration
81 tmr2 channel1 ,channel2 and channel3 as hall signal input channel, trigger
82 generated each signal edge. */
83
84 /* tmr2 and tmr3 counter mode configuration */
85 tmr_32_bit_function_enable(TMR2, TRUE);
86
87 tmr_base_init(TMR2, 0xFFFFFFFF, 0);
88 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
89
90 /* config ti1 trc as input source */
91 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_1;
92 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_STI;
93 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
94 tmr_input_channel_init(TMR2, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
95
96 /* xor funtion enable */
97 tmr_channel1_input_select(TMR2, TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR);
98
99 /* select the tmr2 input trigger: C1INC */
100 tmr_trigger_input_select(TMR2, TMR_SUB_INPUT_SEL_C1INC);
101
102 /* select the slave mode: reset mode */
103 tmr_sub_mode_select(TMR2, TMR_SUB_RESET_MODE);
104
105 tmr_interrupt_enable(TMR2, TMR_TRIGGER_INT, TRUE);
106
107 /* tmr2 trigger interrupt nvic init */
108 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
109 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
110
111 /* enable tmr2 */
112 tmr_counter_enable(TMR2, TRUE);
113
114 while(1)
115 {
116 /* generate hall signal */
117 gpio_bits_set(GPIOA, GPIO_PINS_3);
118 delay_us(10);
119 gpio_bits_set(GPIOA, GPIO_PINS_6);
120 delay_us(10);
121 gpio_bits_set(GPIOA, GPIO_PINS_7);
122 delay_us(10);
123 gpio_bits_reset(GPIOA, GPIO_PINS_3);
124 delay_us(10);
125 gpio_bits_reset(GPIOA, GPIO_PINS_6);
126 delay_us(10);
127 gpio_bits_reset(GPIOA, GPIO_PINS_7);
128 delay_us(10);
129 }
130}
131
137void TMR2_GLOBAL_IRQHandler(void)
138{
139 if(tmr_flag_get(TMR2, TMR_TRIGGER_FLAG) != RESET)
140 {
141 GPIOA->odt ^= GPIO_PINS_8;
142 tmr_flag_clear(TMR2, TMR_TRIGGER_FLAG);
143 }
144}
145
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:36
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:38
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles TMR2 trigger exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:137
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:46
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:37
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:199
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input
Definition: at32f413_tmr.c:1092
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:752
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
@ TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Definition: at32f413_tmr.h:229
TMR_CC_CHANNEL_MAPPED_STI
@ TMR_CC_CHANNEL_MAPPED_STI
Definition: at32f413_tmr.h:239
TMR_SUB_INPUT_SEL_C1INC
@ TMR_SUB_INPUT_SEL_C1INC
Definition: at32f413_tmr.h:135
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:150
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR_TRIGGER_FLAG
#define TMR_TRIGGER_FLAG
Definition: at32f413_tmr.h:56
TMR_TRIGGER_INT
#define TMR_TRIGGER_INT
Definition: at32f413_tmr.h:78
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • hang_mode
  • inc
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • hang_mode
  • inc
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • hang_mode
  • inc
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • hang_mode
  • src
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • hang_mode
  • src
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • hang_mode
  • src
project/at_start_f413/examples/tmr/hang_mode/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 crm_clocks_freq_type crm_clocks_freq_struct = {0};
38 tmr_output_config_type tmr_output_struct;
39 tmr_input_config_type tmr_input_config_struct;
40
46int main(void)
47{
48 system_clock_config();
49
50 at32_board_init();
51
52 /* get system clock */
53 crm_clocks_freq_get(&crm_clocks_freq_struct);
54
55 /* turn led2/led3/led4 on */
56 at32_led_on(LED2);
57 at32_led_on(LED3);
58 at32_led_on(LED4);
59
60 /* enable tmr1/gpioa clock */
61 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* timer1 output pin configuration */
65 gpio_init_struct.gpio_pins = GPIO_PINS_8;
66 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
67 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
68 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
69 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
70 gpio_init(GPIOA, &gpio_init_struct);
71
72 gpio_init_struct.gpio_pins = GPIO_PINS_9;
73 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOA, &gpio_init_struct);
78
79 /* hang mode test
80 1/tmr1 is configured as master timer:
81 - toggle mode is used
82
83 2/tmr1 is configured as slave timer for an external trigger connected
84 to tmr1 ti2 pin (tmr1 ch2 configured as input pin):
85 - the tmr1 ti2fp2 is used as trigger input
86 - rising edge is used to start and stop the tmr1: hang mode.
87
88 the tmr1 are running at:
89 tmrx frequency = tmrx clock counter/ 2*(timx_period + 1) = 500 khz.
90 */
91
92 tmr_base_init(TMR1, 191, 0);
93 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
94
95 /* tmr1 output mode configuration */
96 tmr_output_default_para_init(&tmr_output_struct);
97 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
98 tmr_output_struct.oc_output_state = TRUE;
99 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
100 tmr_output_struct.oc_idle_state = TRUE;
101 tmr_output_struct.occ_output_state = FALSE;
102 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
103 tmr_output_struct.occ_idle_state = FALSE;
104 /* tmr1 channel 1 */
105 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
106 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 50);
107
108 /* configure tmr1 channel2 to get hang signal */
109 tmr_input_default_para_init(&tmr_input_config_struct);
110 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
111 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
112 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
113 tmr_input_channel_init(TMR1, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
114
115 /* select the tmr1 input trigger: c2df2 */
116 tmr_trigger_input_select(TMR1, TMR_SUB_INPUT_SEL_C2DF2);
117
118 /* select the slave mode: hang mode */
119 tmr_sub_mode_select(TMR1, TMR_SUB_HANG_MODE);
120
121 /* output enable */
122 tmr_output_enable(TMR1, TRUE);
123
124 /* enable tmr1 */
125 tmr_counter_enable(TMR1, TRUE);
126
127 while(1)
128 {
129 }
130}
131
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:36
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:46
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:37
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:142
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:174
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:137
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:151
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • input_capture
  • inc
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • input_capture
  • inc
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • input_capture
  • inc
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • input_capture
  • src
project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • input_capture
  • src
project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • input_capture
  • src
project/at_start_f413/examples/tmr/input_capture/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 crm_clocks_freq_type crm_clocks_freq_struct = {0};
38 tmr_input_config_type tmr_input_config_struct;
39void uart_init(uint32_t baudrate);
40__IO uint32_t tmr3freq = 0;
41__IO uint32_t sys_counter = 0;
42__IO uint16_t capturenumber = 0;
43__IO uint16_t ch3readvalue1 = 0, ch3readvalue2 = 0;
44__IO uint32_t capture = 0;
45
51void TMR3_GLOBAL_IRQHandler(void)
52{
53 if(tmr_flag_get(TMR3, TMR_C2_FLAG) != RESET)
54 {
55 tmr_flag_clear(TMR3, TMR_C2_FLAG);
56 if(capturenumber == 0)
57 {
58 /* get the Input Capture value */
59 ch3readvalue1 = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
60 capturenumber = 1;
61 }
62 else if(capturenumber == 1)
63 {
64 /* get the Input Capture value */
65 ch3readvalue2 = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
66
67 /* capture computation */
68 if(ch3readvalue2 > ch3readvalue1)
69 {
70 capture = (ch3readvalue2 - ch3readvalue1);
71 }
72 else
73 {
74 capture = ((0xFFFF - ch3readvalue1) + ch3readvalue2);
75 }
76
77 /* frequency computation */
78 tmr3freq = (uint32_t) crm_clocks_freq_struct.sclk_freq / capture;
79 capturenumber = 0;
80 }
81 }
82}
83
89int main(void)
90{
91 system_clock_config();
92
93 at32_board_init();
94
95 uart_print_init(115200);
96
97 /* get system clock */
98 crm_clocks_freq_get(&crm_clocks_freq_struct);
99
100 /* turn led2/led3/led4 on */
101 at32_led_on(LED2);
102 at32_led_on(LED3);
103 at32_led_on(LED4);
104
105 /* enable tmr3/gpioa clock */
106 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
107 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
108
109 /* timer3 input pin Configuration */
110 gpio_init_struct.gpio_pins = GPIO_PINS_7;
111 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
112 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
113 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
114 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
115 gpio_init(GPIOA, &gpio_init_struct);
116
117 /* tmr3 configuration: input capture mode
118 the external signal is connected to tmr3 ch2 pin (pa.07)
119 the rising edge is used as active edge,
120 the tmr3 c2dt is used to compute the frequency value */
121
122 /* tmr3 counter mode configuration */
123 tmr_base_init(TMR3, 0xFFFF, 0);
124 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
125
126 /* configure tmr3 channel2 to get clock signal */
127 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
128 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
129 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
130 tmr_input_channel_init(TMR3, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
131
132 tmr_interrupt_enable(TMR3, TMR_C2_INT, TRUE);
133
134 /* tmr2 trigger interrupt nvic init */
135 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
136 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
137
138 /* enable tmr3 */
139 tmr_counter_enable(TMR3, TRUE);
140
141 while(1)
142 {
143 delay_ms(100);
144 printf("The external signal frequece is : %d\r\n",tmr3freq);
145 tmr3freq = 0;
146 }
147}
148
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:36
ch3readvalue2
__IO uint16_t ch3readvalue2
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:43
ch3readvalue1
__IO uint16_t ch3readvalue1
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:43
tmr3freq
__IO uint32_t tmr3freq
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:40
capturenumber
__IO uint16_t capturenumber
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:42
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 trigger exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:89
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:38
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:37
sys_counter
__IO uint32_t sys_counter
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:41
capture
__IO uint32_t capture
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:545
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:52
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:74
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_high
  • inc
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_high
  • inc
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_high
  • inc
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_high
  • src
project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_high
  • src
project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
138void TMR2_GLOBAL_IRQHandler(void)
139{
140 if(tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
141 {
142 /* clear tmr2 channel1 interrupt pending bit */
143 tmr_flag_clear(TMR2, TMR_C1_FLAG);
144
145 /* pc.06 turnoff after 1000 ms */
146 gpio_bits_reset(GPIOC, GPIO_PINS_6);
147 }
148 else if(tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
149 {
150 /* clear tmr2 channel2 interrupt pending bit */
151 tmr_flag_clear(TMR2, TMR_C2_FLAG);
152
153 /* pc.07 turnoff after 500 ms */
154 gpio_bits_reset(GPIOC, GPIO_PINS_7);
155 }
156 else if(tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
157 {
158 /* clear tmr2 channel3 interrupt pending bit */
159 tmr_flag_clear(TMR2, TMR_C3_FLAG);
160
161 /* pc.08 turnoff after 250 ms */
162 gpio_bits_reset(GPIOC, GPIO_PINS_8);
163 }
164 else
165 {
166 /* clear tmr2 channel4 interrupt pending bit */
167 tmr_flag_clear(TMR2, TMR_C4_FLAG);
168
169 /* pc.09 turnoff after 125 ms */
170 gpio_bits_reset(GPIOC, GPIO_PINS_9);
171 }
172}
173
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:102
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles tmr2 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:138
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:111
RESET
@ RESET
Definition: at32f413.h:291
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:51
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:52
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:53
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:54
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_high
  • src
project/at_start_f413/examples/tmr/oc_high/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37 crm_clocks_freq_type crm_clocks_freq_struct = {0};
38uint16_t ch1_val = 1000;
39uint16_t ch2_val = 500;
40uint16_t ch3_val = 250;
41uint16_t ch4_val = 125;
42uint16_t div_value = 0;
43
44void gpio_configuration(void);
45
51void gpio_configuration(void)
52{
53 gpio_init_type gpio_init_struct;
54
55 gpio_default_para_init(&gpio_init_struct);
56
57 /* gpioc configuration: pin6, 7, 8 and 9 as output push-pull */
58 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63
64 gpio_init(GPIOC, &gpio_init_struct);
65}
66
72int main(void)
73{
74 /* config nvic priority group */
75 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
76
77 system_clock_config();
78
79 at32_board_init();
80
81 /* get system clock */
82 crm_clocks_freq_get(&crm_clocks_freq_struct);
83
84 crm_apb1_div_set(CRM_APB1_DIV_8);
85 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
86 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
87
88 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
89
90 gpio_configuration();
91
92 /* compute the div value */
93 div_value = (uint16_t)(crm_clocks_freq_struct.sclk_freq / 4000) - 1;
94
95 /* tmr2 time base configuration */
96 tmr_base_init(TMR2, 0xFFFF, div_value);
97 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
98 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
99
100 tmr_output_default_para_init(&tmr_oc_init_structure);
101 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_HIGH;
102 tmr_oc_init_structure.oc_idle_state = FALSE;
103 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
104 tmr_oc_init_structure.oc_output_state = TRUE;
105 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
106 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
107
108 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
109 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
110
111 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
112 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
113
114 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
115 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
116
117 tmr_period_buffer_enable(TMR2, TRUE);
118
119 /* tmr2 int enable */
120 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
121
122 /* set pc.06, pc.07, pc.08 and pc.09 pins */
123 gpio_bits_set(GPIOC, GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9);
124
125 /* tmr2 enable counter */
126 tmr_counter_enable(TMR2, TRUE);
127
128 while(1)
129 {
130 }
131}
132
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:41
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:40
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:72
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:39
gpio_configuration
void gpio_configuration(void)
configure the gpioc pins.
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:51
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:36
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:37
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_APB1_DIV_8
@ CRM_APB1_DIV_8
Definition: at32f413_crm.h:323
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:199
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:586
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_HIGH
@ TMR_OUTPUT_CONTROL_HIGH
Definition: at32f413_tmr.h:172
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:75
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:76
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:73
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:74
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_low
  • inc
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_low
  • inc
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_low
  • inc
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_low
  • src
project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_low
  • src
project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
138void TMR2_GLOBAL_IRQHandler(void)
139{
140 if(tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
141 {
142 /* clear tmr2 channel1 interrupt pending bit */
143 tmr_flag_clear(TMR2, TMR_C1_FLAG);
144
145 /* pc.06 turnoff after 1000 ms */
146 gpio_bits_reset(GPIOC, GPIO_PINS_6);
147 }
148 else if(tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
149 {
150 /* clear tmr2 channel2 interrupt pending bit */
151 tmr_flag_clear(TMR2, TMR_C2_FLAG);
152
153 /* pc.07 turnoff after 500 ms */
154 gpio_bits_reset(GPIOC, GPIO_PINS_7);
155 }
156 else if(tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
157 {
158 /* clear tmr2 channel3 interrupt pending bit */
159 tmr_flag_clear(TMR2, TMR_C3_FLAG);
160
161 /* pc.08 turnoff after 250 ms */
162 gpio_bits_reset(GPIOC, GPIO_PINS_8);
163 }
164 else
165 {
166 /* clear tmr2 channel4 interrupt pending bit */
167 tmr_flag_clear(TMR2, TMR_C4_FLAG);
168
169 /* pc.09 turnoff after 125 ms */
170 gpio_bits_reset(GPIOC, GPIO_PINS_9);
171 }
172}
173
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:102
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles tmr2 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:138
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:111
RESET
@ RESET
Definition: at32f413.h:291
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:51
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:52
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:53
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:54
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_low
  • src
project/at_start_f413/examples/tmr/oc_low/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37uint16_t ch1_val = 1000;
38uint16_t ch2_val = 500;
39uint16_t ch3_val = 250;
40uint16_t ch4_val = 125;
41uint16_t div_value = 0;
42
43void gpio_configuration(void);
44
50void gpio_configuration(void)
51{
52 gpio_init_type gpio_init_struct;
53
54 /* gpioc configuration: pin6, 7, 8 and 9 as output push-pull */
55 gpio_default_para_init(&gpio_init_struct);
56 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61
62 gpio_init(GPIOC, &gpio_init_struct);
63}
64
70int main(void)
71{
72 /* config nvic priority group */
73 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
74
75 system_clock_config();
76
77 at32_board_init();
78
79 crm_apb1_div_set(CRM_APB1_DIV_8);
80 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
82
83 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
84
85 gpio_configuration();
86
87 /* compute the div value */
88 div_value = (uint16_t)(system_core_clock / 4000) - 1;
89
90 /* tmr2 time base configuration */
91 tmr_base_init(TMR2, 65535, div_value);
92 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
93 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
94
95 tmr_output_default_para_init(&tmr_oc_init_structure);
96 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_LOW;
97 tmr_oc_init_structure.oc_idle_state = FALSE;
98 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
99 tmr_oc_init_structure.oc_output_state = TRUE;
100 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
101 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
102
103 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
104 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
105
106 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
107 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
108
109 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
110 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
111
112 tmr_period_buffer_enable(TMR2, TRUE);
113
114 /* tmr2 int enable */
115 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
116
117 /* set pc.06, pc.07, pc.08 and pc.09 pins */
118 gpio_bits_set(GPIOC, GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9);
119
120 /* tmr2 enable counter */
121 tmr_counter_enable(TMR2, TRUE);
122
123 while(1)
124 {
125 }
126}
127
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:40
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:39
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:70
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:38
gpio_configuration
void gpio_configuration(void)
configure the gpioc pins.
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:50
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:36
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:41
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_APB1_DIV_8
@ CRM_APB1_DIV_8
Definition: at32f413_crm.h:323
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:199
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:586
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_LOW
@ TMR_OUTPUT_CONTROL_LOW
Definition: at32f413_tmr.h:173
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:75
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:76
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:73
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:74
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern __IO uint16_t ch1_val;
29extern __IO uint16_t ch2_val;
30extern __IO uint16_t ch3_val;
31extern __IO uint16_t ch4_val;
32
41uint32_t capture = 0;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void TMR3_GLOBAL_IRQHandler(void)
146{
147 /* TMR3_CH1 toggling with frequency = 183.1 Hz */
148 if(tmr_flag_get(TMR3, TMR_C1_FLAG) != RESET)
149 {
150 tmr_flag_clear(TMR3, TMR_C1_FLAG );
151 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_1);
152 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, capture + ch1_val);
153 }
154
155 /* TMR3_CH2 toggling with frequency = 366.2 Hz */
156 if(tmr_flag_get(TMR3, TMR_C2_FLAG) != RESET)
157 {
158 tmr_flag_clear(TMR3, TMR_C2_FLAG);
159 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
160 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, capture + ch2_val);
161 }
162
163 /* TMR3_CH3 toggling with frequency = 732.4 Hz */
164 if(tmr_flag_get(TMR3, TMR_C3_FLAG) != RESET)
165 {
166 tmr_flag_clear(TMR3, TMR_C3_FLAG);
167 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_3);
168 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, capture + ch3_val);
169 }
170
171 /* TMR3_CH4 toggling with frequency = 1464.8 Hz */
172 if(tmr_flag_get(TMR3, TMR_C4_FLAG) != RESET)
173 {
174 tmr_flag_clear(TMR3, TMR_C4_FLAG);
175 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_4);
176 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, capture + ch4_val);
177 }
178}
179
ch4_val
__IO uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:41
ch3_val
__IO uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:40
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:109
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:48
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:136
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:118
capture
uint32_t capture
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:41
RESET
@ RESET
Definition: at32f413.h:291
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:545
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:51
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:52
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:53
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:54
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37__IO uint16_t ch1_val = 32768;
38__IO uint16_t ch2_val = 16384;
39__IO uint16_t ch3_val = 8192;
40__IO uint16_t ch4_val = 4096;
41uint16_t div_value = 0;
42
43void crm_configuration(void);
44void gpio_configuration(void);
45void nvic_configuration(void);
46
52void gpio_configuration(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* gpioa configuration:tmr3 channel1, 2, 3 and 4 as alternate function push-pull */
57 gpio_default_para_init(&gpio_init_struct);
58 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63
64 gpio_init(GPIOA, &gpio_init_struct);
65
66 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
67 gpio_init(GPIOB, &gpio_init_struct);
68
69}
70
76void crm_configuration(void)
77{
78 /* tmr3 clock enable */
79 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
80
81 /* gpioa clock enable */
82 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
83 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
84}
85
91int main(void)
92{
93 system_clock_config();
94
95 /* peripheral clocks configuration */
96 crm_configuration();
97
98 /* nvic configuration */
99 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
100 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
101
102 /* gpio configuration */
103 gpio_configuration();
104
105 /* tmr3 configuration: output compare toggle mode:
106 tmr3clk = system_core_clock,
107 the objective is to get tmr3 counter clock at 24 mhz:
108 - div = (tmr3clk / tmr3 counter clock) - 1
109 cc1 update rate = tmr3 counter clock / ch1_val / 2 = 366.2 hz
110 cc2 update rate = tmr3 counter clock / ch2_val / 2 = 732.4 hz
111 cc3 update rate = tmr3 counter clock / ch3_val / 2 = 1464.8 hz
112 cc4 update rate = tmr3 counter clock / ch4_val / 2 = 2929.6 hz */
113
114 /* compute the div value */
115 div_value = (uint16_t)(system_core_clock / 24000000) - 1;
116
117 /* tmre base configuration */
118 tmr_base_init(TMR3, 65535, div_value);
119 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
120 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
121
122 /* output compare toggle mode configuration: channel1 */
123 tmr_output_default_para_init(&tmr_oc_init_structure);
124 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
125 tmr_oc_init_structure.oc_idle_state = FALSE;
126 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
127 tmr_oc_init_structure.oc_output_state = TRUE;
128 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
129 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, ch1_val);
130
131 /* output compare toggle mode configuration: channel2 */
132 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
133 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, ch2_val);
134
135 /* output compare toggle mode configuration: channel3 */
136 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
137 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, ch3_val);
138
139 /* output compare toggle mode configuration: channel4 */
140 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
141 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, ch4_val);
142
143 /* tmr enable counter */
144 tmr_counter_enable(TMR3, TRUE);
145
146 /* tmr it enable */
147 tmr_interrupt_enable(TMR3, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
148
149 while(1)
150 {
151 }
152}
153
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:91
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:52
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:36
ch3_val
__IO uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:39
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:76
ch4_val
__IO uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:40
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:41
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:38
nvic_configuration
void nvic_configuration(void)
configures the nested vectored interrupt controller.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:46
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:174
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:75
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:76
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:73
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:74
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern __IO uint16_t ch1_val;
29extern __IO uint16_t ch2_val;
30
39uint16_t capture = 0;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void TMR1_BRK_TMR9_IRQHandler(void)
144{
145 /* TMR9_CH1 toggling with frequency = 366.2 Hz */
146 if(tmr_flag_get(TMR9, TMR_C1_FLAG) != RESET)
147 {
148 tmr_flag_clear(TMR9, TMR_C1_FLAG );
149 capture = tmr_channel_value_get(TMR9, TMR_SELECT_CHANNEL_1);
150 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_1, capture + ch1_val);
151 }
152
153 /* TMR9_CH2 toggling with frequency = 732.4 Hz */
154 if(tmr_flag_get(TMR9, TMR_C2_FLAG) != RESET)
155 {
156 tmr_flag_clear(TMR9, TMR_C2_FLAG);
157 capture = tmr_channel_value_get(TMR9, TMR_SELECT_CHANNEL_2);
158 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_2, capture + ch2_val);
159 }
160}
161
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:134
TMR1_BRK_TMR9_IRQHandler
void TMR1_BRK_TMR9_IRQHandler(void)
this function handles TMR9 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:143
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:116
capture
uint16_t capture
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:39
RESET
@ RESET
Definition: at32f413.h:291
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:545
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:51
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:52
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37__IO uint16_t ch1_val = 32768;
38__IO uint16_t ch2_val = 16384;
39uint16_t div_value = 0;
40
41void crm_configuration(void);
42void gpio_configuration(void);
43void nvic_configuration(void);
44
50void gpio_configuration(void)
51{
52 gpio_init_type gpio_init_struct;
53
54 /* gpioa configuration:tmr9 channel1 and 2 as alternate function push-pull */
55 gpio_default_para_init(&gpio_init_struct);
56 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61
62 gpio_init(GPIOA, &gpio_init_struct);
63}
64
70void crm_configuration(void)
71{
72 /* tmr9 clock enable */
73 crm_periph_clock_enable(CRM_TMR9_PERIPH_CLOCK, TRUE);
74
75 /* gpioa clock enable */
76 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
77}
78
84int main(void)
85{
86 system_clock_config();
87
88 /* peripheral clocks configuration */
89 crm_configuration();
90
91 /* nvic configuration */
92 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
93 nvic_irq_enable(TMR1_BRK_TMR9_IRQn, 0, 0);
94
95 /* gpio configuration */
96 gpio_configuration();
97
98 /* tmr9 configuration: output compare toggle mode:
99 tmr9clk = system_core_clock,
100 the objective is to get tmr9 counter clock at 24 mhz:
101 - div_value = (tmr9clk / tmr9 counter clock) - 1
102 cc1 update rate = tmr9 counter clock / ch1val / 2 = 366.2 hz
103 cc2 update rate = tmr9 counter clock / ch2val / 2 = 732.4 hz */
104
105 /* compute the div value */
106 div_value = (uint16_t) (system_core_clock / 24000000) - 1;
107
108 /* tmr base configuration */
109 tmr_base_init(TMR9, 65535, div_value);
110 tmr_cnt_dir_set(TMR9, TMR_COUNT_UP);
111 tmr_clock_source_div_set(TMR9, TMR_CLOCK_DIV1);
112
113 /* output compare toggle mode configuration: channel1 */
114 tmr_output_default_para_init(&tmr_oc_init_structure);
115 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
116 tmr_oc_init_structure.oc_idle_state = FALSE;
117 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
118 tmr_oc_init_structure.oc_output_state = TRUE;
119 tmr_output_channel_config(TMR9, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
120 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_1, ch1_val);
121
122 /* output toggle mode configuration: channel2 */
123 tmr_output_channel_config(TMR9, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
124 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_2, ch2_val);
125
126 /* tmr enable counter */
127 tmr_counter_enable(TMR9, TRUE);
128
129 /* tmr interrupt enable */
130 tmr_interrupt_enable(TMR9, TMR_C1_INT | TMR_C2_INT, TRUE);
131
132 while(1)
133 {
134 }
135}
136
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:84
gpio_configuration
void gpio_configuration(void)
configure the tmr9 pins.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:50
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:70
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:39
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:38
nvic_configuration
void nvic_configuration(void)
configures the nested vectored interrupt controller.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:46
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR9_PERIPH_CLOCK
@ CRM_TMR9_PERIPH_CLOCK
Definition: at32f413_crm.h:119
TMR1_BRK_TMR9_IRQn
@ TMR1_BRK_TMR9_IRQn
Definition: at32f413.h:195
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:174
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:73
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:74
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • one_cycle
  • inc
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • one_cycle
  • inc
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • one_cycle
  • inc
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • one_cycle
  • src
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • one_cycle
  • src
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • one_cycle
  • src
project/at_start_f413/examples/tmr/one_cycle/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37 tmr_input_config_type tmr_ic_init_structure;
38uint16_t div_value = 0;
39
40void crm_configuration(void);
41void gpio_configuration(void);
42
48void gpio_configuration(void)
49{
50 gpio_init_type gpio_init_struct;
51
52 gpio_default_para_init(&gpio_init_struct);
53
54 /* tmr4_ch2 pin (pb.07) configuration */
55 gpio_init_struct.gpio_pins = GPIO_PINS_7;
56 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init(GPIOB, &gpio_init_struct);
61
62 /* tmr4_ch1 pin (pb.06) configuration */
63 gpio_init_struct.gpio_pins = GPIO_PINS_6;
64 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
65 gpio_init(GPIOB, &gpio_init_struct);
66}
67
73void crm_configuration(void)
74{
75 /* tmr3 clock enable */
76 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
77
78 /* gpioa clock enable */
79 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
80}
81
87int main(void)
88{
89 system_clock_config();
90
91 /* peripheral clocks configuration */
92 crm_configuration();
93
94 /* gpio configuration */
95 gpio_configuration();
96
97 /* compute the div value */
98 div_value = (uint16_t)(system_core_clock / 24000000) - 1;
99
100 /* tmr base configuration */
101 tmr_base_init(TMR4, 65535, div_value);
102 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
103 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
104
105 /* output compare toggle mode configuration: channel1 */
106 tmr_output_default_para_init(&tmr_oc_init_structure);
107 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
108 tmr_oc_init_structure.oc_idle_state = FALSE;
109 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
110 tmr_oc_init_structure.oc_output_state = TRUE;
111 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
112 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 16383);
113
114 tmr_input_default_para_init(&tmr_ic_init_structure);
115 tmr_ic_init_structure.input_filter_value = 0;
116 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_2;
117 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
118 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
119 tmr_input_channel_init(TMR4, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
120
121 /* one cycle mode selection */
122 tmr_one_cycle_mode_enable(TMR4, TRUE);
123
124 /* input trigger selection */
125 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_C2DF2);
126
127 /* slave mode selection: trigger mode */
128 tmr_sub_mode_select(TMR4, TMR_SUB_TRIGGER_MODE);
129
130 while(1)
131 {
132 }
133}
134
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:87
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:48
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:37
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:73
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:38
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:810
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:142
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f413_tmr.c:738
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:178
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:137
TMR_SUB_TRIGGER_MODE
@ TMR_SUB_TRIGGER_MODE
Definition: at32f413_tmr.h:152
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR4
#define TMR4
Definition: at32f413_tmr.h:833
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • parallel_synchro
  • inc
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • parallel_synchro
  • inc
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • parallel_synchro
  • inc
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • parallel_synchro
  • src
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • parallel_synchro
  • src
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • parallel_synchro
  • src
project/at_start_f413/examples/tmr/parallel_synchro/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37
38void crm_configuration(void);
39void gpio_configuration(void);
40
46void gpio_configuration(void)
47{
48 gpio_init_type gpio_init_struct;
49
50 gpio_default_para_init(&gpio_init_struct);
51
52 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_0;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
55 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init(GPIOA, &gpio_init_struct);
58
59 gpio_init_struct.gpio_pins = GPIO_PINS_6;
60 gpio_init(GPIOB, &gpio_init_struct);
61
62}
63
69void crm_configuration(void)
70{
71 /* tmr3 clock enable */
72 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
73 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
74 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
75
76 /* gpios clock enable */
77 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
78 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
79 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
80 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
81}
82
88int main(void)
89{
90 system_clock_config();
91
92 /* peripheral clocks configuration */
93 crm_configuration();
94
95 /* gpio configuration */
96 gpio_configuration();
97
98 /* tmr base configuration */
99 tmr_base_init(TMR2, 191, 0);
100 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
101 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
102 tmr_base_init(TMR3, 9, 0);
103 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
104 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
105 tmr_base_init(TMR4, 4, 0);
106 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
107 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
108
109 /* output compare toggle mode configuration: channel1 */
110 tmr_output_default_para_init(&tmr_oc_init_structure);
111 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
112 tmr_oc_init_structure.oc_idle_state = FALSE;
113 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
114 tmr_oc_init_structure.oc_output_state = TRUE;
115 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
116 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, 96);
117
118 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
119 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 3);
120
121 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
122 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 3);
123
124 /* primary mode selection: TMR2 */
125 tmr_sub_sync_mode_set(TMR2, TRUE);
126 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
127
128 /* subordinate mode selection: TMR3 */
129 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
130 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS1);
131
132 /* subordinate mode selection: TMR4 */
133 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
134 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS1);
135
136 /* tmr enable counter */
137 tmr_counter_enable(TMR2, TRUE);
138 tmr_counter_enable(TMR3, TRUE);
139 tmr_counter_enable(TMR4, TRUE);
140
141 while(1)
142 {
143 }
144}
145
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:88
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:46
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:69
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1263
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1164
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f413_tmr.h:132
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:151
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:118
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
TMR4
#define TMR4
Definition: at32f413_tmr.h:833
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_input
  • inc
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_input
  • inc
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_input
  • inc
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_input
  • src
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_input
  • src
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern uint16_t duty_cycle;
29extern uint32_t frequency;
30
39__IO uint16_t ic2value = 0;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void TMR3_GLOBAL_IRQHandler(void)
144{
145 /* clear tmr3 channel interrupt pending bit */
146 tmr_flag_clear(TMR3, TMR_C2_FLAG);
147
148 /* get the input channel data value */
149 ic2value = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
150
151 if(ic2value != 0)
152 {
153 /* duty cycle computation */
154 duty_cycle = (tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_1) * 100) / ic2value;
155
156 /* frequency computation */
157 frequency = system_core_clock / ic2value;
158 }
159 else
160 {
161 duty_cycle = 0;
162 frequency = 0;
163 }
164}
165
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:107
ic2value
__IO uint16_t ic2value
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:39
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:46
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 global interrupt request.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:143
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:81
frequency
uint32_t frequency
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:39
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:134
duty_cycle
uint16_t duty_cycle
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:38
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:116
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:545
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:52
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_input
  • src
project/at_start_f413/examples/tmr/pwm_input/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_input_config_type tmr_ic_init_structure;
37
38__IO uint16_t duty_cycle = 0;
39__IO uint32_t frequency = 0;
40
41void crm_configuration(void);
42void gpio_configuration(void);
43
49void gpio_configuration(void)
50{
51 gpio_init_type gpio_init_struct;
52
53 gpio_default_para_init(&gpio_init_struct);
54
55 gpio_init_struct.gpio_pins = GPIO_PINS_7;
56 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init(GPIOA, &gpio_init_struct);
61}
62
68void crm_configuration(void)
69{
70 /* tmr3 clock enable */
71 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
72
73 /* gpioa clock enable */
74 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
75}
76
82int main(void)
83{
84 system_clock_config();
85
86 /* peripheral clocks configuration */
87 crm_configuration();
88
89 /* nvic configuration */
90 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
91 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
92
93 /* gpio configuration */
94 gpio_configuration();
95
96 uart_print_init(115200);
97
98 tmr_input_default_para_init(&tmr_ic_init_structure);
99 tmr_ic_init_structure.input_filter_value = 0;
100 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_2;
101 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
102 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
103
104 tmr_pwm_input_config(TMR3, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
105
106 /* select the tmr3 input trigger: c2df2 */
107 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_C2DF2);
108
109 /* select the sub mode: reset mode */
110 tmr_sub_mode_select(TMR3, TMR_SUB_RESET_MODE);
111
112 /* enable the sub sync mode */
113 tmr_sub_sync_mode_set(TMR3, TRUE);
114
115 /* tmr enable counter */
116 tmr_counter_enable(TMR3, TRUE);
117
118 /* enable the c2 interrupt request */
119 tmr_interrupt_enable(TMR3, TMR_C2_INT, TRUE);
120
121 while(1)
122 {
123 printf("Frequency = %dHZ,Dutycycle = %d%%\r\n", frequency, duty_cycle);
124 }
125}
126
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:82
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:49
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:68
frequency
__IO uint32_t frequency
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:39
duty_cycle
__IO uint16_t duty_cycle
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:38
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:200
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:142
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1263
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:984
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:137
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:150
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:74
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_input_dma
  • inc
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_input_dma
  • inc
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_input_dma
  • inc
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_input_dma
  • src
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_input_dma
  • src
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_input_dma
  • src
project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "stdio.h"
28
37#define TMR1_C1DT_ADDRESS 0x40012C34
38#define TMR1_C2DT_ADDRESS 0x40012C38
39
40#define SAMPLING_NUM 1000
41
42 tmr_input_config_type tmr_ic_init_structure;
43 dma_init_type dma_init_structure;
44
45__IO uint16_t buffer_ch1[1000];
46__IO uint16_t buffer_ch2[1000];
47
48__IO uint32_t frequency = 0;
49__IO float duty_cycle = 0;
50
51uint32_t freq_result;
52float duty_result;
53
54void crm_configuration(void);
55void gpio_configuration(void);
56
57void DMA1_Channel2_IRQHandler(void)
58{
59 uint16_t i;
60
61 dma_flag_clear(DMA1_FDT2_FLAG);
62
63 duty_result = 0;
64 freq_result = 0.0;
65
66 for(i = 0; i < SAMPLING_NUM; i++)
67 {
68 duty_result += ((buffer_ch2[i] * 100.0) / buffer_ch1[i]);
69 freq_result += (system_core_clock / buffer_ch1[i]);
70 }
71
72 duty_cycle = duty_result / SAMPLING_NUM;
73 frequency = freq_result / SAMPLING_NUM;
74 printf("\r\nFreq=%dHZ, Duty=%.2f%%\r\n", frequency, duty_cycle);
75}
76
82void gpio_configuration(void)
83{
84 gpio_init_type gpio_init_struct;
85
86 gpio_default_para_init(&gpio_init_struct);
87
88 gpio_init_struct.gpio_pins = GPIO_PINS_8;
89 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
90 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
91 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
92 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
93 gpio_init(GPIOA, &gpio_init_struct);
94}
95
101void crm_configuration(void)
102{
103 /* tmr1 clock enable */
104 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
105
106 /* gpioa clock enable */
107 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
108
109 /* dma clock enable */
110 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
111}
112
118int main(void)
119{
120 system_clock_config();
121
122 /* peripheral clocks configuration */
123 crm_configuration();
124
125 /* nvic configuration */
126 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
127 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
128
129 /* gpio configuration */
130 gpio_configuration();
131
132 uart_print_init(115200);
133
134 dma_reset(DMA1_CHANNEL2);
135 dma_default_para_init(&dma_init_structure);
136 dma_init_structure.peripheral_base_addr = (uint32_t)TMR1_C1DT_ADDRESS;
137 dma_init_structure.memory_base_addr = (uint32_t)buffer_ch1;
138 dma_init_structure.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
139 dma_init_structure.buffer_size = SAMPLING_NUM;
140 dma_init_structure.peripheral_inc_enable = FALSE;
141 dma_init_structure.memory_inc_enable = TRUE;
142 dma_init_structure.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
143 dma_init_structure.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
144 dma_init_structure.loop_mode_enable = TRUE;
145 dma_init_structure.priority = DMA_PRIORITY_HIGH;
146 dma_init(DMA1_CHANNEL2, &dma_init_structure);
147
148 dma_reset(DMA1_CHANNEL3);
149 dma_init_structure.peripheral_base_addr = (uint32_t)TMR1_C2DT_ADDRESS;
150 dma_init_structure.memory_base_addr = (uint32_t)buffer_ch2;
151 dma_init(DMA1_CHANNEL3, &dma_init_structure);
152
153 dma_interrupt_enable(DMA1_CHANNEL2, DMA_FDT_INT, TRUE);
154
155 dma_channel_enable(DMA1_CHANNEL2, TRUE);
156 dma_channel_enable(DMA1_CHANNEL3, TRUE);
157
158 tmr_input_default_para_init(&tmr_ic_init_structure);
159 tmr_ic_init_structure.input_filter_value = 0;
160 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_1;
161 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
162 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
163
164 tmr_pwm_input_config(TMR1, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
165
166 /* select the TMR1 input trigger: C2IF2 */
167 tmr_trigger_input_select(TMR1, TMR_SUB_INPUT_SEL_C1DF1);
168
169 /* select the sub mode: reset mode */
170 tmr_sub_mode_select(TMR1, TMR_SUB_RESET_MODE);
171
172 /* enable the sub sync mode */
173 tmr_sub_sync_mode_set(TMR1, TRUE);
174
175 /* enable the c1/c2 dma */
176 tmr_dma_request_enable(TMR1, TMR_C1_DMA_REQUEST, TRUE);
177 tmr_dma_request_enable(TMR1, TMR_C2_DMA_REQUEST, TRUE);
178
179 /* tmr enable counter */
180 tmr_counter_enable(TMR1, TRUE);
181
182 while(1)
183 {
184 }
185}
186
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
duty_cycle
__IO float duty_cycle
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:49
DMA1_Channel2_IRQHandler
void DMA1_Channel2_IRQHandler(void)
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:57
dma_init_structure
dma_init_type dma_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:43
freq_result
uint32_t freq_result
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:51
duty_result
float duty_result
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:52
TMR1_C1DT_ADDRESS
#define TMR1_C1DT_ADDRESS
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:37
buffer_ch2
__IO uint16_t buffer_ch2[1000]
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:118
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:82
SAMPLING_NUM
#define SAMPLING_NUM
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:40
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:42
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:101
frequency
__IO uint32_t frequency
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:48
buffer_ch1
__IO uint16_t buffer_ch1[1000]
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:45
TMR1_C2DT_ADDRESS
#define TMR1_C2DT_ADDRESS
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:38
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f413.h:182
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:244
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:254
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:84
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:479
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1286
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:142
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1263
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:984
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
TMR_C1_DMA_REQUEST
@ TMR_C1_DMA_REQUEST
Definition: at32f413_tmr.h:268
TMR_C2_DMA_REQUEST
@ TMR_C2_DMA_REQUEST
Definition: at32f413_tmr.h:269
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:204
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:237
TMR_SUB_INPUT_SEL_C1DF1
@ TMR_SUB_INPUT_SEL_C1DF1
Definition: at32f413_tmr.h:136
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:150
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:247
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:410
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:413
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:411
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_output_simulate
  • src
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_output_simulate
  • src
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern __IO uint16_t ch1_val;
29extern __IO uint16_t ch2_val;
30extern __IO uint16_t ch3_val;
31extern __IO uint16_t ch4_val;
32
41uint16_t capture = 0;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
140void TMR2_GLOBAL_IRQHandler(void)
141{
142 if(tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
143 {
144 tmr_flag_clear(TMR2, TMR_C1_FLAG );
145
146 /* Pin PC.06 toggling with frequency = 73.24 Hz */
147 gpio_bits_write(GPIOC, GPIO_PINS_6, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_6)));
148 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_1);
149 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, capture + ch1_val);
150 }
151 else if(tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
152 {
153 tmr_flag_clear(TMR2, TMR_C2_FLAG);
154
155 /* Pin PC.06 toggling with frequency = 73.24 Hz */
156 gpio_bits_write(GPIOC, GPIO_PINS_7, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_7)));
157 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_2);
158 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, capture + ch2_val);
159 }
160 else if(tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
161 {
162 tmr_flag_clear(TMR2, TMR_C3_FLAG);
163
164 /* Pin PC.06 toggling with frequency = 73.24 Hz */
165 gpio_bits_write(GPIOC, GPIO_PINS_8, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_8)));
166 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_3);
167 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, capture + ch3_val);
168 }
169 else
170 {
171 tmr_flag_clear(TMR2, TMR_C4_FLAG);
172
173 /* Pin PC.06 toggling with frequency = 73.24 Hz */
174 gpio_bits_write(GPIOC, GPIO_PINS_9, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_9)));
175 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_4);
176 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, capture + ch4_val);
177 }
178}
179
ch4_val
__IO uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:41
ch3_val
__IO uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:40
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:109
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:140
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:48
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:136
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:118
capture
uint16_t capture
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:41
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f413_gpio.c:254
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f413_gpio.c:371
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:545
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:51
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:52
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:53
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:54
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_output_simulate
  • src
project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37
38uint16_t ch1_val = 40961;
39uint16_t ch2_val = 27309;
40uint16_t ch3_val = 13654;
41uint16_t ch4_val = 6826;
42uint16_t div_value = 0;
43
44void crm_configuration(void);
45void gpio_configuration(void);
46
52void gpio_configuration(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 gpio_default_para_init(&gpio_init_struct);
57
58 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63 gpio_init(GPIOC, &gpio_init_struct);
64}
65
71void crm_configuration(void)
72{
73 /* tmr2 clock enable */
74 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
75
76 /* gpioa gpiob clock enable */
77 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
78}
79
85int main(void)
86{
87 /* config nvic priority group */
88 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
89
90 system_clock_config();
91
92 /* peripheral clocks configuration */
93 crm_configuration();
94
95 /* nvic Configuration */
96 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
97
98 /* gpio configuration */
99 gpio_configuration();
100
101 /* compute the div value */
102 div_value = (uint16_t)(system_core_clock / 12000000) - 1;
103
104 /* tmr2 time base configuration */
105 tmr_base_init(TMR2, 65535, div_value);
106 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
107 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
108
109 tmr_output_default_para_init(&tmr_oc_init_structure);
110 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_OFF;
111 tmr_oc_init_structure.oc_idle_state = FALSE;
112 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
113 tmr_oc_init_structure.oc_output_state = TRUE;
114 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
115 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
116
117 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
118 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
119
120 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
121 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
122
123 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
124 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
125
126 /* tmr2 int enable */
127 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
128
129 /* tmr enable counter */
130 tmr_counter_enable(TMR2, TRUE);
131
132 while(1)
133 {
134 }
135}
136
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:41
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:40
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:85
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:39
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:52
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:71
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:42
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:199
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:171
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:75
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:76
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:73
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:74
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37
38uint16_t ch1_val = 333;
39uint16_t ch2_val = 249;
40uint16_t ch3_val = 166;
41uint16_t ch4_val = 83;
42uint16_t div_value = 0;
43
44void crm_configuration(void);
45void gpio_configuration(void);
46
52void gpio_configuration(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 gpio_default_para_init(&gpio_init_struct);
57
58 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63 gpio_init(GPIOA, &gpio_init_struct);
64
65 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
66 gpio_init(GPIOB, &gpio_init_struct);
67}
68
74void crm_configuration(void)
75{
76 /* tmr3 clock enable */
77 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
78
79 /* gpioa gpiob clock enable */
80 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
82}
83
89int main(void)
90{
91 system_clock_config();
92
93 /* peripheral clocks configuration */
94 crm_configuration();
95
96 /* gpio configuration */
97 gpio_configuration();
98
99 /* compute the div value */
100 div_value = (uint16_t)(system_core_clock / 24000000) - 1;
101
102 /* tmr3 time base configuration */
103 tmr_base_init(TMR3, 665, div_value);
104 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
105 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
106
107 tmr_output_default_para_init(&tmr_oc_init_structure);
108 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
109 tmr_oc_init_structure.oc_idle_state = FALSE;
110 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
111 tmr_oc_init_structure.oc_output_state = TRUE;
112 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
113 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, ch1_val);
114 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_1, TRUE);
115
116 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
117 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, ch2_val);
118 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_2, TRUE);
119
120 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
121 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, ch3_val);
122 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_3, TRUE);
123
124 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
125 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, ch4_val);
126 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_4, TRUE);
127
128 tmr_period_buffer_enable(TMR3, TRUE);
129
130 /* tmr enable counter */
131 tmr_counter_enable(TMR3, TRUE);
132
133 while(1)
134 {
135 }
136}
137
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:41
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:40
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:89
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:39
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:52
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:74
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:42
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:56
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:586
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:607
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37
38uint16_t ch1_val = 250;
39uint16_t div_value = 0;
40
41void crm_configuration(void);
42void gpio_configuration(void);
43
49void gpio_configuration(void)
50{
51 gpio_init_type gpio_init_struct;
52
53 gpio_default_para_init(&gpio_init_struct);
54
55 gpio_init_struct.gpio_pins = GPIO_PINS_8;
56 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init(GPIOB, &gpio_init_struct);
61}
62
68void crm_configuration(void)
69{
70 /* tmr10 clock enable */
71 crm_periph_clock_enable(CRM_TMR10_PERIPH_CLOCK, TRUE);
72
73 /* gpioa gpiob clock enable */
74 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
75}
76
82int main(void)
83{
84 system_clock_config();
85
86 /* peripheral clocks configuration */
87 crm_configuration();
88
89 /* gpio configuration */
90 gpio_configuration();
91
92 /* compute the div value */
93 div_value = (uint16_t)(system_core_clock / 10000000) - 1;
94
95 /* tmr10 time base configuration */
96 tmr_base_init(TMR10, 499, div_value);
97 tmr_cnt_dir_set(TMR10, TMR_COUNT_UP);
98 tmr_clock_source_div_set(TMR10, TMR_CLOCK_DIV1);
99
100 tmr_output_default_para_init(&tmr_oc_init_structure);
101 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
102 tmr_oc_init_structure.oc_idle_state = FALSE;
103 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
104 tmr_oc_init_structure.oc_output_state = TRUE;
105 tmr_output_channel_config(TMR10, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
106 tmr_channel_value_set(TMR10, TMR_SELECT_CHANNEL_1, ch1_val);
107 tmr_output_channel_buffer_enable(TMR10, TMR_SELECT_CHANNEL_1, TRUE);
108
109 tmr_period_buffer_enable(TMR10, TRUE);
110
111 /* tmr enable counter */
112 tmr_counter_enable(TMR10, TRUE);
113
114 while(1)
115 {
116 }
117}
118
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:82
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:49
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:68
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:39
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_TMR10_PERIPH_CLOCK
@ CRM_TMR10_PERIPH_CLOCK
Definition: at32f413_crm.h:120
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:586
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:607
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • timer_base
  • inc
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • timer_base
  • inc
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • timer_base
  • inc
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • timer_base
  • src
project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • timer_base
  • src
project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • timer_base
  • src
project/at_start_f413/examples/tmr/timer_base/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 crm_clocks_freq_type crm_clocks_freq_struct = {0};
37
38void clkout_config(void)
39{
40 gpio_init_type gpio_init_struct;
41
42 /* enable gpio port clock */
43 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
44
45 /* set default parameter */
46 gpio_default_para_init(&gpio_init_struct);
47
48 /* clkout gpio init */
49 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
50 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
51 gpio_init_struct.gpio_pins = GPIO_PINS_8;
52 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
53 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
54 gpio_init(GPIOA, &gpio_init_struct);
55
56 /* config clkout division */
57 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
58
59 /* config clkout clock */
60 crm_clock_out_set(CRM_CLKOUT_PLL_DIV_4);
61}
62
68void TMR1_OVF_TMR10_IRQHandler(void)
69{
70 if(tmr_flag_get(TMR1, TMR_OVF_FLAG) != RESET)
71 {
72 /* add user code... */
73 at32_led_toggle(LED3);
74 tmr_flag_clear(TMR1, TMR_OVF_FLAG);
75 }
76}
77
83int main(void)
84{
85 system_clock_config();
86
87 at32_board_init();
88
89 /* get system clock */
90 crm_clocks_freq_get(&crm_clocks_freq_struct);
91
92 /* turn led2/led3/led4 on */
93 at32_led_on(LED2);
94 at32_led_on(LED3);
95 at32_led_on(LED4);
96
97 /* enable tmr1 clock */
98 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
99
100 /* tmr1 configuration */
101 /* time base configuration */
102 /* systemclock/19200/10000 = 1hz */
103 tmr_base_init(TMR1, 9999, (crm_clocks_freq_struct.ahb_freq / 10000) - 1);
104 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
105
106 /* overflow interrupt enable */
107 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
108
109 /* tmr1 overflow interrupt nvic init */
110 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
111 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 0, 0);
112
113 /* enable tmr1 */
114 tmr_counter_enable(TMR1, TRUE);
115 clkout_config();
116
117 while(1)
118 {
119 }
120}
121
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
clkout_config
void clkout_config(void)
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:83
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:36
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
this function handles timer1 overflow handler.
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:68
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:805
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:684
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:418
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:408
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:196
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1351
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:50
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:72
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:471
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • tmr1_synchro
  • inc
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • tmr1_synchro
  • inc
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • tmr1_synchro
  • inc
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • tmr1_synchro
  • src
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • tmr1_synchro
  • src
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • tmr1_synchro
  • src
project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37
38void crm_configuration(void);
39void gpio_configuration(void);
40
46void gpio_configuration(void)
47{
48 gpio_init_type gpio_init_struct;
49
50 gpio_default_para_init(&gpio_init_struct);
51
52 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_8;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
55 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init(GPIOA, &gpio_init_struct);
58
59 gpio_init_struct.gpio_pins = GPIO_PINS_6;
60 gpio_init(GPIOB, &gpio_init_struct);
61}
62
68void crm_configuration(void)
69{
70 /* tmr clock enable */
71 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
72 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
73 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
74
75 /* gpio clock enable */
76 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
77 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
78}
79
85int main(void)
86{
87 system_clock_config();
88
89 /* peripheral clocks configuration */
90 crm_configuration();
91
92 /* gpio configuration */
93 gpio_configuration();
94
95 /* tmr3 time base configuration */
96 tmr_base_init(TMR3, 2, 0);
97 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
98 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
99
100 tmr_output_default_para_init(&tmr_oc_init_structure);
101 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
102 tmr_oc_init_structure.oc_idle_state = FALSE;
103 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
104 tmr_oc_init_structure.oc_output_state = TRUE;
105 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
106 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 1);
107
108 /* input trigger selection */
109 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS0);
110
111 /* slave mode selection: hang mode */
112 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
113
114 /* tmr4 time base configuration */
115 tmr_base_init(TMR4, 1, 0);
116 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
117 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
118
119 tmr_output_default_para_init(&tmr_oc_init_structure);
120 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
121 tmr_oc_init_structure.oc_idle_state = FALSE;
122 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
123 tmr_oc_init_structure.oc_output_state = TRUE;
124 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
125 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 1);
126
127 /* input trigger selection */
128 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS0);
129
130 /* slave mode selection: hang mode */
131 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
132
133 /* tmr1 time base configuration */
134 tmr_repetition_counter_set(TMR1, 4);
135 tmr_base_init(TMR1, 191, 0);
136 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
137 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
138
139 tmr_output_default_para_init(&tmr_oc_init_structure);
140 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
141 tmr_oc_init_structure.oc_idle_state = TRUE;
142 tmr_oc_init_structure.occ_idle_state = FALSE;
143 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
144 tmr_oc_init_structure.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
145 tmr_oc_init_structure.oc_output_state = TRUE;
146 tmr_oc_init_structure.occ_output_state = TRUE;
147 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
148 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 96);
149
150 tmr_primary_mode_select(TMR1, TMR_PRIMARY_SEL_OVERFLOW);
151 tmr_sub_sync_mode_set(TMR1, TRUE);
152
153 tmr_output_enable(TMR1, TRUE);
154
155 /* tmr enable counter */
156 tmr_counter_enable(TMR1, TRUE);
157 tmr_counter_enable(TMR3, TRUE);
158 tmr_counter_enable(TMR4, TRUE);
159
160 while(1)
161 {
162 }
163}
164
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:85
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:46
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:68
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:125
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f413_tmr.c:238
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1186
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1263
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1250
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1164
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:178
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR_SUB_INPUT_SEL_IS0
@ TMR_SUB_INPUT_SEL_IS0
Definition: at32f413_tmr.h:131
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:151
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:118
TMR3
#define TMR3
Definition: at32f413_tmr.h:832
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
TMR4
#define TMR4
Definition: at32f413_tmr.h:833
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • tmr2_32bit
  • inc
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • tmr2_32bit
  • inc
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • tmr2_32bit
  • inc
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • tmr2_32bit
  • src
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • tmr2_32bit
  • src
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • tmr2_32bit
  • src
project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 tmr_output_config_type tmr_oc_init_structure;
37
38uint32_t ch1_val = 0x7FFFF;
39uint32_t ch2_val = 0x3FFFF;
40uint32_t ch3_val = 0x1FFFF;
41uint32_t ch4_val = 0xFFFF;
42
43void crm_configuration(void);
44void gpio_configuration(void);
45
51void gpio_configuration(void)
52{
53 gpio_init_type gpio_init_struct;
54
55 gpio_default_para_init(&gpio_init_struct);
56
57 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3;
58 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
61 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
62 gpio_init(GPIOA, &gpio_init_struct);
63}
64
70void crm_configuration(void)
71{
72 /* tmr clock enable */
73 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
74
75 /* gpio clock enable */
76 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
77}
78
84int main(void)
85{
86 system_clock_config();
87
88 /* peripheral clocks configuration */
89 crm_configuration();
90
91 /* gpio configuration */
92 gpio_configuration();
93
94 tmr_32_bit_function_enable(TMR2, TRUE);
95
96 /* tmr2 time base configuration */
97 tmr_base_init(TMR2, 0xFFFFF, 0);
98 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
99 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
100
101 tmr_output_default_para_init(&tmr_oc_init_structure);
102 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
103 tmr_oc_init_structure.oc_idle_state = FALSE;
104 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
105 tmr_oc_init_structure.oc_output_state = TRUE;
106 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
107 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
108 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_1, TRUE);
109
110 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
111 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
112 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_2, TRUE);
113
114 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
115 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
116 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_3, TRUE);
117
118 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
119 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
120 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_4, TRUE);
121
122 tmr_period_buffer_enable(TMR2, TRUE);
123
124 /* tmr2 enable counter */
125 tmr_counter_enable(TMR2, TRUE);
126
127 while(1)
128 {
129 }
130}
131
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ch1_val
uint32_t ch1_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:38
ch2_val
uint32_t ch2_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:39
ch4_val
uint32_t ch4_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:84
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:51
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:36
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:70
ch3_val
uint32_t ch3_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:40
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:124
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:586
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:203
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:752
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:607
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:94
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR2
#define TMR2
Definition: at32f413_tmr.h:831
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • 6_steps
  • inc
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • 6_steps
  • inc
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • 6_steps
  • inc
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • 6_steps
  • src
project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • 6_steps
  • src
project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • 6_steps
  • src
project/at_start_f413/examples/tmr/6_steps/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 tmr_output_config_type tmr_output_struct;
38 tmr_brkdt_config_type tmr_brkdt_config_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41__IO uint32_t step = 1;
42
43/* systick configuration */
44void systick_configuration(void);
45
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 systick_configuration();
61
62 /* turn led2/led3/led4 on */
63 at32_led_on(LED2);
64 at32_led_on(LED3);
65 at32_led_on(LED4);
66
67 /* enable tmr1/gpioa/gpiob clock */
68 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
69 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
70 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
71
72 /* timer2 output pin Configuration */
73 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
74 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
75 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
76 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
81 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
82 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
83 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
84 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
85 gpio_init(GPIOB, &gpio_init_struct);
86
87 gpio_init_struct.gpio_pins = GPIO_PINS_12;
88 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
89 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
90 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
91 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
92 gpio_init(GPIOB, &gpio_init_struct);
93
94 /*
95 the tmr1 peripheral offers the possibility to program in advance the
96 configuration for the next tmr1 outputs behaviour (step) and change the configuration
97 of all the channels at the same time. this operation is possible when the hall
98 event is used.
99 the hall event can be generated by software by setting the hall bit in the tmr1_swevt
100 register or by hardware (on trc rising edge).
101 in this example, a software hall event is generated each 100 ms: using the systick
102 interrupt.
103 the tmr1 is configured in timing mode, each time a hall event occurs,
104 a new tmr1 configuration will be set in advance.
105 the following table describes the tmr1 channels states:
106 -----------------------------------------------
107 | step1 | step2 | step3 | step4 | step5 | step6 |
108 ----------------------------------------------------------
109 |channel1 | 1 | 0 | 0 | 0 | 0 | 1 |
110 ----------------------------------------------------------
111 |channel1n | 0 | 0 | 1 | 1 | 0 | 0 |
112 ----------------------------------------------------------
113 |channel2 | 0 | 0 | 0 | 1 | 1 | 0 |
114 ----------------------------------------------------------
115 |channel2n | 1 | 1 | 0 | 0 | 0 | 0 |
116 ----------------------------------------------------------
117 |channel3 | 0 | 1 | 1 | 0 | 0 | 0 |
118 ----------------------------------------------------------
119 |channel3n | 0 | 0 | 0 | 0 | 1 | 1 |
120 ----------------------------------------------------------
121 */
122 /* tmr1 configuration */
123 /* time base configuration */
124 tmr_base_init(TMR1, 4095, 0);
125 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
126
127 /* channel 1, 2 and 3 configuration in output mode */
128 tmr_output_default_para_init(&tmr_output_struct);
129 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_OFF;
130 tmr_output_struct.oc_output_state = TRUE;
131 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
132 tmr_output_struct.oc_idle_state = TRUE;
133 tmr_output_struct.occ_output_state = TRUE;
134 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
135 tmr_output_struct.occ_idle_state = TRUE;
136
137 /* channel 1 */
138 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
139 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 2047);
140
141 /* channel 2 */
142 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
143 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, 1023);
144
145 /* channel 3 */
146 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
147 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, 511);
148
149 /* automatic output enable, brake, dead time and lock configuration */
150 tmr_brkdt_default_para_init(&tmr_brkdt_config_struct);
151 tmr_brkdt_config_struct.brk_enable = TRUE;
152 tmr_brkdt_config_struct.auto_output_enable = TRUE;
153 tmr_brkdt_config_struct.deadtime = 0;
154 tmr_brkdt_config_struct.fcsodis_state = TRUE;
155 tmr_brkdt_config_struct.fcsoen_state = TRUE;
156 tmr_brkdt_config_struct.brk_polarity = TMR_BRK_INPUT_ACTIVE_HIGH;
157 tmr_brkdt_config_struct.wp_level = TMR_WP_OFF;
158 tmr_brkdt_config(TMR1, &tmr_brkdt_config_struct);
159 tmr_channel_buffer_enable(TMR1, TRUE);
160
161 /* hall interrupt enable */
162 tmr_interrupt_enable(TMR1, TMR_HALL_INT, TRUE);
163
164 /* tmr1 hall interrupt nvic init */
165 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
166 nvic_irq_enable(TMR1_TRG_HALL_TMR11_IRQn, 0, 0);
167
168 /* tmr1 output enable */
169 tmr_output_enable(TMR1, TRUE);
170
171 /* enable tmr1 */
172 tmr_counter_enable(TMR1, TRUE);
173
174 while(1)
175 {
176 }
177}
183void systick_configuration(void)
184{
185 /* setup systick timer for 20 msec interrupts */
186 if(SysTick_Config((crm_clocks_freq_struct.sclk_freq) / 50))
187 {
188 /* capture error */
189 while(1);
190 }
191 NVIC_SetPriority(SysTick_IRQn, 0x0);
192}
193
200void TMR1_TRG_HALL_TMR11_IRQHandler(void)
201{
202 /* clear tmr1 com pending bit */
203 tmr_flag_clear(TMR1, TMR_HALL_FLAG);
204 if(step == 1)
205 {
206 /* next step: step 2 configuration ---------------------------- */
207 /* channel3 configuration */
208 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
209 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
210
211 /* channel1 configuration */
212 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
213 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
214 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
215
216 /* channel2 configuration */
217 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
218 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
219 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, TRUE);
220 step++;
221 }
222 else if(step == 2)
223 {
224 /* next step: step 3 configuration ---------------------------- */
225 /* channel2 configuration */
226 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
227 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
228 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, TRUE);
229
230 /* channel3 configuration */
231 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
232 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, TRUE);
233 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
234
235 /* channel1 configuration */
236 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
237 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
238 step++;
239 }
240 else if(step == 3)
241 {
242 /* next step: step 4 configuration ---------------------------- */
243 /* channel3 configuration */
244 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
245 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, TRUE);
246 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
247
248 /* channel2 configuration */
249 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
250 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
251
252 /* channel1 configuration */
253 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
254 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
255 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, TRUE);
256 step++;
257 }
258 else if(step == 4)
259 {
260 /* next step: step 5 configuration ---------------------------- */
261 /* channel3 configuration */
262 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
263 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
264
265 /* channel1 configuration */
266 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
267 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
268 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, TRUE);
269
270 /* channel2 configuration */
271 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
272 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, TRUE);
273 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
274 step++;
275 }
276 else if(step == 5)
277 {
278 /* next step: step 6 configuration ---------------------------- */
279 /* channel3 configuration */
280 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
281 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
282 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, TRUE);
283
284 /* channel1 configuration */
285 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
286 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
287
288 /* channel2 configuration */
289 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
290 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, TRUE);
291 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
292 step++;
293 }
294 else
295 {
296 /* next step: step 1 configuration ---------------------------- */
297 /* channel1 configuration */
298 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
299 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
300 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
301
302 /* channel3 configuration */
303 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
304 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
305 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, TRUE);
306
307 /* channel2 configuration */
308 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
309 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
310 step = 1;
311 }
312}
313
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:36
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:37
systick_configuration
void systick_configuration(void)
configures the systick.
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:183
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:39
step
__IO uint32_t step
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:41
TMR1_TRG_HALL_TMR11_IRQHandler
void TMR1_TRG_HALL_TMR11_IRQHandler(void)
this function handles tmr1 trigger and hall interrupts requests.
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:200
tmr_brkdt_config_struct
tmr_brkdt_config_type tmr_brkdt_config_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:38
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
SysTick_IRQn
@ SysTick_IRQn
Definition: at32f413.h:167
TMR1_TRG_HALL_TMR11_IRQn
@ TMR1_TRG_HALL_TMR11_IRQn
Definition: at32f413.h:197
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1389
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer
Definition: at32f413_tmr.c:1228
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f413_tmr.c:423
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:156
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr brake mode and dead-time
Definition: at32f413_tmr.c:1722
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1317
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:882
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f413_tmr.h:215
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f413_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f413_tmr.h:219
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f413_tmr.h:386
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:378
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:171
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:177
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_HALL_FLAG
#define TMR_HALL_FLAG
Definition: at32f413_tmr.h:55
TMR_HALL_INT
#define TMR_HALL_INT
Definition: at32f413_tmr.h:77
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:421
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:422
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:425
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:423
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • 7_pwm_output
  • inc
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • 7_pwm_output
  • inc
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • 7_pwm_output
  • inc
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • 7_pwm_output
  • src
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • 7_pwm_output
  • src
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131 /* trigger TMR1 hall event */
132 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:111
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1412
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:286
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • 7_pwm_output
  • src
project/at_start_f413/examples/tmr/7_pwm_output/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36 gpio_init_type gpio_init_struct = {0};
37 tmr_output_config_type tmr_output_struct;
38 crm_clocks_freq_type crm_clocks_freq_struct = {0};
39
40uint16_t timer_period = 0;
41uint16_t channel1_pulse = 0, channel2_pulse = 0, channel3_pulse = 0, channel4_pulse = 0;
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* get system clock */
55 crm_clocks_freq_get(&crm_clocks_freq_struct);
56
57 /* turn led2/led3/led4 on */
58 at32_led_on(LED2);
59 at32_led_on(LED3);
60 at32_led_on(LED4);
61
62 /* enable tmr1/gpioa/gpiob clock */
63 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
66
67 /* timer1 output pin Configuration */
68 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11;
69 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
70 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
76 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOB, &gpio_init_struct);
81
82 gpio_init_struct.gpio_pins = GPIO_PINS_12;
83 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
84 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
85 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
86 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
87 gpio_init(GPIOB, &gpio_init_struct);
88
89
90 /* tmr1 configuration generate 7 pwm signals with 4 different duty cycles:
91 prescaler = 0, tmr1 counter clock = system_core_clock
92
93 the objective is to generate 7 pwm signal at 17.57 khz:
94 - tim1_period = (system_core_clock / 17570) - 1
95 the channel 1 and channel 1n duty cycle is set to 50%
96 the channel 2 and channel 2n duty cycle is set to 37.5%
97 the channel 3 and channel 3n duty cycle is set to 25%
98 the channel 4 duty cycle is set to 12.5%
99 the timer pulse is calculated as follows:
100 - channelxpulse = duty_cycle * (tim1_period - 1) / 100 */
101
102 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
103 timer_period = (crm_clocks_freq_struct.sclk_freq / 17570 ) - 1;
104
105 /* compute ccr1 value to generate a duty cycle at 50% for channel 1 and 1n */
106 channel1_pulse = (uint16_t)(((uint32_t) 5 * (timer_period - 1)) / 10);
107
108 /* compute ccr2 value to generate a duty cycle at 37.5% for channel 2 and 2n */
109 channel2_pulse = (uint16_t)(((uint32_t) 375 * (timer_period - 1)) / 1000);
110
111 /* compute ccr3 value to generate a duty cycle at 25% for channel 3 and 3n */
112 channel3_pulse = (uint16_t)(((uint32_t) 25 * (timer_period - 1)) / 100);
113
114 /* compute ccr4 value to generate a duty cycle at 12.5% for channel 4 */
115 channel4_pulse = (uint16_t)(((uint32_t) 125 * (timer_period- 1)) / 1000);
116
117 tmr_base_init(TMR1, timer_period, 0);
118 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
119
120 /* channel 1, 2, 3 and 4 configuration in output mode */
121 tmr_output_default_para_init(&tmr_output_struct);
122 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
123 tmr_output_struct.oc_output_state = TRUE;
124 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
125 tmr_output_struct.oc_idle_state = TRUE;
126 tmr_output_struct.occ_output_state = TRUE;
127 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
128 tmr_output_struct.occ_idle_state = FALSE;
129
130 /* channel 1 */
131 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
132 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, channel1_pulse);
133
134 /* channel 2 */
135 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
136 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, channel2_pulse);
137
138 /* channel 3 */
139 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
140 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, channel3_pulse);
141
142 /* channel 4 */
143 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_4, &tmr_output_struct);
144 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_4, channel4_pulse);
145
146 /* output enable */
147 tmr_output_enable(TMR1, TRUE);
148
149 /* enable tmr1 */
150 tmr_counter_enable(TMR1, TRUE);
151
152 while(1)
153 {
154 }
155}
156
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:36
channel1_pulse
uint16_t channel1_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:41
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:37
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:40
channel2_pulse
uint16_t channel2_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:41
channel3_pulse
uint16_t channel3_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:48
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:38
channel4_pulse
uint16_t channel4_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:113
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:317
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:125
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1425
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:178
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:224
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:500
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:104
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:214
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:216
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:178
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:195
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:196
TMR1
#define TMR1
Definition: at32f413_tmr.h:830
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:470
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:396
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:403
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:402
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:397
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:401
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:400
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • half_duplex
  • inc
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • half_duplex
  • inc
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • half_duplex
  • inc
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • half_duplex
  • src
project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • half_duplex
  • src
project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • half_duplex
  • src
project/at_start_f413/examples/usart/half_duplex/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
37#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
38#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
39
40uint8_t usart2_tx_buffer[] = "usart half-duplex transfer: usart2 -> usart3";
41uint8_t usart3_tx_buffer[] = "usart half-duplex transfer: usart3 -> usart2";
42uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
43uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
44uint8_t data_count;
45
51void usart_configuration(void)
52{
53 gpio_init_type gpio_init_struct;
54
55 /* enable the usart2 and gpio clock */
56 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58
59 /* enable the usart3 and gpio clock */
60 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
62
63 gpio_default_para_init(&gpio_init_struct);
64
65 /* configure the usart2 tx pin */
66 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
67 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
68 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
69 gpio_init_struct.gpio_pins = GPIO_PINS_2;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init(GPIOA, &gpio_init_struct);
72
73 /* configure the usart3 tx pin */
74 gpio_init_struct.gpio_pins = GPIO_PINS_10;
75 gpio_init(GPIOB, &gpio_init_struct);
76
77 /* configure usart2 param */
78 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
79 usart_transmitter_enable(USART2, TRUE);
80 usart_receiver_enable(USART2, TRUE);
81 usart_single_line_halfduplex_select(USART2, TRUE);
82 usart_enable(USART2, TRUE);
83
84 /* configure usart3 param */
85 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
86 usart_transmitter_enable(USART3, TRUE);
87 usart_receiver_enable(USART3, TRUE);
88 usart_single_line_halfduplex_select(USART3, TRUE);
89 usart_enable(USART3, TRUE);
90}
91
99uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
100{
101 while(buffer_length--)
102 {
103 if(*pbuffer1 != *pbuffer2)
104 {
105 return 0;
106 }
107 pbuffer1++;
108 pbuffer2++;
109 }
110 return 1;
111}
112
118int main(void)
119{
120 system_clock_config();
121 at32_board_init();
122 usart_configuration();
123
124 /* usart2 transmit and usart3 receive */
125 data_count = USART2_TX_BUFFER_SIZE;
126 while(data_count)
127 {
128 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
129 usart_data_transmit(USART2, usart2_tx_buffer[USART2_TX_BUFFER_SIZE-data_count]);
130 while(usart_flag_get(USART3, USART_RDBF_FLAG) == RESET);
131 usart3_rx_buffer[USART2_TX_BUFFER_SIZE-data_count] = usart_data_receive(USART3);
132 data_count--;
133 }
134
135 /* usart3 transmit and usart2 receive */
136 data_count = USART3_TX_BUFFER_SIZE;
137 while(data_count)
138 {
139 while(usart_flag_get(USART3, USART_TDBE_FLAG) == RESET);
140 usart_data_transmit(USART3, usart3_tx_buffer[USART3_TX_BUFFER_SIZE-data_count]);
141 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
142 usart2_rx_buffer[USART3_TX_BUFFER_SIZE-data_count] = usart_data_receive(USART2);
143 data_count--;
144 }
145
146 while(1)
147 {
148 /* compare data buffer */
149 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
150 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
151 {
152 at32_led_toggle(LED2);
153 at32_led_toggle(LED3);
154 at32_led_toggle(LED4);
155 delay_sec(1);
156 }
157 }
158}
159
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:51
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:99
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:43
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:118
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:40
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:38
data_count
uint8_t data_count
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:44
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:41
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:42
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f413_usart.c:475
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • hw_flow_control
  • inc
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • hw_flow_control
  • inc
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • hw_flow_control
  • inc
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • hw_flow_control
  • src
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • hw_flow_control
  • src
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • hw_flow_control
  • src
project/at_start_f413/examples/usart/hw_flow_control/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BUFFER_SIZE 16
37
38uint8_t rx_buffer[BUFFER_SIZE];
39uint8_t data_count;
40
46void usart_configuration(void)
47{
48 gpio_init_type gpio_init_struct;
49
50 /* enable the usart2 and gpio clock */
51 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
53
54 gpio_default_para_init(&gpio_init_struct);
55
56 /* configure the usart2 tx and rts pin */
57 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
58 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
59 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
60 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_1;
61 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
62 gpio_init(GPIOA, &gpio_init_struct);
63
64 /* configure the usart2 rx and cts pin */
65 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
66 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
67 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
68 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_0;
69 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
70 gpio_init(GPIOA, &gpio_init_struct);
71
72 /* configure usart2 param */
73 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
74 usart_hardware_flow_control_set(USART2, USART_HARDWARE_FLOW_RTS_CTS);
75 usart_transmitter_enable(USART2, TRUE);
76 usart_receiver_enable(USART2, TRUE);
77 usart_enable(USART2, TRUE);
78}
79
85int main(void)
86{
87 system_clock_config();
88 at32_board_init();
89 usart_configuration();
90
91 /* receive a string (BUFFER_SIZE bytes) from the hyperterminal */
92 data_count = BUFFER_SIZE;
93 while(data_count)
94 {
95 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
96 rx_buffer[BUFFER_SIZE-data_count] = usart_data_receive(USART2);
97 data_count--;
98 }
99
100 /* send a buffer from usart to hyperterminal */
101 data_count = BUFFER_SIZE;
102 while(data_count)
103 {
104 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
105 usart_data_transmit(USART2, rx_buffer[BUFFER_SIZE-data_count]);
106 data_count--;
107 }
108
109 while(1)
110 {
111 at32_led_toggle(LED2);
112 at32_led_toggle(LED3);
113 at32_led_toggle(LED4);
114 delay_sec(1);
115 }
116}
117
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
rx_buffer
uint8_t rx_buffer[16]
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:38
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:46
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:36
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:85
data_count
uint8_t data_count
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:49
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:521
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f413_usart.h:170
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • idle_detection
  • inc
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • idle_detection
  • inc
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • idle_detection
  • inc
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • idle_detection
  • src
project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • idle_detection
  • src
project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
139void USART2_IRQHandler(void)
140{
141 if(usart_flag_get(USART2, USART_IDLEF_FLAG))
142 {
143 usart_data_receive(USART2);
144 at32_led_on(LED2);
145 at32_led_on(LED3);
146 at32_led_on(LED4);
147 }
148}
149
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:139
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:112
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f413_usart.h:54
USART2
#define USART2
Definition: at32f413_usart.h:318
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • idle_detection
  • src
project/at_start_f413/examples/usart/idle_detection/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
41void usart_configuration(void)
42{
43 gpio_init_type gpio_init_struct;
44
45 /* enable the usart2 and gpio clock */
46 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
47 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
48
49 gpio_default_para_init(&gpio_init_struct);
50
51 /* configure the usart2 tx pin */
52 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
55 gpio_init_struct.gpio_pins = GPIO_PINS_2;
56 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
57 gpio_init(GPIOA, &gpio_init_struct);
58
59 /* configure the usart2 rx pin */
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
63 gpio_init_struct.gpio_pins = GPIO_PINS_3;
64 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
65 gpio_init(GPIOA, &gpio_init_struct);
66
67 /* config usart nvic interrupt */
68 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
69 nvic_irq_enable(USART2_IRQn, 0, 0);
70
71 /* configure usart2 param */
72 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
73 usart_transmitter_enable(USART2, TRUE);
74 usart_receiver_enable(USART2, TRUE);
75 usart_interrupt_enable(USART2, USART_IDLE_INT, TRUE);
76 usart_enable(USART2, TRUE);
77}
78
84int main(void)
85{
86 system_clock_config();
87 at32_board_init();
88 at32_led_off(LED2);
89 at32_led_off(LED3);
90 at32_led_off(LED4);
91 usart_configuration();
92
93 /* transmit a data */
94 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
95 usart_data_transmit(USART2, 0x55);
96
97 /* receive a data from the tx pin */
98 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
99 usart_data_receive(USART2);
100
101 while(1)
102 {
103 }
104}
105
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/idle_detection/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/idle_detection/src/main.c:84
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:209
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART_IDLE_INT
#define USART_IDLE_INT
Definition: at32f413_usart.h:70
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • interrupt
  • inc
project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • interrupt
  • inc
project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • interrupt
  • inc
project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • interrupt
  • src
project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • interrupt
  • src
project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern uint8_t usart2_tx_buffer[];
29extern uint8_t usart3_tx_buffer[];
30extern uint8_t usart2_rx_buffer[];
31extern uint8_t usart3_rx_buffer[];
32extern uint8_t usart2_tx_counter;
33extern uint8_t usart3_tx_counter;
34extern uint8_t usart2_rx_counter;
35extern uint8_t usart3_rx_counter;
36extern uint8_t usart2_tx_buffer_size;
37extern uint8_t usart3_tx_buffer_size;
38
52void NMI_Handler(void)
53{
54}
55
61void HardFault_Handler(void)
62{
63 /* go to infinite loop when hard fault exception occurs */
64 while(1)
65 {
66 }
67}
68
74void MemManage_Handler(void)
75{
76 /* go to infinite loop when memory manage exception occurs */
77 while(1)
78 {
79 }
80}
81
87void BusFault_Handler(void)
88{
89 /* go to infinite loop when bus fault exception occurs */
90 while(1)
91 {
92 }
93}
94
100void UsageFault_Handler(void)
101{
102 /* go to infinite loop when usage fault exception occurs */
103 while(1)
104 {
105 }
106}
107
113void SVC_Handler(void)
114{
115}
116
122void DebugMon_Handler(void)
123{
124}
125
131void PendSV_Handler(void)
132{
133}
134
140void SysTick_Handler(void)
141{
142}
143
149void USART2_IRQHandler(void)
150{
151 if(USART2->ctrl1_bit.rdbfien != RESET)
152 {
153 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
154 {
155 /* read one byte from the receive data register */
156 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
157
158 if(usart2_rx_counter == usart3_tx_buffer_size)
159 {
160 /* disable the usart2 receive interrupt */
161 usart_interrupt_enable(USART2, USART_RDBF_INT, FALSE);
162 }
163 }
164 }
165
166 if(USART2->ctrl1_bit.tdbeien != RESET)
167 {
168 if(usart_flag_get(USART2, USART_TDBE_FLAG) != RESET)
169 {
170 /* write one byte to the transmit data register */
171 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
172
173 if(usart2_tx_counter == usart2_tx_buffer_size)
174 {
175 /* disable the usart2 transmit interrupt */
176 usart_interrupt_enable(USART2, USART_TDBE_INT, FALSE);
177 }
178 }
179 }
180}
181
187void USART3_IRQHandler(void)
188{
189 if(USART3->ctrl1_bit.rdbfien != RESET)
190 {
191 if(usart_flag_get(USART3, USART_RDBF_FLAG) != RESET)
192 {
193 /* read one byte from the receive data register */
194 usart3_rx_buffer[usart3_rx_counter++] = usart_data_receive(USART3);
195
196 if(usart3_rx_counter == usart2_tx_buffer_size)
197 {
198 /* disable the usart3 receive interrupt */
199 usart_interrupt_enable(USART3, USART_RDBF_INT, FALSE);
200 }
201 }
202 }
203
204 if(USART3->ctrl1_bit.tdbeien != RESET)
205 {
206 if(usart_flag_get(USART3, USART_TDBE_FLAG) != RESET)
207 {
208 /* write one byte to the transmit data register */
209 usart_data_transmit(USART3, usart3_tx_buffer[usart3_tx_counter++]);
210
211 if(usart3_tx_counter == usart3_tx_buffer_size)
212 {
213 /* disable the usart3 transmit interrupt */
214 usart_interrupt_enable(USART3, USART_TDBE_INT, FALSE);
215 }
216 }
217 }
218}
219
usart3_rx_buffer
uint8_t usart3_rx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:43
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:41
usart2_rx_buffer
uint8_t usart2_rx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:42
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:149
USART3_IRQHandler
void USART3_IRQHandler(void)
this function handles usart3 handler.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:187
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:100
usart3_rx_counter
uint8_t usart3_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:47
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:46
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:61
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:74
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:113
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:44
usart3_tx_counter
uint8_t usart3_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:45
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:48
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:131
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:52
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:87
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:49
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:140
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:122
FALSE
@ FALSE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART_TDBE_INT
#define USART_TDBE_INT
Definition: at32f413_usart.h:73
USART2
#define USART2
Definition: at32f413_usart.h:318
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • interrupt
  • src
project/at_start_f413/examples/usart/interrupt/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
37#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
38#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
39
40uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt";
41uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt";
42uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
43uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
44volatile uint8_t usart2_tx_counter = 0x00;
45volatile uint8_t usart3_tx_counter = 0x00;
46volatile uint8_t usart2_rx_counter = 0x00;
47volatile uint8_t usart3_rx_counter = 0x00;
48uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
49uint8_t usart3_tx_buffer_size = USART3_TX_BUFFER_SIZE;
50
56void usart_configuration(void)
57{
58 gpio_init_type gpio_init_struct;
59
60 /* enable the usart2 and gpio clock */
61 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* enable the usart3 and gpio clock */
65 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 gpio_default_para_init(&gpio_init_struct);
69
70 /* configure the usart2 tx pin */
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_pins = GPIO_PINS_2;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init(GPIOA, &gpio_init_struct);
77
78 /* configure the usart3 tx pin */
79 gpio_init_struct.gpio_pins = GPIO_PINS_10;
80 gpio_init(GPIOB, &gpio_init_struct);
81
82 /* configure the usart2 rx pin */
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
85 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
86 gpio_init_struct.gpio_pins = GPIO_PINS_3;
87 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
88 gpio_init(GPIOA, &gpio_init_struct);
89
90 /* configure the usart3 rx pin */
91 gpio_init_struct.gpio_pins = GPIO_PINS_11;
92 gpio_init(GPIOB, &gpio_init_struct);
93
94 /* config usart nvic interrupt */
95 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
96 nvic_irq_enable(USART2_IRQn, 0, 0);
97 nvic_irq_enable(USART3_IRQn, 0, 0);
98
99 /* configure usart2 param */
100 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
101 usart_transmitter_enable(USART2, TRUE);
102 usart_receiver_enable(USART2, TRUE);
103
104 /* configure usart3 param */
105 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
106 usart_transmitter_enable(USART3, TRUE);
107 usart_receiver_enable(USART3, TRUE);
108
109 /* enable usart2 and usart3 interrupt */
110 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
111 usart_enable(USART2, TRUE);
112
113 usart_interrupt_enable(USART3, USART_RDBF_INT, TRUE);
114 usart_enable(USART3, TRUE);
115
116 usart_interrupt_enable(USART2, USART_TDBE_INT, TRUE);
117 usart_interrupt_enable(USART3, USART_TDBE_INT, TRUE);
118}
119
127uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
128{
129 while(buffer_length--)
130 {
131 if(*pbuffer1 != *pbuffer2)
132 {
133 return 0;
134 }
135 pbuffer1++;
136 pbuffer2++;
137 }
138 return 1;
139}
140
146int main(void)
147{
148 system_clock_config();
149 at32_board_init();
150 usart_configuration();
151
152 /* wait until end of transmission from usart2 to usart3 */
153 while(usart3_rx_counter < usart2_tx_buffer_size);
154
155 /* wait until end of transmission from usart3 to usart2 */
156 while(usart2_rx_counter < usart3_tx_buffer_size);
157
158 while(1)
159 {
160 /* compare data buffer */
161 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
162 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
163 {
164 at32_led_toggle(LED2);
165 at32_led_toggle(LED3);
166 at32_led_toggle(LED4);
167 delay_sec(1);
168 }
169 }
170}
171
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:56
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:127
usart3_rx_counter
volatile uint8_t usart3_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:47
usart2_rx_counter
volatile uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:46
usart2_tx_counter
volatile uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:44
usart3_tx_counter
volatile uint8_t usart3_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:45
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:48
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:43
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:146
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:49
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:40
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:38
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:41
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:42
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:209
USART3_IRQn
@ USART3_IRQn
Definition: at32f413.h:210
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART_TDBE_INT
#define USART_TDBE_INT
Definition: at32f413_usart.h:73
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • irda
  • inc
project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • irda
  • inc
project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • irda
  • inc
project/at_start_f413/examples/usart/irda/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • irda
  • src
project/at_start_f413/examples/usart/irda/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • irda
  • src
project/at_start_f413/examples/usart/irda/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • irda
  • src
project/at_start_f413/examples/usart/irda/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
41void usart_configuration(void)
42{
43 gpio_init_type gpio_init_struct;
44
45 /* enable the usart2 and gpio clock */
46 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
47 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
48
49 gpio_default_para_init(&gpio_init_struct);
50
51 /* configure the usart2 tx pin */
52 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
55 gpio_init_struct.gpio_pins = GPIO_PINS_2;
56 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
57 gpio_init(GPIOA, &gpio_init_struct);
58
59 /* configure the usart2 rx pin */
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
63 gpio_init_struct.gpio_pins = GPIO_PINS_3;
64 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
65 gpio_init(GPIOA, &gpio_init_struct);
66
67 /* configure usart2 param */
68 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
69 usart_transmitter_enable(USART2, TRUE);
70 usart_receiver_enable(USART2, TRUE);
71 usart_irda_smartcard_division_set(USART2, 0x01);
72 usart_irda_mode_enable(USART2, TRUE);
73 usart_enable(USART2, TRUE);
74}
75
81int main(void)
82{
83 system_clock_config();
84 at32_board_init();
85 at32_led_off(LED2);
86 at32_led_off(LED3);
87 at32_led_off(LED4);
88 usart_configuration();
89
90#if defined(TRANSMIT)
91 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
92 usart_data_transmit(USART2, 0x55);
93 at32_led_on(LED4);
94#endif
95
96#if defined(RECEIVE)
97 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
98 if(usart_data_receive(USART2) == 0x55)
99 {
100 at32_led_on(LED4);
101 }
102#endif
103
104 while(1)
105 {
106 }
107}
108
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/irda/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/irda/src/main.c:81
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:431
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f413_usart.c:489
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • polling
  • inc
project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • polling
  • inc
project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • polling
  • inc
project/at_start_f413/examples/usart/polling/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • polling
  • src
project/at_start_f413/examples/usart/polling/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • polling
  • src
project/at_start_f413/examples/usart/polling/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • polling
  • src
project/at_start_f413/examples/usart/polling/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
37#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
38#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
39
40uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt";
41uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt";
42uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
43uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
44uint8_t usart2_tx_counter = 0x00;
45uint8_t usart3_tx_counter = 0x00;
46uint8_t usart2_rx_counter = 0x00;
47uint8_t usart3_rx_counter = 0x00;
48uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
49uint8_t usart3_tx_buffer_size = USART3_TX_BUFFER_SIZE;
50
56void usart_configuration(void)
57{
58 gpio_init_type gpio_init_struct;
59
60 /* enable the usart2 and gpio clock */
61 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* enable the usart3 and gpio clock */
65 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 gpio_default_para_init(&gpio_init_struct);
69
70 /* configure the usart2 tx pin */
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_pins = GPIO_PINS_2;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init(GPIOA, &gpio_init_struct);
77
78 /* configure the usart3 tx pin */
79 gpio_init_struct.gpio_pins = GPIO_PINS_10;
80 gpio_init(GPIOB, &gpio_init_struct);
81
82 /* configure the usart2 rx pin */
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
85 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
86 gpio_init_struct.gpio_pins = GPIO_PINS_3;
87 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
88 gpio_init(GPIOA, &gpio_init_struct);
89
90 /* configure the usart3 rx pin */
91 gpio_init_struct.gpio_pins = GPIO_PINS_11;
92 gpio_init(GPIOB, &gpio_init_struct);
93
94 /* configure usart2 param */
95 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
96 usart_parity_selection_config(USART2, USART_PARITY_NONE);
97 usart_transmitter_enable(USART2, TRUE);
98 usart_receiver_enable(USART2, TRUE);
99 usart_enable(USART2, TRUE);
100
101 /* configure usart3 param */
102 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
103 usart_parity_selection_config(USART3, USART_PARITY_NONE);
104 usart_transmitter_enable(USART3, TRUE);
105 usart_receiver_enable(USART3, TRUE);
106 usart_enable(USART3, TRUE);
107}
108
116uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
117{
118 while(buffer_length--)
119 {
120 if(*pbuffer1 != *pbuffer2)
121 {
122 return 0;
123 }
124 pbuffer1++;
125 pbuffer2++;
126 }
127 return 1;
128}
129
135int main(void)
136{
137 system_clock_config();
138 at32_board_init();
139 usart_configuration();
140
141 /* wait until end of transmission from usart2 to usart3 */
142 while(usart3_rx_counter < usart2_tx_buffer_size)
143 {
144 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
145 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
146
147 while(usart_flag_get(USART3, USART_RDBF_FLAG) == RESET);
148 usart3_rx_buffer[usart3_rx_counter++] = usart_data_receive(USART3);
149 }
150
151 /* wait until end of transmission from usart3 to usart2 */
152 while(usart2_rx_counter < usart3_tx_buffer_size)
153 {
154 while(usart_flag_get(USART3, USART_TDBE_FLAG) == RESET);
155 usart_data_transmit(USART3, usart3_tx_buffer[usart3_tx_counter++]);
156
157 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
158 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
159 }
160
161 while(1)
162 {
163 /* compare data buffer */
164 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
165 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
166 {
167 at32_led_toggle(LED2);
168 at32_led_toggle(LED3);
169 at32_led_toggle(LED4);
170 delay_sec(1);
171 }
172 }
173}
174
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/polling/src/main.c:56
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/polling/src/main.c:116
usart3_tx_counter
uint8_t usart3_tx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:45
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:44
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/polling/src/main.c:48
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:43
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:46
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/polling/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/polling/src/main.c:135
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f413/examples/usart/polling/src/main.c:49
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:40
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/polling/src/main.c:38
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:41
usart3_rx_counter
uint8_t usart3_rx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:47
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:42
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:143
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:92
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • printf
  • inc
project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • printf
  • inc
project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • printf
  • inc
project/at_start_f413/examples/usart/printf/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • printf
  • src
project/at_start_f413/examples/usart/printf/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • printf
  • src
project/at_start_f413/examples/usart/printf/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • printf
  • src
project/at_start_f413/examples/usart/printf/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36__IO uint32_t time_cnt = 0;
37
43int main(void)
44{
45 system_clock_config();
46 at32_board_init();
47 uart_print_init(115200);
48
49 /* output a message on hyperterminal using printf function */
50 printf("usart printf example: retarget the c library printf function to the usart\r\n");
51
52 while(1)
53 {
54 printf("usart printf counter: %u\r\n",time_cnt++);
55 delay_sec(1);
56 }
57}
58
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/printf/src/main.c:43
time_cnt
__IO uint32_t time_cnt
Definition: project/at_start_f413/examples/usart/printf/src/main.c:36
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • receiver_mute
  • inc
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • receiver_mute
  • inc
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • receiver_mute
  • inc
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • receiver_mute
  • src
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • receiver_mute
  • src
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern uint8_t usart3_rx_buffer[];
29extern uint8_t rx_counter;
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void USART3_IRQHandler(void)
142{
143 if(usart_flag_get(USART3, USART_RDBF_FLAG) != RESET)
144 {
145 usart3_rx_buffer[rx_counter++] = usart_data_receive(USART3);
146 }
147}
148
usart3_rx_buffer
uint8_t usart3_rx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:43
USART3_IRQHandler
void USART3_IRQHandler(void)
this function handles usart3 handler.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:141
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:44
rx_counter
uint8_t rx_counter
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:114
RESET
@ RESET
Definition: at32f413.h:291
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • receiver_mute
  • src
project/at_start_f413/examples/usart/receiver_mute/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define BUFFER_SIZE 7
37#define MATCH_ID_VAL 0x81
38#define ERROR_ID_VAL 0x82
39#define DATA1_VAL 0x7F
40#define DATA2_VAL 0x7A
41#define DATA3_VAL 0x7B
42#define DATA4_VAL 0x7C
43
44uint8_t usart2_tx_buffer[BUFFER_SIZE] = {DATA1_VAL, MATCH_ID_VAL, DATA2_VAL, ERROR_ID_VAL, DATA3_VAL, MATCH_ID_VAL, DATA4_VAL};
45uint8_t usart3_rx_buffer[BUFFER_SIZE];
46uint8_t tx_counter = 0;
47uint8_t rx_counter = 0;
48
54void usart_configuration(void)
55{
56 gpio_init_type gpio_init_struct;
57
58 /* enable the usart2 and gpio clock */
59 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
61
62 /* enable the usart3 and gpio clock */
63 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
65
66 gpio_default_para_init(&gpio_init_struct);
67
68 /* configure the usart2 tx pin */
69 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
70 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_pins = GPIO_PINS_2;
73 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
74 gpio_init(GPIOA, &gpio_init_struct);
75
76 /* configure the usart3 rx pin */
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
79 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
80 gpio_init_struct.gpio_pins = GPIO_PINS_11;
81 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
82 gpio_init(GPIOB, &gpio_init_struct);
83
84 /* configure usart2 param */
85 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
86 usart_transmitter_enable(USART2, TRUE);
87 usart_enable(USART2, TRUE);
88
89 /* config usart3 nvic interrupt */
90 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
91 nvic_irq_enable(USART3_IRQn, 0 ,0);
92
93 /* configure usart3 param */
94 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
95 usart_receiver_enable(USART3, TRUE);
96 usart_interrupt_enable(USART3, USART_RDBF_INT, TRUE);
97 usart_wakeup_id_set(USART3, 0x01);
98 usart_wakeup_mode_set(USART3, USART_WAKEUP_BY_MATCHING_ID);
99 usart_receiver_mute_enable(USART3, TRUE);
100 usart_enable(USART3, TRUE);
101}
102
108int main(void)
109{
110 system_clock_config();
111 at32_board_init();
112 usart_configuration();
113
114 /* usart2 transmit data */
115 while(tx_counter < BUFFER_SIZE)
116 {
117 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
118 usart_data_transmit(USART2, usart2_tx_buffer[tx_counter++]);
119 }
120
121 /* wait usart2 data transmission complete */
122 while(usart_flag_get(USART2, USART_TDC_FLAG) == RESET);
123
124 while(1)
125 {
126 if((usart3_rx_buffer[0] == MATCH_ID_VAL) && (usart3_rx_buffer[1] == DATA2_VAL) && \
127 (usart3_rx_buffer[2] == MATCH_ID_VAL) && (usart3_rx_buffer[3] == DATA4_VAL))
128 {
129 at32_led_toggle(LED2);
130 at32_led_toggle(LED3);
131 at32_led_toggle(LED4);
132 delay_sec(1);
133 }
134 }
135}
136
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
DATA4_VAL
#define DATA4_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:42
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:54
usart2_tx_buffer
uint8_t usart2_tx_buffer[7]
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:44
ERROR_ID_VAL
#define ERROR_ID_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:38
tx_counter
uint8_t tx_counter
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:46
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:36
rx_counter
uint8_t rx_counter
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:47
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:108
DATA2_VAL
#define DATA2_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:40
DATA3_VAL
#define DATA3_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:41
MATCH_ID_VAL
#define MATCH_ID_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:37
usart3_rx_buffer
uint8_t usart3_rx_buffer[7]
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:45
DATA1_VAL
#define DATA1_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
USART3_IRQn
@ USART3_IRQn
Definition: at32f413.h:210
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f413_usart.c:306
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f413_usart.c:322
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f413_usart.c:336
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_WAKEUP_BY_MATCHING_ID
@ USART_WAKEUP_BY_MATCHING_ID
Definition: at32f413_usart.h:103
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:56
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • rs485
  • inc
project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • rs485
  • inc
project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • rs485
  • inc
project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • rs485
  • src
project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • rs485
  • src
project/at_start_f413/examples/usart/rs485/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • rs485
  • src
project/at_start_f413/examples/usart/rs485/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define RS485_BAUDRATE 9600
37#define RS485_BUFFER_SIZE 128
38
39uint8_t rs485_buffer_rx[RS485_BUFFER_SIZE];
40uint8_t rs485_buffer_rx_cnt = 0;
41
47static void rs485_config(void)
48{
49 gpio_init_type gpio_init_struct;
50
51 /* enable the uart2 and gpio clock */
52 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
54
55 gpio_default_para_init(&gpio_init_struct);
56
57 /* configure the uart2 tx,rx,de pin */
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
61 gpio_init_struct.gpio_pins = GPIO_PINS_2;
62 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
63 gpio_init(GPIOA, &gpio_init_struct);
64
65 gpio_init_struct.gpio_pins = GPIO_PINS_3;
66 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
67 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
68 gpio_init(GPIOA, &gpio_init_struct);
69
70 gpio_init_struct.gpio_pins = GPIO_PINS_1;
71 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 gpio_bits_reset(GPIOA, GPIO_PINS_1);
76
77 /* configure uart2 param */
78 usart_init(USART2, RS485_BAUDRATE, USART_DATA_8BITS, USART_STOP_1_BIT);
79
80 usart_flag_clear(USART2, USART_RDBF_FLAG);
81 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
82
83 usart_receiver_enable(USART2, TRUE);
84 usart_transmitter_enable(USART2, TRUE);
85 usart_enable(USART2, TRUE);
86
87 nvic_irq_enable(USART2_IRQn, 1, 0);
88}
89
96static void rs485_send_data(u8* buf, u8 cnt)
97{
98 gpio_bits_set(GPIOA, GPIO_PINS_1);
99 while(cnt--){
100 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
101 usart_data_transmit(USART2, *buf++);
102 }
103 while(usart_flag_get(USART2, USART_TDC_FLAG) == RESET);
104 gpio_bits_reset(GPIOA, GPIO_PINS_1);
105}
106
112int main(void)
113{
114 char str[]="start test..\r\n";
115 u8 len = 0;
116
117 system_clock_config();
118 at32_board_init();
119 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
120
121 rs485_config();
122
123 len = sizeof(str);
124 rs485_send_data((u8*)str, len);
125 while(1)
126 {
127 if(usart_flag_get(USART2, USART_IDLEF_FLAG) != RESET)
128 {
129 usart_data_receive(USART2);
130 usart_interrupt_enable(USART2, USART_RDBF_INT, FALSE);
131 rs485_send_data(rs485_buffer_rx, rs485_buffer_rx_cnt);
132 rs485_buffer_rx_cnt = 0;
133 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
134 }
135 }
136}
137
143void USART2_IRQHandler(void)
144{
145 uint16_t tmp;
146
147 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
148 {
149 tmp = usart_data_receive(USART2);
150 if(rs485_buffer_rx_cnt < RS485_BUFFER_SIZE)
151 {
152 rs485_buffer_rx[rs485_buffer_rx_cnt++] = tmp;
153 }
154 }
155}
156
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:209
u8
uint8_t u8
Definition: at32f413.h:274
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
USART2_IRQHandler
void USART2_IRQHandler(void)
usart2 interrupt handler
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:143
rs485_send_data
static void rs485_send_data(u8 *buf, u8 cnt)
rs485 send data
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:96
RS485_BAUDRATE
#define RS485_BAUDRATE
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:36
rs485_config
static void rs485_config(void)
rs485 configiguration.
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:47
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:112
rs485_buffer_rx
uint8_t rs485_buffer_rx[128]
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:39
RS485_BUFFER_SIZE
#define RS485_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:37
rs485_buffer_rx_cnt
uint8_t rs485_buffer_rx_cnt
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:40
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:50
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f413_usart.c:602
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f413_usart.h:54
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:56
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • smartcard
  • inc
project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • smartcard
  • inc
project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • smartcard
  • inc
project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • smartcard
  • src
project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • smartcard
  • src
project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "smartcard_config.h"
28
29extern uint32_t card_inserted;
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void EXINT9_5_IRQHandler(void)
142{
143 /* reset smart card cmdvcc */
144 gpio_bits_reset(SC_CMDVCC_PORT, SC_CMDVCC_PIN);
145
146 /* rst low */
147 gpio_bits_reset(SC_RESET_PORT, SC_RESET_PIN);
148
149 /* rst high */
150 gpio_bits_set(SC_RESET_PORT, SC_RESET_PIN);
151
152 /* clear sc exint line pending bit */
153 exint_flag_clear(SC_OFF_EXINT);
154
155 /* smart card detected */
156 card_inserted = 1;
157}
158
164void SC_USART_IRQHandler(void)
165{
166 /* if the sc_usart detects a parity error */
167 if(usart_flag_get(SC_USART, USART_PERR_FLAG) != RESET)
168 {
169 /* enable sc_usart rdbf interrupt (until receiving the corrupted byte) */
170 usart_interrupt_enable(SC_USART, USART_RDBF_INT, TRUE);
171 /* flush the sc_usart dr register */
172 usart_data_receive(SC_USART);
173 }
174
175 if(usart_flag_get(SC_USART, USART_RDBF_FLAG) != RESET)
176 {
177 /* disable sc_usart rdbf interrupt */
178 usart_interrupt_enable(SC_USART, USART_RDBF_INT, FALSE);
179 usart_data_receive(SC_USART);
180 }
181}
182
EXINT9_5_IRQHandler
void EXINT9_5_IRQHandler(void)
this function handles external lines 9 to 5 interrupt request.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:141
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:105
SC_USART_IRQHandler
void SC_USART_IRQHandler(void)
this function handles sc_usart global interrupt request.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:164
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:79
card_inserted
uint32_t card_inserted
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:61
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:114
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:339
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_PERR_FLAG
#define USART_PERR_FLAG
Definition: at32f413_usart.h:50
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
smartcard_config.h
header file of clock program
SC_RESET_PIN
#define SC_RESET_PIN
Definition: smartcard_config.h:46
SC_RESET_PORT
#define SC_RESET_PORT
Definition: smartcard_config.h:50
SC_OFF_EXINT
#define SC_OFF_EXINT
Definition: smartcard_config.h:57
SC_USART
#define SC_USART
Definition: smartcard_config.h:34
SC_CMDVCC_PORT
#define SC_CMDVCC_PORT
Definition: smartcard_config.h:51
SC_CMDVCC_PIN
#define SC_CMDVCC_PIN
Definition: smartcard_config.h:47
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • smartcard
  • src
project/at_start_f413/examples/usart/smartcard/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "smartcard_config.h"
28
37#define T0_PROTOCOL 0x00 /* t0 protocol */
38#define SETUP_LENGTH 20
39#define HIST_LENGTH 20
40#define SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
41
42#define SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
43#define SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */
44
45/* atr structure - answer to reset */
46typedef struct
47{
48 uint8_t ts; /* bit convention */
49 uint8_t t0; /* high nibble = n. of setup byte; low nibble = n. of historical byte */
50 uint8_t t[SETUP_LENGTH]; /* setup array */
51 uint8_t h[HIST_LENGTH]; /* historical array */
52 uint8_t tlength; /* setup array dimension */
53 uint8_t hlength; /* historical array dimension */
54} sc_atr_type;
55
56 sc_atr_type sc_a2r_struct;
57uint32_t sc_baud_rate = 0;
58uint32_t sc_clock_freq = 0;
59uint32_t counter = 0;
60 error_status atr_decode_status = ERROR;
61uint32_t card_inserted = 0, card_protocol = 1;
62uint8_t dst_buffer[50]= {
63 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
64 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
65 1, 1, 1, 1, 1, 1, 1, 1, 1, 1
66 };
67
73void usart_configuration(void)
74{
75 gpio_init_type gpio_init_struct;
76 exint_init_type exint_init_struct;
77 crm_clocks_freq_type crm_clocks_struct;
78
79 /* enable gpio_3_5v, sc_usart_gpio_clk, gpio_reset, gpio_cmdvcc, gpio_off and iomux clocks */
80 crm_periph_clock_enable(SC_3_5V_CLK, TRUE);
81 crm_periph_clock_enable(SC_USART_GPIO_CLK, TRUE);
82 crm_periph_clock_enable(SC_RESET_CLK, TRUE);
83 crm_periph_clock_enable(SC_CMDVCC_CLK, TRUE);
84 crm_periph_clock_enable(SC_OFF_CLK, TRUE);
85 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
86
87 /* enable sc_usart clocks */
88 crm_periph_clock_enable(SC_USART_CLK, TRUE);
89
90 gpio_default_para_init(&gpio_init_struct);
91 /* configure sc_usart ck pin */
92 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
93 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
94 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
95 gpio_init_struct.gpio_pins = SC_USART_CLK_PIN;
96 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
97 gpio_init(SC_USART_CLK_PORT, &gpio_init_struct);
98
99 /* configure sc_usart tx pin */
100 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
101 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
102 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
103 gpio_init_struct.gpio_pins = SC_USART_TX_PIN;
104 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
105 gpio_init(SC_USART_TX_PORT, &gpio_init_struct);
106
107 /* configure smartcard reset pin */
108 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
109 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
110 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
111 gpio_init_struct.gpio_pins = SC_RESET_PIN;
112 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
113 gpio_init(SC_RESET_PORT, &gpio_init_struct);
114
115 /* set reset pin high */
116 gpio_bits_set(SC_RESET_PORT, SC_RESET_PIN);
117
118 /* configure smartcard 3/5v pin */
119 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
120 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
121 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
122 gpio_init_struct.gpio_pins = SC_3_5V_PIN;
123 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
124 gpio_init(SC_3_5V_PORT, &gpio_init_struct);
125
126 /* select 5 v */
127 gpio_bits_set(SC_3_5V_PORT, SC_3_5V_PIN);
128
129 /* configure smartcard cmdvcc pin */
130 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
131 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
132 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
133 gpio_init_struct.gpio_pins = SC_CMDVCC_PIN;
134 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
135 gpio_init(SC_CMDVCC_PORT, &gpio_init_struct);
136
137 /* set smartcard cmdvcc */
138 gpio_bits_set(SC_CMDVCC_PORT, SC_CMDVCC_PIN);
139
140 /* configure smartcard off pin */
141 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
142 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
143 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
144 gpio_init_struct.gpio_pins = SC_OFF_PIN;
145 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
146 gpio_init(SC_OFF_PORT, &gpio_init_struct);
147
148 /* nvic interrupt init */
149 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
150 NVIC_ClearPendingIRQ(SC_OFF_EXINT_IRQ);
151 nvic_irq_enable(SC_OFF_EXINT_IRQ, 0, 0);
152 nvic_irq_enable(SC_USART_IRQn, 1, 0);
153
154 /* configure smartcard off exint */
155 gpio_exint_line_config(SC_OFF_PORTSOURCE, SC_OFF_PINSOURCE);
156
157 exint_default_para_init(&exint_init_struct);
158 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
159 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
160 exint_init_struct.line_select = SC_OFF_EXINT;
161 exint_init_struct.line_enable = TRUE;
162 exint_init(&exint_init_struct);
163
164 /* clear sc exint line pending bit */
165 exint_flag_clear(SC_OFF_EXINT);
166
167 /* sc_usart clock set to (apbclk / (2 * SC_USART_DIV_VAL)) */
168 usart_irda_smartcard_division_set(SC_USART, SC_USART_DIV_VAL);
169 /* sc_usart guard time set to 2 bit */
170 usart_smartcard_guard_time_set(SC_USART, 0x2);
171
172 /* configure sc usart clk */
173 usart_clock_enable(SC_USART, TRUE);
174
175 crm_clocks_freq_get(&crm_clocks_struct);
176 sc_clock_freq = crm_clocks_struct.apb1_freq / (2 * SC_USART_DIV_VAL); /* ISO 7816-3 protocol: the CLK frequency is between 1 and 5 MHz */
177 sc_baud_rate = sc_clock_freq / SC_F_DIV_D;
178 /* configure sc usart param */
179 usart_init(SC_USART, sc_baud_rate, USART_DATA_9BITS, USART_STOP_1_5_BIT);
180 usart_parity_selection_config(SC_USART, USART_PARITY_EVEN);
181 usart_transmitter_enable(SC_USART, TRUE);
182 usart_receiver_enable(SC_USART, TRUE);
183
184 /* enable the sc_usart parity error interrupt */
185 usart_interrupt_enable(SC_USART, USART_PERR_INT, TRUE);
186 usart_enable(SC_USART, TRUE);
187
188 /* enable the nack transmission */
189 usart_smartcard_nack_set(SC_USART, TRUE);
190
191 /* enable the smartcard mode */
192 usart_smartcard_mode_enable(SC_USART, TRUE);
193}
194
200uint8_t sc_response_decode(__IO uint8_t *card)
201{
202 uint32_t i = 0, flag = 0, buf = 0, protocol = 0;
203
204 sc_a2r_struct.ts = 0;
205 sc_a2r_struct.t0 = 0;
206 for(i = 0; i < SETUP_LENGTH; i++)
207 {
208 sc_a2r_struct.t[i] = 0;
209 }
210 for(i = 0;i < HIST_LENGTH; i++)
211 {
212 sc_a2r_struct.h[i] = 0;
213 }
214 sc_a2r_struct.tlength = 0;
215 sc_a2r_struct.hlength = 0;
216
217 /* initial character */
218 sc_a2r_struct.ts = card[0];
219
220 /* format character */
221 sc_a2r_struct.t0 = card[1];
222
223 sc_a2r_struct.hlength = sc_a2r_struct.t0 & 0x0F;
224
225 if((sc_a2r_struct.t0 & 0x80) == 0x80) flag = 1;
226
227 for(i = 0; i < 4; i++)
228 {
229 sc_a2r_struct.tlength = sc_a2r_struct.tlength + (((sc_a2r_struct.t0 & 0xF0) >> (4 + i)) & 0x1);
230 }
231
232 for(i = 0; i < sc_a2r_struct.tlength; i++)
233 {
234 sc_a2r_struct.t[i] = card[i + 2];
235 }
236
237 protocol = sc_a2r_struct.t[sc_a2r_struct.tlength - 1] & 0x0F;
238
239 while(flag)
240 {
241 if((sc_a2r_struct.t[sc_a2r_struct.tlength - 1] & 0x80)== 0x80)
242 {
243 flag = 1;
244 }
245 else
246 {
247 flag = 0;
248 }
249 buf = sc_a2r_struct.tlength;
250 sc_a2r_struct.tlength = 0;
251
252 for(i = 0; i < 4; i++)
253 {
254 sc_a2r_struct.tlength = sc_a2r_struct.tlength + (((sc_a2r_struct.t[buf - 1] & 0xF0) >> (4 + i)) & 0x1);
255 }
256 for(i = 0; i < sc_a2r_struct.tlength; i++)
257 {
258 sc_a2r_struct.t[buf + i] = card[i + 2 + buf];
259 }
260 sc_a2r_struct.tlength += buf;
261 }
262
263 for(i = 0;i < sc_a2r_struct.hlength; i++)
264 {
265 sc_a2r_struct.h[i] = card[i + 2 + sc_a2r_struct.tlength];
266 }
267
268 return ((uint8_t)protocol);
269}
270
276int main(void)
277{
278 uint32_t index = 0;
279 system_clock_config();
280 at32_board_init();
281 usart_configuration();
282
283 /* loop while no smartcard is detected */
284 while(card_inserted == 0)
285 {
286 }
287
288 /* read smartcard atr response */
289 for(index = 0; index < 40; index++, counter = 0)
290 {
291 while((usart_flag_get(SC_USART, USART_RDBF_FLAG) == RESET) && (counter != SC_RECEIVE_TIMEOUT))
292 {
293 counter++;
294 }
295
296 if(counter != SC_RECEIVE_TIMEOUT)
297 {
298 dst_buffer[index] = usart_data_receive(SC_USART);
299 }
300 }
301
302 /* decode atr */
303 card_protocol = sc_response_decode(dst_buffer);
304
305 /* test if the inserted card is iso7816-3 t=0 compatible */
306 if(card_protocol == 0)
307 {
308 /* inserted card is iso7816-3 t=0 compatible */
309 atr_decode_status = SUCCESS;
310 }
311 else
312 {
313 /* inserted smartcard is not iso7816-3 t=0 compatible */
314 atr_decode_status = ERROR;
315 }
316
317 /* judge whether the result is correct */
318 if(atr_decode_status == SUCCESS)
319 {
320 /* trun on the led */
321 at32_led_on(LED2);
322 at32_led_on(LED3);
323 at32_led_on(LED4);
324 }
325
326 while(1)
327 {
328 }
329}
330
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
sc_baud_rate
uint32_t sc_baud_rate
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:73
sc_response_decode
uint8_t sc_response_decode(__IO uint8_t *card)
decode the card atr response.
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:200
card_protocol
uint32_t card_protocol
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:61
counter
uint32_t counter
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:59
SETUP_LENGTH
#define SETUP_LENGTH
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:38
SC_USART_DIV_VAL
#define SC_USART_DIV_VAL
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:42
sc_a2r_struct
sc_atr_type sc_a2r_struct
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:56
SC_F_DIV_D
#define SC_F_DIV_D
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:43
atr_decode_status
error_status atr_decode_status
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:60
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:276
card_inserted
uint32_t card_inserted
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:61
dst_buffer
uint8_t dst_buffer[50]
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:62
SC_RECEIVE_TIMEOUT
#define SC_RECEIVE_TIMEOUT
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:40
sc_clock_freq
uint32_t sc_clock_freq
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:58
HIST_LENGTH
#define HIST_LENGTH
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:577
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
error_status
error_status
error status
Definition: at32f413.h:301
ERROR
@ ERROR
Definition: at32f413.h:301
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:308
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:234
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:238
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f413_usart.c:461
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:143
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:431
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f413_usart.c:417
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f413_usart.c:446
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f413_usart.h:159
USART_DATA_9BITS
@ USART_DATA_9BITS
Definition: at32f413_usart.h:112
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:93
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART_PERR_INT
#define USART_PERR_INT
Definition: at32f413_usart.h:74
smartcard_config.h
header file of clock program
SC_RESET_PIN
#define SC_RESET_PIN
Definition: smartcard_config.h:46
SC_USART_TX_PIN
#define SC_USART_TX_PIN
Definition: smartcard_config.h:37
SC_RESET_PORT
#define SC_RESET_PORT
Definition: smartcard_config.h:50
SC_3_5V_PORT
#define SC_3_5V_PORT
Definition: smartcard_config.h:49
SC_RESET_CLK
#define SC_RESET_CLK
Definition: smartcard_config.h:54
SC_USART_CLK_PIN
#define SC_USART_CLK_PIN
Definition: smartcard_config.h:39
SC_OFF_EXINT
#define SC_OFF_EXINT
Definition: smartcard_config.h:57
SC_USART
#define SC_USART
Definition: smartcard_config.h:34
SC_OFF_CLK
#define SC_OFF_CLK
Definition: smartcard_config.h:56
SC_CMDVCC_CLK
#define SC_CMDVCC_CLK
Definition: smartcard_config.h:55
SC_USART_GPIO_CLK
#define SC_USART_GPIO_CLK
Definition: smartcard_config.h:36
SC_3_5V_PIN
#define SC_3_5V_PIN
Definition: smartcard_config.h:45
SC_OFF_PIN
#define SC_OFF_PIN
Definition: smartcard_config.h:48
SC_CMDVCC_PORT
#define SC_CMDVCC_PORT
Definition: smartcard_config.h:51
SC_USART_IRQn
#define SC_USART_IRQn
Definition: smartcard_config.h:41
SC_USART_CLK_PORT
#define SC_USART_CLK_PORT
Definition: smartcard_config.h:40
SC_3_5V_CLK
#define SC_3_5V_CLK
Definition: smartcard_config.h:53
SC_USART_TX_PORT
#define SC_USART_TX_PORT
Definition: smartcard_config.h:38
SC_OFF_PORTSOURCE
#define SC_OFF_PORTSOURCE
Definition: smartcard_config.h:58
SC_OFF_EXINT_IRQ
#define SC_OFF_EXINT_IRQ
Definition: smartcard_config.h:60
SC_USART_CLK
#define SC_USART_CLK
Definition: smartcard_config.h:35
SC_CMDVCC_PIN
#define SC_CMDVCC_PIN
Definition: smartcard_config.h:47
SC_OFF_PORT
#define SC_OFF_PORT
Definition: smartcard_config.h:52
SC_OFF_PINSOURCE
#define SC_OFF_PINSOURCE
Definition: smartcard_config.h:59
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:469
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:473
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
sc_atr_type
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:47
sc_atr_type::t
uint8_t t[20]
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:50
sc_atr_type::h
uint8_t h[20]
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:51
sc_atr_type::ts
uint8_t ts
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:48
sc_atr_type::tlength
uint8_t tlength
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:52
sc_atr_type::hlength
uint8_t hlength
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:53
sc_atr_type::t0
uint8_t t0
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:49
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • synchronous
  • inc
project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • synchronous
  • inc
project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • synchronous
  • inc
project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • synchronous
  • src
project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • synchronous
  • src
project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • synchronous
  • src
project/at_start_f413/examples/usart/synchronous/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
37#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
38#define SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)
39#define DYMMY_BYTE 0x00
40
41uint8_t usart2_tx_buffer[] = "usart synchronous example: usart2 -> spi2";
42uint8_t spi2_tx_buffer[] = "usart synchronous example: spi2 -> usart2";
43uint8_t usart2_rx_buffer[SPI2_TX_BUFFER_SIZE];
44uint8_t spi2_rx_buffer[USART2_TX_BUFFER_SIZE];
45uint8_t usart2_tx_counter = 0x00;
46uint8_t spi2_tx_counter = 0x00;
47uint8_t usart2_rx_counter = 0x00;
48uint8_t spi2_rx_counter = 0x00;
49uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
50uint8_t spi2_tx_buffer_size = SPI2_TX_BUFFER_SIZE;
51
57void usart_spi_configuration(void)
58{
59 gpio_init_type gpio_init_struct;
60 spi_init_type spi_init_struct;
61
62 /* enable the usart2 and gpio clock */
63 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* enable the spi2 and gpio clock */
67 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 gpio_default_para_init(&gpio_init_struct);
71
72 /* configure the usart2 tx and ck pin */
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
76 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 /* configure the usart2 rx pin */
81 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
82 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
83 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
84 gpio_init_struct.gpio_pins = GPIO_PINS_3;
85 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
86 gpio_init(GPIOA, &gpio_init_struct);
87
88 /* configure the spi2 mosi and ck pin */
89 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
90 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
91 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
92 gpio_init_struct.gpio_pins = GPIO_PINS_15 | GPIO_PINS_13;
93 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
94 gpio_init(GPIOB, &gpio_init_struct);
95
96 /* configure the spi2 miso pin */
97 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
98 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
99 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
100 gpio_init_struct.gpio_pins = GPIO_PINS_14;
101 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
102 gpio_init(GPIOB, &gpio_init_struct);
103
104 /* configure usart2 param */
105 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
106 usart_clock_config(USART2, USART_CLOCK_POLARITY_HIGH, USART_CLOCK_PHASE_2EDGE, USART_CLOCK_LAST_BIT_OUTPUT);
107 usart_clock_enable(USART2, TRUE);
108 usart_transmitter_enable(USART2, TRUE);
109 usart_receiver_enable(USART2, TRUE);
110 usart_enable(USART2, TRUE);
111
112 /* configure spi2 param */
113 spi_default_para_init(&spi_init_struct);
114 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
115 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
116 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
117 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
118 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
119 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
120 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
121 spi_init(SPI2, &spi_init_struct);
122 spi_enable(SPI2, TRUE);
123}
124
132uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
133{
134 while(buffer_length--)
135 {
136 if(*pbuffer1 != *pbuffer2)
137 {
138 return 0;
139 }
140 pbuffer1++;
141 pbuffer2++;
142 }
143 return 1;
144}
145
151int main(void)
152{
153 system_clock_config();
154 at32_board_init();
155 usart_spi_configuration();
156
157 /* wait until end of transmission from usart2 to spi2 */
158 while(spi2_rx_counter < usart2_tx_buffer_size)
159 {
160 /* usart transmit data */
161 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
162 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
163
164 /* wait until spi receive data */
165 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
166 spi2_rx_buffer[spi2_rx_counter++] = spi_i2s_data_receive(SPI2);
167
168 /* wait until usart receive data, and clear dummy byte in data register */
169 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
170 usart_data_receive(USART2);
171 }
172
173 /* wait until end of transmission from spi2 to usart2 */
174 while(usart2_rx_counter < spi2_tx_buffer_size)
175 {
176 /* spi put transmit data in data register */
177 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
178 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[spi2_tx_counter++]);
179
180 /* usart transmit a dummy byte to generate clock to slave */
181 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
182 usart_data_transmit(USART2, DYMMY_BYTE);
183
184 /* wait until usart receive data */
185 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
186 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
187 }
188
189 while(1)
190 {
191 /* compare data buffer */
192 if(buffer_compare(usart2_tx_buffer, spi2_rx_buffer, USART2_TX_BUFFER_SIZE) && \
193 buffer_compare(spi2_tx_buffer, usart2_rx_buffer, SPI2_TX_BUFFER_SIZE))
194 {
195 at32_led_toggle(LED2);
196 at32_led_toggle(LED3);
197 at32_led_toggle(LED4);
198 delay_sec(1);
199 }
200 }
201}
202
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
spi2_tx_buffer
uint8_t spi2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:42
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:132
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:45
usart_spi_configuration
void usart_spi_configuration(void)
config usart and spi
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:57
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:43
spi2_rx_counter
uint8_t spi2_rx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:48
SPI2_TX_BUFFER_SIZE
#define SPI2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:38
DYMMY_BYTE
#define DYMMY_BYTE
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:39
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:49
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:47
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:151
spi2_tx_buffer_size
uint8_t spi2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:50
spi2_rx_buffer
uint8_t spi2_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:44
spi2_tx_counter
uint8_t spi2_tx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:46
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:53
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:96
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:150
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:106
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:158
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
SPI2
#define SPI2
Definition: at32f413_spi.h:447
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:238
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f413_usart.c:222
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
USART_CLOCK_POLARITY_HIGH
@ USART_CLOCK_POLARITY_HIGH
Definition: at32f413_usart.h:139
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f413_usart.h:148
USART_CLOCK_PHASE_2EDGE
@ USART_CLOCK_PHASE_2EDGE
Definition: at32f413_usart.h:130
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART2
#define USART2
Definition: at32f413_usart.h:318
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28extern uint8_t usart2_tx_dma_status;
29extern uint8_t usart2_rx_dma_status;
30extern uint8_t usart3_tx_dma_status;
31extern uint8_t usart3_rx_dma_status;
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void DMA1_Channel1_IRQHandler(void)
144{
145 if(dma_flag_get(DMA1_FDT1_FLAG))
146 {
147 usart2_tx_dma_status = 1;
148 dma_flag_clear(DMA1_FDT1_FLAG);
149 dma_channel_enable(DMA1_CHANNEL1, FALSE);
150 }
151}
152
158void DMA1_Channel2_IRQHandler(void)
159{
160 if(dma_flag_get(DMA1_FDT2_FLAG))
161 {
162 usart2_rx_dma_status = 1;
163 dma_flag_clear(DMA1_FDT2_FLAG);
164 dma_channel_enable(DMA1_CHANNEL2, FALSE);
165 }
166}
167
173void DMA1_Channel3_IRQHandler(void)
174{
175 if(dma_flag_get(DMA1_FDT3_FLAG))
176 {
177 usart3_tx_dma_status = 1;
178 dma_flag_clear(DMA1_FDT3_FLAG);
179 dma_channel_enable(DMA1_CHANNEL3, FALSE);
180 }
181}
182
188void DMA1_Channel4_IRQHandler(void)
189{
190 if(dma_flag_get(DMA1_FDT4_FLAG))
191 {
192 usart3_rx_dma_status = 1;
193 dma_flag_clear(DMA1_FDT4_FLAG);
194 dma_channel_enable(DMA1_CHANNEL4, FALSE);
195 }
196}
197
DMA1_Channel2_IRQHandler
void DMA1_Channel2_IRQHandler(void)
this function handles dma1 channel2 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:158
usart3_tx_dma_status
uint8_t usart3_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:46
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:94
usart2_tx_dma_status
uint8_t usart2_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:44
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:46
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1 channel1 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:143
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:81
usart2_rx_dma_status
uint8_t usart2_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:45
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:188
usart3_rx_dma_status
uint8_t usart3_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:47
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:173
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:116
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:84
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:88
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:479
FALSE
@ FALSE
Definition: at32f413.h:296
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
37#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
38#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
39
40uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma";
41uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma";
42uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
43uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
44volatile uint8_t usart2_tx_dma_status = 0;
45volatile uint8_t usart2_rx_dma_status = 0;
46volatile uint8_t usart3_tx_dma_status = 0;
47volatile uint8_t usart3_rx_dma_status = 0;
48
54void usart_configuration(void)
55{
56 gpio_init_type gpio_init_struct;
57
58 /* enable the usart2 and gpio clock */
59 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
61
62 /* enable the usart3 and gpio clock */
63 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
65
66 gpio_default_para_init(&gpio_init_struct);
67 /* configure the usart2 tx pin */
68 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
70 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
71 gpio_init_struct.gpio_pins = GPIO_PINS_2;
72 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 /* configure the usart3 tx pin */
76 gpio_init_struct.gpio_pins = GPIO_PINS_10;
77 gpio_init(GPIOB, &gpio_init_struct);
78
79 /* configure the usart2 rx pin */
80 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
81 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
82 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
83 gpio_init_struct.gpio_pins = GPIO_PINS_3;
84 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
85 gpio_init(GPIOA, &gpio_init_struct);
86
87 /* configure the usart3 rx pin */
88 gpio_init_struct.gpio_pins = GPIO_PINS_11;
89 gpio_init(GPIOB, &gpio_init_struct);
90
91 /* configure usart2 param */
92 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
93 usart_transmitter_enable(USART2, TRUE);
94 usart_receiver_enable(USART2, TRUE);
95 usart_dma_transmitter_enable(USART2, TRUE);
96 usart_dma_receiver_enable(USART2, TRUE);
97 usart_enable(USART2, TRUE);
98
99 /* configure usart3 param */
100 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
101 usart_transmitter_enable(USART3, TRUE);
102 usart_receiver_enable(USART3, TRUE);
103 usart_dma_transmitter_enable(USART3, TRUE);
104 usart_dma_receiver_enable(USART3, TRUE);
105 usart_enable(USART3, TRUE);
106}
107
113void dma_configuration(void)
114{
115 dma_init_type dma_init_struct;
116
117 /* enable dma1 clock */
118 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
119
120 /* dma1 channel1 for usart2 tx configuration */
121 dma_reset(DMA1_CHANNEL1);
122 dma_default_para_init(&dma_init_struct);
123 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
124 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
125 dma_init_struct.memory_base_addr = (uint32_t)usart2_tx_buffer;
126 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
127 dma_init_struct.memory_inc_enable = TRUE;
128 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
129 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
130 dma_init_struct.peripheral_inc_enable = FALSE;
131 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
132 dma_init_struct.loop_mode_enable = FALSE;
133 dma_init(DMA1_CHANNEL1, &dma_init_struct);
134
135 /* enable transfer full data interrupt */
136 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
137
138 /* dma1 channel1 interrupt nvic init */
139 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
140
141 /* config flexible dma for usart2 tx */
142 dma_flexible_config(DMA1, FLEX_CHANNEL1, DMA_FLEXIBLE_UART2_TX);
143
144 /* dma1 channel2 for usart2 rx configuration */
145 dma_reset(DMA1_CHANNEL2);
146 dma_default_para_init(&dma_init_struct);
147 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
148 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
149 dma_init_struct.memory_base_addr = (uint32_t)usart2_rx_buffer;
150 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
151 dma_init_struct.memory_inc_enable = TRUE;
152 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
153 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
154 dma_init_struct.peripheral_inc_enable = FALSE;
155 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
156 dma_init_struct.loop_mode_enable = FALSE;
157 dma_init(DMA1_CHANNEL2, &dma_init_struct);
158
159 /* enable transfer full data interrupt */
160 dma_interrupt_enable(DMA1_CHANNEL2, DMA_FDT_INT, TRUE);
161
162 /* dma1 channel2 interrupt nvic init */
163 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
164
165 /* config flexible dma for usart2 rx */
166 dma_flexible_config(DMA1, FLEX_CHANNEL2, DMA_FLEXIBLE_UART2_RX);
167
168 /* dma1 channel3 for usart3 tx configuration */
169 dma_reset(DMA1_CHANNEL3);
170 dma_default_para_init(&dma_init_struct);
171 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
172 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
173 dma_init_struct.memory_base_addr = (uint32_t)usart3_tx_buffer;
174 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
175 dma_init_struct.memory_inc_enable = TRUE;
176 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
177 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
178 dma_init_struct.peripheral_inc_enable = FALSE;
179 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
180 dma_init_struct.loop_mode_enable = FALSE;
181 dma_init(DMA1_CHANNEL3, &dma_init_struct);
182
183 /* enable transfer full data interrupt */
184 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
185
186 /* dma1 channel3 interrupt nvic init */
187 nvic_irq_enable(DMA1_Channel3_IRQn, 0, 0);
188
189 /* config flexible dma for usart3 tx */
190 dma_flexible_config(DMA1, FLEX_CHANNEL3, DMA_FLEXIBLE_UART3_TX);
191
192 /* dma1 channel4 for usart3 rx configuration */
193 dma_reset(DMA1_CHANNEL4);
194 dma_default_para_init(&dma_init_struct);
195 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
196 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
197 dma_init_struct.memory_base_addr = (uint32_t)usart3_rx_buffer;
198 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
199 dma_init_struct.memory_inc_enable = TRUE;
200 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
201 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
202 dma_init_struct.peripheral_inc_enable = FALSE;
203 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
204 dma_init_struct.loop_mode_enable = FALSE;
205 dma_init(DMA1_CHANNEL4, &dma_init_struct);
206
207 /* enable transfer full data interrupt */
208 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
209
210 /* dma1 channel4 interrupt nvic init */
211 nvic_irq_enable(DMA1_Channel4_IRQn, 0, 0);
212
213 /* config flexible dma for usart3 rx */
214 dma_flexible_config(DMA1, FLEX_CHANNEL4, DMA_FLEXIBLE_UART3_RX);
215
216 dma_channel_enable(DMA1_CHANNEL2, TRUE); /* usart2 rx begin dma receiving */
217 dma_channel_enable(DMA1_CHANNEL4, TRUE); /* usart3 rx begin dma receiving */
218 dma_channel_enable(DMA1_CHANNEL1, TRUE); /* usart2 tx begin dma transmitting */
219 dma_channel_enable(DMA1_CHANNEL3, TRUE); /* usart3 tx begin dma transmitting */
220}
221
229uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
230{
231 while(buffer_length--)
232 {
233 if(*pbuffer1 != *pbuffer2)
234 {
235 return 0;
236 }
237 pbuffer1++;
238 pbuffer2++;
239 }
240 return 1;
241}
242
248int main(void)
249{
250 system_clock_config();
251 at32_board_init();
252 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
253 usart_configuration();
254 dma_configuration();
255
256 /* wait dma transmission complete */
257 while((usart2_tx_dma_status == 0) || (usart2_rx_dma_status == 0) || (usart3_tx_dma_status == 0) || (usart3_rx_dma_status == 0));
258
259 while(1)
260 {
261 /* compare data buffer */
262 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
263 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
264 {
265 at32_led_toggle(LED2);
266 at32_led_toggle(LED3);
267 at32_led_toggle(LED4);
268 delay_sec(1);
269 }
270 }
271}
272
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:54
usart3_tx_dma_status
volatile uint8_t usart3_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:46
usart2_tx_dma_status
volatile uint8_t usart2_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:44
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:229
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:43
dma_configuration
void dma_configuration(void)
config dma for usart2 and usart3
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:113
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:248
usart2_rx_dma_status
volatile uint8_t usart2_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:45
usart3_rx_dma_status
volatile uint8_t usart3_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:47
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:40
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:38
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:41
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:42
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f413.h:182
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:181
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:183
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:184
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:236
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:163
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_FLEXIBLE_UART3_TX
@ DMA_FLEXIBLE_UART3_TX
Definition: at32f413_dma.h:160
DMA_FLEXIBLE_UART2_RX
@ DMA_FLEXIBLE_UART2_RX
Definition: at32f413_dma.h:157
DMA_FLEXIBLE_UART2_TX
@ DMA_FLEXIBLE_UART2_TX
Definition: at32f413_dma.h:158
DMA_FLEXIBLE_UART3_RX
@ DMA_FLEXIBLE_UART3_RX
Definition: at32f413_dma.h:159
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
FLEX_CHANNEL3
#define FLEX_CHANNEL3
Definition: at32f413_dma.h:64
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:62
FLEX_CHANNEL4
#define FLEX_CHANNEL4
Definition: at32f413_dma.h:65
FLEX_CHANNEL2
#define FLEX_CHANNEL2
Definition: at32f413_dma.h:63
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:50
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:479
DMA1
#define DMA1
Definition: at32f413_dma.h:477
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:293
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:279
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART2
#define USART2
Definition: at32f413_usart.h:318
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
37#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
38#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
39
40uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma";
41uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma";
42uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
43uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
44
50void usart_configuration(void)
51{
52 gpio_init_type gpio_init_struct;
53
54 /* enable the usart2 and gpio clock */
55 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
57
58 /* enable the usart3 and gpio clock */
59 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
61
62 gpio_default_para_init(&gpio_init_struct);
63 /* configure the usart2 tx pin */
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
66 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
67 gpio_init_struct.gpio_pins = GPIO_PINS_2;
68 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
69 gpio_init(GPIOA, &gpio_init_struct);
70
71 /* configure the usart3 tx pin */
72 gpio_init_struct.gpio_pins = GPIO_PINS_10;
73 gpio_init(GPIOB, &gpio_init_struct);
74
75 /* configure the usart2 rx pin */
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
79 gpio_init_struct.gpio_pins = GPIO_PINS_3;
80 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
81 gpio_init(GPIOA, &gpio_init_struct);
82
83 /* configure the usart3 rx pin */
84 gpio_init_struct.gpio_pins = GPIO_PINS_11;
85 gpio_init(GPIOB, &gpio_init_struct);
86
87 /* configure usart2 param */
88 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
89 usart_transmitter_enable(USART2, TRUE);
90 usart_receiver_enable(USART2, TRUE);
91 usart_dma_transmitter_enable(USART2, TRUE);
92 usart_dma_receiver_enable(USART2, TRUE);
93 usart_enable(USART2, TRUE);
94
95 /* configure usart3 param */
96 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
97 usart_transmitter_enable(USART3, TRUE);
98 usart_receiver_enable(USART3, TRUE);
99 usart_dma_transmitter_enable(USART3, TRUE);
100 usart_dma_receiver_enable(USART3, TRUE);
101 usart_enable(USART3, TRUE);
102}
103
109void dma_configuration(void)
110{
111 dma_init_type dma_init_struct;
112
113 /* enable dma1 clock */
114 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
115
116 /* dma1 channel1 for usart2 tx configuration */
117 dma_reset(DMA1_CHANNEL1);
118 dma_default_para_init(&dma_init_struct);
119 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
120 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
121 dma_init_struct.memory_base_addr = (uint32_t)usart2_tx_buffer;
122 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
123 dma_init_struct.memory_inc_enable = TRUE;
124 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
125 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
126 dma_init_struct.peripheral_inc_enable = FALSE;
127 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
128 dma_init_struct.loop_mode_enable = FALSE;
129 dma_init(DMA1_CHANNEL1, &dma_init_struct);
130
131 /* config flexible dma for usart2 tx */
132 dma_flexible_config(DMA1, FLEX_CHANNEL1, DMA_FLEXIBLE_UART2_TX);
133
134 /* dma1 channel2 for usart2 rx configuration */
135 dma_reset(DMA1_CHANNEL2);
136 dma_default_para_init(&dma_init_struct);
137 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
138 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
139 dma_init_struct.memory_base_addr = (uint32_t)usart2_rx_buffer;
140 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
141 dma_init_struct.memory_inc_enable = TRUE;
142 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
143 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
144 dma_init_struct.peripheral_inc_enable = FALSE;
145 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
146 dma_init_struct.loop_mode_enable = FALSE;
147 dma_init(DMA1_CHANNEL2, &dma_init_struct);
148
149 /* config flexible dma for usart2 rx */
150 dma_flexible_config(DMA1, FLEX_CHANNEL2, DMA_FLEXIBLE_UART2_RX);
151
152 /* dma1 channel3 for usart3 tx configuration */
153 dma_reset(DMA1_CHANNEL3);
154 dma_default_para_init(&dma_init_struct);
155 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
156 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
157 dma_init_struct.memory_base_addr = (uint32_t)usart3_tx_buffer;
158 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
159 dma_init_struct.memory_inc_enable = TRUE;
160 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
161 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
162 dma_init_struct.peripheral_inc_enable = FALSE;
163 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
164 dma_init_struct.loop_mode_enable = FALSE;
165 dma_init(DMA1_CHANNEL3, &dma_init_struct);
166
167 /* config flexible dma for usart3 tx */
168 dma_flexible_config(DMA1, FLEX_CHANNEL3, DMA_FLEXIBLE_UART3_TX);
169
170 /* dma1 channel4 for usart3 rx configuration */
171 dma_reset(DMA1_CHANNEL4);
172 dma_default_para_init(&dma_init_struct);
173 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
174 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
175 dma_init_struct.memory_base_addr = (uint32_t)usart3_rx_buffer;
176 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
177 dma_init_struct.memory_inc_enable = TRUE;
178 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
179 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
180 dma_init_struct.peripheral_inc_enable = FALSE;
181 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
182 dma_init_struct.loop_mode_enable = FALSE;
183 dma_init(DMA1_CHANNEL4, &dma_init_struct);
184
185 /* config flexible dma for usart3 rx */
186 dma_flexible_config(DMA1, FLEX_CHANNEL4, DMA_FLEXIBLE_UART3_RX);
187
188 dma_channel_enable(DMA1_CHANNEL2, TRUE); /* usart2 rx begin dma receiving */
189 dma_channel_enable(DMA1_CHANNEL4, TRUE); /* usart3 rx begin dma receiving */
190 dma_channel_enable(DMA1_CHANNEL1, TRUE); /* usart2 tx begin dma transmitting */
191 dma_channel_enable(DMA1_CHANNEL3, TRUE); /* usart3 tx begin dma transmitting */
192}
193
201uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
202{
203 while(buffer_length--)
204 {
205 if(*pbuffer1 != *pbuffer2)
206 {
207 return 0;
208 }
209 pbuffer1++;
210 pbuffer2++;
211 }
212 return 1;
213}
214
220int main(void)
221{
222 system_clock_config();
223 at32_board_init();
224 usart_configuration();
225 dma_configuration();
226
227 /* wait dma transmission complete */
228 while((dma_flag_get(DMA1_FDT1_FLAG) == RESET) || (dma_flag_get(DMA1_FDT2_FLAG) == RESET) || \
229 (dma_flag_get(DMA1_FDT3_FLAG) == RESET) || (dma_flag_get(DMA1_FDT4_FLAG) == RESET));
230
231 while(1)
232 {
233 /* compare data buffer */
234 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
235 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
236 {
237 at32_led_toggle(LED2);
238 at32_led_toggle(LED3);
239 at32_led_toggle(LED4);
240 delay_sec(1);
241 }
242 }
243}
244
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:50
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:201
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:43
dma_configuration
void dma_configuration(void)
config dma for usart2 and usart3
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:109
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:220
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:40
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:38
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:41
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:42
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:236
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_FLEXIBLE_UART3_TX
@ DMA_FLEXIBLE_UART3_TX
Definition: at32f413_dma.h:160
DMA_FLEXIBLE_UART2_RX
@ DMA_FLEXIBLE_UART2_RX
Definition: at32f413_dma.h:157
DMA_FLEXIBLE_UART2_TX
@ DMA_FLEXIBLE_UART2_TX
Definition: at32f413_dma.h:158
DMA_FLEXIBLE_UART3_RX
@ DMA_FLEXIBLE_UART3_RX
Definition: at32f413_dma.h:159
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:264
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:80
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:84
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:88
FLEX_CHANNEL3
#define FLEX_CHANNEL3
Definition: at32f413_dma.h:64
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:62
FLEX_CHANNEL4
#define FLEX_CHANNEL4
Definition: at32f413_dma.h:65
FLEX_CHANNEL2
#define FLEX_CHANNEL2
Definition: at32f413_dma.h:63
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:480
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:478
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:479
DMA1
#define DMA1
Definition: at32f413_dma.h:477
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:166
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:293
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:279
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART2
#define USART2
Definition: at32f413_usart.h:318
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55#define USB_BUFFER_SIZE_EX
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
98void usb_delay_ms(uint32_t ms);
99void usb_delay_us(uint32_t us);
100
109#ifdef __cplusplus
110}
111#endif
112
113#endif
114
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:167
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:178


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • audio
  • src
project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • audio
  • src
project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • audio
  • src
project/at_start_f413/examples/usb_device/audio/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "audio_class.h"
29#include "audio_desc.h"
30#include "usbd_int.h"
31#include "audio_codec.h"
32
41 usbd_core_type usb_core_dev;
42
48void usb_clock48m_select(usb_clk48_s clk_s)
49{
50 if(clk_s == USB_CLK_HICK)
51 {
52 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
53
54 /* enable the acc calibration ready interrupt */
55 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
56
57 /* update the c1\c2\c3 value */
58 acc_write_c1(7980);
59 acc_write_c2(8000);
60 acc_write_c3(8020);
61
62 /* open acc calibration */
63 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
64 }
65 else
66 {
67 switch(system_core_clock)
68 {
69 /* 48MHz */
70 case 48000000:
71 crm_usb_clock_div_set(CRM_USB_DIV_1);
72 break;
73
74 /* 72MHz */
75 case 72000000:
76 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
77 break;
78
79 /* 96MHz */
80 case 96000000:
81 crm_usb_clock_div_set(CRM_USB_DIV_2);
82 break;
83
84 /* 120MHz */
85 case 120000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
87 break;
88
89 /* 144MHz */
90 case 144000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_3);
92 break;
93
94 /* 168MHz */
95 case 168000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
97 break;
98
99 /* 192MHz */
100 case 192000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_4);
102 break;
103
104 default:
105 break;
106
107 }
108 }
109}
110
116int main(void)
117{
118 /* config nvic priority group */
119 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
120
121 /* system clock config */
122 system_clock_config();
123
124 /* audio codec init */
125 audio_codec_init();
126
127 /* at32 board init */
128 at32_board_init();
129
130 /* select usb 48m clcok source */
131 usb_clock48m_select(USB_CLK_HEXT);
132
133 /* enable usb clock */
134 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
135
136 /* enable usb interrupt */
137 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
138
139 /* usb core init */
140 usbd_core_init(&usb_core_dev, USB, &audio_class_handler, &audio_desc_handler, 0);
141
142 /* enable usb pull-up */
143 usbd_connect(&usb_core_dev);
144
145 while(1)
146 {
147 audio_codec_loop();
148 delay_ms(100);
149 }
150}
151
157void USBFS_L_CAN1_RX0_IRQHandler(void)
158{
159 usbd_irq_handler(&usb_core_dev);
160}
161
167void usb_delay_ms(uint32_t ms)
168{
169 /* user can define self delay function */
170 delay_ms(ms);
171}
172
178void usb_delay_us(uint32_t us)
179{
180 delay_us(us);
181}
182
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
audio_class.h
usb audio class file
audio_desc.h
usb audio descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:116
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:157
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:41
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:63
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:63
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:851
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:792
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55#define USB_BUFFER_SIZE_EX
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
98void usb_delay_ms(uint32_t ms);
99void usb_delay_us(uint32_t us);
100
108#ifdef __cplusplus
109}
110#endif
111
112#endif
113
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:176
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:187


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • composite_audio_hid
  • src
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • composite_audio_hid
  • src
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • composite_audio_hid
  • src
project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "usbd_int.h"
29#include "audio_hid_class.h"
30#include "audio_hid_desc.h"
31#include "audio_codec.h"
32
41/* usb global struct define */
42 usbd_core_type usb_core_dev;
43
44uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE];
45
51void usb_clock48m_select(usb_clk48_s clk_s)
52{
53 if(clk_s == USB_CLK_HICK)
54 {
55 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
56
57 /* enable the acc calibration ready interrupt */
58 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
59
60 /* update the c1\c2\c3 value */
61 acc_write_c1(7980);
62 acc_write_c2(8000);
63 acc_write_c3(8020);
64
65 /* open acc calibration */
66 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
67 }
68 else
69 {
70 switch(system_core_clock)
71 {
72 /* 48MHz */
73 case 48000000:
74 crm_usb_clock_div_set(CRM_USB_DIV_1);
75 break;
76
77 /* 72MHz */
78 case 72000000:
79 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
80 break;
81
82 /* 96MHz */
83 case 96000000:
84 crm_usb_clock_div_set(CRM_USB_DIV_2);
85 break;
86
87 /* 120MHz */
88 case 120000000:
89 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
90 break;
91
92 /* 144MHz */
93 case 144000000:
94 crm_usb_clock_div_set(CRM_USB_DIV_3);
95 break;
96
97 /* 168MHz */
98 case 168000000:
99 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
100 break;
101
102 /* 192MHz */
103 case 192000000:
104 crm_usb_clock_div_set(CRM_USB_DIV_4);
105 break;
106
107 default:
108 break;
109
110 }
111 }
112}
113
119int main(void)
120{
121 /* config nvic priority group */
122 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
123
124 /* system clock config */
125 system_clock_config();
126
127 /* audio codec init */
128 audio_codec_init();
129
130 /* at32 board init */
131 at32_board_init();
132
133 /* select usb 48m clcok source */
134 usb_clock48m_select(USB_CLK_HEXT);
135
136 /* enable usb clock */
137 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
138
139 /* enable usb interrupt */
140 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
141
142 /* usb core init */
143 usbd_core_init(&usb_core_dev, USB, &audio_hid_class_handler, &audio_hid_desc_handler, 0);
144
145 /* enable usb pull-up */
146 usbd_connect(&usb_core_dev);
147
148 while(1)
149 {
150 audio_codec_loop();
151 if(at32_button_press() == USER_BUTTON)
152 {
153 report_buf[0] = HID_REPORT_ID_5;
154 report_buf[1] = (~report_buf[1]) & 0x1;
155 audio_hid_class_send_report(&usb_core_dev, report_buf, USBD_AUHID_IN_MAXPACKET_SIZE);
156 }
157 delay_ms(100);
158 }
159}
160
166void USBFS_L_CAN1_RX0_IRQHandler(void)
167{
168 usbd_irq_handler(&usb_core_dev);
169}
170
176void usb_delay_ms(uint32_t ms)
177{
178 /* user can define self delay function */
179 delay_ms(ms);
180}
181
187void usb_delay_us(uint32_t us)
188{
189 delay_us(us);
190}
191
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
audio_hid_class.h
audio_hid_desc.h
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
report_buf
uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE]
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:44
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:119
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:166
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:42
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:65
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:778
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:62
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:224
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:65
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:851
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:792
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97void usb_delay_ms(uint32_t ms);
98void usb_delay_us(uint32_t us);
99
108#ifdef __cplusplus
109}
110#endif
111
112#endif
113
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:233
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:244


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "cdc_keyboard_class.h"
29#include "cdc_keyboard_desc.h"
30#include "usbd_int.h"
31
40 usbd_core_type usb_core_dev;
41uint8_t usb_buffer[256];
42void keyboard_send_string(void *udev, uint8_t *string, uint8_t len);
43
49void usb_clock48m_select(usb_clk48_s clk_s)
50{
51 if(clk_s == USB_CLK_HICK)
52 {
53 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
54
55 /* enable the acc calibration ready interrupt */
56 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
57
58 /* update the c1\c2\c3 value */
59 acc_write_c1(7980);
60 acc_write_c2(8000);
61 acc_write_c3(8020);
62
63 /* open acc calibration */
64 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
65 }
66 else
67 {
68 switch(system_core_clock)
69 {
70 /* 48MHz */
71 case 48000000:
72 crm_usb_clock_div_set(CRM_USB_DIV_1);
73 break;
74
75 /* 72MHz */
76 case 72000000:
77 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
78 break;
79
80 /* 96MHz */
81 case 96000000:
82 crm_usb_clock_div_set(CRM_USB_DIV_2);
83 break;
84
85 /* 120MHz */
86 case 120000000:
87 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
88 break;
89
90 /* 144MHz */
91 case 144000000:
92 crm_usb_clock_div_set(CRM_USB_DIV_3);
93 break;
94
95 /* 168MHz */
96 case 168000000:
97 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
98 break;
99
100 /* 192MHz */
101 case 192000000:
102 crm_usb_clock_div_set(CRM_USB_DIV_4);
103 break;
104
105 default:
106 break;
107
108 }
109 }
110}
111
118void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
119{
120 uint8_t index = 0;
121 usbd_core_type *pudev = (usbd_core_type *)udev;
122 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
123 for(index = 0; index < len; index ++)
124 {
125 while(1)
126 {
127 if(vcpkybrd->g_keyboard_tx_completed == 1)
128 {
129 vcpkybrd->g_keyboard_tx_completed = 0;
130 usb_vcpkybrd_keyboard_send_char(&usb_core_dev, string[index]);
131 break;
132 }
133 }
134 /* send 0x00 */
135 while(1)
136 {
137 if(vcpkybrd->g_keyboard_tx_completed == 1)
138 {
139 vcpkybrd->g_keyboard_tx_completed = 0;
140 usb_vcpkybrd_keyboard_send_char(&usb_core_dev, 0x00);
141 break;
142 }
143 }
144 }
145
146}
147
153int main(void)
154{
155 uint16_t data_len;
156
157 uint32_t timeout;
158
159 uint8_t send_zero_packet = 0;
160
161 /* config nvic priority group */
162 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
163
164 system_clock_config();
165
166 at32_board_init();
167
168 /* select usb 48m clcok source */
169 usb_clock48m_select(USB_CLK_HEXT);
170
171 /* enable usb clock */
172 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
173
174 /* enable usb interrupt */
175 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
176
177 /* usb core init */
178 usbd_core_init(&usb_core_dev, USB, &cdc_keyboard_class_handler, &cdc_keyboard_desc_handler, 0);
179
180 /* enable usb pull-up */
181 usbd_connect(&usb_core_dev);
182
183 while(1)
184 {
185 /* get usb vcp receive data */
186 data_len = usb_vcpkybrd_vcp_get_rxdata(&usb_core_dev, usb_buffer);
187
188 if(data_len > 0 || send_zero_packet == 1)
189 {
190 /* bulk transfer is complete when the endpoint does one of the following
191 1 has transferred exactly the amount of data expected
192 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
193 */
194 if(data_len > 0)
195 send_zero_packet = 1;
196
197 if(data_len == 0)
198 send_zero_packet = 0;
199
200 timeout = 5000000;
201 do
202 {
203 /* send data to host */
204 if(usb_vcpkybrd_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
205 {
206 break;
207 }
208 }while(timeout --);
209 }
210
211 if(at32_button_press() == USER_BUTTON)
212 {
213 keyboard_send_string(&usb_core_dev, (uint8_t *)" Keyboard Demo\r\n", 16);
214 }
215 }
216}
217
223void USBFS_L_CAN1_RX0_IRQHandler(void)
224{
225 usbd_irq_handler(&usb_core_dev);
226}
227
233void usb_delay_ms(uint32_t ms)
234{
235 /* user can define self delay function */
236 delay_ms(ms);
237}
238
244void usb_delay_us(uint32_t us)
245{
246 delay_us(us);
247}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_keyboard_class.h
usb cdc and keyboard class file
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:153
keyboard_send_string
void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
keyboard send string
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:118
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:223
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:41
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:40
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:626
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:705
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:203
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:595
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:63
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
vcp_keyboard_type
Definition: cdc_keyboard_class.h:73
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:86
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97void usb_delay_ms(uint32_t ms);
98void usb_delay_us(uint32_t us);
99
108#ifdef __cplusplus
109}
110#endif
111
112#endif
113
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "cdc_msc_class.h"
29#include "cdc_msc_desc.h"
30#include "usbd_int.h"
31
40 usbd_core_type usb_core_dev;
41uint8_t usb_buffer[256];
42
48void usb_clock48m_select(usb_clk48_s clk_s)
49{
50 if(clk_s == USB_CLK_HICK)
51 {
52 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
53
54 /* enable the acc calibration ready interrupt */
55 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
56
57 /* update the c1\c2\c3 value */
58 acc_write_c1(7980);
59 acc_write_c2(8000);
60 acc_write_c3(8020);
61
62 /* open acc calibration */
63 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
64 }
65 else
66 {
67 switch(system_core_clock)
68 {
69 /* 48MHz */
70 case 48000000:
71 crm_usb_clock_div_set(CRM_USB_DIV_1);
72 break;
73
74 /* 72MHz */
75 case 72000000:
76 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
77 break;
78
79 /* 96MHz */
80 case 96000000:
81 crm_usb_clock_div_set(CRM_USB_DIV_2);
82 break;
83
84 /* 120MHz */
85 case 120000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
87 break;
88
89 /* 144MHz */
90 case 144000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_3);
92 break;
93
94 /* 168MHz */
95 case 168000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
97 break;
98
99 /* 192MHz */
100 case 192000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_4);
102 break;
103
104 default:
105 break;
106
107 }
108 }
109}
110
116int main(void)
117{
118 uint16_t data_len;
119
120 uint32_t timeout;
121
122 uint8_t send_zero_packet = 0;
123
124 /* config nvic priority group */
125 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
126
127 system_clock_config();
128
129 at32_board_init();
130
131 /* select usb 48m clcok source */
132 usb_clock48m_select(USB_CLK_HEXT);
133
134 /* enable usb clock */
135 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
136
137 /* enable usb interrupt */
138 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
139
140 /* usb core init */
141 usbd_core_init(&usb_core_dev, USB, &cdc_msc_class_handler, &cdc_msc_desc_handler, 0);
142
143 /* enable usb pull-up */
144 usbd_connect(&usb_core_dev);
145
146 while(1)
147 {
148 /* get usb vcp receive data */
149 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
150
151 if(data_len > 0 || send_zero_packet == 1)
152 {
153 /* bulk transfer is complete when the endpoint does one of the following
154 1 has transferred exactly the amount of data expected
155 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
156 */
157 if(data_len > 0)
158 send_zero_packet = 1;
159
160 if(data_len == 0)
161 send_zero_packet = 0;
162
163 timeout = 5000000;
164 do
165 {
166 /* send data to host */
167 if(usb_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
168 {
169 break;
170 }
171 }while(timeout --);
172 }
173 }
174}
175
181void USBFS_L_CAN1_RX0_IRQHandler(void)
182{
183 usbd_irq_handler(&usb_core_dev);
184}
185
191void usb_delay_ms(uint32_t ms)
192{
193 /* user can define self delay function */
194 delay_ms(ms);
195}
196
202void usb_delay_us(uint32_t us)
203{
204 delay_us(us);
205}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_msc_class.h
usb cdc class file
cdc_msc_desc.h
usb cdc descriptor header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:116
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:181
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:191
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:202
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:41
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:40
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:343
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:373
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:70
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:67
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
98void usb_delay_ms(uint32_t ms);
99void usb_delay_us(uint32_t us);
100
109#ifdef __cplusplus
110}
111#endif
112
113#endif
114
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:168
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:179


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • custom_hid
  • src
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • custom_hid
  • src
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • custom_hid
  • src
project/at_start_f413/examples/usb_device/custom_hid/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "custom_hid_class.h"
29#include "custom_hid_desc.h"
30#include "usbd_int.h"
31
40 usbd_core_type usb_core_dev;
41uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE];
42
48void usb_clock48m_select(usb_clk48_s clk_s)
49{
50 if(clk_s == USB_CLK_HICK)
51 {
52 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
53
54 /* enable the acc calibration ready interrupt */
55 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
56
57 /* update the c1\c2\c3 value */
58 acc_write_c1(7980);
59 acc_write_c2(8000);
60 acc_write_c3(8020);
61
62 /* open acc calibration */
63 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
64 }
65 else
66 {
67 switch(system_core_clock)
68 {
69 /* 48MHz */
70 case 48000000:
71 crm_usb_clock_div_set(CRM_USB_DIV_1);
72 break;
73
74 /* 72MHz */
75 case 72000000:
76 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
77 break;
78
79 /* 96MHz */
80 case 96000000:
81 crm_usb_clock_div_set(CRM_USB_DIV_2);
82 break;
83
84 /* 120MHz */
85 case 120000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
87 break;
88
89 /* 144MHz */
90 case 144000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_3);
92 break;
93
94 /* 168MHz */
95 case 168000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
97 break;
98
99 /* 192MHz */
100 case 192000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_4);
102 break;
103
104 default:
105 break;
106
107 }
108 }
109}
110
116int main(void)
117{
118 /* config nvic priority group */
119 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
120
121 system_clock_config();
122
123 at32_board_init();
124
125 /* select usb 48m clcok source */
126 usb_clock48m_select(USB_CLK_HEXT);
127
128 /* enable usb clock */
129 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
130
131 /* enable usb interrupt */
132 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
133
134 /* usb core init */
135 usbd_core_init(&usb_core_dev, USB, &custom_hid_class_handler, &custom_hid_desc_handler, 0);
136
137 /* enable usb pull-up */
138 usbd_connect(&usb_core_dev);
139
140 while(1)
141 {
142 if(at32_button_press() == USER_BUTTON)
143 {
144 report_buf[1] = (~report_buf[1]) & 0x1;
145 report_buf[0] = HID_REPORT_ID_5;
146 custom_hid_class_send_report(&usb_core_dev, report_buf, USBD_CUSTOM_IN_MAXPACKET_SIZE);
147
148 }
149 }
150}
151
152
158void USBFS_L_CAN1_RX0_IRQHandler(void)
159{
160 usbd_irq_handler(&usb_core_dev);
161}
162
168void usb_delay_ms(uint32_t ms)
169{
170 /* user can define self delay function */
171 delay_ms(ms);
172}
173
179void usb_delay_us(uint32_t us)
180{
181 delay_us(us);
182}
183
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
custom_hid_class.h
usb custom hid header file
custom_hid_desc.h
usb custom hid descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
report_buf
uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:41
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:116
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:158
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:40
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:224
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:57
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:328
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:55
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:63
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
101#define USB_LOW_POWER_WAKUP
102
103void usb_delay_ms(uint32_t ms);
104void usb_delay_us(uint32_t us);
105
114#ifdef __cplusplus
115}
116#endif
117
118#endif
119
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:334
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:345


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • keyboard
  • src
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • keyboard
  • src
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • keyboard
  • src
project/at_start_f413/examples/usb_device/keyboard/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "keyboard_class.h"
29#include "keyboard_desc.h"
30#include "usbd_int.h"
31
40 usbd_core_type usb_core_dev;
41extern __IO uint8_t hid_suspend_flag;
42void keyboard_send_string(void *udev, uint8_t *string, uint8_t len);
43void system_clock_recover(void);
44void button_exint_init(void);
45void usb_low_power_wakeup_config(void);
46
53void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
54{
55 uint8_t index = 0;
56 usbd_core_type *pudev = (usbd_core_type *)udev;
57 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
58 for(index = 0; index < len; index ++)
59 {
60 while(1)
61 {
62 if(pkeyboard->g_u8tx_completed == 1)
63 {
64 pkeyboard->g_u8tx_completed = 0;
65 usb_hid_keyboard_send_char(udev, string[index]);
66 break;
67 }
68 }
69 /* send 0x00 */
70 while(1)
71 {
72 if(pkeyboard->g_u8tx_completed == 1)
73 {
74 pkeyboard->g_u8tx_completed = 0;
75 usb_hid_keyboard_send_char(udev, 0x00);
76 break;
77 }
78 }
79 }
80}
81
87void usb_clock48m_select(usb_clk48_s clk_s)
88{
89 if(clk_s == USB_CLK_HICK)
90 {
91 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
92
93 /* enable the acc calibration ready interrupt */
94 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
95
96 /* update the c1\c2\c3 value */
97 acc_write_c1(7980);
98 acc_write_c2(8000);
99 acc_write_c3(8020);
100
101 /* open acc calibration */
102 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
103 }
104 else
105 {
106 switch(system_core_clock)
107 {
108 /* 48MHz */
109 case 48000000:
110 crm_usb_clock_div_set(CRM_USB_DIV_1);
111 break;
112
113 /* 72MHz */
114 case 72000000:
115 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
116 break;
117
118 /* 96MHz */
119 case 96000000:
120 crm_usb_clock_div_set(CRM_USB_DIV_2);
121 break;
122
123 /* 120MHz */
124 case 120000000:
125 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
126 break;
127
128 /* 144MHz */
129 case 144000000:
130 crm_usb_clock_div_set(CRM_USB_DIV_3);
131 break;
132
133 /* 168MHz */
134 case 168000000:
135 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
136 break;
137
138 /* 192MHz */
139 case 192000000:
140 crm_usb_clock_div_set(CRM_USB_DIV_4);
141 break;
142
143 default:
144 break;
145
146 }
147 }
148}
149
155int main(void)
156{
157 /* config nvic priority group */
158 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
159
160 system_clock_config();
161
162 at32_board_init();
163
164 /* select usb 48m clcok source */
165 usb_clock48m_select(USB_CLK_HEXT);
166
167#ifdef USB_LOW_POWER_WAKUP
168 /* enable pwc and bpr clock */
169 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
170 button_exint_init();
171 usb_low_power_wakeup_config();
172#endif
173
174 /* enable usb clock */
175 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
176
177 /* enable usb interrupt */
178 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
179
180 /* usb core init */
181 usbd_core_init(&usb_core_dev, USB, &keyboard_class_handler, &keyboard_desc_handler, 0);
182
183 /* enable usb pull-up */
184 usbd_connect(&usb_core_dev);
185
186 while(1)
187 {
188 if(at32_button_press() == USER_BUTTON)
189 {
190 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_CONFIGURED)
191 {
192 keyboard_send_string(&usb_core_dev, (uint8_t *)" Keyboard Demo\r\n", 16);
193 }
194 /* remote wakeup */
195 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_SUSPENDED
196 &&(usb_core_dev.remote_wakup == 1))
197 {
198 usbd_remote_wakeup(&usb_core_dev);
199 }
200 }
201#ifdef USB_LOW_POWER_WAKUP
202 /* enter deep sleep */
203 if(((keyboard_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag == 1)
204 {
205 at32_led_off(LED2);
206 at32_led_off(LED3);
207 at32_led_off(LED4);
208
209 /* enter deep sleep mode */
210 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
211
212 /* wait clock stable */
213 system_clock_recover();
214
215 ((keyboard_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag = 0;
216 at32_led_on(LED2);
217 at32_led_on(LED3);
218 at32_led_on(LED4);
219 }
220#endif
221 }
222}
223
224#ifdef USB_LOW_POWER_WAKUP
230void button_exint_init(void)
231{
232 exint_init_type exint_init_struct;
233
234 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
235 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
236
237 exint_default_para_init(&exint_init_struct);
238 exint_init_struct.line_enable = TRUE;
239 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
240 exint_init_struct.line_select = EXINT_LINE_0;
241 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
242 exint_init(&exint_init_struct);
243
244 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
245 nvic_irq_enable(EXINT0_IRQn, 0, 0);
246}
247
253void EXINT0_IRQHandler(void)
254{
255 /* clear interrupt pending bit */
256 exint_flag_clear(EXINT_LINE_0);
257}
258
264void usb_low_power_wakeup_config(void)
265{
266 exint_init_type exint_init_struct;
267
268 exint_default_para_init(&exint_init_struct);
269
270 exint_init_struct.line_enable = TRUE;
271 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
272 exint_init_struct.line_select = EXINT_LINE_18;
273 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
274 exint_init(&exint_init_struct);
275
276 nvic_irq_enable(USBFSWakeUp_IRQn, 0, 0);
277}
278
284void USBFSWakeUp_IRQHandler(void)
285{
286 exint_flag_clear(EXINT_LINE_18);
287}
288
294void system_clock_recover(void)
295{
296 /* enable external high-speed crystal oscillator - hext */
297 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
298
299 /* wait till hext is ready */
300 while(crm_hext_stable_wait() == ERROR);
301
302 /* enable pll */
303 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
304
305 /* wait till pll is ready */
306 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
307
308 /* enable auto step mode */
309 crm_auto_step_mode_enable(TRUE);
310
311 /* select pll as system clock source */
312 crm_sysclk_switch(CRM_SCLK_PLL);
313
314 /* wait till pll is used as system clock source */
315 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
316}
317
318#endif
324void USBFS_L_CAN1_RX0_IRQHandler(void)
325{
326 usbd_irq_handler(&usb_core_dev);
327}
328
334void usb_delay_ms(uint32_t ms)
335{
336 /* user can define self delay function */
337 delay_ms(ms);
338}
339
345void usb_delay_us(uint32_t us)
346{
347 delay_us(us);
348}
349
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:94
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
hid_suspend_flag
__IO uint8_t hid_suspend_flag
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f413/templates/src/main.c:50
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:87
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:155
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
keyboard_send_string
void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
keyboard send string
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:53
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:324
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:40
system_clock_recover
void system_clock_recover(void)
systemclock recover.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:96
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
USBFSWakeUp_IRQn
@ USBFSWakeUp_IRQn
Definition: at32f413.h:213
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:176
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_LINE_18
#define EXINT_LINE_18
Definition: at32f413_exint.h:68
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:50
ERROR
@ ERROR
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:252
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:275
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:187
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:95
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:460
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:187
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:64
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:130
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:600
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
keyboard_class.h
usb hid keyboard header file
keyboard_desc.h
usb keyboard descriptor header file
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
keyboard_type
Definition: keyboard_class.h:65
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:73
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:128
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
101#define USB_LOW_POWER_WAKUP
102
103void usb_delay_ms(uint32_t ms);
104void usb_delay_us(uint32_t us);
113#ifdef __cplusplus
114}
115#endif
116
117#endif
118
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:310
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:321


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • mouse
  • src
project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • mouse
  • src
project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • mouse
  • src
project/at_start_f413/examples/usb_device/mouse/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "mouse_class.h"
29#include "mouse_desc.h"
30#include "usbd_int.h"
31
40 usbd_core_type usb_core_dev;
41__IO uint8_t press_mouse = 0;
42extern __IO uint8_t hid_suspend_flag;
43uint8_t report_buf[USBD_MOUSE_IN_MAXPACKET_SIZE];
44void system_clock_recover(void);
45void button_exint_init(void);
46void usb_low_power_wakeup_config(void);
52void usb_clock48m_select(usb_clk48_s clk_s)
53{
54 if(clk_s == USB_CLK_HICK)
55 {
56 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
57
58 /* enable the acc calibration ready interrupt */
59 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
60
61 /* update the c1\c2\c3 value */
62 acc_write_c1(7980);
63 acc_write_c2(8000);
64 acc_write_c3(8020);
65
66 /* open acc calibration */
67 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
68 }
69 else
70 {
71 switch(system_core_clock)
72 {
73 /* 48MHz */
74 case 48000000:
75 crm_usb_clock_div_set(CRM_USB_DIV_1);
76 break;
77
78 /* 72MHz */
79 case 72000000:
80 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
81 break;
82
83 /* 96MHz */
84 case 96000000:
85 crm_usb_clock_div_set(CRM_USB_DIV_2);
86 break;
87
88 /* 120MHz */
89 case 120000000:
90 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
91 break;
92
93 /* 144MHz */
94 case 144000000:
95 crm_usb_clock_div_set(CRM_USB_DIV_3);
96 break;
97
98 /* 168MHz */
99 case 168000000:
100 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
101 break;
102
103 /* 192MHz */
104 case 192000000:
105 crm_usb_clock_div_set(CRM_USB_DIV_4);
106 break;
107
108 default:
109 break;
110
111 }
112 }
113}
114
120int main(void)
121{
122 __IO uint32_t delay_index = 0;
123 /* config nvic priority group */
124 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
125
126 system_clock_config();
127
128 at32_board_init();
129
130 /* select usb 48m clcok source */
131 usb_clock48m_select(USB_CLK_HEXT);
132
133#ifdef USB_LOW_POWER_WAKUP
134 /* enable pwc and bpr clock */
135 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
136 button_exint_init();
137 usb_low_power_wakeup_config();
138#endif
139
140 /* enable usb clock */
141 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
142
143 /* enable usb interrupt */
144 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
145
146 /* usb core init */
147 usbd_core_init(&usb_core_dev, USB, &mouse_class_handler, &mouse_desc_handler, 0);
148
149 /* enable usb pull-up */
150 usbd_connect(&usb_core_dev);
151
152 while(1)
153 {
154 if(at32_button_press() == USER_BUTTON)
155 {
156 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_CONFIGURED)
157 {
158 usb_hid_mouse_send(&usb_core_dev, RIGHT_BUTTON);
159 press_mouse = 1;
160 }
161 /* remote wakeup */
162 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_SUSPENDED
163 &&(usb_core_dev.remote_wakup == 1))
164 {
165 usbd_remote_wakeup(&usb_core_dev);
166 }
167 }
168 else if(press_mouse == 1)
169 {
170 delay_ms(10);
171 usb_hid_mouse_send(&usb_core_dev, BUTTON_RELEASE);
172 press_mouse = 0;
173 }
174 #ifdef USB_LOW_POWER_WAKUP
175 /* enter deep sleep */
176 if(((mouse_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag == 1)
177 {
178 at32_led_off(LED2);
179 at32_led_off(LED3);
180 at32_led_off(LED4);
181
182 /* enter deep sleep mode */
183 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
184
185 /* wait clock stable */
186 system_clock_recover();
187
188 ((mouse_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag = 0;
189 at32_led_on(LED2);
190 at32_led_on(LED3);
191 at32_led_on(LED4);
192 }
193#endif
194
195 }
196}
197
198#ifdef USB_LOW_POWER_WAKUP
204void button_exint_init(void)
205{
206 exint_init_type exint_init_struct;
207
208 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
209 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
210
211 exint_default_para_init(&exint_init_struct);
212 exint_init_struct.line_enable = TRUE;
213 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
214 exint_init_struct.line_select = EXINT_LINE_0;
215 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
216 exint_init(&exint_init_struct);
217
218 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
219 nvic_irq_enable(EXINT0_IRQn, 0, 0);
220}
221
227void EXINT0_IRQHandler(void)
228{
229 /* clear interrupt pending bit */
230 exint_flag_clear(EXINT_LINE_0);
231}
232
238void usb_low_power_wakeup_config(void)
239{
240 exint_init_type exint_init_struct;
241
242 exint_default_para_init(&exint_init_struct);
243
244 exint_init_struct.line_enable = TRUE;
245 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
246 exint_init_struct.line_select = EXINT_LINE_18;
247 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
248 exint_init(&exint_init_struct);
249
250 nvic_irq_enable(USBFSWakeUp_IRQn, 0, 0);
251}
252
258void USBFSWakeUp_IRQHandler(void)
259{
260 exint_flag_clear(EXINT_LINE_18);
261}
262
268void system_clock_recover(void)
269{
270 /* enable external high-speed crystal oscillator - hext */
271 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
272
273 /* wait till hext is ready */
274 while(crm_hext_stable_wait() == ERROR);
275
276 /* enable pll */
277 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
278
279 /* wait till pll is ready */
280 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
281
282 /* enable auto step mode */
283 crm_auto_step_mode_enable(TRUE);
284
285 /* select pll as system clock source */
286 crm_sysclk_switch(CRM_SCLK_PLL);
287
288 /* wait till pll is used as system clock source */
289 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
290}
291
292#endif
293
299void USBFS_L_CAN1_RX0_IRQHandler(void)
300{
301 usbd_irq_handler(&usb_core_dev);
302}
303
304
310void usb_delay_ms(uint32_t ms)
311{
312 /* user can define self delay function */
313 delay_ms(ms);
314}
315
321void usb_delay_us(uint32_t us)
322{
323 delay_us(us);
324}
325
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:94
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
hid_suspend_flag
__IO uint8_t hid_suspend_flag
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f413/templates/src/main.c:50
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:52
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:120
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:299
report_buf
uint8_t report_buf[USBD_MOUSE_IN_MAXPACKET_SIZE]
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:43
press_mouse
__IO uint8_t press_mouse
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:41
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:40
system_clock_recover
void system_clock_recover(void)
systemclock recover.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:96
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
USBFSWakeUp_IRQn
@ USBFSWakeUp_IRQn
Definition: at32f413.h:213
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:176
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_LINE_18
#define EXINT_LINE_18
Definition: at32f413_exint.h:68
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:50
ERROR
@ ERROR
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:252
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:275
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:187
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:95
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:56
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:54
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:321
BUTTON_RELEASE
#define BUTTON_RELEASE
Definition: mouse_class.h:72
RIGHT_BUTTON
#define RIGHT_BUTTON
Definition: mouse_class.h:74
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:64
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:130
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:600
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
mouse_class.h
usb hid mouse header file
mouse_desc.h
usb mouse descriptor header file
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
mouse_type
Definition: mouse_class.h:81
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:128
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
98void usb_delay_ms(uint32_t ms);
99void usb_delay_us(uint32_t us);
100
109#ifdef __cplusplus
110}
111#endif
112
113#endif
114
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:161
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:172


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • msc
  • src
project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • msc
  • src
project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • msc
  • src
project/at_start_f413/examples/usb_device/msc/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "msc_class.h"
29#include "msc_desc.h"
30#include "usbd_int.h"
31
32
41 usbd_core_type usb_core_dev;
42
43
49void usb_clock48m_select(usb_clk48_s clk_s)
50{
51 if(clk_s == USB_CLK_HICK)
52 {
53 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
54
55 /* enable the acc calibration ready interrupt */
56 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
57
58 /* update the c1\c2\c3 value */
59 acc_write_c1(7980);
60 acc_write_c2(8000);
61 acc_write_c3(8020);
62
63 /* open acc calibration */
64 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
65 }
66 else
67 {
68 switch(system_core_clock)
69 {
70 /* 48MHz */
71 case 48000000:
72 crm_usb_clock_div_set(CRM_USB_DIV_1);
73 break;
74
75 /* 72MHz */
76 case 72000000:
77 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
78 break;
79
80 /* 96MHz */
81 case 96000000:
82 crm_usb_clock_div_set(CRM_USB_DIV_2);
83 break;
84
85 /* 120MHz */
86 case 120000000:
87 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
88 break;
89
90 /* 144MHz */
91 case 144000000:
92 crm_usb_clock_div_set(CRM_USB_DIV_3);
93 break;
94
95 /* 168MHz */
96 case 168000000:
97 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
98 break;
99
100 /* 192MHz */
101 case 192000000:
102 crm_usb_clock_div_set(CRM_USB_DIV_4);
103 break;
104
105 default:
106 break;
107
108 }
109 }
110}
111
117int main(void)
118{
119 /* config nvic priority group */
120 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
121
122 system_clock_config();
123
124 at32_board_init();
125
126 /* select usb 48m clcok source */
127 usb_clock48m_select(USB_CLK_HEXT);
128
129 /* enable usb clock */
130 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
131
132 /* enable usb interrupt */
133 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
134
135 /* usb core init */
136 usbd_core_init(&usb_core_dev, USB, &msc_class_handler, &msc_desc_handler, 0);
137
138 /* enable usb pull-up */
139 usbd_connect(&usb_core_dev);
140
141 while(1)
142 {
143 }
144}
145
151void USBFS_L_CAN1_RX0_IRQHandler(void)
152{
153 usbd_irq_handler(&usb_core_dev);
154}
155
161void usb_delay_ms(uint32_t ms)
162{
163 /* user can define self delay function */
164 delay_ms(ms);
165}
166
172void usb_delay_us(uint32_t us)
173{
174 delay_us(us);
175}
176
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:117
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:151
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:41
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:55
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:65
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
98void usb_delay_ms(uint32_t ms);
99void usb_delay_us(uint32_t us);
100
109#ifdef __cplusplus
110}
111#endif
112
113#endif
114
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:167
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:178


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • printer
  • src
project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • printer
  • src
project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • printer
  • src
project/at_start_f413/examples/usb_device/printer/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "printer_class.h"
29#include "printer_desc.h"
30#include "usbd_int.h"
31
40uint8_t usb_buffer[256];
41 usbd_core_type usb_core_dev;
42
48void usb_clock48m_select(usb_clk48_s clk_s)
49{
50 if(clk_s == USB_CLK_HICK)
51 {
52 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
53
54 /* enable the acc calibration ready interrupt */
55 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
56
57 /* update the c1\c2\c3 value */
58 acc_write_c1(7980);
59 acc_write_c2(8000);
60 acc_write_c3(8020);
61
62 /* open acc calibration */
63 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
64 }
65 else
66 {
67 switch(system_core_clock)
68 {
69 /* 48MHz */
70 case 48000000:
71 crm_usb_clock_div_set(CRM_USB_DIV_1);
72 break;
73
74 /* 72MHz */
75 case 72000000:
76 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
77 break;
78
79 /* 96MHz */
80 case 96000000:
81 crm_usb_clock_div_set(CRM_USB_DIV_2);
82 break;
83
84 /* 120MHz */
85 case 120000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
87 break;
88
89 /* 144MHz */
90 case 144000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_3);
92 break;
93
94 /* 168MHz */
95 case 168000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
97 break;
98
99 /* 192MHz */
100 case 192000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_4);
102 break;
103
104 default:
105 break;
106
107 }
108 }
109}
110
116int main(void)
117{
118 uint32_t rx_len = 0;
119
120 /* config nvic priority group */
121 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
122
123 system_clock_config();
124
125 at32_board_init();
126
127 /* select usb 48m clcok source */
128 usb_clock48m_select(USB_CLK_HEXT);
129
130 /* enable usb clock */
131 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
132
133 /* enable usb interrupt */
134 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
135
136 /* usb core init */
137 usbd_core_init(&usb_core_dev, USB, &printer_class_handler, &printer_desc_handler, 0);
138
139 /* enable usb pull-up */
140 usbd_connect(&usb_core_dev);
141
142 while(1)
143 {
144 /* get usb printer receive data */
145 rx_len = usb_printer_get_rxdata(&usb_core_dev, usb_buffer);
146 UNUSED(rx_len);
147
148 /* user code ...*/
149 }
150}
151
157void USBFS_L_CAN1_RX0_IRQHandler(void)
158{
159 usbd_irq_handler(&usb_core_dev);
160}
161
167void usb_delay_ms(uint32_t ms)
168{
169 /* user can define self delay function */
170 delay_ms(ms);
171}
172
178void usb_delay_us(uint32_t us)
179{
180 delay_us(us);
181}
182
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UNUSED
#define UNUSED(x)
Definition: at32f413_def.h:63
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:116
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:157
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:40
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:41
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usb_printer_get_rxdata
uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: printer_class.c:302
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:62
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:65
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
printer_class.h
usb printer class file
printer_desc.h
usb printer descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61//#define USB_EPT_AUTO_MALLOC_BUFFER /*!< usb auto malloc endpoint tx and rx buffer */
62
63
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
98void usb_delay_ms(uint32_t ms);
99void usb_delay_us(uint32_t us);
100
109#ifdef __cplusplus
110}
111#endif
112
113#endif
114
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:193
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:204


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • vcp_loopback
  • src
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • vcp_loopback
  • src
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • vcp_loopback
  • src
project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "cdc_class.h"
29#include "cdc_desc.h"
30#include "usbd_int.h"
31
40 usbd_core_type usb_core_dev;
41uint8_t usb_buffer[256];
42
48void usb_clock48m_select(usb_clk48_s clk_s)
49{
50 if(clk_s == USB_CLK_HICK)
51 {
52 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
53
54 /* enable the acc calibration ready interrupt */
55 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
56
57 /* update the c1\c2\c3 value */
58 acc_write_c1(7980);
59 acc_write_c2(8000);
60 acc_write_c3(8020);
61
62 /* open acc calibration */
63 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
64 }
65 else
66 {
67 switch(system_core_clock)
68 {
69 /* 48MHz */
70 case 48000000:
71 crm_usb_clock_div_set(CRM_USB_DIV_1);
72 break;
73
74 /* 72MHz */
75 case 72000000:
76 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
77 break;
78
79 /* 96MHz */
80 case 96000000:
81 crm_usb_clock_div_set(CRM_USB_DIV_2);
82 break;
83
84 /* 120MHz */
85 case 120000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
87 break;
88
89 /* 144MHz */
90 case 144000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_3);
92 break;
93
94 /* 168MHz */
95 case 168000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
97 break;
98
99 /* 192MHz */
100 case 192000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_4);
102 break;
103
104 default:
105 break;
106
107 }
108 }
109}
110
116int main(void)
117{
118 uint16_t data_len;
119
120 uint32_t timeout;
121
122 uint8_t send_zero_packet = 0;
123
124 /* config nvic priority group */
125 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
126
127 system_clock_config();
128
129 at32_board_init();
130
131 /* select usb 48m clcok source */
132 usb_clock48m_select(USB_CLK_HEXT);
133
134 /* enable usb clock */
135 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
136
137 /* enable usb interrupt */
138 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
139
140 /* usb core init */
141 usbd_core_init(&usb_core_dev, USB, &cdc_class_handler, &cdc_desc_handler, 0);
142
143 /* enable usb pull-up */
144 usbd_connect(&usb_core_dev);
145
146 while(1)
147 {
148 /* get usb vcp receive data */
149 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
150
151 if(data_len > 0 || send_zero_packet == 1)
152 {
153
154 /* bulk transfer is complete when the endpoint does one of the following
155 1 has transferred exactly the amount of data expected
156 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
157 */
158 if(data_len > 0)
159 send_zero_packet = 1;
160
161 if(data_len == 0)
162 send_zero_packet = 0;
163
164 timeout = 5000000;
165 do
166 {
167 /* send data to host */
168 if(usb_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
169 {
170 break;
171 }
172 }while(timeout --);
173 }
174 }
175}
176
177
183void USBFS_L_CAN1_RX0_IRQHandler(void)
184{
185 usbd_irq_handler(&usb_core_dev);
186}
187
193void usb_delay_ms(uint32_t ms)
194{
195 /* user can define self delay function */
196 delay_ms(ms);
197}
198
204void usb_delay_us(uint32_t us)
205{
206 delay_us(us);
207}
208
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:116
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:183
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:41
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:40
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:343
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:373
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:67
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61//#define USB_EPT_AUTO_MALLOC_BUFFER /*!< usb auto malloc endpoint tx and rx buffer */
62
66#define USB_VIRTUAL_COMPORT
67
68#ifndef USB_EPT_AUTO_MALLOC_BUFFER
74/* ept0 tx start address 0x40, size 0x40,
75 so rx start address is 0x40 + 0x40 = 0x80 */
76#define EPT0_TX_ADDR 0x40
77#define EPT0_RX_ADDR 0x80
79#define EPT1_TX_ADDR 0xC0
80#define EPT1_RX_ADDR 0x100
82#define EPT2_TX_ADDR 0x140
83#define EPT2_RX_ADDR 0x180
85#define EPT3_TX_ADDR 0x00
86#define EPT3_RX_ADDR 0x00
88#define EPT4_TX_ADDR 0x00
89#define EPT4_RX_ADDR 0x00
91#define EPT5_TX_ADDR 0x00
92#define EPT5_RX_ADDR 0x00
94#define EPT6_TX_ADDR 0x00
95#define EPT6_RX_ADDR 0x00
97#define EPT7_TX_ADDR 0x00
98#define EPT7_RX_ADDR 0x00
100#endif
101
102void usb_delay_ms(uint32_t ms);
103void usb_delay_us(uint32_t us);
104
113#ifdef __cplusplus
114}
115#endif
116
117#endif
118
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • virtual_comport
  • src
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • virtual_comport
  • src
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • virtual_comport
  • src
project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "cdc_class.h"
29#include "cdc_desc.h"
30#include "usbd_int.h"
31
40 usbd_core_type usb_core_dev;
41uint8_t usb_buffer[256];
42
43/* usart global struct define */
44extern linecoding_type linecoding;
45void usb_usart_config(linecoding_type linecoding);
46void usart_gpio_config(void);
47#define usart_buffer_size 2048
48uint8_t usart_rx_buffer[usart_buffer_size];
49uint16_t hw_usart_rx_index = 0;
50uint16_t hw_usart_read_index = 0;
51uint16_t usart_rx_data_len = 0;
52uint16_t ov_cnt = 0;
53void usart_send_data(uint8_t *send_data, uint16_t len);
54uint16_t usart_receive_data(void);
55
61void usb_clock48m_select(usb_clk48_s clk_s)
62{
63 if(clk_s == USB_CLK_HICK)
64 {
65 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
66
67 /* enable the acc calibration ready interrupt */
68 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
69
70 /* update the c1\c2\c3 value */
71 acc_write_c1(7980);
72 acc_write_c2(8000);
73 acc_write_c3(8020);
74
75 /* open acc calibration */
76 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
77 }
78 else
79 {
80 switch(system_core_clock)
81 {
82 /* 48MHz */
83 case 48000000:
84 crm_usb_clock_div_set(CRM_USB_DIV_1);
85 break;
86
87 /* 72MHz */
88 case 72000000:
89 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
90 break;
91
92 /* 96MHz */
93 case 96000000:
94 crm_usb_clock_div_set(CRM_USB_DIV_2);
95 break;
96
97 /* 120MHz */
98 case 120000000:
99 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
100 break;
101
102 /* 144MHz */
103 case 144000000:
104 crm_usb_clock_div_set(CRM_USB_DIV_3);
105 break;
106
107 /* 168MHz */
108 case 168000000:
109 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
110 break;
111
112 /* 192MHz */
113 case 192000000:
114 crm_usb_clock_div_set(CRM_USB_DIV_4);
115 break;
116
117 default:
118 break;
119
120 }
121 }
122}
123
129int main(void)
130{
131 uint16_t data_len;
132
133 uint32_t timeout;
134
135 uint8_t send_zero_packet = 0;
136
137 /* config nvic priority group */
138 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
139
140 system_clock_config();
141
142 at32_board_init();
143
144 /* usart gpio config */
145 usart_gpio_config();
146
147 /* hardware usart config: usart2 */
148 usb_usart_config(linecoding);
149
150 /* select usb 48m clcok source */
151 usb_clock48m_select(USB_CLK_HEXT);
152
153 /* enable usb clock */
154 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
155
156 /* enable usb interrupt */
157 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
158
159 /* usb core init */
160 usbd_core_init(&usb_core_dev, USB, &cdc_class_handler, &cdc_desc_handler, 0);
161
162 /* enable usb pull-up */
163 usbd_connect(&usb_core_dev);
164
165 while(1)
166 {
167 /* get usb vcp receive data */
168 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
169
170 /* send data to hardware usart */
171 if(data_len > 0)
172 {
173 usart_send_data(usb_buffer, data_len);
174 }
175
176 /* if hardware usart received data,usb send data to host */
177 usart_rx_data_len = usart_receive_data();
178 if(usart_rx_data_len || send_zero_packet == 1)
179 {
180 if(usart_rx_data_len > 0)
181 send_zero_packet = 1;
182
183 if(usart_rx_data_len == 0)
184 send_zero_packet = 0;
185
186 timeout = 50000;
187
188 if((hw_usart_read_index + usart_rx_data_len) < usart_buffer_size)
189 {
190 do
191 {
192 /* send data to host */
193 if(usb_vcp_send_data(&usb_core_dev, &usart_rx_buffer[hw_usart_read_index], usart_rx_data_len) == SUCCESS)
194 {
195 hw_usart_read_index = hw_usart_read_index + usart_rx_data_len;
196
197 break;
198 }
199 }while(timeout --);
200
201 }
202 /* process the fifo overflow */
203 else
204 {
205 do
206 {
207 /* send data to host */
208 if(usb_vcp_send_data(&usb_core_dev, &usart_rx_buffer[hw_usart_read_index], usart_buffer_size - hw_usart_read_index) == SUCCESS)
209 {
210 /* get fifo overflow data count */
211 ov_cnt = usart_rx_data_len - (usart_buffer_size - hw_usart_read_index);
212 hw_usart_read_index = 0;
213 break;
214 }
215 }while(timeout --);
216 timeout = 50000;
217 do
218 {
219 /* send data to host */
220 if(usb_vcp_send_data(&usb_core_dev, &usart_rx_buffer[hw_usart_read_index], ov_cnt) == SUCCESS)
221 {
222 hw_usart_read_index = ov_cnt;
223 break;
224 }
225 }while(timeout --);
226 }
227 }
228 }
229}
230
237void usart_send_data(uint8_t *send_data, uint16_t len)
238{
239 uint16_t index = 0;
240 for(index = 0; index < len; index++ )
241 {
242 do
243 {
244 ;
245 }while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
246
247 usart_data_transmit(USART2, send_data[index]);
248 }
249}
250
256uint16_t usart_receive_data(void)
257{
258 uint16_t usart_data_len;
259 if(hw_usart_read_index == hw_usart_rx_index)
260 {
261 usart_data_len = 0;
262 }
263 else
264 {
265 /* whether to process the fifo overflow or not */
266 if(hw_usart_rx_index > hw_usart_read_index)
267 usart_data_len = hw_usart_rx_index - hw_usart_read_index;
268 else if(hw_usart_rx_index == 0 && hw_usart_rx_index != hw_usart_read_index)
269 usart_data_len = usart_buffer_size - hw_usart_read_index;
270 else
271 usart_data_len = (usart_buffer_size-1) + hw_usart_rx_index - hw_usart_read_index;
272 }
273
274 return usart_data_len;
275}
276
282void USART2_IRQHandler(void)
283{
284 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
285 {
286 /* read one byte from the receive data register */
287 usart_rx_buffer[hw_usart_rx_index] = usart_data_receive(USART2);
288 hw_usart_rx_index = ( (hw_usart_rx_index+1) & (usart_buffer_size-1) );
289 }
290}
291
297void usb_usart_config( linecoding_type linecoding)
298{
299 usart_stop_bit_num_type usart_stop_bit;
300 usart_data_bit_num_type usart_data_bit;
301 usart_parity_selection_type usart_parity_select;
302
303 /* enable the usart2 and gpio clock */
304 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, FALSE);
305 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
306
307 /* stop bit */
308 switch(linecoding.format)
309 {
310 case 0x0:
311 usart_stop_bit = USART_STOP_1_BIT;
312 break;
313 /* to be used when transmitting and receiving data in smartcard mode */
314 case 0x1:
315 usart_stop_bit = USART_STOP_1_5_BIT;
316 break;
317 case 0x2:
318 usart_stop_bit = USART_STOP_2_BIT;
319 break;
320 default :
321 break;
322 }
323
324 /* parity */
325 switch(linecoding.parity)
326 {
327 case 0x0:
328 usart_parity_select = USART_PARITY_NONE;
329 break;
330 case 0x1:
331 usart_parity_select = USART_PARITY_ODD;
332 break;
333 case 0x2:
334 usart_parity_select = USART_PARITY_EVEN;
335 break;
336 /* hardware usart not support parity for mark and space */
337 case 0x3:
338 case 0x4:
339 break;
340 default :
341 break;
342 }
343
344 if(USART_PARITY_NONE == usart_parity_select)
345 {
346 /* data bits */
347 switch(linecoding.data)
348 {
349 /* hardware usart not support data bits for 5/6 */
350 case 0x5:
351 case 0x6:
352 case 0x7:
353 break;
354 case 0x8:
355 usart_data_bit = USART_DATA_8BITS;
356 break;
357 /* hardware usart not support data bits for 16 */
358 case 0x10:
359 break;
360 default :
361 break;
362 }
363 }
364 else
365 {
366 /* data bits */
367 switch(linecoding.data)
368 {
369 /* hardware usart not support data bits for 5/6 */
370 case 0x5:
371 case 0x6:
372 break;
373 case 0x7:
374 usart_data_bit = USART_DATA_8BITS;
375 break;
376 case 0x8:
377 usart_data_bit = USART_DATA_9BITS;
378 break;
379 /* hardware usart not support data bits for 16 */
380 case 0x10:
381 break;
382 default :
383 break;
384 }
385 }
386
387 nvic_irq_enable(USART2_IRQn, 0, 0);
388
389 /* configure usart2 param */
390 usart_init(USART2, linecoding.bitrate, usart_data_bit, usart_stop_bit);
391 usart_parity_selection_config(USART2, usart_parity_select);
392 usart_transmitter_enable(USART2, TRUE);
393 usart_receiver_enable(USART2, TRUE);
394
395 /* enable usart2 interrupt */
396 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
397 usart_enable(USART2, TRUE);
398}
399
405void usart_gpio_config(void)
406{
407 gpio_init_type gpio_init_struct;
408 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
409
410 /* configure the usart2 tx pin */
411 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
412 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
413 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
414 gpio_init_struct.gpio_pins = GPIO_PINS_2;
415 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
416 gpio_init(GPIOA, &gpio_init_struct);
417
418 /* configure the usart2 rx pin */
419 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
420 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
421 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
422 gpio_init_struct.gpio_pins = GPIO_PINS_3;
423 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
424 gpio_init(GPIOA, &gpio_init_struct);
425}
426
432void USBFS_L_CAN1_RX0_IRQHandler(void)
433{
434 usbd_irq_handler(&usb_core_dev);
435}
436
442void usb_delay_ms(uint32_t ms)
443{
444 /* user can define self delay function */
445 delay_ms(ms);
446}
447
453void usb_delay_us(uint32_t us)
454{
455 delay_us(us);
456}
457
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:66
main
int main(void)
main function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:264
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
usbfs_l_can1_rx0 interrupt handler
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:123
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usart_buffer_size
#define usart_buffer_size
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:47
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:282
hw_usart_read_index
uint16_t hw_usart_read_index
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:50
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:297
usart_rx_data_len
uint16_t usart_rx_data_len
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:51
linecoding
linecoding_type linecoding
Definition: cdc_class.c:55
ov_cnt
uint16_t ov_cnt
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:52
usart_gpio_config
void usart_gpio_config(void)
this function handles usart2 gpio config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:405
usart_rx_buffer
uint8_t usart_rx_buffer[2048]
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:48
usart_send_data
void usart_send_data(uint8_t *send_data, uint16_t len)
this function handles usart2 send data.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:237
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:41
usart_receive_data
uint16_t usart_receive_data(void)
this function handles usart2 receive data.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:256
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:40
hw_usart_rx_index
uint16_t hw_usart_rx_index
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:49
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:108
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:130
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:209
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
SUCCESS
@ SUCCESS
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:746
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:379
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:143
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:564
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:184
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:104
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:171
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:197
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:262
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:391
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f413_usart.h:155
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f413_usart.h:110
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f413_usart.h:91
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f413_usart.h:159
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:156
USART_STOP_2_BIT
@ USART_STOP_2_BIT
Definition: at32f413_usart.h:158
USART_DATA_9BITS
@ USART_DATA_9BITS
Definition: at32f413_usart.h:112
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:111
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f413_usart.h:94
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:93
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:92
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:55
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:71
USART2
#define USART2
Definition: at32f413_usart.h:318
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:343
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:373
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:67
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:212
linecoding_type::data
uint8_t data
Definition: usb_std.h:215
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:214
linecoding_type::format
uint8_t format
Definition: usb_std.h:213
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97
98void usb_delay_ms(uint32_t ms);
99void usb_delay_us(uint32_t us);
100
109#ifdef __cplusplus
110}
111#endif
112
113#endif
114
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:265
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:276


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • virtual_msc_iap
  • src
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • virtual_msc_iap
  • src
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • virtual_msc_iap
  • src
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "msc_class.h"
29#include "msc_desc.h"
30#include "usbd_int.h"
31#include "flash_fat16.h"
32
41 usbd_core_type usb_core_dev;
42
43void (*pftarget)(void);
44
45void jump_to_app(uint32_t address);
46
47
53void usb_clock48m_select(usb_clk48_s clk_s)
54{
55 if(clk_s == USB_CLK_HICK)
56 {
57 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
58
59 /* enable the acc calibration ready interrupt */
60 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
61
62 /* update the c1\c2\c3 value */
63 acc_write_c1(7980);
64 acc_write_c2(8000);
65 acc_write_c3(8020);
66
67 /* open acc calibration */
68 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
69 }
70 else
71 {
72 switch(system_core_clock)
73 {
74 /* 48MHz */
75 case 48000000:
76 crm_usb_clock_div_set(CRM_USB_DIV_1);
77 break;
78
79 /* 72MHz */
80 case 72000000:
81 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
82 break;
83
84 /* 96MHz */
85 case 96000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_2);
87 break;
88
89 /* 120MHz */
90 case 120000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
92 break;
93
94 /* 144MHz */
95 case 144000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_3);
97 break;
98
99 /* 168MHz */
100 case 168000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
102 break;
103
104 /* 192MHz */
105 case 192000000:
106 crm_usb_clock_div_set(CRM_USB_DIV_4);
107 break;
108
109 default:
110 break;
111
112 }
113 }
114}
115
121int main(void)
122{
123 /* config nvic priority group */
124 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
125
126 system_clock_config();
127
128 flash_fat16_init();
129
130 at32_board_init();
131
132 if(flash_fat16_get_upgrade_flag() == IAP_SUCCESS &&
133 (at32_button_press() == NO_BUTTON))
134 {
135 jump_to_app(flash_iap.flash_app_addr);
136 }
137
138 /* select usb 48m clcok source */
139 usb_clock48m_select(USB_CLK_HEXT);
140
141 /* enable usb clock */
142 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
143
144 /* enable usb interrupt */
145 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
146
147 /* usb core init */
148 usbd_core_init(&usb_core_dev, USB, &msc_class_handler, &msc_desc_handler, 0);
149
150 /* enable usb pull-up */
151 usbd_connect(&usb_core_dev);
152
153 while(1)
154 {
155 flash_fat16_loop_status();
156 }
157}
158
164void usb_reset()
165{
166 delay_ms(1000);
167 usbd_disconnect(&usb_core_dev);
168 delay_ms(1000);
169 usbd_connect(&usb_core_dev);
170}
171
177void flash_fat16_loop_status(void)
178{
179 static uint8_t status = UPGRADE_READY;
180 if(status == flash_iap.msc_up_status)
181 {
182 return;
183 }
184 else
185 {
186 status = flash_iap.msc_up_status;
187 }
188
189 switch(flash_iap.msc_up_status)
190 {
191 case UPGRADE_READY:
192 flash_fat16_set_name((const uint8_t *)"Ready", 5);
193 break;
194 case UPGRAGE_ONGOING:
195 break;
196 case UPGRADE_SUCCESS:
197 flash_fat16_set_name((const uint8_t *)"Success", 7);
198 flash_iap.msc_up_status = UPGRADE_DONE;
199 usb_reset();
200 break;
201 case UPGRADE_FAILED:
202 flash_fat16_set_name((const uint8_t *)"Failed", 6);
203 flash_iap.msc_up_status = UPGRADE_DONE;
204 usb_reset();
205 break;
206 case UPGRADE_LARGE:
207 flash_fat16_set_name((const uint8_t *)"Large", 5);
208 flash_iap.msc_up_status = UPGRADE_DONE;
209 usb_reset();
210 break;
211 case UPGRADE_UNKNOWN:
212 flash_fat16_set_name((const uint8_t *)"Unkown", 6);
213 break;
214 case UPGRADE_DONE:
215 break;
216 case UPGRADE_JUMP:
217 flash_fat16_set_name((const uint8_t *)"Jump", 6);
218 delay_ms(1000);
219 jump_to_app(flash_iap.write_addr);
220 break;
221 default:
222 break;
223 }
224
225}
226
232void jump_to_app(uint32_t address)
233{
234 uint32_t stkptr, jumpaddr;
235 stkptr = *(uint32_t *)address;
236 jumpaddr = *(uint32_t *)(address + sizeof(uint32_t));
237
238 /* clear usb crm */
239 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, FALSE);
240 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, FALSE);
241
242 crm_periph_reset(CRM_USB_PERIPH_RESET, TRUE);
243 crm_periph_reset(CRM_USB_PERIPH_RESET, FALSE);
244
245 __set_MSP(stkptr);
246 pftarget = (void (*) (void))jumpaddr;
247 pftarget();
248}
249
255void USBFS_L_CAN1_RX0_IRQHandler(void)
256{
257 usbd_irq_handler(&usb_core_dev);
258}
259
265void usb_delay_ms(uint32_t ms)
266{
267 /* user can define self delay function */
268 delay_ms(ms);
269}
270
276void usb_delay_us(uint32_t us)
277{
278 delay_us(us);
279}
280
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
flash_fat16.h
fat16 file system header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
usb_reset
void usb_reset()
usb re-connect
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:164
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:232
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:53
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:121
flash_fat16_loop_status
void flash_fat16_loop_status(void)
loop status
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:177
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:255
pftarget
void(* pftarget)(void)
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:43
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:41
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:93
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:234
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
CRM_USB_PERIPH_RESET
@ CRM_USB_PERIPH_RESET
Definition: at32f413_crm.h:180
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: flash_fat16.c:357
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: flash_fat16.c:268
flash_iap
flash_iap_type flash_iap
Definition: flash_fat16.c:171
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: flash_fat16.c:720
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: flash_fat16.h:84
UPGRADE_UNKNOWN
@ UPGRADE_UNKNOWN
Definition: flash_fat16.h:85
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: flash_fat16.h:87
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: flash_fat16.h:83
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: flash_fat16.h:82
UPGRADE_READY
@ UPGRADE_READY
Definition: flash_fat16.h:80
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: flash_fat16.h:81
UPGRADE_DONE
@ UPGRADE_DONE
Definition: flash_fat16.h:86
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:85
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:55
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:65
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_disconnect
void usbd_disconnect(usbd_core_type *udev)
usb device disconnect to host
Definition: usbd_core.c:569
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: flash_fat16.h:120
flash_iap_type::write_addr
uint32_t write_addr
Definition: flash_fat16.h:118
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: flash_fat16.h:109
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • wdt
  • wdt_reset
  • inc
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • wdt
  • wdt_reset
  • inc
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • wdt
  • wdt_reset
  • inc
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • wdt
  • wdt_reset
  • src
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • wdt
  • wdt_reset
  • src
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • wdt
  • wdt_reset
  • src
project/at_start_f413/examples/wdt/wdt_reset/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
42int main(void)
43{
44 system_clock_config();
45
46 at32_board_init();
47
48 if(crm_flag_get(CRM_WDT_RESET_FLAG) != RESET)
49 {
50 /* reset from wdt */
51 crm_flag_clear(CRM_WDT_RESET_FLAG);
52
53 at32_led_on(LED4);
54 }
55 else
56 {
57 /* reset from other mode */
58 at32_led_off(LED4);
59 }
60
61 /* disable register write protection */
62 wdt_register_write_enable(TRUE);
63
64 /* set the wdt divider value */
65 wdt_divider_set(WDT_CLK_DIV_4);
66
67 /* set reload value
68
69 timeout = reload_value * (divider / lick_freq ) (s)
70
71 lick_freq = 40000 Hz
72 divider = 4
73 reload_value = 3000
74
75 timeout = 3000 * (4 / 40000 ) = 0.3s = 300ms
76 */
77 wdt_reload_value_set(3000 - 1);
78
79 /* reload wdt counter */
80 wdt_counter_reload();
81
82 /* enable wdt */
83 wdt_enable();
84
85 while(1)
86 {
87 /* reload wdt counter */
88 wdt_counter_reload();
89
90 at32_led_toggle(LED3);
91
92 delay_ms(200);
93
94 if(at32_button_press() == USER_BUTTON)
95 {
96 while(1);
97 }
98 }
99}
100
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/main.c:42
LED3
@ LED3
Definition: at32f413_board.h:62
LED4
@ LED4
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:328
CRM_WDT_RESET_FLAG
#define CRM_WDT_RESET_FLAG
Definition: at32f413_crm.h:62
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:95
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:47
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f413_wdt.c:57
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:67
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:85
WDT_CLK_DIV_4
@ WDT_CLK_DIV_4
Definition: at32f413_wdt.h:67
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • wdt
  • wdt_standby
  • inc
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • wdt
  • wdt_standby
  • inc
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • wdt
  • wdt_standby
  • inc
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • wdt
  • wdt_standby
  • src
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • wdt
  • wdt_standby
  • src
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • wdt
  • wdt_standby
  • src
project/at_start_f413/examples/wdt/wdt_standby/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
42int main(void)
43{
44 system_clock_config();
45
46 at32_board_init();
47
48 /* enable the pwc clock */
49 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
50
51 if(crm_flag_get(CRM_WDT_RESET_FLAG) != RESET)
52 {
53 /* reset from wdt */
54 crm_flag_clear(CRM_WDT_RESET_FLAG);
55
56 at32_led_on(LED4);
57 }
58 else
59 {
60 /* reset from other mode */
61 at32_led_off(LED4);
62 }
63
64 delay_ms(100);
65
66 /* disable register write protection */
67 wdt_register_write_enable(TRUE);
68
69 /* set the wdt divider value */
70 wdt_divider_set(WDT_CLK_DIV_4);
71
72 /* set reload value
73
74 timeout = reload_value * (divider / lick_freq ) (s)
75
76 lick_freq = 40000 Hz
77 divider = 4
78 reload_value = 3000
79
80 timeout = 3000 * (4 / 40000 ) = 0.3s = 300ms
81 */
82 wdt_reload_value_set(3000 - 1);
83
84 /* reload wdt counter */
85 wdt_counter_reload();
86
87 /* enable wdt */
88 wdt_enable();
89
90 /* delay 100us wait for iwdg enable successfully */
91 delay_us(100);
92
93 /* enter standby mode */
94 pwc_standby_mode_enter();
95
96 while(1)
97 {
98
99 }
100}
101
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/main.c:42
LED4
@ LED4
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:328
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_WDT_RESET_FLAG
#define CRM_WDT_RESET_FLAG
Definition: at32f413_crm.h:62
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:208
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:95
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:47
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f413_wdt.c:57
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:67
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:85
WDT_CLK_DIV_4
@ WDT_CLK_DIV_4
Definition: at32f413_wdt.h:67
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • wwdt
  • wwdt_reset
  • inc
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • wwdt
  • wwdt_reset
  • inc
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • wwdt
  • wwdt_reset
  • inc
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • wwdt
  • wwdt_reset
  • src
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c:46
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • wwdt
  • wwdt_reset
  • src
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while(1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while(1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while(1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while(1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:112
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • wwdt
  • wwdt_reset
  • src
project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
41int main(void)
42{
43 system_clock_config();
44
45 at32_board_init();
46
47 if(crm_flag_get(CRM_WWDT_RESET_FLAG) != RESET)
48 {
49 /* reset from wwdt */
50 crm_flag_clear(CRM_WWDT_RESET_FLAG);
51
52 at32_led_on(LED4);
53 }
54 else
55 {
56 /* reset from other mode */
57 at32_led_off(LED4);
58 }
59
60 /* enable the wwdt clock */
61 crm_periph_clock_enable(CRM_WWDT_PERIPH_CLOCK, TRUE);
62
63 /* set the wwdt divider value */
64 wwdt_divider_set(WWDT_PCLK1_DIV_32768);
65
66 /* set the wwdt window counter value */
67 wwdt_window_counter_set(0x6F);
68
69 /* enable wwdt
70
71 window_value: (0x7F - 0x6F)
72 timeout_value: (0x7F - 0x40) + 1
73
74 timeout = timeout_value * (divider / pclk1_freq ) (s)
75 window = window_value * (divider / pclk1_freq ) (s)
76
77 pclk1_freq = 120 MHz
78 divider = 32768
79 reload_value = 0x40 = 64
80 window_value = 0x10 = 16
81
82 timeout = 64 * (32768 / 96000000 ) = 0.0218s = 21.8ms
83 window = 16 * (32768 / 96000000 ) = 0.0055s = 5.5ms
84
85 */
86 wwdt_enable(0x7F);
87
88 while(1)
89 {
90 at32_led_toggle(LED3);
91
92 /* the reload time must within the window (8ms > 5.5ms) */
93 delay_ms(8);
94
95 /* update the wwdt window counter */
96 wwdt_counter_set(0x7F);
97
98 if(at32_button_press() == USER_BUTTON)
99 {
100 while(1);
101 }
102 }
103}
104
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:62
LED4
@ LED4
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:92
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:328
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_WWDT_PERIPH_CLOCK
@ CRM_WWDT_PERIPH_CLOCK
Definition: at32f413_crm.h:128
CRM_WWDT_RESET_FLAG
#define CRM_WWDT_RESET_FLAG
Definition: at32f413_crm.h:63
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f413_wwdt.c:112
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f413_wwdt.c:62
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f413_wwdt.c:122
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f413_wwdt.c:82
WWDT_PCLK1_DIV_32768
@ WWDT_PCLK1_DIV_32768
Definition: at32f413_wwdt.h:68
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • templates
  • inc
project/at_start_f413/templates/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • templates
  • inc
project/at_start_f413/templates/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
50#if !defined HEXT_VALUE
51#define HEXT_VALUE ((uint32_t)8000000)
52#endif
53
58#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
59#define HICK_VALUE ((uint32_t)8000000)
60#define LEXT_VALUE ((uint32_t)32768)
62/* module define -------------------------------------------------------------*/
63#define CRM_MODULE_ENABLED
64#define TMR_MODULE_ENABLED
65#define RTC_MODULE_ENABLED
66#define BPR_MODULE_ENABLED
67#define GPIO_MODULE_ENABLED
68#define I2C_MODULE_ENABLED
69#define USART_MODULE_ENABLED
70#define PWC_MODULE_ENABLED
71#define CAN_MODULE_ENABLED
72#define ADC_MODULE_ENABLED
73#define SPI_MODULE_ENABLED
74#define DMA_MODULE_ENABLED
75#define DEBUG_MODULE_ENABLED
76#define FLASH_MODULE_ENABLED
77#define CRC_MODULE_ENABLED
78#define WWDT_MODULE_ENABLED
79#define WDT_MODULE_ENABLED
80#define EXINT_MODULE_ENABLED
81#define SDIO_MODULE_ENABLED
82#define USB_MODULE_ENABLED
83#define ACC_MODULE_ENABLED
84#define MISC_MODULE_ENABLED
85
86/* includes ------------------------------------------------------------------*/
87#ifdef CRM_MODULE_ENABLED
88#include "at32f413_crm.h"
89#endif
90#ifdef TMR_MODULE_ENABLED
91#include "at32f413_tmr.h"
92#endif
93#ifdef RTC_MODULE_ENABLED
94#include "at32f413_rtc.h"
95#endif
96#ifdef BPR_MODULE_ENABLED
97#include "at32f413_bpr.h"
98#endif
99#ifdef GPIO_MODULE_ENABLED
100#include "at32f413_gpio.h"
101#endif
102#ifdef I2C_MODULE_ENABLED
103#include "at32f413_i2c.h"
104#endif
105#ifdef USART_MODULE_ENABLED
106#include "at32f413_usart.h"
107#endif
108#ifdef PWC_MODULE_ENABLED
109#include "at32f413_pwc.h"
110#endif
111#ifdef CAN_MODULE_ENABLED
112#include "at32f413_can.h"
113#endif
114#ifdef ADC_MODULE_ENABLED
115#include "at32f413_adc.h"
116#endif
117#ifdef SPI_MODULE_ENABLED
118#include "at32f413_spi.h"
119#endif
120#ifdef DMA_MODULE_ENABLED
121#include "at32f413_dma.h"
122#endif
123#ifdef DEBUG_MODULE_ENABLED
124#include "at32f413_debug.h"
125#endif
126#ifdef FLASH_MODULE_ENABLED
127#include "at32f413_flash.h"
128#endif
129#ifdef CRC_MODULE_ENABLED
130#include "at32f413_crc.h"
131#endif
132#ifdef WWDT_MODULE_ENABLED
133#include "at32f413_wwdt.h"
134#endif
135#ifdef WDT_MODULE_ENABLED
136#include "at32f413_wdt.h"
137#endif
138#ifdef EXINT_MODULE_ENABLED
139#include "at32f413_exint.h"
140#endif
141#ifdef SDIO_MODULE_ENABLED
142#include "at32f413_sdio.h"
143#endif
144#ifdef ACC_MODULE_ENABLED
145#include "at32f413_acc.h"
146#endif
147#ifdef MISC_MODULE_ENABLED
148#include "at32f413_misc.h"
149#endif
150#ifdef USB_MODULE_ENABLED
151#include "at32f413_usb.h"
152#endif
153
162#ifdef __cplusplus
163}
164#endif
165
166#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • templates
  • inc
project/at_start_f413/templates/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • templates
  • src
project/at_start_f413/templates/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
54void system_clock_config(void)
55{
56 /* reset crm */
57 crm_reset();
58
59 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
60
61 /* wait till hext is ready */
62 while(crm_hext_stable_wait() == ERROR)
63 {
64 }
65
66 /* config pll clock resource */
67 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
68
69 /* enable pll */
70 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
71
72 /* wait till pll is ready */
73 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
74 {
75 }
76
77 /* config ahbclk */
78 crm_ahb_div_set(CRM_AHB_DIV_1);
79
80 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
81 crm_apb2_div_set(CRM_APB2_DIV_2);
82
83 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
84 crm_apb1_div_set(CRM_APB1_DIV_2);
85
86 /* enable auto step mode */
87 crm_auto_step_mode_enable(TRUE);
88
89 /* select pll as system clock source */
90 crm_sysclk_switch(CRM_SCLK_PLL);
91
92 /* wait till pll is used as system clock source */
93 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
94 {
95 }
96
97 /* disable auto step mode */
98 crm_auto_step_mode_enable(FALSE);
99
100 /* update system_core_clock global variable */
101 system_core_clock_update();
102}
103
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/templates/src/at32f413_clock.c:54
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • templates
  • src
project/at_start_f413/templates/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/templates/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • templates
  • src
project/at_start_f413/templates/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27
36#define DELAY 100
37#define FAST 1
38#define SLOW 4
39
40uint8_t g_speed = FAST;
41
42void button_exint_init(void);
43void button_isr(void);
44
50void button_exint_init(void)
51{
52 exint_init_type exint_init_struct;
53
54 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
55 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
56
57 exint_default_para_init(&exint_init_struct);
58 exint_init_struct.line_enable = TRUE;
59 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
60 exint_init_struct.line_select = EXINT_LINE_0;
61 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
62 exint_init(&exint_init_struct);
63
64 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
65 nvic_irq_enable(EXINT0_IRQn, 0, 0);
66}
67
73void button_isr(void)
74{
75 /* delay 5ms */
76 delay_ms(5);
77
78 /* clear interrupt pending bit */
79 exint_flag_clear(EXINT_LINE_0);
80
81 /* check input pin state */
82 if(SET == gpio_input_data_bit_read(USER_BUTTON_PORT, USER_BUTTON_PIN))
83 {
84 if(g_speed == SLOW)
85 g_speed = FAST;
86 else
87 g_speed = SLOW;
88 }
89}
90
96void EXINT0_IRQHandler(void)
97{
98 button_isr();
99}
100
106int main(void)
107{
108 system_clock_config();
109
110 at32_board_init();
111
112 button_exint_init();
113
114 while(1)
115 {
116 at32_led_toggle(LED2);
117 delay_ms(g_speed * DELAY);
118 at32_led_toggle(LED3);
119 delay_ms(g_speed * DELAY);
120 at32_led_toggle(LED4);
121 delay_ms(g_speed * DELAY);
122 }
123}
124
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
SLOW
#define SLOW
Definition: project/at_start_f413/templates/src/main.c:38
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f413/templates/src/main.c:50
DELAY
#define DELAY
Definition: project/at_start_f413/templates/src/main.c:36
FAST
#define FAST
Definition: project/at_start_f413/templates/src/main.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/templates/src/main.c:106
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/templates/src/main.c:96
g_speed
uint8_t g_speed
Definition: project/at_start_f413/templates/src/main.c:40
button_isr
void button_isr(void)
button handler function
Definition: project/at_start_f413/templates/src/main.c:73
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
USER_BUTTON_PORT
#define USER_BUTTON_PORT
Definition: at32f413_board.h:97
USER_BUTTON_PIN
#define USER_BUTTON_PIN
Definition: at32f413_board.h:96
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:107
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:176
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:124
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:62
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:76
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:82
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:91
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:50
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:201
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:571
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:252
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:275
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
exint_init_type
exint init type
Definition: at32f413_exint.h:100
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:102
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:104
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:101
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:103
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: fir_filter.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
project_l0/inc/fir_filter.h
Go to the documentation of this file.
1
30/* Define to prevent recursive inclusion -------------------------------------*/
31#ifndef __FIR_FILTER_H
32#define __FIR_FILTER_H
33
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "arm_math.h"
38
39/* Exported types ------------------------------------------------------------*/
40/* Exported constants --------------------------------------------------------*/
41/* Exported macro ------------------------------------------------------------*/
42/* Exported functions ------------------------------------------------------- */
43void arm_fir_init_f32(
44 arm_fir_instance_f32 * S,
45 uint16_t numTaps,
46 const float32_t * pCoeffs,
47 float32_t * pState,
48 uint32_t blockSize);
49
50void arm_fir_f32(
51const arm_fir_instance_f32 * S,
52const float32_t * pSrc,
53float32_t * pDst,
54uint32_t blockSize);
55
56void FIR_lowpass_filter(float32_t * pSrc, float32_t * pDst, uint32_t testlengthsamples);
57
58#endif /* __FIR_FILTER_H */
59
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76


AT32F413 Firmwary Library: math_helper.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
project_l0/inc/math_helper.h
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2013 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.h
10*
11* Description: Prototypes of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41
42
43#include "arm_math.h"
44
45#ifndef MATH_HELPER_H
46#define MATH_HELPER_H
47
48float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize);
49void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples);
50void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
51void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
52void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples);
53void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples);
54void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples);
55void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples);
56void arm_clip_f32(float *pIn, uint32_t numSamples);
57uint32_t arm_calc_guard_bits(uint32_t num_adds);
58void arm_apply_guard_bits (float32_t * pIn, uint32_t numSamples, uint32_t guard_bits);
59uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t * pOut, uint32_t numSamples);
60uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples);
61uint32_t arm_calc_2pow(uint32_t guard_bits);
62#endif
63
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l0/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l0/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l0/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:193
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l0/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:165
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t guard_bits)
Calculates pow(2, numShifts)
Definition: project_l0/src/math_helper.c:310
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l0/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l0/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:119
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61


AT32F413 Firmwary Library: arm_fir_data.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
project_l0/src/arm_fir_data.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8* Title: arm_fir_data.c
9*
10* Description: Data file used for example code
11*
12* Target Processor: Cortex-M4/Cortex-M3/Cortex-M0
13*
14* Redistribution and use in source and binary forms, with or without
15* modification, are permitted provided that the following conditions
16* are met:
17* - Redistributions of source code must retain the above copyright
18* notice, this list of conditions and the following disclaimer.
19* - Redistributions in binary form must reproduce the above copyright
20* notice, this list of conditions and the following disclaimer in
21* the documentation and/or other materials provided with the
22* distribution.
23* - Neither the name of ARM LIMITED nor the names of its contributors
24* may be used to endorse or promote products derived from this
25* software without specific prior written permission.
26*
27* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
28* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
29* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
30* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
31* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
32* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
33* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
34* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
35* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
36* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
37* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
38* POSSIBILITY OF SUCH DAMAGE.
39* -------------------------------------------------------------------- */
40
41#include "at32f413.h"
42#include "arm_math.h"
43
44/* ----------------------------------------------------------------------
45** Test input signal contains 1000Hz + 15000 Hz
46** ------------------------------------------------------------------- */
47
48float32_t testInput_f32_1kHz_15kHz[320] =
49{
50+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
51+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
52+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
53-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
54-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
55-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
56+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
57+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
58+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
59+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
60-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
61-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
62+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
63+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
64+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
65+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
66-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
67-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
68-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
69+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
70+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
71-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
72-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
73-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
74+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
75+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
76+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
77+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
78-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
79-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
80-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
81+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
82+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
83+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
84-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
85-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
86-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
87+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
88+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
89+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
90};
91
92/* ----------------------------------------------------------------------
93** Reference output signal computed with MATLAB
94** ------------------------------------------------------------------- */
95
96float32_t refOutput[320] =
97{
98+0.0000000000f, -0.0010797829f, -0.0007681386f, -0.0001982932f, +0.0000644313f, +0.0020854271f, +0.0036891871f, +0.0015855941f,
99-0.0026280805f, -0.0075907658f, -0.0119390538f, -0.0086665968f, +0.0088981202f, +0.0430539279f, +0.0974468742f, +0.1740405600f,
100+0.2681416601f, +0.3747720089f, +0.4893362230f, +0.6024154672f, +0.7058740791f, +0.7968348987f, +0.8715901940f, +0.9277881093f,
101+0.9682182661f, +0.9934674267f, +1.0012052245f, +0.9925859371f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
102+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
103-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
104-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
105-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
106+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
107+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
108+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
109-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
110-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
111-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
112+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
113+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
114+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
115-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
116-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
117-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
118+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
119+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
120+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
121-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
122-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
123-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
124+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
125+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
126+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
127-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
128-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
129-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, -0.0000000000f, +0.1309866321f,
130+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
131+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
132+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
133-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
134-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
135-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
136+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
137+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f
138};
139
at32f413.h
at32f413 header file
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[320]
Definition: project_l0/src/arm_fir_data.c:48
refOutput
float32_t refOutput[320]
Definition: project_l0/src/arm_fir_data.c:96


AT32F413 Firmwary Library: math_helper.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
project_l0/src/math_helper.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0 b
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.c
10*
11* Description: Definition of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42* Include standard header files
43* -------------------------------------------------------------------- */
44#include<math.h>
45
46/* ----------------------------------------------------------------------
47* Include project header files
48* -------------------------------------------------------------------- */
49#include "math_helper.h"
50
61float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
62{
63 float EnergySignal = 0.0, EnergyError = 0.0;
64 uint32_t i;
65 float SNR;
66 int temp;
67 int *test;
68
69 for (i = 0; i < buffSize; i++)
70 {
71 /* Checking for a NAN value in pRef array */
72 test = (int *)(&pRef[i]);
73 temp = *test;
74
75 if (temp == 0x7FC00000)
76 {
77 return(0);
78 }
79
80 /* Checking for a NAN value in pTest array */
81 test = (int *)(&pTest[i]);
82 temp = *test;
83
84 if (temp == 0x7FC00000)
85 {
86 return(0);
87 }
88 EnergySignal += pRef[i] * pRef[i];
89 EnergyError += (pRef[i] - pTest[i]) * (pRef[i] - pTest[i]);
90 }
91
92 /* Checking for a NAN value in EnergyError */
93 test = (int *)(&EnergyError);
94 temp = *test;
95
96 if (temp == 0x7FC00000)
97 {
98 return(0);
99 }
100
101
102 SNR = 10 * log10 (EnergySignal / EnergyError);
103
104 return (SNR);
105
106}
107
108
119void arm_provide_guard_bits_q15 (q15_t * input_buf, uint32_t blockSize,
120 uint32_t guard_bits)
121{
122 uint32_t i;
123
124 for (i = 0; i < blockSize; i++)
125 {
126 input_buf[i] = input_buf[i] >> guard_bits;
127 }
128}
129
139void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples)
140{
141 uint32_t i;
142
143 for (i = 0; i < numSamples; i++)
144 {
145 /* 1048576.0f corresponds to pow(2, 20) */
146 pOut[i] = (q31_t) (pIn[i] * 1048576.0f);
147
148 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
149
150 if (pIn[i] == (float) 1.0)
151 {
152 pOut[i] = 0x000FFFFF;
153 }
154 }
155}
156
165uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
166{
167 uint32_t i;
168 int32_t diff, diffCrnt = 0;
169 uint32_t maxDiff = 0;
170
171 for (i = 0; i < numSamples; i++)
172 {
173 diff = pIn[i] - pOut[i];
174 diffCrnt = (diff > 0) ? diff : -diff;
175
176 if (diffCrnt > maxDiff)
177 {
178 maxDiff = diffCrnt;
179 }
180 }
181
182 return(maxDiff);
183}
184
193uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t * pOut, uint32_t numSamples)
194{
195 uint32_t i;
196 int32_t diff, diffCrnt = 0;
197 uint32_t maxDiff = 0;
198
199 for (i = 0; i < numSamples; i++)
200 {
201 diff = pIn[i] - pOut[i];
202 diffCrnt = (diff > 0) ? diff : -diff;
203
204 if (diffCrnt > maxDiff)
205 {
206 maxDiff = diffCrnt;
207 }
208 }
209
210 return(maxDiff);
211}
212
223void arm_provide_guard_bits_q31 (q31_t * input_buf,
224 uint32_t blockSize,
225 uint32_t guard_bits)
226{
227 uint32_t i;
228
229 for (i = 0; i < blockSize; i++)
230 {
231 input_buf[i] = input_buf[i] >> guard_bits;
232 }
233}
234
245void arm_provide_guard_bits_q7 (q7_t * input_buf,
246 uint32_t blockSize,
247 uint32_t guard_bits)
248{
249 uint32_t i;
250
251 for (i = 0; i < blockSize; i++)
252 {
253 input_buf[i] = input_buf[i] >> guard_bits;
254 }
255}
256
257
258
267uint32_t arm_calc_guard_bits (uint32_t num_adds)
268{
269 uint32_t i = 1, j = 0;
270
271 if (num_adds == 1)
272 {
273 return (0);
274 }
275
276 while (i < num_adds)
277 {
278 i = i * 2;
279 j++;
280 }
281
282 return (j);
283}
284
293void arm_apply_guard_bits (float32_t *pIn,
294 uint32_t numSamples,
295 uint32_t guard_bits)
296{
297 uint32_t i;
298
299 for (i = 0; i < numSamples; i++)
300 {
301 pIn[i] = pIn[i] * arm_calc_2pow(guard_bits);
302 }
303}
304
310uint32_t arm_calc_2pow(uint32_t numShifts)
311{
312
313 uint32_t i, val = 1;
314
315 for (i = 0; i < numShifts; i++)
316 {
317 val = val * 2;
318 }
319
320 return(val);
321}
322
323
324
334void arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
335{
336 uint32_t i;
337
338 for (i = 0; i < numSamples; i++)
339 {
340 /* 16384.0f corresponds to pow(2, 14) */
341 pOut[i] = (q15_t) (pIn[i] * 16384.0f);
342
343 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
344
345 if (pIn[i] == (float) 2.0)
346 {
347 pOut[i] = 0x7FFF;
348 }
349
350 }
351
352}
353
354
364void arm_float_to_q30 (float *pIn, q31_t * pOut, uint32_t numSamples)
365{
366 uint32_t i;
367
368 for (i = 0; i < numSamples; i++)
369 {
370 /* 1073741824.0f corresponds to pow(2, 30) */
371 pOut[i] = (q31_t) (pIn[i] * 1073741824.0f);
372
373 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
374
375 if (pIn[i] == (float) 2.0)
376 {
377 pOut[i] = 0x7FFFFFFF;
378 }
379 }
380}
381
391void arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
392{
393 uint32_t i;
394
395 for (i = 0; i < numSamples; i++)
396 {
397 /* 1073741824.0f corresponds to pow(2, 30) */
398 pOut[i] = (q31_t) (pIn[i] * 536870912.0f);
399
400 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
401
402 if (pIn[i] == (float) 4.0)
403 {
404 pOut[i] = 0x7FFFFFFF;
405 }
406 }
407}
408
409
419void arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
420{
421 uint32_t i;
422
423 for (i = 0; i < numSamples; i++)
424 {
425 /* 268435456.0f corresponds to pow(2, 28) */
426 pOut[i] = (q31_t) (pIn[i] * 268435456.0f);
427
428 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
429
430 if (pIn[i] == (float) 8.0)
431 {
432 pOut[i] = 0x7FFFFFFF;
433 }
434 }
435}
436
445void arm_clip_f32 (float *pIn, uint32_t numSamples)
446{
447 uint32_t i;
448
449 for (i = 0; i < numSamples; i++)
450 {
451 if (pIn[i] > 1.0f)
452 {
453 pIn[i] = 1.0;
454 }
455 else if ( pIn[i] < -1.0f)
456 {
457 pIn[i] = -1.0;
458 }
459
460 }
461}
462
463
464
465
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l0/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l0/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l0/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:193
arm_provide_guard_bits_q7
void arm_provide_guard_bits_q7(q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:245
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l0/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:165
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l0/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l0/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:119
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t numShifts)
Calculates pow(2, numShifts)
Definition: project_l0/src/math_helper.c:310
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61


AT32F413 Firmwary Library: fir_filter.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
project_l1/inc/fir_filter.h
Go to the documentation of this file.
1
30/* Define to prevent recursive inclusion -------------------------------------*/
31#ifndef __FIR_FILTER_H
32#define __FIR_FILTER_H
33
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "arm_math.h"
38
39/* Exported types ------------------------------------------------------------*/
40/* Exported constants --------------------------------------------------------*/
41/* Exported macro ------------------------------------------------------------*/
42/* Exported functions ------------------------------------------------------- */
43void arm_fir_init_f32(
44 arm_fir_instance_f32 * S,
45 uint16_t numTaps,
46 const float32_t * pCoeffs,
47 float32_t * pState,
48 uint32_t blockSize);
49
50void arm_fir_f32(
51const arm_fir_instance_f32 * S,
52const float32_t * pSrc,
53float32_t * pDst,
54uint32_t blockSize);
55
56void FIR_lowpass_filter(float32_t * pSrc, float32_t * pDst, uint32_t testlengthsamples);
57
58#endif /* __FIR_FILTER_H */
59
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76


AT32F413 Firmwary Library: math_helper.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
project_l1/inc/math_helper.h
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2013 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.h
10*
11* Description: Prototypes of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41
42
43#include "arm_math.h"
44
45#ifndef MATH_HELPER_H
46#define MATH_HELPER_H
47
48float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize);
49void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples);
50void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
51void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
52void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples);
53void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples);
54void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples);
55void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples);
56void arm_clip_f32(float *pIn, uint32_t numSamples);
57uint32_t arm_calc_guard_bits(uint32_t num_adds);
58void arm_apply_guard_bits (float32_t * pIn, uint32_t numSamples, uint32_t guard_bits);
59uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t * pOut, uint32_t numSamples);
60uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples);
61uint32_t arm_calc_2pow(uint32_t guard_bits);
62#endif
63
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l0/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l0/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l0/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:193
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l0/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:165
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t guard_bits)
Calculates pow(2, numShifts)
Definition: project_l0/src/math_helper.c:310
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l0/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l0/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:119
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61


AT32F413 Firmwary Library: arm_fir_data.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
project_l1/src/arm_fir_data.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8* Title: arm_fir_data.c
9*
10* Description: Data file used for example code
11*
12* Target Processor: Cortex-M4/Cortex-M3/Cortex-M0
13*
14* Redistribution and use in source and binary forms, with or without
15* modification, are permitted provided that the following conditions
16* are met:
17* - Redistributions of source code must retain the above copyright
18* notice, this list of conditions and the following disclaimer.
19* - Redistributions in binary form must reproduce the above copyright
20* notice, this list of conditions and the following disclaimer in
21* the documentation and/or other materials provided with the
22* distribution.
23* - Neither the name of ARM LIMITED nor the names of its contributors
24* may be used to endorse or promote products derived from this
25* software without specific prior written permission.
26*
27* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
28* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
29* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
30* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
31* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
32* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
33* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
34* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
35* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
36* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
37* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
38* POSSIBILITY OF SUCH DAMAGE.
39* -------------------------------------------------------------------- */
40
41#include "at32f413.h"
42#include "arm_math.h"
43
44/* ----------------------------------------------------------------------
45** Test input signal contains 1000Hz + 15000 Hz
46** ------------------------------------------------------------------- */
47
48float32_t testInput_f32_1kHz_15kHz[320] =
49{
50+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
51+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
52+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
53-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
54-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
55-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
56+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
57+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
58+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
59+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
60-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
61-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
62+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
63+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
64+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
65+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
66-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
67-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
68-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
69+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
70+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
71-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
72-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
73-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
74+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
75+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
76+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
77+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
78-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
79-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
80-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
81+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
82+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
83+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
84-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
85-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
86-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
87+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
88+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
89+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
90};
91
92/* ----------------------------------------------------------------------
93** Reference output signal computed with MATLAB
94** ------------------------------------------------------------------- */
95
96float32_t refOutput[320] =
97{
98+0.0000000000f, -0.0010797829f, -0.0007681386f, -0.0001982932f, +0.0000644313f, +0.0020854271f, +0.0036891871f, +0.0015855941f,
99-0.0026280805f, -0.0075907658f, -0.0119390538f, -0.0086665968f, +0.0088981202f, +0.0430539279f, +0.0974468742f, +0.1740405600f,
100+0.2681416601f, +0.3747720089f, +0.4893362230f, +0.6024154672f, +0.7058740791f, +0.7968348987f, +0.8715901940f, +0.9277881093f,
101+0.9682182661f, +0.9934674267f, +1.0012052245f, +0.9925859371f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
102+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
103-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
104-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
105-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
106+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
107+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
108+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
109-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
110-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
111-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
112+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
113+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
114+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
115-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
116-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
117-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
118+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
119+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
120+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
121-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
122-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
123-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
124+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
125+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
126+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
127-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
128-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
129-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, -0.0000000000f, +0.1309866321f,
130+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
131+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
132+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
133-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
134-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
135-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
136+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
137+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f
138};
139
at32f413.h
at32f413 header file
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[320]
Definition: project_l1/src/arm_fir_data.c:48
refOutput
float32_t refOutput[320]
Definition: project_l1/src/arm_fir_data.c:96


AT32F413 Firmwary Library: math_helper.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
project_l1/src/math_helper.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0 b
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.c
10*
11* Description: Definition of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42* Include standard header files
43* -------------------------------------------------------------------- */
44#include<math.h>
45
46/* ----------------------------------------------------------------------
47* Include project header files
48* -------------------------------------------------------------------- */
49#include "math_helper.h"
50
61float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
62{
63 float EnergySignal = 0.0, EnergyError = 0.0;
64 uint32_t i;
65 float SNR;
66 int temp;
67 int *test;
68
69 for (i = 0; i < buffSize; i++)
70 {
71 /* Checking for a NAN value in pRef array */
72 test = (int *)(&pRef[i]);
73 temp = *test;
74
75 if (temp == 0x7FC00000)
76 {
77 return(0);
78 }
79
80 /* Checking for a NAN value in pTest array */
81 test = (int *)(&pTest[i]);
82 temp = *test;
83
84 if (temp == 0x7FC00000)
85 {
86 return(0);
87 }
88 EnergySignal += pRef[i] * pRef[i];
89 EnergyError += (pRef[i] - pTest[i]) * (pRef[i] - pTest[i]);
90 }
91
92 /* Checking for a NAN value in EnergyError */
93 test = (int *)(&EnergyError);
94 temp = *test;
95
96 if (temp == 0x7FC00000)
97 {
98 return(0);
99 }
100
101
102 SNR = 10 * log10 (EnergySignal / EnergyError);
103
104 return (SNR);
105
106}
107
108
119void arm_provide_guard_bits_q15 (q15_t * input_buf, uint32_t blockSize,
120 uint32_t guard_bits)
121{
122 uint32_t i;
123
124 for (i = 0; i < blockSize; i++)
125 {
126 input_buf[i] = input_buf[i] >> guard_bits;
127 }
128}
129
139void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples)
140{
141 uint32_t i;
142
143 for (i = 0; i < numSamples; i++)
144 {
145 /* 1048576.0f corresponds to pow(2, 20) */
146 pOut[i] = (q31_t) (pIn[i] * 1048576.0f);
147
148 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
149
150 if (pIn[i] == (float) 1.0)
151 {
152 pOut[i] = 0x000FFFFF;
153 }
154 }
155}
156
165uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
166{
167 uint32_t i;
168 int32_t diff, diffCrnt = 0;
169 uint32_t maxDiff = 0;
170
171 for (i = 0; i < numSamples; i++)
172 {
173 diff = pIn[i] - pOut[i];
174 diffCrnt = (diff > 0) ? diff : -diff;
175
176 if (diffCrnt > maxDiff)
177 {
178 maxDiff = diffCrnt;
179 }
180 }
181
182 return(maxDiff);
183}
184
193uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t * pOut, uint32_t numSamples)
194{
195 uint32_t i;
196 int32_t diff, diffCrnt = 0;
197 uint32_t maxDiff = 0;
198
199 for (i = 0; i < numSamples; i++)
200 {
201 diff = pIn[i] - pOut[i];
202 diffCrnt = (diff > 0) ? diff : -diff;
203
204 if (diffCrnt > maxDiff)
205 {
206 maxDiff = diffCrnt;
207 }
208 }
209
210 return(maxDiff);
211}
212
223void arm_provide_guard_bits_q31 (q31_t * input_buf,
224 uint32_t blockSize,
225 uint32_t guard_bits)
226{
227 uint32_t i;
228
229 for (i = 0; i < blockSize; i++)
230 {
231 input_buf[i] = input_buf[i] >> guard_bits;
232 }
233}
234
245void arm_provide_guard_bits_q7 (q7_t * input_buf,
246 uint32_t blockSize,
247 uint32_t guard_bits)
248{
249 uint32_t i;
250
251 for (i = 0; i < blockSize; i++)
252 {
253 input_buf[i] = input_buf[i] >> guard_bits;
254 }
255}
256
257
258
267uint32_t arm_calc_guard_bits (uint32_t num_adds)
268{
269 uint32_t i = 1, j = 0;
270
271 if (num_adds == 1)
272 {
273 return (0);
274 }
275
276 while (i < num_adds)
277 {
278 i = i * 2;
279 j++;
280 }
281
282 return (j);
283}
284
293void arm_apply_guard_bits (float32_t *pIn,
294 uint32_t numSamples,
295 uint32_t guard_bits)
296{
297 uint32_t i;
298
299 for (i = 0; i < numSamples; i++)
300 {
301 pIn[i] = pIn[i] * arm_calc_2pow(guard_bits);
302 }
303}
304
310uint32_t arm_calc_2pow(uint32_t numShifts)
311{
312
313 uint32_t i, val = 1;
314
315 for (i = 0; i < numShifts; i++)
316 {
317 val = val * 2;
318 }
319
320 return(val);
321}
322
323
324
334void arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
335{
336 uint32_t i;
337
338 for (i = 0; i < numSamples; i++)
339 {
340 /* 16384.0f corresponds to pow(2, 14) */
341 pOut[i] = (q15_t) (pIn[i] * 16384.0f);
342
343 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
344
345 if (pIn[i] == (float) 2.0)
346 {
347 pOut[i] = 0x7FFF;
348 }
349
350 }
351
352}
353
354
364void arm_float_to_q30 (float *pIn, q31_t * pOut, uint32_t numSamples)
365{
366 uint32_t i;
367
368 for (i = 0; i < numSamples; i++)
369 {
370 /* 1073741824.0f corresponds to pow(2, 30) */
371 pOut[i] = (q31_t) (pIn[i] * 1073741824.0f);
372
373 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
374
375 if (pIn[i] == (float) 2.0)
376 {
377 pOut[i] = 0x7FFFFFFF;
378 }
379 }
380}
381
391void arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
392{
393 uint32_t i;
394
395 for (i = 0; i < numSamples; i++)
396 {
397 /* 1073741824.0f corresponds to pow(2, 30) */
398 pOut[i] = (q31_t) (pIn[i] * 536870912.0f);
399
400 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
401
402 if (pIn[i] == (float) 4.0)
403 {
404 pOut[i] = 0x7FFFFFFF;
405 }
406 }
407}
408
409
419void arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
420{
421 uint32_t i;
422
423 for (i = 0; i < numSamples; i++)
424 {
425 /* 268435456.0f corresponds to pow(2, 28) */
426 pOut[i] = (q31_t) (pIn[i] * 268435456.0f);
427
428 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
429
430 if (pIn[i] == (float) 8.0)
431 {
432 pOut[i] = 0x7FFFFFFF;
433 }
434 }
435}
436
445void arm_clip_f32 (float *pIn, uint32_t numSamples)
446{
447 uint32_t i;
448
449 for (i = 0; i < numSamples; i++)
450 {
451 if (pIn[i] > 1.0f)
452 {
453 pIn[i] = 1.0;
454 }
455 else if ( pIn[i] < -1.0f)
456 {
457 pIn[i] = -1.0;
458 }
459
460 }
461}
462
463
464
465
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l1/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l1/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l1/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l1/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l1/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l1/src/math_helper.c:193
arm_provide_guard_bits_q7
void arm_provide_guard_bits_q7(q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l1/src/math_helper.c:245
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l1/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l1/src/math_helper.c:165
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l1/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l1/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l1/src/math_helper.c:119
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t numShifts)
Calculates pow(2, numShifts)
Definition: project_l1/src/math_helper.c:310
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l1/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l1/src/math_helper.c:61


AT32F413 Firmwary Library: random.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
random.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "random.h"
27#include "stdio.h"
28#include <stdlib.h>
29
38/* define at32 mcu uid address */
39#define DEVICE_ID_ADDR1 0x1FFFF7E8
40
46int get_uid_for_seed (void)
47{
48 uint32_t id[3] = {0};
49 uint32_t uid_one_word;
50
51 /* get uid */
52 id[0] = *(int*)DEVICE_ID_ADDR1;
53 id[2] = *(int*)(DEVICE_ID_ADDR1+8);
54 uid_one_word=id[0]&0x7fffffff+((id[2]&(~0x7fffffff))<<16);
55 return uid_one_word;
56}
57
63#if ENABLE_RTC_ASSEED
64void rtc_init_for_seed (void)
65{
66 /* enable pwc and bpr clocks */
67 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
69
70 /* allow access to bpr domain */
71 pwc_battery_powered_domain_access(TRUE);
72
73 if (bpr_data_read(BPR_DATA1) != 0x5051)
74 {
75 /* reset bpr domain */
76 bpr_reset();
77
78 /* enable the lext osc */
79 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
80 /* wait lext is ready */
81 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
82 /* select the rtc clock source */
83 crm_rtc_clock_select(CRM_RTC_CLOCK_LEXT);
84
85 /* enable rtc clock */
86 crm_rtc_clock_enable(TRUE);
87
88 /* wait for rtc registers update */
89 rtc_wait_update_finish();
90
91 /* wait for the register write to complete */
92 rtc_wait_config_finish();
93
94 /* set rtc divider: set rtc period to 1sec */
95 rtc_divider_set(32767);
96
97 /* wait for the register write to complete */
98 rtc_wait_config_finish();
99
100 /* writes data to bpr register */
101 bpr_data_write(BPR_DATA1, 0x5051);
102 }
103 else
104 {
105 /* wait for rtc registers update */
106 rtc_wait_update_finish();
107
108 /* wait for the register write to complete */
109 rtc_wait_config_finish();
110 }
111}
112
113#endif
114
120void randnum_test( void)
121{
122#if ENABLE_RTC_ASSEED
123 rtc_init_for_seed();
124
125 /* set uid and rtc as seed for random */
126 srand(rtc_counter_get()+get_uid_for_seed());
127#else
128 /* set only uid as seed for random */
129 srand(get_uid_for_seed());
130#endif
131
132 while(1)
133 {
134 delay_ms(500);
135 printf("%d\r\n",rand());
136 }
137}
138
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:114
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:131
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:66
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:374
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:384
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:295
CRM_RTC_CLOCK_LEXT
@ CRM_RTC_CLOCK_LEXT
Definition: at32f413_crm.h:372
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f413_crm.h:56
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
get_uid_for_seed
int get_uid_for_seed(void)
get uid value as seed
Definition: random.c:46
DEVICE_ID_ADDR1
#define DEVICE_ID_ADDR1
Definition: random.c:39
randnum_test
void randnum_test(void)
enable rtc as seed
Definition: random.c:120
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:65
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:205
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:80
random.h
at32f413 random header file


AT32F413 Firmwary Library: random.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
random.h
Go to the documentation of this file.
1
25#ifndef __RANDOM_H
26#define __RANDOM_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413.h"
33
46/* this define rtc seed for random number gen,*/
47#define ENABLE_RTC_ASSEED (1)
48
57void randnum_test( void);
58
71#ifdef __cplusplus
72}
73#endif
74
75#endif
at32f413.h
at32f413 header file
randnum_test
void randnum_test(void)
enable rtc as seed
Definition: random.c:120


AT32F413 Firmwary Library: rtc.c Source File

  • rtc
  • calendar
  • src
rtc.c
Go to the documentation of this file.
1
25#include "rtc.h"
26
35 calendar_type calendar;
36
37/* monthly correction data sheet */
38const uint8_t table_week[12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5};
39
40/* monmonth data table of common year */
41const uint8_t mon_table[12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
42
49uint8_t rtc_init(calendar_type *calendar)
50{
51 /* enable pwc and bpr clocks */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
54
55 /* enable the battery-powered domain write operations */
56 pwc_battery_powered_domain_access(TRUE);
57
58 /* check if rtc is initialized */
59 if(bpr_data_read(BPR_DATA1) != 0x1234)
60 {
61 /* reset battery-powered domain register */
62 bpr_reset();
63
64 /* enable the lext osc */
65 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
66 /* wait lext is ready */
67 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
68 /* select the rtc clock source */
69 crm_rtc_clock_select(CRM_RTC_CLOCK_LEXT);
70
71 /* enable rtc clock */
72 crm_rtc_clock_enable(TRUE);
73
74 /* wait for rtc registers update */
75 rtc_wait_update_finish();
76
77 /* wait for the register write to complete */
78 rtc_wait_config_finish();
79
80 /* set rtc divider: set rtc period to 1sec */
81 rtc_divider_set(32767);
82
83 /* wait for the register write to complete */
84 rtc_wait_config_finish();
85
86 /* set time */
87 rtc_time_set(calendar);
88
89 /* writes data to bpr register */
90 bpr_data_write(BPR_DATA1, 0x1234);
91
92 return 1;
93 }
94 else
95 {
96 /* wait for rtc registers update */
97 rtc_wait_update_finish();
98
99 /* wait for the register write to complete */
100 rtc_wait_config_finish();
101
102 return 0;
103 }
104}
105
115uint8_t is_leap_year(uint16_t year)
116{
117 if(year % 4 == 0)
118 {
119 if(year % 100 == 0)
120 {
121 if(year % 400 == 0)
122 {
123 return 1;
124 }
125 else
126 {
127 return 0;
128 }
129 }
130 else
131 {
132 return 1;
133 }
134 }
135 else
136 {
137 return 0;
138 }
139}
140
149uint8_t rtc_time_set(calendar_type *calendar)
150{
151 uint32_t t;
152 uint32_t seccount = 0;
153
154 if(calendar->year < 1970 || calendar->year > 2099)
155 {
156 return 1;
157 }
158
159 for(t = 1970; t < calendar->year; t++)
160 {
161 if(is_leap_year(t))
162 {
163 seccount += 31622400;
164 }
165 else
166 {
167 seccount += 31536000;
168 }
169 }
170
171 calendar->month -= 1;
172
173 for(t = 0; t < calendar->month; t++)
174 {
175 seccount += (uint8_t)mon_table[t] * 86400;
176
177 if(is_leap_year(calendar->year) && t == 1)
178 {
179 seccount += 86400;
180 }
181 }
182
183 seccount += (uint8_t)(calendar->date - 1) * 86400;
184
185 seccount += (uint8_t)calendar->hour * 3600;
186
187 seccount += (uint8_t)calendar->min * 60;
188
189 seccount += calendar->sec;
190
191 /* enable pwc and bpr clocks */
192 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
193 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
194
195 /* enable write access to bpr domain */
196 pwc_battery_powered_domain_access(TRUE);
197
198 /* set the rtc counter value */
199 rtc_counter_set(seccount);
200
201 /* wait for the register write to complete */
202 rtc_wait_config_finish();
203
204 return 0;
205}
206
215uint8_t rtc_alarm_clock_set(calendar_type *calendar)
216{
217 uint16_t t;
218 uint32_t seccount = 0;
219
220 if(calendar->year < 1970 || calendar->year > 2099)
221 {
222 return 1;
223 }
224
225 for(t = 1970; t < calendar->year; t++)
226 {
227 if(is_leap_year(t))
228 {
229 seccount += 31622400;
230 }
231 else
232 {
233 seccount += 31536000;
234 }
235 }
236
237 calendar->month -= 1;
238
239 for(t = 0; t < calendar->month; t++)
240 {
241 seccount += (uint8_t)mon_table[t] * 86400;
242
243 if(is_leap_year(calendar->year) && t == 1)
244 {
245 seccount += 86400;
246 }
247 }
248
249 seccount += (uint8_t)(calendar->date - 1) * 86400;
250 seccount += (uint8_t)calendar->hour * 3600;
251 seccount += (uint8_t)calendar->min * 60;
252 seccount += calendar->sec;
253
254 /* enable pwc and bpr clocks */
255 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
256 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
257
258 /* enable write access to bpr domain */
259 pwc_battery_powered_domain_access(TRUE);
260
261 /* set the rtc counter value */
262 rtc_alarm_set(seccount);
263
264 /* wait for the register write to complete */
265 rtc_wait_config_finish();
266
267 return 0;
268}
269
277uint8_t rtc_week_get(uint16_t year, uint8_t month, uint8_t day)
278{
279 uint16_t temp2;
280 uint8_t yearh, yearl;
281
282 yearh = year / 100;
283 yearl = year % 100;
284
285 if(yearh > 19)
286 {
287 yearl += 100;
288 }
289
290 temp2 = yearl + yearl / 4;
291 temp2 = temp2 % 7;
292 temp2 = temp2 + day + table_week[month - 1];
293
294 if(yearl % 4 == 0 && month < 3)
295 {
296 temp2--;
297 }
298
299 return(temp2 % 7);
300}
301
307void rtc_time_get(void)
308{
309 static uint16_t daycnt = 0;
310 uint32_t timecount = 0;
311 uint32_t temp = 0;
312 uint32_t temp1 = 0;
313
314 timecount = rtc_counter_get();
315 temp = timecount / 86400;
316
317 if(daycnt != temp)
318 {
319 daycnt = temp;
320 temp1 = 1970;
321
322 while(temp >= 365)
323 {
324 if(is_leap_year(temp1))
325 {
326 if(temp >= 366)
327 {
328 temp -= 366;
329 }
330 else
331 {
332 temp1++;
333 break;
334 }
335 }
336 else
337 {
338 temp -= 365;
339 }
340
341 temp1++;
342 }
343
344 calendar.year = temp1;
345 temp1 = 0;
346
347 while(temp >= 28)
348 {
349 if(is_leap_year(calendar.year) && temp1 == 1)
350 {
351 if(temp >= 29)
352 {
353 temp -= 29;
354 }
355 else
356 {
357 break;
358 }
359 }
360 else
361 {
362 if(temp >= mon_table[temp1])
363 {
364 temp -= mon_table[temp1];
365 }
366 else
367 {
368 break;
369 }
370 }
371
372 temp1++;
373 }
374
375 calendar.month = temp1 + 1;
376 calendar.date = temp + 1;
377 }
378
379 temp = timecount % 86400;
380 calendar.hour = temp / 3600;
381 calendar.min = (temp % 3600) / 60;
382 calendar.sec = (temp % 3600) % 60;
383 calendar.week = rtc_week_get(calendar.year, calendar.month, calendar.date);
384}
385
rtc_time_get
void rtc_time_get(void)
get current time.
Definition: rtc.c:307
rtc_init
uint8_t rtc_init(calendar_type *calendar)
rtc peripheral initialization.
Definition: rtc.c:49
calendar
calendar_type calendar
Definition: rtc.c:35
mon_table
const uint8_t mon_table[12]
Definition: rtc.c:41
rtc_week_get
uint8_t rtc_week_get(uint16_t year, uint8_t month, uint8_t day)
get current week by input leap year\mouth\day.
Definition: rtc.c:277
rtc_time_set
uint8_t rtc_time_set(calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:149
rtc_alarm_clock_set
uint8_t rtc_alarm_clock_set(calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:215
table_week
const uint8_t table_week[12]
Definition: rtc.c:38
is_leap_year
uint8_t is_leap_year(uint16_t year)
judeg the leap year or common year.
Definition: rtc.c:115
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:47
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:114
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:131
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:66
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:374
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:384
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:295
CRM_RTC_CLOCK_LEXT
@ CRM_RTC_CLOCK_LEXT
Definition: at32f413_crm.h:372
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f413_crm.h:56
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:59
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:113
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:195
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:65
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:205
rtc_counter_set
void rtc_counter_set(uint32_t counter_value)
rtc counter set
Definition: at32f413_rtc.c:47
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:80
rtc.h
this file provides template for calendar api.
calendar_type
Definition: rtc.h:47
calendar_type::hour
__IO uint8_t hour
Definition: rtc.h:51
calendar_type::month
__IO uint8_t month
Definition: rtc.h:49
calendar_type::sec
__IO uint8_t sec
Definition: rtc.h:53
calendar_type::week
__IO uint8_t week
Definition: rtc.h:54
calendar_type::year
__IO uint16_t year
Definition: rtc.h:48
calendar_type::min
__IO uint8_t min
Definition: rtc.h:52
calendar_type::date
__IO uint8_t date
Definition: rtc.h:50


AT32F413 Firmwary Library: rtc.h Source File

  • rtc
  • calendar
  • inc
rtc.h
Go to the documentation of this file.
1
25#ifndef __RTC_H
26#define __RTC_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413.h"
33
46typedef struct
47{
48 __IO uint16_t year;
49 __IO uint8_t month;
50 __IO uint8_t date;
51 __IO uint8_t hour;
52 __IO uint8_t min;
53 __IO uint8_t sec;
54 __IO uint8_t week;
55} calendar_type;
56
61extern calendar_type calendar;
62
67uint8_t rtc_init (calendar_type *calendar);
68uint8_t rtc_time_set (calendar_type *calendar);
69uint8_t rtc_alarm_clock_set (calendar_type *calendar);
70void rtc_time_get (void);
71
84#ifdef __cplusplus
85}
86#endif
87
88#endif
at32f413.h
at32f413 header file
calendar
calendar_type calendar
Definition: rtc.c:35
rtc_time_get
void rtc_time_get(void)
get current time.
Definition: rtc.c:307
rtc_init
uint8_t rtc_init(calendar_type *calendar)
rtc peripheral initialization.
Definition: rtc.c:49
rtc_time_set
uint8_t rtc_time_set(calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:149
rtc_alarm_clock_set
uint8_t rtc_alarm_clock_set(calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:215
calendar_type
Definition: rtc.h:47
calendar_type::hour
__IO uint8_t hour
Definition: rtc.h:51
calendar_type::month
__IO uint8_t month
Definition: rtc.h:49
calendar_type::sec
__IO uint8_t sec
Definition: rtc.h:53
calendar_type::week
__IO uint8_t week
Definition: rtc.h:54
calendar_type::year
__IO uint16_t year
Definition: rtc.h:48
calendar_type::min
__IO uint8_t min
Definition: rtc.h:52
calendar_type::date
__IO uint8_t date
Definition: rtc.h:50


AT32F413 Firmwary Library: run_in_spim.c Source File

  • flash
  • run_in_spim
  • src
run_in_spim.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "run_in_spim.h"
27
28
43void spim_run(void)
44{
45 while(1)
46 {
47 /* toggle led */
48 at32_led_toggle(LED2);
49 delay_ms(100);
50 at32_led_toggle(LED3);
51 delay_ms(100);
52 at32_led_toggle(LED4);
53 delay_ms(100);
54 }
55}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
spim_run
void spim_run(void)
check the led toggle in spim
Definition: run_in_spim.c:43
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
run_in_spim.h
run_in_spim header file


AT32F413 Firmwary Library: run_in_spim.h Source File

  • flash
  • run_in_spim
  • inc
run_in_spim.h
Go to the documentation of this file.
1
25/* Define to prevent recursive inclusion -------------------------------------*/
26#ifndef __RUN_IN_SPIM_H
27#define __RUN_IN_SPIM_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
42void spim_run(void);
43
56#ifdef __cplusplus
57}
58#endif
59
60#endif /* __RUN_IN_SPIM_H */
61
spim_run
void spim_run(void)
check the led toggle in spim
Definition: run_in_spim.c:43


AT32F413 Firmwary Library: at32_sdio.h Source File

  • sdio
  • sd_mmc_card
  • inc
sd_mmc_card/inc/at32_sdio.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __AT32_SDIO_H
28#define __AT32_SDIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
49#define SDIOx SDIO1
50
62typedef enum
63{
64 SD_TRANSFER_POLLING_MODE = 0,
65 SD_TRANSFER_DMA_MODE = 1
66} sd_data_transfer_mode_type;
67
71typedef enum
72{
73 /* sdio specific error defines ------------------------------------------*/
74 SD_CMD_FAIL = 1,
75 SD_DATA_FAIL = 2,
76 SD_CMD_RSP_TIMEOUT = 3,
77 SD_DATA_TIMEOUT = 4,
78 SD_TX_UNDERRUN = 5,
79 SD_RX_OVERRUN = 6,
80 SD_START_BIT_ERR = 7,
81 SD_CMD_OUT_OF_RANGE = 8,
82 SD_ADDR_MISALIGNED = 9,
83 SD_BLK_LEN_ERR = 10,
84 SD_ERASE_SEQ_ERR = 11,
85 SD_INVALID_ERASE_PARAM = 12,
86 SD_WR_PROTECT_VIOLATION = 13,
87 SD_LOCK_UNLOCK_ERROR = 14,
88 SD_CMD_CRC_ERROR = 15,
89 SD_ILLEGAL_CMD = 16,
90 SD_CARD_ECC_ERROR = 17,
91 SD_CARD_CONTROLLER_ERR = 18,
92 SD_GENERAL_UNKNOWN_ERROR = 19,
93 SD_STREAM_RD_UNDERRUN = 20,
94 SD_STREAM_WR_OVERRUN = 21,
95 SD_CID_CSD_OVERWRITE = 22,
96 SD_WP_ERASE_SKIP = 23,
97 SD_CARD_ECC_DISABLED = 24,
98 SD_ERASE_RESET = 25,
99 SD_AKE_SEQ_ERROR = 26,
100 SD_INVALID_VOLTRANGE = 27,
101 SD_ADDR_OUT_OF_RANGE = 28,
102 SD_SWITCH_ERROR = 29,
103 SD_SDIO_DISABLED = 30,
104 SD_SDIO_FUNC_BUSY = 31,
105 SD_SDIO_FUNC_ERROR = 32,
106 SD_SDIO_UNKNOWN_FUNC = 33,
108 /* standard error defines --------------------------------------------*/
109 SD_INTERNAL_ERROR,
110 SD_NOT_CONFIGURED,
111 SD_REQ_PENDING,
112 SD_REQ_NOT_APPLICABLE,
113 SD_INVALID_PARAMETER,
114 SD_UNSUPPORTED_FEATURE,
115 SD_UNSUPPORTED_HW,
116 SD_ERROR,
117 SD_OK = 0
118} sd_error_status_type;
119
123typedef struct
124{
125 uint8_t csd_struct;
126 uint8_t spec_version;
127 uint8_t reserved1;
128 uint8_t taac;
129 uint8_t nsac;
130 uint8_t max_bus_clk_freq;
131 uint16_t card_cmd_classes;
132 uint8_t max_read_blk_length;
133 uint8_t part_blk_read;
134 uint8_t write_blk_misalign;
135 uint8_t read_blk_misalign;
136 uint8_t dsr_implemented;
137 uint8_t reserved2;
138 uint32_t device_size;
139 uint8_t max_read_current_vdd_min;
140 uint8_t max_read_current_vdd_max;
141 uint8_t max_write_current_vdd_min;
142 uint8_t max_write_current_vdd_max;
143 uint8_t device_size_mult;
144 uint8_t erase_group_size;
145 uint8_t erase_group_size_mult;
146 uint8_t write_protect_group_size;
147 uint8_t write_protect_group_enable;
148 uint8_t manufacturer_default_ecc;
149 uint8_t write_speed_factor;
150 uint8_t max_write_blk_length;
151 uint8_t part_blk_write;
152 uint8_t reserved3;
153 uint8_t content_protect_app;
154 uint8_t file_format_group;
155 uint8_t copy_flag;
156 uint8_t permanent_write_protect;
157 uint8_t temp_write_protect;
158 uint8_t file_formart;
159 uint8_t ecc_code;
160 uint8_t csd_crc;
161 uint8_t reserved4;
162} sd_csd_struct_type;
163
167typedef struct
168{
169 uint8_t manufacturer_id;
170 uint16_t oem_app_id;
171 uint32_t product_name1;
172 uint8_t product_name2;
173 uint8_t product_reversion;
174 uint32_t product_sn;
175 uint8_t reserved1;
176 uint16_t manufact_date;
177 uint8_t cid_crc;
178 uint8_t reserved2;
179} sd_cid_struct_type;
180
184typedef enum
185{
186 SD_CARD_READY = ((uint32_t)0x00000001),
187 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
188 SD_CARD_STANDBY = ((uint32_t)0x00000003),
189 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
190 SD_CARD_SENDING = ((uint32_t)0x00000005),
191 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
192 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
193 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
194 SD_CARD_ERROR = ((uint32_t)0x000000FF)
195} sd_card_state_type;
196
200typedef enum
201{
202 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
203 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
204 SDIO_HIGH_CAPACITY_SD_CARD = 2,
205 SDIO_MULTIMEDIA_CARD = 3,
206 SDIO_SECURE_DIGITAL_IO_CARD = 4,
207 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
208 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
209 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
210 SDIO_SDIO_CARD = 8
211} sd_memory_card_type;
212
216typedef struct
217{
218 uint32_t sd_spec :4; /* [59:56] */
219 uint32_t scr_structure :4; /* [60:63] */
220 uint32_t sd_bus_width :4; /* [51:48] */
221 uint32_t sd_security :3; /* [52:54] */
222 uint32_t data_stat_after_erase :1; /* [55:55] */
223 uint32_t reserved1 :7; /* [46:40] */
224 uint32_t sd_spec3 :1; /* [47:47] */
225 uint32_t cmd20_support :1; /* [32:32] */
226 uint32_t cmd23_support :1; /* [33:33] */
227 uint32_t reserverd2 :6; /* [34:39] */
228 uint32_t reserverd3; /* [31:0] */
229} sd_scr_struct_type;
230
234typedef struct
235{
236 sd_csd_struct_type sd_csd_reg;
237 sd_cid_struct_type sd_cid_reg;
238 sd_scr_struct_type sd_scr_reg;
239 long long card_capacity;
240 uint32_t card_blk_size;
241 uint16_t rca;
242 uint8_t card_type;
243} sd_card_info_struct_type;
244
256#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
257#define SD_CMD_SEND_OP_COND ((uint8_t)1)
258#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
259#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
260#define SD_CMD_SET_DSR ((uint8_t)4)
261#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
262#define SD_CMD_HS_SWITCH ((uint8_t)6)
263#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
264#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
265#define SD_CMD_SEND_CSD ((uint8_t)9)
266#define SD_CMD_SEND_CID ((uint8_t)10)
267#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
268#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
269#define SD_CMD_SEND_STATUS ((uint8_t)13)
270#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
271#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
272#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
273#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
274#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
275#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
276#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
277#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
278#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
279#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
280#define SD_CMD_PROG_CID ((uint8_t)26)
281#define SD_CMD_PROG_CSD ((uint8_t)27)
282#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
283#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
284#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
285#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
286#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
287#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
288#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
289#define SD_CMD_ERASE ((uint8_t)38)
290#define SD_CMD_FAST_IO ((uint8_t)39)
291#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
292#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
293#define SD_CMD_APP_CMD ((uint8_t)55)
294#define SD_CMD_GEN_CMD ((uint8_t)56)
295#define SD_CMD_NO_CMD ((uint8_t)64)
296
301#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
302#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
303#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
304#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
305#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
306#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
307#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
308#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
309
314#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
315#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
316#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
317#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
318#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
319#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
320#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
321#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
322#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
323#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
324#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
325
337#define NULL 0
338#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
339#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
340#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
341#define SDIO_FIFO_Address ((uint32_t)0x40018080)
342
354#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
355#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
356#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
357#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
358#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
359#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
360#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
361#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
362#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
363#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
364#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
365#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
366#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
367#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
368#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
369#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
370#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
371#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
372#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
373#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
374#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
375
379#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
380#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
381#define SD_R5_ERROR ((uint32_t)0x00000800)
382
386#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
387#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
388#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
389#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
390#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
391#define SD_STD_CAPACITY ((uint32_t)0x00000000)
392#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
393#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
394#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
395#define SD_ALLZERO ((uint32_t)0x00000000)
396#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
397#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
398#define SD_CARD_LOCKED ((uint32_t)0x02000000)
399#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
400#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
401#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
402#define SD_0TO7BITS ((uint32_t)0x000000FF)
403#define SD_8TO15BITS ((uint32_t)0x0000FF00)
404#define SD_16TO23BITS ((uint32_t)0x00FF0000)
405#define SD_24TO31BITS ((uint32_t)0xFF000000)
406#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
407#define SD_HALFFIFO ((uint32_t)0x00000008)
408#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
409
421#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
422#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
423#define SD_CCCC_ERASE ((uint32_t)0x00000020)
424
436#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
437
449#define EXT_CSD_Command_set 0x0
450#define EXT_CSD_Set_bit 0x1
451#define EXT_CSD_Clear_byte 0x2
452#define EXT_CSD_Write_byte 0x3
453
454#define EXT_CSD_CMD_SET_NORMAL (1<<0)
455#define EXT_CSD_CMD_SET_SECURE (1<<1)
456#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
457
461#define EXT_CSD_BUS_WIDTH 183
462#define EXT_CSD_HS_TIMING 185
463
472#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
473 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
474#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
475 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
480extern sd_card_info_struct_type sd_card_info;
481
486/* sd exported functions ----------------------------------------*/
487 sd_error_status_type sd_init(void);
488void sdio_clock_set(uint32_t clkdiv);
489 sd_error_status_type sd_power_on(void);
490 sd_error_status_type sd_power_off(void);
491 sd_error_status_type sd_card_init(void);
492 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
493 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
494 sd_error_status_type sd_device_mode_set(uint32_t mode);
495 sd_error_status_type sd_deselect_select(uint32_t addr);
496 sd_error_status_type sd_status_send(uint32_t *p_card_status);
497 sd_card_state_type sd_state_get(void);
498 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
499 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
500 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
501 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
502 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
503 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
504 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
505 sd_error_status_type sd_irq_service(void);
506void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
507
520#ifdef __cplusplus
521}
522#endif
523
524#endif /* __AT32_SDIO_H */
at32f413.h
at32f413 header file
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:46
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:214
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:137
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sd_mmc_card/src/at32_sdio.c:394
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sd_mmc_card/src/at32_sdio.c:1780
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sd_mmc_card/src/at32_sdio.c:777
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sd_mmc_card/src/at32_sdio.c:523
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1691
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sd_mmc_card/src/at32_sdio.c:408
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1179
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sd_mmc_card/src/at32_sdio.c:798
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: sd_mmc_card/src/at32_sdio.c:179
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sd_mmc_card/src/at32_sdio.c:1021
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1480
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sd_mmc_card/src/at32_sdio.c:2480
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sd_mmc_card/src/at32_sdio.c:2697
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1358
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sd_mmc_card/src/at32_sdio.c:2443
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:70
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1644
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sd_mmc_card/src/at32_sdio.c:194
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1268
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:734
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sd_mmc_card/inc/at32_sdio.h:63
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:72
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:185
sd_memory_card_type
sd_memory_card_type
Definition: sd_mmc_card/inc/at32_sdio.h:201
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sd_mmc_card/inc/at32_sdio.h:400
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sd_mmc_card/inc/at32_sdio.h:399
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:65
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:64
SD_ERROR
@ SD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:116
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: sd_mmc_card/inc/at32_sdio.h:96
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sd_mmc_card/inc/at32_sdio.h:106
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:75
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:94
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sd_mmc_card/inc/at32_sdio.h:113
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:74
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:81
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: sd_mmc_card/inc/at32_sdio.h:115
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:105
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:109
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: sd_mmc_card/inc/at32_sdio.h:85
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:92
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: sd_mmc_card/inc/at32_sdio.h:97
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:91
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: sd_mmc_card/inc/at32_sdio.h:98
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:90
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:93
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sd_mmc_card/inc/at32_sdio.h:114
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:78
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:89
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: sd_mmc_card/inc/at32_sdio.h:104
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:88
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:101
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:79
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: sd_mmc_card/inc/at32_sdio.h:111
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sd_mmc_card/inc/at32_sdio.h:112
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:102
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sd_mmc_card/inc/at32_sdio.h:100
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: sd_mmc_card/inc/at32_sdio.h:103
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:77
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: sd_mmc_card/inc/at32_sdio.h:82
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:80
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:87
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: sd_mmc_card/inc/at32_sdio.h:110
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: sd_mmc_card/inc/at32_sdio.h:95
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: sd_mmc_card/inc/at32_sdio.h:86
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:76
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:83
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:117
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:84
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:99
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: sd_mmc_card/inc/at32_sdio.h:189
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: sd_mmc_card/inc/at32_sdio.h:187
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: sd_mmc_card/inc/at32_sdio.h:190
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: sd_mmc_card/inc/at32_sdio.h:188
SD_CARD_READY
@ SD_CARD_READY
Definition: sd_mmc_card/inc/at32_sdio.h:186
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: sd_mmc_card/inc/at32_sdio.h:193
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:194
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:210
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:208
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:207
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:202
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:206
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:203
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:205
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:209
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:235
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:236
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_cid_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:168
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: sd_mmc_card/inc/at32_sdio.h:173
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:169
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: sd_mmc_card/inc/at32_sdio.h:171
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: sd_mmc_card/inc/at32_sdio.h:170
sd_csd_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:124
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: sd_mmc_card/inc/at32_sdio.h:126
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::nsac
uint8_t nsac
Definition: sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: sd_mmc_card/inc/at32_sdio.h:125
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:127
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:146
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::taac
uint8_t taac
Definition: sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:143
sd_scr_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:217
sd_scr_struct_type::cmd20_support
uint32_t cmd20_support
Definition: sd_mmc_card/inc/at32_sdio.h:225
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: sd_mmc_card/inc/at32_sdio.h:220
sd_scr_struct_type::reserverd3
uint32_t reserverd3
Definition: sd_mmc_card/inc/at32_sdio.h:228
sd_scr_struct_type::cmd23_support
uint32_t cmd23_support
Definition: sd_mmc_card/inc/at32_sdio.h:226
sd_scr_struct_type::sd_spec3
uint32_t sd_spec3
Definition: sd_mmc_card/inc/at32_sdio.h:224
sd_scr_struct_type::data_stat_after_erase
uint32_t data_stat_after_erase
Definition: sd_mmc_card/inc/at32_sdio.h:222
sd_scr_struct_type::reserved1
uint32_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:223
sd_scr_struct_type::scr_structure
uint32_t scr_structure
Definition: sd_mmc_card/inc/at32_sdio.h:219
sd_scr_struct_type::sd_security
uint32_t sd_security
Definition: sd_mmc_card/inc/at32_sdio.h:221
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: sd_mmc_card/inc/at32_sdio.h:218
sd_scr_struct_type::reserverd2
uint32_t reserverd2
Definition: sd_mmc_card/inc/at32_sdio.h:227


AT32F413 Firmwary Library: at32_sdio.c Source File

  • sdio
  • sd_mmc_card
  • src
sd_mmc_card/src/at32_sdio.c
Go to the documentation of this file.
1
26#include "at32_sdio.h"
27#include "at32f413_board.h"
28
37 sdio_command_struct_type sdio_command_init_struct;
38 sdio_data_struct_type sdio_data_init_struct;
39
40static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
41static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
42static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
43static uint8_t stop_flag = 0; /* transmit stop flag */
44volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
45volatile uint8_t transfer_end = 0; /* transmit end flag */
46 sd_card_info_struct_type sd_card_info; /* sd card information */
47
48 sd_error_status_type command_error(void);
49 sd_error_status_type command_rsp1_error(uint8_t cmd);
50 sd_error_status_type command_rsp2_error(void);
51 sd_error_status_type command_rsp3_error(void);
52 sd_error_status_type command_rsp4_error(uint8_t cmd);
53 sd_error_status_type command_rsp5_error(uint8_t cmd);
54 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
55 sd_error_status_type command_rsp7_error(void);
56 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
57 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
58 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
59 sd_error_status_type check_card_programming(uint8_t *p_status);
60 sd_error_status_type speed_change(uint8_t speed);
61 sd_error_status_type scr_find(void);
62uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
63
70 sd_error_status_type sd_init(void)
71{
72 uint16_t clkdiv = 0;
73 sd_error_status_type status = SD_OK;
74 gpio_init_type gpio_init_struct = {0};
75 uint8_t retry = 0;
76
77 /* gpioc and gpiod periph clock enable */
78 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
79 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
80
81 /* sdio periph clock enable */
82 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
83
84 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
85 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
86 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
87 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
88 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
89 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
90 gpio_init(GPIOC, &gpio_init_struct);
91
92 /* configure pd.02 cmd line */
93 gpio_init_struct.gpio_pins = GPIO_PINS_2;
94 gpio_init(GPIOD, &gpio_init_struct);
95
96 retry = 3;
97 while(retry--){
98 /* reset sdio */
99 sdio_reset(SDIOx);
100 /* power on */
101 status = sd_power_on();
102
103 if(status == SD_OK)
104 break;
105 }
106
107 if(status == SD_OK)
108 {
109 /* sdio card initialize */
110 status = sd_card_init();
111 }
112
113 if(status == SD_OK)
114 {
115 /* get card information*/
116 status = sd_card_info_get(&sd_card_info);
117 }
118
119 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
120 {
121 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
122 }
123
124 if(status == SD_OK)
125 {
126 /* select card */
127 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
128 }
129
130 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
131 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
132 {
133 status = scr_find();
134 }
135
136 if(status == SD_OK)
137 {
138 /* set normal speed */
139 status = speed_change(0);
140 }
141
142 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
143 {
144 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
145 {
146 /* set sdio_ck to 4mhz */
147 clkdiv = system_core_clock / 4000000;
148
149 if(clkdiv >= 2)
150 {
151 clkdiv -= 2;
152 }
153 }
154 else
155 {
156 /* set sdio_ck to 4mhz */
157 clkdiv = system_core_clock / 4000000;
158
159 if(clkdiv >= 2)
160 {
161 clkdiv -= 2;
162 }
163 }
164 /* set sdio clock divider */
165 sdio_clock_set(clkdiv);
166
167 /* set transfer mode */
168 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
169 }
170
171 return status;
172}
173
179void sdio_clock_set(uint32_t clk_div)
180{
181 /* config clock divide [7:0] */
182 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
183
184 /* config clock divide [9:8] */
185 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
186}
187
194 sd_error_status_type sd_power_on(void)
195{
196 uint8_t retry = 0;
197 sd_error_status_type status = SD_OK;
198 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
199 uint32_t sd_type = SD_STD_CAPACITY;
200
201 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
202 clk_psc = (system_core_clock / 200000) - 2;
203
204 if(clk_psc > 0x3FF)
205 {
206 clk_psc = 0x3FF;
207 }
208
209 /* config sdio clock divide and edge phase */
210 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
211 /* config sdio bus width */
212 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
213 /* disable flow control */
214 sdio_flow_control_enable(SDIOx, FALSE);
215 /* disable clock bypass */
216 sdio_clock_bypass(SDIOx, FALSE);
217 /* disable power saving mode */
218 sdio_power_saving_mode_enable(SDIOx, FALSE);
219
220 /* sdio power on */
221 sdio_power_set(SDIOx, SDIO_POWER_ON);
222 /* enable to output sdio_ck */
223 sdio_clock_enable(SDIOx, TRUE);
224
225 for(retry = 0; retry < 5; retry++)
226 {
227 /* send cmd0, get in idle stage */
228 sdio_command_init_struct.argument = 0x0;
229 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
230 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
231 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
232
233 /* sdio command config */
234 sdio_command_config(SDIOx, &sdio_command_init_struct);
235 /* enable ccsm */
236 sdio_command_state_machine_enable(SDIOx, TRUE);
237
238 /* get command status */
239 status = command_error();
240 }
241
242 /* send cmd8, check card interface feature */
243 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
244 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
245 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
246 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
247
248 /* sdio command config */
249 sdio_command_config(SDIOx, &sdio_command_init_struct);
250 /* enable ccsm */
251 sdio_command_state_machine_enable(SDIOx, TRUE);
252
253 /* waiting R7 */
254 status = command_rsp7_error();
255
256 if(status == SD_OK)
257 {
258 /* set card type and sd type */
259 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
260 sd_type = SD_HIGH_CAPACITY;
261 }
262
263 /* send cmd55, check sd version */
264 sdio_command_init_struct.argument = 0x00;
265 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
266 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
267 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
268
269 /* sdio command config */
270 sdio_command_config(SDIOx, &sdio_command_init_struct);
271 /* enable ccsm */
272 sdio_command_state_machine_enable(SDIOx, TRUE);
273
274 /* waiting R1 */
275 status = command_rsp1_error(SD_CMD_APP_CMD);
276
277 /* check sd card or mmc card */
278 if(SD_OK == status)
279 {
280 /* send acmd41, check voltage operation range */
281 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
282 {
283 delay_ms(10);
284
285 /* send cmd55 before acmd41 */
286 sdio_command_init_struct.argument = 0x00;
287 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
288 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
289 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
290
291 /* sdio command config */
292 sdio_command_config(SDIOx, &sdio_command_init_struct);
293 /* enable ccsm */
294 sdio_command_state_machine_enable(SDIOx, TRUE);
295
296 /* waiting R1 */
297 status = command_rsp1_error(SD_CMD_APP_CMD);
298
299 /* if any errors occured, return status */
300 if(status != SD_OK)
301 {
302 return status;
303 }
304
305 /* send acmd41 */
306 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
307 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
308 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
309 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
310
311 /* sdio command config */
312 sdio_command_config(SDIOx, &sdio_command_init_struct);
313 /* enable ccsm */
314 sdio_command_state_machine_enable(SDIOx, TRUE);
315
316 /* waiting R3 */
317 status = command_rsp3_error();
318
319 /* if any errors occured, return status */
320 if(status != SD_OK)
321 {
322 return status;
323 }
324
325 /* get response1 */
326 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
327
328 /* check sd card power on stage is success or not */
329 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
330 count++;
331 }
332
333 if(count >= SD_MAX_VOLT_TRIAL)
334 {
335 status = SD_INVALID_VOLTRANGE;
336 return status;
337 }
338
339 if(response &= SD_HIGH_CAPACITY)
340 {
341 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
342 }
343 }
344 /* mmc card */
345 else
346 {
347 /* send cmd1 */
348 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
349 {
350 delay_ms(10);
351
352 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
353 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
354 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
355 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
356
357 /* sdio command config */
358 sdio_command_config(SDIOx, &sdio_command_init_struct);
359 /* enable ccsm */
360 sdio_command_state_machine_enable(SDIOx, TRUE);
361
362 /* waiting R3 */
363 status = command_rsp3_error();
364
365 if(status != SD_OK)
366 {
367 return status;
368 }
369
370 /* get response1 */
371 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
372
373 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
374 count++;
375 }
376
377 if(count >= SD_MAX_VOLT_TRIAL)
378 {
379 status = SD_INVALID_VOLTRANGE;
380 return status;
381 }
382
383 card_type = SDIO_MULTIMEDIA_CARD;
384 }
385
386 return(status);
387}
388
394 sd_error_status_type sd_power_off(void)
395{
396 /* sdio power off */
397 sdio_power_set(SDIOx, SDIO_POWER_OFF);
398
399 return SD_OK;
400}
401
408 sd_error_status_type sd_card_init(void)
409{
410 sd_error_status_type status = SD_OK;
411 uint16_t rca_temp = 0x01;
412
413 /* check power status */
414 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
415 {
416 return SD_REQ_NOT_APPLICABLE;
417 }
418
419 /* check is secure_digital_io_card or not */
420 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
421 {
422 /* send cmd2, get cid register */
423 sdio_command_init_struct.argument = 0x0;
424 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
425 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
426 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
427
428 /* sdio command config */
429 sdio_command_config(SDIOx, &sdio_command_init_struct);
430 /* enable ccsm */
431 sdio_command_state_machine_enable(SDIOx, TRUE);
432
433 status = command_rsp2_error();
434 if(status != SD_OK)
435 {
436 return status;
437 }
438
439 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
440 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
441 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
442 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
443 }
444
445 /* check card type */
446 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
447 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
448 {
449 /* send cmd3, get rca */
450 sdio_command_init_struct.argument = 0x00;
451 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
452 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
453 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
454
455 /* sdio command config */
456 sdio_command_config(SDIOx, &sdio_command_init_struct);
457 /* enable ccsm */
458 sdio_command_state_machine_enable(SDIOx, TRUE);
459
460 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
461 if(status != SD_OK)
462 {
463 return status;
464 }
465 }
466
467 /* mmc card */
468 if(card_type == SDIO_MULTIMEDIA_CARD)
469 {
470 /* send cmd3 */
471 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
472 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
473 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
474 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
475
476 /* sdio command config */
477 sdio_command_config(SDIOx, &sdio_command_init_struct);
478 /* enable ccsm */
479 sdio_command_state_machine_enable(SDIOx, TRUE);
480
481 status = command_rsp2_error();
482 if(status != SD_OK)
483 {
484 return status;
485 }
486 }
487
488 /* check is secure_digital_io_card or not */
489 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
490 {
491 rca = rca_temp;
492 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
493 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
494 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
495 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
496
497 /* sdio command config */
498 sdio_command_config(SDIOx, &sdio_command_init_struct);
499 /* enable ccsm */
500 sdio_command_state_machine_enable(SDIOx, TRUE);
501
502 status = command_rsp2_error();
503 if(status != SD_OK)
504 {
505 return status;
506 }
507
508 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
509 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
510 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
511 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
512 }
513
514 return SD_OK;
515}
516
523 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
524{
525 sd_error_status_type status = SD_OK;
526 uint8_t tmp = 0;
527
528 card_info->card_type = (uint8_t)card_type;
529 card_info->rca = (uint16_t)rca;
530
531 /* byte 0 */
532 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
533 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
534 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
535 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
536
537 /* byte 1 */
538 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
539 card_info->sd_csd_reg.taac = tmp;
540
541 /* byte 2 */
542 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
543 card_info->sd_csd_reg.nsac = tmp;
544
545 /* byte 3 */
546 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
547 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
548
549 /* byte 4 */
550 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
551 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
552
553 /* byte 5 */
554 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
555 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
556 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
557
558 /* byte 6 */
559 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
560 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
561 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
562 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
563 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
564 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
565
566 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
567 {
568 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
569
570 /* byte 7 */
571 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
572 card_info->sd_csd_reg.device_size |= (tmp) << 2;
573
574 /* byte 8 */
575 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
576 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
577
578 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
579 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
580
581 /* byte 9 */
582 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
583 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
584 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
585 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
586 /* byte 10 */
587 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
588 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
589
590 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
591 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
592 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
593 card_info->card_capacity *= card_info->card_blk_size;
594 }
595 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
596 {
597 /* byte 7 */
598 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
599 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
600
601 /* byte 8 */
602 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
603
604 card_info->sd_csd_reg.device_size |= (tmp << 8);
605
606 /* byte 9 */
607 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
608
609 card_info->sd_csd_reg.device_size |= (tmp);
610
611 /* byte 10 */
612 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
613
614 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
615 card_info->card_blk_size = 512;
616 }
617
618
619 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
620 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
621
622 /* byte 11 */
623 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
624 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
625 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
626
627 /* byte 12 */
628 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
629 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
630 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
631 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
632 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
633
634 /* byte 13 */
635 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
636 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
637 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
638 card_info->sd_csd_reg.reserved3 = 0;
639 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
640
641 /* byte 14 */
642 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
643 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
644 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
645 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
646 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
647 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
648 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
649
650 /* byte 15 */
651 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
652 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
653 card_info->sd_csd_reg.reserved4 = 1;
654
655 /* byte 0 */
656 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
657 card_info->sd_cid_reg.manufacturer_id = tmp;
658
659 /* byte 1 */
660 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
661 card_info->sd_cid_reg.oem_app_id = tmp << 8;
662
663 /* byte 2 */
664 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
665 card_info->sd_cid_reg.oem_app_id |= tmp;
666
667 /* byte 3 */
668 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
669 card_info->sd_cid_reg.product_name1 = tmp << 24;
670
671 /* byte 4 */
672 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
673 card_info->sd_cid_reg.product_name1 |= tmp << 16;
674
675 /* byte 5 */
676 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
677 card_info->sd_cid_reg.product_name1 |= tmp << 8;
678
679 /* byte 6 */
680 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
681 card_info->sd_cid_reg.product_name1 |= tmp;
682
683 /* byte 7 */
684 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
685 card_info->sd_cid_reg.product_name2 = tmp;
686
687 /* byte 8 */
688 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
689 card_info->sd_cid_reg.product_reversion = tmp;
690
691 /* byte 9 */
692 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
693 card_info->sd_cid_reg.product_sn = tmp << 24;
694
695 /* byte 10 */
696 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
697 card_info->sd_cid_reg.product_sn |= tmp << 16;
698
699 /* byte 11 */
700 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
701 card_info->sd_cid_reg.product_sn |= tmp << 8;
702
703 /* byte 12 */
704 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
705 card_info->sd_cid_reg.product_sn |= tmp;
706
707 /* byte 13 */
708 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
709 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
710 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
711
712 /* byte 14 */
713 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
714 card_info->sd_cid_reg.manufact_date |= tmp;
715
716 /* byte 15 */
717 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
718 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
719 card_info->sd_cid_reg.reserved2 = 1;
720
721 return(status);
722}
723
734 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
735{
736 sd_error_status_type status = SD_OK;
737
738 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
739 {
740 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
741 }
742 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
743 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
744 {
745 if(mode >= 2)
746 {
747 /* not support D8 mode */
748 return SD_UNSUPPORTED_FEATURE;
749 }
750
751 if(SDIO_BUS_WIDTH_D4 == mode)
752 {
753 status = sd_bus_wide_enable(TRUE);
754 }
755 else
756 {
757 status = sd_bus_wide_enable(FALSE);
758 }
759 }
760
761 if(status == SD_OK)
762 {
763 sdio_bus_width_config(SDIOx, mode);
764 }
765
766 return status;
767}
768
777 sd_error_status_type sd_device_mode_set(uint32_t mode)
778{
779 sd_error_status_type status = SD_OK;
780
781 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
782 {
783 device_mode = (sd_data_transfer_mode_type)mode;
784 }
785 else
786 {
787 status = SD_INVALID_PARAMETER;
788 }
789
790 return status;
791}
792
798 sd_error_status_type sd_deselect_select(uint32_t addr)
799{
800 /* send cmd7, select card */
801 sdio_command_init_struct.argument = addr;
802 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
803 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
804 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
805
806 /* sdio command config */
807 sdio_command_config(SDIOx, &sdio_command_init_struct);
808 /* enable ccsm */
809 sdio_command_state_machine_enable(SDIOx, TRUE);
810
811 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
812}
813
821 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
822 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
823{
824 sd_error_status_type status = SD_OK;
825 uint32_t count = 0;
826 uint32_t timeout = SDIO_DATATIMEOUT;
827 uint32_t length = 0;
828
829 if(buf == NULL)
830 {
831 return SD_INVALID_PARAMETER;
832 }
833 /* clear dtctrl register */
834 SDIOx->dtcnt = 0x0;
835
836 /* sdio command config */
837 sdio_data_config(SDIOx, sdio_data_init_t);
838 /* enable dcsm */
839 sdio_data_state_machine_enable(SDIOx, TRUE);
840
841 length = sdio_data_init_t->data_length;
842
843 if(device_mode == SD_TRANSFER_DMA_MODE)
844 {
845 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
846 {
847 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
848 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
849 transfer_error = SD_OK;
850 transfer_end = 0;
851 sdio_dma_enable(SDIOx, TRUE);
852 }
853 }
854
855 /* sdio command config */
856 sdio_command_config(SDIOx, sdio_cmd_init_t);
857 /* enable ccsm */
858 sdio_command_state_machine_enable(SDIOx, TRUE);
859
860 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
861 if(status != SD_OK)
862 {
863 return status;
864 }
865
866 /* polling mode */
867 if(device_mode == SD_TRANSFER_POLLING_MODE)
868 {
869 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
870 {
871 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
872 {
873 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
874 {
875 for(count = 0; count < 8; count++, buf++)
876 {
877 *buf = sdio_data_read(SDIOx);
878 }
879
880 timeout = 0x7FFFFF;
881 }
882 else
883 {
884 if(0 == timeout)
885 {
886 sd_init();
887 return SD_DATA_TIMEOUT;
888 }
889
890 timeout--;
891 }
892 }
893
894 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
895 {
896 *buf = sdio_data_read(SDIOx);
897 buf++;
898 }
899 }
900 else
901 {
902 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
903 {
904 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
905 {
906 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
907 {
908 sdio_data_write(SDIOx, *buf);
909 }
910
911 timeout = 0x3FFFFFFF;
912 }
913 else
914 {
915 if(timeout == 0)
916 {
917 sd_init();
918 return SD_DATA_TIMEOUT;
919 }
920
921 timeout--;
922 }
923 }
924 }
925 /* data timeout */
926 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
927 {
928 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
929 return SD_DATA_TIMEOUT;
930 }
931 /* crc error */
932 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
933 {
934 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
935 return SD_DATA_FAIL;
936 }
937 /* over run error */
938 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
939 {
940 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
941 return SD_RX_OVERRUN;
942 }
943 /* under run error */
944 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
945 {
946 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
947 return SD_TX_UNDERRUN;
948 }
949 /* start bit error */
950 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
951 {
952 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
953 return SD_START_BIT_ERR;
954 }
955 /* data transfer complete */
956 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
957 {
958 /* send cmd12, stop transmission */
959 sdio_cmd_init_t->argument = 0;
960 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
961 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
962 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
963
964 /* sdio command config */
965 sdio_command_config(SDIOx, sdio_cmd_init_t);
966 /* enable ccsm */
967 sdio_command_state_machine_enable(SDIOx, TRUE);
968
969 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
970
971 if(status != SD_OK)
972 {
973 return status;
974 }
975 }
976
977 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
978 }
979 else if(device_mode == SD_TRANSFER_DMA_MODE)
980 {
981 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
982 {
983 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
984 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
985 transfer_error = SD_OK;
986 transfer_end = 0;
987 sdio_dma_enable(SDIOx, TRUE);
988 }
989
990 while(!(SDIOx->sts & SDIOx->inten) && timeout)
991 {
992 timeout--;
993
994 if(transfer_end)
995 {
996 break;
997 }
998 }
999
1000 if(timeout == 0)
1001 {
1002 sd_init();
1003 return SD_DATA_TIMEOUT;
1004 }
1005
1006 if(transfer_error != SD_OK)
1007 {
1008 status = transfer_error;
1009 }
1010 }
1011
1012 return status;
1013}
1014
1021 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1022{
1023 sd_error_status_type status = SD_OK;
1024 uint32_t start_addr = 0, end_addr = 0, response = 0;
1025 uint8_t card_state;
1026
1027 /* high capacity sd card */
1028 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1029 {
1030 start_addr = addr >> 9;
1031 end_addr = start_addr + nblks - 1;
1032 }
1033 else
1034 {
1035 start_addr = addr;
1036 end_addr = start_addr + (nblks - 1) * 512;
1037 }
1038
1039 /* clear dcsm configuration */
1040 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1041 sdio_data_init_struct.data_length = 0 ;
1042 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1043 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1044 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1045
1046 sdio_data_config(SDIOx, &sdio_data_init_struct);
1047 sdio_data_state_machine_enable(SDIOx, FALSE);
1048
1049 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1050
1051 /* check card locked */
1052 if(response & SD_CARD_LOCKED)
1053 {
1054 return SD_LOCK_UNLOCK_ERROR;
1055 }
1056
1057 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1058 {
1059 /* send cmd35, set erase group start */
1060 sdio_command_init_struct.argument = start_addr;
1061 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1062 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1063 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1064
1065 /* sdio command config */
1066 sdio_command_config(SDIOx, &sdio_command_init_struct);
1067 /* enable ccsm */
1068 sdio_command_state_machine_enable(SDIOx, TRUE);
1069
1070 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1071
1072 if(status != SD_OK)
1073 {
1074 return status;
1075 }
1076
1077 /* send cmd36, set erase group end */
1078 sdio_command_init_struct.argument = end_addr;
1079 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1080
1081 /* sdio command config */
1082 sdio_command_config(SDIOx, &sdio_command_init_struct);
1083 /* enable ccsm */
1084 sdio_command_state_machine_enable(SDIOx, TRUE);
1085
1086 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1087
1088 if(status != SD_OK)
1089 {
1090 return status;
1091 }
1092
1093 /* send cmd38, start erase gourp */
1094 sdio_command_init_struct.argument = 0;
1095 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1096
1097 /* sdio command config */
1098 sdio_command_config(SDIOx, &sdio_command_init_struct);
1099 /* enable ccsm */
1100 sdio_command_state_machine_enable(SDIOx, TRUE);
1101
1102 status = command_rsp1_error(SD_CMD_ERASE);
1103
1104 if(status != SD_OK)
1105 {
1106 return status;
1107 }
1108 }
1109 else
1110 {
1111 /* send cmd32, set erase block start */
1112 sdio_command_init_struct.argument = start_addr;
1113 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1114 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1115 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1116
1117 /* sdio command config */
1118 sdio_command_config(SDIOx, &sdio_command_init_struct);
1119 /* enable ccsm */
1120 sdio_command_state_machine_enable(SDIOx, TRUE);
1121
1122 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1123
1124 if(status != SD_OK)
1125 {
1126 return status;
1127 }
1128
1129 /* send cmd33, set erase block end */
1130 sdio_command_init_struct.argument = end_addr;
1131 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1132
1133 /* sdio command config */
1134 sdio_command_config(SDIOx, &sdio_command_init_struct);
1135 /* enable ccsm */
1136 sdio_command_state_machine_enable(SDIOx, TRUE);
1137
1138 if(status != SD_OK)
1139 {
1140 return status;
1141 }
1142
1143 /* send cmd38, start erase block */
1144 sdio_command_init_struct.argument = 0;
1145 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1146
1147 /* sdio command config */
1148 sdio_command_config(SDIOx, &sdio_command_init_struct);
1149 /* enable ccsm */
1150 sdio_command_state_machine_enable(SDIOx, TRUE);
1151
1152 status = command_rsp1_error(SD_CMD_ERASE);
1153
1154 if(status != SD_OK)
1155 {
1156 return status;
1157 }
1158 }
1159
1160 status = check_card_programming(&card_state);
1161
1162 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1163 (card_state == SD_CARD_RECEIVING)))
1164 {
1165 status = check_card_programming(&card_state);
1166 }
1167
1168 return status;
1169}
1170
1179 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1180{
1181 sd_error_status_type status = SD_OK;
1182 uint32_t response = 0;
1183 uint8_t power;
1184
1185 if(NULL == buf)
1186 {
1187 return SD_INVALID_PARAMETER;
1188 }
1189
1190 SDIOx->dtctrl = 0x0;
1191
1192 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1193 {
1194 blk_size = 512;
1195 addr >>= 9;
1196 }
1197
1198 /* clear dcsm configuration */
1199 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1200 sdio_data_init_struct.data_length = 0;
1201 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1202 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1203 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1204
1205 sdio_data_config(SDIOx, &sdio_data_init_struct);
1206 sdio_data_state_machine_enable(SDIOx, FALSE);
1207
1208 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1209
1210 /* check card locked */
1211 if(response & SD_CARD_LOCKED)
1212 {
1213 return SD_LOCK_UNLOCK_ERROR;
1214 }
1215
1216 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1217 {
1218 power = convert_from_bytes_to_power_of_two(blk_size);
1219
1220 /* send cmd16, set block size */
1221 sdio_command_init_struct.argument = blk_size;
1222 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1223 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1224 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1225
1226 /* sdio command config */
1227 sdio_command_config(SDIOx, &sdio_command_init_struct);
1228 /* enable ccsm */
1229 sdio_command_state_machine_enable(SDIOx, TRUE);
1230
1231 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1232
1233 if(status != SD_OK)
1234 {
1235 return status;
1236 }
1237 }
1238 else
1239 {
1240 return SD_INVALID_PARAMETER;
1241 }
1242
1243 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1244 sdio_data_init_struct.data_length = blk_size ;
1245 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1246 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1247 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1248
1249 sdio_command_init_struct.argument = addr;
1250 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1251 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1252 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1253
1254 stop_flag = 0;
1255
1256 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1257}
1258
1268 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1269{
1270 sd_error_status_type status = SD_OK;
1271 uint32_t response = 0;
1272 uint8_t power;
1273
1274 SDIOx->dtctrl = 0x0;
1275
1276 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1277 {
1278 blk_size = 512;
1279 addr >>= 9;
1280 }
1281
1282 /* clear dcsm configuration */
1283 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1284 sdio_data_init_struct.data_length = 0;
1285 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1286 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1287 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1288
1289 sdio_data_config(SDIOx, &sdio_data_init_struct);
1290 sdio_data_state_machine_enable(SDIOx, FALSE);
1291
1292 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1293
1294 /* check card locked */
1295 if(response & SD_CARD_LOCKED)
1296 {
1297 return SD_LOCK_UNLOCK_ERROR;
1298 }
1299
1300 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1301 {
1302 power = convert_from_bytes_to_power_of_two(blk_size);
1303
1304 /* send cmd16, set block size */
1305 sdio_command_init_struct.argument = blk_size;
1306 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1307 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1308 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1309
1310 /* sdio command config */
1311 sdio_command_config(SDIOx, &sdio_command_init_struct);
1312 /* enable ccsm */
1313 sdio_command_state_machine_enable(SDIOx, TRUE);
1314
1315 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1316
1317 if(status != SD_OK)
1318 {
1319 return status;
1320 }
1321 }
1322 else
1323 {
1324 return SD_INVALID_PARAMETER;
1325 }
1326
1327 /* check max receive length */
1328 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1329 {
1330 return SD_INVALID_PARAMETER;
1331 }
1332
1333 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1334 sdio_data_init_struct.data_length = nblks * blk_size ;
1335 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1336 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1337 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1338
1339 /* send cmd18, read block data */
1340 sdio_command_init_struct.argument = addr;
1341 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1342 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1343 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1344
1345 stop_flag = 1;
1346
1347 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1348}
1349
1358 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1359{
1360 sd_error_status_type status = SD_OK;
1361 uint8_t power = 0, card_state = 0;
1362 uint32_t timeout = 0, card_status = 0, response = 0;
1363
1364 if(buf == NULL)
1365 {
1366 return SD_INVALID_PARAMETER;
1367 }
1368
1369 SDIOx->dtctrl = 0x0;
1370
1371 /* clear dcsm configuration */
1372 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1373 sdio_data_init_struct.data_length = 0;
1374 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1375 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1376 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1377
1378 sdio_data_config(SDIOx, &sdio_data_init_struct);
1379 sdio_data_state_machine_enable(SDIOx, FALSE);
1380
1381 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1382
1383 /* check card locked */
1384 if(response & SD_CARD_LOCKED)
1385 {
1386 return SD_LOCK_UNLOCK_ERROR;
1387 }
1388
1389 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1390 {
1391 blk_size = 512;
1392 addr >>= 9;
1393 }
1394
1395 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1396 {
1397 power = convert_from_bytes_to_power_of_two(blk_size);
1398
1399 /* send cmd16, set block size */
1400 sdio_command_init_struct.argument = blk_size;
1401 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1402 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1403 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1404
1405 /* sdio command config */
1406 sdio_command_config(SDIOx, &sdio_command_init_struct);
1407 /* enable ccsm */
1408 sdio_command_state_machine_enable(SDIOx, TRUE);
1409
1410 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1411
1412 if(status != SD_OK)
1413 {
1414 return status;
1415 }
1416 }
1417 else
1418 {
1419 return SD_INVALID_PARAMETER;
1420 }
1421
1422 timeout = SD_DATATIMEOUT;
1423
1424 do
1425 {
1426 timeout--;
1427 status = sd_status_send(&card_status);
1428 }
1429 /* check ready_for_data flag */
1430 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1431
1432 if(timeout == 0)
1433 {
1434 return SD_ERROR;
1435 }
1436
1437 /* send cmd24, write single block */
1438 sdio_command_init_struct.argument = addr;
1439 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1440 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1441 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1442
1443 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1444 sdio_data_init_struct.data_length = blk_size;
1445 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1446 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1447 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1448
1449 stop_flag = 0;
1450
1451 /* single block, stop command is unnecessary */
1452 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1453
1454 if(status != SD_OK)
1455 {
1456 return status;
1457 }
1458
1459 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1460
1461 status = check_card_programming(&card_state);
1462
1463 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1464 {
1465 status = check_card_programming(&card_state);
1466 }
1467
1468 return status;
1469}
1470
1480 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1481{
1482 sd_error_status_type status = SD_OK;
1483 uint8_t power = 0, card_state = 0;
1484 uint32_t timeout = 0, card_status = 0, response = 0;;
1485
1486 if(buf == NULL)
1487 {
1488 return SD_INVALID_PARAMETER;
1489 }
1490
1491 SDIOx->dtctrl = 0x0;
1492
1493 /* clear dcsm configuration */
1494 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1495 sdio_data_init_struct.data_length = 0;
1496 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1497 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1498 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1499
1500 sdio_data_config(SDIOx, &sdio_data_init_struct);
1501 sdio_data_state_machine_enable(SDIOx, FALSE);
1502
1503 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1504
1505 /* check card locked */
1506 if(response & SD_CARD_LOCKED)
1507 {
1508 return SD_LOCK_UNLOCK_ERROR;
1509 }
1510
1511 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1512 {
1513 blk_size = 512;
1514 addr >>= 9;
1515 }
1516
1517 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1518 {
1519 power = convert_from_bytes_to_power_of_two(blk_size);
1520
1521 /* send cmd16, set block size */
1522 sdio_command_init_struct.argument = blk_size;
1523 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1524 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1525 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1526
1527 /* sdio command config */
1528 sdio_command_config(SDIOx, &sdio_command_init_struct);
1529 /* enable ccsm */
1530 sdio_command_state_machine_enable(SDIOx, TRUE);
1531
1532 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1533
1534 if(status != SD_OK)
1535 {
1536 return status;
1537 }
1538 }
1539 else
1540 {
1541 return SD_INVALID_PARAMETER;
1542 }
1543
1544 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1545 {
1546 return SD_INVALID_PARAMETER;
1547 }
1548
1549 timeout = SD_DATATIMEOUT;
1550
1551 do
1552 {
1553 timeout--;
1554 status = sd_status_send(&card_status);
1555 }
1556 /* check ready_for_data flag */
1557 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1558
1559 if(timeout == 0)
1560 {
1561 return SD_ERROR;
1562 }
1563
1564 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1565 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1566 {
1567 /* send cmd55 */
1568 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1569 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1570 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1571 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1572
1573 /* sdio command config */
1574 sdio_command_config(SDIOx, &sdio_command_init_struct);
1575 /* enable ccsm */
1576 sdio_command_state_machine_enable(SDIOx, TRUE);
1577
1578 status = command_rsp1_error(SD_CMD_APP_CMD);
1579
1580 if(status != SD_OK)
1581 {
1582 return status;
1583 }
1584
1585 /* send cmd23, set block count */
1586 sdio_command_init_struct.argument = blk_size;
1587 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1588 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1589 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1590
1591 /* sdio command config */
1592 sdio_command_config(SDIOx, &sdio_command_init_struct);
1593 /* enable ccsm */
1594 sdio_command_state_machine_enable(SDIOx, TRUE);
1595
1596 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1597
1598 if(status != SD_OK)
1599 {
1600 return status;
1601 }
1602 }
1603
1604 /* send cmd25, write mult blocks */
1605 sdio_command_init_struct.argument = addr;
1606 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1607 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1608 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1609
1610 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1611 sdio_data_init_struct.data_length = nblks * blk_size ;
1612 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1613 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1614 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1615
1616 stop_flag = 1;
1617 /* cmd12 is needed */
1618 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1619
1620 if(status != SD_OK)
1621 {
1622 return status;
1623 }
1624
1625 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1626
1627 status = check_card_programming(&card_state);
1628
1629 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1630 {
1631 status = check_card_programming(&card_state);
1632 }
1633
1634 return status;
1635}
1636
1644 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1645{
1646 uint32_t response = 0;
1647
1648 SDIOx->dtctrl = 0x0;
1649
1650 /* clear dcsm configuration */
1651 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1652 sdio_data_init_struct.data_length = 0 ;
1653 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1654 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1655 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1656
1657 sdio_data_config(SDIOx, &sdio_data_init_struct);
1658 sdio_data_state_machine_enable(SDIOx, FALSE);
1659
1660 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1661
1662 /* check card locked */
1663 if(response & SD_CARD_LOCKED)
1664 {
1665 return SD_LOCK_UNLOCK_ERROR;
1666 }
1667 /* send cmd11, read data */
1668 sdio_command_init_struct.argument = addr;
1669 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1670 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1671 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1672
1673 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1674 sdio_data_init_struct.data_length = len;
1675 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1676 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1677 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1678
1679 stop_flag = 1;
1680 /* cmd12 is needed */
1681 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1682}
1683
1691 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1692{
1693 sd_error_status_type status = SD_OK;
1694 uint32_t response = 0;
1695 uint8_t card_state = 0;
1696
1697 if(buf == NULL)
1698 {
1699 return SD_INVALID_PARAMETER;
1700 }
1701
1702 SDIOx->dtctrl = 0x0;
1703
1704 /* clear dcsm configuration */
1705 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1706 sdio_data_init_struct.data_length = 0;
1707 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1708 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1709 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1710
1711 sdio_data_config(SDIOx, &sdio_data_init_struct);
1712 sdio_data_state_machine_enable(SDIOx, FALSE);
1713
1714 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1715
1716 /* check card locked */
1717 if(response & SD_CARD_LOCKED)
1718 {
1719 return SD_LOCK_UNLOCK_ERROR;
1720 }
1721 /* send cmd20, write data */
1722 sdio_command_init_struct.argument = addr;
1723 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1724 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1725 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1726
1727
1728 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1729 sdio_data_init_struct.data_length = len;
1730 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1731 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1732 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1733
1734 stop_flag = 1;
1735 /* cmd12 is needed */
1736 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1737
1738 if(status != SD_OK)
1739 {
1740 return status;
1741 }
1742
1743 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1744
1745 status = check_card_programming(&card_state);
1746
1747 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1748 {
1749 status = check_card_programming(&card_state);
1750 }
1751
1752 return status;
1753}
1754
1760void SDIO1_IRQHandler(void)
1761{
1762 sd_irq_service();
1763}
1764
1770void SDIO2_IRQHandler(void)
1771{
1772 sd_irq_service();
1773}
1774
1780 sd_error_status_type sd_irq_service(void)
1781{
1782 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1783 {
1784 if(stop_flag == 1)
1785 {
1786 /* send cmd12, stop transmission */
1787 sdio_command_init_struct.argument = 0;
1788 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1789 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1790 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1791 /* sdio command config */
1792 sdio_command_config(SDIOx, &sdio_command_init_struct);
1793 /* enable ccsm */
1794 sdio_command_state_machine_enable(SDIOx, TRUE);
1795 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1796 }
1797 else
1798 {
1799 transfer_error = SD_OK;
1800 }
1801 /* clear flag */
1802 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1803 transfer_end = 1;
1804 return transfer_error;
1805 }
1806
1807 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1808 {
1809 /* clear flag */
1810 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1811 transfer_error = SD_DATA_FAIL;
1812 transfer_end = 1;
1813 return transfer_error;
1814 }
1815
1816 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1817 {
1818 /* clear flag */
1819 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1820 transfer_error = SD_DATA_TIMEOUT;
1821 transfer_end = 1;
1822 return transfer_error;
1823 }
1824
1825 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1826 {
1827 /* clear flag */
1828 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1829 transfer_error = SD_RX_OVERRUN;
1830 transfer_end = 1;
1831 return(SD_RX_OVERRUN);
1832 }
1833
1834 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1835 {
1836 /* clear flag */
1837 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1838 transfer_error = SD_TX_UNDERRUN;
1839 transfer_end = 1;
1840 return(SD_TX_UNDERRUN);
1841 }
1842
1843 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1844 {
1845 /* clear flag */
1846 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1847 transfer_error = SD_START_BIT_ERR;
1848 transfer_end = 1;
1849 return(SD_START_BIT_ERR);
1850 }
1851
1852 /* disable interrupt */
1853 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1854 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1855 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1856 return(SD_OK);
1857}
1858
1864 sd_error_status_type command_error(void)
1865{
1866 sd_error_status_type status = SD_OK;
1867 uint32_t timeout = SDIO_CMD0TIMEOUT;
1868
1869 while(timeout--)
1870 {
1871 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1872 {
1873 break;
1874 }
1875 }
1876
1877 if(timeout == 0)
1878 {
1879 return SD_CMD_RSP_TIMEOUT;
1880 }
1881
1882 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1883 return status;
1884}
1885
1891 sd_error_status_type command_rsp7_error(void)
1892{
1893 sd_error_status_type status = SD_OK;
1894 uint32_t sts_reg = 0;
1895 uint32_t timeout = SDIO_CMD0TIMEOUT;
1896
1897 while(timeout--)
1898 {
1899 sts_reg = SDIOx->sts;
1900
1901 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1902 {
1903 break;
1904 }
1905 }
1906
1907 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1908 {
1909 status = SD_CMD_RSP_TIMEOUT;
1910 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1911 return status;
1912 }
1913
1914 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1915 {
1916 status = SD_OK;
1917 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1918 }
1919
1920 return status;
1921}
1922
1928 sd_error_status_type command_rsp1_error(uint8_t cmd)
1929{
1930 uint32_t sts_reg = 0;
1931 uint32_t rsp_cmd = 0;
1932
1933 while(1)
1934 {
1935 sts_reg = SDIOx->sts;
1936
1937 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1938 {
1939 break;
1940 }
1941 }
1942
1943 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1944 {
1945 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1946 return SD_CMD_RSP_TIMEOUT;
1947 }
1948
1949 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1950 {
1951 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1952 return SD_CMD_FAIL;
1953 }
1954
1955 rsp_cmd = sdio_command_response_get(SDIOx);
1956 if(rsp_cmd != cmd)
1957 {
1958 return SD_ILLEGAL_CMD;
1959 }
1960
1961 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1962
1963 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1964}
1965
1971 sd_error_status_type command_rsp3_error(void)
1972{
1973 uint32_t sts_reg = 0;;
1974
1975 while(1)
1976 {
1977 sts_reg = SDIOx->sts;
1978
1979 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1980 {
1981 break;
1982 }
1983 }
1984
1985 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1986 {
1987 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1988 return SD_CMD_RSP_TIMEOUT;
1989 }
1990
1991 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1992
1993 return SD_OK;
1994}
1995
2001 sd_error_status_type command_rsp2_error(void)
2002{
2003 sd_error_status_type status = SD_OK;
2004 uint32_t sts_reg;
2005 uint32_t timeout = SDIO_CMD0TIMEOUT;
2006
2007 while(timeout--)
2008 {
2009 sts_reg = SDIOx->sts;
2010
2011 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2012 {
2013 break;
2014 }
2015 }
2016
2017 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2018 {
2019 status = SD_CMD_RSP_TIMEOUT;
2020 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2021
2022 return status;
2023 }
2024
2025 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2026 {
2027 status = SD_CMD_FAIL;
2028 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2029 }
2030
2031 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2032
2033 return status;
2034}
2035
2041 sd_error_status_type command_rsp4_error(uint8_t cmd)
2042{
2043 uint32_t sts_reg = 0, rsp_cmd = 0;
2044
2045 while(1)
2046 {
2047 sts_reg = SDIOx->sts;
2048
2049 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2050 {
2051 break;
2052 }
2053 }
2054
2055 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2056 {
2057 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2058 return SD_CMD_RSP_TIMEOUT;
2059 }
2060
2061 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2062 {
2063 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2064
2065 return SD_CMD_FAIL;
2066 }
2067
2068 rsp_cmd = sdio_command_response_get(SDIOx);
2069 if(rsp_cmd != cmd)
2070 {
2071 return SD_ILLEGAL_CMD;
2072 }
2073
2074 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2075
2076 return SD_OK;
2077}
2078
2084 sd_error_status_type command_rsp5_error(uint8_t cmd)
2085{
2086 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2087
2088 while(1)
2089 {
2090 sts_reg = SDIOx->sts;
2091
2092 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2093 {
2094 break;
2095 }
2096 }
2097
2098 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2099 {
2100 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2101
2102 return SD_CMD_RSP_TIMEOUT;
2103 }
2104
2105 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2106 {
2107 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2108
2109 return SD_CMD_FAIL;
2110 }
2111
2112 rsp_cmd = sdio_command_response_get(SDIOx);
2113 if(rsp_cmd != cmd)
2114 {
2115 return SD_ILLEGAL_CMD;
2116 }
2117
2118 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2119
2120 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2121
2122 if(response & SD_R5_OUT_OF_RANGE)
2123 {
2124 return SD_CMD_OUT_OF_RANGE;
2125 }
2126
2127 if(response & SD_R5_FUNCTION_NUMBER)
2128 {
2129 return SD_SDIO_UNKNOWN_FUNC;
2130 }
2131
2132 if(response & SD_R5_ERROR)
2133 {
2134 return SD_GENERAL_UNKNOWN_ERROR;
2135 }
2136
2137 return SD_OK;
2138}
2139
2147 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2148{
2149 sd_error_status_type status = SD_OK;
2150 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2151
2152 while(1)
2153 {
2154 sts_reg = SDIOx->sts;
2155
2156 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2157 {
2158 break;
2159 }
2160 }
2161
2162 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2163 {
2164 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2165 return SD_CMD_RSP_TIMEOUT;
2166 }
2167
2168 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2169 {
2170 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2171 return SD_CMD_FAIL;
2172 }
2173
2174 rsp_cmd = sdio_command_response_get(SDIOx);
2175 if(rsp_cmd != cmd)
2176 {
2177 return SD_ILLEGAL_CMD;
2178 }
2179
2180 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2181
2182 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2183
2184 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2185 {
2186 *prca = (uint16_t)(response >> 16);
2187 return status;
2188 }
2189
2190 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2191 {
2192 return SD_GENERAL_UNKNOWN_ERROR;
2193 }
2194
2195 if(response & SD_R6_ILLEGAL_CMD)
2196 {
2197 return SD_ILLEGAL_CMD;
2198 }
2199
2200 if(response & SD_R6_CMD_CRC_ERROR)
2201 {
2202 return SD_CMD_CRC_ERROR;
2203 }
2204
2205 return status;
2206}
2207
2213 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2214{
2215 sd_error_status_type status = SD_OK;
2216 uint32_t response = 0;
2217 uint8_t arg = 0x00;
2218
2219 if(new_state == TRUE)
2220 {
2221 arg = 0x02;
2222 }
2223 else
2224 {
2225 arg = 0x00;
2226 }
2227
2228 /* get response1 */
2229 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2230
2231 /* check card locked or not */
2232 if(response & SD_CARD_LOCKED)
2233 {
2234 return SD_LOCK_UNLOCK_ERROR;
2235 }
2236
2237 if(sd_card_info.sd_scr_reg.sd_bus_width)
2238 {
2239 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2240 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2241 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2242 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2243
2244 /* sdio command config */
2245 sdio_command_config(SDIOx, &sdio_command_init_struct);
2246 /* enable ccsm */
2247 sdio_command_state_machine_enable(SDIOx, TRUE);
2248
2249 status = command_rsp1_error(SD_CMD_APP_CMD);
2250
2251 if(status != SD_OK)
2252 {
2253 return status;
2254 }
2255
2256 sdio_command_init_struct.argument = arg;
2257 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2258 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2259 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2260
2261 /* sdio command config */
2262 sdio_command_config(SDIOx, &sdio_command_init_struct);
2263 /* enable ccsm */
2264 sdio_command_state_machine_enable(SDIOx, TRUE);
2265
2266 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2267 return status;
2268 }
2269 else
2270 {
2271 return SD_REQ_NOT_APPLICABLE;
2272 }
2273}
2274
2282 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2283{
2284 sd_error_status_type status = SD_OK;
2285 uint32_t card_status = 0, timeout = 0;
2286
2287 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2288 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2289 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2290 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2291
2292 /* sdio command config */
2293 sdio_command_config(SDIOx, &sdio_command_init_struct);
2294 /* enable ccsm */
2295 sdio_command_state_machine_enable(SDIOx, TRUE);
2296
2297 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2298 if(status != SD_OK)
2299 {
2300 return status;
2301 }
2302
2303 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2304 if(card_status & MMC_SWITCH_ERROR)
2305 {
2306 return SD_SWITCH_ERROR;
2307 }
2308
2309 timeout = SD_DATATIMEOUT;
2310 do
2311 {
2312 timeout--;
2313 status = sd_status_send(&card_status);
2314 } /* check ready_for_data flag */
2315 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2316
2317 if(timeout == 0)
2318 {
2319 return SD_ERROR;
2320 }
2321
2322 return status;
2323}
2324
2333 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2334{
2335 sd_error_status_type status = SD_OK;
2336 uint8_t power;
2337 uint16_t blk_size;
2338
2339 if(rsp == NULL)
2340 {
2341 return SD_INVALID_PARAMETER;
2342 }
2343
2344 SDIOx->dtctrl = 0x0;
2345
2346 blk_size = 64;
2347 power = convert_from_bytes_to_power_of_two(blk_size);
2348
2349 sdio_command_init_struct.argument = blk_size;
2350 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2351 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2352 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2353
2354 /* sdio command config */
2355 sdio_command_config(SDIOx, &sdio_command_init_struct);
2356 /* enable ccsm */
2357 sdio_command_state_machine_enable(SDIOx, TRUE);
2358
2359 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2360
2361 if(status != SD_OK)
2362 {
2363 return status;
2364 }
2365
2366 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2367 sdio_data_init_struct.data_length = blk_size ;
2368 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2369 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2370 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2371
2372 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2373 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2374 sdio_command_init_struct.argument |= value << (group * 4);
2375 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2376 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2377 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2378
2379 stop_flag = 0;
2380
2381 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2382}
2383
2389 sd_error_status_type check_card_programming(uint8_t *p_status)
2390{
2391 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2392
2393 /* send cmd13 */
2394 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2395 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2396 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2397 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2398
2399 /* sdio command config */
2400 sdio_command_config(SDIOx, &sdio_command_init_struct);
2401 /* enable ccsm */
2402 sdio_command_state_machine_enable(SDIOx, TRUE);
2403
2404 sts_reg = SDIOx->sts;
2405
2406 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2407 {
2408 sts_reg = SDIOx->sts;
2409 }
2410
2411 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2412 {
2413 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2414 return SD_CMD_FAIL;
2415 }
2416
2417 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2418 {
2419 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2420 return SD_CMD_RSP_TIMEOUT;
2421 }
2422
2423 rsp_cmd = sdio_command_response_get(SDIOx);
2424 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2425 {
2426 return SD_ILLEGAL_CMD;
2427 }
2428
2429 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2430
2431 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2432
2433 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2434
2435 return SD_OK;
2436}
2437
2443 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2444{
2445 sd_error_status_type status = SD_OK;
2446
2447 if(p_card_status == NULL)
2448 {
2449 status = SD_INVALID_PARAMETER;
2450 return status;
2451 }
2452
2453 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2454 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2455 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2456 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2457
2458 /* sdio command config */
2459 sdio_command_config(SDIOx, &sdio_command_init_struct);
2460 /* enable ccsm */
2461 sdio_command_state_machine_enable(SDIOx, TRUE);
2462
2463 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2464
2465 if(status != SD_OK)
2466 {
2467 return status;
2468 }
2469
2470 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2471
2472 return status;
2473}
2474
2480 sd_card_state_type sd_state_get(void)
2481{
2482 uint32_t response = 0;
2483
2484 if(sd_status_send(&response) != SD_OK)
2485 {
2486 return SD_CARD_ERROR;
2487 }
2488 else
2489 {
2490 return (sd_card_state_type)((response >> 9) & 0x0F);
2491 }
2492}
2493
2498 sd_error_status_type scr_find(void)
2499{
2500 uint32_t index = 0, sts_reg = 0;
2501 sd_error_status_type status = SD_OK;
2502 uint32_t *tempscr;
2503
2504 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2505
2506 /* send cmd16, set block length */
2507 sdio_command_init_struct.argument = (uint32_t)8;
2508 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2509 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2510 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2511
2512 /* sdio command config */
2513 sdio_command_config(SDIOx, &sdio_command_init_struct);
2514 /* enable ccsm */
2515 sdio_command_state_machine_enable(SDIOx, TRUE);
2516
2517 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2518
2519 if(status != SD_OK)
2520 {
2521 return status;
2522 }
2523
2524 /* send cmd55 */
2525 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2526 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2527 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2528 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2529
2530 /* sdio command config */
2531 sdio_command_config(SDIOx, &sdio_command_init_struct);
2532 /* enable ccsm */
2533 sdio_command_state_machine_enable(SDIOx, TRUE);
2534
2535 status = command_rsp1_error(SD_CMD_APP_CMD);
2536
2537 if(status != SD_OK)
2538 {
2539 return status;
2540 }
2541
2542 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2543 sdio_data_init_struct.data_length = 8;
2544 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2545 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2546 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2547
2548 sdio_data_config(SDIOx, &sdio_data_init_struct);
2549 sdio_data_state_machine_enable(SDIOx, TRUE);
2550
2551 /* send cmd51 */
2552 sdio_command_init_struct.argument = 0x0;
2553 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2554 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2555 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2556
2557 /* sdio command config */
2558 sdio_command_config(SDIOx, &sdio_command_init_struct);
2559 /* enable ccsm */
2560 sdio_command_state_machine_enable(SDIOx, TRUE);
2561
2562 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2563
2564 if(status != SD_OK)
2565 {
2566 return status;
2567 }
2568
2569 sts_reg = SDIOx->sts;
2570
2571 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2572 {
2573 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2574 {
2575 *(tempscr + index) = sdio_data_read(SDIOx);
2576 index++;
2577 }
2578 sts_reg = SDIOx->sts;
2579 }
2580
2581 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2582 {
2583 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2584 return SD_DATA_TIMEOUT;
2585 }
2586 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2587 {
2588 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2589 return SD_DATA_FAIL;
2590 }
2591 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2592 {
2593 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2594 return SD_RX_OVERRUN;
2595 }
2596 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2597 {
2598 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2599 return SD_START_BIT_ERR;
2600 }
2601
2602 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2603
2604 return status;
2605}
2606
2612 sd_error_status_type speed_change(uint8_t speed)
2613{
2614 sd_error_status_type status = SD_OK;
2615 uint8_t switch_sts[64];
2616
2617 if(speed > 1)
2618 {
2619 return SD_ERROR;
2620 }
2621
2622 /* check card type */
2623 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2624 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2625 {
2626 /* version 1.01 card does not support cmd6 */
2627 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2628 {
2629 return SD_ERROR;
2630 }
2631
2632 /* check group 1 function support speed */
2633 status = sd_switch(0, 0, speed, switch_sts);
2634
2635 if(status != 0)
2636 {
2637 return status;
2638 }
2639
2640 if((switch_sts[13] & (1 << speed)) == 0)
2641 {
2642 return SD_ERROR;
2643 }
2644
2645 status = sd_switch(1, 0, speed, switch_sts);
2646
2647 if(status != 0)
2648 {
2649 return status;
2650 }
2651
2652 /* read it back for confirmation */
2653 if((switch_sts[16] & 0xF) != speed)
2654 {
2655 return SD_ERROR;
2656 }
2657 }
2658 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2659 {
2660 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2661
2662 if(status != 0)
2663 {
2664 return status;
2665 }
2666 }
2667
2668 return status;
2669}
2670
2676uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2677{
2678 uint8_t count = 0;
2679
2680 while(number_of_bytes != 1)
2681 {
2682 number_of_bytes >>= 1;
2683 count++;
2684 }
2685
2686 return count;
2687}
2688
2697void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2698{
2699 dma_init_type dma_init_struct;
2700 dma_default_para_init(&dma_init_struct);
2701
2702 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2703
2704 dma_reset(DMA2_CHANNEL4);
2705 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2706
2707 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2708 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2709 dma_init_struct.direction = dir;
2710 dma_init_struct.buffer_size = buf_size / 4;
2711 dma_init_struct.peripheral_inc_enable = FALSE;
2712 dma_init_struct.memory_inc_enable = TRUE;
2713 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2714 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2715 dma_init_struct.loop_mode_enable = FALSE;
2716 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2717 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2718
2719 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2720}
2721
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:46
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: sd_mmc_card/src/at32_sdio.c:2333
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: sd_mmc_card/src/at32_sdio.c:2084
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: sd_mmc_card/src/at32_sdio.c:2612
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sd_mmc_card/src/at32_sdio.c:394
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: sd_mmc_card/src/at32_sdio.c:38
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sd_mmc_card/src/at32_sdio.c:1780
transfer_end
volatile uint8_t transfer_end
Definition: sd_mmc_card/src/at32_sdio.c:45
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: sd_mmc_card/src/at32_sdio.c:1891
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sd_mmc_card/src/at32_sdio.c:777
card_type
static sd_memory_card_type card_type
Definition: sd_mmc_card/src/at32_sdio.c:40
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: sd_mmc_card/src/at32_sdio.c:2676
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sd_mmc_card/src/at32_sdio.c:523
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: sd_mmc_card/src/at32_sdio.c:37
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1691
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sd_mmc_card/src/at32_sdio.c:408
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1179
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sd_mmc_card/src/at32_sdio.c:798
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: sd_mmc_card/src/at32_sdio.c:2147
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: sd_mmc_card/src/at32_sdio.c:1760
stop_flag
static uint8_t stop_flag
Definition: sd_mmc_card/src/at32_sdio.c:43
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: sd_mmc_card/src/at32_sdio.c:2282
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sd_mmc_card/src/at32_sdio.c:1021
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: sd_mmc_card/src/at32_sdio.c:2389
transfer_error
volatile sd_error_status_type transfer_error
Definition: sd_mmc_card/src/at32_sdio.c:44
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: sd_mmc_card/src/at32_sdio.c:2213
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: sd_mmc_card/src/at32_sdio.c:1928
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: sd_mmc_card/src/at32_sdio.c:1770
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1480
csd_table
static uint32_t csd_table[4]
Definition: sd_mmc_card/src/at32_sdio.c:41
sdio_clock_set
void sdio_clock_set(uint32_t clk_div)
set sdio clock devision factor.
Definition: sd_mmc_card/src/at32_sdio.c:179
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sd_mmc_card/src/at32_sdio.c:2480
cid_table
static uint32_t cid_table[4]
Definition: sd_mmc_card/src/at32_sdio.c:41
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sd_mmc_card/src/at32_sdio.c:2697
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1358
device_mode
static sd_data_transfer_mode_type device_mode
Definition: sd_mmc_card/src/at32_sdio.c:42
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sd_mmc_card/src/at32_sdio.c:2443
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: sd_mmc_card/src/at32_sdio.c:821
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: sd_mmc_card/src/at32_sdio.c:2001
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:70
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1644
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: sd_mmc_card/src/at32_sdio.c:2498
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sd_mmc_card/src/at32_sdio.c:194
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: sd_mmc_card/src/at32_sdio.c:2041
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1268
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:734
rca
static uint32_t rca
Definition: sd_mmc_card/src/at32_sdio.c:41
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: sd_mmc_card/src/at32_sdio.c:1971
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: sd_mmc_card/src/at32_sdio.c:1864
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f413_crm.h:105
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:103
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:214
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:245
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:255
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f413_dma.h:490
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
GPIOD
#define GPIOD
Definition: at32f413_gpio.h:749
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:327
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:488
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:414
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:463
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:350
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:139
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:166
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:73
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:102
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:126
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:230
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:313
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:85
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:381
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:439
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:153
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:276
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:192
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:49
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:179
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:363
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:137
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f413_sdio.h:178
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f413_sdio.h:158
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f413_sdio.h:159
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f413_sdio.h:150
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f413_sdio.h:149
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f413_sdio.h:148
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f413_sdio.h:130
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f413_sdio.h:210
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f413_sdio.h:211
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f413_sdio.h:120
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f413_sdio.h:121
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f413_sdio.h:201
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f413_sdio.h:202
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f413_sdio.h:138
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f413_sdio.h:139
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:170
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:169
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:168
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f413_sdio.h:182
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f413_sdio.h:179
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f413_sdio.h:85
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f413_sdio.h:97
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f413_sdio.h:90
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:84
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:88
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f413_sdio.h:98
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f413_sdio.h:104
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f413_sdio.h:83
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f413_sdio.h:89
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f413_sdio.h:93
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:86
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:92
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f413_sdio.h:91
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:87
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f413_sdio.h:59
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f413_sdio.h:65
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f413_sdio.h:53
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f413_sdio.h:54
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f413_sdio.h:55
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f413_sdio.h:51
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f413_sdio.h:64
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f413_sdio.h:58
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: sd_mmc_card/inc/at32_sdio.h:436
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: sd_mmc_card/inc/at32_sdio.h:289
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:301
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:285
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:293
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: sd_mmc_card/inc/at32_sdio.h:258
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: sd_mmc_card/inc/at32_sdio.h:268
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: sd_mmc_card/inc/at32_sdio.h:269
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: sd_mmc_card/inc/at32_sdio.h:277
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:276
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:257
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: sd_mmc_card/inc/at32_sdio.h:272
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: sd_mmc_card/inc/at32_sdio.h:262
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:273
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:304
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: sd_mmc_card/inc/at32_sdio.h:256
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: sd_mmc_card/inc/at32_sdio.h:259
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:288
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:267
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:286
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:287
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:263
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: sd_mmc_card/inc/at32_sdio.h:265
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sd_mmc_card/inc/at32_sdio.h:63
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:72
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:185
sd_memory_card_type
sd_memory_card_type
Definition: sd_mmc_card/inc/at32_sdio.h:201
SDIOx
#define SDIOx
Definition: sd_mmc_card/inc/at32_sdio.h:49
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:472
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:474
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:461
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: sd_mmc_card/inc/at32_sdio.h:454
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: sd_mmc_card/inc/at32_sdio.h:452
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:340
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:339
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: sd_mmc_card/inc/at32_sdio.h:338
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: sd_mmc_card/inc/at32_sdio.h:398
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: sd_mmc_card/inc/at32_sdio.h:389
SD_R5_ERROR
#define SD_R5_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:381
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sd_mmc_card/inc/at32_sdio.h:400
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:379
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: sd_mmc_card/inc/at32_sdio.h:406
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:391
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: sd_mmc_card/inc/at32_sdio.h:380
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:387
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:386
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: sd_mmc_card/inc/at32_sdio.h:394
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:401
SD_ALLZERO
#define SD_ALLZERO
Definition: sd_mmc_card/inc/at32_sdio.h:395
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:388
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:372
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: sd_mmc_card/inc/at32_sdio.h:393
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: sd_mmc_card/inc/at32_sdio.h:392
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: sd_mmc_card/inc/at32_sdio.h:374
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sd_mmc_card/inc/at32_sdio.h:399
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:390
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:65
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:64
SD_ERROR
@ SD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:116
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sd_mmc_card/inc/at32_sdio.h:106
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:75
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sd_mmc_card/inc/at32_sdio.h:113
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:74
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:81
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:92
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sd_mmc_card/inc/at32_sdio.h:114
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:78
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:89
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:88
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:79
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sd_mmc_card/inc/at32_sdio.h:112
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:102
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sd_mmc_card/inc/at32_sdio.h:100
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:77
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:80
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:87
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:76
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:117
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:194
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:208
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:207
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:202
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:206
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:203
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:205
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:235
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:236
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: sd_mmc_card/inc/at32_sdio.h:173
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:169
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: sd_mmc_card/inc/at32_sdio.h:171
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: sd_mmc_card/inc/at32_sdio.h:170
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: sd_mmc_card/inc/at32_sdio.h:126
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::nsac
uint8_t nsac
Definition: sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: sd_mmc_card/inc/at32_sdio.h:125
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:127
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:146
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::taac
uint8_t taac
Definition: sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:143
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: sd_mmc_card/inc/at32_sdio.h:220
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: sd_mmc_card/inc/at32_sdio.h:218
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:227
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:229
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:228
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:231
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:230
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:238
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:243
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:239
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:242
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:240


AT32F413 Firmwary Library: at32_sdio.h Source File

  • sdio
  • sdio_fatfs
  • inc
sdio_fatfs/inc/at32_sdio.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __AT32_SDIO_H
28#define __AT32_SDIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
49#define SDIOx SDIO1
50
62typedef enum
63{
64 SD_TRANSFER_POLLING_MODE = 0,
65 SD_TRANSFER_DMA_MODE = 1
66} sd_data_transfer_mode_type;
67
71typedef enum
72{
73 /* sdio specific error defines ------------------------------------------*/
74 SD_CMD_FAIL = 1,
75 SD_DATA_FAIL = 2,
76 SD_CMD_RSP_TIMEOUT = 3,
77 SD_DATA_TIMEOUT = 4,
78 SD_TX_UNDERRUN = 5,
79 SD_RX_OVERRUN = 6,
80 SD_START_BIT_ERR = 7,
81 SD_CMD_OUT_OF_RANGE = 8,
82 SD_ADDR_MISALIGNED = 9,
83 SD_BLK_LEN_ERR = 10,
84 SD_ERASE_SEQ_ERR = 11,
85 SD_INVALID_ERASE_PARAM = 12,
86 SD_WR_PROTECT_VIOLATION = 13,
87 SD_LOCK_UNLOCK_ERROR = 14,
88 SD_CMD_CRC_ERROR = 15,
89 SD_ILLEGAL_CMD = 16,
90 SD_CARD_ECC_ERROR = 17,
91 SD_CARD_CONTROLLER_ERR = 18,
92 SD_GENERAL_UNKNOWN_ERROR = 19,
93 SD_STREAM_RD_UNDERRUN = 20,
94 SD_STREAM_WR_OVERRUN = 21,
95 SD_CID_CSD_OVERWRITE = 22,
96 SD_WP_ERASE_SKIP = 23,
97 SD_CARD_ECC_DISABLED = 24,
98 SD_ERASE_RESET = 25,
99 SD_AKE_SEQ_ERROR = 26,
100 SD_INVALID_VOLTRANGE = 27,
101 SD_ADDR_OUT_OF_RANGE = 28,
102 SD_SWITCH_ERROR = 29,
103 SD_SDIO_DISABLED = 30,
104 SD_SDIO_FUNC_BUSY = 31,
105 SD_SDIO_FUNC_ERROR = 32,
106 SD_SDIO_UNKNOWN_FUNC = 33,
108 /* standard error defines --------------------------------------------*/
109 SD_INTERNAL_ERROR,
110 SD_NOT_CONFIGURED,
111 SD_REQ_PENDING,
112 SD_REQ_NOT_APPLICABLE,
113 SD_INVALID_PARAMETER,
114 SD_UNSUPPORTED_FEATURE,
115 SD_UNSUPPORTED_HW,
116 SD_ERROR,
117 SD_OK = 0
118} sd_error_status_type;
119
123typedef struct
124{
125 uint8_t csd_struct;
126 uint8_t spec_version;
127 uint8_t reserved1;
128 uint8_t taac;
129 uint8_t nsac;
130 uint8_t max_bus_clk_freq;
131 uint16_t card_cmd_classes;
132 uint8_t max_read_blk_length;
133 uint8_t part_blk_read;
134 uint8_t write_blk_misalign;
135 uint8_t read_blk_misalign;
136 uint8_t dsr_implemented;
137 uint8_t reserved2;
138 uint32_t device_size;
139 uint8_t max_read_current_vdd_min;
140 uint8_t max_read_current_vdd_max;
141 uint8_t max_write_current_vdd_min;
142 uint8_t max_write_current_vdd_max;
143 uint8_t device_size_mult;
144 uint8_t erase_group_size;
145 uint8_t erase_group_size_mult;
146 uint8_t write_protect_group_size;
147 uint8_t write_protect_group_enable;
148 uint8_t manufacturer_default_ecc;
149 uint8_t write_speed_factor;
150 uint8_t max_write_blk_length;
151 uint8_t part_blk_write;
152 uint8_t reserved3;
153 uint8_t content_protect_app;
154 uint8_t file_format_group;
155 uint8_t copy_flag;
156 uint8_t permanent_write_protect;
157 uint8_t temp_write_protect;
158 uint8_t file_formart;
159 uint8_t ecc_code;
160 uint8_t csd_crc;
161 uint8_t reserved4;
162} sd_csd_struct_type;
163
167typedef struct
168{
169 uint8_t manufacturer_id;
170 uint16_t oem_app_id;
171 uint32_t product_name1;
172 uint8_t product_name2;
173 uint8_t product_reversion;
174 uint32_t product_sn;
175 uint8_t reserved1;
176 uint16_t manufact_date;
177 uint8_t cid_crc;
178 uint8_t reserved2;
179} sd_cid_struct_type;
180
184typedef enum
185{
186 SD_CARD_READY = ((uint32_t)0x00000001),
187 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
188 SD_CARD_STANDBY = ((uint32_t)0x00000003),
189 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
190 SD_CARD_SENDING = ((uint32_t)0x00000005),
191 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
192 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
193 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
194 SD_CARD_ERROR = ((uint32_t)0x000000FF)
195} sd_card_state_type;
196
200typedef enum
201{
202 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
203 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
204 SDIO_HIGH_CAPACITY_SD_CARD = 2,
205 SDIO_MULTIMEDIA_CARD = 3,
206 SDIO_SECURE_DIGITAL_IO_CARD = 4,
207 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
208 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
209 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
210 SDIO_SDIO_CARD = 8
211} sd_memory_card_type;
212
216typedef struct
217{
218 uint32_t sd_spec :4; /* [59:56] */
219 uint32_t scr_structure :4; /* [60:63] */
220 uint32_t sd_bus_width :4; /* [51:48] */
221 uint32_t sd_security :3; /* [52:54] */
222 uint32_t data_stat_after_erase :1; /* [55:55] */
223 uint32_t reserved1 :7; /* [46:40] */
224 uint32_t sd_spec3 :1; /* [47:47] */
225 uint32_t cmd20_support :1; /* [32:32] */
226 uint32_t cmd23_support :1; /* [33:33] */
227 uint32_t reserverd2 :6; /* [34:39] */
228 uint32_t reserverd3; /* [31:0] */
229} sd_scr_struct_type;
230
234typedef struct
235{
236 sd_csd_struct_type sd_csd_reg;
237 sd_cid_struct_type sd_cid_reg;
238 sd_scr_struct_type sd_scr_reg;
239 long long card_capacity;
240 uint32_t card_blk_size;
241 uint16_t rca;
242 uint8_t card_type;
243} sd_card_info_struct_type;
244
256#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
257#define SD_CMD_SEND_OP_COND ((uint8_t)1)
258#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
259#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
260#define SD_CMD_SET_DSR ((uint8_t)4)
261#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
262#define SD_CMD_HS_SWITCH ((uint8_t)6)
263#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
264#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
265#define SD_CMD_SEND_CSD ((uint8_t)9)
266#define SD_CMD_SEND_CID ((uint8_t)10)
267#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
268#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
269#define SD_CMD_SEND_STATUS ((uint8_t)13)
270#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
271#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
272#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
273#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
274#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
275#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
276#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
277#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
278#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
279#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
280#define SD_CMD_PROG_CID ((uint8_t)26)
281#define SD_CMD_PROG_CSD ((uint8_t)27)
282#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
283#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
284#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
285#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
286#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
287#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
288#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
289#define SD_CMD_ERASE ((uint8_t)38)
290#define SD_CMD_FAST_IO ((uint8_t)39)
291#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
292#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
293#define SD_CMD_APP_CMD ((uint8_t)55)
294#define SD_CMD_GEN_CMD ((uint8_t)56)
295#define SD_CMD_NO_CMD ((uint8_t)64)
296
301#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
302#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
303#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
304#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
305#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
306#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
307#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
308#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
309
314#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
315#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
316#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
317#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
318#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
319#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
320#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
321#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
322#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
323#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
324#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
325
337#define NULL 0
338#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
339#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
340#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
341#define SDIO_FIFO_Address ((uint32_t)0x40018080)
342
354#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
355#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
356#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
357#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
358#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
359#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
360#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
361#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
362#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
363#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
364#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
365#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
366#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
367#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
368#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
369#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
370#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
371#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
372#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
373#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
374#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
375
379#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
380#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
381#define SD_R5_ERROR ((uint32_t)0x00000800)
382
386#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
387#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
388#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
389#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
390#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
391#define SD_STD_CAPACITY ((uint32_t)0x00000000)
392#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
393#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
394#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
395#define SD_ALLZERO ((uint32_t)0x00000000)
396#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
397#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
398#define SD_CARD_LOCKED ((uint32_t)0x02000000)
399#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
400#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
401#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
402#define SD_0TO7BITS ((uint32_t)0x000000FF)
403#define SD_8TO15BITS ((uint32_t)0x0000FF00)
404#define SD_16TO23BITS ((uint32_t)0x00FF0000)
405#define SD_24TO31BITS ((uint32_t)0xFF000000)
406#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
407#define SD_HALFFIFO ((uint32_t)0x00000008)
408#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
409
421#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
422#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
423#define SD_CCCC_ERASE ((uint32_t)0x00000020)
424
436#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
437
449#define EXT_CSD_Command_set 0x0
450#define EXT_CSD_Set_bit 0x1
451#define EXT_CSD_Clear_byte 0x2
452#define EXT_CSD_Write_byte 0x3
453
454#define EXT_CSD_CMD_SET_NORMAL (1<<0)
455#define EXT_CSD_CMD_SET_SECURE (1<<1)
456#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
457
461#define EXT_CSD_BUS_WIDTH 183
462#define EXT_CSD_HS_TIMING 185
463
472#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
473 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
474#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
475 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
480extern sd_card_info_struct_type sd_card_info;
481
486/* sd exported functions ----------------------------------------*/
487 sd_error_status_type sd_init(void);
488void sdio_clock_set(uint32_t clkdiv);
489 sd_error_status_type sd_power_on(void);
490 sd_error_status_type sd_power_off(void);
491 sd_error_status_type sd_card_init(void);
492 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
493 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
494 sd_error_status_type sd_device_mode_set(uint32_t mode);
495 sd_error_status_type sd_deselect_select(uint32_t addr);
496 sd_error_status_type sd_status_send(uint32_t *p_card_status);
497 sd_card_state_type sd_state_get(void);
498 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
499 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
500 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
501 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
502 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
503 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
504 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
505 sd_error_status_type sd_irq_service(void);
506void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
507
520#ifdef __cplusplus
521}
522#endif
523
524#endif /* __AT32_SDIO_H */
at32f413.h
at32f413 header file
card_type
static sd_memory_card_type card_type
Definition: sd_mmc_card/src/at32_sdio.c:40
rca
static uint32_t rca
Definition: sd_mmc_card/src/at32_sdio.c:41
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:46
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:214
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:137
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:72
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:185
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sd_mmc_card/src/at32_sdio.c:394
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sd_mmc_card/src/at32_sdio.c:1780
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sd_mmc_card/src/at32_sdio.c:777
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sd_mmc_card/src/at32_sdio.c:523
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1691
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sd_mmc_card/src/at32_sdio.c:408
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1179
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sd_mmc_card/src/at32_sdio.c:798
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: sd_mmc_card/src/at32_sdio.c:179
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sd_mmc_card/src/at32_sdio.c:1021
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1480
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sd_mmc_card/src/at32_sdio.c:2480
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sd_mmc_card/src/at32_sdio.c:2697
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1358
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sd_mmc_card/src/at32_sdio.c:2443
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:70
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1644
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sd_mmc_card/src/at32_sdio.c:194
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1268
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:734
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sdio_fatfs/inc/at32_sdio.h:63
sd_error_status_type
sd_error_status_type
Definition: sdio_fatfs/inc/at32_sdio.h:72
sd_card_state_type
sd_card_state_type
Definition: sdio_fatfs/inc/at32_sdio.h:185
sd_memory_card_type
sd_memory_card_type
Definition: sdio_fatfs/inc/at32_sdio.h:201
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sdio_fatfs/inc/at32_sdio.h:65
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sdio_fatfs/inc/at32_sdio.h:64
SD_ERROR
@ SD_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:116
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: sdio_fatfs/inc/at32_sdio.h:96
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sdio_fatfs/inc/at32_sdio.h:106
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sdio_fatfs/inc/at32_sdio.h:75
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:94
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sdio_fatfs/inc/at32_sdio.h:113
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sdio_fatfs/inc/at32_sdio.h:74
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sdio_fatfs/inc/at32_sdio.h:81
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: sdio_fatfs/inc/at32_sdio.h:115
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:105
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:109
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: sdio_fatfs/inc/at32_sdio.h:85
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:92
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: sdio_fatfs/inc/at32_sdio.h:97
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:91
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: sdio_fatfs/inc/at32_sdio.h:98
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:90
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:93
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sdio_fatfs/inc/at32_sdio.h:114
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:78
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sdio_fatfs/inc/at32_sdio.h:89
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: sdio_fatfs/inc/at32_sdio.h:104
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:88
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: sdio_fatfs/inc/at32_sdio.h:101
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:79
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: sdio_fatfs/inc/at32_sdio.h:111
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sdio_fatfs/inc/at32_sdio.h:112
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:102
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sdio_fatfs/inc/at32_sdio.h:100
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: sdio_fatfs/inc/at32_sdio.h:103
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sdio_fatfs/inc/at32_sdio.h:77
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: sdio_fatfs/inc/at32_sdio.h:82
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:80
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:87
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: sdio_fatfs/inc/at32_sdio.h:110
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: sdio_fatfs/inc/at32_sdio.h:95
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: sdio_fatfs/inc/at32_sdio.h:86
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sdio_fatfs/inc/at32_sdio.h:76
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:83
SD_OK
@ SD_OK
Definition: sdio_fatfs/inc/at32_sdio.h:117
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:84
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:99
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: sdio_fatfs/inc/at32_sdio.h:189
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: sdio_fatfs/inc/at32_sdio.h:187
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: sdio_fatfs/inc/at32_sdio.h:190
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: sdio_fatfs/inc/at32_sdio.h:188
SD_CARD_READY
@ SD_CARD_READY
Definition: sdio_fatfs/inc/at32_sdio.h:186
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: sdio_fatfs/inc/at32_sdio.h:193
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:194
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:210
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:208
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:207
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sdio_fatfs/inc/at32_sdio.h:202
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:206
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sdio_fatfs/inc/at32_sdio.h:203
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:205
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:209
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sdio_fatfs/inc/at32_sdio.h:400
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sdio_fatfs/inc/at32_sdio.h:399
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:235
sd_cid_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:168
sd_csd_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:124
sd_scr_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:217


AT32F413 Firmwary Library: at32_sdio.c Source File

  • sdio
  • sdio_fatfs
  • src
sdio_fatfs/src/at32_sdio.c
Go to the documentation of this file.
1
26#include <string.h>
27#include "at32_sdio.h"
28#include "at32f413_board.h"
29
38 sdio_command_struct_type sdio_command_init_struct;
39 sdio_data_struct_type sdio_data_init_struct;
40
41static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
42static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
43static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
44static uint8_t stop_flag = 0; /* transmit stop flag */
45volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
46volatile uint8_t transfer_end = 0; /* transmit end flag */
47 sd_card_info_struct_type sd_card_info; /* sd card information */
48
49 sd_error_status_type command_error(void);
50 sd_error_status_type command_rsp1_error(uint8_t cmd);
51 sd_error_status_type command_rsp2_error(void);
52 sd_error_status_type command_rsp3_error(void);
53 sd_error_status_type command_rsp4_error(uint8_t cmd);
54 sd_error_status_type command_rsp5_error(uint8_t cmd);
55 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
56 sd_error_status_type command_rsp7_error(void);
57 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
58 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
59 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
60 sd_error_status_type check_card_programming(uint8_t *p_status);
61 sd_error_status_type speed_change(uint8_t speed);
62 sd_error_status_type scr_find(void);
63uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
64
71 sd_error_status_type sd_init(void)
72{
73 uint16_t clkdiv = 0;
74 sd_error_status_type status = SD_OK;
75 gpio_init_type gpio_init_struct = {0};
76 uint8_t retry = 0;
77
78 /* gpioc and gpiod periph clock enable */
79 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
80 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
81
82 /* sdio periph clock enable */
83 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
84
85 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
86 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
87 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
88 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
89 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
90 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
91 gpio_init(GPIOC, &gpio_init_struct);
92
93 /* configure pd.02 cmd line */
94 gpio_init_struct.gpio_pins = GPIO_PINS_2;
95 gpio_init(GPIOD, &gpio_init_struct);
96
97 retry = 3;
98 while(retry--){
99 /* reset sdio */
100 sdio_reset(SDIOx);
101 /* power on */
102 status = sd_power_on();
103
104 if(status == SD_OK)
105 break;
106 }
107
108 if(status == SD_OK)
109 {
110 /* sdio card initialize */
111 status = sd_card_init();
112 }
113
114 if(status == SD_OK)
115 {
116 /* get card information*/
117 status = sd_card_info_get(&sd_card_info);
118 }
119
120 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
121 {
122 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
123 }
124
125 if(status == SD_OK)
126 {
127 /* select card */
128 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
129 }
130
131 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
132 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
133 {
134 status = scr_find();
135 }
136
137 if(status == SD_OK)
138 {
139 /* set normal speed */
140 status = speed_change(0);
141 }
142
143 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
144 {
145 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
146 {
147 /* set sdio_ck to 4mhz */
148 clkdiv = system_core_clock / 4000000;
149
150 if(clkdiv >= 2)
151 {
152 clkdiv -= 2;
153 }
154 }
155 else
156 {
157 /* set sdio_ck to 4mhz */
158 clkdiv = system_core_clock / 4000000;
159
160 if(clkdiv >= 2)
161 {
162 clkdiv -= 2;
163 }
164 }
165 /* set sdio clock divider */
166 sdio_clock_set(clkdiv);
167
168 /* set transfer mode */
169 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
170 }
171
172 if(status == SD_OK)
173 {
174 /* Set data width */
175 status = sd_wide_bus_operation_config(SDIO_BUS_WIDTH_D4);
176 }
177
178 return status;
179}
180
186void sdio_clock_set(uint32_t clk_div)
187{
188 /* config clock divide [7:0] */
189 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
190
191 /* config clock divide [9:8] */
192 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
193}
194
201 sd_error_status_type sd_power_on(void)
202{
203 uint8_t retry = 0;
204 sd_error_status_type status = SD_OK;
205 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
206 uint32_t sd_type = SD_STD_CAPACITY;
207
208 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
209 clk_psc = (system_core_clock / 200000) - 2;
210
211 if(clk_psc > 0x3FF)
212 {
213 clk_psc = 0x3FF;
214 }
215
216 /* config sdio clock divide and edge phase */
217 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
218 /* config sdio bus width */
219 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
220 /* disable flow control */
221 sdio_flow_control_enable(SDIOx, FALSE);
222 /* disable clock bypass */
223 sdio_clock_bypass(SDIOx, FALSE);
224 /* disable power saving mode */
225 sdio_power_saving_mode_enable(SDIOx, FALSE);
226
227 /* sdio power on */
228 sdio_power_set(SDIOx, SDIO_POWER_ON);
229 /* enable to output sdio_ck */
230 sdio_clock_enable(SDIOx, TRUE);
231
232 for(retry = 0; retry < 5; retry++)
233 {
234 /* send cmd0, get in idle stage */
235 sdio_command_init_struct.argument = 0x0;
236 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
237 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
238 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
239
240 /* sdio command config */
241 sdio_command_config(SDIOx, &sdio_command_init_struct);
242 /* enable ccsm */
243 sdio_command_state_machine_enable(SDIOx, TRUE);
244
245 /* get command status */
246 status = command_error();
247 }
248
249 /* send cmd8, check card interface feature */
250 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
251 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
252 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
253 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
254
255 /* sdio command config */
256 sdio_command_config(SDIOx, &sdio_command_init_struct);
257 /* enable ccsm */
258 sdio_command_state_machine_enable(SDIOx, TRUE);
259
260 /* waiting R7 */
261 status = command_rsp7_error();
262
263 if(status == SD_OK)
264 {
265 /* set card type and sd type */
266 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
267 sd_type = SD_HIGH_CAPACITY;
268 }
269
270 /* send cmd55, check sd version */
271 sdio_command_init_struct.argument = 0x00;
272 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
273 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
274 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
275
276 /* sdio command config */
277 sdio_command_config(SDIOx, &sdio_command_init_struct);
278 /* enable ccsm */
279 sdio_command_state_machine_enable(SDIOx, TRUE);
280
281 /* waiting R1 */
282 status = command_rsp1_error(SD_CMD_APP_CMD);
283
284 /* check sd card or mmc card */
285 if(SD_OK == status)
286 {
287 /* send acmd41, check voltage operation range */
288 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
289 {
290 delay_ms(10);
291
292 /* send cmd55 before acmd41 */
293 sdio_command_init_struct.argument = 0x00;
294 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
295 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
296 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
297
298 /* sdio command config */
299 sdio_command_config(SDIOx, &sdio_command_init_struct);
300 /* enable ccsm */
301 sdio_command_state_machine_enable(SDIOx, TRUE);
302
303 /* waiting R1 */
304 status = command_rsp1_error(SD_CMD_APP_CMD);
305
306 /* if any errors occured, return status */
307 if(status != SD_OK)
308 {
309 return status;
310 }
311
312 /* send acmd41 */
313 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
314 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
315 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
316 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
317
318 /* sdio command config */
319 sdio_command_config(SDIOx, &sdio_command_init_struct);
320 /* enable ccsm */
321 sdio_command_state_machine_enable(SDIOx, TRUE);
322
323 /* waiting R3 */
324 status = command_rsp3_error();
325
326 /* if any errors occured, return status */
327 if(status != SD_OK)
328 {
329 return status;
330 }
331
332 /* get response1 */
333 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
334
335 /* check sd card power on stage is success or not */
336 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
337 count++;
338 }
339
340 if(count >= SD_MAX_VOLT_TRIAL)
341 {
342 status = SD_INVALID_VOLTRANGE;
343 return status;
344 }
345
346 if(response &= SD_HIGH_CAPACITY)
347 {
348 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
349 }
350 }
351 /* mmc card */
352 else
353 {
354 /* send cmd1 */
355 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
356 {
357 delay_ms(10);
358
359 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
360 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
361 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
362 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
363
364 /* sdio command config */
365 sdio_command_config(SDIOx, &sdio_command_init_struct);
366 /* enable ccsm */
367 sdio_command_state_machine_enable(SDIOx, TRUE);
368
369 /* waiting R3 */
370 status = command_rsp3_error();
371
372 if(status != SD_OK)
373 {
374 return status;
375 }
376
377 /* get response1 */
378 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
379
380 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
381 count++;
382 }
383
384 if(count >= SD_MAX_VOLT_TRIAL)
385 {
386 status = SD_INVALID_VOLTRANGE;
387 return status;
388 }
389
390 card_type = SDIO_MULTIMEDIA_CARD;
391 }
392
393 return(status);
394}
395
401 sd_error_status_type sd_power_off(void)
402{
403 /* sdio power off */
404 sdio_power_set(SDIOx, SDIO_POWER_OFF);
405
406 return SD_OK;
407}
408
415 sd_error_status_type sd_card_init(void)
416{
417 sd_error_status_type status = SD_OK;
418 uint16_t rca_temp = 0x01;
419
420 /* check power status */
421 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
422 {
423 return SD_REQ_NOT_APPLICABLE;
424 }
425
426 /* check is secure_digital_io_card or not */
427 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
428 {
429 /* send cmd2, get cid register */
430 sdio_command_init_struct.argument = 0x0;
431 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
432 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
433 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
434
435 /* sdio command config */
436 sdio_command_config(SDIOx, &sdio_command_init_struct);
437 /* enable ccsm */
438 sdio_command_state_machine_enable(SDIOx, TRUE);
439
440 status = command_rsp2_error();
441 if(status != SD_OK)
442 {
443 return status;
444 }
445
446 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
447 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
448 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
449 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
450 }
451
452 /* check card type */
453 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
454 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
455 {
456 /* send cmd3, get rca */
457 sdio_command_init_struct.argument = 0x00;
458 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
459 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
460 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
461
462 /* sdio command config */
463 sdio_command_config(SDIOx, &sdio_command_init_struct);
464 /* enable ccsm */
465 sdio_command_state_machine_enable(SDIOx, TRUE);
466
467 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
468 if(status != SD_OK)
469 {
470 return status;
471 }
472 }
473
474 /* mmc card */
475 if(card_type == SDIO_MULTIMEDIA_CARD)
476 {
477 /* send cmd3 */
478 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
479 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
480 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
481 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
482
483 /* sdio command config */
484 sdio_command_config(SDIOx, &sdio_command_init_struct);
485 /* enable ccsm */
486 sdio_command_state_machine_enable(SDIOx, TRUE);
487
488 status = command_rsp2_error();
489 if(status != SD_OK)
490 {
491 return status;
492 }
493 }
494
495 /* check is secure_digital_io_card or not */
496 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
497 {
498 rca = rca_temp;
499 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
500 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
501 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
502 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
503
504 /* sdio command config */
505 sdio_command_config(SDIOx, &sdio_command_init_struct);
506 /* enable ccsm */
507 sdio_command_state_machine_enable(SDIOx, TRUE);
508
509 status = command_rsp2_error();
510 if(status != SD_OK)
511 {
512 return status;
513 }
514
515 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
516 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
517 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
518 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
519 }
520
521 return SD_OK;
522}
523
530 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
531{
532 sd_error_status_type status = SD_OK;
533 uint8_t tmp = 0;
534
535 card_info->card_type = (uint8_t)card_type;
536 card_info->rca = (uint16_t)rca;
537
538 /* byte 0 */
539 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
540 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
541 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
542 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
543
544 /* byte 1 */
545 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
546 card_info->sd_csd_reg.taac = tmp;
547
548 /* byte 2 */
549 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
550 card_info->sd_csd_reg.nsac = tmp;
551
552 /* byte 3 */
553 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
554 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
555
556 /* byte 4 */
557 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
558 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
559
560 /* byte 5 */
561 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
562 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
563 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
564
565 /* byte 6 */
566 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
567 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
568 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
569 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
570 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
571 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
572
573 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
574 {
575 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
576
577 /* byte 7 */
578 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
579 card_info->sd_csd_reg.device_size |= (tmp) << 2;
580
581 /* byte 8 */
582 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
583 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
584
585 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
586 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
587
588 /* byte 9 */
589 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
590 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
591 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
592 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
593 /* byte 10 */
594 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
595 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
596
597 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
598 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
599 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
600 card_info->card_capacity *= card_info->card_blk_size;
601 }
602 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
603 {
604 /* byte 7 */
605 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
606 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
607
608 /* byte 8 */
609 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
610
611 card_info->sd_csd_reg.device_size |= (tmp << 8);
612
613 /* byte 9 */
614 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
615
616 card_info->sd_csd_reg.device_size |= (tmp);
617
618 /* byte 10 */
619 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
620
621 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
622 card_info->card_blk_size = 512;
623 }
624
625
626 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
627 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
628
629 /* byte 11 */
630 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
631 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
632 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
633
634 /* byte 12 */
635 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
636 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
637 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
638 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
639 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
640
641 /* byte 13 */
642 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
643 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
644 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
645 card_info->sd_csd_reg.reserved3 = 0;
646 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
647
648 /* byte 14 */
649 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
650 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
651 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
652 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
653 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
654 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
655 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
656
657 /* byte 15 */
658 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
659 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
660 card_info->sd_csd_reg.reserved4 = 1;
661
662 /* byte 0 */
663 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
664 card_info->sd_cid_reg.manufacturer_id = tmp;
665
666 /* byte 1 */
667 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
668 card_info->sd_cid_reg.oem_app_id = tmp << 8;
669
670 /* byte 2 */
671 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
672 card_info->sd_cid_reg.oem_app_id |= tmp;
673
674 /* byte 3 */
675 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
676 card_info->sd_cid_reg.product_name1 = tmp << 24;
677
678 /* byte 4 */
679 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
680 card_info->sd_cid_reg.product_name1 |= tmp << 16;
681
682 /* byte 5 */
683 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
684 card_info->sd_cid_reg.product_name1 |= tmp << 8;
685
686 /* byte 6 */
687 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
688 card_info->sd_cid_reg.product_name1 |= tmp;
689
690 /* byte 7 */
691 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
692 card_info->sd_cid_reg.product_name2 = tmp;
693
694 /* byte 8 */
695 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
696 card_info->sd_cid_reg.product_reversion = tmp;
697
698 /* byte 9 */
699 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
700 card_info->sd_cid_reg.product_sn = tmp << 24;
701
702 /* byte 10 */
703 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
704 card_info->sd_cid_reg.product_sn |= tmp << 16;
705
706 /* byte 11 */
707 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
708 card_info->sd_cid_reg.product_sn |= tmp << 8;
709
710 /* byte 12 */
711 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
712 card_info->sd_cid_reg.product_sn |= tmp;
713
714 /* byte 13 */
715 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
716 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
717 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
718
719 /* byte 14 */
720 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
721 card_info->sd_cid_reg.manufact_date |= tmp;
722
723 /* byte 15 */
724 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
725 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
726 card_info->sd_cid_reg.reserved2 = 1;
727
728 return(status);
729}
730
741 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
742{
743 sd_error_status_type status = SD_OK;
744
745 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
746 {
747 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
748 }
749 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
750 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
751 {
752 if(mode >= 2)
753 {
754 /* not support D8 mode */
755 return SD_UNSUPPORTED_FEATURE;
756 }
757
758 if(SDIO_BUS_WIDTH_D4 == mode)
759 {
760 status = sd_bus_wide_enable(TRUE);
761 }
762 else
763 {
764 status = sd_bus_wide_enable(FALSE);
765 }
766 }
767
768 if(status == SD_OK)
769 {
770 sdio_bus_width_config(SDIOx, mode);
771 }
772
773 return status;
774}
775
784 sd_error_status_type sd_device_mode_set(uint32_t mode)
785{
786 sd_error_status_type status = SD_OK;
787
788 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
789 {
790 device_mode = (sd_data_transfer_mode_type)mode;
791 }
792 else
793 {
794 status = SD_INVALID_PARAMETER;
795 }
796
797 return status;
798}
799
805 sd_error_status_type sd_deselect_select(uint32_t addr)
806{
807 /* send cmd7, select card */
808 sdio_command_init_struct.argument = addr;
809 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
810 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
811 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
812
813 /* sdio command config */
814 sdio_command_config(SDIOx, &sdio_command_init_struct);
815 /* enable ccsm */
816 sdio_command_state_machine_enable(SDIOx, TRUE);
817
818 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
819}
820
828 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
829 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
830{
831 sd_error_status_type status = SD_OK;
832 uint32_t count = 0;
833 uint32_t timeout = SDIO_DATATIMEOUT;
834 uint32_t length = 0;
835
836 if(buf == NULL)
837 {
838 return SD_INVALID_PARAMETER;
839 }
840 /* clear dtctrl register */
841 SDIOx->dtcnt = 0x0;
842
843 /* sdio command config */
844 sdio_data_config(SDIOx, sdio_data_init_t);
845 /* enable dcsm */
846 sdio_data_state_machine_enable(SDIOx, TRUE);
847
848 length = sdio_data_init_t->data_length;
849
850 if(device_mode == SD_TRANSFER_DMA_MODE)
851 {
852 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
853 {
854 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
855 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
856 transfer_error = SD_OK;
857 transfer_end = 0;
858 sdio_dma_enable(SDIOx, TRUE);
859 }
860 }
861
862 /* sdio command config */
863 sdio_command_config(SDIOx, sdio_cmd_init_t);
864 /* enable ccsm */
865 sdio_command_state_machine_enable(SDIOx, TRUE);
866
867 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
868 if(status != SD_OK)
869 {
870 return status;
871 }
872
873 /* polling mode */
874 if(device_mode == SD_TRANSFER_POLLING_MODE)
875 {
876 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
877 {
878 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
879 {
880 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
881 {
882 for(count = 0; count < 8; count++, buf++)
883 {
884 *buf = sdio_data_read(SDIOx);
885 }
886
887 timeout = 0x7FFFFF;
888 }
889 else
890 {
891 if(0 == timeout)
892 {
893 sd_init();
894 return SD_DATA_TIMEOUT;
895 }
896
897 timeout--;
898 }
899 }
900
901 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
902 {
903 *buf = sdio_data_read(SDIOx);
904 buf++;
905 }
906 }
907 else
908 {
909 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
910 {
911 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
912 {
913 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
914 {
915 sdio_data_write(SDIOx, *buf);
916 }
917
918 timeout = 0x3FFFFFFF;
919 }
920 else
921 {
922 if(timeout == 0)
923 {
924 sd_init();
925 return SD_DATA_TIMEOUT;
926 }
927
928 timeout--;
929 }
930 }
931 }
932 /* data timeout */
933 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
934 {
935 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
936 return SD_DATA_TIMEOUT;
937 }
938 /* crc error */
939 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
940 {
941 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
942 return SD_DATA_FAIL;
943 }
944 /* over run error */
945 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
946 {
947 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
948 return SD_RX_OVERRUN;
949 }
950 /* under run error */
951 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
952 {
953 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
954 return SD_TX_UNDERRUN;
955 }
956 /* start bit error */
957 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
958 {
959 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
960 return SD_START_BIT_ERR;
961 }
962 /* data transfer complete */
963 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
964 {
965 /* send cmd12, stop transmission */
966 sdio_cmd_init_t->argument = 0;
967 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
968 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
969 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
970
971 /* sdio command config */
972 sdio_command_config(SDIOx, sdio_cmd_init_t);
973 /* enable ccsm */
974 sdio_command_state_machine_enable(SDIOx, TRUE);
975
976 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
977
978 if(status != SD_OK)
979 {
980 return status;
981 }
982 }
983
984 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
985 }
986 else if(device_mode == SD_TRANSFER_DMA_MODE)
987 {
988 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
989 {
990 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
991 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
992 transfer_error = SD_OK;
993 transfer_end = 0;
994 sdio_dma_enable(SDIOx, TRUE);
995 }
996
997 while(!(SDIOx->sts & SDIOx->inten) && timeout)
998 {
999 timeout--;
1000
1001 if(transfer_end)
1002 {
1003 break;
1004 }
1005 }
1006
1007 if(timeout == 0)
1008 {
1009 sd_init();
1010 return SD_DATA_TIMEOUT;
1011 }
1012
1013 if(transfer_error != SD_OK)
1014 {
1015 status = transfer_error;
1016 }
1017 }
1018
1019 return status;
1020}
1021
1028 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1029{
1030 sd_error_status_type status = SD_OK;
1031 uint32_t start_addr = 0, end_addr = 0, response = 0;
1032 uint8_t card_state;
1033
1034 /* high capacity sd card */
1035 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1036 {
1037 start_addr = addr >> 9;
1038 end_addr = start_addr + nblks - 1;
1039 }
1040 else
1041 {
1042 start_addr = addr;
1043 end_addr = start_addr + (nblks - 1) * 512;
1044 }
1045
1046 /* clear dcsm configuration */
1047 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1048 sdio_data_init_struct.data_length = 0 ;
1049 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1050 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1051 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1052
1053 sdio_data_config(SDIOx, &sdio_data_init_struct);
1054 sdio_data_state_machine_enable(SDIOx, FALSE);
1055
1056 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1057
1058 /* check card locked */
1059 if(response & SD_CARD_LOCKED)
1060 {
1061 return SD_LOCK_UNLOCK_ERROR;
1062 }
1063
1064 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1065 {
1066 /* send cmd35, set erase group start */
1067 sdio_command_init_struct.argument = start_addr;
1068 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1069 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1070 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1071
1072 /* sdio command config */
1073 sdio_command_config(SDIOx, &sdio_command_init_struct);
1074 /* enable ccsm */
1075 sdio_command_state_machine_enable(SDIOx, TRUE);
1076
1077 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1078
1079 if(status != SD_OK)
1080 {
1081 return status;
1082 }
1083
1084 /* send cmd36, set erase group end */
1085 sdio_command_init_struct.argument = end_addr;
1086 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1087
1088 /* sdio command config */
1089 sdio_command_config(SDIOx, &sdio_command_init_struct);
1090 /* enable ccsm */
1091 sdio_command_state_machine_enable(SDIOx, TRUE);
1092
1093 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1094
1095 if(status != SD_OK)
1096 {
1097 return status;
1098 }
1099
1100 /* send cmd38, start erase gourp */
1101 sdio_command_init_struct.argument = 0;
1102 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1103
1104 /* sdio command config */
1105 sdio_command_config(SDIOx, &sdio_command_init_struct);
1106 /* enable ccsm */
1107 sdio_command_state_machine_enable(SDIOx, TRUE);
1108
1109 status = command_rsp1_error(SD_CMD_ERASE);
1110
1111 if(status != SD_OK)
1112 {
1113 return status;
1114 }
1115 }
1116 else
1117 {
1118 /* send cmd32, set erase block start */
1119 sdio_command_init_struct.argument = start_addr;
1120 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1121 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1122 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1123
1124 /* sdio command config */
1125 sdio_command_config(SDIOx, &sdio_command_init_struct);
1126 /* enable ccsm */
1127 sdio_command_state_machine_enable(SDIOx, TRUE);
1128
1129 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1130
1131 if(status != SD_OK)
1132 {
1133 return status;
1134 }
1135
1136 /* send cmd33, set erase block end */
1137 sdio_command_init_struct.argument = end_addr;
1138 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1139
1140 /* sdio command config */
1141 sdio_command_config(SDIOx, &sdio_command_init_struct);
1142 /* enable ccsm */
1143 sdio_command_state_machine_enable(SDIOx, TRUE);
1144
1145 if(status != SD_OK)
1146 {
1147 return status;
1148 }
1149
1150 /* send cmd38, start erase block */
1151 sdio_command_init_struct.argument = 0;
1152 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1153
1154 /* sdio command config */
1155 sdio_command_config(SDIOx, &sdio_command_init_struct);
1156 /* enable ccsm */
1157 sdio_command_state_machine_enable(SDIOx, TRUE);
1158
1159 status = command_rsp1_error(SD_CMD_ERASE);
1160
1161 if(status != SD_OK)
1162 {
1163 return status;
1164 }
1165 }
1166
1167 status = check_card_programming(&card_state);
1168
1169 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1170 (card_state == SD_CARD_RECEIVING)))
1171 {
1172 status = check_card_programming(&card_state);
1173 }
1174
1175 return status;
1176}
1177
1186 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1187{
1188 sd_error_status_type status = SD_OK;
1189 uint32_t response = 0;
1190 uint8_t power;
1191
1192 if(NULL == buf)
1193 {
1194 return SD_INVALID_PARAMETER;
1195 }
1196
1197 SDIOx->dtctrl = 0x0;
1198
1199 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1200 {
1201 blk_size = 512;
1202 addr >>= 9;
1203 }
1204
1205 /* clear dcsm configuration */
1206 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1207 sdio_data_init_struct.data_length = 0;
1208 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1209 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1210 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1211
1212 sdio_data_config(SDIOx, &sdio_data_init_struct);
1213 sdio_data_state_machine_enable(SDIOx, FALSE);
1214
1215 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1216
1217 /* check card locked */
1218 if(response & SD_CARD_LOCKED)
1219 {
1220 return SD_LOCK_UNLOCK_ERROR;
1221 }
1222
1223 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1224 {
1225 power = convert_from_bytes_to_power_of_two(blk_size);
1226
1227 /* send cmd16, set block size */
1228 sdio_command_init_struct.argument = blk_size;
1229 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1230 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1231 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1232
1233 /* sdio command config */
1234 sdio_command_config(SDIOx, &sdio_command_init_struct);
1235 /* enable ccsm */
1236 sdio_command_state_machine_enable(SDIOx, TRUE);
1237
1238 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1239
1240 if(status != SD_OK)
1241 {
1242 return status;
1243 }
1244 }
1245 else
1246 {
1247 return SD_INVALID_PARAMETER;
1248 }
1249
1250 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1251 sdio_data_init_struct.data_length = blk_size ;
1252 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1253 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1254 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1255
1256 sdio_command_init_struct.argument = addr;
1257 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1258 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1259 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1260
1261 stop_flag = 0;
1262
1263 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1264}
1265
1275 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1276{
1277 sd_error_status_type status = SD_OK;
1278 uint32_t response = 0;
1279 uint8_t power;
1280
1281 SDIOx->dtctrl = 0x0;
1282
1283 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1284 {
1285 blk_size = 512;
1286 addr >>= 9;
1287 }
1288
1289 /* clear dcsm configuration */
1290 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1291 sdio_data_init_struct.data_length = 0;
1292 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1293 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1294 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1295
1296 sdio_data_config(SDIOx, &sdio_data_init_struct);
1297 sdio_data_state_machine_enable(SDIOx, FALSE);
1298
1299 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1300
1301 /* check card locked */
1302 if(response & SD_CARD_LOCKED)
1303 {
1304 return SD_LOCK_UNLOCK_ERROR;
1305 }
1306
1307 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1308 {
1309 power = convert_from_bytes_to_power_of_two(blk_size);
1310
1311 /* send cmd16, set block size */
1312 sdio_command_init_struct.argument = blk_size;
1313 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1314 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1315 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1316
1317 /* sdio command config */
1318 sdio_command_config(SDIOx, &sdio_command_init_struct);
1319 /* enable ccsm */
1320 sdio_command_state_machine_enable(SDIOx, TRUE);
1321
1322 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1323
1324 if(status != SD_OK)
1325 {
1326 return status;
1327 }
1328 }
1329 else
1330 {
1331 return SD_INVALID_PARAMETER;
1332 }
1333
1334 /* check max receive length */
1335 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1336 {
1337 return SD_INVALID_PARAMETER;
1338 }
1339
1340 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1341 sdio_data_init_struct.data_length = nblks * blk_size ;
1342 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1343 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1344 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1345
1346 /* send cmd18, read block data */
1347 sdio_command_init_struct.argument = addr;
1348 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1349 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1350 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1351
1352 stop_flag = 1;
1353
1354 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1355}
1356
1365 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1366{
1367 sd_error_status_type status = SD_OK;
1368 uint8_t power = 0, card_state = 0;
1369 uint32_t timeout = 0, card_status = 0, response = 0;
1370
1371 if(buf == NULL)
1372 {
1373 return SD_INVALID_PARAMETER;
1374 }
1375
1376 SDIOx->dtctrl = 0x0;
1377
1378 /* clear dcsm configuration */
1379 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1380 sdio_data_init_struct.data_length = 0;
1381 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1382 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1383 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1384
1385 sdio_data_config(SDIOx, &sdio_data_init_struct);
1386 sdio_data_state_machine_enable(SDIOx, FALSE);
1387
1388 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1389
1390 /* check card locked */
1391 if(response & SD_CARD_LOCKED)
1392 {
1393 return SD_LOCK_UNLOCK_ERROR;
1394 }
1395
1396 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1397 {
1398 blk_size = 512;
1399 addr >>= 9;
1400 }
1401
1402 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1403 {
1404 power = convert_from_bytes_to_power_of_two(blk_size);
1405
1406 /* send cmd16, set block size */
1407 sdio_command_init_struct.argument = blk_size;
1408 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1409 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1410 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1411
1412 /* sdio command config */
1413 sdio_command_config(SDIOx, &sdio_command_init_struct);
1414 /* enable ccsm */
1415 sdio_command_state_machine_enable(SDIOx, TRUE);
1416
1417 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1418
1419 if(status != SD_OK)
1420 {
1421 return status;
1422 }
1423 }
1424 else
1425 {
1426 return SD_INVALID_PARAMETER;
1427 }
1428
1429 timeout = SD_DATATIMEOUT;
1430
1431 do
1432 {
1433 timeout--;
1434 status = sd_status_send(&card_status);
1435 }
1436 /* check ready_for_data flag */
1437 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1438
1439 if(timeout == 0)
1440 {
1441 return SD_ERROR;
1442 }
1443
1444 /* send cmd24, write single block */
1445 sdio_command_init_struct.argument = addr;
1446 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1447 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1448 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1449
1450 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1451 sdio_data_init_struct.data_length = blk_size;
1452 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1453 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1454 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1455
1456 stop_flag = 0;
1457
1458 /* single block, stop command is unnecessary */
1459 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1460
1461 if(status != SD_OK)
1462 {
1463 return status;
1464 }
1465
1466 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1467
1468 status = check_card_programming(&card_state);
1469
1470 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1471 {
1472 status = check_card_programming(&card_state);
1473 }
1474
1475 return status;
1476}
1477
1487 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1488{
1489 sd_error_status_type status = SD_OK;
1490 uint8_t power = 0, card_state = 0;
1491 uint32_t timeout = 0, card_status = 0, response = 0;;
1492
1493 if(buf == NULL)
1494 {
1495 return SD_INVALID_PARAMETER;
1496 }
1497
1498 SDIOx->dtctrl = 0x0;
1499
1500 /* clear dcsm configuration */
1501 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1502 sdio_data_init_struct.data_length = 0;
1503 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1504 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1505 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1506
1507 sdio_data_config(SDIOx, &sdio_data_init_struct);
1508 sdio_data_state_machine_enable(SDIOx, FALSE);
1509
1510 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1511
1512 /* check card locked */
1513 if(response & SD_CARD_LOCKED)
1514 {
1515 return SD_LOCK_UNLOCK_ERROR;
1516 }
1517
1518 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1519 {
1520 blk_size = 512;
1521 addr >>= 9;
1522 }
1523
1524 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1525 {
1526 power = convert_from_bytes_to_power_of_two(blk_size);
1527
1528 /* send cmd16, set block size */
1529 sdio_command_init_struct.argument = blk_size;
1530 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1531 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1532 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1533
1534 /* sdio command config */
1535 sdio_command_config(SDIOx, &sdio_command_init_struct);
1536 /* enable ccsm */
1537 sdio_command_state_machine_enable(SDIOx, TRUE);
1538
1539 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1540
1541 if(status != SD_OK)
1542 {
1543 return status;
1544 }
1545 }
1546 else
1547 {
1548 return SD_INVALID_PARAMETER;
1549 }
1550
1551 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1552 {
1553 return SD_INVALID_PARAMETER;
1554 }
1555
1556 timeout = SD_DATATIMEOUT;
1557
1558 do
1559 {
1560 timeout--;
1561 status = sd_status_send(&card_status);
1562 }
1563 /* check ready_for_data flag */
1564 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1565
1566 if(timeout == 0)
1567 {
1568 return SD_ERROR;
1569 }
1570
1571 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1572 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1573 {
1574 /* send cmd55 */
1575 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1576 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1577 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1578 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1579
1580 /* sdio command config */
1581 sdio_command_config(SDIOx, &sdio_command_init_struct);
1582 /* enable ccsm */
1583 sdio_command_state_machine_enable(SDIOx, TRUE);
1584
1585 status = command_rsp1_error(SD_CMD_APP_CMD);
1586
1587 if(status != SD_OK)
1588 {
1589 return status;
1590 }
1591
1592 /* send cmd23, set block count */
1593 sdio_command_init_struct.argument = blk_size;
1594 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1595 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1596 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1597
1598 /* sdio command config */
1599 sdio_command_config(SDIOx, &sdio_command_init_struct);
1600 /* enable ccsm */
1601 sdio_command_state_machine_enable(SDIOx, TRUE);
1602
1603 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1604
1605 if(status != SD_OK)
1606 {
1607 return status;
1608 }
1609 }
1610
1611 /* send cmd25, write mult blocks */
1612 sdio_command_init_struct.argument = addr;
1613 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1614 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1615 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1616
1617 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1618 sdio_data_init_struct.data_length = nblks * blk_size ;
1619 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1620 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1621 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1622
1623 stop_flag = 1;
1624 /* cmd12 is needed */
1625 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1626
1627 if(status != SD_OK)
1628 {
1629 return status;
1630 }
1631
1632 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1633
1634 status = check_card_programming(&card_state);
1635
1636 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1637 {
1638 status = check_card_programming(&card_state);
1639 }
1640
1641 return status;
1642}
1643
1651 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1652{
1653 uint32_t response = 0;
1654
1655 SDIOx->dtctrl = 0x0;
1656
1657 /* clear dcsm configuration */
1658 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1659 sdio_data_init_struct.data_length = 0 ;
1660 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1661 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1662 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1663
1664 sdio_data_config(SDIOx, &sdio_data_init_struct);
1665 sdio_data_state_machine_enable(SDIOx, FALSE);
1666
1667 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1668
1669 /* check card locked */
1670 if(response & SD_CARD_LOCKED)
1671 {
1672 return SD_LOCK_UNLOCK_ERROR;
1673 }
1674 /* send cmd11, read data */
1675 sdio_command_init_struct.argument = addr;
1676 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1677 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1678 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1679
1680 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1681 sdio_data_init_struct.data_length = len;
1682 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1683 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1684 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1685
1686 stop_flag = 1;
1687 /* cmd12 is needed */
1688 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1689}
1690
1698 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1699{
1700 sd_error_status_type status = SD_OK;
1701 uint32_t response = 0;
1702 uint8_t card_state = 0;
1703
1704 if(buf == NULL)
1705 {
1706 return SD_INVALID_PARAMETER;
1707 }
1708
1709 SDIOx->dtctrl = 0x0;
1710
1711 /* clear dcsm configuration */
1712 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1713 sdio_data_init_struct.data_length = 0;
1714 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1715 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1716 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1717
1718 sdio_data_config(SDIOx, &sdio_data_init_struct);
1719 sdio_data_state_machine_enable(SDIOx, FALSE);
1720
1721 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1722
1723 /* check card locked */
1724 if(response & SD_CARD_LOCKED)
1725 {
1726 return SD_LOCK_UNLOCK_ERROR;
1727 }
1728 /* send cmd20, write data */
1729 sdio_command_init_struct.argument = addr;
1730 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1731 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1732 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1733
1734
1735 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1736 sdio_data_init_struct.data_length = len;
1737 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1738 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1739 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1740
1741 stop_flag = 1;
1742 /* cmd12 is needed */
1743 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1744
1745 if(status != SD_OK)
1746 {
1747 return status;
1748 }
1749
1750 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1751
1752 status = check_card_programming(&card_state);
1753
1754 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1755 {
1756 status = check_card_programming(&card_state);
1757 }
1758
1759 return status;
1760}
1761
1767void SDIO1_IRQHandler(void)
1768{
1769 sd_irq_service();
1770}
1771
1777void SDIO2_IRQHandler(void)
1778{
1779 sd_irq_service();
1780}
1781
1787 sd_error_status_type sd_irq_service(void)
1788{
1789 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1790 {
1791 if(stop_flag == 1)
1792 {
1793 /* send cmd12, stop transmission */
1794 sdio_command_init_struct.argument = 0;
1795 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1796 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1797 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1798 /* sdio command config */
1799 sdio_command_config(SDIOx, &sdio_command_init_struct);
1800 /* enable ccsm */
1801 sdio_command_state_machine_enable(SDIOx, TRUE);
1802 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1803 }
1804 else
1805 {
1806 transfer_error = SD_OK;
1807 }
1808 /* clear flag */
1809 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1810 transfer_end = 1;
1811 return transfer_error;
1812 }
1813
1814 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1815 {
1816 /* clear flag */
1817 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1818 transfer_error = SD_DATA_FAIL;
1819 transfer_end = 1;
1820 return transfer_error;
1821 }
1822
1823 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1824 {
1825 /* clear flag */
1826 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1827 transfer_error = SD_DATA_TIMEOUT;
1828 transfer_end = 1;
1829 return transfer_error;
1830 }
1831
1832 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1833 {
1834 /* clear flag */
1835 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1836 transfer_error = SD_RX_OVERRUN;
1837 transfer_end = 1;
1838 return(SD_RX_OVERRUN);
1839 }
1840
1841 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1842 {
1843 /* clear flag */
1844 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1845 transfer_error = SD_TX_UNDERRUN;
1846 transfer_end = 1;
1847 return(SD_TX_UNDERRUN);
1848 }
1849
1850 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1851 {
1852 /* clear flag */
1853 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1854 transfer_error = SD_START_BIT_ERR;
1855 transfer_end = 1;
1856 return(SD_START_BIT_ERR);
1857 }
1858
1859 /* disable interrupt */
1860 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1861 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1862 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1863 return(SD_OK);
1864}
1865
1871 sd_error_status_type command_error(void)
1872{
1873 sd_error_status_type status = SD_OK;
1874 uint32_t timeout = SDIO_CMD0TIMEOUT;
1875
1876 while(timeout--)
1877 {
1878 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1879 {
1880 break;
1881 }
1882 }
1883
1884 if(timeout == 0)
1885 {
1886 return SD_CMD_RSP_TIMEOUT;
1887 }
1888
1889 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1890 return status;
1891}
1892
1898 sd_error_status_type command_rsp7_error(void)
1899{
1900 sd_error_status_type status = SD_OK;
1901 uint32_t sts_reg = 0;
1902 uint32_t timeout = SDIO_CMD0TIMEOUT;
1903
1904 while(timeout--)
1905 {
1906 sts_reg = SDIOx->sts;
1907
1908 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1909 {
1910 break;
1911 }
1912 }
1913
1914 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1915 {
1916 status = SD_CMD_RSP_TIMEOUT;
1917 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1918 return status;
1919 }
1920
1921 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1922 {
1923 status = SD_OK;
1924 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1925 }
1926
1927 return status;
1928}
1929
1935 sd_error_status_type command_rsp1_error(uint8_t cmd)
1936{
1937 uint32_t sts_reg = 0;
1938 uint32_t rsp_cmd = 0;
1939
1940 while(1)
1941 {
1942 sts_reg = SDIOx->sts;
1943
1944 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1945 {
1946 break;
1947 }
1948 }
1949
1950 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1951 {
1952 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1953 return SD_CMD_RSP_TIMEOUT;
1954 }
1955
1956 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1957 {
1958 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1959 return SD_CMD_FAIL;
1960 }
1961
1962 rsp_cmd = sdio_command_response_get(SDIOx);
1963 if(rsp_cmd != cmd)
1964 {
1965 return SD_ILLEGAL_CMD;
1966 }
1967
1968 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1969
1970 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1971}
1972
1978 sd_error_status_type command_rsp3_error(void)
1979{
1980 uint32_t sts_reg = 0;;
1981
1982 while(1)
1983 {
1984 sts_reg = SDIOx->sts;
1985
1986 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1987 {
1988 break;
1989 }
1990 }
1991
1992 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1993 {
1994 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1995 return SD_CMD_RSP_TIMEOUT;
1996 }
1997
1998 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1999
2000 return SD_OK;
2001}
2002
2008 sd_error_status_type command_rsp2_error(void)
2009{
2010 sd_error_status_type status = SD_OK;
2011 uint32_t sts_reg;
2012 uint32_t timeout = SDIO_CMD0TIMEOUT;
2013
2014 while(timeout--)
2015 {
2016 sts_reg = SDIOx->sts;
2017
2018 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2019 {
2020 break;
2021 }
2022 }
2023
2024 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2025 {
2026 status = SD_CMD_RSP_TIMEOUT;
2027 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2028
2029 return status;
2030 }
2031
2032 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2033 {
2034 status = SD_CMD_FAIL;
2035 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2036 }
2037
2038 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2039
2040 return status;
2041}
2042
2048 sd_error_status_type command_rsp4_error(uint8_t cmd)
2049{
2050 uint32_t sts_reg = 0, rsp_cmd = 0;
2051
2052 while(1)
2053 {
2054 sts_reg = SDIOx->sts;
2055
2056 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2057 {
2058 break;
2059 }
2060 }
2061
2062 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2063 {
2064 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2065 return SD_CMD_RSP_TIMEOUT;
2066 }
2067
2068 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2069 {
2070 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2071
2072 return SD_CMD_FAIL;
2073 }
2074
2075 rsp_cmd = sdio_command_response_get(SDIOx);
2076 if(rsp_cmd != cmd)
2077 {
2078 return SD_ILLEGAL_CMD;
2079 }
2080
2081 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2082
2083 return SD_OK;
2084}
2085
2091 sd_error_status_type command_rsp5_error(uint8_t cmd)
2092{
2093 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2094
2095 while(1)
2096 {
2097 sts_reg = SDIOx->sts;
2098
2099 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2100 {
2101 break;
2102 }
2103 }
2104
2105 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2106 {
2107 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2108
2109 return SD_CMD_RSP_TIMEOUT;
2110 }
2111
2112 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2113 {
2114 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2115
2116 return SD_CMD_FAIL;
2117 }
2118
2119 rsp_cmd = sdio_command_response_get(SDIOx);
2120 if(rsp_cmd != cmd)
2121 {
2122 return SD_ILLEGAL_CMD;
2123 }
2124
2125 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2126
2127 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2128
2129 if(response & SD_R5_OUT_OF_RANGE)
2130 {
2131 return SD_CMD_OUT_OF_RANGE;
2132 }
2133
2134 if(response & SD_R5_FUNCTION_NUMBER)
2135 {
2136 return SD_SDIO_UNKNOWN_FUNC;
2137 }
2138
2139 if(response & SD_R5_ERROR)
2140 {
2141 return SD_GENERAL_UNKNOWN_ERROR;
2142 }
2143
2144 return SD_OK;
2145}
2146
2154 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2155{
2156 sd_error_status_type status = SD_OK;
2157 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2158
2159 while(1)
2160 {
2161 sts_reg = SDIOx->sts;
2162
2163 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2164 {
2165 break;
2166 }
2167 }
2168
2169 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2170 {
2171 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2172 return SD_CMD_RSP_TIMEOUT;
2173 }
2174
2175 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2176 {
2177 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2178 return SD_CMD_FAIL;
2179 }
2180
2181 rsp_cmd = sdio_command_response_get(SDIOx);
2182 if(rsp_cmd != cmd)
2183 {
2184 return SD_ILLEGAL_CMD;
2185 }
2186
2187 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2188
2189 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2190
2191 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2192 {
2193 *prca = (uint16_t)(response >> 16);
2194 return status;
2195 }
2196
2197 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2198 {
2199 return SD_GENERAL_UNKNOWN_ERROR;
2200 }
2201
2202 if(response & SD_R6_ILLEGAL_CMD)
2203 {
2204 return SD_ILLEGAL_CMD;
2205 }
2206
2207 if(response & SD_R6_CMD_CRC_ERROR)
2208 {
2209 return SD_CMD_CRC_ERROR;
2210 }
2211
2212 return status;
2213}
2214
2220 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2221{
2222 sd_error_status_type status = SD_OK;
2223 uint32_t response = 0;
2224 uint8_t arg = 0x00;
2225
2226 if(new_state == TRUE)
2227 {
2228 arg = 0x02;
2229 }
2230 else
2231 {
2232 arg = 0x00;
2233 }
2234
2235 /* get response1 */
2236 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2237
2238 /* check card locked or not */
2239 if(response & SD_CARD_LOCKED)
2240 {
2241 return SD_LOCK_UNLOCK_ERROR;
2242 }
2243
2244 if(sd_card_info.sd_scr_reg.sd_bus_width)
2245 {
2246 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2247 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2248 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2249 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2250
2251 /* sdio command config */
2252 sdio_command_config(SDIOx, &sdio_command_init_struct);
2253 /* enable ccsm */
2254 sdio_command_state_machine_enable(SDIOx, TRUE);
2255
2256 status = command_rsp1_error(SD_CMD_APP_CMD);
2257
2258 if(status != SD_OK)
2259 {
2260 return status;
2261 }
2262
2263 sdio_command_init_struct.argument = arg;
2264 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2265 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2266 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2267
2268 /* sdio command config */
2269 sdio_command_config(SDIOx, &sdio_command_init_struct);
2270 /* enable ccsm */
2271 sdio_command_state_machine_enable(SDIOx, TRUE);
2272
2273 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2274 return status;
2275 }
2276 else
2277 {
2278 return SD_REQ_NOT_APPLICABLE;
2279 }
2280}
2281
2289 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2290{
2291 sd_error_status_type status = SD_OK;
2292 uint32_t card_status = 0, timeout = 0;
2293
2294 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2295 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2296 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2297 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2298
2299 /* sdio command config */
2300 sdio_command_config(SDIOx, &sdio_command_init_struct);
2301 /* enable ccsm */
2302 sdio_command_state_machine_enable(SDIOx, TRUE);
2303
2304 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2305 if(status != SD_OK)
2306 {
2307 return status;
2308 }
2309
2310 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2311 if(card_status & MMC_SWITCH_ERROR)
2312 {
2313 return SD_SWITCH_ERROR;
2314 }
2315
2316 timeout = SD_DATATIMEOUT;
2317 do
2318 {
2319 timeout--;
2320 status = sd_status_send(&card_status);
2321 } /* check ready_for_data flag */
2322 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2323
2324 if(timeout == 0)
2325 {
2326 return SD_ERROR;
2327 }
2328
2329 return status;
2330}
2331
2340 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2341{
2342 sd_error_status_type status = SD_OK;
2343 uint8_t power;
2344 uint16_t blk_size;
2345
2346 if(rsp == NULL)
2347 {
2348 return SD_INVALID_PARAMETER;
2349 }
2350
2351 SDIOx->dtctrl = 0x0;
2352
2353 blk_size = 64;
2354 power = convert_from_bytes_to_power_of_two(blk_size);
2355
2356 sdio_command_init_struct.argument = blk_size;
2357 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2358 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2359 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2360
2361 /* sdio command config */
2362 sdio_command_config(SDIOx, &sdio_command_init_struct);
2363 /* enable ccsm */
2364 sdio_command_state_machine_enable(SDIOx, TRUE);
2365
2366 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2367
2368 if(status != SD_OK)
2369 {
2370 return status;
2371 }
2372
2373 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2374 sdio_data_init_struct.data_length = blk_size ;
2375 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2376 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2377 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2378
2379 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2380 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2381 sdio_command_init_struct.argument |= value << (group * 4);
2382 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2383 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2384 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2385
2386 stop_flag = 0;
2387
2388 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2389}
2390
2396 sd_error_status_type check_card_programming(uint8_t *p_status)
2397{
2398 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2399
2400 /* send cmd13 */
2401 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2402 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2403 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2404 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2405
2406 /* sdio command config */
2407 sdio_command_config(SDIOx, &sdio_command_init_struct);
2408 /* enable ccsm */
2409 sdio_command_state_machine_enable(SDIOx, TRUE);
2410
2411 sts_reg = SDIOx->sts;
2412
2413 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2414 {
2415 sts_reg = SDIOx->sts;
2416 }
2417
2418 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2419 {
2420 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2421 return SD_CMD_FAIL;
2422 }
2423
2424 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2425 {
2426 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2427 return SD_CMD_RSP_TIMEOUT;
2428 }
2429
2430 rsp_cmd = sdio_command_response_get(SDIOx);
2431 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2432 {
2433 return SD_ILLEGAL_CMD;
2434 }
2435
2436 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2437
2438 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2439
2440 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2441
2442 return SD_OK;
2443}
2444
2450 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2451{
2452 sd_error_status_type status = SD_OK;
2453
2454 if(p_card_status == NULL)
2455 {
2456 status = SD_INVALID_PARAMETER;
2457 return status;
2458 }
2459
2460 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2461 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2462 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2463 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2464
2465 /* sdio command config */
2466 sdio_command_config(SDIOx, &sdio_command_init_struct);
2467 /* enable ccsm */
2468 sdio_command_state_machine_enable(SDIOx, TRUE);
2469
2470 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2471
2472 if(status != SD_OK)
2473 {
2474 return status;
2475 }
2476
2477 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2478
2479 return status;
2480}
2481
2487 sd_card_state_type sd_state_get(void)
2488{
2489 uint32_t response = 0;
2490
2491 if(sd_status_send(&response) != SD_OK)
2492 {
2493 return SD_CARD_ERROR;
2494 }
2495 else
2496 {
2497 return (sd_card_state_type)((response >> 9) & 0x0F);
2498 }
2499}
2500
2505 sd_error_status_type scr_find(void)
2506{
2507 uint32_t index = 0, sts_reg = 0;
2508 sd_error_status_type status = SD_OK;
2509 uint32_t *tempscr;
2510
2511 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2512
2513 /* send cmd16, set block length */
2514 sdio_command_init_struct.argument = (uint32_t)8;
2515 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2516 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2517 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2518
2519 /* sdio command config */
2520 sdio_command_config(SDIOx, &sdio_command_init_struct);
2521 /* enable ccsm */
2522 sdio_command_state_machine_enable(SDIOx, TRUE);
2523
2524 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2525
2526 if(status != SD_OK)
2527 {
2528 return status;
2529 }
2530
2531 /* send cmd55 */
2532 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2533 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2534 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2535 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2536
2537 /* sdio command config */
2538 sdio_command_config(SDIOx, &sdio_command_init_struct);
2539 /* enable ccsm */
2540 sdio_command_state_machine_enable(SDIOx, TRUE);
2541
2542 status = command_rsp1_error(SD_CMD_APP_CMD);
2543
2544 if(status != SD_OK)
2545 {
2546 return status;
2547 }
2548
2549 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2550 sdio_data_init_struct.data_length = 8;
2551 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2552 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2553 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2554
2555 sdio_data_config(SDIOx, &sdio_data_init_struct);
2556 sdio_data_state_machine_enable(SDIOx, TRUE);
2557
2558 /* send cmd51 */
2559 sdio_command_init_struct.argument = 0x0;
2560 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2561 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2562 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2563
2564 /* sdio command config */
2565 sdio_command_config(SDIOx, &sdio_command_init_struct);
2566 /* enable ccsm */
2567 sdio_command_state_machine_enable(SDIOx, TRUE);
2568
2569 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2570
2571 if(status != SD_OK)
2572 {
2573 return status;
2574 }
2575
2576 sts_reg = SDIOx->sts;
2577
2578 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2579 {
2580 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2581 {
2582 *(tempscr + index) = sdio_data_read(SDIOx);
2583 index++;
2584 }
2585 sts_reg = SDIOx->sts;
2586 }
2587
2588 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2589 {
2590 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2591 return SD_DATA_TIMEOUT;
2592 }
2593 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2594 {
2595 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2596 return SD_DATA_FAIL;
2597 }
2598 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2599 {
2600 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2601 return SD_RX_OVERRUN;
2602 }
2603 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2604 {
2605 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2606 return SD_START_BIT_ERR;
2607 }
2608
2609 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2610
2611 return status;
2612}
2613
2619 sd_error_status_type speed_change(uint8_t speed)
2620{
2621 sd_error_status_type status = SD_OK;
2622 uint8_t switch_sts[64];
2623
2624 if(speed > 1)
2625 {
2626 return SD_ERROR;
2627 }
2628
2629 /* check card type */
2630 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2631 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2632 {
2633 /* version 1.01 card does not support cmd6 */
2634 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2635 {
2636 return SD_ERROR;
2637 }
2638
2639 /* check group 1 function support speed */
2640 status = sd_switch(0, 0, speed, switch_sts);
2641
2642 if(status != 0)
2643 {
2644 return status;
2645 }
2646
2647 if((switch_sts[13] & (1 << speed)) == 0)
2648 {
2649 return SD_ERROR;
2650 }
2651
2652 status = sd_switch(1, 0, speed, switch_sts);
2653
2654 if(status != 0)
2655 {
2656 return status;
2657 }
2658
2659 /* read it back for confirmation */
2660 if((switch_sts[16] & 0xF) != speed)
2661 {
2662 return SD_ERROR;
2663 }
2664 }
2665 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2666 {
2667 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2668
2669 if(status != 0)
2670 {
2671 return status;
2672 }
2673 }
2674
2675 return status;
2676}
2677
2683uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2684{
2685 uint8_t count = 0;
2686
2687 while(number_of_bytes != 1)
2688 {
2689 number_of_bytes >>= 1;
2690 count++;
2691 }
2692
2693 return count;
2694}
2695
2704void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2705{
2706 dma_init_type dma_init_struct;
2707 dma_default_para_init(&dma_init_struct);
2708
2709 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2710
2711 dma_reset(DMA2_CHANNEL4);
2712 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2713
2714 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2715 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2716 dma_init_struct.direction = dir;
2717 dma_init_struct.buffer_size = buf_size / 4;
2718 dma_init_struct.peripheral_inc_enable = FALSE;
2719 dma_init_struct.memory_inc_enable = TRUE;
2720 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2721 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2722 dma_init_struct.loop_mode_enable = FALSE;
2723 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2724 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2725
2726 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2727}
2728
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:36
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sdio_fatfs/src/at32_sdio.c:47
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: sdio_fatfs/src/at32_sdio.c:2340
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: sdio_fatfs/src/at32_sdio.c:2091
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: sdio_fatfs/src/at32_sdio.c:2619
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sdio_fatfs/src/at32_sdio.c:401
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: sdio_fatfs/src/at32_sdio.c:39
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sdio_fatfs/src/at32_sdio.c:1787
transfer_end
volatile uint8_t transfer_end
Definition: sdio_fatfs/src/at32_sdio.c:46
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: sdio_fatfs/src/at32_sdio.c:1898
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sdio_fatfs/src/at32_sdio.c:784
card_type
static sd_memory_card_type card_type
Definition: sdio_fatfs/src/at32_sdio.c:41
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: sdio_fatfs/src/at32_sdio.c:2683
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sdio_fatfs/src/at32_sdio.c:530
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: sdio_fatfs/src/at32_sdio.c:38
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sdio_fatfs/src/at32_sdio.c:1698
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sdio_fatfs/src/at32_sdio.c:415
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sdio_fatfs/src/at32_sdio.c:1186
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sdio_fatfs/src/at32_sdio.c:805
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: sdio_fatfs/src/at32_sdio.c:2154
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: sdio_fatfs/src/at32_sdio.c:1767
stop_flag
static uint8_t stop_flag
Definition: sdio_fatfs/src/at32_sdio.c:44
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: sdio_fatfs/src/at32_sdio.c:2289
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sdio_fatfs/src/at32_sdio.c:1028
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: sdio_fatfs/src/at32_sdio.c:2396
transfer_error
volatile sd_error_status_type transfer_error
Definition: sdio_fatfs/src/at32_sdio.c:45
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: sdio_fatfs/src/at32_sdio.c:2220
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: sdio_fatfs/src/at32_sdio.c:1935
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: sdio_fatfs/src/at32_sdio.c:1777
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sdio_fatfs/src/at32_sdio.c:1487
csd_table
static uint32_t csd_table[4]
Definition: sdio_fatfs/src/at32_sdio.c:42
sdio_clock_set
void sdio_clock_set(uint32_t clk_div)
set sdio clock devision factor.
Definition: sdio_fatfs/src/at32_sdio.c:186
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sdio_fatfs/src/at32_sdio.c:2487
cid_table
static uint32_t cid_table[4]
Definition: sdio_fatfs/src/at32_sdio.c:42
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sdio_fatfs/src/at32_sdio.c:2704
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sdio_fatfs/src/at32_sdio.c:1365
device_mode
static sd_data_transfer_mode_type device_mode
Definition: sdio_fatfs/src/at32_sdio.c:43
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sdio_fatfs/src/at32_sdio.c:2450
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: sdio_fatfs/src/at32_sdio.c:828
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: sdio_fatfs/src/at32_sdio.c:2008
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sdio_fatfs/src/at32_sdio.c:71
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sdio_fatfs/src/at32_sdio.c:1651
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: sdio_fatfs/src/at32_sdio.c:2505
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sdio_fatfs/src/at32_sdio.c:201
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: sdio_fatfs/src/at32_sdio.c:2048
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sdio_fatfs/src/at32_sdio.c:1275
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sdio_fatfs/src/at32_sdio.c:741
rca
static uint32_t rca
Definition: sdio_fatfs/src/at32_sdio.c:42
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: sdio_fatfs/src/at32_sdio.c:1978
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: sdio_fatfs/src/at32_sdio.c:1871
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f413_crm.h:105
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:103
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:214
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:245
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:255
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:265
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f413_dma.h:490
confirm_state
confirm_state
confirm state
Definition: at32f413.h:296
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:242
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:59
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:60
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:51
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:57
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:748
GPIOD
#define GPIOD
Definition: at32f413_gpio.h:749
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:327
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:488
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:414
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:463
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:350
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:139
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:166
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:73
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:102
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:126
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:230
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:313
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:85
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:381
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:439
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:153
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:276
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:192
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:49
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:179
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:363
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:137
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f413_sdio.h:178
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f413_sdio.h:158
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f413_sdio.h:159
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f413_sdio.h:150
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f413_sdio.h:149
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f413_sdio.h:148
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f413_sdio.h:130
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f413_sdio.h:210
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f413_sdio.h:211
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f413_sdio.h:120
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f413_sdio.h:121
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f413_sdio.h:201
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f413_sdio.h:202
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f413_sdio.h:138
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f413_sdio.h:139
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:170
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:169
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:168
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f413_sdio.h:182
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f413_sdio.h:179
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f413_sdio.h:85
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f413_sdio.h:97
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f413_sdio.h:90
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:84
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:88
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f413_sdio.h:98
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f413_sdio.h:104
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f413_sdio.h:83
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f413_sdio.h:89
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f413_sdio.h:93
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:86
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:92
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f413_sdio.h:91
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:87
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f413_sdio.h:59
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f413_sdio.h:65
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f413_sdio.h:53
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f413_sdio.h:54
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f413_sdio.h:55
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f413_sdio.h:51
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f413_sdio.h:64
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f413_sdio.h:58
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: sd_mmc_card/inc/at32_sdio.h:436
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: sd_mmc_card/inc/at32_sdio.h:289
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:301
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:285
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:293
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: sd_mmc_card/inc/at32_sdio.h:258
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: sd_mmc_card/inc/at32_sdio.h:268
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: sd_mmc_card/inc/at32_sdio.h:269
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: sd_mmc_card/inc/at32_sdio.h:277
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:276
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:257
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: sd_mmc_card/inc/at32_sdio.h:272
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: sd_mmc_card/inc/at32_sdio.h:262
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:273
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:304
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: sd_mmc_card/inc/at32_sdio.h:256
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: sd_mmc_card/inc/at32_sdio.h:259
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:288
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:267
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:286
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:287
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:263
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: sd_mmc_card/inc/at32_sdio.h:265
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sd_mmc_card/inc/at32_sdio.h:63
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:72
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:185
sd_memory_card_type
sd_memory_card_type
Definition: sd_mmc_card/inc/at32_sdio.h:201
SDIOx
#define SDIOx
Definition: sd_mmc_card/inc/at32_sdio.h:49
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:472
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:474
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:461
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: sd_mmc_card/inc/at32_sdio.h:454
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: sd_mmc_card/inc/at32_sdio.h:452
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:340
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:339
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: sd_mmc_card/inc/at32_sdio.h:338
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: sd_mmc_card/inc/at32_sdio.h:398
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: sd_mmc_card/inc/at32_sdio.h:389
SD_R5_ERROR
#define SD_R5_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:381
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sd_mmc_card/inc/at32_sdio.h:400
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:379
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: sd_mmc_card/inc/at32_sdio.h:406
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:391
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: sd_mmc_card/inc/at32_sdio.h:380
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:387
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:386
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: sd_mmc_card/inc/at32_sdio.h:394
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:401
SD_ALLZERO
#define SD_ALLZERO
Definition: sd_mmc_card/inc/at32_sdio.h:395
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:388
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:372
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: sd_mmc_card/inc/at32_sdio.h:393
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: sd_mmc_card/inc/at32_sdio.h:392
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: sd_mmc_card/inc/at32_sdio.h:374
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sd_mmc_card/inc/at32_sdio.h:399
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:390
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:65
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:64
SD_ERROR
@ SD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:116
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sd_mmc_card/inc/at32_sdio.h:106
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:75
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sd_mmc_card/inc/at32_sdio.h:113
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:74
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:81
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:92
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sd_mmc_card/inc/at32_sdio.h:114
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:78
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:89
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:88
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:79
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sd_mmc_card/inc/at32_sdio.h:112
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:102
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sd_mmc_card/inc/at32_sdio.h:100
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:77
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:80
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:87
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:76
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:117
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:194
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:208
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:207
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:202
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:206
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:203
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:205
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:235
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:236
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: sd_mmc_card/inc/at32_sdio.h:173
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:169
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: sd_mmc_card/inc/at32_sdio.h:171
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: sd_mmc_card/inc/at32_sdio.h:170
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: sd_mmc_card/inc/at32_sdio.h:126
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::nsac
uint8_t nsac
Definition: sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: sd_mmc_card/inc/at32_sdio.h:125
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:127
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:146
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::taac
uint8_t taac
Definition: sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:143
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: sd_mmc_card/inc/at32_sdio.h:220
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: sd_mmc_card/inc/at32_sdio.h:218
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:227
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:229
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:228
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:231
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:230
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:238
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:243
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:239
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:242
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:240


AT32F413 Firmwary Library: smartcard_config.h Source File

  • usart
  • smartcard
  • inc
smartcard_config.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __SMARTCARD_CONFIG_H
27#define __SMARTCARD_CONFIG_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* smartcard inteface usart pins */
34#define SC_USART USART2
35#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK
36#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
37#define SC_USART_TX_PIN GPIO_PINS_2
38#define SC_USART_TX_PORT GPIOA
39#define SC_USART_CLK_PIN GPIO_PINS_4
40#define SC_USART_CLK_PORT GPIOA
41#define SC_USART_IRQn USART2_IRQn
42#define SC_USART_IRQHandler USART2_IRQHandler
43
44/* smartcard inteface gpio pins */
45#define SC_3_5V_PIN GPIO_PINS_5
46#define SC_RESET_PIN GPIO_PINS_6
47#define SC_CMDVCC_PIN GPIO_PINS_7
48#define SC_OFF_PIN GPIO_PINS_8
49#define SC_3_5V_PORT GPIOA
50#define SC_RESET_PORT GPIOA
51#define SC_CMDVCC_PORT GPIOA
52#define SC_OFF_PORT GPIOA
53#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
54#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
55#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
56#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
57#define SC_OFF_EXINT EXINT_LINE_8
58#define SC_OFF_PORTSOURCE GPIO_PORT_SOURCE_GPIOA
59#define SC_OFF_PINSOURCE GPIO_PINS_SOURCE8
60#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn
61
62#ifdef __cplusplus
63}
64#endif
65
66#endif /* __SMARTCARD_CONFIG_H */
67


AT32F413 Firmwary Library: spi_flash.c Source File

  • spi
  • w25q_flash
  • src
spi_flash.c
Go to the documentation of this file.
1
25#include "spi_flash.h"
26
35uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE];
36
42void spiflash_init(void)
43{
44 gpio_init_type gpio_initstructure;
45 spi_init_type spi_init_struct;
46
47 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
48 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
49 /* software cs, pb12 as a general io to control flash cs */
50 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
51 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
52 gpio_initstructure.gpio_mode = GPIO_MODE_OUTPUT;
53 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
54 gpio_initstructure.gpio_pins = GPIO_PINS_12;
55 gpio_init(GPIOB, &gpio_initstructure);
56
57 /* sck */
58 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
59 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
60 gpio_initstructure.gpio_pins = GPIO_PINS_13;
61 gpio_init(GPIOB, &gpio_initstructure);
62
63 /* miso */
64 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
65 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
66 gpio_initstructure.gpio_pins = GPIO_PINS_14;
67 gpio_init(GPIOB, &gpio_initstructure);
68
69 /* mosi */
70 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
71 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
72 gpio_initstructure.gpio_pins = GPIO_PINS_15;
73 gpio_init(GPIOB, &gpio_initstructure);
74
75 FLASH_CS_HIGH();
76 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
77 spi_default_para_init(&spi_init_struct);
78 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
79 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
80 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
81 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
82 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
83 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
84 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
85 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
86 spi_init(SPI2, &spi_init_struct);
87 spi_enable(SPI2, TRUE);
88}
89
97void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
98{
99 uint32_t sector_pos;
100 uint16_t sector_offset;
101 uint16_t sector_remain;
102 uint16_t index;
103 uint8_t *spiflash_buf;
104 spiflash_buf = spiflash_sector_buf;
105
106 /* sector address */
107 sector_pos = write_addr / SPIF_SECTOR_SIZE;
108
109 /* address offset in a sector */
110 sector_offset = write_addr % SPIF_SECTOR_SIZE;
111
112 /* the remain in a sector */
113 sector_remain = SPIF_SECTOR_SIZE - sector_offset;
114 if(length <= sector_remain)
115 {
116 /* smaller than a sector size */
117 sector_remain = length;
118 }
119 while(1)
120 {
121 /* read a sector */
122 spiflash_read(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE);
123
124 /* validate the read erea */
125 for(index = 0; index < sector_remain; index++)
126 {
127 if(spiflash_buf[sector_offset + index] != 0xFF)
128 {
129 /* there are some data not equal 0xff, so this secotr needs erased */
130 break;
131 }
132 }
133 if(index < sector_remain)
134 {
135 /* erase the sector */
136 spiflash_sector_erase(sector_pos);
137
138 /* copy the write data */
139 for(index = 0; index < sector_remain; index++)
140 {
141 spiflash_buf[index + sector_offset] = pbuffer[index];
142 }
143 spiflash_write_nocheck(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE); /* program the sector */
144 }
145 else
146 {
147 /* write directly in the erased area */
148 spiflash_write_nocheck(pbuffer, write_addr, sector_remain);
149 }
150 if(length == sector_remain)
151 {
152 /* write end */
153 break;
154 }
155 else
156 {
157 /* go on writing */
158 sector_pos++;
159 sector_offset = 0;
160
161 pbuffer += sector_remain;
162 write_addr += sector_remain;
163 length -= sector_remain;
164 if(length > SPIF_SECTOR_SIZE)
165 {
166 /* could not write the remain data in the next sector */
167 sector_remain = SPIF_SECTOR_SIZE;
168 }
169 else
170 {
171 /* could write the remain data in the next sector */
172 sector_remain = length;
173 }
174 }
175 }
176}
177
185void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
186{
187 FLASH_CS_LOW();
188 spi_byte_write(SPIF_READDATA); /* send instruction */
189 spi_byte_write((uint8_t)((read_addr) >> 16)); /* send 24-bit address */
190 spi_byte_write((uint8_t)((read_addr) >> 8));
191 spi_byte_write((uint8_t)read_addr);
192 spi_bytes_read(pbuffer, length);
193 FLASH_CS_HIGH();
194}
195
201void spiflash_sector_erase(uint32_t erase_addr)
202{
203 erase_addr *= SPIF_SECTOR_SIZE; /* translate sector address to byte address */
204 spiflash_write_enable();
205 spiflash_wait_busy();
206 FLASH_CS_LOW();
207 spi_byte_write(SPIF_SECTORERASE);
208 spi_byte_write((uint8_t)((erase_addr) >> 16));
209 spi_byte_write((uint8_t)((erase_addr) >> 8));
210 spi_byte_write((uint8_t)erase_addr);
211 FLASH_CS_HIGH();
212 spiflash_wait_busy();
213}
214
222void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
223{
224 uint16_t page_remain;
225
226 /* remain bytes in a page */
227 page_remain = SPIF_PAGE_SIZE - write_addr % SPIF_PAGE_SIZE;
228 if(length <= page_remain)
229 {
230 /* smaller than a page size */
231 page_remain = length;
232 }
233 while(1)
234 {
235 spiflash_page_write(pbuffer, write_addr, page_remain);
236 if(length == page_remain)
237 {
238 /* all data are programmed */
239 break;
240 }
241 else
242 {
243 /* length > page_remain */
244 pbuffer += page_remain;
245 write_addr += page_remain;
246
247 /* the remain bytes to be prorammed */
248 length -= page_remain;
249 if(length > SPIF_PAGE_SIZE)
250 {
251 /* can be progrmmed a page at a time */
252 page_remain = SPIF_PAGE_SIZE;
253 }
254 else
255 {
256 /* smaller than a page size */
257 page_remain = length;
258 }
259 }
260 }
261}
262
270void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
271{
272 if((0 < length) && (length <= SPIF_PAGE_SIZE))
273 {
274 /* set write enable */
275 spiflash_write_enable();
276
277 FLASH_CS_LOW();
278
279 /* send instruction */
280 spi_byte_write(SPIF_PAGEPROGRAM);
281
282 /* send 24-bit address */
283 spi_byte_write((uint8_t)((write_addr) >> 16));
284 spi_byte_write((uint8_t)((write_addr) >> 8));
285 spi_byte_write((uint8_t)write_addr);
286 spi_bytes_write(pbuffer,length);
287
288 FLASH_CS_HIGH();
289
290 /* wait for program end */
291 spiflash_wait_busy();
292 }
293}
294
301void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
302{
303 volatile uint8_t dummy_data;
304
305#if defined(SPI_TRANS_DMA)
306 dma_init_type dma_init_struct;
307 dma_reset(DMA1_CHANNEL4);
308 dma_reset(DMA1_CHANNEL5);
309 dma_default_para_init(&dma_init_struct);
310 dma_init_struct.buffer_size = length;
311 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
312 dma_init_struct.memory_base_addr = (uint32_t)&dummy_data;
313 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
314 dma_init_struct.memory_inc_enable = FALSE;
315 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
316 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
317 dma_init_struct.peripheral_inc_enable = FALSE;
318 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
319 dma_init_struct.loop_mode_enable = FALSE;
320 dma_init(DMA1_CHANNEL4, &dma_init_struct);
321
322 dma_init_struct.buffer_size = length;
323 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
324 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
325 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
326 dma_init_struct.memory_inc_enable = TRUE;
327 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
328 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
329 dma_init_struct.peripheral_inc_enable = FALSE;
330 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
331 dma_init_struct.loop_mode_enable = FALSE;
332 dma_init(DMA1_CHANNEL5, &dma_init_struct);
333
334 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
335 spi_i2s_dma_receiver_enable(SPI2, TRUE);
336
337 dma_channel_enable(DMA1_CHANNEL4, TRUE);
338 dma_channel_enable(DMA1_CHANNEL5, TRUE);
339
340 while(dma_flag_get(DMA1_FDT4_FLAG) == RESET);
341 dma_flag_clear(DMA1_FDT4_FLAG);
342
343 dma_channel_enable(DMA1_CHANNEL4, FALSE);
344 dma_channel_enable(DMA1_CHANNEL5, FALSE);
345
346 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
347 spi_i2s_dma_receiver_enable(SPI2, FALSE);
348#else
349 while(length--)
350 {
351 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
352 spi_i2s_data_transmit(SPI2, *pbuffer);
353 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
354 dummy_data = spi_i2s_data_receive(SPI2);
355 pbuffer++;
356 }
357#endif
358}
359
366void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
367{
368 uint8_t write_value = FLASH_SPI_DUMMY_BYTE;
369
370#if defined(SPI_TRANS_DMA)
371 dma_init_type dma_init_struct;
372 dma_reset(DMA1_CHANNEL4);
373 dma_reset(DMA1_CHANNEL5);
374 dma_default_para_init(&dma_init_struct);
375 dma_init_struct.buffer_size = length;
376 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
377 dma_init_struct.memory_base_addr = (uint32_t)&write_value;
378 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
379 dma_init_struct.memory_inc_enable = FALSE;
380 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
381 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
382 dma_init_struct.peripheral_inc_enable = FALSE;
383 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
384 dma_init_struct.loop_mode_enable = FALSE;
385 dma_init(DMA1_CHANNEL5, &dma_init_struct);
386
387 dma_init_struct.buffer_size = length;
388 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
389 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
390 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
391 dma_init_struct.memory_inc_enable = TRUE;
392 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
393 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
394 dma_init_struct.peripheral_inc_enable = FALSE;
395 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
396 dma_init_struct.loop_mode_enable = FALSE;
397 dma_init(DMA1_CHANNEL4, &dma_init_struct);
398
399 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
400 spi_i2s_dma_receiver_enable(SPI2, TRUE);
401 dma_channel_enable(DMA1_CHANNEL4, TRUE);
402 dma_channel_enable(DMA1_CHANNEL5, TRUE);
403
404 while(dma_flag_get(DMA1_FDT4_FLAG) == RESET);
405 dma_flag_clear(DMA1_FDT4_FLAG);
406
407 dma_channel_enable(DMA1_CHANNEL4, FALSE);
408 dma_channel_enable(DMA1_CHANNEL5, FALSE);
409
410 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
411 spi_i2s_dma_receiver_enable(SPI2, FALSE);
412#else
413 while(length--)
414 {
415 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
416 spi_i2s_data_transmit(SPI2, write_value);
417 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
418 *pbuffer = spi_i2s_data_receive(SPI2);
419 pbuffer++;
420 }
421#endif
422}
423
429void spiflash_wait_busy(void)
430{
431 while((spiflash_read_sr1() & 0x01) == 0x01);
432}
433
439uint8_t spiflash_read_sr1(void)
440{
441 uint8_t breadbyte = 0;
442 FLASH_CS_LOW();
443 spi_byte_write(SPIF_READSTATUSREG1);
444 breadbyte = (uint8_t)spi_byte_read();
445 FLASH_CS_HIGH();
446 return (breadbyte);
447}
448
454void spiflash_write_enable(void)
455{
456 FLASH_CS_LOW();
457 spi_byte_write(SPIF_WRITEENABLE);
458 FLASH_CS_HIGH();
459}
460
466uint16_t spiflash_read_id(void)
467{
468 uint16_t wreceivedata = 0;
469 FLASH_CS_LOW();
470 spi_byte_write(SPIF_MANUFACTDEVICEID);
471 spi_byte_write(0x00);
472 spi_byte_write(0x00);
473 spi_byte_write(0x00);
474 wreceivedata |= spi_byte_read() << 8;
475 wreceivedata |= spi_byte_read();
476 FLASH_CS_HIGH();
477 return wreceivedata;
478}
479
485uint8_t spi_byte_write(uint8_t data)
486{
487 uint8_t brxbuff;
488 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
489 spi_i2s_dma_receiver_enable(SPI2, FALSE);
490 spi_i2s_data_transmit(SPI2, data);
491 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
492 brxbuff = spi_i2s_data_receive(SPI2);
493 while(spi_i2s_flag_get(SPI2, SPI_I2S_BF_FLAG) != RESET);
494 return brxbuff;
495}
496
502uint8_t spi_byte_read(void)
503{
504 return (spi_byte_write(FLASH_SPI_DUMMY_BYTE));
505}
506
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:37
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: spi_flash.c:42
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: spi_flash.c:97
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: spi_flash.c:429
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: spi_flash.c:454
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: spi_flash.c:439
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: spi_flash.c:222
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: spi_flash.c:201
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: spi_flash.c:485
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: spi_flash.c:185
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: spi_flash.c:466
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: spi_flash.c:366
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: spi_flash.c:301
spiflash_sector_buf
uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]
Definition: spi_flash.c:35
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: spi_flash.c:270
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: spi_flash.c:502
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:102
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:196
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:360
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:296
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:342
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:62
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:395
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:243
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:216
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:215
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:253
DMA_PRIORITY_VERY_HIGH
@ DMA_PRIORITY_VERY_HIGH
Definition: at32f413_dma.h:266
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:92
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:482
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:481
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:98
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:214
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:212
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:213
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:223
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:243
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:233
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:62
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:61
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:63
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:64
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:747
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:52
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:51
SPI_I2S_BF_FLAG
#define SPI_I2S_BF_FLAG
Definition: at32f413_spi.h:58
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:512
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:497
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:546
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:89
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:69
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:524
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:285
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:483
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:97
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:115
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:124
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:149
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:106
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:158
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:134
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:87
FLASH_CS_LOW
#define FLASH_CS_LOW()
Definition: spi_flash.h:51
FLASH_CS_HIGH
#define FLASH_CS_HIGH()
Definition: spi_flash.h:50
SPIF_READDATA
#define SPIF_READDATA
Definition: spi_flash.h:94
SPIF_PAGE_SIZE
#define SPIF_PAGE_SIZE
Definition: spi_flash.h:81
SPIF_SECTORERASE
#define SPIF_SECTORERASE
Definition: spi_flash.h:100
SPIF_MANUFACTDEVICEID
#define SPIF_MANUFACTDEVICEID
Definition: spi_flash.h:105
FLASH_SPI_DUMMY_BYTE
#define FLASH_SPI_DUMMY_BYTE
Definition: spi_flash.h:107
SPIF_SECTOR_SIZE
#define SPIF_SECTOR_SIZE
Definition: spi_flash.h:80
SPIF_READSTATUSREG1
#define SPIF_READSTATUSREG1
Definition: spi_flash.h:86
SPIF_PAGEPROGRAM
#define SPIF_PAGEPROGRAM
Definition: spi_flash.h:97
SPIF_WRITEENABLE
#define SPIF_WRITEENABLE
Definition: spi_flash.h:83
SPI2
#define SPI2
Definition: at32f413_spi.h:447
spi_flash.h
header file of spi_flash
dma_init_type
dma init type
Definition: at32f413_dma.h:273
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:282
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:277
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:281
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:283
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:278
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:276
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:274
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:275
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:280
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:286
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:289
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:287
spi_init_type
spi init type
Definition: at32f413_spi.h:255
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:257
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:259
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:260
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:261
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:263
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:258
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:256
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:262


AT32F413 Firmwary Library: spi_flash.h Source File

  • spi
  • w25q_flash
  • inc
spi_flash.h
Go to the documentation of this file.
1
25#ifndef __SPI_FLASH_H
26#define __SPI_FLASH_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413.h"
33
43 /* use dma transfer spi data */
44#define SPI_TRANS_DMA
45
50#define FLASH_CS_HIGH() gpio_bits_set(GPIOB, GPIO_PINS_12)
51#define FLASH_CS_LOW() gpio_bits_reset(GPIOB, GPIO_PINS_12)
52
61/*
62 * flash define
63 */
64#define W25Q80 0xEF13
65#define W25Q16 0xEF14
66#define W25Q32 0xEF15
67#define W25Q64 0xEF16
68/* 16mb, the range of address:0~0xFFFFFF */
69#define W25Q128 0xEF17
70
79#define SPIF_CHIP_SIZE 0x1000000
80#define SPIF_SECTOR_SIZE 4096
81#define SPIF_PAGE_SIZE 256
82
83#define SPIF_WRITEENABLE 0x06
84#define SPIF_WRITEDISABLE 0x04
85/* s7-s0 */
86#define SPIF_READSTATUSREG1 0x05
87#define SPIF_WRITESTATUSREG1 0x01
88/* s15-s8 */
89#define SPIF_READSTATUSREG2 0x35
90#define SPIF_WRITESTATUSREG2 0x31
91/* s23-s16 */
92#define SPIF_READSTATUSREG3 0x15
93#define SPIF_WRITESTATUSREG3 0x11
94#define SPIF_READDATA 0x03
95#define SPIF_FASTREADDATA 0x0B
96#define SPIF_FASTREADDUAL 0x3B
97#define SPIF_PAGEPROGRAM 0x02
98/* block size:64kb */
99#define SPIF_BLOCKERASE 0xD8
100#define SPIF_SECTORERASE 0x20
101#define SPIF_CHIPERASE 0xC7
102#define SPIF_POWERDOWN 0xB9
103#define SPIF_RELEASEPOWERDOWN 0xAB
104#define SPIF_DEVICEID 0xAB
105#define SPIF_MANUFACTDEVICEID 0x90
106#define SPIF_JEDECDEVICEID 0x9F
107#define FLASH_SPI_DUMMY_BYTE 0xA5
108
117void spiflash_init(void);
118void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
119void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length);
120void spiflash_sector_erase(uint32_t erase_addr);
121void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
122void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
123void spi_bytes_write(uint8_t *pbuffer, uint32_t length);
124void spi_bytes_read(uint8_t *pbuffer, uint32_t length);
125void spiflash_wait_busy(void);
126uint8_t spiflash_read_sr1(void);
127void spiflash_write_enable(void);
128uint16_t spiflash_read_id(void);
129uint8_t spi_byte_write(uint8_t data);
130uint8_t spi_byte_read(void);
131
144#ifdef __cplusplus
145}
146#endif
147
148#endif
149
at32f413.h
at32f413 header file
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: spi_flash.c:42
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: spi_flash.c:97
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: spi_flash.c:429
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: spi_flash.c:454
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: spi_flash.c:439
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: spi_flash.c:222
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: spi_flash.c:201
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: spi_flash.c:485
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: spi_flash.c:185
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: spi_flash.c:466
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: spi_flash.c:366
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: spi_flash.c:301
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: spi_flash.c:270
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: spi_flash.c:502


AT32F413 Firmwary Library: system_at32f413.c Source File

  • libraries
  • cmsis
  • cm4
  • device_support
system_at32f413.c
Go to the documentation of this file.
1
33#include "at32f413.h"
34
38#define VECT_TAB_OFFSET 0x0
46unsigned int system_core_clock = HICK_VALUE;
62void SystemInit (void)
63{
64#if defined (__FPU_USED) && (__FPU_USED == 1U)
65 SCB->CPACR |= ((3U << 10U * 2U) | /* set cp10 full access */
66 (3U << 11U * 2U) ); /* set cp11 full access */
67#endif
68
69 /* reset the crm clock configuration to the default reset state(for debug purpose) */
70 /* set hicken bit */
71 CRM->ctrl_bit.hicken = TRUE;
72
73 /* wait hick stable */
74 while(CRM->ctrl_bit.hickstbl != SET);
75
76 /* hick used as system clock */
77 CRM->cfg_bit.sclksel = CRM_SCLK_HICK;
78
79 /* wait sclk switch status */
80 while(CRM->cfg_bit.sclksts != CRM_SCLK_HICK);
81
82 /* reset hexten, hextbyps, cfden and pllen bits */
83 CRM->ctrl &= ~(0x010D0000U);
84
85 /* reset cfg register, include sclk switch, ahbdiv, apb1div, apb2div, adcdiv,
86 clkout pllrcs, pllhextdiv, pllmult, usbdiv and pllrange bits */
87 CRM->cfg = 0;
88
89 /* reset clkout[3], usbbufs, hickdiv, clkoutdiv */
90 CRM->misc1 = 0;
91
92 /* disable all interrupts enable and clear pending bits */
93 CRM->clkint = 0x009F0000;
94
95#ifdef VECT_TAB_SRAM
96 SCB->VTOR = SRAM_BASE | VECT_TAB_OFFSET; /* vector table relocation in internal sram. */
97#else
98 SCB->VTOR = FLASH_BASE | VECT_TAB_OFFSET; /* vector table relocation in internal flash. */
99#endif
100}
101
110void system_core_clock_update(void)
111{
112 uint32_t pll_mult = 0, pll_mult_h = 0, pll_clock_source = 0, temp = 0, div_value = 0;
113 crm_sclk_type sclk_source;
114
115 static const uint8_t sys_ahb_div_table[16] = {0, 0, 0, 0, 0, 0, 0, 0, 1, 2, 3, 4, 6, 7, 8, 9};
116
117 /* get sclk source */
118 sclk_source = crm_sysclk_switch_status_get();
119
120 switch(sclk_source)
121 {
122 case CRM_SCLK_HICK:
123 if(((CRM->misc3_bit.hick_to_sclk) != RESET) && ((CRM->misc1_bit.hickdiv) != RESET))
124 system_core_clock = HICK_VALUE * 6;
125 else
126 system_core_clock = HICK_VALUE;
127 break;
128 case CRM_SCLK_HEXT:
129 system_core_clock = HEXT_VALUE;
130 break;
131 case CRM_SCLK_PLL:
132 pll_clock_source = CRM->cfg_bit.pllrcs;
133 {
134 /* get multiplication factor */
135 pll_mult = CRM->cfg_bit.pllmult_l;
136 pll_mult_h = CRM->cfg_bit.pllmult_h;
137 /* process high bits */
138 if((pll_mult_h != 0U) || (pll_mult == 15U)){
139 pll_mult += ((16U * pll_mult_h) + 1U);
140 }
141 else
142 {
143 pll_mult += 2U;
144 }
145
146 if (pll_clock_source == 0x00)
147 {
148 /* hick divided by 2 selected as pll clock entry */
149 system_core_clock = (HICK_VALUE >> 1) * pll_mult;
150 }
151 else
152 {
153 /* hext selected as pll clock entry */
154 if (CRM->cfg_bit.pllhextdiv != RESET)
155 {
156 /* hext clock divided by 2 */
157 system_core_clock = (HEXT_VALUE / 2) * pll_mult;
158 }
159 else
160 {
161 system_core_clock = HEXT_VALUE * pll_mult;
162 }
163 }
164 }
165 break;
166 default:
167 system_core_clock = HICK_VALUE;
168 break;
169 }
170
171 /* compute sclk, ahbclk frequency */
172 /* get ahb division */
173 temp = CRM->cfg_bit.ahbdiv;
174 div_value = sys_ahb_div_table[temp];
175 /* ahbclk frequency */
176 system_core_clock = system_core_clock >> div_value;
177}
at32f413.h
at32f413 header file
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
VECT_TAB_OFFSET
#define VECT_TAB_OFFSET
Definition: system_at32f413.c:38
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
SystemInit
void SystemInit(void)
setup the microcontroller system initialize the flash interface.
Definition: system_at32f413.c:62
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f413_crm.h:390
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f413_crm.h:391
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f413_crm.h:392
CRM
#define CRM
Definition: at32f413_crm.h:842
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
SRAM_BASE
#define SRAM_BASE
Definition: at32f413.h:331
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:328
HEXT_VALUE
#define HEXT_VALUE
in the following line adjust the value of high speed exernal crystal (hext) used in your application
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:42
HICK_VALUE
#define HICK_VALUE
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:50


AT32F413 Firmwary Library: system_at32f413.h Source File

  • libraries
  • cmsis
  • cm4
  • device_support
system_at32f413.h
Go to the documentation of this file.
1
25#ifndef __SYSTEM_AT32F413_H
26#define __SYSTEM_AT32F413_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
44#define HEXT_STABLE_DELAY (5000u)
45#define PLL_STABLE_DELAY (500u)
46#define SystemCoreClock system_core_clock
47
56extern unsigned int system_core_clock;
66extern void SystemInit(void);
67extern void system_core_clock_update(void);
68
81#ifdef __cplusplus
82}
83#endif
84
85#endif
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
SystemInit
void SystemInit(void)
setup the microcontroller system initialize the flash interface.
Definition: system_at32f413.c:62
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46


AT32F413 Firmwary Library: usb_std.h Source File

  • middlewares
  • usbd_drivers
  • inc
usb_std.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_STD_H
27#define __USB_STD_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "usb_conf.h"
36
52#define USB_REQ_RECIPIENT_DEVICE 0x00
53#define USB_REQ_RECIPIENT_INTERFACE 0x01
54#define USB_REQ_RECIPIENT_ENDPOINT 0x02
55#define USB_REQ_RECIPIENT_OTHER 0x03
56#define USB_REQ_RECIPIENT_MASK 0x1F
61#define USB_REQ_TYPE_STANDARD 0x00
62#define USB_REQ_TYPE_CLASS 0x20
63#define USB_REQ_TYPE_VENDOR 0x40
64#define USB_REQ_TYPE_RESERVED 0x60
69#define USB_REQ_DIR_HTD 0x00
70#define USB_REQ_DIR_DTH 0x80
75#define USB_STD_REQ_GET_STATUS 0
76#define USB_STD_REQ_CLEAR_FEATURE 1
77#define USB_STD_REQ_SET_FEATURE 3
78#define USB_STD_REQ_SET_ADDRESS 5
79#define USB_STD_REQ_GET_DESCRIPTOR 6
80#define USB_STD_REQ_SET_DESCRIPTOR 7
81#define USB_STD_REQ_GET_CONFIGURATION 8
82#define USB_STD_REQ_SET_CONFIGURATION 9
83#define USB_STD_REQ_GET_INTERFACE 10
84#define USB_STD_REQ_SET_INTERFACE 11
85#define USB_STD_REQ_SYNCH_FRAME 12
90#define USB_DESCIPTOR_TYPE_DEVICE 1
91#define USB_DESCIPTOR_TYPE_CONFIGURATION 2
92#define USB_DESCIPTOR_TYPE_STRING 3
93#define USB_DESCIPTOR_TYPE_INTERFACE 4
94#define USB_DESCIPTOR_TYPE_ENDPOINT 5
95#define USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
96#define USB_DESCIPTOR_TYPE_OTHER_SPEED 7
97#define USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
102#define USB_LANGID_STRING 0
103#define USB_MFC_STRING 1
104#define USB_PRODUCT_STRING 2
105#define USB_SERIAL_STRING 3
106#define USB_CONFIG_STRING 4
107#define USB_INTERFACE_STRING 5
112#define USB_CONF_REMOTE_WAKEUP 2
113#define USB_CONF_SELF_POWERED 1
118#define USB_FEATURE_EPT_HALT 0
119#define USB_FEATURE_REMOTE_WAKEUP 1
120#define USB_FEATURE_TEST_MODE 2
125typedef enum
126{
127 USB_CONN_STATE_DEFAULT =1,
128 USB_CONN_STATE_ADDRESSED,
129 USB_CONN_STATE_CONFIGURED,
130 USB_CONN_STATE_SUSPENDED
131}usbd_conn_state;
132
136#define USB_EPT0_IDLE 0
137#define USB_EPT0_SETUP 1
138#define USB_EPT0_DATA_IN 2
139#define USB_EPT0_DATA_OUT 3
140#define USB_EPT0_STATUS_IN 4
141#define USB_EPT0_STATUS_OUT 5
142#define USB_EPT0_STALL 6
147#define USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
148#define USB_DEVICE_DESC_LEN 0x12
149#define USB_DEVICE_CFG_DESC_LEN 0x09
150#define USB_DEVICE_IF_DESC_LEN 0x09
151#define USB_DEVICE_EPT_LEN 0x07
152#define USB_DEVICE_OTG_DESC_LEN 0x03
153#define USB_DEVICE_LANGID_STR_DESC_LEN 0x04
154#define USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
159#define USB_CLASS_CODE_AUDIO 0x01
160#define USB_CLASS_CODE_CDC 0x02
161#define USB_CLASS_CODE_HID 0x03
162#define USB_CLASS_CODE_PRINTER 0x07
163#define USB_CLASS_CODE_MSC 0x08
164#define USB_CLASS_CODE_HUB 0x09
165#define USB_CLASS_CODE_CDCDATA 0x0A
166#define USB_CLASS_CODE_CCID 0x0B
167#define USB_CLASS_CODE_VIDEO 0x0E
168#define USB_CLASS_CODE_VENDOR 0xFF
173#define USB_EPT_DESC_CONTROL 0x00
174#define USB_EPT_DESC_ISO 0x01
175#define USB_EPT_DESC_BULK 0x02
176#define USB_EPT_DESC_INTERRUPT 0x03
178#define USB_EPT_DESC_NSYNC 0x00
179#define USB_ETP_DESC_ASYNC 0x04
180#define USB_ETP_DESC_ADAPTIVE 0x08
181#define USB_ETP_DESC_SYNC 0x0C
183#define USB_EPT_DESC_DATA_EPT 0x00
184#define USB_EPT_DESC_FD_EPT 0x10
185#define USB_EPT_DESC_FDDATA_EPT 0x20
190#define USBD_CDC_CS_INTERFACE 0x24
191#define USBD_CDC_CS_ENDPOINT 0x25
192
196#define USBD_CDC_SUBTYPE_HEADER 0x00
197#define USBD_CDC_SUBTYPE_CMF 0x01
198#define USBD_CDC_SUBTYPE_ACM 0x02
199#define USBD_CDC_SUBTYPE_UFD 0x06
200
204#define SET_LINE_CODING 0x20
205#define GET_LINE_CODING 0x21
206
210typedef struct
211{
212 uint32_t bitrate; /* line coding baud rate */
213 uint8_t format; /* line coding foramt */
214 uint8_t parity; /* line coding parity */
215 uint8_t data; /* line coding data bit */
216}linecoding_type;
217
221#define HID_CLASS_DESC_HID 0x21
222#define HID_CLASS_DESC_REPORT 0x22
223#define HID_CLASS_DESC_PHYSICAL 0x23
224
228#define HID_REQ_SET_PROTOCOL 0x0B
229#define HID_REQ_GET_PROTOCOL 0x03
230#define HID_REQ_SET_IDLE 0x0A
231#define HID_REQ_GET_IDLE 0x02
232#define HID_REQ_SET_REPORT 0x09
233#define HID_REQ_GET_REPORT 0x01
234#define HID_DESCRIPTOR_TYPE 0x21
235#define HID_REPORT_DESC 0x22
236
240#define USB_MAX_EP0_SIZE 64
245#define SWAPBYTE(addr) (uint16_t)(((uint16_t)(*((uint8_t *)(addr)))) + \
246 (((uint16_t)(*(((uint8_t *)(addr)) + 1))) << 8))
251#ifndef MIN
252#define MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
253#endif
254
255#ifndef MAX
256#define MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
257#endif
258
262#define LBYTE(x) ((uint8_t)(x & 0x00FF))
263#define HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))
276typedef enum
277{
278 USB_OK,
279 USB_FAIL,
280 USB_WAIT,
281 USB_NOT_SUPPORT,
282 USB_ERROR,
283}usb_sts_type;
284
288typedef struct
289{
290 uint8_t bmRequestType;
291 uint8_t bRequest;
292 uint16_t wValue;
293 uint16_t wIndex;
295 uint16_t wLength;
296}usb_setup_type;
297
301typedef struct
302{
303 uint8_t bLength;
304 uint8_t bDescriptorType;
305 uint16_t bcdUSB;
306 uint8_t bDeviceClass;
307 uint8_t bDeviceSubClass;
308 uint8_t bDeviceProtocol;
309 uint8_t bMaxPacketSize0;
310 uint16_t idVendor;
311 uint16_t idProduct;
312 uint16_t bcdDevice;
313 uint8_t iManufacturer;
314 uint8_t iProduct;
315 uint8_t iSerialNumber;
316 uint8_t bNumConfigurations;
317}usb_device_desc_type;
318
322typedef struct
323{
324 uint8_t bLength;
325 uint8_t bDescriptorType;
326 uint16_t wTotalLength;
327 uint8_t bNumInterfaces;
328 uint8_t bConfigurationValue;
329 uint8_t iConfiguration;
330 uint8_t bmAttributes;
335 uint8_t bMaxPower;
338}usb_configuration_desc_type;
339
343typedef struct
344{
345 uint8_t bLength;
346 uint8_t bDescriptorType;
347 uint8_t bInterfaceNumber;
348 uint8_t bAlternateSetting;
349 uint8_t bNumEndpoints;
350 uint8_t bInterfaceClass;
351 uint8_t bInterfaceSubClass;
352 uint8_t bInterfaceProtocol;
353 uint8_t iInterface;
354}usb_interface_desc_type;
355
359typedef struct
360{
361 uint8_t bLength;
362 uint8_t bDescriptorType;
363 uint8_t bEndpointAddress;
364 uint8_t bmAttributes;
365 uint16_t wMaxPacketSize;
366 uint8_t bInterval;
367}usb_endpoint_desc_type;
368
372typedef struct
373{
374 uint8_t bLength;
375 uint8_t bDescriptorType;
376}usb_header_desc_type;
377
378
390#ifdef __cplusplus
391}
392#endif
393
394#endif
395
usbd_conn_state
usbd_conn_state
usb device connect state
Definition: usb_std.h:126
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:130
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:127
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
USB_CONN_STATE_ADDRESSED
@ USB_CONN_STATE_ADDRESSED
Definition: usb_std.h:128
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
USB_WAIT
@ USB_WAIT
Definition: usb_std.h:281
USB_ERROR
@ USB_ERROR
Definition: usb_std.h:283
USB_NOT_SUPPORT
@ USB_NOT_SUPPORT
Definition: usb_std.h:282
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:280
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:211
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:212
linecoding_type::data
uint8_t data
Definition: usb_std.h:215
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:214
linecoding_type::format
uint8_t format
Definition: usb_std.h:213
usb_configuration_desc_type
format of standard configuration descriptor
Definition: usb_std.h:324
usb_device_desc_type
format of standard device descriptor
Definition: usb_std.h:303
usb_endpoint_desc_type
format of standard endpoint descriptor
Definition: usb_std.h:361
usb_header_desc_type
format of header
Definition: usb_std.h:374
usb_interface_desc_type
format of standard interface descriptor
Definition: usb_std.h:345
usb_setup_type
format of usb setup data
Definition: usb_std.h:290


AT32F413 Firmwary Library: usbd_core.c Source File

  • middlewares
  • usbd_drivers
  • src
usbd_core.c
Go to the documentation of this file.
1
24#include "usbd_core.h"
25#include "usbd_sdr.h"
26
46void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_addr)
47{
48 /* get endpoint info*/
49 usb_ept_info *ept_info = &udev->ept_in[ept_addr & 0x7F];
50
51 if(ept_addr == 0)
52 {
53 /* endpoint 0 */
54 if(udev->ept0_sts == USB_EPT0_DATA_IN)
55 {
56 if(ept_info->rem0_len > ept_info->maxpacket)
57 {
58 ept_info->rem0_len -= ept_info->maxpacket;
59 usbd_ept_send(udev, 0, ept_info->trans_buf,
60 MIN(ept_info->rem0_len, ept_info->maxpacket));
61 }
62 /* endpoint 0 */
63 else if(ept_info->last_len == ept_info->maxpacket
64 && ept_info->ept0_slen >= ept_info->maxpacket
65 && ept_info->ept0_slen < udev->ept0_wlength)
66 {
67 ept_info->last_len = 0;
68 usbd_ept_send(udev, 0, 0, 0);
69 usbd_ept_recv(udev, ept_addr, 0, 0);
70 }
71 else
72 {
73
74 if(udev->class_handler->ept0_tx_handler != 0 &&
75 udev->conn_state == USB_CONN_STATE_CONFIGURED)
76 {
77 udev->class_handler->ept0_tx_handler(udev);
78 }
79 usbd_ctrl_recv_status(udev);
80
81 }
82 }
83 }
84 else if(udev->class_handler->in_handler != 0 &&
85 udev->conn_state == USB_CONN_STATE_CONFIGURED)
86 {
87 /* other user define endpoint */
88 udev->class_handler->in_handler(udev, ept_addr);
89 }
90}
91
98void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_addr)
99{
100 /* get endpoint info*/
101 usb_ept_info *ept_info = &udev->ept_out[ept_addr & 0x7F];
102
103 if(ept_addr == 0)
104 {
105 /* endpoint 0 */
106 if(udev->ept0_sts == USB_EPT0_DATA_OUT)
107 {
108 if(ept_info->rem0_len > ept_info->maxpacket)
109 {
110 ept_info->rem0_len -= ept_info->maxpacket;
111 usbd_ept_recv(udev, ept_addr, ept_info->trans_buf,
112 MIN(ept_info->rem0_len, ept_info->maxpacket));
113 }
114 else
115 {
116 if(udev->class_handler->ept0_rx_handler != 0)
117 {
118 udev->class_handler->ept0_rx_handler(udev);
119 }
120 usbd_ctrl_send_status(udev);
121 }
122 }
123 }
124 else if(udev->class_handler->out_handler != 0 &&
125 udev->conn_state == USB_CONN_STATE_CONFIGURED)
126 {
127 /* other user define endpoint */
128 udev->class_handler->out_handler(udev, ept_addr);
129 }
130}
131
138void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
139{
140 /* setup parse */
141 usbd_setup_request_parse(&udev->setup, udev->setup_buffer);
142
143 /* set ept0 status */
144 udev->ept0_sts = USB_EPT0_SETUP;
145 udev->ept0_wlength = udev->setup.wLength;
146
147 switch(udev->setup.bmRequestType & USB_REQ_RECIPIENT_MASK)
148 {
149 case USB_REQ_RECIPIENT_DEVICE:
150 /* recipient device request */
151 usbd_device_request(udev);
152 break;
153 case USB_REQ_RECIPIENT_INTERFACE:
154 /* recipient interface request */
155 usbd_interface_request(udev);
156 break;
157 case USB_REQ_RECIPIENT_ENDPOINT:
158 /* recipient endpoint request */
159 usbd_endpoint_request(udev);
160 break;
161 default:
162 break;
163 }
164}
165
174void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
175{
176 usb_ept_info *ept_info = &udev->ept_in[0];
177
178 ept_info->ept0_slen = len;
179 ept_info->rem0_len = len;
180 udev->ept0_sts = USB_EPT0_DATA_IN;
181
182 usbd_ept_send(udev, 0, buffer, len);
183}
184
193void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
194{
195 usb_ept_info *ept_info = &udev->ept_out[0];
196
197 ept_info->ept0_slen = len;
198 ept_info->rem0_len = len;
199 udev->ept0_sts = USB_EPT0_DATA_OUT;
200
201 usbd_ept_recv(udev, 0, buffer, len);
202}
203
209void usbd_ctrl_send_status(usbd_core_type *udev)
210{
211 udev->ept0_sts = USB_EPT0_STATUS_IN;
212
213 usbd_ept_send(udev, 0, 0, 0);
214}
215
221void usbd_ctrl_recv_status(usbd_core_type *udev)
222{
223 udev->ept0_sts = USB_EPT0_STATUS_OUT;
224
225 usbd_ept_recv(udev, 0, 0, 0);
226}
227
234void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
235{
236 usb_ept_info *ept_info;
237
238 if(ept_addr & 0x80)
239 {
240 /* in endpoint */
241 ept_info = &udev->ept_in[ept_addr & 0x7F];
242 USB_SET_TXSTS(ept_info->eptn, USB_TX_VALID);
243 }
244 else
245 {
246 /* out endpoint */
247 ept_info = &udev->ept_out[ept_addr & 0x7F];
248 USB_SET_RXSTS(ept_info->eptn, USB_RX_VALID);
249 }
250 ept_info->stall = 0;
251}
252
259void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
260{
261 usb_ept_info *ept_info;
262
263 if(ept_addr & 0x80)
264 {
265 /* in endpoint */
266 ept_info = &udev->ept_in[ept_addr & 0x7F];
267 USB_SET_TXSTS(ept_info->eptn, USB_TX_STALL);
268 }
269 else
270 {
271 /* out endpoint */
272 ept_info = &udev->ept_out[ept_addr & 0x7F];
273 USB_SET_RXSTS(ept_info->eptn, USB_RX_STALL)
274 }
275
276 ept_info->stall = 1;
277}
278
284void usbd_ctrl_unsupport(usbd_core_type *udev)
285{
286 /* return stall status */
287 usbd_set_stall(udev, 0x00);
288 usbd_set_stall(udev, 0x80);
289}
290
299void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
300{
301 /* get endpoint info struct and register */
302 usb_ept_info *ept_info = &udev->ept_in[ept_addr & 0x7F];
303 uint16_t trs_len = 0;
304 usbd_type *usbx = udev->usb_reg;
305
306 /* set send data buffer and length */
307 ept_info->trans_buf = buffer;
308 ept_info->total_len = len;
309 ept_info->trans_len = 0;
310
311 if(ept_info->total_len > ept_info->maxpacket)
312 {
313 trs_len = ept_info->maxpacket;
314 ept_info->total_len -= trs_len;
315 }
316 else
317 {
318 trs_len = len;
319 ept_info->total_len = 0;
320 }
321
322 ept_info->last_len = trs_len;
323
324 if(ept_info->is_double_buffer == 0)
325 {
326 /* write data to endpoint buffer */
327 usb_write_packet(ept_info->trans_buf, ept_info->tx_addr, trs_len);
328
329 /* set send data length */
330 USB_SET_TXLEN((ept_addr & 0x7F), trs_len);
331 }
332 else
333 {
334 if(usbx->ept_bit[ept_addr & 0x7F].txdts)
335 {
336 USB_SET_EPT_DOUBLE_BUF1_LEN((ept_addr & 0x7F), trs_len, DATA_TRANS_IN);
337 usb_write_packet(ept_info->trans_buf, ept_info->rx_addr, trs_len);
338 }
339 else
340 {
341 USB_SET_EPT_DOUBLE_BUF0_LEN((ept_addr & 0x7F), trs_len, DATA_TRANS_IN);
342 usb_write_packet(ept_info->trans_buf, ept_info->tx_addr, trs_len);
343 }
344 USB_FREE_DB_USER_BUFFER((ept_addr & 0x7F), DATA_TRANS_IN);
345 }
346
347 /* set tx status valid */
348 USB_SET_TXSTS((ept_addr & 0x7F), USB_TX_VALID);
349}
350
359void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
360{
361 /* get endpoint info struct and register */
362 usb_ept_info *ept_info = &udev->ept_out[ept_addr & 0x7F];
363 uint32_t trs_len = 0;
364
365 /* set receive data buffer and length */
366 ept_info->trans_buf = buffer;
367 ept_info->total_len = len;
368 ept_info->trans_len = 0;
369
370 if(ept_info->total_len > ept_info->maxpacket)
371 {
372 trs_len = ept_info->maxpacket;
373 ept_info->total_len -= trs_len;
374 }
375 else
376 {
377 trs_len = len;
378 ept_info->total_len = 0;
379 }
380
381 /* set rx status valid */
382 USB_SET_RXSTS((ept_addr & 0x7F), USB_RX_VALID);
383}
384
385
392uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
393{
394 usb_ept_info *ept = &udev->ept_out[ept_addr & 0x7F];
395 return ept->trans_len;
396}
397
404void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
405{
406 usb_ept_info *ept_info;
407 if((ept_addr & 0x80) == 0)
408 {
409 /* out endpoint info */
410 ept_info = &udev->ept_out[ept_addr & 0x7F];
411 }
412 else
413 {
414 /* in endpoint info */
415 ept_info = &udev->ept_in[ept_addr & 0x7F];
416 }
417 ept_info->is_double_buffer = TRUE;
418}
419
425void usbd_ept_buf_auto_define(usb_ept_info *ept_info)
426{
427 if(ept_info->is_double_buffer == 0)
428 {
429 if( ept_info->inout == DATA_TRANS_IN )
430 {
431 if(ept_info->tx_addr == 0)
432 ept_info->tx_addr = usb_buffer_malloc(ept_info->maxpacket);
433 }
434 else
435 {
436 if(ept_info->rx_addr == 0)
437 ept_info->rx_addr = usb_buffer_malloc(ept_info->maxpacket);
438 }
439 }
440 else
441 {
442 /* double buffer auto define */
443 if(ept_info->tx_addr == 0)
444 ept_info->tx_addr = usb_buffer_malloc(ept_info->maxpacket);
445 if(ept_info->rx_addr == 0)
446 ept_info->rx_addr = usb_buffer_malloc(ept_info->maxpacket);
447 }
448}
449
450
451
459void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr,
460 uint32_t addr)
461{
462 usb_ept_info *ept_info;
463 if((ept_addr & 0x80) == 0)
464 {
465 /* out endpoint info */
466 ept_info = &udev->ept_out[ept_addr & 0x7F];
467 }
468 else
469 {
470 /* in endpoint info */
471 ept_info = &udev->ept_in[ept_addr & 0x7F];
472 }
473
474 if(ept_info->is_double_buffer == 0)
475 {
476 if( ept_info->inout == DATA_TRANS_IN )
477 {
478 ept_info->tx_addr = addr;
479 }
480 else
481 {
482 ept_info->rx_addr = addr;
483 }
484 }
485 else
486 {
487 /* double buffer malloc */
488 ept_info->tx_addr = addr & 0xFFFF;
489 ept_info->rx_addr = (addr >> 16) & 0xFFFF;
490 }
491}
492
501void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
502{
503 usbd_type *usbx = udev->usb_reg;
504 usb_ept_info *ept_info;
505
506 if((ept_addr & 0x80) == 0)
507 {
508 /* out endpoint info */
509 ept_info = &udev->ept_out[ept_addr & 0x7F];
510 ept_info->inout = DATA_TRANS_OUT;
511 }
512 else
513 {
514 /* in endpoint info */
515 ept_info = &udev->ept_in[ept_addr & 0x7F];
516 ept_info->inout = DATA_TRANS_IN;
517 }
518
519 /* set endpoint maxpacket and type */
520 ept_info->maxpacket = (maxpacket + 1) & 0xFFFE;
521 ept_info->trans_type = ept_type;
522
523#ifdef USB_EPT_AUTO_MALLOC_BUFFER
524 usbd_ept_buf_auto_define(ept_info);
525#endif
526 /* open endpoint */
527 usb_ept_open(usbx, ept_info);
528}
529
536void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
537{
538 usb_ept_info *ept_info;
539 if(ept_addr & 0x80)
540 {
541 /* in endpoint */
542 ept_info = &udev->ept_in[ept_addr & 0x7F];
543 }
544 else
545 {
546 /* out endpoint */
547 ept_info = &udev->ept_out[ept_addr & 0x7F];
548 }
549
550 /* close endpoint */
551 usb_ept_close(udev->usb_reg, ept_info);
552}
553
559void usbd_connect(usbd_core_type *udev)
560{
561 usb_connect(udev->usb_reg);
562}
563
569void usbd_disconnect(usbd_core_type *udev)
570{
571 usb_disconnect(udev->usb_reg);
572}
573
580void usbd_set_device_addr(usbd_core_type *udev, uint8_t address)
581{
582 usb_set_address(udev->usb_reg, address);
583}
584
590 usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
591{
592 return udev->conn_state;
593}
594
600void usbd_remote_wakeup(usbd_core_type *udev)
601{
602 /* set connect state */
603 udev->conn_state = udev->old_conn_state;
604
605 usb_exit_suspend(udev->usb_reg);
606
607 usb_remote_wkup_set(udev->usb_reg);
608
609 usb_delay_ms(10);
610
611 usb_remote_wkup_clear(udev->usb_reg);
612
613}
614
620void usbd_enter_suspend(usbd_core_type *udev)
621{
622 usb_enter_suspend(udev->usb_reg);
623}
624
630void usbd_ept_defaut_init(usbd_core_type *udev)
631{
632 uint8_t i_index = 0;
633 /* init in endpoint info structure */
634 for(i_index = 0; i_index < USB_EPT_MAX_NUM; i_index ++)
635 {
636 udev->ept_in[i_index].eptn = i_index;
637 udev->ept_in[i_index].ept_address = i_index;
638 udev->ept_in[i_index].inout = DATA_TRANS_IN;
639 udev->ept_in[i_index].maxpacket = 0;
640 udev->ept_in[i_index].trans_buf = 0;
641 udev->ept_in[i_index].total_len = 0;
642 udev->ept_in[i_index].tx_addr = 0;
643 udev->ept_in[i_index].rx_addr = 0;
644 }
645
646 /* init out endpoint info structure */
647 for(i_index = 0; i_index < USB_EPT_MAX_NUM; i_index ++)
648 {
649 udev->ept_out[i_index].eptn = i_index;
650 udev->ept_out[i_index].ept_address = i_index;
651 udev->ept_out[i_index].inout = DATA_TRANS_OUT;
652 udev->ept_out[i_index].maxpacket = 0;
653 udev->ept_out[i_index].trans_buf = 0;
654 udev->ept_out[i_index].total_len = 0;
655 udev->ept_out[i_index].rx_addr = 0;
656 udev->ept_out[i_index].tx_addr = 0;
657 }
658 return;
659}
660
670void usbd_core_init(usbd_core_type *udev,
671 usb_reg_type *usb_reg,
672 usbd_class_handler *class_handler,
673 usbd_desc_handler *desc_handler,
674 uint8_t core_id)
675{
676 /* usb class handler */
677 udev->class_handler = class_handler;
678
679 /* usb description handler */
680 udev->desc_handler = desc_handler;
681
682 /* set usb register type */
683 udev->usb_reg = usb_reg;
684
685 /* set usb connect state to default */
686 udev->conn_state = USB_CONN_STATE_DEFAULT;
687
688 /* init in endpoint info structure */
689 usbd_ept_defaut_init(udev);
690
691#ifdef USB_BUFFER_SIZE_EX
692 /* usb buffer size extend 768-1280 byte */
693 usb_usbbufs_enable(usb_reg, TRUE);
694#endif
695
696 /*usb register config */
697 usb_dev_init(udev->usb_reg);
698}
699
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
TRUE
@ TRUE
Definition: at32f413.h:296
USB_RX_STALL
#define USB_RX_STALL
Definition: at32f413_usb.h:123
USB_TX_VALID
#define USB_TX_VALID
Definition: at32f413_usb.h:117
USB_TX_STALL
#define USB_TX_STALL
Definition: at32f413_usb.h:115
USB_RX_VALID
#define USB_RX_VALID
Definition: at32f413_usb.h:125
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:221
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:222
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:439
usb_write_packet
void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f413_usb.c:314
usb_disconnect
void usb_disconnect(usbd_type *usbx)
disconnect usb device
Definition: at32f413_usb.c:91
usb_enter_suspend
void usb_enter_suspend(usbd_type *usbx)
usb device enter suspend mode
Definition: at32f413_usb.c:427
usb_remote_wkup_clear
void usb_remote_wkup_clear(usbd_type *usbx)
usb remote wakeup clear
Definition: at32f413_usb.c:462
usb_usbbufs_enable
void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area,...
Definition: at32f413_usb.c:114
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:396
usb_buffer_malloc
uint16_t usb_buffer_malloc(uint16_t maxpacket)
usb auto malloc endpoint buffer
Definition: at32f413_usb.c:472
usb_remote_wkup_set
void usb_remote_wkup_set(usbd_type *usbx)
usb remote wakeup set
Definition: at32f413_usb.c:451
usb_connect
void usb_connect(usbd_type *usbx)
connect usb device
Definition: at32f413_usb.c:79
usb_ept_open
void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f413_usb.c:137
usb_dev_init
void usb_dev_init(usbd_type *usbx)
initialize usb peripheral controller register
Definition: at32f413_usb.c:56
usb_ept_close
void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f413_usb.c:256
USB_SET_EPT_DOUBLE_BUF1_LEN
#define USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length
Definition: at32f413_usb.h:375
USB_SET_RXSTS
#define USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status
Definition: at32f413_usb.h:262
USB_FREE_DB_USER_BUFFER
#define USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application
Definition: at32f413_usb.h:460
USB_SET_TXLEN
#define USB_SET_TXLEN(eptn, len)
set endpoint tx/rx transfer length
Definition: at32f413_usb.h:333
USB_SET_TXSTS
#define USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status
Definition: at32f413_usb.h:247
USB_SET_EPT_DOUBLE_BUF0_LEN
#define USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length
Definition: at32f413_usb.h:357
USB_EPT0_STATUS_OUT
#define USB_EPT0_STATUS_OUT
Definition: usb_std.h:141
usbd_conn_state
usbd_conn_state
usb device connect state
Definition: usb_std.h:126
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_EPT0_DATA_IN
#define USB_EPT0_DATA_IN
Definition: usb_std.h:138
USB_REQ_RECIPIENT_DEVICE
#define USB_REQ_RECIPIENT_DEVICE
usb request recipient
Definition: usb_std.h:52
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:56
USB_EPT0_DATA_OUT
#define USB_EPT0_DATA_OUT
Definition: usb_std.h:139
USB_EPT0_SETUP
#define USB_EPT0_SETUP
Definition: usb_std.h:137
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:54
USB_EPT0_STATUS_IN
#define USB_EPT0_STATUS_IN
Definition: usb_std.h:140
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:53
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:127
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:259
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:404
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:209
usbd_set_device_addr
void usbd_set_device_addr(usbd_core_type *udev, uint8_t address)
usb device set device address.
Definition: usbd_core.c:580
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_core_out_handler
void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler
Definition: usbd_core.c:98
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_ctrl_recv_status
void usbd_ctrl_recv_status(usbd_core_type *udev)
usb control endpoint send out status
Definition: usbd_core.c:221
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_core_in_handler
void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler
Definition: usbd_core.c:46
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_clear_stall
void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall
Definition: usbd_core.c:234
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:600
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_ept_defaut_init
void usbd_ept_defaut_init(usbd_core_type *udev)
usb endpoint structure initialization
Definition: usbd_core.c:630
usbd_ept_buf_auto_define
void usbd_ept_buf_auto_define(usb_ept_info *ept_info)
usb auto define endpoint buffer
Definition: usbd_core.c:425
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_enter_suspend
void usbd_enter_suspend(usbd_core_type *udev)
usb device enter suspend mode
Definition: usbd_core.c:620
usbd_disconnect
void usbd_disconnect(usbd_core_type *udev)
usb device disconnect to host
Definition: usbd_core.c:569
usbd_core_setup_handler
void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler
Definition: usbd_core.c:138
usbd_endpoint_request
usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
standard usb endpoint requests
Definition: usbd_sdr.c:419
usbd_setup_request_parse
void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request
Definition: usbd_sdr.c:53
usbd_device_request
usb_sts_type usbd_device_request(usbd_core_type *udev)
standard usb device requests
Definition: usbd_sdr.c:348
usbd_interface_request
usb_sts_type usbd_interface_request(usbd_core_type *udev)
standard usb interface requests
Definition: usbd_sdr.c:392
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:499
usb_ept_info::total_len
uint16_t total_len
Definition: at32f413_usb.h:513
usb_ept_info::ept_address
uint8_t ept_address
Definition: at32f413_usb.h:501
usb_ept_info::trans_len
uint16_t trans_len
Definition: at32f413_usb.h:514
usb_ept_info::inout
uint8_t inout
Definition: at32f413_usb.h:502
usb_ept_info::maxpacket
uint16_t maxpacket
Definition: at32f413_usb.h:507
usb_ept_info::ept0_slen
uint16_t ept0_slen
Definition: at32f413_usb.h:519
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:506
usb_ept_info::trans_buf
uint8_t * trans_buf
Definition: at32f413_usb.h:515
usb_ept_info::stall
uint8_t stall
Definition: at32f413_usb.h:509
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:508
usb_ept_info::last_len
uint16_t last_len
Definition: at32f413_usb.h:517
usb_ept_info::rem0_len
uint16_t rem0_len
Definition: at32f413_usb.h:518
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:505
usb_ept_info::eptn
uint8_t eptn
Definition: at32f413_usb.h:500
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f413_usb.h:503
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::out_handler
usb_sts_type(* out_handler)(void *udev, uint8_t ept_num)
Definition: usbd_core.h:98
usbd_class_handler::ept0_tx_handler
usb_sts_type(* ept0_tx_handler)(void *udev)
Definition: usbd_core.h:95
usbd_class_handler::ept0_rx_handler
usb_sts_type(* ept0_rx_handler)(void *udev)
Definition: usbd_core.h:96
usbd_class_handler::in_handler
usb_sts_type(* in_handler)(void *udev, uint8_t ept_num)
Definition: usbd_core.h:97
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:124
usbd_core_type::setup_buffer
uint8_t setup_buffer[12]
Definition: usbd_core.h:118
usbd_core_type::ept0_wlength
uint16_t ept0_wlength
Definition: usbd_core.h:122
usbd_core_type::ept0_sts
uint8_t ept0_sts
Definition: usbd_core.h:120
usbd_core_type::old_conn_state
usbd_conn_state old_conn_state
Definition: usbd_core.h:125
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core_type::ept_in
usb_ept_info ept_in[USB_EPT_MAX_NUM]
Definition: usbd_core.h:114
usbd_core_type::ept_out
usb_ept_info ept_out[USB_EPT_MAX_NUM]
Definition: usbd_core.h:115
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:117
usbd_core_type::usb_reg
usb_reg_type * usb_reg
Definition: usbd_core.h:109
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:112
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_type
type define usb register all
Definition: at32f413_usb.h:526
usbd_type::ept_bit
struct usbd_type::@734::@748 ept_bit[8]
usbd_type::txdts
__IO uint32_t txdts
Definition: at32f413_usb.h:537
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: usbd_core.h Source File

  • middlewares
  • usbd_drivers
  • inc
usbd_core.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USBD_CORE_H
27#define __USBD_CORE_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34#include "usb_conf.h"
35#include "usb_std.h"
36
52typedef enum
53{
54 USBD_NOP_EVENT,
55 USBD_RESET_EVENT,
56 USBD_SUSPEND_EVENT,
57 USBD_WAKEUP_EVENT,
58 USBD_ERR_EVENT
59}usbd_event_type;
60
64typedef struct
65{
66 uint16_t length;
67 uint8_t *descriptor;
68}usbd_desc_t;
69
73typedef struct
74{
75 usbd_desc_t *(*get_device_descriptor)(void);
76 usbd_desc_t *(*get_device_qualifier)(void);
77 usbd_desc_t *(*get_device_configuration)(void);
78 usbd_desc_t *(*get_device_other_speed)(void);
79 usbd_desc_t *(*get_device_lang_id)(void);
80 usbd_desc_t *(*get_device_manufacturer_string)(void);
81 usbd_desc_t *(*get_device_product_string)(void);
82 usbd_desc_t *(*get_device_serial_string)(void);
83 usbd_desc_t *(*get_device_interface_string)(void);
84 usbd_desc_t *(*get_device_config_string)(void);
85}usbd_desc_handler;
86
90typedef struct
91{
92 usb_sts_type (*init_handler)(void *udev);
93 usb_sts_type (*clear_handler)(void *udev);
94 usb_sts_type (*setup_handler)(void *udev, usb_setup_type *setup);
95 usb_sts_type (*ept0_tx_handler)(void *udev);
96 usb_sts_type (*ept0_rx_handler)(void *udev);
97 usb_sts_type (*in_handler)(void *udev, uint8_t ept_num);
98 usb_sts_type (*out_handler)(void *udev, uint8_t ept_num);
99 usb_sts_type (*sof_handler)(void *udev);
100 usb_sts_type (*event_handler)(void *udev, usbd_event_type event);
101 void *pdata;
102}usbd_class_handler;
103
107typedef struct
108{
109 usb_reg_type *usb_reg;
111 usbd_class_handler *class_handler;
112 usbd_desc_handler *desc_handler;
114 usb_ept_info ept_in[USB_EPT_MAX_NUM];
115 usb_ept_info ept_out[USB_EPT_MAX_NUM];
117 usb_setup_type setup;
118 uint8_t setup_buffer[12];
120 uint8_t ept0_sts;
121 uint8_t speed;
122 uint16_t ept0_wlength;
124 usbd_conn_state conn_state;
125 usbd_conn_state old_conn_state;
127 uint8_t device_addr;
128 uint8_t remote_wakup;
129 uint8_t default_config;
130 uint8_t dev_config;
131 uint16_t config_status;
132}usbd_core_type;
133
141void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_num);
142void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_num);
143void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num);
144void usbd_ctrl_unsupport(usbd_core_type *udev);
145void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len);
146void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len);
147void usbd_ctrl_send_status(usbd_core_type *udev);
148void usbd_ctrl_recv_status(usbd_core_type *udev);
149void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr);
150void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr);
151void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket);
152void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr);
153void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len);
154void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len);
155void usbd_connect(usbd_core_type *udev);
156void usbd_disconnect(usbd_core_type *udev);
157void usbd_set_device_addr(usbd_core_type *udev, uint8_t address);
158uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr);
159 usbd_conn_state usbd_connect_state_get(usbd_core_type *udev);
160void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr);
161void usbd_ept_buf_auto_define(usb_ept_info *ept_info);
162void usbd_ept_buf_custom_define( usbd_core_type *udev, uint8_t ept_addr,
163 uint32_t addr);
164void usbd_ept_defaut_init(usbd_core_type *udev);
165void usbd_remote_wakeup(usbd_core_type *udev);
166void usbd_enter_suspend(usbd_core_type *udev);
167void usbd_core_init(usbd_core_type *udev,
168 usb_reg_type *usb_reg,
169 usbd_class_handler *dev_handler,
170 usbd_desc_handler *desc_handler,
171 uint8_t core_id);
172
173
186#ifdef __cplusplus
187}
188#endif
189
190#endif
191
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
usbd_conn_state
usbd_conn_state
usb device connect state
Definition: usb_std.h:126
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:590
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:259
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:404
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:536
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:209
usbd_set_device_addr
void usbd_set_device_addr(usbd_core_type *udev, uint8_t address)
usb device set device address.
Definition: usbd_core.c:580
usbd_core_in_handler
void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler
Definition: usbd_core.c:46
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_ctrl_recv_status
void usbd_ctrl_recv_status(usbd_core_type *udev)
usb control endpoint send out status
Definition: usbd_core.c:221
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_core_out_handler
void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler
Definition: usbd_core.c:98
usbd_clear_stall
void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall
Definition: usbd_core.c:234
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:392
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:600
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_ept_defaut_init
void usbd_ept_defaut_init(usbd_core_type *udev)
usb endpoint structure initialization
Definition: usbd_core.c:630
usbd_ept_buf_auto_define
void usbd_ept_buf_auto_define(usb_ept_info *ept_info)
usb auto define endpoint buffer
Definition: usbd_core.c:425
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:193
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_enter_suspend
void usbd_enter_suspend(usbd_core_type *udev)
usb device enter suspend mode
Definition: usbd_core.c:620
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_disconnect
void usbd_disconnect(usbd_core_type *udev)
usb device disconnect to host
Definition: usbd_core.c:569
usbd_core_setup_handler
void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler
Definition: usbd_core.c:138
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:53
USBD_ERR_EVENT
@ USBD_ERR_EVENT
Definition: usbd_core.h:58
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
USBD_NOP_EVENT
@ USBD_NOP_EVENT
Definition: usbd_core.h:54
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:499
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usbd_class_handler
usb device class handler
Definition: usbd_core.h:91
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:124
usbd_core_type::default_config
uint8_t default_config
Definition: usbd_core.h:129
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:128
usbd_core_type::ept0_wlength
uint16_t ept0_wlength
Definition: usbd_core.h:122
usbd_core_type::ept0_sts
uint8_t ept0_sts
Definition: usbd_core.h:120
usbd_core_type::old_conn_state
usbd_conn_state old_conn_state
Definition: usbd_core.h:125
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core_type::config_status
uint16_t config_status
Definition: usbd_core.h:131
usbd_core_type::speed
uint8_t speed
Definition: usbd_core.h:121
usbd_core_type::dev_config
uint8_t dev_config
Definition: usbd_core.h:130
usbd_core_type::device_addr
uint8_t device_addr
Definition: usbd_core.h:127
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:117
usbd_core_type::usb_reg
usb_reg_type * usb_reg
Definition: usbd_core.h:109
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:112
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:74
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usbd_type
type define usb register all
Definition: at32f413_usb.h:526
usb_std.h
usb standard header file


AT32F413 Firmwary Library: usbd_int.c Source File

  • middlewares
  • usbd_drivers
  • src
usbd_int.c
Go to the documentation of this file.
1
24#include "usbd_int.h"
25
44void usbd_irq_handler(usbd_core_type *udev)
45{
46 usbd_type *usbx = udev->usb_reg;
47 uint32_t sts_val = usbx->intsts;
48 uint32_t sts_ien = usbx->ctrl;
49
50 if(sts_val & USB_TC_FLAG)
51 {
52 /* endpoint tc interrupt handler */
53 usbd_ept_loop_handler(udev);
54 }
55
56 if(sts_val & USB_RST_FLAG)
57 {
58 /* clear reset flag */
59 usb_flag_clear(usbx, USB_RST_FLAG);
60
61 /* reset interrupt handler */
62 usbd_reset_handler(udev);
63 }
64
65 if((sts_val & USB_SOF_FLAG) &&
66 (sts_ien & USB_SOF_INT))
67 {
68 /* clear sof flag */
69 usb_flag_clear(usbx, USB_SOF_FLAG);
70
71 /* sof interrupt handler */
72 usbd_sof_handler(udev);
73 }
74
75 if((sts_val & USB_LSOF_FLAG) &&
76 (sts_ien & USB_LSOF_INT))
77 {
78 /* clear lsof flag */
79 usb_flag_clear(usbx, USB_LSOF_FLAG);
80 }
81
82 if((sts_val & USB_SP_FLAG) &&
83 (sts_ien & USB_SP_INT))
84 {
85 /* clear suspend flag */
86 usb_flag_clear(usbx, USB_SP_FLAG);
87
88 /* usb suspend interrupt handler */
89 usbd_suspend_handler(udev);
90 }
91
92 if((sts_val & USB_WK_FLAG) &&
93 (sts_ien & USB_WK_INT))
94 {
95 /* usb wakeup interrupt handler */
96 usbd_wakeup_handler(udev);
97
98 /* clear wakeup flag */
99 usb_flag_clear(usbx, USB_WK_FLAG);
100 }
101}
102
109void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num)
110{
111 usbd_type *usbx = udev->usb_reg;
112 usb_ept_info *ept_info;
113 uint32_t ept_val = usbx->ept[ept_num];
114 uint16_t length;
115
116 /* in interrupt request */
117 if(ept_val & USB_TXTC)
118 {
119 /* get endpoint register and in transfer info struct */
120 ept_info = &udev->ept_in[ept_num];
121
122 /* clear endpoint tc flag */
123 USB_CLEAR_TXTC(ept_num);
124
125 /* get endpoint tx length */
126 ept_info->trans_len = USB_GET_TX_LEN(ept_num);
127
128 /* offset the trans buffer */
129 ept_info->trans_buf += ept_info->trans_len;
130
131 if(ept_info->total_len == 0 || ept_num == USB_EPT0)
132 {
133 /* in transfer complete */
134 usbd_core_in_handler(udev, ept_num);
135 }
136 else
137 {
138 /* endpoint continue send data */
139 usbd_ept_send(udev, ept_num, ept_info->trans_buf, ept_info->total_len);
140 }
141 /* set the host assignment address */
142 if(udev->conn_state == USB_CONN_STATE_ADDRESSED && udev->device_addr > 0)
143 {
144 usb_set_address(udev->usb_reg, udev->device_addr);
145 udev->device_addr = 0;
146 }
147 }
148 else
149 {
150 /* setup and out interrupt request */
151
152 /* get endpoint register and out transfer info struct */
153 ept_info = &udev->ept_out[ept_num];
154
155 if((ept_val & USB_SETUPTC) != 0)
156 {
157 /* endpoint setup interrupt request */
158
159 /* get endpoint received data length */
160 ept_info->trans_len = USB_GET_RX_LEN(ept_num);
161
162 /* read endpoint received data */
163 usb_read_packet(udev->setup_buffer, ept_info->rx_addr, ept_info->trans_len);
164
165 /* clear endpoint rx tc flag */
166 USB_CLEAR_RXTC(USB_EPT0);
167
168 /* endpoint setup complete handler */
169 usbd_core_setup_handler(udev, ept_num);
170 }
171 else if(ept_val & USB_RXTC )
172 {
173 /* endpoint out interrupt request */
174 USB_CLEAR_RXTC(ept_num);
175
176 if(ept_info->is_double_buffer == 0)
177 {
178 /* get endpoint received data length */
179 length = USB_GET_RX_LEN(ept_num);
180
181 /* read endpoint received data */
182 usb_read_packet(ept_info->trans_buf, ept_info->rx_addr, length);
183 }
184 else
185 {
186 if( ept_val & USB_RXDTS)
187 {
188 length = USB_DBUF0_GET_LEN(ept_num);
189 usb_read_packet(ept_info->trans_buf, ept_info->tx_addr, length);
190 }
191 else
192 {
193 length = USB_DBUF1_GET_LEN(ept_num);
194 usb_read_packet(ept_info->trans_buf, ept_info->rx_addr, length);
195 }
196 USB_FREE_DB_USER_BUFFER(ept_num, DATA_TRANS_OUT);
197 }
198
199 /* set received data length */
200 ept_info->trans_len += length;
201 ept_info->trans_buf += length;
202
203 if(ept_info->total_len == 0 || length < ept_info->maxpacket || ept_num == USB_EPT0)
204 {
205 /* out transfer complete */
206 usbd_core_out_handler(udev, ept_num);
207 }
208 else
209 {
210 /* endpoint continue receive data */
211 usbd_ept_recv(udev, ept_num, ept_info->trans_buf, ept_info->total_len);
212 }
213 }
214 }
215}
216
222void usbd_ept_loop_handler(usbd_core_type *udev)
223{
224 usbd_type *usbx = udev->usb_reg;
225 usb_ept_number_type ept_num = USB_EPT0;
226 uint32_t sts_val;
227
228 while((sts_val = usbx->intsts) & USB_TC_FLAG)
229 {
230 /* get the interrupt endpoint number */
231 ept_num = (usb_ept_number_type)(sts_val & USB_EPT_NUM_FLAG);
232
233 usbd_eptn_handler(udev, ept_num);
234 }
235}
236
242void usbd_reset_handler(usbd_core_type *udev)
243{
244 /* free usb buffer */
245 usb_buffer_free();
246
247 usbd_ept_defaut_init(udev);
248#ifndef USB_EPT_AUTO_MALLOC_BUFFER
249 usbd_ept_buf_custom_define(udev, 0x80, EPT0_TX_ADDR);
250 usbd_ept_buf_custom_define(udev, 0x00, EPT0_RX_ADDR);
251#endif
252
253 /* open endpoint 0 out */
254 usbd_ept_open(udev, 0x00, EPT_CONTROL_TYPE, 0x40);
255
256 /* open endpoint 0 in */
257 usbd_ept_open(udev, 0x80, EPT_CONTROL_TYPE, 0x40);
258
259 /* set device address to 0 */
260 usb_set_address(udev->usb_reg, 0);
261
262 /* usb connect state set to default */
263 udev->conn_state = USB_CONN_STATE_DEFAULT;
264
265 /* user define reset event */
266 if(udev->class_handler->event_handler)
267 udev->class_handler->event_handler(udev, USBD_RESET_EVENT);
268}
269
275void usbd_sof_handler(usbd_core_type *udev)
276{
277 /* user sof handler in class define*/
278 if(udev->class_handler->sof_handler)
279 udev->class_handler->sof_handler(udev);
280}
281
287void usbd_suspend_handler(usbd_core_type *udev)
288{
289 /* save connect state */
290 udev->old_conn_state = udev->conn_state;
291
292 /* set current state to suspend */
293 udev->conn_state = USB_CONN_STATE_SUSPENDED;
294
295 /* enter suspend mode */
296 usbd_enter_suspend(udev);
297
298 /* user define suspend event */
299 if(udev->class_handler->event_handler)
300 udev->class_handler->event_handler(udev, USBD_SUSPEND_EVENT);
301}
302
308void usbd_wakeup_handler(usbd_core_type *udev)
309{
310 /* exit suspend mode */
311 usb_exit_suspend(udev->usb_reg);
312
313 /* restore connect state */
314 udev->conn_state = udev->old_conn_state;
315
316 /* user define wakeup event */
317 if(udev->class_handler->event_handler)
318 udev->class_handler->event_handler(udev, USBD_WAKEUP_EVENT);
319}
320
EPT0_TX_ADDR
#define EPT0_TX_ADDR
usb endpoint max num define
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:72
EPT0_RX_ADDR
#define EPT0_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:73
USB_RXTC
#define USB_RXTC
Definition: at32f413_usb.h:99
USB_SETUPTC
#define USB_SETUPTC
Definition: at32f413_usb.h:96
USB_RXDTS
#define USB_RXDTS
Definition: at32f413_usb.h:98
USB_TXTC
#define USB_TXTC
Definition: at32f413_usb.h:93
usb_ept_number_type
usb_ept_number_type
usb endpoint number define
Definition: at32f413_usb.h:179
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:221
USB_EPT0
@ USB_EPT0
Definition: at32f413_usb.h:180
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f413_usb.h:201
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:439
usb_buffer_free
void usb_buffer_free(void)
free usb endpoint buffer
Definition: at32f413_usb.c:484
usb_flag_clear
void usb_flag_clear(usbd_type *usbx, uint16_t flag)
clear flag of usb.
Definition: at32f413_usb.c:536
usb_read_packet
void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f413_usb.c:341
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:396
USB_EPT_NUM_FLAG
#define USB_EPT_NUM_FLAG
Definition: at32f413_usb.h:70
USB_SOF_FLAG
#define USB_SOF_FLAG
Definition: at32f413_usb.h:73
USB_WK_FLAG
#define USB_WK_FLAG
Definition: at32f413_usb.h:76
USB_TC_FLAG
#define USB_TC_FLAG
Definition: at32f413_usb.h:79
USB_SP_FLAG
#define USB_SP_FLAG
Definition: at32f413_usb.h:75
USB_RST_FLAG
#define USB_RST_FLAG
Definition: at32f413_usb.h:74
USB_LSOF_FLAG
#define USB_LSOF_FLAG
Definition: at32f413_usb.h:72
USB_SP_INT
#define USB_SP_INT
Definition: at32f413_usb.h:55
USB_WK_INT
#define USB_WK_INT
Definition: at32f413_usb.h:56
USB_LSOF_INT
#define USB_LSOF_INT
Definition: at32f413_usb.h:52
USB_SOF_INT
#define USB_SOF_INT
Definition: at32f413_usb.h:53
USB_GET_TX_LEN
#define USB_GET_TX_LEN(eptn)
get usb endpoint tx/rx data length
Definition: at32f413_usb.h:284
USB_FREE_DB_USER_BUFFER
#define USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application
Definition: at32f413_usb.h:460
USB_DBUF0_GET_LEN
#define USB_DBUF0_GET_LEN(eptn)
double buffer mode get endpoint buf0/buf1 data length
Definition: at32f413_usb.h:292
USB_CLEAR_TXTC
#define USB_CLEAR_TXTC(eptn)
clear tx/rx transfer completed flag
Definition: at32f413_usb.h:476
USB_DBUF1_GET_LEN
#define USB_DBUF1_GET_LEN(eptn)
Definition: at32f413_usb.h:293
USB_CLEAR_RXTC
#define USB_CLEAR_RXTC(eptn)
Definition: at32f413_usb.h:477
USB_GET_RX_LEN
#define USB_GET_RX_LEN(eptn)
Definition: at32f413_usb.h:285
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:130
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:127
USB_CONN_STATE_ADDRESSED
@ USB_CONN_STATE_ADDRESSED
Definition: usb_std.h:128
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:359
usbd_core_in_handler
void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler
Definition: usbd_core.c:46
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:459
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:501
usbd_core_out_handler
void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler
Definition: usbd_core.c:98
usbd_ept_defaut_init
void usbd_ept_defaut_init(usbd_core_type *udev)
usb endpoint structure initialization
Definition: usbd_core.c:630
usbd_enter_suspend
void usbd_enter_suspend(usbd_core_type *udev)
usb device enter suspend mode
Definition: usbd_core.c:620
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:299
usbd_core_setup_handler
void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler
Definition: usbd_core.c:138
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:56
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:55
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:57
usbd_sof_handler
void usbd_sof_handler(usbd_core_type *udev)
usb device sof interrupt request handler.
Definition: usbd_int.c:275
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
usbd_eptn_handler
void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler.
Definition: usbd_int.c:109
usbd_reset_handler
void usbd_reset_handler(usbd_core_type *udev)
usb device reset interrupt request handler.
Definition: usbd_int.c:242
usbd_wakeup_handler
void usbd_wakeup_handler(usbd_core_type *udev)
usb device wakup interrupt request handler.
Definition: usbd_int.c:308
usbd_ept_loop_handler
void usbd_ept_loop_handler(usbd_core_type *udev)
usb device endpoint loop handler.
Definition: usbd_int.c:222
usbd_suspend_handler
void usbd_suspend_handler(usbd_core_type *udev)
usb device suspend interrupt request handler.
Definition: usbd_int.c:287
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:499
usb_ept_info::total_len
uint16_t total_len
Definition: at32f413_usb.h:513
usb_ept_info::trans_len
uint16_t trans_len
Definition: at32f413_usb.h:514
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:506
usb_ept_info::trans_buf
uint8_t * trans_buf
Definition: at32f413_usb.h:515
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:508
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:505
usbd_class_handler::event_handler
usb_sts_type(* event_handler)(void *udev, usbd_event_type event)
Definition: usbd_core.h:100
usbd_class_handler::sof_handler
usb_sts_type(* sof_handler)(void *udev)
Definition: usbd_core.h:99
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:124
usbd_core_type::setup_buffer
uint8_t setup_buffer[12]
Definition: usbd_core.h:118
usbd_core_type::old_conn_state
usbd_conn_state old_conn_state
Definition: usbd_core.h:125
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core_type::ept_in
usb_ept_info ept_in[USB_EPT_MAX_NUM]
Definition: usbd_core.h:114
usbd_core_type::device_addr
uint8_t device_addr
Definition: usbd_core.h:127
usbd_core_type::ept_out
usb_ept_info ept_out[USB_EPT_MAX_NUM]
Definition: usbd_core.h:115
usbd_core_type::usb_reg
usb_reg_type * usb_reg
Definition: usbd_core.h:109
usbd_type
type define usb register all
Definition: at32f413_usb.h:526
usbd_type::intsts
__IO uint32_t intsts
Definition: at32f413_usb.h:582
usbd_type::ept
__IO uint32_t ept[8]
Definition: at32f413_usb.h:532
usbd_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_usb.h:556
usbd_int.h


AT32F413 Firmwary Library: usbd_int.h Source File

  • middlewares
  • usbd_drivers
  • inc
usbd_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_INT_H
27#define __USB_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "usbd_core.h"
36
48void usbd_irq_handler(usbd_core_type *udev);
49void usbd_ept_loop_handler(usbd_core_type *udev);
50void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num);
51void usbd_reset_handler(usbd_core_type *udev);
52void usbd_sof_handler(usbd_core_type *udev);
53void usbd_suspend_handler(usbd_core_type *udev);
54void usbd_wakeup_handler(usbd_core_type *udev);
55
68#ifdef __cplusplus
69}
70#endif
71#endif
72
usb_ept_number_type
usb_ept_number_type
usb endpoint number define
Definition: at32f413_usb.h:179
usbd_sof_handler
void usbd_sof_handler(usbd_core_type *udev)
usb device sof interrupt request handler.
Definition: usbd_int.c:275
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
usbd_eptn_handler
void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler.
Definition: usbd_int.c:109
usbd_reset_handler
void usbd_reset_handler(usbd_core_type *udev)
usb device reset interrupt request handler.
Definition: usbd_int.c:242
usbd_wakeup_handler
void usbd_wakeup_handler(usbd_core_type *udev)
usb device wakup interrupt request handler.
Definition: usbd_int.c:308
usbd_ept_loop_handler
void usbd_ept_loop_handler(usbd_core_type *udev)
usb device endpoint loop handler.
Definition: usbd_int.c:222
usbd_suspend_handler
void usbd_suspend_handler(usbd_core_type *udev)
usb device suspend interrupt request handler.
Definition: usbd_int.c:287
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: usbd_sdr.c Source File

  • middlewares
  • usbd_drivers
  • src
usbd_sdr.c
Go to the documentation of this file.
1
24#include "usbd_sdr.h"
25
39static usb_sts_type usbd_get_descriptor(usbd_core_type *udev);
40static usb_sts_type usbd_set_address(usbd_core_type *udev);
41static usb_sts_type usbd_get_status(usbd_core_type *udev);
42static usb_sts_type usbd_clear_feature(usbd_core_type *udev);
43static usb_sts_type usbd_set_feature(usbd_core_type *udev);
44static usb_sts_type usbd_get_configuration(usbd_core_type *udev);
45static usb_sts_type usbd_set_configuration(usbd_core_type *udev);
46
53void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
54{
55 setup->bmRequestType = *(uint8_t *) buf;
56 setup->bRequest = *(uint8_t *) (buf + 1);
57 setup->wValue = SWAPBYTE(buf + 2);
58 setup->wIndex = SWAPBYTE(buf + 4);
59 setup->wLength = SWAPBYTE(buf + 6);
60}
61
67static usb_sts_type usbd_get_descriptor(usbd_core_type *udev)
68{
69 usb_sts_type ret = USB_OK;
70 uint16_t len = 0;
71 usbd_desc_t *desc = NULL;
72 uint8_t desc_type = udev->setup.wValue >> 8;
73 switch(desc_type)
74 {
75 case USB_DESCIPTOR_TYPE_DEVICE:
76 desc = udev->desc_handler->get_device_descriptor();
77 break;
78 case USB_DESCIPTOR_TYPE_CONFIGURATION:
79 desc = udev->desc_handler->get_device_configuration();
80 break;
81 case USB_DESCIPTOR_TYPE_STRING:
82 {
83 uint8_t str_desc = (uint8_t)udev->setup.wValue;
84 switch(str_desc)
85 {
86 case USB_LANGID_STRING:
87 desc = udev->desc_handler->get_device_lang_id();
88 break;
89 case USB_MFC_STRING:
90 desc = udev->desc_handler->get_device_manufacturer_string();
91 break;
92 case USB_PRODUCT_STRING:
93 desc = udev->desc_handler->get_device_product_string();
94 break;
95 case USB_SERIAL_STRING:
96 desc = udev->desc_handler->get_device_serial_string();
97 break;
98 case USB_CONFIG_STRING:
99 desc = udev->desc_handler->get_device_config_string();
100 break;
101 case USB_INTERFACE_STRING:
102 desc = udev->desc_handler->get_device_interface_string();
103 break;
104 default:
105 udev->class_handler->setup_handler(udev, &udev->setup);
106 return ret;
107 }
108 break;
109 }
110 case USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER:
111 usbd_ctrl_unsupport(udev);
112 break;
113 case USB_DESCIPTOR_TYPE_OTHER_SPEED:
114 usbd_ctrl_unsupport(udev);
115 return ret;
116 default:
117 usbd_ctrl_unsupport(udev);
118 return ret;
119 }
120
121 if(desc != NULL)
122 {
123 if((desc->length != 0) && (udev->setup.wLength != 0))
124 {
125 len = MIN(desc->length , udev->setup.wLength);
126 usbd_ctrl_send(udev, desc->descriptor, len);
127 }
128 }
129 return ret;
130}
131
137static usb_sts_type usbd_set_address(usbd_core_type *udev)
138{
139 usb_sts_type ret = USB_OK;
140 usb_setup_type *setup = &udev->setup;
141 uint8_t dev_addr;
142
143 /* if wIndex or wLength are non-zero, then the behavior of
144 the device is not specified
145 */
146 if(setup->wIndex == 0 && setup->wLength == 0)
147 {
148 dev_addr = (uint8_t)(setup->wValue) & 0x7f;
149
150 /* device behavior when this request is received
151 while the device is in the configured state is not specified.*/
152 if(udev->conn_state == USB_CONN_STATE_CONFIGURED )
153 {
154 usbd_ctrl_unsupport(udev);
155 }
156 else
157 {
158 udev->device_addr = dev_addr;
159
160 if(dev_addr != 0)
161 {
162 udev->conn_state = USB_CONN_STATE_ADDRESSED;
163 }
164 else
165 {
166 udev->conn_state = USB_CONN_STATE_DEFAULT;
167 }
168 usbd_ctrl_send_status(udev);
169 }
170 }
171 else
172 {
173 usbd_ctrl_unsupport(udev);
174 }
175 return ret;
176}
177
183static usb_sts_type usbd_get_status(usbd_core_type *udev)
184{
185 usb_sts_type ret = USB_OK;
186 switch(udev->conn_state)
187 {
188 case USB_CONN_STATE_ADDRESSED:
189 case USB_CONN_STATE_CONFIGURED:
190 if(udev->remote_wakup)
191 {
192 udev->config_status |= USB_CONF_REMOTE_WAKEUP;
193 }
194 usbd_ctrl_send(udev, (uint8_t *)(&udev->config_status), 2);
195 break;
196 default:
197 usbd_ctrl_unsupport(udev);
198 break;
199 }
200 return ret;
201}
202
208static usb_sts_type usbd_clear_feature(usbd_core_type *udev)
209{
210 usb_sts_type ret = USB_OK;
211 usb_setup_type *setup = &udev->setup;
212 switch(udev->conn_state)
213 {
214 case USB_CONN_STATE_ADDRESSED:
215 case USB_CONN_STATE_CONFIGURED:
216 if(setup->wValue == USB_FEATURE_REMOTE_WAKEUP)
217 {
218 udev->remote_wakup = 0;
219 udev->config_status &= ~USB_CONF_REMOTE_WAKEUP;
220 udev->class_handler->setup_handler(udev, &udev->setup);
221 usbd_ctrl_send_status(udev);
222 }
223 break;
224 default:
225 usbd_ctrl_unsupport(udev);
226 break;
227 }
228 return ret;
229}
230
236static usb_sts_type usbd_set_feature(usbd_core_type *udev)
237{
238 usb_sts_type ret = USB_OK;
239 usb_setup_type *setup = &udev->setup;
240 if(setup->wValue == USB_FEATURE_REMOTE_WAKEUP)
241 {
242 udev->remote_wakup = 1;
243 udev->class_handler->setup_handler(udev, &udev->setup);
244 usbd_ctrl_send_status(udev);
245 }
246 return ret;
247}
248
254static usb_sts_type usbd_get_configuration(usbd_core_type *udev)
255{
256 usb_sts_type ret = USB_OK;
257 usb_setup_type *setup = &udev->setup;
258 if(setup->wLength != 1)
259 {
260 usbd_ctrl_unsupport(udev);
261 }
262 else
263 {
264 switch(udev->conn_state)
265 {
266 case USB_CONN_STATE_ADDRESSED:
267 udev->default_config = 0;
268 usbd_ctrl_send(udev, (uint8_t *)(&udev->default_config), 1);
269 break;
270 case USB_CONN_STATE_CONFIGURED:
271 usbd_ctrl_send(udev, (uint8_t *)(&udev->dev_config), 1);
272 break;
273 default:
274 usbd_ctrl_unsupport(udev);
275 break;
276 }
277 }
278 return ret;
279}
280
286static usb_sts_type usbd_set_configuration(usbd_core_type *udev)
287{
288 usb_sts_type ret = USB_OK;
289 static uint8_t config_value;
290 usb_setup_type *setup = &udev->setup;
291 config_value = (uint8_t)setup->wValue;
292
293 if(setup->wIndex == 0 && setup->wLength == 0)
294 {
295 switch(udev->conn_state)
296 {
297 case USB_CONN_STATE_ADDRESSED:
298 if(config_value)
299 {
300 udev->dev_config = config_value;
301 udev->conn_state = USB_CONN_STATE_CONFIGURED;
302 udev->class_handler->init_handler(udev);
303 usbd_ctrl_send_status(udev);
304 }
305 else
306 {
307 usbd_ctrl_send_status(udev);
308 }
309
310 break;
311 case USB_CONN_STATE_CONFIGURED:
312 if(config_value == 0)
313 {
314 udev->conn_state = USB_CONN_STATE_ADDRESSED;
315 udev->dev_config = config_value;
316 udev->class_handler->clear_handler(udev);
317 usbd_ctrl_send_status(udev);
318 }
319 else if(config_value == udev->dev_config)
320 {
321 udev->class_handler->clear_handler(udev);
322 udev->dev_config = config_value;
323 udev->class_handler->init_handler(udev);
324 usbd_ctrl_send_status(udev);
325 }
326 else
327 {
328 usbd_ctrl_send_status(udev);
329 }
330 break;
331 default:
332 usbd_ctrl_unsupport(udev);
333 break;
334 }
335 }
336 else
337 {
338 usbd_ctrl_unsupport(udev);
339 }
340 return ret;
341}
342
348 usb_sts_type usbd_device_request(usbd_core_type *udev)
349{
350 usb_sts_type ret = USB_OK;
351 usb_setup_type *setup = &udev->setup;
352 if((setup->bmRequestType & USB_REQ_TYPE_RESERVED) != USB_REQ_TYPE_STANDARD)
353 {
354 udev->class_handler->setup_handler(udev, &udev->setup);
355 return ret;
356 }
357 switch(udev->setup.bRequest)
358 {
359 case USB_STD_REQ_GET_STATUS:
360 usbd_get_status(udev);
361 break;
362 case USB_STD_REQ_CLEAR_FEATURE:
363 usbd_clear_feature(udev);
364 break;
365 case USB_STD_REQ_SET_FEATURE:
366 usbd_set_feature(udev);
367 break;
368 case USB_STD_REQ_SET_ADDRESS:
369 usbd_set_address(udev);
370 break;
371 case USB_STD_REQ_GET_DESCRIPTOR:
372 usbd_get_descriptor(udev);
373 break;
374 case USB_STD_REQ_GET_CONFIGURATION:
375 usbd_get_configuration(udev);
376 break;
377 case USB_STD_REQ_SET_CONFIGURATION:
378 usbd_set_configuration(udev);
379 break;
380 default:
381 usbd_ctrl_unsupport(udev);
382 break;
383 }
384 return ret;
385}
386
392 usb_sts_type usbd_interface_request(usbd_core_type *udev)
393{
394 usb_sts_type ret = USB_OK;
395 usb_setup_type *setup = &udev->setup;
396 switch(udev->conn_state)
397 {
398 case USB_CONN_STATE_DEFAULT:
399 case USB_CONN_STATE_ADDRESSED:
400 case USB_CONN_STATE_CONFIGURED:
401 ret = udev->class_handler->setup_handler(udev, &udev->setup);
402 if(setup->wLength == 0 && ret == USB_OK)
403 {
404 usbd_ctrl_send_status(udev);
405 }
406 break;
407 default:
408 usbd_ctrl_unsupport(udev);
409 break;
410 }
411 return ret;
412}
413
419 usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
420{
421 usb_sts_type ret = USB_OK;
422 usb_setup_type *setup = &udev->setup;
423 uint8_t ept_addr = LBYTE(setup->wIndex);
424 usb_ept_info *ept_info;
425
426 if((setup->bmRequestType & USB_REQ_TYPE_RESERVED) != USB_REQ_TYPE_STANDARD)
427 {
428 udev->class_handler->setup_handler(udev, &udev->setup);
429 return ret;
430 }
431 switch(setup->bRequest)
432 {
433 case USB_STD_REQ_GET_STATUS:
434 switch(udev->conn_state)
435 {
436 case USB_CONN_STATE_ADDRESSED:
437 if((ept_addr & 0x7F) != 0)
438 {
439 usbd_set_stall(udev, ept_addr);
440 }
441 if((ept_addr & 0x80) != 0)
442 {
443 ept_info = &udev->ept_in[ept_addr & 0x7F];
444 }
445 else
446 {
447 ept_info = &udev->ept_out[ept_addr & 0x7F];
448 }
449 ept_info->status = 0x0000;
450 usbd_ctrl_send(udev, (uint8_t *)(&ept_info->status), 2);
451
452 break;
453 case USB_CONN_STATE_CONFIGURED:
454 {
455 if((ept_addr & 0x80) != 0)
456 {
457 ept_info = &udev->ept_in[ept_addr & 0x7F];
458 }
459 else
460 {
461 ept_info = &udev->ept_out[ept_addr & 0x7F];
462 }
463 if(ept_info->stall == 1)
464 {
465 ept_info->status = 0x0001;
466 }
467 else
468 {
469 ept_info->status = 0x0000;
470 }
471 usbd_ctrl_send(udev, (uint8_t *)(&ept_info->status), 2);
472 }
473 break;
474 default:
475 usbd_ctrl_unsupport(udev);
476 break;
477 }
478 break;
479 case USB_STD_REQ_CLEAR_FEATURE:
480 switch(udev->conn_state)
481 {
482 case USB_CONN_STATE_ADDRESSED:
483 if((ept_addr != 0x00) && (ept_addr != 0x80))
484 {
485 usbd_set_stall(udev, ept_addr);
486 }
487 break;
488 case USB_CONN_STATE_CONFIGURED:
489 if(setup->wValue == USB_FEATURE_EPT_HALT)
490 {
491 if((ept_addr & 0x7F) != 0x00 )
492 {
493 usbd_clear_stall(udev, ept_addr);
494 udev->class_handler->setup_handler(udev, &udev->setup);
495 }
496 usbd_ctrl_send_status(udev);
497 }
498 break;
499 default:
500 usbd_ctrl_unsupport(udev);
501 break;
502 }
503 break;
504 case USB_STD_REQ_SET_FEATURE:
505 switch(udev->conn_state)
506 {
507 case USB_CONN_STATE_ADDRESSED:
508 if((ept_addr != 0x00) && (ept_addr != 0x80))
509 {
510 usbd_set_stall(udev, ept_addr);
511 }
512 break;
513 case USB_CONN_STATE_CONFIGURED:
514 if(setup->wValue == USB_FEATURE_EPT_HALT)
515 {
516 if((ept_addr != 0x00) && (ept_addr != 0x80))
517 {
518 usbd_set_stall(udev, ept_addr);
519 }
520 }
521 udev->class_handler->setup_handler(udev, &udev->setup);
522 usbd_ctrl_send_status(udev);
523 break;
524 default:
525 usbd_ctrl_unsupport(udev);
526 break;
527 }
528 break;
529 default:
530 usbd_ctrl_unsupport(udev);
531 break;
532 }
533 return ret;
534}
535
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:76
USB_DESCIPTOR_TYPE_OTHER_SPEED
#define USB_DESCIPTOR_TYPE_OTHER_SPEED
Definition: usb_std.h:96
USB_INTERFACE_STRING
#define USB_INTERFACE_STRING
Definition: usb_std.h:107
USB_STD_REQ_SET_CONFIGURATION
#define USB_STD_REQ_SET_CONFIGURATION
Definition: usb_std.h:82
USB_FEATURE_REMOTE_WAKEUP
#define USB_FEATURE_REMOTE_WAKEUP
Definition: usb_std.h:119
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:104
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:253
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:61
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:91
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:79
USB_STD_REQ_SET_ADDRESS
#define USB_STD_REQ_SET_ADDRESS
Definition: usb_std.h:78
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:263
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:77
USB_CONF_REMOTE_WAKEUP
#define USB_CONF_REMOTE_WAKEUP
usb configuration attributes
Definition: usb_std.h:112
SWAPBYTE
#define SWAPBYTE(addr)
usb swap address
Definition: usb_std.h:245
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:103
USB_STD_REQ_GET_STATUS
#define USB_STD_REQ_GET_STATUS
usb standard device requests codes
Definition: usb_std.h:75
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:105
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:90
USB_FEATURE_EPT_HALT
#define USB_FEATURE_EPT_HALT
usb standard feature selectors
Definition: usb_std.h:118
USB_STD_REQ_GET_CONFIGURATION
#define USB_STD_REQ_GET_CONFIGURATION
Definition: usb_std.h:81
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:92
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:64
USB_LANGID_STRING
#define USB_LANGID_STRING
usb standard string type
Definition: usb_std.h:102
USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER
#define USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER
Definition: usb_std.h:95
USB_CONFIG_STRING
#define USB_CONFIG_STRING
Definition: usb_std.h:106
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:127
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:129
USB_CONN_STATE_ADDRESSED
@ USB_CONN_STATE_ADDRESSED
Definition: usb_std.h:128
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:259
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:209
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:174
usbd_clear_stall
void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall
Definition: usbd_core.c:234
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:284
usbd_set_feature
static usb_sts_type usbd_set_feature(usbd_core_type *udev)
set usb feature request
Definition: usbd_sdr.c:236
usbd_endpoint_request
usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
standard usb endpoint requests
Definition: usbd_sdr.c:419
usbd_get_status
static usb_sts_type usbd_get_status(usbd_core_type *udev)
get usb status request
Definition: usbd_sdr.c:183
usbd_get_configuration
static usb_sts_type usbd_get_configuration(usbd_core_type *udev)
get usb configuration request
Definition: usbd_sdr.c:254
usbd_get_descriptor
static usb_sts_type usbd_get_descriptor(usbd_core_type *udev)
get usb standard device description request
Definition: usbd_sdr.c:67
usbd_setup_request_parse
void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request
Definition: usbd_sdr.c:53
usbd_device_request
usb_sts_type usbd_device_request(usbd_core_type *udev)
standard usb device requests
Definition: usbd_sdr.c:348
usbd_set_address
static usb_sts_type usbd_set_address(usbd_core_type *udev)
this request sets the device address
Definition: usbd_sdr.c:137
usbd_interface_request
usb_sts_type usbd_interface_request(usbd_core_type *udev)
standard usb interface requests
Definition: usbd_sdr.c:392
usbd_set_configuration
static usb_sts_type usbd_set_configuration(usbd_core_type *udev)
sets the usb device configuration request
Definition: usbd_sdr.c:286
usbd_clear_feature
static usb_sts_type usbd_clear_feature(usbd_core_type *udev)
clear usb feature request
Definition: usbd_sdr.c:208
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:499
usb_ept_info::stall
uint8_t stall
Definition: at32f413_usb.h:509
usb_ept_info::status
uint16_t status
Definition: at32f413_usb.h:510
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:293
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:296
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:291
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:294
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:292
usbd_class_handler::init_handler
usb_sts_type(* init_handler)(void *udev)
Definition: usbd_core.h:92
usbd_class_handler::clear_handler
usb_sts_type(* clear_handler)(void *udev)
Definition: usbd_core.h:93
usbd_class_handler::setup_handler
usb_sts_type(* setup_handler)(void *udev, usb_setup_type *setup)
Definition: usbd_core.h:94
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:124
usbd_core_type::default_config
uint8_t default_config
Definition: usbd_core.h:129
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:128
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:111
usbd_core_type::ept_in
usb_ept_info ept_in[USB_EPT_MAX_NUM]
Definition: usbd_core.h:114
usbd_core_type::config_status
uint16_t config_status
Definition: usbd_core.h:131
usbd_core_type::dev_config
uint8_t dev_config
Definition: usbd_core.h:130
usbd_core_type::device_addr
uint8_t device_addr
Definition: usbd_core.h:127
usbd_core_type::ept_out
usb_ept_info ept_out[USB_EPT_MAX_NUM]
Definition: usbd_core.h:115
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:117
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:112
usbd_desc_handler::get_device_config_string
usbd_desc_t *(* get_device_config_string)(void)
Definition: usbd_core.h:84
usbd_desc_handler::get_device_descriptor
usbd_desc_t *(* get_device_descriptor)(void)
Definition: usbd_core.h:75
usbd_desc_handler::get_device_configuration
usbd_desc_t *(* get_device_configuration)(void)
Definition: usbd_core.h:77
usbd_desc_handler::get_device_interface_string
usbd_desc_t *(* get_device_interface_string)(void)
Definition: usbd_core.h:83
usbd_desc_handler::get_device_lang_id
usbd_desc_t *(* get_device_lang_id)(void)
Definition: usbd_core.h:79
usbd_desc_handler::get_device_manufacturer_string
usbd_desc_t *(* get_device_manufacturer_string)(void)
Definition: usbd_core.h:80
usbd_desc_handler::get_device_product_string
usbd_desc_t *(* get_device_product_string)(void)
Definition: usbd_core.h:81
usbd_desc_handler::get_device_serial_string
usbd_desc_t *(* get_device_serial_string)(void)
Definition: usbd_core.h:82
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:65
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:66
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:67
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: usbd_sdr.h Source File

  • middlewares
  • usbd_drivers
  • inc
usbd_sdr.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USBD_SDR_H
27#define __USBD_SDR_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33
34/* includes ------------------------------------------------------------------*/
35#include "usbd_core.h"
36
49void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf);
50 usb_sts_type usbd_device_request(usbd_core_type *udev);
51 usb_sts_type usbd_interface_request(usbd_core_type *udev);
52 usb_sts_type usbd_endpoint_request(usbd_core_type *udev);
53
54
67#ifdef __cplusplus
68}
69#endif
70
71#endif
72
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
usbd_endpoint_request
usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
standard usb endpoint requests
Definition: usbd_sdr.c:419
usbd_setup_request_parse
void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request
Definition: usbd_sdr.c:53
usbd_device_request
usb_sts_type usbd_device_request(usbd_core_type *udev)
standard usb device requests
Definition: usbd_sdr.c:348
usbd_interface_request
usb_sts_type usbd_interface_request(usbd_core_type *udev)
standard usb interface requests
Definition: usbd_sdr.c:392
usb_setup_type
format of usb setup data
Definition: usb_std.h:290
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
utilities/at32f413_freertos_demo/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
utilities/at32f413_freertos_demo/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
utilities/at32f413_freertos_demo/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_freertos_demo
  • src
utilities/at32f413_freertos_demo/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_freertos_demo/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_freertos_demo
  • src
utilities/at32f413_freertos_demo/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102//void SVC_Handler(void)
103//{
104//}
105
111void DebugMon_Handler(void)
112{
113}
114
120//void PendSV_Handler(void)
121//{
122//}
123
129//void SysTick_Handler(void)
130//{
131//}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:63
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:76
DebugMon_Handler
void DebugMon_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_freertos_demo
  • src
utilities/at32f413_freertos_demo/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "FreeRTOS.h"
28#include "task.h"
29
37TaskHandle_t led2_handler;
38TaskHandle_t led3_handler;
39
40/* led2 task */
41void led2_task_function(void *pvParameters);
42/* led3 task */
43void led3_task_function(void *pvParameters);
44
50int main(void)
51{
52 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
53
54 system_clock_config();
55
56 /* init led2 and led3 */
57 at32_led_init(LED2);
58 at32_led_init(LED3);
59
60 /* init usart1 */
61 uart_print_init(115200);
62
63 /* enter critical */
64 taskENTER_CRITICAL();
65
66 /* create led2 task */
67 if(xTaskCreate((TaskFunction_t )led2_task_function,
68 (const char* )"LED2_task",
69 (uint16_t )512,
70 (void* )NULL,
71 (UBaseType_t )2,
72 (TaskHandle_t* )&led2_handler) != pdPASS)
73 {
74 printf("LED2 task could not be created as there was insufficient heap memory remaining.\r\n");
75 }
76 else
77 {
78 printf("LED2 task was created successfully.\r\n");
79 }
80 /* create led3 task */
81 if(xTaskCreate((TaskFunction_t )led3_task_function,
82 (const char* )"LED3_task",
83 (uint16_t )512,
84 (void* )NULL,
85 (UBaseType_t )2,
86 (TaskHandle_t* )&led3_handler) != pdPASS)
87 {
88 printf("LED3 task could not be created as there was insufficient heap memory remaining.\r\n");
89 }
90 else
91 {
92 printf("LED3 task was created successfully.\r\n");
93 }
94
95 /* exit critical */
96 taskEXIT_CRITICAL();
97
98 /* start scheduler */
99 vTaskStartScheduler();
100}
101
102/* led2 task function */
103void led2_task_function(void *pvParameters)
104{
105 while(1)
106 {
107 at32_led_toggle(LED2);
108 vTaskDelay(1000);
109 }
110}
111
112/* led3 task function */
113void led3_task_function(void *pvParameters)
114{
115 while(1)
116 {
117 at32_led_toggle(LED3);
118 vTaskDelay(500);
119 }
120}
121
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:237
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
led2_task_function
void led2_task_function(void *pvParameters)
Definition: utilities/at32f413_freertos_demo/src/main.c:103
main
int main(void)
main function.
Definition: utilities/at32f413_freertos_demo/src/main.c:50
led3_task_function
void led3_task_function(void *pvParameters)
Definition: utilities/at32f413_freertos_demo/src/main.c:113
led3_handler
TaskHandle_t led3_handler
Definition: utilities/at32f413_freertos_demo/src/main.c:38
led2_handler
TaskHandle_t led2_handler
Definition: utilities/at32f413_freertos_demo/src/main.c:37
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
utilities/at32f413_gen_random_number_demo/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while (1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while (1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while (1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while (1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
utilities/at32f413_gen_random_number_demo/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "stdio.h"
28#include "random.h"
29
43int main(void)
44{
45 system_clock_config();
46
47 at32_board_init();
48 uart_print_init(115200);
49 printf("gen random number test\r\n");
50 randnum_test();
51 while(1)
52 {
53 }
54}
55
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:124
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
randnum_test
void randnum_test(void)
enable rtc as seed
Definition: random.c:120
main
int main(void)
main function.
Definition: utilities/at32f413_gen_random_number_demo/src/main.c:43
random.h
at32f413 random header file
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while (1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while (1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while (1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while (1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
139void FLASH_IRQHandler(void)
140{
141 if(flash_flag_get(FLASH_EPPERR_FLAG))
142 {
143 flash_flag_clear(FLASH_EPPERR_FLAG);
144 delay_ms(500);
145 }
146}
147
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:57
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:96
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f413_flash.h:78
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:112
FLASH_IRQHandler
void FLASH_IRQHandler(void)
flash handler.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:139
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
utilities/at32f413_slib_demo/project_l0/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28#include "math_helper.h"
29#include "fir_filter.h"
30
31extern float32_t testInput_f32_1kHz_15kHz[];
32extern float32_t refOutput[];
33
42#define USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */
43
44#if defined (USE_SLIB_FUNCTION)
45#define FLASH_START_ADDR 0x08000000
46#define TEST_SLIB_PSW 0x55665566
47#define SLIB_START_ADDR 0x08001000
48#define SLIB_DATA_ADDR 0x08002000
49#define SLIB_END_ADDR 0x08002800
50#define FLASH_SECTOR_SIZE 0x800
51#define SECTOR_NUM(dwAddr) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)
52#define SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */
53#endif
54#define SNR_THRESHOLD_F32 140.0f
55#define TEST_LENGTH_SAMPLES 320
56
57#if defined (USE_SLIB_FUNCTION)
58uint32_t dw_start_sector, dw_data_start_sector, dw_end_sector;
59uint32_t temp_buf[512]; /* 2kb buffer */
60#endif
61
62static float32_t testOutput[TEST_LENGTH_SAMPLES];
63
64#if defined (USE_SLIB_FUNCTION)
65 flash_status_type slib_enable(void);
66#endif
67void config_flash_interrupt(void);
68
74void config_flash_interrupt(void)
75{
76 flash_unlock();
77 flash_interrupt_enable(FLASH_ERR_INT, TRUE);
78 flash_lock();
79 /* config nvic priority group */
80 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
81
82 nvic_irq_enable(FLASH_IRQn, 0, 0);
83}
84
85#if defined (USE_SLIB_FUNCTION)
91 flash_status_type slib_enable(void)
92{
93 uint32_t *ptr;
94 uint32_t i, j;
95 flash_status_type status = FLASH_OPERATE_DONE;
96 ptr = (uint32_t *)SLIB_START_ADDR;
97 dw_start_sector = SECTOR_NUM(SLIB_START_ADDR); /* slib start sector */
98 dw_data_start_sector = SECTOR_NUM(SLIB_DATA_ADDR); /* slib data sector */
99 dw_end_sector = SECTOR_NUM(SLIB_END_ADDR); /* slib end sector */
100 flash_unlock();
101 status = flash_slib_enable(TEST_SLIB_PSW, dw_start_sector, dw_data_start_sector, dw_end_sector);
102 if(status != FLASH_OPERATE_DONE)
103 return status;
104 for(i = 0; i <= (dw_end_sector - dw_start_sector); i++)
105 {
106 memcpy(temp_buf, ptr, FLASH_SECTOR_SIZE);
107 status = flash_sector_erase(SLIB_START_ADDR + i * FLASH_SECTOR_SIZE);
108 if(status != FLASH_OPERATE_DONE)
109 return status;
110 for(j = 0; j < (FLASH_SECTOR_SIZE >> 2); j++)
111 {
112 status = flash_word_program(SLIB_START_ADDR + i * FLASH_SECTOR_SIZE + (j << 2), temp_buf[j]);
113 if(status != FLASH_OPERATE_DONE)
114 return status;
115 }
116 ptr += SECTOR_WORD_CNT;
117 }
118 return status;
119}
120#endif
121
127int main(void)
128{
129 arm_status status;
130 float32_t *inputf32, *outputf32, snr;
131
132 system_clock_config();
133 at32_board_init();
134
135 /* initialize input and output buffer pointers */
136 inputf32 = &testInput_f32_1kHz_15kHz[0];
137 outputf32 = &testOutput[0];
138
139 /* configure flash to generate an interrupt when a write protect error occur */
140 config_flash_interrupt();
141
142 /* wait for key button to be pushed, then turn off led3 */
143 while(at32_button_press() == NO_BUTTON)
144 {
145 at32_led_toggle(LED3);
146 delay_ms(100);
147 }
148 at32_led_off(LED3);
149
150 /* call the fir low pass filter function */
151 FIR_lowpass_filter(inputf32, outputf32, TEST_LENGTH_SAMPLES);
152
153 /* compare the generated output against the reference output computed in matlab. */
154 snr = arm_snr_f32(&refOutput[0], &testOutput[0], TEST_LENGTH_SAMPLES);
155 if(snr < SNR_THRESHOLD_F32)
156 {
157 status = ARM_MATH_TEST_FAILURE;
158 }
159 else
160 {
161 status = ARM_MATH_SUCCESS;
162#if defined (USE_SLIB_FUNCTION)
163 /* enable slib protection from sector 2 to sector 5 when fir filter ip-code is tested ok */
164 if(flash_slib_state_get() == RESET)
165 {
166 /* if slib has not been enabled, set slib configuration */
167 if(slib_enable() == FLASH_OPERATE_DONE)
168 {
169 /* if slib configuration is correctly set, tuen on green led4 */
170 at32_led_on(LED4);
171 delay_sec(3);
172
173 /* execute system reset to activate slib protection */
174 nvic_system_reset();
175 }
176 else
177 {
178 /* turn on red led2 if slib activation failed */
179 at32_led_on(LED2);
180 while(1);
181 }
182 }
183#endif
184 }
185
186 /* infinite loop */
187 while(1)
188 {
189 if(status == ARM_MATH_TEST_FAILURE)
190 {
191 /* toggle red led2 if fir function failed */
192 at32_led_toggle(LED2);
193 delay_ms(500);
194 }
195 else
196 {
197 /* toggle green led4 if fir function success */
198 at32_led_toggle(LED4);
199 delay_ms(500);
200 }
201 }
202}
203
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:93
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:265
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:377
FLASH_IRQn
@ FLASH_IRQn
Definition: at32f413.h:174
TRUE
@ TRUE
Definition: at32f413.h:296
RESET
@ RESET
Definition: at32f413.h:291
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f413_flash.c:896
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f413_flash.c:829
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:727
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:412
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:157
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:161
FLASH_ERR_INT
#define FLASH_ERR_INT
Definition: at32f413_flash.h:94
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:50
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
SECTOR_NUM
#define SECTOR_NUM(dwAddr)
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:51
testOutput
static float32_t testOutput[320]
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:62
SECTOR_WORD_CNT
#define SECTOR_WORD_CNT
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:52
config_flash_interrupt
void config_flash_interrupt(void)
config flash error interrupt.
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:74
SLIB_DATA_ADDR
#define SLIB_DATA_ADDR
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:48
dw_end_sector
uint32_t dw_end_sector
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:58
SLIB_END_ADDR
#define SLIB_END_ADDR
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:49
dw_start_sector
uint32_t dw_start_sector
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:58
main
int main(void)
main function.
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:127
TEST_LENGTH_SAMPLES
#define TEST_LENGTH_SAMPLES
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:55
temp_buf
uint32_t temp_buf[512]
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:59
SLIB_START_ADDR
#define SLIB_START_ADDR
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:47
dw_data_start_sector
uint32_t dw_data_start_sector
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:58
slib_enable
flash_status_type slib_enable(void)
config slib enable and program slib area.
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:91
FLASH_SECTOR_SIZE
#define FLASH_SECTOR_SIZE
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:50
TEST_SLIB_PSW
#define TEST_SLIB_PSW
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:46
SNR_THRESHOLD_F32
#define SNR_THRESHOLD_F32
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:54
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[]
Definition: project_l0/src/arm_fir_data.c:48
refOutput
float32_t refOutput[]
Definition: project_l0/src/arm_fir_data.c:96
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27#include "at32f413_board.h"
28
42void NMI_Handler(void)
43{
44}
45
51void HardFault_Handler(void)
52{
53 /* go to infinite loop when hard fault exception occurs */
54 while (1)
55 {
56 }
57}
58
64void MemManage_Handler(void)
65{
66 /* go to infinite loop when memory manage exception occurs */
67 while (1)
68 {
69 }
70}
71
77void BusFault_Handler(void)
78{
79 /* go to infinite loop when bus fault exception occurs */
80 while (1)
81 {
82 }
83}
84
90void UsageFault_Handler(void)
91{
92 /* go to infinite loop when usage fault exception occurs */
93 while (1)
94 {
95 }
96}
97
103void SVC_Handler(void)
104{
105}
106
112void DebugMon_Handler(void)
113{
114}
115
121void PendSV_Handler(void)
122{
123}
124
130void SysTick_Handler(void)
131{
132}
133
139void FLASH_IRQHandler(void)
140{
141 if(flash_flag_get(FLASH_EPPERR_FLAG))
142 {
143 flash_flag_clear(FLASH_EPPERR_FLAG);
144 delay_ms(500);
145 }
146}
147
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:57
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:96
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f413_flash.h:78
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:112
FLASH_IRQHandler
void FLASH_IRQHandler(void)
flash handler.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:139
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
utilities/at32f413_slib_demo/project_l1/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include <stdio.h>
28#include "math_helper.h"
29#include "fir_filter.h"
30
31extern float32_t testInput_f32_1kHz_15kHz[];
32extern float32_t refOutput[];
33
42#define SNR_THRESHOLD_F32 140.0f
43#define TEST_LENGTH_SAMPLES 320
44
45static float32_t testOutput[TEST_LENGTH_SAMPLES];
46
47void config_flash_interrupt(void);
48
54void config_flash_interrupt(void)
55{
56 flash_unlock();
57 flash_interrupt_enable(FLASH_ERR_INT, TRUE);
58 flash_lock();
59 /* config nvic priority group */
60 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
61
62 nvic_irq_enable(FLASH_IRQn, 0, 0);
63}
64
70int main(void)
71{
72 arm_status status;
73 float32_t *inputf32, *outputf32, snr;
74
75 system_clock_config();
76 at32_board_init();
77
78 /* initialize input and output buffer pointers */
79 inputf32 = &testInput_f32_1kHz_15kHz[0];
80 outputf32 = &testOutput[0];
81
82 /* configure flash to generate an interrupt when a write protect error occur */
83 config_flash_interrupt();
84
85 /* wait for key button to be pushed, then turn off led3 */
86 while(at32_button_press() == NO_BUTTON)
87 {
88 at32_led_toggle(LED3);
89 delay_ms(100);
90 }
91 at32_led_off(LED3);
92
93 /* call the fir low pass filter function */
94 FIR_lowpass_filter(inputf32, outputf32, TEST_LENGTH_SAMPLES);
95
96 /* compare the generated output against the reference output computed in matlab. */
97 snr = arm_snr_f32(&refOutput[0], &testOutput[0], TEST_LENGTH_SAMPLES);
98 if(snr < SNR_THRESHOLD_F32)
99 {
100 status = ARM_MATH_TEST_FAILURE;
101 }
102 else
103 {
104 status = ARM_MATH_SUCCESS;
105 }
106
107 /* infinite loop */
108 while(1)
109 {
110 if(status == ARM_MATH_TEST_FAILURE)
111 {
112 /* toggle red led2 if fir function failed */
113 at32_led_toggle(LED2);
114 delay_ms(500);
115 }
116 else
117 {
118 /* toggle green led4 if fir function success */
119 at32_led_toggle(LED4);
120 delay_ms(500);
121 }
122 }
123}
124
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
LED2
@ LED2
Definition: at32f413_board.h:61
LED4
@ LED4
Definition: at32f413_board.h:63
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:93
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:213
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:282
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
FLASH_IRQn
@ FLASH_IRQn
Definition: at32f413.h:174
TRUE
@ TRUE
Definition: at32f413.h:296
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:727
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
FLASH_ERR_INT
#define FLASH_ERR_INT
Definition: at32f413_flash.h:94
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
testOutput
static float32_t testOutput[320]
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:45
config_flash_interrupt
void config_flash_interrupt(void)
config flash error interrupt.
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:54
main
int main(void)
main function.
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:70
TEST_LENGTH_SAMPLES
#define TEST_LENGTH_SAMPLES
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:43
SNR_THRESHOLD_F32
#define SNR_THRESHOLD_F32
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:42
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[]
Definition: project_l0/src/arm_fir_data.c:48
refOutput
float32_t refOutput[]
Definition: project_l0/src/arm_fir_data.c:96
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while (1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while (1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while (1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while (1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "tmr.h"
28#include "usart.h"
29#include "iap.h"
30
44int main(void)
45{
46 /* config vector table offset */
47 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x4000);
48
49 /* config nvic priority group */
50 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
51
52 system_clock_config();
53 at32_board_init();
54
55 /* check and clear iap_upgrade_flag flag */
56 iap_init();
57
58 /* init usart used for app update */
59 uart_init(115200);
60
61 /* init tmr used for show code running state(led cycle toggle) */
62 tmr_init();
63
64 while(1)
65 {
66 iap_command_handle();
67 }
68}
69
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:110
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:50
main
int main(void)
main function.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c:44
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:42
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:42
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while (1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while (1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while (1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while (1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "tmr.h"
28#include "usart.h"
29#include "iap.h"
30
44int main(void)
45{
46 /* config vector table offset */
47 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x4000);
48
49 /* config nvic priority group */
50 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
51
52 system_clock_config();
53 at32_board_init();
54
55 /* check and clear iap_upgrade_flag flag */
56 iap_init();
57
58 /* init usart used for app update */
59 uart_init(115200);
60
61 /* init tmr used for show code running state(led cycle toggle) */
62 tmr_init();
63
64 while(1)
65 {
66 iap_command_handle();
67 }
68}
69
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:110
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:50
main
int main(void)
main function.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c:44
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:42
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:42
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: flash.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
Go to the documentation of this file.
1
25#ifndef __FLASH_H__
26#define __FLASH_H__
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32#include "at32f413_board.h"
33
46#define FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */
47#define SRAM_SIZE 64 /* sram size, unit:kbyte */
48
57void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer);
58 flag_status flash_upgrade_flag_read(void);
59
72#ifdef __cplusplus
73}
74#endif
75
76#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
flag_status
flag_status
flag status
Definition: at32f413.h:291
flash_2kb_write
void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:43
flash_upgrade_flag_read
flag_status flash_upgrade_flag_read(void)
check flash upgrade flag.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:64


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while (1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while (1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while (1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while (1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: flash.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
Go to the documentation of this file.
1
25#include "flash.h"
26#include "usart.h"
27#include "iap.h"
28
43void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
44{
45 uint16_t index, write_data;
46 flash_unlock();
47 flash_sector_erase(write_addr);
48 if(FLASH_SIZE < 0x100) /* less than 256kb, 1kb/sector */
49 flash_sector_erase(write_addr + 0x400);
50 for(index = 0; index < 2048; index += 2)
51 {
52 write_data = (pbuffer[index+1] << 8) + pbuffer[index];
53 flash_halfword_program(write_addr, write_data);
54 write_addr += sizeof(uint16_t);
55 }
56 flash_lock();
57}
58
64 flag_status flash_upgrade_flag_read(void)
65{
66 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
67 return SET;
68 else
69 return RESET;
70}
71
flag_status
flag_status
flag status
Definition: at32f413.h:291
RESET
@ RESET
Definition: at32f413.h:291
SET
@ SET
Definition: at32f413.h:291
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:270
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:450
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:227
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:249
flash_2kb_write
void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:43
flash_upgrade_flag_read
flag_status flash_upgrade_flag_read(void)
check flash upgrade flag.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:64
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: app_led3_toggle/inc/iap.h:50
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: app_led3_toggle/inc/iap.h:54
FLASH_SIZE
#define FLASH_SIZE
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h:46


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "tmr.h"
28#include "usart.h"
29#include "flash.h"
30#include "iap.h"
31
45int main(void)
46{
47 system_clock_config();
48 at32_board_init();
49
50 /* config nvic priority group */
51 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
52
53 /* check iap_upgrade_flag flag */
54 if(flash_upgrade_flag_read() == RESET)
55 {
56 /* check app starting address whether 0x08xxxxxx */
57 if(((*(uint32_t*)(APP_START_ADDR + 4)) & 0xFF000000) == 0x08000000)
58 app_load(APP_START_ADDR);
59 }
60
61 /* init usart used for app update */
62 uart_init(115200);
63
64 /* check whether need to upgrade, if yes, response ok to pc-tool */
65 if(flash_upgrade_flag_read() != RESET)
66 back_ok();
67
68 /* init tmr used for show code running state(led cycle toggle) */
69 tmr_init();
70
71 while(1)
72 {
73 /* upgrade handle */
74 iap_upgrade_app_handle();
75 }
76}
77
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
RESET
@ RESET
Definition: at32f413.h:291
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
main
int main(void)
main function.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c:45
APP_START_ADDR
#define APP_START_ADDR
Definition: app_led3_toggle/inc/iap.h:47
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:42
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:105
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: bootloader/src/iap.c:342
app_load
void app_load(uint32_t appxaddr)
app load.
Definition: bootloader/src/iap.c:58
flash_upgrade_flag_read
flag_status flash_upgrade_flag_read(void)
check flash upgrade flag.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:64
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97void usb_delay_ms(uint32_t ms);
98void usb_delay_us(uint32_t us);
99
108#ifdef __cplusplus
109}
110#endif
111
112#endif
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:128
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:139


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "hid_iap_class.h"
29#include "hid_iap_desc.h"
30#include "hid_iap_user.h"
31#include "usbd_int.h"
32
41 usbd_core_type usb_core_dev;
42
43void usb_clock48m_select(usb_clk48_s clk_s);
44
50void usb_clock48m_select(usb_clk48_s clk_s)
51{
52 if(clk_s == USB_CLK_HICK)
53 {
54 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
55
56 /* enable the acc calibration ready interrupt */
57 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
58
59 /* update the c1\c2\c3 value */
60 acc_write_c1(7980);
61 acc_write_c2(8000);
62 acc_write_c3(8020);
63
64 /* open acc calibration */
65 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
66 }
67 else
68 {
69 switch(system_core_clock)
70 {
71 /* 48MHz */
72 case 48000000:
73 crm_usb_clock_div_set(CRM_USB_DIV_1);
74 break;
75
76 /* 72MHz */
77 case 72000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
79 break;
80
81 /* 96MHz */
82 case 96000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_2);
84 break;
85
86 /* 120MHz */
87 case 120000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
89 break;
90
91 /* 144MHz */
92 case 144000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_3);
94 break;
95
96 /* 168MHz */
97 case 168000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
99 break;
100
101 /* 192MHz */
102 case 192000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_4);
104 break;
105
106 default:
107 break;
108
109 }
110 }
111}
112
118void USBFS_L_CAN1_RX0_IRQHandler(void)
119{
120 usbd_irq_handler(&usb_core_dev);
121}
122
128void usb_delay_ms(uint32_t ms)
129{
130 /* user can define self delay function */
131 delay_ms(ms);
132}
133
139void usb_delay_us(uint32_t us)
140{
141 delay_us(us);
142}
143
149int main(void)
150{
151 /* config vector table offset */
152 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x6000);
153
154 system_clock_config();
155
156 /* config nvic priority group */
157 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
158
159 /* iap init */
160 iap_init();
161
162 at32_board_init();
163
164 /* select usb 48m clcok source */
165 usb_clock48m_select(USB_CLK_HEXT);
166
167 /* enable usb clock */
168 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
169
170 /* enable usb interrupt */
171 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
172
173 /* usb core init */
174 usbd_core_init(&usb_core_dev, USB, &hid_iap_class_handler, &hid_iap_desc_handler, 0);
175
176 /* enable usb pull-up */
177 usbd_connect(&usb_core_dev);
178
179 while(1)
180 {
181 app_loop();
182 at32_led_toggle(LED3);
183 delay_ms(200);
184 }
185}
186
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
LED3
@ LED3
Definition: at32f413_board.h:62
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:110
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:50
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:55
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:66
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:50
main
int main(void)
main function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:149
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:118
usb_core_dev
usbd_core_type usb_core_dev
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:41
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:251
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97void usb_delay_ms(uint32_t ms);
98void usb_delay_us(uint32_t us);
99
108#ifdef __cplusplus
109}
110#endif
111
112#endif
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:128
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:139


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "hid_iap_class.h"
29#include "hid_iap_desc.h"
30#include "hid_iap_user.h"
31#include "usbd_int.h"
32
41 usbd_core_type usb_core_dev;
42
43void usb_clock48m_select(usb_clk48_s clk_s);
44
50void usb_clock48m_select(usb_clk48_s clk_s)
51{
52 if(clk_s == USB_CLK_HICK)
53 {
54 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
55
56 /* enable the acc calibration ready interrupt */
57 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
58
59 /* update the c1\c2\c3 value */
60 acc_write_c1(7980);
61 acc_write_c2(8000);
62 acc_write_c3(8020);
63
64 /* open acc calibration */
65 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
66 }
67 else
68 {
69 switch(system_core_clock)
70 {
71 /* 48MHz */
72 case 48000000:
73 crm_usb_clock_div_set(CRM_USB_DIV_1);
74 break;
75
76 /* 72MHz */
77 case 72000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
79 break;
80
81 /* 96MHz */
82 case 96000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_2);
84 break;
85
86 /* 120MHz */
87 case 120000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
89 break;
90
91 /* 144MHz */
92 case 144000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_3);
94 break;
95
96 /* 168MHz */
97 case 168000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
99 break;
100
101 /* 192MHz */
102 case 192000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_4);
104 break;
105
106 default:
107 break;
108
109 }
110 }
111}
112
118void USBFS_L_CAN1_RX0_IRQHandler(void)
119{
120 usbd_irq_handler(&usb_core_dev);
121}
122
128void usb_delay_ms(uint32_t ms)
129{
130 /* user can define self delay function */
131 delay_ms(ms);
132}
133
139void usb_delay_us(uint32_t us)
140{
141 delay_us(us);
142}
143
149int main(void)
150{
151 /* config vector table offset */
152 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x6000);
153
154 system_clock_config();
155
156 /* config nvic priority group */
157 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
158
159 /* iap init */
160 iap_init();
161
162 at32_board_init();
163
164 /* select usb 48m clcok source */
165 usb_clock48m_select(USB_CLK_HEXT);
166
167 /* enable usb clock */
168 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
169
170 /* enable usb interrupt */
171 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
172
173 /* usb core init */
174 usbd_core_init(&usb_core_dev, USB, &hid_iap_class_handler, &hid_iap_desc_handler, 0);
175
176 /* enable usb pull-up */
177 usbd_connect(&usb_core_dev);
178
179 while(1)
180 {
181 app_loop();
182 at32_led_toggle(LED4);
183 delay_ms(200);
184 }
185}
186
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
LED4
@ LED4
Definition: at32f413_board.h:63
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:110
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:50
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:55
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:66
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:50
main
int main(void)
main function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:149
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:118
usb_core_dev
usbd_core_type usb_core_dev
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:41
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:251
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CLOCK_H
27#define __AT32F413_CLOCK_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported functions ------------------------------------------------------- */
37void system_clock_config(void);
38
39#ifdef __cplusplus
40}
41#endif
42
43#endif /* __AT32F413_CLOCK_H */
44
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_CONF_H
27#define __AT32F413_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
41#if !defined HEXT_VALUE
42#define HEXT_VALUE ((uint32_t)8000000)
43#endif
44
49#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
50#define HICK_VALUE ((uint32_t)8000000)
51#define LEXT_VALUE ((uint32_t)32768)
53/* module define -------------------------------------------------------------*/
54#define CRM_MODULE_ENABLED
55#define TMR_MODULE_ENABLED
56#define RTC_MODULE_ENABLED
57#define BPR_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define SPI_MODULE_ENABLED
65#define DMA_MODULE_ENABLED
66#define DEBUG_MODULE_ENABLED
67#define FLASH_MODULE_ENABLED
68#define CRC_MODULE_ENABLED
69#define WWDT_MODULE_ENABLED
70#define WDT_MODULE_ENABLED
71#define EXINT_MODULE_ENABLED
72#define SDIO_MODULE_ENABLED
73#define USB_MODULE_ENABLED
74#define ACC_MODULE_ENABLED
75#define MISC_MODULE_ENABLED
76
77/* includes ------------------------------------------------------------------*/
78#ifdef CRM_MODULE_ENABLED
79#include "at32f413_crm.h"
80#endif
81#ifdef TMR_MODULE_ENABLED
82#include "at32f413_tmr.h"
83#endif
84#ifdef RTC_MODULE_ENABLED
85#include "at32f413_rtc.h"
86#endif
87#ifdef BPR_MODULE_ENABLED
88#include "at32f413_bpr.h"
89#endif
90#ifdef GPIO_MODULE_ENABLED
91#include "at32f413_gpio.h"
92#endif
93#ifdef I2C_MODULE_ENABLED
94#include "at32f413_i2c.h"
95#endif
96#ifdef USART_MODULE_ENABLED
97#include "at32f413_usart.h"
98#endif
99#ifdef PWC_MODULE_ENABLED
100#include "at32f413_pwc.h"
101#endif
102#ifdef CAN_MODULE_ENABLED
103#include "at32f413_can.h"
104#endif
105#ifdef ADC_MODULE_ENABLED
106#include "at32f413_adc.h"
107#endif
108#ifdef SPI_MODULE_ENABLED
109#include "at32f413_spi.h"
110#endif
111#ifdef DMA_MODULE_ENABLED
112#include "at32f413_dma.h"
113#endif
114#ifdef DEBUG_MODULE_ENABLED
115#include "at32f413_debug.h"
116#endif
117#ifdef FLASH_MODULE_ENABLED
118#include "at32f413_flash.h"
119#endif
120#ifdef CRC_MODULE_ENABLED
121#include "at32f413_crc.h"
122#endif
123#ifdef WWDT_MODULE_ENABLED
124#include "at32f413_wwdt.h"
125#endif
126#ifdef WDT_MODULE_ENABLED
127#include "at32f413_wdt.h"
128#endif
129#ifdef EXINT_MODULE_ENABLED
130#include "at32f413_exint.h"
131#endif
132#ifdef SDIO_MODULE_ENABLED
133#include "at32f413_sdio.h"
134#endif
135#ifdef ACC_MODULE_ENABLED
136#include "at32f413_acc.h"
137#endif
138#ifdef MISC_MODULE_ENABLED
139#include "at32f413_misc.h"
140#endif
141#ifdef USB_MODULE_ENABLED
142#include "at32f413_usb.h"
143#endif
144
153#ifdef __cplusplus
154}
155#endif
156
157#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __AT32F413_INT_H
27#define __AT32F413_INT_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33/* includes ------------------------------------------------------------------*/
34#include "at32f413.h"
35
36/* exported types ------------------------------------------------------------*/
37/* exported constants --------------------------------------------------------*/
38/* exported macro ------------------------------------------------------------*/
39/* exported functions ------------------------------------------------------- */
40
41void NMI_Handler(void);
42void HardFault_Handler(void);
43void MemManage_Handler(void);
44void BusFault_Handler(void);
45void UsageFault_Handler(void);
46void SVC_Handler(void);
47void DebugMon_Handler(void);
48void PendSV_Handler(void);
49void SysTick_Handler(void);
50
51#ifdef __cplusplus
52}
53#endif
54
55#endif
56
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:90
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:51
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:64
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:121
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:42
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:77
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:130
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:112


AT32F413 Firmwary Library: usb_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
Go to the documentation of this file.
1
25/* define to prevent recursive inclusion -------------------------------------*/
26#ifndef __USB_CONF_H
27#define __USB_CONF_H
28
29#ifdef __cplusplus
30extern "C" {
31#endif
32
33#include "at32f413.h"
34#include "at32f413_board.h"
35#include "stdio.h"
36
48#ifndef USB_EPT_MAX_NUM
49#define USB_EPT_MAX_NUM 8
50#endif
51
55//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
56
57
61#define USB_EPT_AUTO_MALLOC_BUFFER
64#ifndef USB_EPT_AUTO_MALLOC_BUFFER
70/* ept0 tx start address 0x40, size 0x40,
71 so rx start address is 0x40 + 0x40 = 0x80 */
72#define EPT0_TX_ADDR 0x40
73#define EPT0_RX_ADDR 0x80
75#define EPT1_TX_ADDR 0xC0
76#define EPT1_RX_ADDR 0x100
78#define EPT2_TX_ADDR 0x140
79#define EPT2_RX_ADDR 0x180
81#define EPT3_TX_ADDR 0x00
82#define EPT3_RX_ADDR 0x00
84#define EPT4_TX_ADDR 0x00
85#define EPT4_RX_ADDR 0x00
87#define EPT5_TX_ADDR 0x00
88#define EPT5_RX_ADDR 0x00
90#define EPT6_TX_ADDR 0x00
91#define EPT6_RX_ADDR 0x00
93#define EPT7_TX_ADDR 0x00
94#define EPT7_RX_ADDR 0x00
96#endif
97void usb_delay_ms(uint32_t ms);
98void usb_delay_us(uint32_t us);
99
108#ifdef __cplusplus
109}
110#endif
111
112#endif
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:129
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:140


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_clock.h"
27
46void system_clock_config(void)
47{
48 /* reset crm */
49 crm_reset();
50
51 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
52
53 /* wait till hext is ready */
54 while(crm_hext_stable_wait() == ERROR)
55 {
56 }
57
58 /* config pll clock resource */
59 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
60
61 /* enable pll */
62 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
63
64 /* wait till pll is ready */
65 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
66 {
67 }
68
69 /* config ahbclk */
70 crm_ahb_div_set(CRM_AHB_DIV_1);
71
72 /* config apb2clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
73 crm_apb2_div_set(CRM_APB2_DIV_2);
74
75 /* config apb1clk, the maximum frequency of APB1/APB2 clock is 100 MHz */
76 crm_apb1_div_set(CRM_APB1_DIV_2);
77
78 /* enable auto step mode */
79 crm_auto_step_mode_enable(TRUE);
80
81 /* select pll as system clock source */
82 crm_sysclk_switch(CRM_SCLK_PLL);
83
84 /* wait till pll is used as system clock source */
85 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
86 {
87 }
88
89 /* disable auto step mode */
90 crm_auto_step_mode_enable(FALSE);
91
92 /* update system_core_clock global variable */
93 system_core_clock_update();
94}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c:46
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:110
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:120
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:139
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:404
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:566
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:283
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:421
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:715
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:47
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:552
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:321
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:293
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:249
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:304
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:393
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:333
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:284
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:55
ERROR
@ ERROR
Definition: at32f413.h:301
FALSE
@ FALSE
Definition: at32f413.h:296
TRUE
@ TRUE
Definition: at32f413.h:296
SET
@ SET
Definition: at32f413.h:291
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
Go to the documentation of this file.
1
25/* includes ------------------------------------------------------------------*/
26#include "at32f413_int.h"
27
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:111
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
Go to the documentation of this file.
1
25#include "at32f413_board.h"
26#include "at32f413_clock.h"
27#include "usbd_core.h"
28#include "hid_iap_class.h"
29#include "hid_iap_desc.h"
30#include "hid_iap_user.h"
31#include "usbd_int.h"
32
41 usbd_core_type usb_core_dev;
42
43void usb_clock48m_select(usb_clk48_s clk_s);
44
50void usb_clock48m_select(usb_clk48_s clk_s)
51{
52 if(clk_s == USB_CLK_HICK)
53 {
54 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
55
56 /* enable the acc calibration ready interrupt */
57 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
58
59 /* update the c1\c2\c3 value */
60 acc_write_c1(7980);
61 acc_write_c2(8000);
62 acc_write_c3(8020);
63
64 /* open acc calibration */
65 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
66 }
67 else
68 {
69 switch(system_core_clock)
70 {
71 /* 48MHz */
72 case 48000000:
73 crm_usb_clock_div_set(CRM_USB_DIV_1);
74 break;
75
76 /* 72MHz */
77 case 72000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
79 break;
80
81 /* 96MHz */
82 case 96000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_2);
84 break;
85
86 /* 120MHz */
87 case 120000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
89 break;
90
91 /* 144MHz */
92 case 144000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_3);
94 break;
95
96 /* 168MHz */
97 case 168000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
99 break;
100
101 /* 192MHz */
102 case 192000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_4);
104 break;
105
106 default:
107 break;
108
109 }
110 }
111}
112
113
119void USBFS_L_CAN1_RX0_IRQHandler(void)
120{
121 usbd_irq_handler(&usb_core_dev);
122}
123
129void usb_delay_ms(uint32_t ms)
130{
131 /* user can define self delay function */
132 delay_ms(ms);
133}
134
140void usb_delay_us(uint32_t us)
141{
142 delay_us(us);
143}
144
150int main(void)
151{
152 system_clock_config();
153
154 /* config nvic priority group */
155 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
156
157 /* iap init */
158 iap_init();
159
160 if(iap_get_upgrade_flag() == IAP_SUCCESS)
161 {
162 jump_to_app(FLASH_APP_ADDRESS);
163 }
164
165 at32_board_init();
166
167 /* select usb 48m clcok source */
168 usb_clock48m_select(USB_CLK_HEXT);
169
170 /* enable usb clock */
171 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
172
173 /* enable usb interrupt */
174 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
175
176 /* usb core init */
177 usbd_core_init(&usb_core_dev, USB, &hid_iap_class_handler, &hid_iap_desc_handler, 0);
178
179 /* enable usb pull-up */
180 usbd_connect(&usb_core_dev);
181
182 while(1)
183 {
184 iap_loop();
185 at32_led_toggle(LED2);
186 delay_ms(200);
187 }
188}
189
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:243
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:46
jump_to_app
iapfun jump_to_app
jump to app
Definition: bootloader/src/iap.c:44
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:51
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:130
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:140
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:120
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:51
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:46
LED2
@ LED2
Definition: at32f413_board.h:61
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:345
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:299
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:157
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:325
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:204
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:771
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:362
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:357
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:363
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:361
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:360
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:358
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:359
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:453
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:191
TRUE
@ TRUE
Definition: at32f413.h:296
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:62
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:95
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:69
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:229
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:230
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:85
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:55
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:66
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:50
main
int main(void)
main function.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:150
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:119
usb_core_dev
usbd_core_type usb_core_dev
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:41
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:670
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:559
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:44
USB
#define USB
Definition: at32f413_usb.h:664
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:59
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:47
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:471
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:108
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: msc_diskio.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
virtual_msc_iap/inc/msc_diskio.h
Go to the documentation of this file.
1
24/* Define to prevent recursive inclusion -------------------------------------*/
25#ifndef __MSC_DISKIO_H
26#define __MSC_DISKIO_H
27
28#ifdef __cplusplus
29extern "C" {
30#endif
31
32
33#include "usb_conf.h"
34#include "usb_std.h"
35
43#define INTERNAL_FLASH_LUN 0
44#define SPI_FLASH_LUN 1
45#define SD_LUN 2
46
47#define USB_FLASH_ADDR_OFFSET 0x08004000
48
49uint8_t *get_inquiry(uint8_t lun);
50 usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len);
51 usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len);
52 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
53
62#ifdef __cplusplus
63}
64#endif
65
66#endif
67
68
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: virtual_msc_iap/src/msc_diskio.c:115
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: virtual_msc_iap/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: virtual_msc_iap/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: virtual_msc_iap/src/msc_diskio.c:95
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F413 Firmwary Library: msc_diskio.c Source File

  • usb_device
  • virtual_msc_iap
  • src
virtual_msc_iap/src/msc_diskio.c
Go to the documentation of this file.
1
24#include "msc_diskio.h"
25#include "msc_bot_scsi.h"
26#include "flash_fat16.h"
27
36uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
37{
38 /* lun = 0 */
39 {
40 0x00, /* peripheral device type (direct-access device) */
41 0x80, /* removable media bit */
42 0x00, /* ansi version, ecma version, iso version */
43 0x01, /* respond data format */
44 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
45 0x00, 0x00, 0x00, /* reserved */
46 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
47 'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
48 '2', '.', '0', '0' /* product revision level */
49 },
50};
51
57uint8_t *get_inquiry(uint8_t lun)
58{
59 if(lun < MSC_SUPPORT_MAX_LUN)
60 return (uint8_t *)scsi_inquiry[lun];
61 else
62 return NULL;
63}
64
73 usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
74{
75
76 switch(lun)
77 {
78 case 0:
79 flash_fat16_read((uint32_t)addr, read_buf, len);
80 break;
81 case 1:
82 break;
83 }
84 return USB_OK;
85}
86
95 usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
96{
97 switch(lun)
98 {
99 case 0:
100 flash_fat16_write((uint32_t)addr, buf, len);
101 break;
102 case 1:
103 break;
104 }
105 return USB_OK;
106}
107
115 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
116{
117 switch(lun)
118 {
119 case INTERNAL_FLASH_LUN:
120 *blk_nbr = 0x0FFF;
121 *blk_size = FLASH_SECTOR_2K_SIZE;
122 break;
123 case SPI_FLASH_LUN:
124 break;
125 case SD_LUN:
126 break;
127 default:
128 break;
129 }
130 return USB_OK;
131}
132
flash_fat16.h
fat16 file system header file
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:43
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:134
SD_LUN
#define SD_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:45
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:44
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:57
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint64_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:73
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint64_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:100
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: virtual_msc_iap/src/msc_diskio.c:36
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:337
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: flash_fat16.h:61
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: flash_fat16.c:329
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: flash_fat16.c:288
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:155
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:81
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:278
USB_OK
@ USB_OK
Definition: usb_std.h:279
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file